Error
After an upgrade to BAC 7.5 from an earlier version of BAC 7.x (7.0, 7.01, 7.02), CPU and memory usage is spiking on client machines when viewing MyBAC pages containing Business Console portlets, and in Applications > Dashboard > Console as well. This can also lock up the web browser, necessitating a force-quit of the browser application.
Cause
Looking in Admin -> Platform -> Setup and Maintenance -> Infrastructure Settings -> Dashboard Application -> Dashboard Application - Dashboard Layout Properties:
The setting "Business Business Console - Number of display levels" is set to a value higher than the default (Default is 2). In BAC 7.5, this is causing BAC to load several times more Configuration Items (CI's) into the client's memory than most clients can handle, causing a rapid spike in the browser's memory usage, and high CPU from page-file swapping.
Fix
Change the "Business Business Console - Number of display levels" setting back to the default of 2 levels. This will load fewer CI's into the client machine, and still allow for proper viewing in the Dashboard Console and MyBAC pages.