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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2002-2008 Hewlett-Packard Development Company, L.P.

No part of this document may be copied, reproduced, or translated to another language without the prior 
written consent of Hewlett-Packard Company. The information contained in this material is subject to change 
without notice.

Trademark Notices

Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated. 

HP-UX Release 10.20 and later and HP-UX Release 11.00 and later (in both 32 and 64-bit configurations) on 
all HP 9000 computers are Open Group UNIX 95 branded products.

Java™ and all Java based trademarks and logos are trademarks or registered trademarks of Sun 
Microsystems, Inc. in the U.S. and other countries.

Microsoft®, Windows®, and Windows® XP are U.S. registered trademarks of Microsoft Corporation.

Windows Vista® is either a registered trademark or trademark of Microsoft Corporation in the United States 
and/or other countries.

Oracle® is a registered U.S. trademark of Oracle Corporation, Redwood City, California.

UNIX® is a registered trademark of The Open Group. 

Intel®, Itanium® and Pentium® are trademarks or registered trademarks of Intel Corporation or its 
subsidiaries in the United States and other countries.
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Support

You can visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

HP Software Support Online provides an efficient way to access interactive technical support tools. As a 
valued support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To find more information about HP Passport, go to:

http://h20229.www2.hp.com/passport-registration.html 
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1 Introduction
The main purpose of the HP OpenView Service Desk 4.5 Client 2008 major release (Client 
2008) is to provide a new client UI for Service Desk 4.5. The original Service Desk 4.5 client 
(the previous client) runs on the Microsoft Java Virtual Machine (JVM) which reached its end 
of life on December 31, 2007. For more information about Microsoft JVM, refer to Microsoft 
Java Virtual Machine Support (http://www.microsoft.com/mscorp/java/default.mspx).

Client 2008 incorporated a number of changes in both its GUI and functionalities. The 
following are the main differences between the two clients.

Client 2008 is very similar to the previous client in feature set, look-and-feel, and deployment. 
Users who are familiar with the previous client can quickly understand the Client 2008 GUI.

The main changes in Client 2008 are the following:

• Uses the Sun JVM instead of the Microsoft JVM.

• Was developed using Eclipse technology.

• Uses a different upgrade and hotfix mechanism.

• The Administrator Console is a workspace and not a separate window.

• The chart view incorporates many changes (it was implemented using different 
technology).

• Uses a new icon and image set which comes from Service Desk 5.0. Does not support 
customizing icons or adding new icons. 

Target Audience

This guide is intended to give a description of the changes in Client 2008 compared to 
previous Service Desk 4.5 client. This guide assumes that the reader is familiar with Service 
Desk 4.5, up to and including Service Pack 23. Information is task-oriented and does not 
always describe exactly how some features work.
7
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2 Installation and Upgrade
Technology

Client 2008 is completely Sun Java-compliant. It was built using Java 2 Standard Edition 
version 1.5. Microsoft Java was completely removed from Client 2008.

Installation and Configuration

For detailed instructions on installing and configuring Client 2008, see the HP OpenView 
Service Desk 4.5 Client 2008: Installation and Configuration Guide.

Upgrade

For detailed instructions on upgrading Client 2008, see Chapter 5: Upgrading Client 2008 of 
the HP OpenView Service Desk 4.5 Client 2008: Installation and Configuration Guide.
  9
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3 Layout Differences
Startup Window

When you start Client 2008, the following startup window appears:

Logon Window

If you select the Display Logon Screen On Startup option in the General tab of the General 
Settings window (accessible from View → Administrator console → System panel → General 
Settings), then restart Client 2008, the Logon window appears.

Previous Client Client 2008
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Client Window

The previous client window looked like the following: 

Previous Client Client 2008

• Slight change in layout: OK and Cancel 
buttons moved down; Help button no longer 
available.
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The new Client 2008 window looks like the following:

The client window has the following changes with corresponding numbers marked on the 
above screenshots:

1 Favorites menu not available in the Client 2008 window.

2 Group by Box not available in the toolbar of the Client 2008 window.

3 All shortcuts have new icons in Client 2008.

4 Client 2008 has a new client icon.

5 All Client 2008 toolbar items have new icons.

6 Client 2008 has new tabbed views. 

7 Client 2008 has the following new view control items:

— Refresh

— Expand All

— Collapse All

— Move up

— Move down

— Minimize

— Maximize

8 The following status bar items were added to Client 2008: 
Layout Differences 13



— Time Zone name: Displays the current time zone.

— Current user: The current user that is connected to the Service Desk server. 

— Heap size: The first number shows the current memory allocated. The second number 
(max) shows the biggest memory that was ever allocated by the client. The third 
number (visible only in the tooltip) shows the maximum memory available for the 
client (it is configured in the client settings). 

— Garbage collector: Click it to start Java garbage collection. Java will release unused 
memory. 

9 Client 2008 has a new navigation pane. You can enable the navigation pane by clicking 
View  → Navigation. It presents all items. When an item is selected, then all views of this 
item are listed. 

Toolbar

Previous Client 

Client 2008 
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In Client 2008:

• The toolbar cannot be customized.

• The toolbar becomes active when Data View or an item is selected.

• Group by Box  in the Toolbar of the previous client is not available.

Menus

File Menu

In Client 2008:

• Open - Active only if an item is selected in the view.

• Merged from the File menu of the Administrator console of the previous client:

— Aces

— Generate Web API 

Previous Client

Client 2008
Client File Menu Administrator Console 

File Menu 
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Edit Menu

In Client 2008:

• Clear - Not available. This button has no use in Client 2008.

• Update All - Moved from the Tools menu of the previous client to the Edit menu of Client 
2008. 

View Menu

In Client 2008:

• The following menu options in the previous client are not available in Client 2008:

— Group By Box

— Toolbars 

— Status Bar - It is moved to the bottom of Client 2008 window.

• Client 2008 has the following new options added in the View menu:

— Navigation - Select this option to enable the navigation pane.

— Data View - Select this option to set the window focus on the data view pane.

— Administrator console -  Select this option to enable the administrator console pane. It 
is no longer a separate window as in the previous client.

— Web Browser - Refer to Web Browser on page 41 for more information.

— Refresh - Moved from the Tools menu of the previous client to the View menu of Client 
2008.

Previous Client Client 2008

Previous Client Client 2008
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Favorites Menu

Not available in Client 2008.

Tools Menu

In Client 2008:

• System - No longer available. The Administrator console is not a separate window 
anymore. You can enable it in the View menu, if you have appropriate rights.

• Update All -  Now it is available in the Edit menu.

• The following items were merged from the Tools menu of the Administrator Console 
window of the previous Client:

— Block/Unblock Selection

— Bulk/Selective Deletion

— Check References

Previous Client

Client 2008Client Window
Tools Menu

Administrator Console 
Tools Menu 
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Options Window 

• The Options window of Client 2008 (accessible from Tools → Options) has the following 
changes:

— Sounds tab - Not available in Client 2008.

— Advanced tab

– Form Cache option is not available.

– Field Selection Menu Style option moved to the new tab Other.

— Other tab - This is a new tab in the Options window of Client 2008.

Previous Client Client 2008
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Help Menu

In Client 2008:

• Update option is new in Client 2008. It allows you to upgrade Client 2008 or to install 
hotfix. For more information about upgrading Client 2008, see the HP OpenView Service 
Desk 4.5 Client 2008: Installation and Configuration Guide. 

Administrator console

Previous Client

Previous Client Client 2008
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Client 2008

• You can access the Administrator console in the same Client window from the View menu 
if you have administrator rights.

• No longer a separate window.

• Nodes in Administrator console are not sorted alphabetically in Client 2008.

• No Service Pages node. Service Pages is in a new group.

• Icons (of nodes) are different in Client 2008.

Changes to specific nodes:

• Business logic

— Database rules and UI rules: Records in the view are not folded to the next line in Client 
2008

• Data

— Codes: Code icons cannot be imported from a file.

In the previous client, when you go to Data → Codes → (choose a code) → (create a new 
code), then click the Quick Find button for the Icon field, you can select any icon from 
a file to customize it for each code. 
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Previous Client 

In Client 2008, you can only select icons from a predefined icon list.

Client 2008 

• Presentation:

— The Shortcut bar is not available. It is not supported in Client 2008.

— Forms - Form Designer

In Client 2008, icons customized in the previous client (imported from a file) are 
not visible.
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When you go to Administrator console → Forms → (choose a form) → (double click an 
item in the view), a form designer appears: 

– The Attributes window is no longer a separate window in Client 2008. It is 
incorporated as a part of the Form Designer window.

– Client 2008 has a toolbar for forms with icons for commonly used items included 
for easy use.

– New preview function is added, accessible from the Preview tab.

• System panel

— General Settings - Remote updater

The status information and the Install button in the previous client are not available 
in Client 2008.

— Functionality is also different. For more detailed information, see Chapter 5: 
Upgrading Client 2008 in the HP OpenView Service Desk 4.5 Client 2008: Installation 
and Configuration Guide.

Previous Client Client 2008

Previous Client Client 2008
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— Regional Settings

– Update all prices is a new tab in the Regional Settings window of Client 2008.

Previous Client Client 2008

— Access this functionality by clicking Update 
on Currency tab.

— Access this functionality from 
the new tab directly.
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4 Forms
Forms in Client 2008 are very similar to the ones in the previous client. There are not many 
changes. This chapter lists general differences, differences in fields, and differences in 
attachment fields.

Previous Client

Client 2008
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• New look and feel of forms.

• New icons for toolbar items.

• New context menu options are available for some fields.

Form Fields

• Drop-down menu button: 

In Client 2008, drop-down context menu options are available by clicking the small arrow 
next to the Quick Find button.  

• New icons for Quick Find buttons.

• Sort order of the items in the drop-down menus is different.

• No icons in combo box: for example, Priority field in Service Call item.

• Boolean fields - The check box image with “none” state is different than in the previous 
client.

Previous Client Client 2008

Previous Client Client 2008

Previous Client Client 2008
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Attachment Fields 

In Client 2008:

• The icon and screen tool-tip is a bit different.

• Four views are available for the attachment. In the previous client, you can right-click on 
the attachment and select Toggle to switch to another view.

Previous Client Client 2008
Forms 27
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5 Views
Client 2008 contains all types of views that were available in the previous client. Most views 
are very similar, only chart views incorporated many changes. This chapter discusses the 
differences in views in details.

Table View

In Client 2008:

• Records cannot be grouped by dragging and dropping a column header.

• “Group items” takes only one column instead of one row in the views.

Previous Client

Client 2008
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• View settings differences

Go to View → Current View → Customize Current View → Other, the Other window which 
contains view settings will appear. 

The following view setting differs in functionality:

— Automatic column sizing 

In Client 2008 this setting is used to remove any empty end column in the Table view. 
In the previous client, this setting is used to ensure that all columns are displayed in 
the screen. You do not have to adjust the horizontal scroll bar to view all columns.

The following view settings are not available in Client 2008. This is a limitation. 

— Headers - Font

— Grid Lines 

– Horizontal and Vertical options not available for Lines. 

– Style and Color settings not available. 

— Other − The following options are not available in Client 2008:

– Show “Group by Box”

– Shade group headers

Previous Client Client 2008
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Context Menu

• The context menu in the previous client is not available in Client 2008 when you right 
click on a column header. This is a limitation.

• The view context menu (when you right click on a record or in the views) includes Format 
Fields and Customize Current View options from the column header context menu of the 
previous client. 

The following menu options are not included: Group By This Field, Remove This Field, 
Alignment, and Best Fit. 

View Menu

• The Group by Box option is not available in the View menu and view settings. This is a 
limitation. See View Menu on page 16 for more information.

Previous Client
Client 2008

Right click on a record Right click in the view
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Explorer View

In Client 2008:

• The current view name is displayed in the view tab header instead of in the field above 
the tree (as marked out on the above screenshots).

• In the explorer views, after you right click on the table, and then in the context menu click 
Customize Current View → Other, you get other Table View settings instead of Explorer 
View settings. This is new in Client 2008. The Customize Current View option is not 
available in the previous client context menu. 

To access Explorer View settings, go to View menu (View → Current View → Customize 
Current View → Other).

Previous Client

Client 2008
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Chart View

The Chart View function in Client 2008 differs from the previous client. In Client 2008, the 
Chart View is implemented using the open source component JFreeChart (www.jfree.org/
jfreechart/). The previous client uses the ChartFX ActiveX component. 

The major difference in the technology means there are many differences in the chart views 
between the previous client and Client 2008. Client 2008 maintains most of the useful 
functionalities available in the previous client chart views.

Overall Differences 

Client 2008 implements most of the graph types available in the previous client. The following 
table shows the Graph Types differences between the two clients:

Previous Client

Client 2008
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Differences in the Chart View Toolbars

In Client 2008, the toolbar for chart views differs from the previous client:

Previous Client

Table 1 Chart View Graph Type Differences 

Previous Client Client 2008

Line Yes

Area Yes

Curve No

Area-curve No

Step Yes

Bubble No

Scatter Yes

Bar Yes

Gantt Yes

Cube No

Candlestick (Column) No

Open-High-Low-Close No

High-Low-Close No

Pie Yes

Doughnut No

Pareto No

Pyramid No

Radar Yes

Contour/Spectral No

Surface No

Colors cannot be displayed in chart views on Windows 2000 Terminal Service which only has 
256 colors.
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Client 2008

The Client 2008 toolbar provides the following functions: Save, Copy, Print, Graph Type, 
Stack Type, Grid Type, 3D or 2D, Legend, Point Label, Option, and Zoom In / Zoom Out.

Functional differences in the toolbar are as follows:

• The tooltip format in the toolbar is different. 

• The following options are not available in the toolbar - Client 2008 does not provide these 
functions in Chart view: 

— Print Preview;

— Data Editor;

— Rotate

— Z-clustered

No Context Menu in the Chart View of Client 2008

Chart FX of the previous client provides a context menu as shown below. In Client 2008, the 
Chart View does not provide a context menu. These functions are no longer available. 

The following functions are no longer available:

• No Data Editor function in the Chart View.

• Cannot edit the title using the context menu in Chart View.

You cannot edit the title directly in the view. But, you can edit the title through the Chart 
Properties window (accessible by clicking Properties button  in the view toolbar) or 
through View settings dialogue box (View → Current View → Customize Current View → Other 
→ More → Title).

• Point labels are available, but the font cannot be customized. 

Point labels can be selected through the Chart view toolbar; Client 2008 uses the default 
(system fonts) for chart labels.

• Color settings not available for charts.

In the previous client, you can customize the color for a chart slice by right clicking on the 
chart as shown below. In Client 2008, the color of a chart slice cannot be customized.
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Previous Client 

• The background color for the Chart View cannot be customized directly in the view, but 
can be set through the Chart Properties window (accessible by clicking Properties  in 
the Chart View toolbar, then go to Other → Background Paint).

Differences in Open and Save Functions

In Client 2008, the Open function is not available. In the previous client, the Open function 
opens the Chart FX resource files (Chart FX files and templates).

In Client 2008, the Save function saves a chart as an image file. In the previous client, the 
Save function saves the chart as a resource file.

Differences in Chart Properties

Chart FX Properties windows in the previous client are as follows: 

Previous 
Client
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You can set most of the Chart FX properties in the Chart FX Properties windows. See the 
previous client for details about these functions.

In Client 2008, the Chart Properties windows are totally different:

The following Chart properties in Client 2008 are new:

Title 

You can set Title properties in the Title tab of Chart Properties window:

• General

— Show Title - Use to show the title or not.

— Text - Use to provide title text for a Chart view.

— Font - Use to set font for the Chart view title.

— Color - Use to set color for the Chart view title. 

Plot

Plot properties vary with Graph Types:

• Domain Axis

— Label - Use to set the label for the X-Axis.

— Font - Use to set the font for the X-Axis label.

— Paint - Use to set the color for the X-Axis label.

— Show tick labels - Use to show labels’ tick or not.

— Tick label font - Use to set the font for the tick label.

• Range Axis

— Label - Use to set the label for the Y-Axis.

— Font - Use to set the font for the Y-Axis label.

— Paint - Use to set the color for the Y-Axis label.

Client 2008
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— Ticks

– Show tick labels - Use to show labels’ tick or not.

– Tick label font - Use to set the font for the tick label.

— Range

– Auto-adjust range  - Use to auto-adjust the range or not.

– Minimum range value  - Use to set the minimum range value.

– Maximum range value  - Use to set the maximum range value.

• Appearance

— Outline stroke - Use to set the style of outline stroke for the chart.

— Outline paint - Use to set the color of outline stroke for the chart.

— Background paint - Use to set the background color for the chart.

— Orientation - Use to set the chart orientation.

Other

• Draw anti-aliased - Use to draw the chart in anti-aliased mode. 

• Background paint - Use to set the background color for the Chart view.

Settings in Properties dialogue box are not saved, so all the changes you made will be lost 
once you restart the Client.
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Card View

In Client 2008:

• Empty fields are also shown. This causes all cards have the same height.

• The field label is truncated if the field space is not enough, and no ellipses are appended to 
the label. The label has no tooltip.

• The drag line is not available to resize the card width. You can set card width in Card 
View settings (View → Current View → Customize Current View → Other).

Previous Client

Client 2008
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Project View

Differences:

• No Pert view in Client 2008.

• The project schedule is weekday based in Client 2008. In the previous client, it is day 
based.

System View

The System View in Client 2008 is the same as in the previous client.

Previous Client

Client 2008
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Web Browser

• You can enable it by clicking View → Web Browser, and then open a Website in this view. 

• The Web Browser tab has navigation buttons and an address field (like a real browser). 

Client 2008
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6 Online Help
The Online Help in the previous client is built with Microsoft Help system in CHM format. In 
Client 2008, the Online Help is built with the Eclipse help system. The following are the 
differences.

In Client 2008 (corresponding numbers are marked in the screenshots above):

1 Navigation tabs are located at the bottom of navigation pane instead of the top. No labels, 
just icons.

2 Navigation buttons are in a different place, also look different (Back, Forward, Home).

Previous 
Client

Client 2008
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3 The Search field and Search scope are always on the top.

4 The following are new buttons: Collapse All / Expand All, Refresh / Show Current Topics, 
Maximize / Minimize, Show in Table of Content, Bookmark Document.

What’s This Function

It displays the description of the field that is currently active/selected. In the previous client 
you can also use “What's this” to point a field. 

Previous Client Client 2008
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7 Localization
Client 2008 reused the localization (L10N) mechanism of the previous client. No extra 
language pack is needed for Client 2008. For most functions in Client 2008, a localized version 
can be enabled by adjusting the language setting. You can go to Tools → Options → General → 
Language, select the language of your choice, and click OK.

You should restart Client 2008 after you change the language settings. In the previous client, 
it is not necessary to restart the client. 

For the following functions, you need to modify the startup parameter to enable a local 
language:

• Progress hints in the startup window or login window

• Popup menu of views and navigation bars

• Heap status bar

• Upgrade manager window

• Online help browser

The language displayed for these functions depends on the language settings in the Windows 
operation system by default. If you choose a language in Client 2008 that is different from the 
language settings of the operating system, you get a mixed-language client UI.

If you want the client UI to display in a language that is different from the operating system 
language setting, you must add a startup parameter in the Command line or modify the 
Configuration file (servicedesk.ini).

Command line

You can add parameter -nl <language_ID> to the following command line or shortcut: 

#servicedesk.exe -nl zh_CN

See Table 2 on page 46 for a list of language IDs available.

Configuration file

Modify the servicedesk.ini configuration file (present in <Client_HOME_DIR>\ 
directory) to add the language ID of your choice at the end of the file. For example, add zh_CN 
for simplified Chinese as shown in the following example:

-application
com.hp.sd.eclipse.application
-clean
-nl
zh_CN
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Table 2 Language ID Parameters

Language ID Parameter

Dutch nl

English en

French fr

German de

Japanese ja

Korean ko

Spain es

S-Chinese zh_CN

T-Chinese zh_TW

For more information about the configuration file, see Chapter 4: Configuring Client 2008 of 
the HP OpenView Service Desk 4.5 Client 2008: Installation and Configuration Guide.
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8 Performance
Form Cache

The Client 2008 cache mechanism does not include the form cache. The main purpose of form 
cache is to save the time/cost for reconstructing the UI component. However, this is not an 
issue in Client 2008. The cost of creating the UI component is not high. No problem is 
expected because hardware requirements for Client 2008 are higher than for the previous 
client. As a result, performance should not be affected by lack of cache.

Memory Settings

Client 2008 allows you to set the java memory size. You can set the memory settings in the 
config files. See the Troubleshooting chapter of the HP OpenView Service Desk 4.5 Client 2008: 
Installation and Configuration Guide for more information about memory settings.

View Performance

View performance of Client 2008 is slower than in the previous client. For more information 
about optimizing view performance, see the Troubleshooting chapter of the HP OpenView 
Service Desk 4.5 Client 2008: Installation and Configuration Guide. 
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9 Miscellaneous
Print

• Project view cannot be printed.

• Standard style print is not available in Client 2008.
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Advance Find

In Client 2008:

• There is a new toolbar.

• The View menu (which has Status Bar option only in the previous client) is not available.

• The Status bar is always displayed. It cannot be disabled.

• Searching criteria are not stored. When Advanced Find is re-opened, it is empty.

Sd dataform

The functionality of Sd dataform in Client 2008 is similar to that in the previous client.

Previous Client

Client 2008
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Bat Files

The previous client is started by running client.exe; Client 2008 is started by running the 
servicedesk.exe command. 

The servicedesk.exe command does not support the following parameters which were 
supported in the previous client: 

/SILENT
/STRESSTEST
/BENCHMARK
/VIEWTEST
/TOY
/OPENTEST
/INSERTTEST

A new command line option is available for servicedesk.exe: 

/DISABLEUPGRADE -  used for disabling the hotfix automatic upgrading in client.

The following commands are not available in Client 2008:

SD45ViewRules.exe
AdjustSLWeight.exe
ViewAuditRules.exe

These commands are used by the Service Desk administrator. They can be found in previous 
client.

Assignment Notification Window

The assignment notification window is a new function in Client 2008. It appears on the right 
bottom corner when an item is assigned to the current user. 

Function Keys

The functions of some of the hot keys are different. Table 3 lists the differences.
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Table 3 Function Keys Differences

Function Key

 Function Differences

Previous Client Client 2008

Tab / Shift+Tab You can switch forward/backward 
among all available fields and 
buttons in a form.

You can only switch forward/
backward among available 
buttons and non-descriptive 
fields in a form.
To switch forward/backward 
among all available fields and 
buttons, press Ctrl+Tab / 
Ctrl+Shift+Tab. 

Ctrl+Tab / 
Ctrl+Shift+Tab

You can switch forward/backward 
among the tabs in a form.
Also, you can use left and right 
arrow keys to achieve the same 
function.

This pair of function keys is not 
supported.
You can switch forward/
backward among tabs in a form 
by simply pressing left or right 
arrow keys.

Ctrl+T When you create a new form, you 
can press Ctrl+T to launch 
template while your cursor is in 
an available field. 

Not supported.
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