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• Look up HP support contacts
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• Enter into discussions with other software customers
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www.managementsoftware.hp.com/passport-registration.html 
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1
Understanding Protocols

VuGen supports a variety of applications and protocols, allowing you to 
record and create a script that accurately emulates your actions.

Note: The HP Virtual User Generator User’s Guide online version is a single 
volume, while the printed version consists of two volumes, Volume I-Using 
VuGen and Volume II - the Protocols user guide.

Using This Guide

This user’s guide, Protocols, is the second volume of the HP Virtual User 
Generator user’s guide. The first volume, Using VuGen, describes how to 
work with VuGen and create tests. This volume describes the unique settings 
and guidelines for the individual protocols. For example, this volume 
includes the recording options and run-time settings that are protocol-
specific, while Using VuGen lists the settings that are common to all or most 
of the protocols.

When you are deciding which Vuser type to record, you may find that your 
application uses several protocols, such Web & FTP or Web & Web Services. 
VuGen supports recording for multi-protocol scripts. For more information, 
see Volume I-Using VuGen.

To view a list of all supported protocols in alphabetical order, choose File > 
New and select All Protocols in the Protocol Type list box.

To develop GUI Vuser scripts for use with LoadRunner, refer to the HP 
WinRunner User’s Guide or HP QuickTest Professional User’s Guide.
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Vuser Types

VuGen provides a variety of Vuser technologies that allow you to emulate 
your system. Each technology is suited to a particular architecture and 
results in a specific type of Vuser script. For example, you use Web Vuser 
Scripts to emulate users operating Web browsers and FTP Vusers to emulate 
an FTP session. The various Vuser technologies can be used alone or 
together, to create effective tests or Business Process Monitor profiles.

The Vuser types are divided into the following categories:

➤ All Protocols. a list of all supported protocols in alphabetical order.

➤ Application Deployment Solution. For the Citrix and Microsoft Remote 
Desktop Protocol (RDP) protocols.

➤ Client/Server. For DB2 CLI, Domain Name Resolution (DNS), Informix, 
Microsoft .NET, MS SQL Server, ODBC, Oracle (2-tier), Sybase Ctlib, 
Sybase Dblib, and Windows Sockets protocols.

➤ Custom. For C templates, Java templates, Javascript, VB script, VB 
templates, and VBNet type scripts.

➤ Distributed Components. For COM/DCOM, and Microsoft .NET 
protocols.

➤ E-business. For Action Message Format (AMF), AJAX (Click and Script), 
Flex, File Transfer Protocol (FTP), Listing Directory Service (LDAP,) 
Microsoft .NET, Web (Click and Script), Web (HTTP/HTML), and Web 
Services protocols.

➤ Enterprise Java Beans. For EJB Testing.

➤ ERP/CRM. For Oracle NCA, Oracle Web Applications 11i, Peoplesoft 
Enterprise, Peoplesoft-Tuxedo, SAP-Web, SAPGUI, SAP (Click and Script), 
and Siebel (Siebel-DB2CLI, Siebel-MSSQL, Siebel-Oracle, and Siebel-Web) 
protocols.

➤ Java. For the Java Record/Replay protocol.

➤ Legacy. For Terminal Emulation (RTE).

➤ Mailing Services. Internet Messaging (IMAP), MS Exchange (MAPI), Post 
Office Protocol (POP3), and Simple Mail Protocol (SMTP).

➤ Middleware. The Tuxedo protocol.
22
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➤ Streaming. For MediaPlayer (MMS) and RealPlayer protocols.

➤ Wireless. For Multimedia Messaging Service (MM) and WAP protocols.
23
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2
Understanding the SOA Test Types

You use VuGen to create tests for your Web Services.

This chapter includes:

 ➤  About SOA Test Types on page 27

 ➤  Getting Started with Web Services Vuser Scripts on page 28

The following information only applies to Web Services/SOA Vuser scripts.

About SOA Test Types

SOA systems are based on Web Services, self-contained applications that can 
run across the Internet on a variety of platforms. The services are built using 
Extensible Markup Language (XML) and Simple Object Access Protocol 
(SOAP). They serve as building blocks enabling the rapid development and 
deployment of new applications.

Using VuGen, you create test scripts for testing your SOA environment. You 
can use a test generation wizard to automatically generate scripts, or create 
the scripts manually.

To automatically generate test scripts, you use the SOA Test Generator. A 
wizard guides you through the process of selecting testing aspects such as 
interoperability with different toolkits, boundary testing, and standard 
compliance. For more information, see Chapter 23, “Using the SOA Test 
Generator.”
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To manually create scripts, you begin by creating an empty script. Then you 
add content to the script either by recording a session, analyzing network 
traffic, or manually inserting calls to the Web service as described in 
Chapter 5, “Adding Content to Web Services Scripts.” 

For manual scripts, you use VuGen to create one of the following scripts.

➤ Single Protocol Script. A script that emulates SOAP traffic by sending SOAP 
requests to the Web service.

➤ Multi Protocol Script. A script that emulates several protocols in a single 
script. For example, if your environment contains a client that accesses a 
Web Services and Web pages, choose both the Web Services and Web (Click 
and Script) protocols.

Getting Started with Web Services Vuser Scripts

This section provides an overview of the process of developing a Web 
Services / SOA Vuser script.

To develop a test script: 

 1 Create a new Web Services script.

Create a new script using the SOA Test Generator, or manually create a new 
single or multiple protocol script, or a Business Process Testing component.

 2 Add content to the script.

Add content to the script (excluding the SOA Test Generator). For details, see 
Chapter 5, “Adding Content to Web Services Scripts.”

 3 Set properties, values, and checkpoints.

Enhance the script by customizing the step properties, inserting argument 
values, and setting checkpoints. For details, see Chapter 7, “Working in the 
Web Service Call View.”
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 4 Parametrize your script. 

Parameterization lets you replace constant values with a variable to 
substitute new values for each iteration. To parameterize a value, double-
click on a step to open its properties and click the ABC icon adjacent to the 
value box. For complex type elements, use the XML parameter type as 
described in “Setting Properties for XML Parameters” on page 182.

 5 Configure the Run-Time settings.

The Run-Time settings control the script’s behavior during execution. These 
settings include Web Service-specific settings (client emulation) and General 
settings—run logic, pacing, logging, and think time. 

For information about the Web Service-specific settings, see “Setting Web 
Services JMS Run-Time Settings” on page 161, and “Configuring Run-Time 
Settings” in Volume I-Using VuGen.

 6 Verify that the script is functional. 

Replay the script in VuGen to verify that it runs correctly. 

For details about replaying the script, see“Running Vuser Scripts in 
Standalone Mode” in Volume I-Using VuGen. 

 7 Save the script.

Save the script in the file system or in a Quality Center repository. If you 
save the scripts in Quality Center, you can associate them to a test set and 
perform functional and regression testing directly from Quality Center. For 
more information about Quality Center and its integration with scripts, see 
“Working with Service Test Management” on page 69.

After you prepare a script, you are ready to use it for your testing. For more 
information, see “Using Your Script” on page 68.

Use Quality Center to manage all of your tests while tracking defects and 
requirements. For more information, see www.hp.com or contact your sales 
representative.
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Working with Web Services Scripts

After creating a Web Services script, you can view it in either Script view or 
Tree view. Within these views, you can modify the script and its properties.

This chapter includes:

 ➤  About Working with Web Services Scripts on page 31

 ➤  Viewing and Editing Scripts on page 32

 ➤  Parameterizing Scripts on page 35

The following information only applies to Web Services Vuser scripts.

About Working with Web Services Scripts

After you create a script, you can view its contents in either Tree view or 
Script view. The tree view is a graphical view, while Script view displays the 
actual functions in the script.

When viewing your script, you can examine it and determine if it needs to 
be enhanced in any way. The most common enhancements are transactions 
and parameterization.

Transactions let you mark a group of actions to be measured to check the 
applications’s performance. For example, if you want to check the time it 
took for a service to update an address, you mark those actions as a 
transaction. For more information, see “Inserting Transactions into a Vuser 
Script” on page 128.
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Parameterization is the replacing of constants with parameters. This is useful 
for testing your service with different values, or passing information from 
one step to another. For more information, see “Parameterizing Scripts” on 
page 35.

Viewing and Editing Scripts

You can view and edit all of the scripts that you created both manually and 
automatically in the VuGenwindow.

You can view a script in either Tree View or Script View. Tree view displays 
the steps of the script in a graphical interface, while the Script view shows 
all steps, including the actual web_service_call functions that emulate your 
service. Script view is ideal for advanced users that require more flexibility 
within the script.

Tree View
The Tree view shows a graphical representation of each one of the script’s 
steps.

When you select a step, VuGen displays information about the step in 
several tabs:

➤ Step Properties. The properties and argument values of the Web service call. 
This tab allows you to modify the properties of an existing step. See 
“Understanding Web Service Call Properties” on page 87.
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➤ Checkpoint. A list of checkpoints defined for the step. See “Setting 
Checkpoints” on page 119.

➤ SOAP Snapshot. A snapshot of the SOAP request and response for both 
record and replay. See “Viewing Web Services SOAP Snapshots” on page 84.

For more information about these tabs, see Chapter 7, “Working in the Web 
Service Call View.” 

To view a script in Tree view:

 1 Click the Tree button or choose View > Tree View.

 2 In the upper left box, select the section containing the steps of the script 
that you want to view: vuser_init, Action, or vuser_end. To specify a new 
action choose Actions > Create New Action.

 3 In the left pane, select the step or sub-node that you want to view or modify.

 4 Select the Step Properties tab in the right pane to view or modify the 
properties.

 5 Select the Snapshot tab to view the step’s SOAP header and body. To display 
a specific replay iteration, choose View > Snapshot > Select Iteration.

 6 To add additional Web Service steps, click the Add Service Call button. For 
more information, see “Adding New Web Service Calls” on page 62.

 7 To insert advanced functionality, such as JMS queue retrieval and SAML 
security, choose Insert > Add Step and choose the appropriate step. For more 
information, see Chapter 8, “Setting Advanced Properties for Web Service 
Scripts.” 

 8 To replace argument values with parameters, go to the Step Properties tab. 
Select the node whose value you want to replace in the script, and click the 
ABC icon to the right of the Value box.

 9 To set a checkpoint, click the Checkpoint tab. For more Information, see 
“Setting Checkpoints” on page 119.
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Script View
The Script view shows the actual functions that were generated in the script. 
You can expand or collapse each of the web_service_call functions to view 
only the functions that interest you.

To view a script in Script view:

 1 Click the Script button or choose View > Script View.

 2 In the left pane, select the section containing the steps of the script that you 
want to view: vuser_init, Action, or vuser_end. To specify a new section 
choose Actions > Create New Action.

 3 To add additional Web Service steps at the location of the cursor, click the 
Add Service Call button. For more information, see Chapter 7, “Working in 
the Web Service Call View.”

 4 To insert advanced functionality, such as JMS queue retrieval and SAML 
security, choose Insert > Add Step and choose the appropriate step. For more 
information, see Chapter 8, “Setting Advanced Properties for Web Service 
Scripts.”

 5 To replace argument values with parameters, select the value you want to 
replace in the script, and select Replace with Parameter from the right-click 
menu.
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For more information about the functions, refer to the Online Function 
Reference (Help > Function Reference) or select a function and click F1.

Parameterizing Scripts

VuGen supports parameterization for all of the argument values. 
Parametrization lets you substitute the original values with external values. 
This is useful for testing your service with different values, or passing 
information from one step to another. For an overview on parameterization, 
see “Creating Parameters” in Volume I-Using VuGen.

If your arguments are the simple, non-array type, you can replace them with 
a simple parameter. For example, if you want to test a service that does 
addition, you can substitute each of the input arguments with a parameter, 
and store the values in a file or a table.

If, however, your arguments are a complex structure with many values, you 
can use an XML type parameter to replace the entire structure with a single 
parameter. You can create several value sets for the XML type parameter and 
assign a different value set for each iteration. For more information, see 
“Understanding Parameter Types” in Volume I-Using VuGen.

Using parameters, you can pass the output value from one operation, as 
input for a later operation. For more information, see “Using Web Service 
Output Parameters” on page 115.
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To replace a constant value with a parameter:

 1 Switch to the Step Properties tab and select the parent or child element 
whose value you want to parameterize.

 2 Under the Input Arguments node, select the argument you want to 
parameterize. In the right pane, click the ABC icon in the Value box. The 
Select or Create Parameter dialog box opens.

 3 Specify a parameter name and type. 

 4 Click Properties to set the type of parameter—File, XML, and so on—and to 
assign values. 

For more information, see “Creating Parameters” in Volume I-Using VuGen.
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Managing Web Services

VuGen provides utilities that let you validate and manage the WSDL files 
associated with your service entries.

This chapter includes:

 ➤  About Managing Web Services Vuser Scripts on page 38

 ➤  Viewing and Setting Service Properties on page 39

 ➤  Importing Services on page 43

 ➤  Specifying a Service on a UDDI Server on page 45

 ➤  Choosing a Service from Quality Center on page 46

 ➤  Specifying WSDL Connection Settings on page 47

 ➤  Deleting Services on page 49

 ➤  Comparing WSDL Files on page 49

 ➤  Viewing WSDL Files on page 54

The following information only applies to Web Services and SOA Vuser 
scripts.
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About Managing Web Services Vuser Scripts

The Service Management window lets you manage a list of service entries for 
the current script. You can view and set the properties of each service entry.

You add service entries to the list by importing WSDL files. When you add a 
WSDL to the list, VuGen creates a working copy that it saves with the 
script—it is not global. Therefore, for each script that you create, you must 
import the desired WSDL files. 

To view the copy of the locally saved WSDL in Internet Explorer, click the 
View WSDL button.
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Note: All validations and modifications to WSDL files are done on the 
working copy. If you want to replace the imported WSDL file with a newer 
version, use the Update Now option described in “Description” on page 39.

To open the Service Management window, choose SOA Tools > Manage 
Services or click the Manage Services toolbar button.

The Service Management window provides an interface for: 

➤ Viewing and Setting Service Properties

➤ Importing Services

➤ Deleting Services

➤ Comparing WSDL Files

➤ Viewing WSDL Files

Viewing and Setting Service Properties

The Service Management window lets you view and modify information 
about the imported WSDLs. It shows details about the selected service entry 
in the following tabs:

➤ Description

➤ Operations

➤ Connection Settings

➤ UDDI Data

Description
The Service Management window’s Description tab displays information 
about the service: WSDL, Endpoint Address, and Details. You can add 
annotations or notes about your service, in the Details area.
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WSDL

The WSDL area provides information about the location of the WSDL, and 
the date that it was last imported.

➤ Original location. The original source of the WSDL file (read-only).

➤ Service name. The name of the Web Service.

➤ Last update from original. (For services not imported from Quality Center) 
The last date that the local copy was updated with a WSDL file from the 
original source. 

➤ To manually update the working copy of the WSDL, click Update Now. 
VuGen backs up the existing WSDL and updates it from the location 
indicated above.

➤ To instruct VuGen to update the WSDL every time you open the script, 
select Update when opening script.

➤ date of the last of the service from QC

➤ Last updated from QC. (For services imported from Quality Center) The last 
date that the service was updated from Quality Center. 

Address

➤ Service address. An endpoint address to which the request is sent.

If you want to override the endpoint specified in the WSDL file, choose 
Override address and specify a different address in the Service address box. 

This is useful for implementing emulated services. VuGen uses the override 
address as targetAddress for the Web Service call. This overriding affects all 
Web Service calls. To use a different target address for a particular Web 
Service call, you specify it in that step’s properties. For more information, 
see “Using Emulated Services in Vuser Scripts” on page 489.

Details

➤ Description. A description of the Web service, taken by default from the 
WSDL file. This text area is editable.

➤ Created by. The name of the user who originally imported the service (read-
only).
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➤ Toolkit. The toolkit associated with the script. You set this before importing 
the first WSDL file.

Operations
Each of the imported services may define multiple operations. The 
Operations tab indicates which operations are being used for the service you 
selected in the left pane.

You can sort the list of operations by clicking on the relevant column. For 
example, to list the operations by name, click the Operation Name column. 
To list them in descending order, click the column name again. A small 
arrow indicates the sorted column. An upward arrow indicates ascending 
order, while a downward arrow indicates descending order.
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Connection Settings
In some cases WSDLs reside on secure sites requiring authentication. In 
certain instances, the WSDL is accessed through a proxy server.

VuGen supports the importing of WSDLs using security and WSDLs accessed 
through proxy servers. The following security and authentication methods 
are supported:

➤ SSL

➤ Basic and NTLM authentication

➤ Kerberos for the .NET and Generic toolkits

It is recommended that you enter the authentication or proxy information 
while importing the WSDL. If however, the settings changed, you can 
modify them through the Service Manager’s Connection Settings tab.

For more information about setting the connection information while 
importing the WSDL, see “Connection Settings” on page 45.
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UDDI Data
You can view the details of the UDDI server for each service that you 
imported from a UDDI registry.

The read-only information indicates the URL of the UDDI server, the UDDI 
version, and the Service key.

For information about importing from a UDDI, see “Specifying a Service on 
a UDDI Server” on page 45.

Importing Services

VuGen lets you import services for the purpose of creating a high-level tests 
with Web Service Call steps. Typically, you begin creating a script by 
importing a WSDL file. 

When importing a file, you specify the following information:

➤ Source. the source of the WSDL: URL, File, UDDI, or Quality Center

➤ Location. the path or URL of the WSDL, entered manually or by browsing

➤ Toolkit. the toolkit to permanently associate with all services in the script 
(only available for the first service added to the script)
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➤ Connection Settings. authentication or proxy server information (optional)

If VuGen detects a problem with your WSDL when attempting to do an 
import, it issues an alert and prompts you to open the report. The report 
lists the errors and provides details about them.

Source

When specifying a WSDL, you can indicate the source: 

➤ URL. The complete URL of the service. 

➤ File. The complete path and name of the WSDL file.

➤ UDDI. Universal Description, Discovery, and Integration—a universal 
repository for services. For more information, see “Specifying a Service on a 
UDDI Server” on page 45.

➤ Quality Center. A service stored in the Quality Center repository. For more 
information, see “Choosing a Service from Quality Center” on page 46.

VuGensupports URL or UDDI paths that are secure, requiring authentication 
or accessed through proxy servers. For more information, see “Specifying a 
Service on a UDDI Server” on page 45.

Location

In the Location box, you specify the path or URL of the WSDL. 

For the URL or UDDI options, make sure to insert a complete URL—not a 
shortened version. Click the Browse button to the right of the text box to 
open the default browser.
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For a file, click the Browse button to the right of the text box to locate the 
WSDL on the file system.

For Quality Center, click the Quality Center Connection button to specify a 
server URL and to initiate a connection. For more information, see 
“Choosing a Service from Quality Center” on page 46.

Toolkit

Choosing a toolkit instructs VuGen to send real client traffic using an actual 
toolkit—not an emulation. Once you select a toolkit, it becomes 
permanently associated with the script for all subsequent recordings, 
imports, and replays. 

VuGen supports the .NET Framework with WSE 2 version SP3 and Axis/Java 
based Web Services Framework toolkits. VuGen imports, records, and replays 
the script using the actual .NET or Axis toolkit.

Connection Settings

When importing WSDL files from a URL or UDDI, the WSDL may require 
authentication if it resides in a secure location. In certain cases, the access to 
the WSDL may be through a proxy server. Using the Connection Settings 
button, you can specify this information. For more information, see 
“Specifying WSDL Connection Settings” on page 47.

Specifying a Service on a UDDI Server

Service brokers register and categorize published Web Services and provide 
search capabilities. The UDDI business registry is an example of a service 
broker for WSDL-described Web Services.

Your Web Service client can use broker services such as the UDDI, to search 
for a required WSDL-based service. Once located, you bind to the server and 
call the service provider.
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Click the Browse button to open the Search for Service in UDDI dialog box.

To search for a service on a UDDI:

 1 In the UDDI server inquiry address box, enter the URL of the UDDI server.

 2 Specify the UDDI version.

 3 Specify the name or part of the name of the service. Select Exact Match or 
Case Sensitive to refine your search, if they are applicable. To perform a 
wildcard search, use the percent (%) character.

 4 Click Search. VuGen displays all of the matching results.

 5 Double-click on a service in the list to import it.

Choosing a Service from Quality Center

HP Quality Center with the Service Test Management add-on, integrates 
with VuGen. This integration allows you to store service entries and tests in 
Quality Center. You can also create and organize services according to your 
test requirements and test plan.
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To specify a service from Quality Center:

 1 In the Import Service dialog box, choose Quality Center.

 2 If you have not yet connected to your Quality Center project, click Quality 
Center Connection to open the Connection dialog box. For information on 
opening a Quality Center connection, see Managing Scripts Using Quality 
Center in Volume I-Using VuGen.

 3 Click the Browse button to view the list of service entries saved in Quality 
Center.

 4 Double-click on a service in the list to import it.

Specifying WSDL Connection Settings

VuGen supports the importing of WSDLs using authentication and WSDLs 
accessed through proxy servers.

Once you enter the security or proxy information, it remains with the 
WSDL, visible through the Connection Settings tab in the Service 
Management dialog box. If you enable the Keep up to date option to allow 
automatic synchronization, Service Test accesses the WSDL at its source 
using the authentication or proxy server settings.
47



Chapter 4 • Managing Web Services
These connection settings only apply to the importing of a WSDL. To use 
authentication during replay for access to a server, use the web_set_user or 
web_set_proxy steps. For more information, refer to the Online Function 
Reference (Help > Function Reference).

To specify authentication or proxy information for importing:

 1 Open the Import Service dialog box as you normally would, either with a 
new Web Service call, recording, or Traffic Analysis.

 2 Select either the URL or UDDI option and specify a URL of the service to be 
imported.

 3 In the Import Service dialog box, click the Connection Settings button to 
open the box.

 4 In the Connections Settings dialog box, select the desired option: Use 
Authentication Settings, Use Proxy Settings or both.

 5 Specify the authentication details, and, for a proxy server, the name and 
port of the server. If you attempt to import the secure service before 
specifying the necessary credentials, VuGen prompts you to enter the 
information.
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 6 To update or modify the security settings, open the Service Manager and 
select the appropriate service in the left pane. Click the Connection Settings 
tab. Edit the required fields and click OK.

Deleting Services

You can delete service entries from the Service Management dialog box, 
when they are no longer required. If a service was updated, you can 
synchronize the WSDL from the source—you don’t need to delete it and 
reimport the service.

Before deleting a service, make sure that it is not required for your script. If 
you created a script based on a specific service and you then attempt to 
delete it, VuGen warns you that the deletion may affect your script. 
Deletions cannot be undone.

To delete a service, select it from the list of services and click the Delete 
button.

Comparing WSDL Files

When you import a WSDL file, VuGen makes a working copy and saves it 
along with the script. This saves resources and enables a more scalable and 
stable environment.

It is possible, however, that by the time you run the script, the original 
WSDL file will have changed. If you run the script, the test results may be 
inaccurate and the script may no longer be functional. Therefore, before 
replaying a Web Services script that was created at an earlier date, you 
should run a comparison test on the WSDL file.

VuGen provides a comparison tool which compares the local working copy 
of the WSDL file with the original file on the file system or Web server. 

If the differences are significant, you can update the WSDL from the original 
copy using the Synchronize option in the Service Management dialog box.

VuGen also has a general utility that allows you to compare any two XML 
files. For more information, see “Comparing XML Files” on page 53.
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Setting WSDL/XML Comparison Options
VuGen offers the following options when comparing the local and global 
copies of the WSDL documents, or the revisions of an XML file:

➤ Show only differences. Show only lines with differences. Do not show the 
entire document.

➤ Ignore case. Ignore case differences between the texts.

➤ Ignore comments. Ignore all comments in the texts.

➤ Ignore processing Instructions. Ignore all texts with processing instructions.

➤ Ignore namespaces. Ignore all namespace differences.

To configure the comparison options: 

 1 Configure the comparison settings. Choose SOA Tools > SOA Settings > 
XML/WSDL Compare. The WSDL Operations Options dialog box opens. 
Select the desired options.

 2 Click OK.

Note: The comparison option settings apply to both WSDL comparisons 
from within the Service Management window, and for XML comparisons 
accessed from the Tools menu.
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Comparison Reports
VuGen lists the differences between the files in a Comparison report. 

In WSDL Comparison reports, there are two columns— Working Copy and 
Original File. The Working Copy is the WSDL stored with the script, while 
the Original File is the WSDL at its original location—a network file path or 
a URL.

In XML Comparison reports, each column displays the path of an XML file.

The Comparison report uses the following legend to mark the differences 
between the two files:

➤ Yellow. Changes to an existing element (shown in both versions).

➤ Green. A new element added (shown in the original file copy).

➤ Pink. A deleted element (shown in the working copy).

In the following example, line 24 was deleted from the original copy and 
and line 28 was added.
51



Chapter 4 • Managing Web Services
Running a WSDL Comparison
After running a file comparison, you can decide whether to ignore the 
changes, if they exist, or reload the WSDL file.

To compare WSDL files: 

 1 Configure the comparison settings. Choose SOA Tools > SOA Settings > 
XML/WSDL Compare. The XML/WSDL Comparison dialog box opens. 
Select the desired options.

 2 Open the Service Management window. Choose SOA Tools > Service 
Management or click the Manage Services toolbar button

 3 Select the service upon which you want to perform a comparison. You can 
only run the comparison on one service at a time.

 4 Click Compare. The WSDL Comparison Report opens.

 5 Scroll down through the file to locate the differences.

If you find differences between the two files and you want to update 
VuGen’s working copy of the WSDL file, click on the WSDL file in the tree in 
the left pane. Select Refresh file from global copy from the right-click menu. 
This copies the current version of the WSDL into the script’s WSDL 
directory.

 6 To close the WSDL Comparison Report window, choose File > Exit.
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Comparing XML Files
VuGen provides a utility that lets you compare two XML files.

You can specify what differences to ignore, such as case or comments. For 
additional information about the comparison options, see “Setting 
WSDL/XML Comparison Options” on page 50.

To compare two XML files:

 1 Choose Tools > Compare XML Files. The XML File Comparison dialog box 
opens.

 2 Click the Browse button to the right of the Base Revision box to locate the 
original XML file.

 3 Click the Browse button to the right of the Compared Revision box to locate 
the newer XML file.

 4 Click OK. VuGen opens the XML Comparison Report window.

For information about the Comparison report, see “Comparison Reports” on 
page 51.
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Viewing WSDL Files

The Service Management window lets you view the WSDL in your default 
browser. 

To view a WSDL:

 1 Select it in the left pane.

 2 Click the View WSDL button in the Service Management window.
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Adding Content to Web Services Scripts

You use VuGen to create a script to test your Web Services through 
recording, manually adding calls, or analyzing server traffic.

This chapter includes:

 ➤  About Adding Content to Web Services Scripts on page 55

 ➤  Recording a Web Services Script on page 56

 ➤  Viewing the Workflow on page 61

 ➤  Adding New Web Service Calls on page 62

 ➤  Importing SOAP Requests on page 65

 ➤  Using Your Script on page 68

 ➤  Working with Service Test Management on page 69

The following information only applies to Web Services and SOA Vuser 
scripts.

About Adding Content to Web Services Scripts

Web Services scripts let you test your environment by emulating Web 
Service clients. 

After creating an empty Web Services script, as described in “Understanding 
the SOA Test Types” on page 27, you add content through one of the 
following methods: recording, manually inserting Web Service calls, 
importing SOAP, or by analyzing server traffic.
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To create scripts automatically, run the SOA Test Generator using the wizard 
to add content. For more information, see Chapter 23, “Using the SOA Test 
Generator.”

Recording a Web Services Script

By recording a Web Services session, you capture the events of a typical 
business process. If you have already built a client that interacts with the 
Web Service, you can record all of the actions that the client performs. The 
resulting script emulates the operations of your Web Service client. After 
recording, you can add more Web Service calls and make other 
enhancements. 

Specify Services for Recording
When you record an application, you can record it with or without a Web 
Service WSDL file. It is recommended to record with a WSDL when possible.

If you include a WSDL file, VuGen allows you to create a script by selecting 
the desired methods and entering values for their arguments. VuGen creates 
a descriptive script that can easily be updated when there are changes in the 
WSDL.

For information on creating scripts by See

recording “Recording a Web Services Script” 
below

manually inserting Web Service calls “Adding New Web Service Calls” on 
page 62

importing SOAP requests “Importing SOAP Requests” on 
page 65

analyzing server traffic Chapter 6, “Creating Server Traffic 
Scripts”

running the SOA Test Generator Chapter 23, “Using the SOA Test 
Generator”
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If you do not specify a WSDL file (not recommended), VuGen creates a test 
with SOAP requests instead of Web Service call steps. If you create a script 
without importing a service, VuGen creates a soap_request step whose 
arguments are difficult to maintain.

To create Web Services script through recording:

 1 Create an empty script. 

Choose File > New to open the New Virtual User dialog box.

For a single protocol script, click New Single Protocol Script in the left pane. 
Select Web Services protocol from the E-Business category. Click OK.

If you need to record several different protocols, such as Web Services and 
Web, click New Multiple Protocol Script in the left pane and specify the 
desired protocols. Click OK.
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 2 Begin the recording process. 

Click the Start Record button or Ctrl+R to open the Specify Services screen.

 3 Add a service to the list. 

To produce a high-level Web Service script, add one or more services using 
the Import button. If the WSDL of the recorded Web Service is available, it is 
recommended to import it here. If you create a script without importing a 
service, VuGen creates a soap_request step. The Import Service dialog box 
opens.
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 a Choose a source and location for the WSDL. 

 b Select a toolkit. The toolkit you choose is permanently associated with 
the script. For more information, see “Importing Services” on page 43.

 c Click Import.

Repeat the above step for each WSDL you want to import.

 4 Enter details for the Web Service.

Click Details to open the Service Manager window and view the details of 
the Web Services that you added. For more information, see Chapter 7, 
“Working in the Web Service Call View.”

In the next step, you choose an application to record.

Selecting an Application to Record
In this screen you specify the application to record. You can record a 
browser session or client application.
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 1 Specify the recording details.

➤ Record default Web Browser. Records the actions of the default Web 
browser, beginning with the specified URL. Select this option where you 
access the Web Service through a Web-based UI.

➤ Record any application. Records the actions of a your client application. 
Specify or browse for the path in the Program to record box. Specify any 
relevant arguments and working directories. 

 2 Configure options.

➤ Record into action. The action in which to generate the code. If there are 
startup procedures that you do not need to repeat, place them in the 
vuser_init section. During recording you can switch to another section, 
such as Action.

➤ Record application startup. Records the application startup as part of the 
script. If you want to begin recording at a specific point, not including 
the startup, clear this check box.

➤ Advanced Options. Opens the Recording Options dialog box, allowing 
you to customize the way in which the script is generated. For more 
information, see the section on setting Script Generation preferences.

 3 Click Finish. 

VuGen opens the application and begins recording. Perform the desired 
actions within your application and then press the Stop button on the 
floating toolbar. VuGen generates web_service_call functions, or 
soap_request functions if you did not import a WSDL.

After recording, you can enhance your script with additional service calls 
and parameterization. You run the completed script in VuGen to check its 
functionality. 

For more information, see “Getting Started with Web Services Vuser Scripts” 
on page 28. 
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Viewing the Workflow

When adding script content through recording or Analyzing traffic, VuGen’s 
workflow guides you through the stages of preparing a script. By clicking in 
the Tasks pane, you can read about the steps for creating a script, view 
information about your recording, and verify the replay. Use the Back and 
Next buttons to navigate between screens.

If you do not see the Workflow screen, click the Tasks button on the toolbar 
to open the Tasks pane, and select a task.

Create Script
The Create Script screen provides several guidelines for creating a Web 
Services script. It also provides a link for opening the Web Services wizard.

➤ Before You Start. Describes what you should know before you begin.

➤ About Script Creation. Describes the stages of script creation.

➤ Actions. Describes script sections and why they are important.

There are two action-related links:

➤ Start Recording. Opens the Start Recording dialog box where you provide 
information about the application to record.

➤ Analyze Traffic. Lets you analyze traffic captured over the network to 
create a script that emulates a server. 

Creation Summary
After you create a script, the Creation Summary screen provides information 
about the recording or script generation. 

➤ Protocols. Lists which protocols were used during the script creation.

➤ Actions. Describes into which sections actions were recorded or 
imported. 
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It also provides links that allow you to modify the script:

➤ Add a web_service_call statement. Lets you manually add a 
web_service_call function to your script by specifying a service, 
operation, and argument values.

➤ Manage the services. Opens the Service Repository window with a list of 
all of the services that are available to the script and their properties.

➤ Compare XML files. Allows you to compare two versions of an XML file. 
This is useful for comparing WSDL files and determining if there was a 
change since your originally imported it into the script.

For information about the remainder of the workflow, see Chapter 3, 
“Viewing the VuGen Workflow.”

Adding New Web Service Calls

You can add new Web Service call functions in both Tree and Script views.

To add a Web Service call:

 1 Click the cursor at the desired location in your script.

 2 Click the Add Service Call button. The New Web Service Call dialog box 
opens. Select the desired Service. If this is a new script and you did not yet 
import a WSDL, do so at this point. For more information, see “Importing 
Services” on page 43.
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 3 Select an Operation. For services using multiple ports, select a Port Name for 
the operation. This lets you differentiate between identical operations 
performed on separate ports.

 4 To specify a target address other than the default for the active port, select 
Override address and enter the address.

 5 To provide sample input values for the service, click on the highest level 
node (the service name) and select Generate auto-values for input 
arguments. VuGen adds sample values and places an arrow before each of 
the arguments, to indicate that it is using auto-values.

To provide sample values for all Input arguments, select the Input 
Arguments node and click Generate.
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 6 To parameterize the input arguments of the operation, see “Setting 
Properties for XML Parameters” on page 182.

 7 Select the Transport Layer Configuration node to specify advanced options, 
such as JMS transport for SOAP messages (Axis toolkit only), asynchronous 
messaging, or WS Addressing. For more information, see “Configuring the 
Transport Layer” on page 128.

 8 Click on each of the nodes and specify your preferences for argument 
values. For more information, see Chapter 7, “Working in the Web Service 
Call View.”

 9 To add an attachment to an input argument, or to specify a parameter to 
store output arguments, select the operation’s main node and make the 
appropriate selection. For more information, see “Attachments” on 
page 107.
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Importing SOAP Requests

VuGen lets you create Web service calls from SOAP files. If you have a SOAP 
request file, you can load it directly into your script. VuGen imports the 
entire SOAP request (excluding the security headers) with the argument 
values as they were defined in the XML elements. By importing the SOAP, 
you do not need to set argument values manually as in standard Web 
Service calls.

For example, suppose you have a SOAP request with the following elements:

- <soap:Body soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
- <q1:AddAddr xmlns:q1="http://tempuri.org/AddrBook/message/">

<Addr href="#id1" /> 
  </q1:AddAddr>

- <q2:Addr id="id1" xsi:type="q2:Addr" xmlns:q2="http://tempuri.org/AddrBook/type/">
<name xsi:type="xsd:string">Tom Smith</name> 

 <street xsi:type="xsd:string">15 Elm Street</street> 
 <city xsi:type="xsd:string">Pheonix</city> 
<state xsi:type="xsd:string">AZ</state> 
<zip-code xsi:type="xsd:string">97432</zip-code> 
<phone-numbers href="#id2" /> 
<birthday xsi:type="xsd:date">1983-04-22</birthday> 

  </q2:Addr>
…
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When you import the SOAP request, VuGen imports all of the values to the 
Web Service call:

To create a new Web Service call based on a SOAP request, you must first 
import a WSDL file. If a WSDL is not available, or if you want to send the 
SOAP traffic directly, you can create a SOAP Request step. You specify the 
URL of the server, the SOAP action, and the response parameter.
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In Script view, the SOAP Request step appears as a soap_request function, 
described in the Online Function Reference (Help > Function Reference).

To import a SOAP request:

 1 Click the Import SOAP button or choose SOA Tools > SOAP Import.

 2 Browse for the XML file that represents your SOAP request.

 3 Choose the type of step you would like to generate: Create Web Service Call 
or Create SOAP Request. In order to create a Web Service Call, you must first 
import at least one WSDL that describes the operation in the SOAP request 
file. To import a WSDL, click Service Management and then click the 
Import button. To view the SOAP before loading it, click View SOAP.

 4 Click Load. VuGen loads the XML element values.

For a Web Service Call, set the properties for the Service call as described in 
“Understanding Web Service Call Properties” on page 87.
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For a SOAP request, provide the URL and the other relevant parameters.

 5 For a Web Service Call, if there are multiple services with same operation 
(method) names, you need to choose the service whose SOAP traffic you 
want to import. For information about additional properties, see 
“Understanding Web Service Call Properties” on page 87.

 6 Click OK to generate the new step within your script.

 7 Set checkpoints and replay the step. For more information, see “Setting 
Checkpoints” on page 119.

Using Your Script

After you create scripts, you can manage them in one of the following ways:

➤ Service Test Management. An add-on for HP Quality Center that lets you 
manage SOA testing by allowing you to import, store and define services in 
Quality Center. Its sections include Requirements Management, Test Plan, 
Test Lab, and Defects Management. For more information, see “Working 
with Service Test Management” on page 69.
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You can use the completed script to test your system in several ways:

➤ Functional Testing. Run the script to see if your Web services are functional. 
You can also check to see if the Web service generated the expected values 
For more information, see Chapter 9, “Running SOA/Web Services Scripts.”

➤ Load Testing. Integrate the script into a LoadRunner Controller scenario to 
test its performance under load. For more information, see the HP 
LoadRunner Controller or Performance Center documentation.

➤ Production Testing. Check your Web service’s performance over time 
through a Business Process Monitor profile. For more information, refer to 
the HP Business Availability Center documentation.

Working with Service Test Management

HP Quality Center is a Web-based application for test management. Its 
sections include Requirements Management, Test Plan, Test Lab, and Defects 
Management. 

The Service Test Management add-on for Quality Center, lets you manage 
SOA testing by allowing you to import, store and define services in Quality 
Center.

The Service Test Management integration lets you:

➤ Store Web Services. You can store and organize Web Services in Quality 
Center for use within Service Test.

➤ Write Service Test scripts. You can create scripts based on the services 
stored in Quality Center, while maintaining up-to-date WSDLs 
throughout the life-cycle of the service and the script.

➤ Compose a Business Process Test. You can create a BPT (Business Process 
Test) in Quality Center based on services defined through Service Test 
Management.

Service Test Management also integrates with HP’s Systinet Registry, to 
create test requirements and plans. Once the services are imported, Service 
Test Management identifies any changes to the services and automatically 
generates the necessary test cases that need to be run.
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Using the Service Test Management add-on for Quality Center, groups 
throughout your organization can contribute to the quality process in the 
following ways:

➤ Business analysts define application requirements and testing objectives.

➤ Test managers and project leads design test plans and develop test cases.

➤ Test managers automatically create QA testing requirements and test assets 
for SOA services and environments.

➤ Test automation engineers create automated scripts and store them in the 
repository.

➤ QA testers run manual and automated tests, report execution results, and 
enter defects.

➤ Developers review and fix defects logged into the database.

➤ Project managers can export test and resource data in various reports, or in 
native Microsoft Excel for analysis.

➤ Product managers decide whether an application is ready to be released.

➤ QA analysts can auto-generate test asset documentation in Microsoft Word 
format.

For more information about the integration, refer to the HP Service Test 
Management User’s Guide.
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Creating Server Traffic Scripts

Using VuGen, you can create scripts to test your Web Service by analyzing 
server traffic capture files.

This chapter includes:

 ➤  About Creating Server Traffic Scripts on page 71

 ➤  Getting Started with Server Traffic Scripts on page 73

 ➤  Generating a Capture File on page 74

 ➤  Creating a Basic Script from Server Traffic on page 76

 ➤  Specifying Traffic Information on page 78

 ➤  Choosing an Incoming or Outgoing Filter on page 79

 ➤  Providing an SSL Certificate on page 80

The following information only applies to Web Services/SOA Vuser scripts.

About Creating Server Traffic Scripts

The main focus when testing enterprises and complex systems, is to measure 
the performance from the client end. Ordinarily, VuGen records the actions 
you perform in the application or browser, and generates a script emulating 
the client actions and requests to the server.

In certain test environments, you may be unable to record the client 
application to retrieve the requests to the server. This may be a result of the 
server acting as a client, or because you do not have access to the client 
application. In these cases, you can create a script using VuGen’s Analyze 
Traffic feature. 
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The Analyze Traffic feature examines a capture file containing the server 
network traffic, and creates a script that emulates requests sent to or from 
the server. The steps in creating a script by analyzing server traffic are 
described below in Getting Started with Server Traffic Scripts.

There are two types of emulations: Incoming traffic and Outgoing traffic.

Incoming traffic scripts emulate situations in which you want to send 
requests to the server, but you do not have access to the client application, 
for example, due to security constraints. The most accurate solution in this 
case is to generate a script from the traffic going into the server, from the 
side of the client. 

When you specify an Incoming server network traffic, you indicate the IP 
address of the server and the port number upon which the application is 
running. VuGen examines all of the traffic going into the server, extracts the 
relevant messages, and creates a script. In the above diagram, if the client is 
unavailable, you could create an Incoming script to emulate the requests 
coming into Server A.

Outgoing Traffic scripts emulate the server acting as a client for another 
server. In an application server that contains several internal servers, you 
may want to emulate communication between server machines, for 
example between Server A and Server B in the above diagram. The solution 
in this case is to generate a script from the traffic sent as output from a 
particular server.
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When you create an Outgoing traffic script, you indicate the IP address of 
the server whose outgoing traffic you want to emulate, and VuGen extracts 
the traffic going out of that server. In the above diagram, an Outgoing script 
could emulate the requests that Server A submits to the Server B.

Getting Started with Server Traffic Scripts

The following section outlines the process of creating a script that analyzes 
server traffic.

 1 Create a capture file. 

VuGen uses the capture file to analyze the server traffic and emulate it. For 
more information, see “Generating a Capture File” on page 74.

 2 Create a new Web Services script.

Using VuGen’s main interface, you create a new Web Services script. For 
more information see Chapter 2, “Understanding the SOA Test Types.”

 3 Specify the Services (optional, but recommended).

To create a high-level script, import a WSDL which describes the Web 
Service you want to test. 

 4 Specify the traffic information.

Click the Analyze Traffic button. Specify the location of the traffic file and 
whether your script will be for Incoming or Outgoing traffic. For more 
information, see “Specifying Traffic Information” on page 78.

 5 Specify the traffic filter Recording options.

Filter options let you determine which hosts to include or exclude in your 
script. For more information, see “Choosing an Incoming or Outgoing 
Filter” on page 79.

 6 Specify the SSL certificate information.

The SSL configuration lets you analyze secure traffic over HTTPS in order to 
generate the script. For more information, see “Providing an SSL Certificate” 
on page 80.
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Generating a Capture File

A capture file is a trace file containing a log of all TCP traffic over the 
network. Using a sniffer application, you obtain a dump of all of the 
network traffic. The sniffer captures all of the events on the network and 
saves them to a capture file.

To generate a smaller, more manageable script, try to capture the network 
traffic only for the time that you perform actions in your application. 

Note: Capture files do not contain loopback network traffic.

You can obtain a capture file using the command line utility or any existing 
capture tool.

The VuGen Command Line Utility

The VuGen command line utility, lrtcpdump, is located in the product’s bin 
directory. There is a separate utility for each of the platforms: lrtcpdump.exe 
(Windows), lrtcpdump.hp9, lrtcpdump.ibm, lrtcpdump.linux, and 
lrtcpdump.solv4.

To invoke the capture tool, type:

lrtcpdump -i<interface> -f<file> 

where interface is the name of the network card whose traffic you want to 
capture, and file is the name of the capture file in which to store the 
information. Do not leave a space between the command line option (i or f) 
and the value.

To create a capture file on a Windows platform:

 1 Choose Start > Run, type cmd and click OK to open a command window.

 2 Drag in or enter the full path of the lrtcpdump.exe program located in the 
product’s bin directory.

 3 Provide a file name for the capture file using the following syntax:
lrtcpdump -f <file>
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for example lrtcpdump -fmydump.cap.

 4 lrtcpdump prompts you to select a network card. If there are multiple 
interface cards, it lists all of them. Type in the number of the interface card 
(1, 2, 3 etc.) and click Enter.

 5 Perform typical actions within your application.

 6 Return to the command window and click Enter to end the capture session.

To create a capture file on a UNIX platform:

 1 Locate the appropriate lrtcpdump utility for your platform in the product’s 
bin directory. Copy it to a folder that is accessible to your UNIX machine. 
For example, for an HP platform, copy lrtcpdump.hp9. If using FTP, make 
sure to use the binary transfer mode.

 2 Switch to the root user to run the utility.

 3 Provide execution permissions. chmod 755 lrtcpdump.<platform>

 4 On UNIX platforms, if there are multiple interface cards, lrtcpdump uses the 
first one in alphabetical order. To get a complete list of the interfaces, use 
the ifconfig command.

 5 Run the utility with its complete syntax, specifying the interface and file 
name. For example, lrtcpdump.hp9 -ietho -fmydump.cap. The capturing of 
the network traffic begins.

 6 Perform typical actions within your application.

 7 Return to the window running lrtcpdump and follow the instructions on 
the screen to end the capture session.

 8 Place the capture file on the network in a location accessible to the machine 
running VuGen.

An Existing Capture Tool

Most UNIX operating systems have a built-in version of a capture tool. In 
addition, there are many downloadable capture tools such as 
Ethereal/tcpdump.

When using external tools, make sure that all packet data is being captured 
and none of it is being truncated. 
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Note: Certain utilities require additional arguments. For example, tcpdump 
requires the -s 0 argument in order to capture the packets without 
truncating their data.

Creating a Basic Script from Server Traffic

You create a script from server traffic just as you would create a recorded 
script. 

You can optionally specify a Web Service for your script. If you specify a 
service, VuGen will create a script with web_service_call functions. If you 
do not specify a service, VuGen creates a script with soap_request functions.

To create a server traffic script:

 1 Choose File > New and click New Single Protocol Script in the left pane.

 2 Select the Web Services protocol and click OK.

 3 Click the Analyze Traffic button or choose Vuser > Analyze Traffic.  The 
wizard opens.

 4 Add one or more services to the list. This step is optional.
76



Chapter 6 • Creating Server Traffic Scripts
➤ To add a new service, click Import. In the Import Service dialog box, 
specify the location of the WSDL. You can specify a URL, File, UDDI 
server (such as Systinet), or a location in Quality Center. In the Import 
Service dialog box, you also choose a toolkit for analyzing the service. 
The selected toolkit will be permanently associated with the script—it 
cannot be changed. For more information, see “Importing Services” on 
page 43.

➤ To set or view details about the services, click Details to open the Service 
Management window. For more information about Service Management, 
see Chapter 4, “Managing Web Services.”

➤ To remove a listed service, select it and click Delete

 5 On the bottom of the wizard screen, click Next to specify the traffic file 
information. For more information, see below.

 6 After providing traffic information, click Finish to generate a script.
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Specifying Traffic Information

The traffic file contains a dump of all the network traffic. Using the wizard, 
you specify the location of the traffic file and whether you want your script 
to emulate incoming or outgoing traffic.

➤ Capture file. The name and path of the traffic file, usually with a cap 
extension.

➤ Incoming traffic:Server/Port. The IP address and port of the server whose 
incoming traffic you want to examine.

➤ Outgoing traffic:Server. The IP address of the server whose outgoing traffic 
you want to examine.

➤ Record into action. The section into which to create the script. If you want 
to use iterations, specify the Actions section.

➤ Filter options. Opens a filter interface allowing you to specify which IP 
addresses to include or exclude from the script. For more information, see 
below.

➤ SSL Configuration. Allows you to add SSL certificates to analyze traffic from 
a secure server with the required credentials. For more information, see 
“Providing an SSL Certificate” on page 80.
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Choosing an Incoming or Outgoing Filter

You can provide a filter to drill down on specific requests going to or from a 
server, by specifying its IP address and port.

It is also possible to filter your capture file with an external tool before 
loading it into VuGen. In that case, you may not require additional filtering.

You filter the requests by choosing the relevant host IP addresses. The filter 
can be inclusive or exclusive—you can include only those IPs in the list, or 
include everything except for those IPs that appear in the list.
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To filter the traffic file:

 1 Open the Traffic Filters recording options. Click Filter Options in the Specify 
Traffic Information step, or choose Tools > Recording Options. Select the 
Traffic Analysis:Traffic Filters node.

 2 Select one of the filtering options: include all IP addresses in the list or 
exclude all IP addresses in the list.

 3 Select the tab that corresponds to your script type: Incoming Traffic or 
Outgoing Traffic.

 4 Add hosts to the list.

To add a host to the list, click the Add button. Specify the IP address of the 
server you want to add to the list. For incoming traffic, specify the port of 
the server to include or exclude. Click OK to accept the settings.

Click Delete to remove an entry.

After the script is created you can change the filters and regenerate the 
script—there is no need to re-analyze the capture file.

Providing an SSL Certificate

To analyze traffic from a secure server, you must provide a certificate 
containing the private key of the server.

If the traffic is SSL encrypted, you must supply a certificate file and password 
for decryption. If you want traffic from multiple servers to be reflected in 
the script, you must supply a separate certificate and password for each IP 
address that uses SSL. 
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To specify an SSL certificate:

 1 In the Specify Traffic Information screen, click SSL Configuration.

 2 Add certificates to the list. 

To add a certificate to the list, click the Add button. Specify the IP address, 
port, path of the certificate file (with a pem extension), and the password for 
the certificate. Make sure the pem file contains the private key. If you are 
unsure of how to obtain the certificate, contact your system administrator.

Click the Delete button to remove an entry from the list.

 3 Repeat the above steps for every certificate you want to add.

 4 Click OK to close the dialog box.
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7
Working in the Web Service Call View

You use the Web Service Call view to display snapshots, set properties, and 
add checkpoints to Web Service calls.

This chapter includes:

 ➤  About the Web Service Call View on page 83

 ➤  Viewing Web Services SOAP Snapshots on page 84

 ➤  Understanding Web Service Call Properties on page 87

 ➤  Working with Optional Parameters on page 99

 ➤  Base 64 Encoding on page 103

 ➤  Attachments on page 107

 ➤  Working with the XML on page 111

 ➤  Using Web Service Output Parameters on page 115

 ➤  Setting Checkpoints on page 119

The following information only applies to Web Services and SOA Vuser 
scripts.

About the Web Service Call View

Using the Web Service Call view, you can view snapshots, set properties, and 
define checkpoints for each of the Web Service calls in your script.

To open the Web Service Call view, you must be in Tree view. Choose View > 
Tree View in the VuGen window to open Tree view.
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The Snapshot lets you view the SOAP structure of each step. You can view 
snapshots of the recording, replay, request, and response. For more 
information, see below.

The Properties tab lets you configure the settings for each Web Service call. 
You can set properties in the area of argument values, parameterization, 
transport layer, and security. For more information, see “Understanding 
Web Service Call Properties” on page 87.

Checkpoints let you verify your Web service results. You can check for 
expected values and view the output to see if they were matched. For more 
information, see “Setting Checkpoints” on page 119.

Viewing Web Services SOAP Snapshots

You can use VuGen’s snapshot viewer to examine the SOAP requests and 
responses that occurred during record and replay. Note that you must replay 
the session at least once in order to view a replay snapshot.

There are several ways to view the SOAP snapshots:

➤ Record and/or Replay

➤ Request or Response Data

➤ Tree or XML View

Using the buttons in the Snapshot window, you can control the view:

In Tree view, you can expand the nodes to view the values of the arguments, 
if they were assigned.

In Request view, the displayed values are those that were sent to the server 
during the Web Services session. In Response view, the displayed values are 
the results returned by the server.
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In the following example, the Snapshot window shows the Record and 
Replay snapshots of the Request data in Tree view.

 

To learn more about a node, select it and choose Node Properties from the 
right-click menu.
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In the XML view, you can view the whole SOAP message in XML format.

 

Choosing a Replay Iteration

If you replayed the script with multiple iterations, you can specify which 
iteration to display in the snapshot. In addition, you can display a snapshot 
from test results that you saved in a location other than the script’s folder.

By default, the Snapshot view shows the last iteration.

To choose an iteration to display:

 1 Choose View > Snapshot > Choose Iteration.

 2 Select the desired iteration and click OK.

 3 To display results from another folder, choose Select Folder and browse to 
the location of the test results.
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Understanding Web Service Call Properties

VuGen provides an interface for you to view and modify the properties of 
each one of the Web Service calls. 

Properties describe the behavior of each method within your service. You 
can set a target address, argument values, parameterization, and transport 
layer preferences for each of your service’s methods.

You can view a step’s properties from Tree view (View > Tree view) in one of 
the following ways:

➤ Double-click on a step in the left pane to open the Web Service Call 
Properties dialog box.

➤ Select the Step Properties tab in the right pane.
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The Properties view displays each of the service’s operations in a tree 
hierarchy. The nodes of the tree represent the Transport Layer 
Configuration, the SOAP header, input arguments, and output arguments.

By default, the script takes the target address from the WSDL. You can 
override this address for each operation. Select the Override Address option 
and specify the desired Target Address.
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The contents of the right pane changes, depending on the level of the 
selected tree node. The following table describes the content for each node:

If you select… The right pane shows…

A method or operation 
name

➤ The method’s properties.

➤ A check box to enable the automatic generation 
of values for input arguments.

➤ A check box to include attachments.

Transport Layer 
Configuration

Advanced transport options:

➤ HTTP/S Transport with async. or WS-A routing.

➤ JMS Transport support with response and request 
Queue information.

SOAP Header An edit box to indicate the value of the SOAP 
header for the current element. For more 
information, see “SOAP Headers” on page 111.

Input Arguments node ➤ The Name of each method and its Value.

➤ Include All, Reset and Generate buttons.

An individual argument ➤ Name. The name of the argument (read-only)

➤ Type. The argument type as defined in the 
WSDL. When the WSDL contains derived types, 
this box becomes a drop down list. For more 
information, see “Derived Types” on page 98.

➤ Include argument in call. Includes the Optional 
parameters in the Web Service call. See “Working 
with Optional Parameters” on page 99.

➤ Nil. Sets the Nillable attribute to True.

➤ Value. The value of the argument. For base64 
binary type arguments, Get from file or Base64 
Encoded text. 

➤ Generate auto-value for this argument. Insert 
automatic values for this node.
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A complex input 
argument

➤ XML. Enables the Edit, Import, and Export 
buttons. By editing the XML, you can manually 
insert argument values. Click on the ABC icon to 
replace the entire XML structure with a single 
XML type parameter. Note: This import 
operation handles XML files that were previously 
exported—not standard SOAP files. To import 
SOAP, see “Importing SOAP Requests” on 
page 65.

➤ Generate auto-value for this argument. Inserts 
automatic values for all arguments of this 
complex type node. 

➤ Add/Delete. Adds or removes elements from the 
array. 

Output Arguments The Name arguments and the Parameter that will 
store the value

Input Attachments The Attachment Format for encoding the soap 
request: DIME or MIME for the VuGen toolkit, 
DIME only for .NET, and MIME only for Axis.
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You can set argument values for the following elements: (manually edited 
arguments are displayed in blue)

➤ Input Argument Values

➤ Output Arguments

➤ Arrays

➤ Attachments

➤ SOAP Headers

Attachment ➤ Take Data from. The name of the file to attach or 
the name of the parameter containing the data.

➤ Content Type. The attachment’s content type. 
You can instruct VuGen to detect it automatically 
or choose a type from the dropdown list or enter 
a value manually.

➤ Content ID. The attachment’s ID attribute. You 
can instruct VuGen to automatically generate a 
value or specify your own ID.

➤ Delete Attachment. A button to remove the 
attachment.

Output Attachments ➤ Save All Attachments. Saves all attachments to 
parameters:

➤ Content. The name of the parameter prefix for 
storing the attachment.

➤ Content Type. The attachments’ content type 
attribute (read-only).

➤ Content ID. The attachment’s ID attribute (read-
only).

➤ Save Attachments by Index. Save the 
attachments by number, beginning with 1. Click 
Add to insert additional attachment indexes.
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Input Argument Values

The Input Arguments node lets you define values for all of the input 
arguments and lets you control the Optional elements. For more 
information about Optional elements, see “Working with Optional 
Parameters” on page 99.

➤ Include All. Includes all Optional elements—all of the operation’s elements 
are included.

➤ Reset. Excludes all Optional elements and only includes the mandatory 
ones.

➤ Generate. Includes all Optional elements and generates automatic values for 
all of the operation’s elements.
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➤ Edit Argument. Opens the node of the selected argument and lets you set its 
values.

The individual argument nodes lets you define values for each of the input 
arguments.

➤ XML/Value. A manually specified value for the node. If your argument is an 
array, you can specify an XML structure. Otherwise, specify an ordinary 
value. To create a parameter for the argument, click the ABC icon in the 
right corner of the XML/Value box to open the Select or Create Parameter 
dialog box.

➤ Generate auto-value for this argument. If you want VuGen to automatically 
generate a value for this argument, select this option or select the argument 
in the tree hierarchy and choose Generate Auto-values from the right-click 
menu.
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Choice Elements

If your WSDL defines Choice elements, you can view them and set their 
values in the Properties view.

To set a value for a choice element, select the parent element, enable the 
Include argument in call option in the right pane, and provide a value. 

To parameterize the argument, click the ABC icon. In the Parameter 
Properties dialog box, provide values for the choice argument. You only 
need to provide values for one of the choice elements. When running 
multiple iterations, the script uses the values for the same choice element, 
according to the assignment method (sequential, unique or random). For 
example, if your choice elements are Decimal Number, String, and Number, 
and you provided values for Number, the Vuser will always use the Number 
element.

Choice support is provided for both Input and Output arguments, 
Parameterization, Checkpoints, and Service Emulation.

For information about working with optional arguments, see “Working with 
Optional Parameters” on page 99.
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Output Arguments

You can view the output argument values and save them to parameters or in 
an array.

➤ Save returned value in parameter. Saves the returned value to a parameter 
whose name you specify in the text box.
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Arrays 

To work with an array—for either input or output arguments, select it in the 
left pane.

➤ XML. The path of the XML file containing the values of the array elements. 
Click the ABC icon to replace the XML with an XML type parameter. XML 
parameterization supports arrays as input arguments. In the XML parameter, 
you define the number of array elements as required. 

When saving an array to a parameter, the number of array elements per 
parameter is constant. If you want to run multiple iterations, with each 
iteration using a different number of array elements, you need to define 
separate parameters, each containing the desired number of array elements. 

For more information about XML parameters, see “Setting Properties for 
XML Parameters” in Volume I-Using VuGen.
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➤ Edit/Import/Export. To modify complex types and arrays, select the 
elements and arguments and click Edit. Click Export to export the selected 
entry to a separate XML file, or Import to load a previously exported XML 
file. Note: This Import operation handles XML files that were previously 
exported—not standard SOAP files. To import SOAP, see “Importing SOAP 
Requests” on page 65.

➤ Add. Opens the Add Array Elements dialog box, allowing you to add array 
elements, either simple or complex. 

➤ Delete. Deletes array elements. Specify the starting index and the number of 
elements to remove.

Adding Array Elements

When you click Add in the Array Elements section, the Add Array Elements 
dialog box opens as described below.

➤ Start Index. The index of the first element that will be added. 

➤ Elements. The number of elements to add. 

➤ Copy values from index. Assigns values of an existing array element to the 
new elements. Specify the array index of the element whose value you want 
to use. 
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Derived Types

VuGen supports WSDLs with derived types. When setting the properties for 
a Web Service Call, you can set the arguments to use the base type or derived 
type.

After you select the desired type, VuGen updates the argument tree node to 
reflect the new type.
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Abstract Types

Abstract is a declaration type declared by the programmer. When an 
element or type is declared to be abstract, it cannot be used in an instance 
document. Instead, a member of the element's substitution group, provided 
by the XML schema, must appear in the instance document. In such a case, 
all instances of that element must use the xsi:type to indicate a derived type 
that is not abstract.

When VuGen encounters an Abstract type, it cannot create an abstract class 
and replay will fail. In this case, VuGen displays a warning message beneath 
the Type box, instructing you to replace the Abstract type with a derived 
type.

Working with Optional Parameters

If your WSDL file contains optional parameters, you can indicate whether or 
not to include them in the SOAP request. 

In WSDL files, optional parameters are defined by one of the following 
attributes:

minoccurs='0' 

nillable='true'

minoccurs = 0 indicates a truly optional element, that can be omitted. 
Nillable means that the element can be present without its normal content, 
provided that the nillable attribute is set to true or 1. By default, the 
minoccurs and maxoccurs attributes are set to 1.

In the following example, name is mandatory, age is optional, and phone is 
nillable.

<s:element minOccurs="1" name="name" type="s:string" /> 
<s:element minOccurs="0" name="age" type="s:int" /> 
<s:element minOccurs="1" name="phone" nillable="true" type="s:string" /> 
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When setting argument values for your service call, VuGen indicates the 
type of element by enabling or disabling the options:

The following table indicates the availability of the options:

To include a specific optional argument in the service call, click the node 
and select Include Argument in Call. The nodes for all included arguments 
are colored in blue. Arguments that are not included are colored in gray.

Parameter type Nil radio button Include arguments in call

Mandatory disabled disabled

MinOccurs=0 disabled enabled

Nillable enabled disabled
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If you include an element on a parent level, it automatically includes all 
mandatory and nillable children elements beneath it. If it is a child element, 
then it automatically includes the parent element and all other mandatory 
or nillable elements on that level. If you specify Generate auto-value to a 
parent element, VuGen provides values for those child elements that are 
included beneath the parent.

Note: VuGen interprets whether elements are mandatory or optional 
through the toolkit implementation. This may not always be consistent 
with the element’s attributes in the WSDL file.

To include a sub elements:

 1 To include a specific sub element, choose it in the left pane and select the 
Include Argument in Call option.

 2 To include all sub elements of a parent element, apply Include Argument in 
Call to the parent element and click the Include button beneath it.

 3 To exclude all sub elements, select the parent element and click the Exclude 
button. It will exclude all omittable arguments.
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Recursive Elements

Using the Properties dialog box, you can control the level of recursive 
elements to include in the Web Service call. 

To exclude a certain level and exclude those below, highlight the lowest 
parent node that you want to include and select Include Argument in Call. 
VuGen includes the selected nodes, its mandatory children, and all of its 
parent nodes.

In the following example, three levels of the Choice argument are 
included—the rest are not. A non-included node is grayed out.

Choice Optional Elements

A Choice element in a WSDL defines a set of elements where only one of 
them appears in the SOAP message. In some cases, one of the Choice 
elements is optional, while the others are not. In Service Test, you can select 
the Choice element and still prevent its optional element from appearing in 
the SOAP envelope. In Tree view, select the Choice element, and clear the 
Include argument in call option. In Script view, delete the line that defines 
the Choice argument.
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Base 64 Encoding

Base 64 encoding is an encoding method used to represent binary data as 
ASCII text. Since SOAP envelopes are plain text, you can use this encoding 
to represent binary data as text within SOAP envelopes.

When VuGen detects a WSDL element of base64Binary type, it lets you 
provide an encoded value. You can specify a value in two ways:

➤ Get from file. Reference a file name.

➤ Embed encoded text. Specify the text to encode.
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To specify a base64Binary value:

 1 Select the Value option.

 2 To specify a file, select Get from file and locate the file using the Browse 
button below.

 3 To specify text, select the Embed encoded text option and click the Browse 
button below. The Process Base64 Data dialog box opens.

Enter text in the Text to encode box.

To use an encoding other than the default UTF-8 method, select it from the 
Encoding Options list. 

Click Encode.

 4 Click OK. VuGen adds the Web Service call to the script. You can now view 
the step and its properties in Tree view.

If you referenced the value from a file, the Web Service call will contain the 
file name:

"xml:arr="
"<arr base64Mode=\"file\">C:\\Load_testing\\TEcho.xml</arr>",
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If you inserted the actual text using the Base 64 Encoding Text option, then 
the Web Service call in the script will contain the encoded text.

Setting a Parameter Value for Base64Binary Data

To set the Base64 argument value to a parameter, create a new parameter of 
of File type, or XML type for Complex arguments. For more information, see 
“Setting Properties for XML Parameters” in Volume I-Using VuGen.

For complex type arguments containing base64Binary values, VuGen lets 
you process the base64Binary for setting parameter, checkpoint, or 
emulation values. When specifying the values, you can get values from a File 
or specify the Text manually and apply encoding.

If you choose to get the value from a file, specify one of the following 
options:

➤ Link to file. Reference the file containing the values. 

"xml:arr="
"<arr base64Mode=\"encoded\">YWJjZGVmZw==</arr>",
105



Chapter 7 • Working in the Web Service Call View
➤ Do not Link to a file. Use the content of the specified file. VuGen copies the 
content to the script folder. To use this option, clear the Link to file check 
box.

Tip: It is generally recommended to link to a file since this improves the 
script’s performance. If your text exceeds 10KB, you must link to a file.

To open the Process Base64 dialog box:

 1 Create a new parameter for a complex argument.

 2 In the grid view (XML parameters or checkpoints), click the Browse button 
to the right of the value box. The Process Base64 dialog box opens.

 3 Specify File or Text as a source for the value.

 4 If you chose File as the Source, specify whether or not to link to a file.

 5 To decode an encrypted value, for example, a value obtained during replay, 
click Decode to File. For more information, see below.
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This section applies to all of the places within VuGen that use the grid view 
of argument values: the parameter list and checkpoints.

Decoding to a File

VuGen lets you decode the encoded text to a file. This is especially useful for 
checking the correctness of base64 encoded values returned from the server, 
such as images.

The following procedure describes how to check if the Record and Replay 
images match one another.

To validate images using decoding:

 1 Create a New Web Service call.

 2 Set a value for the Base64 argument, using the Get from file option. Specify 
an image file. Continue creating the script.

 3 Save the script and replay it.

 4 Switch to the Checkpoint tab and load the Replay values.

 5 Click on the Replay value of the Base 64 argument and open its properties.

 6 Click Decode to file. Specify a file name to which to save the file. Use the 
same extension as the original file.

 7 Compare the decoded image to your original one to verify a match.

Attachments

When transferring binary files such as images over SOAP, the data must be 
serialized into XML. Serialization and deserialization can cause a significant 
amount of overhead. Therefore, it is common to send large binary files using 
an attachments mechanism. This keeps the binary data intact, reducing the 
parsing overhead.

Using attachments, the original data is sent outside the SOAP envelope, 
eliminating the need to serialize the data into XML and making the transfer 
of the data more efficient.
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The mechanisms used for passing a SOAP message together with binary data 
are MIME (Multipurpose Internet Mail Extensions) and the newer, more 
efficient DIME (Direct Internet Message Encapsulation) specifications. 

VuGen supports the sending and receiving of attachments with SOAP 
messages. You can send Input (Request) or save Output (Response) 
attachments. 

To add or save attachments, select an operation or a method in the left pane 
to which the attachments will be associated. You can add both input or 
output attachments

Input Attachments

Input attachments are added to the request message.

To add an attachment to the request:

 1 Select the operation in the left pane, to which you want to add the 
attachment. 

 2 In the right pane, select Add to request (Input). VuGen prompts you to 
enter information about the attachment and adds it to the method’s tree 
structure.

The Add Input dialog box opens.
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Specify the following information:

➤ Take data from. The location of the data. This can be a file or a parameter 
that contains the binary data. 

➤ File. You can specify the file location in two ways:

➤ Absolute Path: The full path of the file. Note that this file must be 
accessible from all machines running the script.

➤ Relative Path: (recommended) A file name. Using this method, during 
replay, VuGen searches for the attachment file in the script’s folder. To 
add it to the script’s folder, choose File > Add Files to Script and specify 
the file name.

➤ Parameter. You specify the name of a parameter containing the data.

➤ Content-type. The content type of the file containing the data. The Detect 
Automatically option instructs VuGen to automatically determine the 
content type. You can also choose from a list of the common content types 
in the Value box, such as text/html, and image/gif or type in another content 
type.

➤ Content-ID. The ID of the content. By default, VuGen generates this 
automatically by VuGen and serves as a unique identifier for the 
attachment. Optionally, you can specify another ID in the Value box.

Output Attachments

Output attachments are added to the response message.

To save the response as an attachment:

 1 Select the operation in the left pane, for which you want to save the 
response. 

 2 In the right pane, select Save received (Output). VuGen adds an Output 
Attachment node to the method’s tree structure in the left pane.
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 3 Select the desired option: Save All Attachments or Save Attachment by 
Index based on their index number—beginning with 1.

When you specify Save All Attachments, VuGen creates three parameters for 
each attachment based on the parameter name that your specify: a 
parameter containing the attachment data, the content type of the 
attachment, and a unique ID for the attachment. 

For example, if you specify the name MyParam in the Content field, the 
parameter names for the first attachment would be:

MyParam_1 
MyParam_1_ContentType
MyParam_1_ContentID
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When you specify Save Attachments by Index, you specify the index 
number and name of the parameter in which to store the attachment. The 
parameter name that you specify for Content, is used as a prefix for the 
Content type and Content ID parameters.

To edit the properties of either an Input or Output attachment, click the 
attachment in the left pane, and enter the required information in the right 
pane.

SOAP Headers

This view is available when you select SOAP header in the method’s tree 
view. The right pane lets you indicate whether or not to use SOAP headers. 
To use them, select Use SOAP header. Note that you must individually 
specify SOAP headers for each element. You can import XML code for the 
SOAP header, or compose your own using the Edit XML option. For more 
information, see “Editing an XML Tree” on page 112.

Working with the XML

Web Services allow you to viewand edit your XML. 

The following sections describe:

➤ Editing an XML Tree

➤ Saving and Copying the SOAP Response
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Editing an XML Tree
You can use VuGen’s XML Editor to view and edit the XML representation of 
complex types (structures, objects, etc.) and arrays.

Entering the values for the XML elements is a tedious and error-prone task. 
VuGen provides you with an interface that simplifies the task of entering, 
saving, and restoring the information. Once you enter the data manually, 
you can save it to an XML file using the Export option. For subsequent tests, 
you can import this file without needing to reenter the values a second 
time.

To edit XML strings:

 1 Select the Web Service call whose element you want to modify and click the 
Step Properties tab.

 2 In the method’s tree hierarchy, click on a complex type or array argument. 
The right-most pane shows the XML code as a single string. Select the XML 
option. 

 3 To edit the XML code for that entry, click Edit. VuGen may issue a warning 
indicating that only changes to element values and the number of array 
elements will be saved—not changes in the XML elements themselves.
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 4 Click OK. The XML Editor dialog box opens.

 5 In the XML Tree view, double-click on a node to open its property dialog 
box. Edit the value as required. Click OK to save the new values.

 6 To edit the code in text mode, click the Text View tab. Edit the XML code 
manually. Click OK to save the changes.

 7 To import a previously saved XML file, click Import and specify the file’s 
location. Edit the file in the XML Editor dialog box.
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 8 To save your XML data to a file so it can be used for other tests, click Export 
and specify a location.

Saving and Copying the SOAP Response
In addition to saving the input argument values as an XML type parameter, 
you can also save the SOAP response to a parameter or copy it for use within 
an editor.

To save the SOAP response to a parameter:

 1 Switch to the SOAP Snapshot tab and select the parent or child element 
whose value you want to parameterize.

 2 Select Save XML in parameter from the right-click menu. The XML 
Parameter Properties dialog box displays the properties of the selected XML 
element.

 3 Specify a name for the XML parameter, and click OK.

To copy the XML structure for use within another editor, choose Copy XML 
from the right-click menu.
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Using Web Service Output Parameters

In certain cases, you may need to use the result of one Web Service call as 
input for another. To do this, you save the result to an output parameter and 
reference it at the required point. 

In the following example, the output argument is saved to a parameter 
My_Array_String.
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The script shows the saved output parameter as a result argument:

For information on saving results to parameters, see “Saving Output 
Parameters” on page 117. 

After you save an output parameter, it becomes available for parameter 
substitution or for other referencing, such as evaluating it and printing its 
value. In the following example, the saved output parameter, 
My_Array_String, is used as an input argument for a subsequent Web Service 
call.

web_service_call( "StepName=EchoStringArray_101",
"SOAPMethod=ExtendedECHO_doc_literal.ExtendedECHO_doc_literalSoap.EchoStri
ngArray",

"ResponseParam=response",
"Service=ExtendedECHO_doc_literal",
"Snapshot=t1169994766.inf",
BEGIN_ARGUMENTS,
"xml:strString=<strString><string></string></strString>",
END_ARGUMENTS,
BEGIN_RESULT,
"EchoStringArrayResult/*[1]=My_Array_String",
END_RESULT,
LAST);
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For information on using saved output parameters, see “Using Saved 
Parameters for Input” on page 118. 

Saving Output Parameters
You can save multiple result arguments to parameters through the Properties 
dialog box, or by manually editing them in the script code. 

You can also save result parameters from XML actions, and use them as 
input arguments. For example, if you save the result parameter for 
lr_xml_insert, you can reference the saved parameter in a subsequent Web 
Service call. For more information, see “Using Result Parameters” in Volume 
I-Using VuGen.

To save an output parameter:

 1 View the script in Tree view. 

Make sure you are in Tree view. Otherwise, choose View > Tree view.

 2 Check for a Service.

Click the Manage Services button to verify that you have imported at least 
one service. To import a new service, click Import in the Service 
Management dialog box.

 3 View the steps’s properties.

For a new Web Service call, click Add Service Call. 

For an existing Web Service call, double-click on the step or click the 
Properties tab in the right pane. 

 4 Select the output argument. 

In the left pane, select the output argument whose value you want to save to 
a parameter.

 5 Enable the saving of the output parameter.

In the right pane, select Save returned value in parameter. Accept the 
default name or specify a custom name.
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Using Saved Parameters for Input
After saving output parameters, you can use them in subsequent Web 
Service calls.

You can also use saved result parameters from XML actions as input. For 
example, if you saved the result parameter for lr_xml_insert, you can 
reference it in a subsequent Web Service call. For more information, see 
“Using Result Parameters” in Volume I-Using VuGen.

To use a saved parameter for input:

 1 View the steps’s properties in Tree view.

For a new Web Service call, click Add Service Call. 

For an existing Web Service call, double-click on the step or click the 
Properties tab in the right pane. 

 2 Select the input argument. 

In the left pane, select the input argument whose value you want to replace 
with a previously saved output parameter.

 3 Open the Select Parameter dialog box.

In the right pane, select Value, and click on the ABC icon adjacent to the 
Value box. The Select or Create Parameter box opens.

 4 Choose an output parameter.

Select the desired output parameter from the drop-down list and click OK.

To specify an input parameter in Script view, select the value you want to 
replace and select Use Existing Parameters from the right-click menu. 
Choose one of the available parameters.
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Note: If you modify an output parameter name in Script view, it will not be 
updated in the parameter list until you switch to Tree view.

Setting Checkpoints

In functional testing, one of the most important tasks is to check the 
response from the server to confirm that your test performed the actions 
correctly. In Web Services, the response can contain several arguments, each 
containing several data items.

VuGen’s Checkpoint tab is a central point for defining the required checks 
for your test.
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Before running the test, you set expected values for the arguments. You can 
load a set of expected values as they were captured either during recording 
or during replay. This is useful when you have many argument values—
instead of manually entering values, you automatically load them. 

After the test run, you can view the Replay log or the test results and 
determine if the results were as expected.

VuGen automatically displays all of the method’s arguments with a check 
box. To include a checkpoint in the test, you select its check box. You can 
load the recorded or replay values (if they exist) and then select only those 
that you want to check.

An optional Stop on Validation Error flag indicates whether or the step fails 
in case of a checkpoint failure.

In the script, VuGen adds a checkpoint argument for each row that you 
select in the Checkpoint tab.

VuGen also provides support for standard XPATH validations using 
lr_xml_find. For verification of the SOAP body (or SOAP headers with the 
.NET toolkit), you can use checkpoints. However, when using a toolkit other 
than .NET, checkpoints are not supported for SOAP headers—instead use 
lr_xml_find. For more information, refer to the Online Function Reference 
(Help > Function Reference).

 web_service_call("StepName=Add_2",
"SOAPMethod=Calc.CalcSoapPort.Add",

…
BEGIN_CHECKPOINTS,
 StopOnValidationError=1,
 CHECKPOINT, "XPATH=Result[1]", "Value=13",
 CHECKPOINT, "XPATH=AddResult", "Expression=Hel*?",
END_CHECKPOINTS,
LAST);
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Expected Value Types

During replay, VuGen creates a set of expected values for the purpose of 
validation. These are listed in the upper section, Basic Validation. 

In addition to the basic validation, you can define Advanced Validation to 
validate a checkpoint on non-leaf nodes or to define expected values in 
terms of a regular expression.

In Basic validation, VuGen looks for exact matches of the value in the 
Expected value column.

In Advanced validation, VuGen looks for either exact matches or those 
based on regular expressions.

You define the advanced validation values by entering an XPATH query in 
the Advanced Validation section. To obtain the initial XPATH expression, 
you can copy it from the basic validation (Copy Row XPATH from the right-
click menu) and paste it in the Advanced Validation section. 

Note that when you choose a non-leaf node, you need to supply all of the 
XML beneath the node.
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You can define both basic and advanced validations for the same step.

In the Vuser script, VuGen indicates an exact match by Value= and a regular 
expression with Expression=:

To set a basic checkpoint:

 1 In Tree view (View > Tree view), select a step in the left pane.

 2 Select the Checkpoint tab.

 3 To check for exact matches, specify expected values in the upper Basic 
Validation section: 

➤ To manually specify expected values, enter the values in the Expected 
Values column. 

➤ To load data from a recording or replay session, click the Record or 
Replay buttons in the Load From section. VuGen fills in the data as it was 
captured during record or replay.

 4 Select the check boxes in the Validate column for all the results you want to 
check. To select all Basic validation checkpoints, click Select All. To clear all 
of the selections, click Unselect All.

 5 Click Delete All in the upper section to clear all of the expected values.

 6 Select Stop On Validation Error to instruct the Vusers to fail the step when 
the replay did not generate the expected values.

 7 Run the script and view the Replay log to determine if the service returned 
the expected values. It is recommended that you enable the Extended log in 
the run-time settings. If there is no match, the Replay log issues an 
appropriate message:

 8 Open the Test Results (View > Test Results) to see a detailed report of the 
validation. For more information about viewing test results, see below.

BEGIN_CHECKPOINTS,
 CHECKPOINT, "XPATH=/AddResult[1]", "Value=50"
 CHECKPOINT, "XPATH=AddResult", "Expression=Hel*?",

END_CHECKPOINTS,

Action.c(14): Failure: checkpoint "/AddResult[1]" expected value="3" actual result="15"
Action.c(14): Error: Web service call "Add" 1/1 checks failed
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To set an advanced checkpoint:

 1 In Tree view (View > Tree view), select a step in the left pane.

 2 Select the Checkpoint tab.

 3 Provide expected values in the bottom section, Advanced Validation: 

➤ An XPATH Query expression describing the criteria of the search. You can 
copy XPATH expressions from the Basic Validation section in the upper 
window. To copy an XPATH expression, select the text in the Schema 
column, and choose Copy Row XPath from the right-click menu. In the 
Advanced Validation section, double-click in the next available row and 
choose Paste from the right-click menu. Modify the expression as 
required.

➤ A Validation Method: Choose Exact Phrase or Regular Expression from 
the dropdown list.

➤ The Expected Value, either in the form of an exact value or a regular 
expression.

 4 To delete an advanced checkpoint, select it and click Delete Row in the 
Advanced Validation section. 

 5 To delete all of the advanced checkpoints, click the Delete All button in the 
Advanced Validation section.

 6 Select Stop On Validation Error to instruct the Vusers to stop when the 
replay did not generate the expected values.

 7 Run the script and view the Replay log, which contains information on 
whether or not the match was found.

 8 Open the Test Results (View > Test Results) to see a detailed report of the 
validation. For more information about viewing test results, see “Viewing 
Web Services Reports” on page 163.
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Parameterizing Checkpoints

You can parameterize the expected values for Checkpoint leaf nodes. This 
allows the Vuser to use different expected values for multiple iterations.

To replace the expected value with a parameter:

 1 Choose Vuser > Parameter List to open the Parameter List dialog box.

 2 Create a new parameter, selecting the appropriate type: File, Table and so 
forth. For more information, see “Working with VuGen Parameters” in 
Volume I-Using VuGen.

 3 In Script view, locate the CHECKPOINT section and replace the actual values 
with the parameter name you created earlier.

Viewing Checkpoint Results

After running a script, you can view the checkpoint results to see their 
status—Passed or Failed, and the reason for the failure.

To view the test results for the checkpoints: 

 1 Choose View > Test Results to open the Test Results window.

 2 In the left pane, expand the step whose checkpoint you want to view.

BEGIN_CHECKPOINTS,
 CHECKPOINT, "XPATH=EchoMixResult[1]", "Value=MyParam"

END_CHECKPOINTS,
124



Chapter 7 • Working in the Web Service Call View
 3 Click on the Checkpoint step in the left pane. The right pane shows the 
details about the test run.
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The lower pane provides detailed information about the checkpoint:

➤ The number of successful and failed checkpoints (for multiple iterations)

➤ The expected values and actual results

➤ The type of evaluation (exact phrase or regular expression) 

➤ The response argument tree

For more information about viewing test results, see “Viewing Test Results” 
in Volume I-Using VuGen.
126



8
Setting Advanced Properties for Web 
Service Scripts

Advanced users can customize Web Service calls by setting the transport 
layer properties and security policies, and by writing user handlers to define 
the behavior of the Web Service calls.

This chapter includes:

 ➤  About Setting the Transport Layer, Security and User Handlers on page 127

 ➤  Configuring the Transport Layer on page 128

 ➤  Creating Web Service Security Policies on page 141

 ➤  Setting SAML Options on page 147

 ➤  Customizing Web Service Script Behavior on page 150

The following information only applies to Web Services and SOA Vuser 
scripts.

About Setting the Transport Layer, Security and User 
Handlers

You can configure your script with advanced capabilities to customize its 
behavior. 

Using VuGen, you can specify a transport method, such as JMS, for your 
Web Service calls. You can also set security policies for your Web Service, 
including standard security with security tokens, SAML security, and JMS.
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With user handlers, you can process SOAP requests and responses and assign 
them a custom behavior. For more information, see “Customizing Web 
Service Script Behavior” on page 150.

Configuring the Transport Layer

VuGen allows you to configure the transport layer for your services. The 
transport layer lets you indicate how to transport messages to and from the 
server—HTTP/HTTPS or JMS (Java Message Service). To learn more about 
HTTP/HTTPS, see below. For more information about using JMS transport, 
see “Understanding JMS” on page 137.

HTTP/HTTPS

HTTP is used for sending requests from a Web client, usually a browser, to a 
Web server. HTTP is also used to return the Web content from the server 
back to the client.

HTTPS handles secure communication between a client and server. 
Typically, it handles credit card transactions and other sensitive data.

If you are working with HTTP or HTTPS transport, you can use 
asynchronous calls and WS-Addressing.

Asynchronous Messages 
In synchronous messaging, the replay engine blocks script execution until 
the server sends its response. In asynchronous mode, the replay engine 
executes the script without waiting for server’s response for previous 
messages. 

VuGen supports both types of messaging. 
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In Script view, VuGen indicates asynchronous messaging with the added 
parameter, AsyncEvent.

To enable asynchronous messaging in Tree view, select the Transport Layer 
Configuration node in the Step Properties tab.

web_service_call("StepName=EchoString_101",
"SOAPMethod=EchoRpcEncoded.EchoSoap.EchoString",
"ResponseParam=response1",
"Service=ExtendedECHO_rpc_encoded",
"AsyncEvent=event_1",
"Snapshot=t1157371707.inf",
BEGIN_ARGUMENTS,
"sec=7",
"strString=mytext",
END_ARGUMENTS,
BEGIN_RESULT,
"EchoStringResult=first_call",
END_RESULT,
LAST);
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Select the Add Async support option and specify an event.

When working with asynchronous messaging, you perform synchronization 
within your script using the Web Service Wait for Event step or the 
web_service_wait_for_event function in Script view. This function 
instructs the Vuser to wait for the response of previous asynchronous service 
requests. The listener blocks the execution of the service until the server 
responds.

When adding a Web Service Wait for Event step:

➤ You list all of the asynchronous events for which you want to wait.

➤ You then specify whether you want the Vuser to wait for all events to receive 
a response or just one of them. If you specified ANY, then during replay the 
function returns the name of the first event to receive a response. If you 
specified ALL, any one of the event names is returned. 
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➤ You provide a timeout in milliseconds. If no events receive responses in the 
specified timeout, web_service_wait_for_event returns a NULL.

In the following example, the web_service_wait_for_event call waits forty 
milliseconds for any of the events: event_1, event_2, or event_3.

When running a script with asynchronous messaging, the Replay log 
provides information about the events and the input and output arguments.

For additional information about the web_service_wait_for_event 
function, see the Online Function Reference (Help > Function Reference or 
click F1 on the function).

You can also indicate the location you want the service to reply to when it 
detects an event, using WS-Addressing. For more information, see the 
section below.

WS-Addressing
WS-Addressing is a specification that defines a standard for allowing Web 
Services to communicate addressing information. It identifies Web service 
endpoints in order to secure end-to-end endpoint identification in 
messages. This allows you to transmit messages through networks that have 
additional processing nodes such as endpoint managers, firewalls, and 
gateways. WS-Addressing supports Web Services messages traveling over 
both synchronous or asynchronous transports.

The WS-Addressing specification requires a WSAReplyTo address—the 
location to which you want the service to reply.

web_service_wait_for_event("StepName=First_Wait", 
"Quantifier=ANY", 
"Timeout=40", 
BEGIN_EVENTS, 
"event_1", 
"event_2", 
"event_3", 
END_EVENTS, 
LAST);
131



Chapter 8 • Setting Advanced Properties for Web Service Scripts
An optional WSAAction argument allows you to define a SOAP action for 
instances where transport layers fails to send a message.

The following example illustrates a typical SOAP message using WS-
Addressing, implemented by VuGen in the background.

<S:Envelope xmlns:S="http://www.w3.org/2003/05/soap-envelope"
                xmlns:wsa="http://www.w3.org/2004/12/addressing">
    <S:Header>
        <wsa:MessageID>
            http://example.com/SomeUniqueMessageIdString
        </wsa:MessageID>
        <wsa:ReplyTo>
            <wsa:Address>http://myClient.example/someClientUser</wsa:Address>
        </wsa:ReplyTo>
<wsa:Address>http://myserver.example/DemoErrorHandler</wsa:Address>
        </wsa:FaultTo>
        <wsa:To>http://myserver.example/DemoServiceURI</wsa:To>
        <wsa:Action>http://myserver.example/DoAction</wsa:Action>
    </S:Header>
    <S:Body>
         <!-- Body of SOAP request message -->
    </S:Body>
</S:Envelope>
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To create a SOAP request using WS-Addressing in VuGen, you specify a 
WSAReplyTo entry in the Transport Layer Configuration’s node under the 
Step Properties tab.

For the WSAReplyTo argument, you can specify an IP address or autotdetect 
to instruct the service to detect the host name of the machine. This is useful 
when running the same script on several different machines.
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In the following example, the server responds to the interface 
212.199.95.138 when it detects Event_1.

WS-Addressing calling may be issued in both asynchronous and 
synchronous modes. To use WS-Addressing in synchronous mode, you leave 
the Async Event box empty in the Transport Layer options. In Script view, 
you remove the AsyncEvent argument. This instructs the replay engine to 
block script execution until the complete response is received from the 
server.

web_service_call("StepName=Add_101",
"SOAPMethod=Calc.CalcSoap.Add",
"ResponseParam=response",
"AsyncEvent=Event_1",

                "WSAReplyTo=212.199.95.138",
"WSDL=http://lab1/WebServices/CalcWS/Calc.asmx?wsdl",
"UseWSDLCopy=1",
"Snapshot=t1153825715.inf",
BEGIN_ARGUMENTS,

"first=1",
"second=2",

END_ARGUMENTS,
BEGIN_RESULT,

"AddResult=Param_AddResult1",
END_RESULT,
LAST);
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To add support for asynchronous messages and WS-Addressing:

 1 For a new Web Service call, select the Transport Layer Configuration node. 
For an existing Web Service call, select the step in Tree view, and select the 
Step Properties tab. Select the Transport Layer Configuration node.

 2 To mark the Web Service call as an asynchronous message: 

➤ Select the Add Async support option. This is only enabled for HTTP/S 
type transport.

➤ Provide an event name in the Async Event box. This can be an arbitrary 
name.

 3 In the WS-A Reply to box, enter an IP address or autodetect to use the 
current host. The server will reply to the specified location when the event 
occurs.
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 4 For asynchronous events, choose Insert > New Step and add a Web Service 
Wait For Event step after the Web Service call step.

 5 Specify a step name, quantifier, and timeout. To add an event name, click 
Add. The Web Service will wait for the specified event before responding.
 

 6 Use the Edit, Move Up, and Move Down buttons to manipulate the events.

 7 Click OK.
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Understanding JMS
JMS implements point-to-point messaging by defining a message queue as 
the target for a message. Multiple senders send messages to a message queue, 
and the receiver gets the message from the queue. VuGen supports the 
sending and receiving JMS messages to a queue from a Web Service call and 
by using JMS script functions.

Before you can send messages over JMS transport, you need to configure 
several items that describe the transport:

➤ JNDI initial context factory. The class name of the factory class that creates 
an initial context which will be used to locate the JMS resources such as JMS 
connection factory or JMS queue.

➤ JNDI provider. The URL of the service provider which will be used to locate 
the JMS resources such as JMS connection factory or JMS queue.

➤ JMS connection factory. The JNDI name of the JMS connection factory.

In addition, VuGen lets you set a timeout for received messages and the 
number of JMS connection per process. 

You can configure all of these settings through the JMS run-time settings, as 
described in “Setting Web Services JMS Run-Time Settings” on page 161.

JMS Script Functions

VuGen uses its JMS API functions to implement the JMS transport. Each 
function begins with a jms prefix. For example, 
jms_receive_message_queue Receives a message from a queue.

For additional information about the JMS functions, see the Online Function 
Reference (Help > Function Reference or click F1 on the function).

Using JMS as a Transport Layer

The JMS transport for Web services allows users to send SOAP messages 
using a JMS transport instead of the common HTTP transport.
137



Chapter 8 • Setting Advanced Properties for Web Service Scripts
A Web Service can:

➤ Import a WSDL and then specify JMS instead of HTTP as a transport layer.

➤ Record SOAP messages using HTTP, and use the recorded script for sending 
the messages through JMS transport.

➤ Send and/or receive general JMS messages to a JMS destination (queue) from 
the Web Services script.

The basic steps in transmitting messages over JMS protocol are:

 1 Import a WSDL file. For more information, see “Importing Services” on 
page 43.

 2 Setting the queue information, as described below.

 3 Configuring the JMS run-time settings before running the script, as 
described in “Setting Web Services JMS Run-Time Settings” on page 161.
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For each Web Service call step, you can specify JMS Transport and the 
Request and Response queues.

To specify JMS transport information:

 1 In Tree view, select the Step Properties tab and select the Transport Layer 
Configuration node.

 2 Select the JMS Transport option.

 3 Specify the names of the Request Queue and Response Queue. You can use 
the same queue for the request and response. The Response Queue box is 
disabled for one-way functions in Axis toolkits.
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 4 To manually set additional transport information or get and set properties, 
add one of the JMS functions. Choose Insert > New Step and expand the 
JMS Functions node.

The current solution is a replay only solution and does not allow recording 
JMS messages sent between the client and server. VuGen only supports 
synchronized calls.

For additional information about these functions, see the Online Function 
Reference (Help > Function Reference or click F1 on the function).

JMS Message Types

JMS can be sent with several message body formats. Two common formats 
are TextMessage and BytesMessage.

Service Test attempts to resolve the desired format based on the message’s 
content type. If the content type is text/*, it sends the message in 
TextMessage format. Otherwise, it sends it in BytesMessage format.

To override the default behavior, use a jms_set_general_property function 
before sending the message. Set the JMS_MESSAGE_TYPE property to 
TextMessage, BytesMessage, or Default. For Example:

jms_set_general_property("step1","JMS_MESSAGE_TYPE","BytesMessage");

For more information, see the Online Function Reference.
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Creating Web Service Security Policies

When building Web Service applications, there is a challenge in building 
scalable applications that are secure. You can secure Web Services by having 
the message sent over a secure transport, such as Secure Sockets Layer (SSL), 
but that is limited to point-to-point communication.

To allow you to send your messages securely, VuGen supports several 
security mechanisms: Security Tokens and SAML.

Note: If your WSDL is located in a secure location, you must provide the 
security information through the Service Management dialog box. For more 
information, see “Specifying WSDL Connection Settings” on page 47.

For more information on tokens, see below.

For more information on SAML, see “Setting SAML Options” on page 147.

Security Tokens and Encryption
The WS-Security specification lets you place security credentials in the 
actual SOAP message. You accomplish this by instructing a client to obtain 
security credentials from a source that is trusted by both the sender and 
receiver. When a SOAP message sender sends a request, those security 
credentials, known as security tokens, are placed in the SOAP message. 
When the Web server receives the SOAP request, it does not need to send 
additional requests to verify the integrity of the sender. The server verifies 
that the credentials are authentic before letting the Web Service execute the 
application. By not having to go back to the source of the credentials, this 
significantly improves the application’s scalability.

To further secure Web Services, it is common to use digital signatures or 
encryption for the SOAP messages. Digitally signing a SOAP message, 
verifies that the message has not been altered during transmission. 
Encrypting a SOAP message helps secure a Web Service by making it difficult 
for anyone other than the intended recipient, to read the contents of the 
message.
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The Web Services security mechanism associates security tokens with 
messages. This mechanism supports several security token formats to 
accommodate a variety of authentication requirements. For example, a 
client might need to provide a proof of identity or a security certificate.

To support WS-Security, VuGen allows you to create security tokens for your 
script. You can create multiple tokens and set their properties. After creating 
a token, you use it to sign or encrypt a SOAP message.

In certain instances, you do not send the token explicitly—you use the 
token for the purpose of signatures or encryption, without including the 
actual token in the SOAP envelope header. Using the Add option, you can 
indicate whether to send the actual token explicitly. 

The available tokens are Username and Password, X.509 Certificate, 
Kerberos Ticket, Kerberos2 Ticket, Security Context Token, and Derived 
Token. The information you need to provide differs for each token.

➤ User Name and Password. The User Name and Password token contains 
user identification information for the purpose of authentication: User 
Name and Password. 

You can also specify Password Options, indicating how to send the password 
to the server for authentication: SendPlainText, SendNone, or SendHashed. 

➤ X.509 Certificate. This security token is a token based on an X.509 
certificate. To obtain a certificate, you can either purchase it from a 
certificate authority, such as VeriSign, Inc. or set up your own certificate 
service to issue a certificate. Most Windows servers support the public key 
infrastructure (PKI) which enable you to create certificates. You can then 
have it signed by a certificate authority or use an unsigned certificate.

When you add an X.509 token to the Vuser script, you specify the Logical 
Name, Store Name, Key identifier type, Key identifier value, and Store 
Location arguments.
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➤ Kerberos Ticket/Kerberos2 Ticket. (for Windows 2003 or XP SP1 and later) 
The Kerberos protocol is used to mutually authenticate users and services on 
an open and unsecured network. Using shared secret keys, it encrypts and 
signs user credentials. A third party, known as a KDC (Kerberos Key 
Distribution Center), authenticates the credentials. After authentication, the 
user may request a service ticket to access one or more services on the 
network. The ticket includes the encrypted, authenticated identity of the 
user. The tickets are obtained using the current user’s credentials.

VuGen supports tokens based on both Kerberos and Kerberos2 security 
tokens. The primary difference between the Kereberos and Kerberos2 tokens, 
is that Kerberos2 uses the Security Support Provider Interface (SSPI), so it 
does not require elevated privileges to impersonate the client's identity. In 
addition, the Kerberos2 security token can be used to secure SOAP messages 
sent to a Web Service running in a Web farm.

When you add a Kerberos token to the Vuser script, you specify a Logical 
Name for the token along with the Host and Domain names of the Web 
Services machine.

➤ Security Context Token. These tokens are security tokens that can be used 
repeatedly until they expire. SOAP message senders can use security context 
tokens to sign and/or encrypt a series of SOAP messages, known as a 
conversation, between a SOAP message sender and the target Web Service. 
The main benefits of this type of token are:

➤ As long as the security context token has not expired, the SOAP message 
sender can use the same security context token to sign and/or encrypt 
the SOAP messages sent to the target Web Service. 

➤ Security context tokens are based on a symmetric key, making them more 
efficient at digitally signing or encrypting a SOAP message than an 
asymmetric key. 

➤ Security context tokens can be requested from one security token service 
by sending a SOAP message to another security token service.

When you add a Security Context token to the Vuser script, you specify 
values for the Logical Name, Base Token, Issuer Token, End Point URI, and 
Add applies to arguments.
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➤ Derived Token. The Derived token is a token based on another existing 
token, excluding X.509 for which derivation is not supported. You need to 
specify a Logical Name and the Derived From token. If you remove the 
original token, then the derived token will no longer be available. Note that 
you cannot use a Derived type of token in a recursive manner.

For more information about configuring tokens, refer to the Online Function 
Reference (Help > Function Reference).

When you add a Web Services Set Security step to your script, VuGenadds a 
web_service_set_security function that contains arguments with the 
tokens, message signatures, and encryption that you defined in the security 
properties.

Note that parameterization is not supported for the following arguments: 
Token Type, Logical Name, Base Token, Issuer Token or Derive From 
arguments.

Working with Message Signatures and Encrypted Data

When you add a security token to a SOAP message, it is added to the SOAP 
message in the form of an XML element in the WS-Security SOAP header. 

The message, however, is exposed and therefore requires additional security. 
This is especially true when the credentials, including the password, are sent 
in plain text as it is with role-based security.

The two methods used to secure the data are digital signatures and 
encryption. 

➤ Digital Signatures. Digital Signatures are used by message recipients to verify 
that messages were not altered since their signing. The digital signature is 
usually in the form of XML within the SOAP message. The recipient checks 
the signature to make sure it is valid. Certain environments, such as WSE, 
automatically verify the signature on the SOAP recipient's computer. 

web_service_set_security(
SECURITY_TOKEN, "Type=USERNAME", "TokenName=mytoekn1", 
"UserName=bob", "Password=123", "PasswordOptions=SendNone", "Add=True", 

LAST);
144



Chapter 8 • Setting Advanced Properties for Web Service Scripts
➤ Encryption. Although the XML digital signature does offer a mechanism for 
verifying that the message has not been altered since it was signed, it does 
not encrypt the SOAP message—the message is still plain text in XML 
format. To secure the message in order that it should not be exposed, you 
encrypt it, making it difficult for an intruder to view and obtain a user 
passwords.

VuGen allows you to supply information about the encryption and message 
signatures.

Note that parameterization is not supported for message signatures and 
encryption arguments. For more information on adding message signatures 
and encryption to your script, see below.

Setting Web Services Security
While developing a script, you can add security to your Web Service calls 
using standard WS-Security.

To add Web Service security:

 1 Click at the appropriate location in your script. To apply the security to the 
entire script, place the cursor at the beginning of the script.

 2 Choose Insert > New Step to open the Add Step dialog box.
145



Chapter 8 • Setting Advanced Properties for Web Service Scripts
 3 Select Web Services Set Security and click OK. The Set Security Properties 
box opens.

 4 Click Add to add a new token. The Add Token dialog box opens.
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 5 Choose a token type. For information about the token types, see “Security 
Tokens and Encryption” on page 141.

In the Logical Name box, assign an arbitrary name for the token to be used 
by VuGen in identifying the token.

Add any relevant information, such as User Name and Password for the 
User Name and Password type token.

To send the token explicitly in the SOAP envelope header, choose True. To 
exclude the token from the SOAP envelope header, choose False.

 6 To specify a time for which the message packet is considered valid, select 
Time To Live and specify the time in seconds. 

 7 Click OK. VuGen inserts a Web Services Set Security step at the location of 
the cursor.

Setting SAML Options

VuGen supports SAML (Security Assertion Markup Language) for Web 
Services. SAML is an XML standard for exchanging security-related 
information, called assertions, between business partners over the Internet. 
The assertions can include attribute statements, authentication, decision 
statements, and authorization decision statements.

SAML uses brokered authentication with a security token issued by STS 
(Security Token Service). The STS is trusted by the client and the Web Service 
to provide interoperable security tokens. SAML tokens are important for 
Web Service security because they provide cross-platform interoperability 
and a means of exchanging information between clients and services that 
do not reside within a single security domain.

You can set the SAML settings for an entire script or part of the script. To set 
SAML security, add a Web Services Set Security SAML step. To remove the 
security, insert a Web Services Cancel Security SAML step. 
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Note: You cannot apply SAML security and the standard Web Service (a Web 
Service Set Security step) security to the same step. To cancel Web Service 
security, insert a web_service_cancel_security function.

Policy Files

SAML policy files follow the WSE 3.0 standard and define the attribute 
values for the SAML security. By default, VuGen uses the samlPolicy.config 
file located in the installation’s dat folder.

When entering SAML security information, you can enter it manually in the 
properties dialog box, or you can refer to a policy file containing all of the 
security information. You can create your own policy file based on 
samlPolicy.config.

You can modify the policy file to include values for the security parameters, 
such as username and certificate information. When adding a SAML security 
step to your script, if you explicitly specify values for the security arguments, 
they override the values in the policy file.

If you make changes to the default policy file, it is recommended that you 
copy the new policy file to your script’s folder. Make sure to save custom 
policy files with a .config extension to insure that they remain with the 
script, even when running it on other machines or calling it from the 
LoadRunner Controller. 

To learn more about the SAML policy files, refer to the SAML STS example 
on the MSDN Web site. If you want to emulate SAML Federation behavior, 
copy the samlFederationPolicy.config file from the data folder to your 
script’s folder, and specify it as the policy file.

To add SAML security:

 1 Click at the appropriate location in your script. To apply the security to the 
entire script, place the cursor at the beginning of the script.
148



Chapter 8 • Setting Advanced Properties for Web Service Scripts
 2 Choose Insert > New Step to open the Add Step dialog box.

 3 To add SAML security, choose Web Services Set Security SAML.

Enter the desired information. If you enter values into this dialog box, they 
override any values that were set in the policy file. You must provide an 
Issuer URL, also known as the STS URL.

To use a different policy file, specify it in the Policy File box. Specify a full 
path, or a file location relative to the script’s path.
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 4 To remove the security, choose Web Services Cancel Security SAML. The 
security is cancelled from that point onward.

For additional information about these functions, see the Online Function 
Reference (Help > Function Reference or click F1 on the function).

Customizing Web Service Script Behavior

VuGen provides several advanced capabilities that allow you to customize 
the way your script behaves. These capabilities are:

➤ User Handlers

➤ .NET Filters 

➤ Configuration Files

User Handlers
VuGen allows you to call user handlers to process SOAP requests and 
responses. Using the handlers, you can retrieve and modify the SOAP 
envelope, get or set parameters, and issue log messages. You can also use the 
handler mechanism to add security features, message compression, and 
filters.

You can implement a user handler in several ways:

➤ Defining a Handler Function in a Script

➤ Creating a Custom User Handler as a DLL

Defining a Handler Function in a Script

For basic implementation of a user handler, you define a user handler 
function within your Vuser script:

int MyScriptFunction(const char* pArgs, int isRequest)
{
…
}
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The pArgs argument contains the string that is specified in UserHandlerArgs 
argument of web_service_call function. For more information, see the 
Online Function Reference (Help > Function Reference).

The isRequest argument indicates whether the function is being called 
during processing of a Request (1) or Response (0) SOAP envelope. 

The content of SOAP envelope is passed to a parameter called 
SoapEnvelopeParam for both requests and responses. After the function 
processes the SOAP envelope, make sure to store it in the same parameter 

To call the handler function, specify the function name as a value for the 
UserHandlerFunction argument in the relevant Web Service Call step. 

VuGen recognizes the following return codes for the handler function.

web_service_call(
…
"UserHandlerFunction=MyScriptFunction", 
"UserHandlerArgs=<handler arguments>", 

LAST);

Return Code Description

LR_HANDLER_SUCCEEDED 0 The Handler succeeded, 
but the SOAP envelope 
did not change.

LR_HANDLER_FAILED 1 The Handler failed and 
further processing should 
be stopped.

LR_HANDLER_SUCCEEDED_AND_MODIFIED 2 The Handler succeeded 
and the updated SOAP 
envelope is stored in 
SoapEnvelopeParam.
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In the following example a script handler manipulates the outgoing 
envelope:

//This function processes the SOAP envelope before sending it to the server.
int MyScriptFunction(const char* pArgs, int isRequest) 
{ 
if (isRequest == 1) {

//Get the request that is going to be sent
char* str = lr_eval_string("{SoapEnvelopeParam}");

//Manipulate the string...

//Assign the new request content
lr_save_string(str, "SoapEnvelopeParam");

return LR_HANDLER_SUCCEEDED_AND_MODIFIED;
}
return LR_HANDLER_SUCCEEDED;

} 
Action()
{
//Instruct the web_service_call to use the handler
web_service_call( "StepName=EchoAddr_102",

"SOAPMethod=SpecialCases.SpecialCasesSoap.EchoAddr",
"ResponseParam=response",
"userHandlerFunction=MyScriptFunction",
"Service=SpecialCases",
"Snapshot=t1174304648.inf",
BEGIN_ARGUMENTS,
"xml:addr="

"<addr>"
"<name>abcde</name>"
"<street>abcde</street>"
"<city>abcde</city>"
"<state>abcde</state>"
"<zip>abcde</zip>"

"</addr>",
END_ARGUMENTS,
BEGIN_RESULT,
END_RESULT,
LAST);

return 0;
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Overriding the Transport Layer

You can write a user handler function to override the transport layer. In this 
case, VuGen will not automatically send the SOAP request over HTTP 
transport—instead it follows the transport method indicated in the custom 
handler. 

After you receive a response, you can set the response envelope with the 
command:

To apply an alternate transport layer, specify ReplaceTransport as an value 
for the UserHandlerOrder argument, and define the transport layer in the 
handler function. 

Creating a Custom User Handler as a DLL

You can also define a user handler by creating a DLL file through Visual 
Studio and the handler API. The API header file, LrWsHandlerAPI.h, located 
in the LoadRunner/include folder, contains many in-line comments and 
descriptions.

VuGen provides a sample Visual Studio project that can be used as a 
template for creating a handler. The sample retrieves the request and 
response envelope and saves it to a parameter. This sample is located in the 
LoadRunner/samples/WebServices/SampleWsHandler folder. To use this 
sample, open it in Visual Studio and modify it as required. If you do not 
need to save the request/response to a parameter, you can remove that 
section of the sample.

lr_save_string(someResponseEnvelopeStr, "SoapEnvelopeParam");

web_service_call(
…
"UserHandlerFunction=<Transport HandlerFunction>", 
"UserHandlerArgs=<handler arguments>",
"UserHandlerOrder=ReplaceTransport" 
…

LAST);
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After editing the sample, save it and compile the DLL. When you compile 
the project, Visual Studio places the <user_handler_name>.DLL file in the 
LoadRunner/bin folder. If you compile the project from another location, or 
if you want to copy the DLL from one machine to another, make sure to 
place it in the bin folder.

Configuring the User Handler

You can declare the user handler DLL globally or locally.

To use the handler globally, for all requests in the script, add the following 
section to the default.cfg file located in the script’s folder.

➤ Name. The name of the DLL.

➤ Args. A list of the configuration arguments for the handler. Use the 
GetArguments method to retrieve the arguments in your handler.

➤ Order. The order in which Vusers process the user handler in requests: 
Before Security, After Security, or After Attachments. You can also use this 
argument to override the transport layer, by entering the value Replace 
Transport. 

Note: Setting the UserHandlerFunction property of a web_service_call 
function, overrides the definitions in the .cfg file.

By default, user handlers are processed before the security. For request 
messages, Vusers process the attachments handler after the security handler. 
For responses, Vusers process the handlers in a reversed order. In typical 
cases the order does not matter, so any value is acceptable.

[UserHandler]
Function=<name>
Args=<arguments>
Order=<BeforeSecurity/AfterSecurity/AfterAttachments>
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To override the Transport layer, specify Order=Replace Transport and specify 
the new transport handler. If you implement the transport handler as a 
separate DLL, the HandleRequest function is called, while the 
HandleResponse function is ignored.

To use the handler locally, for a specific request, add the following 
arguments to the web_service_call function:

Note: If you copy the script to another machine, it retains the handler 
information, since it is defined in script’s folder. A user handler defined 
locally for a specific step in the script, overrides the global handler settings 
(defined in the script’s default.cfg file).

Note: The user handler DLL should be accessible to all Load Generator 
machines running scripts that call it. You may, for example, copy it to the 
LoadRunner/bin folder.

Implementing the User Handler

To implement a user handler, you use the entry functions HandleRequest or 
HandleResponse. Both functions have a single parameter, context, whose 
properties you can set in your handler. Use the Get functions to retrieve 
properties, and Set functions to pass information from the replay framework 
to the handlers or between the handlers.

➤ GetEnvelope. Gets the envelope content. For example, example: 
const char * pEnvelope = context->GetEnvelope();

➤ GetEnvelopeLength. Gets the envelope length

UserHandlerName=<name1>
UserHandlerArgs=<args1>
UserHandlerOrder=<BeforeSecurity/AfterSecurity/AfterAttachments/Replace 

Transport>
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➤ SetEnvelope. Sets the envelope content and length. For example:
string str("MySoapEnvelope...");
context->SetEnvelope(str.c_str(), str.length());

➤ SetContentType. Sets a new value for HTTP header content type

➤ LogMessage. Issues a message to the replay log

➤ GetArguments. Gets the configuration arguments defined for the current 
handler in order to pass it to the DLL

➤ GetProperty. Gets a custom property value

➤ SetProperty. Sets a custom property value

For more information, see the comments in the LrWsHandlerAPI.h file 
located in the LoadRunner/include folder.

.NET Filters
If you are familiar with Microsoft's Web Service Enhancements (WSE) 2.0, 
you can create a .NET filter and register it for incoming or outgoing SOAP 
messages. A .NET filter is a class that is derived from 
Microsoft.Web.Services2.SoapInputFilter or 
Microsoft.Web.Services2.SoapOutputFilter. By overriding the 
ProcessMessage function of this class, you can examine and modify the 
envelope’s body and header.

You can apply a .NET filter to your messages using the user handler 
mechanism.

To define the filter globally for the entire script, add the following lines to 
the script’s default.cfg file below.

[UserHandler]
Function=LrWsSoapFilterLoader
Args=<Filters InputFilterClass="class name" InputFilterLib="lib name" 
OutputFilterClass="class name" OutputFilterLib="lib name" />
Order=BeforeSecurity/AfterSecurity/AfterAttachments
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The InputFilterClass parameter indicates the name of your class, and 
InputFilterLib indicates the name of the assembly in which the class resides. 
For example:

Use SoapOutputFilter to examine an outgoing web_service_call request, 
and SoapInputFilter to examine the response from the server. Use 
InputFilterClass and InputFilterLib if your filter is derived from 
SoapInputFilter, or OutputFilterClass and OutputFilterLib if your filter is 
derived from SoapOutputFilter. 

To define the filter for a specific step, add the following arguments to the 
web_service_call function.

Configuration Files
The mmdrv.exe.config file, located in the LoadRunner/bin folder, is a 
standard .NET configuration file, and contains information such as the WSE 
configuration. Use the filter with the Input prefix if your filter is derived 
from SOAP input, or the Output prefix if your filter is derived from SOAP 
output.

web_service_call( 
...
"UserHandlerName=LrWsSoapFilterLoader",
"UserHandlerArgs=<Filters 

InputFilterClass=\"MyFilterNamespace.MyFilterClassName\" 
InputFilterLib=\"MyAssemblyName\" />",

BEGIN_ARGUMENTS,
...
END_ARGUMENTS,
...
);

UserHandlerName= LrWsSoapFilterLoader

UserHandlerArgs=<Filters InputFilterClass=\"class name\" InputFilterLib=\"lib name\" 
OutputFilterClass=\"class name\" OutputFilterLib=\"lib name\" />

UserHandlerOrder=BeforeSecurity/AfterSecurity/AfterAttachments
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If your application has its own configuration file, app.config, you can 
implement it in several ways:

➤ Save it as mmdrv.exe.config, overwriting the existing configuration file. This 
will apply your configuration information to all scripts on the machine. 

➤ Save app.config to the script’s folder. The settings in the app.config file 
override the ones in mmdrv.exe.config. In addition, if you save it to the 
script’s file, it will always be associated with the script, not requiring you to 
copy it over separately to other machines.

In addition, the configuration file contains security information. You can 
configure whether or not to allow unsigned test certificates. 

By default, VuGen allows unsigned certificates to facilitate testing. To 
disallow unsigned certificates, modify the allowTestRoot flag in the 
mmdrv.exe.config file to false.

<security>
<x509 storeLocation=”currentuser” alllowTestRoot=”false”
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Running SOA/Web Services Scripts

After you create an SOA/ Web Services scripts, you run it to make sure it is 
functional. After you run the script, you can view the test results to see 
whether the services performed as expected.

This chapter includes:

 ➤  About Running Web Services Vusers on page 159

 ➤  Setting Web Services JMS Run-Time Settings on page 161

 ➤  Using Web Services Functions on page 163

 ➤  Viewing Web Services Reports on page 163

The following information only applies to Web Services and SOA Vuser 
scripts.

About Running Web Services Vusers

In Tree view, VuGen provides three tabs that allow you to understand and 
examine your script before running it: 

➤ Snapshot. Displays the SOAP requests and responses that occurred during 
record and replay. For more information, see “Viewing Web Services SOAP 
Snapshots” on page 84.

➤ Step Properties. Provides details of each step in your script, along with its 
argument values, attachments, SOAP headers, and transport layer 
configuration. For more information, see Chapter 7, “Working in the Web 
Service Call View.”
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➤ Checkpoint. VLists the verification points that help your determine whether 
or not your service produced correct results. For more information, see 
“Setting Checkpoints” on page 119.

Before running the script, you can set run-time settings that help you 
emulate real users more accurately. These settings include general run-time 
settings (iteration, log, think time, and general information), and Web-
Services related settings (JMS). 

For details, see the following sections or “Configuring Run-Time Settings” in 
Volume I-Using VuGen. 
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Setting Web Services JMS Run-Time Settings

To use JMS as a transport for Web Service calls, there are several resources 
that need to be allocated and configured. Those resources include the JVM, 
JNDI initialization parameters, JMS resources, and timeout values. 

VuGen lets you configure some of those resources through the run-time 
settings.

You can set options in the area of VM (Virtual Machine), the JMS 
connections, and message timeouts.

VM

➤ Use external VM. Enables you to select a VM (Virtual Machine) other than 
the standard one. If you disable this option, Vusers use the JVM provided 
with VuGen.

➤ JVM Home. The location of the external JVM. This should point to the JDK 
home directory, defined by JDK_HOME. VuGen supports JDK 1.4 and above.
161



Chapter 9 • Running SOA/Web Services Scripts
➤ Classpath. The vendor implementation of JMS classes together with any 
other required supporting classes, as determined by the JMS implementation 
vendor

JMS

➤ Additional VM Parameters. Extra parameters to send to the JVM such as 
Xbootclasspath, and any parameters specified by the JVM documentation

➤ JNDI initial context factory. The fully qualified class name of the factory 
class that will create an initial context. Choose a context factory from the 
list or provide your own.

➤ JNDI provider. The URL string of the service provider. For example:
Weblogic - t3://myserver:myport
Websphere - iiop://myserver:myport

➤ JMS connection factory. The JNDI name of the JMS connection factory. You 
can only specify one connection factory per script.

➤ JMS security principal. Identity of the principal (for example the user) for 
the authentication scheme.

➤ JMS security credentials. The principal’s credentials for the authentication 
scheme.

➤ Number of JMS connections per process. The number of JMS connections 
per mdrv process, or Vuser. All Vusers sharing a connection will receive the 
same messages. The default is 1, and the maximum is 50 Vusers. The less 
connections you have per process, the better your performance.

➤ Receive message timeout options. The timeout for received messages. The 
default is No wait.

➤ Indefinite wait. Wait as long as required for the message before 
continuing.

➤ No wait. Do not wait for the Receive message, and return control to 
the script immediately. If there was no message in the queue, the 
operation fails. (default)

➤ Specify the timeout in seconds. Manually specify a timeout value for 
the message. If the timeout expired and no message arrived, the 
operation fails.
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User defined timeout. Specify the amount of seconds to wait for the 
message before timing out. The default is five seconds.

➤ Automatically generate selector. Generates a selector for the response 
message with the correlation ID of the request (No by default). Each JMS 
message sent to the server has a specific ID. Enable this option if you want 
VuGen to automatically create a selector that includes the message ID.

Using Web Services Functions

Web Service functions call services and provide security and 
synchronization. The Web Service functions begin with the web_service 
prefix. For example, web_service_call performs a SOAP request from a 
WSDL and its argument data. 

To perform a SOAP request from raw data, use the soap_request function.

In addition, you can enhance your script with JMS functions, jms_<suffix> 
or XML functions, lr_xml_<suffix>. For more information, refer to the 
Online Function Reference (Help > Function Reference).

Viewing Web Services Reports

After you run a Web Services script, you can view a summary of the test 
results using the Test Results viewer. The viewer also shows the results of the 
checkpoints.

This section describes the Summary report’s Web Services information. 

The Summary report opens automatically after you replay the script. To 
open the report manually, choose View > Test Results.
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The test results are divided into iterations, actions, and steps. When you 
select a node in the left pane, the report shows relevant information about 
that node.

The Results report marks a successful step with a green check mark and a 
failed step with a red X. An iteration is only marked as successful if all of its 
steps and actions have succeeded.

If VuGen cannot interpret the script or if it encounters another type of error, 
the report displays a message in the right pane stating the problem.
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When you click on one of the service’s operations, the report shows 
information about the service, operation, toolkit, testing aspect, and WSDL.
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If you expand an operation’s node further, you can view the actual SOAP 
trafffic for the Request and Response.
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Checkpoint Results

The Results window also shows checkpoint results. It provides a summary 
with a reason for the failure. It also provides the Expected Value and Actual 
Results as well as the argument tree. 

To view the checkpoint details, expand the appropriate step under the 
operation in the left pane and click the Checkpoint node.

For more information about working with the Test Results, see Volume I-
Using VuGen.
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Part III

Working with Java Language Protocols

Working with Java Language Protocols refers to RMI, CORBA, JMS, EJB, and 
Jacada types. For each of the mentioned protocols, refer to the appropriate 
section. This part contains information that applies to all types of Java 
Vusers.
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Recording Java Language Vuser Scripts

VuGen allows you to record applications or applets written in Java, in 
protocols such as CORBA, RMI, EJB, JMS or Jacada. You can also use VuGen’s 
navigation tool to add any method to your script.

This chapter includes:

 ➤  About Recording Java Language Vuser Scripts on page 172

 ➤  Getting Started with Recording on page 173

 ➤  Recording Java Events on page 175

 ➤  Recording a Corba-Java Vuser on page 178

 ➤  Recording RMI over IIOP on page 179

 ➤  Recording an RMI Vuser on page 180

 ➤  Recording a Jacada Vuser on page 180

 ➤  Recording on Windows XP and Windows 2000 Servers on page 181

The following information applies to Java Record Replay Vuser scripts for 
the CORBA-Java, RMI-Java, EJB, JMS and Jacada protocols.
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About Recording Java Language Vuser Scripts

Using VuGen, you can record a Java application or applet. VuGen creates a 
pure Java script enhanced with Vuser API Java-specific functions. After 
recording, you can enhance or modify the script with standard Java code 
using JDK libraries or custom classes. 

After you prepare your script, you run it in standalone mode from VuGen. 
Sun’s standard Java compiler, javac.exe, checks the script for errors and 
compiles it. Once you verify that the script is functional, you incorporate it 
into a LoadRunner scenario or Business Process Monitor profile.

When you create a script through recording and manual enhancements, all 
of the guidelines and limitations associated with Java Vuser scripts apply. In 
addition, any specific classes used in the script must be present on the 
machine executing the Vusers and indicated by the classpath environment 
variable. Refer to Chapter 24, “Programming Java Scripts” for important 
information about function syntax and system configuration.

Before recording a Corba-Java Vuser, verify that your application or applet 
functions properly on the recording machine. 

Ensure that you have properly installed a JDK version from Sun on the 
machine running VuGen—JRE alone is insufficient. You must complete this 
installation before recording a script. Verify that the classpath and path 
environment variables are set according to the JDK installation instructions. 

Note: When you load an applet or application from VuGen during 
recording, it may take several seconds longer than if you were to load it 
independent of VuGen. 
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VuGen provides a tool that enables you to convert a Vuser script created for 
Web, into Java. For more information, see  “Converting Web Vuser Scripts 
into Java” on page 540.

After recording, you can enhance or modify the script with standard Java 
code using JDK libraries or custom classes. 

After you prepare your script, you run it in standalone mode from VuGen. 
Sun’s standard Java compiler, javac.exe, checks the script for errors and 
compiles it. 

You integrate finished scripts into your environment: a LoadRunner 
scenario, Performance Center load test, or Business Process Monitor profile. 
For more information, refer to the HP LoadRunner Controller, Performance 
Center, or HP Business Availability Center documentation. 

Getting Started with Recording

The following procedure outlines how to record Java language Vuser scripts.

 1 Ensure that the recording machine is properly configured.

Make sure that your machine is configured properly for Java before you 
begin recording. For more information, see Chapter 24, “Programming Java 
Scripts” and the Readme file.

 2 Create a new Vuser script.

Select The Java Record/Replay Vuser type.

 3 Specify a Java protocol.

Select a protocol from the recording options. 
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 4 Set the recording parameters and options for the script.

You specify the parameters for your applet or application such as working 
directory and paths. You can also set JVM, serialization, correlation, 
recorder, and debug recording options. For more information, see 
Chapter 12, “Setting Java Recording Options.”

 5 Record typical user actions.

Begin recording a script. Perform typical actions within your applet or 
application. VuGen records your actions and generates a Vuser script. 

 6 Enhance the Vuser script.

Add Vuser API specific functions to enhance the Vuser script. For details, see 
Chapter 24, “Programming Java Scripts.” You can use the built-in Java 
function Navigator. For more information, see “Viewing the Java Methods” 
on page 190. 

 7 Parameterize the Vuser script. 

Replace recorded constants with parameters. You can parameterize complete 
strings or parts of a string. Note that you can define more than one 
parameter for functions with multiple arguments. For details, see “Defining 
Parameters” in Volume I-Using VuGen.

 8 Configure the run-time setting for the script.

Configure run-time settings for the Vuser script. The run-time settings 
define the run-time aspects of the script execution. For the specific run-time 
settings for Java, see Chapter 14, “Configuring Java Run-Time Settings.”

 9 Save and run the Vuser script.

Run the script from VuGen and view the execution log for run-time 
information. For details, see “Running Vuser Scripts in Standalone Mode” in 
Volume I-Using VuGen.

For detailed information on the recording procedure, refer to the specific 
chapter for your Vuser type.
174



Chapter 10 • Recording Java Language Vuser Scripts
Recording Java Events

Ensure that you have properly installed a JDK version from Sun on the 
machine running the Vusers—JRE alone is insufficient.Verify that the 
classpath and path environment variables are set according to the JDK 
installation instructions. Before you replay a Vuser script, verify that your 
environment is configured properly for the JDK and relevant Java classes. 

This is the general procedure for recording a Java session.

To begin recording:

 1 Choose File > New and select JAVA Record Replay from the Java category. 
The Start Recording dialog box opens.

 2 In the Application Type box, select the appropriate value. 

➤ Java Applet to record a Java applet through Sun’s appletviewer. 

➤ Java Application to record a Java application. 

➤ Netscape or IExplore to record an applet within a browser. 

➤ Executable/Batch to record an applet or application that is launched 
from within a batch file or the name of an executable file. 
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➤ Listener to instruct VuGen to wait for the batch file that initializes the 
configuration and runs an application before recording. This mode 
requires you to define the system variable _JAVA_OPTIONS as --
Xrunjdkhook using jdk1.2.x and higher. (For JDK 1.1.x, define the 
environment variable _classload_hook=JDKhook. For JDK 1.6 set 
_JAVA_OPTIONS as -agentlib:jdhook.)

 3 In the Vendor Classes box, select Network if the classes are being 
downloaded from the network. Otherwise, when classes are loaded locally, 
(such as JDK 1.2 and higher), only Local is supported. 

 4 Specify additional parameters according for the following chart:

Note: A Working Directory is necessary only if your application must know 
the location of the working directory (for example, reading property files or 
writing log files). 

 5 Click Options to open the Recording Options dialog box. You select a Java 
protocol: CORBA, RMI, JMS, or Jacada and set other recoridng properties. 
For information about setting recording options, see Chapter 12, “Setting 
Java Recording Options.” 

Application Type Fields to Set

Java Applet Applet Path, Working Directory

Java Application App. Main Class, Working Directory, App. parameters

IExplore IExplore Path, URL

Netscape Netscape Path, URL

Executable/Batch Executable/Batch, Working Directory

Listener N/A
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 6 In the Record into Action box, select the section corresponding to the 
method into which you want to record. The Actions class contains three 
methods: init, action, and end, corresponding to the vuser_init, Actions, and 
vuser_end sections. The following table shows what to include into each 
method, and when each method is executed.

Note: Make sure to import the org.omg.CORBA.ORB function in the 
vuser_init section, so that it will not be repeated for each iteration.

 7 Click OK to begin recording. VuGen starts your application, minimizes itself 
and opens a progress bar and the floating recording toolbar. The progress 
toolbar displays the names of classes as they load. This indicates that the 
Java recording support is active.

 8 Perform typical actions within your application. Use the floating toolbar to 
switch methods during recording.

method within 
Actions class

Record into
action

Used to emulate... Executed during...

init vuser_init a login to a server Initialization

action Actions client activity Running

end vuser_end a log off procedure Finish or Stopped
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 9 After recording the typical user actions, select the vuser_end method from 
the floating toolbar.

Perform the log off procedure. VuGen records the procedure into the 
vuser_end method of the script. 

 10 Click Stop Recording on the Recording toolbar. The VuGen script editor 
displays all the recorded statements.

Click Save  and provide a name for the script. 

Recording a Corba-Java Vuser

For recording a CORBA Java script, you need to set the following options in 
the Recording Options:

➤ JNDI

➤ Use DLL hooking to attach VuGen support
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Using CORBA Application Vendor Classes
Running CORBA applications with JDK1.2 or later, might load the JDK 
internal CORBA classes instead of the specific vendor CORBA classes. To 
force the virtual machine to use the vendor classes, specify the following 
java.exe command-line parameters: 

Recording RMI over IIOP

The Internet Inter-ORB Protocol (IIOP) technology was developed to allow 
implementation of CORBA solutions over the World Wide Web. IIOP lets 
browsers and servers exchange complex objects such as arrays, unlike HTTP, 
which only supports transmission of text. 

RMI over IIOP technology makes it possible for a single client to access 
services which were only accessible from either RMI or CORBA clients in the 
past. This technology is a hybrid of the JRMP protocol used with RMI and 
IIOP used with CORBA. RMI over IIOP allows CORBA clients to access new 
technologies such as Enterprise Java Beans (EJB) among other J2EE 
standards.

Visigenic 3.4
-Dorg.omg.CORBA.ORBClass=com.visigenic.vbroker.orb.ORB 
-Dorg.omg.CORBA.ORBSingletonClass=com.visigenic.vbroker.orb.

ORBSingleton

Visigenic 4.0
-Dorg.omg.CORBA.ORBClass=com.inprise.vbroker.orb.ORB 
-Dorg.omg.CORBA.ORBSingletonClass=com.inprise.vbroker.orb.ORBSingleton

OrbixWeb 3.x
-Dorg.omg.CORBA.ORBClass=IE.Iona.OrbixWeb.CORBA.ORB 
-Dorg.omg.CORBA.ORBSingletonClass=IE.Iona.OrbixWeb.CORBA.

singletonORB

OrbixWeb 2000
-Dorg.omg.CORBA.ORBClass=com.iona.corba.art.artimpl.ORBImpl 
-Dorg.omg.CORBA.ORBSingletonClass=com.iona.corba.art.artimpl.

ORBSingleton
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VuGen provides full support for recording and replaying Vusers using the 
RMI over IIOP protocol. Depending on what you are recording, you can 
utilize VuGen’s RMI recorder to create a script that will optimally emulate a 
real user: 

➤ Pure RMI client. recording a client that uses native JRMP protocol for remote 
invocations

➤ RMI over IIOP client. recording a client application that was compiled using 
the IIOP protocol instead of JRMP (for compatibility with CORBA servers).

Recording an RMI Vuser

Before recording an RMI Vuser, verify that your application or applet 
functions properly on the recording machine. 

Before you record, verify that your environment is configured properly. 
Make sure that the required classes are in the classpath and that you have a 
full installation of JDK. For more information on the required environment 
settings, see Chapter 24, “Programming Java Scripts.” 

Recording a Jacada Vuser

The Jacada Interface Server provides an interface layer for mainframe 
applications. This layer separates the user interface from the application 
logic in order to insulate the organization from changes in standards and 
technologies. Instead of working with green-screen applications, the Jacada 
server converts the environment to a user friendly interface.

VuGen records Jacada’s Java thin-client. To record communication with the 
Jacada server through the HTML thin-client, use the Web HTTP/HTML type 
Vuser. For more information, see Chapter 34, “Creating Web Vuser Scripts.”

Before replay, you must also download the clbase.jar file from the Jacada 
server. All classes used by the Java Vuser must be in the classpath—either set 
in the machine’s CLASSPATH environment variable or in the Classpath Entries 
list in the Classpath node of the Run-Time settings.
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During replay, the Jacada server may return screens from the legacy system, 
in a different order than they appear in the recorded script. This may cause 
an exception in the replay. For information on how to handle these 
exceptions, please contact support.

Recording on Windows XP and Windows 2000 Servers

When recording on Windows XP and Windows 2000 servers, the Java plug-
in may be incompatible with VuGen’s recorder. To insure proper 
functionality, perform the following procedure after the installation of the 
java plug-in, before recording a script. 

To configure your machine for a Corba-Java or Rmi-Java recording:

 1 Open the Java Plug-in from the Control Panel. Choose Start > Settings > 
Control Panel and open the Java Plug-in component. The Basic tab opens.

 2 Clear the Enable Java Plug-In check box and click Apply. Then, reselect the 
Enable Java Plug-In check box and click Apply.
181



Chapter 10 • Recording Java Language Vuser Scripts
 3 Open the Browser tab.

 4 Clear the Microsoft Internet Explorer check box and click Apply. Then, 
reselect the Microsoft Internet Explorer check box and click Apply.
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11
Working with Java Vuser Scripts

VuGen allows you to record applications or applets written in Java. You can 
run the recorded script or enhance it using standard Java library functions 
and Vuser API Java-specific functions.

This chapter includes:

 ➤  Understanding Java Vuser Scripts on page 184

 ➤  Working with Corba-Java on page 185

 ➤  Working with RMI Java on page 187

 ➤  Working with Jacada on page 188

 ➤  Running a Script as Part of a Package on page 189

 ➤  Viewing the Java Methods on page 190

 ➤  Manually Inserting Java Methods on page 192

 ➤  Configuring Script Generation Settings on page 194

 ➤  Java Custom Filters on page 198

The following information applies to Java Record Replay Vuser scripts for 
the CORBA-Java, RMI-Java, EJB, JMS and Jacada protocols.
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Understanding Java Vuser Scripts

When you record a session, VuGen logs all calls to the server and generates a 
script with functions. These functions describe all of your actions within the 
application or applet. The script also contains supplementary code required 
for proper playback, such as property settings, and naming service 
initialization (JNDI).

The recorded script is comprised of three sections: 

➤ Imports

➤ Code

➤ Variables

The Imports section is at the beginning of the script. It contains a reference 
to all the packages required for compiling the script. The Code section 
contains the Actions class and the recorded code within the init, actions, 
and end methods. The Variables section, after the end method, contains all 
the type declarations for the variables used in the code. 

After you finish recording, you can modify the functions in your script, or 
add additional Java or LoadRunner functions to enhance the script. Note 
that if you intend to run Java Vusers as threads, the Java code you add to 
your script must be thread-safe. For details about function syntax, refer to 
the Online Function Reference (Help > Function Reference). In addition, you 
can modify your script to enable it to run as part of another package. For 
more information, see “Compiling and Running a Script as Part of a 
Package” on page 399.
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Working with Corba-Java

CORBA-specific scripts usually have a well-defined pattern. The first section 
contains the ORB initialization and configuration. The next section 
indicates the location of the CORBA objects. The following section consists 
of the server invocations on the CORBA objects. The final section includes a 
shutdown procedure which closes the ORB. Note that pattern is not 
mandatory and that each one of these sections may appear multiple times 
within a script.

In the following segment, the script initializes an ORB instance and 
performs a bind operation to obtain a CORBA object. Note how VuGen 
imports all of the necessary classes. 

The org.omg.CORBA.ORB function makes the connection to ORB. 
Therefore, it should only be called once. When running multiple iterations, 
place this function in the init section. 

import org.omg.CORBA.*;
import org.omg.CORBA.ORB.*;
import lrapi.lr;

public class Actions {

// Public function: init 
public int init() throws Throwable {

// Initialize Orb instance...
MApplet mapplet = new MApplet("http://chaos/classes/", null);
orb = org.omg.CORBA.ORB.init(mapplet, null);

        
// Bind to server...
grid = grid_dsi.gridHelper.bind("gridDSI", "chaos");
return lr.PASS;

}
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In the following section, VuGen recorded the actions performed upon a grid 
CORBA object. 

At the end of the session, VuGen recorded the shutdown of the ORB. The 
variables used throughout the entire recorded code appear after the end 
method and before the Actions class closing curly bracket.

Note that the ORB shutdown statement was customized for this product. 
This customization prevents a single Vuser’s shutdown from shutting down 
all other Vusers.

// Public function: action 
public int action() throws Throwable {
        

grid.width();
grid.height();
grid.set(2, 4, 10);
grid.get(2, 4);

return lr.PASS;
}

// Public function: end 
    public int end() throws Throwable {

        if (lr.get_vuser_id() == -1)
            orb.shutdown();

        return lr.PASS;
}

// Variable section
    org.omg.CORBA.ORB orb;
    grid_dsi.grid grid;
}
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Working with RMI Java

This section describes the elements of the Java Vuser script that are specific to 
RMI Vusers. RMI does not have constructs (as in CORBA)—instead it uses 
Serializable Java objects. The first section performs a Naming Registry 
initialization and configuration. The next section is generated when Java 
objects (both Remote and Serializable) are located and casted. The following 
section consists of the server invocations on the Java objects. In RMI there is 
no specific shutdown section (unlike CORBA). Note that objects might 
appear multiple times within the script.

The following segment locates a naming registry. This is followed by a 
lookup operation to obtain a specific Java object. Once you obtain the 
object, you can work with it and perform invocations such as set_sum, 
increment, and get_sum. The following segment also shows how VuGen 
imports all of the necessary RMI classes. 

Import java.rmi.*;
Import java.rmi.registry.*;

:
:

// Public function: action 
public int action() throws Throwable {
        

_registry = LocateRegistry.getRegistry("localhost",1099);

counter = (Counter)_registry.lookup("Counter1");

counter.set_sum(0);
counter.increment();
counter.increment();
counter.get_sum();

return lr.PASS;
}

:
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When recording RMI Java, your script may contain several calls to 
lr.deserialize, which deserializes all of the relevant objects. The 
lr.deserialize calls are generated because the object being passed to the next 
invocation could not be correlated to a return value from any of the 
previous calls. VuGen therefore records its state and uses lr.deserialize call 
to represent these values during replay. The deserialization is done before 
VuGen passes the objects as parameters to invocations. For more 
information, see “Using the Serialization Mechanism” on page 226.

Working with Jacada

The Actions method of a Java Vuser script using Jacada, has two main parts: 
properties and body. The properties section gets the server properties. 
VuGen then sets the system properties and connects to the Jacada server.

 // Set system properties...
        _properties = new Properties(System.getProperties());
        _properties.put("com.ms.applet.enable.logging", "true");
        System.setProperties(_properties);
        
        _jacadavirtualuser = new cst.client.manager.JacadaVirtualUser();
        
        lr.think_time(4);
        _jacadavirtualuser.connectUsingPorts("localhost", 1100, "LOADTEST", "", "", "");
 …
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The body of the script contains the user actions along with the exception 
handling blocks for the checkFieldValue and checkTableCell methods. 

The checkField method has two arguments: field ID number and expected 
value. The checkTableCell method has four arguments: table ID, row, 
column, and expected value. If there is a mismatch between the expected 
value and the received value, an exception is generated.

By default, the try-catch wrapper blocks are commented out. To use them in 
your script, remove the comment markers. 

In addition to the recorded script, you can add any of the Java Vuser API 
functions. For a list of these functions and information on how to add them 
to your script, see Chapter 24, “Programming Java Scripts.”

Running a Script as Part of a Package

This section is not relevant for Jacada type scripts.

When creating or recording a Java script, you may need to use methods 
from classes in which the method or class is protected. When attempting to 
compile such a script, you receive compilation errors indicating that the 
methods are not accessible. 

 l…
/* 
try {
        _jacadavirtualuser.checkFieldValue(23, "S44452BA");
        }catch(java.lang.Exception e) {
         lr.log_message(e.getMessage());
        }
*/ l…
/* 
try {
_jacadavirtualuser.checkTableCell(41, 0, 0, "");

        }catch(java.lang.Exception e) {
         lr.log_message(e.getMessage());
        }
*/ l… 
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To use the protected methods, add the Vuser to the package of required 
methods. At the beginning of your script, add the following line:

where a.b.c represents a directory hierarchy. VuGen creates the a/b/c 
directory hierarchy in the user directory and compiles the Actions.java file 
there, thus making it part of the package. Note that the package statement 
is not recorded—you need to insert it manually. 

Viewing the Java Methods

VuGen provides a navigator that lets you view all of the Java classes and 
methods in your application’s packages.

 

package a.b.c;
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To insert a class or method into your script, you select it and paste it into 
your script. For step-by-step instructions, see “Manually Inserting Java 
Methods” on page 192.

The lower part of the dialog box displays a description of the Java object, its 
prototype, return values and path. In the following example, the description 
indicates that the deserialize method is a public static method that receives 
two parameters—a string and an integer. It returns a java.lang.object and 
throws an exception. 

The following table describes the icons that represent the various Java 
objects:

public static synchronized java.lang.Object deserialize (java.lang.String, int) throws 
Exception

Icon Item Example

Package java.util

Class public class Hashtable extends java.util.Dictionary

implements java.lang.Cloneable, java.io.Serializable

Interface 
Class
(gray icon)

public interface Enumeration

Method public synchronized java.util.Enumeration keys ()

Static Method
(yellow icon)

public static synchronized java.util.TimeZone 
getTimeZone 

Constructor 
Method

public void Hashtable ()
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Manually Inserting Java Methods 

You use the Java Function navigator to view and add Java functions to your 
script. The following section apply to EJB Testing and Java Record/Replay 
Vusers. You can customize the function generation settings by modifying 
the configuration file. For more information, see “Configuring Script 
Generation Settings” on page 194. 

To insert Java functions:

 1 Click within your script at the desired point of insertion. When you paste a 
function, VuGen places it at the location of the cursor. 

 2 Choose Insert > Insert Java Function. The Insert Java Function dialog box 
opens.
192



Chapter 11 • Working with Java Vuser Scripts
 3 Click Locations. The Locations dialog box opens. By default, VuGen lists the 
paths defined in the CLASSPATH environment variable.

 4 Click Browse to add another path or archive to the list. To add a path, 
choose Browse > Folder. To add an archive (jar or zip), choose Browse > File. 
When you select a folder or a file, VuGen inserts it in the Add Location box. 

 5 Click Add to add the item to the list.

 6 Repeat steps 4 and 5 for each path or archive you want to add. 

 7 Select or clear the check boxes to the left of each item in the list. If an item is 
checked, its members will be listed in the Java Class navigator.

 8 Click OK to close the Locations dialog box and view the available packages. 

 9 Click the plus and minus signs to the left of each item in the navigator, to 
expand or collapse the trees.

 10 Select an object and click Paste. VuGen places the object at the location of 
the cursor in the script. To paste all the methods of a class into your script, 
select the class and click Paste. 

 11 Repeat the previous step for all of the desired methods or classes.
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 12 Modify the parameters of the methods. If the script generation setting 
DefaultValues is set to true, you can use the default values inserted by 
VuGen. If DefaultValues is set to false, you must add parameters for all 
methods you insert into the script.

In addition, modify any return values. For example, if your script generated 
the following statement "(String)=LavaVersion.getVersionId();", replace 
(String) with a string type variable.

 13 Add any necessary statements to your script such as imports or Vuser API 
Java functions (described in Chapter 24, “Programming Java Scripts”).

 14 Save the script and run it from VuGen.

Configuring Script Generation Settings

You can customize the way the navigator adds methods to your script in the 
following areas:

➤ Class Name Path

➤ Automatic Transactions

➤ Default Parameter Values

➤ Class Pasting

To view the configuration setting, open the jquery.ini file in VuGen’s dat 
directory. 

[Display]
FullClassName=False

[Insert]
AutoTransaction=False
DefaultValues=True
CleanClassPaste=False
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Class Name Path
The FullClassName option displays the complete package and class name in 
the Java Function navigator. This option does not affect the way the 
functions are added into the script—it only affects the way the classes are 
displayed in the navigator. By default, this option is set to false. If your 
packages have many classes and you are unable to view the package and 
class names at the same time, you should enable this option.

FullClassName enabled FullClassName disabled
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Automatic Transactions
The AutoTransaction setting creates a Vuser transaction for all methods. 
When you enable this option, VuGen automatically encloses all Java 
methods with lr.start_transaction and lr.end_transaction functions. This 
allows you to individually track the performance of each method. This 
option is disabled by default.

Default Parameter Values
The DefaultValues setting includes default values for all methods you paste 
into your script. This option is enabled by default and inserts a null for all 
objects. If you disable this option, you must manually insert parameter 
values for all functions in the script. The following table illustrates the 
DefaultValues flag enabled and disabled. 

DefaultValues enabled DefaultValues disabled

lr.message((String)"");

lr.think_time((int)0);

lr.enable_redirection((boolean)false); 

lr.save_data((byte[])null, (String)"");

lr.message((String));

lr.think_time((int));

lr.enable_redirection((boolean));

lr.save_data((byte[]), (String));
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Class Pasting
The CleanClassPaste setting pastes a class so that it will compile cleanly: 
with an instance returning from the constructor, with default values as 
parameters, and without a need for import statements. Using this option, 
you will most likely be able to run your script without any further 
modifications. If you disable this option (default), you may need to 
manually define parameters and include import statements. Note that this 
setting is only effective when you paste an entire class into your script—not 
when you paste a single method. 

The following segment shows the toString method pasted into the script 
with the CleanClassPaste option enabled.

The same method with the CleanClassPaste option disabled is pasted as 
follows: 

The next segment shows the NumInserter Constructor method pasted into 
the script with the CleanClassPaste option enabled. 

The same method with the CleanClassPaste option disabled is pasted as: 

_class.toString();
// Returns: java.lang.String

(String) = toString();

utils.NumInserter _numinserter = new utils.NumInserter 
((java.lang.String)"", (java.lang.String)"", (java.lang.String)""…);

// Returns: void

new utils.NumInserter((String)"", (String)"", (String)"",...);
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Java Custom Filters

When testing your JAVA application, your goal is to determine how the 
server reacts to client requests. When load testing, you want to see how the 
server responds to a load of many users. With VuGen’s Java Vuser, you create 
a script that emulates a client communicating with your server.

VuGen provides filter files that define hooking properties for commonly 
used methods. There are filter definitions for RMI, CORBA, JMS, and 
JACADA protocols. You can also define custom filters as described below.

When you record a method, the methods which are called from the 
recorded method either directly or indirectly, will not be recorded.

In order to record a method, VuGen must recognize the object upon which 
the method is invoked, along with the method’s arguments. VuGen 
recognizes an object if it is returned by another recorded method provided 
that:

➤ the construction method of that object is hooked

➤ it is a primitive or a built-in object 

➤ It supports a serializable interface. 

You can create a custom filter to exclude unwanted methods. When 
recording a JAVA application, your script may include calls to methods that 
do not affect the server, such as calls to a local utility or the GUI interface. 
These calls are usually not relevant to your testing goals, and it would be 
correct to filter them out. 

The built-in filters for RMI, CORBA, JMS, and JACADA protocols were 
designed to record only the server related traffic relevant to your testing 
goals. In some instances, however, you may need to customize filters to 
capture your JAVA application's calls or exclude unnecessary calls. Custom 
JAVA protocols, proprietary enhancements and extensions to the default 
protocols, and data abstraction all require a custom filter definition.
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Guidelines for Setting Filters 
Before creating a test, it is recommended that you become familiar with 
your application and determine its primary classes and methods, so that you 
will know which ones to include in your recording. 

If you are not familiar with your application's classes, VuGen allows you to 
record with a stack trace that logs all of the methods that were called by 
your application. In order to record with stack trace set the log level to 
Detailed. For more information, see “Defining an Effective Filter” on 
page 201.

Once you determine the required methods and classes, you include them by 
updating the user.hooks file. When preparing a script, you may need to 
customize the filter several times in order to achieve the optimal filter. An 
optimal filter records the relevant methods without introducing a large 
number of irrelevant calls to the script. 

Note: If you plan to add manual code to your script such as control flow or 
message statements, make sure to do so after you have a functional script 
that runs inside VuGen. The reason for this, is that if you rerecord a script 
after modifying the filters, it will overwrite all manual changes. 
199



Chapter 11 • Working with Java Vuser Scripts
Determining which Elements to Include or Exclude 
When designing a custom filter, it is recommended that you start by 
choosing the appropriate built-in filter as a base filter. You can then 
customize the filter using one of the following approaches: 

➤ Top Down Approach. An approach in which you include the relevant 
package and exclude specific classes that are not part of the client-server 
activity. This is recommended if you are familiar with your application and 
you can identify a well-defined layer which implements all client-server 
activity without involving any GUI elements. 

➤ Bottom up Approach. An approach in which you use the default filter and 
refine it by adding individual methods or classes. Use this approach if you 
cannot identify a well-defined layer or if you are not familiar with your 
application. Do not add all AUT packages and then try to remove extra 
component one by one. 

The following section provides guidelines on when to include or exclude 
elements. 

➤ If, as a result of your including a class, your script has many unrelated 
method calls, try modifying the filter to exclude the irrelevant methods.

➤ If you identify a non-client/server call in your script, exclude its method 
in the filter.

➤ During recording, VuGen may detect an unknown input argument, for 
example, an argument whose construction it had never encountered 
before. If this argument supports serialization, VuGen serializes it by 
saving it to a file in a special format. During replay, VuGen reconstructs 
the argument by deserializing it. 

➤ VuGen serializes objects passed as arguments that were not included by 
the filter. It is recommended that you include this object in the filter in 
order to track its construction and activity instead of using it in its 
serialized form. You can identify serialized objects in the script by 
searching for calls to the lr.deserialize() method in your script. For more 
information see “Using the Serialization Mechanism” on page 226.

➤ Exclude all activity which involves GUI elements.

➤ Add classes for utilities that may be required for the script to be 
compiled.
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Defining an Effective Filter 
When preparing a script, you may need to customize the filter several times 
in order to achieve the optimal filter. An optimal filter records the relevant 
methods without introducing a large number of irrelevant calls to the script. 

To define an effective filter: 

 1 Create a new filter based on one of the built-in filters by modifying the 
user.hooks file which is located in the product’s classes directory. 

 2 Open the Recording Options (Ctrl+F7) and select the Log Options node. 
Select the Log Level to Detailed. 

 3 Record your application. Click Start Record (Ctrl + R) to begin and Stop 
(Ctrl + F5) to end.

 4 View the script's steps. If you can determine the business logic from the 
steps and apply correlation, you may not need to create custom filters. If, 
however, the script is very long or hard to maintain and correlate, you 
should customize the script's filter. 

 5 Try to identify the high-level method in the call that captures or wraps one 
or more client server calls. You can do this by opening the AUT source files 
(if they are available) or by viewing a Stack Trace of the script.

 6 Set the filter to include the relevant methods. For more information, see 
“Determining which Elements to Include or Exclude” on page 200.

 7 Record the application again. You should always rerecord the application 
after modifying the filter.

 8 Repeat steps 4 through 7 until you get a simple script which can be easily 
maintained and correlated.

 9 Correlate the script. In order for your test to run properly, you may need to 
insert a correlation to capture a value and use it at a later point in the script. 
For more information about the built-in correlation mechanism, see 
Chapter 13, “Correlating Java Scripts.”
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Note: Do not modify any of the other .hooks file as it might damage the 
VuGen recorder.

Adding custom hooks to the default recorder is a complicated task and 
should be considered thoroughly as it has both functional and performance 
consequences.

Incorrect hooking definitions can lead to incorrect scripts, slow recording, 
and application freeze-up.

Hooks Files Structure 
The following section describes the structure of a typical hooks file:

The hook files are structured as .ini files where each section represents a 
hook definition. Regular expressions are supported in some of the entries. 
Any entry that uses regular expression must start with a '!'. 

Hook-Name

Specifies the name of this section in the hooks file. Hook-Name must be 
unique across all hooks files. A good practice is to give the fully qualified 
class name and method. For example:

[javax.jms.Queue.getQueueName]

[Hook-Name]
class      = MyPackage.MyClass
method     = MyMethod
signature  = ()V
ignore_cl =
ignore_mtd = 
ignore_tree = 
cb_class   = mercury.ProtocolSupport
cb_mtd = 
general_cb = true
deep_mode = soft | hard
make_methods_public = true | false
lock = true | false
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Class

 A fully qualified class name. Regular expression can be used to include 
several classes from the same package, a whole package, several packages, or 
any class that matches a name. For example:

Class = !javax\.jms\.*

Method

The simple name of the method to include. Regular expressions can be used 
to include more than one method from the class. For example:

Method = getQueueName

Signature 

The standard Java internal type signature of the method. To determine the 
signature of a method, run the command javap -s class-name where class 
name is the fully qualified name of the class. Regular expressions can be 
used to include several methods with the same name, but with different 
arguments. For example:

Signature = !.* 

ignore_cl

A specific class to ignore from the classes that match this hook. This can be a 
list of comma separated class names. Each item in the list can contain a 
regular expression. If an item in the list contains a regular expression, 
prepend a '!' to the class name. For example:

Ignore_cl = !com.hp.jms.Queue,!com\.hp\..*

ignore_mtd

A specific method to ignore. When the loaded class method matches this 
hook definition, this method will not be hooked. The method name must 
be the simple method name followed by the signature (as explained above). 
To ignore multiple methods, list them in a comma separated list. To use a 
regular expression, prepend a '!' to the method name. For example:

Ignore_cl = open, close
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ignore_tree

A specific tree to ignore. When the name of the class matches the ignore tree 
expression, any class that inherits from it will not be hooked, if it matches 
this hooks definition. To ignore multiple trees, list them in a comma 
separated list. To use a regular expression, prepend a '!' to the class name. 
This option is relevant only for hooks that are defined as deep.

cb_class

The callback class that gets the call from the hooked method. It should 
always be set to mercury.ProtocolSupport. 

cb_mtd

A method in the callback class that gets the call from the hooked method. If 
omitted, it uses the default, general_rec_func. For cases where you just need 
to lock the subtree of calls, use general_func instead. 

general_cb

The general callback method. This value should always be set to true.

Deep_mode

Deep mode refers to classes and interfaces that inherit or implement the 
class or interface that the hook is listed for. The inherited classes will be 
hooked according to the type of hook: Hard, Soft, or Off.

➤ Hard. Hooks the current class and any class that inherits from it. If regular 
expressions exist, they are matched against every class that inherits from the 
class in the hook definition. Interface inheritance is treated the same as class 
inheritance.

➤ Soft. Hooks the current class and any class that inherits from it, only if the 
methods are overridden in the inheriting class. If the hook lists an interface, 
then if a class implements this interface those methods will be hooked. If 
they exist in classes that directly inherit from that class they will also be 
hooked. However, if the hook lists an interface and a class implements a 
second interface that inherits from this interface, the class will not be 
hooked.
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Note: Regular expressions are not inherited but converted to actual 
methods.

➤ Off. Only the class listed in the hook definition and the direct inheriting 
class will be hooked. If the hook lists an interface, only classes that directly 
implement it will be hooked.

make_methods_public:

Any method that matches the hook definition will be converted to public. 
This is useful for custom hooks or for locking a sub tree of calls from a non-
public method.

Note that this applies only during record. During replay, the method will 
use the original access flags. In the case of non-public methods, it will throw 
java.lang.VerifyError.

Lock

When set to true, it locks the sub tree and prevents the calling of any 
method originating from the original method. 

When set to false, it will unlock the sub tree, record any method originating 
from the current method (if it is hooked), and invoke the callback.
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12
Setting Java Recording Options 

VuGen allows you to control the way in which you record your CORBA, 
RMI, JMS or Jacada application. You can use the default recording options, 
or customize them for your specific needs.

This chapter includes:

 ➤  About Setting Java Recording Options on page 208

 ➤  Java Virtual Machine (JVM) Recording Options on page 209

 ➤  Setting Classpath Recording Options on page 211

 ➤  Recorder Options on page 212

 ➤  Serialization Options on page 214

 ➤  Correlation Options on page 216

 ➤  Log Options on page 217

 ➤  CORBA Options on page 219

The following information applies to Java Record Replay and EJB Vuser 
scripts.
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About Setting Java Recording Options 

Using VuGen, you record a CORBA (Common Object Request Broker 
Architecture) or RMI (Remote Method Invocation) Java application or 
applet. For recording an EJB test, see Chapter 47, “Performing EJB Testing.”

Before recording, VuGen lets you set recording options for the Java Virtual 
Machine (JVM) and for the code generation stage. Setting the recording 
options is not mandatory; if you do not set them, VuGen uses the default 
values.

The options described in this chapter were previously handled by modifying 
the mercury.properties file.

You can set recording options in the following areas:

➤ Java Virtual Machine (JVM) Recording Options

➤ Setting Classpath Recording Options

➤ Recorder Options

➤ Serialization Options

➤ Correlation Options

➤ Log Options
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Java Virtual Machine (JVM) Recording Options 

The Java VM options indicate additional parameters to use when recording 
Java applications. 

When you record a Vuser, VuGen automatically sets the Xbootclasspath 
variable with default parameters. If you use this dialog box to set the 
Xbootclasspath with different parameters, it will use those command 
parameters—not the default ones.

You can also instruct VuGen to add the Classpath before the Xbootclasspath 
(prepend the string) to create a single Classpath string.

By default, VuGen uses the classic VM during recording. You can also 
instruct VuGen to use another virtual machine (Sun’s Java Hotspot VM).
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To set the Java Virtual Machine recording options:

 1 Click Options in the Start Recording dialog box. Select the Java Environment 
Settings:Java VM node in the Recording Options tree.

 2 In the Additional VM Parameters box, list the Java command line 
parameters. These parameters may be any Java VM argument. The common 
arguments are the debug flag (-verbose) or memory settings (-ms, -mx). For 
more information about the Java VM flags, see the JVM documentation. In 
additional, you may also pass properties to Java applications in the form of a 
-D flag. 

VuGen automatically sets the -Xbootclasspath variable (for JDK 1.2 and 
higher) with default parameters. When you specify -Xbootclasspath with 
parameter values as an additional parameter, VuGen uses this setting instead 
of the default one.

 3 To use the same Additional VM parameters in replay, select the Use the 
specified Additional VM Parameters during replay check box. 

 4 To use the classic VM, select the Use classic Java VM check box (default). To 
use another VM (Sun’s Java HotSpot), clear the check box. 

 5 To add the Classpath before the Xbootclasspath (prepend the string), select 
the Prepend CLASSPATH to -Xbootclasspath parameter check box.

 6 Click OK to close the dialog box and begin recording.
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Setting Classpath Recording Options

The Java Environment Settings:Classpath node lets you specify the location 
of additional classes that were not included in the system’s classpath 
environment variable. You may need these classes to run Java applications 
and insure proper recording.

You can browse for the required classes on your computer or network and 
disable them for a specific test. You can also manipulate the classpath 
entries by changing their order.

To set the Classpath recording options:

 1 Click Options in the Start Recording dialog box. Select the Java Environment 
Settings:Classpath node in the Recording Options tree.

 2 To add a classpath to the list: 

Click the Add Classpath button. VuGen adds a new line to the classpath list.

Type in the path and name of the jar, zip or other archive file for your class. 
Alternatively, click the Browse button to the right of the field, and locate 
the desired file. VuGen adds the new location to the classpath list, with an 
enabled status.

 3 To permanently remove an entry, select it and click the Delete button. 
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 4 To disable a classpath entry for a specific test, clear the check box to the left 
of the entry.

 5 To move an entry down in the list, select it and click the Down arrow. 

 6 To move a classpath entry up within the list, select it and click the Up arrow. 

 7 Click OK to close the dialog box and begin recording.

Recorder Options 

The Recorder options indicate which protocol to record and some of the 
protocol-specific settings. 

➤ Recorded protocol. Specifies which protocol to record: RMI, CORBA, JMS, or 
Jacada. (RMI by default).

➤ Extensions list. A comma separated list of all supported extensions. Each 
extension has its own hooks file (JNDI by default).

➤ Use DLL hooking to attach LoadRunner support. Use DLL hooking to 
automatically attach LoadRunner support to any JVM.
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➤ Load parent class before class. Change the loading order so that parent 
classed are loaded before child classes. This helps identify hooking for trees 
with deep inheritance. (enabled by default).

➤ Use _JAVA_OPTION flag. Forces JVM versions 1.2 and higher to use the 
_JAVA_OPTION environment variable which contains the desired JVM 
parameters (disabled by default).

➤ Insert functional check. Inserts verification code that compares the return 
value received during replay, to the expected return value generated during 
recording. This option only applies to primitive return values (disabled by 
default).

➤ Comment lines containing. Comment out all lines in the script containing 
one of the specified strings. To specify multiple strings, separate the entries 
with commas. By default, any line with a string containing <undefined>, 
will be commented out.

➤ Remove lines containing. Remove all lines containing one of the specified 
strings from the script. To specify multiple strings, separate the entries with 
commas. This feature is useful for customizing the script for a specific 
testing goal.

➤ Bytes as characters. Displays readable characters as characters with the 
necessary casting—not in byte or hexadecimal form (enabled by default).

➤ Unreadable strings as bytes. Represents strings containing unreadable 
characters as byte arrays. This option applies to strings that are passed as 
parameters to invocations (enabled by default).

➤ Byte array format. The format of byte arrays in a script: Regular, Unfolded 
Serialized Objects, or Folded Serialized Objects. Use one of the serialized 
object options when recording very long byte arrays. The default is Regular.

➤ Record LoadRunner callback. Records the LoadRunner stub object as a 
callback. If disabled, VuGen records the original class as the callback 
(enabled by default).
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To set the Java Recorder options:

 1 Click Options in the Start Recording dialog box and select the Recording 
Properties:Recorder Options node.

 2 Set the options as desired. For the options with check boxes, select or clear 
the check box adjacent to the option. For options that require strings, type 
in the desired value. 

 3 To set all options to their default values, click Use Defaults.

 4 Click OK to close the dialog box and begin recording.

Serialization Options

The Serialization options let you to control how objects are serialized. 
Serialization is often relevant to displaying objects in an ASCII 
representation in order to parameterize their values. 
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The following options are available:

➤ Unfold Serialized Objects. Expands serialized objects in ASCII 
representation. This option allows you to view the ASCII values of the 
objects in order to perform parameterization (enabled by default).

➤ Limit Object Size (bytes). Limits serializable objects to the specified 
value. Objects whose size exceeds this value, will not be given ASCII 
representation in the script. The default value is 3072. 

➤ Ignore Serialized Objects. Lists the serialized objects not to be 
unfolded when encountered in the recorded script. Separate objects 
with commas.

➤ Serialization Delimiter. Indicates the delimiter separating the elements 
in the ASCII representation of objects. VuGen will only parameterize 
strings contained within these delimiters. The default delimiter is ‘#’.

➤ Unfold Arrays. Expands array elements of serialized objects in ASCII 
representation. If you disable this option and an object contains an array, 
the object will not be expanded. By default, this option is enabled—all 
deserialized objects are totally unfolded.

➤ Limit Array Entries. Instructs the recorder not to open arrays with more 
than the specified number of elements. The default value is 200. 

To set the Serialization options:

 1 Click Options in the Start Recording dialog box and select the Recording 
Properties:Serialization Options node.

 2 Set the options as desired. To set all options to their default values, click Use 
Defaults.

 3 Click OK to close the dialog box and begin recording.

For more information on serialization, see “Using the Serialization 
Mechanism” on page 226.
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Correlation Options 

The Correlation options let you enable automatic correlation, and control 
its depth.

The following options are available:

➤ Correlate Strings. Correlate all strings that require correlation. If this option 
is disabled, VuGen prints them in the script, wrapped in quotes (disabled by 
default).

➤ Correlate String Arrays. Correlate text within string arrays (enabled by 
default).

➤ Correlate Collection Type. Correlates objects from the Collection class for 
JDK 1.2 and higher (disabled by default).

➤ Advanced Correlation. Enables deep correlation in CORBA container 
constructs and arrays (enabled by default).

➤ Correlation Level. Indicates the level of deep correlation, the number of 
inner containers to be scanned (15 by default). 
216



Chapter 12 • Setting Java Recording Options
To set the Correlation options:

 1 Click Options in the Start Recording dialog box and select the Recording 
Properties:Correlation Options node.

 2 Enable the desired options, or for options that require values, enter the 
desired value. To set all options to their default values, click Use Defaults.

 3 Click OK to close the dialog box and begin recording.

For more information about correlation, see Chapter 13, “Correlating Java 
Scripts.”

Log Options 

The Log recording options let you determine the level of debug information 
generated during recording.
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The following options are available:

➤ Log Level. The level of recording log to generate.

➤ None. No log file is created

➤ Brief. Generates a standard recording log and output redirection

➤ Detailed. Generates a detailed log for methods, arguments, and return 
values. 

➤ Debug. Records hooking and recording debug information, along with 
all of the above. 

➤ Class Dumping. Dumps all of the loaded classes to the script directory. 
(disabled by default).

➤ Synchronize Threads. For multi-threaded applications, instructs VuGen to 
synchronize between the different threads (disabled by default).

➤ Digest Calculation. Generate a digest of all recorded objects (disabled by 
default).

➤ Exclude from Digest. A list of objects not to be included in the digest 
calculation. 

To set the Log options:

 1 Click Options in the Start Recording dialog box and select the Recording 
Properties:Log Options node.

 2 Choose a Log level: None, Brief, Detailed, or Debug. 

 3 Enable the desired options, or for options that require values, enter the 
desired value.

 4 To set all options to their default values, click Use Defaults.

 5 Click OK to close the dialog box and begin recording.
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CORBA Options 

The following options are specific to Corba-Java. These options let you set 
the CORBA specific recording properties and several callback options.

The following options are available:

➤ Vendor. The CORBA vendors Inprise Visibroker, Iona OrbixWeb, or Bea 
Weblogic.

➤ Use local vendor classes. Use local vendor classes and add the srv folder to 
the BOOT classpath. If you disable this option, VuGen uses network classes 
and adds the script’s classes to the classpath (enabled by default).

➤ Record Properties. Instructs VuGen to record system and custom properties 
related to the protocol (enabled by default).

➤ Show IDL Constructs. Displays the IDL construct that is used when passed as 
a parameter to a CORBA invocation (enabled by default).

➤ Record DLL only. Instructs VuGen to record only on a DLL level (disabled by 
default).

➤ Resolve CORBA Objects. When correlation fails to resolve a CORBA object, 
recreate it using its binary data (disabled by default).
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➤ Record CallBack Connection. Instructs VuGen to generate a connect 
statement for the connection to the ORB, for each callback object (disabled 
by default). 

To set the Corba recording options:

 1 Click Options in the Start Recording dialog box and select the Recording 
Properties:Corba Options node.

 2 Enable or disable the options as desired.

 3 To set all options to their default values, click Use Defaults.

 4 Click OK to close the dialog box and begin recording.
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Correlating Java Scripts

VuGen’s correlation allows you to link Java Vuser functions by using the 
results of one statement as input to another.

This chapter includes:

 ➤  About Correlating Java Scripts on page 222

 ➤  Standard Correlation on page 223

 ➤  Advanced Correlation on page 223

 ➤  String Correlation on page 225

 ➤  Using the Serialization Mechanism on page 226

The following information only applies to Java Vuser scripts.
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About Correlating Java Scripts

Vuser scripts containing Java code often contain dynamic data. When you 
record a Java Vuser script, the dynamic data is recorded into scripts, but 
cannot be re-used during replay. If you encounter an error when running 
your Vuser, examine the script at the point where the error occurred. In 
many cases, correlation will solve the problem by enabling you to use the 
results of one statement as input to another.

VuGen’s Java recorder attempts to automatically correlate statements in the 
generated script. It only performs correlation on Java objects. When it 
encounters a Java primitive (byte, character, boolean, integer, float, double, 
short, and long) during recording, the argument values appear in the script 
without association to variables. VuGen automatically correlates all objects, 
arrays of objects, and arrays of primitives. Note that Java arrays and strings 
are also considered objects.

VuGen employs several levels of correlation: Standard, Enhanced, Strings. 
You enable or disable correlation from the Recording options. An additional 
method of Serialization can be used to handle scripts where none of the 
former methods can be applied. For more information, see “Using the 
Serialization Mechanism” on page 226.
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Standard Correlation

Standard correlation refers to the automatic correlation performed during 
recording for simple objects, excluding object arrays, vectors, and container 
constructs. 

When the recorded application invokes a method that returns an object, 
VuGen’s correlation mechanism records these objects. When you run the 
script, VuGen compares the generated objects to the recorded objects. If the 
objects match, the same object is used. The following example shows two 
CORBA objects my_bank and my_account. The first object, my_bank, is 
invoked; the second object, my_account, is correlated and passed as a 
parameter in final line of the segment:

Advanced Correlation

Advanced or deep correlation refers to the automatic correlation performed 
during recording for complex objects, such as object arrays and CORBA 
container constructs. 

The deep correlation mechanism handles CORBA constructs (structures, 
unions, sequences, arrays, holders, ‘any’s) as containers. This allows it to 
reference inner members of containers, additional objects, or different 
containers. Whenever an object is invoked or passed as a parameter, it is also 
compared against the inner members of the containers. 

public class Actions {

  // Public function: init 
      public int init() throws Throwable {

Bank my_bank = bankHelper.bind("bank", "shunra");
Account my_account = accountHelper.bind("account","shunra");

my_bank.remove_account(my_account);
      }
:
}
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In the following example, VuGen performs deep correlation by referencing 
an element of an array. The remove_account object receives an account 
object as a parameter. During recording, the correlation mechanism searches 
the returned array my_accounts and determines that its sixth element 
should be passed as a parameter.

The following segment further illustrates enhanced correlation. The script 
invokes the send_letter object that received an address type argument. The 
correlation mechanism retrieves the inner member, address, in the sixth 
element of the my_accounts array.

public class Actions {

// Public function: init 
public int init() throws Throwable {

my_banks[] = bankHelper.bind("banks", "shunra");
my_accounts[] = accountHelper.bind("accounts","shunra");

my_banks[2].remove_account(my_accounts[6]);
}

:
}

public class Actions {

// Public function: init 
public int init() throws Throwable {

my_banks = bankHelper.bind("bank", "shunra");
my_accounts = accountHelper.bind("account", "shunra");

my_banks[2].send_letter(my_accounts[6].address);
}

:
}
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String Correlation

String correlation refers to the representation of a recorded value as an 
actual string or a variable. When you disable string correlation (the default 
setting), the actual recorded value of the string is indicated explicitly within 
the script. When you enable string correlation, it creates a variable for each 
string, allowing you to use it at a later point in the script.

In the following segment, string correlation is enabled—you store the value 
returned from the get_id method in a string type variable for use later on in 
the script.

You set the correlation method from the Correlation tab in the recording 
options. 

➤ Correlate Strings. Correlate strings in script during recording. If you disable 
this option, the actual recorded values are included in the script between 
quotation marks. If this option is disabled, all other correlation options are 
ignored (disabled by default).

➤ Correlate String Arrays. Correlate strings within string arrays during 
recording. If you disable this option, strings within arrays are not correlated 
and the actual values are placed in the script (enabled by default).

➤ Advanced Correlation. Enables correlation on complex objects such as 
arrays and CORBA container constructs and arrays. This type of correlation 
is also known as deep correlation (enabled by default).

public class Actions {

// Public function: init 
public int init() throws Throwable {

my_bank = bankHelper.bind("bank", "shunra");
my_account1 = accountHelper.bind("account1", "shunra");
my_account2 = accountHelper.bind("account2", "shunra");

string = my_account1.get_id();
string2 = my_account2.get_id();
my_bank.transfer_money(string, string2);

}
:
}
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➤ Correlation Level. Determines the level of deep correlation—how many 
inner containers to search.

➤ Correlate Collection Type. Correlate objects contained in a Collection class 
for JDK 1.2 or higher (disabled by default).

Using the Serialization Mechanism

In RMI, and some cases of CORBA, the client AUT creates a new instance of 
a Java object using the java.io.serializable interface. It passes this instance as 
a parameter for a server invocation. In the following segment, the instance p 
is created and passed as a parameter.

The automatic correlation mechanism is ineffective here, since the object 
did not return from any previous call. In this case, VuGen activates the 
serialization mechanism and stores the object being passed as a parameter. It 
saves the information to a binary data file under the user directory. 
Additional parameters are saved as new binary data files, numbered 
sequentially. VuGen generates the following code:

The integer passed to lr.deserialize represents the number of binary data 
files in the Vuser directory.

// AUT code:
java.awt.Point p = new java.awt.Point(3,7); 
map.set_point(p);
:

public class Actions {

  // Public function: init 
      public int init() throws Throwable {
          java.awt.Point p = (java.awt.Point)lr.deserialize(0, false);
          map.set_point(p);
      }
:
}
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To parameterize the recorded value, use the public setLocation method (for 
information, see the JDK function reference). The following example uses 
the setLocation method to set the value of the object, p. 

In certain instances the public method of setLocation is not applicable. As 
an alternative, you can use the API of your class that incorporate get or set 
accessor methods. If you are working with AUT classes that do not have 
get/set methods or use private methods, or if you are unfamiliar with the 
classes’ API, you can use VuGen’s built-in serialization mechanism. This 
mechanism allows you to expand objects in their ASCII representation and 
manually parameterize the script. You enable this mechanism in the 
Recording Options dialog box (see Chapter 12, “Setting Java Recording 
Options”).

VuGen generates an lr.deserialize method that deserializes the data or 
displays complex data structures as serial strings. Once the structure is 
broken down to its components, it is easier to parameterize. The 
lr.deserialize method receives two arguments, a string and an integer. The 
string is the parameter’s value that is to be substituted during replay. The 
integer is the index number of binary file to load. 

public class Actions {

  // Public function: init 
      public int init() throws Throwable {
          java.awt.Point p = (java.awt.Point)lr.deserialize(0, false);
          p.setLocation(2,9);
          map.set_point(p);
      }
:
:
}

227



Chapter 13 • Correlating Java Scripts
If you choose not to expand objects in your script by clearing the Unfold 
Serialized Objects check box, you can control the serialization mechanism 
by passing arguments to the lr.deserialize method. The first argument is an 
integer indicating the number of binary files to load. The second integer is a 
boolean value: 

The following segment shows a generated script in which the serialization 
mechanism was enabled. 

The string values are placed between delimiters.The default delimiter is "#". 
You can change the delimiter in the Serialization tab of the recording 
options. Delimiters are used to speed up the parsing of the string during 
replay. 

When modifying the string, you must maintain the following rules: 

➤ Order of lines may not be changed. The parser reads the values one-by-
one—not the member names.

➤ Only values between two delimiters may be modified.

➤ Object references may not be modified. Object references are indicated only 
to maintain internal consistency. 

true Use VuGen’s serialization mechanism.

false Use the standard Java serialization mechanism.

public class Actions {

  // Public function: init 
      public int init() throws Throwable {
          _string = "java.awt.Point __CURRENT_OBJECT = {" +
                     "int x = "#5#" +
                     "int y = "#8#" +
          "}";
          java.awt.Point p = (java.awt.Point)lr.deserialize(_string,0);
          map.set_point(p);
      }
:
}
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➤ "_NULL_" can appear as a value, representing the Java null constant. You can 
replace it with string type values only.

➤ Objects may be deserialized anywhere in the script. For example, you can 
deserialize all objects in the init method and use the values in the action 
method. 

➤ Maintain internal consistency for the objects. For example, if a member of a 
vector is element count and you add an element, you must modify the 
element count. 

In the following segment, a vector contains two elements: 

public class Actions {

  // Public function: init 
      public int init() throws Throwable {
          _string = "java.util.Vector CURRENTOBJECT = {" +
                     "int capacityIncrement = "#0#" +
                     "int elementCount = #2#" +
                     "java/lang/Object elementData[] = {" +
                            "elementData[0] = #First Element#" +
                            "elementData[1] = #Second Element#" +
                            "elementData[2] = _NULL_" +

....
                            "elementData[9] = _NULL_" +

                     "}" +
          "}";
          _vector = (java.util.Vector)lr.deserialize(_string,0);
          map.set_vector(_vector);
      }
:
}
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In the following example, one of the vector’s elements was changed—a 
"_NULL_" value was changed to "Third element". In coordination with the 
addition of the new element, the "elementCount" member was modified to 
"3". 

Due to the complexity of the serialization mechanism, which opens up the 
objects to ASCII representation, opening large objects while recording may 
increase the time required for script generation. To decrease this time, you 
can specify flags which will improve the performance of the serialization 
mechanism. 

When adding lr.deserialize to your script, it is recommended that you add it 
to the init method—not the action method. This will improve performance 
since VuGen will only deserialize the strings once. If it appears in the action 
method, VuGen will deserialize strings for every iteration.

public class Actions {

  // Public function: init 
      public int init() throws Throwable {
          _string = "java.util.Vector CURRENTOBJECT = {" +
                     "int capacityIncrement = "#0#" +
                     "int elementCount = #3#" +
                     "java/lang/Object elementData[] = {" +
                            "elementData[0] = #First Element#" +
                            "elementData[1] = #Second Element#" +
                            "elementData[2] = #Third Element#" +

....
                            "elementData[9] = _NULL_" +
                     "}" +
          "}";
          _vector = (java.util.Vector)lr.deserialize(_string,0);
          map.set_vector(_vector);
      }
:
}
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The following list shows the available options which you set in Serialization 
tab of the recording options: 

➤ Serialization Delimiter

➤ Unfold Serialized Objects

➤ Unfold Arrays

➤ Limit Array Entries

➤ Ignore Serialized Objects

For complete information on the recording options, see Chapter 12, 
“Setting Java Recording Options.” 
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Configuring Java Run-Time Settings 

After you record a Java Vuser script, you configure the run-time settings for 
the Java Virtual Machine.

This chapter includes:

 ➤  About Configuring Java Run-Time Settings on page 233

 ➤  Specifying the JVM Run-Time Settings on page 234

 ➤  Setting the Run-Time Classpath Options on page 235

The following information applies to Java and EJB Testing type Vusers.

About Configuring Java Run-Time Settings 

After developing a Java Vuser script, you set the run-time settings for the 
Java VM (Virtual Machine). These settings let you set additional paths and 
parameters, and determine the run mode. 

You set the Java related run-time settings through the Java VM options in 
the Run-Time Settings dialog box.

To display the Run-Time Settings dialog box, click the Run-Time Settings 
button on the VuGen toolbar.

This chapter only discusses the Run-Time settings for Java type Vusers. For 
information about run-time settings that apply to all Vusers, see 
“Configuring Run-Time Settings” in Volume I-Using VuGen. 
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Specifying the JVM Run-Time Settings
In the Java VM section, you provide information about the Java virtual 
machine settings.

The following settings are available:

➤ Virtual Machine settings

➤ Use internal logic to locate JDK. Search the PATH, registry, and Windows 
folder for the JDK to use during replay.

➤ Use specified JDK. Use the JDK specified below during replay.

➤ Additional VM Parameters. Enter any optional parameters used by the 
virtual machine.

➤ Using Xbootclasspath parameters. Replays the script with the 
Xbootclasspath /p option.

➤ Class Loading Settings

➤ Load each Vuser using dedicated class loader. Load each Vuser using a 
dedicated class loader. This will allow you to use a unique namespace 
for each Vuser and manage their resources separately.

 

234



Chapter 14 • Configuring Java Run-Time Settings
To set the Java VM run-time settings: 

 1 Choose Vuser > Run-Time Settings and select the Java Environment 
Settings:Java VM node in the Run-Time Settings tree.

 2 Select the desired Virtual Machine settings indicating the JDK to use for the 
replay.

 3 To replay with the -Xbootclasspath/p option, select the Using 
Xbootclasspath parameters option. 

 4 Click OK.

Setting the Run-Time Classpath Options 

The ClassPath section lets you specify the location of additional classes that 
were not included in the system’s classpath environment variable. You may 
need these classes to run Java applications and insure proper replay.

You can browse for the required classes on your computer or network and 
disable them for a specific test. You can also manipulate the classpath 
entries by changing their order. 
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To set the Classpath run-time settings:

 1 Open the Run-Time settings (F4). Select the Java Environment 
Settings:Classpath node in the Run-Time settings tree.

 2 Add a classpath to the list: 

Click the Add Classpath button. VuGen adds a new line to the classpath list.

Type in the path and name of the jar, zip or other archive file for your class. 
Alternatively, click the Browse button to the right of the field, and locate 
the desired file. VuGen adds the new location to the classpath list, with an 
enabled status.

 3 To permanently remove a classpath entry, select it and click the Delete 
button. 

 4 To disable a classpath entry for a specific test, clear the check box to the left 
of the entry.

 5 To move a classpath entry down in the list, select it and click the Down 
arrow. 

 6 To move a classpath entry up within the list, select it and click the Up arrow. 

 7 Click OK to close the dialog box.
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15 
Creating Citrix Vuser Scripts

VuGen allows you to record the actions of a Citrix client communicating 
with its server using the Citrix ICA protocol. The resulting script is called a 
Citrix Vuser script. 

The optional Citrix Agent helps you create an intuitive script that provides 
built-in synchronization. For more information, see Chapter 16, “Using the 
LoadRunner Citrix Agent.” Refer to “Tips for Replaying and Troubleshooting 
Citrix Vuser Scripts” on page 271 for valuable tips on creating scripts.

This chapter includes:

 ➤  About Creating Citrix Vuser Scripts on page 240

 ➤  Getting Started with Citrix Vuser Scripts on page 241

 ➤  Setting Up the Client and Server on page 242

 ➤  Recording Tips on page 245

 ➤  Understanding Citrix Recording Options on page 247

 ➤  Setting the Citrix Recording Options on page 255

 ➤  Setting the Citrix Display Settings on page 256

 ➤  Setting the Citrix Run-Time Settings on page 257

 ➤  Viewing and Modifying Citrix Vuser Scripts on page 260

 ➤  Synchronizing Replay on page 261

 ➤  Understanding ICA Files on page 269

 ➤  Using Citrix Functions on page 270

 ➤  Tips for Replaying and Troubleshooting Citrix Vuser Scripts on page 271
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The following information only applies to the Citrix ICA protocol.

About Creating Citrix Vuser Scripts

Citrix Vuser scripts emulate the Citrix ICA protocol communication 
between a Citrix client and server. VuGen records all activity during the 
communication and creates a Vuser script.

When you perform actions on the remote server, VuGen generates functions 
that describe these actions. Each function begins with a ctrx prefix. These 
functions emulate the analog movements of the mouse and keyboard. In 
addition, the ctrx functions allow you to synchronize the replay of the 
actions, by waiting for specific windows to open.

VuGen also allows you to record a Citrix NFUSE session. With Citrix NFuse, 
the client is installed, but your interface is a browser instead of a client 
interface. To record NFUSE sessions, you must perform a multi-protocol 
recording for Citrix and Web Vusers. (See “Recording with VuGen” in 
Volume I-Using VuGen.) In multi-protocol mode, VuGen generates functions 
from both Citrix and Web protocols during recording. 

In the following example, ctrx_mouse_click simulates a mouse click on the 
left button. 

For more information about the syntax and parameters, refer to the Online 
Function Reference (Help > Function Reference).

You can view and edit the recorded script from VuGen’s main window. The 
API calls that were recorded during the session are displayed in VuGen, 
allowing you to track your actions. 

ctrx_mouse_click(44, 318, LEFT_BUTTON, 0, CTRX_LAST);
240



Chapter 15 • Creating Citrix Vuser Scripts
Getting Started with Citrix Vuser Scripts

This section provides an overview of the process of developing Citrix ICA 
Vuser scripts using VuGen. In addition, see “Tips for Replaying and 
Troubleshooting Citrix Vuser Scripts” on page 271.

To develop a Citrix ICA script: 

 1 Make sure that your client and server are configured properly.

For general information about these settings, see “Setting Up the Client and 
Server” on page 242.

 2 Record the actions using VuGen.

Invoke VuGen and create a new Vuser script. Insert bitmap and text 
synchronization during recording as described in “Synchronizing Replay” 
on page 261. 

For general information about recording, see “Recording with VuGen” in 
Volume I-Using VuGen. 

 3 Enhance the Vuser script.

Enhance the Vuser script by inserting transactions, rendezvous points, and 
control-flow structures into the script.

For details, see “Enhancing Vuser Scripts” in Volume I-Using VuGen. 

 4 Define parameters (optional).

Define parameters for the fixed-values recorded into your Vuser script. By 
substituting fixed-values with parameters, you can repeat the same business 
process many times using different values. 

For details, see “Creating Parameters” in Volume I-Using VuGen.

 5 Configure the Citrix display options.

Configure the display options for replaying Citrix Vusers. These options let 
you show the Citrix client during replay and open a snapshot when an error 
occurs. For details, see “Setting the Citrix Display Settings” on page 256.

 6 Configure the Run-Time settings.

The Run-Time settings control Vuser behavior during script execution. 
These settings include pacing, logging, think time, and connection 
information. 
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For details about the Citrix specific Run-Time settings, see “Setting the Citrix 
Run-Time Settings” on page 257. For information about general Run-Time 
settings, see “Configuring Run-Time Settings” in Volume I-Using VuGen.  

 7 Save and run the Vuser script from VuGen. 

Save and run the Vuser script from VuGen to verify that it runs correctly. 
While you record, VuGen creates a series of configuration, data, and source 
code files. These files contain Vuser run-time and setup information. VuGen 
saves these files together with the script.

For details about running the Vuser script as a standalone test, see “Tips for 
Replaying and Troubleshooting Citrix Vuser Scripts” on page 271 and 
“Running Vuser Scripts in Standalone Mode” in Volume I-Using VuGen.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

Setting Up the Client and Server

Before creating a script, make sure you have a supported Citrix client 
installed on your machine, and that your server is properly configured. This 
section describes:

➤ Client Versions

➤ Server Configuration

Client Versions
In order to run your script, you must install a Citrix client on each Load 
Generator machine. If you do not have a client installed, you can download 
one from the Citrix Website www.citrix.com under the download section.

VuGen supports all Citrix clients with the exception of versions 8.00, 
version 6.30.1060 and earlier, and Citrix Web clients.
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Server Configuration
To record in VuGen, you need to configure the Citrix server in the following 
areas:

➤ MetaFrame. Make sure the MetaFrame server (1.8, XP, 3, or 4) is installed. To 
check the version of the server, select Citrix Connection Configuration on 
the server’s console toolbar and choose Help > About.

➤ Configure Server to Close Sessions. Configure the Citrix server to 
completely close a session. After a Citrix client closes the connection, the 
server is configured, by default, to save the session for the next time that 
client opens a new connection. Consequently, a new connection by the 
same client will face the same workspace from which it disconnected 
previously. It is preferable to allow each new test run to use a clean 
workspace. 

The ensure a clean workspace for each test, you must configure the Citrix 
server not to save the previous session. Instead, it should reset the 
connection by disconnecting from the client each time the client times-out 
or breaks the connection.

➤ MetaFrame 1.8 or XP Servers

➤ MetaFrame 3 and 4 Servers

MetaFrame 1.8 or XP Servers

To reset the connection for every session on a MetaFrame Server:

 1 Open the Citrix Connection Configuration dialog box. Choose Start > 
Programs > Citrix > MetaFrame > Citrix Connection Configuration.

 2 Double-click on the ica-tcp connection name. The Edit Connection dialog 
box opens.
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 3 Click the Advanced button. The Advanced Connection Settings dialog box 
opens.

 4 In the bottom section of the dialog box, clear the inherit user config check 
box adjacent to the On a broken or timed-out connection list box. Change 
the entry for this list box to reset.

 5 Click OK.

MetaFrame 3 and 4 Servers

To reset the connection for every session on a MetaFrame 3 server:

 1 Open the Citrix Connection Configuration dialog box. Choose Programs > 
Citrix > Administration Tools > Citrix Connection Configuration Tool.

 2 Select the ica-tcp connection name and choose Connection > Edit. 
Alternatively, double-click on the connection. The Edit Connection dialog 
box opens.
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 3 Click the Advanced button. The Advanced Connection Settings dialog box 
opens.

 4 In the bottom section of the dialog box, clear the inherit user config check 
box adjacent to the On a broken or timed-out connection list box. Change 
the entry for this list box to reset.

 5 Click OK.

Recording Tips

When recording a script, be sure to follow these guidelines in order to create 
an effective script.

Single vs. Multi-Protocol Scripts

When creating a new script, you may create a single protocol or multi-
protocol script. If you plan to record a simple Citrix ICA session, use a single 
protocol script. When recording an NFUSE Web Access session, however, 
you must create a multi-protocol script for Citrix ICA and 
Web(HTML/HTTP), to enable the recording of both protocols. For more 
information, see “Recording with VuGen” in Volume I-Using VuGen. 

Record into Appropriate Sections

Record the connection process into the vuser_init section, and the closing 
process into the vuser_end section. This will prevent you from performing 
iterations on the connecting and disconnecting. For more information 
about recording into sections, see “Recording with VuGen” in Volume I-Using 
VuGen.

Run a Clean Session

When recording a session, make sure to perform the complete business 
process, starting with the connection and ending with the cleanup. End 
your session at a point from where you could start the entire process from 
the beginning. Do not leave any client or application windows open. 
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Explicit Clicks

When opening expanded menu options, click explicitly on each option—do 
not depend on the expanding menu. For example, when choosing Start > 
Programs > Microsoft Word, be sure to click on the word Programs.

Do not Resize Windows

Although VuGen supports the resizing of windows during recording the 
session, it is recommended that you do not move or resize them while 
recording. To change the size or position of a window, double-click on the 
relevant Sync on Window step in the script’s Tree view and modify the 
window’s coordinates.

Make Sure Resolution Settings are Consistent

To insure successful bitmap synchronization, make sure that the resolution 
settings match. On the recording machine, check the settings of the ICA 
client, the Recording Options, and the Run Time settings. On the Injector 
machines, check the settings of the ICA client, and make sure that they are 
consistent between all injector and recording machines. If there is an 
inconsistency between the resolutions, the server traffic increases in order to 
make the necessary adjustments.

Add Manual Synchronization Points

While waiting for an event during recording, such as the opening of an 
application, it is recommended that you add manual synchronization 
points, such as Sync on Bitmap or Sync on Text. For details, see 
“Synchronizing Replay” on page 261.

Disable Client Updates

Disable client updates when prompted by the Citrix client. This will prevent 
forward compatibility issues between VuGen and newer Citrix clients that 
were not yet tested.
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Windows Style

For Sync on Bitmap steps, record windows in the "classic" windows style—
not the XP style.

To change the Windows style to "classic":

 1 Click in the desktop area.

 2 Choose Properties from the right-click menu.

 3 Select the Theme tab. 

 4 Choose Windows Classic from the Theme drop down list.

 5 Click OK.

Understanding Citrix Recording Options

You can set the Citrix Recording options in the following areas. 

➤ Configuration Recording Options

➤ Recorder Recording Options

➤ Code Generation Recording Options

➤ Login Recording Options (only for single protocol Citrix ICA scripts)
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Configuration Recording Options
In the Citrix:Configuration Recording options, you set the window 
properties and encryption settings for the Citrix client during the recording 
session. 

➤ Encryption Level. The level of encryption for the ICA connection: Basic, 128 
bit for login only, 40 bit, 56 bit, 128 bit, or Use Server Default to use the 
machine’s default. 

➤ Window Size. The size of the client window: 640 x 480, 800 x 600 (default), 
1024 x 768, 1280 x 1024, or 1600 x 1200.
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Recorder Recording Options
The Citrix:Recorder Recording options let you specify how to generate 
window names where the window titles change during recording. You can 
also specify whether to save snapshots of the screens together with the script 
files and whether to generate text synchronization functions.

Window Name

In some applications, the active window name changes while you are 
recording. If you try to replay the script as is, the Vuser uses the original 
window name and the replay may fail. Using the recording options, you can 
specify a naming convention for the windows in which VuGen uses a 
common prefix or common suffix to identify the window.

For example, if the original window’s name is "untitled - Notepad" where the 
name changes during application's run to "my_test - Notepad", you can 
instruct VuGen to use the common suffix only, "Notepad".

The following options are available for generating window names during 
recording. 

➤ Use new window name as is. Set the window name as it appears in the 
window title. (default)
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➤ Use common prefix for new window names. Use the common string from 
the beginning of the window titles, as a window name.

➤ Use common suffix for new window names. Use the common string from 
the end of the window titles, as a name.

Note: Alternatively, you can modify the window names in the actual script 
after recording. In the Script view, locate the window name, and replace the 
beginning or end of the window name with the "*" wildcard notation. 
ctrx_sync_on_window ("My Application*", ACTIVATE, …CTRX_LAST);

Snapshots

The Save snapshots option instructs VuGen to save a snapshot of the Citrix 
client window for each script step, when relevant. It is recommended that 
you enable this option to provide you with a better understanding of the 
recorded actions. Saving snapshots, however, uses more disk space and slows 
down the recording session.
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Code Generation Recording Options
The Recording:Code Generation Recording options let you configure the 
way VuGen captures information during recording.

➤ Use Citrix Agent input in Code Generation. Use the Citrix Agent input to 
generate a more descriptive script with additional synchronization 
functions (enabled by default).

➤ Add text synchronization calls. Adds text synchronization Sync on Text 
steps before each mouse click (disabled by default).

Text synchronization steps that you add manually during the recording are 
not affected by the above settings—they appear in the script even if you 
disable the above options. For more information about adding Sync on Text 
steps during recording, see “Manual Synchronization” on page 264.

The above options are also available for regenerating a script. For 
example, if you originally recorded a script with Add text synchronization 
calls disabled, you can regenerate after to recording to include text 
synchronization. For more information about regenerating your script, see 
“Recording with VuGen” in Volume I-Using VuGen.
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Note:  If you use the VuGen 8.1 or higher to regenerate a script from an 
earlier version of VuGen, the script will no longer be compatible with earlier 
versions—it behaves as if you created a new script.

Login Recording Options
In the Citrix:Login Recording options, you set the connection and login 
information for the recording session. (When working with NFUSE, the 
Login options are not available since the login is done through the Web 
pages.)

You can provide direct login information or instruct VuGen to use an 
existing configuration stored in an ica file.

You must provide the name of the server—otherwise the connection VuGen 
generates a ctrx_connect_server function: 

ctrx_connect_server("steel", "test", "test", "testlab", CTRX_LAST);
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If you do not provide login information, you are prompted for the 
information when the client locates the specified server.

You provide the following user and server information for the Citrix session.

Logon Information. This section contains the login information: 

➤ the User Name for the Citrix user. 

➤ the Password for the Citrix user.

➤ the Domain of the Citrix user.

➤ the Client Name, by which the MetaFrame server identifies the client 
(optional).
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Connection. This section contains the server information: 

➤ Network Protocol. the preferred TCP/IP or TCP/IP+HTTP. Most Citrix 
Servers support TCP/IP. Certain servers, however, are configured by the 
administrators to allow only TCP/IP with specific HTTP headers. If you 
encounter a communication problem, select the TCP/IP+HTTP option.

➤ Server. The Citrix server name. To add a new server to the list, click Add, 
and enter the server name (and its port for TCP/IP + HTTP). Note that 
multiple servers apply only when you specify a Published Application. If 
you are connecting to the desktop without a specific application, then 
list only one server.

➤ Published Application. The name of the Published Application as it is 
recognized on Citrix server. The drop-down menu contains a list of the 
available applications. If you do not specify a published application, 
VuGen uses the server’s desktop. If you added or renamed a published 
application, close the Recording options and reopen them to view the 
new list.

To change the name of the published application on the Citrix client, 
you must make the change on the Citrix Server machine. Choose 
Manage Console > Application and create a new application or rename 
an existing one.

Note that if you do not specify a published application, Citrix load 
balancing will not work. To use load balancing when accessing the 
server’s desktop, register the desktop as a published application on the 
server machine, and select this name from the Published Application 
drop-down list.

Using an ICA File with Connection Parameters

If you have an existing .ica file with all of the relevant configuration 
information, select Use ICA file for connection parameters. In the following 
row, specify the full path of the .ica file. 

For information about the format of an ICA file, see “Understanding ICA 
Files” on page 269 and the Citrix Website, www.citrix.com.
254

http://www.citrix.com
http://www.citrix.com


Chapter 15 • Creating Citrix Vuser Scripts
Setting the Citrix Recording Options

Before recording, you set the desired recording options. 

To set the Citrix recording options:

 1 Open the Recording Options dialog box. Choose Tools > Recording Options 
or click the Options button in the Start Recording dialog box. The keyboard 
shortcut key is CTRL+F7.

 2 Select the Citrix:Login node (only for single protocol Citrix ICA scripts).

➤ If you have an existing ica file with all of the relevant configuration 
information, select Use ICA file for connection parameters. Specify the 
full path of the ica file, or click the Browse button and locate the file on 
the local disk or network. 

➤ If you do not have an ica file, select Define connection parameters. This 
is the default setting. Enter the Connection and Identification 
information. 

 3 Select the Citrix:Configuration node. Choose an encryption level and a 
window size.

 4 Select the Citrix:Code Generation node. To use information from the Citrix 
agent for a more descriptive script, enable the node’s options.

 5 Select the Citrix:Recorder node. Specify how to generate window names for 
windows whose titles change during the recording session. 

 6 To prevent VuGen from saving a snapshot for each step, clear Save 
snapshots.

 7 When recording an NFUSE session, set the Web recording mode to URL-
based. Choose the General:Recording recording option and select URL-
based script.

 8 Click OK to accept the setting and close the dialog box. 
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Setting the Citrix Display Settings

Before running your Citrix Vuser script, you can set several display options 
to be used during replay. Although these options increase the load upon the 
server, they are useful for debugging and analyzing your session. 

To set the Citrix display options:

 1 Open the General Options dialog box. Choose Tools > General Options in 
the main VuGen window. 

 2 Select the Citrix Display tab.

 3 Select Show client during replay to display the Citrix client when replaying 
the Vuser script.

 4 Select Show Bitmap Selection popup to issue a popup message when you 
begin to work interactively within a snapshot. VuGen issues this message 
when you choose the right-click menu option Insert Sync Bitmap or Insert 
Get Text, before you select the bitmap or text. 

 5 Click OK.
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Setting the Citrix Run-Time Settings

After creating a Citrix Vuser script, you set the run-time settings. These 
settings let you control the behavior of the Vuser when running the script. 
Your Citrix run-time settings in the Configuration node should correspond 
to the properties of your Citrix client. These settings will influence the load 
on the server. To view the connection properties, select the icon 
representing the ICA connection in the Citrix Program Neighborhood, and 
choose Properties from the right-click menu. Select the Default Options tab.

Note: Citrix Vusers do not support IP spoofing.

To set the General Run-time settings, see “Configuring Run-Time Settings” 
in Volume I-Using VuGen. To set the Speed Emulation properties, see 
“Configuring Network Run-Time Settings” in Volume I-Using VuGen.  

You can set the Citrix-specific run-time settings in the following areas:

➤ Citrix Configuration Run-Time Settings

➤ Citrix Timing Run-Time Settings

Citrix Configuration Run-Time Settings
The configuration settings relate to the screen latency, data compression, 
disk cache, and queuing of mouse movements.

To set the Configuration Run-Time Settings:

 1 Open the Run-Time settings dialog box. Click the Run-Time Settings button 
on the VuGen toolbar, or choose Vuser > Run-Time Settings.
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 2 Select the Citrix:Configuration node. Specify the General properties: 

Set the desired client configuration options:

➤ SpeedScreen Latency Reduction. The mechanism used to enhance user 
interaction when the network speed is slow. You can turn this mechanism 
on or off, depending on the network speed. The auto option turns it on or 
off based on the current network speed. If you do not know the network 
speed, set this option to Use Server Default to use the machine’s default. 

➤ Use data compression. Instructs Vusers to compress the transferred data. To 
enable this option, select the check box to the left of the option; to disable 
it, clear the check box. You should enable data compression if you have a 
limited bandwidth (enabled by default).

➤ Use disk cache for bitmaps. Instructs Vusers to use a local cache to store 
bitmaps and commonly-used graphical objects. To enable this option, select 
the check box to the left of the option; to disable it, clear the check box. You 
should enable this option if you have a limited bandwidth (disabled by 
default).

➤ Queue mouse movements and keystrokes. Instructs Vusers to create a queue 
of mouse movements and keystrokes, and send them as packets to the server 
less frequently. This setting reduces network traffic with slow connections. 
Enabling this option makes the session less responsive to keyboard and 
mouse movements. To enable this option, select the check box to the left of 
the option; to disable it, clear the check box (disabled by default).
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➤ Sound quality. Specifies the quality of the sound: Use server default, Sound 
off, High sound quality, Medium sound quality, or Low sound quality. If the 
client machine does not have a 16-bit Sound Blaster-compatible sound card, 
select Sound Off. With sound support enabled, you will be able to play 
sound files from published applications on your client machine. 

Citrix Timing Run-Time Settings
The timeout settings relate to the connect and waiting times.

To set the Timing Run-Time Settings:

 1 Open the Run-Time settings dialog box. Click the Run-Time Settings button 
on the VuGen toolbar, or choose Vuser > Run-Time Settings.

 2 Select the Citrix:Timing node. 

 3 Indicate the Connect Time, the time in seconds to wait idly at an established 
connection before exiting. The default is 180 seconds.

 4 Indicate the Waiting Time, the time in seconds to wait idly at a 
synchronization point before exiting. The default is 60 seconds.

To set the waiting time for a specific section of the script, use the Insert > 
Add Step dialog box to insert a Set Waiting Time step. The new waiting time 
applies from the point of insertion until the end of the script or the next Set 
Waiting Time step.

 5 Specify a Typing rate, the delay in milliseconds between keystrokes.

 6 Click OK to accept the settings and close the dialog box. 
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Viewing and Modifying Citrix Vuser Scripts

You can view the contents of your Vuser script in VuGen’s Script view or 
Tree view. For general information about viewing a script, see “Introducing 
Service Test” in Volume I-Using VuGen.  

In Tree view, you can view a Citrix Vuser’s snapshots. Each step has an 
associated snapshot. In addition to displaying the client window, the 
snapshot also highlights the object upon which the action was performed. 

➤ For the Mouse steps, a small pink square indicates where the user clicked.

➤ For Sync on Bitmap, a pink box encloses the bitmap area. 

For Sync on Window, a pink box encloses the entire window. In the 
following example, the snapshot shows the Sync On Window step. 
Notepad’s confirmation box is enclosed by a box indicating the exact 
window on which the operation was performed.

 

260



Chapter 15 • Creating Citrix Vuser Scripts
Note that VuGen saves snapshots as bitmap files in the script’s 
data/snapshots directory. You can determine the name of the snapshot file 
by checking the function’s arguments.

After recording, you can manually add steps to the script in either Script 
view or Tree view. For information about the various script views, see 
“Introducing Service Test” in Volume I-Using VuGen.

In addition to manually adding new functions, you can add new steps 
interactively for Citrix Vusers, directly from the snapshot. Using the right-
click menu, you can add bitmap synchronizations. When the Citrix Agent is 
installed on the Citrix server machine, you can also add text and object 
synchronizations from the right-click menu. For more information, see 
Chapter 16, “Using the LoadRunner Citrix Agent.”

To insert a function interactively:

 1 Click on a step within Tree view. Make sure that a snapshot is visible.

 2 Right-click and choose one of the commands. A dialog box opens with the 
available properties. 

 3 Modify the desired properties and click OK. VuGen inserts the step into your 
script.

Synchronizing Replay

When running a script, it is often necessary to synchronize the actions to 
insure a successful replay. Synchronization refers to the timing of events 
within your script, waiting for windows and objects to become available 
before executing an action. For example, you may want to check whether a 
certain window has opened before attempting to press a button within the 
window. 

VuGen automatically generates functions that synchronize the actions 
during replay. In addition, you can add manual synchronization functions. 

ctrx_sync_on_window("ICA Administrator Toolbar", ACTIVATE, 768, 0, 33, 
573, "snapshot12", CTRX_LAST);
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Automatic Synchronization
During recording, VuGen automatically generates steps that help 
synchronize the Vuser’s replay of the script:

➤ Sync on Window

➤ Sync on Obj Info

➤ Sync on Text

Sync on Window

The Sync On Window step instructs the Vuser to wait for a specific event 
before resuming replay. The available events are Create or Active. The Create 
event waits until the window is created. The Active event waits until the 
window is created and then activated (in focus). Usually VuGen generates a 
function with a CREATE event. If, however, the next instruction is a keyboard 
event, VuGen generates a function with an ACTIVE event. 

In Script view, the corresponding function call to the Sync On Window step 
is ctrx_sync_on_window.

Sync on Obj Info

The Sync On Obj Info step instructs the Vuser to wait for a specific object 
property before resuming replay. The available attributes are Enabled, 
Visible, Focused, Text, Checked, Lines, or Item. The Enabled, Visible, 
Focused, and Checked attributes are boolean values that can receive the 
values true or false. The other attributes require a textual or numerical 
object value. 

A primary objective of this step is to wait for an object to be in focus before 
performing an action upon it.

VuGen automatically generates Sync On Obj Info steps when the Citrix 
agent is installed and the Use Citrix Agent Input in Code Generation option 
is enabled in the Recording options. By default, this Recording option is 
enabled. For more information, see “Code Generation Recording Options” 
on page 251.

ctrx_sync_on_obj_info("Run=snapshot9", 120, 144, TEXT, "OK", 
CTRX_LAST);
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Sync on Text

The Text Synchronization step, Sync On Text, instructs the Vuser to wait for 
a text string to appear at the specified position before continuing. When 
replaying Sync On Text, Vusers search for the text in the rectangle whose 
modifiable coordinates are specified in the step’s properties.

With an agent installation (see Chapter 16, “Using the LoadRunner Citrix 
Agent”), you can instruct VuGen to automatically generate a text 
synchronization step before each mouse click or double-click. By default, 
automatic text synchronization is disabled. For information on how to 
enable this Recording option, see “Code Generation Recording Options” on 
page 251.

Note, that even if you record a script with the option disabled, if you enable 
the option and regenerate the script, VuGen will insert text synchronization 
calls throughout the entire script. For more information, see “Code 
Generation Recording Options” on page 251.

You can manually add text synchronizations for individual steps both 
during and after recording as described in “Manual Synchronization” on 
page 264.

In Script view, the corresponding function call to the Sync On Text step is 
ctrx_sync_on_text_ex.

The following segment shows a ctrx_sync_on_text_ex function that was 
recorded during a Citrix recording with the HP Citrix Agent installed and 
text synchronization enabled.

For more information on this function, refer to the Online Function Reference 
(Help > Function Reference).

ctrx_sync_on_window ("ICA Seamless Host Agent", ACTIVATE, 0, 0,391,224, 
"snapshot1", CTRX_LAST);

ctrx_sync_on_text_ex (196, 198, 44, 14, "OK", "ICA Seamless Host 
Agent=snapshot2", CTRX_LAST);

ctrx_obj_mouse_click ("<class=Button text=OK>", 196, 198, LEFT_BUTTON, 0, "ICA 
Seamless Host Agent=snapshot2", CTRX_LAST);
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Manual Synchronization
In addition to the automatic synchronization, you can manually add 
synchronization both during and after recording. A common use of this 
capability is where the actual window did not change, but an object within 
the window changed. Since the window did not change, VuGen did not 
detect or record a Sync on Window. 

For example, if you want the replay to wait for a specific graphic image in a 
browser window, you insert manual synchronization. Or, if you are 
recording a large window with several tabs, you can insert a synchronization 
step to wait for the new tab’s content to open.

The following section describes synchronizing on a bitmap. For information 
on adding a Sync on Text manually, see “Retrieving Text” on page 281.

Manually Adding Synchronization During Recording

To add synchronization during recording, you use the floating toolbar. The 
Sync On Bitmap function lets you to mark an area within the client window 
that needs to be in focus before resuming replay.

To mark a bitmap area for synchronization:

 1 Click the Insert Sync on Bitmap button on the toolbar.

 2 Mark a rectangle around the desired bitmap. In Tree view, VuGen generates a 
Sync on Bitmap step after the current step. In Script view, VuGen generates a 
ctrx_sync_on_bitmap function with the selected coordinates as arguments. 

During replay, Vusers look for the bitmap at the specified coordinates, and 
wait until it is available before resuming the test.

ctrx_sync_on_bitmap(93, 227, 78, 52, 
"66de3122a58baade89e63698d1c0d5dfa", CTRX_LAST);

Sync on Bitmap
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Manually Adding Synchronization After Recording

You can also add synchronization after the recording session. To add a 
synchronization step, right-click in the snapshot window and choose a 
synchronization option:

➤ Sync on Bitmap. Waits until a bitmap appears

➤ Sync on Obj Info. Waits until an object’s attributes have the specified values 
(agent installations only)

➤ Sync on Text. Waits until the specified text is displayed (agent installations 
only)

During recording, the bitmaps generated for the Sync on Bitmap step are 
saved under the script’s data/snapshots directory. If synchronization fails 
during replay, VuGen generates a new bitmap that you can examine to 
determine why synchronization failed. VuGen displays both bitmaps in the 
Failed Bitmap Synchronization dialog box. For more information, see 
“Failed Bitmap Synchronization” on page 268.

The bitmap name has the format of sync_bitmap_<hash_value>.bmp. It is 
stored in the script’s output directory, or for a scenario or profile, wherever 
the output files are written.

Additional Synchronizations
In addition, you can add several other steps that affect the synchronization 
indirectly:

➤ Setting the Waiting Time

➤ Checking if a Window Exists or Closed

➤ Waiting for a Bitmap Change

Setting the Waiting Time

The Set Waiting Time step sets a waiting time for the other Citrix 
synchronization functions. This setting applies to all functions that follow it 
within the script. For example, if your Sync on Window steps are timing out, 
you can increase the default timeout of 60 seconds to 180.

To insert this step, choose Insert > Add Step > Set Waiting Time.
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Checking if a Window Exists or Closed

The Win Exist step checks if a window is visible in the Citrix client. By 
adding control flow statements, you can use this function to check for a 
window that does not always open, such as a warning dialog box. In the 
following example, ctrx_win_exist checks whether a browser was launched. 
The second argument indicates how long to wait for the browser window to 
open. If it did not open in the specified time, it double-clicks its icon.

To insert this step, choose Insert > Add Step > Win Exist.

Another useful application for this step is to check if a window has been 
closed. If you need to wait for a window to close, you should use a 
synchronization step such as UnSet Window or ctrx_unset_window.

For detailed information about these functions, refer to the Online Function 
Reference (Help > Function Reference).

Waiting for a Bitmap Change

In certain cases, you do not know what data or image will be displayed in an 
area, but you do expect it to change. To emulate this, you can use the Sync 
on Bitmap Change step or its corresponding function, 
ctrx_sync_on_bitmap_change. Perform a right-click in the snapshot, and 
choose an Insert Sync on Bitmap from the right-click menu. VuGen inserts 
the step or function at the location of the cursor.

The syntax of the functions is as follows:

if (!ctrx_win_exist("Welcome",6, CTRX_LAST))
ctrx_mouse_double_click(34, 325, LEFT_BUTTON, 0, CTRX_LAST)

ctrx_sync_on_bitmap (x_start, y_start, width, height, hash, CTRX_LAST);
ctrx_sync_on_bitmap_change (x_start, y_start, width, height, 

[initial_wait_time,] [timeout,] 
[initial_bitmap_value,] CTRX_LAST);
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The following optional arguments are available for 
ctrx_sync_on_bitmap_change: 

➤ initial wait time value—when to begin checking for a change.

➤ a timeout—the amount of time in seconds to wait for a change to occur 
before failing.

➤ initial bitmap value—the initial hash value of the bitmap. Vusers wait until 
the hash value is different from the specified initial bitmap value.

In the following example, the recorded function was modified and assigned 
an initial waiting time of 300 seconds and a timeout of 400 seconds.

Note: If you are using Sync on Bitmap, make sure that the Configuration 
settings in the Controller, Load Generator machine, and screen are the 
same. Otherwise, VuGen may be unable to find the correct bitmaps during 
replay. For information on how to configure the client settings, see 
“Configuration Recording Options” on page 248.

ctrx_sync_on_bitmap_change(93, 227, 78, 52, 
300,400, "66de3122a58baade89e63698d1c0d5dfa",CTRX_LAST);
267



Chapter 15 • Creating Citrix Vuser Scripts
Failed Bitmap Synchronization
The Failed Bitmap Synchronization dialog box opens when there is a 
mismatch between the Recording and Replay snapshots during script replay.

You can indicate whether or not you want to mark the mismatch as an error 
or adopt the changes.

When this dialog box opens, click on one of the following buttons to 
proceed:

➤ Stop. Consider the mismatch between the snapshots to be an error. This 
error will be handled like all other errors and halt the execution. You can 
specify Continue on Error for a specific function as described in 
“Continuing on Error” on page 274.

➤ Continue. Accept the mismatch and use both the original and new 
snapshots as a basis for comparison between screens during future replays. If 
replay returns either one of the bitmaps, the Vuser will not fail.
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Understanding ICA Files

Citrix ICA client files are text files that contain configuration information 
for the applications accessed through the Citrix client. These files must have 
an .ica extension and must conform to the following format:

Note: When you load an ICA file using the Recording Options, VuGen saves 
the file together with your script, eliminating the need to copy the ICA file 
to each injector machine. 

[WFClient]
Version=
TcpBrowserAddress=
 
[ApplicationServers]
AppName1=
 
[AppName1]
Address=
InitialProgram=#
ClientAudio=
AudioBandwidthLimit=
Compress=
DesiredHRES=
DesiredVRES=
DesiredColor=
TransportDriver=
WinStationDriver=

Username=
Domain=
ClearPassword=
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The following example shows a sample ICA file for using Microsoft Word on 
a remote machine through the Citrix client:

For more information, see the Citrix Website www.citrix.com.

Using Citrix Functions

During a Citrix recording session, VuGen generates functions that emulate 
the communication between a client and a remote server. The generated 
functions have a ctrx prefix. You can also manually edit any of the 
functions into your Vuser script after the recording session. For example, 
ctrx_obj_mouse_click emulates a mouse click for a specific object.

For more information about the ctrx functions, refer to the Online Function 
Reference (Help > Function Reference). 

[WFClient]
Version=2
TcpBrowserAddress=235.119.93.56
 
[ApplicationServers]
Word=
 
[Word]
Address=Word
InitialProgram=#Word
ClientAudio=On
AudioBandwidthLimit=2
Compress=On
DesiredHRES=800
DesiredVRES=600
DesiredColor=2
TransportDriver=TCP/IP
WinStationDriver=ICA 3.0

Username=test
Domain=user_lab
ClearPassword=test
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Note that for the functions that specify a window name, you can use the 
wildcard symbol, an asterisk (*). You can place the wildcard at the 
beginning, middle, or end of the string.

Tips for Replaying and Troubleshooting Citrix Vuser Scripts

The following sections provide guidelines and tips for Citrix Vusers in the 
following areas:

➤ Replay Tips

➤ Debugging Tips

For recording tips, see “Recording Tips” on page 245.

Replay Tips

Wildcards

You can use wildcards (*) in defining window names. This is especially 
useful where the window name may change during replay, by its suffix or 
prefix. 

In the following example, the title of the Microsoft Internet Explorer 
window was modified with a wildcard.

For more information, see the Function Reference (Help > Function 
Reference).

Set Initialization Quota

To prevent overloading by multiple Vusers while connecting, set an 
initialization quota of 4 to 10 Vusers (depending on the capacity of the 
server) or apply ramp-up initialization using the Scheduler. 

ctrx_mouse_click(573, 61, LEFT_BUTTON, 0, 
"Welcome to MSN.com - Microsoft Internet Explorer");
ctrx_mouse_click(573, 61, LEFT_BUTTON, 0, 
"* - Microsoft Internet Explorer");
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Enable Think Time

For best results, do not disable think time in the Run-Time settings. Think 
time is especially relevant before the ctrx_sync_on_window and 
ctrx_sync_on_bitmap functions, which require time to stabilize.

Regenerate Script

During recording, VuGen saves all of the agent information together with 
the script. By default, it also includes this information in the script, 
excluding the Sync On Text steps. If you encounter text synchronization 
issues, then you can regenerate the script to include the text 
synchronization steps. 

In addition, if you disabled the generation of agent information in the 
Recording options, you can regenerate the script to include them.

Regenerating scripts is also useful for scripts that you manually modified. 
When you regenerate the script, VuGen discards all of your manual changes 
and reverts back to the originally recorded version.

To regenerate a script, choose Tools > Regenerate and select the desired 
options. For more information about regenerating scripts, see “Regenerating 
a Vuser Script”in Volume I-Using VuGen.

Set Consistency Between Machines

If you intend to replay the script on another machine, make sure that the 
following items are consistent between the record and replay machines: 
Window Size (resolution), Window Colors, System Font and the other 
Default Options settings for the Citrix client. These settings affect the hash 
value of bitmaps, and inconsistencies may cause replay to fail. To view the 
Citrix Client settings, select an item from the Citrix program group and 
choose Application Set Settings or Custom Connection Settings from the 
right-click menu. Select the Default Options tab. 
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Increasing the Number of Vusers per Load Generator Machine

Load Generator machines running Citrix Vusers may be limited in the 
number of Vusers that can run, due to the graphic resources available to that 
machine, also known as the GDI (Graphics Device Interface). To increase the 
number of Vusers per machine, you can open a terminal server session on 
the machine which acts as an additional injector machine.

The GDI count is Operating System dependent. The actual GDI (Graphics 
Device Interface) count for a heavily loaded machine using LoadRunner is 
approximately 7,500. The maximum available GDI on Windows 2000 
machines is 16,384.

For more information on creating a terminal server session, see the Terminal 
Services topics in the HP LoadRunner Controller. 

Note: By default, sessions on a terminal server use a 256-color set. If you 
intend to use a terminal session for load testing, make sure to record on 
machines with a 256-color set. 

Debugging Tips

Single Client Installation

If you are unsuccessful in recording any actions in your Citrix session, verify 
that you have only one Citrix client installed on your machine. To verify 
that only one client is installed, open the Add/Remove Programs dialog box 
from the Control Panel and make sure that there is only one entry for the 
Citrix ICA client.

Add Breakpoints

Add breakpoints to your script in VuGen to help you determine the 
problematic lines of code.
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Synchronize Your Script

If replay fails, you may need to insert synchronization functions into your 
script to allow more time for the desired windows to come into focus. 
Although you can manually add a delay using lr_think_time, it is 
recommended that you use one of the synchronization functions discussed 
in “Synchronizing Replay” on page 261.

Continuing on Error

You can instruct Vusers to continue running even after encountering an 
error, such as not locating a matching window. You specify Continue on 
Error for individual steps. 

This is especially useful where you know that one of two windows may 
open, but you are unsure of which. Both windows are legal, but only one 
will open. 

To indicate Continue on Error:

In Tree view, right-click on the step and choose Properties. In the Continue 
on Error box, select the CONTINUE_ON_ERROR option.

In Script view, locate the function and add CONTINUE_ON_ERROR as a 
final argument, before CTRX_LAST.

This option is not available for the following functions: ctrx_key, 
ctrx_key_down, ctrx_key_up, ctrx_type, ctrx_set_waiting_time, 
ctrx_save_bitmap, ctrx_execute_on_window, and ctrx_set_exception.

Extended Log

You can view additional replay information in the Extended log. To do this, 
enable Extended logging in the Run-Time settings (F4 Shortcut key) Log tab. 
You can view this information in the Replay Log tab or in the output.txt file 
in the script’s directory. 

Snapshot Bitmap

When an error occurs, VuGen saves a snapshot of the screen to the script’s 
output directory. You can view the bitmap to try to determine why the error 
occurred.
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During recording, the bitmaps generated for the ctrx_sync_on_bitmap 
function are saved under the script’s data directory. The bitmap name has 
the format of hash_value.bmp. If synchronization fails during replay, the 
generated bitmap is written to the script’s output directory, or if you are 
running it in a scenario, to wherever the output files are written. You can 
examine the new bitmap to determine why synchronization failed.

Show Vusers

To show Vusers during a scenario, enter the following in the Vuser 
command line box: -lr_citrix_vuser_view. In the Controller, open the Vuser 
Details dialog box and click More to expand the dialog box. Note that this 
will affect the scalability of the test, so this should only be done to examine 
a problematic Vuser’s behavior.

To reduce the effect on the script’s scalability, you can show the details for 
an individual Vuser by adding the Vuser’s ID at the end of the command 
line: -lr_citrix_vuser_view <VuserID>.

To open multiple Vusers, place a comma-separated list of IDs after the 
command line. Do not use spaces, but you may use commas or dashes. For 
example, 1,3-5,7 would show Vusers 1,3,4,5, and 7, but would not show 
Vuser 2, 6 or any Vuser with an ID higher than 7.

View Recording and Replay Logs

To see detailed information about the recording, view the Recording and 
Replay logs in the Output window. To open the Output window, choose 
View > Output Window. 
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To view the Recording Log, select the Recording Log tab. VuGen displays a 
detailed log of all functions that were generated by the recording and the 
warning messages and errors that were issued during that time.

 

To view the Replay Log, select the Replay Log tab. VuGen provides a 
description of all actions performed by VuGen and any warnings and errors 
that were issued during the replay.

To go directly to the step in the script associated with the log message, 
double-click on the message in the Replay log. 

Note that the extent of information in the Replay log depends on the Log 
Run-Time settings. For more information, see “Configuring Run-Time 
Settings” in Volume I-Using VuGen.
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Using the LoadRunner Citrix Agent

The LoadRunner Citrix Agent is an optional utility that you can install on 
the Citrix server. It provides you with several important benefits that can 
enhance your script:

This chapter includes:

 ➤  About the LoadRunner Citrix Agent on page 277

 ➤  Benefitting From the Citrix Agent on page 278

 ➤  Installation on page 283

 ➤  Effects and Memory Requirements of the Citrix Agent on page 284

 ➤  Sample Script on page 284

The following information only applies to the Citrix ICA protocol.

About the LoadRunner Citrix Agent

The LoadRunner Citrix Agent is an optional utility that you can install on 
the Citrix server. It is provided on the product’s CD and you can install it on 
any Citrix server.

It provides you with the following benefits:

➤ Intuitive and readable scripts

➤ Built-in synchronization

➤ Detailed Information about all objects 

➤ Ability to work interactively within the Client window
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The agent provides Load Generator machines with detailed information 
about objects and events in the client window. It also lets you work 
interactively within the client screen to add object-specific steps.

Benefitting From the Citrix Agent

The Citrix agent provides enhancements in the following areas:

➤ Object Details. Provides detailed information about individual objects in the 
Citrix client window.

➤ Active Object Recognition. Shows you which objects in the client window 
are recognized by VuGen.

➤ Expanded Right-Click Menu. Additional right-click menu items that allow 
you to add synchronization, verification, and text retrieval steps.

➤ Retrieving Text. Capability to insert text searches to your script.

Object Details 
When the Citrix agent is installed, VuGen records specific information 
about the active object instead of a general information about the action. 
For example, VuGen generates Obj Mouse Click and Obj Mouse Double Click 
steps instead of Mouse Click and Mouse Double Click that it generates 
without the agent.

The following example shows the same mouse-click action recorded with 
and without the agent installation. Note that with an agent, VuGen 
generates ctrx_obj_xxx functions for all of the mouse actions, such as click, 
double-click and release.

/* WIthout Agent Installation */
ctrx_mouse_click(573, 61, LEFT_BUTTON, 0, test3.txt - Notepad);

/* WIth Agent Installation */
ctrx_obj_mouse_click("<text=test3.txt - Notepad class=Notepad>" 573, 

61, LEFT_BUTTON, 0, test3.txt - Notepad=snapshot21, CTRX_LAST);
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In the example above, the first argument of the ctrx_obj_mouse_click 
function contains the text of the window’s title and the class, Notepad. Note 
that although the agent provides additional information about each object, 
Vusers only access objects by their window name and its coordinates. 

Active Object Recognition
The agent installation lets you see which objects in the client window are 
detected by VuGen. This includes all Windows Basic Objects such as edit 
boxes, buttons, and item lists in the current window. 

To see which objects were detected, you move your mouse through the 
snapshot. VuGen highlights the borders of the detected objects as the mouse 
passes over them.

In the following example, the Yes button is one of the detected objects.
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Expanded Right-Click Menu
When you click within a snapshot, you can insert several functions into the 
script using the right-click menu. When no agent is installed, you are 
limited to the Insert Mouse Click, Insert Mouse Double Click, Insert Sync on 
Bitmap and Insert Get Bitmap Value. If you are using a 256-color set, the 
Insert Sync on Bitmap and Get Bitmap Value steps are not available from the 
right-click menu.

When an agent is installed, the following additional options are available 
from the right-click menu of window in focus: Insert Get Text, Insert Sync 
on Text, Insert Obj Get Info, and Insert Sync on Obj Info. These commands 
are interactive—when you insert them into the script, you mark the object 
or text area in the snapshot. 

The Obj Get Info and Sync on Obj Info steps provide information about the 
state of the object: ENABLED, FOCUSED, VISIBLE, TEXT, CHECKED, and 
LINES. The Insert Sync on Obj Info step, generated as a 
ctrx_sync_on_obj_info function, instructs VuGen to wait for a certain state 
before continuing. The Insert Obj Get Info step, generated as a 
ctrx_get_obj_info function, retrieves the current state of any object 
property. The Insert Sync on Text and Get Text steps are discussed in the 
section “Retrieving Text” on page 281.

In the following example, the ctrx_sync_on_obj_info function provides 
synchronization by waiting for the Font dialog box to come into focus. 

Utilizing VuGen’s ability to detect objects, you can perform actions on 
specific objects interactively, from within the snapshot. 

To insert a function interactively using the agent capabilities:

 1 Click at a point within the tree view to insert the new step. Make sure that a 
snapshot is visible.

 2 Click within the snapshot.

 3 To mark a bitmap, right-click on it and choose Insert Sync on Bitmap.

ctrx_sync_on_obj_info("Font", 31, 59, FOCUSED, "TRUE", CTRX_LAST);
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VuGen issues a message indicating that you need to mark the desired area by 
dragging the cursor. Click OK and drag the cursor diagonally across the 
bitmap that you want to select.

When you release the mouse, VuGen inserts the step into the script after the 
currently selected step. 

 4 For all other steps, move your mouse over snapshot objects to determine 
which items are active—VuGen highlights the borders of active objects as 
the mouse passes over them. 

Right-click and choose one of the Insert commands. A dialog box opens 
with the step’s properties. 

Set the desired properties and click OK. VuGen inserts the step into your 
script. 

Retrieving Text
With the agent installed, VuGen lets you save standard text to a buffer. Note 
that VuGen can only save true text—-not a graphical representation of text 
in the form of an image. 

You save the text using the Sync On Text step either during or after 
recording.
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To retrieve a text string: 

 1 During recording: Click the Insert Sync On Text button on the toolbar.

After recording: Choose Insert Sync On Text from the snapshot’s right-click 
menu. The Bitmap Selection dialog opens, indicating that you are inserting 
a synchronization or informational function and that you need to mark an 
area.

 2 Click at the corner of the text that you want to capture, drag the mouse 
diagonally to mark the text you want to save, and release the mouse button.

 3 If you add the step during recording, VuGen places a Insert Sync On Text 
step at the current location and saves the text to a buffer. 

If your are adding the step after recording, VuGen prompts you with the 
Sync On Text Ex dialog box, allowing you to manually specify text.

VuGen marks the saved text with a pink box. In the following snapshot, the 
Insert Sync On Text step retrieved the text This.

Bottom callout 
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Installation

The installation file for the Citrix Agent is located on the LoadRunner CD 
#2, under the Additional Components\CitrixAgent folder. The disk space 
required for installing the Citrix agent is 25 MBs. 

Note that the agent should only be installed on your Citrix server 
machine—not Load Generator machines.

If you are upgrading a Citrix Agent, make sure to uninstall the previous 
version before installing the next one (see uninstallation instructions 
below).

To install the Citrix Agent:

 1 If your server requires administrator permissions to install software, log in as 
an administrator to the server.

 2 Locate the installation file, CitrixAgent.exe, on the LoadRunner CD #2 in 
the Additional Components\CitrixAgent folder.

Note: After installation the agent will only be active for LoadRunner 
invoked Citrix sessions—it will not be active for users who start a Citrix 
session without LoadRunner.

To disable the Citrix Agent, you must uninstall it.

To uninstall the Citrix Agent:

 1 If your server requires administrator privileges to remove software, log in as 
an administrator to the server.

 2 Choose Start > LoadRunner Citrix Agent > Uninstall LoadRunner Citrix 
Agent and follow the uninstall instructions.

Alternatively, open Add/Remove Programs in the server machine’s Control 
Panel. Select LoadRunner Citrix Agent and click Change/Remove.
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Effects and Memory Requirements of the Citrix Agent

When you run Citrix Vusers with the agent installed, each Vuser runs its 
own process of ctrxagent.exe. This results in a slight reduction in the 
number of Vusers that can run on the server machine (about 7%). 

The memory requirements per Citrix ICA Vuser (each Vuser runs its own 
ctrxagent.exe process) is approximately 4.35 MB. To run 25 Vusers, you 
would need 110 MBs of memory.

Sample Script

The following script illustrates a true Citrix ICA session with an agent.

vuser_init ()
{

ctrx_set_connect_opt (NETWORK_PROTOCOL, "TCP/IP + HTTP");
ctrx_connect_server ("Plato", "test", lr_decrypt("428c4445a14409b9"), "QAlab");
ctrx_wait_for_event ("LOGON");
ctrx_sync_on_window ("ICA Seamless Host Agent", ACTIVATE, 0, 0,391,224, 

"snapshot1", CTRX_LAST);
ctrx_sync_on_text (196, 198, "OK", TEXT, "ICA Seamless Host Agent=snapshot2", 

CTRX_LAST);
ctrx_obj_mouse_click ("<class=Button text=OK>", 196, 198, LEFT_BUTTON, 0, "ICA 

Seamless Host Agent=snapshot2", CTRX_LAST);
lr_think_time (73);

return 0;
}
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Creating Remote Desktop Protocol Vuser 
Scripts

VuGen allows you to record the actions of a client communicating with its 
server using the Microsoft Remote Desktop (RDP) protocol. The resulting 
script is called a RDP Vuser script.

This chapter includes:

 ➤  About Microsoft Remote Desktop Protocol (RDP) Vuser Scripts on page 286

 ➤  Recording Tips on page 286

 ➤  Understanding The RDP Recording Options on page 287

 ➤  Recording a RDP Vuser Script on page 291

 ➤  Understanding the RDP Run-Time Settings on page 293

 ➤  Running RDP Vuser Scripts on page 295

 ➤  Working with Clipboard Data on page 296

 ➤  Synchronizing Replay on page 298

The following information only applies to Microsoft Remote Desktop 
Protocol (RDP) Vuser scripts.
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About Microsoft Remote Desktop Protocol (RDP) Vuser 
Scripts

The Microsoft Remote Desktop Protocol (RDP) allows users to connect to a 
remote computer. For example, you can use RDP to connect to a central and 
powerful server for working on specific business applications or graphic 
terminals. This provides the user with the same look and feel as if they are 
working on a standalone PC.

Note: RDP versions 5.1 and later have an Experience tab that allows you to 
set various options. This tab is not supported by VuGen recording. All 
options are set to the ON position.

Recording Tips

When recording a script, be sure to follow these guidelines in order to create 
an effective script.

Single vs. Multi-Protocol Scripts

When creating a new script, you may create a single protocol or multi-
protocol script. For example, to record both RDP traffic and Web responses, 
create a multi-protocol script for RDP and Web to enable the recording of 
both protocols. For more information, see “Recording with VuGen” in 
Volume I-Using VuGen. 

Record into Appropriate Sections

Record the connection process into the vuser_init section, and the closing 
process into the vuser_end section. This will prevent you from performing 
iterations on the connecting and disconnecting. For more information 
about recording into sections, see “Vuser Script Sections” on page 76.
286



Chapter 17 • Creating Remote Desktop Protocol Vuser Scripts
Run a Clean Session

When recording a session, make sure to perform the complete business 
process, starting with the connection and ending with the cleanup. End 
your session at a point from where you could start the entire process from 
the beginning. Do not leave any client or application windows open. 

You should also configure your terminal server to end disconnected 
sessions. Select Administrative Tools > Terminal Services Configuration > 
Connection Properties > Sessions > Override User Settings and set the server 
to end disconnected sessions.

Explicit Clicks

When opening expanded menu options, click explicitly on each option—do 
not depend on the expanding menu. For example, when choosing Start > 
Programs > Microsoft Word, be sure to click on the word Programs.

Understanding The RDP Recording Options

Before recording the script, you can configure how the RDP activities are 
recorded and how the script is generated. You do this by setting the 
Recording Options.

You can set the recording options in the following areas:

➤ “RDP Login Options” on page 288

➤ “RDP Code Generation Options” on page 289
287



Chapter 17 • Creating Remote Desktop Protocol Vuser Scripts
RDP Login Options
In the RDP Login Options, you indicate how to run the Terminal Services 
client session.

➤ Run Client. Run the Terminal Services client.

➤ Connection File. Run the Terminal Services client using an existing 
connection file. The file should have an *.rdp extension. You can browse for 
the file on your file system or network.

➤ Default Connect File. Use the Default.rdp file in your document’s directory 
to connect.
288



Chapter 17 • Creating Remote Desktop Protocol Vuser Scripts
RDP Code Generation Options
The Code Generation settings control the way VuGen creates a script—the 
level of detail, triggers, and timeouts.

Yo

You can set the following options:

➤ Script Level. The level of the script and the type of API functions to use 
when generating the script. The available levels are High, Low or Raw. 

➤ High. Generate high level scripts. Keyboard events are translated to 
rdp_type calls. Two consecutive mouse clicks with the same 
coordinates are translated as a double-click.

➤ Low. Generate low level scripts. Key up/down events are translated 
into rdp_key events. Modifier keys (Alt, Ctrl, Shift) are used as a 
KeyModifier parameter for other functions. Mouse up/down/ move 
events are translated to mouse click/drag events.
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➤ Raw. Generates a script on a raw level, by extracting input events from 
network buffers and generating calls in their simplest form: key 
up/down, mouse up/down/move. The KeyModifier parameter is not 
used.

➤ Generate Mouse Movement Calls. Generates rdp_mouse_move calls in the 
script. When enabled, this option significantly increases the script size 
(disabled by default). 

➤ Generate Raw Mouse Calls. If enabled, VuGen generates 
rdp_mouse_button_up/down calls as if the script level was set to Raw. 
Keyboard calls will still be generated according to the script level. If 
disabled, VuGen generates Mouse calls according to the script level. If the 
script level is set to Raw, this option is ignored (disabled by default).

➤ Generate Raw Keyboard Calls. If enabled, VuGen generates 
rdp_raw_key_up/down calls as if the script level was set to Raw. Mouse 
calls will still be generated according to the script level. If disabled, VuGen 
generates Keyboard calls according to the script level. If the script level is set 
to Raw, this option is ignored (disabled by default).

➤ Always Generate Connection Name. If selected, function call will contain 
the ConnectionName parameter. If not selected, the functions will only 
contain this parameter if more than a single rdp_connect_server appears in 
the script (disabled by default).

➤ Generate Automatic Sync Points for Mouse. Generates sync_on_image 
functions before mouse clicks and drags (enabled by default).

➤ Sync Radius. The number of pixels to include on each side of the image 
synchronization point. The default is 20 pixels.

➤ Double-click Timeout (msec). The maximum time in milliseconds between 
two consecutive mouse button clicks, to be considered a double-click. The 
default is 500 milliseconds.

➤ Snapshots’ Prefix. The prefix to generate for all snapshots file names, for the 
current script. This is useful when merging scripts—you can specify a 
different prefix for each script. The default is snapshot_.

➤ Clipboard Parameters’ Prefix. The prefix to add before all clipboard 
parameters for the current script. This is useful when merging scripts—you 
can specify a different prefix for each script.
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➤ Correlate clipboard parameters. Replaces the recorded clipboard text sent 
by the user, with the correlated parameter containing the same text as 
received from the server.

Code Generation Notes

➤ You can also access the RDP:Code Generation by clicking the Options 
button in the Regenerate Script dialog box.

➤ Each mouse and keyboard function contains the step and image name in 
the following format:

➤ A ‘Step Description=XXX’ parameter in the function call. This is used for 
log output and for tree view. You can freely change this argument.

➤ A ‘Snapshot=XXX’ parameter in the function call. This name points 
directly to the image file on the disk and should not be modified.

➤ All keyboard or mouse actions are generated as functions in the script.

Recording a RDP Vuser Script

Before recording, you set the desired recording options as described above.

Note: Whenever recording an RDP script, make sure that you record the act 
of logging off the server. This ensures that when you run the script you will 
begin with a new session.

At any point during recording, you can choose to mark an area of the 
remote desktop to synchronize upon. The image is stored on disk as 
snapshot_xxx.png where xxx is a sequential index that starts at 1 and is 
increased by 1 for each image and includes images from other steps, for 
example, mouse clicks. A matching function appears in the script at this 
point during code generation.
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To create a RDP Vuser script:

 1 Choose File > New or click the New button. The New Virtual User dialog box 
opens.

 2 Select Microsoft Remote Desktop Control Protocol (RDP). The Start 
Recording dialog box opens.

 3 Click Options to set the Recording Options. For more information, see 
“Understanding The RDP Recording Options” on page 287.

 4 Select the RDP: Login node. Choose one of the session options: Run Client, 
Connection File, or Default Connection File.

 5 Select the RDP: Code Generation node and enable the desired options.

 6 During recording to select a screen region for synchronization, click the 
Sync on image button on the recording toolbar and indicate an area for 
synchronization.

Note: You can also add an image synchronization after recording the script. 
Right-click on the image snapshot and select Insert Sync On Image from the 
menu.

 7 Stop recording and save the script.
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Understanding the RDP Run-Time Settings

After creating a RDP Vuser script, you set the run-time settings. These 
settings let you control the behavior of the Vuser when running the script.

You can set the RDP-specific run-time settings in the following areas:

➤ RDP Configuration Run-Time Settings

➤ RDP Synchronization Run-Time Settings

RDP Configuration Run-Time Settings
You use the RDP Configuration settings to set the behavior of the (virtual) 
RDP client.

➤ RDP Client Version Emulation. The version of RDP packets to produce during 
replay: As Recorded, or a specific version number. 

➤ Enable RDP caching. Support data caching orders in RDP (enabled by 
default).

➤ Window size. The size of the window in which the applications are run: 
As Recorded, or a specific size. 

➤ Color Resolution. The color resolution settings for the replay: As 
Recorded, or a specific resolution.

➤ Start the following program on connection. Invoke the specified 
application after opening the RDP connection. Specify the following 
information: Program path and file name and optionally, Start in folder.
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RDP Synchronization Run-Time Settings
RDP Synchronization settings indicate the default timing values for various 
functions.

➤ Default Sync Timeout (sec). The time in seconds to wait for synchronization 
operations. Enter a value between 0 and 1000. The default value is 60.

➤ Default Image Sync Tolerance. The tolerance level for performing 
synchronization on images. Choose one of the options: Exact, Low (default), 
Medium, or High. High has the most tolerance for changes and mismatches. 
Low requires a match of approximately 95 per cent, Medium requires a 
match of approximately 85 per cent, High requires a match of 
approximately 70 per cent, and Exact requires an 100 per cent match.

➤ Default input Origin. The default origin for input operations:

➤ Recorded. Use coordinates as recorded. This is the default selection.

➤ Synched. Add offsets from the last synchronization function to the 
recorded coordinates.

➤ Default Offset Addition. Adds the offset of images that moved during 
synchronization, to all subsequent function calls (No by default).
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➤ Fail image synchronization step on timeout. Instructs Vusers how to proceed 
when images are not found. Yes sets a Fail status and Vusers follow the 
Continue on Error setting. No returns an LR_NOT_FOUND flag and the 
script continues.

➤ Disable Synchronization Failure Dialog. When selected, it prevents the 
Synchronization Failure Dialog box from opening (not selected by default).

➤ Typing Speed (msec/char). The time in milliseconds for sending 
consecutive characters in keyboard commands. Enter a value between 0 and 
1000. The default value is 150.

Running RDP Vuser Scripts

Before running an RDP script, you can set the run-time settings to customize 
the behavior of the script. You can set general run-time settings for all 
protocols, such as think time, iterations, pacing, and logging, as described in 
“Configuring Run-Time Settings” in Volume I-Using VuGen.

For RDP-specific settings, see above.

To run an RDP script:

 1 Open the Run-Time settings dialog box. Click the Run-Time Settings button 
on the toolbar, or choose Vuser > Run-Time Settings.

 2 Select the Configuration node. Choose the desired settings.

 3 Select the Synchronization node. Choose the desired settings.

 4 Click OK to accept the run-time settings and close the dialog box.

 5 Click the Run button or select Vuser > Run.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 
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Working with Clipboard Data

VuGen allows you to copy and paste the textual contents of a clipboard 
during an RDP session. You can copy them locally and paste them remotely, 
or vice versa—copy them from the remote machine and paste them locally. 
The copying of text is supported in TEXT, LOCALE, and UNICODE formats. 

VuGen generates separate functions when providing or saving the clipboard 
data.

The following example illustrates a copy operation on a local machine and a 
paste on a remote machine:

//Notifies the Remote Desktop that new data is available in the Local machine’s
//clipboard.The data can be provided in three formats: TEXT, UNICODE and LOCALE
rdp_notify_new_clipboard_data(
"StepDescription=Send local clipboard formats 1",
"Snapshot=snapshot1.inf",
"FormatsList=RDP_CF_TEXT|RDP_CF_UNICODE|RDP_CF_LOCALE",
RDP_LAST );

rdp_key(
"StepDescription=Key Press 2", 
"Snapshot=snapshot_9.inf", 
"KeyValue=V", 
"KeyModifier=CONTROL_KEY", 
RDP_LAST );

//Provides clipboard data to the Remote Desktop when it requests the data.
rdp_send_clipboard_data(
"StepDescription=Set Remote Desktop clipboard 1",
"Snapshot=snapshot1.inf",
"Timeout=20",
REQUEST_RESPONSE, "Format=RDP_CF_UNICODE", "Text=text for clipboard",
RDP_LAST);
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This example illustrates a copy operation on a remote machine and a paste 
on a local machine:

Normally, the Remote Desktop clipboard data is saved in UNICODE format. 
If the Remote Desktop requests data in the TEXT or LOCALE formats, the 
rdp_send_clipboard_data function automatically converts the content of 
MyParam from UNICODE into the requested format and sends it to the 
Remote Desktop. The Replay log indicates this conversions with an 
informational message. If the conversion is not possible, the step fails.

For more information about the rdp functions, see the Online Function 
Reference (Help > Function Reference).

Correlating Clipboard Parameters

During a recording session, if the client sends the server the same data as it 
received, then VuGen replaces the sent data with a parameter during code 
generation. VuGen only performs this correlation when the received and 
sent data formats are consistent with one another.

rdp_key(
"StepDescription=Key Press 2", 
"Snapshot=snapshot_9.inf", 
"KeyValue=C", 
"KeyModifier=CONTROL_KEY", 
RDP_LAST);

// The function requests the Remote Desktop UNICODE text and saves it to a 
//parameter
rdp_receive_clipboard_data(
"StepDescription=Get Remote Desktop clipboard 1",
"Snapshot=snapshot1.inf",
"ClipboardDataFormat=RDP_CF_UNICODE",
"ParamToSaveData=MyParam",
RDP_LAST);
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The following example shows how the same parameter, MyParam, is used 
for both receiving and sending the data.

Synchronizing Replay

An RDP session executes remotely. All keyboard and mouse handling is 
done on the server, and it is the server that reacts to them. For example, 
when you double-click an application on the desktop, it is the server that 
realizes a double-click took place and that the application must be loaded 
and displayed.

When an RDP client connects to a server, it does two things:

➤ It sends the server coordinates of actions. For example, 'clicked the left 
mouse button at coordinates (100, 100) on the screen'.

➤ It receives images from the server showing the current status of the screen 
after the action took place

The RDP client (and therefore, LoadRunner) does not know that the screen 
contains windows, buttons, icons, or other objects. It only knows the screen 
contains an image and at what coordinates the user performed the action. 
To allow the server to correctly interpret the actions, you set 
synchronization points within the script. These points instruct the script to 
wait until the screen on the server matches the stored screen before 
continuing.

// Receive the data from the server
rdp_receive_clipboard_data("StepDescription=Get Remote Desktop clipboard 1", 
"Snapshot=snapshot_9.inf", 
"Timeout=0", 
"ClipboardDataFormat=RDP_CF_UNICODETEXT", 
"ParamToSaveData=MyParam", 
RDP_LAST);
…
// Send the data to the server
rdp_send_clipboard_data("StepDescription=Get Remote Desktop clipboard 1", 
"Snapshot=snapshot_9.inf", 
"Timeout=10", 
REQUEST_RESPONSE, "Format=RDP_CF_UNICODETEXT", "Text={MyParam}", 
RDP_LAST);
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To add image synchronization points to a script:

 1 View the script in Tree view. Select View > Tree view.

 2 Select an operation to which you would like to add a synchronization point.

 3 Right-click on the image snapshot and select Insert Synch On Image from 
the menu. The cursor will change to a cross-hair.

 4 Mark the area on the screen that you would like to synchronize upon by 
clicking on the left button and dragging the box to enclose the area. When 
you release the mouse button, the Sync on Image dialog box opens.

 5 Click OK. VuGen adds a new Sync on Image step before the selected step. 
When you select this step, VuGen displays a snapshot that contains a pink 
box around the area you selected for synchronization.

The next time you replay the script, it will wait until the image returned by 
the server matches the image you selected.

Image Synchronization Tips
Use the following guidelines for effective image synchronization:

Synchronize on Smallest Significant Area

When synchronizing on an image, try to synchronize only the part of the 
image that is necessary. Additional details within the image may not be 
reproduced during replay and could result in a synchronization failure.

For example, when synchronizing on an image of a button, select only the 
text itself and not the dotted lines around the text as they may not appear 
during replay.
299



Chapter 17 • Creating Remote Desktop Protocol Vuser Scripts
When synchronizing a highlighted area, try to capture only the part of the 
image that is not effected by the highlighting. In the following example, 
perform a synchronization on the Log Off icon, but not the entire button, 
since the highlighting may not appear during replay, and the color could 
vary with different color schemes.

Synchronize Before Every User Action

You need to synchronize before every mouse operation. It is also 
recommended that you synchronize before the first rdp_key / rdp_type 
operation that follows a mouse operation.

Failed Image Synchronization
The Failed Image Synchronization dialog boxes open when there is a 
mismatch between the Recording and Replay snapshots during script replay. 
There are several Failed Image Synchronization dialog boxes:

➤ Append Snapshot

➤ Raise Tolerance

➤ Lower Tolerance

➤ No Snapshot
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Note: Raising or lowering the tolerance level from the dialog box only 
changes the level for that step. To change the tolerance level for the whole 
script, change the Default Image Sync Tolerance setting as described in 
“RDP Synchronization Run-Time Settings” on page 294.

Append Snapshot

The Failed Image Synchronization - Append Snapshot dialog box opens 
when the replay image is so different from the recorded image that 
changing the tolerance level will not help. You can indicate whether or not 
you want to mark the mismatch as an error or adopt the changes.
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When this dialog box opens, click on one of the following buttons to 
proceed:

➤ Stop. Consider the mismatch between the snapshots to be an error. This 
error will be handled like all other errors and halt the execution.

➤ Continue. Accept the mismatch and use both the original and new 
snapshots as a basis for comparison between screens during future replays. If 
replay returns either one of the bitmaps, the Vuser will not fail.

When you append a new snapshot to the original snapshot, VuGen adds it 
to the current step. You can then view both the original and appended 
snapshots by clicking the arrows above the Recording snapshot. The Replay 
snapshot only shows a single image, the image found during replay.
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Raise Tolerance
The Failed Image Synchronization - Raise Tolerance dialog box opens when 
the script replay failed to find the exact image requested, but if the tolerance 
level for performing synchronization on images was relaxed, then it would 
have succeeded in finding the image.

When this dialog box opens, click on one of the following buttons to 
proceed:

➤ Stop. Consider the mismatch between the snapshots to be an error. This 
error will be handled like all other errors and halt the execution.

➤ Continue. Accept the mismatch and raise the tolerance level so that VuGen 
permits a greater degree of a mismatch between the recorded images and 
those displayed during the replay.
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Lower Tolerance
The Failed Image Synchronization - Lower Tolerance dialog box opens when 
the script replay fails to meet the NotAppear or Change conditions. VuGen 
detected an image match where you expected it not to detect one. If the 
tolerance level was reduced, the recorded and replay images would not 
match, and the NotAppear or Change conditions would be met resulting in 
a successful replay.

When this dialog box opens, click on one of the following buttons to 
proceed:

➤ Stop. Consider the mismatch between the snapshots to be an error. This 
error will be handled like all other errors and halt the execution.

➤ Continue. Accept the mismatch and lower the tolerance level so that VuGen 
permits a less degree of a mismatch between the recorded images and those 
displayed during the replay.
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No Snapshot
The Failed Image Synchronization dialog box opens when the script replay 
fails to meet any of the synchronization conditions such as NotAppear or 
Change. VuGen did not find another image at the original coordinates that 
could be appended to the script. You can instruct VuGen to continue replay 
despite the mismatch. This is ideal for situations where you know that the 
missing image is not essential to the business process.

When this dialog box opens, click on one of the following buttons to 
proceed:

➤ Stop. Consider the mismatch between the snapshots to be an error. This 
error will be handled like all other errors and halt the execution.

➤ Continue. Accept the mismatch, and do not make any changes in the script. 
Continue script execution despite the mismatch.
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Shifted Coordinates
When replaying a script, a recorded object may appear at different 
coordinates on the screen. The object is the same, but its placement has 
been shifted. For example, during recording a window opened at 
coordinates (100, 100), but during replay at (200, 250). 

In this case, the synchronization point will automatically find the new 
coordinates without any intervention on your part. It will automatically 
note the difference of 100 pixels in the horizontal axis and 150 pixels in the 
vertical axis. 

All subsequent mouse operations that are coordinate dependent will use the 
modified coordinates, so that a mouse click recorded at (130, 130) will be 
replayed to (230, 280) = (130 + 100, 130 + 150).

You control the shifting of the coordinates through the AddOffsetToInput 
parameter in the rdp_sync_on_image step. You can override this parameter 
to either add or not add the differences in location during replay to the 
recorded coordinates for any further operations. If you do not override this 
parameter, VuGen takes its value from the default setting in the run-time 
settings. 

The corresponding parameter in the operations (rdp_mouse_click, 
rdp_mouse_drag, etc.) is Origin. This parameter decides whether the 
operation should take its coordinates only from the 'clean' values that were 
recorded, or whether it should take into account the differences that were 
added by the last synchronization point. If not explicitly specified, VuGen 
takes the value for this parameter from the run-time settings. 
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18
Developing Database Vuser Scripts 

You use VuGen to record communication between a database client 
application and a server. The resulting script is called a Database Vuser 
script.

This chapter includes:

 ➤  About Developing Database Vuser Scripts on page 310

 ➤  Introducing Database Vusers on page 311

 ➤  Understanding Database Vuser Technology on page 312

 ➤  Getting Started with Database Vuser Scripts on page 313

 ➤  Setting Database Recording Options on page 314

 ➤  Database Advanced Recording Options on page 316

 ➤  Using LRD Functions on page 318

 ➤  Understanding Database Vuser Scripts on page 319

 ➤  Working with Grids on page 322

 ➤  Evaluating Error Codes on page 324

 ➤  Handling Errors on page 325

The following information only applies to Client Server Database (Sybase 
CTLib, Sybase DbLib, Informix, MS SQL Server, Oracle 2-Tier, ODBC, and 
DB2 CLI) and ERP/CRM Siebel Vuser scripts.
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About Developing Database Vuser Scripts

When you record a database application communicating with a server, 
VuGen generates a Database Vuser script. VuGen supports the following 
database types: CtLib, DbLib, Informix, Oracle, ODBC, and DB2-CLI. The 
resulting script contains LRD functions that describe the database activity. 
Each LRD function has an lrd prefix and represents one or more database 
functions. For example, the lrd_fetch function represents a fetch operation. 

When you run a recorded session, the Vuser script communicates directly 
with the database server, performing the same operations as the original 
user. You can set the Vuser behavior (run-time settings) to indicate the 
number of times to repeat the operation and the interval between the 
repetitions. For more information, see “Configuring Run-Time Settings” in 
Volume I-Using VuGen.

Using VuGen, you can parameterize a script, replacing recorded constants 
with parameters. For more information, see “Creating Parameters” in Volume 
I-Using VuGen.

In addition, you can correlate queries or other database statements in a 
script, linking the results of one query with another. For more information, 
see “Correlating Statements” in Volume I-Using VuGen.

For troubleshooting information and scripting tips, see “VuGen Debugging 
Tips” in Volume I-Using VuGen.
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Introducing Database Vusers 

Suppose that you have a database of customer information that is accessed 
by customer service personnel located throughout the country. You use 
Database Vusers to emulate the situation in which the database server 
services many requests for information. A Database Vuser could:

➤ connect to the server

➤ submit an SQL query

➤ retrieve and process the information

➤ disconnect from the server

You distribute several hundred Database Vusers among the available load 
generators, each Vuser accessing the database by using the server API. This 
enables you to measure the performance of your server under the load of 
many users.

The program that contains the calls to the server API is called a Database 
Vuser script. It emulates the client application and all of the actions 
performed by it. The Vusers execute the script and emulate user load on the 
client/server system. The Vusers generate performance data which you can 
analyze in report and graph format.
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Understanding Database Vuser Technology

VuGen creates Database Vuser scripts by recording all the activity between a 
database client and a server. VuGen monitors the client end of the database 
and traces all the requests sent to and received from the database server.

Like all other Vusers created using VuGen, Database Vusers communicate 
with the server without relying on client software. Instead, each Database 
Vuser executes a script that executes calls directly to server API functions. 

You create Database Vuser scripts in a Windows environment using VuGen. 
Once you create a script, you can assign it to Vusers in both Windows and 
UNIX environments. For information about recording scripts, see 
“Recording with VuGen” in Volume I-Using VuGen.

Users working in a UNIX only environment can create Database Vuser 
scripts through programming using VuGen templates as the basis for a 
script. For information about programming Database Vuser scripts on UNIX, 
see the appendix “Programming Scripts on UNIX Platforms” in Volume I-
Using VuGen.
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Getting Started with Database Vuser Scripts 

This section provides an overview of the process of developing Database 
Vuser scripts using VuGen. 

To develop a Database Vuser script: 

 1 Record the basic script using VuGen.

Invoke VuGen and create a new Vuser script. Specify the type of Vuser 
(Client Server or ERP protocol types). Choose an application to record and 
set the recording options. Record typical operations on your application.

For details, see “Recording with VuGen” in Volume I-Using VuGen.

 2 Enhance the script.

Enhance the Vuser script by inserting transactions, rendezvous points, and 
control-flow structures into the script.

For details, see “Enhancing Vuser Scripts” in Volume I-Using VuGen.

 3 Define parameters (optional).

Define parameters for the fixed-values recorded into your script. By 
substituting fixed-values with parameters, you can repeat the same query 
many times using different values. 

For details, see “Creating Parameters” in Volume I-Using VuGen.

 4 Correlate queries (optional).

Correlating database statements allows you to use the result of a query in a 
subsequent one. This feature is useful when working on a database with user 
constraints. 

For details, see “Correlating Statements” in Volume I-Using VuGen.

 5 Configure the run-time settings.

The run-time settings control the Vuser script behavior during script 
execution. These settings include loop, log, and timing information. 

For details, see “Configuring Run-Time Settings” in Volume I-Using VuGen.

 6 Run the script from VuGen. 

Save and run the script from VuGen to verify that it runs correctly.
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For details, see “Running Vuser Scripts in Standalone Mode” in Volume I-
Using VuGen.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

Setting Database Recording Options

Before you record a database session, you set the recording options. You can 
set basic recording options for automatic function generation, script 
options, and think time:

➤ Automatic Transactions. Marks every lrd_exec and lrd_fetch function as a 
transaction. When these options are enabled, VuGen inserts 
lr_start_transaction and lr_end_transaction around every lrd_exec or 
lrd_fetch function. By default, automatic transactions are disabled. 
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➤ Script Options. Generates comments into recorded scripts, describing the 
lrd_stmt option values. In addition, you can specify the maximum length 
of a line in the script. The default length is 80 characters.

➤ Think Time. VuGen automatically records the operator’s think time. You can 
set a threshold level, below which the recorded think time will be ignored. If 
the recorded think time exceeds the threshold level, VuGen places an 
lr_think_time statement before LRD functions. If the recorded think time is 
below the threshold level, an lr_think_time statement is not generated. The 
default value is five seconds.

To set the Database recording options:

 1 Choose Tools > Recording Options. The Recording Options dialog box 
opens.

 2 Select Generate transactions for all lrd_exec functions to enable automatic 
transactions for lrd_exec statements.

Select Generate transaction for all lrd_fetch functions to enable automatic 
transactions for lrd_fetch statements.

 3 Select Generate script comments to instruct VuGen to insert descriptive 
comments within the script. 

 4 To change the maximum length of a line in the VuGen editor, specify the 
desired value in the Maximum length of script line box. 

 5 To change the think-time threshold value from the five second default, 
specify the desired value in the Think-time threshold box. 

You can also set advanced recording options relating to the trace level, Ctlib 
function generation, and the code generation buffer.
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Database Advanced Recording Options

In addition to the basic recording options, you can configure advanced 
options for the log file detail, CtLib specific functions, buffer size, and the 
recording engine.

➤ Recording Log Options. You can set the detail level for the trace and ASCII 
log files. The available levels for the trace file are Off, Error Trace, Brief 
Trace, or Full Trace. The error trace only logs error messages. The Brief Trace 
logs errors and lists the functions generated during recording. The Full Trace 
logs all messages, notifications, and warnings. 

You can also instruct VuGen to generate ASCII type logs of the recording 
session. The available levels are Off, Brief detail, and Full detail. The Brief 
detail logs all of the functions, and the Full detail logs all of the generated 
functions and messages in ASCII code.

➤ CtLib Function Options. You can instruct VuGen to generate a send data 
time stamp or an extended result set statement.

➤ Time Stamp. By default, VuGen generates lrd_send_data statements with 
the TotalLen and Log keywords for the mpszReqSpec parameter. The 
Advanced Recording Options dialog box lets you instruct VuGen to also 
generate the TimeStamp keyword. If you change this setting on an 
existing script, you must regenerate the Vuser script by choosing Tools > 
Regenerate Script. It is not recommended to generate the Timestamp 
keyword by default. The timestamp generated during recording is 
different than that generated during replay and script execution will fail. 
You should use this option only after a failed attempt in running a script, 
where an lrd_result_set following an lrd_send_data fails. The generated 
timestamp can now be correlated with a timestamp generated by an 
earlier lrd_send_data. 

➤ Extended Result Set. By default, VuGen generates an lrd_result_set 
function when preparing the result set. This setting instructs VuGen to 
generate the extended form of the lrd_result_set function, 
lrd_result_set_ext. In addition to preparing a result set, this function 
also issues a return code and type from ct_results. 

➤ Code Generation Buffer Size. Specify in kilobytes the maximum size of the 
code generation buffer. The default value is 128 kilobytes. For long database 
sessions, you can specify a larger size. 
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➤ Recording Engine. You can instruct VuGen to record scripts with the older 
LRD recording engine for compatibility with previous versions of VuGen. 
This option is only available for single-protocol scripts. 

To set advanced recording options:

 1 Click the Advanced button in the Database node of the Recording Options 
dialog box. The Advanced Recording Options dialog box opens.

 2 Select a Trace file detail level. To disable the trace file, select Off.

 3 To generate an ASCII log file, select the desired detail level from the ASCII 
file detail level box. 

 4 For CtLib: To instruct VuGen to generate the TimeStamp keyword for 
lrd_send_data functions, select the Generate send data time stamp option. 

 5 For CtLib: To instruct VuGen to generate lrd_result_set_ext instead of 
lrd_result_set, select the Generate extended result set statement option. 

 6 To modify the size of the code generation buffer from the default value of 
128 kilobytes, enter the desired value in the Code generation buffer size 
box.
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 7 To use the old VuGen recording engine to allow backwards compatibility, 
select the Record script using old recording engine option. 

 8 Click OK to save your settings and close the Advanced Recording Options 
dialog box.

Using LRD Functions

The functions developed to emulate communication between a database 
client and a server are called LRD Vuser functions. Each LRD Vuser function 
has an lrd prefix. VuGen automatically records most of the LRD functions 
listed in this section during a database session (CtLib, DbLib, Informix, 
Oracle (2-Tier), and ODBC). You can also manually program any of the 
functions into your script. 

The LRD functions are classified into several categories: Access Management 
Functions, Environment Functions, Retrieval Handling, Statement 
Handling, Statement Correlating, Variable Handling, Siebel, and Oracle 8.

For syntax and examples of the LRD functions, refer to the Online Function 
Reference (Help > Function Reference).
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Understanding Database Vuser Scripts

After you record a database session, you can view the recorded code in 
VuGen’s built-in editor. You can scroll through the script, see the SQL 
statements that were generated by your application, and examine the data 
returned by the server. 

The VuGen window provides you with the following information about the 
recorded database session: 

➤ the sequence of functions recorded

➤ grids displaying the data returned by database queries 

➤ the number of rows fetched during a query

Function Sequence
When you view a Vuser script in the VuGen window, you see the sequence 
in which VuGen recorded your activities. For example, the following 
sequence of functions is recorded during a typical Oracle database session:

lrd_init Initializes the environment.

lrd_open_connection Connects to the database server.

lrd_open_cursor Opens a database cursor.

lrd_stmt Associates an SQL statement with a cursor.

lrd_bind_col Binds a host variable to a column.

lrd_exec Executes an SQL statement.

lrd_fetch Fetches the next record in the result set.

lr_commit Commits a database transaction.

lr_close_cursor Closes a cursor.

lrd_close_connection Disconnects from the database server.

lrd_end Cleans up the environment. 
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In the following script, VuGen recorded the actions of an operator who 
opened a connection to an Oracle server and then performed a query 
requesting the local settings. 

Row Information
VuGen generates an lrd_fetch function for each SQL query. 

The second parameter of the function indicates the number of rows fetched. 
This number can be positive or negative. 

Positive Row Values

A positive value shows the number of rows fetched during recording, and 
indicates that not all rows were fetched. (For example, if the operator 
cancelled the query before it was completed.)

In the following example, four rows were retrieved during the database 
query, but not all of the data was fetched. 

lrd_init(&InitInfo, DBTypeVersion);
lrd_open_connection(&Con1, LRD_DBTYPE_ORACLE, "s1", "tiger", "hp1", "", 0, 0, 0);
lrd_open_cursor(&Csr1, Con1, 0);
lrd_stmt(Csr1, "select parameter, value     from v$nls_parameters "
"    where (upper(parameter) in ('NLS_SORT','NLS_CURRENCY',"
"'NLS_ISO_CURRENCY', 'NLS_DATE_LANGUAGE',"
"'NLS_TERRITORY'))", -1, 0 /*Non deferred*/, 1 /*Dflt Ora Ver*/, 0);

lrd_bind_col(Csr1, 1, &D1, 0, 0);
lrd_bind_col(Csr1, 2, &D2, 0, 0);
lrd_exec(Csr1, 0, 0, 0, 0, 0);
lrd_fetch(Csr1, 7, 7, 0, PrintRow2, 0);
…
lrd_close_cursor(&Csr1, 0);
lrd_commit(0, Con1, 0);
lrd_close_connection(&Con1, 0, 0);
lrd_end(0);

 lrd_fetch(Csr1, -4, 1, 0, PrintRow7, 0);

 lrd_fetch(Csr1, 4, 1, 0, PrintRow7, 0);
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During execution, the script retrieves the number of rows indicated by the 
positive value (provided the rows exist).

Negative Row Values

A negative row value indicates that all available rows were fetched during 
recording. The absolute value of the negative number is the number of rows 
fetched. 

In the following example, all four rows of the result set were retrieved: 

When you execute an lrd_fetch statement containing a negative row value, 
it retrieves all of the available rows in the table at the time of the run—not 
necessarily the number at the time of recording. In the above example, all 
four rows of the table were retrieved during the recording session. However, 
if more rows are available during script execution, they are all retrieved. 

For more information about lrd_fetch, refer to the Online Function Reference 
(Help > Function Reference).

 lrd_fetch(Csr1, -4, 1, 0, PrintRow7, 0);
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Working with Grids 

The data returned by a query during a recording session is displayed in a 
grid. By viewing the grid you can determine how your application generates 
SQL statements and the efficiency of your client/server system. 

The data grid is represented by a GRID statement. To open the data grid, 
click on the icon in the margin adjacent to the GRID statement.
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In the following example, VuGen displays a grid for a query executed on a 
flights database. The query retrieves the flight number, airport code, 
departure city, day of the week, and other flight-relevant information.

If the data value is very long, only part of it is shown in the grid. This 
truncation only occurs in the displayed grid and has no impact on the data.

The grid columns are adjustable in width. You can scroll up to 200 rows 
using the scroll bar. To change this value, open the vugen.ini file on your 
machine’s Operating System folder (for example, C:\WINNT) and modify 
the following entry:

To correlate a value or save the data to a file, click in a cell and use the right-
click menu options, Create Correlation or Save To File.

[general]
max_line_at_grid=200
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To search for data within the entire grid, including the non-visible part, 
Select Search Grids in the Find dialog box.

VuGen displays the results in the Output window’s Grid Results tab.

Evaluating Error Codes

When a Vuser executes an LRD function, the function generates a return 
code. A return code of 0 indicates that the function succeeded. For example, 
a return code of 0 indicates that another row is available from the result set. 
If an error occurs, the return code indicates the type of error. For example, a 
return code of 2014 indicates that an error occurred in the initialization.

There are four types of return codes, each represented by a numerical range:

Type of Return Code Range

Informational 0 to 999

Warning 1000 to 1999

Error 2000 to 2999

Internal Error 5000 to 5999
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For more detailed information on the return codes, refer to the Online 
Function Reference (Help > Function Reference). 

You can evaluate the return code of an LRD function to determine if the 
function succeeded. The following script segment evaluates the return code 
of an lrd_fetch function:

Handling Errors

You can control how database Vusers handle errors when you run a database 
Vuser script. By default, if an error occurs during script execution, the script 
execution is terminated. To change the default behavior, you can instruct 
the Vuser to continue when an error occurs. You can apply this behavior in 
the following ways:

➤ Globally Modifying Error Handling. Provides error handling to the entire 
script, or to a segment of the script

➤ Locally Modifying Error Handling. Provides error handling to a specific 
function only

Globally Modifying Error Handling 
You can change the way that Vusers handle errors by issuing an 
LRD_ON_ERROR_CONTINUE or LRD_ON_ERROR_EXIT statement. By 
default, a Vuser aborts the script execution when it encounters any type of 
error—database, parameter related, and so on. To change the default 
behavior, insert the following line into your script:

static int rc;
rc=lrd_fetch(Csr15, -13, 0, 0, PrintRow4, 0);
if (rc==0)
lr_output_message("The function succeeded");

else
lr_output_message("The function returned an error code:%d",rc);

LRD_ON_ERROR_CONTINUE;
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From this point on, the Vuser continues script execution, even when an 
error occurs. 

You can also specify that the Vuser continue script execution when an error 
occurs only within a segment of the script. For example, the following code 
tells the Vuser to continue script execution even if an error occurs in the 
lrd_stmt or lrd_exec functions:

Use the LRD_ON_ERROR_CONTINUE statement with caution, as significant 
and severe errors may be missed. 

Locally Modifying Error Handling 
You can set error handling for a specific function by modifying the severity 
level. Functions such as lrd_stmt and lrd_exec, which perform database 
operations, use severity levels. The severity level is indicated by the 
function's final parameter, miDBErrorSeverity. This parameter tells the Vuser 
whether or not to continue script execution when a database error occurs 
(error code 2009). The default, 0, indicates that the Vuser should abort the 
script when an error occurs. 

For example, if the following database statement fails (e.g., the table does 
not exist), then the script execution terminates.

To tell a Vuser to continue script execution, even when a database operation 
error occurs for that function, change the statement's severity parameter 
from 0 to 1. 

LRD_ON_ERROR_CONTINUE;
lrd_stmt(Csr1, "select…"…);
lrd_exec(…);
LRD_ON_ERROR_EXIT;

lrd_stmt(Csr1, "insert into EMP values ('Smith',301)\n", -1, 1 /*Deferred*/, 
1 /*Dflt Ora Ver*/, 0);

lrd_stmt(Csr1, "insert into EMP values ('Smith',301)\n", -1, 1 /*Deferred*/, 
1 /*Dflt Ora Ver*/, 1);
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When the severity is set to 1 and a database error occurs, a warning is issued. 
Note that the severity level set for a particular function applies only to that 
function.

CtLib Result Set Errors
In CtLib recording, the application retrieves all of the available result sets 
after executing a statement. If the returned result set contains fetchable 
data, the application performs bind and fetch operations on the data as 
indicated in the following example: 

If a result set does not contain fetchable data, bind and fetch operations 
cannot be performed. 

When you parametrize your script, result data may become unfetchable 
(depending on the parameters). Therefore, a CtLib session that recorded 
bind and fetch operations for a particular statement, may not be able to run, 
if the new data is unfetchable. If you try to execute an lrd_bind_col or an 
lrd_fetch operation, an error will occur (LRDRET_E_NO_FETCHABLE_DATA 
— error code 2064) and the Vuser will terminate the script execution.

You can override the error by telling the Vuser to continue script execution 
when this type of error occurs. Insert the following line into your script:

To return to the default mode of terminating the script execution, type the 
following line into your script:

Use this option with caution, as significant and severe errors may be missed.

lrd_stmt(Csr15, "select * from all_types", -1, 148, -99999, 0);
lrd_exec(Csr15, 0, 0, 0, 0, 0);
lrd_result_set(Csr15, 1 /*Succeed*/, 4040 /*Row*/, 0);
lrd_bind_col(Csr15, 1, &tinyint_D41, 0, 0);
…
lrd_fetch(Csr15, -9, 0, 0, PrintRow3, 0);

LRD_ON_FETCHABLE_SET_ERR_CONT;

LRD_ON_FETCHABLE_SET_ERR_EXIT;
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Correlating Database Vuser Scripts

After you record a database session, you may need to correlate one or more 
queries within your script—use a value that was retrieved during the 
database session, at a later point in the session.

This chapter includes:

 ➤  About Correlating Database Vuser Scripts on page 329

 ➤  Scanning a Script for Correlations on page 330

 ➤  Correlating a Known Value on page 332

 ➤  Database Correlation Functions on page 334

The following information only applies to Database (CtLib, DbLib, 
Informix, Oracle, and ODBC, DB2-CLI) Vuser scripts.

About Correlating Database Vuser Scripts

If you encounter an error when running your script, examine the script at 
the point where the error occurred. In many cases, you can overcome the 
problem by correlating the query. Correlating the query means that you 
save a run-time value to a parameter. You then use the saved value at a later 
point in the same script. In summary, correlation is using the results of one 
statement as input to another. 

There are many queries whose inputs depend on the result of prior queries. 
To emulate this behavior, use VuGen’s correlation capabilities.
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Scanning a Script for Correlations

VuGen provides a correlation utility to help you repair your script and allow 
a successful replay. It performs the following steps: 

➤ Scans for potential correlations

➤ Inserts the appropriate correlation function to save the results to a 
parameter

➤ Replaces the statement value with the parameter

You can perform automatic correlation on the entire script, or at a specific 
location in your script. 

This section describes how to determine the statement which needs to be 
correlated. If you already know which value you want to correlate, proceed 
to the next section for instructions on correlating a specific value. 

To scan and correlate a script detected with automatic correlation:

 1 Open the Output window.

Select View > Output to display the output tabs at the bottom of the 
window. Check for errors in the Replay Log tab. Often, these errors can be 
corrected by correlation.

 2 Select Vuser > Scan for Correlations. 

VuGen scans the entire script and lists all possible values to correlate in the 
Correlated Query tab. 
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In the following example, in the lrd_ora8_fetch function, VuGen detected a 
value to correlate.

 3 In the Correlated Query tab, double-click on the result you want to 
correlate. Click on the words (grid column x, row y) VuGen sends the cursor 
to the location of the value in your grid. 

 4 Choose Create Correlation from the right-click menu. VuGen prompts you 
to enter a parameter name for the result value.

 5 Specify a name, or accept the default. Click OK to continue. VuGen inserts 
the appropriate correlation statement (lrd_save_value, lrd_save_col, or 
lrd_save_ret_param, lrd_ora8_save_col) which saves the result to a 
parameter.
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 6 Click Yes to confirm the correlation.

A message box opens asking if you want to search for all occurrences of the 
value in the script. 

➤ To replace only the value in the selected statement, click No. 

➤ To search and replace additional occurrences, click Yes. 

 7 A Search and Replace dialog box opens. Confirm any replacements, 
including your original statement. 

 8 Close the Search and Replace dialog box. VuGen replaces the statement 
value with a reference to the parameter. If you choose to cancel the 
correlation, VuGen also erases the statement created in the previous step.

Correlating a Known Value

If you know which value needs to be correlated, perform the following 
procedure.

To correlate a specific value:

 1 Locate the statement in your script, with the query containing the value you 
want to correlate. This is usually one of the arguments of the lrd_assign, 
lrd_assign_bind, or lrd_stmt functions. Select the value without the 
quotation marks.

 2 Choose Scan for Correlations (at cursor) from the right-click menu. VuGen 
scans the selected value for correlations.

 3 In the Output window’s Correlated Query tab, double-click on the result 
you want to correlate. Click on the words (grid column x, row y). VuGen 
sends the cursor to the location of the value in your grid. 
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 4 In the grid, click on the value you want to correlate and choose Create 
Correlation from the right-click menu. VuGen prompts you to enter a 
parameter name for the result value.

 5 Specify a name, or accept the default. Click OK to continue. VuGen inserts 
the appropriate correlation statement (lrd_save_value, lrd_save_col, or 
lrd_save_ret_param, lrd_ora8_save_col) which saves the result to a 
parameter.

 6 Click Yes to confirm the correlation.

A message box opens asking if you want to search for all occurrences of the 
value in the script. 

➤ To replace only the value in the selected statement, click No. 

➤ To search and replace additional occurrences, click Yes. 

 7 A Search and Replace dialog box opens. Confirm any replacements, 
including your original statement. 

 8 Close the Search and Replace dialog box. VuGen replaces the statement 
value with a reference to the parameter. If you cancel the correlation, VuGen 
also erases the statement created in the previous step.

Note: If you are correlating a value from an lrd_stmt function, the following 
data types are not supported: date, time, and binary (RAW, VARRAW). 
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Database Correlation Functions

When working with Database Vuser scripts, (DbLib, CtLib, Oracle, Informix, 
and so forth) you can use VuGen’s automated correlation feature to insert 
the appropriate functions into your script. The correlating functions are:

➤ lrd_save_col saves a query result appearing in a grid, to a parameter. This 
function is placed before fetching the data. It assigns the value retrieved 
by the subsequent lrd_fetch to the specified parameter. 
(lrd_ora8_save_col for Oracle 8 and higher)

➤ lrd_save_value saves the current value of a placeholder descriptor to a 
parameter. It is used with database functions that set output placeholders 
(such as certain stored procedures under Oracle).

➤ lrd_save_ret_param saves a stored procedure’s return value to a 
parameter. It is used primarily with database procedures stored in DbLib 
that generate return values.

Note: VuGen does not apply correlation if the saved value is invalid or 
NULL (no rows returned). 

For more information about these functions and their arguments, refer to 
the the Online Function Reference (Help > Function Reference).
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Developing DNS Vuser Scripts 

VuGen allows you to emulate network activity by directly accessing a DNS 
server. 

This chapter includes:

 ➤  About Developing DNS Vuser Scripts on page 335

 ➤  Working with DNS Functions on page 336

The following information applies only to DNS Virtual User scripts.

About Developing DNS Vuser Scripts

The DNS protocol is a low-level protocol that allows you to emulate the 
actions of a user working against a DNS server. 

The DNS protocol emulates a user accessing a Domain Name Server to 
resolve a host name with its IP address. Only replay is supported for this 
protocol—you need to manually add the functions to your script.

To create a script for the DNS protocol, choose File > New to open the New 
Virtual User dialog box. Choose the Domain Name Resolution (DNS) 
protocol type from the Client/Server category. Since recording is not 
supported for DNS, you program the script with the appropriate DNS, Vuser 
API and C functions. For more information on these functions, refer to the 
Online Function Reference (Help > Function Reference). 

After you create a Vuser script, you integrate it into a scenario on either a 
Windows or UNIX platform. For more information on integrating Vuser 
scripts in a scenario, refer to the HP LoadRunner Controller User’s Guide. 
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Working with DNS Functions

DNS Vuser script functions record queries to and from a Domain Name 
Resolution (DNS) server. Each DNS function begins with a dns prefix. For 
detailed syntax information on these functions, refer to the Online Function 
Reference (Help > Function Reference).

In the following example, a query is submitted to the DNS server and the 
results are printed to the log file.

Function Name Description

ms_dns_query Resolves the IP address of a host. 

ms_dns_nextresult Advances to the next IP address in the list 
returned by ms_dns_query.

Actions()
{
int    rescnt = 0;
char results = NULL;
results = (char *) ms_dns_query("transaction",

"URL=dns://<DnsServer>",
"QueryHost=<Hostname>",
LAST);

// List all the IP addresses of the host names...
while (*results) {

rescnt++;
lr_log_message(lr_eval_string("(%d) IP of<Hostname> is %s"),

rescnt, results);
results = (char *) ms_dns_nextresult(results);

}
return 1;

}
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Developing WinSock Vuser Scripts

You use VuGen to record communication between a client application and a 
server that communicate using the Windows Sockets protocol. The resulting 
script is called a Windows Sockets Vuser script.

This chapter includes:

 ➤  About Recording Windows Sockets Vuser Scripts on page 337

 ➤  Getting Started with Windows Sockets Vuser Scripts on page 338

 ➤  Setting the WinSock Recording Options on page 340

 ➤  Using LRS Functions on page 343

The following information applies to the Windows Sockets protocol.

About Recording Windows Sockets Vuser Scripts

The Windows Sockets protocol is ideal for analyzing the low level code of an 
application. For example, to check your network, you can use a Windows 
Sockets (WinSock) script to see the actual data sent and received by the 
buffers. The WinSock type can also be used for recording other low level 
communication sessions. In addition, you can record and replay 
applications that are not supported by any of the other Vuser types.

When you record an application which uses the Windows Sockets protocol, 
VuGen generates functions that describe the recorded actions. Each 
function begins with an lrs prefix. The LRS functions relate to the sockets, 
data buffers, and the Windows Sockets environment. Using VuGen, you 
record your application’s API calls to the Winsock.dll or Wsock32.dll.
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For example, you could create a script by recording the actions of a telnet 
application.

In the following example, lrs_send sends data to a specified socket:

You can view and edit the recorded script from VuGen’s main window. The 
Windows Sockets API calls that were recorded during the session are 
displayed in the window, allowing you to track your network activities. 

VuGen can display a WinSock script in two ways:

➤ As an icon-based representation of the script. This is the default view, and 
is known as the Tree view.

➤ As a text-based representation of the script showing the Windows Sockets 
API calls. This is known as the Script view.

You use VuGen to view and edit your Vuser script from either the Tree view 
or Script view. For more information, see “Introducing Service Test” in 
Volume I-Using VuGen.

After creating a script, you can view the recorded data as a snapshot or as a 
raw data file. For details, see Chapter 22, “Working with Windows Socket 
Data.”

Getting Started with Windows Sockets Vuser Scripts

This section provides an overview of the process of developing Windows 
Sockets Vuser scripts using VuGen. 

To develop a Windows Sockets script: 

 1 Record the actions using VuGen.

Invoke VuGen and create a new Vuser script, specifying Windows Sockets as 
the type. Choose an application to record and set the recording options. 
Record typical operations on your application.

For details, see “Recording with VuGen” in Volume I-Using VuGen.

lrs_send("socket22", "buf44", LrsLastArg);
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 2 Enhance the Vuser script.

Enhance the Vuser script by inserting transactions, rendezvous points, and 
control-flow structures into the script.

For details, see “Enhancing Vuser Scripts” in Volume I-Using VuGen.

 3 Define parameters (optional).

Define parameters for the fixed-values recorded into your Vuser script. By 
substituting fixed-values with parameters, you can repeat the same business 
process many times using different values. 

For details, see “Creating Parameters” in Volume I-Using VuGen.

 4 Correlate statements (optional).

Correlating statements enables you to use the result of one business process 
in a subsequent one. 

For details, see “Correlating Statements” in Volume I-Using VuGen.

 5 Configure the run-time settings.

The run-time settings control the Vuser behavior during script execution. 
These settings include loop, log, and timing information. 

For details, see “Configuring Run-Time Settings” and “Configuring Network 
Run-Time Settings” in Volume I-Using VuGen.

 6 Run the Vuser script from VuGen. 

Save and run the Vuser script from VuGen to verify that it runs correctly.

For details, see “Running Vuser Scripts in Standalone Mode” in Volume I-
Using VuGen.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 
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Setting the WinSock Recording Options

The following recording options are available for WinSock Vusers: 

➤ Configuring the Translation Table

➤ Excluding Sockets

➤ Setting the Think Time Threshold

To open the Recording Options dialog box, choose Tools > Recording 
Options or click the Options button in the Start Recording dialog box. 
VuGen displays the WinSock options.
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Configuring the Translation Table
To display data in EBCDIC format, you specify a translation table in the 
recording options. 

The Translation Table lets you specify the format for recording sessions. This 
applies to users running on mainframe machines or AS/400 servers. Both 
the server and client machines determine the format of the data from 
translation tables installed on your system. Choose a translation option 
from the list box. 

The first four digits of the listbox item represent the server format. The last 
four digits represent the client format. In the above example, the selected 
translation table is 002501b5. The server format is 0025 and the client 
format is 01b5 indicating a transfer from the server to the client. In a 
transmission from the client to the server, you would choose the item that 
reverses the formats—01b50025 indicating that the client’s 01b5 format 
needs to be translated to the server’s 0025 format.

The translation tables are located in the ebcdic directory under the VuGen’s 
installation directory. If your system uses different translation tables, copy 
them to the ebcdic directory. 

Note: If your data is in ASCII format, it does not require translation. You 
must select the None option, the default value. If you do select a translation 
table, VuGen will translate the ASCII data. 

When working on Solaris machines, you must set the following 
environment variables on all machines running the Vuser scripts:

setenv LRSDRV_SERVER_FORMAT 0025
setenv LRSDRV_CLIENT_FORMAT 04e4
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Excluding Sockets 
VuGen supports the Exclude Socket feature, allowing you to exclude a 
specific socket from your recording session. To exclude all actions on a 
socket from your script, you specify the socket address in the Exclude Socket 
list. To add a socket to the list, click the plus sign in the upper right corner of 
the box and enter the socket address in one of the following formats:

You can exclude multiple hosts and ports by adding them to the list. To 
remove a socket from the excluded list, select the socket address and click 
the minus sign in the upper right corner of the box. It is recommended that 
you exclude hosts and ports that do not influence the server load under test, 
such as the local host and the DNS port (53), which are excluded by default.

By default, VuGen does not log the actions of the excluded sockets in the 
Excluded Socket List. To instruct VuGen to log the actions of the excluded 
socket(s) clear the Do not include excluded sockets in log check box. When 
logging is enabled for the excluded sockets, their actions are preceded by 
"Exclude" in the log file.

Value Meaning

host:port Exclude only the specified port on the specified host.

host Exclude all ports for the specified host.

:port Exclude the specified port number on the local host.

*:port Exclude the specified port number on all hosts.

Exclude : /* recv(): 15 bytes were received from socket 116 using flags 0 */
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Setting the Think Time Threshold 
During recording, VuGen automatically inserts the operator’s think time. 
You can set a threshold level, below which the recorded think time will be 
ignored. If the recorded think time exceeds the threshold level, VuGen 
places an lr_think_time statement before LRS functions. If the recorded 
think time is below the threshold level, an lr_think_time statement is not 
generated. 

To set the think time threshold, enter the desired value (in seconds) in the 
Think Time Threshold box. The default value is five seconds.

Using LRS Functions

The functions developed to emulate communication between a client and a 
server by using the Windows Sockets protocol are called LRS Vuser 
functions. Each LRS Vuser function has an lrs prefix. VuGen automatically 
records most of the LRS functions listed in this section during a Windows 
Sockets session. You can also manually program any of the functions into 
your Vuser script. 

The LRS functions are classified into several categories: Socket, Buffer, 
Environment, Correlating Statements, Conversion, and Timeout.

For more information about the LRS functions, refer to the Online Function 
Reference (Help > Function Reference). 

After you record a session, VuGen’s built-in editor lets you view the recorded 
code. You can scroll through the script, view the functions that were 
generated by your application, and examine the transferred data. When you 
view the script in the main window, you see the sequence in which VuGen 
recorded your activities. 
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The following function sequence is recorded during a typical session:

VuGen supports record and replay for applications using the Windows 
Socket protocol on Windows; on UNIX platforms, only replay is supported.

lrs_startup Initializes the WinSock DLL. 

lrs_create_socket Initializes a socket.

lrs_send Sends data on a datagram or to a stream 
socket.

lrs_receive Receives data from a datagram or stream 
socket.

lrs_disable_socket Disables an operation on a socket.

lrs_close_socket Closes an open socket. 

lrs_cleanup Terminates the use of the WinSock DLL.
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Working with Windows Socket Data

After you record a session in the Windows Socket protocol you can view and 
manipulate the data.

This chapter includes:

 ➤  About Working with Windows Socket Data on page 346

 ➤  Viewing Data in the Snapshot Window on page 346

 ➤  Navigating Through the Data on page 348

 ➤  Modifying Buffer Data on page 351

 ➤  Modifying Buffer Names on page 358

 ➤  Viewing Windows Socket Data in Script View on page 359

 ➤  Understanding the Data File Format on page 360

 ➤  Viewing Buffer Data in Hexadecimal format on page 362

 ➤  Setting the Display Format on page 365

 ➤  Debugging Tips on page 368

 ➤  Manually Correlating WinSock Scripts on page 369

The following information applies to all protocols recorded on a Windows 
Socket level.
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About Working with Windows Socket Data

After you record an application using VuGen, you have multiple data buffers 
containing the data.

When you view the WinSocket script in tree view, VuGen provides a 
snapshot window which allows you to navigate within the data buffers and 
modify the data. 

When working in script view, you can view the raw data in the data.ws file. 
For more information, see “Viewing Windows Socket Data in Script View” 
on page 359.

Viewing Data in the Snapshot Window

When viewing a Windows Socket script in tree view, VuGen provides a 
buffer snapshot window which displays the data in an editable window. You 
can view a snapshot in either Text view or Binary view. 

The text view shows a snapshot of the buffer with the contents represented 
as text.

By default, VuGen stores the buffer data as read-only data. If you want to 
modify the contents of the buffer, clear the Read only box in the buffer’s 
Text View. VuGen issues a warning that bookmarks and parameters may be 
affected.
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The binary view shows the data in hexadecimal representation. The left 
column shows the offset of the first character in that row. 
The middle column displays the hexadecimal values of the data. The right 
column shows the data in ASCII format.

The status bar below the buffer snapshot provides information about the 
data and buffer: 

➤ Buffer number. The buffer number of the selected buffer.

➤ Total bytes. the total number of bytes in the buffer.

➤ Buffer type. the type of buffer—received or sent.

➤ Data. the value of the data at the cursor in decimal and hexadecimal 
formats, in Little Endian order (reverse of how it appears in the buffer). 

➤ Offset. the offset of the selection (or cursor in text view) from the beginning 
of the buffer. If you select multiple bytes, it indicates the range of the 
selection. 

ASCII formatOffset Hexadecimal format
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The status bar also indicates whether or not the original data was modified. 

Navigating Through the Data

In tree view, VuGen provides several tools that allow you to navigate 
through the data in order to identify and analyze a specific value:

➤ Buffer Navigator

➤ Go To Offset

➤ Bookmarks

Buffer Navigator
By default, VuGen displays all the steps and buffers in the left pane. The 
Buffer Navigator is a floating window that lets you display only the receive 
and send buffers steps (lrs_send, lrs_receive, lrs_receive_ex, and 
lrs_length_receive). In addition, you can apply a filter and view either the 
send or receive buffers. 

When you select a buffer in the navigator, its contents are displayed in the 
buffer snapshot window. 
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If you change a buffer’s name after recording, its contents will not appear in 
the snapshot window when you click on the step. To view the renamed 
buffer’s data, use the buffer navigator and select the new buffer’s name. 
VuGen issues a warning message indicating that parameter creation will be 
disabled for the selected buffer.

To open the Buffer Navigator, choose View > Buffer Navigator. To close the 
navigator, click the X in the top right corner of the navigator dialog box. 

Note that you can also navigate between buffers by clicking on the buffer 
step in the left pane’s tree view. The advantages of the buffer navigator are 
that it is a floating window with filtering capabilities. 

Go To Offset
You can move around within the data buffer by specifying an offset. You can 
indicate the absolute location of the data, or a location relative to the 
current position of the cursor within the buffer. This dialog box also lets you 
select a range of data, by specifying the starting and end offsets. 

To go to an offset:

 1 Click within the snapshot window. Then select Go to offset from the right-
click menu. The Go to offset dialog box opens.

 2 To go to a specific offset within the buffer (absolute), click Go to offset and 
specify an offset value.

 3 To jump to a location relative to the cursor, click Advance by and specify the 
number of bytes you want to advance. To advance ahead, enter a positive 
value. To move backwards within the buffer, use a negative value. 
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 4 To select a range of data within the buffer, click Select range from and 
specify the beginning and end offsets. 

Bookmarks
VuGen lets you mark locations within a buffer as bookmarks. You give each 
bookmark a descriptive name and click on it to jump directly to its location. 
The bookmarks are listed in the Output window’s Bookmarks tab below the 
buffer snapshot.

Bookmarks can be used in both the text and binary views. You can locate 
the desired data in text view, save the location as a bookmark, and jump 
directly to that bookmark in binary view. 

The bookmark can mark a single byte or multiple bytes. When you click on 
a bookmark in the list, it is indicated in the buffer snapshot window as a 
selection. Initially, in the text view the data is highlighted in blue, and in 
binary view the bookmark block is marked in red. Also in binary view, when 
you place your cursor over a bookmark, a popup text box opens indicating 
the name of the bookmark.

You can create both permanent and simple bookmarks. A permanent 
bookmark is always marked within the buffer’s binary view—it is enclosed 
by a blue box. The bookmark stays selected in blue, even when pointing to 
another location in the buffer. The cursor location is marked in red. A 
simple bookmark, however, is not permanently marked. When you jump to 
a simple bookmark, it is marked in red, but once you move the cursor 
within the buffer, the bookmark is no longer selected. By default bookmarks 
are permanent. 
350



Chapter 22 • Working with Windows Socket Data
To work with bookmarks:

 1 To create a bookmark, select one or more bytes in a buffer snapshot (text or 
binary view) and select New Bookmark from the right-click menu. 

 2 To view the bookmark list, choose View > Output Window and select the 
Bookmarks tab. 

 3 To assign a name to a bookmark, click on it in the bookmark list and edit the 
title.

 4 To change the location of a bookmark, select the bookmark in the 
Bookmarks tab, then select the new data in the buffer snapshot. Click 
Modify in the Bookmarks tab. 

 5 To change a bookmark form being Permanent to simple (permanent means 
that it is always marked, even when you move the cursor to a new location), 
select the bookmark, perform a right-click, and clear the check adjacent to 
Permanent Bookmark.

 6 To display only permanent bookmarks in the list, select the Show 
Permanent Bookmarks only check box in the Bookmarks tab. 

 7 To view bookmarks from a specific buffer, select a bookmark from the 
desired buffer and choose Selected buffer only in the Filter box. 

 8 To delete a bookmark, select it in the Bookmarks tab and click Delete.

Modifying Buffer Data

In tree view, VuGen provides several tools that allow you to modify the data 
by deleting, changing or adding to the existing data.

➤ Inserting Data

➤ Editing Data

➤ Parameterizing the Data
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Inserting Data
You can insert a numerical value into a data buffer. You can insert it as a 
single, double-byte or 4-byte value.

To insert a number into a data buffer:

 1 Click at a location in the buffer. 

 2 Open the right-click menu and choose Advanced > Insert Number > 
Specify…

 3 Enter the ASCII value that you want to insert into the Value box.

 4 Select the size of the data you want to insert: 1 byte, 2 bytes, or 4 bytes from 
the Size box. 

 5 Click OK to finish. VuGen inserts the hexadecimal representation of the 
data into the buffer. 

Editing Data
You can perform all of the standard edit operation on buffer data: copy, 
paste, cut, delete, and undo. In the binary view you can specify the actual 
data to insert. VuGen allows you to specify the format of the data—single 
byte, 2-byte, or 4-byte, and hexadecimal or decimal value. You can copy 
binary data and insert it as a number into the buffer. You can see the 
decimal or hexadecimal numbers in the right column of the binary view.

In the following example, the word OK was selected.
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If you perform simple copy (CTRL+C) and paste (CTRL+V) operations at the 
beginning of the next line of data, it inserts the actual text.

If you choose and Advanced Copy as Number > Decimal and then paste the 
data, it inserts the decimal value of the ASCII code of the selected characters:

If you choose and Advanced Copy as Number > Hexadecimal and then paste 
the data, it inserts the hexadecimal value of the ASCII code of the selected 
characters:

The Undo Buffer retains all of the modifications to the buffer. This 
information is saved with the file—if you close the file it will still be 
available. If you want to prevent others from undoing your changes, you 
can empty the Undo buffer. To empty the Undo buffer, choose Advanced > 
Empty Undo Buffer in the right-click menu. 

To edit buffer data in the binary view:

 1 To copy buffer data:

➤ As characters, select one or more bytes and press CTRL+C.

➤ As a decimal number, Advanced > Copy As Number > Decimal in the 
right-click menu.

➤ As a hexadecimal number, Advanced > Copy As Number > Hexadecimal 
in the right-click menu.

 2 To paste the data:

➤ As a single byte (assuming the size of the data on the clipboard is a single 
byte), click at the desired location in the buffer and press CTRL+V. 

➤ In short format (2-byte), Advanced >Insert Number >Paste Short (2-byte) 
in the right-click menu.

➤ In long format (4-byte), Advanced >Insert Number >Paste Long (4-byte) 
in the right-click menu.
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 3 To delete data, select it in either one of the views and choose Delete from 
the right-click menu. 

Parameterizing the Data
In tree view, VuGen lets you parameterize the data directly from the buffer 
snapshot view. You can specify a range of what to parameterize and you can 
specify borders. If you do not specify borders for the parameterized string, 
then VuGen inserts an lrs_save_param function into your script. If you 
specify borders, VuGen inserts lrs_save_searched_string into your script 
since this function allows you to specify boundary arguments. 

Note that the lrs_save_param and lrs_save_searched_string functions 
correlate the data. This means that it stores the data that is received, for use 
in a later point within the test. Since correlation stores the received data, it 
only applies to Receive buffers and not to Send buffers. The recommended 
procedure is to select a string of dynamic data within the Receive buffer that 
you want to parameterize. Use that same parameter in a subsequent Send 
buffer. 

This type of correlation should not be confused with simple 
parameterization. Simple parameterization (Insert > New Parameter) only 
applies to data within Send buffers. You set up a parameter and assign it 
several values. VuGen uses the different values in each of the test runs or 
iterations. For more information, see “Creating Parameters” in Volume I-
Using VuGen. 

The next sections discuss the correlation of data in Receive buffers.
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After you create a parameter, VuGen lists all the locations in which it 
replaced the string with a parameter. VuGen also provides information 
about the creation of the parameter—the buffer in which it was created and 
the offset within the buffer. It lists all occurrences of the parameter in the 
Output Window’s Parameters tab, below the snapshot view. 

VuGen allows you to manipulate the parameters:

➤ Filtering. You can filter the parameter replacements by the parameter name.

➤ Go to Source. Select a replacement and click Go To Source to jump to the 
exact location of the replaced parameter within the buffer. 

➤ Deleting. You can delete any one of the parameters. When you delete a 
parameter, VuGen replaces the data with its original value and removes the 
parameterization function from the script. 

➤ Name. You can provide a name to each replacement.

➤ Undo Replacement. You can also undo one or more replacements displayed 
in the list. 
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To parameterize data from the snapshot window:

 1 Select the data you want to parameterize and choose Create Parameter from 
the right-click menu (only available for Receive buffers). A dialog box opens:

 2 Specify a name for the parameter in the Parameter Name box.

 3 Select a range of characters to parameterize. By default, VuGen takes the 
range of data that you selected in the buffer. To select a range other than the 
one that appears in the dialog box, click Select Range. A small dialog box 
opens indicating the selected range. 

Choose a range in the buffer snapshot window and then click Done.

 4 If the parameter data is not constant but its borders are consistent, you can 
specify a right and left boundary. 
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To specify boundaries: 

➤ Select the Extract Parameter Data Using Boundaries check box. VuGen 
changes the function in the Script Statement section from 
lrs_save_param to lrs_save_searched_string. Click Done.

➤ Click the browse button adjacent to the Left box in the Boundaries 
section. A small dialog box opens, indicating your selection within the 
buffer. Select the boundaries within the buffer and click Done. Repeat 
this step for the right boundary.

 5 Make the desired modifications to the arguments in the Script Statement 
section. For example you can add _ex to the lrs_save_param function to 
specify an encoding type. For more information about these functions refer 
to the Online Function Reference (Help > Function Reference).

 6 Click OK to create the parameter. VuGen asks you for a confirmation before 
replacing the parameter. Click Yes. You can view all the replacements in the 
Parameters tab.

 7 To jump to the original location of the parameter within its buffer, select it 
and click Go To Source.

 8 To jump to the buffer location of the selected replacement, select it and click 
Go To.

 9 To delete an entire parameter, choose the parameter in the Filter box and 
click Delete Parameter.

 10 To undo a replacement, select it in the Parameters tab and click Undo. To 
undo all replacements of the displayed parameter, select it in the Parameters 
tab and click Undo All. 

 11 When you undo specific replacements, the Parameterized column shows No 
for that occurrence. To reapply the parameterization rule to an occurrence 
that was undone, select it and choose Replace With Parameter from the 
right-click menu.

 12 To delete an entire parameter and undo all the replacements, select the 
parameter in the Filter box and click Delete Parameters.

 13 Choose Vuser > Parameter List to assign data to the parameters.
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Modifying Buffer Names

You can modify the name of a buffer using the Script view of the data.ws 
file. If you modify a buffer name after recording, this will affect the replay of 
the Vuser script. You can view the contents of the renamed buffer in the 
Script view or in Tree view using the Buffer Navigator. 

If you created bookmarks in the buffer and it is not longer available, VuGen 
prompts you to delete the bookmarks within the buffer in which they were 
defined.

If you created parameters in the buffer and it is not longer available, VuGen 
prompts you to delete the parameters from the buffer in which they were 
defined. When you delete the parameter, all replacements are undone, even 
those in other buffers. 

When you view the renamed buffer in the Buffer Navigator, VuGen warns 
you that parameter creation will be disabled within that buffer.
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Viewing Windows Socket Data in Script View

When you use VuGen to create a Windows Sockets Vuser script, your actions 
are recorded into the three sections of the script: vuser_init, Actions, and 
vuser_end. In addition to the Vuser script, VuGen also creates a data file, 
data.ws that contains the data that was transmitted or received during the 
recording session. You can use VuGen to view the contents of the data file 
by selecting data.ws in the Data Files box of the main VuGen window. 

The option to view a data file is available by default for Windows Sockets 
scripts. Note that you can only view the data in script view. 

Several LRS functions, such as lrs_receive and lrs_send, handle the actual 
data that is transferred between servers and clients. The data that is received 
or transmitted is stored in data buffers, which can be very large. In order to 
simplify the appearance of the Vuser script, the actual data is stored in 
external files—not in the C file. When a data transfer occurs, the data is 
copied from the external file into a temporary buffer. 

The external file, data.ws, contains the contents of all the temporary 
buffers. The buffers’ contents are stored as sequential records. The records 
are marked by identifiers indicating whether the data was sent or received, 
and the buffer descriptor. The LRS functions use the buffer descriptors to 
access the data. 
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The descriptors have one of the following formats:

The buffer index begins with 0 (zero), and all subsequent buffers are 
numbered sequentially (1,2,3 etc.) regardless of whether they are send or 
receive buffers. 

In the following example, an lrs_receive function was recorded during a 
Vuser session:

In this example, lrs_receive handled data that was received on socket1. The 
data was stored in the fifth receive record(buf4)—note that the index 
number is zero-based. The corresponding section of the data.ws file shows 
the buffer and its contents. 

Understanding the Data File Format

The data.ws data file has the following format:

➤ File header

➤ A list of buffers and their contents

recv bufindex  number of bytes received
send bufindex

lrs_receive("socket1", "buf4", LrsLastArg) 

recv buf4 39
"\xff\xfb\x01\xff\xfb\x03\xff\xfd\x01"
"\r\n"
"\r\n"
"SunOS UNIX (sunny)\r\n"
"\r"
"\x0"
"\r\n"
"\r"
"\x0"
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The file header includes an internal version number of the data file format. 
The current version is 2. If you try to access data from a data file with format 
version 1, VuGen issues an error.

An identifier precedes each record, indicating whether the data was received 
or sent, followed by the buffer descriptor, and the number of bytes received 
(for lrs_receive only). The buffer descriptor contains a number identifying 
the buffer. 

For example,

indicates that the buffer contains data that was received. The record number 
is 5, indicating that this receive operation was the sixth data transfer (the 
index is zero based), and twenty-five bytes of data were received. 

If your data is in ASCII format, the descriptor is followed by the actual ASCII 
data that was transferred by the sockets.

If your data is in EBCDIC format, it must be translated through a look-up 
table. For information on setting the translation table, see “Setting the 
WinSock Recording Options” on page 340. The EBCDIC whose ASCII value 
(after translation) is printable, is displayed as an ASCII character. If the ASCII 
value corresponds to a non-printable character, then VuGen displays the 
original EBCDIC value. 

;WSRData 2 1

recv buf5 25

recv buf6 39
"\xff\xfb\x01\xff\xfb\x03\xff\xfd\x01"
"\r\n"
"SunOS UNIX (sunny)\r\n"
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The following segment shows the header, descriptors, and data in a typical 
data file:

Viewing Buffer Data in Hexadecimal format

VuGen contains a utility allowing you to view a segment of data, displaying 
it in hexadecimal and ASCII format, while indicating the offset of the data. 

To display the data in the viewer window, select the data and press F7. If the 
selected text is less than four characters, VuGen displays the data in short 
format, showing the hexadecimal, decimal and octal representations.

You can customize the short format in the conv_frm.dat file as described in 
“Setting the Display Format” on page 365.

;WSRData 2 1

send buf0
"\xff\xfd\x01\xff\xfd\x03\xff\xfb\x03\xff\xfb\x18"

recv buf1 15
"\xff\xfd\x18\xff\xfd\x1f\xff\xfd"
"#"
"\xff\xfd"
"'"
"\xff\xfd"
"$"

send buf2
"\xff\xfb\x18"
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If the selected text is more than four characters, VuGen displays the data in 
several columns in long format. You can customize the long format by 
modifying the conv_frm.dat file, as described in “Setting the Display 
Format” on page 365.

In the default format, the first column displays the character offsets from 
the beginning of the marked section. The second column displays the 
hexadecimal representation of the data. The third column shows the data in 
ASCII format. When displaying EBCDIC data, all non-printable ASCII 
characters (such as /n), are represented by dots. 

The F7 viewer utility is especially useful for parameterization. It allows you 
to determine the offset of the data that you want to save to a parameter. 

ASCII formatOffset Hexadecimal format
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To determine the offset of a specific character:

 1 View data.ws and select the data from the beginning of the buffer.

 2 Press F7 to display the data and the character offsets. Since more than four 
characters were selected, the data is displayed in long format.

 3 Locate the value you want to correlate in the ASCII data. In this example, we 
will correlate the number 13546 (a process ID during a UNIX session) which 
begins at the 31st character—the last character in the second line. 

ASCII formatOffset Hexadecimal format
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 4 Use the offset value in the lrs_save_param_ex function in order to correlate 
the value of the process ID. For more information, see “Correlating 
Statements” in Volume I-Using VuGen.

Setting the Display Format

You can specify how VuGen will display the buffer data in the viewer (F7) 
window. The conv_frm.dat file in the lrun/dat directory contains the 
following display parameters:

➤ LongBufferFormat. The format used to display five or more characters. Use 
nn for offset, XX for the hex data, and aa for ASCII data. 

➤ LongBufferHeader. A header to precede each buffer in Long buffer format.

➤ LongBufferFooter. A footer to follow each buffer in Long buffer format.

➤ ShortBufferFormat. The format used to display four characters or less. You 
can use standard escape sequences and conversion characters. 

The supported escape sequence characters are: 

\a Bell (alert)

\b Backspace

\f Formfeed

\n New line

\r Carriage return

\t Horizontal tab

\v Vertical tab

\' Single quotation mark

\" Double quotation mark

\\ Backslash

\? Literal question mark

\ooo ASCII character -octal
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The supported conversion characters are: 

➤ AnyBufferHeader. A header to precede each buffer.

➤ AnyBufferFooter. A footer to follow each buffer.

➤ NonPrintableChar. The character with which to represent non-printable 
ASCII characters.

➤ PrintAllAscii. Set to 1 to force the printing of non-printable ASCII characters. 

In the default settings, long and short formats are set, and a dot is specified 
for non-printable characters.

%a ASCII representation

%BX Big Endian (Network Order) Hex

%BO Big Endian (Network Order) Octal

%BD Big Endian (Network Order) Decimal

%LX Little Endian Hex

%LO Little Endian Octal

%LD Little Endian Decimal

[BufferFormats]
LongBufferFormat=nnnnnnnn      XX XX XX XX   XX XX XX XX   XX XX XX XX   XX XX 
XX XX     aaaaaaaaaaaaaaaa\r\n
LongBufferHeader=
LongBufferFooter=
ShortBufferFormat=ASCII:\t\t\t%a\r\n\t\tNetwork Order\t\tLittle Endian\r\n\t\t (Big 
Edian)\r\nHex:\t\t%BX\t\t%LX\r\nOctal:\t\t%BO\t\t%LO\r\nDecimal:\t%BD\t\t%LD\r\n
AnyBufferHeader=
AnyBufferFooter=----------------------------------------------------------------------\r\n
NonPrintableChar=.
PrintAllAscii=0
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The default LongBufferFormat is displayed as:

The default ShortBufferFormat is displayed as:
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Debugging Tips

VuGen offers several means which allow you to debug your script. You can 
view the various output logs and windows for detailed messages issued 
during execution.

Specifically for Windows Sockets Vuser scripts, VuGen provides additional 
information about buffer mismatches. A buffer mismatch indicates a 
variation in the received buffer size (generated during replay) and the 
expected buffer (generated during record). However, if the received and 
expected buffer are the same size, even though the contents are different, a 
mismatch message is not issued. This information can help you locate a 
problem within your system, or with your Vuser script. 

You can view the buffer mismatch information in the Execution log. Choose 
View > Output to display the Execution log if it is not visible. 

Note that a buffer mismatch may not always indicate a problem. For 
example, if a buffer contains insignificant data such as previous login times, 
this type of mismatch can be ignored.

However, if there is a very large discrepancy between the size of the 
Expected and Received buffers, this could indicate a problem with your 
system. Check the data in the corresponding buffer for discrepancies.

In order for you to determine whether or not the mismatch is significant, 
you must thoroughly understand your application.

Mismatch (expected 54 bytes, 58 bytes actually received)
The expected buffer is:
=================
\r\n Last login: Wed Sep 2 10:30:18 from acme.hplab.c\r\n
=================
The received buffer is:
=================
\r\n Last login: Thu Sep 10 11:19:50 from dolphin.hplab.c\r\n
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Manually Correlating WinSock Scripts 

VuGen provides a user interface for correlating Vuser scripts. Correlation is 
required when working with dynamic data. A common issue with WinSock 
Vuser scripts is dynamic ports—ports whose numbers are assigned 
dynamically. While certain applications always use the same port, others use 
the next available port. If you try to replay a script and the recorded port is 
no longer available, your test will fail. To overcome this issue, you must 
perform correlation—save the actual run-time values and use them within 
the script. 

You can manually correlate a Vuser script using the correlation functions 
that save the dynamic values to a parameter. The lrs_save_param and 
lrs_save_param_ex functions let you save data to a parameter based on the 
offset of the data in the received buffer. An advanced correlation function 
lrs_save_searched_string lets you designate the data by specifying its 
boundaries and indicating which occurrence of the matched pattern to save 
to a parameter. The following example describes correlation using 
lrs_save_param_ex. For information about using other correlation 
functions, refer to the Online Function Reference.

To correlate the WinSock Vuser statements:

 1 Insert the lrs_save_param_ex statement into your script at the point where 
you want to save the buffer contents. You can save user, static, or received 
type buffers. 

 2 Reference the parameter.

View the buffer contents by selecting the data.ws file in the Data Files box 
of the main VuGen window. Locate the data that you want to replace with 
the contents of the saved buffer. Replace all instances of the value with the 
parameter name in angle brackets (< >).

lrs_save_param_ex (socket, type, buffer, offset, length, encoding, parameter);
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In the following example, a user performed a telnet session. The user used a 
ps command to determine the process ID (PID), and killed an application 
based on that PID. 

During execution, the PID of the procedure is different (UNIX assigns 
unique PIDs for every execution), so killing the recorded PID will be 
ineffective. To overcome this problem, use lrs_save_param_ex to save the 
current PID to a parameter. Replace the constant with the parameter.

 3 In the data.ws file, determine the buffer in which the data was received, 
buf47. 

 4 In the Actions section, determine the socket used by buf47. In this example 
it is socket1. 

frodo:/u/jay>ps
   PID TTY      TIME CMD
14602 pts/18 0:00 clock
14569 pts/18 0:03 tcsh

frodo:/u/jay>kill 14602
[3]    Exit 1                 clock
frodo:/u/jay>

recv buf47 98
"\r"
"\x00"
"\r\n"
"   PID TTY      TIME CMD\r\n"
" 14602 pts/18   0:00 clock\r\n"
" 14569 pts/18   0:02 tcsh\r\n"
"frodo:/u/jay>"

.

.

.
send buf58
"kill 14602"

lrs_receive("socket1", "buf47", LrsLastArg);
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 5 Determine the offset and length of the data string to save. Highlight the 
entire buffer and press F7. The offset of the PID is 11 and its length is 5 
bytes. For additional information about displaying the data, see 
“Understanding the Data File Format” on page 360.

 6 Insert an lrs_save_param_ex function in the Actions section, after the 
lrs_receive for the relevant buffer. In this instance, the buffer is buf47. The 
PID is saved to a parameter called param1. Print the parameter to the output 
using lr_output_message. 

 7 In the data file, data.ws, determine the data that needs to be replaced with a 
parameter, the PID.

 8 Replace the value with the parameter, enclosed in angle brackets.

lrs_receive("socket1", "buf79", LrsLastArg);
lrs_save_param("socket1", "user”, buf47, 11, 5, ascii, param1);
lr_output_message ("param1: %s", lr_eval_string("<param1>"));   
lr_think_time(10);
lrs_send("socket1", "buf80", LrsLastArg);

send buf58
"kill 14602"

send buf58
"kill <param1>"

Offset of first character in line 
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Creating Custom Vuser Scripts

In addition to recording a session, you can create a custom Vuser script. You 
can use both Vuser API functions and standard C, Java, VB, VBScript, or 
Javascript code.

This chapter includes:

 ➤  About Creating Custom Vuser Scripts on page 376

 ➤  C Vusers on page 377

 ➤  Using the Workflow Wizard for C Vuser Scripts on page 378

 ➤  Java Vusers on page 381

 ➤  VB Vusers on page 382

 ➤  VBScript Vusers on page 383

 ➤  JavaScript Vusers on page 384

The following information applies to all custom Vuser scripts: C, 
JavaScript, Java, VB and VBScript.
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About Creating Custom Vuser Scripts

VuGen allows you to program your own functions into the script, instead of 
recording an actual session. You can use the Vuser API or standard 
programming functions. Vuser API functions allow you to gather 
information about Vusers. For example, you can use Vuser functions to 
measure server performance, control server load, add debugging code, or 
retrieve run-time information about the Vusers participating in the test or 
monitoring.

This chapter describes how to program a Vuser script from within the 
VuGen editor, incorporating your application’s libraries or classes. 

You can also develop a Vuser script through programming within the Visual 
C and Visual Basic environments. In these environments, you develop your 
Vuser script within your development application, while importing the 
Vuser API function libraries. For more information, see “Creating Vuser 
Scripts in Visual Studio” in Volume I-Using VuGen.

To create a customized script, you first create a skeleton script. The skeleton 
script contains the three primary sections of a script: init, actions, and end. 
These sections are empty and you manually insert functions into them. 

You can create empty scripts for the following programming languages:

➤ C

➤ Java

➤ Visual Basic

➤ VBScript

➤ JavaScript

Note: When working with JavaScript and VBScript Vusers, the COM objects 
that you use within your script must be fully automation compliant. This 
makes it possible for one application to manipulate objects in another 
application, or to expose objects so that they may be manipulated.
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C Vusers

In C Vuser Scripts, you can place any C code that conforms with the 
standard ANSI conventions. To create an empty C Vuser script, choose C 
Vuser from the Custom category, in the New Virtual User dialog box. VuGen 
creates an empty script:

You can use C Vuser functions in all of Vuser script types that use C 
functions. 

You can also refer to the Online Function Reference (Help > Function 
Reference) for a C reference with syntax and examples of commonly used C 
functions.

Action1()
{

return 0;
}
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Using the Workflow Wizard for C Vuser Scripts

The Workflow Wizard guides you through the steps of creating a script. By 
clicking on a link in the Tasks pane, you can read about the steps in creating 
a script, and view information about your replay. Use the Back and Next 
buttons to navigate between screens.

 

If you do not see the Workflow Wizard, make sure that the Tasks pane is 
open. (You show and hide the Task pane using the Tasks button on the 
toolbar). Then click the first link, Introduction.

For more information about the wizard, see Chapter 3, “Viewing the VuGen 
Workflow.”
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Create the Script
The Create Script window contains several guidelines for creating a Web 
Services script.

➤ Adding Functions. describes how and where to enter the functions.

➤ Verifying Your Script. describes how to verify your script after adding 
functions.

Guidelines for Using C Functions
All standard ANSI-C conventions apply to C Vuser scripts, including control 
flow and syntax. You can add comments and conditional statements to the 
script just as you do in other C programs. You declare and define variables 
using ANSI C conventions.

The C interpreter that is used to run Vuser scripts accepts the standard ANSI 
C language. It does not support any Microsoft extensions to ANSI C. 

Before you add any C functions to a Vuser script, note the following 
limitations:

➤ A Vuser script cannot pass the address of one of its functions as a callback 
to a library function.

➤ The stdargs, longjmp, and alloca functions are not supported in Vuser 
scripts. 

➤ Vuser scripts do not support structure arguments or return types. Pointers 
to structures are supported. 

➤ In Vuser scripts, string literals are read-only. Any attempt to write to a 
string literal generates an access violation.

➤ C Functions that do not return int, must be casted. For example, 
extern char * strtok(); 
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Calling libc Functions

In a Vuser script, you can call libc functions. However, since the interpreter 
that is used to run Vuser scripts does not support any Microsoft extensions 
to ANSI C, you cannot use Microsoft's include files. You can either write 
your own prototypes, or ask HP Customer Support to send you ANSI-
compatible include files containing prototypes for libc functions.

Linking Mode

The C interpreter that is used to run Vuser scripts uses a "lazy" linking mode 
in the sense that a function need not be defined at the start of a run, as long 
as the function is defined before it is used. For example:

lr_load_dll("mydll.dll");
myfun();  /* defined in mydll.dll -- can be called directly, 

immediately after myfun.dll is loaded. */
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Java Vusers

In Java Vuser scripts, you can place any standard Java code. To create an 
empty Java Vuser script, choose Java Vuser from the Custom category, in the 
New Virtual User dialog box. VuGen creates an empty Java script:

Note that for Java type Vusers, you can only edit the Actions class. Within 
the Actions class, there are three methods: init, action, and end. Place 
initialization code in the init method, business processes in the action 
method, and cleanup code in the end method. 

import lrapi.lr;

public class Actions
{

public int init() {
return 0;

}

public int action() {
return 0;

}

public int end() {
return 0;

}
}
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VB Vusers

You can create an empty Visual Basic Vuser script, in which you can place 
Visual Basic code. This script type lets you incorporate your Visual Basic 
application into VuGen. To create an empty VB Vuser script, choose VB 
Vuser from the Custom category, in the New Virtual User dialog box. VuGen 
creates an empty VB script:

VuGen creates three sections, vuser_init, action, and vuser_end. Each of 
these sections contain a VB function—Init, Actions, and Terminate 
respectively. You place your code within these functions, as indicated by the 
TO DO comment. 

An additional section that is viewable from VuGen, is the global.vba file, 
which contains the object and variable global declarations for Vusers and 
the VB application. 

Public Function Actions() As Long

‘"TO DO: Place your action code here

Actions = lr.PASS
End Function
382



Chapter 23 • Creating Custom Vuser Scripts
VBScript Vusers

You can create an empty VBScript Vuser script, in which you can place 
VBScript code. This script type lets you incorporate your VBScript 
application into VuGen. To create an empty VBScript Vuser script, choose 
VB Script Vuser from the Custom category, in the New Virtual User dialog 
box. VuGen creates an empty VBScript Vuser script:

VuGen creates three sections, vuser_init, action, and vuser_end. Each of 
these sections contain a VBScript function—Init, Actions, and Terminate 
respectively. You place your code within these functions, as indicated by the 
TO DO comment. 

An additional section that is viewable from VuGen, is the global.vbs file, 
which creates the objects for the Vuser API functions and VB Script. For 
example, for LoadRunner, the following code creates the standard object, lr:

Public Function Actions() 

‘"TO DO: Place your action code here

Actions = lr.PASS
End Function

Set lr = CreateObject("LoadRunner.LrApi")
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JavaScript Vusers

You can create an empty JavaScript Vuser script, in which to place JavaScript 
code. This script type lets you incorporate your existing JavaScript 
application into VuGen. To create an empty JavaScript Vuser script, choose 
JavaScript Vuser from the Custom category, in the New Virtual User dialog 
box.

VuGen creates three sections, vuser_init, action, and vuser_end. Each of 
these sections contain a JavaScript function—Init, Actions, and Terminate 
respectively. You place your code within these functions, as indicated by the 
TO DO comment. 

An additional section that is viewable from VuGen, is the global.js file, 
which creates the objects for the Vuser API functions and the Javascript. For 
example, for LoadRunner, the following code creates the standard object, lr:

function Actions() 
{

//"TO DO: Place your business process/action code here

return(lr.PASS);
}

var lr = new ActiveXObject("LoadRunner.LrApi")
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Programming Java Scripts

VuGen supports Java type users on a protocol level. This chapter explains 
how to create a Java Vuser script by programming. For information on 
creating a Java Vuser script through recording, see the chapters describing 
the Java protocol.

This chapter includes:

 ➤  About Programming Java Scripts on page 386

 ➤  Creating a Java Vuser on page 387

 ➤  Editing a Java Vuser Script on page 387

 ➤  Java Vuser API Functions on page 389

 ➤  Working with Java Vuser Functions on page 391

 ➤  Setting your Java Environment on page 397

 ➤  Running Java Vuser Scripts on page 398

 ➤  Compiling and Running a Script as Part of a Package on page 399

 ➤  Programming Tips on page 400

The following information applies to Java and EJB Testing, Vuser scripts.
385



Chapter 24 • Programming Java Scripts
About Programming Java Scripts

To prepare Vuser scripts using Java code, use the Java type Vusers. This Vuser 
type supports Java on a protocol level. The Vuser script is compiled by a Java 
compiler and supports all of the standard Java conventions. For example, 
you can insert a comment by preceding the text with two forward slashes 
"//". 

Chapter 10, “Recording Java Language Vuser Scripts” explains how to create 
a script through recording using the Java Record Replay Vuser. To prepare a 
Java coded script through programming, see the following sections.

The first step in creating a Java compatible Vuser script, is to create a new 
Vuser script template of the type Java Vuser. Then, you program or paste the 
desired Java code into the script template. You can add Java Vuser functions 
to enhance the script and parameterize the arguments to use different values 
during iterations.

The Java Vuser script runs as a scalable multi-threaded application. If you 
include a custom class in your script, ensure that the code is thread-safe. 
Code that is not thread-safe may cause inaccurate results. For code that is 
not thread-safe, run the Java Vusers as processes. This creates a separate Java 
Virtual Machine for each process, resulting in a script that is less scalable. 

After you prepare a script, run it as a standalone test from VuGen. A Java 
compiler (Sun’s javac), checks it for errors and compiles the script. 

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 
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Creating a Java Vuser

The first step in creating a Java-compatible Vuser script is creating a Java 
Vuser template. 

To create a Java Vuser script:

 1 Open VuGen.

 2 Choose File > New or click the New button. The New Virtual User dialog box 
opens. 

 3 Select Custom > Java Vuser from the Select Vuser type list, and click OK. 
VuGen displays a blank Java Vuser script.

 4 Click the Actions section in the left frame to display the Actions class.

Editing a Java Vuser Script

After generating an empty template, you can insert the desired Java code. 
When working with this type of Vuser script, you place all your code in the 
Actions class. To view the Actions class, click Actions in the left pane. VuGen 
displays its contents in the right pane.

import lrapi.*;
public class Actions
{
public int init() {

return 0;
}

public int action() {
return 0;

}

public int end() {
return 0;

}
}
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The Actions class contains three methods: init, action, and end. The 
following table shows what to include in each method and when each 
method is executed.

Init Method
Place all the login procedures and one-time configuration settings in the init 
method. The init method is only executed once—when the Vuser begins 
running the script. The following sample init method initializes an applet.

Action Method
Place all Vuser actions in the action method. The action method is executed 
according to the number of iterations you set in the runtime settings. For 
more information on the iteration settings, see “Configuring Run-Time 
Settings” in Volume I-Using VuGen. The following sample action method 
retrieves and prints the Vuser ID. 

Script method Used to emulate... Is executed when...

init a login to a server the Vuser is initialized (loaded)

action client activity the Vuser is in "Running" status

end a log off procedure the Vuser finishes or is stopped

import org.omg.CORBA.*;
import org.omg.CORBA.ORB.*;
import lrapi.lr;

// Public function: init 
    public int init() throws Throwable {

// Initialize Orb instance...
MApplet mapplet = new MApplet("http://chaos/classes/", null);
orb = org.omg.CORBA.ORB.init(mapplet, null);

...

 public int action() {
lr.message("vuser: " + lr.get_vuser_id() + " xxx");
 return 0;

   }
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End Method
In the end method, place the code you want the Vuser to execute at the end 
of the script, such as logging off from a server, cleaning up the environment, 
and so forth. 

The end method is only executed once—when the Vuser finishes running 
the script. In the following example, the end method closes and prints the 
end message to the execution log.

Java Vuser API Functions

VuGen provides a specific Java API for Java Vuser scripts. These functions are 
all static methods of the lrapi.lr class. 

The Java API functions are classified into several categories: Transaction, 
Command Line Parsing, Informational, String, Message, and Run-Time 
functions.

For further information about each of these functions, refer to the Online 
Function Reference (Help > Function Reference). Note that when you create a 
new Java Vuser script, the import lrapi.* is already inserted into the script.

To use additional Java classes, import them at the beginning of the script as 
shown below. 

 public int end() {
        lr.message("End");
        return 0;
    }
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Remember to add the classes directory or relevant jar file to the classpath. 
Make sure that the additional classes are thread-safe and scalable.

import java.io.*;
import lrapi.*;

public class Actions
{
...
}
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Working with Java Vuser Functions

You can use Java Vuser functions to enhance your scripts by:

➤ Inserting Transactions

➤ Inserting Rendezvous Points

➤ Obtaining Vuser Information

➤ Issuing Output Messages

➤ Emulating User Think Time

➤ Handling Command Line Arguments

Inserting Transactions
You define transactions to measure the performance of the server. Each 
transaction measures the time it takes for the server to respond to specified 
requests. These requests can be short or complex tasks. When working with 
LoadRunner, you can analyze the performance per transaction during and 
after the scenario run, using online monitor and graphs.

You can also specify a transaction status: lr.PASS or lr.FAIL. You can let the 
Vuser automatically determine if the transaction was successful, or you can 
incorporate it into a conditional loop. For example, in your code you can 
check for a specific return code. If the code is correct, you issue a lr.PASS 
status. If the code is wrong, you issue an lr.FAIL status. 

To mark a transaction:

 1 Insert lr.start_transaction into the script, at the point where you want to 
begin measuring the timing of a task.

 2 Insert lr.end_transaction into the script, at the point where you want to 
stop measuring the task. Use the transaction name as it appears in the 
lr.start_transaction function.
391



Chapter 24 • Programming Java Scripts
 3 Specify the desired status for the transaction: lr.PASS or lr.FAIL.

Inserting Rendezvous Points
The following section does not apply to the HP Business Availability Center.

To emulate heavy user load on your client/server system, you synchronize 
Vusers to perform a task at exactly the same moment by creating a 
rendezvous point. When a Vuser arrives at the rendezvous point, it is held by 
the Controller until all Vusers participating in the rendezvous arrive.

You designate the meeting place by inserting a rendezvous function into 
your Vuser script. 

To insert a rendezvous point:

➤ Insert an lr.rendezvous function into the script, at the point where you want 
the Vusers to perform a rendezvous. 

public int action() {

for(int i=0;i<10;i++)
{

lr.message("action()"+i);
lr.start_transaction("trans1");
lr.think_time(2);
lr.end_transaction("trans1",lr.PASS);
}

return 0;
}

public int action() {

for(int i=0;i<10;i++)
{

lr.rendezvous("rendz1");
lr.message("action()"+i);
lr.think_time(2);
}
return 0;

}
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Obtaining Vuser Information
You can add the following functions to your Vuser scripts to retrieve Vuser 
information:

In the following example, the lr.get_host_name function retrieves the name 
of the computer on which the Vuser is running.

For more information about the above functions, refer to the Online Function 
Reference (Help > Function Reference). 

Issuing Output Messages
When you run a scenario, the Controller Output window displays 
information about script execution. You can include statements in a Vuser 
script to send error and notification messages to the Controller. The 
Controller displays these messages in the Output window. For example, you 
could insert a message that displays the current state of the client 
application. You can also save these messages to a file.

lr.get_attrib_string Returns a string containing command line 
argument values or runtime information 
such as the Vuser ID or the load generator 
name.

lr.get_group_name Returns the name of the Vuser’s group.

lr.get_host_name Returns the name of the load generator 
executing the Vuser script.

lr.get_master_host_name Returns the name of the machine running 
the LoadRunner Controller or Business 
Process Monitor.

lr.get_scenario_id Returns the ID of the current scenario. 
(LoadRunner only)

lr.get_vuser_id Returns the ID of the current Vuser. 
(LoadRunner only)

String my_host = lr.get_host_name();
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Note: Do not send messages from within a transaction. Doing so lengthens 
the transaction execution time and may skew the actual transaction results. 

You can use the following message functions in your Vuser script:

In the following example, lr.message sends a message to the output 
indicating the loop number:

For more information about the message functions, refer to the Online 
Function Reference (Help > Function Reference).

lr.debug_message Sends a debug message to the Output 
window.

lr.log_message Sends a message to the Vuser log file.

lr.message Sends a message to a the Output window.

lr.output_message Sends a message to the log file and Output 
window with location information.

for(int i=0;i<10;i++)
{

lr.message("action()"+i);
lr.think_time(2);
}
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You can instruct the Vusers to redirect the Java standard output and 
standard error streams to VuGen’s Execution log. This is especially helpful 
when you need to paste existing Java code or use ready-made classes 
containing System.out and System.err calls in your Vuser scripts. In the 
execution log, standard output messages are colored blue, while standard 
errors are shown in red. 

The following example shows how to redirect specific messages to the 
standard output and standard error using lr.enable_redirection: 

Note: When you set lr.enable_redirection to true, it overrides all previous 
redirections. To restore the former redirections, set this function to false. 

For additional information about this function, refer to the Online Function 
Reference (Help > Function Reference).

Emulating User Think Time
The time that a user waits between performing successive actions is known 
as the think time. Vusers use the lr.think_time function to emulate user 
think time. In the following example, the Vuser waits two seconds between 
loops:

lr.enable_redirection(true);

System.out.println("This is an informatory message…");  // Redirected
System.err.println("This is an error message…");  // Redirected

lr.enable_redirection(false);

System.out.println("This is an informatory message…");  // Not redirected
System.err.println("This is an error message…");  // Not redirected

for(int i=0;i<10;i++)
{

lr.message("action()"+i);
lr.think_time(2);
}
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You can use the think time settings as they appear in the script, or a factor of 
these values. To configure how Vusers handle think time functions, open 
the runtime settings dialog box. For more information, see “Configuring 
Run-Time Settings” in Volume I-Using VuGen.

For more information about the lr.think_time function, refer to the Online 
Function Reference (Help > Function Reference).

Handling Command Line Arguments
You can pass values to a Vuser script at runtime by specifying command line 
arguments when you run the script. You insert command line options after 
the script path and filename in the Controller or Business Process Monitor. 
There are three functions that allow you to read the command line 
arguments, and then to pass the values to a Vuser script: 

Your command line should have one of the following two formats where 
the arguments and their values are listed in pairs, after the script name: 

The following example shows the command line string used to repeat 
script1 five times on the machine pc4: 

lr.get_attrib_double Retrieves double precision floating point 
type arguments

lr.get_attrib_long Retrieves long integer type arguments

lr.get_attrib_string Retrieves character strings

script_name  -argument argument_value  -argument argument_value

script_name  -argument argument_value  -argument argument_value

script1 -host pc4 -loop 5 
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For more information on the command line parsing functions, refer to the 
Online Function Reference (Help > Function Reference). For more information 
on how to insert the command line options, refer to the LoadRunner 
Controller, Performance Center, or HP Business Availability Center 
documentation.

Setting your Java Environment 

Before running your Java Vuser script, ensure that the environment 
variables, PATH and CLASSPATH, are properly set on all machines running 
Vusers:

➤ To compile and replay the scripts, you must have complete JDK 
installation, either version 1.1 or 1.2, or 1.3. The installation of the JRE 
alone is not sufficient. It is preferable not to have more than one JDK or 
JRE installation on a machine. If possible, uninstall all unnecessary 
versions.

➤ The PATH environment variable must contain an entry for JDK/bin.

➤ For JDK 1.1.x, the CLASSPATH environment variable must include the 
classes.zip path, (JDK/lib subdirectory) and all of the VuGen classes 
(classes subdirectory).

➤ All classes used by the Java Vuser must be in the classpath—either set in 
the machine’s CLASSPATH environment variable or in the Classpath 
Entries list in the Classpath node of the Run-Time settings. 
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Running Java Vuser Scripts

Java Vuser scripts differ from C Vuser scripts in that they are first compiled 
and then executed; C Vuser scripts are interpreted. VuGen locates the javac 
compiler from within the JDK installation and compiles the Java code inside 
the script. This stage is indicated by the Compiling… status message in the 
bottom of the VuGen window. If errors occur during compilation, they are 
listed in the execution log. To go to the code in your script that caused the 
error, double-click on the error message containing the line number of the 
error. Fix the error and run the script again. 

If the compilation succeeds, the status message Compiling… changes to 
Running… and VuGen begins to execute the script. When you run the script 
again, VuGen runs the script without recompiling it, provided that no 
changes were made to the script. To debug your script further, you can use 
breakpoints and animated run type execution using the step option. 

Note: If you are making calls to JNDI extensions within your script, you may 
encounter problems trying to run your Vusers as threads. This happens 
because JNDI requires each thread to have its own context class loader. In 
order to run as threads, instruct each Vuser to run with its own context class 
loader, by adding the following line to the beginning of the init section:

DummyClassLoader.setContextClassLoader();
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Compiling and Running a Script as Part of a Package

When creating a Java Vuser script, you may need to use methods in other 
classes in which the class or method is protected. If you try to compile this 
type of script, you will receive errors in the compilation stage indicating that 
the methods are inaccessible. To make sure that your script can access these 
methods, insert the package name containing these methods at the top of 
the script, just as you would do in a standard Java program— 
<package_name>. In the following example, the script defines the just.do.it 
package which consists of a path:

In the above example, VuGen automatically creates the my/test directory 
hierarchy under the Vuser directory, and copies the Actions.java file to 
my/test/Actions.java, allowing it to compile with the relevant package. Note 
that the package statement must be the first line in the script, similar to Java 
(excluding comments).

package my.test;

import lrapi.*;
public class Actions
{
     :
}
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Programming Tips

When programming a Java Vuser script, you can paste ready-made code 
segments into scripts or import ready-made classes in order to invoke their 
methods. If Vusers need to run as threads under the Controller (for 
scalability reasons), you need to make sure that all of the imported code is 
thread-safe. 

Thread-safety is often difficult to detect. A Java Vuser may run flawlessly 
under VuGen and under the Controller with a limited number of Vusers. 
Problems occur with a large number of users. Code that is not thread-safe is 
usually the result of static class member usage as shown in the following 
example:

When you run one Vuser, the iteration_counter member accurately 
determines the number of iterations that were executed. When multiple 
Vusers run together as threads on a single virtual machine, the static class 
member iteration_counter is shared by all threads, resulting in an incorrect 
counting. The total number of all Vusers iterations is counted.

import lrapi.*;
public class Actions
{

private static int iteration_counter = 0;

public int init() {
return 0;

}

public int action() {
iteration_counter++;
return 0;

}

public int end() {
lr.message("Number of Vuser iterations: "+iteration_counter);
return 0;

}
}
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If code is known to be non thread-safe and you still want to import it into 
your script, you can run the Vusers as processes. For more information on 
running Vusers as threads or processes, see “Configuring Run-Time Settings” 
in Volume I-Using VuGen.

When you run a basic Java Vuser script, it usually consists of a single 
thread—the main thread. Only the main thread can access the Java Vuser 
API. If a Java Vuser spawns secondary worker threads, using the Java API 
may cause unpredictable results. Therefore, it is recommended to use the 
Java Vuser API only in the main thread. Note that this limitation also affects 
the lr.enable_redirection function.

The following example illustrates where the LR API may and may not be 
used. The first log message in the execution log indicates that the value of 
flag is false. The virtual machine then spawns a new thread set_thread. This 
thread runs and sets flag to true, but will not issue a message to the log, even 
though the call to lr.message exists. The final log message indicates that the 
code inside the thread was executed and that flag was set to true.

boolean flag = false;

public int action() {
lr.message("Flag value: "+flag);
Thread set_thread = new Thread(new Runnable();{

public void run() {
lr.message("LR-API NOT working!");
try {Thread.sleep(1000);} catch(Exception e) {}
flag = true;

}
});
set_thread.start();
try {Thread.sleep(3000);} catch(Exception e) {}
lr.message("Flag value: "+flag);
return 0;

}
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25
Recording COM Vuser Scripts

Many Windows applications use COM-based functions either directly, or 
through library calls. You can use VuGen to record a script that emulates a 
COM-based client accessing a COM server. The resulting script is called a 
COM Vuser script. You can also create COM Vuser scripts by using a Visual 
Basic add-in. For more information about the Visual Basic add-in, see 
“Creating Vuser Scripts in Visual Studio” in Volume I-Using VuGen.

Chapter 26, “Understanding COM Vuser Scripts,” explains how COM Vuser 
scripts operate.

This chapter includes:

 ➤  About Recording COM Vuser Scripts on page 406

 ➤  COM Overview on page 406

 ➤  Getting Started with COM Vusers on page 408

 ➤  Selecting COM Objects to Record on page 409

 ➤  Setting COM Recording Options on page 412

The following information applies only to COM Vuser scripts.
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About Recording COM Vuser Scripts

When you record COM client applications, VuGen generates functions that 
describe COM client-server activity. The recorded script contains interface 
declarations, API calls and instance calls to methods. Each COM function 
begins with an lrc prefix. 

You can view and edit the recorded script from the VuGen’s main window. 
The COM API/method calls that were recorded during the session are 
displayed in the window, allowing you to visually track application 
COM/DCOM calls. 

You can indicate the programming language in which to create a Vuser 
script—either C or Visual Basic scripting. For more information, see “Setting 
Script Generation Preferences” in Volume I-Using VuGen. 

COM Overview

This section provides an outline of COM technology. This should be enough 
to get you started with COM Vuser scripts. Refer to Microsoft Developer’s 
Network (MSDN) and other documentation for further details.

COM (Component Object Model) is a technology for developing reusable 
software components ("plug-ins"). DCOM (Distributed COM) allows use of 
COM components on remote computers. Microsoft transaction servers 
(MTS), Visual Basic and Explorer all use COM/DCOM technology. Thus, the 
application you are testing may use COM technology indirectly, even 
though you don’t know it. You will probably have to include some, but 
certainly not all, of the COM calls made by your application in the Vuser 
script. 
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Objects, Interfaces and Type Libraries
COM objects are binary code modules. Each COM object implements one or 
more interfaces that allow client programs to communicate with it. You 
need to know about these interfaces in order to follow the COM calls in the 
Vuser scripts. Type libraries, used as a reference for accessing COM interface 
methods and parameters, contain descriptions of COM objects and 
interfaces. Each COM class, interface, and type library is identified by a 
Global Unique Identifier (GUID). 

COM Interfaces 
A COM interface provides a grouped collection of related methods. For 
example, a Clock object may have Clock, Alarm and Timer interfaces. Each 
interface has one or more methods. For example the Alarm interface may 
have AlarmOn and AlarmOff methods. 

An interface may also have one or more properties. Sometimes, the same 
function may be performed by calling a method or by setting or getting the 
value of a property. For example, you can set the Alarm Status property to 
On or call the AlarmOn method. 

A COM object may support many interfaces. The IUnknown interface is 
implemented by all components and is used to find out about other 
interfaces. Many components also implement the IDispatch interface, which 
exposes all other interfaces and methods of the object, allowing 
implementation of COM automation in scripting languages.

COM Class Context and Location Transparency
COM objects can run on the same machine as the client application, or on a 
remote server. COM objects that an application creates may be in a local 
library, a local process or a remote machine ("Remote Object Proxy"). The 
location of the COM object, known as the "Context," can be transparent to 
the application. Most users apply the Vusers to check the load on remote 
servers. Therefore, objects accessed by Remote Object Proxy are usually the 
most relevant for these tests. 
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COM Data Types
COM also provides several special data types, including safe arrays, BSTR 
strings and variants. You may need to use these data types for debugging, 
parameterization and similar tasks.

Getting Started with COM Vusers

This section describes the process of developing COM Vuser scripts. 

To develop a COM Vuser script: 

 1 Record the basic script using VuGen.

Start VuGen and create a new Vuser script. Specify COM as the type of Vuser. 
Choose an application to record and set the recording options. To set the 
script related recording options, see “Setting Script Generation Preferences” 
in Volume I-Using VuGen. To set the COM specific options and filters, see the 
“Setting COM Recording Options” on page 412. Record typical operations 
using your application.

For details about recording, see “Recording with VuGen” in Volume I-Using 
VuGen.

 2 Refine the Object Filter.

Use the log file that was generated to refine your choice of objects to be 
recorded in the filter. See the following section, “Selecting COM Objects to 
Record”, for details. 

 3 Enhance the script.

Enhance the Vuser script by inserting transactions, rendezvous points, and 
control-flow structures into the script.

For details, see “Enhancing Vuser Scripts” in Volume I-Using VuGen.

 4 Define parameters (optional).

Define parameters for the fixed-values recorded into your script. By 
substituting fixed-values with parameters, you can repeat the same business 
process many times using different values. 

For details, see “Creating Parameters” in Volume I-Using VuGen.
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 5 Configure the run-time settings.

The run-time settings control the Vuser behavior during script execution. 
These settings include loop, log, and timing information. 

For details, see “Configuring Run-Time Settings” in Volume I-Using VuGen.

 6 Run the script from VuGen.

Save and run the script from VuGen to verify that it runs correctly.

For details, see “Running Vuser Scripts in Standalone Mode” in Volume I-
Using VuGen.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

Selecting COM Objects to Record 

The application you are testing may use a great many COM objects. Only a 
few may actually create load and may be important for the load test. Thus, 
before you record a COM application, you should select the objects you 
want to record for the load test. VuGen allows you to browse for objects 
from type libraries that it can read on the local machine and on other 
computers in the network. 

Deciding Which Objects to Use
There are several ways to decide which COM objects should be included in 
the test. Try to determine which remote objects are used by the software. If 
you are unsure which objects to choose, try using the default filter. The 
Environments branch of the filter includes calls to three sets of objects 
(ADO, RDS and Remote) that are likely to generate load on remote servers. 
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You can also check the actual calls to refine the filter. After you have 
recorded the test, you can save the file and look in the data directory that 
VuGen creates for a file named lrc_debug_list_<nnn>.log", where nnn is the 
process number. This log file contains a listing of each COM object that was 
called by the recorded application, regardless of whether or not the 
recording filter included that object. Only calls that generate load on the 
server should be included for recording. 

For example, the following is a local COM of the Visual Basic library:

It should not be added since it does not generate load on the server.

Likewise, since the OLE DB and Microsoft Windows Common Controls are 
local objects, the following are examples of classes and libraries that are not 
going to place any load on the server and should not be recorded:

However, for example, a listing such as the following indicates a class that 
should be recorded since it does generate load on the server:

Calls to classes of the FRS library, used for instance in the flight_sample that 
is installed with VuGen, use server capacity and should be recorded. 

Class JetES {039EA4C0-E696-11D0-878A-00A0C91EC756}
was loaded from type library "JET Expression Service Type Library"
({2358C810-62BA-11D1-B3DB-00600832C573} ver 4.0)

Class DataLinks {2206CDB2-19C1-11D1-89E0-00C04FD7A829} 
was loaded from type library "Microsoft OLE DB Service Component 1.0 Type Library"
({2206CEB0-19C1-11D1-89E0-00C04FD7A829} ver 1.0) 

Class DataObject {2334D2B2-713E-11CF-8AE5-00AA00C00905}
was loaded from type library "Microsoft Windows Common Controls 6.0 (SP3)"
({831FDD16-0C5C-11D2-A9FC-0000F8754DA1} ver 2.0)

Class Order {B4CC7A90-1067-11D4-9939-00105ACECF9A}
was loaded from type library "FRS"
({B4CC7A8C-1067-11D4-9939-00105ACECF9A} ver 1.0)
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If a COM object itself calls other COM objects, all the calls will be listed in 
the type information log file. For example, every time the application calls 
an FRS class function, the FRS library calls the ActiveX Data Object (ADO) 
library. If several functions in such a chain are listed in a filter, VuGen 
records only the first call that initiates the chain. If you selected both FRS 
and ADO calls, only the FRS calls will be recorded. 

On the other hand, if you select only the ADO library in the filter, then calls 
to the ADO library will be recorded. It is often easier to record the call to the 
first remote object in the chain. In some cases, however, an application may 
use methods from several different COM objects. If all of them use a single 
object that puts a load on the server, you could only record the final 
common object. 

Which Objects Can Be Selected
VuGen can only record objects if it can read their type libraries. If the type 
libraries were not installed in the system or VuGen cannot find them, the 
COM objects will not be listed in the Recording Options dialog box. If they 
are used by your application, VuGen will not be able to identify these 
objects and will identify them as INoTypeInfo in the files.

Which Interfaces Can Be Excluded
For each object, the Recording Options dialog box will show you all 
interfaces that are listed in the Type Library, and allow you to specify 
inclusion or exclusion of each one. However, ADO, RDS and Remote 
Objects can be included in the filter as a group. The filter will not show the 
individual objects of those environments or their interfaces. Objects that 
you included from type libraries may also have interfaces that are not listed 
in the type library and therefore not shown in the Recording Options 
dialog. After generating a VuGen script, you can identify these interfaces in 
the script and get their GUID numbers from the interfaces.h file that VuGen 
generates. Using this information, you can exclude the interfaces as 
explained below.
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Setting COM Recording Options

Use the COM Recording Options dialog box to set the filtering and COM 
scripting options. You use the online browser to locate type libraries in the 
registry, file system, or the Microsoft Transaction Server (MTS).

For more information, see:

➤ Filtering Objects

➤ Setting the Filter

➤ Setting COM Scripting Options

Filtering Objects
The Filter options let you indicate which COM objects should be recorded 
by VuGen. You can select objects from within environments and libraries.

The Filter options set a default filter or create alternate filters. You can filter a 
recording session by environment and type libraries.
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DCOM Profile

➤ Default Filter. The filter to be used as the default when recording a COM 
Vuser script.

➤ New Filter. A clean filter based on the default environment settings. Note 
that you must specify a name for this filter before you can record with its 
settings. 

DCOM Listener Settings 

The DCOM Listener Settings display a tree hierarchy of type libraries. You 
can expand the tree to show all of the available classes in the type library. 
You can expand the class tree to show all of the interfaces supported by that 
class. 

To exclude a type library, clear the check box next to the library name. This 
excludes all of its classes in that type library. By expanding the tree, you can 
exclude individual classes or interfaces by clearing the check box next to the 
item. 

An interface can be implemented differently by various classes. When you 
exclude an interface that is implemented by other classes that have not been 
excluded, a dialog box opens asking you if you also want to exclude the 
interface in all classes that implement it this interface.

Note that when you clear the check box adjacent to an interface, it is 
equivalent to selecting it in the Excluded Interfaces dialog box.

➤ Environment. The environments to record: ADO objects, RDS Objects, 
and Remote Objects. Clear the objects you do not want to record.

➤ Type Libraries. A type library .tlb or .dll file, that represents the COM 
object to record. All COM objects have a type library that represents 
them. You can choose a type library from the Registry, Microsoft 
Transaction Server, or file system.
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Type Libraries. In the lower section of the dialog box, VuGen displays the 
following information for each type library.

➤ TypLib. The name of the type library (tlb file).

➤ Path. The path of the type library.

➤ Guid. The Global Unique Identifier of the type library.

Setting the Filter
This section describes how to set the filters.

To select which COM objects to record:

 1 Choose Tools > Recording Options from the main menu or click Options in 
the Start Recording dialog box. A dialog box opens displaying the Recording 
Options tree. Select the COM/DCOM:Filter node.

Expand the Environments sub-tree, to display the ADO, RDS and Remote 
objects listings. The Filter also includes a Type Libraries tree that is initially 
empty. You can add Type Libraries as described in the steps below. 

By default, all Environments are selected and calls to any of their objects are 
included in the filter. Clear the check box adjacent to ADO, RDS or Remote 
objects to exclude them from the filter. 

 2 Click Add to add another COM type library, and select a source to browse: 
registry, file system, or MTS, as described below.
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 3 Select Browse Registry to display a list of type libraries found in the registry 
of the local computer.

Select the check box next to the desired library or libraries and click OK.

 4 To add a type library from the file system, click Add and select Browse file 
system.

Select the desired file and click OK. 

 5 Once the type library appears in the list of Type Libraries, you can expand 
the tree to show all of the available classes in the type library. You can 
expand the class tree to show all of the interfaces supported by that class. 

To exclude a type library, clear the check box next to the library name. This 
excludes all of its classes in that type library. By expanding the tree, you can 
exclude individual classes or interfaces by clearing the check box next to the 
item.
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When you clear a check box adjacent to an interface, it is equivalent to 
selecting it in the Excluded Interfaces dialog box.

 6 An interface can be implemented differently by various classes. When you 
exclude an interface that is implemented by other classes that have not been 
excluded, VuGen displays the following warning:

If you check Don’t ask me again and close the dialog box, then the status of 
all instances of the interface in all other classes will be changed 
automatically for this filter, whenever you change the status of the interface 
in one object. Click Yes to all to change the status of all instances of this 
interface for all other classes, click No to all to leave the status of all other 
instances unchanged. Click Next Instance to view the next class that uses 
this interface.
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 7 To add a component from a Microsoft Transaction Server, click Add and 
select Browse MTS. The MTS Components dialog box prompts you to enter 
the name of the MTS server.

Type the name of the MTS server and click Connect. Remember that to 
record MTS components you need an MTS client installed on your machine.

Select one or more packages of MTS components from the list of available 
packages and click Add. Once the package appears in the list of Type 
Libraries, you can select specific components from the package.
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 8 In addition to disabling and enabling recording of interfaces in the tree 
display, you can also click Exclude in the Recording Options dialog to 
include or exclude interfaces in the filter, whatever their origin.

Note that you can also exclude classes and interfaces by clearing the check 
box adjacent to the item, inside the type library tree hierarchy.

The checked interface listings are the ones that are excluded. You can also 
add interfaces that are not listed. Click Add Interface... in the Excluded 
Interfaces dialog box and enter the GUID number (interface ID) and name 
of the interface. You can copy the GUID from the interfaces.h file created by 
VuGen and listed in the selection tree in the left-hand column of the VuGen 
screen. Use the Add Interface… feature to exclude interfaces that are called 
needlessly by the script, but are not listed anywhere in the filter. 

 9 When you have finished modifying your filter, click OK to save it and close 
the dialog box. Click Save As to save a New filter, or to save an existing filter 
under a new name. You can select saved filters in subsequent recordings. 
Default settings are given initially in the Default filter.
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Setting COM Scripting Options
You can set additional options for your COM recording session, relating to 
the handling of objects, generation of logs, and VARIANT definitions.

The DCOM scripting options apply to all programming languages. These 
settings let you configure the scripting options for DCOM methods and 
interface handling.

➤ ADO Recordset filtering. Condense multiple recordset operations into a 
single-line fetch statement (enabled by default). 

➤ Declare Temporary VARIANTs as Globals. Define temporary VARIANT types 
as Globals, not as local variables (enabled by default). 

➤ Fill array in separate scopes. Fill in each array in a separate scope (enabled 
by default). 

➤ Fill structure in separate scopes. Fill in each structure in a separate scope 
(enabled by default). 

➤ Generate COM exceptions. Generate COM functions and methods that 
raised exceptions during recording (disabled by default).

➤ Generate COM statistics. Generate recording time performance statistics 
and summary information (disabled by default).
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➤ Limit size of SafeArray log. Limit the number of elements printed in the 
safearray log per COM call, to 16 (enabled by default). 

➤ Release COM Objects. Record the releasing of COM objects when they are 
no longer in use (enabled by default). 

➤ Save Recordset content. Stores Recordset content as grids, to allow viewing 
of recordset in VuGen (enabled by default). 

➤ Trap binded moniker objects. Trap all of the bound moniker objects 
(disabled by default). 

To set COM/DCOM options:

 1 Choose Tools > Recording Options from the main menu or click Options in 
the Start Recording dialog box. VuGen opens the Recording Options tree. 
Select the COM/DCOM:Options node.

 2 Enable the desired options by clicking the check boxes adjacent to them. 

 3 Click OK to save your settings and exit. 
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Understanding COM Vuser Scripts 

This chapter provides details about the scripts VuGen generates for COM 
client communications, including an explanation of the function calls and 
examples. For basic information about getting started with COM Vuser 
scripts, see Chapter 25, “Recording COM Vuser Scripts.”

This chapter includes:

 ➤  About COM Vuser Scripts on page 421

 ➤  Understanding VuGen COM Script Structure on page 422

 ➤  Examining Sample VuGen COM Scripts on page 424

 ➤  Scanning a Script for Correlations on page 430

 ➤  Correlating a Known Value on page 432

The following information applies only to COM Vuser scripts.

About COM Vuser Scripts

For each COM Vuser script, VuGen creates the following:

➤ Interface pointer and other variable declarations in file interfaces.h 

➤ Function calls that you can record in the vuser_init, actions or vuser_end 
sections.

➤ A user.h file containing the translation of the Vuser script into low level calls

When you record COM client communications, VuGen creates a script with 
calls to COM API functions and interface methods. In addition, you can 
manually program COM type conversion functions. 
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After you record the script, you can view any of these files by selecting them 
from the tree on the left-hand side of the VuGen screen. 

Each VuGen COM function has an lrc prefix, such as lrc_CoCreateInstance 
or lrc_long. The lrc functions are classified into several categories: Creating 
Instances, IDispatch Interface Calls, Type Conversion from String, 
Assignment to Variants, Create New Variants, Parameterization, Extracting 
From Variants. Array Types, ADO Recordset, Byte Array, VB Collection 
Support, and Debug functions.

For syntax and examples of the lrc functions, refer to the Online Function 
Reference (Help > Function Reference).

You can indicate the programming language in which to create a Vuser 
script—either C or Visual Basic scripting. For more information, see “Setting 
Script Generation Preferences” in Volume I-Using VuGen. 

Understanding VuGen COM Script Structure

VuGen COM scripts are structured in a special way to meet the needs of 
COM interfaces. 

Interface Methods
Calls to interface methods have the following names and syntax 
conventions:

Note that the instance is always the first parameter passed. 

The vendors of the respective COM components usually supply 
documentation for the interface functions.

Interface Pointers
The interface header file defines the interface pointers, as well as other 
variables, that can be used in the script. Each interface has an Interface ID 
(IID) which uniquely identifies the interface.

lrc_<interface name>_<method name>(instance,...);
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The format of the interface definition is:

In the following example, the interface type is IDispatch, the name of the 
interface instance is IDispatch_0, and the IID of IDispatch type is the long 
number string:

Vuser Script Statements
The COM Vuser script consist of code that creates object instances, retrieves 
interface pointers and calls the interface methods. Each user action may 
generate one or more COM calls. Each COM call is coded by VuGen as a 
group of statements. Each such group is contained in a separate scope 
enclosed in braces. Several different statements prepare for the main call by 
assigning values and performing type conversions. For example, the group 
of calls needed to create an object may look like this:

<interface type>*<interface name> = 0; //”{<IID of the interface type>}”

IDispatch* IDispatch_0= 0;//"{00020400-0000-0000-C000-000000000046}"

{
GUID pClsid = lrc_GUID("student.student.1");
IUnknown * pUnkOuter = (IUnknown*)NULL;
unsigned long dwClsContext = lrc_ulong("7");
GUID riid = IID_IUnknown;
lrc_CoCreateInstance(&pClsid, pUnkOuter, dwClsContext, &riid, (void**)&IUnknown_0, 
CHECK_HRES);
}
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Error Checking
Each COM method or API call returns an error value. VuGen will set a flag to 
check or not to check errors during replay, depending upon whether the call 
succeeded during the original recording. The flag appears as the last 
argument of the function call and has these values:

Examining Sample VuGen COM Scripts

This section shows examples of how VuGen emulates a COM client 
application.

Note that VuGen displays the results of a query in a grid. You can view up to 
200 records by scrolling through the grid. For more information, see 
“Working with Grids” on page 322 

Basic COM Script Operations
The basic operations are: 

➤ Instantiation of the object 

➤ Retrieving interface pointers 

➤ Calling interface methods

Each type of operation is done within a separate scope. 

CHECK_HRES This value is inserted if the function passed 
during recording and errors should be 
checked during replay.

DONT_CHECK_HRES This value is inserted if the function failed 
during recording and errors should not be 
checked during replay.
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Instantiation of the Object 
To use a COM object, the application must first instantiate it and get a 
pointer to an interface of that object.

VuGen does the following to instantiate an object: 

 1 VuGen calls lrc_GUID to get a unique ProgID for the object, to be stored in 
pClsid:

pClsid is the unique global CLSID of the object, which was converted from 
the ProgID student.student.1

 2 If the unknown interface pointer is a pointer to an aggregated object, VuGen 
retrieves the pointer to that object, or else it sets it to NULL:

 3 VuGen sets the contexts of the object to be created: 

dwClsContext contains the context of the object (in process, local, remote 
or combinations of these.)

 4 VuGen sets a variable to hold the requested interface ID, which is IUnknown 
in this case:

riid contains the interface ID of the IUnknown interface. 

 5 After the input parameters are prepared, a call to lrc_CoCreateInstance 
creates an object using the parameters defined in the preceding statements. 
A pointer to the IUnknown interface is assigned to output parameter 
IUnknown_0. This pointer is needed for subsequent calls:

GUID pClsid = lrc_GUID("student.student.1");

IUnknown * pUnkOuter = (IUnknown*)NULL;

unsigned long dwClsContext = lrc_ulong("7");

GUID riid = IID_IUnknown;

lrc_CoCreateInstance(&pClsid, pUnkOuter, dwClsContext, &riid, (void**)&IUnknown_0, 
CHECK_HRES);
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The input parameters were prepared and explained above. Since the call 
succeeded, VuGen sets error checking on during the user simulation by 
inserting the CHECK_HRES value. The call returns a pointer to the 
IUnknown interface in IUnknown_0, that can be used in subsequent calls.

Retrieving an Interface 
After creating an object, VuGen has access only to the IUnknown interface. 
VuGen will use the IUnknown interface for communicating with the 
object. This is done using the QueryInterface method of the IUnknown 
standard interface. The first parameter in a VuGen method call is the 
interface instance. In this case it is the IUnknown_0 pointer set previously 
by CoCreateInstance. The QueryInterface call requires as input the ID of 
the interface to be retrieved, and returns a pointer to the interface 
designated by that ID. 

To get the interface:

 1 First, VuGen sets a parameter, riid, equal to the ID of the Istudent interface: 

 2 A call to QueryInterface assigns a pointer to the Istudent interface to output 
parameter Istudent_0 if the Istudent object has such an interface: 

Using an Interface to Set Data
Here is an example of using the methods of the interface to set data. 
Suppose that in the application, the user is supposed to input a name. This 
activates a method for setting the name. VuGen records this in two 
statements. One statement is used for setting up the name string and the 
second one sets the name property.

GUID riid = IID_Istudent;

lrc_IUnknown_QueryInterface(IUnknown_0, &riid, (void**)&Istudent_0, 
CHECK_HRES);
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To set up the entire function call:

 1 First, VuGen sets a variable (Prop Value) equal to the string. The parameter is 
of type BSTR, a string type used in COM files: 

In subsequent stages, you will probably parameterize this call, replacing 
"John Smith" with a parameter, so that different names are used each time 
the Vuser script is run.

 2 Next, VuGen calls the Put_Name method of the Istudent interface to enter 
the name: 

Using an Interface to Return Data
Returning data from an application is different than entering the data, 
because you might want to store these values and use them as inputs in 
subsequent calls for parameterization.

The following is an example of what VuGen may do when the application 
retrieves data:

 1 Create a variable of the appropriate type (in this case a BSTR) that will 
contain the value of the property. 

 2 Get the value of the property, in this case a name, into the pVal variable 
created above, using the get_name method of the Istudent interface in this 
example.

 3 VuGen then generates a statement for saving the values.

BSTR PropValue = lrc_BSTR("John Smith");

lrc_Istudent_put_name(Istudent_0, PropValue, CHECK_HRES);

BSTR pVal;

lrc_Istudent_get_name(Istudent_0, &pVal, CHECK_HRES);

//lrc_save_BSTR("param-name",pVal); 
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The statement is commented out. You can remove the comments and 
change <param-name> to a variable with a meaningful name to be used for 
storing this value. VuGen will use the variable to save the value of pVal 
returned by the previous call. You can then use the variable as a 
parameterized input in subsequent calls to other methods. 

The IDispatch Interface
Most COM objects have specific interfaces. Many of them also implement a 
general-purpose interface called IDispatch, which VuGen translates in a 
special way. IDispatch is a "superinterface" that exposes all of the other 
interfaces and methods of a COM object. Calls to the IDispatch:Invoke 
method from VuGen scripts are implemented using lrc_Disp functions. 
These calls are constructed somewhat differently from calls to other 
interfaces. 

The IDispatch interface Invoke method can execute a method, it can get a 
property value, or it can set a value or reference value for a property. In the 
standard IDispatch:Invoke method these different uses are signalled in a 
wflags parameter. In the VuGen implementation they are implemented in 
different procedure calls that invoke a method or put or get a property. 

For example, a call to IDispatch to activate the GetAgentsArray method may 
look like this:

The parameters in the above call are:

retValue = lrc_DispMethod1((IDispatch*)IDispatch_0, "GetAgentsArray", /*locale*/1033, 
LAST_ARG, CHECK_HRES);

IDispatch_0 This is the pointer to the IDispatch interface 
returned by a previous call to the 
IUnknown:Queryinterface method.

GetAgentsArray This is the name of the method to invoke. Behind 
the scenes, VuGen will get the ID of the method 
from the name. 

1033 This is the language locale.
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In addition, there might be another parameter, OPTIONAL_ARGS. This 
signals that in addition to any standard parameters, VuGen is sending some 
optional arguments. Each optional argument consists of a pair giving the ID 
or name of the argument and its value. For example, the following call to 
lrc_DispMethod passes optional arguments "#3" and "var3":

The different lrc_Disp methods that use the IDispatch interface are detailed 
in the Online Function Reference. 

Type Conversions and Data Extraction
As shown in the above example, many COM parameters are defined as 
variants. To extract these values, VuGen uses a number of conversion 
functions, derived from the equivalent COM functions. The full list is given 
in the Online Function Reference. Previously, we showed how the 
lrc_DispMethod1 call was used to retrieve an array of name strings:

LAST_ARG This is a flag to tell the IDispatch interface that 
there are no more arguments. 

CHECK_HRES This flag turns on checking of HRES, since the call 
succeeded when it was recorded.

{
GUID riid = IID_IDispatch;
lrc_IOptional_QueryInterface(IOptional_0, &riid, (void**)&IOptional_0, 

CHECK_HRES);
}
{

VARIANT P1 = lrc_variant_short("47");
VARIANT P2 = lrc_variant_short("37");
VARIANT P3 = lrc_variant_date("3/19/1901");
VARIANT var3 = lrc_variant_scode("4");
lrc_DispMethod((IDispatch*)IOptional_0, "in_out_optional_args", /*locale*/1024, 

&P1, &P2, OPTIONAL_ARGS, "#3", &P3, "var3", &var3, LAST_ARG, CHECK_HRES);
}

VARIANT retValue = lrc_variant_empty();
retValue = lrc_DispMethod1((IDispatch*)IDispatch_0, "GetAgentsArray", /*locale*/1033, 
LAST_ARG, CHECK_HRES);
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The following example now shows how VuGen gets the strings out of 
retValue, which is a variant that will be read as an array of strings. 

First, VuGen extracts the BSTR array from the variant:

With all the values in array0, VuGen provides you with code that you can 
use to extract the elements from the array for later use in parameterization, 
as in the example below: 

VuGen has numerous type conversion functions and functions for 
extracting conventional types from variants. These are detailed in the Online 
Function Reference (Help > Function Reference)

Scanning a Script for Correlations

VuGen provides a correlation utility to help you repair your script and assist 
you in getting a successful replay. It performs the following steps: 

➤ scans for potential correlations

➤ insert the appropriate correlation function to save the results to a 
parameter

➤ replace the statement value with the parameter

You can perform automatic correlation on the entire script, or at a specific 
location in your script. 

This section describes how to determine the statement which needs to be 
correlated. If you already know which value you want to correlate, proceed 
to the next section for instructions on correlating a specific value. 

BstrArray array0 = 0;
array0 = lrc_GetBstrArrayFromVariant(&retValue);

//GetElementFrom1DBstrArray(array0, 0); // value: Alex
//GetElementFrom1DBstrArray(array0, 1); // value: Amanda
....
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To scan and correlate a script detected with automatic correlation:

 1 Select View > Output to display the output tabs at the bottom of the 
window. Check for errors in the Replay Log tab. Often, these errors can be 
corrected by correlation.

 2 Select Vuser > Scan for Correlations. VuGen scans the entire script and lists 
all possible values to correlate in the Correlated Query tab. 

 3 Correlate the value. In the Correlated Query tab, double-click on the result 
you want to correlate. This is located on the line of the message where it 
says 
grid column x, row x. 
VuGen sends the cursor to the grid location of the value in your script. 

 4 In the grid, choose Create Correlation from the right-click menu. VuGen 
prompts you to enter a parameter name for the result value.

 5 Specify a name, or accept the default. Click OK to continue. VuGen inserts 
the appropriate correlation statement (lrc_save_<type>) which saves the 
result to a parameter.

 6 Click Yes to confirm the correlation.

 7 A message box opens asking if you want to search for all occurrences of the 
value in the script. 
Click No to replace only the value in the selected statement. 
To search and replace additional occurrences click Yes. 

 8 A Search and Replace dialog box opens. Confirm any replacements, 
including your original statement. 

 9 Close the Search and Replace dialog box. VuGen replaces the statement 
value with a reference to the parameter. Note that if you choose to cancel 
the correlation, VuGen also erases the statement created in the previous 
step.
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Correlating a Known Value

If you know which value needs to be correlated, perform the following 
procedure:

To correlate a specific value:

 1 Locate the argument you want to correlate (usually in an lrc_variant_ 
statement) and select the value without the quotation marks. 

 2 Choose Vuser > Scan for Correlations (at cursor). 

VuGen scans the value and lists all results within the script that match this 
value. The correlation values are listed in the Correlated Query tab.

 3 In the Correlated Query tab, double-click on the result you want to 
correlate. This is located on the line of the message where it says 
grid column x, row x. 
VuGen sends the cursor to the grid location of the value in your script. 

 4 In the grid, select the value you want to correlate and choose Vuser > Create 
Correlation. VuGen prompts you to enter a parameter name for the result 
value.

 5 Specify a name, or accept the default. Click OK to continue. VuGen inserts 
the appropriate correlation statement (lrc_save_<type>) which saves the 
result to a parameter.

 6 Click Yes to confirm the correlation.

lrc_save_rs_param (Recordset20_0, 1, 1, 0, "Saved_AGENT_NAME");
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 7 A message box opens asking if you want to search for all occurrences of the 
value in the script. 
Click No to replace only the value in the selected statement. 
To search and replace additional occurrences click Yes. 

 8 A Search and Replace dialog box opens. Confirm any replacements, 
including your original statement. 
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Developing AJAX (Click and Script) Vusers 

VuGen allows you to create scripts that emulate AJAX (Asynchronous 
JavaScript and XML) enabled applications.

This chapter includes:

 ➤  About Developing AJAX (Click and Script) Vuser Scripts on page 437

 ➤  Recording an AJAX (Click and Script) Session on page 439

 ➤  Understanding AJAX (Click and Script) Scripts on page 439

The following information applies only to AJAX (Click and Script) Vuser 
scripts.

About Developing AJAX (Click and Script) Vuser Scripts

AJAX (Asynchronous JavaScript and XML) is a technique for creating 
interactive Web applications. With AJAX, Web pages exchange small packets 
of data with the server, instead of reloading an entire page. This reduces the 
amount of time that a user needs to wait when requesting data. It also 
increases the interactive capabilities and enhances the usability. 

Using AJAX, developers can create fast Web pages using Javascript and 
asynchronous server requests. The requests can originate from user actions, 
timer events, or other predefined triggers.

AJAX components, also known as AJAX controls, are GUI based controls 
that use the AJAX technique—they send a request to the server when a 
trigger occurs.
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For example, a popular AJAX control is a Reorder List control that lets you 
drag components to a desired position in a list. VuGen’s support for AJAX 
implementation is based on Microsoft’s ASP.NET AJAX Control Toolkit 
formerly known as Atlas. 

The supported frameworks for AJAX functions are:

➤ Atlas 1.0.10920.0/ASP.NET AJAX—All controls

➤ Scriptaculous 1.8—Autocomplete, Reorder List, and Slider

VuGen supports the following frameworks at the engine level. This implies 
that VuGen will create standard Web Click & Script steps, but not AJAX 
specific functions:

➤ Prototype 1.6

➤ Google Web Toolkit (GWT) 1.4
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Recording an AJAX (Click and Script) Session

To create a Vuser script that emulates AJAX enabled applications, you 
choose the AJAX (Click and Script) protocol type from the E-Business 
category. To begin recording, click the Record button and perform typical 
actions on the Web page, that are affected by AJAX such a reordering a list. 
For general information about creating and recording a script, see 
“Recording with VuGen” in Volume I-Using VuGen.

You can set event related recording options. For more information, see 
Chapter 37, “Recording with Click and Script.”

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

Understanding AJAX (Click and Script) Scripts

VuGen uses the control handler layer to create the effect of an operation on 
a GUI control. During recording, when encountering one of the supported 
AJAX controls, VuGen generates a function with an ajax_xxx prefix.
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In the following example, a user selected item number 1 (index=1) in an 
Accordion control. VuGen generated an ajax_accordion function. 

Note: When you record an AJAX session, VuGen generates standard Web 
(Click and Script) functions for objects that are not one of the supported 
AJAX controls. In the example above, the word FILE_PATH was typed into 
an edit box.

web_browser("Accordion.aspx", 
DESCRIPTION, 
ACTION, 
"Navigate=http://labm1app08/AJAX/Accordion/Accordion.aspx", 
LAST);

lr_think_time(5);
    
ajax_accordion("Accordion",

   DESCRIPTION,
  "Framework=atlas",
  "ID=ctl00_SampleContent_MyAccordion", 

     ACTION,
  "UserAction=SelectIndex",
  "Index=1",
  LAST);

web_edit_field("free_text_2", 
"Snapshot=t18.inf", 
DESCRIPTION, 
"Type=text", 
"Name=free_text", 
ACTION, 
"SetValue=" FILE_PATH , 
LAST);
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Developing AMF Vuser Scripts

VuGen allows you to create Vusers that emulate Flash Remoting using the 
AMF format.

This chapter includes:

 ➤  About Developing AMF Vuser Scripts on page 441

 ➤  Understanding AMF Terms on page 443

 ➤  Setting the AMF Recording Mode on page 443

 ➤  Setting AMF Code Generation Options on page 448

 ➤  Working with AMF Functions on page 449

 ➤  Correlating AMF Scripts on page 450

 ➤  Viewing AMF Data on page 454

 ➤  Understanding AMF Scripts on page 454

The following information applies only to AMF Vuser scripts.

About Developing AMF Vuser Scripts

Many client applications communicate with servers using RPC (Remote 
Procedure Calls). RPC, however, presents compatibility and security 
problems when working over the Internet. Firewalls and proxy servers often 
block this type of traffic.

HTTP is supported by all Internet browsers and servers. Therefore, HTTP is a 
preferred method of communication between client applications and servers 
when working over the Internet. 
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SOAP, an XML-based format, provides a secure way to communicate 
between applications over HTTP. However, since the messages are text- 
based, SOAP is inefficient when working with large messages such as Flash 
files and other RIAs (Rich Internet Applications). 

To overcome this inefficiency, Macromedia created a proprietary protocol, 
AMF (Action Messaging Format), which communicates over HTTP in binary 
format. The binary AMF data set is considerably smaller than that of SOAP’s 
text-based XML. 

A typical client application that submits AMF messages to a server is the 
Flash Player that plays Flash clips on personal computers. The Flash Player 
sends native Flash objects to an application server via a gateway. The 
gateway, known as the Flash Remoting gateway, is a server-side object, 
installed on either a Java (including ColdFusion) or .NET server. The 
gateway acts as a broker that handles requests between the Flash Player and 
the server. It translates Flash objects into native objects for the server and 
passes them on to the appropriate server-side services.

After the results are returned, the gateway serializes them back into native 
Flash objects and sends them to the Flash client via AMF.

To create a Vuser script that emulates the AMF traffic, you choose the AMF 
protocol type from the E-Business category. To begin recording, click the 
Record button and perform typical actions against the Web server. For 
general information about creating and recording a script, see “Recording 
with VuGen” in Volume I-Using VuGen.
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After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

Understanding AMF Terms

The following table provides definitions for the most common terms that 
relate to AMF:

Setting the AMF Recording Mode

You can instruct VuGen how to generate a script from a Flash Remoting 
session using the AMF and Web Protocols. The options are:

➤ AMF and Web

➤ AMF Only

➤ Web Only

Term/
Abbreviation

Description

ActionScript A script programming language used for controlling Flash movies 
and applications. Its syntax is similar to JavaScript.

AMF A proprietary binary communication protocol used for Flash 
Remoting.

Flash 
Remoting

Flash Remoting allows data to be exchanged between a Flash 
Player and an application server using the AMF format.

Flex An application server for generating RIAs (Reach Internet 
Applications).

SOAP A standard for exchanging XML-based messages over a computer 
network, normally using HTTP.
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By default, VuGen generates only AMF calls in the script. To configure the 
recorded protocols, open the Recording options (Tools > Recording Options) 
and select the General:Protocols node. For more information, see “Adding 
and Removing Protocols” in Volume I-Using VuGen.

Note: If you record with one of the above options, you can regenerate the 
script afterwards to include or exclude other protocols. For more 
information about regenerating your script, see Recording with VuGen” in 
Volume I-Using VuGen.

AMF and Web

If you enable both AMF and Web protocols, VuGen generates functions for 
the entire business process. When it encounters AMF data, it generates the 
appropriate AMF functions.
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In the following segment, VuGen generated both Web (web_url) and AMF 
(amf_call, amf_define_envelope_header_set) functions.

web_url("flash", 
"URL=http://testlab:8200/flash/", "Resource=0", 
…
"Snapshot=t1.inf", 
EXTRARES, 
"Url=movies/XMLExample.swf", "Referer=", ENDITEM, 
"Url=movies/JavaBeanExample.swf", "Referer=", ENDITEM, 
LAST);

web_link("Sample JavaBean Movie Source", 
"Text=Sample JavaBean Movie Source", 
"Snapshot=t2.inf", 
EXTRARES, 
"Url=XMLExample.swf", "Referer=", ENDITEM, 
"Url=JavaBeanExample.swf", "Referer=", ENDITEM, 
LAST);

amf_set_version("0");

amf_define_header_set("Id=amf_header_set", 
HEADER, 
"Name=amf_server_debug", 
"MustUnderstand=true", 
"Data=<object><boolean key=\"coldfusion\">true</boolean>

<boolean key=\"""amfheaders\">false</boolean>…
LAST);

amf_call("flashgateway.samples.FlashJavaBean.testDocument", 
"Gateway=http://testlab:8200/flashservices/gateway", 
"AMFHeaderSetId=amf_header_set", 
"Snapshot=t3.inf", 
MESSAGE, 
"Method=flashgateway.samples.FlashJavaBean.testDocument", 
"TargetObjectId=/1", 
BEGIN_ARGUMENTS, 
"<xmlString><![CDATA[<TEST message=\"test\"><INSIDETEST/>

</TEST>]]></""xmlString>", 
END_ARGUMENTS, 
LAST);
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AMF Only

If you are just interested in the AMF calls to emulate the Flash Remoting, 
you can disable the Web calls and only generate the AMF calls. 

The following example shows the above session recorded with the AMF 
protocol enabled and the Web protocol disabled.

Note that this recording method may not represent a complete business 
process—it only displays the Flash Remoting calls that use AMF.

Action()
{
amf_set_version("0");

amf_define_header_set("Id=amf_header_set", 
HEADER, 
"Name=amf_server_debug", 
"MustUnderstand=true", 
"Data=<object><boolean key=\"coldfusion\">true</boolean>

<boolean key=\"""amfheaders\">false</boolean>…
LAST);

amf_call("flashgateway.samples.FlashJavaBean.testDocument", 
"Gateway=http://testlab:8200/flashservices/gateway", 
"AMFHeaderSetId=amf_header_set", 
"Snapshot=t3.inf", 
MESSAGE, 
"Method=flashgateway.samples.FlashJavaBean.testDocument", 
"TargetObjectId=/1", 
BEGIN_ARGUMENTS, 
"<xmlString><![CDATA[<TEST message=\"test\"><INSIDETEST 

/></TEST>]]></"
"xmlString>", 
END_ARGUMENTS, 
LAST);

…

446



Chapter 28 • Developing AMF Vuser Scripts
Web Only

The Web Only option provides a fallback to the Web HTTP technology—
VuGen does not generate any AMF calls. Instead it generates 
web_custom_request functions with the Flash Remoting information. 

The following shows the above segment regenerated without AMF:

web_url("flash", 
"URL=http://testlab:8200/flash/", 
"Resource=0", 
"RecContentType=text/html", 
"Referer=", 
"Snapshot=t1.inf", 
"Mode=HTML", 
EXTRARES, 
"Url=movies/XMLExample.swf", "Referer=", ENDITEM, 
"Url=movies/JavaBeanExample.swf", "Referer=", ENDITEM, 
LAST);

web_link("Sample JavaBean Movie Source", 
"Text=Sample JavaBean Movie Source", 
"Snapshot=t2.inf", 
EXTRARES, 
"Url=XMLExample.swf", "Referer=", ENDITEM, 
"Url=JavaBeanExample.swf", "Referer=", ENDITEM, 
LAST);

web_custom_request("gateway", 
"URL=http://testlab:8200/flashservices/gateway", 
"Method=POST", 
"Resource=0", 
"RecContentType=application/x-amf", 
"Referer=", 
"Snapshot=t3.inf", 
"Mode=HTML", 
"EncType=application/x-amf", 

"BodyBinary=\\x00\\x00\\x00\\x01\\x00\\x10amf_server_debug\\x01\\x00\\x00\\x00`\\x0
3\\x00\ncoldfusion\\x01\\x01\\x00\namfheaders\\x01\\x00\\x00\\x03amf\\x01\\x00\\x00\\
x0Bhttpheaders\\x01\\x00\\x00\trecordset\\x01\\x01\\x00\\x05error\\x01\\x01\\x00\\x05tr
ace\\x01\\x01\\x00\\x07m_debug\\x01\\x01\\x00\\x00\t\\x00\\x01\\x00/flashgateway.sam
ples.FlashJavaBean.testDocument\\x00\\x02/1\\x00\\x00\\x004\n\\x00\\x00\\x00\\x01\\x
0F\\x00\\x00\\x00*<TEST message=\"test\"><INSIDETEST /></TEST>", 

LAST);
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Setting AMF Code Generation Options

When recording Flex applications, in certain cases VuGen may be unable to 
decode externalizable objects. This is due to a proprietary encoding scheme 
employed by the Flex 2 application. 

To overcome this issue, you can instruct VuGen to generate a Custom 
Request function in the case the code is not decipherable.

The AMF Recording option instructs VuGen to attempt to generate AMF Call 
requests for externalizable objects. It decodes all externalizable objects as 
standard AMF3 objects, generating amf_call functions. 

If you disable this option (default), VuGen generates a Custom Request 
function containing unparsed AMF3 binary data when encountering an 
externalizable object. 

Note: Enabling this option may reduce the stability of code generation.

To set the AMF code generation for externalizable objects:

 1 Open the Recording Options dialog box. Choose Tools > Recording Options 
or click the Options button in the Start Recording dialog box. The keyboard 
shortcut key is CTRL+F7.

 2 Select the AMF:Code Generation node. To generate standard amf_call 
functions for externalizable objects, enable the recording option.
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Working with AMF Functions

When you record a Flash Remoting session, VuGen generates AMF Vuser 
script functions that emulate your actions. All AMF functions begins with an 
amf prefix.

In the following example, the amf_define_header_set function defines a 
header set. The amf_call function accesses a gateway and sends a message to 
the server.

For detailed syntax information on these functions, refer to the Online 
Function Reference (Help > Function Reference).

amf_define_header_set("Id=amf_header_set", 
HEADER, 
"Name=amf_server_debug", 
"MustUnderstand=true", 
"Data=<object><boolean key=\"coldfusion\">true</boolean>

<boolean key=\"""amfheaders\">false</boolean>…
LAST);

amf_call("flashgateway.samples.FlashJavaBean.testDocument", 
"Gateway=http://testlab:8200/flashservices/gateway", 
"AMFHeaderSetId=amf_header_set", 
"Snapshot=t3.inf", 
MESSAGE, 
"Method=flashgateway.samples.FlashJavaBean.testDocument", 
"TargetObjectId=/1", 
BEGIN_ARGUMENTS, 
"<xmlString><![CDATA[<TEST message=\"test\"><INSIDETEST 

/></TEST>]]></"
"xmlString>", 
END_ARGUMENTS, 
LAST);
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Correlating AMF Scripts

Flash Applications often contain dynamic data, data that changes each time 
you run the script. For example, certain servers use links comprised of the 
current date and time. Alternatively, the object name may change from run 
to run.

When you record a Vuser script, VuGen records a set of data and argument 
values. When you replay the script, however, the server may reject these 
arguments and issue an error. This error could be the result of dynamic data 
that is outdated and no longer accepted by the server. 

To overcome this, you apply correlation to your script:

➤ Save the server response in preparation for extracting the required values.

➤ Extract the required values from the server response.

➤ Save the values to a parameter.

➤ Use those parameters as input to your AMF requests.

These errors are not always obvious, and you may only detect them by 
carefully examining Vuser log files. If you encounter an error when running 
your Vuser, examine the script at the point where the error occurred. Often, 
correlation will solve the problem by enabling you to use the results of one 
statement as input for another.

To perform correlation:

 1 Locate the step in your script that failed due to dynamic values that need 
correlation. 

Use the Replay Log to assist you in finding the problematic step.
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 2 Identify the server response with the correct value in one of the previous 
steps.

Examine the proceeding steps in Tree View and look for the value in the 
Server Response tab.

 3 Save the entire server response to a parameter.

Before you extract the value, the entire server response should be saved to a 
parameter as follows:

➤ Right-click the step node (in the Action pane) corresponding to the 
server response containing the value and select Properties.

➤ In the AMF Call Properties dialog, type a Response parameter name. For 
details, see “AMF Call Properties” on page 455.

➤ Click OK to save the new parameter name. 

 4 Save the original server response value to a parameter.

➤ In the XML tree of the Server Response, right-click the node above the 
value (for example, string), and select Save value in parameter.

➤ In the XML Parameter Properties dialog, specify a parameter Name. You 
will use this name in subsequent steps.

➤ Click OK. The script will now contain a new function, 
lr_xml_get_values.
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 5 Insert the parameter in the subsequent calls. 

In VuGen edit view, beginning with the call that failed, replace the value in 
all subsequent calls to the object with the parameter that you defined:

➤ Right-click the step node (in the Action pane) corresponding to the failed 
call and select Properties.

➤ Locate the argument that required correlation.

➤ In the Value box, type the parameter name in curly brackets, for example, 
{ParamValue_string}.

➤ Click OK.

 6 Run the script. 

Make sure that VuGen properly substitutes the argument value with the 
parameter value that you saved.
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In the following example, lr_xml_get_values retrieves the value from the 
response and creates the parameter ParamValue_string. This parameter, 
ParamValue_string, was used in the next amf_call function.

For more information about correlation for Web Vusers, see Chapter 44, 
“Setting Correlation Rules for Web Vuser Scripts.”

amf_call(
"ConnectService",
"Gateway=http://labm1app08/AMF/EchoAMF/gateway.aspx",
"Snapshot=t6.inf",
"ResponseParameter=resp",
MESSAGE,
"Method=EchoAMF.SpecialCases.ConnectService",
"TargetObjectId=/1",
BEGIN_ARGUMENTS,
END_ARGUMENTS,

LAST);

lr_xml_get_values("XML={resp}",
"FastQuery=/AMFPacket/Messages/Message/string",
"ValueParam=ParamValue_string",
LAST);

amf_call(
"ConnStatus",
"Gateway=http://labm1app08/AMF/EchoAMF/gateway.aspx",
"Snapshot=t7.inf",
MESSAGE,
"Method=EchoAMF.SpecialCases.ConnStatus",
"TargetObjectId=/2",
BEGIN_ARGUMENTS,
"<string>{ParamValue_string}</string>",
END_ARGUMENTS,

LAST);
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Viewing AMF Data

To view the AMF data in XML format, select the appropriate step in the Tree 
View. The right pane of VuGen displays the client request and server 
response in XML hierarchy. To view it in true XML, click the XML button.

To view all the elements of the message, make sure that the nodes of the 
XML are expanded. To view the XML argument values in a grid, select Show 
node values in grid. 

VuGen provides a utility to find XML through its XPath. You can also use 
the Query Builder to assist you in creating the queries. For more 
information, see “Querying an XML Tree” on page 471.

Understanding AMF Scripts

In the following example, the AMF script contains an AMF call, AMF header, 
and AMF envelope header. To view details of each node, you select a node 
and select Properties from the right-click menu.
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The following sections describe the AMF node properties:

➤ AMF Call Properties

➤ AMF Header Set Properties

➤ AMF Envelope Header Set Properties

AMF Call Properties
The AMF Call Properties dialog shows the AMF request details: the AMF call, 
one or more messages, and the arguments for each message. In the example 
below, the AMF call is EchoAny, and it is associated with the amf_headers 
header set.
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Each AMF call has three levels:

➤ The AMF Call level contains a step name, gateway, AMF header set, and 
response parameter

➤ The AMF Message level contains a method, target object ID, and Envelope 
header set

➤ The AMF Argument level contains a name, type, and value

AMF Header Set Properties
The AMF Header Set Properties dialog shows the AMF header set definition: 
One or more AMF header names and associated header data in XML format. 
In the example below, the header set has three headers.
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Each header has a Must understand argument which indicates whether 
processing the call continues if the server cannot interpret the header. If 
MustUnderstand is true, this header is mandatory and processing is aborted 
if it is not understood. 

AMF Envelope Header Set Properties
The AMF Envelope Header Set Properties dialog shows the AMF envelope 
header set and corresponding data for each header.
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Developing FTP Vuser Scripts

VuGen allows you to emulate network activity by directly accessing an FTP 
(File Transfer Protocol) server.

This chapter includes:

 ➤  About Developing FTP Vuser Scripts on page 459

 ➤  Working with FTP Functions on page 460

The following information applies only to FTP Vuser scripts.

About Developing FTP Vuser Scripts

The FTP protocol is a low-level protocol that allows you to emulate the 
actions of a user working against an FTP server. 

For FTP, you emulate users logging into to an FTP server, transferring files, 
and logging out. To create a script, you can record an FTP session or 
manually enter FTP functions.

When you record an FTP session, VuGen generates functions that emulate 
the mail client’s actions. If the communication is performed through 
multiple protocols such as FTP, HTTP, and a mail protocol, you can record all 
of them. For instructions on specifying multiple protocols, see “Recording 
with VuGen” in Volume I-Using VuGen.

To create a script for the FTP protocol, you choose the FTP protocol type in 
the E-Business category. To begin recording, you click the Record button and 
perform typical actions against the FTP server. For more information on 
creating and recording a script, see “Recording with VuGen” in Volume I-
Using VuGen.
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After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
HP Performance Center, or HP Business Availability Center documentation. 

Working with FTP Functions

When recording a FTP session, VuGen generates FTP functions. Each FTP 
function begins with an ftp prefix. 

Most FTP functions come in pairs—one for global sessions and one where 
you can indicate a specific mail session. To apply the action to all sessions, 
use the version without the ex suffix. To apply the action to a specific 
session, use the version with the session identifier with the ex suffix. For 
example, ftp_logon logs on to the FTP server globally, while ftp_logon_ex 
logs on to the FTP server for a specific session. 

For detailed syntax information on these functions, refer to the Online 
Function Reference (Help > Function Reference).

You can indicate the programming language in which to create a Vuser 
script. For more information, see “Setting Script Generation Preferences” in 
Volume I-Using VuGen. 

In the following example, the ftp_delete function deletes the test.txt file 
from the FTP server.

ftp_logon("FTP",
"URL=ftp://user:pwd@ftp.merc-int.com",
"LocalAddr=ca_server:21",
LAST);

ftp_delete("Ftp_Delete", 
"PATH=/pub/for_jon/test.txt", ENDITEM, 
LAST);

ftp_logout();
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Developing Flex Vuser Scripts

VuGen allows you to create Vusers that emulate the protocol suite provided 
with the Flex 2 SDK.

This chapter includes:

 ➤  About Developing Flex Vuser Scripts on page 461

 ➤  Working with Flex Functions on page 463

 ➤  Setting Flex Code Generation Options on page 464

 ➤  Correlating Flex Scripts on page 465

 ➤  Viewing Flex Data on page 470

 ➤  Setting Flex Step Properties on page 473

The following information applies only to Flex Vuser scripts.

About Developing Flex Vuser Scripts

Flex is a collection of technologies that provide developers with a 
framework for building RIAs (Rich Internet Applications) based on the Flash 
Player.

RIAs are lightweight online programs that provide users with more dynamic 
control than with a standard web page. Like Web applications built with 
AJAX, Flex applications are more responsive, because the application does 
not need to load a new Web page every time the user takes action. However, 
unlike working with AJAX, Flex is independent of browser implementations 
such as JavaScript or CSS. The framework runs on Adobe's cross-platform 
Flash Player.
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Flex 2 applications consisting of many MXML and ActionScript files. They 
are compiled into a single SWF movie file which can be played by Flash 
player, installed on the client’s browser. 

Flex 2 supports a variety of client/server communication methods, such as 
RPC, Data Management, and Real-Time messaging. It supports several data 
formats such as HTTP, AMF, and SOAP.

VuGen lets you create a Vuser script that emulates communication with Flex 
2 RPC services. VuGen’s Flex type lets you create scripts that emulate Flex 
applications working with AMF3 or HTTP data. For Flex applications 
working with SOAP data, use the Web Services Vuser type. 

The following sections describe how to create scripts for applications using 
AMF3 or HTTP communication. For information about Web Service 
recording, see Chapter 2, “Understanding the SOA Test Types.”

To create a script, you choose the Flex protocol type from the E-Business 
category. To begin recording, click the Record button and perform typical 
actions in your Flex application. For general information about creating and 
recording a script, see “Recording with VuGen” in Volume I-Using VuGen.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 
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Working with Flex Functions

When you record a Flex application, VuGen generates Flex Vuser script 
functions that emulate your application. The following functions represent 
the Flex Remoting steps: 

In the following example, flex_ping checks for the availability of a service. 
The flex_remoting_call function invokes the service remotely.

Function Name Description

flex_login Logs on to a password-protected Flex 
application. 

flex_logout Logs off of a password-protected Flex 
application. 

flex_ping Checks if a Flex application is available. 

flex_remoting_call Invokes one or more methods of a server-side 
Remote object (RPC). 

flex_web_request Sends an HTTP request with any method 
supported by HTTP.

flex_ping("1", 
"URL=http://testlab1/weborb30/console/weborb.aspx", 
"Snapshot=t6.inf", 
LAST);

flex_remoting_call("getProductEdition::GenericDestination", 
"URL=http://testlab1/weborb30/console/weborb.aspx", 
"Snapshot=t7.inf", 
INVOCATION, 
"Target=/2", 
"Operation=getProductEdition", 
"Destination=GenericDestination", 
"DSEndpoint=my-amf", 
"Source=Weborb.Management.LicenseService", 
"Argument=<arguments/>", 
LAST);
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The following functions represent the AMF over Flex steps: 

For detailed syntax information about all of the Flex functions, refer to the 
Online Function Reference (Help > Function Reference).

Setting Flex Code Generation Options

When recording Flex applications, in certain cases, VuGen may be unable to 
decode externalizable objects. This is due to a proprietary encoding scheme 
employed by the Flex 2 application. 

To overcome this issue, you can instruct VuGen to generate a 
flex_web_request function in the case the code is not decipherable.

The Flex Recording option instructs VuGen to attempt to generate Flex 
Remote requests for externalizable objects. It decodes all externalizable 
objects as standard AMF3 objects, generating flex_remoting_call functions. 

If you disable this option (default), VuGen generates a flex_web_request 
function containing unparsed AMF3 binary data when encountering an 
externalizable object. 

Note: Enabling this option may reduce the stability of code generation.

To set the Flex code generation for externalizable objects:

 1 Open the Recording Options dialog box. Choose Tools > Recording Options 
or click the Options button in the Start Recording dialog box. The keyboard 
shortcut key is CTRL+F7.

Function Name Description

flex_amf_call Sends an AMF request. 

flex_amf_define_header_set Defines a set of AMF headers. 

flex_amf_define_envleope_header_set Defines a set of envelope 
headers. 
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 2 Select the Flex:Code Generation node. To generate standard 
flex_remoting_call functions for externalizable objects, enable the 
recording option.

 3 Click OK.

Correlating Flex Scripts

Flex applications often contain dynamic data, data that changes each time 
you run the script. For example, the object name may change from run to 
run.

When you record a Vuser script, VuGen records a set of data and argument 
values. When you replay the script, however, the server may reject these 
arguments and issue an error. This error could be the result of dynamic data 
that is outdated and no longer accepted by the server. 

To overcome this, you apply correlation to your script:

➤ Save the server response in preparation for extracting the required values.

➤ Extract the required values from the server response.

➤ Save the values to a parameter.
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➤ Use those parameters as input to your Flex requests.

These errors are not always obvious, and you may only detect them by 
carefully examining Vuser log files. If you encounter an error when running 
your Vuser, examine the script at the point where the error occurred. Often, 
correlation will solve the problem by enabling you to use the results of one 
statement as input for another.

To perform correlation:

 1 Locate the step in your script that failed due to dynamic values that need 
correlation. 

Use the Replay Log to assist you in finding the problematic step.

Action.c(16): Error Server returned error for message #1 : "Incorrect session ID sent"/
Action.c(16): There was an error during the Flex Call ("ConnStatus")
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 2 Identify the server response with the correct value in one of the previous 
steps.

Double-Click the error in the Replay log to go to the step with the error. 
Examine the preceding steps in Tree View and look for the value in the 
Server Response tab.

 3 Save the entire server response to a parameter.

Before you extract the value, the entire server response should be saved to a 
parameter as follows:

➤ Right-click the step node (in the left Action pane) corresponding to the 
server response containing the value and select Properties.

➤ In the Flex Call Properties dialog box, type a Response parameter name.

➤ Click OK to save the new parameter name. 
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 4 Save the original server response value to a parameter.

➤ In the Replay Snapshot: Response Data, right-click the node above the 
value (for example, string), and select Save value in parameter.

➤ In the XML Parameter Properties dialog, specify a parameter Name. You 
will use this name in subsequent steps.

➤ Click OK. The script will now contain a new function, lr_xml_get_values.

 5 Insert the parameter in the subsequent calls. 

In VuGen edit view, beginning with the call that failed, replace the value in 
all subsequent calls to the object with the parameter that you defined:

➤ Right-click the step node (in the Action pane) corresponding to the failed 
call and select Properties.

➤ Locate the argument that required correlation.
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➤ In the Value box, type the parameter name in curly brackets, for example, 
{ParamValue_string}.

Click OK.

 6 Run the script. 

Make sure that VuGen properly substitutes the argument value with the 
parameter value that you saved.
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Viewing Flex Data

To view the Flex data, select the appropriate step in the Tree View. The right 
pane of VuGen displays a snapshot of the data. 

To view all the elements of the message, expand the desired nodes. You can 
view the Request or Response data for Recording and Replay, by clicking the 
appropriate buttons in the snapshot.

To view the data in its XML structure, click the XML button in the snapshot.
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Querying an XML Tree
VuGen provides a Query Builder that lets you create and execute queries on 
the XML. 

VuGen displays the XML code in an expandable tree. You can perform a 
query on your XML document, and search for a specific Namespace URI, 
value, or attribute. Note that all queries are case-sensitive.

To perform a query:

 1 In the Snapshot tab, select on the node that you want to search. Click the 
Find XML button. The Find XML dialog button opens.

 2 Select Request or Response. Enter an XPath query and click OK. To formulate 
a query, click Query Builder button. The XML Node Query dialog box opens.
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 3 Enable one or more items for searching.

 4 Enable the Name section to search for the name of a node or element.

 5 Enable the Namespace URI section to search for a namespace.

 6 Enable the Text section to search for the value of the element indicated in 
the Name box.

 7 Enable the Attributes section to search for an attribute. 

 8 Enter the search text in the appropriate boxes. To add an attribute, click the 
Add button. The Attribute Properties box opens. Enter an attribute name 
and value. Click OK.
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 9 Click OK in the XML Node Query dialog box. VuGen places the text of the 
query in the Find XML box. 

 10 Click Find Next to begin the search.

Setting Flex Step Properties

The Flex Vuser script contains a series of Flex calls. You can view 
information about each step by selecting it in the Tree view. 

The right pane has two tabs (for most Flex steps)—Snapshot and Properties 
The Snapshot tab shows the data, while the Properties step displays the 
properties each step:
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The following example shows the properties for a Flex Remoting Call step.

As you select each node, the right pane shows the properties specific for that 
node.
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Developing LDAP Vuser Scripts 

VuGen allows you to emulate the communication with an LDAP server.

This chapter includes:

 ➤  About Developing LDAP Vuser Scripts on page 475

 ➤  Working with LDAP Functions on page 476

 ➤  Defining Distinguished Name Entries on page 478

 ➤  Specifying Connection Options on page 479

The following information applies only to LDAP Vuser scripts.

About Developing LDAP Vuser Scripts

LDAP, the Lightweight Directory Access Protocol, is a protocol used to access 
a directory listing. The LDAP directory is composed of many LDAP entries. 
Each LDAP entry is a collection of attributes with a name, called a 
distinguished name (DN). For more information about DN, see “Defining 
Distinguished Name Entries” on page 478. 

LDAP directory entries are arranged in a hierarchical structure that reflects 
political, geographic, and/or organizational boundaries. Entries representing 
countries appear at the top of the tree. Below them are entries representing 
states or national organizations. Below them might be entries representing 
people, organizational units, printers, documents, or just about anything 
else. 

VuGen records communication over LDAP servers. It creates a script, with 
functions that emulate your actions. This includes logging in and out of the 
server, adding and deleting entries, and querying an entry. 
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To create a script for the LDAP protocol, you choose the LDAP protocol type 
in the E-Business category. To begin recording, choose Vuser > Start 
Recording, and perform typical actions against the LDAP server. For more 
information on the recording procedure, see “Recording with VuGen” in 
Volume I-Using VuGen.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
HP Performance Center, or HP Business Availability Center documentation. 

Working with LDAP Functions

You can indicate the programming language in which to create a Vuser 
script. For more information, see “Setting Script Generation Preferences” in 
Volume I-Using VuGen. 

LDAP Vuser script functions emulate the LDAP protocol. Each LDAP 
function begins with the mldap prefix. 

All LDAP functions come in pairs—one for global sessions and one where 
you can indicate a specific session. To apply the action to all sessions, use 
the version without the ex suffix. To apply the action to a specific session, 
use the version with the session identifier with the ex suffix. For example, 
mldap_logon logs on to the LDAP server globally, while mldap_logon_ex 
logs on to the LDAP server for a specific session.

For detailed syntax information on these functions, refer to the Online 
Function Reference (Help > Function Reference).
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In the following example, the user logs on to an LDAP server, ldap1. It adds 
an entry and then renames the OU attribute from Sales to Marketing. 

Action()
{

// Logon to the LDAP server
mldap_logon("Login", 

"URL=ldap://johnsmith:tiger@ldap1:80",
LAST);

// Add an entry for Sally R. Jones
mldap_add("LDAP Add",

  "DN=cn=Sally R. Jones,OU=Sales, DC=com",
  "Name=givenName", "Value=Sally", ENDITEM,
  "Name=initials", "Value=R", ENDITEM,
  "Name=sn", "Value=Jones", ENDITEM,
  "Name=objectClass", "Value=contact", ENDITEM,
  LAST);

// Rename Sally’s OU to Marketing
mldap_rename("LDAP Rename",

     "DN=CN=Sally R. Jones,OU=Sales,DC=com",
     "NewDN=OU=Marketing",
     LAST);

// Logout from the LDAP server
mldap_logoff();

return 0;
}
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Defining Distinguished Name Entries

The LDAP API references objects by its distinguished name (DN). A DN is a 
sequence of relative distinguished names (RDN) separated by commas.

An RDN is an attribute with an associated value in the form attribute=value. 
The attribute names are not case-sensitive. The following table lists the most 
common RDN attribute types.

The following are examples of distinguished names:

DN=CN=John Smith,OU=Accounting,DC=Fabrikam,DC=COM
DN=CN=Tracy White,CN=admin,DC=corp,DC=Fabrikam,DC=COM
The following table lists reserved characters that cannot be used in an 
attribute value. 

String Attribute Type

DC domainComponent 

CN commonName 

OU organizationalUnitName 

O organizationName 

STREET streetAddress 

L localityName 

ST stateOrProvinceName 

C countryName 

UID userid 

Character Description 

space or # character at the beginning of a 
string 

space character at the end of a string 

, comma
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To use a reserved character as part of an attribute value, you must precede it 
with an escape character, a backslash (\). If an attribute value contains other 
reserved characters, such as the equal sign (=) or non-UTF-8 characters, you 
must encode it in hexadecimal format—a backslash followed by two hex 
digits.

The following are examples of DNs that include escaped characters. The first 
example is an organizational unit name with an embedded comma; the 
second example is a value containing a carriage return.

Specifying Connection Options

Using the mldap_logon[_ex] function, you control the way you login to the 
LDAP server. 

When specifying the URL of the LDAP server, you specify how to connect 
and with what credentilals.

When specifying the server’s URL, use the following format:

+  plus sign 

" double quote 

\ backslash 

< left angle bracket 

>  right angle bracket 

;  semicolon 

DN=CN=Bitwise,OU=Docs\, Support,DC=Fabrikam,DC=COM
DN=CN=Before\0DAfter,OU=Test,DC=North America,DC=Fabrikam,DC=COM

ldap[s][username:[password]@][server[:port]]
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The following table shows several examples of connections to LDAP servers.

You can also specify LDAP modes or SSL certificates using the following 
optional arguments:

➤ Mode. The LDAP call mode: Sync or Async

➤ Timeout. The maximum time in seconds to search for the LDAP server.

➤ Version. The version of the LDAP protocol version 1,2, or 3

➤ SSLCertDir. The path to the SSL certificates database file (cert8.db)

➤ SSLKeysDir. The path to the SSL keys database file (key3.db)

➤ SSLKeyNickname. The SSL key nickname in the keys database file

➤ SSLKeyCertNickname. The SSL key's certificate nickname in the certificates 
database file

➤ SSLSecModule. The path to the SSL security module file (secmod.db)     

➤ StartTLS. Requires that the StartTLS extension's specific command must be 
issued in order to switch the connection to TLS (SSL) mode

For detailed information about these arguments, refer to the Online Function 
Reference (Help > Function Reference).

Syntax Description

ldap://a:b@server.co
m:389

Connects to the server (to 389 port) and then binds with 
username "a" , password "b"

ldap://:@server.com Connects to server (to default unsecured port 389) then 
binds anonymously with a NULL username and password 

ldaps://a:@server.co
m

Connects to server (to default secured port 636)and then 
binds with username "a", password ""

ldap://@server.com, 
ldap://server.com

Connects to server without binding

ldap://a:b@ Binds with username "a", password "b, executing a bind 
on the existing session without reconnecting

ldap://:@ Binds anonymously with a NULL username and password 
(executes bind on existing session without reconnecting)
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Recording Microsoft .NET Vuser Scripts

VuGen records applications that were created in the .NET Framework 
environment.

This chapter includes:

 ➤  About Recording Microsoft .NET Vuser Scripts on page 482

 ➤  Getting Started with Microsoft .NET Vusers on page 483

 ➤  Setting Microsoft .NET Recording Options on page 485

 ➤  Configuring the Recording Settings on page 486

 ➤  Viewing Scripts in VuGen and Visual Studio on page 491

 ➤  Configuring .NET Environment Run-Time Settings on page 493

 ➤  Viewing Data Sets and Grids on page 496

 ➤  Correlating Microsoft .NET Scripts on page 497

 ➤  Configuring Application Security and Permissions on page 500

 ➤  Recording WCF Duplex Communication on page 504

The following information only applies to Microsoft .NET Vuser scripts.

Before recording a script, it is recommended that you read Chapter 33, 
“Setting Filters for .NET Vuser Scripts.” These guidelines will help you create 
an optimal script that accurately emulates your application.
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About Recording Microsoft .NET Vuser Scripts

Microsoft .NET Framework provides a solid foundation for developers to 
build various types of applications such as ASP.NET, Windows Forms, Web 
Services, distributed applications, or applications that combine several of 
these models.

VuGen supports .NET as an application level protocol. It allows you to create 
Vuser scripts that emulate users of Microsoft .NET client applications created 
in its .NET Framework. VuGen records all of the client actions through 
methods and classes, and creates a script in C Sharp or VB .NET. 

By default, the VuGen environment is configured for .NET Remoting, 
ADO.NET, Enterprise Services, and WCF (Windows Communication 
Foundation) applications. Contact Customer Support for information on 
how to configure VuGen to record applications created with other client-
server activity.

For more information about .NET and the above environments, refer to the 
MSDN Web site, http://msdn2.microsoft.com.

Limitations
The following limitations apply to the VuGen recording of a Microsoft .NET 
application:

➤ Microsoft .NET scripts only support single-protocol recording in VuGen.

➤ Direct access to public fields is not supported—the AUT must access fields 
through methods or properties.

➤ VuGen does not record static fields in the applications—it only records 
methods within classes.

➤ Multi-threaded support is dependent on the client application. If the 
recorded application supports multi-threading, then the Vuser script will 
also support multi-threading.

➤ In certain cases, you may be unable to run multiple iterations without 
modifying the script. Objects that are already initialized from a previous 
iteration, cannot be reinitialized. Therefore, to run multiple iterations, make 
sure to close all of the open connections or remoting channels at the end of 
each iteration.
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➤ Recording is not supported for Enterprise Services communication based on 
MSMQ and Enterprise Services hosted in IIS.

➤ VuGen partially supports the recording of WCF services hosted by the client 
application.

➤ Recording is not supported for Remoting calls using a custom proxy.

➤ Recording is not supported for ExtendedProperties property of ADO.NET 
objects, when using the default ADO.NET filter.

➤ Applications created with .NET Framework 1.1 which are not compatible 
with Framework 2.0, cannot be recorded. To check if your Framework 1.1 
application is compatible, add the following XML tags to your application’s 
.config file:

<configuration>
<startup>

<supportedRuntime version="v2.0.50727"/>
</startup>

</configuration>

Invoke the application (without VuGen) and test its functionality. If the 
application works properly, VuGen can record it. Remove the above tags 
before recording the AUT with VuGen. For more information regarding this 
solution, refer to the MSDN Knowledge Base.

Getting Started with Microsoft .NET Vusers

This section describes the process of developing Microsoft .NET Vuser 
scripts. Note that the AUT (Application Under Test) must be installed on the 
machine running the script and all load generators.

To develop a basic .NET Vuser script: 

 1 Record the application using VuGen.

Start VuGen and create a new Vuser script. Specify Microsoft .NET as the 
type of Vuser. Choose an application to record and set the recording 
options. For more information, see “Setting Microsoft .NET Recording 
Options” on page 485.
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For general details about recording, see “Recording with VuGen” in Volume 
I-Using VuGen.

 2 Debug the script and set the filter.

Examine the recorded script and determine if the required methods were 
recorded. If necessary, modify the filter and record the script again.

For details about setting the filter, see “Guidelines for Setting Filters” on 
page 515.

 3 Correlate the script.

Correlate the values in your script to save them as parameters for use at a 
later point in the script. 

For details, see “Correlating Microsoft .NET Scripts” on page 497.

 4 Run the script from VuGen.

Save and run the script in VuGen to verify that it runs correctly. To insure a 
successful replay, compile and run the script in VuGen before running it 
remotely on a Load Generator machine or via the Controller. This applies 
each time you make a change to the script—either in the script’s settings or 
the actual script. In addition, if you save the script under another name, 
replay it in VuGen before running it on a Load Generator.

For details, see “Running Vuser Scripts in Standalone Mode” in Volume I-
Using VuGen.

 5 Configure the run-time settings.

The run-time settings control the Vuser behavior during script execution. 
These settings include loop, log, and timing information. 

For details, see “Configuring .NET Environment Run-Time Settings” on 
page 493.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 
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Setting Microsoft .NET Recording Options

You can set both Script and Microsoft .NET-specific recording options. This 
section describes the recording options specific to Microsoft .NET. For 
information on the Script recording options, see “Setting Script Generation 
Preferences” in Volume I-Using VuGen. 

The recording options specific to Microsoft .NET are in the area of recording 
settings and .NET filters.

The recording settings let you control the logging, serialization, debugging, 
and the trace level of the logging. For more information, see “Configuring 
the Recording Settings” on page 486.

The filtering options let you choose a filter for the recording, using a 
standard .NET Remoting, ADO.NET, Enterprise Services, or WCF filter. You 
can also create custom filters and configure them according to your needs. 
For more information, see Chapter 33, “Setting Filters for .NET Vuser 
Scripts.”.

For information about recording WCF duplex communication, see “Setting 
WCF Recording Options” on page 505.

Some of the recording options are also relevant to code regeneration. After 
recording a script with certain options, you can modify the code generation 
options and regenerate the script with different settings or even in a 
different language. To change the options and regenerate a script, choose 
Tools > Regenerate Script. In the Regenerate Script dialog box, click 
Options. For more information, see “Regenerating a Vuser Script”in Volume 
I-Using VuGen.
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Configuring the Recording Settings

To open the .NET Recording Options dialog box, choose Tools > Recording 
Options and select the Recording node.

You can configure your script in the following areas:

➤ Logging

➤ Serialization Settings

➤ Remote Objects

➤ WCF Duplex Binding

➤ Debug Options

➤ Filters

➤ Code Generation
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Logging

➤ The Logging options let you set the level of detail in the recording log file: 
Log Severity. Sets the level of logging to Errors Only (default), or Debug. The 
severity setting applies for all the logs that you enable below. You should 
always use the Errors Only log unless specifically instructed to do otherwise 
by HP support, since detailed logging may significantly increase the 
recording time.

➤ Instrumentation Log. Logs messages related to the instrumentation process 
(enabled by default).

➤ Recording Log. Logs messages issued during recording (enabled by default).

➤ Code Generation Log. Logs messages issued during the code generation 
stage (enabled by default).

Serialization Settings

The Serialization settings let you set the serialization format.

VuGen uses serialization when it encounters an unknown object during the 
recording, provided that the object supports serialization. An unknown 
object can be an input argument which was not included by the filter and 
therefore its construction was not recorded. Serialization helps prevent 
compilation errors caused by the passing of an unknown argument to a 
method. If an object is serialized, it is often advisable to set a custom filter to 
record this object.

➤ Serialization format. The format of the serialization file that VuGen creates 
while recording a class that supports serialization: Binary, XML, or Both. The 
advantage of the binary format is that since it is more compressed, it is 
quicker. The disadvantage of the binary format is that you do not have the 
ability to manipulate the data as you do with XML.

➤ Serialize long arrays. For long arrays containing serializable objects (for 
example, an array of primitives), use VuGen’s serialization mechanism. 
Enabling this option generates LrReplayUtils.GetSerializedObject calls if the 
array size is equal to or larger than the threshold value.

➤ Threshold value for long array size. The threshold size for an array to be 
considered a long array. If the array size is equal to or larger than this size, 
VuGen serializes it when detecting serializable objects.
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Tip: For XML serialization, you can view the content of the XML file. To 
view the file, select View XML from the right-click menu. 

Remote Objects

This section lets you define the proxy-related recording options.

➤ Record in-process objects. Records activity between the client and server 
when the server is hosted in the same process as the client. Since the actions 
are not true client/server traffic, it is usually not of interest. When in-process 
methods are relevant, for example, in certain Enterprise Service 
applications, you can enable this option to capture them (disabled by 
default).

Asynchronous Calls

In the following section, you specify how VuGen should handle 
asynchronous calls on remote objects and their callback methods. These 
options are mostly relevant for .NET Remoting and WCF environments.

➤ Call original callbacks by default. Uses the recorded application’s original 
callback when generating and replaying the script. If the callback method is 
explicitly excluded by a filter, the callback will be excluded even if you 
enable this option. If your callbacks perform actions that are not directly 
related to the business process, such as updating the GUI, then make sure to 
disable this option. 

➤ Generate asynchronous callbacks. This option defines how VuGen will 
handle callbacks when the original callbacks are not recorded. This is 
relevant when the above option, Call original callbacks is disabled or when 
the callbacks are explicitly excluded. 

When you enable this option, it creates a dummy method which will be 
called during replay instead of the original callback. This dummy callback 
will be generated in the callbacks.cs section of the script. 

When you disable this option, VuGen inserts a NULL value for the callback 
and records the events as they occur.
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The following segment shows script generation for a Calculator client, when 
Generate asynchronous callbacks is enabled.

To display the callback method, OnComplete1, you click on the callback.cs 
file in the left pane.

The following segment shows script generation when the option is disabled. 
VuGen generates a NULL in place of the callback and records the events of 
the callback as they occur.

Note: If you recorded a script with specific recording options, and you want 
to modify them, you do not need to re-record the script. Instead you can 
regenerate the script with the new settings. For more information, see 
“Regenerating a Vuser Script”in Volume I-Using VuGen.

lr.log("Event 2: CalculatorClient_1.Add(2, 3);");
Int32RetVal = CalculatorClient_1.Add(2, 3);
// Int32RetVal = 5;

callback_1 = new AsyncCallback(this.OnComplete1);
lr.log("Event 3: CalculatorClient_1.BeginAdd(2, 3, callback_1, null);");
IAsyncResult_1 = CalculatorClient_1.BeginAdd(2, 3, callback_1, null);

lr.log("Event 3: CalculatorClient_1.BeginAdd(2, 3, null, null);");
IAsyncResult_1 = CalculatorClient_1.BeginAdd(2, 3, null, null);

lr.log("Event 5: CalculatorClient_1.EndAdd(IAsyncResult_1);");
Int32RetVal = CalculatorClient_1.EndAdd(IAsyncResult_1);
// Int32RetVal = 5;

lr.log("Event 6: ((ManualResetEvent)(IAsyncResult_1.AsyncWaitHandle));");
ManualResetEvent_1 = ((ManualResetEvent)(IAsyncResult_1.AsyncWaitHandle));

lr.log("Event 7: ManualResetEvent_1.Close();");
ManualResetEvent_1.Close();
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WCF Duplex Binding

You can set options for applications that use the WCF (Windows 
Communication Foundation). For more information, see “Recording WCF 
Duplex Communication” on page 504.

Debug Options

The debug options allow you to trace the stack and specify its size.

➤ Stack Trace. Traces the contents of the stack for each invocation within the 
script. It allows you to determine which classes and methods were used by 
your application. This can be useful in determining which references, 
namespaces, classes, or methods to include in your filter. Enabling the trace 
may affect your application’s performance during recording. This trace is 
disabled by default. 

➤ Stack Trace Limit. The maximum number of calls to be stored in the stack. 
The default is 20 calls. If the number of calls exceeds the limit, VuGen 
truncates it.

Filters

Ignore all assemblies by default. Ignore all assemblies that are not explicitly 
included by the selected filter. If you disable this option, VuGen looks for a 
matching filter rule for all assemblies loaded during the recording.

Code Generation

The Code Generation options let you indicate whether to show warnings 
and a stack trace during code generation.

➤ Show Warnings. Shows warning messages that are issued during the code 
generation process.

➤ Show Stack Trace. Shows the Recorded stack trace if it is available.

➤ Show All Event Subscriptions. Generate code for all event subscriptions that 
were recorded (disabled by default). If this option is disabled, VuGen will 
only generate code for events in which both the publisher (the object which 
invokes the event) and the subscriber (the object informed of the event) are 
included in the filter. 
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Viewing Scripts in VuGen and Visual Studio

After the recording, you can view the script in VuGen’s Script view.

VuGen records the actions that occurred and generates C Sharp or VB code. 
By default, VuGen wraps all of the steps in lr.log calls.

When you replay the script, VuGen compiles it first to ensure that all of the 
calls are valid and that the syntax is correct. VuGen compiles the script into 
a DLL file, Script.dll, saved in the script’s bin folder. This DLL file contains 
three functions - Init, Actions, and End.

You can compile the script to check its syntax, without running it. To 
compile the script directly from VuGen, click Shift+F5 or choose Vuser > 
Compile. If VuGen detects a compilation error, it displays it in the Output 
window. Double-click on the error to go to the problematic line in the 
script.

To run the script directly from VuGen, click F5 or choose Vuser > Run. 
Breakpoints and step-by-step replay are not supported in VuGen’s editor 
window for Microsoft .NET Vusers. To debug a script and run it with 
breakpoints or step-by-step, run it from within Visual Studio .NET as 
described below.
491



Chapter 32 • Recording Microsoft .NET Vuser Scripts
Viewing Scripts in Visual Studio

Visual Studio provides you with additional tools to view, edit, and debug 
your script. You can add breakpoints, view variable values, add assembly 
references, and edit the script using Visual Studio’s IntelliSense. You can also 
run the script in a step-by-step mode for debugging.

When you save your script, VuGen creates a Visual Studio 2005 solution file, 
Script.sln, in your script’s folder. You can open the solution file in Visual 
Studio .NET and view all of its components in the Solution Explorer.

To open the solution in Visual Studio 2005, choose Vuser > Open Solution in 
Visual Studio or click the Visual Studio button on VuGen’s toolbar. 

Double-click the appropriate section in the Solution Explorer, such as 
vuser_init.cs, to view the contents of the script.

Note that VuGen automatically loads all of the necessary references that 
were required during recording. You can add additional references for use 
during compilation and replay through the Solution Explorer. Select the 
Reference node and choose Add Reference from the right-click menu.

Click on globals.cs or globals.vb in the Solution Explorer to view a list of the 
variables defined and used by your script.
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Configuring .NET Environment Run-Time Settings

Before running your Microsoft .NET Vuser script, you can specify the .NET 
environment settings from the Run-Time Settings dialog box.

You can also set general run-time settings for your Microsoft .NET script for 
configuring the pacing and iteration options. For more information, see 
“Configuring Run-Time Settings” in Volume I-Using VuGen.

AUT Configuration 

AUT Application Base Path. The AUT (Application Under Test) base directory 
from which DLLs are loaded during replay. By default, during recording, all 
of the necessary DLLs are stored in the script’s directory. Use this option to 
specify the location of any missing DLL files for the AUT. This is usually the 
installation path of the recorded application. Note that the AUT must be 
installed on the machine running the script. If you leave this box empty, 
VuGen uses the local script\bin directory as the application base directory 
during replay.
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AUT Configuration File. The file name of the recorded application’s 
configuration file. VuGen copies the AUT configuration file to the script\bin 
directory and loads the locally saved file. To specify a different location, use 
a full path. If you only specify a file name, and the file is not in the 
script\bin folder, VuGen loads it from the App base directory.

Concurrency

➤ AppDomain Per Vuser. Enables execution of each Vuser in a separate app 
domain (true by default). Running Vusers in separate App Domains enables 
each Vuser to execute separately without sharing static variables and 
prevents locking between them.

ADO.NET providers deploy a feature called connection pooling which can 
significantly influence load test accuracy. Whenever only one app domain is 
used for all Vusers, connection pooling is turned on—.NET Framework keeps 
the database connections open and tries to reuse them when a new 
connection is requested. Since many Vusers are executed in the context of a 
single application domain, they may interfere with one another. Their 
behavior will not be linear and that may decrease their accuracy. The default 
setting, true, allocates a separate connection pool for each Vuser. This means 
that there is connection pooling in the scope of each Vuser, but the Vusers 
will not interfere with one another. This setting provides more accuracy, but 
lower scalability.

If you disable this option, you need to manually disable connection pooling 
for the database. 
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The following table describes how to manually disable connection pooling:

To specify .NET resources:

 1 Open the run-time setting—press F4 or choose Vuser > Run-Time Settings.

 2 Click on the .NET Environment node in the left pane.

 3 Set the base folder of the DLLs in the AUT Application Base Path box.

 4 Set the path of the recorded application in the AUT Configuration File box.

 5 The recommended setting for AppDomain Per Vuser is true, the default.

Provider  Option

.NET Framework Data Provider for SQL 
Server

"Pooling=false" or "Pooling=no"

.NET Framework Data Provider for Oracle "Pooling=false" or "Pooling=no"

.NET Framework Data Provider for ODBC Connection pooling is managed by 
an ODBC Driver Manager. To 
enable or disable connection 
pooling, use the ODBC Data Source 
Administrator (found in Control 
Panel or the Administrative Tools 
folder). The Connection Pooling 
tab allows you to specify 
connection pooling parameters for 
each of the installed ODBC drivers.

.NET Framework Data Provider for OLE DB "OLE DB Services=-2"

Oracle Data Provider for .NET "pooling=false"

Adaptive Server Enterprise ADO.NET Data 
Provider

"Pooling=False"
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Viewing Data Sets and Grids

When you record a method returning a dataset, data table, or data reader 
action, VuGen generates a grid for displaying the data.

When working with a data reader, VuGen collects the data retrieved from 
each Read operation and converts it to the replay helper function, 
DoDataRead.

For example, after recording the following application code,

VuGen generates the following lines in the script:

where two the parameters indicate that during recording, the Application 
read all 27 available records. Therefore, during replay the script will read all 
available records.

In addition, VuGen generates a data grid containing all the information 
retrieved by the Read operations.

During replay you can use the output data table, containing the actual 
retrieved values, for correlation and verification. For more information 
regarding the DoDataRead function, refer to the Online Function Reference 
(Help > Function Reference).

SqlDataReader reader = command.ExecuteReader();
while( reader.Read() )
{

// read the values, e.g., get the string located in column 1
 string str = reader.GetString(1)

}

SqlDataReader_1 = SqlCommand_1.ExecuteReader();
LrReplayUtils.DoDataRead(SqlDataReader_1, out valueTable_1, true, 27);
496



Chapter 32 • Recording Microsoft .NET Vuser Scripts
By default, VuGen displays the grids in your script. To disable the grid 
display and instruct VuGen to show the collapsed version of the grid, select 
View > Data Grids.

The dataset is stored in an XML file. You can view this XML file in the 
script’s data/datasets folder. The data files are represented by an 
<index_name>.xml file, such as 20.xml. Since one file may contain several 
data tables, refer to the file datasets.grd file, which maps the script index to 
the file index to determine which XML contains the data.

For additional information about grids, see “Working with Grids” on 
page 322.

Correlating Microsoft .NET Scripts

After you record a session, you may need to correlate one or more values 
within your script. Correlating a value means that you capture a value 
during the script replay, and save it to a parameter. You can then use this 
parameter at a later point in the script.

VuGen automatically does a basic correlation—if an object is returned from 
a function call and later called in the script or if the object is passed to 
another method, VuGen uses the same object instance.

You can further correlate values in your script by manually saving the 
parameters through coding, or through VuGen’s built-in correlation tools. 

To correlate a value within VuGen, you locate the value in your dataset and 
use the right-click menu to save the value to a parameter. 
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To correlate a value for ADO.NET environments:

 1 Locate the dataset in your script. 

Display the grids in your script to show the returned datasets. If the grids are 
not visible, choose View > Data Grids or expand the applicable 
DATASET_XML statement. For example:

 2 Locate the value.

Locate the value you want to correlate. To search for a value in a grid, open 
the Find dialog box, Ctrl+F, and select the Search Grids option.

 3 Create a correlation.

Click on the value in the grid that you want to correlate and choose Create 
Correlation from the right-click menu. The Create a correlation dialog box 
opens. 

 4 Specify a parameter name.

Specify a parameter name, identical to the variable you defined earlier. Click 
OK. VuGen prompts you if you want to search for all occurrences. Click OK.

VuGen adds a lr.save_string function before each dataset. For example:

 5 Reference the parameter at a later point in the script.

Select the value you want to replace with a parameter and choose Replace 
with a parameter from the right-click menu. Insert the saved variable name 
in the Parameter name box. Click OK. VuGen prompts you to replace all of 
the values with a parameter, using the lr.eval_string function to evaluate the 
string’s value.

lr.save_string("MyCustomerID", 
CustomerAndOrdersDataSet_3.Tables["Customers"].Rows[0]["CompanyName"].ToStri
ng());

lr.message("The customer ID is""+ lr.eval_string("{MyCustomerID}") + ");
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Unlike other protocols, the script includes direct calls to the application or 
framework method. Therefore, you cannot replace the string value with the 
{paramName}—instead you must use lr.eval_string to evaluate the 
parameter’s value.

The above method is effective for ADO.NET environments. For primitive 
values, you should generate the script with output parameter values and 
examine the output parameters for correlations.

To correlate with output parameters:

 1 Choose Tools > Recording Options, and choose the General:Script node.

 2 Enable the Insert output parameter values option. Click OK to close 
Recording Options.

 3 Choose Tools > Regenerate Script to regenerate the script.

 4 Search the commented output primitive values for correlations.

For more information about using correlation functions, refer to the Online 
Function Reference (Help > Function Reference).
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Configuring Application Security and Permissions

A Security Exception that occurs while recording an application is usually 
due to a lack of permissions—the recording machine does not have 
sufficient permissions to record the application. This is common where your 
application is not local, but on the Intranet or network.

To solve this problem, you need to allow the recording machine to access 
the application and the script with Full Trust. 

One solution is to copy the application and save your script locally, since by 
default, users have Full Trust permissions to all local applications and 
folders.

An additional solution is to create new code groups that gives Full Trust to 
each application folder, and the script folder.

To grant Full Trust permissions to a specific folder:

 1 Open the .NET Configuration settings. Choose Start > Programs > 
Administrative Tools > Microsoft .NET Framework 2.0 Configuration. The 
.NET Configuration window opens.

 2 Expand the Runtime Security Policy node to show the Code Groups of the 
machine.

 3 Select the All_Code node.
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 4 Choose Action > New …. The Create New Code Group dialog box opens.

 5 Enter a name for a new Code Group for your application or script. Click 
Next.
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 6 Select the URL condition type. In the URL box, specify the full path of the 
application or script in the format file://… and click Next.

 7 Choose the FullTrust permission set. Click Next.
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 8 Click Finish in the Completing the Wizard dialog box. The configuration 
tool adds your Code Group to the list of existing groups.

 9 Repeat the above procedure for all .NET applications that you plan to 
record. 

 10 Repeat the above procedure for the Vuser script folder.

Note: Make sure that the script folder has FullTrust permissions on all Load 
Generator machines that are participating in the test (LoadRunner only).
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Recording WCF Duplex Communication

WCF (Windows Communication Foundation) is a programming model that 
unifies Web Services, .NET Remoting, Distributed Transactions, and Message 
Queues into a single Service-oriented programming model for distributed 
computing. 

WCF creates a proxy object to provide data for the service. It also marshalls 
the data returned by the service into the form expected by the caller.

In addition to general support for the WCF environment, VuGen provides 
specialized support for applications that use WCF’s duplex communication. 
In duplex communication, the client proxy contacts the service, and the 
service invokes the callback handler on the client machine. The callback 
handler implements a callback interface defined by the server. The server 
does not have to respond in a synchronous manner—it independently 
determines when to respond and invoke the callback handler. 

The communication between the client and server is as follows:

➤ The server defines the service contract and an interface for the callback.

➤ The client implements the callback interface defined by the server.

➤ The server calls the callback handler in the client whenever needed.

When trying to record and replay duplex communication, you may 
encounter problems when the script calls the original callback methods. By 
default, the callback handlers are not included in the filter. You could 
customize the filter to include those callback handlers. However, the 
standard playback would be ineffective for a load test, since many of the 
callbacks are local operations such as GUI updates. For an effective load test 
you cannot replay the original callback method invoked by the server.
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VuGen’s solution is based on replacing the original callback handler with a 
dummy implementation. This implementation performs a typical set of 
actions that you can customize further for your application.

You instruct VuGen to replace the original callbacks by activating the 
Generate Dummy Callback Handler recording option. For more 
information, see below.

Setting WCF Recording Options
VuGen’s recording options for WCF’s duplex communications enable you to 
generate a script that will be effective for load testing. You can set recording 
options on the following areas:

➤ Generating Dummy Callback Implementations

➤ Recording Dual HTTP Bindings
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Generating Dummy Callback Implementations
The Generate Dummy Callback Handler recording option instructs VuGen 
to replace the original callback in duplex communication with a dummy 
callback. 

The dummy callback implementation performs the following actions:

➤ Store arguments. When the server calls the handler during replay, it saves 
the method arguments to a key-value in memory map.

➤ Synchronize replay. It stops the script execution until the next response 
arrives. VuGen places the synchronization at the point that the callback 
occurred during recording. This is represented in the script by a warning:

As part of the synchronization, the script calls GetNextResponse to get the 
stored value.

Enabling the Dummy Callback Recording Option

By default, this option is enabled.

To enable this recording option:

 1 Choose Tools > Recording Options. 

 2 Select the Microsoft .NET:Recording node. 

 3 Select Generate Dummy Callback Handler.

VuGen Implementation of a Duplex Callback

As part of the duplex communication solution, VuGen generates two 
support files:

➤ DuplexCallbackHelper.<language>

➤ Callback_Name.<language> 

#warning:  Code Generation Warning
// Wait here for the next response.
// The original callback during record was:…

Vuser<Callback_Name>.GetNextResponse();
506



Chapter 32 • Recording Microsoft .NET Vuser Scripts
The following example shows the generated files for a Calculator 
application using duplex communication:

The Helper file serves as a general template for working with duplex callback 
handlers. It serves as a base class for the implementation of the callback. 

The second file, Callback_Name, contains the implementation of the 
callback. The name of the callback implementation class is Vuser<xxxx> 
where xxxx is the name of the callback interface and it inherits from the 
VuserDuplexCallbackHelper class defined in the Helper file. VuGen creates 
separate implementation files for each interface. 
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This file performs two primary tasks:

➤ Set Response. It stores the data that came from the server in a map. It stores 
them with sequential IDs facilitating their retrieval. This method is called 
from the implementation of the callback interface. The following sample 
code demonstrates the dummy implementation of a callback method 
named Result. The method's arguments are stored in the map as an object 
array.

➤ Get Response. Waits for the next response to arrive. The implementation of 
GetNextResponse retrieves the next response stored in the map using a 
sequential indexer, or waits until the next response arrives.

The script calls GetNextResponse at the point that the original callback 
handler was called during recording. At that point, the script prints a 
warning:

Replacement of the Callback in the Script

When you enable the Dummy Callback option (enabled by default), VuGen 
replaces the original duplex callback handlers with dummy 
implementations. The dummy implementation is called Vuser <Callback 
Name>. At the point of the original callback handler, the script prints a 
warning indicating that it was replaced.

//  -------------------------------------------------------------------------
        public virtual void Result(string operation, double result) {
            // Add here your own callback implementation and set the response data
            SetResponse(responseIndex++, new object[] {
                        operation,
                        result});
}

// Wait here for the next response.
// The original callback during record was:
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Recording Dual HTTP Bindings 
If your application employs dual HTTP Binding, since HTTP is inherently 
not a duplex protocol, the framework uses a standard port to receive 
response data being passed to the callback. When you attempt to run 
multiple instances of your application, you may be unable to do so using 
the same port number. VuGen provides you with an option of replacing the 
original client base address’s port number with a unique port.

When you enable the Generate Unique Client Base Address recording 
option, VuGen checks the type of communication used by the application. 
If it detects dual HTTP communication, WSDualHttpBinding, it runs the 
FindPort utility (provided in LrReplayUtils) in the Helper file and finds 
unique ports for each instance of the callback. 

This option is enabled by default. It is only relevant when you enable the 
above option, Generate dummy callback handler.

When you enable this option, VuGen generates the following code in the 
script:

Customizing the Dummy Implementation
You can modify the implementation file to reflect your environment. 

Several suggested customization are:

➤ Timeouts

➤ Key Identifier

➤ Return Values

➤ Get Response Order

➤ Find Port

#warning:  Code Generation Warning
// Override the original client base address with a unique port number
DualProxyHelper.SetUniqueClientBaseAddress<XXXX>(YYYYY);
509



Chapter 32 • Recording Microsoft .NET Vuser Scripts
Timeouts

The default timeout for which the callback waits for the next response is 
60000 msec, or one minute. To use a specific timeout, replace the call to 
GetNextResponse with the overloading method which gets the timeout as 
an argument as shown below. This method is implemented in the callback 
implementation file <Callback_Name> listed in the left pane after the 
DuplexCallbackHelper file.

To change the default threshold for all callbacks, modify the 
DuplexCallbackHelper file.

Key Identifier

Many applications assign key identifiers to the data, which connects the 
request and response to one another. This allows you to retrieve the data 
from the map using its ID instead of the built-in incremental index. To use a 
key identifier instead of the index, modify the file <Callback_Name> 
replacing the first base template parameter, named ID, with the type of your 
key identifier. For example, if your key identifier is a string you may change 
the first template argument from int to string:

In addition, you may remove the implementation of GetNextResponse() 
and replace it with calls to GetResponse(ID) defined in the base class.

// Get the next response.
        // This method waits until receiving the response from the server
        // or when the specified timeout is exceeded.
        public virtual object GetNextResponse(int millisecondsTimeout) {
            return base.GetResponse(requestIndex++, millisecondsTimeout);
        }

 // Default timeout threshold while waiting for response
        protected int millisecondsTimeoutThreshold = 60000;

public class VuserXXX : VuserDuplexCallbackHelper<string, object>
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Return Values

By default, since VuGen supports OneWay communication, the 
implementation callback does not return any value or update an output 
parameter when it is invoked.

If your application requires that the callback return a value, insert your 
implementation at that point.

Get Response Order

In VuGen’s implementation, a blocking method waits for each response. 
This reflects the order of events as they occurred during recording—the 
server responded with data. You can modify this behavior to execute 
without waiting for a response or to implement the blocking only after the 
completion of the business process.

Find Port

The FindPort method in the Helper file is a useful utility that can be used in 
a variety of implementations. The Helper class uses this method to find 
unique ports for running multiple instances of the script. You can utilize 
this utility method for other custom implementations.

Recording Server Hosted By Client Applications
If the communication in your system is a server hosted by a client, VuGen’s 
default solution for duplex communication will not be effective. In server 
hosted by client environments, it is not true duplex communication since 
the client opens the service and does not communicate through the 
Framework. For example, in queuing, the client sends a message to the 
service and opens a response queue to gather the responses. 

To emulate a server hosted by a client, use the pattern depicted in the above 
solution—replace the original response queues with dummy callbacks and 
perform synchronization as required. For more information, contact HP 
support.

 public virtual void Result(string operation, double result) {
            // Add here your own callback implementation and set the response data
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Setting Filters for .NET Vuser Scripts

VuGen provides several built-in filters and also allows you to customize 
them.

This chapter includes:

 ➤  About Microsoft .NET Filters on page 513

 ➤  Guidelines for Setting Filters on page 515

 ➤  Setting a Recording Filter on page 519

 ➤  Working with the Filter Manager on page 521

The following information only applies to Microsoft .NET Vuser scripts.

About Microsoft .NET Filters

Recording filters indicate which assemblies, interfaces, namespaces, classes, 
or methods to include or exclude during the recording and script 
generation.

By default, VuGen provides built-in system filters for .NET Remoting, 
ADO.NET, Enterprise Services, and WCF (Windows Communication 
Foundation). These filters were designed to include the relevant interfaces 
for standard ADO.NET, Remoting, Enterprise Services, and WCF. VuGen also 
allows you to design custom filters.
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Custom filters provide several benefits:

➤ Remoting. When working with .NET Remoting, it is important to include 
certain classes that allow you to record the arguments passed to the remote 
method.

➤ Missing Objects. If your recorded script did not record a specific object 
within your application, you can use a filter to include the missing interface, 
class or method.

➤ Debugging. If you receive an error, but you are unsure of it’s origin, you can 
use filters to exclude methods, classes, or interfaces in order to pin-point the 
problematic operation.

➤ Maintainability. You can record script in higher level, make script more easy 
to maintain and to correlate. 

A filter manager lets you manipulate existing custom filters. It displays the 
assemblies, namespaces, classes, methods, and properties in a color-coded 
tree hierarchy.

The bottom pane provides a description of the assembly, namespace, class, 
method, property, or event. It also indicates whether or not it is included or 
excluded and a reason for the inclusion or exclusion. 
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The following sections describe when and how to customize a filter:

➤ Guidelines for Setting Filters

➤ Setting a Recording Filter

➤ Working with the Filter Manager

Guidelines for Setting Filters

When testing your .NET application, your goal is determining how the 
server reacts to requests from the client. When load testing, you want to see 
how the server responds to a load of many users. 

When recording a .NET application, your script may include calls to 
methods that do not affect the server, such as calls to a local utility or the 
GUI interface. These calls are usually not relevant to your testing goals, and 
it would be correct to filter them out.

The built-in filters, .NET Remoting, ADO.NET, Enterprise Services, and WCF, 
were designed to record only the server related traffic relevant to your 
testing goals. In some instances, however, you may need to customize filters 
to capture your .NET application’s calls or exclude unnecessary calls. Using 
the Filter Manager, you can design custom filters to exclude the irrelevant 
calls and capture the server related calls.

Before creating a test, it is recommended that you become familiar with 
your application and determine its primary classes and methods, so that you 
will know which ones to include in your recording.

If you are not familiar with your application’s classes, you can use Visual 
Studio or a Stack Trace to help you determine which methods are being 
called by your application in order to include them in the filter. VuGen 
allows you to record with a stack trace that logs all of the methods that were 
called by your application.

Once you determine the required methods and classes, you include them 
using the Filter Manager. When preparing a script, you may need to 
customize the filter several times in order to achieve the optimal filter. An 
optimal filter records the relevant methods without introducing a large 
number of irrelevant calls to the script.
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Tip: Strive to modify the filter so that your script will compile (Shift+F5) 
inside VuGen—a test with correct syntax. Then customize the filter further 
to create a functional script that runs inside VuGen.

Note that if you plan to add manual code to your script such as control flow 
or message statements, make sure to do so after you have a functional script 
that runs inside VuGen. The reason for this is that if you rerecord a script or 
regenerate the script, you will lose all of the manual changes.

Determining which Elements to Include or Exclude
When designing a custom filter, it is recommended that you start by 
choosing the appropriate built-in filter as a base filter. You can then 
customize the filter using one of the following approaches:

➤ Top Down Approach. An approach in which you include the relevant 
namespace and exclude specific classes that are not part of the client-server 
activity. This is recommended if you are familiar with your application and 
you can identify a well-defined assembly which implements all client-server 
activity without involving any GUI elements, such as 
MyDataAccessLayer.dll.

➤ Bottom up Approach. An approach in which you use the default filter and 
refine it by adding individual methods or classes. Use this approach if you 
cannot identify a well-defined layer or if you are not familiar with your 
application. Do not add all AUT assemblies and then try to remove extra 
component one by one.

The following section provides guidelines on when to include or exclude 
elements.

➤ If, as a result of your including a class, your script has many unrelated 
method calls, try modifying the filter to exclude the irrelevant methods.

➤ If you identify a non-client/server call in your script, exclude its method in 
the filter.
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➤ During recording, VuGen may detect an unknown input argument, for 
example, an argument whose construction it had never encountered before. 
If this argument supports serialization, VuGen serializes it by saving it to a 
file in a special format. During replay, VuGen reconstructs the argument by 
deserializing it. 

➤ VuGen serializes objects passed as arguments that were not included by the 
filter. It is recommended that you include this object in the filter in order to 
track its construction and activity instead of using it in its serialized form. 
You can identify serialized objects in the script by searching for calls to the 
LrReplayUtils.GetSerializedObject method or, in WCF environments, 
LrReplayUtils.GetSerializedDataContract. VuGen stores serialized objects in 
the script’s \data\SerializedObjects directory as XML files with indexes: 
Serialization_1.xml, Serialization_2.xml and so forth.

➤ When no rules are specified for a method, it is excluded by default. 
However, when the remoting environment is enabled, all remote calls are 
included by default, even if they are not explicitly included. To change the 
default behavior, you can add a custom rule to exclude specific calls which 
are targeted to the remote server.

➤ Arguments passed in remoting calls whose types are not included by the 
filter, are handled by the serialization mechanism. To prevent the arguments 
from being serialized, you can explicitly include such types in order to 
record the construction and the activity of the arguments.

➤ Exclude all activity which involves GUI elements.

➤ Add assemblies for utilities that may be required for the script to be 
compiled.

For information on how to include and exclude elements, see “Including 
and Excluding Elements” on page 525.

Defining an Effective Filter
When preparing a script, you may need to customize the filter several times 
in order to achieve the optimal filter. An optimal filter records the relevant 
methods without introducing a large number of irrelevant calls to the script.
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To define an effective filter:

 1 Create a new filter based on one of the built-in filters. If you know that the 
AUT (Application Under Test) does not use ADO.NET, Remoting, WCF, or 
Enterprise Services, clear that option since unnecessary filters may slow 
down the recording.

 2 Set the Stack Trace option to true for both recording and code generation. 
Open the Recording Options (CTRL+F7) and select the Recording node. 
Enable Debug Options: Stack Trace and Code Generation: Show Stack 
Trace. 

 3 Record your application. Click Start Record (CTRL + R) to begin and Stop 
(CTRL + F5) to end.

 4 View the script’s steps. If you can determine the business logic from the 
steps and apply correlation, you may not need to create custom filters. If, 
however, the script is very long or hard to maintain or correlate, you should 
customize the script’s filter. 

 5 Try to identify the high-level method in the call that captures or wraps one 
or more client server calls. You can do this by opening the AUT source files 
(if they are available) in Visual Studio or by viewing a Stack Trace of the 
script.

 6 Set the filter to include the relevant methods—you may need to add their 
assembly beforehand. For tips about including and excluding elements in 
the filter, see “Determining which Elements to Include or Exclude” on 
page 516.

 7 Record the application again. You should always rerecord the application 
after modifying the filter.

 8 Repeat steps 4 through 7 until you get a simple script which can be easily 
maintained and correlated.

 9 After creating an optimal script, turn off the Stack Trace options and 
regenerate the script. Open the Recording Options (CTRL+F7) and select the 
Recording node. Disable Debug Options: Stack Trace and Code Generation: 
Show Stack Trace. This will improve the performance of subsequent 
recordings.
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 10 Correlate the script. In order for your test to run properly, you may need to 
insert a correlation to capture a value and use it at a later point in the script. 
For more information about the built-in correlation mechanism, see 
“Correlating Microsoft .NET Scripts” on page 497.

Setting a Recording Filter

The built-in filters, .NET Remoting, ADO.NET, Enterprise Services, and WCF 
(Windows Communication Foundation), were designed to include the 
standard interfaces for those environments. For information on the benefits 
of filters, see “Guidelines for Setting Filters” on page 515.

When you decide to apply a filter to your recording, your first step is 
choosing an appropriate filter. You can use one or more of the environment 
filters or create a new one using the Filters recording options.

➤ New Filter. Indicates that you want to create a new filter.
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➤ Environment Filter. Lists the available environment filters: .NET Remoting, 
ADO.NET, Enterprise Services, and WCF (Windows Communication 
Foundation of Framework 3.0). 

➤ Custom Filter. Shows the filters that you created earlier on the current 
machine.

After creating a filter, you can modify the properties of the filter using the 
Filter Manager. For more information, see “Including and Excluding 
Elements” on page 525.

To specify a filter:

 1 Open the Filters recording option. Choose Tools > Recording Options and 
select the Microsoft .NET:Filters node.

 2 Choose a filter option: New Filter, Environment Filter, or Custom Filter.

 3 For a new filter, click Create. The Create a New Filter dialog box opens.

 4 Select one of the filter options. To base your new filter on an environment 
filter, select the check box adjacent to one or more of the filters. 

 5 Click OK. The Filter Manager opens. 

For existing filters, click on the Filter Manager button in the main recording 
options dialog box to open the Filter Manager.

Make the desired modifications to the filters and save the filter. For more 
information, see below.
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Working with the Filter Manager

The Filter Manager lets you view and modify your filters, with the exception 
of Environment filters which can only be viewed—not modified as they are 
read-only.

You manage and manipulate your filters using the Filter Manager toolbar.

Managing Filters

➤ New. Opens the Create a New Filter dialog box, in which you create an 
empty filter or a new filter based on an existing one 

➤ Save. Saves the changes you made to filter.

➤ Delete. Deletes the selected custom filter. The Filter Manager prompts you 
for a confirmation.

Manipulating Filters

➤ Add Reference. Opens the Add Reference dialog box with a list of .NET 
Framework components or assemblies in the Public Assemblies folder. You 
can also browse the computer to locate a component that is not on the list. 
For more information, see “Adding References” on page 523.

➤ Remove Reference. Removes the assembly that is selected in the Filter 
Manager and all of the elements associated with it. The Filter Manager 
prompts you for a confirmation.

➤ Include, Exclude, and Reset. Includes or excludes an assembly, namespace, 
class, or method. You can also reset the inclusion or exclusion rule to its 
default state. For more information, see “Including and Excluding 
Elements” on page 525.

➤ Back and Forward. Navigates to the previous or next tree node visited by the 
user.

➤ View Impact Log. Opens the Impact log for the selected filter. The Impact 
log shows which nodes in the tree were affected by recent actions. For more 
information, see “Viewing an Impact Log” on page 527.
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In addition, you can copy, paste, and rename filters using the standard 
Windows key combinations and right-click menu.

The Filter Manager tree uses symbols to illustrate the elements and their 
status:

➤ Element icons represent the type of element—assembly, namespace, class, 
method, structure, property, events, or interfaces. 

➤ A check mark or X adjacent to the element icon, indicates whether or not 
the element is included or excluded. 

➤ A bolded element indicates that it was explicitly included or excluded. This 
may be a result of being manually included or excluded by the user or by a 
pre-defined rule in the environment filter. If you reset a bolded node, it 
returns to its original, unbolded state.
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The following table shows the icons that represent the various elements.

Adding References
When you create a new filter, you must add assembly references to the filter 
to indicate its behavior. In addition, you can add references to pre-existing 
custom filters.

assembly interface

assembly that 
couldn't be loaded

method

assembly that was 
partially loaded 

static 
method

class namespace

constructor property

static constructor static 
property

event

structure

static event
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When you open the Add Reference dialog box, the Filter Manager lists all of 
the public assemblies in the GAC (Global Assembly Cache). You can add 
references that are not listed using the Browse button.

In the bottom pane, the Type column differentiates between the references. 
References that reside in the GAC are of the .NET type and references that do 
not reside in the GAC are of File type.

The list of references may include different versions of the same assembly. In 
this case, choose the version that is most appropriate for your test.

To add a reference through the Filter Manager:

 1 Click the Add Reference button on the toolbar. The Add Reference dialog 
box opens.

 2 To add one of the listed items, choose it and click Select. You can choose 
multiple components using CTRL-CLICK. The bottom pane shows the selected 
references.

 3 To add an assembly that is not in the list, click Browse and locate the 
reference on your file system or network.

 4 Repeat the above steps for all of the references you want to add to your filter.
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 5 Review the list of references displayed in the bottom pane. To clear an item 
from the list, select it in the bottom pane and click Remove.

 6 When you finish creating your list of references, click OK to close the dialog 
box and add the references to the filter. VuGen adds it to the end of the list 
of elements in the Filter Manager’s tree. If any of the references you chose 
are not valid assemblies, VuGen will issue an error message.

 7 To remove a reference from the Filter Manager’s tree, select the parent 
assembly node and choose Remove Reference from the right-click menu, or 
click the Remove Reference button on the toolbar.

After you add a reference, you should view it in the Filter Manager and 
determine if all the correct nodes are included or excluded. If necessary, you 
can include or exclude specific namespaces, classes, or methods. For more 
information, see below, Including and Excluding Elements.

Including and Excluding Elements
After you add references to the filter, you can view all of its nodes in the 
Filter Manager’s tree. You can choose to exclude specific namespaces, classes, 
or methods, or include those that were excluded by default or by other rules. 
The description in the Filter Manager’s lower pane, indicates the reason for 
the inclusion or exclusion of the element. 

The Filter Manager’s toolbar provides the following buttons for including or 
excluding elements:

➤ Include. Indicated by a check mark, includes the selected element. If you 
manually include a parent node, the Filter Manager includes the child 
elements below it, provided that no other rule exists. For example, if you 
include a class, it will include all its methods unless you specifically 
excluded a method.
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➤ Exclude. Indicated by an X, excludes the selected element. The child 
elements are also excluded unless they were included by another rule. By 
default, when you exclude a class, the Filter Manager applies the Exclude 
attribute to the class, but it allows the recording engine to record activity 
within the methods of the excluded class. When you exclude a method, 
however, the Filter Manager applies Totally Exclude, preventing the 
recording engine from recording any activity within the methods of the 
excluded class. Advanced users can modify these setting in the filter file. For 
more information, see “Advanced Information About Filter Files” on 
page 528.

➤ Reset. Removes the manual inclusion or exclusion rule. In this case, the 
element may be impacted by other parent elements.

The inclusion and exclusion rules have the following properties:

➤ The rules are hierarchical—if you add an include or exclude rule to a class, 
then the derived classes will follow the same rule unless otherwise specified.

➤ A rule on a class only affects its public methods, derived classes, and inner 
classes.

➤ A rule on a namespace affects all the classes and their public methods.

➤ Note that adding or removing assemblies does not necessarily affect the 
classes that they contain—you can remove an assembly, yet its methods 
may be recorded due to the hierarchical nature of the filter.

➤ As part of the filter design, several methods, such as .cctor() and 
Dispose(bool), do not follow the standard hierarchal rules.

Note: The resetting of a parent node does not override a manual inclusion 
or exclusion applied to a child node. For example, if you manually exclude a 
method, and then reset its class, which by default included all sub-nodes, 
your method will remain excluded.

Properties and events are view-only and cannot be included or excluded 
through the Filter Manager. In addition, several system related elements are 
protected and may not be altered.
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For tips about including and excluding elements in the filter, see 
“Determining which Elements to Include or Exclude” on page 516.

To add or remove assemblies, use the Add and Remove Reference buttons as 
described in “Adding References” on page 523. The following section 
describes how to include namespaces, classes, and methods.

To include or exclude an element: 

 1 Expand the tree hierarchy and choose a namespace, class, or method. 

 2 To include an element, select it and click the Include button or use the 
Include command on the right-click menu.

 3 To exclude an element, click the Exclude button or use the Exclude 
command on the right-click menu. 

 4 To reset an element to its default settings, click the Reset button or choose 
Reset from the right-click menu.

To verify that the change took effect, select the component and view the 
bottom pane.

Viewing an Impact Log
The Impact Log indicates what your last changes were and how they 
affected your filter. The user actions are listed in descending order, with the 
latest changes at the top.

For each element affected by your manual inclusion or exclusion, the log 
indicates how it affected the element. It also provides a link to that element 
in the Filter Manager.
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To view the Impact Log, click the Impact Log button on the Filter Manager’s 
toolbar or choose Actions > View Impact Log in the Filter Manager window. 

Advanced Information About Filter Files
In the Filter Manager’s tree hierarchy, it only displays public classes and 
methods. It does not show non-public classes or delegates. 

You can add classes or methods that are not public by manually entering 
them in the filter’s definition file.

The filter definition files, <filter_name>.xml reside in the dat\DotnetFilters 
folder of your installation. The available Action properties for each element 
are: Include, Exclude, or Totally Exclude. For more information, see 
“Including and Excluding Elements” on page 525. 
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By default, when you exclude a class, the Filter Manager applies Exclude, 
excluding the class, but including activity generated by the excluded class. 
When you exclude a method, however, it applies Totally Exclude, excluding 
all referenced methods.

For example, suppose Function A calls function B. If Function A is Excluded, 
then when the service calls Function A, the script will include a call to 
Function B. However, if function A is Totally Excluded, the script will not 
include a call to Function B. Function B would only be recorded if called 
directly—not through Function A.

VuGen saves a backup copy of the filter as it was configured during the 
recording, RecordingFilterFile.xml, in the script’s data folder. This is useful if 
you made changes to the filter since your last recording and you need to 
reconstruct the environment.
529



Chapter 33 • Setting Filters for .NET Vuser Scripts
530



34
Creating Web Vuser Scripts

You use VuGen to develop Web Vuser scripts based on your actions while 
you operate a client browser.

This chapter includes:

 ➤  About Developing Web Level Vuser Scripts on page 531

 ➤  Introducing Web Vusers on page 532

 ➤  Understanding Web Vuser Technology on page 533

 ➤  Choosing a Web Vuser Type on page 533

 ➤  Getting Started with Web Vuser Scripts on page 537

 ➤  Recording a Web Session on page 539

 ➤  Converting Web Vuser Scripts into Java on page 540

The following information applies to Web (Click and Script) and Web 
(HTTP/HTML) Vuser scripts.

About Developing Web Level Vuser Scripts

You use VuGen to develop Web Vuser scripts. While you navigate through a 
site performing typical user activities, VuGen records your actions and 
generates a Vuser script. When you run the script, the resulting Vuser 
emulates a user accessing the Internet.

After you create a Vuser script, you run the script in stand-alone mode using 
VuGen. When the execution is successful, you are ready to integrate the 
Vuser script into a scenario. For details on how to integrate a Vuser script 
into a scenario, refer to the HP LoadRunner Controller User’s Guide.
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For certain Vuser types, you can create a Business Process Report for 
Microsoft Word that provides information about the script and the events 
that were recorded. For more information, see “Creating Business Process 
Reports” in Volume I-Using VuGen.

Introducing Web Vusers

Suppose you have a Web site that displays product information for your 
company. The site is accessed by potential customers. You want to ensure 
that the response time for any customer query is less than a specified value 
(for example, 20 seconds)—even when a large number of users (for example, 
200) access the site simultaneously. You use Vusers to emulate this case, 
where the Web server services simultaneous requests for information. Each 
Vuser could do the following:

➤ Load a home page

➤ Navigate to the page containing the product information

➤ Submit a query

➤ Wait for a response from the server

You can distribute several hundred Vusers among the available testing 
machines, each Vuser accessing the server by using its API. This enables you 
to measure the performance of the server under the load of many users.

The program that contains the calls to the server API is called a Vuser script. 
It emulates a browser application and all of the actions performed by the 
browser. Using the Controller, you assign the script to multiple Vusers. The 
Vusers execute the script and emulate user load on the Web server.
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Understanding Web Vuser Technology

VuGen creates Web Vuser scripts by recording the activity between a 
browser and a Web server. VuGen monitors the client (browser) end of the 
system and traces all the requests sent to, and received from, the server. 

When you run a recorded Vuser script, the Vuser communicates directly 
with the server without relying on client software. Instead, the Vuser script 
executes calls directly to the Web server via API functions. 

Choosing a Web Vuser Type

When creating a new Web Vuser script, you can choose from two types of 
Web Vusers: 

➤ Web (Click and Script)

➤ Web (HTTP/HTML)
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Web (Click and Script)

The Web (Click and Script) Vuser is a solution for recording Web sessions on 
a user-action GUI level. VuGen creates a GUI-level script that intuitively 
represents actions in the Web interface. For example, it generates a 
web_button function when you click a button to submit information, and 
generates a web_edit_field function when you enter text into an edit box.

Web (Click and Script) Vusers support non-HTML code such as Javascript on 
the client side. VuGen creates an intuitive script that accurately emulates 
your actions on the Web page. In contrast, Web (HTTP/HTML) scripts do not 
support Javascript. Instead, VuGen includes the Javascript as a sub-resource 
of the page’s web_url function. 

Web (Click and Script) Vusers handle most correlations automatically, 
reducing the scripting time. In most cases, you do not need to define rules 
for correlations or perform manual correlations after the recording.

Web (Click and Script) Vusers also allow you to generate detailed Business 
Process Reports which summarize the script and its replay results.

For example, when you click a button to submit data, VuGen generates 
web_button. If the button is an image, VuGen generates 
web_image_submit. In the following example, a user clicked the login 
button.

…
web_image_submit("Login", 

"Snapshot=t4.inf", 
DESCRIPTION, 
"Alt=Login", 
"Name=login", 
"FrameName=navbar", 
ACTION, 
"ClickCoordinates=31,6", 
LAST);}
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The next section illustrates a user navigating to the Asset ExpressAdd process 
under the Manage Assets branch. The user navigates by clicking the text 
links of the desired branches, generating web_text_link functions. 

In the following example, web_list emulates the selection of a list item.

web_text_link("Manage Assets_2", 
DESCRIPTION, 
"Text=Manage Assets", 
"Ordinal=2", 
"FrameName=main", 
LAST);

web_text_link("Use", 
DESCRIPTION, 
"Text=Use", 
"FrameName=main", 
LAST);

web_text_link("Asset ExpressAdd", 
DESCRIPTION, 
"Text=Asset ExpressAdd", 
"FrameName=main", 
LAST);

…
web_list("Year", 

DESCRIPTION, 
"Name=Year", 
"FrameName=CalFrame", 
ACTION, 
"Select=2000", 
LAST);
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When you click on an image that is associated with an image map, VuGen 
generates a web_map_area function.

Note: Web (Click and Script) Vusers do not support Applets or VB Script. If 
the Web site under test contains these items, use the Web (HTTP/HTML) 
user.

Web (HTTP/HTML)

When recording a Web (HTTP/HTML) script, VuGen records the HTTP traffic 
and server response over the Internet. The scripts contain detailed 
information about your actions in the browser.

The Web (HTTP/HTML) Vuser provides two recording levels: HTML-based 
script and URL-based script. These levels lets you specify what information 
to record and which functions to use when generating a Vuser script. For 
more information about selecting a Recording level, see “Selecting a 
Recording Level” on page 598.

This Vuser type does not natively support Javascript—instead it stores it as a 
resource of the Web page. 

Tip: For most applications, including those with JavaScript, use Web (Click 
and Script) Vusers. For browser applications with applets and VB Script or 
for non-browser applications, use the Web (HTTP/HTML) Vuser.

web_map_area("map2_2", 
DESCRIPTION, 
"MapName=map2", 
"Ordinal=20", 
"FrameName=CalFrame", 
LAST);
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Getting Started with Web Vuser Scripts

This section provides an overview of the process of developing Web Vuser 
scripts. 

To develop a Web Vuser script: 

 1 Create a new script using VuGen.

Click on VuGen’s Start Page tab and click on File > New. Choose Web (Click 
and Script) or Web (HTTP/HTML) Vuser script from the e-business category, 
in either single or multiple protocol mode. 

For details about creating a new script, see “Recording with VuGen” in 
Volume I-Using VuGen.

 2 Set the recording options.

Set the recording options. For information about setting common Internet 
recording options, see Chapter 38, “Setting Recording Options for Internet 
Protocols.” 

For details about selecting a recording level, see Chapter 39, “Setting 
Recording Options for Web Vusers.”

For Web (Click and Script) specific options, see Chapter 37, “Recording with 
Click and Script.”

 3 Record a browser session.

Record your actions while you navigate your Web site.

For details about creating a new script, see “Recording with VuGen” in 
Volume I-Using VuGen.

 4 Enhance the recorded Vuser script.

Enhance the Vuser script by inserting transactions, rendezvous points, 
checks, and service steps.

For details, see Chapter 42, “Verifying Web Pages Under Load”, Chapter 43, 
“Modifying Web and Wireless Vuser Scripts”, and Chapter 44, “Setting 
Correlation Rules for Web Vuser Scripts.”
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 5 Define parameters (optional).

Define parameters for the fixed values recorded into your script. By 
substituting fixed values with parameters, you can repeat the same Vuser 
action many times using different values. 

For details, see “Creating Parameters” in Volume I-Using VuGen.

 6 Configure the run-time settings.

The run-time settings control Vuser behavior during script execution. These 
settings include general run-time settings (iteration, log, think time, and 
general information), and Web-related settings (proxy, network, and HTTP 
details). 

For details, see “Configuring Run-Time Settings” in Volume I-Using VuGen.

 7 Perform correlation. 

For Web (HTTP/HTML) scripts, Scan your Vuser script for correlations and 
use one of VuGen’s mechanisms to implement them. 

For details on setting up automatic correlation, see Chapter 44, “Setting 
Correlation Rules for Web Vuser Scripts.” For information on correlation 
after the recording, see Chapter 45, “Correlating Vuser Scripts After 
Recording.”

 8 Run and debug the Vuser script using VuGen.

Run the Vuser script from VuGen to verify that it runs correctly. 

For details, see “Running Vuser Scripts in Standalone Mode” in Volume I-
Using VuGen and “Viewing Test Results” in Volume I-Using VuGen.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 
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Recording a Web Session

When you record a Web session, VuGen monitors all the actions that you 
perform in your Web browser. Your activities can include hyperlink jumps 
(both hypertext and hypergraphic) and form submissions. While recording, 
VuGen saves the recorded actions in a Web Vuser script.

Each Vuser script that you create contains at least three sections: vuser_init, 
one or more Actions, and vuser_end. During recording, you can select the 
section of the script into which VuGen will insert the recorded functions. 
The vuser_init and vuser_end sections are generally used for recording server 
logon and logoff procedures, which are not repeated when you run a Vuser 
script with multiple iterations. 

You should therefore record a Web session into the Actions sections so that 
the complete browser session is repeated for each iteration.
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Converting Web Vuser Scripts into Java

VuGen provides a utility that enables you to convert a script created for a 
Web Vuser into a script for Java Vusers. This also allows you to create a 
hybrid Vuser script for both Web and Java.

To convert a Web Vuser script into a Java Vuser script:

 1 Create an empty Java Vuser script and save it.

 2 Create an empty Web Vuser script and save it.

 3 Record a Web session using standard HTML/HTTP recording. 

 4 Replay the Web Vuser script. When it replays correctly, cut and paste the 
entire script into a text document and save it as a text .txt file. In the text 
file, modify any parameter braces from the Web type, "{ }" to the Java type, 
"< >". 

 5 Open a DOS command window and go to your product’s dat directory.

 6 Type the following command:

<application_directory>\bin\sed -f web_to_java.sed filename > outputfilename

where filename is the full path and filename of the text file you saved 
earlier, and outputfilename is the full path and filename of the output file.

 7 Open the output file, and copy its contents into your Java Vuser script 
action section at the desired location. If you are pasting the contents into an 
empty custom Java template (Java Vuser type), modify the line containing 
public int action() as follows:

public int action() throws Throwable 

This change is done automatically for recorded Java users (RMI and CORBA).

Parameterize and correlate the Vuser script as you would with an ordinary 
Java script and run it. 
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Tips for Web (Click and Script) Vusers

The Record, Replay and Enhancement tips provide guidelines for developing 
Web (Click and Script) scripts.

This chapter includes:

 ➤  Recording Issues on page 541

 ➤  Recording Tips on page 543

 ➤  Replay Problems on page 545

 ➤  Replay Tips on page 547

 ➤  Miscellaneous Problems on page 548

 ➤  Miscellaneous Tips on page 550

 ➤  Enhancing Your Web (Click and Script) Vuser Script on page 551

The following information applies to the Web (Click and Script), Oracle 
Web Applications 11i, and PeopleSoft Enterprise protocols.

Recording Issues

The following section lists the most common recording problems:

Application behaves differently while being recorded
If your application behaves differently during recording, than it does 
without recording, you should determine if the recording problem is unique 
to Web (Click and Script). The effect may be that a Web page will not load, 
part of the content is missing, a popup window does not open, and so forth.
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Create a new Web (HTTP/HTML) script and repeat the recording.

In the event that the recording is OK in Web (HTTP/HTML), it is 
recommended to disable socket level recording (see “Disable socket level 
recording” on page 544). The problem may be the result of an event listener. 
Use trial and error to disable event listeners in the Web Event Configuration 
Recording Options, and then re-record your session as a Web (Click and 
Script) user. 

To disable an event listener:

➤ Open the Recording Options. Choose Tools > Recording Options and select 
the GUI Properties:Web Event Configuration node. 

➤ Click Custom Settings and expand the Web Objects node. Select an object.

➤ Choose Disabled from the list in the Record column for the relevant Web 
object. If the recording still does not work, enable the listener you 
previously disabled, and try disabling another one. Repeat these steps until 
your recording succeeds.

Dynamic menu navigation was not recorded
A dynamic menu is a menu that dynamically changes depending on where 
you select it. If the dynamic menu navigation was not recorded, record 
again using “high” event configuration mode.

To set the configuration level to high:

➤ Open the Recording Options. Choose Tools > Recording Options and select 
the GUI Properties:Web Event Configuration node.

➤ Move the slider to High.

Certain user actions were not recorded
Check if there is a Java applet running inside the browser. If not, record the 
script with the Web (HTTP/HTML) protocol.
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Recording Tips

Use the mouse and not the keyboard
It is preferable to click on an object with the mouse rather then using the 
keyboard. During recording, use only GUI objects that are within the 
browser's pane. Do not use any browser icons, controls, the Stop button, or 
menu items, such as View > Refresh. You may, however, use the Refresh, 
Home, Back and Forward buttons and the address bar.

Do not record over an existing script
It is best to record into a newly created script—not an existing one.

Avoid context menus
Avoid using context menus during recording. Context menus are menus 
which pop up when clicking an item in a graphical user interface, such as 
right-click menus.

Avoid working in a browser while recording
During recording, do not work in any browser window other than the 
browser windows opened by VuGen.

Wait for downloads
Wait for all downloads to complete before doing any action, such as clicking 
on a button or filling in a text field.

Wait for pages to load
During recording, it is best to wait for the page to load completely before 
doing the next step. If you did not wait for all of the pages to load, record 
the script again.
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Navigate to start page
If the last page in an action does not contain the links and buttons that were 
available at the start of the iteration, then the next iteration will fail. For 
example, if the first page has a text link Book A Flight, make sure to navigate 
to the appropriate page at the end of your recording, so that the same link 
will be visible at the end of the business process.

Use a higher event configuration level
Record the business process again the High Event Configuration level. For 
more information on changing the Event Configuration level, see “Dynamic 
menu navigation was not recorded” on page 542.

Disable socket level recording
In certain cases, the capturing of the socket level messages disrupts the 
application. For most recordings, socket level data is not required. To 
prevent the recording of socket level data, disable the option in the 
recording options. For more information, see “Recording Settings” on 
page 571.

Enable the record rendering-related property values
If the client-side scripts of the application use a lot of styling activities, 
enable the Record rendering-related property values option before 
recording the script. For example, enable this option to record additional 
DOM objects such as offsetTop. Note that enabling this option may decrease 
the replay speed.

To enable record rendering-related property values:

➤ Open the Recording Options. Choose Tools > Recording Options and 
select the GUI Properties:Advanced node. 
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Replay Problems

GUI object not found

Is the problematic step at the beginning of the second iteration?

If the error occurs at the beginning of the second iteration’s Action section, 
it is probably the result of a starting page that was present for the first 
iteration, but missing for the second one. If the last page in an action does 
not contain the links and buttons that were available at the start of the 
iteration, then the next iteration will fail. For example, if the first page has a 
text link Book A Flight, make sure to navigate to the appropriate page, so 
that the same link will be visible at the end of the business process.

Is it a text link containing non-ASCII characters?

If the problem occurs with non-ASCII characters, you should instruct VuGen 
to covert the data toa suitable character set.

To enable data conversion on Windows machines:

 1 Open the Run-Time settings. Choose Vuser > Run-Time Settings and select 
the Internet Protocol:Preferences node.

 2 Click Options to open the Advanced Options dialog box.

 3 Locate Charset Conversions by HTTP in the Web (Click and Script) > General 
options, and set it to Yes.

To enable UTF-8 conversion for UNIX machines:

 1 Open the Run-Time settings. Choose Vuser > Run-Time Settings and select 
the Internet Protocol:Preferences node.

 2 Click Options to open the Advanced Options dialog box.

 3 Locate Convert from/to UTF-8 in the General options and set it to Yes.

Alternatively, view the list of alternatives that are displayed when a link is 
not found. Enter the displayed text as-is, such as hex escape sequences \xA0 
or any other non-standard format.
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Can you run the same sequence of actions twice in the application?

In some cases, you can only perform a certain process once, such as deleting 
a user from the database. Replay will fail after the first iteration, because the 
action is no longer valid. Verify that your business process can be repeated 
in the application more than once with the same data, without recording 
again.

Were the image properties 'Id', 'Name' and 'Alt' empty?

In Tree view, double click on the previous image step to open its properties. 
If the Id, Name, and Alt properties are empty, provide further identification 
of the image, such as its file name in the Src property. 

Alternatively, you add an Ordinal argument to specify the occurrence 
number of the image on that page. The Ordinal argument uniquely 
identifies each image on the page where all other identification arguments 
are not unique. For more information, see the Online Function Reference (Help 
> Function Reference).

Did the step’s description change?

Check the Replay Log in the Output window, for a list of the objects in the 
problematic step. In some cases, the object description changes slightly from 
run to run. 

There are several solutions:

➤ If the new value is stable, open the Script View and manually modify the 
value of the step’s DESCRIPTION argument.

➤ If the description changes from run to run, you can use a regular expression 
in the DESCRIPTION argument. For more information, see the Online 
Function Reference (Help > Function Reference).

➤ Alternatively, replace the problematic object description property, such as 
Name, with the Ordinal property For more information, see the Online 
Function Reference (Help > Function Reference).

Did the page load completely during recording?

During recording, it is best to wait for the page to load completely before 
doing the next step. If you did not wait for all of the pages to load, record 
the script again.
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Replay Tips

The following tips may help you in troubleshooting your problems:

Do not reorder
Do not reorder the statements within a recorded script. Also, copying 
segments of code from one Action to another is not recommended.

Convert non-ASCII characters
If your links contain non-ASCII characters, you should instruct VuGen to 
convert the data to or from the UTF-8 format.

To enable UTF-8 conversion:

➤ Open the Recording Options. Choose Vuser > Run-Time Settings and select 
the Internet Protocol:Preferences node.

➤ Click Options to open the Advanced Options dialog box.

➤ Locate the Convert from/to UTF-8 option and set it to Yes.

Alternatively, view the list of alternatives that are displayed when a link is 
not found. Enter the displayed text as-is, such as the hex escape sequences 
\xA0 or any other non-standard format.

Run same sequence of actions twice
In some cases, you can only perform a certain process once, such as deleting 
a user from the database. Replay will fail after the first iteration, because the 
action in no longer valid. Verify that your business process can be repeated 
in the application more than once with the same data, without recording.

Set unique image properties
In Tree view, double click on the previous image step to open its properties. 
If the Id, Name, and Alt properties are empty, provide further identification 
of the image, such as its file name in the Src property. 
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Alternatively, you add an Ordinal argument to specify the occurrence 
number of the image on that page. The Ordinal argument uniquely 
identifies each image on the page where all other identification arguments 
are not unique. For more information, see the Online Function Reference 
(Help > Function Reference).

Check the step’s description
If you receive an error GUI Object is not found, check the Replay Log in the 
Output window, for a list of the objects in the problematic step. In some 
cases, the object description changes slightly from run to run. 

There are several solutions:

➤ If the new value is stable, open the Script View and manually modify the 
value of the step’s DESCRIPTION argument.

➤ If the description changes from run to run, you can use a regular expression 
in the DESCRIPTION argument. For more information, see the Online 
Function Reference (Help > Function Reference).

➤ Alternatively, replace the problematic object description property, such as 
Name, with the Ordinal property For more information, see the Online 
Function Reference (Help > Function Reference).

Miscellaneous Problems

Out of memory error in JavaScript
Increase the JavaScript memory in the Run-Time settings.

To increase the JavaScript memory size:

 1 Open the Recording Options. Choose Vuser > Run-Time Settings and select 
the Internet Protocol:Preferences node.

 2 Click Options to open the Advanced Options dialog box.

 3 Locate the Memory Management JavaScript Runtime Memory Size (Kb) and 
Memory Management JavaScript Stack Memory Size (Kb) options. 

 4 Increase the memory sizes to 512 or higher.
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VuGen displays JavaScript errors
If VuGen displays JavaScript errors in the Replay Log, verify that the 
Javascript itself does not contain errors, by enabling IE (Internet Explorer) 
script errors.

To show script errors:

 1 Open Internet Explorer. Choose Tools > Internet Options and select the 
Advanced tab.

 2 Enable the Display a notification about every script error under the 
Browsing section.

 3 Rerun the application in IE. If IE displays script errors, then there is a 
problem with the JavaScript application. If it is not possible to fix the 
application, you can safely ignore the corresponding replay errors.

Problems following parameterization
If you encounter problems only after you have parameterized values, verify 
that the values are valid for your application. Perform business process with 
the value of the parameter and verify that the application accepts it.

Problems with applications that utilize styling actions
If the client-side scripts of the application use a lot of styling activities, you 
should record the script again after enabling the Record rendering-related 
property values option. This enables the recording of additional DOM 
objects.

To enable record rendering-related property values:

 1 Open the Recording Options. Choose Tools > Recording Options and select 
the GUI Properties:Advanced node. 

 2 Enable the Record rendering-related property values option. Re-record the 
script.
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Miscellaneous Tips

The following additional tips may help you in troubleshooting your 
problems:

Search for warnings
Search for warnings or alerts in the Replay Log. 

Verify the response
Verify the response of the previous step is correct using web_reg_find. For 
more information, see the Online Function Reference (Help > Function 
Reference).

Use alternate navigation
For problematic steps or those using Java applets, Use Alternative 
Navigation to replace the Web (Click and Script) step with an HTTP level 
step. Note that the HTTP level steps may require manual correlations. To 
perform Alternative Navigation, select a step in Tree View, or the text in 
Script View, and choose Replace with alternative navigation from the right-
click menu. 
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Enhancing Your Web (Click and Script) Vuser Script

The following section describes several enhancements that can assist you in 
creating your script.

Most of the features described below are enhancements to the API functions. 
For detailed information about the functions and their arguments, see the 
Online Function Reference (Help > Function Reference) or click F1 on any 
function.

Adding conditional steps
The Web (Click and Script) functions, web_xxxx, allow you to specify 
conditional actions during replay. Conditions are useful, for example, if you 
need to check for an element and perform an action only if the element is 
found.

For example, suppose you perform an Internet search and you want to 
navigate to all of the result pages by clicking Next. Since you do not know 
how many result pages there will be, you need to check if there is a Next 
button, indicating another page, without failing the step. The following 
code adds a verification step with a notification—if it finds the Next button, 
it clicks on it.

For details about the syntax and use of the VERIFICATION section, see the 
Online Function Reference (Help > Function Reference).

Checking a page title
In web_browser steps, you can use the title verification recording option to 
check if a title is present on a page. You can instruct the Vuser to perform 
this check automatically for every step or every navigation to a new top 

While (web_text_link("Next", 
DESCRIPTION, 
"Text=Next",
VERIFICATION,
"NotFound=Notify",
ACTION, 
"UserAction=Click", 
LAST) == LR_PASS);
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level window. 

In addition, you can manually add title verifications to your script at the 
desired locations, using both exact and regular expression matches. 

For more information, see the Online Function Reference (Help > Function 
Reference).

You can set title verification options directly from within the Recording 
options. For more information, see “Setting Advanced GUI Properties” on 
page 571. 

web_browser("test_step",
DESCRIPTION,
…
VERIFICATION,

"BrowserTitle=Title",
ACTION,]

,
LAST);
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Text check verification
Using text checkpoints, you can verify that a text string is displayed in the 
appropriate place on a Web page or application and then perform an action 
based on the findings. You can check that a text string exists, ContainsText, 
or that it does not exist DoesNotContainText, using exact or regular 
expression matching.

For example, suppose a Web page displays the sentence "Flight departing 
from New York to San Francisco". You can create a text checkpoint that 
checks that the words "New York" are displayed between "Flight departing 
from" and "to San Francisco". (In this example, you would need to use 
regular expression criteria.)

To implement these checkpoints, you add the Text Check related arguments 
to the VERIFICATION section of the step. During replay, Vusers search the 
innerText of the browser’s HTML document and any child frames. The 
NotFound argument specifies the action to take if verification fails, either 
because the object was not found or because the text verification failed: 
Error, Warning, or Notify.

You can manually add text verifications to your script for existing steps. 
Place the text verification after the step that generated the element. 

The text validation arguments are valid for the following Action functions: 
web_browser, web_element, web_list, web_text_link, web_table, and 
web_text_area.
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Note: You can only use the same type of text verification once per step (for 
example, ContainsText twice). If you want to check for multiple texts, 
separate them into several steps. You can, however, use different 
verifications in the same step (for example, ContainsText & 
DoesNotContainText). In this case, all conditions have to be met in order for 
the step to pass.

In the following example, the verification arguments check that we were 
not directed from www.acme.com to the French version of the website, 
acme.com/fr.

web_browser("www.acme.com", 
ACTION, 
"Navigate=http://www.acme.com/", 

LAST);

web_browser("Verify", 
VERIFICATION,
"ContainsText=Go to Acme France",
"DoesNotContainText=acme.com in English",

LAST);
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Saving a Java script value to a parameter
The EvalJavaScript argument lets you evaluate Java Script on the Web page.

Suppose you want to click on a link which has the same name as the page 
title. The following example evaluates the document title and uses it in the 
next web_text_link function.

web_browser("GetTitle",
ACTION,
"EvalJavaScript=document.title;",
"EvalJavaScriptResultParam=title",
LAST);

web_text_link("Link",
DESCRIPTION,
"Text={title}",
LAST);
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Working with custom descriptions
Suppose you want to randomly click a link that belongs to some group. For 
example, on hp.com you want to randomly select a country. Regular 
description matching will not allow this type of operation. However, using a 
custom description argument, you can identify the group with an attribute 
that is common to all the links in the group. 

Using the DESCRIPTION argument, you specify any attribute of the 
element, even those that are not predefined for that element. During replay, 
the Vuser searches for those attributes specified in the DESCRIPTION 
section. Replay will not fail on any unknown argument in the 
DESCRIPTION section. 

For example, to find the following hyperlink:

<a href="yahoo.com" my_attribute="bar">Yahoo</a>, use:

In the following example, since all the relevant links have the same class 
name, newmerc-left-ct, you can perform a random click using the following 
code:

The following functions do not support the DESCRIPTION argument: 
web_browser, web_map_area, web_radio_group, and web_reg_dialog.

web_text_link("yahoo", 
DESCRIPTION, 
"Text=yahoo", 
"my_attribute=bar",
LAST);

web_text_link("Click",
                        DESCRIPTION,
                        "Class=newmerc-left-ct",
                        "Ordinal=random",
                        LAST);
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Using Web Vuser Functions

VuGen helps you create Web Vuser scripts that describe user actions on Web 
sites. Each script contains functions that correspond directly to each of the 
actions taken.

This chapter includes:

 ➤  About Web Vuser Functions on page 558

 ➤  Adding and Editing Functions on page 559

 ➤  General API Notes on page 561

 ➤  Using Values Stored in the Cache on page 563

The following information applies to Web (Click and Script), Web 
(HTTP/HTML), Oracle Web Applications 11i, PeopleSoft Enterprise, and 
Wireless Vuser scripts. 
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About Web Vuser Functions

The functions developed to emulate Internet communication between a 
browser or toolkit and a Web server are called Web Vuser functions. Each 
Web Vuser function has a web prefix. Some functions are generated when 
you record a script; others you must manually insert into the script. 

The Web functions are categorized as follows:

➤ Action Functions

➤ Authentication Functions 

➤ Check Functions 

➤ Connection Definition Functions 

➤ Concurrent Group Functions

➤ Cookie Functions 

➤ Correlation Functions 

➤ Filter Functions

➤ Header Functions 

➤ Proxy Server Functions

➤ Replay Functions

➤ Miscellaneous Functions 

Web (Click and Script) Vusers use other functions to emulate user actions. 

Most functions which are not Action functions, may be used in Web (Click 
and Script) Vuser scripts. However, the web_concurrent_start and 
web_concurrent_end functions are specific to Web (HTTP/HTML) Vuser 
scripts.

For detailed information and examples of the Web Protocol functions, refer 
to the Online Function Reference (Help > Function Reference). 

For more information on adding general Vuser functions to scripts, see 
“Enhancing Vuser Scripts” in Volume I-Using VuGen.
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Adding and Editing Functions

Many of the Web Vuser functions are recorded during the browser or toolkit 
session. You can also manually add and edit Web Vuser functions during 
and after recording in both the Tree view and Script view.

When you choose a new step to add to your script, VuGen categorizes the 
steps in the following types:

Step Type Description

Service A Service step is a function that does not make any changes in the 
Web application context. Rather, service steps perform 
customization tasks such as setting proxies, providing 
authorization information, and issuing customized headers. 

URL A URL step is generated when you type a URL into the browser or 
use a bookmark to access a specific Web page. Each URL icon 
represents a web_url function in the Vuser script. The default 
label of a URL icon is the last part of the URL of the target page.

Link VuGen adds a Link step when you click a hypertext link while 
recording. Each Link step represents a web_link function in the 
Vuser script. The default label of the step is the text string of the 
hypertext link (only recorded for the HTML-based recording level).

Image VuGen adds an Image step to the Vuser script when you click a 
hypergraphic link during recording. Each Image step represents a 
web_image function in the Vuser script. If the image in the 
HTML code has an ALT attribute, then this attribute is used as the 
default label of the icon. If the image in the HTML code does not 
have an ALT attribute, then the last part of the SRC attribute is 
used as the icon’s label (only recorded for the HTML-based 
recording level).

Submit 
Form / 
Submit 
Data 

VuGen adds a Submit Form or Submit Data step when you submit 
a form while recording. The default label of the step is the name of 
the executable program used to process the form (Submit Form 
only recorded for the HTML-based recording level).

Custom 
Request

VuGen adds a Custom Request step to a Vuser script when you 
record an action that VuGen cannot recognize as any of the 
standard actions (i.e., URL, link, image, or form submission). This 
is applicable to non-standard HTTP applications.
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To add a new function to an existing Vuser script:

 1 Choose Insert > New Step. The Add Step dialog box opens.
 

 2 Select the desired function and click OK. Most Web Vuser functions are 
under the Services category. The Properties dialog box for that function 
opens. This dialog box lets you specify the function’s arguments.

 3 Specify the properties and click OK. VuGen inserts the function with its 
arguments at the location of the cursor.

You can edit existing steps by opening the Properties dialog box and 
modifying the argument values. This is only valid for protocols that support 
tree view (not available for WAP).
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To edit an existing step:

 1 In the tree view, select Properties from the right-click menu. The Properties 
dialog box for that function opens.

 2 Modify the argument values as necessary and click OK.

You can manually add general Vuser functions such as transactions, 
rendezvous, comments, and log functions during recording. For more 
information, see “Enhancing Vuser Scripts” in Volume I-Using VuGen.

General API Notes

This section lists general notes about the Web (Click and Script) functions. 
Note that you can specify a regular expression for most object descriptions, 
by preceding the text with "/RE" before the equals sign. See the Function 
Reference (Help > Function Reference) for more details. For example: 

web_text_link("Manage Assets", 
DESCRIPTION, 
"Text/RE=(Manage Assets)|(Configure Assets)", 

LAST);
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Ordinals

The Ordinal attribute is a one-based index to distinguish between multiple 
occurrences of identical argument values. In the following example, the two 
recorded web_text_link functions have identical arguments, except for the 
ordinal. The ordinal value of 2, indicates the second occurrence.

Empty Strings

There is a difference between not specifying an argument and specifying it 
as an empty string. When you do not specify an argument, VuGen uses the 
default value or ignores it. When you list an argument, but assign it an 
empty string as a value, VuGen attempts to find a match with an empty 
string or no string at all. For example, omitting the id argument instructs 
VuGen to ignore the id property of the HTML element. Specifying "ID=" 
searches for HTML elements with no id property or with an empty ID.

web_text_link("Manage Assets", 
DESCRIPTION, 
"Text=Manage Assets", 
"FrameName=main", 
LAST);

web_text_link("Manage Assets_2", 
DESCRIPTION, 
"Text=Manage Assets", 
"Ordinal=2", 
"FrameName=main", 
LAST);

web_text_link("Manage Assets_2", 
DESCRIPTION, 
"Text=Manage Assets", 
"Id=", 
"FrameName=main", 
LAST);
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Using Values Stored in the Cache

You can store data into your browser’s cache, and load it at a later point in 
the script. 

To implement caching within your script, you manually add the 
web_dump_cache and web_load_cache functions.

Dumping Information to the Cache

The first step in implementing caching, is dumping the information to a 
cache file. You run the web_dump_cache function to create a cache file in 
the location specified in the FileName argument. You only need to run this 
function once to generate the cache file.

In the following example, the web_dump_cache function creates a cache file 
in C:\temp for each VuserName parameter running the script.

If you run a single Vuser user ten times, VuGen creates ten cache files in the 
following format, where the prefix is the VuserName value:

You can modify the first and second arguments (paycheckcache and 
paycheck in this example) to reflect the current transaction name. Place this 
function at the end of your script, after you have loaded all of the resources. 

Loading Information from the Cache

The final step in implementing caching, is loading the information stored in 
the cache file. The web_load_cache function loads a cache file whose 
location is specified in the FileName argument. Note that the 
web_load_cache function requires the cache file to exist. Therefore, you 
can only run this function after running web_dump_cache.

web_dump_cache("paycheckcache","FileName=c:\\temp\\{Vuser
Name}paycheck", "Replace=yes", LAST)

Ku001paycheck.cache
Ku002paycheck.cache
Ku003paycheck.cache
…
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In the following example, the web_load_cache function loads the paycheck 
cache files from C:\temp.

Inserting the Caching Functions

To implement caching in your script, you must first store the information to 
a cache file. During replay, each Vuser calls this information. 

To use the caching functions:

 1 Insert the web_dump_cache function at the beginning of your script. 

 2 Run the script at least once.

 3 Insert the web_load_cache function into your script, before the Vuser 
actions. 

 4 Comment out the web_dump_cache function.

 5 Run and save the script.

web_load_cache("ActionLoad","FileName=c:\\temp\\{VuserName}paycheck",LAST)
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Caching Example

The following example illustrates a PeopleSoft Enterprise Vuser viewing the 
details of his paycheck.

Action()
{
//web_add_cookie("storedCookieCheck=true; domain=pbntas05; path=/");
 
web_load_cache("ActionLoad","FileName=c:\\temp\\{VuserName}paycheck",LAST); 

web_browser("signon.html", 
DESCRIPTION, 
ACTION, 
"Navigate=http://pbntas05:8200/ps/signon.html", 
LAST);

lr_think_time(35);

web_edit_field("userid", 
"Snapshot=t1.inf", 
DESCRIPTION, 
"Type=text", 
"Name=userid", 
ACTION, 
"SetValue={VuserName}", 
LAST);
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web_edit_field("pwd", 

"Snapshot=t2.inf", 
DESCRIPTION, 
"Type=password", 
"Name=pwd", 
ACTION, 
"SetValue=HCRUSA_KU0007", 
LAST);

lr_start_transaction("login");
web_button("Sign In", 

"Snapshot=t3.inf", 
DESCRIPTION, 
"Type=submit", 
"Tag=INPUT", 
"Value=Sign In", 
LAST);

lr_end_transaction("login", LR_AUTO);

web_image_link("CO_EMPLOYEE_SELF_SERVICE", 
"Snapshot=t4.inf", 
DESCRIPTION, 
"Alt=", 
"Name=CO_EMPLOYEE_SELF_SERVICE", 
"Ordinal=1", 
LAST); …

web_text_link("Sign out", 
"Snapshot=t7.inf", 
DESCRIPTION, 
"Text=Sign out", 
"FrameName=UniversalHeader", 
LAST);

web_dump_cache("paycheck","FileName=c:\\{VuserName}paycheck", "Replace=yes", 
LAST);
return 0;

}
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Recording with Click and Script

The Click and Script solution lets you record Web sessions on a user-action 
GUI level for Web, AJAX, and SAP.

This chapter includes:

 ➤  About Recording with Click and Script on page 567

 ➤  Viewing Web (Click and Script) Vuser Scripts on page 568

 ➤  Setting Click and Script Recording Options on page 569

 ➤  Setting Advanced GUI Properties on page 571

 ➤  Configuring Web Event Recording on page 574

The following information applies to the AJAX (Click and Script), Web 
(Click and Script), SAP (Click and Script), Oracle Web Applications 11i, 
and PeopleSoft Enterprise protocols.

About Recording with Click and Script

The Click and Script mechanism lets you record Web sessions on a user-
action GUI level. VuGen creates a GUI-level script that intuitively represents 
actions in the Web interface. For example, it generates a web_button 
function when you click a button to submit information, and generates a 
web_edit_field function when you enter text into an edit box. For SAP 
applications, VuGen records a sap_button function.

For pure Web sessions, the Web (HTTP/HTML) Vuser type create a lower 
level script. For more information about choosing a script type for your Web 
session, see “Choosing a Web Vuser Type” on page 533.
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Viewing Web (Click and Script) Vuser Scripts

Click and Script Vuser scripts typically contain several actions which make 
up a business process. By viewing the recorded functions that were 
generated on a GUI level, you can determine the user’s exact actions during 
the recorded session. 

For example, in a typical recording, the first stage may contain a sign-in 
process. The browser opens on the sign-in page, and a user signs in by 
submitting a user name and password and clicking Sign In. 
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For the Web (Click and Script) Vuser, VuGen generates a web_edit_field 
function that represents the data entered into an edit field. In the example 
that follows, a user entered text into the userid field, and a password into 
the pwd field which is encrypted. 

Setting Click and Script Recording Options

Before recording a script, you can set options that indicate what to record 
and how to generate the script after the recording.

You can set common recording options in the following areas: General, 
HTTP Properties, and Network.

vuser_init()
{
web_browser("WebTours", 

DESCRIPTION, 
ACTION, 
"Navigate=http://localhost:1080/WebTours/", 
LAST);

web_edit_field("username", 
"Snapshot=t2.inf", 
DESCRIPTION, 
"Type=text", 
"Name=username", 
"FrameName=navbar", 
ACTION, 
"SetValue=jojo", 
LAST);

web_edit_field("password", 
"Snapshot=t3.inf", 
DESCRIPTION, 
"Type=password", 
"Name=password", 
"FrameName=navbar", 
ACTION, 
"SetEncryptedValue=440315c7c093c20e", 
LAST);…
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The following sections discuss the GUI Properties recording options that are 
specific for all Vuser types that use the Click and Script mechanism: AJAX 
(Click and Script), Web (Click and Script), SAP (Click and Script), Oracle 
Applications, and PeopleSoft Enterprise Vusers. These recording options let 
you indicate the events to be recorded and which properties to include for 
each object.

➤ Setting Advanced GUI Properties

➤ Configuring Web Event Recording

For information on the other Recording Options, see the appropriate 
section:

➤ General: Script. See “Setting Script Generation Preferences” in Volume I-
Using VuGen.

➤ General: Recording. See Chapter 39, “Setting Recording Options for Web 
Vusers.”

➤ Network: Port Mapping. See “Configuring the Port Mappings” in Volume I-
Using VuGen.

➤ HTTP Properties: Advanced. See “Setting Advanced Recording Options” on 
page 588. Note that the Save snapshot resources locally and Generate 
web_reg_find functions for page titles options do not apply to GUI-based 
scripts (see explanation of GUI-based scripts below).

➤ HTTP Properties: Correlation. See Chapter 44, “Setting Correlation Rules for 
Web Vuser Scripts.” Note that there are built-in rules for the Oracle and 
PeopleSoft servers. To enable them, select the check box adjacent to your 
server name.

Several additional HTTP properties are only configurable for Web 
(HTTP/HTML) scripts.
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Setting Advanced GUI Properties

VuGen lets you set Click and Script advanced options in the following areas:

➤ Recording Settings

➤ Code Generation Settings

Recording Settings
The Recording settings instruct VuGen what to record. You can enable or 
disable the following features:

Record rendering-related property values

Records the values of the rendering-related properties of DOM objects (e.g. 
offsetTop), so that they can be used during replay. Note that this may 
significantly decrease the replay speed (disabled by default).

Record ‘click’ by mouse events

Records mouse clicks by capturing mouse events instead of capturing the 
click() method. Enable when the recorded application uses the DOM click() 
method, to prevent the generation of multiple functions for the same user 
action (enabled by default).

Record socket level data

Enables the recording of socket level data. If you disable this option you will 
need to manually add the starting URL before recording. In addition, you 
will be unable to regenerate the script on an HTML level. (enabled by 
default).

Code Generation Settings
The Code Generation settings instruct VuGen how to generate the script 
after the recording. You can enable or disable the following features:
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Enable generation of out-of-context steps

You can instruct VuGen to create a URL-based script for ActiveX controls 
and Java applets, so that they will be replayed. Since these functions are not 
part of the native recording, they are referred to as out-of-context recording 
(disabled by default).

In the following example, the script was regenerated with the out-of-context 
recording option enabled.

web_image_link("Search Flights Button", 
"Snapshot=t5.inf", 
DESCRIPTION, 
"Alt=Search Flights Button", 
"FrameName=navbar", 
ACTION, 
"ClickCoordinates=58,9", 
LAST);

web_add_cookie("MSO=SID&1141052844; DOMAIN=localhost");

web_add_cookie("MTUserInfo=hash&47&firstName&Joseph&expDate&%0A&creditCa
rd&&address1&234%20Willow%20Drive&lastName&Marshall%0A&address2&San%2
0Jose%2FCA%2F94085&username&jojo; DOMAIN=localhost");

web_url("FormDateUpdate.class", 
"URL=http://localhost:1080/WebTours/FormDateUpdate.class", 
"Resource=0", 
"RecContentType=text/html", 
"Referer=", 
"UserAgent=Mozilla/4.0 (Windows 2000 5.0) Java/1.4.2_08", 
"Mode=HTTP", 
LAST);

…
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If you disable this option, VuGen does not generate code for the ActiveX 
controls and Java applets. In the following example, VuGen only generated 
the web_image_link function—not the web_url functions containing the 
class files. 

Enable automatic browser title verification

Enables automatic browser title verification (disabled by default).

You can also customize the type of title verification.

➤ Perform a title verification for.

each navigation. Performs a title verification only after a navigation. 
When a user performs several operations on the same page, such as 
filling out a multi-field form, the title remains the same and 
verification is not required.

each step. Performs a title verification for each step to ensure that no 
step modified the browser title. A modified browser title may cause 
the script to fail.

➤ Perform a title verification using the URL if the title is missing. For 
browser windows without a title, perform a title verification for each 
step using its URL.

web_image_link("Search Flights Button", 
"Snapshot=t5.inf", 
DESCRIPTION, 
"Alt=Search Flights Button", 
"FrameName=navbar", 
ACTION, 
"ClickCoordinates=58,9", 
LAST);
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Configuring Web Event Recording

VuGen creates a script by recording HTML object events triggered by user 
actions, such as clicking the mouse or pressing a key while viewing the 
document. 

You may find that you need to record more or fewer events than VuGen 
automatically records by default. You can modify the default event 
recording settings by using the Web Event Recording Configuration dialog 
box to select one of three standard configurations, or you can customize the 
individual event recording configuration settings to meet your specific 
needs.

This section describes how to configure VuGen’s handling of Web Events:

➤ Selecting a Standard Event Recording Configuration

➤ Customizing the Event Recording Configuration

➤ Adding and Deleting Listening Events for an Object

➤ Modifying the Listening and Recording Settings for an Event

➤ Resetting Event Recording Configuration Settings

For example, VuGen does not generally record mouseover events on link 
objects. If, however, you have a mouseover handler connected to a link, it 
may be important for you to record the mouseover event. In this case, you 
could customize the configuration to record mouseover events on link 
objects whenever they are connected to a handler.
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Note: Event configuration is a global setting and therefore affects all tests 
that are recorded after you change the settings. 

Changing the event configuration settings does not affect tests that have 
already been recorded. If you find that VuGen recorded more or less than 
you need, change the event recording configuration and then re-record the 
part of your test that is affected by the change.

Changes to the custom Web event recording configuration settings do not 
take effect on open browsers. To apply your changes for an existing test, 
make the changes you need in the Web Event Recording Configuration 
dialog box, refresh any open browsers, and then start a new recording 
session.

Selecting a Standard Event Recording Configuration
The Web Event Recording Configuration dialog box offers three standard 
event configuration levels, Basic, Medium, or High. By default, VuGen uses 
the Basic configuration level. If VuGen does not record all the events you 
need, you may require a higher event configuration level.

Level Description

Basic Default 

➤ Always records click events on standard Web 
objects such as images, buttons, and radio 
buttons. 

➤ Always records the submit event within forms.

➤ Records click events on other objects with a 
handler or behavior connected.
For more information on handlers and 
behaviors, see “Listening Criteria” on page 581.

➤ Records the mouseover event on images and 
image maps only if the event following the 
mouseover is performed on the same object. 
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To set a standard event-recording configuration:

 1 Open the Recording Options dialog box. Choose Tools > Recording Options.

 2 Select the GUI Properties:Web Event Configuration node.

 3 Use the slider to select your preferred standard event recording 
configuration: Basic, Medium, or High.

Medium In addition to the objects recorded in the Basic 
level, it records click events on the <DIV>, <SPAN>, 
and <TD> HTML tag objects.

High In addition to the objects recorded in the Medium 
level, it records mouseover, mousedown, and 
double-click events on objects with handlers or 
behaviors attached.

For more information on handlers and behaviors, 
see “Listening Criteria” on page 581.

Level Description
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Tip: Click the Custom Settings button to open the Custom Web Event 
Recording dialog box where you can customize the event recording 
configuration. For more information, see “Customizing the Event Recording 
Configuration” below. 

 4 Click OK. 

Customizing the Event Recording Configuration

If the standard event configuration levels do not exactly match your 
recording needs, you can customize the event recording configuration using 
the Custom Web Event Recording Configuration dialog box.

You can customize Web events for standard Web elements, such as an 
image, link, WebArea, WebButton, and so forth. You can also set the 
recording behavior for any HTML tag that you choose. You add the desired 
HTML tag object and then set its recording behavior. For example, you can 
configure VuGen to record all mouseover events for all DIV tags. 

The Custom Web Event Recording Configuration dialog box enables you to 
customize event recording in several ways. You can:

➤ Enable or disable objects to which VuGen should apply special listening or 
recording settings

➤ Add or remove events for which VuGen should listen

➤ Modify the listening and recording settings for an event
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You can modify the event recording configuration using the following 
options: 

To customize the recording configuration for an event:

 1 Open the Recording Options dialog box. Choose Tools > Recording Options.

 2 Select the GUI Properties:Web Event Configuration node. 

Option Description

Event Name Displays a list of events associated with the object.

➤ To add an event to the Events pane, choose Event > Add. 
Select the desired event.

➤ To delete an event, click on the event in the Event Name 
columns, and choose Event > Delete.

For more information, see “Adding and Deleting Listening 
Events for an Object” on page 580.

Listen The criteria for when VuGen listens to the event.

➤ Always. Always listens to the event.

➤ If Handler. Listens to the event if a handler is attached 
to it. A handler is code in a Web page, typically a 
function or routine written in a scripting language, that 
receives control when the corresponding event occurs.

➤ If Behavior. Listens to the event if a DHTML behavior is 
attached to it. A DHTML behavior encapsulates specific 
functionality or behavior on a page. When applied to a 
standard HTML element on a page, a behavior enhances 
that element's default behavior.

➤ If Handler or Behavior. Listens to the event if a handler 
or behavior is attached to it.

➤ Never. Never listens to the event.

For more information, see “Modifying the Listening and 
Recording Settings for an Event” on page 581.

Record Enables or disables recording of the event for the selected 
object, or enables recording of the event only if the 
subsequent event occurs on the same object.

Reset Resets your settings to a pre-configured level: Basic, 
Medium, or High.
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 3 Click the Custom Settings button. The Custom Web Event Recording 
Configuration dialog box opens.

 4 Specify an object:

➤ To configure one of the built-in Web objects, select it in the left pane. 

➤ To specify a different HTML tag object, choose Object > Add and enter 
the name of the HTML tag whose event you want to record.

 5 In the right pane, specify the Listen and Record behavior for each event as 
described above. If the event you want to record does not appear in the right 
pane, choose Event > Add to add the event, as described below.

 6 Click OK to save the customization.

 7 Click Reset to reset your settings to a pre-configured level: Basic, Medium, or 
High.
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Adding and Deleting Listening Events for an Object
You can modify the list of events that trigger VuGen to listen to an object.

To add listening events for an object:

 1 In the Custom Web Event Recording Configuration dialog box, select the 
object to which you want to add an event—one of the built-in Web objects 
or an HTML tag object.

 2 Choose Event > Add. A list of available events opens.

 3 Select the event you want to add. The event is displayed in the Event Name 
column in alphabetical order. By default, VuGen listens to the event when a 
handler is attached and always records the event (as long as it is listened to 
at some level).

For more information on listening and recording settings, see “Modifying 
the Listening and Recording Settings for an Event” below.

To delete listening events for an object:

 1 In the Custom Web Event Recording Configuration dialog box, select the 
object from which you want delete an event in the left pane.

 2 In the Event Name column, select the event you want to delete.

 3 Choose Event > Delete. The event is deleted from the Event Name column. 
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Modifying the Listening and Recording Settings for an Event

You can select the listening criteria and set the recording status for each 
event listed for each object.

Note: The listen and record settings are mutually independent. This means 
that you can choose to listen to an event for a particular object, but not 
record it, or you can choose not to listen to an event for an object, but still 
record the event. For more information, see “Tips for Working with Event 
Listening and Recording” on page 583.

Listening Criteria

For each event, you can instruct VuGen when to listen for an event:

➤ Always. Listen every time the event occurs on the object. 

➤ If Handler. Listen only if an event handler is attached to the event.

➤ If Behavior. Listen only if a DHTML behavior is attached to the event.

➤ If Handler or Behavior. Listen if an event handler or a DHTML behavior is 
attached to the event.

➤ Never. Never listen to the event.

An event handler is code in a Web page, typically a function or routine 
written in a scripting language, that receives control when the 
corresponding event occurs. 

A DHTML behavior encapsulates specific functionality or behavior on a 
page. When applied to a standard HTML element on a page, a behavior 
enhances that element's default behavior. 
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To specify the listening criterion for an event:

 1 From the Custom Web Event Recording Configuration dialog box, select the 
object for which you want to modify the listening criterion.

 2 In the row of the event you want to modify, select the listening criterion 
you want from the Listen column. 

Select a listening criteria from the list: Always, If Handler, If Behavior, 
If Handler or Behavior, or Never.

Recording Status

For each event, you can enable recording, disable recording, or enable 
recording only if the next event is dependent on the selected event.

➤ Enabled. Records the event each time it occurs on the object as long as 
VuGen listens to the event on the selected object, or on another object to 
which the event bubbles.

Bubbling is the process whereby, when an event occurs on a child object, 
the event can travel up the chain of hierarchy within the HTML code until it 
encounters an event handler to process the event. 

➤ Disabled. Does not record the specified event and ignores event bubbling 
where applicable.
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➤ Enabled on next event. (only applicable to the Image and WebArea objects) 
Same as Enabled, except that it records the event only if the subsequent 
event occurs on the same object. For example, suppose a mouseover 
behavior modifies an image link. You may not want to record the 
mouseover event each time you happen to move the mouse over this image. 
Because only the image that is displayed after the mouseover event enables 
the link event, however, it is essential that the mouseover event is recorded 
before a click event on the same object.

To set the recording status for an event:

 1 In the Custom Web Event Recording Configuration dialog box, select the 
object for which you want to modify the recording status. Select Any Web 
Object to set the recording status for all Web objects in the recorded pages.

 2 In the row of the event you want to modify, select a recording status from 
the Record column.

Tips for Working with Event Listening and Recording

It can sometimes be difficult to find the ideal listen and recording settings. 
When defining these settings, keep in mind the following guidelines:

➤ To record an event on an object, you must instruct VuGen to listen for the 
event, and to record the event when it occurs. You can listen for an event on 
a child object, even if a parent object contains the handler or behavior, or 
you can listen for an event on a parent object, even if the child object 
contains the handler or behavior. 

However, you must enable recording for the event on the source object (the 
one on which the event actually occurs, regardless of which parent object 
contains the handler or behavior).
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For example, suppose a table cell with an onmouseover event handler 
contains two images. When a user touches either of the images with the 
mouse pointer, the event also bubbles up to the cell, and the bubbling 
includes information on which image was actually touched. You can record 
this mouseover event by:

➤ Setting Listen on the WebTable mouseover event to If Handler (so that 
VuGen "hears" the event when it occurs), while disabling recording on it, 
and then setting Listen on the Image mouseover event to Never, while 
setting its recording status to Enable (to record the mouseover event on 
the image after it is listened to at the WebTable level). 

➤ Setting Listen on the Image mouseover event to Always (to listen for the 
mouseover event even though the image tag does not contain a behavior 
or handler), and setting the recording status on the Image object to 
Enabled (to record the mouseover event on the image).

➤ Instructing VuGen to listen for many events on many objects may lower 
performance, so try to limit listening settings to the required objects.

➤ In rare situations, listening to the object on which the event occurs (the 
source object) may interfere with the event.

Resetting Event Recording Configuration Settings
After you set custom settings, you can restore standard settings by 
instructing VuGen to use the default Web Event configuration settings. 

Note: When you choose to reset standard settings, your custom settings are 
cleared completely.

To restore basic level configuration settings:

 1 In the Recording Options, select the GUI Properties:Web Event 
Configuration node.

 2 Click Use Defaults. The standard configuration slider is displayed again and 
all event settings are restored to the Basic event recording configuration 
level.
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You can also restore the settings to a specific (base) custom configuration: 
Basic, Medium, or High.

To reset the settings to a custom level:

 1 In the Recording Options, select the GUI Properties:Web Event 
Configuration node.

 2 Click the Custom Settings button. The Custom Web Event Recording 
Configuration dialog box opens.

 3 In the Reset to box, select the standard event recording level you want.

 4 Click Reset. All event settings are restored to the defaults for the level you 
selected. 
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Setting Recording Options for Internet 
Protocols

For protocols that work over the Internet, you can customize the Internet-
related recording options.

This chapter includes:

 ➤  About Setting Recording Options for Internet Protocols on page 587

 ➤  Setting Advanced Recording Options on page 588

 ➤  Setting a Recording Scheme on page 590

The following information only applies to Web, Wireless, and Oracle NCA 
protocols.

About Setting Recording Options for Internet Protocols

VuGen creates Vuser scripts that emulate a true Internet environment. 

Before recording, you can configure VuGen’s script generation preferences. 
You can also set protocol specific recording options for Web Vuser scripts. 

For more information, see the Recording Options chapter for your protocol. 
You can open the Recording Options dialog box in several ways:

➤ The toolbar button: 

➤ The keyboard shortcut: Ctrl+F7

➤ The Tools menu: choose Tools > Recording Options.
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Setting Advanced Recording Options

Use the HTTP Properties:Advanced settings to set the recording options in 
the following areas:

➤ Internet Preferences Recording Options 

➤ Selecting a Recording Engine

➤ Setting a Recording Scheme 

Internet Preferences Recording Options
The Internet Preference options allow the customization of code generation 
settings in the area of think time, resetting contexts, saving snapshots, and 
the generation of web_reg_find functions. Note that some of these options 
are not available in multi-protocol mode. 

➤ Record think time. (Wireless only) This setting, enabled by default, tells 
VuGen to record the think times and generate lr_think_time functions. You 
can also set a Think-time Threshold value—if the actual think-time is less 
than the threshold, VuGen does not generate a lr_think_time function.

➤ Reset context for each action. (Web, Oracle NCA only) This setting, enabled 
by default, tells VuGen to reset all HTTP contexts between actions. Resetting 
contexts allows the Vuser to more accurately emulate a new user beginning 
a browsing session. This option resets the HTML context, so that a 
contextless function is always recorded in the beginning of the action. It 
also clears the cache and resets the user names and passwords. 

➤ Save snapshot resources locally. This option instructs VuGen to save a local 
copy of the snapshot resources during record and replay. This feature lets 
VuGen create snapshots more accurately and display them quicker. 

➤ Generate web_reg_find functions for page titles. (Web, Oracle NCA only) 
This option enables the generation of web_reg_find functions for all HTML 
page titles. VuGen adds the string from the page’s title tag and uses it as an 
argument for web_reg_find. 

➤ Generate web_reg_find functions for sub-frames. Enables the generation 
of web_reg_find functions for page titles in all sub-frames of the 
recorded page. 
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➤ Add comment to script for HTTP errors while recording. This option adds a 
comment to the script for each HTTP request error. An error request is 
defined as one that generated a server response value of 400 or greater 
during recording.

➤ Support charset.

➤ UTF-8. This option enables support for UTF-8 encoding. This instructs 
VuGen to convert non-ASCII UTF-8 characters to the encoding of your 
locale’s machine in order to display them properly in VuGen. You should 
enable this option only on non-English UTF-8 encoded pages. The 
recorded site's language must match the operating system language. You 
cannot record non-English Web pages with different encodings (e.g. UTF-
8 together with ISO-8859-1 or shift_jis) within the same script.

➤ EUC-JP. For users of Japanese Windows, select this option to enable 
support for Web sites that use EUC-JP character encoding. This instructs 
VuGen to convert EUC-JP strings to the encoding of your locale’s 
machine in order to display them properly in VuGen. VuGen converts all 
EUC-JP (Japanese UNIX) strings to the SJIS (Japanese Windows) encoding 
of your locale’s machine, and adds a web_sjis_to_euc_param function to 
the script. (Kanji only)

Selecting a Recording Engine
By default, for Web(HTTP/HTML) Vusers, VuGen uses the multi-protocol 
recording engine for all recordings, even if you are only recording a single 
protocol. 

To use the single-protocol recording engine for backward compatibility, 
select the Record script using earlier recording engine option in the 
Advanced Recording Options. If you enable this option, VuGen will use the 
single-protocol engine the next time you record a Web(HTTP/HTML) 
session.
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Setting a Recording Scheme

You can further customize the recording by specifying a recording scheme in 
the following areas:

➤ Recording Custom Headers

➤ Filtering Content Type

➤ Specifying Non-Resource Content Types

Recording Custom Headers
Web Vusers automatically send several standard HTTP headers with every 
HTTP request submitted to the server. Click Headers to instruct VuGen to 
record additional HTTP headers. You can work in three modes: Do not 
Record headers, Record headers in list, or Record headers not in list. When 
you work in the first mode, VuGen does not record any headers. In the 
second mode, VuGen only records the checked custom headers. If you 
specify Record headers not in list, VuGen records all custom headers except 
for those that are checked and other risky headers. 

The following standard headers are known as risky headers: Authorization, 
Connection, Content-Length, Cookie, Host, If-Modified-Since, Proxy-
Authenticate, Proxy-Authorization, Proxy-Connection, Referer, and 
WWW-Authenticate. They are not recorded unless selected in the Header 
list. The default option is Do not record headers.

In the Record headers in list mode, VuGen inserts a web_add_auto_header 
function into your script for each of the checked headers that it detects. This 
mode is ideal for recording risky headers that are not recorded unless 
explicitly stated. 

In the Record headers not in list mode, VuGen inserts a 
web_add_auto_header function into your script for each of the unchecked 
headers that it detects during recording. 

To determine which custom headers to record, you can perform a recording 
session indicating to VuGen to record all headers (see procedure below). 
Afterwards, you can decide which headers to record and which to exclude. 
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In this example, the Content-type header was specified in the Record 
headers in list mode. VuGen detected the header and added the following 
statement to the script:

indicating to the server that the Content-type of the application is 
x-www-form-urlencode.

To control the recording of custom headers:

 1 In the Recording Options tree, select the HTTP Properties:Advanced node.

 2 Click Headers. The Headers dialog box opens. 

 3 Use one of the following methods:

➤ To instruct VuGen not to record any Headers, choose Do not record 
headers. 

➤ To record only specific headers, select Record headers in list and select 
the desired custom headers in the header list. Note that standard headers 
(such as Accept), are selected by default. 

➤ To record all headers, select Record headers not in list and do not select 
any items in the list.

web_add_auto_header("Content-Type",
"application/x-www-form-urlencoded"); 
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➤ To exclude only specific headers, select Record headers not in list and 
select the headers you want to exclude. 

 4 Click Restore List to restore the list to the corresponding default list. The 
Record headers in list and Record headers not in list each have a 
corresponding default list.

 5 Click OK to accept the settings and close the Headers dialog box.

Filtering Content Type
VuGen allows you to filter the content type for your recorded script. You 
specify the type of the content you want to record or exclude from your 
script. You can work in three modes: Do not filter content types, Exclude 
content types in list, or Exclude content types not in list. When you work in 
the first mode, VuGen does not filter any content type. In the second mode, 
VuGen only excludes the selected content types. If you specify Exclude 
content types not in list, VuGen filters all content type except for the ones 
that are checked. By default, no filters are active.

For example, if you are only interested in the text and images on your Web 
site, you select Exclude content types not in list and specify the types 
text/html, image/gif, and image/jpeg. VuGen will record all HTML pages 
and images, and exclude resources such as text/css, application/x-javascript, 
or other resources that appear on the site. 
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To filter content during recording:

 1 In the Recording Options tree, select the HTTP Properties:Advanced node.

 2 Click Content Types. The Content Type Filters dialog box opens.

 3 Use one of the following methods:

➤ To instruct VuGen not to filter any content, choose Do not filter content 
types. 

➤ To exclude only specific content types, select Exclude content types in list 
and select the desired content types from the list. 

➤ To include only specific content types, select Exclude content types not 
in list and select the content types you want to include. 

 4 Click Restore List to restore the list to the corresponding default list. The 
Exclude content types in list and Exclude content types not in list each have 
a corresponding default list.

 5 Click OK to accept the settings and close the Content Type Filters dialog 
box.
593



Chapter 38 • Setting Recording Options for Internet Protocols
Specifying Non-Resource Content Types
When you record a script, VuGen indicates whether or not it will retrieve 
the resource during replay using the Resource attribute in the web_url 
function. If the Resource attribute is set to 0, the resource is retrieved during 
script execution. If the Resource attribute is set to 1, the Vuser skips the 
resource type.

You can exclude specific content types from being handled as resources. For 
example, you can indicate to VuGen that gif type resources should not be 
handled as a resource and therefore be downloaded unconditionally. When 
VuGen encounters a gif type resource, it sets the Resource attribute to 0, 
indicating to VuGen to download gifs unconditionally during replay. 

web_url("WebTours",
"URL=http://localhost/WebTours/",
"Resource=0",
"RecContentType=text/html",
"Referer=",
"Snapshot=t1.inf",
"Mode=HTML",
LAST);
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To specify which content should not be recorded as resources:

 1 In the Recording Options tree, select the HTTP Properties:Advanced node.

 2 Click Non-Resources to open the dialog box and display the list of content 
types which should not be recorded as resources.

 3 Click the "+" sign to add a content type to the list. Click the "-" sign to 
remove an existing entry.

 4 Select the check boxes adjacent to the items you want to enable.

 5 Click Restore List to restore the list to the default list. 

 6 Click OK to accept the settings and close the Non-Resources list.
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39
Setting Recording Options for Web 
Vusers

Before recording a Web session, you can customize the recording options.

This chapter includes:

 ➤  About Setting Recording Options on page 597

 ➤  Selecting a Recording Level on page 598

 ➤  Setting the Recording Level on page 611

The following information applies to Web (HTTP/HTML), Web (Click and 
Script), Web/WinSocket, Oracle Web Applications 11i, and PeopleSoft 
Enterprise Vuser scripts.

About Setting Recording Options

VuGen enables you to generate Web Vuser scripts by recording typical 
processes that users perform on your Web site. 

Before recording, you can configure the Recording Options and specify the 
information to record, the browser or client with which to record, and 
designate the content for your scripts. 

You can set the common HTTP Properties recording options, such as proxy 
settings and other advanced settings. For more information see Chapter 38, 
“Setting Recording Options for Internet Protocols.”

You can also set Correlation recording options for Web Vuser scripts. For 
more information, see Chapter 44, “Setting Correlation Rules for Web Vuser 
Scripts.”
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Selecting a Recording Level

VuGen lets you specify what information to record and which functions to 
use when generating a Vuser script, by selecting a recording level. The 
recording level you select, depends on your needs and environment. The 
available levels are GUI-based script, HTML-based script, and URL-based 
script. For Web HTTP/HTML Vusers, only the two latter options are 
available.

Use the following guidelines to decide which recording level to choose:

➤ For most applications, including those with JavaScript, use a GUI-based 
script. This level is also recommended for PeopleSoft Enterprise and Oracle 
Web Applications 11i Vusers.

➤ For browser applications with applets and VB Script, create an HTML-based 
script. 

➤ For non-browser applications, use a URL-based script.
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The GUI-based script option instructs VuGen to record HTML actions as 
context sensitive GUI functions such as web_text_link. 

/* GUI-based mode - CS type functions with JavaScript support*//
vuser_init()
{
web_browser("WebTours", 

DESCRIPTION, 
ACTION, 
"Navigate=http://localhost:1080/WebTours/", 
LAST);

web_edit_field("username", 
"Snapshot=t2.inf", 
DESCRIPTION, 
"Type=text", 
"Name=username", 
"FrameName=navbar", 
ACTION, 
"SetValue=jojo", 
LAST);

…
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The HTML-based script level generates a separate step for each HTML user 
action. The steps are also intuitive, but they do not reflect true emulation of 
the JavaScript code. 

/* HTML-based mode - a script describing user actions*/
... 
web_url("WebTours",

"URL=http://localhost/WebTours/",
"Resource=0",
"RecContentType=text/html",
"Referer=",
"Snapshot=t1.inf",
"Mode=HTML",
LAST);

web_link("Click Here For Additional Restrictions",
"Text=Click Here For Additional Restrictions",
"Snapshot=t4.inf",
LAST);

web_image("buttonhelp.gif",
"Src=/images/buttonhelp.gif",
"Snapshot=t5.inf",
LAST);

…
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The URL-based script mode option instructs VuGen to record all browser 
requests and resources from the server that were sent due to the user's 
actions. It automatically records every HTTP resource as URL steps (web_url 
statements). For normal browser recordings, it is not recommended to use 
the URL-based mode since is more prone to correlation related issues. If, 
however, you are recording pages such as applets and non-browser 
applications, this mode is ideal. 

URL-based scripts are not as intuitive as the HTML-based scripts, since all 
actions are recorded as web_url steps instead of web_link, web_image, and 
so on. 

You can switch recording levels and advanced recording options while 
recording, provided that you are not recording a multi-protocol script. The 
option of mixing recording levels is available for advanced users for 
performance testing.

You can also regenerate a script after recording, using a different method 
than the original recording. For example, if your record a script on an 
HTML-based level, you can regenerate it on a URL-based level. To regenerate 
a script, choose Tools > Regenerate Script and click Options to set the 
recording options for the regeneration.

/* URL-based mode - only web_url functions */
… 
web_url("spacer.gif",

"URL=http://graphics.hplab.com/images/spacer.gif",
"Resource=1",
"RecContentType=image/gif",
"Referer=",
"Mode=HTTP",
LAST);

web_url("calendar_functions.js",
"URL=http://www.im.hplab.com/travelp/calendar_functions.js",
"Resource=1",
"RecContentType=application/x-javascript",
"Referer=",
"Mode=HTTP",
LAST);

…
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Setting Advanced HTML-Based Options
The HTML-based option, which is the default recording level for Web 
(HTTP/HTML) Vusers, instructs VuGen to record HTML actions in the 
context of the current Web page. It does not record all resources during the 
recording session, but downloads them during replay.

VuGen lets you set advanced options for HTML-based script in the following 
areas:

➤ Specifying Script Types

➤ Handling Non HTML-Generated Elements
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Specifying Script Types

For HTML-based scripts, you can specify the type of script:

➤ A script describing user actions

➤ A script containing explicit URLs only

The first option, A script describing user actions, is the default option. It 
generates functions that correspond directly to the action taken. It creates 
URL (web_url), link (web_link), image (web_image), and form submission 
(web_submit_form) functions. The resulting script is very intuitive and 
resembles a context sensitive recording. 

/* HTML-based mode - a script describing user actions*//
... 
web_url("WebTours",

"URL=http://localhost/WebTours/",
"Resource=0",
"RecContentType=text/html",
"Referer=",
"Snapshot=t1.inf",
"Mode=HTML",
LAST);

web_link("Click Here For Additional Restrictions",
"Text=Click Here For Additional Restrictions",
"Snapshot=t4.inf",
LAST);

web_image("buttonhelp.gif",
"Src=/images/buttonhelp.gif",
"Snapshot=t5.inf",
LAST);

…
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The second option, A script containing explicit URLs only, records all links, 
images and URLs as web_url statements, or in the case of forms, as 
web_submit_data. It does not generate the web_link, web_image, and 
web_submit_form functions. The resulting script is less intuitive. This 
mode is useful for instances where many links within your site have the 
same link text. If you record the site using the first option, it records an 
ordinal (instance) for the link, but if you record using the second option, 
each link is listed by its URL. This facilitates parameterization and 
correlation for that step. 

The following segment illustrates a session recorded with a script containing 
explicit URLs only selected: 

/* A HTML-based script containing explicit URLs only*//
…
web_url("Click Here For Additional Restrictions",

"URL=http://www.hplab.com/restrictions.html",
"TargetFrame=",
"Resource=0",
"RecContentType=text/html",
"Referer=http://www.hplab.com/home?…
"Snapshot=t4.inf",
"Mode=HTML",
LAST);

web_url("buttonhelp.gif",
"URL=http://www.hplab.com/home?com/rstr?BV_EngineID...,
"TargetFrame=main",
"Resource=0",
"RecContentType=text/html",
"Referer=http://www.hplab.com/home?…
"Snapshot=t5.inf",
"Mode=HTML",
LAST);

… 
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Handling Non HTML-Generated Elements

Many Web pages contain non-HTML elements, such as applets, XML, 
ActiveX elements, or JavaScript. These non-HTML elements usually contain 
or retrieve their own resources. For example, a JavaScript js file, called from 
the recorded Web page, may load several images. An applet may load an 
external text file. Using the following options, you can control how VuGen 
records non HTML-generated elements. 

The following options are available:

➤ Record within the current script step (default)

➤ Record in separate steps using concurrent groups

➤ Do not record

The first option, Record within the current script step, does not generate a 
new function for each of the non HTML-generated resources. It lists all 
resources as arguments of the relevant functions, such as web_url, web_link, 
and web_submit_data. The resources, arguments of the Web functions, are 
indicated by the EXTRARES flag. In the following example, the web_url 
function lists all of the non HTML-generated resources loaded on the page: 

web_url("index.asp",
"URL=http://www.daisy.com/index.asp",
"TargetFrame=",
"Resource=0",
"RecContentType=text/html",
"Referer=",
"Snapshot=t2.inf",
"Mode=HTML",
EXTRARES,
"Url=http://www.daisy.com/ScrollApplet.class", "Referer=", ENDITEM,
"Url=http://www.daisy.com/board.txt", "Referer=", ENDITEM,
"Url=http://www.daisy.com/nav_login1.gif", ENDITEM,
…
LAST);
605



Chapter 39 • Setting Recording Options for Web Vusers
The second option, Record in separate steps using concurrent groups, 
creates a new function for each one of the non HTML-generated resources—
it does not include them as items in the page’s functions (such as web_url, 
web_link, and so on). All of the web_url functions generated for a resource, 
are placed in a concurrent group (surrounded by web_concurrent_start and 
web_concurrent_end).

In the following example, the above session was recorded with this option 
selected. A web_url function was generated for the applet and text file 
loaded with the applet: 

web_url("index.asp",
"URL=http://www.daisy.com/index.asp",
"Resource=0",
"RecContentType=text/html",
"Referer=",
"Snapshot=t2.inf",
"Mode=HTML",
LAST);

web_concurrent_start(NULL);
web_url("ScrollApplet.class",

"URL=http://www.daisy.com/ScrollApplet.class",
"Resource=1",
"RecContentType=application/octet-stream",
"Referer=",
LAST);

web_url("board.txt",
"URL=http://www.daisy.com/board.txt",
"Resource=1",
"RecContentType=text/plain",
"Referer=",
LAST);

web_concurrent_end(NULL);
606



Chapter 39 • Setting Recording Options for Web Vusers
The third option, Do not record, instructs VuGen not to record any of the 
resources generated by non-HTML elements. 

Note that when you work in HTML-Based mode, VuGen inserts the 
TargetFrame attribute in the web_url statement. VuGen uses this 
information to display the Web page correctly in the run-time browser and 
Test Result report.

When you record the URL-based mode, VuGen records the content of all 
frames on the page and therefore omits the TargetFrame attribute. 

web_url("buttonhelp.gif",
"URL=http://www.hplab.com/home?com/rstr?BV_EngineID...,
"TargetFrame=main",
"Resource=0",
"RecContentType=text/html",
"Referer=http://www.hplab.com/home?…
"Snapshot=t5.inf",
"Mode=HTML",
LAST);
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Setting Advanced URL-Based Options
The URL-based mode option instructs VuGen to record all requests and 
resources from the server. It automatically records every HTTP resource as 
URL steps (web_url statements), or in the case of forms, as 
web_submit_data. It does not generate the web_link, web_image, and 
web_submit_form functions, nor does it record frames.

VuGen lets you set advanced options for the URL recording mode in the 
following area:

➤ Resource Handling

➤ Custom HTTP Requests

Resource Handling

In URL-based recording, VuGen captures all resources downloaded as a 
result of a browser request. By default, this option is enabled and VuGen 
records the resources in a concurrent group (enclosed by 
web_concurrent_start and web_concurrent_end statements) after the 
URL. Resources include files such as images, and js files. If you disable this 
option, the resources are listed as separate web_url steps, but not marked as 
a concurrent group.
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The following segment illustrates a session recorded with the Create 
concurrent groups for resources after their source HTML page option 
enabled. 

Note that the script includes gif, and js files. This mode also includes other 
graphic files and imported file such as imp, txt, and cascading style sheet 
(css) files. 

web_concurrent_start (NULL);
… 
web_url("Click Here For Additional Restrictions",

"URL=http://www.hplab.com/restrictions.html",
"Resource=0",
"RecContentType=text/html",
"Referer=http://www.hplab.com/home?…
"Snapshot=t4.inf",
"Mode=HTTP",
LAST);

web_url("buttonhelp.gif",
"URL=http://www.hplab.com/home?com/rstr?BV_EngineID...,
"Resource=0",
"RecContentType=text/html",
"Referer=http://www.hplab.com/home?…
"Snapshot=t5.inf",
"Mode=HTTP",
LAST);

…
web_concurrent_end (NULL);
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Generating Custom HTTP Requests

When recording non-browser applications, you can instruct VuGen to 
record all HTTP requests as custom requests. VuGen generates a 
web_custom_request function for all requests, regardless of their content:

Enabling EUC-Encoded Web Pages

(This option is only for Japanese Windows.) When working with non-
Windows standard character sets, you may need to perform a code 
conversion. A character set is a mapping from a set of characters to a set of 
integers. This mapping forms a unique character-integer combination, for a 
given alphabet. Extended UNIX Code (EUC) and Shift Japan Industry 
Standard (SJIS) are non-Windows standard character sets used to display 
Japanese writings on Web sites. 

Windows uses SJIS encoding, while UNIX uses EUC encoding. When a Web 
server is on a UNIX machine and the client is Windows, the characters in a 
Web site are not displayed on the client machine properly due to the 
difference in the encoding methods. This affects the display of EUC-
encoded Japanese characters in a Vuser script. 

During recording, VuGen detects the encoding of a Web page through its 
HTTP header. If the information on the character set is not present in the 
HTTP header, it checks the HTML meta tag. If the page does not send the 
character set information to the HTTP header or meta tag, VuGen does not 
detect the EUC encoding. 

If you know in advance that a Web page is encoded in EUC, you can instruct 
VuGen to use the correct encoding during record. To record a page in EUC-
encoding, enable the EUC option in the Recording Options Recording tab 
(only visible for Japanese Windows).

web_custom_request("www.hplab.com",
"URL=http://www.hplab.com/",
"Method=GET",
"Resource=0",
"RecContentType=text/html",
"Referer=",
"Snapshot=t1.inf",
"Mode=HTTP",
LAST);
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Enabling the EUC option, forces VuGen to record a Web page in EUC 
encoding, even when it is not EUC-encoded. You should, therefore, only 
enable this option when VuGen cannot detect the encoding from the HTTP 
header or the HTML meta tag, and when you know in advance that the page 
is EUC-encoded. 

During recording, VuGen receives an EUC-encoded string from the Web 
server and converts it to SJIS. The SJIS string is saved in the script’s Action 
function. However, for replay to succeed, the string has to be converted back 
to EUC before being sent back to the Web server. Therefore, VuGen adds a 
web_sjis_to_euc_param function before the Action function, which 
converts the SJIS string back to EUC. 

In the following example, the user goes to an EUC-encoded Web page and 
clicks a link. VuGen records the Action function and adds the 
web_sjis_to_euc_param function to the script before the Action function.

Setting the Recording Level

This section describes the procedure for setting the recording levels and 
their advanced options.

To set the recording options: 

 1 Choose Tools > Recording Options to open the Recording Options. 

 2 Select the General:Recording node in the Recording Options tree.

 3 Select a recording mode: GUI-based (when available), HTML-based, or URL-
based.

 4 For GUI-based recording, open the recording options (Ctrl + F7) and select 
the GUI Properties:Advanced node to set additional options for capturing 
events during recording.

For more information, see “Setting Advanced GUI Properties” on page 571.

 5 For HTML-based recording, click HTML Advanced to set additional options 
for script types and the handling of non-HTML elements.

web_sjis_to_euc_param("param_link","Search");
web_link("LinkStep","Text={param_link}");
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Select a script type.

Select a method for handling non-HTML resources. For more information, 
see “Setting Advanced HTML-Based Options” on page 602.

 6 For URL-based recording, click URL Advanced to set additional script 
options for resource handling and cache enabling.

Select Create concurrent groups for resources after their source HTML page 
to enable the recording of resources and marking them as a concurrent 
group (surrounded by web_concurrent_start and web_concurrent_end).

Select Enable cache to use the browser cache during recording. If you enable 
this option, clear the Clear cache before recording check box to instruct 
VuGen not to clear the cache and use previously accessed pages. 

Select Use web_custom_request only to generate all HTTP requests as 
web_custom_request functions. For more information about these options, 
see “Setting Advanced URL-Based Options” on page 608.

 7 For users of Japanese Windows, select the EUC option to instruct VuGen to 
use EUC encoding. 

If you are recording a Web site whose pages use only the EUC Encoding 
(Japanese content), select the EUC option. VuGen converts the EUC string to 
SJIS and adds a web_sjis_to_euc_param function. If the server sends this 
information to the browser (in an HTTP header or an HTML Meta tag), you 
do not need to enable this option.
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Configuring Internet Run-Time Settings 

After you record an Internet protocol Vuser script, you configure its run-
time settings.

This chapter includes:

 ➤  About Internet Run-Time Settings on page 613

 ➤  Setting Proxy Options on page 615

 ➤  Setting Browser Emulation Properties on page 620

 ➤  Setting Internet Preferences on page 625

 ➤  Filtering Web Sites on page 633

 ➤  Obtaining Debug Information on page 635

 ➤  Performing HTML Compression on page 636

The following information applies to all Internet Protocol Vuser types such 
as Web and Wireless.

About Internet Run-Time Settings

After developing a Internet protocol Vuser script, you set the run-time 
settings. 

For information about the general run-time settings that apply to all Vusers, 
see “Configuring Run-Time Settings” in Volume I-Using VuGen. For 
information about the network speed run-time settings, see “Configuring 
Network Run-Time Settings” in Volume I-Using VuGen.
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The Internet run-time settings let you configure your Internet environment 
so that Vusers can accurately emulate real users. You can set Internet run-
time settings for Proxy, Browser, and other advanced preferences.

You set the Internet-related run-time settings from the Run-Time Settings 
dialog box. You click the appropriate node to specify the desired settings. 

You can also modify the run-time settings directly from the LoadRunner 
Controller. For more information, refer to the HP LoadRunner Controller 
User’s Guide.

Note: A run-time setting assigned a value through a Vuser function, 
overrides the corresponding setting set via the Run-Time Settings dialog 
box. For more information on using Vuser functions, see Chapter 36, “Using 
Web Vuser Functions.”
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Setting Proxy Options

You use the Internet Protocol:Proxy node of the Run-Time Settings tree, to 
set the proxy-related settings.

The following proxy options are available in the Run-Time settings. 

➤ No proxy. All Vusers should use direct connections to the Internet. This 
means that the connection is made without using a proxy server.

➤ Obtain the proxy settings from the default browser. All Vusers use the 
proxy settings of the default browser from the machine upon which they 
are running.
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➤ Use custom proxy. All Vusers use a custom proxy server. You can supply 
the actual proxy server details or the path of a proxy automatic 
configuration script (.pac file) that enables automatic configuration. (See 
“Setting the Automatic Proxy Configuration” on page 617.)

To supply the details of the server, you specify its IP address or name and 
port. You can specify one proxy server for all HTTP sites, and another 
proxy server for all HTTPS (secure) sites. 

After providing the proxy information, you can specify Authentication 
information for the proxy server, and indicate Exceptions to the proxy 
rules.

Note: To instruct the Vusers to wait for the proxy response during replay, 
and not to assume that the proxy supports basic authentication, add the 
following statement: 
web_set_sockets_option("PROXY_INITIAL_BASIC_AUTH", "0");

Authentication
If the proxy server requires authentication for each Vuser, use this dialog 
box to enter the relevant password and user name.

➤ User Name. Enter the user name that Vusers will use to access the proxy 
server.

➤ Password. Enter the password required by Vusers to access the proxy server.

Note: To add authentication dynamically during recording, or to add 
authentication for multiple proxy servers, use the web_set_user function. 
For more information, see the Online Function Reference (Help > Function 
Reference). 
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Exceptions
You can specify that all Vusers use a specified proxy server. In such a case, if 
there are any URLs that you want Vusers to access directly, that is, without 
using the proxy server, enter the list of these URLs in the text box.

➤ Do not use proxy server for addresses beginning with. Enter the addresses 
you want to exclude from the proxy server. Use semicolons to separate 
entries.

➤ Do not use proxy server for local (intranet) addresses. Select this check box 
to exclude local addresses, such as those from an Intranet, from the proxy 
server.

Setting the Automatic Proxy Configuration
Automatic Proxy Configuration is a feature supported by most browsers. 
This feature allows you to specify a JavaScript file (usually with a .pac 
extension) containing proxy assignment information. This script tells the 
browser when to access a proxy server and when to connect directly to the 
site, depending on the URL. In addition, it can instruct the browser to use a 
specific proxy server for certain addresses and another server for other 
addresses. 

You can instruct VuGen or your Internet Explorer browser to work with a 
configuration script. You specify a file for the automatic proxy 
configuration, so that when the Vuser runs the test, it uses the rules from 
the proxy file.

To specify a configuration script in VuGen:

 1 Choose Vuser > Run-TIme Settings, and select the Internet Protocol:Proxy 
node. 

 2 Select Use custom proxy and select the Use automatic configuration script 
option. Specify the location of the script.
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To specify a configuration script in Internet Explorer (IE):

 1 Choose Tools > Internet Options, and select the Connections tab. 

 2 Click the LAN Settings button. The LAN Settings dialog box opens.

 3 Select the Use automatic configuration script option, and specify the 
location of the script.

To track the behavior of the Vusers, generate a log during text execution and 
view the Execution Log tab or the mdrv.log file. The log shows the proxy 
servers that were used for each URL. In the following example, VuGen used 
a direct connection for the URL australia.com, but the proxy server aqua, for 
the URL http://www.google.com.

Action1.c(6): t=1141ms: FindProxyForURL returned DIRECT
Action1.c(6): t=1141ms: Resolving australia.com
Action1.c(6): t=1141ms: Connecting to host 199.203.78.255:80
… 
Action1.c(6): t=1281ms: Request done "http://australia.com/GetElementByName.htm"

… 
Action1.c(6): web_url was successful, 357 body bytes, 226 header bytes
Action1.c(15): web_add_cookie was successful
Action1.c(17): t=1391ms: FindProxyForURL returned PROXY aqua:2080
Action1.c(17): t=1391ms: Auto-proxy configuration selected proxy aqua:2080
Action1.c(17): t=1391ms: Resolving aqua
Action1.c(17): t=1391ms: Connecting to host 199.203.139.139:2080
… 
Action1.c(17): t=1578ms: 168-byte request headers for "http://www.google.com/" 
(RelFrameId=1)
Action1.c(17):     GET http://www.google.com/ HTTP/1.1\r\n
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Setting Proxy Run-Time Settings
The following section discusses the steps required for configuring the proxy 
Run-Time settings.

To set the proxy settings:

 1 Open the Run-Time settings. Click the Run-Time Settings button on the 
VuGen toolbar or choose Vuser > Run-Time Settings.

 2 Click the Internet Protocol:Proxy node.

 3 Select the desired proxy option: No proxy, Obtain the proxy settings from 
the default browser, or Use custom proxy.

 4 If you specified a custom proxy:

➤ indicate the IP addresses for the HTTP and HTTPS proxy servers

➤ To use a pac or JavaScript file to indicate the proxy, select the Use 
automatic configuration script option and specify the script location. 
You can specify either a web location beginning with http:// (for 
example, http://hostname/proxy.pac), or a location on the file server, for 
example, C:\temp\proxy.pac.

 5 To specify URLs that you want Vusers to access directly, without the proxy 
server, click Exceptions and then supply the list of these URLs. In the 
Exceptions dialog box, you can also specify direct access to local (intranet) 
addresses.

 6 If the proxy server requires authentication, click Authentication, and then 
supply the relevant password and user name.

 7 Select the Use the same proxy server for all protocols check box to instruct 
the Vusers to use the same proxy server for all Internet protocols (HTTP, 
HTTPS) rather than specifying a specific server for secure sites.
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Setting Browser Emulation Properties

You use the Browser:Browser Emulation node in the Run-Time Settings tree 
to set the browser properties of your testing environment.

Browser Properties
You can set the browser properties in the following areas:

➤ User-Agent (browser to be emulated)

➤ Simulate browser cache

➤ Download non-HTML resources

➤ Simulate a new user each iteration

You can also set advanced options for caching and checking for newer 
resources.
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User-Agent (browser to be emulated)
Whenever a Vuser sends a request to a Web server, the request includes an 
HTTP header. The first line of text contains a verb (usually "GET" or "POST"), 
the resource name (for example "pclt/default.htm"), and the version of the 
protocol (for example "HTTP/1.0"). Subsequent lines contain "header 
information" in the form of an attribute name, a colon, and some value. The 
request ends with a blank line. 

All Internet Vuser headers include a User-Agent header that identifies the 
type of browser (or toolkit for Wireless) that is being emulated. For example, 

User-Agent: Mozilla/3.01Gold (WinNT; I)

identifies the Browser as Netscape Navigator Gold version 3.01 running 
under Windows NT on an Intel machine. 

Click Change from the Browser emulation node, to specify the browser 
information to include in the header. You can specify that a Web Vuser 
emulate any of the standard browsers. Alternatively, for non-browser HTTP 
applications, you can specify the HTTP client to match a specific user’s 
application. In this case, you must supply a Custom User Agent string that is 
included in all subsequent HTTP headers. By default, the user-agent 
emulates the Microsoft Internet Explorer 5.5 browser agent. 

Simulate browser cache

This option instructs the Vuser to simulate a browser with a cache. A cache 
is used to keep local copies of frequently accessed documents and thereby 
reduces the time connected to the network. By default, cache simulation is 
enabled. When the cache is disabled, Vusers will ignore all caching 
functionality and download all of the resources for every request.

Note that even if you disable the cache simulation, each resource is only 
downloaded once for each page, even if it appears multiple times. A resource 
can be an image, a frame, or another type of script file.

When running multiple Vusers as in LoadRunner and Performance Center, 
every Vuser uses its own cache and retrieves images from the cache. If you 
disable this option, all Vusers emulate a browser with no cache available. 
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You can modify your Run-Time settings to match your browser settings for 
Internet Explorer, as follows:

You can also set the following two browser cache options: 

➤ Cache URLs requiring content (HTML). This option instructs VuGen to 
cache only the URLs that require the HTML content. The content may be 
necessary for parsing, verification, or correlation. When you select this 
option, HTML content is automatically cached. This option is enabled by 
default. 

Tip: To decrease the memory footprint of the virtual users, disable this 
option, unless it is an explicit requirement for your test.

To add more content types to the list of cached types, click Advanced. For 
more information, see “Cache URLs Requiring Content - Advanced” on 
page 624. Note that if you enable the parent option Simulate browser cache, 
but disable this option, VuGen nevertheless stores the graphic files.

Browser Setting Run-Time Setting

Every visit to the page Select Simulate Browser Cache and 
enable Check for newer versions of 
stored pages every visit to the 
page.

Every time you start Internet Explorer Select Simulate Browser Cache only

Automatically Select Simulate Browser Cache only

Never Select Simulate Browser Cache and 
disable Check for newer versions of 
stored pages every visit to the 
page.
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➤ Check for newer versions of stored pages every visit to the page. This 
setting instructs the browser to check for later versions of the specified URL, 
than those stored in the cache. When you enable this option, VuGen adds 
the "If-modified-since" attribute to the HTTP header. This option brings up 
the most recent version of the page, but also generates more traffic during 
the scenario or session execution. By default, browsers do not check for 
newer resources, and therefore this option is disabled. Configure this option 
to match the settings in the browser that you want to emulate. 

Download non-HTML resources

Instructs Vusers to load graphic images when accessing a Web page during 
replay. This includes both graphic images that were recorded with the page, 
and those which were not explicitly recorded along with the page. When 
real users access a Web page, they wait for the images to load. Therefore, 
enable this option if you are trying to test the entire system, including end-
user time (enabled by default). To increase performance and not emulate 
real users, disable this option. 

Tip: Disable this option if you experience discrepancies in image checks, 
since some images vary each time you access a Web page (for example, 
advertiser banners).

Simulate a new user each iteration

Instructs VuGen to reset all HTTP contexts between iterations to their states 
at the end of the init section. This setting allows the Vuser to more 
accurately emulate a new user beginning a browsing session. It deletes all 
cookies, closes all TCP connections (including keep-alive), clears the 
emulated browser’s cache, resets the HTML frame hierarchy (frame 
numbering will begin from 1) and clears the user-names and passwords. This 
option is enabled by default.

➤ Clear cache on each iteration. Clears the browser cache for each iteration in 
order to simulate a user visiting a Web page for the first time. Clear the 
check box to disable this option and allow Vusers to use the information 
stored in the browser’s cache, simulating a user who recently visited the 
page. 
623



Chapter 40 • Configuring Internet Run-Time Settings
Cache URLs Requiring Content - Advanced
The Advanced dialog box lets you specify the URL content types that you 
want to store in the cache. This dialog box is accessible from the Run-time 
Settings - Browser:Browser Emulation node.

Note that changes to the advanced settings for multiple groups 
simultaneously, are not supported—edit each group’s settings individually.

To add a content type:

 1 Enable the Specify URLs requiring content in addition to HTML page 
option.

 2 Click the plus sign to add additional content types, such as text/plain, 
text/xml, image/jpeg, and image/gif. Enter the content name in the text box.

 3 To remove a content type from the list, select it and click the minus sign.
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Setting Internet Preferences

You use the Internet Protocol:Preferences node in the Run-Time Settings 
tree, to set the settings related to the following areas:

➤ Image and Text Checks

➤ Generating Web Performance Graphs

➤ Advanced Web Run-Time Options

Image and Text Checks

The Enable image and text checks option allows the Vuser to perform 
verification checks during replay by executing the verification functions: 
web_find or web_image_check. This option only applies to statements 
recorded in HTML-based mode. Vusers running with verification checks use 
more memory than Vusers who do not perform checks (disabled by default).
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Generating Web Performance Graphs 

Instructs a Vuser to collect data used to create Web Performance graphs. You 
view the Hits per Second, Pages per Second, and Response Bytes per 
Second (Throughput) graphs during test execution using the online 
monitors and after test execution using the Analysis. You view the 
Component Breakdown graph after test execution using the Analysis. Select 
the types of graph data for the Vuser to collect.

Note: If you do not use the Web performance graphs, disable these options 
to save memory.

Advanced Web Run-Time Options

➤ WinInet Replay. Instructs VuGen to use the WinInet replay engine instead of 
the standard Sockets replay. VuGen has two HTTP replay engines: Sockets-
based (default) or WinInet based. The WinInet is the engine used by Internet 
Explorer and it supports all of the features incorporated into the IE browser. 
The limitations of the WinInet replay engine are that it is not scalable, nor 
does it support UNIX. In addition, when working with threads, the WinInet 
engine does not accurately emulate the modem speed and number of 
connections.

VuGen’s proprietary sockets-based replay is a lighter engine that is scalable 
for load testing. It is also accurate when working with threads. The 
limitation of the sockets-based engine is that it does not support SOCKS 
proxy. If you are recording in that type of environment, use the WinInet 
replay engine.

➤ File and line in automatic transaction names. Creates unique transaction 
names for automatic transactions by adding file name and line number to 
the transaction name (enabled by default).

Note: This option places additional information in the log file, and 
therefore requires more memory. 
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➤ Non-critical item errors as warnings. This option returns a warning status 
for a function which failed on an item that is not critical for load testing, 
such as an image or Java applet that failed to download. This option is 
enabled by default. If you want a certain warning to be considered an error 
and fail your test, you can disable this option. You can set a content-type to 
be critical by adding it to the list of Non-Resources. For more information, 
see “Specifying Non-Resource Content Types” on page 594.

➤ Save snapshot resources locally. Instructs VuGen to save the snapshot 
resources to files on the local machine. This feature lets the Run-Time viewer 
create snapshots more accurately and display them quicker. 

Additional Options for Internet Preferences
Click the Options button in the Advanced section of the Preferences node to 
set advanced options in the following areas: DNS caching, HTTP version, 
Keep-Alive HTTP connections, Accept server-side compression, Accept-
Language headers, HTTP-request connect timeout, HTTP-request receive 
timeout, Network buffer size, and Step download timeout.

HTTP

➤ HTTP version. Specifies which version HTTP to use: version 1.0 or 1.1. This 
information is included in the HTTP request header whenever a Vuser sends 
a request to a Web server. The default is HTTP 1.1. HTTP 1.1 supports the 
following features: 

➤ Persistent Connections—see "Keep-Alive HTTP connections" below. 

➤ HTML compression—see “Performing HTML Compression” on page 636.

➤ Virtual Hosting—multiple domain names sharing the same IP address.

➤ Keep-Alive HTTP connections. Keep-alive is a term used for an HTTP 
extension that allows persistent or continuous connections. These long-
lived HTTP sessions allow multiple requests to be sent over the same TCP 
connection. This improves the performance of the Web server and clients.

The keep-alive option works only with Web servers that support keep-alive 
connections. This setting specifies that all Vusers that run the Vuser script 
have keep-alive HTTP connections enabled (enabled by default).
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➤ Accept-Language request header. Provides a comma-separated list of 
accepted languages. For example, en-us, fr, and so forth.

➤ HTTP errors as warnings. Issues a warning instead of an error upon failing to 
download resources due to an HTTP error.

➤ HTTP-request connect timeout (seconds). The time, in seconds, that a Vuser 
will wait for the connection of a specific HTTP request within a step before 
aborting. Timeouts provide an opportunity for the server to stabilize and 
respond to the user (default value is 120 seconds). Note that this timeout 
also applies to the time the Vuser will wait for a WAP connection, initiated 
by the wap_connect function.

➤ HTTP-request receive timeout (seconds). The time, in seconds, that a Vuser 
will wait to receive the response of a specific HTTP request within a step 
before aborting. Timeouts provide an opportunity for the server to stabilize 
and respond to the user (default value is 120 seconds).

➤ Request Zlib Headers. Sends request data to the server with the zlib 
compression library headers. By default, requests sent to the server include 
the zlib headers. This option lets you emulate non-browser applications that 
do not include zlib headers in their requests. To exclude these headers, set 
this option to No (default is Yes).

➤ Accept Server-Side Compression. Indicate to the server that the replay can 
accept compressed data. The available options are: None (no compression), 
gzip (accept gzip compression), gzip, deflate (accept gzip or deflate 
compression), and deflate (accept deflate compression). Note that by 
accepting compressed data, you may significantly increase the CPU 
consumption. The default is to accept gzip, deflate compression.

General

➤ DNS caching. Instructs the Vuser to save a host’s IP addresses to a cache after 
resolving its value from the Domain Name Server. This saves time in 
subsequent calls to the same server. In situations where the IP address 
changes, as with certain load balancing techniques, be sure to disable this 
option to prevent Vuser from using the value in the cache (enabled by 
default).
628



Chapter 40 • Configuring Internet Run-Time Settings
➤ Convert from/to UTF-8. Converts received HTML pages and submitted data 
from and to UTF-8. You enable UTF-8 support in the recording options. For 
more information, see “Setting Advanced Recording Options” on page 588 
(No by default).

➤ Step timeout caused by resources is a warning. Issues a warning instead of 
an error when a timeout occurs due to a resource that did not load within 
the timeout interval. For non-resources, VuGen issues an error (disabled by 
default).

➤ Parse HTML Content-Type. When expecting HTML, parse the response only 
when it is the specified content-type: HTML, text\html, TEXT any text, or 
ANY, any content-type. Note that text/xml is not parsed as HTML. The 
default is TEXT. 

The timeout settings are primarily for advanced users who have determined 
that acceptable timeout values should be different for their environment. 
The default settings should be sufficient in most cases. If the server does not 
respond in a reasonable amount of time, check for other connection-related 
issues, rather than setting a very long timeout which could cause the scripts 
to wait unnecessarily.

➤ Step download timeout (sec). The time that the Vuser will wait before 
aborting a step in the script. This option can be used to emulate a user 
behavior of not waiting for more than x seconds for a page.

➤ Network buffer size. Sets the maximum size of the buffer used to receive the 
HTTP response. If the size of the data is larger than the specified size, the 
server will send the data in chunks, increasing the overhead of the system. 
When running multiple Vusers from the Controller, every Vuser uses its own 
network buffer. This setting is primarily for advanced users who have 
determined that the network buffer size may affect their script’s 
performance. The default is 12K bytes. The maximum size is 0x7FFF FFFF.

➤ Max number of error matches issued as ERRORS. Limits the number of error 
matches issued as ERRORS for content checks using a LB or RB (left 
boundary or right boundary). This applies to matches where a failure occurs 
when the string is found (Fail=Found). All subsequent matches are listed as 
informational messages. The default is 10 matches.

➤ Maximum number of META Refresh to the same page. The maximum 
number of times that a META refresh can be performed per page. The default 
is 2.
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Authentication

➤ Fixed think time upon authentication retry (msec). Automatically adds a 
think time to the Vuser script for emulating a user entering authentication 
information (username and password). This think time will be included in 
the transaction time (default is 0).

➤ Disable NTLM2 session security. Use full NTLM 2 handshake security instead 
of the more basic NTLM 2 session security response (default is No).

➤ Enable integrated Authentication. Enable Kerberos-based authentication. 
When the server proposes authentication schemes, use Negotiate in 
preference to other schemes (default is No).

➤ Induce heavy KDC load. Do not reuse credentials obtained in previous 
iterations. Enabling this setting will increase the load on the KDC (Key 
Distribution Server). To lower the load on the server, set this option to Yes in 
order to reuse the credentials obtained in previous iterations. This option is 
only relevant when Kerberos authentication is used (default is No).

Log

➤ Print buffer line length. Line length for printing request/response 
header/body and/or JavaScript source, disabling wrapping.

➤ Print buffer escape only binary zeros. 

➤ Yes. Escape only binary zeros when printing request/response 
headers/body and/or JavaScript source. 

➤ No. Escape any unprintable/control characters.

Web (Click and Script) Specific

➤ General

➤ Home Page URL. The URL of the home page that opens with your 
browser (default is about:blank). 

➤ DOM-based snapshots. Instructs VuGen to generate snapshots from the 
DOM instead of from the server responses (Yes by default).

➤ Charset conversions by HTTP. Perform charset conversions by the 
‘Content-Type:....; charset=...’ HTTP response header. Overrides ‘Convert 
from /to UTF-8.’
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➤ Reparse when META changes charset. Reparse HTML when a META tag 
changes the charset. Effective only when Charset conversions by HTTP is 
enabled. Auto means reparsing is enabled only if it used in the first 
iteration.

➤ Fail on JavaScript error. Fails the Vuser when a JavaScript evaluation error 
occurs. The default is No, issuing a warning message only after a 
JavaScript error, but continuing to run the script.

➤ Timers

➤ Optimize timers at end of step. When possible, executes a 
setTimeout/setInterval/<META refresh> that expires at the end of the step 
before the expiration time (default is Yes).

➤ Single setTimeout/setInterval threshold (seconds). Specifies an upper 
timeout for the window.setTimeout and window.setInterval methods. If 
the delay exceeds this timeout, these methods will not invoke the 
functions that are passed to them. This emulates a user waiting a 
specified time before clicking on the next element (default is 5 seconds).

➤ Accumulative setTimeout/setInterval threshold (seconds). Specifies a 
timeout for the window.setTimeout and window.setInterval methods. If 
the delay exceeds this timeout, additional calls to window.setTimeout 
and window.setInterval will be ignored. The timeout is accumulative per 
step (default is 30 seconds). 

➤ Reestablish setInterval at end of step. 0 = No; 1 = Once; 2 = Yes.

➤ ActiveX Support

➤ Support ActiveX controls. Create and execute ActiveX objects in the 
DOM (Windows OS only). The default is No.

➤ Support ActiveX objects. Execute ActiveX controls created in the 
JavaScript (Windows OS only). The default is Yes. 

➤ Force WinInet for asynchronous ActiveX navigations. Force using 
WinInet for asynchronous Active X navigations where currently the 
Replay’s network mechanism is used.

➤ Force WinInet for synchronous ActiveX navigations. Force using WinInet 
for synchronous Active X navigations where currently the Replay’s 
network mechanism is used.
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➤ Add cookies to ActiveX WinInet navigations. Add cookies received by 
HTTP turbo-replay to ActiveX WinInet navigations.

➤ Applet Support

➤ Run Java applets. Run Java applets—for example, when encountering an 
APPLET tag or an OBJECT tag without classid.

➤ Force WinInet for Java Applets navigations. Force using WinInet for Java 
Applets navigations where currently the Replay’s network mechanism is 
used.

➤ History

➤ History support. Enables support for the window.history object for the 
test run. The options are Enabled, Disabled, and Auto. The Auto option 
(default) instructs Vusers to support the window.history object only if it 
was used in the first iteration. Note that by disabling this option, you 
improve performance.

➤ Maximum history size. The maximum number of steps to keep in the 
history list (default is 100 steps).

➤ Navigator Properties

➤ navigator.browserLanguage. The browser language set in the navigator 
DOM object’s browserLanguage property. The default is the recorded 
value. Scripts created with older recording engines, use en-us by default.

➤ navigator.systemLanguage. The system language set in the navigator 
DOM object’s systemLanguage property. The default is the recorded 
value. Scripts created with older recording engines, use en-us by default.

➤ navigator.userLanguage. The user language set in the navigator DOM 
object’s userLanguage property. The default is the recorded value. Scripts 
created with older recording engines, use en-us by default.

➤ Memory Management

➤ Default block size for DOM memory allocations. Sets the default block 
size for DOM memory allocations. If the value is too small, it may result 
in extra calls to malloc, slowing the execution times. Too large a block 
size, may result in an unnecessarily big footprint (default is 16384 bytes).

➤ JavaScript Runtime memory size (KB). Specifies the size of the JavaScript 
runtime memory in kilobytes (default is 256 KB). 
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➤ JavaScript Stack memory size (KB). Specifies the size of the JavaScript 
stack memory in kilobytes (default is 32 KB). 

Filtering Web Sites

You can specify the Web sites from which Vusers should download resources 
during replay. You can indicate either the sites to exclude or the sites to 
include. You control the allowed or disallowed sources, by specifying a URL, 
host name, or host suffix name. 

A URL is the complete URL address of a Web site, beginning with http:// or 
https://. Host is the name of the host machine with its domain, such as 
www.hp.com. 

Host suffix is the common suffix for several host names, such as hp.com. 
This is useful where you have several Web sites on a common domain.
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If you specify the sites to exclude, VuGen downloads resources from all Web 
sites except for those specified in the list. If you specify the sites to include, 
VuGen filters out resources from all Web sites except for those in the Include 
list.

To create a list of filtered Web sites:

 1 Click the Internet Protocol:Download Filters node.

 2 Select the desired option: Include only addresses in list or Exclude addresses 
in list.
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 3 Add entries to the list. To add an entry, click Add. The Add filter dialog box 
opens. 

Choose a filter type: URL, Host, or Host Suffix, and enter the filter data, such 
as a URL. When entering a URL, make sure to enter a complete URL 
beginning with http:// or https://. Click OK.

 4 To edit an entry, select it and click Edit.

 5 To delete and entry, select it and click Remove. To delete all entries, click 
Remove All.

Obtaining Debug Information

When you run a Vuser script, the execution information is displayed in the 
Output window or log file. You control the amount of information sent to 
the Output window and log files, using the Log node of the General run-
time settings. For more information, see “Configuring the Log Run-Time 
Settings” in Volume I-Using VuGen.

Debug information includes:

➤ log information

➤ transaction failures

➤ the connection status with the gateway—connecting, disconnecting, and 
redirecting. (WAP only)
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To obtain more information for debugging, edit the default.cfg file. Locate 
the WEB section and set the LogFileWrite flag to 1. The resulting trace file 
documents all events in the execution of the script. 

When performing load testing, make sure to clear the LogFileWrite flag to 
prevent the Vusers from wasting resources by creating a large trace file.

Performing HTML Compression

Browsers that support HTTP 1.1 can decompress HTML files. The server 
compresses the files for transport, substantially reducing the bandwidth 
required for the data transfer. You can enable compression automatically or 
manually.

To automatically enable compression in VuGen, use the Internet Protocol > 
Preferences node of the Run-Time settings. Click Options to open the 
Advanced Options and enable the Accept Server-Side compression option. 
Note that this option is enabled by default. For more information, see 
“Additional Options for Internet Preferences” on page 627.

To manually add compression, enter the following function at the 
beginning of the script:

web_add_auto_header("Accept-Encoding", "gzip");

To verify that the server sent compressed data, search for the string 
Content -Encoding: gzip in the section of the server’s responses of the 
Execution log. The log also shows the data size before and after 
decompression. 

Compression has a greater effect on large data transfers—the larger the data, 
the greater effect the compression will have. When working with larger data, 
you can also increase the network buffer size (see the Network Buffer Size 
option) to get the data in single chunks.
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Checking Web Page Content

After you record a Web Vuser script, you can configure run-time settings to 
check the page content.

This chapter includes:

 ➤  About Checking Web Page Content on page 637

 ➤  Setting the ContentCheck Run-Time Settings on page 638

The following information only applies to Web Vuser types.

About Checking Web Page Content

VuGen’s Content Check mechanism allows you to check the contents of a 
page for a specific string. This is useful for detecting non-standard errors. In 
normal operations, when your application server fails, the browser displays 
a generic HTTP error page indicating the nature of the error. The standard 
error pages are recognized by VuGen and treated as errors, causing the script 
to fail. Some application servers, however, issue their own error pages that 
are not detected by VuGen as error pages. The page is sent by the server and 
it contains a formatted text string, stating that an error occurred.

For example, suppose that your application issues a custom page when an 
error occurs, containing the text ASP Error. You instruct VuGen to look for 
this text on all returned pages. When VuGen detects this string, it fails the 
replay. Note that VuGen searches the body of the pages—not the headers.
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Setting the ContentCheck Run-Time Settings

You use the Internet Protocol:ContentCheck Run-Time setting to specify the 
content for which you want to search. You can define content for several 
applications with multiple rules. The following sections discuss:

➤ Understanding Content Rules

➤ Defining ContentCheck Rules

Understanding Content Rules
You use the ContentCheck run-time options to check the contents of a page 
for a specific string. This is useful for detecting non-standard errors. In 
normal operations, when your application server fails, the browser displays 
a generic HTTP error page indicating the nature of the error. The standard 
error pages are recognized by VuGen and treated as errors, causing the script 
to fail. Some application servers, however, issue their own error pages that 
are not detected by VuGen as error pages. The page is sent by the server and 
it contains a formatted text string, stating that an error occurred.
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For example, suppose that your application issues a custom page when an 
error occurs, containing the text ASP Error. You instruct VuGen to look for 
this text on all returned pages. When VuGen detects this string, it fails the 
replay. Note that VuGen searches the body of the pages—not the headers.

➤ Enable ContentCheck during replay. Enable content checking during replay 
(enabled by default). Note that even after you define applications, you can 
disable it for a specific test run, by disabling this option. 

Rule Information

This right pane contains the matching criteria for the text you want to find. 
You can specify either the actual text or a prefix and suffix of the text. 

➤ Search for Text. The text of the string for which you want to search. 

➤ Search by Prefix and Suffix. The prefix and suffix of the string for which you 
want to search. 

➤ Match case. Perform a case sensitive search. 

➤ Search JavaScript alert box text. Only search for text within JavaScript alert 
boxes (Web (Click and Script), PeopleSoft Enterprise, and Oracle Web 
Applications 11i Vusers only).

Adding and Removing Applications and Rules

➤ New Application. Automatically adds a new application to the list of 
applications in the left pane. The default name is Application_index, 
beginning with Application_1. After you create a new application, click New 
Rule to add a rule to this application. To modify the name of an application, 
double-click on it. 

➤ New Rule. Displays the rule criteria in the right pane, allowing you to enter 
a new rule for the currently selected application. The rules are stored with 
the script in standard xml files. You can export your rule files and share 
them with other users or import them to other machines. 

➤ Delete. Deletes the selected rule or application.
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Importing and Exporting Rules

➤ Import/Export. Imports or exports a rule file. The rule file with an xml 
extension, stores the applications and rules. You can export the file to use 
on other machines. You can also import other rule files. If you import a rule 
and the selected rule conflicts with an existing rule, VuGen issues a warning 
indicating that it is a Conflicting Rule. You can then choose to merge the 
rules you created on a former script with the one you are importing or 
overwrite the current rules. When you click Export, VuGen opens the 
Choose Application to Export dialog box.

Setting Rules as Default

➤ Set as Default. There are three types of rules for Content Checks: 
Installation, Default, and per script. Installation rules are provided 
automatically during installation of the product. Default rules, apply to all 
scripts executed on your machine. The per script rules are the ones defined 
for the current script. When you modify or add rules, these changes only 
apply to the current script. To instruct VuGen to add a rule to the list of 
Default rules so that it will apply to all scripts on that machine, click Set as 
Default.

When working on multiple scripts, or when performing a product upgrade, 
a conflict may arise between the default rules and the script rules. VuGen 
asks you if you want to merge the rules. When you merge the rules 
(recommended), the rule is added to the list of rules for the application.

This action only effects applications that are enabled in the Application list 
(the left pane). If no applications were marked as Enabled in the current 
script, no application will be marked as Enabled in the Defaults file. Click 
Yes to overwrite the Defaults file. Click No to cancel the operation and 
retain the original Defaults file.

The rules are stored in standard xml files. You can export your rule files and 
share them with other users or import them to other machines. 
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When you click Set as Defaults (and confirm the overwriting), VuGen 
performs the following actions:

 1 Marks all applications in the Defaults File as Disabled.

 2 For applications marked as Enabled in the current script, it performs a merge 
or copy, depending on whether the application exists. If the application 
exists, it merges the rules of the current script with those of the Defaults file. 
If the application did not exist in the Defaults file, then VuGen just copies 
the rules to the Defaults file. 

 3 Marks the applications that were enabled in the script, as Enabled in the 
Defaults file. If no application is marked as Enabled in the current script, no 
application will be marked as Enabled in the Defaults file.

Use Defaults

Imports rules from the Defaults file. When you click this button, VuGen 
opens a dialog box with a list of the applications and their default settings. 
You can choose to import these rules or modify them. If this conflicts with 
one of the existing rules, VuGen issues a warning indicating that it is a 
Conflicting Rule. You can also merge the rules defined in the Defaults file 
with the ones currently defined.

To use the default settings for all of your applications, click Use Defaults 
which imports the definitions from the Defaults file. It opens a dialog box 
with a list of the applications and their default settings. You can choose to 
import these definitions or modify them. If this conflicts with one of the 
rules, VuGen issues a warning indicating that it is a Conflicting Rule. You 
can merge or overwrite the rules defined in the Defaults file with the active 
ones.

Defining ContentCheck Rules
You use the Internet Protocol:ContentCheck node in the Run-Time Setting 
tree, to define the rules for checking Web page content.

To define a ContentCheck rule:

 1 Open the Run-Time settings and select the Internet Protocol:ContentCheck 
node.

 2 Select the Enable ContentCheck during replay option.
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 3 Click New Application to add a new entry to the list of applications whose 
content to check. 

 4 Click New Rule to add rules for existing applications. Each application 
server may have one or more rules. Enable or disable the relevant rules by 
clearing or selecting the check boxes adjacent to the rule in the left pane.

 5 To search for the actual text string, select Search for Text and specify the text 
for which you want to search. It is recommended that you be as specific as 
possible. For example, do not use the term Error, rather ASP Error or text 
specific to the application. 

 6 To search for the text preceding and following your string, select Search by 
Prefix and specify the prefix and suffix. 

 7 To indicate a case sensitive search, select the Match case check box. 

 8 To set a rule as a default, indicating that it should apply to all scripts on that 
machine, select the rule or application and click Set as Default.

 9 To export the rule file click Export and specify a save location.

 10 To import a rule file, click Import and locate the file.

 11 To remove an application or rule, select it and click Delete.

 12 To use the default settings for all of your applications, click Use Defaults. A 
dialog box opens with a list of the applications and their default settings. 
You can choose to overwrite or merge the rules if there are conflicts.
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Verifying Web Pages Under Load

You can add Web checks to your Web Vuser scripts to determine whether or 
not the correct Web pages are returned by the server when you run the 
Vuser script.

This chapter includes:

 ➤  About Verification Under Load on page 643

 ➤  Adding a Text Check on page 646

 ➤  Understanding Text Check Functions on page 649

 ➤  Adding an Image Check on page 654

 ➤  Defining Additional Properties on page 657

The following information only applies to Web Vuser scripts.

About Verification Under Load

VuGen enables you to add Web checks to your Web Vuser scripts. A Web 
check verifies the presence of a specific object on a Web page. The object can 
be a text string or an image. 

Web checks enable you to determine whether or not your Web site is 
functioning correctly while it is being accessed by many Vusers—that is, 
does the server return the correct Web pages? This is particularly important 
while your site is under the load of many users, when the server is more 
likely to return incorrect pages.
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For example, assume that your Web site displays information on the 
temperatures in major cities around the world. You use VuGen to create a 
Vuser script that accesses your Web site.

The Vuser accesses the site and executes a text check on this Web page. For 
example, if the word Temperature appears on the page, the check passes. If 
Temperature does not appear because, for example, the correct page was not 
returned by the server, the check fails. Note that the text check step appears 
before the URL step. This is because VuGen registers, or prepares in advance, 
the search information relevant for the next step. When you run the Vuser 
script, VuGen conducts the check on the Web page that follows.

Although the server may display the correct page when you record the script 
and when a single Vuser executes the script, it is possible that the correct 
page will not be returned when the server is under the load of many Vusers. 
The server may be overloaded and may therefore return meaningless or 
incorrect HTML code. Alternatively, in some instances when a server is 
overloaded, the server may return a 500 Server Error page. In both of these 
cases, you can insert a check to determine whether or not the correct page is 
returned by the server.

Note: Web checks increase the work of a Vuser, and therefore you may need 
to run fewer Vusers per load generator. You should use Web checks only 
where experience has shown that the server sometimes returns an incorrect 
page.

You can define Web checks during or after recording a Vuser script. It is 
generally more convenient to define checks while recording—when the Web 
page that you want to check is visible. 
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VuGen uses several different Web check icons, each one representing a 
different check type:

This chapter describes how to use VuGen to add Web checks in the tree 
view. For information about adding checks to the script in the text-based 
script view, see the Online Function Reference (Help > Function Reference).

Web Check Icon Description

Text A text check, searching for a specific string in the next action 
function (web_reg_find) or in the entire business process 
(web_global_verification) step.

Text A text check, searching for a specific string in the next action 
function using the web_find step. For more information, see 
“Understanding Text Check Functions” on page 649.

Image An image check, searching for a specific image on a Web 
page. For more information, see “Understanding Text Check 
Functions” on page 649.
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Adding a Text Check 

VuGen allows you to add a check that searches for a text string on a Web 
page. You can add the text check either during or after recording.

When you create a text check, you define the name of the check, the scope 
of the check, the text you want to check for, and the search conditions.

To add a text check during recording:

 1 If the VuGen main window or application is minimized, restore it. In the 
application or Web browser window, select the desired text. 

 2 Click the Insert Text check button on the recording toolbar. VuGen adds a 
web_reg_find function to the script. 

To add a text check after recording:

 1 Go to the snapshot of the step whose text you want to check.

 2 In the snapshot, select the text you want to verify.

 3 Choose Add a Text Check (web_reg_find) from the right-click menu. The 
Find Text properties dialog box opens.
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Note: For certain protocols, VuGen issues a message indicating that you 
should add text checks from the Server Response tab—not from the 
snapshot. Click the Server Response tab and select the HTML Document tab. 
Expand the body node and then continue as described below.

The following attributes are available for web_reg_find:

➤ Search for specific Text. The text string to search for. This attribute must 
be a non-empty, null-terminated character string. 
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➤ Search for Text by start and end of string

➤ Start string. The prefix of the text string for which you are searching. 
To ignore the case, add "/IC" after the boundary. Specify "/BIN" after 
the text to specify binary data. Use the format "TextPfx=string".

➤ End string. The suffix of the text string for which you are searching. To 
ignore the case, add "/IC" after the boundary. Specify "/BIN" after the 
text to specify binary data. Use the format "TextSfx=string".

After specifying a search method—specific text or a beginning or end string, 
you can specify the search options:

➤ To perform a case -sensitive search, select Match case. To indicate binary 
data, select Binary data. To indicate any digit as a match, use a hash (#) in 
the text string and select Use # for any digit.

➤ Use ^ as a wildcard for all/lowercase/uppercase alphanumerical 
characters. Allows a wildcard search for alphanumerical characters—
either all, uppercase, or lowercase characters. You specify a wildcard with 
the ^ character.

➤ Search in. Where to search for the text. The available values are Headers, 
Body, or All. The default is Body.

➤ Save count. The number of matches that were found. To use this 
attribute, select Save count and specify a parameter name in which to 
store the number of matches. The variable will be a null-terminated 
ASCII value.

➤ Fail if. The handling method when the string is not found. The available 
values are Found and Not Found. Found indicates that a failure occurs 
when the text is found (e.g. "Error"). Not Found indicates that a failure 
occurs when the text is not found.

To view or modify the properties of the text check after it has been created, 
click the Tree View tab and double-click on the new Services: Reg Find step. 
In the Find Text dialog box, you can view or modify all of the step’s 
attributes.
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Understanding Text Check Functions

When you add a text check, VuGen adds a web_reg_find function to your 
script. This function registers a search for a text string on an HTML page. 
Registration means that it does not execute the search immediately—it 
performs the check only after executing the next Action function, such as 
web_url. Note that if you are working with a concurrent functions group, 
the web_reg_find function is only executed at the end of the grouping. 

In the following example, web_reg_find function searches for the text 
string "Welcome". If the string is not found, the next action function fails 
and the script execution stops. 

web_reg_find("Text=Welcome", "Fail=Found", LAST);
web_url("Step", "URL=...", LAST);

In addition to the web_reg_find function, you can use other functions to 
search for text within an HTML page:

Several additional functions can be used for searching for text:

➤ web_find

➤ web_global_verification

The web_find function, primarily used for backward compatibility, differs 
from the web_reg_find function in that web_find is limited to an HTML-
based script (see Recording Options > Recording tab). It also has less 
attributes such as instance, allowing you to determine the number of times 
the text appeared. When performing a standard text search, web_reg_find is 
the preferred function.

The web_global_verification function allows you to search the data of an 
entire business process. In contrast to web_reg_find, which only applies to 
the next Action function, this function applies to all subsequent Action 
functions such web_url. By default, the scope of the search is 
NORESOURCE, searching only the HTML body, excluding headers and 
resources. 

The web_global_verification function is ideal for detecting application 
level errors that are not included the HTTP status codes. This function is not 
limited to an HTML-Based script (see Recording Options > Recording tab).
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To add additional functions to your script:

 1 In the VuGen main window, click at the point where you want to add the 
text check. Choose Insert > New Step.
 

 2 For the web_find functions, expand the Web Checks node and select Text 
Check. For the web_global_verification function, expand the Services node 
and choose the function name. The Properties dialog box opens. 

 3 Set the properties for these functions (see description below).

 4 Click OK. VuGen inserts a new function into the script.
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Setting web_find Properties

You can set the following properties for the web_find function:

➤ Search for. The string you want to verify. An ABC icon indicates that the 
string in the Search for box has not been assigned a parameter. For details 
on assigning parameters, see “Creating Parameters” in Volume I-Using VuGen.

➤ Right of / Left of. The position of the search string relative to adjacent text. 
Type the text in the appropriate field. For example, to verify that the string 
support@hp.com appears to the right of the word 
e-mail:, select Right of and then type e-mail: in the Right of box.

➤ Step Name. The name of the text check. Click the General tab and type a 
name for the text check in the box. Use a name that you can recognize and 
identify later on.
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Note: A Vuser conducts Web checks during script execution only if checks 
are enabled, and if the script runs in HTML mode. To enable checks, select 
the Enable image and text check option in the Preferences tab in the Run-
Time Settings dialog box. For details, see “Configuring Run-Time Settings” 
in Volume I-Using VuGen.

Setting web_global_verification Properties

You can set the following properties for the web_find function:

➤ Search for specific text. The string whose presence you want to verify. An 
ABC icon indicates that the string in the Search for box has not been 
assigned a parameter. For details on assigning parameters, see “Creating 
Parameters” in Volume I-Using VuGen.

➤ Search for Text by Start and End of String. The boundaries, also known as 
Start and End strings that surround the text. Select the appropriate options 
to indicate if you want to Match case or if you are searching for binary data.
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➤ Fail if. Fails the script if the condition is met. You can also indicate the 
failure condition: if the text is Found or Not found. Select the desired 
behavior in the Fail if box. 

Text Flags
When specifying search text using a registered search, web_reg_find, you 
can add flags to control the scope of the search: 

/IC to ignore the case.

/BIN to specify binary data.

/DIG to interpret the pound sign (#) as a wildcard for a single digit. The DIG 
flag does not match a literal pound sign.

/ALNUM<case> to interpret the caret sign (^) as a wildcard for a single US-
ASCII alphanumeric character. There are three syntaxes: ALNUMIC to ignore 
case, ALNUMLC to match only lower case, and ALNUMUC to match only 
upper case. The ALNUM flag does not match a literal caret. 

To use flags, you enter the attribute TEXT, followed by a forward slash and 
the flag name. For example, to search for a string ignoring the case, use 
"Text/IC=search_text'". 
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Adding an Image Check 

VuGen allows you to add a user-defined check that searches for an image on 
a Web page. The image can be identified by the ALT attribute, the SRC 
attribute, or both.

You can add user-defined image checks either during or after recording. 
After recording, you can edit any existing image checks in your script.

To add an image check:

 1 In the VuGen main window, right-click the step corresponding to the Web 
page on which you want to perform a check. Select Insert After from the 
pop-up menu. The Add Step dialog box opens.

Note: During a Web browser recording session, the VuGen main window 
may be minimized. To add an image check during recording, restore the 
VuGen main window. 

 2 Expand Web Checks in the Step Type tree. 
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 3 Select Image Check, and click OK. The Image Check Properties dialog box 
opens. Ensure that the Specification tab is visible.

 4 Select a method to identify the image:

➤ Alternative image name (ALT attribute). Identifies the image using its 
ALT attribute. Type the ALT attribute text in the text box. When you run 
the script, the Vuser searches for an image that has the specified ALT 
attribute.

➤ Image server file name (SRC attribute). Identifies the image using the 
SRC attribute. Type the SRC attribute text into the text box. When you 
run the script, the Vuser searches for an image that has the specified SRC 
attribute.

An ABC icon indicates that the ALT or SRC attribute has not been assigned a 
parameter. For details on assigning parameters, see “Creating Parameters” in 
Volume I-Using VuGen.
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Note: If you select both the ALT attribute and SRC attribute check boxes, the 
Vuser searches for an image that has both the specified ALT attribute and the 
specified SRC attribute.

 5 To name the image check, click the General tab. In the Step Name box, type 
a name for the image check. Use a name that you can recognize later on.

 6 The properties table displays additional properties that define the check.

Clear the View only the active properties check box to view active and non- 
active properties. To enable a property, click the cell to the left of the 
property name. Assign the property a value in the Value column.

For details on assigning property values, see “Defining Additional 
Properties” on page 657.
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 7 Click OK to accept the settings. An icon representing the new image check is 
added to the associated step in the Vuser script.
 

Defining Additional Properties 

You can specify additional properties for each Web check that you insert 
into a Vuser script. You set additional options in the properties table on the 
General tab of the check properties dialog boxes. The following is only 
relevant for web_find and web_image_check functions—not 
web_reg_find.

To set additional properties:

 1 Right-click the Web check whose properties you want to edit, and select 
Properties from the pop-up menu. The appropriate check properties dialog 
box opens. Ensure that the General tab is visible.

 2 Clear the View only the active properties check box to view all the available 
properties.

 3 To enable a property, click the cell to the left of the property name. A red 
check mark appears beside the property.

 4 Assign the property a value in the Value column:

➤ Frame. Type the name of the frame where the check object is located.

➤ AssignToParam. Select YES to enable assigning to a parameter. Select NO 
to disable this capability. The default value is NO.

➤ MatchCase. Select YES to conduct a case-sensitive search. Select NO to 
conduct a non case-sensitive search. The default value is NO.
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➤ OnFailure. Select Abort to abort the entire Vuser script if the check fails. 
VuGen aborts the Vuser script regardless of the error-handling method 
that has been set in the run-time settings. Select Continue to have the 
error-handling method defined in the run-time settings determine 
whether or not the script is aborted if the check fails. 

The default value is Continue. For details on defining the error handling 
method, see “Configuring Run-Time Settings” in Volume I-Using VuGen.

➤ Expect. Select NotFound to indicate that the check is successful if the 
Vuser does not find the specified check object. Select Found to indicate 
that the check is successful if the Vuser finds the specified check object. 
The default value is Found.

➤ Repeat. Select YES to search for multiple occurrences of the specified 
check object. Select NO to end the check as soon as one occurrence of the 
specified check object is found. The Vuser script continues with the next 
step. This option is useful when searching through a Web page that may 
have multiple occurrences of the check object. The default value is YES. 

➤ Report. Select Always to always view a detailed description of the check 
results in the Execution Log. Select Failure to view detailed check results 
only when the check fails. Select Success to view detailed check results 
only when the check succeeds. The default value is Always.

An ABC icon indicates that the property value has not been assigned a 
parameter. Click the icon to assign a parameter. For more information, see 
“Creating Parameters” in Volume I-Using VuGen.
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Modifying Web and Wireless Vuser 
Scripts

After recording a Web or Wireless Vuser script, you use VuGen to modify the 
recorded script. You can add new steps, and edit, rename, and delete 
existing steps.

This chapter includes:

 ➤  About Modifying Web and Wireless Vuser Scripts on page 660

 ➤  Adding a Step to a Vuser Script on page 661

 ➤  Deleting Steps from a Vuser Script on page 662

 ➤  Modifying Action Steps on page 663

 ➤  Modifying Control Steps on page 680

 ➤  Modifying Service Steps on page 683

 ➤  Modifying Web Checks (Web only) on page 684

The following information applies to Web and Wireless Vuser scripts.
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About Modifying Web and Wireless Vuser Scripts

After recording a browser or toolkit session, you can modify the recorded 
script in VuGen by editing a step’s properties or adding and deleting steps.

You can do the modifications either in the icon-based tree view or in the 
text-based script view. For details on the two viewing modes, see Chapter 34, 
“Creating Web Vuser Scripts.” 

This chapter describes how to use VuGen to modify the script in the tree 
view. For information about modifying the script in the text-based script 
view, refer to the Online Function Reference (Help > Function Reference).

Adding Binary Data
To include binary coded data in the body of an HTTP request, use the 
following format: 

\x[char1][char2] 

This represents the hexadecimal value that is represented by [char1][char2]. 

For example, \x24 is 16*2+4=36, is a $ sign, and \x2B is a + sign. 

Do not use single-character hexadecimal sequences. For example, \x2 is not a 
valid sequence but \x02 is. 
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Adding a Step to a Vuser Script 

In addition to the steps that VuGen records during the browser or toolkit 
recording session, you can add steps to a recorded script.

To add a step to a Vuser script:

 1 In the tree view of the script, select the step before or after which you want 
to add the new step.

 2 Select Insert > New Step to insert a step after the selected step, or select 
Insert After or Insert Before from the right-click menu. The Add Step dialog 
box opens.
 

 3 Select the type of step you want to add from the Step Type tree or from the 
Find Function list.

 4 Click OK. An additional dialog box opens, prompting for information about 
the step to add. This dialog box varies, depending on the type of step that 
you are adding.
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For details on using these dialog boxes, see the appropriate section, as listed 
below:

Deleting Steps from a Vuser Script

After recording a browser or toolkit session, you can use VuGen to delete 
any step from the Vuser script.

To delete a step from a Vuser script:

 1 In the tree view of the Vuser script, right-click the step you want to delete, 
and select Delete from the pop-up menu.

 2 Click OK to confirm that you want to delete the step.

The step is deleted from the script.

To add this… See…

Vuser API function “Enhancing Vuser Scripts” in Volume I-Using VuGen 

Service step “Modifying Service Steps” on page 683

Web Check “Modifying Web Checks (Web only)” on page 684

Transaction “Modifying a Transaction” on page 680

Rendezvous point “Modifying a Rendezvous Point” on page 681

Think time step “Modifying Think Time” on page 682

URL step “Modifying a URL Step” on page 663

Link step “Modifying a Hypertext Link Step (Web only)” on 
page 665

Image step “Modifying an Image Step (Web only)” on page 667

Submit form step “Modifying a Submit Form Step (Web only)” on 
page 669

Submit data step “Modifying a Submit Data Step” on page 673

Custom request step “Modifying a Custom Request Step” on page 677

User-defined step “Enhancing Vuser Scripts” in Volume I-Using VuGen 
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Modifying Action Steps 

An action step represents a user action during recording, that is, a jump to a 
new URL or a change in the Web context.

Action steps, represented in the tree view of the Vuser script by Action icons, 
are added to your script automatically during recording. After recording, 
you can modify the recorded action steps.

This section includes:

➤ Modifying a URL Step

➤ Modifying a Hypertext Link Step (Web only)

➤ Modifying an Image Step (Web only)

➤ Modifying a Submit Form Step (Web only)

➤ Modifying a Submit Data Step

➤ Modifying a Custom Request Step

Modifying a URL Step 
A URL step is added to the Vuser script when you type in a URL or use a 
bookmark to access a specific Web page.

The properties that you can modify are the name of the step, the address of 
the URL, target frame, and record mode. 

By default, VuGen runs the URL step, based on the mode in which it was 
recorded: HTML, or HTTP (without resources). For information on the 
recording modes, see “Selecting a Recording Level” on page 598. 
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Setting the Replay Mode

In the URL step’s Properties dialog box, you can modify the mode settings to 
instruct Vusers to execute the script in a mode other than the recorded 
mode. To customize the replay mode, select the Record mode check box. 
The available replay modes are:

➤ HTML. Automatically download all resources and images and store the 
required HTTP information for the steps that follow. This is ideal for script 
with Web links. 

➤ HTTP. Do not download any resources for this step during replay. Download 
only resources that are explicitly represented by functions.

You can also indicate that a certain step should not be counted as a resource. 
For example, if you have a step that represents a specific image that you 
want to skip, you can instruct VuGen to exclude that resource type. For 
more information, see the “Resource Handling” on page 608.

To modify the properties of a URL step:

 1 In the tree view of the Vuser script, select the URL step you want to edit. 
URL steps are shown using the URL icon.

 2 Click the Properties button on the VuGen toolbar. The URL Step Properties 
dialog box opens.
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 3 To change the step name, type a new name in the Step name box. The 
default name during recording is the last part of the URL.

 4 In the URL box, type the Web address (URL) of the Web page that is accessed 
by the URL step. An ABC icon indicates that the URL has not been assigned 
a parameter. For details on assigning parameters, see “Creating Parameters” 
in Volume I-Using VuGen.

 5 In the Target frame list, select one of the following values: 

➤ SELF. Replaces the last (changed) frame.

➤ PARENT. Replaces the parent of the last (changed) frame.

➤ TOP. Replaces the whole page.

➤ BLANK. Opens a new window.

 6 To customize the replay mode, select the Record mode check box.

Choose the desired mode: HTML or HTTP.

 7 To exclude an item from being downloaded as a resource, clear the Resource 
check box. 

 8 Click OK to close the URL Step Properties dialog box. 

Modifying a Hypertext Link Step (Web only)
A hypertext link step is added to the Web Vuser script when you click a 
hypertext link. This step is only recorded when you select the option to 
record in HTML based script mode. For more information, see Chapter 39, 
“Setting Recording Options for Web Vusers.”

The properties that you can modify are the name of the step, how the 
hypertext link is identified, and where it is located.
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To modify the properties of a hypertext link step:

 1 In the tree view of the Vuser script, select the hypertext link step you want 
to edit. Hypertext link steps are shown using the Hypertext Link icon.

 2 Select Properties from the right-click menu. The Link Step Properties dialog 
box opens.

 3 To change the step name, type a new name in the Step Name box. The 
default name during recording is the text string of the hypertext link.

 4 The properties table displays the properties that identify the link.

Clear the View only the active properties check box to view active and non-
active properties. To enable a property, click the cell to the left of the 
property name. Assign the property a value in the Value column:

➤ Text. The exact string of the hypertext link.

➤ Frame. The name of the frame where the link is located.

➤ TargetFrame. The target frame:

➤ TOP. Replaces the whole page.
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➤ BLANK. Opens a new window.

➤ PARENT. Replaces the parent of the last (changed) frame.

➤ SELF. Replaces the last (changed) frame.

➤ Ordinal. a number that uniquely identifies the link when all the other 
property attributes are identical to one or more other links on the Web 
page. Refer to the Online Function Reference for details.

An ABC icon indicates that the link property value has not been assigned a 
parameter. For details on assigning parameters, see “Creating Parameters” in 
Volume I-Using VuGen.

 5 Click OK to close the Link Step Properties dialog box. 

Modifying an Image Step (Web only)
An image step is added to the Vuser script when you click a hypergraphic 
link. This step is only recorded when you select the option to record in 
HTML (context-sensitive) mode. For more information, see Chapter 39, 
“Setting Recording Options for Web Vusers.”

The properties that you can modify are the name of the step, how the 
hypergraphic link is identified, and where it is located.
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To modify the properties of an image step:

 1 In the tree view of the Vuser script, select the image step you want to edit. 
Image steps are shown using the Image icon.

 2 Select Properties from the right-click menu. The Image Step Properties 
dialog box opens.
 

 3 To change the step name, type a new name in the Step Name box. The 
default name during recording is the image’s ALT attribute. If the image does 
not have an ALT attribute, then the last part of the SRC attribute is used as 
the default name.

 4 The properties table displays the properties that identify the link.

Clear the View only the active properties check box to view active and non-
active properties. To enable a property, click the cell to the left of the 
property name. Assign the property a value in the Value column:

➤ ALT. The ALT attribute of the image.
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➤ SRC. The SRC attribute of the image.

➤ MapName. The name of the map related to the image. Applies to client-
side image maps only.

➤ AreaAlt. The ALT attribute of the area to click. Applies to client-side 
image maps only.

➤ AreaOrdinal. The serial number of the area to click. Applies to client-side 
image maps only.

➤ Frame. The name of the frame where the image is located.

➤ TargetFrame.The target frame:

➤ _TOP. Replaces the whole page.

➤ _BLANK. Opens a new window.

➤ _PARENT. Replaces the parent of the last (changed) frame.

➤ _SELF. Replaces the last (changed) frame.

➤ Ordinal. a number that uniquely identifies the image when all other 
property attributes are identical to one or more other images on the Web 
page. Refer to the Online Function Reference for details.

➤ XCoord, YCoord. The coordinates of the mouse-click on the image.

An ABC icon indicates that the link property value has not been assigned a 
parameter. For details on assigning parameters, see “Creating Parameters” in 
Volume I-Using VuGen.

 5 Click OK to close the Image Step Properties dialog box. 

Modifying a Submit Form Step (Web only)
A submit form step is added to the Vuser script when you submit a form. 
This step is only recorded when you select the option to record in HTML 
(context-sensitive) mode. For more information, see Chapter 39, “Setting 
Recording Options for Web Vusers.”

The properties that you can modify are the name of the step, the form 
location, how the form submission is identified, the form data, and the 
resources for the step.
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To modify the properties of a submit form step:

 1 In the tree view of the Vuser script, select the submit form step you want to 
edit. Submit form steps are shown using the Submit Form icon.

 2 Select Properties from the right-click menu. The Submit Form Step 
Properties dialog box opens. Click the Data tab.

➤ The Name column lists all the data arguments on the form. 

➤ The Value column displays the corresponding value input for a data 
argument.

➤ The type column contains an icon. Initially, all values are constants or 
non-parameterized values and have an ABC icon. If you assign a 
parameter to the data value, as described in “Creating Parameters” in 
Volume I-Using VuGen, the ABC icon changes to a table icon.

 3 To edit a data argument, double-click on it to activate the cursor within the 
cell and type the new value in the editable box.
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 4 To add a new data argument to the form submission, click Add. The Add 
Data dialog box opens. 

 5 Type a Name and Value for the data argument, and click OK.

 6 To delete an argument, select it and click Delete.

 7 To change the name of the submit form step, click the General tab.

 8 To change the step name, type a new name in the Step Name box. The 
default name during recording is the name of the executable program used 
to process the form.
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 9 The properties table displays the properties that identify the form 
submission. 

Clear the View only the active properties option to view active and non- 
active properties. To enable a property, click the cell to the left of the 
property name. Assign the property a value in the Value column:

➤ Action. The address to be used to carry out the action of the form.

➤ Frame. The name of the frame where the form submission is located.

➤ TargetFrame. The target frame:

➤ _TOP. Replaces the whole page.

➤ _BLANK. Opens a new window.

➤ _PARENT. Replaces the parent of the last (changed) frame.

➤ _SELF. Replaces the last (changed) frame.

➤ Ordinal. a number that uniquely identifies the form when all other 
property attributes are identical to one or more other forms on the same 
Web page. Refer to the Online Function Reference for details (Help > 
Function Reference).

An ABC icon indicates that the submit form step property value has not 
been assigned a parameter. For details on assigning parameters, see 
“Creating Parameters” in Volume I-Using VuGen.
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 10 To specify resources for the step, click the Resources tab. Click Add to add a 
resource’s URL and Referer page.

 11 Click OK to close the Submit Form Step Properties dialog box. 

Modifying a Submit Data Step 
A submit data step represents the submission of a form of data to your Web 
site for processing. This is different from a Submit Form step because you do 
not need to have a form context to execute this request.

The properties that you can modify are the name of the step, the method, 
the action, the target frame, and the data items on the form.

To modify the properties of a submit data step:

 1 In the tree view of the Vuser script, select the submit data step you want to 
edit. Submit data steps are represented by the Submit Data icon.
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 2 Select Properties from the right-click menu. The Submit Data Step Properties 
dialog box opens. Click the Data tab. 

➤ The Name column lists all the data arguments on the form. This includes 
all hidden fields.

➤ The Value column displays the corresponding value input for a data 
argument.

➤ The type column contains an icon. Initially, all values are constants or 
non-parameterized values and have an ABC icon. If you assign a 
parameter to the data value, as described in “Creating Parameters” in 
Volume I-Using VuGen, the ABC icon changes to a table icon.

 3 To edit a data argument, double-click on it to activate the cursor within the 
cell. Then type the new value.
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 4 To add new data, click Add. The Add Data dialog box opens.

 5 Type a Name and Value for the data argument, and click OK.

 6 To delete an argument, select it and click Delete.

 7 To change the name of the submit data step, click the General tab.

 8 To change the step name, type a new name in the Step name box.

 9 Under Method, click POST or GET. The default method is POST.
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 10 In the Action box, type the address to be used to carry out the action of the 
data submission. An ABC icon indicates that the action has not been 
assigned a parameter. For details on assigning parameters, see “Creating 
Parameters” in Volume I-Using VuGen.

 11 Select a Target frame from the list:

➤ TOP. Replaces the whole page.

➤ BLANK. Opens a new window.

➤ PARENT. Replaces the parent of the last (changed) frame.

➤ SELF. Replaces the last (changed) frame.

 12 To customize the replay mode, select the Record mode option. Choose the 
desired mode: HTML, or HTTP. For more information, see “Setting the 
Replay Mode” on page 664.

 13 To specify an encoding type, such as multipart/www-urlencoded, select the 
Encoding type check box and specify the encoding method. 

 14 To encode the "@" in the URL, select Encode "at" sign as ASCII.

 15 Click OK to close the Submit Data Step Properties dialog box.
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 16 To specify resources for the step, click the Resources tab. Click Add to add a 
resource’s URL and Referer page.

Modifying a Custom Request Step 
A custom request represents a custom HTTP request for a URL, with any 
method supported by HTTP. A custom request step is contextless.

The properties that you can modify are the name of the step, method, URL, 
target frame, and body.

VuGen has a feature that lets you convert a custom request body string to C 
format. For example, if you copy an XML tree or a large amount of data into 
the Body area of the custom request, you can convert the strings to C format 
in order that it may be incorporated into the current function. VuGen 
inserts the necessary escape sequence characters and removes the line breaks 
in the string.

To modify the properties of a custom request step:

 1 In the tree view of the Vuser script, select the custom request step you want 
to edit. Custom request steps are shown using the Custom Request icon.
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 2 Select Properties from the right-click menu. The Custom Request Properties 
dialog box opens.

 3 To change the step name, type a new name in the Step name box. The 
default name during recording is the last part of the URL.

 4 In the Method box, type any method supported by HTTP. For example, GET, 
POST or HEAD.

 5 In the URL box, type the URL being requested.

 6 Select a Target frame from the list:

➤ TOP. Replaces the whole page.

➤ BLANK. Opens a new window.

➤ PARENT. Replaces the parent of the last (changed) frame.

➤ SELF. Replaces the last (changed) frame.
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 7 In the Body attribute box, type the body of the request or paste in the 
desired text. If you select the Binary data check box, the text is treated as 
binary and not as ASCII. For details on using binary data, refer to the Online 
Function Reference (Help > Function Reference).

VuGen replaces a Body attribute whose length exceeds 100K, with a variable 
in the Body variable name box. The variable is defined in the 
lrw_custom_body.h file located in the include folder.

 8 For strings that you pasted into the Body box, select the text and choose 
Convert to C format from the right-click menu.

 9 To customize the replay mode, select the Record mode option. Choose the 
desired mode: HTML or HTTP. For more information, see “Setting the Replay 
Mode” on page 664.

 10 To exclude an item from being downloaded as a resource, clear the Resource 
option. 

 11 To specify an encoding type, such as multipart/www-urlencoded, select 
Encoding type and specify the encoding method. 

 12 Click OK to close the Custom Request Properties dialog box.
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Modifying Control Steps

A control step represents a non-action step used during load testing. Control 
steps include transactions, rendezvous points, and think time.

You add control steps, represented in the tree view of the Vuser script by 
Control icons, to your script during and after recording.

This section includes:

➤ Modifying a Transaction

➤ Modifying a Rendezvous Point

➤ Modifying Think Time

Modifying a Transaction 
A transaction is a task or set of actions whose server response time you want 
to measure.

The properties that you can modify are the name of the transaction (start 
transaction and end transaction) and its status (end transaction only).

To modify a start transaction control step:

 1 In the tree view of the Vuser script, select the start transaction control step 
you want to edit. Start transaction control steps are shown using the Start 
Transaction icon.

 2 Select Properties from the right-click menu. The Start Transaction dialog 
box opens.

 3 To change the transaction name, type a new name in the Transaction Name 
box, and click OK.
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To modify an end transaction control step:

 1 In the tree view of the Vuser script, select the end transaction control step 
you want to edit. End transaction control steps are shown using the End 
Transaction icon.

 2 Select Properties from the right-click menu. The End Transaction dialog box 
opens.

 3 Select the name of the transaction you want to end from the Transaction 
Name list.

 4 Select a transaction status from the Transaction Status list:

➤ LR_PASS. Returns a "succeed" return code.

➤ LR_FAIL. Returns a "fail" return code.

➤ LR_STOP. Returns a "stop" return code.

➤ LR_AUTO. Automatically returns the detected status.

For more information, refer to the Online Function Reference (Help > Function 
Reference).

 5 Click OK to close the End Transaction dialog box.

Modifying a Rendezvous Point 
Rendezvous points enable you to synchronize Vusers to perform a task at 
exactly the same moment.

The property that you can modify is the name of the rendezvous point.

To modify a rendezvous point:

 1 In the tree view of the Vuser script, select the rendezvous point you want to 
edit. Rendezvous points are shown using the Rendezvous icon.
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 2 Select Properties from the right-click menu. The Rendezvous dialog box 
opens.

 3 To change the rendezvous name, type a new name in the Rendezvous Name 
box, and click OK.

Modifying Think Time 
Think time emulates the time that a real user waits between actions. During 
recording, VuGen automatically adds think time to the Vuser script after 
each user action—if the time between that action and the subsequent action 
exceeds a predefined threshold of about four seconds.

The property that you can modify is the think time, in seconds.

To modify the think time:

 1 In the tree view of the Vuser script, select the think time step you want to 
edit. Think time steps are shown using the Think Time icon.

 2 Select Properties from the right-click menu. The Think Time dialog box 
opens.

 3 Type a think time in the Time To Think box, and click OK.
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Note: When you run a Web Vuser script, you can instruct the Vuser to replay 
think time as recorded or ignore the recorded think time. For details, see 
“Configuring Run-Time Settings” in Volume I-Using VuGen.

Modifying Service Steps 

A service step is a function that performs customization tasks such as setting 
proxies, submitting authorization information, and issuing customized 
headers. Service steps do not make any changes to the Web site context. 

You add service steps to your script during and after recording.

To modify the properties of a service step:

 1 In the tree view of the Vuser script, select the service step you want to edit. 
Service steps are shown using the Service icon.

 2 Select Properties from the right-click menu. The appropriate service step 
properties dialog box opens. This dialog box varies, depending on the type 
of service step that you are modifying. A description of the service step is 
displayed in the title bar of the dialog box.

Note: Some service step functions have no arguments. In these cases, the 
Properties menu item is disabled.

 3 Type or select the arguments required for the service step. Refer to the Online 
Function Reference for details of each function (Help > Function Reference).

 4 Click OK to close the service step properties dialog box.
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Modifying Web Checks (Web only)

A Web check is a function that verifies the presence of a specific object on a 
Web page. The object can be a text string or an image.

You add Web checks to your script during and after recording.

To modify the properties of a Web check:

 1 In the tree view of the Vuser script, select the Web check you want to edit. 
Web checks are shown using Web Check icons.

 2 Select Properties from the right-click menu. The appropriate Web check 
properties dialog box opens. This dialog box varies, depending on the type 
of check that you are modifying.

 3 Type or select the properties required for the check. For details, see 
Chapter 42, “Verifying Web Pages Under Load.”

 4 Click OK to close the check properties dialog box.

Icon Description

Image Check 
icon

Text Check 
icon
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44
Setting Correlation Rules for Web Vuser 
Scripts

VuGen’s correlation feature allows you to link Vuser functions by using the 
results of one statement as input for another.

This chapter includes:

 ➤  About Correlating Statements on page 685

 ➤  Understanding the Correlation Methods on page 687

 ➤  Using VuGen’s Correlation Rules on page 688

 ➤  Setting Correlation Rules on page 694

 ➤  Testing Rules on page 696

 ➤  Setting the Correlation Recording Options on page 697

The following information applies to Web and PeopleSoft Enterprise Vuser 
scripts.

About Correlating Statements 

HTML pages often contain dynamic data, which is data that changes each 
time you access a site. For example, certain Web servers use links comprised 
of the current date and time.

When you record a Web Vuser script, dynamic data may be recorded into 
the script. Your script tries to present the recorded variables to the Web 
server, but they are no longer valid. The Web server rejects them and issues 
an error. These errors are not always obvious, and you may only detect them 
by carefully examining Vuser log files. 
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If you encounter an error when running your Vuser, examine the script at 
the point where the error occurred. Often, correlation will solve the problem 
by enabling you to use the results of one statement as input for another.

The dynamic data in an HTML page can be in the form of:

➤ a URL that changes each time you access the associated Web page

➤ a field (sometimes hidden) recorded during a form submission

➤ JavaScript cookies

Case 1

Suppose a Web page contains a hypertext link with text: "Buy me now!" 
When you record a script with HTTP data, the URL is recorded by VuGen as:

"http://host//cgi-bin/purchase.cgi?date=170397&ID=1234"

Since the date "170397" and ID "1234" are created dynamically during 
recording, each new browser session recreates the date and ID. When you 
run the script, the link "Buy me now!" is no longer associated with the same 
URL that was recorded—but with a new one. The Web server is therefore 
unable to retrieve the URL.
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Case 2

Consider a case where a user fills in his name and account ID into a form, 
and then submits the form. 

When the form is submitted, a unique serial number is also sent to the 
server together with the user’s data. Although this serial number is 
contained in a hidden field in the HTML code, it is recorded by VuGen into 
the script. Because the serial number changes with each browser session, 
Vusers were unable to successfully replay the recorded script.

You can use correlated statements to resolve the difficulties in both of the 
above cases. Replace the dynamic data in the recorded script with one or 
more parameters. When the script runs, it assigns values to each of the 
parameters.

Understanding the Correlation Methods

This chapter discusses automatic correlation using built-in or user-defined 
rules. To manually correlate statements, or to perform correlation for 
Wireless Vuser scripts, see “Performing Manual Correlation” on page 711. 

When recording a browser session, you should first try recording in HTML 
mode. This mode decreases the need for correlation. For more information 
about the various recording modes, see “Selecting a Recording Level” on 
page 598.

You can instruct VuGen to correlate the statements in your script either 
during or after recording. The recording-time solutions described in this 
chapter automatically correlate the statements in your script during 
recording time. You can also use VuGen’s snapshot correlation to correlate 
scripts after recording. For more information on correlating after recording, 
see Chapter 45, “Correlating Vuser Scripts After Recording.” 
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Using VuGen’s Correlation Rules

VuGen’s correlation engine allows you to automatically correlate dynamic 
data during your recording session using one of the following mechanisms: 

➤ Built-in Correlation

➤ User-Defined Rule Correlation

For additional information, see “Adding Match Criteria” on page 692 and 
“Advanced Correlation Rules” on page 692.

Built-in Correlation

The Built-in correlation detects and correlates dynamic data for supported 
application servers. Most servers have clear syntax rules, or contexts, that 
they use when creating links and referrals. 

For example, BroadVision servers create session IDs that are always placed 
between the same delimiters: ”BV_SessionID=” on the left, and ”&” on the 
right.

BV_SessionID=@@@@1303778278.0969956817@@@@&
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If you are recording a session with a supported application server, you can 
use one of the existing rules built into VuGen. An application server may 
have more than one rule. You can enable or disable a specific rule by 
selecting or clearing the check box adjacent to the rule. VuGen displays the 
rule definitions in the right pane. 

If you are recording a session on an unsupported application server whose 
context is not known, and you cannot determine any correlation rules, you 
can use VuGen’s snapshot comparison method. This method guides you 
through the correlation procedure after you finish recording. For more 
information, see Chapter 45, “Correlating Vuser Scripts After Recording.”

User-Defined Rule Correlation

If your application has unique rules and you are able to determine them 
clearly, you can define new rules using the Recording Options. 

User-defined rule correlation requires you to define correlation rules before 
you record a session. You create the correlation rules in the Recording 
Options dialog box. The rules include information such as the boundaries of 
the dynamic data you want to correlate and other specifications about the 
match such as binary, case matching, and the instance number. 
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You instruct VuGen where to search for the criteria: 

➤ All Body Text

➤ Link/Form Actions 

➤ Cookie Headers

➤ Form Field Value

➤ Insert Cookie Function

Note that by default, the maximum size of a string that you can save for a 
rule is 4096 characters. If necessary, you can modify this value by increasing 
the value of the MaxParamLen attribute in the CorrelationSettings.xml file, 
located in the Windows Installation directory.

All Body Text

The Search for Parameters in all of the Body Text option instructs the 
recorder to search the entire body—not just links, form actions or cookies. It 
searches the text for a match using the borders that you specify. 

Link/Form Actions

The Search for parameters in links and form actions method instructs 
VuGen to search within links and form type actions for the text to 
parameterize. This method is for application servers where you know the 
context rules. You define a left boundary, a right boundary, an alternate 
right boundary, and an instance (occurrence) of the left boundary within 
the current link. 

For example, suppose you want to replace any text between the second 
occurrence of the string "sessionid=" and "@" with a parameter. Specify 
sessionid= as a left boundary in the Left Boundary box, and @ as a right 
boundary in the Right Boundary box. Since you are looking for the second 
occurrence, choose second in the Instance box. 

If the right boundary is not consistent, you can specify an alternate right 
boundary in the Alternate right boundary box. It uses this value when it 
cannot uniquely determine the specified right boundary. 
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For example, suppose the Web page contains links in the following formats:

"SessionID=122@page.htm"
"Page.htm@SessionID=122&test.htm"

Specifying the right boundary alone is not sufficient, since it is not 
consistent—sometimes it is "@" and other times it is "&". In this case, you 
specify "&" as the alternate right boundary.

The left and right boundaries should uniquely identify the string. Do not 
include dynamic data in the boundaries. You can also specify End of String 
or Newline Character as a right boundary, available as options in the drop-
down menu.

Note that for this option, the left and right boundaries must appear in the 
string that appears in the script—it is not sufficient for the boundaries to be 
returned by the server. This limitation does not apply to the other action 
types.

Cookie Headers

The Search for Parameters from Cookie Header method is similar to the 
previous rule, except that the value is extracted from cookie text (exactly as 
it appears in the recording log) instead of from a link or form action.

In addition, the link/form action rule parameterizes only the part of URL 
that matches the rule boundaries. The cookie rule looks for the extracted 
value in links and action form fields and replaces it with a parameter 
automatically, without having to display the boundaries in the script.

Form Field Value

The Parameterize form field value method instructs the recorder to save the 
named form field to a parameter. It creates a parameter and places it in the 
script before the form’s action step. For this option, you need to specify the 
field name. 
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Insert Cookie Function

The Text to enter a web_reg_add_cookie function by method inserts a 
web_reg_add_cookie function if it detects a certain string in the buffer. It 
only adds the function for those cookies with the specified prefix. For this 
option, you need to specify the search text and the cookie prefix. 

Adding Match Criteria
In addition to the above rules, you can further define the type of match for 
your correlation by specifying the following items for the string: 

➤ Parameter Prefix. Uses a prefix in all automatically generated parameters 
based on this rule. Prefixes prevent you from overwriting existing user 
parameters. In addition, prefixes allow you to recognize the parameter in 
your script. For example, in Siebel-Web, one of the built-in rules searches for 
Siebel_row_id prefix. 

➤ Match Case. Matches the case when looking for boundaries.

➤ Use "#" for any digit. Replaces all digits with a hash sign. The hash signs 
serve as wildcard, allowing you to find text strings with any digit. For 
example, if you enable this option and specify HP### as the left boundary, 
HP193 and HP284 will be valid matches.

Adding Comments

You can instruct VuGen to insert descriptive comments to the correlation 
steps within your script. To enable this option, select the Add Comments to 
script option.

Advanced Correlation Rules
VuGen lets you specify the following advanced correlation rules: 

➤ Always create new parameter. Creates a new parameter for this rule even if 
the value replaced by the parameter has not changed from the previous 
instance. This option should be set if the Web server assigns a different value 
for each page. For example, NetDynamics servers may change the session ID 
from page to page to minimize fraud.
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➤ Replace with parameter only for exact matches. Replace the recorded value 
with a parameter only when the text between the boundaries exactly 
matches the found value (from the first snapshot). If there are additional 
characters either before or after the string, it will not replace the parameter. 

For example, in a form submission, VuGen recorded the characters 1234 
between the boundaries aaa and bbb, aaa1234bbb. In subsequent 
submissions of this form, VuGen only replaces the recorded value with a 
parameter if it finds the characters 1234, Name=1234. If another value is 
entered, even if it contains the first string, for example, Name=12345, 
VuGen will not replace the value with a parameter. Instead, it will use the 
value 12345.

➤ Reverse Search. Searches for the left boundary from the end of the string 
backwards. 

➤ Left boundary Instance. The number of occurrence of the left boundary 
within the string (not the body) for it to be considered a match. 

➤ Offset. The offset of a sub-string of the found value to save to the parameter. 
The default is the beginning of the matched string. Note that you must 
specify a non-negative value.

➤ Length. The length from its offset of a sub-string of the matched string to 
save to the parameter. If you disable this option, the default saves the string 
from the specified offset until the end of the match. 

➤ Alternate Right Boundary. An alternative criteria for the right boundary if 
the previously specified boundary is not found. You can specify text, End of 
String, or Newline Character.
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Setting Correlation Rules

You can add, modify, or remove rules using the Correlation Recording 
options. Note that you can also edit rules that were created automatically for 
application server environments. 

In addition to creating rules using the recording options before recording, 
you can create rules after recording. After running your script, you scan it 
for correlations (CTRL+F8). You select one of the correlation results, and 
create a rule based on its properties. For more information, see “Performing 
a Scan for Correlations” on page 707.

To define correlation rules:

 1 Click on an existing rule or click New Rule in the left pane. The Correlation 
Rules are displayed in the right pane.

 2 Select a type of action: link or form action, cookie, all body, form field, or 
web_reg_add_cookie.

 3 For the first three types, specify boundaries of the data in the Left Boundary 
and Right Boundary boxes. 
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 4 For form field type actions, specify the field name.

 5 Select the desired options: Match Case and/or Parameter Prefix. Specify a 
parameter prefix. To convert all digits to hash signs (#), select Use # for any 
digit.

 6 To set advanced rules, click Advanced in the Correlation node. The 
Advanced Correlation Properties dialog box opens.

➤ Select Always create new parameter to create a new parameter for this 
rule even if the value replaced by the parameter has not changed from 
the previous instance. 
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➤ Select Replace with parameter only for exact matches to replace a value 
with a parameter only when the text exactly matches the found value.

➤ Select Reverse Search to perform a backward search. 

➤ Select the Left Boundary Instance box and specify the desired instance.

➤ Select Offset to specify an offset for the string within the match.

➤ Select Length to specify the length of the matched string to save to the 
parameter. This option may be used in conjunction with the Offset 
option.

➤ Specify another right boundary in the Alternate right boundary box or 
choose End of String or NewLine Character from the drop-down menu.

 7 Click Test Rule to test the rule you just defined. For information, see 
“Testing Rules” on page 696.

 8 Click OK to save the rules and close the dialog box.

Testing Rules

This section applies to user-defined rules that you created for a server with a 
known context. After you define a new rule in the Correlation Rule dialog 
box, you can test it before recording your session by applying the rules to a 
sample string. You test the rules in the Token Substitution Testpad. To use 
the testpad: 

 1 Select a rule from the left pane and click Test. The Token Substitution 
Testpad dialog box opens.
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 2 Enter text in the Source String for Substitution box. 

 3 Click Test.

If substitution occurred, you will see the parameterized source text in the 
Substitution Result box and a list of rules that were applied to it in the 
Applied Rules box.

Setting the Correlation Recording Options

To instruct VuGen to correlate your statements during recording, you set the 
Correlation recording options. You set these options after opening a Web 
Vuser script but before you begin recording the session. 

To set the correlation recording options: 

 1 After you create a script, but before you begin recording, select Tools > 
Recording Options and select the HTTP Properties:Correlation node in the 
Recording Options tree.

 2 Select the Enable correlation during recording option.
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 3 Indicate the servers to which you want to apply the correlation rules. Select 
the check boxes adjacent to the server names to enable the rules for that 
server. To enable specific rules within a server group, click the plus sign to 
expand the tree and select the desired rules. 

 4 To add a new rule to an existing server, select one of the existing entries and 
click New Rule. Set the properties for the rule in the right pane. For more 
information, see “Setting Correlation Rules” on page 694.

 5 To add a set of rules for a new application, click New Application. Then click 
New Rule to create a rule for the application. 

 6 To modify the properties of an existing rule, select the rule in the left pane 
and modify the rules in the right pane.

 7 To delete an application or rule, select it and click Delete. VuGen prompts 
you to confirm your choice before deleting the selection.

 8 To export a set of correlation rules, click Export and save the .cor file to the 
desired location. To import a set of correlation rules created during an earlier 
session, click Import and open the file from its location. 

 9 Click OK.
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Correlating Vuser Scripts After Recording

When correlation was not performed during recording, VuGen’s built-in 
Web Correlation mechanism allows you to correlate Vuser scripts after a 
recording session.

This chapter includes:

 ➤  About Correlating with Snapshots on page 700

 ➤  Viewing the Correlation Results Tab on page 701

 ➤  Setting Up VuGen for Correlations on page 704

 ➤  Performing a Scan for Correlations on page 707

 ➤  Performing Manual Correlation on page 711

 ➤  Defining a Dynamic String’s Boundaries on page 716

The following information applies only to Web, Wireless, SAP-Web, and 
Siebel-Web Vuser scripts.
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About Correlating with Snapshots

VuGen provides several correlation mechanisms for Web Vuser scripts. The 
automatic method discussed in Chapter 44, “Setting Correlation Rules for 
Web Vuser Scripts” detects dynamic values during recording and allows you 
to correlate them right away. If you disabled automatic correlation, or if the 
automatic method did not detect all of the differences, you can use VuGen’s 
built-in correlation mechanism, described in this chapter, to find differences 
and correlate the values. You can also use this mechanism for scripts that 
were only partially correlated. 

The correlation mechanism uses snapshots to track the results of script 
execution. Snapshots are graphical representations of Web pages. 
VuGen captures snapshots of the Web pages during record and replay. You 
compare the recorded snapshot to any of the replay snapshots to determine 
which values you need to correlate to successfully run the script. For more 
information about Record and Replay snapshots, see “Understanding 
Snapshots” on page 41.

The Web correlation mechanism has a built-in comparison utility that 
allows you to view the text or binary differences between the snapshots. You 
can then correlate the differences one-by-one or all at once. 

If VuGen’s correlation mechanisms are insufficient, or for protocols that do 
not support these mechanisms, such as Wireless, use manual correlation. For 
more information, see “Performing Manual Correlation” on page 711.
700



Chapter 45 • Correlating Vuser Scripts After Recording
Viewing the Correlation Results Tab

The Correlation Results tab displays the differences between the Record and 
Replay snapshots.

When you instruct VuGen to scan the script for correlations, it opens the 
Output window and displays the differences between the recording and 
replayed snapshots in the Correlation Results tab.

You can display all the differences in the script or only those for the current 
step or action, by selecting the desired option from the Show Differences In 
list box. 

Differences that were correlated are indicated by a check mark in the 
Correlated column. The next two columns, Text in Recording, Text in 
Replay show the text differences between the snapshots. The next column, 
First occurs in, indicates the Action in which the correlation was first 
detected.

After you detect the differences between the snapshots, you correlate them 
one at a time by selecting the correlation and clicking Correlate. VuGen also 
allows you to undo a specific correlation using the Remove Correlation 
button. If you expect one of the detected correlations to occur in subsequent 
recordings, you can create a new correlation rule. By creating rules, you 
enable VuGen to recognize differences during recording and automatically 
correlate them. For more information, see “Creating a Rule” on page 702.
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When you correlate a value using the this mechanism, VuGen inserts a 
web_reg_save_param function and a comment into your script indicating 
that a correlation was done for the parameter. It also indicates the original 
value.

Creating a Rule

You can create a rule directly from the list of Correlated Results. Creating a 
rule, enables VuGen to recognize the difference during recording and 
automatically correlate it.

// [WCSPARAM WCSParam_Diff1 14 reserveFlights] Parameter {WCSParam_Diff1} 
created by Correlation Studio
web_reg_save_param("WCSParam_Diff1", "LB= NAME=\"", "RB=\"", "Ord=5", 

"Search=Body", "RelFrameId=1", LAST);
web_submit_form("reservations.pl",

"Snapshot=t4.inf",
ITEMDATA,
"Name=depart", "Value=Denver", ENDITEM,
"Name=departDate", "Value=06/25/2004", ENDITEM,
"Name=arrive", "Value=Los Angeles", ENDITEM,
"Name=returnDate", "Value=06/26/2004", ENDITEM,
"Name=numPassengers", "Value=1", ENDITEM,
"Name=roundtrip", "Value=<OFF>", ENDITEM,
"Name=seatPref", "Value=None", ENDITEM,
"Name=seatType", "Value=Coach", ENDITEM,
"Name=findFlights.x", "Value=44", ENDITEM,
"Name=findFlights.y", "Value=12", ENDITEM,
LAST);

lr_think_time(12);
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To create a rule from one of the detected correlations:

Select the correlation and click Create Rule. You can also create a rule by 
selecting a correlation and choosing Create Correlation Rule from the right-
click menu.

VuGen adds this rule to the list of Correlation rules. You can view this rule 
in the Recording Options Correlation node. In the following example, 
VuGen added the rule as CSRule_1.
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Setting Up VuGen for Correlations

You set the global Correlation setting under the General options. These 
options instruct the Vusers to save correlation information during replay, to 
be used at a later stage. You can specify the type of comparison to perform 
when comparing snapshots: HTML or text. In the Advanced options, you 
can indicate which characters should be treated as delimiters.

➤ Enable Scripting and Java applets on Snapshots viewer. Allows VuGen to 
run applets and JavaScript in the snapshot window. This is disabled by 
default because it uses a lot of resources. 

➤ Download images on Snapshots viewer. Instructs VuGen to display graphics 
in the Snapshot view. If you find that the displaying of images in the viewer 
is very slow, you can disable this option. This option is enabled by default. 

➤ Scan for differences between snapshots using. Choose a comparison 
method:

➤ HTML Comparison. Only display the differences in HTML code.

➤ Text Comparison. Display all text, HTML, and binary differences.
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Note: In most cases, it is recommended that you work with the default 
HTML comparison method. If your script contains non-HTML tags, you can 
use the Text comparison method.

➤ Advanced. Opens the Advanced Correlation dialog box.

Advanced Correlation dialog box
This dialog box lets you specify the characters to be treated as delimiters.

➤ Characters that should be treated as delimiters. Specifies one or more non-
standard delimiters.

➤ Additional Delimiters. You can specify standard delimiters such as Carriage 
Return, New line and Tab characters. To change this setting, clear the check 
box next to the delimiter. 

➤ Ignore differences shorter than … characters. Allows you to specify a 
threshold for performing correlation. When VuGen compares the recorded 
script with the executed script during the scanning process, it detects 
differences. It will not correlate the differences unless the number of 
different characters is greater than or equal to the threshold value. The 
default value is 4 characters.

➤ Issue a warning for large correlations. Issues a warning if you try to correlate 
a string whose size is 10 KB or larger.

Setting the Correlation Preferences
Before recording a session, you configure the correlation preferences.

To set the correlation preferences:

 1 Choose Options > General and select the Correlation tab.

 2 Select Enable Scripting and Java applets on Snapshots viewer to allow 
VuGen to run applets and JavaScript in the snapshot window. 

 3 To instruct VuGen to display graphics in the Snapshot view, select the 
Download images on Snapshots viewer option. 
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 4 Choose the comparison method: HTML comparison or Text Comparison (for 
non-HTML elements only).

 5 To set the delimiter characters, click Advanced to open the Advanced 
Correlation dialog box.

 6 In the Characters that should be treated as delimiters box, specify all 
characters that are to be treated as delimiters. 

 7 Select the desired options in the Additional delimiters section, to specify one 
or more standard delimiters. 

 8 Specify a threshold for the correlation in the Ignore differences shorter than 
box. When VuGen compares the recorded script with the executed script 
during the scanning process, it detects differences. It will not correlate the 
differences unless the number of different characters is greater than or equal 
to the threshold value. 

 9 To issue a warning for large correlations, select the option’s check box.

 10 Click OK to accept the Advanced Correlation settings and close the dialog 
box. 

 11 Click OK in the General Options dialog box to accept the Correlation setting 
and close the dialog box. 
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Performing a Scan for Correlations

You can use VuGen’s snapshot window to determine which values within 
your script are dynamic and require correlation. The following section 
describes how to automatically scan the script for differences and use VuGen 
to perform the necessary correlations. 

To scan your script for correlations:

 1 Open a script and view it in Tree view (View > Tree View). Display the 
snapshots (View > Snapshot > View Snapshot).

 2 Select a script step in the Tree view from the left pane. A snapshot opens in 
the right pane.

 3 To display both the recording snapshot and the first replay snapshot, click 
View > Snapshot > Recorded and Replayed. 
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 4 To use a snapshot other than the first, click View > Snapshot > Select 
Iteration. A dialog box opens, displaying the folders that contain snapshot 
files. These are usually the result and Iteration folders below the script’s 
folder.

 5 To select a snapshot file in a folder other than the one in the subfolders of 
the script, click Select Folder. Browse to the desired location, and click OK. 

 6 To view the HTML code, click the Server Response tab. Expand the Body 
branch.
 

To return to the page view, click the Page View tab.
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 7 Choose Vuser > Scan for Correlations or click the Find Correlations button. 
VuGen scans the script for dynamic values that need to be correlated and 
displays them in the Correlation Results tab.

 8 View all differences or choose a filter method in the Show Differences In list 
box. The options are All Actions, Current Action, or Current Step Only.

Determining the Differences to Correlate
Once you generate a list of differences, you need to determine which ones to 
correlate. If you mistakenly correlate a difference that did not require 
correlation, your replay may be adversely affected.

The following strings most probably require correlation:

➤ Login string. A login string with dynamic data such as a session ID or a 
timestamp.

➤ Date/Time Stamp. Any string using a date or time stamp, or other user 
credentials.

➤ Common Prefix. A common prefix, such as SessionID or CustomerID, 
followed by a string of characters.

If you are in doubt whether a difference should be correlated, correlate only 
that difference and then run your script. Check the Replay log to see if the 
issue was resolved.

You should also correlate differences in which some of the recorded and 
replayed strings are identical, but others differ. For example, SessionID 
strings with identical prefixes and suffixes, but different characters in 
between, should be correlated.
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Once you determine that a difference needs to be correlated, you instruct 
VuGen to correlate it.

To correlate the differences:

 1 View the differences in the Correlation tab, and select the one you want to 
correlate. It is recommended that you correlate only one difference at a 
time.

 2 Click Correlate. VuGen places a green check mark next to differences that 
were correlated and inserts a web_reg_save_param function into the script.

Repeat this step for all differences you want to correlate.

 3 To create a rule from one of the detected correlations, select the correlation 
and click Create Rule. This is also available from the right-click menu. 
VuGen issues a message confirming that your rule was created. 
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To view this rule, open the Recording Options (CTRL +F7) and select the 
Correlation node. Expand the Correlation Studio entry and select your rule.

 4 To undo a correlation, select the difference and click Remove Correlation.

 5 Choose File > Save to save the changes to your script.

Performing Manual Correlation

For Web Vusers, VuGen’s automatic or rule-based correlation usually 
correlates the scripts dynamic functions so that you can run the script 
successfully. You can also perform correlation after the recording session 
using VuGen’s snapshot comparison. 

For Wireless Vusers and other Vuser scripts for which automatic correlation 
did not apply, VuGen also allows you to manually correlate your scripts. You 
manually correlate a script by adding the code correlation functions. The 
function that allows you to dynamically save data to a parameter is 
web_reg_save_param. 

When you run the script, the web_reg_save_param function scans the 
subsequent HTML page that is accessed. You specify a left and/or right 
boundary and VuGen searches for text between those boundaries. When 
VuGen finds the text, it assigns it to a parameter. 
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The function’s syntax is as follows:

The following table lists the available attributes. Note that the attribute 
value strings (for example, Search=all) are not case sensitive.

int web_reg_save_param (const char *mpszParamName, <List of Attributes>, LAST);

NotFound The handling method when a boundary is not found and 
an empty string is generated. "ERROR," the default, 
indicates that VuGen should issue an error when a 
boundary is not found. When set to "EMPTY," no error 
message is issued and script execution continues. Note 
that if Continue on Error is enabled for the script, then 
even when NOTFOUND is set to "ERROR," the script 
continues when the boundary is not found, but it writes 
an error message to the Extended log file. 

LB The left boundary of the parameter or the dynamic data. 
This parameter must be a non-empty, null-terminated 
character string. Boundary parameters are case sensitive; 
to ignore the case, add "/IC" after the boundary. Specify 
"/BIN" after the boundary to specify binary data.

RB The right boundary of the parameter or the dynamic data. 
This parameter must be a non-empty, null-terminated 
character string. Boundary parameters are case sensitive; 
to ignore the case, add "/IC" after the boundary. Specify 
"/BIN" after the boundary to specify binary data.

RelFrameID The hierarchy level of the HTML page relative to the 
requested URL. The possible values are ALL or a number. 

Search The scope of the search—where to search for the 
delimited data. The possible values are Headers (search 
only the headers), Body (search only Body data, not 
headers), or ALL (search Body and headers). The default 
value is ALL.

ORD This optional parameter indicates the ordinal or 
occurrence number of the match. The default ordinal is 1. 
If you specify "All," it saves the parameter values in an 
array. 
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To manually correlate your script: 

 1 Identify the statement that contains dynamic data and the patterns that 
characterize the boundaries of the data. See “Defining a Dynamic String’s 
Boundaries” on page 716.

 2 In the script, replace the dynamic data with your own parameter name. See 
below for more details.

 3 Add the web_reg_save_param function into the script before the statement 
that contains the dynamic data. See “Adding a Correlation Function” on 
page 714 or the Online Function Reference (Help > Function Reference).

Replacing Dynamic Data with a Parameter
Identify the actual dynamic data in the recorded statement, then search the 
entire script for the dynamic data and replace it with a parameter. Give the 
parameter any name and enclose it with braces: {param_name}. You can 
include a maximum of 64 parameters per script.

To replace dynamic data with a parameter:

Select Edit > Replace from the VuGen main window to display the Search 
and Replace dialog box. Search the entire script for the dynamic data and 
replace it with a parameter. 

SaveOffset The offset of a sub-string of the found value, to save to the 
parameter. The default is 0. The offset value must be non-
negative.

Savelen The length of a sub-string of the found value, from the 
specified offset, to save to the parameter. The default is -1, 
indicating until the end of the string. 

Convert The conversion method to apply to the data:

HTML_TO_URL: convert HTML-encoded data to a URL-
encoded data format

HTML_TO_TEXT: convert HTML-encoded data to plain 
text format 
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Adding a Correlation Function
You insert the web_reg_save_param statement to save dynamic data in a 
script. This function tells VuGen to create a parameter that saves the run-
time value of the dynamic data during replay. 

When you run the script, the web_reg_save_param function scans the 
subsequent HTML page that is accessed. It searches for an occurrence of the 
left boundary, followed by any string, followed by the right boundary. 
When such an occurrence is found, VuGen assigns the string between the 
left and right boundaries to the parameter named in the function’s 
argument. After finding the specified number of occurrences, 
web_reg_save_param does not search any more HTML pages. The Vuser 
continues with the next step in the script.

Sample Correlation for Web Vusers
Suppose the script contains a dynamic session ID:

You insert a web_reg_save_param statement before the above statement:

web_url("FirstTimeVisitors", 
"URL=/exec/obidos/subst/help/first-time-visitors.html/002-8481703-

4784428>Buy books for a penny ",
"TargetFrame=",
"RecContentType=text/html",
"SupportFrames=0",
LAST);

web_req_save_param ("user_access_number", "NOTFOUND=ERROR", "LB=first-
time-visitors.html/","RB=>Buy books for a penny", "ORD=6", LAST);
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After implementing correlated statements, the modified script looks like 
this, where user_access_number is the name of the parameter representing 
the dynamic data.

Note: Each correlation function retrieves dynamic data once, for the 
subsequent HTTP request. If another HTTP request at a later point in the 
script generates new dynamic data, you must insert another correlation 
function.

Sample Correlation for Wireless Vusers
Suppose your script contains a dynamic session ID for a WAP connection:

web_url("FirstTImeVisitors", 
"URL=/exec/obidos/subst/help/first-time-”

"visitors.html/{user_access_number}Buy books for a penny",
"TargetFrame=",
"RecContentType=text/html",
"SupportFrames=0",
LAST);

web_url("login.po;sk=IuZSuuRlHUMnpF-wpK8PzEpy(1YOSBSMy)",
"URL=http://room33.com/portal/login.po;sk=IuZSuuRlHUMnpF-

wpK8PzEpy(1YOSBSMy)",
"Resource=0",
"RecContentType=text/vnd.wap.wml",
"Mode=HTML",
LAST);
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You insert a web_reg_save_param statement before the above statement and 
replace the dynamic value with the parameter. In the following example, 
the web_reg_save_param functions saves the login ID string to a variable 
called SK. It saves binary data, denoted by the RB/BIN attribute, and sets the 
left boundary as "sk=".

Defining a Dynamic String’s Boundaries

Use these guidelines to determine and set the boundaries of the dynamic 
data: 

➤ Always analyze the location of the dynamic data within the HTML code 
itself, and not in the recorded script. 

➤ Identify the string that is immediately to the left of the dynamic data. This 
string defines the left boundary of the dynamic data. 

➤ Identify the string that is immediately to the right of the dynamic data. This 
string defines the right boundary of the dynamic data.

web_reg_save_param(
    "SK",

    "LB=sk=",
      "RB/BIN=#login\\x00\\x01\\x03",
     "Ord=1",
     LAST);

web_url("login.po;sk={SK}",
"URL=http://room33.com/portal/login.po;sk={SK}",
"Resource=0",
"RecContentType=text/vnd.wap.wml",
"Mode=HTML",
LAST);
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➤ web_reg_save_param looks for the characters between (but not including) 
the specified boundaries and saves the information beginning one byte after 
the left boundary and ending one byte before the right boundary. 
web_reg_save_param does not support embedded boundary characters. 
For example, if the input buffer is {a{b{c} and "{" is specified as a left 
boundary, and "}" as a right boundary, the first instance is c and there are no 
further instances—it found the right and left boundaries but it does not 
allow embedded boundaries, so "c" is the only valid match.

By default, the maximum length of any boundary string is 256 characters. 
Include a web_set_max_html_param_len function in your script to increase 
the maximum permitted length. For example, the following function 
increases the maximum length to 1024 characters:

web_set_max_html_param_len("1024");
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Testing XML Pages

VuGen’s Web Vusers support Web pages containing XML code.

This chapter includes:

 ➤  About Testing XML Pages on page 719

 ➤  Viewing XML as URL Steps on page 720

 ➤  Inserting XML as a Custom Request on page 723

 ➤  Viewing XML Custom Request Steps on page 724

The following information applies to Web and Web Services Vuser scripts.

About Testing XML Pages

VuGen supports record and replay for XML code within Web pages. 

The XML code can appear in the script as a regular URL step or as a custom 
request. VuGen detects the HTML and allows you to view each document 
type definition (DTD), its entities, and its attributes. VuGen can interpret 
the XML when the MIME type displayed in the RecContentType attribute or 
the MIME type returned by the server during replay, ends with xml, such as 
application/xml or text/xml. The DTD is color coded, allowing you to 
identify each one of the elements. You can also expand and collapse the tree 
view of the DTD. 

When you expand the DTD, you can parameterize the attribute values. You 
can also save the values in order to perform correlation using the standard 
correlation functions. For more information about the correlation 
functions, refer to the Online Function Reference (Help > Function Reference).
719



Chapter 46 • Testing XML Pages
Note: VuGen cannot display a DTD with XML islands, segments of XML 
embedded inside an HTML page. VuGen only displays pages that are 
entirely XML.

Viewing XML as URL Steps

One way to test a page with XML code, is to record it with VuGen. You 
record the XML pages as you would record a standard Web page. VuGen 
records the DTD and all of the XML elements. It does not create a snapshot 
for the XML page. Instead, for each XML step it displays the XML code in 
the snapshot frame under the Server Response tab.
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VuGen creates a color-coded expandable hierarchy of the DTD in the 
snapshot frame. Click on the "+" to expand an item, and click on the "-" to 
collapse it. VuGen displays all XML tags in brown, and values in black.

To replace any of the constant values with a parameter, select a value, 
perform a right-click, and select Replace with a Parameter. Follow the 
standard procedure for parameterization. For more information, see 
“Creating Parameters” in Volume I-Using VuGen.
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You can also view the Server response and Client request for the XML page 
by clicking the appropriate tab. The following example shows the Server 
response of an XML page. Note that you can expand and collapse all 
branches of the XML tree. 

The following example shows the Client Request for the header of an XML 
page: 
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Inserting XML as a Custom Request

You can also test your XML pages by inserting the XML code as a custom 
request. In this mode, the Custom Request properties box displays the 
elements of the DTD in either text or XML format. 

To add XML code as a Custom Request:

 1 View the script in tree view mode, place the cursor at the desired location, 
and choose Insert > Add Step. The Add Step dialog box opens.

 2 Scroll to the bottom of the list and select Custom Request. Click OK. The 
Custom Request Properties dialog box opens.

 3 Enter a step name, method (GET or POST), URL, and target frame (optional).

 4 Copy the XML code from your browser or editor and paste it into the Body 
section of the Custom Request Properties box. 
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 5 Select the applicable replay options: Record mode, Resource, or Binary data. 
For more information, see Chapter 43, “Modifying Web and Wireless Vuser 
Scripts.”

 6 Click OK. VuGen places the custom request step into your script. 

Viewing XML Custom Request Steps

You can view or modify the XML code implemented as a custom request 
step, at any time. VuGen provides a viewer that allows you to view the 
hierarchy of the DTD, and expand and collapse the elements as needed. 

To view the XML code of a custom request step:

 1 View the script in tree view mode, and select the desired step.

 2 Choose Properties from the right-click menu. The Custom Request 
Properties dialog box opens. 
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The bottom section of the dialog box displays the XML code. If the 
RecContentType attribute is set to text/xml, by default VuGen displays the 
code in an XML format hierarchy. In this mode, the XML code is not 
editable.
 

If the RecContentType attribute is set to any type other than text/xml, 
VuGen displays the code in plain text format. In this mode, the XML code is 
editable.

 3 To switch between the text and XML views, choose XML view or Text view 
from the right-click menu.
725



Chapter 46 • Testing XML Pages
 4 When you are in XML view, you can view the code in a larger window. 
Choose Extended view from the right-click menu. To switch back to the 
dialog box view, choose Normal view from the right-click menu.
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Performing EJB Testing

The Enterprise Java Beans (EJB) testing tool generates scripts for testing EJB 
objects. 

This chapter includes:

 ➤  About EJB Testing on page 730

 ➤  Working with the EJB Detector on page 731

 ➤  Creating an EJB Testing Vuser on page 735

 ➤  Setting EJB Recording Options on page 739

 ➤  Understanding EJB Vuser Scripts on page 740

 ➤  Running EJB Vuser Scripts on page 746

The following information only applies to EJB Testing Vuser scripts.
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About EJB Testing

VuGen provides several tools for developing a script that tests Java 
applications. For generating a Vuser script through recording, use the 
Jacada, CORBA or RMI Vusers. For creating a script through programming, 
use the custom Java Vusers. 

EJB Testing Vusers differ from the standard Java Vusers in that VuGen 
automatically creates a script to test or tune EJB functionality without 
recording or programming. Before you generate a script, you specify the 
JNDI properties and other information about your application server. 
VuGen’s EJB Detector scans the application server and determines which 
EJBs are available. You select the EJB that you want to test or tune, and 
VuGen generates a script that emulates each of the EJB’s methods. 

It creates transactions for each method so that you can measure its 
performance and locate problems. In addition, each method is wrapped in a 
try and catch block for exception handling. 

Note that in order to create EJB testing scripts, the EJB Detector must be 
installed and active on the application server host. The Detector is described 
in the following sections.

VuGen also has a built-in utility for inserting methods into your script. 
Using this utility, you display all of the available packages, select the desired 
methods, and insert them into your script. For more information, see 
“Running EJB Vuser Scripts” on page 746.
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Working with the EJB Detector

The EJB Detector is a separate agent that must be installed on each machine 
that is being scanned for EJBs. This agent detects the EJBs on the machine. 
Before installing the EJB Detector, verify that you have a valid JDK 
environment on the machine.

Installing the EJB Detector
The EJB Detector can be installed and invoked on the application server's 
machine or alternatively, on the client machine. To run the EJB Detector on 
the client machine you must have a mounted drive to the application server 
machine.

To install the EJB detector agent:

 1 Create a home directory for the EJB Detector on the application server 
machine, or on the client machine (and mount the file systems as 
mentioned).

 2 Unzip the <LR_root>\ejbcomponent\ejbdetector.jar file into the EJB 
Detector directory.

Running the EJB Detector
The EJB Detector must be running before you start the EJB script generation 
process in VuGen. You can either run the EJB detector on the application 
server or on the client machine (in this case, make sure to mount to the 
application server from the EJB Detector (client) machine, specify the 
mount directory in the search root directory, and change the generated 
script to connect to the mounted machine, instead of the local machine).

The EJB Detector can run from the command-line, or from a batch file. 

To run the EJB Detector from the command line:

 1 Before running the EJB Detector from the command line, add the 
DETECTOR_HOME\classes and the DETECTOR_HOME\classes\xerces.jar to 
the CLASSPATH environment variable.

 2 If you are working with EJB1.0 (Weblogic 4.x, WebSphere 3.x), add the 
classes of EJBs that are being tested as well as the following vendor EJB 
classes to the CLASSPATH: 
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For WebLogic 4.x: <WebLogic directory>\lib\weblogicaux.jar

For WebSphere 3.x: <WebSphere directory>\lib\ujc.jar

 3 If your EJBs use additional classes directory or .jar files, add them to the 
CLASSPATH.

 4 To run the EJB Detector from the command-line, use the following string: 

java EJBDetector [search root dir] [listen port]

search root dir One or more directories or files in which to search for EJBs 
(separated by semicolons). Follow these guidelines:

BEA WebLogic Servers 4.x and 5.x. Specify the application 
server root directory. 
BEA WebLogic Servers 6.x. Specify full path of the domain 
folder. 
WebSphere Servers 3.x. Specify the full path of the 
deployed EJBs folder. 
WebSphere Servers 4.0. Specify the application server 
root directory.
Oracle OC4J. Specify the application server root directory.
Sun J2EE Server. Specify the full path to the deployable 
.ear file or directory containing a number of .ear files. 

If unspecified, the classpath will be searched. 

listen port The listening port of the EJB Detector.The default port is 
2001. If you change this port number, you must also 
specify it in the Host name box of the Generate EJB Test 
dialog box. 

For example, if your host is metal, if you are using the 
default port, you can specify metal. If you are using a 
different port, for example, port 2002, enter metal:2002. 
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To run the EJB Detector from a batch file:

You can launch the EJB detector using a batch file, EJB_Detector.cmd. This 
file resides in the root directory of the EJB Detector installation, after you 
unzip ejbdetector.jar. 

 1 Open env.cmd in the EJB Detector root directory, and modify the following 
variables according to your environment:

 2 Save env.cmd.

 3 If you are working with EJB1.0 (Weblogic 4.x, WebSphere 3.x), add the 
classes of EJBs that are being tested, as well as the following vendor EJB 
classes, to the CLASSPATH in the env file: 

➤ For WebLogic 4.x: <WebLogic directory>\lib\weblogicaux.jar

➤ For WebSphere 3.x: <WebSphere directory>\lib\ujc.jar

JAVA_HOME the root directory of JDK installation

DETECTOR_INS_DIR the root directory of the Detector installation

APP_SERVER_DRIVE the drive hosting the application server installation

APP_SERVER_ROOT Follow these guidelines:
BEA WebLogic Servers 4.x and 5.x. Specify the 
application server root directory. 
BEA WebLogic Servers 6.x. Specify full path of the 
domain folder. 
WebSphere Servers 3.x. Specify the full path of the 
deployed EJBs folder. 
WebSphere Servers 4.0. Specify the application server 
root directory.
Oracle OC4J. Specify the application server root 
directory.
Sun J2EE Server. Specify the full path to the deployable 
.ear file or directory containing a number of .ear files. 

EJB_DIR_LIST 
(optional)

list of directories/files, separated by ‘;’ and containing 
deployable .ear/.jar files, and any additional classes 
directory or .jar files or used by your EJBs under test.
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 4 Run the EJB_Detector.cmd or EJB_Detector.sh (Unix platforms) batch file to 
collect information about the deployable applications containing EJBs, for 
example:

where listen_port is an optional argument specifying a port number on 
which the EJB Detector will listen for incoming requests (default is 2001).

EJB Detector Output and Log Files
You can examine the output of the EJB Detector to see if it has detected all 
the active EJBs. The output log shows the paths being checked for EJBs. At 
the end of the scan, it displays a list of the EJBs that were found, their names 
and locations. For example:

If no EJBs were detected (that is, "Found 0 EJBs"), check that the EJB jar files 
are listed in the "Checking EJB Entry:…" lines. If they are not listed, check 
that the search root dir path is correct. If they are being inspected but still 
no EJBs are detected, check that these EJB jar files are deployable (can be 
successfully deployed into an application server). A deployable jar file 
should contain the Home Interface, Remote Interface, Bean 
implementation, the Deployment Descriptor files (xml files, or .ser files), 
and additional vendor-specific files.

If you still encounter problems, set the debug properties in the 
detector.properties file, located in the DETECTOR_HOME\classes directory, 
to retrieve additional debug information.

C:\>EJB_Detector [listen_port]

Checking EJB Entry: f:/weblogic/myserver/ejb_basic_beanManaged.jar…
Checking EJB Entry: f:/weblogic/myserver/ejb_basic_statefulSession.jar…
Checking EJB Entry: f:/weblogic/myserver/ejb_basic_statelessSession.jar…
------------------------- Found 3 EJBs ---------------------------
** PATH: f:/weblogic/myserver/ejb_basic_beanManaged.jar
- BEAN: examples.ejb.basic.beanManaged.AccountBean
** PATH: f:/weblogic/myserver/ejb_basic_statefulSession.jar
- BEAN: examples.ejb.basic.statefulSession.TraderBean
** PATH: f:/weblogic/myserver/ejb_basic_statelessSession.jar
- BEAN: examples.ejb.basic.statelessSession.TraderBean
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After the EJBs are detected, the HTTP Server is initialized and waits for 
requests from the VuGen EJB-Testing Vuser. If there are problems in this 
communication process, enable the property webserver.enableLog in the 
webserver.properties file located in the DETECTOR_HOME\classes 
directory. 

This enables printouts of additional debug information, and other 
potentially important error messages in the webserver.log file.

Creating an EJB Testing Vuser 

To create an EJB Vuser script:

 1 Choose File > New or click the New button. The New Virtual User dialog box 
opens.
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 2 Select EJB Testing from the Enterprise Java Beans category and click OK. 
VuGen opens a blank Java Vuser script and opens the Generate EJB Script 
dialog box. 

 3 Specify a machine on which VuGen’s EJB Detector is installed. Note that the 
Detector must be running in order to connect. Click Connect. The JNDI 
properties section is enabled.
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 4 The EJB Detector automatically detects the default JNDI properties. You can 
manually modify these properties in the appropriate edit boxes. The 
properties you can modify are a string for the Initial Context Factory and the 
Provider URL. 

If your application server requires authentication, enter the user name in 
the Security Principal box and a password in the Security Credentials box. 

Here are the default values of the two JNDI mandatory properties:

 5 To set advanced properties for the JNDI, click Advanced to open the JNDI 
Advanced Properties dialog box.

Type Initial Context Factory Provider URL

WebLogic weblogic.jndi.WLInitialContextFactory t3://<appserver_host>:7001

WebSphere 
3.x

com.ibm.ejs.ns.jndi.CNInitialContextF
actory

iiop://<appserver_host>:900

WebSphere 
4.x

com.ibm.websphere.naming.WsnInitia
l
ContextFactory

iiop://<appserver_host>:900

Sun J2EE com.sun.enterprise.naming.
SerialInitContextFactory

N/A

Oracle com.evermind.server.
AppplicationClientInitialContextFactor
y

ormi://<appserver_host>/
<application_name> (the 
app. name of the EJB in 
<oc4j>/config/server.xml)
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Specify the desired properties: Object Factory, State Factory, URL Package 
Prefixes, Security Protocol, and Security Authentication. Click OK.

 6 In the EJB section of the dialog box, click Select to choose the EJB for which 
you want to create a test. A dialog box opens with a list of all the EJBs 
currently available to you from the application server. 

 7 Highlight the EJB you want to test and click Select. 

 8 In the Generate EJB Script dialog box, click Generate. VuGen creates a script 
with Java Vuser functions. The script contains code that connects to the 
application server and executes the EJB’s methods.

 9 Save the script. 

Note that you cannot generate test code for an additional EJB, within an 
existing script. To create a test for another EJB, open a new script and repeat 
steps 2-9. 
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Setting EJB Recording Options 

The recording options that are available for EJB Vusers are in the areas of 
Classpath and Code Generation. For information on the Classpath options, 
see Chapter 12, “Setting Java Recording Options.” 

The EJB Code Generation options allow you to set properties in the area of 
automatic transactions and value checks. You can also indicate where to 
store the initialization method. 

To set the EJB Code Generation recording options:

 1 Click Options in the Start Recording dialog box. Select the EJB Options:Code 
Generation Options node in the Recording Options tree to edit the code 
generation options.

 2 Enable the Auto Transaction option to automatically mark all EJB methods 
as transactions. This encloses all methods with lr.start_transaction and 
lr.end_transaction functions. By default, this option is enabled (true). 

 3 Enable the Insert Value Check option to automatically insert an 
lr.value_check function after each EJB method. This function checks for the 
expected return value for primitive values and strings.

 4 Choose an EJB Initialization Method. This is the method to which the 
EJB/JNDI initialization properties are written. The available methods are init 
(default) and action.
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Understanding EJB Vuser Scripts

VuGen generates a script that tests your EJB, based on the JNDI (Java 
Naming and Directory Interface) properties you specified when creating the 
Vuser script. JNDI is Sun’s programming interface used for connecting Java 
programs to naming and directory services such as DNS and LDAP. 

Each EJB Vuser script contains three primary parts:

➤ Locating the EJB Home Using JNDI

➤ Creating an Instance

➤ Invoking the EJB Methods

Locating the EJB Home Using JNDI
The first section of the script contains the code that retrieves the JNDI 
properties. Using the specified context factory and provider URL, it connects 
to the application server, looks up the specified EJB and locates the EJB 
Home. 
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In the following example, the JNDI Context Factory is 
weblogic.jndi.WLInitialContextFactory, the URL of the provider is 
t3://dod:7001 and the JNDI name of the selected EJB is 
carmel.CarmelHome.

Note: If the script is generated with an EJB Detector running on the client 
rather than an application server, you must manually modify the URL of the 
provider. For example, in the following line, the provider specifies dod as 
the EJB detector host name:
p.put(javax.naming.Context.PROVIDER_URL, "t3://dod:7001")
Replace the recorded host name with the application server name, for 
example:
p.put(javax.naming.Context.PROVIDER_URL, "t3://bealogic:7001")
You can specify the provider URL before recording, so you don’t have to 
modify it manually, in the JDNI Properties section of the Generate EJB Script 
dialog.

public class Actions
{

public int init() {
CarmelHome _carmelhome = null;
try {

// get the JNDI Initial Context
java.util.Properties p = new java.util.Properties();
p.put(javax.naming.Context.INITIAL_CONTEXT_FACTORY, 

"weblogic.jndi.WLInitialContextFactory");
p.put(javax.naming.Context.PROVIDER_URL, "t3://dod:7001");
javax.naming.InitialContext _context = new javax.naming.InitialContext(p);

// lookup Home Interface in the JNDI context and narrow it
Object homeobj = _context.lookup("carmel.CarmelHome");
_carmelhome = 

(CarmelHome)javax.rmi.PortableRemoteObject.narrow(homeobj, CarmelHome.class);

} catch (javax.naming.NamingException e) {
e.printStackTrace();

}
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Creating an Instance
Before executing the EJB methods, the script creates a Bean instance for the 
EJB. The creation of the instance is marked as a transaction to allow it to be 
analyzed after the script is executed. In addition, the process of creating an 
instance is wrapped in a try and catch block providing exception handling. 

For Session Beans. Use the EJB home 'create' method to get a new EJB 
instance.

In the following example, the script creates an instance for the Carmel EJB. 

For Entity Beans - use the findByPrimaryKey method to locate the EJB 
instance in an existing database, and if not found, then use the create 
method, to create it there. 

// create Bean instance
Carmel _carmel = null;
try {

lr.start_transaction("create");
_carmel = _carmelhome.create();
lr.end_transaction("create", lr.AUTO);

} catch (Throwable t) {
lr.end_transaction("create", lr.FAIL);
t.printStackTrace();

}
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In the following example, the script attempts to locate an instance for the 
account EJB, and if it fails then creates it. 

You may choose to use other find… methods supplied by your Entity Bean, 
to locate the EJB instance. For example: 

// find Bean instance
try {
com.ibm.ejs.doc.account.AccountKey _accountkey = new 

com.ibm.ejs.doc.account.AccountKey();
_accountkey.accountId = (long)0;

lr.start_transaction("findByPrimaryKey");
_account = _accounthome.findByPrimaryKey(_accountkey);
lr.end_transaction("findByPrimaryKey", lr.AUTO);

} catch (Throwable thr) {

lr.end_transaction("findByPrimaryKey", lr.FAIL);
lr.message("Couldn't locate the EJB object using a primary key. Attempting to manually 

create the object... ["+thr+"]");

// create Bean instance
try {

lr.start_transaction("create");
_account = _accounthome.create((com.ibm.ejs.doc.account.AccountKey)null);
lr.end_transaction("create", lr.AUTO);

} catch (Throwable t) {
lr.end_transaction("create", lr.FAIL);
t.printStackTrace();

}

}

// get an enumeration list of all Email EJB instances that represents 
// the name 'John' in the database. 
Enumeration enum = home.findByName("John");
while (enum.hasMoreElements()) {

           Email addr = (Email)enum.nextElement();
...

}

743



Chapter 47 • Performing EJB Testing
Invoking the EJB Methods
The final part of the script contains the actual methods of the EJB. Each 
method is marked as a transaction to allow it to be analyzed after running 
the script. In addition, each method is wrapped in a try and catch block 
providing exception handling. When there is an exception, the transaction 
is marked as failed, and the script continues with the next method. VuGen 
creates a separate block for each of the EJB methods. 

VuGen inserts default values for the methods, for example, 0 for an integer, 
empty strings ("") for Strings, and NULL for complex Java objects. If 
necessary, modify the default values within the generated script. 

The following example shows how to change the default value of a non-
primitive type using parameterization:

// ------- Methods ------------

int _int1 = 0;
try {

lr.start_transaction("buyTomatoes");
_int1 = _carmel.buyTomatoes((int)0);
//lr.value_check(_int1, 0, lr.EQUALS);
lr.end_transaction("buyTomatoes", lr.AUTO);

} catch (Throwable t) {
lr.end_transaction("buyTomatoes", lr.FAIL);
t.printStackTrace();

}

_int1 = _carmel.buyTomatoes((int)0);

Detail details = new Details(<city>,<street>,<zip>,<phone>);
JobProfile job = new JobProfile(<department>,<position>,<job_type>);
Employee employee=new Employee(<first>,<last>, details, job, <salary>);
_int1 = _empbook.addEmployee((Employee)employee);
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For methods that return a primitive, non-complex value or string, VuGen 
inserts a commented method lr.value_check. This method allows you to 
specify an expected value for the EJB method. To use this verification 
method, remove the comment marks (//) and specify the expected value. For 
example, the carmel.buyTomatoes method returns an integer. 

If you expect the method to return a value of 500, modify the code as 
follows: 

If you want to check if the method does not return a certain value, modify 
the code as follows: 

If the expected value is not detected, an exception occurs and the 
information is logged in the output window. 

EJB Vuser scripts support all of the standard Java conventions. For example, 
you can insert a comment by preceding the text with two forward slashes 
"//". 

The Java Vuser script runs as a scalable multi-threaded application. If you 
include a custom class in your script, ensure that the code is thread-safe. 
Code that is not thread-safe may cause inaccurate results. For code that is 
not thread-safe, run the Java Vusers as processes. (see Run-Time settings) 
This creates a separate Java Virtual Machine for each process, resulting in a 
script that is less scalable.

_int1 = _carmel.buyTomatoes((int)0);
//lr.value_check(_int1, 0, lr.EQUALS);

_int1 = _carmel.buyTomatoes((int)0);
lr.value_check(_int1, 500, lr.EQUALS);

_int1 = _carmel.buyTomatoes((int)0);
lr.value_check(_int1, 10, lr.NOT_EQUALS);

System.err: java.lang.Exception: lr.value_check failed.[Expected:500 Actual:5000] 
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Running EJB Vuser Scripts

After you generate a script for your EJB testing, and make the necessary 
modifications, you are ready to run your script. The EJB script allows you to 
perform two types of testing: functional and load. The functional testing 
verifies that the EJB, functions properly within your environment. The load 
testing allows you to evaluate the performance of the EJB when executing 
many users at one time.

To run a functional test:

 1 Modify the default values that were automatically generated.

 2 Insert value checks using the lr.value_check method. These methods were 
generated as comments in the script (see “Invoking the EJB Methods” on 
page 744).

 3 Insert additional methods, and modify their default values. For more 
information, refer to the section on inserting Java functions in Chapter 10, 
“Recording Java Language Vuser Scripts.”

 4 Set the general run-time settings for the script. For more information, see 
“Configuring Run-Time Settings” in Volume I-Using VuGen.

 5 Set the Java VM run-time settings: Specify all additional classpaths and 
additional VM parameters. Make sure to include your application server EJB 
classes. The actual classes of the EJB under test are saved in the Vuser 
directory and retrieved automatically during replay. For information about 
specifying additional classpaths and setting the Java VM run-time settings, 
see Chapter 14, “Configuring Java Run-Time Settings.” 

 6 For Websphere 3.x users:

Using the IBM JDK 1.2 or higher:

➤ Add the <WS>\lib\ujc.jar to the classpath.

Using the Sun JDK 1.2.x:

➤ Remove the file <JDK>\jre\lib\ext\iiimp.jar

➤ Copy the following files from the <WS>\jdk\jre\lib\ext folder to the 
<JDK>\jre\lib\ext directory: iioprt.jar, rmiorb.jar.

➤ Copy the 'ujc.jar' from the <WS>\lib folder, to <JDK>\jre\lib\ext. 
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➤ Copy the file <WS>\jdk\jre\bin\ioser12.dll to the <JDK>\jre\bin folder.

where <WS> is the home folder of the WebSphere installation and <JDK> is 
the home folder of the JDK installation.

Clear the Use -Xbootclasspath VM parameter check box to turn off this 
option.

 7 For WebSphere 4.0 users: 

Make sure that you have valid Java environment on your machine of IBM 
JDK1.3. Open the Run-Time Settings dialog box and select the Java VM 
node. Add the following entries to the Additional Classpath section:

Where <WS> is the home directory of the WebSphere installation.

Clear the Use -Xbootclasspath VM parameter check box to turn off this 
option.

Note: If your application server is installed on a UNIX machine or if you are 
using WebSphere 3.0.x, you must install IBM JDK 1.2.x on the client 
machine to obtain the required files.

 8 For Oracle OC4J users: 

Make sure that you have valid Java environment on your machine of JDK1.2 
or higher (JDK1.3 preferable). Open the Run-Time Settings dialog box and 
select the Java VM node. Add the following entries to the Additional 
Classpath section:

where <OC4J> is the home folder of the application server installation.

<WS>/lib/webshpere.jar;   
<WS>/lib/j2ee.jar;

<OC4J>/orion.jar;<OC4J>/ejb.jar;<OC4J>/jndi.jar; ;<OC4J>/xalan.jar;   
<OC4J>/crimson.jar
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 9 For Sun J2EE users:

Make sure that you have valid Java environment on your machine of JDK1.2 
or higher. Open the Run-Time Settings dialog box and select the Java VM 
node. Add the following entries to the Additional Classpath section:

where <J2EE> is the home folder of the application server installation and 
<AppClientJar> is the full path to the application client jar file created 
automatically by the sdk tools during the deployment process. 

 10 For WebLogic 4.x - 5.x Users: 

Make sure that you have valid Java environment on your machine (path & 
classpath). Open the Run-Time Settings dialog box and select the Java VM 
node. Add the following two entries to the Additional Classpath section:

where <WL> is the home folder of the WebLogic installation.

 11 For WebLogic 6.x and 7.0 users: 

Make sure that you have valid Java environment on your machine (path & 
classpath). WebLogic 6.1 requires JDK 1.3. Open the Run-Time Settings 
dialog box and select the Java VM node. Add the following entry to the 
Additional Classpath section:

where <WL> is the home folder of the WebLogic installation.

Clear the Use -Xbootclasspath VM parameter check box to turn off this 
option.

 12 Run the script. Click the Run button or choose Vuser > Run. View the 
Execution Log node to view any run-time errors. The execution log is stored 
in the mdrv.log file in the script’s folder. A Java compiler (Sun’s javac), 
checks it for errors and compiles the script. 

<J2EE>/j2ee.jar;<AppClientJar>

<WL>/classes;<WL>/lib/weblogicaux.jar

<WL>/lib/weblogic.jar; // Weblogic 6.x
<WL>/server/lib/weblogic.jar // Weblogic 7.x
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After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 
749



Chapter 47 • Performing EJB Testing
750



Part X

ERP/CRM Protocols



752



48 
Creating Oracle NCA Vuser Scripts 

You can use VuGen to create scripts that emulate an Oracle NCA user. You 
record typical NCA business processes with VuGen. You then run the script 
to emulate users interacting with your system.

This chapter includes:

 ➤  About Creating Oracle NCA Vuser Scripts on page 754

 ➤  Getting Started with Oracle NCA Vusers on page 755

 ➤  Recording Guidelines on page 756

 ➤  Enabling the Recording of Objects by Name on page 758

 ➤  Oracle Applications via the Personal Home Page on page 761

 ➤  Using Oracle NCA Vuser Functions on page 762

 ➤  Understanding Oracle NCA Vusers on page 763

 ➤  Configuring Oracle NCA Run-Time Settings on page 764

 ➤  Testing Oracle NCA Applications on page 767

 ➤  Correlating Oracle NCA Statements for Load Balancing on page 771

 ➤  Additional Recommended Correlations on page 772

 ➤  Recording in Pragma Mode on page 774

The following information applies only to the Oracle NCA protocol.
753



Chapter 48 • Creating Oracle NCA Vuser Scripts
About Creating Oracle NCA Vuser Scripts

Oracle NCA is a Java-based database protocol. Using your browser, you 
launch the database client, an applet viewer. You perform actions on the 
NCA database through its applet viewer.

This eliminates the need for client software and allows you to perform 
database actions from all platforms that support the applet viewer. There is a 
Vuser type specifically designed to emulate an Oracle NCA client.

The NCA environment is a three-tier environment. The user first sends an 
http call from his browser to a Web server. This call accesses the startup 
HTML page which invokes the Oracle Applications applet. The applet runs 
locally on the client machine—all subsequent calls are communicated 
between the client and the Forms server through the proprietary NCA 
protocol.

The client (applet viewer) communicates with the application server (Oracle 
Forms server) which then submits information to the database server.

VuGen records and replays the NCA communication between the client and 
the Forms server (application server).

When you record an Oracle NCA session, VuGen records all of the NCA and 
Web actions, even if you only created a single protocol script. If you know in 
advance that the Web functions are important for your test, create a multi-
protocol script from the beginning for the Oracle NCA and Web protocols.

If you initially created a single protocol script for Oracle NCA, and at a later 
stage you require the Web functions for testing, you can regenerate your 
script in VuGen to add the Web functions, without having to re-record the 
754



Chapter 48 • Creating Oracle NCA Vuser Scripts
session. You indicate this from the Protocols node in the Regenerate Script 
dialog box. For more information, see “Recording with VuGen” in Volume I-
Using VuGen.

Getting Started with Oracle NCA Vusers

The following procedure outlines how to create an Oracle NCA Vuser script. 

 1 Ensure that the recording machine is properly configured.

Make sure that your machine is configured to run the Oracle NCA applet 
viewer, before you start VuGen. You must also make sure VuGen supports 
your version of Oracle Forms. For more information, see “Recording 
Guidelines” on page 756 and the Readme file.

 2 Create a skeleton Oracle NCA Vuser script.

Use VuGen to create a skeleton Oracle NCA Vuser script. For details, see 
“Recording with VuGen” in Volume I-Using VuGen.

 3 Record typical user actions.

Begin recording, and perform typical actions and business processes from 
the applet viewer. VuGen records your actions and generates a Vuser script. 
For details, see “Recording with VuGen” in Volume I-Using VuGen.

 4 Enhance the Vuser script.

Use the Insert menu to add transactions, rendezvous points, comments, and 
messages in order to enhance the Vuser script. For details, see “Enhancing 
Vuser Scripts” in Volume I-Using VuGen.

 5 Parameterize the script. 

Replace recorded constants with parameters. For details, see “Creating 
Parameters” in Volume I-Using VuGen.

 6 Set the run-time properties for the script.

Configure run-time settings for the Vuser script. The run-time settings 
define certain aspects of the script execution. For details, see “Configuring 
Run-Time Settings” in Volume I-Using VuGen.
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 7 Save and run the Vuser script.

Run the script from VuGen and view the execution log for run-time 
information. For details, see “Running Vuser Scripts in Standalone Mode” in 
Volume I-Using VuGen.

Recording Guidelines

When recording an Oracle NCA Vuser script, follow these guidelines:

➤ Specify which browser VuGen should use when recording an Oracle NCA 
session. In the Start Recording dialog box, select the desired browser in the 
Program to Record list. The list contains all of the available browsers.

➤ Close all browsers before you begin recording.
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➤ Record the login procedure in the vuser_init section. Record a typical 
business process in the Actions section. When you run the script, you can 
then specify multiple iterations for a specific business process. For more 
information, see “Creating New Virtual User Scripts” on page 78.

➤ Due to a Netscape limitation, you cannot launch an Oracle NCA session 
within Netscape when another Netscape browser is already running on the 
machine.

➤ VuGen supports the recording of Oracle Forms applications using the Forms 
Listener Servlet in multi--protocol mode. The application server uses the 
Forms Listener Servlet to create a runtime process for each client. The 
runtime process, Forms Server Runtime, maintains a persistent connection 
with the client and sends information to and from the server.

To support Forms 4.5 in replay, set the following in the mdrv.dat file: 

To restore Forms 6 or 9 support, restore the original values.

vuser_init()
{
nca_set_connect_opt(SCALE_INFO, 11, 18);
nca_connect_server("labm1orcl05.devlab.ad", "9000", 

"module=/opt/applvis/visappl/fnd/11.5.0/forms/US/FNDSCSGN 
userid=APPLSYSPUB/PUB@VIS fndnam=APPS record=names  ");
nca_set_window("Oracle Applications");
nca_edit_set("SIGNON_USERNAME_0", "OPERATIONS");
nca_obj_type("SIGNON_USERNAME_0", '\t', 0);
nca_edit_set("SIGNON_PASSWORD_0", lr_decrypt("4768d647f4f1840f2e46d5"));
nca_button_press("SIGNON_CONNECT_BUTTON_0");

return 0;
}

[Oracle_NCA] 
ExtPriorityType=protocol 
WINNT_EXT_LIBS=ncarp110.dll 
WIN95_EXT_LIBS=ncarp110.dll 
LINUX_EXT_LIBS=liboranca.so 
SOLARIS_EXT_LIBS=liboranca.so 
HPUX_EXT_LIBS=liboranca.sl 
AIX_EXT_LIBS=liboranca.so 
LibCfgFunc=oracle_gui_configure 
UtilityExt=lrun_api 
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Enabling the Recording of Objects by Name

When recording an Oracle NCA script, you must record the session using 
object names instead of the standard object ID. If the script is recorded using 
the object ID, replay will fail because the ID is generated dynamically by the 
server and differs between record and replay. You can verify that your script 
is being recorded with object names by examining the nca_connect_server 
statement.

If the record=names argument does not appear in the nca_connect_server 
function, you are recording object IDs. You can instruct VuGen to record 
object names in by modifying one of the following:

➤ Startup HTML File 

➤ URL to Record

➤ Forms Configuration File

Note that the ability to capture the developer name for all objects was 
introduced in Oracle Forms6i Patch 9 (Oracle Forms Version: 6.0.8.18.3). 
Test Starter Kit scripts that were written before the release of Oracle Forms 6i 
Patch 9 will not have the developer name as part of an object's physical 
description, except for the edit fields. 

Startup HTML File
If you have access to the startup HTML file, you instruct VuGen to record 
object names instead of its object ID by setting the record=names flag in the 
startup file, the file that is loaded when you start the Oracle NCA 
application.

Edit the startup file that is called when the applet viewer begins. Modify the 
line: 

nca_connect_server("199.35.107.119","9002"/*version=11i*/,"module=/d1/oracle/visap
pl/fnd/11.5.0/forms/US/FNDSCSGN userid=APPLSYSPUB/PUB@VIS fndnam=apps 
record=names ");

<PARAM name="serverArgs … fndnam=APPS"> 
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and add the Oracle key "record=names": 

URL to Record
If you do not have access to the startup HTML file, you can still have Oracle 
NCA record object names instead of its object ID by modifying the URL to 
record. The following solution only works if the startup HTML file does not 
reference another file while loading.

For this solution, you add "?record=names" after the URL in the Start 
Recording dialog box, after the URL name to record. This allows VuGen to 
record object names for the session.

Forms Configuration File
If the application has a startup HTML file that references a Forms Web CGI 
configuration file formsweb.cfg (a common reference), you may encounter 
problems if you add record=names to the Startup file. 

In this situation, you should modify the configuration file.

To modify the configuration file to record object names:

 1 Go to the Forms Web CGI configuration file.

<PARAM name="serverArgs … fndnam=APPS record=names">
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 2 Define a new parameter in this file (see sample Web CGI configuration file 
below for this change).

 3 Open the startup HTML file and locate PARAM NAME="serverArgs". 

 4 Add the variable name as an argument to the ServerArgs parameter, for 
example, record=%xrecord%.

 5 Alternatively, you can edit the basejini.htm file in Oracle Forms installation 
directory. This file is the default HTML file for running a form on the web 
using JInitiator-style tags to include the Forms applet. In the basejinin.hmt 
file add the following line to the parameter definitions:

In the <EMBED> tag, add the following line:

The drawback in editing this file instead of the servlet configuration file 
formsweb.cfg, is that this file is replaced when you reinstall Oracle Forms. 
To avoid this, you can create a copy of the basejini.htm file and store it at 
another location. In the servlet configuration file, edit the 
baseHTMLJinitiator parameter to point to the new file.

serverApp=forecast
serverPort=9001
serverHost=easgdev1.dats.ml.com
connectMode=socket
archive=f60web.jar
archive_ie=f60all.cab
xrecord=names

<PARAM NAME="serverArgs" VALUE="module=%form% userid=%userid% 
%otherParams% record=%xrecord%">

<PARAM NAME="recordFileName" VALUE="%recordFileName%">

serverApp="%serverApp%"
logo="%logo%"
imageBase="%imageBase%"
formsMessageListener="%formsMessageListener%"
recordFileName="%recordFileName%"
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Oracle Applications via the Personal Home Page 

When launching Oracle Forms 6i applications by logging in through the 
Personal Home Page, you must set several system profile options at the user 
level. It is desirable to pass such variables at the user level, and not at the site 
level, where it will affect all users. 

To configure the "ICX: Forms Launcher" profile: 

 1 Sign on to the application and select the "System Administrator" 
responsibility.

 2 Select Profile/System from the Navigator menu. 

 3 Within the Find System Profile Values form: 

 a Select the Display:Site option

 b Users = <your user logon> (i.e. operations, mfg, and so on) 

 c Enter Profile =%ICX%Launch% 

 d Click Find. 

 4 Update the User value to the ICX:Forms Launcher profile: 

➤ If no parameter has been passed to the URL, append the following string 
to the end of the URL of the user value: ?play=&record=names

➤ If a parameter has been passed to the URL, append the following string to 
the end of the URL of the user value: &play=&record=names

 5 Save the transaction. 

 6 Log out of the Oracle Forms session. 

 7 Log out of the Personal Home Page session. 

 8 Sign on again via the Personal Home Page using your username. 

If you were unable to update the ICX: Forms Launcher profile option at the 
user level, open the Application Developer responsibility and select the 
Updatable option for the ICX_FORMS_LAUNCHER profile. 
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The first parameter passed to the URL, must begin with a question mark (?). 
You pass all subsequent parameters with an ampersand (&). In most cases, 
the URL already contains parameters, which you can identify by searching 
for a question mark. 

Using Oracle NCA Vuser Functions

VuGen records typical NCA business processes and generates Oracle NCA-
specific functions. The functions use an nca prefix.

The NCA functions are divided into the following categories: Button Object, 
Connection, Combo Box Object, Edit and Edit Box Object, Flexfield 
Window, Java Object, List Object, Menu Object, Message Object, Object, 
Response Object, Scroll Object, Session, Tab Object, Tree Object, and 
Window Object Functions.

You can also manually program any of the functions into your Vuser script. 
In text view, you can manually add new functions utilizing the Intellisense 
and Complete Function features. In Tree view, choose Insert > New Step and 
select the desired step. 

For more information about the Oracle NCA Vuser functions, refer to the 
Online Function Reference (Help > Function Reference).

You can further enhance your script with C Vuser functions such as 
lr_output_message and lr_rendezvous. For information on using these 
functions, see “Enhancing Vuser Scripts” in Volume I-Using VuGen. 
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Understanding Oracle NCA Vusers

When you create an Oracle NCA Vuser script, VuGen records all of the NCA 
communication between the client and the application server. While you 
record, VuGen generates context sensitive functions. These functions 
describe your actions on the database in terms of GUI objects (such as 
windows, lists, and buttons). As you record, VuGen inserts the context 
sensitive functions into the Vuser script. 

After you finish recording, you can modify the functions in your script, or 
add additional functions to enhance it. For information about enhancing 
Vuser script, see “Enhancing Vuser Scripts” in Volume I-Using VuGen. For a 
list of the available Oracle NCA Vuser functions, see “Using Oracle NCA 
Vuser Functions” on page 762. For details of these functions, see the Online 
Function Reference (Help > Function Reference).

In the following segment, the user selected an item from a list 
(nca_list_activate_item), pressed a button (nca_button_press), retrieved a 
list value (nca_lov_retrieve_items), and performed a click in an edit field 
(nca_edit_click). The logical names of the objects are the parameters of 
these functions. 

… 
nca_lov_select_item("Responsibilities","General Ledger, Vision Operations");
nca_list_activate_item("FNDSCSGN.NAVIGATOR.LIST.0","+ Journals");
nca_list_activate_item("FNDSCSGN.NAVIGATOR.LIST.0","       Enter");
nca_button_press("GLXJEENT.TOOLBAR.LIST.0");
nca_lov_find_value("Batches","");
nca_lov_retrieve_items("Batches",1,9);
nca_lov_select_item("Batches","AR 1020 Receivables 2537: A 1020");
nca_edit_click("GLXJEENT.FOLDER_QF.BATCH_NAME.0");
…
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In certain tests, such as those performed on Oracle Configurator 
applications, information returned by one function is required throughout 
the session. VuGen automatically saves the dynamic information to a 
parameter, by inserting a web_reg_save_param function into the script. In 
the following example, the connection information is saved to a parameter 
called NCAJServSessionID. 

In the above example, the right boundary is \r. The actual right boundary 
may differ between systems.

Configuring Oracle NCA Run-Time Settings

Before running your script, you can set the run-time settings to allow the 
script to accurately emulate a real user. For information on the general run-
time settings for all protocols, such as think time, pacing, and logging, see 
“Configuring Run-Time Settings” in Volume I-Using VuGen. For network 
speed related settings, see “Configuring Network Run-Time Settings” in 
Volume I-Using VuGen.

The following section describes the run-time settings specific to Oracle NCA 
Vusers. These run-time setting allow you to indicate the communication 
parameters. 

web_reg_save_param ("NCAJServSessionId", "LB=\r\n\r\n", "RB=\r",
LAST);

web_url("f60servlet", 
"URL=http://usscifforms05.sfb.na/servlet/f60servlet\?config
=mult", LAST);
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Configuring Oracle NCA Client Emulation Run-Time 
Settings
You can configure several network settings to accurately emulate an Oracle 
NCA client. 

You can set the following options:

Socket Mode

The communication to and from the client is performed on a socket level—
not on the higher HTTP level.

Timeout (seconds): The time that an Oracle NCA Vuser waits for a response 
from the server. The default value of -1 disables the timeout and the client 
waits indefinitely.
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Pragma Mode 

In Pragma mode, communication is carried out in the Oracle-defined 
Pragma mode. This communication level, above the HTTP and Servlet 
levels, is characterized by the periodic sending of messages. In this mode, 
the client recognizes that the server cannot respond with data immediately. 
The server sends messages at given intervals until it is able to send the 
requested data. 

➤ Max Retries. Indicates the maximum number of IfError messages the 
client will accept from the server before issuing an error. IfError messages 
are the periodic messages the server sends to the client, indicating that it 
will respond with the data as soon as it is able. 

➤ Retry Interval. Defines the interval between retries in the case of IfError 
messages. 

➤ Include retry intervals in transaction. Includes the interval between 
retires time, as part of the transaction duration time. 

For information about recording in Pragma mode, see “Recording in Pragma 
Mode” on page 774.

Heartbeat

You can enable or disable the heartbeat sent to the Oracle server. The 
heartbeat verifies that there is proper communication with the server. If you 
are experiencing a heavy load on the Oracle NCA server, disable the 
heartbeat. If you enable the heartbeat, you can set the frequency of how 
often heartbeat messages are sent to the server.

➤ Enable Heartbeat. By default, a heartbeat signal is sent to the server. To 
disable it, clear the check box.

➤ Frequency. The frequency of the heartbeat signal. The default is 120 
seconds.

Forms

You can specify the version of the Oracle Forms server detected during 
recording. 

➤ Version. Modify this setting only if the server was upgraded since the 
recording.
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Diagnostic

This section lets you provide information about diagnostic modules for the 
database layer of Oracle Applications.

➤ Application version. The version of Oracle Application. This option is 
relevant when using Oracle Application—not a custom Oracle NCA 
application. It is only required when using Oracle database breakdown. 

To set the Client Emulation settings:

 1 Open the Run-Time Settings dialog box. Choose Vuser > Run-Time Settings 
or click the Run-Time Settings button on the VuGen toolbar. 

 2 Select the Oracle NCA:Client Emulation node from the Run-Time settings 
tree. 

 3 Set the network timeout value in seconds. To instruct the client to wait 
indefinitely for a server response, use the default value of -1.

 4 When working in Pragma mode, specify the number of retries Max Retries, 
(IfError messages) for the client to accept before issuing an error. The default 
is 5.

 5 To enable the sending a a heartbeat to the Oracle NCA server, select the 
Enable Heartbeat option. In the next line, specify a frequency in seconds for 
the sending of the heartbeat. The default is 120 seconds. 

 6 Click OK to accept the settings and run the script.

Testing Oracle NCA Applications

The following sections contain several tips for testing secure Oracle NCA 
applications and servlets. 

Testing Secure Oracle NCA Applications

➤ When selecting the protocols to record, you only need to select Oracle 
NCA—not Web Protocol from the protocol list. VuGen records the security 
information internally and therefore does not need the explicit Web 
functions. 
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➤ In the Port Mapping recording options, delete any existing entries for port 
443 and create a new entry for the Oracle server name:

Service ID: HTTP
Target Server: Oracle Forms Server IP address or long host name
Target Port: 443
Connection Type: SSL
SSL Version: Active SSL version. If in doubt, select SSL 2/3.

For more information, see “Configuring the Port Mappings” in Volume I-
Using VuGen. 

➤ If you encounter problems when replaying an NCA HTTPS script during the 
nca_connect_server command, insert the following function at the 
beginning of the script. 

web_set_sockets_option("SSL_VERSION","3");

Testing Servlets and other Oracle NCA Applications
Certain NCA sessions use servlets: 

➤ the Forms Listener servlet

➤ applications or modules that use both NCA and HTTP communications, 
such as the Oracle Configurator

➤ the initializing of the NCA application (downloading the applet, jar, and 
gif files)
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When recording servlets, you must record both Oracle NCA and Web 
functions. You can do this by initially creating a multi-protocol script. 
Alternatively, if you created a single protocol script for Oracle NCA, open 
the General:Protocols node in the Recording Options, and enable the Web 
protocol. Then you can begin recording.

If you are unsure whether your application uses servlets, check the 
default.cfg file in the script directory. Locate the entry

UseServletMode=

If the value is 1 or 2, then servlets are being used and you must enable HTTP 
recording in addition to Oracle NCA. 

If you already recorded a script, you can regenerate the code automatically 
to include the Web functions without having to re-record. Choose Tools > 
Regenerate Script, and select the Web protocol in the Protocols section. 

Determining the Recording Mode
When recording Oracle NCA scripts: VuGen automatically determines the 
correct connection mode: HTTP or Socket mode. Generally, you are not 
required to modify any of the recording settings as VuGen auto-detects the 
system configuration. In systems where the standard port mapping are 
reserved by other applications, you may need to modify the Port Mapping 
settings, depending on the recording mode. 
769



Chapter 48 • Creating Oracle NCA Vuser Scripts
You can determine the recording mode in one of the following ways:

➤ When using the NCA application, open the Java Console. 

The connectMode entry indicates HTTP, HTTPS, or socket.

➤ After recording an NCA session, open the default.cfg file in the Vuser 
directory and check the value of the UseHttpConnectMode entry. 

When defining a new port mapping int he Server Entry dialog box, use a 
Service ID of HTTP for HTTP or HTTPS modes. For Socket mode, use a 
Service ID of NCA.

For more information about Port Mapping settings, see “Configuring the 
Port Mappings” in Volume I-Using VuGen.

Recording Trace Information for Oracle DB
To debug your script, you can use the Oracle DB breakdown graphs. To 
gather data for this graph, you turn on the trace mechanism before running 
the script.

To manually turn on the tracing mechanism, use the 
nca_set_custom_dbtrace function. For more information, see the Online 
Function Reference (Help > Function Reference).

proxyHost=null 
proxyPort=0 
connectMode=HTTP 
Forms Applet version is: 60812

[HttpConnectMode]
UseHttpConnectMode= 2 
// 0 = socket 1 = http 2 = https
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Correlating Oracle NCA Statements for Load Balancing

VuGen supports load balancing for multiple application servers. You 
correlate the HTTP return values with the nca_connect_server parameters. 
The Vuser then connects to the relevant server during test execution, 
applying load balancing. 

To correlate statements for load balancing: 

 1 Record a multi-protocol script. 

Record a multi-protocol script for Oracle NCA and Web Protocols. Perform 
the desired actions and save the script.

 2 Define parameters for host and host arguments.

Define two variables, serverHost and serverArgs, for parameterization:

 3 Assign values to serverHost and serverArgs:

web_url("step_name", "URL=http://server1.acme.com/test.htm", LAST);

 4 Modify the nca_connect_server statement from: 

nca_connect_server("199.203.78.170",
9000"/*version=107*/, "module=e:\\appsnca…fndnam=apps "); 

to:

nca_connect_server("< serverHost >", "9000"/*version=107*/, "< 
serverArgs >");

web_set_max_html_param_len("512");
web_reg_save_param("serverHost", "NOTFOUND=ERROR",
"LB=<PARAM name=\"serverHost\" value=\"","RB=\">", LAST); 

web_reg_save_param("serverArgs", "NOTFOUND=ERROR",
"LB=<PARAM name=\"serverArgs\" value=\"","RB=\">", LAST); 
771



Chapter 48 • Creating Oracle NCA Vuser Scripts
The script should now look like this:

Additional Recommended Correlations

When recording an Oracle NCA session, VuGen records dynamic values—
values that change for each record and replay session. Two common 
dynamic arguments are icx_ticket and JServSessionIdroot.

icx_ticket
The icx_ticket variable, is part of the information sent in the web_url and 
nca_connect_server functions:

web_set_max_html_param_len("512");
web_reg_save_param("serverHost", "NOTFOUND=ERROR",
"LB=<PARAM name=\"serverHost\" value=\"","RB=\">", LAST); 

web_reg_save_param("serverArgs", "NOTFOUND=ERROR",
"LB=<PARAM name=\"serverArgs\" value=\"","RB=\">", LAST);
web_url("step_name", "URL=http://server1.acme/test.htm", LAST);

nca_connect_server("<serverHost>","9000"/*version=107*/,"<serverArgs>");

web_url("fnd_icx_launch.runforms", 
"URL=http://ABC-
123:8002/pls/VIS/fnd_icx_launch.runforms\?ICX_TICKET=5843A55058947ED3&RES
P_APP=AR&RESP_KEY=RECEIVABLES_MANAGER&SECGRP_KEY=STANDARD", 
LAST);
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This icx_ticket value is different for each recording. It contains cookie 
information sent by the client. To correlate your recording, add 
web_reg_save_param before the first occurrence of the recorded icx_ticket 
value:

Note: The left and right boundaries of web_reg_save_param may differ 
depending on your application setup. 

JServSessionIdroot
The JServSessionIdroot value is a cookie that the application sets to store the 
session ID. In most cases, VuGen automatically correlates this value and 
inserts a web_reg_save_param function. If VuGen did not add this function 
automatically, you add it manually, replacing all of its occurrences with the 
parameter name. 

To identify the value that you need to correlate, open the Execution log 
(View > Output Window) and locate the response body. 

web_reg_save_param("icx_ticket", "LB=TICKET=", "RB=&RES", LAST); 

… 

web_url("fnd_icx_launch.runforms", 
"URL=http://ABC-
123:8002/pls/VIS/fnd_icx_launch.runforms\?ICX_TICKET=<icx_ticket>&RESP_APP=
AR&RESP_KEY=RECEIVABLES_MANAGER&SECGRP_KEY=STANDARD", LAST);

vuser_init.c(8):     Set-Cookie: JServSessionIdroot=my1sanw2n1.JS4; path=/\r\n
vuser_init.c(8):     Content-Length: 79\r\n
vuser_init.c(8):     Content-Type: text/plain\r\n
vuser_init.c(8):     \r\n
vuser_init.c(8): 81-byte response body for "http://ABC-
123/servlet/oracle.forms.servlet.ListenerServlet?ifcmd=getinfo&ifhost=mercury&ifip=12
3.45.789.12" (RelFrameId=1)
vuser_init.c(8):     
/servlet/oracle.forms.servlet.ListenerServlet?JServSessionIdroot=my1sanw2n1.JS4\r\n
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To correlate this dynamic value, insert a web_reg_save_param function 
before the first occurrence and then replace the variable value with the 
parameter name throughout the script. In this example, the right and left 
boundaries are \r and \n, but you should check your specific environment 
to determine the exact boundaries in your environment.

Recording in Pragma Mode

The client side of the Oracle NCA Vuser can be configured to send an 
additional header to the server named Pragma. The header is a counter that 
behaves in the following way: the initial message of the NCA handshake has 
a value of 1. 

The messages that follow the handshake are counted, beginning with 3. The 
counter is incremented by 1 for each message sent by the client.

If the message received from the server is the type plain\text and the body of 
the message begins with ifError:#/#00, the client sends a 0 byte message to 
the server and the Pragma value changes its sign to a minus. This sign 
changes back after the client succeeds in receiving the information from the 
server.

web_reg_save_param("NCAJServSessionId","LB=\r\n\r\n","RB=\r","ORD=1",LAST)
;

web_url("f60servlet", 
"URL= http://ABC-"123/servlet/oracle.forms.servlet.ListenerServlet?ifcmd=getinfo&" 

"ifhost=mercury&ifip=123.45.789.12", LAST);

web_url("oracle.forms.servlet.ListenerSer", 
"URL=http://ABC-123<NCAJServSessionId>?ifcmd=getinfo&" 

"ifhost=mercury&ifip=123.45.789.12", LAST);
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Recording of the Pragma header is only supported in the multi-protocol 
mode (Oracle NCA and Web). You can identify the Pragma mode within the 
script’s default.cfg file. When operating in Pragma mode, the 
UseServletMode is set to 2.

For information on the Pragma related run-time settings, see “Configuring 
Oracle NCA Client Emulation Run-Time Settings” on page 765.

To identify the Pragma mode, you can perform a WinSocket level recording 
and check the buffer contents. In the first example, the buffer contains the 
Pragma values as a counter:

[HttpConnectMode]
UseHttpConnectMode=1
RelativeURL=<NCAJServSessionId>
UseServletMode=2

send buf108
"POST /ss2servlet/oracle.forms.servlet.ListenerServlet?JServSessionIdss2ser"
"vlet=gk5q79uqy1 HTTP/1.1\r\n"
"Pragma: 1\r\n"
...

send buf110
"POST /ss2servlet/oracle.forms.servlet.ListenerServlet?JServSessionIdss2ser"
"vlet=gk5q79uqy1 HTTP/1.1\r\n"
"Pragma: 3\r\n"
...
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In the following example, the buffer contains the Pragma values as an error 
indicator: 

recv buf129 281
"HTTP/1.1 200 OK\r\n"
"Date: Tue, 21 May 2002 00:03:48 GMT\r\n"
"Server: Oracle HTTP Server Powered by Apache/1.3.19 (Unix) mod_fastcgi/2.2"
".10 mod_perl/1.25 mod_oprocmgr/1.0\r\n"
"Content-Length: 13\r\n"
"Content-Type: text/plain\r\n"
"\r\n"
"ifError:8/100"

send buf130
"POST /ss2servlet/oracle.forms.servlet.ListenerServlet?JServSessionIdss2ser"
"vlet=gk5q79uqy1 HTTP/1.1\r\n"
"Pragma: -12\r\n"
...
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Developing SAPGUI Vuser Scripts

In the growing field of ERP (Enterprise Resource Planning), SAP provides 
solutions allowing companies to manage all of their business processes. HP 
provides tools for testing SAP solution modules on both functional and load 
testing levels. This chapter discusses the solution for testing the SAPGUI for 
Windows client (SAPGUI Vuser). For information on testing solutions for 
mySAP Workplace and Portal clients, see Chapter 51, “Developing SAP-Web 
Vuser Scripts.”

This chapter includes:

 ➤  About Developing SAPGUI Vuser Scripts on page 778

 ➤  Checking your Environment for SAPGUI Vusers on page 779

 ➤  Creating a SAPGUI Vuser Script on page 790

 ➤  Recording a SAPGUI Vuser Script on page 791

 ➤  Setting the SAPGUI Recording Options on page 794

 ➤  Inserting Steps Interactively into a SAPGUI Script on page 797

 ➤  Understanding a SAPGUI Vuser Script on page 799

 ➤  Enhancing a SAPGUI Vuser Script on page 803

The following information only applies to the SAPGUI protocol.
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About Developing SAPGUI Vuser Scripts

This chapter discusses the solution for testing the SAPGUI for Windows 
client (SAPGUI Vuser). To test the SAPGUI user operating only on the client, 
use the SAPGUI Vuser type. To test a SAPGUI user that also uses a Web 
browser, use the SAP (Click and Script) protocol.

Before recording a session, verify that your modules and client interfaces are 
supported by VuGen. The following table describes the SAP client modules 
for SAP Business applications and the relevant tools:

Version 6.20 and later:

➤ For Functional Testing. Use the QuickTest Professional Add-in for 
mySAP.com client.

➤ For Load Testing. Use the SAPGUI or SAP (Click and Script) protocol to 
create a script in VuGen and run a scenario in the Controller. 

You use VuGen to record typical business processes. VuGen records SAPGUI 
for Windows client activity during SAP business processes, and generates a 
Vuser script. When you perform actions within the SAPGUI for Windows 
client, VuGen generates functions that describe this activity. Each function 
begins with a sapgui prefix. 

SAP module VuGen support

SAP Web Client or 
mySAP.com. 

Use the SAP-Web Vuser 
type.

SAPGUI for Windows. A Windows-based client, 
emulated by the SAPGUI 
Vuser. This also supports 
APO module recording 
(requires patch level 24 for 
APO 3.0).

SAPGUI for Windows and 
a web browser. 

Use the SAP (Click and 
Script) protocol.

SAPGUI for Java. This client is not 
supported.
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Checking your Environment for SAPGUI Vusers

The basic steps in checking and setting up your system for the recording of 
SAPGUI Vusers, are Checking the Patch Level and Enabling Scripting. Once 
your environment is configured properly, you can record a typical SAP 
session and replay it in VuGen. 

Checking the Patch Level
You can check the patch level of your SAPGUI for Windows client from the 
About box. The lowest patch level supported is 32.

To check the patch level:

 1 Invoke the SAPGUI logon window. Click the top left corner of the SAP 
Logon dialog box and choose About SAP Logon from the menu. 
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 2 The SAP version information dialog box opens. Verify that the Patch Level 
entry is 32 or higher.

Enabling Scripting
VuGen support for the SAPGUI for Windows client, is based on SAP's 
Scripting API. This API allows Vusers to interact with the SAPGUI client, 
receive notifications, and perform operations. 

The Scripting API is only available in recent versions of the SAP Kernel. In 
kernel versions that support scripting, the option is disabled by default. In 
order to use VuGen, first ensure that the SAP servers support the Scripting 
API, and enable the API on both the server and clients. For more 
information and to download patches, refer to the SAP OSS note #480149.

VuGen provides a utility that checks if your system supports scripting. The 
utility, VerifyScript.exe, is located on DVD in the Additional 
Components\SAP_Tools\VerifySAPGUI folder. For more information, refer 
to the file VerifyScripting.htm provided with this utility.

The following sections describe how to enable scripting. 

➤ Checking the Configuration

➤ Enabling Scripting on the SAP Application Server

➤ Enabling Scripting on SAPGUI 6.20 Client
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Checking the Configuration

The first step in enabling scripting is ensuring that the right kernel version is 
installed, and updating it if required. 

Check the table below, for the minimum kernel patch level required for your 
version of the SAP Application Server. If required, download and install the 
latest patch. 

Software 
Component

 Release
 Package 
Name

 Kernel Patch 
Level

SAP_APPL  31I  SAPKH31I96 Kernel 3.1I 
level 650

SAP_APPL  40B  SAPKH40B71 Kernel 4.0B 
level 903

SAP_APPL  45B  SAPKH45B49 Kernel 4.5B 
level 753

SAP_BASIS  46B  SAPKB46B37 Kernel 4.6D 
level 948

SAP_BASIS  46C  SAPKB46C29 Kernel 4.6D 
level 948

SAP_BASIS  46D  SAPKB46D17 Kernel 4.6D 
level 948

SAP_BASIS  610  SAPKB61012 Kernel 6.10 
level 360
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To check the kernel patch level:

 1 Log in to the SAP system

 2 Select System > Status

 3 Click the Other kernel information button (with the yellow arrow).
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 4 In the Kernel Information section, check the value of the Sup. Pkg. lvl.

If the level is lower than 948, you must download the latest kernel version 
and upgrade your existing one. Refer to the SAP OSS note #480149 for 
detailed instructions on how to perform this upgrade.
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To check the R/3 support packages:

 1 Log on to the SAP system and run the SPAM transaction.

 2 In the Directory section, select All Support Packages, and click the Display 
button.
784



Chapter 49 • Developing SAPGUI Vuser Scripts
 3 Verify that SAPKB46C29 is installed for SAP_BASIS, 4.6C. If it is installed, a 
green circle appears in the Status column.

If you do not have the OCS package installed, download it the from the 
www.sap.com Web site and install it. For more information, refer to the SAP 
OSS note #480149.
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Enabling Scripting on the SAP Application Server

A user with administrative permissions enables scripting by setting the 
sapgui/user_scripting profile parameter to TRUE on the application server. 
To enable scripting for all users, set this parameter on all application servers. 
To enable scripting for a specific group of users, only set the parameter on 
application servers with the desired access restrictions. 

To change the profile parameter:

 1 Open transaction rz11. Specify the parameter name sapgui/user_scripting 
and click Display. The Display Profile Parameter Attributes window opens.

If Parameter name is unknown appears in the status bar, this indicates that 
you are missing the current Support Package. Import the Support Package 
that corresponds to the SAP BASIS and kernel versions of the application 
server, as described in “Checking the Configuration” on page 781.
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 2 If Profile Val is FALSE, you need to modify its value. Click the Change value 
button in the toolbar. The Change Parameter Value window opens. Enter 
TRUE in the ProfileVal box and click the Save button. 

When you save the change, the window closes and ProfileVal is set to TRUE. 

 3 Restart the application server, since this change only takes effect when you 
log onto the system.

If the updated ProfileVal did not change, even after restarting the server, 
then the kernel of the application server is outdated. Import the required 
kernel patch, as specified in the section “Checking the Configuration” on 
page 781.
787



Chapter 49 • Developing SAPGUI Vuser Scripts
Note that the Profile Value may be dynamically activated in the following 
kernel versions, using transaction rz11, without having to restart the 
application server.

Enabling Scripting on SAPGUI 6.20 Client 

To allow VuGen to run scripts, you must also enable scripting on the 
SAPGUI client. You should also configure the client not to display certain 
messages, such as when a connection is established, or when a script is 
attached to the GUI process. 

To configure the SAPGUI client to work with VuGen:

➤ During installation. While installing the SAPGUI client, enable the SAP GUI 
Scripting option.

 Release
Kernel 
Version

 Patch Level

 4.6B, 4.6C, 4.6D  4.6D 972

 6.10  6.10 391

 6.20  all versions all levels
788



Chapter 49 • Developing SAPGUI Vuser Scripts
➤ After installation. Suppress warning messages. Open the Options dialog box 
in the SAPGUI client. Select the Scripting tab and clear the following 
options:

 1 Notify when a script attaches to a running GUI

 2 Notify when a script opens a connection

You can also prevent these messages from popping up by setting the values 
WarnOnAttach and WarnOnConnection in the following registry key to 0:

HKCU\SOFTWARE\SAP\SAPGUI Front\SAP Frontend Server\Security. 
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Creating a SAPGUI Vuser Script

The first step in creating a SAPGUI Vuser script is choosing the Vuser and 
script type. The SAP Vuser type, SAPGUI is under the ERP/CRM category. You 
can create either a single or multi-protocol Vuser script.

To create a SAPGUI Vuser script:

 1 Invoke VuGen and choose File > New. 

 2 To record a standard SAPGUI client session (with no browser controls), 
create a single-protocol Vuser script using the SAPGUI type Vuser. 

 3 To record a SAPGUI session that uses browser controls, create a multi-
protocol Vuser script. Specify both the SAPGUI and SAP-Web Vuser types. 
This allows VuGen to record Web-specific functions when encountering the 
browser controls.

 4 Click OK to open the Vuser script.
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Recording a SAPGUI Vuser Script

After creating an empty script, you set the recording options and then 
record your SAPGUI session. VuGen generates a script corresponding to your 
actions within the client.

To begin recording a SAPGUI script:

 1 If the Start Recording dialog box was not opened, click the Start Recording 
button. The Start Recording dialog box opens.

 2 VuGen detects and fills in the relevant information:

➤ Program to record. VuGen locates the saplogon.exe file in the SAP client 
installation.

➤ Working Directory. For applications that require you to specify a working 
directory, specify it here. The required information differs, depending on 
the type of Vuser script.

➤ Record into Action. Select the section into which you want to record. 
Initially, the available sections are vuser_init, Action1, and vuser_end

 3 Click OK and begin recording. 
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Recording at the Cursor
VuGen also allows you to record actions into an existing script. You may 
choose to record into an existing script for several reasons:

➤ You made a mistake in the actions that you performed during recording.

➤ Your actions were correct, but you need to add additional information such 
as the handling of popup windows. For example the SAP server may issue an 
inventory warning, which did not apply during the recording session.

This feature, called Recording at the Cursor, lets you insert new actions or 
replace existing actions. When you begin Recording at the Cursor, VuGen 
prompts you with two options: 

➤ Insert steps into action. Inserts the newly recorded steps at the cursor 
without overwriting any existing steps. The new segment is enclosed 
with comments indicating the beginning and end of the added section. 
This option is ideal for handling occasional popup windows that were 
not present during the recording

➤ Overwrite the rest of the script. Replaces all steps from the point of the 
cursor onward. This option overwrites the remainder of the current 
Action and deletes all other Actions. It does not affect the vuser_init or 
vuser_end sections. 

After you choose one of the Recording at the Cursor options, VuGen replays 
the script from the beginning until the cursor location. Then it opens the 
Recording floating toolbar and begins recording. If you use the Recording at 
the Cursor feature, the Regenerate Script tool becomes disabled.

Note: To record at the cursor, you need to click in the left margin of the 
VuGen editor, immediately before an existing function.

// Recording at the cursor - Begin 
sapgui_select_active_connection("con[0]");
sapgui_select_active_session("ses[0]");
sapgui_select_active_window("wnd[0]");

//Recording at the cursor - End
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To Record at the Cursor:

 1 Open Script view (View > Script view) and click in the left margin adjacent 
to an existing function.

 2 Click the Recording at the Cursor button. VuGen prompts you to make a 
selection.

 3 Select Insert steps into action or Overwrite the rest of the script. Click OK. 
VuGen replays the script until the point of the cursor. 

 4 Wait for the Recording floating toolbar to open. Then begin performing 
actions in the SAPGUI client, switching between sections and actions as 
required.

 5 Click the Stop button to end the recording session.
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Setting the SAPGUI Recording Options 

You use the recording options to set your SAP-related preferences for the 
recording session. To open the Recording Options dialog box, choose Tools > 
Recording Options or click Options in the Start Recording dialog box. The 
keyboard shortcut is CTRL+F7.

You can set recording options in the following areas:

➤ SAPGUI General Recording Options 

➤ SAPGUI Code Generation Recording Options

➤ SAPGUI Auto Logon Recording Options

If you are recording a multi-protocol Vuser script with a SAP-Web Vuser 
type, see Chapter 38, “Setting Recording Options for Internet Protocols” for 
additional recording options.

SAPGUI General Recording Options
You use these recording options to set your general preferences during the 
recording session in the following areas:

➤ Capture Screen Snapshots. Indicates how to save the snapshots of the 
SAPGUI screens as they appear during recording: ActiveScreen snapshots, 
Regular snapshots, or None. ActiveScreen snapshots provide more 
interactivity and screen information after recording, but they require more 
resources.
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➤ Process Context menus by text. Instructs VuGen to process context menus 
by their text, generating a 
sapgui_toolbar_select_context_menu_item_by_text function. When 
disabled, VuGen processes context menus by their IDs, an advantage when 
working with Japanese characters. In the latter case, VuGen generates a 
sapgui_toolbar_select_context_menu_item for context menus.

To set the General recording options:

 1 Open the Recording Options dialog box and select the SAPGUI:General 
node.

 2 For the Capture screen snapshots option, indicate how to save the 
snapshots of the SAPGUI screens.

 3 Select the method by which to process context menus: Enable Process 
context menus by text, or disable it to process context menus by their IDs.

 4 Click OK to accept the settings and close the dialog box. 

SAPGUI Code Generation Recording Options
The following recording options indicate your code generation preferences.

To set the Code Generation recording options:

 1 Open the Recording Options dialog box and select the SAPGUI:Code 
Generation node.
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 2 Select Generate logon operation as a single step to instruct VuGen to 
generate a single sapgui_logon method for all of the logon operations. This 
helps simplify the code. If you encounter login problems, disable this 
option.

 3 To generate Fill Data steps for table and grid controls—instead of separate 
steps for each cell, select Generate Fill Data Steps.

 4 To create a more compact and cleaner script, select Always generate Object 
IDs in header file which places the Object IDs in a separate header file 
instead of in the script. When you disable this option, VuGen generates the 
IDs according to the specified string length in the general script setting. 
Note that disabling this option only increases readability—there is no 
difference in overhead.

 5 Click OK to accept the settings and close the dialog box.

SAPGUI Auto Logon Recording Options
You set these recording options to log on automatically when you begin 
recording. The logon functions are placed in the vuser_init section of the 
script. The server name list contains all of the servers on the SAP Logon 
description list

To enable and set the Auto Logon recording options:

 1 Open the Recording Options dialog box and select the SAPGUI:Auto Logon 
node.

 2 Select Enable Auto logon. 

 3 Enter the Login information:
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➤ the SAP Server name

➤ the User name for the SAP server 

➤ the Password for the SAP server

➤ the Client name by which the SAP server identifies the client

➤ the interface Language

 4 Click OK to accept the settings and close the dialog box. 

Inserting Steps Interactively into a SAPGUI Script

After recording, you can manually add steps to the script in either Script 
view and Tree View. For information about adding steps from the various 
views, see “Introducing Service Test” in Volume I-Using VuGen. 

In addition to manually adding new functions, you can add new steps 
interactively for SAPGUI Vusers, directly from the snapshot. Using the right-
click menu, you can add object-related steps. 

When adding a step from within a snapshot, VuGen uses the Active Screen 
capability and determines the ID of each object in the SAPGUI client 
window (unless you disabled Active Screen snapshots in the SAPGUI 
General Recording Options).
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To determine which objects were recognized by VuGen, you move the 
mouse over the snapshot. VuGen draws a box around the objects as you pass 
over them and displays a tool tip with the object’s Control ID. In the 
following example, the selected active object is the NORMAL CENTER button.

When you add a step while holding the mouse over a recognized object, 
VuGen automatically inserts the Control ID of that object into the relevant 
field of the Properties dialog box. For example, if you add a Press Button 
step, for the NORMAL CENTER button as shown above, the Properties box 
displays the following ID:

To insert a step interactively for a specific object:

 1 Click within the Snapshot window.

 2 Move the mouse over the object for which you want to add a function. 
Make sure that VuGen recognizes the object and encloses it with a box. 
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 3 Select Insert New Step from the right-click menu. The Insert Step box opens.

 4 Choose a step from the menu. The step’s Properties dialog box opens, with 
the Control ID of the object when relevant. 

 5 Enter a name for the object in the Description box. Click OK. VuGen inserts 
the new step after the selected step. 

 6 To get the Control ID of the object for the purpose of pasting it into a 
specific location, select Copy Control ID from the right-click menu. VuGen 
places it on the clipboard. You can past it into a Properties box or directly 
into the code from the Script view.

Understanding a SAPGUI Vuser Script

The SAPGUI Vuser script typically contains several SAP transactions which 
make up a business process. A business process consists of functions that 
emulate user actions. Open the tree view to see each user action as a Vuser 
script step.

The following example shows a typical recording of a SAPGUI client. The 
first section, vuser_init, contains the opening of a connection and a logon.
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Note that the Open Connection step uses one of the connection names in 
the SAP Logon Descriptions list. If the specified connection name is not in 
the list, the Vuser looks for a server with that name.

In the following section, the functions emulate typical user operations such 
as menu selection and the setting of a check box.
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The final section, vuser_end, illustrates the logoff procedure. 

When recording a multi- protocol script for both SAPGUI and Web, VuGen 
generates steps for both protocols. In the Script view, you can view both 
sapgui and web functions. 
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The following example illustrates a multi-protocol recording in which the 
SAPGUI client opens a Web control. Note the switch from sapgui to web 
functions.

sapgui_tree_double_click_item("Use as general WWW browser, REPTITLE", 
"shellcont/shell", 
"000732", 
"REPTITLE", 
BEGIN_OPTIONAL, 

"AdditionalInfo=sapgui1020", 
END_OPTIONAL);

...
sapgui_set_text("", 
"http:\\\\yahoo.com", 
"usr/txtEDURL", 
BEGIN_OPTIONAL, 

"AdditionalInfo=sapgui1021", 
END_OPTIONAL);

...
web_add_cookie("B=7pt5cisv1p3m2&b=2; DOMAIN=www.yahoo.com");

web_url("yahoo.com",
"URL=http://yahoo.com/",
"Resource=0",
"RecContentType=text/html",
"Referer=",
"Snapshot=t1.inf",
"Mode=HTML",
EXTRARES,

"URL=http://srd.yahoo.com/hpt1/ni=17/ct=lan/sss=1043752588/t1=1043752575385/d1
=1251/d2=1312/d3=1642/d4=4757/0.4097009487287739/*1", 
"Referer=http://www.yahoo.com/", ENDITEM,

LAST);
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Enhancing a SAPGUI Vuser Script

After you examine the recorded Vuser script, you enhance it in the 
following ways:

➤ Transactions. Inserting transactions, rendezvous points, and control-flow 
structures into the script. For details, see “Enhancing Vuser Scripts” in 
Volume I-Using VuGen.

➤ Verification. Insert SAPGUI verification functions to verify the current state 
of SAPGUI objects. For details, see Adding Verification Functions.

➤ Retrieve information. Insert SAPGUI functions to verify the current value of 
SAPGUI objects. You use the sapgui_get_xxx functions to retrieve 
information. For more information, see “Retrieving Information” on 
page 804.

Define parameters (optional). Define parameters for the fixed-values 
recorded into your Vuser script. By substituting fixed-values with 
parameters, you can repeat the same business process many times using 
different values. For details, see “Creating Parameters” in Volume I-Using 
VuGen.

Adding Verification Functions
When working with optional or dynamic windows or frames, you can use 
verification functions to determine if the window or object is available. An 
optional window is a window that does not consistently open during the 
SAP session. This function allow the Vuser script to continue running even if 
an optional window opens or an exception occurs. 

The first example checks if a window is available. If the window is available, 
the Vuser closes it before continuing.

if (!sapgui_is_object_available("wnd[1]"))
sapgui_call_method("{ButtonID}", 

"press", 
LAST, 
AdditionalInfo=info1011");

sapgui_press_button(.....)
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The next example illustrates a dynamic object in the ME51N transaction. 
The Document overview frame is optional, and can be opened/closed by the 
Document overview on/off button. 

The code checks the text on the Document overview button. If the text on 
the button shows Document overview on, we click the button to close the 
Document overview frame.

Retrieving Information
When working with SAGUI Vusers, you can retrieve the current value of a 
SAPGUI object using the sapgui_get_<xxx> functions. You can use this 
value as input for another business process, or display it in the output log. 

Retrieving Status Bar Information

The following example illustrates how to save part of a status bar message in 
order to retrieve the order number. 

To retrieve the order number from the status bar:

 1 Navigate to the point where you want to check the status bar text, and select 
Insert > New Step. Choose the sapgui_status_bar_get_type function. This 
verifies that the Vuser can successfully retrieve text from the status bar.

 2 Insert an if statement that checks if the previous statement succeeded. If so, 
save the value of the argument using sapgui_status_bar_get_param. 

if(sapgui_is_object_available("tbar[1]/btn[9]"))
{

sapgui_get_text("Document overview on/off button", 
"tbar[1]/btn[9]",
"paramButtonText",
LAST);

if(0 == strcmp("Document overview off", lr_eval_string("{paramButtonText}")))
sapgui_press_button("Document overview off", 

"tbar[1]/btn[9]", 
BEGIN_OPTIONAL, 

"AdditionalInfo=sapgui1013", 
END_OPTIONAL);

}
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This sapgui_status_bar_get_param function saves the order number into a 
user-defined parameter. In this case, the order number is the second index of 
the status bar string. 

During test execution, the Execution log indicates the value and parameter 
name:

Saving Date Information

When creating scripts that use dates, your script may not run properly. For 
example, if you record the script on June 2, and replay it on June 3, the date 
fields will be incorrect. Therefore, you need to save the date to a parameter 
during text execution, and use the stored value as input for other date fields. 
To save the current date or time during script execution, use the 
lr_save_datetime function. Insert this function before the function 
requiring the date information. Note that the format of the date is specific 
to your locale. Use the relevant format within the lr_save_datetime 
function. For example, for month.day.year, specify "%m.%d.%Y".

sapgui_press_button("Save (Ctrl+S)", 
"tbar[0]/btn[11]", 
BEGIN_OPTIONAL, 

"AdditionalInfo=sapgui1038", 
END_OPTIONAL);

sapgui_status_bar_get_type("Status");
if(0==strcmp(lr_eval_string("{Status}"),"Success"))
 sapgui_status_bar_get_param("2", " Order_Number ");

Action.c(240): Pressed button " Save (Ctrl+S)"
Action.c(248): The type of the status bar is "Success"
Action.c(251): The value of parameter 2 in the status bar is "33232"
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In the following example, lr_save_datetime saves the current date. The 
sapgui_set_text function uses this value to set the delivery date for two days 
later.

lr_save_datetime("%d.%m.%Y", DATE_NOW + (2 * ONE_DAY), 
"paramDateTodayPlus2");

sapgui_set_text("Req. deliv.date", 
"{paramDateTodayPlus2}",
"usr/ctxtRV45A-KETDAT", 
BEGIN_OPTIONAL, 

"AdditionalInfo=sapgui1025", 
END_OPTIONAL);
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Developing SAP (Click and Script) Vusers 

VuGen allows you to create scripts that emulate SAP applications over the 
Web.

This chapter includes:

 ➤  About Developing SAP (Click and Script) Vuser Scripts on page 807

 ➤  Recording a SAP (Click and Script) Session on page 808

 ➤  Understanding SAP (Click and Script) Scripts on page 808

The following information applies only to SAP (Click and Script) Vuser 
scripts.

About Developing SAP (Click and Script) Vuser Scripts

VuGen can create test scripts for SAP Enterprise portal7 and SAP ITS 
6.20/6.40 environments using specialized test objects and methods that 
have been customized for SAP. The objects are APIs based on HP QuickTest 
support for SAP.

As you record a test or component on your SAP application, VuGen records 
the operations you perform. VuGen recognizes special SAP Windows objects 
such as frames, table controls, iViews, and portals. 

VuGen supports recording for the following SAP controls: button, checkbox, 
drop-down menu, edit field, iview, list, menu, navigation bar, OK code, 
portal, radio group, status bar, tab strip, table, and tree view.
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Recording a SAP (Click and Script) Session

To create a Vuser script that emulates SAP Web applications, you choose the 
SAP (Click and Script) protocol type from the ERP category. To begin 
recording, click the Record button and perform typical actions in your SAP 
Web application. You should record your sign-in information in the 
vuser_init section, and the sign off process in the vuser_end section. For 
further information about creating and recording a script, see “Recording 
with VuGen” in Volume I-Using VuGen.

You can set event related recording options. For more information, see 
Chapter 37, “Recording with Click and Script.”

If you require a lower level script, or if you need to record on unsupported 
SAP control, use the SAP-Web protocol in the ERP category.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

Understanding SAP (Click and Script) Scripts

VuGen uses the control handler layer to create the effect of an operation on 
a GUI control. During recording, when encountering one of the supported 
SAP objects, VuGen generates a function with an sap_xxx prefix.
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In the following example, a user selected the User Profile tab. VuGen 
generated a sap_portal function. 

Note: When you record a SAP (Click and Script) session, VuGen generates 
standard Web (Click and Script) functions for objects that are not SAP-
specific. You do not need to explicitly specify the Web protocol. In the 
example above, VuGen generated a web_text_link function when the user 
clicked the Personalize button.

web_browser("Close_2", 
"Snapshot=t7.inf", 
DESCRIPTION, 
"Ordinal=2", 
ACTION, 
"UserAction=Close", 
LAST);

lr_think_time(7);

web_text_link("Personalize", 
"Snapshot=t8.inf", 
DESCRIPTION, 
"Text=Personalize", 
ACTION, 
"UserAction=Click", 
LAST);

lr_think_time(6);

sap_portal("Sap Portal_2", 
"Snapshot=t9.inf", 
DESCRIPTION, 
"BrowserOrdinal=2", 
ACTION, 
"DetailedNavigation=User Profile", 
LAST);
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Developing SAP-Web Vuser Scripts

You use VuGen’s SAP-Web Vuser type, to record the activity in SAP 
Workplace or SAP Portal clients.

This chapter includes:

 ➤  About Developing SAP-Web Vuser Scripts on page 812

 ➤  Creating a SAP-Web Vuser Script on page 812

 ➤  Setting SAP-Web Recording Options on page 814

 ➤  Understanding a SAP-Web Vuser Script on page 815

 ➤  Replaying a SAP-Web Vuser Script on page 817

The following information only applies to the SAP-Web protocol.
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About Developing SAP-Web Vuser Scripts 

You use VuGen to record typical SAP business processes. VuGen records SAP 
Workplace or Portal activity during the business processes, and generates a 
Vuser script. When you perform actions within your browser, VuGen 
generates functions that describe this activity. Each function begins with a 
web prefix. 

During replay, these functions emulate user activity on the SAP Workplace 
or Portal clients. For example, web_url navigates to the PageBuilder. 

Creating a SAP-Web Vuser Script

The first step in creating a SAP-Web Vuser script, is choosing the Vuser and 
script type. The SAP-Web Vuser is under the ERP/CRM category. You can 
create either a single or multi-protocol Vuser script. In addition, you can use 
the single-protocol SAP (Click and Script) Vuser type. The SAP (Click and 
Script) Vuser generates a higher level, more intuitive script.

To create a SAP-Web Vuser:

 1 Invoke VuGen and choose File > New. 

 2 To record a session that does not incorporate any SAPGUI controls within 
the Workplace or Portal clients, create a single-protocol Vuser script using 
the SAP-Web Vuser type. 

web_url("PageBuilder[myPage]", 
"URL=http://sonata.hplab.com/hrnp$30001/sonata.hplab.co.il:80/Action/PageBuilder[m
yPage]?pageName=com.sapportals.pct.home.mynews", 

"Resource=0", 
"RecContentType=text/html", 
"Referer=http://sonata.hplab.co.il/sapportal", 
"Snapshot=t2.inf", 
"Mode=HTML", 
EXTRARES, 
"Url=/irj/services/laf/themes/portal/sap_mango_polarwind/.., ENDITEM, 
LAST);
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 3 To record a session that uses SAPGUI controls, create either:

➤ a single-protocol Vuser script, specifying the SAP (Click and Script) 
protocol.

➤ a multi-protocol Vuser script, specifying both the SAP-Web and SAPGUI 
Vuser types.
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Setting SAP-Web Recording Options 

You use the recording options to set your preferences for how VuGen 
generates the Vuser script. 

The recommended settings for the General:Recording node are:

For SAP Workplace recordings: URL-based script

For SAP Portal recordings: HTML-based script (the default)

For information about the other Web related recording options, see 
Chapter 38, “Setting Recording Options for Internet Protocols.”
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Understanding a SAP-Web Vuser Script

The SAP-Web Vuser script typically contains several SAP transactions which 
make up a business process. The business process consists of functions that 
emulate user actions. For information about these functions, see the Web 
functions in the Online Function Reference (Help > Function Reference).

The following example shows a typical recording for a SAP Portal client:

vuser_init()
{
web_reg_find("Text=SAP Portals Enterprise Portal 5.0", 

LAST);

web_set_user("junior{UserNumber}", 
lr_decrypt("3ed4cfe457afe04e"), 
"sonata.hplab.com:80");

web_url("sapportal", 
"URL=http://sonata.hplab.com/sapportal", 
"Resource=0", 
"RecContentType=text/html", 
"Snapshot=t1.inf", 
"Mode=HTML", 
EXTRARES, 

"Url=/SAPPortal/IE/Media/sap_mango_polarwind/images/header/branding_image.jpg", 
"Referer=http://sonata.hplab.com/hrnp$30001/sonata.hplab.coml:80/Action/26011[hea
der]", ENDITEM, 

"Url=/SAPPortal/IE/Media/sap_mango_polarwind/images/header/logo.gif", 
"Referer=http://sonata.hplab.com/hrnp$30001/sonata.hplab.com:80/Action/26011[head
er]", ENDITEM, 
…

LAST);
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The following section illustrates a multi-protocol recording in which the 
Portal client opens a SAP control. Note the switch from web_xxx to 
sapgui_xxx functions. 

web_url("dummy", 

"URL=http://sonata.hplab.com:1000/hrnp$30000/sonata.hplab.com:1000/Action/dumm
y?PASS_PARAMS=YES&dummyComp=dummy&Tcode=VA01&draggable=0&CompF
Name=VA01&Style=sap_mango_polarwind", 

"Resource=0", 
"RecContentType=text/html", 
"Referer=http://sonata.hplab.com/sapportal", 
"Snapshot=t9.inf", 
"Mode=HTML", 
LAST);

sapgui_open_connection_ex(" /H/Protector/S/3200 /WP", 
"", 
"con[0]");

sapgui_select_active_connection("con[0]");

sapgui_select_active_session("ses[0]");

/*Before running script, enter password in place of asterisks in logon function*/

sapgui_logon("JUNIOR{UserNumber}", 
"ides", 
"800", 
"EN", 
BEGIN_OPTIONAL, 

"AdditionalInfo=sapgui102", 
END_OPTIONAL);
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Replaying a SAP-Web Vuser Script

After creating and enhancing your SAP-Web Vuser script, you configure its 
run-time settings and run it from VuGen to check its functionality. 

Run-Time settings let you control the Vuser behavior during replay. You 
configure these settings before running the Vuser script. You can set both 
General and Web related run-time settings. 

The General settings include the run logic, pacing, logging, think time, and 
performance preferences. For information about the General run-time 
settings, see “Configuring Run-Time Settings” in Volume I-Using VuGen. For 
SAP-Web specific settings, see Chapter 40, “Configuring Internet Run-Time 
Settings.”

Once you configure the Run-Time settings, you save the Vuser script and 
run it from VuGen as a standalone test, to verify that it runs correctly. For 
further information, see “Running Vuser Scripts in Standalone Mode” in 
Volume I-Using VuGen.

After verifying that your Vuser script is functional, you integrate it into your 
environment: a LoadRunner scenario, Performance Center load test, or 
Business Process Monitor profile. For more information, refer to the HP 
LoadRunner Controller, Performance Center, or HP Business Availability Center 
documentation. 
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Running SAPGUI Vuser Scripts

After creating a SAPGUI script through recording and manual 
enhancements, you replay it in VuGen to test its functionality.

This chapter includes:

 ➤  About Replaying SAPGUI Vuser Scripts on page 819

 ➤  Replaying SAPGUI Optional Windows on page 820

 ➤  Setting SAPGUI Run-Time Settings on page 821

 ➤  SAPGUI Functions on page 824

 ➤  Tips for SAPGUI Vuser Scripts on page 825

 ➤  Troubleshooting SAPGUI Vuser Scripts on page 830

 ➤  Additional Resources on page 832

The following information only applies to the SAPGUI and the SAP (Click 
and Script) protocols.

About Replaying SAPGUI Vuser Scripts

This chapter discusses the running of a SAPGUI Vuser script. You can set 
run-time settings to control the Vuser’s behavior during the test or 
monitoring session.

This chapter also contains several guidelines for working with SAPGUI 
Vusers, as well as a troubleshooting section for solving common issues.

The SAPGUI Vuser script emulates a typical business processes using SAPGUI 
functions that begin with a sapgui prefix. 
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During replay, these functions emulate user activity on SAPGUI objects. 

For example, sapgui_select_radio_button selects the radio button Blue. 

Replaying SAPGUI Optional Windows

When working with SAPGUI Vuser Scripts, you may encounter optional 
windows in the SAPGUI client—windows that were present during 
recording, but do not exist during replay. If you try to replay your recorded 
script as is, it will fail when it attempts to find the missing windows.

VuGen’s optional window mechanism performs the actions on a window 
only after verifying that it exists. The Vuser checks if the window indicated 
in the Select active window step exists. If the window is found during 
replay, it performs the actions as they were recorded in the script. If it does 
not exist, the Vuser ignores all window actions until the next Select active 
window step. Note that only SAPGUI steps (beginning with a sapgui prefix) 
are ignored. 

To use this feature, in Tree view select the appropriate Select Active Window 
step and choose Run steps for window only if it exists from the right-click 
menu.

To disable this feature and attempt to run these steps at all times, regardless 
of whether the Vuser finds the window or not, choose Always run steps for 
this window from the right-click menu.

sapgui_select_radio_button("Blue", 
        "usr/radRB7", 
        BEGIN_OPTIONAL, 
            "AdditionalInfo=sapgui1027", 
        END_OPTIONAL);
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Setting SAPGUI Run-Time Settings

After creating and enhancing your SAPGUI Vuser script, you configure its 
run-time settings and run it from VuGen to check its functionality. Run-
Time settings let you control the Vuser behavior during replay. You 
configure these settings before running the Vuser script. You can set both 
general and SAPGUI-specific run-time settings. 

The general settings include the run logic, pacing, logging, think time, and 
performance preferences. For information about the general run-time 
settings, see “Configuring Run-Time Settings” in Volume I-Using VuGen.For 
SAPGUI- specific settings, see the following sections.

Once you configure the Run-Time settings, you save the Vuser script and 
run it from VuGen to verify that it runs correctly. For details about running 
the Vuser script as a standalone test, see “Running Vuser Scripts in 
Standalone Mode” in Volume I-Using VuGen. 

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

You can configure the SAPGUI specific Run-Time settings in the following 
areas:

➤ SAPGUI General Run-Time Settings

➤ SAPGUI Advanced Run-Time Settings
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SAPGUI General Run-Time Settings
General run-time settings let you set the general settings for a SAPGUI Vuser 
script. VuGen uses these settings when running the script.

The Log run-time settings specify the information a Vuser sends to the 
Execution log whenever an error occurs. 

➤ Send status bar text. Send the text from the status bar to the log file. 

➤ Send active window title. Send the active window title text to the log file. 

The Performance run-time settings allow you to indicate whether or not to 
display the SAP client during replay. 

➤ Show SAP Client during replay. Shows an animation of the actions in the 
SAP client during replay. The benefit of displaying the user interface (UI) is 
that you can see how the forms are filled out and closely follow the actions 
of the Vuser. This option, however, requires additional resources and may 
affect the performance of your load test. 
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➤ Take ActiveScreen snapshots during replay. Captures replay snapshots with 
the Control ID information for all active objects. ActiveScreen snapshots 
differ from regular ones, in that they allow you to see which objects were 
recognized by VuGen in the SAPGUI client. As you move your mouse across 
the snapshot, VuGen highlights the detected objects. You can then add new 
steps to the script directly from within the snapshot. It also allows you to 
add steps interactively from within the snapshot for a specific object. For 
more information, see “Inserting Steps Interactively into a SAPGUI Script” 
on page 797.

Advanced options let you set a timeout for the SAPfewgsvr.exe process, save 
a snapshot on error, and configure VuGen to use SAPlogon during replay. 
For more information, see “SAPGUI Advanced Run-Time Settings” on 
page 823.

To set the SAPGUI Run-Time Settings:

 1 Open the Run-Time settings dialog box. Click the Run-Time Settings button 
on the VuGen toolbar, or choose Vuser > Run-Time Settings. 

 2 Select the SAPGUI:General node. 

 3 In the Log messages on error section, select one or more message sources: 
Send status bar text or Send active window title.

 4 In the Performance section, select the Show SAP client during replay check 
box to show the SAPGUI user interface during replay. 

 5 Click Options to set a timeout for the SAPfewgsvr.exe process. 

SAPGUI Advanced Run-Time Settings
Each Vuser invokes a separate SAPfewgsvr.exe process during test execution. 
In some instances, the process stays active even after the replay session has 
ended. You can check the Windows Task Manager to see if the process is still 
active.
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The Advanced SAPGUI settings let you set a timeout for this application. 
When the timeout is reached, VuGen closes any SAPfewgsvr processes not 
previously terminated.

➤ Replay using running SAPlogon application. Instructs the Vusers to use the 
SAPlogon application that is currently running for replay.

➤ Set SAPfewgsvr application timeout. Allows you to modify the 
SAPfewgsvr.exe process timeout.

➤ Timeout to SAPfewgsvr. The SAPfewgsvr.exe process timeout in seconds. 
The default is 300 seconds. 

SAPGUI Functions

During a SAPGUI recording session, VuGen generates functions that 
emulate user interaction with the SAPGUI client. When you record the 
SAPGUI for Windows client, VuGen generates functions with a sapgui 
prefix. This section lists all of the sapgui functions.

When you record a SAP session using a Web interface such as SAP Workplace 
or Portal, or if the SAPGUI client opens a Web control, VuGen generates 
functions with a web prefix. 
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While most of the functions are recorded, you can manually insert any 
function into your script. The functions that are not recorded are the data 
retrieval functions beginning with sapgui_get, and those used for 
verification, beginning with sapgui_is.

There are several categories of sapgui functions: Connection and Session 
Functions, Method and Property Functions, Verification and Data Retrieval 
Functions, and Object functions. Object functions are those which perform 
an action within a SAPGUI object such as Calendar Functions, Grid 
Functions, APO Grid Functions, Status Bar Functions, Table Functions, Tree 
Functions, Window Functions, and General Object Functions. 

For more information about the sapgui and web functions, use the Show 
Function Syntax feature from the Edit menu, or refer to the Online Function 
Reference (Help > Function Reference).

Tips for SAPGUI Vuser Scripts

The following sections provides Recording Tips, Replay Tips, and Tips for 
Replaying in a Scenario for SAPGUI Vusers. In addition, you can obtain 
information directly from the SAP support site. 

Recording Tips
This section provides recording tips for a SAPGUI Vuser script. 

➤ Make sure to record the actions into the appropriate sections: Record the 
logon procedure into the vuser_init section, the actions that you want to 
repeat in the Actions sections, and the logoff procedure in the vuser_end 
section.

➤ When recording a multi-protocol script in which the SAPGUI client 
contains Web controls, close the SAPLogon application before recording.
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➤ Use modal dialog boxes for F1. Instruct the SAPGUI client to open the F1 
help in a modal dialog box. Choose Help >Settings. Click the F1 Help tab 
and select the in modal dialog box option in the Display section.

➤ Use modal dialog boxes for F4. Instruct the SAPGUI client to open the F4 
help in a modal dialog box. 
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The following procedure must be performed by a SAP administrator:

To open F4 help in modal dialog boxes:

 1 Ensure that all users have logged off from the server.

 2 Choose Help > Settings. Click the F4 Help tab.

 3 In the Display section (bottom left), choose System defaults.

 4 In the Display portion of the System defaults section (bottom right), select 
Dialog. 

 5 Save the changes—click Copy initial system setting or CTRL+S.

 6 Verify that the status bar displays the message Data was saved.

 7 Close the session.

 8 Restart the service through the SAP Management Console. 
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Replay Tips
Follow these guidelines before replaying your script in standalone-mode: 

➤ Replace the encrypted password in the sapgui_logon function generated 
during recording, with the real password. It is the second argument of the 
function, after the user name: sapgui_logon("user", "pswd", "800", "EN"); For 
additional security, you can encrypt the password within the code. Select 
the password text (the actual text, not *****) and choose Encrypt string from 
the right-click menu. VuGen inserts an lr_decrypt function at the location 
of the password: sapgui_logon("user", lr_decrypt("3ea037b758"), "800", "EN");. 

➤ When running a script for the first time, configure VuGen to show the 
SAPGUI user interface during replay, in order to see the operations being 
performed through the UI. To show the user interface during replay, open 
the run-time settings (F4) and select the Show SAP Client During Replay 
option in the SAPGUI:General node. During a load scenario, disable this 
option, since it uses a large amount of system resources in displaying the UI 
for multiple Vusers.

Tips for Replaying in a Scenario
The following sections provide configuration tips for running the script on a 
Controller or Load Generator machine. 

Controller Settings

When working with a LoadRunner scenario, set the following values when 
running your script in a load test configuration:

➤ Ramp-up. One by one (to insure proper logon) in the Scheduler.

➤ Think time. Random think time in the Run-Time settings.

➤ Users per load generator. 50 Vusers for machine with 512 MB of memory in 
the Load Generators dialog box.

Load Generator Settings

When running your script in a scenario, check the agent mode and 
configure the terminal sessions on the Load Generator machines. 

➤ Agent Mode. Make sure that the LoadRunner (or Performance Center) 
Remote Agent is running in Process mode. Service mode is not supported. 
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To check this, move your mouse over the agent’s icon in the Windows task 
bar area, and read the description. If the description reads LoadRunner 
Agent Service, it is running as a service. 

To restart the agent as a process:

 1 Stop the agent. Right-click the LoadRunner Agent icon and select Close. 

 2 Run magentproc.exe, located in the launch_service\bin directory, under the 
LoadRunner installation.

 3 To ensure that the correct Agent is launched the next time you start your 
machine, change the Start type of the Agent Service from Automatic to 
Manual. Then add a shortcut to magentproc.exe to the Windows Startup 
folder.

Terminal Sessions. Machines running SAPGUI Vusers may be limited in the 
number of Vusers that can run, due to the graphic resources available to that 
machine. To increase the number of Vusers per machine, open additional 
terminal server sessions on the Load Generator machines. Choose Agent 
Configuration from Start > Programs > <product_name> > Advanced 
Settings, and select the Enable Terminal Service option. You specify the 
number of terminal sessions in the Load generator machine properties. For 
more information, refer to Configuring Terminal Services in the HP 
LoadRunner Controller User’s Guide.

Note: When the LoadRunner Agent is running in a terminal session, and the 
terminal session’s window is minimized, no snapshots will be captured on 
errors.
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Troubleshooting SAPGUI Vuser Scripts

Question 1: I was able to record a script, but why does replay fail?

Answer: In LoadRunner, make sure that the LoadRunner Remote Agent is 
running in Process mode. Service mode is not supported. For more 
information, see “Replay Tips” on page 828.

Question 2: Why were certain SAPGUI controls not recorded?

Answer: Some SAPGUI controls are only supported in their menu or toolbar 
contexts. Try performing the problematic task using a different means—
through a menu option, context menu, toolbar, and so on.

Question 3: Why can’t I record or replay any scripts in VuGen?

Answer: 

 a Verify that you have the latest patch of SAPGUI 6.20 installed. The lowest 
allowed patch level is patch 32. 

 b Make sure that scripting is enabled. See the “Checking your Environment 
for SAPGUI Vusers” on page 779.

 c Verify that notifications are disabled in the SAPGUI for Windows client. 
Click the Customizing of Local Layout button or press ALT+F12. Click 
Options and select the Scripting tab. Clear both Notify options. 

Question 4: What is the meaning of the error popup messages that are 
issued when I try to run the script?

Answer: Certain SAP applications store the last layout for each user (such as 
which frames are visible or hidden). If the stored layout was changed since 
the script was recorded, this may cause replay problems. For Example, in the 
ME52N transaction, the Document overview Off/On button will change the 
number of visible frames.

If this occurs:

 1 Navigate the transaction to the same point as it was during recording, before 
starting replay. You can use the Snapshot viewer to see the layout in which it 
was recorded.
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 2 Add statements to the script that bring the transaction to the desired layout 
during replay. For example, if an optional frame interferes with your replay, 
insert a verification function that checks if the frame is open. If it is open, 
click a button to close it. For verification examples, see “Adding Verification 
Functions” on page 803.

Question 5: Can I use the single sign-on mechanism when running a script 
on a remote machine?

Answer: No, VuGen does not support the single sign-on connection 
mechanism. In your SAPGUI client, open the Advanced Options and clear 
the Enable Secure Network Communication feature. Note that you must re-
record the script after you modify the Connection preferences.

Question 6: Can VuGen record all SAP objects?

Answer: Recording is not available for objects not supported by SAPGUI 
Scripting. See your recording log for information about those objects.

Question 7: Are all business processes supported?

Answer: VuGen does not support business processes that invoke Microsoft 
Office module controls, nor those that require the use of GuiXT. You can 
disable GuiXT from the SAPGUI for Windows client Options menu. 
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Additional Resources

LoadRunner 

For Online Help on dialog boxes, press F1 within a dialog box. You can also 
choose Help > Contents and Index to manually open the Help. In the Index 
tab, locate the SAPGUI Vuser scripts entry and click the appropriate sub-
entry.

For Online Help with a function, click within the function or step, and click 
F1 to open the Online Function Reference. 

SAP

For more information, refer to the SAP website at www. sap.com or one of 
the following locations:

➤ SAP Notes - https://websmp103.sap-ag.de/notes

Note #480149: New profile parameter for user scripting on the front end

Note #587202: Drag & Drop is a known limitation of the SAPGUI interface 

➤ SAP Patches - https://websmp104.sap-ag.de/patches

SAP GUI for Windows - SAPGUI 6.20 Patch (the lowest allowed level is 32)
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Developing Siebel-Web Vuser Scripts

You use VuGen to record the activity in a Siebel Web environment and 
generate a Vuser script. When you run the script, Vusers emulate the actions 
within your Siebel environment.

This chapter includes:

 ➤  About Developing Siebel-Web Vuser Scripts on page 833

 ➤  Recording a Siebel-Web Session on page 834

 ➤  Correlating Siebel-Web Scripts on page 835

 ➤  Correlating SWECount, ROWID, and SWET Parameters on page 842

 ➤  Troubleshooting Siebel-Web Vuser Scripts on page 844

The following information only applies to Siebel-Web Vuser scripts.

About Developing Siebel-Web Vuser Scripts 

The Siebel-Web protocol is similar to the standard Web Vuser, with several 
changes in the default settings to allow it to work with the Siebel Customer 
Relationship Management (CRM) application.

You record typical activities in your Siebel session. VuGen records the 
actions and generates functions with a web_ prefix, that emulate the 
actions. 

The sections below provide tips for working with Siebel-Web recorded Vuser 
Scripts and provide samples of the parameters that need to be correlated. 
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Recording a Siebel-Web Session

When recording a Siebel-Web session, use the following guidelines: 

To record a Siebel-Web Vuser script:

 1 Create a Siebel-Web type Vuser script from the ERP category.

 2 Set the following Recording Options:

➤ Record node: HTML based script 

Advanced HTML - Script options: a script containing explicit URLs only

Advanced HTML - Non HTML-generated elements: Do not record

➤ Advanced node: Clear the Reset context for each action option. 

 3 Record the login in the vuser_init section.

 4 Record the Business Process in Action1.

 5 Record the logout in the vuser_end section.

 6 In the Run-Time settings, clear the Simulate a new user on each iteration 
option in the Browser Emulation node. 

For more information on how to configure the Recording Options and Web 
related Run-Time settings, see Chapter 38, “Setting Recording Options for 
Internet Protocols”, and Chapter 40, “Configuring Internet Run-Time 
Settings.”
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Correlating Siebel-Web Scripts

When creating a test script for a Siebel session, you will most probably need 
to use correlation in your script. Correlation is the mechanism by which 
VuGen saves dynamic values to parameters during record and replay, for use 
at a later point in the script. If you replayed the recorded script as is, without 
correlation, it would fail, since the values of the arguments differ each time 
the script runs. An example of such variables are SWECount and SWEBMC. 

When you use correlation, VuGen saves the dynamic variables during both 
record and replay, and uses them at the appropriate points within the script. 
You can instruct VuGen to apply correlation during recording using one of 
the following methods: 

➤ Siebel Correlation Library

The Siebel correlation library automatically correlates most of the dynamic 
values, creating a concise script that you can replay without major 
modifications. This is the recommended method for correlation.

➤ VuGen Native Siebel Correlation

The native, built-in rules, work on a low level, allowing you to debug your 
script and understand the correlations in depth.

Siebel Correlation Library
To assist you with correlation, Siebel has released a correlation library file as 
part of the Siebel Application Server version 7.7. This library is available 
only through Siebel. The library file, ssdtcorr.dll, is located under the 
siebsrvr\bin folder for Windows and under siebsrvr/lib for UNIX 
installations. 

The library file, ssdtcorr.dll, must be available to all machines where a Load 
Generator or Controller reside. Support for this library requires VuGen 8.0 
and higher.

To enable correlation with this library:

 1 Copy the DLL file into the bin directory of the product installation.

 2 Open a multi-protocol script using the Siebel-Web Vuser type. 
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 3 Enable UTF-8 support in the recording options. For more information, see 
“Setting Advanced Recording Options” on page 588.

 4 Open the recording option’s Correlation node and click Import. Import the 
rules file, WebSiebel77Correlation.cor, from the 
\dat\webrulesdefaultsetting directory. If you are prompted with warnings, 
click Override. For more information, see “Setting the Correlation Recording 
Options” on page 697.

To revert back to the default correlation, delete all of the Siebel rules and 
click Use Defaults. 

When using the Siebel correlation library, verify that the SWE count rules 
(where the left boundary contains the SWEC string) are not disabled. For 
more information, see “Disabling and Enabling Rules” on page 840.

VuGen Native Siebel Correlation
VuGen’s native built-in rules for the Siebel server detect the Siebel server 
variables and strings, automatically saving them for use at a later point 
within the script. 

You can view these rules in the list of correlation rules (see “Using VuGen’s 
Correlation Rules” on page 688). The rules list the boundary criteria that are 
unique for Siebel server strings. 

When VuGen detects a match using the boundary criteria, it saves the value 
between the boundaries to a parameter. The value can be a simple variable 
or a public function. 

You can also create your own rules by entering unique boundary criteria in 
the Correlation Recording Options (see Chapter 44, “Setting Correlation 
Rules for Web Vuser Scripts”) or after the recording from the Correlation 
Results tab (see “Performing a Scan for Correlations” on page 707).
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In the Replay Log tab, VuGen indicates when it registers, saves, or uses the 
parameters. Note that to display this information, you need to enable 
Extended logging. For more information, see “Configuring the Log Run-
Time Settings” on page 228.

Simple Variable Correlation

In the following example, the left boundary criteria is _sn=. For every 
instance of _sn= in the left boundary and ; in the right, VuGen creates a 
parameter with the Siebel_sn_cookie prefix.
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In the following example, VuGen detected the _sn boundary. It saved the 
parameter to Siebel_sn_cookie6 and used it in the web_url function.

Function Correlation

In certain instances, the boundary match is a function. Functions generally 
use an array to store the run-time values. In order to correlate these values, 
VuGen parses the array and saves each argument to a separate parameter 
using the following format: 

<parameter_name> = <recorded_value> (display_name)

The display name is the text that appears next to the value, in the Siebel 
Application. 

/* Registering parameter(s) from source 
web_reg_save_param("Siebel_sn_cookie6", 
"LB/IC=_sn=", 
"RB/IC=;", 
"Ord=1", 
"Search=headers", 
"RelFrameId=1", 
LAST);

…

web_url("start.swe_3", 
"URL=http://cannon.hplab.com/callcenter_enu/start.swe?SWECmd=GotoPostedAction
&SWEDIC=true&_sn={Siebel_sn_cookie6}&SWEC={Siebel_SWECount}&SWEFrame
=top._sweclient&SWECS=true", 
"TargetFrame=", 
"Resource=0", 
"RecContentType=text/html", 
"Referer=http://cannon.hplab.com/callcenter_enu/start.swe?SWECmd=GetCachedFra
me&_sn={Siebel_sn_cookie6}&SWEC={Siebel_SWECount}&SWEFrame=top._swe", 
"Snapshot=t4.inf", 
"Mode=HTML", 
LAST);
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VuGen inserts a comment block with all of the parameter definitions.

In addition, when encountering a function, VuGen generates a new 
parameter for web_reg_save_param, AutoCorrelationFunction. VuGen also 
determines the prefix of the parameters and uses it as the parameter name. 
In the following example, the prefix is Siebel_Star_Array_Op33.

/* Registering parameter(s) from source task id 159
// {Siebel_Star_Array_Op33_7} = ""
// {Siebel_Star_Array_Op33_6} = "1-231"
// {Siebel_Star_Array_Op33_2} = ""
// {Siebel_Star_Array_Op33_8} = "Opportunity"
// {Siebel_Star_Array_Op33_5} = "06/26/2003 19:55:23"
// {Siebel_Star_Array_Op33_4} = "06/26/2003 19:55:23"
// {Siebel_Star_Array_Op33_3} = ""
// {Siebel_Star_Array_Op33_1} = "test camp"
// {Siebel_Star_Array_Op33_9} = ""
// {Siebel_Star_Array_Op33_rowid} = "1-6F"
// */

web_reg_save_param("Siebel_Star_Array_Op33", 
"LB/IC=`v`", 
"RB/IC=`", 
"Ord=1", 
"Search=Body", 
"RelFrameId=1", 
"AutoCorrelationFunction=flCorrelationCallbackParseStarArray", 
LAST);
839



Chapter 53 • Developing Siebel-Web Vuser Scripts
VuGen uses the parameters at a later point within the script. In the 
following example, the parameter is called in web_submit_data. 

During replay, Vusers do a callback to the public function, using the array 
elements that were saved as parameters. 

Note: Correlation for the SWEC parameter is not done through the 
correlation rules. VuGen handles it automatically with a built-in detection 
mechanism. For more information, see “SWEC Correlation” on page 841.

Disabling and Enabling Rules

In normal situations, you do not need to disable any rules. In some cases, 
however, you may choose to disable rules that do not apply. For example, 
disable Japanese content check rules when testing English-only applications.

Another reason to disable a rule is if the Controller explicitly requires an 
error condition to be generated. View the rule properties in the recording 
options and determine the conditions necessary for your application.

web_submit_data("start.swe_14", 
"Action=http://cannon.hplab.com/callcenter_enu/start.swe", 
"Method=POST", 
"RecContentType=text/html", 
"Referer=", 
"Snapshot=t15.inf", 
"Mode=HTML", 
ITEMDATA, 
"Name=SWECLK", "Value=1", ENDITEM, 
"Name=SWEField", "Value=s_2_1_13_0", ENDITEM, 
"Name=SWER", "Value=0", ENDITEM, 
"Name=SWESP", "Value=false", ENDITEM, 
"Name=s_2_2_29_0", "Value={Siebel_Star_Array_Op33_1}", ENDITEM, 
"Name=s_2_2_30_0", "Value={Siebel_Star_Array_Op33_2}", ENDITEM, 
"Name=s_2_2_36_0", "Value={Siebel_Star_Array_Op33_3}", ENDITEM, 

…
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To disable rules: 

 1 Open the Correlation recording options. Choose Tools > Recording Options 
and click the Correlation node.

 2 Select the Enable correlation during recording option. The dialog box 
displays the supported servers. 

 3 Expand the rules under Siebel and view their properties. 

 4 Clear the check box adjacent to the rule for each rule you want to disable.

SWEC Correlation
SWEC is a parameter used by Siebel servers representing the number of user 
clicks. The SWEC parameter usually appears as an argument of a URL or a 
POST statement. For example:

or

VuGen handles the changes of the SWEC by incrementing a counter before 
each relevant step. VuGen stores the current value of the SWEC in a separate 
variable (Siebel_SWECount_var). Before each step, VuGen saves the 
counter’s value to a VuGen parameter (Siebel_SWECount). 

GET /callcenter_enu/start.swe?SWECmd=GetCachedFrame&_sn=2-
mOTFXHWBAAGb5Xzv9Ls2Z45QvxGQnOnPVtX6vnfUU_&SWEC=1&SWEFrame=top
._swe._sweapp HTTP/1.1

POST /callcenter_enu/start.swe HTTP/1.1
…
\r\n\r\n
SWERPC=1&SWEC=0&_sn=2-
mOTFXHWBAAGb5Xzv9Ls2Z45QvxGQnOnPVtX6vnfUU_&SWECmd=InvokeMethod
…
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In the following example, web_submit_data uses the dynamic value of the 
SWEC parameter, Siebel_SWECount.

Note that the SWEC parameter may also appear in the referrer URL. 
However, its value in the referrer URL usually differs from its value in the 
requested URL. VuGen handles this automatically.

Correlating SWECount, ROWID, and SWET Parameters

This section provides tips for correlating several special parameters:

➤ SWECount

➤ Row ID Length

➤ SWETS (Timestamps)

Siebel_SWECount_var += 1;

lr_save_int(Siebel_SWECount_var, "Siebel_SWECount");

web_submit_data("start.swe_8", 
"Action=http://cannon.hplab.com/callcenter_enu/start.swe", 
"Method=POST", 
"TargetFrame=", 
"RecContentType=text/html", 
"Referer=", 
"Snapshot=t9.inf", 
"Mode=HTML", 
"EncodeAtSign=YES", 
ITEMDATA, 
"Name=SWERPC", "Value=1", ENDITEM, 
"Name=SWEC", "Value={Siebel_SWECount}", ENDITEM, 
"Name=SWECmd", "Value=InvokeMethod", ENDITEM, 
"Name=SWEService", "Value=SWE Command Manager", ENDITEM, 
"Name=SWEMethod", "Value=BatchCanInvoke", ENDITEM, 
"Name=SWEIPS",… 
LAST);
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SWECount

The SWECount parameter value is usually a small number consisting of one 
or two digits. It is often difficult to determine where to replace the recorded 
value with a parameter. 

In the web_submit_data function, VuGen only replaces it in the SWEC 
field.

In URLs, VuGen only replaces the value when it appears after the strings 
"SWEC=" or "SWEC`".

The parameter name for all the SWECount correlations is the same.

Row ID Length

In certain cases, the rowid is preceded by its length, encoded in hexadecimal 
format. Since this length can change, this value must be correlated.

For example, the following string is comprised of a length value and RowID, 
xxx6_1-4ABCyyy, where 6 is the length, and 1-4ABC is the RowID. 

If you define parameters to correlate the string as

xxx{rowid_Length}_{rowid}yyy

then using this enhanced correlation, VuGen generates the following 
function before the string: 

web_save_param_length("rowid", LAST); 

This function gets the value of rowid, and saves its length into the 
parameter rowid_length in hexadecimal format.

SWETS (Timestamps)

The SWETS value in the script, is the number of milliseconds since midnight 
January 1st, 1970.

VuGen replaces all non-empty timestamps in the script, with the parameter 
{SiebelTimeStamp}. Before saving a value to this parameter, VuGen generates 
the following function:

web_save_timestamp_param("SiebelTimeStamp", LAST);
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This function saves the current timestamp to the SiebelTimeStamp 
parameter.

Troubleshooting Siebel-Web Vuser Scripts

This section provides information about errors you might encounter when 
creating a script, and the breakdown diagnostic tool.

➤ Typical Errors

➤ Recording Breakdown Information

Typical Errors
You may encounter one or more of the following errors while creating a 
Siebel-Web Vuser script:

➤ Back or Refresh Error

➤ Same Values

➤ No Content HTTP Response

➤ Restoring the Context

➤ Cannot Locate Record

➤ End of File

➤ Unable to Retrieve Search Categories

Back or Refresh Error

An error message relating to Back or Refresh typically has the following text: 

We are unable to process your request. This is most likely because you used the 
browser BACK or REFRESH button to get to this point. 

Cause: The possible causes of this problem may be: 

➤ The SWEC was not correlated correctly for the current request.

➤ The SWETS was not correlated correctly for the current request.

➤ The request was submitted twice to the Siebel server without the SWEC 
being updated. 
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➤ A previous request should have opened a frame for the browser to 
download. This frame was not created on the server probably because the 
SWEMethod has changed since the recording. 

Same Values

A typical Web page response to the Same Values error is:

@0`0`3`3``0`UC`1`Status`Error`SWEC`10`0`1`Errors`0`2`0`Level0`0`ErrMsg`Th
e same values for 'Name' already exist. If you would like to enter a new record, 
please ensure that the field values are unique.`ErrCode`28591`

Cause: The possible cause of this problem may be that one of the values in 
the request (in the above example, the value of the Name field) duplicates a 
value in another row of the database table. This value needs to be replaced 
with a unique value to be used for each iteration per user. The 
recommended solution is to replace the row ID with its parameter instead 
insuring that it will be unique.

No Content HTTP Response

A typical HTTP response for a No Content HTTP Response type error is:

HTTP/1.1 204 No Content
Server: Microsoft-IIS/5.0
Date: Fri, 31 Jan 2003 21:52:30 GMT
Content-Language: en
Cache-Control: no-cache

Cause: The possible causes of this problem may be that the row ID is not 
correlated at all or that it is correlated incorrectly.

Restoring the Context

The typical Web page response to the Restoring the Context type error is:

@0`0`3`3``0`UC`1`Status`Error`SWEC`9`0`1`Errors`0`2`0`Level0`0`ErrMsg`An 
error happened during restoring the context for requested 
location`ErrCode`27631`

Cause: The possible causes of this problem may be that the rowid is not 
correlated or that it is correlated incorrectly.
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Cannot Locate Record

The typical Web page response to the Cannot locate record type error is:

@0`0`3`3``0`UC`1`Status`Error`SWEC`23`0`2`Errors`0`2`0`Level0`0`ErrMsg`Ca
nnot locate record within view: Contact Detail - Opportunities View applet: 
Opportunity List Applet.`ErrCode`27573`

Cause: The possible causes of this problem may be that the input name 
SWERowId does not contain a row ID for a record on the Web page. This 
input name should have been parameterized. The parameter's source value 
may have changed its location.

End of File

The typical Web page response to the End of File type error is:

@0`0`3`3``0`UC`1`Status`Error`SWEC`28`0`1`Errors`0`2`0`Level0`0`ErrMsg`An 
end of file error has occurred. Please continue or ask your systems administrator 
to check your application configuration if the problem persists.`ErrCode`28601`

Cause: The possible causes of this problem may be that the input name 
SWERowId does not contain a row ID for a record on the Web page. This 
input name should have been parameterized. The parameter's source value 
may have changed its location.

Unable to Retrieve Search Categories

The typical Web page response to the Unable to Retrieve Search Categories 
type error is:

Cause: A possible cause of this problem may be that the search frame was 
not downloaded from the server. This occurs when the previous request did 
not ask the server to create the search frame correctly.
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Recording Breakdown Information
VuGen provides a diagnostic tool for understanding the transaction 
components in your test—transaction breakdown. Using transaction 
breakdown, you can determine where the bottlenecks are and the issues that 
need to be resolved. 

When preparing your script for transaction breakdown, it is recommended 
that you add think time at the end of each transaction using the ratio of one 
second per hour of testing. For more information on entering think time, 
see “Enhancing Vuser Scripts” in Volume I-Using VuGen.

In order to record the transaction breakdown information, you need to 
modify your the parameterization functions in your script.

To prepare your script for transaction breakdown:

 1 Identify the script parameterization replacement of the Session ID.

 2 Mark the next web_submit_data function as a transaction by enclosing it 
with lr_start_transaction and lr_end_transaction functions. 

/* Registering parameter(s) from source task id 15
// {Siebel_sn_body4} = "28eMu9uzkn.YGFFevN1FdrCfCCOc8c_"
// */
web_reg_save_param("Siebel_sn_body4",

"LB/IC=_sn=",
"RB/IC=&",
"Ord=1",
"Search=Body",
"RelFrameId=1",
LAST);
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 3 Before the end of the transactions, add a call to 
lr_transaction_instance_add_info, where the first parameter, 0 is 
mandatory and the session ID has a SSQLBD prefix.

Note: To avoid session ID conflicts, make sure that the Vusers log off from 
the database at the end of each session.

lr_start_transaction("LoginSQLSync");
web_submit_data("start.swe_2",

"Action=http://design/callcenter_enu/start.swe",
"Method=POST",
"RecContentType=text/html",
"Referer=http://design/callcenter_enu/start.swe",
"Snapshot=t2.inf",
"Mode=HTML",
ITEMDATA,
"Name=SWEUserName", "Value=wrun", ENDITEM,
"Name=SWEPassword", "Value=wrun", ENDITEM,
"Name=SWERememberUser", "Value=Yes", ENDITEM,
"Name=SWENeedContext", "Value=false", ENDITEM,
"Name=SWEFo", "Value=SWEEntryForm", ENDITEM,
"Name=SWETS", "Value={SiebelTimeStamp}", ENDITEM,
"Name=SWECmd", "Value=ExecuteLogin", ENDITEM,
"Name=SWEBID", "Value=-1", ENDITEM,
"Name=SWEC", "Value=0", ENDITEM,
LAST);

lr_transaction_instance_add_info(0,lr_eval_string("SSQLBD:{Siebel_sn_body4}"));
lr_end_transaction("LoginSQLSync", LR_AUTO);
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Introducing RTE Vuser Scripts

RTE Vusers operate terminal emulators in Windows environments. This 
chapter describes how to develop Windows-based RTE Vuser scripts.

This chapter includes:

 ➤  About Developing RTE Vuser Scripts on page 851

 ➤  Introducing RTE Vusers on page 852

 ➤  Understanding RTE Vuser Technology on page 852

 ➤  Getting Started with RTE Vuser Scripts on page 853

 ➤  Using TE Functions on page 854

 ➤  Mapping Terminal Keys to PC Keyboard Keys on page 857

The following information applies only to RTE (Windows) Vuser scripts.

About Developing RTE Vuser Scripts

RTE Vusers operate terminal emulators in order to load test client/server 
systems. 

You record a terminal emulator session with VuGen to represent a true user’s 
actions. You can then enhance your recorded script with transaction and 
synchronization functions. 

This chapter describes how to develop Windows-based RTE Vuser scripts. 
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Introducing RTE Vusers

An RTE Vuser types character input into a terminal emulator, submits the 
data to a server, and then waits for the server to respond. For instance, 
suppose that you have a server that maintains customer information for a 
maintenance company. Every time a field service representative makes a 
repair, he accesses the server database by modem using a terminal emulator. 
The service representative accesses information about the customer and 
then records the details of the repair that he performs.

You could use RTE Vusers to emulate this case. An RTE Vuser would:

 1 Type 60 at the command line to open an application program.

 2 Type F296, the field service representative’s number.

 3 Type NY270, the customer number.

 4 Wait for the word "Details" to appear on the screen. The appearance of 
"Details" indicates that all the customer details are displayed on the screen. 

 5 Type Changed gasket P249, and performed Major Service the details of the 
current repair.

 6 Type Q to close the application program.

You use VuGen to create RTE Vuser scripts. The script generator records the 
actions of a human user in a terminal emulator. It records the keyboard 
input from the terminal window, generates the appropriate statements, and 
inserts them into the Vuser script. While you record, the script generator 
automatically inserts synchronization functions into the script. For details, 
see Chapter 57, “Synchronizing RTE Vuser Scripts.”

Understanding RTE Vuser Technology

An RTE Vuser emulates the actions of a real user. Human users use terminals 
or terminal emulators to operate application programs.

 TerminalApplication Human User
EmulatorProgram
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In the RTE Vuser environment, a Vuser replaces the human. The Vuser 
operates PowerTerm, a terminal emulator.

PowerTerm works like a standard terminal emulator, supporting common 
protocols such as IBM 3270 & 5250, VT100, VT220, and VT420-7. 

Getting Started with RTE Vuser Scripts

This section provides an overview of the process of developing RTE Vuser 
scripts using VuGen. 

To develop an RTE Vuser script: 

 1 Record the basic script using VuGen.

Use the Virtual User Generator (VuGen) to record the operations that you 
perform in a terminal emulator. VuGen records the keyboard input from the 
terminal window, generates the appropriate statements, and then inserts 
these statements into the Vuser script. 

For details, see Chapter 55, “Recording RTE Vuser Scripts.”

 2 Enhance the script.

Enhance the Vuser script by inserting transactions, rendezvous points, 
synchronization functions, and control-flow structures into the script.

For details, see “Enhancing Vuser Scripts” in Volume I-Using VuGen.

 3 Define parameters (optional).

Define parameters for the fixed-values recorded into your script. By 
substituting fixed-values with parameters, you can repeat the same business 
process many times using different values. 

For details, see “Creating Parameters” in Volume I-Using VuGen.

PowerTerm
Application

VuserProgram
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 4 Configure the run-time settings.

The run-time settings control the Vuser behavior during script execution. 
These settings include loop, log, and timing information. 

For details, see “Configuring Run-Time Settings” in Volume I-Using VuGen.

 5 Run the script from VuGen. 

Run the script from VuGen to verify that it runs correctly. View the standard 
output to verify that the program is communicating properly with the 
server. 

For details, see “Running Vuser Scripts in Standalone Mode” in Volume I-
Using VuGen.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

Using TE Functions

The functions developed to emulate a terminal communicating with a 
server are called TE Vuser functions. Each TE Vuser function has a TE prefix. 
VuGen automatically records most of the TE functions listed in this section 
during an RTE session. You can also manually program any of the functions 
into your script. 

The TE functions are divided into the following categories: Terminal 
Emulator Connection, Text Retrieval, Cursor, System Variable, Error Code, 
Typing, and Synchronization Functions.

You can also manually program any of the functions into your Vuser script. 
In text view, you can manually add new functions utilizing the Intellisense 
and Complete Function features. In Tree view, choose Insert > New Step and 
select the desired step. 

For syntax and examples of the TE functions, refer to the Online Function 
Reference (Help > Function Reference).
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Working with Ericom Terminal Emulation

VuGen supports record and replay with Ericom Terminal Emulators. 

The Ericom support handles escape sequences during record and replay. 
Ericom’s PowerTerm lets you map PC keys to custom escape sequences. For 
information about mapping, refer to the PowerTerm help.

When a user presses mapped keys while recording an Ericom VT session, 
VuGen generates TE_send_text functions instead of the standard TE_type. 
This allows the script to handle custom escape sequences in a single step. 
For more information, refer to the Online Function Reference (Help > Function 
Reference) for the TE_send_text function.

SSL and SSH Support for Ericom

VuGen also supports SSL/SSH record and replay for the RTE Ericom library. 
To work with SSL or SSH, you select the type in the Security section of the 
Connect dialog box. 
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When working with SSH Security, by default VuGen opens a popup dialog 
box prompting you for more information. It is recommended that you 
disable the Show options to prevent the popups from being issued. If you 
enable these popups, it may affect the replay. You can access the advanced 
security options by clicking the Details button.
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Mapping Terminal Keys to PC Keyboard Keys

Because you are using a terminal emulator, you will be using a PC keyboard 
in place of a terminal keyboard. Many keys that are found on the terminal 
keyboard are not available on a PC keyboard. Examples of such keys are 
HELP, AUTOR, and PUSH, which are found on the IBM 5250 keyboard. To 
successfully operate the terminal emulator and any associated application 
programs, you may have to map certain terminal keys to keys on the PC 
keyboard. 

To map a terminal key to a key on the PC keyboard:

 1 In the terminal emulator, select Options > Keyboard Map, or click the 
Keyboard Mapping button. The Keyboard Mapping dialog box opens.
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 2 Click the Keyboard Mapping button on the toolbar. To map a terminal key 
to a PC key, drag a key from the upper terminal keyboard to a PC key on the 
lower keyboard. 

You can click the Shift and/or Control keys on the upper keyboard to display 
additional key functions that can be viewed only by first selecting either of 
these keys. You can then drag the required key from the upper terminal 
keyboard to a key on the lower PC keyboard.

To cancel a definition, drag the PC key definition to the wastebasket. This 
restores the default function of the PC key.

To restore the default mappings, click Defaults.
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Recording RTE Vuser Scripts

You use VuGen to record Windows-based Remote Terminal Emulation (RTE) 
Vuser scripts.

This chapter includes:

 ➤  About Recording RTE Vuser Scripts on page 860

 ➤  Creating a New RTE Vuser Script on page 860

 ➤  Recording the Terminal Setup and Connection Procedure on page 861

 ➤  Recording Typical User Actions on page 865

 ➤  Recording the Log Off Procedure on page 866

 ➤  Setting RTE Configuration Options on page 867

 ➤  Setting the RTE Recording Options on page 868

 ➤  Typing Input into a Terminal Emulator on page 871

 ➤  Generating Unique Device Names on page 874

 ➤  Setting the Field Demarcation Characters on page 875

The following information applies only to Terminal Emulation (RTE) 
Vuser scripts.
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About Recording RTE Vuser Scripts

You use VuGen to record Windows-based RTE Vuser scripts. VuGen uses the 
PowerTerm terminal emulator to emulate a wide variety of terminal types. 
You use PowerTerm to perform a typical terminal connection, followed by 
typical business processes. Thereafter, you perform the log off procedure. 
While you perform typical user actions in the terminal emulator, VuGen 
generates the appropriate statements, and inserts them into a Vuser script. 
You can view and edit the script while recording.

Before recording an RTE Vuser script, ensure that the recording options are 
set correctly. The recording options allow you to control how VuGen 
generates certain functions while you record a Vuser script. VuGen applies 
the recording options during all subsequent recording sessions.

Creating a New RTE Vuser Script

Before recording a user’s actions into a Vuser script, you must open one. You 
can open an existing script, or create a new one. You use VuGen to create a 
new Vuser script. 

To create a new RTE Vuser script:

 1 Select Virtual User Generator from your product’s start menu. The VuGen 
window opens. 

 2 Click the New button. The New Virtual User dialog box opens:

 3 Select the Legacy protocol type, and choose Terminal Emulator (RTE). Click 
OK. VuGen generates and displays an empty RTE script, with the cursor 
positioned to begin recording in the vuser_init section. 
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Recording the Terminal Setup and Connection Procedure

After you create a skeleton Vuser script, you record the terminal setup and 
connection procedure into the script. VuGen uses the PowerTerm terminal 
emulator when you record an RTE Vuser script.

To record the terminal setup and connection procedure:

 1 Open an existing RTE Vuser script, or create a new one. 

 2 In the Sections box, select the section into which you want VuGen to insert 
the recorded statements. The available sections are vuser_init, Actions, and 
vuser_end.

Note: Always record the terminal setup and connection procedure into the 
vuser_init section. The vuser_init section is not repeated when you run 
multiple iterations of a Vuser script—only the Actions section is repeated. 
For more information on the iteration settings, see “Configuring Run-Time 
Settings” in Volume I-Using VuGen.
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 3 In the Vuser script, place the cursor at the location where you want to begin 
recording. 

 4 Click the Record button. The PowerTerm main window opens. 

 5 From the PowerTerm menu bar, select Terminal > Setup to display the 
Terminal Setup dialog box. 

 6 Select the type of emulation from the VT Terminal and IBM Terminal types, 
and then click OK.

Note: Select an IBM terminal type to connect to an AS/400 machine or an 
IBM mainframe; select a VT terminal type to connect to a UNIX 
workstation.
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 7 Select Communication > Connect to display the Connect dialog box. 

 8 Under Session Type, select the type of communication to use.

 9 Under Parameters, specify the required options. The available parameters 
vary depending on the type of session that you select. For details on the 
parameters, click Help.

Tip: Click Save As to save the parameter-sets for re-use in the future. The 
parameter-sets that you save are displayed in the Sessions List box.
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 10 Click Connect. PowerTerm connects to the specified system, and VuGen 
inserts a TE_connect function into the script, at the insertion point. The 
TE_connect statement has the following form:

The inserted TE_connect statement is followed by an if statement that 
checks whether or not the TE_connect function succeeds during replay.

Note: Do not record more than one connection to a server (TE_connect) in 
a Vuser script.

The terminal setup and connection procedure is complete. You are now 
ready to begin recording typical user actions into the Vuser script, as 
described below.

/* *** The terminal type is VT 420-7 */
TE_connect(

"comm-type = telnet;"
"host-name = alfa;"
"telnet-port = 992;"
"terminal-id = ;"
"set-window-size = true;"
"security-type = ssl;"
"ssl-type = tls1;"
"terminal-type = vt420-7;"
"terminal-model = vt220;"
"login-command-file = ;"
"terminal-setup-file = ;"
  60000);

if (TE_errno != TE_SUCCESS)
   return -1;
TE_wait_text("lt-alfa-kubuntu login: ",90);
TE_wait_cursor(24, 2, 100, 90);
lr_think_time(2);
TE_type("alfa<kReturn>");
TE_wait_text("Password: ",90);
TE_wait_cursor(11, 3, 100, 90);
lr_think_time(2);
TE_type("adServpw<kReturn>");
   return 0;
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Recording Typical User Actions

After recording the setup procedure, you perform typical user actions or 
business processes. You record these processes into the Actions section of the 
Vuser script. Only the Actions section of a Vuser script is repeated when you 
run multiple iterations of the script. For details on setting iterations, see 
“Configuring Run-Time Settings” in Volume I-Using VuGen.

When recording a session, VuGen records the text strokes and not the text. 
Therefore, it is not recommended that you copy and paste commands into 
the PowerTerm window—instead, type them in directly.

To record user actions:

 1 Open an existing RTE Vuser script, and then click Actions in the Section 
box.

 2 Proceed to perform typical user actions in the terminal emulator. VuGen 
generates the appropriate statements, and inserts them into the Vuser script 
while you type. If necessary, you can edit the recorded statements while you 
record the script.

Note: By default, VuGen waits a maximum of 5 seconds between successive 
keystrokes before generating the appropriate TE_type function. To change 
the waiting time, see “Setting the RTE Recording Options” on page 868.

When you finish recording the typical user actions, proceed to record the 
log off procedure, as described in the next section.
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Recording the Log Off Procedure

You record the Vuser log off process into the vuser_end section of the Vuser 
script. The vuser_end section is not repeated when you run many iterations 
of the script. For details on setting iterations, see “Configuring Run-Time 
Settings” in Volume I-Using VuGen.

To record the log off procedure:

 1 Ensure that you have performed and recorded the typical user actions as 
described in the previous section.

 2 In the VuGen main window, click vuser_end in the Section box. 

 3 Perform the log off procedure. VuGen records the procedure into the 
vuser_end section of the script.

 4 Click Stop Recording on the Recording toolbar. The main VuGen window 
displays all the recorded statements.

 5 Click Save to save the recorded session. The Save As dialog box opens (for 
new Vuser scripts only). Specify a script name. After recording a script, you 
can manually edit it in VuGen’s main window.
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Setting RTE Configuration Options

You can set the recording options to match the character set used during 
terminal emulation. The default character set is ANSI. For Kanji and other 
multi-byte platforms, you can specify DBCS (Double-byte Character Set).

To open the Configuration Recording Options, click the Recording Options 
button on the toolbar or select Tools > Recording Options. Select the 
RTE:Configuration node.
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Setting the RTE Recording Options

By setting the recording options, you can customize the code that VuGen 
generates for RTE functions. You use the Recording Options dialog box to set 
the recording options. 

To open the Recording Options dialog box, click the Recording Options 
button on the toolbar, or select Tools > Recording Options. Select the 
RTE:RTE node.

You can set the following recording options:

➤ Automatic Synchronization Commands

➤ Automatic Screen Header Comments (IBM terminals only)

➤ Automatic X-System Transactions (IBM terminals only)

➤ Keyboard Recording Timeout
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Automatic Synchronization Commands
VuGen can automatically generate a number of TE-synchronization 
functions, and insert them into the script while you record.

 1 You can specify that VuGen generate a TE_wait_sync function each time a 
new screen is displayed while recording. To do so, select the X-System check 
box in the Recording Options dialog box. 

By default, VuGen does automatically generate a TE_wait_sync function 
each time a new screen is displayed while recording.

Note: VuGen generates TE_wait_sync functions when recording IBM block 
mode terminals only.

 2 You can specify that VuGen generate a TE_wait_cursor function before each 
TE_type function. To do so, select the Cursor check box in the Recording 
Options dialog box. 

By default, VuGen does not automatically generate TE_wait_cursor 
functions.

 3 You can specify that VuGen generate a TE_wait_text function before each 
TE_type function (where appropriate). To do so, select the Prompt check box 
in the Recording Options dialog box. 

By default, VuGen does not automatically generate a TE_wait_text function 
before each TE_type function.

Note: VuGen generates meaningful TE_wait_text functions when recording 
VT type terminals only. Do not use automatic TE_wait_text function 
generation when recording block-mode (IBM) terminals.
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Automatic Screen Header Comments (IBM terminals only)
You can instruct VuGen to automatically generate screen header comments 
while recording a Vuser script, and insert the comments into the script.

Generated comments make a recorded script easier to read by identifying 
each new screen as it is displayed in the terminal emulator. A generated 
comment contains the text that appears on the first line of the terminal 
emulator window. The following generated comment shows that the Office 
Tasks screen was displayed in the terminal emulator:

To ensure that VuGen automatically generates comments while you record a 
script, select Generate screen header comments in the Recording Options 
dialog box. 

By default, VuGen does not automatically generate screen comments.

Note: You can generate comments automatically only when using block-
mode terminal emulators such as the IBM 5250.

Automatic X-System Transactions (IBM terminals only)
You can specify that VuGen record the time that the system was in the 
X SYSTEM mode during a scenario run. To do so, VuGen inserts a 
TE_wait_sync_transaction function after each TE_wait_sync function. 
Each TE_wait_sync_transaction function creates a transaction with the 
name "default". Each TE_wait_sync_transaction function records the time 
that the system spent in the previous X SYSTEM state.

To instruct VuGen to insert TE_wait_sync_transaction statements while 
recording, select the Generate automatic X SYSTEM transactions check box 
in the Recording Options dialog box. 

By default, VuGen does not automatically generate transactions.

/* OFCTSK                           Office Tasks                                   */
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Keyboard Recording Timeout
When you type text into a terminal emulator while recording, VuGen 
monitors the text input. After each keystroke, VuGen waits up to a specified 
amount of time for the next key stroke. If there is no subsequent keystroke 
within the specified time, VuGen assumes that the command is complete. 
VuGen then generates and inserts the appropriate TE_type function into 
the script. 

To set the maximum amount of time that VuGen waits between successive 
keystrokes, enter an amount in the Keyboard record timeout box.

By default, VuGen waits a maximum of 5 seconds between successive 
keystrokes before generating the appropriate TE_type function.

Typing Input into a Terminal Emulator

Two TE Vuser functions enable Vusers to "type" character input into the 
PowerTerm terminal emulator:

➤ TE_type sends characters to the terminal emulator. When recording, the 
VuGen automatically generates TE_type functions for keyboard input to 
the terminal window. For details, see “Using the TE_type Function” on 
page 872.

➤ TE_typing_style determines the speed at which the Vuser types. You can 
manually define the typing style by inserting a TE_typing_style function 
into the Vuser script. For details, see “Setting the Typing Style” on 
page 873. Alternatively, you can set the typing style by using the run-
time settings. For details, see Chapter 56, “Configuring RTE Run-Time 
Settings.”

Note: While recording an RTE Vuser script, do not use the mouse to relocate 
the cursor within the terminal emulator window. VuGen does not record 
these cursor movements. 
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Using the TE_type Function
When you record a script, the VuGen records all keyboard input and 
generates appropriate TE_type functions. During execution, TE_type 
functions send formatted strings to the terminal emulator. 

Keyboard input is defined as a regular text string (including blank spaces). 
For example:

Input key names longer than one character are represented by identifiers 
beginning with the letter k, and are bracketed within greater-than/less-than 
signs (< >). 

For example, the following function depicts the input of the Return key 
followed by the Control and y keys:

Some other examples include: <kF1>, <kUp>, <kF10>, <kHelp>, <kTab>.

To determine a key name, record an operation on the key, and then check 
the recorded statement for its name.

Note: When you program a TE_type statement (rather than recording it), 
use the key definitions provided in the Online Function Reference (Help > 
Function Reference).

Setting the Timeout Value for TE_type

If a Vuser attempts to submit a TE_type statement while the system is in 
X SYSTEM (or input inhibited) mode, the Vuser will wait until the 
X SYSTEM mode ends before typing. If the system stays in X SYSTEM mode 
for more than TE_XSYSTEM_TIMEOUT milliseconds, then the TE_type 
function returns a TE_TIMEOUT error. 

TE_type ("hello, world");

TE_type("<kReturn><kControl-y>");
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You can set the value of TE_XSYSTEM_TIMEOUT by using TE_setvar. The 
default value for TE_XSYSTEM_TIMEOUT is 30 seconds.

Allowing a Vuser to Type Ahead

Under certain circumstances you may want a Vuser to submit a keystroke 
even though the system is in X SYSTEM (or input inhibited) mode. For 
example, you may want the Vuser to press the Break key. You use the 
TE_ALLOW_TYPEAHEAD variable to enable the Vuser to submit a keystroke 
even though the system is in X SYSTEM mode.

Set TE_ALLOW_TYPEAHEAD to zero to disable typing ahead, and to any 
non-zero number to permit typing ahead. You use TE_setvar to set the value 
of TE_ALLOW_TYPEAHEAD. By default, TE_ALLOW_TYPEAHEAD is set to 
zero, preventing keystrokes from being sent during X SYSTEM mode. 

For more information about the TE_type function and its conventions, refer 
to the Online Function Reference (Help > Function Reference).

Setting the Typing Style
You can set two typing styles for RTE Vuser: FAST and HUMAN. In the FAST 
style, the Vuser types input into the terminal emulator as quickly as 
possible. In the HUMAN style, the Vuser pauses after typing each character. 
In this way, the Vuser more closely emulates a human user typing at the 
keyboard.

You set the typing style using the TE_typing_style function. The syntax of 
the TE_typing_style function is:

int TE_typing_style (char *style);

where style can be FAST or HUMAN. The default typing style is HUMAN. If 
you select the HUMAN typing style, the format is:

HUMAN, delay [,first_delay]
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The delay indicates the interval (in milliseconds) between keystrokes. The 
optional parameter first_delay indicates the wait (in milliseconds) before 
typing the first character in the string. For example,

means that the Vuser will wait 0.5 seconds before typing the letter A; it will 
then wait 0.1 seconds before typing "B" and then a further 0.1 seconds 
before typing "C".

For more information about the TE_typing_style function and its 
conventions, refer to the Online Function Reference (Help > Function 
Reference).

In addition to setting the typing style by using the TE_typing_style 
function, you can also use the run-time settings. For details, see Chapter 56, 
“Configuring RTE Run-Time Settings.”

Generating Unique Device Names

Some protocols, such as APPC, require a unique device name for each 
terminal that logs on to the system. Using the run-time settings, you can 
specify that the TE_connect function generate a unique 8-character device 
name for each Vuser, and connect using this name. Although this solves the 
requirement for uniqueness, some systems have an additional requirement: 
The device names must conform to a specific format. For details about the 
run-time settings, see Chapter 13, “Configuring Run-Time Settings.”

To define the format of the device names that the TE_connect function uses 
to connect a Vuser to the system, add an RteGenerateDeviceName function 
to the Vuser script. The function has the following prototype:

void RteGenerateDeviceName(char buf[32])

The device name should be written into buf.

TE_typing_style ("HUMAN, 100, 500");
TE_type ("ABC");
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If an RteGenerateDeviceName function exists in a Vuser script, the Vuser 
calls the function each time a new device name is needed. If no 
RteGenerateDeviceName function is defined in the script—and unique 
device names are required—the TE_connect function generates the required 
names.

In the following example, the RteGenerateDeviceName function generates 
unique device names with the format "TERMx". The first name is TERM0, 
followed by TERM1, TERM2, and so forth.

Setting the Field Demarcation Characters

Some terminal emulators use demarcation characters to mark the beginning 
and the end of each field. These demarcation characters are not visible—
appearing on the screen as spaces. In the terminal emulator shown below, 
the colors in the middle section of the screen have been inverted to display 
the field demarcation characters. These characters are surrounded by 
ellipses.

RteGenerateDeviceName(char buf[32])
{
static int n=0;
sprintf(buf, "TERM%d", n);
n=n+1;

}
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The TE_wait_text, TE_get_text, and TE_find_text functions operate by 
identifying the characters in a specified portion of the screen. If a field 
demarcation character is located within the specified section, you can 
choose to identify the character either as a space, or as an ASCII character. 
You use the TE_FIELD_CHARS system variable to specify the method of 
identification. You can set TE_FIELD_CHARS to 0 or 1:

➤ 0 specifies that the character in the position of the field demarcation 
characters is returned as a space. 

➤ 1 specifies that the character in the position of the field demarcation 
characters is returned as an ascii code (ascii 0 or ascii 1). 

By default, TE_FIELD_CHARS is set to 0.

You retrieve and set the value of TE_FIELD_CHARS by using the TE_getvar 
and TE_setvar functions.
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Configuring RTE Run-Time Settings 

After you record a Terminal Emulator script, you configure its run-time 
settings. 

This chapter includes:

 ➤  About Terminal Emulator Run-Time Settings on page 878

 ➤  Modifying Connection Attempts on page 879

 ➤  Specifying an Original Device Name on page 880

 ➤  Setting the Typing Delay on page 880

 ➤  Configuring the X-System Synchronization on page 881

The following information only applies to Terminal Emulator (TE) type 
Vusers.
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About Terminal Emulator Run-Time Settings

After developing a Terminal Emulator Vuser script, you set the run-time 
settings. These settings let you control the behavior of the Vuser when 
running the script. Terminal Emulator run-time settings allow you to 
configure your TE Vusers so that they accurately emulate real users 
performing remote terminal emulation. You can configure settings for the 
number of connection attempts, device names, typing delay, and X-System 
synchronization.

You set the Terminal Emulator related run-time settings through the RTE 
node in the Run-Time Settings dialog box.

To display the Run-Time Settings dialog box, click the Run-Time Settings 
button on the VuGen toolbar. You can also modify the run-time settings 
from the LoadRunner Controller. For more information, refer to the HP 
LoadRunner Controller User’s Guide.
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Note: This chapter only discusses the Run-Time settings for Terminal 
Emulator Vusers. For information about run-time settings that apply to all 
Vusers, see “Configuring Run-Time Settings” in Volume I-Using VuGen.

Modifying Connection Attempts

The TE_connect function is generated by VuGen when you record a 
connection to a host. When you replay an RTE Vuser script, the TE_connect 
function connects the terminal emulator to the specified host. If the first 
attempt to connect is not successful, the Vuser retries a number of times to 
connect successfully. Details of each connection are recorded in the report 
file output.txt.

To set the maximum number of times that a Vuser will try to connect, enter 
a number in the Maximum number of connection attempts box in the RTE 
Run-Time settings.

By default, a Vuser will try to connect 5 times.

For more information about the TE_connect function, refer to the Online 
Function Reference (Help > Function Reference). 
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Specifying an Original Device Name

In certain environments, each session (Vuser) requires a unique device 
name. The TE_connect function generates a unique 8-character device 
name for each Vuser, and connects using this name. To connect using the 
device name (that is contained within the com_string parameter of the 
TE_connect function), select the Use original device name option in the 
RTE Run-Time settings.

Note: The original device name setting applies to IBM block-mode terminals 
only.

By default, Vusers use original device names to connect.

For details about the TE_connect function, refer to the Online Function 
Reference (Help > Function Reference). 

Setting the Typing Delay

The delay setting determines how Vusers execute TE_type functions.

To specify the amount of time that a Vuser waits before entering the first 
character in a string, enter a value in the First key box, in milliseconds.

To specify the amount of time that a Vuser waits between submitting 
successive characters, enter a value in the Subsequent keys box, in 
milliseconds. 

If you enter zero for both the first key and the subsequent key delays, the 
Vuser will send characters as a single string, with no delay between 
characters.

You can use the TE_typing_style function to override the Delay settings for 
a portion of a Vuser script. 

For details about the TE_type and TE_typing_style functions, refer to the 
Online Function Reference (Help > Function Reference). 
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Configuring the X-System Synchronization

RTE Vuser scripts use the TE_wait_sync function for synchronization. You 
can set a timeout value and a stable-time value that VuGen applies to all 
TE_wait_sync functions. For details about the TE_wait_sync function, refer 
to the Online Function Reference (Help > Function Reference). 

Timeout

When you replay a TE_wait_sync function, if the system does not stabilize 
before the synchronization timeout expires, the TE_wait_sync function 
returns an error code. To set the synchronization timeout, enter a value (in 
seconds) in the Timeout section of the RTE Run-Time settings.

The default timeout value is 60 seconds.

Stable Time

After a Vuser executes a TE_wait_sync function, the Vuser waits until the 
terminal is no longer in the X-SYSTEM mode. After the terminal returns 
from the X-SYSTEM mode, the Vuser still monitors the system for a short 
time. This makes sure that the terminal has become stable, that is, that the 
system has not returned to the X-SYSTEM mode. Only then does the 
TE_wait_sync function terminate. 

To set the time that a Vuser continues to monitor the system after the 
system has returned from the X-SYSTEM mode, enter a value (in 
milliseconds) in the Stable time box of the RTE Run-Time settings.

The default stable time is 1000 milliseconds.
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Synchronizing RTE Vuser Scripts

Synchronization functions in an RTE Vuser script help you synchronize the 
input that a Vuser submits to a terminal emulator with the responses from 
the server.

This chapter includes:

 ➤  About Synchronizing Vuser Scripts on page 883

 ➤  Synchronizing Block-Mode (IBM) Terminals on page 885

 ➤  Synchronizing Character-Mode (VT) Terminals on page 888

The following information applies only to Terminal Emulation (RTE) 
Vuser scripts.

About Synchronizing Vuser Scripts

Depending on the system you are testing, you may need to synchronize the 
input that a Vuser sends to a terminal emulator with the subsequent 
responses from the server. When you synchronize input, you instruct the 
Vuser to suspend script execution and wait for a cue from the system, before 
the Vuser performs its next action. For instance, suppose that a human user 
wants to submit the following sequence of key strokes to a bank application:

 1 Type 1 to select "Financial Information" from the menu of a bank 
application.

 2 When the message "What information do you require?" appears, type 3 to 
select "Dow Jones Industrial Average" from the menu.

 3 When the full report has been written to the screen, type 5 to exit the bank 
application.
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In this example, the input to the bank application is synchronized because 
at each step, the human user waits for a visual cue before typing. 
This cue can be either the appearance of a particular message on the screen, 
or stability of all the information on the screen.

You can synchronize the input of a Vuser in the same way by using the TE-
synchronization functions, TE_wait_sync, TE_wait_text, TE_wait_silent, 
and TE_wait_cursor. These functions effectively emulate a human user who 
types into a terminal window and then waits for the server to respond, 
before typing in the next command. 

The TE_wait_sync function is used to synchronize block-mode (IBM) 
terminals only. The other TE-synchronization functions are used to 
synchronize character-mode (VT) terminals.

When you record an RTE Vuser script, VuGen can automatically generate 
and insert TE_wait_sync, TE_wait_text, and TE_wait_cursor statements 
into the script. You use VuGen’s recording options to specify which 
synchronization functions VuGen should insert. 

Note: Do not include any synchronization statements in the Vuser_end 
section of a Vuser script. Since a Vuser can be aborted at any time, you 
cannot predict when the Vuser_end section will be executed.
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Synchronizing Block-Mode (IBM) Terminals

The TE_wait_sync function is used for synchronization RTE Vusers 
operating block-mode (IBM) terminals. Block-mode terminals display the 
"X SYSTEM" message to indicate that the system is in Input Inhibited mode. 
When a system is in the Input Inhibited mode no typing can take place 
because the terminal emulator is waiting for a transfer of data from the 
server.

When you record a script on a block-mode terminal, by default, VuGen 
generates and inserts a TE_wait_sync function into the script each time the 
"X SYSTEM" message appears. You use VuGen’s recording options to specify 
whether or not VuGen should automatically insert TE_wait_sync functions. 

When you run a Vuser script, the TE_wait_sync function checks if the 
system is in the X SYSTEM mode. If the system is in the X SYSTEM mode, 
the TE_wait_sync function suspends script execution. When the "X 
SYSTEM" message is removed from the screen, script execution continues. 

Note: You can use the TE_wait_sync function only with IBM block-mode 
terminals emulators (5250 and 3270).

In general, the TE_wait_sync function provides adequate synchronization 
for all block-mode terminal emulators. However, if the TE_wait_sync 
function is ineffective in a particular situation, you can enhance the 
synchronization by including a TE_wait_text function. For more 
information on the TE_wait_text function, see “Waiting for Text to Appear 
on the Screen” on page 890, and the Online Function Reference (Help > 
Function Reference).

The syntax of the TE_wait_sync function is:

TE_wait_sync ();
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In the following script segment, the Vuser logs on with the user name 
"QUSER" and the password "HPLAB". The Vuser then presses Enter to submit 
the login details to the server. The terminal emulator displays the X SYSTEM 
message while the system waits for the server to respond. 

The TE_wait_sync statement causes the Vuser to wait until the server has 
responded to the login request, that is, for the X SYSTEM message to be 
removed—before executing the next line of the script.

When a TE_wait_sync function suspends the execution of a script while an 
X SYSTEM message is displayed, the Vuser continues to monitor the 
system—waiting for the X SYSTEM message to disappear. If the X SYSTEM 
message does not disappear before the synchronization timeout expires, the 
TE_wait_sync function returns an error code. The default timeout is 60 
seconds.

To set the TE_wait_sync synchronization timeout:

 1 Select Vuser > Run-Time Settings. The Run-Time Settings dialog box appears.

 2 Select the RTE:RTE node in the Run-Time setting tree.

 3 Under X SYSTEM Synchronization, enter a value (in seconds) in the Timeout 
box.

 4 Click OK to close the Run-Time Settings dialog box. 

TE_type("QUSER");
lr_think_time(2);
TE_type("<kTab>HPLAB");
lr_think_time(3);
TE_type("<kEnter>");
TE_wait_sync();
....
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After a Vuser executes a TE_wait_sync function, the Vuser waits until the 
terminal is no longer in the X SYSTEM mode. When the terminal returns 
from the X SYSTEM mode, the Vuser continues to monitor the system for a 
short period to verify that the terminal is fully stable, that is, that the system 
does not return to the X SYSTEM mode. Only then does the TE_wait_sync 
function terminate and allow the Vuser to continue executing its script. The 
period that the Vuser continues to monitor the system, after the system has 
returned from the X SYSTEM mode, is known as the stable time. The default 
stable time is 1000 milliseconds.

You may need to increase the stable time if your system exhibits the 
following behavior:

When a system returns from the X SYSTEM mode, some systems "flickers" to 
and from the X SYSTEM for a short period of time until the system 
stabilizes. If the system remains out of the X SYSTEM mode for more than 
one second, and then returns to the X SYSTEM mode, the TE_wait_sync 
function will assume that the system is stable. If a Vuser then tries to type 
information to the system, the system will shift into keyboard-locked mode.

Alternatively, if your system never flickers when it returns from the 
X SYSTEM mode, you can reduce the stable time to less than the default 
value of one second. 

To change the stable time for TE_wait_sync functions:

 1 Choose Vuser > Run-Time Settings. The Run-Time Settings dialog box 
appears.

 2 Select the RTE:RTE node.

 3 Under X SYSTEM Synchronization, enter a value (in milliseconds) in the 
Stable time box.

 4 Click OK to close the Run-Time Settings dialog box. 

For more information on the TE_wait_sync function, refer to the Online 
Function Reference (Help > Function Reference).
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You can instruct VuGen to record the time that the system remains in the 
X SYSTEM mode each time that the X SYSTEM mode is entered. To do so, 
VuGen inserts a TE_wait_sync_transaction function after each TE_wait_sync 
function, as shown in the following script segment:

Each TE_wait_sync_transaction function creates a transaction with the 
name "default." This allows you to analyze how long the terminal emulator 
waits for responses from the server during a scenario run. You use the 
recording options to specify whether VuGen should generate and insert 
TE_wait_sync_transaction statements. 

To instruct VuGen to insert TE_wait_sync_transaction statements: 

 1 Choose Vuser > Recording Options. The Recording Settings dialog box 
appears.

 2 Select the Generate Automatic X SYSTEM transactions option, and then 
click OK. 

Synchronizing Character-Mode (VT) Terminals

There are three types of synchronization that you can use for character-
mode (VT) terminals. The type of synchronization that you select depends 
on:

➤ the design of the application that is running in the terminal emulator

➤ the specific action to be synchronized

Waiting for the Cursor to Appear at a Specific Location
The preferred method of synchronization for VT type terminals is cursor 
synchronization. Cursor synchronization is particularly useful with full-
screen or form-type applications, as opposed to scrolling or TTY-type 
applications.

TE_wait_sync();
TE_wait_sync_transaction("syncTrans1");
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Cursor synchronization uses the TE_wait_cursor function. When you run 
an RTE Vuser script, the TE_wait_cursor function instructs a Vuser to 
suspend script execution until the cursor appears at a specified location on 
the screen. The appearance of the cursor at the specified location means that 
the application is ready to accept the next input from the terminal emulator. 

The syntax of the TE_wait_cursor function is:

int TE_wait_cursor (int col, int row, int stable, int timeout);

During script execution, the TE_wait_cursor function waits for the cursor to 
reach the location specified by col, row. 

The stable parameter specifies the time (in milliseconds) that the cursor 
must remain at the specified location. If you record a script using VuGen, 
stable is set to 100 milliseconds by default. If the client application does not 
become stable in the time specified by the timeout parameter, the function 
returns TIMEOUT. If you record a script using VuGen, timeout is set by 
default to the value of TIMEOUT, which is 90 seconds. You can change the 
value of both the stable and timeout parameters by directly editing the 
recorded script.

The following statement waits for the cursor to remain stable for three 
seconds. If the cursor doesn’t stabilize within 10 seconds, the function 
returns TIMEOUT.

For more information on the TE_wait_cursor function, refer to the Online 
Function Reference (Help > Function Reference).

You can instruct VuGen to automatically generate TE_wait_cursor 
statements, and insert them into a script, while you record the script. The 
following is an example of a TE_wait_cursor statement that was 
automatically generated by VuGen:

TE_wait_cursor (10, 24, 3000, 10);

TE_wait_cursor(7, 20, 100, 90);
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To instruct VuGen to automatically generate TE_wait_cursor statements, 
and insert them into a script while recording: 

 1 Select Vuser > Recording Options. The Recording Settings dialog box 
appears.

 2 Under Generate Automatic Synchronization Commands select the Cursor 
check box, and then click OK. 

Waiting for Text to Appear on the Screen
You can use text synchronization to synchronize an RTE Vuser running on a 
VT terminal emulator. Text synchronization uses the TE_wait_text 
function. During script execution, the TE_wait_text function suspends 
script execution and waits for a specific string to appear in the terminal 
window before continuing with script execution. Text synchronization is 
useful with those applications in which the cursor does not consistently 
appear in a predefined area on the screen. 

Note: Although text synchronization is designed to be used with character 
mode (VT) terminals, it can also be used with IBM block-mode terminals. Do 
not use automatic text synchronization with block-mode terminals.

The syntax of the TE_wait_text function is:

int TE_wait_text (char *pattern, int timeout, int col1, int row1, int col2, int row2, 
int *retcol, int *retrow, char *match);

This function waits for text matching pattern to appear within the rectangle 
defined by col1, row1, col2, row2. Text matching the pattern is returned to 
match, and the actual row and column position is returned to retcol and 
retrow. If the pattern does not appear before the timeout expires, the 
function returns an error code. The pattern can include a regular expression. 
Refer to the Online Function Reference for details on using regular expressions. 
Besides the pattern and timeout parameters, all the other parameters are 
optional.
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If pattern is passed as an empty string, the function will wait for timeout if it 
finds any text at all within the rectangle. If there is no text, it returns 
immediately. 

If the pattern does appear, then the function waits for the emulator to be 
stable (finish redrawing, and not display any new characters) for the interval 
defined by the TE_SILENT_SEC and TE_SILENT_MILLI system variables. 
This, in effect, allows the terminal to become stable and emulates a human 
user. 

If the terminal does not become stable within the interval defined by 
TE_SILENT_TIMEOUT, script execution continues. The function returns 0 
for success, but sets the TE_errno variable to indicate that the terminal was 
not silent after the text appeared. 

To modify or retrieve the value of any of the TE_SILENT system variables, 
use the TE_getvar and TE_setvar functions. For more information, refer to 
the Online Function Reference (Help > Function Reference).

In the following example, the Vuser types in its name, and then waits for 
the application to respond.

You can instruct VuGen to automatically generate TE_wait_text statements, 
and insert them into a script, while you record the script. 

/* Declare variables for TE_wait_text */
int ret_row;
int ret_col;
char ret_text [80];

/* Type in user name. */
TE_type ("John");

/* Wait for teller to respond. */
TE_wait_text ("Enter secret code:", 30, 29, 13, 1, 13, &ret_col, &ret_row,

ret_text);
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To instruct VuGen to automatically generate TE_wait_text statements, and 
insert them into a script while recording: 

 1 Select Vuser > Recording Options. The Recording Settings dialog box 
appears.

 2 Under Generate Automatic Synchronization Commands, select the Prompt 
check box, and then click OK. 

The following is an example of a TE_wait_text statement that was 
automatically generated by VuGen. The function waits up to 20 seconds for 
the string "keys" to appear anywhere on the screen. Note that VuGen omits 
all the optional parameters when it generates a TE_wait_text function. 

Waiting for the Terminal to be Silent
In instances when neither cursor synchronization nor text synchronization 
are effective, you can use "silent synchronization" to synchronize the script. 
With "silent synchronization," the Vuser waits for the terminal emulator to 
be silent for a specified period of time. The emulator is considered to be 
silent when it does not receive any input from the server for a specified 
period of time.

Note: Use silent synchronization only when neither cursor synchronization 
nor text synchronization are effective.

You use the TE_wait_silent function to instruct a script to wait for the 
terminal to be silent. You specify the period for which the terminal must be 
silent. If the terminal is silent for the specified period, then the 
TE_wait_silent function assumes that the application has stopped printing 
text to the terminal screen, and that the screen has stabilized. 

The syntax of the function is:

TE_wait_text("keys", 20);

int TE_wait_silent (int sec, int milli, int timeout);
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The TE_wait_silent function waits for the terminal emulator to be silent for 
the time specified by sec (seconds) and milli (milliseconds). The emulator is 
considered silent when it does not receive any input from the server. If the 
emulator does not become silent (i.e. stop receiving characters) during the 
time specified by the time timeout variable, then the function returns an 
error.

For example, the following statement waits for the screen to be stable for 
three seconds. If after ten seconds, the screen has not become stable, the 
function returns an error.

For more information, refer to the Online Function Reference (Help > Function 
Reference).

TE_wait_silent (3, 0, 10);
893



Chapter 57 • Synchronizing RTE Vuser Scripts
894



58
Reading Text from the Terminal Screen

RTE Vusers can read text from the user interface of a terminal emulator, and 
then perform various tasks with that text.

This chapter includes:

 ➤  About Reading Text from the Terminal Screen on page 895

 ➤  Searching for Text on the Screen on page 896

 ➤  Reading Text from the Screen on page 896

The following information applies only to RTE (Windows) Vuser scripts.

About Reading Text from the Terminal Screen

There are several Vuser functions that RTE Vusers can use to read text from 
the terminal screen. You can use these functions, TE_find_text and 
TE_get_text_line, to check that the terminal emulator is responding 
correctly, or to enhance the logic in your scripts.

After recording, you can manually insert TE_find_text and TE_get_text_line 
statements directly into your RTE Vuser scripts. 
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Searching for Text on the Screen

The TE_find_text function searches for a line of text on the screen. The 
syntax of the function is:

int TE_find_text (char *pattern, int col1, int row1, int col2, int row2,
int *retcol, int *retrow, char *match);

This function searches for text matching pattern within the rectangle 
defined by col1, row1, col2, row2. Text matching the pattern is returned to 
match, and the actual row and column position is returned to retcol and 
retrow. The search begins in the top-left corner. If more than one string 
matches pattern, the one closest to the top-left corner is returned. 

The pattern can include a regular expression. Refer to the Online Function 
Reference for details on using regular expressions.

You must manually type TE_find_text statements into your Vuser scripts. For 
details on the syntax of the TE_find_text function, refer to the Online 
Function Reference (Help > Function Reference).

Reading Text from the Screen

The TE_get_text_line function reads a line of text from the area of the screen 
that you designate. The syntax of the function is:

char *TE_get_text_line (int col, int row, int width, char *text);

This function copies a line of text from the terminal screen to a buffer text. 
The first character in the line is defined by col, row. The column coordinate 
of the last character in the line is indicated by width. The text from the 
screen is returned to the buffer text. If the line contains tabs or spaces, the 
equivalent number of spaces is returned. 
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In addition, the TE_get_cursor_position function can be used to retrieve the 
current position of the cursor on the terminal screen. The 
TE_get_line_attribute function returns the character formatting (for 
instance, bold or underline) of a line of text. 

You must manually type TE_get_text_line statements into your Vuser 
scripts. For details on the syntax of the TE_get_text_line function, refer to 
the Online Function Reference (Help > Function Reference).
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59
Developing Vuser Scripts for Mailing 
Services

VuGen allows you to test several mailing services on a protocol level. It 
emulates the sending of mail, and most of the standard operations 
performed against a mail server.

This chapter includes:

 ➤  About Developing Vuser Scripts for Mailing Services on page 902

 ➤  Getting Started with Mailing Services Vuser Scripts on page 902

 ➤  Understanding IMAP Scripts on page 904

 ➤  Understanding MAPI Scripts on page 905

 ➤  Understanding POP3 Scripts on page 906

 ➤  Understanding SMTP Scripts on page 907

The following information applies only to IMAP, MAPI, POP3, and SMTP 
Viuser scripts.
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About Developing Vuser Scripts for Mailing Services

The Mailing Service protocols emulate a user working with an email client, 
viewing and sending emails. The following mailing services are supported: 

➤ Internet Messaging (IMAP)

➤ MS Exchange (MAPI)

➤ Post Office Protocol (POP3)

➤ Simple Mail Transfer Protocol (SMTP)

The mail protocols support both record and replay, with the exception of 
MAPI that only supports replay. 

When you record an application using one of the mail protocols, VuGen 
generates functions that emulate the mail client’s actions. You can indicate 
the programming language in which to create a Vuser script —either C or 
Visual Basic scripting. For more information, see “Setting Script Generation 
Preferences” in Volume I-Using VuGen. If the communication is performed 
through multiple protocols, you can record both of them. You can record 
several mail protocols, or a mail protocol together with HTTP or WinSock. 
For instructions on specifying multiple protocols, see “Recording with 
VuGen” in Volume I-Using VuGen.

All Mailing Service functions come in pairs—one for global sessions and one 
where you can indicate a specific mail session. For example, imap_logon 
logs on to the IMAP server globally, while imap_logon_ex logs on to the 
IMAP server for a specific session. 

Getting Started with Mailing Services Vuser Scripts

This section provides an overview of the process of developing Vuser scripts 
for Mailing Services using VuGen. 

To develop a Mailing Service Vuser script: 

 1 Create a basic script using VuGen.

Invoke VuGen and create a new Vuser script for either a single mail protocol 
or multiple protocols. 
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 2 Record the basic script using VuGen. (Except MAPI)

Choose an application to record. Perform typical operations in your 
application. For details, see “Recording with VuGen” in Volume I-Using 
VuGen. 

For MAPI, recording is not supported. Instead, you create an empty MAPI 
script and manually insert mapi functions into it. For examples, refer to the 
Online Function Reference (Help > Function Reference).

 3 Enhance the script.

Enhance the script by inserting transactions, rendezvous points, and 
control-flow structures into the script.

For details, see “Enhancing Vuser Scripts” in Volume I-Using VuGen.

 4 Define parameters (optional).

Define parameters for the fixed-values recorded into your script. By 
substituting fixed-values with parameters, you can repeat the same business 
process many times using different values. 

For details, see “Creating Parameters” in Volume I-Using VuGen.

 5 Correlate statements (optional).

Correlating statements enables you to use the result of one business process 
in a subsequent one. 

For details, see “Correlating Statements” in Volume I-Using VuGen.

 6 Configure the run-time settings.

The run-time settings control the Vuser behavior during script execution. 
These settings include loop, log, and timing information. 

For details, see “Configuring Run-Time Settings” in Volume I-Using VuGen.

 7 Run the script from VuGen. 

Save and run the script from VuGen to verify that it runs correctly.

For details, see “Running Vuser Scripts in Standalone Mode” in
Volume I-Using VuGen.
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After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

Understanding IMAP Scripts

IMAP Vuser script functions record the Internet Mail Application Protocol. 
Each IMAP function begins with an imap prefix. 

For detailed syntax information on these functions, refer to the Online 
Function Reference (Help > Function Reference).

In the following example, the imap_create function creates several new 
mailboxes: Products, Solutions, and FAQs. 

Actions()
{
imap_logon("ImapLogon",

"URL=imap://johnd:letmein@exchange.mycompany.com",
LAST);

imap_create("CreateMailboxes",
"Mailbox=Products",
"Mailbox=Solutions",
"Mailbox=FAQs",
LAST);

imap_logout();

return 1;
}
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Understanding MAPI Scripts

MAPI Vuser script functions record activity to and from an MS Exchange 
server. Each MAPI function begins with an mapi prefix. 

For detailed syntax information on these functions, refer to the Online 
Function Reference (Help > Function Reference).

In the following example, the mapi_send_mail function sends a sticky note 
through an MS Exchange server.

Actions()
{
mapi_logon("Logon",

"ProfileName=John Smith",
"ProfilePass=Tiger",
LAST);

//Send a Sticky Note message
mapi_send_mail("SendMail",

"To=user1@techno.merc-int.com",
"Cc=user0002t@techno.merc-int.com",
"Subject=<GROUP>:<VUID> @ <DATE>",
"Type=Ipm.StickyNote",
"Body=Please update your profile today.",
LAST);

mapi_logout();
return 1;

}

905



Chapter 59 • Developing Vuser Scripts for Mailing Services
Understanding POP3 Scripts

POP3 Vuser script functions emulate actions using the Post Office Protocol, 
POP3. Each function begins with a pop3 prefix. 

For detailed syntax information on these functions, refer to the Online 
Function Reference (Help > Function Reference).

In the following example, the pop3_retrieve function retrieves five 
messages from the POP3 server. 

Actions()
{
pop3_logon("Login", "

URL=pop3://user0004t:my_pwd@techno.merc-int.com", 
LAST);

// List all messages on the server and receive that value
totalMessages = pop3_list("POP3", LAST);

// Display the received value (It is also displayed by the pop3_list function)
lr_log_message("There are %d messages.\r\n\r\n", totalMessages);

// Retrieve 5 messages on the server without deleting them
pop3_retrieve("POP3", "RetrieveList=1:5", "DeleteMail=false", LAST);
pop3_logoff();
return 1;

}
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Understanding SMTP Scripts

SMTP Vuser script functions emulate the Single Mail Transfer Protocol 
traffic. Each SMTP function begins with an smtp prefix. 

For detailed syntax information on these functions, refer to the Online 
Function Reference (Help > Function Reference).

In the following example, the smtp_send_mail function sends a mail 
message, through the SMTP mail server, techno. 

Actions()
{
smtp_logon("Logon",

               "URL=smtp://user0001t@techno.merc-int.com",
   "CommonName=Smtp Test User 0001",

               NULL);

smtp_send_mail("SendMail",
"To=user0002t@merc-int.com",
"Subject=MIC Smtp: Sample Test",
"MAILOPTIONS",
"X-Priority: 3",
"X-MSMail-Priority: Medium",
"X-Mailer: Microsoft Outlook Express 5.50.400\r\n",
"X-MimeOLE: By Microsoft MimeOLE V5.50.00\r\n",
"MAILDATA",
"MessageText="

"Content-Type: text/plain;\r\n"
"\tcharset=\"iso-8859-1\"\r\n"
"Test,\r\n"
"MessageBlob=16384",

NULL);

smtp_logout();

return 1;
}

907



Chapter 59 • Developing Vuser Scripts for Mailing Services
908



Part XIII

Middleware Protocols



910



60
Developing Tuxedo Vuser Scripts 

You use VuGen to record communication between a Tuxedo client 
application and a Tuxedo application server. The resulting script is called a 
Tuxedo Vuser script.

This chapter includes:

 ➤  About Tuxedo Vuser Scripts on page 912

 ➤  Getting Started with Tuxedo Vuser Scripts on page 913

 ➤  Understanding Tuxedo Vuser Scripts on page 914

 ➤  Viewing Tuxedo Buffer Data on page 917

 ➤  Defining Environment Settings for Tuxedo Vusers on page 918

 ➤  Debugging Tuxedo Applications on page 919

 ➤  Correlating Tuxedo Scripts on page 919

The following information applies only to PeopleSoft-Tuxedo, Tuxedo 6 
and Tuxedo Vuser scripts.
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About Tuxedo Vuser Scripts

When you record a Tuxedo application, VuGen generates LRT functions that 
describe the recorded actions. These functions emulate communication 
between a Tuxedo client and a server. Each LRT function begins with an lrt 
prefix. 

In addition to the lrt prefix, certain functions use an additional prefix of tp, 
tx or F. These sub-prefixes indicate the function type, similar to the actual 
Tuxedo functions. The tp sub-prefix indicates a Tuxedo client tp session. For 
example, lrt_tpcall sends a service request and awaits its reply. The tx sub-
prefix indicates a global tx session. For example, lrt_tx_begin begins a 
global transaction. The F sub-prefix indicates an FML buffer related 
function. For example, lrt_Finitialize initializes an existing buffer. 

Functions without an additional prefix emulate standard C functions. For 
example, lrt_strcpy copies a string, similar to the C function strcpy.

You can view and edit the recorded script from VuGen’s main window. The 
LRT functions that are recorded during the session are displayed in the 
VuGen window, allowing you to visually track your network activities.

Before You Record
Before you record, verify that the Tuxedo directory, %TUXDIR%\bin is in 
the path. 

If the environment variables have changed since the last time you restarted 
VuGen, VuGen may record the original variable value rather than the 
current value. 

To avoid any inconsistencies, you should restart VuGen before recording 
Tuxedo applications.
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Getting Started with Tuxedo Vuser Scripts

This section provides an overview of the process of developing Tuxedo Vuser 
scripts using VuGen. 

To develop a Tuxedo Vuser script: 

 1 Record the basic script using VuGen.

Invoke VuGen and create a new Vuser script. Specify Tuxedo 6 (for recording 
Tuxedo Version 6.x) or Tuxedo (for recording Tuxedo Version 7.x) as the 
type of Vuser. Choose an application to record. Record typical operations on 
your application.

For details, see “Recording with VuGen” in Volume I-Using VuGen.

 2 Enhance the script.

Enhance the script by inserting transactions, rendezvous points, and 
control-flow structures into the script.

For details, see “Enhancing Vuser Scripts” in Volume I-Using VuGen.

 3 Define parameters (optional).

Define parameters for the fixed-values recorded into your script. By 
substituting fixed-values with parameters, you can repeat the same business 
process many times using different values. 

For details, see “Creating Parameters” in Volume I-Using VuGen.

 4 Correlate statements (optional).

Correlating statements enables you to use the result of one business process 
in a subsequent one. 

For details, see “Correlating Statements” in Volume I-Using VuGen.

 5 Configure the run-time settings.

The run-time settings control the Vuser behavior during script execution. 
These settings include loop, log, and timing information. 

For details, see “Configuring Run-Time Settings” in Volume I-Using VuGen. 

 6 Run the script from VuGen.

Save and run the script from VuGen to verify that it runs correctly.
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For details, see “Running Vuser Scripts in Standalone Mode” in Volume I-
Using VuGen.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

Understanding Tuxedo Vuser Scripts

VuGen records typical Tuxedo sessions and generates Tuxedo-specific 
functions. The functions use an lrt prefix. For example, lrt_tpacall sends a 
service request.

The LRT functions are divided into the following categories: Buffer 
Manipulating, Client/Server Session, Communication, Environment 
Variable, Error Processing, Transaction Handling, and Correlation functions.

You can also manually program any of the functions into your script. For 
syntax and examples of the LRT functions, refer to the Online Function 
Reference (Help > Function Reference). 

After you record a session, VuGen’s built-in editor lets you view the recorded 
code. You can scroll through the script, see Tuxedo statements that were 
generated by your application, and examine the data that was returned by 
the server. The VuGen window provides you with valuable information 
about the recorded Tuxedo session. When you view the script in the main 
window, you see the sequence in which VuGen recorded your activities. 

In the following example, VuGen recorded a client’s actions in a Tuxedo 
bank application. The client performed an action of opening a bank account 
and specifying all the necessary details. The session was aborted when the 
client specified a zero opening balance. 

lrt_abort_on_error();
lr_think_time(65);
tpresult_int = lrt_tpbegin(30, 0);
data_0 = lrt_tpalloc("FML", "", 512);
lrt_Finitialize((FBFR*)data_0);

 

914



Chapter 60 • Developing Tuxedo Vuser Scripts
Using Parameters in Tuxedo Scripts
You can define parameters in Tuxedo scripts, as described in “Creating 
Parameters” in Volume I-Using VuGen.Note that Tuxedo scripts contain 
strings of type "name=..." or "value=...". You can only define parameters for 
the portion of the string following the equal sign (=). For example:

/* Fill the data buffer data_0 with new account information */
lrt_Fadd_fld((FBFR*)data_0, "name=BRANCH_ID", "value=8", 
LRT_END_OF_PARMS);
lrt_Fadd_fld((FBFR*)data_0, "name=ACCT_TYPE", "value=C", 
LRT_END_OF_PARMS);
lrt_Fadd_fld((FBFR*)data_0, "name=MID_INIT", "value=Q", LRT_END_OF_PARMS);
lrt_Fadd_fld((FBFR*)data_0,"name=PHONE","value=123-456-7890", 

LRT_END_OF_PARMS);

lrt_Fadd_fld((FBFR*)data_0, "name=ADDRESS", "value=1 Broadway
New York, NY 10000", LRT_END_OF_PARMS);

lrt_Fadd_fld((FBFR*)data_0,"name=SSN","value=111111111", LRT_END_OF_PARMS);

lrt_Fadd_fld((FBFR*)data_0,"name=LAST_NAME", 
"value=Doe",LRT_END_OF_PARMS);

lrt_Fadd_fld((FBFR*)data_0,"name=FIRST_NAME", 
"value=BJ",LRT_END_OF_PARMS);

lrt_Fadd_fld((FBFR*)data_0, "name=SAMOUNT", 
"value=0.00",LRT_END_OF_PARMS);

/* Open a new account */
tpresult_int = lrt_tpcall("OPEN_ACCT", data_0, 0, &data_0, &olen_2, 0);
lrt_tpabort(0);
lrt_tpcommit(0);
lrt_tpfree(data_0);
lrt_tpterm();

lrt_Fadd_fld((FBFR*)data_0,"name=PHONE","value=<parameter_1>", 
LRT_END_OF_PARMS);
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Note: In general, it is recommended to use lrt_save_parm to save a portion 
of a character array to a parameter. Use lrt_save_searched_string when you 
want to save information, relative to the position of a particular string in a 
character array. For PeopleSoft Vusers, it is recommended to use 
lrt_save_searched_string, since the reply buffers returned from the 
PeopleSoft server often differ in size during replay from what was seen 
during recording.

Running Tuxedo Scripts
If you encounter problems recording or running Tuxedo applications, check 
that the Tuxedo application runs without VuGen, and that the environment 
variables have been defined correctly. For more information, see “Viewing 
Tuxedo Buffer Data” below. Note that after you set or modify the Tuxedo 
variables, you should restart VuGen and your application, in order for the 
changes to take effect. If your application is 16-bit, then you also need to kill 
the NTVDM process.

If you experience problems during execution, check the Tuxedo log file on 
the side of the server for error messages. By default, this file is found in the 
directory indicated by the environment variable APPDIR. The file name has 
the form ULOG.mmddyy, where mmddyy indicates the current month, day, 
and year. The file for March 12, 1999 would be ULOG.031299. The default 
location of this file can be changed by setting the environment variable 
ULOGPFX on the server. A log file can also be found on the client side, in 
the current directory, unless the ULOGPFX variable changes its location.
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Viewing Tuxedo Buffer Data 

When you use VuGen to create a Tuxedo Vuser script, your actions are 
recorded into the three sections of the script: vuser_init, Actions, and 
vuser_end. 

The data that is received or transmitted is stored in data buffers, which can 
be very large. In order to simplify the appearance of the script, the actual 
data is stored in external files—not in the C file. When a data transfer 
occurs, the data is copied from the external file into a temporary buffer. 

The external file is called replay.vdf, and it contains the contents of all the 
temporary buffers. The buffers’ contents are stored as sequential records. 
The records are marked by identifiers indicating whether the data was sent 
or received, and the buffer descriptor. The LRT functions use the buffer 
descriptors to access the data. 

You can use VuGen to view the contents of the data file by selecting the 
replay.vdf file in the left pane’s tree view. 

The option to view a data file is available by default for Tuxedo scripts. 
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Defining Environment Settings for Tuxedo Vusers

The following section describes the system variable settings for Tuxedo 
Vusers running on Windows and UNIX platforms. You define the system 
variables in your Control Panel/System dialog box (NT) or .cshrc or .login 
file (UNIX).

For example:

You must define the following system variables for Tuxedo clients using 
Tuxedo/WS workstation extensions during execution:

TUXDIR the root directory for Tuxedo sources.

FLDTBLDIR list of directories containing FML buffer information. In 
Windows, separate the names of directories with semi-
colons. On UNIX platforms, separate the names of the 
directories with a colon.

FIELDTBLS list of files containing FML buffer information. On both 
Windows and UNIX platforms, separate the file names 
with commas.

SET FLDTBLDIR=%TUXDIR%\udataobj;%TUXDIR%\APPS\WS (PC)
SET FIELDTBLS=bankflds,usysflds (PC)
setenv FLDTBLDIR $TUXDIR/udataobj:$TUXDIR/apps/bankapp (Unix)
setenv FIELDTBLS bank.flds,Usysflds (Unix)

WSNADDR specifies the network address of the workstation listener 
process. This enables the client application to access 
Tuxedo. Note that to define multiple addresses in a 
WSNADDR statement, each address must be separated by 
a comma.

WSDEVICE specifies the device that accesses the network. Note that 
you do not need to define this variable for some network 
protocols.
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For example:

Debugging Tuxedo Applications

In general, use Tuxedo 6 to record applications using Tuxedo 6.x or earlier, 
and use Tuxedo to record applications using Tuxedo 7.1 and higher.

If you encounter problems recording or replaying Tuxedo applications, or 
the script is missing a call to lrt_tpinitialize, contact Customer Support to 
check which DLLs are used with the application.

If the application uses wtuxws32.dll, instead of libwsc.dll, contact Customer 
Support to obtain a patch to enable the recording. 

Correlating Tuxedo Scripts

VuGen supports correlation for Vuser scripts recorded with Tuxedo 
applications. Correlated statements enable you to link statements by saving 
a portion of a buffer and use it in subsequent statements.

To correlate statements, you modify your recorded script within the VuGen 
editor using one of the following LRT functions:

➤ lrt_save[32]_fld_val saves the current value of an FML or FML32 buffer (a 
string in the form "name=<NAME>" or "id=<ID>") to a parameter.

➤ lrt_save_parm saves a portion of a character array (such as a STRING or 
CARRAY buffer) to a parameter.

➤ lrt_save_searched_string searches for an occurrence of a string in a buffer 
and saves a portion of the buffer, relative to the string occurrence, to a 
parameter.

For additional information about the syntax of these functions, refer to the 
Online Function Reference.

SET WSNADDR=0x0002ffffc7cb4e4a (PC)
setenv WSNADDR 0x0002ffffc7cb4e4a (Unix)
setenv WSDEVICE /dev/tcp (Unix)
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Correlating FML and FML32 Buffers 
Use lrt_save_fld_val or lrt_save32_fld_val to save the contents of the FML or 
FML32 buffer. 

To correlate statements using lrt_save_fld_val:

 1 Insert the lrt_save_fld_val statement in your script where you want to save 
the contents of the current FML (or FML32) buffer.

lrt_save_fld_val (fbfr, "name", occurrence, "param_name"); 

 2 Reference the parameter.

Locate the lrt statements with the recorded values that you want to replace 
with the contents of the saved buffer. Replace all instances of the recorded 
values with the parameter name in angle brackets.

In the following example, a bank account was opened and the account 
number was stored to a parameter, account_id. 

/* Fill the data_0 buffer with new account information*/
data_0 = lrt_tpalloc("FML", "", 512);
lrt_Finitialize((FBFR*)data_0);
lrt_Fadd_fld((FBFR*)data_0, "name=BRANCH_ID", "value=1", 
LRT_END_OF_PARMS);
lrt_Fadd_fld((FBFR*)data_0, "name=ACCT_TYPE", "value=S", 
LRT_END_OF_PARMS);
…

LRT_END_OF_PARMS);
lrt_Fadd_fld((FBFR*)data_0, "name=LAST_NAME", "value=Doe", …);
lrt_Fadd_fld((FBFR*)data_0, "name=FIRST_NAME", "value=John", …);
lrt_Fadd_fld((FBFR*)data_0, "name=SAMOUNT", "value=234.12", …);

/* Open a new account and save the new account number*/
tpresult_int = lrt_tpcall("OPEN_ACCT", data_0, 0,&data_0, &olen_2, 0);
lrt_abort_on_error();
lrt_save_fld_val((FBFR*)data_0, "name=ACCOUNT_ID", 0, "account_id");

/* Use result from first query to fill buffer for the deposit*/
lrt_Finitialize((FBFR*)data_0);
lrt_Fadd_fld((FBFR*)data_0, "name=ACCOUNT_ID", "value=<account_id>", 
LRT_END_OF_PARMS);
lrt_Fadd_fld((FBFR*)data_0, "name=SAMOUNT", "value=200.11", …);
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In the above example, the account ID was represented by a field name, 
ACCOUNT_ID. Some systems represent a field by an ID number rather than 
a field name during recording. 

You can correlate by field ID as follows:

lrt_save_fld_val((FBFR*)data_0, "id=8302", 0, "account_id"); 

Correlating Character Strings
Use lrt_save_parm or lrt_save_searched_string to correlate character strings. 

➤ In general, it is recommended to use lrt_save_parm to save a portion of a 
character array to a parameter. 

➤ Use lrt_save_searched_string when you want to save information, relative 
to the position of a particular string in a character array. If the Vuser is for 
PeopleSoft, it is recommended to use lrt_save_searched_string, since the 
reply buffers returned from the PeopleSoft server often differ in size during 
replay from what was seen during recording.

Determining Which Values to Correlate
When working with CARRAY buffers, VuGen generates log files during 
recording (with the .rec extension) and during replay (with the .out 
extension) which you can compare using the Wdiff utility. You can look at 
the differences between the recording and replay logs to determine which 
portions of CARRAY buffers require correlation.
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To compare the log files:

 1 Select View > Output to display the execution log and recording log for your 
script. 

 2 Examine the Replay Log tab.

The error message should be followed by a statement beginning with the 
phrase: Use wdiff to compare.

 3 Double-click on the statement in the execution log to start the Wdiff utility.

WDiff opens and the differences between the record and replay files are 
highlighted in yellow. For more details about the Wdiff utility, see 
“Correlating Statements” in Volume I-Using VuGen.

To correlate statements using lrt_save_parm:

Once you decide which value to correlate, you can use lrt_save_parm to 
save a portion of a character array (such as a STRING or CARRAY buffer) to a 
parameter. 

 1 Insert the lrt_save_parm statement in your script at the point where you 
want to save the contents of the current buffer.

lrt_save_parm (buffer, offset, length, "param_name"); 

 2 In the replay.vdf file, locate the buffer data that you want to replace with the 
contents of the saved buffer.

View the buffer contents by selecting the replay.vdf file in the Data Files box 
of the main VuGen window.

 3 Replace all instances of the value with the parameter name in angle 
brackets.
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In the following example, an employee ID from a CARRAY buffer must be 
saved for later use. The recorded value was "G001" as shown in the output. 

Insert lrt_save_parm using the offset, 123, immediately after the request 
buffer that sends "PprLoad" and 227 bytes.

In the replay.vdf file, replace the recorded value, "G001", with the 
parameter, empid.

lrt_tpcall:227, PprLoad, 1782
Reply Buffer received.
…
123"G001"
126"…"
134"Claudia"

/* Request CARRAY buffer 57 */
lrt_memcpy(data_0, buf_143, 227);
tpresult_int = lrt_tpcall("PprLoad",

data_0, 227, &data_1, &olen, TPSIGRSTRT);
lrt_save_parm(data_1, 123, 9, "empid");

char buf_143[] =    "\xf5\x0\x0\x0\x4\x3\x2\x1\x1\x0\x0\x0\xbc\x2\x0\x0\x0\x0\x0\x0"
    "X"
"\x89\x0\x0\x0\xb\x0"
    "SPprLoadReq"
    "\xff\x0\x10\x0\x0\x4\x3\x6"
    ”<empid>” // G001
    "\x7"
    ”Claudia”
    "\xe"
    "LAST_NAME_SRCH"
...
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This function can also be used to save a portion of a character array within 
an FML buffer. In the following example, the phone number is a character 
array, and the area code is the first three characters. First, the lrt_save_fld_val 
statement saves the phone number to a parameter, phone_num. The 
lrt_save_parm statement uses lr_eval_string to turn the phone number into 
a character array and then saves the area code into a parameter called 
area_code.

To correlate statements using lrt_save_searched_string:

Use lrt_save_searched_string to search for a string in a buffer, and save a 
portion of the buffer, relative to the string occurrence, to a parameter. 

 1 Insert the lrt_save_searched_string statement in your script where you 
want to save a portion of the current buffer.

lrt_save_searched_string (buffer, buf_size, occurrence, string, offset,
length, "param_name"); 

Note that offset is the offset from the beginning of the string.

 2 In the replay.vdf file, locate the buffer data that you want to replace with the 
contents of the saved buffer.

View the buffer contents by selecting the replay.vdf file in the Data Files box 
of the main VuGen window.

 3 Replace all instances of the value with the parameter name in angle 
brackets.

In the following example, a Certificate is saved to a parameter for a later use. 
The lrt_save_searched_string function saves 16 bytes from the specified 
olen buffer, to the parameter cert1. The saved string location in the buffer, is 
9 bytes past the first occurrence of the string "SCertRep". 

This application is useful when the buffer’s header information is different 
depending on the recording environment. 

lrt_save_fld_val((FBFR*)data_0, "name=PHONE", 0, "phone_num");
lrt_save_parm(lr_eval_string("<phone_num>"), 0, 3, "area_code");
lr_log_message("The area code is %s\n", lr_eval_string("<area_code>"));
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The certificate will come 9 bytes past the first occurrence of "SCertRep", but 
the length of the information before this string varies.

/* Request CARRAY buffer 1 */
lrt_memcpy(data_0, sbuf_1, 41);
lrt_display_buffer("sbuf_1", data_0, 41, 41);
data_1 = lrt_tpalloc("CARRAY", "", 8192);
tpresult_int = lrt_tpcall("GetCertificate",
data_0,
41,
&data_1,
&olen,
TPSIGRSTRT);

/* Reply CARRAY buffer 1 */
lrt_display_buffer("rbuf_1", data_1, olen, 51);
lrt_abort_on_error();

lrt_save_searched_string(data_1, olen, 0, "SCertRep", 9, 16, "cert1");
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Developing Streaming Data Vuser Scripts

Streaming media is a rapidly growing market that allows for the delivery of 
audio/visual content over the Internet. The idea behind streaming media is 
that the audio/video content can be transmitted to the end user without 
having to first download the file in its entirety. Streaming works by having 
the server continuously stream the content to the client as it displays it.

RealPlayer is an application that display streaming content.

You use VuGen to record communication between a client application and a 
server that communicate using the RealPlayer protocol. The resulting script 
is called a Real Vuser script.

This chapter includes:

 ➤  About Recording Streaming Data Virtual User Scripts on page 930

 ➤  Getting Started with Streaming Data Vuser Scripts on page 930

 ➤  Using RealPlayer LREAL Functions on page 931

 ➤  Using Media Player MMS Functions on page 932

The following information applies only to the Real and Media Player 
(MMS) protocols.
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About Recording Streaming Data Virtual User Scripts

The Streaming Data protocols allows you to emulate a user playing media or 
streaming data files. 

When you record an application using a streaming data protocol, VuGen 
generates functions that describe your actions. For RealPlayer sessions, 
VuGen generates functions with an lreal prefix. For Media Player sessions, 
VuGen uses functions with an mms prefix. Note that recording is not 
supported for Media Player mms functions—only replay.

Getting Started with Streaming Data Vuser Scripts

This section provides an overview of the process of developing RealPlayer 
and Media Player streaming data Vuser scripts using VuGen. 

To develop a Real or Media Player Vuser script: 

 1 Record the basic script using VuGen. (Real only)

Invoke VuGen and create a new Vuser script. Choose an application to 
record, and record typical operations on your application. For details, see 
“Recording with VuGen” in Volume I-Using VuGen. 

 2 Enhance the script.

Enhance the script by inserting transactions, rendezvous points, and 
control-flow structures into the script.

For details, see “Enhancing Vuser Scripts” in Volume I-Using VuGen.

 3 Define parameters (optional).

Define parameters for the fixed-values recorded into your script. By 
substituting fixed-values with parameters, you can repeat the same business 
process many times using different values. 

For details, see “Creating Parameters” in Volume I-Using VuGen.

 4 Correlate statements (optional).

Correlating statements enables you to use the result of one business process 
in a subsequent one. 

For details, see “Correlating Statements” in Volume I-Using VuGen.
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 5 Configure the run-time settings.

The run-time settings control the Vuser behavior during script execution. 
These settings include loop, log, and timing information. 

For details, see “Configuring Run-Time Settings” in Volume I-Using VuGen.

 6 Run the script from VuGen. 

Save and run the script from VuGen to verify that it runs correctly.

For details, see “Running Vuser Scripts in Standalone Mode” in Volume I-
Using VuGen.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

Using RealPlayer LREAL Functions

The functions developed to emulate communication between a client and a 
server by using the RealPlayer protocol are called Real Player functions. Each 
Real Player function has an lreal prefix.

VuGen automatically records most of the LREAL functions listed in this 
section during a Real Player session. You can also manually program any of 
the functions into your script.

For example, the lreal_play function takes the form:

To play the clip until the end, use any negative value for mulTimeToPlay. To 
play the clip for a specific duration number of milliseconds, specify the 
number of milliseconds. miplayerID represents a unique ID of a RealPlayer 
instance.

For more information about the LREAL functions, refer to the Online 
Function Reference (Help > Function Reference).

int lreal_play (int miplayerID, long mulTimeToPlay); 
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Using Media Player MMS Functions

The functions developed to emulate client/server communication for Media 
Player’s MMS protocol, are called MMS Virtual User functions—each 
function has an mms prefix. 

All MMS functions come in pairs—one for global sessions and one for a 
specific session. For example, mms_close closes the Media Player globally, 
while mms_close_ex closes the Media Player for a specific session. 

A typical function, mms_play, takes the following form: 

In the following example, the mms_play function plays an asf file for 
different durations: 

For detailed syntax information on these functions, refer to the Online 
Function Reference (Help > Function Reference).

int mms_play (char message, <List of Attributes>, LAST); 

//Play for a duration of 10 seconds.
mms_play("Welcome","URL=mms://server/welcome.asf","
duration=10",
LAST); 

//Play the clip until its completion, after waiting 5 seconds.
mms_play ("Welcome","URL=mms://server/welcome.asf", 
"duration=-1", 
"starttime=5",
LAST); 
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Recording Wireless Vuser Scripts

VuGen enables you to generate Wireless Vuser scripts by recording typical 
Wireless sessions. When you run a script, the resulting Vuser emulates 
activity between your toolkit or phone and Web server (or gateway for 
WAP).

This chapter includes:

 ➤  Understanding the WAP Protocol on page 935

 ➤  Getting Started with Wireless Vuser Scripts on page 937

 ➤  Using Wireless Vuser Functions on page 939

 ➤  Push Support on page 940

 ➤  VuGen Push Support on page 942

The following information only applies to all Wireless protocols. 

Understanding the WAP Protocol

The Wireless Application Protocol (WAP) is an open, global specification 
that enables mobile users with wireless devices to instantly access and 
interact with information and services.

The WAP protocol specifies a microbrowser thin-client using a new standard 
called WML that is optimized for wireless handheld mobile terminals. WML 
is a stripped-down version of XML. 
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WAP also specifies a proxy server that:

➤ acts as a gateway between the wireless network and the wire-line Internet

➤ provides protocol translation

➤ optimizes data transfer for the wireless handset

WAP architecture closely resembles the WWW model. All content is 
specified in formats that are similar to the standard Internet formats. 
Content is transported using standard protocols in the WWW domain and 
an optimized HTTP-like protocol in the wireless domain (Wireless Session 
Protocol). You locate all WAP content using WWW standard URLs.

WAP uses many WWW standards, including authoring and publishing 
methods. WAP enhances some of the WWW standards in ways that reflect 
the device and network characteristics. WAP extensions are added to support 
Mobile Network Services such as Call Control and Messaging. It accounts for 
the memory and CPU processing constraints that are found in mobile 
terminals. WAP also supports low bandwidth and high latency networks.

WAP assumes the existence of a gateway that is responsible for encoding and 
decoding data transferred to and from the mobile client. The purpose of 
encoding content delivered to the client is to minimize the size of data sent 
to the client over-the-air, as well as to minimize the computational energy 
required by the client to process that data. The gateway functionality can be 
added to origin servers, or placed in dedicated gateways as illustrated below. 
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WAP Toolkits
To assist developers in producing WAP applications and services, the leading 
companies such as Nokia, Ericsson, and Phone.com, have developed 
toolkits. The WAP Toolkit provides an environment for developers who 
want to provide Internet services and content for mobile terminals. It allows 
developers to write, test, debug, and run applications on a PC-based 
simulator phone. The toolkit allows users to browse WAP sites through an 
HTTP connection or a WAP gateway. 

A mobile phone communicates with a gateway in WSP protocol; a toolkit 
can communicate with the gateway, or directly with the server. VuGen 
automatically detects the communication mode that is configured in the 
toolkit: WSP or HTTP. If you are interested in the traffic to the gateway, you 
record in WSP mode. If you want to check the server and the content 
providers, you can record your toolkit session in HTTP mode, and bypass 
the gateway.

VuGen uses custom API functions to emulate a user session. Most functions 
are the standard Web protocol functions utilizing the HTTP protocol. Several 
WAP functions emulate actions specific to WAP Vusers. For a list of the 
supported functions, see “Using Wireless Vuser Functions” on page 939.

Getting Started with Wireless Vuser Scripts

Wireless Vuser Scripts emulate a user using a wireless browser. You record the 
user browsing on a PC-based simulator phone (toolkit). You can then 
distribute several hundred Vusers among the available testing machines, 
each Vuser accessing the server by using its API. This enables you to measure 
the performance of the server under the load of many users.

This section provides an overview of the process of developing Wireless 
Vuser scripts using VuGen.

To develop a Wireless script: 

 1 Create a new script using VuGen.

Select File > New or click the New button to create a new script in either 
single or multiple protocol mode.
937



Chapter 62 • Recording Wireless Vuser Scripts
For details about creating a new script, see “Recording with VuGen” in 
Volume I-Using VuGen.

 2 Record the actions using VuGen.

Record the actions over the toolkit session. VuGen automatically detects the 
toolkit settings and uses those settings during recording.

For information about recording, see “Recording with VuGen” in Volume I-
Using VuGen.

 3 Enhance the Vuser script.

Enhance the Vuser script by inserting transactions, rendezvous points, and 
control-flow structures into the script.

For details, see “Enhancing Vuser Scripts” in Volume I-Using VuGen.

 4 Define parameters (optional).

Define parameters for the fixed-values recorded into your Vuser script. By 
substituting fixed-values with parameters, you can repeat the same business 
process many times using different values. For details, see “Creating 
Parameters” in Volume I-Using VuGen.

 5 Configure the run-time settings.

The run-time settings control the Vuser behavior during script execution. 
These settings include the run logic, pacing, logging, think time, 
performance preferences, and gateway settings. 

For information about the General run-time settings, see “Configuring Run-
Time Settings” in Volume I-Using VuGen. 

For information about common Internet protocol run-time settings, see 
Chapter 40, “Configuring Internet Run-Time Settings.”

For information about WAP specific run-time settings, see Chapter 63, 
“Configuring WAP Run-Time Settings.”

 6 Perform correlation.

Check your script to determine if there are dynamic values that require 
correlation. For Wireless protocols, you perform manual correlation by 
adding web_reg_save_param functions.

For more information, see “Performing Manual Correlation” on page 711.
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 7 Save and run the Vuser script from VuGen. 

Save and run the Vuser script from VuGen to verify that it runs correctly. 
While you record, VuGen creates a series of configuration, data, and source 
code files. These files contain Vuser run-time and setup information. VuGen 
saves these files together with the script.

For details about running the Vuser script as a standalone test, see “Running 
Vuser Scripts in Standalone Mode” in Volume I-Using VuGen.

After you create a script, you integrate it into your environment: a 
LoadRunner scenario, Performance Center load test, or Business Process 
Monitor profile. For more information, refer to the HP LoadRunner Controller, 
Performance Center, or HP Business Availability Center documentation. 

Using Wireless Vuser Functions

The functions developed to emulate communication between a wireless 
instrument and Web server (or gateway for WAP), are called Vuser functions. 
Some functions are generated when you record a script; others you must 
manually insert into the script. You can also add Vuser message functions 
and custom C functions to your Vuser scripts after recording. 

General Vuser functions begin with an lr prefix. The functions representing 
standard HTTP actions, have a web prefix. 

Functions that are specific to WAP, have a wap prefix. For example, 
wap_connect connects to a WAP gateway. WAP functions are divided into 
the following categories: Bearer, Connection, Formatting, Gateway, Push, 
and Radius functions.

Functions that emulate a RAS or NAS server during a WAP session, have a 
radius prefix. For example, radius_account authenticates a user to a 
RADIUS server. 

For a complete list of all VuGen functions, refer to the Online Function 
Reference (Help > Function Reference).
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For WAP Vusers running scripts in Wireless Session Protocol (WSP) mode, 
only the following functions are supported:

Push Support

In the normal client/server model, a client requests information or a service 
from a server. The server responds by transmitting information or 
performing a service to the client. This is known as pull technology—the 
client pulls information from the server. 

In contrast to this, there is also push technology. The WAP push framework 
transmits information to a device without a previous user action. This 
technology is also based on the client/server model, but there is no explicit 
request from the client before the server transmits its content.

To perform a push operation in WAP, a Push Initiator (PI) transmits content 
to a client. However, the Push Initiator protocol is not fully compatible with 
the WAP Client—the Push Initiator is on the Internet, and the WAP Client is 
in the WAP domain. Therefore, we need to insert a translating gateway to 
serve as an intermediary between the Push Initiator and the WAP Client. 
The translating gateway is known as the Push Proxy Gateway (PPG).

The access protocol on the Internet side is called the Push Access Protocol 
(PAP).

Action Functions web_custom_request, web_submit_data, and 
web_url

Authentication Functions All—web_set_user, web_set_certificate[_ex]

Cookie Functions All—web_add_cookie, web_cleanup_cookie, 
web_remove_cookie

Header Functions All —web_add_auto_header, web_add_header, 
web_cleanup_auto_headers, web_save_header

Correlation Functions All—web_create_html_param[_ex], 
web_reg_save_param, 
web_set_max_html_param_len
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The protocol on the WAP end is called the Push Over-The-Air (OTA) 
protocol.

The Push Initiator contacts the Push Proxy Gateway (PPG) over the Internet 
using the PAP Internet protocol. PAP uses XML messages that may be 
tunneled through various well-known Internet protocols such as HTTP. The 
PPG forwards the pushed content to the WAP domain. The content is then 
transmitted using the OTA protocol over the mobile network to the 
destination client. The OTA protocol is based on WSP services.

In addition to providing basic proxy gateway services, the PPG is capable of 
notifying the Push Initiator about the final status of the push operation. In 
two-way mobile networks, it can also wait for the client to accept or reject 
the content.

Push Services Types
Push services can be of the SL or SI type: 

➤ SL. The Service Loading (SL) content type provides the ability to cause a user 
agent on a mobile client to load and execute a service—for example, a WML 
deck. The SL contains a URI indicating the service to be loaded by the user 
agent without user intervention when appropriate.

➤ SI. The Service Indication (SI) content type provides the ability to send 
notifications to end-users in an asynchronous manner. For example, the 
notifications may be about new e-mails, changes in stock price, news 
headlines, and advertising.

In its most basic form, an SI contains a short message and a URI indicating a 
service. The message is presented to the end-user upon reception, and the 
user is given the choice to either start the service indicated by the URI 
immediately, or postpone the SI for later handling. If the SI is postponed, 
the client stores it and the end-user is given the ability to act upon it at a 
later point of time.
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VuGen Push Support

Push support for VuGen is divided into three parts:

➤ Push support at the client end—the ability to accept push messages.

➤ Push support to WAP HTTP Vusers—emulating Push Initiators.

➤ Push messages (SI & SL) format services—formatting push messages.

Client Push Support 
At the client end, VuGen supports both push services (SL and SI) for all 
replay modes (CO and CL). The wap_wait_for_push function instructs the 
Vuser to wait for a push message to arrive. You set the timeout for this 
function in the run-time settings.

When a push message arrives, the Vuser parses it to determine its type and 
to retrieve its attributes. If parsing was successful, it generates and executes a 
pull transaction to retrieve the relevant data. You can disable the pull event, 
indicating to the Vuser not to retrieve the message data by configuring the 
Run-Time settings. For more information, see Chapter 63, “Configuring 
WAP Run-Time Settings.” 

Emulating a Push Initiator
Push support for WAP HTTP Vusers enables you to perform load testing of 
the PPG. Push support allows Vusers to function as Push Initiators 
supporting the Push Access Protocol (PAP). The PAP defines the following 
sets of operations between the PI and the PPG:

➤ Submit a Push request.

➤ Cancel a Push request.

➤ Submit a query for the status of a push request.

➤ Submit a query for the status of a wireless device’s capabilities.

➤ Initiate a result notification message from the PPG to the PI.
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All operations are request/response—for every initiated message, a response 
is issued back to the PI. PI operations are based on the regular HTTP POST 
method supported by VuGen. Currently, only the first two operations are 
supported through wap_push_submit and wap_push_cancel. 

You can submit data to a Web server using the web_submit_data function. 
It is difficult, however, to send long and complex data structures using this 
function. To overcome this difficulty and provide a more intuitive API 
function, several new API functions were added to properly format the XML 
message data: wap_format_si_msg and wap_format_sl_msg. For more 
information about these functions, refer to the Online Function Reference.
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Configuring WAP Run-Time Settings 

After you record a WAP Vuser script, you configure the WAP specific run-
time settings.

This chapter includes:

 ➤  About WAP Run-Time Settings on page 945

 ➤  Configuring Gateway Options on page 946

 ➤  Configuring Radius Connection Data on page 950

The following information applies to the WAP Vuser Scripts.

For information on setting the common Internet protocol run-time settings 
for WAP and all Wireless protocols, see Chapter 40, “Configuring Internet 
Run-Time Settings.” 

About WAP Run-Time Settings

After developing a WAP Vuser script, you set the WAP specific run-time 
settings. These settings configure the behavior of the WAP Vusers to 
accurately emulate real users on a WAP device. You can configure WAP run-
time settings in the areas of Gateway and Radius settings.

For information about the general run-time settings that apply to all wireless 
Vusers, see Chapter 40, “Configuring Internet Run-Time Settings.”
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Configuring Gateway Options

You use the WAP:Gateway node in the Run-Time Settings tree to set the 
Gateway settings.

Connection Options

The connection options specify the method that the Vuser uses to connect 
to the WAP gateway.

WAP Gateway. Run the Vusers accessing a Web server via a WAP Gateway. 

HTTP Direct. Run the Vusers run in HTTP mode, accessing a Web server 
directly. 

Note: If you choose the HTTP Direct connection mode, the remaining WAP 
Gateway options are not applicable.
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Gateway Settings

If the Vusers connect through a gateway, the IP, Port, and WAP Versions 
options specify the Gateway connection.

IP. Specify the IP address of the gateway.

Port. Specify the port of the gateway. When running your Vusers through a 
WAP gateway, VuGen automatically sets default port numbers, depending 
on the selected mode. However, you can customize the settings and specify 
a custom IP address and port for the gateway.

Wap version. Select the appropriate WAP version, 1.x (WSP) or 2.0 (HTTP 
proxy). If you recorded in WAP 1.x (WSP), you can run the Vuser in either 
1.x (WSP), or 2.0 (HTTP proxy) mode. If you recorded in WAP 2.0 (HTTP 
proxy), then you can only run the Vuser in the same mode.

If you are running the script in WAP 1.x (WSP), you can specify several 
connection and advanced options.

Gateway Connection Mode
The connection mode settings apply to WAP version 1.x (WSP) connections. 

Connection-oriented Mode. Set the connection mode for the WSP session to 
Connection-Oriented.

Connectionless Mode. Set the connection mode for the WSP session to 
Connectionless.

Enable security. Enable a secure connection to the WAP gateway.
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Advanced Gateway Options
Expand the Advanced option in the Gateway node to configure the WAP 
Capabilities and other advanced gateway options. 

➤ Confirm Push support. In CO mode, if a push message is received, this 
option instructs the Vuser to confirm the receipt of the message (disabled by 
default). For more information, see “Push Support” on page 940.

➤ Push support. Enables push type messages across the gateway (disabled by 
default).

➤ CAPSessionResume. Enables requests for session suspend or resume.

➤ Acknowledge headers. Returns standard headers that provide information 
to the gateway (disabled by default).

➤ Server SDU buffer size. The largest transaction service data unit that may 
be sent to the server during the session (4000 by default).

➤ Client SDU buffer size. The largest transaction service data unit that may 
be sent to the client during the session (4000 by default).

➤ MethodMOR. The number of outstanding methods that can occur 
simultaneously.

➤ PushMOR. The number of outstanding push transactions that can occur 
simultaneously.

➤ BearerType. The type of bearer used as the underlying transport.
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➤ Retrieve messages. When a push messages is received, this option 
instructs the Vuser to retrieve the message data from the URL indicated 
in the push message (disabled by default).

➤ Support Cookies. Provide support for saving and retrieving cookies (disabled 
by default).

➤ WTP Segmentation and Reassembly. Enables segmentation and reassembly 
(SAR) in WTP, Wireless Transport Protocol. (True by default).

➤ WTP Retransmission Time. The time in seconds that the WTP layer waits 
before resending the PDU if it did not receive a response. (5000 by 
default).

➤ WTLS Abbreviated Handshake. Use an abbreviated handshake instead of a 
full one, when receiving a redirect message. (False by default).

➤ WTLS Deffie Hellman. Use the Deffie Hellman encryption scheme for WTLS 
(Wireless Transport Layer Security) instead of the default scheme, RSA. (False 
by default).

➤ WTLS Deffie Hellman identifier. An identifier for the Deffie Hellman 
encryption scheme. This identifier is required for the abbreviated 
handshake with the Operwave gateway that uses the Deffie Hellman 
encryption scheme.

➤ Network MTU Size. the maximum size in bytes, of the network packet. 
(4096 by default).

Setting the Gateway Options
The following section describes the procedure for setting the WAP Gateway 
options.

To set the WAP gateway options:

 1 Click the Run-Time Settings button or select Vuser > Run-Time Settings to 
display the Run-Time Settings dialog box. Select the WAP:Gateway node.

 2 To replay the script in WSP mode (not HTTP), select WAP Gateway.

 3 Specify an IP address and port for the gateway. You can also use the default 
port indicated by VuGen.

 4 Select a WAP version: WAP 1.x (WSP) or WAP 2.0 (HTTP).
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 5 For WAP 1.x (WSP), select a connection mode—Connection-oriented or 
Connectionless. To indicate a secure connection mode, select the Enable 
Security option. 

 6 For WAP 1.x (WSP), expand the Advanced node to set the client capabilities 
and other advanced gateway options. For more information about the 
Advanced options, see above.

Configuring Radius Connection Data

RADIUS (Remote Authentication Dial-In User Service) is a client/server 
protocol and software that enables remote access servers to communicate 
with a central server to authenticate dial-in users and authorize their access 
to the requested system or service.

RADIUS allows a company to maintain user profiles in a central database 
that all remote servers can share. It provides better security, allowing a 
company to set up a policy that can be applied at a single administered 
network point. Using a central service makes it easier to track usage for 
billing and store network statistics.

RADIUS has two sub-protocols:

➤ Authentication. Authorizes and controls user access.

➤ Accounting. Tracks usage for billing and for keeping network statistics.

In VuGen, the RADIUS protocol is only supported for WSP replay for both 
Radius sub-protocols—authentication and accounting.

You supply the dial-in information in the Run-Time Settings’ Radius node:

Property Value

Network Type Accounting network type: GPRS (General Packet 
Radio Service) or CSD (Circuit-Switched Data).

IP Address IP address of the Radius server.

Authentication port number Authentication port of the Radius server.

Accounting port number Accounting port of the Radius server.
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To set the WAP Radius options:

 1 Click the Run-Time Settings button or select Vuser > Run-Time Settings to 
display the Run-Time Settings dialog box. Click the Radius node.

 2 Choose an accounting Network type: GPRS (General Packet Radio Service) 
or CSD (Circuit-Switched Data).

 3 Enter the IP address of the Radius server in dot form.

Secret Key The secret key of the Radius server.

Connection Timeout (sec) The time in seconds to wait for the Radius server 
to respond. The default is 120 seconds.

Retransmission retries The number of times to retry after a failed 
transmission. The default is 0.

Store attributes returned by 
the server to parameters

Allow Vusers to save attributes returned by the 
server as parameters, which can be used at a later 
time. The default is False.

Radius client IP Radius packets source IP, usually used to 
differentiate between packets transmitted on 
different NIC cards on a single Load Generator 
machine.
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 4 Enter the Authentication Port number and Accounting Port number of the 
Radius server.

 5 Type in the Secret key for Radius or Accounting Authentication. 

 6 Enter a Connection Timeout value.

 7 Specify the number of Retransmission retries.

 8 Specify whether you want VuGen to store attributes returned by the server 
to parameters.

 9 Click OK to accept the settings and close the dialog box.
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Developing MMS Vuser Scripts

You can create MMS (Multimedia Messaging Service) Vuser scripts to 
emulate MMS activity.

This chapter includes:

 ➤  About MMS (Multimedia Messaging Service) Vuser Scripts on page 953

 ➤  Configuring MMS Run-Time Settings on page 954

 ➤  Running an MMS Scenario in the Controller on page 956

The following information applies to Multimedia Messaging Service 
(MMS) Vuser scripts.

About MMS (Multimedia Messaging Service) Vuser Scripts

MMS (Multimedia Messaging Service) is an extension of the SMS protocol. 
Whereas SMS messages can only contain text, MMS allows you to send and 
receive messages with a wide range of content to MMS capable handsets. 
This content can be in the form of text, sound, e-mail messages, images, 
video clips, and even streaming data. It is also possible to send multimedia 
messages from a mobile phone to an email address.

An MMS message typically includes a collection of attachments. While SMS 
messages are limited to 160 bytes, an MMS message could be several MBs in 
size. MMS usually requires a third generation (3G) network to enable such 
large messages to be delivered.
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To receive an MMS message, a mobile phone receives an MMS notification 
over SMS. The SMS message can be received over various SMS protocols such 
as SMPP, UCP, CIMD2, etc. The SMS message contains a unique path to the 
MMS message stored in the MMSC server’s database and the mobile phone 
uses this path to download the message from the SMSC. The current version 
of VuGen supports the receiving of MMS notifications over the SMPP 
interface.

Multimedia Messaging Service Vuser scripts support the 1.0 and 1.1 versions 
of the MMS protocol, as defined by OMA (Open Mobile Alliance 
organization). Using MMS Vusers, you can send MMS messages to the 
MMSC server directly over the HTTP protocol, or over the WAP protocol 
through a WAP gateway. 

Multimedia Messaging Service functions emulate the sending and receiving 
of MMS messages. Each function begins with an mm prefix. For detailed 
syntax information for these functions, refer to the Online Function Reference 
(Help > Function Reference).

Configuring MMS Run-Time Settings

Before running your script, you can set the run-time settings to allow the 
script to accurately emulate a real user. For information on the general run-
time settings for all protocols, such as think time, pacing, and logging, see 
“Configuring Run-Time Settings” in Volume I-Using VuGen.

The following section describes the run-time settings specific to MMS 
(Multimedia Messaging Service) Vusers. These run-time setting allow you to 
configure the server and protocol settings. 
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You can set the following options:

➤ MMSC URL. The URL of the MMSC (Multimedia Messaging Center) server.

➤ MMS Version. The version of the MMS protocol used by the script.

➤ Timeout (seconds). The time that the server waits for incoming messages. 
The default value is 60 seconds.

➤ SMSC IP. The IP address of the SMSC server used for sending MMS 
notifications over SMPP.

➤ SMSC Port. The IP port of the SMSC server used for sending MMS 
notifications over SMPP.

➤ Automatic WAP Connections. Defines when to connect and disconnect from 
a WAP gateway. This setting is only relevant when a WAP gateway is used. 
The possible values are: 

➤ Per Iteration. Connect at the beginning of each iteration and disconnect 
at the end of each iteration. (default)

➤ Per Send or Receive. Connect and disconnect at the beginning and end 
of each message.

➤ None. Do not use automatic WAP connections.

➤ Default Sender address. The default address sent in the Sender header. The 
default is +999999.
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To set the MMS Server and Protocol settings:

 1 Open the Run-Time Settings dialog box. Choose Vuser > Run-Time Settings 
or click the Run-Time Settings button on the VuGen toolbar. 

 2 Select the MMS:Server and Protocol node from the Run-Time settings tree. 

 3 Select the desired values as explained above.

 4 Select General:Miscellaneous from the Run-Time settings tree. 

 5 Under Multithreading, select Run Vuser as a process.

 6 Click OK to accept the settings and run the script.

Running an MMS Scenario in the Controller

An MMS (Multimedia Messaging Service) scenario requires a command line 
setting.

To set the MMS command line setting:

 1 From the Scenario Schedule screen, click Details. The Group Information 
dialog is displayed. 

 2 If the Command line box is not visible, click the More button. 

 3 Add the following to the end of the Command line text: -usingwininet yes

 4 Click OK to accept the Command line switch.
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recording 811
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run-time settings 817
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properties dialog box 683
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troubleshooting 844
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Citrix Vusers 260
multiple RDP 302
SAPGUI Vusers 797
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Web Services scripts 84
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XML Vusers 720

SOA scripts
getting started 28
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creating 27
parameterizing 35
running 159
viewing and editing 32
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SOAP requests, importing 65
SOAP response, saving 114
Solaris

ASCII translations 341
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575–577
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RealPlayer functions 931
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modifying 669
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text checks
defined 645
defining additional properties 657
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RDP 298
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token, parameterizing 690
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troubleshooting, .NET 500
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