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Documentation Updates

This manual’s title page contains the following identifying information:

• Software version number, which indicates the software version

• Document release date, which changes each time the document is updated

• Software release date, which indicates the release date of this version of the software

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/

http://ovweb.external.hp.com/lpe/doc_serv/
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Support

You can visit the HP Software Support Web site at: www.hp.com/go/hpsoftwaresupport

HP Software online support provides an efficient way to access interactive technical support 
tools. As a valued support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many 
also require a support contract. To find more information about access levels, go to:  
http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport ID, go to:  
http://h20229.www2.hp.com/passport-registration.html 

http://www.hp.com/go/hpsoftwaresupport
http://h20230.www2.hp.com/new_access_levels.jsp
http://h20229.www2.hp.com/passport-registration.html
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Welcome to This Tutorial

Welcome to the QuickTest Professional tutorial. The tutorial is a self-paced 
guide that teaches you the basics of testing your application with QuickTest, 
the powerful functional testing solution. 

This tutorial will familiarize you with the process of creating and running 
automated tests and analyzing the test results. After completing the tutorial, 
you can apply the skills you have learned to your own application or Web 
site. 

Note: In addition to tests, QuickTest enables you to create business 
components for use in business process tests, if you have Quality Center 
with Business Process Testing support installed. The procedures described in 
this tutorial are designed for creating tests, but you can also apply the 
majority of these procedures to creating business components. For more 
information on business components and Business Process Testing, refer to 
the HP QuickTest Professional for Business Process Testing User’s Guide and the 
HP Business Process Testing User’s Guide.

This chapter includes:

 ➤  How This Tutorial Is Organized on page 8

 ➤  Who Should Read This Tutorial on page 9

 ➤  QuickTest Professional Online Documentation on page 9

 ➤  Additional Online Resources on page 12

 ➤  Typographical Conventions on page 13
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How This Tutorial Is Organized

The tutorial is divided into short lessons. Through the lessons you will 
create and run tests on the sample Mercury Tours Web site.

This tutorial contains the following lessons:

 Lesson 1 Introducing QuickTest

Compares automated and manual testing methods. It introduces the 
QuickTest testing process and familiarizes you with the QuickTest user 
interface and the sample Mercury Tours Web site.

 Lesson 2 Analyzing Your Application

Explains what you need to consider before you begin testing your 
application.

 Lesson 3 Creating Object Repositories

Describes how to create object repositories and associate them with your test 
actions.

 Lesson 4 Creating Functions and Function Libraries

Describes how to create functions and function libraries, and how to 
associate them with your test.

 Lesson 5 Creating a Test

Teaches you how to add steps to your test actions and provides an overview 
of the resulting Keyword View display.

 Lesson 6 Running and Analyzing Tests

Describes how to run a test and view the test results.

 Lesson 7 Creating Checkpoints and Using Functions

Provides an overview of different checkpoint types and explains how to add 
checkpoints to your test to verify that information in your Web site is 
displayed as expected.
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 Lesson 8 Parameterizing Tests

Describes how to parameterize a test using Data Table parameters, and then 
run the test on multiple sets of data and analyze the results.

 Lesson 9 Where Do You Go from Here?

Shows you how to get started testing your own application.

Who Should Read This Tutorial

This tutorial is intended for users who are new to QuickTest. No prior 
knowledge of QuickTest is required. A general understanding of testing 
concepts and functional testing processes may be helpful, but is not 
mandatory.

QuickTest Professional Online Documentation

QuickTest Professional includes the following online documentation:

Readme provides the latest news and information about QuickTest. Choose 
Start > Programs > QuickTest Professional > Readme.

QuickTest Professional Installation Guide explains how to install and set up 
QuickTest. Choose Help > Printer-Friendly Documentation > HP QuickTest 
Professional Installation Guide.

QuickTest Professional Tutorial teaches you basic QuickTest skills and shows 
you how to design tests for your applications. Choose Help > HP QuickTest 
Professional Tutorial.

Product Feature Movies provide an overview and step-by-step instructions 
describing how to use selected QuickTest features. Choose Help > Product 
Feature Movies.

Printer-Friendly Documentation displays the complete documentation set in 
Adobe portable document format (PDF). Online books can be viewed and 
printed using Adobe Reader, which can be downloaded from the Adobe Web 
site (http://www.adobe.com). Choose Help > Printer-Friendly Documentation.

http://www.adobe.com
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QuickTest Professional Help includes:

➤ What’s New in QuickTest Professional describes the newest features, 
enhancements, and supported environments in the latest version of 
QuickTest.

➤ QuickTest User's Guide describes how to use QuickTest to test your 
application.

➤ QuickTest for Business Process Testing User's Guide provides step-by-step 
instructions for using QuickTest to create and manage assets for use with 
Business Process Testing.

➤ QuickTest Professional Add-ins Guide describes how to work with 
supported environments using QuickTest add-ins, and provides 
environment-specific information for each add-in.

➤ QuickTest Object Model Reference describes QuickTest test objects, lists 
the methods and properties associated with each object, and provides 
syntax information and examples for each method and property.

➤ QuickTest Advanced References contains documentation for the 
following QuickTest COM and XML references:

➤ QuickTest Automation provides syntax, descriptive information, and 
examples for the automation objects, methods, and properties. It also 
contains a detailed overview to help you get started writing QuickTest 
automation scripts. The automation object model assists you in 
automating test management, by providing objects, methods and 
properties that enable you to control virtually every QuickTest feature 
and capability.

➤ QuickTest Test Results Schema documents the test results XML 
schema, which provides the information you need to customize your 
test results.

➤ QuickTest Test Object Schema documents the test object XML schema 
schema, which provides the information you need to extend test 
object support in different environments.

➤ QuickTest Object Repository Schema documents the object repository 
XML schema, which provides the information you need to edit an 
object repository file that was exported to XML.
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➤ QuickTest Object Repository Automation documents the Object 
Repository automation object model, which provides the information 
you need to manipulate QuickTest object repositories and their 
contents from outside of QuickTest.

➤ VBScript Reference contains Microsoft VBScript documentation, 
including VBScript, Script Runtime, and Windows Script Host.

To access the QuickTest Professional Help, choose Help > QuickTest 
Professional Help. You can also access the QuickTest Professional Help by 
clicking in selected QuickTest windows and dialog boxes and pressing F1. 
Additionally, you can view a description, syntax, and examples for a 
QuickTest test object, method, or property by placing the cursor on it and 
pressing F1.
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Additional Online Resources

Mercury Tours sample Web site is the basis for many examples in this guide. 
The URL for this Web site is http://newtours.demoaut.com. Choose Start > 
Programs > QuickTest Professional > Sample Applications > Mercury Tours 
Web Site.

Knowledge Base opens directly to the Knowledge Base landing page on the 
Mercury Customer Support Web site. Choose Help > Knowledge Base. The 
URL for this Web site is support.mercury.com/cgi-bin/portal/CSO/kbBrowse.jsp.

Customer Support Web site accesses the HP Software Support Web site. This 
site enables you to browse the Support Knowledge Base and add your own 
articles. You can also post to and search user discussion forums, submit 
support requests, download patches and updated documentation, and more. 
Choose Help > Customer Support Web site. The URL for this Web site is 
www.hp.com/go/hpsoftwaresupport.

Most of the support areas require that you register as an HP Passport user 
and sign in. Many also require a support contract.

To find more information about access levels, go to:  
http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport user ID, go to:  
http://h20229.www2.hp.com/passport-registration.html 

Send Feedback enables you to send online feedback about QuickTest 
Professional to the product team. Choose Help > Send Feedback.

HP Software Web site accesses the HP Software Web site. This site provides 
you with the most up-to-date information on HP Software products. This 
includes new software releases, seminars and trade shows, customer support, 
and more. Choose Help > HP Software Web site. The URL for this Web site 
is www.hp.com/go/software.

http://www.hp.com/go/hpsoftwaresupport
http://h20230.www2.hp.com/new_access_levels.jsp
http://h20229.www2.hp.com/passport-registration.html
http://www.hp.com/go/software
http://newtours.demoaut.com
http://support.mercury.com/cgi-bin/portal/CSO/kbBrowse.jsp
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Typographical Conventions

This guide uses the following typographical conventions:

UI Elements and 
Function Names

This style indicates the names of interface elements on 
which you perform actions, file names or paths, and 
other items that require emphasis. For example, “Click 
the Save button.” It also indicates method or function 
names. For example, "The wait_window statement has 
the following parameters:"

Arguments This style indicates method, property, or function 
arguments and book titles. For example, “Refer to the 
HP User’s Guide.”

<Replace Value> Angle brackets enclose a part of a file path or URL 
address that should be replaced with an actual value. 
For example, <MyProduct installation folder>\bin.

Example This style is used for examples and text that is to be 
typed literally. For example, “Type Hello in the edit 
box.”

CTRL+C This style indicates keyboard keys. For example, “Press 
ENTER.”

[ ] Square brackets enclose optional arguments.

{ } Curly brackets indicate that one of the enclosed values 
must be assigned to the current argument. 

... In a line of syntax, an ellipsis indicates that more items 
of the same format may be included. In a 
programming example, an ellipsis is used to indicate 
lines of a program that were intentionally omitted.

| A vertical bar indicates that one of the options 
separated by the bar should be selected.
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1
Introducing QuickTest

This lesson provides you with an overview of automated testing and 
QuickTest, and gets you set up to perform the tutorial.

It is recommended to work with an online copy of this tutorial because 
there are sections in which you will be asked to copy and paste test steps 
into QuickTest. You can open a PDF of this tutorial from your <QuickTest 
Professional installation folder>\help folder or by choosing Help > Printer-
Friendly Documentation in QuickTest. You can access the online version of 
this tutorial by choosing Help > QuickTest Professional Tutorial.

This lesson includes:

 ➤  Benefits of Automated Testing on page 16

 ➤  Testing Process on page 17

 ➤  QuickTest Window on page 19
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Benefits of Automated Testing

If you have ever tested applications or Web sites manually, you are aware of 
the drawbacks. Manual testing is time-consuming and tedious, requiring a 
heavy investment in human resources. Worst of all, time constraints often 
make it impossible to manually test every feature thoroughly before the 
application is released. This leaves you wondering whether serious bugs 
have gone undetected.

Automated testing with QuickTest addresses these problems by dramatically 
speeding up the testing process. You can create tests that check all aspects of 
your application or Web site, and then run these tests every time your site or 
application changes. 

As QuickTest runs tests, it simulates a human user by moving the cursor in a 
Web page or application window, clicking GUI (graphical user interface) 
objects, and entering keyboard input; however, QuickTest does this faster 
than any human user.

Benefits of Automated Testing

Fast QuickTest runs tests significantly faster than human 
users.

Reliable Tests perform precisely the same operations each time 
they are run, thereby eliminating human error.

Repeatable You can test how the Web site or application reacts after 
repeated execution of the same operations.

Programmable You can program sophisticated tests that bring out 
hidden information.

Comprehensive You can build a suite of tests that covers every feature in 
your Web site or application.

Reusable You can reuse tests on different versions of a Web site or 
application, even if the user interface changes.
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Testing Process

The QuickTest testing process consists of the following main phases:

 1 Analyzing your application

The first step in planning your test is to analyze your application to 
determine your testing needs. 

➤ What are your application’s development environments (for example 
Web, Java, or .NET)? You will need load QuickTest add-ins for these 
environments to enable QuickTest to identify and work with the objects 
in your application. 

➤ What business processes and functionality do you want to test? To 
answer this, think about the various activities that customers perform in 
your application to accomplish specific tasks. 

➤ Consider how to divide these business processes into smaller units. You 
will be creating actions based on these tasks. Smaller and more modular 
actions make your tests easier to read and follow, and help ease 
maintenance in the long run. 

At this stage, you can already begin creating test skeletons and adding 
actions to them. 

 2 Preparing the testing infrastructure

Based on your testing needs, you determine what resources are required and 
create these resources, accordingly. Resources include shared object 
repositories containing test objects (which are representations of the objects 
in your application), function libraries containing functions that enhance 
QuickTest functionality, and so on. 

You also need to configure QuickTest settings so that QuickTest will perform 
the tasks you need, such as displaying a results report every time you run a 
test.
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 3 Building your tests and adding steps to them

After the testing infrastructure is ready, you can begin building your tests. 
You can create one or more empty tests and add actions to them to create 
the testing skeletons. You associate your object repositories with the 
relevant actions, and associate your function libraries and recovery scenarios 
with the relevant tests, so that you can insert steps using keywords. You may 
also need to configure test preferences at this point. 

 4 Enhancing your test

Inserting checkpoints into your test lets you search for a specific value of a 
page, object, or text string, which helps you determine whether your 
application or site is functioning correctly.

Broadening the scope of your test, by replacing fixed values with 
parameters, lets you check how your application performs the same 
operations with multiple sets of data. 

Adding logic and conditional or loop statements enables you to add 
sophisticated checks to your test.

 5 Debugging, running, and analyzing your test

You debug a test to ensure that it operates smoothly and without 
interruption. After the test is working correctly, you run it to check the 
behavior of your application. While running, QuickTest opens the 
application, or connects to the Web site, and performs each step in your 
test.

You examine the test results to pinpoint defects in your application. 

 6 Reporting defects

If you have Quality Center installed, you can report the defects you discover 
to a database. Quality Center is the HP test management solution.
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QuickTest Window

Before you begin creating tests, you should familiarize yourself with the 
main QuickTest window.

The image below shows a QuickTest window as it would appear after you 
create a test, with all toolbars and the Data Table and Resources panes 
displayed:

Menu Bar

Toolbars

Test 
Document
(shown 
in the 
Keyword 
View)

Data Table

Resources
pane

Title Bar

Tabs for 
other 
panes
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Document Area

The document area of the QuickTest window can display the following:

➤ Test. Enables you to create, view, and modify your test in Keyword View or 
Expert View.

➤ Function Library. Enables you to create, view, and modify functions 
(operations) for use with your test.

➤ Start Page. Welcomes you to QuickTest and provides links to Process 
Guidance. You can use the shortcut buttons to open new and existing 
documents. 

Key Elements in the QuickTest Window

In addition to the document area, the QuickTest window contains the 
following key elements: 

➤ QuickTest title bar. Displays the name of the active document. If changes 
have been made since it was last saved, an asterisk (*) is displayed next to 
the document name in the title bar.

➤ Menu bar. Displays menus of QuickTest commands.

➤ Standard toolbar. Contains buttons to assist you in managing your test.  

➤ View toolbar. Contains buttons to view the various panes that can assist you 
in the testing process.  

➤ Tools toolbar. Contains buttons to assist you in setting options, checking 
syntax, and working with the Object Spy.

➤ Automation toolbar. Contains buttons to assist you in the testing process.
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➤ Insert toolbar. Contains buttons to assist you in inserting steps, actions, 
checkpoints, and output values into your test. 

➤ Edit toolbar. Contains buttons to assist you in editing your test steps. 

➤ Debug toolbar. Contains buttons to assist you in debugging tests.

Note: For information on all of the toolbar and menu options, see the 
HP QuickTest Professional User’s Guide.

➤ Action toolbar. Contains buttons and a list of actions, enabling you to view 
the details of an individual action or the entire test flow.  

➤ Document tabs and scroll arrows. Enables you to navigate open documents 
in the document area by selecting the tab of the document you want to 
activate (bring into focus). When there is not enough space in the 
document area to display all of the tabs simultaneously, you can use the left 
and right arrows to scroll between your open documents.

➤ Keyword View. Contains each step, and displays the object hierarchy, in a 
modular, icon-based table.

➤ Expert View. Contains each step as a VBScript line. In object-based steps, the 
VBScript line defines the object hierarchy. For more information, see 
Chapter 9, “Working in Function Library Windows.”

Action List

Back

Display selected action
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➤ Status bar. Displays the status of the QuickTest application and other 
relevant information.

You can show or hide the following panes from the View menu:

➤ Test. Contains the Keyword View and Expert View tabs.

➤ Function Library. Enables you to create, view, and modify functions 
(operations) for use with your test. 

➤ Start Page. Welcomes you to QuickTest and provides links to Process 
Guidance. You can use the shortcut buttons to open new and existing 
documents. 

➤ Active Screen. Provides a snapshot of your application as it appeared when 
you performed a certain step during a recording session. (You can display 
the Process Guidance panes by choosing View > Process Guidance, or by 
clicking the Process Guidance panes button.)

➤ Data Table. Assists you in parameterizing your test. (You can display the 
Process Guidance panes by choosing View > Process Guidance, or by 
clicking the Process Guidance panes button.)

➤ Debug Viewer pane. Assists you in debugging your test. The Debug Viewer 
pane contains the Watch, Variables, and Command tabs. (The Debug Viewer 
pane is not displayed when you open QuickTest for the first time. You can 
display the Debug Viewer by choosing View > Debug Viewer.)

➤ Information pane. Displays a list of syntax errors found in your test and 
function library scripts. (You can display the Information pane by choosing 
View > Information.)

➤ Missing Resources pane. Provides a list of the resources that are specified in 
your test but cannot be found, such as unmapped shared object repositories 
and parameters that are connected to shared object repositories. (The 
Missing Resources pane is not displayed when you open QuickTest for the 
first time. You can display the Missing Resources pane by choosing View > 
Missing Resources, or by clicking the Missing Resources button.)
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➤ Process Guidance panes. Displays two panes that provide procedures and 
descriptions on how to best perform specific processes, such as creating a 
test in QuickTest. The Process Guidance Activities pane lists the activities 
that you can perform, such as adding steps to a test. The Process Guidance 
Description pane describes the tasks that you need to perform for a selected 
activity. Your organization may also provide you with process guidance that 
is accessible from these panes. (You can display the Process Guidance panes 
by choosing View > Process Guidance, or by clicking the Process Guidance 
panes button.)

➤ Available Keywords Pane. Displays all the keywords available to your test. 
Enables you to drag and drop objects or calls to functions into your test. 
(You can display the Available Keywords pane by choosing View > Available 
Keywords, or by clicking the Available Keywords Pane button.)

➤ Test Flow Pane. Displays the hierarchy of actions and action calls in the 
current test, and shows the order in which they are run. (You can display the 
Test Flow pane by choosing View > Test Flow, or by clicking the Test Flow 
Pane button.)

➤ Resources Pane. Displays all the resources associated with your current test 
and enables you to manage these resources. (You can display the Resources 
pane by choosing View > Resources, or by clicking the Resources Pane 
button.)

Note: The Action toolbar is displayed only in the Keyword View. It is not 
displayed when you open QuickTest for the first time. You can display the 
Action toolbar by choosing View > Toolbars > Action. If you insert a reusable 
or external action in a test, the Action toolbar is displayed automatically in 
the Keyword View. For additional information, refer to the HP QuickTest 
Professional User’s Guide.

Some of the panes and toolbar options listed above are described in detail in 
subsequent lessons. For information on other panes and toolbar options, 
refer to the HP QuickTest Professional User’s Guide.
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You can also execute many menu commands using shortcut keys. For 
additional information, refer to the "QuickTest at a Glance" chapter in the 
HP QuickTest Professional User’s Guide.

Now that you are familiar with the main QuickTest window, take a few 
minutes to explore its components.
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2
Analyzing Your Application

This lesson provides you with an overview of automated testing and 
QuickTest, and gets you set up to perform the tutorial.

This lesson includes:

 ➤  Getting to Know Your Application on page 25

 ➤  Exploring the Mercury Tours Web Site on page 26

 ➤  Creating an Action on page 28

Getting to Know Your Application

Before you begin creating tests, you need to determine what exactly you 
want to test in your application. To do this, you need to analyze your 
application in terms of its business processes—the distinct activities that 
customers perform in your application to complete particular tasks.

For the purpose of this tutorial, you need to become familiar with the 
Mercury Tours Web site. Mercury Tours is a sample Web application that 
simulates a Web-based flight information and reservation service. You can 
access the Mercury Tours Web site using any Web browser, but you can 
perform the tutorial using only Microsoft Internet Explorer.

As you navigate through this application, consider the following:

➤ How is the application divided? Are there separate areas for each activity? 
What are these areas? What are these activities? What are the expected 
outcomes for each activity?

➤ What screens need to be tested in each of these areas? What objects need to 
be tested in each screen? 
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➤ What activities might be used in more than one scenario? (For example, 
logging on to the application.) Think of these as "reusable" parts. 

Dividing an application into separate parts can help you to design your tests 
so that they comprise small, modular units, which are easier to understand, 
debug, and maintain over time.

➤ What business processes might users perform using this application? One 
scenario discussed in this tutorial is reserving flights. Other scenarios might 
include making cruise or hotel reservations, or even registering on the Web 
site. 

➤ Consider which development environments need to be supported for 
testing purposes. QuickTest provides add-ins to support many testing 
environments. You load these add-ins when you open QuickTest. When 
working with this tutorial, you need to load the Web add-in because 
Mercury Tours is a sample Web application. Your application might require 
you to load Java or other add-ins.

Exploring the Mercury Tours Web Site

Before you begin this tutorial, open the Mercury Tours Web site and explore 
it for a while. As you navigate the site and familiarize yourself with its 
content, consider the questions posed in the previous section. 

To run Mercury Tours:

 1 Launch the Mercury Tours application.

In Microsoft Internet Explorer, type the following URL: 
http://newtours.demoaut.com

The Mercury Tours home page opens.

http://newtours.demoaut.com
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 2 Log in to Mercury Tours.

In the Find a Flight area, enter tutorial in both the User Name and Password 
boxes and click Sign-In.

The Flight Finder page opens.

 3 Explore the Mercury Tours site.

Beginning with the Flight Finder page, follow the on-screen instructions to 
get flight information and reserve a flight. 



Lesson 2 • Analyzing Your Application

28

As you navigate the application, think about what you might want to test, 
and which pages and objects need to be included in each test that you 
might create. 

On the Book a Flight page, you do not have to fill out actual personal or 
credit card information; just enter the required information (indicated in 
red) in the Passengers and Credit Card sections. (You may enter fictitious 
information.)

 4 End your Mercury Tours session.

When you finish exploring the Mercury Tours application, click the 
LOG OUT button on the Flight Confirmation page or the SIGN-OFF link at 
the top of any application page.

To sign on again, simply enter Tutorial in the User Name and Password 
boxes in the SIGN-ON page or in the Mercury Tours home page.

 5 Close the Web browser.

You are now ready to begin using this tutorial to create tests on the Mercury 
Tours application using QuickTest!

Creating an Action

Each QuickTest test comprises calls to actions. Actions are units that divide 
your test into logical sections. When you create a new test, it contains a call 
to one action. By dividing your tests into calls to multiple actions, you can 
design more modular and efficient tests. 

QuickTest lets you insert several types of actions into tests. An internal 
action is an action that is stored in the local test (also known as a source 
test). An external action is a referenced call to an action that is stored in a 
different test. For example, you may have an action that you want to use in 
multiple tests—you would store the action as an internal action in one test 
and insert calls to that action from other tests. In the other tests the action 
would be available as an external action.
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When you insert a call to a new action, it is reusable by default, enabling 
you to insert calls to the action from any test. Reusable actions are especially 
useful when you have a process that you may need to include in several 
tests, such as logging in to your application, or that you may need to insert 
several times in the same test, such as filling in user credential dialog boxes 
that open whenever a user tries to access a secure part of your application. 
Reusable actions can be internal or external actions.

When you insert calls to existing (reusable) actions, they are read-only in 
the calling test. You modify them in the test in which they are stored. 

Inserting calls to existing actions enables you to create and enhance your 
action’s test steps only once and then to call the same action from several 
tests. This makes it easier to maintain tests, because when your application 
changes you only have to update the existing action stored with the original 
test. This also helps ease test maintenance because when you modify these 
actions, all tests containing calls to these actions are updated. This enables 
you to create and enhance your action’s test steps only once and then insert 
calls to the existing actions as needed from any test. If you plan to use the 
same or similar actions in many tests, you might consider creating a 
repository test to store your reusable actions. Then you can insert calls to 
these existing actions from other tests, linking these actions to the source 
test. 

You can also insert a copy of an action in your tests if you plan to make 
changes to the action steps. This inserts a ready-made internal action in the 
current test. Copies of actions are not linked to the source test, so that when 
you insert a call to a copy of an existing action, you can make changes to 
the copied action, and your changes will neither affect, nor be affected by, 
any other test. 

If you want to prevent an action from being reused in any test, you can 
make it non-reusable. Non-reusable actions are internal actions that can be 
used only once. 

In this section, you will open a new test and rename an action so that 
anyone viewing this test will know the purpose of the action. You will use 
this action in subsequent lessons. 
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 1 Start QuickTest and open a new test.

➤ If QuickTest is not currently open, choose Start > Programs > QuickTest 
Professional > QuickTest Professional. 

In the Add-in Manager, confirm that the Web Add-in is selected, and 
clear all other add-ins. Click OK to close the Add-in Manager and open 
QuickTest. 

Note: While QuickTest loads your selected add-ins, the QuickTest splash 
screen is displayed. This may take a few seconds.

If the Start Page window opens, in the Welcome! area, click the New Test 
button.

Otherwise, choose File > New > Test, or click the New button down arrow 
and choose Test.

Note: If a test is already open, clicking the New toolbar button opens a 
new test. 

A blank test opens.

➤ If QuickTest is already open, check which add-ins are loaded by selecting 
Help > About QuickTest Professional. If the Web Add-in is not loaded, 
you must exit and restart QuickTest. When the Add-in Manager opens, 
select the Web Add-in, and clear all other add-ins.

Note: If the Add-in Manager does not open when starting QuickTest, 
choose Tools > Options. In the General tab, select Display Add-in 
Manager on startup. When you exit and restart QuickTest, the Add-in 
Manager opens.
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 2 Rename Action1 so that it has a logical name.

 a Ensure that the Test Flow pane is displayed. If you do not see the Test 
Flow pane, choose View > Test Flow or click the Test Flow Pane button to 
display it.

 b In the Test Flow pane, select Action1 and choose Edit > Action > Rename 
Action. In the confirmation box, click Yes.

 c In the New name box, enter Login. 

 d Click OK to save the change.

 3 Create a new action named FlightFinder.

 a Choose Insert > Call to New Action or click the Insert Call to New Action 
button. The Insert Call to New Action dialog box opens.

 b Enter FlightFinder in the Name box, confirm that both Reusable Action 
and At the end of the test are selected, and click OK. The dialog box 
closes and the FlightFinder action is added to the end of your test.



Lesson 2 • Analyzing Your Application

32

 4 Create calls to additional actions.

Repeat step 3 to add the following actions:

➤ SelectFlight

➤ BookFlight

Your test now contains all of the actions needed to begin this tutorial. 

 5 Save your test.

 a Choose File > Save or click the Save button. The Save dialog box opens to 
the Tests folder.

 b Create a folder named Tutorial, select it, and click Open.

 c Enter MercuryTours in the File name field.

 d Confirm that Save Active Screen files is selected.

 e Click Save. The test name (MercuryTours) and path are displayed in the 
title bar of the main QuickTest window.

Note: If a test has changed and is not yet saved, the test name in the title bar 
contains an asterisk.

Different Ways to Insert Calls to Actions

You can insert calls to actions in your test at any time (except during a test 
run). In the previous section, you inserted a call to a new action using the 
first option listed below. You can use any of the following menu options or 
toolbar buttons to add actions to your test:

➤ Insert > Call to New Action or use the Insert Call to New Action button. 

This option inserts a new, empty action in your test.

(You can also click the down arrow and choose Call to Copy of Action or Call 
to Existing Action, described below.)

➤ Edit > Action > Split Action or use the Split Action button. 
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This option divides an existing action into two separate actions at the step 
you specify.

➤ Insert > Call to Copy of Action or right-click an action and choose Insert Call 
to Copy of Action.

This option inserts a copy of an existing action in your test. The action is 
not linked to the source test from which you copied it.

➤ Insert > Call to Existing Action or right-click an action and choose Insert Call 
to Existing Action.

This option inserts a call to an existing action in your test. You can insert a 
call to an action that is stored in the current test (if you want to insert the 
same action twice, for example), or you can insert a call to an action in 
another test. The action is linked to the source test from which you copied 
it. 
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3
Creating Object Repositories

This lesson introduces test objects and run-time objects, and describes how 
to create shared object repositories.

This lesson includes:

 ➤  Introducing Test Objects and Object Repositories on page 35

 ➤  Learning Objects in Your Application on page 37

 ➤  Using Multiple Object Repositories on page 45

Introducing Test Objects and Object Repositories

Before you create a test, you need to set up the resources that will be used by 
that test. One of the most important resources for any test is the object 
repository. An object repository is a storehouse for the test objects (and 
other object types) used in your test. 

Test objects are stored representations of the actual objects (or controls) in 
your application. QuickTest creates test objects by learning a select set of the 
properties and values of the objects in your application. QuickTest uses the 
information it learns to uniquely identify the run-time objects in your 
application. 

Each test object is part of a test object hierarchy. For example, a Link object 
may be part of a Browser/Page/Link hierarchy. Top-level objects, such as 
Browser objects, are known as container objects, as they can contain lower-
level objects, such as Frame or Page objects.
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Note: Object repositories can also include checkpoint and output value 
objects. These object types are covered in Lesson 7, “Creating Checkpoints 
and Using Functions” and Lesson 9, “Creating Output Values.”

Run-time objects are created and maintained during a run session by the 
object creator (for example, Microsoft for Microsoft Internet Explorer 
objects, Netscape for Netscape Browser objects, the product developer for 
ActiveX objects, and so on). During a run session, QuickTest performs the 
specified test object method on the run-time object. Run-time objects are 
not stored in an object repository, as they are available only during the run 
session.

Later in this lesson, you will use the Object Spy dialog box to view the test 
object and run-time properties and methods of any object in your 
application. 

Object Repositories

QuickTest can store the test objects it learns in two types of object repository 
files, shared and local.

A shared object repository contains test objects that can be used in multiple 
actions. This versatility makes it the preferred repository type for storing and 
maintaining test objects. By associating a shared object repository with an 
action, you make the test objects in that repository available for use in the 
action. Any maintenance you perform on an object in a shared object 
repository is reflected in any step using that object. 

A local object repository stores test objects that can be used in one specific 
action. The objects in this type of repository cannot be used in any other 
action. Local object repositories are useful for backing up your test objects, 
or for learning one or several objects (using the Navigate and Learn tool or 
by recording on them).

During a run session, QuickTest references the test objects stored in the 
associated object repositories in order to perform operations on the 
corresponding objects in your application.
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Learning Objects in Your Application

In this section, you will use the QuickTest Navigate and Learn option to add 
objects from the Mercury Tours Web site to a shared object repository. Then 
you will associate the object repository with your test.

 1 Start QuickTest and open a new test.

If QuickTest is not currently open, open it as described in step 1 on page 30, 
making sure that only the Web Add-in is loaded.

 2 Set the learn settings for QuickTest.

 a Choose Automation > Record and Run Settings. The Record and Run 
Settings dialog box opens.

 b In the Web tab, select Open the following address when a record or run 
session begins. 

 c Confirm that the URL in the first box is http://newtours.demoaut.com and 
in the second box, choose a browser on which to run your test session. 
Microsoft Internet Explorer is the browser used in this tutorial.

http://newtours.demoaut.com
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 d Confirm that Do not record and run on browsers that are already open 
and Close the browser when the test closes are selected.

 e Click OK. When you run the test, your browser will open to the Mercury 
Tours Web site. When the run session ends, your browser will close.

 3 Open the Mercury Tours Web site.

Open Internet Explorer and browse to the Mercury Tours Web site: 
http://newtours.demoaut.com

 4 View the properties and methods for some of the objects in the Mercury 
Tours Web site.

 a In QuickTest, choose Tools > Object Spy. The Object Spy dialog box 
opens.

 b Drag the Object Spy dialog box to the right side of your screen. This will 
enable you to see the objects you want to spy on more clearly. Verify that 
the Keep Object Spy on top while spying check box is selected.

 c Click the pointing hand button. QuickTest is hidden, and the Object Spy 
dialog box is displayed over the Mercury Tours Web site Login page.

http://newtours.demoaut.com
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 d Move the mouse cursor over the various objects on the page and watch 
what happens in the Object Spy dialog box.

 e Position the mouse cursor in the User Name edit box (but do not click it). 
The test object hierarchy of that object is displayed. In the hierarchy box, 
notice that the name of the object is WebEdit, which is its object class 
type.

 f Click the User Name edit box. QuickTest opens again. In the hierarchy 
box, notice that the object class and name are now displayed 
(WebEdit:userName).

 g Click Close to close the Object Spy dialog box.

 5 Use Navigate and Learn to add objects from the Mercury Tours Web site 
Login page to a shared object repository.

 a In QuickTest, choose Resources > Object Repository Manager. The Object 
Repository Manager window opens.

 b In the Object Repository Manager window, choose Object > Navigate 
and Learn. Both QuickTest and the Object Repository Manager are 
hidden, and the Navigate and Learn toolbar opens over the Mercury 
Tours Login page.

 c In the Navigate and Learn toolbar, click the Define Object Filter button. 
The Define Object Filter dialog box opens.
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 d In the Define Object Filter dialog box, select the Selected object types 
radio button and click Select. The Select Object Types dialog box opens.

 e Click the Clear All button to clear all of the check boxes. Then select the 
Edit Box and Image check boxes and click OK. This instructs QuickTest to 
learn only the objects that are needed for your test and add them to the 
object repository. (This helps keep object repository maintenance to a 
minimum.)

 f In the Define Object Filter dialog box, click OK.
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 6 Learn the selected object types from the Mercury Tours Web site Login 
page.

In this step, you instruct QuickTest to learn all of the objects in the Mercury 
Tours Web site Login page that match your filter and to add them to a 
shared object repository. 

 a In the Mercury Tours Web site Login page, click the title to bring it into 
focus.

 b In the Navigate and Learn toolbar, click the Learn button. The Web page 
flickers as QuickTest begins adding representations of the objects on the 
Web page to a new object repository. Adding these objects takes a few 
seconds. Do not interact with the Web page while Navigate and Learn 
runs. When the flashing stops and the Adding Objects box closes, 
Navigate and Learn has finished adding the objects to the object 
repository.

 c In the Navigate and Learn toolbar, click the Close button. The Navigate 
and Learn toolbar closes, and QuickTest and the Object Repository 
Manager window are visible again.

 7 Remove unneeded objects from the object repository.

In the previous step, QuickTest added all of the objects that match your 
filter selection to the object repository. For this test, you need only a few 
objects, so in this step, you will delete the extraneous objects. 
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 a In the Object Repository Manager window, expand the objects in the 
Test Objects tree. You should see a list of objects similar to the following: 

 b Delete all of the image objects EXCEPT for Sign-In, password, and 
userName by selecting the objects and choosing Edit > Delete or clicking 
the Delete button. Click OK in the confirmation box.
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After you delete the extraneous objects, your tree should resemble the 
following: 

Tips: 

➤ You can select multiple objects using the SHIFT and CTRL keys. 

➤ If you delete Sign-In, password, or userName by mistake, click Undo to 
restore the deleted objects.

➤ When you create an object repository, try to include only the objects you 
need for testing purposes. This keeps the object repository relatively 
small and helps makes maintenance and object selection easier. Also, 
make sure that you provide logical names so that others can easily 
choose the correct objects when creating or modifying tests.
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 8 See what QuickTest learned about one of the objects.

In the Test Object tree, highlight the userName object. In the right pane, 
notice its object properties. These are the descriptive properties that 
QuickTest will use to identify the object during a run session. 

 9 Save the object repository.

 a In the Object Repository Manager window, choose File > Save or click the 
Save button. The Save Shared Object Repository dialog box opens.

 b Browse to the location in which you want to save your object 
repositories, create a folder named Tutorial_ObjectRepositories and 
double-click it. In the File Name box, enter MercuryToursLogin.tsr and 
click Save.

 10 Associate the object repository with the Login action.

 a In QuickTest, open the Resources pane, if it is not already open, by 
choosing View > Resources or clicking the Resources button.

 b In the Resources pane, right-click the Login action and choose Associate 
Repository with Action. The Open Attachment dialog box opens.
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 c Locate and select the MercuryToursLogin.tsr shared object repository and 
click Open. The object repository is now associated with the Login 
action, and is displayed in the Resources pane as a child of that action.

Associating an object repository with an action enables you to use any 
object from that repository in any step in the associated action.

 11 Save your test.

Choose File > Save or click the Save button. 

Note: If a test has changed and is not yet saved, the test name in the title bar 
contains an asterisk.

Congratulations! You have created a shared object repository and associated 
it with your test’s action.

Using Multiple Object Repositories

In the previous section, you created a shared object repository for the Login 
page of the Mercury Tours Web site. Now, you will create a shared object 
repository for each of the remaining pages in the site. 

Tip: It is recommended to always create a separate shared object repository 
for each page in your Web site or each area of your application. This makes 
it easier to find the correct object when adding or modifying test steps or 
when performing maintenance tasks when objects are added, removed, or 
modified in your application.

For the purposes of this tutorial, you will instruct QuickTest to learn all of 
the objects on each page. At this point, you do not need to associate the 
object repositories with a specific action.
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 1 Log in to the Mercury Tours Web site. 

 a In the User Name and Password boxes, type tutorial. 

 b Click Sign-In. The Flight Finder page opens.

 2 Open a new shared object repository.

 a If the Object Repository Manager is closed, open it by choosing 
Resources > Object Repository Manager in QuickTest. The Object 
Repository Manager window opens.

 b In the Object Repository Manager window, choose File > New. A blank 
shared object repository opens.

 3 Use Navigate and Learn to add objects from the Mercury Tours Web site 
Login page to a shared object repository.

 a In the Object Repository Manager window, choose Object > Navigate 
and Learn. Both QuickTest and the Object Repository Manager are 
hidden, and the Navigate and Learn toolbar opens over the Mercury 
Tours Flight Finder page.

 b In the Navigate and Learn toolbar, click the Define Object Filter button. 
The Define Object Filter dialog box opens.

 c In the Define Object Filter dialog box, select All object types and click 
OK.
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 4 Learn all of the objects from the Mercury Tours Web site Flight Finder 
page.

In this step, you instruct QuickTest to learn all of the objects in the Mercury 
Tours Web site Login page that match your filter and to add them to a 
shared object repository. 

 a Click the Find a Flight page title bar to change the focus from the 
Navigate and Learn toolbar to the Web page you want QuickTest to learn.

 b In the Navigate and Learn toolbar, click the Learn button. The Web page 
flickers as QuickTest begins adding representations of the objects on the 
Web page to a new object repository. Adding these objects takes a few 
seconds. Do not interact with the Web page while Navigate and Learn 
runs.

 c In the Navigate and Learn toolbar, click the Close button. The Navigate 
and Learn toolbar closes, and QuickTest and the Object Repository 
Manager window are visible again.

 5 Save the shared object repository.

 a In the Object Repository Manager window, choose File > Save or click the 
Save button. The Save Shared Object Repository dialog box opens.

 b Browse to the Tutorial_ObjectRepositories folders and select it. In the File 
Name box, enter MercuryToursFlightFinder.tsr and click Save.

 6 Open a new shared object repository, add objects to it, and save the 
repository.

 a In the Flight Finder page, click Continue. The Select Flight page opens. 
You are now ready to add objects from this page.

 b In the Object Repository Manager window, choose File > New. A blank 
shared object repository opens. 
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 c In the Object Repository Manager window, choose Object > Navigate 
and Learn. Both QuickTest and the Object Repository Manager are 
hidden, and the Navigate and Learn toolbar opens over the Mercury 
Tours Select Flight page.

 d Click the Select Flight page title bar to change the focus from the 
Navigate and Learn toolbar to the Web page you want QuickTest to learn.

 e In the Navigate and Learn toolbar, click the Learn button. The Web page 
flickers as QuickTest begins adding representations of the objects on the 
Web page to a new object repository. Adding these objects takes a few 
seconds. Do not interact with the Web page while Navigate and Learn 
runs.

 f In the Navigate and Learn toolbar, click the Close button. The Navigate 
and Learn toolbar closes, and QuickTest and the Object Repository 
Manager window are visible again.

 g In the Object Repository Manager window, choose File > Save or click the 
Save button. The Save Shared Object Repository dialog box opens.

 h Browse to the Tutorial_ObjectRepositories folders and select it. In the File 
Name box, enter MercuryToursSelectFlight.tsr and click Save.

 7 Create new shared object repositories for each of the remaining Web 
pages.

 a Repeat step 6 to create shared object repositories for the following pages:

➤ Book a Flight 

➤ Flight Confirmation

 b Name the object repositories MercuryToursBookFlight.tsr and 
MercuryToursFlightConfirmation.tsr, respectively.

 8 Associate the MercuryToursFlightFinder.tsr object repository with the 
FlightFinder action.

 a In QuickTest, open the Resources pane, if it is not already open, by 
choosing View > Resources or clicking the Resources Pane button.

 b In the Resources pane, right-click the FlightFinder action and choose 
Associate Repository with Action. The Open Attachment dialog box 
opens.
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 c Locate and select the MercuryToursFlightFinder.tsr shared object 
repository and click Open. The object repository is now associated with 
the FlightFinder action, and is displayed in the Resources pane as a child 
of that action.

 9 Associate the remaining object repositories with the relevant actions.

Repeat step 8 and:

➤ Associate MercuryToursSelectFlight.tsr with the SelectFlight action. 

➤ Associate MercuryToursBookFlight.tsr with the BookFlight action. 

➤ Associate MercuryToursFlightConfirmation.tsr with the BookFlight 
action. 

Later, when you add steps to each action, all of the required test objects will 
be available for use.
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4
Creating Functions and Function Libraries

QuickTest provides built-in functions and methods that will satisfy many of 
your testing needs. However, there may be times when you need to perform 
a task for which no suitable method exists. For example, you may want to 
generate a text file and save it to the file system, or you may want to add a 
step that accesses data from a Microsoft Excel worksheet. You can create a 
user-defined function to perform this task, save it in a function library file, 
and then insert it as a step every time that you need to perform this task.

This lesson includes:

 ➤  Introducing Functions and Function Libraries on page 51

 ➤  Creating a Function on page 52

 ➤  Associating the Function Library with Your Test on page 54

Introducing Functions and Function Libraries

In this lesson, you will use the QuickTest function library window to create a 
function and associate it with your test. Associating a function library with a 
test enables you to call any of the functions in the function library from that 
test.

A function is a set of coded steps that perform a particular task. You can 
create your own user-defined functions to perform operations that are not 
normally available for use with a particular test object class. In this lesson, 
you will create a function that checks the date format on a page generated 
by the Mercury Tours application.
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Creating a Function

In this lesson, you will create a function that you will later call from your 
test. This function checks whether a date is displayed in MM/DD/YYYY 
format. The function also verifies that the date is potentially valid, for 
example, that the month does not exceed 12 or that the date does not 
exceed 31. 

 1 Start QuickTest and open a new function library.

 a If QuickTest is not currently open, open it as described in step 1 on 
page 30, making sure that only the Web Add-in is loaded.

 b Open a new function library.

➤ If the Start Page window opens, in the Welcome! area, click New 
Function Library. 

➤ If QuickTest opens without displaying the Start Page window, choose 
File > New > Function Library or click the New button down arrow and 
choose Function Library. 
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 2 Paste the following function into the function library window.

’The following function checks whether a date string (dateStr) 
'has 10 characters representing MM/DD/YYYY

Function check_data_validity(  dateStr )

Dim firstSlashPos, secondSlashPos
Dim mmPart, ddPart, yyyyPart

firstSlashPos = inStr( dateStr , "/" )
secondSlashPos = inStrRev( dateStr, "/" ) 
If (  firstSlashPos <> 3 or secondSlashPos <> 6 ) Then

reporter.ReportEvent micFail,"Format check", "Date string is missing at least one slash ( / )."
check_data_validity = False

Exit function
End If

mmPart = mid( dateStr, 1,2 )
ddPart  = mid ( dateStr, firstSlashPos+1, 2 )
 yyyyPart = mid( dateStr, secondSlashPos +1 , 4 ) 

If mmPart > 12 Then
 reporter.ReportEvent micFail, "Format Check" , "The month value is invalid. It exceeds 12." 
check_data_validity = False
Exit function

End If
If ddPart > 31 Then

 reporter.ReportEvent micFail, "Format Check" , "The date value is invalid. It exceeds 31." 
 check_data_validity = False
 Exit function

 End If
If yyyyPart < 2000 Then

reporter.ReportEvent micFail, "Format Check" , "The year value is invalid. (Prior to 2000)" 
check_data_validity = False

 Exit function
 End If

check_data_validity = True

End Function
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 3 Save the function library.

 a Choose File > Save or click the Save button. The Save Function Library 
dialog box opens.

 b Save the function library in the suggested location, naming it 
CheckDateFunction.qfl.

Associating the Function Library with Your Test

Now that you created a function and stored it in a function library, you need 
to associate the function library with your test so that its function will be 
available to your test. After you associate the function library with your test, 
you will verify that it was associated successfully. 

 1 Associate the CheckDateFunction.qfl with the Mercury Tours test.

 a In QuickTest, open the Resources pane, if it is not already open, by 
choosing View > Resources or clicking the Resources Pane button. 

 b In the Resources pane, right-click the Associated Function Libraries node 
and choose Associate Function Library. The Open Attachment dialog box 
opens.

 c Locate and select the CheckDateFunction.qfl function library and click 
Open. Click Yes in the Automatic Relative Path Conversion dialog box. 
This converts the path to a relative path. (Using a relative path keeps the 
path valid when you move folders containing tests and other files from 
one location to another, as long as the folder hierarchy remains the 
same.)

The function library is now associated with the Mercury Tours test, and is 
displayed in the Resources pane as a child of the Associated Function 
Libraries node.

 2 Verify that the function library file is associated with your test.

Choose Resources > Associate Function Libraries and verify that 
CheckDateFunction.qfl is listed in the menu.

 3 Save the test.

Choose File > Save or click the Save button. 
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5
Creating a Test

Now that you have created the required automation infrastructure, you are 
ready to create your tests. 

This lesson includes:

 ➤  Preparing to Create a Test on page 55

 ➤  Adding Steps to the Login Action on page 56

 ➤  Analyzing the Login Action in the Keyword View on page 61

 ➤  Adding the Remaining Steps to Your Test on page 63

 ➤  Dividing an Action into Two Actions on page 76

Preparing to Create a Test

Before you begin creating a test, ensure that your application and QuickTest 
are set to match the needs of your test. For the purposes of this tutorial:

➤ In Microsoft Internet Explorer, clear the AutoComplete option for user 
names and passwords (choose Tools > Internet Options > Content tab > 
(AutoComplete) Settings).

➤ Close all browsers before you begin.

➤ Set the proper Web Page/Frame options. Open QuickTest, choose Tools > 
Options and click the Web tab. Click the Page/Frame Options button. In the 
Create a new Page test object for area, select Different URLs or a change in 
data transfer and select the first four check boxes.
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Adding Steps to the Login Action

A step represents an operation to be performed on your application. For 
example, a step might click an image or insert a value into an edit box.

In Lesson 2, “Analyzing Your Application,” you created unique actions for 
most of the pages in the Mercury Tours Web site and added them to your 
test. This enables you to reuse each action in your tests. For example, you 
may want to use the Login action in multiple tests. 

In this section, you will make a reservation for a flight from New York to San 
Francisco on the Mercury Tours Web site, adding steps in various ways. After 
you add steps to the first action, you will analyze the steps to gain a better 
understanding of the Keyword View.

 1 Start QuickTest and open the MercuryTours test.

 a If QuickTest is not currently open, open it as described in step 1 on 
page 30, making sure that only the Web Add-in is loaded.

 b Browse to and open the MercuryTours test.

 2 Open the Login action in the Keyword View.

 a Ensure that the Test Flow pane is displayed. If you do not see the Test 
Flow pane, choose View > Test Flow or click the Test Flow Pane button to 
display it.

 b Ensure that the Keyword View is displayed. 

Click the Keyword View tab if the Expert View is displayed.

 c In the Test Flow pane, double-click the Login action. 

The Login action opens. 
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 3 Add the first step needed to log in to the Mercury Tours Web site. 

 a In the Keyword View, choose Insert > New Step. The Item list opens, 
displaying the top-level (parent) test object in the associated Login 
shared object repository (the Welcome: Mercury Tours browser object). 
You need to insert steps only on the objects on which you want to 
perform operations, so you do not need to insert a step on this object. 

 b Select Object from repository to open the Select Object for Step dialog 
box and expand the test object tree. 
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 c Select userName and click OK. 

The Select Object for Step dialog box closes and one step is added to the 
action, even though three rows are added to the Keyword View. 
(QuickTest adds a row for each of the parent test objects, but does not 
perform an operation on these objects. Therefore, these rows are not 
actually steps.) During a run session, QuickTest uses the parent objects to 
help identify the actual object on which it needs to perform an 
operation.

In this step, the selected userName WebEdit test object is added to the 
Item cell; the default method, Set, is added to the Operation cell; but no 
documentation is added to the Documentation cell because the step is 
still missing a required value.   

 d In the Value cell, enter tutorial. 

Inserting this value completes the step. Documentation for the step in 
plain English is displayed in the Documentation cell.  

 e Click the Expert View tab to view the syntax of the step in VBScript.

Notice that this step is being performed on the WebEdit (edit box) test 
object and that:

➤ The test object hierarchy for the WebEdit (edit box) test object is 
displayed prior to the test object.

➤ The method to be performed on the object is displayed immediately 
after the test object. 

Browser("Welcome: Mercury Tours").Page("Welcome: Mercury Tours").WebEdit("userName").Set "tutorial"
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➤ Full stops (periods) separate each part of the step.

 f Click the Keyword View tab to return to the Keyword View.

 4 Add the next step.

 a Choose Insert > New Step again to insert the next step. 

The Item list opens listing the sibling objects of the previous step's test 
object.

 b Select password from the Item list. 

The password WebEdit test object is added to the Item cell, and the 
default method, Set, is added to the Operation cell. You need to change 
this method because the password needs to be encoded. Also no 
documentation is added to the Documentation cell because the step is 
still missing a required value.

 c Click in the Operation cell to display the down arrow, and then click the 
down arrow to display the list of available methods for the selected test 
object. Select SetSecure from the list. This method enables the use of 
encrypted text. Now, you need to generate the encrypted text and insert 
in the Value cell.

 5 Generate an encoded password.

 a From the Windows menu, choose Start > Programs > QuickTest 
Professional > Tools > Password Encoder. The Password Encoder dialog 
box opens.

 b In the Password box, enter tutorial.
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 c Click Generate. The Password Encoder encrypts the password and 
displays it in the Encoded String box.

 d Click Copy. Paste the encoded value in the Value cell for the password 
step. 

Inserting a value completes this step. Documentation for this step is 
displayed in the Documentation cell.

 e Click Close to close the Password Encoder. 

If you ran your action at this point, QuickTest would automatically open the 
Mercury Tours Web site and insert the values you specified in the User Name 
and Password boxes, as shown below: 
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 6 Insert the last step in the Login action.

 a Click in the Item column below the last step to insert the next step. 

The Item list opens listing the sibling objects of the previous step's test 
object.

 b Select Sign-In from the Item list. 

This step instructs QuickTest to click the Sign-In button.

 7 Save your test.

Choose File > Save or click the Save button. 

Analyzing the Login Action in the Keyword View

Let’s take a look at the steps in your first action. Each step represents an 
operation to be performed in the Web browser.

The columns in the Keyword View show different information for each step, 
as follows:

➤ Item. The item for the step (test object, utility object, function call, or 
statement) in a hierarchical icon-based tree.

➤ Operation. The operation to be performed on the item, for example, Click or 
Select.

➤ Value. The argument values for the selected operation, for example, the 
mouse button to use when clicking the image.

➤ Documentation. Auto-documentation of what the step does, in an 
easy-to-understand sentence, for example, Click the "Sign-In" image.

➤ Assignment. The assignment of a value to or from a variable so you can use 
the value later in the test. This column is not visible by default.

➤ Comment. Any textual information you want to add regarding the step, for 
example, Return to page used in first step of the test. This column is not 
visible by default.
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Note: You can choose to hide or display individual columns as required, by 
right-clicking the column heading in the Keyword View and selecting a 
column name from the list.

In the Item column of the Keyword View, you can click the branch arrows 
to expand or collapse the steps under each Web page. You can expand each 
action by choosing View > Expand All. 

When you expand your action, it should look similar to this: 

The table below provides an explanation of the steps shown in the action in 
the Keyword View above.

Step Description

 Login is the action name. Actions are 
test units that divide your test into 
logical sections.

The browser invokes the Welcome: 
Mercury Tours Web site.

Welcome: Mercury Tours is the name 
of the Web page.

userName is the name of the edit box. 
Set is the method performed on the 
edit box. tutorial is the value of the edit 
box.



Lesson 5 • Creating a Test

63

Take a few minutes to examine the Keyword View in detail, tracing the steps 
you performed while creating this action.

For more information on the Keyword View, refer to the QuickTest 
Professional User’s Guide.

Adding the Remaining Steps to Your Test

Now that you are familiar with the Keyword View, you can continue adding 
steps to your test. You will:

➤ “Add Steps to the FlightFinder Action” on page 63

➤ “Add a Step to the SelectFlight Action” on page 68

➤ “Add Steps to the BookFlight Action” on page 70

Add Steps to the FlightFinder Action
In the previous section, you added steps to the Login action. If you were to 
run your test at this point, the last step would open the Flight Finder page in 
the Mercury Tours Web site. 

Now, you will use the Expert View to add steps to the FlightFinder action 
you created for the Flight Finder page. The steps you add will use test objects 
from the associated MercuryToursFlightFinder shared object repository.

password is the name of the edit box. 
SetSecure is an encryption method 
performed on the edit box. 
4082820183afe512e8bc91c1f7222dbd 
is the encrypted value of the password.

Sign-In is the name of the image link. 
Click is the method performed on the 
image. 

Step Description
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 1 In QuickTest, open the MercuryTours test, if it is not already open.

 a If QuickTest is not already open, choose Start > Programs > QuickTest 
Professional > QuickTest Professional. 

➤ If the Start Page window opens, click Open Test. 

➤ If QuickTest opens without displaying the Start Page window, choose 
File > Open > Test or click the Open button down arrow and choose 
Test. 

 b In the Open Test dialog box, locate and select the MercuryTours test, and 
then click Open.

 2 Open the FlightFinder action.

 a Ensure that the Test Flow pane is displayed. If you do not see the Test 
Flow pane, choose View > Test Flow or click the Test Flow Pane button to 
display it. 

 b In the Test Flow pane, double-click the FlightFinder action. The 
FlightFinder action opens.

 3 Launch the Mercury Tours application and open the Flight Finder page.

 a In Microsoft Internet Explorer, enter the following URL: 
http://newtours.demoaut.com

The Mercury Tours home page opens.

http://newtours.demoaut.com
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 b In the Find a Flight area, enter tutorial in both the User Name and 
Password boxes and click Sign-In. The Flight Finder page opens.
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 c In QuickTest, choose Automation > Record and Run Settings. The Record 
and Run Settings dialog box opens. 

In the Web tab, select Record and run test on any open browser and click 
OK. This enables QuickTest to record on the open Web page. 

 d In QuickTest, choose Automation > Record or click the Record button. 
QuickTest begins recording, and your browser displays the Flight Finder 
page in the Mercury Tours Web site. (You can resize QuickTest to display 
more of the Web page.)

Change the following selections by selecting them from the drop-down 
lists:

➤ Departing From: New York

➤ On: December 29

➤ Arriving In: San Francisco

➤ Returning: December 31
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Click CONTINUE to accept the other default selections. The Select Flight 
page opens.

 e In QuickTest, click Stop on the Automation toolbar to stop the recording 
process.

You have now reserved an imaginary ticket from New York to San 
Francisco. QuickTest recorded your Web browser operations from the 
time you clicked the Record button until you clicked the Stop button.

 f In QuickTest, choose Automation > Record and Run Settings to restore 
the required run settings. The Record and Run Settings dialog box opens. 

In the Web tab:

➤ Select Open the following address when a record or run session 
begins. 

➤ Confirm that the URL in the first box is http://newtours.demoaut.com 
and in the second box, choose a browser on which to run your test 
session. Microsoft Internet Explorer is the browser used in this tutorial.

http://newtours.demoaut.com
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➤ Confirm that Do not record and run on browsers that are already 
open and Close the browser when the test closes are selected.

➤ Click OK to save your changes and close the dialog box.

 4 Save your test.

Choose File > Save or click the Save button. 

Add a Step to the SelectFlight Action
In the previous section, you added steps to the FlightFinder action. If you 
were to run your test at this point, the last step would open the Select Flight 
page in the Mercury Tours Web site. 

For the purpose of this tutorial, you do not need to make any changes in the 
Select Flight page, but you do need to instruct QuickTest to accept the 
default options and continue to the next page. Therefore, in this action, you 
will add one step that instructs QuickTest to click the CONTINUE button. 

 1 Open the SelectFlight action.

 a Ensure that the Test Flow pane is displayed. If you do not see the Test 
Flow pane, choose View > Test Flow or click the Test Flow Pane button to 
display it. 

 b In the Test Flow pane, double-click the SelectFlight action. The 
SelectFlight action opens.

 2 Add a step to the SelectFlight action by clicking in the Item column.

 a Click in the Item column below the action name to insert the next step. 

The Item list opens listing the top-level parent object in the 
MercuryToursSelectFlight shared object repository.
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 b Select Object from repository to open the Select Object for Step dialog 
box and expand the test object tree. Notice that this object repository has 
many more objects than the MercuryToursLogin repository because you 
did not delete extraneous objects from it in Lesson 3, “Creating Object 
Repositories.” 
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 c Select reserveFlights and click OK. 

The selected Image test object is added to the step, together with its 
default method, Click. The Documentation cell describes what the step 
does in plain English. Again, this step is displayed on three rows in the 
Keyword View because the parent test objects are part of the step.

In the Expert View, the step is displayed as follows:

 3 Save your test.

Choose File > Save or click the Save button. 

Add Steps to the BookFlight Action
In the previous section, you added a step to the SelectFlight action. If you 
were to run your test at this point, the last step would open the Book a 
Flight page in the Mercury Tours Web site. 

In “Add Steps to the FlightFinder Action” on page 63, you copied steps from 
this tutorial and pasted them in the Expert View. These steps already 
included built-in values. 

In this section, you will copy/paste steps in the Expert View that do not 
have built-in values (as if you were inserting steps directly from the object 
repository). Then you will insert values for each step using the Keyword 
View.

Finally, you will use the Step Generator to insert a single step. The Step 
Generator enables you to define an entire step in one dialog box, instead of 
inserting different parts of a step in the various columns of the Keyword 
View.

 1 Open the BookFlight action.

 a Ensure that the Test Flow pane is displayed. If you do not see the Test 
Flow pane, choose View > Test Flow or click the Test Flow Pane button to 
display it. 

 b In the Test Flow pane, double-click the BookFlight action. The BookFlight 
action opens.

Browser("Select a Flight: Mercury").Page("Select a Flight: Mercury").Image("reserveFlights").Click
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 2 Add steps to the BookFlight action.

 a Click the Expert View tab to display the Expert View.

 b Copy/paste the following steps:

 3 Fill in the missing step details.

 a Click the Keyword View tab and look at the Documentation column. 
Notice that for most of the steps, no documentation is available. This is 
because the steps you just inserted are missing values. For example, in the 
first step, a value needs to be filled in for the passenger’s first name. The 
details that you need to add are encircled in the following example. 

Browser("Book a Flight: Mercury").Page("Book a Flight: Mercury").WebEdit("passFirst0").Set
Browser("Book a Flight: Mercury").Page("Book a Flight: Mercury").WebEdit("passLast0").Set
Browser("Book a Flight: Mercury").Page("Book a Flight: Mercury").WebList("creditCard").Select
Browser("Book a Flight: Mercury").Page("Book a Flight: Mercury").WebEdit("creditnumber").Set
Browser("Book a Flight: Mercury").Page("Book a Flight: Mercury").WebList("cc_exp_dt_mn").Select
Browser("Book a Flight: Mercury").Page("Book a Flight: Mercury").WebList("cc_exp_dt_yr").Select
Browser("Book a Flight: Mercury").Page("Book a Flight: Mercury").Image("buyFlights").Click
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 b In the Value cell for the relevant step in the Keyword View, enter the 
following:

 4 Add a step using the Step Generator to confirm the booking and return to 
the Home page.

The last step in the steps you pasted clicks the SECURE PURCHASE button in 
the Book a Flight page. This opens the Flight Confirmation page in the 
Mercury Tours Web site. 

You will now use the Step Generator to define an entire step in one dialog 
box, instead of inserting different parts of a step in the various columns of 
the Keyword View, or inserting a step in the Expert View.

For: Enter:

passFirst0 Your first name (or a fictitious first name)

passLast0 Your last name (or a fictitious last name)

creditCard Any of the following credit card names:

➤ American Express

➤ Master Card

➤ Visa

➤ Discover

➤ Diners Club

➤ Carte Blanche

creditnumber Any 8-digit number. (This is a fictitious credit 
card number.)

cc_exp_dt_mn Any month from 01 to 12. (This is the month 
part of the credit card expiration date.)

cc_exp_dt_yr Any year from 2008 to 2010. (This is the year 
part of the credit card expiration date.)
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 a Click in the Item column below the last step to ensure that the next step 
will be inserted after the last existing step in this action.

 b Choose Insert > Step Generator. The Step Generator dialog box opens.
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 c Click the Browse for Object button. The Select Object for Step dialog box 
opens.
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 d Expand the Flight Confirmation: Mercury node of the tree, select the 
home Image object, and click OK. The Step Generator displays the default 
options for the home test object.

You define the arguments and values in the Step Generator just as you 
would in the Keyword View columns:

➤ You use the Category and Object boxes to define the value in the Item 
column in the Keyword View. 

➤ You use the Operation cell to define the value in the Operation 
column. In this step, the default operation for the home test object, 
Click, is displayed in the Operation box. Although you could 
potentially select a different operation for this test object by clicking 
the down arrow, Click is the operation needed for this step.
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➤ You use the Arguments box to define values for the arguments in the 
Value cell in the Keyword View. If any of the arguments were 
mandatory, a red asterisk would be displayed next to the argument 
name. In this step, there are no mandatory arguments, and you do not 
need to define any values.

➤ The Step documentation box displays the instruction for this step as it 
will be displayed in the Documentation cell of the Keyword View.

➤ If you wanted to insert another step, you could select this check box. 
(This is the only step you need in this action, so there is no need to 
select this check box.)

 e Click OK. The Step Generator closes and the step is added to the Keyword 
View. 

 f Click the Expert View tab. You can see that this same step is displayed as 
follows:

 5 Save your test.

Choose File > Save or click the Save button. 

Dividing an Action into Two Actions

Since the BookFlight action currently contains two main processes: 
purchasing a flight and returning to the Home page, it makes sense to divide 
the action into separate actions. This will enable you to create different tests 
that do not return to the Home page after purchasing flights. For example, 
you may want to create a test that books both flight reservations and hotel 
reservations, and only then returns to the Home page.

 1 Select the page where you want the second action to begin. 

 a In the Keyword View, expand the BookFlight action, if needed, by right-
clicking the BookFlight action row (the top row in the action) and 
choosing Expand Sub Tree.

 b Select the first Flight Confirmation: Mercury step to highlight it. 

Browser("Flight Confirmation: Mercury").Page("Flight Confirmation: Mercury").Image("home").Click
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 2 Split the test into two actions.

 a Choose Edit > Action > Split Action or click the Split Action button. This 
splits the current action into two actions. The new action will start on 
the Flight Confirmation: Mercury page, which is the currently selected 
step.

 b Click OK in the message box. If this reusable action was being called from 
another test, splitting it into two actions could affect that test adversely 
because some of the steps would be missing. Since you did not include a 
call to this action from any other test, you can safely split this action.

The Split Action dialog box opens.

 c In the Split Action dialog box, enter names and descriptions for the two 
actions. 

➤ In the Name box of the 1st action, leave the name as BookFlight. 
(Remove _1 from the action name.)

➤ In the Description box of the 1st action, enter: Purchases flights.
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➤ In the Name box of the 2nd action enter: FlightConfirmation

➤ In the Description box of the 2nd action, enter: Confirms purchases 
and returns to the Home page.

 d Click OK to close the Split Action dialog box and accept the other default 
selections. The two actions are displayed in the Keyword View and in the 
Test Flow pane.

 3 Save your test.

Choose File > Save or click the Save button. 

Congratulations! You have created your first test and are ready to run it.
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6
Running and Analyzing Tests

When you run your test, QuickTest opens the appropriate application and 
performs each step in the test sequentially. When QuickTest finishes 
running the test, it displays the results of the run.

This lesson includes:

 ➤  Running a Test on page 79

 ➤  Analyzing Run Results on page 81

Running a Test

In this lesson, you will run the test you prepared in the previous lesson.

 1 Start QuickTest and open the MercuryTours test.

 a If QuickTest is not currently open, open it as described in step 1 on 
page 30, making sure that only the Web Add-in is loaded.

 b Browse to and open the MercuryTours test.

 2 Confirm that all images are saved to the test results.

QuickTest allows you to determine when to save images to the test results. 
In this lesson, all images should be saved to the test results.

Choose Tools > Options or click the Options button, and then click the Run 
tab. In the Save still image captures to results option, select Always. Click 
OK to close the Options dialog box.
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 3 Start running your test.

 a Click Run or choose Automation > Run. The Run dialog box opens.

 b Select New run results folder. Accept the default results folder name.

 c Click OK to close the Run dialog box. 

Watch carefully as QuickTest opens your browser and starts running the test. 
In the browser, you can see QuickTest perform each step you inserted; a 
yellow arrow in the left margin of the Keyword View indicates the step that 
QuickTest is running.
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Analyzing Run Results

When QuickTest finishes running the test, the Test Results window opens.

Results 
Tree

Test 
Results 
Details

Iteration 
Summary

Status 
Summary
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Initially, the Test Results window contains two panes for displaying the key 
elements of your test run.

➤ The left pane displays the results tree, an icon-based view of the steps 
that were performed while the test was running. The results tree is 
organized according to the actions and the Web pages visited during the 
test run and can be expanded (+) to view each step. The steps performed 
during the test run are represented by icons in the tree. You can instruct 
QuickTest to run a test or action more than once using different sets of 
data in each run. Each test run is called an iteration, and each iteration is 
numbered. (The test you ran had only one iteration.)

➤ The right pane displays the run results details. The iteration summary 
table indicates which iterations passed and which failed. The status 
summary table indicates the number of checkpoints or reports that 
passed, failed, and raised warnings during the test.

Your test run succeeded because QuickTest was able to navigate the Mercury 
Tours site according to the steps that you added. In this section, you will 
inspect the steps QuickTest performed when running your test, and how the 
application window appeared when a step was performed.
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 1 View the results for a specific step.

In the results tree, expand (+) FlightFinder Summary > Find a Flight: 
Mercury > Find a Flight: Mercury to display all of the steps performed on the 
Flight Finder page.

Highlight fromPort:Select in the results tree.  

The Test Results window now contains three panes, displaying:

➤ the results tree, with one step highlighted

➤ the test results details of the highlighted step

➤ the still image capture pane, showing a screen capture of the Web page 
on which the step was performed 

Results 
Tree

Test 
Results 
Details

Still Image 
Capture 
Pane
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When you click a page in the results tree, QuickTest displays the 
corresponding page in the application view. When you click a step (an 
operation performed on an object) in the results tree, the corresponding 
object is highlighted in the application view. In this case, the Departing 
From text box is highlighted.

 2 Close the Test Results window.

Choose File > Exit.

You have now successfully created and run a test that reserves a flight from 
New York to San Francisco on the Mercury Tours Web site.



85

7
Creating Checkpoints and Using 
Functions

In the previous lessons, you created and ran a test checking that a series of 
steps performed on the Mercury Tours Web site runs smoothly. A checkpoint 
verifies that expected information is displayed in your application while the 
test is running.

In this lesson, you will insert checkpoints and use a function to check the 
validity of the some of the objects in the Mercury Tours application.

This lesson includes:

 ➤  Understanding Checkpoint Types on page 86

 ➤  Checking Objects on page 88

 ➤  Checking Pages on page 91

 ➤  Checking Tables on page 93

 ➤  Checking Text on page 98

 ➤  Managing Checkpoints in the Object Repository on page 102

 ➤  Running and Analyzing a Test with Checkpoints on page 103

 ➤  Performing a Check Using a Function on page 108
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Understanding Checkpoint Types

QuickTest Professional offers the following types of checkpoints:

Checkpoint 
Type

Description Example of Use

Standard 
Checkpoint 

Checks values of an object’s 
properties.

Check that a radio button is 
selected.

Image 
Checkpoint

Checks the property values of 
an image.

Check that the image source file 
is correct.

Table 
Checkpoint

Checks information in a table. Check that the value in a table 
cell is correct.

Page 
Checkpoint

Checks the characteristics of a 
Web page.

Check how long a Web page takes 
to load or if a Web page contains 
broken links.

Text 
Checkpoint

Checks that a text string is 
displayed in the appropriate 
place in a Web page or 
application.

Check whether the expected text 
string is displayed in the expected 
location in a test object.

Text Area 
Checkpoint

Checks that a text string is 
displayed within a defined area 
in a Windows-based 
application. 

Check that an area of a dialog box 
includes text that was entered in 
another part of the application.

Bitmap 
Checkpoint

Checks an area of a Web page or 
application after capturing it as 
a bitmap.

Check that a Web page (or any 
portion of it) is displayed as 
expected.

Database 
Checkpoint

Checks the contents of 
databases accessed by an 
application or Web site.

Check that the value in a 
database query is correct.
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You can add most checkpoints to your test either while inserting steps or 
while recording. The following sections explain how to create some of the 
checkpoints described above, in the test you created in “Adding Steps to the 
Login Action” on page 56.

Note: When QuickTest creates a checkpoint, it assigns a name based on 
information inside the checkpoint—the checked value, for example. The 
checkpoint name remains unchanged, even if you subsequently modify the 
information on which it was based. Keep this in mind when looking for 
checkpoints displayed in the Keyword View. However, note that QuickTest 
may shorten the name displayed in the Keyword View.

For more information on how to create checkpoints, refer to the QuickTest 
Professional User’s Guide.

Accessibility 
Checkpoint 

Identifies areas of a Web site to 
check for Section 508 
compliancy.

Check if the images on a Web 
page include ALT properties, 
required by the W3C Web 
Content Accessibility Guidelines.

XML 
Checkpoint

Checks the data content of 
XML documents.

Check the content of an element 
to make sure that its tags, 
attributes, and values have not 
changed.

Note: XML file checkpoints are 
used to check a specified XML 
file; XML application checkpoints 
are used to check an XML 
document within a Web page.

Checkpoint 
Type

Description Example of Use
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Checking Objects

In this section, you will add a standard checkpoint in the Book a Flight page. 
This checkpoint verifies the value in the box containing the first name of 
the passenger.

 1 Start QuickTest and open the MercuryTours test.

 a If QuickTest is not currently open, open it as described in step 1 on 
page 30, making sure that only the Web Add-in is loaded.

 b Browse to and open the MercuryTours test.

 2 Save the test as Checkpoint.

Choose File > Save As. Save the test as Checkpoint.

 3 Launch the Mercury Tours application.

In Microsoft Internet Explorer, enter the following URL: 
http://newtours.demoaut.com

The Mercury Tours home page opens.

 4 Display the action in which you want to add a standard checkpoint.

You want to add a checkpoint that checks the property values of the First 
Name edit box after the passenger’s name has been entered in the box.

 a Ensure that the Test Flow pane is displayed. If you do not see the Test 
Flow pane, choose View > Test Flow or click the Test Flow Pane button to 
display it. 

 b In the Test Flow pane, double-click the BookFlight action. In the Item 
column of the Keyword View, highlight the passFirst0 row.

http://newtours.demoaut.com
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 5 Create a standard checkpoint.

 a Choose Insert > Checkpoint > Standard Checkpoint. The Checkpoint 
Properties dialog box opens.

The dialog box displays the object’s properties: 

➤ The Name is the name of the object as defined in the HTML code of 
the Web page.

➤ The Class is the type of object. WebEdit indicates that the object is an 
edit box.

➤ The ABC icon in the Type column indicates that the value of the 
property is a constant.
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For each object class, QuickTest recommends default property checks. 
The table below describes the default checks for the WebEdit class.

 b In the Name box, enter CheckName as the new checkpoint name.

 c Scroll down in the object properties area and select the row containing 
the property named value. You need to enter the value that matches the 
value you entered in the actual step. To do this, click in the Constant box 
and enter the first name value.

 d In the Insert statement area of the Checkpoint Properties dialog box, 
select After current step. This inserts the checkpoint after the passFirst0 
Set... step. (This is the step in which the passenger’s first name is entered 
in the First Name box.) 

 e Accept the rest of the settings as default and click OK. QuickTest adds a 
standard checkpoint step to your test below the selected step. 

Property Value Explanation

html tag INPUT INPUT is the html tag as defined in 
the HTML source code.

innertext In this case, the value of innertext is 
empty. The checkpoint checks that 
the value is empty.

name passFirst0 passFirst0 is the name of the edit 
box.

type text text is the type of object as defined 
in the HTML source code.

value <FirstName> Currently, the value is empty. You 
need to enter the same value that 
you specified for the First Name edit 
box.
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 6 Save the test.

Choose File > Save or click the Save button. 

You can insert many checkpoints in the manner described above. Several 
special types of checkpoints are explained in the following sections.

Checking Pages

In this section, you will add a page checkpoint to your test. The page 
checkpoint checks that the number of links and images in the page when 
you run your test is the same as when QuickTest learned the objects on 
which you inserted steps in your test.

 1 Locate the page where you want to add a page checkpoint.

In the Test Flow pane, double-click the BookFlight action, if the action is not 
already open. In the Item column of the Keyword View, highlight the Book 
a Flight: Mercury row. (This is the row directly above the row displaying 
passFirst0.)
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 2 Create a page checkpoint.

 a Choose Insert > Checkpoint > Standard Checkpoint. The Page 
Checkpoint Properties dialog box opens. 

When you run the test, QuickTest checks the number of links and images 
in the page and the load time, as described in the pane at the top of the 
dialog box.

QuickTest also checks the actual target URL of each link and the actual 
source of each image.
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 b In the Name box, enter CheckLinks as the new checkpoint name.

 c Accept the rest of the settings as default and click OK.

QuickTest adds the page checkpoint to your test. Because this is the first 
operation on the Book a Flight: Mercury page, the operation is added 
directly to the existing Book a Flight: Mercury page node. It is displayed 
in the Keyword View as a checkpoint operation on the Book a Flight: 
Mercury page. 

 3 Save the test.

Choose File > Save or click the Save button.

Checking Tables

In this section, you will add a table checkpoint to check the cost of the 
outbound flight, as displayed in the Book a Flight: Mercury page.

 1 Locate the page where you want to add a table checkpoint.

 a In the Test Flow pane, double-click the BookFlight action, if the action is 
not already open. The action is displayed in the Keyword View. 

 b Highlight the passFirst0 step (the step that enters the passenger’s first 
name into the First Name edit box). 

 2 Open the Mercury Tours application to the Flight Confirmation page.

 a In the User Name and Password boxes of the Mercury Tours Web site 
(http://newtours.demoaut.com), type tutorial. (You opened the Mercury 
Tours Web site in step 3 on page 88.)

Click Sign-In. The Flight Finder page opens.

http://newtours.demoaut.com
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 b Enter flight details.

Change the following selections by choosing from the drop-down list. 
(Do not use the calendar option.)

➤ Departing From: New York

➤ On: December 29

➤ Arriving In: San Francisco

➤ Returning: December 31

Click CONTINUE to accept the other default selections. The Select Flight 
page opens.

 c In the Select Flight page, click CONTINUE to accept the default flight 
selections. The Book a Flight page opens.

 3 Configure QuickTest to record on the open browser page.

 a In QuickTest, choose Automation > Record and Run Settings. The Record 
and Run Settings dialog box opens. 
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 b Select the Record and run test on any open browser radio button and 
click OK to close the dialog box.

 4 Create a table checkpoint.

 a In the Book Flight page of the Mercury Tours Web site, under the flight 
departure date and Price, highlight 270 (the price of the fare of the first 
leg between New York and San Francisco).

 b In QuickTest, click the Record button or choose Automation > Record. 
QuickTest begins a recording session.

 c Choose Insert > Checkpoint > Standard Checkpoint. The QuickTest 
window is hidden, and the pointer changes into a pointing hand. 

 d Click the highlighted string, 270. The Object Selection – Checkpoint 
Properties dialog box opens.

Select WebTable: New York to San Francisco and click OK. 

The Table Checkpoint Properties dialog box opens, showing the rows and 
columns of the table.
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 e Enter CheckCost as the new checkpoint name in the Name box of the 
Table Checkpoint Properties dialog box.

Note that by default, check marks appear in all cells. You can double-click 
a cell to toggle the cell selection, or double-click a row or column header 
to toggle the selection for all the cells in the selected row or column.
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 f Double-click each column header to clear the check marks. Double-click 
column 3, row 3 to check the value of this cell. (QuickTest checks only 
cells containing check marks.)

Scroll through the rows and columns to make sure that only the cell in 
column 3, row 3 is checked. If any other cells are checked, select each 
checked cell and click the Remove from Check button.

Tip: You can change the column widths and row heights by dragging the 
boundaries of the column and row headers.

 g Accept the rest of the settings as default and click OK.

QuickTest adds the table checkpoint to your test. It is displayed in the 
Keyword View as a new step under the Book a Flight: Mercury page. 

 5 Stop the recording session.

Click the Stop button to stop recording.

 6 Save the test.

Choose File > Save or click the Save button. 
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 7 Leave the Mercury Tours Web site open.

In the next section, you will need to navigate to the next page in the 
Mercury Tours application—the Flight Confirmation page. Therefore, you 
may want to keep the Mercury Tours application open to the current page. 

Checking Text

In this section, you will add a text checkpoint to your test to check whether 
New York is displayed in the Flight Confirmation page.

 1 Locate the page where you want to add a text checkpoint.

 a In the Test Flow pane, double-click the FlightConfirmation action. The 
action is displayed in the Keyword View.

 b In the Keyword View, highlight the first row displaying Flight 
Confirmation: Mercury.

 2 Open the Mercury Tours application to the Flight Confirmation page.

Note: If the Mercury Tours application is already open to the Book a Flight 
page, skip to step d, below.

 a Log in to the Mercury Tours Web site: http://newtours.demoaut.com 

In the User Name and Password boxes, type tutorial. 

Click Sign-In. The Flight Finder page opens.

 b Enter flight details.

Change the following selections by choosing from the drop-down list. 
(Do not use the calendar option.)

➤ Departing From: New York

➤ On: December 29

➤ Arriving In: San Francisco

➤ Returning: December 31

http://newtours.demoaut.com
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Click CONTINUE to accept the other default selections. The Select Flight 
page opens.

 c In the Select Flight page, click CONTINUE to accept the default flight 
selections. 

 d In the Book a Flight page, click SECURE PURCHASE. The Flight 
Confirmation page opens.

 3 Configure QuickTest to record on the open browser page.

 a In QuickTest, choose Automation > Record and Run Settings. The Record 
and Run Settings dialog box opens. 

 b Confirm that the Record and run test on any open browser radio button 
is selected and click OK to close the dialog box.

 4 Create a text checkpoint.

 a In the Flight Confirmation page, under Departing, highlight the text 
New York (include the space after it).
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 b Click the Record button or choose Automation > Record. QuickTest 
begins a recording session.

 c Choose Insert > Checkpoint > Text Checkpoint. The QuickTest window is 
hidden, and the pointer changes into a pointing hand. 

 d Click the highlighted text string, New York. The Text Checkpoint 
Properties dialog box opens.
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When Checked Text appears in the list box, the Constant field displays 
the text string you highlighted. This is the text QuickTest looks for when 
running the test.

➤ In the Name box, enter CheckDepartingText as the new checkpoint 
name.

➤ Remove San Francisco from the Checkpoint Summary pane, as follows: 
Click the Configure button to open the Configure Text Selection 
dialog box. Highlight the to text string. (Do not highlight San 
Francisco). Click the Text After button. San Francisco changes from 
black to gray. Click OK to close the dialog box. San Francisco is 
removed from the text after part of the Checkpoint Summary pane.

➤ Accept the rest of the settings as default and click OK. 

QuickTest adds the text checkpoint to your test. It is displayed in the 
Keyword View as a checkpoint operation on the 
Flight Confirmation: Mercury page. 

 5 Stop the recording session.

Click the Stop button to stop recording.

 6 Make sure that the checkpoint is above the home step.

Drag the step up a row, if needed. Otherwise, during the test run, QuickTest 
will click the BACK TO HOME button before performing the checkpoint.

 7 Save the test.

Choose File > Save or click the Save button.
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Managing Checkpoints in the Object Repository

In addition to viewing checkpoints in a specific action, you can also view 
them in the object repository and modify their properties. If applicable, you 
can even use the same checkpoint in more than one location. For example, 
if you want to verify that your organization’s logo appears on every page in 
your application, you can create a checkpoint and insert it in wherever steps 
open another page. For the purposes of this tutorial, you will not be reusing 
checkpoints.

 1 Open the Object Repository window.

 a In QuickTest, choose Resources > Object Repository or click the Object 
Repository button. 

The Object Repository window opens, displaying a tree of all test objects 
and all checkpoint and output objects in the current action (including all 
local objects and all objects in any shared object repositories associated 
with the action. 
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 b Click the Action down arrow and select an action to view the associated 
test objects, checkpoint objects, and output value objects. 

 c Close the Object Repository window by clicking the X in the top-right 
corner or by choosing File > Close.

Running and Analyzing a Test with Checkpoints

In this section, you will review your test with checkpoints, run the test, and 
analyze the checkpoint results.

 1 Configure QuickTest to record on the open browser page.

 a In QuickTest, choose Automation > Record and Run Settings. The Record 
and Run Settings dialog box opens. 

 b Select the Open the following address when a record or run session 
begins radio button and click OK to close the dialog box.
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 2 Start running your test.

 a Click Run or choose Automation > Run. The Run dialog box opens.

 b Ensure that New run results folder is selected. Accept the default results 
folder name.

 c Click OK. When the test run is completed, the Test Results window 
opens.

 3 View the test results.

When QuickTest finishes running the test, the Test Results window opens. 
The test result should be Passed, indicating that all checkpoints passed. If 
one or more checkpoints had failed, the test result would be Failed.

 4 View the results of the page checkpoint.

In the results tree, expand Book a Flight: Summary and highlight 
Checkpoint "CheckLinks".

In the Details pane, you can review the details of the page checkpoint, 
which lists the items checked. 

Tip: You can drag the bottom of the Details pane to enlarge it and/or scroll 
within the pane to view all of the checkpoint details.
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The checkpoint passed because the actual values of the checked properties 
match the expected values. 
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 5 View the results of the table checkpoint.

In the results tree, Book a Flight: Mercury page, expand (+) New York to San 
Francisco.

Highlight Checkpoint "CheckCost".

In the Details pane, you can review the details of the table checkpoint. You 
can also review the values of the table cells (cell values that were checked are 
displayed in black; cell values that were not checked are displayed in gray). 
The checkpoint passed because the actual value of the checked cell matches 
the expected value.
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 6 View the results of the standard checkpoint.

In the results tree, Book a Flight: Mercury page, expand (+) passFirst0.

Highlight Checkpoint "CheckName".

In the Details pane, you can review the details of the standard checkpoint, 
which lists the properties that were checked and their values. The 
checkpoint passed because the actual values of the checked properties 
match the expected values.
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 7 View the results of the text checkpoint.

In the results tree, expand Flight Confirmation: Mercury and highlight 
Checkpoint "CheckDepartingText".

In the Details pane, you can review the details of the text checkpoint. The 
checkpoint passed because the actual text matches the expected text.

 8 Close the Test Results window.

Choose File > Exit.

Performing a Check Using a Function

In the previous sections, you used checkpoints to check various objects in 
the Mercury Tours application. Now you will use the function you created in 
Lesson 4, “Creating Functions and Function Libraries” to check the date 
format of a Web element in the SelectFlight action.

 1 Start QuickTest and open the Checkpoint test.

 a If QuickTest is not currently open, open it as described in step 1 on 
page 30, making sure that only the Web Add-in is loaded.

 b Browse to and open the Checkpoint test.
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 2 Save the test as Function.

Choose File > Save As. Save the test as Function.

 3 Display the Select Flight page in The Mercury Tours Web site.

 a Log in to the Mercury Tours Web site: http://newtours.demoaut.com 

In the User Name and Password boxes, type tutorial. 

Click Sign-In. The Flight Finder page opens.

 b Enter flight details.

Change the following selections by choosing from the drop-down list. 
(Do not use the calendar option.)

➤ Departing From: New York

➤ On: December 29

➤ Arriving In: San Francisco

➤ Returning: December 31

Click CONTINUE to accept the other default selections. The Select Flight 
page opens. Notice the date displayed in the DEPART area. The date is in 
MM/DD/YYYY format.

http://newtours.demoaut.com
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 4 In QuickTest, display the action in which you want to add a function.

You want to add a function that checks the innertext property values of the 
date displayed in the SelectFlight action.

In the Test Flow pane, double-click the SelectFlight action. 

 5 Paste the following in the Expert View.

Click the Expert View tab and paste the following before the existing step. 
(You want the function to run before QuickTest navigates to the next page 
in the application.)

Important: In the PDF version of this tutorial, the first line of the code 
breaks across two lines. If you are copying and pasting from the PDF, make 
sure to remove the line break after the word Flight: so that the first line of 
the code begins with departureDate and ends with ("innertext"). (The Page 
part should be displayed as: Page("Select a Flight: Mercury") with a single 
space between Flight: and Mercury.)

These steps use the check_data_validity function defined in the associated 
function library. You created this function library in Lesson 4, “Creating 
Functions and Function Libraries.”

departureDate=Browser("Select a Flight: Mercury").Page("Select a Flight: 
Mercury").WebElement("12/29/2007").GetROProperty("innertext")

if  check_data_validity(  departureDate ) then
reporter.ReportEvent micPass, "Date is valid" , departureDate

end if 
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 6 Look at these steps in the Keyword View.

Click the Keyword View tab. (The highlighted step is not part of the 
function—it is the step that navigates to the next page in the Mercury Tours 
application.) 

 7 Save your test.

Choose File > Save or click the Save button. 

 8 Start running your test.

 a Click Run or choose Automation > Run. The Run dialog box opens.

 b Ensure that New run results folder is selected. Accept the default results 
folder name.

 c Click OK. When the test run is completed, the Test Results window 
opens.
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 9 View the test results.

The test result should be Passed, indicating that the function passed because 
the date is displayed in the expected format, and it contains acceptable 
values.
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8
Parameterizing Tests

When you test your applications, you may want to check how the 
application performs the same operations with multiple sets of data. For 
example, suppose you want to check how your Web site responds to ten 
separate sets of data. You could create ten separate tests, each with its own 
set of data. Alternatively, you can create Data Table parameters so that your 
test runs ten times, each time using a different set of data.

This lesson includes:

 ➤  Defining a Data Table Parameter on page 113

 ➤  Adding Parameter Values to a Data Table on page 116

 ➤  Modifying Steps Affected by Parameterization on page 117

 ➤  Parameterizing an Action on page 119

 ➤  Running and Analyzing a Parameterized Test on page 123

Defining a Data Table Parameter

In the previous lessons, you reserved a flight from New York to San 
Francisco. New York is a constant value, which means that New York is the 
departure city each time you run the test. In this exercise you will make the 
departure city a parameter so that you can use a different departure city for 
each test run.

 1 Start QuickTest and open the Checkpoint test.

 a If QuickTest is not currently open, open it as described in step 1 on 
page 30, making sure that only the Web Add-in is loaded.

 b Browse to and open the Checkpoint test.
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 2 Save the test as Parameter.

Choose File > Save As. Save the test as Parameter.

 3 Confirm that the Data Table option is enabled.

If you do not see the Data Table at the bottom of the QuickTest window, 
click the Data Table button, or choose View > Data Table. 

 4 Open the FlightFinder action.

 a Ensure that the Test Flow pane is displayed. If you do not see the Test 
Flow pane, choose View > Test Flow or click the Test Flow Pane button to 
display it. 

 b In the Test Flow pane, double-click the FlightFinder action. The 
FlightFinder action opens.

 5 Select the text to parameterize.

In the fromPort row in the Keyword View, click the Value cell and then click 
the parameterization icon . 

The Value Configuration Options dialog box opens.
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 6 Set the parameterization properties.

 a Select the Parameter radio button. This lets you replace the constant 
value (New York) with a parameter.

 b Confirm that the DataTable option is selected. This means that the value 
of the parameter will be taken from the QuickTest Data Table. The Name 
box is enabled and displays p_Item. Delete this and enter departure.

Click OK to close the dialog box. QuickTest adds the departure parameter 
to the Data Table as a new column and inserts New York in the first row 
under it. 

New York will be the first of several departure cities that QuickTest will 
use during test runs of the application.  

New 
Column in 
Data Table
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Note the change in the step’s appearance in the Keyword View. 
Previously, the step was displayed as fromPort Select New York. Now, 
when you click the Value cell, the following information is displayed, 
indicating that the value is parameterized using a Data Table parameter 
called departure:

When you click any other cell, the step is displayed as: 

Adding Parameter Values to a Data Table

As you saw, QuickTest displays parameter values in the Data Table. In this 
section, you will add another departure city to the Data Table (in the 
FlightFinder action of the Parameter test), so that QuickTest can test the 
application with this data.

 1 Enter an additional city in the departure column.

 a Click row 2 in the departure column and enter London.

 b Press Enter.

 2 Save the test.

Choose File > Save or click the Save button. 
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Modifying Steps Affected by Parameterization

After parameterizing one step in a test, other test objects might be affected 
when the value of the parameterized step changes. If so, you must modify 
the expected values of those objects to match the value resulting from the 
parameterized step. In this section, you will modify the text checkpoint so 
that when running the test, QuickTest checks for the text that matches the 
current departure city.

 1 Locate the text checkpoint to modify.

In the FlightConfirmation action, right-click Flight Confirmation: Mercury 
row with the existing checkpoint and select Checkpoint Properties. The Text 
Checkpoint Properties dialog box opens.
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 2 Parameterize the text checkpoint.

In the Checked Text area, New York is displayed in the Constant box. New 
York is the expected value for the checkpoint for every iteration. 

 a Select Parameter and click the Parameter Options button. The Parameter 
Options dialog box opens.

 b In the Name box, select departure. This instructs the checkpoint to use 
the departure parameter values in the Data Table for the expected results.

 c Click OK to close the Parameter Options dialog box, and then click OK 
again to close the Text Checkpoint Properties dialog box. The checkpoint 
is now parameterized.

 3 Save the test.

Choose File > Save or click the Save button.
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Parameterizing an Action

QuickTest enables you to insert various types of parameters. This tutorial 
introduces you to Data Table parameters. For information on other types of 
parameters, see the QuickTest Professional User’s Guide.

If you look at the Data Table at the bottom of the QuickTest window in the 
any test, you will see a tab for each action plus a Global tab. 

Note: If the Data Table is not displayed, choose View > Data Table to 
display it, or click the Data Table button.

The Global tab is a data sheet whose data is used for the entire test. If five 
rows of data are displayed in the Global table, the test will run five times 
(five full iterations). In addition, you can create data sets for each action, 
using the relevant action sheet. If you parameterize a step using a Data Table 
parameter from a local action sheet and enter five rows of data in that sheet, 
you can define that action to run five times within one test iteration. 

In this section, you will create a data set for the FlightFinder action to check 
how the application handles multiple orders during a single user session.

 1 Open the FlightFinder action.

In the Test Flow pane, double-click the FlightFinder action. The FlightFinder 
action opens.
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 2 Select a step to parameterize.

In the toPort row in the Keyword View, click the Value cell and then click 
the parameterization icon . The Value Configuration Options dialog box 
opens.

 3 Enter the parameter information.

 a Select Parameter and confirm that the DataTable option is selected.

 b In the Name box, type arrival.

 c Select Global sheet because you want the iteration to run on the test and 
not on the action. 

 d Click OK to close the Value Configuration Options dialog box.

QuickTest automatically adds the arrival column to the Global data sheet 
and inserts San Francisco into the first cell of the arrival column. 
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 4 Parameterize additional steps.

It is not logical for a single customer to fly to two different locations on the 
same dates, so it makes sense to parameterize the departure and arrival 
dates.

 a In the fromMonth row in the Keyword View, click the Value cell and 
then click the parameterization icon . The Value Configuration 
Options dialog box opens. 

Select Parameter and confirm that the DataTable option is selected. 
Then, in the Name box, type fromMonth. Select Global sheet in the Value 
Configuration Options dialog box and click OK to close the Value 
Configuration Options dialog box.

The third column of the Global sheet of the Data Table displays your 
changes.

 b In the toMonth row in the Keyword View, click the Value cell and then 
click the parameterization icon . The Value Configuration Options 
dialog box opens. 

Select Parameter and confirm that the DataTable option is selected. In 
the Name box type toMonth. Select Global sheet in the Value 
Configuration Options dialog box and click OK to close the Value 
Configuration Options dialog box. The fourth column of the Global 
sheet of the Data Table displays your changes.
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 5 Enter the parameterization data in the Data Table.

 a In the Data Table, click the Global tab.

 b Type Portland in the second row of the arrival column. 

 c Type October in the second row of the fromMonth and toMonth 
columns.

 d Click an empty cell of the first or second row to save your changes.

The Data Table should appear similar to the following:

 6 Save the test.

Choose File > Save or click the Save button.

You have now created a test that signs in to the Mercury Tours site, submits 
two flight orders: a flight from New York to San Francisco from 
December 29 to December 31, and a flight from London to Portland from 
October 29 to October 31, and then returns to the starting point of the test 
by clicking the Home link.



Lesson 8 • Parameterizing Tests

123

Running and Analyzing a Parameterized Test

You will now run the modified Parameter test. QuickTest will run the test 
twice, once for each departure city in the Data Table. Each test run is called 
an iteration.

 1 Run the Parameter test.

 a Click Run on the Automation toolbar or choose Automation > Run. The 
Run dialog box opens. 

 b Select New run results folder and accept the default results folder name.

 c Click OK. When the test run is completed, the Test Results window 
opens.

 2 Examine the results summary.

The Test Results window shows that the iterations of the test passed. Drill 
down in the results tree to view the various results. 
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 3 Close the Test Results window.

Choose File > Exit to close the Test Results window.
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9
Where Do You Go from Here?

Now that you have completed the exercises in this tutorial, you are ready to 
apply the QuickTest concepts and the skills you learned to testing your own 
application.

This lesson includes:

 ➤  Testing Your Own Application—Getting Started on page 125

Testing Your Own Application—Getting Started

In this tutorial, you learned about the basic tools needed for testing 
applications and Web sites. 

We suggest that you follow the procedure outlined below when testing your 
own application.

 1 Analyze your application.

Determine the development environment to load the relevant QuickTest 
add-ins and provide support for the objects in your application. 

Determine the business processes that users will perform and plan your tests 
and actions accordingly.

Decide how to organize your test. Consider what users will want to 
accomplish when deciding which operations to include. Confirm that your 
application and QuickTest are set to match the needs of your test.

At this stage, you can already begin creating the skeletal tests and actions 
that you will use when testing your application.
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 2 Prepare your testing infrastructure.

Decide how to store the objects in your test. You can store the objects for 
each action in its corresponding local object repository, or you can store the 
objects for each action in one or more common (shared) object repositories. 
You can also use the same shared object repository for multiple actions.

If you are new to testing, you may want to use a local object repository for 
each action. This is the default setting, and all objects are automatically 
added to the local repository of each action.

If you are familiar with testing, it is probably most efficient to work in the 
shared object repository mode. In this mode, you can use shared object 
repositories for one or more actions. This means that object information is 
kept in one central location. When the objects in your application change, 
you can update them in one location for multiple actions in multiple tests. 
Although not discussed in this tutorial, you can export test objects from a 
local object repository to a shared object repository, and you can merge 
object repositories.

You may also want to create function libraries to enhance QuickTest 
functionality.

For more information, see the HP QuickTest Professional User’s Guide.

 3 Build your test. 

While you create your test steps (described in Lesson 5, “Creating a Test”), 
follow the steps you expect users to perform as they navigate within your 
application.

 4 Enhance your test.

➤ Add checkpoints (described in “Creating Checkpoints and Using 
Functions” on page 85) to search for specific values of a page, object, text 
string, or table.

➤ Replace fixed values in your test with parameters (described in 
“Parameterizing Tests” on page 113) to check how your application 
performs the same operations with multiple sets of data. 

You can further enhance your test with programming and conditional and 
loop statements, which add logic to your test. These are described in the 
HP QuickTest Professional User’s Guide.
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 5 Debug your test.

Debug your test to check that it operates smoothly and without 
interruption. For additional information on debugging, see the HP QuickTest 
Professional User’s Guide.

 6 Run your test.

Run your test on your application (described in “Running and Analyzing 
Tests” on page 79) to check that the application functions as expected.

 7 Analyze the test results.

Examine the results of your test to pinpoint defects in your application. 
(Refer to the appropriate sections of this tutorial to understand what to look 
for in the test results.)

 8 Report defects.

If you have Quality Center installed, you can submit any defects discovered 
to a Quality Center database. (Quality Center is the HP solution for test 
management. For additional information, refer to the HP QuickTest 
Professional User’s Guide and the documentation included with Quality 
Center.)
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