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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
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Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.
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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.

The following table indicates changes made to this document since the last released edition.  

Chapter Changes

Chapter 1 Minor updates and added section about enhancements in version 1.1.

Chapter 3 Minor updates.

Chapter 4 Added LIR configuration procedure.

Appendix A Added version history appendix.
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Support

You can visit the HP software support web site at:

http://support.openview.hp.com/support.jsp 

HP Software online support provides an efficient way to access interactive technical support tools. As a valued 
support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels and HP Passport, go to:

http://support.openview.hp.com/new_access_levels.jsp 
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1 Overview
This chapter covers the following topics:

• Performance Insight and NNM Events

• Recent Enhancements

• Folders and Reports

• Options for Customizing Reports

• Sources for Additional Information

Performance Insight and NNM Events

Performance Insight collects data from many sources, performs in-depth trend analysis, 
maintains performance baselines, and provides users with convenient, web-based reporting. 
Following is a partial list of product features:

• Distributed architecture

• Easy to scale (supports data collection from thousands of agents)

• CODA/OVPA agent support

• Multi-company security model

• Data warehousing

• Near Real Time reporting

• Forecasting 

• Multiple aggregations (by day, week, month; by location, by customer)

• Thresholding and alerting

• Bottlenecks easy to spot; capacity trends easy to assess

• Accurate and timely documentation for management

Network Node Manager 7.5x defines an event using the following attributes:

• Category

• Severity

• Device

• Device Type

• Vendor 

• Customer
7



The NNM Event and Availability Report Pack uses a built-in datapipe to collect event and 
downtime data from NNM. The report pack processes collected data (summarizations and 
aggregations) and displays the results in report templates. Use the reports to:

• See whether availability for a particular device is improving or worsening

• See whether availability for a particular customer is improving or worsening

• Look at the distribution of alarms across alarm categories

• See the trend line for each alarm category

• Look at the distribution of severity levels

• See the trend line for each severity level

• Find out which devices are responsible for the majority of alarms in each alarm category

Recent Enhancements

The enhancements in version 1.2 are spelled out in the following table.

For details about the enhancements to previous releases, see Appendix A, Version History.

Folders and Reports

When you install NNM Event and Availability, OVPI creates the NNM_Report directory. This 
directory has two child directories: 

• Availability

• Event

The Availability directory contains six reports:

• Detailed Availability

• Availability Forecast by Customer

• Availability Forecast by Vendor

• Availability SLA 

• Detailed Availability on Station Level

• Detailed Availability on Node Level

New in Version 1.2

Features • Node-level drill-down
• NNM 8.0 integration
• Station Version field in the Add or Update NNM List form 

Reports • Detailed Availability - Station Level
• Detailed Availability - Node Level

Upgrade package • UPGRADE_NNM_Event_to_12
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The Event directory contains multiple subdirectories:

• General

• Category

• Severity

• Consolidated 

General (7)

The General directory contains:

• Event Summary by Customer

• Event Summary by Device Type

• Event Summary by NNM Station

• Event Summary by Vendor

• Event Summary by Customer

• Executive Summary by Vendor

• Forecast by Category

Category (4)

The Category directory contains:

• NNM Event Summary by Category and Device 

• NNM Event Summary by Category and Device Type

• NNM Event Summary by Category and Severity

• NNM Event Summary by Category and Vendor

Severity (4)

The Severity directory contains: 

• NNM Events by Severity and Category

• NNM Event Summary by Severity and Device 

• NNM Event Summary by Severity and Device Type

• NNM Event Summary by Severity and Vendor

Consolidated (5)

The Consolidated directory contains:

• NNM Events by Category 

• NNM Events by Severity

• Executive Summary by Category 

• Executive Summary by Severity 

• Hot Spot Report
Overview 9



Options for Customizing Reports

You can customize reports by importing customer names, by applying group filters, by editing 
parameters (applying constraints), and by editing tables and graphs. While group filters 
appeal to service providers, or any organization that wants to share reports with customers, 
editing a table, graph, or parameter is something any user can do.

Group Filters

If you want to share reports with your customers, you have to configure OVPI to produce 
customer-specific reports. Here is an overview of the steps involved:

• Use Common Property Tables to import customer names and device locations

• Create a group account for all the users affiliated with each customer

• Create a group filter for each group account

For more information about group filters, refer to the OVPI Administration Guide. 

Editing Parameters

Editing a parameter applies a constraint to the reports. The constraint eliminates data you 
are not interested in seeing. The NNM Event and Availability Report Pack supports the 
following parameters: 

• Category

• Category ID

• Customer

• Customer ID

• Device

• Device Type

• NNM Station

• Severity

• Severity ID

• Vendor

If you are using Report Viewer, follow these steps to edit a parameter:

1 Select Edit  Parameter Values from the menu bar.

2 When the Modify Parameter Values window appears, click the Current Value field.

3 Enter a new value.

4 Click OK.

If you are using the Web Access Server, follow these steps:

1 Click the Edit icon at the bottom right-hand corner of the report.

2 When the Edit Parameters window opens, type the constraint in the appropriate field.

3 Click Submit.
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Sources for Additional Information

The demo package for the NNM Event and Availability Report Pack contains a sample of every 
report in the package. If you have access to the demo package and you want to see what fully 
populated reports look like, install the demo package. For information regarding the latest 
enhancements to this package, and any known issues affecting this package, refer to the NNM 
Event and Availability Report Pack 1.2 Release Notes. You may also be interested in the 
following documents: 

• Common Property Tables User Guide

• Reporting and Data Analysis with Network Node Manager

• Managing Your Network with HP Software Network Node Manager

• NNM/Performance Insight Integration Guide

• PI Report Packs, CD-ROM Release Notes, October 2007

You can download the documents listed above from this site:

http://ovweb.external.hp.com/lpe/doc_serv/ 

The user guides for PI are listed under Performance Insight. The user guides for report packs 
and datapipes are listed under Performance Insight Report Packs. Each user guide indicates a 
date and if the manual is revised and reposted, the date will change. We post revised manuals 
on a regular basis, so be sure to download the web edition if the web edition is more current 
that your PDF.
Overview 11
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2 The Upgrade Install
This chapter covers the following topics: 

• Guidelines for a Smooth Upgrade

• Upgrading to Version 1.2

• Package Removal

If you are installing the NNM Event and Availability Report Pack for the first time, this 
chapter does not apply to you. See Chapter 3, The New Install.

Guidelines for a Smooth Upgrade

When you insert the report pack CD in the CD-ROM drive and launch the package extraction 
program, the install script extracts every package from the CD and copies the results to the 
Packages directory on your system. When the extract finishes, the install script prompts you 
to launch Performance Insight and start Package Manager. Before running Package Manager, 
review the following guidelines:

• Prerequisites for the NNM Event and Availability Report Pack

• Upgrading Common Property Tables

• Upgrading NNM Event and Availability in a Distributed Environment

Prerequisites for the NNM Event and Availability Report Pack

Make sure the following software is installed before upgrading:

• Performance Insight 5.3

• All service packs available for PI 5.3

• Common Property Tables 3.7

Upgrading Common Property Tables

If you are running an older version of Common Property Tables, you must upgrade that 
package to version 3.7 or higher. If you are not running any version of Common Property 
Tables, Package Manager will install the latest version of Common Property Tables for you, 
automatically.

Do not install an upgrade for Common Property Tables and other packages at the same time. 
Install the upgrade package for Common Property Tables and only the upgrade package for 
Common Property Tables. For more information about installing and using Common Property 
Tables, refer to the Common Property Tables User Guide.
  13



Upgrading NNM Event and Availability in a Distributed Environment

Following is an overview of the upgrade procedure in a distributed environment:

1 Disable trendcopy on the central server.

2 For the central server:

• Upgrade to Common Property Tables 3.7; deploy reports

• Upgrade to NNM Event and Availability 1.2; deploy reports

3 For each satellite server:

• Upgrade to Common Property Tables 3.7 or higher

• Upgrade to NNM Event and Availability 1.2 

4 Re-enable trendcopy on the central server.

5 Reconfigure central and satellite servers. For details, see Chapter 4, Setting Up a 
Distributed System.

Upgrading to Version 1.2

Perform the following tasks to upgrade to version 1.2:

• Task 1: Stop OVPI Timer and extract packages from the report pack CD

• Task 2: Upgrade to Common Property Tables 3.6

• Task 3: Install the Upgrade Packages

• Task 4: Restart OVPI Timer

Task 1: Stop OVPI Timer and extract packages from the report pack CD

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

On Windows, do the following:

a Select Control Panel > Administrative Tools > Services.

b Select OVPI Timer from the list of services.

c From the Action menu, select Stop.

On UNIX, as root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the report pack CD in the CD-ROM drive. On Windows, a Main Menu opens 
automatically; on UNIX, mount the CD if the CD does not mount automatically, navigate 
to the top level directory on the CD, and run the ./setup command. 

4 Type 1 in the choice field and press Enter. The install script displays a percentage complete 
bar. When the copy is complete, the install script starts Package Manager. The Package 
Manager welcome window opens.
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If you navigate to the Packages directory on your system, you will see the following folders 
under the NNM_Event folder:

• NNM_Event.ap

• NNM_Event_Demo.ap

• UPGRADE_NNM_Event_to_12.ap

Task 2: Upgrade to Common Property Tables 3.6

Follow these rules:

• Do not install any other package with the CPT upgrade package; install the CPT upgrade 
package and only the CPT upgrade package. 

• When prompted to accept or disable the option to Deploy Reports, accept the default. If 
you do not deploy reports, you will not deploy the change forms that come with Common 
Property Tables.

• When the install finishes, click Done to return to the Management Console.

If you need more help with this task, refer to the Common Property Tables User Guide.

Task 3: Install the Upgrade Packages

1 From the Management Console, select Tools > Package Manager. The Package Manager 
welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. 

4 Click Next. The Report Deployment window opens. Accept the defaults for Deploy Reports, 
Application Server, and Port. Type your user name and password for the OVPI 
Application Server. 

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following packages:

UPGRADE_NNM_Event_to_12

NNM_Event_Demo 1.2 

7 Click Next. The Type Discovery window opens. Disable the default.

8 Click Next. The Selection Summary window opens

9 Click Install. The Installation Progress window opens and the install begins. When the 
install finishes, a package install complete message appears. 

10 Click Done. 

Task 4: Restart OVPI Timer 

On Windows, do the following:

a Select Control Panel > Administrative Tools > Services.

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

Do not be surprised if the UPGRADE package you just installed disappears from 
view. Package Manager will display what you just installed as NNM Event and 
Availability Report Pack 1.2. This is not an error.
The Upgrade Install 15



On UNIX, as root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Package Removal 

Follow these steps to uninstall NNM Event and Availability:

1 Log in to the system. On UNIX systems, log in as trendadm.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Control Panel > Administrative Tools > Services

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. The Package Manager welcome window opens.

4 Click Next. The Package Location window opens.

5 Click the Uninstall radio button.

6 Click Next. The Report Undeployment window opens.

7 If NNM Event and Availability reports were deployed from this server, accept the defaults 
for Undeploy Reports, Application Server Name, and Port. Otherwise, clear the check box 
and skip to step 9.

8 Type your username and password for the OVPI Application Server.

9 Click Next. The Package Selection window opens.

10 Click the check box next to the following packages:

NNM_Event 1.2

NNM_Event_Demo 1.2

11 Click OK.

12 Click Next. The Selection Summary window opens. 

13 Click Uninstall. The Progress window opens and the removal process begins. When the 
uninstall process is complete, a package removal complete message appears. 

14 Click Done to return to the Management Console.

15 Restart OVPI Timer.

Windows: do the following:

a Select Control Panel > Administrative Tools > Services.

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

UNIX: as root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
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3 The New Install
This chapter covers the following topics: 

• Prerequisites

• Installing NNM Event and Availability

• Accessing Deployed Reports

• Package Removal

Prerequisites

You cannot use the NNM Event and Availability Report Pack unless your NNM server and 
your PI server are integrated. If your servers are not yet integrated, you need to do this now. 
Refer to the NNM/PI Integration Guide for more information about enabling integration on 
the NNM server and running the Integration Wizard on the PI server.

The following software that must be running on your OVPI server before installing the NNM 
Event and Availability Report Pack:

• Performance Insight 5.3

• Any and all Service Packs available for PI 5.3

• Common Property Tables 3.7

Installing NNM Event and Availability

Perform the following tasks to install the report pack: 

• Task 1: Stop OVPI Time and extract report packs from the report pack CD

• Task 2: If necessary, upgrade Common Property Tables

• Task 3: Install the NNM Event and Availability Report Pack

Task 1: Stop OVPI Timer and extract packages from the report pack CD

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Control Panel > Administrative Tools > Services

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop
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3 Insert the report pack CD in the CD-ROM drive. Do one of the following:

• On Windows, run the setup.bat command if auto run is disabled. If outrun is 
enabled, a Main Menu appears. 

• On UNIX, mount the CD manually if the CD does not mount automatically, then run 
the setup command.

4 Type 1 to select OVPI report packs in the choice field and press Enter. The install script 
displays a percentage complete bar. When extraction is complete, the install script starts 
Package Manager. The Package Manager Welcome window opens.

Task 2: Upgrade Common Property Tables 

If you are running an older version of Common Property Tables, upgrade to Common Property 
Tables 3.7. If you are not running any version of Common Property Tables, skip this task.

Installing the Common Property Tables upgrade package is no different from installing other 
upgrade packages; however, do not install this upgrade package and other packages at the 
same time. Install the Common Property Tables upgrade package and only the Common 
Property Tables upgrade package. When the installation is complete, click Done to return to 
the Management Console. 

Task 3: Installing NNM Event and Availability Report Pack 

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. Approve the default installation directory or use the browse feature to select 
a different directory, if necessary. 

4 Click Next. The Report Deployment window opens. Accept the default settings for Deploy 
Reports; also accept the defaults for application server name and port in the same window. 

5 Enter your username and password for the OVPI Application Server. 

6 Click Next. The Package Selection window opens. 

7 Select the check box next to the following packages:

Common Property Tables 3.7 (if not already installed)

NNM Event 1.2 

NNM Event Demo 1.2

8 Click Next. The Type Discovery window opens. 

9 To run Type Discovery immediately after package installation, unselect Type Discovery 
and click Next. The Selection Summary window opens.

10 Click Install. The Installation Progress window opens and the install process begins. When 
the install process is complete, an installation complete message appears. 

11 Click Done. 

If you navigate to the Packages directory on your system, you will see the following 
directories under the parent directory for the report pack:
• NNM_Event.ap
• NNM_Event_Demo.ap

Installing the demo package is optional. You may install the demo package by 
itself, or you may install the demo package along with the report pack.
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12 Restart OVPI Timer.

Windows: do the following:

a Select Control Panel > Administrative Tools > Services.

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

UNIX: as root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Accessing Deployed Reports

When you installed the report pack, you enabled the Deploy Reports option. As a result, the 
reports in this package (as well as any forms that come with it) were deployed to the PI 
Application Server. Once reports reside on the PI Application Server, you have two ways to 
view them:

• PI client applications

• Web browser

If the client applications are installed on your system, you have access to Report Viewer, 
Report Builder, and the Management Console. If you don’t have the clients, use a web browser 
to reach the Web Access Server.

For more information about the clients, refer to the PI Installation Guide. For details about 
the Management Console, including how to use the Object/Property Management view to 
launch reports specific to a selected object, refer to the PI Administration Guide.

Package Removal 

Follow these steps to uninstall NNM Event and Availability:

1 Log in to the system. On UNIX systems, log in as trendadm.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Control Panel > Administrative Tools > Services

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. The Package Manager welcome window opens.

4 Click Next. The Package Location window opens.

5 Click the Uninstall radio button.

6 Click Next. The Report Undeployment window opens.
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7 If NNM Event and Availability reports were deployed from this server, accept the defaults 
for Undeploy Reports, Application Server Name, and Port. Otherwise, clear the check box 
and skip to step 9.

8 Type your username and password for the OVPI Application Server.

9 Click Next. The Package Selection window opens.

10 Click the check box next to the following packages:

NNM_Event 1.2

NNM_Event_Demo 1.2 

11 Click OK.

12 Click Next. The Selection Summary window opens. 

13 Click Uninstall. The Progress window opens and the removal process begins. When the 
uninstall process is complete, a package removal complete message appears. 

14 Click Done to return to the Management Console.

15 Restart OVPI Timer.

Windows: do the following:

a Select Control Panel > Administrative Tools > Services.

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

UNIX: as root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
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4 Setting Up a Distributed System
These are the steps to follow when setting up a distributed system:

• Decide whether or not you want local reporting

• Install the right set of packages on each server (a central server that is not polling will not 
need datapipes; the satellite servers will need datapipes)

• Verify that the system clocks in your environment are synchronized

• Register your satellite servers

• If you are not copying rate data to the central server, enable LIR on the central server

• If you enable LIR, add LIR mapping with the time type set to rate

• Verify that you have all the copy policies you need

• Configure the central server (manual edits to trendtimer.sched and .pro files)

• Configure each satellite server (manual edits to trendtimer.sched and .pro files)

If you want to set up a distributed system, you can implement local reporting or you can 
implement centralized reporting. If you want local reporting, you need to deploy reports when 
you install the report pack on each satellite server, and you need to allow summarizations to 
run on each satellite server. If you do not want local reporting, then you do not need to deploy 
reports when you install a report pack on a satellite server and you can disable the scripts 
that run summarizations on each satellite server.

Before Location Independent Reporting (LIR) was available, our recommendation to anyone 
setting up a distributed system was to deploy reports on satellite servers, keep rate data on 
satellite servers, copy hourly data to the central server, and disable summarizations above the 
hourly level on satellite servers. The advantage to this approach was that it kept a large 
volume of rate data off the network and it decreased the processing load on the central server. 
The disadvantage is that the central server could not display a Near Real Time (NRT) report. 
The only NRT report was a local NRT report, on a satellite server. LIR overcomes this 
disadvantage. If you enable LIR, you can open an NRT report on the central server and 
drill-down on table selections. The selections you make cause the central server to query a 
satellite server for locally aggregated data. Of course, if you would rather copy rate data to the 
central server, you can. If you do that, then enabling LIR is not necessary.

NNM Event and several other report packs in the October 2007 have a new copy policy import 
file. When you install NNM Event, PI uses this file to generate copy policies. As a result, you 
do not need to use the Management Console to create copy policies yourself. Instead, your only 
task is to verify that the copy policies you need already exist. 

Because you are likely to have multiple satellite servers, we designed the hourly process files 
to be satellite-server friendly. This means that most of the time, most of the defaults are 
correct. But some defaults will be incorrect, or less than optimal, and so to improve 
performance you should change them. These manual edits, as well as the other steps listed 
above, are spelled out in detail below.
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Configuring the Central Server

To configure the central server, perform the following tasks:

• Task 1: Register the satellite server by setting the database role

• Task 2: If you are not copying rate data to the central server, enable LIR

• Task 3: If you enable LIR, add LIR mappings

• Task 4: Verify the automatically generated copy policies

• Task 5: Modify the hourly_NNM_Event.pro file

• Task 6: Modify the hourly_NNM_Avail.pro file

Task 1: Register the satellite server by setting the database role

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the database system.

4 Click Database Properties.

5 From the Database Role list, select the Satellite Server role.

6 Enter any information necessary to configure the Satellite Server role.

Task 2: Enable LIR

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the central server.

4 Click LIR Configuration.

5 Select the LIR enabled check box.

Task 3: Add LIR mappings

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the central server.

4 Click LIR Configuration.

5 Click Add Mapping.

6 From the Select Satellite Server list, select a satellite server to which to add a mapping.

7 Select the Category data table option.

8 Select NNM_Event from the drop down list.

9 Select the rate data type.

10 Click Add to List.

To add a new database reference, you can use the Add Database Reference Wizard in the 
System and Network Administration application.
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11 If you want to add additional LIR mappings, click Add to list and repeat step 6 through 
step 10.

12 Click OK.

13 Click Apply.

A copy policy is automatically generated for the hourly data and for each LIR mapping that 
you add. The data type selected when adding an LIR mapping (in step 9 above) determines 
the type of data copied (defined in the generated copy policy). The type of data copied (defined 
in the generated copy policy) is one summarization level greater than the data type selected in 
the LIR mapping. For example, if you select an hourly data type, you will generate a daily 
data copy policy.

Task 4: Verify the automatically generated copy policies

Verify that a copy policy has been generated for the following tables and that the copy type is 
set correctly (to Property and Data):

1 Start the Management Console (log on with Administrator privileges).

2 Click the Copy Policy icon in the navigation pane to start the Copy Policy Manager.

3 Find the following tables and verify the copy type is set to Property and Data for each 
table:

• SH_NNM_Event

• SH_NNM_Avail

• RVNNM_Avail 

A copy policy is required for RVVNNM_Avail only if the cust_id, make, and node_type 
variables are unique on each satellite server; if these variables are not unique and a copy 
policy exists for this table, delete the copy policy.

If a copy policy has not been generated for a table, do the following:

1 Click the New Copy Policy icon or select File > New Copy Policy from the Copy Policy 
Manager. The Copy Policy Wizard displays.

2 Click Next. The Satellite Server and Copy Policy Selection Page displays.

3 Select a satellite server from the pull down list. This is the satellite server from which 
data is copied to the central server.

4 Select Single Table and select the table from the pull down list.

5 Click Next. The Copy Type Selection Page displays.

6 Select Property and Data.

7 Click Next. The Summary page displays.

8 Verify the information in the summary window. If the information is not correct, you can 
modify it by clicking Back.

9 Click Finish.

10 Repeat step 4 - step 9 for all missing tables.

If the copy type is not set to Property and Data, do the following:

1 Double-click the copy policy.

2 Select the Property and Data copy type.

3 Click OK.
Setting Up a Distributed System 23



Task 5: Modify the hourly_NNM_Event.pro file

1 Navigate to:

{DPIPE_HOME}/scripts/ 

where {DPIPE_HOME} is the directory in which OVPI is installed.

2 Open the file.

3 Comment out block0 if this server is a non-collecting central server

Task 6: Modify the hourly_NNM_Avail.pro file

1 Navigate to:

{DPIPE_HOME}/scripts/ 

where {DPIPE_HOME} is the directory in which OVPI is installed.

2 Open the file.

3 Comment out the following line in block1:

{DPIPE_HOME}/bin/trend_sum -f {DPIPE_HOME}/scripts/hourly_NNM_Avail.sum

4 If you did NOT configure a copy policy for the RVNNM_Avail table (refer to task 5), 
comment out the following line in block1:

{DPIPE_HOME}/bin/trend_sum -f {DPIPE_HOME}/scripts/
hourly_NNM_Avail_allnnm.sum

Configuring a Satellite Server

Follow these steps to configure each satellite server.

1 Modify the {DPIPE_HOME}/scripts/hourly_NNM_Event.pro file (where 
{DPIPE_HOME} is the directory in which OVPI is installed).

Make the following changes:

• Comment out block1_init.

• Uncomment block2, including the begin and end lines.

2 Modify the {DPIPE_HOME}/scripts/hourly_NNM_Avail.pro file.

Make the following changes:

• If you configured a copy policy for the RVNNM_Avail table on the central server (refer 
to task 5), comment out the following two lines in block1:

{DPIPE_HOME}/bin/trend_sum -f {DPIPE_HOME}/scripts/hourly_NNM_Avail_allnnm.sum

{DPIPE_HOME}/bin/ovpi_run_sql -sqlscript  
{DPIPE_HOME}/scripts/{DBVENDOR}/update_SH_NNM_Avail.sql -logfile  
{DPIPE_HOME}/tmp/update_SH_NNM_Avail.out

• Uncomment the following three lines in block2:

begin: block2 wait

{DPIPE_HOME}/bin/trendcopy -t SH_NNM_Avail

end: block2
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• If you configured a copy policy for the RVNNM_Avail table on the central server (refer 
to task 5), uncomment the following line in block2:

{DPIPE_HOME}/bin/trendcopy -t RVNNM_Avail

3 Make sure that each satellite server is collecting data from a disjoint set of NNM stations.

System Clocks

Make sure that the system clock on each satellite server is synchronized with the system clock 
on the central server.
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5 Collecting Data from NNM 7.5x
This chapter covers the following topics: 

• Adding and Modifying Properties

• Changing the HTTP Port Number of OVI on NNM

• Synchronizing Node or Category Information

• Changing the NNM Events Data Tool

• Checking Collection Failures

A list of NNM stations is required to collect event and availability data. There are two ways to 
produce this list: bulk import and OVPI forms.

Adding and Modifying Properties

Property information comes from the following sources:

• Forms bundled with the NNM Event and Availability Report Pack

• Common Property Tables batch-mode property import

• Common Property Tables (Device, Customer, Vendor)

• Category List Table

• NNM List Table

• NNM List Tables “add new” and “update” forms 

• Category List Table “add new” and “update” forms 

• Automatic feed from the network

If you have customers associated with specific devices or specific interfaces, or if you have 
vendors associated with specific devices, use Common Property Tables to import this 
information.

Bulk Import

To import a list of NNM stations using bulk import, perform these tasks:

• Task 1: Create the NNM station list file

• Task 2: Import the NNM station list file

• Task 3: OVPI data collection
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Task 1:  Creating the NNM station list file

Create a property parameter file NNM_List.dat in the directory $DPIPE_HOME/data/
PropertyData/NNM_Event/ when bulk import of NNM stations is to be done or a set of 
NNM stations for collection is required. To import one NNM station, use forms as described in 
Using Forms on page 28.

The format of the data is as follows:

<nnm_station_1><tab><ovi_port_number>

<nnm_station_n-1><tab><ovi_port_number>

<nnm_station_n><tab><ovi_port_number>

Example:

nnm1.hp.com  8092

nnm2.hp.com  8092

nnmn.hp.com  8092

The default OVI port number is 8092. 

Task 2: Import the NNM station list

To import the NNM station list, run the NNM List Importer tool:

$DPIPE_HOME/bin/trend_proc -f $DPIPE_HOME/scripts/NNM_Event_import_nnm.pro

The NNM List Importer tool imports NNM_List.dat to the OVPI database. The imported list 
is now ready for data collection. 

Task 3: Data collection

Once the NNM stations list is provisioned, the system is ready for collection. During the first 
collection, the data collection tool will automatically:

1 Get the nodes from NNM with Device Type, Vendor, and Category information. 

2 Get data for the last two days from the NNM station or as available in NNM, whichever is 
faster. 

3 Put the category list into OVPI.

Using Forms

This section describes the following forms:

• Add or Update NNM List

• Remove NNM Station

• Add or Update Category Information

Change this port number only if you have changed the port number for the 
CommandResponder pluglet of OVI.

Errors are logged to: $DPIPE_HOME/log/trend.log

By default, data collection takes place hourly. The periodicity (polling interval) of 
data aggregated by NNM is 15 minutes.
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• Remove Alarm Category

• Update Availability Threshold

Use these forms to create, update, or remove property data. 

To launch a form, click the Objects icon in the panel on the left side of the Management 
Console window. The Object/Property Management view opens. Object Manager shows a list 
of objects. The type of object presented depends on which Object Manager View is open. The 
default view is the Device view, showing a list of devices. To change the view, select View > 
Change View and use the pop-up window to select a different view. Once the type of object you 
are interested in updating is in view, select the particular object you want to update. 

When you select the object, Object Specific Tasks will appear in the window on the right. 
Double-click and open the form. Click Apply to save changes, OK to save changes and close the 
form, or Cancel to close the form without saving changes.

Add or Update NNM List 

Use the Add or Update NNM List form to add a new NNM station or modify the following 
details for an existing NNM station:

• OVPI port number

• Polling interval

• Polling granularity

• HTTP time-out

Follow these steps to update an NNM station:

1 Launch the Management Console.

2 Click the Objects icon. The Add or Update NNM List form appears under General Tasks. 
Navigate to the NNM station you want to update, then double-click the Add or Update 
NNM list form.

3 Highlight the row that contains the data you want to change.

4 If required, change the Polling Granularity and then change the following entry in the 
$DPIPE_HOME/trendtimer.sched:

01:00 - - {DPIPE_HOME}/bin/trend_proc -f {DPIPE_HOME}/scripts/NNM_Event.pro

For example, if Polling Interval is 180 mins, then change the entry as shown below: 

03:00- - {DPIPE_HOME}/bin/trend_proc -f {DPIPE_HOME}/scripts/NNM_Event.pro

Polling Granularity is the result of duration units divided by Polling Interval. For a given 
Polling Interval, events data collected can be aggregated over smaller units of duration 
(called Polling Granularity). For example, if Polling Interval is 60 mins, then Polling 
Granularity can have values such as 30, 60, and 180 mins.

5 Make your changes. Click Apply to save changes, OK to save changes and close the form, or 
Cancel to close the form without saving changes.

Follow these steps to add a new NNM station:

1 Select any row. 

2 Enter the name of the NNM station in the NNM Station field. Change other values as 
required.
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3 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes. 

As soon as NNM 8.0 is supported, the Station Version field will display 8.0. For now, version 
7.5x is the only value this field displays.  
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Remove NNM Station

Follow these steps to remove a single NNM station:

1 Launch the Management Console.

2 Open the Object/Property Management view. Select View > Change View and use the 
pop-up window to select OV NNM view. The NNM stations are listed here. 

3 Select the NNM station you want to remove. 

4 Double-click the Remove NNM Station form under Object Specific Tasks. The form opens, 
showing NNM stations configured for OVPI data collection. 

5 Highlight the row that contains the NNM station that you want to remove. 

6 Click Apply to remove the NNM station, OK to save changes and close the form, or Cancel 
to close the form without saving changes.

Once you remove an NNM station, that NNM station will stop collecting data. 
Existing data is still available.
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Add or Update Category Information

Follow these steps to update a new alarm category for an NNM station:

1 Launch the Management Console.

2 Click Objects. The Add or Update Category Information is listed under General Tasks. 
Double-click the form. 

3 Navigate to the NNM station and double-click the form. The form opens, showing category 
information. 

4 Highlight the row that contains the data you want to change. 

5 Make the changes.

6 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes. 

Follow these steps to add a new NNM station: 

1 Select any row. 

2 Enter the new Category Id and Category Name.

3 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.
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Remove Alarm Category

Follow these steps to remove a category for an NNM station:

1 Launch the Management Console.

2 Open the Object/Property Management view. Select View > Change View and use the 
pop-up window to select OV NNM view. The NNM stations are listed here. 

3 Select the NNM station that you want to remove. 

4 Double-click the Remove Alarm Category form under Object Specific Tasks. The form opens, 
showing NNM stations, Category Id, and Category Name.

5 Highlight the row you want to remove. 

6 Click Apply to remove a category for an NNM station, OK to save changes and close the 
form, or Cancel to close the form without saving changes.
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Update Availability Threshold

The Availability Threshold (percentage of availability) values are based on NNM station, 
Customer, Vendor and Device type. Threshold is the line between normal and abnormal 
performance. When this line is crossed, an exception is recorded. Thresholds are set to default 
values that are easily changed to reflect individual needs.

Follow these steps to change the threshold value:

1 Launch the Management Console (piadmin).

2 Click Objects. Under General Tasks you will see the Update Availability Threshold form. 
Double-click the form. The forms opens, showing a list of NNM stations and an 
availability threshold for each station. 

3 Highlight the row that contains the Availability Threshold you want to change.

4 Make the changes. Click Apply to save changes, OK to save changes and close the form, or 
Cancel to close the form without saving changes.
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Changing the HTTP Port Number of OVI on NNM

If the port number 8092 is already in use, do the following to change the port number:

1 On NNM, change the <serverPort>8092</serverPort> parameter in the file specified 
below to identify the new HTTP port number.

UNIX

$OV_INSTALL_DIR/conf/OVPI_INTEGRATION/ResponderProxyPluglet.config 

Windows

$OV_INSTALL_DIR/newconfig/OVPI_INTEGRATION/
ResponderProxyPluglet.config

2 Re-start the OVI CommandResponder pluglet. To start or stop OVI, do as follows:

UNIX

$OV_BIN/ICO_ctl.ovpl -s : to stop OVI

$OV_BIN/ICO_ctl.ovpl -g : to start OVI

Windows

%OV_BIN%\ICO_ctl.ovpl -s : to stop OVI

%OV_BIN%\ICO_ctl.ovpl -g : to start OVI

Synchronizing Node or Category Information

Use the get_nnm_aggevt tool to synchronize the node information or category information 
from all NNM stations. 

• To update the NNM Event and Availability Report Pack with current node information 
from NNM, use the following script to get the node information:

$DPIPE_HOME/bin/perl $DPIPE_HOME/scripts/get_nnm_aggevt.pl -i

• If you install new SPIs, the alarm category will change. To update the NNM Event and 
Availability Report Pack, use the following script to get node information:

 $DPIPE_HOME/bin/perl $DPIPE_HOME/scripts/get_nnm_aggevt.pl -c

Changing the NNM Events Data Tool

NNM uses the following tools to provide event data:

• ovdumpevents: This tool is the default data collection tool on OVPI. 

• ovdwquery: This tool is based on RDBMS. 

For more information about these tools, refer to Managing Your Network with HP OpenView 
Network Node Manager. 

Follow these steps to change the tool to ovdwquery:

1 Access the $DPIPE_HOME/lib directory
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2 Create a configuration file named NNM_Event_Report.conf with the following entry:

AGG_TOOL,ovdwquery

The new tool will be used in the next poll cycle.

Follow these steps to change the tool to ovdumpevents:

1 Access the $DPIPE_HOME/lib directory

2 Do one of the following:

• Remove the conf file NNM_Event_Report.conf 

• Modify the AGG_TOOL entry in the above configuration file as 
AGG_TOOL,ovdumpevents

Checking Collection Failures

Check the following log files in sequence:

1 On OVPI, the collection details for all NNM stations are logged here:

$DPIPE_HOME/log/trend.log. 

Check for entries with get_nnm_aggevt.pl, the module that collects event data from 
NNM stations.

2 On NNM, collection details and failures, if any, are logged here:

$OV_TMP/OVPI/NNM_EVT_RP_*log
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6 Sample Reports
This chapter provides samples of the following reports:

1 Detailed Availability - Station Level

2 Details Availability - Node Level

3 Availability Forecast by Customer

4 Availability SLA Report

5 Executive Summary by Vendor

6 Event Summary by NNM Station

7 Forecast by Severity

8 Hot Spots Top 20

9 NNM Events by Category and Device

10 NNM Events by Severity and Device

11 Executive Summary by Severity

Sample 1: Detailed Availability Report on Station Level

Daily, monthly, and yearly availability information for a selected customer, and a selected type 
of device, on a per-vendor basis. This report does not show availability across multiple NNM 
stations. This report aggregates data at the NNM station level.

First select the NNM station, then select a vendor, a customer, and a device type. The table 
below the selection fields provides statistics for:

• Availability 

• MTTR 

• Total downtime

• MTBF

• Outage count

Use this report to see if availability for a particular device type managed by a particular NNM 
station is improving or worsening. 

Sample 2: Detailed Availability Report on Node Level

Daily, monthly, and yearly availability information for a selected customer, and a selected type 
of device, on a per-vendor basis. This report does not show availability across multiple NNM 
stations. This report aggregates data at the NNM station level.

First select the NNM station, then select a vendor, a customer, and a device type. The table 
below the selection fields provides statistics for:
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• Availability 

• MTTR 

• Total downtime

• MTBF

• Outage count

Use this report to see if availability for a particular device type managed by a particular NNM 
station is improving or worsening. 

Sample 3: Availability Forecast by Customer

If multiple NNM stations are in use, this report aggregates data from all of them, and rolls up 
data to the customer level. Once you select a customer, you can either select All or a particular 
device type. The bar graph provides baseline, F30, F60, and F90 values for:

• MTBF

• MTTR

• Availability

• Downtime

Use this report to see whether the customer you selected is expected to see improved 
availability metrics or degraded availability metrics.

Sample 4: Availability SLA

The availability SLA report aggregates data for multiple NNM stations. It answers four 
questions:

• On average, is a particular vendor operating above or below the threshold for availability?

• Is a particular device type from one vendor operating above or below the threshold?

• On average, are the devices owned by a customer operating above or below the threshold?

• Is a device type owned by a particular customer operating above or below the threshold?

This report looks at downtime details as well as availability details. You can compare actual 
availability to the SLA value (the threshold for availability), and you can compare actual 
downtime to the SLA value (the threshold for downtime). 

Sample 5: Executive Summary by Vendor

This report aggregates alarm category and alarm severity data at the vendor level, on a 
station by station basis. Use this report to determine:

• The distribution of alarms across alarm categories

• Whether the number of alarms per category is increasing or decreasing

• The distribution of severity levels

• Whether the number of alarms per severity level is increasing or decreasing
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Sample 6: Event Summary by NNM Station

This report aggregates the total number of events on a station by station basis. Use this 
report to find out what the total is for each NNM station and whether the total is increasing 
or decreasing.

Sample 7: Forecast by Severity

This report produces an alarm severity forecast. It aggregates severity data across all devices 
on a station by station basis, calculates a baseline value for each severity level, then lets you 
compare the baseline value to F30, F60, and F90. Use this report to find out which severity 
level was most prevalent over the baseline period and how each severity level is expected to 
behave in the future.

Sample 8: Hot Spots Top 20

This report aggregates events for each device on a station by station basis. Use this report to 
find out which devices are responsible for the most events. Select a station, then select a 
severity level. The graph below produces a list of devices, ranked by number of events, highest 
to lowest, allowing you to see event statistics for the twenty devices responsible for the 
majority of events.

Sample 9: NNM Events by Category and Device

This report aggregates event category statistics on a station by station basis. Use this report 
to drill down from an event category to a list of the devices responsible for the alarms in that 
category. The devices are ranked by the number of events in that alarm category, highest to 
lowest. Use this report to find out which devices are responsible for majority of events in each 
alarm category.

Sample 10: NNM Events by Severity and Device

This report aggregates severity level statistics on a station by station basis. Use this report to 
drill down from a severity level to a list of the devices responsible for the alarms in that level. 
The devices are ranked by number of events in that severity level, highest to lowest. Use this 
report to find out which devices are responsible for most of the events in each severity level.

Sample 11: Executive Summary by Severity

This report compiles data about the number of events per severity level. The results are 
available on a vendor-by-vendor basis and on a customer-by-customer basis. After selecting 
the NNM station, select a vendor and a severity level. The graph to the right shows the trend 
line for the number of events for this particular device and this particular severity level. You 
can also select a customer and a severity level. The graph to the right shows the trend line for 
the number of events for this particular customer and this particular severity level. Use this 
report to find out whether the event count for a severity level is increasing or decreasing.
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A Version History
Version Release Date Changes

1.0 June 2004 19 reports

1.1 April 2007 new features:
• LIR Configuration
• Copy policies updated for LIR 
new upgrade package:
• UPGRADE_NNM_Event_to_11
defect fixes: 
• QXCR1000327601
• QXCR1000348185

1.2 October 2007 new features:
• Copy Policy Enhancement
• Detailed Availability - Station Level
• Detailed Availability - Node Level
new upgrade package:
• UPGRADE_NNM_Event_to_12
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B Editing Tables and Graphs
Any table or graph can be viewed in several ways. Although the default view is usually 
adequate, you can easily change to a different view. If you are using Report Viewer, right-click 
the object to open a list of view options. If you are using the Web Access Server, follow these 
steps to change the default view of a table or graph:

1 Click Preferences on the links bar.

2 Expand Reports in the navigation frame.

3 Click Viewing.

4 Select the Allow element editing box.

5 Click Apply.

6 Click the Edit icon next to the table or graph. 

View Options for Tables

Right-clicking a table, or selecting the Edit Table icon if you are using the Web Access Server, 
opens a list of table view options.

Select Set Time Period to alter the relative time period (relative to now) or set an absolute time 
period. The Set Time Period window opens.

You may shorten the period of time covered by the table from, for example, 42 days to 30 days 
or to 7 days. If you are interested in a specific period of time that starts in the past and stops 
before yesterday, click Use Absolute Time and select a Start Time and an End Time.

Select Change Constraint Values to loosen or tighten a constraint, thereby raising or lowering 
the number of elements that conform to the constraint. The Change Constraint Values 
window opens. To loosen a constraint, set the value lower; to tighten a constraint, set the 
value higher.

The Select Nodes/Interfaces allows you to change the scope of the table by limiting the table to 
specific nodes, specific interfaces, or a specific group of nodes or interfaces. The Select Node 
Selection Type window opens.
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Change Max Rows increases or decreases the number of rows in a table. The default is 50. If 
you expand the default, the table may take more time to open. If you are trending a large 
network, using the default ensures that the table opens as quickly as possible. 
View in new Frame opens the table in a Table Viewer window, shown below. If necessary, make 
the data in the table more legible by resizing the window. 

View Options for Graphs

Right-clicking a graph, or clicking the Edit Graph icon if you are using the Web Access Server, 
opens the following list of view options. 
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The following table provides details about each option.

Style Options

Select Style to display a list of seven view options for graphs.

Option Function

Set Time Period Same as the table option shown above.

Change Constraint Values Same as the table option shown above.

Select Nodes/Interfaces Same as the table option shown above.

Displayed Data For every point on a graph, display data in a 
spreadsheet.

Grid Add these to the graph:
X axis grid lines
Y axis grid lines
X and Y axis grid lines

Legend Delete or reposition the legend. 

Style See the illustrations below.

Change Max Rows... Same as the table option shown above.

Display Data Table See below.

Export Element as CSV... Same as the table option shown above.

View in New Frame Opens graph in a Graph Viewer window.

Print Graph Same as the table option shown above.
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Style > Area

The plot or bar chart changes to an area graph. While relative values and total values are 
easy to view in this format, absolute values for smaller data types may be hard to see. Click 
anywhere within a band of color to display the exact value for that location 

To shorten the time span of a graph, press SHIFT+ALT and use the left mouse button to 
highlight the time span you want to focus on. Release the mouse button to display the selected 
time span.

Style > Stacking Area

The area or plot graph changes to a stacking area graph. This view is suitable for displaying a 
small number of variables.
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Style > Bar

The graph changes to a bar chart. This view is suitable for displaying relatively equal values 
for a small number of variables. There are three variables in the graph below.

Style > Stacking Bar

The plot or area graph changes to a stacking bar chart. If you increase the width of the frame, 
the time scale becomes hourly. If you increase the height of the frame, the call volume shows 
in units of ten.
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Style > Plot

Bands of color in an area graph change to lines. If you adjust the frame width, you can make 
the data points align with hour; if you adjust the frame height, you can turn call volume into 
whole numbers.

Style > Pie

An area graph becomes a pie chart. Bands in an area graph convert to slices of a pie and the 
pie constitutes a 24-hour period. This view is helpful when a small number of data values are 
represented and you are looking at data for one day.

If you are looking at data for more than one day, you will see multiple pie graphs, one for each 
day. 
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Display Data Table

This option changes a graph into a spreadsheet. 

View in New Frame

The graph opens in a Graph Viewer window. Improve legibility by resizing the window. 
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defect fixes
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