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Introducing the Smart Plug-in for 
Exchange 

This chapter introduces you to some basic Smart Plug-in for Microsoft® 
Exchange Server (Exchange SPI) concepts and offers an overview of the 
components that appear in the OpenView for Windows console when 
Exchange SPI is installed. The chapter includes the following sections: 

• What the Exchange SPI does

• How the Exchange SPI works with OpenView Operations for Windows

• Service Discovery and the Service Map

• Policy setup, display and deployment

What the Exchange SPI Does

The Smart Plug-in for Microsoft® Exchange Server (Exchange SPI) adds 
Exchange 2000 and Exchange 5.5 server-monitoring capabilities to 
OpenView Operations for Windows. It provides mission critical monitoring 
and management of the enterprise Exchange environment through 
predefined yet customizable policies, the monitoring of message delivery 
times, and predefined service level reporting.

With the Exchange SPI configured and deployed to Exchange server 
systems you will find that you can increase Exchange availability and 
7



What the Exchange SPI Does
performance, lower the support costs associated with the Exchange 
service, and improve capacity management and planning.

After setup, the Exchange SPI will monitor critical Exchange application/
database resources including:

• Process Monitor (for monitoring the amount of CPU time being used by 
core Exchange processes)

• Inactive Process Monitor (for monitoring core MS Exchange process for 
activity and status)

• Exchange Service Monitor (for monitoring Exchange Server process for 
activity levels)

• Data of message processes by Message Transfer Agent and SMTP

• MTA Work Queue and SMTP Queues

• IS Public Average Delivery Time

• IS Private Average Delivery Time

This information comes to you through the OpenView Operations console, 
in the form of service and organization maps and views, messages, alerts, 
reports and graphs. 
8



Chapter 1:  Introducing the Smart Plug-in for Exchange
9

How the Exchange SPI Works

Like other Smart Plug-ins, the Exchange SPI collects data that is targeted 
and gathered according to rules and schedule specifications contained 
within the Exchange SPI policies. 

After selecting nodes to be managed by the Exchange SPI, Service 
Discovery policies discover your Exchange environment. Through 
deploying and modifying policies you can monitor your Exchange servers 
according to your particular needs. 

Figure 1 SPI for Exchange folder located in the OVO console



How the Exchange SPI Works
Auto Discovery and the Service Map

The Exchange SPI has an auto discovery function which discovers 
Exchange topology. The discovery process is done by Service Discovery 
Policies. The policy of this type for Exchange 5.5 is automatically deployed 
when a node becomes an OVO managed node. The Service Discovery 
policy for Exchange 2000 must be modified to include a domain admin 
user and password to deploy successfully. (For details on this procedure 
see “Modifying Exchange 2000 Service Discovery policy” on page 43).

The Exchange environment information discovered by the Service 
Discovery policies is displayed in Exchange Organization Service maps, 
and the Exchange Messaging and Organization views. 

Service Maps

Service maps are created from the topology discovered on your network by 
the Exchange Service Discovery policies.

In the console, display the service map in the details pane by selecting 
Services > Applications and then selecting any level of the Exchange 
10



Chapter 1:  Introducing the Smart Plug-in for Exchange
organization. Your Exchange organization and its activity can be looked at 
either in the console tree or in the Service Map display. 

Figure 2 Discovered Exchange 2000 “Auburn” Administrative Group 
services, in the Console Tree
11



How the Exchange SPI Works
Figure 3 Service Map of “Auburn” Administrative Group Servers 

Problems in the Exchange Organization are indicated in the Service Map 
and console tree by colors that illustrate severity level. They are also 
indicated by critical, major, minor or warning messages displayed in the 
Message Browser. Hovering the cursor over any entry in the message 
browser will display descriptive details, double-click a message to see 
details.
12



Chapter 1:  Introducing the Smart Plug-in for Exchange
Figure 4 Partial view of Active Message Browser, for an Exchange 5.5 Site

The buttons in the OpenView toolbar give you easy access to the various 
ways of viewing Exchange activity: 

From left to right: Impacted Services, Root Cause, Service Map, Active 
Message Browser, Acknowledged Message Browser.
13



How the Exchange SPI Works
Figure 5 Impacted Services from a Server problem
14



Chapter 1:  Introducing the Smart Plug-in for Exchange
Figure 6 Root Cause view of an Exchange 5.5 site problem

Exchange Organization

After Exchange topology is discovered, the organization of your Exchange 
environment is available for display in the console tree, the dynamic 
service maps and the snapshot service views. The Exchange organization 
15



How the Exchange SPI Works
in an enterprise can be extremely complex, these views help in visualizing 
the organization from the overview down to the details.

Figure 7 Hierarchical View of Exchange Organization
16



Chapter 1:  Introducing the Smart Plug-in for Exchange
Snapshot Views of the Exchange Environment

To see the Exchange Messaging View or Organizational View:

1 Open the SPI for Exchange folder on the console tree, 

2 Select the Exchange version: Exchange 5.5 or Exchange 2000.

3 Open either the Messaging View or Organizational View.

Figure 8 Location on console tree of Exchange SPI Views
17



How the Exchange SPI Works
Messaging View

The Messaging View gives a view of the Exchange network, showing all 
Exchange Servers and Connectors, and the connections between them

Figure 9 SPI for Exchange Messaging View:
18



Chapter 1:  Introducing the Smart Plug-in for Exchange
Organizational View

This hierarchical view shows your Exchange Organization sites or 
administrative/routing groups along with servers.

Figure 10  SPI for Exchange Organizational View:
19



How the Exchange SPI Works
Messages

Policies generate messages and alerts that are displayed in the OpenView 
message browser. They are also forwarded to the appropriate service 
category and are displayed in the Service Maps. 

Double-click messages in the message browser to view the details of any 
message:

Figure 11  Selecting a warning message in the Active Message Browser
20
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Messages include suggestions for corrective actions.

Figure 12  Message Properties with explanatory text
21



How the Exchange SPI Works
Policy Setup and Deployment 

Exchange SPI policies are organized in the following categories: 

• The EXSPI Discovery policy group for Exchange 5.5 and Exchange 2000, 
contains EXSPI-5.5 Exchange Service Discovery and EXSPI-6.0 Exchange 
Service Discovery. These policies perform the Exchange service discovery 
on Exchange 5.5 and Exchange 2000 servers respectively.

• There is an EXSPI Quick Start policy group for Exchange 2000, and one 
for Exchange 5.5. These policy groups contain the basic policies for 
monitoring Exchange servers that most administrators will wish to deploy, 
like policies to monitor key Exchange services, forward application errors 
and warnings, and monitor messaging queues. These policies need no user 
name or password to configure, and no special customization to run. 

• EXSPI Add-Ons policies require no customization, although some do 
require a user name and password. They are determined by the 
applications/programs being used by your Exchange server and are 
available to select, modify and deploy. 

• The EXSPI Advanced policy group is available after some additional 
setup. Once deployed to the Exchange server nodes, advanced policies 
enable the Exchange SPI to target specific data and measure this data 
against predefined rules, generating the particular information set you 
need. 

User Privileges and the Exchange SPI

There are 3 levels of user privileges needed for full usage of the Exchange 
SPI product. For more information on user privileges and the procedures 
required for modifying policies and creating user accounts with the 
required privileges, see Chapter 3 “Exchange SPI and User Privileges” on 
page 41.
22



Chapter 1:  Introducing the Smart Plug-in for Exchange
Policy Display 

Exchange SPI policies are displayed in the OVO console in two places: by 
group under the Policy groups folder, and by type under the Policies 
grouped by type folder. These groupings are for your convenience, when 
an Exchange SPI policy is edited in either of these locations it will appear 
updated in both. See the Exchange SPI on-line Help for detailed 
information on policy groups, policy types, and policy prerequisites.

Figure 13  Console tree showing Policy groups and Policies grouped by type 
23



How the Exchange SPI Works
Policy groups

Under Policy Groups policies are organized according to how you might 
want to deploy them. Discovery and Quick Start contain policies that 
deploy automatically after installation of Exchange SPI and do not need a 
domain admin user name or password (with the exception of the Exchange 
Service Discovery policy for Exchange 2000). The Quick Start group 
contains most of the policies you need to get started; Add-Ons contains 
policies that monitor applications compatible with but not a part of 
Exchange, such as cc:Mail and Chat. Some of the Add-Ons policies require 
modifying to contain a standard Windows domain admin user with 
password. Advanced contains policies that require some advanced 
configuration, either a User account with special Exchange privileges and/
or a mailbox. 
24



Chapter 1:  Introducing the Smart Plug-in for Exchange
For information on user privileges and the procedures required for 
modifying policies and creating user accounts with the required privileges, 
see Chapter 3 “Exchange SPI and User Privileges” on page 41.

Figure 14  Exchange SPI Policy Groups on the console tree

Policies grouped by type

Policies grouped by type displays policies organized according to their 
function, for example, you can find data collection scheduling in Scheduled 
25



How the Exchange SPI Works
Task policies; threshold settings in Measurement Threshold policies, etc. 
Further information on policy types is available in the OVO on-line Help.

Figure 15  Measurement Threshold policies displayed in the details pane 
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Chapter 1:  Introducing the Smart Plug-in for Exchange
Using Exchange SPI tools

There are two groups of Exchange SPI tools: Tools > SPI for Exchange > 
Exchange 5.5, and Tools > SPI for Exchange > Exchange 2000. 

Figure 16  Location of SPI for Exchange Tools on the console tree

In each of the Exchange version folders are three tools:

Figure 17 Exchange SPI Tools for Exchange 5.5/2000
27



How the Exchange SPI Works
• The Exchange SPI MBOX Config tool starts the mailbox configuration 
program that automatically configures a mailbox.

• Tracing is enabled or disabled by these tools. The default setting is off. 
Tracing is generally used for troubleshooting purposes.

OVO Foundation Tools

Certain Advanced and Add-On policies require a domain admin account. 
To help manage those accounts, a tool called ovpmpwutil has been added 
to the OVO foundation tools. This tool is not SPI specific. Documentation 
for ovpmpwutil can be found in the Command-line Tools section of HP 
OpenView Operations for Windows online Help.

Exchange SPI Reports and Graphs

In the Exchange SPI Reports and Graphs folders are a number of pre 
configured reports and graphs, useful for viewing and analyzing data.

Reports and graphs are generated by the EXSPI Reporter Collection 
policies in the EXSPI Advanced group, that interpret collected metric 
values and forward the data. The information is collected nightly and is 
then available for reports and graphs the next day. Some data collectors 
run on Saturday/Sunday only and therefore related reports are available 
after a weekend has passed.
28



Chapter 1:  Introducing the Smart Plug-in for Exchange
Exchange SPI Reports

There are two types of reports available: Summary Reports give 
information showing trends in server performance on your system, Detail 
Reports give, in addition, information system by system.

Figure 18  Location of SPI for Exchange Reports on the console tree
29



How the Exchange SPI Works
Reports are displayed in the console organized by type. By selecting any of 
the categories, the list of available reports in that category displays in the 
details pane, with descriptions. 

Figure 19  SPI for Exchange Conferencing Reports 

For your assistance in choosing reports, the Smart Plug-in for Exchange 
on-line Help contains descriptions of all the preconfigured reports 
available within the Exchange SPI, and a table showing any policies that 
they require to be deployed.
30
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Exchange SPI Graphs

SPI for Exchange Graphs are located in Reports and Graphs > Graphs 
> SPI for Exchange, displayed by type.

Figure 20  SPI for Exchange Graphs listed by type
31



How the Exchange SPI Works
Figure 21  SPI for Exchange Messaging Graphs

Figure 22  Exchange Server Public Folder Usage graph
32
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 Exchange SPI: Getting Started

Task 1: Install the Exchange SPI with OpenView Operations and Performance for 
Windows 

When you insert the hp OpenView Operations 7.0 for Windows CD into 
your CD-ROM drive, the InstallShield wizard is automatically launched. 
In the first window the Smart Plug-in products available to install are 
displayed, select the OpenView Smart Plug-in for Exchange. 

Please see the HP OpenView for Windows Enterprise Management 
Installation Guide included with the product. This guide offers a product 
overview as well as the location of the latest Exchange SPI Release Notes, 
which you should print and read before getting started. 
33



Task 2: Add Exchange Servers to the Nodes folder 

The servers whose services you want to discover and monitor must be 
included in the Nodes folder of the OVO management console. Discovered 
Exchange servers without discovered services are not managed nodes. To 
monitor servers, add them to the OVO Nodes folder now.

To add an Exchange server to the Nodes folder

1 In the OVO console, right-click the Nodes folder, select Configure 
Nodes

Figure 23  Nodes > Configure Nodes menu.

For Exchange 2000:

You must modify EXSPI-6.0 Exchange Service Discovery prior to 
selecting nodes to manage. It is necessary to open the policy and enter 
a domain admin user and password to give the user read permissions 
to the configuration partition of Active Directory. See “Adding Domain 
Admin User and Password to a Policy” on page 43.
34



Chapter 2:  Exchange SPI: Getting Started
2 In the Configure Managed Nodes dialog, drag and drop servers listed on 
the left to the OVO Nodes folder on the right. 

Figure 24  Configure Managed Nodes dialog 

Task 3: Discover Exchange Services

The Exchange SPI implements an LDAP based Exchange topology 
discovery for Exchange 2000 and Exchange 5.5. The discovered topology is 
maintained in the OpenView namespace on the management server or 
console.

• How It Works

Exchange topology is discovered by policies that are automatically 
deployed to all Windows nodes after they are selected to become OVO 
managed nodes. 

The discovery policies are EXSPI-5.5 Exchange Service Discovery for 
Exchange 5.5, and EXSPI-6.0 Exchange Service Discovery for Exchange 
2000. These policies are located in the EXSPI Discovery folder. 
35



• Service Map

The discovered Exchange organization is displayed in the OVO details 
pane, in various Service Maps.

Figure 25  Service view of one Exchange 2000 Routing Group

For Exchange 2000:

You must modify EXSPI-6.0 Exchange Service Discovery prior to 
selecting nodes to manage. It is necessary to open the policy and enter 
a domain admin user and password to give the user read permissions 
to the configuration partition of Active Directory. See “Adding Domain 
Admin User and Password to a Policy” on page 43.
36



Chapter 2:  Exchange SPI: Getting Started
The Organization with the name given by the Exchange administrator is 
located beneath the Exchange folder on the OVO console tree. The 
hierarchical structure below the organization name are folders mirroring 
your Exchange organizational structure. In the case of OVO managed 
nodes, all services are listed by product name. Any Exchange server listed 
in the tree with no services under it is an unmanaged server. 

Task 4: Identify Exchange Servers/Services

The Exchange topology is discovered by the Service Discovery policies and 
the information is visible in the folders labeled Exchange 5.5 or 
Exchange 2000, under Services > Applications on the OVO console 
tree. By expanding the new folders, you see the organization of your 
Exchange services.

Figure 26  Hierarchy of an Exchange 2000 Organization 
37



Where an Exchange server is listed in the tree with no services listed 
under it, it is an unmanaged server. If you wish it to be managed by OVO, 
perform Task 2 “Add Exchange Servers to the Nodes folder” on page 34 
now.

The SPI for Exchange folder below the Tools folder on the console tree 
contains the Messaging and Organizational View folders, see “Snapshot 
Views of the Exchange Environment” on page 17.

Task 5: Exchange Service Discovery Policy Deployment, if required

After adding Exchange servers to the Nodes folder, the EXSPI Exchange 
Service Discovery policies will automatically deploy.

 To perform this step manually

1 In the OVO console tree expand the folders Policy Management > 
Policy Groups > SPI for Exchange > Exchange 5.5 or Exchange 
2000 > EXSPI Discovery.

2 In the details pane select EXSPI-5.5 Exchange Service Discovery for 
Exchange 5.5, or EXSPI-6 Exchange Service Discovery for Exchange 
2000, and right-click.

3 Select All Tasks, then Deploy On. In the dialog select the nodes you wish 
the discovery to be deployed on.

After allowing about five minutes, it will be possible to view the structure 
of Exchange services. 

Task 6: Policy Deployment, as required

After discovery the version specific policies in Quick Start are auto 
deployed.

In order for the EXSPI-6.0 Exchange Service Discovery policy to deploy 
automatically when Exchange 2000 servers are added to the Nodes 
folder, it must contain a domain admin user and password. (See 
“Adding Domain Admin User and Password to a Policy” on page 43.) If 
the node is managed before the policy is modified in this way, then the 
customer needs to follow the procedure for manually deploying the 
Discovery policy.
38
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To perform this step manually, see “Deploying the Quick Start Policy 
Group” on page 83.

Task 7: Verify Installation Results

1 In the OVO Manager console expand the Nodes folder.

2 Right-click the node on which to verify deployment and select View > 
Policy Inventory.

Suggested Daily Tasks

Areas to be routinely monitored are: 

• The OVO message browser 

Watch for warning and critical messages or multiple alarms. Read the 
associated instruction text for recommended actions.

If too many alarms of a particular type are occurring and servers seem to 
be performing correctly, you likely need to adjust the Exchange SPI 
measurement threshold policy that is causing the alarm. See the OVO on-
line Help for instructions on how to adjust a threshold in a policy.

• The OVO reporting and graphing functionality

When you become aware of problems with a server, use the OVO reporting 
function to display additional information or view historical trends in 
graphs. 

• The Service Map, and Messaging and Organizational Views 

Use the Service Map View to see at a glance the extent of a particular 
problem indicated by a message, or its root cause, or what Services might 
be affected and perhaps interrupted. Stay on top of your Exchange 
Organization by using the Messaging and Organizational views. 
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Exchange SPI and User Privileges

This chapter introduces you to:

• Required User privilege levels for full usage of the Exchange SPI. 

• Procedures for modifying a policy to include a standard Windows domain 
admin user with password. 

• Procedures for creating a Domain Admin User Account with special 
Exchange privileges for each combination of Exchange/Windows 
environments.

Levels of User Privileges 

There are 3 levels of user privilege needed for full usage of the Exchange 
SPI product.

1. Local System Account (HP ITO Account) 

All Quick Start policies run under this type of account. No customization 
to policies is required (except threshold changes as desired).
41



Levels of User Privileges
2. Domain Admin Account 

A standard Windows domain admin user with password must be entered 
in the following policies in order for them to perform Active Directory 
queries:

• EXSPI Discovery > EXSPI-6.0 Exchange Service Discovery

• EXSPI Add-Ons > EXSPI Transaction Log > EXSPI-6.0 1d-Transaction Log 

• EXSPI Add-Ons > EXSPI Transaction Log > EXSPI-6.0 15m-Transaction 
Log 

• EXSPI Add-Ons > EXSPI Instant Messaging > EXSPI-6.0 Dc-Instant 
Messaging Enabled Users.

See “Adding Domain Admin User and Password to a Policy” on page 43, 
for details on how to modify policies to add the domain admin user and 
password.

3. Domain Admin User with Special Exchange privileges 

This type of account must be set up and applied for the following tools/
policies to deploy successfully:

• Mailbox Config 

• EXSPI Advanced > EXSPI End to End Message Ping > EXSPI-6.0 End to 
End Message Ping or EXSPI-5.5 End to End Message Ping, schedule policy 
access to the mailboxes created by the tool Mailbox Config.

• EXSPI Advanced > EXSPI Reporter Collection > all policies (for Exchange 
5.5 and 6.0). These policies use the Mailbox created by the tool Mailbox 
Config to extract information from the public folder and mailbox tables via 
MAPI (Messaging Application Programming Interface).

See “Creating a User Account with Proper Access Permissions” on page 45 
for creating the user account.
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Adding Domain Admin User and Password to a 
Policy

When a Windows node is placed under OVO management, policies to 
discover Exchange topology are automatically launched. In addition, they 
are launched automatically whenever a server is added to the OpenView 
Nodes folder and becomes a managed node.

For discovery to work on Exchange 2000 nodes, you must first modify the 
policy EXSPI-6.0 Exchange Service Discovery by entering a domain admin 
user and password. This is because the user needs read permissions to the 
Configuration partition (also called configuration name space) of Active 
Directory. If nodes become managed before this modification is done, the 
EXSPI-6.0 Exchange Service Discovery must be manually deployed 
afterwards. See “To perform this step manually” on page 38.

In addition, this is the case for the following three Add-Ons policies:

• EXSPI Add-Ons > EXSPI Transaction Log > EXSPI-6.0 1d-Transaction Log 

• EXSPI Add-Ons > EXSPI Transaction Log > EXSPI-6.0 15m-Transaction 
Log 

• EXSPI Add-Ons > EXSPI Instant Messaging > EXSPI-6.0 Dc-Instant 
Messaging Enabled Users.

 NOTE: There are three Active Directory partitions: Domain, Configuration and Schema. It is 
not uncommon for each to have their own security permissions. The Exchange SPI discovery 
process only reads the Configuration partition. A domain admin user will have read access on 
this Configuration partition if permissions have not been modified for the Domain Admin User 
group.

Modifying Exchange 2000 Service Discovery policy

1 Open the policy EXSPI6.0 Exchange Service Discovery, in the EXSPI 
Discovery folder.

2 Enter a domain admin user name and password, as below. 
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3 Save and close the policy.

Figure 27  Adding Domain Admin User and Password to Service Discovery 
Policy
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Creating a User Account with Proper Access 
Permissions

Before you can deploy some of the Add-Ons policies, or any of the policies 
in the Additional policy group, you must create an account for each logon 
domain where Exchange servers reside, see “Exchange SPI and User 
Privileges” on page 41. This user account enables the Exchange SPI to 
access information from the Exchange database. 

Because significant configuration differences exist between Exchange 5.5 
and Exchange 2000, and configuration details depend on operating system 
version, detailed instructions for each of the following case scenarios are 
outlined in the following pages:

• Case 1: For Nodes with Exchange 5.5 in a Windows NT Domain (NT4/
Ex5.5)

• Case 2: For Nodes with Exchange 5.5 in a Windows 2000 Domain (W2k/
Ex5.5)

• Case 3: For Nodes with Exchange 2000 in a Windows 2000 Domain (W2k/
Ex2k)
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To enable viewing the administrative groups folder which is necessary 
for creating the user account, open the Exchange server Properties, 
and select Display administrative groups.

Figure 28  Exchange server Properties dialog

You must create an Exchange SPI user in each domain. You may 
use any user name you wish. Here, we are using MSXPI as the 
example for the procedures.
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Case 1: Exchange 5.5 Nodes in a Windows NT Domain (NT4/
EX5.5)

Task 1: Create User Account (NT4/EX5.5) 

1 Log on as Domain Administrator of the domain to which the Exchange 
server belongs. 

2 Select Start > Programs > Administrative Tools (common) > User 
Manager for Domain.

3 Select User > New User. In the dialog that appears create a new user as 
follows (see Case 2 below for Windows 2000 systems):

Figure 29  User Manager dialog 

Username: MSXSPI

Full Name: OVO Exchange SPI 

Description: Exchange SPI for OVO 

Password/Confirm Password: *********
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Remember this password; you will need it later to update Tools and 
Policies.

Figure 30  New User dialog 

4 Deselect User Must Change password at Next Logon and select 
Password Never Expires.

This password must be entered but will not be authenticated 
later.
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5 Click the Groups button to display the Group Memberships window.

Figure 31  Group Memberships dialog

6 At the right, from the Not a member of: box select the Domain Admins 
user, click Add, and OK to close the Group Memberships window.

7 To include necessary information, click buttons in the New User window: 

Profile: No User Profile should be specified.

Hours: All hours of the day and week should be allowed.

Logon To: All workstations should be specified.

Account: Should never expire/should be Global Account.
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8 Click Add to add this user. (If the Exchange Add Mailbox window is 
displayed, select Cancel to close it).

9 Click the Close button to close the New User window.

10 From the User Manager menu bar select Policies > User Rights....

Figure 32  User Manager dialog

11 Check the Show Advanced User Rights checkbox.
50



Chapter 3:  Exchange SPI and User Privileges
12 From the drop-down list select Log on as a service in the Right field

Figure 33  Selecting Log on as a service for User Rights.

13 Click the Add button to open the Add Users and Groups window.

14 Click the Show Users button.
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15 Select the user account just added (MSXSPI), click Add, then OK.

Figure 34  Adding the new User Account

16 Repeat steps 12-15 to add the Profile system performance right.

Task 2: Grant Exchange Access Permissions to User Account (NT4/EX5.5)

In order for the user account (in this example MSXSPI) to have access to a 
mailbox as well as the Exchange IS Public and Private databases, it must 
have Exchange Admin permissions. Use Exchange Administrator to grant 
these permissions at the site level.

1 Select Start > Program > Microsoft Exchange > Microsoft Exchange 
Administrator.
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2 For each Exchange site where Advanced policies are to be deployed:

a In the left pane within the tree, select <site_name>.

b From the File menu select Properties.

c In the Properties window, select the Permission tab and click Add to 
open the Add Users and Groups window.

d Select the user account previously created (MSXSPI), and click Add.

e Click OK to add the user, and close the Add Users and Groups 
window.
53



Creating a User Account with Proper Access Permissions
f Verify the user has the role of Admin.

Figure 35  Verifying the User role

g Click OK to save the changes.
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Case 2: Exchange 5.5 Nodes in a Windows 2000 Domain 
(W2k/EX5.5)

Task 1: Create User Account (W2k/EX5.5)

1 Log on to the system that hosts the managed node’s domain.

2 Select Start > Programs > Administrative Tools > Active Directory 
Users and Computers.

3 Expand the Active Directory of Users and Computers and right-click 
Users and select New User.

Figure 36  Selecting New User dialog
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4 In the dialog box that appears, enter the user name just created (in this 
example MSXSPI) as the First Name and as the User logon name.

Figure 37  New object dialog

5 In the next window, enter Password/Confirm Password for the user 
account (in this example MSXSPI).
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6 Select Password Never Expires. Then click Next

Figure 38  Setting User Privileges.
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7 In the New Object dialog, deselect Create an Exchange mailbox, and 
click Next.

Figure 39  Creating an Exchange Mailbox

8 In the next dialog, complete creating the user by clicking Finish.

9 You are now back at the Active Directory Users and Computers 
dialog. In the right pane, right-click on the user just created (in this 
example MSXSPI) and select Properties.
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10 In the MSXSPI Properties page, select the General tab. Enter 
“Exchange SPI for OpenView Operations for Windows” in the 
Description field.

Figure 40  Properties dialog
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11 Select the Member Of tab. Click Add.
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12 In the Select Group dialog select Domain Admins from the top pane. 
Click Add, then OK.

13 The new user (MSXSPI) is now a member of Domain Admins group. Click 
OK and exit the Active Directory Users and Computer dialog.

Figure 41  New User with new Membership status
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Task 2: Grant Exchange Access Permissions to User Account (W2k/EX5.5)

In order for the user account (in this example MSXSPI) to have access to a 
mailbox as well as the Exchange IS Public and Private databases, it must 
have certain Exchange Admin permissions. Use Exchange Administrator 
to grant these permissions at the site level.

1 Select Start > Program > Microsoft Exchange > Microsoft Exchange 
Administrator.

2 For each Exchange site where Advanced policies are to be deployed:

a In the left pane within the tree, select <site_name>.

b From the File menu select Properties.

c In the Properties window, select the Permission tab and click Add to 
open the Add Users and Groups window.

d Select the user account previously created (in this example MSXSPI), 
and click Add.

e Click OK to add the user, and close the Add Users and Groups 
window.

f Verify the user has the role of Admin.
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Figure 42  Verifying User roles.

g Click OK to save the changes.
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Case 3: Exchange 2000 Nodes in a Windows 2000 Domain 
(W2k/EX2k)

Task 1: Create User Account (W2k/EX2k)

1 Log on to the system that hosts the managed node’s domain.

2 Select Start > Programs > Administrative Tools > Active Directory 
Users and Computers.

3 Expand the Active Directory of Users and Computers and right-click 
Users and select New User.r
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4 In the dialog box that appears, enter the new user account name, in this 
example MSXSPI, as the First Name and as the User logon name

Figure 43  Entering New User Account Name.

5 In the next window, enter Password/Confirm Password for the user 
account (in this example MSXSPI).
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6 Select Password Never Expires. Then click Next.

Figure 44  Setting Password Properties

1 In the New Object dialog, deselect Create an Exchange mailbox, and 
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click Next

Figure 45  Deselecting Creating a Mailbox.

2 In the next dialog, complete creating the user by clicking Finish.

3 You are now back at the Active Directory Users and Computers 
dialog. In the right pane, right-click on the user just created (MSXSPI) 
and select Properties.
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4 In the MSXSPI Properties page, select the General tab. Enter “OVO 
Exchange SPI” in the Display name and Description fields.

Figure 46  Entering Name in Properties dialog

5 Select the Member Of tab, and click Add.
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6 In the Select Group dialog select Domain Admins from the top pane. 
Click Add, then OK.

7 The new user (in this example MSXSPI) is now a member of Domain 
Admins group. Click OK and exit the Active Directory Users and 
Computer dialog.

Figure 47  Confirming Membership Privileges
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Task 2: Grant Exchange Access Permissions to User Account (W2k/EX2k)

In order for the user account (in this example MSXSPI) to have access to a 
mailbox as well as the Exchange IS Public and Private databases, it must 
have certain Exchange Admin permissions. Use Exchange System 
Manager to grant these.

1 Select Start > Program > Microsoft Exchange > System Manager.

Figure 48  Exchange System Manager dialog

2 In the left pane expand the Administrative Groups folder.

3 Expand your <Exchange_server_administrative_group> folder.

4 In the right pane, right-click the server to which you want to grant the 
user account just created (in this example MSXSPI) access and select 
Properties.

5 In the Properties dialog, select the Security tab.
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6 In the Name box select the user name, in this example MSXSPI.

7 In the Permission box, check both the Receive As and Send As 
permissions check boxes.

Figure 49  Properties dialog

8 Uncheck the box Allow inheritable permissions from parent to 
propagate to this object.

9 Click OK and exit the Exchange System Manager dialog.
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10 Repeat this procedure for each targeted Exchange server.

At a large Exchange site, it can take several minutes to propagate 
the new Exchange administrator information. If you experience 
permission problems while accessing Exchange databases, enforce 
the setting of the new Exchange Admin account by logging directly 
on to the affected Exchange server (which is not yet replicated) and 
setting the account manually.
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4

Using Exchange SPI Policies, Reports 
and Graphs

This chapter outlines procedures for: 

• deploying the various policy groups

• creating a User Account with the proper access permissions for each 
combination of Exchange version and operating system

• configuring the EXSPI End to End Message Ping policy to determine SLA 
performance of sending and receiving messages

• generating Exchange SPI reports and graphs
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Using Exchange SPI Policies 

EXSPI Policy Prerequisites and Descriptions

Some policies in the SPI for Exchange policy groups require that 
particular software components/services are installed on Exchange server 
systems before the deployed policies will work. For policies in the EXSPI 
Advanced group, you must configure a domain admin account, see 
“Deploying Policies from other Policy Groups” on page 84. 

Updating the account information in the policies can be performed using 
the HP OpenView Operations for Windows tools called ovpmpwutil. 
Detailed procedures for using ovpmpwutil can be found in the Command-
line Tools section of HP OpenView Operations for Windows on-line Help.

Use the following tables to decide which policies you want to install. In the 
Policy Prerequisites table you can see whether or not a policy group/
subgroup works with Exchange 5.5 and/or Exchange 2000, as well as any 
required configuration. Policy Group Descriptions show you what type of 
data/functionality the policy group offers.

Individual policy definitions are documented in the Exchange SPI on-line 
Help.

Important Microsoft Information on the Web: Before you deploy 
Exchange SPI policies, please refer to the Microsoft article “PRB: 
Performance Object Is Not Displayed in Performance Monitor” at this 
URL: http://support.microsoft.com/support/kb/articles/Q248/9/
93.ASP.

The article contains information on editing the Windows registry so 
that performance objects (tracked by Performance Monitor) are always 
enabled. A disabled performance object could cause an Exchange SPI 
policy to fail. By following the instructions in the article, you can 
ensure that policies are able to collect Exchange performance data as 
expected. 
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Policy Groups are located in the console tree under Policy Management 
> Policy Groups > SPI for Exchange and then the Exchange version.

Figure 50  SPI for Exchange Policy location on the console tree
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EXSPI Policy Group Prerequisites for Exchange 5.5  

Policy Group/ Subgroup Required Exchange 
Service

Required Manual 
Configuration

EXSPI Discovery N/A N/A.

EXSPI Quick Start N/A N/A

EXSPI Add-Ons

EXSPI cc:Mail Connector

cc:Mail Connector N/A

EXSPI MCU Server MCU Server N/A

EXSPI Internet Mail Services Internet Mail Service (IMS) N/A

IS Virus Scan N/A N/A

EXSPI Lotus Notes Connector Lotus Notes Connector N/A

EXSPI News Service N/A N/A

EXSPI Advanced

EXSPI End to End Message 
Ping

• Create MSXSPI User 
account with correct 
permissions

• Edit the MBOX Config Tool 
to contain User Password

• Create mailbox using 
MBOX Config tool

• Configure EXSPI End to 
End Message Ping policy to 
set up server pairs

• Modify the policy to 
include user account and 
password

EXSPI Event Log Warnings & 
Information

Use for troubleshooting

EXSPI Reporter Collection Create MSXSPI User account 
and password
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EXSPI Policy Group Prerequisites for Exchange 2000

Policy Group/ Subgroup Required Exchange 
Service

Required Manual 
Configuration

EXSPI Discovery N/A Policy must be modified to 
contain a domain admin user 
and password

EXSPI Quick Start 

All Policies

N/A N/A

EXSPI Add-Ons

EXSPI cc:Mail Connector

cc:Mail Connector N/A

EXSPI Chat Service Exchange Chat Service N/A

EXSPI Conferencing Service Exchange Conferencing Server N/A

EXSPI MCU Server MCU Server N/A

EXSPI Instant Messaging Exchange Instant Messaging 
Service

Some policies in this group 
must be modified to contain a 
domain admin user and 
password

IS Virus Scan N/A

EXSPI Lotus Notes Connector Lotus Notes Connector N/A

EXSPI NNTP ( Network News Transfer 
Protocol (NNTP)

N/A

Transaction Log Some policies in this group 
must be modified to contain a 
domain admin user and 
password
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EXSPI Advanced

EXSPI End to End Message 
Ping

N/A For each node where the policy 
is to be deployed:

• Create MSXSPI User 
account with correct 
permissions

• Edit the MBOX Config Tool 
to contain User Password

• Create mailbox using 
MBOX Config tool

• Configure EXSPI End to 
End Message Ping policy to 
set up server pairs

• Modify the policy to 
include user account and 
password

EXSPI Event Log Warnings & 
Information

N/A Use for troubleshooting

EXSPI Reporter Collection N/A Create MSXSPI User account 
and password

Policy Group/ Subgroup Required Exchange 
Service

Required Manual 
Configuration
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EXSPI Policy Group Descriptions

Group: 
EXSPI Quick Start 
(Exchange 5.5)

Description

EXSPI-VersionCheck Checks for the Exchange SPI version.

EXSPI Directory 
Service

Executes alarm metrics for problems detected in the Microsoft 
Exchange Directory service.

EXSPI Event Log 
Errors

Monitors all errors (type = Error) in the Windows System Log.

EXSPI General Data 
Collection

Contains all standard data collection policies used to feed data 
into the data collector. The collected data can be graphed or used 
to generate reports.

EXSPI Information 
Store

Executes alarm metrics for problems detected in the Exchange 
Information Store service.

EXSPI Internal Errors Open Message Interface policy for trapping EXSPI errors.

EXSPI Message 
Transfer Agent

Executes alarm metrics for problems detected in the Microsoft 
MTA service.

EXSPI Services and 
Processes

Monitors the availability of key Exchange services and 
processes.

EXSPI Transaction Log Monitors the size in MB of the Exchange transaction logfiles as well as 
the disk space used by the files. When size increases or available disk 
space decreases to specific defined values, messages with warnings 
appear in the message browser.
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Group: 
EXSPI Quick Start 
(Exchange 2000)

Description

EXSPI-VersionCheck Checks for the Exchange SPI version.

EXSPI Event Log Errors Monitors all errors (type = Error) in the Windows System Log.

EXSPI General Data 
Collection

Contains all standard data collection policies used to feed data into the 
OpenView data collector. The collected data can be graphed or used to 
generate reports.

EXSPI Information Store Executes alarm metrics for problems detected in the Exchange 
Information Store service.

EXSPI Internal Errors Open Message Interface policy for trapping EXSPI errors.

EXSPI Message Transfer 
Agent

Executes alarm metrics for problems detected in the Microsoft MTA 
service.

EXSPI Services and 
Processes

Monitors the availability of key Exchange services and processes.

EXSPI Site Replication 
Service

Monitors site replication to verify that synchronization updates are 
being processed efficiently. Non-zero counters indicate that site 
replication synchronization is in process. If the values are not decreasing 
over time a problem may exist with the site replication service or 
performance of the server. High values are not neccessarily bad, but 
values not decreasing is cause for concern. 

EXSPI SMTP Executes alarm metrics for problems detected in messages sent to the 
Simple Mail Transfer Protocol (SMTP) server.
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Group: 
EXSPI Add-Ons Description

EXCHANGE 5.5

EXSPI cc:Mail 
Connector

Executes alarm according to for cc:Mail Connector metrics. 
Deploy on all Exchange servers containing the cc:Mail Connector.

EXSPI Internet Mail 
Services

Executes alarm metrics for the problems detected in Exchange Internet 
Mail service. Deploy on all Exchange servers containing IMS.

EXSPI Lotus Notes 
Connector

Executes alarms for Lotus Notes Connector metrics. Deploy on all 
Exchange servers containing the Lotus Notes Connector.

EXSPI News Service Executes alarm metrics for problems detected in the Exchange News 
service. Deploy on all Exchange 5.5 servers containing the Exchange 
News service.

EXCHANGE 2000

EXSPI cc:Mail 
Connector

Executes alarm according to for cc:Mail Connector metrics. 
Deploy on all Exchange servers containing the cc:Mail Connector.

EXSPI Chat Service Monitors the current client connections to the chat community, 
showing anonymous connections, authenticated connections, 
authentication failures, timeouts.

EXSPI Conferencing 
Service 

Monitors current client connections to the server, server load for online 
data and video conferences, and CPU process time of the T.120 MCU 
(multipoint control unit) server. 

EXSPI Instant 
Messaging

Monitors current connections using instant messaging service, current 
subscriptions, and average processor time per instance.

EXSPI IS Virus Scan Exchange SPI monitors the Anti-Virus API performance counters and 
Windows Event Log informing on the possibility of a virus attach.

EXSPI Lotus Notes 
Connector

Executes alarms for Lotus Notes Connector metrics. Deploy on all 
Exchange servers containing the Lotus Notes Connector.

EXSPI NNTP Executes alarm metrics for outbound newsfeed connections that fail. For 
Exchange 2000 servers.
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EXCHANGE 2000

EXSPI Transaction Log Monitors the size in MB of the Exchange transaction logfiles as well as 
the disk space used by the files. When size increases or available disk 
space decreases to specific defined values, messages with warnings 
appear in the message browser.

Group: EXSPI 
Advanced
EXCHANGE 5.5 and 
EXCHANGE 2000

Description

EXSPI End to End 
Message Ping

Alarms on AND collects data for the End to End Message Ping 
policy

EXSPI Event Log 
Warnings/Information

Monitors all warnings and information messages in the Windows 
System Log. Is not typically deployed.

EXSPI Reporter 
Collection

Feeds data into the OpenView data collector for use by OpenView 
reporter.

Group: 
EXSPI Add-Ons Description
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Deploying the Quick Start Policy Group

To receive any information from a managed Exchange server requires that 
the Quick Start policy group for the appropriate version be deployed. This 
policy group is deployed automatically based on the results of the Service 
Discovery. 

The Quick Start policy group contains the most basic definitions and rules 
for scheduling data collecting/graphing, and for generating messages/
alerts.

After Discovery, the version specific policies in the Quick Start group are 
auto deployed. Or, to perform this manually: 

1 In the left pane of the OVO Manager console expand the Policy manage-
ment > Policy groups folders to view policy groups.

2 Open the SPI for Exchange folder and select the correct Exchange 
version: Exchange 2000 or Exchange 5.5. 

3 Open the appropriate Exchange folder, select the EXSPI Quick Start 
policy group, right-click and select Deploy on....

4 In the Deploy policies on... dialog select all nodes by clicking the check 
box next to Nodes, or select individual nodes by clicking the appropriate 
checkbox.
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Deploying Policies from other Policy Groups

In each of the Exchange 5.5 and Exchange 2000 folders are two additional 
policy groups that supplement the Quick Start group:

EXSPI Add-ons policies

• Some policies in the EXSPI Add-Ons policy group require a standard 
Windows domain admin with password to be supplied in order for them to 
perform Active Directory queries, and some can be deployed with no 
additional configuration. Follow the procedure “Adding Domain Admin 
User and Password to a Policy” on page 43 for editing policies in this way. 
Those requiring the domain admin with password are:

— EXSPI Add-Ons > Transaction Log > EXSPI-6.0 1d-Transaction Log

— EXSPI Add-Ons > Transaction Log > EXSPI-6.0 15m-Transaction 
Log

— EXSPI Add-Ons > Transaction Log > EXSPI-6.0 Dc-Instant 
Messaging

— EXSPI Add-Ons > Transaction Log > EXSPI-6.0 Dc-Instant 
Messaging Enabled Users

• EXSPI Add-Ons policies collect data that show how related services, such 
as Lotus notes or Internet Information Services, are performing. Please see 
the section “EXSPI Policy Prerequisites and Descriptions” on page 74 for 
requirements on installing specific policies in the Add-ons group. 

To deploy policies in the Add-ons group

a In the left pane of the OVO Manager console expand the Policy 
management > Policy groups folder to view policy groups.

b Click the plus sign (+) next to SPI for Exchange, or double-click it to 
view Exchange SPI policy groups.

c Double-click EXSPI Add-ons and select an add-on policy, check the 
description in the details pane to verify it is the correct one (double 
click to open and see details if necessary), right-click and select 
Deploy on....
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d In the Deploy on... dialog select all nodes by clicking the check box 
next to Nodes, or select individual nodes by clicking each appropriate 
checkbox.

EXSPI Advanced policies

There are three groups of policies in the EXSPI Advanced policy group:

EXSPI End to End Message Ping policy group 

• These policies enable the Exchange SPI to test network connections 
between Exchange servers, and collect performance data on message 
receipt and delivery. 

To deploy the EXSPI End to End Message Ping policy see the procedure 
outlined in “Configuring EXSPI End to End Message Ping” on page 86. 

EXSPI Event Log Warnings and Information policy group

• The EXSPI Event Log Warnings and Information policies capture Windows 
event log text and are generally meant to be deployed for troubleshooting 
purposes.

EXSPI Reporter Collection policy group

• To deploy EXSPI Reporter Collection policies, please refer to “Using 
Exchange SPI Reports and Graphs” on page 96 in this manual, and the SPI 
for Exchange on-line Help for a listing of all the preconfigured reports 
offered, with detailed descriptions and policy prerequisites.
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Configuring EXSPI End to End Message Ping

Use the EXSPI-End-to End Message Ping policy in the EXSPI Advanced 
policy group to determine SLA performance by sending and receiving 
messages.

Prior to deploying the EXSPI-End-to End Message Ping policy create a 
user account with special admin privileges (see “Creating a User Account 
with Proper Access Permissions” on page 45) and run the tool SPI for 
Exchange > Exchange 2000 (or 5.5) > MBox Config. This tool will 
create an Exchange mailbox accessible to the special user account.

Requirement: When you configure server connections (see “Set Up 
Server Connections to Test Message Delivery/Receipt” on page 88), you 
must start the EXSPI Admin tool EXSPI Ping Config from the OpenView 
management server.

Task 1: Edit the MBOX Config Tool for user password

To edit the MBOX Config tool

1 Click on Tools on the console tree, and expand SPI for Exchange > 
EXSPI 5.5 (or EXSPI 2000). In the details pane on the right you see the 
MBox Config tool.

2 Right click MBOX Config and select Properties. 

3 Select the Target tab. In the Password/Verify Password text boxes enter 
the password assigned to the user account created in  “Creating a User 
Account with Proper Access Permissions” on page 45.

4 Click OK to save changes, and exit.

This policy requires a mailbox on each node where the policy will be 
deployed. 
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Task 2: Create Mailboxes

You must create a mailbox for the user account (in our example MSXSPI), 
on every targeted Exchange server, so that the user can access mailbox 
and folder information. 

To create a mailbox for the user account

1 In the of the OVO Manager console expand the Tools > SPI for 
Exchange > Exchange 5.5 or Exchange 2000 folders.

2 In the details pane on the right, double-click the MBOX Config tool.

3 Select the servers the tool should launch on.

4 Select Launch to start the tool running on the selected nodes.  
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Task 3: Set Up Server Connections to Test Message Delivery/Receipt 

Before deploying the EXSPI End to End Message Ping policy in the 
Advanced group, the servers you want to monitor must be configured. 

To configure the servers

1 Expand the OVO Manager folder and select Policy Management > Pol-
icies grouped by type. 

2 Right-click the ConfigFile policy type and select New > Policy. 

3 In the configfile dialog, click the down-arrow and select exspi.

(By default exspi_config is selected for Sub-Group, and 
exspilink.txt for Filename.)

4 Select the Data tab and click Load Template, which opens the default 
file as shown: 

If you cannot automatically create mailboxes and receive an 
error, try to manually create a mailbox for each Exchange server 
with the prefix MSXSPI and NT hostname. For example, the 
node rosspidb5.rose.hp.com (Internet name) and NT name 
ROSSPIB5 require a mailbox called MSXSPIROSSPIDB5 
with primary NT account MSXSPI.

# Format of the file:
# Src-Svr:Src-MB:::Dest-MB:Timeout:MetSLA:AlmostMetSLA

# Src-Svr = Source Server (required)

# Src-MB = Source Mailbox (optional)
Defaults to ’MSXSPI<host_name>’.

# Reserved = Reserved for future use, leave empty

# Reserved    = Reserved for future use, leave empty

# Dest-MB = Destination Mailbox (required)

# Timeout = Timeout (required)
 (s-seconds, m-minutes, h-hours)
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Examples:

#                EXCH1::::MSXSPIEXCH2:25m:1m:1m

#                EXCH1:MSXSPIEXCH1:::MSXSPIEXCH3:2h:5m:2m

#                EXCH2:MSXSPIEXCH2:::MSXSPIEXCH4:1h:20m:10m

#                EXCH3:MSXSPIEXCH3:::MSXSPIEXCH4:25m:5m:5m

5 Enter information about the servers to replace each entry separated by a 
colon (:). When finished, select Save and Close. 

• Source Server (required) — The server that the ping originates 
from. Each server where Exchange SPI is distributed has the same 
file, so Exchange SPI can parse this file and use all lines where the 
Source Server matches the server where it is run from.

• Source Mailbox (optional) — The mailbox to send the mail from. If 
this is not included, a default account is used “MSXSPI<host_name>” 
where <host_name> is replaced with the name of the server.

• Destination Mailbox (required) — The mailbox to send the ping to. 
This field is usually the only required destination entry.

• Timeout (required) (s-seconds, m-minutes, h-hours) — If a sent 
message does not return in the defined timeout interval, EXSPI logs it 
as a failure and sends a message to the OVO management server. 
Failed messages are tallied in terms of count and percentage within a 
report. The timeout value must be larger than the values for MetSLA 
and AlmostMetSLA so that a returned message can be processed 
using these values. It may have Exceeded SLA even though it has not 
exceeded the timeout interval. A Failed/Timedout message occurs, 

# MetSLA = Met SLA time (require for reports)
 (s-seconds, m-minutes, h-hours)

# AlmostMetSLA = Almost met SLA time (require for reports) 
(s-seconds, m-minutes, h-hours)
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therefore, only when the message does not return before the timeout 
period is exceeded. 

• MetSLA (required for reports) (s-seconds, m-minutes, h-hours) — If 
the round trip time is greater than this value, the message is logged as 
either Almost Met SLA or Exceeded SLA. This value is required if 
data is being sent to the Measurement Data Collector Agent DSI for 
reporting (-l option when running exspi.exe). It is optional if only 
using alarms.

• AlmostMetSLA (required for reports) (s-seconds, m-minutes, h-
hours)  — If the round trip time is greater than the MetSLA value but 
less than or equal to MetSLA plus AlmostMetSLA, the message is 
logged as Almost Met SLA. Otherwise, when the round trip time is 
higher than MetSLA plus AlmostMetSLA, it is logged as Clearly 
Exceeded SLA. This parameter is required if data is being logged to 
the data collection Agent DSI (-l option when running exspi.exe), 
optional if only using alarms. 

Examples:

EXCH1::::MSXSPIEXCH2:25m:1m:1m
Use the default FROM mailbox of MSXSPIEXCH1. Message must return 
within 1 minute to meet the SLA, 2 minutes to almost meet the SLA, and 
at over 25 minutes a failure/timeout is generated.

The minimum timeout value should be set slightly less than 
the collection interval. For example, if the collection interval 
for metric 1002 is 30 minutes (the default), the timeout should 
be set to at least 25 minutes. The logic is that because the 
next measurement occurs only every 30 minutes, you should 
allow up to that amount of time for any messages to return 
before “giving up” and generating a failure. If you keep the 
timeout value within the collection interval and the reply 
message does return, it can be processed as Met, Almost Met, 
or Exceeded as opposed to Failed/Timedout.

Timeout, MetSLA, and AlmostMetSLA values can have 
optional identifiers that denote the measurement units the 
value represents; for example, 4m (4 minutes) 30s (30 
seconds) or 1h (1 hour). The default unit is seconds; for 
example, the entry 4 by default is recognized as 4 seconds.
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EXCH1:MAILBOXEXCH1:::MAILOXEXCH3:2h:5m:2m 
Message must return within 5 minutes to meet the SLA, 7 minutes to 
almost meet the SLA, and at over 2 hours a failure/timeout is generated.

EXCH2:MAILBOXEXCH2:::MAILOXEXCH4:1h:20m:10m
Message must return within 20 minutes to meet the SLA, 30 minutes to 
almost meet the SLA and at over 1 hour a failure/timeout is generated.

Task 4: Set Up EXSPI End to End Message Ping Alarms—Configure Server Pair 
Thresholds

Alarms can be set to occur with metric 1002 (Ping). As you may need to set 
different thresholds for multiple server pairs, some examples are included 
here to clarify the procedure. These examples show the syntax to insert in 
the exspilnk.txt file to set differing thresholds. Metric 1002 sends the 
“FromMailbox,ToMailbox” in the object pattern fields with the following 
definitions:

FromMailbox = FromServer:FromMailbox
ToMailbox    = :ToMailboxl 

Config Entry Object

EXCH1::::MSXSPIEXCH2:25m:1m:1m EXCH1:MSXSPIEXCH1,:MSXSPIEXCH2

EXCH1:MAILBOXEXCH1:::

MAILOXEXCH3:2h:5m:2m

EXCH1:MAILBOXEXCH1,:MAILOXEXCH3

EXCH2:MAILBOXEXCH2:::

MAILOXEXCH4:1h:20m:10m

EXCH2:MAILBOXEXCH2,:MAILOXEXCH4
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Task 5: Modify the Policy to include the user account password

Before deploying the EXSPI End-to-End Message Ping policy, you must 
edit it so that it has access to data on the Exchange Server system. 

To edit the policy:

1 Open the OVO console and expand the Policy Management folder.

Condition Name & 
Type

Condition Object 
Pattern Threshold Explanation

EXSPI-1002.1

+Message on
Matched Condition

EXCH1:MSXSPIEXCH1, 
:MSXSPIEXCH2

120 Threshold condition for ping 
between System EXCH1 and 
mailbox MSXSPIEXCH2 on 
system EXCH2. Object pattern 
is case sensitive.

EXSPI-1002.2

+Message on 
Matched Condition

EXCH1:MSXSPIEXCH1, 
:MSXSPIEXCH3

240 Threshold condition for ping 
between System EXCH1 and 
mailbox MSXSPIEXCH3 on 
system EXCH3. Object pattern 
is case sensitive.

EXSPI-1002.3

-Suppress 
Matched Condition

EXCH1:MSXSPIEXCH1, 
:MSXSPIEXCH2
EXCH1:MSXSPIEXCH1, 
:MSXSPIEXCH3

If the threshold was not 
exceeded for these two system 
pairs, you must suppress the 
message if either of these 
system pairs gets past 1002.1 
or 1002.2.

EXSPI-1002.4

+Message on 
Matched Condition

60 A blank object pattern to catch 
all remaining system pairs.
92



Chapter 4:  Using Exchange SPI Policies, Reports and Graphs
2 In the left pane select Policy groups > SPI for Exchange > Exchange 
5.5 or Exchange 2000 > EXSPI Advanced > EXSPI End-to-End 
Message Ping group.

Figure 51  Location of Exchange 2000 End to End Message Ping policy group 

3 In the right pane right-click the EXSPI-6.0/5.5-End-to-End Message 
Ping policy and select All Tasks > Edit.

4 In the dialog that appears, confirm or enter the user name (in our example 
MSXSPI), check the Specify Password check box, and enter the 
password you have assigned to the user account.

5 Click Save and Close.
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Task 6: Deploy the Configuration File and the Policy

1 In the OVO Manager console expand the folders Policy management > 
Policy groups > SPI for Exchange > Exchange 5.5 / Exchange 2000 
> EXSPI Advanced.

2 In the EXSPI Advanced folder double-click the Advanced policy sub-
group you want to deploy. 

3 In the details pane where all the policies and/or configuration files are 
now listed, select the policies and/or configuration file needed, right-click, 
and select Deploy on....

4 In the Deploy policies on... dialog, select all nodes by clicking the check 
box next to Nodes, or select individual nodes by clicking the adjacent 
checkbox.

Using Exchange SPI in High Availability 
Environments

Exchange SPI can be configured to work in environments where cluster-
aware applications are used. You can use the XML file included with OVO 
(msexchange.apm.xml) to enter information about the cluster-aware 
application. This file is located in the Instrumentation directory.

Monitoring Exchange in Cluster Environments

The Exchange Smart Plug-in includes an XML file 
(msexchange.apm.xml) to be used for monitoring the Exchange 
environment.This file works in conjunction with another file that you 
must create and name: apminfo.xml. Instructions for doing this are 
included in this section, but are covered in more detail under the OVO 
online Help topic: Managing cluster-aware applications.

These two files: the Exchange SPI XML file and the apminfo.xml file, 
allow you to monitor Exchange in a cluster. As a result, when a package is 
moved from one node in a cluster-such as node #1- to another node in the 
same cluster-such as node #2-monitoring would stop on node #1 and start 
on node #2.
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Configuring the XML File

The procedure below describes a scenario where Exchange SPI is enabled 
for monitoring one node in a cluster while remaining disabled for all other 
nodes in that cluster.

Create the apminfo.xml file (which describes cluster instances)

The example below shows Exchange SPI instances for Exchange. The file 
must be named apminfo.xml.

1 Using a text editor, create a file with entries as specified below.

2 In the file, enter MSExchange for the Application Name to match the 
msexchange.apm.xml file.

3 Enter the Instance Name to match the instance name configured in 
Exchange SPI.

Application Name: MSExchange

Instance Name: MSExchange

Example:

<?xml version="1.0" ?>
<APMClusterConfiguration>
<Application>
 </Name>MSExchange</Name>
 <Instance>
 </Name>MSExchange</Name>
 /Package>Instance name used by the cluster software</Package>
</Instance>
</Application>
<APMClusterConfiguration>
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4 Save the completed apminfo.xml file on each node in the cluster in the

directory: 

<installation_directory>/Installed Packages/790C06B4-844E-11D2-972B-
080009EF8C2A/conf/OpC/

Note: 

• The SPI for Exchange software will only monitor Exchange servers in 
cluster environments. 

• Only the Measurement Threshold Policies in the Quick Start folders are 
supported. Data logging, reporting and graphing are not supported. 

Using Exchange SPI Reports and Graphs

Exchange SPI Reports

Exchange SPI report generation requires that you complete the following:

• Deploy the Quick Start policy group for data collection policies (if not 
automatically deployed).

• Configure and deploy Exchange SPI report collection policies.

Deploying the Quick Start policy group

In order to collect data for reports and graphs the General Data Collection 
policies in the Quick Start policy group need to be deployed.

All policies in the Quick Start policy group are deployed automatically 
after discovery. 

To deploy the policies manually, if required:

1 Locate the General Data Collector policies in the Quick Start policy group-
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for the correct Exchange version.

Figure 52  Location of Exchange SPI General Data Collection policies for 
Exchange 2000

2 Select all the policies in this group in the details pane. 

3 Right click, select All Tasks > Deploy on....

4 Select the nodes the policies should be deployed on. 

5 Confirm the selection with OK.
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Configure/Deploy Reporter Collection Policies 

For any Exchange server system on which you would like to receive 
reports, you need to deploy Exchange SPI policies from the EXSPI 
Advanced > EXSPI Reporter Collection group.

Figure 53  Location of Exchange 2000 Reporter Collection policies 

Task 1: Enable Message Tracking 

Exchange provides a message-tracking facility that stores processed 
message information in a log file. This information, which includes sender 
address, recipient addresses, and message size, is collected by the EXSPI-
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<version>Dc-TrackLog Data collection policy, where <version> is 5.5 (for 
Exchange 5.5) or 6.0 (for Exchange 2000). This policy must be deployed to 
the appropriate managed nodes. 

Enabling Message Tracking on Exchange 5.5 Servers

1 Select Start > Programs > Microsoft Exchange > Microsoft 
Exchange Administrator.

2 Expand the site level and Configuration to view selections beneath it.

3 In the details pane double-click Information Store Site Configuration.

4 In the Information Store Site Configuration Properties dialog, check 
Enable message tracking, and select OK.

Figure 54  Information Store Site Configuration dialog 
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5 Repeat steps 3 and 4 for MTA Site Configuration.

Figure 55  MTA Site Configuration dialog 

6  In the left pane select Connections.

7 In the right pane select Internet Mail Service, check the Enable 
message tracking checkbox, and press OK.

Enabling Message Tracking on Exchange 2000 Servers

1 Select Start > Programs > Microsoft Exchange > System Manager.

2 Expand the Administrative Groups to see individual servers.

3 Right-click on the server and select Properties. 

4 In the General tab check Enable message tracking.

5 Repeat steps 3 and 4 for each server.

If the Internet Mail Service connector does not exist, skip the 
following steps.
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Task 2: Edit the MBOX Config Tool for User Password 

See the procedure “Edit the MBOX Config Tool for user password” on page 
86.

Task 3: Create Mailboxes

See the procedure  “Create Mailboxes” on page 87.

Task 4: Modify the EXSPI Reporter Collection Policies to include the user account 
and password

You need to edit each of the EXSPI Reporter Collection policies in the 
EXSPI Advanced policy group, so that Exchange Server system data is 
accessible. The EXSPI General Data Collector policies in the EXSPI Quick 
Start policy group do not need modification.

To edit EXSPI Reporter Collection policies in the EXSPI Advanced group:

1 Open the OVO console and expand the Policy Management folder.

2 In the left pane select Policy groups > SPI for Exchange > Exchange 
5.5 or Exchange 2000 >EXSPI Advanced > EXSPI Reporter 
Collection policy group.

3 In the right pane right-click a Reporter Collection policy and select All 
Tasks > Edit:

• EXSPI-<version>Dc-Exchange Info policy, where <version> is 5.5 
(for Exchange 5.5) or 6.0 (for Exchange 2000). 

• EXSPI-<version>Dc-TrackLog Data collection policy, where 
<version> is 5.5 (for Exchange 5.5) or 6.0 (for Exchange 2000). 

• EXSPI-<version>Dc-Mailbox Data collection policy, where <version> 
is 5.5 (for Exchange 5.5) or 6.0 (for Exchange 2000). 

• EXSPI-<version>Dc-Public IS Sum. Data collection policy, where 
<version> is 5.5 (for Exchange 5.5) or 6.0 (for Exchange 2000). 

• EXSPI-<version>Dc-Mailbox (or Private) IS Sum. Data collection 
policy, where <version> is 5.5 (for Exchange 5.5) or 6.0 (for Exchange 
2000). 

• EXSPI-<version>Dc-Public Folder Data policy, where <version> is 
5.5 (for Exchange 5.5) or 6.0 (for Exchange 2000).
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4 In the dialog that appears, leave the user name, check the Specify 
Password check box, and enter the password you have assigned to the 
user account.

5 Click Save and Close.

6 Repeat these steps for each Reporter Collection policy in the group.

Task 5: Deploy Reporter Collection Policies

1 In the OVO Manager console expand the Policy management > Policy 
groups folders to view policy groups.

2 Open SPI for Exchange > Exchange 5.5 or Exchange 2000 > EXSPI 
Advanced to view the policy groups in the EXSPI Advanced folder.

3 In the EXSPI Advanced folder double-click the Reporter Collection 
policy sub-group. 

4 In the details pane where all the policies are now listed, select the policies, 
right-click, and select Deploy on....

5 In the Deploy policies on... dialog, select all nodes by checking Nodes, 
or select individual nodes by clicking the adjacent check box.

Time Interval before generating Exchange SPI Reports

Exchange SPI reports will not be available until data has been gathered to 
the management server from the managed nodes. This occurs each night, 
so at least one day of activity is needed for the reports to populate. Where 
a report type requires data from a Sat/Sun collection, those reports will 
require a weekend to pass.

Installing Exchange Report Package to Exchange SPI stand alone

Where the Exchange SPI is installed stand alone, there is a component 
that must be installed on the Windows system running Reporter. This 
component establishes the connection between Reporter and OVO.

To install the SPI for Exchange Report Package on the Reporter-installed 
system:

1 Insert disk B7490-13035/15035 of the OVO Windows CD set in the CD-
ROM drive of the system running Reporter.
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2 Run EXSPI-Reporter.msi to install the SPI for Exchange reporter 
package.

3 Check the Reporter status pane to note changes to Reporter configuration.

4 Add group reports by assigning reports as desired.

Exchange SPI Graphs

Exchange SPI comes with a set of preconfigured graphs. They are located 
on the OVO console tree in the Operations Manager > Reports and 
Graphs > Graphs > SPI for Exchange folder. The graphs show 
Exchange 5.5 and Exchange 2000 data, and are organized in the following 
categories:

Information Store 

Users: This graph shows information store user count metrics, for the 
current day.

Delivery: This graph shows hourly metrics for the average delivery times 
of messages to Exchange Server private and public mailboxes.

Transaction Log Disk Space: This graph shows Transaction Log Disk 
Space usage on the Exchange Server.

Messaging

Queues: This graph show Exchange Server queue lengths. 

Newsfeed Volume: This graph shows Exchange Server newsfeed volume. 

MTA Volume: This graph shows Exchange Server Message Transfer 
Agent volume. 

Internet Mail Volume: This graph shows Exchange Server Internet Mail 
Connector volume. 

Internet Mail Queue: This graph shows the Exchange Server Internet 
Mail Service queue count. 

SMTP Volume: This graph show SMTP Volume on the Exchange Server. 
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SMTP Queues: This graph shows SMTP Server queues on the Exchange 
Server.

Mailbox Database

Private Mailbox Volume: This graph shows Exchange Server Private 
Mailbox volume.

Mailbox Usage: This graph shows Exchange Server Mailbox usage.

Public Folder Database

Public Folder Usage: This graph shows Exchange Server Public Folder 
usage.

Public Folder Database: This graph shows Exchange Server Public 
Folder volume.
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Displaying a graph

1 In the console tree, open the folders Graphs > SPI for Exchange.

Figure 56  Location of Exchange SPI Graphs on the console tree.

2 Select a category of graph on the console tree, then select a graph from the 
list in the details pane and double click. 

3 In the Display graph dialog, select desired Exchange servers from the 
Nodes display, and the date range you wish for the graph. Check the box if 
you wish the data for the graph to be periodically updated.

4 Click Finish and the graph displays.

The policies that enable data collection for these graphs are all included in 
EXSPI Quick Start and are deployed automatically after Discovery. 
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5

Customizing Policies and 
Uninstalling the Exchange SPI

This chapter outlines the procedures for:

• Customizing policies and groups of policies

• Uninstalling the Exchange SPI.

Customizing Policies Using the Tag Feature

If you have servers dedicated to specific sites or business units, you may 
find it effective for those servers to have uniquely named Exchange SPI 
policies. In such cases copy default policies into new groups, affix prefixes 
to the original names and include them in the schedule policy that collects 
data during that measurement interval. The procedure below gives you an 
example of how you might do this.

Task 1. Create the New Policy Group 

1 In the OVO console, expand the Policy management > Policy Groups 
folders.
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2 Right-click the folder in which you want to locate the new group and select 
New > Policy Group.

Figure 57  Creating a new policy group

3 Enter the new group name for the folder created and click Enter.
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4 In the console, use Shift+click or Ctrl+click to select the default policies to 
be in the group, right-click and select Copy. 

5 Right-click the new group you just created and click Paste.

6 The copied policy will be pasted into the new Policy group.

7 If you copied an entire group of default policies into the new group, you 
can eliminate those you do not need by right-clicking them and selecting 
Delete.

Task 2: Tag the Policies

To designate these policies as a specific group, use a special prefix

1 Double-click each policy and make any changes to the policy desired. 

2 Select File > Save As. In the dialog that appears enter the special prefix 
followed by a hyphen in front of the default policy name; for example 
EuroSales-EXSPI-6.0 IS Mailbox Average Delivery Time.

Remember to always copy scheduled task policies from the 
default policy group containing the measurement threshold 
policy you are copying to the new policy group. The scheduled 
task policy is necessary for any data collection to occur. 
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Figure 58  Customizing a policy 

3 After saving any renamed policies, double-click the scheduled task policy 
that you copied to the new group together with the other policies. (In the 
example EXSPI-6.0 Id-Dc-Instant Messaging is used.)

4 In the Command* text box at the end of the text, insert the tag (-t) 
parameter and the <prefix>- 
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For example, to ensure data collection for all the policies renamed with 
the prefix EuroSales the Command text box would appear as shown in the 
figure below: 

Figure 59  Example of an edited Command
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5 When finished, rename the scheduled task policy to include the group 
prefix, in this way: 

Select File > Save As and rename the EXSPI-6.0 Id-Dc-Instant 
Messaging scheduled task policy to EuroSales-EXSPI-6.0 Id-Dc-Instant 
Messaging.

Figure 60  Renaming Policy
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The prefix attached to the beginning of each policy in the new group 
makes the policies easy to find in the Policies grouped by type folder in 
the console. Also, creating a new group for the new policies gives you an 
efficient means to deploy them (right-click the group and select All Tasks 
> Deploy on...). Please see the online Help for more details.

Uninstalling Exchange SPI

To uninstall the Exchange SPI, first uninstall all components and policies 
from the managed nodes, then from the management server:

1 Remove Exchange SPI remote console programs.

2 Remove Exchange SPI package from managed nodes.

3 Remove Exchange SPI policies from managed nodes.

4 Remove Exchange SPI policy groups from management server.

5 Remove Exchange SPI tools from management server.

6 Uninstall Exchange SPI programs from the management server

Task 1: Remove Exchange SPI Policies from all Managed Nodes

1 On the OVO console tree, expand the folders HP OpenView > Opera-
tions Manager > SPI for Exchange.

2 Right-click the SPI for Exchange, select All Tasks > Uninstall from...

3 In the Uninstall Policies on dialog, select All Nodes.

4 Click OK.

Task 2: Remove Exchange SPI Policy Groups from the Management Server

1 On the OVO console tree select and expand the folder Policy Groups.

2 Right-click SPI for Exchange and select Delete.

Task 3: Remove Exchange SPI Tools from the Management Server

1 On the OVO console tree right-click Tools and select Configure Tools.

2 In the Configure Tools dialog right-click SPI for Exchange and select 
Delete.
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Task 4: Uninstall Exchange SPI Programs from the Management Server

1 Select Start > Settings > Control Panel.

2 In the Control Panel dialog, double-click Add/Remove Programs. 

3 In the Add/Remove Properties, select the Install/Uninstall tab, select 
HP OpenView <installed_version>.

4 In the Uninstallation dialog select the Smart Plug-in for Exchange 
checkbox, then click Next.

5 Select Yes and Yes To ALL to prompts regarding removal of shared 
components.
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Exchange SPI Fast Start 

A The following is a concise procedure to follow for getting up and running 
with the Smart Plug-in for Exchange:

1 Install the OVO Windows CDs (B7490-13034/15034 and B7490-13035/
15035) and the SPI for Exchange CD (B7490-13036/15036).

2 If you will need the “EXSPI Advanced” functionality, create the Exchange 
SPI domain admin user “MSXSPI”. Follow the procedure “Deploying 
Policies from other Policy Groups” on page 84 in this manual, including 
creating a mailbox with the EXSPI MBoxConfig tool.

3 Modify the policy EXSPI-6.0 Exchange Service Discovery in the 
EXSPI Discovery folder to contain a domain admin user and password 
(see figure below).
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4 In the OVO console tree select Nodes. Right-click, select Configure 
Nodes and check the nodes to manage. Wait about five minutes, as the 
following occurs on the managed nodes, without user intervention:

• The EXSPI-6.0 Exchange Service Discovery and the EXSPI 
Quick Start policies for 2000 servers, and EXSPI-5.5 Exchange 
Service Discovery and the EXSPI Quick Start policies for NT4 and 
2000 servers, are auto-deployed to the newly managed nodes. The act 
of managing the node will cause these policies to be deployed.

• If Exchange is discovered on the newly managed node the Exchange 
topology is determined and stored in WMI. This topology is used to 
populate the Exchange Service Map and SPI for Exchange Views.

• Any events that require operator action are sent to the active message 
browser and the corresponding service map nodes.

5 The SPI for Exchange policies are set up out of the box with low 
thresholds. It is suggested that the operator modify the base line the SPI 
for Exchange policies are based on, to make it appropriate for the 
Exchange base activity. Any modification to a threshold requires that 
those policies are re-deployed.

6 If policies from the EXSPI Advanced policy group are desired, update all 
policies in this group to contain the MSXSPI user name and password, see 
“Deploying Policies from other Policy Groups” on page 84. Configure the 
End-to-End Message Ping policy, see “Configuring EXSPI End to End 
Message Ping” on page 86. Deploy the desired policies of this group to the 
managed node.

7 Deploy the desired EXSPI Add-ons policies to the managed node. For 
Exchange 2000 some policies for monitoring the Instant Messaging and 
Transaction Log services require the MSXSPI user name and password, 
see the online Help for more details. 

The user needs read permissions to the Configuration 
partition (also called configuration name space) of Active 
Directory. There are three partitions: Domain, Configuration 
and Schema. It is not uncommon for each to have different 
security permissions. The discovery process only reads the 
Configuration partition. A domain admin user will have read 
access on this Configuration partition information, if 
permissions have not been modified for the Domain Admin 
User group.
117



Appendix :  Exchange SPI Fast Start
8 The Quick Start folders contain schedule policies that perform the data 
collection/logging work on the managed nodes.

9 All SPI for Exchange graphs populate with data that is maintained on the 
managed node. These graphs are best viewed with 12 to 48 hours of data.

10 Most SPI for Exchange reports populate with Service Reporter data after 
one day. This is due to the fact that the Service Reporter data gathering 
process needs to run at least once. Trend reports require at least three 
days of data gathered from the managed nodes. See the Exchange SPI on-
line Help to understand which schedule policies are required to populate 
which reports. Some Advance Reporter Collection policies only run on 
Saturday/Sunday, so some reports will not have data until after a 
Saturday/Sunday collection is performed.
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accounts, 92

modifying the EXPSI Reporter 
Collection Policies, 101

using MBOX Config Tool to edit, 86
permissions

access, 45
partitions, 117

policies
Adds-ons group, deploying, 84
advanced, 85
creating new group, 107 to 109
customizing, 107 to 113
deploying, 20, 84 to 85
displaying, 23
modifying to include user account 

password, 92
receiving reports, 98
setup, 20
tagging, 109 to 113

Policies grouped by type folder, 25
Policy Groups folder, 24
procedures

Add-ons group, deploying policies, 84
mailboxes, creating, 87 to 88
message tracking, enabling

5.5 servers, 99 to 100
Exchange 2000 servers, 100

Messaging View, seeing, 17 to 21
Organizational View, seeing, 17 to 21
policies

creating a new group, 107 to 109
editing to include user account 

password, 92
tagging, 109 to 113

Quick Start policies, deploying 
manually, 83

Reporter Collection Policies
editing, 101 to 102

Reporter Collection Policies, deploying, 
102

servers, configuring, 88 to 91
user accounts

creating (NT), 47 to 52
creating in W2k/Ex2k, 64 to 69
creating in W2k/EX5.5, 55 to 56
grant access permission in W2k/

EX5.5, 62 to 63
granting access permissions, 52 to 54
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granting permission, W2k/EX2k, 
70 to 72

user password, using MBOX Config Tool 
to edit, 86

Process Monitor, 8
Public Average Delivery Time, 8

Q
Quick Start, deploying policy group, 83

R
Reporter Collection Policies

deploying, 102
Reporter Collection policy group, 85
reports

using, 96

S
server-monitoring capabilities, 7
servers, configuring, 88 to 91
SMTP Queues, 8
Source Mailbox, 89
Source Server, 89
support costs, lowering, 8

T
tag feature, using, 107
tasks, suggested daily, 39
Timeout, 89
tools

removing from management server, 113
using, 27

U
uninstalling, 113 to 114
user accounts

access permissions
granting, 52 to 54
granting in W2k/EX2k, 70 to 72

creating, 45
NT4/EX5.5, 47 to 52
W2k/EX2k, 64 to 69

creating in W2k/EX5.5, 55 to 56
grant access permissions

W2k/EX5.5, 62 to 63
mailboxes, creating, 87 to 88
modifying the EXSPI Report Collection 

Policies to include passwords, 101
password, modifying policy to include, 92
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