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Chapter 1

Getting Started with TransactionVision

TransactionVision is the transaction tracking solution that graphically shows you the 
interaction between all the components of your system. TransactionVision non-
intrusively records individual electronic events generated by a transaction flowing 
through a computer network. More importantly, TransactionVision's patent-pending 
"Transaction Constructor" algorithm assembles those events into a single coherent 
business transaction. 

Graphical analysis of business transactions enable you to:

• Find lost transactions

• Monitor and meet service level agreements

• Improve efficiencies of your business processes

TransactionVision Basics
To understand the tasks required to use TransactionVision, you must understand the 
TransactionVision components, as well as some basic concepts.

Components

TransactionVision consists of three major components:

• Sensors 

• Analyzers 

• TransactionVision Web User Interface
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The following diagram shows the relationship between these components:

Sensors
Sensors collect transactional events from the various applications involved in your 
distributed transactions. Sensors are lightweight libraries or exit programs that are 
installed on each computer in your environment. Each Sensor monitors each call made 
by supporting technologies on that system and compares it against filter conditions. If 
the call matches the filter conditions, the Sensor generates a TransactionVision event 
that contains information about the call. It then forwards the event to the Analyzer by 
placing it on a designated event queue. 

TransactionVision provides the following types of Sensors: 

• The WebSphere MQ Sensor tracks MQI calls. The following supplemental 
Sensors are available for WebSphere MQ:

• The Proxy Sensor correlates business transactions into process that are not 
monitored using the TransactionVision Sensor libraries (for example, events 
between a sensored application and an application running on a system where 
no Sensor is installed such as an external partner system)

• The WebSphere Business Integration Sensor distinguishes the various 
message flows and identifies individual logical transaction paths within WBI.

...

TransactionVision Web User Interface

Analyzer

Sensor Sensor Sensor

Database
Project Tables
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• The MQSeries-IMS Bridge Sensor tracks MQSeries-IMS bridge messages 
rather than the WebSphere MQ API calls made by the calling applications.

• z/OS WebSphere MQ Sensors are provided for tracking MQI API calls in 
the CICS, batch and IMS environments on the IBM z/OS system. In the CICS 
environment, the API crossing exit provided by the CICS adapter for 
WebSphere MQ is used to intercept the MQ API. In the batch and IMS 
environments, the application has to be re-bound with the Sensor to intercept 
MQ API calls.

• The Servlet Sensor tracks servlet methods in a J2EE application server.

• The JMS Sensor tracks WebSphere MQ Java Message Service events from 
standalone Java applications as well as from J2EE application servers.

• The EJB Sensor tracks transactions through business logic within a J2EE 
application server.

• The CICS Sensor collects non-WebSphere MQ CICS events to track transactions 
in a mainframe environment. 

For instructions on installing and configuring Sensors, see the TransactionVision 
Installation and Configuration Guide. For more detailed information about 
TransactionVision Sensors, including which APIs are monitored by each Sensor, see 
the TransactionVision Administrator’s Guide.

In the following diagram, shaded areas represent the parts of a web application for 
which TransactionVision can track events:
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Analyzers
The Analyzer is a service that communicates with Sensors via WebSphere MQ. It 
generates and delivers configuration messages to Sensors by placing them on a 
designated configuration queue. Configuration messages specify Sensor configuration 
information such as the name of the event queue where the Sensor should place event 
messages and data collection filter definitions for the project. 

The Analyzer also retrieves events placed on an event queue by Sensors and processes 
them for display and analysis by the web user interface. It performs the unmarshalling, 
correlation, analysis, and data management functions. 

Web
Client

HTTP
Server

WebSphere MQ

WebSphere MQ

WebSphere MQ

Java
Servlet

WebSphere

WebSphere MQ

Middle Tier Distributed Servers
(AIX, HP-UX, Linux, Solaris, Windows, OS/400)

OS/390 / Z/OS Mainframe

Batch MQ
Tasks

CICS MQ
Tasks

IMS MQ
Tasks

MQ-IMS
Bridge

JMS

or WebLogic
Application
Server

Enterprise
Java Beans

Tasks

JMSApplicationsWBIMB
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Each TransactionVision project is assigned a single host running the Analyzer. Projects 
enable you to easily group and manipulate communication links, data collection filters, 
database schemas, and Analyzers as one entity. When you start a project, the Analyzer 
on the host assigned to the project is started automatically. 

For instructions on configuring and managing the Analyzer, see the TransactionVision 
Administrator’s Guide.

TransactionVision Web User Interface
The TransactionVision web user interface is an enterprise application for IBM 
WebSphere or BEA WebLogic that provides the TransactionVision graphical interface. 
Users and administrators login to the web user interface via a web browser; all 
interaction is provided through HTML pages. The web user interface communicates 
with the Analyzer to provide data collection configuration information such as 
communication links and data collection filters. It also connects to project database 
schemas display project analysis and report results.

TransactionVision Terms and Concepts
To use TransactionVision effectively, you must be familiar with the following terms 
and concepts:

• Projects

• Analysis views

• Transaction types

• Queries

• Reports

• Transaction classification

• Event times

Projects
Event collection projects enable you to easily group and manipulate communication 
links, data collection filters, database schemas, and Analyzers as one entity. An event 
collection project is used by an Analyzer to define the communication links, the data 
collection filters, and the database schema that data will be written into. A project is 
assigned to a single Analyzer host for event analysis. For more information about 
creating and managing projects, see the TransactionVision Administrator’s Guide.
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Analysis Views
TransactionVision provides four different views of event data in a project:

• Component Topology Analysis, which shows the interaction between all 
components such as message queues, programs, and hosts

• Transaction Analysis, which shows the flow of transactions across all programs in 
your system

• Event Analysis, which shows a sequential list of all events in your project database

• Event Details, which shows detailed contents of each event message, such as 
parameter values and message data buffer contents.

Component Topology Analysis
The Component Topology Analysis view graphically displays the interaction between 
all components of your e-business system, including message queues, programs, and 
hosts. Because the web user interface builds this view from data collected during 
program execution, it is an accurate and complete representation of how information 
flows throughout your system. The thickness of the lines between components can be 
set to indicate performance characteristics of your system. Color-coding makes error 
conditions easy to pinpoint at a glance. You can customize the appearance of the 
Component Topology Analysis and print it as a map of your entire e-business system. 
For instructions on using this view, see Chapter 3, “Using the Component Topology 
Analysis View.”
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Transaction Analysis
The Transaction Analysis view correlates events across multiple programs, hosts, and 
operating systems into transactions. Events are correlated into local transactions, which 
are further correlated into business transactions. For instructions on using this view, see 
Chapter 4, “Using the Transaction Analysis View.”
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Event Analysis
The Event Analysis view displays all events in the event database in chronological 
order. Color coding makes it easy to spot events with a warning or error return code at a 
glance. You can limit the events shown to only the events that make up the local or 
business transaction associated with the currently selected event. For instructions on 
using this view, see Chapter 5, “Using the Event Analysis View.”
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Event Details
The Event Details view provides additional information about any event in the Event 
Analysis view. The Event Details view interprets and displays all of the arguments and 
data structure contents associated with the event.. You may also use the Event Details 
view to compare data structure contents of any two events. For instructions on using 
this view, see Chapter 6, “Using the Event Details View.”

Transaction Types
A local transaction groups related events within a single thread of execution. A local 
transaction includes any number of operations performed during the time span of a 
single unit of work. Operations performed within one unit of work are either committed 
or are backed out together, so that the effects of a number of operations all are either 
made permanent (committed) or reversed (backed out) as one atomic group.

A local transaction consists of a set of events that meet all of the following criteria:

• Belong to the same program instance

• Sorted in chronological order

• Confined by a pair of events that signal commitment or back out of a unit of work
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TransactionVision tracks business transactions by relating local transactions in 
different processes or threads (for example, relating an MQPUT in one process to the 

MQGET in a different process). When communication occurs between different local 

transactions, they are considered part of the same business transaction. For example, 
when a client process sends a message to a server process, it will do so in the context of 

a local transaction, and the server receiving the message will similarly do so within a 
second local transaction. The operations performed within these two local transactions, 

both the communication operations that allow the two processes to exchange data as 

well as any other computational operations within these local transactions, are part of 
the same business transaction. 

For instructions on viewing local and business transactions, see Chapter 4, “Using the 

Transaction Analysis View,” and Chapter 5, “Using the Event Analysis View.”

Queries

Queries control which collected events are actually displayed by TransactionVision. 
Queries enable you to zero in on specific events from the project database. For 

example, you may specify that you only want to see MQPUT events with a particular 

message ID. For instructions on creating and editing queries, see Chapter 2, 
“Configuring Queries.”

Reports

Reports provide vertically focused business reporting to specific industries, as well as 

custom business reports and analysis developed to suit your specific requirements. For 

instructions on using the standard reports installed with TransactionVision, see 
Chapter 7, “Using Reports.” For information on creating your own custom reports, see 

the TransactionVision Programmer’s Guide.

Transaction Classification

While TransactionVision correlates related local transactions into business 

transactions, organizations can further customize transaction information by defining 
transaction classes. If classification rules are defined, TransactionVision automatically 

assigns each business transaction to a transaction class. When you run 

TransactionVision reports, you may view report information for any or all transaction 
classes. 
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For example, the Trade project distributed with TransactionVision categorizes business 
transactions based on the following types of trades: Stock, Bond, and Equity. The 
following scorecard report shows performance gauges for three transaction classes as 
well as all unclassified transactions. Unclassified transactions are business transactions 
that do not meet the classification rules for any transaction class.

TransactionVision provides a default classification bean that enables you to defines 
transaction classes without writing a single line of code by performing the following 
steps before collecting events:

1. Enable either the default classification bean.

2. Define classification rules for each class in an XML file.

3. Insert each class and its attributes into a database table.

For instructions on performing these steps or writing a custom classification bean, see 
the TransactionVision Programmer’s Guide.

Event Times
For non-blocking events, the primary event time is the event entry time and the 
secondary event time is the event exit time. For blocking events such as MQGET and 
JMS receive, the primary event time is the entry exit time and the secondary event time 
is the event entry time. This enables TransactionVision to display events in the proper 
sequence. On the Event Analysis view, TransactionVision sorts events by primary 
event time. 
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Starting TransactionVision for Analysis
The TransactionVision web user interface runs in web browser. To start 
TransactionVision for analysis, start your browser and open the URL provided by the 
administrator who installed TransactionVision in your environment. The 
TransactionVision login page appears.

4. Type your user name in the Login field. If you are unsure of your user name, con-
tact the administrator who installed TransactionVision in your environment.

5. Press the Tab key and type your password in the Password field. If you are unsure 
of your password, contact the administrator who installed TransactionVision in 
your environment.

6. Click Login to display your TransactionVision home page. If the same user ID is 
logged in from a different IP address, TransactionVision displays a warning. Click 
Yes to continue logging in.

Browser Security Settings

For the TransactionVision user interface to function properly, you must configure your 
browser security settings to enable it to run the Java and SVG plug-ins used by 
TransactionVision.

To verify or change browser security settings in IE6, perform the following steps:

1. In your browser window, choose Tools > Internet Options. The Internet Options 
dialog opens.



Chapter 1 • Getting Started with TransactionVision
Starting TransactionVision for Analysis

TransactionVision User’s Guide 13

2. On the Security tab of the Internet Options dialog, click the icon for the zone for 
the server running TransactionVision and click Custom Level. The Security Settings 
dialog opens.

3. Scroll to the Run ActiveX controls and plug-ins setting and click the Enable radio 
button.

4. Click OK.

Important! If the server running TransactionVision is in the Internet zone, you may wish to add it 
to the Trusted Sites zones instead. By default, the Trusted Sites zone has all the 
necessary security settings for TransactionVision to function properly, and you do not 
have to enable ActiveX controls and plug-ins for the entire Internet zone.

Automatic Login
Automatic login may be enabled with cookie files. See the TransactionVision 
Administrator’s Guide for instructions on enabling this automatic login method. If this 
automatic login method is enabled, a Remember Login? checkbox also appears on the 
Login page. Check it to save your user name and password so that you will not have to 
enter them the next time you login. 

Important! To use automatic login, cookies must be enabled for your web browser. Also, you must 
logout from your TransactionVision session by closing your browser window rather 
than clicking Logout.
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Session Timeout
A session is your interaction with TransactionVision from the time you log into the 
TransactionVision WebSphere application until you logout, either by clicking the 
Logout button or closing the TransactionVision browser window.

For security purposes, the TransactionVision sessions expire if there is no activity on 
TransactionVision pages for a certain amount of time. When a session expires, 
TransactionVision logs you out. One minute before logging you out, TransactionVision 
displays a message notifying you that the current session is about to expire and asking 
whether to continue working with TransactionVision. Click Yes to continue working; 
click No or do nothing to end your session. For instructions on setting the session 
timeout period, see the TransactionVision Administrator’s Guide.

The TransactionVision Home Page
When you login to TransactionVision, the TransactionVision home page is displayed. 

Menus 
All TransactionVision user and administrator operations can be performed by selecting 
the appropriate menu item. The following menus are available:

Menu Description

Home Displays your TransactionVision home page.

Views Provides access to the Component Topology Analysis, Transac-
tion Analysis, and Event Analysis views. See Chapters 3 
through 5 of this guide for instructions on using these views.



Chapter 1 • Getting Started with TransactionVision
The TransactionVision Home Page

TransactionVision User’s Guide 15

User Information
The User Information area lists the user name you are logged on as. It also lists the date 
and time of your last logon.

Projects
The Projects area lists all TransactionVision projects that you have access rights to use 
for analysis. For each project, the project name, status, and optional description are 
listed.

Click the circle to the left of a project name to make it the active project for your 
session. When you display the Component Layout Analysis, Transaction Analysis, or 
Event Analysis views, the views are created with data from the active project.

Current Project Provides project status information as well as information about 
scheduled jobs, communication links, data collection filters, and 
queries used by the project. For instructions on using queries, 
see Chapter 2 of this guide. For information about scheduled 
jobs, data collection filters and communication links, see the 
TransactionVision Administrator’s Guide.

Administration Provides commands for managing projects, jobs, Analyzers, 
communication link templates, and database schemas. For more 
information about these topics, see the TransactionVision 
Administrator’s Guide. This menu is only visible if you have 
access rights to perform administrative operations. For more 
information about user access rights, see the TransactionVision 
Administrator’s Guide.

Reports Displays the Reports page, which provides links to all reports 
for which you have the correct access rights. For instructions on 
using the standard reports installed with TransactionVision, see 
Chapter 7 of this guide. For information about creating custom 
reports, see the TransactionVision Programmer’s Guide.

Logout Ends your current TransactionVision session and displays the 
Login page. 

Help Provides access to online help, documentation, version informa-
tion, and links to support information on Bristol’s web site.

Menu Description
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Click the Projects link to display more detailed information about the active project.

Queries
The Queries area lists all available queries for the active project. For each query, the 
query name and optional description is listed.

Click the circle to the left of a query name to make it the active query for your project. 
When you display the Component Layout Analysis, Transaction Analysis, or Event 
Analysis views, the views are created with data from the active project that meets the 
active query criteria.

Click the Queries link to display more detailed information about available queries.

Recently Viewed Reports
The Recently Viewed Reports area lists TransactionVision the reports most recently 
viewed by the current user. Click a report name to access it. Click the Recently Viewed 
Reports link to display a list of all available reports and saved results for each.

Quitting TransactionVision
To end your TransactionVision session, either click Logout, close the TransactionVision 
browser window, or open a web page from a different URL. 

Quick Tour
To get a better idea of how TransactionVision helps you identify problems, let’s look at 
some examples of how you might use TransactionVision.

These examples use the Trade sample shipped as part of the TransactionVision web 
user interface package. On your TransactionVision home page, select Trade as your 
current project.

Important! If this project does not appear on your TransactionVision home page, see the 
TransactionVision Administrator’s Guide for instructions on installing and importing it.

Tracking Messages with TransactionVision
Based on the information collected by TransactionVision, you can pinpoint exactly 
where a message is at any point in time. This information includes criteria such as 
which application has the message, which host it is running on, or even which queue is 
currently holding the messages. 
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Choose the Views > Transaction Analysis menu item to open the Transaction Analysis 
view.

This view shows the progress of the business transaction involving a single message. 
Each icon represents a local transaction. The icon label shows the name of the program 
performing the transaction and the time in milliseconds required to complete the local 
transaction. 

The edge label shows the sequence of local transactions within the business 
transaction. Choose the Edge > Show Transaction Times menu item to add the exit time 
for the MQPUT/MQPUT1 and MQGET calls between the local transactions to the 
edge label, as shown in the following example:

With this view, you can identify the program and technology controlling a message at 
any time.

To view additional information, such as which queue the message is on at any time, 
choose the Switch View > Event Analysis View. The Event Analysis view shows more 
detailed information about the individual events in this business transaction.

To view the JMS class and EJB name, click Options to display the Event Analysis 
Options page:
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Select JMS Class and EJB Name in the [All Available Columns] list and click the right 
arrow to move them to the [All Selected Columns] list, and then click Finish. The Event 
Analysis view should look like the following:
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With this view, you can trace the API calls made by each program in this transaction.

To see changes made to the message data during processing, check the boxes next to 
the first MQGET event and the last MQPUT event for DataFlowEngine, then click 
Compare. The Event Details view opens to provide a side-by-side comparison of these 
events:
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Note that the message data for the final MQPUT shows a status of “Executed.”

In this example, we traced a complete and successful business transaction; you can use 
the same steps with a failed or incomplete business transaction to find problems 
quickly. There are number of ways to identify failed transactions:

• In the Component Topology Analysis view, choose Edge > Edge Color Coding > 
Errors and Warnings to cause TransactionVision to display error and warning event 
paths in red.

• Create a query to view only events with a WebSphere MQ completion code, 
servlet status code, or JMS status code indicating a failure or warning. Use this 
query with the Event Analysis view to identify errors.

Another way to analyze transactions is to use a transaction analysis report. Click 
Reports to display the Reports page:
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Under Reports, click Where are my transactions? TransactionVision displays the 
Transaction Tracking Report.

Specify all time periods and click Generate Report. TransactionVision creates a report 
showing information about all transactions that meet the report parameters:



Chapter 1 • Getting Started with TransactionVision
Quick Tour

22 TransactionVision User’s Guide

To view more detailed information about a particular transaction, click its Transaction 
Class link. The Transaction Details page opens. This page provides three tables of 
information:

• Summary: Provides the Business Transaction ID as well as other information 
specified in the transaction definition.

• Transaction Flow: Provides information about the local transactions that make up 
the business transaction. This table also shows message flows and control flows 
that originate with each local transaction.

• Message Flow: Shows the flow of messages between local transactions within the 
business transaction.
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To view details for a particular message, click its Latency link in the Message Flow 
table. TransactionVision displays the origin and destination message in the Event 
Details view:
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This view shows all the data structure contents for the events in a message flow, 
including the contents of the user data buffer.

Performance Analysis
You can also use TransactionVision analysis views to analyze the transaction 
performance for your system. To get started, return to your TransactionVision home 
page and select the default query for the trade project.

Next, choose Views > Component Topology Analysis, click Switch to Dynamic Mode and set 
the zoom level to 100%. To identify potential performance bottlenecks, choose Edge > 
Edge Widths > Message Call Count.
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In this view, edge widths reflect the number of put and get calls between components. 
Choose Edge > Min/Avg/Max Latency Times to add performance information to the edge 
labels:
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Use this information to identify areas where latency may be too high.

You can also use the Transaction Analysis view to analyze performance of individual 
local and business transactions. Choose Views > Transaction Analysis to open this view:
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In the default view, the labels for the local transaction icons show the time in 
milliseconds required to complete each local transaction. To access more performance 
information, choose Edge > Show Transaction Times to show the times for the put and get 
calls between local transactions. Choose Edge > Show Latency to show the number of 
milliseconds between the exit times of the put and get calls between the local 
transactions.
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Hint: If you cannot read the edge labels easily, select them and move them above or 
below the edges.

You can also use reports to monitor and analyze performance. To analyze performance 
of WebSphere MQ components, click Reports to display the Reports page and click the 
How are my WebSphere MQ components performing? link. TransactionVision displays the 
WebSphere MQ Statistics Report page. 

Choose All Time Periods and click Generate Report. TransactionVision displays a table 
showing the number of applications interacting, average latency, and number of put, 
get, and open calls for each queue.

Similarly, you can click the How are my Application Server components performing? link on 
the Reports page to run the Application Server Statistics Report. This report shows the 
call count and average latency for each EJB method and servlet.



Chapter 1 • Getting Started with TransactionVision
Quick Tour

TransactionVision User’s Guide 29

To view performance information for your entire system, return to the Reports page 

and click How is my IT infrastructure performing? Click Generate Report to generate a report 

showing an overview of performance for transactions, application servers, WebSphere 

MQ components, and JMS components.

CICS Transactions

In addition to the trade sample, TransactionVision provides a sample called account. 

This sample has add, display, delete, and update commands to a CICS VSAM file 

through 3270 terminal input and query commands to the VSAM file from a transaction 

invoked by the WebSphere MQ-CICS bridge in response to WebSphere MQ messages 

on the bridge request queue.

On your TransactionVision home page, select account as your current project and 

choose Views > Component Topology Analysis to display the Component Topology 

Analysis for this project:

This view shows icons specific to CICS events, such as transactions rather than 

applications, temporary storage (TS) and transient data (TD) queues, and files.
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In a CICS environment, you may want to use a query to limit displayed events to file 
I/O events. To modify your current query, choose Current Project > Queries. 
TransactionVision displays the current query. 

To modify the query, click Edit Query. In the Criteria for drop-down list, choose CICS. 
Under the CICS options, click File Name. Check the ACCTFIL and ACCTIX filenames 
and click Finish.

To view information about CICS events in the Event Analysis view, you’ll need to 
modify the Event Analysis options. First, choose Views > Event Analysis to display the 
Event Analysis view. Click Options to open the Event Analysis Options page. 
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In the Event Analysis Columns area, check Common and OS390 CICS, and then click 
Finish. The Event Analysis view then displays columns specific to CICS events.
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You can also use TransactionVision reports to monitor the performance of CICS 
transactions. Choose Reports to display the TransactionVision Reports page, and click 
How did my transactions perform previously? TransactionVision displays the Transaction 
Scorecard settings:

Click Generate Report to create a report showing average transaction performance for 
all transaction classes over all time periods recorded in the project:
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Contacting Bristol Support
If you encounter a problem using TransactionVision, contact Bristol Support by any of 
the following methods:

• TransactionVision: Choose the Help > Bristol Support menu item. From the 
submenu, you may open the Bristol Support home page, open the 
TransactionVision knowledgebase, or open a problem report form.

• Web: http://www.bristol.com/support

• Email: support@bristol.com

• Phone: 203-798-1007 Press 3 (US & Far East)
or +31-33-450-5050 (Europe, Africa, and Middle East) 
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Chapter 2
Configuring Queries

Queries control which events in the project database are actually displayed in the 
TransactionVision views. Query conditions such as Hosts, Queue Managers, Programs, 
Time, and APIs enable you to restrict displayed events to those you need to identify for 
analysis or to resolve a problem. Only events that meet the selected filter conditions are 
displayed by TransactionVision.

Queries are created within each project definition, and are not shared between projects. 
You may create any number of queries for a project, but only one query may be active 
at any time.

Choose an Active Query
Your home page lists the queries already created for the current project. This list shows 
the query name and optional description. Click the radio button to the left of the query 
name to make it the active query for your project. The next time you display the 
Component Topology Analysis, Transaction Analysis, or Event Analysis view, only 
events that match all query conditions are used to create the view.
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If you need more information about query definitions before choosing one, click the 
Queries link or choose the Current Project > Queries menu item. The Project Queries page 
appears.

Click to view
Project Queries

page.

Click to make
this query

active.
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This view displays the query conditions for each query. Click the radio button next to a 
query name to make it the active query.

Add a New Query
To add a new query to a project, perform the following steps:

1. On the Project Queries page, click New Query... to display the Add Query page.

2. Enter the query name. This name is used in the list of queries on your Transaction-
Vision home page and the Project Queries page. It is also displayed on the Compo-
nent Topology Analysis, Transaction Analysis, and Event Analysis views.

3. Enter a brief description of the query (optional). This description is included in the 
list of queries on your TransactionVision home page.

4. Click Next> to display the Add/Edit Criteria page.

The left side of the page lists all query conditions that you may change. The right 
side shows the setting for the currently selected criteria. 
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5. Click the criteria category name on the left side for the condition that you wish to 
change from the default value and make desired changes on the right side of the 
page. See “Query Conditions” later in this chapter for instructions on setting crite-
ria for each condition.

6. Click Set Criteria to save your settings for the current category. To clear changes for 
the current category, click Clear Criteria. To reset all categories to the default crite-
ria, click Reset All Criteria.

7. On the top left corner, there is a technology drop-down box to switch between 
groups of different technologies. Note that there is a checkbox on the left side of 
the box, which indicates whether querying on the given technology is enabled or 
not. Clicking on this checkbox will toggle the status.

8. When all query criteria are set, click Finish. 
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Edit a Query
Perform the following steps to edit a query for a project:

1. On the Project Queries page, select the query you wish to edit and click Edit Query... 
to display the Add/Edit Criteria page.

The left side of the page lists all filter conditions that you may change. The right 
side shows the setting for the currently selected criteria. 

2. Click the criteria category name on the left side for the condition that you wish to 
change and make desired changes on the right side of the page. See “Query Condi-
tions” later in this chapter for instructions on setting criteria for each condition.

3. Click Set Criteria to save your settings for the current category. To clear changes for 
the current category, click Clear Criteria. To reset all categories to the default crite-
ria, click Reset All Criteria.
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4. On the top left corner, there is a technology drop-down box to switch between 
groups of different technologies. Note that there is a checkbox on the left side of 
the box, which indicates whether querying on the given technology is enabled or 
not. Clicking on this checkbox will toggle the status.

5. When all query criteria are set, click Finish. 

Deleting a Query
To delete a query, select it on the Project Queries page and click Delete Query. 

Optimizing Query Performance
To improve the performance of queries and views, include only those technologies that 
your query uses. For example, if your query only includes WebSphere MQ criteria, say 
a WebSphere MQ object, then disable all other technologies except WebSphere MQ to 
make your query faster. To disable a technology, clear the checkbox, next to the combo 
box, on the left side of the query page.

For most criteria, TransactionVision uses a database lookup table, which stores a set of 
predefined key values along with event IDs. However, it uses a linear search for the 
User Buffer Data, WebSphere MQ MQI Broker, and WebSphere MQ MQI Message 
Flow Name criteria. Although linear searching enhances query capabilities, it reduces 
query performance. If you include these criteria in your query, query performance will 
be degraded. To minimize the impact on query performance, try not to use these criteria 
together in the same query.

Another drawback of linear searches is that the resulting views would not know the 
number of events that match the query conditions. This results in limited page 
navigation capabilities in the TransactionVision web interface since the number of 
events and result pages is unknown. For example, after running a query that contains a 
query condition for event User Buffer data, the Event Analysis view would show page 
forward and backward options, but would not provide the number of events, the 
number of event pages, or controls to navigate to a particular page.

Query Conditions
The left side of the Add/Edit Criteria page lists all the criteria categories for queries. 
Only events that match the criteria for each category are displayed in the 
TransactionVision views.
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Criteria For

Select the technology for which you wish to specify query criteria from the drop-down 
list. You may specify criteria that apply to all technologies, or you may specify criteria 
specific to the CICS, BTTrace, EJB, JMS, Servlet, WebSphere MQ, or WebSphere MQ 
IMS Bridge technologies. 

Check the “Criteria for” box for the selected technology to include events for the 
selected technology in your query results, or clear the box to exclude events for the 
selected technology from your query results. For example, to include only JMS events, 
clear the checkbox for all other technologies.

Common Options:

The common options apply to all technologies. However, if you specify a criteria for 
All Technologies, you may specify a different criteria for an individual technology. The 
setting for the individual technology overrides the setting for all technologies. For 
example, suppose you select All Hosts for All Technologies, but on the Host page for 
the JMS technology, you may select only the host Host1. JMS events originating on 
Host1 and other technology events originating on any host all match the query criteria.

Event Time

1. Select whether to Include or Exclude events whose primary event time meets the 
specified event time criteria.
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2. Select the matching criteria. If you choose “in a time frame from”, you may enter a 
beginning and ending date and time for the time frame. For all other matching cri-
teria, you will enter a single date and time.

3. Select wether the criteria should be Absolute, in which case you will enter a spe-
cific date and time, or Relative, in which case you will enter the time relative to the 
current time.

4. Specify the desired time. For absolute times, enter the date and time. Click the cal-
endar icon to select a date from the calendar. For relative times, enter the number 
of hours and minutes before the current time.

5. Select the desired time zone. Both the Event Analysis and Transaction Analysis 
views provide timestamp information for events. The timestamp for all events is 
recorded in Greenwich Mean Time, but all times are displayed in local time. 

Host

1. Select whether to Include or Exclude selected hosts in the query criteria. 

2. Check the box next to each host you want to include specifically in the query crite-
ria, or check the box next to Select All Host to include all hosts in the query crite-
ria. The host list is generated from events collected in the project database. 

Program/Servlet/EJB

1. Select whether to include or exclude events from selected programs, servlets, or 
EJBs. 
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2. Check the box next to each program, servlet, or EJB you want to include specifi-
cally in the query criteria, or check the box next to Select All Program/Servlet/EJB 
to include all programs, servlets, and EJBs in the query criteria. The program/serv-
let/EJB list is generated from events collected in the project database. 

User Buffer Data

1. Click the appropriate radio button to indicate whether the specified user data is in 
binary string or normal string format and enter the buffer data. For normal string 
format, select the correct code page. 

2. To specify an exact location for the specified buffer data, enter the number of bytes 
from the start of the user buffer in the Offset field and the number of bytes in the 
Length field. If you do not specify a buffer displacement, an event will match the 
criteria if the specified user data appears anywhere within the user buffer.

Important! TransactionVision uses a linear search for the User Buffer Data criteria. Although 
linear searching enhances query capabilities, it reduces query performance. If you 
include this criteria in your query, query performance will be degraded. To minimize 
the impact on query performance, try not to use this criteria together with the other 
linear search criteria (WebSphere MQ MQI Broker and WebSphere MQ MQI Message 
Flow Name) in the same query.

BTTrace Criteria:

The following options are only available when BTTrace is the current “Criteria For:” 
technology.
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API

1. Select whether to Include or Exclude events for selected BTTRACE APIs. 
Applications may use the BTTRACE function provided by the Sensor library to 
send user-defined trace messages to the Analyzer.

2. Check the box next to each API you want to include specifically in the query crite-
ria, or check the box next to Select All API to include all BTTRACE APIs in the 
query criteria. For more information about BTTRACE APIs, see the Transaction-

Vision Administrator’s Guide.

Severity

1. Select whether to Include or Exclude events for selected BTTRACE severity 
levels. Applications may use the BTTRACE function provided by the Sensor 
library to send user-defined trace messages to the Analyzer.

2. Check the box next to each severity you want to include specifically in the query 
criteria, or check the box next to Select All Severity to include all BTTRACE 
severity levels in the query criteria. For more information about BTTRACE sever-
ity levels, see the TransactionVision Administrator’s Guide.

CICS Criteria:

The following options are only available when CICS is the current “Criteria for” 
technology.
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API

1. Select whether to Include or Exclude events for selected APIs.

2. Check the box next to each API you want to include specifically in the query crite-
ria, or check the box next to Select All API to include all APIs in the query criteria.

API Type

1. Select whether to Include or Exclude events for selected API types.

2. Check the box next to each API type you want to include specifically in the query 
criteria, or check the box next to Select All API Type to include all API types in 
the query criteria. 

File Name

1. Select whether to Include or Exclude events for selected file names.
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2. Check the box next to each file name you want to include specifically in the query 
criteria, or check the box next to Select All File Name to include all file names in 
the query criteria. The list of file names is generated from events collected in the 
project database.

Response Code

1. Select whether to Include or Exclude events for selected response codes.

2. Check the box next to each response code you want to include specifically in the 
query criteria, or check the box next to Select All Response Code to include all 
response codes in the query criteria. 

SYSID

1. Select whether to Include or Exclude events for selected SYSID values.

2. Check the box next to each SYSID you want to include specifically in the query 
criteria, or check the box next to Select All SYSID to include all SYSID values in 
the query criteria. The list of SYSID values is generated from events collected in 
the project database.

TD Queue Name
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1. Select whether to Include or Exclude events for selected transient data (TD) queue 

names.

2. Check the box next to each TD queue name you want to include specifically in the 

query criteria, or check the box next to Select All TD Queue Name to include all 

TD queue names in the query criteria. The list of TD queue names is generated 

from events collected in the project database.

TS Queue ID

1. Select whether to Include or Exclude events for selected temporary storage (TS) 

queue IDs.

2. Check the box next to each TS queue ID you want to include specifically in the 

query criteria, or check the box next to Select All TS Queue ID to include all TS 

queue IDs in the query criteria. The list of TS queue IDs is generated from events 

collected in the project database.

Terminal ID

1. Select whether to Include or Exclude events for selected terminal IDs.

2. Check the box next to each terminal ID you want to include specifically in the 

query criteria, or check the box next to Select All Terminal ID to include all termi-

nal IDs in the query criteria. The list of terminal IDs is generated from events col-

lected in the project database.
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Transaction ID

1. Select whether to Include or Exclude events for selected transaction IDs.

2. Check the box next to each transaction ID you want to include specifically in the 
query criteria, or check the box next to Select All Transaction ID to include all 
transaction IDs in the query criteria. The list of transaction IDs is generated from 
events collected in the project database.

EJB Criteria:
The following options are only available when EJB is the current “Criteria For:” 
technology.

Application Server

1. Select whether to Include or Exclude events for selected application servers.

2. Check the box next to each application server you want to include specifically in 
the query criteria, or check the box next to Select All Application Server to include 
all application servers in the query criteria. The list of application servers is gener-
ated from events collected in the project database.
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EJB Application

1. Select whether to Include or Exclude events for selected EJB applications.

2. Check the box next to each EJB application you want to include specifically in the 
query criteria, or check the box next to Select All EJB Application to include all 
EJB applications in the query criteria. The list of EJB applications is generated 
from events collected in the project database.

EJB Name

1. Select whether to Include or Exclude events for selected EJB names.

2. Check the box next to each EJB name you want to include specifically in the query 
criteria, or check the box next to Select All EJB Name to include all EJB names in 
the query criteria. The list of EJB names is generated from events collected in the 
project database.
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EJB Method

1. Select whether to Include or Exclude events for selected EJB methods.

2. Check the box next to each EJB method you want to include specifically in the 
query criteria, or check the box next to Select All EJB Method to include all EJB 
methods in the query criteria. The list of EJB methods is generated from events 
collected in the project database. 

JMS Criteria:
The following options are only available when JMS is the current “Criteria For:” 
technology.

Web Application

1. Select whether to Include or exclude Events for selected web applications.

2. Check the box next to each web application you want to include specifically in the 
query criteria, or check the box next to Select All Web Application to include all 
web applications in the query criteria. The list of web applications is generated 
from events collected in the project database.
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Class

1. Select whether to Include or Exclude events for selected JMS classes.

2. Check the box next to each JMS class you want to include specifically in the query 
criteria, or check the box next to Select All Class to include all classes in the query 
criteria. The list of classes is generated from events collected in the project data-
base.

Method

1. Select whether to Include or Exclude events for selected JMS methods.

2. Check the box next to each JMS method you want to include specifically in the 
query criteria, or check the box next to Select All Method to include all methods in 
the query criteria. The list of methods is generated from events collected in the 
project database.

Connection Name

1. Select whether to Include or Exclude events for selected connection names.
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2. Check the box next to each connection name you want to include specifically in 
the query criteria, or check the box next to Select All Connection Name to include 
all connection names in the query criteria. The list of connection names is gener-
ated from events collected in the project database.

Topic

1. Select whether to Include or Exclude events for selected topics.

2. Check the box next to each topic you want to include specifically in the query cri-
teria, or check the box next to Select All Topic to include all topics in the query cri-
teria. The list of topics is generated from events collected in the project database.

JMS Queue

1. Select whether to Include or Exclude events for selected queues.

2. Check the box next to each queue you want to include specifically in the query cri-
teria, or check the box next to Select All JMS Queue to include all queues in the 
query criteria. The list of queues is generated from events collected in the project 
database.

WebSphere MQ Queue Manager
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1. Select whether to Include or Exclude events for selected queue managers.

2. Check the box next to each queue you want to include specifically in the query cri-
teria, or check the box next to Select All WebSphere MQ Queue Manager to 
include all queue managers in the query criteria. The list of queue managers is gen-
erated from events collected in the project database.

WebSphere MQ Queue

1. Select whether to Include or Exclude events for selected WebSphere MQ queues.

2. Check the box next to each queue you want to include specifically in the query cri-
teria, or check the box next to Select All WebSphere MQ Queue to include all 
queues in the query criteria. The list of queues is generated from events collected 
in the project database.

Data Length

1. Select whether to Include or Exclude events for selected data lengths.

2. Select the matching criteria for the selected data length. Choices include less than, 
less than or equal to, equal to, not equal to, greater than or equal to, or greater than.

3. Enter the desired data length in bytes.



Chapter 2 • Configuring Queries
Query Conditions

54 TransactionVision User’s Guide

Exception Code

1. Select whether to Include or Exclude events for selected exception codes.

2. Check the box next to each exception code you want to include specifically in the 
query criteria, or check the box next to Select All Exception Code to include all 
exception codes in the query criteria. The list of exception codes is generated from 
events collected in the project database.

Servlet Criteria:
The following options are only available when Servlet is the current “Criteria For:” 
technology.

Web Application Server

1. Select whether to Include or Exclude events for selected application servers.

2. Check the box next to each application server you want to include specifically in 
the query criteria, or check the box next to Select All Application Server to include 
all application servers in the query criteria. The list of application servers is gener-
ated from events collected in the project database.

Web Application
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1. Select whether to Include or Exclude events for selected web applications.

2. Check the box next to each web application you want to include specifically in the 
query criteria, or check the box next to Select All Web Application to include all 
web applications in the query criteria. The list of web applications is generated 
from events collected in the project database.

Method

1. Select whether to Include or Exclude events for selected servlet methods.

2. Check the box next to each servlet method you want to include specifically in the 
query criteria, or check the box next to Select All Servlet Method to include all 
servlet methods in the query criteria. The list of servlet methods is generated from 
events collected in the project database. 

Status Code

1. Select whether to Include or Exclude events for selected status codes.

2. Check the box next to each status code you want to include specifically in the 
query criteria, or check the box next to Select All Status Code to include all status 
codes in the query criteria. The list of status codes is generated from events col-
lected in the project database.
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Response Data Length

1. Select whether to Include or Exclude events for selected data response lengths.

2. Select the matching criteria for the selected data length. Choices include less than, 
less than or equal to, equal to, not equal to, greater than or equal to, or greater than.

3. Enter the desired data length in bytes.

WebSphere MQ Options
The following options are only available when WebSphere MQ is the current “Criteria 
For:” technology.

User Name

1. Select whether to Include or Exclude events with selected user names.

2. Check the box next to each user name you want to include specifically in the query 
criteria, or check the box next to Select All User Name to include all user names in 
the query criteria. The user name list is generated from events collected in the 
project database.

OS/390 Job Name

1. Select whether to Include or Exclude events for selected OS/390 job names.

2. Check the box next to each job name you want to include specifically in the query 
criteria, or check the box next to Select All OS390 Job Name to include all job 
names in the query criteria. The list of job names is generated from events col-
lected in the project database. 
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OS/390 Job Step

1. Select whether to Include or Exclude events for selected OS/390 job steps.

2. Check the box next to each job step you want to include specifically in the query 
criteria, or check the box next to Select All OS390 Job Step to include all job steps 
in the query criteria. The list of job steps is generated from events collected in the 
project database. 

OS/390 CICS SYSID

1. Select whether to Include or Exclude events for selected OS/390 CICS SYSIDs.

2. Check the box next to each CICS SYSID you want to include specifically in the 
query, or check the box next to Select All OS390 CICS SYSID to include all CICS 
SYSIDs the query criteria. The list of CICS SYSIDs is generated from events col-
lected in the project database. 

OS/390 CICS Transaction

1. Select whether to Include or Exclude events for selected OS/390 CICS 
transactions.

2. Check the box next to each CICS transaction you want to include specifically in 
the criteria, or check the box next to Select All OS390 CICS Transaction to include 
all CICS transactions in the query criteria. The list of CICS transactions is gener-
ated from events collected in the project database. 



Chapter 2 • Configuring Queries
Query Conditions

58 TransactionVision User’s Guide

OS/390 IMS Region Type

1. Select whether to Include or Exclude events for selected OS/390 IMS region types.

2. Check the box next to each IMS region type you want to include specifically in the 
query criteria, or check the box next to Select All OS390 IMS Region Type to 
include all IMS region types in the query criteria. The list of IMS region types is 
generated from events collected in the project database. 

OS/390 IMS Region Identifier

1. Select whether to Include or Exclude events for selected OS/390 IMS region 
identifiers.

2. Check the box next to each IMS region identifier you want to include specifically 
in the query criteria, or check the box next to Select All OS390 IMS Region Iden-
tifier to include all IMS region identifiers in the query criteria. The list of IMS 
region identifiers is generated from events collected in the project database. 

OS/390 IMS Identifier

1. Select whether to Include or Exclude events for selected OS/390 IMS identifiers.

2. Check the box next to each IMS identifier you want to include specifically in the 
query criteria, or check the box next to Select All OS390 IMS Identifier to include 
all IMS identifiers in the query criteria. The list of IMS identifiers is generated 
from events collected in the project database. 



Chapter 2 • Configuring Queries
Query Conditions

TransactionVision User’s Guide 59

OS/390 IMS Transaction

1. Select whether to Include or Exclude events for selected OS/390 IMS transactions.

2. Check the box next to each IMS transaction you want to include specifically in the 
query criteria, or check the box next to Select All OS390 IMS Transaction to 
include all IMS transactions in the query criteria. The list of IMS transactions is 
generated from events collected in the project database. 

OS/390 IMS PSB

1. Select whether to Include or Exclude events for selected OS/390 IMS PSBs.

2. Check the box next to each IMS PSB you want to include specifically in the query 
criteria, or check the box next to Select All OS390 IMS PSB to include all IMS 
PSBs in the query criteria. The list of IMS PSBs is generated from events collected 
in the project database. 

OS/400 Job Name

1. Select whether to Include or Exclude events for selected OS/400 job names. 

2. Check the box next to each job name you want to include specifically in the query 
criteria, or check the box next to Select All OS400 Job to include all job names in 
the query criteria. The list of OS/400 job names is generated from events collected 
in the project database. 
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WebSphere MQ API

1. Select whether to Include or Exclude events for selected WebSphere MQ APIs. 

2. Check the box next to each API you want to include specifically in the query crite-

ria, or check the box next to Select All API to include all WebSphere MQ APIs in 

the query criteria. 

Connection Name

The connection name and queue manager are typically the same, except in the case 

where a queue on one queue manager is opened using a connection (specified with the 

hConn parameter) to a different queue manager. For example, suppose a program opens 

queue QM1.Q using a connection to queue manager QM1, then later opens QM1.Q 

using a connection to queue manager QM2. This event shows QM1.Q as the object 

name, QM1 as the queue manager, and QM2 as the connection name.

1. Select whether to Include or Exclude events for the selected WebSphere MQ 

connections. 

2. Check the box next to each connection you want to include specifically in the 

query criteria, or check the box next to Select All Connection Name to include all 

connections in the query criteria. The list of connection names is generated from 

events collected in the project database. 
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Queue Manager

1. Select whether to Include or Exclude events for selected WebSphere MQ queue 
managers.

2. Check the box next to each queue manager you want to include specifically in the 
query criteria, or check the box next to Select All Queue Manager to include all 
WebSphere MQ queue managers in the query criteria. The list of queue managers 
is generated from events collected in the project database. 

Object

1. Select whether to Include or Exclude events for the selected WebSphere MQ 
objects.

2. Check the box next to each object you want to include specifically in the query cri-
teria, or check the box next to All WebSphere MQ Objects to include all objects in 
the query criteria. The list of objects is generated from events collected in the 
project database. They are grouped according to the queue managers they are asso-
ciated with.
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Reply To Queue Manager

1. Select whether to Include or Exclude events where the selected WebSphere MQ 
queue managers match the Reply To field.

2. Check the box next to each queue manager you want to include specifically in the 
query criteria, or check the box next to Select All Queue Manager to include all 
WebSphere MQ queue managers in the query criteria. The list of queue managers 
is generated from events collected in the project database. 

Reply To Object

1. Select whether to Include or Exclude events where the selected WebSphere MQ 
objects match the Reply To field.

2. Check the box next to each object you want to include specifically in the query cri-
teria, or check the box next to All Entries to include all WebSphere MQ objects in 
the query criteria. The list of objects is generated from events collected in the 
project database. 

Data Length of MQGET/MQPUT/MQPUT1

1. Select whether to Include or Exclude events for the selected data length.

2. Select the matching criteria for the selected data length. Choices include less than, 
less than or equal to, equal to, not equal to, greater than or equal to, or greater than.

3. Enter the desired data length in bytes.
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Completion Code

1. Select whether to Include or Exclude events for selected WebSphere MQ API 
completion codes.

2. Check the box next to each API completion code you want to include specifically 
in the query criteria, or check the box next to Select All Completion Code to 
include all completion codes in the query criteria. 

Reason Code

1. Select whether to Include or Exclude events for selected WebSphere MQ API 
reason codes.

2. Check the box next to each API reason code you want to include specifically in the 
query criteria, or check the box next to Select All Reason Code to include all rea-
son codes in the query criteria. 

Message ID

1. Select whether to Include or Exclude events with the selected WebSphere MQ 
message ID.
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2. Click the appropriate radio button to indicate whether the specified message ID is 
in string or binary format and enter the message ID. For string format, select the 
correct code page. 

Correlation ID

1. Select whether to Include or Exclude events with the selected WebSphere MQ 
correlation ID.

2. Click the appropriate radio button to indicate whether the specified correlation ID 
is in string or binary format and enter the correlation ID. For string format, select 
the correct code page. 

MQI Broker

1. Select whether to Include or Exclude events for selected WebSphere MQ 
Integrator (MQI) brokers.

2. Check the box next to each MQSI broker you want to include specifically in the 
query criteria, or check the box next to Select All MQI Broker to include all MQI 
brokers in the query criteria. The list of MQI brokers is generated from events col-
lected in the project database. 
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Important! TransactionVision uses a linear search for the MQI Broker criteria. Although linear 
searching enhances query capabilities, it reduces query performance. If you include this 
criteria in your query, query performance will be degraded. To minimize the impact on 
query performance, try not to use this criteria together with the other linear search 
criteria (User Buffer Data and WebSphere MQ MQI Message Flow Name) in the same 
query.

MQI Message Flow Name

1. Select whether to Include or Exclude events for selected WebSphere MQ 
Integrator (MQI) message flow names.

2. Check the box next to each MQSI message flow name you want to include specif-
ically in the query criteria, or check the box next to Select All MQI Message Flow 
Name to include all MQI message flow names in the query criteria. The list of 
MQSI message flow names is generated from events collected in the project data-
base. 

Important! TransactionVision uses a linear search for the MQI Message Flow Name criteria. 
Although linear searching enhances query capabilities, it reduces query performance. If 
you include this criteria in your query, query performance will be degraded. To 
minimize the impact on query performance, try not to use this criteria together with the 
other linear search criteria (WebSphere MQ MQI Broker and User Buffer Data) in the 
same query.

WebSphere MQ IMS Bridge Criteria
The following options are only available when WebSphere MQ IMS Bridge is the 
current “Criteria For:” technology.
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API

1. Select whether to Include or Exclude events for selected WebSphere MQ IMS 
Bridge APIs.

2. Check the box next to each API you want to include specifically in the query crite-
ria, or check the box next to Select All API to include all APIs in the query criteria. 
The list of APIs is generated from events collected in the project database.

IMS Transaction

1. Select whether to Include or Exclude events for selected IMS transactions.

2. Check the box next to each transaction you want to include specifically in the 
query criteria, or check the box next to Select All IMS Transaction to include all 
transactions in the query criteria. The list of transactions is generated from events 
collected in the project database.

Connection Name

1. Select whether to Include or Exclude events for selected connection names.

2. Check the box next to each connection name you want to include specifically in 
the query criteria, or check the box next to Select All Connection Name to include 
all connection names in the query criteria. The list of connection names is gener-
ated from events collected in the project database.
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Queue Manager

1. Select whether to Include or Exclude events for selected queue managers.

2. Check the box next to each queue manager you want to include specifically in the 
query criteria, or check the box next to Select All Queue Manager to include all 
queue managers in the query criteria. The list of queue managers is generated from 
events collected in the project database.

Object

1. Select whether to Include or Exclude events for selected objects.

2. Check the box next to each object you want to include specifically in the query cri-
teria, or check the box next to All WebSphere MQ Objects to include all objects in 
the query criteria. The list of objects is generated from events collected in the 
project database. They are grouped according to the queue managers they are asso-
ciated with.
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Message ID

1. Select whether to Include or Exclude events with the selected message ID.

2. Click the appropriate radio button to indicate whether the specified message ID is 
in string or binary format and enter the message ID. For string format, select the 
correct code page. 

Correlation ID

1. Select whether to Include or Exclude events with the selected correlation ID.

2. Click the appropriate radio button to indicate whether the specified correlation ID 
is in string or binary format and enter the correlation ID. For string format, select 
the correct code page. 
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Chapter 3

Using the Component Topology Analysis View

The Component Topology Analysis view shows the interaction between all system 

components for which Sensors collect event information. The Analyzer correlates 

events across host, program, and thread boundaries. These correlated events are used to 

draw a visual map of the flow of information throughout the system.

View commands enable you to customize the appearance of the Component Topology 

Analysis and print it as a map of your entire transaction-based system.

Program Icon

Edge

Message Queue
Icon

View
Commands

Select time period

Overview window shows view contents
relative to entire graph

for static mode

Switch between
modes

Status Bar

Show/Hide
Buttons
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View Components

The Component Topology Analysis consists of resource icons that represent system 
components and edges, which are connecting lines that show the interaction between 
resource icons. 

Resource Icons

Depending on your system, the following resource icons may appear in the Component 
Topology Analysis:

Icon Description

WebSphere MQ cluster node relating multiple queue instances in a clus-
tering environment

WebSphere MQ distribution list

WebSphere MQ message queue

WebSphere MQ remote queue

WebSphere MQ alias queue

WebSphere MQ dead letter queue

WebSphere MQ namelist

Program

Process object
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WebSphere MQ queue manager

WebSphere MQ local queue

WebSphere MQ model queue

WebSphere MQ Integrator broker

WebSphere MQ IMS Bridge node. If you do not have a custom bean to 
add queue and queue manager information for IMS Bridge events, an 
"unknown queue" node is shown for each IMS Bridge node associated 
with the MQIMS_BRIDGE_ENTRY event. For more information 
about the TransactionVision IMS Bridge Sensor, see the TransactionVi-
sion Installation and Configuration Guide.

Proxy object. Proxy objects involve applications that are not monitored 
by a TransactionVision Sensor. See the TransactionVision Installation 
and Configuration Guide for information about the proxy Sensor and 
proxy objects.

Internet.

JMS queue

JMS topic

Java server page

Java servlet

Icon Description
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Edges
The connecting lines, called edges, show the relationship between the resource icons. 
For WebSphere MQ, JMS, and CICS events, solid edges represent message flows. For 
servlet and EJB events, solid edges represent control flow.

Web application

WebSphere web application server

EJB session bean

EJB entity bean

EJB message-driven bean

CICS transaction. Note that TransactionVision automatically filters out 
all CICS transactions that begin with “C” because they are internal 
CICS transactions. One exception is CKBP, which denotes a Web-
Sphere MQ-CICS bridge transaction. All CICS DPL programs invoked 
through MQ-CICS bridge have this transaction name.

CICS file

CICS Transient Data (TD) queue

CICS indirect TD queue. Similar to a TD queue, the indirect TD queue 
is an alias to other TD queues.

CICS temporary storage (TS) queue. Used for temporarily passing data, 
users can create and destroy TS queues on the fly.

Icon Description
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Dashed edges represent a relationship between icons, such as between a remote, alias, 
or model queue and the local queue it is associated with. In the following example, the 
DataFlowEngine and FX Listener programs write to and read from the FX queue, 
respectively. The FX queue is an alias queue for the local FX_LOCAL queue.

WebSphere MQ and JMS Events
For WebSphere MQ and JMS events, an edge represents message flow. For example, 
the following diagram shows that the DataFlowEngine application puts messages on 
the EQUITY and BOND queues of the TRADING queue manager. The 
EquityTradeProcessor and BondTradeProcessor programs retrieve messages from the 
EQUITY and BOND queues, respectively, and put a message on REPLY.
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CICS Events
Like WebSphere MQ and JMS events, edges represent message flow for CICS events. 
For example, in the following diagram, the CKPB CICS transaction reads from the 
SYSTEM.CICS.BRIDGE.QUEUE queue and the ACCTFIL file. It then writes to the 
REMOTE.TO.HUGONGWPC queue, which is a remote queue for 
HUDONG..TEST.QUEUE.

Servlet and EJB Events
For servlet and EJB events, edges represent coltrol flow. In the following example, 
theWeb page calls the TradeServlet and TradeSimulationServlets. TradeServlet calls 
the TradeSession EJB, while TradeSimulationServlet calls a Java server page.



Chapter 3 • Using the Component Topology Analysis View
View Components

TransactionVision User’s Guide 75

WebSphere Business Integration Message Broker (WMIMB) Events

In the following example, the component label of the broker node shows the WBI 
broker name and the corresponding message flow name instead of listing the name of 
the broker process. 

The following table shows the node label meanings for WBI brokers with respect to the 
various distributed program grouping criteria in the Component Topology Analysis:

Grouping Criteria Node Label

Individual Thread Broker and Message Flow name

Individual Process Broker name

Program Name/Host Combination Fixed string "MQSI Broker"

Program Name Fixed string "MQSI Broker"

Host N/A
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WebSphere MQ-IMS Bridge Events

The following example shows a batch job HUDONGWA with a job step, STEP1 
putting messages onto a MQ-IMS bridge input queue. On receiving these messages on 
the input queue, the WebSphere MQ-IMS bridge invokes an IMS transaction TRTIB3 
in the IMS job  IMS71CR1. That transaction places reply messages on the 
IMS.BRIDGE.REPLY.QUEUE, which is read by the job step STEP2 of the job 
HUDONGWA.

Stand-alone Java Applications

When monitoring JMS events from stand-alone Java applications, the Component 
Layout view displays the top level class name as the program name. The top level class 
name is the outmost name in the stack trace. For example, the class name in the 
following stack trace is taken from the last line in the following example:
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at java.lang.Thread.dumpStack(Thread.java:993)
at Test.<init>(Test.java:29)
at Test.main(Test.java:62)

However, this class doesn’t necessarily contain the public static void 
main(String[] args). Instead, it might be a class derived from 
java.lang.Thread, which runs in other threads than the main thread.

If the correct program name is not displayed, set the 
com.bristol.tvision.programname system property in the command line 
when running the stand-alone application. For example, to set the program name to 
MyProgram, start it as follows:

java -Dcom.bristol.tvision.programname=MyProgram ...

View Modes
TransactionVision provides two modes for the Component Topology Analysis view: 
dynamic and static.

Dynamic Mode

In dynamic mode, the Component Topology graph is created by comparing each event 
in the project to the current query and correlating events that match the query. This 
mode enables you to structure your query to view very specific information, but it can 
be time-consuming to perform the analysis and display the graph.

Static Mode

Rather than evaluating all project events against a query, the static graph is created 
from statistics gathered during event collection. This enables the Analyzer to draw the 
graph much faster than in dynamic mode. However, it limits the granularity of event 
data because the static view can only distinguish between the program level, not the 
program instance level used in the dynamic view. The static view also limits queries to 
statistics occurring within a specified time range.

During event collection, statistics for the static mode display are stored in a statistics 
cache. Periodically, this cache is written to the database, making the results available 
for viewing the Component Topology Analysis. Entries in the 
<TVISION_HOME>/config/services/StatisticsCache.properties 
file controls the operation of the cache.



Chapter 3 • Using the Component Topology Analysis View
Open the Component Topology Analysis

78 TransactionVision User’s Guide

• The timeslice_interval property specifies the period of time during which 
all events belonging to the same program and WebSphere MQ object are 
condensed into a single statistic. Note that your time slice interval is the smallest 
increment of time in which you can view your data in static mode. 

• The flush_interval property specifies how often the statistics cache is 
written to the database. 

For more information about these properties, see the TransactionVision Installation and 
Configuration Guide.

Open the Component Topology Analysis

To open the Component Topology Analysis, choose the Views > Component Topology 
Analysis menu item. You may also open the Component Topology Analysis from the 
Event Analysis and Transaction Analysis views with the following command menu 
selections:

TransactionVision displays a Static Component Topology Analysis for the current 
project and query.

Tip! If your browser is unable to display the view or if the view displays, but icons do not 
appear correctly, your browser security settings may not be set so that 
TransactionVision can function properly. For instructions on setting minimum security 
settings for TransactionVision, see “Browser Security Settings” on page 12.

Switching Between Modes

By default, the Component Topology graph is created in static mode. Click Switch to 
Dynamic Mode to display the Dynamic Component Topology graph. To change from 
dynamic mode to static mode, click Switch to Static Mode on the Dynamic Component 
Topology graph.

View Menu Selection

Event Analysis Open these events in: Component Topology Analysis

Transaction Analysis Switch View > Component Topology Analysis View
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Moving Components

To move any component in the graph, select the component in the view area and drag it 
to the desired location. TransactionVision automatically adjusts all edges to and from 
the component.

Opening Multiple Views

You may open new browser windows open multiple Component Topology Analysis 
windows at once and use different queries to display different information. The 
following table shows the browser commands to open a new window in Internet 
Explorer and Netscape:

If you open a Component Layout Analysis view in a new browser window, any 
changes you make in one window are reflected in the other window when it is 
refreshed. If you start a new browser instance and log into TransactionVision in the 
new browser, however, a new TransactionVision session is started. If you use multiple 
sessions, changes you make in one session affect that session only.

Show/Hide the Status Bar

Use the Show/Hide arrow buttons to show, hide, or resize the status message pane. 

To hide the status bar, click the down arrow button. To show a hidden status bar, click 
the up arrow button. To resize the status bar, point the cursor to either arrow button so 
that the cursor changes to a double arrow and drag.

Closing the View

The Component Topology Analysis view closes when you select a different view or 
page from the TransactionVision menus.

Refresh the View
To refresh the Component Topology Analysis view with events collected since it was 
opened or last refreshed, click the Run Query view command.

Browser Menu Selection

Internet Explorer File > New > Window

Netscape File > New Navigator Window
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Change Static View Time Period
The static view is based on one of the following time queries:

• All statistics (default)

• Statistics from a predefined time period

• Statistics from a custom time period

View All Statistics

To use all events, check the Show all statistics checkbox and click Run Query.

View Statistics from a Predefined Time Period

To use events from a predefined time period, perform the following steps:

1. Clear the Show all statistics checkbox, if it is checked.

2. Select one of the following predefined time periods in the Set Time to field:

• Today

• Yesterday

• Past Week

• This Month

• Last 48 hours of data

The date and time fields are automatically populated with the corresponding 
information. These fields are also disabled. 

3. Click Run Query.

View Statistics for a Custom Time Period

To use events from a custom time period, perform the following steps:

1. Clear the Show all statistics checkbox, if it is checked.

2. Select Custom time in the Set Time to field.

3. Enter the desired start and end dates and times in the Display Statics Data from and 
to fields.
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Note that your time slice interval set in StatisticsCache.properties is 
the smallest increment of time in which you can view your data in static mode. For 
example, if your time slice is set to one day, you will not be able to view these 
statistics on an hourly basis. If you set a specify a custom time period smaller than 
the time slice, this view shows all events in the time slice associated with the 
custom time period. For example, if your time slice is set to one day and you 
specify a custom time period of one hour, the resulting view will show all events 
for the entire day. If your custom time period spans multiple time slices, the 
resulting view shows all events from the time slices spanned by the custom time 
period.

4. Click Run Query.

Modify Edges
You may customize the width and color coding of edge widths, or set other edge 
properties.

Edge Widths
Edge width properties may reflect information about the interaction between 
components. By default, edge widths are fixed, but you can modify them so that edge 
thickness represents either the total number of message calls (MQGET and 
MQPUT/MQPUT1 calls for WebSphere MQ events or send and receive calls for JMS 
events), the number of successful message calls, or the message data byte count. 
Setting edge widths enables you to see at a glance logic and performance bottlenecks in 
your system, as in the following example:

To set edge width properties, choose one of the following menu items from the Edge > 
Edge Widths menu:

Edge width 
indicates the 
number of 
successful 
message calls.
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Edge Color Coding

You may color code edges to indicate warning and error messages, enabling you to see 
them easily. To set edge color coding, choose one of the following from the Edge > Edge 
Color Coding menu:

Modify Edge Labels
You may configure edge labels to provide more information about the events they 
represent. Edge labels may include any (or none) of the following information:

• Message and byte count

• Error, warning, and success count

• Latency times

• Edge Label

• EJB methods

Menu Item Description

Message Call Count Edge width indicates the total number of message calls 
(MQGET, MQPUT, and MQPUT1 calls for Web-
Sphere MQ events or send and receive calls for JMS 
events) between components.

Successful Message Call 
Count

Edge width indicates the number of successful mes-
sage calls between components.

Message Data Byte Count Edge width indicates the number of message data 
bytes transferred between components.

Fixed width All edge widths are a fixed width (default).

Menu Item Description

Errors and Warnings Edges representing error and warning events are color 
coded are shown in red.

None Edges representing error and warning events are not 
color coded (default).
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Message Count/Byte Count
Choose the Edge > Message Count/Byte Count menu item to turn on/off edge labels 
indicating the total number of successful message calls between the resources, along 
with the number of bytes transferred. Note that MQIMS_BRIDGE_ENTRY and 
MQIMS_BRIDGE_EXIT calls are not included in the message count/byte count.

To specify whether unit of measure for the byte count, choose one of the following 
from the Edge > Show Byte Counts menu:

• In MegaBytes

• In KiloBytes

• In Bytes

This menu item is only enabled if the message count/byte count is displayed.

Error, Warning, and Success Count
Choose the Edge > Error/Warning/Success Count menu item to turn on/off edge labels 
indicating the number of error events, warning events, and successful events between 
components. Events include the following:

• All WebSphere MQ MQGET, MQPUT, MQPUT1, MQINQ, MQSET, MQOPEN, 
MQIMS_BRIDGE_ENTRY, and MQIMS_BRIDGE_EXIT calls.

• All JMS receive, receiveNoWait, OnMessage, OnException, createReceiver, 
createSubscriber, createBrowser, publish, send, createSender, createPublisher, and 
nextElement calls.

• All servlet HTTP_PUT, HTTP_GET, and HTTP_POST requests.

Edge labels showing
message count/byte
count
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Latency Times

Choose the Edge > Min/Avg/Max Latency Times menu item to turn on/off edge labels 
showing minimum, average, and maximum transaction times for each connection. Use 
this information to identify potential performance bottlenecks. Transaction times are 
defined as the time from when a message is put onto the queue and when it was pulled 
off that queue. For transactions involving a proxy object, TransactionVision shows a 
latency of N/A.

Important! For EJB and servlet events, the time on the edge pointing to a bean represents the time 
spent in that bean’s or servlet’s methods; not a latency time. 

Edge labels showing
error/warning/success
count in addition to
message count/byte
count

Edge labels showing
latency times in addition
to message count/byte
count
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By default, latency times are calculated using a resolution of 1/100 seconds. To modify 
the latency resolution, change the value of the latency_resolution attribute in 
the Analyzer.properties file. For more information about this file, see the 
TransactionVision Installation and Configuration Guide.

Edge Label
Choose the Edge > Edge Label menu item to turn on/off edge labels showing the 
connection associated with the edge. 

EJB Methods
Choose the Edge > EJB Methods > Show Standard EJB Methods menu item to turn on/off 
the inclusion of standard EJB methods in the edge labels showing the 
error/warning/success count. 

Choose the Edge > EJB Methods > Show Access Methods menu item to turn on/off the 
inclusion of access methods in the edge labels showing the error/warning/success 
count. 

Choose the Edge > EJB Methods > Show Bean Relationships menu item to turn on/off 
edges showing EJB relationships.

Edge labels showing
connection names in 
addition to message
count/byte count
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Modify Component Groupings
Changing component groupings changes the granularity of the information displayed in 
the view, depending on the level of information you need. For example, viewing each 
process thread as a separate component provides very fine granularity, but can make it 
difficult to spot an information flow problem between programs.

Note that proxy objects do not support grouping by thread, process, transaction name, 
transaction ID, TCB, and PCB. Selecting these grouping criteria have no affect on 
proxy objects. For more information about proxy objects and the proxy Sensor, see the 
TransactionVision Installation and Configuration Guide.

Queues and Queue Managers
Choose one of the following from the Grouping > Queue Grouping Criteria menu:

• MQSeries Object/Queue Manager Combination to show each object/queue manager 
combination as a separate component.

• Queue Manager to show all objects on a single queue manager as a single 
component.

You may also select Show Model Queue Resolution to turn model queue resolution on/off. 
A model queue is a template of a queue definition that is used when creating a dynamic 
queue. When you call MQOPEN on a model queue, the queue manager creates a 
temporary or permanent local dynamic queue using the attributes of the model queue. 
Select this menu item to show model queues in the Component Topology Analysis.

The edges between a model queue node and its model queue definition, remote queue 
definition, alias queue definition, or cluster queue node representation are displayed as 
dashed lines because they represent a relationship rather than a message flow.

Distributed Platforms
For UNIX and Windows NT hosts, choose one of the following from the Grouping > 
Distributed Program Grouping Criteria menu:

• Individual Thread to show each thread as a separate component. This option does not 
apply to servlets or EJBs.

• Individual Process to show all threads of a single process as a single component.This 
option does not apply to servlets or EJBs.

• Program Name to show each program name on all hosts as a single component.

• Host to show all programs on a single host as a single component.

• Program Name/Host Combination to show the default component grouping.
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OS/390 CICS
For OS/390 CICS hosts, choose one of the following from the Grouping > OS/390 CICS 
Program Grouping Criteria menu:

• Individual Transaction (Task) to show each transaction ID as a separate component.

• Transaction ID/Region/Host Combination to show the default component grouping.

• Transaction ID/Host Combination to show the transaction and host combination for all 
regions as a single component.

• Region/Host Combination to show all transaction IDs for a single region on a host as 
a single component.

• Host to show all transaction IDs for all regions on a single host as a single 
component.

OS/390 Batch
For OS/390 Batch hosts, choose one of the following from the Grouping > OS/390 Batch 
Program Grouping Criteria menu:

• Individual TCB to show each TCB as a separate component.

• Individual Job Step to show each job step as a separate component.

• Individual Job to show each job as a separate component.

• Host to show all TCBs on a single host as a single component.

• Host/Job Name/Step Name Combination to show the job name, job step, and host 
combination as a single component.

• Host/Job Name Combination to show all jobs on a host as a single component.

IMS
For OS/390 IMS hosts, choose one of the following from the Grouping > OS/390 IMS 
Program Grouping Criteria menu:

• Individual PSB Name to show each PSB as a separate component.

• IMS Transaction Name to each show transaction as a separate component.

• IMS Region Identifier to show each region as a separate component.

• IMS Identifier to show each IMS identifier as a separate component.

• Job Name to show each job name as a separate component.

• IMS Type to show each IMS type as a separate component.
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IMS Bridge
Choose one of the following from the Grouping > OS/390 IMS Bridge Grouping Criteria 
menu:

• Transaction Name to show each transaction name as a separate component.

• Job Name to show each job name as a separate component.

Servlet/JSP/EJB
For Servlet/JMS/EJB events, choose one of the following from the Grouping > 
Servlet/JSP Grouping Criteria menu:

• Servlet/JSP/EJB to show servlet, JSP, and EJB icons.

• Web Application to show web application icons.

• Application Server to show WebSphere Application Server icons.

• Host to show all programs on a single host as a single component.

Show Publish-Subscribe Topic
By default, TransactionVision is unable to correlate publish-subscribe events unless 
you monitor the publish-subscribe broker. Therefore, TransactionVision identifies the 
following events as two separate transactions:
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However, if you have enabled publish-subscribe topic correlation, TransactionVision is 
able to correlate these publish-subscribe topics into a single transaction as follows:

For instructions on enabling TransactionVision to correlate publish-subscribe topics, 
see the TransactionVision Installation and Configuration Guide. If correlation is 
enabled, choose Grouping > Show Publish-Subscribe Topic to show the correlation.

Group Method Calls On The Same EJB

To group similar method calls on the same EJB as a single edge, choose Grouping > 
Group Method Calls On the Same EJB. Otherwise, an edge is drawn on the graph to 
represent each method call between EJB beans.

Change Default Settings
As you use the Component Layout View, you may change settings such as program and 
queue grouping criteria, edge labels and appearance, and graph layout. To make the 
current settings the default for the your user ID, click Save Settings.

Zoom In or Out
By default, TransactionVision sizes the Component Topology Analysis graph to fit in 
the view window. There are several ways to adjust the zoom level:

• Choose the Zoom > Zoom > Zoom In menu item to increase the zoom level. 

• Choose the Zoom > Zoom > Zoom Out menu item to decrease the zoom level. 

• Click  or choose Zoom > Selective Zoom to change to selective zoom mode. 
The cursor changes to the selective zoom cursor. Click on the view area and then 
drag the cursor to select an area to zoom. TransactionVision adjusts the zoom level 
so that the selected area fills the view area. Click  to return to selection 
mode.
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• Click  or choose Zoom > Interactive Zoom to change to interactive zoom 
mode. The cursor changes to the interactive zoom cursor. Click in the view area 
and drag the cursor to the top or left to decrease the zoom level or drag to the 
bottom or right to increase the zoom level. Click  to return to selection 
mode.

• Click  or choose Zoom > Zoom > Fit Window to adjust the zoom level so that 
the entire graph appears in the view window.

• Enter a custom zoom percentage or choose a predefined zoom percentage from the 
zoom percentage list.

• Choose the Zoom > Show Overview Window menu item to open a small secondary 
window that contains a read-only view of the view window. The entire graph is 
shown within this window, and a highlighted selection box surrounds the region 
that is displayed in the active window. The highlighted rectangle allows you to 
change the view by changing the focal point and zoom level of the active graph 
window. It is provided as a mechanism to help you see where you are in a graph. 

• To resize the selection box, click one of the corner handles and drag your 
cursor to the desired size. Note that the selection box maintains a constant 
aspect ratio to match the size of the active view window.

• To move the selection box, click inside the selection box and drag your cursor 
to the desired location. 

• To create a new selection box, click outside of the current selection box and 
drag your cursor to the desired size.

Important! Note that any time the Component Topology Analysis view is refreshed, the zoom level 
reverts to Fit Window.

Set Background Color
One way to customize the Component Topology Analysis is to specify a background 
color. To specify a background color, choose the Layout > Background Color menu item. 
The Choose Graph Background Color dialog appears.



Chapter 3 • Using the Component Topology Analysis View
Set Background Color

TransactionVision User’s Guide 91

There are three ways to select a background color:

• On the Swatches page, click the desired color. The preview area shows what your 
choice will look like.

• On the HSB page, click the desired color in the color area. Use the sliding bar to 
adjust the hue, saturation, and brightness levels individually.
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• On the RGB page, enter specific values for red, green, and blue, or click the 
desired value on the scale.

Click OK to make your changes active, Cancel to close the dialog without activating 
your changes, or Reset to reset the background color to the default.
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Print Graphs
To print the Component Topology Analysis graph using the current print setup, choose 
the  > Print Graph... menu item. TransactionVision invokes the standard printing 
mechanism for your platform.

Important! Setting the page orientation to landscape on the Windows Print dialog has no effect. 
Instead, use the TransactionVision Page Setup dialog to set page orientation if you wish 
to print in landscape mode. For more information about this dialog, see page 97.

When you print a graph, a Java warning appears asking permission to print. This 
message is generated by the Java security feature to prevent unauthorized use of 
printers. The first time you print in a session, it appears multiple times; it appears once 
after the first time you print. To disable this message, add the following lines in the 
.java.policy file in your home directory on the client computer:

grant {
permission java.lang.RuntimePermission “queuePrintJob”;

};

Print Preview
To display a print preview, choose the  > Print Preview... menu item.The Print 
Preview window opens. It is a secondary window that displays a preview of the printed 
graph. The Print Preview window allows you to preview graph images before you print 
them so you can see in advance how changes in print setup options affect your printed 
images.
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In the print preview window, you can zoom in on a preview image by moving the 
mouse over it and clicking.

You may also use the following buttons to control the appearance of the print preview:

Button Description

Print... Invokes the standard printing mechanism for your platform.

Print Setup... Opens the Print Setup dialog for setting printing options.

Zoom In Increases the zoom level for the preview image.

Zoom Out Decreases the zoom level for the preview image.

Zoom Percentage Shows the current zoom percentage. You may select a pre-
defined zoom percentage from the list or enter a custom zoom 
percentage.

Fit in Window Scales the preview image to display the complete image in the 
preview window.

Close Closes the Print Preview window.
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Print Setup
To customize the look of your printed graph, choose the  > Print Setup... menu 
item.The Print Setup dialog opens. 

This dialog offers options for tailoring the look of your printed Component Topology 
Analysis or Transaction Analysis view. Set the following options, then click OK to 
apply your changes, Cancel to close the dialog without applying your changes, Default to 
revert to default values, or Page Setup... to display the Page Setup dialog for selecting 
paper size, orientation, and margins.

Option Description

Print Select the part of the graph you want to print. You may print 
the entire graph, only the part of the graph currently visible in 
the view window, or only the selected graph components.

Scale By Set options related to page size. Select Pages and specify the 
number of page rows and columns to scale the image to fit the 
specified page size. The image is not scaled if Actual Size is 
selected. Choose Zoom Level to scale the image to the zoom 
level specified in the view.

Print Caption Select to print the page caption in the Caption field.
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Caption Enter text for the page caption. You must select Print Caption 
to enable caption printing. To select the font for the caption, 
click Font... to display the Choose Font dialog.

Position Select the position on the page for the caption to be printed.

Margins Set the distances in inches between the edge of the paper and 
the edge of the graph. Set margins for the top, bottom, left, and 
right edges.

Print Page 
Numbers

Select to print page numbers on each page when printing multi-
ple pages. Page numbers are printed just outside the crop 
marks.

Print Crop Marks Select to print crop marks when printing multiple pages. Crop 
marks are the lines drawn on the margins of pages that connect 
to other pages.

Print Border Select to print a border around the graph. Click Color... to open 
the Choose Color dialog for setting the border color.

Print Background Select to print the background color. To set the background 
color, choose the Layout > Background Color... menu item on the 
Component Topology or Transaction Analysis view.

Print Grid Select to print a background grid.

Option Description
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Page Setup

Click Page Setup... on the Print Setup dialog to open the Page Setup dialog.

Use this screen to set up page options for printing Component Topology or Transaction 
Analysis graphs. Set the following options, then click OK to activate your changes or 
Cancel to close the dialog without activating your changes.

Option Description

Paper Size: Select a page style from the list.

Paper Source: Select a source from the list.

Margins: Set the distance between the text and the edge of the printed 
page (in inches). Set margins for the top, bottom, left, and right 
edges.

Orientation: Select whether to use Portrait or Landscape for setting up the 
page. Portrait is default (the height of the page is greater than 
the width). For Landscape, the width of the page is greater 
than the height.

Sample: Displays a preview of the selected settings.
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Caption Font

Click Font... on the Print Setup dialog to open the Choose Font dialog.

Use this dialog to select the font to use for the caption when printing a Component 
Topology or Transaction Analysis graph.

Select a font family, text attributes, and font size from the drop-down lists. The sample 
window shows how text on the graphic will look. 

Click OK to make your changes active or Cancel to close the dialog without activating 
your changes.

Border Color

Click Color... on the Print Setup dialog to open the Choose Color dialog. Use this dialog 
to set the border color for printed Component Topology Analysis and Transaction 
Analysis graphs. 

Set the border color in the same way you set the background color for the graph. For 
more information, see “Set Background Color” on page 90.

Modify Layouts and Properties

By default, the Component Topology Analysis is arranged in a hierarchical layout 
organized according to the flow of messages through your system. While this layout is 
typically the best choice for e-business systems and therefore recommended, you may 
choose to display the Component Topology Analysis in a symmetric layout. Note that 
using a different layout may make it more difficult to follow the flow of messages 
throughout your system.
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Hierarchical Layout
To select the hierarchical layout (if it is not the current layout), choose the Layout > 
Hierarchical Style menu item. Components are arranged in a hierarchical organization 
based on the flow of messages through your system, as in the following example. 

To modify layout properties, choose the Layout > Layout Properties menu item. Make 
desired changes on the Hierarchical page, then click OK. 



Chapter 3 • Using the Component Topology Analysis View
Modify Layouts and Properties

100 TransactionVision User’s Guide

Orientation
By default, components are arranged from left to right, but you can change the 
orientation from top to bottom, bottom to top, or right to left.

Level Alignment
Level alignment refers to the alignment of components on the same level. It is similar 
to text alignment within a paragraph. If Orientation is horizontal (Top To Bottom or 
Bottom To Top), you can set the Level Alignment as either Top, Center or Bottom. If 
Orientation is vertical (Left To Right or Right To Left), you can set the Level 
Alignment as either Left, Center or Right.

Spacing
The concept of frames is used to control the margins around components. These 
options allow you to set the spacing between levels of components and between 
component within the same level in a graph by adjusting the frames that surround them.

Left To Right Positions components so that the roots of the graph are near 
the left of the page, and the leaves of the graph are near the 
right. The levels are vertical.

Top To Bottom Positions components so that the roots of the graph are near 
the top of the page, and the leaves of the graph are near the 
bottom. The levels are horizontal.

Right To Left Positions components so that the roots of the graph are near 
the right of the page, and the leaves of the graph are near the 
left. The levels are vertical.

Bottom To Top Positions components so that the roots of the graph are near 
the bottom of the page, and the leaves of the graph are near 
the top. The levels are horizontal.

Variable Level 
Spacing

When enabled, variable level spacing considers the density of 
edges between adjacent levels when adjusting the level spac-
ing. For example, if too many edges cross at the same point 
between levels, then the level spacing is automatically 
increased. Consequently, not all levels would have the same 
spacing. Variable level spacing is usually used in combina-
tion with orthogonal edge routing.

Proportional Spac-
ing

Sets the spacing around each node to a fractional value 
(between 0 and 1) based on the node size.
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Edge Routing
These options allow you to tailor edge routing.

Symmetric Layout
To select the symmetric layout (if it is not the current layout), choose the Layout > 
Symmetric Style from the shortcut menu. The symmetric layout distributes components 
evenly with very few edge crossings, as in the following example. 

Constant Spacing Allows the spacing around each node to be a constant value, 
independent of the size of the node.

Between Levels This field allows you to set the spacing between each level in 
the graph. In left-to-right and right-to-left views, levels run 
vertically. In top-to-bottom and bottom-to-top views, levels 
run horizontally. 

Between Nodes This field allows you to set the spacing between adjacent 
components within a level.

Option Description

Orthogonal Routing When enabled, each edge is drawn as a sequence of line 
segments that run parallel to the x- and y-axes. Edges have 
bend points of 90 degrees only. The orthogonal routing 
style works best in combination with variable level spacing 
and ports.

Straight Edges When enabled, this setting merges the incoming edges of a 
node into a single fork-like structure. Clearer drawings 
result provided the graph is not too dense. This feature is 
only available when orthogonal routing is enabled.
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To modify symmetric layout properties, choose the Layout > Layout Properties menu 
item. Make desired changes on the Symmetric page, then click OK. 

Spring Options
These controls allows you to set the options relating to the spring model of the graph.
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General Properties
The General page of the Properties dialog enables you to specify settings that are 
independent of the layout style. To modify general layout properties, choose the Layout 
> Layout Properties menu item. Make desired changes on the General page, then click OK. 

Node Spacing This value is used in determining the white space between 
components. It specifies the length of each edge as a function 
of the width and height of the components to which the edge 
connects. A node spacing of zero specifies that edge lengths 
be just long enough to keep components from touching (i.e., 
no white space between components). The larger the node 
spacing value, the greater the amount of white space between 
components.

Random Seed The initial layout of the graph is keyed to a random number 
sequence. The value set in this field is used to generate the 
random number sequence to set initial coordinates for each 
components. Each different non-negative value can produce a 
different layout. This field is active when Incremental Layout 
is not checked.
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Spacing Model

The concept of frames is used to control the margins around physical objects. These 
options control which model is used in determining the amount of white space around 
the perimeter of objects in the graph. Two spacing models are available, the 
Proportional Spacing model and the Constant Spacing model. Additional layout-
specific spacing options are available, some of which are affected by the spacing model 
selected here.

Graph Margin Spacing

This group of fields affects the margins for graphs. Separate frame values are stored for 
the Constant Spacing and Proportional Spacing models, but only one spacing model is 
in effect at any given time.

Labeling

This option allows you to tailor the automatic positioning of edge labels.

Select Incremental Layout to maintain the relative positioning of labels from a graph’s 
previous layout whenever the graph is modified. Incremental Layout results in graphs 
that maintain the same overall form when changes are made. 

Proportional 
Spacing

When enabled, proportional spacing is used to determine the 
amount of white space around the perimeter of an object based 
on the area of the object. For example, if a component’s width 
and height increase, the white space between the component 
and an adjacent component also increases. The margins of the 
graph can be controlled through the Graph Margin Spacing 
fields below. You can set independent proportional spacings for 
the left, right, bottom, and top sides of the graph. Note that 
additional spacing controls are available on the other dialog 
pages.

Constant Spacing When enabled, a constant space is allocated between like 
objects in a graph. For example, in hierarchical layout a fixed 
distance is set between each pair of adjacent components 
within a level, regardless of the width and height of the nodes. 
The margins of the graph can be controlled through the Graph 
Margin Spacing fields below. You can set independent constant 
spacing values for the left, right, bottom, and top sides of the 
graph. Note that additional spacing controls are available on 
the other dialog pages.
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Disconnected Properties
The generic term "disconnected objects" is used to refer to both disconnected 
components and connected subgraphs, unless otherwise noted. A disconnected 
component is one which has no edges connected to it. A connected subgraph is a graph 
in which there is an undirected path between each pair of components. In other words, 
each component can be reached from all other components by following the edges that 
connect them, regardless of edge direction. If there is no such path between any two 
components, then either the components belong to different connected components or 
one of the components is a disconnected node.

To modify disconnected layout properties, choose the Layout > Layout Properties menu 
item. Make desired changes on the Disconnected page, then click OK. These options 
only have effect if more than one disconnected object exists within the graph.

These settings allow you to edit the proportional and constant spacing between 
disconnected objects of a graph. 

Constant Spacing Specify the minimum amount of white space between adja-
cent rows and columns.

Proportional Spac-
ing

Specify a factional value. The margin around disconnected 
objects is calculated as the product of this fractional value 
and half the height of the node.
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Chapter 4

Using the Transaction Analysis View

The Transaction Analysis correlates events across multiple programs, hosts, and 
operating systems into local transactions, then correlates local transactions in to 
business transactions.

Transaction Analysis View Components
The following diagram shows an example Transaction Analysis view:

Business
Transactions

Local
Transaction

Edges

Icons

Status

Commands

Bar

View

Show/Hide Buttons
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Business Transactions

The pane on the left lists all business transactions that match the current query for the 
project. By default, the name of a business transaction is the transaction start time. 
However, you may write a custom Java bean to redefine transaction names into 
something more meaningful. For information about writing custom Java beans, see the 
TransactionVision Programmer’s Guide.

TransactionVision tracks business transactions by relating local transactions in 
different processes or threads (for example, relating an MQPUT in one process to the 
MQGET in a different process). When communication occurs between different local 
transactions, they are considered part of the same business transaction. For example, 
when a client process sends a message to a server process, it will do so in the context of 
a local transaction, and the server receiving the message will similarly do so within a 
second local transaction. The operations performed within these two local transactions, 
both the communication operations that allow the two processes to exchange data as 
well as any other computational operations within these local transactions, are part of 
the same business transaction. 

Local Transaction Icons

The graph on the right shows a visual representation of the selected business 
transaction. The icons represent the local transactions that make up the selected 
business transaction. Each icon indicates the technology for the local transaction. The 
icon label shows the name of the program executing the transaction and the number of 
milliseconds required to complete that local transaction. For IMS Bridge events, each 
MQIMS_BRIDGE_ENTRY and MQIMS_BRIDGE_EXIT event is shown as a local 
transaction.

A local transaction groups related events within a single thread of execution. For the 
WebSphere MQ, JMS, EJB, and CICS technologies, a local transaction includes any 
number of operations performed during the time span of a single unit of work. 
Operations performed within one unit of work are either committed or are backed out 
together, so that the effects of a number of operations all are either made permanent 
(committed) or reversed (backed out) as one atomic group. For servlet events, a local 
transaction is a servlet call.

Edges

The connecting lines, called edges, show the relationship between the local 
transactions. Each edge represents a pair of put/get connections. 
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• A solid edge indicates a message path; it represents a flow of data. An example is a 
link between a transaction making an MQPUT call, which puts a message on a 
queue, to a transaction making an MQGET call, which takes that message out of 
the queue. The data transfer occurs in the direction of the arrow.

• A dashed edge indicates a weak message path. For IMS_BRIDGE_EXIT events, 
the edges between them and MQGET events are shown as a weak message path.

• A dotted line indicates a control flow. It represents a call sequence. For example, a 
servlet making several JMS calls will use a dotted line to represent a control flow. 
The transfer of control occurs in the direction of the arrow. 

Weak Message Path

In a weak message path, the following criteria are used to match MQPUT/MQPUT1 
events with corresponding MQGET events in a business transaction:

• Message ID

• Correlation ID

• Put date and time

• Application and type

• User identifier

Weak Message Path

Control Flow

Strong Message Paths
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While these criteria correctly match most events, it is possible that they may result in 
an incorrect match. For example, if the message ID and correlation ID are reused and 
two messages are put onto different queues within the same 100th of a second, a single 
MQGET event could match both MQPUT/MQPUT1 events.

Strong Message Paths
Strong message paths are those paths where the resolved queue manager and 
WebSphere MQ object name match on the message path, along with all of the criteria 
for weak message paths. These additional criteria further enhance the confidence of the 
relationship between local transactions within the business transaction.

In the following business transaction, in the first local WebSphere MQ transaction, the 
DataFlowEngine program gets a message from the REQUEST queue and puts it on the 
FX queue:

Later in the business transaction, DataFlowEngine gets a message from the REPLY 
queue and puts it on the REPLY_FOR_SESSION queue:
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Control Flow
When TransactionVision creates the Transaction Analysis view, its goal is to show the 
control flow between servlets and EJBs in a linear fashion, then show the WebSphere 
MQ message flows around it. This view enables you to see the flow of the business 
process. Time values enable you to see exactly how long it takes for a servlet to 
complete. In the following example, the Begin and End points of the Java server pages 
and servlets represent the primary and secondary times of the HTTP events. 
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View Commands
View commands enable you to show the current transaction in the Event Analysis or 
Component Topology Analysis view, modify the view appearance, or print the view 
graph.

Proxy Paths
The proxy icon  represents a proxy path rather than a transaction message path. 
The time shown in the icon label represents the time from the end of the MQPUT event 
to the beginning of the corresponding MQGET event. Proxy paths involve applications 
that are not monitored by a TransactionVision Sensor. 

For more information about proxy objects and the proxy Sensor, see the 
TransactionVision Installation and Configuration Guide.

CICS Transactions
In addition to the program name and completion time, the Transaction Analysis view 
also displays the CICS transaction name for CICS transactions. 

In the following example, note the program name for the third local transaction. In this 
transaction, the ACCB02 links to TCAPTX3.

Important! TransactionVision filters out transactions that begin with a C character because they are 
internal CICS transactions. One exception is CKBP, which denotes a WebSphere MQ-
CICS bridge transaction. All CICS DPL programs invoked through MQ-CICS bridge 
have this transaction name.
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Queries and the Transaction Analysis View

Query conditions reduce the number of events displayed by restricting the hosts, queue 
managers, programs, times, and APIs associated with displayed events. For example, 
you can set query conditions to view only those transactions that include events for a 
specific technology, program, host, time period, or queue. For instructions on using 
queries, see Chapter 2, “Configuring Queries.”

Open and Close the Transaction Analysis

To open the Transaction Analysis, choose the Views > Transaction Analysis menu item. 
You may also open the Transaction Analysis from the Event Analysis view with the 
Open these events in: Transaction Analysis view command menu selection.

TransactionVision displays a Transaction Analysis view for the current project and 
query.

Tip! If your browser is unable to display the view or if the view displays, but icons do not 
appear correctly, your browser security settings may not be set so that 
TransactionVision can function properly. For instructions on setting minimum security 
settings for TransactionVision, see “Browser Security Settings” on page 12.

Moving Icons

To move any icon in the graph, select the icon in the view area and drag it to the desired 
location. TransactionVision automatically adjusts all edges to and from the icon.

Opening Multiple Views

You may open new browser windows open multiple Transaction Analysis windows at 
once and use different queries to display different information. The following table 
shows the browser commands to open a new window in Internet Explorer and 
Netscape:

Browser Menu Selection

Internet Explorer File > New > Window

Netscape File > New Navigator Window
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If you open a Transaction Analysis view in a new browser window, any changes you 
make in one window are reflected in the other window when it is refreshed. If you start 
a new browser instance and log into TransactionVision in the new browser, however, a 
new TransactionVision session is started. If you use multiple sessions, changes you 
make in one session affect that session only.

Show/Hide the Status Bar and Business Transaction List
Use the Show/Hide arrow buttons to show, hide, or resize the business transaction list 
and status message panes. 

To hide the status bar, click the down arrow button. To show a hidden status bar, click 
the up arrow button. To resize the status bar, point the cursor to either arrow button so 
that the cursor changes to a double arrow and drag.

To hide the business transaction list, click the left arrow button. To show a hidden 
business transaction list, click the right arrow button. To resize the business transaction 
list, point the cursor to either arrow button so that the cursor changes to double arrow 
and drag.

Closing the View
The Transaction Analysis view closes when you select a different view or page from 
the TransactionVision menus.

Refresh the View
To refresh a view with transactions completed since the view was opened, click the Run 
Query view command.

Change Default Settings
As you use the Transaction Analysis view, you may change settings such as edge labels 
and graph layout. To make the current settings the default for the your user name, click 
Save Settings.

Zoom In or Out
By default, TransactionVision sizes the Transaction Analysis graph to fit in the view 
window. There are several ways to adjust the zoom level:

• Choose the Zoom > Zoom > Zoom In menu item to increase the zoom level. 

• Choose the Zoom > Zoom > Zoom Out menu item to decrease the zoom level. 
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• Click  or choose Zoom > Selective Zoom to change to selective zoom mode. 
The cursor changes to the selective zoom cursor. Click on the view area and then 
drag the cursor to select an area to zoom. TransactionVision adjusts the zoom level 
so that the selected area fills the view area. Click  to return to selection 
mode.

• Click  or choose Zoom > Interactive Zoom to change to interactive zoom 
mode. The cursor changes to the interactive zoom cursor. Click in the view area 
and drag the cursor to the top or left to decrease the zoom level or drag to the 
bottom or right to increase the zoom level. Click  to return to selection 
mode.

• Click  or choose Zoom > Zoom > Fit Window to adjust the zoom level so that 
the entire graph appears in the view window.

• Enter a custom zoom percentage or choose a predefined zoom percentage from the 
zoom percentage list.

• Choose the Zoom > Show Overview Window menu item to open a small secondary 
window that contains a read-only view of the view window. The entire graph is 
shown within this window, and a highlighted selection box surrounds the region 
that is displayed in the active window. The highlighted rectangle allows you to 
change the view by changing the focal point and zoom level of the active graph 
window. It is provided as a mechanism to help you see where you are in a graph. 

• To resize the selection box, click one of the corner handles and drag your 
cursor to the desired size. Note that the selection box maintains a constant 
aspect ratio to match the size of the active view window.

• To move the selection box, click inside the selection box and drag your cursor 
to the desired location. 

• To create a new selection box, click outside of the current selection box and 
drag your cursor to the desired size.
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Show/Hide Weak Message Paths
Choose the Edge > Show Weak Link command to show or hide weak message paths in the 
Transaction Analysis view. 

Modify Edge Labels
You may configure edge labels to provide additional information about transaction. 
Edge labels may include any (or none) of the following information:

To enable or disable any of the edge labels in the Transaction Analysis view, choose the 
corresponding command. The following diagram shows a Transaction Analysis graph 
with transaction time and latency labels enabled:

Label Command Description

Transaction Times Edge > Show Transac-
tion Times

Displays edge labels showing the 
exit time for the put and get calls 
between the local transactions. 

Latency Edge > Show Latency Displays an edge label showing 
number of milliseconds between the 
exit times of the put and get calls 
between the local transactions. By 
default, latency times are calculated 
with a resolution of 1/100 seconds. 
To change the resolution, modify 
the value of the 
latency_resolution attribute 
in the Analyzer.properties file. See 
the TransactionVision Installation 
and Configuration Guide for more 
information about this file.
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Display a Business Transaction in Other Views
When performing analysis with TransactionVision, you may want to see the same 
events in different views. To create a new view containing events from the current 
business transaction, choose one of the following menu items:

• Switch View > Component Topology Analysis View creates a new Component Topology 
Analysis view containing only events from the selected business transaction. The 
view is labelled with the business transaction ID shown in the Transaction 
Analysis view. For more information about using the Component Topology 
Analysis view, see Chapter 3.

• Switch View > Event Analysis View creates a new Event Analysis view containing 
only events from the selected business transaction. The view is labelled with the 
business transaction ID shown in the Transaction Analysis view. For more 
information about using the Event Analysis view, see Chapter 5.

Print Graphs
To print the Transaction Analysis graph using the current print setup, choose the  
> Print Graph... menu item. TransactionVision invokes the standard printing mechanism 
for your platform.

Important! When you print a graph, a Java warning appears asking permission to print. This 
message is generated by the Java security feature to prevent unauthorized use of 
printers. The first time you print in a session, it appears multiple times; it appears once 
after the first time you print. To disable this message, add the following lines in the 
.java.policy file in your home directory on the client computer:

Transaction Times

Latency
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grant {
permission java.lang.RuntimePermission “queuePrintJob”;

};

Print Preview

To display a print preview, choose the  > Print Preview... menu item.The Print 
Preview window opens. It is a secondary window that displays a preview of the printed 
graph. The Print Preview window allows you to preview graph images before you print 
them so you can see in advance how changes in print setup options affect your printed 
images.

In the print preview window, you can zoom in on a preview image by moving the 
mouse over it and clicking.

You may also use the following buttons to control the appearance of the print preview:

Button Description

Print... Invokes the standard printing mechanism for your platform.

Print Setup... Opens the Print Setup dialog for setting printing options.

Zoom In Increases the zoom level for the preview image.
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Print Setup

To customize the look of your printed graph, choose the  > Print Setup... menu 
item.The Print Setup dialog opens. 

This dialog offers options for tailoring the look of your printed Component Topology 
Analysis or Transaction Analysis view. Set the following options, then click OK to 
apply your changes, Cancel to close the dialog without applying your changes, Default to 
revert to default values, or Page Setup... to display the Page Setup dialog for selecting 
paper size, orientation, and margins.

Zoom Out Decreases the zoom level for the preview image.

Zoom Percentage Shows the current zoom percentage. You may select a pre-
defined zoom percentage from the list or enter a custom zoom 
percentage.

Fit in Window Scales the preview image to display the complete image in the 
preview window.

Close Closes the Print Preview window.

Button Description
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Option Description

Print Select the part of the graph you want to print. You may print 
the entire graph, only the part of the graph currently visible in 
the view window, or only the selected graph components.

Scale By Set options related to page size. Select Pages and specify the 
number of page rows and columns to scale the image to fit the 
specified page size. The image is not scaled if Actual Size is 
selected. Choose Zoom Level to scale the image to the zoom 
level specified in the view.

Print Caption Select to print the page caption in the Caption field.

Caption Enter text for the page caption. You must select Print Caption 
to enable caption printing. To select the font for the caption, 
click Font... to display the Choose Font dialog.

Position Select the position on the page for the caption to be printed.

Margins Set the distances in inches between the edge of the paper and 
the edge of the graph. Set margins for the top, bottom, left, and 
right edges.

Print Page 
Numbers

Select to print page numbers on each page when printing multi-
ple pages. Page numbers are printed just outside the crop 
marks.

Print Crop Marks Select to print crop marks when printing multiple pages. Crop 
marks are the lines drawn on the margins of pages that connect 
to other pages.

Print Border Select to print a border around the graph. Click Color... to open 
the Choose Color dialog for setting the border color.

Print Background Select to print the background color. To set the background 
color, choose the Layout > Background Color... menu item on the 
Component Topology or Transaction Analysis view.

Print Grid Select to print a background grid.
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Page Setup

Click Page Setup... on the Print Setup dialog to open the Page Setup dialog.

Use this screen to set up page options for printing Component Topology or Transaction 
Analysis graphs. Set the following options, then click OK to activate your changes or 
Cancel to close the dialog without activating your changes.

Option Description

Paper Size: Select a page style from the list.

Paper Source: Select a source from the list.

Margins: Set the distance between the text and the edge of the printed 
page (in inches). Set margins for the top, bottom, left, and right 
edges.

Orientation: Select whether to use Portrait or Landscape for setting up the 
page. Portrait is default (the height of the page is greater than 
the width). For Landscape, the width of the page is greater 
than the height.

Sample: Displays a preview of the selected settings.
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Caption Font
Click Font... on the Print Setup dialog to open the Choose Font dialog.

Use this dialog to select the font to use for the caption when printing a Component 
Topology or Transaction Analysis graph.

Select a font family, text attributes, and font size from the drop-down lists. The sample 
window shows how text on the graphic will look. 

Click OK to make your changes active or Cancel to close the dialog without activating 
your changes.

Border Color
Click Color... on the Print Setup dialog to open the Choose Color dialog. Use this dialog 
to set the border color for printed Component Topology Analysis and Transaction 
Analysis graphs. 

There are three ways to select the border color:

• On the Swatches page, click the desired color. The preview area shows what your 
choice will look like.
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• On the HSB page, click the desired color in the color area. Use the sliding bar to 
adjust the hue, saturation, and brightness levels individually.

• On the RGB page, enter specific values for red, green, and blue, or click the 
desired value on the scale.
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Click OK to make your changes active, Cancel to close the dialog without activating 
your changes, or Reset to reset the border color to the default.

Modify Layouts and Properties
By default, the Transaction Analysis is arranged in a hierarchical layout. While this 
layout is typically the best choice for e-business systems and therefore recommended, 
you may choose to display the Component Topology Analysis in a symmetric layout. 
Note that using a different layout may make it more difficult to follow the flow of 
messages throughout your system.

Hierarchical Layout
To select the hierarchical layout (if it is not the current layout), choose the Layout > 
Hierarchical Style menu item. Components are arranged in a hierarchical organization, as 
in the following example. 

To modify layout properties, choose the Layout > Layout Properties menu item. Make 
desired changes on the Hierarchical page, then click Apply or OK. 
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Orientation
By default, components are arranged from left to right, but you can change the 
orientation from top to bottom, bottom to top, or right to left.

Level Alignment
Level alignment refers to the alignment of icons on the same level. It is similar to text 
alignment within a paragraph. If Orientation is horizontal (Top To Bottom or Bottom 
To Top), you can set the Level Alignment as either Top, Center or Bottom. If 
Orientation is vertical (Left To Right or Right To Left), you can set the Level 
Alignment as either Left, Center or Right.

Left To Right Positions icons so that the roots of the graph are near the left 
of the page, and the leaves of the graph are near the right. The 
levels are vertical.

Top To Bottom Positions icons so that the roots of the graph are near the top 
of the page, and the leaves of the graph are near the bottom. 
The levels are horizontal.

Right To Left Positions icons so that the roots of the graph are near the right 
of the page, and the leaves of the graph are near the left. The 
levels are vertical.

Bottom To Top Positions icons so that the roots of the graph are near the bot-
tom of the page, and the leaves of the graph are near the top. 
The levels are horizontal.



Chapter 4 • Using the Transaction Analysis View
Modify Layouts and Properties

126 TransactionVision User’s Guide

Spacing

The concept of frames is used to control the margins around icons. These options allow 
you to set the spacing between levels of icons and between icons within the same level 
in a graph by adjusting the frames that surround them.

Edge Routing

These options allow you to tailor edge routing.

Variable Level 
Spacing

When enabled, variable level spacing considers the density of 
edges between adjacent levels when adjusting the level spac-
ing. For example, if too many edges cross at the same point 
between levels, then the level spacing is automatically 
increased. Consequently, not all levels would have the same 
spacing. Variable level spacing is usually used in combina-
tion with orthogonal edge routing.

Proportional Spac-
ing

Sets the spacing around each node to a fractional value 
(between 0 and 1) based on the node size.

Constant Spacing Allows the spacing around each node to be a constant value, 
independent of the size of the node.

Between Levels This field allows you to set the spacing between each level in 
the graph. In left-to-right and right-to-left views, levels run 
vertically. In top-to-bottom and bottom-to-top views, levels 
run horizontally. 

Between Nodes This field allows you to set the spacing between adjacent 
components within a level.

Option Description

Orthogonal Routing When enabled, each edge is drawn as a sequence of line 
segments that run parallel to the x- and y-axes. Edges have 
bend points of 90 degrees only. The orthogonal routing 
style works best in combination with variable level spacing 
and ports.

Edge Spacing This field sets the spacing between row and column edges. 
Layout ensures that the distance between edges is at least 
this value.
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Symmetric Layout
To select the symmetric layout (if it is not the current layout), choose the Layout > 
Symmetric Style from the shortcut menu. The symmetric layout distributes components 
evenly with very few edge crossings, as in the following example. 

To modify symmetric layout properties, choose the Layout > Layout Properties menu 
item. Make desired changes on the Symmetric page, then click Apply or OK. 

Straight Edges When enabled, this setting merges the incoming edges of a 
node into a single fork-like structure. Clearer drawings 
result provided the graph is not too dense. This feature is 
only available when orthogonal routing is enabled.

Option Description
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Spring Options

These controls allows you to set the options relating to the spring model of the graph.

General Properties

The General page of the Properties dialog enables you to specify settings that are 
independent of the layout style. To modify general layout properties, choose the Layout 
> Layout Properties menu item. Make desired changes on the General page, then click 
Apply or OK. 

Node Spacing This value is used in determining the white space between 
icons. It specifies the length of each edge as a function of the 
width and height of the icons to which the edge connects. A 
node spacing of zero specifies that edge lengths be just long 
enough to keep icons from touching (i.e., no white space 
between icons). The larger the node spacing value, the 
greater the amount of white space between icons.

Random Seed The initial layout of the graph is keyed to a random number 
sequence. The value set in this field is used to generate the 
random number sequence to set initial coordinates for each 
icon. Each different non-negative value can produce a differ-
ent layout. This field is active when Incremental Layout is 
not checked.
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Spacing Model
The concept of frames is used to control the margins around physical objects. These 
options control which model is used in determining the amount of white space around 
the perimeter of objects in the graph. Two spacing models are available, the 
Proportional Spacing model and the Constant Spacing model. Additional layout-
specific spacing options are available, some of which are affected by the spacing model 
selected here.

Proportional 
Spacing

When enabled, proportional spacing is used to determine the 
amount of white space around the perimeter of an object based 
on the area of the object. For example, if a component’s width 
and height increase, the white space between the component 
and an adjacent component also increases. The margins of the 
graph can be controlled through the Graph Margin Spacing 
fields below. You can set independent proportional spacings for 
the left, right, bottom, and top sides of the graph. Note that 
additional spacing controls are available on the other dialog 
pages.
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Graph Margin Percent
This group of fields affects the margins for graphs. Separate frame values are stored for 
the Constant Spacing and Proportional Spacing models, but only one spacing model is 
in effect at any given time.

Labeling
This option allows you to tailor the automatic positioning of edge labels.
Select Incremental Layout to maintain the relative positioning of labels from a graph’s 
previous layout whenever the graph is modified. Incremental Layout results in graphs 
that maintain the same overall form when changes are made. 

Disconnected Properties
The generic term "disconnected objects" is used to refer to both disconnected icons and 
connected subgraphs, unless otherwise noted. A disconnected icon is one which has no 
edges connected to it. A connected subgraph is a graph in which there is an undirected 
path between each pair of icons. In other words, each icon can be reached from all other 
icons by following the edges that connect them, regardless of edge direction. If there is 
no such path between any two icons, then either the icons belong to different connected 
icons or one of the icons is a disconnected node.

To modify disconnected layout properties, choose the Layout > Layout Properties menu 
item. Make desired changes on the Disconnected page, then click Apply or OK. These 
options only have effect if more than one disconnected object exists within the graph.

Constant Spacing When enabled, a constant space is allocated between like 
objects in a graph. For example, in hierarchical layout a fixed 
distance is set between each pair of adjacent components 
within a level, regardless of the width and height of the nodes. 
The margins of the graph can be controlled through the Graph 
Margin Spacing fields below. You can set independent constant 
spacing values for the left, right, bottom, and top sides of the 
graph. Note that additional spacing controls are available on 
the other dialog pages.
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These settings allow you to edit the proportional and constant spacing between 
disconnected objects of a graph. 

Constant Spacing Specify the minimum amount of white space between adja-
cent rows and columns.

Proportional Spac-
ing

Specify a factional value. The margin around disconnected 
objects is calculated as the product of this fractional value 
and half the height of the node.
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Chapter 5

Using the Event Analysis View

Event Analysis Overview
The Event Analysis view shows all the events in the project that meet query conditions. 
By default, this view displays a number of attributes for each event. 

Number of

Event

Check to 

Click to 

Navigation

View

select event

view details

events

links

commands

attributes

Sort order
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Event Attributes
The following table lists the available attribute columns:

Column Description

API Code The WebSphere MQ or JMS API name or the HTTP request or 
EJB methods name.

API Type For CICS events, the API type (File Control, Interval Control, 
Program Control, Program Start, Start Attach, Task End, Task 
Start, Temporary Storage, and Transient Data).

Application 
Server

For servlet events, the name of the WebSphere MQ application 
server associated with the event. For WebSphere Application 
Server 5.0 Express Edition, the application server name default is 
server1; other names are an alias for this server name.

CICS 
Response Code

For CICS events, the CICS response code associated with the 
event.

CICS SYSID The OS/390 CICS SYSID associated with the event.

CICS Task The OS/390 CICS task associated with the event.

CICS Transac-
tion

The OS/390 CICS transaction ID associated with the event.

Completion 
Code

The completion code in the WebSphere MQ API call return from 
the WebSphere MQ library. 

Connection 
Name

For all technologies, the connection name represents the connec-
tion the event is using. For WebSphere MQ, the connection name 
and queue manager are typically the same, except in the case 
where you open a queue on one queue manager using a connec-
tion (specified with the hConn parameter) to a different queue 
manager over a transmission queue. For example, suppose your 
program opens queue QM1.Q using a connection to queue man-
ager QM1, then later opens QM1.Q using a connection to queue 
manager QM2. This event shows QM1.Q as the object name, 
QM1 as the queue manager, and QM2 as the connection name.
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Data Size For WebSphere MQ events, The size in bytes of the user data 
buffer for MQGET, MQPUT, and MQPUT1 calls. For JMS 
events, the size of JMS user data in send and receive calls. For 
Servlet events, the size of the returning HTML page.

EJB Name For EJB events, the EJB name associated with the event. If the 
Program Name column is displayed, the EJB name also appears 
as the program name.

Entry Time The time stamp of when the event initiated.

Event Time The time used to order the event chronologically. It may be either 
the value of the event entry time or the event exit time, depending 
on the API. For some event types such as those that receive mes-
sages, the important time is not when the event was first called, 
but when it returned (when the message was received). For those 
events, the event time is the event exit time; for all other events, 
the event time is the event entry time.

Exit Time The time stamp of when the event finished.

Host Name The host running the application that called the WebSphere MQ 
or JMS API or the host the WebSphere application server is run-
ning on.

IMS ID The OS/390 IMS identifier associated with the event.

IMS PSB The OS/390 IMS PSB name associated with the event.

IMS Region ID The OS/390 IMS region identifier associated with the event.

IMS Region 
Type

The OS/390 IMS region type associated with the event.

IMS Transac-
tion 

The OS/390 IMS transaction name associated with the event.

JMS Class For JMS events, the JMS class associated with the event.

JMS Excep-
tion Code

For JMS events, the exception code associated with the event.

Column Description
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JMS Queue For JMS events, the name of the JMS queue associated with the 
event.

JMS Topic For JMS events, the name of the topic associated with the event.

Object Name The WebSphere MQ object (queue, distribution list, namelist, 
etc.) associated with the event.

OS390 Job 
Name

The OS/390 Batch job name associated with the event.

OS390 Job 
Step

The OS/390 Batch step name associated with the event.

OS400 Job 
Name

The OS/400 job name associated with the event.

Program Name The name of the program making the event.

Queue Man-
ager

The WebSphere MQ queue manager associated with the Web-
Sphere MQ event. The queue may not be always be the same as 
the connection name. For example, it will be different when you 
are putting to a queue on a different queue manager from your 
connection over a transmission queue.

Reason Code The reason code in the WebSphere MQ API call return from the 
WebSphere MQ library.

Reply To 
Queue

The WebSphere MQ queue in the Reply To field.

Reply To 
Queue Man-
ager

The WebSphere MQ queue manager in the Reply To field.

Resource For CICS events, the resources used by CICS transactions. Cur-
rently, these resources are file name, transient data (TD) queue 
name, and temporary storage (TS) queue name.

Servlet For servlet events, the name of the servlet associated with the 
event.

Column Description
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By default, some columns (for example, those pertaining only to OS/390 events) are 
hidden. See“Set View Options” on page 143 for instructions on showing and hiding 
attribute columns.

Color-Coded Completion Codes
Events with a warning or error completion code are displayed in a different color from 
other events, making them easy to spot. 

Sort Order
If the events are sorted, an arrow to the left of the first attribute column heading 
indicates the sort order. A down arrow indicates that events are sorted in chronological 
order. An up arrow indicates reverse chronological order. If the events are not sorted, 
no arrow is displayed.

For information about sorting, see “Sorting and Navigating Large Numbers of Events” 
on page 139. For instructions on setting the sort order, see “Sort and Navigation 
Options” on page 143.

Navigation
TransactionVision displays events in pages according to the number of events per page 
specified in the Event List Options dialog. See “Set View Options” on page 143 for 
instructions on using this dialog. 

If your Event Analysis view contains more than one page of events, use the following 
navigation links, located below the events, to navigate between pages:

Status Code For servlet events, the status code associated with the event. 
Note: The TransactionVision servlet Sensor is unable to get the 
response status code and any headers in the response object for 
servlet events generated from an HTTP_HEAD request. There-
fore, the status code value for HTTP_HEAD events is always 
N/A.

Technology The technology used by the event. Currently, WebSphere MQ, 
JMS, Servlet, and EJB technologies are supported.

Web Applica-
tion

For servlet events, the name of the web application associated 
with the event.

Column Description
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Important! If a large number of events match your query (greater than 100,000 by default), you 
may optionally disable bi-directional scrolling for faster display. If you disable bi-
directional scrolling, the Prev 10 and Prev links will not appear. See “Sorting and 
Navigating Large Numbers of Events” on page 139 for more information.

Queries and Event Analysis
Query conditions reduce the number of events displayed by restricting the hosts, queue 
managers, programs, times, and APIs associated with displayed events. For instructions 
on using queries, see Chapter 2, “Configuring Queries.”

View Commands
View commands enable you to show selected events in the Transaction Analysis or 
Component Topology Analysis view, view only events in the same local or business 
transaction, view event details, or set display options for the view.

Open and Close the Event Analysis
To open the Event Analysis, choose the Views > Event Analysis menu item. You may also 
open the Event Analysis from the Transaction Analysis view with the Switch View > 
Event Analysis view command menu selection.

Link Description

Page Number Type the page number of the page you wish to display. The num-
bers to the left of this field indicate the current page number and 
the total number of pages. For example, [130/731] indicates that 
the current page is page 130 of 731 total pages.

First Page Displays the first page of events. This navigation link only 
appears after page 10 or greater has been displayed.

Prev 10 Goes back 10 pages. This navigation link only appears after page 
10 or greater has been displayed.

Prev Displays the previous page of events. This navigation link does 
not appear on page 1.

Next Displays the next page of events.

Next 10 Goes forward 10 pages.

Last Page Displays the last page of events.
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TransactionVision displays an Event Analysis view for the current project and query.

Sorting and Navigating Large Numbers of Events

Sorting large numbers of events in the Event Analysis view may take quite a bit of 
time. Enabling bi-directional navigation (so that you can scroll to previous as well as 
following pages in the view) for large numbers of events also slows performance. To 
improve performance in the Event List view, you may choose not to sort results and/or 
enable bi-directional navigation for query results that exceed a certain threshold. 

By default, TransactionVision displays the following dialog if the number of events 
that match the current query is greater than 100,000:

To change the default number of events for this message to be displayed, change the 
value on the Event Analysis Options page; see “Sort and Navigation Options” on 
page 143 for instructions.

The recommended action in response to this message is to modify your query to 
produce fewer events. If you do not wish to modify the query, you may improve 
response time by disabling sorting of events in this view and/or disabling bi-directional 
navigation.
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Sorting Query Results
To sort events in the Event List view, click Yes in response to Sort the query result? For 
faster display, click No.

Allowing Bi-directional Navigation
To enable bi-directional navigation, click Yes in response to Allow bi-directional 
navigation? For faster display, click No. If you do not allow bi-directional navigation, 
the Previous links are not available at the bottom of the view as in the following 
example; only forward navigation is allowed.

When the last page is displayed, the Next link is no longer displayed, as in the following 
example:
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Changing Default Settings
Once you specify whether to sort the query result and allow bi-directional scrolling, 
you may choose to make your selection the new default behavior. If you check the box 
to make this selection the default behavior, the Sort dialog will not appear in the future.

You may also set sorting and navigation defaults on the Event Analysis Options dialog. 
See “Set View Options” on page 143 for instructions.
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Selecting and Deselecting Events

To perform operations such as viewing only events in the same business or local 
transaction or displaying event details, you must select an event. To select an event, 
click your cursor in the checkbox to the left of the event. You may select two events; if 
you select a third event, the first selected event is automatically deselected so that only 
the two most recent events clicked are selected.

To deselect an event, click the checkbox again to clear the checkmark. To deselect all 
selected events (useful if selected events are not near each other in the Event Analysis 
view), click Clear Checks.

Closing the View

The Event Analysis view closes when you select a different view or page from the 
TransactionVision menus.

Refresh the View
To refresh a view with events collected since the view was opened, click the Run Query 
view command.

View Related Events
By default, the Event Analysis displays all events in the project that match the current 
query conditions. 

Business Transaction

To display only events in the same business transaction as an event, click the checkbox 
next to the event to select it and choose the View events as > Business Transaction menu 
item. 

Local Transaction

To display only events in the same local transaction as an event, select the event and 
choose the View events as > Local Transaction menu item. 

No Transaction

To view all events after viewing only events in a local or business transaction, choose 
the View events as > No Transaction menu item.
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Set View Options
To customize the appearance of the Event Analysis, click Options. The Options page 
appears.

Set the following options, then click Finish to activate your changes or Cancel to close 
the dialog without activating your changes:

Event Analysis Options

Events Per Page
The Number of events to display per page option sets the number of events that 
TransactionVision will display per page.

Sort and Navigation Options
Set the default behavior for sorting events and navigating in the Event Analysis view. 
These options are useful for improving performance when large numbers of events 
match the query. By default, TransactionVision displays the following dialog when the 
number of events matching the query exceeds 100,000:
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To change the threshold number at which the dialog is displayed, set the desired value 
for the Minimum number of events for a warning message box to be displayed option.

To display the dialog each time the number of events in this view exceeds the 
threshold, check Display a warning message box when number of events exceeds the 
minimum count. If this option is not checked, TransactionVision uses the default 
behavior set by the user in the dialog. The user’s default is displayed on the Options 
page.

To sort events chronologically when the number of events exceeds the threshold, check 
Sort events by event time when the number of events exceeds the minimum count. If this 
option is not checked, TransactionVision does not sort the events in the Event Analysis 
view. Disabling sorting improves performance for large numbers of events.

To allow bi-directional navigation when the number of events exceeds the threshold, 
check Allow bi-directional navigation of the event list when the number of events exceeds the 
minimum count. If this option is not checked, the Prev and Prev 10 navigational links are 
not shown in the Event Analysis view. Disabling bi-directional navigation improves 
performance for large numbers of events.

To show most recent events first in the Event Analysis view, check Show event list in 
reverse chronological order. By default, events are shown in chronological order if they 
are sorted. This option is not available if sorting is disabled.

Detail Options

Enter the number of bytes of user buffer data to display in the Event Details view.

Time Column Format

Click the Show the date along with the time checkbox to turn on/off the display of the date 
in addition to the time in the Entry Time and Exit Time columns. 
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Select whether times in the Entry Time and Exit Time columns should be displayed in 
millisecond or microsecond format. Note that only events generated on the OS/390 and 
UNIX platforms are recorded with microsecond precision.

Time Zone Options

Select the desired time zone for the Entry Time and Exit Time columns. The timestamp 
for all events is recorded in Greenwich Mean Time, but all times are displayed in local 
time for the selected time zone. 

Event Analysis Columns

To show all columns associated with one or more technologies, check the checkbox for 
the desired technology. The associated columns, shown in the following table, are 
automatically moved to the All Selected Columns list. Clearing a checkbox 
automatically moves associated columns to the All Available Columns list. 

Technology Columns

Common Entry Time, Exit Time, API Code, Host, Program, Tech-
nology

EJB EJB Name

JMS JMS Class, JMS Queue, JMS Topic, JMS Exception Code
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To show a hidden column, select the column name in the All Available Columns list 
and click the right arrow. To hide a visible column, select the column name in the All 
Selected Columns list and click the left arrow. The All Selected Columns list must 
contain at least one column.

To change the order of the columns in the Event Analysis, select a column name in the 
All Selected Columns list and click the up and down arrows.

View Event Details
To view event details for a single event in the Event Analysis, click the API name in the 
event list entry or select the event and click Details. To view event details side-by-side 
for two events, select them and click Compare.The Event Details view opens, 
displaying detailed information about the event. See Chapter 6, “Using the Event Detail 
View,” for more information about this view.

OS390 CICS OS390 Job Name, OS390 Job Step, CICS Task, CICS 
SYSID, CICS Transaction, API Type, Resource, CICS 
Response Code

Servlet Servlet, Status Code, Web Application, Application 
Server

WebSphere MQ Completion Code, Reason Code, Connection Name, 
Queue Manager, MQ Object, Reply To Queue Manager, 
Reply To Queue

WebSphere MQ 
OS390 Batch

OS390 Job Name, OS390 Job Step

WebSphere MQ 
OS390 IMS

IMS Region ID, IMS Region Type, IMS ID, IMS Trans-
action, IMS PSB

Technology Columns
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Menu Item Description

Component Topol-
ogy Analysis

Creates a Component Topology Analysis view. If you are cur-
rently viewing events as a local or business transaction, only 
components related to those transaction events are shown in 
the Component Topology Analysis. If you are currently view-
ing no transactions, the Component Topology Analysis 
reflects all events in the project that meet the current query 
conditions. For more information about using the Component 
Topology Analysis view, see Chapter 3, “Using the Compo-
nent Topology Analysis View.”

Transaction Analysis Creates a new Transaction Analysis view. If you are currently 
viewing events as a business transaction, that business trans-
action is selected and displayed in the Transaction Analysis 
view. Otherwise, the first business transaction in the project is 
selected and displayed. For more information about using the 
Transaction Analysis view, see Chapter 4, “Using the Trans-
action Analysis View.”
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Chapter 6

Using the Event Detail View

The Event Details view provides additional information about any event in the 
Transaction Analysis or the Event Analysis. The Event Details view interprets and 
displays all of the information in the MQMD header information, the dead letter queue 
header, and the user data buffer associated with the event. 

Open and Close the Event Details View
To view details about an event, select the event in the Event Analysis and click Detail. 
The Event Details window opens. This is a secondary window that displays the 
contents of the event data structure fields. If the event is for any of the following calls, 
the window displays the contents of the user data buffer for the event in a separate pane 
below the other fields:

• WebSphere MQ MQPUT, MQPUT1, or MQGET calls. Note that for IBM OS/390 
Batch events, the WebSphere MQ connection handle seen by the user application 
and the one reported by the Analyzer are always different. The user application 
sees the SPC pointer, while the Analyzer reports the real connection handle.

• JMS send or receive calls.

• Servlet HTTP_POST or HTTP_GET requests. When a servlet includes other 
servlets to compose its contents, the user data for each included servlet shows the 
portion of contents it generated. The user data for the parent servlet shows all the 
contents generated by all included servlets, plus its own data.

Important! Note that if the data collection filter assigned to the project specifies to collect the API 
Names Only data range, TransactionVision is unable to display details for events 
recorded with that filter. See the TransactionVision Administrator’s Guide for more 
information about data collection filters.
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Expand and Collapse Details
TransactionVision displays event details in a hierarchy, enabling you to view different 
levels of detail. 

To expand a single node, click . To expand all nodes, click Expand All. 

To collapse the details below a single node, click . To collapse all nodes, click 
Collapse All.

Save Copy of Event Details
To save a copy of the current event as an XML document, click Save as XML. This 
option is only available for Internet Explorer.

Click to collapse
data structure fields.

A + indicates a
collapsed field.

Click it to expand.

User data buffer pane
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Compare Two Events
To compare values for two events, select them both in the Event Analysis view and 
click Compare. The details appear in a secondary window that displays the contents of 
the event data structure fields for both events side-by-side. If the events are both for the 
same call type (for example, both for MQGET events or both JMS send events), any 
fields with different values are highlighted in yellow. Note that any two EJB events are 
comparable, too. The difference will be highlighted and the event detail tree nodes is 
sorted under the same level.

Scroll lock is automatically set for the left and right panes. Scrolling in one window 
automatically scrolls the other window so you can compare fields easily. 

Set Data Buffer Display Options
You may set the following options for the user data buffer contents:
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Option Description

View Data As: Select whether to display the contents of the user data buffer 
in binary or text format.

Code Page: Applies code page conversions to event data. Choose Auto-
Detect or select from available string code conversions.

View MIME Type: Select a MIME type to view or save the contents of the user 
data buffer as and click View. TransactionVision displays the 
contents of the user data buffer as a file of the selected type. 
You may save this file if you wish.
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Chapter 7
Using Reports

Reports provide vertically focused business reporting to specific industries, as well as 
custom business reports and analysis developed to suit your specific requirements.

This chapter provides instructions on using the standard reports installed with 
TransactionVision. For information on creating your own custom reports, see the 
TransactionVision Programmer’s Guide.

Viewing Reports
To view a list of available reports, click Reports. The Available TransactionVision 
Reports page appears.

This page lists all available reports. For each report, it also lists any saved 
configurations. You can save a report configuration after running a report. Saving a 
configuration enables you run a report using the saved configuration settings, rather 
than setting configuration options each time you run the report. This feature is useful 
for reports that you run with the same configuration options on a regular basis, such as 
a daily performance report.
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Running a Report
To run a report, perform the following steps:

1. Click the link for the report. TransactionVision displays a report configuration 
dialog similar to the following: 

Report

Saved
Configuration
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2. Select the reporting time period from the list of predefined time periods. 

• To specify a custom time period, choose Date Range and specify the start and 
end dates and times. The default start and end dates are based on the dates and 
times of events in the project. Click the calendar icon to select a date from a 
calendar control. 

• To include all statistics for the entire project, choose All Time Periods.

3. Different reports may have additional configuration settings; see the section for the 
specific report you are running for information about its configuration settings.

4. For custom reports written with the Actuate reporting tool, specify the desired out-
put format: HTML, PDF, or Excel. For information about integrating Actuate 
reports, see the TransactionVision Programmer’s Guide. 

Important! If you add Actuate reports to TransactionVision, note that the Actuate report engine 
requires an X connection to run. Your web server should be started in an environment 
where DISPLAY is set to a valid X server. By default, it will try to connect to the 
default display, "0:0". If X is not available or permission does not exist for the user to 
access X on the server machine, then you must set the DISPLAY environment variable 
to a valid X server.

5. Click Create Report. TransactionVision runs the report, then displays the results 
page as in the following example. The results page contains the following compo-
nents:

• The report configuration dialog

• A report toolbar for updating the report with different configuration settings, 
generating a print preview of the report results, and saving configuration 
settings

• The chart or table showing report results

Important! To hide the report configuration dialog and report toolbar, click Hide Form in the report 
title. To show a hidden report configuration dialog and report toolbar, click Show Form.
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Saving Configuration Settings
To save the current configuration settings after running a report, perform the following 
steps:

1. Click Save Settings. TransactionVision displays the following dialog:

2. Enter a name and description for the configuration. This information appears on 
the Available TransactionVision Reports page.

3. Click OK. 

Running a Report with Saved Configuration Settings
If you have already saved a report configuration and want to run it again with the same 
settings, click the link for the saved configuration on the Available TransactionVision 
Reports page. TransactionVision runs the report using the saved configuration settings 
and displays the results page.

Configuration Settings

Report Toolbar

Report Results
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Deleting Saved Configuration Settings

To delete saved configuration settings, click the Delete button to the right of the saved 
configuration on the Available TransactionVision Reports page. Only the user that 
saved a configuration may delete it.

Updating a Report

After running a report, you may wish to run it again with different configuration 
settings. To update a report, perform the following steps:

1. On the report results page, change configuration settings as desired.

2. Click Generate Report. TransactionVision runs the report with the new configura-
tion settings and displays the results.

Printing Report Results

Use your browser’s print mechanism to print report results. However, printing the 
report results page prints the configuration settings and report toolbar in addition to the 
report results. To print only the report results, perform the following steps:

1. On the report results page, click Printable View. TransactionVision opens a new page 
showing only the report results. 

2. Choose the browser’s File > Print menu item to print the page.

Service Level Analysis Report
The Service Level Analysis report provides transaction response time and availability 
service level analysis for the current project. The report plots three elements over time 
for each transaction class:

• Average response time

• Maximum transaction response time

• Transaction volume

To run the Service Level Analysis report, perform the following steps:

1. Click the Am I meeting my Service Level Agreement response requirements? link on the 
Reports page. 
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2. Select the reporting time period from the list of predefined time periods. To specify 
a custom time period, choose Date Range and specify the start and end dates and 
times. Click the calendar icon to select a date from a calendar control. To include 
all statistics for the entire project, choose All Time Periods.

3. Check the transaction classes you wish to include in the report. For information 
about defining classes, see the TransactionVision Programmer’s Guide.

4. Click Generate Report. TransactionVision displays the results in a chart similar to 
the example on the following page.

For each transaction class, vertical bars represent transaction volume, triangles 
represent the transaction with the maximum response time, and circles represent 
the average response time.

5. To view more information about a data item in the chart, move your cursor over 
the data item. TransactionVision displays a tool-tip that shows the legend and 
value of the data item.

6. For more detailed information about transactions in the report, do either of the fol-
lowing:

• Click a section of a vertical bar to run the Transaction Tracking report on all 
the transactions it represents. 

• Click a triangle to show the Transaction Details view of the Transaction 
Tracking report for the specific transaction it represents.

For more information about the Transaction Tracking report, see page 162.

7. To zoom in on the results chart, point your cursor to the area of the chart you wish 
to zoom and do either of the following:

• Right-click and choose Zoom In from the shortcut menu.

• Hold the CTRL key and click the chart.
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WebSphere MQ Statistics Report
This report shows statistics on the activity of your WebSphere MQ infrastructure. For 
each queue manager, it reports the following activity for each queue, for both 
WebSphere MQ and JMS:

• Applications interacting with the queue

• Average latency in seconds

• Total number of Get and Put calls received

• Number of successful, warning, or failed Get and Put calls received

To run the WebSphere MQ Statistics report, perform the following steps:

1. Click the How are my WebSphere MQ components performing? link on the Reports 
page. 



Chapter 7 • Using Reports
Application Server Statistics Report

160 TransactionVision User’s Guide

2. Select the reporting time period from the list of predefined time periods. To specify 
a custom time period, choose Date Range and specify the start and end dates and 
times. Click the calendar icon to select a date from a calendar control. To include 
all statistics for the entire project, choose All Time Periods.

3. Click Generate Report. TransactionVision shows the results in a table similar to the 
following example:

Application Server Statistics Report
This report shows statistics on the activity of your EJBs and Servlets. It breaks down 
activity by EJB and EJB method, and by Servlet, showing the following for each:

• Successful call count

• Error call count

• Average latency
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To run the Application Server Performance report, perform the following steps:

1. Click the How are my Application Server components performing? link on the Reports 
page. 

2. Select the reporting time period from the list of predefined time periods. To specify 
a custom time period, choose Date Range and specify the start and end dates and 
times. Click the calendar icon to select a date from a calendar control. To include 
all statistics for the entire project, choose All Time Periods.

3. Click Generate Report. TransactionVision displays results similar to the following 
example:
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Transaction Tracking Report

The Transaction Tracking report enables you to list transactions and drill down into 

individual transactions to analyze their behavior. A number of filtering criteria enable 

you to limit the displayed results to only those transactions with a certain completion 

state, result state, or those transactions that have exceeded the service level. Individual 

transactions can be further examined to display additional details.

To run the Transaction Tracking report, perform the following steps:

1. Click the Where are my transactions link on the Reports page. 
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2. Select the reporting time period from the list of predefined time periods. To specify 
a custom time period, choose Date Range and specify the start and end dates and 
times. Click the calendar icon to select a date from a calendar control. To include 
all statistics for the entire project, choose All Time Periods.

3. Select the transaction states you wish to include in the report. Only transactions 
with the selected state will be included in the report results.

4. Select the transaction result codes you wish to include in the report. Only transac-
tions with the selected result codes will be included in the report results.

5. Check the transaction classes you wish to include in the report. For information 
about defining classes, see the TransactionVision Programmer’s Guide.

6. Specify whether to show only transactions that exceed service level agreements.

7. Specify the number of transactions to show per page of results. If the number of 
transactions that match the setting exceeds this number, TransactionVision gener-
ates multiple pages of results.

8. Click Generate Report. TransactionVision displays results similar to the following 
example:
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By default, this report shows the following information for each transaction that 
meets the report requirements:

• Transaction class. By default, transactions are unclassified. See the 
TransactionVision Programmer’s Guide for information about transaction 
classification.

• Start time

• Response time

• Completion state

• Result state

• Label. By default, transaction labels are null. See the TransactionVision 
Programmer’s Guide for information about modifying transaction attributes.

Furthermore, if you have added rules to the transaction definition file 
$TVISION_HOME/config/services/ 
TransactionDefinition.xml to configure the Analyzer to extract and 
store the other information about transactions (such as session ID, customer ID, 
etc.), the report provides columns for that information as well. For more 
information on adding rules to the transaction definition file, see the 
TransactionVision Programmer’s Guide.
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9. To view details about a particular transaction, click the transaction class link. 
TransactionVision displays the Transaction Details page in a new browser window, 
so you may view details for more than one transaction at a time. The Transaction 
Details page provides the following information for the selected transaction:

• The Summary shows the business transaction ID for the selected transaction.

• The Transaction Flow shows the local transaction ID, application name, start 
time, and processing time for each local transaction within the selected 
business transaction. 

If a message flow starts from the application in a local transaction, a sub-row 
appears. The queue icon in the sub-row indicates that a message flow starts 
from the application. The queue icon is followed by the name of the 
application where the message flow ends. Both the queue icon and the 
application name link to the local transaction where the message flow ends. 
Click this link to navigate to the local transaction where the message flow 
ends.

A sub-row without a queue icon indicates that a control flow starts from the 
application. The sub-row specifies the name of the application where the 
control flow ends. Click the application name in the sub-row to navigate to the 
local transaction where the control flow ends.

Note that processing time for each program does not include the CICS 
TASK_START and TASK_END events, because these events do not contain a 
program name. Therefore, the processing time in this report differs slightly 
from the execution times in the Transaction Analysis view.
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• The Message Flow shows the flow of WebSphere MQ messages between the 
local transactions that make up the selected business transaction. For each 
message, this table shows the departure time, local transaction ID, and 
application name, as well as the arrival time, local transaction ID, and 
application name. It also shows the latency for each message. 

10. To display the Event Details view for an event message in the Transaction Details 
page, click the message link in the Transaction Flow table or the latency link in the 
Message Flow table. The Event Details view opens in a separate browser window. 
For a message flow, separate panes show a side-by-side comparison of the depar-
ture and arrival user data buffer. For a control flow, only the event details for the 
event that corresponds to the destination event in the control flow are shown. For 
more information about the Event Details view, see Chapter 6, “Using the Event 
Details View.” 

11. To display the current business transaction in the Transaction Analysis view, click 
Show in Transaction View on the Transaction Details page. The Transaction Analysis 
View opens in a separate browser window. For more information about the Trans-
action Analysis view, see Chapter 4, “Using the Transaction Analysis View.”

Note that the current query is not applied to the Transaction Analysis view. All 
business transactions are listed in the left pane, with the selected transaction 
highlighted.

12. To display the current business transaction in the Event Analysis view, click Show 
in Event Analysis View on the Transaction Details page. The Event Analysis View 
opens in a separate browser window. For more information about the Event Analy-
sis view, see Chapter 5, “Using the Event Analysis View.”

13. To display the current business transaction in the Component Topology Analysis 
view, click Show in Topology View on the Transaction Details page. The Component 
Topology Analysis View opens in a separate browser window. For more informa-
tion about the Transaction Analysis view, see Chapter 3, “Using the Component 
Topology Analysis View.”

Web Session Report

This report provides access to all transactions by session ID within a specified time 
range. You may optionally specify a customer ID to filter the sessions in the report 
output. 
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Enabling Session Tracking
In order to use this report your Analyzer must be configured to extract and store session 
ID information. This information is not stored by default. To filter using the customer 
ID, the customer field must also be populated for each business transaction. 

To enable analysis and classification of session ID with a servlet's transaction, perform 
the following steps:

1. Modify the transaction.xdm file to include the fields to store the transaction id. 

2. The web session report uses the /Transaction/sessionid and /trans-
action/customer fields to display its report.

To add the customer and session xdm mapping, add the following:

<Column name="customer" type="VARCHAR" size="32" 
description="Customer">

<Path>/Transaction/Customer</Path>
</Column>
<Column name="sessionid" type="VARCHAR" size="32" 
description="SessionId">

<Path>/Transaction/SessionId</Path>
</Column>

3. Enable the Classification bean in the Beans.xml file.

4. Add  the following classification definition to TransactionDefini-
tion.xml.  Add your schema name to the dbschema attribute.

<Class name="web" dbschema="YOUR_SCHEMA_NAME_HERE">
<Classify id="1">      

<Match xpath="/Event/Technology/Servlet/HTTP/Method" 
operator="EQUAL" value="HTTP_GET"/>      

</Classify> 
<Classify id="2">     

<Match xpath="/Event/Technology/Servlet/HTTP/Method" 
operator="EQUAL" value="HTTP_POST"/>     

</Classify> 

<Attribute name="StartTime" final="false">      
<Path>/Transaction/StartTime</Path>        

 <ValueRule name="EventTime">           
 <Value type="XPath">/Event/StdHeader/ 

SecondaryTime</Value>  
 </ValueRule>  
</Attribute>   
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<Attribute name="SessionId">

<Path>/Transaction/SessionId</Path>
<ValueRule name="SetSessionId">

<Match xpath="/Event/StdHeader/TechName" 
operator="EQUAL" value="Servlet"/>

<Value type="XPath">/Event/Technology/Servlet/ 
Session/ID</Value>

</ValueRule>
</Attribute>  

</Class>

5. Add a rule for storing the customer name to TransactionDefinition.xml. 
This rule varies, depending on your system and where this information is stored in 
message data that passes through TransactionVision.

6. Restart your Analyzer, and then create a new project to pick up these changes.

7. Insert the transaction class definition into your new schema by running the follow-
ing sql:

INSERT INTO YOUR_SCHEMA_NAME_HERE.TRANSACTION_CLASS(CLASS_ID, 
CLASS_NAME, SLA) VALUES(1,'web',4);

8. Now start collecting events. The transactions should be classified into the web 
transaction class—this can be verified by going to the Where are my transactions? 
report and seeing web transactions listed. To verify that the session id is stored in 
the transaction table, run the web session report.

Running the Web Session Report
To run the Web Session report, perform the following steps:

1. Click the What transactions occurred within a specific web session? link on the Reports 
page.

2. Select the reporting time period from the list of predefined time periods. To specify 
a custom time period, choose Date Range and specify the start and end dates and 
times. Click the calendar icon to select a date from a calendar control. To include 
all statistics for the entire project, choose All Time Periods.
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3. Optionally specify the customer name to include in the report. If you do not spec-
ify a customer name, the report shows web session information for all customers.

4. Specify the number of results to display per page.

5. Click Generate Report. TransactionVision displays results similar to the following 
example:

For each session, this report shows the session start and end time, the customer, the 
number of transactions in the session, and the dollar value of the session.

6. For information about the transactions that occurred within a specific session, click 
the Session Start link. TransactionVision runs the Transaction Tracking report on 
the transactions within that session.

Capacity Planning Report
The primary purpose of the Capacity Planning report is to make a projection of future 
transaction response times based on current trends. This report displays a graph of 
average response time and transaction volume for each selected transaction class for 
the specified time range. It then performs a linear regression analysis to project forward 
the current transaction response times a specified number of periods. Looking at the 
resulting graph for the intersection of the projected response time to the service level 
for that transaction gives you an estimate of when a particular transaction, using the 
resources it currently has available, might start to exceed its service level.
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To run the Capacity Planning report, perform the following steps:

1. Click the What was my transactional throughput in the past and capacity for the future? 
link on the Reports page. 

2. Select the reporting time period from the list of predefined time periods. To specify 
a custom time period, choose Date Range and specify the start and end dates and 
times. Click the calendar icon to select a date from a calendar control. To include 
all statistics for the entire project, choose All Time Periods.

3. Specify the number of periods into the future to project. You may project one, two, 
or three periods of the same type as the reporting time period.

4. Specify the polynomial degree of analysis to perform when making projections.

5. Select the transaction classes to include in the report. For information about defin-
ing classes, see the TransactionVision Programmer’s Guide.

6. Click Generate Report. TransactionVision displays results in a chart similar to the 
example on the following page.

For each transaction class, this chart shows the following:

• Vertical bars represent transaction volume.

• Solid lines represent actual and projected average response times.

7. To view more information about a data item in the chart, move your cursor over 
the data item. TransactionVision displays a tool-tip that shows the value of the data 
item.

8. To zoom in on the results chart, point your cursor to the area of the chart you wish 
to zoom and do either of the following:

• Right-click and choose Zoom In from the shortcut menu.

• Hold the CTRL key and click the chart.
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Transaction Performance Report

This report displays a gauge showing the average transaction response time for each 
selected transaction class. Additionally, it provides a quality ratio measurement that 
displays the percentage of transactions meeting the service level value.

You may run the Transaction Performance report either for a specific time period in the 
past, or in real-time.

Transaction Performance for a Specific Time Period

To run the Transaction Performance report for a specific time period, perform the 
following steps:

1. Click the How did my transactions perform previously? link on the Reports page. 
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2. Select the reporting time period from the list of predefined time periods. To specify 
a custom time period, choose Date Range and specify the start and end dates and 
times. Click the calendar icon to select a date from a calendar control. To include 
all statistics for the entire project, choose All Time Periods.

3. Select the transaction classes to include in the report. For information about defin-
ing classes, see the TransactionVision Programmer’s Guide.

4. Click Generate Report. TransactionVision displays results in a gauge for each 
selected transaction class, as in the following example:

5. Click the transaction class name on a gauge to run the Transaction Tracking report 
for that transaction class.

6. Click the quality ratio gauge to run the Transaction Tracking report on transactions 
that have exceeded required service levels. 

Transaction Performance in Real Time

To run the Transaction Performance report in real time, perform the following steps:

1. Click the How are my transactions performing? link on the Reports page. 
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2. Select the transaction classes to include in the report. For information about defin-
ing classes, see the TransactionVision Programmer’s Guide.

3. Specify the number of minutes you wish to show performance results for. The 
default value is 60 minutes.

4. Specify the interval (in minutes) that you with to refresh the results. TransactionVi-
sion will continue to update the report results at this interval as long as this report 
page is displayed in the TransactionVision user interface.

5. Click Generate Report. TransactionVision displays results in a gauge for each 
selected transaction class, as in the following example. The time period for the 
results is displayed below each gauge.

6. Click the transaction class name on a gauge to run the Transaction Tracking report 
for that transaction class.

7. Click the quality ratio gauge to run the Transaction Tracking report on transactions 
that have exceeded required service levels. 

Dashboard Report
This report provides an overview of the performance of all activity the following 
categories:

• Transactions
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• Application Servers

• WebSphere MQ

• JMS

For each category, it provides summary information and applicable performance 
statistics, including a graph that plots the activity/volume over the specified time 
interval.

To run the Dashboard report, perform the following steps:

1. Click the How is my IT infrastructure performing? link on the Reports page. 

2. Select the reporting time period from the list of predefined time periods. To specify 
a custom time period, choose Date Range and specify the start and end dates and 
times. Click the calendar icon to select a date from a calendar control. To include 
all statistics for the entire project, choose All Time Periods.

3. Click Generate Report. TransactionVision displays results in text and chart format, 
similar to the example on the following page.

4. To view more information about a data item in a chart, move your cursor over the 
data item. TransactionVision displays a tool-tip that shows the value of the data 
item.

5. To zoom in on a results chart, point your cursor to the area of the chart you wish to 
zoom and do either of the following:

• Right-click and choose Zoom In from the shortcut menu.

• Hold the CTRL key and click the chart.
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Charge-Back Report
This report calculates the charge-back value for different transactions. The rate of 
charge-back is determined by a cost-per-transaction valued defined in the 
COST_PER_TRANSACTION column of the transaction class definition. The cost-
per-transaction is multiplied by the volume of transactions for the given time period.

To run the Charge-Back report, perform the following steps:

1. Click the What are my charge-back costs for the transactional infrastructure? link on the 
Reports page. 

2. Select the reporting time period from the list of predefined time periods. To specify 
a custom time period, choose Date Range and specify the start and end dates and 
times. Click the calendar icon to select a date from a calendar control. To include 
all statistics for the entire project, choose All Time Periods.

3. Select the transaction classes to include in the report. For information about defin-
ing classes, see the TransactionVision Programmer’s Guide.

4. Click Generate Report. TransactionVision displays results in a table similar to the 
following example. If you specify a predefined reporting time period, the table 
shows results from both the current reporting period and the previous one.

Business Impact Report
This report provides a view of the dollar impact of system performance on defined 
business groups. A business group is a group of one or more transaction classes or child 
business groups.
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In order to use this report, you must define business groups and a mapping of 
transaction classes to corresponding business groups. You must also configure the 
Analyzer to extract and store the appropriate Value information.

To set up business groups, see the TransactionVision Programmer’s Guide.

Enabling Value Tracking
In order to use this report your Analyzer must be configured to extract and store value 
information. This information is not stored by default. 

To enable analysis and classification of session ID with a servlet's transaction, perform 
the following steps:

1. Modify the transaction.xdm file to include the fields to store the transaction id. 

2. The Bussiness Impact report uses the /Transaction/value and /trans-
action/sessionid fields to display its report.

To add the value and session xdm mapping, add the following:

<Column name="value" type="DOUBLE" description="Value">
<Path>/Transaction/Value</Path>

</Column>
<Column name="sessionid" type="VARCHAR" size="32" 
description="SessionId">

<Path>/Transaction/SessionId</Path>
</Column>

3. Enable the Classification bean in the Beans.xml file.

4. Add  the following classification definition to TransactionDefini-
tion.xml.  Add your schema name to the dbschema attribute.

<Class name="web" dbschema="YOUR_SCHEMA_NAME_HERE">
<Classify id="1">      

<Match xpath="/Event/Technology/Servlet/HTTP/Method" 
operator="EQUAL" value="HTTP_GET"/>      

</Classify> 
<Classify id="2">     

<Match xpath="/Event/Technology/Servlet/HTTP/Method" 
operator="EQUAL" value="HTTP_POST"/>     

</Classify> 

<Attribute name="StartTime" final="false">      
<Path>/Transaction/StartTime</Path>        
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 <ValueRule name="EventTime">           

 <Value type="XPath">/Event/StdHeader/ 

SecondaryTime</Value>  

 </ValueRule>  

</Attribute>   

           

<Attribute name="SessionId">

<Path>/Transaction/SessionId</Path>

<ValueRule name="SetSessionId">

<Match xpath="/Event/StdHeader/TechName" 

operator="EQUAL" value="Servlet"/>

<Value type="XPath">/Event/Technology/Servlet/ 

Session/ID</Value>

</ValueRule>

</Attribute>  

</Class>

5. Add a rule for storing the value to TransactionDefinition.xml. This rule 

varies, depending on your system and where this information is stored in message 
data that passes through TransactionVision.

6. Restart your Analyzer, and then create a new project to pick up these changes.

7. Insert the transaction class definition into your new schema by running the follow-

ing sql:

INSERT INTO YOUR_SCHEMA_NAME_HERE.TRANSACTION_CLASS(CLASS_ID, 

CLASS_NAME, SLA) VALUES(1,'web',4);

8. Now start collecting events. The transactions should be classified into the web 

transaction class—this can be verified by going to the Where are my transactions? 
report and seeing web transactions listed. To verify that the value is stored in the 
transaction table, run the Business Impact report.

Report Instructions

To run the Business Impact report, perform the following steps:

1. Click the How is system performance affecting each business group? link on the 

Reports page. 
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2. Select the reporting time period from the list of predefined time periods. To specify 
a custom time period, choose Date Range and specify the start and end dates and 
times. Click the calendar icon to select a date from a calendar control. To include 
all statistics for the entire project, choose All Time Periods.

3. To display the change compared to the prior period, check the Show Change vs. 
Prior Period checkbox. This option has no effect if you select All Time Periods.

4. Select the business groups to include in the report. For information about defining 
business groups, see the TransactionVision Programmer’s Guide.

5. Click Generate Report. TransactionVision displays results similar to the following 
example for each selected business group:

The data in the report is grouped into sections according to Business Group. The 
top row of each section (in blue) represents the business group. This row contains 
the aggregated data values for the transaction classes within that group. Subrows in 
each section display data for each transaction class within the business group.

A successful transaction is one that completes and returns a positive status code. 

If you selected Show Change vs. Prior Period, each row is followed by a row showing 
the change from the prior period.
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6. To run the Service Level Analysis report for all transaction classes in a business 
group, click the business group link. TransactionVision opens a separate window 
to display the results of the Service Level Analysis report. For more information 
about this report, see page 157.

7. To run the Service Level Analysis report for a single transaction class, click the 
transaction class link. TransactionVision opens a separate window to the display 
the results of the Service Level Analysis report. For more information about this 
report, see page 157.

8. To run the Transaction Tracking report on the transactions reflected in the Business 
Impact report results, click a Count link. TransactionVision opens a separate win-
dow to display the results of the Transaction Tracking report for the transactions 
included in the count. For more information about this report, see page 162.

Event Replay Report
The Event Replay report enables you to replay, based on a query, the user data in an 
MQPUT, MQPUT1, or MQGET to a particular queue manager/queue. The user data 
for each MQPUT/MQPUT1/MQGET found within the query will be sent to the 
specified queue. The msgid/correlid of a message replayed using this report will be set 
to the same msgid/correlid of the event that is being replayed.

Important! In order for Events Replay report page to work, WebSphere MQSeries needs to be 
configured and installed on the Application Server. The following paths must be added 
to the JVM classpath list of the WebSphere Application Server where 
TransactionVision is installed:

• /opt/mqm/java/lib

• /opt/mqm/java/lib/com.ibm.mqjms.jar

• /opt/mqm/java/lib/fscontext.jar

• /opt/mqm/java/lib/providerutil.jar

• /opt/mqm/java/lib/connector.jar

• /opt/mqm/java/lib/jta.jar

• /opt/mqm/java/lib/com.ibm.mqbind.jar

• /opt/mqm/java/lib/com.ibm.mq.jar

To run the Event Replay report, perform the following steps:

1. Click the Replay WebSphere MQ messages link on the Reports page. 
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2. Specify the following settings:

3. Click Replay Events. TransactionVision replays the events as specified and displays 
results similar to the following example:

Parameter Description

Queue Manager Enter the name of the queue manager on which to replay 
events.

Queue Enter the name of the queue on which to replay events.

Host Enter the name of the host on which to replay events.

Channel Enter the name of the channel on which to replay events.

Port Enter the port number on which to replay events.

Replay Put Event 
Only

Check to replay only MQPUT and MQPUT1 events. Oth-
erwise, MQGET events are also replayed.

Query Name Select the query to use. Only events that match the 
selected query are replayed.
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Chapter 8
Using TransactionVision with

WebSphere Business Integration

TransactionVision Sensors typically monitor WebSphere MQ API calls such as 
MQPUT and MQGET invoked by WebSphere Business Integration Message Brokers 
(WBIMB), rather than the independent message flows that make up the WBI processes. 
The result is that the broker appears as a black box; the Sensor is unable to provide 
insight into the message flow activities. However, TransactionVision provides a WBI 
Sensor that enables TransactionVision to distinguish the various message flows and 
identify individual logical transaction paths within WBI.

Important! See the TransactionVision release notes for information about which versions of WBI 
are supported by TransactionVision.

The WBI Sensor is a WBI plug-in that supports trace nodes, inserted into normal 
execution paths, and failure nodes, inserted into failure paths. You may insert any 
number of processing nodes into an existing message flow at the desired points. Each 
processing node is a checkpoint that collects the state of the current message flow and 
reports it to the Analyzer. The reported event provides information such as broker 
name, message flow name, message data, etc. You may assign a unique label to each 
node; the label is reported in the TransactionVision event associated with the node 
instance.

TransactionVision Nodes
TransactionVision supports the following two types of nodes:

• Trace nodes 

• Failure nodes
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Trace Nodes
The trace node (TransactionVisionTrace) has an input terminal (in) and an output 
terminal (out). You may insert the node at any point within the message flow between 
two existing connected processing nodes. In general, the input terminal of the trace 
node will be connected to the output terminal of an existing source node, while the 
output terminal of the trace node will be connected to the input terminal of the node 
originally connected to the source node.

Failure Nodes
The failure node (TransactionVisionFailure) also has one input terminal (in) and an 
output terminal (failure). In general, you will attach this type of node to the failure 
terminal of an existing node in the message flow through the input terminal. If there is 
already a node attached to the existing node’s failure terminal, this node can be 
reconnected to the failure terminal of the TransactionVision failure node.

Debug Logging
Both trace and failure nodes have a Boolean property called nodeTracing that controls 
informational debug logging. By default, this property is set to false. If you enable this 
property, any informational TransactionVision WBI Sensor events will be recorded in 
the local logging facility supported on the Sensor host. Sensor errors and problems will 
always be logged, regardless of this property setting.

WBI Sensor Events
Events generated by the trace and failure nodes are reported in TransactionVision under 
the API MQSI2TRACE API. This API is an extension API implemented in the Sensor. 
It provides a standard interface to represent message flow states.

The MQSI2TRACE API has the following prototype:

void MQSI2TRACE(
MQHCONN hConn,
BSMQSIMFH *pMFH,
MQMD *pMQMD,
MQLONG nBufferLength,
PMQVOID pBuffer,
PMQLONG pCompCode,
PMQLONG pReason)

The following table describes the parameters for this API:
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The structure BSMQSIMFH is defined by TransactionVision and is used to organize 
information about the message flow. It is defined as follows:

typedef struct tagBSMQSIMFH {
MQCHAR4 StrucId;
MQLONG Version;
MQCHAR48 MsgFlowName;
MQCHAR48 NodeName;
MQCHAR48 NodeLabel;
MQCHAR48 QMgrName;
MQCHAR48 BrokerName;
MQCHAR48 ExecutionGroupName;

} BSMQSIMFH;

Parameter Description

hConn The connection handle to the queue manager associated with 
the broker executing the message flow.

pMFH A pointer to the message flow header structure (BSM-
QSIMFH) defined by TransactionVision.

pMQMD A pointer to the message descriptor structure (MQMD) asso-
ciated with the current message.

nBufferLength The length of the message data reference by pBuffer.

pBuffer Points to the message data at the current stage of message 
flow processing.

pCompCode Points to the completion code representing the current trace 
state. The completion code also indicates the origin of the 
event. Trace nodes always return the completion code 
MQCC_OK. Failure nodes always return MQCC_FAILED.

pReason Points to a reason code.
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The following table describes each field of this structure:

Installation and Configuration
To use the WBI Sensor, you must do the following:

• Integrate the TransactionVision plugin with the Message Brokers Toolkit for 
WebSphere Studio.

• Install the TransactionVision WBI Sensor on the WBIMB platform.

See the TransactionVision Installation and Configuration Guide for instructions on 
installing and configuring the WBI Sensor.

Field Description

StrucId Contains a string that uniquely identifies the struc-
ture. The value for this field is defined as "MFH ".

Version Contains the version number of this structure. In 
the current release, the value of this field is always 
1.

MsgFlowName Contains the name of the message flow associated 
with the current event.

NodeName Contains the name of the type of node associated 
with the current event. For trace nodes, the value is 
ComBristolTVisionTrace. For failure nodes, the 
value is ComBristolTVisionFailure.

NodeLabel Contains the label string associated with the node 
of the current event. This label helps to identify the 
particular trace or failure node instance in a mes-
sage flow.

QmgrName Denotes the queue manager associated with the 
WBIMB handling the current event.

BrokerName Denotes the WBIMB handling the current event.

ExecutionGroupName Denotes the associated execution group for the cur-
rent message flow.
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Node Insertion

Once the installation and configuration tasks are complete, you may insert any number 
of TransactionVision Sensor trace and failure nodes into any message flows through 
the Message Brokers Toolkit. Remember that any changes made to the configuration 
repository must be deployed to the appropriate brokers.

TransactionVision Filtering

TransactionVision filtering support has been extended to support WBI trace and failure 
node monitoring. For both data collection filters and queries, you may filter on the API 
name (MQSI2TRACE), the broker name, and the message flow name. For queries, you 
may also filter on the parameters for the MQSI2TRACE API.

Quick Tour
To illustrate TransactionVision’s WBI monitoring process, modify the Text Messenger 
sample from the WBI sample suite to introduce TransactionVision message flow 
tracing. Before you begin, make sure that TransactionVision has been integrated 
properly for the Message Brokers Toolkit and the WBI Sensor is installed with the WBI 
message broker(s).

Modifying Message Flow

The first step is to modify the Text Messenger message flow by adding 
TransactionVision trace and failure nodes. 

The TEXTMESSENGER node retrieves the original message from the input queue, the 
Add IBM text node processes and modifies the message to add IBM text, and the 
PAGER node delivers the new message to the output queue. If a failure occurs 
somewhere along the flow, the message will be put on a failure queue by the 
TEXTMESSENGER_FAIL node.

Modify this message flow as follows:

1. Insert a TransactionVision trace node named "Before IBM text" between the 
TEXTMESSENGER and Add IBM text nodes. (Right-click the node and select 
Rename... to rename a node.) Connect the trace node in terminal to the out 
terminal of the TEXTMESSENGER node, and the out terminal of the trace node to 
the in terminal of the Add IBM text node. This node captures the flow state before 
the Add IBM text processing.
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2. Insert a trace node named "After IBM text" between the Add IBM text and the 
PAGER nodes. This node captures the flow state after a successful Add IBM text 
processing.

3. Connect a TransactionVision failure node between the TEXTMESSENGER and 
TEXTMESSENGER_FAIL nodes. This node captures the flow state if a failure 
occurs within the message flow.

You may now deploy the modified Text Messenger message flow to the appropriate 
WBI broker.
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