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Before You Install

Welcome to WinRunner, Mercury Interactive’s enterprise functional testing 
tool for Windows 95, Windows 98, Windows NT 4.0, Windows 2000, and 
Windows Me. This guide describes everything you need to know to install 
WinRunner on a standalone computer or on a network. It describes the 
WinRunner package contents, system configuration, registration and 
backup procedures, and how to run the setup program.

Before you begin to install WinRunner, please review the following pre-
installation procedures.

Registering Your Copy of WinRunner

Register your copy of WinRunner to become a licensed user with all rights 
and privileges. Registered users can access technical support and 
information on all Mercury Interactive products, and are eligible for updates 
and upgrades.

Note: You can register your copy of WinRunner on Mercury Interactive’s 
Customer Support site (http://support.mercuryinteractive.com).

If your address changes, notify Mercury Interactive or your local 
representative, so that you can continue to receive product information and 
updates.
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System Requirements

In order to successfully run WinRunner, you need the following minimum 
system requirements:

Platform An IBM-PC or compatible with a Pentium® /100MHz 
or higher microprocessor.

Memory A minimum of 32 MB of RAM memory.

Disk Space 59 MB of free disk space for a compact installation or 
211 MB for a typical or complete installation. You may 
need an additional 9 to 6 MB on the drive where 
Windows is installed, depending on the shared 
components already installed on the machine. (An 
additional 5 MB of free disk space is required during 
the installation process.)

Operating System Windows 95, Windows 98, Windows NT 4.0, Windows 
2000, and Windows Me.

Upgrading from a Previous Version

You can install a standalone version of WinRunner over a previous version. 
Note that any changes made to the tests in the \lib directory or in any other 
files will be overwritten. However, the existing \lib directory will be backed 
up as \lib.bak. Note that if lib.bak already exists, the existing \lib directory 
will not be backed up. You should separately save any files you added or 
changed manually before installing WinRunner 7.01 over a previous 
WinRunner installation. Note that configuration changes made in the 
wrun.ini file will not be overwritten when installing WinRunner 7.01.
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Note: There are documented backward compatibility problems with 
Microsoft ODBC 4, which is installed by WinRunner, Microsoft Office 2000, 
and other applications. When any of these programs is installed on a 
machine where TestDirector 5.0 is installed, TestDirector may behave 
unexpectedly.

Note: When upgrading to WinRunner 6.0 or higher, make sure to upgrade 
to TestDirector 6.0 or higher, or install the software that installs ODBC 4 on 
another machine.

Note that you cannot install WinRunner over WinRunner 2000 or 
WinRunner EURO. You must uninstall WinRunner 2000 or WinRunner 
EURO before installing WinRunner. For more information, see “Uninstalling 
WinRunner” on page 29.

Installing on Windows NT or Windows 2000

If you are installing WinRunner on Windows NT or Windows 2000, 
make sure you have administrator permissions before you run the 
setup program. 
Otherwise, you will receive a warning message and the setup program 
will close.
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Installing WinRunner

You can install WinRunner on a local computer or on a network drive. The 
main steps for a WinRunner installation are as follows:

Standalone Installation

➤ Install WinRunner using the Standalone option.

➤ If you plan to test a Visual Basic application, configure Visual Basic support.

Network Installation

➤ Install WinRunner using the Network option.

➤ Run the workstation installation on each user workstation.

➤ If you plan to test a Visual Basic application, configure Visual Basic support.

Note: If you add WinRunner add-ins to a network installation after 
installing workstations from that network installation, you need to re-run 
the workstation setup to update each workstation with the list of available 
add-ins.

Running a Standalone or Network Installation

You use the following procedure in order to install WinRunner on a 
standalone computer or on a network drive. If you are performing a network 
installation, follow the procedure below, and then run the workstation 
installation on each user workstation as described on page 16.

To install WinRunner:

 1 Insert the CD-ROM into the CD-ROM drive. If the CD-ROM drive is on your 
local machine, the WinRunner Setup window opens. If you are installing 
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from a network drive, connect to it and run autorun.exe under the \setup 
subdirectory. 

If you want to view the Readme file, click Readme. If you want to browse 
the WinRunner Installation CD-ROM, click Browse. If you want to open an 
overview of WinRunner, click Quick Preview.

 2 Click Install. The WinRunner Setup splash screen and the Setup progress bar 
open.

 3 The software license agreement is displayed. To install WinRunner, you 
must accept the terms of the license agreement by clicking Yes. If you click 
No, the setup program will close. 

 4 In the Registration Information screen, type your name, the name of your 
company, and a WinRunner maintenance number. This number can be 
found in the Maintenance Pack Number envelope or on the bill of lading 
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you received when you purchased WinRunner. Note that there is a single 
maintenance number for each team of users. (The maintenance number 
replaces what was formerly a serial number for each purchased copy of 
WinRunner. The maintenance number identifies the customer.)

Click Next.

 5 Click Yes to confirm the registration information.

 6 Do one of the following:

➤ To install on a hard disk of a local computer, click Standalone 
Installation.

➤ To install on a network drive, click Network Installation.

➤ To install on a network drive and configure your workstation to run 
WinRunner from the network, click Network Installation and add 
shortcuts to your Start menu. 
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Note: You cannot install a network installation over a previous version of 
WinRunner.

Click Next.
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 7 If you are installing WinRunner on Windows 2000, the Enable Memory 
Access screen opens.

WinRunner’s text recognition on Windows 2000 requires access to memory 
pages that are protected by default. Choose whether to remove this 
protection. Note that if you do not remove this protection, WinRunner will 
not be able to perform text recognition on your applications.
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 8 Setup prompts you to install DCOM if you:

➤ are installing WinRunner on Windows 95, and 

➤ do not have DCOM version 4,71,0,2618 installed, and 

➤ are performing one of the following:

➤ a standalone installation

• a network installation that adds shortcuts to your Start menu

Note that DCOM must be installed on your machine in order to install 
WinRunner. 

If you click Next to install DCOM, the WinRunner setup program closes and 
the DCOM installation begins. Once you finish installing DCOM, you must 
reboot your computer and then restart the WinRunner setup program.

 9 Choose the type of installation: Typical, Compact, or Custom.

Typical Installation installs commonly used program files, including online 
documentation and samples, WebTest add-in support, and add-in support 
for PowerBuilder and Visual Basic applications and ActiveX controls. Note 
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that you can choose which add-ins to load at the beginning of each 
WinRunner session. For additional information on loading add-in support, 
refer to Chapter 2, “WinRunner at a Glance,” in the WinRunner User’s Guide.

Compact Installation installs only the required WinRunner program files, 
without online documentation, samples, WebTest add-in support, or add-in 
support for PowerBuilder and Visual Basic applications and ActiveX 
controls.

Custom Installation enables you to select which components to install.

Note: When you install a standalone installation of WinRunner, Microsoft 
ODBC version 4.0 is installed on your machine. 

Click Next.

 10 If you chose Custom Installation, the Select Components screen opens. 
Select the components you want to install. You can also specify the 
destination folder using the Browse button. To check the space available on 
a disk drive, click Disk Space.
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Click Next.

 11 If you chose Typical or Compact Installation, the Choose Destination 
Location screen opens. Specify the destination folder. To check the space 
available on a disk drive, click Disk Space.

Click Next.
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 12 If you have Microsoft Internet Explorer version 3.0 or higher installed (or 
any other software that installs wininet), you can check the Mercury 
Interactive Web site for updated components. 

Click Yes to check the Mercury Interactive Web site for updated 
components. If you want to install the components from the CD-ROM 
without checking for updated components, click No. Click Use local update 
folder only if you know that updated components have already been 
downloaded to a folder on your local network. See page 18 for more 
information on this option.

Click Next.

Note: If you are installing WinRunner over a previous WinRunner 
installation, you are prompted to overwrite the installed components.

➤ To overwrite existing components, click Overwrite.

➤ To add new components, only, click Add.
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 13 If you chose Yes in the Update Components screen, the installation checks 
the Mercury Interactive Web site for updated components. If there are 
components on the Web site that are newer than components on the CD-
ROM, setup prompts you to overwrite the CD-ROM components with the 
Web site components. If no newer components are found on the Web site, 
then setup installs all components from the CD-ROM.

If the installation cannot access the Web site, you can click Retry to try to 
connect to the Web site again. If you click Cancel, setup installs the 
WinRunner components from the CD-ROM.

 14 If you selected Network Installation and add shortcuts to your Start menu 
earlier in the setup, the Choose Local WinRunner Folder screen opens. Select 
a location for the local WinRunner folder. This folder enables you to 
configure WinRunner to meet your specific testing requirements, while 
running a shared version over the network.

Click Next.
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 15 Choose the location of your WinRunner temporary folder. 

Click Next.

 16 Review the settings you selected. To select different settings, click Back. To 
confirm the settings, click Next.



Installing WinRunner

15

 17 Select the program folder for the WinRunner icons.

Click Next to proceed.

 18 The installation settings you selected are displayed in a read-only window. 
Review the settings. If you want to select different settings, click Back. If you 
are satisfied with the settings, click Next. 

The installation process begins. To pause or quit the installation process, 
click Cancel.

 19 Read the information about accessing online documentation. If you 
installed add-in support for Visual Basic applications, additional 
information appears on your screen. Click Next to proceed.

The installation process is complete.

 20 Read the information about Mercury Interactive’s Customer Support. If you 
register, you receive:

➤ access to Mercury Interactive’s award-winning customer support Web site

➤ notification of new product releases and upgrades
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To register now as a Mercury Interactive customer, select the Register now 
check box. Mercury Interactive’s customer support Web site opens to the 
registration page.

Click Next.

 21 Choose whether or not to restart your computer and click Finish.

If you installed WinRunner on the network, run a workstation installation 
on all workstations. See the next section for details.

➤ To read any last-minute information, click Start > Programs > WinRunner > 
Read Me. The Readme file opens in Microsoft Wordpad.

➤ To view the WinRunner online books, you must have Acrobat Reader 4.0 
installed. You can install it by clicking Start > Programs > WinRunner > 
Documentation > Acrobat Reader Setup and following the on-screen 
instructions. To view online books, click Start > Programs > WinRunner > 
Documentation > WinRunner Books Online.

➤ To start WinRunner, click Start > Programs > WinRunner > WinRunner.

Running a Workstation Installation

A workstation installation should be performed for each user running 
WinRunner from the network. This installation can be performed only after 
the network installation is successfully completed. 

 1 Click Start > Run.

 2 Type <network installation_directory>\setup\setup.exe and click OK.

Note: If you try to start WinRunner before restarting your computer, 
WinRunner will not run properly.

Note: If you installed WinRunner on Windows NT or Windows 2000, 
then after restarting your computer, you must log in (for the first time) 
with the same login name that was used when installing WinRunner.
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The WinRunner setup program starts. The WinRunner Setup splash screen 
and the Setup progress bar open.

 3 The software license agreement appears. To install WinRunner, you must 
accept the terms of the license agreement by clicking Yes. If you click No, 
the setup program will close.

 4 In the Registration Information dialog box, type your name and click Next.

 5 In the Registration Confirmation screen, click Yes to confirm the 
registration information.

 6 Confirm the Workstation Installation message and click Next.

 7 Setup prompts you to install DCOM if you:

➤ are installing WinRunner on Windows 95, and 

➤ do not have DCOM version 4,71,0,2618 installed

Note that DCOM must be installed on your machine in order to install 
WinRunner. 

If you click Next to install DCOM, the WinRunner setup program closes and 
the DCOM installation begins. Once you finish installing DCOM, you must 
reboot your computer and then restart the WinRunner setup program.

 8 Define the location for the local WinRunner folder.

The WinRunner folder on your hard drive is used to store configuration files 
you create during the testing process. Configuration files in this folder 
override configuration files of the same name on the network, so that you 
can configure WinRunner to your specific testing requirements.

Click Next.

 9 Select the location of your WinRunner temporary folder.

Setup updates and installs system files.

Click Next.

 10 Select the program folder for the WinRunner icons.

Click Next.



WinRunner Installation Guide

18

 11 Restart your computer. 

The WinRunner program folder is added to your Start menu.

➤ To read what’s new in WinRunner and any last-minute information, click 
Start > Programs > WinRunner > Read Me. The Readme file opens in 
Microsoft Wordpad.

➤ To view the WinRunner online books, you must have Acrobat Reader 4.0 
installed. You can install it by clicking Start > Programs > WinRunner > 
Documentation > Acrobat Reader Setup and following the on-screen 
instructions. To view online books, click Start > Programs > WinRunner > 
Documentation > WinRunner Books Online.

➤ To start WinRunner, click Start > Programs > WinRunner > WinRunner.

Using a Local Network Drive for Updates

You can download WinRunner installation updates from the Mercury 
Interactive Web site to a network drive and then access the local network 
drive to update your WinRunner installations.

To download updates to a local network drive:

 1 Insert the CD-ROM into the CD drive and run <CD drive>\update.exe.

Note: If you try to start WinRunner before restarting your computer, 
WinRunner will not run properly.

Note: If you installed WinRunner on Windows NT or Windows 2000, 
then after restarting your computer, you must log in (for the first time) 
with the same login name that was used when installing WinRunner.
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 2 The Download Updates screen opens.

Choose the local network drive for the WinRunner update files. Click Next.

 3 Setup begins to download the files. When the download is complete, the 
Updates Download Complete screen opens. Click Finish.

Note: When you run update.exe, the program downloads all posted updates, 
regardless of their contents and versions. When installing updates from a 
local path, however, the setup program downloads in the same way as it 
downloads from the Web site, installing only those components that are 
part of the current installation and newer than the components on the CD-
ROM. 

Once the updates have been downloaded to a local network drive, you can 
link to that drive from the WinRunner installation in order to download the 
updates locally.
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To download updates from a local network drive:

 1 When the Update Components screen of the WinRunner installation opens, 
select Use local update folder.
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 2 The Select Downloaded Updates Path screen opens.

Use the Browse button to select the path where the updates are stored. Click 
Next. The installation program checks the specified network folder for 
updated components. If there are components in the update folder that are 
newer than components on the CD-ROM, setup prompts you to overwrite 
the CD-ROM components with the update folder components. When the 
check is complete, the installation program continues as described in step 
14 on page 13.
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Configuring Visual Basic 4.0 Support

Before you can start using WinRunner’s extended support for Visual Basic 
4.0 in Windows 95, Windows 98, Windows NT, Windows 2000, or Windows 
Me Visual Basic applications (32-bit), you need to compile the WinRunner 
OCX (wrvb40.ocx) in the application under test.

To configure 32-bit Visual Basic 4.0 support:

 1 Start Visual Basic 4.0 and open the project.

 2 Select Tools > Custom Controls.

 3 In the Custom Controls dialog box, select the Wrvb40 OLE Custom Control 
Module item. Click OK. The item is added to the toolbar.

 4 Drag the new item onto the main application form.

 5 Right-click this object and select View Code.

 6 Select Object > Form.

 7 Insert the following line into the beginning of the Form_Load function: 

Wrvb1.Init Forms

For example:

Private Sub Form Load ()
...
Wrvb1.Init Forms
...
End Sub

 8 Run or recompile your application and run the .exe file.
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Configuring Visual Basic 5.0 and 6.0 
Support

WinRunner’s add-in support for Visual Basic 5.0 and 6.0 applications 
includes all the support provided for Visual Basic 4.0 applications, plus:

➤ all standard Visual Basic 5.0 and 6.0 controls

➤ Visual Basic projects that create ActiveX controls

Preparing Your Visual Basic Application

Before you can start testing a Visual Basic application using WinRunner’s 
add-in support for Visual Basic 5.0 and 6.0, the application developer must 
add the WinRunner agent to the application. To do so, the developer runs 
the setup.exe program from the \vbdev directory on the WinRunner 
installation CD-ROM.

Note that if the application currently references the WinRunner OCX, you 
must first remove all references from forms, as well as the associated code 
(Wrb1.Init Forms).

The WinRunner agent installation installs an AddIn to your Visual Basic 
IDE. The name of this AddIn is WinRunnerAddIn.Connect. It adds lines of 
code to your Visual Basic source code.

WinRunnerAddIn.Connect

➤ adds a reference to the wrvbasr.dll component

➤ adds a new code Module to the Visual Basic project called 
“WinRunnerSupport”

➤ adds a line to the WinRunnerSupport Module:

Global asr As New WRVBASRLib.VbMod



WinRunner Installation Guide

24

➤ adds code to the StartUp object:

If the Startup Object is a Form, the AddIn adds the following line of code to 
the Form_Load event: asr.Init Forms

If the Startup Object is Sub Main, the AddIn adds the following line of code 
to the Main() method: asr.Init Forms

➤ For all Class modules in the project, the AddIn adds the following line of 
code to the Class_Intialize event: asr.Init Forms

➤ For all UserControl modules in the project, the AddIn adds the following 
line of code to the UserControl_Intialize event: asr.Init Forms, UserControl

➤ For all UserDocument modules in the project, the AddIn adds the following 
line of code to the UserControl_Intialize event: asr.Init Forms, UserDocument

Note: If the error message “DllRegisterServer in <windows 
directory>\system\wrvbasr.dll failed” appears during the WinRunner agent 
installation, copy the file oleaut32.dll (version 2.20.4054.1 or higher) to 
your system directory and re-install the WinRunner agent. 

Do not run WinRunner and the Visual Basic IDE together.

Test your application only as a running executable.
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Enabling Table Contents Checks for an 
ActiveX Control

To enable support for contents verification on any ActiveX control that can 
be viewed as a table object, you must implement a capture function for the 
ActiveX control in Visual Basic and then execute a TSL function.

WinRunner includes Visual Basic project files (wrvbsrv4.vbp for Visual Basic 
4.0 and wrvbsrv5.vbp for Visual Basic 5.0 and 6.0) that compile into an OLE 
Automation Server. WinRunner uses this server to capture table contents. 

Follow these steps to enable contents verification on an ActiveX control that 
can be viewed as a table object:

 1 Start Visual Basic 4.0/5.0/6.0.

 2 In Visual Basic, open the appropriate wrvbsrv project file (wrvbsrv4.vbp or 
wrvbsrv5.vbp) located in the WinRunner installation folder under 
custom\wrvbsrv.

 3 Open capture.cls and add a Sub with the following prototype:

Public Sub<CaptureFunctionName>(ByVal <tab_ctrl> As Object, ByVal 
<file_name> As String)

The function should dump the table contents of the ActiveX control into 
<file_name> in the following format:

cells separated by Tab(Chr(9)), rows separated by Newline.

Note: Cell data should not contain escape characters such as Tabs or 
Newlines. Cells in the first row (Column Titles) should not contain either 
escape characters or space characters. See the MSGridCapture Sub for an 
example.
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 4 Compile the project into a .dll.

For Visual Basic 4.0, from the File menu select Make OLE DLL file.

For Visual Basic 5.0 or 6.0, from the File menu select Make WRVBSRV DLL 
file.

 5 In WinRunner, execute the add_table_capture_function statement. Set the 
second argument to the name of the Sub you implemented in the Visual 
Basic function. For example:

add_table_capture_function ("MSGrid.Grid", "MSGridCaptureFunc");
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Adding WinRunner Components

Once you install WinRunner, you can run the setup program at any time to 
add program components, such as an additional development environment 
or control support, samples, or online documentation.

To add components:

 1 Insert the CD-ROM into the drive from which you want to add WinRunner 
components. If the CD drive is on your local machine, the WinRunner 
Setup window opens. If you are installing from a network drive, connect to 
it and run autorun.exe under the \setup subdirectory.

 2 Click Install. The WinRunner setup program starts. The WinRunner Setup 
splash screen and the Setup progress bar open.

 3 The software license agreement appears. To accept the terms of the license 
agreement, click Yes. If you click No, the setup program will close. To install 
additional WinRunner components, you must accept the license agreement.

 4 In the Registration Information dialog box, type your name, the name of 
your company, and a WinRunner maintenance number. You can find this 
number on the outside of your WinRunner box. Click Next to proceed.

 5 Click Yes to confirm the registration information.

 6 Select your installation type: Standalone Installation, Network Installation, 
or Network Installation and add shortcuts to your Start menu. Click Next to 
proceed.

 7 Choose Custom Installation. Click Next to proceed.

 8 Select the components you want to install and specify the destination 
folder. Click Next to proceed.

 9 Select Yes, No, or Use local update folder to set your update components 
preferences. Click Next to proceed.
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 10 If you select a component that is already installed, you are prompted to 
overwrite it. To overwrite existing components of WinRunner, click the 
Overwrite button. If you do not want to overwrite existing components of 
WinRunner, click Cancel. The previous window reopens and you can 
modify your selection.

 11 If you chose Network Installation and add shortcuts to your Start menu in 
step 6, select a location for the local WinRunner folder. Click Next to 
proceed.

 12 Select a location for temporary WinRunner files. Click Next to proceed.

 13 Select a program folder for WinRunner icons. Click Next to proceed.

 14 The installation settings you selected are displayed in a read-only window. 
Review the settings. If you want to select different settings, click Back. If you 
are satisfied with the settings, click Next. 

The installation process begins.

To pause or quit the installation process, click Cancel.
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Uninstalling WinRunner

Your WinRunner installation includes an uninstall program that uninstalls 
WinRunner software and files from your computer and removes WinRunner 
shortcuts from your Start menu. 

To uninstall WinRunner:

 1 Click Programs > WinRunner > Uninstall WinRunner on your Start menu.

The Uninstall Shield window opens.

 2 You may be prompted to remove shared files that are not in use by any 
program. If you are not sure what to do, click No to All.

UninstallShield removes WinRunner from your computer.

 3 When the Uninstall program is completed, the OK button is enabled. Click 
OK.

 4 You must reboot your machine to complete the uninstall process or before 
reinstalling WinRunner.
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	Click Next.
	21 Choose whether or not to restart your computer and click Finish.
	Note: If you try to start WinRunner before restarting your computer, WinRunner will not run prope...
	Note: If you installed WinRunner on Windows NT or Windows 2000, then after restarting your comput...

	If you installed WinRunner on the network, run a workstation installation on all workstations. Se...



	Running a Workstation Installation
	A workstation installation should be performed for each user running WinRunner from the network. ...
	1 Click Start > Run.
	2 Type <network installation_directory>\setup\setup.exe and click OK.
	The WinRunner setup program starts. The WinRunner Setup splash screen and the Setup progress bar ...
	3 The software license agreement appears. To install WinRunner, you must accept the terms of the ...
	4 In the Registration Information dialog box, type your name and click Next.
	5 In the Registration Confirmation screen, click Yes to confirm the registration information.
	6 Confirm the Workstation Installation message and click Next.
	7 Setup prompts you to install DCOM if you:
	Note that DCOM must be installed on your machine in order to install WinRunner.
	If you click Next to install DCOM, the WinRunner setup program closes and the DCOM installation b...
	8 Define the location for the local WinRunner folder.
	The WinRunner folder on your hard drive is used to store configuration files you create during th...
	Click Next.
	9 Select the location of your WinRunner temporary folder.
	Setup updates and installs system files.
	Click Next.
	10 Select the program folder for the WinRunner icons.
	Click Next.
	11 Restart your computer.
	Note: If you try to start WinRunner before restarting your computer, WinRunner will not run prope...
	Note: If you installed WinRunner on Windows NT or Windows 2000, then after restarting your comput...

	The WinRunner program folder is added to your Start menu.

	Using a Local Network Drive for Updates
	You can download WinRunner installation updates from the Mercury Interactive Web site to a networ...
	To download updates to a local network drive:
	1 Insert the CD-ROM into the CD drive and run <CD drive>\update.exe.
	2 The Download Updates screen opens.
	Choose the local network drive for the WinRunner update files. Click Next.
	3 Setup begins to download the files. When the download is complete, the Updates Download Complet...
	Once the updates have been downloaded to a local network drive, you can link to that drive from t...

	To download updates from a local network drive:
	1 When the Update Components screen of the WinRunner installation opens, select Use local update ...
	2 The Select Downloaded Updates Path screen opens.
	Use the Browse button to select the path where the updates are stored. Click Next. The installati...



	Configuring Visual Basic 4.0 Support
	Before you can start using WinRunner's extended support for Visual Basic 4.0 in Windows 95, Windo...
	To configure 32-bit Visual Basic 4.0 support:
	1 Start Visual Basic 4.0 and open the project.
	2 Select Tools > Custom Controls.
	3 In the Custom Controls dialog box, select the Wrvb40 OLE Custom Control Module item. Click OK. ...
	4 Drag the new item onto the main application form.
	5 Right-click this object and select View Code.
	6 Select Object > Form.
	7 Insert the following line into the beginning of the Form_Load function:
	For example:
	8 Run or recompile your application and run the .exe file.


	Configuring Visual Basic 5.0 and 6.0 Support
	WinRunner’s add-in support for Visual Basic 5.0 and 6.0 applications includes all the support pro...
	Preparing Your Visual Basic Application
	Before you can start testing a Visual Basic application using WinRunner’s add-in support for Visu...
	Note that if the application currently references the WinRunner OCX, you must first remove all re...
	The WinRunner agent installation installs an AddIn to your Visual Basic IDE. The name of this Add...
	WinRunnerAddIn.Connect
	If the Startup Object is a Form, the AddIn adds the following line of code to the Form_Load event...
	If the Startup Object is Sub Main, the AddIn adds the following line of code to the Main() method...
	Note: If the error message “DllRegisterServer in <windows directory>\system\wrvbasr.dll failed” a...
	Do not run WinRunner and the Visual Basic IDE together.



	Enabling Table Contents Checks for an ActiveX Control
	To enable support for contents verification on any ActiveX control that can be viewed as a table ...
	WinRunner includes Visual Basic project files (wrvbsrv4.vbp for Visual Basic 4.0 and wrvbsrv5.vbp...
	Follow these steps to enable contents verification on an ActiveX control that can be viewed as a ...
	1 Start Visual Basic 4.0/5.0/6.0.
	2 In Visual Basic, open the appropriate wrvbsrv project file (wrvbsrv4.vbp or wrvbsrv5.vbp) locat...
	3 Open capture.cls and add a Sub with the following prototype:
	The function should dump the table contents of the ActiveX control into <file_name> in the follow...
	4 Compile the project into a .dll.
	For Visual Basic 4.0, from the File menu select Make OLE DLL file.
	For Visual Basic 5.0 or 6.0, from the File menu select Make WRVBSRV DLL file.
	5 In WinRunner, execute the add_table_capture_function statement. Set the second argument to the ...
	Adding WinRunner Components
	Uninstalling WinRunner


