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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

HP provides third-party products, software, and services that are not HP Branded “AS IS” without warranties 
or representations of any kind from HP, although the original manufacturers or third party suppliers of such 
products, software and services may provide their own warranties, representations or conditions. By using 
this software you accept the terms and conditions.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2006- 2007 Hewlett-Packard Development Company, L.P.

Trademark Notices

HP Select Audit includes software developed by third parties. The software HP Select Audit uses includes:

• ANTLR Copyright 2005 Terrence Parr.

• commons-logging from the Apache Software Foundation.

• Install Anywhere, Copyright 2004 Zero G Software, Inc.

• Jasper Decisions Copyright 2000-2006 JasperSoft Corporation.

• JavaScript Tree, Copyright 2002-2003 Geir Landro.

• Legion of the Bouncy Castle developed by Bouncy Castle.

• log4J from the Apache Software Foundation.

• Microsoft SQL Server 2005 JDBC Driver

• OpenAdaptor from the Software Conservancy.

• Oracle JDBC Thin Driver

• Quartz, Copyright 2004 - 2005 OpenSymphony

• spring-framework from the Apache Software Foundation.

• Tomahawk from the Apache Software Foundation.

• treeviewjavascript from GubuSoft.

• Xalan-Java from the Apache Software Foundation.

• Xerces-Java version from the Apache Software Foundation.

Please check the <install_dir>/3rd_party_license folder for expanded copyright notices from such 
third party suppliers.
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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

You can visit the HP software support web site at:

www.hp.com/go/hpsoftwaresupport

HP Software online support provides an efficient way to access interactive technical support tools. As a valued 
support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels and HP Passport, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To find more information about HP Passport, go to:

 http://h20229.www2.hp.com/passport-registration.html
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1 Overview
This guide describes how to use the Report Designer to create reports.

What is the Report Designer?

The Report Designer is a Java-based graphical user interface that lets you create interactive 
or printed reports. The reports can contain any number of tables, crosstabs, and charts. The 
tables can be simple or grouped by rows, and you can easily modify the layout to make more 
complex free-form tables. Your reports can use data from one or several data sources. You can 
position text elements and images anywhere you want, inside or outside the tables. You can 
preview your report, using live data, without leaving the Report Designer.

What’s in This Guide?

The chapters in this guide are shown in Table 1.

The desktop system used to run the Report Designer Java application makes SOAP calls back 
to the Report Center. Consequently the JVM installed on the desktop used to run the Report 
Designer should NOT be setup to use a proxy server for network connections. If using this 
setting, the SOAP calls will be sent to the proxy server instead of the Report Center, resulting 
in an inability to connect to the Report Center.

See the HP Select Audit 1.02 Release Notes (SAudit_release_notes_1.02.html) on the 
Select Audit installation CD for known installation issues at the time of this release.

Table 1 Chapter Summary

Chapter Description

Chapter 1, Overview Gives an overview of the HP Select Audit 1.02 Report 
Designer’s Guide.

Chapter 2, User Interface 
Overview

Defines the terms and concepts used in Select Audit reports.

Chapter 3, Creating a Query Shows how to make the SQL query that you will use to 
create the reports in this guide.

Chapter 4, Creating a Simple 
Table

Shows how to create a basic rows-and-columns table. Also 
introduces basic styling concepts.
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What This Guide Is and Is Not

This guide shows how to build several representative reports. The reports illustrate the 
various functions available to you in the Report Designer. These reports are not designed to 
be realistic and are not templates for real reports.

This guide does not provide an exhaustive description of the user interface, nor does it tell you 
every way to accomplish a given task. Like most graphical user interfaces, Report Designer 
provides many different ways to perform certain tasks. This document only shows one way to 
perform a task. Typically, there are many others as well.

Finally, this book does not show how to use RDL. RDL is Select Audit’s XML-based report 
definition language. You can edit RDL within the Report Designer at any time by editing the 
text in the RDL tab. This document does not show how to hand-edit RDL.

How to Use this Guide

Make sure to read Chapter 3, Creating a Query. The other reports that you will create will use 
the query in that chapter. Also, if possible, follow the rest of the guide sequentially, since in 
some cases, chapters rely on information in previous chapters.

Chapter 5, Creating a Group 
Table

Shows how to create a table with row grouping.

Chapter 6, Creating a 
Free-form Group Table

Shows how to move data and text elements of a table around 
the layout to create a custom table design.

Chapter 7, Creating a 
Crosstab

Shows how to create a crosstab.

Chapter 8, Creating a Chart Shows how to create a chart.

Chapter 9, Creating a 
Multi-component Report

Shows how to create a report with multiple components. 
This example contains a table, a crosstab, text elements and 
image fields.

Chapter 10, Controls and 
Parameters

Shows how to add end-user controls to your report, and how 
to create the parameters that apply the user’s choices to the 
report output.

Chapter 11, Using Report 
Links and Drilldowns

Shows how to link one report to another to give the end user 
additional information about a specific data value.

Chapter 12, Other Topics This section shows how to add headers and footers if you’ve 
deleted or omitted them. You’ll start with a table that has 
had the footer removed. After adding a footer, you’ll add 
summaries to it.

Table 1 Chapter Summary (cont’d)

Chapter Description
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This guide’s examples assume the default preferences. If you make any changes to the 
defaults, for example, by selecting a check box preventing a dialog from reappearing, these 
examples may not work exactly as stated.

The Select Audit Documentation Set

This manual refers to the following Select Audit documents. These documents are available 
on the Select Audit CD.

• HP Select Audit 1.02 Administration Guide, © Copyright 2006 - 2007 Hewlett-Packard 
Development Company, L.P. (administration_guide.pdf).

• HP Select Audit 1.02 Installation Guide, © Copyright 2006 - 2007 Hewlett-Packard 
Development Company, L.P. (installation_guide.pdf).

• HP Select Audit 1.02 User’s Guide, © Copyright 2006 - 2007 Hewlett-Packard 
Development Company, L.P. (user_guide.pdf).

• HP Select Audit 1.02 Sarbanes-Oxley Model Guide, © Copyright 2006 - 2007 
Hewlett-Packard Development Company, L.P. (sb_model_guide.pdf)

• HP Select Audit 1.02 Concepts Guide, © Copyright 2006 - 2007 Hewlett-Packard 
Development Company, L.P. (concepts_guide.pdf)

• HP Select Audit 1.02 Report Center User’s Guide, © Copyright 2006 - 2007 
Hewlett-Packard Development Company, L.P. (rpt_center_guide.pdf)

• HP Select Audit 1.02 Report Designer’s Guide, © Copyright 2006 - 2007 Hewlett-Packard 
Development Company, L.P. (rpt_design_guide.pdf)

• HP Select Audit 1.02 Report Developer’s Guide, © Copyright 2006 - 2007 Hewlett-Packard 
Development Company, L.P. (rpt_devel_guide.pdf)

Online help is available with the Audit Portal.
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2 User Interface Overview
This chapter gives a very high-level description of the Report Designer user interface.

Opening the Report Designer

The Report Designer is only available to users with Select Audit Report Developers.

When you first install Select Audit, you must install the Report Designer in the Developers 
Center.

1 Open the Developers Center using the following URL:

http://<servername>/scopeserver/

where <servername> is the address of the Report server. The Developers Center opens.

Select Audit Report Developers must also be a member of another Select Audit group to 
access the Audit Portal.
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2 Click Install Report Designer. The Report Designer Installation screen opens.

3 Click Click here to install in step 3 to install the Report Designer. When the Report 
Designer finishes installing, an icon is placed on your desktop. Once it is installed, you 
start the Report Designer using this icon.

You must have JVM 1.5 or higher to install the Report Designer.
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User Interface

The Report Designer contains the following areas:

• Menu Bar

• Toolbar

• Tabs

• Tree View

• Properties Area

• Design Pane

• Status Bar

• Error Pane

Figure 1 User Interface

User Interface Sections

You’ll do most of your layout design in the Design Pane, which provides a graphical 
representation of how your report will display.
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When a table is in Edit mode in the Design Pane, a sidebar is on the left of the table. This 
sidebar indicates the headers, footers, and bands. By selecting the appropriate sidebar, you 
can style or resize the entire header, footer, or details section.

The Properties Area enables you to fine-tune the layout. Though you can usually create your 
report using only the Design Pane, for some advanced settings you must use the Properties 
Area. Every setting in the Design Pane except positioning is also available in the Properties 
Area.

The Tree View shows the report in a hierarchical fashion. It is based on RDL, Select Audit’s 
XML-based report definition language. The two most important high-level nodes are Data 
Sources and Layout. Each element of the report is represented by a node on the tree. When you 
select an item in the Tree View, the element is highlighted in the Design Pane and you can 
edit it in the Properties Area. You can also drag a data field from the Tree View into a text 
element in Edit mode in the Design Pane.

Tabs

The Report Designer has three tabs:

• Design

• Preview

• RDL

Design

Most of the time, you’ll use the Design tab to develop your reports. In the Design tab, the Tree 
View, Properties Area, and Design Pane are visible.

Preview

Use the Preview tab to see how your report looks using real data. If you aren’t currently 
connected to a data source, you will be prompted to do so.

In the Preview tab, you can choose whether to display a PDF or HTML view. If you choose 
HTML, the data is displayed roughly as in a browser, although some elements (for example, 
certain controls) don’t appear exactly as they would in a browser.

You can also choose how many rows of returned data to use to generate the report. Use the 
number-of-rows button to control the time it takes for the report preview to display.

Typically, you will alternate between the Design tab and the Preview tab. After making some 
changes, check the Preview tab for a better idea of how the report actually looks.

The number of returned rows is meaningful only for simple tables. If your returned data set is 
large and you set the number of rows to “all”, you may get an out-of-memory error. As a 
general rule, set this control to “all” only for crosstabs, and even then, only when necessary to 
view your output correctly.
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RDL

The RDL tab displays the RDL code that defines the report. RDL is Select Audit’s XML-based 
report definition language. This tab is for fine-tuning by advanced report developers.

Tree View

The Tree View shows a hierarchical view of your report. Its top-level nodes include Parameters, 
Data and Layout. The Data node shows the data available to populate the report.

If you have created a spot for it in the layout, you can drag a data field into the spot in the 
Design Pane.

The highest-level subnodes of the Layout mode are components. In Select Audit, a component 
is a table (called Banded Table in the Tree View), crosstab, or chart. You can create 
combinations of these components to create a complete report. The subnodes of each 
component are different for each component type.

Properties Area

The Properties Area allows you to view and edit details of each item that you have selected in 
the Design Pane or in the Tree View. The Properties Area contains Folder buttons, which 
expand to reveal editable properties. The number of Folder buttons and properties depends on 
the element selected.

Design Pane

The Design Pane graphically shows the report in its current state. It’s not a WYSIWYG view 
(that is available in the Preview tab) but it does show the layout in an abstract form.

Design Pane Objects

The Design Pane can contain the following objects:

• Components (tables, crosstabs, and charts)

• Text elements

• Image elements

• Controls (see Chapter 10, Controls and Parameters)

• Layout

This document does not discuss RDL or the RDL tab.
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Selecting an Object

Click an object in the Design Pane to select it. To select the layout, click anywhere in the 
Design Pane outside all other objects.

When an object is selected, you can do the following:

• Edit it by right-clicking or by using the menus.

• Style it from the toolbar.

• Move it.

• Resize it.

Opening an Object

Double-click an object to open it.

The objects below can be opened so that you can edit them directly within the Design Pane, 
without using the menus, toolbar or dialog:

• tables

• crosstabs

• text elements and crosstab labels

When you open a table, the sidebar is shown, which enables you to resize the headers, footers 
and details section. You can also directly select elements in the table by clicking them.

When you open a crosstab, you can directly select elements in the crosstab by clicking them.

When you open a text element, you can modify the text directly without using a dialog, and 
you can drag a data element from the Tree View into the text element.

Other Elements of the Design Pane

Surrounding the Design Pane, are girders, rulers and the sidebar.

Girders

Immediately surrounding the Design Pane is a narrow horizontal area containing vertical 
lines, and a narrow vertical area containing horizontal lines. These lines are called girders. 
They represent the edges of all the elements in the layout. (When a table is in Edit mode, they 
represent the edges of elements within the table.) You can drag these girders to change the 
size of elements inside the layout.

Rulers

Surrounding the girders are rulers. By default, they measure pixels but by clicking the 
L-shaped area surrounding connecting the rulers, you can change the measurement to inches 
or centimeters.
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Sidebar

If a table is in Edit mode, a sidebar is shown to the left of it. The sidebar delineates areas that 
represent the headers, footers and bands of the table. By dragging the lines within the 
sidebar, you can resize the table’s bands, headers and footers.

Toolbar Icons

The Report Designer toolbar icons are described in Table 2 on page 19.

Status Bar

The Status bar optionally appears on the bottom of the Report Designer. The status bar 
indicates whether you are connected to a server and, if so, to which server. It also indicates 
whether there are errors.

Table 2 Toolbar Icons

Icon Description

Text alignment

Insert Text Element

Bold

Select Background Color

Insert Table

Insert Chart

Insert Crosstab

Insert Image
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Error Pane

The Error pane shows errors found in the report. If there are error messages, they may contain 
hyperlinks to the part of the report that caused the error.

To show or hide the Error pane, use the up and down arrows underneath the Properties Area. 
You can also open the Error pane by double-clicking the arrow icon in the Status bar.
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3 Creating a Query
This chapter shows how to create a query and save it to the Catalog for reuse. The query that 
you create in this chapter will be used to create a simple table, a crosstab and a banded table.

To create a query from scratch, use the Query Wizard. To edit an existing query, use the Query 
Editor. (See Modifying the Query on page 26.)

The Query Wizard helps you write SQL queries. Once you have created a query, you can use it 
to provide data to a table, crosstab, or chart or query-driven parameter.

Launching the Query Wizard

1 Select Data → Query Wizard to launch the Query Wizard. The Query Wizard opens.

2 Select a data source from the Choose the data source field.

3 Type a name for the query the Enter a name for the query field.

4 Click Next. The Select Tables screen opens.
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5 Select the tables you want to use in the query and click Add.

6 Click Next. The Link Columns screen opens.

You need to link tables. Links correspond to joins in the database.

7 Select the tables you want to link from the drop-down lists.

8 Select the fields on each side and then click Link. The linked fields are shown in the box at 
the bottom of the screen.

9 Click Next. The Select the Columns screen opens.

Use the CTRL key to select multiple tables. Click Add All to select all tables in the 
database.
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10 Select the columns that you will use to build your report and click Add.

11 Click Next. The Group and Summarize Data screen opens.

This screen allows you to group and aggregate your data when creating queries for charts 
or generating summarized data. Click Next to skip this screen and proceed to the next 
step.

12 Optionally, select a column name and click Group to use that column to group data.

13 Click the Summary Function column for each of the remaining fields and select a function 
from the drop-down list.

Use the CTRL key to select multiple columns. Click Add All to select all the columns 
in the database.
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14 Click Next. The Column Details screen opens.

15 Optionally, change the column labels by double-clicking the label in the Label column and 
typing a new name.

16 Click Next. The Filtering Results screen opens.

17 Optionally, filter the results using a subset of data by clicking Add. A new row is displayed 
in the text box.

18 Click the Column Name, Logic and Value columns and select a value from the drop-down 
lists.

19 Click Add Parameters to add or edit parameters.

20 Click Next. The Choose Sorting screen opens.
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21 Optionally, sort the column data by clicking Add. A new row is shown in the text box.

22 Click the Name column and select a database column from the drop-down list.

23 Click the Order column and select Ascending or Descending from the drop-down list.

24 Click Finish. If you are prompted to start the Layout Wizard, click No.

The Query Wizard closes and the query is listed under Data Sources in the Report 
Designer Tree View.

Saving the Query to the Catalog

As well as saving the query to the file system, you can also easily upload the query to the 
Report server to reuse later. Once on the server, you can either copy the query into a report or 
reference it without copying it.

1 Expand Data Source in the Tree View.

2 Right-click the query and click Upload Datasource. The Upload Query to Catalog dialog box 
opens.
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3 Select a location in the Queries folder.

4 Click OK.

The query is now saved in the Catalog on the server. You can see the contents of the Catalog 
using the Report Center. See the HP Select Audit 1.02 Report Center User’s Guide for details.

In later chapters, you will fetch the query that you have just saved to the Catalog.

Modifying the Query

You can invoke an SQL editor to modify the query.

1 Expand Data Sources in the Tree View.

2 Right-click the query and click Edit SQL Query. The SQL Editor opens.

Click New Folder to save the query in a different folder.
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For now, do not modify the query. In Chapter 10, Controls and Parameters you will use this 
dialog to add parameters to the query.
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4 Creating a Simple Table
This chapter describes how to create a simple table that consists only of headers, footers and 
data rows. It also describes how to use the Layout Wizard to make common adjustments to 
your table.

Creating the Table

1 Open the Layout Wizard by doing one of the following:

• Click Insert → Table.

• Open the RDL file that you created in Chapter 3, Creating a Query. The Layout Wizard 
prompt opens. Click OK to launch the Layout Wizard.

2 Select the required query from the Select query drop-down list.

3 Select the Tabular radio button in the Choose Layout type section.

4 Select the check boxes beside the fields you want to display the Fields to Display section.

5 Reorganize the fields using the up and down arrow.

6 Click Next. The Select Table Options screen opens.

When saving tables, do not include a combination of blank spaces and the “+” character in the 
report name. The Report server will not recognize this combination.
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7 Select Simple Table in the Select Type of Tabular Layout section.

8 Select the Table Header and Table Footer check boxes in the Include area.

9 Click Next. The Set Label Options screen opens.

10 Double-click the column name in the Column Labels column and type a new label.

11 Click the Sorting Link column and select Ascending or Descending from the drop-down list.

Sorting links allow the end user to change the sorting in the table by clicking on a column 
header.

12 Click Next. The Select Theme screen opens.
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13 Click a theme name.

14 Click Finish. The Layout Wizard closes.

15 Click the Preview tab in the Report Designer to preview the report.

16 Select a file type in the Preview as field.

17 Select a value from the Number of Data Rows drop-down list.

18 Click Refresh.

19 Save the table.

Modifying the Table Content

You can modify the table content after you create it using the Layout Wizard.

Changing the Table Text

1 Double-click the table in the Design Pane to open it and then double-click a table element 
to make it editable.

2 Type the new text.

3 Preview and save the report.

Changing the Date Mask

Use the Text Properties Format tab to change the date the format.

1 Double-click the table in the Design Pane to open it.

Report names cannot include a combination of blank spaces and the “+” character. 
The Report server will not recognize this combination.
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2 Right-click the text element containing the date and click Edit Text Element. The Text 
Properties dialog opens.

3 Click the Format tab and select a date format.

4 Click OK.

Changing the Money Mask

Use the Text Properties Format tab to change the money format to standard money formatting.

1 Double-click the table in the Design Pane to open it, right-click the text element 
containing monetary data and click Edit Text Element. The Text Properties dialog opens.

2 Click the Format tab and select the $#,##0.00;(#,##0.00) number format.

3 Click OK.
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4 Preview and save the report.

Deleting Table Elements

You can delete table elements as required.

1 Double-click the table in the Design Pane to open it.

2 Right-click the element and click Delete.

3 Preview and save the report.

Improving the Layout

This section describes how to make a additional improvements to the layout.

Alternate Row Styling

The table may be hard to read because the detail rows all have the same styling. Style odd- 
and even-numbered rows differently.

1 Click outside the table to exit Edit mode.

2 Right-click the table and click Edit Table. The Tabular Editor opens showing the General tab.

3 Select the Use separate styles for odd and even records check box in the Alternate Data Row 
Styling section.

4 Click OK.

5 Re-apply the theme to the table by selecting the table and clicking Format → Apply Theme.

6 Preview the report.

Changing Alignments

1 Double-click the table in the Design Pane to open it.

2 Select an element and click one of the alignment icons on the toolbar.

3 Preview the report.

Resizing Columns

Column data may wrapping because the column is too narrow. To fix this, move the girders 
just beneath the horizontal ruler.

1 Double-click the table the Design Pane to put it in Edit mode.

2 To narrow or expand a column, move your mouse over the first line until the cursor 
changes to a double-headed arrow. Click and drag the girder until it is the required width.

3 Preview the report.
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Increase the Height of the Title

You can change the height of a row of text elements using the girders in the same way that 
you changed the width of a column.

1 Double-click the table in the Design Pane to put it in Edit mode. To the right of the 
vertical ruler, immediately to the left of the table, there is a gray bar containing horizontal 
lines or girders.

2 Click the first line and drag it down to change the height of the element.

3 Preview and save the report.

Optional Next Steps

Adding a Column Selector Control

You can add a Column Selector control to the table. This control allows the report viewer to 
remove or reorder columns in the table while viewing the report in HTML.

1 Select the entire table. If you are in Edit mode, first click outside the table to close the edit 
and then click the table to select it.

2 Click Insert → Column Selector. The control is shown in the Table Header.

3 Select the title element and mouse over the small white box in the center of the top edge.

4 Click and drag the white box down.

5 Move the column selector into the empty space above the title.

6 Preview the report.

Using the Column Selector Control

When viewing the report in HTML, you will see now a small icon button in the table header.

1 Click the button. The Column Selector dialog opens, showing the column names as they 
appear in the table.

2 Clear some check boxes and click Apply. The table will redraw without the unchecked 
columns.

3 Click the Column Selector dialog and drag it to one side to clear your view of the table.

4 Select one or more column names and use the arrow keys to re-order them.

5 Click OK. The Column Selector dialog closes and the table is redrawn in the new order.

6 Click Refresh on the Preview Pane to restore the table to its original view.

Tables created by hand or with an earlier version of Scope Designer must be 
modified before they will work with the Column Selector. For each column you want 
to include in the Selector, click the Header text element and locate the 
columnSelectorLabel property in the General folder of the Property Pane. The 
value of this property should be the name of the column as it appears in the table 
header. This is the text that will be shown in the Column Selector dialog.
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Uploading the Report to the Library

You can upload the report to the Library on the Report server. This makes the report 
accessible to anyone with the appropriate permissions. It also allows you to schedule report 
output.

1 Click File → Publish. The Publish Report dialog box opens.

2 Expand the User folder and click New Folder. The Input dialog box opens.

3 Type a folder name in the field.

4 Click OK. The new folder is shown in the tree under the User folder.

5 Select the new folder.

6 Type a name in the Upload With Name field.

7 Click OK. The report is now stored in the Library.

For more information on managing reports in the Library, see the HP Select Audit 1.02 Report 
Center User’s Guide.

Adding a Group to a Table

You can convert a simple table to a group table or add a group to an existing group table.

1 If the table is still open, click outside the table in the Design Pane to close it.

2 Right-click the table and click Edit Table. The Tabular Editor opens.

A Column Selector cannot be inserted into a table that has no header.
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3 Click the Data tab.

4 Select a field from the Available Fields drop-down list and click Add. The field is shown in 
the Row Groupings (nesting) box.

5 Click OK.

6 Preview the report. The table is now grouped by the field.

7 Save the report.

For more information about Group Tables, see Chapter 5, Creating a Group Table.
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5 Creating a Group Table
This chapter describes how to create a basic group table. After you have created the table, you 
will make some adjustments to it and explore some options that are specific to group tables.

Inserting a Group Table

1 Click Insert → Table. The Layout Wizard opens.

2 Select the required query from the Select query drop-down list.

3 Select the Tabular radio button in the Choose Layout type section.

4 Select the check boxes beside the fields you want to display the Fields to Display section.

5 Reorganize the fields using the up and down arrow.

6 Click Next. The Select Table Options screen opens.

When saving tables, do not include a combination of blank spaces and the “+” character in the 
report name. The Report server will not recognize this combination.
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7 Select Table with Row Grouping in the Tabular Layout pane.

8 Select a column name from the Row Grouping 1 drop-down list. (This should be 
pre-selected.)

9 If required, select column names from the Row Grouping 2 and Row Grouping 3 drop-down 
lists.

10 Select the check boxes you want to include in the Include section.

11 Click Next. The Set Label Options screen opens.

12 Double-click the column name in the Column Labels column and type a new label.

13 Click the Sorting Link column and select Ascending or Descending from the drop-down list.

Sorting links allow the end user to change the sorting in the table by clicking on a column 
header.

14 Click Next. The Select Theme screen opens.
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15 Click a theme name.

16 Click Finish. The Layout Wizard closes.

17 Preview and save the report.

Modifying Table Content

Changing Footer Summaries

1 In the Tree View, click Layout → Banded Table.

2 Right-click the summary and click Edit Summary. The Edit Summary Function dialog box 
opens.

3 Select a function from the Summary function drop-down list.

4 Click OK.

5 Preview the report. The summary values have changed.

6 Save the report.
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Adding Text to Footers

1 Double-click the table to open it and then select the Table Footer area.

2 Click the Insert Text Element icon in the toolbar. The Text Properties dialog opens.

3 Type the text in the box on the General tab.

4 Click OK. The text field is shown at the left side of the bottom footer.

5 Preview and save the report.

Improving the Layout

Resizing Columns

Column data may wrapping because the column is too narrow. To fix this, move the girders 
just beneath the horizontal ruler.

1 Double-click the table the Design Pane to put it in Edit mode.

2 To narrow or expand a column, move your mouse over the first line until the cursor 
changes to a double-headed arrow. Click and drag the girder until it is the required width.

3 Preview the report.

A Note About Columns

There are not necessarily any real “columns” in a table created in the Report Designer, since 
you can move header, footer and details elements around at will. However, in a newly-created 
simple or group table, the columns still exist, and you can resize them with the girders.

For information about resizing elements when they are not arranged in proper columns, see 
Chapter 6, Creating a Free-form Group Table.

Widening the Table

You can add a margin by widening the table.

1 Click the small white box at the center of the right edge of the table in the Design Pane. 
Drag it to the right about three ticks.

2 Preview the report. The margin is visible, but now the title doesn’t span the whole width 
of the table.

3 Return to the Design Pane and click the table title. Click the right edge and drag it to the 
right until it reaches the edge of the table.

4 Preview the report.
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Custom Alternate Row Styling

You can change that by setting a custom alternate row style.

1 Click outside the table to exit Edit mode.

2 Right-click in the table and click Edit Table. The Tabular Editor opens.

3 Select the Use separate styles for odd and even records check box in the Alternate Data Row 
Styling section.

4 Click the Style tab.

5 Select Repeating Details – even from the Styles for: drop-down list.

6 Select a color from the Background drop-down list.

7 Click OK.

8 Preview and save the report.

Optional Next Steps

Changing the Grouping

After creating a group table, you may decide to group the data in a different way. If you 
haven’t made many adjustments to the table, the simplest solution is to delete it and start 
over with the Layout Wizard. However, if you have made substantial changes, you can use the 
Tabular Editor to change your grouping.

1 Right-click in the table and click Edit Table. The Tabular Editor opens.

2 Click the Data tab.

3 Select a grouping and click Delete.

4 Select an new field from the Available Fields drop-down list and click Add.
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5 Click OK. The Group 2 Hdr and Group 2 Ftr sections are deleted and then added back again. 
As a result, they are empty and unstyled.

6 Double-click the table to open it.

7 Select Group 2 Hdr in the sidebar.

8 Click Format → Apply Theme and select the theme. The header style is restored.

9 Add the grouping field to the header. With Group 2 Hdr still selected, click the Insert Text 
Element icon. The Text Properties dialog opens.

10 Click Data. The Edit Data Field dialog box opens.

11 Select Group Name and click OK.

12 Click OK to close the Text Properties dialog. The new text element is shown in the text box.

13 Preview the report.
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Making a Group Collapsible

Making a group collapsible gives the end user a control that will allow her to see only the 
country data if she wants.

1 Click outside the table to exit Edit mode.

2 Right-click the table and click Edit Table. The Tabular Editor opens.

3 Click the Data tab.

4 Select a group in the Row Groupings (nested) section.

5 Select the Group can be collapsed by viewer check box. Leave the Header radio button 
selected.

6 Click OK.

7 Preview the report. An icon is shown at the left edge of each of the headers. Click the icon 
to see that group collapse and expand.

8 Position the icon closer to the group name by clicking the plus sign and dragging it closer 
to the group name text element.

9 Preview and save the report.

Adding a Sorting Link

1 Double-click the table in the Design Pane.

2 Right-click the element in the table header and click Edit Text Element. The Text Properties 
dialog opens.

Pressing Ctrl on the keyboard while clicking and dragging allows you to override the grid and 
move smoothly in the Design Pane. You can also use your keyboard’s arrow keys.
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3 Select the Sorting Link radio button.

4 Select a field from the Data Field drop-down list.

5 Select Ascending or Descending from the Initial Direction drop-down list.

6 Click OK.

7 Preview the report. You’ll see the column header is now a hyperlink, which the end user 
can use to reorder the table data.

Changing the Theme

If you change your mind about your report’s theme, you can always change it.

1 Click outside the table to select the layout.

2 Click Format → Apply Theme → Select. The Select Theme dialog box opens.

3 Click different theme names to view the thumbnail preview at the right.

In general, themes override most custom styling, with the exception of styles applied to 
individual elements in a table. The title element is the only element directly styled by a 
theme.
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4 Double-click a theme and click OK. The table and the empty space around it change to 
reflect the new theme.

5 Preview and save the report.

By applying a theme, you override any existing styles on that object and its children. In this 
case, the custom alternate row styling you did earlier is replaced by the fall theme’s alternate 
row style.
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6 Creating a Free-form Group Table
In this chapter, you will create a free-form group table. Some data will be in the outermost 
group header, not the details, so you will add these data fields after you have done the initial 
layout. Also, because this table is free-form, themes are not useful for styling. Instead, you 
will learn some custom styling techniques.

Getting Started

Downloading a Query from the Catalog

For this report, you’ll reference the query in the Catalog rather than opening it from the file 
system.

1 Click Data → Get Datasource. The Get Query from Catalog dialog box opens.

2 Select a query and click OK.

When saving tables, do not include a combination of blank spaces and the “+” character in the 
report name. The Report server will not recognize this combination.
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Inserting a Table

The dialog to launch the Layout Wizard opens automatically if you open a report that contains 
a query but no layout. You can also launch the Layout Wizard at any time by clicking Insert → 
Table, Insert → Chart or Insert → Crosstab.

1 Click Insert → Table. The Layout Wizard opens.

2 Select the required query from the Select query drop-down list.

3 Select the Tabular radio button in the Choose Layout type section.

4 Select the check boxes beside the fields you want to display the Fields to Display section.

5 Reorganize the fields using the up and down arrow.

6 Click Next. The Select Table Options screen opens.

7 Select Table with Row Grouping in the Tabular Layout pane.
48 Chapter 6



8 Select a column name from the Row Grouping 1 drop-down list. (This should be 
pre-selected.)

9 If required, select column names from the Row Grouping 2 and Row Grouping 3 drop-down 
lists.

10 Select the check boxes you want to include in the Include section.

11 Click Finish. A preliminary view of the layout is shown in the Design Pane.

12 Preview and save the report.

Improving the Content and Layout

Editing and Styling the Title

1 Double-click the table to open it.

2 Right-click the title text element and click Edit Text Element. The Text Properties dialog 
opens.

3 Edit the title text.

4 Click the Style tab and change the values as required.

5 Click OK.

Deleting Text Elements

1 To delete text elements, right-click a text element and click Delete.
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Adding Text to a Data Field

1 Double-click a text element. A gray oval opens with the text inside it. Your cursor is 
positioned to the left of the oval.

2 Type the text and then click the Group 1 Hdr sidebar to end the edit.

3 Preview the report.

Adding Data to the Group Header

1 Select the Group 1 Hdr section in the table or the sidebar.

2 Click the Insert Text Element icon on the toolbar. The Text Properties dialog opens.

3 Click Data. The Edit Data Field dialog box opens.

4 Select a data field and then click OK. The Text Properties dialog now contains an oval 
representing the field.
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5 Click to the left of the oval in the Text field and type the new data field name.

6 Click OK to close the Text Properties dialog.

7 Without changing the selected element, click the Text Element icon on the toolbar.

8 Type the new text element name in the General tab.

9 Click OK.

10 Click the Text Element icon on the toolbar. The Text Properties dialog opens.

11 Click Data. The Edit Data Field dialog opens.

12 Select the data field and then click OK.

13 If required, select a format in the Format tab.

14 Click OK to close the Text Properties dialog.

15 Preview and save the report.
Creating a Free-form Group Table 51



Resizing and Positioning Elements

Some of the new elements may be too narrow, so the data wraps. You will need to move and 
resize these elements.

1 Select the edge of the text element and drag it to resize it.

2 Preview the report. Continue to move and resize the elements in the header until they are 
to your liking.

Adding Space Between Groups

1 Click the bottom boundary of Group 1 Hdr in the sidebar of the Design Pane and drag it 
down a few grid points.

2 Move each text element in the Group 1 Hdr section down to the bottom of the section.

3 Preview the report. You will now see empty space above the top-level headers.

Adding “Column” Headers at the Group Level

1 Click the bottom boundary of the Group 2 Hdr section in the sidebar in the Design Pane 
and drag it down several ticks.

2 Click the Text Element icon on the toolbar. The Text Properties dialog opens.

3 Type the new header name in the box in the General tab.

4 Click the Style tab and modify the settings as you wish.

5 Click OK.

6 Preview and save the report.

Applying Custom Styling to a Table

You have already styled individual text elements in the table. Now add styling to some table 
sections and to the table itself.

Styling Table Sections with the Toolbar

Using the toolbar to style your table allows you to see your changes as you make them. It also 
lets you style the table without opening a dialog or leaving Edit mode.

1 Select the Group 1 Hdr section in the sidebar of the Design Pane.

2 Click the Bold icon on the toolbar. The text in the header will turn bold.

3 Click the Select Background Color icon in the toolbar.

4 Select lime from the drop-down list. The header background will turn bright green.

5 Select the Details section in the sidebar.

6 Select a font from the Font type drop-down list in the toolbar.

7 Select a size from the Font size drop-down list.
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8 Click an alignment icon.

9 Preview the report.

Adding Borders Around the Entire Table

1 Click outside the table in the Design Pane to exit Edit mode.

2 Right-click the table and select Style Component. The Tabular Editor opens showing the 
Style tab.

3 Select the values for the border using the following:

• The Borders drop-down list.

• The Thickness selection box.

• The Color drop-down list.

4 Click OK.

5 Preview and save the report.

Adding a Single Border to a Text Element

You can add a set of four identical borders around an element by using the Text Properties 
editor but to add a single border you must use the Properties Area.

1 Double-click the table in the Design Pane to open it.

2 Click the element.

3 Click Box Settings in the Properties Area in the Design Pane. The folder opens.

You can select the entire table without leaving Edit mode. To do this, click the plus 
button at the top left corner of the layout, where the two sets of girders meet. 
Right-click this button to access the Table menu.
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4 Select values for the Bottom Border Style, Bottom Border Width and Border Color fields.

5 Preview and save the report.
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7 Creating a Crosstab
This chapter shows how to create and modify a crosstab.

Launch the Layout Wizard

The Layout Wizard launches automatically if you open a report that contains a query but no 
layout. You can also launch the Layout Wizard at any time by clicking Insert → Table, Insert → 
Chart or Insert → Crosstab.

1 Click Insert → Crosstab. The Layout Wizard opens.

2 Select the required query from the Select query drop-down list.

3 Select the Crosstab radio button in the Choose Layout type section.

4 Select the check boxes beside the fields you want to display the Fields to Display section.

5 Reorganize the fields using the up and down arrow.

6 Click Next. The Select Crosstab Options screen opens.

When saving crosstabs, do not include a combination of blank spaces and the “+” character in 
the report name. The Report server will not recognize this combination.
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7 Select a column name from the Row Grouping 1 drop-down list. (This should be 
pre-selected.)

8 If required, select column names from the Row Grouping 2 and Row Grouping 3 drop-down 
lists.

9 Select a field from the Column Grouping drop-down list.

10 Select a field from the Group by drop-down list.

11 Select a field from the Summarized Fields drop-down list.

12 Select a function from the Function drop-down list.

13 Select the check boxes you want to include in the Include section.

14 Click Next. The Select Theme screen opens.

15 Click a theme name.
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16 Click Finish. The Layout Wizard closes.

17 Preview and save the report.

Adjusting the Layout

Changing the Title

1 Double-click the crosstab in the Design Pane to open it and then double-click the report 
title.

2 Replace the text as required.

Eliminating a Subtitle

1 Right-click anywhere in the crosstab and click Edit Crosstab. The Crosstab Editor opens.

2 Select Subtitle in the Optional Crosstab Sections box and click Delete.

3 Click OK.

In general, select All in the Number of Data Rows field only for crosstabs and only when 100 
returned rows does not provide enough data to get an idea how the crosstab will look. 
Returning all rows, especially for simple tables, may exceed the server’s memory limits.
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Setting Row Headers

1 Click Crosstab → Crosstab Row Group →Crosstab Header in the Tree View. The appropriate 
cell is automatically selected in the Design Pane.

2 Click General in the Properties Area in the Design Pane. The folder opens.

3 Click the Text field and type the new header.

4 Click Preview to see your changes.

Setting Column Headers

1 Click Crosstab → Crosstab Column Group →Crosstab Header in the Tree View. The 
appropriate cell is automatically selected in the Design Pane.

2 Click General in the Properties Area in the Design Pane. The folder opens.

3 Click the Text field and type the new header.

4 Click Preview to see your changes.
58 Chapter 7



Adding Another Summarized Data Field

1 Right-click the crosstab in the Design Pane and click Edit Crosstab. The Crosstab Editor 
opens.

2 Click the Data tab.

3 Select a field in the Available Fields box.
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4 Click Data. The field is added to the Summarized Data Fields box.

5 Click the Function field and select a function from the drop-down list.

6 Click OK.

7 Preview the report.

Changing the “Bucketing”

1 Right-click the crosstab in the Design Pane and click Edit Crosstab. The Crosstab Editor 
opens.

2 Click the Data tab.

3 Click the Group By field and select a value from the drop-down list.

4 Click the Labels tab.
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5 Double-click a field in the Text column and type a new label.

6 Click the cursor elsewhere in the table and click OK.

7 Save and preview the report.
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8 Creating a Chart
When creating a chart with the Report Designer, you’ll notice some differences from tables 
and crosstabs:

1 In the Design Pane, you’ll always see the same image for the chart. Use the Preview tab to 
see how your chart appears.

2 You handle grouping in the query instead of in the layout. You have to modify SQL code. 
This chapter assumes you are familiar with the SQL language.

In this chapter, you’ll create a query for the chart, create the chart and modify the chart type.

Creating the Query

1 Select Data → Query Wizard. The Query Wizard opens.

2 Create the query following the steps described in Chapter 3, Creating a Query.

3 Click Finish.

4 Save the file.

When saving charts, do not include a combination of blank spaces and the “+” character in the 
report name. The Report server will not recognize this combination.
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Editing the Query

Edit the query to handle grouping in the layout.

1 Expand Data Sources in the Tree View.

2 Right-click the query and click Edit SQL Query. The SQL Editor opens.

3 Edit the SELECT statement in the text area as required.

4 Click Fields tab.

5 Click the Type column and select a type from the drop-down list for each field.

6 Click OK to save the query.

Upload the Query to the Catalog

Save this query in the Catalog to reuse later.

1 Expand Data Source in the Tree View.

2 Right-click the query and click Upload Datasource. The Upload Query to Catalog dialog box 
opens.
64 Chapter 8



3 Select a location in the Queries folder.

4 Click OK.

Creating the Layout for a Pie Chart

Use the query to create a 3-D pie chart that displays percentage values.

1 Click the Insert Chart icon on the toolbar. The Layout Wizard opens.

2 Leave the Chart radio button selected in the Choose layout type section.

3 Click Next. The Choose Chart Options screen opens.

Click New Folder to save the query in a different folder.
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4 Click a type in the Select Type of Graphical Layout section.

5 Select a field from the Group By drop-down list.

6 Select a field from the Data 1, Data 2 and Data 3 drop-down lists.

7 Click Next. The Edit Chart Labels screen opens.

8 Select the Show Legend check box.

9 Select a position for the legend from the drop-down list in the Legend section.

10 Click Finish.

11 Preview the report.

12 Right-click the chart in the Design Pane and click Edit Chart. The Chart Editor opens 
showing the General tab.
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13 Select the Percentage Values and 3-Dimensional Display check boxes.

14 Click OK.

15 Click PieChart → ChartHeader in the Tree View.

16 Click General in the Properties Area.

17 Type a value in the Height field.

18 Preview and save the report.

Converting the Layout to Another Chart Type

Convert the pie chart you just created to a 2-D bar chart with inverted axes and two data 
fields.

1 Right-click the chart in the Design Pane and click Edit Chart. The Chart Editor opens.
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2 Select Bar in the Chart Type field on the General tab.

3 Select the Inverted Axes check box and clear the 3-Dimensional Display check box in Display 
Options.

4 Click the Data tab.

5 Select a field from the Available Fields list and click Data. The field is shown in the Data 
Fields box.

6 Select the Show Ticks and Show Grid check boxes below the Data Fields box.

7 Click the Labels tab.

8 Double-click a title in the Chart Labels box and type a new title.

9 Double-click a label in the Data Fields box and type a new label.

10 Click OK.

11 Preview the chart.

Turning Off Data Labels

You can turn off the data labels.

1 Click BarChart → ChartDataLabel in the Tree View.

2 Click General in the Properties Area.

3 Select false from the Visible drop-down list.

4 Preview the chart.
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9 Creating a Multi-component Report
In Select Audit report terms, a component is a single table, crosstab or chart. All the reports 
that you have created in previous chapters consisted of a single component. In fact, you can 
easily create a report containing multiple components as well as text elements or images that 
belong to none of the components.

This chapter shows how to create a report that contains two components: the simple table 
that you created in a previous chapter and a crosstab that presents the same data in a 
different format. You will also include text elements and images associated with neither 
component.

There is no limit to the number of components and fields that you can add to your report.

Adding a Simple Table

You will start by using the simple table that you created in Chapter 4, Creating a Simple 
Table and stored in the Library.

1 Click File → Open From Server. The Open a Report dialog box opens.

2 Select a report that you saved previously and click OK.

3 Save the report.

When saving reports, do not include a combination of blank spaces and the “+” character in 
the report name. The Report server will not recognize this combination.
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Creating a Crosstab

1 Click the simple table and drag it down.

2 Click the area above the simple table. Notice that the entire layout is selected.

3 Click the Insert Crosstab icon on the toolbar. (If the icon isn’t visible, either enlarge the 
Report Designer window or click Insert → Crosstab.) The Layout Wizard opens.

4 Leave default query in the Query field and Crosstab radio button selected.

5 Select the check boxes beside the fields you want to display the Fields to Display section.

6 Reorganize the fields using the up and down arrow.

7 Click Next. The Select Crosstab Options screen opens.
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8 Select a column name from the Row Grouping 1 drop-down list. (This should be 
pre-selected.)

9 If required, select column names from the Row Grouping 2 and Row Grouping 3 drop-down 
lists.

10 Select a field from the Column Grouping drop-down list.

11 Select a field from the Group by drop-down list.

12 Select a field from the Summarized Fields drop-down list.

13 Select a function from the Function drop-down list.

14 Select the check boxes you want to include in the Include section.

15 Click Finish. The crosstab is shown in the Design Pane.

Changing the Crosstab Labels

1 Right-click the crosstab and click Edit Crosstab. The Crosstab Editor opens.

2 Click the Labels tab.

3 Double-click a field in the Text column and type a new label.

4 Click the cursor elsewhere in the table and click OK.

5 Save and preview the report.
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Putting Borders Around the Crosstab

1 Click the Style tab.

2 Select Crosstab from the Styles for: drop-down list.

3 Select values for the border using the following:

• The Style drop-down list.

• The Thickness scroll box.

• The Color drop-down list.

4 Click OK to close the Crosstab Editor.
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Adding Fields to the Layout

Adding a Label to the Crosstab

1 Click the Insert Text icon. The Text Properties dialog opens.

2 Type a name in the Text field.

3 Click the Style tab.

4 Select values for the style using the following:

• The Font drop-down list.

• The Size drop-down list.

• The Effects check boxes.
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5 Click OK.

6 The new text element may be shown to the right of the crosstab. If so, drag it to the left 
and place it above and to the left of the crosstab so that the lower-right-hand corner of the 
text element is at the same height as the upper-left-hand corner of the crosstab.

Adding a Label to the Simple Table

Add a label to the left of the simple table. If you try to select and drag the table to the right, 
you may not be able to. This is because the table has taken up the whole allotted width of the 
layout.

1 Click somewhere in the layout other than on one of the tables.

2 Drag the right side of the layout to the right. You may have to scroll to the right to see the 
right side of the layout.

3 Now move the table by selecting it and dragging it to the right. Leave the same amount of 
room on the left side as you did for the crosstab.

4 Repeat the process in Adding a Label to the Crosstab on page 73 to create a new text 
element. Drag it to the left of the simple table and place it so the lower-right-hand corner 
of the text element is at the same height as the upper-left-hand corner of the simple table.

Adding a Report Title

So far, the only report titles used are headers inside a component. For this report, you’ll create 
a text header that is not part of any component.

1 Click outside the components to select the entire layout.

2 Click the Insert Text Element icon. The Text Properties dialog opens.

3 Type a title in the General tab.

4 Click the Style tab.

5 Select values for the style using the following:

• The Font drop-down list.

• The Size drop-down list.

• The Effects check boxes.

6 Click OK.

7 Drag the new text element to the top of the layout.

8 Drag the right side of the text element to increase its width.
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Adding an Image

Now you’ll add an image beneath the report title. The image must be on the server to appear 
in the report. Upload the image to the server before creating your report.

1 Click the Insert Image icon on the toolbar. The Image Editor dialog opens.

2 Type the image URL in the Image URL fields.

3 Type values in the Width and Height field.

4 Select the Set image size in report check box.

5 Click OK.

6 Drag the icon underneath the report title.

7 Preview the report.

8 If the image is too small, click the image in the Design Pane to select it and then drag the 
lower-right-hand corner of the image to make it slightly bigger.

9 Preview and save the report.

You cannot overlap the image with a text element or component. If you do, the image will 
spring back to its original location. To avoid this, either use the Image Editor to reduce the 
image’s size and width or move the other objects around to make more room for the image.

If Set image size in report is not selected, the image always maintains its original 
size even if the containing object is enlarged.
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10 Controls and Parameters
A control performs one of two functions in a report:

• It performs an action pre-defined by Select Audit, such as download, export, profile 
selection or creation. For an example of adding a pre-defined control, see Adding a 
Download Control on page 82.

• It allows the end user to restrict the values that appear in a component (table, crosstab, or 
chart). For example, the control can let the end user restrict the report to show only orders 
for a certain product or ship date. See Using Fixed-list and Free-text Controls on page 78 
for instructions on adding some of these controls.

Controls that restrict shown values are bound to parameters. You must create the parameter 
before you bind it to a control. You must also alter the query that provides data for the 
component whose value you want to restrict.

There are three kinds of parameter values:

In this chapter, you’ll create these three kinds of parameters as well as the controls to bind 
them to. You’ll also create a control that performs a pre-defined action (download).

It’s better to plan for the controls the report will contain before you create the query that 
provides data to the components. This allows you to design the original query to include the 
parameters that will be bound to the controls. It is possible to add a parameter to the query 
after you have already designed the component, but to do this you must alter the query that 
provides data for the component.

To create controls that restrict values, you should be familiar with the SQL language.

fixed-list You provide a pre-defined list of values for the end 
user to choose from. Fixed-list parameters are bound 
to check box, list menu, and radio button controls. (See 
Creating a Fixed-list Parameter on page 79.)

allow any value The end user can type any text into a box. These 
parameters are associated with text fields and 
calendar controls. (See Creating Free Text Parameters 
on page 80.)

query-based These parameters are based on queries defined in the 
report. They are typically associated with a list menu 
control. You must create a new query to use this kind 
of parameter. (See Creating Controls Bound to 
Query-based Parameters on page 85.)
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Using Controls

The Select Audit controls are listed below:

Using Fixed-list and Free-text Controls

In this example, you’ll begin with the query that you created in Chapter 3, Creating a Query, 
modify it to incorporate some parameters, create the parameters and bind them to controls. 
You can create the following controls:

• A check box control consisting of some of the products in the table. (See Creating a 
Fixed-list Parameter on page 79.)

Download Loads the report into a browser in any of several output formats, 
including HTML or PDF format.

Export Saves the report to the Report server in any of a variety of formats.

Push Button A button that is defined either to submit the report to the server or 
to reset the controls in the report. (Using JavaScript, you can also 
assign some other action to a push button.)

Radio Buttons A set of buttons allowing a single choice among a closed set of 
choices.

Check boxes A set of boxes allowing multiple choices among a closed set of 
choices.

List A drop-down list or fixed-size list containing single or multiple 
choices.

Image Button Like a submit push button, but displays an image of your choosing 
rather than a button.
If the image source that you specify is not a full URL, it may not 
display correctly in the Preview pane.

Print Button An icon that prints the report.

Profile Manager A drop-down list that lets you choose from a list of profiles, or create 
a new profile. (In Select Audit terms, a profile is a saved set of 
parameter values.)

Calendar A control that lets you choose the month, day and year.

Download Loads the report into a browser in any of several output formats, 
including HTML or PDF format.

You can fine-tune the action of a control by using the Actions tab in the Controls Editor. You 
can use JavaScript to define the action when end-user action triggers an event.

This chapter shows how to make a working report with various types of parameters. It does 
not show how to style the report. For examples of styling a report, see Chapter 4, Creating a 
Simple Table.
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• Two free-text controls, one for the minimum order number and one for the maximum. (See 
Creating Free Text Parameters on page 80.)

• A download control, which lets you view the report in a browser.

• A submit button, which sends the end user’s control values to the Report server.

Creating the Parameters

This section shows how to create the fixed-list and free-text parameters.

Creating a Fixed-list Parameter

Create a fixed-list parameter, that you will later bind to a check box control. (You could also 
bind it to a radio button or list control in much the same way.)

1 Click Data → Add Parameter. The Parameter Editor opens.

2 Type a name in the Parameter name field.

3 Select the Fixed List radio button.

4 Click Set Values. The Values and Labels dialog box opens.
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5 Click New. A new row is added to the Value box.

6 Double-click the Value field and type a value.

7 Select the Default check box next to the value.

8 Click OK to close the Values and Labels dialog box.

9 Click OK to close the Parameter Editor. The parameter is shown in the tree.

Creating Free Text Parameters

1 Click Data → Add Parameter. The Parameter Editor opens.

2 Type a name in the Parameter name field.

3 Select the Allow any value radio button.

4 Select and type a value in the Default field.

For information about the Mandatory tab, see Making Parameters Mandatory on 
page 84.
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5 Click OK. The parameter is shown in the Tree View.

Modifying the Query

Add the parameters to the query from which you’ll create the component.

Add the Parameter

1 Expand Data Sources in the Tree View.

2 Right-click the query and click Edit SQL Query. The SQL Editor opens.

3 Copy the parameter from the SELECT statement and paste it into the Column Name field 
below. (If you prefer, you can just type it directly into the field without copying and 
pasting.)

4 Leave the Type field as String and the Comparison field as “=”.

5 Select FixedListParameter from the Parameter drop-down list.

6 Place the cursor at the very end of the WHERE clause, hit the carriage return and then type 
the word And with a space after it.

7 Click Insert. The parameter should be in the SQL query.

8 Click OK.

This example uses a query that already contains a WHERE clause. If the query has 
no WHERE clause (this typically happens when the query was built on a single 
database table and you have not yet added any other parameters), instead of 
typing And or Or in the SQL editor, type the word WHERE instead.
Controls and Parameters 81



Creating the Component

Create a component based on the query that you’ve just added parameters to. In this example, 
the component is an extremely simple table.

1 Click the Insert Table icon in the toolbar. The Layout Wizard opens.

2 Leave the query as the default name.

3 Select the Tabular radio button in the Choose Layout type section.

4 Select the check boxes beside the fields you want to display the Fields to Display section.

5 Click Next. The Select Table Options screen opens.

6 Select Simple Table in the Select Type of Tabular Layout section.

7 Clear the Table Footer check box in the Include section.

8 Click Finish. The table is shown in the Design Pane.

Adding Controls

Add the controls to the layout.

Adding a Download Control

A download control enables the end user to view her report in a browser. Adding a download 
control is very straightforward. (Export and profile controls are equally simple.)

1 Click the table in the Design Pane to select it.

2 Click somewhere outside the component in the Design Pane to select the entire layout and 
then click Insert → User Control → Download.

Adding a Check Box Control

1 Click somewhere outside the component and download control in the Design Pane and 
then click Insert → User Control → Checkboxes. The Controls Editor opens.

In Preview mode, some controls are disabled.
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2 Leave the Control Type drop-down list as Checkboxes.

3 Select FixedListParameter from the Associated Parameter drop-down list.

4 Select the Horizontal radio button in the Orientation section.

5 Select the Right radio button in the Label Position section.

6 Select OK.

7 Preview the report. You should see the download control and the check boxes.

8 Save the report.

Adding the Free-text Controls

1 Click somewhere outside the component and download control in the Design Pane and 
then click Insert → User Control → Text Field. The Controls Editor opens.

2 Select a value from the Associated Parameter drop-down list.

3 Type a value in the Width field.

4 Click OK.
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Adding the Submit Control

The report needs a Submit button so that the end user can send her choices, made through 
controls, to the server:

1 Right-click the layout outside the component and controls and click Insert → User Control 
→ Button. The Controls Editor opens.

2 Leave the default function drop-down list and label as Submit.

3 Click OK.

4 Preview and save the report.

Making Parameters Mandatory

You can define a parameter to be mandatory, that is, required within a particular query. If a 
parameter is mandatory, the report viewer must specify a value for it. For instance, if the 
parameter is mapped to a set of check boxes, at least one check box must be selected. If the 
report viewer tries to submit the report with no check boxes selected, a warning message will 
be shown.

1 Expand Parameters in the Tree View.

2 Right-click a parameter and click Edit Parameter. The Parameter Editor opens.
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3 Click the Mandatory tab. A list of available queries is shown.

4 Select the checkbox next to the query and click OK.

Creating Controls Bound to Query-based Parameters

The values in a list control can be populated in one of two ways:

• By pre-defining the values in the list. See Using Fixed-list and Free-text Controls on 
page 78 for instructions on how to define a fixed-value parameter.

• By defining a query to populate the control.

In this section, you’ll create a drop-down list control that enables the end user to restrict the 
report results to certain countries. A database query populates the list.

Creating a Query for the Parameter

1 Right-click Data Sources in the Tree View and click Query Wizard. The Query Wizard opens.

2 Create a query using the steps described in Launching the Query Wizard on page 19.

3 Right-click the query in the Tree View and click Edit SQL Query. The SQL Editor opens.

4 Type the word DISTINCT in the query after SELECT.

5 Click OK to close the SQL Editor.

If you run the report and clear out the default values from the text fields, a red 
asterisk is shown next to each text field along with the following message:

Please specify the missing parameters.
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Creating the Parameter

1 Right-click the query in the Tree View and click Edit SQL Query. The SQL Editor opens.

2 Click Add Parameter. The Parameter Editor opens.

3 Type a name in the Parameter Name field.

4 Click From query and select the query from the drop-down list.

5 Click OK to close the Parameter Editor.

6 Click OK to close the SQL Editor.

Adding the Parameter to the Query

1 Right-click the query in the Tree View and click Edit SQL Query.

2 Place the cursor at the very end of the SQL query, press Enter and then type the word And 
with a space after it.

3 Copy the parameter from the query and paste it into the Column Name field.

4 Leave the Type field as string and the Comparison field as “=” (equals).

5 Select the parameter name from the Parameter drop-down list.

6 Click at the end of the query.

7 Click Insert.

8 Click OK to close the SQL editor.

Adding the Control

Create a list control populated by the results of the query.

1 Right-click outside the controls in the Design Pane and click Insert → User Control → List. 
The Controls Editor opens.

2 Select the parameter in the Associated Parameter field.
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3 Type a value in the Size in lines field.

4 Do not select the Allow multiple selection check box.

5 Do not select the Allow no selection, labeled as check box.

6 Click OK to close the Controls Editor.

Rearranging the Controls

1 Drag the download control to the right of the list control in the Design Pane.

2 Drag the list control to underneath the check boxes control.

3 Drag the text fields under the download control, the one associated with the control 
associated with the minimum parameter on top.

Add Labels to the Controls

1 Right-click to the left of the check boxes control in the Design Pane and click Insert Text 
Element.

2 Type a name in the Text Properties dialog box.

3 Drag the new element to left of the check boxes control.

4 Add a text elements next to the list control and add the free-text controls.

Add the Selected Text Element to the Header

1 Click the table to select it and then double-click it to make it editable.

2 Right-click the top row of the table header and click Edit Text Element.

3 Delete the text from the field.

4 Click Data. The Edit Data Field dialog opens.

5 Select the parameter in the Select Data Field box.

6 Click OK to close the Edit Data Field dialog. An oval representing the parameter value is 
shown.

7 Click the cursor to the left of the symbol for the parameter in the Text Properties dialog.

8 Type a new name.

9 Click OK to close the Text Properties dialog.

10 Save and preview the report.

If you select the Allow multiple selection check box, all items in the list can be deselected at 
once. Therefore, if you allow multiple selection, you do not need to (and cannot) enter a 
default label for Allow no selection.

Selecting the Allow no selection, labeled as check box would give the end user the option to 
bypass all items in the list.
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11 Using Report Links and Drilldowns
You can link one report to another to give the end user additional information about a specific 
data value. This type of special hyperlink is called a report link.

The report that contains the link is the source report. Clicking the link brings you to the 
target report. The target report typically includes one or more parameters. The relevant 
values for these parameters are passed from the source report through the report link to the 
target report.

This chapter describes how to create a parameterized target report with a pie chart and a 
label.

Creating a Parameterized Target Report

The target report uses a query-driven parameter (see Chapter 10, Controls and Parameters). 
You will define the query, add the parameter and modify the chart query. Finally, you will 
create a new pie chart and add a parameterized title.

Creating a Query for the Parameter

1 Click the New toolbar icon to start a new report.

2 Right-click Data Sources in the Tree View and click Query Wizard. The Query Wizard opens.

When saving reports, do not include a combination of blank spaces and the “+” character in 
the report name. The Report server will not recognize this combination.
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3 Create the query using the steps described in Launching the Query Wizard on page 21.

4 Click Finish. Cancel the prompt for the Layout Wizard if it opens.

5 Save the file.

Creating the Parameter

1 Right-click Parameters in the Tree View and click Add Parameter. The Parameter Editor 
opens.

2 Type a name in the Parameter name field.

3 Select the From query check box.

4 Select the query name from the drop-down list.
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5 Click OK.

Modifying the Chart Query

1 Right-click Data Sources in the Tree View and click Get Datasource. The Get Query from 
Catalog dialog box opens.

2 Select the query and select the Copy from catalog check box.

3 Click OK. The query is shown in the Tree View.

4 Right-click the query in the Tree View and click Edit SQL Query. The SQL Editor opens.
Using Report Links and Drilldowns 91



5 Type the query name in the Query name field.

6 Copy the parameter from the SELECT statement and paste it into the Column Name field 
below. (If you prefer, you can just type it directly into the field without copying and 
pasting.)

7 Leave the Type field as String and the Comparison field as “=”.

8 Select FixedListParameter from the Parameter drop-down list.

9 Place the cursor at the very end of the WHERE clause, press Enter and then type the word 
And with a space after it.

10 Click Insert. The parameter should be in the SQL query.

11 Click OK.

12 Save the file.
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Creating the Pie Chart

1 Click the Insert Chart icon on the toolbar. The Layout Wizard opens.

2 Select TargetQuery from the Select query drop-down list.

3 Click Next.

4 Create the pie chart using the steps described in Creating the Layout for a Pie Chart on 
page 65.

5 Click Finish.

6 Preview the report and save the file.

Adding a Parameterized Title

Add a chart title that changes with the value of the parameter.

1 Click in the center of the chart image and drag it down so that the top lines up with the 
number 1 on the vertical ruler.

2 Click outside the chart to select the layout.

3 Click the Insert Text Element icon on the toolbar. The Text Properties dialog opens.
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4 Type the title in the Text Properties field.

5 Click Data. The Edit Data Field dialog box opens.

6 Select the parameter and click OK.

7 Click OK to close the Text Properties dialog. The new text element is shown in the Text 
Properties text box.

8 Click the Style tab and change the values as required.

9 Click OK.

10 Drag the new text element to a position above the chart. Line up the left edges using the 
girders as a guide.

11 Drag the edges of the text element until all the text is visible.

12 Preview the report.

13 Save the file.
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Publishing the Target Report

1 Click File → Publish. The Publish Report dialog box opens.

2 Click the User folder to select and open it.

3 Click OK to upload TargetReport to the User folder.

Adding a Report Link to a Table

The target report you have just created shows inventory value by product, with a parameter 
that can limit the results to a specific product category. You will create a report link that 
passes a single category as a value for this parameter. The report link will be associated with 
a text element that shows the category value.

The free-form group table you created in Chapter 6, Creating a Free-form Group Table 
includes the category value in its Group 2 Header. You will modify this element to include a link 
to your target report.

1 Open FancyGroup.rdl.

2 Double-click the table.

3 Select the text element containing the group name in the Group2 Hdr section. This should 
be the first element in the header.

4 Right-click the element and click Edit Text Element. The words Group Name are visible in 
the gray oval in the Text Properties dialog.

5 Select the Hyperlink option in the Link (optional) section below the text box.

6 Select _blank from the Target drop-down list and then click Report Link.

7 Click Browse at the top and double-click the User Report folder.

8 Select TargetReport and click OK.

9 Click in the Value field for CategoriesParam and select Category from the drop-down list.

10 Click OK to close the Report Link Editor.

11 Click OK to close the Text Properties dialog.
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12 Preview the report. The category names appear as hyperlinks.

13 Test the hyperlinks in the Preview pane.

14 Select File → Publish, click the User Reports folder and upload your report.

15 (Optional) Go to Report Center and run the report (see the HP Select Audit 1.02 Report 
Center User’s Guide for more information). Click a hyperlink that says Produce. A new 
browser window opens showing the target report titled Inventory Value by Product: 
Produce that includes only products from the Produce category.

16 Save the file.
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12 Other Topics
Adding Headers and Footers

This chapter shows you how to add headers and footers if you’ve deleted or omitted them. 
After adding a footer, you’ll add summaries to it.

Adding a Footer

1 Open a report that does not have footers.

2 Right-click in the table and click Edit Table. The Tabular Editor opens.

3 The Table Sections box lists of all the sections currently in your table. Underneath this list 
is a drop-down list of additional sections. Select Group 2 Footer in the drop-down list and 
click Add.

4 Click OK. The table now includes the group footer.

When saving reports, do not include a combination of blank spaces and the “+” character in 
the report name. The Report server will not recognize this combination.
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Adding Summaries

Add summaries to the footer you have just created.

1 Double-click the table to open it.

2 Select the Group2 Ftr section and then click the text icon in the toolbar. The Text Properties 
dialog opens.

3 Click Data. The Edit Data Field dialog box opens.

4 Click Add Summary. The Summary Field Editor dialog box opens.

5 Select a field from the Data Field drop-down list.

6 Select a function from the Summary Function drop-down list.

7 Click OK to close the Summary Field Editor. The data field is now shown in the Select Data 
Field box of the Edit Data Field dialog box.

8 Click OK to close the Edit Data Field dialog. A gray oval with the summary field is shown in 
the Text Properties box.

9 Click the Style tab and change the values as required.

10 Click the Format tab and select the 0.00 mask.

11 Click OK to close the Text Properties dialog.

12 Preview the report.

When you add a summary field, you are actually adding a new object to the report. This object 
is shown in the Tree inside the appropriate Nested Band or at the bottom of the Banded Table. 
Deleting a text element that contains a summary field does not remove the object. The object 
continues to be shown as an option in the Edit Data Field drop-down list in the appropriate 
context.
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Conditional Formatting

You can change the format for cells in a table based on a condition. For example, you can 
specify that numbers below a certain value are shown with a certain color or background.

1 Open a simple table and save the report with a new name.

2 Double-click the table in the Design view to open it.

3 Right-click a cell and click Style Element. The Text Properties dialog opens showing the Style 
tab.

4 Click Conditional. The Define Conditional Style dialog opens.

5 Select a field from the IF drop-down list.

6 Select an operator from the drop-down list.

7 Type a value in the field to the right of the operator.
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8 Select a color from the Foreground drop-down list in the THEN section.

9 Click OK to close the Define Conditional Style dialog box.

10 Click OK to close the Text Properties dialog box.

11 Preview the report and save the report.

Adding a Formula to a Query

You can add a formula to your query that computes a value based on other data fields. This 
computed field can then be used like any other field in the query in tables, charts and 
crosstabs. This section describes how to create a simple formula.

1 Click File → Open and open an RDL file.

2 In the Tree View, under Data Sources, right-click the query and select Edit SQL Query. The 
SQL Editor opens.

3 Click the Formulas tab and click Add. The JavaScript Editor opens with a special Insert 
Options tab at the bottom.
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4 Double-click a field in the Available Fields list. The field information is added to the text 
box.

5 Double-click a function in the Functions list. The function is added to the text box.

6 Click OK.

7 Double-click formula1 in the Label column of the SQL Editor and rename the label.

8 Select a type from the Type drop-down list.

9 Click OK.

10 Click the plus sign beside the query under Data Sources in the Tree View. The script is 
shown at the bottom of the list.

11 Save the file.

12 To view the output of the formula, create a table or crosstab using this query and include 
the field. Preview the report.
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Using JavaScript

You can attach JavaScript to a text element to control the values it displays. This section gives 
an example of using JavaScript to display the current date in a text element.

1 Click Insert → Text Element. A new text element opens.

2 Right-click the text element and select Edit Text Element. The Text Properties dialog opens.

3 Click Script. The JavaScript Editor opens.
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4 Insert the following code in the text box:

function todayStr() { var today=new Date(); return

today.getMonth()+1+"/"+today.getDate()+"/"+(today.getYear() + 1900) } 
todayStr();

5 Click OK. A gray circle representing the script is shown in the Text Properties dialog.

6 Click OK. The text element will show the current date when run.
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JavaScript, using, 102
opening, 13
Properties Area, 17
Status bar, 19
tabs, 16
toolbar icons, 19
Tree View, 17
user interface elements, 15

report link, defined, 89

ruler, defined, 18

S
selecting objects, 18

sidebar, defined, 19

simple table, creating, 29

Status bar, defined, 19

Submit button control, 84

T
tab

Design, 16
Preview, 16
RDL, 17

table
creating a group, 37
creating a simple, 29
linking, 22

Tree View, defined, 17

U
uploading from Report Designer, 35

user interface
Report Designer, 15
sections, 15
106


	Report Designer’s Guide
	Contents
	1 Overview
	What is the Report Designer?
	What’s in This Guide?
	What This Guide Is and Is Not
	How to Use this Guide
	The Select Audit Documentation Set

	2 User Interface Overview
	Opening the Report Designer
	User Interface
	User Interface Sections
	Tabs
	Design
	Preview
	RDL

	Tree View
	Properties Area
	Design Pane
	Design Pane Objects
	Selecting an Object
	Opening an Object
	Other Elements of the Design Pane
	Girders
	Rulers
	Sidebar


	Toolbar Icons
	Status Bar
	Error Pane

	3 Creating a Query
	Launching the Query Wizard
	Saving the Query to the Catalog
	Modifying the Query

	4 Creating a Simple Table
	Creating the Table
	Modifying the Table Content
	Changing the Table Text
	Changing the Date Mask
	Changing the Money Mask
	Deleting Table Elements

	Improving the Layout
	Alternate Row Styling
	Changing Alignments
	Resizing Columns
	Increase the Height of the Title

	Optional Next Steps
	Adding a Column Selector Control
	Using the Column Selector Control
	Uploading the Report to the Library
	Adding a Group to a Table


	5 Creating a Group Table
	Inserting a Group Table
	Modifying Table Content
	Changing Footer Summaries
	Adding Text to Footers

	Improving the Layout
	Resizing Columns
	A Note About Columns
	Widening the Table
	Custom Alternate Row Styling

	Optional Next Steps
	Changing the Grouping
	Making a Group Collapsible
	Adding a Sorting Link
	Changing the Theme


	6 Creating a Free-form Group Table
	Getting Started
	Downloading a Query from the Catalog
	Inserting a Table

	Improving the Content and Layout
	Editing and Styling the Title
	Deleting Text Elements
	Adding Text to a Data Field
	Adding Data to the Group Header
	Resizing and Positioning Elements
	Adding Space Between Groups
	Adding “Column” Headers at the Group Level

	Applying Custom Styling to a Table
	Styling Table Sections with the Toolbar
	Adding Borders Around the Entire Table
	Adding a Single Border to a Text Element


	7 Creating a Crosstab
	Launch the Layout Wizard
	Adjusting the Layout
	Changing the Title
	Eliminating a Subtitle
	Setting Row Headers
	Setting Column Headers

	Adding Another Summarized Data Field
	Changing the “Bucketing”

	8 Creating a Chart
	Creating the Query
	Editing the Query
	Upload the Query to the Catalog
	Creating the Layout for a Pie Chart
	Converting the Layout to Another Chart Type
	Turning Off Data Labels


	9 Creating a Multi-component Report
	Adding a Simple Table
	Creating a Crosstab
	Changing the Crosstab Labels
	Putting Borders Around the Crosstab

	Adding Fields to the Layout
	Adding a Label to the Crosstab
	Adding a Label to the Simple Table
	Adding a Report Title

	Adding an Image

	10 Controls and Parameters
	Using Controls
	Using Fixed-list and Free-text Controls
	Creating the Parameters
	Creating a Fixed-list Parameter
	Creating Free Text Parameters

	Modifying the Query
	Add the Parameter

	Creating the Component
	Adding Controls
	Adding a Download Control
	Adding a Check Box Control
	Adding the Free-text Controls
	Adding the Submit Control

	Making Parameters Mandatory

	Creating Controls Bound to Query-based Parameters
	Creating a Query for the Parameter
	Creating the Parameter
	Adding the Parameter to the Query
	Adding the Control
	Rearranging the Controls
	Add Labels to the Controls

	Add the Selected Text Element to the Header

	11 Using Report Links and Drilldowns
	Creating a Parameterized Target Report
	Creating a Query for the Parameter
	Creating the Parameter
	Modifying the Chart Query
	Creating the Pie Chart
	Adding a Parameterized Title
	Publishing the Target Report
	Adding a Report Link to a Table


	12 Other Topics
	Adding Headers and Footers
	Adding a Footer
	Adding Summaries

	Conditional Formatting
	Adding a Formula to a Query
	Using JavaScript

	Index



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (None)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.4
  /CompressObjects /Off
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.1000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 524288
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments true
  /PreserveOverprintSettings false
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Preserve
  /UCRandBGInfo /Preserve
  /UsePrologue true
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
    /Courier
    /Courier-Bold
    /Courier-BoldOblique
    /CourierNewPS-BoldItalicMT
    /CourierNewPS-BoldMT
    /CourierNewPS-ItalicMT
    /CourierNewPSMT
    /Courier-Oblique
    /Futura-Bold
    /Futura-Book
    /Futura-BookItalic
    /Futura-Heavy
    /Futura-Light
    /Futura-Medium
    /Futura-MediumItalic
    /Garamond
    /Garamond-Bold
    /Garamond-Italic
    /Helvetica
    /Helvetica-Bold
    /Helvetica-BoldOblique
    /Helvetica-Narrow
    /Helvetica-Narrow-Bold
    /Helvetica-Narrow-BoldOblique
    /Helvetica-Narrow-Oblique
    /Helvetica-Oblique
    /NewCenturySchlbk-Bold
    /NewCenturySchlbk-BoldItalic
    /NewCenturySchlbk-Italic
    /NewCenturySchlbk-Roman
    /Symbol
    /SymbolMT
    /Times-Bold
    /Times-BoldItalic
    /Times-Italic
    /Times-Roman
    /Webdings
    /Wingdings2
    /Wingdings3
    /Wingdings-Regular
    /ZapfDingbats
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 150
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 150
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /ColorImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 150
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 150
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /GrayImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 600
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects true
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile (None)
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /False

  /SyntheticBoldness 1.000000
  /Description <<
    /ENU ()
  >>
>> setdistillerparams
<<
  /HWResolution [600 600]
  /PageSize [612.000 792.000]
>> setpagedevice


