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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

You can visit the HP software support web site at:

www.hp.com/go/hpsoftwaresupport 

HP Software online support provides an efficient way to access interactive technical support tools. As a valued 
support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels and HP Passport, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
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1 Overview
This chapter covers the following topics

• OVPI and Cisco CallManager

• Enhancements in Version 3.0

• Data Collection and Aggregation

• Folders and Reports

• Integration with Network Node Manager

• Ways to Customize Reports

• Sources for Additional Information

OVPI and Cisco CallManager

Performance Insight is a performance management application that collects data from many 
sources, performs in-depth trend analysis, maintains performance baselines, and provides 
users with convenient, web-based reporting. Following is a partial list of OVPI features:

• Distributed architecture

• Easy to scale (supports data collection from thousands of agents)

• CODA/OVPA agent support

• Multi-company security model

• Data warehousing

• Near Real Time reporting

• Forecasting 

• Multiple aggregations (by day, week, month; by location, by customer)

• Thresholding and alerting

• Bottlenecks easy to spot; capacity trends easy to assess

• Accurate and timely documentation for management

Our reporting solution for Cisco CallManager call details consists of a report pack and a 
datapipe. Version 3.0 of the IP Telephony Call Detail Report Pack contains 51 reports. The 
datapipe, Cisco CDR Datapipe 3.0, has two data sources, Cisco CallManager and the NNM 
SPI for Cisco IP Telephony. Although Cisco CallManager has its own ad hoc reporting 
capability, those reports are limited and difficult to produce. Our reporting solution offers 
these advantages:

• Spans multiple CallManager clusters (inter-site reporting)
7



• Generates statistics for call quality, call availability, and call usage

• Generates the following statistics for CCM:

— Gateway usage

— Channel usage

— Resource utilization

— Performance Monitor

— Voice application process

• Produces rolling baseline statistics

• Produces forecasts derived from rolling baseline statistics

• Monitors thresholds for usage and availability and reports threshold breaches

• Integrates with the NNM SPI for Cisco IP Telephony

This report pack will not operate correctly until you assign a dial plan to each gateway. The 
procedure for this step is in Chapter 4, Post-Install Configuration. Chapter 4 also includes 
procedures for defining a data source. You can define the data source before installing the 
report pack or after installing the report pack. 

Enhancements in Version 3.0

Version 3.0 includes new reports, new features, new upgrade packages, a new release of the 
Cisco CDR Datapipe, and a defect fix. 

New Reports

• Gateway EndPoint Channel Top Ten by CM

• Gateway EndPoint Channel History Summary by CM

• Gateway EndPoint History Summary by CM

• Gateway EndPoint Channel Forecast by CM

• Gateway EndPoint Top Ten by CM

• Gateway EndPoint Channel History Summary by Location

• Gateway EndPoint History Summary by Location

• Gateway EndPoint Forecast by CM

• PerfMon Forecast

• PerfMon Summary

• Phone Number MOS Forecast

• Phone Number MOS Summary

• Phone Number MOS Top100Offender

• Process CallManager Forecast

• Process CallManager Summary 

• Process Forecast by Location

• Process Summary by Location
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• System Resource Forecast by Location

• System Resource Summary by Location

• System Resource CallManager Forecast

• System Resource CallManager Summary

• Voice Application History Summary by Location

• Voice Application CallManager History Summary

New Features

• Supports Management Console > LIR configuration 

• Supports Management Console > Copy Policy Manager

• Collects MOS data from CCM 5.x

• Collects gateway and channel usage statistics from the Cisco IPT SPI

New Upgrade Packages

• UPGRADE_IPT_CallDetails_Location_to_21

• UPGRADE_IPT_Admin_to_21

• UPGRADE_IPT_CallDetails_to_3

New Datapipe

• Cisco CDR Datapipe 3.0

Defect Fix

• QXCR1000352040

For details about changes to previous releases of the IP Telephony Call Detail, see Appendix 
A, Version History.

Data Collection and Aggregation

The Cisco CDR Datapipe performs the following tasks:

• Creates rate data tables

• Collects data from two sources:

— Cisco CallManager 3.3, 4.x, and 5.x

— NNM SPI for Cisco IP Telephony

• Maps data into hourly tables created by the IP Telephony Call Detail Report Pack.

Cisco CallManager as Data Source

Cisco CallManager produces two call information records: 

For details about the integration procedure, see Integrating with the Cisco IPT 
SPI on page 37.
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• Call Detail Records (CDRs)

• Call Management Records (CMRs)

A CDR stores information about call endpoints and other call control/routing details. CDR 
data is used to generate bills, to track call activity, to diagnose certain types of problems, and 
to evaluate the quality of service of calls through the system. Beginning with Cisco Call 
Manager 5.0, CDR data includes MOS values. MOS values measure call quality.

A CMR contains information about the quality of streamed audio. In Cisco literature, both 
CDRs and CMRs together are referred to as CDR data. 

The Cisco CDR Datapipe includes a preprocessor. If the raw data is not local, the preprocessor 
uses FTP to get the raw data. Next, the preprocessor parses CDR data, creating a format that 
Performance Insight can read and import.

Cisco IPT SPI as Data Source

The Cisco CDR Datapipe collects the following CCM details from the Cisco IPT SPI:

• Gateway availability and usage

• Gateway Endpoint availability and usage

• Channel availability and usage

• Performance Monitor statistics

• System resource usage

• Voice applications

The Cisco CDR Datapipe uses an XML parser to extract data from the SPI. If the SPI is not 
local, the XML parser uses FTP to get data from the SPI.

Mapping Rate Data to Hourly Tables

The Cisco CDR Datapipe runs a collection against each CallManager and the Cisco IPT SPI. 
Using data collected from these sources, the Cisco CDR Datapipe populates rate tables and 
maps data for the following statistics into hourly tables maintained by the report pack: 

• Lost packets

• Jitter

• Latency

• QoS values derived from lost packets, jitter, and latency

• Call volume

• Call duration 

• Call Success Ratio (CSR) 

• Disconnect Cause Distribution

• Call Type Distribution
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Data Summarization and Aggregation

In response to processing directives in the report pack, OVPI produces daily summaries from 
the hourly statistics, and monthly summaries from the daily statistics. In addition, OVPI 
aggregates data by:

• Phone Number 

• Gateway (by CallManager and also by location)

• CallManager 

• CallManager Cluster

• Location 

• Process

• System Resource

• Performance Monitor

Folders and Reports

IP Telephony Call Detail contains the following report folders: 

• CallManager

• CallManager Cluster

• Gateway

• Performance Monitor

• Phone Number 

• Process

• System Resource

• Voice Application

• Location 

Folder contents are as follows:

Call Manager Folder

• CallManager History Summary

• CallManager QoS Summary 

• CallManager History Top Ten

• CallManager QoS Top Ten

• CallManager Forecast

CallManager Cluster Folder

• Cluster History Summary

• Cluster QoS Summary 

• Cluster History Top Ten
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• Cluster QoS Top Ten

• Cluster Forecast

Gateway Folder

• Gateway History Summary by CallManager

• Gateway QoS Summary by CallManager

• Gateway History Top Ten by CallManager

• Gateway QoS Top Ten by CallManager

• Gateway Forecast by CallManager

• Gateway EndPoint Channel History Summary by CallManager

• Gateway EndPoint Channel Top Ten by CallManager

• Gateway EndPoint History Summary by CallManager

• Gateway EndPoint Top Ten by CallManager

Performance Monitor Folder

• Performance Monitor Forecast by CallManager

Phone Number Folder

• Phone Number History Summary

• Phone Number QoS Summary 

• Phone Number History Top Ten

• Phone Number QoS Top Ten

• Phone Number Forecast

• Phone Number MOS Forecast

• Phone Number MOS Summary

• Phone Number MOS Top 100 Offenders

Process Folder

• Process CallManager Forecast

• Process CallManager Summary 

System Resource Folder

• System Resource Metrics Forecast by Call Manager

• System Resource Metrics Summary by Call Manager 

Voice Application Folder

• Voice Service History Summary by Call Manager
12 Chapter 1



Location Folder

• Gateway History Summary by Location

• Gateway QoS Summary by Location

• Gateway History Top Ten by Location

• Gateway QoS Top Ten by Location

• Gateway Forecast by Location

• Location History Summary

• Location QoS Summary 

• Location History Top Ten

• Location QoS Top Ten

• Location Forecast

• Gateway EndPoint Channel History Summary by Location

• Gateway EndPoint History Summary by Location

• Process Forecast by Location

• Process Summary by Location

• System Resource Metrics Forecast by Location

• System Resource Metrics Summary by Location

• Voice Service History Summary by Location 

Admin Folder

The Admin folder contains one inventory report. This report provides a list of clusters, 
CallManagers, gateways, and IP phones. The inventory report reads property tables that are 
created by the Admin module and populated by the Cisco CDR Datapipe.

Generic Report Types

The IP Telephony Report Pack contains multiple instances of these reports:

• History Summary

• History Summary Top Ten

• QoS Summary

• Forecast

History Summary. Provides summary data about call history from multiple perspectives. 
This report focuses on the Call Success Rate (CSR) percentage, while also providing statistics 
for Total Call Minutes and Total Normal Disconnections. Selection tables rank items by CSR, 
highest to lowest. Investigate the CSR more closely by looking at the following graphs:

• Total Call Volume

• Total Call Minutes

IP Telephony Call Detail and IP Telephony Statistics use the same Admin module. They 
share the same inventory report and they share property tables.
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• Call Type Distribution 

• Maximum and Average Call Duration per success call

• Abnormal Disconnect Cause 

• Call Duration Distribution 

History Summary Top Ten. Performs a ranking function, using results from yesterday. 
Provides the following tables: 

• Highest Call Volume

• Highest Call Volume Increase

• Most Call Minutes

• Highest Call Minutes Increase

• Worst Call Success Rate 

• Highest CSR Decrease

QoS Summary. Provides summary data about call QoS metrics for multiple perspectives. 
Focuses on the packets lost, jitter, latency, and average QoS. Investigate call QoS more closely 
by looking at the following graphs:

• Calls by QoS value stacked by:

— Good

— Acceptable

— Fair

— Poor

• Packet Lost 

• Jitter 

• Latency

QoS Top Ten. Performs a ranking function, using results from yesterday. Provides the 
following tables: 

• Highest Packet Lost

• Highest Packet Lost Increase

• Highest Jitter

• Highest Jitter Increase

• Highest Latency 

• Highest Latency Decrease

Forecast reports. Focus on Total Calls 30, 60, and 90 days from today. You can investigate 
forecasts in more detail by using the following tabbed graphs: 

• Call Volume Forecast

• Call Minutes Forecast

• Call Success Rate Forecast

• Average QoS Forecast 

Use the Standard tab to compare the baseline average to future performance; use the Day of 
Week tab to correlate future performance by day of week; use the History tab to track the data 
used in the forecast. The rolling baseline average is based on 91 days of data.
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Integration with Network Node Manager

If you integrate OVPI and NNM, you can diagnose and isolate problems faster. Integrating 
NNM and OVPI involves running an integration script on NNM and running the Integration 
Wizard on OVPI. Installing integration packages on NNM and OVPI is no longer necessary.

If NNM and OVPI are already integrated, be sure to install the optional thresholds 
sub-package that comes with IP Telephony Call Detail. Installing the thresholds sub-package 
configures the Thresholds Module to detect threshold breaches related to Call Success, 
Network Fail, and QoS. If the Thresholds Module detects a breach, it responds by taking an 
action. The default action is to send a threshold trap to NNM. The trap received by NNM 
becomes an alarm in the NNM alarm browser. The NNM operator can respond to the alarm 
by opening the following reports: 

• CallManager History Summary

• CallManager QoS Summary

• Gateway History Summary by Location

• Gateway QoS Summary by Location

Configuring the Thresholds Module is not necessary. You do not need to define an action or 
specify a destination for breach traps. However, you are free to modify category, severity, and 
destination parameters at any time. For details about these options, refer to the Thresholds 
Module User Guide.

Ways to Customize Reports

The contents of a report can be customized. Here are your options:

• Apply group filters

• Edit parameters, tables, and graphs

• Add and modify property information, including thresholds

Service providers use group filters to produce customer-specific reports. Edits to parameters, 
tables, and graphs are temporary change that anyone can make. For more information about 
view options for tables and graphs see Appendix B, Editing Tables and Graphs.

Group Filters

If you want to share reports with your customers, you must configure OVPI to produce 
customer-specific reports. Here is an overview of the steps involved:

• Use Common Property Tables to import customer names and device locations

• Create a group account for all the users affiliated with each customer

• Create a group filter for each group account

For more information about group filters, refer to the OVPI Administration Guide. 
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Importing Property Information

The reports in this package include the following types of property information:

• The ID assigned to a cluster, CallManager, or gateway

• The customer and location associated with a cluster, CallManager, or gateway

• Threshold values assigned to a CallManager, gateway, or QoS parameter

• Users and locations assigned to IP phones

Property information comes from the following sources:

• Cisco CDR Datapipe

• Common Property Tables

• Change forms bundled with IP Telephony Call Detail

If the Cisco CDR Datapipe identifies a new CallManager or gateway, it will add that 
CallManager or gateway to Common Property Tables. When that CallManager or gateway 
appears in reports, the following defaults will appear as associated properties:

• Customer Unassigned 

• Location Unassigned 

To associate a customer or a location with a CallManager or a gateway, use the Update Node 
Information form. This form is bundled with Common Property Tables. When you navigate 
the object tree, you will see the form listed under Object Specific Tasks. 

The following properties are imported using forms bundled with IP Telephony Call Detail:

• CallManager thresholds

— Call Success threshold

— Network Fail threshold

— QoS threshold

• Gateway thresholds

— Call Success threshold

— Network Fail threshold

— QoS threshold

• Gateway dial plans

— International call prefix

— Local area codes 

— Toll free codes

• IP phone properties

— User

— Location

• QoS thresholds

Assigning a dial plan to each of your gateways is mandatory; if this 
step is not taken, the report pack will not function properly. 
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— Packet loss

— Jitter

— Latency

For more details about forms, see Chapter 4, Post-Install Configuration.

Editing Parameters

Editing a parameter applies a constraint. The constraint filters out the data you are not 
interested in seeing. If you edit the Customer Name parameter, data for every customer 
except the customer you typed in the Customer Name field drops from the report. Similarly, if 
you edit the Location parameter, data for all locations except the location you typed in the 
Location field drops from the report. 

You may apply multiple constraints at once. Which constraints are available depends in w 
which report you are viewing. Your constraint options depend on which report you are 
viewing. Each report supports one or more of the following constraints:

• Customer

• Location

• Cluster

• CallManager

• Gateway

• Phone number

If you are using the Web Access Server to view reports remotely, edit parameters by clicking 
the Edit Parameters icon at the bottom right-hand corner of the report. When the Edit 
Parameters window opens, enter the constraint in the field and click Submit. 

If you are using Report Viewer, select Edit > Parameter Values from the menu bar. When the 
Modify Parameter Values window opens, click the Current Value field. Type a new value and 
click OK.

Sources for Additional Information

This guide contains samples of some of the reports in the package. The demo package that 
comes with IP Telephony Call Detail contains a sample of every report in the package. If you 
have access to the demo package and you want to know what fully-populated reports look like, 
install the demo package. Like real reports, demo reports are interactive; unlike real reports, 
demo reports are static.

For information regarding the latest enhancements to this package and any known issues, 
refer to the IP Telephony Call Detail Report Pack Release Notes. You may also be interested in 
the following documents: 

• Call Manager 3.3 Call Detail Record Definition (Cisco)

• Call Manager 4.0(1) Call Detail Record Definition (Cisco)

• Call Manager 5.0 Call Detail Record Definition (Cisco)

• Cisco IP Telephony Statistics User Guide 

• Service Assurance Report Pack User Guide
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• Common Property Tables User Guide

• Thresholds Module User Guide 

• NNM/OVPI Integration User Guide

• OVPI Report Packs, April 2007, Release Notes 

You can download manuals for OVPI and manuals for the reporting solutions that run on 
OVPI from this site:

http://ovweb.external.hp.com/lpe/doc_serv/

The user guides for OVPI are listed under Performance Insight. The user guides for report 
packs and datapipes are listed under Performance Insight Report Packs. Every guide indicates a 
date. If a guide is revised and reposted, the date will change. Since we post revised manuals 
on a regular basis, you should check this site for an update before using any PDF that came 
with the report pack CD-ROM.
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2 The Upgrade Install
This chapter covers the following topics:

• Guidelines for a smooth upgrade

• Installing the upgrade 

• Package removal

Guidelines for a Smooth Upgrade

The report pack CD contains report packs, datapipes, and several shared packages. When you 
insert the CD and launch the extraction program, the install script extracts every package 
from the CD and copies the results to the Packages directory on your system. When the 
extract finishes, the install script prompts you to launch OVPI and start Package Manager. 
Before using Package Manager, review the following guidelines.

Prerequisites for Cisco CallManager

To successfully run IP Telephony Call Detail 3.0, each system running CallManager must be 
running the following software:

• CallManager version 3.3, 4.x, or 5.x

• FTP server (if running CallManager 3.3 or 4.x)

Prerequisites for Installing the Upgrade Package

The following software must be in place before upgrading:

• OVPI 5.2

• Any and all service packs available for OVPI 5.2

• Common Property Tables 3.6

• Cisco IP Telephony Admin 2.0

• Cisco IP Telephony CallDetails 2.0

• Cisco IP Telephony CallDetails Location 2.0 (optional)Cisco CDR Datapipe 2.1 

• FTP server configured with the trendadm user (allows the trendadm user to FTP)

IP Telephony Statistics and IP Telephony Call Detail share the same Admin 
package. If you just upgraded the IP Telephony Statistics Report Pack, the Admin 
sub-package is already upgraded
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Distributed Environments

If you are running IP Telephony Call Detail in a distributed environment, the upgrade is 
more complicated. These are the steps to follow:

1 Disable trendcopy on the central server.

2 Install the following package on the central server:

• UPGRADE_IPT_CallDetails_to_3; deploy reports 

• UPGRADE_IPT_Admin_to_21; deploy reports 

• UPGRADE_IPT_CallDetails_Location_to_21

3 For each satellite server:

• Install the following packages:

— UPGRADE_IPT_CallDetails_to_3

— UPGRADE_IPT_Admin_to_21 

— UPGRADE_IPT_CallDetails_Location_to_21

• Delete Cisco CDR Datapipe 2.1.

• Install Cisco CDR Datapipe 3.0

4 Re-enable trendcopy on the central server.

5 Configure the central server and each satellite server. For details, see Chapter 5, Setting 
up a Distributed System.

Upgrading Common Property Tables

If you are running an earlier version of Common Property Tables, upgrade to version 3.6 by 
installing the upgrade package. Installing this particular upgrade package is no different 
from installing any other upgrade package. However, do not install this upgrade package and 
other packages at the same time. Install the upgrade package for Common Property Tables 
and only the upgrade package for Common Property Tables.

Upgrading to IP Telephony Call Detail to 3.0

Perform the following tasks to upgrade IP Telephony Call Detail:

• Task 1: Extract packages from the report pack CD

• Task 2: If necessary, upgrade to Common Property Tables 3.6

• Task 3: Install the upgrade packages

• Task 4: Delete Cisco CDR Datapipe 2.1

• Task 5: Install Cisco CDR Datapipe 3.0

This 

If your system is distributed, do not install the datapipe on the central server.
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Task 1: Extract Packages from the report pack CD to the Packages directory on your system

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the report pack CD in the CD-ROM drive. On Windows, a Main Menu displays 
automatically; on UNIX, mount the CD if it does not mount automatically, then navigate 
to the top-level directory on the CD and run the ./setup command. 

4 Type 1 in the choice field and press Enter. The install script displays a percentage 
complete bar. When the copy is complete, the install script starts Package Manager. The 
Package Manager welcome window opens.

When the copy to the Packages directory is complete, you have the option of seeing the results 
by navigating to the Packages directory. If you open the IP_Telephony folder, you will see the 
following contents:

• Docs

• Gateway_Statistics.ap

• Gateway_Statistics_Demo.ap

• Gateway_Statistics_Location.ap

• Gateway_Statistics_Thresholds.ap

• IPT_Admin.ap

• IPT_CallDetails.ap

• IPT_CallDetails_Demo.ap

• IPT_CallDetails_Location.ap

• IPT_CallDetails_Thresholds.ap

• NNM_Utils

• UPGRADE_Gateway_Statistics_to_32.ap

• UPGRADE_Gateway_Statistics_Location_to_31.ap

• UPGRADE_IPT_Admin_to_21.ap 

• UPGRADE_IPT_CallDetails_to_3.ap 

• UPGRADE_IPT_CallDetails_Location_to_21.ap

Under the Cisco CDR Datapipe folder, you will see the following folder:

• CiscoCDR_Datapipe.ap

• Docs

Task 2: If necessary, upgrade to Common Property Tables 3.6

IP Telephony Call Detail requires Common Property Tables. If you have not already upgraded 
to version 3.6, upgrade now. Do not install other packages when you upgrade Common 
Property Tables. If you need help with the upgrade, refer to the Common Property Tables User 
Guide. When you finish the upgrade, click Done to return to the Management Console.
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Task 3: Install the upgrade packages

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install.

4 Approve the default installation directory or select a different directory if necessary. 

5 Click Next. The Report Deployment window opens. Accept the default for Deploy Reports; 
accept the defaults for application server name and port; type your user name and 
password for the OVPI Application Server. 

6 Click Next. The Package Selection window opens. 

7 Click the check box next to the following packages:

UPGRADE_IPT_CallDetails_to_3

UPGRADE_IPT_Admin_to_21 

UPGRADE_IPT_CallDetails_Location_to_21

8 Click Next. The Type Discovery window opens. 

9 Disable the default and click Next. The Selection Summary window opens.

10 Click Install. The Installation Progress window opens and the install process begins. When 
the install finishes, an installation complete message appears.

11 Click Done to return to the Management Console. 

Task 4: Remove Cisco CDR Datapipe 2.1 

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Uninstall.

4 Click Next. The Report Undeployment window opens.

5 Accept the defaults for Undeploy Reports, Application Server Name, and Port; type the 
username and password for trendadm.

6 Click Next. The Package Selection window opens. 

7 Click the check box next to the following package:

CiscoCDR_Datapipe 2.1

8 Click Next. The Selection Summary window opens. 

9 Click Uninstall. The Progress window opens and the removal process begins. When 
removal finishes, a removal complete message appears. 

10 Click Done to return to the Management Console.

Task 5: Install Cisco CDR Datapipe 3.0; restart OVPI Timer

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. 
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4 Click Next. The Report Deployment window opens. Disable the default for Deploy Reports; 
accept the defaults for application server name and port. Type your user name and 
password for the OVPI Application Server. 

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following package:

Cisco CDR Datapipe 3.0

7 Click Next. The Type Discovery window opens. Disable the default.

8 Click Next. The Selection Summary window opens.

9 Click Install to begin the installation process. The Installation Progress window opens and 
the install process begins. When the install finishes, an installation complete message 
appears.

10 Click Done to return to the Management Console. 

11 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Package Removal

Follow these steps to uninstall IP Telephony Call Detail and associated packages.

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. The Package Manager welcome window opens.

4 Click Next. The Package Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens. Accept the defaults for Undeploy 
Reports, Application Server Name, and Port; type the username and password for 
trendadm.

7 Click Next. The Package Selection window opens. 

8 Click the check box next to the following packages:

Cisco_IP_Telephony_Admin

Cisco_IP_Telephony_CallDetails

Cisco_IP_Telephony_CallDetails_Location (if installed) 

Cisco_IP_Telephony_CallDetails_Thresholds (if installed) 
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Cisco_IP_Telephony_CallDetails_Demo (if installed)

CiscoCDR_Datapipe

9 Click Next. The Selection Summary window opens. 

10 Click Uninstall. The Progress window opens and the removal process begins. When 
removal finishes, a removal complete message appears. 

11 Click Done to return to the Management Console.

12 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
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3 The New Install
This chapter covers the following topics:

• Guidelines for a smooth installation

• Installing the report pack and associated packages

• Accessing deployed reports

• New objects in the object model

• Package removal

Guidelines for a Smooth Install

An OVPI reporting solution has two ingredients, a report pack and a datapipe. Some reporting 
solutions offer multiple datapipes. Installing a datapipe configures OVPI to collect a specific 
type of performance data at a specific interval, while installing a report pack configures OVPI 
to summarize and aggregate the data collected by the datapipe.

When you insert the report pack CD-ROM and launch the package extraction program, the 
install script extracts every package from the CD and copies the results to the Packages 
directory on your system. After the extract finishes, the install script prompts you to launch 
OVPI and start Package Manager. 

This chapter contains the package extract procedure. If the extraction step has already taken 
place, then IP Telephony Call Detail is ready to install. Before starting Package Manager, 
review the following guidelines.

Prerequisites for a New Install

The following software must be in place before installing the IPT Call Detail package on the 
system running OVPI:

• OVPI 5.2

• Any and all service packs available for version of OVPI 5.2

• FTP server configured with the trendadm user (allows the trendadm user to FTP)

Details about each service pack, including installation instructions, can be found in the 
release notes created for each service pack. 

The following software must be in place on the CallManager system:

• CallManager version 3.3, 4.x, or 5.x

• FTP server (if running CallManager version 3.3 or 4.x) 
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Distributed Environments

If you intend to run this package in a distributed environment, installation is more 
complicated. The rules are as follows:

• Make sure that every server is running the same version of OVPI.

• Make sure that every server is running the same service packs.

• Disable trendcopy on the central server.

• Install the following packages on the central server:

— Cisco IP Telephony Admin; deploy reports

— Cisco IP Telephony CallDetails; deploy reports 

— Cisco IP Telephony CallDetails Location; deploy reports

— Cisco IP Telephony CallDetails Thresholds

— Thresholds Module (Threshold and Event Generation) 

— Common Property Tables 

• Install the following packages on each satellite server:

— Cisco IP Telephony Admin

— Cisco IP Telephony CallDetails

— Cisco IP Telephony CallDetails Location

— Common Property Tables 

— Cisco CDR Datapipe

• Re-enable trendcopy on the central server.

• Configure the central server and each satellite server. For details, see Chapter 5, Setting 
up a Distributed System.

Upgrading Common Property Tables

IP Telephony Call Detail requires Common Property Tables. If you are installing everything 
for the first time, the install wizard will install Common Property Tables for you. If you are 
running an earlier version of Common Property Tables, upgrade to the latest version by 
installing the upgrade package. Do not install other packages when you upgrade Common 
Property Tables. Install the upgrade package for Common Property Tables and only the 
upgrade package for Common Property Tables.

Integration with the NNM Alarm Browser

If NNM and OVPI are integrated, OVPI can notify NNM when threshold breaches are 
detected. To take advantage of this feature, install the optional thresholds sub-package. The 
default settings enabled by the optional thresholds sub-package can be modified by using the 
forms described in Chapter 4, Post-Install Configuration.

The thresholds sub-package has a prerequisite, the Threshold and Event Generation Module, 
commonly known as the Thresholds Module. For more information about configuration 
options, recent changes, and installation, refer to the Thresholds Module User Guide. 
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Installable Packages and Sub-Packages

Once OVPI packages have been extracted from the CD to the Packages directory on your 
system, the following packages are available for installation:

• IPT_Admin.ap

• Cisco_IP_Telephony_CallDetails.ap

• Cisco_IP_Telephony_CallDetails_Location.ap

• Cisco_IP_Telephony_CallDetails_Thresholds.ap

A brief description of each package follows.

IPT_Admin.ap

Allows the Cisco IP Telephony Statistics Report Pack and the IP Telephony Call Detail Report 
Pack to share property data for the objects they have in common. Sharing property data 
eliminates duplication, allows the database to operate more efficiently, and simplifies 
administration. The Admin module creates the following tables:

• K_IPT_Cluster — for IP Telephony CallManager clusters

• K_IPT_CManager — for IP Telephony CallManagers

• K_IPT_gateway — for the gateways associated with CallManagers 

• K_IPT_gateway_loc — for the gateways associated with locations

• K_IPT_phoneNum — for the IP phones associated with CallManagers

• K_IPT_loc — for the IP phones associated with locations

• K_IPT_Qos — for QoS parameters

The data in these tables can be modified using the property update forms described in 
Chapter 4, Post-Install Configuration.

Cisco_IP_Telephony_CallDetails.ap

The main package. Contains directives for OVPI related to summarizing and aggregating 
data.

Cisco_IP_Telephony_CallDetails_Location.ap

An optional sub-package that makes it possible to see usage patterns and trends aggregated 
by location.

Cisco_IP_Telephony_CallDetails_Thresholds.ap

This optional sub-package contains a thresholds policy. The policy is read by the Thresholds 
Module. The Thresholds Module monitors the database for threshold conditions and responds 
to a breach condition by taking an action. The Thresholds Module is a prerequisite for the 
optional thresholds sub-package.
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Installing IP Telephony Call Detail

Perform the following tasks to install IP Telephony Call Detail:

• Task 1: Stop OVPI Timer and extract packages from the report pack CD.

• Task 2: If necessary, upgrade to Common Property Tables 3.6. 

• Task 3: Install these packages:

— Cisco CDR Datapipe 

— Cisco_IP_Telephony_CallDetails 

— Cisco_IP_Telephony_CallDetails_Thresholds (optional)

— Cisco_IP_Telephony_CallDetails_Location (optional)

— Cisco_IP_Telephony_CallDetails_Demo (optional)

Task 1: Stop OVPI Timer and extract packages from the report pack CD

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the report pack CD in the CD-ROM drive. On Windows, a Main Menu displays 
automatically; on UNIX, mount the CD if it does not mount automatically, then navigate 
to the top level directory on the CD and run the ./setup command. 

4 Type 1 in the choice field and press Enter. The install script displays a percentage 
complete bar. When the copy is complete, the install script starts Package Manager. The 
Package Manager welcome window opens.

When the copy to the Packages directory is complete, you have the option of seeing the results 
by navigating to the Packages directory. If you open the IP_Telephony folder, you will see the 
following contents:

• Docs

• Gateway_Statistics.ap

• Gateway_Statistics_Demo.ap

• Gateway_Statistics_Location.ap

• Gateway_Statistics_Thresholds.ap

• IPT_Admin.ap

• IPT_CallDetails.ap

• IPT_CallDetails_Demo.ap

• IPT_CallDetails_Location.ap

This 

This procedure is designed for a stand-alone system. If your system is 
distributed, do not install the datapipe on the central server.
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• IPT_CallDetails_Thresholds.ap

• NNM_Utils

• UPGRADE_Gateway_Statistics_to_32.ap

• UPGRADE_IPT_Admin_to_21.ap 

• UPGRADE_IPT_CallDetails_to_3.ap 

• UPGRADE_IPT_CallDetails_Location_to_21.ap

Under the Cisco CDR Datapipe folder, you will see the following folder:

• CiscoCDR_Datapipe.ap

• Docs

You can ignore the upgrade packages. Installing the demo package is optional. You may install 
the demo package by itself, with no other packages, or you may install the demo package 
along with everything else. 

Task 2: Upgrade to Common Property Tables 3.6

IP Telephony Call Detail requires Common Property Tables 3.6. If you have not already 
upgraded to Common Property Tables 3.6, upgrade now. If you need help with the upgrade, 
refer to the Common Property Tables User Guide. When Package Manager indicates that the 
upgrade is complete, click Done to return to the Management Console.

Task 3: Install IP Telephony Call Detail, the Datapipe, and Optional Sub-Packages

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. Approve the default installation directory or select a different directory if 
necessary. 

4 Click Next. The Report Deployment window opens. Accept the default for Deploy Reports; 
accept the defaults for application server name and port; type your user name and 
password for the OVPI Application Server. 

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following packages:

Cisco_IP_Telephony_CallDetails 

Cisco_IP_Telephony_Admin 

Cisco_IP_Telephony_CallDetails_Location 

Cisco-IP_Telephony_CallDetails_Thresholds

CiscoCDR_Datapipe 

7 Click Next. The Type Discovery window opens. Disable the default.

If your system is distributed, the thresholds sub-package belongs on the 
central server, not on satellite servers. Installing the thresholds sub-package 
on satellite servers is necessary only if you want to set thresholds against 
hourly data.

The Cisco CDR Datapipe must be installed on any server that polls.
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8 Click Next. The Selection Summary window opens.

9 Click Install to begin the installation process. The Installation Progress window opens and 
the install process begins. When the install finishes, an installation complete message 
appears.

10 Click Done to return to the Management Console. 

11 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Accessing Deployed Reports

When you installed the Call Detail package, you enabled the Deploy Reports option. As a 
result, the reports in this package (as well as any forms that come with this package) were 
deployed to the OVPI Application Server. Once reports reside on the OVPI Application Server, 
you have two ways to view them:

• OVPI client applications

• Web browser

If the client applications are installed on your system, you have access to Report Viewer, 
Report Builder, and the Management Console. If you don’t have the client applications, then 
using a web browser is the only way you can view reports.

For more information about the clients, refer to the OVPI Installation Guide. For details about 
the Management Console, including how to use the Object/Property Management view to 
launch reports specific to a selected object, refer to the OVPI Administration Guide.

New Objects for the Object Model

An object is any item that has performance data or property information associated with it. 
Devices, customers, and locations are objects, and all three of these object categories belong to 
OVPI’s default object model. When you select an object in the object model, the right side of 
the Object/Property Management window refreshes, showing a list of forms under General 
Tasks, a list of forms under Object Specific Tasks, and a list of reports under Object Specific 
Reports. 

The object tree changes each time you install a new report pack. Some report packs add a new 
class of objects or services that do not fit within the default model. When this happens, 
installing the report pack adds a new view. To open the new view, select View > Change View. 

IP Telephony Call Detail adds the following object categories to the object model:

• Cluster

• CallManager

• Gateway

• GW Endpoint

• Channel

• IP_Phone
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Package Removal

Follow these steps to uninstall IPT Call Detail and the associated packages.

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Select HP OpenView > Performance Insight > Package Manager. The Package Manager 
welcome window opens.

4 Click Next. The Package Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens. Accept the defaults for Undeploy 
Reports, Application Server Name, and Port; type your username and password.

7 Click Next. The Package Selection window opens. 

8 Click the check box next to the following packages:

Cisco_IP_Telephony_Admin

Cisco_IP_Telephony_CallDetails

Cisco_IP_Telephony_CallDetails_Location (if installed) 

Cisco_IP_Telephony_CallDetails_Thresholds (if installed) 

Cisco_IP_Telephony_CallDetails_Demo (if installed)

CiscoCDR_Datapipe

9 Click Next. The Selection Summary window opens. 

10 Click Uninstall. The Progress window opens and the removal process begins. When 
removal finishes, a removal complete message appears. 

11 Click Done to return to the Management Console.

12 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
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4 Post-Install Configuration
This chapter covers the following topics: 

• Configuring a data source

• Assigning dial plans to gateways

• Integrating the reporting solution with the Cisco IPT SPI

• Modifying default thresholds for CallManagers and gateways

• Modifying users and locations for IP phones

• Modifying QoS parameters

Configuring a Data Source

This section explains how to:

• Configure the preprocessor to FTP CallManager raw data files to your OVPI server

• Collect data from the CallManager 5.x repository server

Using an FTP Session to Transfer Raw Data Files

If CallManager is storing raw data on a remote machine, configure the preprocessor to FTP 
those files from the remote machine to your OVPI server. Follow these steps: 

1 Open this file:

{DPIPE_HOME}/scripts/CiscoCDR_Collection.pro

2 Locate this line:

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoCDR_PP.pl

3 Change that line to:

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoCDR_PP.pl -f 1 
-m <Remote_Host_Name> -u <username> -p <password> -r <remote_directory> 
-v <CDR/CMR_version>

This step is mandatory. The report pack will not operate correctly 
until every gateway has a dial plan assigned to it.
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where options for this command include: 

Collecting Data from a CallManager 5.x Repository Server

To collect data from a CallManager 5.x repository server, follow these steps: 

1 Open this file:

{DPIPE_HOME}/scripts/CiscoCDR_Collection.pro

2 Locate this line:

{DPIPE_HOME}/bin/CCM5_datapipe -username=abc -password=abc -ccmHost=xx.xxx.xx.xxx 
-servicePort=8080 -ftpHost=xyz -ftpUser=xyz -ftpPassword=xyz -ftpDir=/xyz/ -timeZone=PST 

3 Change that line to:

{DPIPE_HOME}/bin/CCM5_datapipe -username=<repository_user> -password=<repository_password> 
-ccmHost=<repository_IP_address> -servicePort=<repository_service_port_number> 
-ftpHost=<name_of_OVPI_server_running_FTP> -ftpUser=<FTP_user> -ftpPassword=<FTP_password> 
-ftpDir=<full_pathname_of_location_of_collected_data> -timeZone=<repository_time_zone>

Option Description

-a The name of the CallManager to be monitored. The default is all devices are 
monitored.

-b The backup option for the Cisco CDR raw data files: delete, keep, or move.
The default is to move the CDR data files to the 
{DPIPE_HOME}/data/ImportData/CiscoCDR_Datapipe/backup directory.

-d The date of the CDR data file (in yyyymmdd format) to retrieve. The default is to 
retrieve all CDR data files (all dates).

-f The location from which to retrieve the CDR data files: 0 or 1 where 0 retrieves 
the CDR files from a local directory (defined by the -l option) and 1 retrieves the 
CDR files using ftp. The default is 0.

-h Lists the description of the command options.

-l The local directory where Cisco CDR data files are located. The default is 
{DPIPE_HOME}/data/ImportData/CiscoCDR_Datapipe

-m The ftp target machine name.

-p The password to use for the ftp session

-r The remote directory on the ftp target machine from which to retrieve the CDR 
data files.

-u The username to use for ftp session.

-v The version of the CCM data definition: 3.x, 4.x, or 5.x. The default is 5.x.
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Assigning Dial Plans to Gateways

The IP Telephony Call Detail Report Pack will not operate correctly until you have assigned a 
dial plan to every gateway. Do this as soon as possible. As soon as possible is one day after the 
datapipe’s first data collection. Follow these steps:

1 Start the Management Console.

2 Click Objects. The Object/Property Management window opens. 

3 Select View > Change View > Cluster.

4 Select a cluster.

5 Open a CallManager folder and select a gateway. You will see the Configure Gateway Dial 
Plan form under Object Specific Tasks.

6 Double-click Configure Gateway Dial Plan. The form opens.

7 Modify the following fields:

— International call prefix

— Local area codes

— Toll free codes

8 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.

9 Repeat this procedure for every gateway.
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Integrating with the Cisco IPT SPI

To integrate the reporting solution with the Cisco IPT SPI, you must install and configure 
files on the NNM server. Complete the following steps after installing the Cisco CDR 
Datapipe:

1 Run the following script to set the appropriate environment variables on the NNM server:

Windows: C:\Program Files\HP OpenView\bin\ov.envvars.bat

UNIX: . /opt/OV/bin/ov.envvars.sh

2 Copy the following files from the /CiscoCDR_Datapipe/CiscoCDR_Datapipe.ap/ 
directory on the OVPI server to the specified location on the NNM server:

3 On a UNIX NNM server, change ownership of the files copied in step 1 to bin:bin.

4 On a UNIX NNM server, change mode of the files copied in step 1 to 744.

5 On the NNM server, edit $OV_MAIN_PATH/java/ovpi_ipt_datapipe_config.txt. 
Set the following values (replace the environment variables $OV_DB, $OV_MAIN_PATH, 
and {DPIPE_HOME} with their actual values):

6 On the NNM server, edit $OV_LRF/ovpi_ipt_datapipe.lrf. In the first line set the 
full path to (replace the environment variable $OV_MAIN_PATH with its actual value):

<$OV_MAIN_PATH>/bin/ovpi_ipt_datapipe.ovpl

7 On the NNM server, run the following commands to register, start, and check the status 
of the datapipe process (replace the environment variable $OV_LRF with its actual value):

Copy this file on OVPI To this location on NNM

commons-net-1.4.1.jar $OV_MAIN_PATH/java

iptdatapipe.jar $OV_MAIN_PATH/java

ovpi_ipt_datapipe_config.txt $OV_MAIN_PATH/java

ovpi_ipt_datapipe.lrf $OV_LRF

ovpi_ipt_datapipe.ovpl $OV_MAIN_PATH/bin

Variable Value

ipt_spi_data_folder <$OV_DB>/nnmet

ftp_server OVPI_SERVER_NAME

ftp_user OVPI_FTP_USER_NAME

ftp_password OVPI_FTP_PASSWORD

remote_directory_path <{DPIPE_HOME}>/data/ImportData/CiscoCDR_Datapipe

sleep_interval_in_minutes 60

If editing the file on a Windows system, backward slashes must be escaped.

If editing the file on a Windows system, backward slashes (\) and colons (:) must 
be escaped.
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Windows:

ovaddobj “%OV_LRF%/ovpi_ipt_datapipe.lrf”
ovstart -d OVPI_IPT_Datapipe
ovstatus OVPI_IPT_Datapipe

UNIX:

ovaddobj <$OV_LRF>/ovpi_ipt_datapipe.lrf
ovstart -d OVPI_IPT_Datapipe
ovstatus OVPI_IPT_Datapipe

Modifying Default Thresholds 

The thresholds sub-package contains a thresholds policy. The thresholds policy imposes six 
defaults. Three pertain to CallManagers and three pertain to gateways. When performance 
reaches a default, OVPI sends a trap to the network management system. The following table 
provides details about the default values and severity levels. 

To modify the thresholds in the preceding table, use one or both of these forms:

• Modify CallManager Call Detail Thresholds 

• Modify Gateway Call Detail Thresholds   

Modifying Default Thresholds for CallManagers

Follow these steps to modify default thresholds for CallManagers:

1 Start the Management Console.

2 Click Objects. The Object/Property Management window opens. 

3 Select View > Change View > Cluster.

4 Select a cluster.

5 Open a CallManager folder and select a CallManager. You will see the Modify 
CallManager Call Detail Thresholds form under Object Specific Tasks.

6 Double-click Modify CallManager Call Detail Thresholds. The form opens.

Threshold Value Breach Condition Severity

Call Success 50% Call success ratio is below the threshold. Warning

Network Fail 50% The ratio of failed calls caused by network 
problems exceeds the threshold. 

Warning

QoS 3.0 Average QoS value for all calls exceeds the 
threshold. 

Warning
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7 Modify one or more defaults. 

8 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.

Modifying Default Gateway Thresholds

Follow these steps to modify default thresholds for gateways:   

1 Start the Management Console.

2 Click Objects. The Object/Property Management window opens.

3 Select View > Change View > Location. 

4 Select a location. 

5 Open the Gateway folder and select a gateway. You will see the Modify Gateway Call 
Detail Thresholds form under Tasks Specific to the Selected Objects.
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6 Double-click Modify Gateway Call Detail Thresholds. The form opens.

7 Modify one or more defaults. 

8 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.
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Modifying IP Phone User and Location

Follow these steps to configure IP phone username and location:

1 Start the Management Console.

2 Click Objects. The Object/Property Management window opens.

3 Select View > Change View > Cluster. 

4 Select a location, then open the CallManager folder.

5 Open the IP phone folder and select an IP phone. You will see the Configure IP Phone 
User and Location form under Tasks Specific to the Selected Objects.

6 Double-click Configure IP Phone User and Location. The form opens.

7 Add the user and location for one or multiple IP phones. 

8 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.
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Modify IP QoS Parameters

Follow these steps to modify default QoS definition ranges:   

1 Start the Management Console.

2 Click Objects. The Object/Property Management window opens.

3 You will see the Modify QoS Parameters form under General Tasks.

4 Double-click Modify QoS Parameters. The form opens.

5 Modify defaults for Good, Acceptable, Fair. 

6 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.
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5 Setting up a Distributed System
If you intend to run IP Telephony Call Detail as a distributed system, and you followed the 
instructions in the installation chapter, you installed packages on the central server and each 
satellite server, as follows: 

Central Server

• IP Telephony Call Detail 

• Location Sub-Package (optional)

• Thresholds Sub-Package (optional)

• Common Property Tables 

Satellite Server:

• IP Telephony Call Detail 

• Location Sub-Package (optional)

• Common Property Tables 

• Cisco CDR Datapipe

Your next step is to configure the central server to pull data from each satellite server. This is 
done by setting up connections from the central server to each satellite server database and 
by configuring trendcopy pull command. In addition, you have to disable daily aggregations 
on each satellite server.

Configuring the Central Server

To configure the central server, perform the following tasks:

• Task 1: Register the satellite server by setting the database role

• Task 2: Enable LIR

• Task 3: Add LIR mappings

• Task 4: Verify the automatically generated copy policies

Task 1: Register the satellite server by setting the database role

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the database system.

4 Click Database Properties.

5 From the Database Role list, select the Satellite Server role.
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6 Enter any information necessary to configure the Satellite Server role.

Task 2: Enable LIR

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the central server.

4 Click LIR Configuration.

5 Select the LIR enabled check box.

Task 3: Add LIR mappings

Configure LIR mappings for the following categories (for the CallDetails and sub-package you 
have installed): Cisco_IP_Telephony_CallDetails and 
Cisco_IP_Telephony_CallDetails_Location.

1 Start the Management Console (log on with Administrator privileges).

2 Click the Systems icon in the navigation pane.

3 Navigate to the OVPI Databases folder and select the central server.

4 Click LIR Configuration.

5 Click Add Mapping.

6 From the Select Satellite Server list, select a satellite server to which to add a mapping.

7 Select the Category data table option.

8 Select Cisco_IP_Telephony_CallDetails from the drop down list.

9 Select the rate data type.

10 Click Add to List.

11 To add an additional LIR mapping for the location sub-package, click Add to list and repeat 
step 6 through step 10.

12 Click OK.

13 Click Apply.

A copy policy is automatically generated for the hourly data and for each LIR mapping that 
you add. The data type selected when adding an LIR mapping (in step 9 above) determines 
the type of data copied (defined in the generated copy policy). The type of data copied (defined 
in the generated copy policy) is one summarization level greater than the data type selected in 
the LIR mapping. For example, if you select an hourly data type, a daily data copy policy is 
generated.

Task 4: Verify the automatically generated copy policies

Verify that a copy policy has been generated for the following tables and that the copy type is 
set correctly (to Property and Data):

1 Start the Management Console (log on with Administrator privileges).

2 Click the Copy Policy icon in the navigation pane to start the Copy Policy Manager.

To add a new database reference, you can use the Add Database Reference Wizard in the 
System and Network Administration application.
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3 Find the following tables (for IP Telephony Call Detail and sub-packages you have 
installed) and verify the copy type is set to Property and Data for each table: 

If a copy policy has not been generated for a table, do the following:

1 Click the New Copy Policy icon or select File > New Copy Policy from the Copy Policy 
Manager. The Copy Policy Wizard displays.

2 Click Next. The Satellite Server and Copy Policy Selection Page displays.

3 Select a satellite server from the pull down list. This is the satellite server from which 
data is copied to the central server.

4 Select Single Table and select the table from the pull down list.

5 Click Next. The Copy Type Selection Page displays.

6 Select Property and Data.

7 Click Next. The Summary page displays.

8 Verify the information in the summary window. If the information is not correct, you can 
modify it by clicking Back.

9 Click Finish.

10 Repeat step 4 - step 9 for all missing tables.

If only the copy type is not set to Property and Data, do the following:

1 Double-click the copy policy.

2 Select the Property and Data copy type.

3 Click OK.

CallDetails Location Sub-package

SHIPT_QoS_phoneNum SHIPT_QoS_gateway_loc

SHIPT_QoS_gateway SHIPT_QoS_loc

SHIPT_QoS_CManager SHIPT_Hist_gateway_loc

SHIPT_QoS_Cluster SHIPT_Hist_loc

SHIPT_Hist_phoneNum

SHIPT_Hist_gateway

SHIPT_Hist_CManager

SHIPT_Hist_Cluster
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Configuring a Satellite Server

Follow these steps to disable daily aggregations on each satellite server:

1 Modify the {DPIPE_HOME}/scripts/IPT_CallDetails_trendcopy.pro file (where 
{DPIPE_HOME} is the directory in which OVPI is installed):

Uncomment all of block0, including the begin and end lines.

2 Modify the {DPIPE_HOME}/scripts/IPT_CallDetails_Location_Daily.pro file: 

If you installed the Location sub-package, comment out the begin and end lines of 
blocks 2 - 5.

3 Modify the {DPIPE_HOME}/scripts/IPT_CallDetails_Loc_trendcopy.pro file): 

If you installed the Location sub-package, uncomment all of block0, including the begin 
and end lines.

4 Verify that the system clock is synchronized with the system clock on the central server. 
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6 Call History Summary
The History Summary reports look at call history from the following perspectives:

• Cluster

• CallManager

• Gateway by CallManager and by Location

• Location

• Phone number

• Gateway Endpoint by CallManager and by Location

• Gateway Endpoint Channel by CallManager and by Location

• Voice Service by CallManager and by Site

The focus of this report, regardless of the perspective you are using, is yesterday’s Call 
Success Rate (CSR). CSR is a percentage calculated by dividing successful calls by total calls 
and multiplying the result by 100. All selection tables sort by CSR, highest to lowest. All 
History Summary reports provide the following graphs:

• Total Call Volume stacked by Success Call and Failed Call

• Total Call Minutes

• Call Type Distribution stacked by:

— Internal

— Incoming PSTN

— Outgoing Local; Long Distance; International

— Tandem

• Maximum and Average Call Duration per success call

• Abnormal Disconnect Cause stacked by:

— Called Party Cause

— Wrong Number

— No Response

— Network Fail

— Others

• Call Duration Distribution stacked by:

— Less than 1 minute

— 1 to 5 minutes

— 5 to 30 minutes

— 30 minutes to 2 hours

— 2 hours to 12 hours

— More than 12 hours
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An hourly graph shows 24 hours for yesterday, a daily graph looks at data for the previous 30 
days, and a monthly graph looks at data for the previous 12 months. 
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7 Top Ten and Top 100 Reports
There are 14 top ten reports (related to call history, call QoS, gateway endpoint, and gateway 
endpoint channel) and one top 100 report (phone number MOS).    

Every top ten/100 report performs a ranking function that makes it easy for you to spot 
potential problem areas in yesterday’s extremes. 

The call history reports contain these tables:

• Highest Call Volume

• Highest Call Volume Increase

• Most Call Minutes

• Highest Call Minutes Increase

• Worst Call Success Rate 

• Highest CSR Decrease

The call QoS reports contain these tables:

• Highest Packet Lost

• Highest Packet Lost Increase

• Highest Jitter

Call History Call QoS

Cluster History Top Ten Cluster QoS Top Ten

CallManager History Top Ten CallManager QoS Top Ten

Gateway History Top Ten by CallManager Gateway QoS Top Ten by CallManager

Phone Number History Top Ten Phone Number QoS Top Ten

Location History Top Ten Location QoS Top Ten

Gateway History Top Ten by Location Gateway QoS Top Ten by Location

Gateway Endpoint Gateway Endpoint Channel

Gateway EndPoint Top Ten by CallManager Gateway EndPoint Channel Top Ten by 
CallManager

Phone Number MOS

Top Hundred Offenders by MOS
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• Highest Jitter Increase

• Highest Latency 

The gateway endpoint report contains these tables:

• Worst Hourly Usage

• Worst Daily Usage

• Worst Monthly Usage

The gateway endpoint channel report contains these tables:

• Worst Hourly 

• Worst Daily 

• Worst Monthly 

The top hundred offenders by MOS report contains this table:

• Top 100 offenders based on lowest MOS values
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8 Call QoS Summary Reports
The call QoS summary reports provide QoS metrics aggregated by:

• Cluster

• CallManager

• The gateways associated with each CallManager

• The gateways associated with each location

• The phone numbers associated with each CallManager

• The phone numbers associated with each location

These reports focus on the following metrics:

• Total calls

• Average packets lost

• Average jitter

• Average latency

• Average QoS

Investigate Packets Lost more closely by looking at the following data graphs, tabbed Hourly, 
Daily, and Monthly:

• Calls by QoS Value stacked by:

— Good

— Acceptable

— Fair

— Poor

• Packets Lost 

• Jitter 

— Average 

— Maximum

• Latency

— Average

— Maximum
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9 Forecast Reports
Forecast reports tell you whether call volume is growing or decreasing and how fast it is 
growing or decreasing. IPT Call Detail includes the following forecast reports:

• CallManager forecast

• Cluster forecast

• Gateway forecast by CallManager

• Phone number forecast

• Gateway forecast by location

• Location forecast

• Performance Monitor Forecast by CallManager

• Phone Number MOS Forecast

• Process CallManager Forecast

• Process Site Forecast

• System Resource Metrics Forecast by Call Manager

• System Resource Metrics Forecast by Site

CallManager, cluster, gateway, phone number, and location reports begin with an estimate of 
future call volume. The time ranges are 30 days from now, 60 days from now, and 90 days from 
now. You can investigate future performance in more detail by using the following graphs: 

• Call Volume Forecast

• Call Minutes Forecast

• Call Success Rate Forecast

• Average QoS Forecast 

Each graph has the following tabs:

Standard

Compare the baseline average to future performance.

Day of Week

Correlate future performance by day of week.

History

Inspect the data collected throughout the baseline period (the previous 91 days).
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10 Inventory Report
The inventory report provides a list of:

• Clusters

• CallManagers associated with each cluster

• Gateways associated with each CallManager

• IP phones associated with each CallManager

If you are in the habit of assigning customers and locations to CallManagers and gateways, 
this report will tell you which CallManager and gateways, if any, do not have customers or 
locations assigned to them.

The inventory report reads property tables created by the Admin module. The Admin module 
that comes with IPT Call Detail is exactly the same as the Admin module that comes with IP 
Telephony Gateway Statistics. Both packages share the same inventory report. The inventory 
report reads the following property tables:

• K_IPT_Cluster

• K_IPT_CManager

• K_IPT_gateway

• K_IPT_phoneNum

• K_IPT_gateway_loc (location module)

• K_IPT_loc (location module)

• K_IPT_QoS

These tables are refreshed daily by the Cisco CDR Datapipe. In addition, they are updated by 
any changes you make using the property update forms that come with IPT Call Detail. 
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11 Summary Reports
There are five summary reports that show summary views by phone number, CallManager, or 
site:

Phone Number MOS Summary - presents MOS metrics aggregated for a given phone 
number associated with a CallManager. This report can be used to view MOS statistic metrics 
and identify device performance issues. 

Process CallManager Summary - gives various process system level metrics reports of the 
selected object type associated with a CallManager. 

Process Site Summary - gives various process system level metrics reports of the selected 
object type associated with a site. 

System Resource Metrics Summary by CallManager - gives various system resource 
system level metrics reports of the selected object type associated with a CallManager. 

System Resource Metrics Summary by Site - gives various system resource system level 
metrics summary reports of the selected object type associated with a site.
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A Version History
Version Release Date Features/Enhancements

1.0 October 2003 • 30 call detail reports, 1 inventory report
• Sybase support
• OVPI Object Manager support
• Cisco CallManager 3.3 support
• CiscoCDR_Datapipe 1.0

2.0 August 2004 • Oracle support
• Cisco CallManager 4.0 support
• CiscoCDR_Datapipe 2.0

2.0 June 2005 new upgrade packages:
• UPGRADE_Cisco_IP_Telephony_Admin_to_2
• UPGRADE_Cisco_IP_Telephony_CallDetails_to_2
• UPGRADE_Cisco_IPT_CallDetails_Location_to_2
CiscoCDR_Datapipe 2.1 (defect fix)

3.0 April 2007 new features:
• LIR configuration (copy policies modified)
• Integration with the Cisco IPT SPI
• CCM 5.0 support (MOS data)

new reports

• Gateway EndPoint Channel Top Ten by CM

• Gateway EndPoint Channel History Summary by CM

• Gateway EndPoint History Summary by CM

• Gateway EndPoint Channel Forecase by CM

• Gateway EndPoint Top Ten by CM

• Gateway EndPoint Channel History Summary by Location

• Gateway EndPoint History Summary by Location

• Gateway EndPoint Forecase by CM

• PerfMon Forecast

• PerfMon Summary
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3.0 April 2007 • Phone Number MOS Forecast

• Phone Number MOS Summary

• Phone Number MOS Top100Offender

• Process CallManager Forecast

• Process CallManager Summary 

• Process Site Forecast

• Process Site Summary

• System Resource Site Forecast

• System Resource Site Summary

• System Resource CallManager Forecast

• System Resource CallManager Summary

• Voice Application Site History Summary

• Voice Application CallManagerHistory Summary

new upgrade packages:
• UPGRADE_IPT_CallDetails_Location_to_21
• UPGRADE_IPT_Admin_to_21
• UPGRADE_IPT_CallDetails_to_3

revised datapipe:

• Cisco CDR Datapipe 3.0
defect fix:
• QXCR1000352040

Version Release Date Features/Enhancements
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B Editing Tables and Graphs
Any table or graph can be viewed in several ways. Although the default view is usually 
adequate, you can easily change to a different view. If you are using Report Viewer, right-click 
the object to open a list of view options. If you are using the Web Access Server, follow these 
steps to change the default view of a table or graph:

1 Click Preferences on the links bar.

2 Expand Reports in the navigation frame.

3 Click Viewing.

4 Select the Allow element editing box.

5 Click Apply.

6 Click the Edit icon next to the table or graph. 

View Options for Tables

Right-clicking a table, or selecting the Edit Table icon if you are using the Web Access Server, 
opens a list of table view options.

Select Set Time Period to alter the relative time period (relative to now) or set an absolute time 
period. The Set Time Period window opens.

You may shorten the period of time covered by the table from, for example, 42 days to 30 days 
or to 7 days. If you are interested in a specific period of time that starts in the past and stops 
before yesterday, click Use Absolute Time and select a Start Time and an End Time.

Select Change Constraint Values to loosen or tighten a constraint, thereby raising or lowering 
the number of elements that conform to the constraint. The Change Constraint Values 
window opens. To loosen a constraint, set the value lower; to tighten a constraint, set the 
value higher.

The Select Nodes/Interfaces allows you to change the scope of the table by limiting the table to 
specific nodes, specific interfaces, or a specific group of nodes or interfaces. The Select Node 
Selection Type window opens.
 99



Change Max Rows increases or decreases the number of rows in a table. The default is 50. If 
you expand the default, the table may take more time to open. If you are trending a large 
network, using the default ensures that the table opens as quickly as possible. 
View in new Frame opens the table in a Table Viewer window, shown below. If necessary, make 
the data in the table more legible by resizing the window. 

View Options for Graphs

Right-clicking a graph, or clicking the Edit Graph icon if you are using the Web Access Server, 
opens the following list of view options. 
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The following table provides details about each option.

Style Options

Select Style to display a list of seven view options for graphs.

Option Function

Set Time Period Same as the table option shown above.

Change Constraint Values Same as the table option shown above.

Select Nodes/Interfaces Same as the table option shown above.

Displayed Data For every point on a graph, display data in a 
spreadsheet.

Grid Add these to the graph:
X axis grid lines
Y axis grid lines
X and Y axis grid lines

Legend Delete or reposition the legend. 

Style See the illustrations below.

Change Max Rows... Same as the table option shown above.

Display Data Table See below.

Export Element as CSV... Same as the table option shown above.

View in New Frame Opens graph in a Graph Viewer window.

Print Graph Same as the table option shown above.
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Style > Area

The plot or bar chart changes to an area graph. While relative values and total values are 
easy to view in this format, absolute values for smaller data types may be hard to see. Click 
anywhere within a band of color to display the exact value for that location 

To shorten the time span of a graph, press SHIFT+ALT and use the left mouse button to 
highlight the time span you want to focus on. Release the mouse button to display the selected 
time span.

Style > Stacking Area

The area or plot graph changes to a stacking area graph. This view is suitable for displaying a 
small number of variables.
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Style > Bar

The graph changes to a bar chart. This view is suitable for displaying relatively equal values 
for a small number of variables. There are three variables in the graph below.

Style > Stacking Bar

The plot or area graph changes to a stacking bar chart. If you increase the width of the frame, 
the time scale becomes hourly. If you increase the height of the frame, the call volume shows 
in units of ten.
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Style > Plot

Bands of color in an area graph change to lines. If you adjust the frame width, you can make 
the data points align with hour; if you adjust the frame height, you can turn call volume into 
whole numbers.

Style > Pie

An area graph becomes a pie chart. Bands in an area graph convert to slices of a pie and the 
pie constitutes a 24-hour period. This view is helpful when a small number of data values are 
represented and you are looking at data for one day.

If you are looking at data for more than one day, you will see multiple pie graphs, one for each 
day. 
104 Appendix B



Display Data Table

This option changes a graph into a spreadsheet. 

View in New Frame

The graph opens in a Graph Viewer window. Improve legibility by resizing the window. 
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