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Support

Please visit the HP OpenView web site at:

http://www.managementsoftware.hp.com/ 

This web site provides contact information and details about the products, services, and support that HP 
OpenView offers.

HP OpenView online software support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As a valuable 
support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track progress on support cases

• Manage a support contract

• Look up HP support contacts

• Review information about available services

• Enter discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and log in. Many also require a 
support contract. 

To find more information about access levels, go to:

http://www.hp.com/managementsoftware/access_level 

To register for an HP Passport ID, go to:

http://managementsoftware.hp.com/passport-registration.html
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1 Overview
The Interface Discovery Datapipe discovers interfaces on SNMP-manageable devices. In 
addition to discovering interfaces, the Interface Discovery Datapipe maintains configuration 
data for discovered interfaces. To ensure continuity of data when the value of ifIndex changes, 
the Interface Discovery Datapipe supports the use of alternate, persistent attributes, namely:

• ifDescr

• ifName

• ifAlias

The following report packs rely on the Interface Discovery Datapipe to discover interfaces and 
maintain configuration information:

• ATM Report Pack

• Cisco Ping Report Pack

• Executive Summaries Report Pack

• Frame Relay Report Pack

• Interface Reporting Report Pack

• MPLS VPN Report Pack

• NetFlow Interface Report Pack

• NetFlow Global View Report Pack

Reindexing Log Report

The Interface Discovery Datapipe includes a Reindexing Log Report. This report deploys to 
the OVPI Application Server when you install the package. The Reindexing Log Report 
contains the following information:

• Identity of each interface (attribute and value)

• Date and time of report

• MIB-II ifIndex value of each interface (“Current Index” column)

• Previous index identifier, if any

• Number of attribute changes

This report, shown below, refreshes whenever an existing device re-indexes or whenever a 
new device is added.
3



Enhancements and Defect Fixes

The following table outlines recent enhancements to the Interface Discovery Datapipe.

Version Release Date Enhancements/Defect Fixes

1.0 January 2003 Sybase support.

1.1 May 2003 Defect fixes.

2.0 April 2004 OVPI Object Manager support. Oracle support.

2.1 November 2004 Added Juniper .dis file.

2.2 June 2005 Defect fixes.

2.3 May 2006 Defect fix:
• QXCR1000282768 (ifAlias available in IR even 

when ifAlias is not used as an interface 
identifier.)
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Sources for Additional Information

The following documents are related to this manual:

• Interface Discovery Datapipe 2.4 Release Statement

• Interface Reporting ifEntry Datapipe 2.4 User Guide

• Interface Reporting Report Pack 5.2User Guide

• OVPI Report Packs, CD-ROM Release Notes, April 2007

Manuals for the core product, OVPI, and manuals for the reporting solutions and shared 
packages that run on OVPI, can be downloaded from this site:

http://ovweb.external.hp.com/lpe/doc_serv/

The user guides for OVPI are listed under Performance Insight. The user guides for report 
packs and datapipes are listed under Performance Insight Reporting Solutions. The entry for a 
manual indicates the month and year it was posted to the web. If a manual is revised and 
reposted, the date will change. Since revised manuals are reposted from time to time, be sure 
to compare your PDF to the web edition and download the web edition if it is newer.

2.4 April 2007 Partition maintenance
Sybase 15 ROW_COUNT updates to this file:
• post_collection_processing.sql
Defect fixes:
• QXCR1000348557 (Datapipe does not collect 

correct info for devices with 10G speed 
interfaces.)

• QXCR1000380493 (Cursor variables in Oracle 
POST_COLLECTION_PROCESSING_P  are 
too small.)

• QXCR1000393264 (Datapipe does not 
correctly update K_IFEntry_Disc.)

Upgrade package:
• UPGRADE_IFEntry_Disc_Datapipe_to_24

Version Release Date Enhancements/Defect Fixes
Overview 5
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2 Package Installation
This chapter covers the following topics:

• Guidelines for a smooth installation

• Using Package Manager

• Additional steps for Remote Pollers

• Package removal

Version 2.4 of the Interface Discovery Datapipe requires OVPI 5.2 or higher. There are no 
package-level prerequisites for the Interface Discovery Datapipe.

Guidelines for a Smooth Installation

The report pack CD has the latest report packs, datapipes, and shared packages. When you 
insert the CD and launch the package extraction program, the install script on the CD 
extracts every package to the Packages directory on your system. When the extract finishes, 
the install script launches Performance Insight and starts Package Manager.

If the extract step has already taken place, every package is available for installation. Install 
the Interface Discovery Datapipe by launching Performance Insight, starting Package 
Manager, and following the on-screen directions. Before using Package Manager, be aware 
that you have an upgrade package if you need it, and be aware that you will be installing this 
datapipe on multiple servers if you have a distributed system.

Upgrading to Version 2.4

If you are running an earlier version of this datapipe, upgrade to version 2.4 by installing the 
upgrade package. Installing the upgrade package will allow you to avoid several unpleasant 
side-effects. If you install the upgrade package, as opposed to removing your current version 
and then reinstalling version 2.4, you can avoid the following problems:

• The IR ifEntry Datapipe will stay in place; it will not be removed.

• You will not lose lose interface configuration data. 

• If you were polling a flagged collection — Poll Flagged Interfaces Only — you will not have 
to re-provision the polling flag.

• You will not lose polling group information. 

• You will not have to reassign devices to the appropriate interface identifier group.
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Distributed Systems

If your system is distributed, installation is more complicated. Install the Interface Discovery 
Datapipe on every OVPI server that performs polling. There is no need to install the Interface 
Discovery Datapipe on the central server unless the central server is polling.

Using Package Manager

Insert the report pack CD and follow the instructions for extracting packages from the CD to 
the Packages directory on your system. On Windows, the instructions appear in a Main Menu 
that opens automatically. On UNIX, log in as root, mount the CD (if the CD does not mount 
automatically), navigate to the top level of the CD directory, and run the ./setup command.

When the extract finishes, the install script starts Package Manager. If you have the Package 
Manager install wizard up and running right now, start this procedure at step 4; otherwise 
begin at step 1.

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows NT: Select Settings > Control Panel > Administrative Tools > Services

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 From the Management Console, start Package Manager. The Package Manager welcome 
window opens.

4 Click Next. The Package Location window opens.

5 Click Install. Approve the default destination directory or browse to a different directory if 
necessary.

6 Click Next. The Report Deployment window opens. Type your OVPI username and 
password.

7 Click Next. The Package Selection window opens. 

8 If you are running version 2.3, click the check box for the upgrade package:

UPGRADE_IFEntry_Disc_Datapipe_to_24

9 If you installing this package for the first time, click the check box next to this entry:

IFEntry_Disc_Datapipe 2.4

10 Click Next. The Type Discovery window opens. Accept the default to run Type Discovery.

The Interface Discovery Datapipe includes vendor-specific type discovery files. These files 
will automatically assign the appropriate index-by group to the devices that belong to those 
vendors. If you want to manually assign additional device types to alternative interface 
identifiers manually, disable the Type Discovery option. Once the package is installed, use 
Polling Policy Management to assign the devices to the appropriate index-by group.
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11 Click Next. The Selection Summary window opens.

12 Click Install. The Installation Progress window opens and the install begins. When the 
install finishes, a package installation complete message appears.

13 Click Done.

14 Restart OVPI Timer.

Windows NT: Select Settings > Control Panel > Administrative Tools > Services

UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

The Interface Discovery Datapipe is now installed on your system.

Package Removal

Follow these steps to uninstall the Interface Discovery datapipe:

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

3 From the Management Console, start Package Manager. The Package Manager welcome 
window opens.

4 Follow the on-screen directions for package removal; when prompted, select the Interface 
Discovery Datapipe for removal. When the uninstall is complete, a package removal 
complete message appears.

5 Click Done.

6 Restart OVPI Timer.
Package Installation 9
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3 Datapipe Configuration
This chapter explains how to:

• Enable support for re-indexing

• Change an interface identifier

• Configure polling groups and polling policies for remote pollers

If you change an interface identifier for a given device after polling for that device has already 
started, the data collected after the change will use the new interface identifier and the 
pre-change data will not be associated with the post-change data. To avoid this outcome, 
assign all devices to the desired index-by groups before data collection begins.

Enabling Re-Indexing Support

The MIB-II definition does not guarantee a persistent value for ifIndex. Adding or removing 
an interface, upgrading software, or even rebooting the system may change the ifIndex value 
for an interface. If one of these events occurs and a unique and persistent identifier is not in 
use, data collected before re-indexing took place not be associated with the interface.

The Interface Discovery Datapipe provides the following alternate identifiers:

• ifDescr — supported by the index-by-ifDescr polling group

• ifName — supported by the index-by-ifName polling group

• ifAlias — supported by the index-by-ifAlias polling group

To enable re-indexing, select an alternate identifier (just one alternate identifier) that is 
unique for the device and persistent. Keep in mind that the Interface Discovery Datapipe 
includes vendor-specific Type Discovery files that automatically assign certain types of 
devices to an alternate interface identifier. As a result, some of the selection work is already 
done for you. If you are moving a device from index-by-ifIndex to any other group, the system 
will update the identifier and replace ifIndex with the new identifier.

The following table contains a list of device types and pre-assigned identifiers.

Device Type Identifier Assigned by OVPI Type Discovery

Cisco Catalyst switches ifName

Cisco routers ifDescr

HP ProCurve switches 
(except 800T)

ifName
  11



The Interface Discovery Datapipe installs vendor-specific type discovery files in the 
DPIPE_HOME/scripts directory. If you already have devices assigned to index-by groups, or if 
you want to assign devices manually, follow these steps:

1 Disable type discovery.

2 Remove the .dis file from the scripts directory.

3 Assign devices manually.

Changing an Interface Identifier

The index-by-ifIndex group is the default group. It automatically contains all the devices in 
the GENMIB2IF_Datapipe group that are not in the index-by-ifAlias, index-by-ifDescr, or 
index-by-ifName groups.

How to Change an Interface Identifier

Follow these steps to change an interface identifier:

1 For each device type, choose the interface identifier.

2 Assign each device of that type to the appropriate index-by group.

a Start the Management Console.

b Click the Polling Policies icon. The Polling Policy Management window opens.

c Select Edit > Polling Groups.

d Select All Nodes of the Same Type in the top pane, and the required index-by group in 
the bottom pane. Click Edit.

e Select the nodes to be assigned to this group in the left-hand pane, and click >> to 
move them into the group on the right. Click OK when complete.

3 Repeat the process above for other device types and index-by groups as necessary.

4 Optional. If you just assigned devices to a polling group that is different from the polling 
group that type discovery would put them in, remove the following Cisco or HP type 
discovery files from the DPIPE_HOME/scripts directory:

• Cisco_device_by_ifName.dis

• Cisco_router_by_ifDescr.dis

• HP_ProCurve_by_ifName.dis

Duplicate Identifier Messages

If a device is assigned to an index-by group but the identifiers are not unique, then a duplicate 
identifier message, similar to the following message, will be inserted in the Trend log.

bcp_gateway,,WARNING,1984,2076,0,"the object [testhost.test.hp.com_AT3/0] is 
duplicate for data table rv_ifentry_disc_ifname"
12 Chapter 3



Configuring for Multiple Pollers

Additional steps are necessary if you are using the Interface Discovery Datapipe with 
multiple remote pollers. The standard installation configures four groups and eight polling 
policies for a single remote poller. Each remote poller will need its own polling group and 
polling policy.

The datapipe package includes group and collection policy files for two pollers. If you need to 
configure more than two pollers against a single database, you will need to generate 
additional sets of group files and policies.

1 Log in to the system. On UNIX, log in as root.

2 Navigate to the Interface Discovery Datapipe package directory:

UNIX:

$DPIPE_HOME/packages/IFEntry_Disc_Datapipe/IFEntry_Disc_Datapipe.ap

Windows:

%DPIPE_HOME%\packages\IFEntry_Disc_Datapipe\IFEntry_Disc_Datapipe.ap

3 Run this command:

trend_proc -f create_groups_multi_pollers.pro

4 Run this command:

collection_manager -import -file IFEntry_Disc_Collection_Policies_multi_pollers

5 Start Polling Policy Management and select Edit > Datapipe Installations.

6 Click Create... to create new pollers. Add the hostname and (optionally) the IP address of 
each poller and click OK.

7 When all pollers have been added, click Close to exit.

8 Click All in the left panel to display all polling policies.

9 Delete the original Flagged Discovery policies (those without an _p1 or _p2 at the end of 
the name).

10 Modify the new Flagged Discovery policies (those with an _p1 or _p2 at the end of the 
name) by double-clicking the policy.

a Change the Polling Assigned to setting for the poller1 policies to be the hostname of 
poller1 as configured in step 8.

b Change the Polling Assigned to setting for the poller2 policies to be the hostname of 
poller2 as configured in step 8.
Datapipe Configuration 13



At this point, the 15-minute policies should look similar to those in the following table.

11 Modify the existing All Discovery policies by double-clicking the policy.

a For the Collect Data From option, select A Combination of Type and View.

b Click the Create... button for the Group to Poll From and create an and intersection 
between the index-by Type group and the poller1 View group.

c Change the Polling Assigned to setting to be the hostname of poller1.

12 Add new All Discovery policies by selecting File > Create Polling Policy...

a Create four new policies similar to the poller1 policies but with the Group to Poll From 
to be the equivalent poller2 group.

b Change the Collect Data From to be A Combination of Type and View.

c Click the Create... button for the Group to Poll From and create an and intersection 
between the index-by Type group and the poller2 View group.

d Set the Polling Assigned to setting to be the hostname of poller2.

At this point, the daily policies should look similar to the policies in the table below.

Polling Policy
Table Alias Name for Data 
to be Collected

Group Name to Collect 
From Poll From

Flagged_ifName_Disc_p1 x_IFEntry_Disc_ifName discover-by-ifName-poller1 Hostname of poller1

Flagged_ifAlias_Disc_p2 xV_IFEntry_Disc_ifAlias discover-by-ifAlias-poller2 Hostname of poller2

Flagged_ifDescr_Disc_p2 xV_IFEntry_Disc_ifDescr discover-by-ifDescr-poller2 Hostname of poller2

Flagged_ifIndex_Disc_p2 xV_IFEntry_Disc_ifIndex discover-by-ifIndex-poller2 Hostname of poller2

Flagged_ifName_Disc_p2 xV_IFEntry_Disc_ifName discover-by-ifName-poller2 Hostname of poller2

Flagged_ifDescr_Disc_p2 xV_IFEntry_Disc_ifDescr discover-by-ifDescr-poller2 Hostname of poller2

Flagged_ifIndex_Disc_p2 xV_IFEntry_Disc_ifIndex discover-by-ifIndex-poller2 Hostname of poller2

Flagged_ifName_Disc_p2 xV_IFEntry_Disc_ifName discover-by-ifName-poller2 Hostname of poller2

Polling Policy
Table Alias Name for Data 
to be Collected

Group Name to Collect 
From Poll From

All_ifIndex_Discovery_p2 xV_IFEntry_Disc_ifIndex index-by-ifIndex-poller2 Hostname of poller2

All_ifName_Discovery_p2 xV_IFEntry_Disc_ifName index-by-ifName-poller2 Hostname of poller2

All_ifAlias_Discovery_p2 xV_IFEntry_Disc_ifAlias index-by-ifAlias-poller2 Hostname of poller2

All_ifDescr_Discovery_p2 xV_IFEntry_Disc_ifDescr index-by-ifDescr-poller2 Hostname of poller2

All_ifAlias_Discovery xV_IFEntry_Disc_ifAlias index-by-ifAlias-poller1 Hostname of poller1

All_ifDescr_Discovery xV_IFEntry_Disc_ifDescr index-by-ifDescr-poller1 Hostname of poller1

All_ifIndex_Discovery xV_IFEntry_Disc_ifIndex index-by-ifIndex-poller1 Hostname of poller1

All_ifName_Discovery xV_IFEntry_Disc_ifName index-by-ifName-poller1 Hostname of poller1
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13 Select Edit > Polling Groups... > All Nodes in Same View in the upper pane, then select poller1 
in the lower pane. Assign nodes to be collected by poller1 to the poller1 View.

14 Select Edit > Polling Groups... > All Nodes in Same View in the upper pane, then select poller2 
in the lower pane. Assign nodes to be collected by poller2 to the poller2 View.
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4 Polling Groups and Polling Policies
A standard installation of the Interface Discovery Datapipe enables five polling groups and a 
combination of daily and 15-minute polling policies. Unless you need to enable support for 
multiple pollers, modifying the default polling policies is unnecessary.

Polling Groups

The polling groups enabled by installing the Interface Discovery Datapipe are described in the

following table.

All four groups are based on GENMIB2IF_Datapipe. The index-by-ifIndex group is 
automatically re-populated by the system once an hour. If a device is reassigned to a new 
group, it will not immediately disappear from the index-by-ifIndex. However, thereafter, the 
device will be polled from its new index-by group.

Any of the five polling groups in the preceding table can be viewed and modified using Polling 
Policy Manager. To view or modify a polling group, open Polling Policy Management and select 
Edit > Polling Groups > All Nodes of the Same Type.

Name Description

GENMIB2IF_Datapipe Top-level group for all nodes that support MIB-II.

index-by-ifAlias Subset of the GENMIB2IF_Datapipe group; contains all 
nodes that should use ifAlias as the identifier.

index-by-ifDescr Subset of the GENMIB2IF_Datapipe group; contains all 
nodes that should use ifDescr as the identifier.

index-by-ifIndex Subset of the GENMIB2IF_Datapipe group; containing all 
the devices that do not belong to the index-by-ifAlias, 
index-by-ifDescr, or index-by-ifName groups. Unless a device 
is assigned to a different group, the device defaults to ifIndex 
as the interface identifier. Editing this group is not 
necessary. 

index-by-ifName Subset of the GENMIB2IF_Datapipe group; contains all 
nodes that should use ifName as the identifier.
  17



Polling Policies

A standard installation of the Interface Discovery Datapipe enables the following polling 
policies:

• Four daily policies, one for each index-by group

• Four 15-minute policies, one for each index-by group

Daily Policies

The daily policies discover (and subsequently, rediscover) all of the interfaces on all of the 
devices that support MIB-II. The daily policies are listed in the following table.

15-Minute Policies

The 15-minute policies discover all of the interfaces for flagged devices only. These policies are 
listed in the following table.

The Interface Discovery Datapipe adds a flag column called ifEntry_discover_flag to the core 
managed node table ksi_managed_node. If a re-indexing event is detected for a particular 
node, or if a new node is added to the system, the discover flag is set and the interfaces on that 
node will be re-discovered during the next polling cycle.

Policy Name
Table Alias Name for Data 
to be Collected 

Group Name to Collect 
From

All_ifAlias_Discovery xV_IFEntry_Disc_ifAlias index-by-ifAlias

All_ifDescr_Discovery xV_IFEntry_Disc_ifDescr index-by-ifDescr

All_ifIndex_Discovery xV_IFEntry_Disc_ifIndex index-by-ifIndex

All_ifName_Discovery xV_IFEntry_Disc_ifName index-by-ifName

Policy Name
Table Alias Name for Data 
to be Collected 

Group Name to Collect 
From

Flagged_ifAlias_Discovery xV_IFEntry_Disc_ifAlias discover-by-ifAlias

Flagged_ifDescr_Discovery xV_IFEntry_Disc_ifDescr discover-by-ifDescr

Flagged_ifIndex_Discovery xV_IFEntry_Disc_ifIndex discover-by-ifIndex

Flagged_ifName_Discovery xV_IFEntry_Disc_ifName discover-by-ifName
18 Chapter 4
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