
HP OpenView Configuration Management 

Service Desk Adapter 
for the Windows operating system 

Software Version: 5.00 

Integration Guide 


Document Release Date: April 2007 

Software Release Date: April 2007 



Legal Notices 

Warranty 

The only warranties for HP products and services are set forth in the express warranty 
statements accompanying such products and services. Nothing herein should be construed as 
constituting an additional warranty. HP shall not be liable for technical or editorial errors or 
omissions contained herein. 

The information contained herein is subject to change without notice. 

Restricted Rights Legend 

Confidential computer software. Valid license from HP required for possession, use or 
copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer 
Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. 
Government under vendor's standard commercial license. 

Copyright Notices 

© Copyright 2007 Hewlett-Packard Development Company, L.P. 

Trademark Notices 

Linux is a registered trademark of Linus Torvalds. 


Microsoft®, Windows®, and Windows® XP are U.S. registered trademarks of Microsoft 

Corporation.


OpenLDAP is a registered trademark of the OpenLDAP Foundation.


PREBOOT EXECUTION ENVIRONMENT (PXE) SERVER

Copyright © 1996-1999 Intel Corporation. 


TFTP SERVER 

Copyright © 1983, 1993 

The Regents of the University of California.


OpenLDAP

Copyright 1999-2001 The OpenLDAP Foundation, Redwood City, California, USA. 

Portions Copyright © 1992-1996 Regents of the University of Michigan. 


OpenSSL License 

Copyright © 1998-2001 The OpenSSLProject. 


Original SSLeay License

Copyright © 1995-1998 Eric Young (eay@cryptsoft.com) 


2 



DHTML Calendar 
Copyright Mihai Bazon, 2002, 2003 

3 



Documentation Updates 

This guide’s title page contains the following identifying information: 

• Software Version number, which indicates the software version 

• Document release date, which changes each time the document is updated 

• Software release date, which indicates the release date of this version of the software 

To check for recent updates or to verify that you are using the most recent edition, visit the 
following URL: 

ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details. 

Table 1 indicates changes made to this document since the last released edition. 

Table 1 Document Changes 

Chapter Release Revision 

All 5.00 Changed all Radia names to new Configuration Management 
(CM) Software brand names 

All 5.00 The HP OVCM Service Desk Adapter now runs under the service 
name:   
httpd-servicedeskadapter. 

Chapter 2 5.00 New default installation paths for the Service Desk Adapter 
components: 

The Admin component installs to: C:\Program Files\Hewlett-
Packard\CM\CMSD\Admin 

The Server component installs to: C:\Program Files\Hewlett-
Packard\CM\CMSD\ 
Server 

Chapter 2 5.00 Page 22, Admin Workstation - Installation of CM Service Desk 
Adapter, added caution to modify the CM Smart Action Tool 
definition if the Admin component is not installed into the default 
path. 

Chapter 4 5.00 Page 55, Application – CM Smart Action Tool, You must change 
the Start In value for the hide.exe command to reflect the path 
where the CM-SDA Admin component was installed. 
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Chapter Release Revision 

Chapter 4 5.00 Page 61, Smart Action — CM Install Software, the definition of 
this Smart Action has changed. See the Parameters row in Table 
13. 

Chapter 5 5.00 Page 68, To create a Methods instance for RMP_RESOLVE, 
updated the ZMTHPRMS parameter value to indicate the new 
default port of the CM Portal: 3471.  

Table 2 Revisions during Early Adapter Releases 

Chapter Release Revision 

Chapter 2 EA 5 Page 23, Admin Workstation – Install Java Program: Added 
Service Desk 5.x task to install Java and related BAT program 
on the Admin Workstation. 

Chapter 6 EA 4 Page 81, Installing Multiple Software Services on a Device: 
added topic to explain how to install multiple software services 
on a device using multiple Work orders associated with a single 
Change order. 
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Support 

You can visit the HP Software support web site at: 

www.hp.com/managementsoftware/services 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.  

HP Software online software support provides customer self-solve capabilities. It provides a 
fast and efficient way to access interactive technical support tools needed to manage your 
business. As a valued support customer, you can benefit by using the support site to: 

• Search for knowledge documents of interest


• Submit and track support cases and enhancement requests 


• Download software patches 


• Manage support contracts 


• Look up HP support contacts 


• Review information about available services 


• Enter into discussions with other software customers 


• Research and register for software training


Most of the support areas require that you register as an HP Passport user and sign in.

Many also require a support contract.


To find more information about access levels, go to: 


www.hp.com/managementsoftware/access_level 

To register for an HP Passport ID, go to:  

www.managementsoftware.hp.com/passport-registration.html 
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1 Introduction 

Integration Overview 
The OpenView Service Desk (OVSD) and OpenView Configuration 
Management (OVCM) integration brings together the automated, desired-
state and policy-based software management capabilities of OVCM and the 
Service Desk ITIL-based processes for tracking incident, change and work 
orders on the hardware Configuration Items in your environment. 

Software Management Actions from the Service Desk Console 

The current implementation enables a Service Desk Administrator to select a 
single device and initiate an immediate OVCM job to deploy or otherwise 
manage software services on it. 

•	 Create and execute a Work order to install, verify, update, repair or 
uninstall a CM-managed software service on a single device. 

•	 Create and execute a Work order to synchronize all software that a device 
is entitled to given its existing policy; this action runs a Full CM-Notify 
job to bring the managed-software on the device to its desired-state. 

•	 Monitor and receive the job status of the software installation or other 
software activity being performed by CM (closed loop). 

•	 Access the CM Reporting Server interface and view a Device report. 

CM Software Lists Added to Service Desk Database 

This integration adds the Configuration Item (CI) Category of Software to the 
Service Desk CMDB. The integration obtains and loads the list of managed-
software services from those available in the OVCM Configuration Server 
Database to the Service Desk CMDB. The software list is updated regularly. 
Administrators also have the ability to manually execute the action: CM Get 
Software List. 

Software lists can be imported by type: ALL, PATCH, OS, and SOFTWARE. 
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Creation of CM-Managed Devices 

This integration allows you to create a managed device in OVCM for a 
Hardware CI already in your Service Desk CMDB. 

CM Software Actions - Jobs Status Updates 

This integration automatically sends status updates to the Service Desk 
Console as any of the software jobs (install, uninstall, update, verify or 
repair) are processed by the Configuration Manager. Any change is 
automatically reflected in the corresponding Service Desk Work order. 

CM Reporting Server 

This integration provides a Device-level report that can be accessed directly 
from the Service Desk console using the action CM Reporting Server. 

The Configuration Management and Service Desk 
Integrated Environment 

The Configuration Management environment includes the following required 
and optional products and components at Version 5.0 or above: 

•	 CM Agents for Application Manager or Application Self-service Manager 
with the CM Portal Agent installed on them. 

•	 CM Configuration Server with a co-located CM Messaging Server 

•	 CM Portal, enabled with Web Services 

•	 CM Reporting Server (optional for Reporting Server) 

The Service Desk environment includes the following required and optional 
components: 

•	 Service Desk 4.5 or 5.0 Server and Database (CMDB) 

•	 HP OVCM Service Desk Adapter (httpd-servicedeskadapter) running 
on the Server and Admin  

•	 Service Desk 4.5 Client (Admin) Workstations, also running the CM 
Service Desk Adapter (httpd-servicedeskadapter) 
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Terminology 
Become familiar with the following terms used throughout this guide. 

Admin 

The term Admin is used in this guide to refer to the HP OpenView Service 
Desk Client Console, also called the Admin Workstation. The term Admin 
has been adopted to distinguish it from the CM agents installed on target 
devices in your infrastructure. 

agent 

An agent refers to the Configuration Manager agent applications installed on 
target devices. Agents include Application Manager, Application Self-service 
Manager, CM Patch Manager, CM Inventory Manager, as well as others. 

CI 

CI is used to refer to a Configuration Item (CI) in the HP OpenView Service 
Desk CMDB. 

CM-SDA 

CM-SDA refers to the Configuration Management Service Desk Adapter 
(CM-SDA) components that are key components for the integration between 
the two products. There are CM-SDA components for the Service Desk 
Servers and Service Desk Admin Workstations in an integrated environment. 

OVCM 

OVCM refers to HP OpenView Configuration Management Software. 

Audience 
This guide is intended for administrators who will be installing, configuring, 
and using the Configuration Management actions available with the OVCM 
integration with HP OpenView Service Desk. 
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Chapter 1, Introduction 

This chapter gives an overview of the integration environment and features 
available when using the HP Service Desk with the HP OpenView 
Configuration Manager with the Service Desk Adapter. 

Chapter 2, Installation 

This chapter provides instructions on how to install the Service Desk Adapter 
components in your Service Desk 4.5 or 5.x environment. 

Chapter 3, Service Desk 4.5 Configuration 

This chapter provides instructions on how to configure the Service Desk 4.5 
environment for the integration with OVCM. 

Chapter 4, Service Desk 5.x Configuration 

This chapter provides instructions on how to configure the Service Desk 5.0 
or greater environment for the integration with OVCM. 

Chapter 5, CM Software Environment Configuration 

This chapter explains how to configure policy for specific actions that are 
available with this integration with Service Desk. 

Chapter 6, Using the CM Smart Actions 

This chapter describes how to use the CM Smart Actions from the Service 
Desk console. The software management actions are launched from a Work 
order for a single hardware CI device. 

Appendix A, Service Desk Object Updates and Command Line Utility 

This chapter contains reference information on the Service Desk Object 
Updates and the Command Line Utility. 

Appendix B, Product Name Changes 

If you have used Radia in the past, and are not yet familiar with the newly 
rebranded HP terms and product names, this appendix contains a list of old 
and new names. 
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2 Installation 

This chapter reviews the contents of the integration solution, the required 
pre-installation states of your Service Desk and Configuration Management 
software environments, and how to install the CMSD Integration software. 
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Contents of the Integration Solution 
The Integration pack consists of a directory that contains the following files: 

•	 CM Service Desk Adapter – Server Install 

•	 CM Service Desk Adapter – Admin Install 

•	 Java program and batch file needed for Service Desk 4.5 and 5.x Admin 
Consoles (version-specific) 

•	 Customization files for Service Desk 4.5 and 5.0 (version-specific) 

—	 CM_config_data_custom_fields_SDnn.xml 

—	 CM_config_data_SDnn.xml 

Pre-Installation Assumptions 

OV Service Desk 4.5 or 5.x Environment 

•	 Before proceeding with the integration, you should have an OpenView 
Service Desk for Windows version 4.5 or 5.x environment installed, 
configured and operational. Refer to the HP OpenView Service Desk 
Installation Guide for the appropriate version of your Service Desk 
environment. 

•	 Use the classic method to install the Service Desk clients (also known as 
Service Desk Admin Workstations) that are to be configured for OV 
Configuration Management (OVCM) actions. The integration with OVCM 
does not currently support Service Desk Admin Workstations that were 
installed using Java WebStart. 

Service Desk 4.5 Installation Prerequisites 

•	 Windows must be installed with the latest patches and must be running. 

•	 Server Desk Application Server for the CMSD Integration 
Both Service Desk and the Service Event program must be installed and 
running on one Application Server that will run the CMSD integration 
software. In addition, the HTTP protocol must be enabled in Server 
Settings. 
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—	 For details on installing Service Desk on an Application Server, refer 
to Chapters 2 and 3 of the HP OpenView Service Desk (Service Desk) 
4.5 Installation Guide. 

—	 For details on installing the Service Event program, refer to the 
Installation Integrations chapter in the Service Desk 4.5 Installation 
Guide. On a Windows platform, Service Event is installed using the 
setup program on the HP OpenView Service Desk CD-ROM and 
making the following selections:  

Install service desk → Integrations Menu → Service Event 

•	 Service Desk Clients 
All Service Desk Clients (Admin Workstations) that need to be capable of 
running the CMSD integration actions must have the Service Desk Client 
and the Service Event programs installed and running on them. 

—	 For details on installing Service Desk Client, refer to Chapters 2 and 
6 of the Service Desk 4.5 Installation Guide. 

—	 For details on installing the Service Event program, refer to the 
Installation Integrations chapter in the Service Desk 4.5 Installation 
Guide. On a Windows platform, Service Event is installed using the 
setup program on the HP OpenView Service Desk CD-ROM by 
making the following sequential selections: 

Install service desk → Integrations Menu → Service Event 

Service Desk 5.x Installation Prerequisites 

•	 Windows must be installed with the latest patches and must be running. 

•	 Server Desk Management Server for the CMDB Integration 
Both Service Desk and the Object Loader program must be installed and 
running on one Management Server that will run the CMSD integration 
software. In addition, the HTTP protocol must be enabled in Server 
Settings. 

—	 For details on installing Service Desk on a Management Server, refer 
to Chapters 2 and 3 of the appropriate Service Desk 5.x Installation 
Guide. 

—	 For details on installing the Service Desk Object Loader, refer to 
Chapter 9 of the appropriate Service Desk 5.x Installation Guide. 

Prior to Service Desk 5.x, the Object Loader was called the 
Service Event program. 
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•	 Service Desk Clients 
All Service Desk Clients, also known as Admin Workstations, that need 
to be capable of running the CMSD integration actions must have the 
Service Desk Client and Object Loader programs installed and running 
on them. 

These GUI clients must be installed using the classic install, and 
cannot be installed using Java Web Start. 

—	 For details on installing Service Desk Client, refer to Chapters 2 and 
4 of the Service Desk 5.x Installation Guide. 

—	 For details on installing the Service Desk Object Loader, refer to 
Chapter 9 of the Service Desk 5.x Installation Guide. 

OV Configuration Management Environment 

Before proceeding with the integration, you should have an OpenView 
Configuration Management Software environment, version 4.2 or above, fully 
installed, configured, and operational. The expected starting point of your 
Configuration Management environment is discussed below. 

•	 Infrastructure Components: The required components that are needed 
to support the integrated environment with Service Desk include the 
following: 

—	 Configuration Server and database delivered with v 5.0 or above 

—	 Messaging Server v 5.0 or above 

—	 CM Portal v 5.0 or above 

—	 Reporting Server v 5.0 or above (Optional) 
Supports access to The Device Details Reports from the Service Desk 
console. 

•	 CM agent: CM Application Manager, CM Application Self-service 
Manager and CM Inventory Manager agents delivered with CM v 5.0 are 
supported with this integration. 

This version of the integration does not support an OV Client 
Configuration Manager (CCM) environment. 

•	 CM Infrastructure and Agent Configuration: 

—	 Messaging Server must be configured to post CM agent events to the 
CM Portal. Optionally, if you are using CM Inventory Manager 
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agents or the CM Reporting Server, ensure the CM Messaging Server 
is configured for those components as well. 

—	 You have packaged and published software to be managed through 
Service Desk to your Configuration Server. 

When you integrate Service Desk with a Configuration 
Management environment, the managed software (known as 
Software Services) in the Configuration Server database 
becomes the source for your Definitive Software Library 
(DSL) in the Service Desk CMDB. 

—	 You have installed CM agents and CM Portal Agents on the 
hardware devices in your network that are hardware device nodes in 
Service Desk. CM Agent devices can successfully connect to the 
Configuration Server.  

—	 The CM Portal Agent on the CM agent devices have reported the 
MAC address back to the CM Portal: this can be viewed from the 
Device's Properties page in the CM Portal. 

To install managed-software from Service Desk, the CM 
Portal must be able to contact the hardware device using 
the same MS API used to map a shared drive to a remote 
device. 

—	 Optionally, you have entitled CM agent devices to the appropriate 
software services through an external Policy store (such as an AD 
directory), or the Policy domain in the Configuration Server database. 

You have several choices as to how you want the software 
policy for a device to be resolved when a CM smart action is 
issued from Service Desk. For more information, see 
Configuring for Policy Resolution on page 68. 

—	 If you are using an existing external LDAP directory, such as AD, for 
your Policy store, you have configured the Configuration Server 
appropriately. For details, refer to the HP OpenView CM Policy 
Server Installation and Configuration Guide. 

This completes the discussion on the required starting environment of the OV 
Configuration Management v5 Environment. 

Installation 	 19 



Install the CM Service Desk Adapter Integration 
Software 

This topic discusses how to install the integration software on one Service 
Desk Management or Application Server and on every Service Desk Admin 
Console that is to support the CM integration actions.  

Before you start the install procedure, ensure you have the 
appropriate permissions. You need Administrator privileges to install 
the integration software 

Service Desk Server -- Installation of CM Service Desk Adapter 

Use the Configuration Management Service Desk Adapter (Server) 
Install program to install the HP OVCM Service Desk Adapter (httpd­
servicedeskadapter) service on your Service Desk Server. 

1	 Run setup.exe from the 
\Infrastructure\management_extensions\service_desk_adapter\ 
server folder of the extracted CM installation media. 

2	 Accept the License Agreement. 

3	 Enter or accept the location to which the CM Service Desk Adapter (CM­
SDA) Service will be installed. 

Default path is: C:\Program Files\Hewlett-Packard\CM\ 
CMSD\Server 

4	 Select the Service Desk Server Version: 5.0 or 4.5. Select 5.0 to support 
Service Desk 5.0 or 5.1. 

5	 Enter the path to your Service Desk Server. 

6	 Enter or accept the listening port for the CM-SDA Service (default is 
3467). 

20	 Chapter 2 



Starting and stopping the CM Service Desk Adapter service 

To start the CM Service Desk Adapter Service (httpd-servicedeskadapter) 

1	 If necessary, go to the Windows Services. For example, in Windows 2000 
Server, right-click the My Computer icon on your desktop. Then, go to 
Manage → Expand Services and Applications → Services. 

2	 Right-click the HP OVCM Service Desk Adapter (httpd­

servicedeskadapter) and select Start. 


To stop the CM Service Desk Adapter Service (httpd-servicedeskadapter) 

1	 If necessary, go to the Windows Services. For example, in Windows 2000 
Server, right-click the My Computer icon on your desktop. Then, go to 
Manage → Expand Services and Applications → Services. 

2	 Right-click the HP OVCM Service Desk Adapter (httpd­

servicedeskadapter) and select Stop.


Post-Install Configuration on Server 

Following installation, use a text editor to modify the configuration file 
cmsd.cfg, located in the \etc directory of where the CM-SDA was installed 
on the Service Desk Server. By default, this location is  
C:\Program Files\Hewlett-Packard\CM\CMSD\Server\etc. 

•	 CM Portal Account Credentials 
The wsUID and wsPID parameters in cmsd.cfg specify the User name 
and password, respectively, for accessing the CM Portal. By default, the 
values are set to the encrypted values for User Admin and the password 
secret, which are the default credentials for the CM Portal System 
Administrator. To change the credential values, edit the file and specify 
the user name or password. The credential values will be encrypted 
during transmission. 

•	 Automatic refresh period of the CM Software List 
The CM Get Software action is run every 10 minutes (600 seconds), by 
default, to update the CI software list on the Service Desk database with 
any new software items available as managed services through the CM 
Portal. To change the automatic refresh period, change the 
PERIODIC_INTERVAL 600 parameter value in cmsd.cfg. The value is 
specified in seconds.  
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The CM Get Software action for this EA release only adds 
software items to the CI Software list; it does not remove a CI 
software entry that was removed from the CM managed-software 
list. To fully synchronize the lists of available software, first 
select and delete all existing CI software entries manually, then 
run CM Get Software. If there are CI relations attached to the 
entries, you will be prompted to remove them also.  

Make sure to keep the CI for CMGETSOFTWARESERVICES, 
which is the required Search Code needed to run the action CM 
Get Software. 

Admin Workstation - Installation of CM Service Desk Adapter 

Run this install program on each Service Desk Admin Workstation that is to 
support the CM integration actions. 

1	 Run setup.exe from the 
\Infrastructure\management_infrastructure\service_desk_adap
ter\admin folder of the expanded CM installation media. 

2	 Accept the license agreement. 

3	 Enter or accept the location to which the HP OVCM Service Desk 
Adapter Service will be installed.  

Default path is:  
C:\Program Files\Hewlett-Packard\CM\CMSD\admin 

If you do not choose the default location, you must also modify 
the Start in path value for the CM Smart Action Tool after 
installation. For details, refer to CM Configuration Data 
Details on page 54. 

4	 Click the radio button for the Service Desk version you are using: Version 
4.5 or 5.0. 

Select 5.0 to support Service Desk 5.0 or 5.1. 

5	 Specify the Host name or IP Address of your Server Desk Management or 
Application Server that has the CMSD Adapter Service installed on it. 

6	 Define the listening port of the CMSD Adapter service. The default port 
is 3467. 
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Post-Install Steps on the Admin Workstation 

Following installation, use a text editor to modify the configuration file 
cmsd.cfg located in the \etc directory of where the CMSD adapter service 
was installed on the Admin workstation. 

•	 CM Portal Account Credentials 
A value in cmsd.cfg specifies the User ID and password credentials 
needed to access the CM Portal. By default, the credentials are set to the 
User Admin and the password secret, which are the default credentials 
for the CM Portal System Administrator. 

Admin Workstation – Install Java Program 

Service Desk Admin Workstations also require a Java program and related 
batch file to be installed on them. The Java program and related batch files 
are provided on the Integration pack; copy the appropriate ones for your 
Service Desk version level using the procedures that follow. 

To install the Java program on Service Desk Admin 4.5 Admin Workstations 

Use these procedures to install the Java program and batch file onto a 
Service Desk 4.5 Workstation. 

1	 Navigate to the \media\javaprograms directory of where the CMSD 
Adapter was installed. The default location is C:\Program
Files\Hewlett-Packard\CM\CMSD\admin\media\javaprograms). 

2	 Copy sdgetworkorderci.jar from the javaprograms directory to the 
\lib directory of where the Service Desk Admin (client) is installed. By 
default, this target location is:  

C:\Program Files\Hewlett Packard\OpenView\service desk 4.5\ 
client\lib 

3	 Copy the sd_getworkorderci.bat file from the \javaprograms 
directory to the \bin directory of where the Admin (client) is installed. 
By default, this target location is: 

C:\Program Files\Hewlett Packard\OpenView\service desk 4.5\ 
client\bin 

Repeat the above steps on each Admin Workstation that will be used for CM 
actions. 
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To install the Java program on Service Desk Admin 5.x Admin Workstations 

Use these procedures to install the required Java program and batch file onto 
each Service Desk 5.x Admin Workstation that is to be used for CM actions. 

1	 Navigate to the \media\javaprograms directory of where the CMSD 
Adapter was installed. The default location is below. 

C:\ Program Files\Hewlett-Packard\CM

\CMSD\admin\media\javaprograms 


2	 Copy the file named below: 

\javaprograms\sd-getworkorderci.jar 

to the HP OpenView \java directory on the Admin (client) machine. By 
default, this target location is:  

C:\Program Files\HP OpenView\java 

3	 For Service Desk 5.0 only, copy the batch file named below 

\javaprograms\OvSdgetworkorderci.bat 

to the HP OpenView \bin directory on the Admin (client) machine. By 
default, this target location is: 

C:\Program Files\HP OpenView\bin 

4	 For SD 5.1 only, navigate to the \sd5.1 subdirectory and copy the batch 
file named below:  

\javaprograms\sd5.1\OvSdgetworkorderci.bat 

to the HP OpenView \bin directory on the Admin (client) machine. By 
default, this target location is: 

C:\Program Files\HP OpenView\bin 

This completes the installation chapter topics. 
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3 Service Desk 4.5 Configuration 
If you are using Service Desk version 4.5, this chapter describes how to 
configure it to support the integration with OVCM. 
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Configuring Service Desk 4.5 

Overview of Tasks 

1 Create and modify the Service Event program configuration file. 

—	 Perform this task on the Service Desk Application Server. 

—	 Perform this task on every Service Desk Admin Workstation 
requiring access to the CM integration actions. 

2	 Create or Import custom fields 

—	 Create or Import Custom fields. 

–	 Use ACES to import custom fields if you have a clean, non-
customized database. 

–	 Import the custom fields manually if you already have custom 
fields in your database. 

—	 Create values for "CM service type." 

—	 Place the custom fields on the forms. 

3	 Import the configuration data using ACES. 

— Import the configuration data for the CM integration. 

4	 HP OpenView Service Desk manual configuration 

—	 Create the special CI with the Search Code 
CMGETSOFTWARESERVICES. 

—	 Assign Roles to Accounts 

Task 1 Create and modify the Service Event Configuration File 

Perform this task on the Service Desk Application Server and on every 
Service Desk Admin Workstation (Service Desk Client) requiring access to 
the CM integration actions. 

The password specified in the Account parameter of the Service 
Event configuration file must match the password of the Account 
named "cm" that is specifically created for this integration. 
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To create and modify the Service Event configuration file for a CM Integration 

LOGFILE=C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\event\log\sd_event.log 

1 Create a Service Event configuration file named cmsd_event_.ini from 
a copy of the default Service Desk Event configuration file, 
sd_event.ini. Place the new cmsd_event.ini file in the target location 
named below. 

Copy this source file: 

C:\Program Files\Hewlett-Packard\OpenView\
service desk 4.5\event\bin\sd_event.ini 

To this target location and name: 

C:\Program Files\Hewlett-Packard\OpenView\
service desk 4.5\event\conf\cmsd_event.ini 

2 After creating the cmsd_event.ini file in the \conf directory, open it using 
a text editor. The unmodified contents of cmsd_event.ini is shown 
below: 

[SD_EVENT] 

ERROR_LOGFILE=C:\Program Files\Hewlett-Packard\OpenView\service desk 4.5\event\log
\sd_event_error.log

ACCOUNT=myusername/mypassword 
SERVER=localhost 
PORT=30980 
MAPPING=external_event 
CLASSNAME=incident 
MODUS=insert 

3	 Rename the section heading to [CMSD_EVENT]. 

4	 Rename the prefixes for the LOGFILE and ERROR LOGFILE names 
from sd_event to cmsd_event. 

5	 Modify the values for ACCOUNT, SERVER and PORT to reflect your Service 
Desk application server environment: 

a	 For the ACCOUNT value, type the name of the account created for this 
service event integration and password. Use the format 
account_name/password. By default, the installation integration 
program creates the account cm with the password openview, which 
would be specified as: 

ACCOUNT=cm/openview 
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b For the SERVER value, replace localhost with the name of your 
Server Desk application server. Use the fully-qualified domain name 
format of hostname.domain.com. For example: 

SERVER=mysdserver.mydomain.com 

c For the PORT value, specify the port number used by the Service Desk 
Service Event program to communicate with the Object Server. The 
default value is 30980. 

The entries for MAPPING, CLASSNAME, and MODUS are 
irrelevant because they are overruled by the Service Event 
program command line. 

6	 Close the file and save the changes. 

Task 2 Create or Import the Custom Fields 

Perform this task on the Application Server to create the custom fields 
needed for the CM integration and place them on the forms. 

How to create the custom fields 

•	 If you have a clean database, you can import the custom data using ACES 
and the Configuration Exchange data file 
CM_config_data_custom_fields_SD45.xml. For details, see Import 
Custom Fields using ACES, below. 

•	 If you have custom fields in your database, you must manually create the 
custom fields. For details, see Manual Creation of Custom Fields on page 
29. 

How to place the custom fields on the form 

After the custom fields exist, place them on the forms. For details, see Placing 
the Custom Fields on the Forms on page 30. 

Import Custom Fields using ACES 

You can import custom fields using ACES if you have a clean database. A 
clean database is one which does not already contain any custom fields. 

For details on using ACES, refer to Chapter 12, Administrator 
Console Export Settings, in the Service Desk 4.5 Administrator's 
Guide. 
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To import custom fields using ACES 

1 On the Tools menu, click System to open the Administrator Console. 

2 From the Administrator Console, click File → Aces → Aces Import 
Wizard. 

3 On the first page of the Import Wizard, click Next. 

4 Use the Import File Selection page to select the required XML file for 
import: CM_config_data_custom_fields_SD45.xml. 

a Click Add. 

b Browse to the \ImportData directory of where the CMSD Adapter was 
installed. The default location is C:\Program Files\
Hewlett-Packard\CM\CMSD\admin\importdata. 

c Select the file CM_config_data_custom_fields_SD45.xml. 

d Confirm or specify the name of the log file, and its location by means 
of the browse button. 

e Ensure Overwrite existing items is unchecked. 

f Click Next. 

5 Click Start Import. 

Progress indicator bars may not appear immediately; they may 
take a minute or more after Start Import is clicked to appear. 

6 When the import is complete, you have the option to view the log file, 
restart the wizard, or close the wizard. You can close the wizard. 

After an import is complete, click F5 (Refresh) to make the 
newly imported settings visible. 

Manual Creation of Custom Fields 

If your Service Desk database has custom fields in it, perform this task to 
manually create the custom fields needed for the CM integration. 

Table 3 summarizes the custom fields that need to be defined and configured. 
Details on how to configure each field follow. 
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Table 3 Custom Fields for the CMSD Integration 

Category Configuration Path Define Custom Field 

Configuration Item 
Custom Fields 

OV Configuration → Data → Custom 
Fields → Configuration Item 

MAC address (Text 40) 
CMDN (Text 255) 
CM service type (Code) 
See Table 6 on page 46. 

Work order 
Custom Fields 

OV Configuration → Data → Custom 
Fields → Work order 

CM job status (Text 40) 
See Table 7 on page 46. 

Code table 
CM Service Type 

OV Configuration → Data → Codes → 
Configuration Item → CM service type 

Add codes for: 
ALL 
SOFTWARE 
OS 
PATCH 

Placing the Custom Fields on the Forms 

Put the custom fields for MAC address, CMDN and CM service type on the 
Configuration Item form. The choice of where to put the custom fields is up to 
you; Figure 1 on page 31 gives sample locations for adding the fields to the 
Configuration Item form. 
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c 

Figure 1 CI Form with Custom Fields added 

Legend 

a Sample MAC address field added below IP Address 

b Sample OVCM page added (use Page → Add Page) 

Sample CMDN field located on OVCM page 

d Sample CM service type located on OVCM page 

To obtain more information on using the forms designer tools, view 
the Forms Designer topics in the Administrator Console online help. 

To add the custom fields to the Configuration Item form 

1 On the Tools menu, click System to open the Administrator Console. 
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2	 On the left pane, navigate to Presentation → Forms → Configuration 
Item. 

3	 On the right pane, double-click Configuration Item, as indicated in the 
following figure. 

This opens the Configuration Item forms designer. 

4	 Select the custom field for MAC Address and drag it to a desired location 
on the Configuration Item form. As you drag a field onto the form, red 
arrows indicate a target location. Our sample form puts the MAC Address 
field below the IP Address field. 

5	 Add a tabbed page named OVCM to the form, and place CMDN, and CM 
Service Type from the Attributes box on this page. 

a	 To add a tabbed page, select the Page menu in the Forms Designer 
dialog box, and select Add Page. 

b	 Give the page the name OVCM. 

c	 Place the fields for CMDN and CM Service Type on this page of the 
form. 

6	 Save and close the Forms Designer for Configuration Item with the 
added fields. 

To add the custom field to the Work order form 

1 On the Tools menu, click System to open the Administrator Console. 

2 On the left pane, navigate to Presentation → Forms → Work order. 

3 On the right pane, double-click Work order. 
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This opens the Work order Forms Designer. 

4	 From the Attributes box on the left, click CM job status and drag it to the 
desired location on the Work order form. For example, you can place it 
directly below the Status field. 

5 Save and Close the Work order form with the new CM job status field. 

This completes the addition of the custom fields to the forms. 

Task 3 Import the Configuration Data using ACES 

Perform this task on the Application Server after the import or manual 
creation of the custom fields, as discussed in Task 2. 

Use ACES to import the configuration data from the provided Configuration 
Exchange data file, CM_config_data_SD45.xml, into Service Desk. Table 4 
on page 34 lists the objects imported from this file. 

For details on using ACES, refer to Chapter 12, Administrator 
Console Export Settings, in the Service Desk 4.5 Administrator's 
Guide. 

To import configuration data using ACES 

1	 On the Tools menu, click System to open the Administrator Console. 

2	 From the Administrator Console, click File → Aces → Aces Import 
Wizard. 

3	 On the first page of the Import Wizard, click Next. 

4	 Use the Import File Selection page to select the required XML file for 
import: CM_config_data_SD45.xml. 
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a	 Click Add. 

b	 Browse to the \ImportData directory of where the CMSD Adapter was 
installed. The default location is C:\Program Files\
Hewlett-Packard\CM\CMSD\Admin\ImportData. 

c	 Select the file CM_config_data_SD45.xml. 

d	 Confirm or specify the name of the log file, and its location by means 
of the browse button. 

e	 Ensure Overwrite existing items is unchecked. 

f	 Click Next. 

5	 Click Start Import. 

Progress indicator bars may not appear immediately; they may 
take a minute or so after Start Import is clicked to appear. 

6	 When the import is complete, you have the option to view the log file, 
restart the wizard, or close the wizard. Close the wizard. 

After an import is complete, click F5 (Refresh) to make the 
newly imported settings visible. 

Configuration Data Imported for the CMSD Integration 

Table 4 identifies the configuration data imported for the CMSD integration. 
Use the page references in the Objects column to locate additional 
information on that object. 

Table 4 SD 4.5 Configuration Data Imported for the CMSD Integration 

Category Administrator Console 
Configuration Path 

Objects 

Applications Business Logic → Application CM Smart Action Tool, see page 34 

Smart Actions Business Logic → Actions → 
Smart Action → Configuration 
Item 

CM get software list, see page 56  
CM create device, see page 59 
CM reporting server 
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Category Administrator Console 
Configuration Path 

Objects 

Smart Actions Business Logic → Actions → 
Smart Action → Work order 

CM synchronize software 
CM repair software 
CM verify software 
CM update software 

Smart Actions 
(Requires a 
Separate Role) 

Business Logic → Actions → 
Smart Action → Work order 

CM install software, on page 61 
CM uninstall software 

Templates Data → Templates For Configuration Item, "CM 
Hardware and Software" 
For Work order, "Cm job" 
For CI relation, "Cm relation" 

Users & 
Security 

Security → Access Application Account for "CM 
Configuration Manager" with 
credentials set to cm/openview  
Role for "CM Configuration 
Manager" 
Role for "CM Configuration 
Manager – install/uninstall" 

Task 4 Create a CI with the Search Code CMGETSOFTWARESERVICES 

This task creates a Configuration Item with the Search Code 
CMGETSOFTWARESERVICES to support the action CM Get software. 

To create the CI named CMGETSOFTWARESERVICES 

1	 From the HP Service Desk Console menus, select File → New → 
Configuration Item. 

The Choose Template dialog box opens. 
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2 Choose the default template for the category CI and click OK. 

3 Specify the fields listed below on the New – Configuration Item form. 

a In the Search Code field, type CMGETSOFTWARESERVICES. 

b In the Name 1 field, type CM Get Software Services. 

c In the System field, select Production or Test, as appropriate. 

d Set the Category field to Software / System / Management using the 
Quick Find dialog box. 

To easily select the Management category, first click the icon to 
open the Quick Find – CI Category dialog box, switch the view to 
CI Category (Table) and type MAN in the Look for field. Select the 
Management category and click OK. 

e Save and close the new Configuration Item. 
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4	 From the Service Desk Console, select the CMDB group item and click 
the Configuration Item icon to display the list of Configuration Items. 

5	 Press F5 to refresh the list. CMGETSOFTWARESERVICES should be 
listed alphabetically. 

This Search code needs to be selected in order to run the action CM get 
software. 

Task 5 Assign Roles to Accounts 

Two roles are provided with the CM integration. You must associate Accounts 
with one or both of the roles to enable the CM smart actions for a user. 

•	 The main role, CM Configuration Manager, enables nearly all of the CM 
smart actions. Smart actions for this role are all operational in that they 
do not affect changes to existing software entitlements (policy) for the 
devices in your CM environment. 

•	 The second role, CM Configuration Manager – install/uninstall, enables 
smart actions that do change the software entitlements on a targeted 
device. These include CM install software and CM uninstall software. If 
you enable this role, you also need to configure policy methods in your 
CM environment appropriately, as discussed in Configuring for Policy 
Resolution on page 68. 

Assign one or both roles to a person's account to enable or disable the related 
CM smart actions for that person. 

The 'cm' account created with this integration is assigned both roles, 
by default. If you do not want to use the install and uninstall actions 
in your environment, remove the assignment of the "CM 
Configuration Manager – install/uninstall" role from the "cm" 
account. 

Table 3 below identifies the roles and the related smart actions associated 
with each role. 
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Table 5 Roles to Assign for CM Smart Actions 

Role 

CM Configuration Manager – 
install/uninstall 

CM Configuration Manager 

Related Smart Actions 

Work order: 
CM install software 

    CM uninstall software 

Work Order:
    CM synchronize software 
    CM repair software
    CM reporting server
    CM update software
    CM verify software 
Configuration Item: 

 CM get device
 CM get software list 

To assign or modify CM-related role assignments for an account 

1	 First open the account for which you want to assign or change CM roles. 

—	 On the Tools menu, click System to open the Administrator Console. 

—	 From the Administrator Console, navigate to Security → Access → 
Account, and choose the account that needs access to CM smart 
actions. 

2	 Click the tab for Roles. 

3	 Check or uncheck the appropriate CM-related role(s) to enable or disable 
the associated smart actions for the account.  

The following figure shows an example of enabling an account for the role 
that permits the use of "CM install software" and "CM uninstall 
software". 
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4 Click Save and Close to save the changes to the account. 

This ends the configuration topics for integrating the CM Adapter for Service 
Desk 5.x. 

Before using the integration smart actions, ensure you configure the 
appropriate policy resolution within your CM environment. See 
Configuring for Policy Resolution on page on page 68. 
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4 Service Desk 5.x Configuration 
If you are using Service Desk version 5.0 or 5.1, this chapter describes how to 
configure it to support the integration with OVCM. 
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Configuring Service Desk 5.x 

Overview of Tasks 

Configuring the CMSD integration on Service Desk 5.x is almost the 
same as configuring it on Service Desk 4.0. The main differences are 
the use of the Object Loader instead of the ACES import/export tool, 
and the addition of Filters and Filter Groups in Service Desk 5.x, 
which are not available in Service Desk 4.0.  

1	 Create and modify the Object Loader configuration file. 

—	 Perform this task on the Service Desk Management Server. 

—	 Perform this task on every Service Desk Admin Workstation 
requiring access to the CM integration actions. 

2	 Create the custom fields and place them on the forms. 

—	 Create or Import Custom fields 

–	 Use the Object Loader import custom fields if you have a clean, 
non-customized database 

–	 Import the custom fields manually if you already have custom 
fields in your database 

—	 Create values for "CM service type" 

—	 Place the custom fields on the forms. 

3 Import the Customization Data using Configuration Exchange. 

—	 Perform this task on the Service Desk Management Server only. 

—	 Customization data for Service Desk 5.x includes Filters and Filter 
Groups, which are not available for Service Desk 4.5. Filters are not 
required, however, they support the easy transfer of the configuration 
data between test and production systems. 

4	 OV Console manual configuration. 

— Create the CI to support the action "CM Get Software List" 

5	 Assign Roles to Accounts 

—	 There are two roles for the CM smart tasks. Assign one or both roles 
to accounts based on which smart actions are to be enabled. 
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Task 1 Create and modify the Object Loader Configuration File 

Perform this task on the Service Desk Management Server and on every 
Service Desk Admin Workstation (Service Desk Client) requiring access to 
the CM integration actions. 

The password specified in the Account parameter of the Object 
Loader configuration file must match the password of the Account 
named "cm" that is specifically created for this integration. If you 
change the default password on the Account, also change its entry in 
the configuration file. 

To create and modify the Object Loader configuration file for an OVCM 
Integration 

1	 Create an Object Loader configuration file named cmLoadObject.conf
from a copy of the default Object Loader configuration file, 
OvObsLoadObject.conf. Place the new cmLoadObject.conf file in the 
target location named below. 

Copy this source file: 

C:\Program Files\Hewlett-Packard\OpenView\
service desk 4.5\event\bin\sd_event.ini 

To this target location and name: 

C:\Program Files\HP OpenView\data\conf\obs\loadobject\
cmLoadObject.conf 

2	 Open the Object Loader configuration file from Step 1 using a text editor. 
The unmodified contents is shown below: 

[OVOBSLOADOBJECT]
LOGFILE=C:\Program Files\HP OpenView\data\log\OvObsLoadObject.lo
ERROR_LOGFILE=C:\Program Files\HP OpenView\data\log\OvObsLoadObject_error.log
ACCOUNT=myusername/mypassword 
SERVER=mysdserver.mydomain.com 
PORT=30980 
MAPPING=mymapping
CLASSNAME=myclassname 
MODUS=insert 

3	 Rename the section heading to [CMLOADOBJECT]. 

4	 Rename the LOGFILE and ERROR LOGFILE filename prefixes from 
OvObsLoadObject to cmLoadObject. 
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5	 Modify the values for ACCOUNT, SERVER and PORT to reflect your Service 
Desk management server environment: 

a	 For the ACCOUNT value, type the name of the account created for this 
service event integration and password. Use the format 
account_name/password. By default, the installation integration 
program creates the account cm with the password openview, which 
would be specified as: 

ACCOUNT=cm/openview 

b	 For the SERVER value, replace localhost with the name of your 
Server Desk management server. Use the format 
hostname.mydomain.com. For example: 

SERVER=mysdserver.mydomain.com 

c	 For the PORT value, specify the port number used by the Service Desk 
Object Loader program to communicate with the Object Server. The 
default value is 30980. 

The entries for MAPPING, CLASSNAME, and MODUS are irrelevant 
because they are overruled by the Object Loader program command 
line. 

6	 Close the file and save the changes. 

Task 2 Create or Import the Custom Fields 

Perform the task on the Management Server to create the custom fields 
needed for the CM integration and place them on the forms. 

How to create the custom fields 

•	 If you have a clean database, you can import the custom data using the 
Object Loader and the Configuration Exchange data file 
CM_config_data_custom_fields_SD50.xml. For details, see Import 
Custom Fields using Configuration Exchange on page 45. 

•	 If you have custom fields in your database, you must manually create the 
custom fields. For details, see Manual Creation of Custom Fields on page 
45. 

How to place the custom fields on the form 

After the custom fields exist, place them on the forms. For details, see Placing 
the Custom Fields on the Forms on page 30. 
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Import Custom Fields using Configuration Exchange 

You can import the custom fields using Configuration Exchange if you have a 
clean database. A clean database is one which does not already contain any 
custom fields. 

For details on using Configuration Exchange, refer to the Service Desk 
5.0 Administrator's Guide or online help. 

To import custom fields using Configuration Exchange 

1	 From the OpenView Console, select File → Configuration Exchange → 
Import.. 

The Configuration Exchange Import Wizard opens. 

2	 Follow the onscreen instructions and import the file 
CM_config_data_custom_fields_SD50.xml. 

—	 This file is found in the \ImportData directory of where the CMSD 
Adapter was installed. The default location is:  

C:\Program Files\Hewlett-Packard\CM 
\CMSD\Admin\ImportData 

—	 Ensure Overwrite existing items is unchecked. 

After an import is complete, click F5 (Refresh) to make the 
newly imported settings visible. 

Manual Creation of Custom Fields 

If your Service Desk database has custom fields in it, perform this task to 
manually create the custom fields needed for the CM integration. 

Create Configuration Item Custom Fields 

Three custom fields are imported for Configuration Item. Manually add and 
configure these custom fields if your database has existing custom fields. 

Access Path: OV Configuration → Data → Custom Fields → Configuration 
Item 
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Table 6 Configuration Item Custom Fields 

Custom Field Type Category to Enable 

MAC address Text 40 Categories related to Hardware 

CMDN Text 255 Categories related to Hardware 

CM service type Code 
See page 46 for 
codes to define. 

Software/Application/Management 
Software 

Add Codes for the CI CM service type 

After defining the custom field for CM service type, you must also manually 
define the codes for it. 

Access Path: OV Configuration → Data → Codes → Configuration Item → 
CM service type. 

Add code values for ALL, SOFTWARE, OS and PATCH. 

Create Work order custom field 

For Work order, one custom field is imported or must be added and 
configured. 

Access Path: OV Configuration → Data → Custom Fields → Work order 

Table 7 Work Order Custom Field 

Custom Field Type Category to Enable 

CM job status Text 40 All categories 

Placing the Custom Fields on the Forms 

Put the custom fields for MAC address, CMDN and CM service type on the 
Configuration Item form. The choice of where to put the custom fields is up to 
you; Figure 1 on page 31 gives sample locations for adding the fields to the 
Configuration Item form. 
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Figure 2 CI Form with Custom Fields Added 

Legend 

a Sample MAC address field added below IP Address 

b Sample OVCM page added (use Page → Add Page) 

c Sample CMDN field located on OVCM page 

d Sample CM service type located on OVCM page 

To obtain more information on using the forms designer tools, view 
the Forms Designer topics in the Administrator Console online help. 

To add the custom fields to the Configuration Item form 

1	 On the Tools menu, click System to open the Administrator Console. 

2	 On the left pane, navigate to Presentation → Forms → Configuration 
Item. 

3	 On the right pane, double-click Configuration Item, as indicated in the 
following figure. 
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This opens the Configuration Item forms designer. 

4	 Select the custom field for MAC Address and drag it to a desired location 
on the Configuration Item form. As you drag a field onto the form, red 
arrows indicate a target location. Our sample form puts the MAC Address 
field below the IP Address field. 

5	 Add a tabbed page named OVCM to the form, and place CMDN, and CM 
Service Type from the Attributes box on this page. 

a	 To add a tabbed page, select the Page menu in the Forms Designer 
dialog box, and select Add Page. 

b	 Give the page the name OVCM. 

c	 Place the fields for CMDN and CM Service Type on this page of the 
form. 

6	 Save and close the Forms Designer for Configuration Item with the 
added fields. 

To add the custom field to the Work order form 

1	 From the OpenView Console, on the Tools menu, click System to open 
the Administrator Console. 

2	 On the left pane, navigate to Presentation → Forms → Work order. 

3	 On the right pane, double-click Work order. 

This opens the Work order Forms Designer. 
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4	 From the Attributes box on the left, click CM job status and drag it to the 
desired location on the Work order form. For example, you can place it 
directly below the Status field. 

5	 Save and Close the Work order form with the new CM job status field. 

This completes the addition of the custom fields to the forms. 

Task 3 Import the Configuration Data using Configuration Exchange 

Perform this task on the Management Server after the import or manual 
creation of the custom fields, as discussed in Task 2. 

Use Configuration Exchange to import the configuration data from the 
provided Configuration Exchange data file, CM_config_data_SD50.xml, into 
Service Desk. Table 8 below lists the objects imported from this file. 

For details on using Configuration Exchange, refer to the Service Desk 
5.0 Administrator's Guide or online help. 

To import configuration data using Configuration Exchange 

1	 From the OpenView Console, select File → Configuration Exchange → 
Import. 

The Configuration Exchange Import Wizard opens. 

2	 Follow the onscreen instructions and import the file 
CM_config_data_SD50.xml. 

—	 This file is in the \ImportData directory of where the CMSD Adapter 
was installed. The default location is:  

C:\Program Files\Hewlett-Packard\ 
CM\CMSD\Admin\ImportData 

— Ensure Overwrite existing items is unchecked. 

After an import is complete, click F5 (Refresh) to make the 
newly imported settings visible. 

Table 8  Service Desk 5.x Configuration Data for the CMSD Integration 

Category Configuration Path Objects 

Applications OV Configuration → Action & Rules 
→ Applications 

CM Smart Action Tool 
See page 55. 
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Category Configuration Path Objects 

Smart Action OV Configuration → Action & Rules 
→ Actions → Smart Action → 
Configuration Item 

CM get software list 
See page 56. 
CM create device 
See page 59. 

Smart Action OV Configuration → Action & Rules 
→ Actions → Smart Action → Work 
order 

CM repair software 
CM synchronize software 
CM update software 
CM verify software 

Smart Action 
(Separate Role 
assignment) 

OV Configuration → Action & Rules 
→ Actions → Smart Action → Work 
order 

CM install software 
See page on page 61. 
CM uninstall software 

Templates OV Configuration → Data → 
Templates 

For Configuration Item, "CM 
Hardware and Software" 
For Work order, "Cm job" 
For CI relation, "Cm relation" 

Users & 
Security 

OV Configuration → Security → 
Access 

Application Account for "CM 
Configuration Manager" with 
credentials set to cm/openview 
Role for "CM Configuration 
Manager" 
Role for "CM Configuration 
Manager – install/uninstall 

Filters OV Configuration → Data → 
Configuration Exchange → Filters 

For "CM get software list", see 
page 57. 
For "CM create device", see 
page 60. 
For "CM install software, see 
page 63. 

Filter Groups OV Configuration → Data → 
Configuration Exchange → Filter 
Groups 

CM_config_data_custom_fields 
CM_config_data 
See page 64. 
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Task 4 Create a CI with the Search Code CMGETSOFTWARESERVICES 

This task creates a Configuration Item with the Search Code 
CMGETSOFTWARESERVICES to support the action CM Get software. 

To create the CI named CMGETSOFTWARESERVICES 

1	 From the OpenView Console, select File → New → Configuration Item. 

The Choose Template dialog opens. 

2	 Choose the default template for the category CI and click OK. 

3	 Specify the fields listed below on the New – Configuration Item form. 

a	 In the Search Code field, type CMGETSOFTWARESERVICES. 

b	 In the Name 1 field, type CM Get Software Services. 

c In the System field, select Production or Test, as appropriate. 

d	 Set the Category field to Software / System / Management using the 
Quick Find dialog box. 

To easily select the Management category, first click the icon to 
open the Quick Find – CI Category dialog box, switch the view to 
CI Category (Table) and type MAN in the Look for field. Select the 
Management category and click OK. 
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e	 Save and close the new Configuration Item. 

4	 From the Service Desk Console, select the CMDB group item and click 
the Configuration Item icon to display the list of Configuration Items. 

5	 Press F5 to refresh the list. CMGETSOFTWARESERVICES should be 
listed alphabetically. 

This Search code needs to be selected in order to run the action CM get 
software. 

Task 5 Assign Roles to Accounts 

Two roles are provided with the CM integration. You must associate Accounts 
with one or both of the roles to enable the CM smart actions for a user. 

•	 The main role, CM Configuration Manager, enables nearly all of the CM 
smart actions. Smart actions for this role are all operational in that they 
do not affect changes to existing software entitlements on the devices. 

•	 The second role, CM Configuration Manager – install/uninstall, enables 
smart actions that do change the software entitlements on a targeted 
device. These include CM install software and CM uninstall software. If 
you enable this role, you also need to configure policy methods on the CM 
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Configuration Server to support the smart actions, as discussed in 
Configuring for Policy Resolution on page 68. 

Assign one or both roles to a person's account to enable or disable the related 

CM smart actions for that person. 


The 'cm' account created with this integration is assigned both roles,

by default. If you do not want to use the install and uninstall actions 

in your environment, remove the assignment of the "CM 

Configuration Manager – install/uninstall" role from the "cm" 

account. 


Table 3 below identifies the roles and the related smart actions associated 
with each role. 

Table 9 Roles to Assign for CM Smart Actions 

Role 

CM Configuration Manager – 
install/uninstall 

CM Configuration Manager 

Related Smart Actions 

Work order: 
CM install software 

    CM uninstall software 

Work Order:
    CM synchronize software 
    CM repair software
    CM reporting server
    CM update software
    CM verify software 
Configuration Item: 

 CM get device
 CM get software list 

To assign or modify CM-related role assignments for an account 

1	 First open the account for which you want to assign or change CM roles. 
From the OpenView console, go to Users and Security → Access → 
Application Account, and choose the account that needs access to one or 
both roles for CM smart actions. 

2	 Click the tab for Roles. 

3	 Check or uncheck the appropriate CM-related role to enable or disable 
the associated smart actions for the account. 
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The following figure shows an example of enabling an account for the role 
that permits the use of "CM install software" and "CM uninstall 
software". 

4 Click Save and Close to save the changes to the account. 

This ends the configuration topics for integrating the CM Adapter for Service 
Desk 5.x. 

Before using the integration smart actions, ensure you configure the 
appropriate policy resolution within your CM environment. See 
Configuring for Policy Resolution on page on page 68. 

CM Configuration Data Details 
This topic summarizes most of the data objects and how they are configured 
for use by the CM integration smart actions. 

You must change the Start In path of the CM Smart Action Tool 
application, discussed below, to identify the exact path where the 
CM-SDA Admin component is installed. 
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Application – CM Smart Action Tool 

The Application "CM Smart Action Tool" is used by all Smart Actions of the 
CMSD integration. It calls nvdkit.exe as a parameter.   

Set the Start In value to match the exact path of where the CM-SDA Admin 
component was installed. 

Access Path: OV Configuration → Action & Rules → Applications 

Table 10 Configuration values for Application: CM Smart Action 
Tool 

Field 

Name 

Command line 

Start in 

Description 

Value 

CM SmartAction Tool 

hide.exe 

Default: 
C:\Program Files\Hewlett-Packard\
CM\CMSD\Admin 

Change this value to reflect the exact path where the 
CM-SDA Admin component was installed. 

Invoke a CM Smart Action 
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Smart Action — CM Get Software List 

The Smart Action "CM Get Software List" obtains a list of software services 
available in the Configuration Management DSL. The command needs one 
parameter: the Service Type, whose default values are ALL, SOFTWARE, OS 
or PATCH. The Service Type is stored in the field "CM service type" of the 
Configuration Item. 

Access Path: OV Configuration → Action & Rules → Actions → Smart 
Action → Configuration Item 

Figure 3 CM get software list – Smart Action 
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Table 11 Configuration values for Smart Action: CM get software 
list 

Field 

Object Type 

Object Filter 

Text 

Comment 

Icon 

Application 

Parameters 

Blocked 

Value 

Configuration Item 

Filter is set 

CM get software list 

Obtain a list of software services available in the Radia 
(Configuration Management) DSL. The command needs 
one parameter: the Service Type. It is stored in the "CM 
service type" of the Configuration Item. 

SmartAction 

CM Smart Action Tool 

./nvdkit.exe ./cmsd.tkd/bin/smart-action.tcl ­
action wsGetSoftwareList -wsSvcType [CM service type] 

No 

Required Parameter 

The [CM service type] parameter is a custom field of a Configuration Item. It 
is defined with the Type of Code and contains the predefined values of ALL,
SOFTWARE, OS or PATCH. 

Object Filter for CM Get Software List 

The object filter is set using the advanced filter criteria Search code is 
(exactly) CMGETSOFTWARESERVICES, as shown in Figure 4 on page 58. 

Using this object filter the Smart Action “CM get software list” is only 
available for the Configuration Item with the Search code 
CMGETSOFTWARESERVICES. 
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Figure 4 Filter Criteria Set for CM Get Software List — Smart Action 
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Smart Action — CM Create Device 

The Smart Action "CM create device" finds or creates a device node in the CM 
Portal directory, Devices container. The action is available only when the 
MAC address of the Configuration Item is filled. 

Access Path: OV Configuration → Action & Rules → Actions → Smart 
Action → Configuration Item 

Figure 5 Configuration for CM Create Device — Smart Action 

Table 12 Configuration values for Smart Action: CM create device 

Field Value 

Object Type Configuration Item 
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Field 

Object Filter 

Text 

Comment 

Icon 

Application 

Parameters 

Blocked 

Value 

Filter is set 

CM create device 

Find or create device node in RMP (CM Portal) directory. 

SmartAction 

CM Smart Action Tool 

./nvdkit.exe ./cmsd.tkd/bin/smart-action.tcl 
action wsCreateDevice  -sdciID [ID]  

-wsDevAttr "dnshostname [Name]  nvdhdwlana [MAC 

address]"


No 

Parameters 

•	 [ID] is the Configuration Item ID that is needed by Load Object to report 
back the results of this action. 

•	 The device is identified by the attributes dnshostname and MAC address 
that are stored in the parameters [Name] and [MAC address], 
respectively. 

Object Filter for CM create device 

The object filter is set with the condition MAC address is not empty, as 
shown in Figure 6 on page 61 . There is no need to set a condition for 
dnshostname because [Name] is a mandatory field. 

Using this filter the Smart Action “CM create device” is only available when 
the MAC address of the Configuration Item is filled. The MAC address is 
needed to identify the device; without the MAC address, the Smart Action 
cannot be started. 
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Figure 6 Filter criteria for CM Create Device — Smart Action 

Smart Action — CM Install Software 

The “CM install software” smart action installs a software service to a 
specific device, as defined by its Distinguished Name (DN).  

Access Path: OV Configuration → Action & Rules → Actions → Smart 
Action → Work order 
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Figure 7 CM install software — Smart Action 

Table 13 Configuration values for the Smart Action: CM install 
software 

Field 

Object Type 

Object Filter 

Text 

Comment 

Icon 

Application 

Value 

Work order 

Filter is set 

CM install software 

Install a service to a specific device defined by its DN. 

SmartAction 

CM Smart Action Tool 
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Field 

Parameters 

Blocked 

Value 

./nvdkit.exe ./cmsd.tkd/bin/smart-action.tcl
-action wsDeploySoftware
 -sdwoID [ID] -sdciID [Change;Configuration Item;ID]  
 -wsDevAttr "dnshostname [Change;Configuration 
Item;Name] 
   nvdhdwlana [Change;Configuration Item;MAC address]" 
 -wsDevDN [Change;Configuration Item;CMDN]
 -wsAction Deploy
 -wsParamattrs "{cat String y}" 

No 

Parameters for CM install software 

The CM install software script requires the parameters defined in Table 14 
below to identify the device that will receive the software. 

Table 14 Parameters required by CM install software 

Parameter 

[ID]


[Change;Configuration 
Item;ID] 

[Change;Configuration Contains the dnshostname of the device that will 
Item;Name]  receive the software. 

[Change;Configuration Contains the MAC address of the device that will 
Item;MAC address] receive the software. 

[Change;Configuration 
Item;CMDN] 

Definition 

The Work order ID that is needed by Load Object 
to report back the results of this action 

The ID of the Configuration Item that will receive 
the software. This parameter is needed by Load 
Object to identify the Configuration Item for 
updating the CMDB after a successful 
installation of the software. 

Contains the Distinguished Name of the device 
that will receive the software. 

Object Filter for CM Install Software 

The object filter criterion specifies that the Configuration Item of the related 
Change must belong to the category Hardware, and the related Configuration 
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Items of the Work order must belong to the category Software. Figure 6 below 
shows this filter criterion. 

Figure 8 Filter criteria for CM install software  

Filters and Filter Groups 

The filters are discussed with the smart actions to which they apply. 

Filters and filter groups are not required to run the CMSD 
integration. However, they allow you to easily export and import the 
configuration data for the CMSD integration from one Service Desk 
system to another Service Desk system, such as from a test system to 
a production system. 

The filter group CM_config_data_custom_fields imports the filters CM CI 
codes and CM Custom Fields. These filter groups must exist prior to 
importing the second filter group: CM_config_data. 
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All other filters are imported using the filter group, CM_config_data. Figure 
9 below lists the contents of the filter group. 

Figure 9 Filter Group for CM_config_data 
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5	 CM Software Environment 
Configuration 

This chapter describes how to configure components in your Configuration 
Management environment to support the integration with Service Desk. 
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Configuring for Policy Resolution 
A new policy method named RMP_RESOLVE must be defined in the 
Configuration Server Database to allow for the policy resolution of devices 
based on their Device DN (Distinguished Name) in the CM Portal. 

Basically, the RMP_RESOLVE method allows the Configuration Server to 
accept the Device DN received from Service Desk through the CM Portal in 
lieu of the typical POLICY.USER names of subscribers. 

For more information on CM Policy Administration, refer to the 
Installation and Configuration Guides for the following HP OpenView 
CM products: 

• CM Application Manager 

• CM Policy Manager 

For more information on using the CM Admin CSDB Editor, refer to 
the CM Admin CSDB Editor Guide. 

Use the steps below to define an RMP_RESOLVE instance in the 
PRIMARY.SYSTEM.Methods class of the Configuration Database, and then 
connect the method to the _NULL_INSTANCE of the 
PRIMARY.POLICY.USERS class. 

To create a Methods instance for RMP_RESOLVE 

1	 Using the CM Admin CSDB Editor, navigate to the 
PRIMARY.SYSTEM.ZMETHOD class of the Configuration Server Database. 

2	 Right-click on the Methods class listing to open the menu, and click New 
Instance to create a new instance. 
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3	 In the Create Instance dialog box, type the name RMP_RESOLVE and press 
Enter. 

The RMP_RESOLVE instance is added to the methods class. 

4	 Edit the RMP_RESOLVE instance and set the following values: 

a	 For ZMTHPRMS, type the value below, substituting rmp_host with 
your CM Portal's host name or IP address and 3471 for its actual port 
number: 

http://rmp_host:3471/policy/device?dn=<<PREFACE.RMADEVDN>> 

b For ZMTHTYPE, set the value to REXX. 


c For ZMTHNAME, set the value to radish.


d Optionally, enter descriptions in ZMTHDSC1 and ZMTHDSC2. 
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The figure below shows an RMP_RESOLVE method edited to resolve 
policy for device DNs from a CM Portal running on svr25 using port 3471. 
Note the method type is set to REXX. 

To connect the RMP_RESOLVE method to the _NULL_ instance of Policy.Users 

1 Using CM Admin CSDB Editor, navigate to the PRIMARY.POLICY.USERS 
class of the Configuration Server database. 

2  Display the _NULL_INSTANCE and then edit the following values: 

a Set the first _ALWAYS_ connection for the Utility Method to specify 
the new RMP_RESOLVE method. Type its value as:  

SYSTEM.ZMETHOD.RMP_RESOLVE 

b	 Edit the first _ALWAYS_ connection for Member of and replace any 
existing entry with the following value: 

_NULL_ 

c	 Save the changes. 
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The figure that follows shows the _NULL_INSTANCE of the 
POLICY.USERS class with these required modifications for the 
RMP_RESOLVE policy resolution. 

This completes the configuration of policy resolution using the method 
RMP_RESOLVE for Service Desk integration. 
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6 Using the CM Smart Actions 

Overview 

The CM integration with Service Desk allows a service desk administrator to 
seamlessly manage requests for software service changes to a single 
hardware device in the CMDB. 

The requests are made using CM Smart Actions from the Service Desk 
Console. The smart actions must be enabled for accounts my assigning one or 
both CM Configuration Management Roles to the accounts. 

The CM Smart Actions include the two smart actions used to establish the 
needed database exchanges and linkages between Service Desk CMDB and 
the Definitive Software Library (DSL). The DSL is the OVCM database on 
the Configuration Server. These actions are CM get software list and CM 
create device. CM get software list brings the managed-software services 
from OVCM into the CMDB as Software Configuration Items (CIs), and CM 
create device creates a Device DN entry in the CM Portal for a Hardware CI 
in the CMDB. 

After software lists are available in the CMDB and Device DNs are created, 
you can initiate the following actions from the Service Desk console for a 
single device: 

•	 Create a Work order to define and execute a verify, repair, or update of a 
single software service on a device. 

•	 Create a Work order to define and execute the install or uninstall of a 
software service on a device. 

•	 Create a Work order to define and synchronize a software service on a 
device; this triggers a CM-Notify job for a Full CM Agent Connect; this 
brings the managed-software on the device to its desired-state according 
to the policy settings established in the OVCM environment. 

In this integrated environment, OVCM owns and maintains the DSL; there is 
no change to the existing publishing interfaces to maintain the DSL. 

OVCM is solely responsible for the continuous enforcement of the assigned 
software services to a hardware Configuration Item (CI). This continuous 
enforcement is known as desired-state maintenance. 
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Using the CM Smart Actions 

Prerequisites 

Servers 

All CM smart actions require the following servers to be running: 

•	 Service Desk Management Server (5.x) or Application Server (4.5) 

•	 Service Desk Admin (client) 

•	 HP OVCM Service Desk Adapter (httpd-servicedeskadapter) – This must 
be running on both the Server Desk Server and Admin (client). 

•	 HP OVCM Portal (httpd-managementportal) – This is the service for the 
CM Portal. The Configuration Server Primary file must be mapped to the 
CM Portal using a directory service connection. 

•	 HP OVCM Configuration Server and HP OVCM Messaging Server 

•	 HP OVCM Reporting Server (to enable Device reports using the action 
CM reporting server) 

Targeted Devices 

The CM Smart Actions that target a Hardware CI device also require the 
target device to have a CM Portal Management Agent and a CM Agent 
installed and running on the target device. 

Service Desk Account and Roles 

Your Account must be enabled for the Roles associated with the desired CM 
Smart Actions. There are two roles. 

•	 Most actions are associated with the CM Configuration Management 
Role. 

•	 The ability to install and uninstall devices is associated with the CM 
Configuration Management – install/uninstall role.  

For details on assigning roles, see Task 5 Assigning Roles to Accounts, in the 
appropriate configuration chapter for your Service Desk version. 
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Get Software List 

Run this action to request an immediate import or refresh of the software CIs 
available for CM actions into the CMDB. This list is retrieved from the 
managed-software cache in the CM Portal, which is kept in sync with the 
services published in the Configuration Manager. 

Prior to running the action, you can specify whether to retrieve the software 
for a single domain (either SOFTWARE, PATCH, or OS) or ALL domains. 

The get software list is refreshed automatically at regular intervals, 
as defined by the PERIODIC_INTERVAL parameter in the cmsd.cfg 
file. The default value is 10 minutes. To set a different period, refer 
to the appropriate Configuration chapter in this guide. 

How to run CM Get Software List 

1 Display the list of Configuration Items for the CMDB. 

2 Locate and select the Search code CMGETSOFTWARESERVICES. 

3 Optionally, if you want to get a list for just a single domain; 

a Double-click CMGETSOFTWARESERVICES to open the 
Configuration Item page. 

b Locate the CM Service Type field, and select a type of service to 
retrieve a list for: ALL, SOFTWARE, PATCH, or OS. 

c Click Save and Close to save the selected service type. 

4 From the Action menu, select CM Get Software List. 
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5 Press F5 to refresh the display. 

The software list is obtained and added to the CMDB Configuration Items 
under the Category of Software. 

Create Device 

The CM Create Device action creates or obtains the Distinguished Name of 
the Device entry from the CM Portal and relates it to the Hardware CI entry 
in the CMDB. If the Hardware CI does not have an existing entry in the 
Portal, a new one is created and its DN is then associated with the Hardware 
CI in the CMDB. 

Hardware CI Prerequisites 

To run CM Create Device, the Hardware CI in the CMDB must include 
entries for Search code, Name 1, and MAC Address. In the Name 1 field, 
place the server name. These entries are illustrated in Figure 1 on page 77. 
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Figure 1 Creating a Device CI and Device DN 

Legend 

a	 In the Search code field, enter a CMDB-unique value for the device. 

b	 In the Name 1 field, specify the DN for the device 

In the MAC address field, type the MAC address value. This can be obtained from a 
command line by typing ipconfig /all. The MAC address is the Physical Address for 
the IP assigned to the device DN.  

d	 In the LOCATION field, select a Location. 

e	 After running the Action CM Create Device, the CMDN field on the OVCM tab contains 
the Device DN from the CM Portal. 

How to Run CM Create Device 

1	 Open Service Desk and display the list of Configuration Items in the 
CMDB. 

2	 Select the Hardware CI for which you want to get a device DN from the 
CM Portal.  

3	 From the Action menu, select CM Create Device. 
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The Device is created in the CM Portal, and its DN is placed in the CMDN 
field on the OVCM tab. 

If a Device with the specified MAC address already exists in the CM Portal, 
its DN is retrieved from the CM Portal and linked to this Hardware CI. 

Installing Software 

•	 This action is enabled by assigning the Role of "CM Configuration 
Manager – install/uninstall" to a person's Account. For details, see 
Assigning Roles for CM actions to Accounts. 

•	 This action requires an OVCM policy configuration that uses the 
RMP_RESOLVE method, as discussed in the previous chapter. 

•	 Use CM install software to entitle and install software to a single device. 
Software entitlement (policy) is added to the Device properties in the CM 
Portal. 

How to Install software using a Work order 

1	 Create a Service Desk Change Request, and select the device's Hardware 
CI as the Configuration item. In Service Desk 4.5, also set a Start Time. 
Set the Status to Approved, when appropriate, so that you can create a 
Work order to initiate the installation. These entries are illustrated in the 
following figure. 
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2	 Open a new Work order for the Change Request. The Work order will 
associate one software service to the selected hardware device.   

—	 Set the Status to New. 

—	 Type a Description that identifies the device and software activity, 
such as "Install redbox on qanj317".  

—	 On the CIs/Outage tab, click Add and then select the desired 
software to deploy from the Configuration drop-down list. 
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Figure 2 Add Software CI to new Work order to install software 

Legend 

a	 Status is New 

b	 Description includes software to be deployed. 

On CIs/Outage tab, click Add 

d	 Select the software to be installed from the Configuration drop-down list. 

e	 Click OK to Add the Configuration Items. 

f	 When the job runs, CM job status shows the job status from the CM Portal. 

g When the job runs, the Information field records the job messages from the CM Portal. 

3 Save the Close the Work order. 
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4	 Select the Work order, and use the Action menu to select CM Install 
software. 

A successful installation creates an entry in the Related CIs area of the 
Hardware Configuration Item window. 

Installing Multiple Software Services on a Device 

A Work order relates one hardware CI with only one software CI. However, 
you can associate a Change order with multiple Work orders for a device.  

To install multiple services on a device 

1	 Create a Change order for the device. 

2	 Create multiple Work orders for the device, one for each software CI that 
needs to be installed on the device. Associate each Work order with the 
same Change order from Step 1. 

3	 Select all of the Work orders for the device and then run the smart action: 
CM install software. 

Uninstalling Software 

•	 This action is enabled by assigning the Role of "CM Configuration 
Manager – install/uninstall" to a person's Account. For details, see 
Assigning Roles for CM actions to Accounts. 

•	 This action requires an OVCM policy configuration that uses the 
RMP_RESOLVE method, as discussed in the previous chapter. 

•	 Use CM uninstall software to entitle and uninstall software from a single 
device. Software entitlement (policy) is added to the Device properties in 
the CM Portal to allow this action. 

How to Run CM Uninstall software 

•	 Running CM uninstall software follows exactly the same steps as CM 
install software with the exception of choosing a different Action. Choose 
CM uninstall software instead of CM install software. 
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Synchronizing All Software on a Device 

•	 Run CM synchronize software to have all managed-software on a device 
brought to its desired-state, according to current policy settings for the 
device. This actions runs a job to perform a full CM-connect. This means 
the device will connect to the CM Configuration Server, and complete a 
full desired-state resolution of the software to which it is entitled. 

•	 Entitlements are resolved according to existing policy in the CM 
environment. 

•	 Follow the same steps as those for CM Install software, with the 
exception of choosing the Action CM synchronize software instead of CM 
install software. 

Verifying Software 

Run CM verify software to initiate a CM job to verify an existing software 
application is installed on the device and is operational.  

•	 Entitlements are resolved according to existing policy in the CM 
environment. 

•	 Follow the same steps as those for CM install software, with the 
exception of choosing the Action CM verify software instead of CM install 
software. 

Repairing Software 

Run CM repair software to initiate a CM job to fix an existing software 
application on the device that is known to be damaged. This action triggers 
the target device to connect to the OVCM Configuration Manager to obtain 
the repair for that software. 

•	 Entitlements are resolved according to existing policy in the CM 
environment. 

•	 Follow the same steps as those for CM Install software, with the 
exception of choosing the Action CM repair software instead of CM install 
software. 
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Updating Software 

Run CM update software to initiate a CM job to apply updates to a software 
application that already exists on the device. For example, if there was a 
recent, known update to a software package, run this action to have it applied 
immediately to that software on the target device. 

•	 Entitlements are resolved according to existing policy in the CM 
environment. 

•	 Follow the same steps as those for CM install software, with the 
exception of choosing the Action CM update software instead of CM 
install software. 

Obtaining Device Reports 

If you have the Reporting Server installed in your environment, use the CM 
Reporting Server action to obtain a Device-level report for a specific device in 
your CMDB.  

Select the device listing, and then select the Action menu and choose CM 
Reporting server. 

Refer to the HP OpenView CM Reporting Server Guide for more information. 
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A	 Service Desk Object Updates and 
Command Line Utility 

[This appendix defines the LoadObject calls that update the Service Desk 
objects for each CM smart action, as well as the Command Line Utility 
ovsdgetowrkorderci, which is used to retrieve software CIs from the Service 
Desk database for a work order. 
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Load Object Calls to Service Desk 

In the calls to Service Desk Object Loader that follow, the class parameter 
specifies which Service Desk object to update, and the object key is identified 
by the keyval parameter displayed in bold. 

Get Software List (Smart Action)

"C:\Program Files\HP OpenView\lbin\obs\loadobject\OvObsLoadObject" 

--configfile "C:\Program Files\HP OpenView\data\conf\obs\loadobject\cmLoadObject.conf" 

--mapping ovcm 

--class softwareci

--keyval SoftwareServiceName=%SoftwareServiceName% 

--keyval SoftwareServiceSearchCode=%SoftwareServiceSearchCode% 

--keyval SoftwareServiceDescription=%SoftwareServiceDescription% 

--keyval SoftwareServiceCategory=%SoftwareServiceCategory% 


Create Device (Smart Action)

call "C:\Program Files\HP OpenView\lbin\obs\loadobject\OvObsLoadObject" 

--configfile "C:\Program Files\HP OpenView\data\conf\obs\loadobject\cmLoadObject.conf" 

--modus=update 

--mapping ovcm 

--class computerci

--modus=update 

--keyval MACaddress=%MACaddress% 

--keyval DN=%DN% 


Install Software (Smart Action)

call "C:\Program Files\HP OpenView\lbin\obs\loadobject\OvObsLoadObject" 

--configfile "C:\Program Files\HP OpenView\data\conf\obs\loadobject\cmLoadObject.conf" 

--modus=update 

--mapping ovcm 

--class cmjobid

--keyval workorderid=%1%

--keyval cmjobid=CM999111 


To report the Job Status on the work order 

call "C:\Program Files\HP OpenView\lbin\obs\loadobject\OvObsLoadObject" 

--configfile "C:\Program Files\HP OpenView\data\conf\obs\loadobject\cmLoadObject.conf" 

--modus=update 

--mapping ovcm 

--class cmjobstatus

--keyval workorderid=%workorderid% 

--keyval cmjobstatus="Currently active" 


To update the CMDB after a job has finished successfully

call "C:\Program Files\HP OpenView\lbin\obs\loadobject\OvObsLoadObject" 
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--configfile "C:\Program Files\HP OpenView\data\conf\obs\loadobject\cmLoadObject.conf" 

--modus=insert 

--mapping ovcm 

--class relation

--keyval cci=%ci_name% 

--keyval sci=%name% 


*To report a job failure* 

*Not currently implemented* 

*call "C:\Program Files\HP OpenView\lbin\obs\loadobject\OvObsLoadObject"

*--configfile "C:\Program Files\HP OpenView\data\conf\obs\loadobject\cmLoadObject.conf" 

*--modus=update 

*--mapping ovcm 

*--class cmjobfailurere

*--keyval workorderid=%workorderid% 

*--keyval jobinfo="CM job failed: wrong username or password" 


Command Line Utility – ovsdgetworkorderci 

The Command Line Utility ovsdgetworkorderci connects to a Service Desk 
Management Server (server) and retrieves information from the Service Desk 
database about Configuration Item(s) that are related to a Work order. The 
utility connects to the server using the credentials that are stored in the 
user_settings file of the user that is running the OpenView Console. 

Syntax 

ovsdgetworkorderci –w <work order ID> -a <attribute name> 

[ -a <attribute name> …] [–o <output file name>] [-l <logfile 
name>] 

Syntax definitions 

<work order ID> is the ID of the Work order for which the related CIs are 
being requested 

<attribute name> is the name of the attribute of the CI related to the 
Work order. The utility can print more than one attribute per CI by 
specifying additional –a flags with attribute names. 

<output file name> is optional; the name of the file that will contain the 
results. If this flag is omitted results are written to standard output. 
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<logfile name> optional the name of the log file that contains error 
messages. If this flag is omitted the default log file, 
ovsdgetworkorderci.log, will be used. 

—	 On Windows this file is located in C:\Program Files\HP 
OpenView\data\log. 

—	 On UNIX this file is located in /var/opt/OV/log. 

Output Format and Examples 

The format of the output of the utility is attribute name=attribute value. 
In case of more than one attribute the attributes are separated by spaces. 
Each line contains the attributes of a CI. 

Example 1: 

ovsdgetworkorderci –w 21 -a name –o C:\Temp\out.txt 

Output: 

NAME=software.zservice.dragview 

Example 2: 

ovsdgetworkorderci –w 21 –a name –a description –o
C:\Temp\out.txt 

Output: 

NAME= software.zservice.dragview DESCRIPTION="Drag & View" 

Exit Codes 

The utility returns with an exit code unequal to 0 upon a failure. Table 1 
below defines additional exit codes. 

Table 1 Exit Codes for Command Line Utility 

ovsdgetworkorderci 


Code Condition Explanation 

0 Utility failure. 

1 Wrong syntax The syntax of the command line 
parameters is incorrect. 
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Code Condition Explanation 

2 Wrong username or 
password 

User does not exist or wrong 
password. 

3 Insufficient privileges User is not allowed to view Work 
orders or CIs. 

4 Work order does not exist A Work order with the given ID does 
not exist. 

5 CIs do not exist The given Work order does not have 
relations to CIs. 

6 Attribute does not exist The CI does not have the given 
attribute(s). 

7 Cannot open or write 
logfile 

The logfile cannot be opened (can be a 
non-existent directory) or cannot be 
written to (possibly due to insufficient 
privileges). 

8 Unsupported attribute. Some attributes are references to 
entities that cannot be shown, for 
example, Schedules of a CI. 
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B Product Name Changes 

If you have used Radia in the past, and are not yet familiar with the newly 
rebranded HP terms and product names, Table 2 below will help you identify 
naming changes that have been applied to the Radia brand. 

Table 2 Product Name and Term Changes 

New Name/Term 

CM agents 

HP OpenView Configuration Management 
Administrator 

HP OpenView Configuration Management 

HP OpenView Configuration Management 
Admin CSDB Editor 

HP OpenView Configuration Management 
Application Manager 

HP OpenView Configuration Management 
Application Self-service Manager 

HP OpenView Configuration Management 
Configuration Server 

HP OpenView Configuration Management 
Configuration Server Database 

HP OpenView Configuration Management 
Inventory Manager 

HP OpenView Configuration Management 
Portal 

HP OpenView Configuration Management 
Patch Manager 

HP OpenView Configuration Management 
Policy Manager 

HP OpenView Configuration Management 
Reporting Server 

Old Name/Term 

Radia clients 

Radia Administrator Workstation 

Radia 

Radia System Explorer 

Radia Application Manager 

Radia Software Manager 

Radia Configuration Server 

Configuration Server Database, Radia 
Database 

Radia Inventory Manager 

Radia Management Portal 

Radia Patch Manager 

Radia Policy Manager 

Radia Reporting Server 
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New Name/Term Old Name/Term 

HP OpenView Configuration Management Radia Service Desk Adapter 
Service Desk Adapter 
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copyright notices, 2 


create device, 76
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document changes, 4 
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modifying Start In path, 55 
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