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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty 
statements accompanying such products and services. Nothing herein should be construed as 
constituting an additional warranty. HP shall not be liable for technical or editorial errors or 
omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. 
Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software 
Documentation, and Technical Data for Commercial Items are licensed to the U.S. 
Government under vendor's standard commercial license.

Copyright Notices

© Copyright 2006 Hewlett-Packard Development Company, L.P.

Trademark Notices

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.
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Documentation Updates

This manual’s title page contains the following identifying information:

• Software version number, which indicates the software version

• Document release date, which changes each time the document is updated

• Software release date, which indicates the release date of this version of the software

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

Please visit the HP OpenView support web site at:

http://www.hp.com/managementsoftware/support 

This web site provides contact information and details about the products, services, and 
support that HP OpenView offers.

HP OpenView online software support provides customer self-solve capabilities. It provides a 
fast and efficient way to access interactive technical support tools needed to manage your 
business. As a valuable support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit enhancement requests online

• Download software patches

• Submit and track progress on support cases

• Manage a support contract

• Look up HP support contacts

• Review information about available services

• Enter discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and log in. Many 
also require a support contract.

To find more information about access levels, go to:

http://www.hp.com/managementsoftware/access_level 

To register for an HP Passport ID, go to: 

http://www.managementsoftware.hp.com/passport-registration.html 
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1 Introduction
HP OpenView DecisionCenter is a business intelligence application that 
enhances your ability to make better decisions about your IT infrastructure. 

IT Performance Analytics (ITPA) shows performance trends for Service Level 
Management, Asset Management, Help Desk, Incident, and Service 
Management. It can display analytics in a dashboard for quick access and 
supports an integrated BusinessObjects Enterprise XI suite of reporting tools. 
ITPA is the baseline component of DecisionCenter.

Business Intelligence Analytics (BIA) is an additional tier that adds more 
detailed analytics, views, an Impact Calculator, as well as the Data Mining 
tool and History Builder.

DecisionCenter Optimization enables you to analyze historical performance 
and predict future performance when impacted by enterprise-wide changes to 
business services. Optimization adds the Scenario Manager and Optimization 
engine to enable predictive analysis.

Related Products

DecisionCenter 1.0 supports data produced by the following products.

* Make sure that you complete the customization steps during installation if you 
use data from any version marked with an asterisk (*).

Table 1.1 Supported versions

Product Name Product Version Connect-It Version

ServiceCenter 5.1*, 6.0*, 6.1, 6.2 3.6, 3.7

AssetCenter 4.3, 4.4, 5.0* 3.6
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Installation Guide Overview

This guide has separate chapters for each major installation step. The 
chapters are in the suggested order of installation, but it is possible to change 
the installation order of the major components.

Table 1 Document Map

Chapter Describes

Chapter 1, Introduction DecisionCenter

Chapter 2, DecisionCenter 
Components

DecisionCenter packaging

Chapter 3, ITPA Installation and 
Configuration

Installation steps for DecisionCenter 
IT Performance Analytics

Chapter 4, BIA Planning and 
Installation

Installation steps for DecisionCenter 
Business Impact Analytics

Chapter 5, Optimization Installation Installation steps for DecisionCenter 
Optimization

Chapter 6, Migration Migrating BI Portal installations to 
DecisionCenter 1.00

Chapter 7, Security Configuring LDAP

Appendix A, Troubleshooting Tips for solving problems during 
installation

Appendix B, Configuring a Remote 
Tomcat Server

Instructions to configure a remote 
application server
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Hardware Requirements

The following table describes the minimum hardware requirements for 
DecisionCenter. For more information, see the DecisionCenter Support Matrix 
on the HP Software Support web site.

Table 2 Hardware Requirements

Item Minimum Requirement

Processor Windows: Pentium3 with 700MHz

Operating 
System

BusinessObjects Enterprise XI in a Windows environment 
requires a 32-bit AMD/Intel chipset.

RAM ITPA only: The minimum recommended RAM is 2 GB for the 
Tomcat server 4 GB for the BusinessObjects server.
BIA and Optimization: The minimum recommended RAM is 2 
GB for the Optimization engine server, 2 GB for the Tomcat 
server, and 4 GB for the BusinessObjects server. 
The minimum recommended RAM is 4 GB if the 
Optimization engine and Tomcat are on the same server.
Multiple instances of the application server, or very large 
databases may require more than the minimum amount of 
memory.

Disk Space 5 GB for BusinessObjects Enterprise XI R2 
1.5 GB for BusinessObjects Enterprise XI Performance 
Manager
5 GB for any database server
200 MB for DecisionCenter application

Heap Size The heap size setting on the Web server that hosts the 
DecisionCenter application must be at least 512 MB. The 
recommended setting is 1024 MB.
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Software and Platform Requirements

For complete information about required software that must be installed and 
configured before you install DecisionCenter, see the DecisionCenter Support 
Matrix on the HP Software Support web site.

Server Configuration

DecisionCenter can run in a single or multi-server environment. In a single 
server configuration, all software resides on the same server. The most 
common configuration for an enterprise organization is a multi-server 
environment with five different servers.
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DecisionCenter and Third Party Software

Before you begin the DecisionCenter installation process:

• Ensure that you have all required licenses for third-party database 
products that interact with DecisionCenter.

• Ensure that the users who will log onto the BusinessObjects Enterprise XI 
server have appropriate rights.

• Ensure that you install and configure BusinessObjects Enterprise XI 
correctly using the BusinessObjects Enterprise XI installation 
instructions.

DecisionCenter and Other OpenView Products

There are additional considerations as you continue the DecisionCenter 
installation process:

• OpenView ServiceCenter and AssetCenter applications must reside on 
servers that are separate from installed DecisionCenter components.

• The ServiceCenter data warehouse and AssetCenter data warehouse 
should reside on a server that is different from the server hosting the 
ServiceCenter and AssetCenter applications.

• Install OpenView Connect-It on the same server where you install the 
ServiceCenter or AssetCenter data warehouse.

For more information, see Server Configuration on page 14.
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Installation Media

The HP OpenView DecisionCenter installation media contains the following 
applications on separate CD-ROMs. They contain the following information.

Table 3 Installation Media

CD-ROM
Number 
of Disks Contents Required?

HP OpenView 
DecisionCenter 
1.00

1 Application

ServiceCenter data 
warehouse

AssetCenter data 
warehouse

Business Impact Analytic 
(BIA) tools, Connect-It 
scenarios, and related 
Analytics

Optimization engine

Yes

BusinessObjects XI 
R2 SP1

3 BusinessObjects 
Enterprise XI application

Yes

BusinessObjects XI 
R2 Supplement

1 File to repair the command 
line import tool 
(bexir2_60080.zip)

Performance Management 
Deployment Tool (PMDT)

Yes

HP OpenView  
Connect-It 3.6

1 Integration application Yes
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License Information

DecisionCenter packaging includes licenses for BusinessObjects 
Enterprise XI R2 and HP OpenView Connect-It 3.6. Other applications 
require separate licenses. You can obtain DecisionCenter licenses by 
contacting your HP sales representative or visiting the HP Software 
Support web site. The following table describes all of the licenses and 
passwords that you should have available when you begin the installation.

Table 4 Required Licenses

Application Included? Notes

HP OpenView
DecisionCenter IT Performance 
Analytics (ITPA)
(baseline tier)

Yes Authorization Code 
required during 
installation; unique 
product key required to 
unzip each ITPA 
analytic package

HP OpenView 
DecisionCenter Business Impact 
Analytics (BIA)
(optional tier)

Yes Authorization Code 
required during 
installation; unique 
product key required to 
unzip the BIA analytic 
package

HP OpenView 
DecisionCenter Optimization 
(optional tier)

Yes Authorization Code 
required during 
installation; unique 
product key required to 
unzip the Optimization 
analytic package

BusinessObjects Enterprise XI Yes License keys required;
HP Service Agreement 
ID required to download 
BusinessObjects 
Critical Hot Fix

HP OpenView Connect-It Yes License key included 
with DecisionCenter
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If you choose Microsoft SQL Server 2000, you must purchase two sets of licenses.

Microsoft SQL Server connections require that you purchase four or more licenses 
from Microsoft.

If you are using the Sprinta driver, you must purchase three Sprinta driver licenses 
from i-net Software.

Oracle is supported only for DecisionCenter ITPA installations. Only Microsoft SQL 
Server 2000 is supported if you add BIA and Optimization. 

HP OpenView AssetCenter No Separately licensed 
application

HP OpenView ServiceCenter No Separately licensed 
application

One of the following: 
• Oracle 10g
• Microsoft SQL Server 2000

No Separately licensed 
application

JDBC drivers No Separately licensed 
applications

Table 4 Required Licenses

Application Included? Notes
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2 DecisionCenter Components
DecisionCenter is a suite of components that support three tiers of packaging 
to address user needs. The packaging levels are:

• DecisionCenter with IT Performance Analytics (ITPA)

• DecisionCenter with ITPA and Business Impact Analytics (BIA)

• DecisionCenter with ITPA, BIA, and DecisionCenter Optimization

DecisionCenter with ITPA

This tier includes:

• Dashboards 

• Analytics: Service Level Management, Asset Management, Help Desk, 
Incident, and Service Management 

• The BusinessObjects Enterprise XI suite of tools 

• Data warehouse schema for ServiceCenter and AssetCenter 

DecisionCenter with ITPA and BIA

This tier includes:

• Dashboards 

• Analytics: Service Level Management, Asset Management, Help Desk, 
Incident, and Service Management 

• The BusinessObjects Enterprise XI suite of tools 
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• Data warehouse schema for ServiceCenter, AssetCenter, and 
DecisionCenter

• Business Intelligence Analytics and views

• Impact Calculator

• Impact definition 

• Business and Environment models

• Data Mining tool

• History Builder

DecisionCenter with ITPA, BIA, and Optimization

This tier includes all DecisionCenter components:

• Dashboards 

• Analytics: Service Level Management, Asset Management, Help Desk, 
Incident, and Service Management 

• The BusinessObjects Enterprise XI suite of tools 

• Data warehouse schema for ServiceCenter, AssetCenter, and 
DecisionCenter

• Business Intelligence Analytics and views

• Impact Calculator 

• Impact definition 

• Business and Environment models 

• Data Mining tool

• History Builder

• Scenario Manager 

• The Optimization engine
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3 ITPA Installation and Configuration
The chapter includes the software installation and configuration preparation 
needed to install and run the DecisionCenter ITPA tier.

Before You Begin

Consider the following information before you begin:

• There are several tasks required to create a complete DecisionCenter 
installation where you can access and customize Analytics, perform 
Business Impact analysis, and run the Optimization engine to predict 
future IT performance. The tasks involve setting up a database, 
populating it with relevant data, and installing the DecisionCenter 
software components. The number of tasks depends on the DecisionCenter 
tier that you select.

• The baseline for all DecisionCenter activities is the ITPA tier. The ITPA 
installation lays the foundation for basic functionality and tiered 
enhancements.

• Because the ITPA installation has multiple tasks and steps that require 
configuration information, ensure that you correctly record the 
case-sensitive values for each step. You can print a copy of the installation 
steps to record the information for future reference.

• Ensure that you complete each task in sequential order and the steps 
within each task in sequential order.

• It is assumed that you have an existing installation of a supported 
database product. 

• Review the DecisionCenter Support Matrix before you begin to ensure 
that you have the required environment. For more information, see the 
DecisionCenter Support Matrix on the HP Software Support web site.
 21
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• ServiceCenter 5.1: If you are customizing the installation to use 
ServiceCenter 5.1 data, your HP Support representative provided 
download instructions for supplemental installation files. Store these files 
locally. You must reference them as you proceed through the normal 
installation steps.

Obtain the BusinessObjects Critical Hot Fix Files

BusinessObjects Enterprise XI produces patch releases, called Critical Hot 
Fixes (CHFs), at regular intervals. DecisionCenter requires you install only 
those Critical Hot Fixes that are recommended by HP to ensure that 
BusinessObjects Enterprise XI integrates seamlessly with DecisionCenter. 
These recommended CHFs are required for full functionality.

Before you begin the ITPA installation, it is recommended that you download 
the BusinessObjects XI Release 2 July 5th Critical Hot Fix and have it 
available on the BusinessObjects server when you are directed to install this 
CHF.

1 Start a Windows Internet Explorer browser session and point to this URL:

http://support.openview.hp.com/patches

2 If you do not already have an HP Passport, click New user registration.

3 Follow the instructions to register with HP.

4 Select DecisionCenter from the drop-down product list.

5 Click the Search icon.

6 An error page appears; however, you can use your Support ID Agreement 
(SAID) number to access the patch site. Type the SAID number in the 
System Handle or SAID text box at the bottom of the screen.

7 Click Product patches in the HP-Peregrine links section.

8 Click DecisionCenter and look for the BusinessObjects XI Release 2 July 5th 
Critical Hot Fix.

9 Download boXIr2win_chf.zip and unzip it to a temporary directory.
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Installation Checklist

Print this checklist to use during the installation process. As you complete 
each task, mark it as completed. You can install all components on the same 
server, but if you want to install these components across multiple networked 
servers, you can refer to this server configuration diagram as you complete 
installation tasks.
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Task 1: Configure Database Servers and Connectors on page 26.

— Step 1a: Run the Oracle Configuration Script File on page 27.

— Step 1b: Configure the Oracle Database Client on page 28.

— Step 2a: Run the SQL Server Configuration Script File on page 30.

— Step 2b: Configure the SQL Server on page 30.

— Step 3: Collect the User Information on page 31.

Task 2: Install and Configure Database Clients on page 32.

— Step 1: Verify All Required Client Installations on page 32.

— Step 2: Configure the SQL Server Client on page 32.

Task 3: Install BusinessObjects Enterprise XI on page 33.

— Step 1: Use These Installation Tips on page 34.

— Step 2: Install the Required Critical Hot Fixes on page 34.

— Step 3: Install the Performance Management Deployment Tool on 
page 37.

— Step 4: Customize BusinessObjects Enterprise XI Files on page 37.

— Step 5: Verify the Business Objects Enterprise XI Installation on 
page 39.

— Step 6: Configure BusinessObjects Enterprise XI on page 40.

Task 4: Install Connect-It on page 44.

Complete Task 1 on the RDBMS server.

Complete Task 2 on the DecisionCenter data warehouse server and the 
Business Objects server.

Complete Task 3 on the Business Objects server.

Complete Task 4 on the DecisionCenter data warehouse server.
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Task 5: Prepare ServiceCenter or AssetCenter on page 45.

— Step 1: Verify That the ServiceCenter Client Is Installed and Available 
on page 45.

— Step 2: Import ServiceCenter Unload Files on page 46.

— Step 3: Import AssetCenter Script Files on page 47.

Task 6: Install the Data Warehouse on page 47.

— Step 1: Install and Configure JDBC Drivers on page 48.

— Step 2. Copy the Configuration File on page 48.

— Step 3: Install the Data Warehouse on page 49.

— Step 4: Run the HP OpenView Connect-It Scenario on page 52.

Task 7: Install DecisionCenter on page 53.

— Step 1: Install the DecisionCenter Application on page 53.

— Step 2: Configure LDAP on page 54

— Step 3: Configure JNDI for Tomcat on page 55.

Task 8: Install ITPA Content on page 57.

— Step 1: Install the AssetCenter Universes, Reports, and Views on 
page 57.

— Step 2: Install the ServiceCenter Universes, Reports, and Views on 
page 59.

— Step 3: Configure Reports for ServiceCenter 5.1 on page 67. 

Complete Task 5 on the ServiceCenter or AssetCenter server.

Complete Task 6 on the DecisionCenter data warehouse server.

Complete Task 7 on the DecisionCenter server.

Complete Task 8 on the Business Objects server.

Complete Task 9 on the workstation that is network connected to the 
DecisionCenter application server.
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Task 9: Verify the DecisionCenter Installation on page 69.

Task 1: Configure Database Servers and Connectors

DecisionCenter supports Oracle or SQL Server 2000 for ITPA installations. 
These instructions assume that you have a licensed database server installed 
before you begin the DecisionCenter installation. 

Always consult your database administrator before installing and configuring 
the database.

HP strongly recommends that your data warehouse be case-sensitive.

Configuration Scripts

You can configure the database server manually or run prepared scripts to 
configure the database. There is a script for each supported database type in 
this folder on the DecisionCenter data warehouse installation media: 

\\ITPA\ITPA-SM\SupportFiles\DatabaseFiles

crtusers_oracle.sql (for Oracle users)

crtusers_sqlsrvr.sql (for SQL Server users)

There are three types of users and three tablespaces:

• A data warehouse user and a data warehouse tablespace for 
DecisionCenter.

• A Central Management Console user and a CMS tablespace for 
BusinessObjects Enterprise XI R2.

• A Performance Management user and a PM tablespace.
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Database Connectors

With most databases, you can access the database server from different clients 
with different names. Because DecisionCenter has multiple components and 
servers, you must reference the database server with the same name. The 
following table lists the database and the terminology for client configuration.

To simplify the names, the client configuration in this document is called the 
database connector.

Step 1a: Run the Oracle Configuration Script File

Follow these steps to configure the Oracle database server:

1 Using a text editor, open the Oracle database script file that you copied 
from the DecisionCenter installation media to the database server. 

\\ITPA\ITPA-SM\SupportFiles\DatabaseFiles\crtusers_oracle.sql 

2 Verify that the settings are appropriate for your installation. 

3 If necessary, change the settings.

4 Save the file locally. 

5 Run the script. 

Table 5 Client Configuration

Database Type Client Configuration

Oracle TNS Alias

SQL Server ODBC SYSTEM DSN
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Step 1b: Configure the Oracle Database Client

To configure the Oracle client, create a net service (TNS) name for the Oracle 
database server where DecisionCenter components reside. When prompted, 
select settings that correspond with your database type. You can disregard 
any value that does not apply to your database environment. Record the 
settings that you specify for future reference.

1 Click Start > Programs > Oracle OraHome<version> > Configuration and 
Migration Tools > Net Configuration Assistant to open the Oracle Net 
Configuration Assistant.

2 Select Local Net Service Name configuration.

3 Click Next.

4 Select Add and click Next.

5 Type the Service Name and click Next. You can find the Oracle Service 
name in your Windows services.

6 Select TCP and click Next.

7 Type the Host name of the Oracle service, confirm the port number, and 
click Next.

Table 6 Oracle Values

Oracle Default Value Your Value

Hostname physical_device_name 

Port 1521 

Database service 
name

orcl 

JDBC URL jdbc:oracle:thin:@dbsrv:1521:orcl 

Data warehouse 
tablespace name

rdsts 

CMS database 
tablespace name

cmsts

PM database 
tablespace name

pmts
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8 Select the Yes, perform a test radio button and click Next.

9 Do one of the following:

— If the Test successful message appears, click Next.

— If you receive an error message, click Change Login. Type the new login 
information, click OK, and click Next. If you continue to receive an 
error message, contact your database administrator.

10 Type a TNS name. Record the TNS information that you specify for the 
Oracle client. Click Next.  

11 Click Next.

12 Click Next.

13 Click Finish.

Ensure that the tnsnames.ora file is configured correctly. The file is in 
this directory:

\\Oracle\product\version_#\server_directory\network\admin\ 

For example:

rdsts =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = dbsrv)(PORT = 1521))
    )
    (CONNECT_DATA =
      (SID = orcl)
    )
  ) 

Table 7 TNS Information

Oracle Default Value Your Value

Data warehouse db rdsts

CMS db cmsts

PM db pmts

Repeat Step 2 through Step 12 for each server. To adhere to best 
practices, use the data warehouse tablespace name.
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Step 2a: Run the SQL Server Configuration Script File

You can change the default values for the database user name, password, and 
database name. Use any text editor to change these values in the script file 
that configures the SQL Server database server. Follow these steps to 
configure the SQL Server database server:

1 From the DecisionCenter installation media, browse to:

\\ITPA\ITPA-SM\SupportFiles\DatabaseFiles\crtusers_sqlsrvr.sql 

2 Open the file with a text editor and verify that the settings are 
appropriate for your installation. If necessary, change the settings.

3 Save the file to a new location.

4 Follow these steps to run the script.

a Copy the contents of the modified crtusers_sqlrvr.sql script.

b Click Start > Programs > Microsoft SQL Server > Query Analyzer.

c Paste the contents in the Query window.

d Click Query > Execute.

Step 2b: Configure the SQL Server

If necessary, configure the SQL Server server. Select the values that 
correspond with your database type. You can disregard the values that do not 
apply to your database environment.

Table 8 SQL Server Values

SQL Server Default Value Your Value

Hostname physical_device_name 

Port 1433 

JDBC URL for data warehouse 
using Sprinta driver (ITPA only)

jdbc:inetdae7:dbsrv: 
1433?database=rdsdb
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Step 3: Collect the User Information

Define the user information for the data warehouse, Central Management 
Server (CMS), and Performance Management (PM).

Data warehouse name rdsdb 

CMS database name cmsdb

PM database name pmdb

Table 8 SQL Server Values

SQL Server Default Value Your Value

Table 9 User Information

Oracle or SQL Server 
Information

Default Value
SQL Server             Oracle Your Value

Data warehouse user name rds_dba rds_dba 

Data warehouse password passw0rd passw0rd 

Data warehouse 
information

rdsdb rdsts 

CMS user name cms_dba cms_dba 

CMS password passw0rd passw0rd 

CMS database information cmsdb cmsts

PM user name pm_dba pm_dba 

PM password passw0rd passw0rd 

PM database information pmdb pmts 
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Task 2: Install and Configure Database Clients

Ensure that the database client that you intend to use is installed on all 
required servers in a multi-server environment. 

Step 1: Verify All Required Client Installations

The following table shows where the database client must be installed. If any 
installations are missing, correct the omissions.

Step 2: Configure the SQL Server Client

Configuring the SQL Server database client, means creating a DSN ODBC 
connection for each database on each server that hosts a SQL Server client. To 
create a create a DSN ODBC connection:

1 Click Start > Settings > Control Panel > Administrative Tools > Data Sources.

2 Click the System DSN tab in the ODBC Data Source Administrator dialog.

3 Click Add. 

4 Select SQL Server.

5 Collect the SQL Server database connector (ODBC DSN) information for 
future reference.

6 Click Finish.

7 In the Name field, type rdsdb. The name you type in this field comes from 
the SQL Server database name you recorded in Step 1a: Run the Oracle 
Configuration Script File on page 27, or Step 2a: Run the SQL Server 
Configuration Script File on page 30.

Table 10 Database Servers

Database Client
Data  
Warehouse Server 

BusinessObjects 
Enterprise XI server

Oracle Required Required

SQL Server Required Required
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8 From the Server drop-down menu, select the SQL Server you are using, 
then click Next.

9 Select With SQL Server authentication using a login ID and password entered 
by the user.

a Type rds_dba and the password provided in the script (or by your 
database administrator) in the login ID and password fields. 

b Click Next.

10 Ensure that the Change Default Database to check box is clear and that the 
DSN name appears. 

11 Click Next.

12 Click Finish.

13 Click Test Data Source to test the connection. If the connection is valid, a 
confirmation message appears.

14 Click OK.

15 Click OK again to see the new entry in the System Data Source list.

16 Click OK to exit the ODBC Data Source Administrator.

17 Repeat Step 1 – Step 16 to create a DSN ODBC connection for the cmsdb 
and pmdb databases.

Task 3: Install BusinessObjects Enterprise XI

BusinessObjects Enterprise XI is a third-party product that integrates with 
DecisionCenter to produce Analytics. BusinessObjects Enterprise XI requires 
a separate BusinessObjects Enterprise XI license and it has its own 
installation instructions that accompany the DecisionCenter installation 
media.

HP recommends that you follow the “Full Java Installation” scenario 
described in the BusinessObjects Enterprise XI Installation Guide. This 
scenario guides you through these critical steps:

• Creating a Tomcat application server. If you already have a Tomcat 
instance, or you want Tomcat to reside on a different server, see  
Appendix B, Configuring a Remote Tomcat Server before you proceed.
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• Choosing which components to install.

• Deploying InfoView.

Step 1: Use These Installation Tips

Ensure that you log on to the server as an administrator before you begin the 
BusinessObjects Enterprise XI R2 installation. You must make choices during 
the installation that will affect your DecisionCenter configuration later. The 
following table lists the critical decisions and the recommended choices.

Step 2: Install the Required Critical Hot Fixes

Follow these steps to install the required HP-supplied CHFs to a full 
BusinessObjects Enterprise XI R2 SP1 installation. For more information 
about downloading the first CHF, see Obtain the BusinessObjects Critical Hot 
Fix Files on page 22. For more information about installing the first CHF, 
refer to the Business Objects readme.txt file in the zip file.

Table 11 BusinessObjects Enterprise XI Installation Tips

On This Dialog Use These Values

Select Client or Server Installation Perform Server Installation

User Information Install Performance Management 
Use the same HP-supplied Product 
Keycode for Performance Management

Install Type Use an existing database server 

Windows Logon Information Leave it blank

CMS Database Information Clear the Auditing Database check box 
after you specify the CMS Database 
information

SQL Server Login (for your CMS 
database)

Use the cmsdb name that you defined 
when you created the database

Choose Web Component Adapter 
Type

Java application server
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Install the Downloaded CHF

1 From the Windows Start menu, click Control Panel > Services and stop 
these services:

— Microsoft SQL Server or Oracle RDBMS services

— Antivirus services

2 Delete all the cached files in this directory:

\\Program Files\BusinessObjects Enterprise 11.5\Tomcat\work

3 Create a backup directory. For example: \\BOXML_backup.

4 Move all files except webcompadapterwar.xml from this directory:

\\Program Files\BusinessObjects Enterprise 11.5\Tomcat\conf 
\Catalina\localhost

 to the backup directory that you created in Step 3.

5 Move this file:

\\Program Files\BusinessObjects Enterprise 11.5\Web Services\en 
\dswsbobje.war

 to the backup directory that you created in Step 3.

6 Navigate to the directory where you stored the downloaded CHF zip file.

7 Run setup.exe.

8 When you are prompted to restart the server, click No.

9 Delete the following applications in this directory:

\\Program Files\BusinessObjects Enterprise 11.5\Tomcat\webapps: 

— analysishelp 

— businessobjects 

— dswsbobje 

— jsfadmin 

— styles
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10 From the Windows Start menu, click Control Panel > Services and start the 
Apache Tomcat service. Ensure that it creates this directory:

\\Program Files\BusinessObjects Enterprise 11.5\Tomcat\webapps\ 
businessobjects\WEB-INF

11 From the Windows Start menu, click Control Panel > Services and stop the 
Apache Tomcat service.

12 Restore the xml files that you backed up in Step 4 on page 35 to:

\\Program Files\BusinessObjects Enterprise 11.5\Tomcat\conf 
\Catalina\localhost

13 Restore the dswsbobje.war file that you backed up in  
Step 5 on page 35 to:

\\Program Files\BusinessObjects Enterprise 11.5\Web Services\en

Install the Supplemental CHF

1 Rename the current cexsd.jar file in

\\Program Files\Business Objects\Common\3.5\java\lib\

to cexsd.bak

2 Insert the BusinessObjects XI R2 Supplement media into your CD-ROM 
drive. 

3 Unzip the bexir2_600804.zip file to a local directory and copy the cexsd.jar 
file to:

\\Program Files\Business Objects\Common\3.5\java\lib\

Restart the Server

1 Restart the server. 

2 Ensure that these Windows services restarted:

— RDBMS services

— Antivirus services

— Apache Tomcat service

— Other related BusinessObjects Enterprise XI services
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Step 3: Install the Performance Management Deployment Tool

When you deploy the analytics for ITPA Incident and Help Desk, and ITPA 
Service Level Management, you must import the related metrics. To import 
the metrics, you should have the Performance Management Deployment 
Tool (PMDT) installed on the target machine.

1 Extract pmdt.zip from the BusinessObjects XI R2 Supplement media to 
the BusinessObjects server.

2 Verify that the server has a supported JDK (jdk1.4.2).

3 Verify that the JAVA_HOME Environment Variable points to the 
supported JDK version. If the CLASSPATH or the PATH environment 
variables reference an earlier version, you must remove that reference to 
run the batch files correctly. 

4 If necessary, you can change the default heap size to the recommended 
values by modifying the run_DeploymentTool.bat file. For more 
information about recommended heap size, see Table 2 on page 13.

Step 4: Customize BusinessObjects Enterprise XI Files

BusinessObjects Enterprise XI R2 requires a moderate amount of 
customization to integrate successfully with DecisionCenter.

Add the Drill Icon

1 From the DecisionCenter installation media, copy this file:

\\ITPA\ITPA-SM\BOCustomization\images\drill.gif file

2 Paste it into the BusinessObjects Enterprise XI image directory. 

For example:

\\...\Business Objects\BusinessObjects Enterprise 11.5\Images

Change the ODBC Settings for Outer Joins

1 Back up this file before you complete the next step:

\\Business Objects\BusinessObjects Enterprise 11.5\win32_x86 
\dataAccess\connectionServer\odbc\sqlsrv.prm
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2 Open sqlsrv.prm with a text editor.

3 Locate this parameter:

<Parameter Name="OUTERJOINS_GENERATION">....

4 Replace USUAL with FULL_ODBC.

5 Add a new parameter:

<Parameter Name="OUTERJOINS_COMPLEX">Y</Parameter>

6 Save and close the file.

Customize Tomcat

1 From the DecisionCenter installation media, copy the following files and 
replace them in your Tomcat installation directory. These files enable 
DecisionCenter to integrate and host BusinessObjects Enterprise XI 
functionality within the DecisionCenter framework. 

Table 12 Customized Files

Copy From:
 
 
\\BOCustomization 
\desktoplaunch

Copy to: 
\\Program Files\BusinessObjects 
\Tomcat\webapps 
\businessobjects\enterprise115 
\desktoplaunch

\jsp\ce\cestartpage.jsp \jsp\ce\...

\scripting\aa-linkbar.js \scripting\...

\InfoView\main\home.jsp \InfoView\main\...

\InfoView\utils\utils.jsp \InfoView\utils\...
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2 From the Windows Start menu, click Control Panel > Services and start the 
Apache Tomcat service.

Step 5: Verify the Business Objects Enterprise XI Installation

Verify that you can log on to Central Configuration Management and 
Performance Manager.

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Central 
Configuration Manager.

2 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

3 Close each application.

\jsp\aa-promptcontent.jsp
\jsp\appsContentFrame.jsp
\jsp\headerPlusAF.jsp
\jsp\
performanceManagementHome.jsp
\jsp\workspaceHeaderAF.jsp

\jsp\....

\viewers\cdz_adv\...
viewCDZDocument.jsp
viewReport.jsp

\viewers\cdz_adv\...

Table 12 Customized Files

Copy From:
 
 
\\BOCustomization 
\desktoplaunch

Copy to: 
\\Program Files\BusinessObjects 
\Tomcat\webapps 
\businessobjects\enterprise115 
\desktoplaunch
ITPA Installation and Configuration 39



Step 6: Configure BusinessObjects Enterprise XI

Complete these configuration steps to ensure that BusinessObjects Enterprise 
XI R2 integrates correctly with DecisionCenter.

Add the License Key

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java Administration Launchpad.

2 Click Central Management Console.

3 Log on as Administrator with no password.

4 In the Manage section, click License Keys.

5 Type the HP-supplied license key in the Add Key text box and click Add.

Verify System User Information

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log on as Administrator with no password.

3 Click Go to Performance Management.

4 Click Setup on the Toolbar.

5 Click the System Setup tab.

6 Click System User.

7 Verify that the User Name in the System User and Initialization User sections 
is Administrator. If necessary, type Administrator into each User Name text 
box and click Apply in each section. 

8 When InfoView returns a verification message, click OK.

9 Follow these steps to restart the Central Management Server.

a From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
Central Configuration Manager.
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b Select the Central Management Server service.

c Click Restart.

Configure the Performance Management Database Connections

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Designer.

2 Log on as Administrator with no password.

3 Click Tools > Connections. BusinessObjects Enterprise XI displays a list of 
connections.

4 Click Add.

5 The New Connection Wizard appears. Click Next.

6 For MS SQL Server, expand the database middleware node for Microsoft 
and click MS SQL Server 2000 > ODBC Drivers.

For Oracle, expand the database middleware node for Oracle and click 
Oracle 10 > Oracle Client. 

7 Click Next.

8 Select or type the following values:

9 Click Next.

10 Click Test Connection to ensure the server is responding. If the connection 
fails, click Back to verify that you specified the correct values. If the 
connection works, click Next.

Table 13 Connection Wizard Settings

Parameter MS SQL Server 2000 Oracle 10

Type: Secured Secured

Name: pmdb pmdb

User name: pm_dba pm_dba 

Password: passw0rd passw0rd

Data source name: pmdb pmts
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11 Accept the advanced parameter default values, or change them to suit 
your environment. Click Next.

12 Add any optional custom parameters to suit your environment. Click 
Finish. 

13 To repeat the process for the rdsdb, click Add.

14 The New Connection Wizard appears. Click Next.

15 For MS SQL Server, expand the database middleware node for Microsoft 
and click MS SQL Server 2000 > ODBC Drivers.

For Oracle, expand the database middleware node for Oracle and click 
Oracle 10 > Oracle Client. 

16 Click Next.

17 Select or type the following values.

18 Click Next.

19 Click Test Connection to ensure the server is responding. If the connection 
fails, click Back to verify that you specified the correct values. If the 
connection works, click Next.

20 Accept the advanced parameter default values, or change them to suit 
your environment. Click Next.

Table 14 Connection Wizard Settings

Parameter MS SQL Server 2000 Oracle 10

Type: Secured Secured

Name: rdsdb rdsdb

User name: rds_dba rds_dba 

Password: passw0rd passw0rd

Data source name: rdsdb rdssts
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21 Add any optional custom parameters to suit your environment. Click 
Finish.

Configure the Repository

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log on as Administrator with no password.

3 Click Go to Performance Management.

4 Click Setup on the Toolbar.

5 Click the System Setup tab.

6 In the Repository Information section, click Change.

7 If necessary, select pmdb from the drop-down list in the Ensure the Choose 
repository connection dialog box. Click OK.

8 In the Repository Information section, click Check.

9 When the verification message appears, click OK.

10 Click Set Up Repository.

11 Accept the defaults and click Next.

12 Click Execute, then click OK.

Update Fonts on the BusinessObjects Enterprise XI Server

Decision Center 1.00 uses the Verdana and Lucida Console fonts. You must 
change the configuration file to add these fonts to the report editor.

1 Back up the fontalias.xml file. The default path is:

\\Business Objects\BusinessObjects Enterprise 11.5\win32_x86\fonts

2 Open fontalias.xml with a text editor.

3 Locate <FONT NAME="default">.

For more information about configuring connections, click Help > 
Designer Help in the BusinessObjects Enterprise XI Designer 
application.
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4 Open this file on the DecisionCenter installation media with a text editor:

\\ITPA\ITPA-SM\BOCustomization\xml\fonts.xml

5 Copy the contents of fonts.xml and paste them above this line in 
fontalias.xml:

<FONT NAME="default">

6 Save and close fontalias.xml.

Task 4: Install Connect-It

HP OpenView Connect-It is a software product that integrates HP OpenView 
applications, such as DecisionCenter, with other HP OpenView applications, 
such as AssetCenter or ServiceCenter. You must install Connect-It on the 
same dedicated server where you plan to install the AssetCenter or 
ServiceCenter data warehouse. Follow these steps to install Connect-It:

1 Insert the Connect-It installation CD into the CD-ROM. If the Connect-It 
installer does not start automatically, click Start > Run and type 
setup.exe. 

2 At the Welcome screen, click Next.

3 Accept the License Agreement and click Next.

4 Provide your customer information and click Next.

5 Choose the Typical option in the Connect-It setup screen and click Next.

6 Click Next to install to the default location, or click Change to install to a 
different directory.

7 Click Install.

8 Click Finish to complete the installation.

9 Copy the authorization code file to the Connect-It installation directory. 

HP Support provides a text file that contains an authorization code for 
Connect-It when you purchase DecisionCenter. If you receive an out-of-date 
license message, copy the contents of license.text and paste it in the 
Authorization Certificate dialog box.
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ServiceCenter 5.1: Connect-It requires some customization to support 
ServiceCenter 5.1. To customize Connect-It, follow these steps:

1 Rename this file in the Connect-It directory:

\\Programs\Peregrine\Connect-It 3.6.0en\config\sc\scdb51.cfg

2 Copy this file from the supplemental ServiceCenter 5.1 installation files: 
DCscdb51.cfg.

3 Rename DCscdb51.cfg to scdb51.cfg.

4 Rename this file in the DecisionCenter directory:

\\Programs\HP OpenView\DC\RDS_SC\cit\rds_sc.scn

5 Copy this file from the supplemental ServiceCenter 5.1 installation files: 
51rds_sc.scn.

6 Rename 51rds_sc.scn to rds_sc.scn.

Task 5: Prepare ServiceCenter or AssetCenter

Ensure that there is a ServiceCenter client on the same server where you 
install the ServiceCenter data warehouse. The following instructions are for 
ServiceCenter 6.1. 

Step 1: Verify That the ServiceCenter Client Is Installed and Available

1 From the Windows Start menu of the server where you will install the 
ServiceCenter data warehouse, click My Computer. 

2 Verify that there is a ServiceCenter Client entry and that you can start the 
ServiceCenter client.

3 The ServiceCenter client should have a configured connection to a 
ServiceCenter server, which may reside on a remote server. Click  
File > Connect > Connections to view the configured client/server 
connections.
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4 Locate the client/server connection information for the target 
ServiceCenter server. Click Connect to test the client/server connection. 
Record the host name and password for future reference. 

If you cannot locate server connection information, contact your ServiceCenter 
administrator.

Step 2: Import ServiceCenter Unload Files

Unload files contain records that you need to use ServiceCenter with 
DecisionCenter. The Data Warehouse for ServiceCenter media contains one 
required unload file. Your ServiceCenter user profile must have system 
administration rights to complete this procedure.

1 Navigate to this folder on the DecisionCenter installation media:

\\ITPA\ITPA-SM\SupportFiles\unload\

2 Copy DCA10.unl to your local hard drive.

ServiceCenter 5.1: If your version of ServiceCenter 5.1 cannot read 
DCA10.unl, copy BI51.unl, which is in the downloaded supplemental 
installation files, to your hard drive.

3 Start the ServiceCenter client that connects to the server where 
ServiceCenter is running.

4 From the ServiceCenter navigation pane, click Toolkit > Database Manager.

5 Right-click anywhere on the screen to open the pop-up menu.

6 Select Import/Load.

7 Click Browse to locate the files you copied to your local hard drive.

8 Select DCA10.unl to import.

9 Click Open.

10 Click Load FG on the toolbar. ServiceCenter displays a confirmation 
message.

11 Close the ServiceCenter client.

User name: falcon (out-of-box user)

Server host name: server_name

Server port number: 99999
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Step 3: Import AssetCenter Script Files

Script files contain records that you need to use for AssetCenter with 
DecisionCenter. The DecisionCenter installation media has one script file: 
dca.lst. The path to the script file is: 

\\ITPA\ITPA-AM\SupportFiles\import

Your user profile in AssetCenter must have system administration rights to 
perform the following procedure. The instructions are for the supported 
versions of AssetCenter. 

To import AssetCenter script files:

1 From the DecisionCenter installation media, copy this folder to your local 
hard drive:

\\ITPA\ITPA-AM\SupportFiles\import

2 Start the AssetCenter client that connects to the AssetCenter server.

3 Click File > Import.

4 Click Execute a Script.

5 Click Browse to locate the folder you copied to your local hard drive.

6 Change the Files of Type drop-down to All Files (*.*).

7 Select the dca.lst file.

8 Click Import.

9 Close the AssetCenter client.

Task 6: Install the Data Warehouse

Before you begin, ensure that HP OpenView Connect-It and the ServiceCenter 
or AssetCenter data warehouse are on the same server. 
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Step 1: Install and Configure JDBC Drivers

You need JDBC drivers on the data warehouse and DecisionCenter 
application servers for the ITPA and BIA installations. You also need JDBC 
drivers on the server that hosts the DecisionCenter Optimization engine for 
the Optimization installation. Oracle JDBC drivers are embedded in the client 
software installation. You can download the JDBC drivers for SQL Server 
from the Microsoft web site. JDBC drivers should reside in the following 
paths.  

DecisionCenter detects the location of the JDBC driver during the installation 
process.

If you do not have a database client installed on the DecisionCenter server, 
you can copy the JDBC drivers from the data warehouse server to the 
DecisionCenter server and store them in this directory:

\\...\Tomcat\common\lib

Check your database vendor licensing policies.

Sprinta is supported only for ITPA. For more information about JDBC drivers 
and Sprinta licenses, visit the Inetsoftware web site.

Step 2. Copy the Configuration File

Connect-it requires a ServiceCenter configuration to run ServiceCenter 
scenarios. From the DecisionCenter installation media, copy:

\\ITPA\ITPA-SM\SupportFiles\CIT\scdb61.cfg

Table 15 JDBC Driver Paths

Database Driver Type Default Path

Oracle JDBC c:\oracle\product\10.2.0\db_1\jdbc 
\lib\ojdbc14.jar 

Microsoft SQL Server JDBC c:\program files\Microsoft SqlServer\....

Microsoft SQL Server JDBC 
Sprinta (ITPA only)

c:\inet\Sprinta2000.jar 
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to your Connect-It installation directory:

\\Program Files\Peregrine\Connect-It 3.6.0 en\config\sc\config

Step 3: Install the Data Warehouse

Follow these steps to install the data warehouse:

1 Insert the data warehouse media in the CD-ROM drive. If the 
DecisionCenter installer does not start automatically, run setup.exe 
from the installation directory.

2 From the ITPA tab, click ITPA for SM.

3 Click Install Data Warehouse for ServiceCenter.

4 From the Welcome screen, click Next.

5 Accept the terms in the license agreement and click Next.

6 Do one of the following:

• Accept the default destination folder and click Next.

• Click Change to choose another folder. then click OK, and click Next. 
The installer searches for a Java Runtime Environment (JRE). If the 
installer locates a JRE, you can accept the JRE in that location. Or, 
click Change, choose another JRE, and click Next. 

7 Choose the type of database server for the data warehouse to use and 
click Next.

8 If you are using Microsoft SQL Server, you must specify the database 
driver. For more information about JDBC drivers, see Step 1: Install and 
Configure JDBC Drivers on page 48. Click Next. 

9 Accept the default folder where the JDBC driver jar files reside, or click 
Change and specify another folder. 

10 Click Next. 

11 Confirm or change the configuration information for the data warehouse 
and its user. You recorded this information in the Installation checklist: 

• Step 1a: Run the Oracle Configuration Script File on page 27.

• Step 2b: Configure the SQL Server on page 30.

• Step 3: Collect the User Information on page 31. 
ITPA Installation and Configuration 49



12 Click Next.

13 The installer displays the database configuration information. Click Next.

14 To accept the default JDBC configuration parameters, click Next. 

15 Accept or change the date parameters for your data warehouse server. 
These include the start year and stop year that the data warehouse uses 
for populating tables with data, and the month in which the fiscal year 
begins. 

16 Click Next.

17 Accept or change the name of the data warehouse log file. 

a Enable or disable the Cascade Delete feature.

b If your database is Microsoft SQL Server, choose Case Sensitive. 

18 Click Next. 

19 Specify the following parameters: 

— The hostname of the ServiceCenter server and its port number. 

— The ServiceCenter connection user name: bi-connector.  
This is the out-of-box database connection user name, not a 
ServiceCenter operator name.

— Omit a ServiceCenter connection password.  
The out-of-box database connection has no password.

For more information, see Step 1: Verify That the ServiceCenter Client Is 
Installed and Available on page 45. 

20 The installer displays the ServiceCenter configuration information. To 
accept these values and continue with the installation, click Next. To 
change any of these values, click Back. 

21 Click Install to begin the installation process. The installer reminds you 
that you must install the correct ServiceCenter unload files prior to 
beginning the data warehouse installation process. For more information, 
see Step 2: Import ServiceCenter Unload Files on page 46. 

22 Click OK.

23 The installation process can take several minutes. The installer displays 
its progress. 

24 Click Finish. 
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Update AssetCenter 5.0 Files

Before you complete the next step, you must update two out-of-box 
DecisionCenter files to support changes in AssetCenter 5.0. If you do not have 
AssetCenter 5.0 installed, you can proceed to Step 4: Run the HP OpenView 
Connect-It Scenario.

1 Contact HP OpenView support for instructions to download a replacement 
file: 50ac_bi.mpt.

2 Rename 50ac_bi.mpt to ac_bi.mpt.

3 Copy ac_bi.mpt.

4 Navigate to:

\\Program Files\HP OpenView\DC\RDS_AC\cit

5 Paste ac_bi.mpt into the cit folder to replace the original file.

To verify the rds_ac scenario is using the appropriate maptable, follow these 
steps: 

1 Click Start > Programs > Peregrine > Connect-It 3.6 > Connect-It 3.6 
Scenario Builder.

2 To open the rds_ac scenario, click File > Open and browse to: 

\\Program Files\HP OpenView\DC\RDS_AC\cit\rds_ac.scn

3 To verify the Maptable location, click Scenario > Maptables. If you do not 
see the ac_bi.mpt file listed, click  the Add File icon.

4 Browse to :

\\Program Files\HP OpenView\DC\RDS_AC\cit

5 Select the ac_bi.mpt file.

You must update the rdsac_etl.xml schema file to increase the size of the 
VALUE field in the AMITEMLISTVAL table to 80. 

1 Open this file with a text editor:

\\Program Files\HP OpenView\DC\RDS_AC\conf\rdsac_etl.xml

2 Change

<dimensionTableField name="VALUE" type="char" size="nn"/>

to

<dimensionTableField name="VALUE" type="char" size="80"/>
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3 Open your SQL Server or Oracle database. 

4 Edit the VALUE field in the AMITEMLISTVAL table, and change the 
Size/Length to a value of 80.

Step 4: Run the HP OpenView Connect-It Scenario

ServiceCenter 5.1: Before you run the scenario, open the new scenario in 
Connect.It Scenario Builder. 

1 Configure the ServiceCenter and RDS connectors appropriate to your 
system.

2 Select Tools > Open All Connectors. No error messages should appear.

3 Save the scenario.

DecisionCenter relies on ServiceCenter data; however, this data requires some 
customization and mapping into new tables that DecisionCenter needs. 
DecisionCenter relies on HP OpenView Connect-It to extract required 
ServiceCenter data and map it into these new tables.

The rds_sc.scn scenario collects ServiceCenter data and synchronizes it with 
the data warehouse. It can take several hours to execute when there is a large 
quantity of data. If you have a large amount of ServiceCenter data, enable the 
RDS connector setting “Enable on initial import” before you run the 
Connect-It scenario. It is important that you do not change the connector 
names defined in data warehouse Connect-It scenarios. Follow these steps to 
run the scenario:

1 From the Windows Start menu, click Programs > Peregrine > 
Connect-it 3.6.0 en > Service Console.

2 The Service Console should be pointing to this scenario file:

\\Program Files\HP OpenView\DC\RDS_SC\cit\rds_sc.scn 

3 Click Start.

Immediately after the initial data synchronization completes, it is 
recommended that you back up your database. This can be crucial when the 
synchronization takes a long time, and you need to restore the data.
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Step 5: Populate the OPERATOR_ADDL Table

You must populate this table manually with data for each of these fields:

• OPERATOR_ADDL_ID

• NAME

• TERMINATION_DATE

Ensure that the NAME field is unique.

Task 7: Install DecisionCenter

The DecisionCenter application provides the basic tier functionality for 
DecisionCenter IT Performance Analytics.

Step 1: Install the DecisionCenter Application

The DecisionCenter application is a web archive (WAR) file on the 
DecisionCenter installation media. The installation process prompts you to 
store the WAR file in the appropriate web server directory. The web 
application server, Apache Tomcat, will deploy the file. Before you begin, 
ensure that you have a valid authorization code. If necessary, contact HP 
Software Support. Follow these steps to install the DecisionCenter 
application:

1 Insert the DecisionCenter installation media into your CD-ROM drive.

2 The installation begins automatically. If necessary, you can start the 
installation from Autorun.exe on the DecisionCenter installation media.

3 From the ITPA tab, click Web Application. 

4 Click Download DecisionCenter Web Interface.

5 Copy decisionCenter.war and paste it into your web server 
deployment folder. The web server deploys the WAR file automatically 
when you start the application. For example, you might paste it into:

\\Program Files\BusinessObjects\Tomcat 5.x\webapps
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6 Back up this directory before you proceed to the next step:

\\Program Files\BusinessObjects\Tomcat 5.x\conf\Cataline\localhost

Step 2: Configure LDAP

1 From the Windows Start menu, click Control Panel > Services and stop the 
Apache Tomcat service.

2 Navigate to this file:

\\...\Tomcat\webapps\decisionCenter\WEB-INF\jaas.config

3 Change the following settings to reflect your LDAP configuration:

— user.provider.url

— security.principal

— security.credentials

— group.provider.url

For example: 

dpJndi {

com.peregrine.shared.security.jaas.JndiLoginModule required 
user.provider.url="ldap://cmldap01.labs.peregrine.com:60339/
     ou=people,dc=labs,dc=peregrine,dc=com" 
security.principal="uid=admin,ou=administrators, 
     ou=topologymanagement,o=netscaperoot" 
security.credentials="falc0n"

group.provider.url="ldap://cmldap01.labs.peregrine.com:60339/
     ou=groups,dc=labs,dc=peregrine,dc=com" 
group.search.objectClass="groupOfUniqueNames";

};

4 Save and close the file.
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Step 3: Configure JNDI for Tomcat

1 Navigate to this directory:

\\Program Files\BusinessObjects\Tomcat 5.x\conf 

2 Open tomcat-users.xml with a text editor. Verify that Tomcat has an 
entry to configure admin and manager user roles. If necessary, edit the file 
to include these lines:

<role rolename=”admin”/>
<role rolename=”manager”/>
<user username=”admin” password=”admin” roles=”admin”/>
<user username=”manager” password=”manager” roles=”manager”/>

3 Save tomcat-users.xml.

4 From the Windows Start menu, click Control Panel > Services and start the 
Apache Tomcat service.

5 Start a Microsoft Internet Explorer browser session.

6 Type http://host-name:port_number in a browser to display the 
Tomcat Home page. For example, you might type http://server_name:8080.

7 In the Administration section, click Tomcat Administration.

8 Type the User Name and Password for the admin user that you configured 
in Step 2. In this example, the User Name would be admin and the 
Password would be admin.

9 Expand the Tomcat Server > Service (Catalina) > Host > 
Context (/decisionCenter) > Resources nodes.

10 Click Data Sources to view the configured JNDI entries for the 
decisionCenter context.

11 From the drop-down Available Actions list, select Create New Data Source.
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12 Type values for the JNDI parameters. The following table shows 
examples; however, they must match your local configuration. For exact 
values, see your database administrator.

13 Click Save.

14 Click Commit Changes. The Tomcat server saves the changes and redeploys 
the DecisionCenter application. 

15 Click Log Out.

16 To verify that the DecisionCenter application deploys correctly, return to 
the Tomcat Home page (http://host-name:port_number)using the 
same browser session.

17 Click Tomcat Manager. 

Table 16 JNDI Parameters

Parameter Suggested Value

JNDI Name: jdbc/dc 
(This is a required value)

Data Source URL: 

• SQL Server:
• Oracle:

Examples (verify your local URLs):
• jdbc:microsoft:sqlserver: //sqlserverHost:1433
• jdbc:oracle:thin:@server_name:1521:ORCL

JDBC Driver Class:

• SQL Server:
• Oracle:

Examples (verify your local URLs):
• com.microsoft.jdbc.sqlserver.SQLServerDriver
• oracle.jdbc.driver.OracleDriver

User Name: rds_dba

Password: passw0rd

Max. Active Connections: 50

Max. Idle Connections: 10

Max. Wait for Connection: 10000

Validation Query: 
(Optional)
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18 Type the User Name and Password for the manager user that you 
configured in Step 2. In this example, the User Name would be manager 
and the Password would be manager.

19 Verify that the DecisionCenter application listed in Applications has a 
value of true in the Running column. If not, click Start in the Command 
column.

Task 8: Install ITPA Content

Before you begin, ensure that you install BusinessObjects Enterprise XI R2, 
configure the BusinessObjects Enterprise XI Central Management Server 
database (cmsdb), and install and configure the AssetCenter data warehouse. 
The following steps describe how to install HP OpenView AssetCenter and 
HP OpenView ServiceCenter content.

Step 1: Install the AssetCenter Universes, Reports, and Views

If you have only HP OpenView ServiceCenter, you can skip this step and 
proceed to Step 2: Install the ServiceCenter Universes, Reports, and Views on 
page 59.

Import the AssetCenter Reports and Universes

1 Create a local directory where you can copy the import files. For example, 
create a new root directory named DecisionCenter_files.

2 From the DecisionCenter installation media, navigate to this folder:

\\ITPA\ITPA-AM\ITPA_Asset_Management

3 Copy the contents of \\ITPA_Asset_Management to the local directory 
you created in Step 1. For example, your local folders would look like this:

\\DecisionCenter_files\ITPA_Asset_Management

4 Unzip this file into the AssetCenter directory using the provided 
authorization code:

\\DecisionCenter_files\ITPA_Asset_Management\AssetCenter 
\AssetCenter.zip
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5 Open this file with a text editor:

\\DecisionCenter_files\ITPA_Asset_Management\itpa_am.bat

6 Replace these variables with the values that are correct for the device 
where you installed BusinessObjects Enterprise XI R2. Save the file.

7 Run the batch program using Windows Explorer or from a Windows 
command prompt. Follow the instructions.

Update the AssetCenter Universe Database Connections

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Designer.

2 Log on as Administrator with no password.

3 Create a new connection, as necessary, to your data warehouse.

4 Click File > Import. 

5 Click the Universes folder from the Folder drop-down list. 

6 Select the ITPA Asset Management universe to import.

7 Click OK.

8 When a success message appears, click OK.

Table 17 AssetCenter Variables

Variable Example

BUSOBJ_HOME= C:\Programs\BusinessObjects\

DC_HOME C:\DecisionCenter_files\ 

CMS_NAME_PORT host_name:6400 
6400 is the default BusinessObjects 
Enterprise XI port number

CMS_USER Administrator

CMS_PASSWORD <blank>

JAVA_HOME %BUSOBJ_HOME%/j2sdk1.4.2_08
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9 Click File > Export.

10 Verify that any exported universe has the same directory destination. 

Step 2: Install the ServiceCenter Universes, Reports, and Views

This section describes how to install the Service Management, Incident and 
Help Desk, and Service Level Management reports and universes. If you have 
only AssetCenter and you do not plan to use DecisionCenter Business Impact 
Analysis or DecisionCenter Optimization, you can skip this step.

Verify that the ServiceCenter Views are Configured

1 Identify a local directory where you can copy the import files. For example, 
DecisionCenter_files.

2 From the DecisionCenter installation media, copy 
\\ITPA\ITPA-SM\SupportFiles\DatabaseFiles\itpa_dcviews_oracle.sql 
or 
\\ITPA\ITPA-SM\SupportFiles\DatabaseFiles\itpa_dcviews_sqlsrvr.sql 
to a folder on your local hard drive.

3 Save the file and run the script. For example, to run the script using SQL 
Server Query Analyzer:

a Copy the contents of the modified script.

b Click Start > Programs > Microsoft SQL Server > Query Analyzer.

c Log on with the User name rds_dba.

d Paste the contents in the Query window.

e Click Query > Execute.

Define the Calendars

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log on as Administrator with no password.

3 Click Go to Performance Management > Performance Management > Setup > 
Time Config > Calendar. 
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4 Click Add to create new calendars called Monthly Calendar, Scenario 
Daily Calendar, and Quarterly Calendar.

Define the ServiceCenter Reports and Universes

1 Create a local directory where you can copy the import files. For example, 
create a new root directory named DecisionCenter_files.

2 From the DecisionCenter installation media, navigate to this folder:

\\ITPA\ITPA-SM\ITPA_Service_Management

3 Copy the contents of \\ITPA_Service_Management to the local directory 
you created in Step 1. For example, your local folder would look like this:

\\DecisionCenter_files\ITPA_Service_Management

4 DecisionCenter offers multiple analytic packages that are require 
authorization codes. For each analytic package that you purchased, unzip 
the file into the ITPA_Service_Management\... directory using the 
applicable authorization code. The complete set contains these zip files:

\\...\ITPA_Service_Management\Help_Desk\Help_Desk.zip

\\...\ITPA_Service_Management\Incident\Incident.zip

\\...\ITPA_Service_Management\Service_Level_Management 
\Service_Level_Management.zip

\\...\ITPA_Service_Management\ServiceCenter\ServiceCenter.zip

Table 18 New Calendars

Calendar Name Interval
Duration Display

Show              Format
Calendar 
Span

Monthly Calendar Monthly First Day of Period Sep-06 User-defined 

Scenario Daily 
Calendar

Daily First Day of Period 9/21/
04

User-defined 

Quarterly 
Calendar

Quarterly First Day of Period Q3-04 User-defined

The calendar start date and end date in the Calendar Span dialog 
box must reflect the time periods for which you have data.
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5 Open this file with a text editor:

\\...\ITPA_Service_Management\itpa_sm.bat

6 Replace these variables with the values that are correct for the device 
where you installed BusinessObjects Enterprise XI R2. 

7 Save the file.

8 Run the batch program using Windows Explorer or from a Windows 
command prompt. Follow the instructions.

Update the ServiceCenter Universe Database Connections

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Designer.

2 Log on as Administrator with no password.

3 Create a new connection, as necessary, to your data warehouse.

4 Click File > Import. 

5 Click the Universes folder from the Folder drop-down list. 

6 For each analytic package that you purchased, click Browse and select the 
universes to import.

Table 19 ServiceCenter Variables

Variable Example

BUSOBJ_HOME= C:\Programs\BusinessObjects\

DC_HOME C:\DecisionCenter_files\

CMS_NAME_PORT host_name:6400 
6400 is the default BusinessObjects 
Enterprise XI port number

CMS_USER Administrator

CMS_PASSWORD <blank>

JAVA_HOME %BUSOBJ_HOME%/j2sdk1.4.2_08
ITPA Installation and Configuration 61



For Help Desk, select:

— ITPM Helpdesk Analysis

— ITPM Helpdesk Metrics

For Incident, select:

— ITPM Incident Analysis

— ITPM Incident Metrics

For Service Level Management, select:

— Alignment Analysis

— Alignment Metrics

For ServiceCenter

— ITPA Service Management

7 Click OK.

8 For each universe, do the following:

a Click File > Parameters. 

b On the Definition tab, select your database connection from the 
drop-down Connection list. For example, select rdsdb.

c Click the Parameter tab.

d Select the ANSI92 parameter and change No to Yes.

e Click Replace.

9 Click File > Export. 

10 Verify that any exported universe has the same directory destination.

Add and Update the Metric Universes in Performance Management

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log on as Administrator with no password.

3 Click Go to Performance Management.

4 Click Setup on the Toolbar.
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5 Click the System Setup tab.

6 Click Universes.

7 Click Add Universe.

8 From the drop-down Measure Universe list, select each metric universe and 
click OK.

• ITPM Helpdesk Metrics

• ITPM Incident Metrics

• Alignment Metrics

Each metric universe should appear in the Universe Definition window.

9 For each new metric universe, click the universe name and select the 
Update Metrics and Control Charts Definitions check box.

10 Click Update. You should see a list of Available Objects in the lower left 
corner.

Run the PMDT Tool

This step extracts the XML source file of metrics to the target machine.

1 Use the Windows command line to locate and run this batch file:

run_DeploymentTool_PSO.bat 

2 When the Performance Management Deployment Tool appears, click Next.

3 Click the Source File radio button and click Browse.

4 Navigate to the ITPA metrics file:

\\ITPA_Service_Management\itpa_sm_metrics.xml

5 For each analytic package that you purchased, select the appropriate 
metrics. Ensure that you do not select the metrics for uninstalled 
packages.

If you do not see a connection name listed next to your universe:

a Log onto Designer.

b Verify that the universe has the correct connection 
parameters.

c Export the universe.
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For Help Desk, select:

Check UNIVERSE: ITPM Helpdesk Metrics

For Incident, select:

Check UNIVERSE: ITPM Incident Metrics

For Service Level Management, select:

Check UNIVERSE: Alignment Metrics

6 On the Export screen, click Target Repository and specify the Target CMS 
repository, the username, and password.

7 Click Export. The Check Screen returns success messages for the assets 
that added to the target repository.

8 Click Close.

9 Return to the command window. Follow the instructions to complete the 
session and close the window.

Set the Database ID at 6000

This is an important step, but you can do it only once. Omit this step in the 
future if you run the PMDT again to extract an XML file.

It is important to reserve the 5000 series IDs tagged for each metric. This step 
sets the cursor ID in your database at 6000. Future metrics will use numbers 
6000 and above.

1 Use the Windows command line to locate and run this batch file:

run_DeploymentTool_PSO.bat 

2 When the Performance Management Deployment Tool appears, click Next.

3 Type your host_name:6400 in the CMS text box.

4 Click ID Reservation.

5 Select Increment Manually. 

6 Change the value for each of these cursors to begin at 6000:

— New Metric Cursor

— New Probe Dimension Cursor

— New Goal Cursor
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— New Goal Type Cursor

— New Metric Tree Cursor

7 Click Apply.

8 Exit the Performance Management Deployment Tool.

Refresh the Data

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log on as Administrator with no password.

3 Click Go to Performance Management.

4 Click Setup on the toolbar.

5 Click the System Setup tab.

6 Click Dimensions.

7 Select an existing Dimension in the upper text box and click Edit 
Dimension.

8 Click Next.

9 Click Refresh.

10 Click Next.

11 Click END.

12 Repeat Step 7 – Step 11 for all dimensions.

13 Click Go To Performance Management.

14 Click Dashboard Manager.

15 Click the Metrics tab.

16 Click the Refresh icon next to the Available Metrics to refresh the list of 
metrics.

17 Select Call Metrics and Dimensions from the Available Metrics drop-down list.

18 For each category listed, select the metric.

19 Click the Purge icon, then the Refresh icon.
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20 When this warning appears, “This operation can be very long. Do you want 
to continue,” click OK. 

21 Repeat Step 17 – Step 20 to refresh other metrics in the list.

Each metric will refresh and when the process is complete, you can see a Last 
Refresh Date in the Metric History section.

Verify the Installation Success

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Central 
Management Console.

2 Navigate to Folders. You should see a list of the DecisionCenter folders 
and objects: 

• ITPA Service Level Management

• ITPA Asset Management

• ITPA Help Desk

• ITPA Incident

• ITPA Service Management

3 Expand each folder to see the list of available objects. For example, if you 
expand ITPA Help Desk, you should see:

• Average Call Volume by Day

• Average Call Volume by Hour

• Call Receiving Summary

• First Call Resolution

• First Call Resolution Details

• Staff Turnover

4 From the Central Management Console Home page, navigate to Universes 
to view the data warehouse and ITPM universes.
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Step 3: Configure Reports for ServiceCenter 5.1

DecisionCenter 1.0 out-of-box reports expect ServiceCenter 6.1 data. They 
display no results when you have ServiceCenter 5.1 data. When your 
Connect-It scenario finishes running, you should review and refresh all 
reports. The following reports will return no data:

• Alignment Reports

— Variable Service Costs by SLA and CI 

— Variable Service Costs by SLA, CI, and Cost Category

• ITPA Service Management 

— Configuration Items by Age 

— Economic Impact of SLA Failure

— Recurrent Outages

— SLA Availability Successes

— SLA Response Time Successes

Recurrent Outages and  SLA Response Time Success reports can produce 
results if you implement the following workaround.

ServiceCenter 5.1 Workaround for Recurrent Outages

The links between the outage and outagedetail tables changed in 
ServiceCenter 6.x. Follow these steps to create a workaround.

1 Edit the report using BusinessObjects InfoView.

2 Select the Edit Query tab.

3 Click View SQL.

4 Select Use Custom SQL. 

5 Edit the following SQL statements to remove the boldface text.

SELECT
  DEVICE_D.LOGICAL_NAME,
  DEVICE_D.TYPEPRGN,
  DEVICE_D.MODEL,
  DEVICE_D.SUBTYPE,
  DEVICE_D.VENDOR,
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  DEVICE_D.ASSET_TAG,
  DEVICE_D.MANUFACTURER,
  RDS_TIMEDIM_D.MONTH,
  RDS_TIMEDIM_D.WEEK,
  count(distinct(OUTAGE_F.Z_RDSOUTAGE_DID)),
  OUTAGE_D.OUTAGE_START
FROM
  DEVICE_D,
  RDS_TIMEDIM_D,
  OUTAGE_F,
  ( 
  Select OUTAGEDETAIL.* , SLOAVAIL_D.SLO_ID AS SLO_ID2 from 
OUTAGEDETAIL,SLOAVAIL_DWhere OUTAGEDETAIL.SLO_ID = 
SLOAVAIL_D.SLO_ID
  )  OUTAGEDETAIL_DR,
  OUTAGE_D,
  DEVICE_F
WHERE
  ( DEVICE_F.Z_RDSDEVICE_DID=DEVICE_D.Z_RDSDEVICE_DID  )
    AND  ( OUTAGEDETAIL_DR.OUTAGE_ID=OUTAGE_D.OUTAGE_ID  )
  AND  ( OUTAGE_D.Z_RDSOUTAGE_DID=OUTAGE_F.Z_RDSOUTAGE_DID  )
  AND  ( 
DEVICE_F.INSTALL_DATEID=RDS_TIMEDIM_D.RDS_TIMEDIM_DID  )
  AND  ( OUTAGE_F.Z_RDSDEVICE_DID=DEVICE_D.Z_RDSDEVICE_DID  )
  AND  ( OUTAGE_F.Z_RDSOBSOLETEIND  =  'N' AND 
OUTAGEDETAIL_DR.LOGICAL_NAME = DEVICE_D.LOGICAL_NAME  )
GROUP BY
  DEVICE_D.LOGICAL_NAME, 
  DEVICE_D.TYPEPRGN, 
  DEVICE_D.MODEL, 
  DEVICE_D.SUBTYPE, 
  DEVICE_D.VENDOR, 
  DEVICE_D.ASSET_TAG, 
  DEVICE_D.MANUFACTURER, 
  RDS_TIMEDIM_D.MONTH, 
  RDS_TIMEDIM_D.WEEK, 
  OUTAGE_D.OUTAGE_START

6 Save the report.
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ServiceCenter 5.1 Workaround for SLA Response Time Successes

The response time average is a decimal value in ServiceCenter 5.x. Therefore, 
the chart values are 1/100th of the correct value. Follow these steps to create a 
workaround.

1 Edit the report using BusinessObjects InfoView.

2 Edit the properties of the chart.

3 Edit the property Y-Axis > Values > Format. 

4 Select type Number and use the percentage format.

5 Edit the property Y-Axis > Scale > Max Value.

6 Set the value to 1.

7 Save the report.

Task 9: Verify the DecisionCenter Installation

1 Start a second browser session and type  
http://host-name:port_number/decisionCenter to verify that 
DecisionCenter starts successfully.

2 Log in with your user name and password.

3 Expand any of the following nodes in the navigation tree:

— Asset Management

— Help Desk

— Incident

— Service Level Management

— Service Management

4 Click any report name to establish a BusinessObjects connection and view 
the ITPA analytic.

The

The information in the URL is case-sensitive.
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Refreshing the Data

HP OpenView Connect-It automatically schedules the data synchronization 
scenario to run daily on a 24-hour schedule. The amount of time required to 
synchronize the data depends on the volume of data to be processed and the 
capacity of your server. Ensure that you schedule the synchronization to occur 
during off-peak hours when the server has no other demands.
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4 BIA Planning and Installation
There are two possible user scenarios when you install the DecisionCenter 
Business Impact Analytics (BIA) tier. In the first case, your objective is to add 
Business Impact Analytics and views to enrich your reporting resources. The 
BIA tier provides more analytics that enrich your business analysis 
capabilities. These new analytics provide information about:

• Business service downtime impact 

• CI type downtime impact

• Downtime Impact by business service and value center

 If this is your only objective, you can safely skip many of the tasks and steps 
in this chapter and complete the installation quickly. These tasks are clearly 
marked as Optimization Only tasks.

In the second case, your objective is to add the Optimization tier, create an 
historical incident cost baseline, and run new what-if scenarios to project the 
cost of new business services and resource allocation. In addition to the ITPA 
and BIA analytics, you will add these BIA features that position you to run 
full optimization scenarios when you install Optimization:

• Data Mining tool

• Business and Environment models

• Impact definition 

• Impact Calculator

• History Builder

If this is your objective, ensure that you complete every task and step in this 
chapter, including those marked Optimization Only.
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Prerequisites

Before you begin, ensure that you complete all the installation tasks in 
Chapter 3, ITPA Installation and Configuration. The data mining tasks 
assume that you have some ServiceCenter Administration knowledge and 
that you are skilled at running SQL queries.

DecisionCenter supports both Microsoft SQL Server and Oracle for ITPA 
installations. DecisionCenter supports only Microsoft SQL Server if you add 
BIA and Optimization. Ensure that you consult the DecisionCenter Support 
Matrix on the HP Software Support web site for the supported versions of 
these products. 

Data Analysis

The most time-consuming steps to prepare for DecisionCenter BIA and 
Optimization are the preparation activities for existing data, and decisions 
required to populate new tables and fields with new data. For example, 
DecisionCenter requires that each incident be associated with a business 
service or value center. Existing incident data may not have those association 
built into each incident record. For BIA and Optimization, you must create 
those associations.

Here is checklist of decisions and data preparation decisions. You may require 
the combined expertise of a ServiceCenter Administrator, Database 
Administrator, and Professional Services personnel to arrive at the decisions 
and complete the required actions.

Business Services and Value Centers

DecisionCenter BIA and Optimization relies heavily on the concepts of 
business services and value centers. Ensure that you understand how they 
impact your organization and daily activities.
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Business Services

A business service is the combination of one or more business applications 
plus the supporting Configuration Items that enable delivery of the business 
service to the customer. The products that IT offers its customers are internal 
and external business services. Business services often have one or more 
associated value centers. A Claims service is an example of a business service; 
Claims entry, Claims processing, and Claims arbitration are examples of 
value centers that support the Claims business service.

Enterprise resource planning (ERP) is a good example of a business service. 
ERP is a business management system that integrates all facets of the 
business, including planning, manufacturing, sales, and marketing. There can 
be many component business applications such as inventory control, order 
tracking, customer service, finance, and human resources.

Value Centers

A value center is that part of your business that provides a product or service 
to an internal or external customer. It can be an entire business unit, a cost or 
profit center, or a functional department. It is an entity that adds value 
directly, or indirectly, to your customer community. An enterprise business 
service can have multiple associated value centers. A Claims service is an 
example of a business service; Claims entry, Claims processing, and Claims 
arbitration are examples of value centers that support the Claims business 
service.

It is easy to see that any revenue producing business unit can be described as 
a value center. However, cost centers also affect corporate value. For example, 
a finance department is a value center. It does not sell a product to an external 
customer, but its forecasts, balance sheets, public statements and other 
outputs affect the profitability of the enterprise.

IT is another example of a value center. How effectively it meets its Service 
Level Agreements obligations affects the performance and profitability of the 
customers that it serves.
BIA Planning and Installation 73



Data Analysis Checklist

Gathering this information may be the most difficult aspect of preparing for 
the actual installation. These are business decisions that require a broad 
range of business expertise at the operational and executive levels. It is 
advisable to consult these experts before you translate these decisions into 
physical data.

What is the range of data that I want to work with? Should it extend over 
a month, a quarter, or a year?

What is the beginning date of relevant incidents?

What are your identifiable business services? This needs to be a specific 
list, preferably in a database table. You may need to import this 
information into the DecisionCenter data warehouse.

Which Configuration Items impact each business service when an outage 
occurs?

What are your identifiable value centers? This needs to be a specific list, 
preferably in a database table. You may need to import this information 
into the DecisionCenter data warehouse.

The answers to these questions will help you customize the ETL and data 
analysis processes for your organization.
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BIA Installation Checklist

Print this checklist to use during the installation process. As you complete 
each task, check it as completed. 

Task 1: Back Up the Data Warehouse on page 77.

Task 2: Create BIA Tables and Views on page 77.

— Step 1: Gather the Database Connection Information on page 77.

— Step 2: Run the SQL Server Configuration Script File on page 78.

Task 3: Install BIA Component Files on page 79.

— Step 1: Run the Installer on page 79.

— Step 2: Verify the BIA Installation on page 79.

Task 4: Extract the ServiceCenter Data on page 80.

— Step 1: Customize the ServiceCenter-to-DC Scenario on page 81.

— Step 2: Run the ServiceCenter-to-DC Scenario on page 82.

Task 5: Prepare the Data on page 82.

— Step 1: Identify the Target Range for Your Data on page 83.

— Step 2: Create the Problem PREP View on page 84.

— Step 3: Populate the Assignment Group PREP Table on page 84.

— Step 4: Populate the Operator PREP Table on page 86.

— Step 5: Populate the Assignment Transition PREP Table on page 88.

— Step 6: Populate the Business Service CI PREP Table on page 91.

— Step 7: Populate the Business Service Incident PREP Table on 
page 91.

Complete Tasks 1–8 on the DecisionCenter data warehouse server. For more 
information, see the distributed server configuration diagram on page 23. 
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— Step 8: Populate the Incident Exclusion PREP Table (Optimization 
Only) on page 92.

— Step 9: Populate the Assignment Shift PREP Table (Optimization 
Only) on page 92.

Task 6: Compute Time-to-Next-Incident (Optimization Only) on page 94.

Task 7: Customize the Data Mapping on page 95.

— Step 1: Customize Business Services Mapping on page 95.

— Step 2: Customize Organization Mapping on page 97.

— Step 3: Customize Value Center Mappings on page 98.

— Step 4: Customize Labor Cost Information on page 99.

— Step 5: Customize Incident Mapping on page 100.

— Step 6: Customize SLO Mapping on page 100.

Task 8: Load the DecisionCenter Tables on page 102.

— Step 1: Create Business Service and CI Types on page 102.

— Step 2: Load Data into the DecisionCenter Tables on page 102.

— Step 3: Run the Data Cleanup SQL Script File on page 103.

Task 9: Install BIA Content on page 103.

— Step 1: Define the Calendars on page 104.

— Step 2: Define the BIA Reports and Universes on page 104.

— Step 3: Update the BIA Universe Database Connections on page 105.

— Step 4: Add and Update the Metric Universes on page 106.

— Step 5: Run the PMDT Tool on page 107.

— Step 6: Refresh the BIA Metrics on page 108.

Task 10: Verify the BIA Installation on page 109.

Complete Task 9 on the BusinessObjects Enterprise XI server.

Complete Task 10 on the workstation that is network connected to the 
DecisionCenter application server.
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Task 1: Back Up the Data Warehouse

Before you begin the BIA installation process, ensure that you back up the 
data warehouse that you installed and configured on the data warehouse 
server.

Task 2: Create BIA Tables and Views

Complete this task on the data warehouse server to create the additional 
tables and views for BIA.

Step 1: Gather the Database Connection Information

During the installation, you must provide information about the data 
warehouse that you built during the ITPA installation. The following table 
lists the configuration information and user identification that you must 
provide during the BIA installation. 

Table 20 Required BIA Installation Information

Required Information
 MS SQL 
Default Value Your Value

Host name of the RDBMS 
server

None your_machine_name

RDBMS server port 
number

1433

Database name rdsdb

DSN Alias rdsdb

User name rds_dba

Password passw0rd

Host name of the 
ServiceCenter server

None your_machine_name
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Step 2: Run the SQL Server Configuration Script File

Follow these steps to create BIA tables and views on the Microsoft SQL Server 
data warehouse server:

1 Identify a local directory where you can copy the script file. For example, 
DecisionCenter_files.

2 From the DecisionCenter installation media, copy the following file from 
this folder on your local hard drive:

\\BIA\SupportFiles\DatabaseFiles\rds_bia_mssql.sql

3 The BIA installation process populates the business_service_type and 
configuration_item_type tables with sample data. If your ServiceCenter 
environment already has content in these tables, you should edit the 
configuration script to remove the SQL statements that populate these 
tables. Otherwise, the demo data will replace your real data. To modify the 
script, remove any statements for the business_service_type and 
configuration_item_type tables.

4 Save the file.

5 Run the script. For example, to run the script using SQL Server Query 
Analyzer:

a Copy the contents of the rds_bia_mssql.sql script.

b Click Start > Programs > Microsoft SQL Server > Query Analyzer. 

ServiceCenter server port 
number

12670

ServiceCenter connector 
user name

bi_connector

ServiceCenter connector 
password

None

Table 20 Required BIA Installation Information

Required Information
 MS SQL 
Default Value Your Value
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c Ensure that you log in with the DecisionCenter user name that 
enables you to access the DecisionCenter schema and that the current 
database is the DecisionCenter database. The script will populate the 
tables in that schema.

d Paste the contents in the Query window.

e Click Query > Execute.

Task 3: Install BIA Component Files

The BIA installation provides the files to create HP OpenView Connect-It 
services for BIA scenarios, and configure the scenario connections. It also 
installs the Data Mining tool and the History Builder.

Step 1: Run the Installer

Before you begin, ensure that you have a valid authorization code. If 
necessary, contact HP Software Support.

1 Insert the DecisionCenter installation media into your CD-ROM drive.

2 The installation begins automatically. If necessary, you can start the 
installation from Autorun.exe on the DecisionCenter installation media.

3 Click the BIA tab.

4 Click Install BIA Component Files.

5 Follow the installation prompts to install the BIA components.

Step 2: Verify the BIA Installation

You can verify the results by checking the installation directory. The default 
path is:

\\Program Files\HP OpenView\DC\BIA
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If you customized the installation path, navigate to the 
HP OpenView\DC\BIA folder. Ensure that you have these folders:

• cit

• DataMining

• logs

Task 4: Extract the ServiceCenter Data

When you installed ITPA, HP OpenView Connect-It extracted the 
ServiceCenter data required for the ITPA tier. When you add the BIA tier, you 
must use Connect-It again to extract the additional data required for the 
BIA tier. 

Most of the incident-related data that DecisionCenter uses comes from the 
following ServiceCenter tables.

Table 21 ServiceCenter Data Sources

ServiceCenter 
Table Name

Type of 
Information Description

assignment Work groups Identifies the names of and members of 
work (assignment) groups.

calholidays Holiday 
schedules

Identifies the days that are designated 
holidays.

caldutyhours Work 
schedules

Identifies the start and stop times for 
defined work schedules.

clocks Time zone Identifies available time zones.

contacts Contact Lists the name, address, and related 
contact information of all ServiceCenter 
customers and users.
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Step 1: Customize the ServiceCenter-to-DC Scenario

If you make any customization to the dco_sc.scn scenario file, use HP InfoView 
Connect-It to change the mappings in the scenario before you proceed to the 
next step.

dept Department Lists all of the departments in the 
organization. These departments define 
Service Level Agreements (SLAs), Service 
Level Objectives (SLOs), and can map to 
business services. Department data is 
used to directly populate the value center 
table with default values.

device Configuration 
Items

Lists the hardware and software 
components managed by IT.

operator Authorized 
users

Lists all authorized ServiceCenter 
technicians, administrators, and 
operators and their permission levels.

probsummary Incidents Contains all the information about 
incidents and outages.

problem Problems Contains all the information about known 
problems, workarounds, and resolution.

sla Service Level 
Agreements

Contains the information about SLAs and 
associated SLOs.

slo Service Level 
Objectives

Contains the information about each SLO 
and associated SLAs.

Table 21 ServiceCenter Data Sources

ServiceCenter 
Table Name

Type of 
Information Description
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Step 2: Run the ServiceCenter-to-DC Scenario

This scenario collects the additional ServiceCenter data and synchronizes it 
with the data warehouse.

1 From the Windows Start menu, click Programs > Peregrine > 
Connect-it 3.6.0 en > Service Console.

2 The Service Console should point to this scenario file:

\\Program Files\HP OpenView\DC\BIA\cit\dco_sc.scn 

3 Click Start.

It can take several hours to execute if there is a large quantity of data. You 
may want to edit the dco_sc scenario to focus only on a range of data instead of 
all incident data. Immediately after the initial data synchronization 
completes, it is recommended that you back up your database. This can be 
crucial when the synchronization takes a long time, and you need to restore 
the data.

Task 5: Prepare the Data

There are several steps to follow in this preparation phase that load data into 
DecisionCenter PREP tables. These are new tables that contain specialized 
ServiceCenter data that has a specific purpose in BIA and Optimization. Each 
of the new tables contains data that is essential to advanced analysis, 
simulation, and optimization activities. In some cases, you will extract data 
from a native ServiceCenter field and populate a new field in a PREP table. In 
other cases, you will collect certain data from diverse ServiceCenter tables 
into a single new PREP table.

The DecisionCenter Data Mining Tool

The Data Mining tool helps you extract some of the required data and 
populate the new BIA tables. If you have a large volume of legacy data, or 
other complexities, you may require assistance from HP Professional Services.
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The BIA installation creates a DataMining folder with four sub-folders:

• bin contains the batch files that start the data mining utilities.

• config contains the database and application configuration files.

• lib contains the Java libraries used by the data mining utilities.

• sql contains template files for SQL statements.

Step 1: Identify the Target Range for Your Data

This is a business decision. Evaluate the time period that you want to see 
represented in the results. DecisionCenter will use all the ServiceCenter data 
related to an incident, such as clock time, problem records, service level 
agreements, and so on. 

For BIA, you must choose a start date for the period of time included in the 
historical impact analysis. For Optimization, you must choose a start date 
that encompasses incidents representing your current incident workflow. For 
example, if you made process or workflow changes that affect the elapsed time 
until an incident closes, you might want to use only incidents opened after the 
process or workflow changes occurred. 

If the BIA starting date and the Optimization starting dates are different, and 
you plan to run Optimization simulations, choose the most recent as the single 
start date.

The resulting incident pool must contain one or more months of meaningful 
data to produce reliable results. It must also include the following attributes 
to calculate a meaningful historical impact analysis. 

• The PROBSUMM_D table must contain all the incidents:

— Open on or after the selected date.

— Open before and on the selected date.

• The PROBLEM and CLOCK_EVENTS tables must contain complete 
information about these incidents. 

You must set this date in the SQL script that extracts the relevant data.
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Step 2: Create the Problem PREP View

You can create the PREP_PROBSUMM_V view using SQL statements that 
you can find in the SQL templates file. 

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media. 

For MicroSoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

2 Search for the General Settings section that begins with 
$NAME=CREATE_VIEW.

3 Change the @startSet variable to the date that you chose in Step 1: 
Identify the Target Range for Your Data on page 83. For example:

SET @startSet = '2005-01-01';

where the date format is yyyy-mm-dd.

4 Run the SQL statements to create the PREP_PROBSUMM_V view.

Step 3: Populate the Assignment Group PREP Table

The PREP_ASSIGNMENT_GROUP table is populated using SQL statements 
that you can find in the SQL templates file. 

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media. 

For MicroSoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

2 Search for the Updating PREP_ASSIGNMENT_GROUP section that begins 
with $NAME=AG_ADD.

3 Run the SQL statements to populate the PREP_ASSIGNMENT_GROUP 
table.
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Validate Assignment Groups

After you populate the PREP_ASSIGNMENT_GROUP table, you must ensure 
that the assignment groups in the table are valid groups that were part of the 
ServiceCenter assignment table. Records with valid groups will have a value 
of 1 in the VALID field. 

Invalid assignment groups can occur when the name was mis-typed by an 
operator, the group was deleted, the group was renamed, or the group was 
split into multiple groups. 

1 To run a query for invalid assignment groups, search for the Updating 
PREP_ASSIGNMENT_GROUP section in the SQL template file.

2 Run the query statements that begin with $NAME=AG_VALID_NULL.

3 Examine the resulting record where VALID is 0 and do the following:

a If the name was mis-typed and you know what it should be, set 
VALID to 1 and ALIAS_FOR to the correct group name.

b If the name was mis-typed and you do not know what it should be, 
leave the VALID value at 0.

c If the group name was deleted from the current assignment table, but 
was once valid, set VALID to 1. 

Best practice: Update the REASON_DROPPED field with the value 
deleted for future reference.

d If the group name was changed to another name, set VALID to 1 and 
ALIAS_FOR to the new assignment group name. 

Best practice: Update the REASON_DROPPED field with the value 
renamed for future reference.

e If the group was split into multiple sub-groups, set VALID to 1. 

Best practice: Update the REASON_DROPPED field with the value 
split for future reference.

f If the group name contains non-assignment group information, leave 
the VALID value at 0.
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Step 4: Populate the Operator PREP Table

The purpose of this step is to populate an operator table and collect 
information from other ServiceCenter records about operator interaction with 
incidents.

Populate the Operator Table

The PREP_OPERATOR table is populated with a query in the following 
SQL script. 

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media.

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

2 Search for the Updating PREP_OPERATOR section that begins with 
$NAME=OP_ADD.

3 Run the query to populate the PREP_OPERATOR table.

Optionally, on a data refresh, you might want to refresh the FOUND field to 
reflect whether the user is still in the operator table or not. 

1 From the SQL template file, search for the Updating PREP_OPERATOR 
section.

2 Run the query statements that begin with $NAME=OP_SET_FOUND.

Validate Operators

After you populate the PREP_OPERATOR table, you must ensure that the 
operators in the table are valid operators that were part of the ServiceCenter 
operator table. If the operator name is valid, the VALID field will have a value 
of 1 in the VALID field. If the operator name is invalid, the VALID field should 
contain 0. If the VALID field contains a null value, it is assumed to be 1. 

Best Practice: It is important that all VALID fields contain 1 or 0.

Invalid operators can occur when the operator name is mis-typed or part of an 
automated process. For validation purposes, if the same operator name 
appears in the SYSMODUSER field in a related table, you can assume it is a 
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valid operator. The following steps check the operator name against the 
SYSMODUSER field in other tables and reduce the number of VALID fields 
that contain null values.

1 From the SQL template file, search for the Updating PREP_OPERATOR 
section.

2 To validate operators found in the SYSMODUSER column of the 
PROBSUMM_D table, run the query statements that begin with 
$NAME=OP_SET_VALID_PROBSUMM.

3 To validate operators found in the SYSMODUSER column of the 
PROBLEM table, run the query statements that begin with 
$NAME=OP_SET_VALID_PROBLEM.

4 To validate operators found in the SYSMODUSER column of the 
CLOCK_D table, run the query statements that begin with 
$NAME=OP_SET_VALID_CLOCK.

5 To verify these operator names from other related tables (such as 
ACTIVITY), run the query statements that begin with 
$NAME=OP_SET_VALID_ACTIVITY.

6 To find the remaining VALID fields with no value, run the query 
statements that begin with $NAME=OP_VALID_NULL.

7 When the number of remaining records is manageable, you should be able 
to examine them individually and set the VALID value to 1 or 0. 

Identify Automated Process Operators

The AUTOMATIC_PROCESS flag value must be 1 if the operator is part of a 
ServiceCenter automatic process. It can be an internal process, a background 
process., or an external process that involves other HP OpenView software. 
Automatic process operators should be omitted from DecisionCenter 
calculations and simulation activities because these operators do not have 
incident assignments. If the AUTOMATIC_PROCESS field contains a null 
value, it is assumed to be 0. 

Best Practice: It is important that all AUTOMATIC_PROCESS fields 
contain 1 or 0. You should run a query to identify any 
AUTOMATIC_PROCESS fields that contain null values.
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Determine Whether an Operator is an Individual or Group

DecisionCenter produces the best results when each operator works 
independently and ServiceCenter captures the amount of time spent on each 
incident. You should run a query to identify any INDIVIDUAL fields that 
contain null values. Valid values are 1 for individual operators or 0 for an 
operator group.

Best Practice: Create unique operator IDs for each operator in ServiceCenter; 
do not assign a single operator name to a group of operators.

Identify Operators with Multiple Operator Names

One ServiceCenter user may have multiple operator names because they have 
multiple user roles. For any user with more than one operator name, you must 
choose which is to be the primary operator name. In all other records for this 
user, ensure that the primary name is the value in the ALIAS_FOR field. One 
of these methods can identify operators with multiple operator names.

1 For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

2 To run a query on the FULL_NAME field in the OPERATOR_D table to 
find individual operators with duplicate FULL_NAMEs:

a Search for the FULL_NAME section.

b Run the query statements that begin with 
$NAME=OP_DUP_FULLNAME.

3 To run a query on the CONTACT_NAME field in the CONTACT_D table 
to find individual operators with duplicate FULL_NAMEs:

a Search for the CONTACT_NAME section.

b Run the query statements that begin with $NAME=OP_DUP_CONTACT.

Step 5: Populate the Assignment Transition PREP Table

You can populate the PREP_ASSIGNMENT_TRANSITION table with a Java 
utility after you configure two properties files.
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Configure the Database Properties File

1 If you use the default installation path, open this file with a text editor:

C:\Program Files\HP OpenView\DC\BIA\DataMining\config 
\database.properties

2 Uncomment the section that describes your database software and driver.

3 Save the file.

4 Copy your JDBC driver files to: 

\\Program Files\HP OpenView\DC\BIA\DataMining\lib

5 From the Windows Start menu, click Run, and type CMD to open a 
command window.

6 Change directories to:

\\Program Files\HP OpenView\DC\BIA\DataMining\bin\

7 Type this command:

data_mining TestDatabaseConnection 

You can change this path to match your installation; however, ensure that 
you specify the exact location of the executable.

8 Press Enter. The server should return your database connection 
information and this message: “Connection to Database Successful.”

Configure the Process Properties File

1 If you use the default installation path, open this file with a text editor:

\\Program Files\HP OpenView\DC\BIA\DataMining\config 
\process.properties
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2 Verify (or change) the following values.

Populate the Table

1 From the Windows Start menu, click Run, and type CMD to open a 
command window.

2 Change directories to:

\\Program Files\HP OpenView\DC\BIA\DataMining\bin\

3 Type this command:

data_mining GenerateIncidentTransitions

4 Press Enter. The amount of time that the process takes depends on your 
configuration and the amount of data. It may take from a few seconds to 
as long as an hour to run.

Table 22 Parameters in process.properties

Parameter Description

rds.database.timezone Set this parameter to a time zone value 
that matches the time zone of the date 
and time fields in the data warehouse. 
You can express this as GMT, 
GMT+HH:MM, or GMT-HH:MM where 
the HH:MM value is the offset from 
GMT.

global.defaultUserTimeZone This value must be a valid Java time 
zone name. From the command line, you 
can run data_mining ListTimeZones  
to obtain a list of valid time zones. It 
should represent the time zone of the 
technician’s default location, which takes 
daylight savings into account. 

If you get an out of memory error, you may need to change the default memory 
limits temporarily. You can change the settings for the 
DATA_MINING_OPTS variable in the data_mining.bat file to this value:

SET DATA_MINING_OPTS=-Xms128m -Xms1024m
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Step 6: Populate the Business Service CI PREP Table

The PREP_BS_CI table creates relationships between the business service 
and the Configuration Items that support the business service. 
ServiceCenter 6.1.x and earlier versions do not capture business service 
relationship; however, DecisionCenter impact calculations and optimization 
tasks require business service data. 

You can manually identify logical business services and assign them by 
mapping business service values to the appropriate fields in the PREP_BS_CI 
table. For example, the ServiceCenter department field could be the logical 
filter to identify business services.

The out-of-box HP OpenView Connect-It scenario maps business services from 
the DEVICE-D table. In this case, you could populate PREP_BS_CI using the 
device parent-child relationship that exists in the BI_DEVICE table.

Step 7: Populate the Business Service Incident PREP Table

ServiceCenter 6.1.x and earlier versions do not capture business service 
relationships; however, DecisionCenter impact calculations and optimization 
tasks require business service data. The PREP_BS_INCIDENT table creates 
relationships between a business service and an incident through the device 
connected to the incident. 

By default, DecisionCenter assumes an affected device maps to a business 
service. Or, you can improve the granularity of business service assignment by 
manually mapping more sophisticated business service values to the 
appropriate fields in the PREP_BS_INCIDENT table.

You need to populate the PREP_BS_INCIDENT table if:

• There is no device associated with the incident.

• The device is not associated with a business service in the PREP_BS_CI 
table.

• The device is associated with a business service, but another business 
service is affected by the incident.

• The device is associated with more than one business service and not all 
those business services are affected by the incident.
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Step 8: Populate the Incident Exclusion PREP Table  
(Optimization Only)

The PREP_PROBSUM_EXT table captures incidents that are not relevant for 
simulation scenarios. You should identify incidents that were opened against 
obsolete devices, or incidents reported by a customer who no longer exists, or 
is not actively reporting incidents. This can be a manual process or a data 
mining exercise that creates one record for each incident that meets this 
criteria. Ensure that the incident number is recorded in the NUMBERPRGN 
field and a value of 1 in the OMIT_FROM_SIMULATION field.

Step 9: Populate the Assignment Shift PREP Table  
(Optimization Only)

The PREP_ASSIGNMENT_SHIFT must contain information about time 
zones and work schedules.

Create the Assignment Shift Records

Every assignment group in the PREP_ASSIGNMENT_TRANSITION table 
must have one or more assignment shifts. 

You can run the following query to create default assignment shifts for the 
assignment groups.

1 Locate the appropriate SQL template file for your environment on the 
DecisionCenter installation media.

For Microsoft SQL Server, open:

\\BIA\SupportFiles\DatabaseFiles\mssql-templates.sql

2 Search for the section that begins with $NAME= SHIFT_ADD. 

3 Run the query to populate the PREP_ASSIGNMENT_SHIFT table. 

You can add more shifts to the assignment groups as necessary. You can also 
rename them to meet your business requirements.
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Set the Time Zone

The dates specified in a ServiceCenter calendar are in local time; however, 
DecisionCenter processes dates within a time zone. The TZ_NAME field in the 
PREP_ASSIGNMENT_SHIFT table must contain a valid time zone name. 
You can obtain a list of these names using the data_mining.bat utility. 

1 From the Windows Start menu, click Run, and type CMD to open a 
command window.

2 Change directories to:

\\Program Files\HP OpenView\DC\BIA\DataMining\bin\

3 Type this command to list all valid time zones:

data_mining ListTimeZones

4 Press Enter.

5 To obtain a smaller list of time zone names where the standard time 
corresponds to a specific offset from GMT, type this command:

data_mining ListTimeZones GMT<s>NN

where <s> is a plus (+) or minus (-) sign, and NN is the offset in hours from 
GMT.

6 Update the TZ_NAME fields using the values you obtain from running 
these commands.

7 If there are TZ_NAME fields that are not set to a valid time zone name, 
run this SQL query:

UPDATE PREP_ASSIGNMENT_SHIFT SET TZ_NAME='Europe/Paris' 

WHERE TZ_NAME='<tbd>'

You can replace the Europe/Paris with the relevant time zone name.

Set the FTE Field

DecisionCenter must know the number of Full Time Equivalent (FTE) 
employees for each shift. This is a manual step where you must estimate the 
number of FTEs assigned to a shift. This number is an integer greater than or 
equal to 1.
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One method to estimate is to sum all the time worked on incidents by all 
employees in a shift for one month. Divide this number by the total work 
hours of one full time employee during a month. Usually, this number will be 
lower than the actual number of technicians assigned to a shift, due to tasks 
unrelated to working the ticket queues.

For example:

• There are five employees who work the 8 – 5 shift each day (an eight-hour 
work day). 

• Each employee works on incidents about six hours a day. 

• Their total hours spent on incidents for an entire month is 600 
(5 employees x 30 hours per week x 4 weeks in a month).

• Total hours spent on incidents divided by the total work hours of one FTE 
is 3.75 FTEs (600/160). For fractional results, round up.

Populate the FTE column in the PREP_ASSIGNMENT_SHIFT table with the 
computed FTE value.

Assign Multiple Shifts

It is possible to set up an assignment group with more than one shift. For 
example, for an assignment group that works 24x7, with significant 
differences in staffing during different shifts, DecisionCenter can produce 
more accurate results if you define the different shifts and their FTEs.

You can remove the default assignment shift for the assignment group in the 
PREP_ASSIGNMENT_SHIFT table and create your own shifts records.

Task 6: Compute Time-to-Next-Incident  
(Optimization Only)

DecisionCenter Optimization requires a value for the average amount of time 
that elapses between the timestamp on incident records. This value varies 
depending on your organization and volume of incidents. A data mining utility 
can create this value for you.

1 From the Windows Start menu, click Run, and type CMD to open a 
command window.
94 Chapter 4



2 Change directories to:

\\Program Files\HP OpenView\DC\BIA\DataMining\bin\

3 Type this command:

data_mining ComputeTTNI 

Ensure that you run this utility before you attempt to start DecisionCenter 
and run simulation scenarios.

Task 7: Customize the Data Mapping

DecisionCenter requires historical data that contains information about:

• Business services

• The organization

• Value centers

• Labor cost

• Impact

• Service Level Objectives

There are assumptions made in the HP OpenView Connect-It scenarios to 
map data that adds required information to ordinary incident data. Because 
each organization runs differently, you may need to customize the mapping 
scenario to accurately reflect how your organization operates.

Step 1: Customize Business Services Mapping

A business service is the combination of one or more business applications 
plus the supporting Configuration Items that enable delivery of the business 
service to the customer. These can be internal or external business services. 
Business services often have one or more associated value centers. 
DecisionCenter uses these tables to add business service information to 
ServiceCenter incident data.
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The business_service Table

Table name: business_service

Populated with data from this table: DEVICE_D

This scenario maps the data: dco_rds.scn

Mapping Action: Assumes that business service-related devices are those 
devices that begin with the letters BS_. You may need to customize the 
scenario to accurately reflect how your organization identifies business 
services.

The business_service_type Table

Table name: business_service_type

Populated with data from this table: devtype

This scenario maps the data: dco_bs.scn

Mapping Action: Creates business services based on device types. You may need 
to customize the scenario to accurately reflect how your organization 
identifies types of business services.

The configuration_item Table

Table name: configuration_item

Populated with data from this table: DEVICE_D

This scenario maps the data: dco_rds.scn

Mapping Action: Contains data for all devices that are not considered to be 
business services. The out-of-box mapping is for all device names that do not 
begin with BS_. You may need to customize the scenario to accurately reflect 
how your organization identifies Configuration Items.

The businessservice_configitem Table

Table name: businessservice_configitem

Populated with data from this table: PREP_BS_CI

This scenario maps the data: dco_rds.scn
96 Chapter 4



Mapping Action: Links a Configuration Item (device) to a business service. 
When an outage occurs, this linkage connects the Configuration Item outage 
back to the affected business service. Customization should occur when you 
populate the PREP_BS_CI table in Step 6: Populate the Business Service CI 
PREP Table on page 91.

The incident_business_service Table

Table name: incident_business_service

Populated with data from this table: PREP_BS_INCIDENT

This scenario maps the data: dco_rds.scn

Mapping Action: Links an incident to a business service. If your data relates 
incidents to Configuration Items (devices) and your devices map to business 
services in the business_service_type table, it is possible to avoid directly 
mapping incidents to business services. If necessary, customization should 
occur when you populate the PREP_BS_CI table in Step 7: Populate the 
Business Service Incident PREP Table on page 91.

The valuecenter_businessservice Table

Table name: valuecenter_businessservice 

Populated with data from this table: business_service and value_center tables 

Scenario to map the data: dco_rds.scn 

Mapping action: Links a business service to a value center. Customization 
should occur when you populate the business_service and value_center tables.

Step 2: Customize Organization Mapping

The organization table describes the internal (organizational) structure of the 
business.

Table name: organization

Populated with data from this table: DEPT_D

This scenario maps the data: dco_rds.scn
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Mapping Action: The mapping concatenates the company name and the 
department name to produce an organization name. You may need to 
customize the scenario to accurately reflect how your organization identifies 
the organizational structure.

Step 3: Customize Value Center Mappings

A value center is that part of your business that provides a product or service 
to an internal or external customer. It is an entity that adds value directly, or 
indirectly, to your customer community. An enterprise business service can 
have multiple associated value centers. There are four tables that support the 
concept of a value center.

The value_center Table

Table name: value_center

Populated with data from this table: DEPT_D

Scenario to map the data: dco_rds.scn

Mapping action: A ServiceCenter department name maps directly to a value 
center. Compare this to the organization table that concatenates the company 
name to the department name. ServiceCenter departments are hierarchical 
where one department can have subordinate departments. You may need to 
customize the scenario to accurately reflect how your organization defines 
value centers. You can verify or create the hierarchical relationship among 
value centers through the DecisionCenter application.

There are two mappings that describe how to import value centers.

• Mapping 1: DEPT_DSrc1_1-value_centerDst1 creates value centers and 
updates their main attributes.

• Mapping 4: DEPT_DSrc4_1-value_centerDst4 connects a value center to 
its parent. 

The value_center_type Table

Table name: value_center_type

Populated with data from this table: No ServiceCenter equivalent
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Scenario to map the data: N/A

Mapping action: Populating this table is a manual process. Choosing value 
center types is a business decision that enables you to organize value centers 
into categories. For example, you might describe them as external or internal 
value centers, or identify them by business unit. How you populate this table 
depends on how you classify your business operations. 

The valuecenter_businessservice Table

Table name: valuecenter_businessservice

Populated with data from this table: business_service and value_center tables

Scenario to map the data: dco_rds.scn

Mapping action: Links a business service to a value center. Customization 
should occur when you populate the business_service and value_center tables.

The incident_valuecenter Table

Table name: incident_valuecenter

Populated with data from this table: incident and value_center tables

Scenario to map the data: dco_rds.scn

Mapping action: Links an incident to a value center. Customization should 
occur when you populate the value_center and incident tables.

Step 4: Customize Labor Cost Information

Table name: ASSIGNMENT_GROUP 

Populated with this data: No ServiceCenter equivalent

Scenario to map the data: dco_rds.scn

Mapping action: Maps an average hourly labor cost to close an incident. The 
default value is 10; however, you can customize dco_rds.scn to use a different 
value. This value is used in all labor cost calculations. There are no special 
considerations for currency unit or exchange rates. It is an absolute value 
used for computations and relative value comparisons.
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Step 5: Customize Incident Mapping

Incident mapping adds additional data to ServiceCenter incident records. You 
can accept the default values used in the dco_rds.scn scenario, or you can 
customize the scenario to use other values.

The impact_scope_type Table

Table name: impact_scope_type 

Populated with this data: incident table

Scenario to map the data: dco_rds.scn

Mapping action: Links each incident to an organizational unit. The default 
mapping is Business_unit. You may need to customize the scenario to 
accurately map impact scope type information. Other valid values are 
Department, Enterprise, or Single_user.

The incident_impact_type Table

Table name: incident_impact_type 

Populated with this data: incident table

Scenario to map the data: dco_rds.scn

Mapping action: Describes the severity of the incident. The default mapping 
value is Outage, which categorizes each incident as a total loss of operation. 
You may need to customize the scenario to accurately map incident impact 
type information. Other valid values are Capacity, Corruption, Inquiry, or 
Degradation.

Step 6: Customize SLO Mapping

Incidents are associated with Service Level Objectives (SLOs) to measure how 
well an organization meets is response time and availability goals. If IT 
cannot meet the service levels described in the SLO, an SLO breach occurs 
that increases Mean Time to Repair (MTTR) metrics. SLOs have a built-in 
escalation and alert scheme that begins when someone opens an incident to 
report an outage. DecisionCenter imports response time and availability 
SLOs, but uses only response time SLOs for Optimization scenarios.
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Priority

As an incident approaches the SLO breach point, the priority of the incident 
escalates in the assignment group queue. DecisionCenter Optimization 
assumes that an available technician will select on the highest priority 
incident in the assignment queue. 

SLOs in DecisionCenter

For any incident, DecisionCenter first selects the Service Level 
Agreement (SLA) that is assigned to the department referenced in the 
incident. Next, DecisionCenter applies the Response Time SLOs that are 
associated with the selected SLA. Although ServiceCenter supports 
customization using RAD expressions to further restrict the association 
between an SLO and an incident, DecisionCenter does not support these 
customizations. DecisionCenter works only with severity and user priority 
selection criteria.

DecisionCenter uses these response time SLO states:

• Open

• Work in progress

• Resolved

When the HP OpenView Connect-It scenario imports SLOs, it converts a 
Closed state to a Resolved state. Thereafter, DecisionCenter ignores SLOs 
with any other state.

SLO Mapping

The out-of-box dco_rds.scn scenario imports SLO information with no 
conditions. Each SLO has a condition field. DecisionCenter selects incidents 
that have a matching impact and urgency. Impact and urgency correspond to 
severity and user priority in the ServiceCenter probsummary record. You must 
create a mapping that imports the SLO condition settings into the 
incident_slo_condition and incident_impact_urg_slo_cond tables.

There are two mapping examples in the dco_rds.scn that show how to import 
SLO condition information into the incident_slo_condition and 
incident_impact_urg_slo_cond tables. These are examples only; you must 
modify them to meet the format of your data.
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Task 8: Load the DecisionCenter Tables

You need to run an HP OpenView Connect-It scenario to populate the 
appropriate tables with business service and Configuration Item information 
before you load the remaining DecisionCenter tables with prepared data.

Step 1: Create Business Service and CI Types

This scenario maps ServiceCenter device types to BIA business service types 
and Configuration Item types.

1 From the Windows Start menu, click Programs > Peregrine > 
Connect-it 3.6.0 en > Service Console.

2 The Service Console should point to this scenario file:

\\Program Files\HP OpenView\DC\BIA\cit\dco_bs.scn 

3 Click Start.

Step 2: Load Data into the DecisionCenter Tables

This step uses another HP OpenView Connect-It scenario to extract data from 
both resources and load it into DecisionCenter tables. To run the dco_rds 
scenario:

1 From the Windows Start menu, click Programs > Peregrine > 
Connect-it 3.6.0 en > Service Console.

2 The Service Console should point to this scenario file:

\\Program Files\HP OpenView\DC\BIA\cit\dco_rds.scn 

3 Click Start.

It can take several hours to execute if there is a large quantity of data. 
Immediately after the initial data synchronization finishes, it is recommended 
that you back up your database. This can be crucial when the synchronization 
takes a long time, and you need to restore the data. 
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Step 3: Run the Data Cleanup SQL Script File

The imported data may contain invalid characters with underscore and 
incidents without transitions. Run this script to replace the invalid characters 
with underscores and flag any incident without transition information.

1 Identify a local directory where you can copy the script file. For example, 
DecisionCenter_files.

2 From the DecisionCenter installation media, copy the following file from 
this folder on your local hard drive:

\\BIA\SupportFiles\DatabaseFiles\mssql-post_dco_rds_scn.sql

3 Run the script. For example, to run the script using SQL Server Query 
Analyzer:

a Copy the contents of the mssql-post_dco_rds_scn.sql script.

b Click Start > Programs > Microsoft SQL Server > Query Analyzer. 

c Ensure that you log in with the DecisionCenter user name that 
enables you to access the DecisionCenter schema and that the current 
database is the DecisionCenter database. The script will populate the 
tables in that schema.

d Paste the contents in the Query window.

e Click Query > Execute.

Task 9: Install BIA Content

The following steps add BIA Analytics to the ITPA Analytics. Complete this 
task on the BusinessObjects server.
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Step 1: Define the Calendars

If you defined the calendars during the ITPA installation, you can skip to the 
next step.

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log on as Administrator with no password.

3 Click Go to Performance Management > Performance Management > Setup > 
Time Config > Calendar. 

4 Click Add to create new calendars called Monthly Calendar, Scenario 
Daily Calendar, and Quarterly Calendar.

Step 2: Define the BIA Reports and Universes

1 Identify a local directory where you can copy the import files. For example, 
DecisionCenter_files.

2 Navigate to this folder on the DecisionCenter installation media:

\\BIA

3 From the DecisionCenter installation media, copy this folder to your local 
directory:

\\BIA\Business_Impact_Analytics

Table 23 New Calendars

Calendar Name Interval
Duration Display

Show              Format
Calendar 
Span

Monthly Calendar Monthly First Day of Period Sep-06 User-defined 

Scenario Daily 
Calendar

Daily First Day of Period 9/21/04 User-defined 

Quarterly Calendar Quarterly First Day of Period Q3-04 User-defined

The calendar start date and end date in the Calendar Span dialog 
box must reflect the time periods for which you have data.
104 Chapter 4



4 Use the password that you obtain from your installation materials to 
unzip this file into the DecisionCenter_BIA directory:

\\BIA\Business_Impact_Analytics\DecisionCenter_BIA 
\DecisionCenter_BIA.zip

5 Open this file with a text editor:

\\BIA\Business_Impact_Analytics\business_impact.bat

6 Replace these variables with the values that are correct for the device 
where you installed BusinessObjects Enterprise XI R2. save the file.

7 Run the batch program using Windows Explorer or from a Windows 
command prompt. Follow the instructions in the batch program.

Step 3: Update the BIA Universe Database Connections

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Designer.

2 Log on as Administrator with no password.

3 Create a new connection, as necessary, to your data warehouse.

4 Click File > Import. 

5 Click the Universes folder from the Folder drop-down list. 

Table 24 Variables

Variable Example

BUSOBJ_HOME= C:\Programs\BusinessObjects\

DC_HOME C:\DecisionCenter_files\

CMS_NAME_PORT host_name:6400 
6400 is the default BusinessObjects 
Enterprise XI port number

CMS_USER Administrator

CMS_PASSWORD <blank>

JAVA_HOME %BUSOBJ_HOME%/j2sdk1.4.2_08
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6 Select the Business Impact Metrics universe and do the following:

a Click File > Parameters. 

b In the Connection field, select the database connection to your data 
warehouse. 

7 Click OK.

8 Click File > Export. Ensure that you save the universe before you export it.

9 Verify that the exported universe has the same directory destination.

10 Click OK.

11 Repeat Step 4 – Step 10 for the Business Impact Analysis universe.

Step 4: Add and Update the Metric Universes

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Java InfoView.

2 Log on as Administrator with no password.

3 Click Go to Performance Management.

4 Click Setup on the Toolbar.

5 Click the System Setup tab.

6 Click Universes.

7 Click Add Universe.

8 From the drop-down Measure Universe list, select Business Impact Metrics. 

9 Click OK. The Business Impact Metrics universe should appear in the 
Universe Definition window.

10 Select the Business Impact Metrics universe name and click the Update 
Metrics and Control Charts Definitions check box.
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11 Click Update. You should see a list of Available Objects in the lower left 
corner.

Step 5: Run the PMDT Tool

This step extracts the XML source file of metrics to the target machine.

1 Use the Windows command line to locate and run this batch file: 
run_DeploymentTool_PSO.bat 

2 When the Performance Management Deployment Tool appears, click Next.

3 Click the Source File radio button and click Browse.

4 Navigate to the BIA metrics file:

\\Business_Impact_Analytics\business_impact_metrics.xml

5 On the Filter screen, you can expand the probedimensions and metrics 
trees to see the values to be exported to your database. Notice that these 
items have a number appended at the end of their name. This is the ID 
number that the item will be stored under in your database. They should 
all be in the 5000 number range. Click Next. 

6 On the Export screen, click Target Repository and specify the Target CMS 
repository, the username, and password.

7 Click Export. The Check Screen returns success messages for the assets 
that added to the target repository.

8 Click Close.

9 Return to the command window. Follow the instructions to complete the 
session and close the window.

If you do not see a connection name listed next to your universe:

a Log onto Designer.

b Verify that the universe has the correct connection 
parameters.

c Export the universe.
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Step 6: Refresh the BIA Metrics

You must use BusinessObjects Enterprise Performance Manager to refresh 
the metrics.

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > Performance Management > Performance 
Management InfoView Java.

2 Log on as Administrator with no password.

3 Click Go to Performance Management.

4 Click Setup on the toolbar.

5 Click the System Setup tab.

6 Click Dimensions.

7 Select an existing Dimension in the upper text box and click Edit 
Dimension.

8 Click Next.

9 Click Refresh.

10 Click Next.

11 Click END.

12 Repeat Step 7 – Step 11 for all dimensions.

13 Click Go To Performance Management.

14 Click Dashboard Manager.

15 Click the Metrics tab.

16 Click the Refresh icon next to the Available Metrics to refresh the list of 
metrics.

17 Select Business Impact Metrics from the Available Metrics drop-down list.

18 For each category listed, select the metric.

19 Click the Purge icon, then the Refresh icon.

20 When this warning appears, “This operation can be very long. Do you want 
to continue,” click OK. 

21 Repeat Step 17 – Step 20 to refresh other metrics in the list.
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Each metric will refresh and when the process is complete, you can see a Last 
Refresh Date in the Metric History section.

Task 10: Verify the BIA Installation

1 Start a second browser session and type  
http://host-name:port_number/decisionCenter to verify that 
DecisionCenter starts successfully.

2 Log in with your user name and password.

3 Expand the Business Impact node in the navigation tree to establish a 
BusinessObjects connection and view any of these analytics:

— Business Service Downtime Impact/Cost

— Business Service Downtime Impact by Assignment Group

— Business Service Downtime Impact by Category

— CI Type Downtime Impact

— CI Type Downtime Impact by Business Service

— Downtime Impact by Top 5 Business Services Details

— Downtime Impact by Top 5 Value Centers Details

— Downtime Impact for Business Service by Value Center

— Downtime Impact for Value Center by Business Service

— IMT Downtime Gross Impact

— IMT Downtime Impact by Top 5 Business Services

— IMT Downtime Impact by Top 5 Value Centers

— Value Center Downtime Impact/Cost

The

The information in the URL address is case-sensitive.
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Refreshing the Data

HP OpenView Connect-It scenarios for BIA run only once. There is no 
automatic schedule defined. Mapping scenarios run once to synchronize all 
the data from identified resources. You may need to re-run the scenarios, data 
mining activities, and the History Builder if you have changes to your original 
source data. 

If you schedule BIA scenarios to run periodically to re-synchronize the data, 
consult the HP OpenView Connect-It documentation for best practice 
guidelines. 

The amount of time required to synchronize the data depends on the volume 
of data to be processed and the capacity of your server. Ensure that you 
schedule the synchronization to occur during off-peak hours when the server 
has no other demands.

If you schedule the dco_rds.scn scenario to run periodically, create the 
scheduling grouped by the order of data source connector sequences. For 
example, sequence rds source 1, rds source 2, rds source 3, and so on. 
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5 Optimization Installation
The chapter describes the software installation and configuration preparation 
needed to install and run the DecisionCenter Optimization tier.

DecisionCenter supports both Microsoft SQL Server and Oracle for ITPA 
installations. DecisionCenter supports only Microsoft SQL Server if you add 
BIA and Optimization. Ensure that you consult the DecisionCenter Support 
Matrix on the HP Software Support web site for the supported versions of 
these products. 

Installation Checklist

Print this checklist to use during the installation process. As you complete 
each task, mark it as completed.

Task 1: Install the Optimization Engine on page 112.

Task 2: Configure the Optimization Engine on page 113.

— Step 1: Configure database.properties on page 113.

— Step 2: Configure the Port Number on page 113.

— Step 3: Configure the Host URL on page 114.

— Step 4: Configure the Optimization Engine Memory Allocation on 
page 115.

— Step 5: Restart Tomcat on page 115.

Complete Tasks 1 and 2 on the Optimization server. For more information, see 
the distributed server configuration diagram on page 23.
 111

http://support.openview.hp.com/


Task 3: Install the Optimization Content on page 115.

— Step 1: Install the Optimization Universes, Reports, and Views on 
page 116.

— Step 2: Update the Universe Database Connection on page 117.

Task 4: Verify the Optimization Installation on page 117.

Task 1: Install the Optimization Engine

Before you begin, ensure that you have a valid authorization code. If 
necessary, contact HP Software Support.

1 Insert the DecisionCenter installation media into your CD-ROM drive.

2 The installation begins automatically. If necessary, you can start the 
installation from Autorun.exe on the DecisionCenter installation media.

3 Click the Optimization tab.

4 Click Install Optimization.

5 Follow the instructions to install the Optimization engine.

The default location for the DecisionCenter installation is:

\\Program Files\HP OpenView\DC\Optimization 

There are three primary installation folders:

• bin

• config

• lib

Complete Task 3 on the DecisionCenter data warehouse server.

Complete Task 4 on the workstation that is network connected to the 
DecisionCenter application server.
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Task 2: Configure the Optimization Engine

When you complete the installation, you must configure some installation 
files.

Step 1: Configure database.properties

1 Navigate to this installation directory:

\\Program Files\HP OpenView\DC\Optimization\config

2 Open the database.properties file with a text editor. This file contains 
typical configuration statements for Microsoft SQL Server and JDBC 
drivers. 

3 Edit the configuration setting to refer to your database environment.

4 Save and close the file.

Step 2: Configure the Port Number

The port and URL settings in three properties file enable the DecisionCenter 
application to communicate with the DecisionCenter Optimization engine if 
they are installed on separate servers. 

1 Open this file with a text editor:

\Program Files\HP OpenView\DC\Optimization\config 
\jmx.properties

to locate this parameter:

jmx.serviceUrl=service:jmx:rmi:///jndi/rmi: 
//localhost:9999/jmxServer

2 Open this file with a text editor:

\\...HP OpenView\DC\Optimization\config\optimizerJmxContext.xml

to locate this parameter:

<property name="port" value="9999"/>
Optimization Installation 113



3 From the Tomcat server, open this file with a text editor: 

\\...Tomcat\webapps\decisionCenter\WEB-INF\jmx.properties

to locate this parameter:

jmx.jmxUrl=service:jmx:rmi:///jndi/rmi: 
//localhost:9999/jmxServer

The port value in each file must be an available port on the 
DecisionCenter optimization server and the port numbers must match.

4 Make the necessary port number changes.

5 Save the files.

6 Close only the optimizerJmxContext.xml file.

Step 3: Configure the Host URL

The host URL settings in two properties file enable the DecisionCenter 
application to communicate with the DecisionCenter Optimization engine if 
they are installed on separate servers.

1 From this file (already open): 

\\...HP OpenView\DC\Optimization\config\jmx.properties

locate this parameter:

jmx.serviceUrl=service:jmx:rmi:///jndi/rmi: 
//localhost:9999/jmxServer

2 From the Tomcat server, open this file with a text editor: 

\\...Tomcat\webapps\decisionCenter\WEB-INF\jmx.properties

to locate this parameter:

jmx.jmxUrl=service:jmx:rmi:///jndi/rmi: 
//localhost:9999/jmxServer

3 The host name and port number (9999) in each file must be the host name 
of the DecisionCenter Optimization engine server and available port on 
that server. The port number must be the same number that you specified 
in the optimizerJmxContext.xml file in Step 4 on page 114.
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4 Make any necessary changes to ensure that these host name and port 
number values match in both properties files.

5 Save and close both files.

Step 4: Configure the Optimization Engine Memory Allocation

If you process large data sets, the Optimization engine will require more 
memory.

1 Open this file with a text editor: 

\\Program Files\HP OpenView\DC\Optimization 
\bin\run_optimizer.bat

2 Change this value:

java -Xmx500m

to

java -Xmx1250m

3 Save and close the file.

Step 5: Restart Tomcat

1 From the Windows Start menu, click Control Panel > Services and stop the 
Apache Tomcat service. 

2 Clear the cache by deleting the files in this directory:

\\Program Files\BusinessObjects Enterprise 11.5\Tomcat 
\work\Catalina\localhost\DecisionCenter

3 From the Windows Start menu, click Control Panel > Services and start the 
Apache Tomcat service. 

Task 3: Install the Optimization Content

Before you begin, ensure that you complete the tasks in Chapter 3, ITPA 
Installation and Configuration and Chapter 4, BIA Planning and Installation. 
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Step 1: Install the Optimization Universes, Reports, and Views

1 Create a local directory where you can copy the import files. For example, 
create a new root directory named DecisionCenter_files.

2 From the DecisionCenter installation media, navigate to this folder:

\\Optimization\ITPO

3 Copy the contents of the ITPO folder to the local directory you created in 
Step 1. For example, your local folders would look like this:

\\DecisionCenter_files\ITPO\DecisionCenter_Simulation

4 Unzip this file into the DecisionCenter_Simulation directory using the 
provided authorization code:

\\DecisionCenter_files\DecisionCenter_Simulation 
\DecisionCenter_Simulation.zip

5 Open\\DecisionCenter_files\DecisionCenter_Simulation\itpo.bat with a 
text editor.

6 Replace these variables with the values that are correct for the device 
where you installed BusinessObjects Enterprise XI R2.

7 Save the file.

8 Run the batch program using Windows Explorer or from a Windows 
command prompt. Follow the Windows instructions.

Table 25 Variables

Variable Example

BUSOBJ_HOME= C:\Programs\BusinessObjects\

DC_HOME C:\DecisionCenter_files\ 

CMS_NAME_PORT host_name:6400 
6400 is the default BusinessObjects 
Enterprise XI port number

CMS_USER Administrator

CMS_PASSWORD <blank>

JAVA_HOME %BUSOBJ_HOME%/j2sdk1.4.2_08
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Step 2: Update the Universe Database Connection

1 From the Windows Start menu, click All Programs > 
BusinessObjects XI Release 2 > BusinessObjects Enterprise > Designer.

2 Log on as Administrator with no password.

3 Create a new connection, as necessary, to your data warehouse.

4 Click File > Import. 

5 Click the Universes folder from the Folder drop-down list. 

6 Click Browse and select the Simulation Optimization Analysis universe to 
import.

7 Click OK.

8 When a success message appears, click OK.

9 Click File > Parameters. 

10 On the Definition tab, select your database connection from the drop-down 
Connection list. For example, select rdsdb.

11 Click OK.

12 Click File > Export.

13 Verify that any exported universe has the same directory destination. 

Task 4: Verify the Optimization Installation

1 Start a second browser session and type  
http://host-name:port_number/decisionCenter to verify that 
DecisionCenter starts successfully.

2 Log in with your user name and password.

3 Expand the Simulation and Optimization node in the navigation tree to 
establish a BusinessObjects connection and run a Simulation 
Optimization query.

The

The information in the URL address is case-sensitive.
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6 Migration
Customers with certain existing BI Portal installations can migrate their 
environment and data warehouse to be compatible with a DecisionCenter 1.00 
installation. If your installation meets the requirements, you can complete the 
migration tasks described in this chapter to ensure that your existing data 
warehouse is compatible with DecisionCenter. 

If your data warehouse is customized, see the migration instructions in the 
DecisionCenter Integration Guide.

Migration Requirements

An HP OpenView BI Portal 5.2 or 5.2.1 is a candidate for migration if you can 
meet these requirements:

• BI Portal 5.2 or 5.2.1 data warehouse

• HP OpenView ServiceCenter 6.1 with one of the following schema 
conditions

— An out-of-box schema

— A well-migrated schema

— A ServiceCenter schema customized only with additional files or fields

Ensure that you complete all ServiceCenter 6.1 migration steps before you 
begin migration. You must run the DecisionCenter 1.00 unload file for 
ServiceCenter that is in the Support files directory on the DecisionCenter 
installation media.

• HP OpenView AssetCenter 4.3.x or 4.4
 119



Ensure that you complete all AssetCenter 4.3.x or 4.4 migration steps 
before you begin migration. You must run the DecisionCenter 1.00 script 
file for AssetCenter that is in the Support files directory on the 
DecisionCenter installation media.

Migration Environment

Ensure that you meet all of the requirements described in Chapter 1, 
Introduction and in the DecisionCenter Support Matrix on the HP Software 
Support web site.

Migration Notes

The following list describes the BusinessObjects resources that you can use 
during the migration process.

1 Install BusinessObjects Enterprise XI R2 using BusinessObjects 
Enterprise XI product installation documentation.

2 If you customized BI Portal 5.2.x reports and universes, you should install 
the DecisionCenter 1.00 reports and universes and re-apply the original 
customization.

3 If you added custom reports or universes to the default BI Portal 
installation, see the BusinessObjects 6.x to XI Release 2 Migration Guide. 
When you use the import wizard utility, you should import only the 
corporate categories, corporate documents, and universes.

4 Review the BusinessObjects documentation for any post-migration tasks 
that you might need to complete, and how to validate the migrated objects, 
such as universes and reports, in the new environment.
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Migration Checklist

Print this checklist to use during the migration process. As you complete each 
task, mark it as completed.

Task 1: Migrate Out-of-Box Data on page 121.

— Step 1: Migrate BI Portal With Out-of-Box ServiceCenter Data on 
page 121.

— Step 2: Migrate BI Portal With Out-of-Box AssetCenter Data on 
page 123.

Task 2: Migrate Customized Data on page 123.

Task 1: Migrate Out-of-Box Data

Follow the steps in the next sections to migrate ServiceCenter or AssetCenter 
data. 

Step 1: Migrate BI Portal With Out-of-Box ServiceCenter Data

Follow these steps to migrate BI Portal out-of-box ServiceCenter data.

1 Stop the data warehouse rds_sc and rds_user Connect-It scenarios from 
the Connect-It Service Console. 

2 Back up the existing data warehouse and existing files, folders, and 
sub-folders in the original data warehouse location. For BI Portal with 
ServiceCenter, the default location is

\\Program Files\Peregrine\RDS_SC 

3 Back up the data warehouse database.

4 Run the application to install the DecisionCenter data warehouse for 
ServiceCenter (or AssetCenter) from the installation media. The default 
installation directory is: 

\\Program Files\HP\Openview\DC\RDS_SC

\\Program Files\HP\Openview\DC\RDS_AC
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5 Restore this data warehouse system file:

\\Program Files\Peregrine\RDS_SC\cit\*.ini 

The rds_sc.ini contains synchronization information. If you want to use 
that *.ini file in the new installation, copy it to:

\\Program Files\HP\Openview\DC\RDS_SC\cit

6 For BI Portal SC 5.2.1 only, rename rds521_etl.xml to rds_etl.xml in

\\Program Files\HP\Openview\DC\RDS_SC\conf

7 Copy all files and sub-folders from 

\\Program Files\Peregrine\RDS_SC\lib 

to 

\\Program Files\HP\Openview\DC\RDS_SC\lib 

8 To migrate BI Portal for ServiceCenter: 

a From the Start menu, click Run, type CMD, and click OK to open a 
command window. 

b Change directories to:

\\Program Files\HP Openview\DC\RDS_SC \common\bin

c Type this command:

rds_sc61_migrate.bat

9 From the DecisionCenter installation media, copy 

SupportFiles\cit\scdb61.cfg 

to

\\Program Files\Peregrine\Connect-It 3.6.0 en\config\sc\config

10 Navigate to this directory in the DOS command window:

\\Program Files\HP\Openview\DC\RDS_SC\common\bin

11 Type this command:

upd_rdssc.cmd
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12 Type this command:

test_rdssc.cmd

Alternate Step: Use the Connect-It Service Console to modify the 
Connect-It data warehouse scenarios service properties and point to the 
new path for the scenarios.

13 Restart the scenarios services from the Connect-It Service Console.

Step 2: Migrate BI Portal With Out-of-Box AssetCenter Data

Follow the steps in Step 1: Migrate BI Portal With Out-of-Box ServiceCenter 
Data on page 121 using the following substitutions.

•  For BI Portal with AssetCenter, the default location is

\\Program Files\Peregrine\RDS_AC 

• For DecisionCenter with AssetCenter, the default location is 

\\Program Files\HP\Openview\DC\RDS_AC

Task 2: Migrate Customized Data

Migrating customized data requires advice from HP Support and may require 
assistance from HP Professional Services personnel. For more information 
visit the HP Software Support web site at:

http://support.openview.hp.com/
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7 Security
DecisionCenter security models use predefined access levels and security 
roles. Administrators must grant access rights to the groups and security roles 
using the BusinessObjects Enterprise XI Central Management Console 
(CMC).

DecisionCenter supports Lightweight Directory Access Protocol (LDAP) 
authentication. Administrators can configure the Common Web Client (CWC) 
to enable LDAP. The BI Authentication Processing filter validates users and 
groups.

After you set up an LDAP server, you must:

• Create DecisionCenter users and groups in the LDAP server. 

• Configure LDAP authentication in BusinessObjects Enterprise XI. 

For more information about configuring LDAP authentication, see your 
BusinessObjects Enterprise XI documentation.
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Security Checklist

Print this checklist to use during the installation process. As you complete 
each task, mark it as completed.

Task 1: Create DecisionCenter Users and Groups on page 126.

Task 2: Configure LDAP on page 127.

— Step 1:Configure the LDAP Host in BusinessObjects Enterprise XI on 
page 127.

— Step 2: Configure the Secure Socket Layer Authentication for LDAP 
on page 128.

— Step 3: Configure LDAP Mapping Options on page 128.

— Step 4: Map LDAP groups on page 128.

Before You Begin

Before you set up and enable LDAP authentication, set up an LDAP server 
and ensure that your LDAP directory is valid. For more information, see your 
LDAP documentation.

Task 1: Create DecisionCenter Users and Groups

You must configure the LDAP host before you make configuration changes to 
BusinessObjects Enterprise XI. This includes adding DecisionCenter 
out-of-box groups and your own groups to the LDAP server. Changes to group 
names require changes to both the web.xml file and the LDAP server. 
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DecisionCenter provides the following out-of-box groups.

Task 2: Configure LDAP

Complete the following steps to configure the host, Secure Socket Layer 
authentication, LDAP mapping options, and LDAP groups.

Step 1:Configure the LDAP Host in BusinessObjects Enterprise XI

1 Click Start > Programs > BusinessObjects XI Release 2 > BusinessObjects 
Enterprise > BusinessObjects Enterprise Java Administration Launchpad.

2 Select the Central Management Console.

3 Log in with your user name and password.

4 Click Authentication, then click the LDAP tab.

5 Click Start LDAP Configuration Wizard.

6 In the Add LDAP Host (hostname: port) field, type your host and port 
information.

7 Click Add, then click Next.

8 In the LDAP Server Type drop-down list, select your server, and click Next.

9 In the Base LDAP Distinguished Name field, type the distinguished name 
and click Next.

Table 26 DecisionCenter Out-Of-Box Groups

Analytic Type
General 
Manager Role

Advanced 
Analysis Role

Administration 
Role

Performance 
Analytics

ITPA_GM ITPA_AA ITPA_Admin

Business Impact 
Analytics

BIA_GM BIA_AA BIA_Admin

Performance 
Optimization

ITPO_GM ITPO_AA ITPO_Admin
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10 Type the LDAP host credentials:

— In LDAP Server Administration Credentials, type the distinguished name 
and password for a user account that has rights to administer your 
LDAP server.

— In LDAP Referral Credentials, type the same distinguished name and 
password you entered for LDAP Server Administration Credentials.

11 In the Maximum Referral Hops field, type the number of referral hops. If you 
set this field to zero, no referrals are followed.

12 Click Next.

Step 2: Configure the Secure Socket Layer Authentication for LDAP

1 From the Type of SSL authentication drop-down list, select Basic (no SSL) 
and click Next.

2 From the Authentication drop-down list, select Basic (no SSO) and click 
Next.

Step 3: Configure LDAP Mapping Options

1 Select the following LDAP mapping options:

— Create a new account for every added LDAP alias 

— No new aliases will be added and new users will not be created 

— New users are created as named users 

2 Click Next.

3 Click Finish.

Step 4: Map LDAP groups

1 Click Start > Programs > BusinessObjects XI Release 2 > BusinessObjects 
Enterprise > BusinessObjects Enterprise Java Administration Launchpad.

2 Select the Central Management Console.

3 Log in with your user name and password.
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4 Click Authentication, then click the LDAP tab.

5 In Mapped LDAP Member Groups, add the DecisionCenter out-of-box groups 
in the Add LDAP group (by cn or dn) field and click Add.

6 Repeat the previous step to add another group. 

7 To remove a group, select the group and click Delete. 

8 Click Update.

For more information, see the BusinessObjects XI R2 documentation.
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A Troubleshooting

Before you attempt to troubleshoot a problem, ensure that your environment 
complies with the requirements of the Support Matrix. If you do not have the 
correct platform, version, browser, or other required component, 
DecisionCenter cannot run successfully. For more information, see the 
DecisionCenter Support Matrix on the HP Software Support web site.

BusinessObjects Critical Hot Fix

If you deploy ITPA or BIA content before you apply the BusinessObjects 
Enterprise Critical Hot Fix (CHF), you cannot re-deploy the ITPA or BIA 
content successfully because the existing reports and universes cannot be 
overwritten. After you install the CHF, you must delete all the folders and the 
universes from the repository before you attempt to deploy the ITPA or BIA 
content again. 

Best practice: Follow the steps in the order presented in Chapter 3, ITPA 
Installation and Configuration.

Heap Size

The heap size setting on the Web application server hosting DecisionCenter 
must be at least 512 MB. The recommended setting is 1024 MB.
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Log Files

DecisionCenter produces two log files that you can access to troubleshoot 
errors:

• The Optimization engine log is in this directory:

\\Program Files\HP OpenView\DC\Optimization\bin\dc.log

• The application log is in this directory:

 \\...\Tomcat\bin\dc.log

Changing web.xml Default Parameters

You can change the default values in the web.xml file if necessary.  
Follow these instructions.

1 From the Windows Start menu, click Control Panel > Services and stop the 
Apache Tomcat service.

2 Open this file with a text editor:

 \\...\Tomcat\webapps\...\WEB-INF\web.xml

3 Modify one or more parameters. Use the information in Table 27 on 
page 133 as a reference.

4 Save and close the file.

5 From the Windows Start menu, click Control Panel > Services and start the 
Apache Tomcat service.va
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Session Timeout Value

To adhere to best practices, change the session timeout values of the 
Business Objects Connection Server and the Web_IntelligenceReportServer. 
Unless otherwise noted, the default value is in seconds. For more information, 
refer to the Business Objects documentation.

1 Click Start > Programs > Business Objects XI Release 2 > BusinessObjects 
Enterprise > BusinessObjects Enterprise Java Administration Launchpad. 

2 Click Central Management Console. 

3 Log on as Administrator. 

4 Click Servers. 

5 Click Connection Server. 

Table 27 Default web.xml Parameters

Name Description Default Values

folderPrefix Display folders in Business 
Objects with the specified 
prefix in DecisionCenter 
navigation menu

ITPA, BIA, ITPO

boProgPath Business Objects InfoView 
application installation 
path

/businessobjects/enterprise115 
/desktoplaunch

DCPackages DecisionCenter application 
packages

ITPA, BIA, ITPO

ITPA Groups defined for the ITPA 
tier

ITPA_GM, ITPA_AA, 
ITPA_Admin

BIA Groups defined for the BIA 
tier

BIA_GM, BIA_AA, BIA_Admin

ITPO Groups defined for the 
Optimization tier

ITPO_GM, ITPO_AA, 
ITPO_Admin
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6 From the Properties tab Connection Pooling section, select No Timeout.

7 In the Connection Server Job section, change the Timeout for Inactive Jobs 
to 120. 

8 Click Apply.

9 Click Web_IntelligenceReportServer. 

10 From the Properties tab Connection Time Out field, change the value to 60 
minutes. 

11 Click Apply.

JDBC Connection Pool Errors

The maxActive property in the JNDI data source configuration defines the 
maximum number of active connections in the pool. You must evaluate the 
factors that drive how large your connection pool should be. If users close their 
browser sessions without logging out, the connections they use remain open 
until:

• The connection expires after being unused for the amount of time specified 
in the JNDI configuration. Some connections can become available 
automatically as the specified timeout occurs.

• The user session expires after the amount of time specified in the 
web.xml file. 

For optimum results, this value can be as low as 10 or as high as 100, 
depending on the number of concurrent users and abandoned browser 
sessions. If you see JDBC connection pool errors, increase the number of 
connections to a value that works in your environment.
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Broken Database Server Connections

When a database server reboots, or a network failure occurs that breaks your 
database server connection, you must restart Tomcat to re-establish the 
connection. You can configure Tomcat to re-create a broken connection 
automatically by editing the decisioncenterContext.xml file and adding the 
validationQuery parameter.

1 From the Windows Start menu, click Control Panel > Services and stop the 
Apache Tomcat service.

2 Open this file with a text editor:

\\...\Tomcat\conf\Catalina\localhost\decisioncenterContext.xml

3 For Microsoft SQL Server, add the following parameter to the file.

<parameter>

<name>validationQuery</name>

<value>select 1</value>

</parameter>

4 For Oracle, add the following parameter to the file.

<parameter>

<name>validationQuery</name>

<value>select 1 from dual</value>

</parameter>

5 Save and close the file.

6 From the Windows Start menu, click Control Panel > Services and start the 
Apache Tomcat service.value>

</parameter>
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B Configuring a Remote Tomcat Server
You can install DecisionCenter with Tomcat and BusinessObjects Enterprise 
XI on separate servers. Follow the directions in Task 3: Install 
BusinessObjects Enterprise XI on page 33 to install BusinessObjects 
Enterprise XI on an application server using the BusinessObjects Enterprise 
XI Installation guide. If you have an existing Tomcat installation that is 
compatible with BusinessObjects Enterprise XI R2, you can use that instance, 
or install the Tomcat server included in the BusinessObjects XI R2 
installation media.

Task 1: Install the Web Component Adapter

You can install the BusinessObjects Enterprise XI Web Component Adapter 
(WCA) from the BusinessObjects installation media. However, ensure that you 
complete the installation of the recommended BusinessObjects Critical Hotfix 
before you begin the remote Tomcat installation. If you upgrade your 
BusinessObjects server installation, you must repeat the steps that require 
files to be copied from the BusinessObjects server.

1 Install BusinessObjects Enterprise XI Web Component Adapter (WCA) 
component on the same drive as the BusinessObjects Enterprise XI 
installation on the BusinessObjects Enterprise XI server. Follow the 
instructions in the BusinessObjects Enterprise XI installation 
documentation to install the WCA. 
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2 Deploy the BusinessObjects Enterprise XI WCA by copying 
webcompadapter.war from your BusinessObjects server:

\\Programs\BusinessObjects\BusinessObjects Enterprise 11.5 
\java\applications 

to your application server:

\\Programs\BusinessObjects\BusinessObjects Enterprise 11.5 
\java\applications

Task 2: Modify webcompadapterwar.xml

1 Copy this file from your BusinessObjects server:

\\Programs\BusinessObjects\Tomcat\conf\Catalina\localhost 
\webcompadapterwar.xml 

to your application server:

\\Tomcat\conf\Catalina\localhost\webcompadapterwar.xml 

2 Open webcompadapterwar.xml with a text editor.

3 Edit the file to ensure the docBase parameter points to the 
webcompadapterwar.war file. For example:

<Context docBase="C:\Program Files\Business 
Objects\BusinessObjects Enterprise 
11.5\java\applications\webcompadapter.war" 
path="/businessobjects" debug="0" reloadable="false"/>

</Context>

4 Save webcompadapterwar.xml.

Task 3: Deploy the .war File

Follow these steps to deploy the .war file on the remote application server.

1 From the Windows Start menu, click Control Panel > Services and start the 
Apache Tomcat service. 
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2 Ensure that it creates this directory:

\\...\Tomcat\webapps\businessobjects 

Task 4: Modify the Remaining Files

1 Copy the remaining .war files from this BusinessObjects Enterprise XI 
server directory:

\\BusinessObjects Enterprise 11.5\java\applications 

to this remote application server BusinessObjects Enterprise XI directory: 

\\BusinessObjects Enterprise 11.5\java\applications

2 Copy the remaining .xml files from this BusinessObjects Enterprise XI 
server directory:

\\BusinessObjects\Tomcat\conf\Catalina\localhost

to this remote application server BusinessObjects Enterprise XI directory:

\\...\Tomcat\conf\Catalina\localhost

3 Open each .xml file and ensure docBase is pointing to the appropriate 
.war file. For example: 

<Context docBase="C:\Program Files\Business 
Objects\BusinessObjects Enterprise 
11.5\java\applications\webcompadapter.war"  
path="/businessobjects" debug="0" reloadable="false"/>

</Context>

Task 5: Deploy the Remaining Files

Follow these steps to deploy the .war file on the remote application server.

1 From the Windows Start menu, click Control Panel > Services and start the 
Apache Tomcat service. 
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2 Verify that no error messages occur except this one:

CANNOT READ INITCONFIG.PROPERTIES af.configdir PROPERTY 
SETTING.

This message is acceptable.

Task 6: Copy cewcanative.jar

1 From the Windows Start menu, click Control Panel > Services and stop the 
Apache Tomcat service. 

2 Copy this file from the BusinessObjects Enterprise XI server:

\\BusinessObjects\Tomcat\shared\lib\cewcanative.jar

to this remote application server BusinessObjects Enterprise XI directory:

\\Tomcat\shared\lib

Task 7: Configure Performance Manager

1 Create a directory on the remote application server for the 
BusinessObjects Enterprise XI Performance Management application. For 
example:

\\Program Files\Business Objects\your_directory\

2 Copy all of the .properties files from this directory:

\\Business Objects\Performance Management 11.5\

to this new directory on your remote application server. For example:

\\Program Files\Business Objects\your_directory\*.properties

3 Open the InitConfig.properties file with a text editor.

4 Ensure that the path to the Central Management Server points to the 
BusinessObjects Enterprise XI server.
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Task 8: Configure Tomcat Java Options

Follow these steps on the remote application server.

1 From the Windows Start menu, click Programs > Tomcat > 
Tomcat Configuration.

2 Click the Java tab.

3 In the Java Options section, ensure that the following Java options exist 
and these paths reflect the correct locations on the remote application 
server. If necessary, modify the paths to these local directories for 
BusinessObjects Enterprise XI WCA and Performance Manager. For 
example:

-Djava.library.path=WINDIR\system32\;C:\Program Files 
\Business Objects\BusinessObjects Enterprise 11.5\win32_x86\

-Daf.configdir=C:\Program Files\Business Objects 
\your_directory\

Task 9: Configure .properties, .wsdl, and .xml Files

1 If you have a dswsbobje application in this folder on the remote 
application server:

\\Business Objects\Tomcat\webapps

skip this step and proceed to step 2 on page 142.

a Copy this file on the BusinessObjects Enterprise XI server:

\\Business Objects\BusinessObjects Enterprise 11.5\Web 
Services\en\dswsbobje.war

If you use Cygwin-based %CATALINA_HOME%\bin\*.sh scripts 
to start and stop your Tomcat server, you should omit spaces in any 
property settings. JAVA_OPTS errors can occur in a Windows 
installation when you try to pass multiple properties with spaces. 
Either omit spaces, or use non-Cygwin 
%CATALINA_HOME%\bin\*.sh scripts to start and stop your 
Tomcat server. If you use .bat scripts, you can use spaces.
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to this remote application server directory:

\\Business Objects\BusinessObjects Enterprise 11.5\java 
\applications\dswsbobje.war

b Copy this file on the BusinessObjects Enterprise XI server:

\\Business Objects\\Tomcat\conf\Catalina\localhost 
\dswsbobje.xml

to this remote application server directory:

\\Business Objects\Tomcat\conf\Catalina\localhost\dswsbobje.xml

c From the Windows Start menu, click Control Panel > Services and start 
the Apache Tomcat service. 

2 Open this file with a text editor:

\\Business Objects\Tomcat\webapps\dswsbobje\WEB-INF\classes 
\dsws.properties

3 Change the domain= parameter to point to your BusinessObjects server. 
For example:

domain=server_name

4 Change the report.server parameter to point to your remote application 
server. For example:

report.server=remote_server_name

5 For each .wsdl file in this directory:

\\Business Objects\Tomcat\webapps\dswsbobje\WEB-INF\classes

do the following:

a Open the file with a text editor.

b Search for:

soap:address location="http://localhost:8080/dsws/services/bicatalog" 

c Change localhost:8080 to your application server name and port 
number.

d Save the file.
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6 For each web.xml file in these directories on the application server:

\\Business Objects\Tomcat\webapps\...\WEB-INF\web.xml

do the following:

a Open the file with a text editor.

b Search for any parameter that points to the Central Management 
Server. The parameter value should point to the BusinessObjects 
server.

c Save any changed file.

Task 10: Customize the Tomcat Installation

Follow these steps to customize BusinessObjects InfoView on the remote 
application server. This task ensures that BusinessObjects InfoView will 
integrate with DecisionCenter.

1 From the Windows Start menu, click Control Panel > Services and stop the 
Apache Tomcat service. 

2 Delete the Tomcat cache.

3 Copy this file on the installation media:

\\ITPA\ITPA-SM\BOCustomization\desktoplaunch\jsp\ce 
\cestartpage.jsp 

and paste it into this directory on your remote application server:

\\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch 
\jsp\ce

4 Click OK to replace the existing file.

5 Copy this file on the installation media:

\\ITPA\ITPA-SM\BOCustomization\desktoplaunch\jsp 
\performanceManagementHome.jsp 

and paste it into this directory on your remote application server:

\\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch\jsp

6 Click OK to replace the existing file.
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7 Copy this file on the installation media:

\\ITPA\ITPA-SM\BOCustomization\desktoplaunch\scripting 
\aa-linkbar.js

and paste it into this directory on your remote application server:

\\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch 
\scripting

8 Click OK to replace the existing file.

9 Copy this file on the installation media:

\\ITPA\ITPA-SM\BOCustomization\desktoplaunch\jsp 
\appsContentFrame.jsp 

and paste it into this directory on your remote application server:

\\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch\jsp

10 Click OK to replace the existing file.

11 Copy this file on the installation media:

\\ITPA\ITPA-SM\BOCustomization\desktoplaunch\jsp 
\headerPlusAF.jsp 

and paste it into this directory on your remote application server:

\\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch\jsp

12 Click OK to replace the existing file.

13 Copy this file on the installation media:

\\ITPA\ITPA-SM\BOCustomization\desktoplaunch\jsp 
\aa-promptconten.jsp 

and paste it into this directory on your remote application server:

\\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch\jsp

14 Click OK to replace the existing file.
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15 Copy this file on the installation media:

\\ITPA\ITPA-SM\BOCustomization\desktoplaunch\jsp 
\workspaceHeaderAF.jsp 

and paste it into this directory on your remote application server:

\\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch\jsp

16 Click OK to replace the existing file.

17 Copy this file on the installation media:

\\ITPA\ITPA-SM\BOCustomization\desktoplaunch\viewers 
\cdz_adv\viewCDZDocument.jsp 

and paste it into this directory on your remote application server:

\\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch 
\viewers\cdz_adv

18 Click OK to replace the existing file.

19 Copy this file on the installation media:

\\ITPA\ITPA-SM\BOCustomization\desktoplaunch\viewers 
\cdz_adv\viewReport.jsp 

and paste it into this directory on your remote application server:

\\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch 
\viewers\cdz_adv

20 Click OK to replace the existing file.

21 Copy this file on the installation media:

\\ITPA\ITPA-SM\BOCustomization\desktoplaunch\InfoView\main 
\home.jsp

and paste it into this directory on your remote application server:

\\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch 
\InfoView\main
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22 Copy this file on the installation media:

\\ITPA\ITPA-SM\BOCustomization\desktoplaunch\InfoView\utils 
\utils.jsp

and paste it into this directory on your remote application server:

\\Tomcat\webapps\businessobjects\enterprise115\desktoplaunch 
\InfoView\main

23 Restart Tomcat by running the startup.bat file in the Tomcat directory.

24 Start a browser session to test the application.

25 Type the following URL. Modify it to point to the BusinessObjects 
Enterprise XI web server provider name and the assigned port number:

http://your application server:port number/dswsbobje/services 

Task 11: Install DecisionCenter

Follow these steps to install DecisionCenter on the remote application server.

1 Copy this file on the installation media:

\\ITPA\web-app\tomcat\decisionCenter.war

and paste it into this directory on your remote application server:

\\Tomcat\webapps

2 From the Windows Start menu, click Control Panel > Services and start the 
Apache Tomcat service. 

3 Copy the JDBC driver file jtds-1.2.jar

and paste it into this directory on your remote application server:

\\Tomcat\common\lib

For more information about JDBC drivers, see Step 1: Install and 
Configure JDBC Drivers on page 48.

4 From the Windows Start menu, click Control Panel > Services and stop the 
Apache Tomcat service.
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5 Clear the businessobjects and Catalina cache files.    

6 From the Windows Start menu, click Control Panel > Services and start the 
Apache Tomcat service

Task 12: Test the DecisionCenter Installation

It is important to test the installation and verify if there is communication 
among the Business Objects Enterprise XI server, the remote Tomcat server, 
and the DecisionCenter application. 

1 Type the following URL and modify it to point to the server and the 
assigned port number:

http://your application server:port number/decisionCenter

2 Log in with your user name and password.

3 Verify that you can expand the Navigation tree and view both the Analytic 
and Optimization nodes.
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