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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2006 Hewlett-Packard Development Company, L.P.

© Copyright 2001-2006 JasperSoft Corporation

Trademark Notices

HP OpenView Select Audit includes the following software developed by third parties:

• ANTLR Copyright 2005 Terrence Parr.

• commons-logging from the Apache Software Foundation.

• Install Anywhere, Copyright 2004 Zero G Software, Inc.

• Jasper Decisions Copyright 2000-2006 JasperSoft Corporation.

• JavaScript Tree, Copyright 2002-2003 Geir Landro.

• Legion of the Bouncy Castle developed by Bouncy Castle.

• log4J from the Apache Software Foundation.

• OpenAdaptor from the Software Conservancy.

• Quartz, Copyright 2004 - 2005 OpenSymphony

• spring-framework from the Apache Software Foundation.

• Tomahawk from the Apache Software Foundation.

• treeviewjavascript from GubuSoft.

• Xalan-Java from the Apache Software Foundation.

• Xerces-Java version from the Apache Software Foundation.
2



Documentation Updates

This manual’s title page contains the following identifying information:

• Software version number, which indicates the software version

• Document release date, which changes each time the document is updated

• Software release date, which indicates the release date of this version of the software

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

You can visit the HP OpenView Support web site at:

www.hp.com/managementsoftware/support 

HP OpenView online support provides an efficient way to access interactive technical support tools. As a 
valued support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels, go to:

www.hp.com/managementsoftware/access_level 

To register for an HP Passport ID, go to:

www.managementsoftware.hp.com/passport-registration.html 
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1 Overview
Welcome to the Report Designer!

What is the Report Designer?

The Report Designer is a Java-based graphical user interface that lets you create interactive 
or printed reports. The reports can contain any number of tables, crosstabs, and charts. The 
tables can be simple or grouped by rows, and you can easily modify the layout to make more 
complex free-form tables. Your reports can use data from one or several data sources. You can 
position text elements and images anywhere you want, inside or outside the tables. You can 
preview your report, using live data, without leaving the Report Designer.

What’s in This Guide?

The chapters in this guide are shown in Table 1.

The desktop system used to run the Report Designer Java application makes SOAP calls back 
to the Report Center. Consequently the JVM installed on the desktop used to run the Report 
Designer should NOT be setup to use a proxy server for network connections. If using this 
setting, the SOAP calls will be sent to the proxy server instead of the Audit Server, resulting 
in an inability to connect to the Report Server.

Table 1 Chapter Summary

Chapter Description

Chapter 1, Overview Gives an overview of the HP OpenView Select Audit 1.01 
Report Designer’s Guide.

Chapter 2, User Interface 
Overview

Defines the terms and concepts used in Select Audit reports.

Chapter 3, Creating a Query Shows how to make the SQL query that you will use to 
create the reports in this guide.

Chapter 4, Creating a Simple 
Table

Shows how to create a basic rows-and-columns table. Also 
introduces basic styling concepts.

Chapter 5, Creating a Group 
Table

Shows how to create a table with row grouping.

Chapter 6, Creating a 
Free-form Group Table

Shows how to move data and text elements of a table around 
the layout to create a custom table design.
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What This Guide Is...and Is Not

This guide shows how to build several representative reports. The reports illustrate the 
various functions available to you in the Report Designer. These reports are not designed to 
be realistic and are not templates for real reports.

This guide does not provide an exhaustive description of the user interface, nor does it tell you 
every way to accomplish a given task. Like most graphical user interfaces, Report Designer 
provides many different ways to perform certain tasks. This document only shows one way to 
perform a task. Typically, there are many others as well.

Finally, this book does not show how to use RDL. RDL is Select Audit’s XML-based report 
definition language. You can edit RDL within the Report Designer at any time by editing the 
text in the RDL tab. This document does not show how to hand-edit RDL.

How to Use this Guide

Make sure to read Chapter 3, Creating a Query. The other reports that you will create will use 
the query in that chapter. Also, if possible, follow the rest of the guide sequentially, since in 
some cases chapters rely on information in previous chapters.

This guide’s examples assume the default preferences. If you make any changes to the 
defaults, for example, by checking a box preventing a dialog from reappearing, these examples 
may not work exactly as stated.

Chapter 7, Creating a 
Crosstab

Shows how to create a crosstab.

Chapter 8, Creating a Chart Shows how to create a chart.

Chapter 9, Creating a 
Multi-component Report

Shows how to create a report with multiple components. 
This example contains a table, a crosstab, text elements and 
image fields.

Chapter 10, Controls and 
Parameters

Shows how to add end-user controls to your report, and how 
to create the parameters that apply the user’s choices to the 
report output.

Chapter 11, Using Report 
Links and Drilldowns

Shows how to link one report to another to give the end user 
additional information about a specific data value.

Chapter 12, Other Topics This section shows how to add headers and footers if you’ve 
deleted or omitted them. You’ll start with a table that has 
had the footer removed. After adding a footer, you’ll add 
summaries to it.

Table 1 Chapter Summary (cont’d)

Chapter Description
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The Select Audit Documentation Set

This manual refers to the following Select Audit documents. These documents are installed 
with Select Audit and are available in the <install_path>/docs folder where 
<install_path> represents the path where Select Audit is installed.

• HP OpenView Select Audit 1.01 Installation Guide, © Copyright 2006 Hewlett-Packard 
Development Company, L.P. (installation_guide.pdf)

• HP OpenView Select Audit 1.01 Administration Guide, © Copyright 2006 Hewlett-Packard 
Development Company, L.P. (administration_guide.pdf).

• HP OpenView Select Audit 1.01 Concepts Guide, © Copyright 2006 Hewlett-Packard 
Development Company, L.P. (concepts_guide.pdf)

• HP OpenView Select Audit 1.01 Sarbanes-Oxley Model Guide, © Copyright 2006 
Hewlett-Packard Development Company, L.P. (sb_model_guide.pdf).

• HP OpenView Select Audit 1.01 Report Designer’s Guide, © Copyright 2006 
Hewlett-Packard Development Company, L.P. (rpt_center_guide.pdf)

• HP OpenView Select Audit 1.01 Report Center User’s Guide, © Copyright 2006 
Hewlett-Packard Development Company, L.P. (rpt_center_guide.pdf)

• HP OpenView Select Audit 1.01 Report Developer’s Guide, © Copyright 2006 
Hewlett-Packard Development Company, L.P. (rpt_dev_guide.pdf)

Online help is available with the Report generation components.
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2 User Interface Overview
This chapter gives a very high-level description of the Report Designer user interface.

The Report Designer contains the following areas:

• Menu bar

• Toolbar

• Tabs

• Tree View

• Properties Area

• Design Pane

• Status Bar

• Error Pane

Figure 1 User Interface
  13



User Interface Sections

You’ll do most of your layout design in the Design Pane, which provides a graphical 
representation of how your report will display.

When a table is in edit mode in the Design Pane, a Sidebar displays to the left of the table. 
This sidebar indicates the headers, footers, and bands. By selecting the appropriate sidebar, 
you can style or resize the entire header, footer, or details section.

The Properties Area enables you to fine-tune the layout. Though you can usually create your 
report using only the Design Pane, for some advanced settings you must use the Properties 
area. Every setting in the Design Pane except positioning is also available in the Properties 
area.

The Tree View shows the report in a hierarchical fashion. It is based on RDL, Select Audit’s 
XML-based report definition language. The two most important high-level nodes are Data 
Sources and Layout. Each element of the report is represented by a node on the tree. When 
you select an item in the Tree view, the element is highlighted in the Design Pane and you can 
edit it in the Properties area. You can also drag a data field from the Tree view into a text 
element in edit mode in the Design Pane.

Tabs

The three tabs are:

• Design Tab

• Preview Tab

• RDL Tab

Design Tab

Most of the time, you’ll use the Design tab to develop your reports. In the Design tab, the Tree 
View, Properties Area, and Design Pane are visible.

Preview Tab

Use the Preview tab to see how your report looks using real data. If you aren’t currently 
connected to a data source, you will be prompted to do so.

In the Preview tab, you can choose whether to display a PDF or HTML view. If you choose 
HTML, the data is displayed roughly as in a browser, though some elements (for example, 
certain controls) don’t appear exactly as they would in a browser.

You can also choose how many rows of returned data to use to generate the report. Use the 
number-of-rows to control the time it takes for the report preview to display.

The number of returned rows is meaningful only for simple tables. If your returned data set is 
large and you set the number of rows to “all”, you may get an out-of-memory error. As a 
general rule, set this control to “all” only for crosstabs, and even then, only when necessary to 
view your output correctly.
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Typically, you will alternate between the Design tab and the Preview tab. After making some 
changes, check the Preview tab for a better idea of how the report actually looks.

RDL Tab

The RDL tab displays the RDL code that defines the report. RDL is Select Audit’s XML-based 
report definition language. This tab is for fine-tuning by advanced report developers.

Tree View

The Tree view shows a hierarchical view of your report. Its top-level nodes include parameters, 
data, and layout. The data node shows the data available to populate the report.

If you have created a spot for it in the layout, you can drag a data field into the spot in the 
Design Pane.

The highest-level subnodes of the layout mode are components. In Select Audit, a component 
is a table (called Banded Table in the Tree view), crosstab, or chart. You can create 
combinations of these components to create a complete report. The subnodes of each 
component are different for each component type.

Properties Area

The Properties area allows you to view and edit details of each item that you have selected in 
the Design Pane or in the Tree view. The Properties area contains folder buttons, which 
expand to reveal editable properties. The number of folder buttons and properties depends on 
the element selected.

Design Pane

The Design Pane graphically shows the report in its current state. It’s not a WYSIWYG view 
(that is available in the Preview Tab) but it does show the layout in an abstract form.

Design Pane Objects

The objects that the Design Pane can contain are:

• components (tables, crosstabs, and charts)

• text elements

• image elements

• controls (see Chapter 10, Controls and Parameters)

This document does not discuss RDL or the RDL tab. 
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• the layout

Selecting an Object

To select an object, click it in the Design Pane. To select the layout, click anywhere in the 
Design Pane outside all other objects.

When an object is selected, you can:

• edit it by right-clicking or by using the menus

• style it from the toolbar

• move it

• resize it

Opening an Object

Some objects can be opened so that you can edit them directly within the Design Pane, 
without using the menus, toolbar, or dialog. These objects are:

• tables

• crosstabs

• text elements and crosstab labels

To open an object, double-click it.

When you open a table, the Sidebar appears, which enables you to resize the headers, footers, 
and details section. You can also directly select elements in the table by clicking them.

When you open a crosstab, you can directly select elements in the crosstab by clicking them.

When you open a text element, you can modify the text directly without using a dialog, and 
you can drag a data element from the Tree View into the text element.

Other Elements of the Design Pane

Surrounding the Design Pane, are:

• Girders

• Rulers

• Sidebar

Girders

Immediate surrounding the Design Pane is a narrow horizontal area containing vertical lines, 
and a narrow vertical area containing horizontal lines. These lines are called girders. They 
represent the edges of all the elements in the layout. (When a table is in edit mode, they 
represent the edges of elements within the table.) You can drag these girders to change the 
size of elements inside the layout.
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Rulers

Surrounding the girders are rulers. By default, they measure pixels, but by clicking the 
L-shaped area surrounding connecting the rulers, you can change the measurement to inches 
or centimeters.

Sidebar

If a table is in edit mode, a sidebar appear to the left of it. The sidebar delineates areas that 
represent the headers, footers, and bands of the table. By dragging the lines within the 
sidebar, you can resize the table’s bands, headers, and footers.

Status Bar

The Status bar optionally appears on the bottom of the Report Designer. The status bar 
indicates whether you are connected to a server and, if so, to which server. It also indicates 
whether there are errors.

Error Pane

The Error pane shows errors found in the report. If there are error messages, they may contain 
hyperlinks to the part of the report that caused the error.

To show or hide the error pane, use the up and down arrows underneath the Properties area. 
You can also open the error pane by double-clicking the arrow icon in the status bar.
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3 Creating a Query
This chapter shows how to create a query and save it to the Catalog for reuse. The query that 
you create in this chapter will be used to create a simple table, a crosstab, and a banded table.

To create a query from scratch, use the Query Wizard. To edit an existing query, use the Query 
Editor. (See Modifying the Query on page 21.)

The Query Wizard helps you write SQL queries. Once you have created a query, you can use it 
to provide data to a table, crosstab, or chart, or query-driven parameter.

Launching the Query Wizard

To launch the Query Wizard, select Data → Query Wizard. The Query Wizard appears.

Selecting the Data Source

To select the data source:

1 Select demo in the Choose data source field.

2 In the Enter a name for the query field, enter MainQuery.

3 Click Next.

Selecting Tables

1 While holding the CTRL key, select the following tables:

• CATEGORIES

• ORDERS

• ORDER_DETAILS

• PRODUCTS

2 Click Add.

3 Click Next.
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Linking Tables

You’ll need to link tables. Links correspond to joins in the database.

1 Choose the tables CATEGORIES and PRODUCTS, and link on the CATEGORY_ID field. To do 
this, select CATEGORY_ID on each side, then click Link.

2 Choose the tables ORDER_DETAILS and PRODUCTS, and link on the PRODUCT_ID field.

3 Choose the tables ORDER_DETAILS and ORDERS and link on the ORDER_ID field.

4 Click Next.

Selecting the Columns

You now need to select the columns that you will use to build your report.

1 In the Available Columns area, select the CATEGORIES table, then select the CATEGORY_ID 
and CATEGORY_NAME columns. Click Add.

2 From the ORDERS table, add the ORDER_ID, CUSTOMER_ID, ORDER_DATE, SHIPPED_DATE, 
SHIP_CITY, SHIP_NAME, and SHIP_COUNTRY columns.

3 From the ORDER_DETAILS table, add the PRODUCT_ID, UNIT_PRICE, and QUANTITY 
columns.

4 From the PRODUCTS table, add the PRODUCT_NAME column.

5 Click Next.

Changing the Labels

The column names in the database are cumbersome. Now create more readable name for the 
columns that you will use. Change the Label column in the Column Details screen as follows:

1 Change CATEGORIES_CATEGORY_ID to Cat_ID.

2 Change CATEGORIES_CATEGORY_NAME to Category.

3 Change ORDERS_ORDER_ID to Order_ID.

4 Change ORDERS_CUSTOMER_ID to Customer_ID.

5 Change ORDERS_ORDER_DATE to Order_Date.

6 Change ORDERS_SHIPPED_DATE to Ship_Date.

7 Change ORDERS_SHIP_CITY to Ship_City.

8 Change ORDERS_SHIP_NAME to Shipped_To.

9 Change ORDERS_SHIP_COUNTRY to Ship_Country.

10 Change ORDER_DETAILS_PRODUCT_ID to Product_ID.

11 Change ORDER_DETAILS_UNIT_PRICE to Unit_Price.

12 Change ORDER_DETAILS_QUANTITY to Quantity.

13 Change PRODUCT_NAME to Product.

14 Click Finish.
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15 If you are prompted to start the Layout Wizard, click No.

16 Save the query as MainQuery.rdl.

Saving the Query to the Catalog

As well as saving the query to the file system, you can also easily upload the query to the 
Report Server to reuse later. Once on the server, you can either copy the query into a report or 
reference it without copying it.

To upload the query to the Report Server:

1 In the Tree view, expand Data Source. MainQuery should now be visible.

2 Right-click MainQuery, and select Upload Datasource.

3 Click OK.

The query is now saved in the Catalog on the server. You can see the contents of the Catalog 
using the Report Center. See the HP OpenView Select Audit 1.01 Report Center User’s Guide 
for details.

In later chapters, you will fetch the query that you have just saved to the Catalog.

Modifying the Query

You can invoke a SQL editor to modify the query. To do this:

1 In the Tree view, expand Data Sources. MainQuery should now be visible.

2 Right-click MainQuery, and select Edit SQL Query. The SQL Editor appears.

For now, do not modify the query. Later, in Chapter 10, Controls and Parameters you will use 
this dialog to add parameters to the query.
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4 Creating a Simple Table
In this section, you will create a simple table that consists only of headers, footers, and data 
rows. Then you will use the Layout Wizard to make common adjustments to your table.

Creating the Table

1 Open the MainQuery.rdl file that you created in Chapter 3, Creating a Query. The 
Layout Wizard prompt appears.

2 Click OK to launch the Layout Wizard. (If the prompt doesn’t appear, choose Insert → Table 
from the top menu.)

3 In the Layout Wizard, General screen, select query MainQuery and layout type Tabular.

4 In Fields to Display, select the following fields:

• Category

• Order_ID

• Ship_Date

• Unit_Price

• Quantity

• Product

5 Using the up arrow, move Order_ID to the top.

6 Using the up arrow, move Product right under Order_ID.

7 Click Next.

8 In the Select Table Options screen, Select Type of Tabular Layout area, select Simple Table.

9 In the Include area, make sure Table Header and Table Footer are checked.

10 Click Next.

11 In the Set Label Options screen, double-click Order_ID in the Column Labels column and 
change it to Order ID.

12 Likewise, change Ship_Date to Ship Date and Unit_Price to Unit Price.

13 Click outside the Column Label column to preserve the changes you have just made.

14 Now, you’ll add a sorting link to the Product column. Sorting links allow the end user to 
change the sorting in the table by clicking on a column header. Click in the Sorting Link 
column on the Product row and choose Ascending from the drop-down list.

15 Click Next.

16 In the Select Theme screen, choose forest.
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17 Click Finish.

18 Click the Preview tab. Preview as HTML. For Number of Data Rows, select 10.

19 Click Refresh.

20 Save the table as MySimpleTable.rdl.

You now have a simple report! Now all you need to do is refine the layout.

Modifying the Table Content

Changing the Title

1 In the Design Pane, double-click the table to open it. Then double-click the title to make it 
editable.

2 Change the table title to Orders Report.

3 Preview the report.

Changing the Date Mask

The date is not in a usable format. To change it:

1 In the Design Pane, double-click on the table to open it, if necessary. Then right-click on 
the text element containing Data.MainQuery.Ship_Date and select Edit Text Element. 
The Text Properties dialog appears.

2 In the Format tab, select date format MM/dd/yyyy.

3 Click OK.

Changing the Money Mask

The formatting for unit price has only one decimal place. To change it to standard money 
formatting:

1 In the Design Pane, double-click on the table to open it, if necessary. Right-click on the 
text element containing data.MainQuery.Unit_Price and select Edit Text Element. The 
Text Properties dialog appears.

2 In the Format tab, select the following number format: $#,##0.00;(#,##0.00).

3 Click OK.

4 Repeat these steps for the Unit Price summary element found in the footer.

5 Preview the report. Set the Number of Data Rows to 10 to see the footer more easily.
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Deleting the Extra Summary

The Layout Wizard creates summaries for all numeric data, but the Order ID field doesn’t 
really need one. You can delete the summary element from the table footer.

1 In the Design Pane, double-click on the table to open it, if necessary. Right-click on the 
Order ID summary element in the Table Footer section and select Delete.

2 Preview and save the report.

Improving the Layout

In this section, you’ll make a few additional improvements to the layout.

Alternate Row Styling

The table is a little hard to read because the detail rows all have the same styling. To change 
that, you’ll style odd- and even-numbered rows differently.

1 Click outside the table to exit edit mode. Right-click in the table and select Edit Table.

2 In the Tabular Editor, General tab, locate the Alternate Data Row Styling area. Check the Use 
separate styles for odd and even records check box. Click OK.

3 To use the alternate row style found in the forest theme, you must re-apply the theme to 
the table. Make sure the table is selected. From the Format menu, choose Apply Theme → 
forest.

4 Preview the report.

Changing Alignments

The Order ID header and data are too close to the left border of the table. A simple solution is to 
center their horizontal alignment.

1 In the Design Pane, double-click on the table to open it. Select the Order ID element in the 
Table Header section.

2 Click Center alignment in the toolbar.

3 Select the Order ID element in the Details section and click Center alignment again.

4 Preview the report.

Resizing Columns

Several of the columns are wider than they need to be, and the Product column data is 
wrapping because the column is too narrow. To fix this, you’ll move the girders just beneath 
the horizontal ruler. Currently, the first girder appears at the 150 px mark on the ruler, the 
second at 300, the third at 450, and so on.

1 In the Design Pane, double-click the table to put it in edit mode, if necessary.
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2 To narrow the Order ID column, move your mouse over the first line until the cursor 
changes to a double-headed arrow. Click and drag the girder until it is under the 125 px 
marker.

3 To widen the Product column, click and drag the second girder to under the 350 px marker.

4 The last line in the gray bar corresponds to the right edge of the Unit Price column. To 
narrow this column, drag this line to under the 750 px marker.

5 The very last girder is hard to see, because it falls on the right edge of the gray bar. To 
narrow the Quantity column, drag this last girder to the 850 px marker.

6 Preview the report.

Increase the Height of the Title

The title looks a little cramped. You can change the height of a row of text elements the same 
way that you changed the width of a column, by using the girders. In this case, of course, the 
title takes up the entire row.

1 In the Design Pane, double-click the table to put it in edit mode, if necessary. To the right 
of the vertical ruler, immediately to the left of the table, you should see a gray bar 
containing horizontal lines, or girders. 

2 Click the first line and drag it down until you have roughly doubled the height of the title 
element.

3 Preview and save the report.

Optional Next Steps

Uploading the Report to the Library

You can upload the report to the Library on the Report Server. This makes the report 
accessible to anyone with the appropriate permissions. It also allows you to schedule report 
output.

1 Select File → Publish.

2 In the Publish Report dialog, select the User Reports folder.

3 Click New Folder. In the Input dialog, enter DocSamples.

4 Click OK. The DocSamples folder appears in the tree under User Reports.

5 Select the DocSamples folder.

6 In the Upload With Name field, enter the name MySimpleTable.

7 Click OK. The report is now stored in the Library.

For more information on managing reports in the Library, see the HP OpenView Select Audit 
1.01 Report Center User’s Guide.
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Adding a Group to a Table

Using the Tabular Editor, you can convert a simple table to a group table or add a group to an 
existing group table. This example will demonstrate how to do it.

1 In the Design Pane, if the table is still open, click outside the table to close it. Then 
right-click on the table and select Edit Table.

2 In the Tabular Editor, click the Data tab. Select Order ID from the Available Fields drop-down 
list and click Add.

3 Click OK.

4 Preview the report. The table is now grouped by Order ID, with an empty header and footer 
around each group.

5 Save the report as GroupedSimpleTable if you wish to work with it later.

There are several ways you could proceed with this table. You might want to remove Order ID 
from the Details section and have it show up in the group header instead. You might want to 
add summaries to the group footer, or delete the footer altogether. Many of these topics are 
covered in Chapter 5, Creating a Group Table.
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5 Creating a Group Table
This chapter shows how to create a basic group table. The table will group orders by country 
and subgroup them by city. After you have created the table, you will make some adjustments 
to it and explore some options that are specific to group tables.

Inserting the Group Table

1 Open the query that you created in Chapter 3, Creating a Query.

2 In the Layout Wizard, General screen, select query MainQuery and layout type Tabular.

3 Select the following fields to display:

• Order_ID

• Ship_City

• Ship_Country

• Product

4 Using the up arrow, move Ship_Country to above Order_ID.

5 Using the up arrow, move Ship_City to just above Order_ID.

6 Click Next.

7 In the Tabular Layout pane, select Table with Row Grouping.

8 For Row Grouping 1, select Ship_Country. (This should be pre-selected.)

9 For Row Grouping 2, select Ship_City.

10 Leave Row Grouping 3 set to None.

11 In the Include area, leave all headers and footers checked.

12 Click Next.

13 In the Set Label Options screen, Column Labels column, change the column names as 
follows:

• Double-click Ship_Country in the Column Labels column and change it to Country.

• Change Ship_City to City and Order_ID to Order ID.

• Do not change the Product column name or any of the sorting selections.

14 Click Next.

15 Select the corporate theme and click Finish.

16 Look at the report in the Preview pane. Set Number of Data Rows to 25.

17 Save the report as MyGroupTable, type report.
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Modifying the Table Content

Changing the Footer Summaries

The only summaries in the table are for the Order ID column, and these display totals rather 
than counts. Next you’ll modify the report to show the total number of orders for each 
subgroup and for the whole report.

1 In the Tree view, open Layout and the Banded Table beneath it.

2 Right-click sum(Order_ID) and select Edit Summary.

3 In the Edit Summary Function dialog, change the summary function to count.

4 Click OK.

5 Still in the Tree view, open the Nested Band under Banded Table. Repeat the process that 
you followed above to change this sum aggregate function to count.

6 Finally, open the Nested Band inside the other Nested Band and follow the same process to 
change the innermost sum aggregate to count.

7 Preview the report. You’ll see the summary values have changed. Save the report.

Adding Text to the Footer

Now, you’ll add descriptive text to show the meaning of the numbers in the table footer.

1 Double-click the table if necessary to open it, then select the Table Footer area.

2 Click the Insert Text Element icon in the toolbar.

3 In the Text Properties dialog, enter Total Orders: followed by a space.

4 Click OK. The text field appears at the left side of the bottom footer.

5 Preview and save the report.

Improving the Layout

Narrowing Columns

The first three data fields in the table are wider than they need to be. You will now narrow 
them.

1 Double-click the table if it is not already in edit mode.

2 Follow the same procedure you used in Resizing Columns on page 25. in the previous 
chapter. However, note that the first girder now corresponds to the Total Orders: element 
you just added above. You must therefore start with the second girder. Drag it left to the 
100 px mark. The first girder is already at that location, so the two will merge into a 
single column.

3 Drag the next girder back to the 200 px mark, and the next to 300 px.

4 Preview the report.
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A Note about Columns

There are not necessarily any real “columns” in a table created in the Report Designer, since 
you can move header, footer, and details elements around at will. However, in a newly created 
simple or group table, the columns still exist, and you can resize them with the girders as 
described in Narrowing Columns on page 30.

For information about resizing elements when they are not arranged in proper columns, see 
Chapter 6, Creating a Free-form Group Table.

Widening the Table

The Product column is too close to the right edge of the table. You can add a margin by 
widening the table.

1 In the Design Pane, click on the small white box at the center of the right edge of the 
table. Drag it to the right about three ticks.

2 Preview the report. The margin is visible, but now the title doesn’t span the whole width 
of the table.

3 Return to the Design Pane and select the table title. Click on the right edge and drag it to 
the right until it reaches the edge of the table.

4 Preview the report.

Custom Alternate Row Styling

Once again, the table is a little hard to read because the detail rows all have the same style. 
You can change that by setting a custom alternate row style.

1 Click outside the table to exit edit mode. Right-click in the table and select Edit Table.

2 In the Tabular Editor, General tab, check the Use separate styles for odd and even records 
check box.

3 Click the Style tab.

4 Select Repeating Details – even from the Styles for: drop-down list. For Background, choose 
silver. Click OK.

5 Preview and save the report.

Optional Next Steps

Changing the Grouping

After creating a group table, you may decide to group the data in a different way. If you 
haven’t made many adjustments to the table, the simplest solution is to delete it and start 
over with the Layout Wizard. However, if you have made substantial changes, you can use the 
Tabular Editor to change your grouping.

In this example, you will change the second grouping from Ship_City to Shipped_To.

1 Right-click in the table and select Edit Table. In the Tabular Editor, choose the Data tab.
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2 In the Row Groupings (nested) area, select Ship_City and click Delete.

3 In the Available Fields drop-down list, select Shipped_To and click Add.

4 Click OK. The Group 2 Hdr and Group 2 Ftr sections have been deleted and then added back 
again. As a result, they are empty and unstyled.

5 Double-click the table to open it. Select Group 2 Hdr in the sidebar and choose Apply Theme 
→ corporate from the Format menu. The header style is restored.

6 Now you will add the grouping field to the header. With Group 2 Hdr still selected, click the 
Insert Text Element icon.

7 In the Text Properties dialog, click Data.

8 In the Edit Data Field dialog, select Group Name and click OK.

9 Click OK to close the Text Properties dialog. The new text element appears.

10 Click on the Group Name text element and drag it to the right until it lines up under the 
Ship City header element.

11 Double-click the Ship City element in the Table Header. Change the text to Company.

12 Preview the report. The company name now appears in place of the city, but the new data 
field appears too narrow. On the Design Pane, drag the girder from the 200 px mark to 
250. Preview again.

13 Return to the Design Pane. The Group 2 Footer is still empty and unstyled. You could style 
it and add a Group Name text element here, as you did with the header. You could also add 
a group summary (see Chapter 12, Other Topics). But for now, you will simply delete the 
footer.

14 Right-click Group 2 Ftr in the table sidebar and choose Delete.

15 Preview and save the report.

Making a Group Collapsible

Now, you’ll make the Shipped_To group collapsible. This will give the end user a control that 
will allow her to see only the country data if she wants.

1 Click outside the table to exit edit mode. Then right-click the table and select Edit Table.

2 Click the Data tab.

3 In the Row Groupings (nested) area, select Shipped_To.

4 Check the Group can be collapsed by viewer check box on the right side of the tab. Leave the 
Header radio button selected.

5 Click OK.

6 Preview the report. An icon appears at the left edge of each of the Shipped_To headers. 
Click the icon to see that group collapse and expand.

7 The icon should be positioned closer to the group name. Return to the Design Pane and 
double-click the table to open it. Click on the tiny plus sign at the far left of the Group 2 Hdr 
section and drag it to the right, closer to the group name text element. Drag it down until 
it is vertically centered with the element.

8 Preview and save the report.

Pressing Ctrl on the keyboard while clicking and dragging allows you to override the grid and 
move smoothly in the Design Pane. You can also use your keyboard’s arrow keys.
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Adding a Sorting Link

You did not choose to include any sorting links when you were creating your table. You will 
add one now for the Order ID column.

1 In the Design Pane, double-click the table if it is not already in edit mode. Right-click on 
the Order ID element in the table header and select Edit Text Element.

2 In the Text Properties dialog, General tab, select the Sorting Link radio button.

3 In the Data Field drop-down list, select Order_ID. Leave the Initial Direction as Ascending.

4 Click OK.

5 Preview the report. You’ll see the Order ID column header is now a hyperlink, which the 
end user can use to reorder the table data.

Changing the Theme

If you change your mind about your report’s theme, you can always change it. In this section, 
you’ll change the report’s theme.

1 Click outside the table to select the layout.

2 From the Format menu, select Apply Theme → Select.

3 In the Select Theme dialog, browse through the themes by clicking on different theme 
names and viewing the thumbnail preview at the right.

4 Select fall and click OK. The table and the empty space around it change to reflect the new 
theme.

5 Preview and save the report.

In general, themes override most custom styling, with the exception of styles applied to 
individual elements in a table. The title element is the only element directly styled by a 
theme.

By applying a theme, you override any existing styles on that object and its children. In this 
case, the custom alternate row styling you did earlier is replaced by the fall theme’s alternate 
row style.
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6 Creating a Free-form Group Table
In this chapter, you’ll use the query that you created in Chapter 3, Creating a Query as the 
basis for a free-form group table. Some data will appear in the outermost group header, not 
the details, so you will add these data fields after you have done the initial layout. Also, 
because this table is free-form, themes are not useful for styling. Instead, you will learn some 
custom styling techniques.

Getting Started

Downloading the Query from the Catalog

For this report, you’ll reference the query in the Catalog rather than opening it from the file 
system.

1 Select Data → Get Datasource.

2 In the Get Query from Catalog dialog, locate MainQuery.

3 Click OK.

Inserting the Table

The dialog to launch the Layout Wizard opens automatically if you open a report that contains 
a query but no layout. You can also launch the Layout Wizard at any time by selecting Table, 
Chart, or Crosstab from the Insert menu.

1 Select Insert → Crosstab. The Layout Wizard appears.

2 In the General screen, select query MainQuery and layout type Tabular.

3 In the Fields to Display area, leave only the following fields checked:

• Category

• Order_ID

• Unit_Price

• Quantity

• Product

4 Now, change the order of the columns. Using the up arrow, move Order_ID to the top, 
Category second from the top, and Product just below that. The order of the checked fields 
is now:

If you do not have access to a server containing the MainQuery that you created earlier, 
Select File → Open and open the MainQuery.rdl file that you created in Chapter 3, Creating 
a Query. The Layout Wizard appears automatically.
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• Order_ID

• Category

• Product

• Unit_Price

• Quantity

5 Click Next.

6 In the Tabular Layout screen, under Select Type of Tabular Layout, select Table with Row 
Grouping.

7 Under Select Special Fields, Row Grouping 1, select Order_ID. (This should be selected 
already since you have moved Order_ID to the top field.)

8 For Row Grouping 2, select Category.

9 Leave Row Grouping 3 as None.

10 In the Include area, uncheck Table Footer and Group Footer.

11 Click Finish. A preliminary view of the layout appears in the Design Pane.

12 Preview to get an idea what the table looks like. Save the report as FancyGroup.rdl.

Improving the Content and Layout

Editing and Styling the Title

1 Double-click on the table to open it. Then right-click the MainQuery Report text element 
and select Edit Text Element. The Text Properties window appears.

2 In the General tab, edit the text to read Orders and Product.

3 In the Style tab, change the font type to Arial, font size to 20 pt, and check Bold under 
Effects.

4 Click OK.

Deleting the Column Headers

You’ll be deleting all the header text elements except the title. Since this table does not really 
contain columns, you won’t need column headers.

1 In the Design Pane, in the Table Header section, right-click the text element containing the 
header Order_ID and select Delete.

2 Delete the headers for Category, Product, Unit_Price, and Quantity the same way.

3 Now in the left sidebar, select and drag the bottom bar of the Table Header section to 
reduce the space between the title and the group header.
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Adding Text to a Data Field

You will label the Order_ID data field in the group header by adding text directly to the 
element.

1 Double-click on the text element located in the Group 1 Hdr section. A gray oval will appear 
with the words Group Name inside it. Your cursor will be positioned to the left of the oval.

2 Type in Order ID: followed by a space. Then click the Group 1 Hdr sidebar to end the edit.

3 Preview the report.

Adding Data to the Group Header

You will also add the customer ID, ship date, and ship city to the group header. Since these 
fields were not selected in the Layout Wizard, you’ll have to add them manually. This section 
shows you how.

1 Select the Group 1 Hdr section in the table or the sidebar.

2 Click the Insert Text Element icon on the toolbar. The Text Properties dialog appears.

3 Click Data. The Edit Data Field dialog appears.

4 Select MainQuery.Customer_ID. Click OK. The Text Properties dialog now contains an oval 
representing the CustomerId field.

5 In the Text area of the Text Properties dialog, click to the left of the CustomerId oval, and 
type Customer: followed by a space.

6 Click OK to close the Text Properties window.

7 Without changing the selected element, click the Text Element element icon on the toolbar.

8 In the General tab, enter Shipped: followed by a space.

9 Click OK.

10 Click the Text Element icon on the toolbar.

11 In the Text Properties dialog, click Data. The Edit Data Field dialog appears.

12 Select MainQuery.Ship_Date.

13 Click OK.

14 In the Format tab of the Text Properties dialog, choose dd-MMM-yy.

15 Click OK.

16 Without changing the selected element, click the Text Element icon on the toolbar. Click 
Data. The Edit Data Field dialog appears.

17 Select MainQuery.Ship_City and click OK.

18 In the General tab, click to the left of the Ship_City oval, type City: followed by a space.

19 Click OK to close the Text Properties dialog.

20 Preview and save the report.

If you add a data formatting mask to a numerical or date field in a text element, you cannot 
include any other text in the element. Instead, create a new text field for the other text.
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Resizing and Positioning Elements

Some of the new elements are too narrow, so the data wraps. You will need to move and resize 
these elements.

1 Select the right edge of the right-most (City) text element, and drag it to the right until it 
reaches the 600 px mark.

2 Now click in the middle of the element and move it about 100 px to the right.

3 Move the next two elements to the right also, so that the three are adjacent again.

4 Select the Customer element, click its right edge, and drag it to the right until it reaches 
the 300 px mark.

5 Preview the report. Continue to move and resize the elements in the header until they 
appear to your liking. 

Adding Space Between Groups

The top-level headers are too close to the previous group’s data rows. To create more space:

1 In the Design Pane, locate Group 1 Hdr in the sidebar. Click on the bottom boundary of this 
section and drag it down a few grid points.

2 Move each text element in the Group 1 Hdr section down to the bottom of the section.

3 Preview the report. You will now see empty space above the top-level headers.

Adding “Column” Headers at the Group Level

Now you’ll put headers on the product, price, and quantity details. You’ll put them in the 
Group 2 Hdr section, because these headers should appear just above the data rows for each 
second-level group.

1 In the Design Pane, locate the Group 2 Hdr section in the sidebar. Click on the bottom 
boundary and drag it down several ticks.

2 Click the Text Element icon on the toolbar. In the General tab of the Text Properties dialog, 
enter Product.

3 In the Style tab, select 8 pt as the font size and Underline as the effect. Set Horizontal 
Alignment to center. 

4 Click OK.

5 Drag the Product text element to immediately above the first data field in the Details 
section. Drag the sides of the Product text element so it is exactly as wide as the data field 
beneath it.

6 Create two more text elements the same way. Set the text of the first to Price and the 
second to Quantity. Style them in the same manner as you styled the Product text element.

7 Move and resize the Price and Quantity text elements as you did the Product element: drag 
them above their corresponding data fields in the Details section and adjust their widths.

8 Preview and save the report. The price and quantity data do not align with their headers. 
You will address this below, when you style the Details section.
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Applying Custom Styling to a Table

You have already styled individual text elements in the table. Now you will add styling to 
some table sections and to the table itself.

Styling Table Sections with the Toolbar

Using the toolbar to style your table allows you to see your changes as you make them. It also 
lets you style the table without opening a dialog or leaving edit mode.

1 In the Design Pane, select the Group 1 Hdr section in the sidebar. On the toolbar, click the 
Bold icon. The text in the header will turn bold.

2 Without changing the selection, click the Select Background Color icon in the toolbar. 
Choose lime from the drop-down list. The header background will turn bright green.

3 Now select the Details section. In the toolbar, in the drop-down list containing serif, choose 
Arial.

4 In the drop-down list containing medium, choose 8pt.

5 Click the Center alignment icon.

6 Preview the report.

Adding Borders Around the Entire Table

1 In the Design Pane, click outside the table to exit edit mode. Right-click the table and 
choose Style Component. The Tabular Editor appears.

2 In the Style tab, Borders area, select solid.

3 For Thickness, choose 3.

4 In the Color field, select blue.

5 Click OK.

6 Preview and save the report.

Adding a Single Border to a Text Element

Now you’ll add a border beneath the title. You can add a set of four identical borders around 
an element by using the Text Properties editor, but to add a single border, you must use the 
Properties area.

1 In the Design Pane, double-click the table to open it.

2 Click on the element containing the title, Orders and Product.

3 In the Properties area, located below the Tree view in the Design Pane, click the Box 
Settings folder button. The folder will open.

4 For Bottom Border Style, select solid.

You can select the entire table without leaving edit mode. To do this, click the 
small plus button at the top left corner of the layout, where the two sets of girders 
meet. Right-click this button to access the Table menu.
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5 For Bottom Border Width, enter 3.

6 For Border Color, select blue.

7 Preview and save the report.
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7 Creating a Crosstab
This chapter shows how to create and modify a crosstab. The crosstab is based on the query 
that you created in Chapter 3, Creating a Query.

This crosstab shows the number of units of each product sold in each quarter. It also displays 
aggregate totals for each product and category. Later, you’ll add the additional information of 
total sales of each product sold each quarter, and change the quarterly grouping to yearly.

Launching the Layout Wizard

The Layout Wizard launches automatically if you open a report that contains a query but no 
layout. You can also launch the Layout Wizard at any time by selecting Table, Chart, or 
Crosstab from the Insert menu.

Select File → Open and open the MainQuery.rdl file that you created in Chapter 3, Creating 
a Query.

Unless you have configured it not to, the Getting Started dialog appears.

If the Getting Started dialog does not appear, select Insert → Table.

Choosing the Columns for the Crosstab

First, choose the query, layout, and columns.

1 In the Select query area, select MainQuery.

2 Choose layout type crosstab.

3 Deselect all fields except the following:

• Category

• Ship_Date

• Product_ID

• Product

4 Click Next.
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Laying Out the Crosstab

1 In the Row Grouping 1 field, select Category.

2 Set Row Grouping 2 to Product.

3 For Column Grouping, select Ship_Date.

4 Group by Quarter.

5 For Summarized Fields, select Product_ID.

6 For Function, select count.

7 In the Include area, check Header, Row Group Summary, and Column Group Summary.

8 Click Next.

9 Select the slate theme.

10 Click Finish.

You should see the initial layout of the crosstab in the Design Pane.

11 Save the file as MyCrosstab, type Report.

Previewing the Crosstab

You have created the basic structure of the crosstab. To see how the crosstab looks in its 
current state:

1 Click the Preview tab.

2 Select HTML.

3 The default number of rows is too small, so you do not have enough data to really see the 
crosstab. Set Number of Data Rows to 100 and click Refresh.

At this point you have a readable crosstab, but you’ll want to improve the layout.

Adjusting the Layout

Changing the Title

1 In the Design Pane, double-click the crosstab to open it. Then double-click the title that 
says MainQuery report.

2 Replace the text with the text Sales by Category and Product.

In general, set Number of Data Rows to All only for crosstabs, and only when 100 returned rows 
does not provide enough data to get an idea how the crosstab will look. Returning all rows, 
especially for simple tables, may exceed the server’s memory limits.
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Eliminating the Subtitle

1 Right-click anywhere in the crosstab and select Edit Crosstab.

2 Under Optional Crosstab Sections, select Subtitle and click Delete.

3 Click OK.

Setting the Row Header

To set the row header:

1 In the Tree view, expand Crosstab, expand Crosstab Row Group, then select Crosstab 
Header. The appropriate cell is automatically selected in the Design Pane.

2 Select the General folder button.

3 For Text, enter Category.

4 Select the Preview tab to see your changes.

Setting the Column Header

To set the column header:

1 In the Tree view, Design tab, under Crosstab Column Group, select Crosstab Header. The 
Crosstab column header is automatically selected in the Design Pane.

2 Select the General folder button.

3 For Text, enter Quarter.

Setting the Row Summary Header

The row summary header has an unfriendly name. To change it:

1 In the Design Pane, double-click the crosstab to open it. Then double click the cell 
containing Ship_Date Summary to make it editable. Select all the text and replace it with 
Totals.

2 Preview and save the report.

Adding Another Summarized Data Field

Now, in addition to the number of orders, you’ll add the total number of units sold. To do this, 
you’ll add another summarized data field:

1 In the Design Pane, right-click the crosstab and select Edit Crosstab.

2 Open the Data tab.

3 In the Available Fields area, select Quantity.

4 Click Data.

5 Leave the Quantity function as sum.
Creating a Crosstab 43



6 Click OK.

7 Preview the report.

You’ll now see that each “row” contains two numbers. The top number represents number of 
orders and the bottom number total of units. To make this clear to the end user, alter one of 
the headers:

1 In the Design Pane, right-click on the crosstab and select Edit Crosstab. The Crosstab Editor 
dialog appears.

2 In the Labels tab, change Column Group 1 Header to Orders and Units Sold by Quarter.

3 Press Enter or click somewhere else in the dialog to make sure the label change is 
registered.

4 Click OK.

5 Preview the report.

Changing the “Bucketing”

The crosstab is “bucketed” by quarter. Now you’ll change it to by year:

1 In the Design Pane, right-click the crosstab and select Edit Crosstab.

2 In the Data tab, Column area, change Ship_Date’s Group By to Year.

3 In the Labels tab, Text column, change Quarter to Year.

4 Click the cursor elsewhere in the table and click OK.

5 Save and preview the report.
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8 Creating a Chart
When creating a chart with the Report Designer, you’ll notice some differences from tables 
and crosstabs:

1 In the Design Pane, you’ll always see the same image for the chart. To see how your chart 
appears, use the Preview tab.

2 You handle grouping in the query instead of in the layout. You have to modify SQL code. 
This chapter assumes you are familiar with the SQL language.

In this chapter, you’ll create a query for the chart, create the chart, and modify the chart type.

Creating the Query

For more detailed instructions on making a query, see Chapter 3, Creating a Query.

1 Click the New toolbar icon to start a new report.

2 From the Data menu, choose Query Wizard.

3 Select the demo data source and enter ChartQuery as the name. Click Next.

4 Select CATEGORIES and PRODUCTS and click Add. Click Next.

5 Choose CATEGORY_ID from both lists and click Link. Click Next.

6 From the CATEGORIES table, choose the CATEGORY_NAME column and click Add.

7 From the PRODUCTS table, choose UNITS_IN_STOCK and UNITS_ON_ORDER and click Add. 
Click Next.

8 Change CATEGORIES_CATEGORY_NAME to Category.

9 Change PRODUCTS_UNITS_IN_STOCK to InStock.

10 Change PRODUCTS_UNITS_ON_ORDER to OnOrder. Click Next.

11 Click Finish. Cancel the prompt for the Layout Wizard if it appears.

12 Save the file as MyChart.rdl.
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Editing the Query

Now you’ll edit the query to handle grouping in the layout.

1 In the Tree view, under Data Sources, right-click ChartQuery and select Edit SQL Query.

2 On the SQL tab, in the text area, find the SELECT statement. Change 
PRODUCTS.UNITS_IN_STOCK to: 

SUM(PRODUCTS.UNIT_PRICE* PRODUCTS.UNITS_IN_STOCK) as InStockValue

3 Change PRODUCTS.UNITS_ON_ORDER to:

SUM(PRODUCTS.UNIT_PRICE* PRODUCTS.UNITS_ON_ORDER) as OnOrderValue

4 At the end of the SQL statement, add the following clauses:

GROUP BY CATEGORIES.CATEGORY_NAME

ORDER BY InStockValue DESC

Your complete SQL statement is now:

SELECT CATEGORIES.CATEGORY_NAME,

  SUM(PRODUCTS.UNIT_PRICE* PRODUCTS.UNITS_IN_STOCK) as InStockValue,

  SUM(PRODUCTS.UNIT_PRICE* PRODUCTS.UNITS_ON_ORDER) as OnOrderValue

FROM CATEGORIES, PRODUCTS

WHERE CATEGORIES.CATEGORY_ID = PRODUCTS.CATEGORY_ID

GROUP BY CATEGORIES.CATEGORY_NAME

ORDER BY InStockValue DESC

5 On the Fields tab, click into the Type column for InStock and select float. Set OnOrder to float 
as well.

6 Click OK to save the query.

Uploading the Query to the Catalog

Save this query in the Catalog to reuse later.

1 In the Tree view, under Data Sources, right-click ChartQuery and select Upload Datasource.

2 Click OK. The query is now saved on the server.

Creating the Layout for a Pie Chart

Now you’ll use the query to create a 3-D pie chart that displays percentage values.

1 Click the Insert Chart icon on the toolbar.

2 In the Select Data fields window, leave Layout Type as Chart, and click Next.

3 Select type Pie. Leave Group By as Category and Data 1 as InStock.
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4 Click Next.

5 Verify that the Show Legend check box is checked and choose Top Right from the drop-down 
list.

6 Click Finish.

7 Preview the report.

8 Back in the Design Pane, right-click the chart icon and click Edit Chart.

9 On the General tab, click Percentage Values and 3-Dimensional Display.

10 Click OK.

11 In the Tree view, open the PieChart and select ChartHeader.

12 In the Properties area, click the General folder button.

13 For Height, enter 50.

14 Preview and save the report.

Converting the Layout to Another Chart Type

Now you’ll convert the pie chart you just created to a 2-D bar chart with inverted axes and two 
data fields.

1 In the Design Pane, right-click the chart icon and select Edit PopChart.

2 On the General tab, select Bar as Chart Type.

3 For Display Options, choose Inverted Axes and uncheck 3-Dimensional Display.

4 On the Data tab, select OnOrder from the Available Fields list and click Data. OnOrder 
appears in the Data Fields list.

5 Beneath the Data Fields list, check Show Ticks and Show Grid.

6 On the Labels tab, change the Chart Title to Inventory Value by Category. Change the legend 
labels to In Stock and On Order.

7 Click OK.

8 Preview the chart.

Turning Off Data Labels

You may want to turn off the data labels. To do this:

1 In the Tree view, open the BarChart and select ChartDataLabel.

2 In the Properties area, click the General folder button.

3 For Visible, select false.

4 Preview the chart.
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9 Creating a Multi-component Report
In Select Audit report terms, a component is a single table, crosstab, or chart. All the reports 
that you have created in previous chapters consisted of a single component. In fact, you can 
easily create a report containing multiple components as well as text elements or images that 
belong to none of the components.

This chapter shows how to create a report that contains two components: the simple table 
that you created in a previous chapter and a crosstab that presents the same data in a 
different format. You will also include text elements and images associated with neither 
component.

There is no limit to the number of components and fields that you can add to your report.

Adding a Simple Table

You will start by using the simple table (MySimpleTable) that you created in Chapter 4, 
Creating a Simple Table and stored in the Library.

1 Select File → Open From Server.

2 In the Open a Report dialog, navigate to the MySimpleTable report that you saved 
previously. Select it and click OK.

3 Save the file as MyMulticomponent, type Report Files.

Creating a Crosstab

You’ll now create a crosstab above the simple table.

1 Click on the simple table and drag it down about 300 pixels (that is, the top of the table is 
at the number 3 on the vertical ruler).

2 Click the area above the simple table. You’ll notice that the entire layout is selected.

3 Click the Insert Crosstab icon on the toolbar. (If the icon isn’t visible, either enlarge the 
Report Designer window or select Insert → Crosstab.) The Layout Wizard appears.

4 Leave the query as MainQuery and the layout type as Crosstab.

5 Uncheck all but the following fields:

• Category

• Ship Date

• Product ID

6 Click Next.
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7 For Row Grouping 1, select Category. Group by Unique Value.

8 For Row Grouping 2, select None.

9 For Column Grouping, select Ship_Date. Group by Quarter.

10 For Summarized Fields, select Product_ID. For Function, select count.

11 In the Include area, check Header, Row Group Summary, and Column Group Summary, but not 
Footer.

12 Click Finish. The crosstab appears in the Design Pane.

Changing the Crosstab Labels

1 Right-click on the crosstab, and select Edit Crosstab.

2 In the Labels tab, change the Title text to Products Sold By Quarter.

3 Still in the Labels tab, change the Row Group 1 Summary section text to Total per Quarter.

4 Still in the Labels tab, change the Column Group 1 Summary section text to Total per 
Category.

Putting Borders Around the Crosstab

1 Click on the Style tab.

2 In the Styles for: drop-down list, make sure Crosstab is selected.

3 In the Borders area, for Style, select solid.

4 For Thickness, select 5.

5 For Color, select black.

6 Click OK to close the Crosstab Editor.

Adding Fields to the Layout

Adding a Label to the Crosstab

1 Click on the crosstab to select it, then drag the component until the upper-left-hand 
corner is 100 pixels to the right and 100 pixels down (that is, at the 1 mark on the vertical 
ruler).

2 Click the Insert Text icon.

3 In the Text Properties dialog, General tab, type in the text Product Sales.

4 In the Style tab, choose font Arial, size 12 pt, effects Bold.

5 Click OK.

6 The new text element may appear to the right of the crosstab. If so, drag it to the left and 
place it above and to the left of the crosstab so that the lower-right-hand corner of the text 
element is at the same height as the upper-left-hand corner of the crosstab.
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Adding a Label to the Simple Table

Now you’ll add a label to the left of the simple table.

If you try to select and drag the table to the right, you may not be able to. This is because the 
table has taken up the whole allotted width of the layout. To add the label:

1 Click somewhere in the layout other than on one of the tables.

2 Drag the right side of the layout to the right. You may have to scroll to the right to see the 
right side of the layout.

3 Now move the table by selecting it and dragging it to the right. Leave the same amount of 
room on the left side as you did for the crosstab.

4 Repeat the process in Adding a Label to the Crosstab on page 50 to create a new text 
element. Make the text of the field List of Orders. Drag it to the left of the simple table, and 
place it so the lower-right-hand corner of the text element is at the same height as the 
upper-left-hand corner of the simple table.

Adding a Report Title

So far, the only report titles we have used are headers inside a component. For this report, 
you’ll create a text header that is not part of any component.

1 Click outside the components to select the entire layout.

2 Click the Text Element icon. In the Text Properties box, General tab, enter Products and 
Orders.

3 In the Style tab, set Arial font, size 24 pt, Effects Bold.

4 Click OK.

5 Drag the new text element to the top of the layout.

6 Drag the right side of the text element to increase its width to 300 pixels.

Adding an Image

Now you’ll add an image beneath the report title. Since the image must be on the server to 
appear in the report, this example uses an image that is provided with the Report Server. For 
a real report, upload the image to the server before creating your report.

1 Click the image icon on the toolbar.

2 In the Image Editor dialog, for the image URL, enter:

/scopeserver/images/user/palmtree.jpg

3 Set width to 30 and height to 30.

4 Check the Set image size in report option.

5 Click OK.

You cannot overlap the image with a text element or component. If you do, the image will 
spring back to its original location. To avoid this, either use the Image Editor to reduce the 
image’s size and width or move the other objects around to make more room for the image.
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6 Drag the icon to underneath the report title.

7 Preview the report.

8 The image is too small. In the Design Pane, click the image to select it, then drag the 
lower-right-hand corner of the image to make it slightly bigger.

9 Preview and save the report.

If Set image size in report is not checked, the image always maintains its original 
size even if the containing object is enlarged.
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10 Controls and Parameters
A control performs one of two functions in a report:

• It performs an action pre-defined by Select Audit (i.e. download, export, profile selection 
or creation). For an example of adding a pre-defined control, see Adding the download 
control on page 57.

• It allows the end user to restrict the values that appear in a component (table, crosstab, or 
chart). For example, the control can let the end user restrict the report to display only 
orders for a certain product or ship date. See Using Fixed-list and Free-text Controls on 
page 54 for instructions on adding some of these controls.

Controls that restrict displayed values are bound to parameters. You must create the 
parameter before you bind it to a control. You must also alter the query that provides data for 
the component whose value you want to restrict.

The three kinds of parameter values are:

In this chapter, you’ll create these three kinds of parameters as well as the controls to bind 
them to. You’ll also create a control that performs a pre-defined action (download).

It’s better to plan for the controls the report will contain before you create the query that 
provides data to the components. This allows you to design the original query to include the 
parameters that will be bound to the controls. It is possible to add a parameter to the query 
after you have already designed the component, but to do this you must alter the query that 
provides data for the component.

To create controls that restrict values, you should be familiar with the SQL language.

fixed-list You provide a pre-defined list of values for 
the end user to choose from. Fixed-list 
parameters are bound to check box, list 
menu, and radio button controls. (See 
Creating a fixed-list parameter on page 55.)

allow any value The end user can type any text into a box. 
These parameters are associated with text 
fields and calendar controls. (See Creating 
free text parameters on page 55.)

query-based These parameters are based on queries 
defined in the report. They are typically 
associated with a list menu control. You must 
create a new query to use this kind of 
parameter. (See Creating Controls Bound to 
Query-based Parameters on page 58.)
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Using Controls

The Select Audit controls are:

Using Fixed-list and Free-text Controls

In this example, you’ll begin with the query that you created in Chapter 3, Creating a Query, 
modify it to incorporate some parameters, create the parameters, and bind them to controls. 
The controls that you’ll create are:

• A check box control consisting of some of the products in the table. (See Creating a 
fixed-list parameter on page 55.)

Download Loads the report into a browser in any of several output formats, 
including HTML or PDF format.

Export Saves the report to the Report Server in any of a variety of formats.

Push Button A button that is defined either to submit the report to the server or 
to reset the controls in the report. (Using JavaScript, you can also 
assign some other action to a push button.)

Radio Buttons A set of buttons allowing a single choice among a closed set of 
choices.

Check boxes A set of boxes allowing multiple choices among a closed set of 
choices.

List A drop-down list or fixed-size list containing single or multiple 
choices.

Image Button Like a submit push button, but displays an image of your choosing 
rather than a button.
If the image source that you specify is not a full URL, it may not 
display correctly in the Preview pane.

Print Button An icon that prints the report.

Profile Manager A drop-down list that lets you choose from a list of profiles, or create 
a new profile. (In Select Audit terms, a profile is a saved set of 
parameter values.)

Calendar A control that lets you choose the month, day, and year.

Download Loads the report into a browser in any of several output formats, 
including HTML or PDF format.

You can fine-tune the action of a control by using the Actions tab in the Controls Editor. You 
can use JavaScript to define the action when end-user action triggers an event.

This chapter shows how to make a working report with various types of parameters. It does 
not show how to style the report. For examples of styling a report, see Chapter 4, Creating a 
Simple Table.
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• Two free-text controls, one for the minimum order number and one for the maximum. (See 
Creating free text parameters on page 55.)

• A download control, which lets you view the report in a browser.

• A submit button, which sends the end user’s control values to the Report Server.

Opening the Query

1 Click the Open File icon and select MainQuery.rdl, which you created in Chapter 3, 
Creating a Query.

2 If the Getting Started dialog appears, click No to using the Layout wizard.

3 Select File → Save As and save the file as MyControls.rdl.

4 Select File → Server → Login to connect to a server.

Creating the Parameters

This section shows how to create the fixed-list and free-text parameters.

Creating a fixed-list parameter

First, you’ll create a fixed-list parameter, which you will later bind to a check box control. (You 
could also bind it to a radio button or list control in much the same way.)

1 From the Data menu, select Add Parameter.

2 In the Parameter Editor, name the parameter FixedListParameter.

3 For Parameter Values, select Fixed List, then click Set Values.

4 In the Values and Labels dialog, click New.

5 In the line that appears, enter value Chai for the value.

6 Similarly, enter new values Chang, Aniseed Syrup, Perth Pasties, and Ravioli Angelo.

7 Click the Default check box next to Chai.

8 Click OK to close the Values and Labels dialog.

9 Click OK to close the Parameter Editor. FixedListParameter appears in the tree.

Creating free text parameters

1 From the Data menu, select Add Parameter.

2 In the Parameter Editor, name the parameter MinimumOrderNo.

3 Select Allow any value. For Default, enter 10000.

4 Click OK. MinimumOrderNo appears in the tree.

5 From the Data menu, select Add Parameter.

6 Name the new parameter MaximumOrderNo.

7 Select Allow any value, For Default, enter 11000.

8 Click OK. MaximumOrderNo appears in the tree.
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Modifying the Query

Now, we’ll add the parameters to the query from which we’ll create the component (in this 
case, a simple table).

Add the FixedListParameter parameter

1 In the Tree view, expand Data Sources.

2 Right-click MainQuery and select Edit SQL Query. The SQL editor appears.

3 From the SQL query, copy PRODUCTS.PRODUCT_NAME from the SELECT list and paste it 
into the Column Name text field below. (If you prefer, you can just type it directly into the 
text field without copying and pasting.)

4 Leave Type as String and Comparison as “=”.

5 In the Parameter field, select FixedListParameter.

6 Place the cursor at the very end of the WHERE clause, hit the carriage return and then type 
the word And with a space after it.

7 Click Insert. The parameter should appear in the SQL query.

Add the MinimumOrderNo parameter

1 From the SQL Query, copy ORDERS.ORDER_ID from the select list and paste it into the 
Column Name text field below.

2 Set Type to number.

3 Set Comparison to > (greater than).

4 For Parameter, pick MinimumOrderNo.

5 Place the cursor at the very end of the SQL query, hit the carriage return and then type 
the word And with a space after it.

6 Click Insert. The parameter should appear in the SQL query.

Add the MaximumOrderNo parameter

1 Set Comparison to < (less than).

2 For Parameter, pick MaximumOrderNo.

3 Place the cursor at the very end of the SQL query, hit the carriage return and then type 
the word And with a space after it.

4 Click Insert. The parameter should appear in the SQL query.

5 Click OK.

If there is an ORDER BY clause, make sure to add the parameter in the WHERE 
clause, above the ORDER BY clause.

This example uses a query that already contains a WHERE clause. If the query has 
no WHERE clause (this typically happens when the query was built on a single 
database table and you have not yet added any other parameters), instead of 
typing And or Or in the SQL editor, type the word WHERE instead.
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Creating the Component

Now you’ll create a component based on the query that you’ve just added parameters to. In 
this example, the component is an extremely simple table. You won’t format the table much; 
this section is to show how the table works with the controls.

1 In the icon bar, click the Insert Table icon.

2 In the Layout Wizard, leave the query as MainQuery.

3 Leave the Layout Type as Tabular.

4 Uncheck all fields except Order_ID, Ship_Country, and Product.

5 Click Next.

6 Leave the Layout Type as Simple Table.

7 In the Include area, uncheck Table Footer.

8 Click Finish. The table appears in the Design Pane.

Adding the Controls

Now you’ll add the controls to the layout.

Adding the download control

A download control enables the end user to view her report in a browser. Adding a download 
control is very straightforward. (Export and profile controls are equally simple.) To add a 
download control:

1 In the Design Pane, click on the table to select it, then drag it down 100 pixels, (that is, to 
where the top of the table is next to “1” on the vertical ruler).

2 In the Design Pane, click somewhere outside the component to select the entire layout, 
then select Insert → User Control → Download from the top menu.

Adding the check box control

1 In the Design Pane, click somewhere outside the component and download control, then 
select Insert → User Control → Checkboxes from the top menu.

2 In the Controls Editor, General tab, leave Control Type as Checkboxes.

3 For Associated Parameter, select FixedListParameter.

4 Click OK.

5 For Orientation, select Horizontal.

6 For Label Position, select Right.

7 Select OK.

8 Preview the report. You should see the download control and the check boxes.

9 Save the report.

In Preview mode, some controls are disabled.
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Adding the free-text controls

Now, you’ll add the free-text controls that specify minimum and maximum order numbers 
that you’ll want to display.

1 In the Design Pane, click somewhere outside the component and download control, then 
select Insert → User Control → Text Field from the top menu.

2 For Associated Parameter, select MinimumOrderNo.

3 For Width, enter 7.

4 Again in the Design Pane, click somewhere outside the component and download control, 
then select Insert → User Control → Text Field from the top menu.

5 For Associated Parameter, select MaximumOrderNo.

6 For Width, enter 7.

7 Click OK.

Adding the Submit control

The report needs a submit button so that the end user can send her choices, made through 
controls, to the server:

1 Right-click the layout outside the component and controls, then select Insert → User 
Control → Button from the top menu.

2 Leave the default function and label: Submit.

3 Click OK.

4 Preview and save the report.

Creating Controls Bound to Query-based Parameters

The values in a list control can be populated in one of two ways:

• by pre-defining the values in the list. See Using Fixed-list and Free-text Controls on 
page 54 for instructions on how to define a fixed-value parameter.

• by defining a query to populate the control.

In this section, you’ll create a drop-down list control that enables the end user to restrict the 
report results to certain countries. A database query populates the list.

Creating a Query for the Parameter

In this section, you’ll create the query that returns the countries to which orders have been 
shipped.

1 Open MyControls.rdl. Stay on the Design tab.

2 In the Tree view, right-click on Data Sources and select Query Wizard. The Query Definition 
Wizard appears.

3 Choose demo for the data source.

4 Enter CountriesQuery for the query name.
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5 Click Next.

6 In the Select Table screen, select Orders and click Add.

7 Click Next.

8 From the available columns, select SHIP_COUNTRY and click Add. ORDERS/SHIP_COUNTRY 
appears in the Selected Columns area.

9 Click Next.

10 In the Column Details window, make no changes and click Next.

11 In the Filter Results window, make no changes and click Next.

12 In the Choose Sorting window, click Add.

13 In the Name field, select ORDERS/SHIP_COUNTRY.

14 Leave ORDER as Ascending.

15 Click Finish.

You need to make one more change to the query: Make sure that the query returns only one 
instance of each country. To do this:

1 In the Tree view, right-click CountriesQuery and select Edit SQL Query. The SQL Editor 
appears.

2 In the SQL tab, type the word DISTINCT in the query after SELECT.

3 Click OK to close the SQL Editor.

Creating the Parameter

1 In the Tree view, right-click MainQuery and select Edit SQL Query. The SQL Editor appears.

2 Click Add Parameter. The Parameter Editor opens.

3 For in the Name field, enter CountriesParam.

4 Click From query and select CountriesQuery.

5 Click OK to close the Parameter Editor.

6 Click OK to close the SQL Editor.

Adding the Parameter to the Main Query

1 In the Tree view, right-click MainQuery and select Edit SQL Query.

2 Place the cursor at the very end of the SQL query, hit the carriage return and then type 
the word And with a space after it.

3 Copy ORDERS.SHIP_COUNTRY from the query and paste it into the Column Name field.

4 Leave Type as string and Comparison as “=” (equals).

5 From the Parameter drop-down list, select CountriesParam.

6 Click at the end of the query.

7 Click Insert.

8 Click OK to close the SQL editor.
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Adding the Control

Now you’ll create a list control populated by the results of CountriesQuery. The list will be five 
lines high and will require the end user to select a single country.

1 In the Design Pane, right-click outside the controls and select Insert → User Control → List 
from the top menu. The Controls Editor appears.

2 For Associated Parameter, select CountriesParam.

3 For Size in lines, enter 5.

4 Do not check Allow multiple selection.

5 Do not check Allow no selection, labeled as.

6 Click OK to close the Controls Editor.

Rearranging the Controls

1 In the Design Pane, drag the download control to the right of the list control.

2 Drag the list control to underneath the check boxes control.

3 Drag the text fields under the download control, the one associated with the control 
associated with the minimum parameter on top.

Add Labels to the Controls

1 In the Design Pane, to the left of the check boxes control, right-click and select Insert Text 
Element.

2 In the Text Properties dialog box, enter Choose Products:.

3 Drag the new element to left of the check boxes control.

4 Similarly, next to the list control add a text element saying Country:, and next to the 
free-text controls put From Order: and To Order:.

Add the Selected Country to the Header

This report forces the end user to restrict table results to a single country. You’ll add the name 
of that country to the table header.

1 Click the table to select it, then double-click to make it editable.

2 Right-click on the top row of the table header, which contains the text MainQuery Report, 
and select Edit Text Element.

3 Delete the text (MainQuery Report) in the text box.

If you check Allow multiple selection, all items in the list can be deselected at once. Therefore, if 
you allow multiple selection, you do not need to (and cannot) enter a default label for Allow no 
selection.

Checking Allow no selection, labeled as would give the end user the option to bypass all items 
in the list. Typically, you’d use a label like All Countries.
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4 In the General tab, click Data. The Edit Data Field dialog appears.

5 In the Select Data Field drop-down list, select Parameters.CountriesParam.

6 Click OK to close the Edit Data Field dialog. An oval representing the parameter value (in 
this case, the name of the country that you selected in the list control) appears.

7 In the Text Properties dialog, click the cursor to the left of the symbol for the parameter.

8 Type Orders Shipped To: followed by a space.

9 Click OK to close the Text Properties dialog.

10 Double-click on the field Order_ID and change the name to Order ID. Similarly, change 
Ship_Country to Country.

11 Save and preview the report.

Since there is no default value for the parameter, all countries will show up on 
preview, and no parameter value will appear in the table header. To see the 
behavior of the report, publish the report and run it in the server.
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11 Using Report Links and Drilldowns
You can link one report to another to give the end user additional information about a specific 
data value. This type of special hyperlink is called a report link.

The report that contains the link is the source report. Clicking the link brings you to the 
target report. The target report typically includes one or more parameters. The relevant 
values for these parameters are passed from the source report through the report link to the 
target report.

In this chapter, you will create a parameterized target report with a pie chart and a label. 
Then you will add report links to some of your existing reports.

Creating a Parameterized Target Report

The target report uses a query-driven parameter (see Chapter 10, Controls and Parameters). 
You will define the query, add the parameter, and modify the chart query. Finally, you will 
create a new pie chart and add a parameterized title.

Creating a Query for the Parameter

First, you’ll create a query to drive the parameter.

1 Click the New toolbar icon to start a new report.

2 In the Tree view, right-click Data Sources and select Query Wizard.

3 Choose demo for the data source, and enter CategoriesQuery for the name.

4 Click Next.

5 Select the CATEGORIES table and click Add.

6 Click Next.

7 Select CATEGORY_NAME and click Add.

8 Click Finish. Cancel the prompt for the Layout Wizard if it appears.

9 Save the file as TargetReport.rdl.
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Creating the Parameter

Now, you’ll create the parameter driven by the query that you just created.

1 In the Tree view, right-click Parameters and select Add Parameter.

2 In the Name field, enter CategoriesParam.

3 Choose the From query option and select CategoriesQuery.

4 Click OK.

5 Save the file.

Modifying the Chart Query

Now, you’ll modify the chart query to include the parameter.

1 In the Tree view, right-click Data Sources and select Get Datasource.

2 Choose ChartQuery and select the Copy from catalog option.

3 Click OK. The query appears in the Tree view.

4 In the Tree view, right-click ChartQuery and select Edit SQL Query.

5 Change the name of the query to TargetQuery.

6 Copy CATEGORIES.CATEGORY_NAME from the SELECT statement and paste it into the 
Column Name field near the bottom of the SQL Editor. 

7 From the Parameter drop-down list, select CategoriesParam. Leave the other settings as 
they are.

8 In the SQL box, change CATEGORIES.CATEGORY_NAME to PRODUCTS.PRODUCT_NAME in 
the SELECT statement.

9 Make the same change in the GROUP BY clause.

10 Start a new line between the WHERE clause and the GROUP BY clause. Type And with a 
space after it.

11 Click Insert near the bottom of the editor.

12 On the Fields tab, click Category and change the text to Product.

13 Click OK to close the SQL Editor.

14 Save the file.

Creating the Pie Chart

Now, you’ll create the pie chart.

1 Click the Insert Chart icon on the toolbar.

2 Select TargetQuery in the drop-down list. Click Next.

3 Select type Pie. Leave Group By as Product and Data 1 as InStock.

4 Select the 3-D Pie icon. 

5 Click Next.
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6 Select the text InStock by Product from the Chart Title field and remove it. (You will add a 
title later in Adding a Parameterized Title on page 65.)

7 Verify that Show Legend is checked, and leave the location at Bottom Right.

8 Click Finish.

9 Preview the report. The labels appear clipped at the left edge.

10 In the Design Pane, click on the right edge of the chart image and drag it out to line up 
with the number 700 on the horizontal ruler.

11 Preview the report and save the file.

Adding a Parameterized Title

Now you’ll add a chart title that changes with the value of the parameter.

1 Click in the center of the chart image and drag it down so that the top lines up with the 
number 1 on the vertical ruler.

2 Click outside the chart to select the layout.

3 Click the Text Element icon on the toolbar. In the Text Properties box, type Inventory Value by 
Product: with a space after it.

4 Click Data and select Parameters.CategoriesParam from the drop-down list. Click OK. The 
CategoriesParam oval appears to the right of the text in the Text Properties box.

5 In the Style tab, set Arial font, size 16 pt, Horizontal Alignment Center, Effects Bold.

6 Click OK.

7 Drag the new text element to a position above the chart. Line up the left edges using the 
girders as a guide.

8 Drag the right edge of the text element to increase its width to 700. Drag the top or bottom 
edge until all the text is visible.

9 In the Preview tab, preview the report with 25 rows of data.

10 Save the file.

Publishing the Target Report

Finally, you’ll publish the report to the Library.

1 From the File menu, choose Publish.

2 Click on the User Reports folder to select and open it.

3 Click OK to upload TargetReport to the User Reports folder.
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Adding a Report Link to a Table

The target report you have just created displays inventory value by product, with a parameter 
that can limit the results to a specific product category. You will create a report link that 
passes a single category as a value for this parameter. The report link will be associated with 
a text element that displays the category value.

The free-form group table you created in Chapter 6, Creating a Free-form Group Table 
includes the category value in its Group 2 Header. You will modify this element to include a link 
to your target report.

1 Open FancyGroup.rdl.

2 Double-click on the table.

3 In the section labeled Group2 Hdr, select the text element containing the group name. This 
should be the first element in the header.

4 Right-click the element and select Edit Text Element. In the Text Properties dialog, the words 
Group Name are visible in the gray oval.

5 Choose the Hyperlink option in the Link (optional) section below the text box.

6 Select _blank from the Target drop-down list, then click Report Link.

7 Click Browse at the top and double-click the User Report folder.

8 Select TargetReport and click OK.

9 Click in the Value field for CategoriesParam and select Category from the drop-down list.

10 Click OK to close the Report Link Editor.

11 Click OK to close the Text Properties dialog.

12 Preview the report. The category names appear as hyperlinks.

13 You cannot test the hyperlinks in the Preview pane. You will have to publish the report and 
then run it from Report Server.

14 Select File → Publish, click the User Reports folder, and upload your report. 

15 (Optional) Go to Report Center and run the report (see the HP OpenView Select Audit 1.01 
Report Center User’s Guide for more information). Click a hyperlink that says Produce. A 
new browser window opens showing the target report titled Inventory Value by Product: 
Produce that includes only products from the Produce category.

16 Save the file.
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12 Other Topics
Adding Headers and Footers

In Chapter 5, Creating a Group Table, you deleted the footer. In Chapter 6, Creating a 
Free-form Group Table, you unchecked the group footer option in the Layout Wizard. This 
section shows how to add headers and footers if you’ve deleted or omitted them. You’ll start 
with a table that has had the footer removed. After adding a footer, you’ll add summaries to it.

Adding a Footer

When you created your free-form group table, you did not include any footers or summaries. 
Now you’ll add them.

1 Open FancyGroup.rdl, which you created in Chapter 6, Creating a Free-form Group 
Table.

2 Right-click in the table and select Edit Table.

3 On the General tab, you will see a list of all the sections currently in your table. 
Underneath this list is a drop-down list of additional sections. Select Group 2 Footer in the 
drop-down list and click Add.

4 Click OK. The table now includes the group footer.

Adding Summaries

Now you’ll add summaries to the footer you have just created. In this example, you will add 
only the average unit price. 

1 Double-click the table to open it.

2 Select the section labeled Group2 Ftr, then click the text icon in the toolbar.

3 On the Text Properties dialog, click Data.

4 On the Edit Data Field dialog, click Add Summary.

5 For Data Field, select Unit Price. For Summary Function, choose avg.

6 Click OK to close the Summary Field Editor. You will see avg(Unit_Price) selected in the Select 
Data Field drop-down list.

7 Click OK to close the Edit Data Field screen. You will see a gray oval with 
Unit_Price_Group2_Summary in the Text Properties box.

8 Click the Style tab and set the style to Arial, 8pt, Bold, with center alignment.

9 Click the Format tab and select the 0.00 mask.

10 Click OK to close the Text Properties dialog.
  67



11 Select the new text element and move it to the right until it aligns with the Unit_Price 
element in the Details section. Drag its right edge until the two elements are the same 
size.

12 Preview the report.

Conditional Formatting

You can change the format for cells in a table based on a condition. For example, you can 
specify that numbers below a certain value appear with a certain color or background.

In this example, you’ll use a simple table that you have already created and mark all quantity 
values beneath 50 in red.

1 Open MySimpleTable.rdl, which you created in Chapter 4, Creating a Simple Table.

2 Save the report as ConditionalQuantity.rdl.

3 In the Design view, double-click the table to open it.

4 In the Details area, right-click the quantity cell and select Style Element. The Text Properties 
window appears.

5 In the Style tab, click Conditional.

6 In the IF area, select the field Quantity.

7 Change the operator to “<“ (less than).

8 In the field to the right of the operator, enter 50.

9 In the THEN area, Foreground field, select red.

10 Click OK to close the Define Conditional Style dialog.

11 Click OK to close the Text Properties dialog.

12 Preview the report and observe the values in the Quantity column.

13 Save the report.

When you add a summary field, you are actually adding a new object to the report. This object 
appears in the Tree inside the appropriate Nested Band or at the bottom of the Banded Table. 
Deleting a text element that contains a summary field does not remove the object. The object 
continues to appear as an option in the Edit Data Field drop-down list in the appropriate 
context.
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