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Legal Notices
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warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2006 Hewlett-Packard Development Company, L.P.

Trademark Notices

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.
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Documentation Updates

This manual’s title page contains the following identifying information:

• Software version number, which indicates the software version

• Document release date, which changes each time the document is updated

• Software release date, which indicates the release date of this version of the software

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

You can visit the HP OpenView Support web site at:

www.hp.com/managementsoftware/support 

HP OpenView online support provides an efficient way to access interactive technical support tools. As a 
valued support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels, go to:

www.hp.com/managementsoftware/access_level 

To register for an HP Passport ID, go to:

www.managementsoftware.hp.com/passport-registration.html 
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Preface
The information in this document is for advanced users who are responsible for customizing, 
installing, and configuring the HP OpenView DecisionCenter data warehouse. Refer to the 
HP OpenView Online Help for standard changes to the data warehouse.

Refer to the HP OpenView DecisionCenter Installation Guide for information about migrating 
an out-of-box DecisionCenter. This document has instructions for migrating a customized data 
warehouse.

You must be familiar with data warehouse schemas, Connect-It scenarios, and 
Business Objects universes. Ensure that you have access to, and permissions to use, the 
resources on the computer and network of the HP OpenView DecisionCenter 1.00 installation.
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1 Advanced Customization
The data warehouse, formerly called the Reporting Data Store (RDS), is a repository of 
integrated information that is available for queries and analysis. It contains the universe, 
which stores information in the data warehouse database. Administrators can customize the 
data warehouse by editing the data warehouse schema, Connect-It scenario, and the universe. 
DecisionCenter Analytics online help provides customization guidelines. Advanced data 
warehouse customization requires additional technical information to implement the changes. 
Familiarization with the Data Warehouse Administration Online Help topics is a prerequisite 
to advanced data warehouse customization. 

Customization Overview

You can customize the data warehouse schema by editing the out-of-box AssetCenter 
rdsac_etl.xml file and ServiceCenter rds_etl.xml file. When you edit any xml file, use 
an xml editor tool such as XML Spy, which validates your changes against the schema file.

Implementation Plan

Planning the customization implementation is critical when you change the ServiceCenter 
schema or DecisionCenter Analytics reporting content. By completing the DecisionCenter 
Analytics Questionnaire, you can prepare to implement your plan. For more information, see 
Appendix A, DecisionCenter Analytics Questionnaire.

The pilot project is responsible for ensuring that the DecisionCenter Analytics content is 
satisfactory before moving to the production environment. A successful pilot project requires 
these actions:

• Define the requirements analysis of reports and systems such as data sources, version, 
and data volume

• Install DecisionCenter Analytics in a test environment that includes configuring 
DecisionCenter Analytics and creating reports based on the requirements

The specific task to customize DecisionCenter Analytics includes modifying the schema, 
Connect-It scenarios, and the universe (see Task 2). Complete all the tasks to implement the 
plan.

Task 1: Review requirements analysis of reports and current system (1-3 days).

• Step 1a: Review current system and overall DecisionCenter Analytics deployment 
environment.

• Step 1b: Verify assumptions and gather requirements, such as data sources, 
ServiceCenter version, data volume, and sync back point. 

• Step 1c: Complete the DecisionCenter Analytics Questionnaire on page 81.
9



Task 2: Customize your environment.

• Step 2a: Customize the Schema on page 16.

• Step 2b: Customize the Connect-It Scenario on page 34.

• Step 3: Customize the Universe on page 41.

Task 3: Implement your customization changes in a test environment (1-5 days).

• Step 3a: Install DecisionCenter Analytics with a typical configuration on the test servers.

• Step 3b: Configure all components to start DecisionCenter Analytics.

• Step 3c: Create a test DecisionCenter Analytics user account with logon rights.

For more information, refer to the HP OpenView DecisionCenter Installation Guide. 

Task 4: Map and test the tailored data schema (3-12 days).

• Step 4a: Customize the DecisionCenter Analytics data schema and synchronization. 

• Step 4b: Test the following:

— Schema difference checking based on ServiceCenter 5.1 schema

— Customization for changed fields

— Data warehouse schema updates

— Connect-It scenarios updates

— Universe updates

— Connect-It data warehouse scenario execution

— Report creation for 3-5 reports

For more information, refer to the HP OpenView DecisionCenter Installation Guide. 

Task 5: Deploy DecisionCenter Analytics to a production environment.

For more information, refer to the HP OpenView DecisionCenter Installation Guide. 

Task 6: Continue to customize the schema, scenarios, and universe, as needed.

Customization is an ongoing process. To adhere to best practices, always back up your files 
before you make changes.

Best Practices for Data Warehouse Customization

For easy migration and maintenance, set proper naming conventions for customized fields 
and tables. For example, to modify the data warehouse schema, the new attributes or tables 
can start with C_ to mean Customized.

Always back up the rds_etl.xml file before you modify the data warehouse schema. To 
adhere to best practices, do not remove the out-of-box data warehouse files and fields. 

When customizing any xml file, use an xml editor tool to validate your changes against the 
schema file. 

The DecisionCenter synchronization process marks AssetCenter and ServiceCenter deletion 
event records in the data warehouse. To adhere to best practices, do not customize the deletion 
process because it may break the existing metadata and sample reports. 
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Naming Conventions

The data warehouse uses consistent naming conventions.

• All the entities in the data warehouse, such as tables or fields, use uppercase. For 
example, INCIDENT_D.

• All the attributes or fields for the data warehouse xml data use single ('…') quotation 
marks. For example, ‘dimensionTableFields’.

All the files or fields for ServiceCenter use double (“…”) quotation marks. For example, 
“incident.id”.

• All the sample codes or xml data definition use Italic font, for example, sample code.

Schema Overview

The Overview: Data warehouse and Schema description online help topics provide an 
introduction to the schemas.

Schema Names

Data warehouse tables use the following categories:

• Dimension tables

• Fact tables

• Aggregates of fact tables

• Associate and join tables

• Hierarchy tables

• Directing mapping tables from ServiceCenter transaction tables

• Data warehouse system tables

Table names use these conventions:

• Dimension table names end with _D and have a maximum 15 characters. If the primary 
key for the dimension name is Z_RDSXXX_DID, assume the dimension table name is 
XXX_D.

• Fact table names end with _F.

• Aggregate table names end with _AGG.

• Associate or bridge table names are the first 8 characters from the two associated table 
names with an underscore (_) as the separator. All the associate or bridge table names end 
with _ASS.

• Direct mapping table names are identical to the source name.

• Hierarchy table names and data warehouse Extract, Transform, and Load (ETL) 
process-related table names begin with BI_.

• Data warehouse system table names begin with RDS_.

Most dimension table fields map directly from ServiceCenter tables through Connect-It. 
Dimension tables have additional data warehouse ETL attributes. 
Advanced Customization 11



The dimension tables come from the ServiceCenter files. The attributes have history, are 
time-related, or have searchable criteria for multiple ServiceCenter reporting modules. 

There are more schema changes for AssetCenter dimension tables comparing AssetCenter 
source tables. For examples, AMASSET_D table is the result of de-normalized amPortfolio, 
amComputer, amAsset, and amSoftIntsall tables. Fact tables are the data warehouse 
tables created to store the measurements and join relationships for associated dimension 
tables. Data warehouse fact tables, hierarchy tables, or aggregate tables store the summary 
data for Online Analysis Process (OLAP) reporting. Data warehouse direct mapping tables 
come from the ServiceCenter transaction tables that contain the attributes that are not 
historic reserved data. Direct mapping tables use the measurements for detail reporting. 
Associate, or bridge, tables created in the data warehouse are used for sub-dimension tables 
or solving many-to-many relationships. Data warehouse system tables created in the data 
warehouse audit the ETL process and store DecisionCenter security and system data. You can 
review the ETL statistics data and data integrity by querying data warehouse system tables 
through DecisionCenter.

DecisionCenter Analytics Content

The data warehouse default schema contains tables for ServiceCenter OLAP summary 
reporting and operational detail reporting as well as AssetCenter Portfolio, Finance, and 
Contract. 

Sample reports are available for ServiceCenter and AssetCenter modules. Common support 
files are linked with ServiceCenter modules. For more information about how AssetCenter 
tables in the data warehouse relate to each other, see Appendix D, Data Warehouse 
AssetCenter ERD.

Metadata Overview

The data warehouse metadata consists of the data warehouse schema, Extract, Transform, 
and Load (ETL) process, and the data warehouse semantic layer (the universe).

Table 1 Default Schema Content

Content ServiceCenter AssetCenter

Modules • Change Management
• Configuration Management
• Incident Management
• Problem Management
• Service Level Agreement Management
• Service Management

• Portfolio
• Finance
• Contract

Common Support Files • Contacts
• Location
• Dept
• Company
• Operator
• Vendor
• Model
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Schema

The rds_etl.xml file provides data warehouse schema data. The rds_etl.xsd file defines 
the xml schema syntax. These files are in the <DataWarehouse_Installation>\conf 
directory.

ETL Mapping Information

Connect-It data warehouse scenarios such as rds_sc.scn describe the metadata for ETL. 

To View the Mapping

1 From the Windows Start menu, click Programs > Connect-It > Scenario Builder. 

2 Open rds_sc.scn. The default path is: 
<DataWarehouse_Installation>\cit\rds_sc.scn 

3 Click Scenario > Open all connectors to ensure that you configured the connectors correctly.

4 Select any Source/Mapping and click the Edit icon to review the ETL mapping information. 

The following diagram shows the mapping for Contact.  
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5 Click the Edit a mapping icon. 

The ServiceCenter data source appears on the left and the data warehouse destination 
table is on the right. The middle section defines the mapping script for each attribute. 
Refer to the Connect-It User Guide for more information.

Semantic Layer—Universe

You can use the Business Objects designer tool to develop the data warehouse universe.

1 From the Windows Start menu, click Programs > BusinessObjects XI Release 2 > 
BusinessObjects Enterprise > Designer. 

2 Log on as the designer user (Administrator).
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3 Click File > Open and navigate to ITPA Service Management. The default path is: 
<BusinessObjects_Installation>\Universes. The following diagram shows the data 
warehouse universe for ServiceCenter.

4 Open the object properties to determine the object definitions for the data warehouse data 
sources. The following diagram shows the Open Time object where OPEN_TIME is the data 
source field in the PROBSUMM_D table.
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Generate the Universe PDF File

You can use the designer tool to produce the universe metadata.

1 From the Windows Start menu, click Programs > BusinessObjects XI Release 2 > 
BusinessObjects Enterprise > Designer. 

2 Log on as the designer user (Administrator).

3 Click File > Open and navigate to ITPA Service Management. The default path is: 
<BusinessObjects_Installation>\Universes.

4 Click File > Save As.

5 From the Save as types drop-down list, select Portable Document Format (*.pdf) and type the 
file name and location.

6 Click Save.

You can use the Business Objects designer tool (Tools > Options > Print/PDF) to set the 
information covered in the universe pdf.

Customize the Schema

The instructions to add tables and fields are available in the DecisionCenter Data Warehouse 
Administration Online Help. The examples that add new tables are direct-mapping type 
tables. The following information contains some exceptions for more advanced customization 
scenarios, such as adding new dimension tables or fact tables for new customized modules. 
Data warehouse schema customization changes the rds_etl.xml file. 

Customize the Data Warehouse Schema

You can customize the data warehouse schema by editing the out-of-box rds_etl.xml file, 
located in the <DataWarehouse_Installation>\conf directory. When customizing any XML 
file, use an XML editor tool such as XML Spy, which validates your changes against the 
schema file. 

Follow these steps to customize the data warehouse schema:

1 Back up the following files:

2 Modify rds_etl.xml. 

This file defines the structure of all fields and tables in the schema. Add or edit objects as 
required. To adhere to best practices, do not delete objects. The HP OpenView Connect-It 
scenario and Business Objects universe deal with unused and obsolete structures. 

3 Validate the XML file.

4 Run the rds_init utility with the appropriate parameters. This creates the schema 
defined in step 2. For more information, see The rds_init Utility on page 33.

rds_etl.xml (ServiceCenter)
rdsac_etl.xml (AssetCenter)
rdbms_keywords.xml 
rds_sc.scn (ServiceCenter)
rds_ac.scn (AssetCenter)
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5 Open the scenario in the Connect-It Scenario Builder.

6 If necessary, configure the connectors.

7 Open all the connectors. If any consistency errors appear, copy the text to a text file and 
save it. 

8 Add and edit documents and mappings as required to match your schema changes. Mark 
any unused objects inactive by clearing the check box next to the mapping and associated 
documents.

9 Change the data warehouse scenario scheduler from the Connect-It Service Console to 
include all the new data file mappings.

10 Open the rds.unv file in Business Objects Designer. Modify the universe to reflect 
changes in your schema. Hide any objects that refer to unused fields and tables. For best 
practices, do not delete objects, as this may break out-of-box reports.

11 Export the universe.

XML Schema Descriptions

The data warehouse XML files have several types of defined tables. Each table has a unique 
purpose and definition. The tables are:

Table 2 Data Warehouse Tables

Table Type Description

Dimension Dimension tables map the tables in your source database 
containing the dimensions and measures at the heart of your 
reports. Good candidates for this type of table are financial 
information (expline, amExpenseLine), Configuration Items 
(device, amAsset), Call and Incident (incidents, 
probsummary), or any tables containing counts and sums 
that require tracking.
Dimension tables are often paired with:
• Fact tables, which contain simplified measure 

information and links to other common Dimension tables, 
and 

• Aggregate tables, which roll up measures based on the 
most common grouping fields for faster processing.

Direct Mapping You can map tables that are useful for reports in a 
supporting capacity as direct mappings. These tables are 
simplest to set up.

Associate Associate, or bridge, tables normalize many-to-many 
relationships, thus preventing many of the traps that can 
lead to bad data.

Hierarchy Drill down functions in reports rely on parent-child 
relationships between records. Hierarchy tables create a 
drill tree for easy layering of data. These are useful for 
organization charts, CI relationships, and locations.
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Each table type has its own section in the XML file. Make sure that you create a table within 
the defined tags for that type. The following sections explain each table type and its syntax in 
detail.

Dimension, Fact, and Aggregate Tables

Dimension tables are robust tables with associated fact (measure) and aggregate tables. Use 
dimension tables to map tables with commonly used measure information. Otherwise, map 
the table as a direct mapping table.

The following code is a simplified version of the out-of-box INCIDENT_D dimension table.

<dimension name=”INCIDENT” rdsVersion=”5.3” attributeAction=”update”>
      <dimensionTableName>
        INCIDENT_D
      </dimensionTableName>
      <dataSourceTableName>
        incidents
      </dataSourceTableName>
      <dimensionTableFields>
        <dimensionTableField name=”INCIDENT_ID” type=”char” size=”100”/>
        <dimensionTableField name=”CONTACT_NAME” type=”char” size=”140”/>
        <dimensionTableField name=”SEVERITY” type=”char” size=”60”/>
        <dimensionTableField name=”HANDLE_TIME” type=”float”/>
        <dimensionTableField name=”OPEN_TIME” type=”date”/>
        <dimensionTableField name=”CLOSE_TIME” type=”date”/>
        <dimensionTableField name=”FIRST_CALL” type=”char” size=”1”/> 
        <dimensionTableField name=”ASSIGNMENT” type=”long”/>
        <dimensionTableField name=”AGEDURATION” type=”float”/>
      </dimensionTableFields>
      <uniqueKeys name=”incident_unique”>
        <uniqueKey fieldName=”INCIDENT_ID” srcFieldName=”''incident.id''” srctype=”char” 
size=”100” 
          seqIndex=”1” defaultValue=”no match”/>
      </uniqueKeys>
      <facts>
        <fact name=”INCIDENT_F”>
          <factKeys>
             <factKey name=”Z_RDSINCIDENT_DID”/>
             <factKey name=”Z_RDSCONTACT_DID” fieldName=”CONTACT_NAME”
               tableName=”CONTACT_D” matchFieldName=”CONTACT_NAME”/>
          </factKeys>
          <factMeasures>

<factMeasure name=”HANDLE_TIME” srcType=”src”/>
<factMeasure name=”INCIDENT_OPEN” srcType=”rdsfactless”/>
<factMeasure name=”INCIDENT_CLOSE” srcType=”rds” 

sqlConditions=”CLOSE_TIME is 
               not null” resetCount=”INCIDENT_OPEN”/>
             <factMeasure name=”FIRST_CALL_COUNT” srcType=”rds” sqlConditions=”FIRST_CALL 
='1'”
               resetCount=””/>
          </factMeasures>
        </fact>
      </facts>
      <scdKeys>
        <scdKey rdsFieldName=”OPENPRGN” srcFieldName=”OPEN” srctype=”char”/>
        <scdKey rdsFieldName=”SEVERITY” srcFieldName=”SEVERITY” srctype=”char”/>
      </scdKeys>
      <aggregateKeys>
        <aggregateKey name=”SEVERITY” type=”char” size=”60”/>
        <aggregateKey name=”OPEN_TIME” type=”TIME”/>
      </aggregateKeys>
    </dimension>
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You need to understand the tags and their attributes before you customize the schema. The 
following sections describe the attributes and tags in this sample code.

The <dimension> Tag

The <dimension> tag frames the whole object. 

It has the following attributes: 

The <dimensionTableName> and <dataSourceTableName> Tags

The <dimensionTableName> displays the name of the table with the _D suffix. Make sure that 
this matches the name attribute from the <dimension> tag. 

The <dataSourceTableName> tag contains the name of the source table as it appears in 
HP OpenView ServiceCenter or HP OpenView AssetCenter. Make sure that the name 
matches exactly because it is case-sensitive.

<dimension name=”INCIDENT” rdsVersion=”5.3” attributeAction=”update”> 

Table 3 <dimension> Attributes

Attribute Description

name The root name (not including suffixes) of the dimension 
table, and any related fact or aggregate tables. The data 
warehouse uses the following conventions as best practices: 
• The name must be unique in the data warehouse.
• The name matches the name of the source table in 

HP OpenView ServiceCenter or HP OpenView 
AssetCenter.

• The name cannot be longer than 15 characters. 
• If the source table name is plural, use the singular 

version of the word. For example, incidents becomes 
incident.

rdsVersion If you set this to”5.0”, the table ignores the 
rdbms_keywords.xml file. Any other setting is simply 
informative. For more information, see The 
rdbms_keywords.xml File on page 34.

attributeAction Optional. This attribute tells the migration program how to 
properly handle the changes. See Table 17 on page 53 and 
Table 18 on page 54 for more information about migration 
attributes.

For proper formatting, make sure that you include </dimension> as the closing tag.

<dimensionTableName>
INCIDENT_D

</dimensionTableName>
<dataSourceTableName>
incidents

</dataSourceTableName>
Advanced Customization 19



The <dimensionTableField> Tag

The <dimensionTableField> contains the main body of the table, defining each field.

It has the following attributes: 

<dimensionTableFields>
   <dimensionTableField name=”INCIDENT_ID” type=”char” size=”100”/>
   <dimensionTableField name=”CONTACT_NAME” type=”char” size=”140”/>
   <dimensionTableField name=”SEVERITY” type=”char” size=”60”/>
   <dimensionTableField name=”HANDLE_TIME” type=”float”/>
   <dimensionTableField name=”OPEN_TIME” type=”date”/>
   <dimensionTableField name=”CLOSE_TIME” type=”date”/>
   <dimensionTableField name=”FIRST_CALL” type=”char” size=”1”/>
   <dimensionTableField name=”ASSIGNMENT” type=”long”/>
   <dimensionTableField name=”AGEDURATION” type=”float”/>
 </dimensionTableFields>

Table 4 <dimensionTableField> Attributes

Attribute Description

name The name that you use for the field. The data warehouse 
uses the following conventions as best practices: 
• The name must be unique in the table.
• The name matches the name of the source table in 

HP OpenView ServiceCenter or HP OpenView 
AssetCenter.

• The underscore character (_) replaces the period (.) in the 
field name. For example, contact.name becomes 
CONTACT_NAME.
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The <uniqueKeys> Tag

The <uniqueKeys> tag defines the unique key for the table. It has only the name property. For 
best practices, use the name of the table, followed by ”_unique”. This name must be unique 
in the database.

<uniqueKeys name=”incident_unique”>
 <uniqueKey fieldName=”INCIDENT_ID” srcFieldName=”''incident.id''” 
srctype=”char” size=”100” seqIndex=”1” defaultValue=”no match”/>
</uniqueKeys>

type This is the data type to use. The data warehouse uses four 
data types: char, float, date, and long. The following chart 
shows how they map from common HP OpenView 
ServiceCenter data 
types:

size You use this attribute only when type=”char”. This is the 
length of the field according to your data.

attributeAction Optional. This attribute tells the migration program how to 
properly handle the changes. See Table 17 on page 53 and 
Table 18 on page 54 for more information about migration 
attributes.

Table 4 <dimensionTableField> Attributes

Attribute Description

ServiceCenter Data Type Data Warehouse Data Type

character char 

number float 

date date 

date (relative) float 

logical char size=1 

array (simple) long 

array of structure map to new table (see 
Handling Arrays on page 31.
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Inside the <uniqueKeys> set of tags is one or more <uniqueKey> tag with the following 
attributes:

Table 5 <uniqueKey> Attributes

Attribute Description

fieldName This is the name of the field from the <dimensionTableField> tag. 
The data warehouse uses the following conventions as best practices:
• The <dimensionTableFields> section must have an equivalent 

field defined.
• The field must be type=”char”. If the key field is a different data 

type, create a second field with the extension _KEY to contain the 
text version of the data. For example, the OUTAGE_D table has the 
the following code:

<dimensionTableField name=”OUTAGE_ID” type=”float”/> 
<dimensionTableField name=”OUTAGE_ID_KEY” type=”char” 
size=”60”/> 

The original numeric data is mapped to OUTAGE_ID, and a text 
equivalent is mapped to OUTAGE_ID_KEY. The <uniqueKey> tag uses 
the latter.

scrFieldName This is the name of the field as it appears in HP OpenView 
ServiceCenter or HP OpenView AssetCenter. This is case-sensitive. 
The data warehouse uses the following conventions as best practices:
•  If the field is contained in a structure, include the structure 

name, separated by a period. For example, In the PROBLEM table, 
srcFieldName=”header.number”.

• If the field name contains a period, surround the name with two 
single quotation marks. For example, in the INCIDENT table, the 
attribute reads: 

     srcFieldName=”''incident.id''” 

The TZFILE_SWITCH table has the following key: 

srcFieldName=”switchover.''local.switchover.time''” 

scrType This is the data type of the original field (char, date, float, or 
long). If you converted the field to char from another type, list the 
data warehouse data type closest to the original type.
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The Fact Table Definition

The fact table definition section is optional. If you do not need a fact table, replace the entire 
section with the <facts/> tag.

A fact table has two sections: <factKeys> and <factMeasures>.

The <factKeys> section defines the links between dimension tables. The first key is the 
unique fact key for this table. It contains only the name attribute. For best practices, use the 
naming convention Z_RDS<table name>_DID.

size You use this attribute only when type=”char”. This is the size of the 
field from the <dimensionTableField> tag.

seqIndex If you use more than one field in the key, the order to process the 
fields starts from 1. The data warehouse uses the following 
conventions as best practices:
• To determine which fields to use and in what order, open the 

Database Dictionary tool from HP Openview ServiceCenter. View 
the structure of the source table and look at the Indexes section 
on the right. Find the FIRST key with a unique designation. 
Mimic the order of these fields. This ensures that deletion sync 
works properly.

• You can use a maximum of 5 fields in a composite key for a 
dimension table. If the table requires more than that, consider 
making a direct mapping table instead.

defaultValue This must always be ”no match”.

Table 5 <uniqueKey> Attributes

Attribute Description

<facts>
 <fact name=”INCIDENT_F”>
   <factKeys>
     <factKey name=”Z_RDSINCIDENT_DID”/>
     <factKey name=”Z_RDSCONTACT_DID” fieldName=”CONTACT_NAME”
      tableName=”CONTACT_D” matchFieldName=”CONTACT_NAME”/>
     <factKey name=”OPEN_TIMEID” fieldName=OPEN_TIME” 
tableName=RDS_TIMEDIM_D” matchFieldName=”FULLDATE”/>
    </factKeys>
    <factMeasures>
       <factMeasure name=”HANDLE_TIME” srcType=”src”/>
       <factMeasure name=”FIRST_CALL_COUNT” srcType=”rds”/>       
sqlConditions=”FIRST_CALL ='1'”
               resetCount=””/>
       <factMeasure name=”INCIDENT_OPEN” srcType=”rdsfactless”/>
       <factMeasure name=”INCIDENT_CLOSE” srcType=”rds” 
sqlConditions=”CLOSE_TIME is not null” resetCount=”INCIDENT_OPEN”/>
    <factMeasures>
 </fact>
</facts>
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All other keys are foreign keys to other dimension tables. They use the following attributes:

Use the following conventions as best practices for fact keys:

• At least one fact key must be a DATE field linked to RDS_TIMEDIM_D.FULLDATE.

• The maximum number of fact keys in a single table is 10.

The <factMeasures> section contains the numeric fields that you want to track and 
aggregate. Most measures are mappings for fields from the <dimensionTableFields> 
section. In that case, use only the attribute srcType=”src”. 

A special pair of types, rdsfactless and rds, create a flag field to use for counts and filters.

To create a simple flag, use the properties srcType=”rds” and resetCount=””. For each 
record, this flags the column with a 1 if the criteria in the sqlConditions is met, and with a 0 
if not met. FIRST_CALL_COUNT is an example of this method.

A more advanced option is to create a binary pair of flags where one is always true and one 
false. To do this, create one measure with the attribute srcType=”rdsfactless” (see 
INCIDENT_OPEN in the previous code). Then create a second with the properties 
srcType=”rds” sqlConditions=”<your criteria>” resetCount=”<factless measure 
name>” (see INCIDENT_CLOSE in the previous code). For each record, the ETL process 
determines if the condition in the sqlConditions attribute is met. If it is, INCIDENT_OPEN 
gets a value of 0, and INCIDENT_CLOSE gets a value of 1. If not, the opposite happens. 

The <scdKeys> Tag

The Slowly Changing Dimension (SCD) fields section is optional. If you do not need a fact 
table, replace the entire section with the <scdKeys/> tag. 

The SCD key tracks the history of a field. When you update a record in a way that alters the 
SCD key, a copy of the record is made. The original record is marked obsolete, but remains in 
the database.

The maximum number of SCD fields is 10.

Table 6 Foreign Key Attributes

Attribute Description

name The name of the fact key for the foreign table.

fieldName The name of the dimension table field (from this table) used for the 
join.

tableName The name of the foreign dimension table.

matchFieldName The name of the dimension table field (from the foreign table) used 
for the join.

You can have only one rdsfactless measure per table.

<scdKeys>
<scdKey rdsFieldName=”OPENPRGN” srcFieldName=”OPEN” srctype=”char”/>
<scdKey rdsFieldName=”SEVERITY” srcFieldName=”SEVERITY” srctype=”char”/>

</scdKeys>
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SCD fields have the following attributes:

The <aggregateKeys> Tag

The aggregate table definition section is optional. If you do not need an aggregate table, 
replace the entire section with the <aggregateKeys/> tag. 

All the measures from your fact table are summed up over time for each unique value in each 
aggregate key. 

Table 7 SCD Field Attributes

Attribute Description

rdsFieldName This is the name of the field from the <dimensionTableFields> 
section. The data warehouse uses the following conventions as best 
practices:
• There must be an equivalent field defined in the 

<dimensionTableFields> section.
• The field must be type=”char”. If the key field is a different data 

type, create a second field with the extension _KEY to contain the 
text version of the data.

srcFieldName This is the name of the field as it appears in HP OpenView 
ServiceCenter or HP OpenView AssetCenter. The data warehouse 
uses the following conventions as best practices:
•  If the field is contained in a structure, include the structure 

name, separated by a period. For example, In the PROBLEM table, 
srcFieldName=”header.number”.

• If the field name contains a period, surround the name with two 
single quotation marks. For example, in the INCIDENT table, the 
attribute reads: 

     srcFieldName=” ''incident.id''” 

The TZFILE_SWITCH table has the following key: 

srcFieldName=”switchover.''local.switchover.time''” 

srctype This is the data type of the original field (char, date, float, or 
long). If you converted the field to char from another type, list the 
data warehouse data type closest to the original type.

<aggregateKeys>
   <aggregateKey name=”SEVERITY” type=”char” size=”60”/>
   <aggregateKey name=”OPEN_TIME” type=”TIME”/>
</aggregateKeys>
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Aggregate keys have the following attributes: 

Aggregate keys use the following conventions:

• Aggregate keys (except the last key) must use the attribute type=”char”.

• The last aggregate key must be a date field with the attribute type=”TIME”. Only one 
date type is allowed.

• The maximum number of aggregate keys is 15. 

Associate Table

The associate tables, also called the bridge tables, are used for many-to-many relationships 
between dimension tables.

<associates>
<associate name=”INCIDENT_MODEL_ASS” tableName=”INCIDENT”     

fieldName=”MODEL” tableName2=”MODEL”fieldName2=”MODEL”/>
<associate name=”CM3R_DEVICE_ASS” tableName=”CM3R” 

fieldName=”logical_name” longFieldName=”assets” tableName2=”DEVICE” 
fieldName2=”LOGICAL_NAME”/>
</associates>

Associate tables have the following parameters:

Table 8 <aggregateKeys> Attributes

Attribute Description

name This is the name of the field from the <dimensionTableFields> 
section.

type This is the data type of the field (char, date, float, or long).

size You use this attribute only when type=”char”. This is the size of the 
field from the <dimensionTableField> tag.

For proper formatting, include </dimension> as the closing tag.

Table 9 Associate Table Parameters

Parameter Description

name The unique name for this table. For best practices, use the first 8 
letters of the tables to be joined, separated by an underscore, 
followed by the extension _ASS.

tableName The name of the first dimension table (with no suffix).

fieldName The name of the field to bridge in the first dimension table.

 longFieldName Optional. If the join in question involves a list of values (such as an 
array of character field in HP OpenView ServiceCenter), map that 
array to a long data type in the dimension table, then refer to that 
long field here. The data in the array of character field merges with 
the field in fieldName to create a list of associate records.
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For example, the cm3r table (Change Management) contains a primary configuration item for 
the change (cm3r.logical.name) and an array of additional configuration items 
(cm3r.assets).

If your original record contains:

the associate table will contain these records:

• tableName2 The name of the second dimension table (with no suffix).

• fieldName2 The name of the field to bridge in the second dimension table.

Hierarchy Table

Hierarchy tables based on dimension tables are created for Online Analytical Processing 
(OLAP) summary reports. You can use the hierarchy levels to drill to lower, or detail, levels. 
The predefined hierarchy examples in HP OpenView ServiceCenter include location, 
department, contacts, and device.

<hierarchies>
     <hierarchy tablename=”location” type=”fullpath” level=”5” 
uniquefieldName=”location” fullpathfieldname=”location_full_name”/>
     <hierarchy tablename=”contact” type=”parent” level=”5” 
uniquefieldName=”contact_name” parenttableName=”contact” 
parentfieldname=”manager”/>
</hierarchies>

The two types of hierarchies are: fullpath and parent.

The fullpath style of hierarchy assumes the presence of a field in the table containing the fully 
qualified path of the object in the hierarchy. This is the traditional method that HP OpenView 
AssetCenter tables use. The location in the previous example illustrates this method.

The parent style of hierarchy assumes the table contains a foreign key that maps to the 
unique key of the parent record. The contact table in the previous example uses this method. 
Each contact record contains a manager field holding the ID of another contact record.

Change Number: C1

Primary CI: Server101

Affected CIs: PC001, PC002, PC003

Change Number Logical Name

C1 Server101

C1 PC001

C1 PC002

C1 PC003
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Hierarchies have the following attributes:

Direct Mapping Table

Direct mapping tables are simple structures with no associated fact, hierarchy, or aggregate 
tables. Use direct mappings for supporting and detail tables.

The following code is a simplified version of the out-of-box Activity direct mapping table.

    <directMapping name=”activity” rdsVersion=”5.0” dataSourceTableName=”activity” 
      parentDimensionTableName=”PROBSUMM” attributeAction=”update”>
      <directMappingFields>
        <directMappingField name=”THENUMBER” type=”char” size=”50”/>
        <directMappingField name=”NUMBERPRGN” type=”char” size=”60”/>
        <directMappingField name=”TYPE” type=”char” size=”60”/>
        <directMappingField name=”NEGDATESTAMP” type=”float”/>
      </directMappingFields>
      <directMappingIndexes>
        <directMappingIndex name=”UNIQACTIVITY_IDX”>
          <DirectMappingIndexKey fieldName=”numberprgn” srcFieldName=”number” 
srctype=”char” 
            size=”60” seqIndex=”1”/>
          <DirectMappingIndexKey fieldName=”negdatestamp” srcFieldName=”negdatestamp” 
            srctype=”date” seqIndex=”2”/>
          <DirectMappingIndexKey fieldName=”thenumber” srcFieldName=”thenumber” 
srctype=”char” 
            size=”60” seqIndex=”3”/>
        </directMappingIndex> 
        <directMappingIndex name=”DELACTIVITY_IDX”>
          <DirectMappingIndexKey fieldName=”NUMBERPRGN” srcFieldName=”NUMBERPRGN” 
            srctype=”char” size=”60”/>
        </directMappingIndex>
      </directMappingIndexes>
    </directMapping>

You need to understand the tags and their attributes before you customize the schema. The 
following sections describe the attributes and tags in this sample code.

Table 10 Hierarchy Table Attributes

Attribute Description

tablename The name of the dimension table to extract the hierarchy from.

type Enter fullpath or parent as appropriate.

level The number of tiers to process. By default this is 5. The maximum is 
10.

uniquefieldName For a fullpath type, this contains the field used to build the fullpath. 
For a parent type, this contains the unique ID of the parent table. 

fullpathfieldname For the fullpath type only, this is the field containing the fully 
qualified path.

parenttablename For the parent type only, this is the name of the table containing the 
parent record. This can be the same as the tablename attribute if the 
table refers to itself.

parentfieldname For the parent type only, this is the field containing the foreign key.
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The <directMapping> Tag 

 The <directMapping> tag frames the whole object. 

It has the following attributes: 

The <directMappingField> Tag

The <directMappingField> contains the main body of the table, defining each field.

 <directMapping name=”activity” rdsVersion=”5.0” dataSourceTableName=”activity” 
      parentDimensionTableName=”PROBSUMM” attributeAction=”update”>

Table 11 <directMapping> Attributes

Attribute Description

name The root name for the table. This must match the name of 
the source table

rdsVersion If you set this to”5.0”, the table ignores the 
rdbms_keywords.xml file. Any other setting is simply 
informative. For more information, see The 
rdbms_keywords.xml File on page 34.

dataSourceTableName The name of the table as it appears in HP OpenView 
ServiceCenter or HP OpenView AssetCenter.

parentDimensionTableName Optional. If you use cascading deletions, this is the name of 
the dimension table where deletions trigger a deletion of 
related records in your direct mapping table. You must 
specify a delete index.

attributeAction Optional. This attribute tells the migration program how to 
properly handle the changes. See Table 17 on page 53 and 
Table 18 on page 54 for more information about migration 
attributes.

For proper formatting, make sure that you include </directMapping> as the closing tag.

<directMappingFields>
<directMappingField name=”THENUMBER” type=”char” size=”50”/>
<directMappingField name=”NUMBERPRGN” type=”char” size=”60”/>
<directMappingField name=”TYPE” type=”char” size=”60”/>
<directMappingField name=”NEGDATESTAMP” type=”float”/>

</directMappingFields>
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It has the following attributes: 

The <directMappingIndex> Tag

The two index types are unique and delete. The unique key is required. You only use the delete 
key if you set up a cascading delete, described in the parentDimensiontableName attribute 
on page 29. 

The <directMappingIndex> tag has one attribute: name. The name attribute typically follows 
the pattern UNIQ<TABLENAME>_IDX for unique keys and DEL<TABLENAME>_IDX for delete keys.

Table 12 <directMappingField> Attributes

Attribute Description

name The name that you use for the field. The data warehouse 
uses the following conventions as best practices: 
• The name must be unique in the table.
• The name matches the name of the source table in 

HP OpenView ServiceCenter or HP OpenView 
AssetCenter.

• The underscore character (_) replaces the period (.) in the 
field name. For example, contact.name becomes 
CONTACT_NAME.

type This is the data type to use. The data warehouse uses four 
data types: char, float, date, and long. The following chart 
shows how they map from common HP OpenView 
ServiceCenter data 
types:

size You use this attribute only when type=”char”. This is the 
length of the field according to your data.

attributeAction Optional. This attribute tells the migration program how to 
properly handle the changes. See Table 17 on page 53 and 
Table 18 on page 54 for more information about migration 
attributes.

ServiceCenter Data Type Data Warehouse Data Type

character char 

number float 

date date 

date (relative) float 

logical char size=1 

array (simple) long 

array of structure map to new table (see 
Handling Arrays on page 31.
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Inside the <DirectMappingIndexKey> set of tags is one or more <DirectMappingIndexKey> 
tag with the following attributes:  

Handling Arrays 

HP OpenView ServiceCenter tables contain array and structure data types that typical 
RDBMS systems do not support. As such, they require special handling. 

The two methods for mapping arrays are:

• Simple Array of Char type fields (a list of strings) where you can create a single field in 
the main table of type long. This concatenates all lines into a single body of text. This is 
useful for comments and lists of items that do not need to be individually processed.

Table 13 <directMappingIndexKey> Attributes

Attribute Description

fieldName This is the name of the field from the <directMapingField> tag. 

scrFieldName This is the name of the field as it appears in HP OpenView 
ServiceCenter or HP OpenView AssetCenter. This is case-sensitive. 
The data warehouse uses the following conventions as best practices:
•  If the field is contained in a structure, include the structure 

name, separated by a period. For example, In the PROBLEM table, 
srcFieldName=”header.number”.

• If the field name contains a period, surround the name with two 
single quotation marks. For example, in the INCIDENT table, the 
attribute reads: 

     srcFieldName=”''incident.id''” 

The TZFILE_SWITCH table has the following key: 

srcFieldName=”switchover.''local.switchover.time''”

scrType This is the data type of the original field (char, date, float, or 
long). Unlike dimension tables, direct mapping keys can be any data 
type.

size You use this attribute only when type=”char”. This is the size of the 
field from the <dimensionTableField> tag.

seqIndex If you use more than one field in the key, the order to process the 
fields starts from 1. The data warehouse uses the following 
conventions as best practices:
• To determine which fields to use and in what order, open the 

Database Dictionary tool on HP OpenView ServiceCenter. View 
the structure of the source table and look at the Indexes section 
on the right. Find the FIRST key with a unique designation. 
Mimic the order of these fields. This ensures that deletion sync 
works properly.

• A maximum of 10 fields is allowed in a composite key for a direct 
mapping table.

For proper formatting, include </directMapping> as the closing tag.
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• Complex items, such as Array of Structure types, where you must map the data to a 
new data warehouse table that is associated to the original.

The clock table in the following example contains an array of structure called events.

The main table, created as a dimension table because it contains measure information, is 
CLOCK_D. The array is mapped to direct mapping table CLOCK_EVENTS because it contains only 
supporting data. 

    <directMapping name=”CLOCK_EVENTS” rdsVersion=”5.3” attributeAction=”add” 
      parentDimensionTableName=”CLOCK”>

As a best practice, the name contains the name of the parent and the name of the array, 
separated by an underscore. The parentDimensionTableName attribute is set to CLOCK, 
indicating that this table is dependent on another table.

<directMappingFields>               
<directMappingField name=”TYPE” type=”char” size=”60”/>
<directMappingField name=”KEY_CHAR” type=”char” size=”60”/>
<directMappingField name=”KEY_NUMERIC” type=”float”/>   
<directMappingField name=”NAME” type=”char” size=”60”/>
<directMappingField name=”START” type=”date”/>
<directMappingField name=”STOP” type=”date”/>

</directMappingFields>

The events array contains only two fields: START and STOP. Because it is necessary to associate 
each record with the parent record from CLOCK_D, you must add a copy of all fields that 
comprise the unique key for the parent table. In this case, CLOCK_D has a composite key made 
of four fields: TYPE, KEY_CHAR, KEY_NUMERIC, and NAME.

<directMappingIndexes>
<directMappingIndex name=”UNIQCLOCKEV_IDX”>
<DirectMappingIndexKey fieldName=”TYPE” srcFieldName=”type” 

srctype=”char” size=”60” 
      seqIndex=”1”/>
    <DirectMappingIndexKey fieldName=”KEY_CHAR” 
srcFieldName=”''key.char''” srctype=”char” 
      size=”60” seqIndex=”2”/>
    <DirectMappingIndexKey fieldName=”KEY_NUMERIC” 
srcFieldName=”''key.numeric''” 
      srctype=”float” seqIndex=”3”/>
    <DirectMappingIndexKey fieldName=”NAME” srcFieldName=”name” 
srctype=”char” size=”60” 
      seqIndex=”4”/>
    <DirectMappingIndexKey fieldName=”START” srcFieldName=”events.start” 
srctype=”date” 
      seqIndex=”5”/>
    <DirectMappingIndexKey fieldName=”STOP” srcFieldName=”events.stop” 
srctype=”date” 
      seqIndex=”6”/>
</directMappingIndex> 
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Arrays do not contain their own unique key, so it is necessary to build a unique set of fields. 
You start by adding all the unique keys from the parent table. Then you add as many fields as 
necessary from the array to enforce uniqueness. In this case, you cannot guarantee a unique 
record unless you add both START and STOP. The result is a six-part composite key.

Because the data warehouse only tracks deletions on source tables, it is necessary to associate 
this table with the parent for cascading deletes. A second index is made containing all fields 
that comprise the unique key for the parent.

Using the Connect-It scenario, you must create a new mapping for this destination table. You 
can reuse the same produced document from HP OpenView ServiceCenter that mapped the 
parent, but you must make a separate mapping.

The rds_init Utility

After you edit and validate your XML file, you must run rds_init to build or edit the 
database schema. You can use the rds_init utility to start the RDSInitRun command, 
which causes the changes you make in the default rds_etl.xml file to take effect.

If you are running a clean installation, run the 
<DataWarehouse_Installation>\common\bin\rds_init.bat file. 

If you are migrating from an existing data warehouse, make sure that you add all the 
appropriate attributeAction tags to any objects you altered or added (see Chapter 2, 
Advanced Migration), then run the 
<DataWarehouse_Installation>\common\bin\rds_init_migrate.bat file.

<directMappingIndex name=”DELCLOCKEV_IDX”>
<DirectMappingIndexKey fieldName=”TYPE” srcFieldName=”type” 

srctype=”char” size=”60” 
    seqIndex=”1”/>
<DirectMappingIndexKey fieldName=”KEY_CHAR” srcFieldName=”''key.char''” 

srctype=”char” 
size=”60” seqIndex=”2”/>

<DirectMappingIndexKey fieldName=”KEY_NUMERIC” 
srcFieldName=”''key.numeric''” 

srctype=”float” seqIndex=”3”/>
<DirectMappingIndexKey fieldName=”NAME” srcFieldName=”name” 

srctype=”char” size=”60” 
seqIndex=”4”/>
</directMappingIndex>
</directMappingIndexes>

</directMapping> 

Do not run this file if you are updating an existing data warehouse because it will 
delete and recreate all the tables.
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The rds_init program generates two output files in the 
<DataWarehouse_Installation>\Logs directory.

If the err file size is not 0, check the error messages, correct the problem, and rerun the 
program.

The rdbms_keywords.xml File

The data warehouse has a predefined rdbms_keywords.xml file to accommodate every 
RDBMS set of reserved words. When the field names specified in the rds_etl.xml file match 
one of the keywords in rdbms_keywords, the data warehouse field name uses the field name 
with the suffix of PRGN. For example, the type field name becomes the TYPEPRGN field name.

For backward compatibility, reserved words domain and value do not change for 
PROBSUMM_D and DEVICE_D. Reserved words type, month, year, and action do not change 
for direct mapping tables with the <rdsVersion> attribute set to 5.0. 

Customize the Connect-It Scenario

The data warehouse uses HP OpenView Connect-It scenarios to synchronize data. You can 
customize the AssetCenter rds_ac.scn and ServiceCenter rds_sc.scn mappings with 
Connect-It Scenario Builder.

Changes to the scenario require several tasks that involve modifying and verifying the 
schema, running the scenario in a test or production environment, and reviewing global 
functions. Complete the tasks in the recommended order.

Task 1: Modify and verify the data warehouse Connect-It scenarios.

• Open the Scenario to Verify the Schema on page 35.

• Reconfigure the Connectors That Fail to Connect on page 36.

• Verify the Schema on page 36.

• Modify Data Sources Document Types on page 36.

• Modify Produced Data Sources for Data Warehouse Tables on page 37.

• Modify the Mapping Scripts on page 37.

Task 2:  Run the modified scenario in a test and production environment.

• Test the Scenario on page 37.

Task 3: Review the data warehouse global functions for the scenario.

• Map Field Array on page 38.

Table 14 Output Files

File Name Description

rds_etl_init.log Stores all the executed SQL statements.

rds_etl_init.err Tracks all the error messages.
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• Map Substructure Array on page 38.

• Map Unique Key Fields on page 39.

• Map Function for Date Field—retdate on page 39.

• Map Function for Long String Data Field—RetLongText on page 40.

• Map Function for Dimension Table on page 40.

ETL Process Modules

The data warehouse ETL process has the following components:

• Data warehouse Connect-It scenario (rds_sc.scn or rds_ac.scn)

• Data warehouse synchronization module (rds_sync.bat) that populates data warehouse 
fact tables, dimension SCD records, associated tables and system tables

• Data warehouse aggregation (rds_agg.bat) population module

• Data warehouse hierarchy (rds_hier.bat) population module

The rds_all Connect-It scheduler groups all these modules. The data warehouse ETL 
process runs daily, based as the incremental updates. 

These programs generate the output files in the <DataWarehouse_Installation>\logs 
directory and save error messages to err files. Check the err files to verify that the size is not 
greater than 0 bytes. If so, check the errors and correct them accordingly.

Modify and Verify Connect-It Scenarios

Follow these steps to verify and modify data warehouse Connect-It scenarios.

1 Click Start > Programs > Connect-It > Scenario Builder.

2 Click File > Open and navigate to rds_sc.scn.

3 Select the a connector.

4 Select the Document Types tab.

5 Modify the Data sources document type.

6 Modify the produced document types:

• Dimension tables mapping scripts.

• Direct mapping tables mapping scripts.

7 Run the modified Connect-It scenario in your test or production environment.

Open the Scenario to Verify the Schema

1 Open the Windows command prompt.

2 Change to the <DataWarehouse_Installation>\common\bin directory. 

3 Run the test_rdssc.bat command.

4 Check the test_rdssc.log log file in <DataWarehouse_Installation>\logs.

The file contains the synchronization activity records. 

5 Search for the string -53. 
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• If you do not find -53, the verification is successful.

• If you find -53 or -XX, errors, confirm that the connectors’ configuration information 
is correct by verifying config_rdssc.txt in the 
<DataWarehouse_Installation>\cit directory. The rds_init program must be 
error-free before you can run the Connect-It scenario.

Reconfigure the Connectors That Fail to Connect

1 With a text editor, modify the content of config_rdssc.txt in the 
<DataWarehouse_Installation>\cit directory.

2 Open the Windows command prompt.

3 Change to the <DataWarehouse_Installation>\common\bin directory.

4 Run the following commands and check the corresponding log files in the 
<DataWarehouse_Installation>\logs directory. Make sure the test log files have 
successful in the last line.

• upd_rdssc.cmd 

• test_rdssc.cmd 

Verify the Schema

1 Back up rds_sc.scn located in <DataWarehouse_Installation>\cit.

2 Click Start > Programs > Connect-It > Scenario Builder.

3 Click File > Open and navigate to rds_sc.scn.

4 Click Scenario > Open all connectors to ensure that you configured the connectors correctly.

5 Click the Mapping connector.

6 Select the Mappings tab.

7 Select any predefined mapping; for example, contactSrc CONTACT_DDst to 
CONTACT_D (CONTACT_DDst). 

8 Click the Edit a mapping icon.

The verification is successful if no schema error window appears. If not successful, copy the 
schema errors to Notepad and save as a text file for later use.

Modify Data Sources Document Types

If you have schema verification errors, or if you need to map new ServiceCenter files or fields 
to data warehouse, modify the data sources.

1 Click Start > Programs > Connect-It > Scenario Builder.

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Select the ServiceCenter connector.

5 Select the Document Types tab.

6 Modify Produced document types for the updates or error ServiceCenter files by removing, 
updating, or adding the tables.
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Modify Produced Data Sources for Data Warehouse Tables

1 Click Start > Programs > Connect-It > Scenario Builder.

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Select the RDS connector.

5 Select the Document Types tab.

6 Modify Produced document types for the updates or error data warehouse tables by 
removing, updating, or adding tables.

Modify the Mapping Scripts

1 Click Start > Programs > Connect-It > Scenario Builder.

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Select the Mapping connector.

5 Select the Mappings tab.

6 Click the Edit the mapping icon.

Test the Scenario

Before you run the new scenario through the Connect-It service console, test the scenario from 
Connect-It builder.

1 Click Start > Programs > Connect-It > Scenario Builder.

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Check or clear the tables that you want to include in the synchronization.

a From the ServiceCenter connector, click Document Types and check or clear the tables. 
from Produced document types. 

b From the Mapping connector, click Mappings and check or clear the tables from Source/
Mapping.

c From the Mapping connector, click Document Types and check or clear the tables from 
Produced document types. 

5 Set the condition.

a From the ServiceCenter connector, click Produced document type, then click Edit 
produced document type. 

b Add the condition to the WHERE clause. For example:

sysmodtime > '11/15/03'

6 Click Tools > Produce now to test the modified scenario.

7 Validate the data and log file to ensure that you have no -xx errors.

8 Click Scenario > Scheduling to modify the scheduling if you have new mapping data 
sources.
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9 Start the rds_sc service through the Connect-It Service Console.

Review Global Functions

You can use predefined data warehouse global functions for data warehouse scenarios 
mapping scripts. 

To Review Global Functions

1 Click Start > Programs > Connect-It > Scenario Builder.

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Global functions.

4 Select the rds.bas script.

Map Field Array

You can map a simple field array and a simple field array in a substructure.

Simple Field Array—RDSCollection2LongText

You can map alternate.contacts from the ServiceCenter contacts file to the CONTACT_D 
alternate_contacts long text field with the data warehouse RDSCollection2LongText 
method.

RDSCollection2LongText(”'alternate.contacts'”)

Simple Field Array in Substructure—RDSAnyCollection2LongText

The approval.structure in cm3r mapping defines the simple field array 
approvals.req.seq. You can map the CM3R_D approved_req_seq long string field with the 
data warehouse RDSAnyCollection2LongText method.

RDSAnyCollection2LongText(”'approval.structure'.'approvals.req.seq'”,
”'approvals.req.seq'”)

Map Substructure Array

By using the separate table created for the structure array, you can edit the rds50db.cfg to 
associate the main table with the separate dependent table. Follow the steps in this example 
to complete the Connect-It scenario changes. For SLA_D, you create the SLAARAVA_D separate 
table for the sla availability structure array. 

To Map the Array in Connect-It

1 With a text editor, open rds50db.cfg. The default path is:

<Connect-It_Installation>\RDS_SC\cit

2 Create the relationships between SLA_D and SLAARAVA_D.

{ STRUCT SLA_D_OUT
    MODEOUT = 0
    TABLE = SLA_D sl

To ensure that the data warehouse Connect-It global functions work, you must name the data 
warehouse connector RDS.
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    { ATTRIBUTE AllFields
      FIELD = sl.self
   }
    { ARRAY SLA_AVAILABILITY
      TABLE = SLAARAva_D
      LINK = @{…agreement_id_key} = agreement_id_key
      { ATTRIBUTE AllFields
        FIELD = self
     }

}
…

3 Save and close the file.

4 Click Start > Programs > Connect-It > Scenario Builder.

5 Click File > Open and navigate to rds_sc.scn.

6 Click Scenario > Open all connectors.

7 Select the Mappings connector.

8 In Source/Mapping, select SLA and click the Edit a mapping icon.

9 Create the mappings from the availability array to SLA_AVAILABILITY elements.

10 Select the SLA_AVAILABILITY collection, type availability for the Source for the 
collection mapping. 

11 Check Active collection reconciliation.

Map Unique Key Fields

If you modify the unique keys or add new tables, you must update the data warehouse 
scenario.

1 Click Start > Programs > Connect-It > Scenario Builder.

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Select the Mappings connector.

5 Select the appropriate Source/Mapping mapping, then click the Edit a mapping icon.

6 Select the unique key element.

7 Start the key.

8 Use the CSTR mapping function.

CONTACT_NAME in CONTACT_D mapping is one of the unique key mappings:
CSTR(['contact.name'])

Map Function for Date Field—retdate

You can use the retdate data warehouse function to map the date field. For example, in the 
CONTACT_D mapping, the mapping for VALID_FROM is:

retdate(['valid.from'])
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Map Function for Long String Data Field—RetLongText

You can use the RetLongText data warehouse function to map the long field. For example, in 
CONTACT_D mapping, the mapping for the comment field is:

RetLongText([comments])

Map Function for Dimension Table

The following functions populate dimension data. The input variable names are based on the 
dimension name. Check any predefined dimension mapping for detail examples, such as 
CONTACT_D.

The following example is from the CONTACT_D OpenSession method.

To Create the OpenSession Method at the Dimension Table Level

1 Click Start > Programs > Connect-It > Scenario Builder.

2 Click File > Open and navigate to rds_sc.scn.

3 Click Scenario > Open all connectors.

4 Select the Mappings connector.

5 In the OpenSession method, use the dimension name without _D for the global variable 
names and the input parameter.

6 At the root level, AMCONTRACT_D in this example, define the mapping scripts as: 

g_tableName = ”AMCONTRACT”
Dim etlStatus as string
etlStatus=RetETLStatus()

You need to change only the g_tableName based on the dimension name without _D.
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Functions for Dimension Attributes

The following functions use the CONTACT_D table. Replace contact with the proper 
dimension table name.

Complete Dimension Table Mappings

You can create mappings for the dimension element from the appropriate ServiceCenter 
source fields. Make sure that you define the ServiceCenter sysmodtime file for more efficient 
data synchronization.

Start the dimension primary key by using the unique key fields and data warehouse system 
unified sequence key field Z_RDSXXX_DID. The dimension name is XXX_D.

Customize the Universe

You can use the Business Objects Designer tool to customize the universe (unv) file. The 
universe is the metadata layer that contains data attributes and data structures. The 
universe files are in your Business Objects directory.

Default Joins for ServiceCenter

You can group all data warehouse joins by different ServiceCenter modules for the 
ITPA Service Management file.

Service Management Module

COMPANY_D.Z_RDSCOMPANY_DID=INCIDENT_F.Z_RDSCOMPANY_DID
CONTACT_D.Z_RDSCONTACT_DID=INCIDENT_F.Z_RDSCONTACT_DID
INCIDENT_D.Z_RDSINCIDENT_DID=INCIDENT_F.Z_RDSINCIDENT_DID
INCIDENT_F.Z_RDSLOCATION_DID=LOCATION_D.Z_RDSLOCATION_DID
INCIDENT_F.Z_RDSVENDOR_DID=VENDOR_D.Z_RDSVENDOR_DID
INCIDENT_MODEL_ASS.Z_RDSINCIDENT_DID=INCIDENT_D.Z_RDSINCIDENT_DID
INCIDENT_MODEL_ASS.Z_RDSMODEL_DID=MODEL_D.Z_RDSMODEL_DID
DEPT_D.COMPANY=COMPANY_D.COMPANY

Table 15 Dimension data warehouse attributes

Attribute Function

Z_ETLSTATUS field g_ETLProcess_Status

Z_RDSACTIVESTATUSIND field ”Y”

Z_RDSCONTACT_DID system 
unified sequence key

newID=RetRDSDID(g_lMaxCounter_contact)
if newID > g_lMaxCounter_contact then
g_lMaxCounter_contact = newID 

end if
retval = newID

Z_RDSCREATEDDATE field retval = RetRDSCreateDateAll()

Z_RDSLASTMODDATE field retval = RetRDSLastModDateAll()

For Z_RDSTRANSLASTIND field ”Y”
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OPERATOR_D.NAME*=INCIDENT_D.OWNER_NAME
SCRELATION.DEPEND=PROBSUMM_D.NUMBERPRGN
INCIDENT_D.Z_RDSINCIDENT_DID=CLOCK_F.Z_RDSINCIDENT_DID
CLOCK_D.Z_RDSCLOCK_DID=CLOCK_F.Z_RDSCLOCK_DID
OUTAGEDETAIL.OUTAGE_ID=OUTAGE_D.OUTAGE_ID
OUTAGE_D.Z_RDSOUTAGE_DID=OUTAGE_F.Z_RDSOUTAGE_DID
INCIDENT_D.Z_RDSINCIDENT_DID=OUTAGE_F.Z_RDSINCIDENT_DID
INCIDENT_D.INCIDENT_ID=SCRELATION.SOURCE
INCIDENT_F.OPEN_TIMEID=RDS_TIMEDIM_D.RDS_TIMEDIM_DID
CM3R_D.NUMBERPRGN=SCRELATION.DEPEND
INCIDENT_F.CLOSE_TIMEID=RDS_TIMEDIM_D.RDS_TIMEDIM_DID
INCIDENT_F.Z_RDSDEVICE_DID=DEVICE_D.Z_RDSDEVICE_DID
DEVICE_D.Z_RDSDEVICE_DID=BI_DEVICE.DEVICEID
CONTACT_D.Z_RDSCONTACT_DID=BI_CONTACT.CONTACTID
LOCATION_D.Z_RDSLOCATION_DID=BI_LOCATION.LOCATIONID
DEPT_D.Z_RDSDEPT_DID=BI_DEPT.DEPTID
DEPT_D.DEPT=CONTACT_D.DEPT
INCIDENT_D.DEPT=DEPT_D.DEPT
CMLABOR_F.Z_RDSCMLABOR_DID=CMLABOR_D.Z_RDSCMLABOR_DID
INCIDENT_D.Z_RDSINCIDENT_DID=CMLABOR_F.Z_RDSINCIDENT_DID
CMPART_F.Z_RDSCMPART_DID=CMPART_D.Z_RDSCMPART_DID
INCIDENT_D.Z_RDSINCIDENT_DID=CMPART_F.Z_RDSINCIDENT_DID
SCRELATION.DEPEND=ROOTCAUS_D.ID
INCIDENT_D.CONTRACT_ID=SERVICEC_D.CONTRACT_ID
INCIDENT_D.AGREEMENT_ID=SLA_D.AGREEMENT_ID
CMLABOR_F.Z_RDSOPERATOR_DID=OPERATOR_D.Z_RDSOPERATOR_DID
MODEL_D.Z_RDSMODEL_DID=CMPART_F.Z_RDSMODEL_DID

Incident Management Module

MODEL_D.Z_RDSMODEL_DID=PROBSUMM_MODEL_ASS.Z_RDSMODEL_DID
PROBSUMM_MODEL_ASS.Z_RDSPROBSUMM_DID=PROBSUMM_D.Z_RDSPROBSUMM_DID
PROBSUMM_D.Z_RDSPROBSUMM_DID=PROBSUMM_F.Z_RDSPROBSUMM_DID
PROBSUMM_F.Z_RDSCONTACT_DID=CONTACT_D.Z_RDSCONTACT_DID
PROBSUMM_F.Z_RDSVENDOR_DID=VENDOR_D.Z_RDSVENDOR_DID
PROBSUMM_F.Z_RDSLOCATION_DID=LOCATION_D.Z_RDSLOCATION_DID
PROBSUMM_F.Z_RDSCOMPANY_DID=COMPANY_D.Z_RDSCOMPANY_DID
DEPT_D.COMPANY=COMPANY_D.COMPANY
OPERATOR_D.NAME*=PROBSUMM_D.TICKET_OWNER
SCRELATION.SOURCE=PROBSUMM_D.NUMBERPRGN
SCRELATION.DEPEND=INCIDENT_D.INCIDENT_ID
CLOCK_D.Z_RDSCLOCK_DID=CLOCK_F.Z_RDSCLOCK_DID
OUTAGEDETAIL.OUTAGE_ID=OUTAGE_D.OUTAGE_ID
OUTAGE_D.Z_RDSOUTAGE_DID=OUTAGE_F.Z_RDSOUTAGE_DID
CATEGORY.NAME=PROBSUMM_D.CATEGORY
ACTIVITY.NUMBERPRGN=PROBSUMM_D.NUMBERPRGN
ASSIGNMENT.NAME=PROBSUMM_D.ASSIGNMENT
PROBCAUSE.CAUSE_CODE*=PROBSUMM_D.CAUSE_CODE
RESOLUTION.RESOLUTION_CODE=PROBSUMM_D.RESOLUTION_CODE
LOCATION_D.COUNTRY=COUNTRY.NAME
PROBSUMM_F.OPEN_TIMEID=RDS_TIMEDIM_D.RDS_TIMEDIM_DID
CM3R_D.NUMBERPRGN=SCRELATION.DEPEND
PROBSUMM_F.CLOSE_TIMEID=RDS_TIMEDIM_D2.RDS_TIMEDIM_DID
PROBSUMM_F.Z_RDSDEVICE_DID=DEVICE_D.Z_RDSDEVICE_DID
DEVICE_D.Z_RDSDEVICE_DID=BI_DEVICE.DEVICEID
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CONTACT_D.Z_RDSCONTACT_DID=BI_CONTACT.CONTACTID
LOCATION_D.Z_RDSLOCATION_DID=BI_LOCATION.LOCATIONID
DEPT_D.Z_RDSDEPT_DID=BI_DEPT.DEPTID
DEPT_D.DEPT=CONTACT_D.DEPT
PROBSUMM_D.DEPT=DEPT_D.DEPT
SCRELATION.DEPEND=ROOTCAUS_D.ID
CMLABOR_F.Z_RDSCMLABOR_DID=CMLABOR_D.Z_RDSCMLABOR_DID
PROBSUMM_D.Z_RDSPROBSUMM_DID=CMLABOR_F.Z_RDSPROBSUMM_DID
CMPART_F.Z_RDSCMPART_DID=CMPART_D.Z_RDSCMPART_DID
PROBSUMM_D.Z_RDSPROBSUMM_DID=CMPART_F.Z_RDSPROBSUMM_DID
PROBSUMM_D.Z_RDSPROBSUMM_DID=CLOCK_F.Z_RDSPROBSUMM_DID
PROBSUMM_D.Z_RDSPROBSUMM_DID=OUTAGE_F.Z_RDSPROBSUMM_DID
PROBSUMM_D.CONTRACT_ID=SERVICEC_D.CONTRACT_ID
PROBSUMM_D.AGREEMENT_ID=SLA_D.AGREEMENT_ID
CMLABOR_F.Z_RDSOPERATOR_DID=OPERATOR_D.Z_RDSOPERATOR_DID
MODEL_D.Z_RDSMODEL_DID=CMPART_F.Z_RDSMODEL_DID

Change Management Module

CLOCK_D.Z_RDSCLOCK_DID=CLOCK_F.Z_RDSCLOCK_DID
CM3R_D.Z_RDSCM3R_DID=CM3R_F.Z_RDSCM3R_DID
CM3T_D.PARENT_CHANGE=CM3R_D.NUMBERPRGN
MODEL_D.Z_RDSMODEL_DID=CM3R_F.Z_RDSMODEL_DID
CM3R_F.Z_RDSLOCATION_DID=LOCATION_D.Z_RDSLOCATION_DID
CM3R_F.Z_RDSVENDOR_DID=VENDOR_D.Z_RDSVENDOR_DID
CM3R_F.Z_RDSCOMPANY_DID=COMPANY_D.Z_RDSCOMPANY_DID
CM3R_D.NUMBERPRGN=APPROVALLOG.NUMBERPRGN
CM3R_D.NUMBERPRGN=ERP_INSTANCE.NUMBERPRGN
SCRELATION_CM3R.SOURCE=CM3R_D.NUMBERPRGN
INCIDENT_D.INCIDENT_ID=SCRELATION.DEPEND
PROBSUMM_D.NUMBERPRGN=SCRELATION.DEPEND
CM3R_F.DATE_ENTEREDID=RDS_TIMEDIM_D.RDS_TIMEDIM_DID
CM3R_D.CURRENT_PHASE=*CM3RCATPHASE.NAME
CM3T_D.CURRENT_PHASE=*CM3TCATPHASE.NAME
CM3RCATPHASE.APPROVALS=*CM3RGROUPS.NAME
CM3R_D.Z_RDSCM3R_DID=CM3R_DEVICE_ASS.Z_RDSCM3R_DID
CM3R_DEVICE_ASS.Z_RDSDEVICE_DID=DEVICE_D.Z_RDSDEVICE_DID
DEVICE_D.Z_RDSDEVICE_DID=BI_DEVICE.DEVICEID
LOCATION_D.Z_RDSLOCATION_DID=BI_LOCATION.LOCATIONID
ROOTCAUS_D.ID=SCRELATION.DEPEND
CMLABOR_F.Z_RDSCMLABOR_DID=CMLABOR_D.Z_RDSCMLABOR_DID
CM3R_D.Z_RDSCM3R_DID=CMLABOR_F.Z_RDSCM3R_DID
CMPART_F.Z_RDSCMPART_DID=CMPART_D.Z_RDSCMPART_DID
CM3R_D.Z_RDSCM3R_DID=CMPART_F.Z_RDSCM3R_DID
SERVICEC_D.Z_RDSSERVICEC_DID=SERVICEC_F.Z_RDSSERVICEC_DID
CM3R_D.Z_RDSCM3R_DID=CLOCK_F.Z_RDSCM3R_DID
CM3R_D.CONTRACT_ID=SERVICEC_D.CONTRACT_ID
CM3SLA.TYPE_LEVEL1=CM3R_D.TYPEPRGN AND 
CM3SLA.TYPE_LEVEL2=CM3R_D.TYPE_LEVEL2 
AND CM3SLA.COMPANY = CM3R_D.COMPANY

CMLABOR_F.Z_RDSOPERATOR_DID=OPERATOR_D2.Z_RDSOPERATOR_DID
MODEL_D.Z_RDSMODEL_DID=CMPART_F.Z_RDSMODEL_DID
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Configuration Management Module

DEPT_D.COMPANY=COMPANY_D.COMPANY
MAINFRAME.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
COMPUTER.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
FURNISHINGS.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DISPLAYDEVICE.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
HANDHELDS.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DEVICE_D.LOGICAL_NAME=NETWORKCOMPONENTS.LOGICAL_NAME
DEVICE_D.LOGICAL_NAME=OFFICEELECTRONICS.LOGICAL_NAME
DEVICE_D.LOGICAL_NAME=SOFTWARELICENSE.LOGICAL_NAME
DEVICE_D.LOGICAL_NAME=STORAGE.LOGICAL_NAME
DEVICE_D.Z_RDSDEVICE_DID=DEVICE_F.Z_RDSDEVICE_DID
COMPANY_D.Z_RDSCOMPANY_DID=DEVICE_F.Z_RDSCOMPANY_DID
CONTACT_D.Z_RDSCONTACT_DID=DEVICE_F.Z_RDSCONTACT_DID
DEVICE_F.Z_RDSLOCATION_DID=LOCATION_D.Z_RDSLOCATION_DID
DEVICE_F.Z_RDSVENDOR_DID=VENDOR_D.Z_RDSVENDOR_DID
DEVICE_D.LOGICAL_NAME=TELECOM.LOGICAL_NAME
DEVICE_ADDL.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DEVICE_FEATURES.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DEVICE_SCANS.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DEVICE_D.LOGICAL_NAME=DEVICE_SUPCONTACT.LOGICAL_NAME
DEVICE_DRIVERS.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DEVICE_CONNECTIONS.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DEVICE_D.LOGICAL_NAME=DEVICE_PORTS.LOGICAL_NAME
DEVICE_D.LOGICAL_NAME=DEVICE_USB.LOGICAL_NAME
DEVICE_LOGICALDRIVERS.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DEVICE_PHYSICALDRIVERS.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DEVICE_POINTING.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DEVICE_D.LOGICAL_NAME=DEVICE_VIDEO.LOGICAL_NAME
DEVICE_D.LOGICAL_NAME=DEVICE_PROCESSORS.LOGICAL_NAME
DEVICE_PRINTER.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DEVICE_KEYBOARDS.LOGICAL_NAME=DEVICE_D.LOGICAL_NAME
DEVICE_D.LOGICAL_NAME=DEVICE_MAINFRAMEALTERNATE.LOGICAL_NAME
DEVICE_D.LOGICAL_NAME=DEVICE_SLOT.LOGICAL_NAME
OUTAGEDETAIL.OUTAGE_ID=OUTAGE_D.OUTAGE_ID
OUTAGE_D.Z_RDSOUTAGE_DID=OUTAGE_F.Z_RDSOUTAGE_DID
DEVICE_F.INSTALL_DATEID=RDS_TIMEDIM_D.RDS_TIMEDIM_DID
DEVICE_D.LOGICAL_NAME=PCSOFTWARE.LOGICAL_NAME
MODEL_D.Z_RDSMODEL_DID=DEVICE_F.Z_RDSMODEL_DID
DEVICE_F.Z_RDSDEPT_DID=DEPT_D.Z_RDSDEPT_DID
OPERATOR_D.NAME*=DEVICE_D.USER_ID
DEVICE_F.LAST_SCANID=RDS_TIMEDIM_D2.RDS_TIMEDIM_DID
DEVICE_D.Z_RDSDEVICE_DID=BI_DEVICE.DEVICEID
CONTACT_D.Z_RDSCONTACT_DID=BI_CONTACT.CONTACTID
LOCATION_D.Z_RDSLOCATION_DID=BI_LOCATION.LOCATIONID
DEPT_D.Z_RDSDEPT_DID=BI_DEPT.DEPTID
DEPT_D.DEPT=CONTACT_D.DEPT
OUTAGE_F.Z_RDSDEVICE_DID=DEVICE_D.Z_RDSDEVICE_DID

SLA Management Module

CLOCK_D.Z_RDSCLOCK_DID=CLOCK_F.Z_RDSCLOCK_DID
OUTAGEDETAIL.OUTAGE_ID=OUTAGE_D.OUTAGE_ID
OUTAGE_D.Z_RDSOUTAGE_DID=OUTAGE_F.Z_RDSOUTAGE_DID
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SLA_F.Z_RDSSLA_DID=SLA_D.Z_RDSSLA_DID
SLAARAVA_F.Z_RDSSLAARAVA_DID=SLAARAVA_D.Z_RDSSLAARAVA_DID
SLAARAVA_F.Z_RDSSLA_DID=SLA_D.Z_RDSSLA_DID
DEVICE_D.Z_RDSDEVICE_DID=SLAARAVA_F.Z_RDSDEVICE_DID
SLAARRES_F.Z_RDSSLA_DID=SLA_D.Z_RDSSLA_DID
SLAARRES_F.Z_RDSSLAARRES_DID=SLAARRES_D.Z_RDSSLAARRES_DID
SLA_D.AGREEMENT_ID=SERVICEENT.SLA_ID
SLA_D.AGREEMENT_ID=SLARESPONSE.AGREEMENT_ID
SLA_D.AGREEMENT_ID=SLAMONTHLY.AGREEMENT_ID
SLA_D.AGREEMENT_ID=SLAMONTHLYAG.AGREEMENT_ID
OUTAGEDETAIL.AGREEMENT_ID=SLA_D.AGREEMENT_ID
CLOCK_F.Z_RDSSLA_DID=SLA_F.Z_RDSSLA_DID

Problem Management Module

ROOTCAUS_D.ID=SCRELATION.SOURCE
SCRELATION.DEPEND=PROBSUMM_D.NUMBERPRGN
SCRELATION.DEPEND=CM3R_D.NUMBERPRGN

CM Parts

CMPART_F.Z_RDSCMPART_DID=CMPART_D.Z_RDSCMPART_DID
SERVICEC_D.Z_RDSSERVICEC_DID=CMPART_F.Z_RDSSERVICEC_DID
CM3R_D.Z_RDSCM3R_DID=CMPART_F.Z_RDSCM3R_DID
PROBSUMM_D.Z_RDSPROBSUMM_DID=CMPART_F.Z_RDSPROBSUMM_DID
INCIDENT_D.Z_RDSINCIDENT_DID=CMPART_F.Z_RDSINCIDENT_DID
RDS_TIMEDIM_D.RDS_TIMEDIM_DID=CMPART_F.DATEUSED_DID
MODEL_D.Z_RDSMODEL_DID=CMPART_F.Z_RDSMODEL_DID

CM Labor

CMLABOR_F.Z_RDSCMLABOR_DID=CMLABOR_D.Z_RDSCMLABOR_DID
SERVICEC_D.Z_RDSSERVICEC_DID=CMLABOR_F.Z_RDSSERVICEC_DID
CM3R_D.Z_RDSCM3R_DID=CMLABOR_F.Z_RDSCM3R_DID
PROBSUMM_D.Z_RDSPROBSUMM_DID=CMLABOR_F.Z_RDSPROBSUMM_DID
INCIDENT_D.Z_RDSINCIDENT_DID=CMLABOR_F.Z_RDSINCIDENT_DID
RDS_TIMEDIM_D.RDS_TIMEDIM_DID=CMLABOR_F.DATEWORKED_DID
OPERATOR_D.Z_RDSOPERATOR_DID=CMLABOR_F.Z_RDSOPERATOR_DID

Expense Line Management

EXPLINE_F.Z_RDSEXPLINE_DID=EXPLINE_D.Z_RDSEXPLINE_DID
DEVICE_D.Z_RDSDEVICE_DID=EXPLINE_F.Z_RDSDEVICE_DID
SERVICEC_D.Z_RDSSERVICEC_DID=EXPLINE_F.Z_RDSSERVICEC_DID
RDS_TIMEDIM_D.RDS_TIMEDIM_DID=EXPLINE_F.DATECUT_DID
RDS_TIMEDIM_D2.RDS_TIMEDIM_DID=EXPLINE_F.DATEPROCESSED_DID
LOCATION_D.Z_RDSLOCATION_DID=EXPLINE_F.Z_RDSLOCATION_DID
COMPANY_D.Z_RDSCOMPANY_DID=EXPLINE_F.Z_RDSCOMPANY_DID
CONTACT_D.Z_RDSCONTACT_DID=EXPLINE_F.Z_RDSCONTACTEB_DID
CONTACT_D2.Z_RDSCONTACT_DID=EXPLINE_F.Z_RDSCONTACTES_DID

Service Contract Management Module

CMLABOR_F.Z_RDSCMLABOR_DID=CMLABOR_D.Z_RDSCMLABOR_DID
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SERVICEC_D.Z_RDSSERVICEC_DID=CMLABOR_F.Z_RDSSERVICEC_DID
OPERATOR_D.Z_RDSOPERATOR_DID=CMLABOR_F.Z_RDSOPERATOR_DID
CMPART_F.Z_RDSCMPART_DID=CMPART_D.Z_RDSCMPART_DID
SERVICEC_D.Z_RDSSERVICEC_DID=CMPART_F.Z_RDSSERVICEC_DID
MODEL_D.Z_RDSMODEL_DID=CMPART_F.Z_RDSMODEL_DID
SERVICEREVIEWS.CONTRACT_ID=SERVICEC_D.CONTRACT_ID
SERVICEC_D.Z_RDSSERVICEC_DID=SERVICEC_F.Z_RDSSERVICEC_DID
RDS_TIMEDIM_D.RDS_TIMEDIM_DID=SERVICEC_F.STARTDATE_DID
RDS_TIMEDIM_D2.RDS_TIMEDIM_DID=SERVICEC_F.ENDDATE_DID
CONTACT_D.Z_RDSCONTACT_DID=SERVICEC_F.Z_RDSCONTACTIN_DID
CONTACT_D2.Z_RDSCONTACT_DID=SERVICEC_F.Z_RDSCONTACTEX_DID
CONTACT_D3.Z_RDSCONTACT_DID=SERVICEC_F.Z_RDSCONTACTES_DID
COMPANY_D.Z_RDSCOMPANY_DID=SERVICEC_F.Z_RDSCOMPANYPRO_DID
COMPANY_D2.Z_RDSCOMPANY_DID=SERVICEC_F.Z_RDSCOMPANYCLI_DID

Clock 

INCIDENT_D.Z_RDSINCIDENT_DID=CLOCK_F.Z_RDSINCIDENT_DID
CLOCK_D.Z_RDSCLOCK_DID=CLOCK_F.Z_RDSCLOCK_DID
PROBSUMM_D.Z_RDSPROBSUMM_DID=CLOCK_F.Z_RDSPROBSUMM_DID
CLOCK_F.OPEN_DATEID=RDS_TIMEDIM_D.RDS_TIMEDIM_DID
CLOCK_F.CLOSE_DATEID=RDS_TIMEDIM_D2.RDS_TIMEDIM_DID
CLOCK_F.Z_RDSSLA_DID=SLA_F.Z_RDSSLA_DID
CM3R_D.Z_RDSCM3R_DID=CLOCK_F.Z_RDSCM3R_DID

Default Joins for HP OpenView AssetCenter

You can group all data warehouse joins by different AssetCenter modules for the rds_ac.unv 
file.

Portfolio Expense Line Module

AMCOMPANY_D.Z_RDSAMCOMPANY_DID=AMASSET_F.Z_RDSAMCOMPANY_DID
AMASSET_F.Z_RDSAMASSET_DID=AMASSET_D.Z_RDSAMASSET_DID
AMMODEL_D.Z_RDSAMMODEL_DID=AMASSET_F.Z_RDSAMMODEL_DID
AMREGION_D.Z_RDSAMREGION_DID=AMASSET_F.Z_RDSAMREGION_DID
AMEMPLDEPT_D.Z_RDSAMEMPLDEPT_DID=AMASSET_F.Z_RDSAMEMPLDEPT_DID
AMCOSTCENTER_D.Z_RDSAMCOSTCENTER_DID=AMASSET_F.Z_RDSAMCOSTCENTER_DID
AMMODEL_D.Z_RDSAMMODEL_DID=BI_AMMODEL.AMMODELID
AMREGION_D.Z_RDSAMREGION_DID=BI_AMREGION.AMREGIONID
BI_AMEMPLDEPT.AMEMPLDEPTID=AMEMPLDEPT_D.Z_RDSAMEMPLDEPT_DID
AMCONTRACT_D.Z_RDSAMCONTRACT_DID=BI_AMCONTRACT.AMCONTRACTID
AMASSET_D.Z_RDSAMASSET_DID=BI_AMASSET.AMASSETID
AMEMPLDEPT_D_DEPT.NAME= (CASE WHEN BI_AMEMPLDEPT.SLEVEL = 4 THEN
BI_AMEMPLDEPT.LEVEL_3_NAME
WHEN BI_AMEMPLDEPT.SLEVEL = 3 THEN BI_AMEMPL
DEPT.LEVEL_2_NAME
WHEN BI_AMEMPLDEPT.SLEVEL = 2 THEN BI_AMEMPLDEPT.LEVEL
_1_NAME
ELSE
BI_AMEMPLDEPT.LEVEL_0_NAME
END)
AND AMEMPLDEPT_D_DEPT.C_BDEPARTMENT = 'Yes'
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AMASSET_D.Z_RDSAMASSET_DID=AMEXPENSELINE_F.Z_RDSAMASSET_DID
AMEXPENSELINE_D.Z_RDSAMEXPENSELINE_DID=AMEXPENSELINE_F.Z_RDSAMEXPENSELINE
_DID
SCHDED_RETIRE_TIMEDIM.RDS_TIMEDIM_DID=AMASSET_F.BIRETIRE_TIMEID
INSTALL_TIMEDIM.RDS_TIMEDIM_DID=AMASSET_F.INSTALL_TIMEID
AMASSET_F.ACQUISITION_TIMEID=RDS_TIMEDIM_D.RDS_TIMEDIM_DID
AMASSET_D.LSTOCKID=AMSTOCK.LSTOCKID
AMPROJECT.LBUDGCNTRID=AMBUDGCENTER_D.LBUDGCNTRID
AMEXPENSELINE_F.BILL_TIMEID=BILLING_TIMEDIM.RDS_TIMEDIM_DID
AMCONTRACT_D.Z_RDSAMCONTRACT_DID=AMASSET_F.Z_RDSMAINTCNTR_DID
AMCONTRACT_D_ACQU.Z_RDSAMCONTRACT_DID=AMASSET_F.Z_RDSACQUCNTR_DID
AMASTPROJDESC.LPROJID=AMPROJECT.LPROJID
AMASSET_D.LASTID=AMASTPROJDESC.LASTID
AMBUDGCENTER_D.Z_RDSAMBUDGCENTER_DID=BUDGET_COST_CENTER.LBUDGCNTRID
AMBUDGCENTER_D.LBUDGCNTRID=AMBUDGLINE.LBUDGCNTRID
BI_AMMODEL.LEVEL_1_NAME=SOFTWARE_EXPENDITURE.LEVEL1
AMASSET_D.LASTID=AMWORKORDER.LASTID
AMCOSTCENTER_D.Z_RDSAMCOSTCENTER_DID=BI_AMCOSTCENTER.AMCOSTCENTERID
EXPENSE_COST_CATEGORY.LCOSTCATID=AMEXPENSELINE_D.LCOSTCATID
AMASSET_D.LCOSTCATID=AMBIUPDCOSTCAT_D.LCOSTCATID
AMBIBRAND_D.LBRANDID_KEY=AMMODEL_D.LBRANDID_KEY
AMBIUPDNATURE_D.LNATUREID_KEY=AMMODEL_D.LNATUREID_KEY
BI_AMBIBRAND.AMBIBRANDID=AMBIBRAND_D.Z_RDSAMBIBRAND_DID
AMPERIOD.LPERIODID=AMBUDGLINE.LPERIODID

Acquisition Contract Module

AMCONTRACT_D_ACQU.Z_RDSAMCONTRACT_DID=AMCONTRACT_F.Z_RDSAMCONTRACT_DID
END_TIMEDIM.RDS_TIMEDIM_DID=AMCONTRACT_F.END_TIMEID
AMCOSTCENTER_D.Z_RDSAMCOSTCENTER_DID=AMCONTRACT_F.Z_RDSAMCOSTCENTER_DID
AMCOMPANY_D.Z_RDSAMCOMPANY_DID=AMCONTRACT_F.Z_RDSAMCOMPANY_DID
AMCONTRACT_D_ACQU.Z_RDSAMCONTRACT_DID=AMCNTRRENT_F.Z_RDSAMCONTRACT_DID
AMCNTRRENT_F.Z_RDSAMCNTRRENT_DID=AMCNTRRENT_D.Z_RDSAMCNTRRENT_DID
AMCONTRACT_D_ACQU.Z_RDSAMCONTRACT_DID=BI_AMCONTRACT.AMCONTRACTID
RDS_TIMEDIM_D.RDS_TIMEDIM_DID=AMCONTRACT_F.START_TIMEID
ACQU_CONTRACT_COST_CATEGORY.LCOSTCATID=AMCONTRACT_D_ACQU.LCOSTCATID

Maintenance Contract Module

AMCONTRACT_D.Z_RDSAMCONTRACT_DID=BI_AMCONTRACT.AMCONTRACTID
AMCONTRACT_D.Z_RDSAMCONTRACT_DID=AMCONTRACT_F.Z_RDSAMCONTRACT_DID
END_TIMEDIM.RDS_TIMEDIM_DID=AMCONTRACT_F.END_TIMEID
AMCOSTCENTER_D.Z_RDSAMCOSTCENTER_DID=AMCONTRACT_F.Z_RDSAMCOSTCENTER_DID
AMCOMPANY_D.Z_RDSAMCOMPANY_DID=AMCONTRACT_F.Z_RDSAMCOMPANY_DID
AMCONTRACT_D.Z_RDSAMCONTRACT_DID=AMCNTRRENT_F.Z_RDSAMCONTRACT_DID
AMCNTRRENT_F.Z_RDSAMCNTRRENT_DID=AMCNTRRENT_D.Z_RDSAMCNTRRENT_DID
RDS_TIMEDIM_D.RDS_TIMEDIM_DID=AMCONTRACT_F.START_TIMEID
AMCONTRACT_D.LCOSTCATID=MAINT_CONTRACT_COST_CATEGORY.LCOSTCATID
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Integrity Check

After you modify the data warehouse universe, make sure to perform an integrity check to 
detect any join loops or context errors.

1 From the Windows Start menu, click Programs > BusinessObjects XI Release 2 > 
BusinessObjects Enterprise > Designer.

2 Log on as the designer user (Administrator).

3 Click Tools > Check Integrity.

4 Select Check All.

5 Click OK. The utility scans the universe and suggests potential problems.

6 Correct any problems.

7 Save your changes.

Schema Changes through Business Objects Designer

Because DecisionCenter Analytics sample reports use the out-of-box data warehouse 
universe, limit your changes to the examples in the following section.

For more information about universe schema changes, refer to the Business Objects Designer 
Guide.

Sample Universe Changes

After you modify the data warehouse universe, make sure to perform an integrity check to 
detect any join loops or context errors.

1 From the Windows Start menu, click Programs > BusinessObjects XI Release 2 > 
BusinessObjects Enterprise > Designer.

2 Log on as the designer user (Administrator).

3 Click Tools > Connections to change an existing connection or create a new connection.

4 Refresh the database structure and perform an integrity check.

5 Limit your universe changes to:

— Table and joins

— Context

— Alias

— Class/objects (Description, SQL and Where) 

— Aggregation
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Changes to an Existing Universe

The Business Objects Designer tool enables you to make the following types of changes to an 
existing universe:

Impact of Universe Changes

The changes you make to the universe impact your schema and existing documents.

Optimizing Universe Samples

Use these suggestions to improve the performance of your universe customization:

• Add tables to the universe structure.

• Insert joins and set cardinalities.

• Detect aliases.

• Detect contexts.

• Create new objects.

• Set up Hierarchies.

Table 16 Impact of Universe Changes

Change Element Description

Schema • Enhanced Impact:
— Adding new columns
— Adding new tables

• Severe Impact:
— Renaming or moving the database
— Changing existing column and table names
— Deleting tables and columns

Existing Document • No Impact:
— Redefining Object SQL
— Renaming an Object
— Copying to a different class
— Moving in the same class or to a different class
— Adding new objects 

• Impact:
— Deleting an existing object
— Deleting and then recreating an object with exactly the same 

definition

• Modify the Array Fetch parameter in Universe Parameters.

• Use shortcut joins.

• Create and use aggregate tables in your database.
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Export the Universe

After you modify the data warehouse universe, export the universe to the universe domain to 
have the new universe take effect.

1 From the Windows Start menu, click Programs > BusinessObjects XI Release 2 > 
BusinessObjects Enterprise > Designer.

2 Click File > Export.

3 From the Domain drop-down list, select your domain.

4 In the Groups list, select an application group.

5 Click OK to export the universe to the application group. You see a message indicating 
that the export is successful.
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2 Advanced Migration
The migration process requires you to update your data warehouse database schema and 
HP OpenView Connect-It scenarios. After you verify these changes, you can begin the 
advanced migration of merging your customized XML file with the current one. Refer to the 
HP OpenView DecisionCenter Installation Guide for information about migrating an 
out-of-box DecisionCenter. 

To adhere to best practices, back up any customizations and configuration files from previous 
releases.

Preparing for the Migration

Before you can begin the advanced migration process, you must do the following tasks:

Task 1: Set up your environment on page 52.

You must stop the scenario prior to migrating the data warehouse and running the installer.

Task 2: Update the data warehouse database schema on page 52.

Run the migration batch file.

Task 3: Upgrade to HP OpenView Connect-It 3.6 on page 55.

Make sure that your environment is running HP OpenView Connect-It 3.6.

Task 4: Upgrade to Business Objects XI Release 2 on page 55.

Make sure that your environment is running BusinessObjects XI R2.

Task 5: Update the DecisionCenter settings in ServiceCenter on page 55.

Import the dca10.unl unload file from the installation media.

Task 6: Update the Connect-It scenario page 56.

Synchronize user records with the data warehouse by updating the scenario.

Task 7: Edit the Connect-It synchronization times page 56.

Changes in the schema require some tables to completely re-synchronize to properly get the 
updates. 

Task 8: Remove deleted records page 57.

To improve the general performance for identifying the records to delete, HP OpenView 
ServiceCenter invokes a delete trigger.
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Setting up Your Environment

Stop the scenario before you begin the migration process.

1 From the Windows Start menu, click Programs > Connect-It > Service Console.

2 Select the rds_sc.scn from the Scenario panel.

3 Click Stop.

4 Back up the <DataWarehouse_Installation>\RDS_SC directory.

5 Insert the data warehouse media in the CD-ROM drive and run the installer.

Updating the Data Warehouse Database Schema

Run the migration batch file that is in the data warehouse installation directory.

1 From the Windows command prompt, navigate to the 
<DataWarehouse_Installation>\RDS_SC\common\bin directory.

2 Run the rds_sc61_migrate.bat batch file.

Checking the Migration

The first time you run the program, you receive the following message:

Migration verification failed…Please make sure you have installed RDS 5.2 
before proceeding 

Exit the program and do the following:

1 Set up the data warehouse RDS 5.1. 

2 Upgrade to the data warehouse RDS v5.2 without completing the manual process. 

3 Run the data warehouse installer for 5.2.1 

4 Run the rds_sc61_migrate.bat program.

You see the following message:

Migration check is complete, continue migration message.

This ensures that you installed the data warehouse RDS 5.2 before proceeding with the 
migration.

To test:

1 From the Windows command prompt, navigate to the 
<DataWarehouse_Installation>\RDS_SC\common\bin directory.

2 Run the rds_sc61_migrate.bat batch file.

Migrating the Problem Management Module

Make sure that the rds_etl_migrate.err file in the 
<DataWarehouse_Installation>\RDS_SC\logs directory has no entries. You can check 
the rds_etl_migrate.log for processing details.
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Before you run the migration program, back up the data warehouse database and record the 
number of rows in each table with an attributeAction=”update” in the rds_etl.xml file. 

For all associate tables, make sure that you set rdsVersion=”5.2.1”. Ensure that you see 
the ROOTCAUS_DEVICE_ASS associate table.

Table 17 Problem Management attributeAction Parameter

Value Table Description

update Outage_d dimension A successful migration has two new columns in 
the table: outage_start_key and 
outage_end_key. Ensure that the data in the 
outage_d and outage_f table is not deleted and 
that the following fields have data:
Z_ETLSTATUS
Z_RDSOUTAGE_DID
Z_RDSTRANSLASTIND
Z_RDSACTIVESTATUSIND
Z_RDSCREATEDDATE

update ServiceC_d dimension You see a record in the RDS_UNIQUECOLUMN table 
for SERVICEC with a key column set to 
contract_id_key.

update SCRELATION direct mapping You see four records in the RDS_UNIQUECOLUMN 
table for SCRELATION with key columns set to 
source, source_filename, depend, and 
depend_filename.

update DEVICEPARENT direct mapping You see two records the in RDS_UNIQUECOLUMN 
table for DEVICEPARENT with key columns set to 
logical_name and parent.

update OUTAGEDETAIL direct mapping You see two new columns in the table: slo_id and 
closed. You see four records in the 
RDS_UNIQUECOLUMN table with key columns set to 
slo_id, logical_name, year and month.

updatewithfact Rootcaus_d You see 21 new columns in the table: 
INCIDENT_CATEGORY, CURRENT_PHASE, 
INCIDENT_COUNT, INITIAL_IMPACT, 
FUTURE_IMPACT, IMPACT, PROBLEM_START_TIME, 
EXPECTED_RESOLUTION_TIME, LOCATION_TYPE, 
FREQUENCY, PROPOSED_SOLUTION, 
REVIEW_NOTES, CAUSE_CODE, 
AFFECTED_COMPANIES, AFFECTED_CI_COUNT, 
LAST_TASK_NO, AGREEMENT_ID, CONTRACT_ID, 
SLA_BREACH, NEXT_BREACH, AFFECTED_CI You 
have a new fact table: rootcaus_f. Ensure that 
the data in the table is not deleted. You see a 
record in the RDS_SCDCOLUMN table for ROOTCAUS 
with the scd key set to current_phase.

add Knownerror direct mapping You see a record in the RDS_UNIQUECOLUMN table 
for Knownerror with the key column set to ID.
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Migrating the Service Level Agreement (SLA) Module

Make sure that the rds_etl_migrate.err file in the 
<DataWarehouse_Installation>\RDS_SC\logs directory has no entries. You can check 
the rds_etl_migrate.log for processing details. 

Verifying Indexes

Ensure that the following indexes exist and verify the details:

Table 18 SLA attributeAction Parameter

Value Table Description

historical SLA_D dimension
SLARAva_D dimension
SLASRRES_D dimension

Ensure that you mark the records in these tables 
as historical.
You must update the following fields:
Z_RDSTRANSLASTIND = 'N'
Z_RDSTRANSENDDATE = Current Date
Z_RDSTRANSMODDATE = Current Date

historical SLA_F fact table
SLAARva_F fact table
SLASRRES_F fact table

You must udpate these fact tables.

add SLAMONTHLYD_D dimension
SLARESPONSED_D dimension
SLO_D dimension
LOAVAIL_D dimension
SLORESPONSE_D dimension

Ensure that you see these dimension tables. Make 
sure the tables have entries in the 
RDS_UNIQUECOLUMN table.

add SLADIRECT direct mapping Ensure that you see this direct mapping table. 
Make sure the table has entries in the 
RDS_UNIQUECOLUMN table.

add SLAMONTHLYD_F fact
SLARESPONSED_F fact
SLORESPONSE_F fact

Ensure that you see these fact tables.

deletedata SLAMONTHLY direct mapping
SLARESPONSE direct mapping

Ensure that all records in these direct mapping 
tables are deleted.

outage_unique
Rootcause_unique
Sla_unique
SLAARAva_unique
SLAARRES_unique
SERVICEC_unique
SLAMON_unique
SLARESP_unique
LO_Unique

SLORESP_unique
UNIQKNOWNERR_IDX
UNIQSCRELATION_IDX
UNIQDEVICEP_IDX
UNIQSLAMONTHLY_IDX
UNIQSLARESP_IDX
UNIQSLA_IDX
UNIQOUTDET_IDX
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Upgrading HP Openview Connect-It

Refer to the HP Openview Connect-It documentation to upgrade from Connect-It 3.4.1 to 
Connect-It 3.6. In a test environment, you can uninstall your current Connect-It application 
and install Connect-It 3.6.

Upgrading Business Objects

Refer to the Business Objects documentation to upgrade from Business Objects e6.5.x to 
BusinessObjects XI Release 2. After you upgrade, you must migrate the old repository objects 
into the new CMS repository.

Updating DecisionCenter Settings in ServiceCenter

Unload files contain records that you need to use HP OpenView ServiceCenter with 
DecisionCenter. The Data Warehouse for ServiceCenter media contains one required unload 
file: dca10.unl. The path is:

\\SupportFiles\ServiceCenter\unload 

Your user profile must have system administration rights to complete this procedure. To 
import ServiceCenter files:

1 From the Data Warehouse for ServiceCenter installation media, copy the contents of this 
directory to your local hard drive:

\\SupportFiles\ServiceCenter\unload files 

2 Start the ServiceCenter client that connects to the server where ServiceCenter is running.

3 From the ServiceCenter Navigation, click Toolkit > Database Manager.

4 Right-click anywhere on the screen to open the pop-up menu.

5 Select Import/Load.

6 Click Browse to locate the files you copied to your local hard drive.

7 Select dca10.unl to import.

8 Click Open.

9 Click Load FG on the toolbar. ServiceCenter displays a confirmation message.

10 Return to the Database Manager and open the triggers file.

11 Search for and delete the following trigger names:

serviceent.bi.after.delete 
cm3sla.bi.after.delete
slamonthly.bi.after.delete
outagedetail.bi.after.delete
outage.bi.after.delete

12 Close the ServiceCenter client.

You must apply Business Objects hot fixes prior to deploying the content. 
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Updating the Connect-It Scenario

You update the scenario to synchronize your user records with the data warehouse.

1 Open the rds_sc.scn scenario.

2 Open all connectors. Click OK through any error messages.

3 Click on the Mapping connector.

4 Click the Mappings tab.

5 Edit the SLADIRECT mapping. Click OK through any error messages.

6 Delete the mapping for the DESCRIPTION field.

7 Click OK.

8 Click the ServiceCenter connector.

9 Click the Document Types tab.

10 Edit the sla (slaSrc) document. Click OK through any error messages.

11 Highlight and delete the Description field. 

12 Add the field description back in the mapping. It should read: data type Long Text.

13 Click OK.

14 Click on the Mapping connector.

15 Click the Mappings tab.

16 Edit the SLADIRECT mapping.

17 Highlight the Description field in the Source pane on the left. Click and drag it to the 
DESCRIPTION field in the Destination pane on the right.

18 Click OK.

19 Save the scenario.

20 To test, close and reopen the scenario. Edit the SLADIRECT mapping. If the mapping 
displays no errors when it opens, the problem is corrected.

Editing Connect-It Synchronization Times

Due to changes in the schema, certain tables must completely re-sync to get updates properly. 
To insure this happens, do the following:

1 Using a text editor, open the \\Program Files\HP\DC\RDS_SC\cit\rds_sc.ini file.

2 Delete the following lines.  

slaSrc (Required)
deviceparentSrc (Required)
screlationSrc (Required)
servicecontractSrc (Required)
slaresponseSrc (Required)
slamonthlySrc (Required)
Rootcausesrc1 (Optional, but strongly encouraged)
outagedetailSrc (Optional)
categorySrc (Optional)

Deleting these lines causes a complete scan of the table; therefore, the more lines that you 
remove, the longer the next synchronization takes.
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Removing Deleted Records

In previous versions of the data warehouse, the delete synchronization function did not work 
correctly for some tables because of primary key issues. You may have leftover records from 
previous deletions that never successfully processed. To correct this, remove or mark data 
historical in the tables in question. Do the following:

1 Using an RDBMS tool (SQL Query Analyzer for SQL Server or SQL Plus Worksheet for 
Oracle), copy and execute following SQL statements:

DELETE FROM DEVICEPARENT;
DELETE FROM SCRELATION;

2 From the Connect-It service console, start the rds_sc.scn scenario file.

3 After the scenario runs completely at least once, return to your RDBMS tool and run the 
following SQL statements.

For Oracle, run the following script.

For SQL Server, run the following script:

UPDATE RDS_ETL_WORK
SET ETL_DATE =
(
SELECT max(Z_RDSLASTMODDATE) from SERVICEC_D
);

UPDATE SERVICEC_D
SET Z_RDSDELETEDDATE= sysdate, Z_RDSLASTMODDATE = sysdate, 

Z_RDSACTIVESTATUSIND='N'
WHERE CONTRACT_ID_KEY in (
SELECT CONTRACT_ID_KEY from SERVICEC_D WHERE 

to_number(to_char(Z_RDSLASTMODDATE,'HH24'))*60+to_number(to_char(Z_RDSLAS
TMODDATE,'MI'))+1000 <
    (SELECT 
to_number(to_char(max(Z_RDSLASTMODDATE),'HH24'))*60+to_number(to_char(max
(Z_RDSLASTMODDATE),'MI')) from SERVICEC_D)
);

UPDATE RDS_ETL_WORK
SET ETL_DATE =
(
SELECT max(Z_RDSLASTMODDATE) from SERVICEC_D
);

UPDATE SERVICEC_D
SET Z_RDSDELETEDDATE= GETDATE(), Z_RDSLASTMODDATE = GETDATE(), 

Z_RDSACTIVESTATUSIND='N'
WHERE CONTRACT_ID_KEY in (
SELECT CONTRACT_ID_KEY from SERVICEC_D, RDS_ETL_WORK
WHERE datediff(hh, ETL_DATE, Z_RDSLASTMODDATE) > 1 or datediff(hh, 

ETL_DATE, Z_RDSLASTMODDATE) < -1
); 
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Customized Migration

A successful migration requires that you customize the rds_etl.xml file, add new tags to the 
XML, modify the Connect-It scenario, and identify changes to the universe structure.

Changes to the XML File for HP OpenView ServiceCenter 6.1 Support

If you customized your XML file, you must manually merge the changes for this release with 
your XML file. The following XML file lists only the changed or additional objects in the 
rds_etl.xml file. Nothing was deleted.

Lines in bold sans serif are field changes. Replace the line with the updated text. 

Lines in bold Courier are key changes. Replace the entire <uniquekey> section with the 
updated text. 

Lines in italics Courier are new. Insert the new text where appropriate. 

<!-- ==========================================================================
Dimension tables
=========================================================================== -->

<!-- ==========================================================================
OUTAGE - This table has had the keys changes to sync with ServiceCenter's primary unique 
key. New fields are added to create char versions of dates that can be used as keys in the 
RDS.
=========================================================================== -->
       <dimension name=’OUTAGE’ rdsVersion=”5.0” attributeAction=”update”>
         <dimensionTableName>
           OUTAGE_D
         </dimensionTableName>
         <dataSourceTableName>
           outage
         </dataSourceTableName>
         <dimensionTableFields>
           <dimensionTableField name=”logical_name” type=”char” size=”60”/>
           <dimensionTableField name=”outage_start” type=”date”/>
           <dimensionTableField name=”outage_end” type=”date”/>
           <dimensionTableField name=”outage_start_key” type=”char” size=”60” 
attributeAction=”add”/>
           <dimensionTableField name=”outage_end_key” type=”char” size=”60” 
attributeAction=”add”/>
           <dimensionTableField name=”outage_id” type=”float”/>
           <dimensionTableField name=”outage_id_key” type=”char” size=”60”/>
           <dimensionTableField name=”last_posting” type=”date”/>
           <dimensionTableField name=”closed” type=”char” size=”1”/>
           <dimensionTableField name=”skip_post” type=”char” size=”1”/>
           <dimensionTableField name=”has_sla” type=”char” size=”1”/>
           <dimensionTableField name=”reference_file” type=”char” size=”40”/>
           <dimensionTableField name=”reference_key” type=”char” size=”40”/>
           <dimensionTableField name=”sysmodcount” type=”float”/>
           <dimensionTableField name=”sysmoduser” type=”char” size=”40”/>
           <dimensionTableField name=”sysmodtime” type=”date”/>
           <dimensionTableField name=”AgeDuration” type=”float”/>
         </dimensionTableFields>
         <uniqueKeys name=”outage_unique”>
           <uniqueKey fieldName=”outage_id_key” srcFieldName=”''outage.id''” 
srctype=”float” size=”60” defaultValue=”no match”/>
         </uniqueKeys>
         <facts>
           <fact name=”OUTAGE_F”>
             <factKeys>
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                <factKey name=”Z_RDSOUTAGE_DID”/>
                <factKey name=”Z_RDSINCIDENT_DID” fieldName=”reference_key” 
tableName=”incident_D” matchFieldName=”incident_ID”/>
                <factKey name=”Z_RDSprobsumm_DID” fieldName=”reference_key” 
tableName=”probsumm_D” matchFieldName=”numberprgn”/>
                <factKey name=”Z_RDSdevice_DID” fieldName=”logical_name” 
tableName=”device_D” matchFieldName=”logical_name”/>
                <factKey name=”outage_startID” fieldName=”outage_start” 
tableName=”RDS_TIMEDIM_D” matchFieldName=”FULLDATE”/>
                <factKey name=”outage_endID” fieldName=”outage_end” 
tableName=”RDS_TIMEDIM_D” matchFieldName=”FULLDATE”/>
             </factKeys>
             <factMeasures>
                <factMeasure name=”AgeDuration” srcType=”src”/>
             </factMeasures>
           </fact>
         </facts>
         <scdKeys/>
         <aggregateKeys/>
       </dimension>
       
<!-- ==========================================================================
ROOTCAUS - New fields have been added to sync with additional fields in SC 6.1 and later.
Fact and aggregates have been added as well.
=========================================================================== -->
       <dimension name=”ROOTCAUS” rdsVersion=”5.0” attributeAction=”updatewithfact”>
         <dimensionTableName>
           ROOTCAUS_D
         </dimensionTableName>
         <dataSourceTableName>
           rootcause
         </dataSourceTableName>
         <dimensionTableFields>
           <dimensionTableField name=”ID” type=”char” size=”60”/>
           <dimensionTableField name=”CATEGORY” type=”char” size=”60”/>
           <dimensionTableField name=”ASSIGNMENT” type=”char” size=”60”/>
           <dimensionTableField name=”STATUS” type=”char” size=”60”/>
           <dimensionTableField name=”LOGICAL_NAME” type=”char” size=”60”/>
           <dimensionTableField name=”BRIEF_DESCRIPTION” type=”char” size=”250”/>
           <dimensionTableField name=”DESCRIPTION” type=”long”/>   
           <dimensionTableField name=”ROOT_CAUSE” type=”long”/>    
           <dimensionTableField name=”UPDATE” type=”long”/>    
           <dimensionTableField name=”OPEN” type=”char” size=”1”/> 
           <dimensionTableField name=”OPEN_TIME” type=”date”/>     
           <dimensionTableField name=”OPENED_BY” type=”char” size=”60”/>
           <dimensionTableField name=”UPDATE_TIME” type=”date”/>     
           <dimensionTableField name=”UPDATED_BY” type=”char” size=”60”/>
           <dimensionTableField name=”CLOSE_TIME” type=”date”/>     
           <dimensionTableField name=”CLOSED_BY” type=”char” size=”60”/>
           <dimensionTableField name=”REOPEN_TIME” type=”date”/>     
           <dimensionTableField name=”REOPENED_BY” type=”char” size=”60”/>
           <dimensionTableField name=”PRIORITY_CODE” type=”char” size=”60”/>
           <dimensionTableField name=”TICKET_OWNER” type=”char” size=”60”/>
           <dimensionTableField name=”SEVERITY” type=”char” size=”60”/>
           <dimensionTableField name=”SYSMODTIME” type=”date”/>     
           <dimensionTableField name=”SYSMODCOUNT” type=”float”/>   
           <dimensionTableField name=”SYSMODUSER” type=”char” size=”60”/>
           <dimensionTableField name=”STATE” type=”char” size=”30”/>
           <dimensionTableField name=”ASSIGNEE_NAME” type=”char” size=”60”/>
           <dimensionTableField name=”SUBCATEGORY” type=”char” size=”60”/>
           <dimensionTableField name=”PRODUCT_TYPE” type=”char” size=”60”/>
           <dimensionTableField name=”PROBLEM_TYPE” type=”char” size=”60”/>
           <dimensionTableField name=”COMPANY” type=”char” size=”60”/>
           <dimensionTableField name=”DUMP” type=”char” size=”60”/>
           <dimensionTableField name=”RESOLUTION” type=”long”/>    
           <dimensionTableField name=”WORKAROUND” type=”long”/>    
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           <!-- All fields below are new to SC6_1 -->
           <dimensionTableField name=”INCIDENT_CATEGORY” type=”char” size=”60” 
attributeAction=”add”/>
           <dimensionTableField name=”CURRENT_PHASE” type=”char” size=”60” 
attributeAction=”add”/>
           <dimensionTableField name=”INCIDENT_COUNT” type=”float” attributeAction=”add”/>   
           <dimensionTableField name=”INITIAL_IMPACT” type=”char” size=”60” 
attributeAction=”add”/>
           <dimensionTableField name=”FUTURE_IMPACT” type=”char” size=”60” 
attributeAction=”add”/>
           <dimensionTableField name=”IMPACT” type=”char” size=”60” attributeAction=”add”/>
           <!-- <dimensionTableField name=”USERS_AFFECTED” type=”float” 
attributeAction=”add”/> -->     
           <dimensionTableField name=”PROBLEM_START_TIME” type=”date” 
attributeAction=”add”/>     
           <dimensionTableField name=”EXPECTED_RESOLUTION_TIME” type=”date” 
attributeAction=”add”/>   
           <dimensionTableField name=”LOCATION_TYPE” type=”char” size=”60” 
attributeAction=”add”/>
           <dimensionTableField name=”FREQUENCY” type=”char” size=”60” 
attributeAction=”add”/>
           <dimensionTableField name=”PROPOSED_SOLUTION” type=”char” size=”60” 
attributeAction=”add”/>
           <dimensionTableField name=”REVIEW_NOTES” type=”char” size=”60” 
attributeAction=”add”/>
           <dimensionTableField name=”CAUSE_CODE” type=”char” size=”60” 
attributeAction=”add”/>
           <dimensionTableField name=”AFFECTED_COMPANIES” type=”long” 
attributeAction=”add”/>    
           <dimensionTableField name=”AFFECTED_CI_COUNT” type=”float” 
attributeAction=”add”/>   
           <dimensionTableField name=”LAST_TASK_NO” type=”float” attributeAction=”add”/>   
           <dimensionTableField name=”AGREEMENT_ID” type=”float” attributeAction=”add”/>   
           <dimensionTableField name=”CONTRACT_ID” type=”float” attributeAction=”add”/>   
           <dimensionTableField name=”SLA_BREACH” type=”char” size=”1” 
attributeAction=”add”/> 
           <dimensionTableField name=”NEXT_BREACH” type=”date” attributeAction=”add”/>   
           <dimensionTableField name=”AFFECTED_CI” type=”long” attributeAction=”add”/>
         </dimensionTableFields>
         <uniqueKeys name=”rootcause_unique”>
           <uniqueKey fieldName=”ID” srcFieldName=”id” srctype=”char” size=”60” 
defaultValue=”no match”/>
         </uniqueKeys>
         <facts>
         <!-- Fact table, scd, aggregates are new to SC6.1 --> 
           <fact name=”ROOTCAUS_F”>
             <factKeys>
                <factKey name=”Z_RDSROOTCAUS_DID”/>
                <factKey name=”Z_RDSOPERATOR_DID” fieldName=”TICKET_OWNER” 
tableName=”OPERATOR_D” matchFieldName=”name”/>
                <factKey name=”START_TIMEID” fieldName=”PROBLEM_START_TIME” 
tableName=”RDS_TIMEDIM_D” matchFieldName=”FULLDATE”/>
                <factKey name=”RESOLUTION_TIMEID” fieldName=”EXPECTED_RESOLUTION_TIME” 
tableName=”RDS_TIMEDIM_D” matchFieldName=”FULLDATE”/>
             </factKeys>
             <factMeasures>
                <factMeasure name=”INCIDENT_COUNT” srcType=”src”/>
                <factMeasure name=”AFFECTED_CI_COUNT” srcType=”src”/>
             </factMeasures>
           </fact>
         </facts>
         <scdKeys/>
         <aggregateKeys>
           <aggregateKey name=”INCIDENT_CATEGORY” type=”char” size=”60”/>
           <aggregateKey name=”CAUSE_CODE” type=”char” size=”60”/>
           <aggregateKey name=”PROBLEM_START_TIME” type=”TIME”/>
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         </aggregateKeys>
       </dimension>
       
<!-- ==========================================================================
SLA - This table has been replaced in the RDS with the direct mapping table SLADIRECT. 
The historical tag notifies the migration program to mark all data within (from older 
versions) as historical.
=========================================================================== -->
       <dimension name=”SLA” rdsVersion=”5.1” attributeAction=”historical”>
       <!--!!! name is the first eight characters from original source table name!!! -->
         <dimensionTableName>
           SLA_D
         </dimensionTableName>
         <dataSourceTableName>
           sla
         </dataSourceTableName>
         <dimensionTableFields>
         <!--!!! types are: char, float, date and long!!! --> 
           <dimensionTableField name=”agreement_id” type=”float”/>
           <dimensionTableField name=”agreement_id_key” type=”char” size=”100”/>
           <dimensionTableField name=”title” type=”char” size=”100”/>
           <dimensionTableField name=”description” type=”long”/>
           <dimensionTableField name=”expiration” type=”date”/>
           <dimensionTableField name=”service_hours” type=”char” size=”80”/>
           <dimensionTableField name=”target” type=”float”/>
           <dimensionTableField name=”time_to_complete” type=”float”/>
           <dimensionTableField name=”schedule_to_complete” type=”char” size=”50”/>
           <dimensionTableField name=”suspend_states” type=”long”/>
           <dimensionTableField name=”sysmodcount” type=”float”/>
           <dimensionTableField name=”sysmoduser” type=”char” size=”60”/>
           <dimensionTableField name=”sysmodtime” type=”date”/>
         </dimensionTableFields>
         <uniqueKeys name=”sla_unique”>
           <uniqueKey fieldName=”title” srcFieldName=”title” srctype=”char” size=”100” 
defaultValue=”no match”/>
         </uniqueKeys>
         <facts>
           <fact name=”SLA_F”>
             <factKeys>
                <factKey name=”Z_RDSSLA_DID”/>
                <factKey name=”expirationD_DID” fieldName=”expiration” 
tableName=”RDS_TIMEDIM_D” matchFieldName=”FULLDATE”/>
             </factKeys>
             <factMeasures>
                <factMeasure name=”target” srcType=”src”/>
                <factMeasure name=”time_to_complete” srcType=”src”/>
             </factMeasures>
           </fact>
         </facts>
         <scdKeys/>
         <aggregateKeys/>
       </dimension>

<!-- ==========================================================================
SLAARAva (SLA availability targets array) - This table has been replaced in the RDS with 
the dimension table SLOAVAIL_D.
The historical tag notifies the migration program to mark all data within (from older 
versions) as historical.
=========================================================================== -->
       <dimension name=”SLAARAva” rdsVersion=”5.1” attributeAction=”historical”>
       <!--!!! It is in SLA availability structure array!!! -->
         <dimensionTableName>
           SLAARAva_D
         </dimensionTableName>
         <dataSourceTableName>
           <!--!!! There is no direct source table!!! -->
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           SLA_AVAILABILITY_ARRAY_OF_STRUCTURE
         </dataSourceTableName>
         <dimensionTableFields>
         <!--!!! types are: char, float, date and long!!! --> 
           <dimensionTableField name=”agreement_id” type=”float”/>
           <dimensionTableField name=”agreement_id_key” type=”char” size=”100”/>
           <dimensionTableField name=”logical_name” type=”char” size=”60”/>
           <dimensionTableField name=”percentage” type=”float”/>
           <dimensionTableField name=”cpm” type=”float”/>
           <dimensionTableField name=”cpm_currency_code” type=”char” size=”60”/>
           <dimensionTableField name=”schedule” type=”char” size=”60”/>
           <dimensionTableField name=”weight” type=”float”/>
         </dimensionTableFields>
         <uniqueKeys name=”SLAARAva_unique”>
           <!--!!! dimension table uniqueKeys type has to be (or converted to) char!!! --> 
           <uniqueKey fieldName=”agreement_id_key” srcFieldName=”''agreement.id''” 
srctype=”float” size=”100” defaultValue=”no match”/>
           <uniqueKey fieldName=”logical_name” srcFieldName=”''logical.name''” 
srctype=”char” size=”20” defaultValue=”no match”/>
         </uniqueKeys>
         <facts>
           <fact name=”SLAARAva_F”>
             <factKeys>
                <factKey name=”Z_RDSSLAARAva_DID”/>
                <factKey name=”z_rdsdevice_did” fieldName=”logical_name” 
tableName=”device_D” matchFieldName=”logical_name”/>
                <factKey name=”z_rdsSLA_did” fieldName=”agreement_id_key” tableName=”SLA_D” 
matchFieldName=”agreement_id_key”/>
             </factKeys>
             <factMeasures>
                <!--!!! Don't use count in measurement names, because BO E6 bugs!!! --> 
                <factMeasure name=”percentage” srcType=”src”/>
                <factMeasure name=”cpm” srcType=”src”/>
                <factMeasure name=”weight” srcType=”src”/>
             </factMeasures>
           </fact>
         </facts>
         <scdKeys/>
         <aggregateKeys/>
       </dimension>

<!-- ==========================================================================
SLAARRES (SLA response targets array) - This table has been replaced in the RDS with the 
dimension table SLO_D.
The historical tag notifies the migration program to mark all data within (from older 
versions) as historical.
=========================================================================== -->
       <dimension name=”SLAARRES” rdsVersion=”5.1” attributeAction=”historical”>
       <!--!!! It is in SLA response structure array!!! -->
         <dimensionTableName>
           SLAARRES_D
         </dimensionTableName>
         <dataSourceTableName>
           <!--!!! There is no direct source table!!! -->
           SLA_RESPONSE_ARRAY_OF_STRUCTURE
         </dataSourceTableName>
         <dimensionTableFields>
         <!--!!! types are: char, float, date and long!!! --> 
           <dimensionTableField name=”agreement_id” type=”float”/>
           <dimensionTableField name=”agreement_id_key” type=”char” size=”100”/>
           <dimensionTableField name=”name” type=”char” size=”100”/>
           <dimensionTableField name=”initial” type=”char” size=”100”/>
           <dimensionTableField name=”final” type=”char” size=”100”/>
           <dimensionTableField name=”time” type=”float”/>
           <dimensionTableField name=”schedule” type=”char” size=”100”/>
           <dimensionTableField name=”weight” type=”float”/>
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         </dimensionTableFields>
         <uniqueKeys name=”SLAARRES_unique”>
           <!--!!! dimension table uniqueKeys type has to be (or converted to) char!!! --> 
           <uniqueKey fieldName=”agreement_id_key” srcFieldName=”''agreement.id''” 
srctype=”float” size=”100” defaultValue=”no match”/>
           <uniqueKey fieldName=”name” srcFieldName=”name” srctype=”char” size=”20” 
defaultValue=”no match”/>
         </uniqueKeys>
         <facts>
           <fact name=”SLAARRES_F”>
             <factKeys>
                <factKey name=”Z_RDSSLAARRES_DID”/>
                <factKey name=”z_rdsSLA_did” fieldName=”agreement_id_key” tableName=”SLA_D” 
matchFieldName=”agreement_id_key”/>
             </factKeys>
             <factMeasures>
                <!--!!! Don't use count in measurement names, because BO E6 bugs!!! --> 
                <factMeasure name=”time” srcType=”src”/>
                <factMeasure name=”weight” srcType=”src”/>
             </factMeasures>
           </fact>
         </facts>
         <scdKeys/>
         <aggregateKeys/>
       </dimension>

<!-- ==========================================================================
SERVICEC - This table has had the keys changes to sync with ServiceCenter's primary unique 
key. 
=========================================================================== -->
       <dimension name=”SERVICEC” rdsVersion=”5.1” attributeAction=”update”>
       <!--!!! It is in SERVICECONTRACT!!! -->
         <dimensionTableName>
           SERVICEC_D
         </dimensionTableName>
         <dataSourceTableName>
           servicecontract
         </dataSourceTableName>
         <dimensionTableFields>
         <!--!!! types are: char, float, date and long!!! --> 
           <dimensionTableField name=”contract_id” type=”float”/>
           <dimensionTableField name=”contract_id_key” type=”char” size=”100”/>
           <dimensionTableField name=”name” type=”char” size=”60”/>
           <dimensionTableField name=”start_date” type=”date”/>
           <dimensionTableField name=”end_date” type=”date”/>
           <dimensionTableField name=”provider” type=”char” size=”60”/>
           <dimensionTableField name=”cost_centre” type=”char” size=”60”/>
           <dimensionTableField name=”internal_contact” type=”char” size=”90”/>
           <dimensionTableField name=”internal_contact_phone” type=”char” size=”60”/>
           <dimensionTableField name=”escalation_contact” type=”char” size=”90”/>
           <dimensionTableField name=”escalation_phone” type=”char” size=”60”/>
           <dimensionTableField name=”client” type=”char” size=”90”/>
           <dimensionTableField name=”external_contact” type=”char” size=”90”/>
           <dimensionTableField name=”duty_calendar” type=”char” size=”60”/>
           <dimensionTableField name=”alert_period” type=”date”/>
           <dimensionTableField name=”call_time_limit” type=”float”/>
           <dimensionTableField name=”warning_time” type=”float”/>
           <dimensionTableField name=”budgeted_amount” type=”float”/>
           <dimensionTableField name=”budgeted_currency” type=”char” size=”60”/>
           <dimensionTableField name=”root_budget_amount” type=”float”/>
           <dimensionTableField name=”root_currency” type=”char” size=”60”/>
           <dimensionTableField name=”spent_root” type=”float”/>
           <dimensionTableField name=”date_of_budget” type=”date”/>
           <dimensionTableField name=”discreet_problems” type=”float”/>
           <dimensionTableField name=”used_problems” type=”float”/>
           <dimensionTableField name=”discreet_calls” type=”float”/>
Advanced Migration 63



           <dimensionTableField name=”used_calls” type=”float”/>
           <dimensionTableField name=”discreet_service_reviews” type=”float”/>
           <dimensionTableField name=”used_service_reviews” type=”float”/>
           <dimensionTableField name=”discreet_site_visits” type=”float”/>
           <dimensionTableField name=”used_site_visits” type=”float”/>
           <dimensionTableField name=”site_visit_cost” type=”float”/>
           <dimensionTableField name=”named_users” type=”long”/>
           <dimensionTableField name=”sysmodcount” type=”float”/>
           <dimensionTableField name=”sysmoduser” type=”char” size=”60”/>
           <dimensionTableField name=”sysmodtime” type=”date”/>
         </dimensionTableFields>
         <uniqueKeys name=”SERVICEC_unique”>
           <!--!!! dimension table uniqueKeys type has to be (or converted to) char!!! --> 
           <uniqueKey fieldName=”contract_id_key” srcFieldName=”''contract.id''” 
srctype=”float” defaultValue=”no match”/>
         </uniqueKeys>
         <facts>
           <fact name=”SERVICEC_F”>
             <factKeys>
                <factKey name=”Z_RDSSERVICEC_DID”/>
                <factKey name=”Z_RDSCONTACTIN_DID” fieldName=”internal_contact” 
tableName=”CONTACT_D” matchFieldName=”CONTACT_NAME”/>
                <factKey name=”Z_RDSCONTACTEX_DID” fieldName=”external_contact” 
tableName=”CONTACT_D” matchFieldName=”CONTACT_NAME”/>
                <factKey name=”Z_RDSCONTACTES_DID” fieldName=”escalation_contact” 
tableName=”CONTACT_D” matchFieldName=”CONTACT_NAME”/>
                <factKey name=”z_rdscompanyPro_did” fieldName=”provider” 
tableName=”COMPANY_D” matchFieldName=”COMPANY”/>
                <factKey name=”z_rdscompanyCli_did” fieldName=”client” 
tableName=”COMPANY_D” matchFieldName=”COMPANY”/>
                <factKey name=”startdate_dID” fieldName=”start_date” 
tableName=”RDS_TIMEDIM_D” matchFieldName=”FULLDATE”/>
                <factKey name=”enddate_dID” fieldName=”end_date” tableName=”RDS_TIMEDIM_D” 
matchFieldName=”FULLDATE”/>
             </factKeys>
             <factMeasures>
                <!--!!! Don't use count in measurement names, because BO E6 bugs!!! --> 
                <factMeasure name=”call_time_limit” srcType=”src”/>
                <factMeasure name=”warning_time” srcType=”src”/>
                <factMeasure name=”budgeted_amount” srcType=”src”/>
                <factMeasure name=”root_budget_amount” srcType=”src”/>
                <factMeasure name=”spent_root” srcType=”src”/>
                <factMeasure name=”discreet_problems” srcType=”src”/>
                <factMeasure name=”used_problems” srcType=”src”/>
                <factMeasure name=”discreet_calls” srcType=”src”/>
                <factMeasure name=”used_calls” srcType=”src”/>
                <factMeasure name=”discreet_service_reviews” srcType=”src”/>
                <factMeasure name=”used_service_reviews” srcType=”src”/>
                <factMeasure name=”discreet_site_visits” srcType=”src”/>
                <factMeasure name=”used_site_visits” srcType=”src”/>
                <factMeasure name=”site_visit_cost” srcType=”src”/>
             </factMeasures>
           </fact>
         </facts>
         <scdKeys/>
         <aggregateKeys/>
       </dimension>

<!-- ==========================================================================
SLM Module Tables - The remaining Dimension tables are new additions created to adapt to 
changes in the 
structure of the Service Level Management module in ServiceCenter 6.1 and later.
=========================================================================== -->
       <dimension name=”SLAMONTHLYD” rdsVersion=”5.2.1” attributeAction=”add”>
         <dimensionTableName>
           SLAMONTHLYD_D
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         </dimensionTableName>
         <dataSourceTableName>
           slamonthly
         </dataSourceTableName>
         <dimensionTableFields> 
           <dimensionTableField name=”AGREEMENT_ID” type=”float”/>    
           <dimensionTableField name=”AGREEMENT_ID_KEY” type=”char” size=”100”/>           
           <dimensionTableField name=”MONTH” type=”float”/>                   
           <dimensionTableField name=”MONTH_KEY” type=”char” size=”100”/>
           <dimensionTableField name=”YEAR” type=”float”/>       
           <!-- Startday will be YEAR/MONTH/01. Do we need Endday? --> 
           <dimensionTableField name=”STARTDAY” type=”date”/>               
           <dimensionTableField name=”YEAR_KEY” type=”char” size=”100”/>
           <dimensionTableField name=”EXPECTED” type=”float”/>                     
           <dimensionTableField name=”ACTUAL” type=”float”/>                     
           <dimensionTableField name=”LOGICAL_NAME” type=”char” size=”100”/>
           <dimensionTableField name=”PERCENTAGE” type=”float”/>                   
           <dimensionTableField name=”COST” type=”float”/>                   
           <dimensionTableField name=”WEIGHTED” type=”float”/>                   
           <dimensionTableField name=”TARGET” type=”float”/>                   
           <dimensionTableField name=”ROOT_COST” type=”float”/>                   
           <dimensionTableField name=”ROOT_CURRENCY_CODE” type=”char” size=”20”/>
           <dimensionTableField name=”COST_CURRENCY_CODE” type=”char” size=”20”/>
           <dimensionTableField name=”SYSMODCOUNT” type=”float”/>                   
           <dimensionTableField name=”SYSMODUSER” type=”char” size=”100”/>
           <dimensionTableField name=”SYSMODTIME” type=”date”/> 
           <dimensionTableField name=”SLO_ID” type=”float”/>    
           <dimensionTableField name=”SLO_ID_KEY” type=”char” size=”100”/>
           <dimensionTableField name=”CLOSED” type=”char” size=”1”/>                 
           <dimensionTableField name=”RESULT” type=”float”/>                   
           <dimensionTableField name=”NEXT_BREACH” type=”date”/>                     
           <dimensionTableField name=”TOTAL_OUTAGES” type=”float”/>                   
           <dimensionTableField name=”AVG_OUTAGE_DURATION” type=”float”/>                     
           <dimensionTableField name=”MTBF” type=”float”/>                     
           <dimensionTableField name=”MAX_DUR_BREACHES” type=”float”/>                   
           <dimensionTableField name=”DUR_PERCENTAGE” type=”float”/>                   
           <dimensionTableField name=”MTBF_ADJUSTED” type=”float”/>                     
           <dimensionTableField name=”AVAIL_TYPE” type=”char” size=”100”/>
         </dimensionTableFields>
         <uniqueKeys name=”SLAMON_UNIQUE”>
           <uniqueKey fieldName=”SLO_ID_KEY” srcFieldName=”''slo.id''” srctype=”float” 
defaultValue=”no match” seqIndex=”1”/>
           <uniqueKey fieldName=”LOGICAL_NAME” srcFieldName=”''logical.name''” 
srctype=”CHAR” size=”60” defaultValue=”no match” seqIndex=”2”/>
           <uniqueKey fieldName=”YEAR_KEY” srcFieldName=”year” srctype=”float” 
defaultValue=”no match” seqIndex=”3”/>
           <uniqueKey fieldName=”MONTH_KEY” srcFieldName=”month” srctype=”float” 
defaultValue=”no match” seqIndex=”4”/>
         </uniqueKeys>
         <facts>
           <fact name=”SLAMONTHLYD_F”>
             <factKeys>
                <factKey name=”Z_RDSSLAMONTHLYD_DID”/>
                <factKey name=”Z_RDSSLOAVAIL_DID” fieldName=”SLO_ID_KEY” 
tableName=”SLOAVAIL_D” matchFieldName=”SLO_ID_KEY”/>
                <factKey name=”STARTDAY” fieldName=”STARTDAY” tableName=”RDS_TIMEDIM_D” 
matchFieldName=”FULLDATE”/>
             </factKeys>
             <factMeasures>
               <factMeasure name=”ACTUAL” srcType=”src”/>           
               <factMeasure name=”PERCENTAGE” srcType=”src”/>                         
               <factMeasure name=”COST” srcType=”src”/>                 
               <factMeasure name=”ROOT_COST” srcType=”src”/> 
               <factMeasure name=”RESULT” srcType=”src”/>                 
               <factMeasure name=”TOTAL_OUTAGES” srcType=”src”/>                 
               <factMeasure name=”AVG_OUTAGE_DURATION” srcType=”src”/>                    
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               <factMeasure name=”MTBF” srcType=”src”/>                    
               <factMeasure name=”MAX_DUR_BREACHES” srcType=”src”/>                 
               <factMeasure name=”DUR_PERCENTAGE” srcType=”src”/>
               <factMeasure name=”MTBF_ADJUSTED” srcType=”src”/>                  
             </factMeasures>
           </fact>
         </facts>
         <scdKeys/>
         <aggregateKeys>
           <aggregateKey name=”AGREEMENT_ID_KEY” type=”char” size=”100”/>
           <aggregateKey name=”LOGICAL_NAME” type=”char” size=”100”/>
           <aggregateKey name=”STARTDAY” type=”TIME”/>
         </aggregateKeys> 
       </dimension>
       <dimension name=”SLARESPONSED” rdsVersion=”5.2.1” attributeAction=”add”>
         <dimensionTableName>
           SLARESPONSED_D
         </dimensionTableName>
         <dataSourceTableName>
           slaresponse
         </dataSourceTableName>
         <dimensionTableFields>
           <dimensionTableField name=”RECORD_ID” type=”float”/>         
           <dimensionTableField name=”RECORD_ID_KEY” type=”char” size=”100”/>          
           <dimensionTableField name=”AGREEMENT_ID” type=”float”/>                   
           <dimensionTableField name=”RESPONSE_NAME” type=”char” size=”60”/>
           <dimensionTableField name=”MEAN” type=”float”/>                     
           <dimensionTableField name=”MEDIAN” type=”float”/>                     
           <dimensionTableField name=”DEVIATION” type=”float”/>                     
           <dimensionTableField name=”MONTH” type=”float”/>                   
           <dimensionTableField name=”YEAR” type=”float”/> 
           <!-- Startday will be YEAR/MONTH/01. Do we need Endday? --> 
           <dimensionTableField name=”STARTDAY” type=”date”/>                  
           <dimensionTableField name=”WEIGHTED” type=”float”/>                   
           <dimensionTableField name=”PERHIT” type=”float”/>                   
           <dimensionTableField name=”SYSMODCOUNT” type=”float”/>                   
           <dimensionTableField name=”SYSMODUSER” type=”char” size=”60”/>
           <dimensionTableField name=”SYSMODTIME” type=”date”/>                  
           <dimensionTableField name=”TOTAL_RECORDS” type=”float”/>                   
           <dimensionTableField name=”TOTAL_BREACHED” type=”float”/>                   
           <dimensionTableField name=”SLO_ID” type=”float”/>    
           <dimensionTableField name=”SLO_ID_KEY” type=”char” size=”100”/>
         </dimensionTableFields>
         <uniqueKeys name=”SLARESP_UNIQUE”>
           <uniqueKey fieldName=”RECORD_ID_KEY” srcFieldName=”''record.id''” 
srctype=”float” defaultValue=”no match”/>
         </uniqueKeys>
         <facts>
           <fact name=”SLARESPONSED_F”>
             <factKeys>
                <factKey name=”Z_RDSSLARESPONSED_DID”/>
                <factKey name=”Z_RDSSLO_DID” fieldName=”SLO_ID_KEY” tableName=”SLO_D” 
matchFieldName=”SLO_ID_KEY”/>
                <factKey name=”STARTDAY” fieldName=”STARTDAY” tableName=”RDS_TIMEDIM_D” 
matchFieldName=”FULLDATE”/>
             </factKeys>
             <factMeasures>
               <factMeasure name=”MEAN” srcType=”src”/>                     
               <factMeasure name=”MEDIAN” srcType=”src”/>                      
               <factMeasure name=”DEVIATION” srcType=”src”/> 
               <factMeasure name=”PERHIT” srcType=”src”/> 
               <factMeasure name=”TOTAL_RECORDS” srcType=”src”/>                  
               <factMeasure name=”TOTAL_BREACHED” srcType=”src”/>     
             </factMeasures>
           </fact>
         </facts>
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         <scdKeys/>
         <aggregateKeys/> 
       </dimension>
       <dimension name=”SLO” rdsVersion=”5.2.1” attributeAction=”add”>
         <dimensionTableName>
           SLO_D
         </dimensionTableName>
         <dataSourceTableName>
           slo
         </dataSourceTableName>
         <dimensionTableFields>
           <dimensionTableField name=”SLO_ID” type=”float”/> 
           <dimensionTableField name=”SLO_ID_KEY” type=”char” size=”100”/>                 
           <dimensionTableField name=”AGREEMENT_ID” type=”float”/>                   
           <dimensionTableField name=”SERVICE_AREA” type=”char” size=”100”/>
           <dimensionTableField name=”NAME” type=”char” size=”100”/>
           <dimensionTableField name=”CONDITION” type=”char” size=”1”/>                 
           <dimensionTableField name=”INITIAL_STATE” type=”char” size=”100”/>
           <dimensionTableField name=”FINAL_STATE” type=”char” size=”100”/>
           <dimensionTableField name=”DURATION_TYPE” type=”char” size=”100”/>
           <dimensionTableField name=”TIME” type=”float”/>                     
           <dimensionTableField name=”TIME_SP” type=”char” size=”100”/>
           <dimensionTableField name=”SCHEDULE” type=”char” size=”100”/>
           <dimensionTableField name=”TZ_TYPE” type=”char” size=”100”/>
           <dimensionTableField name=”TIME_ZONE” type=”char” size=”100”/>
           <dimensionTableField name=”ALERT_NAMES” type=”long”/>
           <dimensionTableField name=”SUSPEND_STATES” type=”long”/>
           <dimensionTableField name=”COMMENTS” type=”char” size=”100”/>
           <dimensionTableField name=”CREATED_FROM_WIZ” type=”char” size=”1”/>                 
           <dimensionTableField name=”SYSMODCOUNT” type=”float”/>                   
           <dimensionTableField name=”SYSMODUSER” type=”char” size=”100”/>
           <dimensionTableField name=”SYSMODTIME” type=”date”/>                     
           <dimensionTableField name=”PROCESS_OWNER” type=”char” size=”100”/>
           <dimensionTableField name=”END_OF_DAY_WINDOW” type=”date”/>                     
           <dimensionTableField name=”END_OF_WEEK” type=”float”/>                   
           <dimensionTableField name=”TYPE” type=”char” size=”100”/>
         </dimensionTableFields>
         <uniqueKeys name=”SLO_UNIQUE”>
           <uniqueKey fieldName=”SLO_ID_KEY” srcFieldName=”''slo.id''” srctype=”float” 
defaultValue=”no match”/>
         </uniqueKeys>
         <facts/>
         <scdKeys/>
         <aggregateKeys/> 
       </dimension>
       <dimension name=”SLOAVAIL” rdsVersion=”5.2.1” attributeAction=”add”>
         <dimensionTableName>
           SLOAVAIL_D
         </dimensionTableName>
         <dataSourceTableName>
           sloavail
         </dataSourceTableName>
         <dimensionTableFields>
           <dimensionTableField name=”SLO_ID” type=”float”/> 
           <dimensionTableField name=”SLO_ID_KEY” type=”char” size=”100”/>                 
           <dimensionTableField name=”AGREEMENT_ID” type=”float”/>                   
           <dimensionTableField name=”NAME” type=”char” size=”100”/>
           <dimensionTableField name=”CI” type=”char” size=”100”/>
           <dimensionTableField name=”SCHEDULE” type=”char” size=”100”/>
           <dimensionTableField name=”TIME_ZONE” type=”char” size=”100”/>
           <dimensionTableField name=”REQ_UPTIME” type=”float”/>                   
           <dimensionTableField name=”MAX_OUTAGE_DURATION” type=”float”/>                     
           <dimensionTableField name=”COMMENTS” type=”char” size=”100”/>
           <dimensionTableField name=”ALERT_NAMES” type=”long”/>
           <dimensionTableField name=”AVAIL_TYPE” type=”char” size=”100”/>
           <dimensionTableField name=”SYSMODCOUNT” type=”float”/>                   
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           <dimensionTableField name=”SYSMODUSER” type=”char” size=”100”/>
           <dimensionTableField name=”SYSMODTIME” type=”date”/>                     
           <dimensionTableField name=”PERCENTAGE” type=”float”/>                   
           <dimensionTableField name=”NEXT_BREACH” type=”date”/>                     
           <dimensionTableField name=”RESULT” type=”float”/>                   
           <dimensionTableField name=”PROCESS_OWNER” type=”char” size=”100”/>
           <dimensionTableField name=”TYPE” type=”char” size=”100”/>
         </dimensionTableFields>
         <uniqueKeys name=”SLOAVAIL_UNIQUE”>
           <uniqueKey fieldName=”SLO_ID_KEY” srcFieldName=”''slo.id''” srctype=”float” 
defaultValue=”no match”/>
         </uniqueKeys>
         <facts/>
         <scdKeys/>
         <aggregateKeys/> 
       </dimension>        
       <dimension name=”SLORESPONSE” rdsVersion=”5.2.1” attributeAction=”add”>
         <dimensionTableName>
           SLORESPONSE_D
         </dimensionTableName>
         <dataSourceTableName>
           sloresponse
         </dataSourceTableName>
         <dimensionTableFields>
           <dimensionTableField name=”FOREIGN_FILENAME” type=”char” size=”100”/>
           <dimensionTableField name=”FOREIGN_KEY” type=”char” size=”100”/>
           <dimensionTableField name=”SLO_ID” type=”float”/>   
           <dimensionTableField name=”SLO_ID_KEY” type=”char” size=”100”/>                
           <dimensionTableField name=”SLO_NAME” type=”char” size=”100”/>
           <dimensionTableField name=”INITIAL_STATE” type=”char” size=”100”/>
           <dimensionTableField name=”FINAL_STATE” type=”char” size=”100”/>
           <dimensionTableField name=”EXPIRATION_TIME” type=”date”/>                     
           <dimensionTableField name=”RUNNING” type=”char” size=”1”/>                 
           <dimensionTableField name=”SUSPENDED” type=”char” size=”1”/>                 
           <dimensionTableField name=”BREACHED” type=”char” size=”1”/>                 
           <dimensionTableField name=”CURRENT_STATUS” type=”float”/>                   
           <dimensionTableField name=”ACTIVE” type=”char” size=”1”/>                 
           <dimensionTableField name=”START_TIME” type=”date”/>                     
           <dimensionTableField name=”END_TIME” type=”date”/>                     
           <dimensionTableField name=”AGREEMENT_ID” type=”float”/>                   
           <dimensionTableField name=”TOTAL_TIME” type=”float”/>                     
           <dimensionTableField name=”SYSMODTIME” type=”date”/>                     
           <dimensionTableField name=”SYSMODUSER” type=”char” size=”100”/>
           <dimensionTableField name=”SYSMODCOUNT” type=”float”/> 
         </dimensionTableFields>
         <uniqueKeys name=”SLORESP_UNIQUE”>
           <uniqueKey fieldName=”FOREIGN_FILENAME” srcFieldName=”''foreign.filename''” 
srctype=”CHAR” size=”100” defaultValue=”no match”/>
           <uniqueKey fieldName=”FOREIGN_KEY” srcFieldName=”''foreign.key''” srctype=”CHAR” 
size=”100” defaultValue=”no match”/>
           <uniqueKey fieldName=”SLO_ID_KEY” srcFieldName=”''slo.id''” srctype=”float” 
defaultValue=”no match”/>
         </uniqueKeys>
         <facts>
           <fact name=”SLORESPONSE_F”>
             <factKeys>
                <factKey name=”Z_RDSSLORESPONSE_DID”/>
                <factKey name=”Z_RDSSLO_DID” fieldName=”SLO_ID_KEY” tableName=”SLO_D” 
matchFieldName=”SLO_ID_KEY”/>
                <factKey name=”STARTTIME” fieldName=”START_TIME” tableName=”RDS_TIMEDIM_D” 
matchFieldName=”FULLDATE”/>
                <factKey name=”ENDTIME” fieldName=”END_TIME” tableName=”RDS_TIMEDIM_D” 
matchFieldName=”FULLDATE”/>
             </factKeys>
             <factMeasures>
               <factMeasure name=”TOTAL_TIME” srcType=”src”/>                         
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             </factMeasures>
           </fact>
         </facts>
         <scdKeys/>
         <aggregateKeys/> 
       </dimension>                

<!-- ==========================================================================
Associate tables
=========================================================================== -->

<!-- ==========================================================================
Formerly, only a single Configuration Item (asset) was associated with a Problem (root 
cause). Now, an array of Cis can be associated, necessitating an associate table between 
rootcaus and device.
=========================================================================== -->
        <associate name=”ROOTCAUS_DEVICE_ASS” rdsVersion=”5.2.1” tableName=”ROOTCAUS” 
fieldName=”LOGICAL_NAME” longFieldName=”AFFECTED_CI” tableName2=”DEVICE” 
fieldName2=”LOGICAL_NAME”/>
   
<!-- ==========================================================================
Direct mapping tables
=========================================================================== -->

<!-- ==========================================================================
KNOWNERROR - This table is new in SC 6.1
=========================================================================== -->
       <directMapping name=”KNOWNERROR” rdsVersion=”5.2.1” dataSourceTableName=”knownerror” 
attributeAction=”add”>
         <directMappingFields>    
           <directMappingField name=”ID” type=”char” size=”60”/>
           <directMappingField name=”CATEGORY” type=”char” size=”60”/>
           <directMappingField name=”ASSIGNMENT” type=”char” size=”60”/>
           <directMappingField name=”STATUS” type=”char” size=”60”/>
           <directMappingField name=”LOGICAL_NAME” type=”char” size=”60”/>
           <directMappingField name=”BRIEF_DESCRIPTION” type=”char” size=”250”/>
           <directMappingField name=”DESCRIPTION” type=”long”/>
           <directMappingField name=”ROOT_CAUSE” type=”long”/>
           <directMappingField name=”UPDATE” type=”long”/>
           <directMappingField name=”OPEN” type=”char” size=”1”/>
           <directMappingField name=”OPEN_TIME” type=”date”/>
           <directMappingField name=”OPENED_BY” type=”char” size=”60”/>
           <directMappingField name=”UPDATE_TIME” type=”date”/>
           <directMappingField name=”UPDATED_BY” type=”char” size=”60”/>
           <directMappingField name=”CLOSE_TIME” type=”date”/>
           <directMappingField name=”CLOSED_BY” type=”char” size=”60”/>
           <directMappingField name=”REOPEN_TIME” type=”date”/>
           <directMappingField name=”REOPENED_BY” type=”char” size=”60”/>
           <directMappingField name=”PRIORITY_CODE” type=”char” size=”60”/>
           <directMappingField name=”TICKET_OWNER” type=”char” size=”60”/>
           <directMappingField name=”SEVERITY” type=”char” size=”60”/>
           <directMappingField name=”SYSMODTIME” type=”date”/>
           <directMappingField name=”SYSMODCOUNT” type=”float”/>
           <directMappingField name=”SYSMODUSER” type=”char” size=”60”/>
           <directMappingField name=”ASSIGNEE_NAME” type=”char” size=”60”/>
           <directMappingField name=”SUBCATEGORY” type=”char” size=”60”/>
           <directMappingField name=”PRODUCT_TYPE” type=”char” size=”60”/>
           <directMappingField name=”PROBLEM_TYPE” type=”char” size=”60”/>
           <directMappingField name=”COMPANY” type=”char” size=”60”/>
           <directMappingField name=”DUMP” type=”char” size=”60”/>
           <directMappingField name=”RESOLUTION” type=”long”/>
           <directMappingField name=”WORKAROUND” type=”long”/>
           <directMappingField name=”INCIDENT_CATEGORY” type=”char” size=”60”/>
           <directMappingField name=”CURRENT_PHASE” type=”char” size=”60”/>
           <directMappingField name=”INCIDENT_COUNT” type=”float”/>
           <directMappingField name=”INITIAL_IMPACT” type=”char” size=”60”/>
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           <directMappingField name=”FUTURE_IMPACT” type=”char” size=”60”/>
           <directMappingField name=”IMPACT” type=”char” size=”60”/>
           <directMappingField name=”USERS_AFFECTED” type=”float”/>
           <directMappingField name=”PROBLEM_START_TIME” type=”date”/>
           <directMappingField name=”EXPECTED_RESOLUTION_TIME” type=”date”/>
           <directMappingField name=”LOCATION_TYPE” type=”char” size=”60”/>
           <directMappingField name=”FREQUENCY” type=”char” size=”60”/>
           <directMappingField name=”PROPOSED_SOLUTION” type=”char” size=”60”/>
           <directMappingField name=”REVIEW_NOTES” type=”char” size=”60”/>
           <directMappingField name=”PARENT_PROBLEM” type=”char” size=”60”/>
           <directMappingField name=”MATCHING_CI_COUNT” type=”float”/>
           <directMappingField name=”MATCHING_CI” type=”long”/>
           <directMappingField name=”AFFECTED_COMPANIES” type=”long”/>
           <directMappingField name=”CAUSE_CODE” type=”char” size=”60”/>
         </directMappingFields>
         <directMappingIndexes>
           <directMappingIndex name=”UNIQKNOWNERR_IDX”>
             <DirectMappingIndexKey fieldName=”ID” srcFieldName=”id” srctype=”char” 
size=”60” seqIndex=”1”/>
           </directMappingIndex> 
         </directMappingIndexes>
       </directMapping>

<!-- ==========================================================================
ROOTCAUSETASK - This table is new in SC 6.1. It is not being used at this time, but the 
definition
remains in the XML (commented out) for easy insertion.
=========================================================================== -->
<!-- ==========================================================================
       RootCauseTask - new in 6.1
       
       <directMapping name=”ROOTCAUSETASK” rdsVersion=”5.2.1” 
dataSourceTableName=”rootcausetask” attributeAction=”add”>
         <directMappingFields> 
           <directMappingField name=”ID” type=”char” size=”60”/>
           <directMappingField name=”PARENT_PROBLEM” type=”char” size=”60”/>
           <directMappingField name=”PRIORITY_CODE” type=”char” size=”60”/>
           <directMappingField name=”TICKET_OWNER” type=”char” size=”60”/>
           <directMappingField name=”BRIEF_DESCRIPTION” type=”char” size=”60”/>
           <directMappingField name=”ASSIGNMENT” type=”char” size=”60”/>
           <directMappingField name=”LOGICAL_NAME” type=”char” size=”60”/>
           <directMappingField name=”ASSIGNEE_NAME” type=”char” size=”60”/>
           <directMappingField name=”DUE_DATE” type=”date”/>
           <directMappingField name=”STATUS” type=”char” size=”60”/>
           <directMappingField name=”WORKAROUND” type=”char” size=”60”/>
           <directMappingField name=”TASK_CATEGORY” type=”char” size=”60”/>
           <directMappingField name=”TASK_RESOLUTION” type=”char” size=”60”/>
           <directMappingField name=”OPEN” type=”char” size=”1”/>
           <directMappingField name=”INITIAL_IMPACT” type=”char” size=”60”/>
           <directMappingField name=”SEVERITY” type=”char” size=”60”/>
           <directMappingField name=”OPENED_BY” type=”char” size=”60”/>
           <directMappingField name=”UPDATED_BY” type=”char” size=”60”/>
           <directMappingField name=”CLOSED_BY” type=”char” size=”60”/>
           <directMappingField name=”REOPENED_BY” type=”char” size=”60”/>
           <directMappingField name=”OPEN_TIME” type=”date”/>
           <directMappingField name=”UPDATE_TIME” type=”date”/>
           <directMappingField name=”CLOSE_TIME” type=”date”/>
           <directMappingField name=”REOPEN_TIME” type=”date”/>
           <directMappingField name=”INCIDENT_CATEGORY” type=”char” size=”60”/>
           <directMappingField name=”SUBCATEGORY” type=”char” size=”60”/>
           <directMappingField name=”PRODUCT_TYPE” type=”char” size=”60”/>
           <directMappingField name=”PROBLEM_TYPE” type=”char” size=”60”/>
           <directMappingField name=”DESCRIPTION” type=”long”/>
           <directMappingField name=”UPDATE” type=”long”/>
           <directMappingField name=”ROOT_CAUSE” type=”long”/>
           <directMappingField name=”AGREEMENT_ID” type=”float”/>
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           <directMappingField name=”CONTRACT_ID” type=”float”/>
           <directMappingField name=”SLA_BREACH” type=”char” size=”1”/>
           <directMappingField name=”NEXT_BREACH” type=”date”/>
           <directMappingField name=”SYSMODTIME” type=”date”/>
           <directMappingField name=”SYSMODUSER” type=”char” size=”60”/>
           <directMappingField name=”SYSMODCOUNT” type=”float”/>    
         </directMappingFields>
         <directMappingIndexes>
           <directMappingIndex name=”UNIQRCTASK_IDX”>
             <DirectMappingIndexKey fieldName=”ID” srcFieldName=”id” srctype=”char” 
size=”60” seqIndex=”1”/>
           </directMappingIndex> 
         </directMappingIndexes>
       </directMapping>    
=========================================================================== --> 

<!-- ==========================================================================
SCRELATION - This table has had the keys changes to sync with ServiceCenter's primary 
unique key. 
=========================================================================== -->
       <directMapping name=”SCRELATION” dataSourceTableName=”screlation” rdsVersion=”5.0” 
attributeAction=”update”>
         <directMappingFields>
           <directMappingField name=”source” type=”char” size=”50”/>
           <directMappingField name=”source_filename” type=”char” size=”50”/>
           <directMappingField name=”depend” type=”char” size=”50”/>
           <directMappingField name=”depend_filename” type=”char” size=”50”/>
           <directMappingField name=”type” type=”char” size=”50”/>
           <directMappingField name=”source_active” type=”char” size=”1”/>
           <directMappingField name=”depend_active” type=”char” size=”1”/>
           <directMappingField name=”sysmodcount” type=”float”/>
           <directMappingField name=”sysmoduser” type=”char” size=”30”/>
           <directMappingField name=”sysmodtime” type=”date”/>
           <directMappingField name=”descprgn” type=”char” size=”300”/>
           <directMappingField name=”depend_call” type=”char” size=”50”/>
           <directMappingField name=”depend_change” type=”char” size=”50”/>
           <directMappingField name=”depend_incident” type=”char” size=”50”/>
           <directMappingField name=”depend_quote” type=”char” size=”50”/>
           <directMappingField name=”depend_rootcause” type=”char” size=”50”/>
         </directMappingFields>
         <directMappingIndexes>
           <directMappingIndex name=”UNIQSCRELATION_IDX”>
             <DirectMappingIndexKey fieldName=”source” srcFieldName=”source” 
srctype=”char” size=”60” seqIndex=”1”/>
             <DirectMappingIndexKey fieldName=”source_filename” 
srcFieldName=”''source.filename''” srctype=”char” size=”60” seqIndex=”2”/>
             <DirectMappingIndexKey fieldName=”depend” srcFieldName=”depend” 
srctype=”char” size=”60” seqIndex=”3”/>
             <DirectMappingIndexKey fieldName=”depend_filename” 
srcFieldName=”''depend.filename''” srctype=”char” size=”60” seqIndex=”4”/>          
           </directMappingIndex> 
         </directMappingIndexes>
       </directMapping>

<!-- ==========================================================================
OUTAGEDETAIL - This table has had the keys changes to sync with ServiceCenter's primary 
unique key. 
Two new fields have also been added.
=========================================================================== -->
       <directMapping name=”OUTAGEDETAIL” rdsVersion=”5.1” dataSourceTableName=”outagedetail” 
attributeAction=”update”>
         <directMappingFields>
           <directMappingField name=”LOGICAL_NAME” type=”char” size=”60”/>
           <directMappingField name=”AGREEMENT_ID” type=”float”/>
           <directMappingField name=”OUTAGE_ID” type=”float”/>
           <directMappingField name=”DOWNTIME” type=”float”/>
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           <directMappingField name=”MONTH” type=”float”/>
           <directMappingField name=”YEAR” type=”float”/>
           <directMappingField name=”COST” type=”float”/>
           <directMappingField name=”COST_CURRENCY_CODE” type=”char” size=”30”/>
           <directMappingField name=”SYSMODCOUNT” type=”float”/>
           <directMappingField name=”SYSMODUSER” type=”char” size=”30”/>
           <directMappingField name=”SYSMODTIME” type=”date”/>
           <directMappingField name=”SLO_ID” type=”float” attributeAction=”add” />                   
           <directMappingField name=”CLOSED” type=”char” size=”1” attributeAction=”add” /> 
         </directMappingFields>
         <directMappingIndexes>
           <directMappingIndex name=”UNIQOUTDET_IDX”>
             <DirectMappingIndexKey fieldName=”SLO_ID” srcFieldName=”''slo.id''” 
srctype=”FLOAT” seqIndex=”1”/>
             <DirectMappingIndexKey fieldName=”LOGICAL_NAME” 
srcFieldName=”''logical.name''” srctype=”CHAR” size=”60” seqIndex=”2”/>
             <DirectMappingIndexKey fieldName=”YEAR” srcFieldName=”year” 
srctype=”FLOAT” seqIndex=”3”/>
             <DirectMappingIndexKey fieldName=”MONTH” srcFieldName=”month” 
srctype=”FLOAT” seqIndex=”4”/>
           </directMappingIndex> 
         </directMappingIndexes>
       </directMapping>

<!-- ==========================================================================
CATEGORY - several fields have had their data types changed from Date to Float. The data in 
ServiceCenter
is actually a relative date (elapsed time), which is better represented as a number of 
seconds.
=========================================================================== -->
       <directMapping name=”category” rdsVersion=”5.0” dataSourceTableName=”category” attributeAction=”update”>
         <directMappingFields>
           <directMappingField name=”name” type=”char” size=”50”/>
           <directMappingField name=”activity” type=”long”/>
           <directMappingField name=”open_format” type=”char” size=”60”/>
           <directMappingField name=”update_format” type=”char” size=”60”/>
           <directMappingField name=”close_format” type=”char” size=”60”/>
           <directMappingField name=”countprgn” type=”float”/>

           <directMappingField name=”alert1” type=”float” attributeAction=”update”/>
           <directMappingField name=”alert2” type=”float” attributeAction=”update”/>
           <directMappingField name=”alert3” type=”float” attributeAction=”update”/>
           <directMappingField name=”reassign” type=”float” attributeAction=”update”/>

           <directMappingField name=”default_assign” type=”char” size=”50”/>
           <directMappingField name=”avail_post” type=”char” size=”1”/>
           <directMappingField name=”qbe_format” type=”char” size=”60”/>

           <directMappingField name=”dl_alert” type=”float” attributeAction=”update”/>
           <directMappingField name=”dl_group” type=”char” size=”60”/>
           <directMappingField name=”print_override” type=”char” size=”1”/>
           <directMappingField name=”print_open” type=”char” size=”1”/>
           <directMappingField name=”print_open_format” type=”char” size=”60”/>
           <directMappingField name=”print_update” type=”char” size=”1”/>
           <directMappingField name=”print_update_format” type=”char” size=”60”/>
           <directMappingField name=”print_close” type=”char” size=”1”/>
           <directMappingField name=”print_close_format” type=”char” size=”60”/>
           <directMappingField name=”alert_pages” type=”char” size=”1”/>
           <directMappingField name=”initial_format” type=”char” size=”60”/>
           <directMappingField name=”check_duplicates” type=”char” size=”1”/>
           <directMappingField name=”check_parents” type=”char” size=”1”/>
           <directMappingField name=”include_unexpired” type=”char” size=”1”/>
           <directMappingField name=”expires_after” type=”date”/>
           <directMappingField name=”script” type=”char” size=”50”/>
           <directMappingField name=”browse_format” type=”char” size=”60”/>
           <directMappingField name=”category_format” type=”char” size=”40”/>
           <directMappingField name=”wdClsDuration” type=”float”/>
           <directMappingField name=”wdUD1” type=”float”/>
           <directMappingField name=”wdUD2” type=”float”/>
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           <directMappingField name=”wdPriority” type=”float”/>
           <directMappingField name=”wdClsCustSatisfaction” type=”char” size=”30”/>
           <directMappingField name=”wdClsActDuration” type=”float”/>
           <directMappingField name=”wdClsRoot” type=”float”/>
           <directMappingField name=”wdClsLevel” type=”float”/>
           <directMappingField name=”wdClsParent” type=”float”/>
           <directMappingField name=”wdClsInflatePriority” type=”float”/>
           <directMappingField name=”wdClsTimeStamp” type=”float”/>
           <directMappingField name=”print_format” type=”char” size=”30”/>
           <directMappingField name=”active” type=”char” size=”1”/>
           <directMappingField name=”sysmodcount” type=”float”/>
           <directMappingField name=”sysmoduser” type=”char” size=”30”/>
           <directMappingField name=”sysmodtime” type=”date”/>
           <directMappingField name=”copy_open_link” type=”char” size=”30”/>
           <directMappingField name=”company” type=”char” size=”60”/>
           <directMappingField name=”alert1_expression” type=”long”/>
           <directMappingField name=”alert2_expression” type=”long”/>
           <directMappingField name=”alert3_expression” type=”long”/>
           <directMappingField name=”dl_expression” type=”long”/>
           <directMappingField name=”reass_expression” type=”long”/>
           <directMappingField name=”device_types” type=”long”/>
           <directMappingField name=”review_print_formats” type=”long”/>
           <directMappingField name=”open_print_formats” type=”long”/>
           <directMappingField name=”update_print_formats” type=”long”/>
           <directMappingField name=”close_print_formats” type=”long”/>
           <directMappingField name=”assignment_expression” type=”long”/>
           <directMappingField name=”wdTips” type=”long”/>
           <directMappingField name=”engine_alerts” type=”long”/>
         </directMappingFields>
         <directMappingIndexes>
           <directMappingIndex name=”UNIQCATEGORY_IDX”>
             <DirectMappingIndexKey fieldName=”name” srcFieldName=”name” srctype=”char” 
size=”60” seqIndex=”1”/>
           </directMappingIndex> 
         </directMappingIndexes>
       </directMapping>

<!-- ==========================================================================
DEVICEPARENT - This table has had the keys changes to sync with ServiceCenter's primary 
unique key. 
=========================================================================== -->
       <directMapping name=”deviceparent” rdsVersion=”5.0” dataSourceTableName=”deviceparent” 
attributeAction=”update”>
         <directMappingFields>
           <directMappingField name=”logical_name” type=”char” size=”60”/>
           <directMappingField name=”parent” type=”char” size=”50”/>
           <directMappingField name=”relationship” type=”char” size=”50”/>
           <directMappingField name=”sysmodcount” type=”float”/>
           <directMappingField name=”sysmoduser” type=”char” size=”30”/>
           <directMappingField name=”sysmodtime” type=”date”/>
           <directMappingField name=”port_no” type=”float”/>
           <directMappingField name=”comments” type=”long”/>
         </directMappingFields>
         <directMappingIndexes>
           <directMappingIndex name=”UNIQDEVICEP_IDX”>
             <DirectMappingIndexKey fieldName=”logical_name” 
srcFieldName=”''logical.name''” srctype=”char” size=”60” seqIndex=”1”/>
             <DirectMappingIndexKey fieldName=”parent” srcFieldName=”parent” 
srctype=”char” size=”50” seqIndex=”2”/>
           </directMappingIndex> 
         </directMappingIndexes>
       </directMapping>

<!-- ==========================================================================
SLA - This table has been replaced in the RDS with the Dimension table SLAMONTHLYD_D.
The deletedata tag notifies the migration program to remove all data (from older versions)
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=========================================================================== -->
       <directMapping name=”slamonthly” rdsVersion=”5.1” dataSourceTableName=”slamonthly” 
attributeAction=”deletedata”>
         <directMappingFields>
           <directMappingField name=”agreement_id” type=”float”/>
           <directMappingField name=”logical_name” type=”char” size=”100”/>
           <directMappingField name=”month” type=”float”/>
           <directMappingField name=”year” type=”float”/>
           <directMappingField name=”expected” type=”float”/>
           <directMappingField name=”actual” type=”float”/>
           <directMappingField name=”target” type=”float”/>
           <directMappingField name=”percentage” type=”float”/>
           <directMappingField name=”weighted” type=”float”/>
           <directMappingField name=”cost” type=”float”/>
           <directMappingField name=”cost_currency_code” type=”char” size=”20”/>
           <directMappingField name=”root_cost” type=”float”/>
           <directMappingField name=”root_currency_code” type=”char” size=”20”/>
           <directMappingField name=”sysmodcount” type=”float”/>
           <directMappingField name=”sysmoduser” type=”char” size=”60”/>
           <directMappingField name=”sysmodtime” type=”date”/>
         </directMappingFields>
         <directMappingIndexes>
           <directMappingIndex name=”UNIQSLAMONTHLY_IDX”>
             <DirectMappingIndexKey fieldName=”agreement_id” 
srcFieldName=”''agreement.id''” srctype=”FLOAT” seqIndex=”1”/>
             <DirectMappingIndexKey fieldName=”logical_name” 
srcFieldName=”''logical.name''” srctype=”CHAR” size=”60” seqIndex=”2”/>
             <DirectMappingIndexKey fieldName=”year” srcFieldName=”year” srctype=”FLOAT” 
seqIndex=”3”/>
             <DirectMappingIndexKey fieldName=”month” srcFieldName=”month” srctype=”FLOAT” 
seqIndex=”4”/>
           </directMappingIndex> 
         </directMappingIndexes>
       </directMapping>

<!-- ==========================================================================
SLA - This table has been replaced in the RDS with the Dimension table SLARESPONSED_D.
The deletedata tag notifies the migration program to remove all data (from older versions)
=========================================================================== -->
       <directMapping name=”slaresponse” rdsVersion=”5.1” attributeAction=”deletedata” 
dataSourceTableName=”slaresponse”>
         <directMappingFields>
           <directMappingField name=”record_id” type=”float”/>
           <directMappingField name=”agreement_id” type=”float”/>
           <directMappingField name=”response_name” type=”char” size=”60”/>
           <directMappingField name=”month” type=”float”/>
           <directMappingField name=”year” type=”float”/>
           <directMappingField name=”mean” type=”float”/>
           <directMappingField name=”median” type=”float”/>
           <directMappingField name=”deviation” type=”float”/>
           <directMappingField name=”weighted” type=”float”/>
           <directMappingField name=”perhit” type=”float”/>
           <directMappingField name=”sysmodcount” type=”float”/>
           <directMappingField name=”sysmoduser” type=”char” size=”60”/>
           <directMappingField name=”sysmodtime” type=”date”/>
         </directMappingFields>
         <directMappingIndexes>
           <directMappingIndex name=”UNIQSLARESP_IDX”>
             <DirectMappingIndexKey fieldName=”agreement_id” 
srcFieldName=”''agreement.id''” srctype=”FLOAT” seqIndex=”1”/>
             <DirectMappingIndexKey fieldName=”response_name” 
srcFieldName=”''response.name''” srctype=”char” seqIndex=”2”/>
             <DirectMappingIndexKey fieldName=”year” srcFieldName=”year” srctype=”FLOAT” 
seqIndex=”3”/>
             <DirectMappingIndexKey fieldName=”month” srcFieldName=”month” srctype=”FLOAT” 
seqIndex=”4”/>
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           </directMappingIndex> 
         </directMappingIndexes>
       </directMapping>

<!-- ==========================================================================
SLADIRECT - This replaces the old Dimension table SLA_D. The importance of the SLA table is
diminished in SC 6.1 and later.
=========================================================================== -->
       <directMapping name=”SLADIRECT” rdsVersion=”5.2.1” dataSourceTableName=”sla” 
attributeAction=”add”>
         <directMappingFields>
           <directMappingField name=”AGREEMENT_ID” type=”float”/>                   
           <directMappingField name=”TITLE” type=”char” size=”100”/>
           <directMappingField name=”EXPIRATION” type=”date”/>                     
           <directMappingField name=”SERVICE_HOURS” type=”char” size=”80”/>
           <directMappingField name=”SYSMODCOUNT” type=”float”/>                   
           <directMappingField name=”SYSMODUSER” type=”char” size=”60”/>
           <directMappingField name=”SYSMODTIME” type=”date”/>                     
           <directMappingField name=”DESCRIPTION” type=”long”/>
           <directMappingField name=”START” type=”date”/>                     
           <directMappingField name=”CUSTOMER” type=”char” size=”100”/>
           <directMappingField name=”SERVICE_CONTRACT” type=”float”/>                   
           <directMappingField name=”AGREEMENTS” type=”char” size=”100”/>
         </directMappingFields>
         <directMappingIndexes>
           <directMappingIndex name=”UNIQSLA_IDX”>
             <DirectMappingIndexKey fieldName=”AGREEMENT_ID” 
srcFieldName=”''agreement.id''” srctype=”FLOAT” seqIndex=”1”/>
           </directMappingIndex> 
         </directMappingIndexes>
       </directMapping>

Changes to the XML File for Adding Custom Structures

The following table contains tags that the XML file uses only for migration. When you add or 
change tables after you run the rds_init utility, you can use these tags to avoid deleting 
tables and data. 

The attributeAction tags:

• Include add, deletedata, historical, update, and updatewithfact values at the table 
level.

• Include the add value at the column level.

Table 19 Valid attributeAction Tags

attributeAction Tag Description

Add Creates a new table with fields specified in rds_etl.xml 
file.

Deletedata Deletes all records in the table.

Historical Marks all records to be historical.

Update Updates table with new fields and creates unique keys. Does 
not recreate the associated fact tables.

Updatewithfact Updates table with new fields and creates unique keys. 
Recreates the associated fact tables.
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• Are not available for fact or associate tables.

• Require the update value when you need to change a unique key for a table.

• Do not support attributeAction=”delete”.

• Add SQL exception entries to the rds_etl_migrate.log file. If you find entries in the 
rds_etl_migrate.err file, the migration is not complete. The only way to recover is to 
restore from your backup file and start the migration process again.

• Require the updatedwithfact value when you update a dimension table and add a new 
associated fact table.

Changes to the Connect-It Scenario for ServiceCenter 6.1 Support

The new structures needed to support ServiceCenter 6.1 required several changes to the 
Connect-It scenario. If you customized your scenario, you must merge the changes with your 
modified scenario.

Table 20 Scenario Changes

 Change Type Affected Table Change

Modified Document INCIDENT Added fields:
• ESS_ENTRY

• CALLBACK_BEEPER 
• CALLBACK_CONTACT 
• CALLBACK_EMAIL 
• CALLBACK_PHONE 
• FIRST_TOUCH 
• OTHER 

Modified Document PROBSUMM  Added fields:

• PROB_MGMT_CANDIDATE 

• ESS_ENTRY 

Modified Document CM3R Added fields:

• CI_DOWN 
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Modified Document CM3T Added fields:
<ATTRIBUTE Name=”parent.change” Type=”String”/>
    <COLLECTION Name=”parts”>
      <ATTRIBUTE Name=”date” Type=”Timestamp”/>
      <ATTRIBUTE Name=”part.gl.number” 
Type=”String”/>
      <ATTRIBUTE Name=”part.no” Type=”String”/>
      <ATTRIBUTE Name=”quantity” Type=”Double”/>
    </COLLECTION>

Removed:
<COLLECTION Name=”parts”>
       <ATTRIBUTE Name=”date” Type=”Timestamp”/>
       <ATTRIBUTE Name=”part.gl.number” 
Type=”String”/>
       <ATTRIBUTE Name=”part.no” Type=”String”/>
       <ATTRIBUTE Name=”quantity” Type=”Double”/>
     </COLLECTION>

Modified Document CMETCATPHASE Added fields: 

• sysmodcount 
• sysmodtime 
• sysmoduser 

Modified Document SERVICEREVIEWS Added fields: 

• contract.id 

• contract.name 

• review.date 

• service.review.id 

• technical.account.manager 

• sysmodcount 

• sysmodtime 

• sysmoduser 

Table 20 Scenario Changes

 Change Type Affected Table Change
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Changes to the Business Objects Universe for SC 6.1 Support

New structures needed to support the Problem Management and Service Level Management 
modules in ServiceCenter 6.1 required several changes to the Business Objects universe.

Modified Document DEPT Added fields:

<STRUCTURE Name=”parentCompany”>
        <ATTRIBUTE Name=”default.sla” 
Type=”Double”/>
        <ATTRIBUTE Name=”sla.no” Type=”String”/>
      </STRUCTURE>
      <STRUCTURE Name=”defaultAgreement”>
        <ATTRIBUTE Name=”enable” Type=”Byte”/>
        <ATTRIBUTE Name=”default.sla” 
Type=”Double”/>
      </STRUCTURE>

Modified Document SLO Added fields: 

<ATTRIBUTE Name=”condition” Type=”String”/>
<dimensionTableField name=”CONDITION” type=”char” 
size=”254”/>

Added Document OUTAGEEVENT  Added fields:
• outageevent 
• ci.name 

• outage.id 
• record.tag 
• sysmodtime 
• sysmoduser 

Table 20 Scenario Changes

 Change Type Affected Table Change
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Problem Management Structure

The following diagram shows the new Problem Management structure.
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Service Level Management Structure

The following diagram shows the new Service Level Management structure.
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A DecisionCenter Analytics Questionnaire
By completing this questionnaire, you can optimize your DecisionCenter Analytics 
implementation plan.

Schema Implementation

1 Is the ServiceCenter schema upgraded as ServiceCenter 5.1?

2 What are the record numbers for ServiceCenter files, such as probsummary, incidents, 
devices, cm3r and cm3t?

3 Every day, what are the updates activity volumes for ServiceCenter files, such as 
probsummary (incident management), incidents (service management), devices 
(inventory management), cm3r and cm3t (change management)?

4 What is the database size if ServiceCenter uses the external RDBMS database?

5 Based on the data warehouse schema XML definition file, compared to your ServiceCenter 
schema, what are the differences, such as how many files are different, how many 
attributes are different and how many new files are needed to add in?

6 Are the unique keys the same as data warehouse default unique keys?

7 Are the Slowly Changing Dimension (SCD) fields (fields need to have historical 
preservation) same as default dimension SCD keys?

8 Are the aggregation fields same as the default data warehouse dimension aggregate keys?

9 Are the association relationships the same as the default data warehouse associates?

10 Are the hierarchy fields the same as data warehouse hierarchy tables' definition?

11 When is your ServiceCenter offline? 

12 Is the daily-based synchronization interval defined for data warehouse data 
synchronization good enough for your reports users? If not, what synchronization 
intervals do you expect?

Data Warehouse Universe Customization

1 How many new tables must you add to the data warehouse universe?

2 How many relationships must you add to the data warehouse universe?

3 How many new query objects must you add to the data warehouse universe?

4 Do you have pre-defined hierarchies of slice-dice drill paths for ServiceCenter Service 
Management, Configuration Management, Incident Management, and Change 
Management?
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5 Can you provide the top five ad hoc queries content?

Customization Reports

1 Are the canned reports from DecisionCenter Analytics sufficient for the initial 
deployment?

2 If not, what are your top three customized reports content?

3 Do you have the corporate customized reports templates or layout standards?

Installation and Configuration

1 What is your operating system for DecisionCenter servers? You can deploy only the 
DecisionCenter server module to a non-Windows operating system.

2 What is the database management system—Oracle, SQL Server?

3 What is your application server and your Web server? 

4 Is your test environment the same as the production environment?

5 How many maximum concurrent DecisionCenter reporting users do you have?

6 Is your DecisionCenter deployment based on single-server deployment or multiple-server 
deployment?

7 If you use a multiple-server deployment, how many servers do you use for DecisionCenter 
server modules? DecisionCenter has three server components: DecisionCenter server, the 
data warehouse server, and the database server.

8 What are your servers' hardware conditions, including database server?

9 Do you have other HP OpenView applications deployed on the same portal server?

10 Do you have Business Objects products deployed in your corporation? If so, what versions 
are they?
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B Dimension Table Sample File
You can use the code in the following testdim.xml file as a sample to create a new dimension 
table. 

<?xml version=”1.0”?>
<!-- edited with XML Spy v4.3 U (http://www.xmlspy.com) by Hewlett-Packard Development 
Company (HP) -->
<rds xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance” 
xsi:noNamespaceSchemaLocation=”C:\BI_Development\JAXB_ETL_1.2\rds_etl.xsd”>
<!-- testdim.xml example -->
<dimensions>

    <dimension name=”CUSTOMEDIM1” rdsVersion=”5.1”>
      <dimensionTableName>
        CUSTOMEDIM1_D
      </dimensionTableName>
      <dataSourceTableName>
        customdim
      </dataSourceTableName>
      <dimensionTableFields>
        <dimensionTableField name=”CUSTOMEDIM_filed1” type=”char” size=”60”/>
        <dimensionTableField name=”name” type=”char” size=”60”/>
        <dimensionTableField name=”Printer” type=”char” size=”60”/>
        <dimensionTableField name=”application_name” type=”char” size=”80”/>
        <dimensionTableField name=”full_name” type=”char” size=”60”/>
        <dimensionTableField name=”msglog_lvl” type=”float”/>
        <dimensionTableField name=”logoff_parm” type=”char” size=”1”/>
        <dimensionTableField name=”password_date” type=”date”/>
        <dimensionTableField name=”priority” type=”float”/>
        <dimensionTableField name=”room” type=”char” size=”60”/>
        <dimensionTableField name=”department” type=”char” size=”60”/>
        <dimensionTableField name=”multi_login” type=”char” size=”1”/>
        <dimensionTableField name=”graphics_printer” type=”char” size=”60”/>
        <dimensionTableField name=”pm_time_limit” type=”float”/>
        <dimensionTableField name=”cm_time_limit” type=”float”/>
        <dimensionTableField name=”phone” type=”char” size=”60”/>
        <dimensionTableField name=”beeper” type=”char” size=”60”/>
        <dimensionTableField name=”time_zone” type=”char” size=”60”/>
        <dimensionTableField name=”date_order” type=”float”/>
        <dimensionTableField name=”change_mgr_group” type=”char” size=”60”/>
        <dimensionTableField name=”authcode” type=”float”/>
        <dimensionTableField name=”message_flag” type=”char” size=”1”/>
        <dimensionTableField name=”message_count” type=”float”/>
        <dimensionTableField name=”external_flag” type=”char” size=”1”/>
        <dimensionTableField name=”nodeid” type=”char” size=”60”/>
        <dimensionTableField name=”authorid” type=”char” size=”60”/>
        <dimensionTableField name=”profsflag” type=”char” size=”1”/>
        <dimensionTableField name=”db_time_limit” type=”float”/>
        <dimensionTableField name=”email” type=”char” size=”70”/>
        <dimensionTableField name=”max_logins” type=”float”/>
        <dimensionTableField name=”last_update” type=”date”/>
        <dimensionTableField name=”last_login” type=”date”/>
        <dimensionTableField name=”fax” type=”char” size=”60”/>
        <dimensionTableField name=”password_errors” type=”float”/>
        <dimensionTableField name=”login_revoked” type=”char” size=”1”/>
        <dimensionTableField name=”beeper_type” type=”char” size=”60”/>
        <dimensionTableField name=”beeper_name” type=”char” size=”60”/>
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        <dimensionTableField name=”beeper_group” type=”char” size=”60”/>
        <dimensionTableField name=”manager” type=”char” size=”60”/>
        <dimensionTableField name=”pager_pin” type=”char” size=”60”/>
        <dimensionTableField name=”pager_vendor” type=”char” size=”60”/>
        <dimensionTableField name=”voice_mailbox” type=”char” size=”60”/>
        <dimensionTableField name=”page_response” type=”char” size=”1”/>
        <dimensionTableField name=”casual_user” type=”char” size=”1”/>
        <dimensionTableField name=”wdUD1” type=”float”/>
        <dimensionTableField name=”wdUD2” type=”float”/>
        <dimensionTableField name=”wdResType” type=”float”/>
        <dimensionTableField name=”wdResTimeStamp” type=”float”/>
        <dimensionTableField name=”sc_manager” type=”char” size=”30”/>
        <dimensionTableField name=”lines_per_page” type=”float”/>
        <dimensionTableField name=”max_line_width” type=”float”/>
        <dimensionTableField name=”print_header” type=”char” size=”60”/>
        <dimensionTableField name=”syslanguage” type=”char” size=”60”/>
        <dimensionTableField name=”rate_hour” type=”float”/>
        <dimensionTableField name=”rate_currency_code” type=”char” size=”80”/>
        <dimensionTableField name=”display_currency_code” type=”char” size=”80”/>
        <dimensionTableField name=”wdIsReadOnlyView” type=”char” size=”1”/>
        <dimensionTableField name=”wdMailBoxName” type=”char” size=”60”/>
        <dimensionTableField name=”sysmodcount” type=”float”/>
        <dimensionTableField name=”sysmoduser” type=”char” size=”60”/>
        <dimensionTableField name=”sysmodtime” type=”date”/>
        <dimensionTableField name=”ldapauthbase” type=”char” size=”40”/>
        <dimensionTableField name=”systemplate” type=”char” size=”40”/>
        <dimensionTableField name=”max_attach_size” type=”float”/>
        <dimensionTableField name=”named_user” type=”char” size=”1”/>
        <dimensionTableField name=”company” type=”char” size=”60”/>
        <dimensionTableField name=”no_force_termination” type=”char” size=”1”/>
        <dimensionTableField name=”set_user_from” type=”char” size=”30”/>
        <dimensionTableField name=”profile_service” type=”char” size=”50”/>
        <dimensionTableField name=”profile_incident” type=”char” size=”50”/>
        <dimensionTableField name=”profile_rootcause” type=”char” size=”50”/>
        <dimensionTableField name=”profile_inventory” type=”char” size=”50”/>
        <dimensionTableField name=”user_role” type=”char” size=”50”/>
        <dimensionTableField name=”man_lockout_user” type=”char” size=”1”/>
        <dimensionTableField name=”user_login_count” type=”float”/>
        <dimensionTableField name=”reset_by” type=”char” size=”40”/>
        <dimensionTableField name=”locked_until” type=”date”/>
        <dimensionTableField name=”locked_reason” type=”float”/>
        <dimensionTableField name=”no_lock_user” type=”char” size=”1”/>
        <dimensionTableField name=”do_password_reset” type=”char” size=”1”/>
        <dimensionTableField name=”expire_password” type=”char” size=”1”/>
        <dimensionTableField name=”gl_number” type=”char” size=”30”/>
        <dimensionTableField name=”assignment_groups” type=”long”/>
        <dimensionTableField name=”cap_exec” type=”long”/>
        <dimensionTableField name=”change_groups” type=”long”/>
        <dimensionTableField name=”change_approvals” type=”long”/>
        <dimensionTableField name=”email_events” type=”long”/>
        <dimensionTableField name=”groups” type=”long”/>
        <dimensionTableField name=”month_ext” type=”long”/>
        <dimensionTableField name=”month_abv” type=”long”/>
        <dimensionTableField name=”names” type=”long”/>
        <dimensionTableField name=”pm_groups” type=”long”/>
        <dimensionTableField name=”profile_change” type=”long”/>
        <dimensionTableField name=”profile_request” type=”long”/>
        <dimensionTableField name=”security_group” type=”long”/>
        <dimensionTableField name=”values” type=”long”/>
        <!-- SC 5.1 new attributes -->
        <dimensionTableField name=”command” type=”float”/>
        <dimensionTableField name=”profile_contract” type=”char” size=”30”/>
      </dimensionTableFields>
      <uniqueKeys name=”CUSTOMEDIM1_unique”>
        <uniqueKey fieldName=”name” srcFieldName=”name” srctype=”char” size=”60” 
defaultValue=”no match”/>
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      </uniqueKeys>
      <facts/>
      <scdKeys/>
      <aggregateKeys/>
    </dimension>
</dimensions>
<associates/>
<hierarchies/>
<directMappings/>

</rds>
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C Direct Mapping Table Sample File
You can use the code in the following testdirect.xml file as a sample to create a new direct 
mapping table.

<?xml version=”1.0”?>
<!-- edited with XML Spy v4.3 U (http://www.xmlspy.com) by Hewlett-Packard Development 
Company (HP) -->
<rds xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance” 
xsi:noNamespaceSchemaLocation=”C:\BI_Development\JAXB_ETL_1.2\rds_etl.xsd”>
<!-- testdirect.xml example -->
<dimensions/>
<associates/>
<hierarchies/>
<directMappings>

    <directMapping name=”C_DMTABLE” rdsVersion=”5.1” dataSourceTableName=”sc_dmtable”>
      <directMappingFields>
        <directMappingField name=”logical_name” type=”char” size=”50”/>
        <directMappingField name=”field2” type=”char” size=”120”/>
        <directMappingField name=”field3” type=”char” size=”120”/>
        <directMappingField name=”field4” type=”char” size=”120”/>
        <directMappingField name=”Z_RDSLASTMODDATE” type=”date”/>
      </directMappingFields>
      <directMappingIndexes>
        <directMappingIndex name=”UNIQC_DMTABLE_IDX”>
          <DirectMappingIndexKey fieldName=”logical_name” srcFieldName=”''logical.name''” 
srctype=”char” size=”50”/>
        </directMappingIndex>
      </directMappingIndexes>
    </directMapping>
</directMappings>

</rds>
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D Data Warehouse AssetCenter ERD
This Entity Relationship Diagram (ERD) shows how HP OpenView AssetCenter tables in the 
data warehouse relate to each other.
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E ETL Processes
Based on the data warehouse dimensional modeling techniques, the following scenarios 
include all the possible fact table Extract, Transform, and Load (ETL) processes. Bold text 
indicates changes to the DecisionCenter Analytics implementation.

Dimension Table and Referenced Dimension Table Changes

When changes to dimension tables occur in ServiceCenter, the ETL process makes changes to 
the data warehouse.

Table 21 Changes to Dimension Tables

ServiceCenter Activity ETL Activity

Main dimension 
table change

• Creates a new line item such as 
incident or portfolio

• Updates the existing line item

• Updates the existing Slowly 
Changing Dimension (SCD) line item

• Marks the existing line item as 
deleted

• Adds a new fact record

• Updates the matched fact record 
only when you change the 
dimensional foreign keys or 
measurements

• Updates the matched fact records 
main foreign key from the old key 
to the new SCD3 key

• Marks the matched fact record as 
obsolete

Referenced 
dimension table 
changes

• Creates a new record in the 
referenced dimension tables 

• Updates existing referenced 
dimensional records

• Updates existing referenced 
dimensional SCD records

• Deletes existing referenced 
dimensional records 

• Makes no changes in the fact table

• Makes no changes in the fact tables

• Updates all the related fact 
records and related dimensional 
foreign key with the new 
surrogate keys

• Makes no changes in the fact tables
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Universe Filter Conditions for Query or Reporting 

The universe has filters that all reports use. The fact and dimensional tables use the following 
filters:

• The fact table is not obsolete.

• Dimensional foreign keys are greater than 5 (>= 5).

• Referenced dimensions include obsolete records. 
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