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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 1993-2006 Hewlett-Packard Development Company, L.P.

Trademark Notices

Microsoft®, Windows®, Windows NT®, and Windows® XP are U.S. registered trademarks of Microsoft 
Corporation.

Java™ is a US trademark of Sun Microsystems, Inc. 

UNIX® is a registered trademark of The Open Group. 
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Support

Peregrine Product Support

You can obtain support information for products formerly produced by Peregrine as follows:

• If you work with an HP OpenView Services Integrator (SVI) partner (www.hp.com/managementsoftware/
svi_partner_list), contact your SVI agent.

• If you have an active HP OpenView support contract, visit the HP OpenView Support site and use the 
Self-Solve Knowledge Search to find answers to technical questions.

• For the latest information about support processes and tools available for products formerly produced by 
Peregrine, we encourage you to visit the HP-Peregrine Software Support web site at: www.hp.com/
managementsoftware/peregrine_support where you can download the Customer Support Handbook.

• Contact your HP Sales Representative if you have additional questions.

HP OpenView Support

You can visit the HP OpenView Support web site at:
www.hp.com/managementsoftware/support

HP OpenView online support provides an efficient way to access interactive technical support tools. As a 
valued support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract. To find more information about access levels, go to:

www.hp.com/managementsoftware/access_level

To register for an HP Passport ID, go to:
www.managementsoftware.hp.com/passport-registration.html
3
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1 Introduction
Welcome to the Network Data Analysis Guide. 

HP OpenView Enterprise DiscoveryTM collects a lot of different data from your network 
devices. This guide will help you understand how to read the data collected by Enterprise 
Discovery’s discovery features. 

For information on data collected by Enterprise Discovery scanners, refer to the Scan Data 
Analysis Guide. 

This guide provides information on the following topics:

• Finding your Network Devices on page 11

• Using the Network Map on page 21

• Using the Service Analyzer on page 47

• Using the Health Panel and Alarms Viewer on page 51

• Using the Events Browser on page 57

• Using the Device Manager on page 65

• Using the Port Manager on page 85

• Using the Attribute Manager on page 101

• Using the MIB Browser on page 105

• Using the Scan Data Viewer on page 115

• Using the Reports on page 123
  9
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2 Finding your Network Devices
The Find command lets you locate and examine any device on the network. There are many 
ways to search for a particular device, based on its DNS name, IP address, MAC address, and 
so on. 

There is also an Aggregate Find feature that will let you search for devices across all of your 
aggregated Enterprise Discovery servers. The Aggregate Find is almost identical to the 
regular Find, but the Aggregate Find has fewer search options. 

How to Find Your Devices

There are six Find modes. 

Table 1 Types of Find

Name Why use it?

Easy Find This option is a “catch-all” that should be good for most searches. 
Read more details about it in Easy Find on page 13. 
Note: Not available with Aggregator Find. 

Basic Match A Basic match allows you to perform a search based on various device 
attributes.

Asset Match An Asset match allows you to perform a search based on asset data 
collected.

IP Address Find a device with a specific IP address. 

MAC Address Find a device with a specific MAC address. 

DNS Query Do a DNS Query on a specific domain name. 
Note: Not available with Aggregator Find. 
  11



Finding devices

To use the Find tool:

1 Open the Find tool:

2 By default, you can use the Easy Find feature (go to step 6). If you want to do a more 
advanced find, continue with the next step in this procedure.

3 In the first pull-down list, select the Find mode you want to use to perform the search (for 
example, “Asset Match”).

4 In the second pull-down list, select the device data you want to search on (for example, 
“NetBIOS Name”).

5 In the third pull-down list, select a match mode (for example, “containing”). (For 
explanation of these match modes, see Advanced Find on page 20).

6 Enter a match value.

7 Press Enter or click Go. 

Table 2 Opening Find

From Click

Navigation Tree Find

Health Panel, Network Map, Alarms 
Viewer, Events Browser, MIB 
Browser, or Service Analyzer

Tools > Find

When using Easy Find, enter the first letters of a title or the first numbers of an 
address to find multiple devices in the Enterprise Discovery database.
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Enterprise Discovery searches for the device. The results of the search appear in table format, 
and you can select the device you want to open. You can double-click (or right-click) to open a 
Device Manager or Port Manager.

Easy Find

When you enter text into the Find box, Enterprise Discovery searches the network in the 
following order. 

Select the Find 
mode

Select a match 
mode

Select the 
device data

If there is no result at one stage, Enterprise Discovery will try the next.
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Example: Once an IP address has been found, Enterprise Discovery does not search domain 
names and device titles.

Table 3 Internal Search Order for the Easy Find

Find Method Explanation

“localhost” or “nmc” These are two shortcuts for finding the Enterprise 
Discovery server. 

MAC address Enterprise Discovery will try to search based on the 
known MAC address. 
Note: To find a specific device, you must enter its 
complete MAC address in one of these formats: 
12:AB:34:CD:56:EF or 12AB34CD56EF.

IPv4 or IPv6 
address

Enterprise Discovery will try to search based on the 
known IP address (IPv4 or IPv6). 
Note: To find a specific device, you must enter its 
complete IP address. 

Domain Name Enterprise Discovery searches based on the DNS 
suffix as configured in your server DNS (done in 
Control Panel).

Device Title Enterprise Discovery will then search the network 
based on your device title preferences from 
Administration > System Configuration > Display 
preferences > Device title preference. Only the selected 
titles are searched. 

Asset Tag Even if Asset Tag is not listed in your Device title 
preference, Enterprise Discovery will search for it 
next.

NetBIOS Name Even if NetBIOS name is not listed in your Device title 
preference, Enterprise Discovery will search for it 
next.

Multiple results are based only on the device title. Example: If you enter “192.168.2.”, you will 
not find all devices 192.168.2.0–192.168.2.255. You will only find devices with “192.168.2.” in 
the title. If the device with IP address 198.168.2.55 takes its title from its domain name, that 
device will not be found. 

When using the Easy Find, it may take several seconds to get a response, especially on a large 
network. 
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Basic Match

Table 4 Basic Match

Name Why use it? Examples

Device Title Find a device when you know the name, 
but not necessarily the type of device. 

172.22.5.5
anydevice.example.com

Device Tag Find a device with a specific device tag. 
A device tag is a short descriptive string 
assigned to this type of device. 
You can also enter a partial device tag 
to find several devices with similar 
numbers.

VMware or Microsoft

Domain Name Find a device with a specific domain 
name. 

anydevice.example.com
hp.com

NetBIOS Name Find a device with a specific NetBIOS 
name. 

NT4WORKQA
mymachine

NetBIOS 
Workgroup

Find a device within a specific NetBIOS 
workgroup. 

QA_SAN_DIEGO
ACTIVE

Family Find a device within a specific family. Cisco 2600 Series Modular 
Access Routers
WaveSwitch 1000 Series 
Workgroup Switch

Model Find a device of a specific model. IBM xSeries 330 (867411X)
Cisco Intelligent Gigabit 
Ethernet Switch Module 
(IGESM)

Operating System Find a device with a specific operating 
system. 

Linux
HP-UX 10.20

Network Function Find a device which serves a specific 
network function. 

router

SNMP Description Find a device with a specific description 
in the SNMP MIB. 

Linux Virtual Gateway
3Com SuperStack II

SNMP Contact Find a device with a specific contact in 
the SNMP MIB. 

Kevin
IT Manager
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Asset Match

An Asset match allows you to perform a search based on asset data collected. It includes 
details about users, departments, physical assets, equipment, and any other information that 
is useful to record.

There are three methods of collecting asset data: Scanner, Bulk import, Web Asset 
Questionnaire (WAQ). One or multiple methods can be used for a device but the order of 
priority is as follows:

• Web Asset Questionnaire

• Bulk import

• Scanner

When you perform a Find query, the search query will look at all three levels in the priority 
order.

For example, a device may be picked based on the AssetTag collected by the Scanner if the 
value matches and there is no AssetTag collected through either the WAQ or bulk import.

The resultant value is always the one collected by the method with the highest priority.

SNMP Name Find a device with a specific name in 
the SNMP MIB. 

Demo Server
manager.example.com

SNMP Location Find a device with a specific location in 
the SNMP MIB. 

server room
QA LAB

SNMP Serial 
Number

Find a device with a specific serial 
number in the SNMP MIB. 

12345ABCDE

Table 4 Basic Match

Name Why use it? Examples

Table 5 Asset Match

Name Why use it? Examples

Description Find a device from the Description line 
that contains a brief description of the 
asset.

Development Machine

Asset Tag Find a device with a specific asset tag. 
The Asset Tag field contains a unique 
identifier for the machine. 
You can also enter a partial asset tag to 
find several devices with similar 
numbers. 

EXAMPLE123456
123456

Employee ID Find devices from a specific Employee 
ID as used in the organization.

FINANCE3746
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Last Name Find devices with a specific last name of 
user

SMITH

Full Name Find devices with a specific full name of 
user

JOHN SMITH

Job Title Find devices with a specific job title of 
user

IT Manager

Cost Center Find devices with a specific cost center 
description or code

Business Unit Find devices with a specific name of 
business unit

Division Find devices with a specific division 
description or code

Department Find devices with a specific department 
description or code

IT32

Section Find devices with a specific section 
description or code

Office Location Find devices with a specific location of 
office.

UKRichmond

Building Find devices from the building 
containing the machine

RICHMOND

Floor Find devices with a specific floor on 
which the machine is located

first

Room Find devices with a specific description, 
name or number of the room containing 
the machine

Room5

Bar Code Find a device with a specific bar code. 

Telephone 
Extension

Find devices with a specific internal 
telephone extension

3256

Telephone Number Find devices with a specific full direct 
telephone number of user

020 8956 5569

Cellphone Number Find devices with a specific cell/mobile 
phone number of user

07285692658

Printer Description Find devices with a specific description 
of a local printer attached to the 
machine, if any

FinancePrinter

Printer Asset Tag Find devices with a specific from the 
Asset tag of a local printer attached to 
the machine, if any

FinancePrinter1234

Table 5 Asset Match

Name Why use it? Examples
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IP Address

This works only for IP address and MAC address searches. You must enter an entire IP or 
MAC address in these formats:

• IP - 123.123.123.123

• MAC - 12:AB:34:CD:56:EF

Note: You can substitute a * for an octet in an IP address octet or a segment of a MAC address. 
For example: “123.*.123.123” or 12:AB:*:CD:56:EF
Note: For MAC addresses, you can compress the zeros in each segment. For example, you can 
enter “5” instead of “05” for a segment. 

Machine Make Find devices with a specific Make or 
Manufacturer of the machine. This data 
is automatically collected on machines 
supporting SMBIOS

HP

Machine Model Find devices from the Model of the 
machine. This data is automatically 
collected on machines supporting 
SMBIOS

Device Type Find devices from the Device type of the 
machine.

Server, Notebook, Tower

User field 29 User field 29 is the default label for a 
user defined field. 
When the field is configured in the User 
Interface, the field is given a 
meaningful name.
The user defined fields will show in the 
Asset Match list only if a custom label 
is being used for a field.

Table 5 Asset Match

Name Why use it? Examples

Table 6 IP Address

Name Why use it? Examples

IP Address Find a device with a specific IP 
address. 
Note: You must enter a complete 
IP address. You can use 
asterisks (*) to find multiple 
devices. 

172.22.5.5
172.*.*.255
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Note: If an IP or MAC address is associated with a port, you will see a port listed in your Find 
results. 

MAC Address

This works only for IP address and MAC address searches. You must enter an entire IP or 
MAC address in these formats:

• IP - 123.123.123.123

• MAC - 12:AB:34:CD:56:EF

Note: You can substitute a * for an octet in an IP address octet or a segment of a MAC address. 
For example: “123.*.123.123” or 12:AB:*:CD:56:EF
Note: For MAC addresses, you can compress the zeros in each segment. For example, you can 
enter “5” instead of “05” for a segment. 

Note: If an IP or MAC address is associated with a port, you will see a port listed in your Find 
results. 

DNS Query

Table 7 MAC Address

Name Why use it? Examples

MAC Address Find a device with a specific 
MAC address. 
Note: You must enter a complete 
MAC address. You can use 
asterisks (*) to find multiple 
devices. 

12:AB:34:CD:56:EF 
12:*:34:*:56:EF 
12AB34CD56EF

Table 8 DNS Query

Name Why use it? Examples

DNS Query Do a DNS Query on a specific 
domain name. 
Note: Not available with 
Aggregator Find. 

www.hp.com
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Advanced Find

For each advanced find option described above, there are different match modes that will help 
your search. These modes are described in the following table. 

Searches are not case-sensitive.

Table 9 Advanced Find

Match Modes Notes

containing —

beginning with —

ending with —

equal to —

matching ?* Wildcard characters:

• “?” can represent any single character. For 
example, “gr?y” finds “gray” and “grey.”

• “*” can find multiple characters. For 
example, “E*t” finds “Ethernet.”

matching regex Matching a regular expression. 
Note: For some examples of regular expressions, 
see the Analysis Workbench chapter in the Scan 
Data Analysis Guide. 
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3 Using the Network Map
You can only use the Network Map if you have an Enterprise Discovery topology license. 

The Network Map gives you a graphical view of your network, using icons and lines the 
represent the devices in your network and their connectivity. 

There are many ways to change how you view the map. You can change how layout, and many 
look-and-feel features. You can even save different layouts (configuration files) in case you 
want to look at the network in different ways. 

This chapter will start off by explaining what you first see on the map (icons, lines), and then 
get into details about how to change the map. 

In this chapter, you will find information on the following topics:

• How does the map work? on page 22

• What are the icons on the map? on page 23

• Customizing Your View of the Network Map on page 27

• Changing the map background image on page 31

• Managing your background image library on page 32

• Packaging Your Network on page 32

• Organizing Map Configuration Files on page 39

• Saving a map window as a graphic file on page 45

The map is generated automatically based on the data gathered through the discovery 
process. If the source data is reliable, the map will accurately represent your network. There 
may be cases where information is not available for certain devices or connections. In these 
cases, Enterprise Discovery will make its best “guess” about connectivity. 
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How does the map work?

To determine what the Map will display, select an alarm category on the Health Panel or 
Alarms Viewer, or click the alarm list on the map status bar. 

The colored ring around an icon indicates the device’s status for the category you select. For 
example, if you select Device Adds/Deletes, any devices that were recently added will have 
green rings.

Status Bar

The Status Bar appears at the top of every map window. It displays information about the 
window contents, and allows you to change the window display.

The following graphic shows the Status Bar. The table below the graphic explains the features 
available on the Status Bar.

To show rings, the objects must be within the priority range as selected on the map status bar, 
Health Panel, or Alarms Viewer. (Information about setting device priorities is in the 
Configuration and Customization Guide.)

Devices and ports that do not have applicable attribute or report data will not have a ring (for 
example, virtual devices). 

device 
icon

package 
icon

Some parts of the Status Bar duplicate information available on the Health Panel. 
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What are the icons on the map? 

Devices and Packages

Enterprise Discovery tries to develop a realistic view of your network, and that view is 
represented with icons (representing a device or a group of devices) and lines that connect the 
devices. 

1 2 3 4 5 6 7 8 9 10 11

Table 1 Toolbar Legend

Number Name

1 package alarm state

2 object alarm state (if there are no object 
selected, this will be blank)

3 alarm type pull-down list

4 priority range pull-down list

5 map configuration file

6 map scale slider

7 map scale percentage in this window

8 number of devices in this package

9 Find a device

10 go up one level

11 connectivity (green = OK, red = no 
connection to server)
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The icons on the map fall into categories:

Enterprise Discovery selects device icons based on the data collected from that device. For 
example, if Enterprise Discovery sees that a device is a Microsoft Windows 2000 workstation, 
that device will appear on the map with a “Win2000 Workstation” icon. 

Virtual Devices

When Enterprise Discovery is unable to determine the exact physical, port-level connectivity 
between devices, it displays the connection with a virtual device icon representing the logical 
subnet. 

Enterprise Discovery creates two types of virtual devices: clouds and diamonds.

For more information on the real and virtual devices, see the Reference Guide.

You can see a complete list of all the icons used in Enterprise Discovery in Help > 
Classifications > Device Types/Package Types.

Table 2 Icon Categories

Icon Type Example Description

Device Icons Device icons represent the physical equipment in 
your network. 

Package 
Icons

A package is a collection of objects (objects means 
either devices or packages). 

Enterprise Discovery will usually select the correct device icon. If for some reason, the wrong 
icon has been selected, you can change it. See Customizing Your View of the Network Map on 
page 27.

Table 3 Virtual Devices

Icon Type Example Description

Cloud Clouds represent one or more devices or MAC 
systems that provide connectivity in the network. 

Diamond Diamonds do not represent actual network 
devices; they indicate connectivity. Sometimes, 
Enterprise Discovery knows that there is 
connectivity without being able to specify the 
devices. 
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The priority

In Enterprise Discovery, devices can have priorities 1–6. Devices with priority 1 are the least 
important. The higher the number, the higher the priority and greater the importance.

By default, priorities 5 and 6 are reserved for the user. By default, priority 6 is reserved for 
those devices that should trigger event notification—see the Event Filters chapter in the 
Configuration and Customization Guide.

Package icons group other icons together

Enterprise Discovery helps you organize and simplify your Network Map with packages. A 
package is a collection of objects (objects means either devices or packages) that is represented 
by an icon. You can double-click a package icon to open the package in its own window. There 
are two types of packages:

Any map window can contain packages. You can modify the contents of a package (selecting 
objects or groups of objects) exactly as you can in the Main Map. 

As with other icons, you will sometimes see package icons with colored rings around them 
(when you select an alarm type). The color of the ring around the package depends on the 
color of rings around objects inside the package. The ring around the package icon will match 
the most severe alarm of the devices in the package. 

For example, if there are Critical (red), Minor (gold) and Info (green) rings inside a package, 
the package will have a Critical (red) ring.

For more information on packaging, see Packaging Your Network on page 32. 

Table 4 Packages

Package Type Description Example

Automatic 
Package

These packages are 
automatically created by 
Enterprise Discovery. For 
more information on 
packaging, see Packaging Your 
Network on page 32. 

Multi-object 
Package

These packages are created by 
the user, and can contain any 
devices you wish to place in 
them. For more information on 
packaging, see Packaging Your 
Network on page 32.
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Icon Appearance

The following table shows a device icon in the possible states as it will appear on the Network 
Map. 

Table 5 Icon Appearance

Appearance What it means

Normal Icon
This is how a device icon will appear when:

• no alarms are selected

• an alarm has been selected but that type of 
alarm does not apply to this device

• an alarm has been selected but this device is 
not in the priority range

Colored Ring
A thin gray ring will appear around a device when:

• this device is in the priority range

• this device is not alarmed

A colored ring will appear around a device when:

• an alarm is selected that exists on this device

• this device is in the priority range

Faded Icon
If an object appears faded, that means Enterprise 
Discovery has not seen that device for more than 24 
hours. Enterprise Discovery will eventually 
deactivate such a device from the Network Map 
and, eventually, Enterprise Discovery will purge 
the device and all its associated data. 

Locked Icons
If you have manually packaged your map 
configuration, you will see many icons with a blue 
line beneath them, if you have selected the 
“Underline locked objects” option in Edit > User 
Preferences. The blue line indicates that the device 
has been manually packaged by a user, meaning it 
has been put inside a package (Package command), 
promoted from a package (Promote), or has had its 
package removed (Unpackage). 
Enterprise Discovery does create some automatic 
packages. They are created during discovery and 
whenever you use the Pack or the Unpack All 
commands. 
For more information on packaging, see Packaging 
Your Network on page 32.
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Customizing Your View of the Network Map

There are several ways you can change the look and feel of your Network Map. Your 
account-type determines the preferences and properties you are allowed to change.

All accounts can change preferences such as line style, background color, background image, 
and scale. 

Administrator or IT Manager users have the option of changing Device Properties such as 
device icon, device title, and so on (from the Network Map, click Device > Device Properties). 
These properties will affect all accounts.

Selected Icon
If you select an icon on the Network Map, it will 
appear dark. 

Found Icon
This icon was located on the Network Map using 
the Locate feature.
Note: For packages, the large yellow circle 
indicated that you have just left this package, as 
you are navigating through the Network Map. Also 
note that the package tag is a different color after 
you have been inside the package.

Deactivated or Hidden Icon
This device has been manually deactivated or 
hidden by an Admin account. It will disappear from 
the Network Map at the end of the next network 
poll cycle. 

Table 5 Icon Appearance

Appearance What it means
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Changing Map User Preferences

You can change the look of your Network Map in several ways. To open this dialog from the 
Network Map, click Edit > User Preferences. 

Table 6 Map Preferences

Preference Description

Line Style This option lets you choose which style of line to draw 
to connect objects in a Network Map window. You can 
change this setting from the default (straight) 
whenever you wish. 

Background This option lets you choose the background color for 
your map windows. 

Show pop-up info This option lets you choose whether an information 
box associated with an object or a line appears when 
you position the mouse pointer over an icon.

Underline locked 
objects

This option lets you choose if locked objects should be 
underlined in all map windows. Objects that are 
“locked” from a packaging status are shown with a 
blue line under the icon.
Typically, objects acquire locked status when they are 
packaged by a user. When an object is locked, 
Enterprise Discovery does not package or unpackage 
it automatically.

Confirm packaging 
commands

This option lets you choose if you will require 
confirmation when using packaging commands such 
as Layout, Make Top of the Network, Unpackage, Pack , 
Unpack, and Unpack All.
You receive a confirmation question that gives you 
time to reconsider what you are doing. You can turn 
confirmation messages off, if you wish.
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Placing an object at the top of the map window

When you are organizing a map window, you can assign one object to appear at the top of the 
window. This object should be of special significance in relation to the other objects in the 
window.

Enterprise Discovery may not have been running long enough to show the right device at the 
top of the map, or you may know a top-of-network router or a core device would make more 
sense. 

To place an object at the top of the map window:

1 Select an icon.

2 Click Configure > Top of Network.

A confirmation message appears.

3 Click Top of Network.

The window is redrawn with the selected icon at the top.

To reset the top object for the window to the default chosen by Enterprise Discovery:

1 Select the icon at the top of the map window.

The Top of Network command should have a check mark with it, indicating that you have 
previously chosen this object to be at the top of the window.

2 Click Configure > Top of Network.

Truncate object 
titles

This option lets you choose if you want to truncate 
object titles on your map. Sometimes, the object titles 
are very long, and Enterprise Discovery will 
automatically truncate them to save space on the 
map. If you would rather have the full object name 
appear on the map, you can change it. 

Scale This option lets you choose the scale for all map 
windows. 
Also, the scale slider appears on every map window. 
You can click this and change the scale to from as 
small as 1% up to 200%. You can also type in a 
number into the text box, and hit Enter on your 
keyboard to initiate the change. 
You can also use the Zoom In and Zoom Out commands 
to change the scale of one map window at a time. 

Open Health Panel 
with Network Map

This option lets you choose if the Health Panel will 
automatically be opened when you click open the 
Network Map. 
Note: This setting does not affect the Aggregate 
Health Panel.

Table 6 Map Preferences

Preference Description

This preference will affect the current map configuration file.
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A confirmation message appears.

3 Click Top of Network.

The window is redrawn with the default icon at the top, as chosen by Enterprise Discovery.

Layout

The Layout command reorganizes the layout of the active map window, then redraws the 
window. Use it to tidy a map with confusing layout and crisscrossing connections.

To clean up a map window:

• Click Configure > Layout.

This command will destroy any custom layout, but will not affect any of the packaging.

Promoting objects

The Promote command moves the selected objects to the window one level above the current 
window (in terms of hierarchy, not screen space). 

To promote an object:

• Click Configure > Promote.

This command locks all selected objects (unless they are promoted into the Main Map).

Reverting your map changes

If you are making changes to your map layout, and decide not to save your changes, you can 
Revert your map. This way, the autosave function will not save your changes. 

To revert your map to the version you last saved:

1 Click File > Revert.

A warning dialog appears.

2 Click OK. 

When the last object is promoted out of the package, the package is destroyed.

This feature works for changes to your map layout and packaging. Changes to the device 
properties (device tag, title, icon, or priority) or port properties cannot be reverted.
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Changing the map background image

You can add images to your Network Map background (main map and packages). 

There is a library of images you can select, all of which are available to all users. An 
Administrator or IT Manager account can add more pictures to the library (see Managing 
your background image library on page 32). 

To test an image file from your computer:

1 Click Configure > Background Image. 

The Map Background Image dialog appears.

2 Select Test Local Image File and browse to find the file you want. 

3 Click Apply. 

To select an image file from the library:

1 Click Configure > Background Image. 

The Map Background Image dialog appears.

2 Select an image from the image library pull-down list.

3 Click Apply. 

The image will appear as the background of your map window. By default, the image will 
cover the entire map window. You can alter the size of the image by clicking and dragging the 
image from its bottom-right corner. 

This background will not be saved as part of your map configuration. Only files in 
the image library can be saved. 

Click here 
and drag to 
resize the 
image. 
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Managing your background image library

An Administrator or IT Manager account can add and delete images from the Enterprise 
Discovery image library. These images are available to every user, regardless of account type. .

To add an image to the library:

1 Click Configure > Background Image. 

The Map Background Image dialog appears.

2 Select the Manage Library panel. 

3 Click Browse and search for your image file. 

4 Click Add. 

To delete an image from the library:

1 Click Configure > Background Image. 

The Map Background Image dialog appears.

2 Select the Manage Library panel. 

3 Select the file you want to delete. 

4 Click Delete. 

Packaging Your Network

You can group objects into packages so that the map is more organized and easier to 
understand.

If you add images that are larger than 250KB, you may notice the Network Map scrolling 
slowly

You will notice that the background images are dimmed slightly, so the image colors will not 
interfere with the map icons and lines. If you add your own images to the library, Enterprise 
Discovery will automatically dim the images, so you need not alter your graphic files before 
adding them to the library. 
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Regardless of your account type, you can package the network any way you want. You can also 
save different layouts and packages into map configuration files. 

How packaging works

By packaging devices, you can reduce the size of the Network Map. You can package your 
network differently in each map configuration file.

You can create packages to represent hierarchies, such as campuses, buildings, floors in 
buildings and so on. There are many package icons available to help you create the desired 
look and feel of the Network Map. 

There are two types of packages: the type Enterprise Discovery creates automatically and the 
type you can create yourself.

One application of multi-object packaging is mapping the network at a physical location, such 
as a city. For example, in the figure below, the main map contains a package for Building 1. 
Drilling down one level, the Building 1 map contains packages for the first floor and the 
server room. Drilling down further, you reach the devices for the “server room” within the end 
node package. 
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You can request the creation of packages

Enterprise Discovery can create packages for you. This is a quick way to reduce the size of the 
Network Map. Enterprise Discovery will create a package for each port of the device at the top 
of the network. Each package will contain the devices connected to that port.

To have Enterprise Discovery create your multi-object packages for you:

1 Select a map window.

2 Click Configure > Pack.

You are asked to confirm the action.

3 Click Pack.

The Pack command does not lock your objects on the Network Map.

The Pack command does not delete any existing packages. However, the Pack command will 
remove any other layout changes you have made.

If you wish, you can open each package and click Pack again to continue packaging your 
network.

Multi-object packages can be created by the user. Enterprise Discovery can create them with 
the Pack command, but if the packages are to be meaningful to you, it is best to create them 
yourself. 

You can create your own packages

If you wish, you can create your own packages as well. Packages you create are called 
multi-object packages. How you package the Network Map will depend on how your network 
is connected, and on how you want to view the map. You are not changing the actual 
connectivity of any devices only how you view them on the map.

Here are three quick procedures that will show you how to create your own packages.

To create a new package with objects in it:

1 Click an object icon, or select a group of objects.

2 Click Configure > Create Package.

Exception: While customizing your network, you may decide to use the Unpack All command. 
This command will destroy all the packages you have created. However, Enterprise Discovery 
will recreate all of the automatic packages. 

Remember, you can create many different map configuration files, each with different 
packaging. 

You can add new devices to a package at any time by dragging the icons on the map, or 
between map windows. However, your  layout may change when you drop new devices into a 
package:

• If the package has been laid out by the user: when adding new devices, Enterprise 
Discovery places them without moving any of the other icons. 

• If the package is in "auto-layout" mode: when adding new devices, Enterprise Discovery 
places them and moves the other icons around as well. 
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To create a new package with objects in it:

1 Right click an object that has dependent objects. 

2 Select Create Package.

The object will absorb any dependent object that:

• is not packaged

• is not locked

• does not have another connection

To change the icon and title of your package:

1 With the package icon selected, click Package > Package Properties.

2 Select a custom package icon from the pull-down list.

3 Enter a custom title for the package.

4 Click Apply or OK.

You can also unpack your packages

To move the contents of the active package up one level:

• From the package window, click Configure > Promote All.

This command causes the following:

• Only the current package window is destroyed. Packages within the current package are 
not destroyed.

• Unlocks all objects.

• Automatic packages that were within the window are repackaged.

To unpack the entire Network Map, and destroy all packaging:

• From the Main Map window, click Configure > Unpack All.

This command causes the following:

• All packages are destroyed.

• Unlocks all objects.

• Automatic packages are repackaged.

To empty one package:

• From any map window, with a package selected, click Configure > Unpackage.

This command causes the following:

This method is handy for tidying up devices connected to a Logical View icon.

In the Main Map window, this command is replaced by Unpack All.

In a package window, this command is replaced by Promote All.
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• Causes the selected package to be unpackaged, which also deletes the package

• Locks all objects within the package (unless they are unpackaged into the main map).

Locked objects

If you have manually packaged your map, you will see many icons with a blue line beneath 
them, if you have selected the “Underline locked objects option in Edit > User Preferences. The 
blue line indicates that the device has been manually packaged, meaning it has been put 
inside a package (Package command), promoted from a package (Promote), or has had its 
package removed (Unpackage).

When you manually package or unpackage an icon, you lock it into position. For example, if 
you take a workstation icon from a package and place the icon on the Network Map, that 
workstation icon will be locked there. 

Enterprise Discovery creates some automatic packages. Whenever you use the Pack or the 
Unpack All commands, Enterprise Discovery will recreate all automatic packages. To keep a 
device from being automatically packaged, you can lock the device by using the Lock 
command. 

To use the Lock command:

• Click Configure > Lock.

Changing the automatic packaging preferences

Automatic packaging is based on connectivity. There are a few basic scenarios: 

• device with one connection to a single connectivity device (such as a router or switch)

• device with multiple connections to a single connectivity device

• devices connected to a cloud or phone, which has a single connection to a connectivity 
device (in this case, the cloud or phone is also packaged with the devices)

Enterprise Discovery automatically creates packages, based on the major connectivity devices 
in your network. 

These packages appear on your map with the label “X devices for Y” where X is the number of 
devices (this number is constantly updated as devices are added to or removed from the 
package) and Y is the name of the connectivity device. 

Available to single packages only.

To see which objects have been locked, turn on View locked objects. An icon you have moved 
yourself—into a place Enterprise Discovery would not naturally have chosen—will have a 
blue line beneath it to indicate that it is locked. 
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Connectivity devices will have other devices associated with them (for example, 
workstations). Enterprise Discovery automatically packages the devices associated with that 
connectivity device.

By default, whenever Enterprise Discovery detects two or more end nodes of any classes, it 
creates a package to contain those objects. If it detects 3 or more objects of the same class (for 
example, workstations) it will create class-specific packages. The default is 3, but you can 
change this threshold if you wish. 

Also by default, whenever Enterprise Discovery detects 10 or more network devices, it will 
automatically package those devices. 

The defaults work well with most networks. You can change them to package the network in a 
particular way. 

There are seven automatic package types available:

• Workstations

• Servers

• Printers

• POS/ATM

• Controllers

• Unknown

• Network Devices

• End Nodes

Automatic packaging settings do not affect your ability to create custom packages. 

Enterprise Discovery usually treats a telephone as an end-node, but it may see it as a 
connectivity device.

If you have an Administrator account, you can change whether or not each class of device is 
packaged. 

The End Nodes package is a generic package type. If there are devices that do not fit the 
thresholds of another package type, those devices may fit into a generic End Node package. 
There are also three device icons native to this package type. 
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To create automatic packages of a particular type:

1 Click Administration > System Configuration > Automatic packaging.

2 For the package types you want to create, turn the package type On.

3 Select a threshold for each type of package.

4 To prevent a class of devices from being packaged, turn it Off.

5 Click Submit. 

To restore the default settings, click Restore Default. 

A few examples

If you don't usually monitor end nodes, you should package all types of end node into a single 
type of package: 

1 Set these controls Off: 

— Workstations 

— Servers 

— Printers 

— POS/ATM 

— Controllers 

— Unknown 
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2 Set this control On: 

— End Nodes 

3 Set the End Nodes threshold to 2. 

If your network contains many servers for which you are responsible, you should package 
servers separately, but allow all other end nodes to be placed in a single type of package: 

1 Set these controls Off: 

— Workstations 

— Printers 

— POS/ATM 

— Controllers 

— Unknown 

2 Set these controls On: 

— Servers 

— End Nodes 

3 Set the Servers threshold to 1. 

4 Set the End Nodes threshold to 2. 

If you are responsible for the three most common types of end nodes (workstations, servers, 
and printers), you should package each type separately for easy locating and identifying. 

1 Set these controls Off: 

— POS/ATM 

— Controllers 

— Unknown 

2 Set these controls On, and set each threshold to 1: 

— Workstations 

— Servers 

— Printers 

— End Nodes 

Organizing Map Configuration Files

Enterprise Discovery lets you save different map configuration files. Each of these map 
configurations contains your layout and packaging. You can save as many configurations as 
you want, so you can quickly change your view of the Network Map. 

These configuration files are saved (by default) at this location: 
C:\Documents and Settings\All Users\Application Data\Peregrine\Enterprise 
Discovery\Topology\config

If you backup your system data, these configuration files will be included. For more 
information on creating a backup, see the Installation and Initial Setup Guide. 
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For example, you may want to concentrate on one particular building or campus. So, you 
create a map configuration that shows that campus, and all your important devices there. In 
another map configuration, you may want to see an overview of the entire network. 

What is a Map Configuration?

Enterprise Discovery automatically opens a map configuration file at the start of each map 
session. The first time a new account starts a map session, this is always a copy of the Prime 
configuration. All other times, the map configuration file that Enterprise Discovery opens 
depends on the type of account you are using.

When you end a map session, Enterprise Discovery takes note of what map configuration file 
is in use. The next time you start a map session, Enterprise Discovery opens that file. There 
are two exceptions:

• You can designate a different configuration file to be opened next time.

• Demo accounts always start a map session with a configuration called “Copy of Prime”. 
This is so that each user of a Demo account can start fresh, unaffected by previous users.

Demo accounts can open a saved configuration if they want to pick up where they left off.

The Prime configuration

The Prime configuration is a special configuration not associated with a particular account. 
As the owner of an Administrator account or an IT Manager account, you control the Prime 
map configuration. The Prime configuration can serve as a basis or starting point; people can 
copy it and make their own configurations.

Any user can open a copy of the Prime configuration in the Network Map by clicking File > 
Open Copy of Prime.

Saving your changes

Each account may save one or more named map configuration files. Each file contains 
information on the account’s Network Map, and priorities, layout, packaging, package icons 
and titles.

Table 7 Default Map Configurations

Account type Subsequent default file

Demo Copy of Prime

IT Employee last opened or designated

IT Manager last opened or designated

Administrator last opened or designated

If you have just installed and set up Enterprise Discovery, you will notice that the Prime 
configuration does not exist. First, an Administrator account or IT Manager account must 
save a Prime configuration with the Save As Prime command (in a Network Map window, click 
File > Save As Prime). 
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An account owner can use the different map configuration files for different purposes. For 
example, one configuration file could show the network geographically, and another 
configuration file could show the network by subnets.

An account may open a different configuration at any time. Once saved, this configuration 
becomes the “current” configuration and will be used for the next map session.

Each account has the configuration files saved in a separate space. Therefore, each account 
may have a configuration named “test” without interfering with other accounts.

Starting a map configuration

To start a new map configuration:

• Click File > New.

Saving a map configuration file

Creating a specific configuration name enables you to see your configuration the next time 
you log in to the Network Map.

A configuration name must be 1–30 bytes long (the number of characters depends on 
language encoding). You can use the following characters:

• A through Z (upper case)

• a through z (lower case)

• 0 though 9 (numbers)

• underscore (_)

• hyphen (-)

To save a map configuration:

1 Click File > Save As.

2 Enter the new configuration name.

3 Click OK.

Autosave

Enterprise Discovery provides an autosave capability for recovery purposes by saving the 
“current” configuration to a recovery file. Enterprise Discovery will make an autosave file 
(within a time period ranging from 10 seconds to two minutes, depending on the changes 
made by the account). If a session ends abnormally, the recovery file will be used the next time 
you open a map.

Your current configuration is normally the one active when you exit the Network Map, but 
you can alter this with the Manage Map Configurations option.

A new configuration will be labeled “Untitled” until you save it, at which time you are able to 
name the file.
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When you next open a map, you will see the message “Restored configuration from autosave” 
to remind you that a recovery has occurred. In the event that Enterprise Discovery uses the 
recovery file, the user still has the opportunity to discard the unsaved changes and re-open 
the configuration that represents the state of the last explicit save.

Saving the Prime map configuration

The Prime map configuration is the default configuration for all accounts. Any account can 
open the Prime map configuration, but only Administrator and IT Manager accounts can 
change it. IT Employee and Demo accounts must save their changes under a different file 
name. 

To save the Prime map configuration:

1 Click File > Save As Prime.

A confirmation box appears, asking if you really want to save this configuration as the 
Prime configuration.

2 Click Save As Prime.

Autosave will not overwrite your named configuration. When you respond “no” to the 
question “Do you want to save the changes?”, you are discarding the active changes and the 
autosave file. The autosave file is also discarded when you save a configuration.
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Opening a saved map configuration file 

You can only open your own configuration files with this procedure. If you wish to use the 
configuration file of another account, you must first copy that file into your account.

To open a saved map configuration:

1 Click File > Open.

2 Select the file name of the configuration you wish to use. 

3 Click OK.

Managing map configuration files

This section is for any accounts, except demo. The demo account cannot perform any 
administration functions. The other three types of accounts can:

• copy map configuration files

• delete map configuration files

• rename map configuration files

• choose which map configuration file will be the one that opens first (Make current)

To reach the Administration menu, click the Administration button.

To copy a map configuration file:

1 Click Administration > My map configurations > Manage map configurations.

2 Select a configuration file from the first pull-down list.

3 Select Copy.

4 Click Next.

5 Enter a name for the new configuration file. 

6 Click Finish.

To delete a map configuration file:

1 Click Administration > My map configurations > Manage map configurations.

2 Select a configuration file from the first pull-down list.

3 Select Delete.

4 Click Next.

5 Click No to delete the file.

To rename a configuration file:

1 Click Administration > My map configurations > Manage map configurations.

When you open a configuration file, all open package windows close. The Device Manager 
windows, Port Manager windows, Line Manager windows, Network Map, and Health Panel 
stay open.

Close your map before performing any of these procedures.
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2 Select a configuration file from the first pull-down list.

3 Select Rename.

4 Click Next.

5 Enter a name for the new configuration file. 

6 Click Finish.

To choose which map configuration that will open first:

The command, Make Current, makes a map file the first one you see when you open the 
Network Map.

1 Click Administration > My map configurations > Manage map configurations.

2 Select a configuration file from the first pull-down list.

3 Select Make Current.

4 Click Next.

5 Click Yes to make this your default map configuration.

Sharing map configuration files with other accounts

You can make it possible for other accounts to make copies of your files, but you cannot 
actually send a file. The procedure is simple and quick. First, you make sure that your 
account has its permissions set correctly. Next, the user with whom you want to share the file 
requests it.

To permit others to share your map configuration files:

1 Click Administration > My account administration > Modify properties. 

2 Click Account Properties. 

3 Select “Yes” from the “Allow others to copy map configurations?” radio button. (If “Yes” has 
already been selected, your task is complete.) 

4 Click Modify Properties. 

You have just permitted all users to copy all your map configuration files.

What the other user must do:

1 Click Administration > My map configurations > Copy map configurations. 

2 Select an account name (of the person whose file they want to copy) and click Next. 

3 Select a configuration file and click Next. 

4 Enter a name for the configuration file. 

5 Click Finish. 

The other user now has a copy of one of your map configuration files.

The other user must not have a map session open. 
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Saving a map window as a graphic file

You can save any map window (the main map, or any package) as an image file (either jpg or 
png).

To save your map as an image file:

1 Click File > Save Map Image.

The File Chooser dialog appears.

2 Enter the name and location of the image file you want to save. 

3 Select a file type.

4 Click Save.
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4 Using the Service Analyzer 
The Enterprise Discovery Service Analyzer allows you to analyze the network path between 
two devices. To get started with the Service Analyzer, you must identify the devices at the 
ends of the path you want to analyze.

Choosing Your Path

The toolbar contains two search boxes: From and To. Each box searches for a device based on 
its name, title, or address. This Find window works exactly the same way as the global Find 
feature. For more information, see Finding your Network Devices on page 11. 

To use the Service Analyzer:

1 From the Enterprise Discovery navigation tree, click Service Analyzer.

2 Click the first Find icon. 

3 In the Match value box, enter the IP address or the first few characters of the device 
identifier for the first device that you want to find, and press Enter.

4 Select a device from the Find dialog and click OK.

5 Repeat step 2 to step 4 for the second Find icon.

You can also open the Service Analyzer from the Device Manager. That device will 
be the first device in the Service Analyzer query.

It is important to fill in the device on the left first. Changing the device on the left 
side will automatically clear the device on the right side.

Click the “Find” 
icons, and the Find 
dialog appears.

Enter the devices 
you want to locate.
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The Service Analyzer Window

After you provide valid endpoints for the path to be analyzed, the Service Analyzer displays a 
diagram of the path in the upper pane and a graphical representation of performance  
information for that path in the lower pane.

In the following example, the lower pane shows the rate of collisions observed over a 48-hour 
period. To see the number of broadcasts or errors that took place during this same 48 hours,  
you would click the Broadcasts button or the Errors button.

Path Diagram

You will notice that the path diagram has a similar look to the Network Map. The path 
diagram presents only devices and lines. Packages are not shown. In the Paths drop-down list, 
multiple views are available to display the data for different paths between the two devices.

Path 
Diagram

Performance
Information

Tab Selector

If there is only a single path, it will be the only choice. The percentage indicates how 
frequently a path was taken. If the sum of the percentages is less than 100, this indicates that 
a path was not available at some point during the preceding 48 hours..
48 Chapter 4



Full-Path Graphs Tab

The Full-Path Graphs tab shows a summary of the entire path for the following alarm 
categories:

You can click any of the buttons to view the related alarm category. All graphs display traffic 
levels for the last 48 hours across the entire path.

Alarms Tab

This tab is not available in Enterprise Discovery version 2.1.1.

Attribute Graphs Tab

This tab is not available in Enterprise Discovery version 2.1.1.

Table 1 Graphs

Alarm Category Notes

Collisions Collisions per seconds; for ports

Broadcasts Broadcasts in frames/sec.; for ports, bi-directional

Errors Errors in frames/sec.; for ports
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5 Using the Health Panel and Alarms Viewer
There are many ways to look at your device data with Enterprise Discovery. The Health Panel 
and the Alarms Viewer allow you to see your devices, and to determine the devices that 
currently have problems. 

Typically, a user would start with the Health Panel, which lists all the alarms currently on 
your network. To see a list of devices with these alarms, double-click on an alarm category in 
the Health Panel, and the Alarm Viewer opens. 

The Alarms Viewer shows all the devices on the network with current alarms. From the 
Alarms Viewer, you can open up a Device Manager, Port Manager, or Attribute Manager. 

Topics in this chapter include:

• See a network overview with the Health Panel on page 51

• Using the Aggregate Health Panel on page 53

• Using the Alarms Viewer on page 54

• Using the Aggregate Alarms Viewer on page 55

• Saving data to a text file on page 55

See a network overview with the Health Panel

The Health Panel enables you to set up, highlight, and examine conditions, alarms, and 
statistics that Enterprise Discovery has gathered about your devices.

The Health Panel is automatically updated with current device information.
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There are icons on the Health Panel to distinguish device and port alarms. The Health Panel 
is divided into sections as indicated by these icons:

The Health Panel will show you how many devices have alarms. You can drill down with the 
Alarms Viewer to see exactly which devices have the alarms. 

Customizing the Alarm List

My User Alarms

You can change the appearance of the Health Panel so you see only the alarms in which you 
are interested. 

Table 1 Alarm Indicators

Category Indicator

Port Attribute Alarm 

Device Attribute Alarm 

Port Report Alarm 

Device Report Alarm 

The Aggregate Health Panel works the same way as the normal Health Panel, but it shows 
information for all the Enterprise Discovery servers in your network. For more information, 
see Using the Aggregate Alarms Viewer on page 55.

Table 2 Health Panel footer

Statistic Explanation

Devices The number of discovered devices in the network.

Ports The number of discovered ports in your network

Availability This number represents the number of real devices 
with priority 3 (or higher) that are operational as a 
percentage of the total number of real devices with 
priority 3 (or higher).

Frames This number represents the instantaneous number of 
frames per second seen on the entire network.

Errors This number represents the instantaneous number of 
errors per second seen on the entire network. This 
includes the number of errors on both the “in” and the 
“out” ports of the network devices.
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To customize the alarms shown on the Health Panel:

1 From the Health Panel, click Edit > User Preferences > Health Panel tab.

Here, you can create a list of the alarms you want to see on the Health Panel. 

2 After you have created your list, click Apply. 

3 Click OK.

Next, you must select these changes in the View menu.

4 Click View > My User Alarms Only.

Hide Inactive Alarms

You can hide the categories that currently have no alarms associated with them. 

To hide the inactive alarm categories:

• Click View > Hide Inactive Alarms. 

Using the Aggregate Health Panel

The Aggregate Health Panel looks similar to the regular Health Panel; it has all the same 
buttons and statistics. However, the Aggregate Health Panel combines all the statistics from 
all the aggregated Enterprise Discovery servers in your network.

You can click on the report buttons to see complete lists of all alarms in the entire network. If 
you were looking at a regular Health Panel for one server, you would only see alarms for a 
portion of your network.

The statistics listed in the Aggregate Health Panel are the same as those listed in the regular 
Health Panel.

Servers button

Clicking the servers button at the bottom of the Health Panel takes you to the Aggregate server 
Health page. This page shows you a summary of the health status of all your remote 
Enterprise Discovery servers.

By clicking on any of the server hyperlinks on this page, you can see the server Health page for 
that Enterprise Discovery server.

You can tell what Health Panel you’re looking at by the report banner. If it is the Aggregate 
Health Panel, the banner says “Aggregate Health” rather than “Health Panel”. A “globe” 
symbol also shows that you are looking at an Aggregator.

The local Enterprise Discovery server is always at the top of the list with an asterisk (*).
Using the Health Panel and Alarms Viewer 53



Using the Alarms Viewer

The Alarms Viewer is an extension of the Health Panel, and shows you exactly on which 
devices and ports the alarms have occurred. 

By double-clicking on a line in the Health Panel, you will open the Alarms Viewer. The Alarms 
Viewer works with the Health Panel to show you which devices on your network have Critical, 
Major, Minor, or Info alarms. 

The status bar in the Alarms Viewer is similar to that on the Health Panel. You can change 
the displayed alarm type or priority with the pull-down lists on either window. Your selection 
will appear in the Health Panel and the Alarms Viewer. 

The Alarms Viewer will show a maximum of 1000 alarms.
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Using the Aggregate Alarms Viewer

The Aggregate Alarms Viewer is almost identical to the regular Alarms Viewer. The major 
difference is that the “Server” column shows which server is the source of the alarm data.

Saving data to a text file

You can now use the Save Table Data feature to save selected info into a tab separated value 
(.tsv) file in the following Enterprise Discovery features: 

• Health Panel

• MIB Browser

• Find

• Alarms Viewer

• Service Analyzer

• Events Browser

You can save the entire contents of a window, or you can Ctrl-click to select the data you want 
to save. 

Saving data to a text file:

1 Select the table items you want to save. To select the entire table, click Edit > Select Table. 

2 Click File > Save Table Data.

A Save Table Data dialog appears.
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Saving data to the clipboard:

1 Select the table items you want to save. To select the entire table, click Edit > Select Table. 

2 Click Edit > Copy.

Your selected items have been copied to the clipboard. For example, you can paste it into a 
file, or an e-mail. 

3 Select a file name and location for the text files.

4 Click Save. 
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6 Using the Events Browser
Enterprise Discovery logs network and access events. The Events Browser can display up to 
1,000 events at a time. 

An event occurs when:

• A device or port is physically added, deleted, or moved.

• A device or port property is changed by a user (through the Device or Port Properties 
dialog) or by the system itself.

An access event occurs when:

• Users access (or attempt to access) or logout of the Enterprise Discovery server.

• An admin or IT manager user writes to a device MIB, updates a device model, changes a 
device’s visibility, or changes device properties. 

For example, Enterprise Discovery can log an event if it discovers a device has been added to 
the network. It may also log an event when a line breaks or if there are too many delays on a 
line. The Events Browser shows you a list of events that occurred on lines and devices in your 
network during a specified period. 

The Health Panel and Network Map give you information about the current state of your 
network. The Events Browser gives you historical information. The Health Panel and 
Network Map can tell you what’s wrong now. The Events Browser shows you problems that 
only patterns over time can reveal.

Opening the Events Browser

To open the Events Browser:

• On the navigation tree, click the Events Browser link.

OR

• From the Health Panel or Alarms Viewer, click Tools > Events Browser.

OR

• From a Device Manager or Port Manager, click the Events button.

Only admin accounts can view access events. 

The Events Browser shows events for the past 45 days or up to a maximum of 500,000 events 
(whichever is less).
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Network Events

All users can see the network events on the Events Browser. The next figure shows an 
example of what you will see if you selected All Events from the events pull-down list. If you 
select one type of event from the list, the display will change, and you will see only that event 
and columns relating to that event-type. 

Each row in the Events Browser window contains the following information:

Table 1 Events Browser columns

Data Explanation

Event Time The time the event was generated.

Device 
Priority

—

Device type Small device icon

Device Device titlea 

a. If no device title can be determined, the Events Browser title 
column is blank. This depends on the Device Title 
Preferences as set in Administration > System 
Configuration > Display preferences.

Port Port number (will not appear if a device 
alarm is selected)

Alarm type Alarm type icon

Attribute Name of the alarm

Valueb Numerical value, if any, associated with this 
alarm.
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“Broadcast In” and “Broadcast out” alarms are not logged, due to the potentially very high 
number of events. “Source of Broadcast” alarms are logged.

Access Events

Only admin accounts can view access events on the Events Browser. You can select any of the 
these event types to view: 

• Server Access

• SNMP Write by MIB OID

• SNMP Write by Attribute

• Port Adds/Deletes

• Port Changes

• Device Adds/Deletes

• Device Changes

• Update Model

You will notice that the Port and Device events are listed in the Network Events panel as well 
as the admin-only Access Events panel. The same events are listed in both panels, but under 
Access Events, you can see more details about where these changes originated: the source IP 
address and account name. 

Similar to the network events list, the columns will change depending on the type of event you 
choose to display. 

Server Access events show the following data:

b. There will not be a Value column for Line and Device Breaks. 

Table 2 Server Access Events

Data Explanation

Event time the time of the access event

Account name the user accessing Enterprise Discovery
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SNMP Write events show the following data:

From IP the IP address from which the user accessed Enterprise Discovery

Access point the part of Enterprise Discovery accessed by the user:

• MIB Browser – the user has accessed the MIB Browser.

• Network Map – the user has accessed the Network Map. 

• HTTP – the user has successfully logged into Enterprise Discovery

• Telnet Proxy – the first time this account has logged into a remote 
appliance through the aggregator.

• HTTP Proxy – the first time this account has logged into a remote 
appliance through the aggregator. 

• MIB Browser Proxy – the first time this account has opened a MIB 
Browser session on a remote appliance through the aggregator.

• Network Map Proxy – the first time this account has opened a Network 
Map session on a remote appliance through the aggregator.

Access status whether or not the user was able to access Enterprise Discovery:

• Connect – the user has connected to Enterprise Discovery, and 
disconnected without attempting to login. 

• Login OK – the user has successfully logged in to Enterprise Discovery.

• Login fail – the user has attempted to login, and did not have the 
correct password. 

• Logout – the user has logged out of Enterprise Discovery.a

• Login disabled – the user has tried to login with a failed password too 
many times (limit has been set in Administration > System Configuration 
> Appliance passwords)

• Login no permission – this account has been denied permission to 
access Enterprise Discovery. 

a. Logout for HTTP and HTTP proxy has a timeout of 5 minutes from your last HTTP request.

Table 3 SNMP Write Events

Data Explanation

Event time the time of the access event

Account name the user accessing Enterprise Discovery

From IP the IP address from which the user accessed the device

To IP the device that had its MIB changed

MIB OID the MIB OID changed by the user (for “Write by MIB OID” only)

Table 2 Server Access Events

Data Explanation
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Device and Port Add/Delete events show the following data:

Device and Port Change events show the following data:

Attribute either Administrative Status or Bridge Aging Interval, these being the 
only attributes a user can change through the MIB (for “Write by 
Attribute” only)

Write 
Community 
String

the community string used to access the MIB

Value the new “changed” value of the OID

Access Status whether or not the user was able to write to the MIB:

• Write OK

• Fail (any of the following messages may appear): invalid response, too 
big, no such name, bad value, read only, gen err, no access, wrong type, 
wrong length, wrong encoding, wrong value, no creation, inconsistent 
value, resource unavailable, commit failed, undo failed, authorization 
error, not writable. 

Table 4 Add/Delete Events

Data Explanation

Event Time the time of the access event

Account name the user accessing Enterprise Discovery

From IP the IP address from which the user accessed the device

Priority the priority of the device

Icon the current icon representing this device

Device the current device title

Port The port number (only appears for Port event)

Attribute Add or Delete

Table 5 Change Events

Data Explanation

Event Time the time of the access event

Account name the user accessing Enterprise Discovery

From IP the IP address from which the user accessed the device

Priority the priority of the device

Icon the current icon representing this device

Table 3 SNMP Write Events

Data Explanation
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Update Model events show the following data:

To view access events on the Events Browser:

• Click View > Show Access Events.

Device the current device title

Port The port number (only appears for Port event)

Attribute The type of change (device title, etc.)

Value The changed value

Table 6 Update Model Events

Data Explanation

Event Time the time of the access event

Account Name the user accessing Enterprise Discovery

From IP the IP address from which the user accessed the device

Priority the priority of the device

Icon the current icon representing this device

Device the current device title

Access 
Command

The command issued by the user (Update Model, Enrich XML, etc.)

Table 5 Change Events

Data Explanation
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Toolbar

The following diagram of the Events Browser toolbar shows all the methods of changing the 
event list. You can use the different buttons and text boxes to view the events in which you are 
most interested.  

The Aggregate Events Browser

The Aggregate Events Browser is almost identical to the regular Events Browser. The major 
difference is that the “Server” column shows which server is the source of the event data. 

By default, the Aggregator updates events hourly. Due to the time lag, events may not be 
completely up to date.

If aggregation is turned on, but no Aggregators have been set up, the aggregate Events 
Browser will look very much like the regular Events Browser, except for the time delay.

Table 7 Toolbar Legend

Number Feature

1 Event Category Pull-down list

2 Priority

3 Recent device list

4 Find a device

5 Older

6 Events Time Frame

7 Newer

8 Maximum number of events to find

9 Show Additional Info

10 Open Device Manager

11 Open Port Manager

12 Locate on Network Map

13 Refresh

14 Connectivity Indicator

1 2 3 4

5 6 7 8 9 10 11 12 13 14
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7 Using the Device Manager
The Device Manager provides you with detailed information about a device, in several panels. 

Through its series of panels, you can see the current alarms on the device, as well as historical 
statistics. You can also interact with the device directly through the Device Manager, by 
pinging the device, opening a telnet session, or by forcing Enterprise Discovery to update the 
device model. 

To open the Device Manager:

Table 1 Opening Device Manager

From Open by...

Health Panel, Alarms Viewer, 
Events Browser, Network Map, 
Service Analyzer, Scan Viewer

Click Tools > Find (Ctrl - F). Enter a device address 
or title, then click Find. 

Alarms Viewer, Events Browser Double-click on a table row, or right-click on the 
device icon, title, or IP address.

Find Enter a device address or title, then click Find.

Reports, Status, Manager panels Click a hyperlinked device title

Network Map, Service Analyzer Double-click a device icon. Right-click a device icon, 
and select Open Device. Click a device icon, and click 
Object > Open Device. 
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List of Device Manager Panels

This is a complete list of panels available in the Device Manager. If you are reading this 
document online, click the hyperlinks in this table to read more information on these panels. 

Icon Name Description

Configuration This panel identifies a device and presents an overview of the 
device’s identity and status. 
For more information, see page 68.

Reports This panel displays current values for report and summary 
historical data. Displays alarm signals even when the device 
priority is less than the minimum priority for a configuration 
(unlike in map windows).
For more information, see page 72.

Diagnosis This panel displays information about the current state of the 
device that can be helpful in diagnosing problems. There are 
buttons that give you access to diagnostic tools.
For more information, see page 73. 

Ports This panel lists ports for this device and summarizes the 
information available for them. Displays 24 ports at a time (by 
default, you can change this in Administration > Account 
administration > Account properties).
For more information, see page 81.

Events This button opens the Events Browser with this device in 
context. 
For more information, see Using the Events Browser on 
page 57.

Locate This button highlights in a map window the location of the 
device.
If a map session was not open already, one will open now. 
Within the map window, the device you are locating has a 
yellow circle around it.
If the window containing the device was already open, that 
window becomes the front-most window, and the window scrolls 
so that the highlighted icon can be seen.

Service Analyzer This button opens the Service Analyzer query with the current 
device already selected as Device 1, to allow the user to view the 
state of the path between this device and any other device on 
the Network Map. 

Manage This button launches an element manager of your choice.
The URL or application must defined in Administration > System 
Configuration > Element management. If not, this button is 
dimmed.
Note: for Aggregator—Definitions for Element management are 
supplied from the Aggregator server, not the remote server.
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Browse MIB This button opens the MIB Browser to allow the user to view 
the device’s SNMP MIB.
The MIB Browser also allows an expert user with an 
Administrator or IT Manager account to manipulate the device 
on a more detailed level.

View Scan Data This button opens one of the Enterprise Discovery Viewers to 
show information about the device collected by Enterprise 
Discovery scanners.
For more information, see page 81. 

Web This button attempts to open a web browser window for the 
device.
For more information, see page 81. 
Note: The device must have an IP address. If not, this button is 
dimmed.
Note: The device must support Telnet sessions. (Enterprise 
Discovery does not check before attempting a connection.)

Telnet This button attempts to open a Telnet session. Many network 
devices provide Telnet as a means to set up and configure the 
device.
Note: The device must have an IP address. If not, this button is 
dimmed.
Note: The device must support Telnet sessions. (Enterprise 
Discovery does not check before attempting a connection.)

Update Model 
(Administrator or 
IT Manager)

This panel gives several options for updating the device 
information in the Discovery database.
For more information, see page 82. 

Device Visibility 
(Administrator or 
IT Manager)

This panel gives you options to activate, deactivate, hide, or 
purge devices on this panel. 
For information on how to activate, deactivate, hide, or purge 
devices, see the Configuration and Customization Guide.

Properties This button allows you to change the icon and name of a device 
in your network. 
For instructions on how to use this feature, see the 
Configuration and Customization Guide.

Asset 
Questionnaire

This button opens up an Asset Questionnaire for this device. 
For more information on how to create and use this feature, see 
the Installation and Initial Configuration Guide. 

Icon Name Description
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Configuration

This panel identifies a device and presents an overview of the device’s identity and status.

This panel is divided into the following principal sections:

• Identity table (real devices only)

• Asset Data table 

• SNMP Configuration

• Device structure (Serial number and description, disk, CPU, memory)

• Address table (real devices only)

• Virtual LANs

Identity table

The information in this table can come from these sources: the Enterprise Discovery 
Rulebase, the SNMP MIB of the object, and the data included in a scan file. 

The Rulebase determines the device’s operating system, application, device family, and model. 

Some of the information collected from the SNMP MIB has been set by the device 
manufacturer; other information can be customized.

More elements of identity appear for the Enterprise Discovery server than for any other 
device.

Refresh This button refreshes the contents of the panel.
When used with IP Ping and SNMP Ping panels, uses the last 
entered value instead of prompting you for a value. 
Note: Does not re-read the data in the panel from the network. 
Re-reads the data only from the Enterprise Discovery database.
Note: Does not affect Properties or Locate panels, or any of the 
interactive session windows (Browse MIB, Web, Telnet).

Print This button prints the contents of the panel.

Close This button closes the window and exits the Device Manager.

Icon Name Description

This panel is blank if the device is not in the Enterprise Discovery database.

All these elements are optional. 
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Table 2 Identity Table

Data Example Creator
Administrator 
or IT Manager

Packagea Main Map Enterprise 
Discovery/
account

—

UNSPSC Computer Servers Rulebase —

Family Cisco 2600 Series 
Modular Access Routers

Rulebase —

Family current 
manufacturer

Cisco Systems Inc Rulebase —

Model Cisco 2621XM Modular 
Access router

Rulebase —

Model current 
manufacturer

Cisco Systems Inc Rulebase —

Model historical 
manufacturerb

Cisco Systems Inc Rulebase —

Operating system Cisco IOS Version 12.2 
(8) T5

Rulebase —

Operating system 
current manufacturer

Cisco Systems Inc Rulebase —

Operating system 
historical 
manufacturer

Cisco Systems Inc Rulebase —

Network Function — Rulebase —

Network Function
current manufacturer

— Rulebase —

Network Function 
historical 
manufacturer

— Rulebase —

Operating system Linux Enterprise Discovery —

Service pack — Enterprise Discovery —

NetBIOS name 
(network)

DUPONT device owner —

NetBIOS workgroup MARKETING device owner —

rulebase extra info — Enterprise Discovery 
Rulebase

—

Device-specific title — scripts —

System OID .1.3.6.1.4.1.295.5.1.1.2 manufacturer —
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About the Package data

The package row displays the position of a device within the packaging of the Network Map. 
Click on a hyperlink to open a corresponding map window.

If you have a map open, this row reflects the packaging of your current configuration. If you 
open the Device Manager and then make packaging changes that affect the device, click the 
Refresh button to have this row updated.

If you do not have a map open, this row reflects the packaging of the configuration you were 
using in your previous map session.

If you have never had a map open, this row does not appear.

System OID 
manufacturer

PlainTree Systems Inc Rulebase —

System description Ethernet Switch manufacturer —

System contact test@example.com device owner setc link

System name ws1216-2 device owner setc. link

System location Server Room device owner setc. link

Asset tag 78LL996 Scanner —

BIOS asset tag — Scanner —

BIOS product name eserver xSeries 330 
-[867441X]-

Scanner —

BIOS product 
manufacturer

IBM Scanner —

BIOS serial number 78LL996 Scanner —

BIOS chassis — Scanner —

CPU Pentium III 1133 MHz 
(Genuine Intel)

Scanner —

NetBIOS name (scan)d, 
e

DUPONT device owner —

Memory (MB) 1024 Scanner —

Windows/NIS domain MARKETING Scanner —

a. This is optional if you have not opened a map configuration since this object was discovered.

b. Appears only when different from the current manufacturer.

c. A shortcut to the MIB Browser.

d. On Windows workstations, frequently the same as the system name.

e. NetBIOS data is blank unless the device has an IP address.

Table 2 Identity Table

Data Example Creator
Administrator 
or IT Manager
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If the device has been added to the network since the last time you saved your configuration, 
this row does not appear.

Asset Data

This table displays the data entered in the Asset Questionnaire. 

SNMP Configuration

These are the community strings (for devices with SNMPv1/v2) and users (for devices with 
SNMPv3) that will be tried for this device. This will be blank if there are no strings or users 
configured in Enterprise Discovery. 

An Admin or IT Manager user will also see a read and a write community string (for devices 
with SNMPv1/v2) or user (for devices with SNMPv3) for a device. These values are taken from 
the list of community strings and users; however:

• strings and users from the list appear here only if they are valid.

• only a single valid string/user appears here even if the list has multiple valid strings/
users for this device.

• the read string/user that appears here is the string/user that Enterprise Discovery is 
currently using to poll the device.

Device Structure

Provides information on the serial number of the chassis and modules in a device. You will see 
the following information about each module:

• Type (backplane, container, misc, other, powerSupply, stack, chassis, fan, module, port, 
sensor, CD, disk, cpu, ram, vram, tray, toner, unknown)

• Hardware

• Firmware

• Software

• SerialNumber

• Mount Point

• Capacity

• Description

Address

Provides information about the IP addresses and/or MAC addresses of a device’s ports. The 
information comes from the Network Explorer or from scan file data.

This table has hyperlinks for all the ports with addresses. If a port does not have an address, 
it does not appear in the list. To open a Port Manager, click a port hyperlink. Each table row 
contains either:

• a MAC address, an OUI abbreviation (if known), and a manufacturer (if known)

• an IP address, a netmask (if known), and a domain name (if known)

A special port of “Device” is used:
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• for the IP or MAC address that Enterprise Discovery identifies as the primary IP or MAC 
address for the device

• when Enterprise Discovery does not know which port an IP or MAC address is associated 
with

The address table is particularly useful:

• When the device is

• a router

• a device with multiple IP addresses and domain name aliases (such as a web server)

• When you want to know a device’s domain name (and domain name is not included in the 
list of Device Title Preferences)

VLANs

VLANs are software-defined broadcast domains, created by your System Administrator at the 
switch. If your device has any VLANs configured, you will see them in the Device Manager. 

VLAN example:

Reports

This panel displays current values for report and summary historical data. Displays alarm 
signals even when the device priority is less than the minimum priority for a configuration 
(unlike in map windows). 

This ‘report’ data is historical information. You can use the data on this panel in conjunction 
with the State panel to look for problem trends in your device. For example, you can see an 
alarm in the State panel for the device CPU, you can check the ‘reports panel’ to see if there 
was a problem yesterday, or over the past week or month. 

Data Notes

Port index port number and description

MAC/IP address —

OUI/Netmask netmask in octet notation

Manufacturer/Domain name usually hyperlinked to an external 
web site
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This panel is not available if the object is not in the Enterprise Discovery database.

State

Displays ‘report’ data like adds, deletes, and changes. Also displays notifications if any of 
these are in an alarm state (info, minor, major, critical).

If there are any exceptions for the device, they are noted in this table. For a list of exceptions 
in your network devices, see the Health Panel and Alarms Viewer. For a complete listing of 
Enterprise Discovery exceptions, see Help > Classifications > Exceptions.

a) Device moves are only reported if the Topology license is installed.

Diagnosis

This panel displays information about the current state of the device that can be helpful in 
diagnosing problems. There are buttons that give you access to diagnostic tools. 

Diagnostic Information

Beneath the heading, this panel is divided into these main sections:

• Main Diagnosis

• Network Configuration

• SNMP Configuration

• Asset Data

• Property Assignment

Data Notes

Report name Exceptions, Device Adds, Device Deletes, Device Movesa, 
Device Changes, Not Recently Seen

State OK, Info, Minor, Major, Critical

Value For exceptions:

• description

• effect

• action

Exceptions cannot always be reported for a device. 
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Main Diagnosis

The main table indicates the data flow for this device—when the device was first and most 
recently seen by various parts of Enterprise Discovery—plus the current values for several 
parameters.

Table 3 Main Diagnosis

Data Output Notes

First discovered elapsed timea / absolute date 
& time

Reset if database is cleared.

Scanner model last updated elapsed time / absolute date 
& time

—

Added to map elapsed time / absolute date 
& time

Resets if the device is 
deactivated, but then returns 
to the map.

Last replied to ICMP elapsed time / absolute date 
& time

in ping or poll by Enterprise 
Discovery

Last changed elapsed time / absolute date 
& time

the last time a connection to 
this device changed

Device last modeled as a 
managed device

elapsed time / absolute date 
& time

the last time the model 
changed; determines whether 
or not the model has been 
updated for this device

Device last modeled as an 
unmanaged device

elapsed time / absolute date 
& time

the last time a device was 
pinged for discovery; should be 
“n/a” or a time before “Model 
last updated”

Last deactivated or hidden elapsed time / absolute date 
& time

the last time a device was 
deactivated

Mean break diagnosis time minutes for alarms Mean break diagnosis time is 
approximate. Diagnosing a 
break may take longer, if 
communication with the device 
is unreliable.

Agent version version number (example, 
2.1.1)

—

Agent operating system name of operating system —

Agent port number port number (example, 
2738)

—

Scanner version version number (example, 
2.1.1.3809)

—
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Scanner configuration name of scanner 
configuration applied to this 
device

—

Scan file location location of scan file on your 
Enterprise Discovery server

—

Scan type the type of scan performed 
on the device

—

ARP tables seen elapsed time / absolute date 
& time

the last time the ARP tables 
were seen, to the nearest 30 
minutes. 

Port ARP tables seen elapsed time / absolute date 
& time

the last time the ARP tables 
were seen by this port, to the 
nearest 30 minutes. 

Port Bridge tables seen elapsed time / absolute date 
& time

the last time the Bridge tables 
were seen by this port, to the 
nearest 30 minutes. 

Port Source address capture 
seen

elapsed time / absolute date 
& time

the last time the Source 
address capture was seen by 
this port, to the nearest 30 
minutes. 

Port Radio link seen elapsed time / absolute date 
& time

the last time a Radio link was 
seen by this port, to the 
nearest 30 minutes. 

Port Bus link seen elapsed time / absolute date 
& time

the last time a Bus link was 
seen by this port, to the 
nearest 30 minutes. 

Port carrier link seen elapsed time / absolute date 
& time

the last time a carrier link was 
seen by this port, to the 
nearest 30 minutes. 

Port link training seen elapsed time / absolute date 
& time

the last time link training was 
seen by this port, to the 
nearest 30 minutes. 

Port detailed link training 
seen

elapsed time / absolute date 
& time

the last time detailed link 
training was seen by this port, 
to the nearest 30 minutes. 

Device modeler interval either “Default as set in 
Network Configuration” or 
time (in days, hours, 
minutes, seconds)

If custom, is shown here.

Table 3 Main Diagnosis

Data Output Notes
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Network Configuration

The Network Configuration table shows what parameters have been set up for the range in 
which the device resides and what their values are. It shows the Network Properties 
(Administration > Network Configuration).

The Network Configuration table displays the Default settings, and will display any overrides 
that have been performed through External means such as Web Services. 

Network Properties include:

• Allow devices

• Actively ping

• NetBIOS query

• Resource manage

• Force ARP table read

• Accumulate IP addresses

• Allow IP addresses

• Allow ICMP and SNMP

• Device Modeler interval

• Bandwidth 

• Frequency 

• Win32 platform

• HP-UX platform

• Mac OS/X

• Linux platform

• AIX platform

• Solaris platform

• Scanner upgrade

• Scanner upgrade schedule

Mean device modeler update 
run time

elapsed time the mean length of time it 
takes to update the model for 
this device the previous 4 
times

Recent device modeler 
update run times

elapsed time the length of time it took to 
update the model for this 
device the previous 4 times

Rulebase ID — an internal number

a. Elapsed time is reported in at least two of the following units: weeks, days, hours, minutes, and 
seconds. As elapsed time increases, the finer units of measure are not reported.

Table 3 Main Diagnosis

Data Output Notes
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• Scanner run schedule

• Scan file download schedule

• Agent upgrade

• Agent upgrade schedule

• Agent action

• Listener uninstall

• Agent communication port

• Collect utilization data

SNMP Configuration

These are the community strings (for devices with SNMPv1/v2) and users (for devices with 
SNMPv3) that will be tried for this device. This will be blank if there are no strings or users 
configured in Enterprise Discovery. 

Asset Data

This table displays the data entered in the Asset Questionnaire. 

Property Assignment

The Property Assignment table helps you to determine the rules Enterprise Discovery has 
used to assign the title, icon, and priority to the device.

The Property Assignment table displays the Default settings, and will display any overrides 
that have been performed through External means such as Web Services, or by an Admin user 
through the Device Properties feature. 

If no value has been assigned, an asterisk (*) appears in this table, indicating that the value 
for the property comes from the previous row of the table.

Only Admin and IT Manager accounts can see the community strings and users. 

Parameter Notes

Title The device title (default, external, and user-assigned)

Icon The device icon (default, external, and user-assigned)

Priority The device priority (default, external, and user-assigned)

Tag The device tag (default, external, and user-assigned)
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Agent Deployment Log

The agent deployment log shows you all the operations performed during the deployment 
process, including any errors that may occur. This is very useful for troubleshooting.

Scanner Deployment Log

The scanner deployment log shows you all the operations performed during the deployment 
process, including any errors that may occur. This is very useful for troubleshooting. 

IP Ping

Pings the device to see if it responds, and how quickly. The IP address pinged is the address 
identified by Enterprise Discovery as the primary IP.

Limits

• 1–20 pings

• The device must have an IP address. If not, this button is dimmed.

Default

5 pings

Traceroute

Displays the path that data takes to get from the Enterprise Discovery server to the selected 
device by listing the gateway devices associated with each hop of the journey. The device 
identifier is often the host name, where available, but can also be the IP address. Each device 
title is hyperlinked to a Device Manager.

Traceroute also displays the amount of time each hop took. This time is the round trip in 
milliseconds. Traceroute includes two retry hops for each try, so the times for all three hops 
are shown.

Traceroute helps you to understand where on the network problems are occurring. It is often 
used after IP Ping has been used to confirm the existence of a device.

When to use it

• If you suspect that you are losing packets due to a large hop count. 

In a TCP/IP network, where data are transmitted in packets, the header for a packet 
tracks the hop count. If the hop count grows too large, the packet is discarded.

This button is only available if the Inventory license is present. An exception is the 
Enterprise Discovery server itself, where this button is always available regardless of license.

This button is only available if the Inventory license is present. An exception is the 
Enterprise Discovery server itself, where this button is always available regardless of license.

The path displayed by traceroute is at OSI layer 3 and may not match the connectivity on the 
Network Map or in the Service Analyzer, which map at layer 2.
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• If you are trying to determine the point along the path where traffic is slowing down or 
getting lost altogether.

• If you are trying to determine the precise path taken—not so much to solve a problem as 
for general information.

Results of an asterisk for the device and for all three times (i.e. the result * * *) indicates that 
data is not available for that hop of the journey, and usually indicates a trouble spot along the 
path. The following table explains codes you may see when you attempt a Traceroute.

SNMP Ping

Queries the device for basic SNMP information and displays this information, and supports 
SNMPv1/v2 and SNMPv3. The IP address pinged is the address identified by Enterprise 
Discovery as the primary IP.

Limits

The device must have an IP address. If not, this button is dimmed.

Default

• Demo, IT Employee, IT Manager: “public”

• Administrator: the read community string or user for the device as defined in 
Administration > Network configuration > SNMP Property Groups.

The device must have an IP address. If not, this button is dimmed.

Character Meaning

* no response within a 3-second timeout interval

! ttl <= 1a

a. The ttl value is supposed to start at 1 and increase by 1 until the host is 
reached.

!H host is unreachable

!N network is unreachable

!P protocol is unreachable

!S source route failed

!F fragmentation needed

!X communication is prohibited administratively

!V a host precedence violation has occurred

!C precedence cutoff is in effect
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Agent Ping

Makes a connection to the agent running on the device to see if:

• the port number you have is correct (you can set this in Administration > System 
Configuration > Agent communication)

• the agent is installed and running on the device

• the security keys are correct

Limits

The device must be in the Enterprise Discovery database.

DNS Query

Sends a host query to the domain name server and displays a table that highlights 
configuration errors. A highlighted line indicates that the next line in the progression is 
missing.

The highlighted configuration errors are:

• a pointer (PTR) without an IP address (A or AAAA)

• duplicate pointer (PTR) records for the same IP address (A or AAAA)

• a mail exchanger (MX) directed to a canonical name (CNAME)

• a canonical name (CNAME) directed to anything that doesn’t exist

Highlighted information also includes an explanation in the “Exceptions” column. You will see 
one of the following explanations:

• Duplicate

• Target does not exist

• n/a

If no information in the table is highlighted, Enterprise Discovery did not detect any problems 
with the DNS configuration of the device.

Limits

If the device does not have an IP address, the button is dimmed.

This button is only available if the Inventory license is present. An exception is the 
Enterprise Discovery server itself, where this button is always available regardless of license.

If Enterprise Discovery displays the message “Non-existent domain”, it means that the device 
has not been assigned a domain name.
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Ports

This panel lists ports for this device and summarizes the information available for them. 
Displays 24 ports at a time (by default, you can change this in Administration > Account 
administration > Account properties). 

There are also Previous and Next buttons and an All button that shows all ports in a single 
panel.

You can create different views for this panel, so you can concentrate on the data most 
important to you. See Administration > System Configuration > Device Manager ports display 
preferences. Read the inline help for definitions of all the preference properties.

The Configuration panel and Ports panel are the most commonly used ways of starting the 
Port Manager.

View Scan Data

This button opens one of the Enterprise Discovery Viewers to show information about the 
device collected by Enterprise Discovery scanners. 

There are two different Viewers in Enterprise Discovery. The Win32 Viewer is available with 
the Enterprise Discovery client, and the Java Viewer is available through the web user 
interface. You can select your preferred Viewer under Administration > Account Administration > 
Account Properties. 

When you click this button, your preferred Viewer will appear. 

You can see a complete list of hardware and software installed on the device, plus usage data, 
depending on how you have configured your Scanners with the Scanner Generator (see the 
Configuration and Customization Guide). 

Limits

If there is no scan data, the View Scan data button is dimmed.

Web

This button attempts to open a web browser window for the device. 

Only use this feature if the device supports web-based management or other web services.

Ports do not always support all the attributes listed on the Device Manager Ports panel. If an 
attribute is not supported, the table column will be blank.

This button is only available if the Inventory license is present. An exception is the 
Enterprise Discovery server itself, where this button is always available regardless of license.

The Enterprise Discovery server always has scan data, as long as you have installed the 
Agent on the server. For more information, see the Installation and Initial Setup Guide. 
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Limits

• The device must have an IP address. If not, this button is dimmed.

• The device must support HTTP sessions. (Enterprise Discovery does not check before 
attempting a connection.)

Update Model (Administrator or IT Manager)

This panel gives several options for updating the device information in the Discovery 
database. 

At the top of the panel, there is a pull-down list so you can select the command you want to 
perform:

Command Explanation

Query Network Puts the device at the top of the device modeler’s queue, and 
runs through all the steps as required.
This command tries all valid community strings or users for 
this device, in the order specified in Administration > Network 
Configuration > SNMP Property Groups. This command does not 
begin with the currently active community string/user, it 
begins with the first string/user in the list.

Deploy Agent Sends the Agent to the device. 

Upgrade Agent Upgrades the Agent on the device. 

Upgrade Scanner Transfers the relevant scanner executable and configuration 
files to the device, then execute the scanner and finally transfer 
the resulting scan file to the Enterprise Discovery server. 

Run Scanner Requests the immediate Enterprise Discovery scan of this 
device.

Retrieve Scan File Transfers the result of the latest scan from the device to the 
Enterprise Discovery server.

Uninstall Agent Removes the Agent from the device. To verify that it has been 
uninstalled, try to do an Agent Ping on the Diagnosis panel. 
Once the Agent is uninstalled, the Agent-related options will 
disappear from the Update Model panel’s pull-down list. 

Enrich XML Requests immediate enrichment of the scan file associated with 
this device. 

Run Rulebase Allows you to only re-check the Enterprise Discovery rulebase 
for this device.

On the Query Network panel, you will see a list of alarms associated with this device. The 
following is a list of all possible options that you can see. If doing an Update Model on a new 
device, there may be a delay of as much as 1–2 hours before the device appears on the 
Network Map.
82 Chapter 7



When to use it

• When you’ve made physical changes to a device—for example, when you’ve changed cards 
in a router.

• When you’ve made changes to a device’s community strings/users.

Limits

The device must have an IP address. If not, this button is dimmed.

Related

To determine when these commands have been run (either manually or automatically by 
Enterprise Discovery) see the Diagnosis panel. It lists all the relevant information. 

State Message

major alarm IP address is not in scope

major alarm no read community strings/users have been specified

minor alarm no write community strings/users have been specified

minor alarm IP address is not in scope for resource management

info current discovery process

info list of read community strings/users to be tried

info list of write community strings/users to be tried

info update interval

info mean time to update model
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8 Using the Port Manager
To select a different port for the same device, use the port list box.

Provides you with detailed information about a device’s ports, in one of several panels.

Administrator or IT Manager: Also enables you to change the way Enterprise Discovery 
perceives a connection.

To open the Port Manager:

List of Port Manager Panels

This is a complete list of panels available in the Port Manager. Click the hyperlinks in this 
table to read more information on these entries.

The Port Manager enables you to change only Enterprise Discovery’s perception of a 
connection. The Port Manager does not change the physical connection.

From Open by...

Device Manager (State or 
Port panel), Reports

Click a port hyperlink. 

Network Map Right-click a line.

Events Browser, Alarms 
Viewer

Double-click a port number. 

Many of the panels in the Port Manager feature data in table form. Not all tables will look the 
same for all ports, because the tables will only show data that is available for that port. 
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Icon Button name Description

Configuration This panel identifies a port and presents an overview of the 
port’s identity and properties.
For more information, see page 87. 

Reports This panel displays current values for report and summary 
historical data. Displays alarm signals even when the device 
priority is less than the minimum priority for a configuration 
(unlike in map windows).
For more information, see page 88. 

Diagnosis This panel displays information about the current state of the 
port that can be helpful in diagnosing problems with 
Enterprise Discovery.
For more information, see page 89. 

Events This button opens the Events Browser with this device and 
port in context.
For more information, see Using the Events Browser on 
page 57.

Locate This button highlights in a map window the location of the 
device.
If a map session was not open already, one will open now. 
Within the map window, the device you are locating has a 
yellow circle around it.
If the window containing the device was already open, that 
window becomes the front-most window, and the window 
scrolls so that the highlighted icon can be seen.
NOTE: This button is only available if the Topology license is 
present.

Purge Port This panel lets you remove the port from the device’s model as 
created by Enterprise Discovery.
For more information, see page 92. 

Create Connection 
(Administrator or IT 
Manager)

For more information, see page 92. 
NOTE: This button is only available if the Topology license is 
present.

Break Connection 
(Administrator or IT 
Manager)

For more information, see page 93. 
NOTE: This button is only available if the Topology license is 
present.

Port Properties You can use the Properties dialog to change how Enterprise 
Discovery sees this port.
For more information, see page 93. 
86 Chapter 8



Configuration

This panel identifies a port and presents an overview of the port’s identity and properties.

This panel is divided into these main sections:

• Connectivity table

• Identity table

• VLAN table

Connectivity

Most information in this table comes from the Enterprise Discovery Rulebase.

Refresh This button refreshes the contents of the panel.
Does not re-read the data in the panel from the network. 
Re-reads the data only from the Enterprise Discovery 
database.

Print This button prints the contents of the panel.

Close This button closes the window and exits the Port Manager.

Port number This pull-down list allows you to select from the valid port 
numbers for this device.
Note: The number Enterprise Discovery uses for the port may 
not match the physical port.
On your Cisco devices, the Cisco naming convention is 
displayed (for example, “Tu1” for Tunnel 1, or “Fa0/1” for Fast 
Ethernet 1). 

Icon Button name Description

Data Example Notes

Connected to the selected port is 
connected to another device 
on this port

hyperlinked to Device Manager, Port 
Manager, and Line Manager
NOTE: This column is only displayed 
when the Topology license is present

Description 100Base-TX Port from device manufacturer

MTU 1500 from device

Interface type Ethernet CSMA/CD from device MIB/Enterprise Discovery 
Rulebase
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Identity

This table identifies the port and the manufacturer of the device:

• MAC address of the port

• OUI of the device/card (alphabetic abbreviation of the device manufacturer)

• Manufacturer of the device, hyperlinked to manufacturer’s web site

• IP address of the port

• Netmask of the port

• Domain Name of the port

VLAN data

VLANs are software-defined broadcast domains, created by your System Administrator at the 
switch. By showing VLAN information in Enterprise Discovery, the Administrator can see 
how the devices in that virtual domain are configured. 

Reports

This panel displays current values for report and summary historical data. Displays alarm 
signals even when the device priority is less than the minimum priority for a configuration 
(unlike in map windows).

This ‘report’ data is historical information. You can use the data on this panel in conjunction 
with the State panel to look for problem trends in your device.

Limits

This panel is not available if the object is not in the Enterprise Discovery database.

Line alarm type Ethernet 100 HD from device MIB/Enterprise Discovery 
Rulebase

Interface rate 100 Mbits/sec. from device MIB/Enterprise Discovery 
Rulebase

Duplex Half Half | Full

Autonegotiation Auto negotiate  - 

Data Example Notes
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State

Lists ‘report’ data like adds, deletes, and changes, lets the user know if any of these are in an 
alarm state (info, minor, major, critical).

Diagnosis

This panel displays information about the current state of the port that can be helpful in 
diagnosing problems with Enterprise Discovery.

This panel is divided into these main sections:

• Main table

• Property Assignment

Main table

The main table indicates the data flow for this port—when the device was first and most 
recently seen by various parts of Enterprise Discovery—plus the current values for several 
parameters.

Data Notes

Report name Exceptionsa, Device Adds, Device Deletes, Device Movesb, 
Device Changes, Not Recently Seen

a. For a full list of possible exceptions, see Help > Classifications > Exceptions.

b) Device moves are only reported when the Topology license is installed.

State OK, Info, Minor, Major, Critical

Value For exceptions:
description
effect
action

Data Output Notes

First discovered elapsed timea / absolute 
date & time

resets if database is cleared

Added to map elapsed time / absolute date 
& time

resets if the device is deactivated/
hidden, but returns to the map

Last moved elapsed time / absolute date 
& time

the last time a connection to this 
device changed
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Network model 
last updated

elapsed time / absolute date 
& time

the last time the model changed; 
determines whether or not the 
model has been for this device

Scanner model 
last updated

elapsed time / absolute date 
& time

—

Last deactivated 
or hidden

elapsed time / absolute date 
& time

the last time a device was 
deactivated or hidden

Mean break 
diagnosis time

time for alarms —

ARP tables seen elapsed time / absolute date 
& time

—

Bridge tables 
seen

elapsed time / absolute date 
& time

—

Source address 
capture seen

elapsed time / absolute date 
& time

—

Radio link seen elapsed time / absolute date 
& time

—

Bus link seen elapsed time / absolute date 
& time

—

Carrier link seen elapsed time / absolute date 
& time

—

Link training 
seen

elapsed time / absolute date 
& time

—

Data Output Notes
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Property Assignment

The Property Assignment table displays the Default settings, and will display any overrides 
that have been performed through External means such as Web Services, or by an Admin user 
through the Device Properties feature. 

Detailed link 
training seen

elapsed time / absolute date 
& time

—

Connection 
method

bridge tables
source address capture
traffic
link training
logical subnet
approximate; see “Terms 
and Concepts” in the 
Reference Guide. 
user-defined
unknown

—

Previously 
connected to

none
device (real or virtual), 
hyperlinked to Device 
Manager
device and port, hyperlinked 
to the Device Manager and 
Port Manager

if blank, the device is no longer in 
the database, or the connection 
has never changed

a.  As elapsed time increases, the finer units of measure are not reported.

Data Output Notes

Parameter Notes

Interface Rate The interface rate (default, external, and 
user-assigned)

Interface Type The interface type (default, external, and 
user-assigned)

Line Alarm Type The line alarm type (default, external, and 
user-assigned)

Duplex Mode The duplex mode (default, external, and user-assigned)
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Purge Port

This panel lets you remove the port from the device’s model as created by Enterprise 
Discovery.

When to use it

When a port has been removed from the network and you wish to update Enterprise 
Discovery’s representation of the device.

Effects

• Deletes the statistical history associated with the port. This in turn affects the graphs and 
reports for this port.

• Deletes the events associated with the port from the event log.

• breaks the connection on the port

Related

• To break a connection between ports, see Break Connection (Administrator or IT 
Manager) on page 93.

• To purge an attribute or a device, see the Configuration and Customization Guide.

Create Connection (Administrator or IT Manager)

This panel lets you force a new connection. You can create a connection to a real device or to a 
virtual device.

Create connection does not change the physical connection on the device; they change only 
how Enterprise Discovery represents the connection on the Network Map.

Connections changes take effect at the end of the current sampling period.

Effects

This action cannot be undone.

You are not making a physical change to the port. If you purge a port but the port is still 
operational, the port will be rediscovered and will reappear. 

This panel is only available if the Topology license is present.

You can create a virtual device by creating a connection to a nonexistent virtual device.

Do not create a connection to another real device except as a last resort. If you force a 
connection prematurely, you could slow Enterprise Discovery down or even make it 
impossible for Enterprise Discovery to correctly connect to your network. Never use forcing a 
connection as a quick fix.
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Forcing a new connection first breaks any existing connection. 

When to use it

When Enterprise Discovery has made incorrect assumptions about connectivity.

Break Connection (Administrator or IT Manager)

This panel lets you break an existing connection.

Breaking a connection does not change the physical connection on the device; they change 
only how Enterprise Discovery represents the connection on the Network Map.

When to use it

When Enterprise Discovery has made incorrect assumptions about connectivity.

Port Properties

You can use the Properties dialog to change how Enterprise Discovery sees this port. 

Interface Rate 

Sets rate for a line interface.

When to use it

• When you want to set a custom line speed

• When Enterprise Discovery has set the wrong line speed.

Limits

0 bit/sec.–1 Tbit/sec.

Effects

Interface rate affects utilization statistics.

Do not create a connection without consulting your Enterprise Discovery Customer Support 
representative. If you force a connection, Enterprise Discovery may not be able to correctly 
connect your network devices. 

An exception: you may create connections to ports external to your network (for example, to 
your ISP) to ensure that the line break is reported.

This panel is only available if the Topology license is present.
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Interface Type 

Sets the media type used for the line.

When to use it

• When Enterprise Discovery does not recognize the type of interface for the line.

• When Enterprise Discovery has set the wrong interface type for the line.

Limits

Enterprise Discovery assigns a default duplex to each interface type. 

Related

To change the duplex mode, see Duplex Mode on page 94.

Line Alarm Type 

Sets the line alarm type for the connection. The line alarm type is normally associated with 
the interface type, but may be changed independently.

When to use it

When the default line alarm type associated with the interface is inappropriate.

Duplex Mode 

Sets the duplex to full or half. Full duplex allows for two-way communication over a line; half 
duplex permits only one-way communication.

When to use it

When Enterprise Discovery has set the wrong duplex. This changes how Enterprise Discovery 
interprets the duplex mode, not the setting on the actual port. 

Limits

Full | Half

Abbreviation Expanded form

ATM asynchronous transfer mode

DSL digital subscriber line

FD full duplex

FDDI fiber distributed data interface

HD half duplex

LAN local area network

SPN switched packet network
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Effects

Duplex affects utilization statistics.
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9 Using the Line Manager
Enterprise Discovery has two different Line Managers:

• Single Line Manager on page 97

• Multiple Line Manager on page 99

Single Line Manager

The single Line Manager provides you with detailed information about the two devices on 
either side of a connection.

The line can be between:

• the ports on two known devices

• a port on a known device and an unknown port on a device

• unknown ports on two devices
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To open the Line Manager:

List of Line Manager Panels

This is a complete list of panels available in the Line Manager. Click the hyperlinks in this 
table to read more information on these entries. 

About

This panel shows two columns. In each column are a device and the relevant port for that 
device. If the Line Manager was opened by the Device Manager or Port Manager, the left 
column contains the device that was in context for the other Manager.

Underneath the heading is a single line that explains how the connection was made. This is 
identical to the “Connection method” row in the Port Manager panel for Diagnosis on page 89.

From Open by...

Network Map Double-click a line, or right-click a line. 

Service Analyzer Click a line. 

Device Manager, Port 
Manager

Click a [line] hyperlink. 

Report Click a [line] hyperlink. 

Icon Button name

About This panel shows two columns. In each column are a device 
and the relevant port for that device. If the Line Manager was 
opened by the Device Manager or Port Manager, the left 
column contains the device that was in context for the other 
Manager.

Break Connection 
(Administrator or IT 
Manager)

This panel lets you break an existing connection.

Refresh This button refreshes the contents of the panel.
Note: Does not re-read the data in the panel from the 
network. Re-reads the data only from the Enterprise 
Discovery database.

Print This button prints the contents of the panel.

Close This button closes the window and exits the Line Manager.
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Attribute name, unit, and value

Displays the current statistics for any attribute available. 

These values are refreshed at the end of each poll cycle and may change each time they are 
viewed.

The metrics tables presented here is similar to the ones that would appear in the Device 
Manager and Port Manager’s State panel for each device port. The only difference here is the 
absence of the “update time column.”

Break Connection (Administrator or IT Manager)

This panel lets you break an existing connection.

When to use it

When Enterprise Discovery has made incorrect assumptions about connectivity.

Related

See also the Port Manager Break Connection (Administrator or IT Manager) on page 93.

Multiple Line Manager

The multiline window opens when a line represents multiple connections between:

• two devices

• a device and a package

At the top of the multiline window is a graphic (looking like the Network Map), showing you 
the connected devices. Below the graphic is a table detailing all the connections. 

It is important to understand that metrics for the two device ports will probably not match 
exactly. This is because the statistics for each device are not collected at the same time. 
Although there is rarely an exact match, the two sets of statistics should however be 
approximately equal, with in/out values reversed.
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By right-clicking on the port number, you can open a Port Manager or Single Line Manager. 
By right-clicking on a device name, you can open the Device Manager. 

Connections

Right-click to open a 
Line Manager or 
Port Manager
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10 Using the Attribute Manager
The Attribute Manager provides you with detailed history of an attribute associated with a 
device or a port.

Administrator or IT Manager: Also enables you to change the state of an attribute, and to 
change the way Enterprise Discovery perceives an attribute.

To open the Attribute Manager:

List of Attribute Manager Panels

This is a complete list of panels available in the Attribute Manager. Click the hyperlinks in 
this table to read more information on these entries. 

Virtual devices cannot have attributes.

From Open by...

Device Manager, Port 
Manager, Line Manager

Click an attribute hyperlink.

Events Browser, Alarms 
Viewer

Right-click an attribute or event on the list. 

Icon Button name Description

Configuration This panel identifies an attribute and presents details of its 
most recently observed state.

Locate This button highlights in a map window the location of the 
device.
If a map session was not open already, one will open now. 
Within the map window, the device you are locating has a 
yellow circle around it.
If the window containing the device was already open, that 
window becomes the front-most window, and the window 
scrolls so that the highlighted icon can be seen.

Manage 
(Administrator or IT 
Manager)

This panel lets you manage the attribute.
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Configuration

This panel identifies an attribute and presents details of its most recently observed state.

Identity

Purge Attribute 
(Administrator or IT 
Manager)

This panel lets you remove an attribute and its historical 
statistics from the Enterprise Discovery database.

Refresh This button refreshes the contents of the panel.
Note: Does not re-read the data in the panel from the 
network. Re-reads the data only from the Enterprise 
Discovery database.

Print This button prints the contents of the panel.

Close This button closes the window and exits the Attribute 
Manager.

Icon Button name Description

Element Notes Optional

Name for a complete list, see Help > Supported 
Device/Port Attributes

—

Description there can be multiples of an attribute (for 
example, disk, CPU, memory, toner)

Volume label —

Serial number —

Units varies according to the attribute, for 
example, time, percent, bytes/sec., frames/
sec., milliseconds, days and hours, 
gigabytes. Not applicable for Breaks

Minimum value —

Maximum value —

System threshold available only for those attributes tracked 
on the Health Panel
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For the Break attribute, there are two different times listed:

• The State Time represents the time when the attribute changed state (when the break 
occurred). 

• The Update Time represents the most recent time Enterprise Discovery has seen the 
problem (i.e. the time of the last poll cycle where the problem was still present). 

Manage (Administrator or IT Manager)

This panel lets you manage the attribute.

Examples: In the case of ports, Administrative Status can be turned on or off. In the case of 
the Bridge Aging Interval, the length of the interval can be changed.

Limits

• Available only when Enterprise Discovery has a write community string for the attribute.

• Not all attributes can be managed.

Default threshold available only for those attributes tracked 
on the Health Panel

State available only for those attributes tracked 
on the Health Panel

State Time available only for the Break attribute

Value — —

Update time — —

Forecast sample 
count

available only when using the Forecast 
feature

Forecast first 
sample

available only when using the Forecast 
feature

Forecast last 
sample

available only when using the Forecast 
feature

If a device had a partitioned disk, each partition will appear as a separate “Disk” attribute. 
You can open an Attribute Manager for each partition. Each partition will have a different 
disk serial number (assigned by the device OS). 

Element Notes Optional
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Purge Attribute (Administrator or IT Manager)

This panel lets you remove an attribute and its historical statistics from the Enterprise 
Discovery database.

When to use it

• When an attribute is no longer associated with a device or port.

• When you no longer wish to retain or examine the history of an attribute.

This action cannot be undone.

You are not making a physical change. If you purge an attribute but the attribute is still 
present—that is, still associated with a device or port that is still present in your network—
Enterprise Discovery will discover the attribute and the attribute will reappear. 
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11 Using the MIB Browser
The MIB Browser is a tool for the SNMP expert who knows what details to look for and how to 
look for them. 

The MIB (Management Information Base) is a set of data that can be managed with SNMP. If 
you have the proper credentials for a device, you can use the Enterprise Discovery MIB 
Browser to read or write data to the device MIB.

Enterprise Discovery has a database of MIB definitions that the MIB Browser uses. The MIB 
Browser’s private enterprises sub-tree contains placeholders for many of the vendors of 
network equipment who have non-standard or proprietary MIBs. 

Opening the MIB Browser

You can open a MIB Browser with or without a device in context. In other words, you can open 
a MIB Browser for a specific device, or you can open the MIB Browser and use its Find 
function to locate the device you want to see.

When you open a MIB Browser with a device in context, you will see the device icon, label and 
IP address in the right panel. It also shows the value of the “sysName” object from the MIB of 
that device. 

There are three ways to open a MIB Browser with a device in context:

• From the Device Manager, click the Browse MIB button. 

• From the Device Manager’s Configuration panel, click a [set] hyperlink. You must have 
Admin privileges.

• From any applet window (Network Map, Health Panel, and so on), click Device > Browse 
MIB. 

There are three ways to open a MIB Browser without a device in context:

• From the home page, click MIB Browser.

• From the MIB Browser, click File > New MIB Browser. 

• From any applet window (Network Map, Health Panel, and so on), click Tools > MIB 
Browser. 

In order to work, the device must have an IP address, and it must support basic SNMP 
functionality.
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Parts of the MIB Browser

MIB Browser example - Variable Panel:

1

2

3 4 6 7 8 9

10

11

12

5

13

14

15
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Tree View

The left hand side of a MIB Browser shows a tree view of all the MIBs for which Enterprise 
Discovery has definitions. These definitions are stored within the Enterprise Discovery server, 
independent of any one device in your network. You can browse through the definition tree 
even without an SNMP device in context, by clicking on those tree nodes. Each node 
represents one SNMP object, and the hierarchy of nodes reflects the SNMP object hierarchy. 
The name, object ID, type and description of each SNMP object is displayed on the right hand 
side. 

Pull-down list of Devices

You can toggle between devices in the MIB Browser with this pull-down list. The pull-down 
list will display the 10 most recent devices that have been displayed in any applet window.

Table 1 MIB Browser legend

Number Feature

1 MIB Tree View

2 MIB OID Description

3 Pull-down list of devices

4 Find (to locate devices)

5 Credentials (to view or add device credentials)

6 Locate on Map

7 Get Next

8 Refresh

9 Colored lamps represent when the MIB Browser is 
connecting with the server. 

10 SNMP Credentials (community string or user name)

11 Entry View

12 Move up a Level

13 OID number

14 Type of OID

15 Value of the OID

When there is an SNMP device in context (i.e. the device icon and IP address appear), 
clicking on a tree node will “Get” the value for that object from the device, if that object is 
supported. No one device supports all the objects in the MIB definition tree.
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Find Function

If you want to find a particular device to check its MIB, you can use the MIB Browser Find 
button. It works like the Find in the Network Map and other Enterprise Discovery features. 
Click the button, and a dialog appears. Enter the device name in the dialog and press Enter.

Credentials Function

If you want to view or add credentials for a particular device, click Credentials. The 
Credentials dialog opens.

This dialog lists all the community strings and users the administrator has assigned to this 
device by way of an SNMP Property Group. Click Create to create additional credentials for 
this device by specifying a community string or user name that you know is valid for that 
device. Click Copy if you want to duplicate and edit the credential information for the 
currently highlighted credential. The credentials you specify will apply for this one session 
and will not be added to the credentials that are associated with the SNMP Property Group 
for this device. See Read and Write Credentials on page 111.  

Locate on Map

The Locate button works like the Locate button in other Enterprise Discovery features. Click 
this button and you will see where this device is located on the Network Map.

When creating credentials for an SNMPv3 device, you must follow certain rules for the 
various fields that make up the credentials for that device. Refer to the “Setting up SNMP 
Property Groups” chapter in the Installation and Initial Setup Guide for the rules governing 
user name, algorithms, and pass phrases.
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Get Next

The Get Next button will assist you in moving through the list of MIB objects.

Refresh

The Refresh button should be used after you change a community string, or after you change 
the device in context by using the device pull-down list.

Folder Tab

Entry

Within an SNMP device, each supported object can have one or more entries, each of which 
has a value. For example, an object may define a column of a table, but each row of the column 
is a different value.

Each entry has an ID too, which defines how to index that entry within the object. The entry 
ID has the same syntax as an object ID. When a value is displayed, the “OID” field is actually 
the object ID followed by the entry ID. The “Name” field shows the name of the object followed 
by the entry ID. 

Try thinking of it this way. The tree view on the left hand side shows objects and their 
hierarchy. The right hand side shows the values of instances of objects. As you press Get 
Next, you may see several successive instances of the same object. 

For a given SNMP device, it is not possible to efficiently determine which MIB definitions it 
supports. It is only by “MIB walking” (using the Get Next button) a device that its supported 
objects can be determined. Thus the MIB Browser displays the same tree of MIB definitions 
for all devices, but not all of it is valid for any one device. 
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The pull-down list will let you choose how the entries are displayed in the Folder Tab. By 
choosing All, you will see a list of all the entries, in numerical order. Also, you can select an 
entry number (for example, “.1”) and see only the object values for .1 entries. 

Move Up a Level

This button will move you up one level in the MIB tree view. 

Variable Tab

Read/Get

The Read area of the Variable tab displays the currently selected OID. If you want to update 
the view of that OID, click the Get button.

Write

IT Manager and Administrator accounts can write to a device MIB.

Some devices may have a directed community string, which means they will only accept 
SNMP operations from specific devices. The network administrator may have created directed 
community strings that will allow only the Enterprise Discovery server access to the devices 
on your network. 

Entry setting to 
“All”

Entry setting to 
“.1”

Remember that although the MIB Browser GUI runs on a user's workstation, it is actually 
the Enterprise Discovery server that performs the SNMP Set and Get. A malicious user with 
the MIB Browser could leverage the Enterprise Discovery server to effectively bypass the 
protection of a directed community string. Thus it is a potential security breach to allow a 
user other than Administrator or IT Manager to do a Set with the MIB Browser. 
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To change a MIB entry:

1 In the MIB Browser Folder panel, select an OID.

2 Click the Variable panel.

The Variable panel will show you the current definition for the OID.

3 Select the correct Write credentials. 

4 In the Write section, enter a new definition for that OID. 

5 Click Set.

Find OID

When you select an OID in the tree view, the OID will also appear in the “Find OID” text box. 
Click the Next button to move through the MIB, like you would with the Get Next button at the 
top of the panel.

To go to a specific OID, you can change the OID in the “Find OID” text box, and click Next. The 
MIB Browser will go directly to that object entry. 

MIB Description

This area provides the standard description for each MIB object. 

Sometimes, especially when first learning about MIBs, it is educational to view just the 
description of an object. Open a MIB Browser without a device in context, and you can see all 
the MIB descriptions available. 

Read and Write Credentials

Your ability to read or write MIB data depends on your account type.

Demo and IT Employee accounts can only read MIB data. They can do this with the “public” 
read community string for SNMPv2 devices. IT Employee accounts have the ability to enter 
temporary credentials for SMNMPv3 devices. There is no default SNMPv3 credentials for the 
Demo account.

IT Manager and Administrator accounts have full read/write access, as long as you have the 
correct credentials. 

The MIB Browser Read Write pull-down lists display the network community strings and 
users you created in Administration > Network configuration > SNMP Property Groups. This 
procedure is described in the Installation and Initial Setup Guide.

The MIB Browser requests the complete list of credentials, as supplied on the SNMP Property 
Groups page, and takes from that list all strings and users that apply to the device in context. 
For example, if the SNMP Property Groups page lists the following strings for the network 
being explored: 

• public (r), for 0.0.0.0-255.255.255.255

• private (w), for 192.168.0.0-192.168.9.255

• su_only (r/w), for 192.168.0.0-192.168.0.255

• OnTheHalves (r/w), for 192.168.1.0-192.168.1.255
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then the device 192.168.1.32 will show the following strings:

• public (r)

• private (w)

• OnTheHalves (r/w)

The string “su_only (r/w)” will not appear in this window since the device's IP address 
(192.168.1.32) is outside the range of the string (192.168.0.0-192.168.0.255). 

If necessary, you can enter new credentials for the device by clicking Credentials in the MIB 
Browser as described in Credentials Function on page 108.

As Enterprise Discovery discovers the managed devices in your network, it uses the read 
credentials that you have configured to read the MIBs of those devices. The MIB Browser 
automatically uses the read credentials that Enterprise Discovery has determined is valid for 
that device. 

However, if that device is not yet known to Enterprise Discovery, then Enterprise Discovery 
does not know the valid read credentials for that device, and you need to create new 
credentials by clicking Credentials. 

The situation is a bit different for write credentials. Enterprise Discovery must have valid 
read credentials to discover a managed device, but valid write credentials are optional. 
Enterprise Discovery tries to determine valid write credentials for each managed device from 
the list of credentials in the Network Configuration menu. If it finds one, the MIB Browser uses 
it, but otherwise the MIB Browser has no current write credentials.

Walking the MIB

The Get Next button requests the value of the next SNMP object instance supported by this 
device. You may have noticed that as you push Get Next, the tree is expanded as necessary to 
keep the current object highlighted. Sometimes the next object a device supports is not the 
next item in the MIB tree because no one device supports all the objects in the MIB definition 
tree; some parts of the MIB tree are not relevant for any given device. These irrelevant 
sections of the MIB tree get skipped.

If there is no data available for a MIB object, the Value column will appear gray. If the 
community string does not allow you access to the MIB, you will see “no response.”

If there is a “no response” message, the SNMP device did not respond to a Get, Get Next, or 
Set request. There are a few reasons for this error: 

• The device does not have an SNMP agent; in other words the device is not managed. 

• The device has an SNMP agent, but it did not respond to the request within a certain 
amount of time. Some devices drop management requests when they are too busy 
handling their network traffic. 

• The community string being used by the MIB Browser is incorrect. Perhaps someone 
recently changed the device's community string and Enterprise Discovery has not yet, or 
cannot, determine a valid one. 

Community strings are case-sensitive. “Public” and “public” are two different strings. 

If at any time you change the credentials that you are using to view the MIB, click the Refresh 
button. 
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• The device supports directed community strings, and Enterprise Discovery is not on the 
access list. 

Unfortunately, the SNMP protocol does not distinguish amongst these conditions. 

Using Multiple MIB Browser Sessions

You can have more than one MIB Browser window open at any time. Also, you can toggle 
between several devices in the “found device” pull-down list at the top-left of the MIB Browser 
window. 

To open a new MIB Browser session from your current MIB Browser window, click File > New 
MIB Browser. 

Watching an OID with MIB Radar

You can use the MIB Radar feature to watch a particular MIB object in a separate small 
window on your screen. If you want to monitor one counter in the MIB (for example, 
sysUpTime), you can select that OID and then click File > Open Radar. The radar window will 
appear, which looks like this:

You can change the refresh rate by entering a number (5 or higher) in the text box. Also, you 
can view the history of the OID by clicking on the Show History button. 

Saving MIB Data as a Text file

There are two ways you can save MIB Browser data to a text file:

• Save Table Data

• MIB Walk

By default, the data refreshes every 30 seconds.

Click 
Show 
History 
button
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Save Table Data

You can use the Save Table Data feature to save selected info into a tab-separated-value (.tsv) 
file. This feature can also be found in the Health Panel, MIB Browser, Alarms Viewer, Service 
Analyzer, and Events Browser.

You can save the entire contents of a MIB Browser table, or you can Ctrl-click to select the 
OIDs you want to save. 

Saving data to a text file

1 Select the MIB OIDs you want to save. 

2 Click File > Save Table Data.

A Save Table Data dialog appears.

3 Select a file name and location for the text files.

4 Click Save. 

MIB Walk

You can use the MIB Walk feature to save a sub-tree from the MIB Browser as a text (.txt) file.

Saving a MIB Walk:

1 Click File > Open Walk. 

The MIB Walk dialog appears.

2 Enter an OID that represents the start of the sub-tree you want to save. 

3 Click Browse to select a name and location for your output file. 

4 Click Walk. 
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12 Using the Scan Data Viewer
The Scan Data Viewer displays detailed information contained in the Discovery Database, 
data compiled from Enterprise Discovery’s discovery and scanning processes.  This provides a 
convenient way of displaying software, hardware and asset information collected for an 
individual device. 

In summary, the Scan Data Viewer displays:

• Detailed and summarized hardware configuration information.

• Asset information.

• Details of all software scanned.

• Software Utilization data (if you have a Utilization license).

Opening the Scan Data Viewer

You can open a Scan Data Viewer with or without a device in context. In other words, you can 
open a Scan Data Viewer for a specific device, or you can open the Scan Data Viewer and use 
its Find function to locate the device you want to see.

There are three ways to open a Scan Data Viewer with a device in context:

• From the main navigation tree, click on Devices with Scan files. From the Device Manager, 
click the View Scan Data button.

• From any applet window (Network Map, Health Panel, and so on), click Device > View Scan 
Data. 

There are three ways to open a Scan Data Viewer without a device in context:

• From the main navigation tree, click Scan Data Viewer.

• From the Scan Data Viewer, click File > New Scan Data Viewer. 

• From any applet window (Network Map, Health Panel, and so on), click Tools > Scan Data 
Viewer. 

When you open a Scan Data Viewer with a device in context, you will see the device icon, title,  
IP address, and asset tag in the top panel. It also shows the following values:

• OS

• CPU

• Memory

• Disk

The Scan Data Viewer is similar to the Viewer (part of the Enterprise Discovery client). They 
both show similar information, but the Scan Data Viewer is accessible through the web user 
interface. 
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Parts of the Scan Data Viewer

Pull-down list of Devices

You can toggle between devices in the Scan Data Viewer with this pull-down list. This list 
records the 10 devices that have been most recently used in any applet window.

Find Function

If you want to find a particular device to load its scan file, you can use the Scan Data Viewer 
Find button. It works like the Find in the Network Map and other Enterprise Discovery 
features. Click the button, and a dialog appears. Enter the device name in the dialog and 
press Enter.

Any devices that have been found, but for which there is no scan data in the database, will be 
grayed out and cannot be opened.

Locate on Map

The Locate button works like the Locate button in other Enterprise Discovery features. Click 
this button and you will see where this device is located on the Network Map.

Refresh

The Refresh button launches a new request to the database to fetch the information again. A 
refresh will be done automatically when the device changes. It is not necessary to do it 
manually.

Using Multiple Scan Data Viewer Sessions

You can have more than one Scan Data Viewer window open at any time. Also, you can toggle 
between several devices in the “found device” pull-down list at the top-left of the Scan Data 
Viewer window. 

To open a new Scan Data Viewer session from your current Scan Data Viewer window, click 
File > New Scan Data Viewer. 
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Menu commands

Viewing Hardware and Configuration Data

Hardware and Configuration Data Page Overview

The Hardware and Configuration tab displays:

• User and asset information collected using the asset questionnaire during the inventory.

• High level hardware information scanned during the inventory.

Further Information

• For a detailed list of all the hardware items scanned see the document entitled Data 
collected by the Scanners.

Table 1 Menu commands in the Scan Data Viewer

Command Description

Print command in File menu This command will print the table currently displayed.

Save Table Data in File menu This command will output tab-separated data to a file.

Copy in Edit menu This command will copy the selected table rows to the 
clipboard.
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The Hardware and Configuration Tab Page Layout

The left hand side of a Scan Data Viewer shows a tree view of all the Hardware and Asset 
data items for which Enterprise Discovery has definitions. All data shown is from the scan 
date shown at the bottom of the page.

You can browse through the hardware definition tree even without a device in context, by 
clicking on those tree nodes. Each node usually represents one hardware object. Those nodes 
with a red “i” indicate multiple values for that node, which often represent multiple hardware 
objects. The Item Number, Name and Value of the scanned data item is displayed on the right 
hand side.

Asset data is displayed in the first folder under Hardware data. The asset data to be collected 
is configured in the Web Asset Questionnaire, or in old scan files.

The information includes details about users, departments, physical assets, equipment, and 
any other information that is useful to record.

A description of the scanned data item can be found in the bottom pane.

Pull-down list of 
devices

Find 
function

Move up a level
Refresh

Locate on 
Map

Hardware 
definition 
tree

Hardware 
information

Hardware 
description

Scan Date Scanner Version
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A detailed list of all the hardware items scanned and descriptions for all of these can be found 
in the document entitled Data Collected by the Scanners.

Move Up a Level

This button will move you up one level in the Scan Data Viewer tree view. 

Viewing Software Application Data

The Software Applications tab displays applications that have been recognized by the 
Software Applications Index.

All data shown is from the scan date shown at the bottom of the page.

Information shown in the Application data window

The following information is shown about each software application:

• Application

Application 
Information

Directory 
information

Last Used information

Dir button

Scan Date Scanner Version
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The name of the software application.

• Version

The application version

• Release

The application release

• OS

The operating system the application was running on.

• Language

The name of the language of the application.

• Publisher

The name of the software publisher (for example, Microsoft, IBM).

Two fields at the bottom of the page show the following information for an application:

• Directory

The directory on the scanned machine where the application was installed.

• Last Used

The last time the file was accessed - (yyyy/mm/dd) (hrs:mins)

The Dir button

If this button is clicked the view presented will change to display the following columns:

• Application

• Version

• Directory

• Last used
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Software Utilization

The Viewer shows per-user application utilization data (select a particular user from the User 
pull-down list).

This information is only available if the software utilization agent plug-in was running on the 
computer which was scanned. 

To view application utilization data:

Select the user you want to see data for from the drop-down list. The following information is 
shown for how users utilized a particular application.

• Application

• Version

• Utilization

The number of days that the application was used (as a percentage) over a period of time. 
The period is calculated automatically depending on how long the application was used 
for. As a rough guideline the time periods are as follows:

• Application used for more than 3 months - utilization is calculated over the year.

Utilization 
Information

Scan Date
Scanner Version

User 
pull-down 
list

See the Scan Data Analysis Guide for more information on the Win32 Viewer, and software 
utilization. 
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If the earliest application usage recorded is more than 3 months old, but less than 1 
year (i.e. there was a record that the application was used more than 3 months ago, 
but less than a year ago), an annual figure will be used (number of days used in the 
last year / 365) 

• Application used for less than 3 months but more than 1 month - utilization is 
calculated over a quarterly period.

If the earliest usage recorded is less than 3 months, but greater than 1 month, a 
quarterly figure is used (number of days used in the last quarter / 90). 

• Application used for less than one month - utilization is calculated monthly

A monthly figure is used here (number of days used in the last month / 31)

• Used31

The number of days the application was used in the last month.

• Used90

The number of days the application was used in the last quarter.

• Used 365

The number of days the application was used in the last year.

• Avg Hrs

The daily average in hours over the period configured.

• Peak Hrs

The highest daily number in hours over the period configured. 

• Hrs31

The number of hours the application was used in the last month.

• Hrs90

The number of hours the application was used in the last quarter.

• Hrs365

The number of hours the application was used in the last year.
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13 Using the Reports
Enterprise Discovery provides numerous reports to help you analyze and understand what is 
contained in your network. 

Enterprise Discovery reports comprise the following groups: 

Table 1 Enterprise Discovery Reports

Report Category Explanation

Executive/Summary Network Reports 
on page 125

These reports are intended as a general overview 
of what is in your network. You can see lists of all 
your network devices. 

Scanned Device Reports on page 127 If you use Enterprise Discovery to scan devices in 
your network, these reports show data about the 
applications on those devices, and data on any 
unrecognized files. 

WAN Reports on page 130 These reports show information about your Frame 
Relay, Point to Point Serial, and other WAN 
connections in your network. 

LAN Reports on page 131 These reports show information about your FDDI 
and Token Ring connections in your network. 

Device Reports on page 131 These reports show inventory information. 
  123



Report periods

There are two types of report, summary and detail. Both report types have a different group of 
reporting periods. 

Table 2 Report Periods

Period Contents Generated Summary Detail

Today data for today and yesterday each houra

a. For a restricted period: 0600–2000 (6 AM–8 PM).

—

Yesterday data for the previous 24 hours each day after 
midnight

—

Last 7 
Days

data for the previous 7 days, 
starting yesterday (not including 
today)

each day after 
midnight

Last Week data for the previous week (weeks 
begin each Monday)

each Monday

This 
Month

data for the days in the current 
month, starting yesterday (not 
including today)

each day after 
midnight

—

Last 
Month

data for the previous calendar 
month

on the first day of 
each month
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Report statistics

Many reports feature bar graphs and values for three statistics: the peak, the mean peak, and 
the mean.

A mean value and a peak value are collected for every sample. At the end of the report period, 
all peak values are used to calculate the mean peak.

Imagine that we record a mean value and a peak value three times a day:

To obtain the mean peak for the day, we take the peak values of 6.0, 7.0, and 6.0, and find the 
mean of those three values, which is 6.3.

Different report periods have different statistical sampling periods. For example, a report 
with the period “Yesterday” takes samples every five minutes. 

Executive/Summary Network Reports

Executive Summary reports are about the network as a whole. Here is one example of how 
you might use them—just to see what’s in your network.

To view the Executive/Summary Network Inventory Reports

• Click Reports > Network Documentation > Device Inventory Summary

• Or click Reports > Network Documentation > Device Inventory 

You may have very little idea of what is actually in your network beyond the core network 
devices:

• There may be several people responsible for the network.

• Someone or several people may be adding equipment without informing you.

• You may be new to the job and the last person didn’t keep complete records or records you 
can understand.

• Some or all of the network management may have been delegated to someone outside your 
organization.

• You may be outside the organization whose network you must manage.

The Device Inventory Summary report tells you what is in your network, and the Device 
Inventory report tells you in more detail.

Table 3 Statistics Example

Value first second third

Mean 2.0 2.0 3.0

Peak 6.0 7.0 6.0
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The following Reports are available:

Folder Report Type

Network 
Documentation

Network Classification pie graph, 
table

Network Devices by Function pie graph, 
table

End Nodes by Function pie graph, 
table

Device Inventory Summary table

Device Inventory by Category table

Device Inventory by UNSPSC pie graph, 
table

Device Inventory by Virtual 
LAN

table

Port Inventory by Virtual LAN table

Device Inventory list

Frame Relay PVC Inventory table

Possible Modems Report list
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Scanned Device Reports

Scanned Device Summaries

These reports display summary counts of the scanned devices grouped by different device 
properties. For example, devices at the top level may be grouped by their company division, in 
turn by their office location within that division, and finally by the department to which they 
belong. 

The summary reports provide drill-down to details of those devices which belong to the 
summary group clicked on.

Summary report by Division, Location, Department

This report lists summary counts for all scanned devices by Division, Location, and 
Department.

Clicking on a summary count for a Division, Location, or Department will display a report of 
devices belonging to those categories summarized and sorted by any lower level categories. 
For example, clicking on a location count will display all devices at that location and division 
sorted by department. 

Clicking on the Total Scanned Devices count at the bottom of the report will display a report 
of all scanned devices sorted by division, location, and department.

Summary Report By Location, Division, Department

This report lists summary counts for all scanned devices by Location, Division, and 
Department. 

Clicking on a summary count for a Location, Division, or Department will display a report of 
devices belonging to those categories summarized and sorted by any lower level categories. 
For example, clicking on a division count will display all devices at that division and location 
sorted by department. 

Clicking on the Total Scanned Devices count at the bottom of the report will display a report 
of all scanned devices sorted by location, division, and department. 

Summary Report By Department, Location

This report lists summary counts for all scanned devices by Department and Location. 

Clicking on a summary count for a Department or Location will display a report of devices 
belonging to those categories summarized and sorted by any lower level categories. For 
example, clicking on a department count will display all devices at that department sorted by 
location. 

Clicking on the Total Scanned Devices count at the bottom of the report will display a report 
of all scanned devices sorted by department and location. 

Summary Report By Location, Building, Floor

This report lists summary counts for all scanned devices by Location, Building, and Floor. 

If collection of the relevant Asset Data fields is not enabled, the data will be categorized as N/
A, making the reports less useful).
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Clicking on a summary count for a Location, Building, or Floor will display a report of devices 
belonging to those categories summarized and sorted by any lower level categories. For 
example, clicking on a building count will display all devices at that building and location 
sorted by floor. 

Clicking on the Total Scanned Devices count at the bottom of the report will display a report 
of all scanned devices sorted by location, building, and floor. 

Summary Report By Location, Cost Center 

This report lists summary counts for all scanned devices by Location and Cost Center. 

Clicking on a summary count for a Location or Cost Center will display a report of devices 
belonging to those categories summarized and sorted by any lower level categories. For 
example, clicking on a location count will display all devices for that location sorted by cost 
center. 

Clicking on the Total Scanned Devices count at the bottom of the report will display a report 
of all scanned devices sorted by location and cost center. 

Summary Report By Cost Center, Location

This report lists summary counts for all scanned devices by Cost Center and Location. 

Clicking on a summary count for a Cost Center or Location will display a report of devices 
belonging to those categories summarized and sorted by any lower level categories. For 
example, clicking on a cost center count will display all devices for that cost center sorted by 
location. 

Clicking on the Total Scanned Devices count at the bottom of the report will display a report 
of all scanned devices sorted by cost center and location. 

Summary Report By Operating System Category

This report lists summary counts for all scanned devices by Operating System Category. 

Clicking on a summary count for an Operating System category will display a detailed report 
of devices belonging to that Operating System category. 

Clicking on the Total Scanned Devices count at the bottom of the report will display a report 
of all scanned devices sorted by Operating System category.

Summary Report By Hardware Chassis Type

This report lists summary counts for all scanned devices by hardware chassis type. 

Clicking on a summary count for a chassis type will display a detailed report of devices 
belonging to that chassis type. 

Clicking on the Total Scanned Devices count at the bottom of the report will display a report 
of all scanned devices sorted by hardware chassis type.

Application Reports

These reports display software application license and installation counts for all installed 
applications grouped by application, application version, and application publisher. These 
reports also display whether there is usage data being collected for each application. 
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The reports also provide links to detailed reports of those scanned devices where the 
individual applications are installed.

These reports are based on Application Recognition performed by the XML Enricher.

To ensure that the data presented is sufficiently accurate, make sure that

• Application Recognition is enabled in the XML Enricher. 

• The Software Application Library used is up to date. 

License Counts by Application

This summary report displays all applications by publisher and application with counts of 
licenses required and installations for each application. This report also displays whether 
there is usage data being collected for each application.

Clicking in the Publisher column will display detailed version information about all of the 
publisher's applications. Clicking in the Application Name column will display the details of 
the different versions of that application. 

Top Applications

This report lists those applications requiring the largest number of licenses, sorted by number 
of licenses. This report also displays whether there is usage data being collected for each 
application.

Clicking in the Publisher column will display detailed version information about all of the 
publisher's applications. Clicking in the Application Name column will display the details of 
the different versions of that application.

Publishers Summary

This summary report lists all publishers sorted by name together with their application 
licenses required and installed application counts. 

Clicking on the publisher's name will display detail information for all of the publisher's 
applications. 

Top Publishers

This report lists the publishers with the greatest number of installed applications that 
require licenses. 

Clicking on the publisher's name will display detail information for all of the publisher's 
applications. 

Unrecognized Files

The unrecognized file reports display the files on your scanned devices that were not 
recognized as belonging to a known application. You can view the file data by Scanner Type or 
you can drill down to view the directories and devices where these files are located. 
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Unrecognized File Reports

These reports display the unrecognized files found on your scanned devices grouped by 
Scanner Platform. 

Devices with High Risk Files

These reports display the devices that have the greatest number of files considered to be high 
risk. These "high risk" files are the 100 files that are not recognized as belonging to any 
known software application that occur most often in the population of scanned devices. 

These devices are likely to be those devices that it will be most effective to teach to lower the 
number of unrecognized files. If you click on the link "[Export Analysis Workbench Load 
Script]", it will create a load script which will load the scan files for the 10 devices with the 
greatest number of high risk files into Analysis Workbench to begin the process of teaching. 

Clicking on the link "[View the 100 Highest Risk Files Present]" will display file details for the 
100 files considered highest risk used to rate each device for teaching. Clicking on the number 
in the column "# of the 100 Highest Risk Files ..." will display those files on that device that 
are in the group of 100 highest risk files. 

WAN Reports

Frame Relay reports, as an example, can tell you if you are getting the service you are paying 
for. Note, for instance, the Data Delivery Ratio Report, one of the detailed reports. The Data 
Delivery Ratio Report tells you which Permanent Virtual Circuits (PVCs) are dropping data 
and is a good guide to whether or not you are getting the Frame Relay service you are paying 
for and whether you could do with less.

To view a Data Delivery Ratio Report:

• Click Reports > WAN Reports > Frame Relay Service > Data Delivery Ratio

There are two report structures for WAN Reports:

• Frame Relay folder

• all other folders

Frame Relay Detail Reports

Inventory

Connected DLCI Inventory

Other Detail Reports

Inventory
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LAN Reports

You can get inventory reports for your LAN backbone, FDDI, or Token Ring. 

Device Reports

Device reports give you inventory information and information about availability, throughput 
and utilization, broken down by category of device. They can also give you such information as 
what servers are using the most memory for a given time.

Device Inventory reports are available for the following groupings of devices:

• Servers

• Routers

• Input and Output Devices

• Web Servers

The Inventory report exported to a CSV file reflects the default map configuration for the 
current account.

All other reports reflect the Prime map configuration and its packaging.
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Diagnosis
Device Manager panel, 73
Port Manager panel, 89
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E
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Events Browser, 57
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exporting data
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F
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family, 20

Find, 11
advanced, 20
MIB Browser, 108
Scan Data Viewer, 116

Find OID, 111
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forcing a connection, 92
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G
Get, 110

Get Next, 109, 112

H
Hardware data

viewing in viewer, 117

Health Panel, 22, 51
aggregator, 53
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hide inactive alarms, 53

Hide Inactive Alarms, 53

HTTP session, 81

I
icons, 23

appearance, 26
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found, 27
locked, 26
package, 25
selected, 27
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Interface Rate panel (Port Manager), 93

Interface Type panel (Port Manager), 94

IP address
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IP Ping
Device Manager button, 78

L
LAN Reports, 131

Layout, 30
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Line Manager, 97
About, 98
Break Connection, 99

link training, 91

Locate
MIB Browser button, 108
Scan Data Viewer button, 116

location, system, 70

Lock, 26, 36

locked objects, 26, 36
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M
Manage

Attribute Manager button, 103

map configuration, 39
change default, 44
copy, 43
default, 40
delete, 43
New, 41
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Entry, 109
find a device, 108
Find OID, 111
Folder tab, 109
Get, 110
Get Next, 109, 112
locate, 108
MIB description, 111
MIB radar, 113
opening, 105
pull-down list of devices, 107
refresh, 109
set, 110
tree view, 107
Variable tab, 110
write, 110

model, 20

multi-object packages, 34
create manually, 34

multiple IP addresses, 72

multiple lines, 99

My User Alarms Only, 52

N
name, system, 70

NetBIOS name, 20

NetBIOS workgroup, 20

network function, 20

Network Map
autosave, 41
colored ring, 26
customizing, 27
faded icon, 26
icons, 23
opening a configuration, 43
placing an object at top, 29
saving a map configuration, 41
starting a configuration, 41
Status Bar, 22

New MIB Browser
MIB Browser

New MIB Browser, 113

not seen device, 26

O
objects

placing at top of network, 29

Open Copy of Prime, 40

operating system, 20

P
Package, 34

packaging, 25, 33
map configuration files, 39
multi-object packages, 34

Pack command, 34

peak statistics, 125

ping button (Device Manager), 78

Port Manager
Alarm Type, 94
Break Connection, 93
Configuration, 87
Create Connection, 92
Diagnosis, 89
Duplex Mode, 94
Interface Rate, 93
Interface Type, 94
Purge Port, 92
Reports, 88

Ports panel (Device Manager), 81

Preferences
automatic packaging, 36

Prime map configuration, 40
saving, 42

priority
device

range, 25
reserved, 25

Progress Bar, 22

Promote, 30

properties
object

priority, 25

Purge Port (Port Manager), 92

R
Radar, 113
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business

device, 131
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WAN, 130
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Reports (Device Manager), 72

Reports (Port Manager), 88

ring, colored, 26

S
sampling period, 92

Save, 40

Save as Prime, 40

Save Table Data, 55

Scan Data
Device Manager button, 81

Scan Data Viewer, 115
find a device, 116
locate, 116
New Scan Data Viewer, 116
pull-down list of devices, 116
refresh, 116

selected objects, 27

Service Analyzer, 47

Set, 110

SNMP contact, 20

SNMP description, 20

SNMP location, 20

SNMP name, 20

SNMP Ping
Device Manager button, 79

SNMP serial number, 20

SNMP write by Attribute, 62

SNMP write by MIB OID, 62

Software Utilization, 121

source address capture, 91

speed, line
see  Interface Rate

Starting
Viewer, 115

Status Bar, 22

system contact, 70

system location, 70

system name, 70

T
table-based connection, 91

text file, saving data to, 55

title
device, 14

top of network, 29

Traceroute
Device Manager button, 78

traffic-based connection, 91

U
Unlock, 26, 36

Unpack, 35

Unpackage, 35

Unpack All, 35

Update Model button (Device Manager), 82

Utilization, 121

V
Variable Tab, 110

virtual device
creating, 92
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Device Manager button, 81

Write, 110
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