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Legal Notices 

Warranty 

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein. 

The information contained herein is subject to change without notice. 

Restricted Rights Legend 

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license. 

Copyright Notices 

© Copyright 1993-2006 Hewlett-Packard Development Company, L.P. 

For additional trademark information, see the Copyright chapter in the Reference Guide.  
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Support 

Peregrine Product Support 

You can obtain support information for products formerly produced by Peregrine as follows: 

• If you work with an HP OpenView Services Integrator (SVI) partner 
(www.hp.com/managementsoftware/svi_partner_list), contact your SVI agent. 

• If you have an active HP OpenView support contract, visit the HP OpenView Support site and use the 
Self-Solve Knowledge Search to find answers to technical questions. 

• For the latest information about support processes and tools available for products formerly produced by 
Peregrine, we encourage you to visit the HP-Peregrine Software Support web site at: 
www.hp.com/managementsoftware/peregrine_support 
where you can download the Customer Support Handbook. 

• Contact your HP Sales Representative if you have additional questions. 

HP OpenView Support 

You can visit the HP OpenView Support web site at: 

www.hp.com/managementsoftware/support 

HP OpenView online support provides an efficient way to access interactive technical support tools. As a 
valued support customer, you can benefit by using the support site to: 

• Search for knowledge documents of interest 

• Submit and track support cases and enhancement requests 

• Download software patches 

• Manage support contracts 

• Look up HP support contacts 

• Review information about available services 

• Enter into discussions with other software customers 

• Research and register for software training 

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.   

To find more information about access levels, go to:  
www.hp.com/managementsoftware/access_level 

To register for an HP Passport ID, go to: 
www.managementsoftware.hp.com/passport-registration.html
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HP OpenView Enterprise Discovery 

Release Notes 
Software version: 2.1 / 21 July 2006 

This document provides an overview of the changes made to Enterprise Discovery for version 2.1. It contains 
important information not included in the manuals or in online help. 

In This Version 

Documentation Updates 

Installation Notes 

Enhancements and Fixes 

Known Problems, Limitations, and Workarounds 



2 

In This Version 

Introduction 

These release notes are for Enterprise Discovery 2.1. This new version of Enterprise Discovery is the 
upgrade path for users of Enterprise Discovery 2.0.x, and users of Network Discovery 5.2.5.  

If you have been using Network Discovery 5.2.5, some of the “new features” of Enterprise Discovery 2.1 will 
not be new to you. For example, the Network Map has been available in Network Discovery, but has now 
been introduced in Enterprise Discovery.  

If you would like to see what other features have been introduced in Enterprise Discovery 2.0, 2.0.1, 2.0.2, 
and 2.0.3, you can read the Release Notes for those versions, available on your installation CD under 
bin\documentation.  

Rebranding 

This is the first version of Enterprise Discovery to be released as a part of Hewlett-Packard’s OpenView 
suite of products. If you are upgrading from a previous version of the Enterprise Discovery product, you will 
notice several changes as a result of the rebranding.  

• All logos and graphics have been changed to meet HP standards.  

• All the Windows services have been renamed. All the services contained the Peregrine name, and now 
they are all labeled with the name “HP OpenView.” Also, all the short names have been renamed from 
having a “prgn” prefix to a new “oved” prefix.  

• Under the Windows Start menu, the software has been renamed “HP OpenView.” 

• The default install directory has changed to C:\Program Files\HP OpenView\Enterprise 
Discovery\2.1.0 

License Schema 

Each Enterprise Discovery server can collect data for a maximum of 50,000 devices or 100,000 ports 
(whichever comes first). An Enterprise Discovery Aggregator can support 50 servers and up to 500,000 
devices.   

Updated third party components 

• MySQL 4.1.19 

• OpenSSL 0.9.8a 

• Net-SNMP library 5.3.0 

• wxBase-2.6.2 
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New Features 

Many new features have been added to this version of Enterprise Discovery.  

Network Topology License 

Enterprise Discovery has been enhanced with a new Network Topology license. The Network Topology 
license will compute a port-to-port connection between all your network devices, and display it graphically.   

There are several features associated exclusively with the Network Topology license: 

• Network Map 

• MIB Browser 

• Service Analyzer 

• Some new Reports 

Note: Customers upgrading from Enterprise Discovery 2.0 will not automatically get these features. Contact 
your sales representative for pricing information. 

For a description of the license options, see the Installation and Initial Setup Guide.  

Network Map  

This feature will display your network devices and how they are connected. The Network Map was available 
in Network Discovery.  

In Network Discovery, the number of concurrent map sessions was determined by the hardware. In 
Enterprise Discovery, you can set the maximum number of concurrent map sessions by clicking 
Administration > System Configuration > Server Configuration > Maximum Concurrent Map Sessions. 

You can check how many users are accessing the map by clicking Status > Network Map Sessions. 

If you have used the Network Map in Network Discovery 5.2.5, there is a new feature: you can now drag and 
drop devices and packages between map windows.  

The Network Map accesses the server over secure HTTPS/SSL. 

MIB Browser 

This feature is available with the Network Topology license, and will allow you to walk the MIB of any 
SNMP-managed device on your network.  

The Variable tab has been redesigned since Network Discovery 5.2.5.  

The MIB Browser can use the discovered SNMPv3 authentication/encryption.  

The MIB Browser accesses the server over secure HTTPS/SSL. 

Service Analyzer 

This feature will display paths between any two devices on your network.  

Line Manager and Attribute Manager 

These features display Line and Attribute data.  
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SNMPv3 support 

Enterprise Discovery now supports SNMPv3. The Community Property Groups have been renamed to 
SNMP Property Groups to accommodate community strings (SNMPv1/v2) and users (SNMPv3).  

The SNMP configuration can be viewed in the Device Manager for each device.  

Note: This does not change how Enterprise Discovery works with SNMP Traps. Those are still sent with 
SNMPv2c. 

Asset Questionnaire 

The web-based Asset Questionnaire has been added. It replaces the Asset Questionnaire that was available 
through the Scanner Generator. 

An administrator user can click Administration > Asset Questionnaire to configure the fields that will 
appear in the questionnaire.  

The resulting questionnaire can be found by clicking Asset Questionnaire in the web interface navigation 
tree.   

The data that is entered for a device will be visible in the Device Manager, and will be added to any data 
collected by the scanners. Any data collected previously (in Enterprise Discovery 2.0.x) will remain in the 
database even after you make changes using the new Asset Questionnaire. If you reset the Asset 
Questionnaire to default settings, the old values will again be visible in the Device Manager’s Diagnostics 
panel.  

Note: You can also override old asset values with the Import Device and Port Data feature.  

If you would like to see the Asset Questionnaire when you log into Enterprise Discovery, you can change 
your Default Home Page under Administration > Account Administration > Account Properties.  

Mac Support 

Enterprise Discovery now provides agent and scanner support for Mac OS X (version 10.3 and 10.4).  

Note: Only PowerPC-based Macs are supported.  

Per-user Utilization Data 

The Utilization agent will now track utilization per application by user. This means that in the Viewer and 
Scan Data Viewer, you can now see utilization data based on individual users.  

The Utilization plug-in is Citrix-aware. 

Changes available in HP OpenView Connect-It 3.6 SP2 will allow this information to be populated to 
AssetCenter 4.4 or later.  

Rules-Based Recognition  

The rules-based recognition feature will help Enterprise Discovery anticipate new versions of the 
applications already installed on your devices, and already saved in your User SAI. 

Scanner Generator 

The troubleshooting tab is now always visible. It provides command line parameters and the content of 
.override.ini that are processed, in addition to normal command line parameters and the .override.ini file 
found on the computer where the scanner is executed. 
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Events Browser 

Under View > Show Access Events, there are new options to show user-initiated actions, such as Deploy 
Agent, Run Scanner, Purge Device, etc.   

Accounts 

There have been some security improvements for accounts and passwords (also see Account Administration 
below for new UI options).  

• Inactive accounts will be disabled after 90 days.  

• Passwords cannot have more than two consecutive identical characters.  

SAI Files 

The SAI files have been changed. They are now XML-based, and have the extension .zsai.  

SAI files configured to be used by the XML Enricher are automatically migrated. User SAIs need to 
manually migrated using the SAI Update Wizard.  

Scan Data Viewer 

The new web-based Scan Data Viewer was introduced to allow more Enterprise Discovery users to have a 
zero-footprint client. However, it differs from the Win32 Viewer in that:  

• It starts faster because it does not have to load the SAI.  

• It reads its information directly from the enriched data in the database.  

• It does not have a “compare scan file” function.  

• It shows hardware, application, and utilization data, not file data.  

• It has integrated find. 

• It has context menus for Update Model, Locate on Map, etc.  

Scanners 

There have been some enhancements to the scanners: 

• More CPUs are correctly identified. 

• MAC addresses are now always converted to uppercase. 

• Command line options for Win32 and UNIX scanners have been unified – use the same format as UNIX 
scanner in Enterprise Discovery 2.0 (both use the .override.ini file).  

• The Win32 scanner detects the destination of a directory junction that is located on a different drive 
from the junction.  

Some features have been dropped from the scanners. See the Obsolete Features section.  
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Status Menu 

Status > Device Status > Stale Connections  This report displays any broken connections. At the 
end of the Stale Line Break Interval, Enterprise 
Discovery will automatically delete the connection 
between these devices.  

Status > Device Status > Licensed Devices This report is associated with the Home Page 
“Devices Discovered” link, and provides a complete 
list of all the devices discovered in your network.  

Status > Unrecognized Files Distribution  This report allows you to see how many 
unrecognized files exist on your scanned devices.  

Similar to what you can see in the Analysis 
Workbench, these reports provide you with details 
about the unrecognized files on your scanned 
devices. While the Analysis Workbench can provide 
you with data about specific scan files, these reports 
will be up to date with data from all the scanned 
devices on your network. 

You can configure Enterprise Discovery to collect 
this data at Administration > System Configuration 
> Recognition File Data.  

Status > Currently Logged In Users This report displays which users are currently logged 
into the Enterprise Discovery web user interface.  

Status > Current Settings > Installed Components There is now a listing for the current Knowledge 
Package that is installed on your server.  

Status > Deactivated Devices You can now see how a device became deactivated.  

Administration Menu 

Account Administration 

There are several improvements to accounts relating to security: 

Administration > Account Configuration > List 
Accounts 

You can now see information on recent logins and 
login attempts on this page. 

Administration > Account Configuration > Account 
Properties 

You can now select which Viewer to open when you 
select the View Scan Data button in the Device 
Manager. 

Administration > Account Configuration > Account 
Password 

My Account Administration > Account Password 

New passwords must be re-authenticated, except for 
administrators changing other user passwords.  

Administration > System Configuration > Server 
Passwords 

New users are forced to change their passwords on 
their first login.  
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Event Handling  

Note: These features were previously available in Network Discovery.  

Administration > Event Filter Configuration This feature lets you configure Enterprise Discovery 
to notify you when specific events happen on your 
network. 

Not available in Network Discovery, there is a new 
feature allowing you to create XML files as your 
notification for specific events. These XML files can 
be used by another application, if necessary.  

Administration > SNMP Trap Recipient 
Configuration 

This feature lets you configure which devices will 
receive SNMP traps from event filters.  

 

System Configuration 

The “System Preferences” menu has been renamed “System Configuration.” 

Administration > System Configuration > Report 
Time Periods  

The Not Seen Intervals have been removed. They 
have been replaced with Multiplier for Scan Not 
Seen and Multiplier for Network Not Seen.  

This feature will extend the time that can pass 
before raising a Scan Not Recently Seen or Network 
Not Recently Seen alarm. If you set this to 2 (the 
default), a "not seen" alarm will appear for a device 
when it has been unseen for two times the Device 
Modeler Interval.  

Administration > System Configuration > Network 
Devices > Static Export Frequency 

This feature lets you save a complete list of all the 
values of all the attributes from all of your network 
devices. This list will appear as a single CSV file, 
located in your server's shared directory (Data 
Directory/statistics). You can select a frequency 
(from 5-60 minutes) that determines how often that 
data will be saved.   

This feature was included in Network Discovery 
5.2.5, but not in previous versions of Enterprise 
Discovery.  

Administration > System Configuration > Agent 
Communication > Agent Port 

This feature lets you determine which port 
Enterprise Discovery will use to communicate with 
the Agent. There are two choices: 2738 and 7738.  

Administration > System Configuration > Expiry > 
Stale Line Break Interval  

This feature lets you determine how much time will 
pass between a line break occurring, and when 
Enterprise Discovery will automatically delete the 
connection between these devices.  
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Data Management 

Administration > Data Management > Delete 
Connections  

This feature lets you delete connections between 
objects on the Network Map. It will take a few 
minutes for changes to be reflected in the map.  

Note: This feature was previously available in 
Network Discovery.  

Administration > Data Management > Import Device 
and Port Data/Export Device and Port Data 

This feature has been designed for users to import a 
large amount of data to the Enterprise Discovery 
database.  

Administration > Data Management > Data Delete There are two new levels of data deletion.   

Note: This feature was previously available in 
Network Discovery.  

 

Other Administrative Options 

Administration > My Map Configurations  This feature lets you save different map 
configuration files.  

Note: This feature was previously available in 
Network Discovery.  

Administration > Router Discovery This feature has been redesigned to include SNMPv3 
data.  

Reports 

There are several new reports in Enterprise Discovery 2.1: 

The new Unrecognized Files reports provides details of the unrecognized application files found on scanned 
machines. 

• Unrecognized Files Summary by Scanner Type 

• Unrecognized Files with Drill Down to Directories and Machines 

• Machines with Highest Number of Most Unrecognized Files 

• Machines with Highest Number of Most Used Files 

There are also new Device Resource Inventory reports.  

Applets 

On each applet window (Network Map, Events Browser, Alarms Viewer, etc), there are the following 
changes:  

• LEDs that indicate the status of the applet’s communication with the Enterprise Discovery server.  

• Many commands have been rearranged into new Device, Port, and Attribute menus. 

• In applets with tables of data (for example, the Events Browser), you can multi-select any combination of 
rows.  
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• The Update Model submenu has been updated to include all agent and scanner commands.  

• The applets now support JRE 1.5, and the Java Ocean look and feel.  

• The contextual Find feature remembers recent entries.  

• You can open the Line Manager from a virtual port.  

• The Network Map supports pop-up information for virtual ports, including connectivity.  

Home Page 

• “Port License” has been changed to “Port Capacity.” 

• There is a new warning on the Home Page if you have either not installed or misconfigured SNMP on 
the Enterprise Discovery server.  

• The links to Exceptions now take you to exception-specific reports.  

• The device counts for “Devices Discovered” and “Active Devices” are not identical. The counter for 
“Devices Discovered” is equal to the “Licensed Devices” count. The “Devices Discovered” link now points 
to this new report. 

• Most tools have new icons.  

Find 

• You can Find by device tag.  

• A Go button has been added, and the Refresh button has been removed.  

Device Manager for the Enterprise Discovery server 

There are new statistical graphs on the Device Manager for the Enterprise Discovery server. Some of these 
were available in Network Discovery 5.2.5, but there were none in Enterprise Discovery 2.0.  
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Obsolete Features 

When upgrading from Enterprise Discovery 2.0 or Network Discovery 5.2.5, you will find the following 
features no longer supported: 

Agent Support for Windows 98 and ME 

Windows 98 and ME no longer have Agent support. Windows 98SE is still supported.  

Scanners 

• Scanners from Enterprise Discovery 2.0 are not compatible with Enterprise Discovery 2.1. On upgrade, 
Enterprise Discovery 2.0 scanners will be deleted and the system will start using Enterprise Discovery 
2.1 scanners.  

• Win16 and Remote scanners have been removed. 

• Plug-in support removed, CAB handling is now included in the base scanners. 

• The DOS and OS/2 scanners are supplied separately through the support website.  

• The scanners no longer have a user interface.  

• User entered asset questionnaire is no longer supported. The new web-based Asset Questionnaire can be 
used instead. Automatic asset fields are still supported. 

• DMI asset extract fields have been removed.  

• Low level disk scanning features (partition table scan, low level scanning of drives not visible by the 
currently running operating system) have been removed. 

Network Discovery Features 

The following features were available in Network Discovery, but have been removed: 

• Page by Modem 

• Microsoft Word Template 

• Resource License 

• Force Basic Discovery 

• Proxy Services  

• QuickDeploy Console  

• Restore Prime Map Configuration  

• Network Map – blue background color preference 

• ServiceCenter compatibility  

Scanner Generator 

A number of legacy options have been removed: DMI and Hard Disk Partition, scanner user-interface, plug-
in, and asset refilling.  

The user-entered asset data fields have been removed from the Scanner Generator, and the new Asset 
Questionnaire (in the web user interface) has taken its place.  
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FSF File Format 

The FSF file format is no longer used in Enterprise Discovery. The FSF Converter and FSF Delta Tool have 
been removed.  Before upgrading to Enterprise Discovery 2.1, you must convert your FSF files to the XSF 
format. Refer to the XSF white paper for more details.  

Analysis Workbench 

The Analysis Workbench reports have been removed. Also, you can no longer edit the Asset Questionnaire 
fields. 

Limited Installer 

The Limited Client Installer has been removed.  

Find – NetBIOS Query 

The NetBIOS query find option has been removed, but the option to search by NetBIOS remains. 

Save Delta Scan file over HTTP 

Delta Scanning over HTTP has been removed.  

Viewer 

You can no longer edit asset data in the Viewer. Instead, you can use the new web-based Asset 
Questionnaire.  

DNS Configuration 

This option has been removed. Enterprise Discovery now finds its DNS information from the server on which 
it is installed.  
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Documentation Updates 
The first page of this release notes document contains the following identifying information: 

• Version number, which indicates the software version. 

• Publish date, which changes each time the document is updated. 

To check for recent updates or to verify that you are using the most recent edition, visit the following URL: 

http://ovweb.external.hp.com/lpe/doc_serv/ 

1 In the Product list, click the product name. 

2 In the Version list, click the version number. 

3 In the OS list, click the OS type. 

4 In the document list, click the document title. 

5 To retrieve the document, click Open or Download. 

NOTE: To view files in PDF format (*.pdf), Adobe Acrobat Reader must be installed on your system. To 
download Adobe Acrobat Reader, go to the following URL: 

www.adobe.com 

 

The following PDF documents are available in the Enterprise Discovery user interface: 

• Planning Guide  

• Installation and Initial Setup Guide 

• Configuration and Customization Guide 

• Network Data Analysis Guide 

• Scan Data Analysis Guide 

• Reference Guide 

• Network Discovery Migration Guide 

One other PDF file is available on the install CD at bin/documentation: 

• Legacy Scanners 

And this last document is available in HTML format, through the Enterprise Discovery client (Start > All 
Programs > HP OpenView > Enterprise Discovery 2.1 > Documentation) 

• Data Collected by the Scanners 
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Installation Notes 
Installation requirements, as well as instructions for installing Enterprise Discovery, are documented in the 
Installation and Initial Setup Guide provided in Adobe Acrobat (.pdf) format.  

If you are upgrading from a previous version, you need to follow these steps: 

1 If you have created your own User SAIs, make sure you back them up manually before uninstalling 
Enterprise Discovery.   

2 Save an external backup of your data, if necessary.  

3 Uninstall the old version of Enterprise Discovery, using the Windows “Add/Remove Programs” feature.  

4 Delete the following directory from the server:  
C:\Program Files\Peregrine\Enterprise Discovery\*.* 

5 Reboot the server before you install the new version.  

⎯ The uninstallation will not delete the Enterprise Discovery Data directory. Rebooting the server will 
ensure that all parts of Enterprise Discovery are removed. 

6 Install the new version and follow the steps in the Installation and Initial Setup Guide. 

⎯ If you changed the default location of the Data directory when you installed a previous version, you 
need to ensure that you use the same location when you install the new version.  

Note: Perl, MySQL, Tomcat and Apache are standard parts of the Enterprise Discovery, included with each 
server installation. If you have these components installed already, make sure to remove them before 
installing Enterprise Discovery. You may NOT substitute any other technologies in place of the standard 
installation.  
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Software and Hardware Requirements 

The Enterprise Discovery server can be installed on Windows 2003 Server SP1. (Windows XP SP2 is also 
compatible, but should only be used for trial or demo installations.) 

The following table details a variety of scenarios that can help you estimate your server hardware 
requirements. The Disk value is for your data directory. You will require at least 6MB under Program Files 
for the Enterprise Discovery installation.  

Devices Ports Aggregation Inventory Topology 
Memory 
(GB) CPU 

Disk 
(GB) 

5,000 30,000   x    1.5 
1 CPU 
2.4GHz 25 

5,000 30,000     x  1.5* 

1 CPU 
2.8 GHz 
hyperthreading 15 

5,000 30,000   x x  2* 

1 CPU 
2.8 GHz 
hyperthreading 35 

15,000 90,000   x    2 

2 CPUs 
3 GHz 
hyperthreading 70 

15,000 90,000     x  3.5 

2 CPUs 
3 GHz 
hyperthreading 35 

15,000 90,000   x x 4  

2 CPUs 
3 GHz 
hyperthreading 100 

50,000 100,000   x   3 

2 CPUs 
3.6 GHz 
hyperthreading 200 

50,000 100,000     x 4 

2 CPUs 
3.6 GHz 
hyperthreading 50 

50,000 100,000   x x 5 

2 CPUs 
3.6 GHz 
hyperthreading 240 

50,000 n/a x n/a n/a 2  

2 CPUs 
3 GHz 
hyperthreading 10 

500,000 n/a x n/a n/a  3 

2 CPUs 
3.6 GHz 
hyperthreading 50 

* This is for 5 map sessions. If you want to use more than 5 map sessions, you will require more memory 
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These calculations have been tested as scenarios for maximum disk size on the server. For the Inventory 
license, this includes: 

• Backup Scan Files in enabled (on average, each scan file is 250KB) 

• Generate MIF Files is enabled  

• Delta scanning is enabled 

• Space required for two backups (one stored backup, and one “in process” backup) 

For the Network Topology license, this includes: 

• Statistic Export is enabled (CSV files) 

• 200 users, with each user account saving 10 map configurations files 

• Space required for two backups (one stored backup, and one “in process” backup) 

The Enterprise Discovery client has the following requirements: 

Operating System Windows 2000, XP, or 2003 

CPU Pentium III, 500 MHz 

RAM 500 MB (1-3 GB if you will be analyzing a large number of scan files.) 

Disk 100MB required (2GB recommended) 

Java Runtime 
Environment 

1.4.2 or 1.5 
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Enhancements and Fixes 
The following items (identified by error tracking number) are fixed in the current software release. 

Number Location Description 

11131 

 

Device Manager 

Administration > Schedule 
Management 

The way the agent/scanner schedules were deployed in the 
Device Manager was confusing and inconsistent.  

The schedule times have been updated to be consistent.  

11878 Device Manager Query Network in the applet did not work for devices that 
were not already in the database. 

12827 Property Groups/Sets You can now use an apostrophe (‘) in a description for a 
Property Group or Property Set.  

14427 Time zone Time zones were not consistently displayed in the user 
interface if the server and client were in different time 
zones.  

14457 XML Enricher If the XML Enricher encounters a log file in the incoming 
directory, it will be sent to the scans\logs directory.  

14544 Analysis Workbench Analysis Workbench would run out of memory when 
loading a large number of scan files.  

14582 Analysis Workbench When adding a new publisher, AW would occasionally 
hang.  

14775 SAI Editor The “zsai” file extension is now added by default when 
renaming SAIs.  

14779 SAI Editor If a new version was taught into the User SAI inside SAI 
Editor, files within that version could not be sorted 
according to their Version details data. If you clicked on the 
'Version Data' column inside SAI Editor, nothing would 
happen. 

14780 SAI Editor If you loaded a scan file into 'Recognition Result Import' 
and activated 'Install Strings' tab, only install strings for 
installed applications would appear. An OS install string 
would not appear on the list. 

14800 Aggregator Navigation If a remote server is unavailable, the breadcrumb is 
updated properly.  

14803 SAI Editor In some circumstances, the Release Relation icon would 
disappear, so you could not explore the license relations 
window.  
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14820 Installation In very rare circumstances, an “Error 1721” occurred 
during installation.  

14837 Server Name The backslash character “\” would be treated as an escape 
character, when it should have been seen as plain text.  

14854 Applets The applets could not properly display server names with 
an apostrophe (‘).  

14885 UNIX scanner Unix scanner would not scan nfs mount points when 
"network drives" were enabled. 

15069 Uninstallation After uninstalling, the Tomcat directory would remain. 

15213 Device Manager The Device Manager may have crashed Apache when you 
clicked buttons before the window had fully loaded.  

15221 Administration > Data 
Management 

In the Aggregate View, the Administration > Data 
Management menu would not appear.  

15225 SAI Editor When you save, the relations editor now closes. 

15227 Viewer The "Last Accessed" field in the "Directory and Files" tab 
and "Last Used" field in the "Software Applications" tab 
were not sorting correctly. 

15246 Log User Actions In Administration > System Configuration > Server 
Configuration, if you enabled “Log User Actions,” you 
needed to restart the Enterprise Discovery server to initiate 
the change.  

15248 Viewer Under Options > Asset Fields > Add > Text File Extract, 
the trailing blanks were always removed whether the 
"Remove trailing blanks" option was selected or not. 

15256 Backup/Restore Restoring data from Network Discovery to Enterprise 
Discovery caused the scanners directory to be empty. 

15273 Web user interface Links to external websites will open a new browser window. 

15329 Scanner Generator The settings on the Software page were not saved when you 
clicked Back.  

15427 Administration > Schedule 
Management 

Renamed the default “<none>” setting to “<all the time>” 
which better indicates its function.  

15442 Viewer The Find dialog is now resizable, so you can read the entire 
file path.  

15493 SAI Location Path When you upgraded to Enterprise Discovery 2.0.3 (from 2.0, 
2.0.1, or 2.0.2), the location of the Master.sai file may not 
have been updated in the XML Enricher.ini file.  
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15521 Agent In some cases, the memory usage of discusge.exe would 
steadily increase. 

15540 Device License  Virtual devices are no longer included in the total device 
count for an Aggregate license.  

15592 Line Alarms Some “invisible” lines were getting an alarm state 
inappropriately.  

15594 Scanners The stored Utilization files are no longer truncated to 2MB. 

15601 Event Filters In some cases, notification on specific events would not 
occur.  

15622 Scanners Bitmap fields were not reported properly in the XML scan 
file. 

15723 AIX Scanner Mount Point Volume Type and Media unknown in AIX 5.2 
scan. 

15754 Import Network 
Configuration data 

Now, when you import a CSV file with your Network 
Configuration data, it is clear that you must activate your 
changes.  

15763 Event Filters There were no notifications for property change events. 
There was a warning in the log: 

"not sending notifications because object is not active" 

15785 Shortcut commands The Device Manager shortcut command was not working if 
you accessed the server from another location (i.e., not 
localhost).  

15787 SAI Editor In the New Publisher screen, an access violation may have 
occurred when filling in the publisher data.  

15808 Win32 Scanner hwDisplayDesktopRefreshRate was not detected.  

15828 Analysis Workbench In Windows > Layout > Save As, the drop-down list was 
empty and the "Up one level" button did not respond to 
clicking. This dialog has been updated to be a standard 
Windows “Save As” dialog.  

15923 Database The vram attribute was not being stored in the discovery 
and aggregate databases. 

15985 Scanner Generator In Enterprise Deployment Mode of the Scanner Generator, 
if a user field was added into the Asset Data page, the 
following Access Violation dialog would appear after hitting 
Generate: 

“Access violation at address 00403A54 in module 'Scanner 
Generator.exe'.” 
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15982 Multiline Report The Multiline report was failing for accounts that had a 
hyphen in their names.  

16157 Find Easy Find will now timeout in 6 seconds if the DNS server 
is misconfigured.   

16165 Administration > Data 
Management > Update 
network model 

If you try to update the model of a device that is not in your 
list of IP ranges, you will get a warning.  

16283 Administration > System 
Configuration > Aggregate 
configuration > Number of 
days to keep imported 
Discovery Database files 

This setting would work for all values other than 1. You can 
now enter 1, and the files will be deleted after 1 day.  

16343 Health Panel/Aggregate 
Health Panel 

The two Health Panels are usually different, but they could 
be the same if a server is an Aggregator and it is only 
aggregating itself.  

16389 Viewer Extra characters are no longer appended to the beginning of 
text stored files when displayed in the Viewer.  

16476 Scanners The card description logic has been improved to show more 
specific hardware details.  
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Known Problems, Limitations, and Workarounds 

Installation 

• When installing the client machine, there may be conflicting warnings about minimum RAM 
requirements (SCR #15239). 

• Enterprise Discovery with a Network Topology license should not be installed on VMWare (SCR #16524). 

Mac Agent 

• On MAC OS X devices, agent upgrades may require a reboot (SCR #16469).  

Scanners 

• The AIX scanner may not properly detect the graphic card manufacturer, or the network card MAC 
address (SCR #16517). 

• In Manual Deployment mode, the UNIX scanner will not save offsite scan files to a Microsoft FTP server 
when the user name is specified in the form domainname/username (SCR #12893). 

• Enterprise Discovery 2.1 scan configurations running with Enterprise Discovery 2.0.3 scanner binaries 
will not work properly (SCR #16442) 

• The Linux scanner uses more CPU than it should (SCR #16468). 

• The scanners can not open some files in non-English operating systems (SCR #16462).  

• The UNIX scanners need to normalize hwSCxxx Yes/No  to 0 and 1 depending on platform and how 
these values are supported on the platform (SCR #14746).  

• Some files excluded in .override.ini are still being scanned (SCR #15766).  

• In the Scan Command Line /O Switch, the “/O” should be “/o” (lower case) (SCR #15852).  

• Automounts are being scanned in HP-UX and Linux systems (SCR #15950).  

• The scanners cannot collect SMBIOS information when different users are logged in (SCR #15957).  

• The scanner collects shortcuts, but does not scan the shortcut (SCR #16211).  

• The scanner may cause errors in 64-bit Windows systems (SCR #16221).  

• The legacy DOS scanner requires at least 600K to run and save scan (SCR #16234).  

• The device driver file attribute is not detected by the Win32 scanner (SCR #16262).  

• The UNIX scanners cannot properly identify newer CPUs (SCR #16372).  

• Scanners can not properly detect dual core CPUs (SCR #15543, 16401).  

• In some cases, WINS information is not added to the scan file (SCR #16402).  

• File times collected by UNIX scanners are reported in the local time (Enterprise Discovery 2.0.3 and 
earlier used to report them in UTC (SCR #16434).  

• On Solaris, the disk size reported in Scan file viewer is 0 (SCR #16483). 
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• On Solaris, the data under Bus Data > Buses supported > Cards is blank (SCR #16479). 

Analysis Workbench 

• In File > Load Options > Asset Fields > Add > Text File Extract > Options, whenever the "Treat field as 
a File Name" option is selected, the "Replace invalid characters with" field must be populated as well, 
even if the "Delete invalid characters" option is selected instead.  Otherwise, the “The file ‘Replace 
invalid characters with’ may not be empty” error dialog appears (SCR #15827): 

Server Installation 

• Server uninstallation will report a “Fatal error” if the Favorites in the Registry contains an invalid path 
(SCR #15303).  

• After an uninstallation, the branding registry keys are leftover (SCR #15507).  

• When uninstalling Enterprise Discovery on a small server, the uninstaller may not be able to stop the 
database. It may take several tries to uninstall the software (SCR #14370).  

Client Installation 

• After uninstalling the client, the menu items will still appear under the Windows Start menu (SCR 
#16437). 

Server 

• If your server has another service using port 80, the Apache service will not run properly (SCR #14808).  

• If there is a MySQL query that takes too long, Enterprise Discovery will not function properly and you 
may need to restart System Monitor to recover (SCR #13964).  

• Filtering unknown files is not consistent (SCR #16220).  

• Sometimes, manually stopping a service does not work (SCR #16232).  

• Delete Data > Above plus accounts does not delete the default accounts and re-create them (SCR 
#16310).  

• An older openssl DLLs in the system PATH can affect the Enterprise Discovery Apache server and perl 
engines (SCR #16318).  

• Changing the system time can stop the System Monitor process (SCR #16341).  

• If you have enabled grouping of scan files, and then disable the grouping, the UI scan files cannot always 
be located in the correct folder (SCR #16376).  

• Unrecognized file counts calculated from the file and hwRecognitionInfo do not match (SCR #16433).  

• The Microsoft snmptrap command hangs when executed. If you are using the SNMP trap notification in 
your event filters, it is very important that the user installs the 3rd party SNMP tools and ensure that 
its path is before C:\WINDOWS\system32 (SCR #16435, 16445).  

• When performing an upgrade, and deleting scanners from <data directory>\scanners, the scanners will 
not be automatically updated (SCR #16443).  

• The Data Delete feature does not work exactly as described in the documentation; however the online 
help is correct (SCR #16448).  
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Backup/Restore/Migration/Upgrade 

• When migrating from Network Discovery, an XML Enricher setting may have a different default (SCR 
#16264).  

• When performing a restore, the performance is poor when the FileInstance table is particularly large 
(SCR #16367).  

• MySQL accounts are not backed up properly (SCR #16447). You need to recreate any MySQL accounts 
after performing a data restore.  

Web User Interface 

• Some web pages do not render correctly if the configuration of the Enterprise Discovery server has the 
decimal separator as any other character than "." (SCR #14307).  

• There are some issues with the navigation tree. Some entries in the navigation tree do not perfectly 
match the entries in the UI menus, and it may take a while to build the navigation tree on an 
Aggregator with many remote servers (SCR #16236, 16259, 16353).  

• When you click a link from an Assistant Help window, the breadcrumbs on the main UI page will not be 
updated (SCR # 16239).  

Administration 

• Depending on the licenses, the "Resource/ Environment manage" property in Network Configuration 
may not have any effect (SCR #14388).  

• If you select the custom value radio button, but do not actually change the default setting, Enterprise 
Discovery will not recognize the change (SCR #16205).  

• The local account name allows a dash character (-), but an Aggregator account does not allow a dash 
(SCR #16286).  

Device/Port/Attribute/Line Manager 

• There may be a Server Error when making a connection for a newly modeled device (SCR #16207).  

• When the Port Manager is already open, the port number is not pre-selected when the Port Manager is 
called from the Device Manager (SCR #16423).  

Reports 

• Sometimes web pages under Reports do not completely render or print source code in Mozilla Firefox. 
Use the refresh button (SCR #13803).  

• The graphs in the Unrecognized Files reports do not handle a specified maximum value of 0 (SCR 
#16348).  

Asset Questionnaire 

• The Answer Selection page cannot display multiple spaces (SCR #16082).  

• A blank numeric field should be accepted if it is not a required field (SCR #16279).  

• The UI may show non-printable characters in text fields (SCR #16285).  
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• The radio button values are not displayed properly when reset to default (SCR #16291).  

• The same items should not appear in the selection list (SCR #16306).  

• Demo users should not be able to access the Asset Questionnaire (SCR #16439).  

Miscellaneous 

• A “No ED server” warning may erroneously appear on the Home Page if the Enterprise Discovery server 
has a duplicate model in the database (SCR #16212). 

• A blank Last Failed Login shows up on homepage when it should not (SCR #16430).  

• The Network Map may disconnect automatically, especially if the server is very busy (SCR #16344). If 
you Map session disconnects, you need to use the File > Reconnect command.  

Aggregator 

• There may be a duplicated server name for your Aggregator if you have named it “aggregator” (SCR 
#16391).  

Applets 

• In the Value column of the exception called "Read/Write is Enabled in Serial Number entry in MIB,” 
there is HTML code visible (SCR #15619).  

• If you have a large network, and you do a search for a relatively vague value using easy find in the Find 
tool, then the database crashes (and recovers) if you have a lot of matches (SCR #16050). 

• When changing the Map Scale or the MIB Radar count, the input value should change back to the 
previous value if the user does not click Enter (SCR #16063).  

• In the MIB Browser, a continuous search for a non-existing device causes intermittent "system error" 
pop-up (SCR #16190).  

• The green communication lamp stays on during error dialog (SCR #16208).  

• There may be empty event records in the Events Browser (SCR #16209).  

• The Applet ports window cannot sort by device icon (SCR #16223).  

• The device popup info may be empty in the Alarms Viewer (SCR #16224).  

• The Description field in the Scan Data Viewer is not always updated (SCR #16225).  

• Selecting a report alarm in the Alarms Viewer does not update the recent device list (SCR #16266).  

• In the Alarms Viewer, Edit > Copy fails to include the date (SCR #16396).  

• The Aggregate Find sometimes displays erroneous entries (SCR #16144).  

Scanner Generator 

• In Manual Deployment mode, if you move back and forth through the wizard, your selections may not 
remain. When you return to a screen, the defaults will reappear (SCR #15238). 
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Licensing 

Inventory License 

• Scanning-related menu are grayed out, when they should not appear at all (SCR #16009, 16039, 16040, 
16043). 

• In the Device Manager, the View Scan Data icon should not appear if there is no Inventory license (SCR 
#16273).  

Alarms License  

• Alarms-related items are not always hidden (SCR #16014, 16027, 16213, 16215, 16271, 16272, 16322, 
16325, 16041). 

• Administration > Event Filters needs to be updated for Alarms license (SCR #16359).  

Network Topology License 

• Topology-related items are not always hidden (SCR #16269, 16270). 

• In the Port Manager, some icons should not appear if you do not have the Network Topology license 
(SCR #16275, 16276). 

• In the Device Manager, the “port moves” section should not appear on the Reports page if you do not 
have the Network Topology license (SCR #16277).  

Rebranding 

• In the Installer, Peregrine appears as the publisher for "Setup.exe" (SCR #15605).  
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