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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2006 Hewlett-Packard Development Company, L.P.

This product includes i-net OPTA software, which is © Copyright 2002-2006 i-net software GmbH, Berlin, 
Germany.

Trademark Notices

Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated.

AMD is a trademark of Advanced Micro Devices, Inc.

HP-UX Release 11.00 and later (in both 32 and 64-bit configurations) on all HP 9000 computers are Open 
Group UNIX 95 branded products.

Intel and Pentium are registered trademarks of Intel Corporation or its subsidiaries in the United States and 
other countries.

Java™ and all Java based trademarks and logos are trademarks or registered trademarks of Sun 
Microsystems, Inc. in the U.S. and other countries.

Microsoft®  and Windows®  are U.S. registered trademarks of Microsoft Corporation.

Oracle® is a registered US trademark of Oracle Corporation, Redwood City, California.

UNIX® is a registered trademark of The Open Group.
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Support

Please visit the HP OpenView support web site at:

http://www.hp.com/managementsoftware/support 

This web site provides contact information and details about the products, services, and support that HP 
OpenView offers.

HP OpenView online software support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As a valued 
support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit enhancement requests online

• Download software patches

• Submit and track progress on support cases

• Manage a support contract

• Look up HP support contacts

• Review information about available services

• Enter discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and log in. Many also require a 
support contract.

To find more information about access levels, go to:

http://www.hp.com/managementsoftware/access_level 

To register for an HP Passport ID, go to:

http://www.managementsoftware.hp.com/passport-registration.html 
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1 Documentation Map
Figure 1 shows the documentation map for HP OpenView Dashboard RealTime Health View. 
You can use this map to determine which manual contains the information you need. For a list 
of available product documentation, see RealTime Health View Documentation on page 10.

Figure 1 RealTime Health View Documentation Map
  9



RealTime Health View Documentation

Table 1 lists the documents in the RealTime Health View documentation set. These 
documents are provided in Adobe Acrobat (.pdf) format and are located in the following 
directories:

• On the HP OpenView Dashboard management station:

<OvInstallDir>\paperdocs\dashboard\rhview

where <OvInstallDir> is the location where RealTime Health View is installed.

• On the product DVD-ROM:

\Docs\

• On the system where SLI is installed (for the SLI installation guide):

<OvInstallDir>\paperdocs

RealTime Health View Online Help

You can access RealTime Health View online help for HP OpenView Dashboard Service 
Composer from the composer Help menu.

Table 1 RealTime Health View Documentation

Document Title and Filename Main Topics

HP OpenView Dashboard Installation Guide
Installation.pdf

Installing and uninstalling HP OpenView 
Dashboard

RealTime Health View Concepts Guide
RealTime_Health_View_Concept.pdf

Introduction to the terms and concepts of 
RealTime Health View

RealTime Health View Administrator Guide
RealTime_Health_View_Admin.pdf

• Configuring RealTime Health View
• Maintaining RealTime Health View

Smart Link Integration for Mercury Business 
Availability Center Installation Guide
MBACOvSLI\Mercury_SLI_Install.pdf

Installing Smart Link Integration (SLI) 
for Mercury Business Availability Center

Smart Link Integration for BMC Remedy 
Help Desk Installation Guide
RemedyOvSLI\Remedy_SLI_Install.pdf

Installing Smart Link Integration (SLI) 
for Remedy Help Desk
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Documentation Updates

This manual’s title page contains the following identifying information:

• Software version number, which indicates the software version

• Document release date, which changes each time the document is updated

• Software release date, which indicates the release date of this version of the software

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details
Documentation Map 11
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2 Introduction
This chapter provides an overview of HP OpenView Dashboard RealTime Health View. It also 
provides information about basic configuration and administration tasks. 

This chapter includes the following topics:

• About HP OpenView Dashboard on page 13

• About HP OpenView Dashboard RealTime Health View on page 13

• Getting Started with RealTime Health View on page 15

 About HP OpenView Dashboard

HP OpenView Dashboard is a suite of tools that you can use to monitor the health and status 
of vital business, application, and IT services. You can use these tools to link existing service 
definitions from different management stations to create a customized dashboard view of your 
environment. HP OpenView Dashboard consists of the following tools:

• HP OpenView Dashboard RealTime Health View: enables you to look at high-level 
service-related data.

• HP OpenView Dashboard Operations View: enables you to look at detailed 
operations-level data.

 About HP OpenView Dashboard RealTime Health View

RealTime Health View enables you to collect, aggregate, and analyze service-related data 
from existing management stations in your environment. You can use this data to create a set 
of high-level aggregated views of application, business, and IT services. RealTime Health 
View provides the following key components:

• RealTime Health View Composer

• RealTime Health View Portal

• RealTime Health View Adapters

• RealTime Health View Server

For information about HP OpenView Dashboard Operations View, see the 
Operations View documentation
  13



RealTime Health View Composer

You can use the composer module to design the portal views that your end users will view. You 
can introspect services from selected management stations in your environment (such as 
those running HP OpenView Internet Services, HP OpenView Operations for Windows, 
Mercury BAC, and so on) to provide high-level dashboard views. 

The composer module enables you to do the following:

• Import services from management stations such as HP OpenView Internet Services, 
HP OpenView Service Navigator, HP OpenView Service Desk, and Mercury Business 
Availability Center. You can also import HTTP and SQL data sources.

• Create dashboards and define service groups. This enables you to display high-level 
service views grouped by geographies, business units, organizational units, and so on.

• Deploy any newly designed dashboard view so that it displays as a complete portal-based 
web site. The portal view also displays all drilldowns based on the content template you 
select in the composer.

RealTime Health View Portal

Your end users view the dashboards by using the portal view, which is a set of 
JSR168-compliant portlets that are auto-generated for the dashboards designed by using the 
composer. These portlets provide a consolidated view of services and enable end users to drill 
down to the elementary services. They also provide detailed information about each 
dashboard component including health metrics and other attributes.

The portal module provides the following:

• Summary views that show multi-dimensional aspects of a service, such as health, 
availability, service-level objective (SLO) compliance, alerts, and help desk incidents.   

• First-level drilldown portlets show the service hierarchies as defined by the service 
managers. These portlets also show cross-domain heterogeneous views of data from 
multiple products within a specified service context.

• Second-level drilldown portlets show additional details about selected dependent services 
from products such as HP OpenView Internet Services and HP OpenView Service 
Navigator.

RealTime Health View Adapters

RealTime Health View adapters provide integration between the RealTime Health View 
server and the management stations from which it collects data. The adapters are web 
service-based applications that you deploy on each management station from which RealTime 
Health View collects data.

Adapters are available for the following HP products:

• HP OpenView Internet Services

• HP OpenView Service Desk

• HP OpenView Service Navigator

• HP OpenView Operations for Windows

Adapters designed to work with non-HP OpenView management stations are called Smart 
Link Integration (SLI). SLIs are available for the following products:
14 Chapter 2



• Mercury Business Availability Center

• BMC Remedy Help desk 

RealTime Health View Server

The RealTime Health View server acts as a repository for dashboards created by using the 
composer. It also contains an engine that accepts runtime data from adapters and SLIs, and 
computes status for each of the dashboard components at runtime. 

 Getting Started with RealTime Health View

Before using RealTime Health View, you must configure it by using the OV Dashboard 
Configuration Manager. OV Dashboard Configuration Manager enables you to configure 
connection parameters such as port number, polling interval, database, and portal server. It 
also enables you to start or stop the RealTime Health View servers.

For an overview of configuration and administration tasks, see Table 2.

Table 2 Organization of Tasks

Task 
Number

Task Name and 
Reference Description

1.0 See Installing and 
Configuring Adapters 
on page 17.

RealTime Health View collects data with the help of 
adapters. After you install RealTime Health View, you 
must install the necessary adapters on each 
management station or data source.

2.0 See Configuring 
RealTime Health View 
on page 31.

Configure RealTime Health View database details, 
server properties, and adapters.

3.0 See Creating 
Dashboards on 
page 47.

Create and deploy dashboards by using the 
HP OpenView Dashboard Service Composer.

4.0 See Managing Users 
on page 67.

Add, delete, and manage users. Assign dashboards to 
portal users.
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3 Installing and Configuring Adapters
In order to retrieve data from selected management stations, you must first install and 
configure adapters on each management station or data source. RealTime Health View 
provides adapters for the following HP OpenView management products:

• HP OpenView Internet Services 

•  HP OpenView Service Desk

• HP OpenView Service Navigator

• HP OpenView Operations for Windows

The set of adapters for HP OpenView management products are packaged in two different 
compressed files. These files are:

• For Windows systems: HPOvDshAdapter-02.00.001.zip 

• For HP-UX systems: HPOvDshAdapter-02.00.001.tar.gz 

These files are placed by the RealTime Health View installation wizard in the following 
location:

<OvInstallDir>\misc\dashboard\rhview 

HP OpenView Internet Services

System Requirements

In order to install this adapter successfully, the target management station must meet the 
following minimum system requirements:

<OvInstallDir> is also the location of other HP OpenView Dashboard files.

Table 3 System Requirements for the Adapter for HP OpenView Internet 
Services

Software Requirements

Operating System Windows 2000, 2003

HP OpenView Internet 
Services 

 Versions 5.2 and 6.1
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Installation Tasks

1 Copy the HPOvDshAdapter-02.00.001.zip to the HP OpenView Internet Services 
management station and extract the contents of the file.

2 Run the extracted files in the following sequence:

a HPOvXpl-02.61.050-WinNT4.0-release.msi

b HPOvJxpl-02.61.050-WinNT4.0-release.msi

c HPOvJre-01.04.211-WinNT4.0-release.msi

d HPOvDshRhvCo-02.00.001-WinNT4.0-release.msi

e HPOvDshISAdapt-02.00.001-WinNT4.0-release.msi

3 To modify the HP OpenView Internet Services adapter configuration, edit the following 
properties file: 

<OvDataDir>\conf\ovdshisadapter\OVISAdapterConfig.properties 

4 Start the adapter as a service from Windows service explorer.

HP OpenView Service Desk

System Requirements

In order to install the adapter successfully, the target management station must meet the 
following minimum system requirements:

Attribute Default Value Description

Port 80 The port on which HP OpenView Internet Services 
measurement server is running

Hours 1 The number of hours to be considered while calculating 
drilldown data for a service health and HP OpenView 
Internet Services service elements.

Restart the adapter every time you edit the OVISAdapterConfig.properties 
file.

Table 4 System Requirements for the Adapter for HP OpenView Service Desk

Software Requirements

Operating System Windows XP, HP-UX 11.11 and 11.23 PA-RISC

HP OpenView Service Desk  Version 4.5 SP 17
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Installation Tasks

Perform the following steps (on Windows or HP-UX platforms) to install and configure the 
adapter:

Windows

1 Copy the HPOvDshAdapter-02.00.001.zip to the HP OpenView Service Desk 
management station and extract the contents of the file. 

2 Run the extracted files in the following sequence:

a HPOvXpl-02.61.050-WinNT4.0-release.msi

b HPOvJxpl-02.61.050-WinNT4.0-release.msi

c HPOvJre-01.04.211-WinNT4.0-release.msi

d HPOvDshRhvCo-02.00.001-WinNT4.0-release.msi

e HPOvDshSDAdapt-02.00.001-WinNT4.0-release.msi

3 From Start menu, click Programs → HP OpenView → Dashboard → RealTime Health View → 
Configure SD Adapter. The OpenView Dashboard Service Desk Adapter Configuration 
dialog box opens.

4 Enter the user name and password for HP OpenView Service Desk application server, and 
then click Save. When you finish, click Exit.

5 To modify the HP OpenView Service Desk adapter configuration, edit the following 
properties file:

 <OvDataDir>\conf\ovdshsdadapter\OVSDAdapterConfig.properties file.

6 Start the adapter as a service from Windows service explorer.

Attribute Default Value Description

Hostname localhost The machine on which the 
HP OpenView Service Desk application server is 
running

Port 30999 The port on which the 
HP OpenView Service Desk application server is 
running

Restart the adapter every time you edit the OVSDAdapterConfig.properties 
file.
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HP-UX

1 Copy the HPOvDshAdapter-02.00.001.tar.gz to the HP OpenView Service Desk 
management station.

2 Extract the contents of the file to a local subdirectory <ExtractDir>.  

3 At the command prompt, install the extracted files by using the swinstall command. 
Make sure that you install the files in the listed sequence.

a swinstall -s 
<ExtractDir>/HPOvXpl-02.61.050-HPUX11.0-release.depot

b swinstall -s 
<ExtractDir>/HPOvJxpl-02.61.050-HPUX11.0-release.depot

c swinstall -s <ExtractDir>
/HPOvJre-01.04.211-HPUX11.0-release.depot

d swinstall -s <ExtractDir>
/HPOvDshRhvCo-02.00.001-HPUX11.0-release.depot

e swinstall -s <ExtractDir>
/HPOvDshSDAdapt-02.00.001-HPUX11.0-release.depot

4 Run the file ovdsdpwdchg.sh from /opt/OV/bin on the command prompt. The 
OpenView Dashboard Service Desk Adapter Configuration dialog box appears. 

5 Enter the user name and password for HP OpenView Service Desk application server, 
click Save, and then click Exit.

6 To modify the HP OpenView Service Desk adapter configuration, edit the following 
properties file:

/var/opt/OV/conf/ovdshsdadapter/OVSDAdapterConfig.properties

7 Run the file ovsd_adapter.sh from /opt/OV/bin on the command prompt. The 
adapter starts running as a daemon.

Attribute Description Default

Hostname The machine on which the 
HP OpenView Service Desk 
application server is running

localhost

Port The port on which the 
HP OpenView Service Desk 
measurement server is running

30999

Restart the adapter every time you edit the OVSDAdapterConfig.properties 
file.
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HP OpenView Service Navigator

System Requirements

In order to install the adapter successfully, the target management station must meet the 
following minimum system requirements:

Installation Tasks

Perform the following tasks to install and configure the adapter:

1 Configure HP OpenView Operations for UNIX

2 Install and Configure the Adapter for HP OpenView Service Navigator

Task 1: Configure HP OpenView Operations for UNIX

1 Run opc at the command prompt. The user interface for OVO for UNIX opens.

2 On the Actions menu, click Server→ Configure. The Configure Management Server window 
opens.

Table 5 System Requirements for the Adapter for HP OpenView Service 
Navigator  

Software Requirements

Operating System HP UX 11.11 and HP UX 11.23 PA-RISC

HP OpenView Service 
Navigator 

 Versions 7.x and 8.x.
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3 Select the following options:

• Under Message Stream Interface, select Enable Output. 

• Under Enable Output, select Send All Messages to Server MSI.

4 Select Copy Messages. 

5 Click OK to save your configuration choices.

Task 2: Install and Configure the Adapter for HP OpenView Service Navigator

1 Copy the file HPOvDshAdapter-02.00.001.tar.gz to the HP OpenView Service 
Navigator management station.

2 Extract the contents of the file to a local subdirectory <ExtractDir>.  

3 At the command prompt, install the extracted files by using the swinstall command. 
Make sure that you install the files in the listed sequence.

a swinstall -s 
<ExtractDir>/HPOvXpl-02.61.050-HPUX11.0-release.depot

b swinstall -s 
<ExtractDir>/HPOvJxpl-02.61.050-HPUX11.0-release.depot

c swinstall -s <ExtractDir>
/HPOvJre-01.04.220-HPUX11.0-release.depot

d swinstall -s <ExtractDir>
/HPOvDshRhvCo-02.00.001-HPUX11.0-release.depot
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e swinstall -s <ExtractDir>
/HPOvDshSNAdapt-02.00.001-HPUX11.0-release.depot

4 To modify the HP OpenView Service Navigator adapter configuration, edit the following 
properties file:

/var/opt/OV/conf/ovdshsnadapter/OVSNAdapterConfig.properties

5 Run the file ovsn_adapter.sh from the location /opt/OV/bin in the command prompt. 
The adapter starts running as a daemon.

HP OpenView Operations for Windows

System Requirements

In order to install the adapter successfully, the target management station must meet the 
following minimum system requirements:

Attribute Default Value Description

MESSAGE_COUNT 5 The maximum number of HP OpenView 
Operations messages you want to view for 
an HP OpenView Service Navigator service 
element.The MESSAGE_COUNT is the 
maximum number of messages to be 
fetched by the RealTime Health View 
server at every polling interval.

OVSN_SERVICE_TREE_DEPTH 3 The depth of the imported HP OpenView 
Service Navigator service tree. This is 
useful when you want to control the depth 
of 
HP OpenView Service Navigator service 
tree, which is displayed in RealTime 
Health View composer.

Restart the adapter every time you edit the OVSNAdapterConfig.properties 
file.

Table 6 System Requirements for the Adapter for HP OpenView Operations for 
Windows

Software Requirements

Operating System Windows 2003

HP OpenView Operations 
for Windows

Versions 7.21 and 7.5

Microsoft .NET framework Version 1.1 or greater
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Installation Tasks

Perform the following steps to install and configure the adapter:

1 Copy the HPOvDshAdapter-02.00.001.zip to the HP OpenView Operations for 
Windows management station and extract the contents of the file. 

2 Run the extracted files in the following sequence:

a HPOvXpl-02.61.050-WinNT4.0-release.msi

b HPOvJxpl-02.61.050-WinNT4.0-release.msi

c HPOvJre-01.04.211-WinNT4.0-release.msi

d HPOvDshRhvCo-02.00.001-WinNT4.0-release.msi

e HPOvDshOWAdapt-02.00.001-WinNT4.0-release.msi

3 To modify the HP OpenView Operations for Windows adapter configuration, edit the 
following properties file: 

<OvDataDir>\conf\ovdshowadapter\OVOWAdapter.cfg.

4 Start the adapter as a service from Windows service explorer.

Verifying Adapter Installation

To verify that the adapter is installed and running on the management station, load the 
following URL in a browser:

http://<hostname>:<port number>/axis/services/<adapter>?wsdl

where <hostname> is the name of the management server, <portnumber> is the port used by 
the adapter, and <adapter> is the web service name of the adapter.

The default port numbers and names of all the adapters are listed in the table below.

Attribute Default Value Description

hierarchydepth 3 The depth of the imported HP OpenView Operations 
for Windows service tree. You can edit this attribute 
to control the depth of HP OpenView Operations for 
Windows service tree. 

messagecount 5 The maximum number of HP OpenView Operations 
messages you want to view for a service element of
HP OpenView Operations for Windows. The 
MESSAGE_COUNT is the maximum number of messages 
to be fetched by the RealTime Health View server at 
every polling interval

Restart the adapter every time you edit the OVOWAdapterConfig.cfg file.
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 If the adapter is installed and running, a page similar to the following appears.

After you install adapters on the target management stations, it is time to configure RealTime 
Health View to use the adapters. For more information about adding adapters by using the 
OV Dashboard Configuration Manager, see Configure Adapters with RealTime Health View 
on page 34.

Adapter Name
Default Port 
Number

Web Service Name of the 
Adapter 

Adapter for 
HP OpenView Internet 
Services

18091 OVISAdapter

Adapter for 
HP OpenView Service 
Desk

18092 OVSDAdapter

Adapter for 
HP OpenView Service 
Navigator

18093 OVSNAdapter

Adapter for 
HP OpenView 
Operations for Windows

18094 OVOWAdapter
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Changing Port Numbers of Adapters

If the default port of an adapter is used by some other application, you must change the port 
number of the adapter on the management server. 

Perform the following steps on the management server to change the adapter port number on 
Windows:

1 On management server, open Registry Editor window.

2  On left pane of the window, expand HKEY_LOCAL_MACHINE → System → ControlSet001 → 
Services → <adapter service name>, where <adapter service name> is the name of the 
adapter service in Windows.

3 Click Parameters.

4 On the right pane, double-click Start Param Number 1. The Edit String dialog box appears.

5 In the Value data text box, enter an available port number, and then click OK.

Perform the following steps to change the adapter port number on HP-UX:

1 Go to the location /opt/OV/bin.
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2 To change the existing port of the adapter for HP OpenView Service Navigator, run the 
following command in the command prompt:

./ovdsnadapterportchg.sh <port number>

where <port number> is an available port.

3 To change the existing port of the adapter for HP OpenView Service Desk, run the 
following command in the command prompt:

./ovdsdadapterportchg.sh <port number>

where <port number> is an available port.

Uninstalling Adapters

Perform the following steps to uninstall an adapter:

Windows

1 Go to Start → Settings → Control Panel.

2 Click Add/ Remove Programs. Add/ Remove Programs window appears.

3 Remove the adapter from Add/ Remove Programs window.

HPUX 

On HP-UX environment, run swremove command in the command prompt to uninstall the 
adapter.
Installing and Configuring Adapters 27



Importing Large Service Trees

By default, the adapters are capable of importing service trees of approximately one MB in 
size and three levels of depth. You can customize the level of depth up to twenty by editing the 
adapter properties file. However, if the size of the service tree is greater than one MB and 
depth is more than twenty levels, RealTime Health View may fail to import service definitions 
from the source management station. To counter this limitation, you must increase the Java 
Virtual Machine (JVM) heap size of the management stations where adapters are installed.

Increase the JVM Heap Size

To increase the JVM heap size of an adapter, perform the following steps:

Windows

1 Stop the adapter service from the Services window.

2 Open the Registry Editor window.

3 To increase the JVM heap size of the adapter for HP OpenView Service Desk, perform the 
following:

a In the left pane, expand HKEY_LOCAL_MACHINES → System → ControlSet001 → 
Services → HP OpenView Dashboard Service Desk Adapter, and then click Parameters.

b In the right pane, double-click JVM Option Number 6. The Edit String dialog box 
appears.

c In the Value Data text box, change the value from -Xmx256m to -Xmx512m and click OK.

4 To increase the JVM heap size of the adapter for HP OpenView Internet Services, perform 
the following:

a In the left pane, expand HKEY_LOCAL_MACHINES → System → ControlSet001 → 
Services → HP OpenView Dashboard Internet Services Adapter, and then click Parameters.

b In the right pane, double-click JVM Option Number 6. The Edit String dialog box 
appears.

c In the Value Data text box, change the value from -Xmx256m to -Xmx512m and click OK.

5 To increase the JVM heap size of the adapter for HP OpenView Operations for Windows, 
perform the following:

a In the left pane, expand HKEY_LOCAL_MACHINES → System → ControlSet001 → 
Services → HP OpenView Dashboard Operations Windows  Adapter and click Parameters.

b In the right pane, double-click JVM Option Number 8. The Edit String dialog box 
appears.

c In the Value Data text box, change the value from -Xmx256m to -Xmx512m and click OK.

6 Restart the adapter service from the Services window.

HP-UX

1 Stop the adapter daemon.

2 To increase the JVM heap size of the adapter for HP OpenView Service Navigator, 
perform the following steps:
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a Open the file ovsn_adapter.sh from /opt/OV/bin/.

b Go to the line:
nohup $ADAPTER_HOME/nonOV/jre/1.4/bin/java -cp $CP $SYSPROPS -Xms128m 
-Xmx256m org.apache.axis.transport.http.SimpleAxisServer -p $PORT >> 
$LOGFILE 2>&1 &

c Change -Xmx256m to -Xmx512m

3 To increase the JVM heap size of the adapter for HP OpenView Service Desk, perform the 
following steps:

a Open the file ovsd_adapter.sh from /opt/OV/bin/.

b Go to the line:
nohup $ADAPTER_HOME/nonOV/jre/1.4/bin/java -cp $CP $SYSPROPS -Xms128m 
-Xmx256m org.apache.axis.transport.http.SimpleAxisServer -p $PORT >> 
$LOGFILE 2>&1 &

c Change -Xmx256m to -Xmx512m

4 Restart the adapter daemon.
Installing and Configuring Adapters 29



30 Chapter 3



4 Configuring RealTime Health View
After installing HP OpenView Dashboard RealTime Health View, you can configure it by 
using the OV Dashboard Configuration Manager. OV Dashboard Configuration Manager 
enables you to enter or modify configuration parameters and to start or stop the RealTime 
Health View server. By using the OV Dashboard Configuration Manager, you can perform the 
following tasks:

• Start and stop RealTime Health View server.

• Add or remove adapters.

• Assign dashboards to users.

• Remove dashboards from users.

• Change the database details for RealTime Health View.

• Change the server properties for RealTime Health View.

Organization of OV Dashboard Configuration Manager

OV Dashboard Configuration Manager consists of five tabs. These tabs are:

• Server — This tab displays RealTime Health View server related information, such as 
port number and polling interval. 

• Database — This tab displays database configuration information, such as database 
type, database driver name, database driver type, and so on. You can modify the database 
properties of RealTime Health View from this tab.

• Adapter — This tab displays the list of configured adapters. You can add or remove 
adapters here.

• Dashboard — This tab displays the list of users and available dashboards. Here you can 
assign a dashboard to a particular user.

• Administrator — You can start and stop RealTime Health View servers from this tab.

Configuration Procedure

To be able to start and use RealTime Health View, you must complete the following 
configuration procedure using the OV Dashboard Configuration Manager. 

1 Launch Configuration Manager

2 Configure Server Details

3 Configure Database Properties
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4 Configure Adapters with RealTime Health View

5 Start Servers

Launch Configuration Manager

From Start menu, click Programs  → HP OpenView → Dashboard → RealTime Health View → 
Configuration Manager. OV Dashboard Configuration Manager appears.

If you try to launch the OV Dashboard Configuration Manager while it is already running, the 
following error message appears:

An instance is already running.

Configure Server Details

When OV Dashboard Configuration Manager is launched, Server tab is selected by default 
and Server details section is displayed. 

In this section, you can set and modify the following server properties:

• Port — This is the port number of RealTime Health View application. By default, it is set 
as 55000. Enter an available port number in the Port text box if the default port number is 
already being used by some other application.

• Polling Interval — Polling is a process by which RealTime Health View continuously 
retrieves data from management servers. You must set the interval of polling (in minutes) 
in Polling interval text box.

If you try to launch OV Dashboard Configuration Manager after it was abruptly closed, you 
may see the above mentioned error message. In that case, you must delete the file gui.lck 
from <OvInstallDir>\bin, and then launch OV Dashboard Configuration Manager.
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After you set the server properties, click Save.

Configure Database Properties

You must configure the database properties in OV Dashboard Configuration Manager to be 
able to connect to a database. You can use the default Microsoft SQL Server 2005 Express 
Edition database that was created while installing RealTime Health View, or a custom 
database.

To configure the database properties, perform the following steps:

1 Select Database tab. Database Configuration section appears. 

By default, it displays the following:

— database as Microsoft SQL Server 

— Driver Type as Inet Type 4 Driver (Windows Authentication for Named Instance)

— Driver name as com.inet.pool.PoolDriver

— URL as jdbc:inetpool:inetdae7://<localhost>/pipe/MSSQL$OVDASHBOARD/sql/
query?database=ovddb. 

2 Keep all the default settings, leave User Name and Password fields blank, and then click 
Save.

It is recommended to configure RealTime Health View with the default database settings 
first. If the default database is not adequate for your requirement, you can use any other 
relational database. Refer to Configuring Custom Database on page 35 for information on 
configuring custom database with RealTime Health View.

RealTime Health View is also verified to work with Oracle 9i.
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 Configure Adapters with RealTime Health View

You must configure and add adapters installed on management servers to OV Dashboard 
Configuration Manager to retrieve runtime data. Perform the following steps to configure 
adapters on OV Dashboard Configuration Manager:

1 Select Adapter tab. The Adapters section appears.

2 Click Add. The Enter adapter details dialog box appears.

3 From the Product Name drop down box, select the name of the adapter.

4 In the Host text box, enter the hostname or IP address of the system where the adapter is 
installed.

5 In the Port text box, enter the port number used by the adapter.

6 Click OK.
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7 Repeat steps 2 to 6 to add more adapters.

Start Servers

To start RealTime Health View server, perform the following:

1 Select the Administrator tab. The Server section appears.

2 Click the Start buttons to start RealTime Health View server and portal server. Click Start 
All to start both the servers together.

Configuring Custom Database

You can configure OV Dashboard Configuration Manager to connect to a database other than 
the default database. The custom databases can be

• a Microsoft SQL Server 2000 Enterprise Edition database

• a Microsoft SQL Server 2000 Desktop Engine database

• an Oracle database

Configure Microsoft SQL Server Database

Instead of using the default database, you can use a different Microsoft SQL database as the 
back-end database.You can either use a database available in your local system, or a database 
in a remote system in the network domain.
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The OV Dashboard Configuration Manager gives you a set of options to choose the database 
driver type and the database. After you select a driver type, the driver name appears in the 
Driver Name text field. Url text field displays the url string with variable parameters such as 
<hostname> and <database>.

Create Database in Microsoft SQL Server

Perform the following steps to create a database in Microsoft SQL Server:

1 From Start menu, click Programs → Microsoft SQL Server → Enterprise Manager. Enterprise 
Manager window appears.

2 On left pane, expand Microsoft SQL Servers → SQL Server Groups. List of available servers 
appear on the left pane.

3 Double-click the server where you want to create the database. 

4 Double-click the Database folder on left pane. Set of all the available databases on that 
server appears on the right pane.
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5 On the menu bar, click Tools  → SQL Query Analyzer. SQL Query Analyzer window appears.

6 From File menu, open the query file eddb_script.sql from the location 
<OvInstallDir>\misc\dashboard\rhview\server. The contents of the script file 
appears on the editor pane.

7 Click Query → Execute. ovddb database is created.

8 If you want to use Windows authentication, you need not create a login as Windows 
authentication does not need login and password. If you want to use SQL authentication, 
you must create a login. Perform the following steps to create a login for ovddb:
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a In the left pane of SQL Server Enterprise Manager window, expand Security folder.

b Right-click on Logins icon, and then select New Login. SQL Server Login Properties - 
NewLogin dialog-box appears.

– In Name text-field, enter a name for the login. For example, test.

– Select SQL Server Authentication radio button.

– Enter a password for the login test in Password text-field.

– Select the database that was created in step 7 from the Database drop-down box.

– Keep the Language setting as default, and then click OK. Confirm Password 
pop-up appears.

– Enter the password in Confirm new password text-filed, and then click OK. The 
login is created and appears on the details pane.

– Right-click the newly created login, and then select Properties. SQL Server Login 
Properties dialog-box for the login appears.

– Go to Database Access tab.

–  Select ovddb check-box to specify the database that test can access, select 
db_owner check-box, and then click OK.

Configure RealTime Health View for Microsoft SQL Server Database

After you set up the Microsoft SQL Server database and driver, perform the following steps to 
use a custom Microsoft SQL Server as back-end database:

1 Select Database tab. Database Configuration section appears.

2 Select the option Microsoft SQL Server from the Database drop-down list.

3 Specify the following database configuration parameters:

— Driver Type

— Driver Name

For more information, refer to the documentation provided with Microsoft SQL Server.
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— URL 

— Username

— Password 

Table 7 lists the details of database configuration parameters for a Microsoft SQL Server 
database.

 

Table 7 Configuration Parameters for Microsoft SQL Server Database

Serial
No. Driver Type Driver Name URL Login Details

1.0 Inet Type 4 
Driver 
(Windows 
Authentication 
for Named 
Instance)

com.inet.pool.
PoolDriver

For local database —
jdbc:inetpool:inetdae7
://<localhost>/pipe/
MSSQL$<instance 
name>/sql/
query?database=<data
base name>
where <database name> 
is the name of the 
database and <instance 
name> is the name of the 
database instance.

Leave the User 
name and 
Password fields 
blank.

For remote database —
jdbc:inetpool:inetdae7
:// <hostname>/pipe/
MSSQL$<instance 
name>/sql/
query?database=<data
base name>
where <database name> 
is the name of the 
database, <hostname> is 
the hostname or IP 
address of the system, 
and <instance name> is 
the name of the database 
instance.

Leave the User 
name and 
Password fields 
blank. For a 
remote database,
Windows 
Authentication for 
Named Instance 
only works when 
the host system of 
the remote 
database and 
RealTime Health 
View server are in 
same domain.
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2.0 Inet Type 4 
Driver 
(Windows
Authentication)

com.inet.pool.
PoolDriver

For local database —
jdbc:inetpool:inetdae7
://<localhost>/pipe/
sqlquery?database=
<database name>
where <database name> 
is the name of the 
database

Leave the User 
name and 
Password fields 
blank.

For remote database —
jdbc:inetpool:inetdae7
://<hostname>/pipe/
sqlquery?database=
<database name>
where <database name> 
is the name of the 
database
and <hostname> is the 
hostname or IP address 
of the system.

Leave the User 
name and 
Password fields 
blank. For a 
remote database,
Windows 
Authentication  
only works when 
the host system of 
the remote 
database and 
RealTime Health 
View server are in 
same domain.

Table 7 Configuration Parameters for Microsoft SQL Server Database

Serial
No. Driver Type Driver Name URL Login Details
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4 Click Save to save the database configuration.

3.0 Inet Type 4 
Driver (SQL 
Authentication)

com.inet.pool.
PoolDriver

For local database —
jdbc:inetpool:inetdae7
:<localhost>:1433?data
base=<database name>
where <database name> 
is the name of the 
database

Enter the User 
name and 
Password to access 
the database 
<database name>.

For remote database —
jdbc:inetpool:inetdae7
:<hostname>:1433?data
base=<database name>
where <database name> 
is the name of the 
database
and <hostname> is the 
hostname or IP address 
of the system.

Enter the User 
name and 
Password to access 
the database 
<database name>.

4.0 Inet Type 4 
Driver (SQL 
Authentication 
for Named 
Instance)

com.inet.pool.
PoolDriver

For local database —
jdbc:inetpool:inetdae7
:<localhost>/<instance 
name>?database=<dat
abase name>
where <database name> 
is the name of the 
database and <instance 
name> is the name of the 
database instance.

Enter the User 
name and 
Password to access 
the database 
<database name>.

For remote database —
jdbc:inetpool:inetdae7
: <hostname> /<instance 
name>?database=<dat
abase name>
where <database name> 
is the name of the 
database, <hostname> is 
the hostname or IP 
address of the system, 
and <instance name> is 
the name of the database 
instance.

Enter the User 
name and 
Password to access 
the database 
<database name>.

Table 7 Configuration Parameters for Microsoft SQL Server Database

Serial
No. Driver Type Driver Name URL Login Details
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Configure Oracle Database

As RealTime Health View supports Oracle database, you can use a database in Oracle to use 
with RealTime Health View. To use Oracle as database, you must have Oracle installed in the 
system where the database is hosted.

Create Database in Oracle

Perform the following steps to create a database in Oracle: 

1 Launch SQL Plus. You can also perform the following steps using the Enterprise Manager 
Console.

2 Create tablespace into which you will load the tables for RealTime Health View.

Run the following script on SQL command prompt:

CREATE TABLESPACE ovddb
DATAFILE '<Oracle Install Directory>\oradata\<test>\ovddb.dbf'
SIZE 10M
AUTOEXTEND ON NEXT 10M
MAXSIZE unlimited;

Where ovddb is the name of the tablespace. You must enter the DATAFILE location 
according to your oracle installation location. 

<Oracle Install Directory> is the directory where Oracle is installed in the system.

<test> is the name of the instance or System Identifier (SID).

You must reference this name while creating the database user. This command creates 
10MB of tablespace, and then automatically extends the tablespace as needed.

3 Create a user profile, which will be used by RealTime Health View:

Run the following script on SQL command prompt:

CREATE USER <user_name> PROFILE DEFAULT
IDENTIFIED BY <password> DEFAULT TABLESPACE ovddb
ACCOUNT UNLOCK;
GRANT CONNECT TO <user_name>;
GRANT RESOURCE TO <user_name>;

This command creates a user in the database. <user_name> is the name of the database 
user, password is the user's password, and ovddb is the default tablespace assigned to the 
user. 

4 Log in to Oracle with the newly created user account. Run the following command in the 
SQL command prompt to log in:

CONNECT <user_name>/<password>

5 Create the schema for ovddb. To create the schema, run the following script in the SQL 
command prompt:

@<path>/eddb_orascript_ddl.sql

<path> is the full path to the file eddb_orascript_ddl.sql. If HP OpenView 
Dashboard is installed in <OvInstallDir>, <path> is 
<OvInstallDir>\misc\dashboard\rhview\server.
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6 Verify if any error message appears.

7 The database tables are created in the database ovddb.

8 Insert the required default data in ovddb. To insert the default data, run the following 
script in the SQL command prompt:

@path/ eddb_orascript_dml.sql

<path> is the full path to the file eddb_orascript_ddl.sql. If HP OpenView 
Dashboard is installed in <OvInstallDir>, <path> is 
<OvInstallDir>\misc\dashboard\rhview\server.

9 Verify if any error message is displayed.

The default values are inserted in ovddb.

Set up Oracle Driver

To be able to use Oracle as back-end database, you also need to set up Oracle driver. Perform 
the following steps to download and set up the Oracle driver:

1 Download the Oracle Type 4 Thin Driver – ojdbc14.jar from following location:

http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/htdocs/
jdbc9201.html

2 Copy the ojdbc14.jar file to the following two locations:

• <OvInstallDir>\nonOV\dashboard\rhview

• <OvInstallDir>\nonOV\dashboard\rhview\jetspeed\jakarta-tomcat-5.0.30\s
hared\lib

Configure RealTime Health View for Oracle Database

After you set up the Oracle database and driver, perform the following steps to use Oracle as 
back-end database:

1 Select Database tab. Database Configuration section appears.

2 Select the option Oracle from the Database drop-down list.

3 Specify the following database configuration parameters:

— Driver Type: Select the JDBC database driver from the list of available drivers. Select 
Oracle Type 4 Thin Driver- ojdbc14.jar.

— Driver Name: Default is set to oracle.jdbc.driver.OracleDriver.

— URL: Type the JDBC URL. For example, jdbc:oracle:thin:@gspint7:1521:<Host 
String>=ovddb. Here, Host String is the instance or SID that was created in step 2 
on page 42. 

The eddb_orascript_ddl.sql script creates tables into the user's default tablespace. 
If you do not want to assign the tablespace of ovddb as the user's default 
tablespace, you must edit the script

For more information, refer to the documentation provided with Oracle.
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— Username: Type the username for accessing the database that was created in step 2 
on page 42.

— Password: Type the password for accessing the database that was created in step 2 on 
page 42. 

4 Click Save to save the database configuration.

Table 8 lists the details of database configuration parameter for Oracle database.

Configuring BEA WebLogic as Portal Server

RealTime Health View supports BEA WebLogic as portal server. Jetspeed is bundled with 
RealTime Health View and installed automatically during installation. If you want to use 
BEA WebLogic as the portal server for RealTime Health View, you must have BEA WebLogic 
8.1 Workshop installed on the system where RealTime Health View is installed.

To configure BEA WebLogic to be used as a portal server, perform the following.

1 Create a Portal Domain

If you change the database from Microsoft SQL Server to Oracle, or vice versa, you must 
restart the servers from OV Dashboard Configuration Manager for the changes to take effect.

Table 8 Configuration Parameters for Oracle Database

Serial
No. Driver Type Driver Name URL

Login
Details

1.0 Oracle Type 4 
Thin Driver

oracle.jdbc.driv
er.OracleDriver

For local database —
jdbc:oracle:thin:@
localhost:<portname>
:<Host String>
where <portname> is the 
port name of Oracle 
database and <Host String> 
is the name of the System 
Identifier created in step 2 
on page 42.

Enter the 
User name 
and 
Password of 
the Oracle 
database.

For remote database —
jdbc:oracle:thin:@
<hostname>:<portname>
:<Host String>
where <hostname> is the 
name of the system, 
<portname> is the port 
name of Oracle database, 
and <Host String> is the 
name of the System 
Identifier created in step 2 
on page 42.

Enter the 
User name 
and 
Password of 
the Oracle 
database.
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2 Deploy RealTime Health View Portlet Application to BEA WebLogic

Create a Portal Domain

To create a portal domain in BEA WebLogic, perform the following steps:

1 From Start menu, click Programs  → BEA WebLogic Platform 8.1 → Configuration Wizard. 
BEA WebLogic Configuration Wizard appears.

2 Select Create a new WebLogic configuration radio button, and then click Next.

3 Select Basic WebLogic Portal Domain from the Templates pane, and then click Next. 
Choose Express or Custom Configuration screen appears.

4 Select Express radio button, and then click Next.

5 Enter a name and password in User name and User password fields. These access details 
will be used as administrative username and password.

6  Click Next. Configure Server Start Mode and SDK screen appears.

7  Keep all the default settings, and then click Next. Create WebLogic Configuration screen 
appears. 

8 If you want, you can change the configuration name, and then click Create.

9 Click Done.

Deploy RealTime Health View Portlet Application to BEA WebLogic

Perform the following tasks to deploy RealTime Health View portlet application to BEA 
WebLogic:

1 Create a Portal Application

2 Create a Web Application

3 Deploy the Application

Task 1: Create a Portal Application

1 Start BEA WebLogic Workshop 8.1.

2 Click File → New → Application. New Application dialog-box appears.

3 Select Portal Application on right pane.

4 In the Directory field, enter the location where you want to store the application.

5 In the Name field, enter a name of the application.

6 Make sure that the data in the Server field is the location of config.xml file for the 
newly created portal domain. See Create a Portal Domain on page 45 for information on 
creating a portal domain in BEA WebLogic.

7 Click Create. The new portal application appears in Application pane.

Task 2: Create a Web Application

1 Copy the ovdportal.war file from <OvInstallDir>\java to a local directory.

2 Extract the contents of this file. To extract the contents, go to the location you copied 
ovdportal.war, and then run the command jar -xvf ovdportal.war.
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3 Import the project to WebLogic Workshop 8.1. To do this, perform the following steps:

a In WebLogic Workshop 8.1, click File → Import Project. Import Project - New Project 
dialog-box appears.

b Select portal on left pane. The list of projects appear on right pane.

c Select the portal web project from right pane. 

d Click Browse, and then navigate to the directory where you want to stage the 
RealTime Health View portlet application.

e Select the Copy into Application directory check box.

f The value in the Name field is the name that will appear in the BEA WebLogic 
configuration tools.Verify the project name, change the name if necessary, and then 
click Import. A popup to update the Workshop appears.

g Click Yes.

Task 3: Deploy the Application

1 Click Build → Build EAR. It creates the EAR file <application name>.ear where 
<application name> is the name of the application. 

2 Deploy the EAR file in WebLogic.

Configuration for Custom Database

If you are using a custom database instead of the default one, you must copy the 
DATABASE_DETAILS.properties file from the location 
<OvDataDir>\conf\dashboard\rhview\common to 
<BEA-HOME>\user_projects\Application\<Application Name>\<Project 
Name>\WEB-INF\classes
where <Application Name> is the name of the application created in step 5 on page 45 and 
<Project Name> is the name of the project imported in step f on page 46.

For more information, refer to the documentation provided with BEA WebLogic Workshop 
8.1.
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5 Creating Dashboards
You can use the RealTime Health View composer module to design the portal views that your 
end users see. RealTime Health View collects real-time data from various management 
systems via web service based adapters.

The composer enables you to do the following:

• Import services from management applications and other data sources such as HP 
OpenView Internet Services, HP OpenView Service Navigator, HP OpenView Service 
Desk, and Mercury Business Availability Center. You can also import SQL data sources by 
using queries.

• Create, modify, or remove dashboard views and define service groups. This enables you to 
display high-level service views grouped by geographies, business units, organizational 
units, and so on.

• Deploy any newly designed dashboard view so that it displays as a complete portal-based 
web site. The portal view also displays all drilldowns based on the content template you 
select in the composer.

Organization of Composer

To launch the composer, click Start → Programs → HP OpenView → Dashboard →

RealTime Health View → Composer. The HP OpenView Dashboard Service Composer window 
opens.

The composer is divided in three panes — navigator pane, summary pane, and view pane.
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Figure 2 Composer for RealTime Health View

• Navigator pane – it is a navigation tool go to existing dashboards and data sources. Basic 
elements of this pane are Dashboard, Data Sources, and Standalone Services.

Figure 3 Navigator Pane

— Dashboard – this element contains existing dashboards. If you expand this element, 
you can see the available dashboards.

— Data Sources – This element has two sub-elements — HTTP and SQL. RealTime 
Health View imports data from remote servers with the help of adapters. It can also 
collect data from a SQL Server (available in the network), or an HTTP web address. 
These SQL Servers and HTTP servers are called data sources. You can expand each 
element to see the available data sources configured inside the group.

— Standalone Services – this displays the list of underlying services imported from 
management servers. It also lists the user-defined data source that are configured for 
status calculation.

• Summary pane – the summary pane is located right below the navigation pane. It 
displays the details of each element of the navigation pane. 
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Figure 4 Summary Pane

If you select a particular dashboard, imported service, or data source in the navigation 
pane, the summary pane displays the following details.

— Type – the type of the element, whether it is a dashboard, HTTP data source, or SQL 
data source.

— Name – name of the element

— Deployment Status – whether the element is deployed or not

— Description – description about the element. For example, name of the dashboard.

— Last saved – date and time when the element was saved

• View pane – This pane is located at the right side of the navigation pane and summary 
pane. You need to use this pane while modeling a dashboard or creating a new data 
source.

Designing a Dashboard

To design and deploy a new dashboard, you need to perform the following steps based on your 
requirement and the type of dashboard you want to build:

1 Import Service Definitions

2 Create Data Sources

3 Create a New Dashboard

4 Build the Dashboard

5 Generate the Dashboard

Import Service Definitions

Perform the following steps to import service definitions from adapters.

1 On the menu bar, click Services → Import Service Definitions. The Import Services pop-up 
box appears displaying the list of available adapters.

2 Select the adapters that you want to use, and then click OK. The selected adapters are 
imported to the composer.

Step 2 is optional. Skip this step if you do not want to add data sources to your dashboard.
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3 On the navigator pane, click and expand Standalone Services → Imported Services. The list 
of imported adapters appear.

4 You can click on an individual adapter to see the list of services available with each 
adapter.

Create Data Sources

If you do not need to retrieve data from SQL or HTTP data sources, skip to the next section. 
You can create the following two types of data sources: 

• HTTP data source

• SQL data source

Prerequisite

Before you create a data source, you must meet the following prerequisites:

• If you want to create an HTTP data source, you must edit the 
HTTPDataSource.properties files with proxy settings of your browser. Perform the 
following steps to edit HTTPDataSource.properties files:

a Open HTTPDataSource.properties files from the locations 
<OvDataDir>\conf\dashboard\rhview\composer and 
<OvDataDir>\conf\dashboard\rhview\server.

b Edit the following lines in both the files to change the proxy server name and the port 
number:

proxyserver=abc-proxy.xyz.hp.com
proxyserverport=8021

• If you want to create an SQL data source, perform the following steps to edit 
SQLDataSource.properties files.

a Open the SQLDataSource.properties file from the location 
<OvDataDir>\conf\dashboard\rhview\composer.

b Change the number of rows to be displayed on the portal from the extracted data, 
using the SQL data source. In the following line, change '0' to the number of lines that 
you want to display on the portal: Response_Truncation=0

• If you want to create an HTTP data source or an SQL data source for status calculation, 
you must have Perl installed on the RealTime Health View system. Also, you must edit 
the oved-repository.cfg file with the location details of Perl. 

To edit oved-repository.cfg:

You can verify whether the service definitions have been imported or not from the 
status bar of the Composer window. It displays a message, Service imported if the 
service is imported successfully. Otherwise, it shows an error message, Error 
occured during service synchronization.

If the default value zero is used, then RealTime Health View server fetches all the 
rows available for that data source. If the data is too large, then JVM may throw 
Out of Memory exception.
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a Open the oved-repository.cfg file from 
<OvDataDir>\conf\dashboard\rhview\server.

b Under the UDDS section, set EXEC_PATH to the location of Perl, and SUFFIX to.pl.

For example:

[udds]
EXEC_PATH=C:\Perl\bin\perl.exe
SUFFIX=.pl.

Create HTTP Data Source

You can create three different types of HTTP data sources — configured URL, raw data, and 
status calculation. 

Perform the following steps to create an HTTP data source:

1 In the navigator pane, right click on Data Sources, and then click New → Http datasource.

 The HTTPUserDefinedService dialog box appears on the view pane.

2 In the HTTPUserDefinedService dialog box, enter the name and description of the data 
source under the Datasource Identity tab.
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3 Select the Proxy check box under Datasource Properties tab to enable connection through 
proxy server. It is not necessary to select this check box if you want to connect to an 
intranet address.

4 Perform the following to configure the HTTP data source as configured URL.
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a  Select Configured URL from the Runtime Data Type drop-down list.

b In the Configured URL Details section, enter name of the URL in the Label text field.

c In the same section, enter a web address in the URL text field, and then click Test & 
Add. The URL is added to the Configured URL Details panel. You can add more than 
one URL. This URL appears in the dashboard portal as a hyperlink.

5 Perform the following steps to configure the HTTP data source as raw data:

a Select Raw Data from the Runtime Data Type drop-down list.

b In the Datasource Information section, enter the name of the URL in the Label text 
field.

c In the same section, enter a web address in the URL text field, and then click Test. If 
the URL is correct, a confirmation pop-up appears. The content of the page linked to 
this URL appears in a portlet in the dashboard portal.

6 Perform the following steps to configure the HTTP data source as status calculation.

a Enter data in the Label and the URL text fields in the Datasource Information 
section.

b Paste a Perl script in the Transformation Script field. Refer to Guidelines for Writing 
Data Source Transformation Script on page 83 while creating a Perl script program.

Create SQL Data Source

Perform the following steps to create an SQL data source.

1 In the navigator pane, right click on Data Sources, and then click New → Sql datasource. 
The SQLUserDefinedService dialog box appears on the view pane.

Web pages with dynamic HTML content may not be displayed properly as raw 
data.
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2 Under the Datasource Identity tab, enter name and description of the data source.

3 In the SQL Details tab, enter a name for the data source in the Label field.

4  Check the System DSN check-box.

5 In the DSN Name field, enter the DSN name of the database which you want to connect to 
the dashboard.
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6 Enter the username and password in the text fields to access the database.

7 If you select Raw Data in the Runtime Data drop-down box, you must enter an SQL 
statement in the Query field, click the Save All icon, and then click Test to check if you can 
access the database.

8 If you select Status Calculation in the Runtime Data drop-down box, you must enter a 
Perl script in the Transformation Script field. Refer to Guidelines for Writing Data Source 
Transformation Script on page 83 while creating a Perl script program.  

If you create DSN by using Windows authentication, you do not need to enter any 
username or password.

Field Name Sample Value

In General Information section

Label SQL my Table

DSN Name myDSN

User name username

Password password

In Datasource Details section
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Create a New Dashboard

To create a new dashboard, perform the following steps. 

1 On the menu bar, click File → New → Dashboard.

Alternatively, in the Navigator pane, right-click on Dashboard folder, and then click New → 
Dashboard.

The dashboard appears with four tabs — Identity, Template Selection, Content Selection, 
and Dashboard Editor.

2 Under the Identity tab, enter name and description of the dashboard.

Runtime Data Type Raw data or Status Calculation

Query Select * from myDbTable
Enter this only when Runtime Data Type 
is Raw Data. Otherwise, leave this field 
blank

Transformation Script The Perl script for status calculation.  
(Enter the Perl script only when Runtime 
Data Type is Status Calculation. 
Otherwise, this field is disabled.)

Field Name Sample Value
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3 Under the Template Selection tab, choose the template. Each template gives a unique look 
and feel to the portal. The available templates are Classic, Default, and Magenta.

4 Under the Content Selection tab, select the content for the dashboard portal page from the 
list of available contents. The available content types are Service Manager Centric View, 
Business-IT Centric View, IT-Operation Centric View, and IT-Help Desk Centric View. The 
layout of the generated dashboard portal page differs based on the selected content type.
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5 Under the Dashboard Editor tab, you can see that the dashboard node icon appears in the 
composer canvas.

Build the Dashboard

Under the Dashboard Editor tab, you must build the dashboard hierarchy. Perform the 
following tasks to build a dashboard hierarchy, which is also known as service tree.

1 Create a Service Group

2 Create a Composite Service

3 Create an Elementary Service

4 Define Relationship

Task 1: Create a Service Group

A service group is a collection of composite services. After importing service definitions to a 
dashboard, you can create groups with the services imported from management servers. A 
group view usually represents a group of composite services or a sub-grouping of dashboard 
views for facilitating more summarized views. You can create organizational, geographical, or 
analogical grouping of your dashboard by creating service groups.

If you do not want to create a service group, skip this task. Perform the following steps to 
create a service group: 

1 From the menu bar at the top of the composer canvas, click the group icon and drop it on 
the composer canvas. 

2 To name the group, double-click on the group node. The Node Properties - Group dialog 
box appears. 

3 In the Name text box, enter a name of the group. 
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4 Select AND or OR depending on the status calculation requirement.

5 In the Description text box, enter a brief description of the group. 

6 Perform the following steps if you want to add any data sources to the group node. 

a Click the Data Source tab. The Datasources pane appears.

b On top left corner of the pane, click the new service icon. Select Services for Node 
pop-up appears.

c Expand the Data Sources folder, and then select the data source you want to add.

d Click OK

7 Click OK

Task 2: Create a Composite Service

To create a composite service, perform the following steps.

1  Click the Dashboard Editor tab.

2 From the menu bar, click Tools → Composite Service Node, and then click on the dashboard 
canvas. A new composite service node appears on the canvas.

3 Double-click the composite service node. The Node Properties CompositeService dialog 
box appears.
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The dialog box has four tabs — Node, Service, Data Source, and Look Across Service.

4 Go to the Node tab, and perform the following.

a In the Name text field, enter a name for the composite service. 

b In the Description text field, enter a brief description of the composite service. 

c Select AND, OR, or WEIGHT depending on the status calculation requirement.

5 Click the Service tab. Service pane appears.
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6 If you do not want to add a service for the node, skip to the next step. To add a service, 
click the Services tab, and then perform the following:

a On the top left corner of the pane, click the new service icon. Select Services for Node 
pop-up appears.

b Expand Standalone Services → Imported Services to see the list of available service 
definitions imported with the help of various adapters and SLIs.

c Select an available service, and then click OK. The service is added to the composite 
service.

7 Click the Data Source tab. The Datasources pane appears.
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8 If you do not want to add a data source to the node, skip to the next step. To add a data 
source, perform the following:

a On top left corner of the pane, click the new service icon. Select Services for Node 
pop-up appears. 

b Expand the Data Sources folder, and then select the data source you want to add.

c Click OK.

9 Click the Look Across Service tab. The LookAcross pane appears.

10 If you do not want to add a look across service, ignore this step. To add a look across 
service, perform the following.

a Click the new service icon. Select Look Across Services for Node pop-up appears.

b Expand the Imported Services folder, and then select an available service.

c Click OK.

11 Click OK on the Node Properties CompositeService dialog box.

Task 3: Create an Elementary Service

An elementary service is the basic unit of dashboard hierarchy. You can create independent 
nodes of elementary service, associate the elementary service with some underlying services 
imported from underlying management systems, and then add to a composite service node. To 
create an elementary service, perform the following:

1 Click the Dashboard Editor tab.

2 From the menu bar, click Tools → Service Node, and then click on the dashboard canvas. A 
new elementary service node appears on the canvas.

3 Double-click the node. The Node Properties - Service dialog box appears.
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4 In the Node tab, enter name and description of the service.

5 If you do not want to add an associated imported service to the node, skip to the next step. 
To add a service, click the Services tab, and then perform the following:

a On the top left corner of the pane, click the new service icon. The Select Services for 
Node pop-up appears.

b Expand Standalone Services → Imported Services to see the list of available service 
definitions imported with the help of various adapters and SLIs.

c Select an available service, and then click OK. The service is added to the elementary 
service.
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d Similarly you can select a user-defined service. To add a user-defined service, click 
Standalone Services → User Defined  Services on Select Services for Node pop-up.

6 Click the Data Source tab. The Datasources pane appears.

7 If you do not want to add a data source for the node, skip to the next step. To add a data 
source, perform the following.

a On the top left corner of the pane, click the new service icon. Select Services for Node 
pop-up appears.

b Expand the Data Sources folder, and then select the data source you want to add.

c Click OK.

8 Click OK on the Node Properties - Service dialog box.

9 Link the elementary service node to the composite service node. To do this, perform the 
following steps.

a From the tool bar on the dashboard editor pane, click the arrow icon.

b Bring the mouse arrow over the elementary service node, which you want to associate 
with composite service node. Plus (+) sign appears on the elementary service node.

c Click, drag, and drop the plus sign to the composite service node. The link between the 
nodes is established.

Task 4: Define Relationship

After importing service definitions to a dashboard, you must create a service tree by defining 
relationships between all the nodes in dashboard editor. To define relationships, you must 
perform the following.

• Link elementary service nodes to composite service nodes.

User-defined services are HTTP or SQL data sources with the type set to status 
calculation.
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• Link composite service nodes to dashboard node.

• Link composite service nodes to group nodes as required. 

• Link data sources to composite service nodes, group nodes, or directly to the dashboard 
node as required.

To link a lower-level node to a higher-level node, perform the following.

1 From the tool bar on the dashboard editor pane, click the arrow icon.

2 Bring the mouse arrow over the node, which you want to associate with a higher-level 
node. Plus (+) sign appears on the lower-level node.

3 Click, drag, and drop the plus sign to the higher-level node.The link between the nodes is 
established. 

Generate the Dashboard

After designing a dashboard and building the service tree, perform the following steps to 
generate it.

1 On the menu bar, click File → Generate Dashboard. The Generate Dashboard pop-up 
appears.

2 Click Generate Dashboard. After the dashboard is generated, a confirmation message 
appears.

After generating the dashboard, you must go to OV Dashboard Configuration Manager, click 
the Dashboard tab, and then associate the generated dashboard to a user. After associating a 
dashboard to a user, you can view the dashboard by logging in to the portal server via web 
browser.

An elementary service node cannot be directly linked to the dashboard node.

If some adapters to underlying data sources are down, some error may appear while 
generating the dashboard, but that does not prevent the generation of dashboard in most of 
the cases. The dashboard is generated if there is no fatal error.
Creating Dashboards 65



66 Chapter 5



6 Managing Users
As an administrator, you can create, delete, and manage portal user profiles for RealTime 
Health View. You can perform these tasks from the RealTime Health View portal.

The portal for RealTime Health View provides a platform to manage user profiles and 
displays the information provided by dashboard models. Portal has two types of login.

• User login: users view the dashboard assigned to the specific user’s profile.

• Administrator login: administrators can add, delete, and manage users.

 

Add and Manage Users in Jetspeed

Perform the following steps to manage user in Jetspeed portal:

1 Start the portal server from OV Dashboard Configuration Manager, if it is not already 
started.

2 From Start menu, Click Programs → HP OpenView → Dashboard → RealTime Health View → 
Web Portal. Jetspeed portal’s login page appears.

3 Log in with the administrator's user name and password.

4 Click the Security tab. User Browser section appears with the list of existing users. 

5 To add a new user, click Add User link below the list of users.

6 Enter the user details, and then click Add User. The user is added to the user list.

Add and Manage Users in BEA WebLogic

BEA WebLogic portal server is not bundled with RealTime Health View. You must have BEA 
WebLogic 8.1.4 installed in RealTime Health View system to be able to use it. 

To create or delete a user account from the portal, you must log in to the portal with 
administrator privileges.

 In Jetspeed, the default administrator's user name is admin and password is 
jetspeed.

In Jetspeed, the user name must not exceed 256 characters.
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Refer to Configuring BEA WebLogic as Portal Server on page 44 to configure BEA WebLogic.

Perform the following steps to use BEA WebLogic portal to manage users:

1 Copy weblogic.jar from <BEA_HOME>\weblogic81\server\lib to the location 
<OvInstallDir>\nonOv\dashboard\rhview where <BEA_HOME> is the location of 
BEA WebLogic and <OvInstallDir> is the location where RealTime Health View is 
installed.

2 Start a BEA WebLogic portal domain. See Create a Portal Domain on page 45 for 
information on creating a portal domain on BEA WebLogic. To start the portal domain, go 
to Start → Programs  → BEA WebLogic Platform 8.1 → User Projects →<Portal Domain> 
→Start WLS Server for Portal Domain. 

3 Launch WebLogic console by loading the url http://localhost:7001/console in the 
browser. 

4 Log in to the console by using the administrative user name and password for <Portal 
Domain>, which were created in step 5 on page 45.

5 On left pane, expand Security → Realms  → myrealms.

6 Click Users folder. Users page appears on the right pane.

7 Click Configure a New User link to create a user.

8 Enter user details, and then click Apply.

Map Users to Dashboards in OV Dashboard Configuration 
Manager

Perform the following steps to map dashboards against a particular user:

1 Launch OV Dashboard Configuration Manager.

2 Select the Dashboard tab.

3 To map the users created in WebLogic portal server, perform the following steps:
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a Select WebLogic from the Portal Server drop-down box. The Select your portal server 
setup dialog box appears.

b Enter the administrative User name and Password, which were created in step 5 on 
page 45 while creating the portal domain.

c Enter 7001 in the Port number text box.

d Click OK. OV Dashboard Configuration Manager displays the list of available 
dashboards and list of users created in WebLogic.

4 To map the users created in Jetspeed portal server, select Jetspeed from the Portal Server 
drop-down box. OV Dashboard Configuration Manager displays the list of available 
dashboards and list of users created in Jetspeed.

5 Select a user from the User List.

6 Select the dashboard you want to assign to the selected user from Available Dashboards 
pane.

7 Click << button to send the selected dashboard to Dashboard assigned to User pane. You 
can assign as many dashboards as you like against a user.

8 Click >> button to remove dashboards from a user.
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7 Using the Portal
RealTime Health View portal gives you a top-level view of your service health and status to 
simplify your monitoring and decision making process. The portal consists of several portlets, 
which provide a consolidated view of service health and helps you drill down to the 
elementary services managed by HP OpenView and third-party management systems. 

To be able to use the portal to view dashboards, you must have the following:

• A valid username and password to access the portal.

• Dashboards assigned to your user profile.

After you log in to the portal as a user, you can view the health and status of the services in 
multiple levels. You get a broad-level view first, and then you can drill down and see more 
details related to the service. You can drill down from the dashboard level to the elementary 
service level.

The organization of the view depends on the way the dashboard was designed and modeled by 
using the composer. Refer to Creating Dashboards on page 47 for information on creating and 
designing a dashboard.

Launching the Portal

You must launch the portal to view the dashboards. You can use either the default Jetspeed 
portal server, which is bundled with RealTime Health View, or you can use BEA WebLogic 
portal server.

Launch Jetspeed Portal

To launch the default Jetspeed portal, perform the following tasks:

1 Start the portal server from OV Dashboard Configuration Manager, if it is not already 
started.

2 From Start menu, click Programs → HP OpenView → Dashboard → RealTime Health View → 
Web Portal. Jetspeed portal appears in web browser.

Alternatively, you can launch Jetspeed by typing the URL http://localhost:18080/
jetspeed.

You can log in to the portal with your username and password.

By default, RealTime Health View creates a user test with password test in Jetspeed 
portal server, which can be used to test the dashboard portal.
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Launch BEA WebLogic Portal

To use BEA WebLogic as a portal server, you must create portal application, web application, 
and portal domain in BEA WebLogic. Refer to Add and Manage Users in BEA WebLogic on 
page 67 for information on configuring BEA WebLogic.

To start BEA WebLogic portal server, perform the following steps:

1 From Start menu, click Programs → BEA WebLogic Platform 8.1 → User Projects →  
<PortalDomain> →  Start WLS Server for Portal Domain where <PortalDomain> is the name 
of the domain created in BEA WebLogic. Refer to Create a Portal Domain on page 45 for 
information on creating portal domain in BEA WebLogic.

2 On a web browser, load the URL http://localhost:<port>/<PortalDomain>

BEA WebLogic portal appears.

You can log in to the portal with your username and password.

Viewing Dashboards

You can view the generated dashboards in the portal. The portal home page displays a list of 
all the dashboards assigned to you. You can drill down and view status at composite service 
and elementary service levels. The organization of view depends on the design of the 
dashboard. 

Portal Home Page

In the portal home page, you can see the list of all the dashboards assigned to you in a portlet. 
If you bring the mouse-arrow near each dashboard, a pop-up appears indicating the aggregate 
health of all the underlying services in the dashboard.

Figure 5 List of Dasboards in the Portal Home Page 

To drill down further, click on the dashboard name. The top-level view of the dashboard 
appears. 

Dashboard Level View

The top-level view of each dashboard gives an overall status of service health. This view 
consists of a set of portlets. For this page, organization of the view depends on the content 
defined in composer while designing the dashboard. Refer to step 4 on page 57 for information 
on selecting the content of start page.
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Each content type has a specific look and feel, and a specific arrangement of portlets. The 
top-level view of the dashboard on start page depends on the pre-selected contents.

Business-IT Centric View

This view consists of four portlets. The portlets and their contents are listed in Table 9.

Figure 6 Business-IT Centric View Page

Table 9 Portlets in Business-IT Centric View Page

Portlet Content

Business View Services • Health status
• Trend
• Potential Risks
• Alerts
• Links to associated composite service

Summary View • Status of all incidents and alerts

• Pie chart representation of alerts

• Percentage graph of service 
availability

All Alerts Description of all the alerts.

Service Tree View Complete hierarchical structure of the 
dashboard.
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Service Manager Centric View

This view comprises of three portlets — Service Summary portlet, Key Metrics portlet, and 
Alerts portlet. The portlets and their contents are listed in Table 10.

Figure 7 Service Manager Centric View Page

IT-Operation Centric View

This view consists of four portlets. The portlets and their contents are listed in Table 11.

Table 10 Portlets in Service Manager Centric View Page

Portlet Content

Service Summary • Health status
• Trend
• Potential Risks
• Alerts
• Links to associated composite service

Key Metrics • List of 

— Average critical alerts per hour
— Average number of incidents per 

hour
— Average number of service calls per 

hour

• Pie chart representation of alerts

• Percentage graph of service availability

Alerts Description of all the alerts.
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Figure 8 IT-Operation Centric View Page

IT-Help Desk Centric View

Help Desk view is designed to display the dashboard that has a service desk management 
product (such as BMC Remedy Help Desk, HP OpenView Service Desk, and so on) as 
underlying service.

The portlets and their contents are listed in Table 12.

Table 11 Portlets in IT-Operation Centric View Page

Portlet Content

Business View Services • Health status
• Trend
• Potential Risks
• Alerts
• Links to associated composite service

Alerts Description of all alerts.

Service Tree View Complete hierarchical structure of the 
dashboard.

Alert and Incident Graph 
View

• Pie chart representation of alerts and 
incidents.

• Percentage graph of service health.
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Table 12 IT-Help Desk Centric View Page

Portlet Content

Service Tree View Complete hierarchical structure of the 
dashboard.

Help Desk Incidents 
Information

Description of all incidents.

Executive Summary A summary of all the incidents, problems, 
changes, and service calls.

Executive Summary View Two different portlets called Executive 
Summary View appear 

• The bottom portlet displays bar graph 
representation of service calls, 
incidents, and problems.

• The extreme right portlet displays the 
following:

— Incident graph.
— Pie-chart representation of service 

calls.
— Measure of changes and problems.

Alerts Description of all the alerts.

PDF ReadUtility This portlet provides a utility to display 
PDF files stored in RealTime Health View 
server.
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Figure 9 IT-Help Desk Centric View Page

Composite Service Level View

On the dashboard page, all the associated composite services are listed and hyper-linked in a 
portlet. To drill down to the next level, click on the composite service link. The 
CompositeServiceBreakDown page appears. This page displays the list of associated 
elementary services and their health status. 

Elementary Service Level View

In the CompositeServiceBreakDown page, all the elementary services are hyper-linked in a 
portlet. To drill down to the elementary service level, click on the composite service link. The 
ElementaryServices page appears.

This page displays the health status of individual elementary service.

If Operations View is installed along with RealTime Health View, you can have one more level 
of drilldown.

Drill down to Operations View

If you have Operations View installed, you can enable RealTime Health View to Operations 
View drilldown from the ElementaryServices page. To enable the drilldown, you must 
configure both Operations View and RealTime Health View.
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Configure Operations View

You can drill down to Operations View for the services provided by HP OpenView Internet 
Services, HP OpenView Operations for Windows, HP OpenView Serivce Desk, and HP 
OpenView Service Navigator.

The service, for which you want to configure the drilldown, must be deployed in the 
Operations View application portal. To make the drilldown possible from the Realtime Health 
View dashboard view, you need to map the portlets to an anonymous user, anon. Perform the 
following steps to map a portlet to anon user in Operations View:

1 Type http://<servername>:<port>/jetspeed/portal in the address bar of the browser 
window to open the Operations View portal.

2 Login to the portal as administrator. The Admin Home page appears.

3 Click the Admin tab.

4 Click the PSML Browser option in the left pane. The PSML details page appears on the 
right pane.

5 Click the link default.psml under User → anon -→ html → en. The Customize Pane page 
appears.

6 Click the Add Pane button and specify the name of the pane.

7 Click Apply.

8 Click the newly added pane. You can select the layout of your portlet.

9 Click the Add Portlet button and a list of all available portlets appears.

10 Select JSR 168 from the Category dropdown list, and then click Filter. A list of Operations 
View portlets appears.

11 Select the portlets, such as OVIS_ops and OVSN_ops that you want to add, and then click 
Apply.

12 Click Save and Apply. You can see the name of the pane you have added in the portal home 
page.

Refer to the following set of documents for information about creating, configuring, and 
deploying portlet applications in Operations View:

• To create and configure portlet applications, refer to the following documents:

While creating a portlet for HP OpenView Internet Services services, you must select 
OVISDashboard option as Portlet Type. 

The default username and password for the administrator account are admin and 
jetspeed respectively.

For a successful drilldown from Realtime Health View dashboard view to the Operations 
View portlet, you must check whether the portlet application has been deployed or not. Type 
http://<servername>:<port>/<portlet application>/portletRegistration in the address 
bar of the browser. Make sure that the type attribute for each portlet you have added is 
displayed in the output XML file. The type attribute appears only if the portlet has been 
accessed at least once before.

In the Operations View Weblogic portal, you can drill down to a portlet, which is not assigned 
to any user.
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— HP OpenView Dashboard Operations View Integration Guide: HP OpenView Internet 
Services for a service under HP OpenView Internet Services. 

— HP OpenView Dashboard Operations View Integration Guide: HP OpenView 
Operations and HP OpenView Service Navigator for services under HP OpenView 
Operations and HP OpenView Service Navigator.

— HP OpenView Dashboard Operations View Integration Guide: HP OpenView 
Operations and HP OpenView Service Desk, HP OpenView Performance Insight, and 
HP OpenView Reporter for a service under HP OpenView Service Desk.

• To deploy a portlet application on an application server, refer to the HP OpenView 
Dashboard Operations View Administrator Guide.

Configure RealTime Health View

Perform the following steps to configure RealTime Health View:

1 Enter the Operations View URL in opsViewUrl.properties file, which is located in 
<OvDataDir>\conf\dashboard\rhview\common. Sample URL of Operations View is 
http://<servername>:<port>/<portlet application>
where <servername> is the hostname or IP address of machine hosting Operations View, 
<port> is the port number where Operations View is running, and <portlet application> is 
webapp context name that is configured in Operations View.

2 Restart the portal server from OV Dashboard Configuration Manager.

Portlets for Data Sources

User-defined data sources (HTTP and SQL data sources) are displayed inside portlets. As 
user-defined data sources can be added at any level of the dashboard, they can appear in the 
dashboard page, or in the CompositeServiceBreakdown page, depending on how the 
dashboard has been modeled in the composer at design time.

You can view two different types of user-defined data sources in the portal — HTTP and SQL 
data sources, which are listed below.

• HTTP data source — You can display an HTTP data source in three different ways 
depending on the requirement.

— Raw data — It displays contents of a web page in a portlet.

— Configured URL — It displays a hyper-link to a web page in a portlet.

— Status Calculation — It displays the web page as well as the status calculated by the 
transformation script.

• SQL data source — You can display SQL data sources in two different ways depending on 
the requirement:

—  Raw data — It displays a database table in a portlet.

If you are using BEA WebLogic as the portal server instead of the default Jetspeed 
server, you must copy the opsviewurl.properties file from the location: 
<OvDataDir>\conf\dashboard\rhview\common to 
<BEA-HOME>\user_projects\<Application Name>\<Project 
Name>\WEB-INF\classes where <Application Name> is the name of the 
application created in step 5 on page 45 and <Project Name> is the name of the 
project imported in step f on page 46.
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— Status Calculation — It displays the database table and the status calculated by the 
transformation script.

Refer to Create Data Sources on page 50 for more information.
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A Exporting and Importing Dashboard 
Definitions
After building a dashboard hierarchy by using the composer, you can save the dashboard 
definition by exporting it to a location on your system, and then reuse it if required. If you 
delete a dashboard from the composer accidentally, you can retrieve the dashboard by 
importing the definition that you have saved.

To export a dashboard definition, perform the following steps: 

1 In the Navigator pane of the composer, select the dashboard that you want to export.

2 Click File  → Export Definitions. The Export Definitions dialog box appears.

3 Select the location on your system where you want to export the definition, and then click 
Export. The dashboard definition is saved as a compressed file on your system.

To import the definition, perform the following steps:

1 Click File  → Import Definitions. The Import Definitions dialog box appears.

2 Click Browse, locate the compressed definition file on your system, and then click Next.

3 Click Import. The dashboard definition is imported to the composer and it appears on the 
Navigator pane.
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B Guidelines for Writing Data Source 
Transformation Script
User defined data sources like SQL and HTTP data sources with the Runtime Data Type set 
to Status Calculation can be used as elementary services while creating a dashboard.These 
data sources are also referred to as user-defined services. To calculate the status of these 
user-defined services, you must provide a Perl transformation script while creating the 
underlying SQL/HTTP data source. You must follow the guidelines listed below to generate 
the transformation script.

1 The Perl script must accept the raw data of the data source as a command line argument.

2 The Perl script must process this raw data to generate an event. The generated event is 
an XML string that indicates the status of the user-defined service. 

3 The Perl script must return zero (0).

The schema of the event XML is given below.

Figure 10 Event Schema for Status Calculation

The elements of the schema are described below.

• Name — Enter a name of the event. It can be any string.

• Type — Set the type of the event to ALARM.

• Alert — Set this element to false.

• Value — Enter an integer value between one and five. One indicates the status of 
user-defined service is NORMAL and five indicates the status is CRITICAL.

This event XML script must be printed to stdout of the script.
 83



• Service ID — Leave this element blank. This value is populated by RealTime Health 
View server.

• Source — Leave this element blank. This value is populated by RealTime Health View 
server.

• Timestamp — Leave this element blank. This value is populated by RealTime Health 
View server.

• Attributes — It is an optional element.

— Attribute — This is a sub-element of the optional Attributes element. This 
element holds Name and Value elements.

      Name— Set this element to ALARMMESSAGE.

      Value — Set this with the alarm message.

A sample event XML string is given below:

<Events>
  <Event>
     <Name>ElementStatus</Name>
     <Type>ALARM</Type>
     <Value>4</Value>
     <ServiceID></ServiceID>
     <Source></Source>
     <Alert>false</Alert>
     <Timestamp></Timestamp>
     <Attributes>
       <Attribute>
         <Name>ALARMMESSAGE</Name>
         <Value>FTP Service RESPONSE_TIME is slow
         </Value>
     </Attribute>
   </Attributes>
  </Event>
</Events>

In the above example an event called ElementStatus is generated for a user-defined service 
with a status value of 4 (Major). It also generates an alarm message (FTP Service 
RESPONSE_TIME is slow). 
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C Using MSI Packages to Install RealTime Health 
View
If you want to install RealTime Health View manually by using the MSI packages, perform 
the following steps:

1 Install the following packages in the given sequence:

a HPOvJre-01.04.211-WinNT4.0-release.msi

b HPOvJdkA-01.04.210-WinNT4.0-release.msi

c HPOvXpl-02.61.050-WinNT4.0-release.msi

d HPOvJxpl-02.61.050-WinNT4.0-release.msi

e HPOvDshRhvCo-02.00.001-WinNT4.0-release.msi

f HPOvDshRhvServ-02.00.001-WinNT4.0-release.msi

g HPOvDshRhvComp-02.00.001-WinNT4.0-release.msi

h HPOvDshRhvPrtl-02.00.001-WinNT4.0-release.msi

2 After installing packages, you must install Autopass from the command prompt to enable 
licensing. You cannot start RealTime Health View services without enabling the license. 
Perform the following steps to install Autopass:

a From the command prompt, change the directory to the folder containing 
HPOvLic-05.40.060-WinNT4.0-release.msi package, and then run the 
commands given below.

msiexec.exe /i HPOvLic-05.40.060-WinNT4.0-release.msi /qn 
INSTALLSTANDALONE=1

"%CommonProgramFiles%\Hewlett-Packard\HPOvLIC\demo"\hpovliccli -io 
"%OvDataDir%\conf\dashboard\rhview\server\ovdshrhvserv.txt"

3 To install MSDE 2000, go to the folder containing the MSDE 2000 package from the 
command prompt, and then run the following command:

Setup.exe DISABLENETWORKPROTOCOLS=0 SAPWD="ovd" 
INSTANCENAME="OVDASHBOARD" SECURITYMODE=SQL
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After installing MSDE 2000, you must start MSSQL$OVDASHBOARD service from Control 
Panel → Administrative Tools → Services.

4 To create a database from the command prompt, change directory to 
%OvInstallDir%\misc\dashboard\rhview\server, and then run the following 
command:

osql -E -S .\OVDASHBOARD -i eddb_script.sql
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To uninstall RealTime Health View by using the MSI packages, perform the following steps.

1 Click Start → Settings → Control Panel.

2 Click Add/Remove Programs. 

3 Uninstall the MSI packages in the given sequence.

a HPOvDshRhvPrtl-02.00.001-WinNT4.0-release.msi

b HPOvDshRhvComp-02.00.001-WinNT4.0-release.msi

c HPOvDshRhvServ-02.00.001-WinNT4.0-release.msi

d HPOvDshRhvCo-02.00.001-WinNT4.0-release.msi

e HPOvJxpl-02.61.050-WinNT4.0-release.msi

f HPOvXpl-02.61.050-WinNT4.0-release.msi

g HPOvJdkA-01.04.210-WinNT4.0-release.msi

h HPOvJre-01.04.211-WinNT4.0-release.msi
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