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About this guide

This guide discusses the following:

• HP Storage Essentials
• Installing the product
• Uninstalling the product
• Troubleshooting

Intended audience
This guide is intended for:

• Network Engineers
• Administrators
• Any one who wants to monitor or manage Storage Essentials installation using OpenView

Operations for Windows

Related documentation
In addition to this guide, the following documents are available for this product:

• HP Storage Essentials 5.0 installation guide
• HP Storage Essentials 5.0 user guide
• HP Storage Essentials 5.0 application guide
• HP Storage Essentials 5.0 CLI guide
• HP Storage Essentials 5.0 for file servers guide
• HP Systems Insight Manager installation guide
• HP OpenView SMART Plug-In for HP Storage Essentials release notes

These and other HP documents are available at the HP web site: http://welcome.hp.com/country/us/
en/support.html
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Typographical conventions and symbols
Table 1 lists the conventions used in this document

Table 1 Document conventions

Convention Element

Medium blue text: Related
documentation

Cross-reference links and e-mail addresses

Medium blue, underlined text
(http://www.hp.com)

Web site addresses

Bold font • Key names
• Text typed into a GUI element, such as into a box
• GUI elements that are clicked or selected, such as menu and list

items, buttons, and check boxes

Italic font Text emphasis

Monospace font • File and directory names
• System output
• Code
• Text typed at the command line

Monospace, italic font • Code variables
• Command-line variables

Monospace, bold font Emphasis of file and directory names, system output, code, and text
typed at the command line

CAUTION:
Indicates that failure to follow directions can result in damage to equipment or data.

IMPORTANT:
Provides clarifying information or specific instructions.

NOTE:
Provides additional information.

8 About this guide
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HP technical support
Telephone numbers for worldwide technical support are listed on the HP support web site:
http://www.hp.com/support/

Collect the following information before calling:

• Technical support registration number (if applicable)
• Product serial numbers
• Product model names and numbers
• Applicable error messages
• Operating system type and revision level
• Detailed, specific questions

For continuous quality improvement, calls may be recorded or monitored.

HP recommends that customers sign up online using Subscriber’s choice web site:
http://www.hp.com/go/e-updates

• Subscribing to this service provides you with e-mail updates on the latest product enhancements,
newer versions of drivers, and firmware documentation updates, as well as instant access to
numerous other product resources.

• After signing up, you can quickly locate your products by selecting Business support and then
Storage under Product Category.

HP-authorized reseller
For the name of your nearest HP-authorized reseller:

• In the United States, call 1-800-345-1518.
• In Canada, call 1-800-263-5868.
• Elsewhere, visit the HP web site: http://www.hp.com and click Contact HP to find locations and

telephone numbers.
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1 HP Storage Essentials

This chapter discusses the following:

• Overview
• Key features and benefits of HP Storage Essentials
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Overview
HP Storage Essentials (HP SE) is a family of standards-built Storage Area Network (SAN) management
and Storage Resource Management (SRM) solutions. It enables you to visualize, monitor, report on,
provision, and manage your heterogeneous storage environment.

The HP Storage Essentials suite delivers integrated heterogeneous functionality for network (DAS, SAN,
NAS) management, storage resource management, provisioning, backup reporting, and application
infrastructure monitoring. The suite consists of HP Storage Essentials Enterprise Edition and features
a portfolio of value added plug-ins. The architecture and interfaces are built on industry standards,
allowing for quick deployment and investment protection.

Storage Essentials runs on a central server as Storage Essentials central management application
(AppStorManager service). It relies on CIM Extensions, which acts as an agent to provide information
about hosts and applications. A CIM Extension is an agent program that gathers information about a
host and its applications, and forwards this information to the Storage Essentials central management
application.

Key features and benefits of HP Storage Essentials
Following are the features and benefits of HP Storage Essentials:

• End-to-end visibility of business applications
Provides an interface to monitor business applications, including their associated infrastructure
and interdependencies.

• Web-based global management console
Manages heterogeneous storage environments through a web-based user interface.

• Reporting
Offers flexible, in-depth report generation in both predefined and user defined formats.
It can also export data to other management applications.

• Standards-based architecture
Protects user flexibility and investments with a standards-based interface for managing
heterogeneous storage environments.

• Storage server, network and subsystem provisioning
Reduces manual processes and risk of downtime because of free-space outages with multi-level
storage provisioning.

• Integrated asset management and carriageable
Centralizes all aspects of storage inventory for maximum asset utilization. Improves accountability
and budgeting with cost accounting-based carriageable on user defined utilization characteristics.

• Integrated storage management
Lowers cost of acquiring and managing a heterogeneous storage environment using multiple
disparate point solutions.

For more information on features of HP Storage Essentials, see the website at: http://
www.managementsoftware.hp.com/
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2 HP OpenView SMART Plug-In
for HP Storage Essentials (Storage
Essentials SPI)

This chapter discusses the following:

• Overview
• Features and functionality
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Overview
HP OpenView Operations SMART Plug-In for HP Storage Essentials (Storage Essentials SPI) integrates HP
Storage Essentials (HP SE) with HP OpenView Operations for Windows (OVOW). The Storage Essentials
SPI extends OVO’s management scope to include systems managed by HP Storage Essentials installed in
an environment consisting of one or more OVO servers and one or more OVO managed nodes. The
Storage Essentials SPI can be used to monitor HP SE services.

The Storage Essentials SPI along with the HP OpenView Operations – Integration for HP Systems Insight
Manager (HP SIM Integration) integrates HP Storage Essentials with HP OpenView Operations by:

• Discovering Storage Essentials Services.
• Forwarding storage events from HP SIM Integration to OVO.

NOTE:
HP SIM Integration must be installed before installing the Storage Essentials SPI. For more information
on installation prerequisites, see Installation prerequisites.

• Monitoring and controlling the services and daemons of HP Storage Essentials.

The HP SIM Integration, together with the Storage Essentials SPI, allows the storage network to be
monitored and managed from the OpenView Operations management server console. The Storage
Essentials SPI allows OVO administrators to troubleshoot problems in the storage network before they
become serious enough to affect applications, and ultimately the end-users. Storage events are stored in
the HP Systems Insight Manager’s database. OVO intelligent agents are configured on the HP Systems
Insight Manager, HP Storage Essentials CMS, and managed servers, which are managed nodes in the
OVO management domain.

The OVO agent monitors the availability of the Storage Essentials processes at periodic intervals and
forwards appropriate events to the administrator if the processes are not running. Storage Essentials SPI
also has the ability to discover the Storage Essentials related services. This enables administrators to
perform root-cause analysis of the inherent Storage Essentials services.

Features and functionality
Following are the key features of Storage Essentials SPI:

• Monitors the Storage Essentials central management application, the AppStorManager process
on Windows node.

• Monitors the Storage Essentials CIM Extension process, on UNIX managed nodes.
• Offers tools to start, stop, and view status of Storage Essentials AppStorManager service.
• Offers tools to start, stop, and view status of Storage Essentials CIM Extension process on UNIX

managed nodes.
• Offers tools to view status of Storage Essentials CIM Extension process on Windows managed

nodes.
• Discovers HP Storage Essentials services.
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3 Installing Storage Essentials SPI

This chapter discusses the following:

• Installation prerequisites
• Installing Storage Essentials SPI
• Verifying installation
• File locations
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Installation prerequisites
This section lists the prerequisites for the installation of the Storage Essentials SPI. To avoid problems
during the installation of the Storage Essentials SPI software, it is mandatory that you read this section,
and other documents recommended in this section before you start the installation process.

Hardware requirements
For a detailed list of hardware requirements, see the following documents:

• For OVO management server, see HP OpenView Operations for Windows installation guide.
• For OVO managed node, see HP OpenView Operations for Windows installation guide.

Table 2 lists the disk space requirements for each operating system.

Table 2 Disk space requirements

Machine Operating System Installation Runtime
Files

Total

OVO management
server (includes
documentation)

Microsoft Windows 2000
Microsoft Windows 2003 (32-bit)

3 MB 1 MB 4 MB

Microsoft Windows 2000
Microsoft Windows 2003 (32-bit)

HP-UX 11.00, 11.11, 11.23 IA and PA

Solaris 8, 9,10

RedHat Linux Advanced Server 3.0 (32–bit)
SuSE Linux Enterprise Server 9 (32–bit)

AIX 5.1, 5.2 and 5.3

OVO managed
node

Tru64 5.1B

1 MB 1 MB 2 MB

NOTE:
No additional memory (RAM) is required either on the OVO management server or on the managed nodes.

Software requirements
This section lists the software requirements for the installation of Storage Essentials SPI.

Prerequisites
Following are the software requirements for installing the Storage Essentials SPI:

• HP OpenView Operations for Windows 7.5
• HP Systems Insight Manager SIM 5.0 SP3 or later
• HP Storage Essentials 5.0 or later
• HP SIM Integration 01.10

For more information on installing HP SIM Integration, see HP OpenView Operations - Integration
for HP Systems Insight Manager installation and reference guide.
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Other Software requirements
Table 3 lists the versions of Storage Essentials Central Management Server (CMS) that Storage Essentials
SPI supports.

Table 3 Storage Essentials Central Management Server (CMS) supported versions

Operating System Storage Essentials CMS Version

Microsoft Windows 2000 5.0 and 5.00.01

Microsoft Windows 2003 (32-bit) 5.00.01

Following are the operating systems supported by Storage Essentials SPI for Storage Essentials CIM
Extension:

• Microsoft Windows 2000
• Microsoft Windows 2003 (32-bit)
• HP-UX 11.00
• HP-UX 11.11
• HP-UX 11.23 IA
• HP-UX 11.23 PA
• Tru64 5.1B
• Solaris 8
• Solaris 9
• Solaris 10
• AIX 5L 5.1
• AIX 5L 5.2
• AIX 5L 5.3
• RedHat Linux Advanced Server 3.0 (32–bit)
• SuSE Linux Enterprise Server 9 (32–bit)

Table 4 lists the versions of OVO Management Server that Storage Essentials SPI supports.

Table 4 OVO management server supported versions

Operating System OVO Version

Microsoft Windows 2000

Microsoft Windows 2003 (32-bit)

A.07.50

HP OpenView SMART Plug-In for HP Storage Essentials Administrator’s Reference for HP OpenView
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Following are the operating systems supported by Storage Essentials SPI for the OVO agent:

• Microsoft Windows 2000
• Microsoft Windows 2003 (32-bit)
• HP-UX 11.00
• HP-UX 11.11
• HP-UX 11.23 IA
• HP-UX 11.23 PA
• Tru64 5.1B
• Solaris 8
• Solaris 9
• Solaris 10
• AIX 5L 5.1
• AIX 5L 5.2
• AIX 5L 5.3
• RedHat Linux Advanced Server 3.0 (32–bit)
• SuSE Linux Enterprise Server 9 (32–bit)
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Installing Storage Essentials SPI
You can install Storage Essentials SPI from the HP OpenView New and Upgraded Smart Plug-ins installer
CD Volume 1. The Installer executable verifies whether OVO is installed. It also installs the package,
and uploads the configuration on OVO.

To install the Storage Essentials SPI software bundle on the OVO management server, complete the
following steps:

1. Ensure that the OVO management server system where you want to install the HP Storage
Essentials SPI meets installation prerequisites. For more information, see Installation prerequisites.

2. Login to the OVO management server as a user with Administrator privileges.
3. Insert the HP OpenView New and Upgraded Smart Plug-ins installer CD Volume 1 into the

CD drive. The installation wizard appears.
4. Select SPI for HP Storage Essentials in the Product Selection window, and click Next.

NOTE:
Selecting SPI for HP Storage Essentials in the Product Selection window also installs HP SIM
Integration.

Figure 1 displays the SPI Installation window.
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Figure 1 SPI Installation window

5. Follow the instructions as they appear in the installation wizard. The wizard displays the status of
the installation.

6. Click Finish to exit from the installation wizard.
For more information on installing HP OpenView New and Upgraded Smart Plug-ins, see
theNew and Upgraded Smart Plug-ins CD for OpenView Operations installation/upgrade guide.
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Verifying installation
To verify whether the installation of the Storage Essentials SPI on the OVO management server is
successful, open the OVO console and check whether the elements listed in Table 5 are present.

Table 5 OVO elements

OVO Console Element

Nodes SE AppStorMgr-Win
SE CIM Extension-Win
SE CIM Extension-Unix

Tools HP Storage Essentials

Policy Management HP Storage Essentials

User Roles HP Storage Essentials SPI Admin

If the elements listed in Table 5 are not present in the OVO console, it indicates that the Storage Essentials
SPI is not installed properly. You must uninstall and re-install the Storage Essentials SPI to resolve this issue.

For information on uninstalling Storage Essentials SPI, see Uninstalling Storage Essentials SPI.

For information on re-installing Storage Essentials SPI, see Installing Storage Essentials SPI.
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File locations
The installation process copies the necessary files to the OVO management server.

Table 6 lists the directories that are created during the installation process of the Storage Essentials
SPI on the OVO management server.

Table 6 File locations on the OVO management server

File Type Description

OVO integration %OvInstallDir%install\HPSESPI
%OvInstallDir%Data\shared\SPI-Share\HPSESPI
%OvInstallDir%Data\shared\Instrumentaion\Supported Operating
Systems\HP Storage Essentials

Documentation %OvInstallDir%install\HPSESPI\doc

MofFiles %OvInstallDir%NLS\1033\MofFiles

Table 7 lists the directories for Storage Essentials SPI components that are used on deployment of the
policies to the OVOW managed node(s).

Table 7 File locations for the OVO managed node

Operating System Installed Location

HP-UX, Solaris, Redhat Linux, SuSE Linux and Tru64 /var/opt/OV/bin/instrumentation

Microsoft Windows %OvAgentDir%\bin\instrumentation

AIX /var/lpp/OV/OpC/instrumentation

The Storage Essentials SPI commands and instrumentation scripts are copied into these paths when the
HP Storage Essentials instrumentation is deployed to the managed nodes.
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4 Configuring Storage Essentials
SPI

This chapter discusses the following:

• Installing OVO agent
• Obtaining HP Systems Insight Manager CMS Credentials
• Assigning nodes to node group
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Installing OVO agent
Before installing the OVO agent, ensure that the system on which you want to install the OVO agent
meets the installation prerequisites. For more information, see Installation prerequisites.

You can install the OVO agent by various methods on a managed node. For more information about the
various installation methods, see HP OpenView Operations for Windows installation guide.

Obtaining HP Systems Insight Manager CMS credentials
In order to activate the service discovery functionality provided with Storage Essentials SPI, you must
obtain the HP SIM credentials with administrative privileges before adding nodes to the Storage
Essentials node groups.

NOTE:
Enter the same credentials that is used to login to HP Systems Insight Manager. The HP SIM credentials used
must have the role Domain_Admin in Storage Essentials CMS in order for the Storage Essentials SPI to
function correctly. HP SIM credentials are stored in an encrypted format on the OVO nodes.

To obtain the HP SIM credentials, complete the following steps:

1. Login to the OVO management server and start the OVO Console GUI.
2. Select Tools > HP Storage Essentials > AppStorManager-Win and right-click Get HP SIM

Credentials.
3. Select All Tasks > Launch Tool. The command prompt window displays the following message:

Enter the HP Systems Insight Manager DOMAIN\username:
Enter the Domain\username and press Enter.

4. The following message appears:
Enter the HP Systems Insight Manager password:
At this prompt, enter the corresponding HP Systems Insight Manager password and press Enter.

CAUTION:
Service Discovery does not function correctly if the values for the user name and password are
incorrect. If you do not know the user name and password, contact your system administrator.

5. Confirm the password by re-entering the password at the prompt:
Re-enter password:
After re-entering the correct password, the following message is displayed:
Done creating hpsimcms.conf file.
Press any key to continue . . .

6. Press Enter, the command prompt window closes.
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Assigning nodes to node group
You must add the HP Storage Essentials management server and the nodes running the CIM Extensions to
the nodes group folder.

NOTE:
The Storage Essentials SPI node groups are associated with respective policy groups. When the nodes are
added to the node groups, policies relevant to that particular node and instrumentation are automatically
deployed.

CAUTION:
The automatic policy deployment requires that the OVO agent be present on the managed nodes. If the OVO
agent is not present on the Windows nodes, the management server deploys the agent automatically. For
UNIX nodes, the agent must be installed manually. You can install the OVO agent by various methods on
a managed node. For more information, see Installing OVO agent.

Assigning the nodes to the node group involves the following:

• Assigning AppStorManager node to the node group
• Assigning CIM Extension Unix node to the node group
• Assigning CIM Extension Windows node to the node group

Assigning AppStorManager node to the node group
To assign the Windows node on which the Storage Essentials AppStorManager service is running to
the node group, complete the following steps:

1. Login to the OVO management server, and start the OVO Console GUI.
2. Select Tools > HP Storage Essentials > AppStorManager-Win, and right-click Assign

AppStorManager node to node group.
3. Select All Tasks > Launch Tool. The Edit Parameters window opens.

Figure 2 shows the Edit Parameters window.
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Figure 2 Edit Parameters window

4. Select the Windows node on which the Storage Essentials AppStorManager service is running in
the nodes tree in Select the nodes/services to replace $OPC window pane.

5. Click Launch… . The Tool status window opens.
Figure 3 shows the Tool Status window.
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Figure 3 Tool Status window

You have now successfully assigned the Windows node on which the Storage Essentials AppStorManager
service is running, to the SE AppStorMgr-Win node group.

Assigning CIM Extension Unix node to the node group
To assign the Unix node on which the Storage Essentials CIM Extension process is running to the node
group, complete the following steps:

1. Login to the OVO management server, and start the OVO Console GUI.
2. Select Tools > HP Storage Essentials > CIM Extension-Unix, and right-click Assign CIM Extension

Unix node to node group.
3. Select All Tasks > Launch Tool. The Edit Parameters window opens.

Figure 4 shows the Edit Parameters window.
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Figure 4 Edit Parameters window

4. Select the Unix node on which the Storage Essentials CIM Extension process is running in the
nodes tree in Select the nodes/services to replace $OPC window pane.

5. Click Launch… . The Tool Status window opens.
Figure 5 shows the Tool Status window.
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Figure 5 Tool Status window

You have now successfully assigned the Unix node on which the Storage Essentials CIM Extension
process is running, to the SE CIM Extension-Unix node group.

Assigning CIM Extension Windows node to the node group
To assign the Windows node on which the Storage Essentials CIM Extension service is running to the
node group, complete the following steps:

1. Login to the OVO management server, and start the OVO Console GUI.
2. Select Tools > HP Storage Essentials > CIM Extension-Win, and right-click Assign CIM Extension

Windows node to node group.
3. Select All Tasks > Launch Tool. The Edit Parameters window opens.

Figure 6 shows the Edit Parameters window.
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Figure 6 Edit Parameters window

4. Select the Windows node on which the Storage Essentials CIM Extension process is running in
the nodes tree in Select the nodes/services to replace $OPC window pane.

5. Click Launch…. The Tools Status window opens.
Figure 7 shows the Tool Status window.
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Figure 7 Tool Status window

You have now successfully assigned the Windows node on which the Storage Essentials CIM Extension
service is running, to the SE CIM Extension-Win node group.

Deploying Instrumentation to CIM Extension Windows nodes
After you have successfully assigned the Windows node on which the Storage Essentials CIM Extension
service is running to the SE CIM Extension-Win node group, Storage Essentials SPI Instrumentation
have to be deployed to the node.

To deploy instrumentation on the Windows node on which the Storage Essentials CIM Extension service is
running, complete the following steps:

1. Login to the OVO management server, and start the OVO Console GUI.

NOTE:
Ensure that the nodes are added to the node folders before deploying instrumentation to the nodes.
To add nodes to the node folders, see Assigning CIM Extension Windows node to the node group.

2. Right-click SE CIM Extension-Win node folder in the nodes tree.
3. Select All Tasks > Deploy instrumentation. The Deploy Instrumentation window opens.

Figure 8 shows the Deploy Instrumentation window.
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Figure 8 Deploy Instrumentation Window

4. Select HP Storage Essentials.
5. Click OK.
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5 Using Storage Essentials SPI

This chapter discusses the following:

• Using Storage Essentials SPI node folders
• Using Storage Essentials SPI tools
• Using Storage Essentials SPI policies
• Using Storage Essentials SPI messages
• Using Storage Essentials SPI service map
• Re-configuring HP SIM CMS credentials for Storage Essentials SPI
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Using Storage Essentials SPI node folders
Installing Storage Essentials SPI creates the following nodes folders:

• SE AppStorMgr-Win
• SE CIM Extension-Win
• SE CIM Extension-Unix

Figure 9 shows the Storage Essentials SPI node folders

Figure 9 Storage Essentials SPI node folders

For more information on adding nodes to node groups, see Assigning nodes to node group.

Table 8 lists the association between the nodes folder and the relevant tools folders.

Table 8 Association of tools folder to nodes folder

Nodes folder Tools folder

SE AppStorMgr-Win AppStorManager-Win

SE CIM Extension-Win CIM Extension-Win

SE CIM Extension-Unix CIM Extension-Unix
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Using Storage Essentials SPI tools
Installing Storage Essentials SPI creates the following tools folders:

• AppStorManager-Win
• CIM Extension-Win
• CIM Extension-Unix

These tool folders contain a number of tools that help the OVO administrator to manage Storage
Essentials. These tools are grouped under HP Storage Essentials folder.

Figure 10 shows the Storage Essentials SPI tools folder.

Figure 10 Storage Essentials SPI tools folder
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Table 9 describes the function of the applications created by the Storage Essentials SPI in the tools folder.

Table 9 Storage Essentials SPI applications and their descriptions

HP Storage Essentials
Tools Group

Tools Name Description

AppStorManager Start Starts the Storage Essentials
AppStorManager Service on Windows
node.

AppStorManager Stop Stops the Storage Essentials
AppStorManager Service on Windows
node.

AppStorManager Status
Reports the Storage Essentials

Reports the AppStorManager Service
status on Windows node.

Get HP SIM Credentials Gets username and password of HP
Systems Insight Manager for Storage
Essentials SPI.

Assign AppStorManager node
to node group

Assigns Storage Essentials
AppStorManager Windows node
to SE AppStorMgr-Win node group.

AppStorManager-Win

De-assign AppStorManager
node from node group

De-assigns Storage Essentials
AppStorManager Windows node
from SE AppStorMgr-Win node
group.

CIM Extension Start Starts the Storage Essentials CIM
Extension process on Unix node.

CIM Extension Stop Stops the Storage Essentials CIM
Extension process on Unix node.

CIM Extension Status Reports the Storage Essentials
AppStorManager Service status on
Unix node.

Assign CIM Extension
Windows node to node
group

Assigns Storage Essentials CIM
Extension Windows node to SE CIM
Extension-Unix node group.

CIM Extension-Unix

De-assign CIM Extension
Windows node from node
group

De-assigns Storage Essentials CIM
Extension Unix node from SE CIM
Extension-Unix node group.

CIM Extension Status Reports the Storage Essentials
AppStorManager Service status on
Windows node.

Assign CIM Extension
Windows node to node
group

Assigns Storage Essentials CIM
Extension Windows node to SE CIM
Extension-Win node group.

CIM Extension-Win

De-assign CIM Extension
Windows node from node
group

De-assigns Storage Essentials CIM
Extension Windows node from SE CIM
Extension-Win node group.
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Using Storage Essentials SPI policies
The policies provided with the Storage Essentials SPI are grouped under the Storage Essentials policy
group.

Figure 11 shows the Storage Essentials policy group.

Figure 11 Storage Essentials policy group

Storage Essentials SPI deals with the messages of Storage Essentials CMS and Storage Essentials
managed hosts. Messages generated by the Storage Essentials SPI policies pass through a filtration
process, and are prioritized and assigned an OVO severity level as defined in the policies. All messages
generated by the Storage Essentials SPI policies by default belong to the Storage Essentials SPI’s
HPSESPI-Storage_Essentials message group. Additional monitor policies verify the status of the
Storage Essentials software through the AppStorManager service running on the Storage Essentials
management server. In addition, it verifies the Storage Essentials CIM Extension software service run on
the Storage Essentials hosts, and generates messages to indicate any change in status.

Storage Essentials SPI supplies a policy Service Discovery, that is used for Service Discovery.
Deployment of this policy on the Storage Essentials management server enables the Storage Essentials SPI
to discover the Storage Essentials Service views supported by the Storage Essentials.
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Table 10 lists the default policies provided with the Storage Essentials SPI.

Table 10 Default Storage Essentials SPI policies

Policy Group Policy Type Policy Name Description

AppStorManager-Win

Measurement Threshold AppStorManager Monitors the
AppStorManager
service and sends a
message to the event
browser, if the service is
not running.

CIM Extension-Unix Measurement Threshold CIM_Extension-Unix Monitors the process CIM
Extension on UNIX
Storage Essentials hosts
and sends a message to
the event browser, if not
running.

Service Discovery Service Auto-Discovery Storage_Essen-
tials_Hosts_Discovery

Discovers the Storage
Essentials central
management server
(CMS) services and the
hosts managed by the
management server.

Using Storage Essentials SPI messages
Events generated by the Storage Essentials SPI are grouped under the Storage Essentials SPI’s
HPSESPI-Storage_Essentials message group. The messages generated by the Storage
Essentials SPI templates appear in the Message Browser window and contain information that is vital
for understanding the problems being reported.

Figure 12 shows the Message Browser window with a selection of messages generated by the Storage
Essentials SPI.

NOTE:
In Figure 12, there are messages for other applications apart from the messages for Storage Essentials SPI.
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Figure 12 Storage Essentials SPI messages in the message browser

The message headline describes the scope of the problem. In the Storage Essentials SPI context, this
information can be categorized into the following:
• Node - Name of the Storage Essentials management server or CIM Extension.
• Application - Category of the message is Storage Essentials.
• Text - A single line description of the event.
• Object - Source of the event is AppStorManager or CIM Extension.

Using Storage Essentials SPI service map
Storage Essentials SPI provides the administrator with the additional perspective of Service Views.

For more information about Service Views, see Viewing services.

Storage Essentials SPI provides the following service view:

• Storage Essentials services

The Storage Essentials SPI discovers the services automatically and uses the discovered data to generate
service maps that can be viewed by the administrator from the OVO console.

As shown in Figure 13, the third node represents the Storage Essentials CMS node - the node running the
AppStorManager service. The Storage Essentials managed hosts are discovered by querying the Storage
Essentials CMS for it’s managed hosts. Hence, some of the nodes represented in this tree may not be
OVO managed nodes. The user can decide whether these nodes must be configured as OVO managed
nodes or not. The user can also decide whether the Storage Essentials policies must be installed or not. If
the nodes in this tree are also OVO managed nodes with the Storage Essentials policies deployed, the
service map node status changes based on the status of the CIM Extension on the node.

Figure 13 shows the services discovered by the Storage Essentials SPI where AppStorMgr has a status of
not running.
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Figure 13 Storage Essentials service when AppStorMgr has a status of not running

Table 11 lists the Storage Essentials SPI service description.

Table 11 Storage Essentials SPI service description

Item Description

1 Storage Essentials CMS node

2 Nodes that have the CIM Extensions installed/running

Figure 14 shows the services discovered by the Storage Essentials SPI where CIM Extension is not running.
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Figure 14 Storage Essentials service when CIM Extension has a status of not running

The service discovered by the Storage Essentials SPI allows root-cause analysis of problems in the most
crucial elements of the Storage Essentials node in the storage network being managed by Storage
Essentials. Propagation rules for the objects in the Storage Essentials service trees are defined as
Unchanged by default. This means that a parent service does not change the status of a child object. For
example, attaching a priority to it. Such a scenario is feasible only if a parent service considered the
status of one child service to be more important than the status of another child service. Calculation rules
for the Storage Essentials service trees are set to Most Critical by default. Hence, if a parent service has
more than one child service, it assumes the status equal to the highest severity of its child services.

Viewing services
The service maps are created a few minutes after Storage Essentials CMS is added to AppStorMgr-Win
node group. For information on adding Storage Essentials CMS to the AppStorMgr-Win node group, see
Obtaining HP Systems Insight Manager CMS Credentials and Assigning nodes to node group.

To view the discovered services, click Services on the OVO Management console and select the
appropriate service.

NOTE:
By default, the services are discovered by OVO once every day at 2:30 am. The administrator can change
the service discovery period by modifying the service discovery policy. The changed discovery period comes
into effect only after the policies are redeployed on the Storage Essentials CMS.

Using Storage Essentials SPI user roles
The installation of the Storage Essentials SPI software adds a new user role called HP Storage Essentials
SPI Admin to OVO.
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Figure 15 shows the User Roles window.

Figure 15 User Roles window

The OVO administrator utilizes user roles to simplify the process of assigning responsibilities to OVO
users. The users associated with the role HP Storage Essentials SPI would have all the Storage Essentials
SPI tools, policies and HPSESPI-Storage_Essentials message groups assigned to them and would
be able to manage and control the Storage Essential CMS and CIM Extension nodes.

Re-configuring HP SIM CMS credentials for Storage Essentials
SPI

To re-configure HP SIM CMS credentials for Storage Essentials SPI, complete the following steps:

1. Enter the new HP Systems Insight Manager CMS Credentials.
For more information, See Obtaining HP Systems Insight Manager CMS Credentials.

2. Deploy instrumentation to the Storage Essentials CMS node.
• To deploy the instrumentation on the Storage Essentials node, right-click on the Storage

Essentials CMS node, select All Tasks and select Deploy Instrumentation. The Deploy
Instrumentation window opens.
Figure 16 shows the Deploy Instrumentation window.
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Figure 16 Deploy Instrumentation window

3. Select HP Storage Essentials.
4. Click OK.

The credentials are used for Storage Essentials service discovery.
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6 Uninstalling Storage Essentials
SPI

This chapter discusses the following:

• Uninstalling Storage Essentials SPI Policies from the OVO managed nodes
• De-assigning nodes from the node group
• Uninstalling Storage Essentials SPI from the OVO management server
• Uninstalling Storage Essentials SPI components from the OVO GUI
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Uninstalling Storage Essentials SPI Policies from the OVO
managed nodes

To uninstall the Storage Essentials SPI Policies from the OVO managed nodes, complete the following
steps:

1. Start the OVO console GUI.
2. Select Policy Groups > HP Storage Essentials in the Policy Management folder.
3. Right click on the policy group AppStorManager-Win, and select All tasks > Uninstall from...
4. In the Uninstall policies on... window, select the node group SE AppStorMgr-Win from which the

policy has to be removed.
Figure 17 shows Uninstall policies on... window.

Figure 17 Uninstall policies on... window

5. Select the remove all versions in the Deployment Options at the bottom of the Uninstall policies
on... window.

6. Click OK.
7. Right click on the policy group Service Discovery, and select All tasks > Uninstall from...
8. In the Uninstall policies on... window, select the node group SE AppStorMgr-Win from which the

policy has to be removed.
Figure 17 shows Uninstall policies on... window.
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Figure 18 Uninstall policies on... window

9. Click OK.
10. Right click on the policy group CIM Extension-Unix, and select All tasks > Uninstall from...
11. In the Uninstall policies on... window, select the node group SE CIM Extension-Unix from which

the policy has to be removed.
12. Select the remove all versions in the Deployment Options at the bottom of the Uninstall policies

on... window.
Figure 19 shows the Uninstall policies on... window.

Figure 19 Uninstall policies on... window

13. Click OK.

HP OpenView SMART Plug-In for HP Storage Essentials Administrator’s Reference for HP OpenView
Operations on Windows

47



NOTE:
To verify whether the Storage Essentials SPI policies are removed, on the OVO console expand the nodes
group folder, right-click a node (HP SE CMS), and select View > Policy Inventory.

The Storage Essentials SPI nodes folders are removed automatically while uninstalling the product from
the OVO management server. For more details, see Uninstalling Storage Essentials SPI from the OVO
management server.

De-assigning nodes from the node group
De-assigning a node from the node group involves the following:

• De-assigning AppStorManager node from the node group
• De-assigning CIM Extension Windows node from the node group
• De-assigning CIM Extension Unix node from the node group

De-assigning AppStorManager node from the node group
To de-assign the Windows node on which the Storage Essentials AppStorManager service running from
the SE AppStorMgr-Win node group, complete the following steps:

1. Login to the OVO management server, and start the OVO Console GUI.
2. Select Tools > HP Storage Essentials > AppStorManager-Win, and right-click De-assign

AppStorManager node from node group.
3. Select All Tasks > Launch Tool. The Edit Parameters window opens.

Figure 20 shows the Edit Parameters window.
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Figure 20 Edit Parameters window

4. Select the node in SE AppStorMgr-Win in the Select the nodes/services to replace $OPC
window pane.

5. Click Launch…. The Tool Status window opens.
Figure 21 shows the Tool Status window
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Figure 21 Tool Status window

You have now successfully de-assigned the Windows node on which the Storage Essentials
AppStorManager service running from the SE AppStorMgr-Win node group.

De-assigning CIM Extension Unix node from the node group
To de-assign the Unix node on which the Storage Essentials CIM Extension process is running from the SE
CIM Extension-Unix node group, complete the following steps:

1. Login to the OVO management server, and start the OVO Console GUI.
2. Select Tools > HP Storage Essentials > CIM Extension-Unix, and right-click De-assign CIM

Extension Unix node from node group.
3. Select All Tasks > Launch Tool. The Edit Parameters window opens.

Figure 22 shows the Edit Parameters window.
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Figure 22 Edit Parameters window

4. Select the node in SE CIM Extension-Unix folder in the Select the nodes/services to
replace $OPC window pane.

5. Click Launch…. The Tool Status window opens.
Figure 23 shows the Tool Status window.
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Figure 23 Tool Status window

You have now successfully de-assigned the Unix node on which the Storage Essentials CIM Extension
process running from the SE CIM Extension-Unix node group.

De-assigning CIM Extension Windows node from the node group
To de-assign the Windows node on which the Storage Essentials CIM Extension service running from the
SE CIM Extension-Win node group, complete the following steps:

1. Login to the OVO management server, and start the OVO Console GUI.
2. Select Tools > HP Storage Essentials > CIM Extension-Win, and right-click De-assign CIM

Extension Windows node from node group.
3. Select All Tasks > Launch Tool. The Edit Parameters window opens.

Figure 24 shows the Edit Parameters window.
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Figure 24 Edit Parameters window.

4. Select the node in the SE CIM Extension-Win in the Select the nodes/services to replace
$OPC window pane.

5. Click Launch…. The Tool Status window opens.
Figure 25 The Tool Status window opens.
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Figure 25 Tool Status window

You have now successfully de-assigned the Windows node on which the Storage Essentials CIM Extension
service running from the SE CIM Extension-Win node group.

Uninstalling Storage Essentials SPI from the OVO management
server

To uninstall the Storage Essentials SPI components from the OVO management server, complete the
following steps:

NOTE:
Ensure that OVO managed nodes are not present under Storage Essentials SPI node groups. They must be
moved out of their respective groups before uninstalling Storage Essentials SPI. For information on removing
the OVO managed nodes, see De-assigning nodes from the node group.
Ensure that you uninstall the Storage Essentials SPI policies from the OVO managed nodes before uninstalling
Storage Essentials SPI from the OVO management server. For more information on uninstalling Storage
Essentials SPI policies, see Uninstalling Storage Essentials SPI Policies from the OVO managed nodes.

1. Insert the HP OpenView New and Upgraded Smart Plug-ins, Volume 1 CD in the CD-ROM drive.
2. Select Remove products to proceed to the product selection dialog box.
3. In theProduct Selection Uninstall window, select SPI for HP Storage Essentials and click Next.

NOTE:
Selecting HP SIM Integration in the Product Selection Uninstall window also uninstalls SPI for
HP Storage Essentials.

Figure 26 displays the SPI Uninstallation window.
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Figure 26 SPI Uninstallation window

4. Select Remove.
5. Click Finish to complete the uninstallation procedure and exit the wizard.

This removes all the configuration files and executables of Storage Essentials SPI from the OVO server.
The Storage Essentials SPI node groups, policies, and tools are also removed from the OVO GUI.

For more information on uninstalling HP OpenView New and Upgraded Smart Plug-ins, refer to the New
and Upgraded Smart Plug-ins CD for OpenView Operations install/upgrade guide.

Uninstalling Storage Essentials SPI components from the OVO
GUI

Most of the components of the Storage Essentials SPI in the OVO GUI are automatically removed during
the uninstallation of the product. However, Storage Essentials SPI Admin user role must be removed
manually.
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Removing Storage Essentials SPI user roles
To remove the Storage Essentials SPI user roles, complete the following steps:

1. Start the OVO console GUI and click the User Roles Configuration Editor button located on the top
menu bar of the main OVO GUI. The User Roles window opens.
Figure 27 shows the User Roles window.

Figure 27 User Roles window

2. Select HP Storage Essentials SPI Admin and click Delete.

You have now successfully removed the Storage Essentials SPI user roles.
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7 Troubleshooting

This chapter discusses the following:

• Before you start
• Service monitoring events not arriving on the OVO management server message browser console
• HP Storage Essentials services not visible in the OVO console
• Storage Essentials service discovery may fail for more than one Storage Essentials CMS
• You get a message ”Errors occurred during distribution of the monitors...”

HP OpenView SMART Plug-In for HP Storage Essentials Administrator’s Reference for HP OpenView
Operations on Windows

57



Before you start
Before investigating the problem, you must perform the following basic checks to ensure that the Storage
Essentials SPI environment is installed and configured correctly:

• Ensure that the Storage Essentials SPI is installed properly. For more information on installing
Storage Essentials SPI, see Installing Storage Essentials SPI.

• Ensure that the Storage Essentials SPI is configured properly. For more information on configuring
Storage Essentials SPI, see Configuring Storage Essentials SPI.

The above steps ensure that you have installed and configured the Storage Essentials SPI in the
recommended manner, and that the messages seen in the OVO Events Browser are:

• Intercepted by the Storage Essentials SPI policies.
• Appearing in the OVO message browser in the form you expect.

If the preliminary check does not resolve the problems, go through the list of common problems and
their solutions described in the following section.
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Service monitoring events not arriving on the OVO
management server message browser console

Table 12 provides troubleshooting information for service monitoring events that do not arrive on the
OVO management server message browser console.

Table 12 Service monitoring events not arriving on the OVO management server
message browser console

Symptom Solution

No Storage Essentials service monitoring
events arriving on the OVO management
server.

• Ensure that the connection between the OVO management
server and the Storage Essentials CMS and the CIM
Extension nodes is up and running.

• Send a test message from OVO console, and ensure that it
is received in the OVO Events Browser. You can send a test
message using the test tools available in the HP OpenView
Operations console.

• Verify whether the OVO agent has been correctly installed
and configured on the management server, and the OVO
agent processes (and in particular the control agent) are
running.

• Ensure that the correct HP SIM Credentials are entered
when configuring the Storage Essentials CMS node before
adding the node to the SE AppStorMgr-Win node
group. For more information, see Obtaining HP Systems
Insight Manager CMS Credentials.

• Ensure that Storage Essentials CMS and CIM Extension
nodes are added to the appropriate node groups. For
more information, see Assigning nodes to node group.

• Ensure that the Storage Essentials SPI policies have been
correctly deployed to the Storage Essentials CMS and
CIM Extension nodes. To check whether the policies
are correctly deployed on the OVO console expand the
Nodes folder, right-click a node, and select View > Policy
Inventory. Right-click on the node, Select View > Policy
Inventory, and ensure that the relevant Storage Essentials
SPI policies are present.

• If CIM Extension monitoring has failed on UNIX node,
check if the HPSESPI-CIM_Extension-Unix policy is
enabled. If disabled, enable it or redeploy the policy to the
node. This situation can arise when the policy has been
deployed to the node before installation of CIM Extension
and the policy is automatically disabled.
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HP Storage Essentials services not visible in the OVO console
Table 13 provides troubleshooting information for HP Storage Essentials services that are not visible
in the OVO console.

Table 13 HP Storage Essentials services not visible in the OVO console

Symptom Solution

HP Storage Essentials services are not visible in the
OVO console.

• Ensure that the connection between the OVO
management server and the Storage Essentials
CMS nodes is up and running.

• Send a test message from OVO console and
ensure that it is received in the OVO Events
Browser. You can send a test message using
the test tools available in the HP OpenView
Operations console.

• Verify whether the OVO agent has been correctly
installed and configured on the management
server, and the OVO agent processes (and in
particular the control agent) are running.

• Ensure that the correct HP SIM Credentials are
entered when configuring the Storage Essentials
CMS node before adding the node to the
SE AppStorMgr-Win node group. For more
information, see Obtaining HP Systems Insight
Manager CMS Credentials.

• Ensure that the correct HP SIM Credentials
are entered before adding the node to the SE
AppStorMgr-Win node group, and also ensure
that the nodes are added using the Tools > HP
Storage Essentials > AppStoManager-Win >
Assign AppStorManager node to node group
tool. This ensures that the proper credentials are
copied to the Storage Essentials CMS node along
with other instrumentation.

• If there are multiple Storage Essentials CMS nodes
with different credentials, the Get SIM CMS
Credentials tool must be launched for one
node at a time and that node must be added to
the SE AppStorMgr-Win node group before
entering the credentials for the next node.

• Ensure that the Service Discovery policies present
at Policy Management > Policy Groups > HP
Storage Essentials > Service Discovery are
deployed on the Storage Essentials CMS node. To
check whether the policies are correctly deployed,
right-click on the node, Select View > Policy
Inventory, and ensure that the Service Discovery
policies are present.
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Storage Essentials service discovery may fail for more than
one Storage Essentials CMS

Symptom:

Storage Essentials service discovery may fail for more than one Storage Essentials CMS.

For example, the Storage Essentials services are successfully discovered for one Storage Essentials
CMS with CIM Extension nodes and fails to discover the CIM Extension nodes for the other Storage
Essentials CMS.

Cause/Solution:

To resolve this issue, complete the following steps:

1. On the OVO console, select Policy Groups > HP Storage Essentials > Service Discovery in the
Policy Management folder.

2. Right click Service Discovery policy group, and select All tasks > Uninstall from...
3. In the Uninstall policies on... window, select SE AppStorMgr-Win node folder from which the

policy has to be removed.
Figure 28 shows Uninstall policies on... window.

Figure 28 Uninstall policies on... window

4. Select remove all versions in the Deployment Options at the bottom of the Uninstall policies
on... window.

5. Click OK.
6. Right-click Services and select Configure > Services…. The Configure Services window opens.

Figure 29 shows Configure Services window.
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Figure 29 Configure Services window

7. Select HP Storage Essentials in the Systems Infrastructure service tree.
8. Click Delete.
9. Click OK.
10. Select Policy Groups > HP Storage Essentials > Service Discovery in the Policy Management

folder.
11. Right-click Service Discovery policy group, and select All Tasks > Deploy on.... The Deploy

policies on... window opens.
Figure 30 shows the Deploy Policies on... window.
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Figure 30 Deploy policies on... window

12. In the Deploy policies on... window, select one Storage Essentials CMS node whose CIM
Extension nodes discovery failed, in the SE AppStorMgr-Win node folder.

13. Click OK.

NOTE:
Wait for the discovery of Storage Essentials services to complete and update the OVO service map,
showing the successfully discovered Storage Essentials services.

14. Select Policy Groups > HP Storage Essentials > Service Discovery in the Policy Management
folder.

15. Right-click Service Discovery policy group, and select All Tasks > Deploy on.... The Deploy
policies on... window opens.
Figure 30 shows the Deploy Policies on... window.
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Figure 31 Deploy policies on... window

16. In the Deploy policies on... window, select the other Storage Essentials CMS node in the SE
AppStorMgr-Win node folder.

17. Click OK.

You get a message ”Errors occurred during distribution of the
monitors...” on OVO console when you deploy HP Storage
Essentials instrumentation

Symptom:

When HP Storage Essentials instrumentation is deployed/redeployed, messages like this appear:

Errors occurred during distribution of the monitors. Solve
the problems and distribute the monitors again. (OpC30-1030)
Error during transfer dir: Cannot move running binary from
\Program Files\HP OpenView\Installed Packages\{790c06b4-844e-
11d2-972b-080009ef8c2a}\bin\instrumentation/LogConf.prp to
C:\DOCUME~1\HPITOA~1.000\LOCALS~1\Temp\old45 (Errorcode: 32).
(OpC30-1066) Error during transfer dir: Cannot move binary from
\Program Files\HP OpenView\Installed Packages\{790c06b4-844e-11d2-
972b-080009ef8c2a}\tmp\OpC\bin\instrumentation/LogConf.prp to
\Program Files\HP OpenView\Installed Packages\{790c06b4-844e-11d2-
972b-080009ef8c2a}\bin\instrumentation/LogConf.prp. (OpC30-1067)

Cause/Solution:

If the HP SIM Integration Event Listener is configured on the OVO managed node, ensure that the HP
SIM Integration event listener is not running before deploying/re-deploying HP Storage Essentials
instrumentation to that node. Use HP SIM Integration > HP Systems Insight Manager tool Stop Event
Listener to stop the HP SIM Integration event listener on HP SIM CMS node or run the following command
on the OVO managed node from the command prompt opcagt -id 31 –stop.
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Glossary

Common Informa-
tion Model (CIM)

The Common Information Model is a common data model of an
implementation-neutral schema for describing overall management information
in a network/enterprise environment. CIM comprises a specification and
a schema. The specification defines the details for integration with other
management models such as Simple Network Management Protocol’s
(SNMP’s), Management Information Base (MIBs) or the Distributed Management
Task Force’s (DMTF’s) Maker Interchange Formats (MIFs) and the schema
provides the actual model descriptions.

Central Manage-
ment Server (CMS)

The central management server (CMS) runs the HP Storage Essentials
AppStorManager service and initiates all management operations within the
management domain.
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