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Overview

The Interface Discovery Datapipe discovers interfaces on SNMP-manageable devices. In
addition to discovering interfaces, the Interface Discovery Datapipe maintains configuration
data for discovered interfaces. To ensure continuity of data when the value of iflndex changes,
the Interface Discovery Datapipe supports the use of alternate, persistent attributes, namely:

e ifDescr

e fName

e ifAlias

The following report packs use data maintained by the Interface Discovery Datapipe:
e ATM Report Pack

e (Cisco Ping Report Pack

e Executive Summaries Report Pack
¢ Frame Relay Report Pack

e Interface Reporting Report Pack

e MPLS VPN Report Pack

e NetFlow Interface Report Pack

e NetFlow Global View Report Pack

Reindexing Log Report

The Interface Discovery Datapipe includes the Reindexing Log Report. This report deploys to
the OVPI Application Server when you install the package. The Reindexing Log contains the
following information:

e Identity of each interface (attribute and value)

e Date and time of report

e MIB-II ifIndex value of each interface (“Current Index” column)
e Previous index identifier, if any

e Number of attribute changes

This report, shown below, will refresh whenever an existing device re-indexes or whenever a
new device is added.
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The following table outlines recent enhancements to the Interface Discovery Datapipe.

Version Release Date Features/Enhancements

1.0 January 2003 Sybase support.

1.1 May 2003 Minor fixes.

1.1 October 2003 No changes.

2.0 April 2004 OVPI Object Manager support. Oracle
support.

2.0 August 2004 No changes.

2.1 November 2004 Added Juniper .dis file.
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Version Release Date Features/Enhancements

2.2 June 2005 Defect fixes.

2.2 December 2005 No changes.

2.3 May 2006 QXCR1000282768: ifAlias available in IR
even when ifAlias is not used as an interface
identifier.

Sources for Additional Information

The following documents are related to this manual:

e [Interface Discovery Datapipe 2.3 Release Statement

e [Interface Reporting ifEntry Datapipe 2.3 User Guide

e [Interface Reporting Report Pack 5.1 User Guide

e OVPI Report Packs, CD-ROM Release Notes, May 2006

Manuals for the core product, OVPI, and manuals for the reporting solutions and shared
packages that run on OVPI, can be downloaded from this site:

http:/www.managementsoftware.hp.com

Select Support > Product Manuals to reach the Product Manuals Search page. The user guides for
OVPI are listed under Performance Insight. The user guides for report packs and datapipes are
listed under Performance Insight Reporting Solutions. Each entry indicates the date. If a manual
is revised and reposted, the date will change. Since we post revised manuals on a regular
basis, you should check this site for updates before using any PDF you pulled from the Docs
directory on the report pack CD-ROM.
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2 Package Installation

This chapter covers the following topics:
¢ Guidelines for a smooth installation
¢ Running Package Manager

e Additional steps for Remote Pollers

e Package removal

Version 2.2 of the Interface Discovery Datapipe requires OVPI 5.0 or higher. There are no
package-level prerequisites for the Interface Discovery Datapipe.

Guidelines for a Smooth Installation

The report pack CD has the latest report packs, datapipes, and shared packages. When you
insert the CD and launch the package extraction program, the install script on the CD
extracts every package to the Packages directory on your system. When the extract finishes,
the install script launches Performance Insight and starts Package Manager.

If the extract step has already taken place, every package is available for installation. Install
the Interface Discovery Datapipe by launching Performance Insight, starting Package
Manager, and following the on-screen directions. Before using Package Manager, be familiar
with the following guidelines.

Removing an Earlier Version

Although most report packs can be upgraded, datapipes cannot be upgraded. Since there is no
upgrade path for the Interface Discovery Datapipe 2.3, your first step is to uninstall the older
version, if you are running the older version.

Uninstalling an earlier version has the following side-effects:

¢ The IR ifEntry Datapipe depends on the Interface Discovery Datapipe. If you remove an
older version of the Interface Discovery Datapipe, Package Manager will automatically
remove the older version of the IR ifEntry Datapipe.

¢ You will lose interface configuration data. However, the data you lose will be recollected
immediately and reports will not be affected.

e Ifyou were polling a flagged collection — Poll Flagged Interfaces Only — you must
re-provision the polling flag once version 2.3 is installed.

¢ You will lose polling group information. Reassign devices to the appropriate interface
identifier group once version 2.3 is installed.



Distributed Systems

If your system is distributed, installation is more complicated. Install the Interface Discovery
Datapipe on every OVPI server that performs polling. There is no need to install the Interface
Discovery Datapipe on the central server, unless the central server is polling.

The Package Manager Procedure

Insert the report pack CD and follow the instructions for extracting packages from the CD to
the Packages directory on your system. On Windows, the instructions appear in a Main Menu
that opens automatically. On UNIX, log in as root, mount the CD (if the CD does not mount
automatically), navigate to the top level of the CD directory, and run the ./setup command.

When the extract finishes, the install script starts Package Manager. If you have the Package
Manager install wizard up and running right now, start this procedure at step 4; otherwise
begin at step 1.

1 Login to the system. On UNIX systems, log in as root.
2 Stop OVPI Timer and wait for processes to terminate.
Windows NT: Select Settings > Control Panel > Administrative Tools > Services
UNIX: As root, do one of the following:
HP-UX: sh /sbin/ovpi_timer stop
Sun: sh /etc/init.d/ovpi_timer stop

3 From the Management Console, start Package Manager. The Package Manager welcome
window opens.

4 Click Next. The Package Location window opens.

Click Install. Approve the default destination directory or browse to a different directory if
necessary.

6  Click Next. The Report Deployment window opens. Type your OVPI username and
password.

7  Click Next. The Package Selection window opens. Click the check box for:
IFEntry_Disc_Datapipe 2.3
8 Click Next. The Type Discovery window opens. Accept the default to run Type Discovery.

) The Interface Discovery Datapipe includes vendor-specific type discovery files. These files
will automatically assign the appropriate index-by group to the devices that belong to those
vendors. Follow these steps if you want to assign additional device types to alternative
interface identifiers manually:

e Disable the Type Discovery option.

After the package is installed, use Polling Policy Management to assign the devices to the
appropriate index-by group.

9 Click Next. The Selection Summary window opens.

10 Click Install. The Installation Progress window opens and the install begins. When the
install finishes, a package installation complete message appears.

11 Click Done.
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12 Restart OVPI Timer.
Windows NT: Select Settings > Control Panel > Administrative Tools > Services
UNIX: As root, do one of the following:
HP-UX: sh /sbin/ovpi_timer start
Sun: sh /etc/init.d/ovpi_timer start

The Interface Discovery Datapipe is now installed on your system.

Package Removal

Follow these steps to uninstall the Interface Discovery datapipe:
1 Login to the system. On UNIX systems, log in as root.
2 Stop OVPI Timer and wait for processes to terminate.

3 From the Management Console, start Package Manager. The Package Manager welcome
window opens.

4  Follow the on-screen directions for package removal; when prompted, select the Interface
Discovery Datapipe for removal. When the uninstall is complete, a package removal
complete message appears.

5 Click Done.
6 Restart OVPI Timer.

Package Installation 9
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3 Datapipe Configuration

This chapter explains how to:

e Enable support for re-indexing

¢ Change an interface identifier

¢  Configure polling groups and polling policies for remote pollers

If you change an interface identifier for a given device after polling for that device has already
started, the data collected after the change will use the new interface identifier and the
pre-change data will not be associated with the post-change data. To avoid this outcome,
assign all devices to the desired index-by groups before data collection begins.

Enabling Re-Indexing Support

The MIB-II definition does not guarantee a persistent value for iflndex. Adding or removing
an interface, upgrading software, or even rebooting the system may change the ifIndex value
for an interface. If one of these events occurs and a unique and persistent identifier is not in
use, data collected before re-indexing took place not be associated with the interface.

The Interface Discovery Datapipe provides the following alternate identifiers:
e ifDescr — supported by the index-by-ifDescr polling group

e ifName — supported by the index-by-ifName polling group

e ifAlias — supported by the index-by-ifAlias polling group

To enable re-indexing, select an alternate identifier (just one alternate identifier) that is
unique for the device and persistent. Keep in mind that the Interface Discovery Datapipe
includes vendor-specific Type Discovery files that automatically assign certain types of
devices to an alternate interface identifier. As a result, some of the selection work is already
done for you. If you are moving a device from index-by-ifindex to any other group, the system
will update the identifier and replace ifIndex with the new identifier.

The following table contains a list of device types and pre-assigned identifiers.

Device Type Identifier Assigned by OVPI Type Discovery
Cisco Catalyst switches ifName

Cisco routers ifDescr

HP ProCurve switches ifName

(except 800T)
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The Interface Discovery Datapipe installs vendor-specific type discovery files in the
DPIPE_HOME/scripts directory. If you already have devices assigned to index-by groups, or if
you want to assign devices manually, follow these steps:

1 Disable type discovery.
2 Remove the .dis file from the scripts directory.

3 Assign devices manually.

Changing an Interface Identifier

The index-by-ifIndex group is the default group. It automatically contains all the devices in
the GENMIB2IF_Datapipe group that are not in the index-by-ifAlias, index-by-ifDescr, or
index-by-ifName groups.

How to Change an Interface Identifier

Follow these steps to change an interface identifier:

1 For each device type, choose the interface identifier.

2 Assign each device of that type to the appropriate index-by group.
a Start the Management Console.
b Click the Polling Policies icon. The Polling Policy Management window opens.
¢ Select Edit > Polling Groups.

d Select All Nodes of the Same Type in the top pane, and the required index-by group in
the bottom pane. Click Edit.

e Select the nodes to be assigned to this group in the left-hand pane, and click >> to
move them into the group on the right. Click OK when complete.

Repeat the process above for other device types and index-by groups as necessary.

4 Optional. If you just assigned devices to a polling group that is different from the polling
group that type discovery would put them in, remove the following Cisco or HP type
discovery files from the DPIPE_HOME/scripts directory:

e (Cisco_device_by_ifName.dis
e (Cisco_router_by_ifDescr.dis

e HP_ProCurve_by_ifName.dis

Duplicate Identifier Messages

If a device is assigned to an index-by group but the identifiers are not unique, then a duplicate
identifier message, similar to the following message, will be inserted in the Trend log.

bcp_gateway, ,WARNING, 1984,2076,0, "the object [testhost.test.hp.com AT3/0] is
duplicate for data table rv_ifentry disc_ifname"
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Configuring for Multiple Pollers

Additional steps are necessary if you are using the Interface Discovery Datapipe with
multiple remote pollers. The standard installation configures four groups and eight polling
policies for a single remote poller. Each remote poller will need its own polling group and
polling policy.

The datapipe package includes group and collection policy files for two pollers. If you need to
configure more than two pollers against a single database, you will need to generate
additional sets of group files and policies.

1 Login to the system. On UNIX, log in as root.
2 Navigate to the Interface Discovery Datapipe package directory:
UNIX:
SDPIPE_HOME/packages/IFEntry_Disc_Datapipe/IFEntry Disc_Datapipe.ap
Windows:
$DPIPE_HOME%\packages\IFEntry Disc_Datapipe\IFEntry_Disc_Datapipe.ap
3  Run this command:
trend_proc -f create_groups_multi pollers.pro

4  Run this command:

collection_manager -import -file IFEntry Disc_Collection Policies_multi_pollers

5 Start Polling Policy Management and select Edit > Datapipe Installations.

6  Click Create... to create new pollers. Add the hostname and (optionally) the IP address of
each poller and click OK.

7 When all pollers have been added, click Close to exit.
Click All in the left panel to display all polling policies.

9 Delete the original Flagged Discovery policies (those without an _p1 or _p2 at the end of
the name).

10 Modify the new Flagged Discovery policies (those with an _p1 or _p2 at the end of the
name) by double-clicking the policy.

a Change the Polling Assigned to setting for the pollerl policies to be the hostname of
pollerl as configured in step 8.

b Change the Polling Assigned to setting for the poller2 policies to be the hostname of
poller2 as configured in step 8.

At this point, the 15-minute policies should look similar to those in the following table.

Polling Policy

Table Alias Name for Data
to be Collected

Group Name to Collect
From

Poll From

Flagged_ifName_Disc_pl

x_IFEntry_Disc_ifName

discover-by-ifName-pollerl

Hostname of pollerl

Flagged_ifAlias_Disc_p2

xV_IFEntry_Disc_ifAlias

discover-by-ifAlias-poller2

Hostname of poller2

Flagged_ifDescr_Disc_p2

xV_IFEntry_Disc_ifDescr

discover-by-ifDescr-poller2

Hostname of poller2

Flagged_ifIndex_Disc_p2

xV_IFEntry_Disc_ifIndex

discover-by-ifIndex-poller2

Hostname of poller2

Datapipe Configuration
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Polling Policy

Table Alias Name for Data

to be Collected

Group Name to Collect
From

Poll From

Flagged_ifName_Disc_p2

xV_IFEntry_Disc_ifName

discover-by-ifName-poller2

Hostname of poller2

Flagged_ifDescr_Disc_p2

xV_IFEntry_Disc_ifDescr

discover-by-ifDescr-poller2

Hostname of poller2

Flagged_ifIndex_Disc_p2

xV_IFEntry_Disc_ifIndex

discover-by-ifIndex-poller2

Hostname of poller2

Flagged_ifName_Disc_p2

xV_IFEntry_Disc_ifName

discover-by-ifName-poller2

Hostname of poller2

11 Modify the existing All Discovery policies by double-clicking the policy.

a For the Collect Data From option, select A Combination of Type and View.

b Click the Create... button for the Group to Poll From and create an and intersection
between the index-by Type group and the pollerl View group.

¢ Change the Polling Assigned to setting to be the hostname of pollerl.

12 Add new All Discovery policies by selecting File > Create Polling Policy...

a Create four new policies similar to the pollerl policies but with the Group to Poll From

to be the equivalent poller2 group.
b Change the Collect Data From to be A Combination of Type and View.

¢ Click the Create... button for the Group to Poll From and create an and intersection
between the index-by Type group and the poller2 View group.

d Set the Polling Assigned to setting to be the hostname of poller2.

At this point, the daily policies should look similar to those in the table below.

Polling Policy

Table Alias Name for Data

to be Collected

Group Name to Collect
From

Poll From

All_ifIndex_Discovery_p2

xV_IFEntry_Disc_ifIndex

index-by-ifindex-poller2

Hostname of poller2

All_ifName_Discovery_p2

xV_IFEntry_Disc_ifName

index-by-ifName-poller2

Hostname of poller2

All_ifAlias_Discovery_p2

xV_IFEntry_Disc_ifAlias

index-by-ifAlias-poller2

Hostname of poller2

All_ifDescr_Discovery_p2

xV_IFEntry_Disc_ifDescr

index-by-ifDescr-poller2

Hostname of poller2

All_ifAlias_Discovery

xV_IFEntry_Disc_ifAlias

index-by-ifAlias-pollerl

Hostname of pollerl

All_ifDescr_Discovery

xV_IFEntry_Disc_ifDescr

index-by-ifDescr-pollerl

Hostname of pollerl

All_ifIndex_Discovery

xV_IFEntry_Disc_ifIndex

index-by-ifindex-pollerl

Hostname of pollerl

All_ifName_Discovery

xV_IFEntry Disc_ifName

index-by-ifName-pollerl

Hostname of pollerl

13 Select Edit > Polling Groups... > All Nodes in Same View in the upper pane, then select pollerl
in the lower pane. Assign nodes to be collected by pollerl to the pollerl View.

14 Select Edit > Polling Groups... > All Nodes in Same View in the upper pane, then select poller2
in the lower pane. Assign nodes to be collected by poller2 to the poller2 View.

14
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4 Polling Policies and Polling Groups

A standard installation of the Interface Discovery Datapipe enables five polling groups and a
combination of daily and 15-minute polling policies. Unless you need to enable support for
multiple pollers, modifying the default polling policies is unnecessary.

Polling Groups

The polling groups enabled by installing the Interface Discovery Datapipe are described in the

following table.
Name Description
GENMIB2IF_Datapipe Top-level group for all nodes that support MIB-II.
index-by-ifAlias Subset of the GENMIB2IF_Datapipe group; contains all
nodes that should use ifAlias as the identifier.
index-by-ifDescr Subset of the GENMIB2IF_Datapipe group; contains all
nodes that should use ifDescr as the identifier.
index-by-ifindex Subset of the GENMIB2IF_Datapipe group; containing all
the devices that do not belong to the index-by-ifAlias,
index-by-ifDescr, or index-by-ifName groups. Unless a device
is assigned to a different group, the device defaults to ifindex
as the interface identifier. Editing this group is not
necessary.
index-by-ifName Subset of the GENMIB2IF_Datapipe group; contains all
nodes that should use ifName as the identifier.

All four groups are based on GENMIB2IF_Datapipe. The index-by-ifIndex group is
automatically re-populated by the system once an hour. If a device is reassigned to a new
group, it will not immediately disappear from the index-by-ifIndex. However, thereafter, the
device will be polled from its new index-by group.

Any of the five polling groups in the preceding table can be viewed and modified using Polling
Policy Manager. To view or modify a polling group, open Polling Policy Management and select
Edit > Polling Groups > All Nodes of the Same Type.
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Polling Policies

A standard installation of the Interface Discovery Datapipe enables the following polling

policies:

e Four daily policies, one for each index-by group

e Four 15-minute policies, one for each index-by group

Daily Policies

The daily policies discover (and subsequently, rediscover) all of the interfaces on all of the
devices that support MIB-II. The daily policies are listed in the following table.

Policy Name

Table Alias Name for Data
to be Collected

Group Name to Collect
From

All_ifAlias_Discovery

xV_IFEntry_Disc_ifAlias

index-by-ifAlias

All_ifDescr_Discovery

xV_IFEntry_Disc_ifDescr

index-by-ifDescr

All_ifIndex_Discovery

xV_IFEntry_Disc_ifIndex

index-by-ifindex

All_ifName_Discovery

xV_IFEntry_Disc_ifName

index-by-ifName

15-Minute Policies

The 15-minute policies discover all of the interfaces for flagged devices only. These policies are

listed in the following table.

Policy Name

Table Alias Name for Data
to be Collected

Group Name to Collect
From

Flagged_ifAlias_Discovery

xV_IFEntry_Disc_ifAlias

discover-by-ifAlias

Flagged_ifDescr_Discovery

xV_IFEntry_Disc_ifDescr

discover-by-ifDescr

Flagged_ifIndex_Discovery

xV_IFEntry_Disc_ifIndex

discover-by-ifIndex

Flagged_ifName_Discovery

xV_IFEntry_Disc_ifName

discover-by-ifName

The Interface Discovery Datapipe adds a flag column called ifEntry_discover_flag to the core
managed node table ksi_managed_node. If a re-indexing event is detected for a particular

node, or if a new node is added to the system, the discover flag is set and the interfaces on that
node will be re-discovered during the next polling cycle.
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