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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2006 [or range of years] Hewlett-Packard Development Company, L.P.

Trademark Notices

OpenView is a U.S. registered trademark of Hewlett-Packard Development Company, L.P. 

Java™ is a U.S. trademark of Sun Microsystems, Inc.

Oracle® is a registered U.S. trademark of Oracle Corporation, Redwood City, California. 

UNIX® is a registered trademark of The Open Group.

Windows® and Windows NT® are U.S. registered trademarks of Microsoft Corporation. 

All other product names are the property of their respective trademark or service mark holders and are 
hereby acknowledged.
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Documentation Updates

To verify that the manual you are using is in fact the most recent edition, go to:

http://ovweb.external.hp.com/lpe/doc_serv/ 

Locate the product, then look to see if a more recent edition of this document is available for downloading. If 
you subscribe to the appropriate product support service, you can arrange to have document updates sent to 
you. Contact your HP sales representative for details.

The following table provides a list of changes made to this document since the last update in December 2005.  

Chapter Changes

Chapter 1 Minor editorial enhancements.

Chapter 2 Minor editorial enhancements.

Chapter 4 Minor editorial enhancements.
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Support

Please visit the HP OpenView web site at:

http://www.managementsoftware.hp.com/ 

This web site provides contact information and details about the products, services, and support that HP 
OpenView offers.

You can also go directly to the support web site at:

http://support.openview.hp.com/ 

HP OpenView online software support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As a valuable 
support customer, you can use the support site to:

• Search for knowledge documents of interest

• Submit and track progress on support cases

• Manage a support contract

• Look up HP support contacts

• Review information about available services

• Enter discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and log in. Many also require a 
support contract. 

To find more information about access levels, go to:

http://www.hp.com/managementsoftware/access_level 

To register for an HP Passport ID, go to:

http://managementsoftware.hp.com/passport-registration.htm 
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1 Overview
Common Property Tables lets the reporting solutions that run on OVPI share the same data 
for customers, locations, and nodes. Sharing data for customers, locations, and nodes 
eliminates duplication, allows the database to operate more efficiently, and simplifies the 
administration of report packs.

Installing Common Property Tables creates the following tables:

• K_Customer for customers

• K_Location for locations

• K_Node for nodes

The data in these tables comes from three sources:

• Report packs

• The batch-mode import utility bundled with Common Property Tables

• The create and update forms bundled with Common Property Tables

Version History

The following table outlines recent enhancements to Common Property Tables.

Version Release Date OVPI Version/Enhancements

2.1 May 2003 OVPI 4.5
HOSTS file property import (for easier mapping 
of node name to IP address in K_node)
upgrade package:
2.0 to 2.1 upgrade package

2.2 October 2003 OVPI 4.6
OVPI Object Manager support; “create new” 
forms and “update” forms
upgrade package:
2.0 and 2.1 to 2.2
7



Nightly Delete Process

Common Property Tables includes a nightly delete process:

CommonPropertyTables_delete_nodes.pro

The nightly delete process performs the following tasks:

• Rebuilds stored procedures, one per property table

• Deletes nodes from individual property tables 

• Deletes nodes from ksi_managed_node

Although there are two versions of this process, one for Sybase and one for Oracle, the process 
itself is database independent. The deletion of nodes from individual property tables takes 
place in response to the user marking nodes for deletion in Polling Policy Manager. Deleted 
nodes are listed in the log file maintained by Common Property Tables.

Sources for Additional Information

For information about the latest enhancements and any known problems affecting Common 
Property Tables 3.5, refer to the following document: 

• Common Property Tables 3.5 Release Statement

3.0 April 2004 OVPI 5.0
Oracle support
two new directories:
$DPIPE_HOME\data\ImportData 
$DPIPE_HOME\data\PropertyData

new nightly process:
CommonPropertyTables_delete_nodes.pro

upgrade package:
2.2 to 3.0

3.5 August 2004 Modified TableAlias values; minor bug fixes
upgrade package:
3.0 to 3.5 

3.5 November 2004 No changes

3.5 June 2005 upgrade package:
UPGRADE_CommonPropertyTables_to_3.5

3.5 March 2006 No changes

3.5 May 2006 No changes

Version Release Date OVPI Version/Enhancements
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Manuals for OVPI and manuals for the reporting solutions and shared packages that run 
on OVPI can be downloaded from this site:

http://www.managementsoftware.hp.com

Select Support > Product Manuals to reach the Product Manuals Search page. The user guides for 
OVPI are listed under Performance Insight. The user guides for report packs and datapipes are 
listed under Performance Insight Reporting Solutions. 

The manuals listed under Performance Insight Reporting Solutions indicate the month and year 
of publication. If a manual is revised and reposted, the date of publication will change. Since 
we post revised manuals on a regular basis, we recommend that you search this site for 
updates before using an older manual that might not be the latest version available.
Overview 9
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2 Package Installation
This chapter covers the following topics:

• Guidelines for a smooth installation

• Installing Common Property Tables 3.5

• Package removal

Guidelines for a Smooth Install

The December 2005 report pack CD contains the latest report packs, datapipes, and shared 
packages. When you insert the CD and launch the package extraction interface, the install 
script extracts every package from the CD and copies the results to the Packages directory on 
your system. After the extract finishes, the install script prompts you to launch Performance 
Insight and start Package Manager. Before using Package Manager, review the following 
guidelines.

Software Prerequisites

Common Property Tables 3.5 requires:

• OVPI 5.0 or higher

• All service packs available for the version of OVPI (5.0 or 5.1) you are running

Upgrading to Version 3.5

If you are running an earlier version of Common Property Tables, you can upgrade to 
Common Property Tables 3.5 by installing one upgrade package. When upgrading Common 
Property Tables, keep these rules in mind:

• Do not install other packages (a report pack or a datapipe) when you upgrade Common 
Property Tables. Install the upgrade package for Common Property Tables and only the 
upgrade package for Common Property Tables.

• When you install the upgrade package, you will be prompted to accept or disable the 
Deploy Reports option. The forms that come with Common Property Tables will not deploy 
to the OVPI Application Server unless you accept the default for Deploy Reports.

• If you are running OVPI on multiple servers, install the upgrade package on every server 
that is running Common Property Tables.
  11



Directory Structure

When OVPI was installed, the installation program created the following:

• A directory for OVPI; the directory name is OVPI

• A directory for packages available for installation

• An environment variable that points to the OVPI directory

On a UNIX system, the directory for OVPI defaults to /OVPI. On Windows, the directory for 
OVPI defaults to C:\OVPI. 

The Packages directory is where Package Manager looks for packages awaiting installation. 
This directory contains one sub-folder for each package copied from the report pack CD. When 
you run Package Manager, any package currently in the Packages directory will show up as 
install option in the Package Selection window. 

The environment variable is {DPIPE_HOME}. 

The ImportData and PropertyData Directories

Installing Common Property Tables creates two directories:

• $DPIPE_HOME\data\ImportData 

• $DPIPE_HOME\data\PropertyData

All report packs that rely on Common Property Tables use the PropertyData directory. 
They import flat files from the PropertyData directory and they export flat files to the 
PropertyData directory.
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Installing Common Property Tables 3.5

If the packages on the report pack CD have not been extracted yet, insert the CD and follow 
the instructions for extracting packages. On Windows, the instructions appear in a menu that 
opens automatically; on UNIX, mount the CD, navigate to the top level directory for the CD 
drive, and run the setup command. 

After the install script copies packages to your system, you will be prompted to start Package 
Manager. If the packages on the report pack CD were extracted, but Performance Insight is 
not running, begin at step 1. If you just extracted packages from the report pack CD and and 
Package Manager is running, begin this procedure at step 4.

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Open the Management Console and start Package Manager. The Package Manager 
welcome window opens. 

4 Click Next. The Package Location window opens.

5 Click Install. Approve the default installation directory or select a different directory if 
necessary. 

6 Click Next. The Report Deployment window opens. Accept the default to deploy reports. 
Type your username and password for the OVPI Application Server and click Next. The 
Package Selection window opens. 

7 If this is a new install, click the check box next to:

CommonPropertyTables

If you are upgrading, click the check box next to:

UPGRADE_CommonPropertyTables_to_3.5

8 Click Okay.

9 Click Next. The Type Discovery window opens. 

10 To run Type Discovery immediately after package installation, accept the default and 
click Next. The Selection Summary window opens.

11 Click Install. The Package Installation window opens and the install begins. When the 
install finishes, a package installation complete message appears.

12 Click Done to return to the Management Console.

13 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
Package Installation 13



Package Removal

If you just installed Common Property Tables for the first time, you may uninstall it. 
However, since Common Property Tables is a prerequisite for lots of report packs, you will also 
uninstall any report pack that depends on Common Property Tables as a prerequisite. 

If you just installed the upgrade package, you cannot return to the previous version of 
Common Property Tables by removing the upgrade package. Instead, to return to the previous 
version, uninstall the new version and then re-install the version you were running.

Follow these steps to uninstall Common Property Tables. 

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Do the following:

a Select Control Panel > Administrative Tools > Services.

b Select OVPI Timer from the list of services.

c From the Action menu, select Stop.

UNIX: As root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer stop

— Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. The Package Manager welcome window opens. 

4 Click Next. The Package Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens. 

7 Click Next. The Package Selection window opens. 

8 Click the check box next to Common Property Tables and click Next. The Selection 
Summary window opens.

9 Click Uninstall. The Progress window opens and the removal begins. When the removal 
finishes, a package removal complete message appears. 

10 Click Done.

11 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services.

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
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3 Import and Export Utilities
The user input forms described in the previous chapter are suitable when you are dealing 
with a small number of customer, location, or node objects. However, for a large number of 
objects, entering data using a batch process is probably more efficient. The Common Property 
Tables package includes import and export utilities for this purpose. 

The import utility imports the four property data files described in Chapter 5, Property 
Import Files. The utility runs once a day, automatically. The default run time is midnight, but 
you can change it to any hour of the day. You can also run the import utility manually, ahead 
of schedule. Run the export utility as needed.

The Import Utility

The import utility performs three tasks:

• Reads property data files containing records for the elements to be updated

• Stores the data in temporary tables in the database

• Uses imported data to update Common Property Tables (K_Node, K_Customer, and 
K_Location)

If the data in the property data file is for an element (node, customer, or location) that already 
exists in the property table, the data in the property table is overwritten by the imported 
data. If an element does not exist, a new row is inserted in the appropriate property table.

The default directory for property import and export files is:

{DPIPE_HOME}/OVPI/data/PropertyData

You never need to have all four property files in this directory. This directory can be empty, or 
it can contain just one or two files. When you want to update just one property table, edit just 
one file and store just one file.

To run the import utility manually, before the utility is scheduled to run, do the following:

1 Open a command prompt at the system level.

2 Navigate to the {DPIPE_HOME}/scripts directory.

3 Type the following command: 

trend_proc -f CommonPropertyTables_importdata.pro 
  15



The Export Utility

The export utility exports the contents of property tables as tab-delimited flat files and stores 
these files in the default property export directory or in a directory that you specify. The 
export utility is based on a process known as trend_export. This process determines which 
columns to export from the database and generates tab-delimited files in the proper directory, 
appending each file name with a timestamp, as follows:

• CommonPropertyTables_Customer.dat.<timestamp>

• CommonPropertyTables_Location.dat.<timestamp>

• CommonPropertyTables_Node.dat.<timestamp>

To run the export utility:

1 Open a command prompt at the system level.

2 Navigate to the {DPIPE_HOME}/scripts directory.

3 Type the following command:

trend_proc -f CommonPropertyTables_exportdata.pro 

Changing Default Directories

Common Property Tables creates a default directory reserved for property import and 
property export files. The import utility looks for files in this directory, and the export utility 
stores files in this directory. You are not required to establish a different directory. However, if 
changing the default directory is necessary, these are the tasks you would need to perform:

• Task 1: Create a new directory for import and export files

• Task 2: Provide the import utility with the path to the new directory

• Task 3: Provide the export utility with the path to the new directory

You can use the same directory for import and export files, or you can set up separate 
directories for import and export files.

Changing the Default Import Directory

The default directory for data property files, the location where the import utility will look for 
your edited files, is specified by the SourceDirectory path. This path appears in the following 
TEEL files:

• CommonPropTablesCustomer.teel

• CommonPropTablesHosts.teel

• CommonPropTablesLocation.teel

• CommonPropTablesNode.teel

If you are changing the default directory before you install the Common Property Tables 
package, you can locate the TEEL files in the CommonPropertyTables.ap directory. If you 
want to change the default directory after running Package Manager, you must change the 
path information in two directories:
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• CommonPropertyTables.ap

• {DPIPE_HOME}/lib

To change the SourceDirectory, do the following:

1 Create the new source directory.

2 Navigate to the appropriate directory and open the directory. (See the discussion in the 
preceding section about which directories are involved.) You will see the following files:

• CommonPropTablesCustomer.teel

• CommonPropTablesHosts.teel

• CommonPropTablesLocation.teel

• CommonPropTablesNode.teel

3 Double-click the CommonPropTablesCustomer.teel file.

4 Locate the line beginning with: SourceDirectory = 

5 Change the path, replacing the existing path with the complete path to the new directory; 
begin the new path name just after the equals sign ( = ). 

6 Make the same change in these files:

• CommonPropTablesHosts.teel

• CommonPropTablesLocation.teel

• CommonPropTablesNode.teel

Changing the Default Export Directory

To change the default export directory, modify the export data process file. If you are making 
this change before you install the package, you must make this modification only once, in the 
CommonPropertyTables.ap directory. If you are making this change after you run Package 
Manager, make this modification in two places: 

• CommonPropertyTables.ap

• {DPIPE_HOME}/scripts

Follow these steps to change the default export directory: 

1 In the CommonPropertyTables.ap directory, edit the 
CommonPropertyTables_exportdata.pro file. See sample file below.

2 Locate the three trend_export statements and, beginning at the bracket after the -o, 
replace the existing path with the complete path to the new directory.

Leave the file filters as specified in the original SourceDirectory.
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3 Only if necessary—only if you have already installed this package—navigate to the 
{DPIPE_HOME}/scripts directory and make the same changes you made to 
CommonPropertyTables_exportdata.pro.

Changing the Default Run Time

The default run time for the automatic import process is 12:00 midnight. Follow these steps to 
change the default:

1 In the {DPIPE_HOME}/lib directory, edit the trendtimer.sched file.

2 Scroll down the file and locate the line that defines the interval and offset for the 
trend_proc that executes the CommonPropertyTables_importdata.pro command.

3 Modify the offset indicator. The offset indicator is the number after the plus (+) sign. For 
example, if you change 24:00 to 18:00, the import utility will run at 18 hours after 
midnight, or 6:00 p.m.
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4 User Input Forms
The node, customer, and location objects maintained by Common Property Tables can be 
modified in two ways: 

• By using the input forms discussed in this chapter

• By using the import and export utilities discussed in the next chapter

The input forms allow you to create new objects for customers, locations, and nodes and 
modify existing objects. Using the forms is appropriate when you are adding or updating just 
a few objects. The batch-oriented utilities are more efficient when many entries are involved.

The “Create New” Forms

The Create-New forms allow you add new objects to the database. Follow these steps to 
launch a create-new form.

1 Click the Objects icon in the panel on the left side of the Management Console window. 
The Object/Property Management view opens. 

2 Click the New icon in the tool bar, or select File > New... from the menu. The Create 
Managed Object window opens.

3 Select an option and click Create at the bottom of the window.

Create New Customer

To add a new customer, type a customer name and a description. If you are entering only one 
customer, click OK. The customer will be added and the window will close. If you have more 
customers to add, click Apply. The customer will be added, the form will be cleared, and the 
form will remain open for the next customer. 

Keep the following rules in mind when using the Create New Customer form:

• You must supply a name to create a new customer object.
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• The customer name must be unique; you cannot have two customer objects with the same 
name.

• If a description is not specified, it will be set to the customer name.

Create New Location

To add a new location, enter a location name and a description. If you are entering only one 
location, click OK. The location will be added and the window will close. If you have more 
locations to add, click Apply. The location will be added, the form will be cleared, and the form 
will remain open for the next location. 

Keep the following rules in mind when using the Create New Location form:

• You must supply a name to create a new location object.

• The location name must be unique; having two location objects with the same name is not 
permitted.
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• If a description is not specified, it will be set to the location name.

Create New Node

To add a new node, enter a node name and any other information you may have. To assign a 
node to a customer or a location, click the customer or location drop box and select the desired 
entry. If you are entering only one node, click OK. The node will be added and the window will 
close. If you have more nodes to add, click Apply. The node will be added, the form will clear, 
and the form will remain open for the next node. 

Keep the following rules in mind when using the Create New Node form:

• You must supply a name for the node to create a new node object. The name can be its 
DNS name or its IP address.

• The name you supply must be unique; you cannot create a new node with the same name 
as an existing node.

• A node can only be assigned to pre-existing customers and locations. If you want to assign 
a node to a customer or location that does not exist, you must first add the customer or 
location using the New Customer or New Location form.

• If a description is not specified, it will be set to the node name.

Creating a new node via this form will not automatically result in data 
collection. To initiate SNMP collections, the same node must be defined in 
Polling Policy Manager and added to a polling group. See the OVPI 
Administration Guide for more information on Polling Policy Manager.
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The “Update” Forms

The update forms modify properties for customer, location, and node objects that already exist 
in the database. To launch an update form, click the Objects icon in the panel on the left side of 
the Management Console window. The Object/Property Management view opens. 
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Object Manager will present you with a list of objects. The type of object presented depends on 
which Object Manager view is open. The default view is the Device view, showing a list of 
devices, that is, nodes. The Customer view shows a list of customers, and the Location view 
shows a list of locations. To change the view, select View > Change View and use the pop-up 
window to select a different view.

When the type of object you are interested in updating is displayed, select the particular 
object you would like to update. When you select the object, Update <Object Type> Information 
will appear under Object Specific Tasks. Double-click the update task to open the appropriate 
update form.

Update Customer

To update customer information, type the changes in the fields provided. The ID is a reference 
number and cannot be changed. When changing the customer name, do not change it to 
another existing customer name. Having two customer objects with the same name is not 
allowed. To save your changes, click Apply. When you finish making changes, click OK. Your 
changes will be saved and the window will close.

 Update Location

To update location information, type the changes in the fields provided. The ID is a reference 
number and cannot be changed. When changing the location name, do not change it to 
another existing location name. Having two location objects with the same name is not 
allowed. To save your changes, click Apply. When you finish making changes, click OK. Your 
changes will be saved and the window will close. 
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Update Node

To update node information, type the changes in the fields provided. The node name cannot be 
changed. To assign a node to a different customer or location, click the customer or location 
drop box and select the desired entry. To save your changes, click Apply. When you finish 
making changes, click OK. Your changes will be saved and the window will close.
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5 Property Import Files
The import utility reads the following tab-delimited flat files:

• Customer data file

• Location data file

• Hosts data file

• Node data file

If the data that needs to be in these files already exists in a provisioning system, you can 
probably generate each flat file automatically by writing a script and exporting the data 
directly from the provisioning system database. If you cannot generate the file automatically, 
you must create it yourself. You may create it using a spreadsheet program such as Excel, or a 
text editor such as Notepad.

You can also generate customer, location, and node property import files by running the 
property export utility that comes with the Common Property Tables package. However, this 
approach to updating property information works only if the property tables were populated 
by a datapipe. If you run the export utility and notice that the export file is empty, the 
property tables are empty.

File Generation Guidelines

Whether you are exporting the data from a database or creating your own property import 
files, produce a separate file for customer, location, hosts, and node information and follow 
these guidelines:

• The sequence of columns, shown in the format tables below, is important. Adhere to this 
sequence and do not use values reserved for use by OVPI. 

• Do not embed tabs in quoted text strings. 

• If you are using a spreadsheet program, save each file as a tab-delimited file. If you are 
using a different method, be sure to enter a tab between columns.

• Give each input file the proper file name and save all the files to the directory where the 
import utility expects to find them.

The required file names are listed in the following table.

Property File File Name

Customer CommonPropertyTables_Customer.dat

Location CommonPropertyTables_Location.dat

Host CommonPropertyTables_Hosts.dat
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If you are using the default SourceDirectory path, save your property data files to:

{DPIPE_HOME}/data/PropertyData

If you changed the SourceDirectory path, copy the files to the new directory.

Format of the Import Files

This section describes the format of the customer, location, hosts, and node data files. Make 
sure the sequence of columns in your files is correct—the same exact sequence shown here—
and make sure you do not use values that are reserved by OVPI. If you were able to export 
data from a provisioning system database and specify the proper column sequence, most of 
your work is already done and your only task is to verify that reserved values are used 
correctly.

Customer Data File

The customer data file contains three columns separated by tabs. Each row represents one 
customer. See below for a description of each column.

Restrictions

Follow these rules when you prepare the customer data file:

• Do not include column headers in your file. The first entry in your file should be an actual 
customer ID, not “cust_id.” 

• Reserved values for column 1 (cust_id) are: -2, -1, 0. 

• If the cust_id string was exported from the K_Customer property table, do not change it. 

• If you are adding a new customer to K_Customer, the value in column 1 (cust_id) must be 
different from all existing cust_id values.

• If you use an existing cust_id value (a value that matches the cust_id value of an existing 
customer), you will overwrite that cust_id’s data.

• Since conflict with cust_ids that were automatically assigned by a report pack or datapipe 
is possible, try to use high numbers in column 1. For example, you could begin with 10,000 
and go up from there.

Node CommonPropertyTables_Node.dat

Property File File Name

Column No. Description

1 Unique integer value for each customer. This value is 
known as “cust_id.”

2 The name associated with the customer ID. 

3 A description of the customer.
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Location Data File

The location data file contains three columns separated by tabs. Each row represents one 
location. See below for a description of each column.

Restrictions

Follow these rules when you prepare the location data file:

• Do not include column headers in your file. The first entry in your file should be an 
integer value for a location ID, not “location_id.”

• Reserved values for column 1 (location_id) are: -2, -1, and 0.

• If the location_id string was exported from the K_Location property table, do not change 
it. 

• If you are adding a new location to K_Location, the value in column 1 (location_id) must 
be unique; that is, it must be different from all existing location_id values. 

• Since conflict with location_ids that were automatically assigned by a report pack or 
datapipe is possible, try to use high numbers in column 1. For example, you could begin 
with 10,000 and go up from there.

Hosts Data File

The hosts data file contains a one-to-one mapping of IP address to host name. This can be the 
system HOSTS file or a file with the same format as a system HOSTS file. The file contains 
two columns separated by a tab. Each row represents one device. See below for a description of 
each column.

Restrictions

Follow these rules when you prepare the hosts data file:

• Do not include column headers in your file. The first entry in your file should be an 
integer value for a location ID, not “IP address.”

• Each IP address and host name should be listed only once. Only the first occurrence of an 
IP address or host name will be imported; subsequent occurrences will be ignored.

Column No. Description

1 Unique integer value for each location. This value is 
known as “location_id.”

2 The name associated with the location ID. 

3 A description of the location.

Column No. Description

1 IP address

2 Host name
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• If an IP address had previously been mapped to a host name, importing it mapped to a 
different host name will make the previous mapping invalid. Only the latest mapping will 
be considered valid.

Node Data File

The node data file contains 15 columns separated by tabs. Each row represents one node. See 
below for a description of each column. 

Column No. Description

1 A unique text string that matches the node name or the 
node IP address. 
Note: The node name, if the name is resolvable, or the 
node IP address.

2 The node reference number specified by the user.
Note: This number is known as “node_id.”

3 Note: This column is not used; it is preserved to 
maintain compatibility with earlier versions.

4 The node IP address.

5 The node type. Initially, this should be set to host. Other 
node types will be added in the future.

6 A description of the node composed by the user.

7 The manufacturer of the node.

8 Node model type.

9 Node serial number.

10 Node operating system.

11 A name defined by the customer for the department 
where the node resides.

12 The ID number for the customer who owns the node; in 
other words, cust_id. This value establishes a link 
between the node and a customer in the K_Customer 
property table. 
Note: Default cust_id = -2.

13 The ID number for the location of the node; in other 
words, location_id. This value establishes a link between 
the node and a location in the K_Location property table.
Note: Default location_id = -2.

14 Customer name associated with cust_id.

15 Location name associated with location_id.
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The customer name and location name columns are not necessary and are supported as a 
convenience for the user when specifying cust_ids and location _ids that are not defined in the 
K_Customer and K_Location common property tables.

If a new customer_id or location_id is specified for a given node, that cust_id/location_id will 
be inserted into the K-Customer or K-Location table along with the specified customer name 
or location name. If the customer name or location name is not specified, the name will be set 
to Undefined Customer or Undefined Location, as appropriate.

Restrictions

Follow these rules when you prepare the node data file:

• Do not include column headers in your file.

• If a node name was exported from the K_Node Common Property Table, do not change it. 

• If you want to add a new node to the node property table, the text string in column 1 must 
be unique and it should be set to the node name (if available) or the node IP address. 

• If the text string in column 1 is not unique—that is, if the text string matches an existing 
value for node name—the other columns of your data file will overwrite the corresponding 
row in the common property table.

Import Files and Property Tables

The import file on the left updates the table on the right.

When you want to modify existing information in a property table, values must match exactly. 
If you are modifying a row in the K_Customer table, the cust_id values in the property file and 
the property table must match. Similarly, if you are modifying a row in the K_Location table, 
location_id values must match, and if you are modifying values in the K_Node table, node 
name values must match.

If the property import file introduces an existing value—that is, an existing cust_id, 
location_id, or node name value—the other values in the row from the property data file will 
overwrite the corresponding row in the common property table. If the property data file 
introduces a new value, a new row and keyid value will be inserted in the property table.

Property File Common Property Table

CommonPropertyTables_Customer.dat K_Customer

CommonPropertyTables_Location.dat K_Location

CommonPropertyTables_Node.dat K_Node

CommonPropertyTables_Hosts.dat K_Node
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6 Property Tables
The Common Property Tables package creates the following property tables:

• K_Customer

• K_Location

• K_Node

Each table is described below. 

K_Customer

The K_Customer property table contains customer-specific information. This table maintains 
customer ID, name, and description only. However, it can be expanded to support additional 
customer information (for example, address) if needed.

Column Description

dsi_key_id Unique value automatically assigned

dsi_target_name Always set to “0” for customer information

dsi_table_key Set equal to cust_id

dsi_descr Customer definable

cust_id Unique reference number for each customer

cust_name Customer name associated with cust_id
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K_Location

The K_Location property table contains location-specific information. This table maintains 
location id, name, and description only. However, it can be expanded to support additional 
location information if needed.

K_Node

The K_Node property table contains node-specific information. A node is any network device 
(computer, router, switch) capable of being polled for performance data.

Column Description

dsi_key_id Unique value automatically assigned

dsi_target_name Always set to “0” for location information

dsi_table_key Set equal to location_id; if the location information is 
not pre-provisioned, dsi_table_key will equal dsi_key_id

dsi_descr Customer definable

location_id Unique reference number for each location; if the 
location information is not pre-provisioned, location_id 
will equal dsi_key_id

location_name Location name associated with location_id

Column Description

dsi_key_id Unique value automatically assigned

dsi_target_name Always set to “0”

dsi_table_key Set equal to node_name.

dsi_descr Customer definable

node_id Customer-assigned reference number for each node

node_name Name of node; the DNS name or the IP address

node_type Type of node; only valid type = Host

IP_address Node IP address

make Node manufacturer

model Node model type

serial_num Node serial number

operating_sys Node operating system

department Customer-defined name for node department
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sysObjectID MIB II system object ID — not currently used

cust_fk Foreign key pointing to table K_Customer; default 
value points to default K_Customer row 

location_fk Foreign key pointing to table K_Location; default value 
points to default K_Location row

IP_state Flag indicating if the IP address node name mapping is 
the most recent mapping for the IP address

Column Description
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