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Legal Notices

Warranty

Hewlett-Packard makes no warranty of any kind with regard to this document, including, but not limited to, 
the implied warranties of merchantability and fitness for a particular purpose. Hewlett-Packard shall not be 
held liable for errors contained herein or direct, indirect, special, incidental or consequential damages in 
connection with the furnishing, performance, or use of this material. 

A copy of the specific warranty terms applicable to your Hewlett-Packard product can be obtained from your 
local Sales and Service Office.

Restricted Rights Legend

Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in subparagraph 
(c)(1)(ii) of the Rights in Technical Data and Computer Software clause in DFARS 252.227-7013.

Hewlett-Packard Company 
United States of America

Rights for non-DOD U.S. Government Departments and Agencies are as set forth in FAR 52.227-19(c)(1,2).

Copyright Notices

© Copyright 2002 - 2006 Hewlett-Packard Development Company, L.P.

No part of this document may be copied, reproduced, or translated into another language without the prior 
written consent of Hewlett-Packard Company. The information contained in this material is subject to change 
without notice.

Trademark Notices

OpenView is a U.S. registered trademark of Hewlett-Packard Development Company, L.P. 

Java™ is a U.S. trademark of Sun Microsystems, Inc.

Oracle® is a registered U.S. trademark of Oracle Corporation, Redwood City, California. 

UNIX® is a registered trademark of The Open Group.

All other product names are the property of their respective trademark or service mark holders and are 
hereby acknowledged.
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Support

Please visit the HP OpenView web site at:

http://www.managementsoftware.hp.com/ 

This web site provides contact information and details about the products, services, and support that HP 
OpenView offers.

HP OpenView online software support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As a valuable 
support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track progress on support cases

• Manage a support contract

• Look up HP support contacts

• Review information about available services

• Enter discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and log in. Many areas also 
require a support contract. 

To find more information about access levels, go to:

http://www.hp.com/managementsoftware/access_level 

To register for an HP Passport ID, go to:

http://managementsoftware.hp.com/passport-registration.html
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1 Overview
This chapter covers the following topics:

• OVPI and Cisco CallManager/Gateway Statistics

• Folders and Reports

• Integration with NNM

• Ways to Customize Reports

• Package Version History

• Sources for Additional Information

OVPI and Cisco CallManager/Gateway Statistics

HP OpenView Performance Insight (OVPI) is a performance management and reporting 
application. Long-term data collection, in-depth analysis, and automated web-based reporting 
are this application’s primary strengths. If desired, OVPI can be integrated with network 
management and system management applications, including NNM and OVO. Integration 
will enhance your ability to isolate faults, diagnose problems, and anticipate capacity 
problems.

The Cisco IP Telephony Statistics Report Pack installs on OVPI. The report pack’s primary 
purpose is to automate reporting for Cisco CallManager and Cisco gateways. The reports in 
this package analyze call volume and resource usage by tracking the following metrics:

• CAS channel usage

• PRI channel usage

• FXO port usage

• FXS port usage

• Total call volume handled by an instance of a CallManager

• Time spent in different states by channels of a given gateway

Gateway Support

Cisco GSU (Gateway Statistics Utility) is a drop-in module for CiscoWorks IP Telephony 
Environment Monitor. Although Cisco GSU collects performance statistics for Media Gateway 
Control Protocol (MGCP) gateways and Cisco IOS (H323) gateways, the current version of 
Cisco IP Telephony Statistics supports MGCP gateways only. 
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Data Flow

Output from the Cisco GSU is reformatted by a preprocessor. The preprocessor is part of the 
Cisco GSU Datapipe. After the preprocesssor reformats output from the Cisco GSU, the Cisco 
GSU Datapipe uses OVPI to import the results. The figure below shows a Cisco CallManager, 
a Cisco GSU, the Cisco GSU Datapipe, and an OVPI server running the Cisco IP Telephony 
Statistics Report Pack. 

Folders and Reports

If the OPVI application clients are installed on your system, you can access the reports in 
Cisco IP Telephony Statistics by opening the Management Console and navigating the object 
model. If you are accessing reports on the web, you will see the following folders:

• CallManager Cluster

• CallManager

• Gateway

• Location

Each folder contains a mix of summary reports, top ten reports, and forecast reports. The 
following table provides a list of the reports in each folder.

Folder Reports

CallManager 1 CallManager CAS Channel Activity Summary
2 CallManager Call Activity Summary
3 CallManager Call Activity Top Ten
4 CallManager FXO Port Activity Summary
5 CallManager FXS Port Activity Summary
6 CallManager Forecast
7 CallManager PRI Channel Activity Summary
8 CallManager Port Utilization Top Ten

CallManager Cluster 1 Cluster Busy Hour Utilization Correlation
2 Cluster CAS Channel Activity Summary
3 Cluster Call Activity Summary
4 Cluster Call Activity Top Ten
5 Cluster FXO Port Activity Summary
6 Cluster FXS Port Activity Summary
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Top Ten reports perform a ranking function. They make it easy for you to locate heavily used 
CallManagers, CallManager Clusters, gateways, and locations based on yesterday’s resource 
utilization levels.

Summary reports provide historical data for groups of devices organized by CallManager 
Cluster, CallManager, gateway, DS1 and other user-defined groups. Use these reports to find 
out whether recent high usage is a temporary event or a longer-term trend that may require 
corrective action. 

Forecast reports show estimates for future utilization. These reports highlight items that are 
trending toward over-utilization or under-utilization. Use these reports to find out which 
CallManager Clusters, CallManagers, gateways, and locations will be over-utilized or 
under-utilized in the near future. 

Integration with NNM

If NNM and OVPI are integrated, you should install the optional thresholds sub-package that 
comes with IP Telephony Statistics. The optional thresholds sub-package configures the 
Thresholds Module to detect threshold conditions and to respond to the threshold condition by 
taking an action. The default action is to send a breach trap to NNM. The breach trap received 
by NNM becomes an alarm in the NNM alarm browser, which the NNM operator can respond 
to by highlighting the alarm and launching a Near Real Time report. 

If your NNM server is the correct destination for breach traps, configuring the Thresholds 
Module is not necessary. You do not need to define an action or specify a destination for breach 
traps. However, you are free to modify category, severity, and destination parameters at any 
time. For details about these options, refer to the Thresholds Module 5.0 User Guide. For 
details about integrating NNM and OVPI, refer to the NNM/OVPI Integration Module 2.0 
User Guide.

7 Cluster Forecast
8 Cluster PRI Channel Activity Summary
9 Cluster Peak Utilization Correlation
10 Cluster Port Utilization Top Ten

Gateway 1 DS0 Usage Summary
2 DS1 Usage Summary
3 Gateway CAS Channel Activity Summary
4 Gateway FXO Port Activity Summary
5 Gateway FXS Port Activity Summary
6 Gateway Forecast
7 Gateway PRI Channel Activity Summary

Location 1 Channel Usage Summary by Location
2 DS1 Usage Correlation by Location
3 Gateway Forecast by Location
4 Gateway Summary by Location
5 Location Forecast
6 Location Summary
7 Location/Gateway Top Ten

Folder Reports
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Package Version History

The following table outlines recent changes to the Cisco IP Telephony Statistics Report Pack.

Ways to Customize Reports

You can change the contents of a report by applying group filters, by applying constraints, and 
by selecting a different view option for individual tables and graphs. For details about view 
options for tables and graphs, see Appendix A, Editing Tables and Graphs.

Applying Group Filters

If you intend to share reports with external customers, you must configure OVPI to produce 
customer-specific reports. Creating customer-specific reports involves the following tasks:

• Importing customer names and device locations using Common Property Tables 

Version Release Date Features/Enhancements

1.0 May 2003 32 reports
Cisco GSU Datapipe 1.0

2.0 October 2003 OVPI Object Manager support
new datapipe:
Cisco GSU Datapipe 2.0
new change forms:
• Configure a New CallManager Cluster
• Assign CallManagers to Clusters
• Configure Gateway Thresholds
• Configure CallManager Thresholds
• Configure Channel/Port Thresholds

2.0 April 2004 OVPI 5.0 support

3.0 August 2004 Oracle support
new datapipe:
Cisco GSU Datapipe 3.0

3.0 November 2004 No changes

3.1 June 2005 new upgrade packages:
• UPGRADE_Cisco_IP_Telephony_Statistics_to_31
• UPGRADE_Cisco_IPT_Statistics_Location_to_3
new datapipe:
Cisco GSU Datapipe 3.1

3.1 March 2006 No changes

3.1 May 2006 No changes
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• Creating a group account for all of the users affiliated with a particular customer

• Creating a group filter for the group account

For more information about using group filters, refer to the OVPI 5.1 Administration Guide. 

Applying Constraints

A constraint eliminates the data you are not interested in seeing. Apply a constraint is the 
same as editing a parameter. If you edit the Gateway parameter, data for all gateways except 
the gateway you typed in the Gateway field drops from the report. If you edit Gateway 
Location, data for all locations except the location you typed in the Gateway Location field 
drops from the report. You may apply multiple constraints at once. Cisco IP Telephony 
Statistics 3.0 supports the following parameters:

• CallManager Cluster Name

• CallManager Name

• Gateway Name

• Gateway Location

If you are using the Web Access Server to view reports from a web browser, edit parameters by 
clicking the edit parameters icon at the bottom right-hand corner of the report. When the Edit 
Parameters window opens, enter the constraint in the field and click Submit. 

If you are using Report Viewer, select Edit > Parameter Values from the menu bar. When the 
Modify Parameter Values window opens, click the Current Value field. Type a new value and 
click OK.

 Sources for Additional Information

This user guide contains samples of most of the reports in the package. The demo package 
that comes with Cisco IP Telephony Statistics contains a sample of every report in the 
package. If you have access to the demo package, and you want to know what fully-populated 
reports look like, install the demo package. Like real reports, demo reports are interactive. 
Unlike real reports, demo reports are static.

For details about the latest enhancements and known problems, refer to:

Cisco IP Telephony Statistics Report Pack 3.1 Release Statement

You may also be interested in the following documents: 

• Cisco IP Telephony Smart-Plug-in 1.0 User Guide

• Common Property Tables 3.5 User Guide

• IP Telephony Call Detail Report Pack 2.0 User Guide

• OVPI Report Packs, Release Notes, May 2006

Manuals for the Cisco SPI and the reporting solutions that run on OVPI can be 
downloaded from this site:

http://www.managementsoftware.hp.com
Overview 11



Select Support > Product Manuals to reach the Product Manuals Search page. The user guides for 
report packs and datapipes are listed under Performance Insight Reporting Solutions; the user 
guide for the Cisco SPI is located under Network Node Manager. 

The manuals listed under each product show a date, the month and year of publication. If a 
manual is revised and reposted, the date will change. Since we post revised manuals on a 
regular basis, you should check this site for updates before using any PDF that was shipped to 
you on the report pack CD-ROM.
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2 The Upgrade Install
This chapter covers the following topics: 

• Guidelines for a Smooth Upgrade

• Upgrading to Version 3.1

• Package Removal

Guidelines for a Smooth Upgrade

When you insert the December 2005 report pack CD in the CD-ROM drive and launch the 
package extraction program, the install script extracts every package from the CD and copies 
the results to the Packages directory on your system. When the extract finishes, the install 
script prompts you to start Package Manager. 

Upgrading to IP Telephony Statistics 3.1 is easy and straightforward:

• Install the “to_31” upgrade for IP Telephony Statistics (the main package)

• Install the “to_3” upgrade for the location sub-package

• Remove the old datapipe, Cisco GSU Datapipe 2.0

• Install the latest datapipe, Cisco GSU Datapipe 3.1

Before running Package Manager, review the following guidelines. 

Prerequisites

Make sure the following software is already installed before upgrading to version 3.1:

• OVPI 5.0 or higher

• All service packs available for the version of OVPI (5.0 or 5.1) you are running

• Common Property Tables 3.5

Common Property Tables

If you are running an earlier version of Common Property Tables, upgrade your current version 
to version 3.5. Do this before upgrading the report pack. When you install the “to_3.5” upgrade 
package, do not install anything else. Install the upgrade package for Common Property Tables 
and only the upgrade package for Common Property Tables.
  13



Datapipes and Remote Pollers

Upgrading a report pack usually entails uninstalling one or more datapipes. When you 
uninstall an existing datapipe, the following information is lost:

• Single polling policy for a remote poller

• Cloned polling policies for multiple remote pollers

• Customized polling groups 

To prevent this information from being lost, you can export existing polling policy 
configurations and customized polling groups by using the following commands:

• collection_manager

• group_manager 

Exporting Polling Policy Configurations

If your environment contains polling policies for remote pollers, use the collection_manager 
command to export existing policy configurations to a file. 

UNIX: As user trendadm, run the following command: 

cd $DPIPE_HOME

./bin/collection_manager -export -file /tmp/savePollingPolicy.lst

Windows: As Administrator, launch a command window. Navigate to the OVPI install 
directory and execute the following command: 

bin\collection_manager -export -file \temp\savePollingPolicy.lst

Exporting Polling Group Configurations

If your environment contains customized polling groups, use the group_manager command to 
export groups to individual .xml files. 

UNIX: As user trendadm, execute the following command: 

cd $DPIPE_HOME

./bin/group_manager -export_all -outfile /tmp/savePollingGroups

Windows: As Administrator, launch a command window, then navigate to the OVPI install 
directory and execute the following command: 

bin\group_manager -export_all -outfile \temp\savePollingGroups

Custom Table Views

If you created custom views for data or property tables, the views you created may interfere 
with the report pack upgrade, causing the process to fail. Whether or not your custom views 
interfere with the upgrade process depends on how you created them. If you created them 
using SQL, the upgrade will succeed but your custom views will not be available once the 
upgrade is complete. If you created them using Datapipe Manager, the upgrade is likely to 
fail. To prevent the upgrade from failing, delete your custom views before upgrading the 
report pack. After the upgrade is complete, recreate these views.
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Distributed Environments

If your system is distributed, every server must be running the same version of OVPI and all 
available Service Packs for that version of OVPI. Following is an overview of the upgrade 
install for a distributed environment:

1 Disable trendcopy on the central server.

2 At the central server, install these packages:

• UPGRADE_Common_Property_Tables_to_35; deploy reports

• UPGRADE_Cisco_IP_Telephony_Statistics_to_31; deploy reports

• UPGRADE_Cisco_IPT_Statistics_Location_to_3; deploy reports

3 At each satellite server, install these packages:

• UPGRADE_Common_Property_Tables_to_35; deploy reports

• UPGRADE_Cisco_IP_Telephony_Statistics_to_31; deploy reports.

• Remove Cisco GSU Datapipe 2.0.

• Install Cisco GSU Datapipe 3.1.

4 Re-enable trendcopy on the central server.

When you installed Cisco IP Telephony Statistics for the first time, you set up connections 
with satellite server databases, configured trendcopy pull commands, and switched off 
aggregations at each satellite server. If you recently upgraded from OVPI 4.6 to OVPI 5.0 or 
OVPI 5.1, the following configuration changes, which you made the first time shortly after you 
installed Cisco IP Telephony Statistics the first time, must be redone:

• Setting up connections with satellite server databases (using the Add Database Wizard)

• Configuring trendcopy pull commands 

For details, see Chapter 5, Setting Up a Distributed System.

Upgrading to Version 3.1

Perform the following tasks to upgrade to version 3.1:

• Task 1: Stop OVPI Timer and extract packages from the report pack CD

• Task 2: If necessary, upgrade Common Property Tables to version 3.5

• Task 3: Install two packages:

— UPGRADE_Cisco_IP_Telephony_Statistics_to_31; deploy reports

— UPGRADE_Cisco_IPT_Statistics_Location_to_3; deploy reports

• Task 4: Remove Cisco GSU Datapipe 2.0

• Task 5: Install Cisco GSU Datapipe 3.1

• Task 6: Restart OVPI Timer

Task 1: Stop OVPI Timer and extract packages from the report pack CD

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.
The Upgrade Install 15



Windows: Select Settings > Control Panel > Administrative Tools > Services

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the report pack CD in the CD-ROM drive. On Windows, a Main Menu displays 
automatically; on UNIX, mount the CD, navigate to the top-level directory for the CD 
drive, and type the setup command. 

4 Select OVPI report packs by typing 1 in the choice field and pressing Enter. The install 
script displays a percentage complete bar. When extraction finishes, the install script 
starts Package Manager. The Package Manager welcome window opens.

When the extract finishes, you have the option of navigating to the to the Packages directory 
on your system to see the results. These are the folders beneath the IP_Telephony folder:

• Docs

• Gateway_Statistics.ap

• Gateway_Statistics_Demo.ap

• Gateway_Statistics_Location.ap

• Gateway_Statistics_Thresholds.ap

• IPT_Admin.ap

• IPT_CallDetails.ap

• IPT_CallDetails_Demo.ap

• IPT_CallDetails_Location.ap

• IPT_CallDetails_Thresholds.ap

• NNM_Utils

Under Cisco GSU Datapipe, you will see the following folder:

• CiscoGSU_Datapipe.ap

Task 2: If necessary, upgrade to Common Property Tables 3.5

If you are running an earlier version of Common Property Tables, upgrade to Common 
Property Tables 3.5. If you are not running any version of Common Property Tables, skip this 
task. If you are upgrading, observe these rules:

• Do not install any other package with the upgrade package; install the upgrade package 
for Common Property Tables upgrade package and only the upgrade package for Common 
Property Tables. 

• When prompted to accept or disable the option to Deploy Reports, accept the default. If 
you disable the default, the forms that come with Common Property Tables will not be 
deployed.

• When the install finishes, click Done to return to the Management Console.

If you need help with the upgrade, refer to the Common Property Tables 3.5 User Guide. 
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Task 3: Upgrade Cisco IP Telephony Statistics

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. Approve the default installation directory or select a different directory if 
necessary. 

4 Click Next. The Report Deployment window opens; accept the default for Deploy Reports 
and enter your username and password for the OVPI Application Server. 

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following packages:

• UPGRADE_Cisco_IP_Telephony_Statistics_to_31

• UPGRADE_Cisco_IPT_Statistics_Location_to_3

7 Click Next. The Type Discovery window opens. Disable the default and click Next. The 
Selection Summary window opens. 

8 Click Install. The Installation Progress window opens; when installation is complete, a 
package installation complete message appears.

9 Click Done to return to the Management Console. 

Task 4: Remove the Cisco GSU Datapipe 2.0

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Uninstall.

4 Click Next. The Report Undeployment window opens.

5 Click Next. The Package Selection window opens.

6 Click the check box next to the following package:

• CiscoGSU_Datapipe 2.0

7 Click Next. The Selection Summary window opens.

8 Click Uninstall. The Progress window opens. When the uninstall process is complete, a 
package removal complete message appears.

9 Click Done.

Task 5: Install the Cisco GSU Datapipe 3.1

1 Start Package Manager. The Welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. 

4 Click Next. The Report Deployment window opens. Disable the default for Deploy Reports 
and click Next. The Package Selection window opens. 

5 Click the check box next to the following package:

• CiscoGSU_Datapipe 3.1

6 Click Next. The Type Discovery window opens. Disable the default and click Next. The 
Selection Summary window opens. 
The Upgrade Install 17



7 Click Install. The Installation Progress window opens. When the installation finishes, a 
package installation complete message appears.

8 Click Done. 

Restart OVPI Timer.

Windows: 

Do the following:

a From the Control Panel, select Administrative Tools > Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

UNIX:

As root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer start

— Sun: sh /etc/init.d/ovpi_timer start
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3 The New Install
This chapter covers the following topics: 

• Guidelines for a smooth installation

• Prerequisites related to OVPI and Cisco

• Installing IP Telephony Statistics 3.1

• Accessing deployed reports; new objects in the object model

• Package removal

Guidelines for a Smooth Install

An OVPI reporting solution has at least two ingredients, a report pack and a datapipe. Some 
reporting solutions offer multiple datapipes. When you install a datapipe, you configure OVPI 
to collect a specific type of performance data at a specific interval. When you install a report 
pack, you configure OVPI to summarize and aggregate the data collected by the datapipe.

The report pack CD-ROM contains report packs, datapipes, and several shared packages.. 
When you insert the report pack CD in the CD-ROM drive and launch the package extraction 
program, the install script extracts every package on the CD to the Packages directory on your 
system. When the extract finishes, the install script prompts you to start Package Manager. 
Review the following guidelines before using Package Manager.

Prerequisites

Cisco IP Telephony Statistics 3.1 has the following prerequisites:

• OVPI 5.0 or higher

• All service packs available for the version of OVPI (5.0 or 5.1) you are running

• A functioning CallManager environment (Cisco CallManager 3.3 or 4.0)

• MGCP gateways

• Cisco GSU 1.0 or Cisco GSU 2.0

The Cisco IP Telephony Statistics Report Pack shares property data with the IP Telephony 
Call Detail Report Pack. Sharing property data eliminates duplication and simplifies 
administration. However, since these report packs operate independently, installing both 
packages is not necessary.
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Upgrading Common Property Tables

If you are running an earlier version of Common Property Tables, upgrade to version 3.5. If 
you are not running any version of Common Property Tables, Package Manager will install 
the latest version of Common Property Tables for you, automatically.

Do not install the “to_3.5” upgrade package for Common Property Tables and other packages 
at the same time. Install the upgrade package for Common Property Tables and only the 
upgrade package for Common Property Tables. For more information about installing and 
using Common Property Tables, refer to the Common Property Tables 3.5 User Guide.

Distributed Environments

If you intend to run Cisco IP Telephony Statistics in a distributed environment, the 
installation procedure is more complicated. Here is an outline of the steps involved when 
installing Cisco IP Telephony Statistics in a distributed environment:

1 Verify that every server is running the same version of OVPI and all service packs 
available for that version.

2 Install Cisco IP Telephony Statistics on the central server:

a Disable trendcopy.

b If necessary, upgrade to Common Property Tables 3.5; deploy reports (forms).

c Install two packages:

— Cisco IP Telephony Statistics 3.1; deploy reports

— Cisco IPT Statistics Location 3.0; deploy reports

3 Install Cisco IP Telephony Statistics on each satellite server:

a If necessary, upgrade to Common Property Tables 3.5; deploy reports (forms)

b Install Cisco IP Telephony Statistics 3.1; deploy reports

c Install the Cisco GSU Datapipe 3.1.

4 Re-enable trendcopy on the central server.

After the installation is complete, you must set up connections with satellite server databases, 
configure trendcopy pull commands, and switch off aggregations above the hourly level on the 
satellite servers. For details, see Chapter 5, Setting Up a Distributed System.

Installing CiscoWorks

A functioning CallManager environment consists of CallManager systems and MGCP 
gateways.

CiscoWorks is available on Cisco CD One, Fifth Edition for Windows. Please refer to 
documentation published by Cisco for more information about installing, configuring, and 
troubleshooting CiscoWorks. 

Follow these steps to install CiscoWorks:

1 Download Cisco GSU from the following URL: 

http://www.cisco.com/cgi-bin/tablebuild.pl/cw-gtwystat-util 

You need a Cisco CCO login to download Cisco GSU. If you do not have a login, contact 
your local Cisco representative. 
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2 Download both the Cisco GSU readme and the executable installation file.

3 Read the readme.

4 Run the GSU installation file. The CiscoWorks menu window opens.

Configuring Cisco GSU

To configure Cisco GSU, perform the following tasks:

• Task 1: Create a data collection file.

• Task 2: Import the data collection file.

• Task 3: Schedule data collection.

Task 1: Creating a Data Collection File

Create a comma-separated data collection file. Your file will include a list of the gateways you 
want to monitor. Use the following syntax rules:

Field Description

Device Name Required. The device name or IP address for the CCM 
system.

Device Capabilities Required. The only valid value is “CCM”.
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Here is an example of an entry in your data collection file:

CCMSys1,CCM,MCS,3.1, 

For more information, refer to online help.

Task 2: Importing the Data Collection File

Follow these steps to import the data collection file:

1 From the CiscoWorks menu, select Gateway Statistics.

2 From the Gateway Statistics menu, select Device Management.

3 From the Device Management menu, select Device Import. When you are prompted, enter 
the path and name of the data collection file you created. 

4 Close the Device Import window. 

Task 3: Scheduling Data Collection

Follow these steps to schedule data collection by defining study parameters:

1 From the CiscoWorks menu, select Gateway Statistics.

Device Family Optional. Describes the CCM platform.

Software Version Required. The version number of the CCM software. 
Valid values are 3.1 and 3.2.

HTTP Server Optional. The DNS name or IP address of the HTTP 
server in the CCM cluster. If this field is not specified, the 
address or the name of the CCM system is used.

Field Description
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2 From the Gateway Statistics menu, select Study Management. The Define Study 
Parameters window opens. 

3 Schedule data collection by accepting or modifying the defaults for polling interval and 
schedule.

4 Click OK.

Installing Cisco IP Telephony Statistics 3.1

This section covers the following tasks:

• Task 1: Stop OVPI Timer and extract packages from the report pack CD

• Task 2: Upgrade to Common Property Tables 3.5

• Task 3: Remove Thresholds Module 4.0

• Task 4: Install these packages:

— Cisco IP Telephony Statistics 3.1

— Cisco IPT Statistics Location 3.0

— Cisco IP Telephony Statistics Thresholds (optional)

— Cisco GSU Datapipe

• Task 5: Restart OVPI Timer
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Task 1: Stop OVPI Timer and extract packages from the report pack CD

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the report pack CD in the CD-ROM drive. On Windows, a Main Menu displays 
automatically; on UNIX, mount the CD, navigate to the top-level directory for the CD 
drive, and type the setup command. 

4 Select OVPI report packs by typing 1 in the choice field and pressing Enter. The install 
script displays a percentage complete bar. When extraction finishes, the install script 
starts Package Manager. The Package Manager welcome window opens.

Once the extract is done, you have the option of navigating to the to the Packages directory on 
your system to see the results. These are the folders beneath the IP_Telephony folder:

• Docs

• Gateway_Statistics.ap

• Gateway_Statistics_Demo.ap

• Gateway_Statistics_Location.ap

• Gateway_Statistics_Thresholds.ap

• IPT_Admin.ap

• IPT_CallDetails.ap

• IPT_CallDetails_Demo.ap

• IPT_CallDetails_Location.ap

• IPT_CallDetails_Thresholds.ap

• NNM_Utils

Under Cisco GSU Datapipe, you will see the following folder:

• CiscoGSU_Datapipe.ap

Task 2: If necessary, upgrade to Common Property Tables 3.5

If you are running an earlier version of Common Property Tables, upgrade to Common 
Property Tables 3.5. Observe these rules:

• Do not install other package at the same time; install the Common Property Tables 
upgrade package and only the Common Property Tables upgrade package. 

• Accept the Deploy Reports option. If you disable the default, the forms that come with 
Common Property Tables will not be deployed to the OVPI Application Server. 

• When Package Manager indicates that the upgrade is complete, click Done to return to the 
Management Console.

If you need help with the upgrade, refer to the Common Property Tables 3.5 User Guide. 
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Task 3: Remove any previous version of the Thresholds Module

There is no upgrade path for the Thresholds Module. The latest version is version 5.0. If you 
are running an earlier version of the Thresholds Module (most likely version 3.0 or possibly 
version 4.0) uninstall this package by starting Package Manager and following the on-screen 
directions for package removal. When the uninstall is complete, click Done to return to the 
Management Console.

Package Manager will install the newest version of the Thresholds Module for you, 
automatically, if and when you select for installation the thresholds sub-package that comes 
with Cisco IP Telephony Statistics. In Task 4, below, you are directed to install the thresholds 
sub-package. Install the thresholds sub-package and Package Manager will select and install 
Thresholds Module 5.0 for you.

Task 4: Install Cisco IP Telephony 3.1 and the Cisco GSU Datapipe

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. Approve the default installation directory or use the browse feature to select 
a different directory if necessary. 

4 Click Next. The Report Deployment window opens. Accept the default for Deploy Reports; 
accept the default for application server name and port. Type your username and 
password for the OVPI Application Server. 

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following package:

• Cisco IP Telephony Statistics 3.1 

• Cisco IPT Statistics Location 3.0

• Cisco IP Telephony Statistics Thresholds

• Cisco IP Telephony Statistics Demo [optional]

• Cisco GSU Datapipe 3.1

7 Click Next. The Type Discovery window opens. To run Type Discovery immediately after 
package installation, accept the default.

8 Click Next. The Selection Summary window opens.

9 Click Install. The Installation Progress window opens and the install process begins. When 
the install finishes, a package install complete message appears. 

10 Click Done to return to the Management Console. 

11 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

12 Click Next. The Type Discovery window opens. 

13 Type Discovery is not required for Cisco IP Telephony Statistics and CiscoGSU_Datapipe. 
If no other packages are to be installed at the same time, clear the Discover check box and 
click Next. The Selection Summary window opens. 
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14 Click Install. The Installation Progress window opens; when installation is complete, the 
following message appears: Report Package: Completed.

15 Click Done. 

16 Restart OVPI Timer.

Windows: Do the following:

a From the Control Panel, select Administrative Tools > Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

UNIX: As root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer start

— Sun: sh /etc/init.d/ovpi_timer start

Accessing Deployed Reports

When you installed the this package, you enabled the Deploy Reports option. As a result, the 
reports (as well as any change forms that come with the reports) were deployed to the OVPI 
Application Server. Once reports reside on the OVPI Application Server, you can view reports 
using a web browser or one of the OVPI client applications. 

If the client applications are installed on your system, you have access to Report Viewer, 
Report Builder, and the Management Console. If you don’t have the client applications, using 
a web browser to view reports is the only way you can view reports.

For more information about the clients, refer to the OVPI Installation Guide. For details about 
the Management Console, including how to use the Object/Property Management view to 
launch reports specific to a selected object, refer to the OVPI Administration Guide.

New Objects for the Object Model

An object is any item that has performance data or property information associated with it. 
Devices, customers, and locations are objects categories that belong to OVPI’s default object 
model. When you select an object in the object model, you refresh the right side of the Object/
Property Management window. Under General Tasks, you will see a list of forms, under Object 
Specific Tasks, you will see a list of forms, and under Object Specific Reports, you will see a list 
of reports.

The object tree changes each time you install a new report pack. Installing the Cisco IP 
Telephony Statistics package adds the following object categories to the object model:

• Cluster

• CallManager

• Gateway

• DS1

• Port/Channel
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Package Removal 

Follow these steps to uninstall Cisco IP Telephony Statistics:

1 Log on to the system. On UNIX systems, log on as root.

2 Stop OVPI Timer and wait for processes to stop running.

Windows: Do the following:

a From the Control Panel, select Administrative Tools  Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Stop.

UNIX: As root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer stop

— Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. The Package Manager welcome window opens.

4 Click Next. The Package Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens. Accept the default for Undeploy 
Reports; also accept the defaults for application server name and port. Type your 
username and password for the OVPI Application Server. 

7 Click Next. The Package Selection window opens.

8 Click the check box next to the following packages:

• Cisco IP Telephony Statistics 

• Cisco IPT Statistics Location

• CiscoGSU_Datapipe

• Cisco IP Telephony Statistics Thresholds (if installed)

• Cisco IP Telephony Statistics Demo (if installed)

9 Click Next. The Selection Summary window opens. 

10 Click Uninstall. The Progress window opens. When the uninstall process is complete, a 
removal complete message appears.

11 Click Done.

12 Restart OVPI Timer.

Windows: Do the following:

a From the Control Panel, select Administrative Tools  Services

b Select OVPI Timer from the list of services.
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c From the Action menu, select Start.

UNIX: As root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer start

— Sun: sh /etc/init.d/ovpi_timer start

Removing Cisco IP Telephony Statistics automatically removes the Cisco 
GSU Datapipe even if you did not select the datapipe for removal.
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4 Package Configuration
This chapter covers the following topics: 

• Specifying the Source Data Directory

• CallManager Clusters

• Resource Thresholds and Change Forms 

Specifying the Source Data Directory

Before the Cisco GSU Datapipe can begin to collect data, it needs to know where the source 
data files are located. According to the default, the raw data files from Cisco Gateway 
Statistics Utility should be located on the server that is running the Cisco GSU Datapipe. If 
the raw data files are located on a remote server, the Cisco GSU Datapipe can be configured to 
use FTP to retrieve those files.

The default directory for the location of the raw data files is:

${DPIPE_HOME}/data/ImportData/CiscoGSU_Datapipe

The Cisco GSU Datapipe includes a preprocessor. The purpose of the preprocessor is to filter 
the raw data and put the raw data into a format that can be manipulated by the Cisco GSU 
Datapipe. The preprocessor (a perl script, CiscoGSU_PP.pl) produces the following output:

• CManager.dat

• Gateway.dat

• Channel.dat

The preprocessor stores these files in the source data directory. The Cisco GSU Datapipe 
reads the output from the preprocessor and imports the data into the OVPI database using 
the CiscoGSU_Collection.pro file and the following specialized configuration TEEL files:

• CiscoGSU_Cmanager.teel

• CiscoGSU_gateway.teel

• CiscoGSU_channel.teel

Before package installation, the TEEL files are located in: 

{DPIPE_HOME}/packages/CiscoGSU_Datapipe/CiscoGSU_Datapipe.ap

After installation, the TEEL files are located in: 

{DPIPE_HOME}/packages/CiscoGSU_Datapipe/CiscoGSU_Datapipe.ap
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{DPIPE_HOME}/lib

Changing the Source Directory Path

If raw GSU data files are located on a remote system, you must modify a line in a file. Follow 
these steps:

1 Open the {DPIPE_HOME}/scripts/CiscoGSU_Collection.pro file

2 Locate this line: 

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoGSU_PP.pl 

3 Add this to the end of the line:

-f 1 -m <Remote_Host_Name> -u <Username> -p <Password> -r <Remote_directory>

If the data source directory is not the same as the default directory described in the preceding 
section, make the following changes: 

1 Navigate to the appropriate directory (see the discussion above regarding which 
directories are involved).

2 Open the CiscoGSU_Collection.pro file.

3 Locate the following line:

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoGSU_PP.pl

4 Add this to the end of the line: 

-l <new directory path>

5 Open the following files:

— CiscoGSU_Cmanager.teel

— CiscoGSU_gateway.teel

— CiscoGSU_channel.teel

6 Locate the line beginning with Sourcefile = 

7 Change the path, replacing the existing path with the complete path name to the new 
directory; begin the new path name just after the equals sign (=). The source directory 
specified would normally be the directory created to receive the output from the Cisco 
Gateway Statistics Utility. 

Changing Source Disposition

TEEL files are also used to specify what to do with a data file once the data has been 
imported. The default behavior for the Cisco GSU Datapipe is to delete the preprocessed files. 
Because raw data files are archived, there is no need to archive data output by the 
preprocessor. 

If you make changes to TEEL files after installation, make the same changes 
in both directories.

Leave the filename as specified in the original SourceFile.
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CallManager Clusters

Although the Cisco IP Telephony Statistics package operates without importing custom 
property information, none of the cluster nor location-oriented reports provide meaningful 
data (for example, all CallManagers would be combined into one group called “Location 
Unassigned”).

The Cisco IP Telephony Statistics Report Pack allows the user to place the devices 
(CallManagers and gateways) into logical groups:

• Groups of CallManagers (based on cluster or other criteria)

• Groups of gateways (based on geographic location or user-defined criteria)

The grouping of these objects is enabled by creating a cluster name and assigning 
CallManagers or gateways to the cluster. For example, if the CallManagers s1ccm1 and 
s1ccm2 are assigned to a cluster named cluster1 and similarly if the CallManagers s2ccm1 
and s2ccm2 are assigned a cluster named cluster2, the report pack aggregates the data 
belonging to these four CallManagers into two groups (cluster1 and cluster2).

To get cluster information into reports, configure a CallManager cluster. You see clusters in 
reports immediately after OVPI processes your updated import file. 

Configuring a CallManager Cluster

To configure a CallManager cluster, do the following:

1 Create a cluster name:

a Launch the Management Console.

b Click Objects. The Object/Property Management window opens.
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c Select File > New > Create a new CallManager Cluster. The Configure A New CallManager 
Cluster form opens.

d Enter a name for the cluster and a brief description.

e Click Apply to save changes, OK to save changes and close the form, or Cancel to close 
the form without saving changes.

2 Assign CallManagers or gateways to the cluster:

a From the Object/Property Management window, select View > Change View > Location. 

b Select a location.

c Highlight the Location Unassigned folder.
32 Chapter 4



d Double-click Assign CallManagers to Clusters under Object Specific Tasks. The form 
opens.

e Highlight a CallManager name in the CallManager List and select the cluster name 
to which it is assigned.

f Click Apply to save changes, OK to save changes and close the form, or Cancel to close 
the form without saving changes.
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Resource Thresholds and Change Forms

Cisco_IP_Telephony_Statistics_Thresholds, the optional thresholds sub-package that comes 
with IP Telephony Statistics, imposes thresholds for resource utilization monitoring. When 
performance reaches one of these default thresholds, OVPI sends a trap to the Network Node 
Manager (NNM). The following table describes the condition behind each threshold and the 
severity of the alarm. 

Modifying Gateway and CallManager Thresholds

Threshold values can be modified, using forms, for a gateway or CallManager. To modify a 
threshold value, do the following:

1 Launch the Management Console.

Threshold Default Condition Severity

PRIOverUtilization 95% 95% of PRI channels or more were 
occupied for each monitored device 
(CallManager or Gateway) during the 
previous day.

Warning

PRIUnderUtilization 5% 5% of PRI channels or less were 
occupied for each monitored device 
(CallManager or Gateway) during the 
previous day.

Warning

CASOverUtilization 95% 95% of CAS channels or more were 
occupied for each monitored device 
(CallManager or Gateway) during the 
previous day.

Warning

CASUnderUtilization 5% 5% of CAS channels or less were 
occupied for each monitored device 
(CallManager or Gateway) during the 
previous day.

Warning

FXOOverUtilization 95% 95% of FXO ports or more were occupied 
for each monitored device (CallManager 
or Gateway) during the previous day.

Warning

FXOUnderUtilization 5% 5% of FXO ports or less were occupied 
for each monitored device (CallManager 
or Gateway) during the previous day.

Warning

FXSOverUtilization 95% 95% of FXS ports or more were occupied 
for each monitored device (CallManager 
or Gateway) during the previous day.

Warning

FXSUnderUtilization 5% 5% of FXS ports or less were occupied 
for each monitored device (CallManager 
or Gateway) during the previous day.

Warning

DeadChan N/A A channel was in OutofService status all 
the time during the previous day.

Warning
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2 Click Objects. The Object/Property Management window opens.

3 Select View > Change View > Cluster. 

4 Select a gateway or cluster.

5 Under Object Specific Tasks, double-click Configure Gateway Thresholds or Configure 
CallManager Thresholds. The form opens. Both forms are similar and the Configure 
Gateway Thresholds form is shown below.

6 Modify the threshold.

7 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.

Modifying Channel/Port Thresholds

The channel/port threshold value (DeadChan) can be modified:

1 Start Report Builder. 

On a Windows system, select Programs > HP OpenView > Performance Insight > Builder. 
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On a UNIX system, cd to $OVPI_HOME/bin and type ./builder.

2 From Report Builder, select File > Open.

3 Open the following file:

%OVPI_HOME%\forms\deploy\admin\Cisco_IPT_Admin_Forms\ 
Cisco_IPT_Statistics_Forms\ChannelPortThreshConfig.frep

The Configure Channel/Port Thresholds form opens.

4 Modify the threshold.

5 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.
36 Chapter 4



5 Setting Up a Distributed System
If you intend to run Cisco IP Telephony Statistics as a distributed system across multiple 
servers, and you followed the installation guidelines in the installation chapter, your central 
server is running the report pack and each of your satellite servers is running the report pack 
and the Cisco GSU Datapipe. You are now ready to perform these tasks:

• Configure the central server

• Configure each satellite server

• Verify that all system clocks are synchronized

Configuring the Central Serve

Perform these tasks to configure the central server:

• Set up connections with satellite server databases

• Configure trendcopy pull commands 

Task 1: Set up connections with satellite server databases.

1 Start the Management Console.

2 Click the Systems icon on the lower left. The System/Network Administration pane opens.

3 Right-click the Databases folder. When prompted, select Add OVPI Database. The Add 
Database Wizard opens. 

4 Click Next.

5 Type the hostname and port number for the database you want to add; click Next.

6 Review the Summary. Repeat Steps 4 and 5 for each additional database.

7 Click Finish when you are done. 

Task 2: Configure trendcopy pull commands from the central server to each satellite server.

1 Open the following file:

$DPIPE_HOME/scripts/Cisco_IP_Telephony_Statistics_Daily.pro

2 Modify block0 as follows:

a Remove “#” before each line in block0, including the begin and end lines.

b Replace SATELLITE_SERVER_1_DATABASE with the satellite server name.

c Replace THIS_MACHINE_DATABASE with the central server name.
  37



3 If there is more than one satellite server, create a copy of block0 for each satellite server 
and repeat step 2 for each block.

4 Save and close:

$DPIPE_HOME/scripts/Cisco_IP_Telephony_Statistics_Daily.pro

Configuring a Satellite Server

Switch off daily aggregations. Follow these steps:

1 Locate the $DPIPE_HOME/lib/trendtimer.sched file.

2 Comment out the lines referencing Cisco_IP_Telephony_Statistics_Daily.pro.

System Clocks

Make sure that the system clock on each satellite server is synchronized with the system clock 
on the central server.

If the satellite server is performing local reporting, or if the 
Cisco_IP_Telephony_Statistics_Location module is installed, do not switch off daily 
aggregations.
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6 Top Ten Reports
Top Ten reports allow you to rank CallManagers,CallManager clusters, Gateways, and 
locations. The key metrics are baseline average and the rate of increase. The baseline average 
is calculated by averaging all the busy hours reported over the baseline period. The rate of 
increase is calculated by dividing the 30-day forecast value by the baseline average. 

There are five Top Ten reports:

• 2 CallManager reports (one for active calls, one for port utilization)

• 2 cluster reports (one for call activity, one for port utilization)

• 1 location/gateway report

The CallManager reports provide statistics for individual CallManagers. The cluster reports 
aggregate statistics for multiple CallManagers. The location report aggregates statistics for 
groups of devices at each location. All reports contain two tables, one for utilization and one 
for rate of increase. The utilization table on the left looks at data for yesterday, while the rate 
of increase table on the right looks at baseline data, which includes data for yesterday. Top 
Ten reports refresh once daily

The following table describes what each report is ranking.

Report Ranking

CallManager Active Calls • Highest average active calls
• Rate of increase in active calls

CallManager Port Utilization • Highest port utilization rate
• Highest rate of increase in port utilization

Cluster Call Activity • Highest average active calls
• Rate of increase in active calls

Cluster Port Utilization • Highest port utilization rate
• Highest rate of increase in port utilization

Location/Gateway • Highest percentage of active ports by location
• Rate of increase in port utilization by location
• Highest percentage of port utilization by gateway
• Highest rate of increase in port utilization by gateway
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7 Summary Reports
Summary reports add depth to Top Ten Reports. They aggregate data for a particular element 
type and plot metrics on an hourly, daily, and monthly basis. Hourly graphs show anomalies 
and time-of-day usage patterns; daily and monthly graphs reveal trends derived from hourly 
data. Use summary reports to find out whether the performance you see in a Top Ten report 
reflects a temporary condition or an on-going trend.

CallManager Cluster Selection Table. Sorts clusters by busy hour call activity, from 
highest to lowest. This table reports events for yesterday. Selecting a cluster updates the PRI 
Channel Activity graph to reflect activity for the selected cluster. 

PRI Channel Activity Graph. If the average or busy hour levels for PRI channel activity in 
the hourly graph seem unusual, compare the hourly graph to the daily graph. The daily graph 
gives you a feel for what was normal for the last few weeks. If the hourly graph diverges 
significantly from the daily graph, yesterday’s levels were not typical. The daily tab includes 
busy hour. If conditions are normal, busy hour and average utilization will not converge.

CallManager Cluster Selection Table. Sorts clusters by busy hour calls, from highest to 
lowest. Use this table to see which clusters require further investigation and which type or 
types of metrics need more attention. This table reports events for yesterday. Select a cluster 
to view call activity by CallManager in the CallManager Selection table. 

CallManager Selection Table. Sorts CallManagers by call activity for the selected cluster, 
from highest to lowest. This table reports events for yesterday. 

Gateway Selection Table and DS1 Selection Table. Displays data aggregated at various 
levels in the hierarchy. Similar to the CallManager Cluster and CallManager selection tables. 
The DS1 selection table is the lowest level in the hierarchy. Selecting a DS1 updates the 
Channel States graph with metrics for that DS1.

Channel States Graph. Displays the percentage of time spent in various states by the 
channels that belong to the selected DS1. Displays data at hourly, daily and monthly levels; if 
the hourly graph diverges significantly from the daily graph, yesterday was not typical.

See below for samples of the following reports:

• CallManager Call Activity Summary

• Cluster PRI Channel Activity Summary

• Gateway Summary by Location

• DS0 Usage Summary

• DS1 Usage Summary
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8 Forecast Reports
Forecast reports alert you to conditions where port over-utilization or port under-utilization is 
developing. All forecast reports include a selection table followed by graphs. The selection 
table performs a ranking function, allowing you to see which elements are seeing the highest 
rates of increase based on data in the rolling baseline. The selection table sorts items from 
highest rate of increase to lowest rate of increase. In addition to baseline values, the selection 
table includes projections for:

• F30 

• F60 

• F90 

The graphs below the selection table provide more detail about the item highlighted in the 
selection table. Each graph has three tabs:

Standard. Compares the baseline to F30, F60, and F90 values. 

Day of Week. Aggregates data by day and shows whether overall growth is generally the 
same throughout the week or significantly different one day to the next. Because this view 
factors “downdays” out of the calculation, you can see what the forecasts are like when they 
are not skewed by abnormally low levels of utilization.

History. Displays the busy hour metrics that were used to calculate values for F30, F60, and 
F90. 

See below for samples of the following reports:

• CallManager Forecast

• CallManager Cluster Forecast

• Gateway Forecast by CallManager

• Gateway Forecast by Location

• Location Forecast
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9 Correlation Reports
Correlation Reports allow you to compare:

• Peak utilization for CallManagers within the same cluster

• Busy hour utilization for CallManagers within the same cluster

• DS1 usage on a location-by-location basis

These reports will help you see where utilization is not balanced. See below for samples of the 
following reports:

• CallManager Cluster Peak Utilization Correlation

• CallManager Cluster Busy Hour Utilization Correlation

• DS1 Usage Correlation by Location
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A Editing Tables and Graphs
Any table or graph can be viewed in several ways. While the default view is usually adequate, 
you can easily change to a different view. If you are using Report Viewer, right-click the object 
to open a list of view options. If you are using the Web Access Server, follow these steps to 
change the default view of a table or graph:

1 Click Preferences on the links bar.

2 Expand Reports in the navigation frame.

3 Click Viewing.

4 Select the Allow element editing box.

5 Click Apply.

6 Click the Edit icon next to the table or graph. 

View Options for Tables

Right-clicking a table, or selecting the Edit Table icon if you are using the Web Access Server, 
opens a list of table view options.

Select Set Time Period to alter the relative time period (relative to now) or set an absolute time 
period. The Set Time Period window opens.

You may shorten the period of time covered by the table from, for example, 42 days to 30 days 
or to 7 days. If you are interested in a specific period of time that starts in the past and stops 
before yesterday, click Use Absolute Time and select a Start Time and an End Time.

Select Change Constraint Values to loosen or tighten a constraint, thereby raising or lowering 
the number of elements that conform to the constraint. The Change Constraint Values 
window opens. To loosen a constraint, set the value lower; to tighten a constraint, set the 
value higher.
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The Select Nodes/Interfaces allows you to change the scope of the table by limiting the table to 
specific nodes, specific interfaces, or a specific group of nodes or interfaces. The Select Node 
Selection Type window opens.
Change Max Rows increases or decreases the number of rows in a table. The default is 50. If 
you expand the default, the table may take more time to open. If you are trending a large 
network, using the default ensures that the table opens as quickly as possible. 
View in new Frame opens the table in a Table Viewer window, shown below. If necessary, make 
the data in the table more legible by resizing the window. 
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View Options for Graphs

Right-clicking a graph, or clicking the Edit Graph icon if you are using the Web Access Server, 
opens the following list of view options. 

The following table provides details about each option.

Option Function

Set Time Period Same as the table option shown above.

Change Constraint Values Same as the table option shown above.

Select Nodes/Interfaces Same as the table option shown above.

Displayed Data For every point on a graph, display data in a 
spreadsheet.

Grid Add these to the graph:
X axis grid lines
Y axis grid lines
X and Y axis grid lines

Legend Delete or reposition the legend. 

Style See the illustrations below.

Change Max Rows... Same as the table option shown above.

Display Data Table See below.
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Style Options

Select Style to display a list of seven view options for graphs.

Style > Area

The plot or bar chart changes to an area graph. While relative values and total values are 
easy to view in this format, absolute values for smaller data types may be hard to see. Click 
anywhere within a band of color to display the exact value for that location 

To shorten the time span of a graph, press SHIFT+ALT and use the left mouse button to 
highlight the time span you want to focus on. Release the mouse button to display the selected 
time span.

Export Element as CSV... Same as the table option shown above.

View in New Frame Opens graph in a Graph Viewer window.

Print Graph Same as the table option shown above.

Option Function
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Style > Stacking Area

The area or plot graph changes to a stacking area graph. This view is suitable for displaying a 
small number of variables.

Style > Bar

The graph changes to a bar chart. This view is suitable for displaying relatively equal values 
for a small number of variables. There are three variables in the graph below.
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Style > Stacking Bar

The plot or area graph changes to a stacking bar chart. If you increase the width of the frame, 
the time scale becomes hourly. If you increase the height of the frame, the call volume shows 
in units of ten.

Style > Plot

Bands of color in an area graph change to lines. If you adjust the frame width, you can make 
the data points align with hour; if you adjust the frame height, you can turn call volume into 
whole numbers.
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Style > Pie

An area graph becomes a pie chart. Bands in an area graph convert to slices of a pie and the 
pie constitutes a 24-hour period. This view is helpful when a small number of data values are 
represented and you are looking at data for one day.

If you are looking at data for more than one day, you will see multiple pie graphs, one for each 
day. 

Display Data Table

This option changes a graph into a spreadsheet. 
Editing Tables and Graphs 77



View in New Frame

The graph opens in a Graph Viewer window. Improve legibility by resizing the window. 
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Glossary
active ports rate

A measure of the percentage of total active channels/ports divided by the total channels/ports.

baseline average

The average of all samples during the baseline period. The baseline period is a rolling period 
comprising the previous 91 days

busy hour

Busy hour is the maximum hourly average for the day. This value is the basis for calculating 
future performance. Unlike the average for the day, this value does not smooth out daily peaks 
and valleys. In addition, unlike the daily maximum, or peak, and the daily minimum, this 
value represents a relatively persistent phenomenon, not a momentary condition. Since busy 
hour is an average, actual utilization could have been well above the average for a portion of 
that particular hour, as well as well below the average for a portion of that particular hour. 

Cisco IP Telephony Statistics calculates a busy hour for the following metrics:

• Number of calls

• Active PRI channels

• Active CAS channels

• Active FXO ports

• Active FXS ports 

CallManager

A Cisco AVVID IP Telephony service whose primary function is the control and routing of calls 
from voice-enabled IP devices.

CAS

Channel Associated Signaling. A scheme for transmission of call signaling information that 
relies on interleaving the call signaling within the media information that the interface 
transmits.

channel name

The concatenation of DS1Name and Channel Index.
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daily

Performance over the preceding 30 days for the following metrics:

• PRI channel activity

• CAS channel activity

• FXO port activity

• FXS port activity 

The most recent day in this view is yesterday.

day of week

A forecast, derived from baseline data, that correlates growth rate to each day of the week. 

F30, F60, F90

The level where utilization is expected to be 30, 60, and 90 days from now. Calculated by 
applying linear regression to busy-hour levels over the baseline period.

FXO

Foreign Exchange Office. A VoIP gateway providing analog access to central office’s line 
termination.

FXS

Foreign Exchange Station. A VoIP gateway providing analog to a Plain Old Telephone Service 
(POTS) station.

gateway

A device that provides real-time, two-way communications between the packet-based network 
and other stations on a switched network.

growth rate

Also known as rate of increase. F30 utilization divided by average busy-hour utilization.

hourly

A view of yesterday’s performance for the following metrics:

• PRI channel activity

• CAS channel activity

• FXO port activity

• FXS port activity 

location

The place where gateways are located. Value imported by the Common Property Tables 
provisioning process. If not provisioned, field reads unassigned.

PRI 

Primary Rate Interface. An ISDN interface containing 24 or 32 channels for the 
communication of media and signaling information.
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install the upgrade, 17
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Cisco IP Telephony resources, 7
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upgrade package, 17
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configure
CallManager cluster, 31
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central server, 37
channel/port thresholds, 35
Cisco GSU data collection file, 21
cluster name, 31
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satellite server, 38
source data directory, 29
source directory, 30
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create
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cluster name, 31

customer-specific reports, 10

custom views of data or property tables, 14

D
daily, 80

data collection
schedule for Cisco GSU, 22

data collection file
create, 21
example, 22
import, 22

datapipe
Cisco GSU, 7
install the upgrade, 17
remove, 17, 27

Datapipe Manager, 14

day of week, 80

demo package, 11

Display Data Table, 73

displayed data option, 73

distributed systems, 15, 20
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E
edit
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F
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FXO, 80
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G
gateway, 80

modify thresholds, 34
selection table, 43

graphs
edit, 10
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group_manager (command), 14

group filters, 11

growth rate, 80

H
hourly, 80

I
import

Cisco GSU data collection file, 22

install
Cisco GSU datapipe, 17
datapipe, 17

installing Interface Reporting 3.0, 23, 25

integration
Cisco IP Telephony Call Detail Report Pack, 11
NNM, 9

IP Telephony Environment Monitor (ITEM), 7

L
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location, 80

M
modify

CallManager thresholds, 34
channel/port thresholds, 35
gateway thresholds, 34
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integration, 9
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OVPI resources, 7
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package

remove, 27
upgrade, 13

parameters
edit, 10
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POTS, 80

PRI, 80
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Product Manuals Search (web page), 12

R
remove

Cisco GSU datapipe, 17, 27
datapipe, 17, 27
package, 27
report pack, 27

report pack
remove, 27
upgrade, 13

reports
correlation, 65
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summary, 9, 43
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view, 26
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resources
Cisco IP Telephony, 7
OVPI, 7

resource utilization thresholds, 34

restart
OVPI Timer, 26, 27

S
satellite server

configure, 38

schedule
Cisco GSU data collection, 22

source data directory
specify, 29

source directory
change, 30

source disposition, 30

specify
source data directory, 29

stop
OVPI Timer, 27

style options for graphs, 73

summary report, 9, 43
CallManager cluster selection table, 43
CallManager selection table, 43
channel states graph, 43
DS1 selection table, 43
gateway selection table, 43
PRI channel activity graph, 43

system clocks, 38

T
tables

edit, 10

thresholds
channel/port, 35
modify CallManager, 34
modify gateway, 34
resource utilization, 34

top ten report, 9, 39

trendcopy pull commands, 37

U
upgrade

Cisco IP Telephony Statistics package, 17
package, 13
report pack, 13

upgrading Common Property Tables, 20

Use Absolute Time, 71

V
view

reports, 26

view in new frame, 72
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