
HP OpenView
JMX Metric Builder Plug-in for Eclipse
For HP-UX and Solaris OpenView Operations Management Servers

Software Version: A.01.00 
Getting Started
December 2005
 



Legal Notices

Warranty

Hewlett-Packard makes no warranty of any kind with regard to this document, including, but not limited to, 
the implied warranties of merchantability and fitness for a particular purpose. Hewlett-Packard shall not be 
held liable for errors contained herein or direct, indirect, special, incidental or consequential damages in 
connection with the furnishing, performance, or use of this material. 

A copy of the specific warranty terms applicable to your Hewlett-Packard product can be obtained from your 
local Sales and Service Office.

Restricted Rights Legend

Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in subparagraph 
(c)(1)(ii) of the Rights in Technical Data and Computer Software clause in DFARS 252.227-7013.

Hewlett-Packard Company
United States of America

Rights for non-DOD U.S. Government Departments and Agencies are as set forth in FAR 52.227-19(c)(1,2).

Copyright Notices

© Copyright 2005 Hewlett-Packard Development Company, L.P.

No part of this document may be copied, reproduced, or translated into another language without the prior 
written consent of Hewlett-Packard Company. The information contained in this material is subject to change 
without notice.

Trademark Notices

UNIX® is a registered trademark of The Open Group.
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Support

Please visit the HP OpenView support web site at:

http://www.hp.com/managementsoftware/support 

This web site provides contact information and details about the products, services, and support that HP 
OpenView offers.

HP OpenView online software support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As a valuable 
support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit enhancement requests online

• Download software patches

• Submit and track progress on support cases

• Manage a support contract

• Look up HP support contacts

• Review information about available services

• Enter discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and log in. Many also require a 
support contract.

To find more information about access levels, go to:

http://www.hp.com/managementsoftware/access_level 

To register for an HP Passport ID, go to: 

http://www.managementsoftware.hp.com/passport-registration.html 
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1 JMB Plug-in for Eclipse
The HP OpenView JMX Metric Builder (JMB) is an application integrated with HP 
OpenView Operations (OVO) used to create user defined metrics (UDMs) that gather data 
from application MBeans registered in a JMX-compliant MBean server. The UDMs generate 
data about your applications that can be collected and monitored by OVO. Use the JMB to:

• edit a UDM file by mapping MBeans to UDMs 

• validate metric IDs 

• create UDMs that conform to the metric definitions DTD 

• browse MBeans registered in an MBean server 

• generate templates (OVO for UNIX only)

The HP OpenView JMX Metric Builder Plug-in for Eclipse (JMB Plug-in for Eclipse) is 
the same application as the JMB but is run independently from the OVO environment (the 
JMB Plug-in for Eclipse is launched from Eclipse, not OVO). 

Like the JMB, the JMB Plug-in for Eclipse is used to create UDMs that gather data from 
application MBeans. In addition, the JMB Plug-in for Eclipse includes the following features:

• Start the JMB from Eclipse

• Test UDMs

MBean data is obtained directly from the application server (currently, the JMB Plug-in for 
Eclipse only supports the BEA WebLogic Application Server). This allows a developer to 
create UDMs and templates outside of the OVO environment. UDMs and templates generated 
by the JMB Plug-in for Eclipse must be copied to the OVO management server and deployed 
to managed nodes.

This guide contains basic installation and configuration information. To successfully use the 
JMB Plug-in for Eclipse, you should be familiar with the metrics definitions DTD, have an 
intermediate to advanced understanding of JMX, and should be familiar with Eclipse. 

For more information about the metrics definitions DTD, refer to the OVO online help, JMX 
Metric Builder topic (if you are running OVO for Windows) or the online User Defined Metrics 
User Guide (if you are running OVO for UNIX).
 7
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2 Installation
p 

 

System and Software Requirements

This section lists software requirements to run the JMB Plug-in Plug-in for Eclipse. Refer to 
Installation on page 10 for information about installing the software.

Minimum Requirements

To run the JMB Plug-in for Eclipse, the following software is required (if the download 
hyperlink spans more than a single line, usable hyperlinks appear in the row below the 
unusable link; click on the usable link to open the download page):  

Software Version Available From

OS HP-UX 11.11, 
11.23 (PA-RISC) 
Windows 2000, XP

N/A

JDK
(WebLogic 8.1)

1.4.2_07 or later Windows http://java.sun.com/j2se/1.4.2/download.html 

HP-UX http://www.hp.com/go/java

JDK 
(WebLogic 9)

5.0 or later Windows http://java.sun.com/j2se/1.5.0/download.html

HP-UX http://www.hp.com/go/java (HP-UX)

Eclipse SDK 3.1.0 Windows http://download.eclipse.org/eclipse/downloads/
drops/R-3.1-200506271435/
download.php?dropFile=eclipse-SDK-3.1-win32.zip

HP-UX http://download.eclipse.org/eclipse/downloads/drops/
R-3.1-200506271435/
download.php?dropFile=eclipse-SDK-3.1-hpux-motif.zip

Windows:
http://download.eclipse.org/eclipse/downloads/drops/R-3.1-200506271435/download.php?dropFile=eclipse-SDK-3.1-win32.zip 

HP-UX:
http://download.eclipse.org/eclipse/downloads/drops/R-3.1-200506271435/download.php?dropFile=eclipse-SDK-3.1-hpux-motif.zi

BEA WebLogic 
Application Server

8.1 SP4 or later http://commerce.bea.com/index.jsp

HP OpenView 
Smart Plug-in for 
BEA WebLogic 
Server

A.04.00 or higher Application SPI CD. You must also install the WASSPI-UDM-Bldr 
software bundle. Refer to the HP OpenView Smart Plug-in User Defined
Metrics User Guide for more information about installing this bundle.
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Supported Software

The JMB Plug-in for Eclipse is used with the following software to create UDMs:

Installation

1 Install the minimum required software: 

HP OpenView 
JMB Plug-in for 
Eclipse

1.0 Windows /opt/OV/jmb/JMB-Developer/JMBPlugin-Windows.zip 
on the OVO management server (after installing the 
WASSPI-UDM-Bldr software bundle) or
http://devresource.hp.com/drc/resources/
jmbdwnld/index.jsp

HP-UX /opt/OV/jmb/JMB-Developer/JMBPlugin-HPUX.zip on 
the OVO management server (after installing the 
WASSPI-UDM-Bldr software bundle) or 
http://devresource.hp.com/drc/resources/
jmbdwnld/index.jsp

Windows and HP-UX:
http://devresource.hp.com/drc/resources/jmbdwnld/index.jsp

Software Version Available From

Software Version

HP OpenView Operations for UNIX 7.x, 8.0, 8.1

HP OpenView Smart Plug-in for BEA WebLogic Server A.04.00 or higher

BEA WebLogic Application Server 8.1 SP4 or later

Software/File Name Where to Extract\Install

JDK <JDK-home>

Eclipse SDK
eclipse-SDK-3.1-win32.zip (Windows)
eclipse-SDK-3.1-hpux-motif.zip (HP-UX)

<eclipse-home>

BEA WebLogic Application Server <weblogic-home>

HP OpenView JMB Plug-in for Eclipse 
JMBPlugin-Windows.zip (Windows)
JMBPlugin-HPUX.zip (HP-UX)

<JMB-home>

HP OpenView JMB Plug-ins 
<JMB-home>/JMBPlugin.zip (Windows)
<JMB-home>/JMBPlugin.tar (HP-UX)

<eclipse-home>/plugins
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2 Copy the BEA WebLogic server jar file (<weblogic-home>/weblogic##/server/lib/
weblogic.jar) to 
<eclipse-home>/plugins/com.hp.openview.jmb.integ.bin_1.0.0/lib/
ovojmxtool/plugins/com.hp.ovojmxtool_1.0.0/lib/.

Uninstallation

To uninstall the JMB Plug-in for Eclipse, remove the following directories:

• <eclipse-home>/plugins/com.hp.openviw.jmb.integ.bin_1.0.0

• <eclipse-home>/plugins/com.hp.openviw.jmb.integ.ui_1.0.0

• <eclipse-home>/plugins/com.hp.ovojmxtool-doc_1.0.0

To uninstall other software you may have installed with the JMB Plug-in for Eclipse, refer to 
uninstallation information provided with that software.
Installation 11



12 Chapter 2



3 Configuration
JMB Plug-in for Eclipse on HP-UX

If you are running the JMB Plug-in for Eclipse on HP-UX, set the JAVA_HOME environment 
variable:

JAVA_HOME = <JDK-home>
export JAVA_HOME

Go to Start the JMB Plug-in for Eclipse on page 13 for information on how to start the JMB 
Plug-in for Eclipse.

Start the JMB Plug-in for Eclipse

To start the JMB Plug-in for Eclipse,

1 Launch Eclipse. Double-click <eclipse-home>/eclipse/eclipse.exe.

1 Select File → New → Other.

2 Open Java.

3 Select Java Project.

4 Click Next.

5 Enter a name for the project.

6 Click Finish.

7 In the Package Explorer, highlight the project you just created.

8 Select Management → User Defined Metrics.

Connect to an MBean Server

To specify the MBean server from which to obtain MBean data, do the following:

1 Configure the MBean server in the JMB Plug-in for Eclipse:

a Start the JMB Plug-in for Eclipse. Refer to Start the JMB Plug-in for Eclipse on 
page 13 for more information.

b Select Window → Preferences.

c From the Preferences window, open JMX Metric Builder.
 13



d Highlight Agent Information.

e Click Add.
14 Chapter 3



f Enter the following information for each field: 

The configuration information is updated in the <eclipse-home>/plugins/
com.hp.openview.jmb.integ.bin_1.0.0/lib/ovojmxtool/plugins/
com.hp.ovojmxtool_1.0.0/extapps/StandAloneWebLogicCollector/conf/
SiteConfig file (the password is encrypted in this file).

g Click OK.

h Click OK.

2 Restart the JMB Plug-in for Eclipse. 

a Select File → Exit. 

b Select Management → User Defined Metrics. 

Field
Configuration 
Property Value to Enter

T3 - Weblogic or OVO N/A T3 - Weblogic

Name ALIAS Unique name for the WebLogic Server

Url ADDRESS The domain name or IP address where the 
WebLogic Server is listening

Port PORT The port on which the WebLogic Server is 
listening

Login checkbox N/A Select to enter the WebLogic Server login and 
password

User Name LOGIN The WebLogic administration user configured 
at installation or other user with appropriate 
permissions

Password PASSWORD The password for the user entered above
Configuration 15
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4 Integration with OVO
The following lists all the steps needed to successfully collect metrics from UDMs when using 
the JMB Plug-in for Eclipse. Unless otherwise noted, a detailed description of the steps 
performed by the OVO administrator can be found in the HP OpenView Smart Plug-in User 
Defined Metrics User Guide. If you have already installed and configured the JMB Plug-in for 
Eclipse software, start at step 9.

On the OVO management server (completed by the OVO administrator):

1 Install the WLS-SPI.

2 Install the WASSPI-UDM-Bldr software bundle.

3 Install the JMX connector (optional).

4 Register custom MBeans (optional).

5 Configure the MBean server environment.

6 Complete additional configuration tasks.

On the development system(s) (completed by the system administrator or developer):

7 Install the JMB Plug-in for Eclipse and other required software. See Installation on 
page 9.

8 Configure the JMB Plug-in for Eclipse. See Configuration on page 13.

9 Develop and test UDMs. Refer to the online help and the HP OpenView Smart Plug-in 
User Defined Metrics User Guide for more information.

10 Generate templates. Select Run → Policy Generation. Refer to the online help for more 
information.

On the OVO management server (completed by the OVO administrator):

11 Copy the generated UDM and template files from the development system.

12 Deploy UDMs. 

13 Create a UDM template group or assign the new template(s) to a template group 
(optional).

14 Distribute templates.

15 Disable/re-enable graphing.

On the OVO managed node (completed by the OVO or system administrator):

16 Verify that the /var/opt/OV/bin/instrumentation directory is defined in the PATH 
environment variable. If not, add it:

export PATH=$PATH:/var/opt/OV/bin/instrumentation
 17



17 Verify the UDMs. Test one or more of the UDMs by running the following command:

wasspi_wls_perl -S wasspi_wls_ca -m <metric_id_number> -x print=on

If no data is returned, verify that you are using registered, JMX-compliant MBeans in 
your UDM. MBean data is collected differently on the OVO management server and the 
development system (an MBean that appears in the JMB Plug-in for Eclipse may not be 
available on the OVO management server).
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5 Troubleshooting
Error Message

Log Files

Known Problem

Problem: When testing a metric that uses multiple MBeans or formulas, the Test History 
displays the attribute/formula from the first entry in the MBeans or Calculations table for all 
results.

Message

The requested operation was not completed on “localagent” because a copy of the 
weblogic.jar file has not been placed in the <eclipse-home>/plugins/
com.hp.openview.jmb.integ.bin_1.0.0/lib/ovojmxtool/plugins/
com.hp.ovojmxtool_1.0.0/lib/ directory.

Action

Copy <weblogic-home>/weblogic81/server/lib/weblogic.jar to 
<eclipse-home>/plugins/com.hp.openview.jmb.integ.bin_1.0.0/
lib/ovojmxtool/plugins/com.hp.ovojmxtool_1.0.0/lib/.

Log File Name What is Logged Directory

SpiEngineUserLog0.log Policy/Template 
generation errors

<eclipse-home>/plugins/com.hp.openview/
jmb.integ.bin_1.0.0/lib/ovojmxtool/plugins/
com.hp.ovojmxtool_1.0.0/extapps/
SpiGeneratorEngine/

j2eeErrorlog Metric testing 
errors

<eclipse-home>/plugins/com.hp.openview/
jmb.integ.bin_1.0.0/lib/ovojmxtool/plugins/
com.hp.ovojmxtool_1.0.0/extapps/
StandAloneWebLogicCollector/log/

.log All other errors 
related to the 
JMB

<project-folder>/UDM/.metadata/
 19
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