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PEREGRINE
ServiceCenter 6.1.1.0 Release Notes
These Release Notes contain an overview of new features, describe known 
issues with this release, and provide instructions to access information from 
other sources, such as the Peregrine Customer Support Web site. Before you 
begin, ensure that you have a valid Customer Support login ID and password.

The media shipped with this release contains a complete installation of the 
product and documentation. See the packing list included with your shipment 
for a complete description of the media provided.

About this release
This release provides improvements to the web client and localized French, 
German, Italian, Japanese, and Spanish versions of the ServiceCenter® 6.1 
software and documentation. See the ServiceCenter 6.1 Language Pack 
Installation Guide for information and instructions on how to install localized 
versions of ServiceCenter. 

Key features of ServiceCenter
ServiceCenter is a suite of service management applications that enables an 
organization to automate and optimize service support and delivery processes 
through a single point of contact, improving the availability and productivity of 
the infrastructure and reducing costs. 
ServiceCenter 6.1.1.0 Release Notes | 5
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ServiceCenter enables IT organizations to manage Calls, Incidents, Change 
Requests, Problems, and Service Level Agreements. ServiceCenter makes it 
possible to improve delivery of services and availability of technology and 
infrastructure assets with predefined processes for managing configuration 
items. 

ServiceCenter supports the ITIL best practice standards, and can be tailored to 
meet your organization's specific needs. With support for Web Services, as well 
as an extensive set of prebuilt integrations, ServiceCenter can be integrated to 
virtually any third-party enterprise application.

Compatibility Matrix
The Compatibility Matrix lists supported versions of operating systems, 
browsers, Peregrine products, and other compatibility and support information. 

To access the Compatibility Matrix

1 Use a browser to navigate to the Peregrine Customer Support Web site at 
http://support.peregrine.com.

2 Log on with your Customer ID and password.

3 From the left navigation pane, click Product Information > Product 
Family > ServiceCenter > Compatibility matrices > Product Version.

Software Change Requests
In addition to the ServiceCenter 6.1 features, ServiceCenter 6.1.1.0 includes 
resolutions for many Software Change Requests (SCRs). 

To view the SCRs included in this release

1 Use a browser to navigate to the Peregrine Customer Support Web site at 
http://support.peregrine.com.

2 Log on with your Customer ID and password.
6 | ServiceCenter 6.1.1.0 Release Notes 
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3 From the left navigation pane, click Product Information > Product 
Family > ServiceCenter > View SCRs.

4 Filter the query by selecting the version, category, or subcategory for SCRs 
as search criteria.

The Web site displays a report that matches your criteria. You can view the 
report or click Create Excel Report to download a spreadsheet with the 
contents matching your search criteria.

KnowledgeBase
The KnowledgeBase contains articles with related information, tips, and 
workarounds for this release.

To search the KnowledgeBase

1 Use a browser to navigate to the Peregrine Customer Support Web site at 
http://support.peregrine.com.

2 Log on with your Customer ID and password. 

3 From the left navigation pane, click Advanced Search.

4 Type one or more keywords to filter the search, then choose a product from 
the drop-down list. 

5 Click Go. 

Known issues
The following table describes some ServiceCenter 6.1.1.0 known issues. To 
search the KnowledgeBase for more information on these known issues, type 
the Known Issue Document ID (enclosed in quotation marks) as the search 
criteria.
KnowledgeBase | 7
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Document 
ID

Known issue Workaround

498321 Some multi-byte characters do not display 
properly in multi-line text boxes in the 
Windows client.

Set the font manually to one that supports 
Japanese characters like MS Mincho.
1 Go into Window > Preferences > 

ServiceCenter > Appearance.
2 Click Change.
3 Select MS Mincho in the font selection 

screen.
4 Save the preferences.
5 Restart your client.

506427 The documentation currently states that the 
sqljoinsok parameter is obsolete, and that 
ServiceCenter 6.1 servers no longer support 
DB2 on 0S/390 platforms. Neither is the 
case. The sqljoinsok parameter is working in 
the ServiceCenter 6.1 releases, and DB2 
Universal is supported for OS/390.

The documentation will be corrected in an 
upcoming documentation release.

506462 The main menu of localized versions of 
ServiceCenter displays word the "Top" in 
English. The other terms are in the localized 
language. 

This problem will be corrected in an 
upcoming release of ServiceCenter. 

506517 When you attempt to push a single table 
with SQL Server 2000, and then select 
Create Tables as the conversion option, an 
erroneous message is returned stating that 
the operation completed successfully. The 
log information, such as the sqldebug log, 
also erroneously indicates that the action 
was successful.
The table is not created on SQL Server 2000. 
After refreshing the SQL Server 2000 
database to confirm that the tables were 
properly populated, Enterprise Manager 
hangs.
This problem is encountered only in 
Windows Server 2003 and SQL Server 2000 
environments. Identical operations using 
Windows to DB2 AIX to DB2 function as 
expected.

Use the following steps to complete the 
action successfully:
1 Shut down the ServiceCenter client and 

Enterprise Manager.
2 Restart Enterprise Manager.
3 Confirm that the tables were not 

created.
4 Perform the action again selecting  

Move Data instead of Create Table.
5 The table create is successful and the 

data is moved.
8 | ServiceCenter 6.1.1.0 Release Notes 
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510022 If a Self-Service ticketing user clicks Submit 
on the Password Change dialog box, the 
Navigator Tree (with the logout function) is 
suppressed.

There are two potential workarounds:
1 If you click Submit, you can continue to 

work without the Navigator by using the 
menu. You must kill your browser 
session by using the upper-right- 
corner-X when you are finished.

2 On the password change screen, after 
you change your password, press Enter 
rather than clicking Submit. You will 
change your password, but you will get 
the Navigator tree and be able to work 
normally in Self-Service ticketing mode.

510070 When using the web client to add a new 
Configuration Item (CI), you can not exit the 
new record and must kill the browser 
session.

After you create the CI by entering the 
information and clicking Add, you must kill 
your browser session to get out of the 
newly-created CI record.

540386 ServiceCenter 6.1.1 Client update utility 
does not support automated updates to 
6.1.2 for localized clients. Automated 
updates only work on the English core 
components of the client.

To update a localized client, you can 
perform the update manually.
1 Open the Help menu and select  

Check for Updates. 
2 Select Search for new features to install 

and click Next. 
3 Open ServiceCenter discovery site, 

select all components and click Next. 
4 Click Select All and click Next. 
5 Accept the License Agreement and click 

Next. 
6 Select the installation location and click 

Finish.

540493 ServiceCenter 6.1.1.0 recognizes and tries to 
execute input conversion RAD routines for 
text boxes, however, input conversion for 
numeric fields does not work.
ServiceCenter 6.1.1 does not support input 
RAD routines that use input masks or output 
RAD routines. The only widgets supporting 
these input RAD routines are text boxes. If 
the client dynamically substitutes a 
different widget for the text box (as 
happens with date/time fields), the input 
RAD routines will not work.

There is no workaround available at this 
time.

Document 
ID

Known issue Workaround
KnowledgeBase | 9
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543268 You cannot re-configure the Help Server on 
a Japanese system. The initial installation 
does display the configuration screens for 
the Help Server and you can make an initial 
configuration. However, if you select 
Configure Help Server from the Start Menu 
or run configure.bat from a command 
prompt, after the initial installation, no 
screens display and you cannot 
re-configure the Help Server.

Delete or rename 
helpserverconfig_ja.xml. You can 
then re-configure in English.

544986 Some implementations of string related 
functions result in unanticipated results. 
The issue is based on the fact that 
ServiceCenter functions, including lng, 
index, and string functions, such as stradj, 
strchrcp, strclpl, strclpr, strcpy, strdel, strins, 
strpadl, strpadr, strrep, strtrml, strtrmr, are 
byte rather than character oriented. Thus, a 
function you believe will act on the third 
character in a string actually acts on the 
third byte. For example, 
index("c","Bücher") returns 4 instead 
of 3. This issue affects all multi-byte versions 
of ServiceCenter, including Japanese 
versions back to 1996 and all versions of 
ServiceCenter 6 and above.

You can use the rtecall function mbindex for 
a character version of index. Similarly, you 
can use the function substrchars() for a 
character version of substr(). Refer to the 
Knowledge Article for workarounds for the 
other functions. 

545012 The Load Manager may have a GP fault 
under an extremely heavy load of resource 
locks/unlocks.

There is no workaround available at this 
time.

Document 
ID

Known issue Workaround
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Documentation
ServiceCenter Help is the primary documentation. Field Help is also available. 
Administrators can change Field Help and ServiceCenter Help by following the 
customization instructions in the Help system.

To access Field Help

1 Place your cursor in the text box for a specific field.

2 Click Help > Help on Field, or 

For the Windows client, press Ctrl + H.

For the Web client, press F1.

To access Help from the client

1 Launch the ServiceCenter client.

2 Click Help > Contents.

Note: You do not need to connect to the server to view ServiceCenter Help.

To access ServiceCenter Help from a server

1 Install a Help server by following the instructions in the ServiceCenter 6.1.1.0 
Installation Guide.

2 Start any supported Web browser.

3 Type the connection address of the Help server.

Related documentation
Peregrine Systems provides electronic versions of related documents in your 
installation package. 

Peregrine Systems also supplies electronic versions of all documents on the 
Customer Support Web site.
Documentation | 11
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Upgrade Information
A complete upgrade to ServiceCenter 6.1.1.0 requires the installation of a 
 6.1.1.0 client and server, and the SC61 applications. For more information, view 
ServiceCenter Upgrade Center on the Peregrine Customer Support Web site, 
and refer to the ServiceCenter upgrade documentation. 

The ServiceCenter Server Upgrade Guide contains information about upgrading 
the ServiceCenter server, including:

Running the 6.1.1.0 client and server with SC61 applications.

Converting existing data to UTF-8 (for pre-ServiceCenter 6 customers)

Combining favorites and inboxes

Converting existing attachments to a new format

The ServiceCenter  Application Upgrade Guide contains information about 
upgrading SC4 and later applications to SC61. 

The ServiceCenter Language Pack Installation Guide contains information about 
installing localized versions of ServiceCenter. 

Unicode (UTF-8) support
UTF-8 is part of the Unicode standard, which enables you to encode text in 
practically any script and language. ServiceCenter 6.1.1.0 supports UTF-8 as an 
encoding method for new or existing data. It can support multiple languages 
that adhere to the Unicode standard on the same server.

Third-party products
Peregrine Systems products often integrate third-party products that use open 
source standards. The Peregrine Customer Support Web site contains specific 
statements about the support of third-party products and open source 
standards.
12 | ServiceCenter 6.1.1.0 Release Notes 
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Need more information?
The Peregrine Systems Customer Support Web site has resource information 
about third-party products, the Compatibility Matrix, documentation, and 
customer support contact information. 

Start your browser and navigate to http://support.peregrine.com. You need your 
Customer ID and password to log on.

Education services
For a complete listing of Peregrine training courses, see the Peregrine Education 
Service Web site, http://www.peregrine.com/customers/value-path/education/.

Corporate headquarters
See the Peregrine Systems corporate Web site for the location of offices, 
information about products, news, and contact information. Start your browser 
and navigate to http://www.peregrine.com.
Need more information? | 13
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