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CHAPTER
1 I
ntroduction
Welcome to the Network Data Analysis Guide. 

Enterprise DiscoveryTM collects a lot of different data from your network devices. 
This guide will help you understand how to read the data collected by 
Enterprise Discovery’s discovery features. 

For information on data collected by Enterprise Discovery scanners, refer to the 
Scan Data Analysis Guide. 

This guide provides information on the following topics:

Finding devices

Understanding the Health Panel and Alarms Viewer

Understanding the Events Browser

Exporting Data

Deleting data from the Enterprise Discovery database

Understanding the Device Manager

Understanding the Port Manager
Introduction | 7
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CHAPTER
2 F
inding your Network Devices
The Find command lets you locate and examine any device on the network. 
There are many ways to search for a particular device, based on its DNS name, IP 
address, MAC address, and so on. 

There is also an Aggregate Find feature that will let you search for devices across 
all of your aggregated Enterprise Discovery servers. For more information, see 
Aggregate Find on page 13.

Finding devices
To use the Find tool:

1 Open the Find tool:

a On the Home page click Find.

OR

b From the Health Panel, Alarms Viewer, or Events Browser, click Tools > 
Find (or Ctrl-F).

2 By default, you can use the Easy Find feature (go to Step 5). If you want to 
do a more advanced find, continue with the next step in this procedure. 

3 In the first pull-down list, select the device data you want to search on (for 
example, “asset tag”).
Finding your Network Devices | 9
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4 In the second pull-down list, select a match mode (for example, 
“containing”).

Note: There are different match modes available for different types of device 
data. 

5 Enter a match value.

Note: When using Easy Find, enter the first letters of a title or the first numbers 
of an address to find multiple devices in the Enterprise Discovery 
database.

6 Press Enter. 

Enterprise Discovery searches for the device. The results of the search appear in 
table format, and you can select the device you want to open. You can 
double-click (or right-click) to open a Device Manager or Port Manager.

Select the 
device data

Select a match 
mode
10 | Finding your Network Devices 
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Easy Find
When you enter text into the Find box, Enterprise Discovery searches the 
network in the following order. 

Note: If there is no result at one stage, Enterprise Discovery will try the next.

Example: Once an IP address has been found, Enterprise Discovery does not 
search domain names and device titles.

Important: Multiple results are based only on the device title. Example: If you 
enter “192.168.2.”, you will not find all devices 
192.168.2.0–192.168.2.255. You will only find devices with 
“192.168.2.” in the title. If the device with IP address 198.168.2.55 
takes it title from its domain name, that device will not be found. 

Find Method Explanation

“localhost” or “nmc” These are two shortcuts for finding the Enterprise Discovery 
server. 

MAC address Enterprise Discovery will try to search based on the known 
MAC address. 
Note:  To find a specific device, you must enter its complete 

MAC address in one of these formats: 
12:AB:34:CD:56:EF or 12AB34CD56EF.

IP address Enterprise Discovery will try to search based on the known IP 
address. 
Note:  To find a specific device, you must enter its complete 

IP address. 

Domain Name Enterprise Discovery searches based on the DNS suffix as 
configured in your server DNS (done in Control Panel).

Device Title Enterprise Discovery will then search the network based on 
your device title preferences from Administration > 
System preferences > Display preferences > Device 
title preference. Only the selected titles are searched. 

Asset Tag Even if Asset Tag is not listed in your Device title preference, 
Enterprise Discovery will search for it next.

NetBIOS Name Even if NetBIOS name is not listed in your Device title 
preference, Enterprise Discovery will search for it next.
Easy Find | 11
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Advanced Find
Note: Searches are not case-sensitive.

Match Modes Notes

containing —

beginning with —

ending with —

equal to —

matching ?* Wildcard characters:

“?” can represent any single character. For 
example, “gr?y” finds “gray” and “grey.”

“*” can find multiple characters. For example, 
“E*t” finds “Ethernet.”

matching regex Matching a regular expression. 

matching address* This works only for IP address and MAC address 
searches. You must enter an entire IP or MAC address 
in these formats:

IP - 123.123.123.123

MAC - 12:AB:34:CD:56:EF

Note:  You can substitute a * for an octet in an IP 
address octet or a segment of a MAC address. 
For example: “123.*.123.123” or 
12:AB:*:CD:56:EF

Note:  For MAC addresses, you can compress the 
zeros in each segment. For example, you can 
enter “5” instead of “05” for a segment. 

Note:  If an IP or MAC address is associated with a 
port, you will see a port listed in your Find 
results. 

name prefix —

name equal to —
12 | Finding your Network Devices 
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Aggregate Find
The Aggregate Find is almost identical to the regular Find feature. The major 
difference is that there are fewer find options in the Aggregate Find. 

  Regular Find Aggregate Find

Easy Find —

Device Title

IP Address

MAC Address

Asset Tag

Domain Name

NetBIOS Name

NetBIOS Workgroup

Family

Model

Operating System

Network Function

SNMP Description

SNMP Contact

SNMP Name

SNMP Location

SNMP Serial Number

DNS Query —

NetBIOS Query —
Aggregate Find | 13
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CHAPTER
3 H
ealth Panel and Alarms Viewer
There are many ways to look at your device data with Enterprise Discovery. The 
Health Panel and the Alarms Viewer allow you to see your devices, and to 
determine the devices that currently have problems. 

Typically, a user would start with the Health Panel, which lists all the alarms 
currently on your network. To see a list of devices with these alarms, 
double-click on an alarm category in the Health Panel, and the Alarm Viewer 
opens. 

The Alarms Viewer shows all the devices on the network with current alarms. 
From the Alarms Viewer, you can double click on an alarm and open up a Device 
Manager, and from there you can investigate a problem with that device. 

Topics in this chapter include:

See a network overview with the Health Panel on page 16

Using the Aggregate Health Panel on page 18

Using the Alarms Viewer on page 19

Using the Aggregate Alarms Viewer on page 20

Saving data to a text file on page 21
Health Panel and Alarms Viewer | 15
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See a network overview with the Health Panel
The Health Panel enables you to set up, highlight, and examine conditions, 
alarms, and statistics that Enterprise Discovery has gathered about your devices.

Note: The Health Panel is automatically updated with current device 
information.

There are icons on the Health Panel to distinguish device and port alarms. The 
Health Panel is divided into sections as indicated by these icons:

The Health Panel will show you how many devices have alarms. You can drill 
down with the Alarms Viewer to see exactly which devices have the alarms. 

Note: The Aggregate Health Panel works the same way as the normal Health 
Panel, but it shows information for all the Enterprise Discovery servers in 
your network. For more information, see Using the Aggregate Alarms 
Viewer on page 20.

Category Indicator

Port Report Alarm 

Device Report Alarm 
16 | Health Panel and Alarms Viewer 
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Customizing the Alarm List
My User Alarms

You can change the appearance of the Health Panel so you see only the alarms 
in which you are interested. 

To customize the alarms shown on the Health Panel:

1 From the Health Panel, click Edit > User Preferences > Health Panel tab.

Here, you can create a list of the alarms you want to see on the Health Panel. 

2 After you have created your list, click Apply. 

3 Click OK.

Next, you must select these changes in the View menu.

4 Click View > My User Alarms Only.

Hide Inactive Alarms
You can hide the categories that currently have no alarms associated with them. 

To hide the inactive alarm categories:

Click View > Hide Inactive Alarms. 
See a network overview with the Health Panel | 17
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Using the Aggregate Health Panel
The Aggregate Health Panel looks similar to the regular Health Panel; it has all 
the same buttons and statistics. However, the Aggregate Health Panel 
combines all the statistics from all the aggregated Enterprise Discovery servers 
in your network.

You can click on the report buttons to see complete lists of all alarms in the 
entire network. If you were looking at a regular Health Panel for one server, you 
would only see alarms for a portion of your network.

Note: You can tell what Health Panel you’re looking at by the report banner. If it 
is the Aggregate Health Panel, the banner says “Aggregate Health” rather 
than “Health Panel”. A “globe” symbol also shows that you are looking at 
an Aggregator.

The statistics listed in the Aggregate Health Panel are the same as those listed in 
the regular Health Panel.

Banner says 
“Aggregate 
Health”

Globe symbol 
also indicates 
Aggregate 
Health Panel
18 | Health Panel and Alarms Viewer 
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Using the Alarms Viewer
The Alarms Viewer is an extension of the Health Panel, and shows you exactly on 
which devices and ports the alarms have occurred. 

By double-clicking on a line in the Health Panel, you will open the Alarms Viewer. 
The Alarms Viewer works with the Health Panel to show you which devices on 
your network have Critical, Major, Minor, or Info alarms. 

The status bar in the Alarms Viewer is similar to that on the Health Panel. You can 
change the displayed alarm type or priority with the pull-down lists on either 
window. Your selection will appear in the Health Panel and the Alarms Viewer. 

Note: The Alarms Viewer will show a maximum of 1000 alarms.
Using the Alarms Viewer | 19
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Using the Aggregate Alarms Viewer
The Aggregate Alarms Viewer is almost identical to the regular Alarms Viewer. 
The major difference is that the “Server” column shows which server is the 
source of the alarm data.
20 | Health Panel and Alarms Viewer 
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Saving data to a text file
You can now use the Save Table Data feature to save selected info into a tab 
separated value (.tsv) file in the following Enterprise Discovery features: 

Health Panel

Find

Alarms Viewer

Events Browser

You can save the entire contents of a window, or you can Ctrl-click to select the 
data you want to save. 

Saving data to a text file:

1 Select the table items you want to save. To select the entire table, click Edit 
> Select Table. 

2 Click File > Save Table Data.

A Save Table Data dialog appears.

Saving data to the clipboard:

1 Select the table items you want to save. To select the entire table, click Edit 
> Select Table. 

2 Click Edit > Copy.

Your selected items have been copied to the clipboard. For example, you 
can paste it into a file, or an e-mail. 
Saving data to a text file | 21
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3 Select a file name and location for the text files.

4 Click Save. 
22 | Health Panel and Alarms Viewer 



CHAPTER
4 E
vents Browser
Enterprise Discovery logs network and access events. The Events Browser can 
display up to 1,000 events at a time. 

An event occurs when:

a device or port is physically added or deleted

a device or port property is changed by a user (through the Device or Port 
Properties dialog) or by the system itself

An access event occurs when:

users access (or attempt to access) or logout of the Enterprise Discovery 
server

Note: Only admin accounts can view access events. 

For example, Enterprise Discovery can log an event if it discovers a device has 
been added to the network. The Events Browser shows you a list of events that 
occurred on devices in your network during a specified period. 

The Health Panel gives you information about the current state of your network. 
The Events Browser gives you historical information. The Health Panel can tell 
you what’s wrong now. The Events Browser shows you problems that only 
patterns over time can reveal.

Important: The Events Browser shows events for the past 45 days or up to a 
maximum of 500,000 events (whichever is less).
Events Browser | 23
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Opening the Events Browser
To open the Events Browser:

On the Home page, click the Events Browser link.

OR

From the Health Panel or Alarms Viewer, click Tools > Events Browser.

OR

From a Device Manager or Port Manager, click the Events button.

Network Events
All users can see the network events on the Events Browser. The next figure 
shows an example of what you will see if you selected All Events from the events 
pull-down list. If you select one type of event from the list, the display will 
change, and you will see only that event and columns relating to that 
event-type. 
24 | Events Browser 
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Each row in the Events Browser window contains the following columns.

Toolbar 
The following diagram of the Events Browser toolbar shows all the methods of 
changing the event list. You can use the different buttons and text boxes to view 
the events in which you are most interested.

Data Explanation

Time The time the event was generated.

Device Priority —

Device type small device icon

Device device titlea 

a If no device title can be determined, the Events Browser title column 
is blank. This depends on the Device Title Preferences as set in Ad-
ministration > System preferences > Display preferences.

Port port number

State alarm icon

Attribute For more information on the attributes, see the 
Reference Guide.

Value For more information on the values, see the 
Reference Guide.

Event Category 
Pull-down list

Events Time 
Frame

Recent device listPriority

NewerOlder Maximum number of 
events to find

Open Device 
Manager

Refresh
Find a 
device

Open Port Manager

Show Additional Info
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Event Category Pull-down List
Selects the category of events for display so that you can focus on a specific 
event type.

Priority
Selects the priority of devices that you want to see.

Recent Device list
This is a list of recently seen devices. You can toggle between these devices to 
see the events on each device. 

A device will appear on this list by being selected on Find, the Alarms Viewer or 
the Events Browser.

Find Device
By clicking the “Find” button, you can find a single device and see only the 
events on that device. 

Refresh
Refreshes the events shown.

Older
Updates the window with earlier events, relative to currently displayed events.

Limits
45 days ago (or 500,000 events, whichever is less)

Events Time Frame
This pull-down list lets you select older events from a particular time.

Limits
Now | 1 hour ago | 2 hours ago | 4 hours ago | 8 hours ago | 16 hours ago | 1 day 
ago | 2 days ago | 4 days ago | 1 week ago | 2 weeks ago | 4 weeks ago 

Default
Now
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Newer
Updates the window with later events, relative to currently displayed events.

Limits
current time

Limit
Set the maximum number of events per window.

Limits
1–1000

Default
25

Events
Shows the number of events listed in the window.

Open Device Manager
Clicking this button will open the Device Manager for the selected device.

Open Port Manager
Clicking this button will open the Port Manager for the selected port.

The Aggregate Events Browser
The Aggregate Events Browser is almost identical to the regular Events Browser. 
The major difference is that the “Server” column shows which server is the 
source of the event data. 

By default, the Aggregator updates events hourly. Due to the time lag, events 
may not be completely up to date.

If aggregation is turned on, but no Aggregators have been set up, the aggregate 
Events Browser will look very much like the regular Events Browser, except for 
the time delay.
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CHAPTER
5 U
nderstanding the Device Manager
The Device Manager provides you with detailed information about a device, in 
several panels.

To open the Device Manager:

From Open by...

Health Panel, Alarms Viewer, 
Events Browser

Click Tools > Find (Ctrl - F). Enter a device 
address or title, then click Find. 

Alarms Viewer, Events Browser Double-click on a table row, or right-click on the 
device icon, title, or IP address.

Find Enter a device address or title, then click Find.

Reports, Status, Manager panels Click a hyperlinked device title
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Toolbar
This table shows the availability of buttons in the Device Manager toolbar.

Important: Many of the panels in the Device Manager feature data in table 
form. Not all tables will look the same for all devices, because the 
tables will only show data that is available for that device.   

Icon Button name No IP 
address

Not in 
database

Unknown Demo or IT 
Employee 
user

Configuration

Reports —

Diagnosis

  Buttons on the Diagnosis Panel

 Diagnostic 
Information

—

 Agent Deployment 
Log

— —

 Scanner Deployment 
Log

— —

 IP Ping —

 Traceroute —

 SNMP Ping —

 Agent Ping — —

 DNS Query —

Ports —
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Events —

      

View Scan Data — —

Web —

Telnet —

      

Update Model 
[Administrator or IT 
Manager]

— —

Device Visibility 
[Administrator or IT 
Manager]

— — —

Properties

      

Refresh

Print

Close

Icon Button name No IP 
address

Not in 
database

Unknown Demo or IT 
Employee 
user
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Configuration
Identifies a device and presents an overview of the device’s identity and status.

Note: This panel is blank if the device is not in the Enterprise Discovery 
database.

This panel is divided into the following principal sections:

Heading

Identity table (real devices only)

Device structure (Serial number and description, disk, CPU, memory)

Address table (real devices only)

Heading
The heading also appears in the State, Reports, and Diagnosis panels (when 
available).

Element Notes Type

Icon for a complete list, see Help > Classifications > 
Device Types/Package Types

all

Descriptive prefix for example, “SNMP-managed device”  

Device type for a complete list, see Help > Device Types all

Device tag see the Configuration and Customization 
Guide.

real

No. of ports the number Enterprise Discovery uses for the 
port may not match the physical port

all

Object title first title available; see Terms and Concepts in the 
Reference Guide. 

all

Address IP address; does not appear if identical to object 
title

real

Priority see Terms and Concepts in the Reference Guide. all
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Identity
The information in this table can come from these sources: the Enterprise 
Discovery Rulebase, the SNMP MIB of the object, and the data included in a scan 
file. 

The Rulebase determines the device’s operating system, application, device 
family, and model. It determines as many of these as are available.

Some of the information collected from the SNMP MIB has been set by the 
device manufacturer; other information can be customized.

More elements of identity appear for the Enterprise Discovery server than for 
any other device.

Note: All these elements are optional. 

Data Example Creator Administrator or IT 
Manager

UNSPSC Computer Servers Rulebase —

Family Cisco 2600 Series Modular 
Access Routers

Rulebase —

Family current 
manufacturer

Cisco Systems Inc Rulebase —

Model Cisco 2621XM Modular 
Access router

Rulebase —

Model current 
manufacturer

Cisco Systems Inc Rulebase —

Model historical 
manufacturera

Cisco Systems Inc Rulebase —

Operating system Cisco IOS Version 12.2 (8) 
T5

Rulebase —

Operating system current 
manufacturer

Cisco Systems Inc Rulebase —

Operating system 
historical manufacturer

Cisco Systems Inc Rulebase —

Network Function — Rulebase —

Network Function 
current manufacturer

— Rulebase —
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Network Function 
historical manufacturer

— Rulebase —

Operating system Linux Enterprise Discovery —

Service pack — Enterprise Discovery —

NetBIOS name (network) DUPONT device owner —

NetBIOS workgroup MARKETING device owner —

rulebase extra info — Enterprise Discovery 
Rulebase

—

Device-specific title — scripts —

System OID .1.3.6.1.4.1.295.5.1.1.2 manufacturer —

System OID manufacturer PlainTree Systems Inc Rulebase —

System description Ethernet Switch manufacturer —

System contact test@example.com device owner set link

System name ws1216-2 device owner set link

System location Server Room device owner set link

Read community string public device owner view

Write community string n/a device owner view

Asset tag 78LL996 Scanner —

BIOS asset tag — Scanner —

BIOS product name eserver xSeries 330 
-[867441X]-

Scanner —

BIOS product 
manufacturer

IBM Scanner —

BIOS serial number 78LL996 Scanner —

BIOS chassis — Scanner —

CPU Pentium III 1133 MHz 
(Genuine Intel)

Scanner —

NetBIOS name (scan)b, c DUPONT device owner —

Last name DUPONT Scanner —

First name MARIE Scanner —

Data Example Creator Administrator or IT 
Manager
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Community Strings
An Admin or IT Manager user will also see a read and a write community string 
for a device. These values are taken from the list of community strings; however:

strings from the list appear here only if they are valid.

only a single valid string appears here even if the list has multiple valid 
strings for this device.

the read string that appears here is the string that Enterprise Discovery is 
currently using to poll the device.

Device Structure
Provides information on the serial number of the chassis and modules in a 
device. You will see the following information about each module:

Type (backplane, container, misc, other, powerSupply, stack, chassis, fan, 
module, port, sensor, CD, disk, cpu, ram, tray, toner, unknown)

Name

Hardware

Firmware

Software

SerialNumber

Memory (MB) 1024 Scanner —

Windows/NIS domain MARKETING Scanner —

a Appears only when different from the current manufacturer.

b On Windows workstations, frequently the same as the system name.

c NetBIOS data is blank unless the device has an IP address.

Data Example Creator Administrator or IT 
Manager
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Mount Point Capacity

Description

Device Structure example:

Address
Provides information about the IP addresses and/or MAC addresses of a device’s 
ports. The information comes from the Network Explorer or from scan file data.

This table has hyperlinks for all the ports with addresses. If a port does not have 
an address, it does not appear in the list. To open a Port Manager, click a port 
hyperlink. Each table row contains either:

a MAC address, an OUI abbreviation (if known), and a manufacturer (if 
known)

an IP address, a netmask (if known), and a domain name (if known)
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A special port of “Device” is used:

for the IP or MAC address that Enterprise Discovery identifies as the primary 
IP or MAC address for the device

when Enterprise Discovery does not know which port an IP or MAC address 
is associated with

The address table is particularly useful:

When the device is

a router

a device with multiple IP addresses and domain name aliases (such as a 
web server)

When you want to know a device’s domain name (and domain name is not 
included in the list of Device Title Preferences)

VLANs
VLANs are software-defined broadcast domains, created by your System 
Administrator at the switch. If your device has any VLANs configured, you will 
see them in the Device Manager. 

VLAN example:

Data Notes

Port index port number and description

MAC/IP address —

OUI/Netmask netmask in octet notation

Manufacturer/Domain name usually hyperlinked to an external web 
site
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Reports
Displays current values for report (Adds, Deletes, Changes) and summary 
historical data. 

This panel is not available if the object is not in the Enterprise Discovery 
database.

State
Displays ‘report’ data like adds, deletes, and changes. Also displays notifications 
if any of these are in an alarm state (info, minor, major, critical).

If there are any exceptions for the device, they are noted in this table. For a list 
of exceptions in your network devices, see the Health Panel and Alarms Viewer. 
For a complete listing of Enterprise Discovery exceptions, see Help > 
Classifications > Exceptions.

Note: Exceptions cannot always be reported for a device. 

Data Notes

Report name Exceptions, Device Adds, Device Deletes, Device Changes

State OK, Info, Minor, Major, Critical

Value For exceptions:

description

effect

action
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Diagnosis
Displays information about the current state of the device that can be helpful in 
diagnosing problems. Has buttons that give you access to diagnostic tools. 
Opens with a configuration panel. 

Diagnostic Information
Beneath the heading, this panel is divided into these main sections:

Main Diagnosis

Network Configuration

Property Assignment

Main Diagnosis
The main table indicates the data flow for this device—when the device was first 
and most recently seen by various parts of Enterprise Discovery—plus the 
current values for several parameters.
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Data Output Notes

First discovered elapsed timea / absolute date & 
time

Reset if database is cleared.

Scanner model last updated elapsed time / absolute date & 
time

—

Last replied to ICMP elapsed time / absolute date & 
time

in ping by Enterprise Discovery

Device last modeled as a 
managed device

elapsed time / absolute date & 
time

the last time the model changed; 
determines whether or not the 
model has been updated for this 
device

Device last modeled as an 
unmanaged device

elapsed time / absolute date & 
time

the last time a device was pinged 
for discovery; should be “n/a” or a 
time before “Model last updated”

Last deactivated or hidden elapsed time / absolute date & 
time

the last time a device was 
deactivated

Mean break diagnosis time minutes for alarms Mean break diagnosis time is 
approximate. Diagnosing a break 
may take longer, if 
communication with the device is 
unreliable.

Agent version version number (example, 
2.0.0)

—

Agent operating system name of operating system —

Agent port number port number (example, 2738) —

Scanner version version number (example, 
2.0.0.3809)

—

Scanner configuration name of scanner configuration 
applied to this device

—

Scan file location location of scan file on your 
Enterprise Discovery server

—

Scan type the type of scan performed on 
the device

—

ARP tables seen elapsed time / absolute date & 
time

the last time the ARP tables were 
seen, to the nearest 30 minutes. 
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Network Configuration
The Network Configuration table shows what parameters have been set up for 
the range in which the device resides and what their values are. It shows the 
Network Properties (Administration > Network Configuration).

Network Properties include:

Note: Network Properties may be set to On or Off. 

Allow devices

Actively ping

NetBIOS query

Resource manage

Force ARP table read

Accumulate IP addresses

Allow IP addresses

Allow ICMP and SNMP

Port ARP tables seen elapsed time / absolute date & 
time

the last time the ARP tables were 
seen by this port, to the nearest 30 
minutes. 

Port Bridge tables seen elapsed time / absolute date & 
time

the last time the Bridge tables 
were seen by this port, to the 
nearest 30 minutes. 

Device modeler interval either “Default as set in Network 
Configuration” or time (in days, 
hours, minutes, seconds)

If custom, is shown here.

Mean device modeler update 
run time

elapsed time the mean length of time it takes to 
update the model for this device 
the previous 4 times

Recent device modeler update 
run times

elapsed time the length of time it took to 
update the model for this device 
the previous 4 times

Rulebase ID — an internal number

a Elapsed time is reported in at least two of the following units: weeks, days, hours, minutes, and sec-
onds. As elapsed time increases, the finer units of measure are not reported.

Data Output Notes
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Device Modeler interval

Community read and Community write (These are the strings that will be 
tried for this device. This will be blank if there are no strings configured in 
Enterprise Discovery.) 

Note: Only Admin and IT Manager accounts can see the community strings. 

Bandwidth 

Frequency 

Win32 platform

HP/UX platform

Linux platform

AIX platform

Solaris platform

Scanner upgrade

Scanner upgrade schedule

Scanner run schedule

Scan file download schedule

Agent upgrade

Agent upgrade schedule

Agent action

Listener uninstall

Collect usage data

Property Assignment
The property assignment table helps you to determine the rules Enterprise 
Discovery has used to assign the title, icon, and priority to the device.

Parameter Notes

Default title —

Custom title takes precedence over default

Actual title the title as it appears for your account

Default icon —
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If no value has been assigned, an asterisk (*) appears in this table, indicating that 
the value for the property comes from the previous row of the table.

Agent Deployment Log
The agent deployment log shows you all the operations performed during the 
deployment process, including any errors that may occur. This is very useful for 
troubleshooting. 

Scanner Deployment Log
The scanner deployment log shows you all the operations performed during the 
deployment process, including any errors that may occur. This is very useful for 
troubleshooting. 

Custom icon the icon assigned by an Administrator or IT 
Manager account in Object > Device 
Properties.

Actual icon the icon as it appears for your account

Default priority —

Custom priority for information only; never affects active 
configuration; useful if you receive e-mail or a page 
from Enterprise Discovery

Actual priority the priority as it appears for your account

Default tag —

Custom tag the tag assigned by an Administrator or IT Manager 
account in Object > Device Properties

Actual tag the tag as it appears for your account

Parameter Notes
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IP Ping
Pings the device to see if it responds, and how quickly. The IP address pinged is 
the address identified by Enterprise Discovery as the primary IP.

Limits
1–20 pings

The device must have an IP address. If not, this button is dimmed.

Default
5 pings

Traceroute
Displays the path that data takes to get from the Enterprise Discovery server to 
the selected device by listing the gateway devices associated with each hop of 
the journey. The device identifier is often the host name, where available, but 
can also be the IP address. Each device title is hyperlinked to a Device Manager.

Traceroute also displays the amount of time each hop took. This time is the 
round trip in milliseconds. Traceroute includes two retry hops for each try, so the 
times for all three hops are shown.

Traceroute helps you to understand where on the network problems are 
occurring. It is often used after IP Ping on page 44 has been used to confirm the 
existence of a device.

When to use it
If you suspect that you are losing packets due to a large hop count.  
 
In a TCP/IP network, where data are transmitted in packets, the header for a 
packet tracks the hop count. If the hop count grows too large, the packet is 
discarded.

If you are trying to determine the point along the path where traffic is 
slowing down or getting lost altogether.

If you are trying to determine the precise path taken—not so much to solve 
a problem as for general information.

Note: The device must have an IP address. If not, this button is dimmed.
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Results of an asterisk for the device and for all three times (i.e. the result * * *) 
indicates that data is not available for that hop of the journey, and usually 
indicates a trouble spot along the path. The following table explains codes you 
may see when you attempt a Traceroute.

SNMP Ping
Queries the device for basic SNMP information and displays this information. 
The IP address pinged is the address identified by Enterprise Discovery as the 
primary IP.

Limits
The device must have an IP address. If not, this button is dimmed.

Default
Demo, IT Employee, IT Manager: “public”

Administrator: the read community string for the device as defined in 
Administration > Network configuration > Community Property Groups.

Character Meaning

* no response within a 3-second timeout interval

! ttl <= 1a

aThe ttl value is supposed to start at 1 and increase by 1 until the host 
is reached.

!H host is unreachable

!N network is unreachable

!P protocol is unreachable

!S source route failed

!F fragmentation needed

!X communication is prohibited administratively

!V a host precedence violation has occurred

!C precedence cutoff is in effect
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Agent Ping
Makes a connection to the agent running on the device to see if:

the agent is installed and running on the device

the security keys are correct

Limits
The device must be in the Enterprise Discovery database.

DNS Query
Sends a host query to the domain name server and displays a table that 
highlights configuration errors. A highlighted line indicates that the next line in 
the progression is missing.

The highlighted configuration errors are:

a pointer (PTR) without an IP address (A or AAAA)

duplicate pointer (PTR) records for the same IP address (A or AAAA)

a mail exchanger (MX) directed to a canonical name (CNAME)

a canonical name (CNAME) directed to anything that doesn’t exist

Highlighted information also includes an explanation in the “Exceptions” 
column. You will see one of the following explanations:

Duplicate

Target does not exist

n/a

If no information in the table is highlighted, Enterprise Discovery did not detect 
any problems with the DNS configuration of the device.

Limits
If the device does not have an IP address, the button is dimmed.

Important: If Enterprise Discovery displays the message “Non-existent 
domain”, it means that the device has not been assigned a domain 
name.
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Ports
Lists ports for this device and summarizes the information available for them. 
Displays 24 ports at a time (by default, you can change this in Administration > 
Account administration > Account properties). There are also Previous and 
Next buttons and an All button that shows all ports in a single panel.

The Configuration panel and Ports panel are the most commonly used ways of 
starting the Port Manager.

Events
Opens the Events Browser with this device in context. 

For detailed information, see Events Browser on page 23.

View Scan Data
Important: You must perform a client install of Enterprise Discovery to use the 

Viewer on your workstation. 

Opens the Enterprise Discovery Viewer to show information about the device 
collected by Enterprise Discovery scanners.

You can see a complete list of hardware and software installed on the device, 
plus usage data, depending on how you have configured your Scanners with 
the Scanner Generator (see the Configuration and Customization Guide). 

Limits
If there is no scan data, the View Scan data button is dimmed.

Note: The Enterprise Discovery server always has scan data, as long as you have 
installed the Agent on the server. For more information, see the 
Installation and Initial Setup Guide. 
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Web
Attempts to open a web browser window for the device.

When to use it
If the device supports web-based management or other web services.

Limits
The device must have an IP address. If not, this button is dimmed.

The device must support HTTP sessions. (Enterprise Discovery does not 
check before attempting a connection.)

Related
Note: for Aggregator—See also Administration > Remote appliance 

administration > Remote appliance properties.

Telnet
Attempts to open a Telnet session. Many network devices provide Telnet as a 
means to set up and configure the device.

Limits
The device must have an IP address. If not, this button is dimmed.

The device must support Telnet sessions. (Enterprise Discovery does not 
check before attempting a connection.)

Related
Note: for Aggregator—See also Administration > Remote appliance 

administration > Remote appliance properties.
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Update Model [Administrator or IT Manager]
At the top of the panel, there is a pull-down list so you can select the command 
you want to perform:

Command Explanation

Query Network Puts the device at the top of the device modeler’s 
queue, and runs through all the steps as required.
This command tries all valid community strings for 
this device, in the order specified in Administration > 
Network Configuration > Community Property 
Groups. This command does not begin with the 
currently active community string, it begins with the 
first string in the list of community strings.

Deploy Agent Sends the Agent to the device. 

Upgrade Agent Upgrades the Agent on the device. 

Upgrade Scanner Transfers the relevant scanner executable and 
configuration files to the device, then execute the 
scanner and finally transfer the resulting scan file to 
the Enterprise Discovery server. 

Run Scanner Requests the immediate Enterprise Discovery scan of 
this device.

Retrieve Scan File Transfers the result of the latest scan from the device 
to the Enterprise Discovery server.

Uninstall Agent Removes the Agent from the device. To verify that it 
has been uninstalled, try to do an Agent Ping on the 
Diagnosis panel. Once the Agent is uninstalled, the 
Agent-related options will disappear from the 
Update Model panel’s pull-down list. 

Enrich XML Requests immediate enrichment of the scan file 
associated with this device. 

Run Rulebase Allows you to only re-check the Enterprise Discovery 
rulebase for this device.
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On the Query Network panel, you will see a list of alarms associated with this 
device. The following is a list of all possible options that you can see. 

When to use it
When you’ve made physical changes to a device—for example, when 
you’ve changed cards in a router.

When you’ve made changes to a device’s community strings.

Limits
The device must have an IP address. If not, this button is dimmed.

Related
To determine when these commands have been run (either manually or 
automatically by Enterprise Discovery) see the Diagnosis panel. It lists all the 
relevant information. 

Device Visibility [Administrator or IT Manager]
You can activate, deactivate, hide, or purge devices on this panel. 

For information on how to activate, deactivate, hide, or purge devices, see the 
Configuration and Customization Guide.

State Message

major alarm IP address is not in scope

major alarm no read community strings have been specified

minor alarm no write community strings have been specified

minor alarm IP address is not in scope for resource management

info current discovery process

info list of read community strings to be tried

info list of write community strings to be tried

info update interval

info mean time to update model
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Properties
Allows you to change the icon and name of a device in your network. 

For instructions on how to use this feature, see the Configuration and 
Customization Guide.

Refresh
Refreshes the contents of the panel.

When used with IP Ping and SNMP Ping panels, uses the last entered value 
instead of prompting you for a value. 

Limits
Does not re-read the data in the panel from the network. Re-reads the data only 
from the Enterprise Discovery database.

Print
Prints the contents of the panel.

Close
Closes the window and exits the Device Manager.
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CHAPTER
6 U
nderstanding the Port Manager
To select a different port for the same device, use the port list box—see Port 
number on page 63.

Provides you with detailed information about a device’s ports, in one of several 
panels.

To open the Port Manager:

Default panel
initial: Configuration

subsequent: from Administration > Account administration > Account 
properties

From Open by...

Device Manager (State or Port 
panel), Reports

Click a port hyperlink. 

Events Browser, Alarms Viewer Double-click a port number. 
Understanding the Port Manager | 53



Enterprise Discovery
Toolbar
This table shows the availability of buttons in the Port Manager toolbar.

Important: Many of the panels in the Port Manager feature data in table form. 
Not all tables will look the same for all ports, because the tables will 
only show data that is available for that port. 

Icon Button name IT Employee or 
Demo user 

Admin or IT 
Manager user

Configuration

Reports

Diagnosis

Events

Purge Port —

Port Properties

Interface Rate

Interface Type

Line Alarm Type

Duplex Mode

—

Refresh

Print

Close

 Port number
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Configuration
Identifies a port and presents an overview of the port’s identity and properties.

This panel is divided into these main sections:

Heading

Identity table

VLAN table

Heading
The heading also appears in other panels.

Properties
Most information in this table comes from the Enterprise Discovery Rulebase.

Element Notes Type

Device Icon for a complete list, see Help > Classifications 
> Device Types/Package Types

all

Device type for a complete list, see Help > Classifications 
> Device Types

all

Device tag see the Configuration and Customization Guide real

No. of ports the number Enterprise Discovery uses for the 
port may not match the physical ports

all

Object title first title available; see Terms and Concepts in the 
Reference Guide. 

all

Port no./ description number of port / description of port all

Device priority see Terms and Concepts in the Reference Guide. all

Data Example Notes

Description 100Base-TX Port from device manufacturer

Interface 
type

Ethernet CSMA/CD from device MIB/Enterprise 
Discovery Rulebase
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Identity
This table identifies the port and the manufacturer of the device:

MAC address of the port

OUI of the device/card (alphabetic abbreviation of the device manufacturer)

Manufacturer of the device, hyperlinked to manufacturer’s web site

IP address of the port

Netmask of the port

Domain Name of the port

VLAN data
VLANs are software-defined broadcast domains, created by your System 
Administrator at the switch. By showing VLAN information in Enterprise 
Discovery, the Administrator can see how the devices in that virtual domain are 
configured. 

Alarm type Ethernet 100 HD from device MIB/Enterprise 
Discovery Rulebase

Interface rate 100 Mbits/sec. from device MIB/Enterprise 
Discovery Rulebase

Duplex Half Half | Full

Data Example Notes
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Reports
This panel shows details on all Add, Delete, or Change events associated with 
this port. 

Limits
This panel is not available if the object is not in the Enterprise Discovery 
database.
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Diagnosis
Displays information about the current state of the port that can be helpful in 
diagnosing problems with Enterprise Discovery.

This panel is divided into these main sections:

Main table

Property Assignment

Main table
The main table indicates the data flow for this port—when the device was first 
and most recently seen by various parts of Enterprise Discovery—plus the 
current values for several parameters.

Data Output Notes

First discovered elapsed timea / absolute date & 
time

resets if database is cleared

Network model last 
updated

elapsed time / absolute date & 
time

the last time the model changed; 
determines whether or not the model has 
been for this device

Scanner model last 
updated

elapsed time / absolute date & 
time

—

Last deactivated or 
hidden

elapsed time / absolute date & 
time

the last time a device was deactivated or 
hidden

ARP tables seen elapsed time / absolute date & 
time

—

Bridge tables seen elapsed time / absolute date & 
time

—

a As elapsed time increases, the finer units of measure are not reported.
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Property Assignment
The property assignment table helps you to determine how Enterprise 
Discovery sees the port.

Events
Opens the Events Browser with this device and port in context.

For detailed information, see Events Browser on page 23.

Parameter Notes

Default Interface Rate as generated automatically by Enterprise Discovery

Custom Interface Rate as set by the Administrator or IT Manager account

Actual Interface Rate the interface rate as it appears for your account

Default Interface Type as generated automatically by Enterprise Discovery

Custom Interface Type as set by the Administrator or IT Manager account

Actual Interface Type the interface type as it appears for your account

Default Line Alarm Type as generated automatically by Enterprise Discovery

Custom Line Alarm Type as set by the Administrator or IT Manager account

Actual Line Alarm Type the line alarm type as it appears for your account

Default Duplex Mode as generated automatically by Enterprise Discovery

Custom Duplex Mode as set by the Administrator or IT Manager account

Actual Duplex Mode the duplex mode as it appears for your account
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Purge Port
Removes the port from the device’s model as created by Enterprise Discovery.

Warning: This action cannot be undone.

Important: You are not making a physical change to the port. If you purge a port 
but the port is still operational, the port will be rediscovered and will 
reappear. 

When to use it
When a port has been removed from the network and you wish to update 
Enterprise Discovery’s representation of the device.

Effects
Deletes the events associated with the port from the event log.

Related
To purge a device, see the Configuration and Customization Guide.

Port Properties
Interface Rate 

Sets rate for a line interface.

When to use it
When you want to set a custom line speed

When Enterprise Discovery has set the wrong line speed.

Limits
0 bit/sec.–1 Tbit/sec.

Interface Type 
Sets the media type used for the line.
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When to use it
When Enterprise Discovery does not recognize the type of interface for the 
line.

When Enterprise Discovery has set the wrong interface type for the line.

Limits
Enterprise Discovery assigns a default duplex to each interface type. 

Related
To change the duplex mode, see Duplex Mode on page 62.

Line Alarm Type 
Sets the line alarm type for the connection. The line alarm type is normally 
associated with the interface type, but may be changed independently.

When to use it
When the default line alarm type associated with the interface is inappropriate.

Abbreviation Expanded form

ATM asynchronous transfer mode

DSL digital subscriber line

FD full duplex

FDDI fiber distributed data interface

HD half duplex

LAN local area network

SPN switched packet network
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Duplex Mode 
Sets the duplex to full or half. Full duplex allows for two-way communication 
over a line; half duplex permits only one-way communication.

When to use it
When Enterprise Discovery has set the wrong duplex. This changes how 
Enterprise Discovery interprets the duplex mode, not the setting on the actual 
port. 

Limits
Full | Half

Refresh
Refreshes the contents of the panel.

Limits
Does not re-read the data in the panel from the network. Re-reads the data only 
from the Enterprise Discovery database.

Print
Prints the contents of the panel.

Close
Closes the window and exits the Port Manager.
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Port number
Allows you to select from the valid port numbers for this device.

Note: The number Enterprise Discovery uses for the port may not match the 
physical port.

On your Cisco devices, the Cisco naming convention is displayed (for example, 
“Tu1” for Tunnel 1, or “Fa0/1” for Fast Ethernet 1). 
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CHAPTER
7 E

A

xporting Data into Data Access 
pplications
This chapter contains a tutorial that walks you through a simple example of how 
to connect to the Enterprise Discovery database from Microsoft Access by 
means of ODBC; how to link in the tables and perform two basic queries.

Topics in this chapter include:

Step 1: Set up Enterprise Discovery to export data on page 66

Step 2: Install the MySQL ODBC driver on page 66

Step 3: Select MYSQL as the data source (create an ODBC alias) on page 67

Step 4: Create a new database in Microsoft Access 2000 on page 70

Step 5: Link in the Enterprise Discovery tables on page 71

Step 6: Create a basic assets and recognition query on page 74

Step 7: Create a basic license query on page 78
Exporting Data into Data Access Applications | 65



Enterprise Discovery
Step 1: Set up Enterprise Discovery to export data
To set up Enterprise Discovery to export data

1 Click Administration > Account administration > Account Capabilities.

2 Select the account that should have MySQL access.

3 Click Modify Capabilities.

4 Select Yes for MySQL ODBC access. 

5 Click Modify Capabilities.

Step 2: Install the MySQL ODBC driver
If your computer does not already have a MySQL driver, download the MySQL 
Connector/ODBC driver MSI or executable from the following URL and run the 
program:

http://www.mysql.com/products/connector/odbc/

In this example we have downloaded version 3.51 of the MYSQL 
Connector/ODBC driver.
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Step 3: Select MYSQL as the data source (create an ODBC 
alias)

Before you can use the Enterprise Discovery data with Microsoft Access you 
need to create an ODBC alias for the database.

To set up MySQL as the data source

1 From the Windows Control Panel, select Administrative Tools|Data 
Sources (ODBC).

The ODBC Data Source Administrator appears. 
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2 In the User DSN tab, click Add. 

The Create New Data Source dialog appears.

3 In the list box select MySQL ODBC.

4 Click Finish. 

The Connector/ODBC - Add Data Source Name dialog appears.
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5 Enter the following information:

The Windows Data Source Name (DSN). In the following example we 
have called it ED 2.0 Tutorial.

The name or IP address of the Enterprise Discovery server.

For the name of the user, enter the account name of anyone who has 
been set up with a user account

Enter the password for the above user.

In the Database name field, select the name of the database from the 
drop-down list. 

6 Click on the Connect Options tab. For the number of the port, always enter 
8108.

7 Once you have entered these fields, click OK.

Now you are returned to the UserDSN tab in the ODBC Data Source 
Administrator dialog box. 

8 Click OK to exit.

You are now ready to connect to the Enterprise Discovery database with 
applications such as MS Access by means of ODBC.
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Step 4: Create a new database in Microsoft Access 2000
To create a new database

1 Start Microsoft Access.

2 Create a new blank database. Give it a name and save it. 

The following screen is displayed. In this example, the database has been 
named EnterpriseDiscoveryTutorial.mdb and saved in the following 
directory

C:\Program Files\Peregrine\Enterprise Discovery\2.0.0\Common

The following dialog is displayed.
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Step 5: Link in the Enterprise Discovery tables
To link in the Enterprise Discovery tables

1 In the Objects menu, select Tables and click New. 

The following dialog appears.

2 Select Link Table and click OK. 

The following screen appears.

3 In the Files of type pull-down list, select ODBC Databases. 

The following dialog appears.
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Note: The EnterpriseDiscoveryTutorial.mdb file is not supplied with Enterprise 
Discovery, but is the file that you created in Step 2 on page 70.

4 Click the Machine Data Source tab.

5 Select your entry (in this case EnterpriseDiscoveryTutorial) and click OK.

Note: Note, that this is the Tutorial data source name that you created in Step 5 
on page 69.

The following Link Tables dialog is displayed.
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6 Click Select All.

All the entries are now highlighted.

7 Click OK.

You are returned to the Tables Tab which shows the newly linked Enterprise 
Discovery tables.
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Step 6: Create a basic assets and recognition query
To create a basic assets and recognition query

1 From the Objects list, select Queries.

2 Double click Create query in Design view.

The Show Table dialog appears.
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3 In the Tables tab page, from the list, select:

hwAssetData

Device

hwCPUData

hwRecognitionInfo

hwSystemData

4 With the table selected, click Close. 

The table appears.

5 Save the query. (In this example we have called it Assets and Recognition.)
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6 Enter the query field parameters as shown below:  

7 Run the Query. From the Query pull-down menu, select Run. 

A query is generated, showing asset and recognition data from the 
inventory scans in the Inventory Database.
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Step 7: Create a basic license query
To create a basic license query

1 From the Objects list, select Queries. 

2 Double click Create query in Design view.

The Show Table dialog appears.
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3 In the Tables tab page, select:

SWSubComponent

Version

Application

Company

4 With the table selected, click Add, then Close. 

The table displayed is similar to this:

5 Click File > Save As and save the query

In this example, we have called it Licenses.
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6 Enter the query field parameters as shown below: 

7 Run the Query. From the Query pull down menu, select the Run option. 

A query is generated, showing license data from the inventory scans in the 
Inventory Database.
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8 D
eleting Data 
This section is for Administrator accounts only.

Do not perform these procedures unless you completely understand the 
consequences.

Important: If you are working on an Aggregator server, you can only delete the 
data native to the Aggregator. To delete the data associated with a 
remote server, you must delete the remote server. For more 
information, see the Configuration and Customization Guide. 

Deleting data
This procedure will delete all of your network and configuration data. Once you 
complete this operation, your server will appear as it did when you first installed 
Enterprise Discovery. 

Warning: Deleting network data stored on your server is an extremely drastic 
action that cannot be undone. Consider making an external backup of 
your data first. See the Installation and Initial Setup Guide.

Performing this delete means that you will delete all of the following:

Network data: the Enterprise Discovery database of your network devices 
are deleted, along with device statistics, and reports.

Account Information: all accounts and passwords.

Configuration: all configuration settings from the Administration menu.
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Backup: all backup files.

Scanners: all scanners that you have created with the Scanner Generator.

After performing the data delete, your server will appear as it did when you first 
installed Enterprise Discovery. 

To delete Enterprise Discovery data:

1 Click Administration > Data management > Delete data.

2 Click Delete Data.
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eports
Enterprise Discovery reports comprise the following groups: 

Executive/Summary Network Reports on page 83

Scanned Machine Reports on page 84

Executive/Summary Network Reports
Executive Summary reports are about the network as a whole. Here is one 
example of how you might use them—just to see what’s in your network.

To view the Executive Summary Network Inventory Reports

Reports > Network Documentation > Device Inventory Summary 

Or Reports > Network Documentation > Device Inventory 

You may have very little idea of what is actually in your network beyond the core 
network devices:

There may be several people responsible for the network.

Someone or several people may be adding equipment without informing 
you.

You may be new to the job and the last person didn’t keep complete records 
or records you can understand.
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Some or all of the network management may have been delegated to 
someone outside your organization.

You may be outside the organization whose network you must manage.

The Device Inventory Summary report tells you what is in your network, and the 
Device Inventory report tells you in more detail.

The following Reports are available:

Scanned Machine Reports
Scanned Machine Summaries

These reports display summary counts of the scanned machines grouped by 
different machine properties. For example, machines at the top level may be 
grouped by their company division, in turn by their office location within that 
division, and finally by the department to which they belong. 

The summary reports provide drill-down to details of those machines which 
belong to the summary group clicked on.

Note: If collection of the relevant Asset Data fields is not enabled, the data will 
be categorized as N/A, making the reports less useful).

Folder Report Type

Network 
Documentation

Network Classification pie graph, 
table

Network Devices by Function pie graph, 
table

End Nodes by Function pie graph, 
table

Device Inventory Summary table

Device Inventory by Category list

Device Inventory by UNSPSC pie graph, 
table

Device Inventory by Virtual LAN table

Port Inventory by Virtual Lan table

Device Inventory list
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Summary report by Division, Location, Department
This report lists summary counts for all scanned machines by Division, Location, 
and Department.

Clicking on a summary count for a Division, Location, or Department will display 
a report of machines belonging to those categories summarized and sorted by 
any lower level categories. For example, clicking on a location count will display 
all machines at that location and division sorted by department. 

Clicking on the Total Scanned Machines count at the bottom of the report will 
display a report of all scanned machines sorted by division, location, and 
department.

Summary Report By Location, Division, Department
This report lists summary counts for all scanned machines by Location, Division, 
and Department. 

Clicking on a summary count for a Location, Division, or Department will display 
a report of machines belonging to those categories summarized and sorted by 
any lower level categories. For example, clicking on a division count will display 
all machines at that division and location sorted by department. 

Clicking on the Total Scanned Machines count at the bottom of the report will 
display a report of all scanned machines sorted by location, division, and 
department. 

Summary Report By Department, Location
This report lists summary counts for all scanned machines by Department and 
Location. 

Clicking on a summary count for a Department or Location will display a report 
of machines belonging to those categories summarized and sorted by any lower 
level categories. For example, clicking on a department count will display all 
machines at that department sorted by location. 

Clicking on the Total Scanned Machines count at the bottom of the report will 
display a report of all scanned machines sorted by department and location. 
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Summary Report By Location, Building, Floor
This report lists summary counts for all scanned machines by Location, Building, 
and Floor. 

Clicking on a summary count for a Location, Building, or Floor will display a 
report of machines belonging to those categories summarized and sorted by 
any lower level categories. For example, clicking on a building count will display 
all machines at that building and location sorted by floor. 

Clicking on the Total Scanned Machines count at the bottom of the report will 
display a report of all scanned machines sorted by location, building, and floor. 

Summary Report By Location, Cost Center 
This report lists summary counts for all scanned machines by Location and Cost 
Center. 

Clicking on a summary count for a Location or Cost Center will display a report 
of machines belonging to those categories summarized and sorted by any lower 
level categories. For example, clicking on a location count will display all 
machines for that location sorted by cost center. 

Clicking on the Total Scanned Machines count at the bottom of the report will 
display a report of all scanned machines sorted by location and cost center. 

Summary Report By Cost Center, Location
This report lists summary counts for all scanned machines by Cost Center and 
Location. 

Clicking on a summary count for a Cost Center or Location will display a report 
of machines belonging to those categories summarized and sorted by any lower 
level categories. For example, clicking on a cost center count will display all 
machines for that cost center sorted by location. 

Clicking on the Total Scanned Machines count at the bottom of the report will 
display a report of all scanned machines sorted by cost center and location. 

Summary Report By Operating System Category
This report lists summary counts for all scanned machines by Operating System 
Category. 
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Clicking on a summary count for an Operating System category will display a 
detailed report of machines belonging to that Operating System category. 

Clicking on the Total Scanned Machines count at the bottom of the report will 
display a report of all scanned machines sorted by Operating System category.

Summary Report By Hardware Chassis Type
This report lists summary counts for all scanned machines by hardware chassis 
type. 

Clicking on a summary count for a chassis type will display a detailed report of 
machines belonging to that chassis type. 

Clicking on the Total Scanned Machines count at the bottom of the report will 
display a report of all scanned machines sorted by hardware chassis type.

Application Reports
These reports display software application licence and installation counts for all 
installed applications grouped by application, application version, and 
application publisher. These reports also display whether there is usage data 
being collected for each application. 

The reports also provide links to detailed reports of those scanned machines 
where the individual applications are installed.

These reports are based on Application Recognition performed by the XML 
Enricher.

To ensure that the data presented is sufficiently accurate, make sure that

Application Recognition is enabled in the XML Enricher. 

The Software Application Library used is up to date. 

Licence Counts by Application
This summary report displays all applications by publisher and application with 
counts of licences required and installations for each application. This report 
also displays whether there is usage data being collected for each application.
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Clicking in the Publisher column will display detailed version information about 
all of the publisher's applications. Clicking in the Application Name column will 
display the details of the different versions of that application. 

Top Applications
This report lists those applications requiring the largest number of licences, 
sorted by number of licences. This report also displays whether there is usage 
data being collected for each application.

Clicking in the Publisher column will display detailed version information about 
all of the publisher's applications. Clicking in the Application Name column will 
display the details of the different versions of that application.

Publishers Summary
This summary report lists all publishers sorted by name together with their 
application licences required and installed application counts. 

Clicking on the publisher's name will display detail information for all of the 
publisher's applications. 

Top Publishers
This report lists the publishers with the greatest number of installed 
applications that require licences. 

Clicking on the publisher's name will display detail information for all of the 
publisher's applications. 
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