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Documentation Updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.

l Document Release Date, which changes each time the document is updated.

l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using themost recent edition of a document, go
to:

http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign in. To register for an HP Passport
ID, go to:

http://h20229.www2.hp.com/passport-registration.html

Or click theNew users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.
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Support
Visit the HP Software Support Online web site at:

http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support
that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed tomanage your business. As a
valued support customer, you can benefit by using the support web site to:

l Search for knowledge documents of interest

l Submit and track support cases and enhancement requests

l Download software patches

l Manage support contracts

l Look up HP support contacts

l Review information about available services

l Enter into discussions with other software customers

l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To findmore information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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Welcome to this Guide
Welcome to HP Application Lifecycle Management (ALM). ALM empowers IT tomanage the core
application lifecycle, from requirements through deployment, granting application teams the crucial
visibility and collaboration needed for predictable, repeatable, and adaptable delivery of modern
applications.

Note: HP Quality Center Enterprise Edition is in Technology Preview. It will be released
formally after completion of the Technology Preview period.

How This Guide is Organized
TheWhat's New contains the following parts:

Part Description

"What's New in HP ALM
11.50" on page 8

Provides an overview of the features that were introduced or
enhanced in ALM 11.50.

"What's New in HP ALM
11.00" on page 24

Provides an overview of the features that were introduced or
enhanced in ALM 11.00.
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What's New in HP ALM 11.50
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Chapter 1

What's New in HP ALM
This What’s New guide provides an overview of the features that were introduced or enhanced in
HP Application Lifecycle Management (ALM) 11.50. For more information on using ALM, refer to
theHP Application Lifecycle Management User Guide.

You can also view video demonstrations of HP Application Lifecycle Management features by
choosingHelp > Product Feature Movies in the ALMmain window.

HP Application Lifecycle Management 11.50 10

HP ALM Editions 11

Installation 11

Business Views 12

LabManagement 13

User Updates 13

Administration Updates 15

Changes in Feature Availability 16

Business Process Testing 16

API and Database Updates 17

Documentation Library 18

HP Application Lifecycle Management 11.50
HP Application Lifecycle Management (ALM) empowers IT tomanage the core application
lifecycle, from requirements through deployment, granting application teams the crucial visibility
and collaboration needed for predictable, repeatable, and adaptable delivery of modern applications.

ALM supports you through all the phases of application lifecycle management. By integrating the
tasks involved in applicationmanagement, ALM enables you to better align IT with your business
needs.

ALM also includes Performance Center functionality, enabling you tomanage all aspects of a large-
scale performance testing project, including resource allocation and scheduling, from a centralized
location accessible through theWeb. For details on new features in Performance Center, see
"What's New in HP ALM Performance Center" on page 20.
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HP ALM Editions
ALM is also available in several editions which provide subsets of ALM functionality —HP ALM
Essentials Edition, HP Quality Center Enterprise Edition, and HP ALM Performance Center
Edition.

HP ALM
Edition

Description

HP ALM A unified platform for managing and automating processes, activities, and assets
for building, testing, delivering, andmaintaining applications. It includes modules
for requirement, test, defect, and development management, and overall release
and project planning. HP ALM helps organizations drive consistent processes,
shared best-practices, and asset sharing across projects.

HP ALM
Essentials
Edition

Provides a subset of HP ALM product functionality, and is designed to help
smaller teams get up and running quickly. It provides core functionality for
requirements management, test management, and defect management.

HP Quality
Center
Enterprise
Edition

Resides on the same unified platform as HP ALM. It delivers core functionality for
quality management. It supports building a quality center of excellence through
tight integrations with HP Unified Functional Testing, HP Business Process
Testing, and HP Sprinter.

HP ALM
Performance
Center
Edition

Functionality for the completemanagement, scheduling, running, andmonitoring
of performance test scripts. It resides on the same platform as HP ALM and
integrates directly with HP ALM andHP LoadRunner.

For more information, refer to theHP Application Lifecycle Management User Guide.

Installation
The following updates have beenmade to the installation process. For more information, refer to the
HP Application Lifecycle Management Installation Guide.

Supported Environments
For the supported and recommended system configurations for your ALM server and client
machine, refer to theHP Application Lifecycle Management 11.50 Readme.

Important: The supported environment information in theHP Application Lifecycle
Management 11.50 Readme is accurate for the ALM 11.50 release, but theremay be updates
for ALM 11.50 patches. For themost up-to-date supported environments, refer to the HP
SoftwareWeb site using the following URL: http://www.hp.com/go/TDQC_SysReq.

ALM offers integrations with other HP testing tools. To verify that you are using a supported
version, on the Add-ins page, click theMore HP Application Lifecycle Management Add-ins
link. Choose theALM 11.50 integrationmatrix.
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Application Server
You no longer need to install a third party application server to host ALM. The application server is
now part of the core ALM functionality.

This provides the following benefits:

l Reduces third party application server dependencies, maintenance, and costs.

l Simplifies troubleshooting.

l Lowers thememory footprint of ALM.

l Simplifies installation, upgrade and product updates.

l Enables ALM to be a ‘Cloud Ready’ platform.

Extension Deployment
ALM extensions, such as HP Enterprise Integrationmodule for SAP applications and HP Service
Test Management, provide added functionality to ALM. Previously available for download from the
ALM Add-ins site, extensions are now an integrated part of the ALM installation. If you have a
license for an ALM extension, you can utilize the added functionality by enabling the extension on a
per project basis.

l Formore details on enabling extensions, refer to theHP Application Lifecycle Management
Administrator Guide.

l To view the list of extensions available with ALM 11.50, or to download documentation for ALM
extensions, visit the HP ALM Add-ins Page, accessible from themain ALM Helpmenu.

Business Views
Previously, graphs could be based on single entities only, such as requirements or defects. Now,
you can create graphs based on business views, which are defined andmanaged in Project
Customization.

You can create business views based on single or multiple entities. For example, you could create
a view that combines theRuns entity with the Test Set entity. This would enable you to analyze
test runs according to test sets.

ALM provides a set of pre-defined business views that are available for selection. These pre-
defined views, in addition to user-defined views, are fully customizable and can be continually
edited according to your needs.

You create business views using DQL, a domain query language. DQL is based on ANSI SQL 9.2,
with the following advantages:

l DQL enforces data hiding in accordance with user's permission levels.

l DQL queries run equally well on Oracle and SQL database servers.

l The DQL query creates a database abstraction which is then used as a basis for the business
view. Since the basis of the view is an abstraction of the database and not the database itself,
you do not need to identify entity fields according to their actual names. Rather the query
simplifies them andmakes them easier to identify. For example, all fields that relate to an
object's identification appear with the suffix "ID", such as Defect ID, Cycle ID, and Release ID.
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Lab Management
HP ALM LabManagement supports continuous integration and delivery practices, by providing
tools for automatically deploying test environments, and scheduling functional and performance
tests with or without user intervention.

By integrating HP ALM with HP Continuous Delivery Automation (CDA), you can automatically
deploy test environments on a private or public cloud.

To test the environment, you can define Build Verification Suites, consisting of multiple test sets
and a performance test. You run the Build Verification Suite against a dynamic environment, which
is provisioned and deployed by CDA at the beginning of the test schedule.

LabManagement offers QA professionals new ways for planning test executions. You can create
timeslots dedicated to running automated functional tests, and request testing hosts required for the
automation run. To ensure that the QA professional has the testing tools required for the run, you
can either name specific hosts, or specify the type and amount of hosts needed for a specific test
set run. In this case, the system will automatically allocatematching hosts.

In addition, new Test Set Run reports allow QA Professionals to analyze each individual test set
run, by viewing either previous Test Set Runs or Runs in progress.

With LabManagement, testing resources can bemanagedmore effectively from a central location,
allowing you to allocate testing resources to projects, based on project scale and priority. This
ensures that each project has the testing resources it needs.

The Lab Administrator can specify the number of testing hosts, or specify named hosts, that will be
allocated to projects. Testing hosts can be automatically allocated according to their priority or
volume.

LabManagement also ensures more secure communications with testing hosts, allowing you to run
tests on testing hosts over a firewall. This is enabled by controlling test execution from the ALM
server. The new server execution continues even if the ALM Client disconnects or is logged out.

ALM Editions: LabManagement functionality is available for HP ALM and Performance
Center editions.

User Updates
This section describes usability enhancements in HP Application Lifecycle Management 11.50.

Product Movies
Product movies are removed from the server, andmoved to an external site. You can copy selected
movies to the server, and link to them from a custom link in the Helpmenu. For details, see theHP
Application Lifecycle Management User Guide.

Default Entity Values
Creating new entities, such as tests, test configurations, and defects, sometimes requires entering
a large number of fields. Often, the values for these fields are the same, and entering the data is a
repetitive and time consuming task.
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Now, default values for certain entities can be created per entity, per user, and per project. Each
time you create an entity, these default values can be automatically filled in, or filled in at the click
of a button. For details, see theHP Application Lifecycle Management User Guide.

Mail Enhancements
The following updates weremade to the ALMmail command:

l When sending an entity with parameters, the parameters are included in themail.

l You can send test instances including details, history, attachments, run summary, and last run
steps.

l You can send runs with their run steps and run results.

l Mail is now sent asynchronously, and does not interfere with your work in ALM.

Data Awareness Enhancements
The following enhancements weremade to data awareness features such as test configurations:

l You can automatically map business process and UFT test configuration parameters to the
dynamic data in an external data table resource.

l You can select business process and UFT test configuration parameter names using a drop-
down list, that contains all the resource (Excel) headers, instead of typing names manually.

l You can preview the data in the external data table resource according to predefined filters in the
Test Configuration tab.

For user interface details, see theHP Business Process Testing User Guide.

Test Resource Enhancements
The following enhancement was made in the Test Resources module:

l You can now add API shared resources. These resources contain locally stored services for use
with API automated tests.

Manual Runner Enhancements
The following enhancement was made toManual Runner:

l When running a test set, you can cancel the run of remaining tests when canceling a test run.

Project Report Enhancements
The following enhancements weremade to Project Reports:

l You can download the report locally as a .zip file.

l You can add existing graphs to the report, or create new graphs directly in the report.

l Pre-defined project reports can now be accessed from within the Requirements, Test Plan, Test
Lab, Defects, and Business Components modules.

Analysis View Enhancements
The following enhancement was made to the Analysis View module:
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l A new Analysis Menu tab has been added to the Analysis View module. This tab enables project
administrators to manage the analysis items that are available to users in the Requirements,
Test Plan, Test Lab, Defects, and Business Components modules.

Administration Updates
This section describes administration enhancements in HP Application Lifecycle Management
11.50.

Side-by-Side Site Administration Clients
l Multiple versions of Site Administration can run side-by-side on a workstation, similar to the

side-by-side support of ALM.

l Instances of Quality Center 10.00 Site Administration can be opened side-by-side with
instances of ALM11.50 Site Administration.

l Third-party tools can integrate Site Administration operations into their scripts by registering the
Site Administration client component. For details, see the HP ALM Client Registration add-in on
the HP ALM Add-ins page.

License Management
Using themodified Licenses tab in Site Administration, you can now dynamically allocate licenses
to specific domains, projects, and users. For details, see theHP Application Lifecycle Management
Administrator Guide.

Unicode Support
ALM projects on SQL Server now support Unicode.

Site Configuration
In the Site Configuration tab, the following parameters were added: 

l ASYNC_MAIL_ENABLED

l CLEAN_ORPHAN_ANALYSIS_DATA_JOB_SLEEP_INTERVAL

l CUSTOM_HELP_MENU_LINK

l CUSTOM_PREREQUISITES_PAGE_URL

l DISABLE_DEFAULT_VALUES

l DISABLE_GET_CHILDREN_LISTS_WITH_VERSIONING

l DOWNLOAD_REST_ATTACHMENTS

l ENABLE_CREATE_STANDARD_REPORT

l ENABLE_CREATE_LEGACY_EXCEL_REPORT

l ENABLE_CREATE_DOCGEN_FAVORITE

l GET_COVERAGE_FROM_BL_FOR_PINNED_TESTSET

l GRAPH_RESULTS_LIFESPAN
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l LDAP_RESULT_SIZE_LIMIT

l MAX_CONCURRENT_REPORTS

l MAX_GRAPH_RESULT_DATA_TABLE_VOLUME

l ORPHAN_ANALYSIS_DATA_FILE_INACTIVE_PERIOD

l QPM_KPI_FAILURES_PERCENTAGE_PER_RELEASE_FUSE

l QPM_RECENTLY_USED_PROJECTS_THRESHOLD_MINUTES

l REPORT_MAX_ALLOWED_SIZE

l REPORT_RESULTS_LIFESPAN

l REST_API_HTTP_CACHE_ENABLED

l REPOSITORY_GC_DELAY_CANDIDATE_TIME

l SKIP_CLIENT_PREREQUISITES_CHECK

l UPLOAD_ATTACH_MAX_SIZE

The following parameter was removed:

l ANALYSIS_ITEM_RESULTS_LIFESPAN

Formore information on the new parameters, refer to theHP Application Lifecycle Management
Administrator Guide.

Changes in Feature Availability
The following features are no longer fully available from HP Application Lifecycle Management
11.50.

Standard Reports
You can no longer create new standards reports. Existing reports from previous versions of ALM
can still be viewed and edited.

Document Generator
You cannot add new project documents to the Favorites list. All existing favorites from previous
versions can still be accessed and generated.

Business Process Testing
New HP Application Lifecycle Management 11.50 features are also supported for Business
Process Testing entities. In addition, the Business Process Testing features described below have
been introduced or enhanced in ALM 11.50.

For more information on these features, refer to theHP Business Process Testing User Guide.
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Test Script Canvas
A new canvas view is available from the Test Planmodule’s Test Script tab. The view enables
users to visualize the data flow in the test/flow (including parameters and links). With the canvas,
users canmodify test scripts using a graphical display. The canvas includes all the functionality of
the Test Script Pane grid, including:

l Setting the level of detail you want to view, and collapse and expand flows and groups, for easier
navigation.

l Dragging and dropping entities from the Components and Flows pane into your business
process test or flow.

l Performing functions, such as setting iterations and creating run conditions, directly from the
canvas.

Manual and Automated Business Components
You can now create a business component without determining in advance if the component will be
automated or manual. A component can contain manual design steps, automation, or both. You can
addmanual design steps or automation to a component at any point.

General Enhancements
You can now insert component and flow parameters between existing parameters in the grid, not
just at the end.

API and Database Updates
The HP ALM REST API, first introduced in ALM 11.00, now provides REST resources for most
day-to-day functionality. The functionality will continue to be expanded in upcoming releases. The
REST API provides a platform-independent method of working with ALM data using standard web
services. This enables the REST API:

l To support activities like server-to-server integration, which are difficult to implement using the
older OTA API.

l To be a platform for developing applications that can bemaintained in the future as the
underlying ALM technology evolves to support modern infrastructures.

See the following sections of theHP ALM REST API Reference:

l What's new in this release

l Compatibility Breaks between versions 11.00 and 11.50

ALM 11.50 can use Client-Side Deployment so that a client can connect to more than one instance
of ALM. This affects APIs in the following ways:

l TheOTA type library and the Site Administration type libraries are no longer registered
automatically on the client machine. Before connecting to ALM with anOTA or Site
Administration application, register the libraries for the server by running HP ALM Client
Registration from the ALM Add-ins page. For more information, see the information about
registering ALM on aworkstation in theHP Application Lifecycle Management Installation
Guide.

l The installation of custom test types has changed. See theHP ALM Custom Test TypeGuide.

See the topicWhat's new in this release in the HP ALMOpen Test Architecture Reference.
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Documentation Library
The following updates weremade to the HP ALM Documentation Library.

Online Help
The online help browser has been redesigned, and includes the following enhancements:

l An improved search engine returns more relevant results for your searches in the documentation
library.

l Forward and Back buttons enable you to return to topics that you previously viewed.

l You can flag favorite topics for future reference, that are then listed together in a Favorites pane.

New Documentation
The following additions have beenmade to the documentation:

l The HP ALM Documentation Library now includes theHP ALM LabManagement Guide.
Sections in this guide were previously included in theHP ALM Performance Center Guide.

l Best Practices Documentation includes the following new guides:

n TheHP ALM Agile Testing Best Practices Guide provides best practices for the
implementation of agile testing principles in various organizations.

n TheHP ALM Versioning and Baselining Best Practices Guide provides best practices for the
implementation of version control and the creation andmaintenance of baselines in various
organizations.

n TheHP ALM Project Topology Best Practices Guide provides best practices for structuring
HP ALM projects in various organizations.

n TheHP ALM Entities Sharing Best Practices Guide provides best practices for
implementation of entities sharing in various organizations.

n TheHP ALM Project Planning and Tracking Best Practices Guide provides best practices for
implementation of managing and tracking releases in various organizations.

l API References documentation includes the following new guide:

n TheHP ALM .NET Custom Test Type Developer Guide contains instructions for creating and
installing custom test types on a .NET platform. The COM guide has been renamed theHP
ALM COMCustom Test Type Developer Guide.
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Chapter 2

What's New in HP ALM Performance Center
This What’s New guide provides an overview of the features that were introduced or enhanced in
HP ALM Performance Center11.50. For more information on using HP ALM, refer to theHP ALM
Performance Center Guide.

You can also view video demonstrations of HP ALM Performance Center features by choosing
Help > Product Feature Movies in the ALMmain window.

Installation 20

Performance Application Lifecycle (PAL) 20

Integrating Virtualized Services 20

VuGen Enhancements 21

Protocols 21

Recording 64-bit Applications 23

Installation
The Performance Center extension is now installed and deployed as part of themain ALM
installation process. If you have a license for Performance Center, you can utilize the added
functionality by enabling the extension on a per project basis. For more details on enabling the
extension, refer to theHP Application Lifecycle Management Administrator Guide.

Performance Application Lifecycle (PAL)
Performance Application Lifecycle (PAL) enables you to share performance information between
development and operations to better plan your performance tests and application deployment. This
includes information such as scripts, user traffic, and systemmonitors. You can use this
information to create scripts and load tests that better resemble a production environment. Sharing
performance testing information with production can be used to determine when to deploy an
application. PAL supports data from HP Business ServiceManagement (BSM) andWebtrends
Analytics.

For details, see theHP ALM Performance Center Guide.

Integrating Virtualized Services
As part of your performance test, youmay want to test applications that depend on other services
which are a part of your business scenario. Instead of loading actual services, you can use
simulated services in your test run. The virtualized services are a simulation of actual services. To
facilitate load testing business processes that contain services that are not readily available or too
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costly, Performance Center integrates with HP Service Virtualization. This integration allows you to
run virtual services that simulate actual services.

For details, see theHP ALM Performance Center Guide.

VuGen Enhancements

The VuGen user interface has been improved and enhanced to provide amore flexible and
customizable user experience. An all new IDE makes LoadRunner scripting easier andmore
productive.

The following enhancements have been added: 

l New look and feel – Flexible panes, layouts, andmore

l Solution Explorer – An easier way to groupmultiple scripts, access script items, and perform
script-related operations.

l Snapshots –Multiple views, improved performance, snapshot synchronization, and search
functionality.

l Improved editor – Context-sensitive support, code completion support, and provides enhanced
coloring and formatting.

l Debugger – Real C language debugger.

l Search and replace – New capabilities include search in log and snapshots.

l Step navigator – The new Step Navigator replaces the tree view, providing a single view of the
script with easy filtering and searchmechanisms.

l New panes – Errors, Tasks, and Bookmarks panes display all errors, messages, and tags in
simple, easy to locate views.

l Join the Community – Community integration provides easy access to conversations and
threads in the HP Software Community.

Protocols
Ajax TruClient Firefox Enhancements
This ground breaking protocol has been enhanced to support the latest technologies, and includes
many usability improvements in response to customer needs.

The Ajax TruClient Firefox protocol has been improved with the following enhancements:

l Moving to Firefox 8 for improved performance.

l HTML5 support.

l Create functions to easily reuse and share code.

l Think-time recording.

l Event handlers to support asynchronous behavior.

l API for URL filtering.
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l API for setting HTTP headers.

l Automatic transactions per step.

l Ajax TruClient Internet Explorer. A new protocol that brings TruClient capabilities to Internet
Explorer 9. This new addition to the Ajax TruClient family expands support to Internet Explorer
(IE) based applications.

Web Protocol Asynchronous Support
Support for asynchronous behavior has been added. This new capability enables recording of Poll,
Long Poll, and Push interactions.

AdvancedWeb applications contain a lot of asynchronous communication designed to keep
information current and up to date. Applications such as chat, messaging, stock tickers, and news
updates all use various asynchronous mechanisms such Poll, Long Poll, and Push tomaintain
data. Support for thesemechanisms has been added toWeb (HTTP/HTML) Vuser scripts, and
web-based functions inside Flex, Silverlight, andWeb Services Vuser scripts. These unique
communication patterns are recognized automatically and the recorded script is updated
accordingly.

Improved Correlations
A new response correlation capability has been added so correlation is easier and faster.
Correlations can now be found based on server responses during recording, in many cases
eliminating the need to replay iteratively to find dynamic values. Coupling this with the new
Correlation Studio interface and new APIs for locating parameters based on XPath and Regular
Expressions, makes scripting easier and faster.

Flex Enhancements
Various enhancements have been added to better support this important environment.

Flex enhancements include:

l UsingWeb correlationmechanisms (rules, studio, response based correlation, web correlation
APIs).

l SupportingWeb requests.

l Adobe Flex platform jars bundled in the product so application jars are not needed for message
serialization.

l RTMP FMS streaming support.

l RTMPT & RTMPS support.

l GraniteDS support.

Mobile Protocols
New protocols enabling you to develop scripts for mobile applications. Traffic based analysis is
used for native applications and Ajax TruClient technology is used for browser basedmobile
applications.

Data Format Extension (DFE) for Google Web Toolkit (GWT)
Web protocol includes a built-in DFE to support decoding and encoding of GWT information
exchanged as part of GWT remote procedure calls. This facilitates easy correlation and
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parameterization of GWT basedWeb applications. The DFE feature is designed to help ease
scripting of applications that exchange formatted data. By turning the formatted data into amore
readable format the script can be easily correlated and parameterized. GWT DFE is the latest
addition to the already supported formats of Base64, JSON, URLEncoding, XML, and Prefix-
Postfix.

GWT support includes:

l Format the GWT RPC data into readable and correlate-able content.

l Exposemore data, such as object field names.

l Enable simple parameterization.

l Solve specific correlations for GWT.

.NET4 Support
The .NET protocol now supports .NET4 framework.

.NET4 support has been added to the existing support for .NET frameworks 2-3.5.

Web Services Enhancements
TheWeb Services protocol includes new features for better security support, improved handling of
WCF, as well as additional improvements based on customer feedback.

TheWeb Services protocol includes the following enhancements:

l Improved interface for security settings, including addressing versions.

l Easier certificate selection.

l Flexible definition of signature and encryption algorithms. Also includes the option to exclude
timestamps.

l Support of custom extensions toWCF.

l Support of LoadRunner HTTP capabilities forWCF.

Recording 64-bit Applications

Recording of 64-bit applications has been added to the existing support for 64-bit operating
systems. 64-bit applications can usually be recognized when the ‘*32’ suffix is not displayed in the
Windows Task Manager for their process. Replay is in 32-bit.
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This What’s New guide provides an overview of the features that were introduced or enhanced in
HP Application Lifecycle Management (ALM) 11.00. For more information on using ALM, refer to
theHP Application Lifecycle Management User Guide.

You can also view video demonstrations of HP Application Lifecycle Management features by
choosingHelp > Product Feature Movies in the ALMmain window.
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Installation
The following updates have beenmade to the installation process. For more information, refer to the
HP Application Lifecycle Management Installation Guide.

Installation Wizard
l Validations have been added throughout the installation process.
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l The installation wizard now consists of two stages: file delivery and server configuration. This
means that you can reconfigure the server without having to reinstall the application.

Data Security
ALM encrypts information for accessing external systems (databases, Windows, and LDAP), and
secures communication with other HP BTO applications.

ALM Client
Installing an ALM client no longer requires administrator privileges on themachine. Administrator
privileges are still required for installing certain add-ins.

Optimized Project Repositories
Project files are now saved over an optimized repository system, that ensures better performance
for common actions, and extends the capacity of the file system.

Files in the project repository are stored in an optimized folder structure that allows maximum
storage space. In addition, any two files with identical content are stored in the repository only
once. This results in a significant reduction in disk space. For example, if you attach the same file
to several ALM records, the file is stored only once in the project repository.

In addition, you can browse the optimized repositories using an FTP client (available with ALM
11.00 Patch 01).

For more information, refer to theHP Application Lifecycle Management Administrator Guide.

When upgrading from Quality Center 9.2 or 10.00, ALMmigrates files from the legacy project
repository to the optimized project repository.

Side-by-Side ALM Clients
You can now runmultiple versions of HP Application Lifecycle Management (ALM) side-by-side on
a workstation. This includes multiple ALM 11.00 clients connecting to different ALM servers, and a
single Quality Center 10.00 or 9.2 client.

For more information, refer to theHP Application Lifecycle Management Installation Guide.

Project Planning and Tracking (PPT) Releases
Using the Project Planning and Tracking (PPT) feature, you can now track application readiness by
definingmilestones for activities of an application release in the Releases module. PPT uses key
performance indicators (KPIs) to analyze the data of your definedmilestones. The overall health
and deployment readiness of a release in displayed in the form of a scorecard. The scorecard
monitors and tracks how well eachmilestone is beingmet on a daily basis. To further analyze your
output, you can generate dashboard reports and graphs.

For more information, refer to theHP Application Lifecycle Management User Guide.

Quality Center Editions: PPT is not available for Quality Center Starter Edition, Quality
Center Enterprise Edition, or HP ALM Performance Center Edition.
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Business Process Model Integration
You can now import business process models created in external model authoring tools. Importing
business process models into the new Business Models module automatically creates a framework
of requirements representing eachmodel and activity. You can then create test coverage and
assess the quality of your business process models.

In addition, you can add path entities to your models that represent end-to-end sequences of
activities, enabling you to test your business flows.

For more information, refer to theHP Application Lifecycle Management User Guide and to theHP
ALM Business Models Best Practices Guide.

Quality Center Editions: The Business Models module is not available for Quality Center
Starter Edition or HP ALM Performance Center Edition.

Traceability Matrix
You can now determine the extent of relationships between different requirements, and between
requirements and tests, using the Traceability Matrix view in the Requirements module. The
traceability matrix helps you verify that all requirements aremet, and identify changes to the scope
of your requirements when they occur. For more information, refer to theHP Application Lifecycle
Management User Guide.

Test Configurations
Using the Test Configurations tab in the Test Planmodule, you can now design tests that run
according to different use-cases, each with different sets of data. Each use-case is called a test
configuration. Values for the test configurations are supplied from within your ALM project or from
an external data resource.

For more information, refer to theHP Application Lifecycle Management User Guide.

New Manual Runner—HP Sprinter
You can now runmanual tests in ALM from the Test Labmodule using the new HP Sprinter.
Sprinter provides enhanced functionality and a variety of tools to assist in themanual testing
process, including the ability to:

l create and annotate screen captures

l capturemovies of your run

l record and runmacros on your test application

l automatically enter data into fields in your application

l automatically include the list of your steps or user actions in any defect you submit

l replicate your user actions onmultiple machines with different configurations
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Formore information, refer to theHP Sprinter User Guide, available from the HP Application
Lifecycle ManagementAdds-ins Page (select Help > Add-ins Page).

ALM Editions: Sprinter functionality is not available with Quality Center Starter Edition or HP
ALM Performance Center Edition.

Project Reports
A new Project Report reporting tool is available in the Analysis View module, enabling you to design
and generate comprehensive reports of project data. Using templates designed by the project
administrator for each ALM entity, users create project reports, by selecting the entities that are
included in report sections, and defining data filters.

Project reports offer the following advantages:

l rich style and layout option usingMSWord templates

l enhanced performance

l single configuration for multiple output formats (doc, docx, html, pdf)

l centralized templatemanagement

For more information, refer to theHP Application Lifecycle Management User Guide.

User Updates
This section describes usability enhancements in HP Application Lifecycle Management 11.00. For
more information, refer to theHP Application Lifecycle Management User Guide.

Module Navigation
A new module navigation sidebar enables quick access to themodules available in ALM.

Favorite Views
You can now add subfolders to help you organize your favorite views. For example, you can create
folders to organize favorite views by product, release version, or team.

Library Enhancements
The following enhancements weremade in the Libraries module:

l Improved library creation process:

n Filtered libraries. Previously, when you created a library, all records within the folders you
selected were added to the library. In ALM 11.00, when you create a library, you can also
define a filter for each entity tree you include, providing you with better control over library
content.

n Automatically include related entities during baseline creation. Previously, when you
created a library that included tests, you also needed to select all the related entities that were
required for the tests to run, such as called tests and test resources. In ALM 11.00, these
related entities are automatically included when you create a baseline for the library.
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n Add tests to a library based on coverage.When you select tests to include in a library,
you now have the option to automatically include only those tests that cover requirements in
the library.

l Export baseline and library comparison results. You can now save baseline and library
comparison results in .csv file format.

Quality Center Editions: The Libraries module functionality is not available for Quality Center
Starter Edition.

Requirements Enhancements
The following enhancements weremade in the Requirements module:

l Requirements Ordering. Previously, requirements were added to the requirements tree by
order of creation. To arrange the order, you sorted the tree by selected fields. In ALM 11.00, you
canmove the requirements in any logical order in the tree.

l Rich Text Editor. The rich text feature has been improved in ALM 11.00. It includes the
following enhancements:

n changed from aMicrosoft Word-based editor to an HTML editor

n expanded the viewable area

n improved performance of opening and saving rich text

n available as searchable field

n enables using a rich text template

Test Execution Enhancements
The following enhancements weremade in the Test Labmodule:

l The Test Labmodule now contains twomain tabs:

n The Test Sets tab displays the test sets tree view.

n The Test Runs tab displays all project runs in a grid.

The Test Sets Grid View is no longer available.

l Run Management. You can now view and filter all runs for your project in a single grid view.
This is available from the new Test Runs tab in the Test Labmodule.

l Draft runs. You can now set a test as a draft run to instruct ALM to ignore the run results. This
enables you to try out tests while they are still in development or after they have beenmodified
without impacting statistics such as test or coverage status.

l Run State field. The new test runState field enables you to track the status of a run in
progress.

l Blocked run status. A new status has been added to test runs. TheBlocked status indicates
that the test cannot run. This enables you to distinguish between tests that were not completed,
possibly due to lack of time, and those that could not be completed for some other reason, such
as network problems or hardware failure.
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l Execution summary. You can now instruct ALM to send a summary of test results in an email
to specified users when test set execution completes. This option is available from the
Automation tab.

l The Test Instance Properties dialog box is renamed the Test Instance Details dialog box.

Dashboard Enhancements
The following enhancements weremade in the Dashboardmodule:

l Dashboard Module. The Dashboardmodule now contains two sub-modules:

n TheAnalysis Viewmodule contains the analysis items that were previously displayed in the
Analysis View tab.

n TheDashboard Viewmodule contains the dashboard pages that were previously displayed
in the Dashboard View tab.

l Graphs. The following enhancements are introduced in graphs:

n Sharing Graphs. You can now share graphs for viewing in aWeb browser, without
downloading an ALM client.

n Configuration Options. In progress and trend graphs, you now have full control over the
time period that is covered by graphs.

Task Manager
You can now view the progress and status of asynchronous tasks run in your project. The new
Task Manager dialog box enables you to view tasks that run in the background, such as creating a
baseline or importing a library.

Session Reconnect
When your ALM session is inactive for a period of time, the session expires. Previously this
required you to log out and log in again, which includes reloading project customization.

Now when your session expires, you are prompted to reconnect. If the project administrator has not
made any significant changes to the project customization, the customization does not reload,
enabling you to reconnect quickly and continue working where you left off.

Administration Updates
This section describes administration enhancements in HP Application Lifecycle Management
11.00.

Importing LDAP Users
Previously, you could import LDAP users by browsing and filtering the LDAP tree. In ALM 11.00,
you can search LDAP users by entering keywords. For more information, refer to theHP
Application Lifecycle Management Administrator Guide.

Enabling Project Extensions
Previously, you could enable an extension for a project only after creating the project. You can now
enable extensions for a project while creating the project. For more information, refer to theHP
Application Lifecycle Management Administrator Guide.
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Cross Project Customization
When you apply template customization, module access customization in the template is now
applied to linked projects. For more information, refer to theHP Application Lifecycle Management
Administrator Guide.

Quality Center Editions: Cross Project Customization is not available for Quality Center
Starter Edition or Quality Center Enterprise Edition.

Deactivating Users
You can now deactivate users in Site Administration. An inactive user cannot log in to any ALM
project. This enables you to temporarily deny a user access to projects, while maintaining user
details, and preserving a user’s settings and permissions. For more information, refer to theHP
Application Lifecycle Management Administrator Guide.

Update Test Types
After registering custom test types with ALM, you are now required to synchronize changes with
active projects in Site Administration. For more information, refer to theHP Application Lifecycle
Management Administrator Guide.

QC Sense
You can now analyze ALM usage and performance data using QC Sense, the new internal
monitoring tool. QC Sense collects data on user actions performed in the ALM user interface, and
monitors all client and server activity resulting from those actions. You can generate reports based
onQC Sense data, enabling you to examine and compare performance. For more information, refer
to theHP Application Lifecycle Management Administrator Guide.

Saving Customization Changes
You can now save a change that youmake to project customization as amajor change or aminor
change. The option you select determines if customization is reloaded when a user reconnects after
a session expires. If you have not made any major changes to the project customization, the
customization does not reload, enabling users to reconnect quickly. For more information, refer to
theHP Application Lifecycle Management Administrator Guide.

Site Configuration
In the Site Configuration tab, the following parameters were added:

l DEBUG_CLOSURE_LOG_DOM_PROJ

l DISABLE_PASSWORD_OTA_ENCRYPTION

l ENTITY_LINK_HOST

l ENTITY_LINK_PORT

l EVENT_LOG_PURGE_PERIOD_DAYS

l EXTENDED_MEMO_FIELDS

l FAST_RECONNECT_MODE

l FETCH_LIMIT (available with ALM 11.00 Patch 01)

HP ALM (11.50)Page 32 of 50



HP ALM What's New
Chapter 3: What's New in HP ALM

l LIBRARY_FUSE

l QC_SENSE_REPORT_USERS (available with ALM 11.00 Patch 01)

l REQUIREMENTS_LIBRARY_FUSE

l REST_API_DEFAULT_PAGE_SIZE

l REST_API_MAX_PAGE_SIZE

l REST_SESSION_MAX_IDLE_TIME

l SSO_EXPIRATION_TIME

l SUPPORT_TESTSET_END

The following parameters were removed:

l ALLOW_REQ_COVERAGE_BY_TEST_INSTANCE

l LIBRARY_BROKEN_LINKS_VERIFICATION_FUSE

Workflow Events
Workflow event procedures were added for the followingmodules:

Module Events

Releases l ReleaseFolder_AfterPost

Business
Models

l CanReImportModels

l A set of events (such as _MoveTo, _FieldChange) for the BusinessModel,
BusinessModel_Activity, BusinessModelPath, and BusinessModelFolder
entities.

Business
Components

l CanAddComponentstoTest

l CanRemoveComponentsFromTest

l CanAddFlowsToTest

l CanRemoveFlowsFromTest

l CanDeleteGroupsFromTest

l Component_CanDelete and ComponentFolder_CanDelete. (Separate
CanDelete event syntaxes are now available for components and component
folders.)

l A set of events (such as _New, _FieldChange) for the ComponentFolder
entity.

Test Plan l Test_CanDelete and TestFolder_CanDelete. (Separate CanDelete event
syntaxes are now available for tests and test folders.)

l A set of events (such as _New, _FieldChange) for the TestFolder and
TestConfiguration entities.
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Module Events

Test Lab l RunTests_Sprinter

l TestSet_CanDelete and TestSetFolder_CanDelete. (Separate CanDelete
event syntaxes are now available for test sets and test set folders.)

l A set of events (such as _New, _FieldChange) for the TestSetFolder entity.

Other enhancements include:

l TheGetDetailsPageName event is now supported for all entities, not just defect entities.

l Certain events are no longer supported for new projects, but for purposes of backward
compatibility, are available in upgraded projects (for example, MoveToSubject and
GetNewReqPageName).

For more information, refer to theHP Application Lifecycle Management Administrator Guide.

Changes in Feature Availability
The following features are no longer supported in HP Application Lifecycle Management 11.00:

WinRunner EOL
You can no longer createWinRunner tests in ALM 11.00. However, if you are upgrading from a
previous version of Quality Center, you can still run your existingWinRunner tests.

Defect Customization: Visible Fields in Add Defect Dialog Box
The Visible Fields in Add Defect Dialog Box field in Groups customization is no longer available in
ALM 11.00. To determine which Defect fields are visible, use the Select Fields dialog box from the
Data-hiding tab of the Groups and Permissions page in the Customizationmodule. Alternatively,
you can create a workflow script.

Printing Defects
In the Defects module, you can no longer print defects directly from the Defects Grid. Instead, you
can export defect data, or generate graphs and reports of defect data.

Library Broken Links Verification
The verification of broken links is no longer a part of the baseline creation process in ALM 11.00.
The baseline creation process now automatically includes all the related entities that tests in the
library need in order to run. For more information, see "Library Enhancements" on page 29.

Fixed Columns in the Defects Grid
The option of setting non-scrolling columns displayed in the Defects grid is no longer available.

Add Required Fields to Grid
When adding a test to a test set, or creating or updating a defect, the option to automatically add
required fields to the grid is no longer available. Instead, you can use the Select Columns option to
add the required fields.
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Assigning Existing Sets of Permissions to User Groups
When you create a new user group, you can assign the privileges of an existing user group that has
similar access privileges to those you want to assign to the new group. The option of later resetting
one user group's permissions according to another group's permissions is no longer available.

Adding Users to Projects from a Previous Version
In ALM 11.00, you cannot add users to a project from an earlier version before you upgrade the
project.

Business Process Testing
New HP Application Lifecycle Management 11.00 features are also supported for Business
Process Testing entities. In addition, the Business Process Testing features described below have
been introduced or enhanced in ALM 11.00.

Improved Performance when Running QuickTest Automated Components
To improve performance, business process tests or flows that contain only QuickTest automated
components now compile as QuickTest tests using amechanism called BPT wrapper tests. The
tests and flows are automatically wrapped when the test is executed, without any action on the
user’s part. For more information on running tests with the BPT wrapper test mechanism, refer to
theHP Business Process Testing User Guide.

Enhanced User Interface
The following enhancements weremade to the Business Process Testing user interface:

l The “look and feel” for business process tests and flows in the Test Plan is redesigned. For
example, the flat list of components is now replaced by a tree-like view, enabling you to collapse
and expand groups of components in the tree.

l The Iterations dialog box now provides additional capabilities such as searching for values,
toggling between single andmultiple iteration views, andmore.

Application Area Improvements
Application areas are now standard test resources and are available from the ALM Test Resources
module. As a result, you can easily recognize the components linked to each application area and
each application area’s content (such as object repositories and function libraries).

Improvements include:

l Application areas can now be created in the ALM Test Resources module, without having to
open theQuickTest Professional testing tool. For more information, refer to theHP Business
Process Testing User Guide.

l Component dependencies on application areas can now be viewed.

l Application areas are included in libraries and baselines, and can be compared and imported.

l Application areas (excluding the BusinessComponentTemplate10 template application area)
that are not associated with a component can be deleted from within ALM without having to open
theQuickTest Professional testing tool.
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Test Configurations that Access Static and Dynamic Data
Business Process Testing supports test configurations that access static data and test
configurations that access dynamic data.

l While ALM test configurations access static data at a configuration level, Business Process
Testing configurations can also access different sets of data values for each iteration of each
configuration.

l You can create test configurations for business process tests that access dynamic data.
Dynamic data enable you to run test instances using test configurations based on an external
data resource file, such as Microsoft Excel.

The granularity of requirement coverage is expanded, because a requirement can be covered by a
business process test and several of its test configurations (use cases). Each test configuration
can test different data for a run of the same test script.

For more information, refer to theHP Business Process Testing User Guide.

Criteria
When creating coverage between requirements and business process tests, instead of covering
each requirement only at the level of a test, you can define coverage by a test criterion such as a
business component and/or a flow.

This feature expands the granularity of requirement coverage, allowingmore accurate results to be
propagated to the ALM Requirements module. You can select which components and flows interest
you from the coverage perspective, and only those components and flows affect requirement
coverage calculations.

For more details on test criteria, see theHP Business Process Testing User Guide.

Additional Features in the NewManual Runner—HP Sprinter
In addition to the features listed under "New Manual Runner—HP Sprinter" on page 28, the
following enhanced functionality is available for Business Process Testing:

l the ability to view parameters in your steps

l flows can be expanded and collapsed as any other entity in the test hierarchy

l the ability to navigate to the previous/next components in the Steps sidebar

For more information, refer to theHP Sprinter User Guide, available from the HP Application
Lifecycle Management Adds-ins Page (select Help > Add-ins Page).

Changes in Feature Availability
l The grid view for the Business Components module was removed.

l Parameter types were removed. All parameters are now of type string.

REST-based API Set
There are now ALM REST resources available. For details, see theHP ALM REST API
Reference.

The REST-based API provides a platform-independent way to access ALM data with HTTP
applications and with a browser.
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API and Database Updates
This section describes API updates:

l ALM 11.00 can use Client-Side Deployment so that a client can connect to more than one
instance of ALM. This affects APIs in the following ways:

n TheOTA type library is no longer registered automatically on the client machine. Before
connecting to ALM with anOTA application, register the library for the server by running HP
ALM Client Registration from the ALM Add-ins page. For more information, see the
information about registering ALM on aworkstation in theHP Application Lifecycle
Management Installation Guide.

n The installation of custom test types has changed. See theHP ALM Custom Test Type
Guide.

l The content of theHP Quality Center Entity Dependencies API Reference that was published
with Quality Center has beenmerged into theHP ALM Open Test Architecture Reference. The
dependencies reference is not delivered as a separate help with ALM.

l TheOTA TreeMananager object is now responsible only for the Test Subject tree. For project
lists, use Customization.Lists.

l Rich text fields are now saved as memo fields and not as .DOC files.

l The Site Administration API’s CreateProjectCopy method no longer supports the SA_
PROJECT_CREATION_FORCE_IF_ACTIVE option. A project must be deactivated before it
can be copied.

l The HISTORY table no longer exists. Events are now logged in the AUDIT_LOG and AUDIT_
PROPERTIES tables. There are corresponding changes to OTA.

l New items in the API and database references aremarked with a red tag in the table of contents.
The tag is at the object or table level. Individual fields, methods, and properties are not tagged.

Documentation Library
The following updates weremade to the HP ALM Documentation Library.

New Look
For some user related functionality, the documentation content has been reorganized to enable
quicker access, with feature descriptions divided into topics:

l Use concept topics for background, descriptive, or conceptual information about what a feature
does.

l Use task topics for step-by-step guidance to help you work with the application and accomplish
your goals.

l Use reference topics to look up specific reference information relevant to a particular feature.
This includes understanding user interface elements, such as a window, dialog box, or wizard.
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New Documentation
The following additions have beenmade to the documentation:

l The HP ALM Documentation Library now includes Performance Center documentation. Note
that the previous HP Performance Center Monitor Reference is now incorporated into the new
HP ALM Performance Center Guide. This guide now includes both user and administration
documentation.

l Best Practices Documentation includes the following new guides:

n TheHP ALM Upgrade Best Practices Guide provides methodologies for preparing and
planning your ALM upgrade.

n TheHP ALM Business Models Module Best Practices Guide provides best practices for
working with the new Business Models module.

n TheHP Performance Center of Excellence Best Practices Guide provides best practices for
successfully building and operating Performance Centers of Excellence.

n TheHP PerformanceMonitoring Best Practices Guide provides best practices for monitoring
the performance of applications under test.

l API References now includes a new online HP ALM REST API Reference. You can use the
REST API to access and work with ALM data.

Discontinued Documentation
The following deliverables have been discontinued:

l HP Quality Center Upgrade Preparation Guide: The content of this guide is now available as
part of theHP Application Lifecycle Management Administrator Guide.

l HP Quality Center Entity Dependencies API Reference: The content from this help file is now
available as part of theHP ALM Open Test Architecture Reference.

l HP Business Process Testing Tutorial: Refer instead to the Product FeatureMovies for
Business Process Testing.
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What's New in HP ALM Performance Center
This What’s New guide provides an overview of the features that were introduced or enhanced in
HP ALM Performance Center 11.00. For more information on using HP ALM, refer to theHP ALM
Performance Center Guide.

You can also view video demonstrations of HP ALM Performance Center features by choosing
Help > Product Feature Movies in the ALMmain window.

Administration and LabManagement 40

User Features 41

Standalone Applications 44

FeatureMapping 45

Administration and Lab Management
The following administration enhancements have been added:

Enhanced Project Management
Projects are now created andmanaged on ALM. Themain benefits are:

l The ability to group projects into domains based on various criteria, for example, Line of
Business, Application.

l Flexible project customization that includes adding fields and properties to existing entities.

l Project templates enabling you to define andmaintain a common set of project customizations
for multiple projects.

l Import and export capabilities enabling easy archiving of projects.

Virtual User Days (VUDs)
Performance Center 11.00 provides a new pay-per-use licensingmodel that helps service providers
and enables sporadic testing. VUDs are licensed on a daily basis and can be used for any protocol.

Once a license for a VUD is activated, it can be used for 24 hours for multiple performance tests
and for any protocol. After 24 hours the VUD expires and is deducted from the license.

VUDs can be used as amore flexible licensingmodel or when a temporary license for additional
Vusers is needed. VUDs can also be used when you do not have a permanent license for a
particular protocol.

Improved Host Management
There is now more flexibility in the way hosts are assigned to projects and used in performance
tests (previously known as load tests).
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Merged pools have been removed and instead, any host can be assigned tomultiple pools. This
enhancement facilitates host sharing among projects.

In addition, hosts can be linked to a host pool directly from the pool itself.

Another important enhancement is the Host Properties feature. Using Project Customization, the
list of available properties (for example, location, CPU Power, Memory Size, Software
Installations, and so on) can be defined and can be selected for each host. These properties can be
used when designing performance tests and reserving timeslots to narrow down the automatch
hosts (previously known as virtual hosts) and find an appropriate match.

Enhanced System Health Checks
The new Check Host and Check Server features enable tracking andmaintaining the system's
status. These periodic checks are run automatically and ensure constant monitoring of the
system’s key components. In addition, several automated tasks have been added to locate and fix
any failures that may occur.

Full Redundancy
ALM Performance Center is based on ALM, which supports multiple nodes. Multiple Performance
Center Servers with internal load balancingmechanisms can also be added.

User Features
The following user enhancements have been added: 

Requirements to Defects Traceability
You can now manage performance requirements, and trace their status down to defects. A defect
can be linked directly to a requirement, or to the performance test that covers it.

The following workflow is recommended:

1. Define a performance requirement.

2. Cover the requirement by a performance test.

3. Define the appropriate service level agreement.

4. Link relevant defects to the test runs.

Note: The use of requirements and defects within Performance Center may require additional
licenses.

Timeslot Reservations
The timeslot reservation user interface is now more informative and intuitive and includes the
following improvements:

l The calendar view includes the following enhancements:

n Displays multiple reservations in parallel.

n The ability to view complete details of timeslot reservations, including the allocated hosts,
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from your project and any other project accessible to you.

n Displays dual time zones.

n The ability to select a daily or weekly view.

n Displays a quick view of upcoming reservations.

l Reserving new timeslots includes the following enhancements:

n The ability to define a name for the timeslot.

n The scheduling assistant provides a clear indication of when requested resources are
available.

n Reserves amixture of specific and automatch hosts (previously known as actual and virtual
hosts respectively) in the same timeslot.

n Automatch hosts can be refined using host properties that providemore specific
characteristics about the hosts that are needed.

n There is a new type of timeslot: a maintenance timeslot. This is scheduled by the
Performance Center administrator in LabManagement and is used to allocate hosts for
maintenance tasks such as patch installations.

l Error handling includes the following enhancements:

n Comprehensive and detailed information in case of allocation problems.

n Timeslot failure generates email notifications.

n Changes to a performance test are automatically propagated to a timeslot linked to the
performance test.

l A grid view is available with more advanced filtering and sorting capabilities.

For details, see theHP Application Lifecycle Management User Guide.

Application Under Test (AUT) Management
This feature introduces the capability to manage an inventory of application under test (AUT) hosts.
The AUT hosts can be grouped into AUT host pools, similar to Performance Center hosts and host
pools.

The AUT hosts are a core element of the new Topology and SiteScope integration features. As
such, they can be added not only in LabManagement, but also in the ALM project itself.

For details, see theHP ALM Performance Center Guide.

Topology and SiteScope Integration
ALM Performance Center can now articulate the Application Under Test topology (deployment
view) and use it as an interface for defining performancemonitors using the new integration with HP
SiteScope.

Key added value introduced:

l All stakeholders in the project can visually understand the tested environments.

l Monitor template deployment facilitates monitor configuration.
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l Runtime performance issues are pinpointed by highlighting a topology node's status based on
the SiteScopemonitor threshold.

l New and improved SiteScope integration:

n The SiteScope user interface is hosted in ALM Performance Center, enabling leveraging
SiteScope functionality in a use-case oriented approach, without requiring additional monitor
configuration on the Performance Center side.

n Ability to control whether or not to runmonitors outside the context of the performance test.
This contributes to the scalability of the SiteScope server, and reduces network noise when
no tests are running.

n SiteScope data is displayed in different graphs in the Performance Center run screen and
measurement names can be easily identified and filtered.

For details, see theHP ALM Performance Center Guide.

Enhanced Performance Test Assets Management
Management of performance testing assets (tests, scripts, andmonitors) has been improved and
includes the following enhancements:

l Manages your assets in a hierarchal folder tree view.

l Manages test execution cycles.

l Copies all testing assets within and between projects.

l Uses version control to track changes.

l Manages assets in libraries that are shareable between projects.

l You can now benefit from advancedmanagement of dependencies between testing assets, for
example, performance tests and scripts.

Performance Test Design Enhancements
ALM Performance Center has improved the usability and capabilities provided in the performance
test design phase. The following capabilities and enhancements have been added:

l The ability to select a Controller host for a test.

l The ability to assign properties to hosts (for example, installed on a Citrix client) for allocating
appropriate hosts during a run.

l The ability to assign both automatch (virtual) and specific (actual) hosts in the same test.

l The ability to tag Vuser groups to facilitate test design andmodifications.

l The ability to assignmultiple scripts to a test simultaneously.

l Runtime Settings: The ability to manage Additional Attributes in ALM Performance Center.

l J2EE/.NET Diagnostics Integration (HP Diagnostics 9.0 only): The ability to filter probes using
the health status field.

l Enhanced test summary view.

l Service Level Agreements (SLAs):
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n The ability to measure a Transaction Percentile SLA.

n The ability to set decimal-valued thresholds.

n The ability to measure an unlimited number of transactions in the SLA.

n The ability to view a report that displays the SLA status.

Start Run
The following enhancements have beenmade to the Start Run process:

l The process now covers more test initialization steps, such as host allocation.

l Performance tests now start faster than before.

l Performance tests can be cancelled in the initialization phase if a critical error occurs.

For details, see theHP ALM Performance Center Guide.

My Performance Center
My Performance Center is an additional view which provides an interface specifically designed for
test execution. It allows you to create a personalized view of performance testing features,
facilitating execution of day-to-day performance testing activities.

For details, see theHP ALM Performance Center Guide.

Standalone Applications
The following standalone application enhancements have been added: 

VuGen and Protocols
New protocols and features have been added, and enhancements have beenmade to existing
features:

l Ajax TruClient. A new advanced protocol for modern JavaScript-based applications, including
Ajax. The protocol emulates user activity within aWeb browser. Scripts are developed
interactively in Mozilla Firefox.

l Silverlight. A new protocol for Silverlight-based applications emulating user activity at the
transport level. This protocol allows the generation of high-level scripts by automatically
importing and configuringWSDL files used by the application.

l Java over HTTP. A new protocol designed to record Java-based applications and applets. This
protocol produces a Java language script usingWeb functions, and is distinguished from other
Java protocols in that it can record and replay Java remote calls over HTTP.

l Data Format Extension (DFE). A new feature that enhances data format capabilities for the
Web (HTTP/HTML) protocol family. This feature allows the conversion of raw HTTP traffic into
amaintainable and structured XML format, and enables correlations by XPATH.

l Correlation Studio. This Web (HTTP/HTML) automatic correlationmechanism has been
enhanced to search for possible correlations in the larger scope of snapshot data created during
code generation, including data formatted by DFE.

HP ALM (11.50)Page 44 of 50



HP ALM What's New
Chapter 4: What's New in HP ALM Performance Center

l Snapshot View. New snapshot view for theWeb (HTTP/HTML) protocol steps enables viewing
complete HTTP traffic in both raw and DFE generated formats.

For more information, refer to theHP Virtual User Generator User Guide.

Analysis
The following enhancements weremade to HP Analysis:

Area Enhancement

Reporting
capabilities

l Fully customizable report templates that allow you to control the
content and format of a report.

l Exports the report to different formats, such as Word, Excel, PDF, or
HTML, for any reporting purpose.

l The Analysis Session template enables you to associate multiple
report templates, each in a different time range.

l Automatically generates reports upon creation of Analysis data via
standalone Analysis.

Service Level
Agreement (SLA)

l Added the Transaction percentile SLA type.

l Sets decimal threshold values.

Usability l Filters the graph legend, graph data, or raw data by any column by
using wildcards and 'like' statements.

l Filters a graph before opening it.

Note: This may reduce the Analysis process footprint when
working with large sessions.

l WholeMeasurement names in the graph legend in the HTML report
are now visible.

l Enhanced user interface for managing Analysis session templates.

For more information, refer to theHP LoadRunner Analysis User Guide.

Feature Mapping
This section includes mapping information that enables you to locate HP Performance Center 9.5x
features in HP ALM Performance Center 11.00.

Performance Center 9.5x Administration Site Feature Mapping
The following table shows the location of Performance Center 9.5x Administration site features in
ALM Performance Center 11.00 LabManagement. For information on how to log in to Lab
Management, refer to theHP ALM Performance Center Guide.
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Feature Performance Center
9.5x Module

HP ALM Performance Center 11.00 Lab Management

Hosts Resources On the LabManagement sidebar, under Lab Resources,
select Hosts.

MI Listeners Resources On the LabManagement sidebar, under Lab Resources,
selectMI Listeners.

Host
Locations

Resources On the LabManagement sidebar, under Lab Resources,
select Locations.

Host Pools Resources On the LabManagement sidebar, under Lab Resources,
select Host Pools.

Servers Resources On the LabManagement sidebar, under Lab Resources,
select PC Servers.

Test Runs Site Management On the LabManagement sidebar, under Lab Resources,
select Test Runs.

Timeslots Site Management On the LabManagement sidebar, under Lab Resources,
select Timeslots.

Autostart
Viewer

Site Management l Past autostart performance tests. On the Lab
Management sidebar, under Lab Usage, select Test
Runs.

l Future autostart performance tests. On the Lab
Management sidebar, under Lab Usage, select
Timeslots. The future tests can be identified by their
start date.

Event log Site Management l On the LabManagement sidebar, under Lab
Resources, select Hosts.

l On the LabManagement sidebar, under Lab Usage,
select Test Runs.

l On the LabManagement sidebar, under Lab Settings,
select PC Servers.

l In LabManagement common toolbar, select Tools >
Event Log.

License System Configuration On the LabManagement sidebar, under Lab Settings,
select License.

General
Settings

System Configuration In the LabManagement common toolbar, select Tools >
Performance Center General Settings.

Diagnostics System Configuration On the LabManagement sidebar, under Lab Settings,
select Diagnostics.
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Feature Performance Center
9.5x Module

HP ALM Performance Center 11.00 Lab Management

Server
Configuration

System Configuration On the LabManagement sidebar, under Lab Settings,
select Diagnostics.

Server
Authentication

System Configuration Server authentication is now performed using ALM User
Management functionality.

Alerts
Configuration

System Configuration Monitoring is now performed by an internal periodic check
host mechanism that replaces SiteScope.

Reports Reports On the LabManagement sidebar, under Lab Usage, select
Usage Reports

l Two new reports are available:

n VUDs License Project Usage Report

n VUDs License Site Usage Report

l TheSite Users Report is no longer available.

Personal
Details

User Management In the ALM Project, select Tools > Customize > User
Properties.

Users User Management In the ALM Project, select Tools > Customize > Project
Users.

Roles &
Privilege
Management

User Management In the ALM Project, select Tools > Customize > Groups
and Permissions.

Projects User Management Add project:You create projects in Site Administration.
For information about accessing Site Administration, refer
to theHP Application Lifecycle Management Administrator
Guide.

Project information: To define project settings, on the
LabManagement sidebar, under Lab Settings, select
Project Settings.

Performance Center 9.5x User Site Feature Mapping
The following table shows the location of Performance Center 9.5x User site features in ALM
Performance Center 11.00. For information on how to start ALM, refer to theHP Application
Lifecycle Management User Guide.
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Feature Performance
Center 9.5x
Module

HP ALM Performance Center 11.00

Status >
General

Project Only available in Performance Perspectives. For more information
on Performance Perspectives, refer to theHP ALM Performance
Center Guide.

Status >
Dashboard

Project On the ALM sidebar, underRequirements, select
Requirements. Then select View > Coverage Analysis.

Note: This is not an exact reproduction of the Performance
Center Dashboard. In ALM Performance Center 11.00:

l Transaction level status can only be viewed in the SLA
report.

l Youmust define the requirements in order to get full status
information.

Hosts Project On the ALM sidebar, under Lab Resources, select Hosts.

Timeslots Project On the ALM sidebar, under Lab Resources, select Timeslots.

Topologies On the ALM sidebar, under Lab Resources, select Topologies.

Note: Topologies is a new feature.

Vuser
Scripts

Project On the ALM sidebar, under Testing, select Test Plan.

Note: A table detailing basic information for all the scripts in
the project is not available. To view information for an
individual script, select Script Folder > <desired script>.
The information displays in the upper right hand pane.

Monitor
Profiles

Project On the ALM sidebar, under Testing, select Test Resources.

Autostart
Viewer

Project l Past autostart performance tests. On the ALM sidebar,
under Testing, select Test Resources.

l Future autostart performance tests. On the ALM sidebar,
under Lab Resources, select Timeslots. The future tests can
be identified by their start date.

Options Project On the ALM sidebar, under Tools, select PC Project Settings.

Change
Project

Project On the ALM sidebar, under Tools, select Change Project.
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Feature Performance
Center 9.5x
Module

HP ALM Performance Center 11.00

Manage Load Tests On the ALM sidebar, under Testing, select Test Plan.

Test Runs Load Tests On the ALM sidebar, under Testing, select the Test Runs tab.

Trend
Reports

Load Tests On the ALM sidebar, under Testing, select Test Lab. Then select
the Test Runs tab and click thePerformance Trending button

.

Personal
Details

User
Management

In the common toolbar, select Tools > Customize > User
Properties.

Users User
Management

In the common toolbar, select Tools > Customize > Project
Users.

Roles User
Management

In the common toolbar, select Tools > Customize > Groups
and Permissions.

Projects Not available in ALM Performance Center 11.00.

Privilege
Management

User
Management

In the common toolbar, select Tools > Customize > Project
Users.

Downloads Miscellaneous In the common toolbar, select Tools > Download Standalone
Applications.

What's New Miscellaneous In the common toolbar, select Help > What's New.
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