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Documentation Updates

The title page of this document contains the following identifying information:
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• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a 
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Support

Visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As 
a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many 
also require a support contract.  To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
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Welcome to This Guide

This guide describes how to use the System Availability Management (SAM) 
application to monitor system availability across the entire enterprise 
infrastructure from a centralized, real-time perspective.

This chapter includes:

➤ How This Guide Is Organized on page 12

➤ Who Should Read This Guide on page 12

➤ How Do I Find the Information That I Need? on page 13

➤ Additional Online Resources on page 15

➤ Documentation Updates on page 16
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How This Guide Is Organized

The guide contains the following parts:

 Part I SAM Administration

Describes how to work with SAM Administration including how to 
register, configure, and maintain multiple SiteScopes, how to globally 
search and replace any of the properties of the selected object across your 
SiteScopes, and how the Monitor Deployment Wizard provides a 
monitoring solution for existing BSM configuration item (CI) data using 
SiteScope templates.

It also describes how to configure SiteScope as a data collector for Business 
Service Management (BSM), how to send events and report metrics to HP 
Operations Manager (HPOM) and BSM’s Operations Management, and 
how to send events and report metrics to Network Node Manager i 
(NNMi).

 Part II SAM Reports

Describes how to view and analyze reports based on the performance data 
collected by the SiteScope data collector and stored in the BSM database. 
It also describes how to use the SAM event log to display SiteScope events.

Who Should Read This Guide

This guide is intended for the following users of BSM:

➤ BSM administrators

➤ BSM application administrators

➤ BSM data collector administrators

➤ BSM end users

Readers of this guide should be knowledgeable about enterprise system 
administration, infrastructure monitoring systems, and SiteScope, and have 
familiarity with the systems being set up for monitoring. In addition, 
readers who are integrating with BSM should be familiar with BSM and 
enterprise monitoring and management concepts.
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How Do I Find the Information That I Need?

This guide is part of the HP Business Service Management Documentation 
Library. This Documentation Library provides a single-point of access for all 
Business Service Management documentation.

You can access the Documentation Library by doing the following:

➤ In Business Service Management, select Help > Documentation Library.

➤ From a Business Service Management Gateway Server machine, select 
Start > Programs > HP Business Service Management > Documentation.

Topic Types
Within this guide, each subject area is organized into topics. A topic 
contains a distinct module of information for a subject. The topics are 
generally classified according to the type of information they contain.

This structure is designed to create easier access to specific information by 
dividing the documentation into the different types of information you 
may need at different times. 
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Three main topic types are in use: Concepts, Tasks, and Reference. The topic 
types are differentiated visually using icons.

Topic Type Description Usage

Concepts Background, descriptive, or 
conceptual information. 

Learn general information 
about what a feature does.

Tasks Instructional Tasks. Step-by-
step guidance to help you 
work with the application and 
accomplish your goals. Some 
task steps include examples, 
using sample data. 

Task steps can be with or 
without numbering:

➤ Numbered steps. Tasks that 
are performed by following 
each step in consecutive 
order.

➤ Non-numbered steps. A list 
of self-contained operations 
that you can perform in any 
order.

➤ Learn about the overall 
workflow of a task.

➤ Follow the steps listed in 
a numbered task to 
complete a task.

➤ Perform independent 
operations by 
completing steps in a 
non-numbered task.

Use-case Scenario Tasks. 
Examples of how to perform a 
task for a specific situation.

Learn how a task could be 
performed in a realistic 
scenario.
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Additional Online Resources

Troubleshooting & Knowledge Base accesses the Troubleshooting page on 
the HP Software Support Web site where you can search the Self-solve 
knowledge base. Choose Help > Troubleshooting & Knowledge Base. The 
URL for this Web site is http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software Support accesses the HP Software Support Web site. This site 
enables you to browse the Self-solve knowledge base. You can also post to 
and search user discussion forums, submit support requests, download 
patches and updated documentation, and more. Choose Help > HP Software 
Support. The URL for this Web site is www.hp.com/go/hpsoftwaresupport.

Most of the support areas require that you register as an HP Passport user 
and sign in. Many also require a support contract.

Reference General Reference. Detailed 
lists and explanations of 
reference-oriented material.

Look up a specific piece of 
reference information 
relevant to a particular 
context.

User Interface Reference. 
Specialized reference topics 
that describe a particular user 
interface in detail. Selecting 
Help on this page from the 
Help menu in the product 
generally opens the user 
interface topics.

Look up specific 
information about what to 
enter or how to use one or 
more specific user interface 
elements, such as a 
window, dialog box, or 
wizard.

Troubleshooting 
and Limitations

Troubleshooting and 
Limitations. Specialized 
reference topics that describe 
commonly encountered 
problems and their solutions, 
and list limitations of a feature 
or product area.

Increase your awareness of 
important issues before 
working with a feature, or 
if you encounter usability 
problems in the software. 

Topic Type Description Usage
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To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport user ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

HP Software Web site accesses the HP Software Web site. This site provides 
you with the most up-to-date information on HP Software products. This 
includes new software releases, seminars and trade shows, customer support, 
and more. Choose Help > HP Software Web site. The URL for this Web site 
is www.hp.com/go/software.

Documentation Updates

HP Software is continually updating its product documentation with new 
information.

To check for recent updates, or to verify that you are using the most recent 
edition of a document, go to the HP Software Product Manuals Web site 
(http://h20230.www2.hp.com/selfsolve/manuals).
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1
Introduction to SAM Administration

This chapter includes:

Concepts

➤ SAM Administration Overview on page 20

➤ Licensing Points on page 22

Tasks

➤ How to Manage Multiple SiteScopes in SAM on page 25

Reference

➤ SAM Administration User Interface on page 28

Troubleshooting and Limitations on page 51
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Concepts

SAM Administration Overview

System Availability Management (SAM) Administration is a Web-based, 
centralized solution for accessing SiteScopes from within Business Service 
Management (BSM). (Windows-based and Solaris-based SiteScope 
installations both work with Windows-based or Solaris-based BSM servers.) 

You install SiteScope on designated host machines with access to the 
applications and operating systems to be monitored. SiteScope collects key 
performance measurements and reports topology on a wide range of back- 
and front-end infrastructure components, including Web, application, 
database, and firewall servers. For details on installing SiteScope, see the 
HP SiteScope Deployment Guide PDF.

SAM Administration enables you to register, configure and maintain your 
SiteScope servers. You can configure and manage multiple SiteScopes from 
within SAM Administration. You can configure SiteScope monitors, alerts, 
and reports and make any other configuration changes for the SiteScope. All 
the configuration changes that are done from SAM Administration are 
reflected in the SiteScope itself.

SAM Administration enables you to:

➤ Add SiteScopes to SAM Administration. For user interface details, see 
"New SiteScope Page" on page 38.

➤ Copy group, monitor, report, and alert instances from one SiteScope to 
another SiteScope using copy/paste. For details on this topic, see 
"Copying and Moving SiteScope Objects" in Using SiteScope in the 
SiteScope Help.

➤ Synchronize a SiteScope’s settings with another SiteScope by copying 
settings, preferences, and template files using the Sync SiteScope wizard. 
For user interface details, see "Select Source and Targets Page" on page 45.
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➤ Manage SiteScope monitor metrics that are mapped to indicators in the 
Indicator Assignment repository. You can create, edit, and delete 
assignments for specific monitor types. For user interface details, see 
"Metrics and Indicators Tab" on page 186.

➤ Perform a Global Replace operation across multiple SiteScopes. For details, 
see "Global Search and Replace Wizard" on page 250.

➤ View accessibility information and summary information regarding 
registration status of the SiteScope to BSM, licence points, sample 
reporting rates, monitor run rates and health of the SiteScopes. For user 
interface details, see "System Availability Management Administration 
Page" on page 29.

➤ Run the Monitor Deployment Wizard to deploy monitors onto 
configuration items in BSM’s RTSM (Run-time Service Model). (This 
feature is not available to users accessing SiteScope from Operations 
Manager.) For user interface details, see "Monitor Deployment Wizard" on 
page 203.

Note: This book contains information on SAM topics only. For all other 
topics relating to working with SiteScope, see the SiteScope Help. You can 
access the SiteScope help from SAM Administration by selecting a SiteScope 
instance in the list of SiteScope Servers in the left pane, and then selecting 
Help > Help on this page.
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Licensing Points

The number of license points that you purchase depends on how you plan 
to deploy SiteScope and what level of systems and services you want to 
monitor.

This section includes the following topics:

➤ "SAM Points" on page 22

➤ "EMS Points" on page 23

SAM Points
The number of license points for SAM corresponds to the number of points 
used by the SiteScope monitor currently enabled and reporting metrics or 
topology to BSM from this SiteScope. SAM points are updated only when 
the next monitor using SAM points runs.

Each monitor uses a different number of points. For details, see "Estimating 
the Number of License Points" in the HP SiteScope Deployment Guide PDF. 

The number of license points used by SiteScope monitors do not include 
Technology Integration Monitor (EMS) points. 
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EMS Points
EMS points (available and used) are counted together with SAM points 
under the System Availability Management Reports and Administration 
license in License Management. For details, see "Licenses" in Platform 
Administration.

EMS points depend on how many integration monitors have been 
configured and on what these monitors monitor.

➤ If you configure an integration monitor to monitor a node and report 
Events or Tickets, then this monitor creates either an EMS Monitor CI 
related to the monitored node, or an EMS Measurement CI related to the 
monitored node, depending on the topology script you created.

➤ If you configure an integration monitor to monitor a node and report 
Metrics, then this monitor creates a SiteScope Monitor CI related to the 
monitored node, or a SiteScope Measurement CI related to the monitored 
node, depending on the topology script you created. In addition, the 
value of the Is EMS attribute of such SiteScope Monitor CI and SiteScope 
Measurement CI, is equal to true.

To calculate the number of EMS points, the SAM License - EMS point TQL 
searches the topology to find how many integration monitors have been 
configured in BSM. 

Example of the SAM License - EMS point TQL:
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EMS Points Calculation

EMS points are calculated as follows:

➤ When one or more EMS Measurement or EMS Monitor CIs are 
monitoring any of the CIs listed below, a license point is added per node, 
independently of the number of CIs monitoring that node: 

➤ When one or more SiteScope Monitor or SiteScope Measurement CIs are 
monitoring any of the CIs listed below, and the CI Type representing 
these monitors has the Is EMS attribute, a license point is added per node, 
independently of the number of CIs monitoring that node: 

If the SiteScope Monitor or SiteScope Measurement CI Type does not 
have the Is EMS attribute, it represents a regular SiteScope monitor whose 
license points are calculated like the other SiteScope monitor’s license 
points and not like the EMS monitors.

For user interface details, see "System Availability Management 
Administration Page" on page 29.

You specify the number of points you want while setting up your license. 
For details on License Management, see "License Management Overview" in 
Platform Administration. 
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Tasks

How to Manage Multiple SiteScopes in SAM

This task describes how to work with SAM to manage multiple SiteScopes.

This task includes the following steps:

➤ "Prerequisites" on page 25

➤ "Add a SiteScope to SAM Administration" on page 26

➤ "Configure integration preferences in SiteScope - optional" on page 26

➤ "Edit metrics-to-indicator mappings - optional" on page 26

➤ "Use the Sync SiteScopes Wizard to update properties - optional" on 
page 26

➤ "Perform a Global Search and Replace - optional" on page 27

➤ "Copy monitoring objects from one SiteScope to another SiteScope - 
optional" on page 27

➤ "View accessibility, license, and monitoring data for all registered 
SiteScopes" on page 27

 1 Prerequisites

➤ You must have at least one SiteScope running in a network location 
that is accessible to the SAM application.

➤ If you are working in BSM, you can download SiteScope from the 
Downloads page in Platform Administration. For user interface details, 
see "Download Components Page" on page 74.
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 2 Add a SiteScope to SAM Administration

Add one or more SiteScope profiles. While entering the information in 
the New SiteScope page, keep the following in mind (note that the 
following fields are mandatory in the Main Settings pane):

➤ Display Name. Enter a name to represent this SiteScope in BSM and 
Operations Manager applications and in SAM Administration.

➤ Host Name. If you are using a BSM with Lightweight Single Sign-on 
enabled (by default), you must enter a fully qualified domain name as 
the host name.

➤ Port Number. The default value is 8080. If the port number used to 
communicate with SiteScope is different than 8080, enter it here.

For user interface details, see "New SiteScope Page" on page 38.

 3 Configure integration preferences in SiteScope - optional

In SiteScope, access the Integration Preferences interface and modify the 
fields as necessary. 

For details, see "Integration Preferences" in Using SiteScope in the SiteScope 
Help.

 4 Edit metrics-to-indicator mappings - optional

You can use the Metrics and Indicators tab in SAM Administration to 
manage metrics mapped from different SiteScope monitors to indicators, 
per monitor type. 

For user interface details, see "Metrics and Indicators Tab" on page 186.

 5 Use the Sync SiteScopes Wizard to update properties - 
optional

You can use the Sync SiteScopes wizard to update the properties of all the 
SiteScopes in SAM Administration. This is useful for copying 
configuration objects, such as templates, alert templates, schedule 
preferences, MIB files, and script files, from one SiteScope to one or 
multiple SiteScopes in your network environment.

For user interface details, see "Sync SiteScopes Wizard" on page 44.
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 6 Perform a Global Search and Replace - optional

Use the Global Search and Replace Wizard to replace values across 
multiple SiteScopes. This is useful for when you must update values 
pertaining to the integration between SiteScope and BSM or for enterprise 
level updates to perform across multiple SiteScopes and large monitoring 
environments.

For task details, see "How to Perform a Global Search and Replace" on 
page 243.

 7 Copy monitoring objects from one SiteScope to another 
SiteScope - optional 

Once you have multiple SiteScopes running in SAM Administration, you 
can copy monitoring and other SiteScope objects from one SiteScope to 
another. You can copy multiple or single groups, monitors, and alerts. 

Right-click the object to be copied and select Copy from the context 
menu. Select the parent object to where you want to copy, right-click and 
select Paste from the context menu. The source and the target can be in 
different SiteScopes.

Note: When copying monitors, groups, or other entities between multiple 
SiteScope instances, tag assignments are lost even if the tags that were 
assigned to the copied entities on the source SiteScope are present on the 
target SiteScope.

 8 View accessibility, license, and monitoring data for all 
registered SiteScopes

The main page of SAM Administration enables you to view the details of 
your multiple SiteScopes.

For user interface details, see "System Availability Management 
Administration Page" on page 29.
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Reference

SAM Administration User Interface

This section includes:

 ➤ System Availability Management Administration Page on page 29

 ➤ New SiteScope Page on page 38

 ➤ Sync SiteScopes Wizard on page 44
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System Availability Management Administration Page

SAM Administration is a portal within BSM that enables you to add 
SiteScope servers to an BSM system and to access those SiteScope servers. 

The SiteScopes are represented as nodes in the tree in the left pane. When 
you select the root node, the right pane displays the SAM functions, 
including summary information for the SiteScopes. When you select a 
SiteScope in the tree, the right pane displays that SiteScope’s Dashboard and 
you can perform any function within the SiteScope.

To access Select Admin > System Availability Management

Important 
information

➤ Each SiteScope is listed by name with an icon 
displaying its current connection status to BSM.

➤ You access the SiteScope server by highlighting the 
name of the server in the list in the left pane.

➤ If a SiteScope is restarted while being accessed in SAM 
Administration, you may get an error and have to 
renavigate to the SiteScope to properly access the 
SiteScope server. 

➤ For topics relating to working with SiteScope, see the 
SiteScope Help which is accessible from SAM 
Administration by selecting a SiteScope instance in 
the list of SiteScope Servers in the left pane, and then 
selecting Help > Help on this page.
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List of SiteScope Servers (left pane)

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

<SiteScope server 
name>

Represents an individual SiteScope server.

The name includes a tooltip that displays the following 
data:

➤ Health. Health status of the SiteScope server 
represented by a status icon.

➤ Mode. Whether the SiteScope is currently hosted by 
the BSM.

➤ Points. The number of license points in use by the 
SiteScope.

➤ Remote server. The number of remote servers being 
monitored by this SiteScope.

➤ Operating system. The type of operating system on 
which the SiteScope is running.

➤ High Availability server. The name of the server used 
by this SiteScope for failover.

Icon accompanying the SiteScope name indicating that 
the SiteScope is registered to BSM and fully accessible 
from SAM Administration. A SiteScope with this status is 
considered ‘hosted’ by BSM.

Icon accompanying the SiteScope name indicating that 
the SiteScope is registered to BSM but not available for 
configuring. A SiteScope with this status reports data to 
BSM but can be configured only when accessing the 
SiteScope standalone.

Icon accompanying the SiteScope name indicating that 
the existing SiteScope profile is empty and there is no 
running SiteScope associated with it.
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Shortcut Menu Options

User interface elements are described below:

Icon accompanying the SiteScope name indicating that 
the integration between BSM and the SiteScope has been 
reset. The profile remains in BSM and can be used to 
prepare history reports. Data, however, is not reported to 
BSM applications.

New SiteScope. Adds a SiteScope. Opens the New 
SiteScope page.

Edit SiteScope. Enables editing the properties of the 
highlighted SiteScope’s connection to this BSM. Opens 
the Edit SiteScope page.

Delete SiteScope. Deletes the highlighted SiteScope 
from this BSM.

Menu Item Description

New SiteScope (When highlighting the root node) Adds a SiteScope to 
the list of SiteScopes that are accessible to this BSM. 
Opens the New SiteScope page.

Edit SiteScope Edits the properties of the highlighted SiteScope’s 
connection to this BSM. Opens the Edit SiteScope page.

Delete SiteScope Deletes the highlighted SiteScope from this BSM.

UI Element Description
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Summary Information (right pane)

When you select the root node, the right pane displays the summary 
information for all the SiteScopes accessed by this BSM. 

User interface elements are described below:

To access Select Admin > System Availability Management and 
select the root node in the left pane.

Important 
information

➤ You access the SiteScope server by highlighting the 
name of the server in the list in the left pane or by 
clicking the name of the SiteScope in the table.

➤ The graphs displayed at the top of the page are a 
summary of all the SiteScopes listed.

UI Element Description

Graph represents the overall health status of the listed 
SiteScopes. Each SiteScope represents its proportionate 
section of all the SiteScopes attached to BSM.

Gauge represents the current monitor points that are in 
use by all the registered and configurable (hosted) 
SiteScopes as opposed to the total points available for 
this installation.

Note: The points displayed are per individual SiteScope. 
You cannot share license points among SiteScopes but 
you can shift a license key from one SiteScope to 
another. Delete the license key from the SiteScope that 
no longer uses that license and enter the same license 
key in the SiteScope that you want to use the license. For 
details on entering license information, see "General 
Preferences Page" in Using SiteScope in the SiteScope 
Help.
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Gauge represents SAM license points information.

The maximum value on the gauge represents the 
number of license points you purchased.

The pointer (needle) represents the number of SAM and 
EMS points that you are currently using. 

If you are using more license points than you purchased, 
the gauge becomes red and the tooltip displays a 
warning. Additionally, a warning message is also 
displayed at the bottom of the page. The warning 
message indicates that the license point limit is 
exceeded.

The tooltip displays the total number of currently-in-use 
SAM points, regular SAM points, and EMS points.

For details on SAM and EMS points, see "Licensing 
Points" on page 22.

Gauge represents the total runs per minute and is 
calculated by taking the sum of all monitor runs per 
minute for all the hosted SiteScopes as opposed to the 
number of hosted SiteScopes times 1000 (the maximum 
number of monitor runs per minute).

Gauge displaying the rate of samples being reported 
from all SiteScopes to BSM. The maximum number of 
samples per minute is determined by the BSM 
deployment.

Reset Column Width. You can adjust the width of the 
table's columns by dragging the borders of the column 
to the right or the left. 

Click to reset the table columns' width to their default 
setting. 

UI Element Description
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SiteScope Summary Table (right pane)

User interface elements are described below:

Select Columns. Opens the Select Columns dialog box 
enabling you to select the columns you want displayed 
in the SiteScope Summary table. For a description of the 
table columns, see "SiteScope Summary Table (right 
pane)" on page 34 and "Optional Columns for SiteScope 
Summary Table" on page 37.

Global Search and 
Replace

Opens the Global Search and Replace Wizard enabling 
you to update properties across multiple SiteScopes. For 
user interface details, see "Global Search and Replace 
Wizard" on page 250.

Sync SiteScopes Opens the Sync SiteScope Wizard enabling you to copy 
preferences, settings, and configuration files between 
SiteScopes. For user interface details, see "Sync 
SiteScopes Wizard" on page 44.

Table Column Description

Display Name Name given to the SiteScope when it was added to SAM 
Administration. Click the link to display that SiteScope's 
Dashboard in the right pane.

Points Used/Total Number of license points currently being used out of the 
total license points available.

Deployed Monitors Number of monitors configured on the specific SiteScope 
server.

Monitors/Minute Number of monitor runs per minutes.

Remote Targets Number of remote servers being monitored by this 
SiteScope.

OS Operating system on which the SiteScope is running.

Version Version of the SiteScope software.

UI Element Description
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HA Status Displays whether the SiteScope Failover Manager 
installation is running or not, and whether the Failover 
Manager is running instead of the primary SiteScope. 

Health Indicates the status of the SiteScope itself. The following 
are the available status levels:

OK. All performance measurements are within the 
OK threshold level.

Warning. At least one performance measurement is 
within the Warning range, but no measurements are 

within the Error or Poor range.

Error/Poor. At least one performance measurement 
is within the Error or Poor range. This indicates 

either of the following:

➤ the performance measurement has a value, but at 
poor quality level

➤ there is no measurement value due to some error

No thresholds breached. No thresholds were 
defined for the monitor, so no status is assigned.

Samples 
Report/Second

Displays the rate, in seconds, of samples reported from 
this SiteScope to BSM.

Table Column Description
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SAM Points Used Displays the number of points used by monitors 
currently enabled and reporting metrics or topology to 
BSM from this SiteScope. SAM points status is checked 
once every five minutes, and is updated whenever 
monitors that report metrics or topology to BSM are 
added or removed. 

This number differs from the Points Used/Total field 
which is the number of points currently in use out of the 
total number of points available for the SiteScope.

Note: SAM points do not include Technology Integration 
Monitor (EMS) points. EMS points (available and used) 
are counted together with SAM points under the System 
Availability Management Reports and Administration 
license in License Management. EMS points are 
calculated according to the number of high level CIs 
created or updated by EMS integrations (Host and 
Application resources are ignored). For details on License 
Management, see "License Management Overview" in 
Platform Administration. For details on EMS points, see 
"Licensing Points" on page 22.

MDW Opens the Monitor Deployment Wizard. You use the 
wizard to deploy monitors from the SiteScope onto 
existing CIs in BSM. For details on this topic, see 
"Monitor Deployment Wizard" on page 203.

License information Displays the number of SAM points used, EMS points 
used, and total SAM points used. 

Total SAM points used = SAM points + EMS points. EMS 
points are points used by Technology Integration 
Monitor. For details, see "Licensing Points" on page 22.

Table Column Description
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Optional Columns for SiteScope Summary Table

User interface elements are described below:

Table Column Description

Host Name Host name or IP address of the machine on which the 
SiteScope is currently running.

Port Number Port number used to communicate with SiteScope.

Default value: 8080

Use SSL Displays whether this SiteScope is using a secure 
communication through HTTPS.

Profile Name Name to identify this SiteScope for BSM operations and 
reports. 

Note: If no value is entered, the Display Name entered in 
the Main Settings is used.

GMT Offset The GMT Offset set for the SiteScope profile used for 
reports and aggregation purposes. 

Failover Host Displays the host name of the SiteScope Failover 
Manager server if one has been installed for this 
SiteScope.

Description Description of this SiteScope as entered when adding the 
SiteScope to SAM Administration.

Last Report Time The last time monitor data was reported to BSM, 
displayed in the format: Day Month Date 
Hours:Minutes:Seconds.

Inaccessible Profile Displays if this SiteScope profile was added to SAM 
Administration without a running SiteScope server 
registered to it. This means that the profile name was 
added to the database but there is no connection to the 
SiteScope from BSM until the actual registration from the 
SiteScope server.

Enable Reporting to 
HP BSM

Displays whether the SiteScope is enabled to forward 
measurements to BSM. 

Gateway server 
name/IP address

Name or IP address of BSM’s Gateway server.
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New SiteScope Page

This page enables you to add an existing SiteScope to this BSM. You can 
determine whether the SiteScope is hosted by SAM or if it just reports data to 
BSM.

SiteScope agent 
machine location 

Displays the location of the SiteScope agent machine. If 
no value is entered, the default is used. 

Default topology 
probe domain

Default domain of the SiteScope topology probe. 

Topology receiver 
port

Topology receiver port used in BSM. 

Topology receiver 
SSL port

Topology receiver SSL port used in BSM.

Topology 
resynchronization 
time interval

Number of days for SiteScope to synchronize topology 
data with BSM. 

The topology information SiteScope reports to BSM is 
synchronized when SiteScope restarts after this time 
interval has been reached.

To access Select Admin > System Availability Management and 
click the New SiteScope button.

Important 
information

➤ Once a SiteScope is added to the SAM page, it is 
assigned a connectivity status.

➤ Only a user who is defined with Administrator 
permissions in SiteScope standalone can add that 
SiteScope to SAM Administration.

See also "System Availability Management Administration Page" 
on page 29

Table Column Description
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Main Settings

User interface elements are described below:

UI Element Description

Display Name Descriptive name representing this SiteScope in SAM 
Administration. This name identifies the SiteScope in the 
list of SiteScopes in the left pane and in the summary list 
in the right pane.

Host Name Host name or IP address of the machine on which 
SiteScope is currently running. 

Note: If the BSM you are using uses Lightweight Singe 
Sign-on (enabled by default), you must enter a fully 
qualified domain name.

Example: lab1.emea.hp
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Port Number Port number used to communicate with SiteScope. 

Default value: 8080

Inaccessible Profile Creates a profile for a SiteScope that is not currently 
accessible from BSM. Creating the profile in this way 
adds the profile name to the database but there is no 
connection to the SiteScope from BSM until the actual 
registration from the SiteScope. Registering a SiteScope to 
an empty profile is done in SiteScope by creating an 
integration setting for BSM in Preferences > Integration 
Preferences.

Example: In the Profile Settings pane, enter a profile 
name for a SiteScope to report data to HP Software-as-a-
Service (HP SaaS). HP SaaS cannot access the SiteScope 
until it has been registered from the SiteScope.

Note: 

➤ Verify that BSM-SiteScope registration is completed 
before editing the relevant profile.

➤ After registering a SiteScope with an inaccessible 
profile to BSM with a load balancing environment, 
you should verify the following when changing the 
inaccessible profile:

➤ Gateway server name/IP address is set to the load 
balancer center host and not to the default Gateway 
Server.

➤ Web Server Use SSL should be selected in Profile 
Settings when BSM uses SSL.

UI Element Description
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Distributed Settings

User interface elements are described below:

Advanced Settings

User interface elements are described below:

UI Element Description

Gateway Server 
name/IP address

The name or IP address of the Gateway Server.

Note: Modify this box only if BSM uses a load balancer. 
In this case, make sure that the URL is the Default Virtual 
Server for Application Users URL (and not the Default 
Virtual Server for Data Collectors URL). This URL can be 
found in Admin > Platform > Setup and Maintenance > 
Infrastructure Settings > Foundations > Platform 
Administration > Host Configuration table.

SiteScope agent 
machine location

SiteScope agent machine location. If no value is entered, 
the default is used. 

Gateway Server 
authentication user 
name

Login user name used to access the Gateway Server. If no 
value is entered, the default is used.

Gateway Server 
authentication 
password

Password used to access the Gateway Server. If no value is 
entered, the default is used.

UI Element Description

SiteScope user name User name needed to connect to the SiteScope. 

Note: SiteScope currently integrates with BSM through 
its admin user account only.  Any attempt to integrate 
using a different SiteScope account will not be successful.

SiteScope password SiteScope login password if the SiteScope you are adding 
has been set up with a password.
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Profile Settings

User interface elements are described below:

Failover Host If SiteScope Failover Manager has been installed for this 
SiteScope, enter the Failover Manager host name.

Note: There is no validation to check if there is a 
SiteScope Failover running on this host.

Description Description for this SiteScope. 

UI Element Description

Use SSL Select to secure the communication of the SiteScope API 
through a secure HTTPS. Selecting this option requires 
you to configure your SiteScope to run with SSL. For 
details, see "Configuring SiteScope to Use SSL" in the 
HP SiteScope Deployment Guide PDF.

Profile name Name to identify this SiteScope for BSM operations and 
reports. If no value is entered, the Display Name entered 
in the Main Settings is used.

GMT offset Select the GMT Offset for the SiteScope profile used for 
reports and aggregation purposes. 

Web server 
authentication user 
name

User name for the authentication (basic authentication 
and protocol) of the Web server security options.

Web server 
authentication 
password

Password for the authentication of the Web server 
security options (basic authentication and protocol).

Web server use SSL Web server uses HTTPS protocol over a secure 
connection.

Proxy name/IP 
address

IP address if SiteScope uses a proxy to connect to the BSM 
server.

Proxy user name User name for the proxy, if SiteScope uses a proxy to 
connect to the BSM server.

UI Element Description
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Topology Settings

User interface elements are described below:

Proxy password Password for the proxy, if SiteScope uses a proxy to 
connect to the BSM server.

Profile database 
name

Select the database (Microsoft SQL) or schema (Oracle) 
into which the profile information is saved.

Enable Reporting to 
BSM

Enables reporting SiteScope measurements to BSM. 

You can clear this option to temporarily disable reporting 
from this SiteScope to BSM. 

Default value: Selected. Can be cleared only in edit mode 
and not when adding a SiteScope.

UI Element Description

Topology 
resynchronization 
time interval

Number of days for SiteScope to synchronize topology 
data with BSM.

The topology information SiteScope reports to BSM is 
synchronized when SiteScope restarts after this time 
interval has been reached. 

Default value: 7 days

Minimum value: 1 day

Note: All topologies created by SiteScope and stored in 
the RTSM are subjected to the aging process. To prevent 
aging, see "Aging of CIs in RTSM" on page 71.

Default topology 
probe domain

Default domain of the SiteScope topology probe.

Note: You must restart SiteScope if you change this 
setting.

UI Element Description
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Sync SiteScopes Wizard

This wizard enables you to synchronize settings from different SiteScopes by 
copying files and settings from one SiteScope to another. 

Topology receiver 
port

Topology receiver port used in BSM. 

Default value: 8080

Note: You must restart SiteScope if you change this 
setting.

Topology receiver 
SSL port

Topology receiver SSL port used in BSM.

Default value: 443

Note: You must restart SiteScope if you change this 
setting.

To access Select Admin > System Availability Management and 
click Sync SiteScopes. 

Important 
information

➤ This wizard can be used to copy the settings 
configured for a SiteScope to another SiteScope. 

➤ To copy groups, monitors, alerts, or reports from one 
SiteScope to another SiteScope, use the Copy and Paste 
to another SiteScope option in the monitor tree’s 
context menu.

Wizard map This wizard contains:

Select Source and Targets Page > Select Types to Sync > 
Select Instances to Sync > Summary Page

UI Element Description
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Select Source and Targets Page
This wizard page enables you to select the source SiteScope from which to 
copy settings, and the target SiteScope to which to copy settings.

 

User interface elements are described below:

Important 
information

➤ General information about this wizard is available 
here: "Sync SiteScopes Wizard" on page 44.

➤ The Select Source and Targets page lists only those 
SiteScopes that:

➤ are version 9.0 or later 

➤ have been added to SAM

➤ are currently accessible to BSM 

Wizard map The Sync SiteScopes Wizard contains:

Select Source and Targets Page > Select Types to Sync > 
Select Instances to Sync > Summary Page

UI Element Description

Source SiteScope Select the SiteScope from which to copy settings or files. 
You can select only one SiteScope from which to copy. A 
SiteScope that has been selected as the source cannot also 
be selected as a target.

Note: Only SiteScopes for which the current user has at 
least view permissions in Permissions Management are 
displayed. For details on this topic, see "Operations" in 
Platform Administration.

Target SiteScope Select the SiteScopes to which to copy settings or files. 
You can select multiple SiteScopes as the target of the 
synchronization. 

Note: Only SiteScopes for which the current user has at 
least view permissions in Permissions Management are 
displayed. For details on this topic, see "Operations" in 
Platform Administration.
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Select Types to Sync
This wizard page enables you to select objects, settings, or files to copy from 
one SiteScope to other SiteScopes. You can copy preferences, views, and 
categories. Only those objects appear that have been configured in the 
source SiteScope.

SiteScope Objects

The following are the objects that can be copied from one SiteScope to other 
SiteScopes:

Important 
information 

➤ General information about this wizard is available 
here: "Sync SiteScopes Wizard" on page 44.

➤ You can use the Select All, Clear Selection, and Invert 
Selection buttons to modify your selections.

Wizard map The Sync SiteScopes Wizard contains:

Select Source and Targets Page > Select Types to Sync > 
Select Instances to Sync > Summary Page

UI Element Description

Category 
(Search/Filter tags in 
SiteScope 10.00 and 
later)

Copy the categories configured in the source SiteScope to 
the target SiteScope. If no categories have been defined in 
the source SiteScope, there are no categories listed here. 
In SiteScope 10.00 and later, categories are know as 
Search/Filter tags and include the same functionality.

For details about using categories (Search/Filter tags) in 
SiteScope, see "Working with Search/Filter Tags" in Using 
SiteScope in the SiteScope Help.

Example: A category defining operating system with 
values of Windows, Linux, and so forth has been defined 
in the source SiteScope. These same categories can be 
copied for use in the target SiteScope.
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Preferences Copy the preferences configured in the source SiteScope 
to the target SiteScope. Only those preferences that have 
been configured in the source SiteScope appear here. If 
no preferences or instances of preference types have been 
defined in the source SiteScope, there are no preferences 
listed here.

The following preferences can be selected for the sync 
operation: 

➤ Email preferences

➤ Pager preferences

➤ SNMP trap preferences

➤ Absolute schedule preferences

➤ Range schedule preferences

For details on types of preferences, see "Preferences 
Menu" in Using SiteScope in the SiteScope Help.

Example: Copy the absolute schedules that have been 
configured in the source SiteScope to the target SiteScope. 
You can then use those same absolute schedules when 
scheduling monitors to run (while configuring or editing 
monitors) in the target SiteScope.

Templates Copy the templates configured in the source SiteScope to 
the target SiteScope. If no templates have been defined in 
the source SiteScope, there are no templates listed here.

For details about working with templates in SiteScope, 
see "SiteScope Templates Overview" in Using SiteScope in 
the SiteScope Help.

UI Element Description
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SiteScope Files

The following are the files that can be copied from one SiteScope to other, 
multiple SiteScopes:

UI Element Description

Script Remote Files Select to copy all the files in the following folder path: 
<SiteScope root directory>\scripts.remote

Mail Reports 
Template Files

Select to copy all the files in the following folder path: 
<SiteScope root directory>\templates.history

Post Template Files Templates that can be selected when creating a post alert 
action. 

Select to copy all the files in the following folder path: 
<SiteScope root directory>\templates.post

OS Template Files Select to copy all the files in the following folder path: 
<SiteScope root directory>\templates.os

Script Files Scripts that can be selected when creating a script alert 
action. 

Select to copy all the files in the following folder path: 
<SiteScope root directory>\scripts

SNMP Template Files Templates that can be selected when creating an SNMP 
trap alert action. 

Select to copy all the files in the following folder path: 
<SiteScope root directory>\templates.snmp

MIB Files Select to copy all the files in the following folder path: 
<SiteScope root directory>\templates.mib

OS Template 
Browsable Files

Select to copy all the files in the following folder path: 
<SiteScope root directory>\templates.os\browsable

Mail Subject 
Template Files

Templates that can be selected when creating an email 
alert subject.

Select to copy all the files in the following folder path: 
<SiteScope root directory>\templates.mail.subject
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Select Instances to Sync
This wizard page displays a tree with all the instances of the type of file or 
object selected in the Select Types to Sync page. You can then select specific 
instances of the file type or object type you want copied from the source 
SiteScope to the target SiteScopes.

Sound Template Files Templates that can be selected when creating a sound 
alert action. They include the media files that create the 
sound for a triggered alert.

Select to copy all the files in the following folder path: 
<SiteScope root directory>\templates.sound

Certificates Template 
Files

Select to copy all the files in the following folder path: 
<SiteScope root directory>\templates.certificates

Mail Template Files Templates that can be selected when creating an email 
alert action.

Select to copy all the files in the following folder path: 
<SiteScope root directory>\templates.mail

Important 
information 

➤ General information about this wizard is available 
here: "Sync SiteScopes Wizard" on page 44.

➤ You can use the Select All, Clear Selection, and Invert 
Selection buttons to modify your selection of file or 
object instances.

➤ When you finish making your selections, click Finish.

Wizard map The Sync SiteScopes Wizard contains:

Select Source and Targets Page > Select Types to Sync > 
Select Instances to Sync > Summary Page

UI Element Description
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

<Files/objects tree> Use the tree to select or clear specific instances occurring 
in the source SiteScope of the file type or object type you 
want to copy to the target SiteScope. The tree lists all 
instances of the selected file type or object type that 
occur in the source SiteScope.

Default value: All instances of every file or object selected 
in the Select Types to Sync page are selected. Clear the 
check box next to an instance to remove it from the sync 
operation.

Override existing 
instances

Select this option for the sync action to override any 
instances of the same name in the target SiteScopes with 
the selected instances.

If this option is cleared and during the sync operation, 
an instance of the object or type with the same name is 
found in the target, the sync operation does not copy the 
instance onto the target SiteScope.

Example: You selected Absolute Schedule Preferences in 
the Select Type to Sync page and the target SiteScope has 
an absolute schedule with the same name as in the 
source SiteScope:

➤ If this option is selected, the target’s absolute schedule 
is overwritten with the properties of the schedule in 
the source SiteScope.

➤ If this option is cleared, the target’s absolute schedule 
maintains its properties and is not overwritten.
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Summary Page
This wizard page displays the number of objects or files successfully copied 
to the target SiteScopes. If any objects or files failed to copy to the target 
SiteScopes, this number is also displayed.

Troubleshooting and Limitations

This section describes troubleshooting and limitations for SAM 
Administration.

This section includes:

➤ "408 error when attempting to access SiteScope user interface from SAM 
Administration" on page 52

➤ "Reverse integration does not work" on page 52

➤ "Page cannot be displayed due to 404 error" on page 52

➤ "Flash components (summary graphs) are not displayed in the SAM 
Administration page" on page 52

➤ "Error while adding a SiteScope to SAM Administration in the Add 
SiteScope page" on page 53

➤ ""Failed to register SiteScope profile" error while trying to add a SiteScope 
in the New SiteScope page" on page 53

➤ "Error while opening the SiteScope user interface when SiteScope is 
unable to access the BSM permissions application" on page 54

➤ "JavaScript errors while opening specific features in a SiteScope hosted 
from BSM when using a Firefox 2.x browser" on page 54

Important 
information 

General information about this wizard is available here: 
"Sync SiteScopes Wizard" on page 44.

Wizard map The Sync SiteScopes Wizard contains:

Select Source and Targets Page > Select Types to Sync > 
Select Instances to Sync > Summary Page
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408 error when attempting to access SiteScope user 
interface from SAM Administration
Possible Solution 1: Add the SiteScope machine’s URL to your Web browser’s 
list of trusted sites and restart all browsers.

Possible Solution 2 (if using Internet Explorer 7): Configure the browser to 
accept cookies from the SiteScope server. 

 1 In Internet Explorer, select Tools > Internet Options > Privacy tab, and 
click the Advanced button.

 2 Select Override automatic cookie handling, make sure First-party cookies 
and Third-party cookies are set to Accept, and select Always allow session 
cookies.

Reverse integration does not work
Possible Solution: Enter the SiteScope machine name in the SiteScope agent 
machine location field when adding a SiteScope to SAM. 

Page cannot be displayed due to 404 error
This error may occur because there is no access from the browser machine to 
SiteScope (pinging the machine also does not work). The SiteScope host may 
be changed to a fully qualified host name after adding the SiteScope to SAM 
Administration.

Possible Solution: If there is no DNS configured for the network, you can 
configure SiteScope to report its IP address to BSM. Open the <SiteScope 
root directory>\groups\master.config file, and enter the SiteScope 
machine’s IP address in the _sisHostNameOverride property.

To solve the problem on the browser’s machine, you can add the SiteScope 
machine name with IP to the host’s file in the 
//WINDOWS/system32/drivers/ directory on the BSM machine.

Flash components (summary graphs) are not displayed in 
the SAM Administration page
Possible solution: Install Flash on the client browser.
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Error while adding a SiteScope to SAM Administration in 
the Add SiteScope page
While adding the SiteScope to SAM Administration, an error occurs and you 
want to change the Display name field to try to add the SiteScope again. The 
Profile name field, which is used in BSM reports, Service Health, and so 
forth, is defined from the Display name field. The Profile name may still 
have the default value from the first time you tried adding the SiteScope.

Possible solution: If you change the Display name field or Host name field 
after an error during initially trying to add the SiteScope, you should change 
all the fields that get their default values from those fields, for example 
Profile name.

"Failed to register SiteScope profile" error while trying to 
add a SiteScope in the New SiteScope page
This message is displayed while trying to add a SiteScope to SAM 
Administration in the New SiteScope page.

Possible Solutions: 

➤ Check that SiteScope is up and running. Try restarting SiteScope to make 
sure it started correctly.

➤ Check for errors in:

➤ <BSM root directory>\log\topaz_all.ejb.log

➤ <SiteScope root directory>\logs\bac_integration\bac_integration*.log.

➤ Make sure the profile database was created before adding a new SiteScope, 
and that BSM can access the SiteScope server and port.
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Error while opening the SiteScope user interface when 
SiteScope is unable to access the BSM permissions 
application
The following error message is displayed: "The SiteScope interface failed to 
open because SiteScope was unable to access BSM's permissions application 
using http://<your BSM server>/topaz/ url. SiteScope needs this access to 
build the permission model before granting access to the SiteScope interface. 
Check your network configuration and verify that SiteScope can access 
Business Service Management."

Possible Solution 1: Check your network configuration.

Possible Solution 2: Add the IP address of the BSM server to the etc\hosts 
file on the SiteScope machine.

Possible Solution 3: If BSM is configured with an SSL deployment, 
configuring SiteScope as described in "Configuring SiteScope for Mutual SSL 
Configuration" in the HP SiteScope Deployment Guide PDF.

JavaScript errors while opening specific features in a 
SiteScope hosted from BSM when using a Firefox 2.x 
browser
When SiteScope is hosted from BSM, the following features may not work 
when using a Firefox 2.0.x browser: Opening help pages, diagnostic tools, 
reports, copying between SiteScopes, Monitor Deployment Wizard, and the 
Publish Templates PDF report.

Possible Solution: Use Firefox 3.x or an Internet Explorer browser.
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2 
Working with BSM

This chapter includes:

Concepts

➤ Understanding How SiteScope Communicates with BSM on page 56

➤ Configuring the Connection on page 58

➤ Integrating SiteScope Data with BSM’s Configuration Items on page 59

➤ Reporting Discovered Topologies to BSM on page 66

➤ Accessing SiteScope and Building Permissions Model on page 69

➤ CI Downtime on page 71

Tasks

➤ How to Configure the Integration Between SiteScope and BSM on page 74

➤ How to Connect SiteScope to a BSM Server That Requires SSL on page 83

➤ How to Connect SiteScope to a BSM Server That Requires a Client 
Certificate on page 84

➤ How to Configure Topology Reporting on page 85

Reference

➤ Monitors Not Reporting Topology Data By Default on page 89

➤ Monitors Reporting CI Per Metric on page 90

Troubleshooting and Limitations on page 91
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Concepts

Understanding How SiteScope Communicates with BSM

SiteScope can be used as a data collector for Business Service Management 
(BSM). BSM uses data about end-users, business processes, and systems.

When configured as a data collector for BSM, the metrics and topology data 
collected by SiteScope monitors can be passed on to BSM for analysis and for 
use in reports. Monitor data can be sent for all monitors or for selected 
monitors only. 

The following diagram illustrates the use of SiteScope as a data collector for 
BSM.
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Note: The BSM integration should not be confused with the integration 
using the HP Operations agent, which is required for displaying metrics data 
in the Performance Perspective tab in BSM’s Operations Management or in 
HPOM. For details on collecting metrics using the HP Operations agent, see 
"Reporting Metrics Using the HP Operations Agent" on page 111. 

BSM includes a System Availability Management (SAM) Administration 
page, that enables you to manage SiteScope monitor configurations for one 
or more SiteScope servers through a central console. After activating the 
BSM integration, SiteScope data flows to BSM regardless of whether you 
manage SiteScopes through SAM Administration or the SiteScope 
standalone user interface.

For the SiteScope releases that are compatible with BSM, refer to the Support 
Matrices section in the BSM release notes.

Tip: For best practices and troubleshooting for reporting metrics data to BSM 
and HPOM, see Best Practices for the SiteScope-Business Service 
Management/Operations Manager Integration in the SiteScope Help. 
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Configuring the Connection

To enable the connection between SiteScope and BSM, the SiteScope must 
be configured as a data collector for BSM. This involves adding a SiteScope 
to the SAM Administration page in the BSM. For details on this task, see 
"How to Configure the Integration Between SiteScope and BSM" on page 74.

For details on configuring integration preferences, see "Integration 
Preferences Page" in Using SiteScope in the SiteScope Help.

For information about troubleshooting reporting data to BSM, see 
"Troubleshooting and Limitations" on page 91.

Using SSL for SiteScope-BSM Communication 
You can use Secure Sockets Layer (SSL) to transmit data from SiteScope to 
the BSM server. If you have installed a certificate signed by a root Certificate 
Authority on the BSM server, no additional setup is required on the 
SiteScope server. 

If you are using a self-signed certificate on the BSM server and want to use 
that certificate for secure communication with SiteScope, you must perform 
the steps as described in "Configure SiteScope to connect to a BSM server 
that requires a client certificate or SSL - optional" on page 77.

Changing the Gateway Server to Which SiteScope Sends 
Data
You can change the Gateway Server to which a SiteScope reports its data. 
Generally, this is only applicable if you are working with a BSM deployment 
with components installed on more than one server (in the case of a 
distributed deployment where the BSM Gateway Server is installed on a 
different machine to the Data Processing Server). 

For details on making this change, see "Change the Gateway Server to which 
SiteScope sends data - optional" on page 78.
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Integrating SiteScope Data with BSM’s Configuration 
Items

When a monitor instance is added to a SiteScope reporting data to BSM, that 
monitor creates a corresponding configuration item (CI) in Run-time Service 
Model (RTSM). For details on understanding configuration items, see 
"Configuration Items (CI)" in the RTSM Administration Guide. 

The SiteScope monitors that populate RTSM include both actual monitors 
and the groups in which they are created. 

➤ Actual monitors instances are represented in RTSM as monitor CIs. 
Monitor CIs receive data from the corresponding SiteScope monitor 
instance and use the data, along with health indicators (HIs) and event 
type indicators (ETIs) that are assigned to SiteScope monitor metrics, to 
calculate key performance indicator status. These indicators provide a 
more detailed view of the health of a CI. For details on understanding 
indicators, see "Health Indicators, KPIs, and KPI Domains" in Service 
Health. 

➤ SiteScope groups are represented as group CIs in RTSM and receive KPI 
status from the monitor CIs created by the monitors they are running.

Monitor Types and Topology Reporting

SiteScope reports different levels of topology data to RTSM depending on 
the type of monitor and the options selected for the monitor. SiteScope 
forwards the topology to create or update a CI under the following 
conditions:

➤ When the CI is created in SiteScope for the first time as a result of the 
monitor retrieving data, regardless of whether the CI exists in RTSM.

➤ If there were any changes to any of the CI's properties.

This prevents overloading RTSM with CI updates coming from the monitor.

When working with specific monitors, you do not select a topology and the 
topology is preconfigured with the necessary data for the integration.
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The types of monitors are as follows:

➤ Technology Integration Monitors. These monitors report data based on 
the topology settings script you select and edit for the monitor. The data 
they report is tightly integrated with BSM. You can create a custom 
topology or use a predefined script to forward the relevant data. For 
details on these monitors and how to work with their topology settings, 
see "Topology Settings for Technology Integration Monitors" in Using 
SiteScope in the SiteScope Help.

➤ Monitors of Supported Environments. For these supported environments, 
SiteScope acts like a discovery probe when the monitor is created or its 
configuration is changed. When topology reporting is enabled, SiteScope 
automatically discovers the application’s topologies and populates RTSM 
with the relevant CIs and monitor CIs. For details and a list of supported 
environments, see "Reporting Discovered Topologies to BSM" on page 66. 

You can create a custom topology for monitors of a supported 
environment (except for monitors where the CI type is per metric as 
described in "Monitors Reporting CI Per Metric" on page 90). For details 
on creating a topology, see "How to Configure Topology Reporting" on 
page 85.

➤ Monitors Not Reporting Topology Data By Default. SiteScope includes 
monitors that do not report hosts or servers and, therefore, it is not 
possible to know the CI type that is being monitored in advance. To 
include topology data for these monitors when reporting to BSM, you 
must select the CI type, define CI type key attributes, and map metrics 
related to the monitor type to specific indicators. SiteScope then creates a 
CI for the monitor in RTSM and forwards monitor CI data to BSM. For the 
list of monitors that do not have a default topology defined, see 
"Monitors Not Reporting Topology Data By Default" on page 89. For 
details on how to create a topology for these monitors, see "How to 
Configure Topology Reporting" on page 85.
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This section also includes:

➤ "Creating Relationships Between Monitors and CIs" on page 61

➤ "Aging of CIs in RTSM" on page 62

➤ "Managing Indicator Assignments in System Availability Management" on 
page 63

➤ "Assigning SiteScope Metrics to Indicators" on page 63

➤ "When are Health Indicators Created" on page 64

➤ "Discovery Scripts and the Package Manager" on page 64

➤ "Topology Script Properties File" on page 65

➤ "Topology Reporting Limitation" on page 66

Creating Relationships Between Monitors and CIs
You can also create relationships between SiteScope monitor CIs and 
existing CIs in RTSM. This relationship enables the monitor to pass HI status 
information to the CI to which it is attached, even if that CI was not created 
from a topology forwarded by SiteScope.

You can create these relationships in SiteScope or in SAM Administration. 
For details, see task step "Create relationships between SiteScope monitors 
and existing CIs in RTSM - optional" on page 80.
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Aging of CIs in RTSM
In RTSM, CIs that have had no activity over a period of time are removed 
from the database. The CIs created from SiteScope data are also subject to 
this aging policy. To prevent the aging policy from acting on CIs that 
SiteScope has sent to BSM, SiteScope synchronizes the data it sends to BSM. 
The synchronization refreshes the data for those CIs and creates activity on 
the CIs.

For details on setting the time interval for topology synchronization, see 
"Topology Settings" on page 43. For details on the aging mechanism, see 
"Working with CIs" in the Modeling Guide. 

Note: 

➤ Synthetic monitors and groups created by the EMS integration monitors 
that use Measurement field mapping are subject to the aging process 
regardless of the synchronization.

➤ To prevent CIs for EMS integration monitors being removed from RTSM 
when aging is enabled, EMS topology is resent during a hard 
synchronization of SiteScope. In addition, you can enable topology 
resending as part of an anti-aging process by adding the property 
_reportEmsCIsAsPartOfAntiAging=true to the 
<SiteScope root directory>\groups\master.config file.

➤ If you delete a CI from RTSM you must perform a resynchronization or a 
hard synchronization of SiteScope (in Integration Preferences), or you 
must wait for a restart of SiteScope so the CI is restored to RTSM. This is 
due to the CI cache in SiteScope that prevents SiteScope from sending an 
unchanged CI twice. For details, see "BSM Preferences Available 
Operations" in Using SiteScope in the SiteScope Help.
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Managing Indicator Assignments in System Availability 
Management

Note: This section is relevant only to those users connecting to SiteScope 
version 11.00 or later.

SiteScope metrics that are mapped to indicators, are stored and managed in 
the Indicator Assignments repository in SAM Administration. For details on 
the Indicator Assignments repository, see "Indicator Assignment Settings" on 
page 167. 

Assigning SiteScope Metrics to Indicators

Note: This section is relevant only to those users connecting to SiteScope 
version 11.00 or later.

When configuring monitor instances, you can also map a metric to an 
indicator. Indicators provide a more detailed view of the health of a CI when 
SiteScope is reporting data to BSM. SiteScope monitor metrics are mapped to 
indicators on a monitor type basis as follows: 

➤ Monitors of supported environments and monitors that have a defined 
topology have indicators assigned to metrics by default. For details of 
these monitors, see "Monitor Types and Topology Reporting" on page 59. 
For the list of default indicator assignments, see "Indicator Mapping 
Alignment" on page 173.

➤ For SiteScope monitors that do not have a defined topology, there are no 
default indicator mappings, since these monitors can be linked to 
different CI types, and a single mapping cannot be set. For these 
monitors, you can map metrics to the appropriate indicators for the CI 
type linked to the monitor. For a list of monitors that do not have a 
defined topology, see "Monitors Not Reporting Topology Data By Default" 
on page 89.
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You can change the default metrics mappings in SiteScope. If indicator 
mappings are modified locally in SiteScope, these mappings are not 
overridden by the centralized repository mappings when SiteScope 
downloads the latest mappings from BSM. This enables you to:

➤ Override indicators for a monitor instance or some metrics of a monitor. 

➤ Configure non-default indicators in templates. Note that the CI type for 
custom topology and metric mappings is not configurable through 
variables in templates (they should be predefined in a template).

➤ Configure indicators for alerts. Since the CI type of a triggered alert is not 
always known when configuring an alert for groups or for Monitors 
Reporting CI Per Metric, you can manually enter the indicator and 
indicator state for an alert. For details, see "HP Operations Manager 
Integration Settings" in Using SiteScope in the SiteScope Help.

For task details on mapping SiteScope metrics to indicators, see "Map 
Indicators to monitors" on page 87. 

For user interface details, see "Indicator Settings" in Using SiteScope in the 
SiteScope Help.

When are Health Indicators Created

➤ Events in SiteScope are based on SiteScope monitor metric status changes 
and alerts being triggered. Events are created after the first event arrives to 
the CI. For more details, see "Event Generation" on page 105.

➤ Metrics are created when the monitor topology is reported to RTSM. For 
more details, see "Reporting Discovered Topologies to BSM" on page 66.

Discovery Scripts and the Package Manager
The scripts that enable SiteScope to act as a discovery probe are stored on 
the BSM server in the SiteScope package. When SiteScope is configured to 
discover an application’s topology, SiteScope downloads the appropriate 
script from the BSM server. It then uses the script to perform the discovery 
while monitoring the application.
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The SiteScope package includes scripts and other SiteScope-related RTSM 
resources, such as views and enrichments. You can access this package in 
BSM in Admin > RTSM Administration > Administration > Package Manager. 
The package is a factory package, meaning that the out-of-the-box 
configurations for the package enable it to perform the discoveries in 
SiteScope. For details on working with packages, see "Package 
Administration Overview" in the Modeling Guide.

Note: Advanced users may want to modify the topology scripts within the 
package. Be warned that the SiteScope package uses scripts from other 
packages which may be shared by SiteScope and Data Flow Management. 
Any changes made to the scripts in the package can also affect Data Flow 
Management.

Any changes made to the topology script that influence the way a topology 
is reported to BSM can affect all the applications that use those topologies, 
including BSM applications and Operations Management.

Topology Script Properties File
If you are working in a secure  installation that has a certificate, you may 
have to insert the following line into the <SiteScope root 
directory>\discovery\discovery_agent.properties file: 
appilog.agent.Probe.BasicAuth.Realm=authRealm.

Where authRealm is a variable for Basic Authentication Realm. If you want 
to find out what realm a given URL belongs to, you can open the URL with a 
Web browser and see the first line in the popup box.

Note: When you modify the discovery_agent.properties, you must restart 
SiteScope to enable your changes to take effect.
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Topology Reporting Limitation
The number of characters in SiteScope group and monitor descriptions that 
can be reported to BSM is limited to 600 characters. If a group or monitor 
description contain more than this number, SiteScope truncates the 
description to the first 600 characters.

Reporting Discovered Topologies to BSM

SiteScope can act as a discovery probe and discover the hierarchy of the 
monitored entities of selected environments. These hierarchies are 
represented by topologies that SiteScope reports to BSM. The CIs within the 
topologies correspond to the hosts, servers, and applications that SiteScope 
monitors, and are created in BSM’s RTSM. Monitor and measurement CIs are 
also created and SiteScope reports their status to BSM. The relationships 
between the CIs are defined by the topology reported by SiteScope.

You enable this feature by selecting the Report monitor and related CI 
topology option under the HP Integration Settings panel when creating or 
configuring a monitor instance. If this option is cleared, the CIs that were 
created in RTSM are not automatically deleted. If there is no activity on the 
CI, they are eventually removed from the database through aging or they 
must be manually deleted.

For details on the Topology Settings user interface, see "Topology Settings" 
on page 43.

For troubleshooting problems involving topology reporting, see "Business 
Service Management Topology Issues" in Best Practices for the SiteScope-
Business Service Management/Operations Manager Integration in the SiteScope 
Help.
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Supported Environments

This direct connection between SiteScope and BSM is available for selected 
environments only. SiteScope reports specific topologies for the following 
monitors:

Environment/
Monitor Type

Monitors

Monitors 
Reporting 
Node 
Topology

This includes all monitors that report the status of a host or 
server (other than Technology Integration monitors and the 
supported environments listed below) that can forward 
topology data to BSM using a predefined CI type such as Node, 
Computer, or some other child CI type derivative. When 
topology reporting is enabled, SiteScope forwards the topology 
along with monitor CI data to BSM. For details on this option, 
see "HP Integration Settings" in Using SiteScope in the SiteScope 
Help.

Note: This does not include monitors that do not monitor the 
status of a host or server, since it is not possible to know the CI 
type that is being monitored in advance. For the list of monitors 
without host data, see "Monitors Not Reporting Topology Data 
By Default" on page 89.

Database 
Environments

➤ "DB2 8.x and 9.x Topology" (see Monitor Reference in the 
SiteScope Help)

➤ "Microsoft SQL Server Topology" (see Monitor Reference in the 
SiteScope Help)

➤ "Oracle Database Topology" (see Monitor Reference in the 
SiteScope Help)

ERP/CRM 
Application 
Environments

➤ "SAP CCMS Topology" (see Monitor Reference in the SiteScope 
Help)

➤ "SAP Work Processes Topology" (see Monitor Reference in the 
SiteScope Help)

➤ "Siebel Application Server Topology" (see Monitor Reference in 
the SiteScope Help)

➤ "Siebel Web Server Topology" (see Monitor Reference in the 
SiteScope Help)

Server 
Environments

"Dynamic Disk Space Monitor" (see Monitor Reference in the 
SiteScope Help)



Chapter 2 • Working with BSM

68

SOA 
Environments

"Web Service Topology" (see Monitor Reference in the SiteScope 
Help)

Virtualization 
Environments

➤ "Solaris Zones Topology" (see Monitor Reference in the 
SiteScope Help)

➤ "VMware Performance Topology" (see Monitor Reference in the 
SiteScope Help)

➤ "VMware Host Monitor Topology" (see Monitor Reference in 
the SiteScope Help)

Web server 
Environments

➤ "Microsoft IIS Server Topology" (see Monitor Reference in the 
SiteScope Help)

➤ "WebLogic Application Server Topology" (see Monitor 
Reference in the SiteScope Help)

➤ "WebSphere Application Server Topology" (see Monitor 
Reference in the SiteScope Help)

Environment/
Monitor Type

Monitors
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Accessing SiteScope and Building Permissions Model

Note: This section is relevant only to those users accessing SiteScope from 
SAM Administration in BSM.

SAM Administration builds a permissions model for each BSM user accessing 
SiteScope. The permissions model is based on the BSM user's permissions for 
SiteScope objects and not on the user’s permissions as defined in SiteScope. 

When assigning permissions to users in BSM for accessing a SiteScope 
through SAM Administration, be aware that the permissions in BSM have 
been mapped to the equivalent permissions in SiteScope. The permissions 
model maps between the types of permissions available in SiteScope to what 
can be granted in BSM. 

There are several differences between the BSM permissions model and 
SiteScope standalone permissions:

➤ BSM permissions enables granting permissions per group instance. In 
SiteScope standalone, permissions are granted onto groups as an object 
and do not have the instance granularity that exists in BSM. 

For example, a user can have permissions within BSM to view or change 
specific instances of SiteScope groups with no permission to access other 
SiteScope groups. 

➤ SiteScope enables specific types of permissions onto object types, such as 
the ability to enable/disable whereas in BSM the operations are standard 
for all objects and include view, change, add, and full control. In this case, 
enable/disable is mapped to BSM’s change permission. 
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➤ When granting a BSM user change permissions for SiteScope objects, you 
also need to define on which group to grant permissions. This is because 
SiteScope checks if the user has change permissions for the object type 
and then checks the user has permissions on the specified group. 

For example, to give a BSM user change permissions for SiteScope 
monitors under a specified group, open the SiteScope Content under 
System Availability Management permissions (in Platform Administration 
> Users and Permissions > User Management > Permissions > System 
Availability Management context) and change the permissions on the 
group which contains the monitors you want to change (select the group 
and under Permissions > Operations, and select Change permissions). 
This allows you to change monitor settings under the specified group 
only. If you want the user to be able to change all monitors in SiteScope 
and not just under the specified group, you need to do this for every 
group in SiteScope. For more details, see "How to Configure Users and 
Permissions — Workflow" in Platform Administration.

Note: When you grant permissions to a top level group, those 
permissions are automatically granted to all its descendant groups.

➤ When applying permissions in BSM onto SiteScope objects, you can hover 
over an operation to see a description of how it maps to the permissions 
available to users of SiteScope standalone. 

➤ Only a user at the Administrator level in SiteScope standalone has the 
necessary permissions to add a SiteScope to SAM Administration in BSM.
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CI Downtime

Note: This section is relevant only to those users connecting to SiteScope 
version 11.00 or later.

Downtimes are defined and managed in BSM using the Downtime 
Management page in Platform Administration. For details about configuring 
downtime, refer to "Downtime Management — Overview" in Platform 
Administration.

SiteScope is affected by downtime if a SiteScope monitor, measurement, or 
group CI is directly linked to a CI that BSM detects is in downtime. 

Monitors affected by a CI that is currently in downtime do not go into 
downtime immediately. The time that it takes for the monitors to go into 
downtime is affected by two configuration parameters:

➤ The interval between SiteScope queries to BSM for downtime requests (the 
default downtime retrieval frequency value is 15 minutes). This can be 
modified in SiteScope in Preferences > Infrastructure Preferences > 
General Settings > BSM downtime retrieval frequency (minutes).

➤ The interval between the updates of the SiteScope downtime cache in 
BSM (the default value is 5 minutes). This can be modified in BSM in 
Admin > Platform > Setup and Maintenance > Infrastructure Settings: 

➤ Select Applications. 

➤ Select End User/System Availability Management.

➤ In the Downtime table, locate SiteScope Downtime Cache Update 
Interval. Change the value to the required cache update interval.
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The action that is taken in SiteScope during the downtime depends on the 
downtime configuration in BSM. Downtime can be enforced on the 
following:

➤ Alerts. No alerts are sent for any of the CIs associated with the downtime. 

➤ Reports. Reports are not updated and display the downtime for the CI.

➤ KPIs. KPIs attached to the CI are not updated and display the downtime 
for the CI in Service Health.

➤ Monitoring. SiteScope monitoring stops for any of the CIs associated with 
the downtime. 

A monitor that is in downtime is indicated in the SiteScope Dashboard 
Summary column by "disabled by <Downtime Name> from BSM". Details of 
downtimes that are associated with the monitor and are currently taking 
place are displayed in the Monitor Downtime table in the Enable/Disable 
Monitor panel. For details, see "Enable/Disable Monitor" in Using SiteScope in 
the SiteScope Help. 

If the monitor is affected by a CI that is currently in downtime and the 
downtime applies to associated alerts of the monitor, downtime details are 
displayed in the Associated Alerts Downtime table in the Enable/Disable 
Associated Alerts panel. For details, see "Enable/Disable Associated Alerts" in 
Using SiteScope in the SiteScope Help.
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Notes and Limitations

➤ When SiteScope queries BSM for downtime requests, it gets the 
downtimes for the downtime period (up to a maximum of 24 hours). A 
record is written to the audit.log in the <SiteScope root directory>\logs 
directory which includes new downtimes, changes to existing downtimes, 
and deleted downtimes.

➤ When SiteScope 11.00 or later is connected to BSM, the downtime 
mechanism is enabled by default. To change the default setting, clear the 
Enable downtime mechanism check box in SiteScope’s Preferences > 
Infrastructure Preferences > General Settings.

➤ Downtime is not supported for SAP, Siebel, or SOA topologies (regardless 
of whether the Application Management for Siebel/SAP license is 
installed).

➤ For monitors that report the CI per metric, when a CI connected to a 
metric is in downtime, this sends the monitor to which the metric 
belongs into downtime. This is applicable to the "VMware Performance 
Monitor" and "Solaris Zones Monitor". For details, see Monitor Reference in 
the SiteScope Help.

➤ Downtime information is not available in System Availability 
Management reports. 

➤ When SiteScope is connected to BSM 9.10, downtime on the SiteScope 
profile is upgraded to downtime on the hosts and software elements that 
are monitored by the SiteScope profile monitors and measurements. 

➤ For additional troubleshooting relating to CI downtime, see "Business 
Service Management CI Downtime Issues" in Best Practices for the SiteScope-
Business Service Management/Operations Manager Integration in the 
SiteScope Help.
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Tasks

How to Configure the Integration Between SiteScope 
and BSM

This task describes how to configure the integration between SiteScope and 
BSM.

This task includes the following steps:

➤ "Prerequisites" on page 75

➤ "Download and install SiteScope" on page 75

➤ "Connect the installed SiteScope with BSM" on page 76

➤ "Configure SiteScope to connect to a BSM server that requires a client 
certificate or SSL - optional" on page 77

➤ "Change the Gateway Server to which SiteScope sends data - optional" on 
page 78

➤ "Create a monitoring structure in SiteScope" on page 79

➤ "Create relationships between SiteScope monitors and existing CIs in 
RTSM - optional" on page 80

➤ "Map SiteScope metrics to indicators - optional" on page 81

➤ "Assign permissions in BSM" on page 81

➤ "Modify the connection settings - optional" on page 82
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 1 Prerequisites

➤ You must be an administrator in SiteScope to integrate SiteScope with 
BSM. For details on user permissions, see "User Management Preferences 
Overview" on page 928.

➤ Prepare a plan that maps out the specific IT infrastructure resources whose 
data you want to collect. Include information about the business 
processes that are affected by the specified infrastructure components. For 
example, business processes being monitored by Business Process 
Monitor, that are running on an application server against which you 
plan to run SiteScope monitors. 

Note: When connecting SiteScope with BSM 9.x, the HPOprInf, 
HPOprMss, HPOprOra, and HPOprJEE content packs are required (they 
are installed by default, so you generally do not need to do anything). If 
you do not have these content packs, you need to import them as 
described in "How to Create and Manage Content Packs".

 2 Download and install SiteScope

In BSM, navigate to Admin > Platform > Setup and Maintenance, and 
click Downloads. Download and save the SiteScope installation files (for 
Windows or Solaris) to a local or network drive.

Install SiteScope on machines designated to run the SiteScope data 
collector. You can run multiple SiteScopes from multiple platforms. For 
more information, see the HP SiteScope Deployment Guide PDF.
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 3 Connect the installed SiteScope with BSM

In BSM, navigate to Admin > System Availability Management, and add 
the SiteScope to SAM Administration. For user interface details, see "New 
SiteScope Page" on page 38. 

➤ If you are connecting to a BSM Server different from the one to which 
SiteScope reports data (for example, where the BSM Gateway Server is 
installed on a different machine to the Data Processing Server), you 
must provide connection information for both servers under 
Distributed Settings in SAM Administration’s New SiteScope Page (or 
under the BSM Integration Main Settings in SiteScope’s Integration 
Preferences).

➤ To change logging options, edit a specific monitor and select the 
relevant option in the HP Integration Settings panel of the monitor 
properties page. For details, see "HP Integration Settings" in Using 
SiteScope in the SiteScope Help. You can use the Global Search and 
Replace wizard to update the logging options on those monitors 
created before the integration was established. For details on the 
wizard, see "Global Search and Replace Wizard" on page 250.

➤ Monitors created in SiteScope before registration to BSM have their 
logging option set to Disable reporting to BSM. After you configure 
SiteScope as a data collector reporting to BSM, the default for new 
monitors created in SiteScope is to log their monitoring data to BSM.

Note: 

➤ If you are working with a SiteScope that is not accessible to BSM (for 
example in HP Software-as-a-Service), the procedure for the 
connection includes creating an empty profile in SAM Administration 
and creating an Integration Preference for BSM in SiteScope. For task 
details, see "How to Configure SiteScope-BSM Integration Preferences 
for Inaccessible Profiles" in Using SiteScope in the SiteScope Help.

➤ When working under high load, you should suspend all monitors 
before connecting to BSM for the first time. 
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 4 Configure SiteScope to connect to a BSM server that requires 
a client certificate or SSL - optional

If you are using a certificate on the BSM server and want to use that 
certificate for secure communication with SiteScope, you must perform 
the appropriate step below:

➤ For a BSM server that requires SSL, see "How to Connect SiteScope to a 
BSM Server That Requires SSL" on page 83.

➤ For a BSM server that requires a client certificate, see "How to Connect 
SiteScope to a BSM Server That Requires a Client Certificate" on 
page 84.

Note: 

➤ You must specify these settings only if the certificate installed on the 
BSM machine is not signed by a root Certificate Authority (CA). For 
example, if you are using a certificate signed by a Certificate Authority 
like Verisign, you do not need to change these settings.

➤ You can import the self-signed certificate into the same keystore file 
used for other SiteScope monitors but that is not required. You can 
create a separate keystore for the BSM server certificate.

➤ The machine name in the certificate must be a fully qualified domain 
name that is exactly the same name (including case sensitive) as the 
one used in the New SiteScope page in System Availability 
Management Administration.
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 5 Change the Gateway Server to which SiteScope sends data - 
optional

You can change the Gateway Server to which a SiteScope reports its data. 
Generally, this is only applicable if you are working with a BSM 
deployment with components installed on more than one server. 

➤ In SiteScope’s BSM Integration Preferences, enter the required Gateway 
Server name or IP address in the Business Service Management 
machine name/IP address box. For user interface details, see "BSM 
Integration Preferences Dialog Box" in Using SiteScope in the SiteScope 
Help.

➤ In SAM Administration, update the SiteScope settings with the 
Gateway Server name in Distributed Settings. For user interface details, 
see "New SiteScope Page" on page 38.

Note: This can only be used for changing the Gateway Server for a 
SiteScope that is already registered with a given BSM installation. It 
cannot be used to add a new SiteScope, or to connect a SiteScope to a 
different BSM system.
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 6 Create a monitoring structure in SiteScope

 a Create groups and subgroups to organize the monitors to be deployed, 
and then create monitors in these groups. When configuring 
monitors, verify that BSM data logging and topology settings are set as 
required. 

For details on creating a monitoring structure, see "How to Configure 
SiteScope for Monitoring" in Using SiteScope in the SiteScope Help.

 b Configure SiteScope to report metrics and to send events to BSM. 

➤ For details on configuring BSM metrics integration, see "BSM 
Integration Data and Topology Settings" in Using SiteScope in the 
SiteScope Help.

Note: For details on configuring the metrics integration using the 
HP Operations agent, which is required to display metrics data in 
the Performance Perspective tab in BSM’s Operations Management 
and in HPOM, see "How to Enable SiteScope to Report Metrics to the 
HP Operations Agent" on page 140.

➤ For task details on enabling SiteScope to send events to BSM, see 
"How to Enable SiteScope to Send Events to HPOM or BSM" on 
page 115.
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 7 Create relationships between SiteScope monitors and 
existing CIs in RTSM - optional

You can create relationships to enable a monitor to pass HI status 
information to the CI to which it is attached (even if that CI was not 
created from a topology forwarded by SiteScope):

➤ In SiteScope, you can customize the relationship between SiteScope 
monitor CIs and existing CIs by manually selecting the CI type option 
in HP Integration Settings when editing a monitor instance. The CI 
type is defined by default for monitors of supported environments and 
monitors that have a defined topology. For task details, see "Select the 
CI type" on page 86.

➤ In SAM Administration, by using the Monitor Deployment Wizard 
which uses the existing CI property data in RTSM to deploy SiteScope 
monitors, groups, and remote servers. This creates in RTSM a 
monitored by relationship between the monitored CI and the created 
monitor. For concept details, see "Monitor Deployment Wizard 
Overview" on page 204.

Once defined, the SiteScope and its groups and monitors are added as CIs 
to RTSM and are automatically attached to the relevant monitor views, 
from where they can be added to other views. When editing a monitor in 
SAM Administration, you can associate the monitor with existing CIs 
using HP BSM Integration Settings. For example, you can attach the CPU 
monitor to an existing logical CI representing a machine whose CPU is 
being monitored.

The data from the SiteScope is available in Service Health and Service 
Level Management.
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 8 Map SiteScope metrics to indicators - optional

In SiteScope, you can add mappings for monitors that do not have default 
indicator metric mappings, or modify settings for existing mappings 
(monitors of supported environments and monitors that have indicators 
mapped to metrics by default).

For task details, see "Map Indicators to monitors" on page 87.

 9 Assign permissions in BSM

In BSM, navigate to Admin > Platform > Users and Permission, and click 
User Management.

For each defined user, assign permissions to view SiteScope groups and 
their subgroups in SAM reports and custom reports. For details, see 
"System Availability Management" in Platform Administration.

For details on how permissions are applied, see "Accessing SiteScope and 
Building Permissions Model" on page 69.
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 10 Modify the connection settings - optional

After you have created the connection, you can modify the settings either 
in SiteScope or in BSM, depending on the setting that you are modifying.

➤ In BSM, select Admin > System Availability Management. In the list of 
SiteScopes, right-click the relevant SiteScope and select Edit SiteScope 
from the context menu. For user interface details, see "New SiteScope 
Page" on page 38.

➤ In SiteScope, open the Preferences context and select Integration 
Preferences. Edit the BSM Integration Preference. For user interface 
details, see "BSM Integration Preferences Dialog Box" in Using SiteScope in 
the SiteScope Help.

Tip: 

➤ To secure the connection to BSM (since the BSM user name and 
password are not used for authentication), it is recommended to 
configure either Basic Authentication in SiteScope or use two-way SSL. 
If BSM is configured to use Basic Authentication, the same user name 
and password entered in the Authentication user name and 
Authentication password fields in SiteScope are used for reporting 
both data and topology to BSM. If BSM is not configured to use Basic 
Authentication, the credentials sent are ignored.

➤ To enable data to be compressed before being sent from the SiteScope 
server to BSM, set _topazCompressDataInGzip=true in the <SiteScope 
root directory>\groups\master.config file. When enabled, SiteScope 
monitor (ss_monitor_t) and SiteScope metric (ss_t) samples are 
compressed in gzip before being sent to BSM (where it is 
decompressed). 
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How to Connect SiteScope to a BSM Server That Requires 
SSL

This task describes the steps involved in enabling secure communication 
between SiteScope and BSM when the BSM server requires SSL.

 1 Import the CA or BSM server certificate into SiteScope using Certificate 
Management in the SiteScope user interface. For task details, see "How to 
Import Server Certificates Using Certificate Management" in Using 
SiteScope in the SiteScope Help.

Note: The machine name in the certificate must be a fully qualified 
domain name that is exactly the same name (including case sensitive) as 
the one used in the New SiteScope page in System Availability 
Management Administration.

 2 In BSM, select Admin > System Availability Management Administration, 
and click the New SiteScope button to add the SiteScope instance. In the 
New SiteScope page, make sure the following settings are configured:

➤ Distributed Settings: Check that the Gateway Server name/IP address 
contains the correct server name and port (default 443).

➤ Profile Settings: Select the Web Server Use SSL check box.
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How to Connect SiteScope to a BSM Server That Requires 
a Client Certificate

This task describes the steps involved in enabling secure communication 
between SiteScope and BSM when the BSM server requires a client 
certificate.

 1 Obtain the client certificate in JKS format and copy it to the 
<SiteScope root directory>\templates.certificates folder. 

For details on configuring SiteScope to connect to a BSM server that 
requires a client certificate, see "Configuring SiteScope to Connect to a 
BSM Server That Requires a Client Certificate" in the HP SiteScope 
Deployment Guide PDF. 

Note: Make sure that the private key password is at least 6 characters long, 
and that the private key and keystore passwords are the same. 

 2 Edit the master.config file in the <SiteScope root directory>\groups 
using a text editor. Add the following entries with the data indicated:

_urlClientCert=<keystoreName>

_urlClientCertPassword=<keystorePassword>

For example:

 3 Save the changes to the file.

 4 Restart the SiteScope server.

_urlClientCert=.ks
_urlClientCertPassword=changeit 
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How to Configure Topology Reporting

Note: Only advanced users with a thorough knowledge of CIs and indicators 
should attempt to edit the indicator mappings or to add mappings to 
metrics.

This task describes how to configure topology settings for monitors. It also 
describes how to select or modify the CI type and map metrics to indicators. 

This task includes the following steps:

➤ "Prerequisites" on page 85

➤ "Select the CI type" on page 86

➤ "Map Indicators to monitors" on page 87

➤ "Select a preference for influencing BSM Service Health when events and 
metrics are reported to BSM - optional" on page 87

➤ "Results" on page 88

 1 Prerequisites

➤ If BSM requires a client certificate, you must configure the topology 
discovery agent in SiteScope to report topology to the BSM server. For 
details, see "Configuring the Topology Discovery Agent in SiteScope 
When BSM Server Requires a Client Certificate" in the HP SiteScope 
Deployment Guide PDF. 

➤ For SiteScope to forward the host topology along with monitor CI data to 
BSM, the Report monitor and related CI topology option must be selected 
under the HP Integration Settings panel in the monitor properties. By 
default, this option is selected for monitors of supported environments 
and monitors that have a CI type defined by default. For user interface 
details, see "BSM Integration Data and Topology Settings" in Using 
SiteScope in the SiteScope Help.
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 2 Select the CI type

For monitors that report a topology by default (the default CI type 
associated with the monitor is displayed in parenthesis in the CI type list), 
you can use the default selection, or override the selection by modifying 
the CI type and entering key attributes.

For monitors that do not report a topology by default, select the CI type 
for the monitor in the BSM Integration Data and Topology Settings 
section, and enter values for the CI type key attributes. For the list of 
monitors that do not report a topology by default, see "Monitors Not 
Reporting Topology Data By Default" on page 89.

Note: For monitors where the CI type is per metric (for the list of 
monitors, see "Monitors Reporting CI Per Metric" on page 90), the CI type 
cannot be modified and CI key attributes are not displayed.

Tip: It is recommended to perform a resynchronization of SiteScope if 
BSM is restarted within 10 minutes after making changes to a monitor's 
topology settings. To do so, select Preferences > Integration Preferences > 
BSM Integration > BSM Preferences Available Operations, and click 
Re-Synchronize.

For user interface details, see "BSM Integration Data and Topology 
Settings" in Using SiteScope in the SiteScope Help.
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 3 Map Indicators to monitors

When a CI type is selected, the table in the Indicator Settings section is 
filtered to show indicator settings for the selected CI type. Monitors of 
supported environments and monitors that have a defined topology have 
indicators mapped to metrics by default. You can add new metric 
mappings or edit settings for existing mappings.

For monitors that do not have default indicator metric mappings, you can 
map metrics to the appropriate indicators for the CI type linked to the 
monitor. For the list of default indicator assignments, see "Indicator 
Mapping Alignment" on page 173.

For concept details, see "Assigning SiteScope Metrics to Indicators" on 
page 63.

For user interface details, see "Indicator Settings" in Using SiteScope in the 
SiteScope Help.

 4 Select a preference for influencing BSM Service Health when 
events and metrics are reported to BSM - optional

Since SiteScope events and metrics can affect BSM’s Service Health, select 
the preference for influencing Service Health when both data types are 
reported. Select the preference in the BSM Service Health Preferences 
section of HP Integration Settings. For user interface details, see "BSM 
Service Health Preferences" in Using SiteScope in the SiteScope Help.

This preference is relevant only when:

➤ Both BSM and HP Operations Manager integrations are active.

➤ The HP Operations Manager event integration is connected to the BSM 
server—not the HPOM server.

➤ The following settings are selected in the monitor’s HP Integration 
Settings:

➤ In the BSM Integration Data and Topology Settings section: Enable 
reporting monitor status and metrics or Enable reporting monitor 
status and metrics with thresholds.

➤ In the HP Operations Manager Integration Settings section: Send 
events.
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Note: 

➤ The preference can also be set globally for each newly-created monitor 
in Integration Preferences > HP Operations Manager Integration > HP 
Operations Manager Integration Main Settings. For user interface 
details, see "HP Operations Manager Integration Main Settings" in 
Using SiteScope in the SiteScope Help.

➤ For more information on choosing the preference to use, see 
"Integrating SiteScope with Business Service Management 
Applications" in Best Practices for the SiteScope-Business Service 
Management/Operations Manager Integration in the SiteScope Help.

 5 Results

After configuring the topology settings click Save. SiteScope creates a CI 
for the monitor in RTSM and forwards monitor CI data to BSM.
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Reference

Monitors Not Reporting Topology Data By Default

Following is a list of monitors that do not monitor the status of a host or 
server. 

Note: For these monitors to report CI information to BSM, you must select 
the CI type, enter the required CI key attributes, and select an indicator 
relevant for the CI type linked to the monitor. For task details, see "How to 
Configure Topology Reporting" on page 85.

➤ Composite

➤ Directory

➤ e-Business Transaction

➤ File

➤ Formula Composite

➤ HP NonStop Event Log

➤ JMX (when not monitoring WebLogic)

➤ Link Check Transaction

➤ Log File

➤ Microsoft Windows Dial-up

➤ Microsoft Windows Media Player

➤ Multi Log File

➤ Network Bandwidth

➤ Real Media Player

➤ Script

➤ SNMP Trap
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➤ URL

➤ URL Content

➤ URL List

➤ URL Sequence

➤ XML Metrics

Monitors Reporting CI Per Metric

Following is a list of monitors that report CI per metric. These monitors 
have multiple CIs; hence the CI for these monitors cannot be modified and 
indicator mappings for these monitor types can be modified only from BSM 
(SAM Admin > Metrics and Indicators tab).

➤ SAP CCMS

➤ SAP Work Processes

➤ Siebel Application Server

➤ Siebel Web Server

➤ Solaris Zones

➤ VMware Host CPU

➤ VMware Host Memory

➤ VMware Host Network

➤ VMware Host State

➤ VMware Host Storage

➤ VMware Performance

Note: You can define a custom topology Node for the monitor and specify a 
host name for it. If there is a remote server in any SiteScope connected to 
this BSM, this CI is automatically changed to Unix or Windows CI type, 
depending on the environment of the remote server.
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Troubleshooting and Limitations

This section describes troubleshooting and limitations for BSM integrations.

➤ "Accessing SiteScope from SAM Administration Using Internet Explorer 7" 
on page 91

➤ "Reporting Data to BSM" on page 92

➤ "SiteScope-BSM Integration Troubleshooting" on page 93

Accessing SiteScope from SAM Administration Using 
Internet Explorer 7
When accessing SiteScope from SAM Administration using Internet Explorer 
7, a 408 Request Timeout error is displayed.

Workaround: To be able to log on to SiteScope from BSM, configure the 
browser to accept cookies from the SiteScope server.

 1 In Internet Explorer, select Tools > Internet Options > Privacy tab, and 
click the Advanced button.

 2 Select Override automatic cookie handling, make sure First-party cookies 
and Third-party cookies are set to Accept, and select Always allow session 
cookies.
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Reporting Data to BSM
Due to the complexity of some monitoring deployments and network 
communications, SiteScope may be temporarily unable to communicate 
with the BSM server. SiteScope Health monitoring includes several monitors 
for watching connectivity and data transfers to the BSM server.

If SiteScope is unable to connect to the BSM Server, SiteScope continues to 
record and store monitor data files locally. After the number of data files 
exceeds a specified threshold, SiteScope saves the data files in a cache folder 
with the syntax 
<SiteScope_root>\cache\persistent\topaz\data<index>.old. You can 
configure the number of data.old folders to keep by modifying the 
_topazMaxOldDirs property in the 
<SiteScope root directory>\groups\master.config file.

Note: By default, the threshold number of data files is set to 1,000 files. You 
can change this setting by modifying the _topazMaxPersistenceDirSize 
property in the master.config file.

After the connection between SiteScope and the Agent Server is restored, 
you must manually copy the files from these folders to the 
<SiteScope root directory>\cache\persistent\topaz\data folder. 

Tip: We recommend that you only copy these files when the data folder is 
empty to avoid overloading the system with large amounts of data to 
upload. When the number of data.old folders exceeds a specified threshold, 
by default 10 folders, the oldest folders are deleted.
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SiteScope-BSM Integration Troubleshooting
For troubleshooting issues related to SiteScope-BSM metrics integration, CI 
topology reporting, and CI downtime, see "Troubleshooting SiteScope 
Integration Issues" in Best Practices for the SiteScope-Business Service 
Management/Operations Manager Integration in the SiteScope Help. 
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3
Working with Operations Manager and 
BSM Using the HP Operations Agent

This chapter includes:

Concepts

➤ Understanding How SiteScope Communicates with HPOM and BSM 
on page 96

➤ Sending Events on page 102

➤ Reporting Metrics Using the HP Operations Agent on page 111

Tasks

➤ How to Enable SiteScope to Send Events to HPOM or BSM on page 115

➤ How to Enable SiteScope to Report Metrics to the HP Operations Agent 
on page 140

Reference

➤ SiteScope-Operations Agent Metrics Alignment on page 143

➤ Sizing Recommendations for SiteScope-Operations Manager Metrics 
Integration on page 147
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Concepts

Understanding How SiteScope Communicates with 
HPOM and BSM

Note: This section is relevant only to those users connecting SiteScope 11.00 
or later with HP Operations Manager (HPOM) products or to BSM. 

SiteScope, as a standalone application, is an agentless solution for IT 
infrastructure performance and availability monitoring. SiteScope can also 
work together with HP Operations Manager (HPOM), HP Performance 
Manager (a reporting component of HPOM), and Operations Management 
in BSM, to provide a powerful combination of agentless and agent-based 
infrastructure management. 

SiteScope communicates with these applications using the HP Operations 
agent, which is installed on the SiteScope server. The HP Operations agent 
enables SiteScope to integrate both event and metrics data.

➤ Events. The HP Operations agent sends event data to the HPOM 
management server, or to BSM for use in Operations Management, Service 
Health, and Service Level Management. Events in SiteScope are based on 
SiteScope monitor metric status changes and alerts being triggered. For 
details on enabling event reporting, see "Sending Events" on page 102.

➤ Metrics. The HP Operations agent also acts as a data storage for metrics 
data collected by SiteScope. This enables SiteScope to make metrics data 
directly available to Performance Manager (an HPOM reporting 
component) and to the Performance Perspective tab in BSM’s Operations 
Management. For details on enabling metrics reporting, see "Reporting 
Metrics Using the HP Operations Agent" on page 111. 

The combined functionality of SiteScope and HPOM provides an effective 
and in-depth monitoring solution. For more details on using HPOM, refer to 
the HPOM documentation.
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Note: 

➤ Metrics integration using the HP Operations agent (where metrics data is 
used in the Performance Perspective tab in Operations Management) 
should not be confused with the BSM integration where SiteScope 
monitor metrics are used by the various BSM applications to calculate CI 
status (for example, in Service Health, Service Level Management, and 
System Availability Management). For details on BSM metrics 
integration, see "Working with BSM" on page 55. 

➤ Metrics integration using the HP Operations agent is supported by 
SiteScopes running on Windows and UNIX platforms for HPOM and 
Operations Management.

➤ For the HP Operations agent version supported in this release, refer to the 
HP SiteScope Support Matrices section in the release notes (in SiteScope, 
select Help > What’s New?).

Tip: For best practices and troubleshooting for reporting metrics data to BSM 
and HPOM products using the HP Operations agent, see Best Practices for the 
SiteScope-Business Service Management/Operations Manager Integration in the 
SiteScope Help.

This section contains the following topics:

➤ "Event and Metrics Flow Diagram" on page 98

➤ "HP Operations Agent Topology" on page 99

➤ "SiteScope Failover Manager and Operations Manager Integration" on 
page 100

➤ "Classic SiteScope Failover and Operations Manager Integration" on 
page 101
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Event and Metrics Flow Diagram
The following diagram illustrates the metrics data and event flow between 
SiteScope and the HPOM and BSM applications. 
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HP Operations Agent Topology
HP Operations agent CIs are created when SiteScope is connected to HPOM, 
and HPOM is connected to BSM. 

When SiteScope is connected directly to BSM, SiteScope creates the agent CI 
through its usual topology flow. When SiteScope sends its main topology 
(profile CI) and there is either an event or metrics integration with HP 
Operations Manager active, it also sends the agent topology.

Note: 

➤ The agent CI is deleted only when both event and metrics integrations 
are removed.

➤ The agent CI is not deleted when SiteScope is disconnected from BSM, 
because SiteScope does not know if the connection is though HPOM or 
BSM (the agent CI will eventually disappear due to the aging process).
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SiteScope Failover Manager and Operations Manager 
Integration
If you are using SiteScope Failover Manager to provide backup monitoring 
availability, the HP Operations agent must be installed on the 
SiteScope Failover Manager to enable it to send events or store metrics data 
for integrating with the HPOM management or BSM Gateway Server when 
the primary SiteScope is down. The agent can be installed during 
SiteScope Failover Manager installation or after SiteScope Failover Manager 
is installed using the SiteScope Configuration Tool.

Event Integration

When the primary SiteScope goes down, the SiteScope Failover Manager 
instance is activated and continues sending events to HPOM or BSM. 

Note: The agent on both the failover and primary SiteScope servers must be 
connected to HPOM, and the SiteScope policies must be uploaded and 
installed on the agent nodes in HPOM to enable the integration. For 
configuration details, refer to the HP SiteScope Failover Manager Guide PDF.

Metrics Integration

Continuous data graphing can be achieved using the HPOM and BSM 
reporting tools by selecting both the primary SiteScope and 
SiteScope Failover Manager for graphing.

Note: While event integration with HPOM and BSM, and metrics 
integration with HPOM can be configured on primary SiteScopes, these 
integrations are not supported for high availability when Microsoft Cluster 
Service is used to provide failover monitoring.

For details on using SiteScope Failover Manager, refer to the HP SiteScope 
Failover Manager Guide PDF.
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Classic SiteScope Failover and Operations Manager 
Integration
The classic SiteScope Failover solution was reinstated in SiteScope 11.11 as 
an alternative to using the SiteScope Failover Manager solution for 
providing automated failover functionality. Classic SiteScope Failover 
provides support for Operations Manager event and metrics integration.

Classic SiteScope Failover can be enabled from the SiteScope Configuration 
Tool. For details, see "Using the SiteScope Configuration Tool" in the 
HP SiteScope Deployment Guide PDF in the SiteScope 11.11 Help.

Event Integration

To enable classic SiteScope Failover support for OM event integration, 
perform the steps in "How to Enable SiteScope to Send Events to HPOM or 
BSM" on page 115, both for the primary SiteScope and for the SiteScope 
Failover. 

Event flow and host discovery flow work without any additional steps. For 
the Monitor Discovery integration, follow the steps in "How to Enable the 
SiteScope Monitor Discovery Policy" on page 127 for the primary SiteScope 
only.

Notes and Limitations

➤ Since there will be only one SiteScope service tree (and it is affected by 
events), it is not possible to know if it is affected by what was reported 
from the primary or failover SiteScope.

➤ The Failover group is not displayed since this group is on the failover 
server only.

➤ When the primary is down, events triggered from monitors that are 
monitoring the SiteScope server (in this case, the SiteScope server is the 
failover) do not affect the service tree.

➤ Groups and monitors added when the primary is down are not displayed 
in the service tree.

➤ The Drill Down to SiteScope tool works only when the primary SiteScope 
is running.
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➤ If there are different agent configurations on the primary and SiteScope 
Failover (for example, an agent is installed on a different path), the agent 
command on the failover server will not run from the Event Integration 
preferences user interface and you need to enter the agent path manually 
beforehand.

Metrics Integration

Classic SiteScope Failover provides support for OM metrics integration. Note 
that SiteScope Failover reports metrics to its HP Operations agent (not to the 
primary's agent).

Sending Events

Note: This section is relevant only to those users connecting SiteScope 11.00 
or later with HP Operations Manager (HPOM) products or to BSM. 

You can enable SiteScope to send events directly to the HPOM management 
server and to BSM (for use in Operations Management, Service Health, and 
Service Level Management). Events in SiteScope are based on SiteScope 
monitor metric status changes and alerts being triggered. 

To enable SiteScope to send events, the HP Operations agent must be 
installed on the SiteScope server. The agent can be installed from the 
SiteScope installation media during SiteScope installation, or after SiteScope 
is installed using the Configuration Tool. It can also be installed manually 
from the HPOM management server, although this is not recommended 
unless it is the same or a later version than the one packaged with SiteScope.

After the agent is installed, it must be configured in SiteScope Integration 
Preferences. This involves entering the installation path of the agent and the 
host name or IP address of the HPOM management or BSM Gateway Server, 
and connecting the agent to HPOM or BSM. The agent then sends a 
connection request to HPOM or BSM which must grant the certificate 
request (the HPOM management server can be configured to accept this 
client automatically). 
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After the certificate request has been granted on the HPOM or BSM server, a 
preconfigured log file policy should be installed and signed on the agent 
installation on the SiteScope server. This enables SiteScope to sign the 
preconfigured Operations Manager policies locally and automatically. This 
policy comes with SiteScope, and is deployed from the HP Operations 
Manager Integration dialog box in SiteScope’s Integration Preferences. 

When an event is triggered, SiteScope writes the event data to the 
HPSiteScopeOperationsManagerIntegration.log file which is located in the 
<SiteScope root directory>\logs directory. Each event is written as a 
separate line in the log. The log file policy instructs the agent to read this file 
and create event messages that are sent to HPOM or BSM.

The format of the event attributes is determined using the event mapping 
template. The template maps SiteScope runtime data to the event attribute 
values that are sent to the HPOM management or BSM Gateway Server 
when an event is triggered. For details on event mappings, see "Common 
Event Mappings Overview" in Using SiteScope in the SiteScope Help.

After the data is converted to an event, the agent sends the event to the 
HPOM management/BSM Gateway Server. Events are displayed in:

➤ HPOM’s Event Console.

➤ BSM’s Operations Management Event Browser if you have an Event 
Management Foundation license, and in Service Health for events that 
affect CIs. If Operations Management is not part of your BSM installation, 
you can still view events that affect CI status using a health indicator in 
Service Health. 

For details on configuring SiteScope to send events, see "How to Enable 
SiteScope to Send Events to HPOM or BSM" on page 115.

This section also contains the following topics:

➤ "Event Integration Diagram" on page 104

➤ "SiteScope-HP Operations Manager Support Matrix - Event Integration" 
on page 105

➤ "Event Generation" on page 105

➤ "Discovery Scripts and the Drill Down User For Viewing HPOM Events" on 
page 107
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➤ "Troubleshooting and Limitations" on page 109

Event Integration Diagram
The following diagram illustrates event data flow. 

Note: The HP Operations agent can be configured either to report events to 
an HPOM management or a BSM Gateway Server—not to both.
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SiteScope-HP Operations Manager Support Matrix - Event 
Integration
For the HP Operations Manager versions supported in this release, refer to 
the HP SiteScope Support Matrices section in the release notes (in SiteScope, 
select Help > What’s New?).

Event Generation
You can configure events to be generated and sent to the HPOM 
management server or to Operations Management in BSM following a 
change in a monitor's metric status or when a SiteScope alert is triggered.

➤ Status Change. Every metric or counter status change is an event (for 
example, if the CPU utilization counter status changes from Good to 
Error). You can choose whether events are triggered for metrics status 
changes in the monitor’s properties. By default, SiteScope sends an event 
for each metric status change for the monitor instance.

You can change the default settings for sending events and the event 
attribute values used when an event is triggered. The event attribute 
values are filled according to the event configuration mappings using the 
monitor's properties. For details on event mappings, see "Common Event 
Mappings Overview" in Using SiteScope in the SiteScope Help.

In addition to sending the monitor properties, SiteScope also sends health 
indicators or event type indicators (indicators) for the monitor instance. 
Events are categorized according to indicators. The BSM event manager 
uses indicators to categorize events according to the type of occurrence in 
the managed IT environment (for example, CPU Load). Indicators that 
provide CI state information are then used to calculate the CI.

Note: Status change is applicable only to metrics that are configured in 
the monitor's Thresholds Settings.
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➤ Alert. Every alert is an event. Since alerts are triggered per monitor, an 
event triggered by an alert can use the monitor's properties, but not the 
indicators associated with a specific metric. Therefore, when configuring 
an event alert, you can manually select the indicator that is reported 
when an event is triggered by an alert. As a result, the indicator is more 
generic, and you should select indicators that do not affect health 
indicators in BSM. 

You can choose whether an alert sends events to HPOM or BSM in the 
alert definition in the HP Operations Manager Integration Settings panel.

Note: 

➤ When a SiteScope alert is triggered, it is possible that two events are 
generated if both the alert and monitor are configured to send events. 
When configuring alerts to send events, you should not also enable 
the monitors to send events.

➤ SiteScope also includes threshold information in alerts that are sent to 
HPOM. In earlier versions of SiteScope and BSM, it was not possible to 
include the thresholds created for monitors in alerts.

➤ In Operations Management, it is recommended to use alert events for 
notification purposes only.
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Discovery Scripts and the Drill Down User For Viewing 
HPOM Events
When SiteScope is integrated with HPOM, the Node discovery and Monitor 
discovery policies are activated for nodes and monitors on the HPOM 
management server.

Both discovery policies rely on the Integration Viewer user in SiteScope. 
This is the user provided by SiteScope for drilling down from HPOM events. 
This user has been granted view permissions, and permissions to refresh 
groups and monitors. For details on users and user permissions, see "User 
Management Preferences" in Using SiteScope in the SiteScope Help.

Note: 

➤ If the Integration Viewer user is deleted from User Management 
Preferences, this user type is automatically created when SiteScope is 
restarted. 

➤ If the Integration Viewer user properties are changed, you must restart 
SiteScope to update the user properties file, or you can manually update 
the user properties in the <SiteScope root directory>\conf\
sitescope_connection.properties file. When changing Integration Viewer 
user properties manually, the user login name and password should be 
encrypted using the SiteScope Encryption Tool. For details on the 
encryption tool, see "How to Encrypt Text" in Using SiteScope in the 
SiteScope Help.

For details on deploying the discovery policies on the HPOM management 
server, refer to the HPOM documentation.

This section includes:

➤ "Node Discovery Policy" on page 108 

➤ "Monitor Discovery Policy" on page 108
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Node Discovery Policy

When SiteScope is connected with HPOM, a node is automatically created 
and registered in HPOM for each node monitored by SiteScope. This enables 
SiteScope to report all the nodes that it monitors to HPOM. Only hosts for 
monitors which report events are sent to HPOM through the discovery 
policy. 

Tip: When you are not connected to HPOM (if connected to Operations 
Management), it is recommended to disable the node discovery by running 
the command: ovpolicy -disable -polname SiteScope_Hosts_Discovery

Note: SiteScope does not report nodes or services to HPOM for monitors 
that are disabled, or are not configured to send events.

Monitor Discovery Policy

This is an optional policy that must be activated manually on HPOM using 
the files in the <SiteScope root directory>\tools\OMIntegration\
SiteScopeMonitorDiscoveryPolicy directory. After the policy has been 
activated, SiteScope runs the SiteScope-OM monitor discovery script when it 
is connected with HPOM. 

This policy enables the HPOM Service Navigator to view the SiteScope 
monitor tree in the HPOM service maps. When new monitors, groups, or 
both, are added or changes are made in the SiteScope monitor tree, the 
services tree is updated in HPOM to reflect these changes. In addition, when 
events arrive to HPOM, they affect the SiteScope services tree and color all 
related nodes affected by them.

For details on how to enable the monitor discovery policy, see "How to 
Enable the SiteScope Monitor Discovery Policy" on page 127. 
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For details on enabling the tool to drill down to SiteScope from HPOM, see 
"How to Enable the Drill Down to SiteScope Tool on HPOM for Windows" 
on page 134 and "How to Enable the Drill Down to SiteScope Tool on HPOM 
for UNIX/Linux/Solaris" on page 137.

Troubleshooting and Limitations

➤ Upgrades for earlier SiteScope-OM event integration (pre-SiteScope 11.00) 
are not supported. 

➤ While SiteScope 10.x versions support HPOM event integration, events 
generated in SiteScope versions earlier than 11.00 do not affect Service 
Health and Service Level Management in BSM 9.0x.

➤ Sending events to HPOM using the HP Operations agent is available only 
when connected to SiteScope 11.00 or later. Although the earlier HPOM 
integration solution of installing the HP SiteScope Adaptor on the HPOM 
management server is supported in earlier versions of SiteScope, it is not 
supported with SiteScope 11.00 or later and should be uninstalled. You 
should therefore upgrade to the new implementation using the 
HP Operations agent.

➤ If you are having problems activating node discovery or deploying the 
monitor discovery policy, verify that the SiteScope node system properties 
are discovered correctly, and fix them if necessary. In the Node Properties 
dialog box, select the System tab and make sure the settings matches you 
SiteScope node system settings.

➤ If you currently use HPOM with SiteScope and you plan to upgrade 
HPOM to BSM, you must connect SiteScope directly to BSM to perform 
the upgrade. This also enables SiteScope to report the topology to BSM. 
For details on connecting SiteScope to BSM, see "Working with BSM" on 
page 55.

➤ When SiteScope sends an event in which a monitor metric value does not 
match any of the thresholds, the indicator severity Normal is sent to the 
HPOM management/BSM Gateway Server. 
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➤ When SiteScope is connected to BSM, after a monitor is created on a new 
host, the event is sent to Operations Management without the value of 
the related CI (the event is triggered before topology is reported to BSM). 
To avoid waiting for the next event to be sent, select the Manually send 
first event check box in the monitor’s HP Integration Settings > 
HP Operations Manager Integration Settings. This action can be 
performed globally using Global Search and Replace.

➤ Events are not closed (relevant to HPOM and BSM) and the indicator 
status is not cleared (relevant to BSM) if SiteScope stops monitoring in the 
following instances:

➤ The related SiteScope monitor skipped or was disabled/suspended 
(permanently or by the scheduler)

➤ The related SiteScope monitor was deleted

➤ SiteScope stops reporting to BSM (for example, if it is disconnected)

➤ To exclude indicators of disabled monitors from Service Health, Service 
Level Management, or both, it is recommended to use Downtime 
Management. For details, see "Downtime Management — Overview" in 
Platform Administration.

➤ For additional troubleshooting relating to the HP Operations agent 
installation, event integration setup, sending events, and with node and 
monitor discovery, see "Troubleshooting SiteScope Integration Issues" in 
Best Practices for the SiteScope-Business Service Management/Operations 
Manager Integration in the SiteScope Help.
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Reporting Metrics Using the HP Operations Agent

Note: This section is relevant only to those users connecting SiteScope 11.00 
or later with Operations Management in BSM, or to HP Performance 
Manager 9.0 or later, and only when using the HP Operations agent.

SiteScope uses the HP Operations agent to make its metrics data available to 
HP Performance Manager (the reporting component of HPOM) and to the 
Performance Perspective tab in BSM’s Operations Management. To enable 
SiteScope metrics to be collected by these reporting products, the 
HP Operations agent must be installed on the SiteScope server.

Note: Metrics integration using the HP Operations agent (where metrics 
data is used in the Performance Perspective tab in Operations Management) 
should not be confused with the integration of SiteScope monitor metrics 
used by the various BSM applications when calculating status for CIs (for 
example, in Service Health, Service Level Management, and System 
Availability Management). For details on BSM metrics integration, see 
"Working with BSM" on page 55. 

Metrics integration with Performance Manager can be activated regardless of 
the connection status between the HP Operations agent and the 
HPOM/BSM server, since metrics are collected by the agent.

SiteScope collects metrics data, and logs it to the agent data store, which is 
installed on the SiteScope host. For sizing recommendations, see "Sizing 
Recommendations for SiteScope-Operations Manager Metrics Integration" 
on page 147. 
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When a user in Performance Manager draws or designs a graph, 
Performance Manager collects metrics data from the agent data store for the 
selected node in Performance Manager that is monitored by SiteScope, and 
draws the graph. Agentless graphing is supported in Performance Manager 
9.0. For details on Performance Manager, refer to the Performance Manager 
documentation. 

Metrics data collected from SiteScope can also be used in the Performance 
Perspective tab, the graphing component of BSM’s Operations Management.

Metric name alignment, the process of aligning metric names in SiteScope 
with those used in HPOM/BSM, has been performed for some of the most 
commonly used monitors. For details, see "SiteScope-Operations Agent 
Metrics Alignment" on page 143.

Tip: For best practices and troubleshooting for reporting metrics data to BSM 
and HPOM products using the HP Operations agent, see Best Practices for the 
SiteScope-Business Service Management/Operations Manager Integration in the 
SiteScope Help.

For details on configuring metrics integration, see "How to Enable SiteScope 
to Report Metrics to the HP Operations Agent" on page 140. 

This section also contains the following topics:

➤ "Metrics Data Flow Diagram" on page 113

➤ "Troubleshooting and Limitations" on page 114
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Metrics Data Flow Diagram
The following diagram illustrates the metrics data flow.
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Troubleshooting and Limitations

➤ The agent data store supports only alphanumeric and the underscore (_) 
character in SiteScope metric names. All other characters are converted to 
supported characters (the metric display name (heading) remains in the 
SiteScope style).

➤ Web Script monitor data cannot be reported to Operations Management 
or HPOM.

➤ After upgrading from HP Performance Manager to BSM’s Operations 
Management (Performance Perspective) and connecting SiteScope to 
BSM, historical report data cannot be upgraded since it does not have CI-
based reporting capability (it can still be viewed in the old 
HP Performance Manager way).

➤ To enable reporting numerical values with postfixes (such as 25% or 
400MB) to the agent data store, add the list of postfixes, separated by 
commas, to the _omMetricIntergationAllowedNumberPostfixs property 
in the <SiteScope root directory>\groups\master.config file. For 
example, to include %, MB, KB, and GB, add =%,mb,kb,gb. Note that all 
postfixes should be in lower case.

➤ In an Operations Management Manager of Managers configuration 
(where multiple HPOM servers are connected to Operations Management, 
and multiple SiteScopes are connected to the HPOM servers, and 
indirectly to Operations Management), data sent from SiteScope is not 
supported by Performance Perspective in Operations Management, since 
SiteScope does not send topology to Operations Management. For details 
on Operations Management deployment configurations, see "Connecting 
Servers" in Using Operations Management.

➤ To prevent overloading the agent data store, follow the sizing 
recommendations as described in "Sizing Recommendations for 
SiteScope-Operations Manager Metrics Integration" on page 147.

➤ For troubleshooting problems involving HP Operations agent 
configuration, health monitor errors, and with Performance Manager 
configuration, see "Troubleshooting SiteScope Integration Issues" in Best 
Practices for the SiteScope-Business Service Management/Operations Manager 
Integration in the SiteScope Help.
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Tasks

How to Enable SiteScope to Send Events to HPOM or BSM

Note: This section is relevant only to those users connecting SiteScope 11.00 
or later with HP Operations Manager (HPOM) products or to BSM. 

This task describes how to enable SiteScope to be used to send events to the 
HPOM management server or BSM Gateway Server.

This task includes the following steps:

➤ "Prerequisites" on page 116

➤ "Install the HP Operations agent on the SiteScope server" on page 116

➤ "For BSM on a distributed environment only, configure the connection 
request to be passed to the Data Processing Server" on page 117

➤ "Configure the agent connection settings on the SiteScope server" on 
page 119

➤ "Accept the agent connection request on the HPOM management server 
or BSM Gateway/Web Processing server" on page 120

➤ "Install the log policies on the SiteScope server" on page 120

➤ "Check connection status and send test message from the SiteScope server 
- optional" on page 121

➤ "Extend the integration using monitor discovery - optional" on page 121

➤ "Enable SiteScope to send events to HPOM or BSM" on page 122

➤ "Enable default event severity mappings to be used - optional" on 
page 123

➤ "Enable/Disable sending events for monitor instances and alerts" on 
page 123
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➤ "Configure event mappings for monitors and alerts - optional" on 
page 124

➤ "Results" on page 125

 1 Prerequisites

Only an administrator in SiteScope, or a user granted Edit integration 
preferences and Edit common event mappings permissions can create or 
make changes to Integration Preferences and common event mappings. 
For details, see "User Management Preferences" in Using SiteScope in the 
SiteScope Help.

 2 Install the HP Operations agent on the SiteScope server

You can install the HP Operations agent during SiteScope installation 
from the SiteScope installation media, or after SiteScope is installed using 
the Configuration Tool. The agent enables SiteScope to send event data to 
the HPOM management server or BSM Gateway Server. 

For details on installing the agent during SiteScope installation, see 
"Installing Using the Installation Wizard" in the HP SiteScope Deployment 
Guide PDF. 

For details on installing the agent using the Configuration Tool, see 
"Using the SiteScope Configuration Tool" in the HP SiteScope Deployment 
Guide PDF. 

For the supported HP Operations agent version and HPOM environments, 
refer to the HP SiteScope Support Matrices section in the release notes.
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 3 For BSM on a distributed environment only, configure the 
connection request to be passed to the Data Processing 
Server

If BSM uses a separate Gateway and Data Processing Server, perform the 
following to enable the request received on the Gateway Server to be 
passed to the Data Processing Server:

 a In BSM, select Admin > Platform > Infrastructure Settings:

➤ Select Applications.

➤ Select Operations Management.

➤ In the Certificate Server Settings, locate the Certificate Server Host. 
Make sure that the value matches the host name or IP address of the 
active BSM Data Processing Server that acts as the certificate server 
host. If it does not match, change it accordingly. 

Note: If the BSM Data Processing Server fails and automatic failover 
has been configured, you must change the Certificate Server Host 
setting to the name of the backup Data Processing Server to handle 
new certificate requests. However, if you do not expect any new 
certificate requests during the Data Processing Server failover 
timeframe, you can keep the setting unchanged as it does not affect 
any event integrations configured previously. 

 b On the Gateway Server:

➤ Change the active directory to the \bin directory by typing 
cd <HPBSM root directory>\bin.

➤ Run setup-secure-communication.bat and enter the DNS name of 
the Data Processing Server.
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 c On the Data Processing Server:

➤ Change the active directory to the \bin directory by typing 
cd <HPBSM root directory>\bin.

➤ Run setup-secure-communication.bat and type g to grant the 
request (make sure that you grant this request and not some other 
request).

 d If you are using a BSM failover environment with load balancer, make 
sure to keep the certificate server of each Data Processing Server 
synchronized.

➤ Repeat steps b and c for every Gateway Server. It does not matter to 
which Data Processing Server you send the certificate request 
because the Data Processing Servers already trust each other. As a 
result, all Gateway Servers trust both Data Processing Servers and 
can communicate with them regardless of which one is active at any 
given moment.

➤ If you install a new certificate on the running Data Processing 
Server, you also have to install the certificate on the secondary Data 
Processing Server which is used as failover. To install the new 
certificate, run the following commands:

ovcert -importtrusted -file <newCertificateFilePath>

ovcert -importtrusted -file <newCertificateFilePath> -ovrg server

➤ Configure the load balancer to forward all HTTPS traffic that arrives 
on port 383 to the Gateway Servers. This enables the certificate 
requests and event forwarding to work.
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 4 Configure the agent connection settings on the SiteScope 
server

In SiteScope Integration Preferences, configure the HP Operations agent 
connection settings to the HPOM management server or BSM server.

 a Select Preferences > Integration Preferences, and click HP Operations 
Manager Integration to create a new integration or select an existing 
integration. For user interface details, see "Integration Preferences 
Page" in Using SiteScope in the SiteScope Help.

 b In the HP Operations Manager Integration dialog box, expand the HP 
Operations Manager Integration Main Settings panel, and enter the 
installation path of the agent and the name or IP address of the HPOM 
management or BSM server. For user interface details, see "HP 
Operations Manager Integration Main Settings" in Using SiteScope in 
the SiteScope Help.

 c Click Connect to connect the agent to the HPOM management or BSM 
server. This sends a connection request from the agent to the HPOM 
management or BSM server.

 d You can click the Analyze button to verify the success of each phase of 
the process. Use the information supplied in the analysis results to 
perform problem analysis and for troubleshooting. For example, you 
can verify connectivity between the agent and server by checking the 
bbcutil connection protocol.

Note: If an agent is connected to an HPOM or BSM server and you want 
to connect it to a different server, you must uninstall and reinstall the 
agent or redirect the agent to another server. For task details, see "How to 
Reconnect the HP Operations Agent to a Different HPOM or BSM Server" 
on page 125.
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 5 Accept the agent connection request on the HPOM 
management server or BSM Gateway/Web Processing server

➤ For HPOM:

In the HPOM user interface, you need to configure the SiteScope node, 
map the certificate request to this node, and accept the certificate request. 
For details, refer to "Configuring Managed Nodes" and "Configuring 
Certificates" in the "Administering Your Environment" section of the 
HPOM documentation, or contact your HPOM administrator.

➤ For BSM:

For BSM running on a Gateway Server only, perform the following on the 
BSM Gateway Server. If BSM runs on a distributed environment, perform 
the following on the Data Processing Server. 

 a (Optional) To make sure that the OV Certificate Server process is 
running, run the command line run ovc -status. If it is not running, run 
the command ovc -start or contact your BSM administrator.

 b Change the active directory to the \bin directory by typing 
cd <HPBSM root directory>\bin.

 c Run setup-secure-communication.bat and type g to grant the request 
(make sure that you grant this request and not some other request).

 d Make sure that the request ID you are going to accept is associated 
with the agent’s core ID. To retrieve the agent’s core ID, in SiteScope, 
click the Analyze button in HP Operations Manager Integration, or run 
the agent's ovcoreid command on the SiteScope server.

 6 Install the log policies on the SiteScope server

In the HP Operations Manager Integrations Main Settings panel of the 
HP Operations Manager Integration dialog box, click Install Policies. The 
preconfigured log file policy is installed and signed on the agent.

For user interface details, see "HP Operations Manager Integration Main 
Settings" in Using SiteScope in the SiteScope Help.
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 7 Check connection status and send test message from the 
SiteScope server - optional

If there are connectivity problems, you can perform problem analysis and 
check the status of the agent and the certificate request. In the HP 
Operations Manager Integration dialog box, expand the HP Operations 
Manager Integrations Main Settings panel, and click Analyze.

To check that the agent is connected to the HPOM management or BSM 
server, expand the HP Operations Manager Integrations Advanced 
Settings panel, type a message in the Test message text box, and click 
Send Test Message. If the test is successful, the text message is displayed 
in the HPOM console or in the Operations Management Event Browser in 
BSM. This message is generated by a basic opcmsg policy command.

For user interface details, see "HP Operations Manager Integration Main 
Settings" in Using SiteScope in the SiteScope Help.

 8 Extend the integration using monitor discovery - optional

To enable the OM Service Navigator to view SiteScope groups and 
monitors in the OM service maps, you must manually enable the Monitor 
discovery policy on HPOM using the files in the <SiteScope root 
directory>\tools\OMIntegration\SiteScopeMonitorDiscoveryPolicy 
directory. 

For details on how to enable the policy, see "How to Enable the SiteScope 
Monitor Discovery Policy" on page 127.

Note: To enable classic SiteScope Failover support for OM event 
integration, follow the steps for configuring the monitor discovery policy 
in "Classic SiteScope Failover and Operations Manager Integration" on 
page 101.
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Tip: You can also use the Drill Down to SiteScope tool to enable opening 
the SiteScope user interface from the monitor or group service that was 
discovered by the monitor discovery policy and added to the HPOM 
Service Navigator. 

➤ For details on enabling the tool on HPOM for Windows, see "How to 
Enable the Drill Down to SiteScope Tool on HPOM for Windows" on 
page 134.

➤ For details on enabling the tool on HPOM for UNIX/Linux/Solaris, see 
"How to Enable the Drill Down to SiteScope Tool on HPOM for 
UNIX/Linux/Solaris" on page 137.

 9 Enable SiteScope to send events to HPOM or BSM

 a In the HP Operations Manager Integration dialog box, expand the HP 
Operations Manager Integrations Main Settings panel, and select 
Enable sending events to enable SiteScope to send events to the 
HPOM/BSM server. For user interface details, see "HP Operations 
Manager Integration Main Settings" in Using SiteScope in the SiteScope 
Help.

 b To check that the agent can send events to the HPOM/BSM, expand 
the HP Operations Manager Integrations Advanced Settings panel, 
and click Send Test Event. SiteScope writes a test event to the log, 
which the agent sends to HPOM/BSM. For user interface details, see 
"HP Operations Manager Integration Advanced Settings" in Using 
SiteScope in the SiteScope Help.
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 10 Enable default event severity mappings to be used - optional

In the Default Severity Mappings section of the HP Operations Manager 
Integrations Advanced Settings panel, you can enable the default severity 
mappings that correlate the severity level in HPOM/BSM to the monitor 
threshold status in SiteScope to be used. These mappings are sent in 
events triggered by SiteScope alerts, when SiteScope is not connected to 
BSM, or in any case where the indicator state and severity value is missing 
(for example, when using monitors that do not have a defined topology). 
You can also customize the default severity mappings. 

For user interface details, see "HP Operations Manager Integration 
Advanced Settings" in Using SiteScope in the SiteScope Help.

Note: You can override the severity mapping at the monitor level by 
modifying the Severity attribute in Common Event Mappings. For details, 
see step 12 on page 124.

 11 Enable/Disable sending events for monitor instances and 
alerts

By default, each newly-created monitor instance is configured to send an 
event for each metric status change, and each new alert is configured to 
send an event when triggered. Monitors and alerts that are upgraded from 
earlier versions of SiteScope are not configured to send events.

➤ To disable sending events for a monitor instance, in the monitor 
properties for the selected monitor instance, expand HP Integration 
Settings > HP Operations Manager Integration Settings, and clear the 
Send events check box. For user interface details, see "HP Operations 
Manager Integration Settings" in Using SiteScope in the SiteScope Help.

➤ To disable sending events for an alert, in the New/Edit Alert dialog 
box, expand the HP Operations Manager Integration Settings panel, 
and clear the Send events check box. For user interface details, see "HP 
Operations Manager Integration Settings" in Using SiteScope in the 
SiteScope Help.
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Note: The Send events setting is active only if Enable sending events is 
selected in the HP Operations Manager Integration Main Settings panel of 
HP Operations Manager Integration Preferences.

 12 Configure event mappings for monitors and alerts - optional

Monitor instances and alerts are assigned a common event mapping that 
is used when an event is triggered. This is the mapping between SiteScope 
runtime data and the values of the attributes of the event that will be 
sent. 

You can use the default event mapping associated with the monitor or 
alert, select a different event mapping (if any exist), or create a new event 
mapping in Preferences > Common Event Mappings. Alternatively, for 
alerts, you can use the event mapping template associated with the 
monitor that triggered the alert.

You select the event mapping template:

➤ When configuring a monitor instance from the monitor Properties tab 
> HP Integration Settings > HP Operations Manager Integration 
Settings > HP Operations Manager Integration Main Settings in 
SiteScope versions earlier than 11.11, or HP Integration Settings > 
Event Mapping Settings in SiteScope 11.11 or later.

➤ When configuring alerts from the Alerts tab > New/Edit Alert > HP 
Operations Manager Integration Settings > Event mapping.

For details of the Common Event Mapping user interface, see "New/Edit 
Event Mappings Dialog Box" in Using SiteScope in the SiteScope Help.
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 13 Results

After a monitor metric status change or an alert is triggered in SiteScope, 
the event is written to the integration log file in the format selected for 
the monitor instance or alert in Common Event Mappings. 

The agent monitors the log file and creates an event, which it sends to 
HPOM or BSM. Events are displayed in the Event Console in HPOM, or in 
BSM in the Operations Management Event Browser (if you have an Event 
Management Foundation license). If Operations Management is not part 
of your BSM installation, you can view events that affect CI status using a 
health indicator in Service Health.

 How to Reconnect the HP Operations Agent to a 
Different HPOM or BSM Server
You can reconnect the HP Operations agent to a different HPOM 
management or BSM server by either:

➤ Uninstalling and reinstalling the HP Operations agent.

➤ Redirecting the HP Operations agent to a different server.

Note: This task is part of a higher-level task. For details, see "How to Enable 
SiteScope to Send Events to HPOM or BSM" on page 115.

To uninstall and reinstall the HP Operations agent:

 1 In SiteScope, select Preferences > Integration Preferences, and delete the 
HP Operations Manager integration.

 2 Open the SiteScope Configuration Tool (Start > Programs > HP SiteScope 
> Configuration Tool), select the HP Operations Agent option, and 
uninstall the HP Operations agent.

 3 Open the SiteScope Configuration Tool, select the HP Operations Agent 
option, and install the HP Operations agent.

 4 In SiteScope, configure the HP Operations Manager integration with the 
new HPOM/BSM server to which you want to connect. For user interface 
details, see "HP Operations Manager Integration Dialog Box" in Using 
SiteScope in the SiteScope Help.
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Note: After reconnecting to the HPOM server, it can take some time until 
events are sent to HPOM. Restarting the HPOM server, the HP Operations 
agent, or both, might fix it.

To redirect the HP Operations agent to a different server:

Note: If you are cloning a machine with an HP Operations agent which 
usually includes a host name and IP address change, start from step 1 below; 
otherwise start from step 4.

 1 On the SiteScope server where the HP Operations agent is installed, run 
the following command to create a new core ID: ovcoreid -create -force

 2 Run ovcert -list to remove the certificates. For all IDs in the output, run the 
command ovcert -remove ’id’.

 3 Adapt the xpl configuration variable OPC_NODENAME by running the 
command: ovconfchg -ns eaagt -set OPC_NODENAME ’hostname’

 4 Set the new server host name and core ID by running the commands:

ovconfchg -ns sec.cm.client -set CERTIFICATE_SERVER <new OM server>
ovconfchg -ns sec.core.auth -set MANAGER <new OM server>
ovconfchg -ns sec.core.auth -set MANAGER_ID <new OM server ovcoreid>
ovconfchg -ns eaagt.lic.mgrs -set general_licmgr <new OM server>
ovconfchg -ns sec.cm.certificates -set CERT_INSTALLED FALSE

 5 Restart the HP Operations agent by running the commands:

ovc -kill
ovc -start

 6 Run ovcert -certreq to create a new certificate request.

 7 Grant a certificate request on the HPOM/BSM Gateway Server (in case of 
distributed BSM, grant certificate request on the Data Processing Server).
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 8 In SiteScope, open the HP Operations Manager Integration dialog box and 
perform the following in the HP Operations Manager Integration Main 
Settings panel:

➤ Change the name or IP address of the HPOM/BSM server in the HP 
Operations Manager / BSM host box. For details, see "HP Operations 
Manager Integration Main Settings" in Using SiteScope in the SiteScope 
Help.

➤ Install the log policies by clicking the Install Policies button.

Note: After reconnecting to the HPOM server, it can take some time until 
events are sent to HPOM. Restarting the HPOM server, the HP Operations 
agent, or both, might fix it.

 How to Enable the SiteScope Monitor Discovery Policy
This task describes how to enhance the SiteScope integration with HPOM by 
enabling HPOM Service Navigator to view SiteScope groups and monitors in 
HPOM service maps.

Note: 

➤ This task is part of a higher-level task. For details, see "How to Enable 
SiteScope to Send Events to HPOM or BSM" on page 115.

➤ HPOM 9.0 for Windows 64-bit console does not support the services tree 
view. The tree view is available in the left pane, but not in the service 
map on the right.

➤ To enable classic SiteScope Failover support for OM event integration, 
follow the steps for configuring the monitor discovery policy in "Classic 
SiteScope Failover and Operations Manager Integration" on page 101.
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This task includes the following steps:

➤ "Copy policy files to the instrumentation folder" on page 128

➤ "Upload the policy to the HPOM server (for HPOM for Windows servers)" 
on page 129

➤ "Upload the policy to the HPOM server (for HPOM for Linux, UNIX, 
Solaris 9.x servers)" on page 130

➤ "Set the Schedule Interval" on page 130

➤ "Deploy the policy" on page 131

➤ "Manually run the Monitor Discovery policy - optional" on page 132

➤ "Drill down to the SiteScope user interface from HPOM - optional" on 
page 133

➤ "Troubleshooting" on page 133

 1 Copy policy files to the instrumentation folder

On the SiteScope server:

➤ For Windows: Copy the discoverSiteScope.bat file from the 
<SiteScope root directory>\integrations\om\bin folder to the 
%OvDataDir%\bin\instrumentation folder.

➤ For Linux, UNIX, Solaris: Copy all files from 
/opt/HP/SiteScope/integrations/om/bin/* to the 
/var/opt/OV/bin/instrumentation folder.

Note: All relevant policy files can be found in the 
<SiteScope root directory>\tools\OMIntegration\
SiteScopeMonitorDiscoveryPolicy\SiS_Discovery_policy_3.0 folder.
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 2 Upload the policy to the HPOM server (for HPOM for 
Windows servers)

Prerequisites: 

➤ HPOM for Windows 8.16 (or an equivalent patched 8.10 server) or 
9.10, and sufficient user rights (typically, Administrator).

➤ All uploads are performed using the HPOM for Windows command 
line tool ovpmutil which is normally in the environment path.

To upload the policy to the HPOM server:

 a Open a command prompt, and navigate to the folder where the 
SiteScope Discovery 3.0 server components are located. For example, 
C:\temp\SiS_Discovery_3.0:

cd C:\temp\SiS_Discovery_3.0\ForServer

 b Upload the Service Model using ovpmutil:

ovpmutil cfg svt upl .\DiscoverSiteScope.mof

The Service Model is displayed in the HPOM Service Type 
Configuration Editor (under Application Services > SiteScope).

 c Upload the SiteScope monitor discovery policy using ovpmutil and the 
provided index file:

ovpmutil cfg pol upl .\PolicyConfig_77BFF2F6-38BD-45B3-BEA9-
E237C55F7877.xml

The policy is now available in the HPOM server policy repository 
under Policy management > Policy groups.
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 3 Upload the policy to the HPOM server (for HPOM for Linux, 
UNIX, Solaris 9.x servers)

 a Upload the HPOM Service Model to the HPOM management server. 
Open a command shell and type:

/opt/OV/bin/OpC/utils/mof_cfgupld.sh /opt/HP/SiteScope/tools/\

OMIntegration/SiteScopeMonitorDiscoveryPolicy/\

SiS_Discovery_policy_3.0/ForServer/DiscoverSiteScope.mof

(The .mof file is located in the <SiteScope>/tools/OMIntegration/
SiteScopeMonitorDiscoveryPolicy/SiS_Discovery_policy_3.0/ForServer 
folder.)

 b Upload the policies by typing in a command shell:

/opt/OV/bin/OpC/utils/opcpolicy -upload dir=/opt/HP/SiteScope/\

tools/OMIntegration/SiteScopeMonitorDiscoveryPolicy/\

SiS_Discovery_policy_3.0/ForServer

 c Assign the policies to the node, and deploy to the SiteScope node by 
typing in a command shell:

# /opt/OV/bin/OpC/utils/opcnode -assign_pol node_name=<NODENAME> 
net_type=NETWORK_IP pol_name= "SiteScope Discovery" 
pol_type=svcdisc

 4 Set the Schedule Interval

You can set the schedule interval for running the SiteScope monitor 
discovery policy on the HPOM agent in the HPOM for Windows console.

 a Select Policy management > Policy groups > SiteScope Discovery. In 
the right pane, right-click SiteScope Discovery and select All Tasks > 
Edit. 

 b In the Service Auto-Discovery policy editor, select the Schedule tab 
and specify an interval for running the SiteScope monitor discovery 
policy on the HPOM agent in the HPOM for Windows console. 
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 5 Deploy the policy

Prerequisites: 

➤ The SiteScope server to be integrated is set up as an HPOM managed 
node. 

➤ The HP Operations agent is running and connected (for details, see 
"How to Enable SiteScope to Send Events to HPOM or BSM" on 
page 115). 

➤ A certificate has been granted (for details, see "Configuring Managed 
Nodes" in the "Administering Your Environment" section of the HPOM 
documentation).

➤ The SiteScope monitor discovery policy has been uploaded to the 
SiteScope Discovery policy group (for details, see step 2 on page 129 or 
step 3 on page 130).

To deploy the policy for HPOM for Linux, UNIX, Solaris 9.x servers:

Open a command shell and type: # opcragt -dist <NODENAME>
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To deploy the policy for HPOM for Windows servers:

 a Right-click the SiteScope Discovery policy and select All Tasks > Deploy 
on.

 b In the Deploy Policies on dialog box, select the SiteScope Server OM 
node from the available managed nodes, and click OK. The 
deployment status is displayed in Deployment jobs in the OM 
Console.

 c To view the policy inventory of the node, right-click the SiteScope 
Server OM node under Nodes, and select View > Policy Inventory.

 d The policy inventory is displayed in the right pane, showing all 
policies deployed to the node. 

 6 Manually run the Monitor Discovery policy - optional

For testing or debugging purposes, it is useful to run the discovery 
manually. This can be done using the ovagtrep command line tool on the 
SiteScope server HPOM agent node where the policy is running. 

To do so, run the following commands:

 a To force execution of the policy, run the command:

ovagtrep -run "SiteScope Discovery"

 b To force submittal to server, run the command:

ovagtrep -publish 

 c For troubleshooting, use the System.txt file in the %OvDataDir%\log 
folder. 
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 7 Drill down to the SiteScope user interface from HPOM - 
optional

You can also use the Drill Down to SiteScope tool to enable opening the 
SiteScope user interface from the monitor or group service that was 
discovered by the monitor discovery policy and added to the HPOM 
Service Navigator. 

For details on enabling the tool for HPOM for Windows, see "How to 
Enable the Drill Down to SiteScope Tool on HPOM for Windows" on 
page 134.

For details on enabling the tool for HPOM for UNIX/Linux/Solaris, see 
"How to Enable the Drill Down to SiteScope Tool on HPOM for 
UNIX/Linux/Solaris" on page 137.

 8 Troubleshooting

For troubleshooting, you can check the following files:

➤ System.txt file in the <SiteScope Server>\%OvDataDir%\log folder 
(for Linux: <SiteScope Server>/var/opt/OV/log).

➤ agtrep.xml file in <SiteScope Server>\%OvDataDir%\datafiles folder 
(for Linux: <SiteScope Server>/var/opt/OV/datafile) to see the 
discovered instances the agent knows about.

➤ <HPOM Server>\%OvShareDir%\server\log\OvSvcDiscServer.log to 
see what the HPOM server receives.
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 How to Enable the Drill Down to SiteScope Tool on 
HPOM for Windows
This task describes how to enable the Drill Down to SiteScope tool on the 
HPOM for Windows management server. This tool enables you to open the 
SiteScope user interface from the monitor or group service that was 
discovered by the monitor discovery policy and added to the HPOM Service 
Navigator.

Note: This task is part of a higher-level task. For details, see "How to Enable 
SiteScope to Send Events to HPOM or BSM" on page 115.

This task includes the following steps:

➤ "Prerequisites" on page 134

➤ "Install the Drill Down to SiteScope tool on the HPOM for Windows 
server" on page 135

➤ "Associate the tool with the SiteScope Service" on page 135

➤ "Launch the tool (from the SiteScope service)" on page 135

➤ "Launch the tool (from the Tools repository)" on page 136

 1 Prerequisites

The Monitor Discovery policy must be enabled and deployed on the 
SiteScope Server node on HPOM. 

For task details, see "How to Enable the SiteScope Monitor Discovery 
Policy" on page 127.
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 2 Install the Drill Down to SiteScope tool on the HPOM for 
Windows server

 a Log on to the HPOM for Windows server machine as an Administrator.

 b Copy the drillDownToSiteScope.vbs file from the 
<SiteScope root>\tools\OMIntegration\DrillDownTool\ForOMW 
folder to \\<HPOM server>\SPI-Share\SiteScope.

 c Upload the Drill Down to SiteScope tool to the HPOM server:

➤ Copy the tls_drillDownToSIS.mof file from the 
<SiteScope root>\tools\OMIntegration\DrillDownTool\ForOMW 
folder to any folder on the HPOM server machine (<tls path>).

➤ Open a command line and run the command:

>> ovpmutil cfg tls upl <tls path>\tls_drillDownToSIS.mof

 d The Drill Down to SiteScope tool is available on the HPOM server 
under Tools > SiteScope Tools.

 3 Associate the tool with the SiteScope Service

 a In the HPOM for Windows console, open the Service Type 
Configuration Editor, select Application Services > SiteScope, and click 
Properties.

 b In the SiteScope Properties dialog box, click the Tools tab, select 
SiteScope Tools, and then click OK. 

 4 Launch the tool (from the SiteScope service)

 a In the HPOM for Windows console, right-click the SiteScope service 
that you want to view (SiteScope monitor, group, or server service), 
and select All Tasks > Launch Tool.

 b Select the Drill Down to SiteScope tool, and click Launch.

 c The SiteScope user interface opens displaying the selected monitor, 
group, or the default Dashboard view (if SiteScope Server service was 
selected).
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 5 Launch the tool (from the Tools repository)

 a In the HPOM for Windows console, expand Tools > SiteScope Tools. In 
the right pane, right-click the Drill Down to SiteScope tool and select 
All Tasks > Launch Tool.

 b In the Edit Parameters dialog box, select the monitor, group, or 
SiteScope Server service that you want to view, and click Launch.

 c The SiteScope user interface opens displaying the selected monitor, 
group, or default Dashboard view (if SiteScope Server service was 
selected).
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 How to Enable the Drill Down to SiteScope Tool on 
HPOM for UNIX/Linux/Solaris
This task describes how to enable the Drill Down to SiteScope tools on the 
HPOM for UNIX/Linux/Solaris management server. This tool enables you to 
open the SiteScope user interface from events or from the monitor or group 
service that was discovered by the monitor discovery policy and added to 
the HPOM Service Navigator.

Note: This task is part of a higher-level task. For details, see "How to Enable 
SiteScope to Send Events to HPOM or BSM" on page 115.

This task includes the following steps:

➤ "Prerequisites" on page 137

➤ "Install the Drill Down to SiteScope tools on the HPOM for 
UNIX/Linux/Solaris server" on page 138

➤ "Launch the tool (from the SiteScope service)" on page 139

➤ "Launch the tool (from an event)" on page 139

 1 Prerequisites

The Monitor Discovery policy must be enabled and deployed on the 
SiteScope Server node on HPOM. 

For task details, see "How to Enable the SiteScope Monitor Discovery 
Policy" on page 127.
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 2 Install the Drill Down to SiteScope tools on the HPOM for 
UNIX/Linux/Solaris server

 a Log on to the HPOM for UNIX/Linux/Solaris server machine as an 
Administrator.

 b Open a command shell and create a new directory by typing:

# mkdir -p /opt/OV/newconfig/SiteScope

 c Change to the SiteScope directory by typing: 

cd /opt/OV/newconfig/SiteScope

 d Copy the DrillDownToSIS.tar file from the 
<SiteScope root>\tools\OMIntegration\DrillDownTool\ForOMX 
folder to /opt/OV/newconfig/SiteScope on the HPOM server 
machine.

 e Extract the .tar file to the current directory by typing:

# cd /opt/OV/newconfig/SiteScope
# tar -xvf DrillDownToSIS.tar

 f Upload the Drill Down to SiteScope tools to the HPOM server by 
typing:

# cd /opt/OV/bin/OpC/
# opccfgupld -replace -subentity /opt/OV/newconfig/SiteScope/ 
DrillDownToSIS

 g The Drill Down to SiteScope tools are available on the HPOM 
Administrator user interface under Browse > All Tool Groups.

 h Assign Drill Down to SiteScope tools to the opc_adm user. 

➤ Click Action > Assign to User/Profile... 

➤ Select All Users > opc_adm and click OK.

 i Update the HPOM user interface by selecting File > Reload 
Configuration.

 j The Drill Down to SiteScope tools are available on the HPOM server 
under Tools > Drill Down to SiteScope tools.
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 3 Launch the tool (from the SiteScope service)

 a In the HPOM Administrator user interface, right-click the SiteScope 
service (server, group, or monitor), select Start > Tools > Drill Down to 
SiteScope tools > Drill Down to SiteScope service, and select the tool 
according to the service type selected.

 b The SiteScope user interface opens displaying the selected monitor, 
group, or default SiteScope Dashboard view.

 4 Launch the tool (from an event)

 a In the HPOM Administrator user interface, right-click an event and 
select Start > Drill Down to SiteScope tools > Drill Down to SiteScope 
event.

 b The SiteScope user interface opens displaying the selected monitor 
that send the event.
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How to Enable SiteScope to Report Metrics to the 
HP Operations Agent

Note: This section is relevant only to those users connecting SiteScope 11.00 
or later with Operations Management in BSM, or to HP Performance 
Manager 9.0 or later, and only when using the HP Operations agent.

This task describes how to enable SiteScope to report metrics data to HPOM 
and BSM reporting products.

This task includes the following steps:

➤ "Prerequisites" on page 140

➤ "Install the HP Operations agent on the SiteScope server" on page 141

➤ "Enable SiteScope to send metrics" on page 141

➤ "Enable monitor instances to send metrics" on page 142

➤ "Results" on page 142

 1 Prerequisites

➤ Only an administrator in SiteScope or a user granted Edit integration 
preferences permissions has the permissions to perform this task. For 
details, see "User Management Preferences" in Using SiteScope in the 
SiteScope Help.

➤ Performance Manager administrator must configure Performance 
Manager to connect to the SiteScope node where the SiteScope instance is 
logging data. For details, refer to the Performance Manager 
documentation. 
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 2 Install the HP Operations agent on the SiteScope server

You can install the HP Operations agent during or after a SiteScope 
installation from the SiteScope installation media. The agent enables 
SiteScope to act as data storage for metrics data collected by SiteScope. 

For details on installing the agent, see "Installing Using the Installation 
Wizard" in the HP SiteScope Deployment Guide PDF. 

 3 Enable SiteScope to send metrics

In Preferences > Integration Preferences, select an existing Operations 
Manager integration or click HP Operations Manager integration to 
create a new integration. In the HP Operations Manager Integration 
dialog box, expand the HP Operations Manager Metrics Integration panel 
and select Enable HP Operations Manager metrics integration. 

Note: Metrics integration with HP Operations Manager can be activated 
regardless of the connection status between the HP Operations agent and 
the HPOM/BSM server, since metrics are collected by the agent.

For user interface details, see "HP Operations Manager Metrics 
Integration" in Using SiteScope in the SiteScope Help.
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 4 Enable monitor instances to send metrics

For each monitor instance that you want to report metrics data to the 
agent data storage, expand HP Integration Settings in the monitor 
properties, and select Report metrics to HP Operations agent in the HP 
Operations Manager Integration Settings section. 

For user interface details, see "HP Operations Manager Integration 
Settings" in Using SiteScope in the SiteScope Help.

Tip: You can enable reporting metrics for all Memory, CPU, Disk Space, 
and Windows Resources without having to select Report metrics to HP 
Operations agent in the monitor properties for each monitor instance. To 
do so, click the Enable metrics reporting for specific monitors button in 
Integration Preferences > HP Operations Manager Integration > HP 
Operations Manager Metrics Integration panel. 

 5 Results

Each monitor metric is logged as an instance by the agent on the 
SiteScope host node, with the time and host as the instance identifier. The 
metrics data is collected from the agent data storage by HPOM and BSM 
for use in the reporting products.

Metrics error data is written to the oa_metric_integration.log file which is 
found in the <SiteScope root directory>\logs directory. For details on 
using log files, see "Log Files Page" in Using SiteScope in the SiteScope Help.
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Reference

SiteScope-Operations Agent Metrics Alignment

Metrics name alignment is the process of aligning metrics names in 
SiteScope with those used by Operations Manager Performance Agent (PA). 
Metrics name alignment has been performed for the commonly used 
metrics listed below. 

Note: For more information on metrics provided by Performance Agent, 
refer to the HP Performance Agent Metric Help Viewer in the Performance 
Agent 5.0 documentation 
(http://support.openview.hp.com/selfsolve/document/KM864772/binary/
PA5_MetricHelpView.html?searchIdentifier=-65c7a852:127e60d1b54:
6921&resultType=document). To enter the HP Software Self-solve knowledge 
base, you must log on with your HP Passport ID.

PA Metrics Name
(Display Name)

SiteScope Metrics Name

BYCPU_CPU_TOTAL_UTIL

(Total CPU%)

Windows: 

➤ CPU Monitor \utilization (cpu #1, cpu #2, etc)

➤ Microsoft Windows Resources Monitor 
\Processor\{instance}%\ Processor Time

Linux: UNIX Resources Monitor \Processor\{instance}\System

HP-UX: N/A

Solaris: N/A

AIX: UNIX Resources Monitor \Processor\{instance}\%sys
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BYNETIF_IN_BYTE_RATE 

(In KB Rate)

Windows: Microsoft Windows Resources Monitor 
\Network Interface\{instance}\Bytes Received\sec 

Linux: UNIX Resources Monitor \Network Interface\ReceiveBytes

HP-UX: N/A

Solaris: UNIX Resources Monitor \Network Interface\obytes

AIX: N/A

BYNETIF_OUT_BYTE_RATE 

(Out KB Rate)

Windows: Microsoft Windows Resources Monitor 
\Network Interface\{instance}\Bytes Sent\sec 

Linux: UNIX Resources Monitor \Network Interface\TransmitBytes

HP-UX: N/A

Solaris: UNIX Resources Monitor \Network Interface\rbytes

AIX: N/A

BYDSK_PHYS_READ_BYTE_
RATE

(Phys Read KB Rate)

Windows: Microsoft Windows Resources Monitor 
\Physical Disk\{instance}\% Disk Read Bytes\sec

Linux: N/A

HP-UX: N/A

Solaris: UNIX Resources Monitor \PhysicalDisk\nread

AIX: N/A

BYDSK_PHYS_WRITE_BYTE
_RATE

(Phys Write KB Rate)

Windows: Microsoft Windows Resources Monitor 
\Physical Disk\{instance}\% Disk Write Bytes\sec

Linux: N/A

HP-UX: N/A

Solaris: UNIX Resources Monitor \PhysicalDisk\nwritten

AIX: N/A

BYDSK_REQUEST_QUEUE

(Req Queue)

Windows: Microsoft Windows Resources Monitor 
\Physical Disk\{instance}\Avg. Disk Queue Length 

Linux: N/A

HP-UX: N/A

Solaris: N/A

AIX: N/A

PA Metrics Name
(Display Name)

SiteScope Metrics Name
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BYDSK_UTIL

(Disk %)

Windows: Microsoft Windows Resources Monitor 
\Physical Disk\{instance}\% Disk Time

Linux: N/A

HP-UX: UNIX Resources Monitor \Block device activity\<device>\
%busy

Solaris: UNIX Resources Monitor \Block device activity\<device>\
%busy

AIX: UNIX Resources Monitor\Block device activity\<device>\
%busy

FS_SPACE_UTIL 

(Space%)

Windows: Disk Space Monitor \percent full

Linux: Disk Space Monitor \percent full

HP-UX: Disk Space Monitor \percent full

Solaris: Disk Space Monitor \percent full

AIX: Disk Space Monitor \percent full

GBL_CPU_TOTAL_UTIL

(CPU %)

Windows: 

➤ CPU Monitor \utilization (avgas)

➤ Microsoft Windows Resources Monitor \Processor\_Total\
% Processor Time

Linux: UNIX Resources Monitor \Processor\Total\System

HP-UX: N/A

Solaris: N/A

AIX: UNIX Resources Monitor\Processor\Total\%sys

GBL_MEM_PAGEOUT_RATE 

(Pg Out Rate)

Windows: Microsoft Windows Resources Monitor \Memory\Pages 
Output/sec 

Linux: N/A

HP-UX: N/A

Solaris: UNIX Resources Monitor \Page-out memory and memory 
freeing activities\ppgout/s

AIX: N/A

PA Metrics Name
(Display Name)

SiteScope Metrics Name
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GBL_MEM_UTIL

(Memory %)

Windows: Memory Monitor \percent used

Linux: MemoryMonitor \percent used

HP-UX: MemoryMonitor \ percent used

Solaris: MemoryMonitor \percent used

AIX: N/A

GBL_SWAP_SPACE_UTIL

(Swap %)

Windows: Microsoft Windows Resources Monitor \Memory\
% Committed Bytes In Use 

Linux: N/A

HP-UX: N/A

Solaris: N/A

AIX: N/A

PA Metrics Name
(Display Name)

SiteScope Metrics Name
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Sizing Recommendations for SiteScope-Operations 
Manager Metrics Integration

While the default SiteScope configuration enables running thousands of 
monitors, sizing is important for planning the maximum number of 
monitors, metrics, and monitors types that can be stored within the 
SiteScope-HPOM metrics integration. 

The sizing should not exceed:

➤ Maximum insertion rate of 1000 metrics per minute.

➤ Total retention storage of 1 GB.

➤ Total retention period of 5 weeks.

Definitions

The following are definitions of the terms used in the validation 
calculations below:

➤ Monitors. The number of monitors that report metrics to HPOM 
Performance Manager.

➤ Metrics. The average number of metrics of the above mentioned monitors 
that report to HPOM Performance Manager.

➤ Frequency. The average frequency at which the above mentioned 
monitors feed data into the integration.
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Validation

When choosing the specific SiteScope monitors and metrics to store within 
the SiteScope-HPOM metrics integration, you should validate that the 
insertion and retention rates do not exceed the recommendations. You can 
do that using the formulae below:

➤ Supported Insertion Rate Validation:
(Monitors * Metrics) / Frequency <= 1000 metrics/minute

➤ Supported Retention Period Validation: 
(1000 MB) / ((Monitors * Metrics / Frequency) * 0.07 MB) = configured 
retention period in days (which should be less than the maximum 
retention period of 5 weeks) 

where 0.07 MB is the storage size for each metric/minute per day.

Example

If you have 2500 monitors that report data using the HPOM metrics 
integration, and every monitor has 4 metrics, the frequency of these 
monitors is every 10 minutes, and the average metric storage size per day is 
0.07 MB, you will be able to store your historical data for 14 days.

Validation calculations:

➤ Insertion Rate Validation:
(2500 monitors * 4 metrics) / 10 minutes = 1000 <= 1000 metrics/minute

➤ Retention Period Validation:
1000 MB / (((2500 * 4 Metrics) / 10 minutes) * 0.07 MB) = 14.28 days 
(<= 5 weeks) 
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4
Working with Network Node Manager i 
(NNMi)

This chapter includes:

Concepts

➤ Sending SiteScope Events to NNMi on page 150

➤ Reporting Metrics to NNMi on page 152

Tasks

➤ How to Configure SiteScope to Send Event Data to NNMi on page 153

➤ How to Configure SiteScope to Report Metrics Data to NNMi on page 156

Reference

➤ SNMP Trap Format for SiteScope Objects Sent to NNMi on page 160

➤ SiteScope Monitor Metrics Reported to NNMi on page 163

Troubleshooting and Limitations on page 165
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Concepts

Sending SiteScope Events to NNMi

SiteScope can be used as a data collector for Network Node Manager i 
(NNMi)—an event console used for network monitoring. SiteScope 
monitors the application side of the system that NNMi is monitoring, and 
uses SNMP Trap alerts to forward event data from any type of SiteScope 
monitor to NNMi. Events in SiteScope are based on SiteScope monitor 
metric status changes and triggered alerts. 

SiteScope sends SNMP traps to NNMi which are converted to NNMi 
incidents. From the resulting incidents, an NNMi console user can launch 
SiteScope in the context of that monitor (using the URL in the SNMP trap 
format sent to the NNMi server). For the list of SNMP trap formats used to 
identify the SiteScope object sending the message to the NNMi server, see 
"SNMP Trap Format for SiteScope Objects Sent to NNMi" on page 160.
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The following diagram illustrates the use of SiteScope as an event data 
collector for NNMi.

To enable SiteScope to send event data to NNMi, the SiteScope must be 
configured as a data collector for NNMi. This involves configuring an SNMP 
preference for the server to which you want to report the SNMP trap, and 
creating an SNMP Trap alert and assigning it to those monitors that you 
want to report to NNMi.

For details on configuring SiteScope to send events, see "How to Configure 
SiteScope to Send Event Data to NNMi" on page 153.

Supported Versions

➤ SiteScope version 11.10 or later

➤ NNMi version 9.10 or later

For the most recent information about supported hardware platforms and 
operating systems, see the support matrices for all products.
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Reporting Metrics to NNMi

SiteScope can also report metrics data to NNMi. To enable SiteScope to 
report metrics, the Generic Data Integration must be configured on the 
SiteScope server. The SiteScope–NNMi metrics integration populates the 
NNM iSPI Performance for Metrics Network Performance Server (NPS) with 
system metrics data collected by SiteScope monitors.

Supported Versions

➤ SiteScope version 11.10 or later

➤ NNMi version 9.10 or later

➤ NNM iSPI Performance for Metrics version 9.10 or later 

For the most recent information about supported hardware platforms and 
operating systems, see the support matrices for all products.

Supported SiteScope Monitors

While SiteScope reports all monitor types, NNMi only recognizes and 
forwards data to NPS for consumption from the following SiteScope 
monitor types:

➤ CPU Utilization Monitor

➤ Disk Space Monitor

➤ Memory Monitor

➤ The Process monitored object of the Microsoft Windows Resources 
Monitor

➤ The Process monitored object of the UNIX Resources Monitor 

The nodes being monitored must be managed in NNMi. The integration 
discards data for nodes that are not in the NNMi topology and for 
unmanaged nodes.

For details on how to configure SiteScope to communicate with NNM, see 
"How to Configure SiteScope to Report Metrics Data to NNMi" on page 156. 

For details on how to configure NNMi to communicate with SiteScope, refer 
to the NNMi Deployment Reference included on the NNMi product media.
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Tasks

How to Configure SiteScope to Send Event Data to NNMi

This task describes how to configure SiteScope to send event data to NNMi.

This task includes the following steps:

➤ "Create an SNMP preference for reporting the SNMP Trap to the NNMi 
server" on page 153

➤ "Configure a SiteScope alert to send events to NNMi" on page 154

➤ "Results" on page 155

 1 Create an SNMP preference for reporting the SNMP Trap to 
the NNMi server

In SiteScope, select Preferences > SNMP Preferences, and create a 
preference for the server to which you want to report the SNMP trap using 
the following settings: 

➤ SNMP trap ID. Select Enterprise-Specific SNMP trap ID, and enter 1.

➤ SNMP object ID. Select Preconfigured SNMP object IDs and choose HP 
SiteScope Event from the list.

Complete the other SNMP trap fields as required. 

For user interface details, see "New/Edit SNMP Trap Dialog Box" in Using 
SiteScope in the SiteScope Help.
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 2 Configure a SiteScope alert to send events to NNMi

Create a SiteScope alert and configure an SNMP Trap alert action for each 
monitor state.

 a In the SiteScope monitor tree, right-click the SiteScope root and select 
New > Alert. 

 b In the Alert Targets panel, select the groups, monitors, or both, to 
trigger this alert. For user interface details, see "New/Edit Alert Dialog 
Box" in Using SiteScope in the SiteScope Help.

 c In the Alert Actions panel, click New Alert Action and select SNMP 
Trap action type. For user interface details, see "Action Type Dialog 
Box" in Using SiteScope in the SiteScope Help.

 d In the Alert Action: SNMP Trap dialog box, configure an SNMP Trap 
alert action for each monitor state. 

➤ In the Action Type Settings panel, select SiteScopeEvent.xml from 
the Template list. This template contains the format and content of 
messages sent by SNMP to NNMi when a SNMP trap is triggered. You 
can copy and customize this template which is located in the 
<SiteScope root directory>\templates.snmp. For user interface 
details, see "SNMP Trap Alert Properties" in Using SiteScope in the 
SiteScope Help.

➤ In the Status Trigger panel, select an SNMP trap status. For user 
interface details, see "Status Trigger Panel" in Using SiteScope in the 
SiteScope Help.

➤ Repeat step c for each monitor state in the Status Trigger panel 
(Error, Warning, Good, and Unavailable).
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Example:

The example shows an NNMi alert with an SNMP trap alert action for 
each trigger status (Error, Warning, Good, and Unavailable).

 3 Results

When an alert is triggered in SiteScope as a result of monitor status 
change, the alert reports an SNMP trap to the NNMi server. NNMi reads 
the SNMP trap, translates the attributes, and displays the SiteScope event 
data in the NNMi Incidents Console. 

For details on the NNMi Incidents Console, refer to the NNMi Deployment 
Reference included on the NNMi product media.
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How to Configure SiteScope to Report Metrics Data to 
NNMi

This task describes how to configure SiteScope to report metrics data to 
NNMi.

This task includes the following steps:

➤ "Enable the integration on the NNMi server" on page 156

➤ "Configure SiteScope to communicate with NNMi using SSL" on page 156

➤ "Create a search/filter tag to identify the NNMi server" on page 157

➤ "Configure the connection between SiteScope and the NNMi server" on 
page 157

➤ "Configure the monitors that contribute to SiteScope reports on the 
NNMi server" on page 158

➤ "Results" on page 159

 1 Enable the integration on the NNMi server

For details on how configure the NNMi metrics integration in the NNMi 
console, see "HP NNMi—HP SiteScope System Metrics Integration" in 
NNMi Deployment Reference included on the NNMi product media.

 2 Configure SiteScope to communicate with NNMi using SSL

 a In SiteScope, select Preferences > Certificate Management, and click 
the Import Certificates  button. For user interface details, see 
"Import Certificates Dialog Box" in Using SiteScope in the SiteScope 
Help. 

 b Under Source Selection, provide information to identify the NNMi 
management server to SiteScope:

➤ Select Host, and enter the fully-qualified domain name of the NNMi 
management server.

➤ If necessary, change the port number to match the HTTPS port on 
the NNMi management server.
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 c Click Load. The NNMi certificate information appears under Loaded 
Certificates. Note the certificate alias.

 d Select the NNMi certificate, and then click Import. The imported 
certificate is listed on the Certificate Management keystore list.

 3 Create a search/filter tag to identify the NNMi server

 a In SiteScope, select Preferences > Search/Filter Tags, and click the New 
Tag  button. For user interface details, see "New/Edit Tag Dialog 
Box" in Using SiteScope in the SiteScope Help. 

 b Enter a tag name (for example, NNMi_upload) and at least one value.

 4 Configure the connection between SiteScope and the NNMi 
server

 a In SiteScope, select Preferences > Integration Preferences, click the 
New Integration  button, and then click Data Integration. For user 
interface details, see "Data Integration Preferences Dialog Box" in Using 
SiteScope in the SiteScope Help.

 b Under General Settings, enter a name (for example, NNMi_receiver) 
and a description (optional).

 c Under Data Integration Preferences Settings, include the following 
settings:

➤ In the Receiver URL field, paste the URL returned after enabling the 
integration in the NNMi Console (for example: 
https://NNMi_server.example.com:443/sitescope-
adapter/sitescopereceiver).

➤ Select the GZIP compression check box.

➤ Clear the Include additional data and Error on redirect check boxes. 
(These are the default settings.)

➤ Select the Authentication when requested check box. (This is the 
default setting.)

➤ Clear the Disable integration check box. (This is the default setting.)

➤ For all other settings, the default configuration is acceptable.
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 d Under Web Server Security Settings, enter the user name and 
password for the NNMi user that was specified on the integration 
configuration form in the NNMi console. Contact your NNMi 
administrator for assistance.

 e Under Reporting Tags, select the search/filter tag that you created in 
step 3 (for example, NNMi_upload).

 5 Configure the monitors that contribute to SiteScope reports 
on the NNMi server

 a Create new monitors or identify existing monitors of the supported 
types (as required):

➤ CPU Utilization Monitor

➤ Disk Space Monitor

➤ Memory Monitor

➤ The Process monitored object of the Microsoft Windows Resources 
Monitor

➤ The Process monitored object of the UNIX Resources Monitor

Configure monitor settings. For a description of the monitor settings, 
see the help for the specific monitor in Monitor Reference in the 
SiteScope Help.

For the list of available counters, see "SiteScope Monitor Metrics 
Reported to NNMi" on page 163.

 b Add the search/filter tag that you created in step 3 (for example, 
NNMi_upload) to the monitors that should pass data to NNMi.

The integration can only process data for managed nodes in the NNMi 
topology. So, only apply the tag to monitors on nodes in the NNMi 
topology.

Tip: It is recommended to organize the monitors that pass data to 
NNMi into one monitor group.
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 6 Results

The NNM iSPI Performance for Metrics Network Performance Server (NPS) 
is populated with system metrics data collected by the SiteScope 
monitors. 

For more details, refer to the NNMi Deployment Reference included on the 
NNMi product media.
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SNMP Trap Format for SiteScope Objects Sent to NNMi

Following is a list of SNMP trap formats used to identify the SiteScope object 
sending the message to the NNMi server. This enables an NNMi console user 
to launch SiteScope in the context of that monitor.

The SNMP trap formats are stored in the SiteScopeEvent.xml file which is 
located in the <SiteScope root directory>\templates.snmp folder.

Field Name Object ID (OID) Description Values

Enterprise OID .1.3.6.1.4.1.11.15.1 SiteScope root Object ID .1.3.6.1.4.1.11.15.1

Trap OID .1.3.6.1.4.1.11.15.1.0 SNMP Trap Object ID (OID)

For V1: 
[1.3.6.1.4.1.11.15.1.4.0.
1]

For V2: 
[1.3.6.1.4.1.11.15.1.4.1]

SiteScope Host .1.3.6.1.4.1.11.15.1.1.2 IP address or host name 
of the SiteScope server

(IpAddress) 

[16.55.244.182] or 

(OctetString) 

[sisserver.mydomain]

Provider 
(Collector)

.1.3.6.1.4.1.11.15.1.1.3 SiteScope application 
name

(OctetString)

SiteScope

Monitor Name .1.3.6.1.4.1.11.15.1.2.1.1 SiteScope monitor name (OctetString) 

[Memory monitor on 
myhost.mydomain]

Monitor Type .1.3.6.1.4.1.11.15.1.2.1.2 SiteScope monitor type (OctetString)

[Memory Monitor]
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Monitor ID .1.3.6.1.4.1.11.15.1.2.1.3 Monitor unique ID (OctetString) 

[067e6162-3b6f-4ae2-
a171-2470b63dff00]

Monitor Drill 
Down URL 
Secured 

.1.3.6.1.4.1.11.15.1.2.1.4 URL that opens 
SiteScope in context of 
the alerted monitor, 
without silent login 
information. This allows 
configuration per 
integration instance 
level. 

To get drill down URL 
with user credentials, 
change the reference 
value from 
monitorDrilldownUrl
Secured to 
monitorDrilldownUrl.

(OctetString)

[http://sisserver:8080/Si
teScope/servlet/Main?
activeid=__SiteScope
Root__&activerighttop=
dashboard&view=new
&dashboard_view=
Details&dashboard_
model=true&dashb

Monitor Target 
Host

.1.3.6.1.4.1.11.15.1.2.1.5 Monitor target host (IpAddress) 

[16.55.244.182] or

(OctetString) 

[myhost.mydomain]

Monitor Target 
IP

.1.3.6.1.4.1.11.15.1.2.1.6 Monitor target IP 
address

(IpAddress) 

[16.55.244.182]

Monitor Full 
Name

.1.3.6.1.4.1.11.15.1.2.1.7 SiteScope monitor name 
including full path from 
the root.

(OctetString) 

[Memory monitor on 
myhost.mydomain]

Title .1.3.6.1.4.1.11.15.1.3.1.1 SiteScope Event Title (OctetString) 

[Alert 'Memory Alert' 
was triggered on 
monitor 'Memory 
monitor on 
myhost.mydomain' due 
to a status change]

Field Name Object ID (OID) Description Values
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Event Source .1.3.6.1.4.1.11.15.1.3.1.2 Source of the event (alert 
or metric)

(OctetString)

Severity .1.3.6.1.4.1.11.15.1.3.1.3 SiteScope event severity (Integer) [0,1,2,3]

For [unavailable, good, 
warning, error]

Event Time .1.3.6.1.4.1.11.15.1.3.1.4 Original event time in 
milliseconds

(TimeTicks)

1287316779

Value .1.3.6.1.4.1.11.15.1.3.1.5 (Not for alerts flow) (OctetString) 

[running] or [25] or 
[n/a] - for alerts

Event 
Description

.1.3.6.1.4.1.11.15.1.3.1.6 Description of fired 
event

(OctetString) 

Event Key .1.3.6.1.4.1.11.15.1.3.1.7 Key of the event (OctetString) 

[sisserver:067e6162-
3b6f-4ae2-a171-
2470b63dff00:Memory 

Event Close 
Key Pattern

.1.3.6.1.4.1.11.15.1.3.1.8 Key to identify paring 
events

[sisserver:067e6162-
3b6f-4ae2-a171-
2470b63dff00]

Field Name Object ID (OID) Description Values
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SiteScope Monitor Metrics Reported to NNMi

Following is a list of SiteScope monitor metrics that are reported to the 
NNMi server.

Monitor Available Metrics

CPU Utilization CPU Utilization

Note: SiteScope delivers CPU utilization data 
collected on the HP-UX and AIX operating systems 
as a single average value for the system, not per 
specific CPU. Because the integration does not send 
average values to NNMi, CPU utilization data is not 
available for the HP-UX and AIX operating systems.

Disk Space ➤ Disk MB Free

➤ Disk Percent Full

Memory ➤ Memory Pages/Sec

➤ Physical Memory MB Free

➤ Physical Memory Used Percent

➤ Swap Memory MB Free

➤ Swap Memory Used Percent

➤ Virtual Memory MB Free

➤ Virtual Memory Used Percent

Note: SiteScope does not collect all of these metrics 
for all operating systems.
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Microsoft Windows 
Resources

➤ Windows Process – Creating Process ID

➤ Windows Process – Elapsed Time

➤ Windows Process – Handle Count

➤ Windows Process – ID Process

➤ Windows Process – IO Data Bytes/sec

➤ Windows Process – IO Data Operations/sec

➤ Windows Process – IO Data Other Bytes/sec

➤ Windows Process – IO Read Bytes/sec

➤ Windows Process – IO Read Operations/sec

➤ Windows Process – IO Write Bytes/sec

➤ Windows Process – IO Write Operations/sec

➤ Windows Process – Page Faults

➤ Windows Process – Page File Bytes

➤ Windows Process – Page File Bytes Peak

➤ Windows Process – Percent Privileged Time

➤ Windows Process – Percent Processor Time

➤ Windows Process – Percent User Time

➤ Windows Process – Pool Nonpaged Bytes

➤ Windows Process – Pool Paged Bytes

➤ Windows Process – Priority Base

➤ Windows Process – Private Bytes

➤ Windows Process – Private Working Set

➤ Windows Process – Thread Count

➤ Windows Process – Virtual Bytes

➤ Windows Process – Virtual Bytes Peak

➤ Windows Process – Working Set

➤ Windows Process – Working Set Peak

Monitor Available Metrics
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Troubleshooting and Limitations

This section describes troubleshooting and limitations when integrating 
SiteScope with NNMi.

➤ Troubleshooting the SiteScope-NNMi Event Integration

If the NNMi incident views do not contain any SiteScope monitor alert 
incidents, verify in SiteScope that at least one monitor alert has been 
configured to send SNMP traps to NNMi. For details, see "Configure a 
SiteScope alert to send events to NNMi" on page 154.

For troubleshooting the integration from the NNMi side, refer to the 
"Troubleshooting the HP NNMi—HP SiteScope Events Integration" section 
in the NNMi Deployment Reference.

➤ Troubleshooting the SiteScope-NNMi Metrics Integration Data Flow

Check the SiteScope error log files (data_integration.log) for messages 
relating to problems with the data integration. For more information, see 
"Using Log Files" in Using SiteScope in the SiteScope Help.

For troubleshooting the integration from the NNMi side, refer to the 
"Troubleshooting the HP NNMi—HP SiteScope System Metrics 
Integration" section in the NNMi Deployment Reference.

UNIX Resources ➤ Unix Process – CPU Percent

➤ Unix Process – Memsize

➤ Unix Process – Number_Running

➤ Unix Process – PID

Note: For the UNIX Resources monitor on the 
HP-UX operating system, SiteScope collects CPU 
percent, number running, and process ID only. 
Memory size and user data are not available for 
HP-UX nodes.

Monitor Available Metrics
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5
Indicator Assignment Settings

This chapter includes:

Concepts

➤ Indicator Assignments Overview on page 168

Tasks

➤ How to Create and Manage Indicator Assignments on page 170

Reference

➤ Indicator Mapping Alignment on page 173

➤ Indicator Assignments User Interface on page 186
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Concepts

Indicator Assignments Overview

Note: 

➤ This section is relevant only to those users connecting SiteScope 11.00 or 
later with HP Operations Manager (HPOM) or Operations Management 
in BSM version 9.00 or later. 

➤ Only advanced users with a thorough knowledge of creating and 
updating indicators and assignment mappings should edit settings in the 
Metrics and Indicators tab.

SiteScope monitor metrics are mapped to health indicators (HIs) and event 
type indicators (ETIs), which are stored and managed in the Indicator 
Assignments repository in SAM Administration. Indicators provide a more 
detailed view of the health of a configuration item (CI). For details on 
understanding indicators, see "Configuring KPIs and Health Indicators" in 
Service Health. 
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The Indicator Assignments repository has the following benefits:

➤ Centralized management of metric-to-indicator assignments makes it 
easier to manage large numbers of SiteScopes and monitors. The Indicator 
Assignments repository is available for editing in the Metrics and 
Indicators tab. 

➤ Metrics are assigned from different SiteScope monitors to indicators, per 
monitor type. You can create, edit, and delete assignments for specific 
monitor types.

➤ Metrics can be assigned to new monitors. This is useful where:

➤ The version of SiteScope contains a monitor type that is unavailable in 
the version of BSM being used.

➤ Indicators need to be configured for synthetic monitors and groups 
created by the EMS integration monitors (by adding new monitors to 
the repository).

➤ If new indicator assignments are added or existing assignments are 
modified in the Indicator Assignments repository, these changes can be 
published to all SiteScopes that are connected to BSM. This ensures that 
new monitor instances created in SiteScope have indicators according to 
the latest centralized assignments. 

➤ The central repository ensures compatibility with earlier versions of 
SiteScope by mapping metrics from earlier SiteScopes to indicators. When 
a hard synchronization is performed on SiteScope, all the latest mappings 
are downloaded from BSM.

➤ In cases where indicator assignments have been modified on a local 
SiteScope server (mappings for monitor metrics were changed), these 
assignments are not overridden by the centralized assignments when 
publishing assignment changes to SiteScope.

For task details, see "How to Create and Manage Indicator Assignments" on 
page 170.

For user interface details, see "Metrics and Indicators Tab" on page 186.
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Tasks

How to Create and Manage Indicator Assignments

The following steps describe how to map SiteScope monitor metrics to 
indicator assignments in SAM Administration.

➤ "Prerequisites" on page 170

➤ "Manage existing indicator assignments" on page 171

➤ "Create a new indicator assignment" on page 171

➤ "Publish indicator assignment changes to SiteScope" on page 172

➤ "Results" on page 172

 1 Prerequisites

Only advanced users with a thorough knowledge of creating and 
updating indicators and assignments should edit settings in the Metrics 
and Indicators tab.

Note: When connecting SiteScope with BSM 9.x, the HPOprInf, 
HPOprMss, HPOprOra, and HPOprJEE content packs are required (they 
are installed by default, so you generally do not need to do anything). If 
you do not have these content packs, you need to import them as 
described in "How to Create and Manage Content Packs" in Platform 
Administration.
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 2 Manage existing indicator assignments

You can view, edit, or delete metric-to-indicator assignments in the 
Metrics and Indicators tab in SAM Administration. In addition, you can 
export and import indicator assignments to and from an XML file. 

For user interface details, see "Metrics and Indicators Tab" on page 186.

 3 Create a new indicator assignment

You can create indicator assignments for a new or an existing monitor 
type.

 a Select Admin > System Availability Management > Metrics and 
Indicators tab, and click the Select Monitor button.

➤ For an existing monitor, select a monitor from the list. For user 
interface details, see "Select Monitor Dialog Box" on page 189.

➤ For a new monitor, click the New Monitor button and enter the 
name for the monitor and select a monitor category. For user 
interface details, see "Create New Monitor Dialog Box" on page 191.

 b In the Indicator Assignment Settings panel, click the New Assignment 
button. 

 c In the New/Edit Assignment dialog box, enter a regular expression 
pattern for the metric based on the metric name, and select the 
indicator mapping assigned to the selected CI type. For user interface 
details, see "New/Edit Assignment Dialog Box" on page 192.

Note: To check the correctness of regular expression syntax used in 
indicator assignments, run the HIMappingValidator.bat tool located in 
the <SiteScope root directory>\tools\TopazIntegration directory. To 
use this tool, you must specify the Indicator Assignment XML file (this 
is the file to which monitor indicator assignments were exported after 
making changes to indicator assignments).

 d Click Save. A validation message indicates whether the assignment 
was successfully created.
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 4 Publish indicator assignment changes to SiteScope

To publish changes to SiteScope, click the Publish Changes button. All 
new indicator assignments and changes to existing assignments are 
downloaded to SiteScope, and override the indicator states for existing 
monitor instances. 

For user interface details, see "Metrics and Indicators Tab" on page 186.

Note: Indicator assignment states that were modified on a local SiteScope 
server are not overridden by the updated centralized assignments.

 5 Results

SiteScope periodically checks with BSM for updated assignments, and 
downloads the updated assignments to SiteScope. This ensures that new 
monitor instances created in SiteScope have indicators according to the 
latest centralized assignments. 

For details on assigning metrics to indicators in SiteScope, see "Assigning 
SiteScope Metrics to Indicators" on page 63.
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Indicator Mapping Alignment

Indicator mapping alignment is the process of aligning metrics names in 
SiteScope with indicators used by content packs in HP Operations Manager. 
Indicator mapping alignment has been performed for the SiteScope monitor 
metrics listed below. 

Note: 

➤ All monitors have a default Legacy System mapping which is listed at the 
bottom of the mappings table. This is the default configuration for 
monitors that do not have an out-of-the box mapping. If you change the 
metrics order and move the Legacy System mapping to the top of the list, 
since the Legacy System mapping does not have a regular expression, 
none of the other listed mappings for the monitor are mapped.

➤ Indicator assignment mappings for Microsoft Exchange and Active 
Directory monitors cannot be reported to BSM.

➤ If a content pack has not been installed on the BSM server, no mappings 
related to indicators of the missing content pack are displayed.

This section includes indicator mappings for the following monitors:

➤ "CPU Monitor" on page 175

➤ "Database Counter Monitor" on page 175

➤ "Disk Space Monitor" on page 175

➤ "JMX (JBoss) Monitor" on page 175

➤ "JMX (WebLogic) Monitor" on page 176

➤ "Memory Monitor" on page 176

➤ "Microsoft SQL Server Monitor" on page 177



Chapter 5 • Indicator Assignment Settings

174

➤ "Microsoft Windows Resources Monitor" on page 178

➤ "Oracle Database Monitor" on page 178

➤ "Ping Monitor" on page 179

➤ "SAP CCMS Monitor" on page 179

➤ "SAP Work Processes Monitor" on page 180

➤ "Service Monitor" on page 180

➤ "Siebel Application Server Monitor" on page 181

➤ "Siebel Web Server Monitor" on page 181

➤ "Solaris Zones Monitor" on page 182

➤ "UNIX Resources Monitor" on page 182

➤ "UNIX Resources (AIX) Monitor" on page 182

➤ "UNIX Resources (HP-UX) Monitor" on page 182

➤ "UNIX Resources (Linux) Monitor" on page 182

➤ "UNIX Resources (Solaris) Monitor" on page 183

➤ "VMware Host CPU Monitor" on page 183

➤ "VMware Host Memory Monitor" on page 183

➤ "VMware Host Network Monitor" on page 183

➤ "VMware Host State Monitor" on page 184

➤ "VMware Host Storage Monitor" on page 184

➤ "WebSphere Application Server Monitor" on page 184
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CPU Monitor

Database Counter Monitor

Disk Space Monitor

JMX (JBoss) Monitor

Metric Pattern CI Type Name Indicator

/utilization.*/ Computer CPU Load

Metric Pattern CI Type Name Indicator

round trip time Database SQL Query Performance

Metric Pattern CI Type Name Indicator

percent full Computer Host Disk Utilization

Metric Pattern (A-Z) CI Type Name Indicator

/.*CommitCount/ J2EE Server Transaction Commit Rate 

/.*HeapMemoryUsage\/used/ J2EE Server Heap Size Current 

/.*processingTime/ J2EE Server Servlet Performance

/.*RollbackCount/ J2EE Server Transaction Rolled Back 

/.*SystemLoadAverage/ Computer CPU Load

/.*SystemLoadAverage/ J2EE Server Application Server Load

/.*ThreadPool/.*/current
ThreadCount/

J2EE Server Thread Pool Availability

/.*ThreadPool\/.*/current
ThreadsBusy/

J2EE Server Thread Pool Utilization

/.*WebModule/.*/processing
Time/

J2EE Server Http Request Average 
Service Time
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JMX (WebLogic) Monitor

Memory Monitor

Metric Pattern (A-Z) CI Type Name Indicator

/.*AllProcessorsAverageLoad/ J2EE Server All Processors Average 
Load

/.*CurrentWaitTime/ J2EE Server Thread Request Wait Time

/.*\ExecuteThreadTotalCount/ J2EE Server Thread Pool Utilization

/.*HeapFreeCurrent/ J2EE Server Heap Free Current

/.*JvmProcessorLoad/ Computer CPU Load

/.*MissTotalCount/ J2EE Server EJB Missed Count Rate

/.*OpenSocketsCurrentCount/ J2EE Server Active Sockets Count

/.*TimeoutTotalCount/ J2EE Server EJB Timeout Rate

/.*TransactionCommitted
TotalCount/

J2EE Server Transaction Commit Rate

/.*\TransactionTotalCount/ J2EE Server Transaction Start Rate

/.*TransactionsRolledBack
TotalCount/

J2EE Server EJB Transaction Rollback 
Rate

/.*TransactionRolledBackTotal
Count/

J2EE Server Transaction Rollback Rate

/.*TransactionsTimedOutTotal
Count/

J2EE Server Transaction Timeout Rate

/.*WaitingForConnection
CurrentCount/

J2EE Server JDBC Connection Pool 
Wait Count

/.*\UsedHeap/ J2EE Server Heap Size Current

Metric Pattern CI Type Name Indicator

percent used Computer Memory Load
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Microsoft SQL Server Monitor

Metric Pattern (A-Z) CI Type Name Indicator

/.*Active cursors.*/ SQL Server SQL Server Active Cursor

/.*Active Transactions.*/ SQL Server SQL Server Database Active 
Transactions

/.*Average Latch Wait Time 
(ms).*/

SQL Server Database Latch Wait Rate

/.*Cache Hit Ratio.*/ SQL Server Cache Performance

/.*Cursor memory usage.*/ SQL Server SQL Server Cursor Memory 
Usage 

/.*Data File(s) Size (KB).*/ SQL Server SQL Server Databases Data 
File Size

/.*Lock Memory (KB).*/ SQL Server Lock Memory Used Pct

/.*Lock Timeouts/sec.*/ SQL Server Database Lock Timeout 
Rate

/.*Lock Wait Time (ms).*/ SQL Server Lock Wait Rate

/.*Lock Waits/sec.*/ SQL Server Lock Wait Rate

/.*Number of active cursor 
plans.*/

SQL Server SQL Server Active Cursor

/.*Number of Deadlocks/sec.*/ SQL Server Database Deadlock

/.*Percent Log Used.*/ SQL Server Transaction Log Usage 
Level

/.*SQLServer:Replication 
Agents : Running.*/

Database Replication Status

/.*Transactions/ Database Server Transaction Rate

/.*Transaction Delay.*/ SQL Server Database Mirroring 
Transaction Delay
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Microsoft Windows Resources Monitor

Oracle Database Monitor

/.*Transactions/sec.*/ SQL Server SQL Server Databases 
Transaction Rate

/.*User Connections.*/ SQL Server Users Connected 
Percentage

Metric Pattern (A-Z) CI Type Name Indicator

/Network 
Interface*\\.*\\Packets 
Received Discarded/

Computer Interface Discard Rate

/Network 
Interface\\.*\\Packets 
Received Errors/

Computer Interface Error Rate

/Paging File.*\\% Usage/ Computer PageFile Usage

/Paging File\\_Total\\% 
Usage/

Computer Swap Usage Level

/Processor\\.*\\% Processor 
Time/ 

Computer CPU Load

Metric Pattern (A-Z) CI Type Name Indicator

/.*CPU used by this session/ Database SQL Query Performance

/.*opened cursors current/ Oracle Oracle Opened Cursor 
Current 

/.*parse count (hard)/ Oracle Oracle Parse Count (Hard)

/.*parse count (failures)/ Oracle Oracle Parse Count 
(Failures)

/*.physical reads/ Oracle Physical Read Rate

Metric Pattern (A-Z) CI Type Name Indicator
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Ping Monitor

SAP CCMS Monitor

/.*redo log space wait time/ Oracle Waits On Redo Log Space

/.*session connect time/ Oracle Oracle Session Connect 
Time

/.*session cursor cache hits/ Oracle Row Cache Hit Ratio

/*.session logical reads/ Oracle Logical Read Rate

/.*table scans (long tables)/ Oracle Long Table Scans 
Percentage

/.*total file opens/ Oracle Datafiles Status

/.*user calls/ Oracle Oracle Users Call Rate

Metric Pattern CI Type Name Indicator

round trip time Node Ping Availability

Metric Pattern CI Type Name Indicator

* SAP Work Process SAP General

* SAP ABAP 
Application 
Server

SAP General

* SAP System SAP General

* Database SAP General

Metric Pattern (A-Z) CI Type Name Indicator
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SAP Work Processes Monitor

Service Monitor

Metric Pattern CI Type Name Indicator

* SAP Work Process SAP General

* SAP ABAP 
Application 
Server

SAP General

Metric Pattern (A-Z) CI Type Name Indicator

/(?i).*apache.*/ Computer WebServer Service

/(?i).*ftp.*/ Computer WebServer Service

/(?i).*nfs.*/ Computer WebServer Service

/(?i).*smbd.*/ Computer WebServer Service

/(?i).*sshd.*/ Computer Secure Login Service

/(?i)crond.*/ Computer Batch Job Service

/DHCPServer.*/ Computer DHCP Server Service

/DNSServer.*/ Computer DNS Service

/EventLog.*/ Computer Event Logging Service

/IISAdminService.*/ Computer WebServer Service

/TaskScheduler.*/ Computer Batch Job Service

/TerminalServices.*/ Windows MS Terminal Server 
Service
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Siebel Application Server Monitor

Siebel Web Server Monitor

Metric Pattern (A-Z) CI Type Name Indicator

/.*No. of Running Sessions/ Siebel Component Siebel Sessions

/.*No. of Running Sessions/ Siebel Component 
Group

Siebel Sessions

/.*No. of Running Sessions/ Siebel Application 
Server

Siebel Sessions

/.*No. of tasks in error/ Siebel Component Siebel Tasks in Error

/.*No. of tasks in error/ Siebel Component 
Group

Siebel Tasks in Error

/.*No. of tasks in error/ Siebel Application 
Server

Siebel Tasks in Error

* Siebel Component Siebel General

* Siebel Component 
Group

Siebel General

* Siebel Application 
Server

Siebel General

Metric Pattern CI Type Name Indicator

* Siebel Web Server 
Extension

Siebel General

* Siebel Web 
Application

Siebel General
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Solaris Zones Monitor

UNIX Resources Monitor

UNIX Resources (AIX) Monitor

UNIX Resources (HP-UX) Monitor

UNIX Resources (Linux) Monitor

Metric Pattern (A-Z) CI Type Name Indicator

/HostSystem/.*/cpu/%sys/ Computer CPU Load

/Zone/.*/cpu/%usageOfMachine
Cpu/

Computer CPU Load

/Zone/.*/mem/%memory/ Computer Memory Load

Metric Pattern CI Type Name Indicator

/FileSystems\.*\Use%/ Unix File System Usage

Metric Pattern (A-Z) CI Type Name Indicator

/FileSystems\/\%Used Computer Root Disk Usage level

/Paging Spaces/.*/%Used Computer Swap Usage Level

Metric Pattern CI Type Name Indicator

/FileSystems\/\Used Computer Root Disk Usage level

/Paging Spaces/.*/USED-PERC Computer Swap Usage Level

Metric Pattern CI Type Name Indicator

/FileSystems\/\Use % Computer Root Disk Usage level



Chapter 5 • Indicator Assignment Settings

183

UNIX Resources (Solaris) Monitor

VMware Host CPU Monitor

VMware Host Memory Monitor

VMware Host Network Monitor

Metric Pattern (A-Z) CI Type Name Indicator

/FileSystems\/\used Computer Root Disk Usage level

Unused memory pages and disk 
blocks\freeswap

Unix Swap Space

Metric Pattern (A-Z) CI Type Name Indicator

/.*/cpu/usage.average/ Computer CPU Load

/.*/cpu/usagemhz.average/ Computer CPU Load

Metric Pattern (A-Z) CI Type Name Indicator

/.*/mem/active.average/ Computer Memory Load

/.*/mem/swapinRate.average/ Computer Swap Usage Level

/.*/mem/swapoutRate.average/ Computer Swap Usage Level

/.*/mem/usage.average/ Computer Memory Load

Metric Pattern (A-Z) CI Type Name Indicator

/.*/net/droppedRx.summation/ Computer Interface Discard Rate

/.*/net/droppedTx.summation/ Computer Interface Discard Rate

/.*/net/received.average/ Computer Interface Utilization

/.*/net/ReceivedPacketsDropped/ Computer Interface Discard Rate

/.*/net/transmitted.average/ Computer Interface Utilization
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VMware Host State Monitor

VMware Host Storage Monitor

WebSphere Application Server Monitor

/.*/net/TransmittedPackets
Dropped/

Computer Interface Discard Rate

/.*/net/usage.average/ Computer Interface Utilization

Metric Pattern (A-Z) CI Type Name Indicator

/.*/connectionState/ Computer Node Status (Node)

/.*/inMaintenanceMode/ Computer Node Status (Node)

/.*/powerState/ Computer Node Status (Node)

/.*/standbyMode/ Computer Node Status (Node)

Metric Pattern (A-Z) CI Type Name Indicator

/.*/disk/numberWrite.summation/ Computer Node Status (Node)

/.*/disk/usage.average/ Computer Host Disk Utilization

Metric Pattern (A-Z) CI Type Name Indicator

/.*ConnectionsInUse/ J2EE Server Connections In Use

/.*connectionPoolModule/
WaitingThreadCount/

J2EE Server JDBC Connection Pool 
Wait Count

/.*jvmRuntimeModule/Used
Memory/

J2EE Server JVM Memory 
Utilization

/.*threadPoolModule/Active
Count/

J2EE Server Thread Pool 
Utilization

/.*transactionModule/
CommittedCount/

J2EE Server Transaction Commit 
Rate

Metric Pattern (A-Z) CI Type Name Indicator
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/.*transactionModule/
GlobalTimeoutCount/

J2EE Server Transaction Timeout 
Rate

/.*transactionModule/
GlobalTranTime/

J2EE Server Transaction Time

/.*transactionModule/
RolledbackCount/

J2EE Server Transaction Rollback 
Rate

was:/server/beanModule/
ServerSessionPoolUsage

J2EE Server EJB Utilization

was:/server/connectionPool
Module/ConnectionPool 
Utilization

J2EE Server DataSource 
Connection Pool 
Utilization

was:/server/jvmRuntimeModule/
FreeMemory

J2EE Server EJB Timeout Rate

was:/server/jvmRuntimeModule/
HeapSize

J2EE Server Heap Size Current

was:/server/jvmRuntimeModule/
ProcessCpuUsage

J2EE Server All Processors Average 
Load

was:/server/systemModule/CPU
UsageSinceServerStarted 

Computer CPU Load

was:/server/systemModule/
FreeMemory

Computer Memory Load

was:/server/threadPoolModule/
DeclaredThreadHungCount

J2EE Server Thread Hung Rate

was:/server/threadPoolModule/
PoolSize

J2EE Server Thread Pool 
Availability

was:/server/webAppModule/
LoadedServletCount

J2EE Server Servlets Loaded

was:/server/webAppModule/
RequestCount

J2EE Server Servlet Requests

was:/server/webAppModule/
URIServiceTime 

J2EE Server Http Request Average 
Service Time

Metric Pattern (A-Z) CI Type Name Indicator
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Indicator Assignments User Interface

This section includes:

 ➤ Metrics and Indicators Tab on page 186

 ➤ Select Monitor Dialog Box on page 189

 ➤ Create New Monitor Dialog Box on page 191

 ➤ New/Edit Assignment Dialog Box on page 192

 ➤ Import Monitor Indicator Assignments Wizard on page 197

 ➤ Export Monitor Indicator Assignments Dialog Box on page 201

Metrics and Indicators Tab

This tab enables you to manage metrics that are mapped from different 
SiteScope monitors to indicators on the CI, per monitor type, and to 
configure mappings for new monitors that have been created.

To access Select Admin > System Availability Management > 
Metrics and Indicators tab

Important 
information

➤ Only advanced users with a thorough knowledge of 
CIs and indicators should attempt to edit any of the 
mappings or to add mappings to metrics.

➤ When connecting SiteScope with BSM 9.x, the 
HPOprInf, HPOprMss, HPOprOra, and HPOprJEE 
content packs are required (they are installed by 
default, so you generally do not need to do anything). 
If you do not have these content packs, you need to 
import them as described in "How to Create and 
Manage Content Packs" in Platform Administration.
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Relevant tasks ➤ "How to Create and Manage Indicator Assignments" 
on page 170

➤ "How to Configure Topology Reporting" on page 85

➤ "How to Enable SiteScope to Send Events to HPOM or 
BSM" on page 115

See also ➤ "Managing Indicator Assignments in System 
Availability Management" on page 63

➤ "Assigning SiteScope Metrics to Indicators" on page 63

➤ "Indicator Repository" in Service Health

UI Element Description

Reset Indicator Assignments. Resets the indicator 
assignments to the default setting for the monitor.

Import Monitor Indicator Assignments. Imports monitor 
indicator assignments from an XML file. For details, see 
"Import Monitor Indicator Assignments Wizard" on 
page 197.

Export Monitor Indicator Assignments. Exports monitor 
indicator assignments to an XML file. For details, see 
"Export Monitor Indicator Assignments Dialog Box" on 
page 201.

<Name of monitor> The selected monitor type.

Select Monitor Opens the Select Monitor dialog box, which enables you 
to select or create a new monitor. For user interface 
details, see "Select Monitor Dialog Box" on page 189.
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Publish Changes Publishes new indicator assignments and changes to 
existing assignments to SiteScopes connected to BSM. 
The changes to existing assignments override the 
indicator states for existing monitor instances in 
SiteScope.

Note: Assignment states are not overridden by the 
updated centralized assignments if they were modified 
on a local SiteScope server.

Apply Ordering Saves changes made to the indicator mapping sort order.

Indicator Assignments table
(After selecting a monitor, existing indicator mappings for the selected monitor 
type are displayed in the Indicator Assignments table.)

New Assignment. Opens the New Assignments dialog 
box, which enables you to create an indicator assignment 
mapping for the selected monitor type. For user interface 
details, see "New/Edit Assignment Dialog Box" on 
page 192.

Edit Assignment. Enables editing the properties of the 
selected indicator assignment mapping. For user interface 
details, see "New/Edit Assignment Dialog Box" on 
page 192.

Delete Assignment. Deletes the selected indicator 
assignment mapping from the list.

Select All. Selects all the listed indicator assignments.

Clear Selection. Clears the selection.

Refresh. Refreshes the indicator assignment list.

Move Down. Enables you to sort the indicator 
assignment order by moving the selected indicator 
assignment down the list. 

UI Element Description
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Select Monitor Dialog Box 

This dialog box enables you to select a SiteScope monitor from the list of 
existing monitors, or to create a new monitor.

Move Up. Enables you to sort the indicator assignment 
order by moving the selected indicator assignment up 
the list.

Metric Pattern The regular expression pattern for the monitor metric. 
Double-click a mapping to view or edit details of the 
indicator mapping. For details, see "New/Edit Assignment 
Dialog Box" on page 192.

If there is more than one CI type for the same regular 
expression, they are displayed in different rows.

CI Type Name The CI type name for the selected indicator.

Indicator The name of the indicator that is mapped to the metric. 

Click here to create a 
new Indicator 
mapping

Opens the New Assignment dialog box, which enables 
you to configure new indicator assignments. For user 
interface details, see "New/Edit Assignment Dialog Box" 
on page 192.

Click on this link to 
create new Indicators

Opens the Indicator Repository page, which enables you 
to configure new indicators. For user interface details, see 
"Indicator Repository page" in Service Health. 

To access Select Admin > System Availability Management > 
Metrics and Indicators tab, and click the Select Monitor 
button.

Important 
information

Only advanced users with a thorough knowledge of CIs 
and indicators should attempt to edit any of the 
assignment mappings or to add mappings to metrics.

UI Element Description
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User interface elements are described below:

Relevant tasks "How to Create and Manage Indicator Assignments" on 
page 170

See also ➤ "How to Configure Topology Reporting" on page 85

➤ "How to Enable SiteScope to Send Events to HPOM or 
BSM" on page 115

UI Element Description

New Monitor. Opens the Create New Monitor dialog box, 
which enables you to create a new monitor. For user 
interface details, see "Create New Monitor Dialog Box" on 
page 191.

Refresh. Refreshes the monitor type list.

Monitor Name Displays the list of available monitors. 

Select a monitor to deploy from the list of available 
monitors by clicking the monitor link. 

Monitor Category Displays the category for each monitor type.

To select a monitor by category, click the arrow to the 
right of the Monitor Category heading, and select a 
category from the list detailed below.

➤ Application

➤ Database

➤ Generic

➤ Integration

➤ Network

➤ Server

➤ Stream

➤ Virtualization 

➤ Web Transaction
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Create New Monitor Dialog Box 

This dialog box enables you to create new SiteScope monitor types, which 
are added to the list of monitor types.

User interface elements are described below:

To access Select Admin > System Availability Management > 
Metrics and Indicators tab, click the Select Monitor 
button, and then click the New Monitor button.

Important 
information

Only advanced users with a thorough knowledge of CIs 
and indicators should attempt to edit any of the 
assignment mappings or to add mappings to metrics.

Relevant tasks "How to Create and Manage Indicator Assignments" on 
page 170

See also ➤ "How to Configure Topology Reporting" on page 85

➤ "How to Enable SiteScope to Send Events to HPOM or 
BSM" on page 115

UI Element Description

Monitor display 
name

The name of the monitor that you want to create. 
Example: JMX (for a JMX monitor)

Monitor topaz name The topaz name for the SiteScope monitor.

Example: JMX Monitor

Monitor class name SiteScope’s full class name for the monitor.

Example: 
com.mercury.sitescope.monitors.facades.JMXMonitor

Monitor category Select a category for the new monitor from the following:

➤ Application

➤ Database

➤ Generic

➤ Integration

➤ Network

➤ Server

➤ Stream

➤ Virtualization 

➤ Web Transaction



Chapter 5 • Indicator Assignment Settings

192

New/Edit Assignment Dialog Box 

This dialog box enables you to create or modify a metric-to-indicator 
assignment mapping for the selected monitor type. 

To access Select Admin > System Availability Management > 
Metrics and Indicators tab, click the Select Monitor 
button, and select a monitor. In the Indicator 
Assignment Settings Panel, click the New Assignment 
button to create a new mapping, or select an existing 
mapping and click the Edit Assignment button.

Important 
information

➤ Only advanced users with a thorough knowledge of 
CIs and indicators should attempt to edit any of the 
assignment mappings or to add mappings to metrics.

➤ After configuring a mapping, click the Save button to 
validate the mapping. An error message is displayed if 
the metric pattern is not valid.

➤ The CI Type Tree displays a hierarchy of the CI types 
in your system. The tree includes the following tabs:

➤ Browse Views. Enables you to browse through the 
view to locate a particular CI. 

➤ Search CIs. Enables you to search for one or more 
CIs in the tree or by CI type. 

➤ The CI Type <CI name> section on the right includes 
the following panes:

➤ Indicators. Displays the indicators assigned to the 
selected CI type.

➤ Details. Displays details regarding the indicator 
selected in the Indicators pane. This includes the 
name, type, and description for all indicators. 
Application and units are relevant for HIs only. The 
Values table displays the states that the indicator 
can have, the severity that corresponds to each 
state, and the icon that corresponds to each 
severity.
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User interface elements are described below:

Browse Views Tab
User interface elements are described below:

Relevant tasks "How to Create and Manage Indicator Assignments" on 
page 170

See also ➤ "How to Configure Topology Reporting" on page 85

➤ "How to Enable SiteScope to Send Events to HPOM or 
BSM" on page 115

➤ "Indicator Repository" in Service Health

UI Element Description

Metric Pattern Enter a regular expression pattern for the metric to map 
to the indicators. The pattern should be based on the 
metric name.

You can edit the regular expression pattern for an 
existing assignment mapping. 

Default assignment Uses the default assignment mapping for the monitor 
(Legacy System). If selected, you do not need to enter a 
regular expression (Metric pattern is disabled).

Default value: Not selected

UI Element Description

<CI types> A hierarchy of the CI types in your system. Select a CI to 
view its assigned indicators. 
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Search CIs Tab
User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

Change Visible Columns. Opens the Choose Columns to 
Display dialog box, which enables you to select the 
columns to display in the CIs list. Name and Type are 
selected by default.

Name To search for a CI by the name, enter the name of the CI 
for which to search. 

Type To search for a CI by CI type, enter the type in the box, or 
click the Search button to select a CI from the list of CIs. 
Click the column header to display the CI list in 
ascending or descending order.

Search Performs the search.

<Search results> After you run the search, the results are listed in the 
lower part of the Search CIs tab. The results are shown in 
two columns:

➤ Name. Contains the name of the CI.

➤ Type. Contains the CI type of the CI.

If the CI name is abbreviated, hold the pointer over the 
entry to see the full name. You can sort the search results 
by clicking the appropriate heading.

ID The CI’s internal unique identifier. 
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Indicators Pane
User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Details Pane - General Area
User interface elements are described below:

UI Element Description

<Indicator> An indicator assigned to the selected CI type (this label is 
defined by the indicator's Display Name field).

Select an indicator to map to the metric.

UI Element Description

Name The internal name of the indicator, as defined in the 
event generating the indicator (for example CPULoad).

Type The indicator type (automatically defined as health 
indicator with associated ETI). 

Description Optional text describing the indicator.

Application Specifies which application displays this indicator: 
Service Health, Service Level Management, or both.

Units The type of unit applicable to the rule results displayed in 
the HI only. Typical units are: 

➤ <No unit>. For rules that handle volume, where 
metrics represent a simple numerical count.

➤ Financial ($). For rules that determine financial loss for 
a CI.

➤ Milliseconds or Seconds. For rules that handle 
performance time data for a transaction or monitor.

➤ Percentage (%). For rules that handle availability over 
time data.
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Details Pane - States Area
User interface elements are described below:

UI Element Description

Display Name The state of the indicator (for example, Very high CPU). 
For details, see "Indicator Repository" in Service Health.

Status The severity corresponding to the indicator state (for 
example, Warning). 

Icon The icon corresponding to the indicator severity. 
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Import Monitor Indicator Assignments Wizard 

This wizard enables you to import SiteScope monitor indicator assignment 
mappings from an XML file to SAM Administration. 

Select File to Import Page
This wizard page enables you to select the XML file to import.

To access Select Admin > System Availability Management > 
Metrics and Indicators tab, and click the Import Monitor 
Indicator Assignments  button. 

Relevant tasks "How to Create and Manage Indicator Assignments" on 
page 170

Wizard map This wizard contains:

Select File to Import Page > Select Monitors Page > Select 
Type Page

See also "Indicator Assignments Overview" on page 168

Important 
information

General information about this wizard is available here: 
"Import Monitor Indicator Assignments Wizard" on 
page 197.

Wizard map The Import Monitor Indicator Assignments Wizard 
contains:

Select File to Import Page > Select Monitors Page > 
Select Type Page

See also "Indicator Assignments Overview" on page 168
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Select Monitors Page
This wizard page enables you to select the monitors that you want to import 
from the selected XML file.

UI Element Description

Browse. Enables you to navigate to the folder that 
contains the XML file you want to import. Click the 
Open button and select the XML file you want to import.

Note: Only files in XML format can be imported.

<File name> The path and name of the selected XML file.

Important 
information

General information about this wizard is available here: 
"Import Monitor Indicator Assignments Wizard" on 
page 197.

Wizard map The Import Monitor Indicator Assignments Wizard 
contains:

Select File to Import Page > Select Monitors Page > Select 
Type Page

See also "Indicator Assignments Overview" on page 168
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User interface elements are described below:

UI Element Description

All Monitors Select monitors to deploy from the list of available 
monitors or by category. You can search for monitors by 
typing a search string in the Monitor Name box. To select 
by category, click the arrow to the right of the Category 
heading, and select a monitor category from the list 
detailed below. Monitors that have assignment mappings 
that have changed are displayed in red with an a asterisk.

Select the monitors you want to import, and click the 
Move to Selected Monitors button. The selected 
monitors are moved to the Selected Monitors table. To 
import all available monitors, click the Move all to 
Selected Monitors button.

You can change the alphabetical order (ascending or 
descending) of the listed monitors or categories, by 
clicking the arrow in the header of the Monitor Name or 
Monitor Category column. 

Selected Monitors Displays the monitors to be imported from the selected 
XML file.

To remove monitors selected for importing, select the 
monitors you do not want to import, and click the Move 
to All Monitors button. The monitors are moved to the 
All Monitors table. To remove all selected monitors, click 
the Move all to All Monitors button.



Chapter 5 • Indicator Assignment Settings

200

Select Type Page
This wizard page enables selecting the import type; monitor objects in the 
target system that match the selected monitor can be overwritten.

User interface elements are described below:

Important 
information

General information about this wizard is available here: 
"Import Monitor Indicator Assignments Wizard" on 
page 197.

Wizard map The Import Monitor Indicator Assignments Wizard 
contains:

Select File to Import Page > Select Monitors Page > Select 
Type Page 

See also "Indicator Assignments Overview" on page 168

UI Element Description

Overwrite Enables monitor assignment mappings from the 
imported XML file to overwrite existing monitor matches 
in the target system. Monitors that have assignment 
mappings that have changed are listed in this screen. 
Any new objects are also created. 

Default value: Not selected
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Export Monitor Indicator Assignments Dialog Box 

This dialog box enables you to export SiteScope monitor mappings to an 
XML file.

User interface elements are described below:

To access Select Admin > System Availability Management > 
Metrics and Indicators tab, and click the Export Monitor 
Indicator Assignments  button. 

Relevant tasks "How to Create and Manage Indicator Assignments" on 
page 170

See also "Indicator Assignments Overview" on page 168

UI Element Description

Select the location to which the monitor indicator 
assignment file is saved for export. By default, files are 
saved in XML format. 
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All Monitors Select monitors to export from the list of available 
monitors or by category. You can search for monitors by 
typing a search string in the Monitor Name box. To select 
by category, click the arrow to the right of the Category 
heading, and select a monitor category from the list 
detailed below. 

You can change the alphabetical order (ascending or 
descending) of the listed monitors or categories, by 
clicking the arrow in the header of the Monitor Name or 
Monitor Category column. 

Select the monitors you want to export, and click the 
Move to Selected Monitors button. The selected 
monitors are moved to the Selected Monitors table. To 
export all available monitors, click the Move all to 
Selected Monitors button.

Selected Monitors Displays the monitors selected for export.

To remove monitors selected for export, select the 
monitors you do not want to export, and click the Move 
to All Monitors button. The monitors are moved to the 
All Monitors table. To remove all selected monitors, click 
the Move all to All Monitors button.

UI Element Description
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6
Monitor Deployment Wizard

This chapter includes:

Concepts

➤ Monitor Deployment Wizard Overview on page 204

➤ Monitor Deployment Wizard Templates and Variables on page 206

➤ Full and Partial Monitor Coverage on page 209

➤ Wizard Options on page 210

➤ Monitor Deployment Wizard for Siebel on page 211

Tasks

➤ How to Deploy Monitors Using the Monitor Deployment Wizard 
on page 212

Reference

➤ Template Reference on page 219

➤ Monitor Deployment Wizard on page 228
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Concepts

Monitor Deployment Wizard Overview

Note: The Monitor Deployment Wizard is available only to those users 
accessing SiteScope from SAM Administration in BSM.

The Monitor Deployment Wizard provides a monitoring solution for 
existing BSM configuration item (CI) data using SiteScope templates. The 
wizard uses SiteScope templates to deploy monitors, groups, and remote 
servers with the existing and discovered CI data from the Run-time Service 
Model (RTSM). For details on understanding CIs, see "Configuration Items 
(CI)" in the RTSM Administration Guide.

SiteScope templates enable you to deploy group and monitor configurations 
across multiple infrastructure elements with a minimal number of 
configuration steps. For details, see "SiteScope Templates" in Using SiteScope 
in the SiteScope Help. 

The Monitor Deployment Wizard uses SiteScope’s template functionality to 
create a monitoring solution for the CIs in your RTSM. When you select CIs 
to monitor using the Monitor Deployment Wizard, the wizard automatically 
matches templates to the selected CIs based on the CI type selected. You can 
also select additional templates to apply to the selected CIs for your specific 
monitoring requirements. For details on which templates are deployed onto 
which CI types, see "Template Reference" on page 219.

The RTSM may already include CI data that can be used for monitor 
deployment. These properties may have been entered while adding the CI to 
Modeling Studio or may have been discovered by the Discovery Manager. 
For details, see "How to Create CIs and Relationships in the RTSM" in the 
Modeling Guide. The wizard is also able to retrieve the data from the RTSM 
for the selected CIs and use that data when deploying the SiteScope 
templates.
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BSM enables you to use that data to create SiteScope monitors, groups, and 
remote servers for existing CIs in the RTSM.

The Monitor Deployment Wizard: 

➤ Enables you to select CIs onto which to deploy the SiteScope templates 
and recognizes which templates to deploy onto which CIs.

➤ Enables you to refine the selection of templates to deploy onto CIs.

➤ Checks the CI for existing monitors and measurements that match the 
monitoring solution to be deployed by the template and enables you to 
handle duplicate monitoring.

➤ Imports the configuration item’s properties that have been defined in 
RTSM Administration into the monitor’s properties and creates remote 
servers on SiteScope.

➤ Uses template variables to enable you to enter data for monitor properties 
that are not imported from the configuration item’s definition.

➤ Creates in the RTSM a monitored by relationship between the monitored 
CI and the created monitor.

Note: The Monitor Deployment Wizard only supports topology reporting 
for monitors that have a default topology defined. This means you can 
select to add a template to a CI only if the CI type is the default CI type for 
all the monitors in the template.
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Example of Monitor Deployment
For example, an Oracle database has been added as a CI to Modeling Studio 
in the RTSM. You can use the Monitor Deployment Wizard to deploy the 
Oracle Database monitor onto the CI. The wizard imports the following 
properties that are defined for the server in the RTSM:

➤ database server IP address or server name

➤ database user name

➤ database password

➤ database port

➤ database SID

If the RTSM cannot provide values for some of the variables that are 
necessary for the deployment of the monitors, you must add these values 
manually. This can occur if the CI was not entered during the Data Flow 
Management process or if only a partial discovery was run.

Monitor Deployment Wizard Templates and Variables

The Monitor Deployment templates appear by default in the template tree 
in a container called Monitor Deployment Wizard Templates when 
SiteScope is connected to BSM. This container and the templates and 
variables within it should not be edited or deleted.
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Only advanced users with a thorough knowledge of working with templates 
should attempt to edit any of the variables or to add variables to the 
templates. For details, see "SiteScope Templates" in Using SiteScope in the 
SiteScope Help.

This section also includes:

➤ "Monitor Template Variables" on page 207

➤ "Selecting Templates" on page 207

➤ "Manual Template Matches" on page 208

Monitor Template Variables
The templates associated with the selected CIs have variables which must be 
filled in before the wizard can deploy them. The system fills in most of the 
variables automatically by checking the CI information or the results of the 
Data Flow Management process. Other variables are not filled in by the 
system because the data was missing from the CI information, the DDM 
process did not run completely, or because the data is dependent on the 
user. You must fill in the missing information for any selected monitor 
templates. You also have the option of not deploying the template by 
clearing the template selection if you do not know the variable values.

Selecting Templates
Once a CI is selected, all the relevant templates are matched to the CI.

In the step for entering variable values, a check box appears next to each 
monitor template associated with that CI. By default, if there is any missing 
data for the variables in a template, that template is not selected for 
deployment. This enables the wizard to streamline the deployment process. 

You can select or clear templates for deployment. If you select a template for 
deployment but fail to enter the missing data for its variables, an error 
message appears and the wizard cannot proceed until you enter the data. If 
you leave any templates unselected, a warning message appears to alert you 
that there are unselected templates but you can choose to proceed with the 
wizard anyway. This applies to all unselected templates, whether data was 
entered for them or not.
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Manual Template Matches
The wizard enables you to select other templates for deployment that were 
not automatically mapped by the wizard. For example, you may want to use 
an existing template that includes log file monitoring that is set to search for 
a specific string that would be relevant for host CIs in your environment. 
You can choose to deploy that template onto the host CIs you selected in 
the Select CIs to Monitor page. 

You may also want to select a CI type that does not have a template 
associated with it and deploy an existing template onto that CI. 

If you have matched additional monitor templates to be deployed onto CI 
types that are not in those predefined in the wizard, you can save these 
matches for future use when the same BSM user runs the wizard. 

Also, if you removed templates that were matched by the wizard for specific 
CIs and chose to save matching, those templates are not matched to the 
selected CIs the next time the same BSM user runs the wizard.

For details, see "Save matching" on page 232.
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Full and Partial Monitor Coverage

For each selected CI, the Monitor Deployment Wizard checks whether the 
CI already has a monitored by relationship with any monitor CIs that are 
equivalent to the monitor instances that would result from the wizard 
deploying the templates mapped for that CI. It further checks the actual 
measurements within the monitor CIs and determines if the monitoring 
solution deployed by the wizard duplicates the monitors that exist for the 
selected CI. 

If the CI onto which you want to deploy the monitoring solution already 
contains all of the same monitor and measurement instances, the CI is 
considered fully covered. If the CI has only part of the monitors and 
measurements already deployed, the CI is considered partially covered.

You can choose to clear fully or partially covered CIs and disable them for 
the deployment. Or, you have the option of continuing with the 
deployment and handling the duplicate monitors in the final step of the 
wizard. If, in the final step of the wizard, duplicate monitors on CIs were 
detected and the wizard successfully deployed templates onto these CIs, a 
Handle Duplicates button is displayed and enables you to delete these 
monitors, disable them or leave them in tact as duplicated monitors.
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Wizard Options

This section includes the following Monitor Deployment Wizard topics:

➤ "CI Group Hierarchy Option" on page 210

➤ "SiteScope Remote Servers" on page 210

➤ "Reporting" on page 211

CI Group Hierarchy Option
When you deploy templates using the Monitor Deployment Wizard, you 
can choose to create a CI group hierarchy which mirrors the CI hierarchy in 
the selected view in BSM. This means that SiteScope groups are created to 
correspond to the parent and grandparent CIs of the CI being monitored. 
These groups are arranged in a tree structure identical to the one that 
contains the actual CIs in the selected view in BSM.

SiteScope Remote Servers
The SiteScope templates used in the Monitor Deployment Wizard are 
configured with template remotes which create remote server preferences in 
SiteScope for use by other SiteScope monitors. The remote servers created 
can be found in SiteScope under Remote Servers > Microsoft Windows 
Remote Servers (for Windows monitors) and Remote Servers > UNIX 
Remote Servers (for UNIX monitors). For details on remote servers, see 
"Working with Remote Servers" in Using SiteScope in the SiteScope Help.

When the wizard deploys a template with remote server definitions for a 
physical monitor (for example, a CPU monitor), a remote preference is 
created with the name of the host (the host DNS name) plus the user name. 
When deploying a template with a remote server that already exists in 
SiteScope’s remote servers, SiteScope uses the existing remote and does not 
create another remote preference. For details on creating remote servers 
with templates, see "SiteScope Templates" in Using SiteScope in the SiteScope 
Help.
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Reporting
The final step of the Monitor Deployment Wizard consists of the 
Deployment Results page which displays information about the successful 
and unsuccessful monitor deployments. The report contains the names of 
the selected CIs and the monitors selected for deployment. The deployment 
status is indicated for each monitor. 

The report can be exported to a PDF file. These reports include detailed 
information displaying all the created groups, monitors, and alerts, 
including the exact location where they can be found in SiteScope. These 
reports are useful for large deployments. For example, when hundred of CIs 
are selected in the wizard, the resulting deployment can include thousands 
of new objects added to the SiteScope. For details, see "Deployment Results 
Page" on page 236.

Note: After running the Monitor Deployment Wizard, the deployed 
monitors are not run immediately, but rather within the defined frequency 
scheduled for the monitor. 

Monitor Deployment Wizard for Siebel

You can use the Monitor Deployment Wizard to monitor your Siebel 
environment. The view to use for the wizard is the Siebel Enterprise view. 
The wizard can identify the Siebel configuration items in the RTSM and 
deploy a set of pre-configured monitors onto those items. The monitors 
include those that are specifically designed to monitor Siebel, as well as 
generic monitors that can monitor the performance of your Siebel network.

For details on the available templates used for the Siebel environment, see 
"Siebel Solution Templates" in Using SiteScope in the SiteScope Help.

For reference information on the Siebel monitor template and configuration 
items, see "Template Reference for Siebel" on page 223.
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Tasks

How to Deploy Monitors Using the Monitor Deployment 
Wizard

This task describes the steps involved in deploying monitors using the 
Monitor Deployment wizard.

This task includes the following steps:

➤ "Prerequisites" on page 212

➤ "Run Data Flow Management" on page 213

➤ "Run the Wizard" on page 213

➤ "Enter missing data for selected CIs" on page 215

➤ "Check the configuration summary and deploy monitors" on page 216

➤ "Review the deployment results and export the report" on page 217

 1 Prerequisites

➤ To run the Monitor Deployment Wizard, you must be assigned one of 
the following roles: SuperUser or Administrator (in BSM), Customer 
Administrator (in HP SaaS).

➤ Before running the Monitor Deployment Wizard, you should update 
the template with the relevant counters. This is because SiteScope is 
unable to provide a common template for all UNIX machines, as UNIX 
machines do not have a common file system configuration or 
common counters. For example, a counter might be named avail on 
one machine, and available on another.
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 2 Run Data Flow Management

You must run the relevant discovery jobs to discover CIs and populate 
views before deploying monitors with the Monitor Deployment Wizard. 
For details, refer to the RTSM Data Flow Management Guide.

After you have discovered the relevant CIs in your business environment, 
you can select one of the pre-defined views populated by the DDM jobs. 
Alternatively, you can create a view manually for the purpose of running 
the Monitor Deployment Wizard. For task details, see "How to Create a 
Node Credentials View" on page 217.

Tip: We recommend creating a Node Credentials view which contains 
hosts with credentials, so that the necessary credentials exist to access the 
servers. This can help to streamline the process of selecting the relevant 
hosts to be monitored in the Select CIs to Monitor step of the wizard. 

Note: Do not create a view in which the same CI appears more than once. 
If you select a view in which the same CI appears more than once, the 
selection of the whole view in the wizard fails.

 3 Run the Wizard

Begin running the wizard. For user interface details, see "Monitor 
Deployment Wizard" on page 228. 

The first step is to select CIs to monitor using the Model Explorer. For user 
interface details, see "Select CIs to Monitor Page" on page 229.

After selecting CIs to monitor, you can select monitor templates to apply 
to them using the Templates Selection dialog box. For user interface 
details, see "Templates to CI Type Selection Dialog Box" on page 231.
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Example:
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 4 Enter missing data for selected CIs

On the Enter Required Data for Selected CIs page, select the monitor 
templates to deploy and enter any missing data for them. For user 
interface details, see "Enter Required Data for CIs Page" on page 232.

Example:
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 5 Check the configuration summary and deploy monitors

On the Final Configuration Summary page, review the final configuration 
summary and select a SiteScope group on which to deploy the templates. 
Click Finish to complete the wizard and deploy the monitors. For user 
interface details, see "Final Configuration Summary Page" on page 234.

Example:
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 6 Review the deployment results and export the report

On the Deployment Results page, review the results of the deployment 
and, if necessary, retry deploying those template that failed to deploy. In 
this page, you can also handle duplicate monitors that were deployed. 
Optionally, you can export the deployment results to a .pdf file. For user 
interface details, see "Deployment Results Page" on page 236.

Example:

How to Create a Node Credentials View
This task describes the steps involved in creating a Node Credentials view.

Note: This task is part of a higher-level task. For details, see "How to Deploy 
Monitors Using the Monitor Deployment Wizard" on page 212.

To create a Node Credentials view:

 1 Select Admin > RTSM Administration > Modeling > Modeling Studio.

 2 Click New > Pattern View. The New Pattern View dialog box opens.

 3 Select Create New TQL and click OK. The Pattern View Editor opens.

 4 In the CI Types tab (left pane), expand the Managed Object > 
Configuration Item > Infrastructure Element branch of the tree. Click and 
drag the Node CI type onto the right pane.

 5 In the Infrastructure Element branch of the tree, expand Running 
Software > Agent. Click and drag the Shell CI type onto the right pane.
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 6 Holding down the CTRL key, select both the Node and Shell query nodes 
in the Editing pane. Right-click one of them, and select Add Relationship. 
The Add Relationship dialog box opens.

 7 Select Composition from the tree in the relationship window. Click OK.

 8 Right-click the Shell query node and select Query Node Properties. The 
Query Node Properties dialog box opens.

 9 Clear the Visible check box and click OK.

 10 Click the Save button in the toolbar to save the view. The Save Pattern 
View dialog box opens.

 11 Enter Node Credentials in the View name box and click OK.

For details on creating views, see "How to Create a Pattern View" in the 
Modeling Guide.

Note: In the Select CIs to Monitor step of the wizard, you can select CIs to 
monitor from many different views, but a specific CI may be selected only 
once, even if it appears in more than one view.
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Reference

Template Reference

The Monitor Deployment Wizard is enabled by a series of templates 
preconfigured in the SiteScope monitor tree. 

This section includes:

➤ "Template Reference Table" on page 219

➤ "Template Reference for Siebel" on page 223

Template Reference Table
Following is a table listing all the configuration items onto which the 
Monitor Deployment Wizard can deploy templates. The table lists the 
templates and CI types, the monitors which are deployed, the monitor 
properties imported from the RTSM, and the variable definitions that are 
either imported from the RTSM or defined within the wizard.

Template CI Type
Applicable 
Monitor

Discovered 
Properties

Variables

Apache server Apache Apache 
Server 
monitor

server name or 
IP address

application_IP

application port 
(default value is 
8080)

application_port
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Host Host Ping 
monitor

dns name host_dnsname

Windows

UNIX

Network

Switch

Router

switch-
router

Windows server Windows Microsoft 
Windows 
Resources 
monitor

dns name host_dnsname

host_password

host_username

nt_domain

UNIX UNIX CPU and 
Memory 
monitor, 
UNIX 
Remote 
server

connection_
method

dns name host_dnsname

host_os

host_password

host_username

Microsoft IIS 
server

IIS Microsoft 
IIS Server 
monitor

server name or 
IP address

application_IP

host password host_password

user name host_username

NT domain nt_domain

Template CI Type
Applicable 
Monitor

Discovered 
Properties

Variables
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Microsoft SQL 
server

sqlserver Microsoft 
SQL 
Server 
monitor

server name or 
IP address

application_IP

nt_domain

SqlServerHost
Password

SqlServerHost
UserName

Oracle database Oracle Oracle 
Database 
monitor

server name or 
IP address

application_IP

application 
password 
(default value is 
manager)

application_
password

application user 
name (default 
value is system)

application_user
name

database port 
(default value is 
1521)

database_dbport

database SID database_dbsid

UDDI UDDI 
Registry

UDDI 
Server

data_name data_name

business_name business_name

Template CI Type
Applicable 
Monitor

Discovered 
Properties

Variables
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Web Services Web 
Service

WSDL method_name method_name

method_ns

ParamUrl ParamUrl

port

purl purl

service_name

soap_action soap_action

WsdlUrl WsdlUrl

Template CI Type
Applicable 
Monitor

Discovered 
Properties

Variables
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Template Reference for Siebel
Following are tables listing all the Siebel configuration items onto which the 
Monitor Deployment Wizard can deploy monitors. The Siebel templates are 
divided according to groups. The table lists the CI Templates and CI types, 
the monitors which are deployed, the monitor properties imported from the 
RTSM, and the variable definitions that are either imported from the RTSM 
or defined within the wizard.

Siebel Application Server Monitor
 

Template CI Type
Applicable 
Monitor

Discovered 
Properties

Variables

Siebel 
Application 
Server

Application 
Server

Siebel 
Application 
Server log

Server_Name Server_Name

Siebel_Root_Dir Siebel_Root_Dir

Siebel_Logical_
Instance_Name

Siebel_Logical_
Instance_Name

Siebel 
Application 
Server

Application Application

Gateway Gateway

Enterprise Enterprise

Username Username

Server_Manager
_Path

Server_Manager_
Path

PASSWORD PASSWORD

Database Siebel 
Enterprise 
Integration 
Manager 
process 
(growth 
rate)

Database_
Connection_
URL

Database_
Connection_
URL

Database_Driver Database_Driver

Database_
UserName

Database_
UserName

Database_Server
_Name

Database_Server_
Name

PASSWORD PASSWORD
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Siebel 
Application 
Server cont’d

Database 
cont’d

Siebel 
Transaction 
Logging 
process (is 
enabled)

Database_
UserName

Database_
UserName

Database_Driver Database_Driver

Database_
Connection_
URL

Database_
Connection_
URL

Database_Server
_Name

Database_Server_
Name

Database_PASS
WORD

Database_
PASSWORD

Siebel 
Transaction 
Router 
process 
(growth 
rate)

Database_UserN
ame

Database_
UserName

Database_Driver Database_Driver

Database_Conn
ection_URL

Database_
Connection_URL

Database_Server
_Name

Database_Server_
Name

Database_PASS
WORD

Database_
PASSWORD

Siebel 
Workflow 
Rules 
process 
(growth 
rate)

Database_UserN
ame

Database_
UserName

Database_Driver Database_Driver

Database_Conn
ection_URL

Database_
Connection_URL

Database_Server
_Name

Database_Server_
Name

Database_PASS
WORD

Database_
PASSWORD

Template CI Type
Applicable 
Monitor

Discovered 
Properties

Variables
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Siebel 
Application 
Server Host

Host Disk Space Server_Name Server_Name

Ping Server_Name Server_Name

Memory Server_Name Server_Name

CPU Server_Name Server_Name

Directory 
log

Server_Name Server_Name

Siebel_Root_Dir Siebel_Root_Dir

Service 
Siebel 
Server

Server_Name Server_Name

Enterprise Enterprise

Server_Logical_
Instance_Name

Server_Logical_
Instance_Name

Directory Server_Name Server_Name

Siebel_Root_Dir Siebel_Root_Dir

Siebel 
Component

Siebel 
Component

Siebel 
Component 
log

alias alias

Server_Name Server_Name

Application Application

Siebel_Root_
Dir

Siebel_Root_
Dir

Siebel_Logical_
Instance_Name

Siebel_Logical_
Instance_Name

Siebel 
Component

alias alias

Username Username

Enterprise Enterprise

Application Application

Gateway Gateway

Server_Manager
_Path

Server_Manager_
Path

Server_Logical_
Instance_Name

Server_Logical_
Instance_Name

PASSWORD PASSWORD

Group_Name Group_Name

data_name data_name

Template CI Type
Applicable 
Monitor

Discovered 
Properties

Variables
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Siebel Gateway Monitors

Siebel 
Component 
Group

Siebel 
Component 
Group

Siebel 
Component 
Group on

alias alias

Server_Logical_
Instance_Name

Server_Logical_
Instance_Name

Enterprise Enterprise

Application Application

Gateway Gateway

data_name data_name

Server_Manager
_Path

Server_Manager_
Path

Server_Name Server_Name

PASSWORD PASSWORD

Template CI Type
Applicable 
Monitor

Discovered 
Properties

Variables

Siebel 
Gateway 
Server Host

Host CPU Server_Name Server_Name

Directory Server_Name Server_Name

Siebel_Root_Dir Siebel_Root_Dir

Disk Space Server_Name Server_Name

Memory Server_Name Server_Name

Ping Server_Name Server_Name

Service Server_Name Server_Name

Template CI Type
Applicable 
Monitor

Discovered 
Properties

Variables
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Siebel Web Server Monitors

Template CI Type
Applicable 
Monitor

Discovered 
Properties

Variables

Siebel Web 
Server 
Extension

Siebel Web 
Server 
Extension

Service Server_Name Server_Name

Siebel Web 
Server

Server_Name Server_Name

Application Application

Username Username

PASSWORD PASSWORD

URL Server_Name Server_Name

Application Application

Username Username

PASSWORD PASSWORD

Siebel Web 
Server Host

Host CPU host_dnsname host_dnsname

Directory host_dnsname host_dnsname

Siebel_Root_Dir Siebel_Root_Dir

Disk Space host_dnsname host_dnsname

Memory host_dnsname host_dnsname

Ping host_dnsname host_dnsname

Service host_dnsname host_dnsname

Web Server Web Server Microsoft 
IIS Server

host_dnsname host_dnsname

Port 80 host_dnsname host_dnsname
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Monitor Deployment Wizard

Note: The Monitor Deployment Wizard is available only to those users 
accessing SiteScope from SAM Administration in BSM.

This wizard enables you to deploy SiteScope monitors using the 
configuration item data from the RTSM using pre-defined templates.

To access Select Admin > System Availability Management. Right-
click the required SiteScope server or group and select 
Monitor Deployment Wizard or click the Monitor 
Deployment Wizard icon in the Summary page next to 
the required SiteScope server.

Important 
information

➤ The wizard is accessible only if you have a running 
SiteScope hosted in SAM Administration.

➤ After running the Monitor Deployment Wizard, the 
deployed monitors do not begin to run immediately, 
but rather within the defined monitor running 
frequency time. You must give the system time to 
implement all the updates.

Relevant tasks "How to Deploy Monitors Using the Monitor 
Deployment Wizard" on page 212

See also "Monitor Deployment Wizard Overview" on page 204

Wizard map The Monitor Deployment Wizard contains:

Welcome Page > Select CIs to Monitor Page > (Templates 
to CI Type Selection Dialog Box) > Enter Required Data 
for CIs Page > Final Configuration Summary Page > 
Deployment Results Page
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Welcome Page
This wizard page describes the wizard.

Select CIs to Monitor Page
This wizard page enables you to select CIs onto which to deploy the 
SiteScope monitors.

Important 
information

➤ General information about this wizard is available 
here: "Monitor Deployment Wizard" on page 228.

➤ An error message appears when you attempt to 
proceed to the next page if:

➤ The SiteScope you selected is not available.

➤ The RTSM is not available.

Wizard map The Monitor Deployment Wizard contains:

Welcome Page > Select CIs to Monitor Page > (Templates 
to CI Type Selection Dialog Box) > Enter Required Data 
for CIs Page > Final Configuration Summary Page > 
Deployment Results Page

See also "Monitor Deployment Wizard Overview" on page 204

Important 
information

➤ General information about this wizard is available 
here: "Monitor Deployment Wizard" on page 228.

➤ If a CI appears under more than one view in the left 
pane, you cannot select it more than once in the 
selection that appears in the right pane, even if you 
attempt to select it from different views.

➤ The wizard checks for full and partial monitor 
coverage of the selected CIs. You have the option of 
deploying the template onto these CIs and handling 
duplicate monitors.
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Wizard map The Monitor Deployment Wizard contains:

Welcome Page > Select CIs to Monitor Page > (Templates 
to CI Type Selection Dialog Box) > Enter Required Data 
for CIs Page > Final Configuration Summary Page > 
Deployment Results Page

See also ➤ "Monitor Deployment Wizard Templates and 
Variables" on page 206

➤ "Full and Partial Monitor Coverage" on page 209

UI Element Description

<Model Explorer> The Select CIs to Monitor page uses the standard Model 
Explorer functionality to select CIs in the left pane and 
move them to the right pane. For details, see "CI Selector 
User Interface" in the Modeling Guide.

Note: The wizard cannot create monitors for the 
following CIs:

➤ CIs that do not have a matching template for 
deploying a monitor type

➤ CIs that are monitor CIs, generally those appearing in 
the monitor view

If you selected any CIs of these types, a warning message 
appears when you attempt to proceed to the next step of 
the wizard.
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Templates to CI Type Selection Dialog Box
This wizard page enables you to apply templates to CI Types which were not 
automatically matched by the wizard.

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Important 
information

➤ General information about this wizard is available 
here: "Monitor Deployment Wizard" on page 228.

➤ The Monitor Deployment Wizard automatically 
matches templates to the CI Types of the selected CIs. 
You can add additional templates manually in this 
dialog box. The selected templates are added to all of 
the selected CI Types.

➤ The Monitor Deployment Wizard supports topology 
reporting for monitors that have a default topology 
defined only. This means you can select to add a 
template to a CI only if the CI is the default CI for all 
the monitors in the template.

Wizard map The Monitor Deployment Wizard contains:

Welcome Page > Select CIs to Monitor Page > (Templates 
to CI Type Selection Dialog Box) > Enter Required Data 
for CIs Page > Final Configuration Summary Page > 
Deployment Results Page

See also "Monitor Deployment Wizard Templates and Variables" 
on page 206

UI Element Description

Adds the selected templates in the left pane to the CI 
selection in the right pane.

Removes selected templates from the CI selection.

<Template list> The left pane lists all the available templates in the 
wizard. The child objects are the monitors that are 
deployed by the template. 
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Enter Required Data for CIs Page
This wizard page enables you to fine tune your template selection for 
specific CIs and fill in the missing information for those templates.

<CI Type Selection> The right pane lists the CI Types of all the CIs selected in 
the Select CI to Monitor step of the Monitor 
Deployment Wizard. If the wizard was able to match 
templates to the selected CI Types, the CI Type is listed 
with the applicable template as a child object.

Save matching Saves your template selection as a preference. This 
includes those templates that are selected manual for CI 
types and those that are cleared from the automatic 
selection of the wizard. The manually adjusted 
templates selection is matched to the selected CIs 
automatically the next time the same BSM user runs the 
wizard.

Restore Defaults Resets the list and removes all the added templates from 
the CI Types (those added automatically by the wizard 
remain).

Important 
information

➤ General information about this wizard is available 
here: "Monitor Deployment Wizard" on page 228.

➤ If data is missing for any selected templates, an error 
appears and you are unable to proceed to the next 
step.

➤ If any templates are unselected, a warning appears 
before you proceed to the next step that informs you 
that there are unselected templates. This applies 
whether data is filled in for the unselected templates 
or not.

Wizard map The Monitor Deployment Wizard contains:

Welcome Page > Select CIs to Monitor Page > (Templates 
to CI Type Selection Dialog Box) > Enter Required Data 
for CIs Page > Final Configuration Summary Page > 
Deployment Results Page

UI Element Description
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

<Expanded CI list> The CIs that are missing required data are expanded. (If 
no CIs are missing data, this section does not appear.)

<Unexpanded CI list> CIs that are not missing data are not expanded. You can 
optionally expand the CIs to modify the data. (If all CIs 
are missing data, this section does not appear.)

CI column Each template for each CI is displayed separately with 
the relevant number of license points for that template. 
Select the check box for the CI and template 
combinations for which you want to deploy monitors.

Variable column The variables for templates with missing data are listed in 
the Variable column.

Value column The missing data in the Value column for all the selected 
templates. You can tab between the fields and enter the 
required data in the available fields. You do not need to 
enter missing data for templates that are not selected.
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Final Configuration Summary Page
This wizard page displays a list of the monitors about to be deployed and 
enables you to select the SiteScope group onto which they are deployed.

User interface elements are described below:

Important 
information

➤ General information about this wizard is available 
here: "Monitor Deployment Wizard" on page 228.

➤ Above the table, a note displays the total number of 
license points available on the SiteScope server (after 
the current action is complete). If the number of 
license points required for the current action exceeds 
your available points, a warning appears to tell you to 
remove some of the selected templates.

Wizard map The Monitor Deployment Wizard contains:

Welcome Page > Select CIs to Monitor Page > (Templates 
to CI Type Selection Dialog Box) > Enter Required Data 
for CIs Page > Final Configuration Summary Page > 
Deployment Results Page

UI Element Description

CI Name/Template 
Name column

Lists each selected CI with its templates.

Monitors to be 
Created column

Indicates the number of monitors being created for each 
template.

License Points 
column

Indicates the number of SiteScope license points required 
for each monitor.

SiteScope Group 
selection window

To select the SiteScope group under which the monitors 
are deployed, click Browse and select a group from the 
tree in the Choose Target SiteScope Group dialog box.

Note: If you attempt to deploy the same monitor on the 
same CI in the same group twice, the deployment fails 
with a unique name error. However, you may select a 
different group under which to deploy that monitor onto 
that CI.
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Create CI group 
hierarchy

Creates a CI group hierarchy. This creates SiteScope 
groups under the target group with the identical 
hierarchy of the CIs. For details, see "CI Group Hierarchy 
Option" on page 210.

Default value: Not selected 

Verify monitor 
properties with 
remote server

Verifies the correctness of the monitor configuration 
properties in the selected template with the remote 
servers on which the template is deployed. 

Note: 

➤ Selecting this option slows performance time due to 
the remote connection. 

➤ This option is available when working with SiteScope 
10.10 and later.

Default value: Not selected 

UI Element Description
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Deployment Results Page
This wizard page displays a summary of the successful and unsuccessful 
template deployments.

User interface elements are described below:

Important 
information

➤ General information about this wizard is available 
here: "Monitor Deployment Wizard" on page 228.

➤ The deployment of monitors occurs at the template 
level. This means that if the deployment fails for any 
of the template elements (monitor, group, remote, or 
alert), no other monitors in the template are 
deployed.

➤ When you deploy a physical monitor (for example, a 
CPU monitor), a remote server with the same name is 
also created if such a remote server does not already 
exist under Remote Servers (Microsoft Windows or 
UNIX). 

Wizard map The Monitor Deployment Wizard contains:

Welcome Page > Select CIs to Monitor Page > (Templates 
to CI Type Selection Dialog Box) > Enter Required Data 
for CIs Page > Final Configuration Summary Page > 
Deployment Results Page

UI Element Description

Export. Exports the Monitor Deployment Wizard 
Summary page to a PDF. This report includes all created 
entities in SiteScope displaying the deployment 
directory and status. It also displays the status of 
duplicate monitors.

CI Name column Lists the names of the selected CIs.

Object Name column Lists the monitors selected for deployment onto a given 
CI.

Status column Indicates whether the deployment succeeded.
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Retry Failed 
Deployments

Click Retry Failed Deployments to re-attempt to deploy 
those monitors whose deployment failed by modifying 
the data entered in the Type Required Data for CIs page.

Note: This button appears only if there were failed 
deployments.

Handle Duplicate 
Monitors

If duplicate monitors were deployed, click Handle 
Duplicate Monitors to open the Handle Duplicate 
Monitors dialog box. For each duplicate monitor listed, 
you can select to leave it intact, disable it, or delete it. If 
all the monitors are to be handled in the same way, you 
can use the Leave All Intact, Disable All or Delete All 
buttons at the bottom of the page. For details on 
understanding duplicate monitors, see "Full and Partial 
Monitor Coverage" on page 209.

UI Element Description
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7
Global Search and Replace

This chapter includes:

Concepts

➤ Global Search and Replace Overview on page 240

Tasks

➤ How to Perform a Global Search and Replace on page 243

Reference

➤ Global Search and Replace Wizard on page 250
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Concepts

Global Search and Replace Overview

The Global Search and Replace Wizard enables you to make changes to 
monitor, alert, alert action, group, preferences, and report properties. You 
can select an object based on object type and globally replace any of the 
properties of the selected object across your SiteScope or across multiple 
SiteScopes when working in SAM Administration.

For example, when upgrading BSM, use the Global Search and Replace 
Wizard to configure all the SiteScopes reporting data to BSM to the upgraded 
version. 

This section contains the following topics:

➤ "Filter Affected Objects" on page 240

➤ "Replace or Find and Replace" on page 241

➤ "Threshold Settings" on page 241

Filter Affected Objects
Use the Filter Affected Options option to further refine your selected object 
for the search operation. You can select specific properties and select or 
enter values pertaining to your object. This enables you to limit the selected 
objects but not the value to replace. 

When performing the replace operation, only the value to replace is 
replaced and only on those objects that match the properties selected in the 
Filter Affected Options page. For example, select all monitors with frequency 
set to 5 minutes and replace the monitor dependency setting for all of those 
monitors, or select only those monitors monitoring a specific server and 
replace the threshold settings for only those monitor instances matching 
the value of the server entered in the filter.
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Replace or Find and Replace
Use the replace method to search for a field value and replace it with a new 
value. For example, change the default monitor run frequency setting for 
the selected monitors by selecting the Frequency check box in the Monitor 
Run Settings panel, and updating the frequency value from 10 to 15 
minutes. 

Use the find and replace method to search for specific settings and property 
values and replace only those objects with the entered setting or value. You 
can search a string, value, or regular expression pattern and replace only 
that string. Replacements are made only if the filter criteria matches. For 
example, search for all monitors whose name value includes a server name 
that is no longer in use. Replace the string representing the old server with a 
new string representing the updated server. 

Threshold Settings
When replacing threshold settings for monitors, by default you replace only 
those settings that share all of the following:

➤ Have the same condition (Error if, Warning if, or Good if). 

➤ Are configured for the same schedule. 

➤ Use the same operator type (< <=, > >=, ==, !=, contains, !contains). 

Note: < (less than) and <= (less than and equal to) are considered the 
same operator type, as are > (greater than) and >= (greater than and equal 
to). 

You also have the option to override all the existing threshold settings that 
have the same condition (Error if, Warning if, or Good if) regardless of the 
operator used and the schedule configured. The option is called Override 
Category and appears in the Choose Changes page of the wizard under the 
Threshold Settings panel if you selected Monitor in the Select Type page of 
the wizard. 
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For example, you want to change the Error if threshold settings for all CPU 
monitors to greater than 85%. In the wizard, you select Monitor in the 
Select Type page, CPU in the Select Subtype page, and expand the Threshold 
Settings panel in the Choose Changes page. 

If you select the Override Category option when selecting greater than 85% 
as the New Error if status condition, all the existing Error if settings for all 
CPU monitors are overwritten and changed to greater than 85% when you 
complete the wizard. 

If you leave the option cleared, the greater than 85% Error if setting you 
select in the wizard replaces only those Error if settings that use the > 
(greater than) and >= (greater than and equal to) operators and were 
configured for the same schedule for all CPU monitors.

For details on setting thresholds, see "Setting Status Thresholds" in Using 
SiteScope in the SiteScope Help.
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Tasks

How to Perform a Global Search and Replace

This task describes how to perform a global search and replace for objects, 
using the Global Search and Replace Wizard.

This task includes the following steps:

➤ "Begin running the Global Search and Replace Wizard" on page 243

➤ "Select SiteScope (in SAM only)" on page 243

➤ "Select object type" on page 244

➤ "Search and replace objects" on page 245

➤ "Check affected objects" on page 248

➤ "Review replaced objects" on page 249

 1 Begin running the Global Search and Replace Wizard

In SAM Admin, select Admin > System Availability Management and click 
the Global Search and Replace button.

For user interface details, see "Global Search and Replace Wizard" on 
page 250.

 2 Select SiteScope (in SAM only)

Note: This step is only applicable when you access the Global Search and 
Replace wizard from SAM.

In the Select SiteScope page, select one or more SiteScopes on which to 
run the search and replace.
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 3 Select object type

In the Select Type and Select Subtype page, select the object and, if 
relevant, the subtype on which you want to make a replacement. 

For user interface details, see "Select Type Page" on page 252 and "Select 
Subtype Page" on page 253.

Example:

You want to change the threshold boundaries for all CPU monitors.

You select Monitor as the object type.

You select CPU as the specific monitor type.
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 4 Search and replace objects

In the Replace Mode page, select the type of replacement. Select Replace 
to globally replace the object or select Find and Replace to replace specific 
instances of the object. Optionally, you can open the Advanced Filter 
dialog box to filter by the object properties. Here you select on which 
objects to perform the replace operation. In the Choose Changes page, 
you select what properties or values to replace. 

For user interface details, see "Replace Mode Page" on page 254 and 
"Choose Changes Page" on page 255.

Example - Reducing the Frequency of a Monitor Run on a Specific Server:

You want to reduce the frequency of how often a monitor runs on a 
specific server in your company.

You filter your selection in the Monitor Settings panel in the Choose 
Changes page to include only those monitors monitoring the specified 
server.
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In the Choose Changes page, you then enter a new frequency of once a 
day, to monitor the specified server.

Example - Setting Up Alert Action to Send Alert Messages to Specified 
Email Addresses:

You set up your alert action to send alert messages to specified email 
addresses. However, one of the email addresses you configured to receive 
the alerts has changed and you want to send alert messages to the new 
email address. You want to update only the email address that has 
changed.

After selecting Alert Action as the object type, you select Find and Replace 
in the Replace Mode page.
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In the Choose Changes page, you enter the old email address in the Find 
field and the new email address in the and replace with field.



Chapter 7 • Global Search and Replace

248

 5 Check affected objects

In the Affected Objects page, view the affected objects and, if necessary, 
clear or select objects for the replacement operation. Optionally, you can 
open the Filter Affected Objects dialog box to filter by the object 
properties. Here you select on which objects to perform the replace 
operation. 

For user interface details, see "Affected Objects Page" on page 260.

Example - Reducing the Frequency of a Monitor Run on a Specific Server:

You want to reduce the frequency of how often a monitor runs on a 
specific server in your company.

If you had selected Replace in the Replace Mode page, in the Choose 
Changes page, you then enter a new frequency of once a day, to monitor 
the specified server.
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The affected objects are displayed in the Affected Objects page.

You can filter your selection in the Filter Affected Objects page to include 
only those monitors monitoring the specified server.

 6 Review replaced objects

In the Review Summary page, review the results of the replacement 
operation and click Finish to complete the wizard. You can view a 
summary of the changes in the Summary page to see which changes were 
implemented successfully and in which errors occurred.

For user interface details, see "Review Summary Page" on page 262 and 
"Summary Page" on page 264.
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Reference

Global Search and Replace Wizard

This wizard enables you to make changes to group, monitor, preferences, 
alert, alert action, and report properties. These changes can be made across a 
SiteScope or across several SiteScopes when working in SAM Administration. 

 

To access ➤ In SiteScope, right-click SiteScope root or the group or 
monitor in the monitor tree to which you want to 
perform the global replace. To replace Preferences 
objects, right-click SiteScope root. To replace alert 
objects, right-click SiteScope root, or the relevant 
group or monitor object. Select Global Search and 
Replace from the context menu.

➤ In BSM, select Admin > System Availability 
Management. Below the SiteScope Summary table in 
the right pane, click the Global Search and Replace 
button. 

Relevant tasks "How to Perform a Global Search and Replace" on 
page 243

Wizard map This wizard contains:

(Select SiteScope Page) > Select Type Page > Select 
Subtype Page > Replace Mode Page > Choose Changes 
Page > Affected Objects Page > (Filter Affected Objects 
Dialog Box) > Review Summary Page > Summary Page.
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Select SiteScope Page

Note: This page is displayed only when you are working in SAM 
Administration.

This wizard page enables you to select the SiteScope on which to make 
replacements.

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Important 
information 

➤ General information about this wizard is available 
here: "Global Search and Replace Wizard" on page 250.

➤ Only SiteScopes running version 9.0 and later and 
whose connection status permits configuration 
changes from SAM are listed.

➤ You must select at least one SiteScope.

Relevant tasks "How to Perform a Global Search and Replace" on 
page 243

Wizard map The Global Search and Replace Wizard contains:

(Select SiteScope Page) > Select Type Page > Select 
Subtype Page > Replace Mode Page > Choose Changes 
Page > Affected Objects Page > (Filter Affected Objects 
Dialog Box) > Review Summary Page > Summary Page.

UI Element Description

<SiteScope 
machines>

Select one or more SiteScopes on which to run the search 
and replace.
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Select Type Page
This wizard page enables you to select the object type on which you want to 
make replacements.

 

User interface elements are described below:

Important 
information 

➤ General information about this wizard is available 
here: "Global Search and Replace Wizard" on page 250.

➤ Only those types of objects available for the node you 
selected are listed. 

Relevant tasks "How to Perform a Global Search and Replace" on 
page 243

Wizard map The Global Search and Replace Wizard contains:

(Select SiteScope Page) > Select Type Page > Select 
Subtype Page > Replace Mode Page > Choose Changes 
Page > Affected Objects Page > (Filter Affected Objects 
Dialog Box) > Review Summary Page > Summary Page.

UI Element Description

Alert

Alert Action

Group

Monitor

Preferences

Report

You can select only one object type for each replace 
operation. Only those objects that exist in the SiteScope 
appear.

When performing Global Search and Replace from SAM 
Administration, group, monitor, alert, alert action, and 
preferences appear only if they exist on at least one 
SiteScope selected in the previous page.
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Select Subtype Page
This wizard page enables you to select the properties of the object type on 
which you want to make replacements.

 

User interface elements are described below:

Important 
information 

➤ General information about this wizard is available 
here: "Global Search and Replace Wizard" on page 250.

➤ This page opens only if you selected Alert Action, 
Monitor, or Preferences as the object type in the Select 
Type Page of the wizard. 

➤ If you selected the object type Group, Alert, or Report, 
this page does not open.

Relevant tasks "How to Perform a Global Search and Replace" on 
page 243

Wizard map The Global Search and Replace Wizard contains:

(Select SiteScope Page) > Select Type Page > Select 
Subtype Page > Replace Mode Page > Choose Changes 
Page > Affected Objects Page > (Filter Affected Objects 
Dialog Box) > Review Summary Page > Summary Page.

UI Element Description

<Object type 
properties>

Displays properties of the object type. For example, if 
you selected Monitor as the object type, it lists all monitor 
types for the selected SiteScopes. 
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Replace Mode Page
This wizard page enables you to select the type of replacement: global 
replacement or replacement based on filter criteria.

 

User interface elements are described below:

Important 
information 

General information about this wizard is available here: 
"Global Search and Replace Wizard" on page 250.

Relevant tasks "How to Perform a Global Search and Replace" on page 243

Wizard map The Global Search and Replace Wizard contains:

(Select SiteScope Page) > Select Type Page > Select Subtype 
Page > Replace Mode Page > Choose Changes Page > 
Affected Objects Page > (Filter Affected Objects Dialog Box) 
> Review Summary Page > Summary Page.

UI Element Description

Replace Globally replaces all matching objects with the new string or value. 

Find and 
Replace

Searches the target objects for properties that match a string or 
regular expression and replaces only the matching pattern with the 
replacement value. 

This method of replacement includes a search for specific settings 
and property values and replaces only those objects with the 
entered setting or value. You can select only a partial value and 
replace only that string.

Note:

➤ If you select this option, only settings whose values can contain 
a string are available in the settings area of the Choose Changes 
page and can be selected for the find and replace action.

➤ Use this setting to determine the selection and the value to 
replace. It differs from the Advanced Filter option which is a way 
to limit the selected objects but not the value to replace. 

Example: Search for all monitors whose name value includes a 
server name that is no longer in use. Replace the string representing 
the old server with a new string representing the updated server.
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Choose Changes Page
This wizard page enables you to select what to replace for the global replace. 
The wizard displays only the settings and properties that may be changed 
for the object type selected in the previous pages. The filter criteria is built 
from your selections in the Type, Subtype, and Advanced Filter pages.

Important 
information 

➤ General information about this wizard is available 
here: "Global Search and Replace Wizard" on page 250.

➤ The subtype’s properties may be displayed differently 
than how they are displayed when editing a monitor, 
alert, preference, and so forth in SiteScope. 

Examples: Mail Preferences is a text box in Global 
Search and Replace utility rather than a drop-down 
list, and the Depends on property is not displayed in 
the Global Search and Replace utility. 

➤ The Server property is available only when monitors 
from the following group are selected: CPU, Disk 
Space, Memory, Microsoft Windows Performance 
Counter, Web Server, and Service monitor. For other 
monitors, the server attribute can only be changed by 
selecting that specific monitor subtype in the Select 
Subtype page. For example, if a CPU monitor is 
selected with a Web Server monitor, the server 
property is available. If a monitor not from this group 
is also selected, the server property is not available. 

➤ Note for users of SiteScope within SAM 
Administration: If the SiteScopes selected for the 
replace operation are not all the same version, the 
subtypes of the SiteScopes may have different 
properties. 

Relevant tasks "How to Perform a Global Search and Replace" on 
page 243

Wizard map The Global Search and Replace Wizard contains:

(Select SiteScope Page) > Select Type Page > Select 
Subtype Page > Replace Mode Page > Choose Changes 
Page > Affected Objects Page > (Filter Affected Objects 
Dialog Box) > Review Summary Page > Summary Page.
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

Find 

Replace With

If you chose the Find and Replace option in the Replace 
Mode page, the text boxes Find and Replace With are 
added to the top of this page.

➤ In the Find box, enter the search string, value, or 
regular expression pattern for the setting or property 
you want to replace.

➤ In the Replace With box, enter the string or value to 
which you want all matching patterns to be changed.

Note: If you select Frequency in the Monitor Run 
Settings, the values you enter in the Find and Replace 
With text boxes must be in seconds. For example, you 
want to find monitors with a frequency of 10 minutes 
and change the frequency to 20 minutes. In the Find text 
box, enter 600 and in the Replace With text box enter 
1200.

If no objects are found that meet the filter criteria, an 
error message appears. Reselect your filter criteria.

<Settings area> This area includes the settings for the object you 
selected. For details about these settings, refer to the 
selected object’s settings page. 

➤ If you selected Find and Replace in the Replace Mode 
page, you select only the setting in the settings area. 
Enter the old and new values to replace in the 
Find/Replace with boxes.

➤ If you selected Replace in the Replace Mode page, you 
select the setting and the new value in the settings 
area.

For details about some of the areas, see:

➤ "Threshold Settings Area" on page 257

➤ "Filter Settings Area" on page 257

➤ "Server Settings Area" on page 258
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Threshold Settings Area

The Threshold Settings area is:

➤ Displayed only if you select monitor in the Select Type page, and one 
monitor in the Select Subtype page. 

➤ Not displayed in the Choose Changes page, if you select more than one 
monitor in the Select Subtype page, and one of the monitors does not 
include threshold definitions.

The Override Category option is displayed in the Threshold Settings area 
only if you selected Monitor in the Select Type page:

➤ When the option is selected, you can override the threshold settings of 
the same threshold condition (Error if, Warning if, or Good if) for the 
selected monitor instances with the settings you enter here for the replace 
operation. 

➤ When the option is cleared, the settings you enter here replace only those 
settings with the same operator type (< <=, > >=, !=, ==, contains, 
doesNotContain)) and the same configured schedule for the monitor 
instances. Any other settings for the same condition but with a different 
operator type or a different schedule remain. For details on this option 
and an example, see "Threshold Settings" on page 241.

Filter Settings Area

If you selected Alert in the Select Type page, the Monitor type match field in 
the Filter Settings is not displayed and its values cannot be replaced in the 
wizard. 
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Server Settings Area

The Server Settings area is displayed in the Choose Changes page if you 
select monitor in the Select Type page, and one monitor in the Select Subtype 
page. 

If you select two or more monitors in the Select Subtype page, and these 
monitors do not belong to the same family (as listed in the table below), the 
Server Settings Panel is not displayed.

Family of Monitors Monitors

SAP monitors ➤ SAP CCMS

➤ SAP CCMS Alerts

➤ SAP Java Web Application Server

➤ SAP Performance

➤ SAP Work Processes

SNMP monitors ➤ Cisco

➤ F5 Big-IP

➤ Network Bandwidth

➤ SNMP by MIB

URL monitors ➤ URL

➤ URL List

➤ URL Content

➤ URL Sequence

Media Player monitors ➤ Microsoft Windows Media Player

➤ Real Media Player
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Windows Counters 
monitors

➤ ASP 

➤ Citrix 

➤ ColdFusion 

➤ Microsoft Hyper-V 

➤ Microsoft IIS Server 

➤ Microsoft SQL Server 

➤ Microsoft Windows Media

➤ Real Monitor

Server monitors ➤ CPU

➤ Disk Space 

➤ Memory 

➤ Microsoft Windows Performance Counter

➤ Service 

➤ UNIX Resources 

➤ Web Server 

Family of Monitors Monitors
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Affected Objects Page
This wizard page enables you to view the objects that you selected to 
change. The page displays the selected objects in tree format. You can clear 
or select objects in the Affected Objects tree for the replacement operation.

 

Important 
information 

➤ General information about this wizard is available 
here: "Global Search and Replace Wizard" on 
page 250.

➤ The objects displayed depend on whether the user has 
change permissions on those objects. 

➤ In SAM Administration, the permissions are set in 
BSM’s Permissions Management (Admin > Platform 
> Users and Permissions). 

➤ In SiteScope standalone, the permissions are set in 
Preferences > User Management Preferences.

➤ If you selected Find and Replace in the Replace Mode 
page, replacements are made only if the filter criteria 
are matched. If you selected Replace, replacements 
are made in all selected objects.

Relevant tasks "How to Perform a Global Search and Replace" on 
page 243

Wizard map The Global Search and Replace Wizard contains:

(Select SiteScope Page) > Select Type Page > Select 
Subtype Page > Replace Mode Page > Choose Changes 
Page > Affected Objects Page > (Filter Affected Objects 
Dialog Box) > Review Summary Page > Summary Page.
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Filter Affected Objects Dialog Box
This dialog box enables you to select objects based on their specific settings 
and not only based on object type. For example, you can select all alerts that 
have a defined category of critical and replace any setting for those alerts. 
You can also select all groups with a dependency set to a specific monitor or 
group and replace any setting for those groups.

UI Element Description

Filter. Optionally, click to open the dialog box if you 
want to further refine your selections. For user interface 
details, see "Filter Affected Objects Dialog Box" on 
page 261.

<Affected Objects 
tree>

The Affected Objects tree includes all objects that are 
matched against the filter criteria selected in the 
previous pages of the wizard.

Select or clear objects as required for the replace 
operation.

Note: When using Global Search and Replace from SAM 
Administration, a tree is displayed for each SiteScope 
selected.

To access Click the Filter  button in the Affected Objects Page.

Important 
information

➤ General information about this wizard is available 
here: "Global Search and Replace Wizard" on page 250.

➤ Using this option only refines your selection for the 
replace and does not determine what to replace.
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Review Summary Page
This wizard page enables you to preview the objects on which the 
replacement operation is performed. When working with multiple 
SiteScopes in SAM Administration, a table is displayed for each SiteScope 
and the name of the SiteScope appears above the table.

 

Relevant tasks "How to Perform a Global Search and Replace" on 
page 243

Wizard map The Global Search and Replace Wizard contains:

(Select SiteScope Page) > Select Type Page > Select 
Subtype Page > Replace Mode Page > Choose Changes 
Page > Affected Objects Page > (Filter Affected Objects 
Dialog Box) > Review Summary Page > Summary Page.

UI Element Description

<Settings areas> The setting areas pertinent to the object you selected are 
displayed. For details about these settings, refer to the 
selected object’s settings page. Select the properties and 
enter the values by which to filter the selected objects.

Important 
information 

➤ General information about this wizard is available 
here: "Global Search and Replace Wizard" on 
page 250.

➤ The number of objects that are affected by the global 
replacement is displayed above the table.

➤ Each table column can be sorted in ascending or 
descending order by right-clicking the column title. 
An up or down arrow indicates the sort order.

➤ Once you click Apply in this page, you cannot undo 
the replacement operation. 
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Relevant tasks "How to Perform a Global Search and Replace" on 
page 243

Wizard map The Global Search and Replace Wizard contains:

(Select SiteScope Page) > Select Type Page > Select 
Subtype Page > Replace Mode Page > Choose Changes 
Page > Affected Objects Page > (Filter Affected Objects 
Dialog Box) > Review Summary Page > Summary Page.

UI Element Description

Change the sort order in the columns by clicking the up 
and down arrow in the column title. 

Default: The Full Name column is in alphabetical order, 
from top to bottom.

Full Name Displays a tree of the server name, group, monitor name, 
and the monitor’s properties whose value is being 
replaced.

<property> The box name that you marked in the Choose Changes 
page that changes as a result of the replace operation.

Previous Value The current value that changes as a result of the replace 
operation.Note: If the value being replaced is a check 
box that was cleared and is now being selected, you may 
not see the previous value (cleared) for the check box. 

New Value The new value that you entered in the Choose Changes 
page.

Verify monitor 
properties with 
remote server

Verifies the correctness of the monitor configuration 
properties against the remote servers on which the 
changes are being made. 

Default value: Selected 

Note: When this option is selected, it takes more time to 
make changes due to the remote connections. 
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Summary Page
The Summary page reports the changes that were implemented successfully 
and those in which errors occurred. The page displays the changes in table 
format. When working with multiple SiteScopes in SAM Administration, a 
table is displayed for each SiteScope and the name of the SiteScope appears 
at the top of the table.

 

Important 
information 

➤ General information about this wizard is available 
here: "Global Search and Replace Wizard" on page 250.

➤ There is no way to undo changes made by the replace 
operation.

➤ The number of objects affected by the global 
replacement is given above the table.

➤ Each table column can be sorted in ascending or 
descending order by right-clicking the column title. 
An up or down arrow indicates the sort order.

Relevant tasks "How to Perform a Global Search and Replace" on 
page 243

Wizard map The Global Search and Replace Wizard contains:

(Select SiteScope Page) > Select Type Page > Select 
Subtype Page > Replace Mode Page > Choose Changes 
Page > Affected Objects Page > (Filter Affected Objects 
Dialog Box) > Review Summary Page > Summary Page.
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

Change the sort order in the columns by clicking the up 
and down arrow in the column title. 

Default: The Full Name column is in alphabetical order, 
from top to bottom.

Full Name Displays a tree of the server name, group, monitor name, 
and the monitor’s properties whose value is being 
replaced.

<property> The box name that you marked in the Choose Changes 
page that changes as a result of the replace operation.

Previous Value The value that was replaced in the global replace 
operation.

New Value The new value that resulted from the global replace 
operation.

Print. Click to print the table. This icon appears for each 
table in the summary.

Apply Closes the wizard.
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8
SAM Reports

This chapter includes:

Concepts

➤ SAM Reports Overview on page 270

➤ Working with SAM Reports on page 271

➤ SiteScope Over Time Reports on page 273

➤ Understanding the Cross-Performance Report Scale on page 275

➤ Understanding the Group Performance Report on page 276

Tasks

➤ How to Create a Monitor Performance Report on page 277

➤ How to Create a Cross-Performance Report on page 279

➤ How to Rescale a Cross-Performance Report on page 280

➤ How to Add SAM Reports to Custom Reports on page 281

Reference

➤ SAM Legacy Reports on page 283

➤ SAM Reports User Interface on page 283

Troubleshooting and Limitations on page 323
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Concepts

SAM Reports Overview

You use the SAM application to view and analyze reports based on the 
performance data collected by the SiteScope data collector and stored in the 
BSM database.

In addition, using SiteScope Integration Monitors, you can integrate data 
collected by enterprise management systems (such as BMC Patrol, Tivoli, 
Concord, and NetIQ) into BSM, and view the data in SAM reports.

SAM utilizes data collected by SiteScope and enables you to:

➤ Monitor system availability across the entire enterprise infrastructure 
from a centralized, real-time perspective.

➤ Apply a business perspective to system management view data at the 
application level rather than viewing numerous low-level system metrics.

➤ View information about events collected from external applications or 
software and SiteScope events.

Note: 

➤ You access the SAM reports from the SAM application in the Applications 
menu.

➤ For details on working with BSM reports, see "Working in Reports" in 
Reports.

➤ Downtime information is not available in SAM reports. 

This section also includes:

➤ "Report Access and Permissions" on page 271

➤ "Data Aggregation" on page 271
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Report Access and Permissions
The availability of report data to a specific user is dependent on the profile 
access permissions granted to that user. In addition, access to specific data 
within a profile may also be filtered by using the group permission filters. 
For details on granting permissions, see "Permissions Overview" in Platform 
Administration. For details on defining group permission filters, see "System 
Availability Management" in Platform Administration.

Data Aggregation
BSM uses data aggregation to make data handling and management more 
efficient and to improve the speed and performance of report generation. 
For information about data aggregation in BSM, see "Data Aggregation" in 
Reports.

Working with SAM Reports

SAM reports help you identify server resource usage trends, as well as 
bottlenecks and other server-related issues that may be contributing to 
application performance problems. You can continually monitor report data 
to identify poor server performance or to spot developing trends that may 
lead to server performance problems.

Alternatively, when you become aware of a performance problem with your 
application (for example, after analyzing End User Management reports or 
receiving an alert), you can use SAM reports to help you identify, or rule out, 
infrastructure machine-related issues as the root cause of the problem. By 
analyzing the infrastructure machine resource usage data for the same time 
period during which the performance problem occurred, you can assess 
whether one or more infrastructure machine resource measurements are 
outside normal performance thresholds for that time period.

This section also includes:

➤ "Improving Report Generation Times" on page 272

➤ "Long Labels Used in Reports" on page 272
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Improving Report Generation Times

Note: This section is not relevant for HP Software-as-a-Service customers.

To optimize the performance of SAM report generation, we recommend that 
a database administrator perform an update statistics procedure to the 
database on a regular basis. The regularity of the update depends on the 
amount of data generated by the applications you are monitoring.

➤ Microsoft SQL Server users.

➤ For a small site, you should update once every three to four days.

➤ For a medium site, you should update daily.

➤ For a large site, you should update every four hours.

For details on Microsoft SQL Server maintenance, see "Maintaining 
Microsoft SQL Server Databases" in the HP Business Service Management 
Database Guide PDF.

➤ Oracle Server users. Analyze all tables according to database size.

For details on optimizing performance in Oracle, see "Collecting Statistics 
for Databases" in the HP Business Service Management Database Guide PDF.

Long Labels Used in Reports
You can control the location of the ellipsis ("...") used in long labels in 
System Availability Management Reports. This enables you to move the 
ellipsis from the end to the middle of the label.

To enable this feature, add the following properties to the 
<BSM root directory>\AppServer\webapps\site.war\
WEB-INF\rfw\conf\applications\sam-presentation.xml file:

<property key="stringBreakFormattingPolicyStr" value="Break_Middle"/> 
           <property key="stringBreakCutLocation" value="2" />
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SiteScope Over Time Reports

The SiteScope Over Time reports are the individual reports displayed in the 
SAM application in BSM. You use the SiteScope Over Time reports to view 
and analyze infrastructure machine-related data collected by the SiteScope 
data collector and stored in the BSM database. You cross-reference this data 
with transaction performance problems, such as slow transaction response 
times and failed transactions, to understand the root cause of application 
performance issues.

The contents of SiteScope Over Time reports depend on the types of 
SiteScope monitors and measurements that are defined in SAM 
Administration. 

BSM users can use group permissions filters to control the data that SAM 
reports display. This enables filtering data that may be irrelevant to a specific 
user, making reports more manageable and report generation faster. For 
details, see "System Availability Management" in Platform Administration.

Note: 

➤ For details on generating reports, see "Working in Reports" in Reports.

➤ Certain SAM reports can be added to custom reports. For task details, see 
"How to Add SAM Reports to Custom Reports" on page 281.

➤ Data collected by the SiteScope data collector can also be viewed in trend 
reports. Trend reports enable you to compare multiple measurements 
from different data sources on the same graph. For details, see "Trend 
Report Wizard" in Reports.

➤ To avoid affecting the correctness of system availability data during the 
Daylight Savings Time change (forward or backward), we recommend 
defining downtime or scheduling an event during the time change 
period. For more information on scheduling Downtime and Events, see 
"Downtime Management" in Platform Administration.

➤ If a SiteScope contains many measurements, report generation can take a 
few minutes.
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The following SAM reports are available (click the report name for details on 
the report):

Report Description

Monitor Performance 
Report

Displays the best- or worst-performing 
SiteScope monitors across various 
SiteScope categories.

Cross-Performance 
Report 

Displays data from more than one 
SiteScope server filtered by monitored 
servers, monitor types, and measurements. 

Group Performance 
Report

Displays the infrastructure machine 
resource usage data for the monitors in the 
selected group and its subgroups.

Status Summary 
Report

Displays a quick snapshot of the 
performance of monitored infrastructure 
machines, organized by SiteScope group.

Warning Summary 
Report

Displays a list of the monitors, for the 
selected group and its subgroups, whose 
measurements fell within the minor 
threshold level during the selected time 
period.

Error Summary 
Report

Displays a list of the monitors, for the 
selected group and its subgroups, whose 
measurements fell within the critical 
threshold level during the selected time 
period.
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Understanding the Cross-Performance Report Scale

Measurement values in the cross-performance report are displayed along the 
y-axis using a normalized scale. By default, BSM automatically sets the scale 
factor for each measurement. If required, you can manually modify the scale 
factor for any measurement in the Selected Measurements table, for 
example, to better view multiple measurements whose data values span a 
wide range. For details, see "How to Rescale a Cross-Performance Report" on 
page 280.

When you manually modify the scale factor, BSM scales measurement 
values by dividing the actual value by the value chosen in the scale list. 
Thus, a value of 100 with a scale setting of 0.1 is shown as 1000 along the y-
axis. A value of 100 with a scale setting of 10 is shown as 10 along the y-axis.

Rescaling a Cross-Performance Report

Cross-performance reports are generally scaled so that the lowest y-axis 
value is zero and the highest y-axis value is the highest result of the data. 

You can rescale the report to make it more relevant to the measurement. For 
example, to measure CPU utilization, you can rescale the report so that the 
y-axis range is 0 to 100.

For details on rescaling a Cross-Performance report, see "How to Rescale a 
Cross-Performance Report" on page 280. 
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Understanding the Group Performance Report

You create the Group Performance report and its subreports to view data 
that helps you spot trends in server performance that could lead to 
application performance problems. You can also analyze whether slow or 
failed transactions are being caused by server resource bottlenecks or other 
infrastructure machine-related problems.

The Group Performance table is the top level of the report. For each group, 
the table displays a color-coded quality level, the number of subgroups, and 
the number of included measurements. The quality-level indicators enable 
you to see how monitors in the defined groups are performing.

The Group Performance report contains the following sub-reports:

➤ SiteScope Performance Report. The SiteScope Performance subreport 
displays a list of measurements collected by SiteScope for the specified 
group, over the selected time range. If the specified group contains 
subgroups, these are displayed at the top of the page. For details, see 
"SiteScope Performance Report" on page 296.

➤ SiteScope Data Over Time Report. The SiteScope Data Over Time report 
displays specific measurement data over the selected time range. You can 
view this report for a single measurement, or for several measurements 
simultaneously. For details, see "SiteScope Data Over Time Report" on 
page 300.
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Tasks

How to Create a Monitor Performance Report

This task describes how to specify the criteria on which you want the 
Monitor Performance Report to be based and create the report.

This task includes the following steps:

➤ "Access the Monitor Performance report" on page 277

➤ "Select the SiteScope" on page 277

➤ "Specify monitors to include in the report" on page 278

➤ "Generate the report" on page 278

 1 Access the Monitor Performance report

Access the Monitor Performance report: Select Applications > System 
Availability Management > SiteScope Over Time Reports > Monitor 
Performance.

 2 Select the SiteScope

Click Profile(s) and select the SiteScope for which you want to view the 
report.
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 3 Specify monitors to include in the report

 a In the Monitor title and Server name boxes, specify the monitors (by 
their title, as defined in SiteScope) and servers on which you want the 
custom report data to be based. 

Leave a box empty to instruct BSM to base the report on all values.

If required, you can use the wildcard asterisk symbol (*) to instruct 
BSM to base the report on a subset of all values. For example, if you are 
using the naming convention cpu_<servername> to name all CPU 
monitors in SiteScope, specify cpu* to instruct BSM to include all CPU 
monitors in the custom report.

Note: Using the wildcard asterisk symbol (*) as the first character in 
the string slows report generation times, as BSM is unable to use the 
Index tables when querying the database.

 b From the Monitor type list, select the monitor on which you want the 
report data to be based. To base the report on all monitors, choose All 
types.

 c Specify whether you want BSM to display the worst- or best-
performing monitors, and choose the number of monitors to be 
displayed in the report.

 4 Generate the report

Click Generate to create the report. For user interface details, see 
“Monitor Performance Report” on page 284.
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How to Create a Cross-Performance Report

This task describes how to create a Cross-Performance report.

This task includes the following steps:

➤ "Access the Cross-Performance report" on page 279

➤ "Select the time range and granularity" on page 279

➤ "Select measurements for monitoring" on page 280

➤ "Configure scale report information" on page 280

➤ "Generate and format the report" on page 280

 1 Access the Cross-Performance report

Access the Cross-Performance report: Select Applications > System 
Availability Management > SiteScope Over Time Reports > 
Cross-Performance.

 2 Select the time range and granularity

Select the time period and the granularity with which you want to run 
the report. For task details on using the Time Range and Granularity bar, 
see "How to Run Reports" in Reports.

Note: In certain reports the selected time range is displayed along the x-
axis. SAM breaks down the time range according to segments, which 
differ depending on the selected time range.
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 3 Select measurements for monitoring

Click the Select Measurements link to choose the measurements you 
want the Cross-Performance report to monitor. For user interface details, 
see "Select Measurements Dialog Box" on page 292.

 4 Configure scale report information

If required, enter scale information in the Scale Min and Max boxes. For 
task details, see "How to Rescale a Cross-Performance Report" on 
page 280.

 5 Generate and format the report

Click Generate to create the report. The filter area of the page closes and 
the report opens.

You can print the report, send it by email, or open it in CSV or PDF 
format. For user interface details, see "Common Report and Page 
Elements" in Reports.

How to Rescale a Cross-Performance Report

This task describes how to change the y-axis scale of a Cross-Performance 
report.

 1 Click the Select Measurements link on the Cross-Performance report page 
to open the Select Measurements dialog box. 

 2 Specify a minimum, a maximum, or both a minimum and a maximum 
value in the Scale Min and Max boxes. 
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How to Add SAM Reports to Custom Reports

The following steps describe how to add SAM reports to custom reports from 
the Report Manager. You can add SAM reports to custom reports from the 
Report Manager. For details, see "Custom Report Wizard" in Reports.

This task includes the following steps:

➤ “Add Monitor Performance Report to custom reports” on page 281

➤ “Add SiteScope Data Over Time Report to custom reports” on page 281

➤ “Add SiteScope Group Performance Report to custom reports” on 
page 282

➤ “Add Overall Performance Report to custom reports” on page 282

Add Monitor Performance Report to custom reports

 1 Select Applications > User Reports > Report Manager.

 2 In Report Manager, click New, and select New Custom Report

 3 On the Report Components page, click Add New Component.

 4 In the Select Component Category pane, select System Availability 
Management > SiteScope Monitor Performance.

Add SiteScope Data Over Time Report to custom reports

 1 Select Applications > User Reports > Report Manager.

 2 In Report Manager, click New, and select New Custom Report

 3 On the Report Components page, click Add New Component.

 4 In the Select Component Category pane, select System Availability 
Management > SiteScope Reports.

 5 In the Select Component pane, select SiteScope Data Over Time in the 
Type list. 
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Add SiteScope Group Performance Report to custom reports

 1 Select Applications > User Reports > Report Manager.

 2 In Report Manager, click New, and select New Custom Report

 3 On the Report Components page, click Add New Component.

 4 In the Select Component Category pane, select System Availability 
Management > SiteScope Reports.

 5 In the Select Component pane, select SiteScope Profile Summary in the 
Type list. 

Add Overall Performance Report to custom reports

 1 Select Applications > User Reports > Report Manager.

 2 In Report Manager, click New, and select New Custom Report

 3 On the Report Components page, click Add New Component.

 4 In the Select Component Category pane, select System Availability 
Management > SiteScope Reports.

 5 In the Select Component pane, select SiteScope Data Over Time in the 
Type list. 
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Reference

SAM Legacy Reports

The following are legacy reports in SAM, and not all the report functions 
listed in "Common Report and Page Elements" in Reports are supported in 
these reports:

➤ Monitor Performance Report

➤ Group Performance Report

➤ Status Summary Report

➤ Warning Summary Report

➤ Error Summary Report

SAM Reports User Interface

This section includes:

 ➤ Monitor Performance Report on page 284

 ➤ Cross-Performance Report on page 288

 ➤ Group Performance Report on page 294

 ➤ SiteScope Performance Report on page 296

 ➤ SiteScope Data Over Time Report on page 300

 ➤ Status Summary Report on page 303

 ➤ SiteScope Uptime Summary Report on page 306

 ➤ Warning Summary Report on page 308

 ➤ SiteScope Warning Details Report on page 311

 ➤ Error Summary Report on page 315

 ➤ SiteScope Error Details Report on page 318

 ➤ Overall Performance Report on page 321
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Monitor Performance Report

This report displays the best- or worst-performing SiteScope monitors across 
various SiteScope categories, such as monitor type, monitored server, or 
monitor title. You can create a Monitor Performance report for multiple 
SiteScope profiles.

This is an example of a Monitor Performance report:
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To access Select Applications > System Availability Management > 
SiteScope Over Time Reports > Monitor Performance

Important 
information

➤ Monitors are sorted in the report by quality, which is 
derived using a formula that takes into account the 
measurement values returned for the monitor during 
the specified time range relative to the measurement 
threshold ranges configured in SiteScope. 

The formula used is: 1-((0.35*W+0.5*E)/(G+W+E)), 
where G, W, and E represent the number of 
measurements that occurred during the selected time 
range whose value was within the OK, Warning, and 
Error threshold range, respectively. The formula 
returns values from 0.5 to 1, inclusively. The better a 
monitor performs, the closer its value is to 1. For 
example, a monitor with 25% error and 75% OK 
values would be displayed as better than a monitor 
with 100% Warning values.

➤ All data in the report is based on aggregated data. The 
Monitor Performance report does not use raw data.

➤ You can control the location of the ellipsis ("...") used 
in long labels in System Availability Management 
Reports. For details, see "Long Labels Used in Reports" 
on page 272.

➤ SiteScope data is not displayed when you click a 
SiteScope link in the Monitor Performance report. 

➤ Some of the report functions listed in "Common 
Report and Page Elements" in Reports are not 
supported in this report.

Relevant tasks "How to Create a Monitor Performance Report" on 
page 277

See also "SiteScope Over Time Reports" on page 273
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This section includes:

➤ “Report Settings” on page 286

➤ “Report Content” on page 287

➤ “Color Coding in Reports” on page 288

Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element (A-Z) Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.

Note: Some of the common report settings are not 
supported in this report.

Monitor title Specify the monitors (by their title, as defined in 
SiteScope) on which you want the custom report data to 
be based.

Monitor type Select the monitor on which you want the report data to 
be based. To base the report on all monitors, choose All 
types.

Server name Specify the servers on which you want the custom report 
data to be based.

Show the <number 
and performance 
level> monitors

Specify whether you want BSM to display the worst- or 
best-performing monitors, and choose the number of 
monitors to be displayed in the report.
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Report Content

User interface elements are described below:

UI Element (A-Z) Description

Critical The percentage of measurement instances that return a 
critical-level threshold status.

Group The group or subgroup in which the monitor is defined. 
Hover over the selected entry to view the path from the 
displayed group or subgroup to the root group. Click the 
group or subgroup name to open the management page 
for the group in SiteScope.

Minor The percentage of measurement instances that return a 
minor-level threshold status. 

Monitor Title The title of the SiteScope monitor. Hover over the entry 
to view a tooltip with the full monitor title. 

Profile Name The name of the SiteScope profile in which the monitor 
is defined.

Quality A color-coded representation of quality. Hover over the 
color to view a tooltip with the exact percentage for each 
colored section of the bar.

For an explanation of the indicated colors, see "Color 
Coding in Reports" on page 288.

Server Name The name of the monitored server. Hover over the 
selected entry to view a tooltip with the full server name.

Total Runs The total number of measurement instances SiteScope 
ran for the selected time range.
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Color Coding in Reports

SAM reports use the following colors when displaying color-coded 
performance levels:

Cross-Performance Report

This report displays data from more than one SiteScope server filtered by 
monitored servers, monitor types, and measurements. 

This is an example of a Cross-Performance report:

Color Description

Green All measurements fell within the OK threshold range.

Yellow At least one measurement fell within the minor threshold range, 
but no measurements fell within the critical threshold range.

Red At least one measurement fell within the critical threshold range.

Gray No measurement data reported.
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This section includes:

➤ “Report Settings” on page 290

➤ “Report Content as Graph” on page 290

➤ “Report Content as Table” on page 291

To access Select Applications > System Availability Management > 
SiteScope Over Time Reports > Cross-Performance

Important 
information

➤ Click the appropriate tab to choose how you want to 
view the Cross-Performance report:

➤ View as Graph

➤ View as Table

➤ You can choose to view data in separate graphs for 
each measurement, or in one graph for all 
measurements. For details, see "Select Measurements 
Dialog Box" on page 292.

➤ You can control the location of the ellipsis ("...") used 
in long labels in System Availability Management 
Reports. For details, see "Long Labels Used in Reports" 
on page 272.

Relevant tasks "How to Create a Cross-Performance Report" on page 279

See also "Troubleshooting and Limitations" on page 323
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Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Report Content as Graph

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element (A-Z) Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.

Select Measurements Click to open the Select Measurements dialog box and 
filter the data you want to include in the report. For 
details, see "Select Measurements Dialog Box" on 
page 292.

Note: You cannot create a report if you have not selected 
at least one measurement.

UI Element (A-Z) Description

<data points> Indicate one of the following: 

➤ A change in the data value or measurement frequency 
from the previous time point on the graph.

➤ One hour has passed since the last change in data 
value or measurement frequency.

<graph lines> The value of the specified measurements, at the indicated 
time. A straight line indicates the following: 

➤ There has been no change in the value of the 
incoming data from the previous time point on the 
graph.

➤ There has been no change in the frequency that the 
incoming data is measured in since the previous time 
point on the graph.

Note: A gap in the graph indicates that no data has been 
retrieved for the specific time period.
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Report Content as Table

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

<x-axis> Displays the date and time of the monitored 
measurements. 

Note: Depending on the time range you select, SAM 
generates reports using either raw data or aggregated 
data. The text: Note: Report uses aggregated data is 
displayed in the report when aggregated data is used. For 
details on how SAM determines when to use aggregated 
data, see "Data Aggregation" in Reports.

<y-axis> Displays the measurement values and the monitor type 
or title, depending on whether you selected Filter by 
Monitor Type or Filter by Monitor Title in the Select 
Measurements dialog box.

UI Element (A-Z) Description

<date> The date and time of the measurements’ data.

Note: Depending on the time range you select, SAM 
generates reports using either raw data or aggregated 
data. The text: Note: Report uses aggregated data is 
displayed in the report when aggregated data is used. For 
details on how SAM determines when to use aggregated 
data, see "Data Aggregation" in Reports.

<value> The value of the specific measurement.

Measurement Name The name of the measurement, including the server on 
which it is running. 

Tootlip: Displays the full path of the measurement name. 

UI Element (A-Z) Description
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Select Measurements Dialog Box
This dialog box enables you to filter the data you want to include in the 
Cross-Performance report. 

User interface elements are described below:

To access On the Cross-Performance report page, click the Select 
Measurements link. 

Important 
information

If you select a measurement for which data exists from 
more than one group or profile for the same target server, 
the data is averaged together in the report. For example, 
if you have two SiteScope profiles each containing two 
groups, and in three of those groups the Ping monitor is 
set up to monitor the same server, if you select both 
profiles and the round trip time measurement, all round 
trip time data collected from all three groups in both 
profiles is displayed in the report as an average value. 

Relevant tasks "How to Create a Cross-Performance Report" on page 279

See also "Troubleshooting and Limitations" on page 323

UI Element (A-Z) Description

Click to list all the elements whose name includes the 
string entered in the Contains box. 

Contains Optionally, enter a string by which you want to filter 
elements in the selected column. 

Disable auto-scale Click to disable automatic rescaling of the report scale 
factor. For details on changing the report scale, see 
"Understanding the Cross-Performance Report Scale" on 
page 275.

Filter by Monitor 
Title

Select to display the monitor title when choosing the 
component to add to the report.

Example: myserver, CPU finance_server
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Filter by Monitor 
Type

Select to display the monitor type when choosing the 
component to add to the report.

Example: Ping, CPU

Graph per 
measurement

Select to display a separate graph for each measurement. 
The graph legend displays the server on which the 
measurement is running. 

If de-selected, a new graph is created for each 
measurement with the title <server_name> continued.

Default Value: Selected

Measurements Select one or more measurements. The list includes the 
measurements that are associated with the selected 
profiles, servers, and monitor types, in alphabetical order.

Monitor 
Types/Monitor 
Measurements

Depending on whether you chose Filter by Monitor Type 
or Filter by Monitor, displays monitor types or monitor 
names, associated with the selected profiles and servers, 
in alphabetical order. Select one or more monitors.

Profiles Select one or more SiteScope profiles to be included in 
the report.

Note: The number of selected profiles are calculated after 
you click Generate. You can choose up to 10 profiles. If 
these numbers exceed the limit, an error message is 
displayed.

Scale Optionally, enter relevant values in the Min and Max 
boxes to rescale the y-axis for the report. For details, see 
"How to Rescale a Cross-Performance Report" on 
page 280.

Note: If the data values of a monitor are outside the 
minimum or maximum configured values of the graph, 
the data points are displayed outside the boundaries of 
the graph.

Servers Select one or more servers. The list includes all monitored 
servers associated with the selected profiles, in 
alphabetical order. 

UI Element (A-Z) Description



Chapter 8 • SAM Reports

294

Group Performance Report

This report displays the infrastructure machine resource usage data for the 
monitors in the selected group and its subgroups. You use this report to view 
data that helps you spot trends in server performance that could lead to 
application performance problems.

This is an example of a Group Performance report:

To access Select Applications > System Availability Management > 
SiteScope Over Time Reports > Group Performance

Important 
information

➤ The Group Performance Report contains the following 
sub-reports: 

➤ SiteScope Performance Report

➤ SiteScope Data Over Time Report

➤ You click the group name to open the SiteScope 
Performance report for the specified group. 

➤ You can control the location of the ellipsis ("...") used 
in long labels in System Availability Management 
Reports. For details, see "Long Labels Used in Reports" 
on page 272.

➤ Some of the report functions listed in "Common 
Report and Page Elements" in Reports are not 
supported in this report.

See also "SiteScope Performance Report" on page 296

"SiteScope Data Over Time Report" on page 300
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This section includes:

➤ “Report Settings” on page 295

➤ “Report Content” on page 295

Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Report Content

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element (A-Z) Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.

Note: Some of the common report settings are not 
supported in this report.

GUI Element (A-Z) Description

<quality level 
indicator>

A color-coded icon which enables you to see how 
monitors in the defined groups are performing.

Tooltip: Indicates the group’s quality level and number of 
critical errors.

<quality level 
legend>

Indicates the quality level that the colored icons in the 
Group Performance table represent. 

Group Name The name of the SiteScope monitor group. Click the 
group name to open the SiteScope Performance report for 
the specified group. For details on the SiteScope 
Performance report, see "SiteScope Performance Report" 
on page 296. 

Tooltip: Displays the full group name.
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SiteScope Performance Report

This report displays a list of measurements collected by SiteScope for the 
specified group, over the selected time range.

This is an example of a SiteScope Performance report:

Number of 
Measurements

The number of measurements contained in the specified 
group. 

Number of 
Subgroups

The number of subgroups contained in the specified 
group.

To access Click an entry in the Group Name field on the Group 
Performance table.

Important 
information

The SiteScope Performance Report is divided into the 
following sections: 

➤ Subgroups for Group: <Group name>. The elements 
displayed in this section are identical to those 
displayed on the Group Performance report main 
page. 

➤ SiteScope Measurements for Group: <Group name>. 
Displays the measurements collected for the specified 
group. 

➤ You can control the location of the ellipsis ("...") used 
in long labels in System Availability Management 
Reports. For details, see "Long Labels Used in Reports" 
on page 272.

GUI Element (A-Z) Description
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This section includes:

➤ “Report Settings” on page 297

➤ “Report Content for Subgroups for Group: <Group Name> Table” on 
page 298

➤ “Report Content for SiteScope Measurements for Group: <Group Name> 
Table” on page 299

Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element (A-Z) Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.

Generate Click to generate the SiteScope Data Over Time report for 
the selected measurements.

Note: This button is located underneath the SiteScope 
Performance report, and is enabled only if there are 
enabled check boxes in the SiteScope Measurements for 
Group: <Group name> section. 
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Report Content for Subgroups for Group: <Group Name> Table

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element (A-Z) Description

<quality level 
indicator>

A color-coded icon which enables you to see how 
monitors in the defined groups are performing.

Tooltip: Indicates the group’s quality level and number of 
critical errors.

<quality level 
legend>

Indicates the quality level that the colored icons in the 
Group Performance table represent. 

Group Name The name of the SiteScope monitor group. Click the 
group name to open the SiteScope Performance report for 
the specified group’s measurements. For details, see 
"Report Content for SiteScope Measurements for Group: 
<Group Name> Table" on page 299. 

Tooltip: Displays the full group name.

Number of 
Measurements

The number of measurements contained in the specified 
group. 

Number of 
Subgroups

The number of subgroups contained in the specified 
group.
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Report Content for SiteScope Measurements for Group: <Group 
Name> Table

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element (A-Z) Description

<check box> An enabled check box indicates that there is monitor 
data that can be viewed in the SiteScope Data Over Time 
report. To view this data, select the checkbox 
corresponding to the measurement for which you want 
to view data, and click Generate. 

For details on the SiteScope Data Over Time report, see 
"SiteScope Data Over Time Report" on page 300.

<quality level 
indicator> 

Displays measurement threshold colored icons, which 
indicate whether the average measurement is within the 
OK, Warning, or Error range, as reported by SiteScope. 
You define measurement thresholds for each 
measurement when you configure the monitor in SAM 
Administration. For details, see "Setting Status 
Thresholds" in Using SiteScope in the SiteScope Help.

Avg. Value The average value of each listed measurement, or 
counter, for the specified time period.

Critical Errors/Total The number of critical errors that occurred while 
collecting measurement data, out of the total number of 
measurements taken during the defined time period. 
Click the link to view a list of critical error messages. BSM 
displays the link only if errors occurred. 

Host Name The name of the SiteScope host machine. 

Measurement Name The name of the measurement. If measurement data 
exists for the selected time range, the measurement name 
appears as a link. Click the measurement link to open the 
SiteScope Data Over Time report. For details on the 
SiteScope Data Over Time report, see "SiteScope Data 
Over Time Report" on page 300.

Monitor Title The title of the monitor.
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SiteScope Data Over Time Report

This report displays specific measurement data over the selected time range. 

This is an example of a SiteScope Data Over Time report:
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To access From the SiteScope Performance Report, perform one of 
the following actions:

➤ Select the checkbox corresponding to the 
measurement you want to view data for and click 
Generate. 

➤ Click the measurement link in the Measurement 
Name column. This column displays a link only if 
there is measurement data exists for the selected time 
range.

Important 
information

➤ You can view this report for a single measurement, or 
for several measurements simultaneously.

➤ You can add the SiteScope Data over Time report to 
custom reports. For details, see "Custom Report 
Wizard" in Reports.

➤ Click the appropriate tab to view the report either in 
graph or table format. When viewing in table format, 
the table displays actual measurement values, not 
normalized values.

➤ You can control the location of the ellipsis ("...") used 
in long labels in System Availability Management 
Reports. For details, see "Long Labels Used in Reports" 
on page 272.
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This section includes:

➤ “Report Settings” on page 302

➤ “Report Content as Graph” on page 302

➤ “Report Content as Table” on page 303

Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Report Content as Graph

User interface elements are described below:

UI Element Description

<Format Buttons> Click the appropriate button to print the report, send it 
by email, or open it in CSV or PDF format. For user 
interface details, see "Common Report and Page 
Elements" in Reports

UI Element Description

<color code legend> Identifies the measurements in the graph, by color. 

<data points> Tooltip: Displays measurement details, including the 
measurement’s original value. 

<x-axis> Displays the date and time of the monitored 
measurements. 

<y-axis> Displays a normalized scale of 0 - 100 for the monitored 
measurements. BSM uses the following formula to 
convert the original y-axis value to a value in the merged 
y-axis:

[original y-axis value]  x  [scale value]  =  y-axis value in 
merged graph

View as Table Click to view the SiteScope Data Over Time report in 
table format. 
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Report Content as Table

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Status Summary Report

This report displays a quick snapshot of the performance of monitored 
infrastructure machines, organized by SiteScope group. You create the Status 
Summary report and its subreport to get an overall view of the performance 
of defined SiteScope groups and the monitors defined therein.

This is an example of a Status Summary report:

UI Element Description

<date> The date of the data output for the selected 
measurement.

<monitor title and 
measurement name>

Tooltip: Hover over the entry to view the title of the 
monitor being measured, and the name of the specific 
measurement.

This element is located on the left side of the table.

<time> The time of the data output for the selected 
measurement.

<value> The value of the measurement for the specified time.

View as Graph Click to view the SiteScope Data Over Time report in 
graph format.
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This section includes:

➤ “Report Settings” on page 304

➤ “Report Content” on page 305

Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

To access Select Applications > System Availability Management > 
SiteScope Over Time Reports >Status Summary

Important 
information

➤ You can control the location of the ellipsis ("...") used 
in long labels in System Availability Management 
Reports. For details, see "Long Labels Used in Reports" 
on page 272.

➤ Some of the report functions listed in "Common 
Report and Page Elements" in Reports are not 
supported in this report.

UI Element Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.

Note: Some of the common report settings are not 
supported in this report.



Chapter 8 • SAM Reports

305

Report Content

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element (A-Z) Description

<quality level 
indicator>

A color-coded icon which enables you to see how 
monitors in the defined groups are performing.

Tooltip: Indicates the group’s quality level and number of 
critical errors.

<quality level 
legend>

Indicates the quality level that the colored icons in the 
Group Performance table represent. 

Group Name The name of the SiteScope monitor group. Click the 
group name to open the SiteScope Uptime Summary 
report for the specified group. For details on the 
SiteScope Uptime Summary report, see "SiteScope Uptime 
Summary Report" on page 306. 

Tooltip: Displays the full group name.

Number of 
Measurements

The number of measurements contained in the specified 
group. 

Number of 
Subgroups

The number of subgroups contained in the specified 
group.
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SiteScope Uptime Summary Report

This report displays OK, Minor, and Critical information for each monitor in 
the group, over the selected time range. The SiteScope Uptime Summary 
report enables you to determine the overall performance trend of a given 
monitor.

This is an example of the SiteScope Uptime Summary Report:

To access Click a group name in the Status Summary report.

Important 
information

➤ If the specified group contains subgroups, these are 
displayed at the top of the page. Click the subgroups 
to view their SiteScope Uptime Details subreports.

➤ This report cannot be opened in PDF format.

➤ You can control the location of the ellipsis ("...") used 
in long labels in System Availability Management 
Reports. For details, see "Long Labels Used in Reports" 
on page 272.
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This section includes:

➤ “Report Settings” on page 307

➤ “Report Content” on page 307

Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Report Content

User interface elements are described below:

UI Element Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.

UI Element (A-Z) Description

Critical % The percentage of measurement instances whose values 
fell within the Critical threshold level.

Minor % The percentage of measurement instances whose values 
fell within the Minor threshold level.

Monitor Title The title of the monitor being measured.

OK % The percentage of measurement instances that 
completed successfully.
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Warning Summary Report

This report displays a list of the monitors, for the selected group and its 
subgroups, whose measurements fell within the minor threshold level 
during the selected time period. You create the Warning Summary report 
and its subreport to identify the SiteScope groups whose measurements fell 
within the minor threshold level during the selected time period.

This is an example of the Warning Summary report:

To access Select Applications > System Availability Management > 
SiteScope Over Time Reports > Warning Summary

Important 
information

➤ You can control the location of the ellipsis ("...") used 
in long labels in System Availability Management 
Reports. For details, see "Long Labels Used in Reports" 
on page 272.

➤ Some of the report functions listed in "Common 
Report and Page Elements" in Reports are not 
supported in this report.
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This section includes:

➤ “Report Settings” on page 309

➤ “Report Content” on page 310

Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.

Note: Some of the common report settings are not 
supported in this report.
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Report Content

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element (A-Z) Description

<quality level 
indicator>

A color-coded icon which enables you to see how 
monitors in the defined groups are performing.

Tooltip: Indicates the group’s quality level and number of 
critical errors.

<quality level 
legend>

Indicates the quality level that the colored icons in the 
Group Performance table represent. 

Group Name The name of the SiteScope monitor group. Click the 
group name to open the SiteScope Warning Details report 
for the specified group. For details on the SiteScope 
Warning Details report, see "SiteScope Warning Details 
Report" on page 311. 

Tooltip: Displays the full group name.

Number of 
Measurements

The number of measurements contained in the specified 
group. 

Number of 
Subgroups

The number of subgroups contained in the specified 
group.
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SiteScope Warning Details Report

This report displays minor status information for each measurement 
instance of each monitor in the group, over the selected time range. 

This is an example of the SiteScope Warning Details report:

To access Click a group name in the Warning Summary report.

Important 
information

➤ SAM displays only raw data in the SiteScope Warning 
Details report. Aggregated data is not used. Therefore, 
if raw historical data is removed from the profile 
database using the Purging Manager, you are unable to 
view data in the SiteScope Warning Details report for 
the time period for which the data was removed.

➤ This report cannot be opened in PDF format.
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This section includes:

➤ “Report Settings” on page 312

➤ “Report Content for Subgroups for Group: <Group Name> Table” on 
page 313

➤ “Report Content for SiteScope Warning Measurements for Group: <Group 
Name> Table” on page 314

Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.
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Report Content for Subgroups for Group: <Group Name> Table

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element (A-Z) Description

<quality level 
indicator>

A color-coded icon which enables you to see how 
monitors in the defined groups are performing.

Tooltip: Indicates the group’s quality level and number of 
critical errors.

<quality level 
legend>

Indicates the quality level that the colored icons in the 
Group Performance table represent. 

Group Name The name of the SiteScope monitor group. Click the 
group name to open the SiteScope Warning Details report 
for the specified group and view the group’s 
measurements. For details, see on the SiteScope 
Performance report, see "Report Content for SiteScope 
Warning Measurements for Group: <Group Name> Table" 
on page 314. 

Tooltip: Displays the full group name.

Number of 
Measurements

The number of measurements contained in the specified 
group. 

Number of 
Subgroups

The number of subgroups contained in the specified 
group.
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Report Content for SiteScope Warning Measurements for 
Group: <Group Name> Table

User interface elements are described below:

UI Element (A-Z) Description

Measurement Name The measurement instance whose threshold fell within 
the Minor level.

Monitor Title The monitor to which the measurement is associated.

Status The value of the measurement.

Time The date and time of the measurement instance.
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Error Summary Report

This report displays a list of the monitors, for the selected group and its 
subgroups, whose measurements fell within the critical threshold level 
during the selected time period. You create the Error Summary report and its 
subreport to identify the SiteScope groups whose measurements fell within 
the critical threshold level during the selected time period.

This is an example of an Error Summary report:

To access Select Applications > System Availability Management > 
SiteScope Over Time Reports > Error Summary

Important 
information

➤ For each SiteScope group in the selected profile, the 
report displays a color-coded quality level, the number 
of subgroups, and the number of included 
measurements. The quality-level indicators enable you 
to get a quick snapshot of how monitors in the 
defined SiteScope groups are performing.

➤ You can control the location of the ellipsis ("...") used 
in long labels in System Availability Management 
Reports. For details, see "Long Labels Used in Reports" 
on page 272.

➤ Some of the report functions listed in "Common 
Report and Page Elements" in Reports are not 
supported in this report.
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This section includes:

➤ “Report Settings” on page 316

➤ “Report Content” on page 317

Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.

Note: Some of the common report settings are not 
supported in this report.



Chapter 8 • SAM Reports

317

Report Content

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

<quality level 
indicator>

A color-coded icon which enables you to see how 
monitors in the defined groups are performing.

Tooltip: Indicates the group’s quality level and number of 
critical errors.

<quality level 
legend>

Indicates the quality level that the colored icons in the 
Group Performance table represent. 

Group Name The name of the SiteScope monitor group. Click the 
group name to open the SiteScope Error Details report for 
the specified group. For details on the SiteScope Error 
Details report, see "SiteScope Error Details Report" on 
page 318. 

Tooltip: Displays the full group name.

Number of 
Measurements

The number of measurements contained in the specified 
group. 

Number of 
Subgroups

The number of subgroups contained in the specified 
group.



Chapter 8 • SAM Reports

318

SiteScope Error Details Report

This report displays error status information for each measurement instance 
of each monitor in the group, over the selected time range.

This is an example of a SiteScope Error Details report:

To access Click a group name in the Error Summary report.

Important 
information

➤ SAM displays only raw data in the SiteScope Error 
Details report. Aggregated data is not used. Therefore, 
if raw historical data was removed from the profile 
database using the Purging Manager, you are unable to 
view data in the SiteScope Error Details report for the 
time period for which the data was removed.

➤ This report cannot be opened in PDF format.



Chapter 8 • SAM Reports

319

This section includes:

➤ “Report Settings” on page 319

➤ “Report Content for Subgroups for Group: <Group name> Table” on 
page 320

➤ “Report Content for SiteScope Error Messages for Group: <Group name> 
Table” on page 320

Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.
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Report Content for Subgroups for Group: <Group name> Table

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Report Content for SiteScope Error Messages for Group: 
<Group name> Table

User interface elements are described below:

UI Element Description

<quality level 
indicator>

A color-coded icon which enables you to see how 
monitors in the defined groups are performing.

Tooltip: Indicates the group’s quality level and number of 
critical errors.

<quality level 
legend>

Indicates the quality level that the colored icons in the 
Group Performance table represent. 

Group Name The name of the SiteScope monitor group. Click the 
group name to open the SiteScope Error Details report for 
the specified group’s measurements. For details, see 
"Report Content for SiteScope Error Messages for Group: 
<Group name> Table" below. 

Tooltip: Displays the full group name.

Number of 
Measurements

The number of measurements contained in the specified 
group. 

Number of 
Subgroups

The number of subgroups contained in the specified 
group.

UI Element (A-Z) Description

Measurement Name The measurement instance whose threshold fell within 
the Error level.

Monitor Title The monitor to which the measurement is associated.

Status Error information as reported by SiteScope.

Time The data and time of the measurement instance.
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Overall Performance Report

This report displays a quick snapshot of the performance of the monitored 
infrastructure machines in the selected SiteScope profiles.

This is an example of an Overall Performance report:

To access 1  Select Applications > User Reports > Report Manager.

2  In Report Manager, click New, and select New Custom 
Report. 

3  On the Report Components page, click Add New 
Component.

4  In the Select Component Category pane, select 
System Availability Management > SiteScope Reports.

5  In the Select Component pane, select Overall 
Performance in the Type list.

To access an existing Overall Performance report: Select 
the appropriate custom report in the Report Manager and 
click the View  button.

Important 
information

This report is available only in Custom reports, and is not 
visible on the SAM interface.

See also "Configure Custom Reports Using Report Manager" in 
Reports
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This section includes:

➤ “Report Settings” on page 322

➤ “Report Content” on page 322

Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Report Content

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Element Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.

UI Element Description

<color code legend> Identifies the measurement statuses in the graph, by 
color. 

<pie charts> Represents the performance of each element of the 
infrastructure that SiteScope is monitoring.

Tooltip: Describes the exact number and percentage of 
measurements for each segment of the chart.

Profile The profile that is being monitored.
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Troubleshooting and Limitations 

This section describes troubleshooting and limitations for SAM reports.

Problem 1: 

When generating a Cross-Performance report from the context menu (for 
example, from the MyBSM 360° view by right-clicking a CI monitored by 
SiteScope and selecting Report > SiteScope Cross Performance), automatic 
report rescaling is enabled by default, and there is no option to disable it.

Solution:

To manually configure the scale when generating a Cross-Performance 
report from the context menu, you must reload the configuration as follows:

 1 In the Web browser, type http://<Gateway or Data Processing Server 
name>:8080/jmx-console/index.html to connect to the JMX management 
console.

 2 Enter a user and password for the JMX Management Console.

 3 Under the TOPAZ section, select service=repositories_manager and run 
the cleanRepositoryTypeDBAndCache operation using the following 
parameters: 

➤ repository type: contextMenu

➤ customer id: 0

 4 In BSM, select Admin > Service Health > Repositories > Actions tab to 
reload the configuration. You can also edit the consolidateGraphs 
and disableAutoScale properties from here as required. 
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Problem 2: 

Unable to generate Cross-Performance reports using the Filter by Monitor 
Title option in the Select Measurements dialog box when the monitor name 
contains special characters ('No Data was found' message is displayed). 

Possible solution:

 1 On the BSM Gateway server, make a copy of <Gateway server root 
directory>\Appserver\webapps\site.war\WEB-INF\web.xml for backup 
purposes.

 2 Open the web.xml file in a text editor, and search for the XSSEncoder 
filter name.

 3 Search for excluded_params in this section, and add 
selectedMonitorTypes to the end of the excluded_params values list (note 
that the values must be separated by a comma).

 4 Save the file changes, and restart the MercuryAS process.
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9
Event Log

This chapter includes:

Concepts

➤ Event Log Overview on page 326

Tasks

➤ How to View the Event Log on page 328

➤ How to Customize the Event Log on page 330

➤ How to Set Additional Filters for SiteScope on page 331

Reference

➤ Event Log User Interface on page 332
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Concepts

Event Log Overview

The SAM event log displays events collected by SiteScope (generated alerts, 
or change of status in some element or system in your infrastructure), as 
well as events collected from external applications or software by enterprise 
management systems (EMS) using SiteScope.

Note: The Event Log is available only to BSM users.

The Event Log page displays the logs of events that are sent to the system. 
You can use filters (time frame, data source, severity, and target name) to 
display specific information. If you select the SiteScope data source, you can 
then select additional filters: SiteScope profile, groups, and monitor type.

The event log enables you to diagnose specific issues in real time and to 
create trend reports. For details on creating trend reports, see "Trend 
Reports" in Reports. 

The event log enables you to view event data over time, events that 
happened at a specific time, the details of a specific event, and (where 
possible) the event history.

The type of event that is collected depends on what is defined as an event in 
the external applications or software. Event types can be warnings, alerts, 
user logins, and so on.

When you create the event log, the Event Log page displays the events 
sorted by the time of their occurrence in descending order. It also shows 
columns that are common to all the data sources that can send events. The 
data of the SiteScope data source is filtered according to SiteScope Profile 
permissions (for details, see "Permissions Overview" in Platform 
Administration).
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The event log displays event data that is common to all data sources, 
including:

➤ The severity of the event.

➤ The application or software from which the event is collected.

➤ The time the event occurred.

➤ The hierarchy of the event source.

➤ The name (or the IP address) of the host or device that caused the event.

➤ The status or type of event.

➤ The external system description of the event.

You can filter the events for a specific time frame, data source, severity, and 
target name. For details, see "How to View the Event Log" on page 328.

After the events are filtered, you can drill down to the common data to:

➤ Display data that is specific to the data source where the event occurred. 
For details on this topic, see "Event Details Page" on page 337.

➤ Display the history of a specific event. For details on this topic, see "Event 
History Page" on page 338.
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Tasks

How to View the Event Log

This task describes how to view the logs of events sent to BSM.

This task includes the following steps:

➤ "Prerequisites" on page 328

➤ "Select the Event Log time period" on page 328

➤ "Edit filters in the Active Filters dialog box - optional" on page 329

➤ "Format the Event Log - optional" on page 329

 1 Prerequisites

Make sure that SiteScopes are configured to monitor the infrastructure of 
your BSM system. Select Admin > System Availability Management and 
verify that there are hosted SiteScopes in the <left pane> by hovering over 
the entries, and view the information presented on the resulting tooltip. 

For task details, see "How to Configure the Integration Between SiteScope 
and BSM" on page 74.

 2 Select the Event Log time period

Select Applications > System Availability Management > Event Log to 
display the Event Log page. In the View list, select the time period for 
which you want to gather information to display in the report. 

For task details, see "How to Run Reports" in Reports.
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 3 Edit filters in the Active Filters dialog box - optional

You can click the Active Filters link to edit the filters for the events to be 
displayed on the Events Log page. 

For user interface details, see "Active Filters Dialog Box" on page 336.

 4 Format the Event Log - optional

Click one of the action buttons to print, email, or open a report in Excel 
or PDF format. 

For user interface details, see "Common Report and Page Elements" in 
Reports.
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How to Customize the Event Log

This task describes how to customize the Event Log.

This task includes the following steps:

➤ "Change the maximum number of rows displayed in a page" on page 330

➤ "Configure history view for data sources" on page 330

 1 Change the maximum number of rows displayed in a page

When there are too many events to display in one page of a table, you 
may want to modify the number of rows permitted on a page. 

To modify the setting, select Admin > Platform > Setup and Maintenance 
> Infrastructure Settings.

➤ Select Applications. 

➤ Select End User/System Availability Management.

➤ In the Event Reports table, locate Max Table Rows. Change the value 
to the required number of rows per page.

 2 Configure history view for data sources

You can enable the History button for selected data sources by configuring 
the relevant parameters in the Infrastructure Settings. To modify the 
setting, select Admin > Platform > Setup and Maintenance > 
Infrastructure Settings.

➤ Select Applications. 

➤ Select End User/System Availability Management.

➤ In the End User/System Availability Management - Data table, locate 
Event Log Report Data Sources History. In the Value box, set the 
property value by adding the data source names for which you want to 
enable the History  button. Separate multiple data source names 
with commas.

The change takes effect after restart. 
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How to Set Additional Filters for SiteScope

If you select a SiteScope data source in the active filter, an additional filter is 
automatically provided to filter the data by SiteScope profile, group, and 
monitor type. 

To work with additional filters for SiteScope data sources:

 1 Click SiteScope Filters, to open the SiteScope Filter page.

 2 Select the type of monitor in the Monitor Type list. The default is All 
Monitor Types.

 3 Select the SiteScope profile in the Profile list. The default is All Profiles. To 
view events of interest regarding the profile or group permissions, select 
one of the profiles in the Profile list. The list of groups allowed for the 
selected profile is displayed. For details on profile or group permissions, 
see "Permissions Overview" in Platform Administration.

Note: If you select All Profiles, your profile or group permissions are not 
applied to the displayed events.

 4 If available, select the required group in the group tree. Select All Groups 
if you want to select all the groups in the tree. When a tree CI changes its 
status (from selected to unselected or from unselected to selected) the 
status of the whole sub-tree changes. 
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Reference

Event Log User Interface 

This section includes:

 ➤ Event Log Page on page 332

 ➤ Active Filters Dialog Box on page 336

 ➤ Event Details Page on page 337

 ➤ Event History Page on page 338

Event Log Page

This page displays the event data common to all event data sources. The 
Event Log displays events collected from SiteScope, as well as events 
collected from external applications or software by enterprise management 
systems (EMS) using SiteScope.

This is an example of the Event Log:
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Report Settings

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Report Content

User interface elements are described below:

To access Select Applications > System Availability Management > 
Event Log

Important 
information

If the number of events that occur during the specified 
time frame is larger than the maximum number of events 
that can be displayed in the report, a message is displayed 
indicating this. To reduce the number of events, select a 
more specific time range. For example, to see events for 
the past week, select the individual days of the week.

UI Element (A-Z) Description

<Common report 
settings>

For user interface details, see "Common Report and Page 
Elements" in Reports.

Active Filters Enables you to set filters on event log components, to 
pinpoint the specific events you most want to view. For 
details on Active Filters, see "Active Filters Dialog Box" on 
page 336.

Note: You can click a value in a specific row to add that 
value to the active filter.

UI Element (A-Z) Description

Event Details. Opens the Event Details page enabling you 
to view additional data for the event. For details, see 
"Event Details Page" on page 337.

Event History. Opens the Event History page enabling 
you to view details about the event history data. For 
details, see "Event History Page" on page 338.
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Description The event description. If the description is very long, the 
value is shortened and the tooltip displays the full 
hierarchy.

Event Source The application or software from which the event is 
collected. For a list of possible event sources, see "Event 
Sources" on page 335.

Hierarchy The hierarchy description of the event source. It can 
include the path to where the event occurred in the area, 
sub area, or instance and/or the event depending on the 
application or software from which the event is collected. 
The hierarchy can have two to four branches, depending 
on the data source. If the hierarchy is very long, this field 
displays the shortened string and the tooltip displays the 
complete hierarchy.

Severity A colored icon indicating the severity level of the event. 

➤  Unknown

➤  Informational

➤  Warning

➤  Minor

➤  Major

➤  Critical

Tooltip: Displays the severity of the event.

Status The status or type of the event. If the hierarchy is very 
long, the value is shortened and the tooltip displays the 
full hierarchy.

Target Name The name or the IP address of the host or device that 
caused the event.

Time The time when the event occurred. By default, the data 
sorted in this column is in descending order.

UI Element (A-Z) Description
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Event Sources

Following are the applications and software from which events can be 
collected, depending on the external systems that sent the events to BSM: 

➤ HP Operations Manager

➤ Remedy ARs

➤ SitescopeAlert

➤ SitescopeAlertStatusChange

➤ Tivoli TEC

➤ BMC Patrol

➤ CA Unicenter

➤ HP SIM

➤ Compaq Insight Manager

➤ Whatsup

➤ Compaq Insight Manager
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Active Filters Dialog Box

This dialog box enables you to set filters on specific event log fields, to 
pinpoint the events you most want to view. 

The Active Filters dialog box includes the following filter tabs and areas: 

To access Click the Active Filters link in on the Event Log Page. 

UI Element (A-Z) Description

Event Source Enables you to filter the data displayed in the Event Log 
according to specific event sources.

The Event Source tab includes the following options: 

➤ All. Click to view all event sources in the Event Log 
page. 

➤ <Event Source Name>. Click to view only the specified 
event source in the Event Log page.

Severity Enables you to filter the data displayed in the Event Log 
according to event severity level.

Target Enables you to filter the data displayed in the Event Log 
according to target location. 

Note: To view all targets, enter an asterisk ("*") in the 
Targets field. 
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Event Details Page

This page displays detailed information about the specified event as well as 
the fields and the field values from the event data.

User interface elements are described below:

To access Click the Event Details  button on the Event Log page 
next to the event from which you want to retrieve 
information. 

Important 
information

The type of information provided depends on the data 
source. Not all elements are displayed for all events.

See also “Event Log Page” on page 332

UI Element (A-Z) Description

Acknowledged By The operator who acknowledged the event.

Collector Host IP The IP address of the machine that collected the data.

Collector Host Name The name of the machine that collected the data.

Description A description of the event.

Event Source The application or software from which this event is 
collected.

Group The additional logical level of event hierarchy.

Original Severity The original severity of the event.

Severity The severity of the event.

Status The event status or type. 

Target Name The name of the host or device that caused the event.

Time The time of the event.

Value Any numeric values that are sent with the event. 
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Event History Page

This page displays detailed information about the specified event for 
different time periods. You use the event history report to receive a historical 
view of the event.

To access Click the Event History  button on the Event Log 
page.

Important 
information

The elements displayed in the Event History page are 
identical to those displayed on the Event Log page. 
However, you cannot view the event details report from 
the Event History page, as the Event Details  button is 
not displayed. 

See also “Event Log Page” on page 332
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