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About this Guide
Welcome to the HP Systinet Plug-In for Eclipse Guide. This guide explains how to use Systinet Plug-In
for Eclipse with HP Systinet.

This guide contains the following chapters and appendices:

• Chapter 1, Systinet Plug-In for Eclipse

• Chapter 2, Getting Started

• Chapter 3, Exploring the Repository

• Chapter 4, Modifying Resources

• Chapter 5, Validating Resources

• Chapter 6, Generating Service Clients

• Chapter 7, Generating Service Skeletons

• Chapter 8, Requesting Consumption of HP Systinet Artifacts

• Chapter 9, Requesting Lifecycle Approval

• Appendix A, Dialog Boxes

• Appendix B, Preferences

• Appendix C, Configuring Systinet Plug-In for Eclipse

• Appendix D, Eclipse Plug-in Requirements
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Document Conventions

This document uses the following typographical conventions:

run.bat make Script name or other executable command plus mandatory arguments.

[--help] Command-line option.

either | or Choice of arguments.

replace_value Command-line argument that should be replaced with an actual value.

{arg1 | arg2} Choice between two command-line arguments where one or the other is
mandatory.

java -jar

hpsystinet.jar

User input.

C:\System.ini File names, directory names, paths, and package names.

a.append(b); Program source code.

server.Version Inline Java class name.

getVersion() Inline Java method name.

Shift+N Combination of keystrokes.

Service View Label, word, or phrase in a GUI window, often clickable.

OK Button in a user interface.

New>Service Menu option.
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Documentation Updates

This guide's title page contains the following identifying information:

• Software version number, which indicates the software version

• Document release date, which changes each time the document is updated

• Software release date, which indicates the release date of this version of the software

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign-in. To register for an HP Passport ID, go
to:

http://h20229.www2.hp.com/passport-registration.html

Or click the New users - please register link on the HP Passport logon page.

You will also receive updated or new editions if you subscribe to the appropriate product support service.
For details, contact your HP sales representative.

http://h20230.www2.hp.com/selfsolve/manuals
http://h20229.www2.hp.com/passport-registration.html
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Support

You can visit the HP Software Support Web site at:

http://www.hp.com/go/hpsoftwaresupport

HP Software Support Online provides customer self-solve capabilities. It provides a fast and efficient
way to access interactive technical support tools needed to manage your business. As a valued support
customer, you can benefit by using the HP Software Support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require
a support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

http://www.hp.com/go/hpsoftwaresupport
http://h20230.www2.hp.com/new_access_levels.jsp
http://h20229.www2.hp.com/passport-registration.html
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1 Systinet Plug-In for Eclipse

HP Systinet enables your organization to manage the growth and development of your service
infrastructure. HP Systinet Plug-In for Eclipse bridges the gap between your development environment
and HP Systinet.

This chapter introduces Systinet Plug-In for Eclipse in the following sections:

• Overview on page 9

• Usecases on page 10

Overview

HP Systinet Plug-In for Eclipse is a set of features enabling you to integrate HP Systinet with your IDE.

Systinet Plug-In for Eclipse contains the following features:

• Search

Search the HP Systinet repository to find the service definitions you require.

For details, see Chapter 3, Exploring the Repository.

• Modify

Download resources from HP Systinet, modify them in your IDE, and then upload them back to HP
Systinet.

For details, see Chapter 4, Modifying Resources.

• Validate

Validate resources in your IDE against policies in the HP Systinet repository.
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For details, see Chapter 5, Validating Resources.

• Generate

Generate service clients and skeletons from repository resources.

For details, see Chapter 6, Generating Service Clients and Chapter 7, Generating Service Skeletons.

Usecases

Systinet Plug-In for Eclipse is designed to assist in the development of services for the following users:

• Service Architects

• Download resources.

Import service definition files from HP Systinet.

For details, see Downloading HP Systinet Resources on page 23.

• Edit resources.

Edit service definitions using the standard functionality of your IDE.

• Validate resources before publication.

Using policies imported from HP Systinet, validate your service definitions to ensure they meet your
policy requirements.

For details, see Chapter 5, Validating Resources.

• Upload resources.

Export your service definition files to HP Systinet.

For details, see Uploading HP Systinet Resources on page 24.

• Service Consumers

• Locate the services you want to consume.
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Repository Search enables you to identify services you want to consume. You can limit the search to
services that are consumable, or to a particular lifecycle stage (for example, Production).

For details, see Searching the Repository on page 17.

• Generate service clients for services you want to consume.

Using the service definitions located in the search, generate a service client from the service
definition to assist the development of your consuming service.

For details, see Chapter 6, Generating Service Clients.

• Service Providers

• Locate the service definitions you want to develop.

Repository Search enables you to identify services you want to develop. You can limit the search to
services at particular lifecycle stages (for example, Initial or Development).

For details, see Searching the Repository on page 17.

• Validate your local resources against policies from the HP Systinet repository.

Using policies imported from HP Systinet, validate your resources to ensure they meet your policy
requirements.

For details, see Chapter 5, Validating Resources.

• Generate service skeletons for services you want to develop.

Using the service definitions located in the search, generate a service skeleton from the service
definition to assist the development of your service.

For details, see Chapter 7, Generating Service Skeletons.
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2 Getting Started

Systinet Plug-In for Eclipse works in conjunction with your existing development platform.

This chapter contains the following sections:

• Installing Systinet Plug-In for Eclipse on page 13

• Setting Up 2-way SSL on page 16

Installing Systinet Plug-In for Eclipse

HP Systinet Plug-In for Eclipse is a plug-in for Eclipse distributed as the following archive file:

hp-systinet-eclipse-plugin-4.03.zip

Table 1. System Requirements

Operating System Java JDK IDE

Eclipse 3.2.x

Eclipse 3.3.x

Eclipse 3.4.x

Windows XP Sun JDK 5.0

Eclipse 3.5.x

Eclipse 3.3.x

Eclipse 3.4.x

Windows Vista Sun JDK 5.0

Eclipse 3.5.x

Eclipse 3.2.x

Eclipse 3.3.x

Eclipse 3.4.x

RHEL 5.2 Sun JDK 5.0

Eclipse 3.5.x



14

For supported platforms and known issues, see readme.txt alongside the archive.

The following versions of Eclipse can be used with Systinet Plug-In for Eclipse without any other plug-in
dependencies:

• Europa for Java EE Developers (eclipse-jee-europa-winter-win32.zip)

• Ganymede for Java EE Developers (eclipse-jee-ganymede-SR2-win32.zip)

• Galileo for Java EE Developers (eclipse-jee-galileo-win32.zip)

If you use another version of Eclipse, you may require a number of plug-ins. For details, see Appendix D,
Eclipse Plug-in Requirements.

To install Systinet Plug-In for Eclipse to Eclipse:

1 In your current Eclipse SDK (3.2 or later), use the software updates feature to install Systinet Plug-
In for Eclipse.

Select Help>Software Updates>Find and Install....

The Install/Update dialog opens.

2 In the Install/Update dialog, select Search for new features to install, and click Next.

The Install – Update Sites to Visit dialog opens.

3 In the Update Sites to Visit dialog, click New Archived Site.

The Select Local Archive Site dialog opens.

4 Locate and select hp-systinet-eclipse-plugin-4.03.zip, and then click Open.

The Edit Local Site dialog opens.

5 In the Edit Local Site dialog, if required, rename the local archive name, and click OK.

6 In the Install – Update Sites to Visit dialog, select the new local archive, and then click Finish.
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The Updates – Search Results dialog opens.

7 Select the archive, or expand the archive and select individual components, and click Next.

Systinet Plug-In for Eclipse consists of the following components:

• Search and Validate

The search and validation features of Systinet Plug-In for Eclipse.

• WTP Integration

The integration points with the WTP plug-in.

The Install – Feature License dialog opens.

8 In the Feature License dialog, select I accept the terms in the license agreements, and click Next.

The Install – Installation dialog opens.

9 In the Installation dialog, if required, change the installation location, and then click Finish.

To start Systinet Plug-In for Eclipse

• Execute ECLIPSE_HOME/eclipse.exe.

The first time you start Systinet Plug-In for Eclipse, you are prompted for the connection URL and
credentials for the HP Systinet server and the domain to use.

Do one of the following:

• Set a connection URL and credentials and optionally select to save them, and then click OK.

The HP Systinet server must be running.

• Click Skip to set them later. For details, see Setting the Server on page 57.
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Systinet Plug-In for Eclipse uses the Eclipse API to store passwords. Saved passwords are
stored in a file that is difficult but not impossible for an intruder to read.

Setting Up 2-way SSL

You can set up 2-way SSL communication between Systinet Plug-In for Eclipse and HP Systinet using
the client certificate for your SSL environment.

To enable 2-way SSL:

1 Close Systinet Plug-In for Eclipse

2 Open ECLIPSE_HOME/eclipse.ini with a text editor.

3 Add the following properties using your certificate values:

• -Djavax.net.ssl.keyStore=<user_keystore>

• -Djavax.net.ssl.keyStorePassword=<keystore_pass>

• -Djavax.net.ssl.keyStoreType=<keystore_format>

• -Djavax.net.ssl.trustStore=<user_truststore>

• -Djavax.net.ssl.trustStorePassword=<truststore_pass>

• -Djavax.net.ssl.trustStoreType=<truststore_format>

4 Restart Eclipse using ECLIPSE_HOME/eclipsec.exe.
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3 Exploring the Repository

Systinet Plug-In for Eclipse enables you to search and examine data in the HP Systinet repository.

These features are described in the following sections:

• Searching the Repository on page 17

Locate specific artifacts using lifecycle, consumption, and property criteria.

• Search Results on page 18

View artifacts matching your search criteria and their related artifacts.

• Artifact Detail View on page 19

Examine individual artifacts in detail.

• Viewing Artifacts in HP Systinet on page 20

Open the HP Systinet Artifact Details page from Systinet Plug-In for Eclipse.

• Using HP Systinet Navigator on page 21

Open an instance of HP Systinet in Systinet Plug-In for Eclipse to view selected artifacts using the
Graphical Navigator feature.

Searching the Repository

HP Systinet Plug-In for Eclipse includes a Repository Search feature, enabling you to explore the content
of HP Systinet.

Search explores the domain set in preferences and not the entire Catalog. For details, see
Setting the Domain on page 58
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To search the repository:

1 Do one of the following:

• From the menu, select Search>Repository.

• Use the keyboard shortcut, Ctrl+Alt+Y.

The Search dialog opens displaying the Repository Search tab.

2 In the Scope section, select an artifact type to search, and if required, a specific lifecycle stage and
domain.

The Properties section refreshes showing specific details depending on the artifact type.

Generating service clients and skeletons uses WSDL definitions to create code stubs.
To find the WSDL you need, search for SOAP Services or Operations, as these
artifacts contain lifecycle and contract information. The functionality for generating
code stubs is available on search results for SOAP Services and Operations and utilises
the WSDLs associated with them.

3 Enter your search parameters. The parameters vary depending on the artifact type.

For parameter details, see the "SDM Documentation" in HP Systinet.

4 To display the parent artifacts search result artifacts depend on, select Show Parent Artifacts

5 Click Search to execute the search.

Systinet Plug-In for Eclipse displays the results of the search in the Repository Search Result tab.
For details, see Search Results on page 18.

Search Results

Systinet Plug-In for Eclipse displays the results of a repository search in the Repository Search Results
tab.

To search the repository, see Searching the Repository on page 17.
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The results show a tree of artifacts for each artifact matching the search criteria, as shown in Figure 1,
“Repository Search Results View”:

Figure 1. Repository Search Results View

The tree for each matching artifact contains any related child artifacts. If you select Show Parent
Artifacts in your search, the tree also includes related parent artifacts.

Double-click an artifact name in the Repository Search Results tab to view its details in an artifact details
tab. The tab name is the name of the artifact. For details, see Artifact Detail View on page 19.

For SOAP Services and Operation artifacts, the search results provide code generation functionality.
Right-click the resource and select Generate Service Client or Generate Service Skeleton. For details,
see Chapter 6, Generating Service Clients or Chapter 7, Generating Service Skeletons.

To download any associated service resources, right-click a result entry, and select Save As. For details,
see Downloading HP Systinet Resources on page 23.

The hierarchy of artifact types and the properties displayed for each artifact type are defined
in the configuration you can customize.

For details, see Appendix C, Configuring Systinet Plug-In for Eclipse.

Artifact Detail View

Systinet Plug-In for Eclipse enables you to view the details for a particular artifact in its own detail view.
The content of this view is similar to the Artifact Detail View in the Tools tab in HP Systinet.
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In Eclipse, this kind of view is normally called an Editor. However, Systinet Plug-In for
Eclipse does not provide editing features in these Artifact Views.

The artifact details vary depending on the artifact type and your customization and configuration.

For details about customizing the detail views, see Appendix C, Configuring Systinet Plug-In for Eclipse.

The Artifact Detail view contains the following segments depending on the artifact type:

• General

Displays a description, the owner of the artifact, and a URL to the XML representation of the artifact.

• Details

Displays a set of properties for the artifact. These properties vary depending on the artifact type.

• Data

Displays a link to the attached data in the repository for artifacts with attached data content. Click the
link to view the content of the attached data.

• Relationships

Displays the set of related artifacts, indicating the type of relationship, the related artifact, and the
direction of the relationship.

Double-click an artifact name to open its detail view.

Viewing Artifacts in HP Systinet

Systinet Plug-In for Visual Studio enables you to directly open the Artifact Details page in the HP
Systinet UI.

To View Artifact Details in HP Systinet:

• Do one of the following:

• In the Project Explorer view, open the context menu for the Catalog artifact you want to view in
HP Systinet, and select HP Systinet>Open in HP Systinet.
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• In the Synchronization view, open the context menu for the Catalog artifact you want to view in
HP Systinet, and select Open in HP Systinet.

A HP Systinet view opens showing the Artifact Details page for the selected artifact.

You may need to log in using your HP Systinet credentials.

For more details about the Artifact Details page, see the "Artifact Details Page" section in the HP
Systinet User Guide.

Using HP Systinet Navigator

HP Systinet includes a Graphical Navigator which provides a visual representation representation of the
content of the Catalog. Instead of focusing on the details of single artifacts, it helps to understand the
structure and dependencies of applications, services, and processes in your SOA Catalog. As its name
suggests, it is not only an alternative view but also a navigator that enables the exploration, browsing, and
traversing of your Catalog content in a graphical way.

Systinet Plug-In for Eclipse enables you to view Catalog content using the Navigator feature of HP
Systinet.

To view Catalog content in Navigator:

• Do one of the following:

• In the Project Explorer view, open the context menu for the Catalog artifact you want to view in
Navigator, and select HP Systinet>View Graphical Navigator or HP Systinet>View Impact
Analysis.

• In the Search Results view, open the context menu for the Catalog artifact you want to view in
Navigator, and select View Graphical Navigator or View Impact Analysis.

A HP Systinet view opens in the Navigator showing the graph for the selected artifact. If you
selected View Impact Analysis the graph highlights the related artifacts that have a dependency on
the selected artifact and could be affected by a change to that artifact.



22

You may need to log in using your HP Systinet credentials.

For more details about the Navigator and its use, see the "Catalog Visualization" chapter in the HP
Systinet User Guide.
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4 Modifying Resources

Systinet Plug-In for Eclipse enables you to download resources from HP Systinet, modify them, and then
upload them back to HP Systinet.

These features are described in the following sections:

• Downloading HP Systinet Resources on page 23

Download service definitions from HP Systinet.

• Uploading HP Systinet Resources on page 24

Upload service definitions to HP Systinet.

• Synchronizing Resources on page 27

Synchronize local resources with their HP Systinet versions.

• Deleting HP Systinet Resources on page 27

Delete resources from the HP Systinet repository.

Downloading HP Systinet Resources

Systinet Plug-In for Eclipse enables you to download the service definitions associated with artifacts
from HP Systinet.

Systinet Plug-In for Eclipse supports download for the following file types:

• WSDL

• BPEL

• XSD
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• DTD

• SCA

To download service definitions from HP Systinet:

1 Perform a repository search to locate the service you want to download the definitions for.

For details, see Searching the Repository on page 17.

2 In the Repository Search Results view, right-click a search result, and select Save As.

The Download Document from HP Systinet dialog opens.

3 In the Download Document from HP Systinet dialog:

Select Resolve Dependencies to resolve any dependencies in the service definition files and
download all referenced files as well.

Select Open Resource after Downloading to open an editor view of the downloaded resource after
download.

Select a location in your project to store the downloaded resources, and then click Finish.

Systinet Plug-In for Eclipse downloads the relevant service definition files and copies them to the
selected location. The structure of the HP Systinet publishing location space is preserved.

For details about the Publishing Location space, see "Publishing Locations Workspace" in the HP
Systinet Developer Guide.

Uploading HP Systinet Resources

Systinet Plug-In for Eclipse enables you to upload service definition documents directly to HP Systinet.

Systinet Plug-In for Eclipse supports upload for the following file types:

• WSDL

• BPEL

• XSD
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• DTD

• SCA

Systinet Plug-In for Eclipse auto-detects referenced documents for upload in SCA documents by QName
according to the following rules:

From To Element Tag

SCA Composite SCA Composite <include name="{QNAME}" />

SCA Composite SCA Composite <implementation.composite name="{QNAME}" />

SCA Composite SCA Constraining
Type

<composite constrainingType="{QNAME}" />

SCA Composite SCA Constraining
Type

<component constrainingType="{QNAME}" />

SCA Composite BPEL File <implementation.bpel process="{QNAME}"/>

SCA Component
Type

SCA Constraining
Type

<componentType constrainingType="{QNAME}" />

SCA Contribution SCA Composite <deployable composite="{QNAME}" />

Systinet Plug-In for Eclipse also resolves referenced local WSDL files in SCA files for upload.

To upload service definitions to HP Systinet:

1 In the Project Explorer, right-click the resource or folder of resources you want to upload, and select
HP Systinet > Upload to open the Upload Documents dialog box.

This option is only available if you have appropriate permissions in HP Systinet.

2 Select resources to upload, and then click Next.

3 Select the publishing location folder, or input a new one, and then click Next.

4 Select from the following Advanced Options:
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Parameter Definition

BPEL Decomposition Select whether to create Business Process artifacts defined by a BPEL
document.

WSDL Decomposition Select a WSDL processing level from the following options:

• Services

Process any WSDLs, create all defined content and create business
services to associate with any newly created implementations.

• Implementations

Process any WSDLs and create all defined content. Business services
are not created.

• None

Publish any WSDLs as artifacts with attached data content. The WSDL
files are not processed.

Service Type Select a service categorization for created service artifacts.

Remove
Unsynchronized

If a WSDL is republished the artifacts it references may change and
previously created artifacts may no longer be required. Select artifact
types to remove the relationships with these obsolete referenced artifacts.

Click Next.

HP Systinet processes the content for upload and returns an Upload Overview to Systinet Plug-In for
Eclipse.

If your version of HP Systinet does not support the new advanced options, Systinet
Plug-In offers a reduced set of the listed options.

5 Review the overview and click Finish to complete the upload and create the relevant artifacts, or
Cancel to abort the upload.
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The artifacts upload to the domain selected in preferences. For details, see Setting the
Domain on page 58.

Synchronizing Resources

After downloading resources from HP Systinet, you may want to synchronize them with HP Systinet.

To synchronize a local resource with HP Systinet:

1 In the Project Explorer, right-click the resource you want to synchronize and select HP
Systinet>Synchronize with Server.

The Synchronization view opens showing any files that differ.

2 Optionally, right-click an item that differs from the server version, and select Update to import the
latest version from HP Systinet.

You can configure Systinet Plug-In to perform automatic synchronization. For details, see Setting
Synchronization on page 61.

Deleting HP Systinet Resources

Systinet Plug-In for Eclipse enables you to delete resources stored in the HP Systinet repository.

To delete HP Systinet resources:

1 In the Project Explorer, right-click the resource you want to delete, and select HP Systinet>Delete
from Server.

The HP Systinet UI opens requesting authentication.

2 Enter your credentials.

The detail view of the artifact you want to delete opens.

3 Use HP Systinet functionality to delete the artifact. For details, see the HP Systinet User Guide.
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5 Validating Resources

Systinet Plug-In for Eclipse enables you to validate local resources against policies.

This chapter contains the following sections:

• Setting Up Validation on page 29

Explains the process of importing and updating policies from the Policy Manager.

• Ad Hoc Validation on page 33

Explains how to run unscheduled validation and produce reports.

• Automatic Validation on page 38

Explains how to set up automatic validation.

Setting Up Validation

Systinet Plug-In for Eclipse contains a default set of policies. You can add or delete policies, and update
your local policies against versions from an HP Systinet server. Systinet Plug-In for Eclipse also includes
the default HP Systinet Policy Manager extension, which contains default Policy Manager validation
handlers.

Validation is introduced in the following sections:

• Setting Up Policies on page 30

• Importing Policies on page 31

• Removing Policies on page 32

• Updating Policies on page 32

• Customizing Validation Handlers on page 32
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Setting Up Policies

You can add, delete, or update policies in the Systinet Plug-In for Eclipse Policies page.

To set up policies:

1 From the menu, select Window>Preferences.

The Preferences dialog box opens.

2 In the tree view of the Preferences dialog box, expand HP Systinet>Policy Validation>Policies.

The Policies page opens, as shown in Figure 2, “Policies Page”.

Figure 2. Policies Page
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In the Policies page, do any of the following:

• Import an archive or folder.

For details, see Importing Policies on page 31.

• Remove a policy

For details, see Removing Policies on page 32.

• Update local policies.

For details, see Updating Policies on page 32.

Importing Policies

You can import policies from an archive or folder from a designated HP Systinet server.

To import an archive or folder from an HP Systinet server:

1 In the Policies page, do one of the following:

• Click Import Archive to open the Select an Archive to Import dialog box, and then go to Step 2.

• Click Import Folder to open the Select a Folder to Import dialog box, and then go to Step 3.

2 Enter the required parameters and browse for the archive you need, and then click Open.

The selected archive is imported to the Policies page.

3 Browse for the folder you need, and then click OK.

The selected folder is imported to the Policies page.

The Import Archive and Import Folder buttons load policies, assertions, and remote server
information from the client distribution, created during the installation process in the folder
SOA_HOME.

The import of the client distribution will fail if the provided folder or archive does not
follow the structure of the HP Systinet 4.03 client distribution, which must include the bin,
conf, data, extensions, and lib folders.
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Removing Policies

To remove a policy:

• Highlight the policy in the Policies page, and then click Delete.

Updating Policies

You can use Systinet Plug-In for Eclipse to update local policies against policies on an HP Systinet
server.

To update policies:

1 Make sure the HP Systinet server is running.

2 Click Update.

The local version of the policy is updated to reflect the version on the HP Systinet server.

Customizing Validation Handlers

Systinet Plug-In for Eclipse includes a set of validation handlers, contained in the standard Policy
Manager extension. Custom validation handlers can be included in the Systinet Plug-In for Eclipse by
adding the appropriate extensions.

To add extensions to Systinet Plug-In for Eclipse:

1 From the menu, select Window>Preferences.

The Preferences dialog box opens.

2 In the tree view of the Preferences dialog box, expand HP Systinet>Policy Validation>PM
Extensions.

3 Click Add.

The Select an Extension dialog box opens.

4 Browse for the .jar file you require, and then click Open.

The extension is now visible in the PM Extensions page.
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You must restart Systinet Plug-In for Eclipse for your changes to take effect.

Ad Hoc Validation

Ad hoc validation is the unscheduled validation of documents against policies.

Ad hoc validation is described the following sections:

• Running Ad Hoc Validation on page 33

• Viewing Ad Hoc Validation Results on page 34

• Revalidating a Document on page 36

• Exporting Reports on page 37

• Setting Report Style on page 37

Running Ad Hoc Validation

To run ad hoc validation on a single resource:

1 Right-click a document in Project Explorer to open its context menu, and then scroll over Check
Policy Compliance.

A list of available policies is displayed.

2 Select the policy you want to validate the document against.

The validation runs and the result is shown in the Validation Result tab.

For details, see Viewing Ad Hoc Validation Results on page 34.

To run ad hoc validation using multiple resources or policies:

1 Right-click a document in Project Explorer to open its context menu, and then scroll over Check
Policy Compliance.

A list of available policies is displayed.
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2 Select More Validation Options.

The Edit Configuration and Launch dialog box opens, as shown in Edit Configuration and Launch
on page 52.

3 To add documents, do one of the following:

• Click Add File to browse and select documents from your Eclipse project.

• Click Add External File to browse and select documents from your file system.

• Click Add External Folder to browse and select all documents in a folder in your file system.

• Click Add URL to enter the endpoint URL of a remote document.

4 In the Technical Policies field, click Add to select from a list of available policies to use in the
validation.

5 Click Run.

The validation runs and the result is shown in the Validation Result tab.

For details, see Viewing Ad Hoc Validation Results on page 34.

Viewing Ad Hoc Validation Results

When validation completes, the Validation Result view displays the results. For each result, you can view
a detailed HTML report. You can also view a summary report for all validation results.

The default report style is similar to that of Policy Manager validation reports. For information about
setting report styles, see Setting Report Style on page 37.

To view a validation report:

• Right-click a validation result in the Validation Result tab to open its context menu, and then select
 View Detail.

An HTML report opens, as shown in Figure 3, “Validation Report”.
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Figure 3. Validation Report

If you have more than one validation result, you can view a summary report of all the validation results.

To view a summary report, click the  Summary Report button on the Validation Result tab.

The Summary Report view opens, as shown in Figure 4, “Summary Report”.
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Figure 4. Summary Report

To view the detailed report of a document in the summary, click the report hyper link in the Details
column.

You can set a resource in the results view to be automatically validated. Right-click the resource to open
its context menu, and select Set as Automatic Validation. The resource is re-validated against the set
of automatic policies for the project and added to the custom list of project resources to be validated. For
details, see Setting Up Automatic Validation on page 38.

Revalidating a Document

If recent changes have been made to a document, you can revalidate that document.

To revalidate a document:

•
Select a result in the Validation Result tab, and click  Revalidate.

The document is revalidated against the selected policies.
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Exporting Reports

You can export the report to your file system.

To export a validation report:

•
Select a result in the Validation Result tab, and then click  Export Reports.

• Browse for the location to which you want to save the report, and click OK.

Both detail and summary reports are saved.

Setting Report Style

Included with Systinet Plug-In for Eclipse is the Policy Manager detail report stylesheet. If you want to
change the stylesheeet, you can select from a pure text style or XML format.

To change the style of ad hoc validation reports:

1 From the menu, select Window>Preferences.

The Preferences dialog box opens.

2 In the tree view of the Preferences dialog box, expand HP Systinet>Policy Validation.

The Policy Validation page opens. For details, see Policy Validation on page 54.

3 In the Validation Result Format pane, select one of the following options:

• Text Format, then go to Step 5.

• XML Format, then go to Step 4.

4 In the Stylesheet pane, select one of the following options:

• Associate with default stylesheet.

• Custom stylesheet, then browse for the stylesheet you need.
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5 Click OK to produce the report in the selected format.

Automatic Validation

Systinet Plug-In for Eclipse enables the automatic validation of documents while you work on them.

After you set up automatic validation, you can see annotations to your document that change in real time.

Automatic validation is described in the following sections:

• Setting Up Automatic Validation on page 38

• Disabling Spell Checker on page 41

• Assertion Details on page 41

Setting Up Automatic Validation

To enable automatic validation, you must set it up for a project.

To enable automatic validation:

1 Do one of the following:

• Right-click the project in Project Explorer to open its context menu, and select Configure
Automatic Validation>Set Project to be Automatically Validated.

• Right-click the project in Project Explorer to open its context menu, and select Properties.

In the tree menu, select Automatic Validation.

The Properties for [Project Name] dialog box opens showing thw Automatic Validation options. For
details, see Properties for [Project Name] on page 55.

2 Select Set Project to be Automatically Validated if it is not already set.

3 In the List of Policies pane, click Add and select the policies you need. Click OK.

4 In the List of Resources pane, select one of the following:
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• Default (Entire Project), then go to Step 6.

• Custom, then go to Step 5.

5 Select any of the following:

• Add

To add a folder from your project.

• Exclude

To exclude individual files from the selected folder.

• Remove

To remove the folder from the list.

6 In the Filtered By pane, do any of the following:

• Click Add to add a file extension.

• Click Remove to remove a file extension from the list.

7 Click OK to confirm automatic validation settings.

The validation runs and the results are displayed in the Automatic Validation Results view, as shown in
Figure 5, “Automatic Validation Results”.
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Figure 5. Automatic Validation Results

After automatic validation has been set up, you have the option to include or exclude documents for
validation.

To include or exclude documents:

1 Right-click the document in Project Explorer to open its context menu.
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2 Select Configure Automatic Validation, and do one of the following:

• Select Exclude from Validation Path to remove the document from the validation process.

• Select Include in Validation Path to add the document to the validation process.

You can also add resources to the custom list from the Validation Results view. For
details, see Viewing Ad Hoc Validation Results on page 34.

Disabling Spell Checker

In Eclipse 3.2 (or higher), the spell checker annotates documents that are open in the main view. The
spell checker annotations can obscure Systinet Plug-In for Eclipse automatic validation annotations. You
should disable the Eclipse spell checker.

To disable the Eclipse spell checker:

1 From the menu, select Window>Preferences.

The Preferences dialog box opens.

2 In the tree menu, expand General>Editors>Text Editors>Spelling.

3 Deselect Enable spell checking and click OK.

Assertion Details

You can view additional details about assertions that were violated. Systinet Plug-In for Eclipse can
create a special tooltip describing the assertion, with HTML links to assertion description web pages.

To view an assertion description:

• Right-click one of the errors listed in the Problems view to open its context menu, and then click
View Assertion Description.

A tooltip opens with the assertion description and a link to available online resources about the
assertion.
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6 Generating Service Clients

Systinet Plug-In integrates with existing Eclipse Web Tools Platform (WTP) functionality, enabling you
to create a client stub from resources in the repository.

To generate a service client stub:

1 Perform a repository search to locate the resource you want to use for client generation.

For details, see Searching the Repository on page 17.

For consumer use cases search for Consumable services at the Production lifecycle
stage.

2 In the Repository Search Results view, right-click the Operation or SOAP Service to use for client
generation, and select Generate Service Client.

If the Environment preference is set to Always Ask, you are prompted to select from the available
endpoint options, otherwise any endpoint uses the default setting. For details, see Setting the
Environment on page 59.

Generating a client uses the WSDL associated with SOAP Service or Operation.

The Web Service Client dialog opens.
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3 Use the Web Service Client dialog to select your project and environment settings.

For details, see the WTP documentation at the following location:

http://help.eclipse.org/help33/topic/org.eclipse.jst.ws.axis.ui.doc.user/tasks/tsampappa.html

The WTP plug-in looks for a Dynamic Web Project and warns you if there is no such
project available. It is possible to ignore the warning and select a plain Java project
instead.

Click Client Project and select the project you require.

The WTP plug-in uses the provided WSDL to generate source code stubs for the service client.

Use the Package Explorer to access the generated code.

http://help.eclipse.org/help33/topic/org.eclipse.jst.ws.axis.ui.doc.user/tasks/tsampappa.html


45

7 Generating Service Skeletons

Systinet Plug-In for Eclipse integrates with existing Eclipse Web Tools Platform (WTP) functionality,
enabling you to create a skeleton stub from resources in the repository.

To generate a service skeleton stub:

1 Perform a repository search to locate the resource you want to use for skeleton generation.

For details, see Searching the Repository on page 17.

For provider use cases search for services at early lifecycle stages, such as Initial or
Development.

2 In the Repository Search Results view, right-click the SOAP Service or Operation to use for client
generation, and select Generate Service Skeleton.

Generating a skeleton against a SOAP Service or Operation uses the WSDL associated
with it.

The Web Service dialog opens.
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3 Use the Web Service dialog to select your project and environment settings.

For details, see the WTP documentation at the following location:

http://help.eclipse.org/help33/topic/org.eclipse.jst.ws.axis.ui.doc.user/tasks/tsklwsdla.html

The WTP plug-in requires a Dynamic Web Project for skeleton generation.

http://help.eclipse.org/help33/topic/org.eclipse.jst.ws.axis.ui.doc.user/tasks/tsklwsdla.html
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The WTP plug-in uses the provided WSDL to generate source code stubs for the service skeleton.

Use the Package Explorer to access the generated code.
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8 Requesting Consumption of HP
Systinet Artifacts

HP Systinet enables users to request the consumption of an artifact in order to use it subject to terms set
by the provider.

This feature is only available for artifacts that are marked as consumable in HP Systinet.

Systinet Plug-In for Visual Studio enables you to request consumption directly.

To Request Consumption of HP Systinet Artifacts:

• Do one of the following:

• In the Search Results view, open the context menu for the artifact you want to consume, and
select Request Contract.

• In the Artifact Detail view, in the Server Requests section, select Request Contract.

A HP Systinet view opens in the Create Request page. For details about requesting consumption of
artifacts, see "How to Request Consumption" in the HP Systinet User Guide.

You may need to log in using your HP Systinet credentials.

For more details about Contracts, see "Contract Management" in the HP Systinet User Guide.
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9 Requesting Lifecycle Approval

HP Systinet uses Lifecycle Processes to govern artifacts. An important stage in lifecycle is the approval
of particular lifecycle stages.

Systinet Plug-In for Eclipse enables you to request lifecycle approval directly.

To Request Approval of HP Systinet Artifacts:

1 Do one of the following:

• In the Project Explorer view, open the context menu for the Catalog artifact you want to request
approval for, and select HP Systinet>Request Approval.

• In the Search Results view, open the context menu for the artifact you want to consume, and
select Request Approval.

• In the Artifact Detail view, in the Server Requests section, select Request Approval.

The Request Approval dialog box opens.

2 Input a description, and click OK to submit your stage approval request. For more details about
requesting approval of artifacts, see "How to Request Approval" in the HP Systinet User Guide.

You may need to log in using your HP Systinet credentials.

For more details about Lifecycle, see "Lifecycle Governance" in the HP Systinet User Guide.
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A Dialog Boxes

Each Systinet Plug-In for Eclipse input dialog is described in the following sections:

• Edit Configuration and Launch on page 52 Run ad hoc validation on several documents and
policies at the same time.

• Policy Validation on page 54 Set preferences for your report style.

• Properties for [Project Name] on page 55 Set up automatic validation for your project.

Edit Configuration and Launch

Run ad hoc validation on several documents and policies at the same time:
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Parameter Definition

Name The name you want to use for the validation check.

Sources The list of resources you want to use for validation.

Add Resource Browse and select documents from your Eclipse project.

Add External File Browse and select documents from your file system.

Add External
Folder

Browse and select all documents in a folder in your file system.

Add URL Enter an endpoint URL of a remote document.

Remove Remove previously selected documents.

Technical Policies The list of technical policies associated with the resources.
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Parameter Definition

Add Select from a list of available policies to use in the validation.

Remove Remove previously selected policies.

Filtered By Filter available documents or policies by file type.

Add Add a specific file type.

Remove Remove a previously selected file type.

Apply Apply the current configuration.

Revert Restore the previous configuration.

Run Start validation.

Close Close the dialog box without launching validation.

Policy Validation

Set preferences for your report style:



55

Parameter Definition

Validation Result
Format

Choose whether you want the validation results to be in Text or XML format.

Stylesheet Choose whether to use the default or a custom stylesheet.

Browse Browse for and select a custom stylesheet.

Validation Result
Limit

Specify the maximum number of returned results.

Filtered By Filter available stylesheets by file type.

Add Add a specific file type.

Remove Remove a previously selected file type.

OK Save your preferences.

Cancel Exit without saving your preferences.

Properties for [Project Name]

Set up automatic validation for your project.
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Parameter Definition

List of Policies Available policies for use in validation.

Add Browse for and select the policies you need.

Remove Remove previously selected policies.

List of Resources Choose whether you want to use resources in the entire project (default) or create a
custom selection.

Add Add custom resources.

Exclude Exclude specific files from the selected resource.

Remove Remove previously selected resources.

Filtered By List of associated file types.

Add Add a specific file type to the filter.

Remove Remove a previously selected file type from the filter.

OK Save your settings.

Cancel Exit without saving your settings.
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B Preferences

Systinet Plug-In for Eclipse contains a set of preferences determining its interaction with HP Systinet.
These settings are prompted for when required, but they can also be changed from the Tools>Options
menu.

These settings are described in the following sections:

• Setting the Server on page 57

Specify the installation of HP Systinet to integrate with.

• Setting the Domain on page 58

Specify the HP Systinet domain to work in.

• Setting the Environment on page 59

Specify the environment categorization to use when obtaining endpoints.

• Setting Synchronization on page 61

Specify whether to automatically synchronize local resources with the equivalent resources in HP
Systinet.

Setting the Server

The develop services in conjunction with HP Systinet you must set the credentials for the server you are
working with.

To set the HP Systinet server:

1 From the menu, select Window>Preferences.

The Preferences dialog box opens.
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2 In the tree view of the Preferences dialog box, select HP Systinet.

The HP Systinet page opens, as shown in Figure 6, “HP Systinet Page”.

Figure 6. HP Systinet Page

3 Set the connection details for the HP Systinet server. Optionally, save these credentials or use
Validate to test the connection.

4 Click OK.

Setting the Domain

The develop services in conjunction with HP Systinet you must select the domain that you are working
in.

To set the HP Systinet domain:

1 From the menu, select Window>Preferences to open the Preferences dialog box.

2 In the tree view of the Preferences dialog box, select HP Systinet>Domains to open the Domain
pages, as shown in Figure 7, “HP Systinet Domain Page”.
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Figure 7. HP Systinet Domain Page

3 Select the domain to access and click OK.

Setting the Environment

HP Systinet uses an Environment taxonomy to categorize endpoints enabling multiple endpoints for a
single service without requiring modification of the WSDL definition.

This means that the WSDL itself does not define the environment specific endpoints that you may require
for service development.

Systinet Plug-In contains an environment setting that allows you to define a default environment you are
developing your services for in order to obtain the relevant endpoints associated with the service.

To set the default environment:

1 From the menu, select Window>Preferences.

The Preferences dialog box opens.
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2 In the tree view of the Preferences dialog box, select HP Systinet>Environment.

The Environments page opens, as shown in Figure 8, “Environments Page”.

Figure 8. Environments Page

3 Set the default environment from the following options:

Environment Option Description

As originally uploaded Use the WSDL without any environment specific endpoints.

Environment Categories Use the endpoints for the service categorized as the selected
environment. For example, Development or Testing.

Always Ask Prompt for environment selection whenever it is required.

4 Click OK.
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Setting Synchronization

Systinet Plug-In enables you to download resources from HP Systinet. In addition, you can specify
automatic synchronization between HP Systinet resources and their local equivalents in your IDE project.

To set up automatic synchronization:

1 From the menu, select Window>Preferences.

The Preferences dialog box opens.

2 In the tree view of the Preferences dialog box, select HP Systinet>Auto Synchronization.

The Auto Synchronization page opens, as shown in Figure 9, “Auto Synchronization Page”.

Figure 9. Auto Synchronization Page

3 To enable automatic synchronization, select Auto Synchronization, and select from the following
synchronization options:
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Auto Synchronization
Option

Description

Each Time Platform is Started Update local versions with newer versions from HP Systinet
whenever the HP Systinet server starts.

Hourly Update local versions with newer versions from HP Systinet
every hour.

Each Time Project is Opened Update local versions with newer versions from HP Systinet
whenever a project is opened.

4 Click OK.



63

C Configuring Systinet Plug-In for
Eclipse

Systinet Plug-In for Eclipse uses a configuration file at the following location in the HP Systinet
repository:

http://host:port/soa/platform/restSecure/location/hpsoa/client/search-configuration.xml

This file is a server specific configuration that all instances of Systinet Plug-In for Eclipse access to
determine the format and content of repository search for that server.

When you first use Systinet Plug-In for Eclipse in your organization you must upload this configuration
to the HP Systinet server after you make any changes to reflect your requirements.

Systinet Plug-In for Eclipse contains a default configuration defined in the following file:

ECLIPSE_HOME/plugins/com.hp.systinet.tools.search.core_4.0.0.vBUILDTIME/config/search-

configuration.xml

To change the Systinet Plug-In for Eclipse configuration and upload it to HP Systinet:

1 Create a working copy of search-configuration.xml.

2 Open search-configuration.xml with a text editor.

3 Edit search-configuration.xml to reflect your requirements.

For details, see the following sections:

• Configuring Search and Detail Parameters on page 64

• Configuring Search Results on page 65

• Configuring Artifact Hierarchies on page 66
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• Configuring Localization on page 67

4 In HP Systinet use the Upload Content feature to store the configuration in the repository.

In the Upload Content page, specify the following location:

/hpsoa/client

For details, see "Uploading Service Infrastructure from Definition Documents" in the HP Systinet
User Guide.

Configuring Search and Detail Parameters

The artifact types in Repository Search and the property parameters displayed in Repository Search and
the Artifact Detail View are defined in the <details_view> section of the configuration file.

For example, the application artifact is defined as follows:

<details_view>
  <artifact_type localName="hpsoaApplicationArtifact">
    <invisible_properties>
      <property localName="lastRevision"/>
      <property localName="revision"/>
      <property localName="identifierBag"/>
      <property localName="artifactType"/>
      <property localName="categoryBag"/>              
      <property localName="stakeholderEmail"/>
      <property localName="criticality"/>
    </invisible_properties>
  </artifact_type>
  ...
</details_view>

To configure the Repository Search:

1 Open search-configuration.xml with a text editor.

2 Do any of the following:

• Add an artifact type to search by adding an <artifact_type> segment using the localName of the
artifact type.
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• Remove properties from the search parameters and detail view by adding a <property> in the
<invisible_properties> segment of an artifact, using the localName of the property.

You can locate the localNames in your configuration at the following location:

http://host:port/soa/systinet/platform/restBasic/repository/sdm/

sdmConfig.xml

3 Save search-configuration.xml.

Configuring Search Results

The property parameters displayed for artifacts in the Repository Search Results view are defined in the
<search_result> section of the configuration file.

For example, the application artifact is defined as follows:

<search_result>
  <artifact_type localName="hpsoaApplicationArtifact">
    <visible_properties>
      <property localName="name"/>
      <property localName="version"/>
      <property localName="productionStage"/>
      <property localName="description"/>
    </visible_properties>
  </artifact_type>
  ...
</search_result>

To configure the Repository Search:

1 Open search-configuration.xml with a text editor.

2 Do any of the following:

• Add an artifact type to search results by adding an <artifact_type> segment using the
localName of the artifact type.

• Add properties to the results for an artifact type by adding a <property> in the
<visible_properties> segment of an artifact, using the localName of the property.
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You can locate the localNames in your configuration at the following location:

http://host:port/soa/systinet/platform/restBasic/repository/sdm/

sdmConfig.xml

3 Save search-configuration.xml.

Configuring Artifact Hierarchies

Service artifacts in HP Systinet form natural hierarchies. Repository Search locates the artifacts matching
your search criteria, and if requested, any related artifacts specified in the hierarchical structure defined in
the configuration.

For example, the default hierarchy is defined as follows:

<hierarchical>
  <artifact localName="hpsoaApplicationArtifact">
    <artifact localName="businessServiceArtifact" upRef="hpsoaProvidingApplication"
      downRef="hpsoaProvidesBusinessService">
      <artifact localName="webServiceArtifact" upRef="inBusinessService"
 downRef="service">
        <artifact localName="wsdlArtifact" upRef="definitionOf" downRef="definition"/>
      </artifact>
    </artifact>
  </artifact>
</hierarchical>

You can add and modify hierarchies to match those relevant to your requirements.

To configure the Repository Search hierarchies:

1 Open search-configuration.xml with a text editor.

2 Do any of the following:

• Add a hierarchy by adding the top level <artifact> within the <hierarchical> segment, defined
by its local name.

• Add artifacts to hierarchies by adding <artifact> within a nested structure of an artifact
hierarchy. Define the artifact with a local name and directional relationship properties.
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You can locate the localNames and property names in your configuration at the
following location:

http://host:port/soa/systinet/platform/restBasic/repository/sdm/

sdmConfig.xml

3 Save search-configuration.xml.

If you define multiple hierarchies, the first hierarchy defined takes precedence in the event
of a conflict.

Configuring Localization

Localized text can be configured in repository search for artifact names in the <artifact_mapping>
section of the configuration file.

For example, the application artifact is defined as follows in English, Spanish, and Vietnamese:
<artifact_mapping>  
  <artifact_type localName="hpsoaApplicationArtifact">
    <custom_name value="Application"/>
    <custom_name locale="es" value="Aplicacion"/>                
    <custom_name locale="vi" value="&#7912;ng D&#7909;ng"/>                
  </artifact_type>
  ...
</artifact_mapping>

To configure the localized text in Repository Search:

1 Open search-configuration.xml with a text editor.

2 Add a new mapping rule for localization to Repository Search by adding an <artifact_type>
segment using the localName of the artifact type.

Specify the text to be localized with a <custom_name> specifying the text to be localized when the
artifact type is rendered.

Add location specific text for an artifact type by adding a <custom_name> to the artifact specifying
the locale and the text to use in that location.
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You can locate the localNames in your configuration at the following location:

http://host:port/soa/systinet/platform/restBasic/repository/sdm/

sdmConfig.xml

3 Save search-configuration.xml.
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D Eclipse Plug-in Requirements

If you use a non-packaged version of Eclipse you may require a number of plug-ins.

The following sections list the plug-ins required by Systinet Plug-In for Eclipse for each supported
version of Eclipse:

• Eclipse 3.2.x Plug-in Requirements on page 69

• Eclipse 3.3.x Plug-in Requirements on page 70

• Eclipse 3.4.x Plug-in Requirements on page 70

• Eclipse 3.5.x Plug-in Requirements on page 71

Eclipse 3.2.x Plug-in Requirements

For Eclipse 3.2.x, Systinet Plug-In for Eclipse has dependencies on the following plug-ins:

• DTP SDK 0.9 (dtp-sdk_0.9.1.zip)

http://www.eclipse.org/datatools/downloads.php

• EMF SDO Runtime 2.2.0 (emf-sdo-runtime-2.2.0.zip)

http://www.eclipse.org/modeling/emf/downloads/

• GEF Runtime 3.2 (GEF-runtime-3.2.zip)

http://archive.eclipse.org/tools/gef/downloads/drops/R-3.2-200606270816/

• WTP-R-1.5.0 (wtp-R-1.5.0-200606281455.zip)

http://www.eclipse.org/webtools/releases/1.5/

• XSD Runtime 2.2.0 (xsd-runtime-2.2.0.zip)

http://www.eclipse.org/datatools/downloads.php
http://www.eclipse.org/modeling/emf/downloads/
http://archive.eclipse.org/tools/gef/downloads/drops/R-3.2-200606270816/
http://www.eclipse.org/webtools/releases/1.5/
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http://www.eclipse.org/modeling/mdt/downloads/?project=xsd

• JEM-SDK-1.2 (JEM-SDK-1.2.zip)

http://download.eclipse.org/tools/ve/downloads/drops/R-1.2-200606280938/

Install these plug-ins before installing Systinet Plug-In for Eclipse.

Eclipse 3.3.x Plug-in Requirements

For Eclipse 3.3.x, Systinet Plug-In for Eclipse has dependencies on the following plug-ins:

• DTP SDK 1.5 (dtp-sdk_1.5.zip)

http://www.eclipse.org/datatools/downloads.php

• EMF SDO Runtime 2.3.0 (emf-sdo-runtime-2.3.0.zip)

http://www.eclipse.org/modeling/emf/downloads/

• GEF Runtime 3.3 (GEF-runtime-3.3.zip)

http://archive.eclipse.org/tools/gef/downloads/drops/R-3.3-200706281000/index.php

• WTP 2.0 (wtp-R-2.0-200706260303.zip)

http://www.eclipse.org/webtools/releases/2.0/

• XSD Runtime 2.3 (xsd-runtime-2.3.1.zip)

http://www.eclipse.org/modeling/mdt/downloads/?project=xsd

Install these plug-ins before installing Systinet Plug-In for Eclipse.

Eclipse 3.4.x Plug-in Requirements

For Eclipse 3.4.x, Systinet Plug-In for Eclipse has dependencies on the following plug-ins:

• DTP SDK 1.6 (dtp-sdk_1.6.0.zip)

http://www.eclipse.org/modeling/mdt/downloads/?project=xsd
http://download.eclipse.org/tools/ve/downloads/drops/R-1.2-200606280938/
http://www.eclipse.org/datatools/downloads.php
http://www.eclipse.org/modeling/emf/downloads/
http://archive.eclipse.org/tools/gef/downloads/drops/R-3.3-200706281000/index.php
http://www.eclipse.org/webtools/releases/2.0/
http://www.eclipse.org/modeling/mdt/downloads/?project=xsd
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http://www.eclipse.org/datatools/downloads.php

• EMF SDO Runtime 2.4.0 (emf-runtime-2.4.0.zip, sdo-runtime-2.4.0.zip)

http://www.eclipse.org/modeling/emf/downloads/

• GEF Runtime 3.4 (GEF-runtime-3.4.0.zip)

http://archive.eclipse.org/tools/gef/downloads/drops/

• WTP 3.0 (wtp-R-3.0-20080616152118a.zip)

http://www.eclipse.org/webtools/

• XSD Runtime 2.4.0 (xsd-runtime-2.4.0.zip)

http://www.eclipse.org/modeling/mdt/downloads/?project=xsd

Install these plug-ins before installing Systinet Plug-In for Eclipse.

Eclipse 3.5.x Plug-in Requirements

For Eclipse 3.5.x, Systinet Plug-In for Eclipse has dependencies on the following plug-ins:

• DTP SDK 1.7 (dtp-sdk_1.7.0.zip)

http://www.eclipse.org/datatools/downloads.php

• EMF SDO Runtime 2.5.0 (emf-runtime-2.5.0.zip)

http://www.eclipse.org/modeling/emf/downloads/

• GEF Runtime 3.5 (GEF-runtime-3.5.0.zip)

http://archive.eclipse.org/tools/gef/downloads/drops/

• WTP 3.1 (wtp-R-3.1-20090616025105.zip)

http://www.eclipse.org/webtools/

http://www.eclipse.org/datatools/downloads.php
http://www.eclipse.org/modeling/emf/downloads/
http://archive.eclipse.org/tools/gef/downloads/drops/
http://www.eclipse.org/webtools/
http://www.eclipse.org/modeling/mdt/downloads/?project=xsd
http://www.eclipse.org/datatools/downloads.php
http://www.eclipse.org/modeling/emf/downloads/
http://archive.eclipse.org/tools/gef/downloads/drops/
http://www.eclipse.org/webtools/
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• XSD Runtime 2.5.0 (xsd-runtime-2.5.0.zip)

http://www.eclipse.org/modeling/mdt/downloads/?project=xsd

Install these plug-ins before installing Systinet Plug-In for Eclipse.

http://www.eclipse.org/modeling/mdt/downloads/?project=xsd
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