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Overview
The HP-UX Provisioning feature in HP Server Automation (SA) enables you to install HP-UX on bare 
metal servers using golden image archives. You can model your HP-UX installation with customized 
configurations to provision multiple servers using HP's native unattended provisioning technology, 
Ignite-UX. HP-UX Provisioning in SA does not require separate dedicated Ignite-UX setup, instead SA 
core running with RedHat Linux can be used with Ignite-UX setup. HP-UX Provisioning feature is also 
supported on multi-master mesh and satellite environment.

Using HP-UX Provisioning feature in SA, you can:

• Perform network-based unattended installations using Ignite golden images
• Define Ignite attributes values different than specified in golden image for customized 

provisioning
• Bundle additional SA software policies to remediate as part of HP-UX installation
• Segment custom configurations in multi-customer environment on multi-mesh environment with 

permissions escalations.

Supported HP-UX Platforms and Systems

Prerequisites

This document does not cover SA core setup because it is assumed that SA 7.8 setup already exists. 
For more details, see the SA 7.8 User Guide for instructions on setting up a new SA core.

Supported Not Supported

Bare metal HP-UX provisioning on Integrity 
servers only

HP 9000 (PA-RISC)

All Integrity standalone, blade, nPar/vPar/
HPVM

Support for provisioning other operating systems 
such as Windows and Linux

Provisioning HP-UX 11.23 and 11.31 only Provisioning HP-UX 11.11 or earlier

Provisioning using golden images Alternate methods to provision HP-UX servers 
such as software depot-based install

Network boot support only

Multi-customer environment

HP-UX configuration selection based on 
customer permissions granted

Configuration customization:

• Configurations isolated by customer
• Ability to upload Ignite image files as part 

of operating system profiles

Bundling additional SA software policies to 
remediate

SA core platforms - RHEL (AS4-x64), Solaris, 
SUSE
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DHCP Setup
To provision servers with unattended installations, DHCP should be enabled. HPSA ships the DHCP 
server plus a highly customized configuration file to handle DHCP for OS provisioning purposes. To 
provision HP-UX instead of Linux on Integrity servers, HP-UX provisioning feature must be enabled on 
each core/satellite.

To enable HP-UX Provisioning feature, make the following changes on the core:

1 Modify the /etc/opt/opsware/dhcpd/dhcpd.conf file by commenting the following line:

#filename "elilo.efi";

2 Uncomment the following line to enable network boot on HP-UX Provisioning:

filename "/opt/ignite/boot/nbp.efi";

3 Restart the dhcp service:

/etc/opt/opsware/startup/dhcpd restart

Ignite Setup on Core
To provision the servers, you must set up Ignite Configurations such as updating the configuration file, 
updating the Index file, and copying the golden image archives on each SA core.

For detailed information on Ignite-LUX software on a server running Linux, see http://www.hp.com/
go/ignite-ux-docs.

The following tasks are required to set up the 11.31 golden archive-based configuration on the core:

• Copy over the sample golden image to the following location:
/var/opt/ignite/archives/B.11.31/ 

• Copy over the corresponding cfg file to following location:
/var/opt/ignite/data/Rel_B.11.31/B.11.31_archive_IA.cfg 

• Add an entry in /var/opt/ignite/INDEX for the configuration as follows:
cfg "HP-UX B.11.31 Opsware Archive" {
description "This selection supplies the sample golden archive 
created by the IUX team"
"/opt/ignite/data/Rel_B.11.31/config"
"/opt/ignite/data/Rel_B.11.31/hw_patches_cfg"
"/var/opt/ignite/data/Rel_B.11.31/B.11.31_archive_IA.cfg"
"/var/opt/ignite/data/config.local"
 }

APXs
• While upgrading the patch on the SA core, the HP-UX Provisioning APX (Automation Platform 

Extensions) and Custom Config Editor APX are installed to perform actions for the provisioning 
process. These APXs appear in the SA Client's APX Library.

• APXs are accessible either through the SA client or through Internet explorer. HP recommends 
running the Custom Config Editor APX on Internet Explorer.

• Adobe Flash Player Version 10.0 or above must be installed on all machines on which you plan to 
run HP-UX Provisioning APXs.

Customer Configuration Subfolders
SA Administrators for HP-UX Provisioning or any user who has privileges to the following folder must 
create a sample configuration for every customer for whom users want to create configurations:

Library > By Folder > Opsware > Tools > OS Provisioning > HP-UX Provisioning/
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The sample configuration is the same as the configuration that is created when you use the Custom 
Config Editor APX. It is called the sample configuration because it is the first configuration created for 
each new customer. When the first configuration is created, a subfolder is created for that new 
customer. If the SA Administrator for HP-UX Provisioning wants to assign restricted access to a user/
group based on configurations belonging to a specific customer, they must grant permission to that 
customer subfolder.

The SA Administrator for HP-UX Provisioning can see subfolders created with the customer name only 
after creating the sample configuration.

When you create the sample configuration, make sure that you select the new customer so that the 
subfolder with the customer name is created immediately within the configuration folder. The SA 
Administrator for HP-UX can assign read/write access to the user/group to access configurations. For 
example, say that prov_usr needs access to HP-UX Provisioning and should have access only to 
configurations belonging to CustA and CustB customers. To set this up, follow these steps:

1 Open the Custom Config Editor APX using Internet Explorer.

2 Log on as SA Administrator or as any user who has access to Library > By Folder > Opsware > 
Tools > OS Provisioning > HP-UX Provisioning/

3 Create a sample configuration for CustA and CustB using the Custom Config Editor APX. 

4 Log on to the SA client as SA Administrator for HP-UX Provisioning. Subfolders named CustA and 
CustB are created at the following location:

Library > By Folder > Opsware > Tools > OS Provisioning > HP-UX Provisioning/CustA

Library > By Folder > Opsware > Tools > OS Provisioning > HP-UX Provisioning/CustB

Permissions
This section discusses the minimum permissions required to use the HP-UX Provisioning feature. SA 
Administrators for HP-UX Provisioning can provide additional permissions that enable more features.

User/Group Permissions

SA Administrators for HP-UX Provisioning must grant the following permissions to the user/group.

• Facilities – You must have read/write access to any facility where the Integrity servers are 
provisioned with the configurations created by the Custom Config Editor APX.

• Customers – You must have read/write access to any Not Assigned customer to run the 
provisioning job successfully.

You must also have read/write access to any customer on whose behalf the HPUX configurations 
are being created.

• Features – You must have Managed Server and Groups permission so that you can actually see 
the server in SA after you provision it.

Folder Permissions

SA Administrators for HP-UX Provisioning must also grant folder permissions to list APXs, software 
policies, and configurations.

• APXs – You must have List Contents Of Folder and Execute Objects Within Folder permissions to 
the following folder to access HP-UX Provisioning and Custom Config Editor APXs:

Library > By Folder > Opsware > Tools > OS Provisioning > HP-UX

• Software Policies – You must have List contents of Folder, Read Objects Within Folder, and 
Execute Objects Within Folder permissions to the folders where HP-UX software policies used to 
define the configurations are placed.
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• Configurations – You must have Read Objects Within Folder and Write Objects Within Folder 
permissions to the following folder because it contains the HP-UX configurations:

Library > By Folder > Opsware > Tools > OS Provisioning > HP-UX Provisioning/
<customer_name>

HP-UX Provisioning Overview

HP-UX Provisioning installs HP-UX on bare metal systems using custom configurations. The HP-UX 
Provisioning process requires the following tasks:

• Setting up an Ignite environment on SA cores/satellites
• Creating custom configurations using the Custom Config Editor APX on the SA core
• Booting the target to the Network boot prompt
• Provisioning targets using the HP-UX Provisioning APX on the SA Core

The following sections discuss these tasks.

Setting Up an Ignite Environment
Setting up an Ignite environment on SA cores/satellites requires the following tasks:

• Setting up corresponding Ignite configurations and Index files.
• Obtaining the HP-UX golden image archives.
• Copying the archives (install media) to a network file share.

For more information, see Ignite Setup on Core on page 3.

Creating a Custom Configuration
You can specify customized configurations to be applied to an Integrity server. You can specify Ignite 
attributes that are applied on the server during HP-UX installation on top of the standard golden 
image configurations. You can also select additional software policies to be remediated as part of the 
HP-UX installation.

You can build customer-specific configurations by specifying the platform, base configuration, Ignite 
attributes, and related software policies. You can customize the installation to meet your specific 
needs.

To provision the server in a customized way, you must first create a custom configuration.

HP-UX Custom Config Editor APX

To access the HPUX Custom Config Editor APX on the SA web client, follow these steps:

1 Open Internet Explorer and type https://<your core>/webapp/<APX Unique Name>. The unique 
name for the APX is displayed on the SA NGUI.

2 Click the Library tab and select Extensions > Web > HPUX Custom Config Editor. The unique name 
for the APX is displayed when you select the APX.

In this instance, the Custom Config Editor APX name is com.hp.osprov.hpuxconfig.
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Figure 1 HP-UX Custom Config Editor APX   

All existing custom configurations are listed with Name, Customer, HP-UX Platform, Ignite Server, and 
Base Config details. The Refresh, Create, and Delete buttons also appear.

Figure 2 HP-UX Custom Config Editor APX – List Existing Configs 

When you select any existing configuration from the list, you will see additional details such as 
Custom Configurations and Software policies.

The Configuration listings are based on permissions assigned to you. You are able to list 
configurations belonging to the customers for which you have been granted permission. The 
configuration can be customer dependent or customer independent.

A customer independent configuration is accessible to all users. A customer dependant configuration 
is accessible to only those users who have appropriate permissions assigned. You can make the 
configuration dependant or independent by selecting the customer when you create the configuration.

The HP-UX Custom Config Editor APX enables you to:

• Create Custom Configurations
• Delete Custom Configurations
6



Creating a Custom Configuration

To create a custom configuration, follow these steps:

1 Open the HP-UX Custom Config Editor APX using Internet Explorer. 

2 Click the Create button and specify the required details to create a new custom configuration.

Figure 3 HP-UX Custom Config Editor – Create Custom Config 

3 You must specify the following required details to define the HP-UX custom configuration:

— Config Name: This is a mandatory field. It must be unique for each customer. The APX 
validates the following specifications:
– Must not exceed 255 characters in length.
– Must not begin or end with an empty space.
– Must not begin with punctuation, including @#$%^&*()+_-,./:;~{}[]|\'"?=` 
– Should not use newline, tab, flash, or backslash.

— Config Description: This is an optional field that can contain explanatory text describing the 
purpose and use of the configuration.

— Customer: By default, this is set to Not Assigned, which makes the configuration customer 
independent. You can only list those customers for which you have permission. You will not be 
able to list the configurations if appropriate permissions have not been granted to you for that 
customer.

— Platform: This is a mandatory field. You must select either 11.31 or 11.23 from the drop-down 
menu. Base configuration or Related Software Policies are dependent on platform selection. If 
the platform was not selected and you try to select either Base configuration or Related 
Software Policies, a warning message appears.

— Base Configuration: Content is displayed based on the HP-UX platform selected.
— Custom Config: This is an optional field that can be used to specify Ignite attributes. Any 

valid Ignite attributes specified in this field overwrite the configuration values specified in the 
golden image, which allows you to provision the servers in a customized manner. 

The following are examples of Ignite attributes:

_hp_pri_swap=6291456Kb
"Create /export volume"=TRUE
_hp_root_disk="0/1/1/1.2.0"
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_hp_disk_layout="Logical Volume manager (LVM) with VxFS"

For detailed information on Ignite custom attributes, see http://docs.hp.com/en/5992-1999/
5992-1999.pdf.

If the attributes and values specified are valid, they are applied on the servers on top of the 
standard image configurations. However, if the attributes specified are invalid or have incorrect 
syntax, provisioning will not start.

In some cases, attributes and values are incompatible. For example, say that you want to 
provision the server with the following Ignite attributes:

_hp_pri_swap=6291456Kb
"Create /export volume"=TRUE

The Ignite attributes syntax is correct and also has valid values but your target does not have 
enough disk space to implement it. As a result, a warning message is displayed on the targets 
before provisioning starts.

• Related Software Policies: This is an optional field consisting of a drop-down menu whose 
contents are displayed based on the platform selected. You can select multiple Related Software 
policies by holding the CTRL key and dragging the policies to the selected software policies list to 
apply them on the server after provisioning is completed and the agent is installed. You can 
change the sequence of a selected software policy by dragging it up or down. Polices specified 
in Selected Software Policies are applied on top of the standard policies in the golden Ignite 
image.

After the details for all mandatory fields, Config Name, Platform and Base Config are specified, 
the Create button is enabled.

4 Click the Create button. A confirmation message appears and the newly created configuration is 
listed.

Figure 4 Newly Created Custom Config Profile 

Boot Target
The network booted integrity client requires selecting the desired LAN and target OS to install. It waits 
for server side install instructions to start HP-UX Provisioning. The following figure shows a target client 
waiting to be installed.
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Figure 5 Server Waiting to be Installed  

For details, go to: http://docs.hp.com/en/5991-1247B_ed2/ch05s17.html#aes-npar-229b.

Provision the Targets
Once the custom configuration is created, it is listed on the HP-UX Provisioning APX on the SA client. 
Also, the target waiting at the network boot prompt is listed under the unprovisioned servers list on the 
HP-UX Provisioning APX. The following section describes how to provision the targets.

HP-UX Provisioning APX

To access HP-UX Provisioning APX, follow these steps:

1 Log on to the SA NGUI.

2 Click the Library tab and select Extensions > Web > HP-UX Provisioning.

Figure 6 HP-UX Provisioning APX   

The HP-UX Provisioning APX popup window showing the HP-UX configuration opens.
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Figure 7 HP-UX Provisioning APX – Listing of HP-UX Configurations   

All the configurations created using the Custom Config Editor APX are listed on the HP-UX 
Provisioning APX based on permissions granted. Configurations are listed with Name, Customer, 
HP-UX Platform, Ignite Server, and Base configurations details. The Refresh, Next, and Start 
buttons are also displayed. Select the HP-UX configuration you want installed on the servers and 
click Next.

When you select a configuration, additional details, including Custom Configurations and 
Software policies of the chosen configuration, are displayed. When you select a configuration, 
the Next button is enabled.

Figure 8 HP-UX Provisioning APX – Select HP-UX Configuration  

3 Click Next to select the unprovisioned servers.

All unprovisioned servers waiting at the network boot prompt matching the selected configuration 
platform are displayed and show MAC address, install OS, Ignite Server and Model details. 
Servers in the Unprovisioned Servers list register their presence, but do not have an operating 
system installed. 

4 Select the server to provision. Hold down the CRTL key to select multiple servers to provision at the 
same time using the same configuration.
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Figure 9 Select Client to Provision Using the Config Selected Before   

Once all servers are selected, provisioning starts immediately after you click the Start button. 

5 To set email notification, click the Next button. The following screen appears.

Figure 10 Set the Email Notification   

On Email Notification, by default, your email address (the user running the job) is displayed. To 
add additional email addresses, click +Add. Select the check boxes to receive notifications when 
job failure or success occurs. To remove an email address, select the address and click Remove.

You can also specify the Job Ticket ID in the Ticket Integration section. This Ticket ID is associated 
with the Job.

6 When you click Start, the job is initiated for program APX and the Job ID is assigned to it. 
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Figure 11 Initializing the Provisioning Job   

Figure 12 Initializing the Provisioning Job   

If the provisioning job was initiated successfully on the servers, you will see the following screen. This 
screen has a progress bar that is refreshed with updated progress status messages. The following 
status messages are updated during the provisioning job:

• Waiting_to_install
• Prepare_Config_File
• Configure_Disks
• Download_mini-system
• Loading_software
• Build_Kernel
• Boot_From_Client_Disk
• Run_Postconfigure_Scripts
• Agent Install
• Remediate software policy
12



Figure 13 Progress Bar with Status Message   

Once the provisioning job starts, two different progress bars are displayed. The consolidated 
progress bar displays the average percentage of progress on all servers being provisioned. It also 
displays the average percentage of jobs finished with the job start time.

The progress bar for each of the servers being provisioned shows % of provisioning complete with 
Server Name, MAC address, Status, and Status Message details. The % Complete and Status 
Message is updated along with the progress of the provisioning job.

Figure 14 Progress Bar with Status Message Remediate Software Policies   

Once the server is provisioned, the agent is installed by default. Also, the software policies chosen in 
the configuration are remediated on the servers. When the HP-UX Provisioning job completes, an 
email is sent to you if you set up email notification.
13



Figure 15 Progress Bar with Job Completed Message   

The provisioned servers are managed by SA. The servers are listed under Devices > All Managed 
Servers. Select the server, and then select Go to View > Properties. You can see the customer value, 
which is the same as the configuration customer value. You can see the servers listed as managed 
servers only if you have permission granted for the customer.

You can also verify the configuration name associated with the server. Go to View > Custom 
Attributes. This can be useful to find out which configuration was used to provision the server.

Jobs and Sessions on SA Core

HP-UX Provisioning APX assigns the job ID. You can use job ID to verify the job status at the following 
location: SA > Jobs and Sessions > Job Logs.

Figure 16 Job Status on SA Jobs and Sessions   

You can also find the specified Job Ticket ID in the notifications tab by double-clicking the job.
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Deleting Custom Configurations

To delete a custom configuration, follow these steps:

1 Open the HP-UX Custom Config Editor APX using Internet Explorer. 

2 Select the configuration or hold the CTRL key to select multiple configurations and click Delete.

Figure 17 Delete Custom Config Profile   

3 Click Yes on the confirmation window. The selected configurations are deleted and are no longer 
listed.

You are allowed to delete only those configurations for which you were granted privileges to execute 
the delete configuration operation.
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Glossary
Ignite-UX

An HP-UX administration toolset that allows simultaneous installation of HP-UX on multiple clients, 
create custom installation configurations (golden images) for multiple installations on clients, 
create recovery media, and recover HP-UX clients both locally and remotely. 

Ignite-UX server

A server from which Ignite-UX is used to install HP-UX on client systems.

Golden Image

A combination of a golden archive and a configuration file describing a system's disk layout and 
file system. Used as a common configuration to install clients.

Ignite Attributes

Custom attributes that allow provisioning the server with new customized values that overwrite the 
standard attributes values defined in the golden image.

Network boot

When a system boots the HP-UX install kernel over the network from an Ignite-UX server.

Target

The HP integrity server to be provisioned.

Custom Config Editor APX

The APX used to create and delete the custom configurations for HP-UX Provisioning.

HP-UX Provisioning APX

The APX used to start HP-UX Provisioning on target servers.

Sample Configuration

The first configuration created for the new customer by the SA Administrator for HP-UX 
Provisioning. It is same as the custom configuration but is the first configuration for a new 
customer. It creates a subfolder with the customer name under the HP-UX Configs folder in SA.

Useful Links

• 11iv3 installation information: http://docs.hp.com/en/5992-4165/ch02s01.html 
• Ignite-LUX: Management and Integration of Ignite-UX Software on a Server Running nux white 

paper at http://www.hp.com/go/ignite-ux-docs 
• Ignite-UX custom configuration files: http://docs.hp.com/en/5992-1999/5992-1999.pdf 
• Ignite-UX: http://www.docs.hp.com/en/osHP-UX11iv3.html#Ignite-UX 
16



Troubleshooting
Following are some suggested solutions.

Scenario: No Servers Waiting to be Installed
If there are no servers waiting at the network boot prompt with the HP-UX version that matches the 
selected configuration's HP-UX version, the following message is displayed:

Figure 18 No Servers Waiting to be Installed   

Scenario: Servers Waiting to be Installed are Managed Servers
If there are servers waiting at the network boot, but they are already managed servers in SA, the 
following warning message is displayed.

Figure 19 Servers Waiting to be Installed are Managed Servers   

This warning message indicates that the listed servers are waiting at the network boot prompt but 
cannot get listed here for reprovisioning because they are listed as managed servers in SA. To 
continue reprovisioning on these servers, you must manually delete them from the SA managed 
servers.

For detailed information on deactivating and deleting a server from the SA managed servers list, see 
https://external1.collaboration.hp.com/external/dca_pubs/Shared%20Documents/
SA%207.50%20Manuals/SA_7.50_Users_Guide_Server.pdf.

Figure 20 HP-UX Provisioning APX Listing Deleted Managed Servers for Reprovisioning   

Once a server is deleted, it is not listed under the SA managed server list. Click Refresh in the HP-UX 
Provisioning APX window and the server should be listed under the unprovisioned server pool. Select 
the server and continue provisioning it.
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Scenario: Configurations Unavailable or Permissions Not Granted
This message appears when you do not have enough permission granted to list the configurations, or 
there are no configurations created.

Figure 21 No Configs Available or Permissions Granted   

Contact your SA Administrator to obtain permission, or create configurations using the Custom Config 
Editor APX.

Scenario: Incorrect Target Listing
In certain error scenarios, you might notice stale data in the APX client’s menu such as clients that are 
not currently waiting to be network installed or clients with an incorrect hostname. Following are some 
of the reasons for this and how to address them.

• A client that is not currently waiting to be network installed shows up in the APX clients list.

This could be due to the target being reset while it was waiting to be network installed. If this is 
done, the Ignite-UX does not detect this change and continues to think that the client is still 
waiting. This can be addressed either by retrying the install, or by deleting the directories for this 
target under /var/opt/ignite/clients/. There are two directories for each client, one of the form 
<mac address> (for example, 0x00306EF37245) and the other a symbolic link to this directory. 
Delete both of them.

• A client is listed with an incorrect hostname in the APX.

This could happen if you modified dhcp to provide a different hostname after having tried 
provisioning this client earlier. Ignite UX seems to reuse the directories it set up for a client in /
var/opt/ignite/clients/ if it finds one based on the MAC address, so the APX ends up reusing the 
earlier information. To get around this, delete the two directories for this client under /var/opt/
ignite/clients and retry the install process.

Scenario: Install Timed Out Error
An install timed out error occurs when the provisioning job does not get initiated on the server. This 
could be due to a network issue, the golden image not being available, or another reason.

Figure 22 Provisioning Did Not Get Initiated on Server   
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Make sure the network connection and Ignite images are accessibility and open a new APX to initiate 
provisioning.

Scenario: Loading Software Error
A loading software error can occur in situations like the following:

• Network issues
• Corresponding archive does not exist or not accessible
• Incorrect setup of golden images

Figure 23 Golden Image Set Up Incorrectly   

To resolve this, make sure that the Ignite specific configuration file, Index file, and archives are set up 
correctly and pointing to correct locations. Also make sure the network connection between the target 
and the Ignite server is accessible.

Scenario: Prepare Config File Error
The provisioning job fails to get initiated on the server if any syntax errors are found in the custom 
attributes specified in the configuration or custom attributes are not compatible.

Figure 24 Provisioning Failed Due to Invalid Ignite Attributes   

You might need to reboot the system and bring it back to the network boot prompt. On SA, create a 
new configuration with corrected custom attributes. Make sure the syntax specified is correct and 
compatible. Use the newly created profile.

Scenario: Agent Fails to Start
After successful job completion, if the Opsware agent fails to start on a newly provisioned target, 
there is a possibility that the golden image you used already has the agent installed. As part of the 
standard provisioning process, once HP-UX is installed on the server, the post-install script runs on the 
server that installs the agent. Because the agent is already installed through the golden image, it 
contradicts the usual process of provisioning and the agent does not get started on the target.
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