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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

Visit the HP Software Support Online web site at:

www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and support that HP 
Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to 
access interactive technical support tools needed to manage your business. As a valued support customer, you 
can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract. To register for an HP Passport user ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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1 HP Client Automation Agent Migration
The upgrade information in this guide applies to the following HP Client Automation (HPCA) 
agents:

• HPCA Application Manager

• HPCA Application Self-Service Manager

• HPCA Inventory Manager

HP Client Automation Documentation

The HP Client Automation documents referenced in this migration guide are:

• HP Client Automation Administrator Installation and User Guide

• HP Client Automation Application Manager and Application Self-Service Manager 
Installation and Configuration Guide. 

For information on upgrading HPCA Enterprise Edition environment, see the HP Client 
Automation Enterprise Edition Migration Guide.

These guides are available on the installation media as well as the HP documentation web 
site: www.hp.com/go/hpsoftwaresupport.

Abbreviations and Variables

This guide uses the abbreviations and variables defined in the following tables.

Table 1 Abbreviations Used in this Guide

Abbreviation Definition

HPCA HP Client Automation

Core and Satellite HPCA Enterprise environment consisting of one Core 
server and one or more Satellite servers. All features 
are installed as part of the Core or Satellite server 
installation.

CSDB Configuration Server Database

Portal HPCA Portal
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Requirements for the HPCA Agent

For information about the operating systems on which the HPCA agent can be installed, see 
the Release Notes for HPCA 8.10.

The requirements for installing the HPCA agent are:

• Administrative rights on the computer on which you intend to install the HPCA agents.

• Microsoft .NET runtime version 1.1 and above.

This requirement is specific to systems on which the HPCA Application Self-Service 
Manager is installed.

The .NET installation program is available in the \dotnet directory on the HPCA agent 
installation media. It automatically runs on HPCA Application Self-Service Manager host 
devices on which it is not already installed. This can be configured in the Install.ini 
file.

• TCP/IP connection to a computer on which the Configuration Server is running.

The HPCA Agent Upgrade

If you have a HPCA agent and a HPCA Administrator on the same device, HP recommends 
that you upgrade the HPCA Administrator after you upgrade the HPCA agent. For more 
information on upgrading the HPCA Administrator, see the HP Client Automation Enterprise 
Edition Migration Guide.

Table 2 Variables Used in this Guide

Variable Description Default Values

InstallDir Location where 
the HPCA server 
is installed

For a 32-bit OS: C:\Program 
Files\Hewlett-Packard\HPCA

For a 64-bit OS: C:\Program 
Files(x86)\Hewlett-Packard\HPC
A

SystemDrive Drive label for 
the drive where 
the HPCA server 
is installed

C:

Microsoft .NET requires version 5.01 (or later) of Microsoft Internet Explorer.

While migrating the agent, make sure that there are no other connects running. 
HPCA Agent Migration service installation runs asynchronously. Any other 
connect must run only after the agent upgrade is completed. To check the status of 
the agent upgrade, check upgrade.log in the %IDMLOG% directory.
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HPCA Agent Upgrade Files

• To upgrade the HPCA agent using the HPCA agent installation service, use the files 
located on the installation media under Setup-Core\Media\clients\Migration.

The files are:

HPCA_AGENT_810_UPGRADE_WIN.XPI

HPCA_AGENT_810_UPGRADE_WIN.XPR

• To upgrade the HPCA agent using the installation media, you can use the files located in 
the following directories:

— HPCA DVD: Setup-Core\Media\client\default\win32

— HPCA Core installation directory:

<InstallDir>\Media\client\default\win32

The above directories contain the following files:

– setup.exe: This file launches the standard HPCA agent installation.

If a previous version of the HPCA agent is detected, this file launches 
upgrdmaint.exe.

– upgrdmaint.exe: This file performs the HPCA agent upgrade.

– HPCAE-MgmtApps.msi: This MSI database file contains the default 
configuration information for the installation and the HPCA agent components.

– HPCAE-MgmtApps2.cab: This cabinet file contains HPCA agent components 
that are specific to non-Thin client devices such as desktops, notebooks, and 
workstations. This file is used by the HPCAE-MgmtApps.msi file during 
installation.

– Install.ini: With this file you can (optionally) customize the HPCA agent 
installation and the HPCA agent arguments file, args.xml.

– The dotnet and Samples subdirectories.

For more information about the files mentioned in this section, see HP Client Automation 
Application Manager and Application Self-Service Manager Installation and Configuration 
Guide.

Pre-upgrade Requirement

The default values set in the [Args] section of the Install.ini file are: 

identification=$MACHINE

startdir=SYSTEM

With these values, HPCA Applications Self-Service Manger has a SYSTEM connect with the 
HPCA Configuration Server. If the existing value for identification is $USER, you need to 
modify the [Args] section of the Install.ini file so that the device does not have a SYSTEM 
connect. If the identification and startdir values are not modified, the Install.ini 
overwrites the default values into the existing args.xml file after the upgrade and the HPCA 
Application Self-Service Manager has a SYSTEM connect.
HP Client Automation Agent Migration 9



HPCA Agent Upgrade Process

There are several ways to upgrade the HPCA agents:

• Using HPCA agent installation service to distribute the agent upgrade.

See the section Configuring the HPCA Agent Installation Service on page 12.

• Using HPCA installation media to upgrade a HPCA agent in your lab environment.

The HPCA installation media contains the installation files, as well as the upgrade files.

— When you run the installation, a standard installation is performed.

— If the installation program detects a previous version of the HPCA agent, it launches 
the upgrade process. In this case, existing HPCA agent object attributes are 
maintained and the HPCA agent version information is updated to reflect the latest 
version.

• Run the upgrade from a network drive.

To run the HPCA agent upgrade from a network drive, connect to the network drive, and 
run the following command from the command line:

setup.exe /runlocal

This command copies the contents of the installation media to the local drive and 
automatically performs the upgrade.

HPCA Agent Upgrade using Installation Service Files

This section describes how to use the HPCA agent installation service files or the export decks 
to perform the HPCA agent upgrade. When you upgrade an existing HPCA agent, it is 
installed in the existing HPCA agent’s directory. The HPCA agent default directories are:

• C:\Program Files\Hewlett-Packard\CM\Agent (HP OVCM 5.x)

• C:\Program Files\Hewlett-Packard\HPCA\Agent (HPCA 7.5x and above)

Importing the Decks

In order to distribute the HPCA agent upgrade as an HPCA service, you must import the 
HPCA agent installation service into the HPCA Configuration Server Database.

- The HPCA agent upgrade removes a previous version of the HPCA agent 
installed on the device.

- In a Lockdown enabled environment, if you have applied Access Control List 
(ACL) settings to the HPCA agent directories, make sure to revert the ACL 
settings before you perform the remove, repair, or modify operations for a HPCA 
agent installer.

You must reboot the device for a successful Agent upgrade.
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To import the decks

1 Stop the HPCA Configuration Server. You can use the command prompt or the Control 
Panel to stop the HPCA Configuration Server.

— To stop the HPCA Configuration Server using the command prompt, run the net 
stop ztoptask command from the command prompt.

— To stop the HPCA Configuration Server using the Control Panel, click Start → Control 
Panel → Administrative Tools → Services. From the list of services, select HPCA 
Configuration Server and click Stop the service.

2 From the installation media folder, Setup-Core\Media\clients\Migration, copy the 
HPCA agent installation service files; HPCA_AGENT_810_UPGRADE_WIN.XPI and 
HPCA_AGENT_810_UPGRADE_WIN.XPR to \bin directory of the HPCA Configuration 
Server.

For example:

C:\Program Files\Hewlett-Packard\HPCA\ConfigurationServer\bin

3 Open a command prompt window.

4 Change the directory path to <InstallDir>\ConfigurationServer\bin directory of 
the HPCA Configuration Server.

5 Type:

ZEDMAMS 
VERB=IMPORT_INSTANCE,FILE=HPCA_AGENT_810_UPGRADE_WIN.XPI,PREVIEW=NO. 
Press Enter.

6 Review the ZEDMAMS.LOG file created in the \bin directory to ensure that there are no 
errors and that the import completed successfully with Return Code (RC) 0.

7 After the instances are imported, type:

ZEDMAMS 
VERB=IMPORT_RESOURCE,FILE=HPCA_AGENT_810_UPGRADE_WIN.XPR,PREVIEW=NO. 

Press Enter.

8 Review the ZEDMAMS.LOG file created in the 
<InstallDir>\ConfigurationServer\bin directory to ensure that there are no 
errors and that the import completed successfully with RC 0.

9 Close the command prompt window.

10 Start the HPCA Configuration Server. You can use the command prompt or the Control 
Panel to start the HPCA Configuration Server.

— To start the HPCA Configuration Server using the command prompt, run the net 
start ztoptask command from the command prompt.

— To start the HPCA Configuration Server using the Control Panel, click Start → Control 
Panel → Administrative Tools → Services. From the list of services, select HPCA 
Configuration Server and click Restart the service.

11 Use the HPCA Administrator CSDB Editor to view the new service in 
PRIMARY.SOFTWARE.ZSERVICE. To view the class names in the HPCA Admin CSDB 
Editor window, click View → Options... → General and enable the Show Class Names Next to 
Descriptions checkbox. Click OK to close the Options dialog box. 
HP Client Automation Agent Migration 11



Customizing the HPCA Agent Installation Service (Optional)

To customize the HPCA agent installation service, follow these steps:

1 Open the HPCA Administrator CSDB Editor.

2 In the HPCA Administrator CSDB Editor, go to Options → Advanced tab, and select Show 
Edit Replace and Add Component options for File type components.

3 Navigate to the Install.ini resource of the HPCA 8.10 update service.

4 Right-click Install.ini in the tree view. A shortcut menu opens.

5 Select Edit this Component from the shortcut menu.

6 The Editor Selector for Install.ini dialog box opens. Use this dialog box to select the 
resident editor you want to use to make the changes to this file. For example, select 
Notepad to open the Install.ini file with Notepad.exe.

For details about the parameters in Install.ini, see HP Client Automation Application 
Manager and Application Self-Service Manager Installation and Configuration Guide.

For more information on the Edit this Component command, see HP Client Automation 
Administrator Installation and User Guide.

Configuring the HPCA Agent Installation Service

To configure the HPCA agent installation service, follow these steps:

1 Customize the HPCA Agent Installation Service, if required.

2 Connect the service to the appropriate users for distribution.

For more information, see HP Client Automation Application Manager and Application 
Self-Service Manager Installation and Configuration Guide.

After the service is distributed to a user and the HPCA agent upgrade is complete. The service 
will no longer be available to the user and is automatically removed from the HPCA agent 
desktop. There is a ZSTOP expression in the HPCA agent upgrade (ZSERVICE) instance that 
evaluates to TRUE after the HPCA agent is upgraded. Once this expression evaluates to 
TRUE, the temporary service folder and the HPCA agent installation files are removed.

You must reboot the device for a successful Agent upgrade.
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2 Migration Scenarios
This chapter includes migration scenarios for:

• HPCA agent 7.80 or 7.90 Non-Lockdown to HPCA agent 8.10 Non-Lockdown mode.

• HPCA agent 7.80 or 7.90 Non-Lockdown to HPCA agent 8.10 Lockdown mode.

• HP CM agent 5.11.4 / HPCA agent 7.8.1 or 7.90 Lockdown to HPCA agent 8.10 Lockdown 
mode.

• HP CM agent 5.11.4 / HPCA agent 7.8.1 or 7.90 Lockdown to HPCA agent 8.10 
Non-Lockdown mode.

HPCA Agent 7.80 or 7.90 Non-Lockdown to HPCA Agent 8.10 
Non-Lockdown Mode

The HPCA agent 7.80 or 7.90 can be migrated to HPCA agent 8.10 with Non-Lockdown mode 
through a simple upgrade. For information on the upgrade steps, see HPCA Agent Upgrade 
Process on page 10.

HPCA Agent 7.80 or 7.90 Non-Lockdown to HPCA Agent 8.10 
Lockdown Mode

When migrating from HPCA agent 7.80 or 7.90 with Non-Lockdown mode to HPCA agent 8.10 
with Lockdown enabled mode, make sure you set the Lockdown parameters in the 
[Properties] section of the Install.ini file. The Lockdown parameters are:

[Properties]

LOCKDOWN=Y

LOCKDOWNSCRIPT=<Customized-Script>

HP provides a sample file, setacls.bat that contains sample statements that you can use to 
create a customized script. The customized script is used to set the Access Control Lists 
(ACLs) to the agent folders in the HPCA environment. Ensure that the customized script is in 
the same directory as the Install.ini and setup.exe files.

You can now migrate to HPCA agent 8.10. To upgrade the agent, see HPCA Agent Upgrade 
Process on page 10.
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Migrating the User Data to the User Profile

After successful agent upgrade, you need to transfer the user data to the respective user 
profiles. You can retain the user data in the respective user profiles by running the 
secure_migrate.tcl script.

To migrate the user data to the respective user profiles, follow these steps:

1 Copy the secure_migrate.tcl file from 
Setup-Core\Media\client\default\win32 to the IDMSYS folder.

2 From the command line, run the following command: nvdkit secure_migrate.tcl 
-idmusr <User-Folder-path> -usrmsi <User-Msi-Folder-path>

On Windows Vista, Windows 7, and Windows 2008 Server the User-Folder-path is

C:\Users\<username>\AppData\Local\HPCA\Agent

On Windows XP, and Windows 2003 Server the User-Folder-path is:

C:\Documents and Settings\<username>\Local Settings\Application 
Data\HPCA\Agent

You can move the data objects of all the users at the same time by replacing the 
<username> with the value ZUSERID in the above mentioned paths.

The User-Msi-Folder-path is the IDMUSRMSI path

IDMUSRMSI=”<InstallDir>\Agent\usermsi”

The secure_migrate.tcl script automatically reads all the data objects in the IDMROOT 
folder, <InstallDir>\Agent\Lib, for each user and moves the data objects to the user 
profile set in the script.

On Windows XP, and Windows 2003 Server, the Administrator user contents are moved 
to:

C:\Documents and Settings\Administrator\Local Settings\Application 
Data\HPCA\Agent

On Windows Vista, Windows 7, and Windows 2008 Server, the Administrator user 
contents are moved to:

C:\Users\Administrator\Appdata\Local\HPCA\Agent

HP CM Agent 5.11.4/HPCA Agent 7.8.1 or 7.90 Lockdown to 
HPCA Agent 8.10 Lockdown Mode

Perform the following steps before migrating to HPCA agent 8.10 in Lockdown enabled mode:

If you need to run the customized script for setting ACLs as well as the 
secure_migrate.tcl script, you can append the contents of the 
secure_migrate.tcl script to the customized script. Use this customized script 
in the LOCKDOWNSCRIPT parameter in the [Properties] section of the 
Install.ini file.
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Retaining ACL Settings

In HP CM 5.11.4 and HPCA 7.8.1, Lockdown mode is enabled using the setsecure.bat file. 
This batch file performs two functions: 

• Enables lockdown mode.

• Sets Access Control Lists (ACLs) to the agent folders.

The setsecure.bat file contains sample statements that you can use to create a customized 
script to set ACLs.

Before migrating to HPCA agent 8.10 in Lockdown enabled mode, perform the following steps:

1 Copy the customized script you had previously created for HP CM 5.11.4, HPCA 7.8.1 and 
7.90 to the folder Setup-Core\Media\client\default\win32. The contents of this 
folder are delivered to the target device during remote deployment.

2 Set LOCKDOWN=Y in Install.ini file of HPCA 8.10 to enable Lockdown.

3 Set LOCKDOWNSCRIPT=<Customized-Script>.

Retaining User Contents after Upgrade

In HPCA 8.10, the default value for IDMUSR in Install.ini file is 
CSIDL_LOCAL_APPDATA\HPCA\Agent. The Install.ini file uses the IDMUSR parameter 
to create user specific contents in the respective user profiles folders on the target device. 
During migration, set the IDMUSR value in the latest version to the IDMUSR value used in 
the previous version of agent installation. You must modify the [Properties] section of 
Install.ini file of HPCA 8.10 for IDMUSR to retain the user contents after a successful 
upgrade.

For example, in HPCA 5.11.4, the value of IDMUSR is CSIDL_LOCAL_APPDATA\CM\Agents, 
and the user profiles are created within the \CM\Agents folder structure. If the IDMUSR 
value is not retained while upgrading to HPCA agent 8.10, the Install.ini file will create 
user profiles within the \HPCA\Agents folder structure. Therefore, even if the migration is 
successful, the user data is not retained.

Updating the Registry for NVD.INI file Location

In a Non-Lockdown enabled mode, the NVD.INI file resides in the IDMROOT folder, 
<InstallDir>\Agent\Lib. The NVD.INI file location saved in the registry file is 
HKEY_LOCAL_MACHINE\Software\Novadigm\Radia\Settings\INIPath.

When the Lockdown mode is enabled, the NVD.INI file is moved from the IDMROOT folder to 
the IDMSYS folder, <InstallDir>\Agent. After the NVD.INI file is moved, it is no longer 
available to the user.

After the Lockdown mode is enabled, the location of the NVD.INI file is changed to the 
IDMSYS folder however the IDMROOT folder’s path is retained in the registry file. When 
migrating to HPCA agent 8.10 in Lockdown enabled mode, update the registry file to reflect 
the new location of the NVD.INI file. This prevents a new installation of the HPCA agent.

You can use any one of the following methods to ensure that the registry contains the correct 
location of the NVD.INI file.

While migrating to HPCA 8.10, do not use the default setsecure.bat and 
setacls.bat files in the LOCKDOWNSCRIPT parameter. Update the files based on 
your requirements and use them.
Migration Scenarios 15



Method 1 

Modify the registry using command line or batch mode (preferred method).

1 Create an updateINIpath.txt file with the following content, 
HKEY_LOCAL_MACHINE\SOFTWARE\Novadigm\Radia\SettingsINIPath = REG_SZ 
"C:\PROGRA~1\HEWLET~1\HPCA\Agent\"

2 From the command line, run the command regini updateINIpath.txt. You can also 
run this command on all the target devices before the upgrade.

Method 2

Make sure that the NVD.INI file resides in both the IDMSYS and the IDMROOT folder. You can 
write a script to copy the NVD.INI file from the IDMSYS folder to IDMROOT folder.

Method 3

Uninstall the existing agent and then install the HPCA agent 8.10 with Lockdown enabled 
mode. Only the SYSTEM or an Administrator user can uninstall the HPCA agent.

HP CM Agent 5.11.4 / HPCA Agent 7.8.1 or 7.90 Lockdown to 
HPCA Agent 8.10 Non-Lockdown Mode

To migrate to HPCA agent 8.10 with Non-Lockdown mode:

1 Uninstall the existing agent from the target device.

2 Install the HPCA agent 8.10 without setting the Lockdown parameters in the [Properties] 
section of the Install.ini file.

Migration of Lockdown enabled HP CM 5.11.4 agent / HPCA 7.8.1 or 7.90 agent to 
HPCA agent 8.10 with Non-Lockdown mode is not supported.
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We appreciate your feedback!

If an email client is configured on this system, click    

If no email client is available, copy the following information to a new message in a web mail 
client and send the message to docfeedback@hp.com.

Product name and version: HP Client Automation 8.10

Document title:

Feedback:  

               

mailto:docfeedback@hp.com?Subject=Feedback on the HPCA (8.10) documentation
&body=Please enter your comments here:
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