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Support

Support for the HP Service Activator Extended Pack product is available on the following mailing list:

hpsa-support@hp.com
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In This Guide

This guide explains how to use the Solution Container and the user administration GUI provided with it.

Audience

The audience for this guide is the Solutions Integrator (Sl). The SI has a combination of some or all of the
following capabilities:
Understands and has a solid working knowledge of:
— UNIX® commands
- Windows® system administration
Understands networking concepts and language
Is able to program in Java™ and XML
Understands security issues

Understands the customer’s problem domain

References

HPSA Extension Pack — Solution Container — Developer Reference.

HP Service Activator — Inventory Subsystem.

Manual Organization

This guide contains the following chapters:

Chapter 1, “Introduction”, provides a brief explanation about the purpose, the scope and the definitions
involved in this document.

Chapter 2, “General description”, provides a wide description of the tool this document is focused on.

Chapter 3, “User management”, describes the administration GUI provided with the SC for the user
management.

Chapter 4, “Permission management”, describes the administration GUI provided with the SC for the
assignment of permissions for the different users to access the different applications under the SC.

Chapter 5, “Inventory management”, describes the administration GUI provided with the SC for the
Inventory tool.

Chapter 6, “User RMI management”, describes the way to manage the SC users from an external system
through RMI.
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Conventions

The following typographical conventions are used in this guide.

Font What the Font Example
Represents
Italic Book or manual titles, Refer to the HP Service Activator — Workflows and the
and man page names | Workflow Manager and the Javadocs man page for more
information.
Provides emphasis You must follow these steps.
Specifies a variable Run the command:
that you mU_St supply I nvent or yBui | der <sourceFiles>
when entering a
command
Parameters to a method | The assigned_criteria parameter returns an ACSE response.
Bold New terms The distinguishing attribute of this class...
Conput er Text and items on the The system replies: Press Ent er
computer screen
Command names Use the I nvent or yBui | der command ...
Method names The get _al |l _replies() method does the
following...
File and directory Edit the file
names $ACTI VATOR_ETC/ confi g/ mvf m xm
Process names Check to see if mavf mis running.
Window/dialog box In the Test and Track dialog...
names
XML tag references Use the <DBTabl e> tag fo...
gorgm er Text that you must type | At the prompt, type: |'s -1
0
Keycap Keyboard keys Press Return.
[Button] Buttons on the user Click [ Del et e] .
interface Click the [ Appl y] bution.
Menu ltems | A menu name followed | Select Locate:Objects->by Comment.
by a colon (:) means
that you select the
menu, then the item.
When the item is
followed by an arrow
(), a cascading menu
follows
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Install Location Descriptors

The following names are used throughout this guide to define install locations.

Descriptor What the Descriptor Represents
$ACTI VATOR_OPT The install base location of Service Activator.
The UNIX location is / opt / OV/ Ser vi ceAct i vat or

The Windows location is
<drive>:\ HP\ OpenVi ew\ Servi ceActi vat or\

$ACTI VATOR_ETC The install location of specific Service Activator configuration files.
The UNIX location is / et c/ opt / OV/ Ser vi ceAct i vat or

The Windows location is
<drive>:\ HP\ OpenVi ew\ Servi ceActivator\etc\

$ACTI VATOR_VAR The install location of specific Service Activator logging files.
The UNIX location is / var / opt / OV/ Ser vi ceAct i vat or

The Windows location is

<drive>:\ HP\ OpenVi ew\ Servi ceActi vat or\var\

$ACTI VATOR _BI N The install location of specific Service Activator binary files.
The UNIX location is / opt / OV/ Ser vi ceAct i vat or/ bin

The Windows location is
<drive>:\ HP\ OpenVi ew\ Servi ceActi vat or\ bi n\

$ACTI VATOR_THI RD_PARTY | The location for new Java components such as workflow nodes and
modules. Third-party libraries can also be placed in this directory.

The UNIX location is /opt / OV/ Servi ceActi vator/3rd-party

The Windows location is

<drive>:\ HP\ OpenVi ew\ Servi ceAct i vat or\ 3rd- party\
Customized inventory files are stored in the following locations:
UNIX: $ACTI VATOR_THI RD_PARTY/ i nvent ory

Windows: $ACTI VATOR_THI RD_PARTY\i nvent ory
$JBOSS_HOMVE HOME The install location for JBoss.

The UNIX location is / opt / HP/ j boss

The Windows location is

<drive>:\HP\j boss
$JBOSS_DEPLOY The install location of the Service Activator J2EE components.

The UNIX location is
[ opt/ HP/ j boss/ server/ def aul t/ depl oy
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The Windows location is

<drive>:\HP\jboss\server\defaul t\depl oy

$ACTI VATOR _DB_USER

The database user name you define.

Suggestion: ovacti vat or

$ACTI VATOR_SSH_USER

The Secure Shell user name you define.

Suggestion: ovact usr

$SOSA_HOMVE

The install base location of SOSA.
The default UNIX location is / opt / OV/ Sosa

The default Windows location is

<drive>:\HP\OpenView\Sosa\

$SOSA BI N

The install location of specific SOSA binary files.
The default UNIX location is / opt / OV/ Sosa/ bi n

The default Windows location is
<drive>:\ HP\ OpenVi ewh Sosal\ bi n\

$SOSA _ETC

The install location of specific SOSA configuration files.
The default UNIX location is / opt / OV/ Sosal confi g
The default Windows location is

<drive>:\HP\OpenView\Sosa\config\

$ECP_HOME

The install base location of Equipment Connections Pool.
The default UNIX location is / opt / Ov/ ECP
The default Windows location is

<drive>:\HP\OpenView\ECP\

$ECP_BI N

The install location of specific Equipment Connections Pool binary files.
The default UNIX location is / opt / Ov/ ECP/ bi n
The default Windows location is

<drive>:\HP\OpenView \ECP\bin\

$ECP_ETC

The install location of specific Equipment Connections Pool
configuration files.

The default UNIX location is / opt / OV/ ECP/ conf
The default Windows location is

<drive>:\HP\OpenView\ECP\conf\
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1 Introduction

1.1 Purpose

This document is a manual for the users of the Solution Container. It explains every feature of the Solution
Container and the administration tool provided with it.

1.2 Document Scope

This document is oriented for the users of the Solution Container. It is focused on the main featured
provided with the EP around the Solution Container.

1.3 Definitions

1.3.1 Acronims

MWFM: Micro Work Flow Manager
HPSA: HP Service Activator
EP: Extension Pack

SC: Solution Container

UAG: User Administration GUI
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2 General Description

2.1

Solution Container

The SC is an application framework for the development and deployment of user applications. Integrated
info the HPSA, it provides mechanisms to integrate the applications into the activation system.

lts objectives are:

e To establish a common interface for all the user applications.

e To establish a main design which provides a clear separation between logical and presentation
layers.

e To provide APls and designing regulations for a lively and effective development of the user
applications.

e To personalize the applications for each user accessing the tool.
The EP provides the SC with several tools and applications whose documentation is deployed with the
installation of the EP itself.

This tool provides a common visual interface in which developers can deploy new user applications. The
figure below shows an example this interface.

» File | » Search | » Administrator | » Inventory | » Help E’] .

Login information:

» Login date: Wed Oct 15 16:53:32 CEST...
» Last login date: 2008-10-15 16:43:01.0

» User ip: 16.28.27.15

» Failed attempts 0

Fig. 1: Solution Container

SC provides several APIs for developing and a designing guide which makes it easy developing and
deploying new user applications. Integrated in the SC, all the applications possess the same look and feel
based on configured menus.

Apart from a common interface, the user applications developed for the SC share the same designing
criteria.

2.1.1 Inventory

The Inventory is a general purpose environment which allows storing the information of the physical and
logical elements, and the services associated to each element:

e Provides an open data model which allows to store the desired elements and attributes and to
particularize it for the needs of each client.

e The definition of the data model, relationships and operations over each Inventory element is
performed declaratively through XML files and is object oriented.

For further information, see the document HP Service Activator — Inventory Subsystem.
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2.1.2 User management

The UAG, given with the SC, provides all the necessary features that allow an easy, graphical
management of either any configurable element or the permissions applied on them.

Every element managed through this GUI is explained in detail in further sections. Some of these elements
reference the SC, and the other reference the Inventory application.

A brief description of the elements involved in the SC management can be seen below:

e Users: the ones logging on the SC.

e Roles: grouping of common permissions for their associated users.

e Teams: user groups with the same (or at least very similar) privileges.
e User sessions: the logged on users information.

e Account profiles: logging on features of each user.

e Applications: the available user applications.

Elements involved in the Inventory application are:

e Inventory views: tree representations of the data stored in the database.

e Branches: the branches of the different inventory views.

e Stored searches: advanced searches on the beans stored in the database for further reference.

e Filters: personal restrictions applied over inventory trees.
Depending on the kind of user (super users, team administrators or normal users) there will be more or
less operations allowed.

Users can also be managed remotely thanks to the User RMI Manager. The URM will publish some
methods which can be used from other applications to manage the user configuration. Those methods
will be explained in detail later.

2.1.3 Integration with HPSA

SC provides several mechanisms for the integration with HPSA, establishing an easy manner to access the
HPSA and invoking activation tasks over the system.

There are also predefined applications integrated with HPSA that can be deployed into the SC, offering
this way a high amount of solutions based on this tool.
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3 Solution Container

Every user application is deployed into the SC.

In this section there will be reviewed the main concepts involved in the SC development.

3.1 Single entrance point
There is only a single entrance point to access the SC where the user must enter a valid username and
password and, in base of his account, there will be loaded the menus which of his available applications.
The URL to access the SC is:
hitp://localhost:8089/activator/jsp/future-qui/hpac.jsp

where localhost may be substituted by the server’s IP.

The figure below shows the web page which is always shown to log on the SC.

Tl ol STl B T T

1

Applicationd. container

Fig. 2: log on

3.2 Solution Container Structure

The SC has a well defined visual structure which divides the screen in several modules, each of them with
a specific functionality.
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3.3

3.4

VIEWS MENU

STATUS MENU

4 STATUS >

-

Fig. 3: SC screen structure

The following sections describe the main characteristics of these modules.

The view menu

Provides access to the different user applications. It is loaded the first time the user enters the SC (just
before the log on) and remains without changes while the user session lasts. Each user application
includes one or more menus in the views menu bar.

»File | » Search | » Administrator | » Inventory | » Help (O) |

Login information:

» Login date: Wed Oct 15 16:53:32 CEST.
» Last login date: 2008-10-15 16:48:01.0

» User ip. 16.38.37.15

» Failed attempts: 0

Fig. 4: Views menu

As it can be seen in the example above, the user may access to the UAG (menus Search and
Administrator) and the Inventory application (menu Inventory). The other menus (File and Help) belong to
the SC.

The views

Once an application has been selected in the views menu this view frame can contain:

» File | » Search | » Administrator | » Inventory | » Help (O) |
User: Associated roles:
» Hame: sdmin » Restricted Ho » futuregui ~
» Real name: Administratar » Super user: Yas » eop
» Company HE » Locked account o » ummadmin
» Description: Usr sdministrator » Password never expires: Yas » sosa3
» Language: English » loskmanager
» concurrentworkflows .
it
» User

Fig. 5: View example

e Component information: it is the one shown in the previous figure. It presents the available
data of the selected component. SC provides APIs and design guides for the quick
development of these kind of views.
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» File | » Search | » Administrator | » Inventory | » Help (O) |

» User search

» Real name » Restricted
» Name ‘ | ¥ Vs “ No
" | » Company » Super user
£ Yes * No

Fig. 6: Search example

o Component search: it presents a form through which a component can be located. The form
submitted becomes a query to get a list of components. Once the component has been
selected the SC loads its information view. The SC provides the needed functionality to
automate this task.

The data load in this frame will be referred from now on this document as “actual view”.

3.5 The status menu

The status menu is associated to the actual view and contains the operations that can be executed over
the selected component which data is being showed.

They are showed just below the view space and remains there while the user is working on the same
component.

G}

Fig. 7: Status menu

3.6 The status space

This space is placed below the status menu. Each time a task performed over a selected component is
fired, the result will be shown here.

In this space there will be launched the operations over a component and the user interaction can be
carried on.
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» File | » Search | » Administrator | » Inventory | » Help (D) |
User: Associated roles:
» Hame: admin » Restricted No » futuregui
» Real name: Administrater » Super user. Yas » ummadmin
» Company: HP » Locked account: Mo » lockmanager
» Description: User sdministrator » Password never expires: Yes » concurrentworkflows
» Language: English » inventory
» User
User edition
» Name:* admin » Real name:* \Administrator
» Company:* HP » Restricted: * 9
» Password never
» Super user* * ve= © Mo e * ves Mo
» Description:* User administrator
Settings
» Language:* English b
Teams
» User's team:* default + | » Administrator:* Fives T ho
Associated roles
. futuregui
ummadmin
lockmanager
concurrentworkflows
inventary

Fig. 8: Status example

Each time the user interacts with a component the status is being modified. Checking this status the SC
enables or disables the available component menus.

Imagine for instance an application performed for text file edition. The Save file option will only be
enabled when the text file has been modified. Modifying the file means a change in the status, which
results in the enabling of the menu Save file. This principle is the same followed by the SC, which allows
defining status that enable or disable certain menu options. SC provides the needed functionality for
defining and managing the status changes.
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4 User Management

4.1

4.2

User Structure

The figure below shows the UML representation of the elements involved in the user management.

Session

1

*

Team User Account profile
&>
1 0..* 1 1
0.* 0.*
Super user
Role
1.* 0.*

Fig. 9: Elements involved in the user management
Users are the ones who can access the SC. There are three possible kinds of users:

e Super users, who have no restrictions at all. They have access over any element and are allowed
to manage every kind of permissions.

e Team administrators, who are allowed to manage permissions only over the elements associated
to their team.

e And normal users, who have no managing permissions, only those given by super users or team
administrators.

Each defined user must have its own account profile, where there are set the logging on features, such as
the password expiration period or the number of wrong logging on attempts before the user becomes
blocked, for instance.

Each user must belong to a team, and only to one. Teams define groups of users with similar privileges.
These privileges can only differ on the accessible roles available for each user.

Each team can have an administrator. There is no limitation on the number of administrator users over a
single team.

Roles define a set of available applications and application menus. Every user associated to a role will
have access to both the applications and the applications menus attached to that role.

A role can belong to one or more teams and there is no limitation on the number of teams associated to
each role. Since roles belong to teams, a user will only be able to access those roles. It is not allowed for
a user to access roles which are not associated to the user’s team.

User Administration

The user administration allows the creation of new users and search already defined ones. Once a user
has been selected, there are several operations which can be performed over him which will be available
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depending on the kind of user who is trying to perform the operation. Since there are operations only
allowed for super users or team administrators, if another user tries to access any of those the next
message will be displayed. The next sections will provide a wide explanation of them.

4.2.1 User Creation

To create a new user it is necessary to reach the menu "Administrator" > "Users" = "New", as it is
showed in the image below.

This operation is available only for super users and team administrators.

» File  » Search [ERSIGMIES(EGIE » Inventory  » Help

» Applications
» Account profiles

Login information: | * Stored searchs »
» Login date: » Inventory views »
» Last login date: » Filters N
» Userip:
» Failed attempts: » Users » |» New
» Teams » |» List
» Roles » | » Sessions
»
»

Fig. 10: Accessing the user creation

By clicking on the “New” menu it should be displayed the page showed on the image below, where
several information is required for the user creation.

= Uit

| = Em n
T eI
et s el mame”
4 :l.ul-nm
R + Bratricied” " v =
& Juper wmepr T .“'."."':::_'“I LR L ™
= Drecrpbon
Salting
= Langgaagac Spaneh w
Tewii
w Unr's tare oatzll v Admeriutrsioe C vge T g
Agaodlaved roles
. LTSRS
L T
> E g

Fig. 11: Creating a new user
The requested fields are:
e Name: the username.
e Real name: the user real name.
e Password: the user password.

e Password confirm: confirmation for user password.
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e Company: the user company.

e Restricted: indicates whether the user has any kind of restriction or not. There is no need of
knowing the restriction applied for the user at this point, that will depend on each application.

e Super user: indicates if the user must be set as super user or not.

e Password never expires: indicates if the user password should expire after the period set in his
account profile or not. If this value is set to Yes, the user will be asked to change his password the
first time he is logged on the SC.

e Description: the user brief description.

e language: the language in which the SC will be displayed for the user. It is selected from a list
with the available languages.

e User team: the team this user will belong to. It is selected from a list with the available teams.
When the one creating the user is a team administrator, this field will be fixed with the
administrator’s team name.

e Administrator: indicates if the user will be administrator of the selected team or not.

e Associated roles: this box shows the roles marked as associated to the user. The list with the
available roles is obtained automatically and depends on the previously selected team.

4.2.2 User listing

All the already existing users can be listed by accessing the menu "Administrator" > "Users" > "List", as
it can be seen in the image below.

» File | » Search [PYGLINE{E G » Inventory | » Help

. » Users » [» New Associateq
» Name: » Roles » | w List | » futuregui
» Real name: - =
» Applications 3
» PP ? kecoun t Ne
» » Account profiles » [rd never expires: es
» Language: speTE

Fig. 12: Accessing user list

found users is displayed. Results are listed from ten to ten users, so it is p055|b|e to navigate over the next
and previous results. It is also possible to sort results by either of the displayed columns.
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» File | » Search  » Administrator | » Inventory | » Help

» Real name » Restricted
C Yes & No

l:l » Company » Super user

© Yes & No

Found users

Identifier Name Description Real name Company Restricte
1 admin Usuario administrader Administrador HP true
2z leti une leti hp false
5 usert usuario 1 pass never expired user! hp false
4 user2 dd user2 hp false
& usuaricprueba usuaric prueba usuaric prueba hp false
S registros encontrados, mostrando todos los registros. Pagina 1
Exportar: CSV | Excel | XML | PDF
Fig. 13: User list
Clicking on a result will display the selected user information on the screen, as it is shown on Fig. 16: //£

User informationFig—8:Shewing-userinformetion.
4.2.3 User Search

User search is a similar process than listing them.

To access the user search select one of the two available options below the menu “Search” > “Users”,
which allow to find users "by name" or to perform an "Advanced" search.

ERSL-EIM » Administrator | » Inventory | » Help
» Stored searchs »
» Inventory views

» Filters

» Users

»
»
% | = By name

» Teams » |
»
»
»

» Advanced

» Roles
» Applications
» Account profiles

Fig. 14: Searching users

If the desired option has been to search users by name, it is requested to enter the user name. This
searching option will not return a list of results but a single user if it has the same username or an error if
no result is found at all.

» File | » Se; » Administrator | » Inventory | » Help

» User search

Fig. 15: Searching users by name
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For example, let's perform a user search by name using the username admin. Since that user is found
among the existing users, his information is displayed. At this point, operations over this user, explained
in the next sections, can be performed.

» File  » Search | » Administrator | » Inventory | » Help

User: Associate|
» Name: admin » Restricted » futuregui
» Real name: Administrador » Super user: » ummadmi
» Company: HF » Locked account: o

» Description Usuaric sdministrador » Password never expires: Yas

» Language: English

Fig. 16: User information

If the desired option has been to perform an advanced user search, then the page in the image below will
be displayed.

» File | » Search | » Administrator  » Inventory = Help

» User search

» Real name » Restricted

2 Name [ ] T Yes € Mo
» Company » Super user

 Yes & MNo

Fig. 17: Advanced user search

As the fields become filled (it is not necessary to fill all of them), advanced searches can be performed by
clicking on the Search button at the right side. The image below shows an example of an advanced

search.

» File  » Search | » Administrator | » Inventory  » Help

» User search

» Real name » Restricted

» Name [ CYes F ot
usu3 » Company » Super user

Ihp—l © Yes & No

Users found

Identifier Name Description Real name Company Restricted

3 usu3 hp false

Found one record. Page 1
Export: CSV | Excel| XML | PDF

Fig. 18: Advanced user search results
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4.2.4 Operations over a user

The next sections explain the operations which can be performed over a selected user. This selected user
can be reached by any of the previous steps, such as user creation, user listing or a user search.

4.2.4.1 User edition

Once a user has been selected, the first available operation which can be performed over it is the one
which allows editing the user information.

To edit the stored information it is necessary to access the menu “User” > “Edit” as it is shown in the
image below.

» File ' » Search | » Administrator  » Inventory =

User: Associateq
» Name: us » Restricted No » futuregui
» Real name: us » Super user Yes

» Company: hp » Looked acoount: No

» Description: us » Password never expires: Yas

» Language: Spanish

» User
» Edit

» Save

» Password

» Delete

» Unlock account
» Permissions

» Lock account

Fig. 19: Accessing the user edition

The user information is displayed at the status space in editable fields. Once these values are updated
properly, changes are stored by clicking the “User” - “Save” menu.

» File | » Search » Administrator | » Inventory  » Help

User:

Associate|
» Name: usertest » Restricted No » futuregui
» Real name: usertest » Super user: No » ummadm|
» Company: h » Locked account No
» Description: usertsst » Password never expires: No
» Language: Spanish

» User

» Edit
» Save
» Password
» Delete | » Real name:* |Usertest
» Lock account | » Restricted:* " ves * o
» Permissions
F o » Pa_ssv\.‘vﬂord never C ves & o

» Unlock account expires:

» Description:* ‘userlest

Settings

» Language:* ‘Spamsh lv]

Teams

» User's team: | Team2 [v] »administrators e & g

Associated roles

RolTeam1 futuregui
ummadmin

Fig. 20: User edition

The fields on the screen above are the same as the ones needed for the user creation. See the section
dedicated to the Error! Reference source not found.User creation for further information. Note that
the user name cannot be modified.

25



HPSA Extension Pack
Solution Container - User Reference

4.2.4.2 User deletion

For a selected user it is possible to delete it by selecting the menu “User” - “Delete”.

» File | » Search | » Administrator | » Inventory | » Help

» Description » Password never expires: Mo

» Language

User: Associatd
» Hame: » Restricted: No » futuregui
» Real name: » Super user: No » ummadny
» Company. » Locked account: No

» User

» Edit
» Save
» Password
‘ » Real name:* |usertest
» Delete
» Lock account ‘ » Restricted:* C ves ™ o

» Permissions
= No

» Unlock account

Password never
: - C ves & wo
expires:

» Description:* |usertest

Settings

» Language: |Spanish

]

Teams

» User's team:* |Team2

[v] » Administrator:* C ves Mo

Associated roles

RolTeam1

futuregui
ummadmin

Fig. 21: User deletion

Before a user is deleted a confirmation message is displayed. Accepting will result on the user deletion.
Cancelling will cancel the operation.

» File | » Search | » Administrator | » Inventory | » Help

User:

Associate]

» Hame: » Restricted:
» Real name: » Super user

» Company: » Locked account:

» Deseription usertest » Passwerd never expires:

» Language: Spanish

» User

User edition

» futuregui
» ummadn

» Name:* |userlesl

| peal names lhsarnast

» Company:* |hp

» Super user:”* ™ ves o

» Description:* |userlesl

Settings

OPERATION CONFIRMATION

2 Are you sure you want to delete this user?

» Language:* |Spam5h

¥

Teams

» User's team:* |Team2

[v] » Administrator* {yes .l ho

Associated roles

RolTeaml

futuregui
ummadmin

[

Fig. 22: Confirmation for user deletion

4.2.4.3 User permissions

User permissions can be seen for a selected user by clicking the “User” - “Permissions” menu. This is
only an information section, there is nothing configurable here.
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» File | » Search » Administrator  » Inventory » Help

User:

» Hame: usu3
» Real name: usu3
» Company: he

» Description: usud

Associated
» Restricted: No » futuregui
» Super user No » RolTeam1
» Locked account: No

» ummadmi
» Password never expires: No
» Language: Spanish

» User
» Edit
» Save
» Passwaord

» Delete

» Lock account
» Permissions

» Unlock account

Fig. 23: Accessing user permissions

The next screen shows a list of user applications and menus, and inventory views and operations, for
which user has permissions.

» File | » Search  » Administrator | » Inventory | » Help

User: Associatec
» Hame: usu3 » Restricted: No » futuregui
» Real name: usu3 » Super user, No » RolTeam
» Company: hp » Looked acoount: No » ummadmil
» Description: usu3 » Password never expires: No
» Language: Spanish
» User

Access permissi blished for applications and menus

ummadmin
future-gui

Access permissions establiched for inventory views

O
O

Fig. 24: User permissions

The upper list in the screen above shows the available user applications (in dark blue color) and the not

accessible ones (faded). Accessible menus for each application can be seen by clicking on their
associated “+” icon.

The list at the bottom shows the inventory views accessible for the user. As it happens with the
applications, operations can be seen by clicking on their associated “+” icon.

When either a user application or an inventory view has no children, that is, menus or operations, the “+”
icon is replaced by a dot icon.

4.2.4.4 User Lock/Unlock

Users can be locked to assure they will never ever be able to log on the SC while they are not unlocked.

To lock a user, click the “User” & “Lock” menu and press the Accept button on the confirmation message
that will be displayed before the operation is completed.

When a user is locked, the “User” = “Lock” menu is replaced by the “User” = “Unlock” menu, which
allows unlocking a locked user the same way it was explained for locking it.

This operation is only available for super users and team administrators.
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4.2.4.5 Password Update

a. Own user password update

Any user can change its own password by clicking on the “File” > “Change password” menu, as it can
be seen in the image below.

EAN(:W » Search | » Administrator | » Inventory | » Help
» Change password
» Settings 11:35.10 CES...
» Add to favorites (ST

» Exit

Fig. 25: Accessing the own user password update

A new screen is displayed (see the figure below) which asks for the old and new passwords.

» File | » Search | » Administrator | » Inventory | » Help

» Please, change the password for the user: Admin
Edit password

» Old Password: | |

» Password

— | |
confirmation:

Fig. 26: Own user password update
The asked field information is:

e Old password: the old password is required to assure that anyone but the own user is allowed to
update his password.

e Password: the new password, which must fulfill the security policies.

e Password confirmation: the user is asked to retype his new password just to assure that there are
no errors in the new one.

To save the new password, click the “Actions” > “Save” menu on the status menu bar. If no security
policy has been violated, a message will confirm that the operation has been successfully performed.
Otherwise, an error message will be displayed, the password update will not be performed and the user
will be asked to set another new password.

b. Updating another user’s password

This option is only available for super users and team administrators and forces the password change for
the selected user. Thus, super users and team administrators can reset the passwords of the other users.

28



HPSA Extension Pack
Solution Container - User Reference

Changing any user password from the “User” - “Change password” menu stores a new password for
that selected user. Since this option is only available for super users and team administrators, the entered
password must not fulfill the security policies. The owner of the reset password will be asked to change it
again the next time he is logged in.

c. User password expiration

User passwords are valid along a period of time, as it is set by the active account profile (see the section
about Account Profiles for further information). This will never happen to users whose passwords are
marked as never expire.

When a user whose password is near to expire gets logged on the SC, an advertisement like the one in
the figure below will be displayed before granting him access to the SC. Thus, he will be able to update
his password as it was explained in the previous sections.

Your password is almost expired
0 days left for yvour password to expire

Fig. 27: Password almost expired

4.2.4.6 User settings

Actually there are no other settings for each user but the desired language in which the SC should be
displayed.

Any user can set the language in which the SC should be shown before he gets logged on.

To change the user settings it is necessary to click on the “File” = “Settings” menu from the view menu
bar. Then the user must select the desired language from the list with the available ones and press the
button on the right. This will warn the user with an advertisement in which it is noticed that he will be
asked to log in again. At this point, if the user clicks on the Accept button he will be redirected to the log
on page. Otherwise no action will be performed.

» File  » Search  » Administrator | » Inventory  » Help

» Language

English [v] H

Fig. 28: User settings
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4.3 User session administration

User sessions can be managed through the administration GUI by clicking Administrator = Sessions.

» File | » Search [ERNIWHIENEGIE » Inventory | » Help

Login information: | * Stored searchs B

» Login date: » Filters 5
Sl i » Inventory views »
» User ip:
» Failed attempts: » Users »
» Sessions
» Roles

» Applications

» Account profiles
» SOSA

» ECP

» Sosal

B ow ¥ ow oW oW oW

Fig. 29: Accessing the user session administration

It gives information about the different users connected, the number of sessions created for each user,
their IP, and their log on date.

It also allows forcing the logging off of the found users.

» File  » Search  » Administrator | » Inventory | » Help

User sessions actually logged on the FG

& Admin (1]
IP: 127.0.0.1; Logged on: Mon Sep 28 11:35.10 CEST 2008

Fig. 30: User session administration

The connected users will be shown as follows:

+user Nane [ N]|
+user Nane [ N|
I1P:172.1.1.1; Tinme Access: Tue Jun 24 14:54:32 CEST 2008
I P:172.1.1.2; Tinme Access: Tue Jun 24 14:54: 32 CEST 2008
+user Nane [ N]|
I1P:172.1.1.3; Tinme Access: Tue Jun 24 14:54:32 CEST 2008

N is the maximum number of sessions which can be logged on with the same username.

4.3.1 User forced log off

At this point users can be forced to log off. To do so, the user session must be selected (clicking on the
row representing it) and then clicking on the “Operations” - “Log off” menu.
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» File  » Search | » Administrator = » Inventory » Help

» Operations
» Log off
Iser sessions actually logged on the FG

= Admin [1]

IP: 127.0.0.1; Logged on: Mon Sep 29 11:35:10 CEST 2008

Fig. 31:

Forced log off

4.4 Team administration

The next sections explain the available operations which can be performed for team administration.

Since in HPAS 5.1 teams are optional, the operations described below and every other reference to
teams in any other section about the user management will be disabled when teams are not enabled.

4.4.1 Team creation

This operation is only available for super users.

A new team may be created by clicking on the “Administrator” > “Teams” - “New” menu.

The screen accessed then (see the figure below) allows the super user to define a new team.

There are several fields which must be filled:

Name: the team name.
Description: the team description.

Usernames per session: the number of users with the same username which can be logged on the
SC at the same time. A value of zero (0) in this field indicates that there is no limitation on this
feature.

Associated users: the users belonging to this team. If the selected users were previously
associated to any other team that association will be removed to assure that there are no users
belonging to more than one team.

Team administrators: indicates which of the associated users are set as team administrators. There
is no limitation on the number of administrators a team can have.

Associated roles: the roles associated to this team. Since a role can be associated to more than
one team, the selected roles will not be removed from any other team.
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» File  » Search EWGINHIE{EGIE » Inventory | s

Help
» Stored searchs »
» Inventory views »
» Filters »
» Users »
» Teams » | » New
» Roles » | » List
» Team » Applications »
» Account profiles »
Team creatior
 Hames ‘ » Usernames per
. session:”
» Description:” ‘
Associated users
» Not associated: » Associated: » Administrator:
usu3 .
B
Admin E
admin
Associated roles
» Not associated: » Associated:
inventory futuregui
ummadmin
RolTeam1

Fig. 32: Team creation

4.4.2 Team Listing

This operation is only available for super users and team administrators.

The already defined teams may be listed by clicking on the “Administrator” > “Team” > “List” menu, as
it is shown below.

» File  » Search PEGINNIENEGIE » Inventory  » H
» Team search | » Stored searchs »
» Inventory views »
» Filters » » Description » Usemames per session
» Users » ] [
» Teams » | » New
» Roles » |» List
» Applications »
» Account profiles »
Teams found
Name Description Usernames per session
default Default team 1
Acebo Acebo 0
Team1 consuttar o
3 records found, showing all records. Page 1
Export: CSV | Excel| XL | FOF

Fig. 33: Team listing

A list with all the already defined teams is displayed below. Teams are shown from ten fo ten, so if there
are more than ten teams it will be necessary to move over the next or previous ones. It is also possible to
sort the results by any of the displayed columns.

Clicking on one of the showed results will display the team information on the view space.
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» File | » Search  » Administrator = » Inventory | » Help

ITeam: Users:
» Hame: Team1
» Description: consultar
» Usernames per session: 0

Roles: Associate|
» Users number: ] » Humber of roles: 3

Fig. 34: Team information

4.4.3 Team search

Team search is a similar process than listing them.

To access the team search select one of the two available options below the menu “Search” > “Teams”,

which allow to find teams "by name", or to perform an "Advanced" search, or find “my team”, that is,
the team the user belongs to.

» File [N » Administrator | » Inventory | » Help (O) |
Login inf * Lock Manager B
» Login d » List Histaric Jobs Ce=T
»Lastlol | Jsarg . P
» User ip
» Failed { » Teams » |» By name
» Roles » |» Advanced
» Applications » | » My team
- » Account profiles »
» Inventary views »
» Filters »
» Stored searches »
» ECP »
» Sosal »

Fig. 35: Team search

If the desired option has been to search teams by name, it is requested to enter the team name. This

searching option will not return a list of results but a single team if it has the same name or an error if no
result is found at all.

» File | » Search  » Administrator | » Inventory | » Help E’] -
» Team search

Fig. 36: Team search by name
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For example, let's perform a team search by name using the name default. Since that team is found
among the existing teams, its information is displayed. At this point, operations over this team, explained
in the next sections, can be performed.

» File | » Search  » Administrator | » Inventory | » Help B’] -
[Team: Users: Roles: Associated users:
» ame: default » Users number. 3 » Humber of roles: 7 > admin
» Description: Default team » juan
» dibi

» Usernames per session: 0

» Team

Fig. 37: Showing team information

If the desired option has been to perform an advanced team search, then the page in the image below
will be displayed.

» File | » Search  » Administrator | » Inventory | » Help B’] -
» Team search

» Name » Description » Usernames per session

Fig. 38: Advanced team search

As the fields become filled (it is not necessary to fill all of them), advanced searches can be performed by
clicking on the Search button at the right side. The image below shows an example of an advanced
search.

»File | » Search | » Administrator | » Inventory | » Help (O) |

» Team search

» Name » Description » Usernames per session

Teams found

Name Description Usernames per session

defautt Default team 0
Found one record. Page 1
Export: C5V | Excel | XML

Fig. 39: Advanced team search results
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4.4.4 Operations over a team

The operations which can be performed over a selected team (edition and deletion) which information is
being displayed in the view space are explained in the next sections.

4.4.4.1 Team edition

A team can be edited by clicking on the “Team” > “Edit” menu. It is only accessible for super users and
team administrators. A team administrator can only edit its own team.

The editable fields for a team are the same as it was explained in the section Error! Reference source
not found.Team creation.

» File | » Search  » Administrator | » Inventory | » Help

Team: Users: Roles: Associated users:
» Name: default » Users number. 3 » Humber of roles: 7 » admin

» Description: Default team » juan

» Usernames per session: 0 » dibi

~
Team creation

» Names* |defaut | » Usernames per P ]

session:*

» Description:* |Defaultteam |

Associated users

» Not associated: » Associated: » Administrator:

o =
-
Associated roles
» Not associated: » Associated:

futuregui g
inventory

ummadmin
sosal

El concurrentworkflows
lnrlmananar

Fig. 40: Team Edition

To save the updated fields, click on the “Team” = “Save” option.

4.4.4.2 Team deletion

A selected team can be deleted by clicking on the “Team” > “Delete” menu. The only team which cannot
be deleted is the default team.

This operation is only available for super users.
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» File | » Search [EWNGMIEEGIE » Inventory | » Help

e » Stored searchs »
= » Inventory views »
Dl e » Filters El
» Enabled:
» Users B
» Teams B
» Roles B
» Application » Applications »
» Account profiles » ‘1 New I
[ LSt |

» File | » Search  » Administrator | » Inventory

» Account profile

Account profile creation

» Hame? |

» Password expire dayse

[
» Humber of previous passwords: |

» Password format checker class:

w H® maximun inactived days: |ED
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» Account profile
» Save
ccount profile creation

» Hame:”

» Pagsword expire days:*

» Humber of previous passwords:
» Password format checker class:

» N® maximun inactived days:

» Adrministrator

» Account profile | » Stored searchs »
» Inventory views »
» Filters 3 .
» U ’ » Mumber of previous passwords » Password expire days
» Users » *I
» Teams » ‘ ‘ | ‘
» Raoles »
+ Appications .|
» Account profiles » |» Mew I
—Aceountprefil
I'» List I
1 )
Identifier Name Password expire days Number of previous passwords Password format checker class N° maximun inactived
1 Default 20 3 com.hp.spain. futuregui.pwd.SimplePazswordFormatChecker 60
Found ene record. Page 1
Export: CSV | Excel | XML | PDF

» File | » Search | » Administrator » Inventory | » Help

lAccount profile:

» Hame: Default
» Humber of previous password 3

» Password expire days: 20

» H® maximun inactived days: 50
» Active: ez

profiteeditiom

» Password format checker elas com hp spain futursgui pwd

» Account profile

» Hame:*

» Password expire days:*

» Number of previous passwords:
» Password format checker class:

» N® maximun inactived days:

|Defau\t

|20
[3

|com hp.spain.futuregui.pwd.SimplePasswordFormatChecker

[e0
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PR-CEIM » Administrator | » Inventory | » Help

» Stored searchs »
IAccount
» Hame: | » INventory views »
»Humbe| , Fitters N
» Passu|
» Passw| » LUsers »
» NEmax .
» Active] » Teams »
» Roles »
» Applications »
» Account profiles » ‘,o By name I
» Advanced |

» Search | » Administrator | » Inventory | » Help

» Account profile search

» Mame

EEETR— - |

» File | » Search | » Administrator  » Inventory | » Help

» Account profile search

» Mame » Mumber of previous passwords  » Password expire days

Found account profiles

Identifier ~Mame Password expire days Number of previous passwords Password format checker class N°® maximun inactived
1 Cefault 20 2 com.hp.spain. futuregui.pved. SimplePasswerdFormatChecker &0
3 prueba 3 2 com.hp.spain. futuregui.pwd.SimplePasswordFormatChecker 1

2 registros encontrados, mostrando todes los registros. Pagina 1
Exportar: CSW | Excel| XML

Fig. 48: Advanced account profile search
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» File  » Search | » Administrator

» Inventory | » Help

Account profile:

» Name: Defsult
» Number of previous password 2

» Password expire days 20

» Password format checker clas cam.hp
» N° maximun inactived days: 80
» Active: Yas

in futuregui_pwd

» Account profile

File | » Search | » Administrator

|Account profile:

» Hame: Default
» Humber of previous password 2

» Password expire days: 2

» Password format checker clas oo
» N® maximun inactived days:
» Active:

<a

» Account profile

» Password format checker class:

» N* maximun inactived days:

» Edit
» Save
|Defau\t
» Password expire days:* |ZU
» Humber of previous passwords: |3

|com hp.spainfuturegui pwd SimplePasswordFormatChecker

[70
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» File | » Search | » Administrator
\Account profile:
» Hame:

» Inventory | » Help

» Humber of previous password 2
» Password expire days:

» Password format checker clas
» H® maximun inactived days: 1
» Active:

» Account profile
» Edit

spain futureg

» Activate account profile
» Delete

OPERATION CONFIRMATION

Are you sure you want to delete this account profile?

Accept Cancel

» File | » Search  » Administrator | » Inventory | » Help

[Account profile:

» Name: APTest
» Humber of previous password &

» Password expire days 50

» Password format checker clas

» Active:

» Account profile
» Edit

» Activate account profile
» Delete
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S Permission management

5.1 Permissions structure

User permissions are established through roles.

There are two main permissions which can be managed: user applications and menus in one hand, and
inventory views and operations in the other.

Operations 0. 1 [inventory views| 0.* 0.* Role Applications Menus

——® >
0.* 0.* 1 0.*

Fig. 4154: Permissions structure

A role can have access to n applications, and each menu belongs to a single application. To access the
application menus it is necessary to specifically set permissions between each role and each application
menu.

The situation with the inventory views is very similar. A role can have access to n inventory views, and
each inventory operation must be associated to a single inventory view. To access either an inventory
view or ifs operations it is necessary to set permissions for both of them.

5.2 Role administration
Role administration can only be performed by super user.

5.2.1 Role creation

This operation can only be performed by a super user.

A new role can be created by clicking on the “Administrator” - “Roles” - “New” menu.

» File  » Search PENINNIENEGIE » Inventory  » Help
» Stored searchs »

Team: Users: Roles: Associaty
» Name: » Inventory views » » Users number. 0 » Number of roles:
» Description: » Filters N
» Usernames per sess
» Users »
» Teams »
» Roles 5 | » New
» Team » Applications » | » List
» Account profiles » |

Fig. 4255: Accessing role creation
Then, the screen in the figure below is displayed.
As it can be seen, several fields must be filled before the role is created.
e Name: the role name. It cannot contain space characters.

o Description: the role brief description.
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e Not associated teams: available teams to associate to role

e Associated teams: teams associated to the role. As they become associated to the role, they are
removed from the Not associated teams box.

e Associated users: users associated to the role. The available users are refreshed as the role is
associated to different teams.

» File | » Search | » Administrator | » Inventory | » Help

» Role
» Save
ole creation
» Name:* |Ru\eDoc ‘ » Description:* ‘documenlat\on
Teams
» Not associated: » Associated:
Teaml default
Acebo
Associated users
» Not associated: » Associated:
admin Admin
usu3
B

Fig. 4356: Role creation

After filling the fields it is necessary to click on the menu “Role” - “Save” to store the new role.

5.2.2 Role listing

All the already defined roles can be listed by clicking on the "Administrator" = "Roles" = "List" menu.
This will display an ordered list where results are shown from ten to ten, and they can be sorted by
columns.

» File | » Search | » Administrator | » Inventory | » Help

» Role search

» Mame » Description » Search

Roles found

Identifier Name Description

1 futuregui Grupo con los accesos basicos a la Future GUI
2 inventory Grupo con acceso al inventario de la Future GUI
ummadmin UMM administration group
78 RefTeam1 RolTeam1
4 records found, showing all recerds. Page 1
Export: CSV | Excel| XML | PDF

Fig. 4457: Role listing

Clicking over one of the printed results will display the selected role information, as it is shown in the
image below. At this point operations over the selected role can be performed. These operations will be
explained in the next sections.
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» File  » Search | » Administrator | » Inventory | » Help

Role: Users: Applications: Associated
» Hame: RolTeam1 » Users number 1 » Humber of applications: 0 » admin
» Description RolTesm1

Fig. 4558: Role information

5.2.3 Role search

Role search is a similar process than listing them.

To access the role search select one of the two available options below the menu “Search” - “Roles”,
which allow to find roles "by name" or to perform an "Advanced" search.

» File » Administrator | » Inventory | » Help

Role: | » Stored searchs » Users: Applcatons: p—
» Hame: | » Inventory views »
» Descrif y Filters .
» Users w

» Teams »
B

B

B

» Users number 1 » Humber of applications: 0 » admin

» Roles
ERALEY » Applications
» Account profiles

» By name
» Advanced

Fig. 465%: Accessing role search

If the desired option has been to search roles by name, it is requested to enter the role name. This
searching option will not return a list of results but a single role if it has the same role name or an error if
no result is found at all.

» File | » Search | » Administrator | » Inventory | » Help

» Role search

» Name

Fig. 4760: Role search by name
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For example, let's perform a role search by name using the name RolTeam1. Since that role is found
among the existing roles, its information is displayed. At this point, operations over this role, explained in

the next sections, can be performed.

Users: Applications: Associate
n Users number: n Number of applications: 0 » admin

» File | » Search | » Administrator | » Inventory | » Help

RolTeam1

» Name:
RaolTeam?

» Description:

Fig. 486+: Role information

If the desired option has been to perform an advanced role search, then the page in the image below will

be displayed.
» File | » Search | » Administrator | » Inventory | » Help
» Role search
» Name » Description
| |F‘\0ITeam1 ‘
Roles found
Identifier Name Description
RolTeam1 RofMeami

Found one record. Page 1
Export: CSV | Excel| XML | PDF

Fig. 4962: Advanced role search

As the fields become filled (it is not necessary to fill all of them), advanced searches can be performed by
clicking on the Search button at the right side. The image above shows an example of an advanced

search.

5.2.4 Operations over a role
The next operations can be performed by a super user once a role has been selected and its information

is displayed in the view space.
5.2.4.1 Role edition

The role edition can be performed by clicking on the “Role” = “Edit” menu, available on the status menu
bar. The status space will display some editable fields with the role information.

44




HPSA Extension Pack
Solution Container - User Reference

» File  » Search | » Administrator = » Inventory  » Help

Role: Users: Applications: Associate|
» Hame: RolTeem1 » Users number. 1 » Humber of applications: 0 » admin
» Description AolTeam1

Role edition

» Name:* |F‘\0\Team1 | » Description:* |F‘\G\Team1
Teams
» Not associated: » Associated:
default Teaml
2
Acebo
Associated users
» Not associated: » Associated:
admin
=

Fig. 5063: editing role (Il)

These fields are just the same as it was explained for the role creation. See the Role creation section for
further information.

To store the changes performed for the role, click the “Role” = “Save” menu option on the status menu

bar.

5.2.4.2 Deleting roles

Once the role information has been displayed in the view space, that role can be deleted by clicking on
the "Role" > "Delete".

» File | » Search | » Administrator | » Inventory | » Help

Role: Users: Applications: Associatg
» Hame: RolTsm1 » Users number: 1 » Humber of applications: 0 » admin
» Description: RelTzam1
» Edit
» Save
» Delete
‘ » Description:* ‘RolTeam]
» Permissions »
Teams
» Not associated: » Associated:
default Team1
Acebo
Associated users
» Not associated: » Associated:
b admin
e

Fig. 5164: deleting role

Before the role is deleted, the super user will be asked for confirmation.
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OPERATION CONFIRMATION

Are you sure you want to delete this role?
Accept Cancel

Fig. 5265: deleting role confirmation

5.2.4.3 Role permissions

Permissions through roles can be assigned below the "Roles" - "Permissions" menu, and there are two
available options:

e Applications and menus permissions.

e Inventory views and operations permissions.

» File  » Search | » Administrator = » Inventory » Help

Users: Applications: Associatyg

Role:
» Humber of applications: 0 » admin

» Users number: 1

» Hame: RolTeam1
» Description RolTesm1

» Role
» Edit
» Save

» Delete

» Permissions » |p Applications and menus

| » Inventory views

Fig. 5364é: Accessing role permissions

Permissions over applications and menus show every application defined for the SC. The ones in dark
blue colour are associated to the role, and the faded ones are not associated. There is a checkbox at the
right side which allows changing this association.

There is also possible to display the available menus for each application by clicking on the “+” icon.
Each application menu has another checkbox on the right side which allows associating the given menu
to the selected role.

When all permissions over application and menus have been set, it is necessary to click on the “Role” >
“Save” menu to store the changes.

The next figure shows an example of applications and menus permissions.
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» File | » Search | » Administrator | » Inventory | » Help

Role: Users: Applications: Associaty
» Name: RclTeam! » Users number. 1 » Humber of applications: 0 o admin
» Description: RclTeamt
5] r
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
r
r

Fig. 5467: Application and menu permissions

Permissions over inventory views and their operations are managed as it was explained for applications
and menus.

» File | » Search | » Administrator | » Inventory | » Help

Role: Users: Applications: Associats
» Hame: RolTeam1 » Users number: 1 » Mumber of applications: o » admin
» Description: RolTeam1

Role permissions RolTeam1

=] r
-
-
-

r

Fig. 5568: Inventory view and operation permissions

As it was told with the application and menu permissions, when all permissions over inventory views and
operations have been set, it is necessary to click on the “Role” > “Save” menu to store the changes.

5.3 Application administration

Application administration can only be performed by super users. An application can only be created by
developers, so there is no way through the administration GUI to create or delete them.

5.3.1 Application listing

The available applications can be listed by clicking on the “Administrator” = “Application” = “List”
menu in the view menu bar.
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» File | » Search ERNIWLIS(EIGIE » Inventory | » Help

T » Stored searchs »
= » Inventory views »
» Description: » Filters N
» Enabled
» Users »
» Teams »
» Roles »
» Application » Applications » |» List
» Account profiles » |

Fig. 566%: Accessing application listing

Results are listed from ten to ten applications, so it is possible to navigate over the next and previous
results. It is also possible to sort results by each displayed column.

» File  » Search | » Administrator = » Inventory | » Help

» Name » Description

‘ | | ‘ » Search

Found applications

Identifier Name Description

1 future-gui Contenedor de aplicaciones - NIMBA
2 ummadmin Administracion del UMM
2 registros encontrados, mostrando todos los registros. Pagina 1
SV | Excel | XML | PDF

Fig. 5770: Application listing
5.3.2 Application search

Application search is a similar process than listing them.

To access the application search select one of the two available options below the menu “Search” >
“Applications”, which allow to find applications "by name" or to perform an "Advanced" search.

PRSEEUS = Administrator | » Inventory | » Help

lapplicat » Stored searchs »
» Hame: | » Inventory views
» Deserif , Filtarg
» Enable|

» Users

» Teams
» Roles
(Xa2ill » Applications
» Account profiles

» By name

¥ o ¥ ¥ ¥ ¥ ow

» Advanced

Fig. 587+: Application search

If the desired option has been to search applications by name, it is requested to enter the user name. This

searching option will not return a list of results but a single application if it has the same username or an
error if no result is found at all.
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If the desired option has been to perform an advanced application search, then the page in the image
below will be displayed. As the fields become filled (it is not necessary to fill all of them), advanced
searches can be performed by clicking on the Search button at the right side.

» File | » Search | » Administrator = » Inventory  » Help

» Name » Description

fuwe i | |

Found applications

Identifier Name Description

1 future-gui Contenedor de aplicaciones - NIMBA
Se encontro un registro. Pagina 1
Exportar: C3V | Excel| XML | PDF

Fig. 5972: Advanced applications search

5.3.3 Operations over an application

The next operations can be performed once an application can be selected.

5.3.3.1 Application permissions

Application permissions are used to establish the roles which will be associated to the selected
application.

To select this operation it is needed to click on the "Applications" >"Permission" - "Roles" menu, as it
can be seen in the image below.

» File  » Search | » Administrator = » Inventory  » Help

\pplication:
» Hame:

» Description:
» Enabled:

» Application

» Edit

» Save

» Permissions » | » Roles ]

Fig. 6073: Accessing application permissions

The screen below shows the roles that have access to an application. There is a checkbox associated to
each role, which in case of being checked will set the role associated to the selected application.
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» File | » Search | » Administrator » Inventory | » Help

IApplication:

» Hame: umminventary

» Description Inventory views mansgement
» Enabled: Yes

» Application

Roles all d for the

O

0ooo
NN

Fig. 6174: Applications permissions

To store the performed changes it is necessary to click on the "Application" 2"Save" menu.

» File | » Search » Administrator | » Inventory  » Help

lApplication:

» Name: umminventory
» Description: Inventory vi

» Enabled ras

views managemant

» Application
» Edit
» Save

lon umminventory
» Permissions

L futuregui

<l

O inventory

<l

[ ummadmin
[1 RolTeam1

<l

Fig. 6275: Saving application permissions
5.3.3.2 Application edition

This feature allows enabling or disabling applications. Disabled ones will never be accessible, not even
for super users.

» File | » Search | » Administrator | » Inventory | » Help

Application:
» Name:
» Description:
» Enabled

» Application

Application edition

» Name: umminventery » Description: Inventory views management
» Enabled:* " ves T Mo

Fig. 637é: Application edition

Click on the “Application” > “Save” menu in the status menu bar to store the changes.
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Inventory management

The next sections explain how to manage the inventory elements, such as inventory views and their
operations, personalized filters and stored advanced searches.

Inventory view administration

Inventory views can only be managed by super users.

6.1.1 Inventory view listing

All the already existing inventory views can be listed by accessing the menu “Administrator” = “Inventory
Views” = “List”, as it can be seen in the image below.

» File  » Search PEGNNEIEGIE » Inventory | » Help
» Stored searchs »

» Inventory views
» Filters
» Users

» List I

» Roles

»

»

»

» Teams »
»

» Applications »
»

» Account profiles

Fig. 6477: listing inventory views

A list with all the found inventory views will be displayed. Results are listed from ten to ten inventory
views, so it is possible to navigate over the next and previous results. It is also possible to sort results by
either of the displayed columns.

» File  » Search | » Administrator = » Inventory  » Help

» Inventory views

Inventory views

Viewtreeid Name Description Enable

1 Future Tree TEST Future Tree TEST true
2 Future Tree TEST OFF Future Tree TEST OFF true
2 records found, showing all records. Page 1
Export: CSV | Excel| XML | PDF

Fig. 6578: inventory status list

Clicking on a result will display the selected inventory view information on the screen.

6.1.2 Inventory view search

The only search which can be performed over inventory views is the search by name, accessible by
clicking on the “Search” - “Inventory views” = “By name” menu.
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» File EESEEGM » Administrator | » Inventory | » Help

» Stored searchs »
» Inventory views » | » By name
» Filters »
» Users »
» Teams »
» Roles »
» Applications »
»

» Account profiles

Fig. 6679 Inventory view search

To perform the search it is requested to enter the desired inventory view name. This searching option will
not return a list of results but a single inventory view if it has the same name, or an error if no result is
found at all.

6.1.3 Operations over an inventory view

These operations can be performed once an inventory view has been selected and its information is being
shown in the view space.

6.1.3.1 Inventory view permissions

This feature allows establishing the roles which will be associated to the selected inventory view, its
branches and its operations.
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3 Applications container - HP - Microsoft Internet Explorer provided by Hewlett-Packard

File Edit Wiew Favorites Tools  Help

€Eack = £3 - ¥ 2] wn | ) Search ¢ Favorites  4) | 1= ¢ ] - L) Br @ D 3

Address I@ http: [ flocalhost: 5089 activator fjsp/Future-guifhpac. jsp

AR Taool ch onfiguration Management dministrator ventory
Hventory view:
# Marme: WF Launcher Tracker TEST
#» Description: WF Launcher Tracker TEST

Administration of the inventory views

WF Launcher Tracker TEST Roles
Branches
Cataiog Rolas
WiiauncherTest Rolas
Qperations
Borrado Rolas
Lanzamianto Rolas
Buscueds Rolas
Default Rolas
Creacion Roles
¥ iaualzacion Aoligs
Modificacion Rolas

Fig. 6780: inventory view permissions [l]

It is possible to change the roles assigned to it or to its branches and operations just by selecting them
from the emergent menu which spreads when you click on the “Roles” button:
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; Applications container - HP - Microsoft Internet Explorer provided by Hewlett-Packard

File Edt ‘iew Favorites Tools Help

O Back -~ &3 - [x] 2] . | ) Search - Favorites 421 | -~ ] - L] Br @ @ 3

Address I@ http: filocalbost: 5089/ ackivator fjspfuture-guihpac. jsp

onfiguration hia
nventory view:
# Hame: WF Launcher Tracker TEST
# Description: WF Launcher Tracker TEST

Administration of the inventory views

WF Launcher Tracker TEST Roles

Eranches _fuluregui v
Cataiog lmrer[:tn!y I': olas

ummadmin

WLauncherTest SNMPToolRole [ oles

Operations concurrentworkflows [~
Borracio |nckmanager p oles
Lanzarmiento ecp [ foles
Buarueds confMngRead [ |
Defoult confMngPerformBackup [ ;

el confMngSendBackup [ e

Creacion sosa3 [ [oies
Wayalizacion Roies
Modificacion Roles

| Fig. 688+: inventory view permissions [lI]

To store the selected changes over the selected inventory view it is needed to click on the “Actions” >
“Save” menu.

6.2 Stored searches administration
The stored search administration only includes the following operations: search, list and delete. For

information regarding how to save search operations, please refer to the documentation on the Inventory
(‘"HP Service Activator — Inventory Subsystem.’).

6.2.1 Stored search structure

The stored search structure in the SC application is:

User 0.x 0.* |Stored search Team

0. 0.

Fig. 6982: Stored search structure

N teams and n users can be associated to a stored search. This means that many users can be related to
many stored searches which in turn are related to any number of teams.
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The administration of searches includes the ability to search for particular searches or list all the stored
searches. Each stored search selected can be assigned to particular users and/or teams, can be deleted,
or last of all can be executed all over again, to retrieve the data produced by the search.

6.2.2 Search for stored searches

In order to search for stored searches, you have at your disposal several options.
You can search for stored searches by:

- By my stored searches (only the ones assigned to my user will appear).

- By user (only the ones assigned to that particular user will appear).

- By team (only the ones assigned to that particular team will appear).

If you choose search by my stored searches, you must click on “Search” = “Stored searches” = “Search
my stored searches”.

» File [ERSCEIMIM » Administrator | » Inventory | » Help
Login inf ” Stored searchs » | » Search my stored searchs

» Login 4 » Inventory views » | » By user
7 poe e » Filters » |» By team
» User i Y
» Failed { » Users »
» Teams 5
» Roles 5
» Applications 9
N

» Account profiles

Fig. 7083: Search for my stored searches

In the search form, you can search by any of the fields on the screen (by name, associated view and
description).

» File  » Search | » Administrator = » Inventory  » Help

» storedsearch Search

» Name » Associated view » Description
\ \ \ [ \ \

Future Tree TEST
Future Tree TEST OFF

Stored search List

Name Associated view Creator Description

Search 1 Future Tree TEST admin Search 1
Found one record. Page 1
Export: CSV | Excel| XML | PDF

Fig. 7184: Search my stored associated view

If you don’t enter values for any of the searchable fields, the results show you all the stored searches that
the current user has associated.

The form asks for:
e Name: name of the search, this is the name with which the search was saved in the Inventory.

The next field depends on the type of search that was selected.
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If the search was on my stored searches, the next field to be entered will be:
e Associated view: name of the view the search belongs to.
If the current user is a super user all views will appear in the list.

If the current user is an Admin, the views will be limited to those that are associated with the roles it has in
its team.

For the rest of the users, the views shown will be limited to those which are associated with the roles the
user has.

If the search was done by user, a different searchable field’s data appears:
e Associated user: name of the user.
If current user is a super user all users will be listed.
If current user is team administrator the users shown will be those associated to his team.
The rest of the users are not allowed this kind of search.
Last of all if you chose a search by team, a different field appears:
e Associated team: name of the team.
Only a super user has the privileges to perform this action, and he will see all teams.

e Description: description of search.

6.2.3 Stored searches listing

You can list stored searches by selecting the “Administrator” - “Stored searches” > “List”.

» File  » Search [ERSIGMIE(EGIE » Inventory  » Help

Stored search: = S S22 EE L Users:

» Hame: » Inventory views
» Description:

2 Creator:
 Associated view :

Teams:
» Users number 1 » Teams number: 1 » admin

» Filters
» Users
» Teams

» Roles

» Operations » Applications

¥ ¥ ¥ o® ¥ ¥ ¥

» Account profiles

Fig. 7285: Accessing stored searches listing

You will see the next screen
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» File | » Search | » Administrator | » Inventory | » Help

» Stored search Search

» Name » Associated view » Description

| | Mo |

Stored search List

Name Associated view Creator Description

Search 1 Future Tree TEST admin
Found ene record. Page 1

Export: CSV | Excel| XML | PDF

Search 1

Fig. 738é: Stored searches listing
6.2.4 Operations on stored searches

If you click on one stored search from a list, you will see an operation menu. It lets you delete, assign or
show the stored search’s data.

6.2.4.1 Assignation of stored searches

The stored search can be assigned to a team by selecting the “Operation” > “Assign” - “To teams”
menu.

» File | » Search  » Administrator | » Inventory | » Help

Stored search:

Users: Teams: Associatg
» Name: Sesrch 1 » Users number: 1 » Teams number: 1 » admin
» Description: Search 1
» Creator: sdmin
» Associated wiew : Future Tree TEST

» Operations

» Delete

» Save

» Assign » |» Toteams

» Show stored searchs data » To users |

Fig. 748#: Assign fo feams

This operation can only be executed by a super user.

It can also be assigned to a particular user by clicking on the “Operation” > “Assign” > “A user” menu:

» File  » Search | » Administrator | » Inventory | » Help

Stored search: Users:

Teams: Associate|
» Name: Search 1 » Users number: 1 » Teams number: 1 » admin
» Desoription Search 1
» Creator: admin
» Associated view Futurs Tree TEST

» Operations

» Delete

» Save

» Assign » |» Toteams

» Show stored searchs data » To users |

Fig. 7588: Assign a user
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This operation can be executed by both a super user and a team administrator.

» File | » Search | » Administrator | » Inventory » Help

Btored search: Users: Teams: Associatg
[» Name: Search 1 » Users number. 1 » Teams number. 1 » admin

l» Description: Search 1

v Creator: sdmin

I» Associated view Future Tree TEST

Associated users stored search management

Associated users

» Not associated: » Associated
admin

Fig. 7689: Assigning available user

6.2.4.2 Stored searches deletion

Deleting stored searches is done selecting the “Operation” = “Delete” menu.

» File | » Search  » Administrator » Inventory » Help

Stored search: Users: Teams: Associated
» Hame: Search 1 » Users number 1 » Teams number. 1 » admin

» Description: Sesrch 1

» Creator: admin

» Assooiated view : Future Tree TEST

» Operations
» Delete

» Assign »
» Show stored searchs data

OPERATION CONFIRMATION

¢ Are you sure you want to delete this stored search?

| Fig. 7799: Stored searches deletion
A message will be shown to confirm this operation was successful.
6.3 Filters administration

Filter administration includes the search and listing of filters. The operations that can be executed on them
are assigning them to users and teams, to show filter’s data and finally to delete filters from the system.

6.3.1 Filters structure

A filter can be associated to an unlimited number of teams and users.

User 0.” 0.* Filter Team

0.* 0.7
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Fig. 789+ filters structure

N users and team can be associated to a particular filter.

6.3.2 Search for filters

In order to search for filters, you have at your disposal several options.
You can search filters by my filters, by team and by user.

To search for my filters, you must click on “Search” > “Filters” > “Search my filters”:

» File [ERSEEIGHM » Administrator | » Inventory | » Help

» Applications
» Account profiles

» Filter » Stored searchs »
» Inventory views .
» Filters » | » Search my filters lclaled Jiew » Descriptian ’W
» Users » |» By team [Vl | _
» Teams » | » By user I
» Ruoles »
»
»

Fig. 7992: search for my filters

You can search by any of the fields on the screen (name, associated view and description).

» File  » Search » Administrator  » Inventory

» Filter Search

» Name » Associated view » Description
| | ] | |

ENPE e
Future Tree TEST OFF

Filters List

Name Associated view Creator Description Mandatory

Fitter 1 Future Tree TEST admin filer1 false
Found ene record. Page 1
Export: CSV | Excel | XML | PDF

Fig. 8093: search filters associated view
If you don’t enter any field in the form, the results shows you all filters that the current user has associated.
The searchable fields to be entered are:
e Name : filter's name with which it was saved in the Inventory application.

The next field is dependent on the type of search selected previously. If the user selected to search his
filters, the field to set will be:

e Associated view: name of the view.
If the current user is a super user all views will be listed.

If the current user is an Admin, the views listed will include all that are associated with the roles it has in
its team.

For the rest of users, the views listed will be those who are associated with its roles.

59



HPSA Extension Pack
Solution Container - User Reference

Else if the search was done by user, the field to be entered would be:
e Associated user: name of the user.
If current user is a super user all users will be listed.
If current user is team administrator, the users will include all those associated to his team.
The rest of users cannot perform this action.
Finally if the search was done by team, the field will be:
e Associated team: name of the team.
Only a super user can perform this action, and he will see all teams
The last field to be set is:

o Description: the filter description.

6.3.3 Filter listing

The filter listing can be shown by selecting: Administrator>Filters >List

» Administrator
» Filter Search | » Stored searchs

» Inventory views
» Filters

»
»
» |» List I » Description » Search
» Users »
| | 4 | |
»
»
»
»

» Teams

» Roles

» Applications

» Account profiles

Fig. 8194: Accessing filter listing

You will see the following screen:

» File | » Search | » Administrator | » Inventory | » Help

» Filter Search

» Mame » Associated view » Description
| | \ ] | \
Filters List
Name Associated view Creator Description

Fiter 1 Future Tree TEST admin filer1

Found one record. Page 1
Export: CSV | Excel | XML | PDF

Fig. 8295: Filter listing

6.3.4 Operations on filters

If you click on one of the filters listed, you will see the Operations menu. It lets you to delete a filter, to
modify its assignation setftings and to view the filter’s data.
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6.3.4.1 Filter assignation

The assignation of filters to teams is done by clicking on the “Operation” > “Assign” > “To teams”
menus.

» File | » Search | » Administrator | » Inventory | » Help

Filter: Users:

Teams: Associate|
» Hame: Filter 1 » Users number: 1 » Teams number: 1 » admin
» Description: filert
» Creator: admin
» Associated wiew : Future Tree TEST

» Operations
» Delete
» Save
» Show filter data

» Assign » | » To teams

| » To users

Fig. 8396: Assign fo feams
This operation can only be performed by a super user.

The assignation of filters to users is achieved by selecting the “Operation” > “Assign” = “A user” menu.

» File | » Search | » Administrator | » Inventory | » Help

Filter: Users: Teams: Associatg
» Hame: Filter 1 » Users number: 1 » Teams number: 1 » admin

» Description: filert

» Creator: admin

» Associated view : Future Tree TEST

» Operations
» Delete
» Save
» Show filter data

» ASSIgN » ‘ » To teams

|» To users

Fig. 8497: assign to user

This operation can be executed by both a super user and a team administrator.

» File | » Search » Administrator | » Inventory  » Help

Filter: Users:

Teams: Associatg
» Name: Filter 1 » Users number: 1 » Teams number: 1 » admin
» Description: filert
» Creator: admin
» Associated view : Future Tree TEST

Associated users filter management

Associated users

» Not associated: » Associated: s»Mandatory

admin

H @ H @

B @ E @

Fig. 8598: Associated user

When you associate a filter to a user you can make this filter mandatory.
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6.3.4.2 Filter deletion

Filters can be deleted by clicking on “Operation” - “Delete”.

» File  » Search  » Administrator | » Inventory

» Help

Filter:

Users: Teams: Associate|
» Name: Filtar 1 » Users number 1 » Teams number. 1 » admin
» Description filart
» Creator: admin
» Associated view Future Tree TEST

» Operations

OPERATION CONFIRMATION
¢ Are you sure you want to delete this filter?

Fig. 8699: Delete filters

A message will be shown to confirm this operation.
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/7 User RMI Manager

7.1

7.2

7.3

Description

The User RMI Manager allows the remote management of the users defined in the system. The manager
will publish some methods which can be invoked from other applications through a RMI connection to the
configured URL.

The RMI provided with the SC contains a small number of methods with functionality that is exclusive of
the SC and not used in the HPSA. HPSA provides a RMI with a great number of methods which can be
invoked in order to manage users and permissions. See the HPSA documentation related to the
authentication module and the UMM for further information.

Configuration

The URL of the RMI connection can be configured. For further details about how and where configure this
URL read the document HPSA Extension Pack — Solution Container - Developer Reference.doc.

User Management through RMI

These are the methods which are accessible using the User RMI Manager and its parameters:

e auditAction: logs an action in DB. Refer to HPSA Extension Pack — Solution Container —
Developer Reference for more information about the Audit Action Module. Parameters needed:

1. messageType: the message type (i.e. error, info, etc.)
username: the name of the user who performs the action.
workld: |dentifier of the work.

sourceComponent: component upon which the action is referred.

o N

actionPerformed: the name of the action performed.
6. description: a briet description of the action performed.
o getUserRestriction: Gets the restriction (identified by its name) of a given user. Parameters:
1. username: the name of the user.
2. restriction: the restriction name.
o getUserRestrictions: Gets all the restrictions for a given user. Parameters:
1. username: the name of the user.
o isUserRestricted: checks whether a user has restrictions or not. Parameters:
1. username: the name of the user.
2. umm: reference to the HPSA UMM RMI.
e setUserRestriction: adds a restriction to a given user. Parameters:
1. loggedUsername: name of the logged on user.
loggedUserPassword: password in clear text of the logged on user.
umm: reference to the HPSA UMM RMI.

username: the name of the user.

o~ 0N

restrictions: a HashMap with the information about the restrictions as they are needed in
the restriction driver.
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7.4 Example

The steps that must be executed in order to access to the User RMI Manager and check whether the user
admin has restrictions or not will be showed in the next example:

i mport java.rm . Nanm ng;

i mport java.rm . Renot eExcepti on;

i mport com hp. spai n. futuregui .| ogi n. Logi nConst ant s;

i mport com hp. spai n. f ut uregui . users. rm . def. SPI User Managenent RM Def ;
i nport com hp. ov. acti vat or. n/f m User Managenent Manager ;

SPI User Managenent RM Def user Manager = ( SPI User Managenent RM Def )
Nam ng. | ookup (“//1 ocal host: 2000/ userrm ”);
User Managenment Manager unm =

(User Managenent Manager)

request . get Sessi on().get Attri but e(Logi nConst ants. UM ;

user Manager . i sUserRestricted(“adnm n”);

The first step is to get the RMI object which has been published in the URL “//localhost:2000/userrmi”.
This URL is configurable and the value specified here is only for the purposes of the example. Details
about how configure a specific URL for the User RMI Manager are provided in the document “HPSA
Extension Pack — Solution Container - Developer Reference.doc”. The kind of the object published in that
URL is com.hp.spain.futuregui.users.rmi.def.SPIlUserManagementRMIDef.

Once we have access to the User Manager Object the user can invoke the different methods explained
before in the section 6.3.
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8 Audited Actions Management

8.1

8.2

8.3

Every audited action inside the SC may be managed through its administration GUI. There are two main
operations available for the audited actions: searching and listing. Both of them provide a listing of
audited actions which can be removed if necessary.

Listing audited actions

Every audited action may be listed by clicking on Administrator > Audited Actions = List. The figure
below shows the result of this operation.

- Applications container - HP - Windows Internet Explorer

@.\-/-. - http: flocalhost ;8089 activator jsp{future-guifhpac jsp V‘ || % | | L~
archive  Edicion  Yer Faverios Hemamientas  Ayuda @

= »
w IAppIicatinns container - HP I I % - B - & - [5hregns - G Herrsmientss -

» File | » SNMP Tool » Search » Configuration Management | » Administrator = » Inventory  » Help

» Audited actions search

» From » Message type » Component » Detail

\ & 3 | =R |

» To » User » Action » Process

\ = g | a3 |

~
Audited actions found
Date Message type User Component Action Detail Process
2009-08-03 10:24:22.0 INFO admin User Login User name: admin Core
2009-08-03 10:24:19.0 INFO admin User Logout User name: admin Core
2009-08-03 10:24:10.0 INFO admin User Login User name: admin Core
2009-08-03 09:23:26.0 INFO admin User Login User name: admin Core
2009-07-31 09:15:43.0 INFO admin User Logout User name: admin Core
2009-07-31 08:15:21.0 INFO admin User Login User name: admin Core
2009-07-31 08:59:21.0 INFO admin User Login User name: admin Core
2009-07-30 19:48:37.0 INFO admin User Logout User name: admin Core
2009-07-30 18:07:48.0 INFO admin User Login User name: admin Core
2009-07-30 13:52.22.0 ERROR admin Queue Create Queue name: ‘sdfs’ Core
2009-07-30 13:51:35.0 INFO admin Protocol adapter Resume Protocol adapter name: WS_PA’ Core
2009-07-30 13:50.26.0 INFQ admin Manager Pause Wanager name: PERFORMANCE' Core
2009-07-30 13:50:15.0 INFO admin Action executer Lock Action executor name: MWFM_SA_EXECUTOR Core
2009-07-30 13:49:50.0 INFO admin User Login User name: admin Core
2009-07-30 13:46:08.0 INFO admin User Login User name: admin Core =)
2009-07-30 12:19:19.0 INFO admin User Login User name: admin Core
2008-07-30 12:16:33.0 INFO admin User Login User name: admin Core
2009-07-30 12:16:32.0 INFO admin User Logout User name: admin Core
2009-07-30 12:16:17.0 INFO admin User Login User name: admin Core g
% Intranet local #100% -

Fig. 87400: Audited actions listing

Searching audited actions

Instead of listing every audited action, an advanced search can be defined in order to obtain a lesser
number of results. The figure above shows in the view area the different fields available for the search.

Removing audited actions

Once a list of audited actions has been obtained they can be selected by clicking on the different rows.
When selected, they can be removed by clicking on Audited Actions - Delete.

It can be seen in the figure below, where three audited actions have been selected:
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Applications container - HP - Windows Internet Explorer

- hittp: lacalhost 3089 activator jsp/future-gui/hpac.jsp o 42 [x ] [

Archivo  Edicidn  wer  Favoritos  Herramientas — Ayuda

Applications container - HP ] I £ - B - ® - [2rpagna - (G Herramientas +

Administratc

» Audited actions search
» From » Message type » Component » Detail
\ e | 3 | d | |
»To » User » Action » Process
\ & | ¥ C I |
» Audited actions
» Delete
Date Message type User Component Action Detail Process
2009-08-03 10:24:22.0 INFO admin User Login User name: admin Core
2009-08-03 10:24:19.0 INFO agmin User Logout User name: admin Core
2009-08-03 10:24:10.0 INFO agmin User Login User name: admin Core
2009-08-03 09:23:26.0 INFQ admin User Login User name: admin Core
2009-07-31 09:15:43.0 INFO admin User Logout User name: admin Core
2009-07-31 09:15:21.0 INFO admin User Login User name: admin Core
2009-07-31 08:59:21.0 INFO admin User Login User name: admin Core
2009-07-30 19:48:37.0 INFO admin User Logout User name: admin Core
2009-07-30 18:07:48.0 INFO admin User Login User name: admin Core
2009-07-30 13:5222.0 ERROR admin Queue Create Queue nams: ‘sdfs’ Core
2009-07-30 13:51:36.0 INFQ admin Protocol adapter Resume Protocol adapter name: WS_PA’ Core
2009-07-30 13:50:26.0 INFQ admin Manager Pause Wanager name: PERFORMANCE’ Core
2009-07-30 13:50:15.0 INFO admin Action executor Lock Action executor name: ‘MWFM_SA_EXECUTOR Core
2009-07-30 13:49:50.0 INFO admin User Login User name: admin Core
2009-07-30 13:45:08.0 INFO admin User Login User name: admin Core 1)
2009-07-30 12:19:12.0 INFQ admin User Login User name: admin Core
2009-07-30 12:16:33.0 INFO admin User Login User name: admin Core
2009-07-30 12:16:32.0 INFO admin User Logout User name: admin Core
2009-07-30 12:18:17.0 INFO admin User Login User name: admin Core v
% Trtranet lacal F100% -

Fig. 8846+ Removing audited actions
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9 ECP Console

The ECP Console is a web application that allows establishing connections with remote equipments
through the ECP, using several available protocols such as telnet or SSH, for example.

The ECP Console application can analyze execution permissions on any typed command for every user
and thus, the operations that can be performed on remote equipments are strictly controlled.

Also, the ECP Console application allows defining command scripts for each user and remote equipment.

This console can be managed through the ECP console administration GUI, letting the users save scripts,
hosts and command filters in the database.

9.1 ECP Console Components
9.1.1 Hosts

A host determines a specific kind of equipment depending on several parameters:
e Manufacturer: the host manufacturer. Ex. Riverstone
e Model: The host model. Ex. RS
e Version: The host version. Ex. 3000
e Command Template: The template which will be used to send commands to this host.

Each host has a specific Command Template that must be defined by the user. These templates are
explained in detail in the document “HPSA Extension Pack - ECP - Developer Reference.pdf”.

To illustrate the use of command templates we will show an example:

[ TEMPLATE: Do]

[ TEMPLATE: Secti on 0]

${ conmand}

[ TEMPLATE: EndStrPattern "host [\ n]*[#>]"]
[ TEMPLATE: Undo]

[ TEMPLATE: Secti on 0]

The templates used in the host definitions have two differences with the templates described in the ECP
Developers reference. The first one is that these templates can have only one section since they will
execute only one command. The other particularity is that in the host templates the specific command must
not be included, instead of it the string “${command}” must be added in the section. This string will be
replaced by the desired command by the console.

lt's important fo notice that the EndSt r Pat t er n section must be able to match all the possible strings
with which any command can finish its execution.

9.1.2 Scripts

Command scripts are predefined command sequences which are executed using a different ECP template
than typed commands do. For further information about how to define a template check the document
“HPSA Extension Pack - ECP - Developer Reference.pdf”

The command scripts permit a high degree of complexity, allowing the users to define loops and create
variables. Using them it is possible to store complex structures in the database and execute them with a
single click from the console.
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9.1.

9.2

The access to the scripts through the ECP console can be restricted to the desired teams and users. That
can be specified in the creation process of the scrip through the administration GUI, and can be modified
later by editing the script (see section 5.2 for further detail about creation and edition of command
scripts).

3 Command filters

A command filter is a regular expression which matches every typed command. Only those commands
that match a regular expression will be accepted. The other ones will become forbidden and an error
message will be displayed for the user.

Command filters are associated to users. Any typed command is matched with every user’s command
filter and, if it matches one of them then it is accepted and executed.

ECP Console usage

The ECP Console is a web console which allows opening connections to remote hosts using several given
protocols, typically telnet or SSH, sending them commands and printing the obtained command output as
it is made in any traditional console.

@ Future Console - Microsoft Internet Explorer

Archivo  Edicidn Ver Favoritos Herramientas Ayuda :f’
A Y o . ) = 3 = J 2
<) _/J x n: (| & Blsqueda :}\( Favoritos {3 = ii ‘i
N - . - . .
Direccidn ﬂ:lhtu::,r_r'localhost:BDBQIracth-'ator,rOpenConsoIeECP.do V| Ir Vinculos ** | @3
b
32 : snmp set community public privilege read both é
33 : snmp set community private privilege read-write both
!
34 : rtr schedule ping owner HPSE test-name Infovista target 13Z2.168.1_.220 probes 10 data—-size 1024
35 : rtr schedule ping use-pettern owner HPSA test-name Prueka target 1532.168.1.1 probes 10 data-size 1024

1

3¢ : snmp set group rodZ vE level zuth reaed 21l write 211

37 : snmp set user rodrigoZ group rodZ hashed-

password 38:08:68€:1b:08:62:2£:08:4b:3£:08:72:75:08:ea:£f2:08:44:96:08:4a:62:08:4e:0c:08:4c:db:08:68:be:058:4e:
-protocol mds

38 : snmp set group rod3 w3 level priv read A1l write A1l

39 : snmp set user rodrigo3 group rod3 hashed-

password B84:08:55:4c:08:62:54:-08:6c:62:08:52:54:08:42:71:08:47:b1:08:73:£8:08:Ta:b7:08:52:5f:08:4c:45:08:65
-protocol mds

40 : snmp set user rodrigod4 group rod3 hashed-

pegsword TE:0B8:5Z:28:08:71:02:08:4b:59d:08:69:b£:08:483:01:08:66:61:08:46:27:08:6c:ee:08:T8:de:08:65:03:08:6d:
—-protocnl mds hashed-encryption-

key TB:08:52:28:08:71:02:08:4b:5d:08:69:b£:08:48:01:08:668:61:08:46:27:08:6c:ee:08:78:de:08:65:03:08:6d:eB8:0E
41 : snmp set group rodl w3 level nosuth read 211 write A11

42 : snmp set user rodrigol group rodl

nina {config) § A

< | >
= |
&] Listo & Intranet local

The upper bar of the ECP Console provides a button which allows connecting and disconnecting to the
remote equipment, and a second one which shows the available command scripts, if any.

The main space is dedicated to the console output.

At the bottom there is a space for the command typing and a button for their execution.
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To send a command, just type it in the commands text field and press enter or click the Enter button on the
right. If you are allowed to execute the typed command on the remote host you will see the output on the
console. Otherwise an error notification will be displayed.

9.2.1 Command Scripts

When there are available command scripts, clicking on the scripts button will display a screen like the
one below, where the command scripts are listed and can be selected for their execution.

‘2 Future Console - Microsoft Internet Explorer - I:||r5_<|
Archiva Edicidn Ver Favoritos Herramientas Ayuda -.'f
" — n . —~, T ¥
.I ! .I - - B { T'. - h
il \_/'I \ﬂ @ v I\-I .."’h Eosrlzis k:"nf’ Eea @3 [‘“‘ i
Direcddn @ http: /localhost: 8089 /factivator /OpenConsoleECP. do W Ir Vinculos ** EE_,‘
— » Scripts: x =
q
F show configuraticn Descripticn:
Shows the remate host full configuration
Usage:
Mo parameaters nesded
Result:
Displays the full egquipment configuration
|| ||
[ g oo
I@hl Listo % Intranet local

There are two ways to execute a command script.

The first one consists on typing on the command text field the string script: and the command script name:

| scri pt:show configuration [enter] |

The second one consists on clicking on the scripts button and double clicking the desired script on the list.
Then press the Enter button to execute it.

There is an arrow button at the bottom right corner of the command script window which directly executes
the selected script without writing it on the command text field. It is a quicker way for executing command
scripts.
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9.3 ECP Console management

9.3.1 Host management

9.3.1.1 Creating a new Host

In order to create a new host the user must click in the menu “Administration —> ECP -> Hosts -> New”

» File | » Search | » SNMP Tool ERESINGEREGIE » Inventory | » Help
Login information: » Users »
» Login date: » Sessions
» Last login date: » Roles N
» User ip: 0.
» Failed attempts » Teams »
» Applications »
» Account profiles »
» Filters »
» Stored searches 5
» Logs »
» ECP » [» Pool »
» Sosald » |» Scripts »
» Subpool B
» Host » | » Mew
» Command Filter » | » List

The next menu to be shown will allow the user to specify the parameters for the host:

» File  » Search » SNMP Tool | » Administrator = » Inventory | » Help

host creation

» manufacturer: ‘Iesl

» model: ‘model

» version: ‘version

» Command template
Template:

And save the changes:
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» File | » Search | » SNMP Tool | » Administrator | » Inventory | » Help

» Host
» Save

host creation

» manufacturer: |tE!Sl

» model: |m0de|
»version: |Ver8i0n

» Command t,err.p'_at,e|
Template:

A message confirming that the host has been successfully created will appear:

SUCCESSFUL OPERATION

The host has been successfully created

[ reow |

9.3.1.2 Listing hosts

The administrator user can list all the hosts that have been defined in the system by clicking in the menu
“Administrator->ECP->Hosts->List”

» File » Search | » SNMP Tool ERRUGINENEGIE = Inventory | » Help

» Hosts Search » Users »
» Sessions
» Roles # » model » version
e | | |
» Applications »
» Account profiles »
» Filters »
Hosts found » Stored searches »
» Logs »
SECD s | » Pool N model version
test » Sosad » |» Scripts » foe! version
» Subpool 5 g’i{f“f‘ﬂ
» Host » | » New
» Command Filter » | » List

The screen will show a list containing all the defined hosts specifying its manufacturer, model and version:
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» File | » Search | » SNMP Tool  » Administrator | » Inventory | » Help

» Hosts Search

» manufacturer » model » Version
[ | | |
Hosts found
manufacturer maodel version
test model version

Found one recerd. Page 1
Export: 03V | Excel| XIIL

In the upper side of the screen the search parameters will be shown. The users can fill this parameters and
search for the hosts which satisfy the specified values.

9.3.1.3 Editing a host

In order to edit a host this must be previously selected from the list of hosts obtained through the “list”
menu or by searching for it using the “search” menu. Once the host is being shown in the screen the user
must select the “Host->Edit” menu:

» File | » Search | » SNMP Tool | » Administrator | » Inventory | » Help

Host:

» manufacturer;
» model:

» version:

» Host
» Save
» Edit
» Delete

The edit window will appear in the screen showing all the configurable fields which are contained by a
host. These fields can be edited by the user.
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» File | » Search | » SNMP Tool | » Administrator
Host:

» Inventory | » Help

» manufacturer:
» model
# Version

host edition

» manufacturer: |tE!Bt

» model: |m0de|

» version: |version

» Command template
Template:

The changed parameters can be stored in the database clicking in the “Host->Save” menu:

» File  » Search | » SNMP Tool | » Administrator
Host:

» manufacturer:
» model

» wersion

» Inventory | » Help

» Save

» Edit
» Delste
L
» model: ‘model
» version: ‘version
» Command template
Template:

Once the host has been edited a message will appear confirming that the changes were applied
successfully:

SUCCESSFUL OPERATION

The host has been successfully edited

9.3.1.4 Searching for a host

The user can search for hosts by clicking in the menu “Search->ECP->Host->Advanced”.
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» SNMP Tool | » Administrator | » Inventory | » Help

Loginini * Lock Manager »
» Login d » List Histaric Johs CET ...
»Lastlod , |Jsars s P
» User ip|
»Failed { » T2AMS »
» Roles »
» Applications »
B - ccount roies . |
» Logs »
» Inventary views »
» Filters »
» Stored searches »
» ECP » |» Pool »
» Sosa3d » |» Subpool ®
» Scripts »
» Command Filter »
» Host » | » Advanced I

The next window will be shown containing all the editable fields which can be used to perform the
search:

» File | » Search | » SNMP Tool | » Administrator | » Inventory | » Help

» Hosts Search

» manufacturer » model » version

| | ‘ | ‘ | » Search

9.3.1.5 Deleting a host

The administrator user can delete a host from the detailed view window of that host by clicking in the
“Host->Delete” menu:
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» File » Search  » SNMP Tool | » Administrator | » Inventory

Host:

» manufacturer: test

» model: madel
» Wersion: version

Once the host has been deleted a message will appear confirming that the changes were applied
successfully:

SUCCESSFUL OPERATION

The host has been successfully deleted

[ e

9.3.2 ECP Command Scripts Management

9.3.2.1 Creating a new Script

In order to create a new Script the menu “Administrator->ECP->Scripts->New” must be clicked:

» File | » Search | » SNMP Tool [ERSGINMIS(EGIE » Inventory | » Help

Login information: » Users »
» Login date:
» Last login date:
» Userip: 0.0 »
» Failed attempts: 0 » Teams B
» Applications »
» Account profiles »
» Filters »
» Stored searches »
» Logs »
» ECP » |» Pool »
» Sosal » |» Scripts » | » Mew
» Subpool » | = List
» Host »
» Command Filter »

The screen will show all the configurable parameters which can be filled by the user:
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» File | » Search | » SNMP Tool = » Administrator | » Inventory | » Help

Script creation

» Name:* | | » Description:”

» Seript usage:* | | » Seript result: ‘

» Script code:*

Hosts

» Not associated: » Associated:

test-model-version

3B = B

The fields are:
e Name: The name of the script
e Script Usage: A description of how to use the script
e Description: A brief text describing the script’s functionality
e Script result: The expected result of this script
e Script code: The template associated to this script
e Hosts: The hosts in which this script can be used
e Teams: The team associated to this script

e Users: The users who can use this script

In order to save the Script, the menu “Script->Save” must be clicked:

» File | » Search ' » SNMP Tool » Administrator | » Inventory | » Help

» Script
» Save

!:l:npf creation

» Name:* |IESI | » Description:* ‘tesl
» Script usage:” |tESt | » Script result: ‘tesl
test

» Script code:”

Hosts

» Not associated: » Associated:

|

test-model-version
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Once the script has been saved a message will appear confirming that the changes were applied
successfully:

SUCCESSFUL OPERATION

The script has been created succesfully

=

9.3.2.2 Llisting scripts

The administrator user can list all the scripts that have been defined in the system by clicking in the menu
“Administrator->ECP->Scripts->List”

» File | » Search | » SNMP Tool ENNINNEEIG » Inventory | » Help

Script: » USE[S_ » Users:
' Name: = » Sessions w Users number: 3
» Description: test » Roles }
» Script usage: test »
» Script result: test » Teams B
» Applications »
» Account profiles »
» Scipt » Imentory views .
» Filters W
» Stored searches W
» Logs »
» ECP » | » Pool »
» Sosad » | » Scripts » | » MNew
» Subpool w |» List
» Host »
» Command Filter »

The screen will show a list containing all the defined scripts specitying its fields:

» File | » Search | » SNMP Tool | » Administrator | » Inventory | » Help
» Script search

» Mame » Script usage » Script result

\ | [ | [ \ » Search

Scripts found

Name Description

test test

Found one record. Page 1
Export: CSV | Excel | XML
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In the upper side of the screen the search parameters will be shown. The users can fill this parameters and
search for the scripts which satisfy the specified values.

9.3.2.3 Editing a script

In order to edit a Script this must be previously selected from the list of scripts obtained through the “list”
menu or by searching for it using the “search” menu. Once the host is being shown in the screen the user
must select the “Script->Edit” menu:

» File » Search | » SNMP Tool  » Administrator » Inventory  » Help

Script: Users:
» Name:

» Description:

» Script usage:
» Script result:

» Users number: 8

» Script
» Edit
» Save

» Delete

The edit window will appear in the screen showing all the configurable fields which are contained by a
script. These fields can be edited by the user.

» File | » Search | » SNMP Tool | » Administrator | » Inventory | » Help

Script: Users:

» Name: test » Users number: ]
» Description: test

» Script usage: test

» Script result: test

Script edition

» Name:® ‘Iesl ‘ » Description:* |test
» Script usage:* ‘test ‘ » Script result:* |test
test

» Script code”

Hosts

» Hot associated: » Associated:

The changed parameters can be stored in the database clicking in the “Script->Save” menu:
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» File | » Search | » SNMP Tool » Administrator | » Inventory | » Help

Script: Users:

» Hame: » Users number: 8

test
# Description: test
test
test

» Seript usage
» Seript result:

- _________________________________________________________________
» Edit

» Save

» Delste

T | » Description:® ‘Iest

» Script usage:* test | » Script result:* ‘IE st

test

» Script code:™

Hosts

» Not associated:

» Associated:

Once the Script has been edited a message will appear confirming that the changes were applied
successfully:

SUCCESSFUL OPERATION

The script information has been updated succesfully

[ e |

9.3.2.4 Searching for a Script: Advanced search

The user can search for scripts by clicking in the menu “Search->ECP->Scripts->Advanced”.

» SNMP Tool | » Administrator | » Inventory | » Help

script: | Lock Manager » Users:
» Name: | # List Historic Jobs ' Users number: s
» Des.cr\ » Users 2
» Seript
» Scripty ® TEAMS »
» Roles »
» Applications n
» Account profies . —
» Logs »
» Inventory views »
» Filters B
» Stored searches »
» ECP » |» Pool »
» Sosal » |» Subpool »
» Scripts » |» By name
» Command Filter » | » Advanced
» Host »
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The next window will be shown containing all the editable fields which can be used to perform the
search:

» File | » Search | » SNMP Tool | » Administrator | » Inventory | » Help

» Script search

» Mame » Script usage » Script result

| ‘ | | | | » Search

9.3.2.5 Searching for a Script: Search by name

The user can search for scripts by name by clicking in the menu “Search->ECP->Scripts->By Name”.

» File PESEENSMN » SNMP Tool | » Administrator | » Inventory | » Help

» Serip » Lock Manager »
» List Historic Jobs
» Users * hme » Script usage » Script result
» Teams » | | | | |
» Roles W
» Applications »
B . ccount pofies ..
» Logs »
» Inventory views »
» Filters »
» Stored searches »
» ECP » |» Pool »
» Sosal » | » Subpool »
» Scripts » | » By name
» Command Filter » | » Advanced
» Host »

The next window will be shown containing the field “Name” which can be used to perform the search:
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» File | » Search | » SNMP Tool | » Administrator

» Inventory | » Help
» Script search

9.3.2.6 Deleting a script

The administrator user can delete a script from the detailed view window of that script by clicking in the
“Script->Delete” menu:

» File  » Search » SNMP Tool » Administrator

» Imventory | » Help

Script: Users:

» Name: test » Users number: 8
» Description: test

» Script usage: test

» Script result: test

» Script
» Edit
» Save
» Delete

Once the script has been deleted a message will appear confirming that the changes were applied
successfully:

SUCCESSFUL OPERATION

The script has been deleted successfully

[ heew |
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9.3.3 Command filter management

9.3.3.1 Creating a new Command Filter

In order to create a new command filter the user must click in the menu “Administration —> ECP ->
Command Filter -> New”

» File | » Search | » SNMP Tool ERSINE{EGE » Inventory | » Help

» Users »
» Sessions
» Roles B
» Teams B
» Applications »
» Account profiles »
» Filters »
» Stored searches »
» Logs »
» ECP » |» Pool »
» Sosal » |» Scripts »
» Subpool »
» Host »
» Command Filter » | » Mew
» List

The next menu to be shown will allow the user to specify the parameters for the new command filter:

» File | » Search | » SNMP Tool | » Administrator | » Inventory | » Help

» Command Filter

Command Filter Creation

STl | ‘ » Description:* |
Expression:
Haosts
» Not associated: » Associated:
test-model-version
o
Teams
» Not associated: » Associated:

These parameters are:

Regular Expression: The regular expression which must be satisfied by the command.
Description: A brief description of the filter.

Hosts: The hosts in which the filter will be used.

Teams: The teams associated to the filter.

Users: The users associated to the filter.

And save the changes:
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» File | » Search » SNMP Tool | » Administrator | » Inventory | » Help

» Command Filter
» Save
ommand Filter Creation
» Regular ey
e |IESI | » Description: |test
Hosts
» Hot associated: » Associated:
test-model-version
Teams
» Not associated: » Associated:

A message confirming that the command filter has been successfully created will appear:

SUCCESSFUL OPERATION

The Command Filter has been created

[ heor |

9.3.3.2 Listing command filters

The administrator user can list all the command filters that have been defined in the system by clicking in
the menu “Administrator->ECP->Command Filter->List”

» File  » Search  » SNMP Tool ERSIGNEIEGIE » nventory | » Help

(Command Filter: » Users » Users:
» Description: test » Sessions » Users number: 8
» Description: test » Roles »
» Teams »
» Applications »
» Account profiles »
» Filters »
» Stored searches 3
» Logs »
» ECP » |» Pool »
» Sosal » |» Scripts »
» Subpool »
» Host »
» Command Filter » | » New
» List

The screen will show a list containing all the defined command filters specifying its parameters:
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» File | » Search | » SNMP Tool | » Administrator  » Inventory | » Help

» Regular Expression » Description

= Search

Command Filters Found

Regular Expression Description

Found cne recerd. Page 1
Export: CSV | Excel| XML

In the upper side of the screen the search parameters will be shown. The users can fill this parameters and
search for the command filters which satisfy the specified values.

9.3.3.3 Editing a Command Filter

In order to edit a command filter this must be previously selected from the list of command filters obtained
through the “list” menu or by searching for it using the “search” menu. Once the command filter is being
shown in the screen the user must select the “Command Filter->Edit” menu:

» File | » Search | » SNMP Tool | » Administrator | » Inventory | » Help

Users:
» Users number: 8

Command Filter:
» Description: test
» Description: test

» Command Filter
» Save

» Edit

» Delete

The edit window will appear in the screen showing all the configurable fields which are contained by a
command filter. These fields can be edited by the user.
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» File | » Search | » SNMP Tool  » Administrator | » Inventory | » Help

Command Filter: Users:
» Description: test w Users number: g
» Description: test

» Command Filter

Command Filter Creation

» Regular

Expression:* |TE!St | » Description:* |tE! st
Hosts
» Not associated: » Associated:
testmodel-version
Teams

» Not associated: » Associated:

The changed parameters can be stored in the database clicking in the “Command Filter->Save” menu:

» File | » Search = » SNMP Tool | » Administrator | » Inventory | » Help

Command Filter: Users:
» Description: test » Users number: 2
» Description: test

» Command Filter

» Save

» Edit

» Delete
Expression:” v==t | » Description:* |test
Hosts

» Not agsociated: » Associated:
test-model-version

Teams

» Not associated: » Associated:

Once the command filter has been edited a message will appear confirming that the changes were
applied successfully:

9.3.3.4 Searching for a Commad Filter

The user can search for command filter by clicking in the menu “Search->ECP->Command Filter-
>Advanced”.

85



HPSA Extension Pack
Solution Container - User Reference

PRSLEEN M » SNMP Tool | » Administrator | » Inventory | » Help

Loginini * Lock Manager »
» Logind » List Historic Jobs ET2...
»Lastiof , |Jgarg » |
» User ip]
» Failed { » 123mMs »
» Roles »
» Applications »
B . ccourt proies L
» Logs »
» Inventory views »
» Filters »
» Stored searches »
» ECP » |» Pool »
» Sosald » | » Subpool »
» Scripts »
» Command Filter » | » Advanced I
» Host » |

The next window will be shown containing all the editable fields which can be used to perform the
search:

» File | » Search  » SNMP Tool | » Administrator | » Inventory | » Help

» Regular Expression » Description

» Search

9.3.3.5 Deleting a Command Filter

The administrator user can delete a command filter from the detailed view window of that command filter
by clicking in the “Command filter->Delete” menu:
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» File | » Search | » SNMP Tool | » Administrator | » Inventory | » Help

Command Filter: Users:

» Description:
» Description:

# Users number: ]

» Command Filter
» Save

» Edit

» Delete

Once the command filter has been deleted a message will appear confirming that the changes were
applied successfully:

SUCCESSFUL OPERATION

The Command Filter has been deleted

[ e |
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