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Documentation Updates 
The first page of this release notes document contains the following identifying information: 

• Version number, which indicates the software version. 

• Publish date, which changes each time the document is updated. 

To check for recent updates or to verify that you are using the most recent edition, visit the following URL: 
http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to:  
http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page. 

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details. 

Note: To view files in PDF format (*.pdf), Adobe Acrobat Reader must be installed on your system. To 
download Adobe Acrobat Reader, go to the following web site:  
http://www.adobe.com/ 

In This Version 
Service Manager Version 9.30, build 047 Patch 1 (SM 9.30p1) includes several customer requested software 
enhancements and fixes. Refer to the sections below for information about the defects and enhancements for 
each release included in this cumulative patch.  

Service Manager 9.30 Patch 1 updates the following areas.  

• Enhancements 

• Server Updates 

• Web Client Updates 

• Windows Client Updates 

http://h20230.www2.hp.com/selfsolve/manuals�
http://h20229.www2.hp.com/passport-registration.html�
http://www.adobe.com/�
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Enhancements  

The following enhancements are included with this software release. 

Global ID Problem  Resolution  

QCCR1E65967 Enhance usability of 
the Condition Editor 
in Process Designer. 

This enhancement includes: 

More flexibility to define an expression 
An expression has a Left-Hand-Side (LHS) and Right-Hand-Side 
(RHS) separated by an operator. Previously, users were restricted 
to have only values on the RHS. Now there can be a combination of 
variables, types, and values on either side of the expression. 

Ability to edit a pre-existing condition 
Clicking the pencil icon allows user to see and edit exiting values. 
Previously, this action caused the values to be removed. 

Negation of Condition Groups 
To negate a group, click the `!' icon that appears in the group when 
hovering the mouse to the top left corner of a Condition Editor. 
Clicking `!' icon again will undo negate. 

Note: The current version does not support an expression 
combined with negate and !=. For example, the 
"Not(CurrentRecord.priority != 'high')" expression is not supported 
in the current version of Service Manager. Condition Editor allows 
building such an expression, but it will always evaluate to false. 

QCCR1E65968 In Process Designer, 
provide support for a 
Workflow Viewer 
component. 

Added a new widget to Form Designer, represented with an icon of 
a small workflow. This widget gives you the ability to add the 
Workflow Viewer as a component. With SM 9.30.p1, you can use 
this component to display the workflow of tables kmdocument 
(Knowledge Management) and WorkflowDemo. For more 
information, see Additions to the Documentation. 

QCCR1E65969 In Process Designer, 
add the ability to 
specify additional 
forms on the Forms 
tab of a workflow. 

Added an editable grid in the Forms tab where you can add, edit, 
and delete additional forms for a workflow phase. 

Note: This functionality will not be available until an upcoming 
Process Designer Content pack is applied. 
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Server Updates 

The following items are fixed with this software release. 

Global ID Problem  Resolution  

QCCR1E56872 Adds and updates to triggers and link 
records require a recycle to take effect on 
other hosts in a horizontally-scaled 
environment. 

Adds and updates to cached form 
definitions and link records in one host of a 
horizontally-scaled system are now 
automatically propagated to the other hosts 
as expected.  

QCCR1E57650 When trying to add a unique key to the 
Contacts table, Service Manager displays 
errors. 

When trying to modify the unique key of a 
table with array tables or m2 table, a full-
table copy will be invoked. 

QCCR1E60613 User cannot log in to the Service Manager 
server and instead receives the message 
"SOAP Fault occurred: "Server is running 
low on memory try again." The Service 
Manager server service has to be restarted 
to temporarily resolve the problem. 

When JVM memory usage is higher than 
90%, the system GC is automatically called. 

QCCR1E62273 After removing a record from a To Do 
record list and then selecting a subsequent 
record Service Manager (SM) displays a 
different record than the record selected. 

Service Manager refreshes the To Do queue 
correctly after closing a ticket from the To 
Do queue. 

QCCR1E62546 Querying the Incident REST WS returns an 
HTTP error 500 along with a stack trace if 
no Incidents are found that match the 
query. 

When querying the Incident REST WS and 
no entries are found which match the 
query, an empty list is returned to the 
caller. 

QCCR1E64802 With the following conditions in Service 
Manager: 

• There is a record, to which another 
record is linked via relatedObjectMap 

• There is an inbox on the base record. 
This displays the primary key from the 
second table in the inbox for the first. 

• The primary keys of the two tables are 
named identically (e.g., both are "id") 

When you double-click a record in the inbox 
list and save it, the primary key of the first 
table is corrupted, so it contains the 
primary key of the second record. 

Fixed the code so that the table name is 
added as a prefix to the fields that are not 
coming from the first table. This will ensure 
that the primary key of the first table will 
not be corrupted. 

QCCR1E64858 After deleting a record, the wrong 
interaction record displays after a user 
clicks a new record with a higher record ID. 

When deleting a record from a QBE list 
displayed by the Web client without record 
list turned on, the QBE list displays 
correctly after the delete. Clicking any 
record of that QBE list selects the correct 
record. 
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QCCR1E65135 When a record from a search that involved 
adhocsql files is updated, and the updated 
record does not match the filter criteria, the 
record is not removed from the search list. 

When a record from a search that involved 
adhocsql files is updated, the record will be 
re-evaluated to verify it still matches the 
filter criteria. 

QCCR1E65486 New parameter ir_sql_limit can only set the 
number of records fetched from SQL to 
32767 or higher. 

Removed the special code, and made the 
number of records to be fetched a 
parameter to sqQbe(). 

QCCR1E65535 Table caption disappears after modifying 
the column of a configuration item. 

Captions in usergrid will be used when 
there is no caption in the datadict. 

QCCR1E65548 If "ldapdisconnect:1" and 
"ldapauthenticateonly" are set in the sm.ini 
file, a signal 11 will be raised in native code 
when a user tries to log in. 

Since the parameters "ldapdisconnect:1" 
and "ldapauthenticateonly" are meant to 
close the LDAP connection after login, the 
LDAP connection will be checked before 
closing the LDAP connection in case it has 
already been closed. 

QCCR1E65659 User servlets are crashing several times a 
week on a loadbalanced system with three 
nodes.  

Refactored the thread monitor mechanism. 

QCCR1E65740 The make.sig() RAD function returned 
different results on AIX when compared to 
an x86 machine. 

The make.sig() RAD function returns 
consistent results on all platforms. 

QCCR1E66066 Web Tier waits for a response when trying 
to delete a wrongly-configured search 
server. After about six minutes, the Web 
Tier is active again. 

Reset the timeout connection to 20 seconds, 
so that the timeout is not too long. 

QCCR1E66066 Web Tier waits for a response when trying 
to delete a wrongly-configured search 
server. After about six minutes, the Web 
Tier is active again. 

Reset the timeout connection to 20 seconds, 
so that the timeout is not too long. 

QCCR1E66209 Client will exit when user chooses the 
Tasks, Changes, or Configuration Items 
queue and double-clicks a record. 

Client operations will be no problem when 
user chooses the Tasks, Changes, or 
Configuration Items queue and double-
clicks a record. 
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Web Tier Updates 

The following items are fixed with this software release. 

Global ID Problem  Resolution  

QCCR1E61753 Inconsistent behavior with the 
cursor.field.contents() functionality between 
Windows and Web clients. 

In the Web client, the 
cursor.field.contents() function in a table 
has the same behavior as the Windows 
client. If the reference from a table points 
to one line of an array, the value of that 
line is referenced. 

QCCR1E61919 After an upgrade, the Comfill fields retain 
the previously-selected value when a user 
clicks Fill. 

The Comfill fields no longer retain the 
previously-selected value when a user 
clicks Fill. 

QCCR1E64634 In the Web client, "Print Page" does not work 
properly for fields with a visible condition. 
These fields do not display in the print form 
when "Print Page" is clicked. 

Printing a page correctly displays fields 
with a visible condition.  

QCCR1E64876 Fill and DVD routines executed from Data 
Changed Event do not complete successfully. 

Set the correct target for Data Change 
Event, so that fill and DVD routines now 
run as expected. 

QCCR1E65031 There is some incorrect print information in 
the print form. 

1 "Assignee Name" is not in the screen, but 
it is shown in the print form. 

2 The following are missing in the print 
form: 

— Impact/Dependency 

— Test Documentation 

— IST 

Print of a cm3r record which includes a 
DVD-visible condition will display 
correctly. 

QCCR1E65118 When the Service Manager Web Tier is 
deployed on the JBoss 5.1 web application 
server, updating a workflow that contains 
more than 4096 bytes will cause the following 
error: "Server failure: -1, See server log for 
details." 
Note: There is a known issue in JBoss 5.1 
(JBWEB-165), and is fixed in JBoss 6.0 
(which is not yet supported by Service 
Manager). 

Refactored the code to work around JBoss 
issue with request larger than 4096 bytes. 
Users can save updated workflows 
without errors. 

QCCR1E65374 Using direct URL access to a specified 
incident does not work. 

Using direct URL access to a web page 
will open up the form with the specified 
Incident values filled in. 
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QCCR1E65545 Confirmation messages do not appear after 
Employee Self Service (ESS) users submit 
requests. 

Confirmation messages will appear after 
ESS users submit requests. 

QCCR1E65601 The field assigned to contact on a quote 
cannot be filled when using the web client. 

Field will no longer empty out and instead 
keep filled information. 

QCCR1E65602 Opening a new incident does not get a 
confirmation message (from index.do). 

Messages will display on all tabs. 

QCCR1E65683 The Condition Editor's JavaScript files aren't 
concatenated into one file and aren't 
minified. The Condition Editor's JavaScript 
files are always loaded into all pages even 
though some pages don't have a condition 
editor. 

Condition Editor JavaScript is now 
concatenated and minified. Condition 
Editor JavaScript is now loaded only if a 
SM form has a condition editor widget in 
it. 

QCCR1E65741 Read-only comfill array widget shows 
mandatory image on DVD condition. 

Read-only comfill array widget does not 
show a mandatory image on the DVD 
condition. 

QCCR1E65883 When a user connects to Service Manager 
through Trusted Sign-on (TSO) and the 
maximum number of concurrent logins is 
exceeded, there is no message sent to the 
user. 

When a user logs in through TSO and the 
maximum number of concurrent logins is 
exceeded, the following message is 
displayed: "Login failed. Maximum active 
logins for this user exceeded." 

QCCR1E66419 Web client appends hard-coded help directory 
to any help URL. 

Added a new parameter 
(helpServerContext) to solve this issue. 

For more information see Additions to the 
Documentation. 

QCCR1E66837 When creating a new workflow in Process 
Designer, the default phase is not marked as 
active. 

When creating a new workflow in Process 
Designer, the default phase is marked as 
active. 

QCCR1E67012 When creating a new workflow in Process 
Designer, you must specify a table to 
associate the workflow. At this point, all 
tables in the database are listed in the drop-
down list. However, only tables that will 
work with Process Designer should be listed. 

The drop-down list has been restricted to 
only tables that have been enabled with 
Process Designer. As of the SM 9.30 GA 
release, only kmdocument WorkflowDemo 
tables will appear. The list is controlled 
by detecting if the table has a Workflow 
Location defined in the Object table. As 
more SM modules move to Process 
Designer, this value will be set. Setting it 
manually before the module is enabled 
will cause the table to appear in the 
Process Designer, but the workflow 
definition will not execute. 



 8 

Windows Client Updates 

The following items are fixed with this software release. 

Global ID Problem  Resolution  

QCCR1E60834 After performing a binary upgrade on a 
Service Manager 7.02 system and bringing 
the system to Service Manager 9.20 patch 
level 1, a chart that was selected did not 
show the record list as expected. Instead, 
the Advanced search form was displayed. 

The record list is shown after selecting a 
chart. 

QCCR1E65388 Windows Client did not show Arabic 
language as an option even after the 
language pack was installed. Opening the 
Windows client on an Arabic operating 
system shows the client in English instead 
of Arabic strings. 

Support for the Arabic language is enabled 
on the Windows client, so that the 
Windows client will show Arabic as a 
language option during connectivity and 
opening the Windows client on an Arabic 
operating system shows the client in 
Arabic. 

QCCR1E65435 Drop-down position and scroll bar issues 
in Arabic RTL Windows client. 

Shifted the coordinate X of drop-down 
content and also shifted the X in 
determining if the event is inside the 
control or outside, so the drop-down 
contents will display properly. 

QCCR1E65743 Current build process of the Windows 
client does not include all the localization 
files for the Arabic language. 

Added new Arabic Language Pack from 
Windows and updated the build process to 
include all the Arabic localization files. 

QCCR1E66418 Windows client appends hard-coded help 
directory to any help URL. 

Added a new parameter (Help Server 
Context) to solve this issue. 
For more information see Additions to the 
Documentation. 

Known Problems, Limitations, and Workarounds 
This software release has the following known issues. 

Global ID  Known Issue  Solution 

QCCR1E62584 In the Windows client on an Arabic 
operating system, Arabic strings are 
displayed from the left side of a field 
when and after you enter them in the 
field. 

Add a system property in client config.ini file 
in installation directory to enforce right-to-left. 
Navigate to the Windows client configuration 
file, <client installation 
path>/configuration/config.ini. The default is 
location is  
C:\Program Files\HP\Service Manager 
9.30\Client\configuration\config.ini.  

Open the file and add this line at the end. 
eclipse.orientation=rtl  
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Installation Notes 

Web Tier installation 

The Web Tier update consists of a compressed file, sm9.30.047-P1_Web_Tier.zip. The specific upgrade 
process depends on your particular Web application server, but follows the same steps as deploying a new 
installation. For more information, refer to the Service Manager Installation Guide. 

The upgrade does not automatically save your Web Tier customizations. To keep your changes, you must 
save your customized files and replace the new version of these files with your customized version. 

Note: Arabic language support requires Internet Explorer 8. 

To install the Web Tier update: 

1 Back up your web.xml file, splash screen, style sheets, and any other customizations you made, including 
your webtier-9.30.war (Webtier.ear-9.30.ear) file. 

2 Delete or uninstall the existing webtier-9.30.war (.ear) file. 

Note: The "Update Application" function in WebSphere Application Server 6.x allows you to redeploy 
using a new copy of webtier-9.30.war (Webtier.ear-9.30.ear). First, update the web.xml in the 
webtier-9.30.war (.ear) file, and then redo the shared library configuration. For more information, 
see the IBM WebSphere documentation. 

3 Deploy the new webtier-9.30.war (.ear) file by following the instructions in the Service Manager 
Installation Guide. 

4 Replace the new versions of any files you customized with your customized versions. 

5 Make any new customizations necessary for your deployment. 

6 Restart the Application server. 

Windows client installation 

The Windows client update consists of a compressed file, sm9.30.047-P1_Windows_Client.zip, which 
contains the executable installation files. 

To install the Windows client update: 

1 Stop the Service Manager Windows client. 

2 Uninstall the Service Manager Windows client. (Your connection and personalized settings are retained.) 

3 Run setup.exe and install the client by following the instructions in the Service Manager Installation 
guide and Release Notes for your version. 

4 Check the version in Help > About Service Manager Client.  
The client should be Release: 9.30.047. 
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Server installation 

The server update for your operating system (OS) consists of a compressed file, sm9.30.047-P1_<OS>.zip  
(or .tar), which contains the Service Manager server files. These files add to or replace the files in the [SM 
Root]\ ([SM Root]/) RUN, irlang, legacyintegration, and platform_unloads directories. 

To install the Server update: 

1 Stop all Service Manager clients. 

2 Stop the Service Manager server. 

3 Make a backup of the RUN directory. 

4 Extract the compressed files for your operating system into the main Service Manager directory on the 
server. The default path is: C:\Program Files\HP\Service Manager 9.30. 

5 For UNIX servers, set the file permissions for all Service Manager files to 755. 

6 Restart the Service Manager server. 

7 Restart the Service Manager clients. 

8 Check the version in Help > About Service Manager Server.  
The server should be Release: 9.30.047. 
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Additions to the Documentation  

Process Designer  

The following information supports the enhanced Process Designer Workflow Viewer. 

Integrate Workflow Viewer into the kmdocument form 

User role: System Administrator and Implementer 
A new icon 'Workflow Viewer' is available in Forms Designer. The following example will help you to 
integrate the Workflow Viewer widget into the kmdocument.document form. After the integration, you can 
see a graphical view of the workflow in the Contribute Knowledge -> External -> Workflow tab. Using 
similar steps, you can integrate the Workflow Viewer with other forms. 

To integrate the Workflow Viewer widget into the kmdocument form: 

1 Log on as a System Administrator and open Forms Designer in the Windows client (In the System 
Navigator, go to Tailoring > Forms Designer). For information on accessing Forms Designer and 
updating a form, see the following topics in the Help server: "Access Forms Designer" and "Update a 
form"  

2 In the Form field, type kmdocument.external and click Search. The Contribute Knowledge form opens 
with the External Document Upload tab selected. 

3 Add 'Workflow' tab in the form. 

4 Set the visible condition to [$showWF]=true in the Workflow tab. 

Note: The condition hides the tab in the Windows client, but is visible in the Web client. 

5 Add the Workflow Viewer component to the new Workflow tab. 

6 In the Workflow Viewer component, set the following variables in the properties.  
Workflow Name: $L.wfgWFName 
Workflow Table: $L.wfgWFTable 
Workflow RecordID: $L.wfgWFRecId 
Workflow Current Phase: $L.wfgWFPhase 

7 Add four text boxes at the bottom of the Workflow Viewer. 

8 Set their input values in the properties to: 
$L.wfgWFName 
$L.wfgWFTable 
$L.wfgWFRecId 
$L.wfgWFPhase 

Note: The four text boxes display workflow name, table name, document id, and phase of the record. 

9 Set the Workflow Viewer variables in the Main -> Initialization tab of display screens kmdocFlow.open 
and kmdocFlow.view: 
$L.wfgWFName=workflowName in $L.wfPhase 
$L.wfgWFTable=tableName in $L.wfPhase 
$L.wfgWFPhase=phaseName in $L.wfPhase 
$L.wfgWFRecId=id in $L.file 
if (sysinfo.get("environment")~="scguiwswt") then ($showWF="true") else ($showWF="false") 

Note: To go to display screen, type ds in Service Manager command prompt and search for the 
kmdocument.document form. 
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10 Follow steps 1 through 7 to add Workflow View in the other Knowledge Management forms: 
kmdocuments (kmdocument.probsol, kmdocument.howto, kmdocument.reference and 
kmdocument.errormsg). 

View a workflow in Workflow Viewer 

Workflow Viewer enables you to view a graphical layout of the entire lifecycle of a process or record. You can 
see color-coded phases and transitions of the workflow, as follows: 

Phase/Transition −  Color property used 

Current phase −  Green highlight 

Past phase −  Green border 

Future phase −  Blue border 

Inactive phase −  Grey border  

Past transition −  Dotted green line 

Future transition −  Blue line arrow  

Note: To view a workflow in the Workflow Viewer, you should have integrated Workflow widget into 
Knowledge Management or any form associated with a table that has been enabled for Process Designer. 
This is currently available for kmdocument and WorkflowDemo only. 

New Parameters  

The following parameters enable you to connect to the help from the Service Manager client. 

Web Client Parameter: helpServerContext 

To connect the help from the Web client: 

1 Open the Web tier configuration file (web.xml) in a text editor. 

2 Specify the following parameters: 
helpServerHost: The host name of the Help Server 
helpServerPort: The communications port of the Help Server 

3 If your Help Server is not deployed in the default "/help" folder (for example: C:/Apache/2.2/htdocs/help), 
specify the Help Server context path (either empty or not) by adding the helpServerContext parameter 
in the web.xml. The following are two examples:  
<init-param> 
<param-name>helpServerContext</param-name> 
<param-value/> 
</init-param/> 
 
Or  
<init-param> 
<param-name>helpServerContext</param-name> 
<param-value>sm/9.30_help</param-value> 
</init-param> 

4 In the web.xml file, make sure that the showHelp parameter value is set to true.  

5 Restart the web application server. 
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6 Click the Help (question mark) button in the web client tooltray to launch the Help Server. Service 
Manager will automatically launch the Help Server URL: 
http://<helpServerHost>:<helpServerPort>/<helpServerContext>  

Windows Client Parameter: Help Server context 

To connect the help from the Windows client: 

1 Log in to the Windows client. 

2 From the menu bar, click Window > Preferences. 

3 Expand Help to set the Help Server preferences. 

a In the "Help Server host name" field, type the host name of the Help Server. 

b In the "Help Server port number" field, type the Help Server port number. 

c In the "Help Server context" field, change the context path of the Help Server as necessary 
(default: help). For example, if your Help Server is deployed in C:/Apache/2.2/htdocs/sm/9.30_help, 
type "sm/9.30_help" in this field. 

d Click Apply. 

4 From the Service Manager menu bar, click Help > Help Contents to launch the Help Server. 



 14 

Verified Environments 
The Compatibility Matrix lists supported versions of operating systems, browsers, HP Software products, 
and other compatibility and support information. 

To access the Compatibility Matrix: 

1 Use a browser to navigate to the Software Support Online (SSO) web page:  
http://support.openview.hp.com/sc/support_matrices.jsp 

2 Log on with your Customer ID and password or your HP Passport sign-in. 

3 Navigate to the applicable information. 

Local Language Support 
UTF-8 is part of the Unicode standard, which enables you to encode text in practically any script and 
language. Service Manager 9.30 supports UTF-8 as an encoding method for new or existing data. It can 
support multiple languages that adhere to the Unicode standard on the same server. 

The Arabic language pack requires either the Windows client 9.30p1 or greater (on a supported Windows 
operating system other than Windows XP) or the Service Manager Web client and Internet Explorer 8. 

Note: For Arabic language support on the Windows client, refer to QCCR1E62584 included in Known 
Problems, Limitations and Workarounds. 

http://support.openview.hp.com/sc/support_matrices.jsp�
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Support 
You can visit the HP Software support web site at: 
www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and support that HP 
Software offers. 

HP Software online software support provides customer self-solve capabilities. It provides a fast and efficient 
way to access interactive technical support tools needed to manage your business. As a valued support 
customer, you can benefit by using the support site to: 

• Search for knowledge documents of interest 

• Submit and track support cases and enhancement requests 

• Download software patches 

• Manage support contracts 

• Look up HP support contacts 

• Review information about available services 

• Enter into discussions with other software customers 

• Research and register for software training 

Most of the support areas require that you register as an HP Passport user and sign in. Many also require 
an active support contract. To find more information about support access levels, go to the following URL: 
http://h20230.www2.hp.com/new_access_levels.jsp 

To register for an HP Passport ID, go to the following URL: 
http://h20229.www2.hp.com/passport-registration.html 

http://h20230.www2.hp.com/new_access_levels.jsp�
http://h20229.www2.hp.com/passport-registration.html�
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Legal Notices 

Warranty 

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein. 

The information contained herein is subject to change without notice. 

Restricted Rights Legend 

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license. 

Copyright Notice 

© Copyright 1994-2011 Hewlett-Packard Development Company, L.P. 

Trademark Notices 

• Adobe™ is a trademark of Adobe Systems Incorporated. 

• Java is a registered trademark of Oracle and/or its affiliates. 

• Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation. 

• Oracle® is a registered US trademark of Oracle Corporation, Redwood City, California. 

• UNIX® is a registered trademark of The Open Group. 

For a complete list of open source and third party acknowledgements, visit the HP Software Support Online 
web site and search for the product manual called HP Service Manager Open Source and Third Party 
License Agreements. 
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