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Conventions

Boldface Words in boldface type represent programs, commands, and 
user selections.

Capitalization Capitalized first letters represent company or product names.

Computer font Words in computer font represent file or path names, 
command syntax statements, prompts or messages that appear 
on your screen, or text you should type on your workstation or 
terminal.

Italics Words in italics represent variables in syntax statements 
or words that are emphasized in the text.

{ } Represents required elements in a syntax statement. 
When several elements are separated by the | symbol, 
you must select one of the elements.

[ ] Represents optional elements in a syntax statement.
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 Chapter 1: Introducing the SMART Plug-In for Exchange 

This chapter introduces you to some basic Exchange SPI concepts and offers an 
overview of SPI components that, once installed, appear in the VantagePoint for 
Windows (VP/Windows) console. The chapter includes the following sections. 

� What the Exchange SPI Does
� How the Exchange SPI Works with VantagePoint for Windows
� Using the Exchange SPI with VantagePoint Reporter
� Suggested Daily Tasks
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What the Exchange SPI Does

The SMART Plug-In (SPI) for Microsoft® Exchange Server adds Exchange 
server-monitoring capabilities to VantagePoint for Windows. With the Exchange 
SPI configured and deployed to Exchange Server systems you will find that you 
can:

� Increase Exchange availability and performance 

� Lower your support costs associated with the Exchange service 

� Improve capacity management and planning for Exchange

After you complete your Exchange SPI setup, within the VantagePoint for 
Windows console, you receive information on the performance and availability 
of monitored Exchange servers. The information that you receive to comes to 
you in the form of messages, alerts, and graphs so that you know when 
Exchange servers are performing well and, conversely, when they are not. With 
this information you can pinpoint and respond to potential problems. 

NOTE In addition, if you use VantagePoint Reporter, reports are also available that 
show additional Exchange-related data that accumulates over time. The 
information contained in these reports will help you manage capacity on 
Exchange servers, plan for future load balancing when you see trends of 
overloading on any one server developing, and spot performance bottlenecks 
between servers. 
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How the Exchange SPI Works
Like other SMART Plug-Ins, the Exchange SPI collects data that is targeted and 
gathered according to rules and schedule specifications contained within the 
Exchange SPI policies. The collection of this data also relies on the programs 
contained within the Exchange SPI package. In the beginning, you will find that 
deploying Exchange SPI to any Exchange server(s) (selected node(s) within the 
VantagePoint tree) requires that you focus mainly on the areas of Policy Groups 
and Deployment packages.

The policy setup and deployment: Basic Exchange SPI components do not 
require custom configuration. The EXSPI Quick Start policy group contains the 
policies you need to deploy with no special customization. EXSPI Add-Ons 
policies also require no customization and are available to select and deploy 
according to the applications/programs being used by the Exchange server. The 
EXSPI Advanced policy group is also available and ready for use after you 
complete some additional setup. Once deployed to the Exchange server node(s), 
the policy enables Exchange SPI programs to target specific data and measure 
the data against predefined rules to generate useful information. 

New folders for 
Tools, Policy 
management, and 
Deployment 
packages contain 
Exchange SPI 
components after 
you install the 
Exchange SPI.



Chapter 1: Introducing the SMART Plug-In for Exchange
How the Exchange SPI Works

1 - 5

When the resulting messages and alerts appear in the VantagePoint message 
browser, you can use the information for resolving and analyzing problems. In 
the message browser you can also double-click messages to view message 
details where suggestions appear for corrective actions associated with the 
generated data.

Policy display: Exchange SPI policies are available in the VP/Windows console 
two different ways: the first is according to group under the Policy groups folder, 
and the second is according to type under the Policies grouped by type folder. 
You can view or edit an Exchange SPI policy within either of these categories. 

� Policy groups: organizes policies according to how you might want to 
deploy them. Quick Start contains the basic policies you need to get 
started; Advanced contains policies that require some configuring such 
as setting up a mailbox or pinging Exchange servers; and Add-Ons 
contains policies that cover applications compatible with but not part of 
Exchange, such as cc:Mail. 

� Policies grouped by type: organizes policies according to their function; 
for example, you can find data collection scheduling in Scheduled 
Command policies; threshold settings in Measurement Threshold 
policies, etc.

Deployment Package use: Exchange SPI deployment is simplified with the 
package used to activate the programs necessary to implement policies. 

Tools use: Exchange SPI tools include two groups: EXSPI Admin and EXSPI 
Graphs that allow you to do the following:

� EXSPI Admin: Control the on/off state of Exchange SPI data 
collections, run a diagnostic discovery of installed Exchange SPI 
components, and complete certain configurations required for some 
policies. 

� EXSPI Graphs: Generate graphs representative of some collected data. 
By deploying the Measurement Data Collector to selected nodes, you 
enable this tool to graph data collected on those nodes. To generate 
graphs, you double-click the tool which launches the VantagePoint 
Performance grapher. In the dialog that appears you can configure the 
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metrics you want drawn within the graph. 

Some messages that appear in the Message Browser have operator 
actions associated with them. In these cases, you have another means of 
graphing data where you can graph the metric that generated the 
message as well as others that may be related to it. Data from any 
Exchange SPI server can be drawn using the Performance Grapher. For 
more information on graphing with the Performance Grapher, see the 
VP/Windows on-line Help.

Configuration requirement for remote VP/Windows console: If you 
plan to use any EXSPI Graphs tool from a remote VP/Windows 
console, you must complete two simple configuration modifications. 
Instructions for these modifications are located in Chapter 2, Using 
Graphs Tools from a Remote VP/Windows Console on page 32.

NOTE Other graphs representing Exchange data are available through the separately 
purchased VantagePoint Reporter. Exchange SPI comes with a default set of 
reports ready for use with VP Reporter. The chapter that follows provides 
instructions on how to configure the Exchange SPI to work with VantagePoint 
Reporter to produce Web-based, management-ready reports showing Exchange 
server performance/availability. 
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Suggested Daily Tasks
After installing and configuring the Exchange SPI, you can now focus on other 
areas of the VP/Windows console (aside from Policy Management) to routinely 
monitor and interpret the collected data. Those areas are as follows: 

� Check the VP/Windows message browser: 
Watch for warning and critical messages or multiple alarms. Read the 
associated instruction text.

If too many alarms are occurring and servers seem to be performing all 
right, you likely need to adjust the Exchange SPI measurement threshold 
policy that is causing the alarm. See the VantagePoint for Windows on-line 
Help for instructions on how to adjust a threshold in a policy).
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� Use the VP/Performance Grapher 
When you become aware of problems with a server (system), you can use 
the Performance Grapher to drill down for additional information or view 
historical trends.The Exchange SPI Graphs tools allow you to launch the 
VP/Windows Performance Grapher, where you can view data in graphs like 
the one pictured:

For details on the Performance Grapher, use the VP/Windows on-line Help 
for instructions for graphing selected Exchange SPI metrics. 
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� Review VP/Reporter Reports (if available) 
If you have purchased VantagePoint Reporter, you can review summary and 
detail reports, generated on a daily basis, for information on Exchange 
server performance/availability. These reports are listed and defined in the 
Exchange SPI on-line Help.

Using VantagePoint Reporter, you can view Exchange data in the many 
reports included in the Exchange SPI report package:
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Bar graphs and pie charts of Exchange Server data are also available in 
VantagePoint Reporter 



2

Installing & Configuring the 
SMART Plug-In for Exchange
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Getting Started with the Exchange SPI
The sections that follow offer instructions for deploying the VP/Windows agent, 
the Measurement Data Collector, the Exchange SPI package, and the Exchange 
SPI policies to the servers you want to monitor. Exchange SPI policy groups are 
covered after the last task in this section.

TASK 1: INSTALL THE EXCHANGE SPI WITH THE 
VANTAGEPOINT FOR WINDOWS ENTERPRISE SOLUTION 

When you insert the VantagePoint For Windows Enterprise Solution CD into 
your CD-ROM drive, the InstallShield wizard is automatically launched. In the 
first window you choose which products to install, one of which is VantagePoint 
SMART Plug-In for Exchange. 

Please see the HP OpenView VantagePoint for Windows Enterprise 
Management Installation Guide included with the product. This guide offers an 
overview of the products included in your package as well as the location of all 
product Release Notes, which you should print and read before getting started.

Note Choosing to install VantagePoint Reporter also usually installs the Exchange 
SPI report package. After you configure and deploy Reporter Collection 
policies, you receive reports in VantagePoint Reporter. If you do not install VP/ 
Reporter now but do so later, you must manually install the Exchange SPI 
report package (instructions for manual installation of the report package are 
included in the section Using the Exchange SPI with VantagePoint Reporter on 
page 36).

TASK 2: ADD EXCHANGE SERVERS TO THE NODES FOLDER

The servers you plan to monitor must be included in the Nodes tree of the 
VP/Windows management console window. If you have not already added every 
server, you need to do so now.
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To add the Exchange server(s) to the Nodes folder:

1. Open the VP/Windows console and right-click the Nodes folder and select 
Configure Nodes...

2. In the Configured Managed Nodes dialog, drag and drop nodes from left to 
right to add to the VP/Windows Nodes tree. 
(Note that in the right pane of the dialog you can create a folder for 
Exchange servers before you begin selecting individual servers or domains 
from the left.)
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TASK 3: DEPLOY THE (A) ENTERPRISE MESSAGE ACTION 
AGENT, (B) MEASUREMENT DATA COLLECTOR, AND (C) 
SPI FOR EXCHANGE PACKAGE TO THE NODES

After you have added all Exchange servers to the Nodes tree, you are ready to 
deploy the necessary components for data collection, alarm-generating, and 
reporting to those nodes.

To deploy the VP/Windows Enterprise Message/Action agent:

1. In the VP/Windows console expand the Policy management folder.

2. In the expanded tree of the console select Deployment packages.

3. In the details pane within the list that appears, right-click Enterprise 
Message / Action Agent and select All Tasks->Deploy on....

4. In the Deploy packages on... dialog select all nodes by clicking the check 
boxes next to Nodes, or select individual nodes by clicking check boxes 
next to each node and click OK.

5. To deploy the Measurement Data Collector, right-click Measurement Data 
Collector and select All Tasks>Deploy on....

6. In the Deploy packages on... dialog select all nodes as you did above and 
click OK.
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7. To deploy the Exchange SPI components, right-click SPI for Exchange 
and select All Tasks>Deploy on....

8.  Check Exchange server nodes once again and click OK. 

TASK 4: VERIFY INSTALLATION RESULTS

To check for successful deployment of the packages and policies on the 
monitored servers:

1. In the VP/Windows Manager console expand the Nodes folder.

2. Right-click the node on which to verify deployment and select 
View>Package Inventory.
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Using Exchange SPI Policies
Some Exchange SPI policies require that other software components, an 
Exchange SPI user account, and a mailbox be present on the monitored 
Exchange Server. The table that follows shows you group-by-group what 
requirements may exist. For ease of use, you can begin by installing the Quick 
Start policy group (as outlined in Deploying the Quick Start Policy Group on 
page 10).

EXSPI Policy Prerequisites/Descriptions

Some policies in the SPI for Exchange group require software 
components/services be present on Exchange server systems. For both the 
EXSPI Quick Start and the EXSPI Advanced groups, you must configure an 
MSXSPI account. 

Use the following tables to decide which policy groups you want to install.With 
Policy Group Compatibility/Requirements, you can see whether or not the policy 
group/subgroup works with Exchange 5.5 and/or Exchange 2000 as well as any 
required configuration (which is covered in the instructions for deploying the 
policy). Policy Group Descriptions shows you what type of data/functionality 
the policy group offers.

POLICY GROUP COMPATIBILITY/REQUIREMENTS

 Policy Group/
   Subgroup

Required Exchange 
Service

Exchange
5.5

Exchange 
2000

Required Manual 
Configuration 

 EXSPI Quick Start 
  All Policies

N/A YES YES  — MSXSPI user created
—Transaction Log
      policies modified
      with password

EXSPI Add-Ons
   EXSPI Internet Mail Service

Internet Mail Service
 (IMS)

YES NO
N/A
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POLICY GROUP DESCRIPTIONS 

 EXSPI Add-Ons
   EXSPI Lotus Notes 
Connector

Lotus Notes Connector YES YES N/A

 EXSPI Add-Ons
   EXSPI News Service

N/A YES NO N/A

 EXSPI Add-Ons
   EXSPI NNTP

Network News Transfer  
Protocol   (NNTP)

NO YES N/A

 EXSPI Add-Ons
   EXSPI SMTP

Simple Mail Transfer 
Protocol (SMTP)

NO YES N/A

 EXSPI Add-Ons
   EXSPI cc:Mail Connector

cc:Mail Connector YES YES N/A

 EXSPI Advanced
   EXSPI End to End Message
   Ping

N/A YES YES — MSXSPI user created
—MSXSPI mailboxes
     created on each system
—EXSPI Ping Config 
     to set up server pairs
—All policies modified
      with password

EXSPI Advanced
   EXSPI Reporter Collection

N/A YES YES — MSXSPI user created
—MSXSPI mailboxes
     created on each system
—EXSPI Ping Config 
     to set up server pairs
—All policies modified
      with password

EXSPI Advanced
   EXSPI Event Log Warnings
    &  Information

N/A YES YES  Use only for 
troubleshooting

 Policy Group/
   Subgroup

Required Exchange 
Service

Exchange
5.5

Exchange 
2000

Required Manual 
Configuration 

Group: EXSPI Quick Start Description

EXSPI Directory Service Executes alarm metrics for problems detected in the 
Microsoft Exchange Directory service.

EXSPI Event Log Errors Monitors all errors (type = Error) in the Windows 
System Log.
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EXSPI General Data Collection Contains all standard data collection policies used to 
feed data into the Measurement Data Collector. The 
collected data can be graphed in the 
VP/Performance Grapher or used to generate reports 
in VantagePoint Reporter.

EXSPI Information Store Executes alarm metrics for problems detected in the 
Exchange Information Store service

EXSPI Internal Errors Open Message Interface policy for trapping EXSPI 
errors.

EXSPI Message Transfer Agent Executes alarm metrics for problems detected in the 
Microsoft MTA service.

EXSPI Services and Processes Monitors the availability of key Exchange services 
and processes.

EXSPI Transaction Log Monitors disk space usage so that the transaction log 
disk does not run out of room.

Group: EXSPI Add-Ons Description

EXSPI Internet Mail Service Executes alarm metrics for the problems detected in 
Exchange Internet Mail service. Deploy on all 
Exchange servers containing IMS.

EXSPI Lotus Notes Connector Executes alarms for Lotus Notes Connector metrics. 
Deploy on all Exchange servers containing the Lotus 
Notes Connector.

EXSPI News Service Executes alarm metrics for problems detected in the 
Exchange News service. Deploy on all Exchange 5.5 
servers containing the Exchange News service.

EXSPI NNTP Executes alarm metric for outbound newsfeed 
connections that fail. For Exchange 2000 servers.

EXSPI SMTP Executes alarm metrics for problems detected in 
messages sent to the Simple Mail Transfer Protocol 
(SMTP) server. 

EXSPI-cc:Mail Connector Executes alarm according to for cc:Mail Connector 
metrics. Deploy on all Exchange servers containing 
the cc:Mail Connector.
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Group: EXSPI Advanced Description

EXSPI End to End Message Ping Alarms on AND collects data for the End to End 
Message Ping metric, 1002.

EXSPI Reporter Collection Feeds data into the Measurement Data Collector for 
use by VantagePoint Reporter.

EXSPI Event Log 
Warnings/Information

Monitors all warnings and information messages in 
the Windows System Log. Is not typically deployed.
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Deploying the Quick Start Policy Group
To receive any information from a configured Exchange server (one that you 
have added to the VP/Windows console), you must deploy the Quick Start policy 
group. This group contains the most basic definitions and rules for scheduling 
data collecting/graphing, and for generating messages/alerts.

PRELIMINARY TASK: DEPLOY THE BASIC EXCHANGE SPI 
POLICIES TO NODES

Prerequisite: VP/Windows agent (Enterprise Message/Action Agent), the 
Measurement Data Collector, and the SPI for Exchange deployment packages 
deployed to Exchange servers (see Getting Started with the Exchange SPI on 
page 2 of this section).

TASK 1: CREATE AN EXCHANGE SPI USER ACCOUNT

Before you can deploy Quick Start policies, you must create an account for each 
logon domain where Exchange servers reside. This account enables the 
Exchange SPI to access information from the Exchange database. 

Because significant differences exist between the configuration for Exchange 5.5 
and Exchange 2000, two sets of instructions are included for both 5.5 or 2000. 
Also, if you are using Windows 2000, you will notice that Exchange 5.5 uses 
some of its features, such as Active Directory, where you can create users and 
assign permissions.

NOTE You must create an MSXSPI user in each domain.

FOR MANAGED NODES USING EXCHANGE 5.5 IN A 
WINDOWS NT DOMAIN

For Windows 2000 systems, see page 13.

1. Log on as Domain Administrator of the domain to which the Exchange 
server belongs. 
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2. Select Start>Programs>Administrative Tools (common)>
User Manager for Domain.

3. Select User>New User, and in the dialog that appears create a new user as 
follows (see below for Windows 2000 systems:

Username: MSXSPI
Full Name: VP/Windows Exchange SPI
Description: Exchange SPI for VP/Windows
Password/Confirm Password: *********

Remember this password; you will need it later to update Tools and 
Policies.

NOTE This password must be entered but will not be authenticated later.
4. Deselect User Must Change password at Next Logon and select Password 

Never Expires
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5. Click the Groups button to display the Group Memberships window.

Adding the user account to the Domain Admins Group

6. At the right, from the Not a member of: box select the Domain Admins 
user, click Add, and OK to close the Group Memberships window.

To include necessary information, click buttons in the New User window:

Profile: No User Profile should be specified.
Hours: All hours of the day and week should be allowed.
Logon To: All workstations should be specified.
Account: Should never expire/should be Global Account.

7. Click Add to add this user. (If the Exchange Add Mailbox window is 
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displayed, select Cancel to close it.)

8. Click the Close button to close the New User window.

9. From the User Manager menu bar select Policies>User Rights....

10. Check the Show Advanced User Rights checkbox.

11. From the drop-down list select the following rights for the user account just 
added:
Log on as a service.
Profile system performance.

12. To assign rights, perform the following steps:

a Select Log on as a service in the Right field.

b Click the Add button to open the Add Users and Groups window.

c Click the Show Users button.

d Select the user account just added, click Add, then OK.

e Repeat to add the Profile system performance right.

FOR MANAGED NODES USING EXCHANGE 5.5. OR 2000 IN A 
WINDOWS 2000 DOMAIN:
1. Log on to the system that hosts the managed node’s domain.

2. For Exchange 5.5, select Start>Programs>Administrative Tools>
Active Directory Users and Computers

 Exchange 2000, select Start>Programs>Microsoft Exchange>
Active Directory Users and Computers

3. Expand the Active Directory of Users and Computers and right-click Users and 
select New>User.
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4. In the dialog box that appears enter MSXSPI as the First name and as the 
User logon name; click the down arrow to select the system name and click 
Next:

Enter information according to dialogs pictured previously, starting on 
page 11.

TASK 2: (FOR WINDOWS 2000 SYSTEMS ONLY) ENTER AN 
MSXSPI ACCOUNT DESCRIPTION

After you have created the MSXSPI user and mailbox, you can open the 
Properties page for the User to supply a description that helps identify the 
MSXSPI account as the SPI program that checks the server’s availability. 

To enter a description of the MSXSPI account: 

1. At the task bar, select Start>Programs>Microsoft Exchange>Active 
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Directory Users and Computers.

2. In the Active Directory window expand the Domain folder.

3. In the left pane expand the Users folder.

4. In the right pane, right-click MSXSPI and select Properties.

5. In the MSXSPI Properties page select the General tabbed page.
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6. Enter a description such as Exchange SPI for VantagePoint for Windows 
and exit.

Now you should see the description of the MSXSPI account in the Description 
column in the Active Directory window.

You have now created an Exchange SPI user account. Continue with “Grant 
Access Permissions to the User Access” on the next page.
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TASK 3: GRANT ACCESS PERMISSIONS TO THE USER 
ACCOUNT 

In order for the MSXSPI user account to have access to a mailbox as well as the 
Exchange IS Public and Private databases, it must have Exchange Admin 
permissions. Use Exchange Administrator to grant these permissions at the site 
level.

For Exchange 5.5 to grant MSXSPI access to each target Exchange 
server:
1. Select Start>Program>Microsoft Exchange>Microsoft Exchange 

Administrator.

2. For each Exchange site where Advanced policies are to be deployed:

a In the left pane within the tree, select <site_ name>.

a From the File menu select Properties.

b In the Properties window, select the Permission tabbed page and click 
Add to open the Add Users and Groups window.

c Select the MSXSPI user account previously created, and click the Add.

d Click OK to add the user and close the Add Users and Groups window.

e Verify the user has the role of Admin.

f Click OK to save the changes.

For Exchange 2000 grant MSXSPI access to each targeted 
Exchange server and enable Message Tracking:
1. Select Start>Program>Microsoft Exchange>System Manager

2. In the left pane expand the Administrative Groups folder.

3. Expand your <Exchange_server_administrative_group>folder.
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4. In the right pane, right-click the server to which you want to grant MSXSPI 
access and select Properties.

5. On the Properties page, select the Security tab.

6. In the Name box select MSXSPI.

7. In the Permission box, find the Receive As and Send As permissions check 
boxes and check both.

8. Repeat this procedure for each targeted Exchange server.
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Granting User MSXSPI Admin Privileges

NOTE At a large Exchange site, it can take several minutes to propagate the new 
Exchange administrator information. If you experience permission problems 
while accessing Exchange databases, enforce the setting of the new Exchange 
Admin account by logging directly on to the affected Exchange server (which is 
not yet replicated) and setting the account manually. 

TASK 4: ENABLE/EDIT QUICK START POLICIES

Quick Start policy sub-group EXSPI Transaction contains two Scheduled 
Command policies 
   —EXSPI-15m-Transaction Log 
   —EXSPI-1d-Transaction Log 
that require editing to include the MSXSPI account password as part of the 
policy properties. 
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To edit the policies:

1. In the VP/Windows console expand the Policy Management folder to 
display Policy Groups> SPI for Exchange-> EXSPI Quick Start-> 
EXSPI Transaction Log

2. In the details pane double-click EXSPI-15m-Transaction Log to open/edit 
the policy.

3. In the Properties sheet that appears on the Command tabbed page select the 
Specify password* check box and enter the password assigned to the 
MSXSPI account you created in Task 1: Create an Exchange SPI User 
Account on page 10.

4. Repeat step #2 and #3 for EXSPI-1d-Transaction Log.

TASK 5: DEPLOY EXCHANGE SPI QUICK START POLICIES

1. In the left pane of the VP/Windows Manager console expand the Policy 
management>Policy groups folders to view policy groups.

2. Click the plus next to Exchange SPI or double-click it to view Exchange 
SPI policy groups.

3. Right-click Quick Start and select Deploy on....

4. In the Deploy packages on... dialog select all nodes by clicking the check 
box next to Nodes, or select individual nodes by clicking checkboxes next 
to each node.
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Deploying Other Policy Groups
Two additional policy groups supplement the Quick Start group and contain 
policies that you can select individually rather than deploy as a group:

� EXSPI Add-ons can be deployed with no additional configuration. These 
policies collect data that show how related services, such as Lotus notes and 
Internet Information Services, are performing. Please see the previous 
section, listing the policies, for requirements for installing a specific policy 
in the Add-Ons group.
 

To deploy Add-ons policies, select individual policies, and follow the same 
steps used for deploying the Quick Start group.

� EXSPI Advanced policies:

� EXSPI End to End Message Ping policy group enables the Exchange 
SPI to test network connections to Exchange servers and collect 
performance data on message receipt and delivery. 

To deploy the EXSPI End to End Ping policy, complete the tasks, 
starting in the next section. 

� EXSPI Reporter Collection policy group requires that you have 
VantagePoint Reporter installed. 

To deploy EXSPI Reporter Collection policies, please refer to 
page 36, “Using the Exchange SPI with VantagePoint Reporter," for 
complete instructions.

� The EXSPI Event Log Warnings and Information policy group captures 
Windows event log text and are generally meant to be deployed for 
troubleshooting purposes.
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Configuring EXSPI End to End Message 
Ping
To test server connections and performance in sending/receiving messages, you 
can use the EXSPI End to End Message Ping policy group. To set up this policy 
requires a number a steps and the use of the EXSPI MBOX Config tool that 
allows you to create an Exchange mailbox accessible to the MSXSPI user you 
created when you set up the EXSPI Quick Start policies. The 
configuration/deployment instructions below take you through everything you 
need to do to start using the policy.

Requirement: When you configure server connections (Task 3: Set Up Server 
Connections to Test Message Delivery/Receipt (using PING) on page 25), you 
must start the EXSPI Admin tool EXSPI Ping Config from the VantagePoint 
management server.

TASK 1: EDIT THE MBOX CONFIG TOOL

To edit the MBOX Config tool:

1. In the VP/Windows console right-click the Tools folder.

2. In the Configure Tools window click to expand to display SPI for 
Exchange->EXSPI  Admin->EXSPI MBOX Config 

3. Double-click EXSPI MBOX Config and select the Target tabbed page in 
the Tool Properties sheet.

4. In the Password/Verify Password text boxes enter the password assigned to 
the MSXSPI user account you created in Task 1: Create an Exchange SPI 
User Account on page 10.

5. Click OK as required to save the change and exit.
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TASK 2: CREATE MAILBOXES

For Exchange 5.5 you must create a mailbox (for the MSXSPI 
account/password) on every targeted Exchange server so that MSXSPI user can 
access that mailbox and folder information. For Exchange 2000, you create a 
user and mailbox for every server; then grant permission for the MSXSPI user to 
access each of those mailboxes.

For Exchange 5.5, to create a mailbox:

1. In the of the VP/Windows Manager console expand the Tools>SPI for 
Exchange>EXSPI Admin folders.

2. In the scope pane double-click the EXSPI Admin folder and in the details 
pane right-click EXSPI MBOX Config and select Configure Tools....

3. Expand the tree again by selecting SPI for Exchange->EXSPI Admin.

4. Double-click EXSPI MBOX Config and in the Tools Properties sheet 
select the Target tabbed page and enter:
User name: MSXSPI
Password: <password> (assigned to this account in Task 1).

5. Select OK twice to exit the Properties sheet.

6. In the details pane, double-click EXSPI MBOX Config to configure 
mailboxes for the Exchange servers (you can select multiple nodes 
simultaneously).
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Example of successful Mailbox creation

OR
If you receive an error in the above step or you cannot automatically create 
mailboxes, you must manually complete the following on each Exchange 
server:

� For each Exchange server create a mailbox with the prefix MSXSPI
and NT hostname. For example, in the illustration above, the node 
rosspidb5.rose.hp.com (Internet name) and NT name ROSSPIB5 
require a mailbox called MSXSPIROSSPIDB5 with primary NT 
account MSXSPI.

For Exchange 2000 to create a user/mailbox for every targeted server:

1. Select Start>Programs>Administrative Tools>Active Directory Users and 
Computers.
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2. In the dialog box that appears enter MSXSPI as the First name and as the 
User logon name; click the down arrow to select the system name and click 
Next and enter information as required.

3. Repeat this process to create a mailbox for each Exchange 2000 server you 
are monitoring.

TASK 3: SET UP SERVER CONNECTIONS TO TEST MESSAGE 
DELIVERY/RECEIPT (USING PING)

To track the round trip time of a message—from one server to another, then back 
again—you can use the EXSPI End to End Message Ping policy in the Advanced 
group. Before deploying the policy, though, you must configure the pair of 
servers that you want to monitor. 

To configure the servers:
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1. From the VP/Windows management server within the console window, 
expand the VP/Windows Manager folder to display and select Tools>SPI 
for Exchange>EXSPI Admin folders.

2. In the details pane, double-click EXSPI Ping Config to configure the 
Exchange servers. The EXSPI Ping Config tool opens the default file as 
shown: 

# Examples:
# Format of the file:
# Src-Svr:Src-MB:::Dest-MB:Timeout:MetSLA:AlmostMetSLA
#
# Src-Svr = Source Server (required)
# Src-MB = Source Mailbox (optional).

Defaults to 'MSXSPI<host_name>'.
# Reserved = Reserved for future use, leave empty
# Reserved = Reserved for future use, leave empty
# Dest-MB = Destination Mailbox (required)
# Timeout = Timeout (required) (s-seconds, m-minutes,

h-hours) _
# MetSLA = Met SLA time (require for reports)

(s-seconds, m-minutes, h-hours)
# AlmostMetSLA = Almost met SLA time

(require for reports)
(s-seconds, m-minutes, h-hours)

#
# Examples:
# EXCH1::::MSXSPIEXCH2:25m:1m:1m
# EXCH1:MSXSPIEXCH1:::MSXSPIEXCH3:2h:5m:2m
# EXCH2:MSXSPIEXCH2:::MSXSPIEXCH4:1h:20m:10m
# EXCH3:MSXSPIEXCH3:::MSXSPIEXCH4:25m:5m:5m

3. Enter information about the servers to replace each entry separated by a 
colon (:). 

� Source Server - The server that the ping originates from. Each 
server where Exchange SPI is distributed has the same file, so 
Exchange SPI can parse this file and use all lines where the Source 
Server matches the server where it is run from.

� Source Mailbox (optional) - The mailbox to send the mail from. If 
this is not included, a default account is used 
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“MSXSPI<host_name>” where <host_name> is replaced with the 
name of the server.

� Destination Mailbox (required) -The mailbox to send the ping to. 
This field is usually the only required destination entry.

� Timeout (required) (s-seconds, m-minutes, h-hours): - If a sent 
message does not return in the defined timeout interval, EXSPI logs 
it as a failure and sends a message to the VP/Windows management 
server. Failed messages are tallied in terms of count and percentage 
within a report. The timeout value must be larger than the values for 
MetSLA and AlmostMetSLA so that a returned message can be 
processed using these values. It may have Exceeded SLA even 
though it has not exceeded the timeout interval. A 
Failed/Timedout message occurs, therefore, only when the 
message never returns and the timeout period is exceeded.

NOTE The minimum timeout value should be set slightly less than the collection 
interval. For example, if the collection interval for metric 1002 is 30 minutes 
(the default), the timeout should be set to at least 25 minutes. The logic is that 
because the next measurement occurs only every 30 minutes, you should allow 
up to that amount of time for any messages to return before “giving up” and 
generating a failure. If you keep the timeout value within the collection interval 
and the reply message does return, it can be processed as Met, Almost Met or 
Exceeded as opposed to Failed/Timedout.

� MetSLA (required for reports) (s-seconds, m-minutes, h-hours) -   
If the round trip time is greater than this value, the message is 
logged as either Almost Met SLA or Exceeded SLA. This value is 
required if data is being sent to the Measurement Data Collector 
Agent DSI for reporting (-l option when running exspi.exe). It is 
optional if only using alarms.

� AlmostMetSLA (required for reports) (s-seconds, m-minutes, 
h-hours) - If the round trip time is greater than the MetSLA value 
but less than or equal to MetSLA plus AlmostMetSLA, the message 
is logged as Almost Met SLA. Otherwise, when the round trip time 
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is higher than MetSLA plus AlmostMetSLA, it is logged as Clearly 
Exceeded SLA. This parameter is required if data is being logged to 
MeasureWare Agent DSI (-l option when running exspi.exe), 
optional if only using alarms.

NOTE Timeout, MetSLA, and AlmostMetSLA values can have optional identifiers that 
denote the measurement units the value represents; for example, 4m (4 minutes) 
30s (30 seconds) or 1h (1 hour). The default unit is seconds; for example, the 
entry 4 is recognized as 4 seconds.

Examples:

EXCH1::::MSXSPIEXCH2:25m:1m:1m - 
Use the default FROM mailbox of MSXSPIEXCH1. Message must return within 
1 minute to meet the SLA, 2 minutes to almost meet the SLA, and at over 25 
minutes generates a failure/timeout.

EXCH1:MAILBOXEXCH1:::MAILOXEXCH3:2h:5m:2m - 
Message must return within 5 minutes to meet the SLA, 7 minutes to almost 
meet the SLA, and at over 2 hours generates a failure/timeout.

EXCH2:MAILBOXEXCH2:::MAILOXEXCH4:1h:20m:10m - 
Message must return within 20 minutes to meet the SLA, 30 minutes to almost 
meet the SLA and at over 2 hours generates a failure/timeout.
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TASK 4: (OPTIONAL) SET UP EXSPI END TO END MESSAGE 
PING ALARMS—CONFIGURE SERVER PAIR THRESHOLDS

Alarms can be set to occur with metric 1002 (Ping). Because you may need to set 
different thresholds for multiple server pairs, the following examples are 
included. These examples show the syntax to insert in the exspilnk.txt file to set 
differing thresholds. Metric 1002 sends the "FromMailbox,ToMailbox" in the 
object pattern fields with the following definitions:

FromMailbox = FromServer:FromMailbox
ToMailbox    = :ToMailboxl

For example:

Config Entry Object
EXCH1::::MSXSPIEXCH2:25m:1m:1m EXCH1:MSXSPIEXCH1,:MSXSPIEXCH2
EXCH1:MAILBOXEXCH1:::
MAILOXEXCH3:2h:5m:2m

EXCH1:MAILBOXEXCH1,:MAILOXEXCH3

EXCH2:MAILBOXEXCH2:::
MAILOXEXCH4:1h:20m:10m

EXCH2:MAILBOXEXCH2,:MAILOXEXCH4

Condition Name & 
Type

Condition Object 
Pattern

Thrshld Explanation

EXSPI-1002.1
+Message on 
Matched Condition

EXCH1:MSXSPIEXCH1
,:
MSXSPIEXCH2

120 Threshold condition for 
ping between System 
EXCH1 and mailbox 
MSXSPIEXCH2 on 
system EXCH2. Object 
pattern is case sensitive.

EXSPI-1002.2
+Message on 
MatchedCondition

EXCH1:MSXSPIEXCH1
,:
MSXSPIEXCH3

240 Threshold condition for 
ping between System 
EXCH1 and mailbox 
MSXSPIEXCH3 on 
system EXCH3. Object 
pattern is case sensitive.
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TASK 5: MODIFY THE POLICY TO INCLUDE THE MSXSPI 
ACCOUNT PASSWORD

You need to edit the EXSPI End-to-End Message Ping policy for access to data 
on the Exchange Server system. 

To edit the policy:

1. Open the VP/Windows console and expand the Policy Management folder.

2. In the left pane select Policy groups>SPI for Exchange>EXSPI 
End-to-End Message Ping group.

3. In the right pane right-click the EXSPI End-to-End Message Ping policy 
and select All Tasks>Edit.

4. In the dialog that appears, leave the user name as MSXSPI, check the 
Specify Password check box, and enter the password you have assigned to 
the MSXSPI account.

5. Select the Save and Close button.

EXSPI-1002.3
-Suppress
Matched Condition

EXCH1:MSXSPIEXCH1
,:
MSXSPIEXCH2
EXCH1:MSXSPIEXCH1
,:
MSXSPIEXCH3

If the threshold was not 
exceeded for these two 
system pairs, you must 
suppress the message if 
either of these system 
pairs gets past 1002.1 or 
1002.2.

EXSPI-1002.4
+Message on
Matched Condition

60 A blank object pattern 
to catch all remaining 
system pairs.

Condition Name & 
Type

Condition Object 
Pattern

Thrshld Explanation
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TASK 6: DEPLOY INSTRUMENTATION

To distribute the configuration set up in the previous section, you use the 
VP/Windows Manager Instrumentation deployment package as follows:

1. In the of the VP/Windows Manager console expand the Nodes folder.

2. Select the node, right-click to select All Tasks>Deploy Instrumentation.

3. Repeat for each node to which you want to deploy the EXSPI End to End 
Message Ping policy.

TASK 7: DEPLOY THE POLICY

1. In the of the VP/Windows Manager console expand the Policy 
management>Policy groups folders to view policy groups.

2. Click the plus next to Exchange SPI>EXSPI Advanced to view the policy 
groups.

3. In the EXSPI Advanced folder double-click the Advanced policy group you 
want to deploy. 

4. In the details pane where all the policies are now listed, select the policies, 
right-click, and select Deploy on....

5. In the Deploy packages on... dialog select all nodes by clicking the check 
box next to Nodes, or select individual nodes by clicking checkboxes next 
to each node.

You have now completed the advanced configuration installation process. The 
Exchange SPI is ready to use. 
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Using Graphs Tools from a Remote 
VP/Windows Console
When the VP/Windows management server and the VP/Windows console are 
used on separate systems, you need to configure the tool to launch from the 
management server and display in the console. The configuration procedure 
involves two tasks. First, you change the properties of the directory where the 
tools program resides to shared. Second, you modify the tool properties to 
include the path to the VP/Windows management server.

TASK 1: SET THE VP/WINDOWS BIN FOLDER TO SHARED

1. On the VP/Windows management server start Windows Explorer.

2. In the Explorer window on the drive where VP/Windows is installed expand 
the tree to display
Program Files>Hewlett-Packard>OpenView>VantagePoint>bin.
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3. Right-click bin and select Sharing...

4. Select the Share this folder radio button and click OK.
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TASK 2: CHANGE INDIVIDUAL EXSPI GRAPHS TOOLS 
PROPERTIES

1. Using the VP/Windows console, expand the console tree to display: 
VantagePoint Manager>Tools.

2. Right-click Tools and select Configure Tools.

3. In the Configure Tools window expand the Tools tree to display:
Tools>SPI for Exchange>EXSPI Graphs>*.

4. Right-click an EXSPI Graphs tool and select Properties
OR
double-click the EXSPI Graphs tool.

5. In the Properties sheet Details tab in the Command:* text box modify the 
file name to include the following path: 
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\\$OPC_MGMTSV\bin\exspipv.vbs

6. Click OK.

7. Repeat for each tool.
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Using the Exchange SPI with VantagePoint 
Reporter
If you have purchased VantagePoint Reporter, you can use it with the SMART 
Plug-In for Exchange to generate reports. Report generation requires that you 
complete the following:

� Verify Installation of the Exchange SPI Report Package; 
Install the Exchange SPI Report Package (if necessary)

� Configure/deploy Exchange SPI Reporter Collection policies
� Enable VP Reporter to generate Exchange SPI reports

VERIFY INSTALLATION OF THE EXCHANGE SPI REPORT 
PACKAGE

VantagePoint Reporter, as a stand-alone application, may or may not be present 
on the VantagePoint for Windows system. If Reporter is not present on the same 
system as VP/Windows, you may need to install the Exchange SPI Report 
package.

To verify the Exchange SPI Report Package installation:

1. On the VantagePoint Reporter-installed system, open the Reporter main 
window and select File>Configure>Report Packages.
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2. In the Configure Report Packages dialog, check whether or not 
SPI for Exchange is present:
(a) If the SPI for Exchange is not present, proceed to the following section, 
"Install the Exchange SPI Report Package (if necessary)."

(b) If the SPI for Exchange is listed in the Available Packages, click the 
right-arrow and the OK button to install, and proceed to "Configure/Deploy 
Reporter Collection Policies for Use with VantagePoint Reporter."

(c) If the SPI for Exchange is listed in the Installed Packages, proceed to 
"Configure/Deploy Reporter Collection Policies for Use with VantagePoint 
Reporter."   
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INSTALL THE EXCHANGE SPI REPORT PACKAGE (IF 
NECESSARY)

To install the Exchange SPI Report Package on the VP Reporter system 
(necessary when VP Reporter is present on a system different from 
VP/Windows):

1. Insert the VP/Windows CD in the CD-ROM drive of the VP Reporter. 
system.

2. Select Start>Run>\<CD-ROM drive>:
\Products\
VP Exchange SPI Reporter Package\setup.exe

and follow the instructions on screen.

Now the Exchange SPI report templates are loaded into VantagePoint Reporter, 
you can proceed to the next section, where you set up policies for data collection.

Configure/Deploy Reporter Collection 
Policies for Use with VantagePoint Reporter

For any Exchange server system on which you would like to receive reports, you 
need to deploy Exchange SPI policies from the EXSPI Advanced-> 
EXSPI Reporter Collection group. But before deploying a Reporter Collection 
policy, you complete enable message tracking (for Exchange 5.5 systems), and 
configure an EXSPI user account with mailbox. Any steps you have completed 
in other setup procedures (for example, EXSPI End to End Message Ping), you 
can omit.

TASK 1: ENABLE MESSAGE TRACKING 

Exchange provides a message-tracking facility that stores processed message 
information in a log file. This information, which includes sender address, 
recipient address(es), and message size, is collected by the EXSPI-Dc-TrackLog 
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Data collection policy. This policy, part of the EXSPI Reporter Collection (Adv)
policy group, must be deployed to the appropriate managed node(s) as described 
later in this chapter. 

Message tracking must be enabled on Exchange servers as shown below.

For Exchange 5.5: Follow these steps to enable message tracking.

1. Select Start>Programs>Microsoft Exchange>Microsoft Exchange 
Administrator.

2. Expand the site level and Configuration to view selections beneath it.

3. In the details pane double-click Information Store Site Configuration.

4. In the Information Store Site Configuration Properties window, check the 
Enable message tracking checkbox, and select OK. 
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Enabling Message Tracking 
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5. Repeat steps 3 and 4 for MTA Site Configuration. 

Configuring the MTA Site

If the Internet Mail Service connector does not exist, skip the following steps.

6. In the left pane select Connections.

7. In the right pane select Internet Mail Service, check the Enable message 
tracking checkbox, and press OK.

For Exchange 2000: Follow these steps to enable message tracking.

1. Select Start>Programs>Microsoft Exchange>System Manager.

2. Expand the Administrative Groups to see individual servers.

3. Right-click on the server and select Properties. 

4. In the General tab check the Enable message tracking check box.
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5. Repeat steps #3 and #4 for each server.

TASK 2: EDIT THE MBOX CONFIG TOOL

To edit the MBOX Config tool:

1. In the VP/Windows console right-click the Tools folder.

2. In the Configure Tools window click to expand to display SPI for 
Exchange->EXSPI  Admin->EXSPI MBOX Config 

3. Double-click EXSPI MBOX Config and select the Target tabbed page in 
the Tool Properties sheet.

4. In the Password/Verify Password text boxes enter the password assigned to 
the MSXSPI user account you created in Task 1: Create an Exchange SPI 
User Account on page 10.

5. Click OK as required to save the change and exit.

TASK 3: CREATE MAILBOXES

For Exchange 5.5 you must create a mailbox (for the MSXSPI 
account/password) on every targeted Exchange server so that MSXSPI user can 
access that mailbox and folder information. For Exchange 2000, you create a 
user and mailbox for every server; then grant permission for the MSXSPI user to 
access each of those mailboxes.

For Exchange 5.5, to create a mailbox:

1. In the of the VP/Windows Manager console expand the Tools>SPI for 
Exchange>EXSPI Admin folders.

2. In the scope pane double-click the EXSPI Admin folder and in the details 
pane right-click EXSPI MBOX Config and select Configure Tools....

3. Expand the tree again by selecting SPI for Exchange->EXSPI Admin.
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4. Double-click EXSPI MBOX Config and in the Tools Properties sheet 
select the Target tabbed page and enter:
User name: MSXSPI
Password: <password> (assigned to this account in Task 1).

5. Select OK twice to exit the Properties sheet.

6. In the details pane, double-click EXSPI MBOX Config to configure 
mailboxes for the Exchange servers (you can select multiple nodes 
simultaneously).

Example of successful Mailbox creation

OR
If you receive an error in the above step or you cannot automatically create 
mailboxes, you must manually complete the following on each Exchange 
server:
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� For each Exchange server create a mailbox with the prefix MSXSPI
and NT hostname. For example, in the illustration above, the node 
rosspidb5.rose.hp.com (Internet name) and NT name ROSSPIB5 
require a mailbox called MSXSPIROSSPIDB5 with primary NT 
account MSXSPI.

For Exchange 2000 to create a user/mailbox for every targeted server:

1. Select Start>Programs>Administrative Tools>Active Directory Users and 
Computers.

2. In the dialog box that appears enter MSXSPI as the First name and as the 
User logon name; click the down arrow to select the system name and click 
Next and enter information as required.

3. Repeat this process to create a mailbox for each Exchange 2000 server you 



Chapter 2: Installing & Configuring the SMART Plug-In for Exchange
Using the Exchange SPI with VantagePoint Reporter

2 - 45

are monitoring.

TASK 4: MODIFY THE REPORTER COLLECTION POLICIES 
TO INCLUDE THE MSXSPI ACCOUNT PASSWORD

You need to edit each EXSPI Reporter Collection policy so that Exchange 
Server system data is accessible. 

To edit the policy:

1. Open the VP/Windows console and expand the Policy Management folder.

2. In the left pane select Policy groups>SPI for Exchange>EXSPI 
Advanced>EXSPI Reporter Collection group.

3. In the right pane right-click each Reporter Collection policy and select All 
Tasks>Edit:

� EXSPI-Dc-Exchange Info

� EXSPI-Dc-Mailbox Data

� EXSPI-Dc-Private IS Sum. Data

� EXSPI-Dc-Public Folder Data

� EXSPI-Dc-Public IS Sum. Data

� EXSPI-Dc-Tracklog Data

4. In the dialog that appears, leave the user name as MSXSPI, check the 
Specify Password check box, and enter the password you have assigned to 
the MSXSPI account.

5. Select the Save and Close button.

6. Repeat for each policy.
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TASK 5: DEPLOY REPORTER COLLECTION POLICIES

1. In the of the VP/Windows Manager console expand the Policy 
management>Policy groups folders to view policy groups.

2. Click the plus next to Exchange SPI>EXSPI Advanced to view the policy 
groups.

3. In the EXSPI Advanced folder double-click the Advanced policy group you 
want to deploy. 

4. In the details pane where all the policies are now listed, select the policies, 
right-click, and select Deploy on....

5. In the Deploy packages on... dialog select all nodes by clicking the check 
box next to Nodes, or select individual nodes by clicking check boxes next 
to each node.

Enable VP Reporter to Generate Exchange 
SPI Reports

A couple more tasks remain that you must complete at the VP Reporter system. 

TASK 1: ADD EXCHANGE SERVER SYSTEMS TO VP 
REPORTER DISCOVERY AREA

In order for VP Reporter to generate reports on any Exchange Server system, it 
must "discover" the system. To enable VP Reporter to discover the Exchange 
Server system(s):

1. Open the Reporter main window.

2. Expand the Discovery Area to display the Exchange Server systems you 
need to add.

3. From left pane to right, drag and drop each system to be discovered.
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4. From the Action menu select Run>Discover Systems.
(In Reporter’s Status pane, text appears to notify you of system(s) 
discovery.)

5. Expand the Discovered Systems>All folder and drag and drop the 
Exchange Server systems from the All area to the NT area.

TASK 2: ASSIGN EXCHANGE SPI REPORTS TO EXCHANGE 
SERVER SYSTEMS 

You need to assign only the Exchange Detail Reports to individual Exchange 
Server systems. Exchange Summary Reports are automatically generated for all 
managed Exchanged Server systems.

1. In the Reporter main window left pane, expand Reports to display 
Exchange Detail reports.

2. In the left pane expand the Discovered Systems to display the Exchange 
Server system for which you want to generate reports.

3. Double-click the Exchange Server system to which you want to assign the 
Exchange SPI report.
(The system information should appear in the right pane.)

4. Use Ctrl+Shift to select all the Exchange Detail reports and drag them from 
left to right to the Exchange Server system that should be displayed in the 
right pane.

5. Repeat for every Exchange Server.

You may find it necessary to wait until the following day to see reports 
generated for the servers to which you have assigned Exchange SPI reports.
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Customizing Policies Using the Tag Feature
If you have servers dedicated to specific sites or business units, you may find it 
effective for those servers to have specific, uniquely named Exchange SPI 
policies. In such cases, you copy default policies into new groups, affix prefixes 
to the original names and include them in the schedule policy that collects data 
during that measurement interval. The procedure below gives you an example of 
how you might do this.

TASK 1: CREATE THE NEW POLICY GROUP AND 
COPY/PASTE POLICIES INTO IT

1. In the Console, expand the Policy management>Policy Groups folders.

2. Right-click the folder in which you want to locate the new group and select 
New>Policy Group.

3. Enter the new group name for the folder created and press Enter.

4. In the Console, right-click the default policy group that has policies you 
want use, or you can use Shift+Click or Ctrl+Click to select the specific 
policies you want placed in the group and select Copy.



Chapter 3: Customizing/Removing the Exchange SPI
Customizing Policies Using the Tag Feature

3 - 3

NOTE Remember to always copy Schedule Command policies from the default policy 
group containing the policy you are copying to the new policy group. After you 
create the new policy, you must also include it for data collection in the 
Schedule Command policy. 
5. Right-click the new group you just created and click Paste.

TASK 2: TAG THE POLICIES.

To associate these policies with a specific group, use a prefix. (If you copied an 
entire group of default policies into the new group, you can eliminate those you 
do not need by right-clicking them and selecting Delete.) 
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1. Double-click each policy and make changes (if any) as desired. 

2. When you are finished, select File>Save As and in the dialog that appears 
enter a prefix followed by a hyphen (<prefix>-) to precede the default 
policy name; for example MKT-EXSPI006.

3. After saving the renamed policies, double-click each schedule command 
policy that included the original policy to open the Schedule Command 
dialog.

4. In the dialog that appears, select the Command tab.

5. In the Command* text box at the end of the text, insert the tag (-t) 
parameter and the <prefix>- 
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For example, to ensure data collection for all the policies renamed with the 
prefix MKT- the Command text box would appear as follows:

6. When you are finished, select the Save and Close button (above the 
Command tab).

The prefix attached to the beginning of each policy in the new group makes the 
policies easy to find in the Policies grouped by type folder in the Console. Also, 
creating a new group for the new policies gives you an efficient means to deploy 
them (right-click the group and select All Tasks>Deploy on...). Please see the 
online Help for details.
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Uninstalling Exchange SPI
To remove the Exchange SPI, first uninstall all components and policies from 
the managed nodes, then from the management server. 

TASK 1: REMOVE THE EXCHANGE SPI PACKAGE FROM 
MANAGED NODES

1. In the VP/Windows console tree double-click (or click the plus next to) 
VantagePoint Manager to expand the tree.

2. Double-click (or click the plus next to) Nodes and click the node from 
which you want to remove the Exchange SPI package (or you can 
right-click the node, select View>Package Inventory). 

3. In the details pane select EXSPI components, right-click, and select All 
Tasks>Remove from node.

4. Repeat for every managed node.

TASK 2: REMOVE EXCHANGE SPI POLICIES FROM ALL 
MANAGED NODES

1. From the VP/Windows console window, in the console tree double-click (or 
click the plus next to) VantagePoint Manager to expand the tree.

2. Double-click (or click the plus next to) Policies grouped by type to display 
all policies.

3. In the console tree select Measurement Threshold.

4. In the details pane click the Name column to sort policies by name and 
select all (Shift+click) policies starting with EXSPI.

5. In the details pane right-click highlighted policies and select All 
Tasks>Remove from all nodes.
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6. Repeat for remaining three Exchange SPI policy types: 
Open Message Interface, 
Scheduled Command, and 
Windows Event Log, 
selecting all policies that start with EXSPI, right-clicking and choosing 
AllTasks>Remove from all nodes.

TASK 3: REMOVE EXCHANGE SPI POLICY GROUPS FROM 
THE MANAGEMENT SERVER

1. In the console tree select Policy groups.

2. Right-click SPI for Exchange and select Delete.

TASK 4: REMOVE EXCHANGE SPI TOOLS FROM THE 
MANAGEMENT SERVER

1. In the console tree right-click Tools and select Configure Tools.

2. In the Configure Tools dialog right-click SPI for Exchange and select 
Delete.

TASK 5: UNINSTALL EXCHANGE SPI PROGRAMS FROM 
THE VP/WINDOWS MANAGEMENT SERVER

1. Select Start>Settings>Control Panel.

2. In the Control Panel select Add/Remove Programs. 

3. In the Add/Remove Properties Install/Uninstall tabbed page, select SPI for 
Exchange <current_version> and click the Add/Remove button.

4. Select Yes and Yes To ALL to prompts regarding removal of shared 
components.
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