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Support

Please visit the HP OpenView web site at:

http://www.managementsoftware.hp.com/ 

This web site provides contact information and details about the products, services, and 
support that HP OpenView offers.

You can also go directly to the support web site at:

http://support.openview.hp.com/ 

HP OpenView online software support provides customer self-solve capabilities. It provides a 
fast and efficient way to access interactive technical support tools needed to manage your 
business. As a valuable support customer, you can benefit by using the support site to:

• Search for knowledge documents of interest

• Submit and track progress on support cases

• Manage a support contract

• Look up HP support contacts

• Review information about available services

• Enter discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and log in. 
Throughout the site, access levels are indicated by the following icons:  

To find more information about access levels, go to the following URL:

http://support.openview.hp.com/access_level.jsp 

To register for an HP Passport ID, go to:

 https://passport2.hp.com/hpp/newuser.do
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Chapter 1
Introducing the Active Directory SPI

This chapter introduces you to the HP OpenView Smart Plug-in for Microsoft 
Active Directory, offering an overview of its functions and components. The 
chapter covers the following: 

• “What the Active Directory SPI Does” on page 7

• “Components of the Active Directory SPI” on page 8

• “What to Expect After Installing AD-SPI” on page 12

What the Active Directory SPI Does

The Smart Plug-in (SPI) for Active Directory adds single master operations, 
replication, DNS, DIT, GC and trust monitoring/mapping capabilities to 
OpenView Operations for Windows. The Active Directory SPI keeps you 
informed of Active Directory-related conditions occurring across the network 
so that you can view your environment and be continually updated on the 
following:

• Data is consistent across all Domain Controllers.

• Replication is successfully completing in a timely manner.

• Systems are able to cope with outages.

• All role masters are running.

• Domain controllers are not contending with overly utilized CPUs.
7



Components of the Active Directory SPI
• Active Directory is not experiencing capacity and fault-tolerance issues.

• Active Directory global catalog is replicating in a timely manner.

• Services, events, processes, and synchronizations are at acceptable 
performance levels.

• Index and query activities for authentications, LDAP client sessions, etc., 
are occurring at acceptable levels.

• Trust relationship status between sites and DCs is as expected.

• Forests, sites, domain controllers appear as expected in both hierarchical 
and map renderings through the OpenView Topology Viewer tool 
(included with the Active Directory SPI).

Components of the Active Directory SPI

The Active Directory SPI (AD-SPI) components include policies for service 
monitoring, tools for graphical displays of site/server connections, updating 
information on domain controllers, and troubleshooting AD-SPI, and finally 
reports and graphs for consolidating and charting the collected data. 

Policies: AD-SPI policies allow you to control the monitoring schedule and 
receipt of collected information in the form of service problem alerts and 
messages. AD-SPI service map alerts are shown in the OVO service map, while 
AD-SPI messages are available in the OVO message browser. 

Tools: The AD-SPI includes tools as follows: 

— The OpenView Topology Viewer: This tool provides you with a 
simple means for viewing the content and topology of your Active 
Directory domains and sites, rearranging objects on the map, and 
saving the layout you have arranged on the map. When launched and 
connected to a domain controller, the OpenView Topology Viewer 
generates a tree showing your Active Directory components as well as 
a graphical map that shows the Active Directory site(s), forest(s), 
domains, and DC replication connections.

The OpenView Topology Viewer also allows you to view the 
Exchange environment if you are also running the Exchange SPI.
8



Chapter 1
— The AD DC Demotion Preparation tool is used in preparation for a 
domain controller demotion. This tool should be used only after you 
have installed and configured the Active Directory SPI and begun to 
use it to monitor DCs in your Active Directory environment. In 
preparation of a domain controller demotion, you use this tool to 
disable the Active Directory SPI from continuing to monitor the 
demoted DC. 

— The AD Trust Relationships tool, when launched on an Active 
Directory managed node, generates information about the domain 
controller and its trust relationship within its domain that includes 
trust type, trust status, and the tree (in the OV console) in which it 
resides.

— The AD Self-Healing Info tool, when launched on an Active 
Directory managed node, collects error-related logfile entries that you 
can send to HP support for assistance in solving operations issues 
with AD-SPI.

Reports and Graphs: AD-SPI integrates with OVO’s reporting/graphing 
capabilities to produce Web-based, management-ready reports as well as 
graphs. While AD-SPI message and service map alerts provide you with 
information about present conditions on specific managed nodes, the OVO 
reporting and graphing provide you an overview, helpful in determining needs 
for the long-term.

Active Directory SPI Policy Group Descriptions 

Two major subfolders for Active Directory SPI policies are located under 
Policy Groups→SPI for Active Directory; they are Auto-Deploy and 
Manual-Deploy. The Auto-Deploy folder contains policies that are 
automatically deployed to any system running Active Directory after services 
relevant to them are discovered. The Manual-Deploy folder contains policies 
that you must “push” out to the managed nodes as needed. Many of these 
policies may have already been deployed as a result of the Windows OS 
9



Components of the Active Directory SPI
discovery that runs automatically when system nodes are added to the 
Managed Nodes folder (please see the OpenView Operations/Performance 
Installation Guide following your OVO for Windows installation). 

• Auto-Deploy policy subgroups and their functions are as follows: 

— Discovery: AD-SPI includes service discovery policies that can detect 
DIT, DNS, FSMO, replication, global catalog, and trust services/
components running on OVO-managed nodes. These discovered 
services augment the topology already created through the OVO 
Windows discovery (included with OVO). 

— DIT Monitoring. (Size and activity) Checks the size of the Active 
Directory database known as the directory information tree (DIT) and 
monitors the amount of free space. Also tracks the number of 
operations pending against the DIT.

— DNS Monitoring (Configuration/Connectivity). DNS monitoring 
policies check the existence, visibility, and validity of various service 
resource records on a DNS server. The SRV records enable DNS 
clients to locate specific services available on other servers; when a 
DNS policy encounters missing or incorrect information, it sends an 
alert to the OVO message browser. Other policies check the 
responsiveness and availability of specific DNS servers and DNS 
services used by Active Directory.

— FSMO Monitoring (Operations Masters general responsiveness and 
role movement). Through bind/ping, monitors general responsiveness 
of operations master services and master role movement among 
domain controllers that includes domain naming, schema master 
response, infrastructure master, schema master, PDC master, and 
RID master (RID pool requests).

— Replication Latency. Replication policies can measure the time 
required to propagate a change to all domain controllers within the 
domain. In addition, a policy can also monitor the replication time of 

The Manual-Deploy policies are also available in the OVO for Windows Core 
SPI policies. The Windows OS SPI service discovery automatically discovers 
the Active Directory services associated with these policies, but deployment of 
the policies is not automatic. You can deploy these policies as necessary either 
individually or as a group.
10



Chapter 1
inter-site and intra-site replication latency. Replication policies are 
run regularly in order to modify an Active Directory latency object to 
determine acceptable/unacceptable response times/conditions.

— Response Time. Response time policies measure the general 
responsiveness of Active Directory as well as the responsiveness of 
global catalog binds and queries.

— Global Catalog Replication. These policies measure the time 
required for the global catalog to replicate from two perspectives: (1) a 
domain controller providing the service (GC) and (2) a domain 
controller accessing the service (DC).

— Sysvol Monitoring. These policies monitor Sysvol file replication 
service [FRS], Sysvol size, connectivity, and synchronization with 
Group Policy Objects [GPOs], all of which are major indicators of 
Active Directory health.

— Trust Monitoring (for Windows 2003 systems only): These 
policies monitor trust health and gather data that allows the Trust 
Relationships tool to provide updates in changes within trust 
relationships. 

Manual-Deploy policy subgroups/functions are as follows (please refer to the 
Smart Plug-in for Windows OS online Help for descriptions of the individual 
policies): 

— Connector policies (9): These policies use Active Directory 
Connector performance monitor counters to check activities occurring 
around connection issues involving logon authentication, pages in 
memory (working set), page faults, warnings, errors, and processing 
time. 

— Domain and OU Structure policies (2): These policies monitor 
domain and organization unit (OU) changes.

— Directory Services Access policies (3): These policies monitor 
Directory Services servers, gathering data from their performance 
monitor counters in regards to reads/writes/searches of the directory.

— Health Monitors policies (20): These policies check areas of Active 
Directory involving services, events, processes, and synchronizations 
essential to its acceptable performance. Key services and their 
associated processes include Kerberos Key Distribution Center (KDC), 
11



What to Expect After Installing AD-SPI
NetLogon, NT LM Security Support Service, PolicyAgent, directory, 
and Security Account Manager. Log monitoring checks for the 
occurrence of specific events in the Windows Event Log and the 
System log. 

— Index and Query policies (5): Monitors index and query activity for 
authentications, LDAP client sessions, etc.

— Replication (Manual-Deploy) policies (5): Monitors replication 
through measurement of inbound objects between and within sites, 
verification of synchronization of replication updates, pending 
updates, and queue size in replication inbound objects.

— Replication Activity policy (1): Monitors the Directory Service log 
for replication events. 

— Security policies (10): Monitors (a) Security event logs for Active 
Directory related events, (b) Security group changes, (c) performance 
monitor counters associated with Security.

— Site Structure policy (1): Monitors the Active Directory Site to 
ensure that IP subnets are not being added, changed, or deleted 
unnecessarily.

What to Expect After Installing AD-SPI

Like other Smart Plug-ins, the Active Directory SPI adds specific monitoring 
capabilities to OVO. After you have performed all steps required for 
installation and configuration of the AD-SPI, discovery occurs and the OVO 
console displays services in both the details (left) and content (right) panes. 
Within the details pane, the hierarchy expands to show the specific services 
present on each domain controller (DC). Likewise, the service map now 
includes another level of detail below each DC. In addition in the console tree, 
you will see all Active Directory folders under Policies, Tools, and Reports & 
Graphs.
12



Chapter 1
The Services and Components Discovered by the Active 
Directory Smart Plug-in (AD-SPI)

The Active Directory Smart Plug-in includes service/component discovery 
policies that build on the initial discovery that takes place with the Windows 
OS Smart Plug-in. The Windows OS SPI Auto-Discovery policies discover the 
Windows infrastructure (including the defined Active Directory domains and 
sites). AD-SPI expands that discovery to add multiple levels of detail at both 
higher and lower levels. At a higher level, the Active Directory Smart Plug-in 
identifies forest(s), while at a lower level AD-SPI identifies each Domain 
Controller by its specified name and adds the services/components available 
on it. Finally the AD-SPI shows the partitions in the discovered sites. 

Figure 1 Below is a diagram of the Active Directory Smart Plug-in 
discovery, which supplements the Windows OS SPI 
discovery to includes forest(s), sites, domain controller 
services/components, and the preferred bridgehead 
servers (PBHS) connecting sites. 
13



What to Expect After Installing AD-SPI
After AD-SPI discovery occurs, Active Directory services and components are 
displayed in the service map so that you are able to see the specific domain 
controllers and specific sites. More detail appears both above and below each 
domain controller, where you can now see Active Directory components and 
services, including forests, replication, and Sysvol, to name just a few. 

Figure 2 Below is the OVO service map in which AD-SPI now 
identifies the Active Directory forest and DC services/
components. With these additions, you can drill down from 
a service alert at the forest level to the domain controller 
service/component causing the problem.    
14



Chapter 1
Figure 3 By right-clicking a service where an alert is occurring 
(indicated by its having turned red) and choosing Root 
Cause, you can see where the problem is originating. 

How AD-SPI Policies Generate Information in the OVO Console

Active Directory data is targeted and gathered according to rules and schedule 
specifications contained within policies. Policies control Active Directory data 
collection and interpretation and enable its display in the following formats.

Service map alerts: After the AD-SPI discovery occurs, the OVO Services 
tree is updated with more information on Forests/Domains/Sites/Domain 
Controllers (DCs). The service map is updated to graphically add specific 
forests, services and components to the Domain Controller names (DC: 
<name>). Those Active Directory DC services/components include replication, 
DIT, DNS, GC (global catalog), operations master (FSMO), and Sysvol (see 
Figure 2 on page 14). In addition, the Site map also shows the added Domain 
Controllers/Services, from a site-centric perspective. 

Messages in the OVO message browser: Using the measurement 
threshold policy settings and the collected values/states for each targeted 
domain controller, the OVO agent software forwards appropriate messages to 
the console, where they are displayed with color-coded severity level.
15



What to Expect After Installing AD-SPI
OVO reporting/graphing: Reports are available under Reports & Graphs in 
the OVO console tree. These reports cover master operations connect times, 
DIT activity/size, DNS availability, GC replication delay times, and graphs on 
replication latency, DC availability, global catalog search response time levels, 
Sysvol size, and trust monitoring relationships. Each offers helpful 
information for analyzing trends and balancing server loads. 

How the OV Topology Viewer Displays Information

The OV Topology Viewer is a tool that, once launched and then connected to a 
domain controller, opens a window of its own where it displays information 
about Active Directory forests, domain controllers, partitions, and 
connections. The tool also works in conjunction with the Exchange SPI, so if 
you are running the Exchange SPI, the generated view will likely contain 
Exchange servers. The OV Topology Viewer allows a view of Active Directory 
and Exchange information in two ways:

Expandable/collapsible tree: In the left pane of the OV Topology Viewer 
window you can see the various components that comprise an Active Directory 
forest and its domains, the domain which hosts the domain controller, as well 
as the sites available through the connection. For environments containing 
parent/child domain relationships, the Topology Viewer also reflects those 
distinctions: within the tree, as appropriate, child/grandchild domains are 
nested within in the parent domain in a hierarchical structure.

Topological view of site connections: The right-pane of the window offers 
a graphical representation of forests, sites and site links, DCs, GCs, and the 
connection objects linking them. Sites and DCs can be moved to accommodate 
more effective viewing in the map. Double-clicking a DC retrieves further 
information, such as the version of Windows that is running, status 
information, and more. The map also has zoom-in/zoom-out functions and 
allows exporting the view of the topology to a bitmap.

SPI Changes/Uses

You can use AD-SPI policies with no customization, or you can change them as 
you find necessary. Minor and major changes can occur as follows:

Modification of default policies: You can change a default policy by using 
the OVO console to select the policy and change conditions within it. The 
changes you might make include: (1) frequency of the monitoring interval, (2) 
message text, and (3) severity of the alert.
16



Chapter 1
Creation of custom data collection groups: You can also create custom 
data collections where you can change the monitoring interval and/or 
threshold for a single Domain Controller. To create a separate group of polices, 
you can copy the desired polices into a folder with the new group name; after 
pasting the policies into the new group, you can then modify them and 
re-version them with your own version numbers (see, “Modify a Monitoring 
Schedule or Measurement Threshold” on page 55). The user-created versions 
make it possible to deploy specifically tailored policies to node groups to meet 
their monitoring needs. Using this method makes it possible to bring nodes 
and policies together in groups that are easily recognizable. 

Following are summaries for how the Active Directory SPI policies are used.

Policy use: Active Directory SPI policies are available in the OVO console in 
two different ways: the first is according to group name under the Policy 
groups folder, and the second is according to type under the Policies grouped 
by type folder. You can view or edit an Active Directory SPI policy within 
either of these categories. 

• Policy groups: organizes policies according to deployment method and area 
to be targeted for discovery or monitoring. The Auto Deploy group allows 
you to deploy all subgroups at once. The sub-groups allow you to choose a 
specific task (such as discovery) or area to monitor (such as DIT, DNS, 
FSMO, GC, Replication, Response Time, Sysvol, or Trust*).
The Manual Deploy subgroup allows you to choose additional policies and 
deploy as you desire.
*Trust relationship monitoring is available for Windows 2003 systems 
only. 

• Policies grouped by type: organizes policies according to their function; for 
example, you can find the scheduling for GC, replication, or FSMO 
monitoring in Scheduled Tasks policies; you can find the conditions 
(thresholds) for those replication/FSMO policies in the Measurement 
Threshold policies. 

A printable management-ready graph of Active Directory replication latency 
data is available through the Reports & Graphs area of the OVO console. This 
graph provides baseline latency response time averages to help you determine 
how to adjust schedules/thresholds.
17



What to Expect After Installing AD-SPI
The Topology Viewer Tool

The Topology Viewer generates a map that shows the selected Active Directory 
environment, its forest(s), and the connections between sites and servers. 
Other details also available in the map are the names of the domain 
controllers, inter- and intra-site connections. To use the tool requires only that 
you connect to a domain controller. Once connected to a server, the tool does 
the rest. 

Figure 4 The replication map captures information on site links at 
the time of the map’s generation. Changes to your 
environment are not automatically reflected in the map. 
However, you can update the map by selecting 
File→Refresh Data.
18



Chapter 2
Upgrading/Installing the Active 
Directory SPI

The sections that follow cover upgrades and new installations of the HP 
OpenView Smart Plug-in for Microsoft Active Directory. After you upgrade or 
install the SPI, you can discover Active Directory services running on 
OVO-managed nodes. Details are included on the discovery actions 
automatically occurring and those requiring manual steps, depending upon 
previous installations/configurations.

For instructions on upgrading, installing, or uninstalling the AD-SPI, refer to 
the specific sections:

• “Before Starting” on page 19

• “Upgrading the Active Directory SPI” on page 21

• “Installing the Active Directory SPI” on page 25.

• “Uninstalling the Active Directory SPI” on page 39

Before Starting

Policy changes listed in the table below include modifications of any kind to 
the SPI for Active Directory policy group. This list and the suggested 
preparation for upgrades can help you determine whether you need to modify 
newly installed policies.
19
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Modifications should occur prior to your deployment of Discovery policies 
(after which new policies are automatically deployed as appropriate).

Table 1 Version B.03.10 policy modifications

Policy Name Policy Change

ADSPI-FSMO_RoleMvmt New scheduled task policy; determines when 
a FSMO role is seized or transferred from 
one domain controller to another.

ADSPI-FSMO_RoleMvmt_INFRA New measurement threshold policy; 
monitors the domain controller’s ownership 
of the Infrastructure Master FSMO role.

ADSPI-FSMO_RoleMvmt_NAMING New measurement threshold policy; 
monitors the domain controller’s ownership 
of the Domain Naming Master FSMO role.

ADSPI-FSMO_RoleMvmt_PDC New measurement threshold policy; 
monitors the domain controller’s ownership 
of the PDC Emulator FSMO role.

ADSPI-FSMO_RoleMvmt_RID New measurement threshold policy; 
monitors the domain controller’s ownership 
of the RID Master FSMO role.

ADSPI-FSMO_RoleMvmt_SCHEMA New measurement threshold policy; 
monitors the domain controller’s ownership 
of the Schema Master FSMO role.

All DNS Monitoring policies Modified continued actions: Alarms, once 
generated, do not continue to generate 
duplicate messages. All DNS monitoring 
policies now detect 'Hub and Spoke' settings 
in the user's Active Directory environment 
and taylor the alarms generated for missing 
records to reflect the 'Hub and Spoke' 
settings.

All Response Time Monitoring policies Modified continued actions: Alarms, once 
generated, do not continue to generate 
duplicate messages
20
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Upgrading the Active Directory SPI

Some manual actions are suggested before you begin (see below). During an 
upgrade, using Volume 1 of the Smart Plug-ins, New and Upgraded CD set, 
the previous version is detected and the smart plug-in installation proceeds as 
expected. To ensure easy access to policy customizations made in your 
previous version, be sure to complete the procedure below.

Prepare to Upgrade the New AD-SPI

Before upgrading the Active Directory SPI using the Smart Plug-ins, New and 
Updated, CD set, please see the Openview Operations for Windows Readme to 
ensure that you have met OpenView Operations for Windows management 
server prerequisites. Then complete the tasks below to (1) ready nodes to 
receive new policies and set up a reference folder for convenient access to 
previous customizations.

Task 1: Remove AD-SPI policies from managed nodes.

1 At the console, select Operations Manager→Policy management→Policy 
groups→SPI for Active Directory→Auto-Deploy.

2 Right-click Auto-Deploy and select All Tasks→Uninstall from...

3 Select all Nodes running Active Directory.
(It is all right to select every node since you are removing only AD-SPI 
policies and nothing else).

4 Click OK.

Task 2: Rename the SPI for Active Directory policy group.

1 At the console, select Operations Manager→Policy management→Policy 
groups.

2 Select the SPI for Active Directory group and rename it (for example, SPI for 
Active Directory_old).
21
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Upgrade to the New AD-SPI

Having completed the preceding tasks, you can now install the new AD-SPI 
and customize it as desired. The instructions below provide suggestions for 
retrieving previous customizations.

Task 1: Install the SPI for Active Directory

Insert the Smart Plug-ins, New and Upgraded, Volume 1, in the CD-ROM 
drive and follow the instructions as they appear on screen to select Microsoft 
Active Directory as the SPI to install.

Figure 5 During an upgrade installation, the previous SPI version is 
detected, and the new version displayed.

Task 2: Determine whether to change AD-SPI policies:

Now that new policies are available in the SPI for Active Directory policy 
group, you can compare your previously customized policies with this new 
group (as desired). Open each policy, as explained below, to compare old/new 
policies as necessary.

1 Choose Policy management→Policy groups→SPI for Active Directory.
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2 Select <renamed policy group> created in the task: “Rename the SPI for 
Active Directory policy group.” on page 21.

3 Compare old and new policies by opening them side by side and change 
the new policy to match the previous customization (as desired):

Figure 6 Policies that have been customized show original version 
number with a decimal number; for example, 3.0. Open 
customized policies (from the renamed group) and 
compare them to the new policies (version 3.7). In the 
illustration below the thresholds for the 
ADSPI-Sysvol_PercentFull policy were changed. 

4 When finished, delete the renamed group (if desired).

Task 3: Deploy updated instrumentation.

To enable the new/updated policies to work, you must deploy the updated 
AD-SPI instrumentation. You can deploy instrumentation in one step on a 
group of nodes (if defined), or you can deploy on individual nodes.

1 At the OVO console, open Operations Manager→Nodes.

2 Right-click any node running Active Directory (if you have an Active 
Directory group, you can right-click the group).

See the list of policy changes at the beginning of this chapter to determine 
whether or not to deploy the new policies; if so, continue to the next step.
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3 Select All Tasks→Deploy instrumentation.

4 From the Instrumentation Files area, select ADSPI_Com and ADSPI_Disc.

5 Click OK.

6 Repeat this process as necessary for remaining nodes running Active 
Directory.

Task 4: Deploy AD-SPI Discovery policies.

To enable deployment of the new policies, manually deploy the Discovery 
group. Manual deployment of this group causes new services to be discovered 
and added to the OVO services tree/service map. In turn, this discovery 
results in deployment of the relevant AD-SPI policies on nodes running those 
services.

1 At the OVO console, open Policy Management→Policy Groups→SPI for Active 
Directory→Auto-Deploy.

2  Right-click Discovery and select All Tasks→Deploy on....

3 In the Deploy policies on... dialog select all nodes where Active Directory 
might be running and click OK.

Shortly, you should see additional Active Directory components listed 
within the Services→DC tree as well as additional Active Directory 
services in the OVO services map. Also implemented through the 
Auto-Discovery process is the automatic deployment of relevant AD-SPI 
policies to monitor every discovered Active Directory service.

Task 5: (optional) Deploy AD-SPI Manual-Deploy policies.

You can choose policies from the Manual-Deploy policy group to deploy on 
nodes as desired. Some of these policies are likely already deployed as a result 
of the Windows OS SPI discovery.
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Installing the Active Directory SPI

The HP OpenView Smart Plug-in for Active Directory is contained on the HP 
OpenView New and Upgraded Smart Plug-ins, Volume 1, of the CD set. 

Important! In Task 1 you install Active Directory; then you will see that 
Tasks 2 and 3 both contain methods for discovering Active Directory services. 
Complete Task 2 and/or 3 as relevant to your current configuration:

• Complete Task 2: if systems (nodes) running Active Directory are 
currently managed by OpenView Operations. 

• Complete Task 3 if systems (nodes) running Active Directory are not 
currently managed by OpenView Operations 

Task 1: Install the Active Directory SPI

1 Insert the HP OpenView New and Upgraded Smart Plug-ins, Volume 1, 
into the CD-ROM drive.

2 Follow the instructions as they appear on screen and install the AD-SPI 
by clicking the check box next to Microsoft Active Directory (SPI).

3 Follow the instructions as they appear in each dialog (you are updated on 
the status of the installation as it progresses and finally completes).

Installation of the OVO Console, Management Server, and Agents is required 
for Active Directory SPI programs to work.
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Figure 7  After InstallShield wizard automatically starts, you 
eventually reach the dialog below, where you can select the 
Microsoft Active Directory SPI. 

After you have installed the Active Directory SPI, you should see the SPI for 
Active Directory folder in the console tree under the OVO Policy Groups and 
under the Reports and Graphs folders as well.

Task 2: Discover services on nodes already managed by OVO.

To discover Active Directory services on nodes already managed by OVO, 
deploy the AD-SPI service Discovery policies. By deploying these policies, you 
launch an automated process that adds the discovered services to the OV 
services tree/service map and deploys the relevant AD-SPI policies on nodes 
running those services.

1 At the OVO console, open Policy Management→ 
Policy Groups→SPI for Active Directory→Auto Deploy→Discovery.
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2 Right-click Discovery and select All Tasks→Deploy on....

3 In the Deploy policies on... dialog select all nodes where Active Directory is 
running and click OK. 

To view the deployment, under the Policy Management folder, you can 
right-click Deployment jobs, select New Window from Here and choose 
Window→Tile Horizontally. 

In the tiled window you should see the executed processes complete as 
follows:

• Discovery of Active Directory DIT, DNS, FSMO, GC, Replication, 
Sysvol, and Trust services and consequent deployment of relevant 
policies. 

• Update of the OVO service map, showing DIT, DNS, FSMO, GC, 
Replication, and Sysvol services/components successfully discovered.

Starting at the Services→Systems Infrastructure folders of the OVO console 
tree (in the left pane), you can navigate downward to each domain controller 
(DC: <name>), under which you should now see a Services folder that could 
contain DIT, DNS, FSMOs, GC, Sysvol, and/or Replication. The Services folder 
should always include Replication and may include FSMO if the DC runs any 
flexible single master operations [FSMO] service. 

Task 3:  Discover services on nodes not yet managed by OVO.

To discover services on unmanaged nodes, you add those nodes to the OVO 
console’s Nodes folder. By adding nodes, you launch an automated service 
discovery process that duplicates the manually invoked process described 
above. 

1 At the OVO console right-click the Nodes folder and select Configure Nodes.
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2 In the Configure Managed Nodes dialog, you can add systems to the Nodes 
folder using any of three methods:

— In the left pane double-click each system you want to add,

or

— Drag and drop systems from left to right 

or

— In the left pane right-click each system and select Manage. 

Figure 8  More than one way is available to configure a node for 
management by OVO. The illustration below shows how 
you can select a node, right-click it, and select “Manage.” 

3 (as needed) If a system running OV agent software is not available in the 
Discovered Nodes folder in the left pane, in the details pane you can 
right-click the Nodes folder, select New Node, and enter the system name 
and other relevant information.

4 Click OK.

When you close the dialog, first the Windows OS SPI discovery is run; 
then the Active Directory SPI discovery occurs. The AD-SPI discovery 
involves deployment of the AD-SPI Discovery policies and then, as 
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appropriate, the DIT, DNS, FSMO, GC, Replication, Response Time, 
Sysvol, and Trust monitoring policies according to the detected services on 
each new system.

To view the deployment, under the Policy Management folder, you can 
right-click Deployment jobs, select New Window from Here and choose 
Window→Tile Horizontally. 

In the tiled window you can watch the executed processes complete as 
follows:

• Discovery of forests, domains/sites using methods specific to the 
Windows OS discovery; then discovery of Microsoft Active Directory 
DIT, DNS, FSMO, GC, Sysvol, and Replication services.

• Update of OVO service map, showing discovered DIT, DNS, FSMO, 
GC, PBHS, and replication services within domains/sites. 

• Deployment of relevant Active Directory SPI policies for monitoring 
the discovered services.

Figure 9 OVO automatically places nodes within the correct 
Windows OS folder when you close the dialog, but you can 
define your own group(s) in which to place nodes if you 
choose.    
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Task 4: View the service map with Active Directory services now added.

Now that auto-discovery has occurred, you should see the discovered services 
graphically represented under Domains and Sites within the OVO service 
map.

1 In the OVO console details pane select Services→System 
Infrastructure→Windows. 

2 Select Active Directory. 

In the console tree, when you select Services, you can view the service map in 
the right pane. There you see Domains/Sites/Domain Controller (DC:) names. 
For nodes managed by OVO, you should now see discovered services/
components under the Services box. Among the possible discovered services/
components are Replication, DNS, DIT, GC, FSMO, PBHS, and Sysvol. You 
can further expand FSMO (clicking the plus [+]) to show the specific master 
operations services on the selected DC. 
30



Contents
Figure 10 The service map can show services/components from both 
domain- and a site-centric perspectives (the site-centric 
perspective is shown below). 
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Obtaining a License/Password

The Active Directory SPI can be used for 60 days without a license. Within 
this time frame, however, you should obtain a license/password to avoid 
continued, uninterrupted use of the AD-SPI. 

To obtain a license/password for the AD-SPI, use the OpenView Operations 
Obtain License tool. When you launch the tool, you will see that you can 
choose from three methods for obtaining the required license/password 
information:

• Method #1, Retrieve/Install License Key: If you have an Internet 
connection from the OVO console, you can directly access license/password 
key information. In addition, information about the server you are using is 
automatically detected (unless you are connecting to the Internet through 
a proxy server, in which case, you will have to enter the proxy server IP 
address).

• Method #2, Install/Restore License Key: If you do not have an 
Internet connection from the OVO console, use this method, where you 
obtain the license/password information from an HP Web site 
(www.webware.hp.com). You store the information gained from the Web 
site in a file on the OVO console and import it during the procedure.

• Method #3, Request License Key though Email/Fax: Use this method 
if you would prefer to receive the license key through an email or fax.

Please see the SPI CD Installation Guide for details on each method.

The terms “license” and “password” are used interchangeably and mean 
essentially the same thing: a license key that allows permanent use of the 
AD-SPI.
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Using Method #1, Install the License Key Using an Internet 
Connection

Prerequisite: The License Entitlement Certificate, included with the 
purchased HP Smart Plug-in for Active Directory. From the Certificate you 
retrieve the unique Product Order#.

1 At the OVO console select Tools→OpenView Tools→Licensing and 
double-click Obtain License.

Figure 11 Starting the process to obtain an AD-SPI permanent 
password.

2 In the Obtain License dialog select SPI for Active Directory and click OK.

Figure 12 Selecting the SPI for Active Directory for licensing.
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3 In the HPOV Auto Pass: Internet Connection dialog select the appropriate 
Internet connection method:

Direction connection. (if the console connects directly to the Internet)
or
Proxy server. (if the console connects to the Internet through a proxy 
server). Enter host name or IP address (required), and proxy port numer 
(required); for example, 8088.

4 Click Next.

5 In the dialog that appears, enter the HP Order number (as it appears in 
the License Entitlement Certificate included with the product) and click 
Next.

6 In the System identification and product details dialog:
-In the Product profile Select column, click the product checkbox.
-In the LTUs column, enter the number of purchased licenses. 

7 Select Next.

8 In the Member ID maintenance dialog enter your email address, then 
existing or first-time password/password verification, and click Next.

9 Enter customer information as required, then click Next.

10 In the dialog that appears verify that the IP address, host name, etc., 
information is correct and select the Get password button.

11 In the Confirmation window select Finish.

An email confirmation will be sent to you for your records containing the 
Permanent Password Certificate, which contains product information and 
password/license you have been issued.

Using Method #2, Retrieve the License Key from a File

This method differs from the first in that it has a preliminary task where you 
open an HP Web site for information that you enter later in the second task.

Prerequisite: The License Entitlement Certificate, included with the 
purchased HP Smart Plug-in for Active Directory. From the Certificate you 
retrieve the unique Product Order#.
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Task 1: Obtain license/password information from the Web:

1 At a system with Internet access, launch your Internet browser, and in the 
Address text box enter www.webware.hp.com.

2 Select generate product password(s).

Figure 13 Accessing the HP Web site for licensing information.

3 In the page that appears, review the information, then scroll to the bottom 
of the page and click Next.
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4 In the password delivery service page in the Order Number text box, enter 
the order number for your AD-SPI (as it appears in the License 
Entitlement Certificate included with the product).

5 Click Next.

6 In the page that appears, select the check box next to HP OpenView Smart 
Plug-in for Microsoft Active Directory and click Next.

7 In the page that appears showing your product number, name, version, 
enter information in columns as follows:

# LTU: number of AD-SPI licenses you have purchased

Management Server Host Name: name of the management server on 
which OVO for Windows is installed.

IP Address: as above, the IP address of the OVO for Windows server 
(must be correct or your license cannot be installed successfully)

Platform: select the Windows version used on the OVO for Windows 
server.

8 Click Next.

9 In the member login page enter your email address, then your existing or 
first-time password/password verification, and click login.

10 In the address information page, enter information as required and click 
Next.
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11 In the permanent password certificates page above the certificate, click 
the text: 
Save password file for <product_number>.

You will need to remember the location of the stored certificate for the next 
task. The file is titled <product_number>.dat. In addition, the Permanent 
Password Certificate is also mailed to the email address you entered. 

Task 2: Import license/password information.

1 At the OVO console in the contents pane, select Tools→OpenView 
Tools→Licensing and double-click Obtain License
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Figure 14 Starting the process to import a permanent password.

2 In the Obtain License dialog select SPI for Active Directory and click OK.

3 In the HPOV Auto Pass: Internet Connection dialog select 
No Internet connection and click Next.

4 In the Order Validation dialog, select Import passwords and click Next.

5 In the Import passwords dialog click the Browse... button, navigate to the 
location of the file you stored in previous task, and select the file titled 
<product_number>.dat.

6 Select the Choose button.

7 (Required) Click the View file contents button.

8 Select Permanent Password for Product Number <AD-SPI_product#>.
(For example, Permanent Password for Product Number B917AA.)

9 Click Import.

Successfully imported passwords are stored in 
\Program Files\Common Files\Hewlett-Packard\PPP\LicFile.txt.
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Uninstalling the Active Directory SPI

To remove the Active Directory SPI, first uninstall all policies/policy groups 
from the managed nodes, then from the management server. 

Task 1: Remove the Active Directory SPI policies from all managed nodes

1 At the console expand the folder Policy Management.

2 Right-click SPI for Active Directory and select All tasks→Uninstall from....

3 In the Uninstall on... window, select each check box next to the node(s) from 
which policies should be removed. 

4 Click OK. 

Task 2: Remove the Active Directory SPI policy group from the management server.

1 In the console expand the folder Policy groups.

2 Right-click SPI for Active Directory and select Delete.

Task 3: Remove the Active Directory SPI tool group from the management server.

1 In the console expand the folder Tools.

2 Right-click SPI for Active Directory and select Configure→Tools....

3 In the Configure Tools dialog right-click SPI for Active Directory and select 
Delete.

Task 4: Uninstall Active Directory SPI programs from the OVO management server.

1 Insert the HP OpenView Operations/Performance for Windows CD 
(Disk 1) into the CD-ROM drive.

2 Follow the instructions as they appear on screen and start the uninstall 
procedure by selecting the Remove products radio button.

3 In the Product Selection Uninstall window select Microsoft Active Directory 
(SPI) and click Next.

To verify policies have been removed, at the OVO console expand 
the Nodes folder, right-click a node, and select View→Policy 
Inventory.
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4 In the next window select Remove.

(You are updated on the progress of the AD-SPI program removal)

5 Click Finish to complete.

Figure 15 Removing the Smart Plug-in for Microsoft Active Directory 
software from the management server.   
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Using the Active Directory SPI

After you complete your Active Directory SPI (AD-SPI) setup, the OVO 
console shows updates in areas as follows: 

— Service map now shows newly added Active Directory services 
displayed in both the console Services tree and the service map.

— Message Browser now displays information in the form of messages 
(indicating problem severity level). 

— Reports/Graphs are available, which consolidate Active 
Directory-related data as accumulated over time. The information 
contained in the reports and graphs can help you see trends so that 
you are better able to manage your Active Directory Server 
environment, implementing effective load balancing, capacity 
planning, and policy scheduling/thresholding adjustments.

— Topology Viewer is available for connecting to an Active Directory 
domain controller and viewing your Active Directory topology (see 
“The OpenView Topology Viewer” on page 55).

At the core of the Active Directory SPI are the policies that enable the above 
information to be displayed. As you review the numbers of service map alerts, 
browser messages, and reporting/graphing data, you may determine that you 
need to make some adjustments to policy settings. If a policy requires 
customizing, this chapter provides additional information for modifications. 
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More details concerning policies are also included in the online Help available 
in the OVO console. The topics below offer information on what the policies do, 
what you can do to customize them, and what to do for some specific problems. 
The topics for these issues are covered as follows: 

• “Auto-Deploy Policies” on page 44

• “Basic Policy Modifications” on page 54

Auto-Deploy Policies

Active Directory SPI Auto-Deploy policies are divided into logical groups: one 
for service discovery and the others for monitoring Active Directory services/
components DIT, DNS, GC, FSMO (flexible single master operations), 
replication, response time, and trust relationships. Please see the Active 
Directory SPI online Help for individual policy descriptions. 

Replication Monitoring

• ADSPI-Rep_ModifyObj: This policy updates an object that is used by 
the ADSPI-Rep_Mon policy so that replication latency for both inter-site 
and intra-site purposes can be tracked. 

• ADSPI-Rep_Mon: Windows 2000 Active Directory takes a multi master 
approach to common administrative tasks. Using this multi-master 
approach means that changes made to the directory on a domain 
controller are propagated to all other domain controllers. No single master 
is required. Every hour this policy modifies an Active Directory replication 
object. It works in conjunction with another policy that tracks the latency. 

• ADSPI-Rep_Modify_User_Object: Every hour this policy modifies an 
Active Directory user object. It works in conjunction with the 
ADSPI-Rep_GC_Check_and_Threshold policy to provide the means for 
tracking the replication delay time between domain controllers and the 
global catalog server and vice versa. 

• ADSPI-Rep_Check_Obj: This policy checks replication of the object 
modified by the ADSPI-Rep-Modify User_Object. 

• ADSPI-Rep_TimeSynch: Windows 2000 (Win2K) uses a time service, 
known as Windows Time Synchronization Service (Win32Time), to ensure 
that all Win2K computers on a network use a common time. Win2K's 
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default authentication protocol requires the service. Time synchronization 
is crucial because Kerberos protocol uses workstation time as part of the 
authentication process.

The time synchronization policy measures the delta between the 'time 
master' and the local host. If the delta exceeds a given threshold, an alert/
message is sent to the OVO console.

• ADSPI-Rep_InboundObjs: The number of connection objects inbound is 
an important metric to measure. A high number can indicate that a 
bridgehead may be getting overloaded and that a failure may have 
occurred. A failed bridgehead can cause a large number of DCs to retarget 
their requests; hence the high number of re-directed requests to another 
DC. 

This policy measures the DRA inbound object/sec counter and monitors 
the number of inbound replication objects.

• ADSPI-Rep_ISM_Chk: This policy checks the status of the InterSite 
Messaging service to determine whether or not the service is running and 
the number of associated processes currently running. When Intersite 
Messaging does not run properly, inter-site replication problems can occur, 
resulting in the inability of the KCC to calculate the replication topology. 

FSMO Monitoring (Flexible Single Master Operations)

Two AD-SPI scheduled task policies run checks on master operations (FSMO) 
configurations and performance. The two policies are: 
ADSPI-FSMO_Consist (configuration replication across DCs) and 
ADSPI-FSMO_Logging (FSMO service response time across DCs).

ADSPI-FSMO_Consist: When a domain controller is demoted from a 
domain, its operation master roles are transferred to another domain 
controller. If the domain controller is not properly demoted or is taken off line 
without transferring role responsibilities, operation master identification can 
become inconsistent. The ADSPI-FSMO_Consist policy is a scheduled task 
policy that checks domain controller replication. Possible states are:

— state 0 = information is present and consistent

— state 1 = information is not present on the domain controller (critical)

— state 2 = information is not present on the replication partner (critical)
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— state 3 = information is present on domain controller and replication 
partner, but is not consistent (warning)

The state is compared to the measurement threshold policy that matches 
the FSMO service, resulting in appropriate service map alerts and/or 
messages to the OV message browser. 

• ADSPI-FSMO_Logging: This scheduled task policy adds to the 
configuration check by, once again, detecting FSMO services, then pinging 
and binding to those services. This policy logs the response times for each 
service. The data collected through this policy is used in the FSMO 
reports. It is also used to generate service map alerts and messages to the 
OV console when threshold policies have been deployed on the targeted 
managed node.

Measurement threshold policies allow the above master operations states and 
response times to be interpreted and acted upon in the form of messages/
service map alerts. The master operations (FSMO) measurement threshold 
policy sets are:

• ADSPI-FSMO_Naming (Bind & Ping): The domain-naming master is 
the domain controller responsible for making changes to the forest-wide 
domain name space. This domain controller is responsible for adding/
removing a domain from the forest and adding/removing cross-references 
to domains in external directories. Each forest has only one domain 
naming master. The ADSPI-FSMO_Naming policies measure the general 
responsiveness of the domain naming master. To do this, the policies 
periodically bind to and ping the domain controller that is the domain 
naming master.

• ADSPI-FSMO_INFRA (Bind & Ping): The infrastructure master is the 
domain controller responsible for keeping track of objects referenced in 
multiple directories. The infrastructure master is responsible for 
maintaining security IDs and distinguished names for cross-domain 
references. Each domain in a forest has only one infrastructure master. 
The ADSPI-FSMO-INFRA_Bind policies measure the general 
responsiveness of the infrastructure master. They periodically bind to and 
ping the domain controller that is the infrastructure master. 

• ADSPI-FSMO_SCHEMA (Bind & Ping): The schema master is the 
domain controller responsible for performing updates to the directory 
schema. The updated schema is replicated to the other domain controllers 
in the forest. There is one schema master per forest.
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• ADSPI-FSMO_PDC (Bind & Ping): The PDC emulator is a Windows 
2000 domain controller that acts as the primary domain controller to 
down-level workstations, member servers and domain controllers. In a 
Windows NT domain, there is one PDC master per domain in a forest, 
which performs the following functions:

— Password changes, performed by other domain controllers in the 
domain are replicated preferentially to the PDC master. 

— Authentication failures occurring at a given domain controller in a 
domain because of an incorrect password, forwarded to the PDC 
master before a bad password failure message is reported to the user. 

— Account lockout, processed on the PDC master.

• ADSPI-FSMO_RID (Bind & Ping): The RID master is the domain 
controller responsible for processing RID pool requests from all domain 
controllers within a given domain. When a domain controller creates a 
security principal object such as a user, it attaches a unique Security ID 
(SID) to the object. The SID consists of a domain SID and a relative ID 
(RID).

Each Windows 2000 domain controller is allocated a pool of RIDs. When a 
domain controller's pool falls below a threshold, that domain controller 
issues a request to the domain's RID master for a new pool. There is one 
RID master per domain in a forest.

The ADSPI-FSMO_RID policies measure the general responsiveness of 
the RID master. They periodically bind to and ping the domain controller 
that is the PDC master.

• (a) ADSPI-FSMO_Consist_INFRA, (b) ADSPI-FSMO_Consist_RID, 
(c) ADSPI-FSMO_Consist_PDC, (d) 
ADSPI-FSMO_Consist_SCHEMA, and 
(e) ADSPI-FSMO_Consist_NAMING. These policies alarm when the 
ADSPI-FSMO_Consist policy determines that the domain controller 
running the policy and one or more of its replication partners do not agree 
on which domain controller holds the specified FSMO role.

• (a) ADSPI-FSMO_RoleMvmt, scheduled task policy, all other FSMO role 
movement policies are measurement threshold policies: 
(b) ADSPI-FSMO_RoleMvmt_INFRA, 
(c) ADSPI-FSMO_RoleMvmt_NAMING, 
(d) ADSPI-FSMO_ RoleMvmt_PDC, 
(e) ADSPI-FSMO_RoleMvmt_RID, and 
(f) ADSPI-FSMO_RoleMvmt_SCHEMA. 
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These policies generate messages to the console when a FSMO role is 
moved from one domain controller to another, a major change in the 
environment. An alarm is sent if a domain controller gains or loses a 
FSMO role.

Directory Information Tree Monitoring

Policies monitoring the Active Directory database, the directory information 
tree (DIT), ensure that DIT operations (as related to queue lengths), size, and 
occupied space on the disk of the hosting server fall within specific limits. 
Specifically, DIT policies monitor the following:

• ADSPI-DIT_DITPercentFull: Monitors the percentage of space used 
and the free space remaining on the logical drive hosting the DIT.

• ADSPI-DIT_TotalDITSize: Monitors the size of the Active Directory 
database and the remaining space on the logical hosting drive.

• ADSPI-DIT_DIT QueueLength: Monitors the queue length on the DIT 
logical drive, indicating the number of incomplete operations pending.

• ADSPI-DIT_LogFilesQueueLength: Monitors the log queue length, 
indicating the number of incomplete updates pending.

• ADSPI-DIT_LogFilesPercentFull: Calculates the percentage full of the 
logical drive hosting the DIT log files; the policy thresholds and logs the 
information. 

Domain Name Server Monitoring

For DNS monitoring, the Active Directory SPI checks DNS responsiveness 
and consistency with the data contained in Active Directory. To this end, 
AD-SPI-DNS policies show you whether or not: (1) DNS is returning the 
correct IP address for each domain controller, (2) DNS contains all SRV 
records that ADS dictates it should, and (3) each SRV record is accurate. The 
DNS group contains the following policies:

• ADSPI-DNS_DC_A_Chk: Checks the two DNS host records (A records) 
associated with a Domain Controller. There are two host records 
associated with each Domain Controller-one for its fully qualified domain 
name and one for the domain that it serves. A critical message is 
generated if one or both records are missing.
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• ADSPI-DNS_DC_CNAME_Chk: Generates a critical message when a 
Domain Controller cannot be found using the alias:
<domain_controller_GUID>._msdcs.<domain>

• ADSPI-DNS_DC_Response: Alerts the user when DNS queries made by 
the domain controller result in an unexpected or unacceptable response 
time; the policy thresholds on specified length of time and logs information 
for reporting.

• ADSPI-DNS_LDAP_SRV_Chk: Checks for extra DNS SRV resource 
records registered for the LDAP service. Generates a warning message if the 
domain controller is registered as an LDAP server on a site that it does not reside in. 
A warning message is generated because this can be a desirable situation under 
certain circumstances.

• ADSPI-DNS_Extra_GC_SRV_Chk: Checks for expected and unexpected 
DNS host records registered for the global catalog. A GC record is 
unexpected if the domain controller does not host the global catalog. Only 
a warning severity level is attached to the message because the situation 
may be intentional under certain circumstances.

• ADSPI-DNS_Extra_Kerberos_SRV_Chk: Generates a warning 
message if the domain controller is registered as a Kerberos KDC on a site 
in which it does not reside. Only a warning severity level is attached to the 
message because the situation may be intentional under certain 
circumstances.

• ADSPI-DNS_Extra_LDAP_SRV_Chk: Checks for extra DNS SRV 
resource records registered for the LDAP service. If an LDAP server is 
registered on a site in which it does not reside, a warning message is 
generated. The extra LDAP server incurs only a warning because the 
situation may be intentional under certain circumstances.

• ADSPI-DNS_GC_A_Chk: Checks for extra DNS host records registered 
for the registered for the global catalog. Checks for expected and 
unexpected DNS host records registered for the global catalog. A global 
catalog record is unexpected if the domain controller does not host the 
global catalog.

• ADSPI-DNS_GC_SRV_Chk: Checks for expected DNS SRV resource 
records registered for the global catalog.

• ADSPI-DNS_GC_StrandedSite: Checks for the existence of a global 
catalog on every site in the forest in which the domain controller resides.
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• ADSPI-DNS_Island_Server: Generates a warning message if a domain 
controller is configured to use itself as a primary DNS server because 
replication problems can occur in such situations.

• ADSPI-DNS_Kerberos_SRV_Chk: Checks for missing resource records 
for Kerberos and generates a critical message when a domain controller is 
not properly registered in DNS as a Kerberos KDC server or Kerberos 
Password Change server. That is, it alerts the user when one or more SRV 
records that identify it as a Kerberos KDC server or Kerberos Password 
Change server are missing. 

• ADSPI-DNS_Obsolete_GUIDS: Checks for hosts within the forest that 
the domain controller resides in that are registered under obsolete GUIDs.

Global Catalog Monitoring

The primary purpose of global catalog monitoring is to ensure that systems 
hosting global catalog (GC) servers are replicating in a timely manner. GC 
replication delay time is measured through two policies: the first is included in 
the Replication Monitoring group. This policy creates a user object and 
modifies it. The ADSPI-Rep_GC_Check_and_Threshold policy (contained in 
the GC Monitoring group) measures the delay time occurring in replicating 
this modified user object to other domain controllers and vice versa (from DC 
to GC, and from GC to other DCs). How this data is represented in the OVO 
message browser and reports should show you how timely/slowly replicating 
is occurring throughout your Active Directory environment. Policies are 
automatically deployed through Auto-Deployment (following discovery) as 
follows:

• The ADSPI-Rep_GC_Check_and_Threshold is used to measure the 
replication time from domain controllers throughout the Active Directory 
forest to a domain controller hosting global catalog services. This policy is 
deployed only on systems hosting global catalog services. 

Sysvol Monitoring

Sysvol monitoring covers areas that are key to the health of Active Directory 
such as the Sysvol size, connectivity, and synchronization. Problems with 
Sysvol can initiate a cascading effect.
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• ADSPI-Sysvol_Connectivity: The ability to connect to the Sysvol 
volume is a key indicator of the health of Active Directory. If Sysvol is 
unavailable, the Netlogon service cannot start. Group policies cannot 
replicate. It is not uncommon for a person to mistakenly un-share the 
Sysvol volume out of ignorance. When this happens, a cascading effect 
occurs. 

The ADSPI-Sysvol_Connectivity identifies the DC's replication partner 
and checks to see that the Sysvol is available to ensure its group 
replication and other services. 

• ADSPI-Sysvol_PercentFull: Calculates the percent full of the Sysvol 
and collects information about its size and logs the information for later 
reporting.

• ADSPI-Sysvol_FRS: Monitors the file replication service in the Sysvol 
from one domain controller to another. 

• ADSPI-Sysvol_AD_Sync: Checks that the Group Policy objects in Sysvol 
and Active Directory synchronized with each other. 

Response Time Monitoring

Response time monitoring policies ensure that Active Directory operations are 
completing in acceptable time frames. Response time monitoring checks the 
general health of Active Directory operations, the time required for binding to 
the global catalog, and the time required for global catalog searches and 
queries. The policies in this group are:

ADSPI-ResponseTime_Logging: This scheduled task policy logs Active 
Directory response times. 

ADSPI-ResponseTime_Query: This policy measures the time required for 
the Active Directory queries. It periodically queries Active Directory and 
monitors latency. 

ADSPI-ResponseTime_GC_Bind: This policy measures the time required 
to bind to the global catalog. The data gathered is used for a graph, which aids 
in base-lining what the value should be for your environment.

ADSPI-ResponseTime_Bind: This policy periodically binds to Active 
Directory to measure the domain controller's bind response time, which is 
graphed in order to aid in base-lining what the value should be for your 
environment.
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ADSPI-ResponseTime_GCQuery: Monitors response times of Active 
Directory global catalog queries.

Trust Monitoring

These policies monitor the trust relationships between domain controllers of 
managed nodes that are Windows 2003 systems. The policies log modifications 
as they occur. You can also review this information on demand by using the 
AD Trust Relationships tool. The tool is located within the console in 
Tools→SPI for Active Directory→AD Trust Relationships. The policies are as 
follows:

ADSPI-Trust_CreateDataSources: Sets up the data sources necessary for 
the ADSPI-Trust_Mon policy to check trust relationships.

ADSPI-Trust_Mon: Monitors the trust changes in Active Directory (on 
Windows 2003 domain controllers only). The policy checks for creation, 
deletion and modification of Active Directory Trust information. 

Accessing Trust Relationship Information

In addition to the policies that supply messages relating to additions, 
deletions, and changes in trust relationships, you can generate trust 
relationship information for each domain controller by using the AD Trust 
Relationships tool. 

In a Windows 2000 Server environment for selected managed nodes, this 
tool displays a list showing the two-way trusts within a forest. In the 
Windows 2003 Server environment it not only reports two-way trusts within 
a forest but can also show trusts from one forest to another for the selected 
managed nodes. Please see the online Help for using the AD Trust 
Relationships tool.

Active Directory SPI and Demoting Domain Controllers

Use the AD DC Demotion Preparation tool before you demote any domain 
controller. This tool removes the OVReplication objects inserted into the 
directory to monitor replication. 
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This tool should be used only after you have installed and configured the 
Active Directory SPI and begun to use it to monitor DCs in your Active 
Directory environment.   Please see the Active Directory online Help for how 
to use this tool.

Figure 16  The AD Trust Relationships tool lists information about 
the trust relationships for the selected managed node.

If you do not use the AD DC Demotion Preparation tool before demoting a 
domain controller, you can manually reconfigure Active Directory to no longer 
recognize the demoted domain controller by following the steps in the online 
Help topic “AD DC Demotion Preparation tool.” 
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Manual-Deploy Policies

Active Directory SPI Manual-Deploy policies are not automatically deployed, 
like the Auto-Deploy policies, after the Active Directory service occurs. Some, 
however, may already be running on nodes as a result of the service discovery 
occurring with the Windows OS SPI installation. 

Manual-Deploy policies offer basic monitoring that cover areas of Active 
Directory involving connectivity, domain and organization unit structure, 
health, index and query, replication/replication activities, security, and site 
structure. For detailed descriptions, please see the online Help topic “Choosing 
an Active Directory SPI policy.”   

Basic Policy Modifications

After using the Active Directory SPI for awhile, you may decide that specific 
policies need some modification. Measurement threshold policies contain the 
rules for interpreting Active Directory states/conditions according to the 
thresholds set for the incoming data. Scheduled task policies also contain the 
rules for how often the data is monitored. How to change either policy type is 
described below. Specific policy descriptions are provided in the OVO online 
Help.    

Below find suggestions for basic customizations that you might implement for 
every managed node. 

When you modify a policy, OVO assigns a version number to the modified 
policy; this means that an extension such as “.1” is added to the policy version. 
You can then deploy the new policy to managed nodes.
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Modify a Monitoring Schedule or Measurement Threshold

You can modify the monitoring schedule or measurement threshold polices for 
any AD-SPI policy. After you update the policy for the nodes to which you 
want the latest change applied, you can right-click the policy group, select All 
Tasks→Update to latest, and then re-deploy the policy or policies to the 
node(s):

1 Expand the Policies grouped by type folder and select the Scheduled Task 
type (or Measurement Threshold).

2 In the details pane of the console double-click the specific (ADSPI-<policy 
name>) scheduled task policy. 

3 Select the Schedule tab and modify the Schedule Task as desired (or in 
some measurement threshold type policies, the Global Polling Interval” or 
“Polling Interval” in the Source tabbed page). 

The OpenView Topology Viewer

The OpenView Topology Viewer supplements the information you receive from 
other Active Directory SPI components and has no dependency on any Active 
Directory SPI policies. Using this tool (located in the OVO console under 
Tools→SPI for Active Directory), you are able to quickly see the forests and 
various site links and connection objects within your Active Directory 
environment.

The display: The information gathered by the Topology Viewer is presented 
in both a tree in the Viewer’s left pane that a map in the right pane. The tree 
shows forest(s) and domains, including parent/child/grandchild domains, 
while the map shows the site/replication topology.

How the display gets generated: The Site Topology view requires only that 
you connect to any domain controller in an Active Directory forest and the tool 
is able to access the DC’s information, which includes information on other 
DCs and their links as replicated across the Active Directory environment. 
With this information, the tool displays current sites, partitions, and unique 
ID elements making up those Active Directory components in the left pane of 
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the Topology Viewer window. In the right pane the tool generates a topological 
map that shows specific forests, sites, and DC replication links among the 
Active Directory forest.

Figure 17 To highlight specific site links or connections, you can 
right-click one in the tree (left pane) and click Find in 
View, and the relevant object is highlighted as shown 
below. 

The site/server information shown in the AD Topology Viewer is a snapshot of 
the data retrieved at the time of the connection to the specified server. It is not 
automatically updated, but can be refreshed (select File→Refresh Data or 
right-click a selected forest and select Refresh Data). 
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The topology contains discovered components as follows:

• Forest(s)

• Partitions (ID component groupings)

• Sites (physical sites)

• Site Links (user-defined links between physical sites)

To launch the Topology Viewer tool:

1 At the OVO console select Operations Manager→Tools→SPI for Active 
Directory.

2 Double-click OV Topology Viewer.

3 In the window that appears, from the File menu select Add Forest....
(You can also right-click on the root node of the tree.)

By default, the Topology Viewer privileges are the same as the logged-on user 
at the OV console. If this user has permissions to access the forest that is 
being added, alternate credentials are unnecessary. If the logged-on user does 
not have permission to access the desired forest, the alternate credentials can 
be used to specify an account which does have access to the forest.
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4 In the Add Forest dialog, enter the requested information and click OK.

Figure 18 As the Topology Viewer makes the connection to the 
specified domain controller, you are updated on data 
retrieval progress.   

When you have both 
the Active Directory 

and Exchange SPIs, you 
can select this check box 
to allow additional 
Exchange data to appear 
in the Site Topology view 
of the map. However, 
gathering this data 
significantly impacts the 
efficiency of the map 
generation. You may need 
to wait several minutes, 
possibly up to an hour, 
depending on the size of 
your environment, for the 
map to be completely 
drawn.
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Getting Started with the OV Topology Viewer

Each time you launch the Topology Viewer and make the connection to a 
domain, you are presented with two window panes that represent the 
information gathered from a server. Even though some of the information is 
the same, the dual-paned window shows you two different representations of 
it.

The tree and the map: On the left, you see folders containing forest, 
partition, site, and site link information. On the right, you see the topological 
map that places the forest, with its sites and site links in a context. While the 
left window lists components, the right pane shows the relationships among 
those components.

The initial map view: The map shows only site links (represented by green 
lines), which are user-defined. These links are the foundation on which the 
Active Directory is able to build connections between servers. 

The Site Topology view shows servers identified by their Active Directory 
functionality. If you are running the Exchange SPI, you will see Exchange 
functionality as well. The symbols shown next to each server are explained in 
a legend that you can display by selecting View→Legend (as shown in the 
illustration that follows). 

The Exchange Topology view shows Exchange routing groups and is available 
only if you run the Exchange SPI. This view is entirely devoted to Exchange 
functionality, while the Site Topology view, though primarily focused on Active 
Directory functionality, does include some Exchange functionality. Please refer 
to the Exchange SPI Configuration Guide, online Help, and Release Notes for 
details about the Topology Viewer when used in conjunction with the 
Exchange SPI.

Site link cost: In the tree site links, in addition to showing the connections 
between sites, show the associated “cost” of each connection. Site links with a 
lower cost are able to replicate data between those sites more easily than 
those site links showing a higher cost. 

Right-click any server in the OV Topology Viewer map, and you are shown its 
DC: <name> or Exchange Server: <name>.
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Figure 19 The Topology Viewer Legend explains the symbols used to 
represent server roles. Server roles are also shown in the 
server properties page (right-click server and select 
Properties....

Figure 20 In the OV Topology Viewer map, a domain controller (top) 
and a server (bottom) have slightly different appearances; 
Active Directory functions appear on the left; Exchange, on 
the right. A domain controller with dual functionality 
(Exchange and Active Directory), displays functions on 
both left and right sides. 

Both Active Directory and 
Exchange server functions 
are explained in the OV 
Topology Viewer legend. 
Active Directory functions 
comprise only the first 
four. If you are using the 
Active Directory SPI only, 
only the first four 
functions appear. 
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Figure 21 To change the map background or grid appearance, select 
View→Properties, and the General tabbed page.

Figure 22 To show/hide the server connections/links or labels, select 
View→Properties, and the Visibility tabbed page.
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Figure 23 To change the server connections and links appearance, 
select View→Properties, and the Colors and Lines tabbed 
page.

Manipulating the Map View

You may find when you view the OV Topology Viewer replication map that 
sites or servers do not appear within the viewable area. You can access 
Topology Viewer features through its menu commands, its toolbar buttons, or 
by mouse right-clicks within areas of either side of the window pane. For 
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complete menu and toolbar descriptions, please refer to the SPI for Active 
Directory online Help. You may also want to resize the viewable area. These 
and other changes are possible as follows: 

Table 2 Modifying the OV Topology Viewer  

Tree/map modification How to do it

To move sites to different 
locations on the map.

Drag and drop the site to desired the desired 
position on the grid.

To move servers. Drag and drop to desired tiles within the site.

To display server or site 
labels.

From the View menu select Properties....

To increase/decrease the 
size of the row/columns in 
the map’s grid.

Right-click the unused space on or off the map and 
select Properties.... and choose the General tabbed 
page.

To find a site, site link, 
server, or server connection 
in the tree.

On the map, right-click the site or server on the 
map and select Find in Tree.

To find a server in the map. In the tree, right-click on the site or server and 
select Find in View.
(Label appears in highlighted text.)
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Using the keyboard to move around the map.

Accessing Server and Map Properties

After you have successfully connected to a forest, resulting in a populated tree 
and topological map, you can access the following information:

Server Properties: By right-clicking a domain controller/server in either the 
tree or the map, you can open that server’s properties sheet, where you can 
view:

— Domain Controller information: Shows the fully qualified domain 
name, distinguished name, GUID assigned to the server, and server 
Active Directory roles.

— System Information: Operating system and its version, date created, 
the operating system and OS version, and (if applicable) service pack 
and hot fix (as appropriate).

— Connections: Inbound connections and outbound notification

Table 3 Keyboard Functionality

Keystroke Map function

← left arrow Scrolls the map view to the left approximately one tile 
width.

→ right arrow Scrolls the map view to the right approximately one tile 
width.

↑ up arrow Scrolls the map view up approximately one tile height.

↓ down arrow Scrolls the map view down approximately one tile 
height.

Page Up Scrolls the map view up approximately 3 tiles.

Page Down Scrolls the map view down approximately 3 tiles

Home Scrolls the map view to the left extent. (Vertical 
position remains the same).

End Scrolls the map view to the right extent. (Vertical 
position remains the same).
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— Partitions: Shows all naming contexts associated with the server as 
displayed in the OV Topology Viewer tree, grouping them either 
within the master read-write components, or the replicating read-only 
context.

— Replication: Shows information about completed and pending 
replication operations. 

— DNS: Shows the fully qualified DNS host name and Name Servers, 
depending on the WMI access rights.

Site Topology Properties: Right-click outside the grid area, choose View 
Properties.... or from the View menu, select Properties. You can use the 
properties sheet to modify the display as desired (see Figure 22, Figure 23):

— General tab: Color choices for the background (behind the grid) and 
the grid; grid tile size.

— Visibility tab: Toggles on/off the display of connections/links (between 
servers in a site), Intra-site connections (server connections between 
sites), Site links, server and site labels, and server roles.

— Color and Lines tab: Color choices for connection and site link lines, 
and site background.

– Object visibility on/off settings: Allows you to turn on/off the display of 
links, labels, and domain controller/server roles.

Use the Defaults button to return to the default settings.

The availability of some information in the server (DC) property 
sheet is dependent on the WMI access rights of the user.
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Reporting and Graphing

Active Directory SPI report- and graph-generating templates are installed 
when you install the AD-SPI. These reports cover availability/activity in DIT, 
DNS, GC, replication, FSMO operations, Sysvol, and trust relationship 
changes for each domain controller running those services. 
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Automatically generated every night, these Web-ready reports provide you 
with a routine means of checking the GC and DNS availability, disk space and 
queue length issues occurring with DIT, replication latency, and connection 
times specific to domain controllers running master operations services. Also 
available for 2003 systems are reports covering trust relationship changes 
between domain controllers. 

By showing consolidated information, available otherwise only in pieces, OVO 
reporting provides you with a more complete view of how Active Directory 
services are performing over time. 

AD-SPI Reports and Data Sources

After you install the Active Directory SPI, OVO can generate reports using the 
Active Directory SPI-collected data. These reports are generated after OVO 
runs through its first nightly schedule. From that point on, you can expect to 
see updated reports every day since OVO, by default, re-generates reports 
every night with the day’s data. 

AD-SPI report data is collected according to metrics used for each report. This 
data is stored in the MS SQL “Reporter” database. The example metric 
formatting below (for the AD Domain Controller Availability report) shows 
how metric variables are identified for reporting purposes:

<report_table_name>.<AD-SPI_metic_name> 
as in:

ADSPI_RESPONSEMON. SYSTEMNAME

If you use OpenView Reporter and it is installed on a separate system, you 
need to complete that installation on the Reporter system.

Customizing reports requires that you purchase HP OpenView Reporter. 
The Reporter documentation set details how to modify reports and includes a 
Concepts Guide, an Installation and Special Configurations Guide, online 
Help, and Release Notes.

report table name AD-SPI metric
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AD-SPI reports are accessible from the Reports & Graphs area of the OVO 
console. Complete descriptions of all reports and graphs are available in the 
OVO online Help. 

The following table shows reports, report template names, and the AD-SPI 
policies required to generate them.

Table 4 Active Directory Reports, report template names, and their required policies.

Report Name Report Template File Name Required Policy

AD Domain Controller 
Availability

g_ADDCAvailability.rpt ADSPI-Response_Logging

AD GC Rep Delay Times 
by DC/GC Report - 
Monthly

g_ADDCGCmonthly.rpt ADSPI-Rep_GC_Check_
and_Threshold

AD GC Rep Delay Times 
by DC/GC Report - 
Weekly

g_ADDCGCweekly.rpt ADSPI-Rep_GC_Check_
and_Threshold

AD DIT Disk Size 
Summary - Monthly

g_ADDITDiskSpaceMonthly.rpt ADSPI-DIT_DITPercentFull
ADSPI-DIT_TotalDitSize

AD DIT Disk Size 
Summary -Weekly

g_ADDiskSpaceWeekly.rpt ADSPI-DIT_DITPercentFull
ADSPI-DIT_TotalDitSize

AD DIT Disk Queue 
Length - Weekly 

g_ADDITQueueLengthWeekly.rpt ADSPI-DIT_DITQueueLength

AD DC DNS Availability 
Report -Daily

g_ADDNSDCAvailDaily.rpt ADSPI-DNS_DC_RESPONSE

AD DC DNS Availability 
Report- Weekly

g_ADDNSDCAvailWeekly.rpt ADSPI-DNS_DC_RESPONSE

AD DNS Server 
Availability Report -Daily

g_ADDNSrvAvailDaily.rpt ADSPI-DNS_DC_RESPONSE

AD DNS Server 
Availability Report 
-Weekly

g_ADDNSSrvAvailWeekly.rpt WINOSSPI-DNS_ServerResponse
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AD DNS Server Memory 
Capacity Planning 
Report - Monthly

g_ADDNSSrvMemCapPlanMonthl
y.rpt

WINOSSPI-DNS_ServerResponse

AD DNS Server Memory 
Capacity Planning 
Report - Weekly

g_ADDNSSrvMemCapPlanWeekly.
rpt

WINOSSPI-DNS_LogDNSPagesSec

AD Domain and Forest 
Trust Changes - Monthly

g_ADDomainForestTrustMonthly.r
pt

ADSPI-Trust_Mon

AD Domain and Forest 
Trust Changes - Weekly

g_ADDomainForestTrustWeekly.rp
t

ADSPI-Trust_Mon

AD GC Rep Delay Times 
by GC/DC Report - 
Monthly

g_ADGCDCmonthly.rpt ADSPI-Rep_GC_Check_and_Thresh
old

AD GC Rep Delay Times 
by GC/DC Report - 
Weekly

g_ADGCDCweekly.rpt ADSPI-Rep_GC_Check_and_Thresh
old

AD GC Response Time - 
Monthly

g_ADGCResponseTimeMonthly.rpt ADSPI-Reponse_Logging

AD GC Response Time - 
Weekly 

g_ADGCResponseTimeWeekly.rpt ADSPI-Reponse_Logging

AD Log Files Disk Size 
Summary - Monthly

g_ADLogFilesDiskSpaceMonthly.r
pt

ADSPI-DIT_LogFilesPercentFull

AD Log Files Disk Size 
Summary - Weekly

g_ADLogFilesDiskSpaceWeekly.rpt ADSPI-DIT_LogFilesPercentFull

AD Log Files Disk Queue 
Length - Weekly

g_ADLogQueueLengthWeekly.rpt ADSPI-DIT_LogFilesQueueLength

AD Operations Masters 
Connection Time by 
FSMO 

g_ADOpMstrConTimeByFsmo.rpt ADSPI-FSMO_Logging

AD Operations Masters 
Connection Time by 
Server

g_ADOpMstrConTimeBySvr.rpt ADSPI-FSMO_Logging

Table 4 Active Directory Reports, report template names, and their required policies.

Report Name Report Template File Name Required Policy
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The following table shows the data sources for all AD-SPI reports.

Table 5 Active Directory Reports with Required Metrics

AD Size of Sysvol Report 
- Monthly 

g_ADSizeOfSysvolMonthly.rpt ADSPI-REP_SysVolPercentFull

AD Size of Sysvol Report 
- Weekly

g_ADSizeOfSysvolWeekly.rpt ADSPI-REP_SysVolPercentFull

Table 4 Active Directory Reports, report template names, and their required policies.

Report Name Report Template File Name Required Policy

AD-SPI Reports and Source Policies Data Source Tables & Metrics

Report title: AD DIT Disk Queue Length Report (weekly)
Policy: ADSPI-DIT_DITQueueLength

Tables: 
ADSPI_Domain
ADSPI_Site
ADSPI_LogQueueLength
Metrics:
SYSTEMNAME
INSTANCEVALUE
DATETIME

Report title: AD DIT Disk Size Summary Report (weekly 
& monthly)
Policies: 
(1) ADSPI-DIT_DITPercentFull and 
(2) ADSPI-DIT_TotalDitSize

Tables: 
ADSPI_DITDatabaseSize
ADSPI_DITPercentFull
ADSPII_Domain
ADSPI_Site.
Metrics:
DATETIME
INSTANCEVALUE
SYSTEMNAME

Report title: AD DC DNS Availability Report (daily and 
weekly)
Policy: ADSPI-DNS_DC_RESPONSE

Table: 
ADSPI_DNS_DCRESP
Metrics: 
DATETIME
RESPONSETIME
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Report title: AD DNS Server Availability Report
(daily and weekly)
Policy: WINOSSPI-DNS_ServerResponse

Table: 
WINOSSPI_DNS_SVRRESP
 Metrics:
DATETIME
RESPONSETIME
ISDOMAINCONTROLLER

Report title: AD DNS Server Memory Capacity Planning 
Report (weekly and monthly)
Policy: WINOSSPI-DNS_LogDNSPagesSec

Table: 
WINOSSPI_DNS_SVRPLAN
 Metrics: 
DATETIME
PAGESSEC(Avg)
PAGESSEC (Max) 
PAGESSEC (Min) 

Report title: AD Domain Controller Availability
Policy: ADSPI-Response_Logging

Table: 
ADSPI_RESPONSEMON
Metrics: 
SYSTEMNAME 
DATETIME 

Report title: AD GC Rep Delay Times (DC to GC(s) and GC to 
DC(s) (weekly and monthly)
Policies: 
 (1) ADSPI-Rep_Modify_User_Object (must be deployed to all 
domain controllers);
 (2) ADSPI-Rep_GC_Check_and_Threshold (must be deployed 
to all global catalog servers).

Table: 
ADSPI_REP_GC
Metrics: 
SYSTEMNAME 
DATETIME
LATENCYDELTA

Report title: AD GC Response Time (weekly and monthly)
Policy: ADSPI-Reponse_Logging

Tables: 
ADSPI_RESPONSEMON
ADSPI_REP_GC
Metrics: 
SYSTEMNAME
DATETIME (Date)
GCPRESENT
GCBINDTIME
QUERYTIME

AD-SPI Reports and Source Policies Data Source Tables & Metrics
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Report title: AD Log Files Disk Queue Length (weekly)
Policy: DSPI-DIT_LogFilesQueueLength

Tables: 
ADSPI_Domain
ADSPI_Site
ADSPI_LogQueueLength
Metrics: 
SYSTEMNAME
INSTANCEVALUE 
DATETIME

Report title: AD Log Files Disk Size Summary
(weekly and monthly)
Policy: ADSPI-DIT_LogFilesPercentFull

Tables:
ADSPI_LogDiskSize
ADSPI_Domain
ADSPI_Site
ADSPI_LogPercentFull
Metrics: 
DATETIME
INSTANCEVALUE
INSTANCENAME

Report title: AD Operations Master Connection Time (by 
FSMO and by Server)
Policies: 
ADSPI-FSMO_NAMING_Bind (& Ping), 
ADSPI-FSMO_PDC_Bind (& Ping), 
ADSPI-FSMO_SCHEMA_Bind (& Ping), 
ADSPI-FSMO_INFRA_Bind (& Ping), 
ADSPI-FSMO_RID_Bind (& Ping).

NOTE: FSMO reports graphically represent 
connections in both ping and bind measurements. 
The ping time measures the network connection 
time. Bind time measures the time between the 
ping connection and the connection to the targeted 
Active Directory service. 

Table: 
ADSPI_FSMO_MET
Metrics:
FSMO 
GMT
PINGTIME
BINDTIME

AD-SPI Reports and Source Policies Data Source Tables & Metrics
73



AD-SPI Reports and Data Sources
Report title: AD Size of Sysvol Report (weekly and 
monthly)
Policy: ADSPI-Sysvol_PercentFull

Table: 
ADSPI_SYSVOL_PCT_FULL 
Metrics: 
SYSTEMNAME 
DATETIME
INSTANCENAME (SysVolFilePath) 
INSTANCEVALUE   (SysvolDriveFreeSpace)

Report title: AD Domain and Forest Changes (weekly and 
monthly)
Policy: ADSPI-Trust_Mon

Table: 
ADSPI_TRUST 
Metrics: 
DATETIME 
CHANGETYPE
TRUSTEDDOMAIN
TRUSTATTRIBUTES
TRUSTDIRECTION
TRUSTSTATUSSTRING
TRUSTTYPE
TRUSTINGDOMAIN

Report title: AD FSMO Role Holder Movement (weekly 
and monthly)
Policy: ADSPI-FSMO_Role_Mvmt

Table
ADSPI_FSMO_ROLEMVMT
Metrics
SYSTEMNAME
DATETIME
FSMO
ISROLEHOLDER

AD-SPI Reports and Source Policies Data Source Tables & Metrics
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Figure 24 The FSMO Role Holder Report lists DCs and their loss or 
gain of FSMO roles. The report is available for weekly and 
monthly updates. 
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Using AD-SPI with OpenView Reporter

If you use OpenView Reporter, you can install the Active Directory SPI reports 
on the Reporter system so that you can customize them and apply them, as 
desired, to groups of systems and single systems. 

Install Report Package 

If Reporter and OVO for Windows are installed on the same system, no 
separate installation for the AD-SPI is necessary (as described in the tasks 
below). 

However, stand-alone Reporter installations require that you run the 
ADSPI-Reporter.msi set up. This setup installs the AD-SPI report package 
within Reporter.

To install the Active Directory SPI Report Package on a Reporter standalone 
system:

1 From the Smart Plug-ins, New and Upgraded, for OVO Windows CD set, locate 
Volume 1 and insert it in the CD-ROM drive of the Reporter system.

2 On CD Volume 1 open \SPIs\AD SPI\ and double-click the file: 
ADSPI-Reporter.msi. 

3 In the dialog that appears, for the setup type select Complete and click Next.

4 Open the Reporter main window and check the status pane to note changes to the 
Reporter configuration, which include uploading AD-SPI reports.

AD-SPI Reports are automatically assigned to the ALL group in the Reporter main 
window. (See the preceding section “AD-SPI Reports and Data Sources” on 
page 68 for OVO Report list.) 

5 Add group and single system reports by assigning reports as desired. 

Reports are available for viewing the following day.

Instructions are available in the Reporter Help for assigning AD-SPI reports 
to the targeted nodes. To access Help, select Reports or Discovered 
Systems in the left panel of the Reporter main window and right-click it. 

Group and single system AD-SPI reports require that you identify systems by 
their full name; for example, abc.xyz.com is acceptable while abc is not.
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Select Report Help or Discovered Systems Help from the submenu that 
appears. See the topic “To assign a report definition to a Discovered Systems 
Group.” Reporter also includes two online documents: the Concepts Guide and 
the Installation/Special Configurations Guide for further information.

AD-SPI Graphs and Data Sources

The Active Directory SPI also includes graphs available in the OVO console in 
Reports & Graphs→Graphs→SPI for Active Directory. OVO graphs differ from 
reports in that you manually generate them and then view data that is more 
immediate and granular in nature. 

AD-SPI graphs, which consolidate collected data, are listed in the following 
table. 

Table 6 Active Directory Graphs and Source Policies 

Graphs showing response times are meant to aid you in establishing baseline 
values for setting thresholds in other policies.

AD-SPI Graphs and Policies Source Metrics 

Graph Title: Active Directory Replication 
Latency Graph
Source Policies: 
ADSPI-Rep_ModifyObj and ADSPI-Rep_Mon

Metrics: 
LatencyMin
LatencyMax
LatencyAvg 

NOTE: The Replication Latency Graph can 
be generated only when one or more domain 
controllers exist in a forest; a forest with a 
single domain controller has no replication 
occurring, and so no data for graphing is 
available.

Graph Title: Active Directory Bind Response 
Time
Source Policy: ADSPI-Response_Logging

Metrics: 
GCBindTime
BindTime
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AD-SPI Graphs and Data Sources
To access the Active Directory SPI graphs:

1 Select Reports & Graphs→Graphs→SPI for Active Directory. 

2 Right-click the graph name, such as Active Directory Replication Latency Graph, 
and select Show Graph.... 

3 Select the Node and Date Range and click Finish. 

Graph Title: Active Directory GC Availability 
Source Policy: ADSPI-Response_Logging 

Metrics: 
GCAVAILABILITY
GCQueryTime

Graph Title: Active Directory Query Response 
Time Graph
Source Policy: ADSPI-Response_Logging

Metric: 
GCQueryTime

Graph Title: Active Directory Replication Time 
by Global Catalog
Source Policy: ADSPI-Response_Logging

Metric: 
GCBindTime

AD-SPI Graphs and Policies Source Metrics 
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Figure 25 In the right pane, you see the graph generated by the OVO 
grapher.   
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AD-SPI Graphs and Data Sources
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Troubleshooting
The situations described below offer methods of solving or detecting problems 
that may or may not require support assistance. Please see each for the 
relevancy to the problem you are experiencing.

Problem Solving with Self-Healing Services

Preferred method (using the HP Online Software Support web site): 
Troubleshooting information is greatly enhanced with cross-referencing 
capabilities available through the HP support site: 
http://support.openview.hp.com/self_healing.jsp. To access this 
information and the search capabilities available on the site, you must first 
download and configure the Self-Healing Services client software, an added 
benefit of your HP support contract. A link is then automatically set up to the 
Self-Healing Services web site, where your SPI problem can be matched to 
similar SPI problems/solutions for increased troubleshooting effectiveness. 
Please see the SPI CD Installation Guide section on Self-Healing Services for 
information on how to download, configure, and use the software and its 
automatic link to the HP web site support service.
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Alternative method (using the AD-SPI tool): If Self-Healing Services is 
not installed/configured on the node, you can use the Active Directory 
Self-Healing Info tool. This tool also gathers SPI troubleshooting data and 
stores it in a file that you submit to HP support for assistance.

Using the Self-Healing Info tool

To use the Self-Healing Info tool, complete these steps:

1 At the console expand Tools→SPI for Active Directory.

2 Right-click the Self-Healing Info tool and select All Tasks→Launch Tool....

3 Locate the node on which you want to run the Self-Healing Info tool and 
click the check box next to it.

4 Select the Launch... button..

5 You can select where to store the file after the tool has run.

In your call to HP support, you can then send the file, as your support 
representative directs you, as part of your support case.

Detecting Problems Through Tracing

On occasion you may have a problem for which you cannot easily find a 
solution. To capture all Active Directory information, including FSMO and 
replication conditions, status, and errors included in the Active Directory SPI 
logs, you can turn on tracing to access this information.

To turn on tracing for FSMO service consistency monitoring:

1 At the OVO console tree, expand the Policies grouped by type folder and 
select Scheduled Task.

2 In the right pane double-click the policy; for example ADSPI-FSMO_Consist.

Depending on a Windows setting, the file may be a hidden file on some 
managed nodes. If you do not see the file, open Windows Explorer and from the 
Tools menu select Folder Options...→View tabbed page. Under Hidden files and 
folders, select Show hidden files and folders.
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3 In the Command* text box, place the cursor at the end of the command 
and type: 
-l 1 
(a minus sign [-], the letter “l” for “log”, a blank space, and the number 
“1”).

4 Click Save and Close.

5 Re-deploy the policy to the node for which you want to conduct the trace.

To turn on tracing for FSMO service response time monitoring:

Repeat the above procedure, substituting the policy ADSPI-FSMO_Logging.

To turn on tracing for Replication service latency and response times. 

1 At the OVO console tree, expand the Policies grouped by type folder and 
select Measurement Threshold.

2 In the right pane double-click the policy:
ADSPI-Rep_Mon
or
ADSPI-Rep_Sysvol
or
ADSPI-Rep_TimeSync

3 In the Program* text box, place the cursor at the end of the command and 
type: 
-l 1 
(a minus sign [-], the letter “l” for “log”, a blank space, and the number 
“1”).

4 Click Save and Close.

5 Re-deploy the policy to the node for which you want to conduct the trace.

To view trace logs.

1 At the managed node start your preferred text editor.

2 Open the directory: <installed_drive>:\Program Files
\HP OpenView\installedpackages\<GUID>\log\

The above location shows the path to the file for default 
installations. For installations where file locations were modified, 
the location is determined by:%ovagentdir%\log.
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In the log directory, open the file with a .log extension and a name 
matching the command or program executable name used in the 
Command* or Program text box above. 
For example:
ADSPI_consist.log

Graphing Problems

Errors that occur when trying to generate a graph could result from the 
following:

Problem (graphing): Error 33, no data available for the replication latency 
graph.

— Cause(s): 
(1) Replication has not had sufficient time to occur.

(2) The user account settings for both the agent and the policy do not 
match. The default setting for the agent is to run as the Local 
SYSTEM account. However, the default setup may have been disabled 
though using the ToolsÆOpenView ToolsÆAgent Account tool group.

Solution(s): 
(1) Check the Scheduled Task policy to see how often replication 
latency is scheduled to occur. Wait until sufficient time elapses and 
then try once again to view or generate the report/graph.

(2) Check the agent account by going to Tools→OpenView Tools→Show 
agent account. Check the four AD-SPI Scheduled Task policies to 
ensure their user account settings match the agent account setup on 
the management server. Those policies are: ADSPI-FSMO_Consist, 
ADSPI-FSMO_Logging, ADSPI-REP_ModifyObj, 
ADSPI_Response_Logging. Double-click each policy and on the Task 
tabbed page of the Properties, see the Task type Command segment 
and note the Execute setting. The $AGENT_USER selection means 
that the agent runs as the Local SYSTEM account. Change the agent 
or policies as necessary to make all user account settings match.

— Cause: The Active Directory forest contains only a single domain 
controller; as a result, no replication occurs.

Solution: No replication latency graph can be generated when this 
configuration exists.
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Problem (graphing): Error 33, data not available for the graph.

— Cause: The system selected for graphing purposes is not a domain 
controller and therefore has no AD-SPI policies deployed on it. As a 
result, no data is available for the graph.

Solution: N/A; no real problem exists.

Reporting Problems

Errors that occur when trying to view a report could result from the following:

Problem (reporting): No data available for reports:

— Cause: The policies needed for the report’s data have not been 
deployed.

— Solution: Examine the policy inventory on the node in question to 
determine whether or not the policy is there. If not, deploy the policy.

Problem: The agent appears to be failing; that is, not collecting the data 
necessary for reporting.

— Cause: The user account settings for both the agent and the policy 
do not match. The default setting for the agent is to run as the Local 
SYSTEM account. However, the default setup may have been disabled 
through using the Tools→OpenView Tools→Agent Account tool group.

— Solution: Check the agent account by going to Tools→OpenView 
Tools→Show agent account. Check the four AD-SPI Scheduled Task 
policies to ensure their user account settings match the agent account 
setup on the management server. Those policies are: 
ADSPI-FSMO_Consist, ADSPI-FSMO_Logging, 
ADSPI-REP_ModifyObj, ADSPI_Response_Logging. Double-click each 
policy and on the Task tabbed page of the Properties, see the Task type 
Command segment and note the Execute setting. The $AGENT_USER 
selection means that the agent runs as the Local SYSTEM account. 
Change the agent or policies as necessary to make all user account 
settings match.
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Problem: The report “AD Domain Controller Availability Report” shows a 
non-global catalog server with a GC as unavailable 100% of the time.

— Cause: This error occurs whenever a server that hosts no global 
catalog services has a response-time monitoring policy deployed on it. 
Because no global catalog services are running, no data is available.

— Solution: The report is in error and no action is necessary. 
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