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HP-UX Provisioning

Overview

HP-UX Provisioning installs HP-UX on bare metal systems using custom configurations.
The HP-UX Provisioning process requires the following tasks:
e Setting up an Ignite environment on SA cores/satellites

e Creating custom configurations using the Custom Configuration Editor APX on the SA
core

e Booting the target to the Network boot prompt
e Provisioning targets using the HP-UX Provisioning APX on the SA Core

The following sections discuss these tasks.

Prerequisites

You must insure that the following prerequisites are met before you can provision HP-UX
servers.

DHCP Setup

To provision servers with unattended installations, DHCP must be enabled. HPSA ships the

DHCP server plus a highly customized configuration file to handle DHCP for OS provisioning
purposes. To provision HP-UX instead of Linux on Integrity servers, the HP-UX provisioning
feature must be enabled on each Core/Satellite.

To enable the HP-UX Provisioning feature, make the following changes on the SA Core:

1 Modify the /etc/opt/opsware/dhcpd/dhcpd. conf file by commenting the following line:
#filename "elilo.efi";

2 Uncomment the following line to enable network boot for HP-UX Provisioning:
filename "/opt/ignite/boot/nbp.efi";

3 Restart the DHCP service:

/etc/opt/opsware/startup/dhcpd restart



Ignite Setup on the SA Core

To provision HP-UX servers, you must set up Ignite Configurations. This includes:
e updating the configuration file

e updating the Index file

e copying the golden image archives on each SA core

For detailed information on Ignite-LUX software on a server running Linux, see

http:/ /www.hp.com/go/ignite-ux-docs

The following tasks are required to set up the 11.31 golden archive-based configuration on the
SA Core:

e Copy over the sample golden image to the following location:
/var/opt/ignite/archives/B.11.31/

e Copy over the corresponding .cfg file to following location:
/var/opt/ignite/data/Rel B.11.31/B.11.31 archive IA.cfg

¢ Add an entry in /var/opt/ignite/INDEX for the configuration as follows:

cfg "HP-UX B.11.31 Opsware Archive" ({
description "This selection supplies the sample golden archive
created by the IUX team"
"/opt/ignite/data/Rel B.11.31/config"
"/opt/ignite/data/Rel B.11.31/hw patches cfg"
"/var/opt/ignite/data/Rel B.11.31/B.11.31 archive IA.cfg"
"/var/opt/ignite/data/config.local"

}

APXs

e SA installs the HP-UX Provisioning APX (Automation Platform Extensions) and Custom
Configuration Editor APX which perform parts of the provisioning process. These APXs
appear in the SA Client APX Library.

¢  You can access APXs either through the SA Client or through an SA supported browser.
HP recommends running the Custom Configuration Editor APX with Internet Explorer.

e Adobe Flash Player Version 10.0 or above must be installed on all machines on which you
plan to run HP-UX Provisioning APXs.

Customer Configuration Subfolders

SA Administrators for HP-UX Provisioning or any user who has privileges to the following
folder must create a sample configuration for every customer for whom users want to create
configurations:

Library » By Folder>» Opsware » Tools » OS Provisioning » HP-UX Provisioning

The sample configuration is the same as the configuration that is created when you use the
Custom Configuration Editor APX. It is called the sample configuration because it is the first
configuration created for each new customer. When the first configuration is created, a
subfolder is created for that new customer. If the SA Administrator wants to assign restricted
access to a user/group based on configurations belonging to a specific customer, they must
grant permission to that customer subfolder.
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The SA Administrator can see subfolders created with the customer name only after creating
the sample configuration.

When you create the sample configuration, make sure that you select the new customer so
that the subfolder with the customer name is created immediately within the configuration
folder. The SA Administrator can assign read/write access to the user/group to access
configurations. For example, say that PROV_USR needs access to HP-UX Provisioning and
should have access only to configurations belonging to CustA and CustB customers:

1 Open the Custom Configuration Editor APX using Internet Explorer.

2 Log on as SA Administrator or as any user who has access to Library » By Folder »
Opsware » Tools » OS Provisioning » HP-UX Provisioning

3 Create a sample configuration for Cust? and CustB using the Custom Configuration
Editor APX.

4  Log on to the SA client as SA Administrator for HP-UX Provisioning. Create subfolders
named CustA and CustB at the following location:

Library » By Folder » Opsware » Tools » OS Provisioning »
HP-UX Provisioning/CustA

Library » By Folder » Opsware » Tools » OS Provisioning »
HP-UX Provisioning/CustB

Permissions

This section discusses the minimum permissions required to use the HP-UX Provisioning
feature. Your SA Administrators for HP-UX Provisioning can optionally provide additional
permissions that enable more features.

User/Group Permissions

SA Administrators for HP-UX Provisioning must grant the following permissions to the user/
group:

e Facilities — You must have read/write access to any facility where the Integrity servers are
provisioned with the configurations created by the Custom Configuration Editor APX.

e (Customers — You must have read/write access to any Not Assigned customer to run the
provisioning job successfully.

¢ You must also have read/write access to any customer on whose behalf the HP-UX
configurations are created.

e Features — You must have Managed Server and Groups permission so that you can
actually see the server in SA after you provision it.

Folder Permissions

SA Administrators for HP-UX Provisioning must also grant folder permissions to list APXs,
software policies, and configurations.

e APXs — You must have List Contents Of Folder and Execute Objects Within Folder
permissions to the following folder to access HP-UX Provisioning and Custom
Configuration Editor APXs:

Library » By Folder » Opsware » Tools » OS Provisioning » HP-UX

e Software Policies — You must have List contents of Folder, Read Objects Within Folder,
and Execute Objects Within Folder permissions to the folders where HP-UX software
policies used to define the configurations are placed.
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¢ Configurations — You must have Read Objects Within Folder and Write Objects Within
Folder permissions to the following folder because it contains the HP-UX configurations:

Library » By Folder » Opsware » Tools » OS Provisioning »
HP-UX Provisioning/<customer_name>

OS Installation

Installing an Operating System on HP-UX Servers

>»

HP-UX Provisioning installs HP-UX on bare metal systems using custom configurations. The
HP-UX Provisioning process requires the following tasks:

e Setting up an Ignite environment on SA cores/satellites

e Creating custom configurations using the Custom Configuration Editor APX on the SA
core

e Booting the target to the Network boot prompt
e Provisioning targets using the HP-UX Provisioning APX on the SA Core

The following sections discuss these tasks.

You must have set up Ignite before continuing. For more information, see Ignite Setup on the
SA Core on page 4.

Creating a Custom Configuration

You can specify customized configurations to be applied to an Integrity server. You can specify
Ignite attributes that are applied on the server during HP-UX installation on top of the
standard golden image configurations. You can also select additional software policies to be
remediated as part of the HP-UX installation.

You can build customer-specific configurations by specifying the platform, base configuration,
Ignite attributes, and related software policies. You can customize the installation to meet
your specific needs.

To provision the server in a customized way, you must first create a custom configuration.

HP-UX Custom Configuration Editor APX

To access the HP-UX Custom Configuration Editor APX:

1 In the SAS Web Client: Open Internet Explorer and specify the URL:
https:/ | <your core>/webapp !/ <APX Unique Name>
The unique name for the APX is displayed in the SAS Web Client.

2 In the SA Client: Click the Library tab and select Extensions » Web » HPUX
Custom Config Editor. The unique name for the APX is displayed when you select the
APX.

In this instance, the Custom Configuration Editor APX name is
com.hp.osprov.hpuxconfig.
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Figure 1 HP-UX Custom Configuration Editor APX
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All existing custom configurations are listed with Name, Customer, HP-UX Platform, Ignite
Server, and Base Config details. The Refresh, Create, and Delete buttons also appear.

Figure 2 HP-UX Custom Configuration Editor APX - List Existing Configurations
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When you select any existing configuration from the list, you will see additional details such
as Custom Configurations and Software policies.

The Configuration listings are based on permissions assigned to you. You are able to list
configurations belonging to the customers for which you have been granted permission. The
configuration can be customer dependent or customer independent.

A customer independent configuration is accessible to all users. A customer dependant
configuration is accessible to only those users who have appropriate permissions assigned.
You can make the configuration dependant or independent by selecting the customer when
you create the configuration.

The HP-UX Custom Configuration Editor APX enables you to:
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¢ Create Custom Configurations
¢ Delete Custom Configurations

Creating a Custom Configuration

To create a custom configuration:

1 Open the HP-UX Custom Configuration Editor APX using Internet Explorer.

2  Click the Create button and specify the required details to create a new custom
configuration.

Figure 3 HP-UX Custom Configuration Editor - Create Custom Config
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3 You must specify the following required details to define the HP-UX custom configuration:

— Config Name: This is a mandatory field. It must be unique for each customer. The
APX validates the following specifications:

— Must not exceed 255 characters in length.

— Must not begin or end with an empty space.

— Must not begin with punctuation, including @#5$%"~s&* ()+ -, ./:;~{}[II\""2="
— Should not use newline, tab, flash or backslash.

— Config Description: This is an optional field that can contain explanatory text
describing the purpose and use of the configuration.

— Customer: By default, this is set to Not Assigned, which makes the configuration
customer independent. You can only list those customers for which you have
permission. You will not be able to list the configurations if appropriate permissions
have not been granted to you for that customer.

— Platform: This is a mandatory field. You must select either 11.31 or 11.23 from the
drop-down menu. Base configuration or Related Software Policies are dependent on
platform selection. If the platform was not selected and you try to select either Base
configuration or Related Software Policies, a warning message appears.
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HP-UX Provisioning

— Base Configuration: Content is displayed based on the HP-UX platform selected.

— Custom Config: This is an optional field that can be used to specify Ignite attributes.
Any valid Ignite attributes specified in this field overwrite the configuration values
specified in the golden image, which allows you to provision the servers in a
customized manner.

The following are examples of Ignite attributes:

_hp pri swap=6291456Kb

"Create /export volume"=TRUE

_hp root disk="0/1/1/1.2.0"

_hp disk layout="Logical Volume manager (LVM) with VxFS"

For detailed information on Ignite custom attributes, see

http:/ /1 h20000.www2.hp.com /be/ docs / support / SupportManual /c01942568 /
c01942568.pdf

If the attributes and values specified are valid, they are applied on the servers on top
of the standard image configurations. However, if the attributes specified are invalid
or have incorrect syntax, provisioning will not start.

In some cases, attributes and values are incompatible. For example, say that you want
to provision the server with the following Ignite attributes:

_hp pri swap=6291456Kb
"Create /export volume"=TRUE

The Ignite attributes syntax is correct and also has valid values but your target does
not have enough disk space to implement it. As a result, a warning message is
displayed on the targets before provisioning starts.

Related Software Policies: This is an optional field consisting of a drop-down menu whose
contents are displayed based on the platform selected. You can select multiple Related
Software policies by holding the CTRL key and dragging the policies to the selected
software policies list to apply them on the server after provisioning is completed and the
agent is installed.

You can change the sequence of a selected software policy by dragging it up or down.
Polices specified in Selected Software Policies are applied on top of the standard policies in
the golden Ignite image.

After the details for all mandatory fields, Config Name, Platform and Base Config are
specified, the Create button is enabled.

Click the Create button. A confirmation message appears and the newly created
configuration is listed.
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Boot Target

The network booted integrity client requires selecting the desired LAN and target OS to
install. It waits for server side install instructions to start HP-UX Provisioning. The following
figure shows a target client waiting to be installed.

Figure 5 Server Waiting to be Installed
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For more information, see:

http:/ / h20000.www2.hp.com /be/docs ! support / SupportManual /c01868281/c01868281.pdf
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Provision the Target Servers

Once the custom configuration is created, it is listed on the HP-UX Provisioning APX on the

SA Client. The target server waiting at the network boot prompt is listed under the

unprovisioned servers list on the HP-UX Provisioning APX. The following section describes

how to provision the targets.

HP-UX Provisioning APX

To access HP-UX Provisioning APX:
1 Log on to the SA Client.

2  Click the Library tab and select Extensions » Web » HP-UX Provisioning.

Figure 6 HP-UX Provisioning APX
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The HP-UX Provisioning APX popup window showing the HP-UX configuration opens.
Figure 7 HP-UX Provisioning APX - Listing of HP-UX Configurations
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12

All the configurations created using the Custom Configuration Editor APX are listed on
the HP-UX Provisioning APX based on permissions granted. Configurations are listed
with Name, Customer, HP-UX Platform, Ignite Server, and Base configurations details.
The Refresh, Next, and Start buttons are also displayed. Select the HP-UX configuration
you want installed on the servers and click Next.

When you select a configuration, additional details, including Custom Configurations and
Software policies of the chosen configuration, are displayed. When you select a
configuration, the Next button is enabled.

Figure 8 HP-UX Provisioning APX - Select HP-UX Configuration
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Click Next to select the unprovisioned servers.

All unprovisioned servers waiting at the network boot prompt matching the selected
configuration platform are displayed and show MAC address, install OS, Ignite Server
and Model details. Servers in the Unprovisioned Servers list register their presence, but
do not have an operating system installed.

Select the server to provision. Hold down the CRTL key to select multiple servers to
provision at the same time using the same configuration.

Figure 9 Select Client to Provision Using the Config Selected Before
( 53 HP-UX Prov ===

- SO s

Select Servers to Provision (Step 2 of 2)

Choose one or more servers from the provisioning pool. To add = server to the pool, it must be network booted.

Selected HPUX Config:  @f  11.31 vPar

Install OS Ignite Server Model

B.11.31 4. ia64 hp server <7620
B.11.21 2. . 4. ia64 hp server <7620

Refresh | <Back || Next> | | start |

Once all servers are selected, provisioning starts immediately after you click the Start
button.
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HP-UX Provisioning

5 To set email notification, click the Next button. The following screen appears.

Eigure 10 Set the Email Notification

£5 HP-UX Prov == =m )|
-5 SO0

Additional Job Options (Step 3 of 3)

Optionally spacify people to notify whan the job is completed, snd whether they should be notified if an =rror occurs. Also provide a tickst
1D, if required.

Selected HP-UX Config: @Y

Email Notifications

Email Address of Recipient Success Failure

parikh@hp.com 1] w1

gk Add Remowve

Ticket Integration

Ticket ID: | 123456

< Back Start

On Email Notification, by default, your email address (the user running the job) is
displayed. To add additional email addresses, click +Add. Select the check boxes to receive

notifications when job failure or success occurs. To remove an email address, select the
address and click Remove.

You can also specify the Job Ticket ID in the Ticket Integration section. This Ticket ID is
associated with the Job.

6 When you click Start, the job is initiated for program APX and the Job ID is assigned to it.
Figure 11 Initializing the Provisioning Job
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Figure 12 Initializing the Provisioning Job

59 HP-UX Prov E=3E=8c>2
- SO ao

Job Progress for Job ID 20720058

View the status of the job. Active jobs will continue to run if the window is closed.
Selected HPUX Config: @ 11.31 vPar
[r— ]

Status: 6 % complete
Start tirme: Fri Jun 11 14:22:48 GMT-0700 2010

Server Name MAC address Status % Complete Status Message
dhep-184-253 00:30:6E:4B:C7:47 Active . 6 Configure_Disks
dhcp-184-254 00:0F:20:2B:23:2F Active . 6 Configure_Disks

If the provisioning job was initiated successfully on the servers, you will see the following
screen. This screen has a progress bar that is refreshed with updated progress status
messages. The following status messages are updated during the provisioning job:

— Waiting_to_install

— Prepare_Config_File

— Configure_Disks

— Download_mini-system
— Loading_software

— Build_Kernel

— Boot_From_Client_Disk
— Run_Postconfigure_Scripts
— Agent Install

— Remediate software policy

Figure 13 Progress Bar with Status Message

1 HP-LX e [F=nEen ~==|
= = T O o

Job Progress for Job 1D F0SI005E

Wimw tha stetus of the job., Active jobe w8l continus to run i the sndow i dossd
Salectad HPUK Configs B 1131 vOur

51 % complate
% tmmn FriJun 1L EB 0438 GMT-0T00 2019

Ssrves Mamts MAL addreas Statis o Complets
dhcps L4253 [T IET A Active 1
dhepe L0 20 DO IOF 1201 281231 2F et —— Bt _warnai
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Once the provisioning job starts, two different progress bars are displayed. The
consolidated progress bar displays the average percentage of progress on all servers being

provisioned. It also displays the average percentage of jobs finished with the job start
time.

The progress bar for each of the servers being provisioned shows the percentage of
provisioning complete with Server Name, MAC address, Status, and Status Message

details. The % Complete and Status Message are updated along with the progress of the
provisioning job.

Figure 14 Progress Bar with Status Message Remediate Software Policies
S HP-UK Pree =
=5 SO O

2ok Progress for Job 10 20010038

Wi tha status of the job. Actiee joba will coatinue 15 nun @ the window in coaed,
Baleciod HOUX Confige 9 1131 vlar

Stabus: B9 % complate

SEart timas Fri Jun 81 35104039 GMT-0T00 2030

Server Hams HAC addraus Status o Complets Status Mosssge

divcp- 184- 253 001 I01EE 481 CT 147 in Progreas — 80 Famadiste Softwars Polices
dheg-184-354 00IOF 20/ ZBIINF  in Progeass [ —

Emmadiate Snfimane Bples

Once the server is provisioned, the agent is installed by default. Also, the software policies
chosen in the configuration are remediated on the servers. When the HP-UX Provisioning
job completes, an email is sent to you if you set up email notification.

Figure 15 Progress Bar with Job Completed Message
'ﬁm-u;pm :

==
- SO BE

Job Prograss for Job 1D 20810058

View the status of the job. Adtive jobs wll conbinee o run if the window is dosed,

Salected WPUX Config: Y 1131 vPar

casnfully
13:04:39 GMT-0700 2010
Ervd tima: Fri Jun 11 13130112 GMT-0M00 2010

Sarver Hame HAC sddrass. Status
dhep- 184253 OO B0EE B TT 4T
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oot Canaplete Statss Messsge
Cometated succasstuty [N ecixts Softrare Policies

O00F 201201220 2F Complated successfully _ Remediste Scfteare Policies

Herum Job
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The provisioned servers are managed by SA. The servers are listed under Devices »
All Managed Servers. Select the server, and then select Go to View » Properties. You
can see the customer value, which is the same as the configuration customer value. You

can see the servers listed as managed servers only if you have permission granted for the
customer.

You can also verify the configuration name associated with the server. Go to View »

Custom Attributes. This can be useful to find out which configuration was used to
provision the server.

Jobs and Sessions on SA Core

HP-UX Provisioning APX assigns the job ID. You can use the job ID to verify the job status at
the following location: SA » Jobs and Sessions » Job Logs.

Figure 16 Job Status on SA Jobs and Sessions
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You can also find the specified Job Ticket ID in the notifications tab by double-clicking the job.

Deleting Custom Configurations

To delete a custom configuration:

1 Open the HP-UX Custom Configuration Editor APX using Internet Explorer.

2 Select the configuration or hold the CTRL key to select multiple configurations and click
Delete.
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Figure 17 Delete Custom Config Profile

28 sy /192. 168, 184 195/ we Bapieom B 030w Must gy - Windows Internet Exploser Lo} 5 el
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3 Click Yes on the confirmation window. The selected configurations are deleted and are no
longer listed.

You are allowed to delete only those configurations for which you were granted privileges
to execute the delete configuration operation.

Additional Information

Glossary

Ignite-UX
An HP-UX administration toolset that allows:
— simultaneous installation of HP-UX on multiple clients

— creation of custom installation configurations (golden images) for multiple
installations on clients

— creation of recovery media

— recovery of HP-UX clients both locally and remotely
Ignite-UX server

A server from which Ignite-UX is used to install HP-UX on client systems.
Golden Image

A combination of a golden archive and a configuration file describing a system's disk
layout and file system. Used as a common configuration to install clients.

Ignite Attributes

Custom attributes that allow provisioning of a server with new customized values that
overwrite the standard attributes values defined in the golden image.

Network boot
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A system boot of the HP-UX install kernel over a network connection from an Ignite-UX
server.

Target or Target Server
The HP Integrity server to be provisioned.
Custom Configuration Editor APX
The APX used to create and delete the custom configurations for HP-UX Provisioning.
HP-UX Provisioning APX
The APX used to start HP-UX Provisioning on target servers.
Sample Configuration

The first configuration created for the new customer by the SA Administrator for HP-UX
Provisioning. It is same as the custom configuration but is the first configuration for a
new customer. It creates a subfolder with the customer name under the HP-UX Configs
folder in the SA Client Library.

Useful Links

e 11iv3 installation information:

http:/ / h20000.www2.hp.com /be/docs / support / SupportManual /c01916012/
c01916012.pdf

e  White paper: Ignite-LUX: Management and Integration of Ignite-UX Software on a Server
Running Linux at:

http:/ lwww.hp.com/go/ignite-ux-docs
e Ignite-UX custom configuration files:

http:/ / h20000.www2.hp.com /be/docs / support / SupportManual /c01942568 /
c01942568.pdf

e Ignite-UX:

http:/ 1 h20000.www2.hp.com [ bizsupport | TechSupport /
DocumentIndex.jsp?lang=en&cc=us&taskld=101&prodClassld=10008&contentType=Sup
portManual&docIndexId=64255&prodTypeld=18964&prodSeriesId=4077173

Troubleshooting

Following are some problem scenarios and suggested solutions.
Scenario: No Servers Waiting to be Installed

If there are no servers waiting at the network boot prompt with the HP-UX version that
matches the selected configuration's HP-UX version, the following message is displayed:

Figure 18 No Servers Waiting to be Installed

Ensure that you have the selected correct configuration.
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Scenario: Servers Waiting to be Installed are Managed Servers

If there are servers waiting for network installation but they are already managed by SA, the
following warning message is displayed.

Figure 19 Servers Waiting to be Installed are Managed Servers

The follovdng servers are managed servers in
SA, but are in the waiting to be installed list,

Fesre delete them from S# if you went to re-
provizion HE-UX on them.
ID:1 110058 Namae: blade-BED

This warning message indicates that the listed servers are waiting for installation but are not
candidates for reprovisioning because they are listed as Managed Servers in SA. To continue
reprovisioning these servers, you must manually delete them from the SA managed server
list.

For more information about deactivating and deleting a server from the SA managed servers
list, see the SA User Guide: Server Automation.

Figure 20 List of Deleted Managed Servers for Reprovisioning
% HP-UX Prov
SO0 ag

Select Servers to Provision (Step 2 of 3)

Choose one or more servers from the provisioning pool. To add = server to the pool, it must be network booted.

Selected HPUX Config: ‘@Y Config 11.31 StandAlone2

Name MAC Install OS Ignite Server Model
@ blade-850 00:11:0A:AS:40:07 B.11.31 192.168.184.195 i264 hp Intagrity BLEGDC
Refresh | sBack || mesis

Once a server is deleted, it is not listed under the SA managed server list. Click Refresh in the
HP-UX Provisioning APX window and the server should be listed under the unprovisioned
server pool. Select the server and continue provisioning it.

Scenario: Configurations Unavailable or Permissions Not Granted

This message appears when you do not have enough permission granted to list the
configurations or there are no configurations found.

Figure 21 No Configurations Available or Permissions Granted

Y¥ou do not have access to any HP-UX
Configurations or there are no HP-UX

Configurations created in SA. Please re-validate
then press the refresh button

Contact your SA Administrator to obtain permission or create required configurations using
the Custom Configuration Editor APX.
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Scenario: Incorrect Target Listing

In certain error scenarios, you may see stale data in the APX client’s menu such as clients
that are not currently waiting to be network installed or clients with an incorrect hostname.

e A client that is not currently waiting to be network installed is displayed in the APX
clients list.

If the target server is reset while waiting to be network installed, the Ignite-UX cannot
detect the change and does not update the client’s status.

Retry the installation or delete the directories for the target under /var/opt/ignite/
clients/. There are two directories for each client, one of the form <mac address> (for

example, 0x00306EF37245) and the other a symbolic link to the directory. Delete both
directories.

e A client is listed in the APX with an incorrect hostname.

This can happen when you modify DHCP to provide a different hostname after having
previously provisioned the client. Ignite UX reuses the directories in /var/opt/ignite/
clients/ it set up for a client (when it finds a client based on the MAC address), so the
APX reuses that information. You can delete the two directories for the client under
/var/opt/ignite/clients and retry the installation.

Scenario: Installation Timed Out Error

An installation timed out error occurs when the provisioning job is not initiated on the target

server. This could be due to a network issue, the golden image not being available, or for other
reasons.

Figure 22 Provisioning Not Initiated on Server
59 HP-UX Prov

[E=18|EoR| x>
— 7 =
SO ago
Job Progress for Job ID 14670058
View the status of the job. Active jobs will continue to run if the window is closed.
Selectad HPUX Config: @Y 11.31 multo targat
Status: Completed successfully
Start time: Wed May 19 13:55:05 GMT-0700 2010
End time: Wed May 19 14:18:45 GMT-0700 2010
Server Name MAC address Status % Complete Status Message v
ko082 00:30:6E:48:C7:47 tnstall timad out [ =itino_To_ Install
081_vpar 00:0F:20:28:23:2F completed successf [ S R --d=te Softvare Policies

Ensure that the network connection and Ignite images are accessibility and run the APX
again to initiate provisioning.

Scenario: Loading Software Error

A loading software error can occur due to:

e Network issues

e Corresponding archive missing or not accessible

e Incorrect setup of golden images
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Figure 23 Golden Image Set Up Incorrectly

3 HP-UX Prov
« % SO G5

Job Progress for Job ID 14750053

[E=H BB

View the status of the job. Active jobs will continue to run if the window is closed.
Selected HPUX Config: @¥ 11.31 Blade860C config

Status: Completed successfully
Start time: Wed May 19 14:58:32 GMT-0700 2010
End tima: Wed May 19 15:21:44 GMT-0700 2010

Server Name MAC address Status % Complete Status Message

blade-860 00:11:0A:AS5:40:07 Error I - dino_softvare

To resolve this, ensure that the Ignite-specific configuration file, Index file, and archives are
correctly set up and pointing to correct locations. Also ensure that the network connection
between the target and the Ignite server is accessible.

Scenario: Prepare Config File Error

The provisioning job fails to initiate on the server when any syntax errors are found in the

custom attributes specified in the configuration or when the custom attributes are not
compatible.

Figure 24 Provisioning Failed Due to Invalid Ignite Attributes

55 HP-UX Prov
«% SO ag

Job Progress for Job ID 15540058

=)o ] s

View the status of the job. Active jobs will continue to run if the window is closed.
Selected HPUX Config: @f LUM attributes 11.31 vPar

Status: Completad successfully
Start time: Tue May 25 10:11:03 GMT-0700 2010
End time: Tue May 25 10:11:28 GMT-0700 2010

Server Name MAC address Status % Complete Status Message

kosz 00:30:6E:4B:C7:47 Error N - <-==_Config_File

You may need to reboot the system and bring it back to the network boot prompt, then create

a new configuration with corrected custom attributes. Ensure that the specified syntax is
correct and compatible.

Scenario: Agent Fails to Start

If, after successful job completion, the SA Agent fails to start on a newly provisioned target,
the golden image you used may already have an Agent installed.

For example, as part of the standard provisioning process, after HP-UX is installed on the
server, a post-install script that installs an Agent runs on the server. Because the Agent was
previously installed with the golden image, the Agent may not start.
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