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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to:

http://support.openview.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

Visit the HP Software Support Online web site at:

www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and support that HP 
Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to 
access interactive technical support tools needed to manage your business. As a valued support customer, you 
can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
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HP-UX Patch Management
Overview

In Server Automation (SA), patches for the HP-UX operating system are delivered exclusively 
by HP as depots. Depots contain multiple patch products and each patch product contains 
multiple patch file sets. These depots can be uploaded into Server Automation. 

In patch management for HP-UX, you can:

• Create HP-UX software policies from HP-UX patches or patch bundles.

• Identify, install, and remove HP-UX patches from the server.

• Install software and patches by remediating software policies.

• Download metadata information associated with each patch.

• Support multi-platform patches, patch dependencies, and automatic reboots.

• Run compliance scans. 

Features

SA automates HP-UX patch management by enabling you to:

• Define HP-UX software policies that provide a model-based approach to managing your 
HP-UX servers. Server Automation enables you to create a model of your IT environment 
using HP-UX software policies. These software policies specify patches and scripts that 
can be installed on the managed servers.

• Install HP-UX patches and patch bundles on your managed servers.

• Establish a patch installation process.

• Schedule the stages of patch management: analysis, download, and installation. You can 
also set up email notification for each stage and associate a ticket ID for each job.

• Verify the compliance status of servers, based on software policies.

• Display the Compliance view to see whether servers are configured according to the 
software policy and to remediate non-compliant servers.

• Search for software resources and servers.

• Use the Library to search for HP-UX packages, patches, and software policies using 
powerful and flexible search criteria, such as availability, architecture, operating system, 
reboot options, version, and so on. You can also search for HP-UX software policies by 
name, folder name, availability, and operating system.

• View patch dependencies and patch applicability analysis while previewing patch 
installation.
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Prerequisites

You must complete the following tasks to use the patch management for HP-UX:

• Download the HP-UX Software Catalog file. 

You must have a service level contract to download the HP-UX Software Catalog file. Use 
the import_hpux_metadata script to download this file. For more information, review the 
-h option that is provided with this script. See HP-UX Depots on page 4.

• Upload the new patches and re-upload the existing HP-UX patches, depots, and bundles 
to the SA. 

• Update the HP-UX agent on all existing managed servers. The agent version must be 
equal to or higher than opsware-agent-37.0.0.2.130.

Supported Operating Systems 

See the SA Support and Compatibility Matrix for detailed information about supported 
HP-UX operating systems for patch management.

HP-UX Depots

The import_hpux_depot script imports HP-UX patches, bundles, and depots into the SA 
Library. For each source depot, this tool creates a <depot name> Depot policy in the SA 
Library that contains the depot's products.

The import_hpux_depot script requires the .depot extension to script input: 

• By default, standard HP-UX bundles that are downloaded from http://itrc.hp.com 
already have a .depot extension.

• By default, HP-UX patches that are downloaded from http://itrc.hp.com do not include 
the .depot extension. These patches must be manually downloaded to an HP-UX server, 
unshared to create a .depot file, and then uploaded to the SA Library using the 
import_hpux_depot script.

The import_hpux_depot script is located in the following directory:

/opt/opsware/mm_wordbot/util/import_hpux_depots

Importing patches and depots using the SA Client instead of scripts will not create software 
policies and patch dependency will not work.

After HP-UX patches have been uploaded to the SA Library, you cannot delete them. The 
delete option is disabled when you select an "HP-UX Patch Product" or an "HP-UX Patch 
Fileset". 
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Table 1 describes the script’s options.  

Table 1 Options of import_hpux_depot

Option Description

import_hpux_depots [options] All *.depot files in the current working directory 
are imported into the Library.

import_hpux_depots [options] 
<source-directory>

All *.depot files in the specified directory are 
imported into the Library.

import_hpux_depots [options] 
<*.depot

The specified depots are imported into the 
Library.

import_hpux_depots -h Show additional options.

-b, --bundle-policies create a 
policy for each depot bundle

For each bundle that appears in a source depot, 
this tool creates a <bundle name> Bundle policy 
in the SA Library that contains the bundle's 
products using the --bundle-policies option.

-f, --force Force depot products to be imported even if 
already in the SA Library.

-h, --help Displays the help message.

-n, --silent Display errors only.

-o OS, --os=OS HP-UX release of depot products 10.20, 11.00, 
11.11, 11.23, and 11.31. 
Some patches are common to both 11.23 and 
11.31 operating system versions. Use -o=11.23 or 
-o=11.31 to upload these patches into the SA 
Library.

-p POLICY_FOLDER, 
--policy_folder=POLICY_FOLDER

Path to Library folder in which to create policies.

-s SPLIT, --split=SPLIT How to 
split each depot (default: 
product): 'product', 'instance', 
'none'

Products that are already in the SA Library are 
not re-imported unless --force is specified.

By default, depots containing multiple products 
are split by product so that each product is kept 
in the SA Library as its own self-contained depot. 
The split behavior is controlled by the --split 
option:

• none—Source depots are not split but are 
imported as is.

• product—Source depots are split by product. 
If a depot contains multiple instances of the 
same product (by name), the instances are 
kept together. This is the default.

• instance—Source depots are split by product 
instance. If a depot contains multiple 
instances of the same product (by name), each 
instance is split into its own depot.
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HP-UX Software Catalog File

The HP-UX Software Catalog file is the HP-UX Patch Database in XML format. The catalog 
file is swa_catalog.xml and can be downloaded from ftp://ftp.itrc.hp.com/export/patches.

The HP-UX Metadata script is used to import the HP-UX Software Catalog file into the SA 
Library. This script can list dependent patches for any patch that exists in the software 
catalog file and indicate the dependent patches that are missing in the package repository.

The HP-UX Metadata script is located in the following directory:

/opt/opsware/mm_wordbot/util/import_hpux_metadata

Table 2 describes the script’s options.  

-u USERNAME, --username=USERNAME Upload packages as specified user (default: 
opsware).

-v, --verbose Display verbose output

--manual Show manual page and exit.

--version Show version and exit.

Table 1 Options of import_hpux_depot (cont’d)

Option Description

Table 2 Options of the HP-UX Metadata Script

Option Description

-a HPUX_ANALYZE_PATCHES, 
--analyze_patches=HPUX_ANALYZE_PA
TCHES

Specifies the HP-UX patches that will be 
analyzed for any dependent patches missing in 
the package repository. Multiple HP-UX patches 
can be specified by separating them with a 
comma (,). To analyze all HP-UX patches in the 
package repository, include the keyword all.

-c HPUX_SW_CATALOG_FILE, 
--catalog_file=HPUX_SW_CATALOG_FI
LE

Specifies the source location of the HP-UX 
software catalog file. The swa_catalog.xml 
catalog file can be downloaded from ftp://
ftp.itrc.hp.com/export/patches. This option does 
not apply when the user ID and password are 
specified.

-d 
DISPLAY_DEPENDENCIES,--display_de
pendencies=DISPLAY_DEPENDENCIES

Specifies HP-UX patches for which the 
dependencies should be displayed. To display the 
dependencies for all patches in the software 
catalog file, include the keyword all.

-h, --help Displays the help message.
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Software Policy Management

In Server Automation, HP-UX software policies enable you to install HP-UX software and 
patches on servers and groups of servers. When you create a software policy, you attach it to 
servers or groups of servers. When you remediate a server or a group of servers, the patches 
specified in the attached software policy are automatically installed. The remediation process 
compares what is actually installed on a server with the software policy that specifies the 
patches that should be installed on the server. SA then determines what operations are 
required to modify the server to bring it in compliance with the policy. The following sections 
describe how to manage HP-UX software policies.

Creating an HP-UX Software Policy

In the SA Client, you create a software policy by using either one of the following Library 
features:

• Library—By Type

• Library—By Folder

You must have permissions to create and manage an HP-UX software policy. To obtain these 
permissions, contact your system administrator. See the SA Administration Guide for more 
information about software management permissions.

In the content pane, a dimmed patch icon indicates that the patch has not been uploaded to 
the Library. Use the column selector to control the columns of patch metadata data that you 
want to display. See Table 1.

-n, --no_supersedence Flag is used with the -a option indicating 
whether to use the superseded dependence tree or 
the basic dependence tree for reporting missing 
patches. The superseded dependence tree is the 
default behavior for HP-UX patching. It performs 
the most recent dependency check. The basic 
dependency tree performs the least recent 
dependence check.

-p PASSWORD 
--password=PASSWORD

The password that is required to access the 
itrc.hp.com website to automatically download the 
swa_catalog.xml file. Both user ID and 
password must be specified.

-u USERID, --user=USERID The user ID that is required to access the 
itrc.hp.com website to automatically download the 
swa_catalog.xml file. Both user ID and 
password must be specified.

Table 2 Options of the HP-UX Metadata Script (cont’d)

Option Description
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Figure 1 HP-UX Patches in the SA Client Library

Library—By Type

To use the By Type feature to create a software policy:

1 In the navigation pane, select Library ➤  By Type ➤ Software Policies ➤  HP-UX. 
The content pane displays a list of software policies. By default, the software policies are 
organized by operating system families.

2 Double-click to select an operating system.

3 From the Actions menu, select New to open the New Software Policy window.

4 In the Name field, enter the name of the HP-UX software policy.

5 (Optional) In the Description field, enter text that describes the purpose or contents of the 
policy.

6 Next to the Location field, click Select to specify the location for the software policy in the 
folder hierarchy. 

7 In the Select Folder window, select a folder in the Library to specify the location of the 
software policy and then click Select to save your setting.

8 From the Availability drop-down list, select an SA server life cycle value (Available or 
Deprecated) for the software policy.

9 From the OS drop-down list, select the operating system family or specific operating 
systems in that family.
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10 Keep the Template value set to No, which is the default.

11 From the File menu, select Save.

Library—By Folder

To use the By Folder feature to create a software policy:

1 In the navigation pane, select Library ➤  By Folder. The content pane displays the 
folder hierarchy in the library.

2 In the content pane, select the folder that you want to contain the software policy.

3 From the Actions menu, select New ➤ Software Policy to open the New Software Policy 
window.

4 In the Name field, enter the name of the HP-UX software policy.

5 (Optional) In the Description field, enter text that describes the purpose or contents of the 
policy.

6 Next to the Location field, click Select to change the location for the software policy in the 
folder hierarchy. 

7 In the Select Folder window, select a folder in the Library to specify the location of the 
software policy and then Select to save your setting.

8 In the Availability drop-down list, select an SA server life cycle value (Available or 
Deprecated) for the software policy.

9 In the OS drop-down list, select the operating system family or specific operating systems 
in that family.

10 Keep the Template value set to No, which is the default.

11 From the File menu, select Save.

Viewing an HP-UX Software Policy

In the SA Client, you view a software policy by using any of the following navigation features:

• Search

• Devices

• Library—By Type

• Library—By Folder

Search

To use the Search feature to view a software policy:

1 In the navigation pane, select Search.

2 In the drop-down list, select Software Policy and then enter the name of the policy in the 
text field.

3 Click  to display the search results in the content pane.

4 In the content pane, select the software policy and then right-click to open the Software 
Policy window.
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Devices

To use the Devices feature to view a software policy:

1 In the navigation pane, select Devices ➤ Servers ➤  All Managed Servers to display a 
list of servers in the content pane.

Or 

In the navigation pane, select Devices ➤  Device Groups to display a list of servers in 
the content pane

2 In the content pane, select a server. 

3 Right-click the selected server to open the Server window.

4 In the Information pane, select Management Policies.

5 In the Management Policies pane, select Software Policies to display the software policies 
attached to the server in the content pane.

6 In the content pane, select the software policy and then right-click to open the Software 
Policy window.

Library—By Type

To use the By Type feature to view a software policy:

1 In the navigation pane, select Library ➤  By Type ➤  Software Policies ➤  HP-UX and 
an operating system version. The content pane displays a list of software policies. By 
default, the software policies are organized by operating system families.

2 In the content pane, select the software policy and then right-click to open the Software 
Policy window.

Library—By Folder

To use the By Folder feature to view a software policy:

1 In the navigation pane, select Library ➤  By Folder. The content pane displays the 
folder hierarchy in the library.

2 In the content pane, select the folder that contains the software policy.

3 Right-click to open the folder.

4 Select the software policy and then right-click to open the Software Policy window.
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Editing an HP-UX Software Policy

After you create an HP-UX software policy, you can view and modify its properties. You can 
view properties, such as the SA user who created the software policy, the date when it was 
created, and the SA ID of the software policy. You can also modify (edit) the name, description, 
availability, location of the software policy in the Library, and the operating systems of the 
software policy.

You must have permissions to manage an HP-UX software policy. To obtain these permissions, 
contact your system administrator. See the SA Administration Guide for more information 
about software management permissions.

To edit the properties of a software policy:

1 In the navigation pane, select Library ➤  By Type ➤  Software Policies ➤  HP-UX and 
an operating system version.

2 In the content pane, select the software policy and then right-click to open the Software 
Policy window.

3 In the Software Policy window, in the Views pane, select Properties. 

4 In the Properties content pane, you can edit the Name, Description, Location, Availability, 
and OS for the software policy. See Creating an HP-UX Software Policy on page 7 for 
guidelines about information in these fields.

5 After you have made your changes, from the File menu, select Save.

Adding an HP-UX Patch to a Software Policy

After you create an HP-UX software policy, you can add HP-UX patches, HP-UX software, and 
server scripts to it. Adding these does not install them on a managed server. You must attach 
the software policy to a managed server and then remediate the server. 

You must have permissions to add an HP-UX patch, HP-UX software, and server scripts to an 
HP-UX software policy. To obtain these permissions, contact your system administrator. See 
the SA Administration Guide for more information about software management permissions.

To add software resources to a software policy:

1 In the navigation pane, select Library ➤ By Type ➤ Software Policies ➤  HP-UX and 
an operating system version.

2 In the content pane, select a software policy.

3 Right-click the selected software policy to open the Software Policy window.

4 In the Views pane, select Policy Items.

5 Click  or, from the Actions menu, select Add to display the Select Library Item window.

6 Select the Browse Types tab to display items that can be added to the software policy.
HP-UX Patch Management 11



7 Select one or more items you want to add to the policy and then click Select. The items 
are added to the policy.

Or 

Select the Browse Folders tab to display the folder hierarchy in the Library and the list of 
items contained in the folders. Select one or more items you want to add to the policy and 
then click Select. The items are added to the policy.

8 To change the order in which the software is installed, use the  arrows. 

9 To remove an item from the policy, select it and then click . See Removing Software 
from a Software Policy on page 12 for more information about this action.

10 From the File menu, select Save to save the changes you made to the policy.

Removing Software from a Software Policy

When you remove software from an HP-UX software policy, the software is not uninstalled 
from the managed server. This action only removes the software from the policy. To uninstall 
the HP-UX software from a managed server, you must directly uninstall the software from the 
managed server.

You must have permissions to remove HP-UX software from an HP-UX software policy. To 
obtain these permissions, contact your system administrator. For more information, see the 
SA Administration Guide.

To remove HP-UX software from a software policy:

1 In the navigation pane, select Library ➤ By Type ➤ Software Policies ➤  HP-UX and 
an operating system version.

2 In the content pane, select the software policy and then right-click to open the Software 
Policy window.

3 In the Views pane, select Policy Items.

4 Select the items that you want to remove from the list of policy items displayed in the 
Content pane.

5 Click  or, from the Actions menu, select Remove.

6 From the File menu, select Save to save the changes you made to the policy.
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Viewing Software Policy History

To view the events associated with an HP-UX software policy:

1 In the navigation pane, select Library ➤ By Type ➤ Software Policies ➤  HP-UX and 
an operating system version.

2 In the content pane, select the software policy and then right-click to open the Software 
Policy window.

3 In the Views pane, select History. The events associated with the software policy display 
in the content pane. You can view the action performed on the policy, the user who 
performed the action, and the time when the action was performed.

4 From the Show drop-down list, select a meaningful time period narrows or widens the 
volume of events.

Viewing Servers Attached to a Software Policy

In the SA Client, you can view a list of all servers and device groups that have a selected 
HP-UX software policy attached to them.

To view a list of all servers that have a selected HP-UX software policy attached to them:

1 In the navigation pane, select Library ➤ By Type ➤ Software Policies ➤  HP-UX and 
an operating system version.

2 In the content pane, select the software policy and then right-click to open the Software 
Policy window.

3 In the Views pane, select Server Usage. A list of servers that have the selected software 
policy attached to them displays in the content pane.

Finding a Software Policy in Folders

To find an HP-UX software policy in the folder hierarchy:

1 In the navigation pane, select Library ➤ By Type ➤ Software Policies ➤  HP-UX and 
an operating system version.

2 In the content pane, select a software policy.

3 Right-click and then select Locate in Folders to display the folder hierarchy for the 
software policy in the content pane.
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Custom Attributes

Patch management for HP-UX enables you to set a hpuxpatch_dont_supersede custom 
attribute to any managed server, as shown in Figure 2.

Figure 2 Custom Attribute: hpuxpatch_dont_supersede

Server Automation requires that the latest patches are included in the software policy, with 
the custom attribute not set. This default behavior is designed to resolve dependency by 
looking for the latest patches in the software policy. If the latest patches are not available, SA 
will display an error message that reminds you to download the latest patches from HP. 

Patch Compliance

An HP-UX patch compliance scan compares the patches that are installed on a managed 
server with the patch policies that are attached to the server. If the actual server 
configuration does not match the patch policies attached to the server, the server is out of 
compliance with the patch policies. In addition, if a patch in the patch policy has been 
superseded by a newer patch and the newer patch is installed on a server, that server will be 
marked as compliant.

In the SA Client, when you perform a patch compliance scan, the scan indicates the server's 
overall compliance with all HP-UX patch policies that are attached to the server. Even if only 
one HP-UX patch policy attached to the server is not compliant, the server is considered 
non-compliant. You can then view the non-compliant server and remediate the server against 
the applicable patch policy.

The SA Client displays the following compliance information for a patch policy:

Table 3 Compliance Status for a Managed Server

 Icon Status Description

Compliant All patch policies attached to a server are 
compliant—all patches specified in all patch 
policies are installed on the server.

Non-compliant At least one of the patch policies attached to the 
server is not compliant—at least one patch in the 
policy is not installed on the server.

Scan Started The patch compliance information is currently 
being collected.
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See Figure 3 for an example of patch compliance status for the Standard HP-UX bundle.

Figure 3 Patch Compliance Status

In this example, Server Automation reports that the compliance status for the Standard 
HP-UX QPK bundle is “2 of 258 rules out of compliance.” The total number of patches within 
QPK bundle is 259. SA determined that one patch in this bundle is not applicable to this 
managed server. Therefore, it reports compliance status only for 258 patches instead of 259 
patches.

SA also determined that two patches have superseded patches and that these superseded 
patches are installed on the server but not uploaded in the repository. Therefore, they are 
reported as out of compliance. 

Scan Failed The patch compliance scan was unable to run.

Scan Needed The patch compliance information needs to be 
collected or the compliance information may be 
inaccurate.

— Not Applicable The patch compliance information does not apply.

Table 3 Compliance Status for a Managed Server

 Icon Status Description
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Patch Installation

The patch installation process consists of two phases:

• Download Phase—This is when the patch is downloaded from Server Automation to the 
managed server. This phase is commonly referred to as staging.

• Installation Phase: This is when the patch is installed on the managed server. This 
phase is commonly referred to as deployment.

You can specify whether you want the installation to occur immediately after the patch is 
downloaded (staged) or you can schedule it to occur at a later date and time. Patch 
management also supports the need for best-effort installations of multiple patches by 
allowing you to specify that the patch installation process will continue even when an error 
occurs with one of the patches.

SA displays the name of the command that installs the patch. The SA Agent runs this 
command on the managed server. You can override the default command-line arguments that 
you want to perform the installation.

To optimally manage HP-UX patch installations, patch management enables you to manage 
server reboot options and pre- and post-installation scripts, simulate (preview) a patch 
installation, and set up email notifications to alert you about the status of the installation 
process. The Install Patch wizard guides you through the setup. See Figure 4.

Figure 4 Install Patch Wizard

Installation Flags

You can specify installation flags that are applied when an HP-UX patch is installed. 
However, Server Automation also uses default installation flags and requires that patches be 
installed with these flags. make sure that you do not specify any installation flags that 
override or contradict the default flags passed in by SA.
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Installing an HP-UX Patch
Before a patch can be installed on a managed server, it must be imported into SA and its 
status must be Available. Only system administrators who have the required permissions can 
install patches that are marked Limited.

You must have permissions to manage patches. To obtain these permissions, contact your 
system administrator. For more information, see the SA Administration Guide.

You can perform the installation by explicitly selecting patches and servers.

To install a patch on a managed server: 

1 In the navigation pane, select Devices ➤  Servers ➤  All Managed Servers 

2 In the content pane, select an HP-UX server.

3 From the Actions menu, select Install Patch. The first step of the Install Patch window, 
Servers and Server Groups, opens.

4 Click Next to advance to the next step in the Install Patch wizard.

5 From the list of patches, select the patch you want to install.

6 After you complete a step, click Next to advance to the next step. Before you click Start 
Job, you can return to a completed step to make changes by clicking on it in the list of 
steps.

7 When you are ready to launch the installation job, click Start Job.

After you launch the job, you cannot change its parameters, even if the job is scheduled to 
run at a later time.

Setting HP-UX Install Options
You can specify the following types of patch installation options:

• Perform the patch installation immediately after the patch is downloaded or at a later 
date and time.

• Do not interrupt the patch installation process, even when an error occurs with one of the 
patches.

• Use different command-line options to perform the installation.

To set these install options:

1 In the Install Patch window, click Next to advance to the Options step.

2 Select one of the following Staged Install Options:

— Continuous: Enables you to run all phases as an uninterrupted operation.

— Staged: Enables you to schedule the download and installation to run separately.

3 Select the Error Options check box if you want the patch installation process to continue 
even when an error occurs with one of the patches. By default, this check box is not 
selected.

4 In the Install Command text box, enter command-line arguments for the command that is 
displayed.

5 Click Next to go to the next step or click Cancel to close the Install Patch window.
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Setting Reboot Options

To minimize the downtime that server reboots can cause, you can control when servers will 
and will not be rebooted. You can adopt the vendor's reboot assignments, reboot a server each 
time a patch is installed on it, completely suppress all server reboots, or postpone reboots 
until all patches are installed.

When you are selecting reboot options in the Install Patch window, HP recommends that you 
use the HP-UX reboot recommendations, which is the “Reboot servers as specified by patch 
properties” option. If you cannot use the HP-UX reboot setting, select the single reboot option, 
which is the “Do not reboot servers until all patches are installed” option.

The following options determine whether the servers are rebooted after the patch is installed. 
These options apply only to the job launched by the Install Patch window. They do not change 
the Reboot Required option, which is on the Install Parameters tab of the patch properties 
window. Except for the first option, the following options override the Reboot Required option.

• Reboot servers as specified by patch properties

• By default, the decision to reboot depends on the Reboot Required option of the patch 
properties. The server is rebooted only once at the end. This is done to satisfy the patch 
dependency. In effect, the option works as the third option which is to not reboot servers 
until all patches are installed

• Reboot servers after each patch install

• Even if the Reboot Required option of the patch properties is not set, reboot the server. If 
multiple patches are installed, the server will be rebooted only once after all patches are 
installed.

• Do not reboot servers until all patches are installed

• If the Reboot Required option is set for some selected patches but not for others, the server 
is rebooted one time after all patches are installed. If the Reboot Required option is not set 
for any of the selected patches, the server is not rebooted.

• Suppress all server reboots

• Even if the Reboot Required option of the patch properties is set, do not reboot the server. 
(Because of vendor settings, some patches ignore the suppress option and force a reboot.)

To set reboot options:

1 In the Install Patch window, click Next to advance to the Pre & Post Actions step.

2 Select one of the Rebooting Options.

3 Click Next to go to the next step or click Cancel to close the Install Patch window.

Specifying Install Scripts

For each patch, you can specify a command or script to run before installation or after 
installation. A pre-install script, for example, could check a certain condition on the managed 
server. If the condition is not met or if the pre-install script fails, the patch is not installed. A 
pre-install script could also be used to shut down a service or application before it is patched. 
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A post-install script could be used to perform a certain cleanup process on the managed 
server. You can also specify the following types of scripts to run on the managed server before 
or after an installation or download phase:

• Pre-Install: A script that runs before patches are installed on the managed server.

• Post-Install: A script that runs after patches are installed on the managed server.

To specify a pre-install script:

1 In the Install Patch window, click Next to advance to the Pre & Post Actions step.

2 Select the Pre-Install tab. You may specify different scripts and options on each of the 
tabs.

3 Select Enable Script. This option enables the remainder of the fields on the tab. If 
Enable Script is not selected, the script will not run.

4 Select either Saved Script or Ad-Hoc Script.

5 A Saved Script was previously stored in SA with the SAS Web Client. To specify the script, 
click Select.

6 If the script requires command-line flags, enter the flags in the Command text box.

7 Specify the information in the User section. If you choose a system other than Local, enter 
the User Name, Password, and Domain. The script will be run by this user on the 
managed server.

8 To stop the installation if the script returns an error, select the Error check box.

9 Click Next to go to the next step or click Cancel to close the Install Patch window.

Scheduling a Patch Installation

Because the two phases of patching can be decoupled, you can schedule when you want 
patches installed (deployed) to occur independently of when patches are downloaded (staged).

To schedule a patch installation:

1 In the Install Patch window, click Next to advance to the Scheduling step.

By default, the Scheduling step displays only the scheduling options for the install phase. 
If you selected Staged in the Install Options step, the scheduling options for the download 
phase are also displayed.

2  Select one of the following Install Phase options:

— Run Task Immediately: This enables the system to perform a preview analysis in 
the Summary Review step. The scheduling option for the download phase is Run 
Immediately Following Download.

— Run Task At: This enables you to specify a later date and time that you want the 
installation or download performed.

3  Click Next to go to the next step or click Cancel to close the Install Patch window. A 
scheduled patch installation can be cancelled (prior to its execution), even if the patch 
download has already completed.
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Setting Up Email Notifications

You can set up email notifications to alert users when the download and installation 
operations complete successfully or with errors.

To set up email notifications:

1 In the Install Patch window, click Next to advance to the Notifications step.

2 To set the notification status on the success of a Job, select the icon. To set the notification 
status on the failure of a Job, select the icon. By default, the Notification step displays 
only the notification status for the installation phase.

3 Enter a Ticket ID to be associated with a Job in the Ticket ID field.

4 Click Next to go to the next step or click Cancel to close the Install Patch window.

If you previously selected Staged in the Install Options step, the Notifications pane displays 
notification options for both the download and installation phase

Previewing a Patch Installation

The installation preview process provides an up-to-date report about the patch state of 
servers. The installation preview is an optional step that lets you see what patches, either 
single patch or patches part of standard HP-UX bundle, will be installed on managed servers 
and what type of server reboots are required. This preview process verifies whether the 
servers you selected for the patch installation already have that patch installed. In some 
cases, a server could already have the patch installed if a system administrator manually 
installed it, which means that SA does not know about it.

The preview process also reports on dependency information, such as patches that require 
certain HP-UX products, and patches that obsolete other patches or are obsoleted by other 
patches. If a dependency is not met, SA displays an error message indicating this condition.

To preview a patch installation:

1 From the Install Patch window, click Next to advance to the Summary Review step.

2 Verify the information displayed for the Servers, Server Groups, and Patches at the top of 
the window.

3 (Optional) Click Preview to see the separate actions that will be performed when the 
patch is installed. To view the details of a previewed action, select a row in the table. See 
Figure 5.

4 Click Start Job to launch the installation job or click Cancel to close the Install Patch 
window without launching the installation.

If you selected Run Task Immediately in the Scheduling step, the job begins now. If you 
selected Run Task At, the job will be launched at the specified time and date.
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Figure 5 Patch Installation Preview

Viewing Job Progress

You can review progress information about a patch installation (job), such as whether actions 
completed or failed.

To display job progress information:

1 From the Install Patch window, click Next to advance to the Job Progress step. This starts 
the installation job.

The Progress bar and text indicate how many of the actions listed in the table were 
completed. For each server, the following actions can be performed:

— Analyze: SA examines the patches needed for the installation, checks the managed 
servers for the most recent patches installed, and determines other actions it must 
perform.

— Download: The patch is downloaded from SA to the managed server.

— Install: After being downloaded, the patch is installed.

— Final Reboot: If this action is specified in the Pre & Post Actions step, the server is 
rebooted.

— Pre/Post Install/Download Script: If this action is specified in the Pre & Post 
Actions step, a script is run before or after the uninstallation.

— Install & Reboot: When a patch will be installed is also when the server will be 
rebooted.
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— Verify: Installed patches will be included in the software registration.

2 To view additional details about a specific action, select the row in the table to display the 
start and completion times of the job. In the navigation pane, select Jobs and Sessions to 
review detailed information about the job.

3 Click End Job to prevent the job from running or click Close to close the Install Patch 
window.

Patch Uninstallation

Uninstalling HP-UX patches and bundles is not supported in this release. To uninstall an 
HP-UX patch and bundle from a managed server, you must directly uninstall the HP-UX 
patch and bundles from the managed server.
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