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Documentation Updates

The title page of this document contains the following identifying information:

¢ Software Version number, which indicates the software version.

o Document Release Date, which changes each time the document is updated.

o Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go
to:

http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign in. To register for an HP Passport
ID, goto:

http://h20229.www2.hp.com/passport-registration.htmi
Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.

Page 4 of 92 HP Network Node Manager iSPI Performance for Metrics Software (9.11)



Online Help

Support

Visit the HP Software Support Online web site at:
http://www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and support
that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed to manage your business. As a
valued support customer, you can benefit by using the support web site to:

o Search for knowledge documents of interest

o Submit and track support cases and enhancement requests
o Download software patches

« Manage support contracts

e Look up HP support contacts

¢ Review information about available services

¢ Enterinto discussions with other software customers

o Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.htmi
To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp
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Disclaimer for PDF Version of Online Help

This document is a PDF version of the online help. This PDF file is provided so you can easily print
multiple topics from the help information or read the online help in PDF format.

Note: Some topics do not convert properly to PDF, causing format problems. Some elements of
online help are completely removed from the PDF version. Those problem topics can be
successfully printed from within the online help.
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Welcome to the Network Performance Server

The Network Performance Server (NPS) enhances NNMi's network management capabilities by
introducing a foundation for network performance management.

With the infrastructure provided by the NPS, you can use add-in products like the NNM iSPI
Performance for Metrics (NNM iSPI Performance for Metrics) to view context-specific reports
that help you understand performance bottlenecks in the network.

At the core of the foundation provided by the NPS is the column-based database management
system (DBMS), which enables you to effectively store, access, and track the network
performance data.

Different extension packs introduced by NNM iSPI products add rules and definitions to the NPS
deployment to generate reports. These rules and definitions, enable the business intelligence
component—the Bl Server—to generate rich and elaborate reports.

Related Topics:
Launching Reports

Documentation Conventions

Documentation Conventions

The HP Network Node Manager i Software Smart Plug-in documentation uses the following
conventions:

Symbol Meaning

%nnminstalldir¥e | Windows only. The environment variable for the NNMi application directory.
This variable is automatically created by the NNMi installer. If you install the
NNM iSPI on an NNMi (Windows) management server, all application files
of the iSPI are placed here.

%nnmdatadir% Windows only. The environment variable for the NNMi data directory. This
variable is automatically created by the NNMi installer. If you install the
NNM iSPI on an NNMi (Windows) management server, all the data and
configuration files of the iSPI are placed here.

%NPSInstallDir% | Windows only. The NNM iSPI application directory. When you install the
iSPI on the NNMi management server, the iSPI installer uses
%nnminstalldir¥% as the application directory for the iSPI.

%NPSDataDir% | Windows only. The NNM iSPI data directory. This directory contains all the
configuration and data files used by the NNM iSPI. When you install the
iSPI on the NNMi management server, the iSPI installer uses
%nnmdatadir% as the data directory for the iSPI.

On Linux, the NNM iSPI installer directly installs the necessary files into the following directories:
o Application files: /opt/0V

o Data and configuration files: /var/opt/0ov
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Administration Overview

The NNMi administrator is also an administrator for the NNM iSP| Performance. The NNM iSPI
Performance accommodates one administrator at a time. This restriction avoids conflicts and
satisfies OEM licensing requirements. Since administrator permissions are broad, and potentially
hazardous in the wrong hands, anyone with administrator access to the HP NNM iSPI Performance
for Metrics Bl Server Portal must be familiar with Bl Server tutorials and Bl Server documentation.

To run a report, or to access the ad hoc query features available from the HP NNM iSPI
Performance for Metrics Bl Server Portal, you must be logged on to NNMi. When you launch NNMi,
use the Fully-Qualified Domain Name (FQDN). This way of launching NNMi enables a security
function known as Single Sign-On (SSO). When SSQO is enabled, you need not log on a second time
when you move from NNMi to a report.

Overview of NPS Operations

This section contains background information, procedures for maintaining the NPS, and information
about tasks that may be necessary from time to time.

Bl Server Documentation

To access the Bl Server documentation, on the HP NNM iSPI Performance for Metrics Bl Server
Portal click BHelp.

Information About Commands

On the NNMi console, click Help > NNMi Documentation Library :> Reference Pages to open
a list of command links. On Windows, many of the commands listed on this page are Start menu

options. Click the link to open a reference page. The reference page provides the following
information about each command:

¢ Name

Synopsis

o Description

e Author

Location of Program and Runtime Files

Network Performance Server (NPS) consists of static application software files and dynamic
runtime files.

The default path for static application software is:

e Windows: C:\Program Files (x86)\HP\HP BTO Software
e Linux: /opt/0OV

The NNMPerformanceSPI directory contains the following folders:

e bin

o config

e Docs
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o extensionpacks

¢ Installation

e java

e L1ON

o lib

The default path for the dynamic runtime files is:

e Windows: C:\ProgramData\HP\HP BTO Software
e Linux:/var/opt/0ov

The performance of NPS depends on the 1/0O performance of the disk subsystem where this
directory resides. We strongly recommend that this data location is hosted on a high-performance
file system, such as alocal multi-disk RAIDO/S array.

The NNMPerformanceSPI directory contains the following folders:

e contentstore

o database

¢ nnmappfailover

e L10ON

e logs

o PerfSPI_Diagnostics

¢ rconfig

e Component_Health: Only if NNM iSPI Performance for Metrics is installed.
o Interface_ Health: Only if NNM iSPI Performance for Metrics is installed.

The above folders are placed by the default NPS installation. Additional folders may be present if
additional extensionPacks (for example, Metrics customPoll, or Traffic extensionPacks) are
present.

Tables and Data Dimensions
NPS uses the following kinds of data tables to store data:
o Aggregate
e Live
¢ Archive tables

The BI Server automatically picks the appropriate table based on the selected granularity of the
data and its time span.

o If you are looking for data with one hour grain and above, it picks the aggregate table

o If you are looking for data less than one hour grain and within last two days it picks the live table
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o If you are looking for data less than one hour grain and more than two days ago it picks the
archive table

The retention period for data in the aggregate table and the live table is not configurable; the
retention period for archive data table is configurable. The default retention period for archive data is
14 days. To adjust the default, use the Configuration Utility.

Increasing the retention of detail data enables longer online access to the fine-grained data, which is
useful for forensic network analysis. However, this approach requires more disk space and
computing resource when querying.

Each table is partitioned. Each partition is stored in multiple files, and the file format is proprietary. A
measure, sometimes referred to as a fact, is a numeric value stored in a table. Every measure is
defined in terms of multiple dimensions. For example, bytesin is a measure. Without context, for
example, without an interface and a time period, this measure has no meaning. Each table is
defined by multiple dimensions.

Data Retention Defaults
Data retention varies from table to table. Retention per-table is as follows:
e The live table retains data for 1 day
o The aggregate table retains data for 70 days
o The detail archive table retains data for 14 days

If you want to modify the default detail archive retention, use the Configuration Ultility.

Single Sign-On Security (SSO)

Network Performance Server (NPS) enables you to use a security function known as Single Sign-
on (SSO). SSO allows NPS to recognize the same usernames and passwords that the NNMi
Console recognizes. When SSO is enabled, a user who is already logged in to NNMi can move
from NNMi to a report without having to log in again.

For SSO to operate, the following conditions must be met:
e The NNM system and the NPS system must be configured with fully qualified domain names.

o The user must use the fully-qualified domain (not "localhost" or the machine name without the
domain) when launching the NNMi console.

A fully-qualified domain name (FQDN) has the following format:
http://<fully-qualified-hostname>/nnm

If the user launches NNMi using an unqualified host name, the SSO servlet will open a login
window and force the user to log in again.

Note: If the address, or the domain, of the NNMi management server or the NPS system changes
after you install NPS, you should re-run the enablement script on NNMi. Rerunning the enablement
script configures NNMi with updated location information.

Direct Access to the NPS

You can access NPS directly, without going through NNMi, by pointing your browser at:
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http://<fully-Qualified-serverName>:9300/PerfSpi/login

When the login window opens, enter the same username and password you use to launch NNMi.
After you are authenticated, the NPS Home Page opens.

Monitoring the NPS Processes
NPS includes reports that enable you to monitor NPS processes.
To view the available reports:
1. Loginto NPS.
2. Inthe NPS Home Page, click the Reports tab.
3. Select Self Monitoring > Self diagnostics > DiagnosticMetrics.

See Self Diagnostics for details
Scheduling Reports
To schedule a report:

1. Logintothe HP NNM iSPI Performance for Metrics Bl Server Portal.

2. Open the report folder that contains the report you want to schedule.
3. Under the Actions column, click the k& Schedule icon.
The Schedule form opens.
4. Inthe Frequency field, select one of the following options:
a. By Day
b. By Week
c. By Month
d. By Year
e. By Trigger
5. Select a start date and time.
6. Select an end date and time.

7. Click OK.

For more information about each of these actions, see IBM Cognos 8 Administration and Security
Guide.

Tip: To open the IBM Cognos 8 Administration and Security Guide, click Help in the Schedule
form.

Setting Thresholds for Metrics in NNMi

Until you set the thresholds for the extension pack metrics, the reports in that extension pack do not
track exception counts.

NNMi does not set thresholds for performance metrics for you, automatically. You must set the
thresholds for the NNM iSPI Performance for Metrics metrics manually using the Thresholds
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Settings form.in NNMi console. The following list shows some of the metrics for which you can set
the thresholds:

e Discardratein

¢ Discard rate out

o Errorratein

o Error rate out

o Utilization in

o Utilization out

e CPU 5 second utilization
e CPU 1 minute utilization
¢ CPU 5 minute utilization
¢ Memory utilization

o Buffer utilization

o Buffer miss rate

o Buffer failure rate

For information about how to set thresholds using the NNMi console see Configure Threshold
Monitoring for Interfaces (HP Network Node Manager iSPI Performance for Metrics Software) in
the HP Network Node Manager i Software Online Help: Help for Administrators.

Although you may want to see exception counts as soon as possible, setting thresholds right away
may not be feasible. This is because you may not be ready to set thresholds until you are better
acquainted with the way your network behaves. You need to know what is normal for your network,
and if you set thresholds prematurely, problems may arise. For example, if the thresholds are
wrong, NNMi may detect too many exceptions, and if you configure NNMi to generate incidents in
response to threshold conditions, NNMi may generate too many incidents.

Support for Application Failover

Application Failover for NNMi ensures redundancy. Failover allows a secondary NNMi server to
take over immediately following the failure of a primary NNMi server. Failover relies on jboss
clustering technology, ongoing file system synchronization, and a Java keystore file that must be
copied from NNM to the NPS. Copying the keystore file is a manual step.

The NPS supports NNMi Application Failover. From the perspective of anyone using the NPS,
Application Failover is a transparent event, for users as well as for the administrator. Aside from a
minor interruption in service lasting about 15 minutes while failover is in progress, users won't be
aware that a failover took place, and the administrator won't be required to perform any special
tasks related to failover.

The ability of the NPS to support application failover depends on files it retrieves from the primary
server in the cluster. The NPS retrieves these files during startup. As soon as the NPS has the
files, it begins monitoring the status of the primary server by checking for status changes every 5
minutes. If the NPS detects a status change, the following events take place automatically:
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e The NPS determines which server is the new primary server

o The NPS redirects data collection to a shared directory on the new primary server

o The NPS begins collecting data (metrics and topology files) from the new primary server in the

cluster

Immediately after these events take place, NPS users will be able to link from the NPS to NNMi
views on the new primary server, just as they were able to do before failover.

Messages Related to Failover

The following table provides alist of INFO, WARN, and ERROR messages that pertain to
Application Failover.

Condition Message Comments
Failovernot | DEBUG: NNM Logged every 5 minutes if the DEBUG logging is enabled
enabled Application Failover is
not enabled.\n
Failover INFO: NNM Logged every 5 minutes
enabled Application Failover is
enabled. Checking if
active node has
changed.\n
Failover INFO: NNM Logged every 5 minutes. Displays current NNM hostname
enabled Hostname currently being used by the NPS.
used by NPS is:
$nnm_current\n
Failover INFO: Logged every 5 minutes. Displays NNM hostname reported
enabled $getNNMActiveScript | as the active node in the cluster.
reports active nnm
node is: $nnm_
active\n
Failover INFO: Active NNM Logged every 5 minutes.
enabled but | host is unchanged.\n
the active
host has not
changed.
Failover INFO: Changing NPS | A configuration update is imminent. This message is logged
enabled configuration to use only when the active node is different from the node
$nnm_active\n currently used by the NPS.
Failover INFO: Configuration Logged after the configuration file is successfully updated in
enabled and | updated. Path to response to an application failover.
config files NNM is now
successfully [ $newpath\n
updated
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Condition Message Comments

Failover WARN: NNM If the NPS is running on the same machine as NNN, the

enabled but | Application Failoveris | path does not contain the hostname.

the NNM not supported on

hosthame is | same-system

not in the NNM/NPS

path syntax [ installations\n

Failover WARN: Cannot The user may have specified the path in a non-conventional

enabled but | extract remote nnm way (for example, by using a hard mount or drive mapping).

the NNM hostname from value | If the path does not contain the remote NNM hostname, the

hosthame is | of PRSPI_NNMDIR NPS will not be able to detect application failover.

not in the ($cfg{PRSPI_

path syntax [ NNMDIR})..\n

Failover WARN: Expected The user may have specified the path in a non-conventional

enabled but | PRSPI_NNMDIR of | way (for example, by using a hard mount or drive mapping).

the NNM form If the path does not contain the remote NNM hostname, the

hostname is | /net/hostname/var... | NPS will not be able to detect application failover.

not in the or

path syntax | //hostname/PerfSpi\n

Failover ERROR: nnm_ This message is logged is there is no copy of nnm_

enabled but | details.xml not found | details.xml on the remote NNM machine. This condition will

the nnm_ in $newpath occur if the nnmenableperfspi script was not run on that

details.xml machine, since running the script is what creates the nnm_

file is not details.xml file. This condition could also occur if the

available. machine configurations are not identical. For example, if the
pathnames to the shared drive are not identical, the new
path will be incorrect when the NPS substitutes the new
hostname into the path. The configurations must be
identical.

Failover ERROR: Unable to The NPS configuration will not change; a file permissions

enabled but | modify timestamp of | erroris preventing the nnm_detail.xml file from being

there is afile | $newpath/nnm_ modified on the NNM server.

permissions | details.xml: $!.

error

Failover ERROR: Unable to Failure to update the config file could be caused by another

enabled but | write changes to process that is locking the config file.

unable to config file. Will try

update the again next time.\n

config file.

Prerequisites for Successful Application Failover

Application Failover support will not succeed unless the following prerequisites are met:

1. Every installation of NNMi is set up and configured the same way.

2. Youran the NPS enablement script on every server in the cluster.
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3. Youresponded to enablement script prompts exactly the same way each time you ran the
enablement script.

4. Oneach server, you established the same path to the datafiles folder.

5. You copied a certificate (a java keystore file) from NNM to the NPS.
Copying the Keystore File from NNMi to the NPS

To copy the shared certificate file—cluster . keystore—from NNMi to the NPS:
1. Navigatetothe cluster. keystore file on NNMi:
s Windows: N\nmDataDir%\shared\nnm\conf\nnmcluster\cluster.keystore
m Linux: /var/opt/0V/shared/nnm/conf/nnmcluster/cluster.keystore
2. Copy cluster.keystore to the following directory:
s Windows: $NnmDataDir%\NNMPerformanceSPI\nnmappfailover\keystore
m Linux: /var/opt/OV/NNMPerformanceSPI/nnmappfailover/keystore

The keystore is used to enable access to the NNMi cluster. We recommend using a secure copy
mechanism, for example, SCP or USB key.

Backup and Restore

The NPS provides you with command-line tools to back up and restore all the NPS data.

To Back Up the NPS Data:
1. Log ontothe NPS system with the same account that was used to install the NPS.

2. Run the following command:
On Windows: %NPSInstallDir% \NNMPerformanceSPI\bin\backup.ovpl -b <dir>
[-c] [-d] [-f] [-V]
On Linux: %NPSlInstallDir% /NNMPer formanceSPI/bin/backup.ovpl -b <dir> [-
cl [-d] [-f] [-V]

In this instance, <dir> is the location where you want to place the backed-up data. Do not use
%NPSiInstallDir% or %NPSDataDir% with this option.
Options

¢ Usethe —c option to back up contentstore.
o Usethe —d option to backup the database.
¢ Use the - £ option to backup all NPS files.
o Use the -v option for verbose output.

You must specify a valid directory location as an argument of the -b option. If you do not specify
any other options, the backup script by default backs up contentstore and the database.

The duration of the backup process depends on the size of the database you want to back up.
Before you start the backup process, verify the disk space used by the data that you want to back
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up, and then make sure the system has as much available free disk space. Although the script
produces compressed output, the backup process requires sufficient temporary disk space.

To Restore the NPS Data:

1. Logontothe NPS system with the same account that was used to install the NPS.

2. Run the following command:
On Windows: %NPSInstallDir%\NNMPerformanceSPI\bin\restore.ovpl -b
<file> [-Vv]
On Linux: %NPSiInstallDir% /NNMPerformanceSPI/bin/restore.ovpl -b <file>
[-v]

In this instance, <file> is the backup file that you want to restore. You can use the -v option for
verbose output. The restore operation overwrites all the preceding NPS data.

Note: If you change the password of the database after a backup operation, you have to change it
again after restoring the backed-up database.

Configuring the Network Performance Server (NPS)

If you install NPS on the NNMi management server, NPS configuration takes place automatically
during the installation.

If you install NPS on a dedicated server, you must use the Configuration Utility to specify
configuration details. During installation, the Configuration Utility opens and asks you necessary
configuration details. After installation, you can anytime launch the utility to change the
configuration data.

Launching the Configuration Utility

Windows
Select Start > All Programs > HP > NNM iSPI Performance > Configuration Utility
Linux

1. Navigate to the following directory:
/opt/0OV/NNMPerformanceSPI/bin

2. Type the following command:
./runConfigurationGUI.ovpl

Using the Configuration Utility

Specify the following configuration details:

User Account Details
Not required when you install the NPS on an Linux system and NNMi is installed on a UNIX or
Linux system.

The Configuration Utility enables you to specify the details of the system user account that enables
the NPS to run necessary services.
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o If youinstall the NPS on the NNMi management server (Windows), you must set this to the
Local System account.

o If youinstall the NPS on a dedicated Windows system, you must select the Named User
account option.

Make sure you specify exactly the same account information that was used with the enablement
script on the NNMi management server.

Path to the NNM iSPI Performance for Metrics datafiles folder
Specify the location of the NPS data files on the NNMi management server.

o If youinstall the NPS on the NNMi management server, alocal path is displayed in this field,
which you must not change.

o If youinstall the NPS on a dedicated server, the enablement script creates a shared space on
the NNMi server.

In this field, you must specify the location of shared space in the correct format.

Hourly Data Retention Period (days)
Specify the aggregate table retention period.

o The default retention period is 70 days

e The maximum retention period is 400 days

Detailed Data Retention Period (days)

Specify the archive table retention period.
o The default retention period is 14 days

o The maximum retention period is 400 days

Use the Stop and Start buttons to stop and start necessary NPS processes.
To make any of these changes to configuration parameters:

1. Click Stop.
2. Make your change.
3. Click Apply.
4. Click Start.
5. Click Exit.

Master Configuration File: NNMPerformanceSPI.cfg

The master runtime configuration file, NNMPerformanceSPI.cfg, controls the operation of the NNM
iSPI Performance for Metrics. The path to this file is:
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Windows

$NnmDataDir%\NNMPerformanceSPI\rconfig

Linux

/var/opt/OV/NNMPerformanceSPI/rconfig

Configuration Item Setting

The following table indicates the default setting for each parameter in the file.

Configuration Item Setting

Log level

DEBUG

Location of NNM staging area

C:\ProgramData\HP\HP BTO
Software\shared\perfSpi\datafiles

Location of PRSPI_INSTALLDIR

C:\Program Files\HP\HP BTO
Software\NNMPerformanceSPI

Location of PRSPI_DATADIR

C:\ProgramData\HP\HP BTO
Software\NNMPerformanceSPI

Location of PRSPI_BIN

C:\Program Files\HP\HP BTO
Software\NNMPerformanceSPI\bin

Location of PRSPI_JAVA

C:\Program Files\HP\HP BTO
Software\NNMPerformanceSPI\java

Location of PRSPI_SAMPLES

C:\Program Files\HP\HP BTO
Software\NNMPerformanceSPI\samples

Location of PRSPI_LIB

C:\Program Files\HP\HP BTO
Software\NNMPerformanceSPI\lib

Location of PRSPI_CONFIG

C:\Program Files\HP\HP BTO
Software\NNMPerformanceSPI\config

Location of PRSPI_LOGS

C:\ProgramData\HP\HP BTO
Software\NNMPerformanceSPI\logs

files.

Place hourly data in the delivery area for True
consumption by the HP PI Datapipe.
PRSPI_HTTP_PORT 9300
Check poller records and suppress if Enabled
invalid.

Number of copies of deployed cubes to 3

keep before deleting.

Retention period for old datasource fact 96 hours
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Configuration Item Setting

Retention period for archived lodfiles.

336 hours (2 weeks)

Retention period for archived NNM files.

336 hours (2 weeks)

one batch.

Retention period for archived topology files. | 96 hours
Retention period for near real time data 6 hours
Retention period for summary data 70 days
Retention period for HP Pl Datapipe data 5 days
Buffer for late arriving facts (hours after 2 hours
midnight).

Number of NNM metrics files to process in | 12

Location of cognostr_bin_dir

C:\Program Files\HP\HP BTO
Software\nonOV\cognos\cer5\bin

Location of cognosbi_bin_dir

C:\Program Files\HP\HP BTO
Software\nonOV\cognos\c8\bin

Location of cognos_dispatcher_host localhost
Location of cognos_dispatcher_port 9300
Location of cognos_dispatcher_dir \p2pd\servlet\dispatch

Location of perl_dir

C:\Program Files\HP\HP BTO
Software\nonOV\perl\a\bin

Location of java_dir

C:\Program Files\HP\HP BTO
Software\nonOV\cognos\c8\bin\jre\1.4.2\bin

Location of test data PRSPI_TESTBIN

C:\Program Files\HP\HP BTO
Software\NNMPerformanceSPNTESTBIN

Location of test data PRSPI_TESTDATA

C:\Program Files\HP/HP BTO
Software\NNMPerformanceSPINTESTDATA

Location of PRSPI_TESTSTAGING

C:\Program Files\HP\HP BTO
Software\NNMPerformanceSPINTESTSTAGING

Location of PRSPI_TESTDATA _
BASEFILES

C:\Program Files\HP\HP BTO
Software\NNMPerformanceSPNTESTDATA _
BASEFILES

PerfSPI Extension Packs

InterfaceHealth
ComponentHealth

PerfSPIDiagnostics
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Note:

o The behavior of the InterfaceHealth extension pack is controlled by: InterfaceHealth.cfg

o The behavior of the ComponentHealth extension pack is controlled by: ComponentHealth.cfg
file

Checking the Validity of NNM iSPI Performance for Metrics
Configurations

You can verify proper configuration of the NPS by launching the Configuration Checker. The
Configuration Checker verifies the validity of the configuration file entries and displays the following
message if all the entries are valid:

INFO: Configuration File Validated OK

Launching the Configuration Checker
Windows
Select Start > All Programs > HP > NNM iSPI Performance > Configuration Checker
Linux
1. Navigate to the following directory:
/opt/OV/NNMPerformanceSPI/bin
2. Type the following command:
./checkConfig.ovpl
Collecting Diagnostics for Support

If you want to collect diagnostic data for Support, run the Diagnostics Collector utility. Support will
use the data you supply to diagnose the problem.

Launching the Diagnostics Collector
Windows
Start > All Programs > HP > NNM iSPI Performance > Diagnostics Collector
Linux

1. Navigate to the following directory:
/opt/OV/NNMPerformanceSPI/bin

2. Type the following command:
./collectDiagnostics.ovpl

After collecting data, the Diagnostics Collector saves the output in the form of a compressed
tar. gz file in the following location:

Windows:
%NPSDataDir%\HPNNMPerformanceSPI\collectDiag

Linux:
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/var/opt/OV/HPNNMPerformanceSPI/collectDiag
Forward the tar . gz file from the collectDiag folder to Support.

Resetting the NPS

The reset utility enables you to do the following:

o Delete all data from database and keep all archived data.

o Delete all data from database and restore archived data for re-processing.

¢ Delete all data from database and delete all archived metrics/topology.

o Delete all data from database, delete all archived data and log files, and then restart all services.
Launching the NPS Reset Utility

Windows

Select Start > All Programs > HP > NNM iSPI Performance > Reset Utility

Linux

1. Navigate to the following directory:

/opt/OV/NNMPerformanceSPI/bin

2. Type the following command:

./resetSPI.ovpl

The Reset Utility window opens displaying the following options. Select an option.

T Reset Utility - O] x

all data from database, & keep all archived data
all data from databaze, & restore archived data for re—processing
all data from databasze, & delete all archived metrics- topology
all data from database, delete all archived data and logfiles, & resta
all szervices
Enter Option <1-4>, or @ to guit: _
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Retrieving Last Logon Information for a User

Network Performance Server (NPS) enable you to find out the user logon information by using the
following log file:

Windows
%NPSDataDir%\NNMPerformanceSPI\logs\perfspiAudit.log
Linux
/var/opt/OV/NNMPerformanceSPI/logs/perfspiAudit.log
Whenever a user logs in to NPS, the following information gets recorded in this log file:
¢ Username
e Logon date
e Logontime
Analyzing Log Files
Use the Log File Analyzer to view:

o A daily summary of errors, warnings, and other notifications produced by each process within
each extension pack

« Timing data for selected processes belonging to each extension pack
« Timing data for generating reports for different extension packs

The Log File Analyzer tool analyzes the prspi.logand Per£SPI Diagnostic
Metrics.logfiles.

Launching the Log File Analyzer
Windows
Select Start > All Programs > HP > NNM iSPI Performance > Log File Analyzer
Linux

1. Go to the following directory:
/opt/OV/NNMPerformanceSPI/bin

2. Type the following command:
./log_analyzer.ovpl

Warnings, Errors, and Other Notifications in NNM iSPI Performance for
Metrics Log Files

The summary data for warnings, errors, and other notifications covers the previous two weeks. The

last summary covers today. Today's summary will be incomplete until midnight. Summary data
indicates:

e Date

o Number of errors per process, if any

Page 28 of 92 HP Network Node Manager iSPI Performance for Metrics Software (9.11)



Online Help
Administration Overview

o Number of warnings per process, if any
« Number of processes with fatal errors, if any
For example:

prspi.20080729.1log:

WARN - 240 in ETL.Component Health
WARN - 268 in ETL.Interface Health
WARN - 285 in MainServiceLoop

ERROR - 2 in MainServiceLoop

prspi.20090915.10g:

WARN - 27 in ETL.Interface Health

WARN - 714 in MainServiceLoop

FATAL - 1 in Utility.startBI

FATAL - 152 in ETL.Interface Health

FATAL - 1 in Utility.installExtensionPack

A warning normally indicates a transient condition, usually a temporary mismatch, that will self-
correct. If you see a warning message or a fatal error message, you may want to examine it in more
detail by viewing the associated logfile in a text editor.

The last log in the list of logs is today's partially complete log. Today's partially complete log does
not have a date attached to it. The file name for today's log is just this: prspi.log

Viewing Timing Data

Under the summary of all warnings and errors, if you press Enter, you can continue to see the
timing data.

The timing data shows:
o Total number of times a process executed over the previous two weeks
o Average execution time per process over the previous two weeks and standard deviation
o Maximum execution time per process over the previous two weeks
o Average number of records processed per execution
o Average number of records processed per second
Monitoring Log Files

The log file viewer is Chainsaw 2.0. With Chainsaw, you can monitor DEBUG, INFO, WARN,
ERROR, and FATAL messages as they reachthe prspi . logfile. Theperfspi.logfile
contains every message generated since the last night at midnight. The pathto prspi.logis:

Windows
%NPSDataDir%\NNMPer formanceSPI\1logs
Linux

/var/opt/OV/NNMPerformanceSPI/logs

Launching the Log File Monitor

Follow these steps to launch the log file monitor:
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Windows

To open the log file monitor, select Start > All Programs > HP > NNM iSPI Performance > Log
File Monitor

Linux
1. Navigate to the following directory:
/opt/OV/NNMPerformanceSPI/bin
2. Type the following command:

./runChainsaw.ovpl

Using the Chainsaw Message Interface for NNM iSPI Performance for Metrics

The welcome page includes several tabs. To open the message interface, click this tab:
NNMPerformanceSPI/logs/prspi.log

The Chainsaw message interface opens, showing the following panes:

e Event pane

o Detail event pane

o Treelogger pane

The event pane changes constantly, displaying the most recent message, as it arrives in prspi.log.
This pane also displays additional information about that message in the detail event pane. The
detail event pane indicates the following:

o Level

o Logger

e Time

e Thread

e Message

e NDC [null]

o Class [not used]
o Method [not used]
e Line

« File

o Properties

o Throwable [not used]

If you select an older message in the event pane, the detail event pane will refresh with additional
information about the message you just selected. The logger tree pane shows the following folder:

Root Logger
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The ETL folder, which belongs under the Root Logger folder, contains three loggers folders; one for
each standard extension pack. If additional extension packs are installed (such as custom poll
packages), additional loggers appears (one additional logger for each new package).

New messages generated by the loggers appear once in every few seconds in the event pane. If
you want to see messages for one logger only, type that logger name inthe Refine focus on
field. For example:

Refine focus on: Interface Health

You may expand the event pane by closing the logger tree pane and the detail event pane.
Following is a partial list of Chainsaw version 2.0 features:

¢ Fully customize each tab the way you want it
o Control the frequency of updates

o Specify your own rules for color-coding events (the defaults are yellow for WARN, red for
ERROR)

o Apply simple filters, or advanced expression-based filters
e Save memory by setting a cyclic-based view that looks at X events only
For more information about Chainsaw, run the tutorial under the Help menu or visit:

http://logging.apache.org/chainsaw/quicktour.html

Enabling Demo Data

The demo database is part of NPS. The NPS installation places the demo database on the system.
If you want to view reports using the demo data, you must enable the demo database.

Enabling the demo database does not disrupt any the ongoing data collection process of the NPS.
When you disable the demo database, NPS begins building reports using the real network data.

Launching Demo Data Enable Utility
Windows
Select Start > All Programs > HP > NNM iSPI Performance > Demo Data Enable.

To disable the demo database, select Start > All Programs > HP > NNM iSPI Performance >
Demo Data Disable.

Linux
To enable the demo database:

1. Navigate to the following directory:
/opt/OV/NNMPerformanceSPI/bin

2. Run the following command:

./demoData.ovpl enable

To disable the demo database:

Page 31 of 92 HP Network Node Manager iSPI Performance for Metrics Software (9.11)



Online Help
Administration Overview

1. Navigate to the following directory:
/opt/OV/NNMPerformanceSPI/bin

2. Run the following command:

./demoData.ovpl disable

HP NNM iSPI Performance for Metrics Bl Server Portal

Use the HP NNM iSPI Performance for Metrics Bl Server Portal to perform the following tasks:
o Open Public Folders and access reports from Bl Server Connection.
« Open My Reports and view reports with various filter preferences that you saved.

o Set up the following preferences:
= Set up the display parameters for the reports.

» Select the report format

= Set up a schedule for running summary reports.

= Set up email report delivery.

= Modify Bl Server tuning parameters for large multi-user installations.
= Select language and time zone for your reports

o Create custom reports using Query Studio.

Launching the HP NNM iSPI Performance for Metrics Bl Server
Portal

To launch Bl Portal:

1. Log on to Network Performance Server (NPS). You must have administrator privileges to
access the HP NNM iSPI Performance for Metrics Bl Server Portal.

2. Onthe navigation panel on NPS Home Page, click Bl Server.
The Bl Server Log On page opens.

3. Login using the ErsAdmin username and password. The default password is
rooDkcaBnimdAsrE.

We recommend you to change this password after you log in to Bl Portal for the first time. For
information about how to change this password, see IBM Cognos 8 Administration and
Security Guide.

Optionally you can start the HP NNM iSPI Performance for Metrics Bl Server Portal using the
following method:

Web Access: !

TPoint your browser at:
http://<localhost>:9300/p2pd/NPS

When the login page opens, type your ErsAdmin username and password
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Logging in to the HP NNM iSPI Performance for Metrics Bl Server
Portal as ErsAdmin

If you are unable to launch NNMi, you can still reach the HP NNM iSPI Performance for Metrics Bl
Server Portal by pointing your browser at this address:

http://<localhost>:9300/p2pd

When the login page opens, type your ErsAdmin username and password. The default password for
the this user account is rooDkcaBnimdAsrE.

We recommend changing this password once you log on to Bl portal for the first time using the
ErsAdmin username. Restart Bl portal with the new password after you change the default
password. For information about how to change passwords in Bl Portal, see /BM Cognos 8
Administration and Security Guide.

If you face problem launching NNMi, you need to contact support.

If you can open the HP NNM iSPI Performance for Metrics Bl Server Portal, you can confirm that
Bl Serveris running.

Change Report Format Using HP NNM iSPI Performance for Metrics
Bl Server Portal

The default report format used by the Network Performance Server (NPS) and Bl Server is the web-
based HTML format.

You can set the HP NNM iSPI Performance for Metrics Bl Server Portal Preferences and enable
NPS to generate reports in any of the following formats:

o Adobe PDF

¢ Microsoft Excel 2007

¢ Microsoft Excel 2002

o Microsoft Excel 2000 Single Sheet

e Comma Separated Value (CSV) Files
e XML

To change the format of the reports generated by NPS:

1. Loginto NPS Home Page. You must have administrator privileges to perform this task.

2. On the navigation panel, click the Bl Server tab.

3. Select the Bl Portal link.

4. Inthe HP NNM iSPI Performance Bl Portal form, click m My Area.

5. Select My Preferences.

1Displayed as Delimited Text (CSV)in NNM iSPI Performance for Metrics Bl Server Portal

Page 33 of 92 HP Network Node Manager iSPI Performance for Metrics Software (9.11)



Online Help
Administration Overview

6.

In the General tab, select a Report Format. The default format is HTML.

7. Click OK.

The new report format becomes the default report format for your user account. Bl Portal applies the
new report format to all the reports generated from your user account.

Schedule Report Delivery

From the HP NNM iSPI Performance for Metrics Bl Server Portal, you can schedule the generation
and delivery of reports. You can create schedules to email or print a report, or you can save the
report on the NPS system once in every interval. You can modify the default settings of reports
when you create schedules.

NNM iSPI Performance for Metrics enables only the administrators and level2 users to schedule
the reports. Only those NNMi users, who are part of administrators or level2 user groups can
schedule the reports using HP NNM iSPI Performance for Metrics Bl Server.

Users who belong to level1 user group can not schedule reports. NPS does not allow the level1
users to schedule reports using HP NNM iSPI Performance for Metrics Bl Server.

Follow these steps to allow the level1 users to schedule reports:

1.

Loginto HP NNM iSPI Performance for Metrics Bl Server using the Bl administrator or
ErsAdmin privileges.

On the HP NNM iSPI Performance for Metrics Bl Server page, click on Security and then
select Capabilities.

Select Scheduling.

Use the Permissions tab to change the user group permissions.

Use one of the following procedures to create a schedule:

Use the Report Templates suitable for scheduling

1.
2.
3.

© ® N o

Log into NPS Home Page.

On the navigation panel, click the Bl Server tab.
Select the Bl Portal link.

On the HP NNM iSPI Performance for Metrics Bl Server Portal, select an extension pack. The
list of reports provided by the extension pack appears.

Select the Report Templates suitable for scheduling link.

The Report Templates suitable for scheduling form opens displaying the list of report templates
that you can use to create scheduled reports.

Select a report template.
Select the Time Controls for your report.
Select either Confirm Selection or Next.

Select the required Topology Filter for your report.

Page 34 of 92 HP Network Node Manager iSPI Performance for Metrics Software (9.11)



Online Help
Administration Overview

10.
11.
12.

Select either Confirm Selection or Next.
Select the required Report Options.

Select either Confirm Selection or Finish.

Use the Schedule icon on Bl Portal

1.
2.
3.

10.

1.

12.

13.

Log into NPS Home Page.

On the navigation panel, click the Bl Server tab.
Select the Bl Portal link.

On the HP NNM iSPI Performance for Metrics Bl Server Portal, select an extension pack. The
list of reports provided by the extension pack appears.

Select a report, and then click Ez Copyon the toolbar.
Select Scheduled folder, and then click EPaste on the toolbar.

Copy the reports in My Folders, if you want the scheduled output to be restricted only to your
account. If you want the scheduled output to be available to all users, create a new folder (for
example, Public Scheduled Reports) under Public Folders, and then copy the reports there
before scheduling. You must have administrative privileges to create and modify the Public
Folder content.

Follow these steps to create a folderin HP NNM iSPI PerformanceBl Portal.

Under Actions column click E'Set properties .

Specify a name for the report, and then click OK.

On the Schedule page, make the following selections:
= Frequency: Select a frequency of your choice. The report generation will be scheduled with
the frequency specified in this section.

= Start: Specify the start time and date of the schedule.
= End: Specify the end start and date of the schedule.

In the Options section, select the Override the default values option, and then specify the

following details:

= Formats: You can choose one or more formats from the HTML, PDF, and Microsoft Excel
formats. The CSV and XML formats are not supported.

= Delivery: You can print the report, email the report, or save the report on the NPS system. If
you select email as the delivery mechanism, you must configure the Bl Server with an email
server.

In the Prompt values section, select the Override the default values option, and then click
Set.

Click OK.
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If you want to use the NPS to email reports, you must configure the Bl Server to use an SMTP
email server.

To configure the Bl Server to send emails:

1.

Launch the Bl Server Configuration GUI.

On Windows:
%NPSInstallDir’%s\NNMPerformanceSPI\bin\runBIConfigGUI.ovpl

On Linux:
lopt/OV/INNMPerformanceSPI/bin/runBIConfigGUl.ovpl
In the Explorer pane, select Notification.

Specify appropriate values for the following fields:
= SMTP Mail server

= Account and password

» Default Sender

To test the connection, right-click Notification in the left pane, and then click Test.
Click File > Save.

Select Yes when prompted to restart the service NNM iSPI Performance BIServer.

Setting the Same Schedule for Multiple Reports

You can set the same schedule for multiple reports by creating a job. A job identifies a collection of
reports, report views, or queries that are scheduled together and share the same settings.

To set the same schedule for multiple reports:

5.

& New Job icon on the toolbar.

Click the £
The New Job wizard opens.

Specify a name and location for the job.

In the Select the steps - New Job wizard form, click Add... to add the job steps.

You can submit the steps in sequence or all at once. To modify the sequence of steps, click
Modify the sequence... and then rearrange the sequence of steps.

In the Select an action - job form, specify whether you want to save and run, schedule, or only
save the new job.

Click Finish.

Create Custom Reports with Query Studio

With the Query Studio feature of the HP NNM iSPI Performance for Metrics Bl Server Portal, you
can create custom reports with the metrics from all available extension packs. You can combine
metrics from all available extension packs while creating a custom report.

Note: HP does not offer any support for custom reports.

To create new reports using multiple extension packs:
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1. Loginto Network Performance Server (NPS).

2. Onthe NPS Home page, click Bl Server tab in the left navigation panel.

w

To enable Query Studio reports display data in a time zone different from the server time zone,
specify your time zone using the Set Preferences form.

Select Query Studio.
Select an extension pack. For example, All ExtensionPacks.

Select time range for your report.

Select a topology group for your report.

® N o o &

Add topology context to your report.

NPS displays all topology attributes from all installed extension packs. However, not all
topology attributes are applicable to metrics from all extension packs. If you point the mouse
arrow over a topology attribute, a tool tip appears and shows the extension packs that support
that attribute.

9. Select a metric for your report.

10. Format the report with the toolbar in the work area.
11. Save the report.

Make sure that you save the report in the My Folder or any other customized location. Do not
save the reports made via Query Studio in any of the extension pack folders.

12. You can view the report when you log on to the HP NNM iSPI Performance for Metrics Bl
Server Portal.

Avoid using IBM Cognos 8 Bl Report Studio to create or customize NNM iSPI Performance
reports. HP does not provide support for reports made or customized using IBM Cognos 8 Bl
Report Studio

Note: For more information on how to use Query Studio, you can use the following Bl Server
documents:

o Query Studio Quick Tour
o Query Studio User Guide

Overview of Custom Poller Configuration
Available only with the NNM iSPI Performance for Metrics.

After the 30-day evaluation period, you can view reports based on Custom Poller collections only if
you obtain a license for the NNM iSPI Performance for Metrics.

NNMi's Custom Polling feature enables the NNMi administrator to take a proactive approach to
network management by gathering additional device information using SNMP MIB variables.

For example, an NNMi administrator might want NNMi to monitor the Status of COM
(communication) ports on all of your Windows servers.

Using Custom Poller, the NNMi administrator can also configure NNMi to do the following:
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¢ Send incidents when certain MIB values are detected
o Map returned MIB values to States and include these States as part of node Status calculations.
The NNMi Custom Poller feature enables network operators to:

o View the list of topology nodes for which additional information is being polled as well as the
name of the associated Policy.

« View the polling results. The first time the results for a specified MIB variable are discovered, the
results appear in a Polled Instance object. The Polled Instance object is updated whenever a
change in State is detected and includes the most current polled value that caused the State to
change.

« View incidents that are generated by Custom Poller for a MIB Poll Variable.

You can use the data collected by Custom Poller collections to construct and view reports if you
use the NNM iSPI Performance for Metrics.

Overview of Custom Poller Collections and Their Associated Policies

Custom Poller Collections ]

Define “What information” you want to gather,

{Choose a MIB variable, and, if necessary, F a
MIB Filter Variable.) £ —~ 1]
Custom Poller Policy (1)

Define "How™ MMM reacts to the gathered data.

{ \ Define “Where (which Node Group)™

: MMM gathers this extra information.
Generate Incidents Include State changes
that alert aperators in calculations far the

i “When"
to certain situations? source Mode's Status? Defing the logic.af

MMM collects this extra infarmation.

. * Triggered by a related MIB variable's
Map Roliad valizas fo Stafea by deining relﬁ?ned varue (a MIB Filter VYariable

threshalds and/or comparison mappings? valug)?

\ / * Based on a time interval?

HHNMI automates the response
to any detected problem.

Incidents that alert your team.

Hode “Status™ changes to alert your team.

Note: See NNMi online help for more information on Custom Poller.

Reports for Custom Poller Collections

If you use the Custom Poller feature of NNMi, you can configure the NNM iSPI Performance to
create reports based on the data collected by NNMi's Custom Poller. The Report Groups tab in the
Custom Poller Configuration form enables you to generate reports from the metrics obtained from
Custom Poller collections.

The NNM iSPI Performance creates new extension packs to display reports generated from the
data collected by Custom Poller collections.
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Mechanism of Creating Additional Extension Packs

When you add a report group to the Report Groups tab, NNMi creates an extension pack for each
SNMP MIB table referenced in the Custom Poller collection. On the NPS Home Page, the
extension pack reflects the name of the SNMP MIB table. Multiple Custom Poller collections are
combined into a single extension pack if the collections use OIDs from the same MIB table.

Custom Poller Report Controls

You can use the standard report control links to access Time Controls, Topology Filter, Report
Options and Adjust Time Range filters. You can search using any of the available attributes and
set filters to create a report based on the modification.

Time Control

On the navigation panel of NPS Home Page, click the Time Control tab to change the default time
filters for a report.

Time Control Filters

Filter Usage

- Click the drop-down calendar box and select the appropriate date.
By default, the date is automatically set to the current date when you select the Time
Range.
- To set the time manually, select the Hour/Minutes/Meridian options separately, and
X then select the value by clicking the arrow.
By default, the time is automatically set to the current time when you select the Time
Range.
Time Click the drop-down menu to display the list of time ranges, and then select the
Range | appropriate time.
If you select a time range that is beyond the Start Date and Time, the following
message appears:
Your start date/time is out of range. It will be adjusted.
Click OK to adjust accordingly.
Auto Click the drop-down menu, and then select the desired time to recreate the reports
Refresh | based on the set interval.
By default, the Auto refresh is OFF.
The Auto Refresh option appears on the Time Controls page only after the first report
is generated.

Topology Filters

On the navigation panel of NPS Home Page, click the Topology Filters tab to launch the Topology
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Selector.

The Topology Filter enables you to quickly find or select an element from the topology table using
selection mechanisms appropriate for the attribute type.

Attributes and Related Parameters Available for the Topology Filters

Attribute
Parameter

Node Contains the list of the available Node groups in the network.

Group

Name

Node Contains the list of the available Node name in the network.

Name

Node Contains the list of the available Node Contact in the network.

Contact

Node Contains the list of the available Node Location in the network

Location

Node Contains the list of the available Node Families in the network.

Family

Node Contains the list of the available Vendors in the network.

Vendor

Node ID | Contains the list of the available Nodes ID in the network.

Node Contains the list of the available Node UUID in the network.

UulD

Index Contains the list of the available Index in the network. This field contains the SNMP
index OID values that identify specific MIB table instances polled by Custom Poller
policies; if you want, you can use these SNMP index OID values to filter Custom
Poller reports to show only specific instances from the MIB table (use in conjunction
with the NodeName filter).

Report Options

On the report, click on the Options link to access the Report Options panel.

Report options provide a list of primary and secondary metrics for the selected Custom Poller
extension pack.

Note: The metrics drop-down list differs according to the selected extension pack.

Create Extension Packs for Custom Poller Collections

To create an extension pack for a Custom Poller Collection, you must create a report group for a
Custom Poller Collection from the NNMi console.
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Prerequisite: You must log on to the NNMi console with the administrative privilege.

Task 1: Create a Custom Poller Collection

Create a Custom Poller Collection in the Custom Poller Configuration form by following the
instructions in NNMi Help for Administrators.

Task 2: Create a Custom Poller policy

Create a Custom Poller policy in the Custom Poller Configuration form by following the instructions
in NNMi Help for Administrators.

Task 3: Create an extension pack for a Custom Poller Collection

1.

Navigate to the Custom Poller Configuration form.

a. From the workspaces navigation pane, select the Configuration workspace.
b. Select Custom Poller Configuration.
In the Custom Poller Configuration form, go to the Report Groups tab.

Click + New. The Report Group form opens.

In the Report Group form, specify a name for the extension pack in the Basics section. Do not
use spaces in the name.

In the Report Collections tab, click ] New. The Report Collections form opens.

To add a Custom Poller Collection to the report group, click - Eﬁ v (the Lookup icon):
= To specify a Custom Poller Collection, click == @uick Find... |Quick Find.

: : '{EINEW
= To create a new Custom Poller Collection, click New.

Set the Report Data Type to one of the following values:

= Gauge: Represents single non-cumulative values. Examples of Gauge data types include
Response Time, Bit Rate, and Temperature. During aggregation, the NNM iSPI
Performance for Metrics calculates the minimum, maximum, and average values of gauge
metrics.

= Percent: Represents single non-cumulative values that are formatted with a percent sign
(%) and two decimal places. Examples of Percent data types include Utilization and
Discard Rate. During aggregation, the NNM iSPI Performance for Metrics calculates the
minimum, maximum, and average values of percent metrics.

= Counter: Represents incremental values. Examples of Counter data types include byte
counts, packet counts, and flow counts.

In the Report Collections form, click Save and Close.

In the Report Group form, click Save and Close. The NNM iSPI Performance for Metrics
creates a new extension pack and adds a new tab on the Report Menu page.

Guidelines to Create Custom Poller Extension Pack
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e You can associate a Custom Poller Collection to only one report group.

o If you associate more than one Custom Poller Collection with the same Report Group, make
sure the combination of Collections generates a meaningful report. As a general guideline, select
Collections whose MIB Variables represent the same index value across Custom Poller
Collections.

« Avoid using keyboard symbols while naming the Custom Poller collection and customPoll OID.
If you still use the following symbols <,>,”,’ , &, \, they are replaced by a ! character in the
report.

o Reports are not created if the # symbol is used in a customPoll name.

Remove Custom Poller Extension Packs

If you want, you can remove the extension packs. The NNM iSPI Performance provides you with
command line tools to remove Custom Poller extension packs.

To remove Custom Poller extension packs:

1. Log on with the administrative or root privileges to the system where the NNM iSPI
Performance is installed.

2. Gotothe following directory:
»  On Windows: %NPSinstallDir%\NNMPerformanceSPI\bin

s OnUNIXorLinux: /opt/OV/NNMPerformanceSPI/bin

3. Run the following command to view the list of extension packs:
uninstallExtensionPack.ovpl

4. Run the following command:
uninstallExtensionPack.ovpl -p <extension_pack_name>

Note: You cannot recover the data associated with an extension pack if you inadvertently delete it.
Make sure to type the correct extension pack name with the command. Do not delete the
following default NNM iSPI Performance for Metrics extension packs unless you want to
remove NNM iSPI Performance for Metrics reports: Interface Health, Component
Health. If you delete the Per£SPI Diagnostics.extension pack, you will not be able
to monitor the health of the NPS processes.

Modifying Topology Attribute Values and Group Memberships from
NNMi
The topology attributes and groups help you filter the data and build the report with the data polled
from nodes and interfaces of your interest. The NPS retrieves the topology attribute details from

NNMi and other iSPIs. If you make modifications to topology attributes and group memberships
from NNMi, the changes are reflected in the NPS within about an hour.

Changes are not applied retroactively to the existing data. Changes are always forward-looking; the
NPS preserves the historical accuracy of the data ‘as it was’ when it was collected.

For example:
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o Ifanew node is added to a group, it is only added for the new data collected going forward. The
NPS cannot assume that the node was a member of the group in the past.

« If aninterface attribute changes—for example, ifSpeed is changed from old to new value, it is
only applied going forward. The NPS does not assume that the new speed applies to the
historical data.

If you delete or change a member of a topology attribute, the old member continues to appear in the
list of topology filters in NPS. The old attribute member continues to appear in the list of topology
filters. If you select the old member, the data that was collected before making the change gets
sampled in the report.

Example

If you modify the node group name A to B in the NNMi console, the new node name gets reflected in
NPS after at least an hour. Later on, the old node group name continues to appear in the list of Node
Groups in the Topology Filters section. However, when you select A, you cannot retrieved data
samples associated with A that are polled after changing the Node Group name to B.

For example, you might have an interface group called “Oracle Server Ports” identifying switch
interfaces assigned to your Oracle Server cluster, but now you have a new server cluster available
online, and you want to transfer your Oracle applications to the new one, and re-purpose the old
servers to host the Microsoft Exchange Server.

Therefore, you rename “Oracle Server Ports” to “Exchange Server ports” and create a new interface
group for “Oracle Server Ports” identifying the ports associated with the new servers. If you want to
run a report at the end of the month to see the health of your “Oracle Server Ports” and your new
“Exchange Server Ports” over the month, the NPS will define “Oracle Server ports" group to include
the data collected for the original ports up until the point you made the change, and for the new ports
after that point.

Similarly, the NPS will define the “Exchange Server ports” group to only include the ports from the
point the group was renamed—it does not include the ports while they were still being used for
Oracle.

Location of Program and Runtime Files

Network Performance Server (NPS) consists of static application software files and dynamic
runtime files.

The default path for static application software is:

e Windows: C:\Program Files (x86) \HP\HP BTO Software
e Linux: /opt/OV

The NNMPerformanceSPI directory contains the following folders:

e bin

« config

e Docs

o extensionpacks

o Installation
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e java

e L1ON

e lib

The default path for the dynamic runtime files is:

e Windows: C:\ProgramData\HP\HP BTO Software
e Linux:/var/opt/0OV

The performance of NPS depends on the I/O performance of the disk subsystem where this
directory resides. We strongly recommend that this data location is hosted on a high-performance
file system, such as a local multi-disk RAID0/5 array.

The NNMPerformanceSPI directory contains the following folders:

e contentstore

o database

e nnmappfailover

e L10N

o logs

e PerfSPI_Diagnostics

o rconfig

o Component_Health: Only if NNM iSPI Performance for Metrics is installed.
o Interface_ Health: Only if NNM iSPI Performance for Metrics is installed.

The above folders are placed by the default NPS installation. Additional folders may be present if
additional extensionPacks (for example, Metrics customPoll, or Traffic extensionPacks) are
present.

Setting Polling Characteristics in NNMi

Performance polling has an impact on NNMi and it also has an impact on your network. If you
enable additional performance polling, NNMi needs to allocate a portion of its resources to handle
the additional polling. Also, your network needs to accommodate an increase in SNMP traffic. To
use the system and network resources wisely, it is important to limit performance polling to the
devices you require the most.

By default NNMi enables performance polling for the following Node Groups:
o Network Infrastructure Devices
¢ Routers

The following are some of the ways you can modify the performance polling defaults that will be in
place right after the iSPI is installed:

o Set thresholds for a node group that you are already polling for performance data (no thresholds
are set by default).

« Modify the frequency of performance polling.
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o Add nodes to the Important Nodes group, and enable performance polling for this group.
« Enable performance polling for the Microsoft Windows Systems group.

All these processes involve monitoring configuration tasks. Monitoring configuration tasks are
related to polling.

For information about any of these processes, see HP Network Node Manager i Software Online
Help: Help for Administrators.

Setting Thresholds for Metrics in NNMi

Until you set the thresholds for the extension pack metrics, the reports in that extension pack do not
track exception counts.

NNMi does not set thresholds for performance metrics for you, automatically. You must set the
thresholds for the NNM iSPI Performance for Metrics metrics manually using the Thresholds
Settings form.in NNMi console. The following list shows some of the metrics for which you can set
the thresholds:

¢ Discardratein

¢ Discard rate out

e Errorratein

o Errorrate out

o Utilization in

o Utilization out

o CPU 5second utilization
e CPU 1 minute utilization
o CPU 5 minute utilization
o Memory utilization

o Buffer utilization

o Buffer miss rate

o Bufferfailure rate

For information about how to set thresholds using the NNMi console see Configure Threshold
Monitoring for Interfaces (HP Network Node Manager iSPI Performance for Metrics Software) in
the HP Network Node Manager i Software Online Help: Help for Administrators.

Although you may want to see exception counts as soon as possible, setting thresholds right away
may not be feasible. This is because you may not be ready to set thresholds until you are better
acquainted with the way your network behaves. You need to know what is normal for your network,
and if you set thresholds prematurely, problems may arise. For example, if the thresholds are
wrong, NNMi may detect too many exceptions, and if you configure NNMi to generate incidents in
response to threshold conditions, NNMi may generate too many incidents.
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Threshold Terminologies
« High Value (HV):"
« High Value Rearm (HVR):2
o High Trigger Count (HTC):3
e Low Value (LV):4
o Low Value Rearm (LVR):5
o Low Trigger Count (LTC):6
o Duration:’

« Duration Window 8

1Any value above this value is in the high range; any value in the high range triggers a High status.
2Any value below High Value; indicates that the High status has ended.

3The number of consecutive polls a high value must remain the same before the status changes to
High. A trigger count of 1 is usually appropriate.

4Any value below this value is in the low range; any value in the low range triggers a Low status.
5Any value above Low Value;indicates that the Low status has ended.

6The number of consecutive polls a low value must remain the same before the status changes to
Low. A trigger count of 1 is usually appropriate.

"The time limit before which the baseline metric state cannot change to Abnormal Range or
generate an incident. This time period specifies the minimum time within which the metric value
must remain out of the configured Baseline Range.

8The window of time in which the Upper Baseline Limt or Lower Baseline Limit criteria must be met.
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Integrating NNM iSPI Performance with Other iSPIs

The NNM iSPI Performance suite extends the capabilities of HP Network Node Manager i
Software (NNMi) by monitoring and analyzing the performance of your network. The NNM iSPI
Performance suite includes the following products:

o NNMiSPI Performance for Metrics
o HP Network Node Manager iSPI Performance for Quality Assurance Software
o HP Network Node Manager iSPI Performance for Traffic Software

Network Performance Server (NPS) provides you with the infrastructure and resources for the
NNM iSPI Performance products to generate network performance reports.

Baseline Metrics

The Network Performance Server (NPS) provides you the baseline metrics to define the normal
(expected) range of values for any given metric.

The baselines metrics enable you to forecast the future value for a given metric based on the
historical data. NPS derives the baseline values based on the following concepts:

o Seasonality
o [nitialization period2

o Adaptation Parameters3

Baseline Metrics Glossary

The baseline metrics compute the trends, seasonal patterns and time range deviations for all the
HP Network Node Manager i Software Smart Plug-in products. The following table lists the
baseline metrics:

1 Represents a periodic and repetitive pattern in the metrics utilization levels. The repetitive (cyclic)
nature of this pattern enables NPS to predict the future utilization values for the metric. The default
period for seasonality is one week with five minutes granularity.

2Represents the period during which NPS collects data required for calculating the baseline
metrics. NPS does not generate any exceptions for this period, considering the data range to be
insufficient to calculate a reasonable normal range. For example, if the initialization period is set as
four weeks, NPS does not calculate any baseline exception for these four weeks. After four weeks,
NPS calculates the normal ranges of metric values based on the data collected during these four
weeks.

The default initialization period for NPS is three weeks or three seasons. The default time range for
each season is one week.

3Represents the technique used to smooth the historical data for a given time range and forecast
the metrics value. NPS uses intercept, trend, and seasonal adaptation formulas to smooth the
historical data and calculate the forecast value.
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Metric Name Description

Baseline Average

Average value presenting the normal (expected)
range of utilization for the selected topology filter
based on the historical data

The NNM iSPI can analyze the following using this
metric:

e The actual utilization of the topology filter as
compared to the normal utilization ranges.

o Forecast the topology filter utilization for a
selected time range.

o ldentify the over-utilized and under-utilized
topology filters before they violate the thresholds.

Baseline Deviation

Deviation of the samples spread over a specific time
range.

Represents the extent of the range of values
normally seen for the selected time range in the
seasonal cycle, based on historical data.

The NNM iSPI can analyze the following using this
metric:

¢ Analyze the utilization pattern for the selected
topology filters over a selected time range.

o ldentify the utilization values that are lower or
higher than the mean utilization. This in turn
enables you to identify the over-utilized and
under-utilized topology filters.

Baseline Slope

Increase or decrease in the average utilization in one
day. Negative slope indicates a declining trend.

The NNM iSPI can analyze the following using this
metric:

¢ Identify any unexpected change in the topology
filter utilization.

¢ Avoid resource bottlenecks by identifying gradual
increase in resource utilization.

o Identify the point in a selected time range when
the resource utilization was the highest or lowest.
This enables you to derive a pattern in the
topology filter utilization.

Upper Normal Upper limit of the normal range for the sample. The
normal range for the sample may vary for every
NNMiSPI.
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Metric Name Description

NNMi supplies the upper normal value based on
values that you enter in the Threshold Configuration
form. You can disable the upper normal value if you
do not require to set the upper threshold for the
metric.

See HP Network Node Manager i Software Online
Help for Administrators for information about
Threshold Configuration form.

The value is calculated using the following formula:

Upper Normal = Baseline Average + (N1 * Baseline
Deviation)

Where N1 is the upper sleeve width

Lower Normal

Lower limit of the normal range for the sample. The
normal range for the sample may vary for every
NNMiSPI.

NNMi supplies the lower normal value based on
values that you enter in the Threshold Configuration
form. You can disable the lower normal value if you
do not require to set the lower threshold for the
metric.

See HP Network Node Manager i Software Online
Help for Administrators for information about
Threshold Configuration form.

The value is calculated using the following formula:

Lower Normal = Baseline Average - (N2 * Baseline
Deviation)

Where N2 is the lower sleeve width

Days to Threshold

Forecast for the topology filter utilization to reach the
upper or lower threshold limit.

Represents the number of days left for the utilization
to reach the threshold value.

NPS calculates this metric based on the following:
e Baseline Slope

e The static upper and lower thresholds defined in
NNMi Threshold Configuration form

Exception Count

Total number of sample counts that are marked for
an exception.
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Metric Name Description

NPS raises an exception for the metric if the a
certain number of samples within a sample window
are out of normal range.

For example, NPS raises a baseline exception if 7
samples out of a sample window of 10 samples are
beyond the upper normal range. You must configure
NNMi for the upper and lower normal ranges to
enable NPS to raise the exceptions.

If the topology filter utilization is between Upper
Normal and Lower Normal, the exception count is
set to 0 (Zero) for the selected sample.

If you disable the upper or lower normal thresholds in
NNMi, NPS does not raise exceptions for the upper
and lower normal ranges.

The NNM iSPI can analyze the following using this
metric:

o Analyze the performance of the selected topology
filter for a specific time range.

¢ Identify network performance problem if the
exception count is persistently high for the
selected time range.

Baseline Exception Rate Percentage of samples that has the exception flag
set.
Forecast Baseline (avg) Average value presenting the normal (expected)
4 week range of utilization for the selected topology filter
L]

based on the forecast data

* 8week The NNM iSPI can analyze the following using this
e 12week metric:
o The forecast utilization of the topology filter as
compared to the normal utilization ranges.
o Forecast the topology filter utilization for a
selected time range.
o Identify the over-utilized and under-utilized
topology filters before they violate the thresholds.
Forecast Upper Normal (max) Upper limit of the normal range for the forecast data.
4 K The normal range for the data may vary for every
o awee NNM iSPI.
o 8week
e 12 week
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Metric Name Description

Forecast Lower Normal (min) Lower limit of the normal range for the forecast data.
4 K The normal range for the data may vary for every

¢ awee NNM iSPI.

o 8week

e 12 week

Baseline Exceptions Generated by NNM iSPI Performance
Software

Network Performance Server (NPS) stores the records that are marked with baseline exceptions.
These records reflect only the most recent fact record for any affected component, interface, node,
or node group. These records reflect the average baseline exceptions for each of the metrics used
by an extension pack.

For individual samples the baseline exception is either represented as 0% or as 100%. The NNM
iSPI Performance software uses this table to perform the following tasks:

o Provide an interface to HP Network Node Manager i Software (NNMi). NNMi in turn creates
incidents for each interface that is marked with a baseline exception.

o Generate ad-hoc reports for the interfaces that are currently having baseline exceptions, thus
having any network health or performance problems.

Baseline Exceptions Used by NNM iSPI Performance for Metrics
Component Health
Baseline exceptions are enabled for the following metrics in the Component Health extension pack:
e Memory Utilization
o Buffer Utilization
o Buffer Miss Rate
o Buffer Failure Rate
o Buffer No Memory Rate
e CPU 1min Utilization
o CPU 5sec Utilization
¢ CPU 5min Utilization

Interface Health

Baseline exceptions are enabled for the following metrics in the Interface Health extension pack:
o Utilization In

o Utilization Out

e ErrorRate In
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e Error Rate Out
o Discard Rate In

o Discard Rate Out

Security Groups in Network Performance Server (NPS)

Security groups enable NPS to display topology groups and metrics based on your user access
level.

Security groups are created by NNMi administrators. They ensure that the reports display only the
data that is related to your user group. Every user group in NNMi is associated with a security
group. Security groups created in NNMi apply to all iSPIs.

Security groups enable NPS to:

o Filter the fact table queries for all report graphs/tables, including reports created using Query
Studio.

o Filter the dimension data queries used in topology filter prompts orin Query Studio.

o Filter group member queries used in topology filter prompts or in Query Studio. NPS does not
display data related to the groups, where none of the members have access to the report data.

NPS contains all performance data saved by NNMi and the iSPIs for various security groups. Only
NNMi administrators can access data saved for all security groups.

Example

This example uses NNMi's security configuration to divide the access to NPS data based on the
following locations:

o SiteA

o SiteB

Each location includes the following local users:

o Operator 1: This user can access data for only Site A

o Operator 2: This user can access data for only Site B

The following global users can access data from all locations

o Admin: The NNMi and NPS Administrator, handles both locations and can access NPS data
from all locations.

o Backup: The backup user for both Site A and Site B and must access the NPS data in both the
locations.

The following user groups ensure that the NPS access for each security group is restricted:

User

Account NPS User Group NPS Access Privileges

Admin NNMi and e Can access all NPS data irrespective of location
NPS Administrator
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e Can access all user group datain NPS

o Can add, modify, or delete NPS users and user groups
using NNMi console

e Canaccess NPS using the ErsAdmin user account

e Can access all report templates, schedule reports, and
define global report settings

Backup Level 2 Operator Can generate reports for both Site A and Site B
Operator | Level 1 Operator Can generate reports for only Site A

1

Operator | Level 1 Operator Can generate reports for only Site B

2

Once the administrator (Admin in this example) creates these user groups in NNMi, NPS ensures
that the access to NPS features and data are restricted based on the privileges defined for each
user group.

For more information on user groups and configuring user groups, see Configuring Security in HP
Network Node Manager i Software Online Help: Help for Administrators.

Custom Dashboard in NNM iSPI Performance for Metrics

NNM iSPI Performance for Metrics enables you to create dashboards based on multiple reportlets
from the same or different extension pack1 S.

Example

Let us consider a scenario, where you need to monitor the following:

o Hourly utilization of Interface A on Component X

o Average normal CPU utilization for Component X

o Number of days left for memory utilization to reach threshold

You can create a custom dashboard combining the following reportlets:
¢ Interface Health Heat Chart Report for the metric Utilization (avg)

e Component Health Simple Chart Report for the following metrics:
= Primary metric: Memory Utilization - Baseline Average (avg)

= Secondary metric:CPU 5min Utilization - Days to Threshold (min)

TExtension packs provide rules and definitions to generate reports from the data gathered from
different sources. The default, ready-to-use extension pack available with the NPS—the Self
Diagnostics extension pack—helps you view reports indicating the health and performance of
different components and processes of the NPS.
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Creating Custom Dashboard Using HP NNM iSPI Performance for
Metrics Bl Server Portal

To create a custom dashboard:
Step 1
Log in to Network Performance Server (NPS).

Step 2

Copy bookmarks for the reportlets that you need to include in your dashboard
To copy the bookmarks for the reportlets that you need to include in your dashboard:
1. Onthe NPS Home Page, click Dashboard Reportlets tab.
2. Select an extension pack!. For example, iSPI Metrics > Interface Health > InterfaceMetrics
3. Select areportlet. For example, Heat Chart reportlet
4. Click Show Bookmark.
5. Copy the bookmark and paste it in a text editor.

Repeat these steps for all the reportlets that you need to include in your dashboard.

Step 3
Create the dashboard using Bl Portal
To create the custom dashboard:
1. Onthe NPS Home Page, click Bl Servertab.
2. Select Bl Portal.
3. Select alocation for your dashboard. For example, My Folders
4. Click [E2l New Page.
5

. Inthe Specify a name and description - New page wizard form, specify the required information
about the dashboard.

TExtension packs provide rules and definitions to generate reports from the data gathered from
different sources. The default, ready-to-use extension pack available with the NPS—the Self
Diagnostics extension pack—helps you view reports indicating the health and performance of
different components and processes of the NPS.
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Hour f Day Filtars ~
Topology Filters Specify a name and location For this entry, You can also specify a descrip
BI Server Name:
Utilization Dashboard - Interface & on Cormponent x|
Bl Portal
Public Folders Description:
My Folders
Preferences
Query Studio [opens in new window)
Screen kip:
Location:
My Folders
Select another location. ..

Cancel Mext = Firish

6. Inthe Set columns and layout - New page wizard form, specify the following:
= Number of columns you require in the dashboard

= Width of the columns. For a multi-column dashboards, the columns must be of same width.
7. Inthe Set columns and layout - New page wizard form, click Add...
8. Select Cognos Utility.

9. Inthe Available entries column, select a utility. For example, to display multiple reportlets in
the dashboard, select HTML Viewer.

= Add to move the selected utilities in the Selected entries column.

10. Click
11. Click OK.
12. Click Next.

13. Inthe Set page style - New page wizard specify the title, style, and any instructions that you
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want the dashboard to display.

Avoid selecting the following options:
= Hidetitle bars

= Hide Edit buttons on the title bar

You need the Edit button on the title bar to complete creating the dashboard.

BI Server i
BI Portal
add a title and instructions which appear above the portlets on the page
Pukblic Falders
My Folders Title:
Frafarances Return bo defaulk » | Tahoma bt
Query Studie (epens in new windaw) Dashboard - Utilization of Interface A on
[ ] Hide title on the page
Instructions:
Return to default 3 | Tahoma b
[] Hide instructions on the page
Portlet style
[] Hide borders
L] Hide title bars | Awoid selecting any o
Dashboard Repartlets [] Hide Edit buttons on the title bar aptions.
Crass Launching
e
< > Cancel < Back Mext = Firish
14. Click Next.

15. Inthe Select an action - New page wizard form, select the required options and click Finish.

The new dashboard opens in the Edit mode.

Step 4

Edit the dashboard to display the selected reportlets
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To edit the dashboard:

1. Select any of the following tools:
. Edit in the title bar

= [ Editin the Actions column

2. Specify the content for the dashboard using the reportlet bookmark. For example, if you
selected HTML Viewer to view the dashboard reportlets, copy the bookmark you saved in the
text editor and paste it in the HTML content field.

3. Specify the height for the panel where Cognos displays the reportlet.
4. Click OK.
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Using Reports

The NPS generates reports on operational metrics over a selected period of time. The content of
these reports is defined in the core NPS reports, and is extended by installing additional NNM iSPIs
such as the NNM iSPI Performance for Traffic or NNM iSPI Performance for QA.

Some of the tasks that you can perform using NPS are:
o View the operational performance of metrics over a period of time.

« Modify the default settings of a report to view additional attributes related to the monitored
element.

o Customize dashboards with pre-defined reportlets.
o Customize the schedule and format for report delivery.
o Create customized reports using Query Studio.

Avoid using IBM Cognos 8 Bl Report Studio to create or customize NNM iSPI Performance
reports. HP does not provide support for reports made or customized using IBM Cognos 8 Bl
Report Studio

Launching Reports

You can launch reports created by the NPS or NNM iSPI products either from the NPS Home
Page, the HP NNM iSPI Performance for Metrics Bl Server Portal.

To launch a report from the NPS Home Page:
1. Log onto NPS using either the NNMi console or the NPS home page.

2. Onthe NPS Home Page, select Reports in the navigation panel.

NPS presents the default, ready-to-use Self Diagnostic extension pack (to generate reports on
the performance of the NPS itself). Depending on the number of the NNM iSPI Performance
products or extension packs available on the NPS system, you may see many other sets of
reports.

3. Select areport type (for example, Chart Detail or Heat Chart).
4. Modify the default report settings, if required.

Tip: On the NNMi Network Overview workspace, if you select a node, and then click Actions >
Reporting-Report Menu, the Report Menu page presents reports created with the data
collected from the selected node.

Note: If you want to navigate back to the NNMi console:

« Inthe NPS Home page navigation panel, click the Cross Launching tab.
o Click NNMi Links.
o Click NNMi Console.
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The NNMi Console link enables you to go back to NNMi workspaces based on the topology
objects currently selected in the NPS.

Launching Reportlets

You can launch Reportlets created by the NPS or NNM iSPI products either from NPS home page
(introduced by the NPS), or you can use the HP NNM iSPI Performance for Metrics Bl Server
Portal.

To launch a reportlet from the NPS home page:

1. Log onto NPS using either the NNMi console or the NPS home page.

2. Onthe NPS Home Page, select Dashboard Reportlets in the navigation panel.

NPS presents the default, ready-to-use Self Diagnostic extension pack (to generate Reportlets
on the performance of the NPS itself). Depending on the number of the NNM iSPI Performance
products or extension packs available on the NPS system, you may see many other sets of
reportlets.

3. Select areportlet type (for example, Exceptions Pie Chart or Simple Bar and Line Chart).
4. Modify the default reportlet settings, if required.

Tip: On the NNMi Network Overview workspace (available in Topology Maps workspace), if you
select a node, and then click Actions > Reporting-Report Menu, the NPS home page
presents Reportlets created with the data collected from the selected node.

Change Default Settings

NPS generates reports with a set of parameters, which are set when you launch a report from the
NPS home page or the NNMi console. Every NPS report or reportlet is built with the following sets
of parameters:

« Time controls:’

T tirr]e [olo] H’ols_belp you set the time range for the report or reportlet that you want to view. The
RPSESBYsE $l5res the data collected from different nodes over a period of time. By using the
time controls parameters, you can view a report or reportlet created for the range of time of your
thﬁhg)afbup:mnel§o select the display grain of a report or reportlet. When a report or reportlet is
rendered, the time range is always shown in the Filter Summary section at the top of the report or
reportlet.

2 The topology filters enable you to create a report that is filtered, or constrained in scope, by
specific topology attributes. By default, when you launch a report or reportlet for the first time from
the NPS Home Page, NPS generates the report or reportlet that is not filtered. However, you can
select a specific node or a set of nodes from the NNMi console (from the Topology Maps
workspace), and then launch the NPS Home Page to view reports or reportlets only on the selected
nodes. The topology filters extend this capability by offering a range of filters on the NPS home
page, which help you select the data to be included or excluded prior to viewing the report. When a
report or reportlet is rendered, the selected filters are always shown in the Filter Summary section at
the top of the report or reportlet.

3 Reports and reportlets display graphical and statistical representation of different operational
characteristics of the managed network. These characteristics are represented with metrics;
parameters that indicate the health and operational performance of the network. While every report
and reportlet opens with the default metric set, the Report Options Panel helps you generate the
report or reportlet with the metrics of your choice.
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Change Time Controls

When you launch a report from the Network Performance Server (NPS) Home Page, the report
shows the data collected over the selected time range; relative to the most recent data sample.

To change time controls:

1. Log onto NPS using either the NNMi console or the NPS home page

2. Inthe navigation panel, click Reports tab, select the extension pack, and select the report that
you want to view.

To modify the time controls for one of the most used reports, click My reports. For information
about how to save a report into My Folders location, see Saving a Report into My Folder.

3. Onthe navigation panel, click the Time Control tab.

4. You can change the following parameters:

Time Control Function

Relative Start Sets the start date for the reports based on the available data
B~ Changes the Start Date or Time for the Report

Time Range Changes the time range for the report

Display Grain Changes the display grain for the report

Auto Refresh Refreshes report data automatically

Time Zone Enables you to select a preferred time zone

Hour of Day Enables you to:

» Select the appropriate hour of the day from the list.

= Formultiple selections, select the appropriate hour from the list, and then hold down
hour.

Day of week Enables you to:
» Select the appropriate day of the week from the list.

» For multiple selection, select the appropriate day from the list, and then hold down C

Select All Enables you to select the available values from the list.

Deselect All Enables you to deselect the available values from the list.

5. Perform one of the following steps:
= Onthe Re[port Options panel, click Submit

= Onthe report, Confirm Selection
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If you are viewing the Time Control pane while launching the report from within Bl Server
Connection, you may see additional navigation buttons at the bottom of the screen. These
additional buttons enable you to move forward to the Topology Filters screen.

Button

Function

Cancel Click to cancel the report generation

Back Click to go back to the previous page of the report generation; if you are in the first
page the option will be disabled.

Next Click to move to the next page of the report generation

Finish Click to display the report for the selected filter.

Time Ranges with Default Display Grains

When you set a time range for a report, a predefined display grain is applied to the report. The
following table shows the mapping between the time ranges with the default display grains.

31 Days 1 Day

7 Days 1 Day

24 Hours 1 Hour
12 Hours 1/2 Hour
2 Hours 5 Minutes
1 Hour 5 Minutes
30 Minutes 1 Minute
15 Minutes 1 Minute
5 Minutes As Polled
1 Minute As Polled
Until Now Adjusted appropriately based on Start Date/Time

Your choice of display grain defines the data source for the reports.

The following three types of data sources exist within NPS:

¢ Internal Summary tables (data for up to 70 days)

o Internal Live tables (data for up to 1 day)

o Archive tables (data for up to ‘N’ days as set by the Configuration Utility)
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Using a display grain of 1 hour or above ensures your reports will source their data from the Internal
Summary tables. Using a display grain of less than 1 hour, combined with a Start Date/Time within
the last day, will result in the Live tables being used. Using a display grain of less than 1 hour,
combined with a Start Date Time prior to the last day, will force the NPS to use the Archive tables
to fulfil the query. In this last case, a waming message informs you that the report might be
relatively slower, as it must perform more expensive and time-consuming database query to
retrieve the data.

Related Topics

Time Ranges with Default Display Grains

Changing Default Settings

Special Scenarios

o Start Date/Time and Time Range extend beyond the available data: The Start Date and Time
automatically shift to allow the requested Time Range to be selected from the available data set.

o Start Date/Time requested is prior to the oldest data: If you request a Start Date/Time that is
prior to the oldest data in the NPS, the Start Date and Time shift to coincide with the oldest data
available. The Time Controls section notifies you of this after you make the selection.

o Start Date/Time is not on the boundary of the display grain: Graphs and charts always show
data grouped into sample sets—the sample size is defined by the display grain1 . If the Start
Date/Time is not on the boundary of a display grain-sized sample, results can look unusual. The
NPS always attempts to round down the Start Date/Time to the beginning of the nearest display
grain-sized sample.

For example: a Start Time of 12.15 am and a Time Range of 1 Day will have a default Time Grain of
1 Hour—resulting in 24 samples. However, the samples for the hour representing 12.00 will only
have data from 45 minutes and will appear unusually low. To correct this, the Time Control will
move the Start Date/Time back to begin at 12.00 am automatically.

Related Topics

Changing Time Controls

Time Ranges with Default Display Grains

Changing the Default Date/Time for Reports

To change the default date and time for reports:

1. Logonto NPS using either the NNMi console or the NPS home page.

2. Inthe navigation panel, click Reports and select the report that you want to view.

1The display grain defines how samples of data are grouped across the time range. For example, a
one hour chart with a display grain of five minutes displays 12 samples of data.
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To modify the topology filters for one of the most used reports, select a report from the My
Folders location. For more information on how to save a report into My Folders location, see
Saving a Report into My Folder.

3. Inthe navigation panel, click Hour / Day Filters.

4. Select the following:
= Inthe Hour of Day list, select a default time for the reports.

= Inthe Day of Week list, select a default date for the reports.
5. Click Submit.

Click Reset to cancel the selection.
Selecting Relative Start for Your Report

The Start Date/Time defines the point of origin of the report. The report shows the data collected
from the time and date specified in the Start Date/Time field.

To set relative start for your report:

1. Logonto NPS using either the NNMi console or the NPS home page.

2. Inthe navigation panel, click Reports and select the report that you want to view.
3. Inthe navigation panel, select Time Control.

4. Inthe Relative Start field, select Yes. By default, relative start is set to Yes.

5

In the Last field, select a time range for the report. For example, if you want to generate a report
based on last 31 days data, select 31 days in the Last field.

6. Select adifferent time grain if required.
7. Click Submit.

If you request a time range that is relative to the most recent sample of data, the NNM iSPI
Performance moves the Start Date/Time appropriately. In some cases, especially with a very
recent installation, this may result in a Start Date/Time that appears to be older than the start of the
first data collection interval.

Automatically Refreshing the Report Data

The report gets automatically refreshed with the fresh data samples if you select the auto refresh
rate with a relative start date and time.

For example, if you have selected Last 1 Hour as the Time Range, and 1 Minute in the Auto Refresh
field, the report displays the data samples collected in past one hour and refreshes this data every
minute. As aresult,if you generated the report at 12 pm, the report shows data from 11 am to 12 pm,
and refreshes the report data at 12.01 pm.

To automatically refresh the report data:

1. Log onto NPS using either the NNMi console or the NPS home page.

2. Inthe navigation panel, click Reports and select the report that you want to view.
3. Inthe navigation panel, select Time Control.
4

In the Relative Start field, select Yes. By default, relative start is set to Yes.
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5. Select the check box Auto Refresh.
By default, auto refresh is set to No.

6. Click Submit

Change the Start Date or Time for the Report

The Start Date/Time defines the point of origin of the report. The report shows the data collected
from the time and date specified in the Time Control section.

To change the start date or time for a report:

—_

Log on to NPS using either the NNMi console or the NPS home page

In the navigation panel, click Reports and select the report that you want to view.

In the navigation panel, select Time Control.

In the Relative Start field, select No.

In the Start Date/Time section, click on the Date box, and select the appropriate date.

In the Start Date/Time section, click on the Time box, and select the appropriate time.

N o o > 0D

Click Submit

NNM iSPI Performance adjusts the Start Date/Time automatically under the following
circumstances:

o Start Date/Time and Time Range extend beyond the available data:
o Start Date/Time requested is prior to the oldest data: 2

o Start Date/Time is not on the boundary of the Time Grain: 3

1 The NNM iSPI Performance moves back the Start Date/Time and selects the requested Time
Range from the currently available data set.

2 |f you request for a Start Date/Time that is prior to the oldest data in the system, the NNM iSP
Performance advances the Start Date/Time to coincide with the oldest data available.

The Time Control advises you of this when your data set begins.

3 NNM iSPI Performance reports always show data grouped into sample sets. The sample size is
defined by the Time Grain. If the Start Date/Time is not on the boundary of a Time Grain sized
sample, results can look unusual when displayed. To prevent this, the Time Control always
attempts to round down the Start Date/Time to the beginning of the nearest Time Grain sized
sample.

For example, a Start Time of 12.15 am and an Interval of 24 Hours will have a default Time Grain of
1 Hour; resulting in 24 samples. However, the samples for the hour representing 12.00 will only
have data from 45 minutes and will appear unusually low. To correct this, the Time Control will
move the Start Date/Time back to begin at 12.00 am automatically
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Change the End Date or Time for the Report

The End Date/Time defines the endpoint for the displayed data. The report shows the data collected
from the start time till the date specified in the Time Control tab.

To change the end date or time for a report:

1. Log onto NPS using either the NNMi console or the NPS home page

In the navigation panel, click Reports and select the report that you want to view.

In the navigation panel, select Time Control.

In the Relative Start field, select No.

In the End Date/Time section, click on the Date box, and select the appropriate date.

In the End Date/Time section, click on the Time box, and select the appropriate time.

N o o > w0 Db

Click Submit to generate the report for the time range ending on the date and time specified in
the End Date/Time.

NNM iSPI Performance adjusts the Start Date/Time automatically under the following
circumstances:

o End Date/Time and Time Range extend beyond the available data:"

o Time Range requested is prior to the oldest data: 2
Changing the Display Grain for the Report

The Time Grain defines how samples of data are grouped across the Time Range.

A 1 Hour chart with a Time Grain of 5 Minutes displays 12 samples of data. Adjusting the Time
Range automatically sets the Time Grain to a default value. However, you can adjust the Time
Grain manually using the navigation panel in NPS Home Page.

To avoid partial samples of data being grouped together, NNM iSPI Performance adjusts the Start
Date/Time value to the boundary of the default Time Range.

To change the default time grain for the reports:

1. Log on to NPS using either the NNMi console or the NPS home page

2. Inthe navigation panel, click Reports and select the report that you want to view.

3. Inthe navigation panel, select Time Control.

1 The NNM iSPI Performance moves back the End Date/Time and selects the requested Time
Range from the currently available data set.

2)f you request for a time range (time between the Start Date/Time and End Date/Time) that is prior
to the oldest data in the system, the NNM iSPI Performance advances the Start Date/Time and
End Date/Time to coincide with the oldest data available.

The Time Control advises you of this when your data set begins.
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4. Inthe Grain section, select a time grain for your report.
5. Click Submit

Your selection of Time Grain defines the data source for the reports. NNM iSPI Performance uses
the following types of data source:

o Internal Aggregate tables
o Intemnal Live tables?

e Archive tables

Changing the Default Time Zone for the Report

By default the reports are generated based on the NPS server's time zone. You can select a
different time zone while viewing or scheduling a report in the Time Zone field.

The NNM iSPI Performance uses the selected time zone to generate all subsequent reports.

The selected time zone overrides the time zone preferences associated to your user account.
However, if you set the time zone back to the default value, NNM iSPI Performance uses any of
the following time zones:

e Thetime zone set in your user account preferences. This overrides the NPS server time zone.
Follow any of these methods to change your default time zone:

= Using the Time Control tabin NPS Home Page

= Using the Bl Server Portal Preferences page. You must have the administrative privileges to
NPS

e Thetime zone used by the NPS server. If the you have not set any preference for time zone in
your user account, NNM iSPI Performance uses this option.

The Filter Summary (depicted by b4 icon) of each report displays the selected time zone unless
the effective time zone is the default NPS server time zone, known as "Server Time".

Tip: Select the default time zone, in case you generate reports in a large scale environment.
Selecting a different time zone than the "Server Time" (NPS server time zone) requires NPS to
convert the time stamps for the selected time zone while generating the report. This may
consume a lot of time if you have large volume of data.

1 Using a course time grain, that is of 1 Hour or above ensures your reports will source their data
from the internal Aggregate tables.

2Using a fine time grain (less than one hour) requires NNM iSP| Performance to analyze the volume
of live data in the database and set the table type accordingly.

If the start time requested is before the earliest live data then NNM iSPI Performance uses the
internal aggregate table as the data source.

Otherwise NNM iSPI Performance uses the internal live table as the data source.
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Set Topology Filters

Network Performance Server (NPS) generates reports created from different metrics that are polled
from different nodes, interfaces, and other network elements. If you want to modify the report to
contain data polled from selected network elements, use the Topology Filters section.

The Topology Filters tab enables you to filter and generate reports on network elements with
specific topology attributes.

All topology attributes shown in the list are obtained from NNMi or the collectors and pollers of
iSPIs in use. You cannot add new attributes or delete existing attributes from this list.

By default, NPS preserves the historical integrity of topology data such that any changes made to
topology attributes (such as Interface Speed, ifAlias values, and so on) are not retroactively applied
to the existing historical data, but only to new data.

To Change Topology Filters:

1. Log onto NPS using either the NNMi console or the NPS home page

2. Inthe navigation panel, click Reports and select the report that you want to view.

To modify the topology filters for one of the most used reports, select a report from the My
Folders location. For more information on how to save a report into My Folders location, see
Saving a Report into My Folder.

3. On the navigation panel, click Topology Filters.

4. Do one of the following for the topology attributes that you want to filter:

= If you want to select just one value for a topology attribute, click 21 Single Value Select,
and then select a topology filter.

= |f you want to select multiple values, click E= Multi value select, and then select the
topology filters (by using Ctrl-click or Ctrl+Shift).

= |f you want to search and select a value from a list of values, click IZxl Search and select.
5. Toapply different types of topology filters, click Apply, and then repeat step 3.

Clicking the Apply button suppresses the values from the other topology attributes that are
irrelevant in the context of your selection.

To discard your selection, click Reset.

6. Click Confirm Selection. The NPS generates the report based on the specified topology
attributes.

Note:

o Cookies are used to preserve your preferred method of selecting each topology filter. For
example, if you open a ‘single value selector’ for an attribute, the next time you run a report, the
single-valued selector will already be opened. Do not open more selectors than you routinely use
as they do add some overhead (extra time) to running the report.

o The Self Diagnostic tab displays reports on different NPS processes with the data collected
from the NPS server. Therefore, you cannot see any node or interface-related attributes in the
Topology Filters section of any Self Diagnostic reports.
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Tip: You can also select the option as displayed in the following image

Topology Filter

Attribute

MPLS YRF Name =] e
MPLS L3VPN Mame =) e
ModeGroup Mame OB

InterfaceGroup Mame 1 = EE g
Qualified Interface Name = E Ol

Interface Name DB Interface Mame =
Interface Alias DOEBE
Interface Descr DB
Interface Index D EBEG
Interface Type OB

Select this option to exclude an

Interface Physical Address_ & B2 (g object from the report.

Interface Speed (In:0ut) = E g

Interface ID DOEHBGE
Interface ULID =
Interface ODBID =] e
Mode Mame CDOEHBE
Mode Contact OB
Mode Location OB
Mode Farnily =] e
AT — = = e

]

if you want to exclude selected objects from the report.

Select Type 1 Topology Groups
Network Performance Server (NPS) generates reports based on the following two elements:
o Topology Filters
o Metrics?2

By default, when you create a topology group and generate reports based on the group, the report
displays only the data that are stored into NPS after the group was created. That is, by default,
NPS preserves the historical integrity of topology data such that a newly created topology group
does not filter the existing historical data, but only the new data. This default behavior is consistent

TEnable you to filter and generate reports on network elements with specific topology attributes.
The reports display the data polled from selected network elements
2 Enable you to determine the health and performance of the selected topology elements.
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. However, NNM iSPI Performance for Metrics now enables you to create a group of topology
elements and use it to generate reports that display the data that were stored into NPS before the
group was created.

Note: The term 'Type1' is borrowed from standard data warehousing terminology. Type 1 Slowly
Changing Dimensions describe the case where historical changes to dimensional/descriptive data
are ignored in favor of applying only the most current definition.

Example

The connectivity between the routers in Site A is suffering from high data loss percentage for past
one week. You need to check the routers with the highest volume of incoming and outgoing traffic in
this location. You create a node group for the routers in Site A and generate the Top N Report to see
the list of routers that have the highest volume of data passed through them. However, if you use
the traditional "NodeGroup Name" filter to apply the node group that you created today, you cannot
filter data that are older than today. This means, using the default "NodeGroup Name" filter, you
cannot display data that are older than the node group.

To resolve this problem, you can use the new "NodeGroup_Type1 Name" filter instead of the
traditional "NodeGroup Name" filter. Type 1 groups apply the most recent group definition to all the
historical data. In other words, reports generated based on Type 1 topology groups display all data
that match the most recent definition of the group irrespective of the age of the data. In the above
example, the report, if generated based on Type 1 node group, would display past one week's data.

To Select Type 1 Topology Group:
1. Logonto NPS using either the NNMi console or the NPS home page

2. Inthe navigation panel, click Reports and select the report that you want to view.
3. On the navigation panel, click Topology Filters.

4. Select a Type 1 group. For example, if you want to select a Type 1 interface group, select an
interface group for the InterfaceGroup_Type1 Name topology filter. Do one of the following for
the topology attributes that you want to filter:

= If you want to select just one value for a topology attribute, click E£1 Single Value Select,
and then select a topology filter.

= If you want to select multiple values, click B Multi value select, and then select the
topology filters (by using Ctrl-click or Ctrl+Shift).

= If youwant to search and select a value from a list of values, click £zl Search and select.

When launching reports from NNMi with a NodeGroup or InterfaceGroup selected, the default
behavior is to continue to use the traditional (Type2) "NodeGroup Name" or "InterfaceGroup
Name" filters in NPS. If you prefer to use the new Type1 filters, then you can use the Topology
Filters page to clear the existing filters and apply the "NodeGroup_Type1 name" or
"InterfaceGroup_Type1 Name" filters instead. The new Type1 groups are also available in the
Top-N reports as a element group-by option.

5. Toapply different types of topology filters, click Apply, and then repeat step 3.

3A standard data warehousing concept to describe the preservation of historical changes in dimen-
sional/descriptive data
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Clicking the Apply button suppresses the values from the other topology attributes that are
irrelevant in the context of your selection.

To discard your selection, click Reset.

6. Click Confirm Selection. The NPS generates the report based on the specified topology
attributes.

Note:

Cookies are used to preserve your preferred method of selecting each topology filter. For example,
if you open a ‘single value selector for an attribute, the next time you run a report, the single-valued
selector will already be opened. Do not open more selectors than you routinely use as they do add
some overhead (extra time) to running the report.

Change Report Options
The Options panel enables you to:
o Customize the report with additional options that vary for each report type.
o Select the metrics that are displayed on the report.
To change the report options:
1. Launch the report from the NPS navigation panel.

2. Click Options.

The Report Options panel for the report opens.

3. You can change the following settings:
n Metrics: Available only with Top N, Top N Chart, and Most Changed reports.A report
displays the metric, performance or utilization associated with the monitored element. Most
reports open with the data for a default set of metrics.

To change these default metrics use the Selected Metric(s) field.
To display only specific metric values, click W Apply Filter.

= Grouping By: Available only with select reports. In the Grouping By box, select an attribute
to define the grouping mechanism for the tabular data on the report.

o To select more than one attribute, click ‘{F_hl Add New Metric. A new Grouping By box
with the list of attributes appears.

o Toremove a grouping attribute, click P Remove Metric.

© Todisplay or hide the start date, start time or display grain for the report data, click i
Apply Filter.

= Top/Bottom N: Available only with the Top N and Most Changed reports. The Top/Bottom
N option helps you specify the number and order of data points for use with the Top N and
Most Changed reports.

= Display Time Series Chart:Available only with the Top N report. The Display Time Series
Chart option enables you to view the time series chart at the bottom of the Top N report.

4. Click Confirm Selection. The modified report appears.
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Note: NPS preserves your choice of metrics for a report. When you come back to the report in the
future, the metrics that you selected the last time will be automatically used as the default

metrics.

Reportlet Controls

The Dashboard Reportlet page enables you to modify the reportlet properties using the following

tools.

Filter Control Description

Eﬁ Displays or hides the reportlet control toolbar
w Displays or hides the following information:

o Start date for the data displayed

o Start time for the data displayed

o Display grain for the data displayed
T Displays or hides the Report Options panel.
Displays or hides the Add Bookmark panel.

Contextual Navigation

NPS adds contextual links on the report content to navigate to related reports. By clicking a
hyperlink on the report, you can navigate to related reports with the context of the original report.

The following table displays the different report types and contextual navigation available for each

of them:

Contextual Navigation

Report
Type Contextual Navigation Point
Calendar | X-axis; opens report links for reports with the same Date/time context and the same
primary metric.
Chart X-axis; opens report links for reports with the same Date/time context and the same
Detail primary metric.
Heat Chart | « Hour of Day Row Header; opens report links for reports with the same Hour of
Day filter of the selected row.
o Day of Month Header; opens report links for reports with the same Date/Time
filter of the selected row.
o Data cell value; opens report links for reports with the same Hour of Day filter of
the selected row and the same Date/Time filter of the selected date.
Headline X-axis; opens report links for reports with the same Date/Time context and the
same metric.
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Report
Type Contextual Navigation Point

Dashboard | e Interface name from the Top 10 utilization, Response Time, or Discard charts;
opens report links for reports with the same topology filter to selected interface
and the same metric.

¢ Needles of the Exception Count gauges; opens report links for reports with the
same metric.

TopN Object name (for example, interface name or node name); opens report links for
reports with the same topology filter.

Most Object name (for example, interface name or node name); opens report links for
Changed | reports with the same topology filter.

Note: You can launch a report from the same extension pack tab, or from a different extension pack
tab. If you launch a report from a different extension pack tab, only the relevant topology filters
are preserved. Since metrics typically vary between extension packs, the selected metric
cannot be transferred to the target report.

Cross Launching a Report or Reportlet

Where appropriate, the report or reportlet presents links to navigate to another related report or
reportlet. This feature enables you to refine your selection based on time, topology, or metrics that
are displayed on the report.

To cross launch a report or reportlet:

1. Click on the data point in the report or reportlet that launches another report or reportlet. For
example, you can click on a point of time in the X axis of the Chart Detail report to drill down to
the Heat Chart report displaying the metric performance for the hour selected.

2. Select the metrics for the drill-through report or reportlet.
NNM iSPI Performance saves your selection for the next session.

3. Select areport or reportlet from the navigation panel. The new report or reportlet displays the
selected metric.

For more information on the contextual navigation available for each report type, see
Contextual Navigation.

Examples

The following examples explain this behavior for different Interface Health reports:

o The Dashboard report for Interface Health shows a high availability exception count. Clicking on
the needle of the gauge launches the Report Menu with Availability Exceptions as the primary
metric. You can then launch the Top N report to find which set of Nodes is causing the
availability exceptions.

o Looking at the Top N interfaces and their network discard figures, one interface seems more
problematic than usual. Clicking on the interface name launches the Report Menu with that
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interface as a topology filter. You can then launch the Chart Detail report to examine discard
figures over the selected time interval for just that interface and determine when the problem
started.

o Using the Heat Chart report for Interface Health shows a peak in traffic on one particular day.
Clicking on the cell with the high value launches the Report Menu with that day already selected.
You can then launch the Interface Health Headline report and get an overview of multiple metrics
for each hour during that day.

Create Bookmarks in Reports
NNM iSPI Performance enables you to create bookmarks for reports in the NPS home page.

These bookmarks encapsulate all the selected settings (Time, filters, Options) and enable you to be
able to quickly visit the report. again from your browser.

Bookmarks are also convenient for emailing and sharing reports.

If you want the bookmark to open the report within the same time range as the original report, make
sure to select a non-relative time range (for example, Start Date/Time with ‘1 Hour and not ‘Last 1
hour as the time range). Otherwise, the report will show the most recent data.

To create a bookmark for a report:

1. Launch areport.

2. Click Show Bookmark. A URL appears. Follow any of these steps:
= Only for Microsoft Internet Explorer. Click Add Bookmark. A bookmark to the report is
automatically added to the browser with a new entry to the Favorites list..

» Only for Mozilla Firefox. To create a new bookmark by using the displayed URL, right click
on the URL and then select Bookmark This Link.

The bookmarked URL retains all the properties of the report.

Create Bookmarks in Reportlets
NNM iSPI Performance enables you to create bookmarks for reportlets in the NPS home page.

These bookmarks encapsulate all the selected settings (Time, filters, Options) and enable you to be
able to quickly visit the reportlet. again from your browser.

Bookmarks are also convenient for emailing and sharing reportlets.

If you want the bookmark to open the reportlet within the same time range as the original reportlet,
make sure to select a non-relative time range (for example, Start Date/Time with ‘1 Hour and not
‘Last 1 hour as the time range). Otherwise, the reportlet will show the most recent data.

To create a bookmark for a reportlet:

1. Launch areportlet.

2. Click E Show Toolbar to display the reportlet toolbar.
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3. Click E3show Bookmark. A URL appears. Follow any of these steps:
» Only for Microsoft Internet Explorer. Click Add Bookmark. A bookmark to the reportlet is
automatically added to the browser with a new entry to the Favorites list..

= Only for Mozilla Firefox. Create a new bookmark by using the displayed URL.
The bookmarked URL retains all the properties of the reportlet.

Create Bookmarks in Reports

NNM iSPI Performance enables you to create bookmarks for reports in the NPS home page.

These bookmarks encapsulate all the selected settings (Time, filters, Options) and enable you to be
able to quickly visit the report. again from your browser.

Bookmarks are also convenient for emailing and sharing reports.

If you want the bookmark to open the report within the same time range as the original report, make
sure to select a non-relative time range (for example, Start Date/Time with ‘1 Hour’ and not ‘Last 1
hour’ as the time range). Otherwise, the report will show the most recent data.

To create a bookmark for a report:

1. Launch areport.

2. Click Show Bookmark. A URL appears. Follow any of these steps:
= Only for Microsoft Internet Explorer. Click Add Bookmark. A bookmark to the report is
automatically added to the browser with a new entry to the Favorites list..

» Only for Mozilla Firefox. To create a new bookmark by using the displayed URL, right click
on the URL and then select Bookmark This Link.

The bookmarked URL retains all the properties of the report.
Add URL Actions in the NNMi Console

After you generate a bookmark, you can create a new Actions menu item with the newly generated
bookmark, which enables you to launch the report or the reportlet of your choice directly from the
NNMi console.

To add URL actions in the NNMi console to launch a report or reportlet:

1. Generate the bookmark for the required report. Or, generate the bookmark for the required
reportlet.

2. Inthe NNMi console, select the Configuration workspace from the workspace navigation
panel.

3. Select User Interface.
4. Select Menu ltems.
5. Click ¥ (New).

The Menu Item form opens.
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6. Inthe basics section of the Menu Item form, specify the following details:
= Menu Item Label:"

= Unique Key:2

=« Author:3

=« Parent Menu:#

. Ordering:5

= Prepend Separator:6
= Enable:’

7. Retain all other default settings in the Basics section.

8. Inthe Menu Item Context tab, click ﬁ New.

The Menu Item Context form opens.

9. Inthe Basics section, click ef ~ , and then click " |Mew Launch sction . New Launch
Action.

The Launch Actions form opens.

10. Inthe Launch Actions form, specify the following:
= Name in the Name box

= Bookmark URL in the Full URL section
11. Click % Save and Close.
12. Click % Save and Close in the Menu Item Context form.
13. Click % Save and Close in the Menu Item form.

14. Click "% Save and Close in the User Interface Configuration form.

Now you can launch the report or reportlet from the Actions menu.

1The name of the report or reportlet that you want to launch.
2 unique identifier for the menu item. Type an identifier with the maximum of 80 characters.

You can use alpha-numeric and period (.) characters. Do not use spaces and underline characters.
To make sure that the value is unique, use the Java name space convention while specifying this
value. Include the Menu Item Label value as part of the unique key as shown in the following
example: com. <company_name>.nnm.menu. item.<menu_item label>.

3You can specify the default value Customer, or click to add a new author name (for example:
NPS).

4Retain the default value—Actions.

5Specify an integer between 1 and 100. The lowest number appears at the top of the Actions menu.
The highest number appears at the bottom of the Actions menu.

6Select this option to add a horizontal line before the report or reportlet menu item in the Actions
menu.

"Select this option to use the report or reportlet bookmark.
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View a Report Using Different Report Formats

The default report format used by the Network Performance Server (NPS) and Bl Server is the web-
based HTML format.

Using NPS, you can view a report in the following additional formats:
¢ Adobe PDF
¢ Microsoft Excel
To view areport in non-HTML format:
1. Inthe NNMi console, click Actions > Reporting-Report Menu. The NPS Home Page opens.

2. Onthe navigation panel, select the Reports tab. The NPS presents the self
Diagnosticreports for the default, ready-to-use Self Diagnostic extension pack.
Depending on the number of the NNM iSPI products or extension packs available on the NPS
system, you may see many other report folders.

3. Under an extension pack (Example: Component Health, Interface Health, etc), select a report.

4. Inthe Time Controls tab, select a time range for the report. For information on selecting the
time range for a report, see Change Time Controls.

5. Click 7| View in HTML Format.

6. Select one of the following options:
= Forthe PDF format, click View in PDF Format. A PDF version of the report appears in the
same browser window.

= Forthe Microsoft Excel format, click View in Excel Options, and then click View in Excel
2007 Format, View in Excel 2002 Format, or View in Excel 2000 Single Sheet Format.
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Troubleshooting Tips

Click the appropriate link from the lists below to display its details :

NNMi console Action menu has no link to Reporting — Report menu

Does the Bl Server have guidelines for tuning performance?

An error message says that NNMi is not polling one or more objects for performance data. What
went wrong?

If | leave a report, and return later, | see a login screen. Why?

I'm waiting too long for reports to display. What can | do to improve the run-time?

When | leave my browser open for a while, | lose my connection and | can't get logged in again.

Where can | find more information about polling?

Why am | being asked to log in again when | navigate from NNMi to a report?

Why are exception counts missing from reports?

Errors and Warnings Glossary

A B c

|w)
Im
I

General

Message Type Cause/Suggested Actions

Attempting to extend allocated space for WARN [ The database requires additional
DBSPACE {DB_SPACE} using dbsize.ovpl disk space; the ETL process will
allocate more.

Attempting to restart HP Bl Server Processes WARN | The Bl server process has stopped
while ETL is running. ETL will
attempt to restart the process.

Attempting to restart HP DB Server WARN | The database server process has
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Message Type Cause/Suggested Actions
stopped while ETL is running. ETL
will attempt to restart the process.
Automatic NNM HA add-on configuration failed: ERROR | High availability configuration failed.

Exit Code {EXIT_CODE}

failed.

Bl Processes not running. WARN | The Bl server process has stopped
while ETL is running.
Bl Processes still not running.. restart attempt ERROR | The Bl server process has stopped

|

while ETL is running. ETL has
attempted to restart the process but
failed to do so, and ETL cannot
continue. Try starting the Bl server
process manually using
startBl.ovpl.

ERRORY}

Cannot extract remote nnm hostname from value | ERROR | On a dedicated server installation,

of PRSPI_NNMDIR ({PRSPI_NNMDIR}) the configuration entry for the NNMi
shared directory should contain the
name of the NNMi server. Failure to
determine this hostname affects
application failover configurations.

Cannot find the OV Install Dir <{DIR}>. ERROR | %nnminstalldir¥ does not exist.
Check the NNMi installation.

Cannot find the nnm.ports.properties file to ERROR | If the jobs port cannot be determined

establish port for jboss http server. the iSPI cannot be enabled. Check
the NNMi installation.

Check NNM HA environment then run ERROR | EnablingiSPI in an HA environment

nnmenableperfspi.ovpl. must be done in a specific order.
See the HA-specific topic in the
NNMi Deployment Guide for more
information.

Check your environment for NNM environment ERROR | Some or all required NNMi variables

variables then run nnmenableperfspi.ovpl. cannot be determined. Check the
NNMi installation.

Command Failed: {PERL} getNNMActiveScript: ERROR | An application failover specific

{CHILD_ERROR} script has failed. Check your
application failover environment.

Command Failed: {UNZIP} {ZIPFILE}: {CHILD_ ERROR | An error occurred unzipping the

identified file. The CHILD_ERROR
may give more information (corrupt
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Message Type Cause/Suggested Actions
zip file, permissions issue etc.)

Command: ERROR | A high availability specific script has

{OVDIR}/misc/nnm/ha/nnmhaclusterinfo.ovpl - failed. Check your high availability

config NNM -get HA_PERFSPI_ADAPTER_DIR environment.

Command: ERROR | A high availability specific script has

{OVDIR}/misc/nnm/ha/nnmhaclusterinfo.ovpl - failed. Check your high availability

config NNM -get NNM_INTERFACE environment.

Command: ERROR | A high availability specific script has

{OVDIR}/misc/nnm/ha/nnmhaconfigure.ovpl NNM failed. Check your high availability

-addon PerfSPIHA environment.

Configuration file contains errors. ERROR | The iSPI configuration file contains
errors, check the associated error
messages for specifics.

Configuration: Unable to access directory ERROR | The shared directory for metrics is

{PRSPI_METRICS} inaccessible. Check that NFS or
Samba is operating properly.

Configuration: Unable to access directory ERROR | The main shared directory is

{PRSPI_NNMDIR} inaccessible. Check that NFS or
Samba is operating properly.

Configuration: Unable to access directory ERROR | The shared directory for topology

{PRSPI_TOPODUMP} information is inaccessible. Check
that NFS or Samba is operating
properly.

Configuration: directory {PRSPI_METRICS} must | ERROR | The shared directory for metrics is

have write access not writable. Check your NFS or
samba configuration and file
permissions.

Configuration: directory {PRSPI_TOPODUMP} ERROR | The shared directory for topology

must have write access information is not writable. Check
your NFS or samba configuration
and file permissions.

Configuration: java not found in 'java_dir' ({java_ ERROR | The HP Java installation appears to

dir}) be corrupted.

Configuration: perl not found in 'perl_dir' ({perl_dir}) | ERROR | The HP Perl installation appears to
be corrupted.

Configuration: {NAME} not defined. ERROR | A required configuration parameter

is not defined.
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Message Type Cause/Suggested Actions
Configuration: {NAME} value must be a valid path. | ERROR | A required configuration parameter
Invalid value: {VALUE} must be a valid path and it is not.
Configuration: {NAME} value must be numeric. ERROR | A required configuration parameter

Invalid value: {VALUE}

DB Processes still not running.. restart attempt
failed.

ERROR

must be numeric and it is not.

The database server process has
stopped while ETL is running. ETL
will has attempted to restart the
process but failed to do so. ETL
cannot continue. Try starting the
database server process manually
using startDB.ovpl

DBSPACE {DBSPACE}, FILE {FILE}: Cannot
extend because there is no reserve space left.

WARN

The database needs to be extended
but cannot because there is no disk
space available. You should free
existing disk space or add new
disks before your database runs out
of space.

DBSPACE {DBSPACE}, FILE {FILE}: Cannot
extend {PATH} because there is insufficient disk
space left on file system.

WARN

The database needs to be extended
but cannot because there is no disk
space available. You should free
existing disk space or add new
disks before your database runs out
of space.

Database Processes not running!

WARN

The database server has stopped
while ETL is running

Dropping connection_id {CONNECTION_ID}

WARN

The specified connection is being
dropped. This is normally a
transparent operation for report
users.

Error - Unable to remove the nnm actions for iSPI WARN | Check NNM is running. You can

for Performance also remove actions from the NNMi
console.

Error running dbisql: {DB_ERROR} ({SQL}) WARN [ The described SQL error occurred.

Check for other messages
associated with this one.
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Message Type Cause/Suggested Actions
Expected PRSPI_NNMDIR of form WARN | On a dedicated server install the
/net/hostname/var... or //hostname/PerfSpi NNM directory path should be one
of the forms shown.
Extension Pack {EXTENSION_PACK}: process WARN [ An ETL process had to be restarted.

not running. Restarting

Failed archiving logfile PerfSPI_Diagnostic_ WARN | The log archive process failed.

Metrics.log

Failed archiving logfile prspi.log WARN [ The log archive process failed.

Failed building extensionPack for new or updated ERROR | This should not be encountered by

NNM metadata: {(METADATA} customers.

Failed chdirto {DIR}: {OS_ERROR} ERROR | Failed changing directory to the
specified directory, the OS error
may give more information
(directory does not exist,
permissions etc.)

Failed command:copy({FILE_LIST}):{OS _ WARN | Failed copying the specified files,

ERROR} the OS error may give more
information (directory does not
exist, permissions etc.)

Failed command:copy({FILE_LIST}):{OS _ ERROR | Failed copying the specified files,

ERROR} the OS error may give more
information (directory does not
exist, permissions etc..) The
program immediately exits.

Failed command:fork():{OS_ERROR} ERROR | Failed forking (creating a new
process), the OS error may give
more information (lack of system
resource, etc..) The program
immediately exits.

Failed command:mkpath({PATH_LIST}):{OS_ ERROR | Failed creating the specified

ERROR} directories, the OS error may give
more information (directory does not
exist, permissions etc..) The
program immediately exits.

Failed command:mkpath({PATH_LIST}):{OS_ WARN | Failed creating the specified

ERROR} directories, the OS error may give
more information (directory does not
exist, permissions etc..)

Failed command:move({FILE_LIST}):{OS_ ERROR | Failed moving the specified files,
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Message Type Cause/Suggested Actions

ERROR} the OS error may give more
information (directory does not
exist, permissions etc..) The
program immediately exits.

Failed command:move({FILE_LIST}):{OS_ WARN | Failed moving the specified files,

ERROR} the OS error may give more

information (directory does not
exist, permissions etc..)

Failed command:open({HANDLE},{ARGS}):{OS_ | ERROR | Failed opening the specified file, the
ERROR} arguments and OS error may give
more information (directory does not
exist, permissions etc..) The
program immediately exits.

Failed ERROR | Failed opening the specified file, the
command:open({HANDLE},{FLAG},{ARGS}):{OS __ arguments and OS error may give
ERROR} more information (directory does not

exist, permissions etc..) The
program immediately exits.

Failed command:opendir(DIR,{DIR Configuration: | WARN [ Failed opening the specified
{NAME} not defined.NAME}):{OS_ERROR} directory, the OS error may give
more information (directory does not
exist, permissions etc..)

Failed command:system({COMMAND}:{CHILD_ | WARN [ Failed running the specified system
ERROR}) command, the OS error may give
more information (lack of system
resources etc..)

Failed command:system({COMMAND}):{CHILD_ | ERROR | Failed running the specified system
ERROR} command, the OS error may give
more information (lack of system
resources etc..) The program
immediately exits.

Failed command:unlink({FILE_LIST}):{OS_ ERROR | Failed removing the specified files,
ERROR} the OS error may give more
information (directory does not
exist, permissions etc..) The
program immediately exits.

Failed command:unlink({FILE_LIST}):{OS_ WARN | Failed removing the specified files,
ERROR} the OS error may give more
information (directory does not
exist, permissions etc..)

ERROR | Failed copying file from specified
source to destination, the OS error
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may give more information
(directory does not exist,
permissions etc..)
Failed copying {SRC}to {DEST}: {OS_ERROR} ERROR
Failed creating {FILE}: {OS_ERROR} ERROR | Failed creating the specified file, the

/1 <Package name>

WARN

OS error may give more information
(directory does not exist,
permissions etc..)

General Warnings

This warning can appear for any one
of the following reasons:

e Thereis no data in the topology
tables for the displayed package.

e The topology filters chosen will
result in empty reports.

o The topology filters chosen are
not appropriate for the selected
package and will be dropped.

/i The system is currently running with
demonstration data!

WARN

The system is currently running with
demonstration data.

Problem: Reports Take Too Long to Display

Do you think any of the following caused the problem?

Diagnosis Step 1 Did NNMi experience a recent topology reset?

Diagnosis Step 2 Were one or more interface groups recently added to performance monitoring?
Diagnosis Step 3 Are a large number of users logged in to the system?

Diagnosis Step 4 Are the hardware resources over-utilized?

General Resolution Tips

o Create areport view with the required prompts and schedule this report view to run on a regular
basis. Then view the scheduled output, or bookmark a URL to view the scheduled output. For
more information on scheduling reports, see Schedule Report Delivery.

o Filters can improve report performance. A report on a specific node group is generally faster than
a report on All Nodes/Interfaces; the same logic applies to the time dimension. For more
information on report filters, see the following topics:
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» Set Topology Filters

= Change Time Controls

« Run the same report again. Data caching, which took place the first time you ran the report, will
decrease the run time the next time you run the same report.

Problem: User Needs to Re-Login while Navigating from
NNMi to a NNM iSPI Performance Report

This problem may occur if you launched the NNM console using the IP address of the NNMi
system and not the NNM's fully-qualified domain name (FQDN).

Resolution
Always use the FQDN of the NNMi system to log into NNMi Console.

Explanation

Whenever you move from NNMi to the a report, account information is passed between your NNM
login session and the NPS using cookies in your browser. A function known as Single Sign-On
(SSO) makes it possible for you to move from NNM to a report without having to log in a second
time.

For SSO to operate, the following conditions must be met:
o The NNMi system and the NPS system must be configured with fully qualified domain names.

o You must use the fully-qualified domain in your browser (not "localhost" or the machine name
minus the domain) when you launch the NNMi console.

A fully-qualified domain name (FQDN) has this format:
http://fully_qualified_domain_name:port/nnm

If NNMi and the NPS are installed on the same machine, the SSO function will operate if you use
either of these:

¢ NNM's FQDN
e NNM's IP address

The NPS is responsible for configuring use of NNMi's |P address; this step takes place
automatically, when the NPS is installed.

Problem: NNMi Console Action Menu Has No Link to
Reporting — Report menu

The NNMi console does not display the Reporting-Report menu item in the Action menu if you
do not completely (and successfully) run the enablement script. Follow the Installation Guide to run
the enablement script (nnmenableperfspi.ovpl)onthe NNMi management server.
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Error: NNMi Is Not Polling One or More Objects for
Performance Data

Do you think any of the following caused the problem?

Diagnosis Step 1 | Is NNMi polling the specified device, or devices, for performance data?

Diagnosis Step2 | Can NNMi synchronize the topology information with NPS?

Problem: Leaving a Report Open Requires Re-Login
The NPS requires you to re-login to view a report under the following circumstances:
o You are trying to access the NPS without being authenticated by NNMi.
e You pointed your browser at the NPS without logging into NNMi first.
e Your browser session has expired.

Resolution
Log in again to return to the NPS.

Problem: Leaving the Browser Open for a While Prevents
Re-Login

The inactivity timeout setting for the NPS is one hour. If your browser is inactive for an hour, your
session will expire. If your session expires, the NPS requires you to log in again. The login window
requires the administrator username and password.

Resolution
1. Close the timeout login window.

2. Loginto the NNMi console using the standard URL:
http://fully-qualified-hostname:port;/nnm

3. Navigate to the NNM iSPI Performance report that you were using.
Problem: Exception Counts Are Missing from Reports
Before you can resolve this problem, follow this navigation path to diagnose the cause of the error:
Diagnosis
Did you define thresholds in NNMi?

Resolution

Setting up thresholds in NNMi requires administrator privileges. Follow these steps to locate
applicable help topics:

1. Launch the NNMi console.
2. Click Help — Help for Administrators.
3. Select Configure Threshold Monitoring for Nodes

Page 88 of 92 HP Network Node Manager iSPI Performance for Metrics Software (9.11)



Online Help
Troubleshooting Tips

Immediately after thresholds are set, exceptions will begin to register in reports.

Problem: The NPS Stops Functioning and Does Not Show
Any Report

Before you can resolve this problem, follow this step to diagnose the cause of the error:

Diagnosis

Did you change the address or hostname of the NPS Server?

Resolution

Change the IP address, hostname, or MAC address of the NPS server, after following these steps:

1.

On the NPS server, run the following command:

On Windows:
%NPSInstallDir’%a\NNMPerformanceSPI\bin\stopAll.ovpl

On Linux:
lopt/OV/INNMPerformanceSPIl/bin/stopALL.ovpl
Open the Bl Server configuration GUI with the following command:

On Windows:
%NPSInstallDir’%s\NNMPerformanceSPI\bin\runBIConfigGUI.ovpl

On Linux:
lopt/OV/INNMPerformanceSPI/bin/runBIConfigGUl.ovpl
Click File > Export As.

Specify alocation and a file name in the dialog box, and then click Save.The configuration data
is saved in the XML format.

Delete the following directories manually:
On Windows:

%NPSInstallDir%\nonOvV\cognos\c8\configuration\signkeypair
%NPSInstallDir%\non0OvV\cognos\c8\configuration\encryptkeypair

On Linux:

/opt/0OV/nonOV/cognos/c8/configuration/signkeypair
/opt/0V/nonOV/cognos/c8/configuration/encryptkeypair

Copy the XML file saved in step 3 to the following directory:

On Windows:
%NPSInstallDir%\nonOv\cognos\c8\configuration

On Linux:
/opt/0OV/nonOV/cognos/c8/configuration
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Finding More Information about Polling

Performance polling has an impact on NNMi and it also has an impact on your network. If you
enable additional performance polling, NNMi needs to allocate a portion of its resources to handle
the additional polling, and your network will have to accommodate an increase in SNMP traffic. To
ensure that the performance polling does not cause in wasted resources, it is important to limit
performance polling to the important devices.

You need NNMi administrator privileges to enable performance polling. Follow these steps to locate
applicable help topics:

1. Launch the NNM console.
2. Click Help — Help for Administrators.

3. Select Monitoring Configuration.

Finding More Information about Creating New Node Groups

Creating a new node group involves setting device-level filters. After you create the new node
group, you may want to use the group as a way to filter NNMi views, and you might also want to
add the node group as afilter to the iISPI element selection tree.

Creating node groups, and using the filter options, are NNMi administrator tasks. Follow these
steps to locate applicable help topics:

1. Launch the NNMi console.
2. Click Help — Help for Administrators.

3. Select Monitoring.
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Self Diagnostics

The Self Diagnostics extension pack monitors the health of the processes which function within the
NPS.

Some of the tasks that these reports enable you to perform, are:

« Investigate how the processes within the NPS are performing by looking at Self Diagnostic
reports.

o Analyze if the metrics measuring NPS performance are within the acceptable (normal) range.
o Compare the performances of various NPS processes for selected time range.

« Analyze the performance of various NPS processes during the busiest tome of the day.

Monitor the Health of the NPS and Extension Packs

The reports generated by the Self Diagnostic extension pack helps you monitor the health and
performance of the processes that build up the core functionality of the NPS. The reports also help
you monitor the performance of different extension packs available on the NPS system.

The Self Diagnostic extension pack identifies every process on the NPS system as a task. Every
task is grouped under relevant task type, task category, and extension pack in the following order:

E xtension Pack

Task category

Task type

Task name

Task Categories
The NPS uses two broad categories to group all processes—ETL and Report Generation.
Task Types

Under the ETL category, the NPS groups relevant process under the following task types:

Page 1 of 16 HP Network Node Manager iSPI Performance for Metrics Software (9.11)



Online Help
Self Diagnostics

build_groupcache_from_db
build_topcache from_db

checkAggregates
process_group_dump_file
process_metricsfiles
process_metricsfiles->bulkload archive table
process_metricsfiles->bulkload live table
process_metricsfiles->prepare_baselining
process_metricsfiles->Sorting CSV files
process_metricsfiles->preprocessing
process_retention->aggregate table
process_retention->live table
process_retention->archive table
process_retention->timeDimension table
process_summary->Summary Child Proc
process_summary->Summary Parent Proc

process_topodump _file

Tasks

The NPS monitors and administers essential processes as tasks running on the NPS system. All
such processes are introduced by different extension packs on the system. The processes are
named in the following format:

extension_pack _name>.<task_category>.<task_type>

Metrics

Some of the metrics that you can use in the Self Diagnostics reports are as follows:

Process Time (time in seconds for the task to complete)
Number of Rows (applies to select tasks, such as ETL bulk loads, and so on)

Available System Memory — shows free memory (on Linux, free and cached) enabling you to see
if your system’s memory usage is increasing, causing available memory to decrease. Low
available memory can cause system performance to degrade.

Available Disk Space — enables you to monitor your disk usage in the ‘Data Directory’ file
system. By plotting the Available Disk trend over time, you can see if your disk usage has
reached a steady state, or if you are on a trajectory to run out of disk space.

Calendar Report

The Calendar Report uses a traditional, calendar-style layout to show hourly statistics for two
metrics in a single, extended graph spanning over multiple days.

To change the Time Controls defaults, see Change Time Controls.
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To change the Topology Filters defaults, see Set Topology Filters.

To change the Report Options defaults, see Change Report Options.

Features and Defaults

The Calendar Report defaults to:

Task Categories, Task Types, and Task Names= All

o Dates/Times = Last 31 days

o Metric(s) Shown on Y1 Axis = Process Time (secs)(avg)
o Metric(s) Shown on Y2 Axis = Process Time (secs)(min)

The default view shows data for the current month. Depending on how long the NPS has been
collecting data, you may have the option of looking at data for the previous 70 days if you use the
option Until Now.

Use Case

Use this report to observe:

gradual trends over time

isolated spikes

to verify that an abnormal condition has returned to normal

o tomake comparisons
This report also reveals:
o Day of week patterns

o Hour of day patterns

Chart Detail Report

The Chart Detail report enables you to perform a trend analysis for the NPS process health and
performance based on historical performance data.

The Chart Detail report displays a comparative analysis of the selected metrics for each time unit.

For example, if you need to compare how the average Threshold Exception Rate was affected by
variance in the average Process Time per millisecond for the past one week, you can generate the
Weekly Performance Diagnostics report for the selected node group.

You can also select two or more task type, task name, extension pack, etc to generate Chart Detail
report.

Using this report you can:

o Analyze the trend of network health and performance for multiple task type, task name,
extension pack, etc based on one unit of time. Each unit of time is called as a Display Grain .
Each Display Grain is measured as follows:
= Five minutes for Hourly report

= One hour for daily report
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= One day for weekly report
= One day for monthly report
o Identify any ups and downs in the health and performance of the NPS processes.

o Compare the health and performance of more than two task type, task name, extension pack,
etc based on historical health and performance data.

The following are the available filters in the Time Controls pane for Chart Detail Report:
o Start Date/Time

o Time Range

o Display Grain

o Hour of day

o Day of Week

To change the Time Controls defaults, see Change Time Controls.

To change the Topology Filters defaults, see Set Topology Filters.

To change the Report Options defaults, see Change Report Options.

Features and Defaults

The graph on this report tracks up to metrics over the selected time period. Unless you modify the
defaults, Chart Detail defaults to the following:

o Task Categories, Task Types, and Task Names = All
o Primary metric = Process Time (secs)(avg)

e Secondary metric = Process Time (secs)(min)

To add another primary or secondary metric, click Options and then click ﬁ
To remove a primary or secondary metric that you have already added, click Options and then click

>

The Chart Detail report enables you to view the data in the tabular format as well. To view the table,
click Options, and then select Table. The Table appears instead of the chart. To view both the
chart and the table, click Options, and then select Chart and Table.

Heat Chart Report

The Heat Chart Report tracks the hourly performance of a single metric. The default metric is
Process Time (secs) (avg). The default time period is the last 24 hours. Performance is color-
coded, making it easy to spot a condition that is gradually worsening and making it easy to
distinguish satisfactory performance from unsatisfactory performance.

The following are the available filters in the Time Controls pane for Heat Chart Detail:
o Start Date/Time
o Time Range

¢ Display Grain
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¢ Auto Refresh
o Hours of Day
o Day of Week

To change the Time Controls defaults, see Change Time Controls.

To change the Topology Filters defaults, see Set Topology Filters.

To change the Report Options defaults, see Change Report Options.

Features and Defaults

The legend at the top of the report ties a range of normalized performance values to a particular
color. Any value within that range will get that color. Beneath the legend, each day of the month is
listed left to right, day 1 through 31. Down the side of the report is each hour of the day. Each cell
inside the table is color-coded and each cell inside the table indicates a specific value. You can
move the mouse pointer on a cell to view raw data.

The Heat Chart defaults to:

o Time Period = Last 24 hours
o Hourof Day = All

o Day of Week = Al

o Metric = Process Time (secs) (avg)

Managed Inventory Report

Use the Managed Inventory Report to view the list of available topology attributes. You can use the
available attributes to filter the data of your interest and create a report that represents only the
elements of your interest. The report presents the list of attributes in the form of a table; the Count
column of the table indicates the number of entries for each attribute.

For the topology item Extension Pack, the Count column indicates the number of available
extension packs on the NPS system.

For the topology item Task Category, the Count column indicates the number of task categories
created by the NPS.

To change the Time Controls defaults, see Change Time Controls.

To change the Topology Filters defaults, see Set Topology Filters.

Most Changed Report

This report compares performance for two different (consecutive) time periods and ranks processes
by the amount of change. The sort order is most-changed to least-changed.

To change the Time Controls defaults, see Change Time Controls.

To change the Topology Filters defaults, see Set Topology Filters.

To change the Report Options defaults, see Change Report Options.

Features and Defaults

This report contains one table and provides data for one metric only.
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Following are the columns in the table:

o Performance for the previous time period

o Performance for the selected time period

o Growth, expressed as a percentage increase
o Change

The Most Changed report defaults to:

o Dates/Times = Last Day (and the day before)
o Hourof Day = All

o Day of Week = All

o Rank Metric = Process Time (secs)(avg))

e Top N Option=Top 10

If you select a month, the report will compare two months (the month you selected and the prior
month); if you select a week, the report will compare two weeks (the week you selected and the
prior week).

Self Diagnostics Peak Period Report

The Self Diagnostics Peak Period Report ranks the performance of an NPS processes during the
busiest time of the selected time range.

Using this report, you can:
« Identify the performance and utilization of the selected metrics during the peak period.

« Identify the NPS processes that have the highest or lowest performances during the peak
period.

o Compare the performance for multiple NPS processes during the peak period using this report.

Self Diagnostics Peak Period Report Options

e Top / Bottom NT
o Metric?
o Grouping by Time Period3

This report tracks up to six metrics over the selected time period.
To add another metric, click Options and then click E

To remove a metric that you have already added, click Options and then click E

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the

selected component.
2Select the metric based on which you want to generate the report. The metric that you select is

used to rank the report data.
SEnables you to group the report data based on a specific time grain. Click Add New Grouping icon

to add a new group.
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To select a range of value for the metric, click 4 and select a range of metric value that the report
should consider.

For example if you want to see the top five interfaces with the average memory utilization between
10% and 90%, select 10 as Lowest value and 90 as the Highest value.

By default, the report groups data by Time Period. You can select multiple grouping attributes by

using the E (Add New Grouping) button. Use the gl (Remove Grouping) button to remove a
grouping attribute.

Tip:
o Use this report to identify the period when the NPS processes performance was the lowest.
o Check this report once a day to see which NPS processes may need special attention.

To change the Time Controls defaults, see Change Time Controls.

To change the Topology Filters defaults, see Set Topology Filters.

To change the Report Options defaults, see Change Report Options.

Top 10 Task Duration Report

The Self Diagnostics extension pack monitors the health of all the ETL and report generation
processes on the NPS system. You can easily investigate how the ETL processes and reports are
performing by using the Top 10 Task Duration Report.

This report monitors the Top 10 ETL and report generation processes and tracks the time taken by
each process during the selected time range.

To change the Time Controls defaults, see Change Time Controls.

Top N Report

This report ranks the NPS processes by the metric you select. Use this report to spot the process
that performed at the extremes. You can use this report to analyze the historical data for the
processes that are exhibiting unusual performance levels.

Some of the topology filters that you can use to generate this report are as follows:
o Extension Pack

e Task Category

e Task Type

e Task Name

Using this report you can:

« Rank the performance of the extension packs and tasks running on your Performance iSPI
server.

o Detect the underlying reason of a persistent problem with a process. You can compare the
performance for multiple tasks using this report.
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Example

Some of the processes in your network are performing poorly. Using this report, you can group the
processes reporting highest processing time. The process reporting the highest processing time is
ranked first.

Performance SPI Top N Reports Options

The Top N report displays the following options:
« Top/Bottom'N 1

o Metric?

o Display Time Series Chart3

e Grouping By4

Thi-
s report tracks up to six metrics for each metric type over the selected time period.

To add another metric, click Options and then click '{F_hl
To remove a metric that you have already added, click Options and then click BI

To select a range of value for the metric, click g and select a range of metric value that the report
should consider. For example if you want to see the average process time for the Self Diagnostics
extension pack between the range of 100 and 500 seconds, select 100 as minimum value and 500
as the maximum value.

By default, the report groups data by Extension Pack. You can select multiple grouping attributes

by using the E (Add New Grouping) button. Use the BI (Remove Grouping) button to remove a
grouping attribute.

Tip :

o By default, Top N Report is displayed without Time Series Chart. Click Display Time Series
Chart to view the chart with the detail table.

o Check this report once a day to see which extension pack or process may need special
attention.

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected NPS processes.

2Select the metric based on which you want to generate the report. The metric that you select is
used to rank the report.

3Select Yes to view the detail chart with the table. Select No to hide the chart and display only the
table. The created Top N Report displays the graphical representation of the metric values for the
NPS processes over the selected time range.

4E Enables you to group the report data based on a specific parameter. Click to add a subgroup.
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o Check this report periodically throughout the day to see which extension packs or processes are
performing at the extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls.

To change the Topology Filters defaults, see Set Topology Filters.

To change the Report Options defaults, see Change Report Options.

Self Diagnostics Top N Chart
Like the Top N report, this report also ranks the NPS processes by the metric you select.
Using this report, you can:
e Spot the NPS processes that performed at the extremes.

o Detect the NPS processes having a performance problem.
Self Diagnostics Top N Chart Options

The Top N Chart displays the following options:
e Top / Bottom N

o Metric?

¢ Grouping By3

This report tracks up to six metrics over the selected time period.

To add another metric, click Options and then click E

To remove a metric that you have already added, click Options and then click x.

To select a range of value for the metric, click g . and select a range of metric value that the report
should consider.

For example if you want to see the top five interfaces with the average availability between 10%
and 90%, select 10 as Lowest value and 90 as the Highest value.

By default, the report groups data by Extension Pack. You can select multiple grouping attributes

by using the E (Add New Grouping) button. Use the Pt (Remove Grouping) button to remove
a grouping attribute.

Tip :
Check this report once a day to see which NPS processes may need special attention.

To change the Time Controls defaults, see Change Time Controls.

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

2Select the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.

3Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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To change the Topology Filters defaults, see Set Topology Filters.

To change the Report Options defaults, see Change Report Options.

NNM iSPI Performance for Metrics Reportlets

In a large enterprise network the NNM iSPI Performance products1 may produce a large amount
of data and large cardinality. This means that these networks often have a very large amount of
unique IP addresses, source nodes and destination nodes, interfaces, and components each
producing large amount of data. Generating reports using such large data volume may be time
consuming.

Reportlets enable you to generate quick impressions of the larger reports using the NNM iSPI
Performance for Metrics Dashboards.

Viewing NNM iSPI Performance for Metrics Reportlets
To display the reportlets:
1. Loginto NPS Home Page.

2. On the left navigation panel, select Dashboard Reportlets.
3. Select an extension pack and then select a reportlet.

You can also create custom dashboards using the reportlets. See Creating Custom Dashboards
Using Bl Server Portal for information on the procedure to create the custom dashboards.

Calendar
Displays a comparative study of the selected Primary Metric2 and Secondary Metric3
The default display grain is set to one hour. You cannot change the display grain of this reportlet.
Enables you to monitor the following:
o Daily system resource utilization by the NPS processes
« Volume of data processed by the NPS processes for the selected time range
o Performance of the NPS processes for the selected time range
This reportlet supports two metrics.
Gauge
Evaluates the metric for the selected point of time.

Enables you to:

TNNM iSPI Performance for Metrics, NNM iSPI Performance for Quality Assurance, and NNM
iSPI Performance for Traffic

2Enables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

SEnables you to select the metric that would overlay the primary metric. The secondary metric that
you select is displayed on the right Y axis of the report.
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o Measure the daily performance of the selected metric.
o Detect any abnormal or unexpected performance level.

This reportlet supports one metric.

Heat Chart
Grades the performance of the selected metric for the selected time range.
The metric performance is aggregated based on an hourly display grain.
Enables you to perform the following tasks:
o View how the NPS process performance gets affected by a varying metric.
o Compare the hourly performance of the selected metric.

o Detect the time range when the NPS process performance was affected adversely because of
the fluctuating metric value.

This reportlet supports one metric.

Metric Snapshot
Displays the metric performance for the selected time range.

Enables you to:

o Build a performance history for the selected metric and analyze how the metric performance
changes over time.

Such history may help you to decide the baseline value for the metric
o Compare the performance for multiple metrics over a specified time range.

Though you can generate snapshot report for a single metric, you can save the snapshot report
for various metrics and compare the performance of each metric over a time range.

This reportlet supports one metric.
Most Changed
Compares the metric performance between yesterday and today.
Aggregates the daily metric utilization and ranks the performance in a descending order.
Enables you to:
o Measure the performance fluctuations for the NPS processes.
o Detect the top N NPS processes having a common performance or utilization problem.
You can enhance the report usability using the following features:
e Top N

e Grouping By1

1Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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This reportlet supports one metric.

Multimetric Chart
Analyzes the utilization trend for the selected metrics for the selected time range.
Enables you to perform the following tasks:
o Perform comparative analysis of the selected metrics for each display grain.
The default display grain is one hour.
o Analyze the reason for any ups and downs in the NPS process performance.

o Detect any persistent problem in the NPS process performance.

This reportlet supports up to six metrics.
Simple Bar and Line Chart

Displays the trend of NPS process performance for the selected time range using the following
values:

e Primary Metric! on the bar chart

o Secondary Metric2 on the line chart

Enables you to:

o Compare the performance trends of multiple metrics.

« Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports two metrics.
Simple Bar Chart
Compares the performance of two metrics for the selected time range.
Enables you to:
e Compare the performance trends of multiple metrics.

« Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports two metrics.
Simple Chart

Analyzes the utilization trend for the selected metrics for the selected time range.

Enables you to:

TEnables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

Enables you to select the metric that would overlay the primary metric. The secondary metric that
you select is displayed on the right Y axis of the report.
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o Perform comparative analysis of the selected metrics for each display grain.
The default display grain is one hour.
o Analyze the reason for any ups and downs in the NPS process performance.
o Detect any persistent problem in the NPS process performance.
This reportlet supports two metrics.
Simple Table
Analyzes the utilization trend for the selected metrics for the selected time range.
The default display grain is one hour.
Enables you to:
¢ Analyze the hourly performance of the metrics.
o Detect any abnormal or unexpected NPS process performance.

¢ Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports two metrics.
Sparkline
Evaluates the trend of how the selected metric value has changed for the selected time range.
Enables you to perform the following tasks:
o Analyze the variations in the performance for the selected metric.
o Decide whether the expected behavior for the selected metric should be reassessed.
This reportlet supports one metric.

Top N Chart

Ranks the individual contribution of each metric for the NPS process performance for the selected
time range.

The performance of the NPS process is aggregated on hourly basis.

Enables you to:

o Spot the NPS processes for which the performance metrics present extreme values.

« Investigate the aggregated data for the NPS processes that are exhibiting unusual utilization
levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the NPS processes.

o Group the report data based on a specific parameter. Click E Add Group to add a subgroup.
This reportlet supports one metric.

Top N Line Chart

Ranks the utilization trend for the selected metrics for the selected time range.
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The performance of the NPS process is aggregated on hourly basis.
Enables you to:
o Spot the NPS processes for which the performance metrics present extreme values.

o Investigate the aggregated data for the NPS processes that are exhibiting unusual utilization
levels.

¢ Select the metric based on which you want to generate the report. The metric that you select is
used to rank the NPS processes.

o Group the report data based on a specific parameter. Click E Add Group to add a subgroup.
This reportlet supports one metric.

Top N Stacked Chart
Ranks the individual contribution of each NPS process based on the selected metrics.
The performance of each NPS process is aggregated for the default display grain of one hour.
Enables you to:
o Spot the NPS processes for which the performance metrics present extreme values.

o Investigate the aggregated data for the NPS processes that are exhibiting unusual utilization
levels.

This reportlet supports one metric.

Top N Table

Ranks the NPS processes based on the selected metric.

Enables you to:

o Spot the NPS processes for which the performance metrics present extreme values.

o Investigate the aggregated data for the NPS processes that are exhibiting unusual utilization
levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the NPS processes.

o Group the report data based on a specific parameter. Click E Add Group to add a subgroup.
This reportlet supports one metric.

Top N Table With Bars

Ranks the NPS processes based on the selected metric and displays a horizontal bar to depict the
aggregated metric value.

Enables you to:

o Spot the NPS processes for which the performance metrics present extreme values.

¢ Investigate the aggregated data for the NPS processes that are exhibiting unusual utilization
levels.
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o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the NPS processes.

o Group the report data based on a specific parameter. Click E Add Group to add a subgroup.

This reportlet supports one metric.
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Welcome to the iSPI Performance for Metrics

The iSPI Performance for Metrics enables the combination of NNMi and iSPI Performance to
produce rich and insightful reports from the network performance data collected by NNMi. With the
introduction of extension packs that add definitions to generate reports, the iSPI Performance for
Metrics presents you with ready-to-use report templates that offer meaningful representation of the
aggregated data gathered from NNMi.

The iSPI Performance for Metrics introduces the following extension packs:
o Interface Health: Creates reports that help you examine the MIB Il interface statistics.
o Component Health: Creates reports that examine memory, CPU, and buffer utilization.

o Path Health: Uses data from the other two sources—Interface Health and Component Health—
to create reports on network paths built with a combination of nodes and interfaces.

The iSPI Performance for Metrics removes most of the labor required to detect a network problem
and pinpoint the cause. The iSPI Performance for Metrics automates the following chores:

o Exception reporting
¢ Ranking
¢ Trending

Exception reporting highlights threshold conditions, providing an easy way to spot abnormal
performance. Ranking sorts elements by the metric of your choice and allows you to identify
network elements with unusually high or unusually low values. If an element in the network is
experiencing unusual or extreme performance, ranking will make that element easy to spot.
Trending looks at a period of time and lets you see whether performance is stable, getting worse, or
improving.

In addition to reporting exceptions, ranking elements, and displaying trends, the iSPI Performance
for Metrics lets you drill down on any aggregate of data until you isolate the node, interface, or
component responsible for the condition you are investigating. After you locate the element, you
can drill down on the time dimension as well and find out precisely when the condition started.

iISPI Performance for Metrics query features let you modify a report by applying filters to the
network dimension and the time dimension. Use the network topology filter to modify the report on a
particular node group or a particular node. Use time dimension filter to select a particular day, week,
or month. In addition, you can also filter data by day-of-week and by hour-of-day. Some reports let
you replace the primary and secondary metric with any metrics you choose, and some reports let
you modify the scope and direction of ranking. For example, you can specify that you want to look
at the Top 25 elements instead of the default Top 10, and you can specify that you want to look at
the Bottom 5 elements instead of the Top 5.
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Component Health Reports

The Component Health reports show the performance data for network components in your
environment. Graphs and charts on Component Health reports reflect the details related to the
following elements of devices:

o CPU
o Memory
o Buffer

SNMP response time

Use Component Health reports to determine if a component is over-utilized or if it needs an
upgrade.

Opening Reports from NNMi
From the NNMi Console, you have these options:

¢ Click the Reporting - Report Menu option under the Actions menu; launch reports from the
Report Menu.

o Launching Pre-Filtered iSPI Reports Directly from NNMi

If you are interested in a particular component, launch a pre-filtered report from NNMi; otherwise,
open a workspace view from NNMi, move to the iSPI, and begin your investigation from the
Report Menu. To move from NNMi to the iSPI:

a. Logintothe NNMi Console.
b. Select aworkspace.
c. Open aview (nodes, interfaces, components, or incidents).

d. Select Actions > Reporting - Report Menu page

Glossary of Metrics
Memory Utilization

Percentage of memory in use compared to the total amount of memory available.
Buffer Utilization

Percentage of buffer space in use compared to the total amount of buffer space available.
Buffer Miss Rate

A counter measures the number of buffers available in the buffer pool. An exception is recorded
when the number of buffers drops below a minimum number. The miss rate percentage shows how
the number of below-minimum samples compares to total samples.
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Buffer Failure Rate

A counter measures the number of times buffer creation fails due to insufficient memory. An
exception occurs when the number of failures crosses a threshold. The buffer failure rate is a
percentage that shows how the number of buffer creation failures compares to the total number of
buffer creations.

CPU Utilization

Percentage of CPU utilization in use compared to the total amount of CPU capacity available. (This
metric maps to the CPU 1m utilization value from NNM.)

CPU 5-Second Utilization

This metric averages CPU utilization over a 5-second period, providing a snapshot of the past 5-
seconds at the time of polling. Available from Cisco devices only.

CPU 1-Minute Utilization

This metric averages CPU utilization over a 1-minute period, providing a snapshot of the previous
minute at the time of polling. Available from Cisco and Nortel Passport devices.

CPU 5-Minute Utilization

This metric averages utilization over a 5-minute period, providing a snapshot of the previous 5
minutes at the time of polling. Available from Cisco devices only.

Response Time
The time it takes a node to respond to an SNMP request from NNMi
SampleCount

The number of samples. Some nodes do not support the full range of metrics. To avoid skewing the
averages, separate counts are kept for each metric received.

NodeCount

The number of nodes polled.
ComponentCount

The number of components polled.

Glossary for Polling Metrics

Metric Name Description

Target Error (avg) Generated if the target component returns any of the following
SNMP error responses:

o Authentication error
o Nosuchname

o Nosuch object.
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Reboot (avg) Generated if the target component was restarted during the poll and
no data could be retrieved from the component.
NNMi checks the sysUptime metric to determine whether the
component was restarted during the last poll.
Invalid Data (avg) Generated when NNMi has successfully polled data from the

target, but has determined that the data is invalid. For example,
this metric is calculated when the number of packets is greater
than the number of octets.

Unresponsive Target (avg) | Generated when the SNMP agent did not respond when collecting
metrics for a particular polling policy.

Glossary for Backplane Utilization Metrics

Backplane utilization provides indication on how much traffic is flowing through the switches
available in a network.

Metric Name Description

Backplane Utilization (avg) Average rate of network traffic flowing through
the components available in the network

Backplane Utilization (min) Minimum rate of traffic flowing through the
components available in the network

Backplane Utilization (max) Maximum rate of traffic flowing through the
components available in the network

Backplane Utilization - Threshold Exception Total number of times the backplane
Count (sum) utilization for the switches available in the
network crossed the threshold level.

Indicates that the data being transmitted over
a switch's backplane is excessive.

Backplane Utilization - Threshold Exception Rate of the backplane utilization exceptions
Rate (avg) for the switches available in the network
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Glossary for Disk Space Utilization Metrics

Metric Name Description

Disk Space Utilization - Threshold Exception Total number of times the disk space utilization
Count (sum) has crossed the threshold level

Disk Space Utilization - Threshold Exception Rate of disk space utilization exceptions for the
Rate (avg) available hosts in a network

Disk Space Total - MB (avg) Average amount of disk space allocated by all
the selected hosts

Disk Space Total - MB (min) Minimum amount of disk space allocated by all
the selected hosts

Disk Space Total - MB (max) Maximum amount of disk space allocated by all
the selected hosts

Disk Space Used - MB (avg) Average amount of host disk space used by the
selected components

Disk Space Used - MB (min) Minimum amount of host disk space used by
the selected components

Disk Space Used - MB (max) Maximum amount of host disk space used by
the selected components

Disk Space Free - MB (avg) Average amount of free host disk space
available for the selected components

Disk Space Free - MB (min) Minimum amount of free host disk space
available for the selected components
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Glossary for Node Availability Metrics

Metric Name Description

Node Availability The amount of time the node was available for polling.
e Average The node availability depends on the sysU pTime1 of the
. node.
e Maximum
o Minimum Calculating the node availability.
Node Reachability The amount of time the node's management address was
available to the ICMP polls performed by NNMi.
e Average
Iculating th hability.
o Maximum Calculating the node reachability
e Minimum
.ICMP ResponseTime ICMP response time as milliseconds.

(Milliseconds) , .
If NNMi poll does not receive any responses from the

e Average node's management address, NPS considers this value to
: be NULL.

¢ Maximum

e Minimum

¢ Baseline Average

o Average Baseline Deviation

¢ Average Slope

e Maximum Upper Normal Value
¢ Minimum Lower Normal Value
¢ Minimum Days to Threshold

o Average Forecast Baseline (for
four weeks)

o Average Forecast Baseline (for
eight weeks)

e Maximum Forecast Upper
Normal value (for 12 weeks)

e Minimum Forecast Lower
Normal value (for 12 weeks)

e Sum of Baseline Exception
Count

TNNMi uses the sysUptime to detect a system reboot. Any time a system reboot is detected,
NNMi resets the sysUpTime value to zero.

Page 6 of 30 HP Network Node Manager iSPI Performance for Metrics Software (9.11)



Online Help
Component Health Reports

Metric Name Description

o Average Baseline Exception
Rate

o Average Baseline Intercept
Component

¢ Average Baseline Trend
Component

o Average Baseline Seasonal
Component

o Maximum value for Anomaly
Sample Flags Window

¢ Average Baseline Linear
Samples Used

o Average Baseline Seasonal
Samples Used

o Maximum value for the Upper
Threshold

e Minimum value for the Lower
Threshold

e Sum of Threshold Exception
Count

o Average Threshold Exception
Rate

Component Health Baseline Sleeve Report

This report analyzes how close the metric performance value is to the threshold levels. In other
words, this report enables you to analyze when the metric will reach the threshold.

Using this report, you can:

o Analyze if the component utilization is within the expected (normal) range for the selected time
range.

o Detect if the metric performance is about to cross the high and low thresholds.

For example, if you generate the Baseline Sleeve Chart report for the baseline metric Memory
Utilization, the chart displays the how close the baseline buffer utilization is to the high and low
threshold.

o Save multiple Baseline Sleeve Reports for a specific metric for different time ranges, and
analyze the metric performance trend.

This report supports one metric.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.
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o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Component HealthCalendar Report

The Calendar Report uses a traditional, calendar-style layout to show hourly statistics for two
metrics in a single, extended graph spanning over multiple days.

Features and Defaults

The Calendar Report defaults to:

o Nodes/Components = All

o Dates/Times =Last 31 days

¢ Metric(s) Shown on Y1 Axis = Memory Utilization (avg)

o Metric(s) Shown on Y2 Axis = CPU 5min Utilization — Exception Rate (max)

The default view shows the data for the current month. Depending on how long the iISPI has been
collecting data from NNM, you may have the option of looking at data for the previous two months
as well as last 31 days.

Note: If you set the Time Range below 24 hours, the following message appears:
This report is not designed to operate with a time range of less than
24 hours. Please modify your time selections.

You can use the following Time Controls parameters:
o Start Date/Time

o Time Range

¢ Auto Refresh

Use Cases

Use this report to observe:

gradual trends over time

to spot isolated spikes

to verify that an abnormal condition has returned to normal
o tomake comparisons

For example, to compare the data of the last 31 days, or to compare data for last month to data for
the preceding month.

This report also reveals:
o Day of week patterns

o Hour of day patterns
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For example, if utilization is spiking on Tuesdays, or if response time issues are occurring daily at
11:00 a.m., the report will highlight these events.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

Component Health Chart Detail Report

Component Health Chart Detail report enables you to perform a trend analysis for the network
health and performance based on historical component health data.

The Chart Detail report displays a comparative analysis of the selected metrics for each time unit.

For example, if you need to compare how the average Threshold Exception Rate was affected by
variance in the average SNMP Response Time per millisecond for the past one week, you can
generate the Weekly Component Health report for the selected node group.

You can also select two or more component or component groups to generate Chart Detail report.
Using this report you can:

o Analyze the trend of network health and performance for multiple components or component
groups based on one unit of time. Each unit of time is called as a Display Grain . Each Display
Grain is measured as follows:
= Five minutes for Hourly report

= One hour for daily report

= One day for weekly report

= One day for monthly report
o Analyze the reason for any ups and downs in the network health and performance.
o Detect any persistent problem in the network health and performance.

e Compare network health and performance of more than two components or component groups
based on historical component health data.

Component Health Chart Detail Reports Options

The Chart Detail report displays the following options:
o Metric(s) Shown on Y1 Axis:
e Metric(s) Shown on Y2 Axis: 2

1The default selection is Memory Utilization (avg)
2The default selection is CPU 5 min Utilization - Exception Rate (max)
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e Chartor Table'

This report tracks up to six metrics for each axis for the selected time period. This report displays
the selected metrics using two Y axis.

e TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

To add another metric, click Options and then click ﬁ (Add new metric).
To remove a metric that you have already added, click Options and then click P (Remove
metric).

o To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

« To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Component Health Dashboard

The Dashboard report provides an overview of the components available on your network using a
combination of gauges, heat charts, and ordered Top 5 lists. The report displays the threshold
violations for volume, error, and availability. Threshold violations can point to a network-related
problem or may indicate that your thresholds within NNMi need to be changed.

To group the data within the dashboard:
1. Click Options.
2. Inthe Grouping By: field, select a topology filter to group the dashboard data.

For example: if you use a grouping option of Node Name, all Availability exceptions that fall
within the time and topology constraints are grouped by Node Name and displayed as a
percentage of the total samples in the left gauge.

Dashboard Sections
Gauge
The gauges provide the following exception count statistics:
o Memory Utilization Exceptions (% samples)

o Buffer Utilization Exceptions (% samples)

1The Chart Detail report enables you to view the data in the tabular format as well. To view the
table, click Options, and then select Table. To view both the chart and the table, click Options,
and then select Chart and Table.
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o Buffer Miss Rate Exceptions (% samples)
o CPU Utilization Exceptions (% samples)

When the NPS database has no data, the needle icons on the gauges on the Dashboard report do
not appear.

Top 5 Lists
The top-5 lists displays nodes responsible for the exceptions showing up in the gauges:
¢ Top 5 Qualified Component Names by Memory Utilization Exceptions

o Top 5 Qualified Component Names by CPU Utilization Exceptions

Top 5 Qualified Component Names by Buffer Utilization Exceptions and Buffer Utilization Heat
Chart

Using the heat chart, you can:
« Analyze the pattern of buffer utilization exception for past one hour.
o Compare the buffer utilization performance of different components.

o Detect the time range in the past one hour when the buffer utilization performance was the
lowest.

Example

If the gauges are showing few or no exceptions, this means that none of your nodes, including the
nodes in the top 5 lists, are experiencing problems with memory, buffer, or CPU utilization.

For example, your network is divided into groups that represent regions or strategic locations for
your enterprise. With the grouping option set to Node Group name, the report lists each of your
strategic Node Groups (as defined within NNMi) and provides the current statistics for exceptions
within each group.

If an unexpected change in exception counts is noted, you can click the appropriate gauge needle or
Node Group within the Top 5 lists, and then launch another report (such as Chart Detail) to
investigate trends or changes within the network as they are occurring.

The thresholds that create exceptions are set from NNMi, not from the iSPI. If you want to set or
modify thresholds, refer to the online help for NNMi administrators.

o To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.
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Component Health Executive Report

The Executive Report provides a broad view of component performance for the selected time
range, using the following graphs:

o Average Memory Utilization and Exception Percentage

¢ Average Backplane Utilization and Exception Percentage

o Average Buffer Utilization and Exception Percentage

o Maximum Rate of Buffer Miss, Buffer Failure, and No Memory Exceptions

o Average 1 minute CPU Utilization and Exception Percentage

o Average Disk Space Utilization and Exception Percentage

This report enables you to:

o View every aspect of performance at once.

o View trends and verify that performance is meeting expectations.

o Identify isolated aberration in the graphs and detect any unexpected performance trend.
The Executive report does not provide options to create graphs based on other metrics.
The default display grain for the Executive report is one hour.

This report shows the data for exceptions only if thresholds for perfformance metrics are set in
NNMi.

e Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

Component Health Executive Report

The Executive Report provides a broad view of component performance for the selected time
range, using the following graphs:

o Average Memory Utilization and Exception Percentage

o Average Backplane Utilization and Exception Percentage

o Average Buffer Utilization and Exception Percentage

o Maximum Rate of Buffer Miss, Buffer Failure, and No Memory Exceptions
o Average 1 minute CPU Utilization and Exception Percentage

o Average Disk Space Utilization and Exception Percentage

This report enables you to:

o View every aspect of performance at once.

« View trends and verify that performance is meeting expectations.

o ldentify isolated aberration in the graphs and detect any unexpected performance trend.
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The Executive report does not provide options to create graphs based on other metrics.
The default display grain for the Executive report is one hour.

This report shows the data for exceptions only if thresholds for performance metrics are set in
NNMi.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

Component HealthHeat Chart Report

The Heat Chart Report tracks the hourly performance of a single metric. The default metric is
Memory Utilization (avg). The default time period is the last 31 days. Performance is color-coded,
making it easy to spot a condition that is gradually worsening and making it easy to distinguish
satisfactory performance from unsatisfactory performance.

Features and Defaults

The legend at the top of the report maps a range of normalized performance values to a particular
color.

Beneath the legend, a table represents the normalized values of a performance metric (rows of the
table represent hours of the day; columns of the table represent days).

Each cell inside the table is color-coded and each cell inside the table indicates a specific value of
the metric. You can also hover the mouse pointer on the cell to see the absolute metric value of
each hour.

The Heat Chart defaults to:

o Nodes/Components = All

e Time Period = Last 31 days

o Hourof Day = All

o Day of Week = All

o Metric = Memory Utilization (avg)

While selecting the Time Controls parameters, you can choose the following values:

A specific day other than Last Day

A specific week this month (or partial week)

A specific week in a previous month (or partial week)

Last 31 days

e A previous month

Note: If you set the Time Range below 24 hours, the following message appears:
This report is not designed to operate with a time range of less than
24 hours. Please modify your time selections.
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This report tracks percentages. If you open Heat Chart from a report that is using a non-supported
metric (for example, Sample Count or Response Time), you will be told to open the report controls
window and select an alternate metric.

Use Case

Use the Heat Chart to identify:

o gradual shifts from one range of performance to another range

o tospot anisolated instance of poor performance that affected the results for one day
o to spot day-of-week or hour of day patterns

o to verify that an abnormal condition returned to normal after a problem was corrected

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

Component Health Managed Inventory Report

Use the Managed Inventory Report to view the number of instances of each topology attribute seen
in the collected data within the selected time range. For example, if the report is run for ‘Last 1
Hour,” you will see the number of unique values for each attribute seen in the data collected over the
last hour. This report can be useful for checking, for example, the number of nodes polled over any
given time range.

You can use the available attributes to filter the data of your interest and create a report that
represents only the elements of your interest. The report presents the list of attributes in the form of
a table; the Count column of the table indicates the number of entries for each attribute. For
example, count 5 for the topology item Node Location means all nodes on your network can be
grouped based on 5 different locations that host the nodes.

You can use the following topology attributes with the Component Health reports:
¢ Qualified Component Name

e Component Name

e Component Type

e Component ID

e Component UUID

¢ Node Name

¢ Node Contact

¢ Node Location

¢ Node Family
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o Node Vendor
e NodelD
e Node UUID

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

The Managed Inventory report may take significant time to build if you select a time range greater
than one day.

Component HealthMost Changed Report

This report compares performance of the components for two different (consecutive) time periods
and ranks components by the amount of change. The sort order is most-changed to least-changed.

Features and Defaults

This report contains one table and provides data for one metric only.

The table presents the following columns:

e Component

o Performance for the previous time period

o Performance for the selected time period

o Growth, expressed as a percentage increase

e Change

The Most Changed report defaults to:

o Grouping by Elements = Qualified Component Name

o Start Date/Time = Depends on default Time Range and data available in the database
e Time Range = Last 1 hour

o Hourof Day = All

o Day of Week = All

o Rank Metric = Memory Utilization (Avg%)

e Top N Option=Top 10

By default, the report groups data by Qualified Component Name. You can select multiple grouping

attributes by using the E (Add New Grouping) button. Use the x (Remove Grouping) button
to remove a grouping attribute.

Use Case

Use this report to identify components that saw significant change from one time period to the next.
Significant change could point to a developing problem. The report shows the rate of change in the
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Growth Rate column. You can change the ranking metric and you can change how many elements
are listed.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

Component Health Overview Report

The Overview Report displays the utilization and performance of the most commonly monitored
metrics in Component Health extension pack.

Using this report, you can:
o Monitor the daily utilization and performance of a set of pre-defined metrics.

¢ Identify the components with unusual performance or utilization and drill down to other reports to
analyze the problem.

« Rank the components based on their utilization levels.

« Identify the metrics that are close to the threshold. Use the following sections to identify such
components:
= Top 10 CPU Forecasts

= Top 10 Memory Forecasts

The default display grain for this report is one hour. To select a different time grain or time range,
use the Time Controls tab in the navigation panel.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the topology filters, use the Topology Filters tab in the navigation panel.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

You cannot select the metrics for this report.

Component Health Peak Period Report

The Component Health Peak Period Report ranks the utilization and performance of a component
during the busiest time of the selected time range.

Using this report, you can:
o Identify the performance and utilization of the selected metrics during the peak period.

« lIdentify the components that have the highest or lowest performances or utilization levels during
the peak period.

o Compare the performance for multiple components during the peak period using this report.
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Use Case
Use this report to:
o Identify a group of components or nodes having a common network performance problem.

« Identify the component that is suffering from a persistent performance problem.
Component Health Peak Period Report Options

e Top/ Bottom NT
o Select Metric(s)2
e Grouping by Time Period3

This report tracks up to six metrics over the selected time period.

To add another metric, click Options and then click '{F_hl

To remove a metric that you have already added, click Options and then click X_

To select a range of value for the metric, click '{F_hl click ¥, and select a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five CPUs with the average memory utilization between 10%
and 90% type the following ranges:

e 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value

By default, the report groups data by Qualified Component Name. You can select multiple grouping

attributes by using the E (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

Tip:
o Use this report to identify the period when the component utilization was the highest.

o Check this report once a day to see which component may need special attention.

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

2Select the metrics based on which you want to generate the report.

SEnables you to group the report data based on a specific time grain. Click Add New Grouping icon
to add a new group.
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o Check this report periodically throughout the day to see which component is performing at the
extremes and may need special attention.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

« Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Component Health Threshold Sleeve Report

This report analyzes how close the metric performance value is to the threshold levels. In other
words, this report enables you to analyze when the metric will reach the threshold.

Using this report, you can:
o Forecast over-utilization or under-utilization of the selected component.
o Detect if the metric performance is about to cross the high and low thresholds.

For example, if you generate the Threshold Sleeve Chart report for Buffer Utilization (avg), the
chart displays the how close the average buffer utilization is to the high and low threshold.

o Save multiple Threshold Sleeve Reports for a specific metric for different time ranges, and
analyze the metric performance trend.

This report supports one metric.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

« To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Component HealthTop N Report
This report ranks network elements by the metric you select.

Use this report to spot the element that performed at the extremes. You can use this report to
analyze the historical data for elements that are exhibiting unusual utilization levels.

Using this report you can:
o Detect the component having a health or performance problem.

o Analyze the utilization of the NNMi managed network components based on a specific time
range.

¢ Detect the over-utilized and under-utilized components in the network.

o Compare the performance for multiple network components using this report.
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Example

Some of the routers in your network are performing poorly. Using this report, you can group the
routers reporting highest average response time. The router reporting the highest response time is
ranked first.

Component Health Top N Reports Options

The Top N report displays the following options:
o Top / Bottom NT

¢ Select Metric(s)z: The report ranks the selected nodes or components based on the value of the
first metric listed in the Select Metric(s) field.

o Display Time Series Chart3
o Grouping By4

This report tracks up to six metrics for each metric type for the selected time period. The report
supports the following metric types:

o The main metric: Also known as the primary metric. The report is generated based on this
metric.

o The secondary metric: Displays the performance of the metric that should overlay the main
(primary) metric.

To add a new metric, click Options and then click 7 (Add new metric).
To remove a metric that you have already added, click Options and then click P (Remove
metric).

To select a range of value for the metric, click w (Apply Filter), and select a range of metric value
that the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five CPUs with the average memory utilization between 10%
and 90% type the following ranges:

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

2Select the metrics based on which you want to generate the report.

3Select Yes to view the detail chart with the table. Select No to hide the chart and display only the
table. The created Top N Report displays the graphical representation of the metric values for the
components over the selected time range.

4Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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e 0.10r10% as Lowest Value

o 0.90r90% as the Highest Value

By default, the report groups data by Qualified Component Name. You can select multiple grouping

attributes by using the E (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

The Time Series Chart report displays the selected metrics usingtwo Y axis.

e TheleftY axis (also known as the Y1 axis) displays the performance of the primary metric.

o Theright Y axis (also known as the Y2 axis) displays the performance of the secondary metric.

Tip :

By default, Top N Report does not display the Time Series Chart. To view the chart with the
detail table,perform any of the following steps:
= Select Options > Display Time Series Chart > Confirm Selection.

= Click Show Chart link below the detail table.
Check this report once a day to see which network component may need special attention.

Check this report periodically throughout the day to see which network components are
performing at the extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Component Health Top N CSV Report

Top N report may have performance problem, as it retrieves huge amount of data from the NPS
database for the selected time range. To resolve this problem, NPS enables you to schedule the
following reports in CSV format:
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e TopNCSV report1
e Top N Detail CSV repor’c2

Component HealthTop N Chart Report

Like the Top N report, this report also ranks the components by the metric you select. Moreover, the
Top N Chart report displays an individual chart for each topology filter and metric selected for the
report.

Using this report, you can:

e Spot the component that performed at the extremes.

o Analyze the historical data for components that are exhibiting unusual utilization levels.

¢ Detect the component having a health or performance problem.

o Analyze the utilization of the NNMi managed components based on a specific time range.
o Detect the over-utilized and under-utilized components in the network.

o Detect the underlying reason of a persistent problem with a component. You can compare the
performance for multiple components using this report.

Example
Some of the routers in your network are performing poorly. Using this report, you can group the
routers reporting highest average response time. The router reporting the highest response time is

ranked first.

Component Health Top N Chart Reports Options

The Top N report displays the following options:

The Top N CSV report ranks selected topology element based on the utilization level of the
selected metric in the descending order.

2The Top N Detail CSV report lists the metric utilization for the selected topology element based on
the selected time grain.

This report displays the ranks the elements based on the total metric utilization for the selected time
range and breaks up the metric utilization value for each time grain. For example, you selected the
following options for the Top N CSV report:

Time Range: Last 24 Hours. The default Display Grain for this time range is one hour.

Topology Element: Qualified Component Name

Metric: Memory Utilization (avg) and CPU 1min Utilization (avg)

The displayed report ranks the Qualified Component Names based on the average memory
utilization. The Qualified Component Name with the highest memory utilization receives the highest
rank. The Top N Detail CSV report then calculates and lists the one minute CPU utilization for
these components for every hour in last 24 hours.
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e Top / Bottom N1
o Select Metric(s)2
e Grouping By3

This report tracks up to six metrics for each axis for the selected time period. This report displays
the selected metrics usingtwo Y axis.

o Theleft Y axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

e TherightY axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

To add another metric, click Options and then click ] (Add new metric).

To remove a metric that you have already added, click Options and then click P (Remove
metric).

To select a range of value for the metric, click w (Apply Filter), and select a range of metric value
that the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five CPUs with the average memory utilization between 10%
and 90% type the following ranges:

¢ 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value

By default, the report groups data by Qualified Component Name. You can select multiple grouping

attributes by using the E (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

o To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

« To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the

selected component.
2Select the metrics based on which you want to generate the report.
3Organize the report data based on a specific parameter. Click Add New Grouping icon to add a

new group.
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iISPI for Performance Reportlets

In a large enterprise network the NNM iSP| Performance products1 may produce a large amount
of data and large cardinality. This means that these networks often have a very large amount of
unique IP addresses, source nodes and destination nodes, interfaces, and components each

producing large amount of data. Generating reports using such large data volume may be time
consuming.

Reportlets enable you to generate quick impressions of the larger reports using the iSPI for
Performance Dashboards.

Viewing iSPI for Performance Reportlets
To display the reportlets:

1. Loginto Network Performance Server (NPS) Home Page.

2. Onthe left navigation panel, select Dashboard Reportlets.
3. Select an extension pack and then select a reportlet.

You can also create custom dashboards using the reportlets. See Creating Custom Dashboards
Using Bl Server Portal for information on the procedure to create the custom dashboards.

Baseline Metric Snapshot with Range
Displays the aggregated metric performance for the selected time range.

Enables you to:

o Build a performance history for the selected baseline metric and analyze how the metric
performance changes over time.

Such history may help you to select an expected performance level for the metric
o Compare the performance for multiple metrics over a specified time range.

Though you can generate snapshot report for a single metric, you can save the snapshot report
for various metrics and compare the performance of each metric over a time range.

This reportlet supports one metric.
Baseline Sleeve Chart
Analyzes how close the metric performance value is to the threshold levels.
Enables you to:
o Detect if the metric performance is about to cross the high and low thresholds.

For example, if you generate the Baseline Sleeve Chart reportlet for Utilization (avg), the chart
displays how many exceptions are raised on average utilization in the past one day,

TNNM iSPI Performance for Metrics, NNM iSPI Performance for Quality Assurance, and NNM
iSPI Perforance for Traffic
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o Save multiple Sleeve Reports for a time range, and for analyze the trend of performance for the
metric.

This reportlet supports one metric.
Baseline Sparkline

Evaluates the trend of how the selected baseline metric value has changed for the selected time
range.

Enables you to:
¢ Analyze the variations in the performance for the selected metric.
o Decide whether the expected behavior for the selected metric should be reassessed.
This reportlet supports one metric.
Baseline Sparkline with Range

Evaluates the trend of how the selected baseline metric value has changed for the selected time
range.

Enables you to:

o Evaluate the performance trend of the selected metric for the selected time range.

o Compare the present performance trend with the normal (expected) performance range.
o Measure the performance of past one day in percentage.

This reportlet supports one metric.
Calendar
Displays a comparative study of the selected Primary Metric! and Secondary Metric?

The default display grain is set to one hour. You cannot change the display grain of this reportlet.

Enables you to monitor the following:
o Daily component utilization
« Volume of data passed through the component for past one day
o Performance of the component for past one day
This reportlet supports two metrics.
Gauge
Evaluates the metric for the selected point of time.

Select only the metrics that displays the percentage values.

Enables you to:

TEnables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

Enables you to select the metric that would overlay the primary metric. The secondary metric that
you select is displayed on the right Y axis of the report.
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o Measure the daily performance of the selected metric.

o Detect any abnormal or unexpected performance level.

This reportlet supports one metric.

When the NPS database has no data, the needle icon on the gauge does not appear.

Heat Chart

Grades the performance of the selected metric for the selected time range.
The metric performance is aggregated based on an hourly display grain.
Enables you to:

« View how the component performance gets affected by a varying metric.
o Compare the hourly performance of the selected metric.

o Detect the time range when the component performance was affected adversely because of the
fluctuating metric value.

This reportlet supports one metric.

Metric Snapshot
Displays the metric performance for the selected time range.

Enables you to:

o Build a performance history for the selected metric and analyze how the metric performance
changes over time.

Such history may help you to decide the baseline value for the metric
o Compare the performance for multiple metrics over a specified time range.

Though you can generate snapshot report for a single metric, you can save the snapshot report
for various metrics and compare the performance of each metric over a time range.

This reportlet supports one metric.
Most Changed
Compares the metric performance between the following:
¢ Selected time range
o Period preceding the selected time range
Aggregates the metric utilization and ranks the performance in a descending order.
Enables you to:
o Measure the performance fluctuations for the components.
o Detect the top N components having a common performance or utilization problem.

You can enhance the report usability using the following features:
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e Top / Bottom N1
o Grouping By2
This reportlet supports one metric.
Multimetric Chart
Analyzes the performance trend for the selected metrics for the selected time range.
Enables you to:
o Perform comparative analysis of the selected metrics for each display grain.
The default display grain is one hour.
o Analyze the reason for any ups and downs in the component performance.
o Detect any persistent problem in the component performance.

This reportlet supports up to six metrics.

Simple Bar and Line Chart
Displays the trend of component performance for past one day using the following values:
e Primary Metric3 on the bar chart
o Secondary Metric# on the line chart
Enables you to:
o Compare the performance trends of multiple metrics.

« Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports two metrics.

Simple Bar Chart
Compares the performance of two metrics for the selected time range.
Enables you to:
e Compare the performance trends of multiple metrics.

¢ Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports two metrics.

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

2Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.

SEnables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

4Enables you to select the metric that would overlay the primary metric. The secondary metric that
you select is displayed on the right Y axis of the report.
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To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Chart

Analyzes the utilization trend for the selected metrics for the selected time range.

Enables you to:
o Perform comparative analysis of the selected metrics for each display grain.
The default display grain is one hour.
o Analyze the reason for any ups and downs in the component performance.
o Detect any persistent problem in the component performance.
This reportlet supports two metrics.
Simple Table
Analyzes the utilization trend for the selected metrics for the selected time range.
The default display grain is one hour.
Enables you to:
¢ Analyze the hourly performance of the metrics.
o Detect any abnormal or unexpected component performance.

« Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports up to six metrics.
Sparkline

Evaluates the trend of how the selected metric value has changed for the selected time range.
Enables you to:

¢ Analyze the variations in the performance for the selected metric.

¢ Decide whether the expected behavior for the selected metric should be reassessed.

This reportlet supports one metric.

Threshold Sleeve Chart
Analyzes how close the metric performance value is to the threshold levels.
Enables you to:
o Detect if the metric performance is about to cross the high and low thresholds.

For example, if you generate the Exception Sleeve Chart reportlet for Utilization (avg), the chart
displays how many exceptions are raised on average utilization in the past one day,

o Save multiple Sleeve Reports for a time range, and analyze the trend of performance for the
metric.

This reportlet supports one metric.
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Top N Chart

Ranks the individual contribution of each metric for the component performance for the selected
time range.

The performance of the component is aggregated on hourly basis.

Enables you to:

o Spot the components for which the performance metrics present extreme values.

o Investigate the aggregated data for the components that are exhibiting unusual utilization levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the components.

o Group the report data based on a specific parameter. Click @ Add Group to add a subgroup.
This reportlet supports one metric.
Top N Line Chart
Ranks the utilization trend for the selected metrics for the selected time range.
The performance of the component is aggregated on hourly basis.
Enables you to:
o Spot the components for which the performance metrics present extreme values.
o Investigate the aggregated data for the components that are exhibiting unusual utilization levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the components.

o Group the report data based on a specific parameter. Click E Add Group to add a subgroup.

This reportlet supports one metric.
Top N Stacked Chart
Ranks the individual contribution of each component based on the selected metrics.
The performance of each component is aggregated for the default display grain of one hour.
Enables you to:
o Spot the components for which the performance metrics present extreme values.
¢ Investigate the aggregated data for the components that are exhibiting unusual utilization levels.
o Detect the network path having a common network performance problem.
This reportlet supports up to six metrics.
Top N Table

Ranks the components based on the selected metric.

Enables you to:
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o Spot the components for which the performance metrics present extreme values.
« Investigate the aggregated data for the components that are exhibiting unusual utilization levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the components.

o Group the report data based on a specific parameter. Click E Add Group to add a subgroup.

This reportlet supports up to six metrics.

Top N Table With Bars

Ranks the components based on the selected metric and displays a horizontal bar to depict the
aggregated metric value.

Enables you to:
o Spot the components for which the performance metrics present extreme values.
o Investigate the aggregated data for the components that are exhibiting unusual utilization levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the components.

o Group the report data based on a specific parameter. Click '{F_bl Add Group to add a subgroup.

This reportlet supports up to six metrics.
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Interface Health Reports

The Interface Health reports show the performance data for network interfaces. Graphs and
charts on Interface Health reports reflect the details that help you identify the following:

¢ Interface utilization
e Errors ininterfaces

Interface discard rate

Availability of interfaces

Use Interface Health reports to determine the status of the interfaces on your network.

Opening Reports from NNMi
From the NNMi Console, you have the following options to open reports:
o Move from NNMi to the iSPI, and launch reports from the Report Menu.
e Launch pre-filtered reports directly from NNMi.

If you are interested in a particular node group, node, or interface, you will probably want to launch
a pre-filtered report from NNMi; otherwise, open a workspace view from NNM, move to the iSPI,
and begin your investigation from Report Menu. To move from NNM to the iSPI:

1. Log ontothe NNMi console.

2. Select aworkspace.

3. Open a view of nodes, interfaces, or incidents.
4. Select Actions > Reporting - Report Menu
Related Topics

Glossary of Metrics

iSPI for Performance Metrics Types
The Interface Health extension pack provides you with the following types of metrics:
o Gauge:‘I

o Percent:2

TMetrics with single non-cumulative values. For example: SNMP Response Time, Throughput
(bps). The iSPI Performance for Metrics calculates the average, minimum, and maximum values
while aggregating the values of gauge metrics.

2Metrics with single non-cumulative percentage values. For example: Discards Rate, Error Rate.
The iSPI Performance for Metrics calculates the average, minimum, and maximum values while
aggregating the values of percent metrics.
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« Counter:!

o Exceptions:2

TMetrics that have incremental values. For example: Volume - Bytes, Volume - Packets. The
iSPI Performance for Metrics calculates the sum while aggregating the values of counter metrics.
2The exceptions metrics indicate the count or percentage of samples that are out of the threshold
boundary defined in NNM.i. If you want to use exception metrics, you must set the thresholds in
NNMIi by following the instructions in the Configure Threshold Monitoring for Interfaces section in
NNMi Help for Administrators. The Exception (sum) metrics indicate the count of samples that
are outside the threshold boundary (depends on the polling interval); the Exception (Avg%, Max%,
Min%) metrics indicate the percentage of sample outside the threshold boundary (independent of
the polling interval).
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Glossary for the Basic iSPI for Performance Metrics

Metric Name Description

Discards Packets Total number of discarded packets, in and out combined,
followed by the number of discarded incoming packets and

» Discards Packets (sum) the number of discarded outbound packets.

o Discards Packets In (sum)

e Discards Packets Out (sum)

Discard Rate Total number of packets with discards as a percentage of
total packets (minimum, maximum, and average); followed

e Discard Rate (avg, min, and by the number of discarded packets incoming, as a

max) percentage of total incoming packets (minimum, maximum,
¢ Discard Rate In (avg, min, and average), and the number of discarded packets
and max) outbound, as a percentage of total outbound packets

. . (minimum, maximum, and average).
¢ Discard Rate Out (avg, min,

and max)

Errors Total number of packets with errors, in and out combined;
number of incoming packets with errors; number of

e Emors - Packets (sum) outbound packets with errors.

o Errors - Packets In (sum)

e Errors - Packets Out (sum)

Error Rate Total number of packets with errors as a percentage of total
packets; followed by number of packets with errors received
as a percentage of total packets received, and number of

o Error Rate (min) packets with errors transmitted, as a percentage of total
packets transmitted.

o Error Rate (avg)

e Error Rate (max)

o Error Rate In (avg)

¢ Error Rate In (min)

o Error Rate In (max)
e Error Rate Out (avg)
e Error Rate Out (min)

o Error Rate Out (max)

Throughput (bps) e Total throughput on the interface (in bits-per-second):
= Throughput (bps) (avg)

= Throughput (bps) (min)
= Throughput (bps) (max)
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¢ Incoming throughput on the interface (in bits-per-
second):
= Throughput In (bps) (avg)

= Throughput In (bps) (min)
= Throughput In (bps) (max)

o Outgoing throughput on the interface (in bits-per-second):
= Throughput Out (bps) (avg)

= Throughput Out (bps) (min)
= Throughput Out (bps) (max)

Utilization Exceptions
o Utilization Exceptions (sum)

o Utilization Exceptions
(Y%osamples)

Number of exceptions; percentage of samples above or
below the threshold range set in NNMi.

Discard Exceptions
o Discard Exceptions (sum)

o Discard Exceptions
(Y%osamples)

Number of packet discard exceptions; percentage of
samples above the discard exception threshold.

Error Exceptions
o Error Exceptions (#samples)

o Error Exceptions (%samples)

Number of packet error exceptions; percentage of samples
above the error exception threshold.

SNMP Response Time

SNMP Response Time (msec) (avg, min, max): time for
interface/device to respond to polling request

Sample Count

Sample count = number of polled samples.

Utilization - avg%
o Utilization (avg)
o Utilization In (avg)

o Utilization Out (avg)

Average utilization from any sample

Utilization - max%
o Utilization (max)
¢ Utilization In (max)

o Utilization Out (max)

maximum utilization in (the largest value from any sample);
maximum utilization out (the largest value from any sample)

Utilization - min%

minimum utilization in (the smallest value from any sample);
minimum utilization out (the smallest value from any
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o Utilization (min)
o Utilization In (min)

o Utilization Out (min)

sample)

Volume
e Volume - Packets (sum)

¢ Volume - Packets In (sum)

e Volume - Packets Out (sum)
¢ Volume -Bytes (sum)

e Volume - Bytes In (sum)

e Volume - Bytes Out (sum)

Total number of data packets or bytes passing through the
network

Period - Length (secs) (sum)

The duration (in seconds) between consecutive polling
cycles of NNMi.

countDistinct Metrics

The Interface Health extension pack provides you with an
additional set of metrics—the countDistinct metrics. The
countDistinct metrics are the counter metrics that help you
track the number of interfaces over a period of time. You can
use a countDistinct metric on a report with a topology filter
selection to track the number of interfaces that belong to the
selected topology group.

For example, if you select the Qualified Interface Name
metric with the topology filter selection of a particular
Interface Group, you can track the number of interfaces that
belong to the selected group from the generated report.

Some of the available countDistinct metrics are:
¢ Qualified Interface Name

o Interface Name

¢ Interface Alias

¢ Interface Descr

o Interface Index

o Interface Type

o Interface Physical address

o Interface Speed (In:Out)

e Interface ID

¢ Interface UUID
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e Node Name
o Node Contact
o Node Location
o Node Family
¢ Node Vendor
e NodelD

e Node UUID

Glossary for Polling Metrics

Metric Name Description

Target Error (avg) Generated if the target interface returns any of the following
SNMP error responses:

e Authentication error
¢ Nosuchname

¢ No such object.

Reboot (avg) Generated if the target interface was restarted during the
poll and no data could be retrieved from the interface.

NNMi checks the sysUptime metric to determine whether
the interface was restarted during the last poll.

Invalid Data (avg) Generated when NNMi has successfully polled data from
the target, but has determined that the data is invalid. For
example, this metric is calculated when the number of
packets is greater than the number of octets.

Unresponsive Target (avg) Generated when the SNMP agent did not respond when
collecting metrics for a particular polling policy.
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Glossary for Packet Type Counts Metrics

Metric Name Description

NonUnicast - Packets (sum)

Total number of packets received and sent
by the interfaces using the non-unicast
protocol

NonUnicast - Packets In (sum)

Total number of packets received by the
interfaces using the non-unicast protocol

NonUnicast - Packets Out (sum)

Total number of packets sent by the
interfaces using the non-unicast protocol

Multicast - Packets (sum)

Total number of packets received and sent
by the interfaces using the multicast
protocol

Multicast - Packets In (sum)

Total number of packets received by the
interfaces using the multicast protocol

Multicast - Packets Out (sum)

Total number of packets sent by the
interfaces available using the multicast
protocol

Unicast - Packets (sum)

Total number of packets received and sent
by the interfaces using the unicast protocol

Unicast - Packets In (sum)

Total number of packets received by the
interfaces using the unicast protocol

Unicast - Packets Out (sum)

Total number of packets sent by the
interfaces using the unicast protocol

Broadcast - Packets (sum)

Total number of packets received and sent
by the interfaces using the broadcast
protocol

Broadcast - Packets In (sum)

Total number of packets received by the
interfaces using the broadcast protocol

Broadcast - Packets Out (sum)

Total number of packets sent by the
interfaces using the broadcast protocol

Unknown Protocol - Packets (sum)

Total number of packets received and sent
by the interfaces using any protocol other
than the following ones:

¢ Unicast

o Non-unicast
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o Multicast

e Broadcast

Average Packet Size - Bytes (avg) Average number of bytes received and
transmitted by the selected interface for the

selected time range.
Calculated using the following method:

Volume - Bytes (sum) / Volume -
Packets (sum)

Average Packet Size - Bytes In (avg) Average number of bytes received by the
selected interface for the selected time

range.
Calculated using the following method:

Volume - Bytes In (sum) /
Volume - Packets In (sum)

Average Packet Size - Bytes Out (avg) Average number of bytes transmitted by the
selected interface for the selected time

range.
Calculated using the following method:

Volume - Bytes Out (sum) /
Volume - Packets Out (sum)

Glossary for LAN Metrics
Available for any of the following MIB:
e ETHERLIKE -MIB
e OLD-CISCO-INTERFACES-MIB
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Metric Name Description

LAN FCS Error Count

Sum

Average

Minimum

Maximum

Baseline Average (avg)
Baseline Deviation (avg)
Slope (avg)

Upper Normal (max)
Lower Normal (min)
Days To Threshold (min)

Baseline Exception Count
(sum)

Baseline Exception Rate
(avg)

Baseline Intercept
Component (avg)

Baseline Trend Component
(avg)

Baseline Seasonal
Component (avg)

Anomaly Sample Flags

Number of frames received on the selected interface that
consist of the necessary number of octets in length but do not
pass the FCS check.

This count does not include the frames received with any of
the following errors:

o frame-too-long
o frame-too-short

The count of LAN FCS error increases when the MAC service
returns a frameCheckError to the LLC or another MAC user.

NNMi enables you to define an upper and a lower thresholds
for the count of FCS WLAN Errors.

See HP Network Node Manager i Software Online Help for
Administrators for information about how to define thresholds
using the Threshold Configuration form.
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Metric Name Description

Window (sum)

o Baseline Linear Samples
Used (avg)

o Baseline Seasonal
Samples Used (avg)

e Upper Threshold (max)
e Lower Threshold (min)

e Threshold Exception Count
(sum)

e Threshold Exception Rate
(avg)

LAN Collision Count (sum) Number of output collisions detected on the selected interface
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Metric Name Description
LAN Collision Rate Percentage of output collisions detected on the selected
interface for the selected time range
e Average
- Calculated using any of the following methods based on the
e Minimum .
interface type:
e Maximum

e ((100.0 * collisonsOutl) /
(ifHCOutUcastPktsl +
ifHCOutMulticastPkts! +
ifHCOutBroadcasthtsl)

e ((100.0 * collisonsOut) /
(1 fOutUcastPkts! + ifOutNUcastPkts?!)

e ((100.0 * collisonsOut) / (ifOutUcastPkts
+ ifOutMulticastPkts + ifOutBroadcastPkts)

LAN Deferred Frames (sum) [ Total number of frames for which the first transmission
attempt on the selected interface is delayed because the
medium is busy

The count does not include the following:
o Frames involved in collisions
o Interfaces that are operating in full-duplex mode

o Frames delayed because of discontinuities in the
management system

LAN Alignment Errors (sum) Total number of input packets that had cyclic redundancy
checksum errors

Input Queue Drops Number of packets the selected interface dropped because
the input queue was full

INumber of output collisions detected on the selected interface for the selected time range
INumber of packets that higher-level protocols requested be transmitted, and which were not
addressed to a multicast or broadcast address at the sub-layer for the selected interface. These
include those packets that were discarded or not sent.

INumber of packets transmitted to a multicast address per second during the selected time range
INumber of packets transmitted to a broadcast address per second during the selected time
range

INumber of packets that higher-level protocols requested be transmitted, and which were not
addressed to a multicast or broadcast address at the sub-layer for the selected interface. These
include those packets that were discarded or not sent.

INumber of packets that higher-level protocols requested be transmitted to a non-unicast (i.e., a
subnet roadcast or subnet multicast) address. These include the packets that were discarded or
not sent.
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Metric Name Description
e Sum NNMi enables you to define an upper and a lower thresholds

« Baseline Average (avg) for the count of input queue drops.

See HP Network Node Manager i Software Online Help for
Administrators for information about how to define thresholds
o Baseline Slope (avg) using the Threshold Configuration form.

o Baseline Deviation (avg)

e Upper Normal (max)
e Lower Normal (min)
e Days To Threshold (min)

o Baseline Exception Count
(sum)

o Baseline Exception Rate
(avg)

o Baseline Intercept
Component (avg)

o Baseline Trend Component
(avg)

e Baseline Seasonal
Component (avg)

o Anomaly Sample Flags
Window (sum)

o Baseline Linear Samples
Used (avg)

e Baseline Seasonal
Samples Used (avg)

o Upper Threshold (max)
e Lower Threshold (min)

e Threshold Exception Count
(sum)

o Threshold Exception Rate

(avg)

Output Queue Drops Number of packets the selected interface dropped because
Sum the output queue was full

° u

NNMi enables you to define an upper and a lower thresholds

* Baseline Average (avg) for the count of output queue drops.

o Baseline Deviation (avg)

See HP Network Node Manager i Software Online Help for
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Metric Name Description

Baseline Slope (avg)
Upper Normal (max)
Lower Normal (min)
Days To Threshold (min)

Baseline Exception Count
(sum)

Baseline Exception Rate
(avg)

Baseline Intercept
Component (avg)

Baseline Trend Component
(avg)

Baseline Seasonal
Component (avg)

Anomaly Sample Flags
Window (sum)

Baseline Linear Samples
Used (avg)

Baseline Seasonal
Samples Used (avg)

Upper Threshold (max)
Lower Threshold (min)

Threshold Exception Count
(sum)

Threshold Exception Rate
(avg)

Administrators for information about how to define thresholds
using the Threshold Configuration form.

Note:The ETHERLIKE-MIB polling policies override the OLD-CISCO-INTERFACES-MIB polling
policies, if the selected interface supports both ETHERLIKE-MIB and OLD-CISCO-
INTERFACES-MIB, and thus both State Poller policies.

Glossary for Wireless LAN Metrics

Available only on WLAN interfaces — Following IEEE802dot11 performance policy
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Metric Name Description

SuccessfulRetryCount (sum)

Total number of times the MSDU is successfully
transmitted after one or more re-transmissions.

RTSSuccessCount (sum)

Total number of CTS ! received in response to an RTs™.

TransmittedFragmentCount
(sum)

Total number of acknowledged MPDU with an individual
address in the address 1 field or an MPDU with a multicast
address in the address 1 field of type Data or
Management."

MaxedOutTransmitAttempts
(sum)

Total number of times the MSDU is not transmitted
successfully due to the number of transmit attempts
exceeding either the dot11ShortRetryLimit or
dot11LongRetryLimit.

ReceivedFragmentCount (sum)

Total number of successfully received MPDU of type Data
or Management.

UndecryptableFrames (sum)

Total number of frames received with the WEP subfield of
the Frame Control field set to one and the WEPOn value for
the key mapped to the TA's MAC address indicates that
the frame should not have been encrypted or that frame is
discarded due to the receiving STA not implementing the
privacy option.

RTSFailureCount (sum)

Total number of CTS signals failed to be sent in response
toan RTS.

ACKFailureCount (sum)

Total number of times the ACK was not received when
expected.

FrameDuplicateCount (sum)

Total number of frames received that the Sequence Control
field indicates is a duplicate.

FCSErorCount (sum)

Total number of FCS errors detected in received MPDU.

Glossary for Wireless LAN Metrics
Available only on WLAN interfaces supporting CISCO-DOT11-ASSOCIATION-MIB

Metric Name

Description

NumActiveWirelessClients

Number of wireless clients currently associating with the
selected device on the selected interface

Clearto Send
1 Request to Send
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e Average You can select the device and interface using the
o Minimum NPS Topology Selector.
. NPS calculates the metric to display average, minimum,
e Maximum . . . .
and maximum number of wireless clients associated to the
selected interface.
NumActiveBridges Number of bridges currently associating with this device on
the selected interface.
o Average
Minimum You can select the device and interface using the
¢ NPS Topology Selector.
e Maximum

NPS calculates the metric to display average, minimum,
and maximum number of bridges associated to the
selected interface.

NumActiveRepeaters
o Average
e Minimum

e Maximum

Number of repeaters currently associating with this device
on the selected interface.

You can select the device and interface using the
NPS Topology Selector.

NPS calculates the metric to display average, minimum,
and maximum number of repeaters associated to the
selected interface.

StationsAssociated (sum)

Total number of stations associated with this device on the
selected interface.

Displays the number of stations associated to the interface
since the device re-started.

StationsAuthenticated (sum)

Total number of stations authenticated with this device on
the selected interface.

Displays the number of stations authenticated on the
interface since the device re-started.

StationsRoamedIn (sum)

Total number of stations roamed (transferred) from another
device to this device on the selected interface

Displays the number of stations transferred to the selected
interface since the device re-started.

StationsRoamedAway (sum)

Total number of stations roamed (transferred) away from
this device on the selected interface

Displays the number of stations transferred from the
selected interface since the device re-started.

StationsDeauthenticated (sum)

Total number of stations de-authenticated with this device
on the selected interface
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Displays the number of stations for which the
authentication were removed from the selected interface
since the device re-started.

StationsDisassociated (sum)

Total number of stations disassociated with this device on
the selected interface

Displays the number of stations that were disassociated
from the selected interface since the device re-started.

Glossary for SDH DS1 Metrics

Available only for DS1 Interfaces

Metric Name Description

DSx1SESs Rate of Severely Errored Seconds encountered by the selected DS1 interface
Rate in one second.
e Average The object returns the total number of Severely Errored Seconds encountered
. by the interface in past 15 minutes.
e Minimum
Maxi NPS calculates the rate of Severely Errored Seconds per second.
e Maximum
NPS calculates the metric to display average, minimum, and maximum rate of
Severely Errored Seconds encountered by the selected interface.
DSx1SEFSs Rate of Severely Errored Framing Seconds encountered by the selected DS1
Rate interface in one second.
e Average The object returns the total number of Severely Errored Framing Seconds
- encountered by the interface in past 15 minutes.
e Minimum
. NPS calculates the rate of Severely Errored Framing Seconds per second.
e Maximum

NPS calculates the metric to display average, minimum, and maximum rate of
Severely Errored Framing Seconds encountered by the selected interface.

DSx1ESs Rate

Rate of Errored Seconds encountered by the selected DS1 interface in one
second.

e Average
- The object returns the total number of Errored Seconds encountered by the

e Minimum . . .

interface in past 15 minutes.
Maxi

¢ Maximum NPS calculates the rate of Errored Seconds per second.
NPS calculates the metric to display average, minimum, and maximum rate of
Errored Seconds encountered by the selected interface.

DSx1UASs Rate of Unavailable Seconds encountered by the selected DS1 interface in

Rate one second.

e Average The object returns the total number of Errored Seconds encountered by the

interface in past 15 minutes.

Page 17 of 51



PerfiSPI (8.13) Online Help: Interface Health
Interface Health Reports

Metric Name Description

e Minimum NPS calculates the rate of Errored Seconds per second.
¢ Maximum NPS calculates the metric to display average, minimum, and maximum rate of
Errored Seconds encountered by the selected interface.
DSx1PCVs/sec | Rate of Path Coding Violations encountered by the selected DS1 interface in
one second.
o Average
- The object returns the total number of Path Coding Violations encountered by
e Minimum . . .
the interface in past 15 minutes.
* Maximum NPS calculates the rate of Path Coding Violations per second.
NPS calculates the metric to display average, minimum, and maximum rate of
Path Coding Violations encountered by the selected interface.
DSx1DMs Rate | Rate of Degraded Minutes encountered by the selected DS1 interface in one
second.
o Average
- The object returns the total number of Degraded Minutes encountered by the
e Minimum . . .
interface in past 15 minutes.
* Maximum NPS calculates the rate of Degraded Minutes per second.
NPS calculates the metric to display average, minimum, and maximum rate of
Degraded Minutes encountered by the selected interface.
DSx1BESs Rate of Bursty Errored Seconds encountered by the selected DS1 interface in
Rate one second.
e Average The object returns the total number of Bursty Errored Seconds encountered by
- the interface in past 15 minutes.
e Minimum
. NPS calculates the rate of Bursty Errored Seconds per second.
e Maximum
NPS calculates the metric to display average, minimum, and maximum rate of
Bursty Errored Seconds encountered by the selected interface.
DSx1LESs Rate of Line Errored Seconds encountered by the selected DS1 interface in
Rate one second.
e Average The object returns the total number of Line Errored Seconds encountered by
. the interface in past 15 minutes.
e Minimum
. NPS calculates the rate of Line Errored Seconds per second.
e Maximum
NPS calculates the metric to display average, minimum, and maximum rate of
Line Errored Seconds encountered by the selected interface.
DSx1LCVs/sec | Rate of Line Coding Violations encountered by the selected DS1 interface in
one second.
e Average
The object returns the total number of Line Coding Violations encountered by
the interface in past 15 minutes.
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Metric Name Description

e Minimum NPS calculates the rate of Line Coding Violations per second.

e Maximum NPS calculates the metric to display average, minimum, and maximum rate of
Line Coding Violations encountered by the selected interface.

DSx1CSSs Rate of Controlled Slip Seconds encountered by the selected DS1 interface in

Rate one second.

e Average The object returns the total number of Controlled Slip Seconds encountered by

- the interface in past 15 minutes.
e Minimum
. NPS calculates the rate of Controlled Slip Seconds per second.

¢ Maximum
NPS calculates the metric to display average, minimum, and maximum rate of
Controlled Slip Seconds encountered by the selected interface.

Glossary for SDH DS3 Metrics

Available only for

DS3 Interfaces

Metric Name Description

DSx3PCVs/sec | Count of Path Coding Violations encountered by the selected DS3 interface
in one second.

o Average

. The object returns the total number of Path Coding Violations encountered

e Minimum ; . .
by the interface in past 15 minutes.

* Maximum NPS calculates the total number of Path Coding Violations per second.
NPS calculates the metric to display average, minimum, and maximum
number of Path Coding Violations encountered by the selected interface.

DSx3LESs Rate of Line Errored Seconds encountered by the selected DS3 interface in

Rate one second.

e Average The object returns the total number of Line Errored Seconds encountered by

- the interface in past 15 minutes.
e Minimum
Maxi NPS calculates the percentage of Line Errored Seconds per second.

e Maximum
NPS calculates the metric to display average, minimum, and maximum rate
of Line Errored Seconds encountered by the selected interface.

DSx3LCVs/sec | Count of Line Coding Violations encountered by the selected DS3 interface
in one second.

e Average

. The object returns the total number of Line Coding Violations encountered by

e Minimum . . .
the interface in past 15 minutes.

e Maxi

aximum NPS calculates the total number of Line Coding Violations per second.
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Metric Name Description

NPS calculates the metric to display average, minimum, and maximum
number of Line Coding Violations encountered by the selected interface.

DSx3CCVs/sec | Count of C-bit Coding Violations encountered by the selected DS3 interface
in one second.
e Average
- The object returns the total number of C-bit Coding Violations encountered
e Minimum ; : .
by the interface in past 15 minutes.
e Maxi
aximum NPS calculates the number of C-bit Coding Violations per second.
NPS calculates the metric to display average, minimum, and maximum
number of C-bit Coding Violations encountered by the selected interface.
DSx3SEFSs Rate of Severely Errored Framing Seconds encountered by the selected
Rate DS3interface in one second.
e Average The object returns the total number of Severely Errored Framing Seconds
- encountered by the interface in past 15 minutes.
e Minimum
. NPS calculates the percentage of Severely Errored Framing Seconds per
e Maximum
second.
NPS calculates the metric to display average, minimum, and maximum rate
of Severely Errored Framing Seconds encountered by the selected interface.
DSx3CSESs Rate of C-bit Severely Errored Seconds encountered by the selected DS3
Rate interface in one second.
e Average The object returns the total number of C-bit Severely Errored Seconds
- encountered by the interface in past 15 minutes.
e Minimum
. NPS calculates the percentage of C-bit Severely Errored Seconds per
o Maximum
second.
NPS calculates the metric to display average, minimum, and maximum rate
of C-bit Severely Errored Seconds encountered by the selected interface.
DSx3PESs Rate of P-bit Errored Seconds encountered by the selected DS3 interface in
Rate one second.
e Average The object returns the total number of P-bit Errored Seconds encountered by
- the interface in past 15 minutes.
e Minimum
. NPS calculates the percentage of P-bit Errored Seconds per second.
e Maximum
NPS calculates the metric to display average, minimum, and maximum rate
of P-bit Errored Seconds encountered by the selected interface.
DSx3PSESs Rate of P-bit Severely Errored Seconds encountered by the selected DS3
Rate interface in one second.
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Metric Name Description

e Average The object returns the total number of P-bit Severely Errored Seconds
- encountered by the interface in past 15 minutes.
e Minimum
. NPS calculates the percentage of P-bit Severely Errored Seconds per
e Maximum
second.
NPS calculates the metric to display average, minimum, and maximum rate
of P-bit Severely Errored Seconds encountered by the selected interface.
DSx3UASs Rate of Unavailable Seconds encountered by the selected DS3 interface in
Rate one second.
e Average The object returns the total number of Errored Seconds encountered by the
- interface in past 15 minutes.
e Minimum
Maxi NPS calculates the percentage of Errored Seconds per second.
e Maximum
NPS calculates the metric to display average, minimum, and maximum rate
of Errored Seconds encountered by the selected interface.
DSx3CESs Rate of C-bit Errored Seconds encountered by the selected DS3 interface in
Rate one second.
e Average The object returns the total number of C-bit Errored Seconds encountered by
- the interface in past 15 minutes.
e Minimum
. NPS calculates the percentage of C-bit Errored Seconds per second.
e Maximum
NPS calculates the metric to display average, minimum, and maximum rate
of C-bit Errored Seconds encountered by the selected interface.

Glossary for SONET/SDH Metrics
Available only for SONET/SDH Interfaces

Metric Name Description

o Average
e Minimum

¢ Maximum

SonetSectionESs Rate

Rate of Errored Seconds encountered by the selected
SONET/SDH Section interface in one second.

The object returns the total number of Errored Seconds
encountered by the SONET/SDH Section interface in past 15
minutes.

NPS calculates the rate of Errored Seconds per second.

NPS calculates the metric to display average, minimum, and
maximum rate of Errored Seconds encountered by the selected
SONET/SDH Section interface.

SonetSectionSESs Rate

Rate of Severely Errored Seconds encountered by the selected
SONET/SDH Section interface in one second.
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Metric Name Description
e Average The object returns the total number of Severely Errored Seconds
- encountered by the SONET/SDH Section interface in past 15
e Minimum .
minutes.
e Maxi
aximum NPS calculates the rate of Severely Errored Seconds per second.
NPS calculates the metric to display average, minimum, and
maximum rate of Severely Errored Seconds encountered by the
selected SONET/SDH Section interface.
SonetSectionSEFSs Rate | Rate of Severely Errored Framing Seconds encountered by the
selected SONET/SDH Section interface in one second.
o Average
Mini The object returns the total number of Severely Errored Framing
* Minimum Seconds encountered by the SONET/SDH Section interface in
e Maximum past 15 minutes.
NPS calculates the rate of Severely Errored Framing Seconds per
second.
NPS calculates the metric to display average, minimum, and
maximum rate of Severely Errored Framing Seconds encountered
by the selected SONET/SDH Section interface.
SonetSectionCVs/sec Rate of Coding Violations encountered by the selected
SONET/SDH Section interface in one second.
e Average
Minimum The object returns the total number of Coding Violations
* Vinimu encountered by the SONET/SDH Section interface in past 15
o Maximum minutes.
NPS calculates the rate of Coding Violations per second.
NPS calculates the metric to display average, minimum, and
maximum rate of Coding Violations encountered by the selected
SONET/SDH Section interface.
SonetLineESs Rate Rate of Errored Seconds encountered by the selected
SONET/SDH Line interface in one second.
e Average
Mini The object returns the total number of Errored Seconds
° Vinimum encountered by the SONET/SDH Line interface in past 15
e Maximum minutes.
NPS calculates the rate of Errored Seconds per second.
NPS calculates the metric to display average, minimum, and
maximum rate of Errored Seconds encountered by the selected
SONET/SDH Line interface.
SonetLineSESs Rate Rate of Severely Errored Seconds encountered by the selected
SONET/SDH Line interface in one second.
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Metric Name Description

e Average
e Minimum

¢ Maximum

The object returns the total number of Severely Errored Seconds
encountered by the SONET/SDH Line interface in past 15
minutes.

NPS calculates the rate of Severely Errored Seconds per second.

NPS calculates the metric to display average, minimum, and
maximum rate of Severely Errored Seconds encountered by the
selected SONET/SDH Line interface.

SonetLineUASs Rate

Rate of Unavailable Seconds encountered by the selected
SONET/SDH Line interface in one second.

o Average
Mini The object returns the total number of Unavailable Seconds

* Minimum encountered by the SONET/SDH Line interface in past 15

e Maximum minutes.

NPS calculates the rate of Unavailable Seconds per second.
NPS calculates the metric to display average, minimum, and
maximum rate of Unavailable Seconds encountered by the
selected SONET/SDH Line interface.

SonetFarEndLineESs Rate of Far End Errored Seconds encountered by the selected

Rate SONET/SDH Medium/Section/Line interface in one second.

e Average The object returns the total number of Far End Errored Seconds

- encountered by the SONET/SDH Medium/Section/Line interface

e Minimum ; .
in past 15 minutes.

* Maximum NPS calculates the rate of Far End Errored Seconds per second.
NPS calculates the metric to display average, minimum, and
maximum rate of Far End Errored Seconds encountered by the
selected SONET/SDH Medium/Section/Line interface.

SonetFarEndLineSESs Rate of Far End Severely Errored Seconds encountered by the

Rate selected SONET/SDH Medium/Section/Line interface in one
second.

e Average

Mini The object returns the total number of Far End Severely Errored
° Vinimum Seconds encountered by the SONET/SDH Medium/Section/Line
e Maximum interface in past 15 minutes.

NPS calculates the rate of Far End Severely Errored Seconds per
second.

NPS calculates the metric to display average, minimum, and
maximum rate of Far End Severely Errored Seconds encountered
by the selected SONET/SDH Medium/Section/Line interface.
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Metric Name Description

SonetFarEndLineCVs/sec

Rate of Far End Coding Violations encountered by the selected
SONET/SDH Medium/Section/Line interface in one second.

e Average

o Minimum The object returns the total number of Far End Coding Violations
encountered by the SONET/SDH Medium/Section/Line interface

e Maximum in past 15 minutes.
NPS calculates the rate of Far End Coding Violations per second.
NPS calculates the metric to display average, minimum, and
maximum rate of Far End Coding Violations encountered by the
selected SONET/SDH Medium/Section/Line interface.

SonetFarEndLineUASs Rate of Far End Unavailable Seconds encountered by the

Rate selected SONET/SDH Medium/Section/Line interface in one
second.

e Average

- The object returns the total number of Far End Unavailable
* Minimum Seconds encountered by the SONET/SDH Medium/Section/Line
e Maximum interface in past 15 minutes.

NPS calculates the rate of Far End Unavailable Seconds per
second.

NPS calculates the metric to display average, minimum, and
maximum rate of Far End Unavailable Seconds encountered by
the selected SONET/SDH Medium/Section/Line interface.

SonetPathESs Rate

Rate of Errored Seconds encountered by the selected
SONET/SDH Path interface in one second.

e Average

« Minimum The object returns the total number of Errored Seconds
encountered by the SONET/SDH Path interface in past 15

e Maximum minutes.

NPS calculates the rate of Errored Seconds per second.

NPS calculates the metric to display average, minimum, and
maximum rate of Errored Seconds encountered by the selected
SONET/SDH Path interface.

SonetPathSESs Rate

Rate of Severely Errored Seconds encountered by the selected
SONET/SDH Path interface in one second.

e Average

« Minimum The object returns the total number of Severely Errored Seconds
encountered by the SONET/SDH Path interface in past 15

e Maximum minutes.

NPS calculates the rate of Severely Errored Seconds per second.

NPS calculates the metric to display average, minimum, and
maximum rate of Severely Errored Seconds encountered by the
selected SONET/SDH Path interface.
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Metric Name Description

SonetPathCVs/sec
e Average
e Minimum

¢ Maximum

Rate of Coding Violations encountered by the selected
SONET/SDH Path interface in one second.

The object returns the total number of Coding Violations
encountered by the SONET/SDH Path interface in past 15
minutes.

NPS calculates the rate of Coding Violations per second.

NPS calculates the metric to display average, minimum, and
maximum rate of Coding Violations encountered by the selected
SONET/SDH Path interface.

SonetPathUASs Rate

Rate of Unavailable Seconds encountered by the selected
SONET/SDH Path interface in one second.

e Average
Minimum The object returns the total number of Unavailable Seconds

* u encountered by the SONET/SDH Path interface in past 15

e Maximum minutes.

NPS calculates the rate of Unavailable Seconds per second.
NPS calculates the metric to display average, minimum, and
maximum rate of Unavailable Seconds encountered by the
selected SONET/SDH Path interface.

SonetFarEndPathESs Rate of Far End Errored Seconds encountered by the selected

Rate SONET/SDH Path interface in one second.

e Average The object returns the total number of Far End Errored Seconds

- encountered by the SONET/SDH Path interface in past 15

e Minimum .
minutes.

* Maximum NPS calculates the rate of Far End Errored Seconds per second.
NPS calculates the metric to display average, minimum, and
maximum rate of Far End Errored Seconds encountered by the
selected SONET/SDH Path interface.

SonetFarEndPathSESs Rate of Far End Severely Errored Seconds encountered by the

Rate selected SONET/SDH Path interface in one second.

o Average The object returns the total number of Far End Severely Errored

- Seconds encountered by the SONET/SDH Path interface in past

e Minimum :

15 minutes.
e Maximum

NPS calculates the rate of Far End Severely Errored Seconds per
second.

NPS calculates the metric to display average, minimum, and
maximum rate of Far End Severely Errored Seconds encountered
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Metric Name Description

by the selected SONET/SDH Path interface.

SonetFarEndPathCVs/sec | Rate of Far End Coding Violations encountered by the selected
SONET/SDH Path interface in one second.

e Average

« Minimum The object returns the total number of Far End Coding Violations
encountered by the SONET/SDH Path interface in past 15

e Maximum minutes.

NPS calculates the rate of Far End Coding Violations per second.

NPS calculates the metric to display average, minimum, and
maximum rate of Far End Coding Violations encountered by the
selected SONET/SDH Path interface.

SonetFarEndPathUASs Rate of Unavailable Seconds encountered by the selected

Rate SONET/SDH Path interface in one second.
e Average The object returns the total number of Unavailable Seconds
- encountered by the SONET/SDH Path interface in past 15
e Minimum .
minutes.
e Maximum

NPS calculates the rate of Unavailable Seconds per second.

NPS calculates the metric to display average, minimum, and
maximum rate of Unavailable Seconds encountered by the
selected SONET/SDH Path interface.

Interface Health Reports

The Interface Health reports show the performance data for network interfaces in your
environment.

Use Interface Health reports to determine if an interface is over-utilized or if it needs an upgrade.

Opening Reports from NNMi
From the NNMi Console, you have these options:

¢ Click the Reporting - Report Menu option under the Actions menu; launch reports from the
Report Menu.

e Launching Pre-Filtered iSPI Reports Directly from NNMi

If you are interested in a particular interface, launch a pre-filtered report from NNMi; otherwise,
open a workspace view from NNMi, move to the iSPI, and begin your investigation from the
Report Menu. To move from NNMi to the iSPI:

a. Logintothe NNMi Console.

b. Select aworkspace.
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c. Open aview (nodes, interfaces, components, or incidents).

d. Select Actions > Reporting - Report Menu page

Interface Health Baseline Sleeve Report

This report analyzes how close the metric performance value is to the threshold levels. In other
words, this report enables you to analyze when the metric will reach the threshold.

Using this report, you can:

o Analyze if the interface utilization or performance is within the expected (normal) range for the
selected time range.

o Detect if the metric performance is about to cross the high and low thresholds.

For example, if you generate the Baseline Sleeve Chart report for the baseline metric
Utilization In, the chart displays the how close the interface utilization for incoming flow is to
the high and low threshold.

o Save multiple Baseline Sleeve Reports for a specific metric for different time ranges, and
analyze the metric performance trend.

This report supports one metric.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Interface Health Calendar Report

The Calendar Report uses a traditional, calendar-style layout to show hourly statistics for two
metrics in a single, extended graph spanning over multiple days.

Features and Defaults

The Calendar Report defaults to:

¢ Interfaces = All

o Dates/Times = Last 31 days

o Metric(s) Shown on Y1 Axis (Primary Metric) = Volume Bytes (sum)
o Metric(s) Shown on Y2 Axis (Secondary Metric) = Utilization (avg)

The default view shows data for the current month. Depending on how long the iSPI has been
collecting data from NNMi, you may have the option of looking at data for the previous 70 days if
you use the option Until Now.
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Note: If you set the Time Range below 24 hours, the following message appears:
This report is not designed to operate with a time range of less than
24 hours. Please modify your time selections.

Use Case

Use this report to observe:

¢ gradual trends over time

o isolated spikes

o toverify that an abnormal condition has returned to normal
o tomake comparisons

This report also reveals:

o Day of week patterns

e Hour of day patterns

For example, if utilization is spiking on Tuesdays, or if response time issues are occurring daily at
11:00 a.m., the report will highlight these events.

e To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

e Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

e To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Interface Health Chart Detail Report

Chart Detail report enables you to perform a trend analysis for the network health and
performance based on historical interface health data.

The Chart Detail report displays a comparative analysis of the selected metrics for each time unit.

For example, if you need to compare how the average Threshold Exception Rate was affected by
variance in the average Response Time per millisecond for the past one week, you can generate
the Weekly Interface Health report for the selected node group.

You can also select two or more nodes, node groups, interfaces, or interface groups to generate
Chart Detail report.

Using this report you can:

o Analyze the trend of network health and performance for multiple nodes, node groups,
interfaces, or interface groups based on one unit of time. Each unit of time is called as a
Display Grain . Each Display Grain is measured as follows:
= Five minutes for Hourly report

= One hour for daily report
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= One day for weekly report
= One day for monthly report

o ldentify the interface that is causing any ups and downs in the network health and
performance.

o Detect any persistent problem in the interface health and performance.

o Compare network health and performance of more than two nodes, node groups, interfaces, or
interface groups based on historical interface health data.

The following are the available filters in the Time Controls pane for Chart Detail Report:
o Start Date/Time

¢ Time Range

o Display Grain

e Hour of day

o Day of Week

Features and Defaults

The graph on this report tracks up to six metrics per axis over the selected time period. Unless
you modify the defaults, Chart Detail defaults to the following:

¢ Interfaces = All

e Metric(s) Shown on Y1 Axis = Volume Bytes (sum)

o Metric(s) Shown on Y2 Axis = Availability - Utilization (avg)

The Chart Detail report displays the selected metrics using two Y axis.

e Theleft Y axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

To add another metric, click Options and then click '{EI

To remove a metric that you have already added, click Options and then click X_

The Chart Detail report enables you to view the data in the tabular format as well. To view the
table, click Options, and then select Table. The Table appears instead of the chart. To view both
the chart and the table, click Options, and then select Chart and Table.

e To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

e Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.
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e To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Interface Health Dashboard

The Dashboard report provides an overview of the interfaces available on your network using a
combination of gauges, heat charts, and ordered Top 5 lists. The report displays the threshold
violations for volume, error, and availability. Threshold violations can point to a network-related
problem or may indicate that your thresholds within NNMi need to be changed.

To group the data within the dashboard:
1. Click Options.
2. Inthe Grouping By: field, select a topology filter to group the dashboard data.

For example: if you use a grouping option of Node Name, all Availability exceptions that fall
within the time and topology constraints are grouped by Node Name and displayed as a
percentage of the total samples in the left gauge.

Dashboard Sections
Gauge
The gauges provide the following exception count statistics:
¢ Availability Exceptions (% samples)
o Utilization Exceptions (% samples)
o Discard Rate Exceptions (% samples)
o Error Rate Exceptions (% samples)

When the NPS database has no data, the needle icons on the gauges on the Dashboard report do
not appear.

Top 5 Lists

The top-5 lists displays nodes responsible for the exceptions showing up in the gauges:
o Top 5 Qualified Interface Names by Utilization Exceptions

o Top 5 Qualified Interface Names by Availability Exceptions

Top 5 Qualified Interface Names by Discard Exceptions Heat Chart
Using the heat chart, you can:

o Analyze the pattern of discard exception for past one hour.
o Compare the discard performance of different interfaces.

o Detect the time range in the past one hour when the discard rates were the highest.
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Example

If the gauges are showing few or no exceptions, this means that none of your interfaces, including
the interfaces in the top 5 lists, are experiencing problems with utilization or availability.

For example, your network is divided into groups that represent regions or strategic locations for
your enterprise. With the grouping option set to Node Group name, the report lists each of your
strategic Node Groups (as defined within NNMi) and provides the current statistics for exceptions
within each group.

If an unexpected change in exception counts is noted, you can click the appropriate gauge needle
or Node Group within the Top 5 lists, and then launch another report (such as Chart Detail) to
investigate trends or changes within the network as they are occurring.

The thresholds that create exceptions are set from NNMi, not from the iSPI. If you want to set or
modify thresholds, refer to the online help for NNMi administrators.

e Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o To change the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

e Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Interface Health Headline Report

The Headline Report provides a broad view of interface performance for past one day, using the
following graphs:

o Volume of data passed through the interface (in MB)

o Average percentage of interface availability

o Average and maximum interface utilization percentage

o Threshold and baseline utilization exception rates

o Maximum throughput per second (in bps)

o Total number of data packets transmitted or received using unknown protocol
e Maximum percentage of discard rate

o Total number of discard rate exceptions

e Maximum percentage of error rate

o Total number of error rate exceptions

This report enables you to:

o View every aspect of interface utilization and performance at once.

o View trends and verify that interface utilization and performance are meeting expectations.
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« lIdentify isolated aberration in the graphs and detect any unexpected utilization or performance
trend.

The Headline report does not provide options to create graphs based on other metrics.

This report shows the data for exceptions only if thresholds for performance metrics are set in
NNMi.

¢ To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

e Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

e To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Interface Health Executive Report

The Executive Report provides a broad view of interface performance for the selected time range,
using the following graphs:

o Volume of data passed through the interface (in GB)

o Average percentage of interface availability

¢ Average and maximum interface utilization percentage
e Threshold and baseline utilization exception rates

o Volume of data aggregated based on the following:
= Volume of data passed through the node groups

= Volume of data passed for each hour of the for the selected time range
o Average percentage of interface utilization for the node groups for the selected time range

o Average number of threshold and baseline exception faced by the node groups for the selected
time range

This report enables you to:
o View every aspect of interface utilization and performance at once.
o View trends and verify that interface utilization and performance are meeting expectations.

« lIdentify isolated aberration in the graphs and detect any unexpected utilization or performance
trend.

o View the trend of utilization for the node groups for the selected time range
The Executive report does not provide options to create graphs based on other metrics.
The default display grain for the Executive report is one hour.

This report shows the data for exceptions only if thresholds for performance metrics are set in
NNMi.
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e Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o To change the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

Interface Health Headline - Wireless LAN Report
Available only on WLAN interfaces — Following IEEE802dot11 performance policy

The Headline - Wireless LAN Report provides a performance overview of the wireless
LAN interfaces available in your network. The report displays interface availability and
performance for past 24 hours, using the following graphs:

o Total number of fragmented packets the interfaces have transmitted (sent and received)
successfully

o Total number of successful RTS compared to the total number of failed RTS
¢ Average and maximum number of wireless clients using the interface
¢ Maximum number of active bridges and repeaters available in the network for past 24 hours

o Total number of wireless stations available in the network. The graph displays total number of
associated, authenticated, roamed in and roamed away stations available in the network.

o Total number of ACK?2 failures occurred in the wireless LAN for past 24 hours

o Total number of duplicate frames transmitted by the wireless LAN

o Total number of maxed out transmission attempts made by wireless LAN

o Total number of undecryptable frames received by wireless LAN in past 24 hours

« Total number of FCS3 error occurred in the wireless LAN for past 24 hours

This report enables you to:

o View every aspect of the wireless LAN interface utilization and performance at once.

o View trends and verify that the utilization and performances of the wireless LAN interfaces are
meeting expectations.

o Identify isolated aberration in the graphs and detect any unexpected utilization or performance
trend.

TRequest To Send: A message sent from a device seeking access to a wireless network.
2Acknowledgement code: A transmission control character used to indicate that a transmitted
message was received uncorrupted, without errors or that the receiving station is ready to accept
transmissions. The receiving station sends this code to the sender to indicate that it has accepted
the transmission.

3Frame Check Sequence: Each PPP packet has a checksum attached to ensure that the data
being received is the data being sent. If the FCS of an incoming packet is incorrect, the packet is
dropped and the FCS error count is increased.
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The Headline - Wireless LAN report does not provide options to create graphs based on other
metrics.

This report shows the data for exceptions only if thresholds for performance metrics are set in
NNMi.

¢ To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

e Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

e To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Interface Health Heat Chart Report

The Heat Chart tracks the hourly performance of a single metric. The default metric is Volume -
Bytes (sum). The default time period is the last 31 days. Performance is color-coded, making it
easy to see whether performance has been satisfactory or unsatisfactory.

Features and Defaults

The legend at the top of the report maps a range of normalized performance values to a particular
color.

Beneath the legend, a table represents the normalized values of a performance metric (rows of the
table represent hours of the day; columns of the table represent days).

Each cell inside the table is color-coded and each cell inside the table indicates a specific value of

the metric. You can also hover the mouse pointer on the cell to see the absolute metric value of
each hour.

The default topology filters for the Heat Chart are as follows:
o Interfaces = All

e Time Period = Last 31 days

e Hourof Day = All

o Day of Week = All

e Metric = Volume - Bytes (sum)

Time range options are any period that is not less than 24 hours.

Use Case

Use the Heat Chart to identify gradual shifts from one range of performance to another range, to
spot an isolated instance of poor performance that affected the results for past 24 hours, to spot

day-of-week patterns, and to verify that an abnormal condition returned to normal after a problem
was corrected.

o To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.
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e Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

e Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Interface Health Managed Inventory Report

Use the Managed Inventory Report to view the number of instances of each topology attribute
seen in the collected data within the selected time range. For example, if the report is run for ‘Last
1 Hour,’ you will see the number of unique values for each attribute seen in the data collected over
the last hour. This report can be useful for checking, for example, the number of nodes polled over
any given time range.

You can use the available attributes to filter the data of your interest and create a report that
represents only the elements of your interest. The report presents the list of attributes in the form
of a table; the Count column of the table indicates the number of entries for each attribute. For
example, count 5 for the topology item Node Location means all nodes on your network can be
grouped based on 5 different locations that host the nodes.

You can use the following topology attributes with the Interface Health reports:
¢ Qualified Interface Name

¢ Interface Name

o Interface Alias

o Interface Descr

o Interface Index

o Interface Type

¢ Interface Physical Address
o Interface Speed (In:Out)

o Interface ID

¢ Interface UUID

e Node Name

¢ Node Contact

o Node Location

o Node Family

o Node Vendor

e NodelD

e Node UUID

¢ Interface ODBID

e Node ODBID
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e Tenant Name
e Tenant UUID
e SecGroup Name

e SecGroup UUID)

¢ To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

¢ Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.
The Managed Inventory report may take significant time to build if you select a time range
greater than 24 hours.

The Managed Inventory report may take significant time to build if you select a time range greater
than 24 hours.

Interface Health Most Changed Report

This report compares performance the components for two different (consecutive) time periods
and ranks components by the amount of change. The sort order is most-changed to least-
changed.

Features and Defaults

This report contains one table. The table provides data for one metric only.
The table columns are:

o Grouping by levels; one to five columns, each displaying a level

o Performance for the previous time period

o Performance for the current time period

o Growth, expressed as a percentage increase

e Change

The default filters for the Most Changed report defaults to:

¢ Grouping by Elements = Qualified Interface Name

o Start Date/Time = depends on default Time Range and data available in database
e Hourof Day (HOD) = All

o Day of Week (DOW) = All

e Ranking Metric = Volume - Bytes (sum)

e Top N Option=Top 10
You can select multiple grouping attributes by using the ﬁ (Add New Grouping) button. Use

the P (Remove Grouping) button to remove a grouping attribute.
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Use Case

Use this report to spot objects at selected grouping level that saw significant growth from the
previous selected time period to the selected time period. Significant growth could point to a
developing problem you need to know about. You can change the ranking metric and you can
change how many elements are listed.

o To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

e Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

e To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Interface Health Overview Report

The Overview Report displays the utilization and performance of the most commonly monitored
metrics in Interface Health extension pack.

Using this report, you can:
« Monitor the daily utilization and performance of a set of pre-defined metrics.

o Identify the interfaces with unusual performance or utilization and drill down to other reports to
analyze the problem.

¢ Rank the interfaces based on their utilization levels.

o Identify the metrics that are close to the threshold. Use the following sections to identify such
interfaces:
= 12 Weeks Utilization In Forecasts

= 12 Weeks Utilization Out Forecasts

The default display grain for this report is one hour. To select a different time grain or time range,
use the Time Controls tab in the navigation panel.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the topology filters, use the Topology Filters tab in the navigation panel.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

You cannot select the metrics for this report.

Interface Health Peak Period Report

The Interface Health Peak Period Report ranks the utilization and performance of an interface
during the busiest time of the selected time range.

Using this report, you can:
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« Identify the performance and utilization of the selected metrics during the peak period.

« Identify the interfaces that have the highest or lowest performances or utilization levels during
the peak period.

o Compare the performance for multiple interfaces during the peak period using this report.
Use Case

Use this report to:

o Identify a group of interfaces having a common network performance problem.

« Identify the interface that is suffering from a persistent performance problem.

Interface Health Peak Period Report Options

e Top/ Bottom N'
e Metric
¢ Grouping by Time Period?

This report tracks up to six metrics over the selected time period.

To add another metric, click Options and then click '{F_hl

To remove a metric that you have already added, click Options and then click X.

To select a range of value for the metric, click ﬁ click ', and type a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

¢ Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five interfaces for the node 15.2.103.112 with the average
utilization between 10% and 90% type the following ranges:

e 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value

By default, the report groups data by Qualified Interface Name. You can select multiple grouping

attributes by using the '{F_hl (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

Tip:

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for

the selected component.
2Enables you to group the report data based on a specific time grain. Click Add New Grouping

icon to add a new group.
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o Use this report to identify the period when the interface utilization was the highest.
o Check this report once a day to see which interface may need special attention.

o Check this report periodically throughout the day to see which interface is performing at the
extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Interface Health Threshold Sleeve Report

This report analyzes how close the metric performance value is to the threshold levels. In other
words, this report enables you to analyze when the metric will reach the threshold.

Using this report, you can:
o Forecast over-utilization or under-utilization of the selected interface.
o Detect if the metric performance is about to cross the high and low thresholds.

For example, if you generate the Threshold Sleeve Chart report for Availability (avg), the chart
displays the how close the average interface availability is to the high and low threshold.

o Save multiple Threshold Sleeve Reports for a specific metric for different time ranges, and
analyze the metric performance trend.

This report supports one metric.

e Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

e Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

e Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Interface Health Top N Report

This report ranks network elements by the metric that you select. Use this report to spot the
element that performed at the extremes. You can use this report to analyze the historical data for
elements that are exhibiting unusual utilization levels.

Using this report you can:
o Detect the network interface having a health or performance problem.

o Analyze the utilization of the NNMi managed network interfaces based on a specific time
range.

o Detect the over-utilized and under-utilized network interfaces in the network.
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e Compare the performance of multiple network interfaces for a single node or multiple nodes
using this report.

Example

One of the routers in your network are performing poorly. Using this report, you can group the
router interfaces reporting highest average error rate. The interface reporting the highest average
error rate is ranked first.

Interface Health Top N Reports Options

The Top N report displays the following options:
e Top/ Bottom N'

o Select Metric(s)z: The report ranks the selected interfaces based on the value of the first
metric listed in the Select Metric(s) field.

¢ Display Time Series Chart3
e Grouping By4

This report tracks up to six metrics for each metric type over the selected time period.

To add another metric, click Options and then click '{F_hl

To remove a metric that you have already added, click Options and then click 'X_

To select a range of value for the metric, click ﬁ click 'F, and select a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five interfaces for the node 15.2.103.112 where the
average utilization between 10% and 90% type the following ranges:

e 0.10r10% as Lowest Value

e 0.90r90% as the Highest Value

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for
the selected component.

2Select the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.

3elect Yes to view the detail chart with the table. Select No to hide the chart and display only the
table. The created Top N Report displays the graphical representation of the metric values for the
components over the selected time range.

4Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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By default, the report groups data by Qualified Interface Name. You can select multiple grouping

attributes by using the =1 (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

The Time Series Chart report displays the selected metrics using two Y axis.

e TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

e Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

Tip :

o By default, Top N Report does not display the Time Series Chart. To view the chart with the

detail table,perform any of the following steps:
n Select Options > Display Time Series Chart > Confirm Selection.

n Click Show Chart link below the detail table.
o Check this report once a day to see which network interface may need special attention.

o Check this report periodically throughout the day to see which network interfaces are
performing at the extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Interface HealthTop N CSV Report

Top N report may have performance problem, as it retrieves huge amount of data from the NPS
database for the selected time range. To resolve this problem, NPS enables you to schedule the
following reports in CSV format:
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e TopNCSV report1
e Top N Detail CSV report2

Interface Health Top N Chart
Like the Top N report, this report also ranks the interfaces by the metric you select.
Using this report, you can:
e Spot the interface that performed at the extremes.
o Analyze the historical data for interfaces that are exhibiting unusual utilization levels.
o Detect the interface having a health or performance problem.
o Analyze the utilization of the NNMi managed interfaces based on a specific time range.
o Detect the over-utilized and under-utilized interfaces in the network.

o Detect the underlying reason of a persistent problem with a interface. You can compare the
performance for multiple interfaces using this report.

Interface Health Top N Chart Options

The Top N Chart displays the following options:
e Top/ Bottom N3

e Metric

« Grouping By*

This report tracks up to six metrics over the selected time period.

The Top N CSV report ranks selected topology element based on the utilization level of the
selected metric in the descending order.

2The Top N Detail CSV report lists the metric utilization for the selected topology element based
on the selected time grain.

This report displays the ranks the elements based on the total metric utilization for the selected
time range and breaks up the metric utilization value for each time grain. For example, you
selected the following options for the Top N CSV report:

Time Range: Last 24 Hours. The default Display Grain for this time range is one hour.
Topology Element: Qualified Interface Name

Metric: Volume —Bytes (sum) and Utilization (avg)

The displayed report ranks the Qualified Component based on the metric Volume — Bytes (sum).
The Qualified Interface Name with the highest volume of data passing through it receives the
highest rank. The Top N Detail CSV report then calculates and lists the volume of data passed
through this element every hourin last 24 hours.

3Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for
the selected component.

4Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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To add another metric, click Options and then click '{EI

To remove a metric that you have already added, click Options and then click X.

To select a range of value for the metric, click '{F_hl click "W, and select a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five interfaces for the node 15.2.103.112 with the average
utilization between 10% and 90% type the following ranges:

e 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value

By default, the report groups data by Qualified Interface Name. You can select multiple grouping

attributes by using the '{EI (Add New Grouping) button. Use the x (Remove Grouping) button
to remove a grouping attribute.

The Top N Chart report displays the selected metrics using two Y axis.

o Theleft Y axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

e Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

Tip :
o Check this report once a day to see which interface may need special attention.

o Check this report periodically throughout the day to see which interfaces are performing at the
extremes and may need special attention.

¢ To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

e Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

e To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.
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iISPI for Performance Reportlets

In a large enterprise network the NNM iSPI Performance products.1 may produce a large
amount of data and large cardinality. This means that these networks often have a very large
amount of unique IP addresses, source nodes and destination nodes, interfaces, and components
each producing large amount of data. Generating reports using such large data volume may be
time consuming.

Reportlets enable you to generate quick impressions of the larger reports using the iSPI for
Performance Dashboards.

Viewing iSPI for Performance Reportlets
To display the reportlets:

1. Loginto Network Performance Server (NPS) Home Page.

2. Onthe left navigation panel, select Dashboard Reportlets.
3. Select an extension pack and then select a reportlet.

You can also create custom dashboards using the reportlets. See Creating Custom Dashboards
Using Bl Server Portal for information on the procedure to create the custom dashboards.

Baseline Metric Snapshot with Range
Displays the aggregated metric performance for the selected time range.
Enables you to:

o Build a performance history for the selected baseline metric and analyze how the metric
performance changes over time.

Such history may help you to select an expected performance level for the metric
e Compare the performance for multiple metrics over a specified time range.

Though you can generate snapshot report for a single metric, you can save the snapshot report
for various metrics and compare the performance of each metric over a time range.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Baseline Sleeve Chart
Analyzes how close the metric performance value is to the threshold levels.

Enables you to:

TNNM iSPI Performance for Metrics, NNM iSPI Performance for Quality Assurance, and NNM
iSPI Perforance for Traffic
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o Detect if the metric performance is about to cross the high and low thresholds.

For example, if you generate the Baseline Sleeve Chart reportlet for Utilization (avg), the chart
displays how many exceptions are raised on average utilization in the past 24 hours,

e Save multiple Sleeve Reports for a time range, and for analyze the trend of performance for the
metric.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Baseline Sparkline

Evaluates the trend of how the selected baseline metric value has changed for the selected time
range.

Enables you to:

o Analyze the variations in the performance for the selected metric.

¢ Decide whether the expected behavior for the selected metric should be reassessed.
This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Baseline Sparkline with Range

Evaluates the trend of how the selected baseline metric value has changed for the selected time
range.

Enables you to:

o Evaluate the performance trend of the selected metric for the selected time range.

e Compare the present performance trend with the normal (expected) performance range.
e Measure the performance of past 24 hours in percentage.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Calendar
Displays a comparative study of the selected Primary Metric! and Secondary Metric?

The default display grain is set to one hour. You cannot change the display grain of this reportlet.

TEnables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

2Enables you to select the metric that would overlay the primary metric. The secondary metric
that you select is displayed on the right Y axis of the report.
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Enables you to monitor the following:

o Daily interface utilization

« Volume of data passed through the interface for past 24 hours
o Performance of the interface for past 24 hours

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Gauge
Evaluates the metric for the selected point of time.
Select only the metrics that displays the percentage values.
Enables you to:
¢ Measure the daily performance of the selected metric.
o Detect any abnormal or unexpected performance level.
This reportlet supports one metric.
When the NPS database has no data, the needle icon on the gauge does not appear.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Heat Chart
Grades the performance of the selected metric for the selected time range.
The metric performance is aggregated based on an hourly display grain.
Enables you to:
« View how the interface performance gets affected by a varying metric.
o Compare the hourly performance of the selected metric.

o Detect the time range when the interface performance was affected adversely because of the
fluctuating metric value.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Metric Snapshot
Displays the metric performance for the selected time range.

Enables you to:
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o Build a performance history for the selected metric and analyze how the metric performance
changes over time.

Such history may help you to decide the baseline value for the metric
o Compare the performance for multiple metrics over a specified time range.

Though you can generate snapshot report for a single metric, you can save the snapshot report
for various metrics and compare the performance of each metric over a time range.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Most Changed
Compares the metric performance between the following:
e Selected time range
o Period preceding the selected time range
Aggregates the metric utilization and ranks the performance in a descending order.
Enables you to:
o Measure the performance fluctuations for the interfaces.
o Detect the top N interfaces having a common performance or utilization problem.
You can enhance the reportlet usability using the following features:
e Top/ Bottom N'
e Grouping By2
This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Option in the Using Reports >
Change Default Settings section..

Multimetric Chart
Analyzes the performance trend for the selected metrics for the selected time range.
Enables you to:
o Perform comparative analysis of the selected metrics for each display grain.

The default display grain is one hour.

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for

the selected component.
2Organize the report data based on a specific parameter. Click Add New Grouping icon to add a

new group.
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o Analyze the reason for any ups and downs in the interface performance.
o Detect any persistent problem in the interface performance.
This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Bar and Line Chart
Displays the trend of interface performance for past 24 hours using the following values:
e Primary Metric' on the bar chart
o Secondary Metric? on the line chart
Enables you to:
e Compare the performance trends of multiple metrics.

¢ Analyze how the value of the secondary metric increases or decreases based on the increase
or decrease in the value of the primary metric.

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Bar Chart
Compares the performance of two metrics for the selected time range.
Enables you to:
e Compare the performance trends of multiple metrics.

¢ Analyze how the value of the secondary metric increases or decreases based on the increase
or decrease in the value of the primary metric.

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Chart
Analyzes the utilization trend for the selected metrics for the selected time range.

Enables you to:

TEnables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

2Enables you to select the metric that would overlay the primary metric. The secondary metric
that you select is displayed on the right Y axis of the report.
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o Perform comparative analysis of the selected metrics for each display grain.
The default display grain is one hour.

o Analyze the reason for any ups and downs in the interface performance.

o Detect any persistent problem in the interface performance.

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Table
Analyzes the utilization trend for the selected metrics for the selected time range.
The default display grain is one hour.
Enables you to:
¢ Analyze the hourly performance of the metrics.
o Detect any abnormal or unexpected interface performance.

¢ Analyze how the value of the secondary metric increases or decreases based on the increase
or decrease in the value of the primary metric.

This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Sparkline
Evaluates the trend of how the selected metric value has changed for the selected time range.
Enables you to:
o Analyze the variations in the performance for the selected metric.
o Decide whether the expected behavior for the selected metric should be reassessed.
This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Threshold Sleeve Chart
Analyzes how close the metric performance value is to the threshold levels.
Enables you to:
o Detect if the metric performance is about to cross the high and low thresholds.

For example, if you generate the Exception Sleeve Chart reportlet for Utilization (avg), the
chart displays how many exceptions are raised on average utilization in the past 24 hours,
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o Save multiple Sleeve Reports for a time range, and for analyze the trend of performance for the
metric.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Chart

Ranks the individual contribution of each metric for the interface performance for the selected
time range.

The performance of the interface is aggregated on hourly basis.

Enables you to:

o Spot the interfaces for which the performance metrics present extreme values.

o Investigate the aggregated data for the interfaces that are exhibiting unusual utilization levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the interfaces.

o Group the report data based on a specific parameter. Click '{F_hl Add Group to add a subgroup.
This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Line Chart
Ranks the utilization trend for the selected metrics for the selected time range.
The performance of the interface is aggregated on hourly basis.
Enables you to:
e Spot the interfaces for which the performance metrics present extreme values.
o Investigate the aggregated data for the interfaces that are exhibiting unusual utilization levels.

¢ Select the metric based on which you want to generate the report. The metric that you select is
used to rank the interfaces.

¢ Group the report data based on a specific parameter. Click '{F._hl Add Group to add a subgroup.
This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Stacked Chart
Ranks the individual contribution of each interface based on the selected metrics.
The performance of each interface is aggregated for the default display grain of one hour.

Enables you to:
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o Spot the interfaces for which the performance metrics present extreme values.

¢ Investigate the aggregated data for the interfaces that are exhibiting unusual utilization levels.
¢ Detect the network path having a com m on network performance problem.

This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Table
Ranks the interfaces based on the selected metric.
Enables you to:
e Spot the interfaces for which the performance metrics present extreme values.
o Investigate the aggregated data for the interfaces that are exhibiting unusual utilization levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the interfaces.

o Group the report data based on a specific parameter. Click '{F_hl Add Group to add a subgroup.

This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Table With Bars

Ranks the interfaces based on the selected metric and displays a horizontal bar to depict the
aggregated metric value.

Enables you to:
e Spot the interfaces for which the performance metrics present extreme values.
o Investigate the aggregated data for the interfaces that are exhibiting unusual utilization levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the interfaces.

o Group the report data based on a specific parameter. Click '{F_hl Add Group to add a subgroup.
This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.
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Glossary for ATM Metrics

Available only on ATM interfaces

Metric Name Description

AAL5VCC PDUs In

Total number of 32 bit and 64 bit AAL5S CPCS1 PDUs

received
on the selected AAL5 VCC (virtual circuit) at the selected
AALS5 interface

AAL5VCC PDUs Out Total number of 32 bit and 64 bit AAL5 CPCS PDUs
transmitted on the selected AALS5 virtual circuit at the
selected AALS interface

Discarded AAL5 VCC PDUs Total number of AAL5 CPCS PDUs dropped at the receive

side and transmit side of the selected AAL5 VCC at the
selected AALS interface

Calculated using the following formula:

([VCC Discarded AAL5 PDUs In] + [VCC
Discarded AAL5 PDUs Out])

Discarded AAL5 VCC PDUs
Percentage

Percentage of AAL5 CPCS PDUs dropped from the total
number of AAL5 CPCS PDUs received and transmitted on
the selected AAL5VCC

Calculated using the following formula:

([VCC Discarded AALS5 PDUs In]+ [VCC
Discarded AAL5 PDUs Out])/ (([VCC AAL5
PDUs QOut + VCC Discarded AALS5 PDUs
Out])+([VCC AAL5 PDUs Out + VCC Discarded
AAL5 PDUs Out])) /100

Discarded AAL5VCC PDUs In

Total number of AAL5 CPCS PDUs dropped at the receive
side of the selected AAL5 VCC at the selected AALS
interface

1Common Part Convergence Sublayer
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Discarded AAL5VCC PDUs In Percentage of AAL5 CPCS PDUs dropped from the total
Percentage number of AAL5 CPCS PDUs received

Calculated using the following formula:

[VCC Discarded AAL5 PDUs In]/ ([VCC AALS
PDUs In + VCC Discarded AAL5 PDUs In])

Discarded AAL5 VCC PDUs Out Total number of AAL5 CPCS PDUs dropped at the
transmit side of the selected AAL5 VCC at the selected
AALS5 interface

Discarded AAL5 VCC PDUs Out Percentage of AAL5 CPCS PDUs dropped from the total
Percentage number of AAL5 CPCS PDUs transmitted

Calculated using the following formula:

[VCC Discarded AAL5 PDUs Out]/ ([VCC AALS
PDUs Out + VCC Discarded AALS5 PDUs Out])

AAL5VCC In Octets Total number of 32 bit and 64 bit AAL5 CPCS PDU octets
received on the selected AALS virtual circuit at the
selected AALS interface

AAL5 VCC Out Octets Total number of 32 bit and 64 bit AAL5 CPCS PDU octets
transmitted on the selected AALS virtual circuit at the
selected AALS interface

AAL5 VCC In Utilization Average utilization for the selected virtual circuit
Calculated using the following formula:

([Number of octets received by the AALS

VCC] * 8 * 100)/([Interface in speed] *

Number of seconds the AAL5 interface was
available)

AALS5 VCC Out Utilization Average utilization for the selected virtual circuit
Calculated using the following formula:

([Number of octets transmitted by the
AAL5 VCC] * 8 * 100)/([Interface out
speed] * Number of seconds the AALS
interface was available)

Reboot (avg) Generated if the selected AALS interface was restarted
during the poll and no data could be retrieved from the
interface.

NNMi checks the sysUptime metric to determine whether
the interface was restarted during the last poll.

Unresponsive Target (avg) Generated when the SNMP agent did not respond when
collecting metrics for a particular polling policy.

Invalid Data (avg) Generated when NNMi has successfully polled data from
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the target, but has determined that the data is invalid. For
example, this metric is calculated when the number of
packets is greater than the number of octets.
Target Error (avg) Generated if the selected AALS interface returns any of the

following SNMP error responses:
¢ Authentication error
e Nosuchname

¢ No such object.

ATM Calendar Report

The Calendar Report uses a traditional, calendar-style layout to show hourly statistics for two
metrics in a single, extended graph spanning over multiple days.

Features and Defaults

The Calendar Report defaults to:

e ATMPVC Name = All

o Dates/Times = Last 31 days

o Metric(s) Shown on Y1 Axis (Primary Metric) = Volume Bytes (sum)

o Metric(s) Shown on Y2 Axis (Secondary Metric) = CIR Utilization (avg)

The default view shows data for the current month. Depending on how long the iSPI has been
collecting data from NNMi, you may have the option of looking at data for the previous 70 days if
you use the option Until Now.

Note: If you set the Time Range below 24 hours, the following message appears:
This report is not designed to operate with a time range of less than
24 hours. Please modify your time selections.

Use Case

Use this report to observe:
o gradual trends over time
o isolated spikes

to verify that an abnormal condition has returned to normal

o tomake comparisons
This report also reveals:
o Day of week patterns
e Hour of day patterns

For example, if utilization is spiking on Tuesdays, or if response time issues are occurring daily at
11:00 a.m., the report will highlight these events.
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o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Chart Detail Report

Chart Detail report enables you to perform a trend analysis for the network health and performance
based on historical virtual circuit health data.

The Chart Detail report displays a comparative analysis of the selected metrics for each time unit.

For example, if you need to compare how the volume of AAL5 CPCS PDUs received and sent was
affected by variance in the AAL5 CPCS PDU discards per millisecond for the past one week, you
can generate the Weekly ATM report for the selected node group.

You can also select two or more nodes, node groups, virtual circuits, or interface types to generate
Chart Detail report.

Using this report you can:

o Analyze the trend of network health and performance for multiple nodes, node groups, virtual
circuits, or virtual circuit groups based on one unit of time. Each unit of time is called as a
Display Grain. Each Display Grain is measured as follows:
= Five minutes for Hourly report

= One hour for daily report
= One day for weekly report
= One day for monthly report

o Identify the virtual circuit that is causing any ups and downs in the network health and
performance.

o Detect any persistent problem in the virtual circuit health and performance.

o Compare network health and performance of more than two nodes, node groups, virtual circuits,
or virtual circuit groups based on historical virtual circuit health data.

The following are the available filters in the Time Controls pane for Chart Detail Report:
o Start Date/Time

o Time Range

¢ Display Grain

o Hour of day

o Day of Week

Features and Defaults

The graph on this report tracks up to six metrics per axis over the selected time period. Unless you
modify the defaults, Chart Detail defaults to the following:
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e ATMPVC Name = All

o Metric(s) Shown on Y1 Axis = Volume Bytes (sum)

o Metric(s) Shown on Y2 Axis = CIR Utilization (avg)

The Chart Detail report displays the selected metrics using two Y axis.

o TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

To add another metric, click Options and then click '{F_hl

To remove a metric that you have already added, click Options and then click X_

The Chart Detail report enables you to view the data in the tabular format as well. To view the table,
click Options, and then select Table. The Table appears instead of the chart. To view both the
chart and the table, click Options, and then select Chart and Table.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Heat Chart Report

The Heat Chart tracks the hourly performance of a single metric. The default metric is Volume -
Bytes (sum). The default time period is the last 31 days. Performance is color-coded, making it
easy to see whether performance has been satisfactory or unsatisfactory.

Features and Defaults

The legend at the top of the report maps a range of normalized performance values to a particular
color.

Beneath the legend, a table represents the normalized values of a performance metric (rows of the
table represent hours of the day; columns of the table represent days).

Each cell inside the table is color-coded and each cell inside the table indicates a specific value of
the metric. You can also hover the mouse pointer on the cell to see the absolute metric value of
each hour.

The default topology filters for the Heat Chart are as follows:
e ATMPVC Name = All

e Time Period = Last 31 days

o Hourof Day = All
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e Day of Week = Al
e Metric = Volume - Bytes (sum)

Time range options are any period that is not less than 24 hours.
Use Case

Use the Heat Chart to identify gradual shifts from one range of performance to another range, to

spot an isolated instance of poor performance that affected the results for past 24 hours, to spot

day-of-week patterns, and to verify that an abnormal condition returned to normal after a problem
was corrected.

« To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Managed Inventory Report

Use the Managed Inventory Report to view the number of instances of each topology attribute seen
in the collected data within the selected time range. For example, if the report is run for ‘Last 1
Hour,” you will see the number of unique values for each attribute seen in the data collected over the
last hour. This report can be useful for checking, for example, the number of nodes polled over any
given time range.

You can use the available attributes to filter the data of your interest and create a report that
represents only the elements of your interest. The report presents the list of attributes in the form of
atable; the Count column of the table indicates the number of entries for each attribute. For
example, count 5 for the topology item Node Location means all nodes on your network can be
grouped based on 5 different locations that host the nodes.

You can use the following topology attributes with the virtual circuit Health reports:
¢ Qualified ATM PVC Name
o ATMPVC Name

e ATMPVCID

¢ Qualified Interface Name

o Interface Name

¢ Interface Alias

o Interface Physical Address
« ATMPVC UUID

e Node Name

¢ Node Contact

o Node Location
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o Node Family

¢ Node Vendor

e NodelD

e Node UUID

¢ Interface ODBID
o Node ODBID

e Tenant Name

e Tenant UUID

o SecGroup Name

e SecGroup UUID)

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

« Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.
The Managed Inventory report may take significant time to build if you select a time range greater
than 24 hours.

The Managed Inventory report may take significant time to build if you select a time range greater
than 24 hours.

ATM Most Changed Report

This report compares performance the components for two different (consecutive) time periods and
ranks components by the amount of change. The sort order is most-changed to least-changed.

Features and Defaults

This report contains one table. The table provides data for one metric only.
The table columns are:

« Grouping by levels; one to five columns, each displaying a level

o Performance for the previous time period

o Performance for the current time period

o Growth, expressed as a percentage increase

¢ Change

The default filters for the Most Changed report defaults to:

Grouping by Elements = Qualified ATM PVC Name

Start Date/Time = depends on default Time Range and data available in database
Hour of Day (HOD) = All
Day of Week (DOW) = All
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e Ranking Metric = Volume - Bytes (sum)

e Top N Option=Top 10

You can select multiple grouping attributes by using the '{F._hl (Add New Grouping) button. Use the
x (Remove Grouping) button to remove a grouping attribute.
Use Case

Use this report to spot objects at selected grouping level that saw significant growth from the
previous selected time period to the selected time period. Significant growth could point to a
developing problem you need to know about. You can change the ranking metric and you can
change how many elements are listed.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

« Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Peak Period Report

The ATM Peak Period Report ranks the utilization and performance of an interface during the
busiest time of the selected time range.

Using this report, you can:
« Identify the performance and utilization of the selected metrics during the peak period.

« lIdentify the interfaces that have the highest or lowest performances or utilization levels during
the peak period.

o Compare the performance for multiple interfaces during the peak period using this report.
Use Case

Use this report to:

o Identify a group of virtual circuits having a common network performance problem.

« Identify the virtual circuit that is suffering from a persistent performance problem.

ATM Peak Period Report Options

e Top/ Bottom N

o Select Metric(s)2

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the

selected component.
2Select the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.
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¢ Grouping by Time Period’

This report tracks up to six metrics over the selected time period.

To add another metric, click Options and then click '{F_bl

To remove a metric that you have already added, click Options and then click X.

To select a range of value for the metric, click '{EI click 7, and type a range of metric value that the
report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five virtual circuits for the node 15.2.103.112 with the
average utilization between 10% and 90% type the following ranges:

¢ 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value
By default, the report groups data by Qualified ATM PVC Name. You can select multiple grouping

attributes by using the ﬁ (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

Tip:
o Use this report to identify the period when the virtual circuit utilization was the highest.
o Check this report once a day to see which virtual circuit may need special attention.

o Check this report periodically throughout the day to see which virtual circuit is performing at the
extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

To change the Report Options defaults, see Change Report Options in the Using Reports > Change
Default Settings section.

ATM Top N Report

This report ranks network elements by the metric that you select. Use this report to spot the
element that performed at the extremes. You can use this report to analyze the historical data for
elements that are exhibiting unusual utilization levels.

Using this report you can:

TEnables you to group the report data based on a specific time grain. Click Add New Grouping icon
to add a new group.
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o Detect the ATM virtual circuits having a health or performance problem.

o Analyze the utilization of the NNMi managed ATM virtual circuits based on a specific time
range.

o Detect the over-utilized and under-utilized ATM virtual circuits in the network.
o Compare the performance of multiple ATM virtual circuits for a single node or multiple nodes
using this report.

Example

One of the routers in your network are performing poorly. Using this report, you can group the ATM
virtual circuit for the router reporting highest average error rate. The virtual circuit reporting the
highest average error rate is ranked first.

Interface Health Top N Reports Options

The Top N report displays the following options:
e Top/ Bottom N

o Select Metric(s)2: The report ranks the selected virtual circuits based on the value of the first
metric listed in the Select Metric(s) field.

o Display Time Series Chart3
o Grouping By4

This report tracks up to six metrics for each metric type over the selected time period.

To add another metric, click Options and then click '{F_hl

To remove a metric that you have already added, click Options and then click X_

To select a range of value for the metric, click '{F_hl click ¥, and select a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
« Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

23elect the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.

3elect Yes to view the detail chart with the table. Select No to hide the chart and display only the
table. The created Top N Report displays the graphical representation of the metric values for the
components over the selected time range.

4Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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For example if you want to see the top five interfaces for the node 15.2.103.112 where the average
utilization between 10% and 90% type the following ranges:

¢ 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value
By default, the report groups data by Qualified ATM PVC Name. You can select multiple grouping

attributes by using the E (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

The Time Series Chart report displays the selected metrics using two Y axis.

e TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

Tip :

o By default, Top N Report does not display the Time Series Chart. To view the chart with the
detail table,perform any of the following steps:
= Select Options > Display Time Series Chart > Confirm Selection.

= Click Show Chart link below the detail table.
o Check this report once a day to see which network interface may need special attention.

o Check this report periodically throughout the day to see which network interfaces are performing
at the extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

To change the Report Options defaults, see Change Report Options in the Using Reports > Change
Default Settings section.

ATMTop N CSV Report

Top N report may have performance problem, as it retrieves huge amount of data from the NPS
database for the selected time range. To resolve this problem, NPS enables you to schedule the
following reports in CSV format:
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e TopNCSV report1
e Top N Detail CSV repor’c2

ATM Top N Chart

Like the Top N report, this report also ranks the ATM virtual circuits by the metric you select.
Using this report, you can:

e Spot the virtual circuits that performed at the extremes.

« Analyze the historical data for virtual circuits that are exhibiting unusual utilization levels.
o Detect the virtual circuits having a health or performance problem.

o Analyze the utilization of the NNMi managed ATM virtual circuits based on a specific time
range.

o Detect the over-utilized and under-utilized ATM virtual circuits in the network.

o Detect the underlying reason of a persistent problem with a virtual circuit. You can compare the
performance for multiple virtual circuits using this report.

ATM Top N Chart Options
The Top N Chart displays the following options:
e Top/ Bottom N3

o Select Metric(s)4

¢ Grouping By5

1The Top N CSV report ranks selected topology element based on the utilization level of the
selected metric in the descending order.

2The Top N Detail CSV report lists the metric utilization for the selected topology element based on
the selected time grain.

This report displays the ranks the elements based on the total metric utilization for the selected time
range and breaks up the metric utilization value for each time grain. For example, you selected the
following options for the TOP N CSV report:

Time Range: Last 24 Hours. The default Display Grain for this time range is one hour.

Topology Element: Qualified ATM Pvc Name

Metric: Volume — Bytes (sum) and Utilization (avg)

The displayed report ranks the Qualified ATM Pvc Names based on the metric Volume — Bytes
(sum). The Qualified ATM Pvc Name with the highest volume of data passing through it receives
the highest rank. The Top N Detail CSV report then calculates and lists the volume of data passed
through this element every hour in last 24 hours.

3Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

4Select the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.

5Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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This report tracks up to six metrics over the selected time period.

To add another metric, click Options and then click '{F_bl

To remove a metric that you have already added, click Options and then click X.

To select a range of value for the metric, click '{F._hl click ¥, and select a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five ATM virtual circuits for the node 15.2.103.112 with the
average utilization between 10% and 90% type the following ranges:

e 0.10r10% as Lowest Value
o 0.90r90% as the Highest Value
By default, the report groups data by Qualified ATM PVC Name. You can select multiple grouping

attributes by using the ﬁ (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

The Top N Chart report displays the selected metrics using two Y axis.

e TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

Tip :
o Check this report once a day to see which interface may need special attention.

o Check this report periodically throughout the day to see which interfaces are performing at the
extremes and may need special attention.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

« Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Calendar Report

The Calendar Report uses a traditional, calendar-style layout to show hourly statistics for two
metrics in a single, extended graph spanning over multiple days.

Features and Defaults

The Calendar Report defaults to:
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e ATMPVC Name = All

o Dates/Times = Last 31 days

o Metric(s) Shown on Y1 Axis (Primary Metric) = Volume Bytes (sum)

o Metric(s) Shown on Y2 Axis (Secondary Metric) = CIR Utilization (avg)

The default view shows data for the current month. Depending on how long the iSPI has been
collecting data from NNMi, you may have the option of looking at data for the previous 70 days if
you use the option Until Now.

Note: If you set the Time Range below 24 hours, the following message appears:
This report is not designed to operate with a time range of less than
24 hours. Please modify your time selections.

Use Case

Use this report to observe:

o gradual trends over time

o isolated spikes

o to verify that an abnormal condition has returned to normal
o tomake comparisons

This report also reveals:

o Day of week patterns

o Hour of day patterns

For example, if utilization is spiking on Tuesdays, or if response time issues are occurring daily at
11:00 a.m., the report will highlight these events.

o To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

« To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Chart Detail Report

Chart Detail report enables you to perform a trend analysis for the network health and performance
based on historical virtual circuit health data.

The Chart Detail report displays a comparative analysis of the selected metrics for each time unit.

For example, if you need to compare how the volume of AAL5 CPCS PDUs received and sent was
affected by variance in the AAL5 CPCS PDU discards per millisecond for the past one week, you
can generate the Weekly ATM report for the selected node group.

You can also select two or more nodes, node groups, virtual circuits, or interface types to generate
Chart Detail report.

Using this report you can:
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Analyze the trend of network health and performance for multiple nodes, node groups, virtual
circuits, or virtual circuit groups based on one unit of time. Each unit of time is called as a
Display Grain. Each Display Grain is measured as follows:

= Five minutes for Hourly report

= One hour for daily report
= One day for weekly report
= One day for monthly report

Identify the virtual circuit that is causing any ups and downs in the network health and
performance.

Detect any persistent problem in the virtual circuit health and performance.

Compare network health and performance of more than two nodes, node groups, virtual circuits,
or virtual circuit groups based on historical virtual circuit health data.

The following are the available filters in the Time Controls pane for Chart Detail Report:

Start Date/Time
Time Range
Display Grain
Hour of day

Day of Week

Features and Defaults

The graph on this report tracks up to six metrics per axis over the selected time period. Unless you
modify the defaults, Chart Detail defaults to the following:

ATM PVC Name = All
Metric(s) Shown on Y1 Axis = Volume Bytes (sum)

Metric(s) Shown on Y2 Axis = CIR Utilization (avg)

The Chart Detail report displays the selected metrics using two Y axis.

The left Y axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

The right Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

To add another metric, click Options and then click '{F_bl

To remove a metric that you have already added, click Options and then click X.

The Chart Detail report enables you to view the data in the tabular format as well. To view the table,
click Options, and then select Table. The Table appears instead of the chart. To view both the
chart and the table, click Options, and then select Chart and Table.

To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.
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o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Heat Chart Report

The Heat Chart tracks the hourly performance of a single metric. The default metric is Volume -
Bytes (sum). The default time period is the last 31 days. Performance is color-coded, making it
easy to see whether performance has been satisfactory or unsatisfactory.

Features and Defaults

The legend at the top of the report maps a range of normalized performance values to a particular
color.

Beneath the legend, a table represents the normalized values of a performance metric (rows of the
table represent hours of the day; columns of the table represent days).

Each cell inside the table is color-coded and each cell inside the table indicates a specific value of

the metric. You can also hover the mouse pointer on the cell to see the absolute metric value of
each hour.

The default topology filters for the Heat Chart are as follows:
e ATMPVC Name = All

e Time Period = Last 31 days

e Hour of Day = All

o Day of Week = Al

¢ Metric = Volume - Bytes (sum)

Time range options are any period that is not less than 24 hours.

Use Case

Use the Heat Chart to identify gradual shifts from one range of performance to another range, to
spot an isolated instance of poor performance that affected the results for past 24 hours, to spot

day-of-week patterns, and to verify that an abnormal condition returned to normal after a problem
was corrected.

o To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

« To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.
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ATM Managed Inventory Report

Use the Managed Inventory Report to view the number of instances of each topology attribute seen
in the collected data within the selected time range. For example, if the report is run for ‘Last 1
Hour,” you will see the number of unique values for each attribute seen in the data collected over the
last hour. This report can be useful for checking, for example, the number of nodes polled over any
given time range.

You can use the available attributes to filter the data of your interest and create a report that
represents only the elements of your interest. The report presents the list of attributes in the form of
a table; the Count column of the table indicates the number of entries for each attribute. For
example, count 5 for the topology item Node Location means all nodes on your network can be
grouped based on 5 different locations that host the nodes.

You can use the following topology attributes with the virtual circuit Health reports:
¢ Qualified ATM PVC Name
o ATMPVC Name

e ATMPVCID

¢ Qualified Interface Name
o Interface Name

o Interface Alias

o Interface Physical Address
e ATMPVCUUID

o Node Name

¢ Node Contact

¢ Node Location

o Node Family

¢ Node Vendor

e NodeID

¢« Node UUID

¢ Interface ODBID

o Node ODBID

e Tenant Name

e Tenant UUID

o SecGroup Name

e SecGroup UUID)
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o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.
The Managed Inventory report may take significant time to build if you select a time range greater
than 24 hours.

The Managed Inventory report may take significant time to build if you select a time range greater
than 24 hours.

ATM Most Changed Report

This report compares performance the components for two different (consecutive) time periods and
ranks components by the amount of change. The sort order is most-changed to least-changed.

Features and Defaults

This report contains one table. The table provides data for one metric only.
The table columns are:

o Grouping by levels; one to five columns, each displaying a level

o Performance for the previous time period

o Performance for the current time period

o Growth, expressed as a percentage increase

e Change

The default filters for the Most Changed report defaults to:

o Grouping by Elements = Qualified ATM PVC Name

o Start Date/Time = depends on default Time Range and data available in database
o Hourof Day (HOD) = All

o Day of Week (DOW) = All

o Ranking Metric = Volume - Bytes (sum)

e Top N Option=Top 10

You can select multiple grouping attributes by using the '{EI (Add New Grouping) button. Use the
x (Remove Grouping) button to remove a grouping attribute.
Use Case

Use this report to spot objects at selected grouping level that saw significant growth from the
previous selected time period to the selected time period. Significant growth could point to a
developing problem you need to know about. You can change the ranking metric and you can
change how many elements are listed.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

Page 18 of 30 HP Network Node Manager iSPI Performance for Metrics Software (9.11)



Online Help
Chapter 1:

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Peak Period Report

The ATM Peak Period Report ranks the utilization and performance of an interface during the
busiest time of the selected time range.

Using this report, you can:
« lIdentify the performance and utilization of the selected metrics during the peak period.

o Identify the interfaces that have the highest or lowest performances or utilization levels during
the peak period.

o Compare the performance for multiple interfaces during the peak period using this report.
Use Case

Use this report to:

o Identify a group of virtual circuits having a common network performance problem.

« lIdentify the virtual circuit that is suffering from a persistent performance problem.

ATM Peak Period Report Options
e Top/ Bottom N1
e Select Metric(s)2
e Grouping by Time Period3

This report tracks up to six metrics over the selected time period.

To add another metric, click Options and then click '{F_hl

To remove a metric that you have already added, click Options and then click X_

To select a range of value for the metric, click '{F_hl , click ¥, and type a range of metric value that the
report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
« Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the

selected component.
2Select the metric based on which you want to generate the report. The metric that you select is

used to rank the report data.
SEnables you to group the report data based on a specific time grain. Click Add New Grouping icon

to add a new group.
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For example if you want to see the top five virtual circuits for the node 15.2.103.112 with the
average utilization between 10% and 90% type the following ranges:

¢ 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value
By default, the report groups data by Qualified ATM PVC Name. You can select multiple grouping

attributes by using the ﬁ (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

Tip:
o Use this report to identify the period when the virtual circuit utilization was the highest.
o Check this report once a day to see which virtual circuit may need special attention.

o Check this report periodically throughout the day to see which virtual circuit is performing at the
extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

To change the Report Options defaults, see Change Report Options in the Using Reports > Change
Default Settings section.

ATM Top N Report

This report ranks network elements by the metric that you select. Use this report to spot the
element that performed at the extremes. You can use this report to analyze the historical data for
elements that are exhibiting unusual utilization levels.

Using this report you can:
o Detect the ATM virtual circuits having a health or performance problem.

o Analyze the utilization of the NNMi managed ATM virtual circuits based on a specific time
range.

o Detect the over-utilized and under-utilized ATM virtual circuits in the network.

o Compare the performance of multiple ATM virtual circuits for a single node or multiple nodes
using this report.

Example

One of the routers in your network are performing poorly. Using this report, you can group the ATM
virtual circuit for the router reporting highest average error rate. The virtual circuit reporting the
highest average error rate is ranked first.

Interface Health Top N Reports Options
The Top N report displays the following options:
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e Top / Bottom N1

o Select Metric(s)z: The report ranks the selected virtual circuits based on the value of the first
metric listed in the Select Metric(s) field.

o Display Time Series Chart3
« Grouping By?#

This report tracks up to six metrics for each metric type over the selected time period.

To add another metric, click Options and then click '{F_bl

To remove a metric that you have already added, click Options and then click X.

To select a range of value for the metric, click '{EI click "I, and select a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five interfaces for the node 15.2.103.112 where the average
utilization between 10% and 90% type the following ranges:

¢ 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value
By default, the report groups data by Qualified ATM PVC Name. You can select multiple grouping

attributes by using the E (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

The Time Series Chart report displays the selected metrics using two Y axis.

e TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

Tip :

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

23elect the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.

3elect Yes to view the detail chart with the table. Select No to hide the chart and display only the
table. The created Top N Report displays the graphical representation of the metric values for the
components over the selected time range.

4Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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o By default, Top N Report does not display the Time Series Chart. To view the chart with the
detail table,perform any of the following steps:
= Select Options > Display Time Series Chart > Confirm Selection.

= Click Show Chart link below the detail table.
o Check this report once a day to see which network interface may need special attention.

o Check this report periodically throughout the day to see which network interfaces are performing
at the extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

To change the Report Options defaults, see Change Report Options in the Using Reports > Change
Default Settings section.

ATMTop N CSV Report

Top N report may have performance problem, as it retrieves huge amount of data from the NPS
database for the selected time range. To resolve this problem, NPS enables you to schedule the
following reports in CSV format:

e TopNCSV report1
e Top N Detail CSV repor’c2

ATM Top N Chart

Like the Top N report, this report also ranks the ATM virtual circuits by the metric you select.

Using this report, you can:

The Top N CSV report ranks selected topology element based on the utilization level of the
selected metric in the descending order.

2The Top N Detail CSV report lists the metric utilization for the selected topology element based on
the selected time grain.

This report displays the ranks the elements based on the total metric utilization for the selected time
range and breaks up the metric utilization value for each time grain. For example, you selected the
following options for the TOP N CSV report:

Time Range: Last 24 Hours. The default Display Grain for this time range is one hour.

Topology Element: Qualified ATM Pvc Name

Metric: Volume — Bytes (sum) and Utilization (avg)

The displayed report ranks the Qualified ATM Pvc Names based on the metric Volume — Bytes
(sum). The Qualified ATM Pvc Name with the highest volume of data passing through it receives
the highest rank. The Top N Detail CSV report then calculates and lists the volume of data passed
through this element every hour in last 24 hours.
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e Spot the virtual circuits that performed at the extremes.
« Analyze the historical data for virtual circuits that are exhibiting unusual utilization levels.
o Detect the virtual circuits having a health or performance problem.

o Analyze the utilization of the NNMi managed ATM virtual circuits based on a specific time
range.

o Detect the over-utilized and under-utilized ATM virtual circuits in the network.

o Detect the underlying reason of a persistent problem with a virtual circuit. You can compare the
performance for multiple virtual circuits using this report.

ATM Top N Chart Options
The Top N Chart displays the following options:
e Top/ Bottom N1
e Select Metric(s)2
o Grouping By3

This report tracks up to six metrics over the selected time period.

To add another metric, click Options and then click '{F_hl

To remove a metric that you have already added, click Options and then click X_

To select a range of value for the metric, click '{F_hl click ¥, and select a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
« Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five ATM virtual circuits for the node 15.2.103.112 with the
average utilization between 10% and 90% type the following ranges:

e 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value
By default, the report groups data by Qualified ATM PVC Name. You can select multiple grouping

attributes by using the ﬁ (Add New Grouping) button. Use the X (Remove Grouping) button
to remove a grouping attribute.

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

2Select the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.

3Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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The Top N Chart report displays the selected metrics using two Y axis.

e TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

Tip :
o Check this report once a day to see which interface may need special attention.

o Check this report periodically throughout the day to see which interfaces are performing at the
extremes and may need special attention.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

iSPI for Performance Reportlets

In a large enterprise network the NNM iSP| Performance products1 may produce a large amount
of data and large cardinality. This means that these networks often have a very large amount of
unique IP addresses, source nodes and destination nodes, virtual circuits, interfaces, and
components each producing large amount of data. Generating reports using such large data volume
may be time consuming.

Reportlets enable you to generate quick impressions of the larger reports using the iSPI for
Performance Dashboards.

Viewing iSPI for Performance Reportlets
To display the reportlets:

1. Loginto Network Performance Server (NPS) Home Page.

2. Onthe left navigation panel, select Dashboard Reportlets.
3. Select an extension pack and then select a reportlet.

You can also create custom dashboards using the reportlets. See Creating Custom Dashboards
Using Bl Server Portal for information on the procedure to create the custom dashboards.

Calendar

Displays a comparative study of the selected Primary Metric2 and Secondary Metric3

TNNM iSPI Performance for Metrics, NNM iSPI Performance for Quality Assurance, and NNM
iSPI Perforance for Traffic

2Enables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

SEnables you to select the metric that would overlay the primary metric. The secondary metric that
you select is displayed on the right Y axis of the report.
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The default display grain is set to one hour. You cannot change the display grain of this reportlet.
Enables you to monitor the following:

o Daily CIR or EIR utilization for the selected ATM virtual circuits

« Volume of data passed through the virtual circuit for past 24 hours

o Performance of the virtual circuit for past 24 hours

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Gauge
Evaluates the metric for the selected point of time.
Select only the metrics that displays the percentage values.
Enables you to:
o Measure the daily performance of the selected metric.
o Detect any abnormal or unexpected performance level.
This reportlet supports one metric.
When the NPS database has no data, the needle icon on the gauge does not appear.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Heat Chart

Grades the performance of the selected metric for the selected time range.

The metric performance is aggregated based on an hourly display grain.

Enables you to:

« View how the performance of the selected ATM virtual circuits get affected by a varying metric.
o Compare the hourly performance of the selected metric.

¢ Detect the time range when the performance of the selected ATM virtual circuits were affected
adversely because of the fluctuating metric value.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Metric Snapshot
Displays the metric performance for the selected time range.

Enables you to:
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o Build a performance history for the selected metric and analyze how the metric performance
changes over time.

Such history may help you to decide the baseline value for the metric
o Compare the performance for multiple metrics over a specified time range.

Though you can generate snapshot report for a single metric, you can save the snapshot report
for various metrics and compare the performance of each metric over a time range.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Most Changed
Compares the metric performance between the following:
o Selected time range
o Period preceding the selected time range
Aggregates the metric utilization and ranks the performance in a descending order.
Enables you to:
o Measure the performance fluctuations for the ATM virtual circuits.
o Detectthetop N ATM virtual circuits having a common performance or utilization problem.
You can enhance the reportlet usability using the following features:
e Top/ Bottom N
o Grouping By2
This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Option in the Using Reports >
Change Default Settings section..

Multimetric Chart
Analyzes the performance trend for the selected metrics for the selected time range.
Enables you to:
o Perform comparative analysis of the selected metrics for each display grain.
The default display grain is one hour.

¢ Analyze the reason for any ups and downs in the performance of the selected ATM virtual
circuits.

o Detect any persistent problem in the performance of the ATM virtual circuits.

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the

selected component.
2Organize the report data based on a specific parameter. Click Add New Grouping icon to add a

new group.
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This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Bar and Line Chart

Displays the trend of performance of the ATM virtual circuits for past 24 hours using the following
values:

e Primary Metric' on the bar chart

o Secondary Metric? on the line chart

Enables you to:

o Compare the performance trends of multiple metrics.

¢ Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Bar Chart
Compares the performance of two metrics for the selected time range.
Enables you to:
o Compare the performance trends of multiple metrics.

¢ Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Chart
Analyzes the utilization trend for the selected metrics for the selected time range.
Enables you to:
o Perform comparative analysis of the selected metrics for each display grain.

The default display grain is one hour.

TEnables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

Enables you to select the metric that would overlay the primary metric. The secondary metric that
you select is displayed on the right Y axis of the report.
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o Analyze the reason for any ups and downs in the performance of the selected ATM virtual
circuits.

o Detect any persistent problem in the performance of the selected ATM virtual circuits

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Table
Analyzes the utilization trend for the selected metrics for the selected time range.
The default display grain is one hour.
Enables you to:
¢ Analyze the hourly performance of the metrics.
o Detect any abnormal or unexpected performance for the selected ATM virtual circuits.

« Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Sparkline
Evaluates the trend of how the selected metric value has changed for the selected time range.
Enables you to:
¢ Analyze the variations in the performance for the selected metric.
o Decide whether the expected behavior for the selected metric should be reassessed.
This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Chart

Ranks the individual contribution of each metric for the performance for the selected ATM virtual
circuits for the selected time range.

The performance of the interface is aggregated on hourly basis.
Enables you to:
e Spot the virtual circuits for which the performance metrics present extreme values.

« Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.
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o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

o Group the report data based on a specific parameter. Click '{F_bl Add Group to add a subgroup.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Line Chart
Ranks the utilization trend for the selected metrics for the selected time range.
The performance of the virtual circuits is aggregated on hourly basis.
Enables you to:
e Spot the virtual circuits for which the performance metrics present extreme values.

o Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

o Group the report data based on a specific parameter. Click '{F_hl Add Group to add a subgroup.
This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Stacked Chart
Ranks the individual contribution of each virtual circuit based on the selected metrics.
The performance of each interface is aggregated for the default display grain of one hour.
Enables you to:
o Spot the virtual circuits for which the performance metrics present extreme values.

¢ Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

o Detect the network path having a common network performance problem.
This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Table
Ranks the interfaces based on the selected metric.

Enables you to:
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Spot the virtual circuits for which the performance metrics present extreme values.

Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

Group the report data based on a specific parameter. Click '{F_hl Add Group to add a subgroup.

This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Table With Bars

Ranks the ATM virtual circuits based on the selected metric and displays a horizontal bar to depict
the aggregated metric value.

Enables you to:

Spot the virtual circuits for which the performance metrics present extreme values.

Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

Group the report data based on a specific parameter. Click '{F_bl Add Group to add a subgroup.

This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.
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Glossary for ATM Metrics

Available only on ATM interfaces

Metric Name Description

AAL5VCC PDUs In

Total number of 32 bit and 64 bit AAL5S CPCS1 PDUs

received
on the selected AAL5 VCC (virtual circuit) at the selected
AALS5 interface

AAL5VCC PDUs Out Total number of 32 bit and 64 bit AAL5 CPCS PDUs
transmitted on the selected AALS5 virtual circuit at the
selected AALS interface

Discarded AAL5 VCC PDUs Total number of AAL5 CPCS PDUs dropped at the receive

side and transmit side of the selected AAL5 VCC at the
selected AALS interface

Calculated using the following formula:

([VCC Discarded AAL5 PDUs In] + [VCC
Discarded AAL5 PDUs Out])

Discarded AAL5 VCC PDUs
Percentage

Percentage of AAL5 CPCS PDUs dropped from the total
number of AAL5 CPCS PDUs received and transmitted on
the selected AAL5VCC

Calculated using the following formula:

([VCC Discarded AALS5 PDUs In]+ [VCC
Discarded AAL5 PDUs Out])/ (([VCC AAL5
PDUs QOut + VCC Discarded AALS5 PDUs
Out])+([VCC AAL5 PDUs Out + VCC Discarded
AAL5 PDUs Out])) /100

Discarded AAL5VCC PDUs In

Total number of AAL5 CPCS PDUs dropped at the receive
side of the selected AAL5 VCC at the selected AALS
interface

1Common Part Convergence Sublayer
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Discarded AAL5VCC PDUs In Percentage of AAL5 CPCS PDUs dropped from the total
Percentage number of AAL5 CPCS PDUs received

Calculated using the following formula:

[VCC Discarded AAL5 PDUs In]/ ([VCC AALS
PDUs In + VCC Discarded AAL5 PDUs In])

Discarded AAL5 VCC PDUs Out Total number of AAL5 CPCS PDUs dropped at the
transmit side of the selected AAL5 VCC at the selected
AALS5 interface

Discarded AAL5 VCC PDUs Out Percentage of AAL5 CPCS PDUs dropped from the total
Percentage number of AAL5 CPCS PDUs transmitted

Calculated using the following formula:

[VCC Discarded AAL5 PDUs Out]/ ([VCC AALS
PDUs Out + VCC Discarded AALS5 PDUs Out])

AAL5VCC In Octets Total number of 32 bit and 64 bit AAL5 CPCS PDU octets
received on the selected AALS virtual circuit at the
selected AALS interface

AAL5 VCC Out Octets Total number of 32 bit and 64 bit AAL5 CPCS PDU octets
transmitted on the selected AALS virtual circuit at the
selected AALS interface

AAL5 VCC In Utilization Average utilization for the selected virtual circuit
Calculated using the following formula:

([Number of octets received by the AALS

VCC] * 8 * 100)/([Interface in speed] *

Number of seconds the AAL5 interface was
available)

AALS5 VCC Out Utilization Average utilization for the selected virtual circuit
Calculated using the following formula:

([Number of octets transmitted by the
AAL5 VCC] * 8 * 100)/([Interface out
speed] * Number of seconds the AALS
interface was available)

Reboot (avg) Generated if the selected AALS interface was restarted
during the poll and no data could be retrieved from the
interface.

NNMi checks the sysUptime metric to determine whether
the interface was restarted during the last poll.

Unresponsive Target (avg) Generated when the SNMP agent did not respond when
collecting metrics for a particular polling policy.

Invalid Data (avg) Generated when NNMi has successfully polled data from
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the target, but has determined that the data is invalid. For
example, this metric is calculated when the number of
packets is greater than the number of octets.
Target Error (avg) Generated if the selected AALS interface returns any of the

following SNMP error responses:
¢ Authentication error
e Nosuchname

¢ No such object.

ATM Calendar Report

The Calendar Report uses a traditional, calendar-style layout to show hourly statistics for two
metrics in a single, extended graph spanning over multiple days.

Features and Defaults

The Calendar Report defaults to:

e ATMPVC Name = All

o Dates/Times = Last 31 days

o Metric(s) Shown on Y1 Axis (Primary Metric) = Volume Bytes (sum)

o Metric(s) Shown on Y2 Axis (Secondary Metric) = CIR Utilization (avg)

The default view shows data for the current month. Depending on how long the iSPI has been
collecting data from NNMi, you may have the option of looking at data for the previous 70 days if
you use the option Until Now.

Note: If you set the Time Range below 24 hours, the following message appears:
This report is not designed to operate with a time range of less than
24 hours. Please modify your time selections.

Use Case

Use this report to observe:
o gradual trends over time
o isolated spikes

to verify that an abnormal condition has returned to normal

o tomake comparisons
This report also reveals:
o Day of week patterns
e Hour of day patterns

For example, if utilization is spiking on Tuesdays, or if response time issues are occurring daily at
11:00 a.m., the report will highlight these events.

Page 3 of 20 HP Network Node Manager iSPI Performance for Metrics Software (9.11)




Online Help
Chapter 1:

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Chart Detail Report

Chart Detail report enables you to perform a trend analysis for the network health and performance
based on historical virtual circuit health data.

The Chart Detail report displays a comparative analysis of the selected metrics for each time unit.

For example, if you need to compare how the volume of AAL5 CPCS PDUs received and sent was
affected by variance in the AAL5 CPCS PDU discards per millisecond for the past one week, you
can generate the Weekly ATM report for the selected node group.

You can also select two or more nodes, node groups, virtual circuits, or interface types to generate
Chart Detail report.

Using this report you can:

o Analyze the trend of network health and performance for multiple nodes, node groups, virtual
circuits, or virtual circuit groups based on one unit of time. Each unit of time is called as a
Display Grain. Each Display Grain is measured as follows:
= Five minutes for Hourly report

= One hour for daily report
= One day for weekly report
= One day for monthly report

o Identify the virtual circuit that is causing any ups and downs in the network health and
performance.

o Detect any persistent problem in the virtual circuit health and performance.

o Compare network health and performance of more than two nodes, node groups, virtual circuits,
or virtual circuit groups based on historical virtual circuit health data.

The following are the available filters in the Time Controls pane for Chart Detail Report:
o Start Date/Time

o Time Range

¢ Display Grain

o Hour of day

o Day of Week

Features and Defaults

The graph on this report tracks up to six metrics per axis over the selected time period. Unless you
modify the defaults, Chart Detail defaults to the following:
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e ATMPVC Name = All

o Metric(s) Shown on Y1 Axis = Volume Bytes (sum)

o Metric(s) Shown on Y2 Axis = CIR Utilization (avg)

The Chart Detail report displays the selected metrics using two Y axis.

o TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

To add another metric, click Options and then click '{F_hl

To remove a metric that you have already added, click Options and then click X_

The Chart Detail report enables you to view the data in the tabular format as well. To view the table,
click Options, and then select Table. The Table appears instead of the chart. To view both the
chart and the table, click Options, and then select Chart and Table.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Heat Chart Report

The Heat Chart tracks the hourly performance of a single metric. The default metric is Volume -
Bytes (sum). The default time period is the last 31 days. Performance is color-coded, making it
easy to see whether performance has been satisfactory or unsatisfactory.

Features and Defaults

The legend at the top of the report maps a range of normalized performance values to a particular
color.

Beneath the legend, a table represents the normalized values of a performance metric (rows of the
table represent hours of the day; columns of the table represent days).

Each cell inside the table is color-coded and each cell inside the table indicates a specific value of
the metric. You can also hover the mouse pointer on the cell to see the absolute metric value of
each hour.

The default topology filters for the Heat Chart are as follows:
e ATMPVC Name = All

e Time Period = Last 31 days

o Hourof Day = All
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e Day of Week = Al
e Metric = Volume - Bytes (sum)

Time range options are any period that is not less than 24 hours.
Use Case

Use the Heat Chart to identify gradual shifts from one range of performance to another range, to

spot an isolated instance of poor performance that affected the results for past 24 hours, to spot

day-of-week patterns, and to verify that an abnormal condition returned to normal after a problem
was corrected.

« To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Managed Inventory Report

Use the Managed Inventory Report to view the number of instances of each topology attribute seen
in the collected data within the selected time range. For example, if the report is run for ‘Last 1
Hour,” you will see the number of unique values for each attribute seen in the data collected over the
last hour. This report can be useful for checking, for example, the number of nodes polled over any
given time range.

You can use the available attributes to filter the data of your interest and create a report that
represents only the elements of your interest. The report presents the list of attributes in the form of
atable; the Count column of the table indicates the number of entries for each attribute. For
example, count 5 for the topology item Node Location means all nodes on your network can be
grouped based on 5 different locations that host the nodes.

You can use the following topology attributes with the virtual circuit Health reports:
¢ Qualified ATM PVC Name
o ATMPVC Name

e ATMPVCID

¢ Qualified Interface Name

o Interface Name

¢ Interface Alias

o Interface Physical Address
« ATMPVC UUID

e Node Name

¢ Node Contact

o Node Location
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o Node Family

¢ Node Vendor

e NodelD

e Node UUID

¢ Interface ODBID
o Node ODBID

e Tenant Name

e Tenant UUID

o SecGroup Name

e SecGroup UUID)

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

« Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.
The Managed Inventory report may take significant time to build if you select a time range greater
than 24 hours.

The Managed Inventory report may take significant time to build if you select a time range greater
than 24 hours.

ATM Most Changed Report

This report compares performance the components for two different (consecutive) time periods and
ranks components by the amount of change. The sort order is most-changed to least-changed.

Features and Defaults

This report contains one table. The table provides data for one metric only.
The table columns are:

« Grouping by levels; one to five columns, each displaying a level

o Performance for the previous time period

o Performance for the current time period

o Growth, expressed as a percentage increase

¢ Change

The default filters for the Most Changed report defaults to:

Grouping by Elements = Qualified ATM PVC Name

Start Date/Time = depends on default Time Range and data available in database
Hour of Day (HOD) = All
Day of Week (DOW) = All
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e Ranking Metric = Volume - Bytes (sum)

e Top N Option=Top 10

You can select multiple grouping attributes by using the '{F._hl (Add New Grouping) button. Use the
x (Remove Grouping) button to remove a grouping attribute.
Use Case

Use this report to spot objects at selected grouping level that saw significant growth from the
previous selected time period to the selected time period. Significant growth could point to a
developing problem you need to know about. You can change the ranking metric and you can
change how many elements are listed.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

« Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

ATM Peak Period Report

The ATM Peak Period Report ranks the utilization and performance of an interface during the
busiest time of the selected time range.

Using this report, you can:
« Identify the performance and utilization of the selected metrics during the peak period.

« lIdentify the interfaces that have the highest or lowest performances or utilization levels during
the peak period.

o Compare the performance for multiple interfaces during the peak period using this report.
Use Case

Use this report to:

o Identify a group of virtual circuits having a common network performance problem.

« Identify the virtual circuit that is suffering from a persistent performance problem.

ATM Peak Period Report Options

e Top/ Bottom N

o Select Metric(s)2

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the

selected component.
2Select the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.
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¢ Grouping by Time Period’

This report tracks up to six metrics over the selected time period.

To add another metric, click Options and then click '{F_bl

To remove a metric that you have already added, click Options and then click X.

To select a range of value for the metric, click '{EI click 7, and type a range of metric value that the
report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five virtual circuits for the node 15.2.103.112 with the
average utilization between 10% and 90% type the following ranges:

¢ 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value
By default, the report groups data by Qualified ATM PVC Name. You can select multiple grouping

attributes by using the ﬁ (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

Tip:
o Use this report to identify the period when the virtual circuit utilization was the highest.
o Check this report once a day to see which virtual circuit may need special attention.

o Check this report periodically throughout the day to see which virtual circuit is performing at the
extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

To change the Report Options defaults, see Change Report Options in the Using Reports > Change
Default Settings section.

ATM Top N Report

This report ranks network elements by the metric that you select. Use this report to spot the
element that performed at the extremes. You can use this report to analyze the historical data for
elements that are exhibiting unusual utilization levels.

Using this report you can:

TEnables you to group the report data based on a specific time grain. Click Add New Grouping icon
to add a new group.

Page 9 of 20 HP Network Node Manager iSPI Performance for Metrics Software (9.11)



Online Help
Chapter 1:

o Detect the ATM virtual circuits having a health or performance problem.

o Analyze the utilization of the NNMi managed ATM virtual circuits based on a specific time
range.

o Detect the over-utilized and under-utilized ATM virtual circuits in the network.
o Compare the performance of multiple ATM virtual circuits for a single node or multiple nodes
using this report.

Example

One of the routers in your network are performing poorly. Using this report, you can group the ATM
virtual circuit for the router reporting highest average error rate. The virtual circuit reporting the
highest average error rate is ranked first.

Interface Health Top N Reports Options

The Top N report displays the following options:
e Top/ Bottom N

o Select Metric(s)2: The report ranks the selected virtual circuits based on the value of the first
metric listed in the Select Metric(s) field.

o Display Time Series Chart3
o Grouping By4

This report tracks up to six metrics for each metric type over the selected time period.

To add another metric, click Options and then click '{F_hl

To remove a metric that you have already added, click Options and then click X_

To select a range of value for the metric, click '{F_hl click ¥, and select a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
« Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

23elect the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.

3elect Yes to view the detail chart with the table. Select No to hide the chart and display only the
table. The created Top N Report displays the graphical representation of the metric values for the
components over the selected time range.

4Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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For example if you want to see the top five interfaces for the node 15.2.103.112 where the average
utilization between 10% and 90% type the following ranges:

¢ 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value
By default, the report groups data by Qualified ATM PVC Name. You can select multiple grouping

attributes by using the E (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

The Time Series Chart report displays the selected metrics using two Y axis.

e TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

Tip :
o By default, Top N Report does not display the Time Series Chart. To view the chart with the

detail table,perform any of the following steps:
= Select Options > Display Time Series Chart > Confirm Selection.

= Click Show Chart link below the detail table.
o Check this report once a day to see which network interface may need special attention.

o Check this report periodically throughout the day to see which network interfaces are performing
at the extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

To change the Report Options defaults, see Change Report Options in the Using Reports > Change
Default Settings section.

ATMTop N CSV Report

Top N report may have performance problem, as it retrieves huge amount of data from the NPS
database for the selected time range. To resolve this problem, NPS enables you to schedule the
following reports in CSV format:
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e TopNCSV report1
e Top N Detail CSV repor’c2

ATM Top N Chart

Like the Top N report, this report also ranks the ATM virtual circuits by the metric you select.
Using this report, you can:

e Spot the virtual circuits that performed at the extremes.

« Analyze the historical data for virtual circuits that are exhibiting unusual utilization levels.
o Detect the virtual circuits having a health or performance problem.

o Analyze the utilization of the NNMi managed ATM virtual circuits based on a specific time
range.

o Detect the over-utilized and under-utilized ATM virtual circuits in the network.

o Detect the underlying reason of a persistent problem with a virtual circuit. You can compare the
performance for multiple virtual circuits using this report.

ATM Top N Chart Options
The Top N Chart displays the following options:
e Top/ Bottom N3

o Select Metric(s)4

¢ Grouping By5

1The Top N CSV report ranks selected topology element based on the utilization level of the
selected metric in the descending order.

2The Top N Detail CSV report lists the metric utilization for the selected topology element based on
the selected time grain.

This report displays the ranks the elements based on the total metric utilization for the selected time
range and breaks up the metric utilization value for each time grain. For example, you selected the
following options for the TOP N CSV report:

Time Range: Last 24 Hours. The default Display Grain for this time range is one hour.

Topology Element: Qualified ATM Pvc Name

Metric: Volume — Bytes (sum) and Utilization (avg)

The displayed report ranks the Qualified ATM Pvc Names based on the metric Volume — Bytes
(sum). The Qualified ATM Pvc Name with the highest volume of data passing through it receives
the highest rank. The Top N Detail CSV report then calculates and lists the volume of data passed
through this element every hour in last 24 hours.

3Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

4Select the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.

5Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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This report tracks up to six metrics over the selected time period.

To add another metric, click Options and then click '{F_bl

To remove a metric that you have already added, click Options and then click X.

To select a range of value for the metric, click '{F._hl click ¥, and select a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five ATM virtual circuits for the node 15.2.103.112 with the
average utilization between 10% and 90% type the following ranges:

e 0.10r10% as Lowest Value
o 0.90r90% as the Highest Value
By default, the report groups data by Qualified ATM PVC Name. You can select multiple grouping

attributes by using the ﬁ (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

The Top N Chart report displays the selected metrics using two Y axis.

e TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

Tip :
o Check this report once a day to see which interface may need special attention.

o Check this report periodically throughout the day to see which interfaces are performing at the
extremes and may need special attention.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

« Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.
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iISPI for Performance Reportlets

In a large enterprise network the NNM iSP| Performance products1 may produce a large amount
of data and large cardinality. This means that these networks often have a very large amount of
unique IP addresses, source nodes and destination nodes, virtual circuits, interfaces, and
components each producing large amount of data. Generating reports using such large data volume
may be time consuming.

Reportlets enable you to generate quick impressions of the larger reports using the iSPI for
Performance Dashboards.

Viewing iSPI for Performance Reportlets
To display the reportlets:

1. Loginto Network Performance Server (NPS) Home Page.

2. Onthe left navigation panel, select Dashboard Reportlets.
3. Select an extension pack and then select a reportlet.

You can also create custom dashboards using the reportlets. See Creating Custom Dashboards
Using Bl Server Portal for information on the procedure to create the custom dashboards.

Calendar
Displays a comparative study of the selected Primary Metric2 and Secondary Metric3
The default display grain is set to one hour. You cannot change the display grain of this reportlet.
Enables you to monitor the following:
o Daily CIR or EIR utilization for the selected ATM virtual circuits
« Volume of data passed through the virtual circuit for past 24 hours
o Performance of the virtual circuit for past 24 hours
This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Gauge
Evaluates the metric for the selected point of time.
Select only the metrics that displays the percentage values.

Enables you to:

TNNM iSPI Performance for Metrics, NNM iSPI Performance for Quality Assurance, and NNM
iSPI Perforance for Traffic

2Enables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

SEnables you to select the metric that would overlay the primary metric. The secondary metric that
you select is displayed on the right Y axis of the report.
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o Measure the daily performance of the selected metric.

o Detect any abnormal or unexpected performance level.

This reportlet supports one metric.

When the NPS database has no data, the needle icon on the gauge does not appear.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Heat Chart
Grades the performance of the selected metric for the selected time range.
The metric performance is aggregated based on an hourly display grain.
Enables you to:
o View how the performance of the selected ATM virtual circuits get affected by a varying metric.
o Compare the hourly performance of the selected metric.

o Detect the time range when the performance of the selected ATM virtual circuits were affected
adversely because of the fluctuating metric value.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Metric Snapshot
Displays the metric performance for the selected time range.
Enables you to:

o Build a performance history for the selected metric and analyze how the metric performance
changes over time.

Such history may help you to decide the baseline value for the metric
o Compare the performance for multiple metrics over a specified time range.

Though you can generate snapshot report for a single metric, you can save the snapshot report
for various metrics and compare the performance of each metric over a time range.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Most Changed
Compares the metric performance between the following:
o Selected time range
o Period preceding the selected time range
Aggregates the metric utilization and ranks the performance in a descending order.

Enables you to:
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o Measure the performance fluctuations for the ATM virtual circuits.

o Detectthetop N ATM virtual circuits having a common performance or utilization problem.
You can enhance the reportlet usability using the following features:

e Top/ Bottom N1

e Grouping By2

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Option in the Using Reports >
Change Default Settings section..

Multimetric Chart
Analyzes the performance trend for the selected metrics for the selected time range.
Enables you to:
o Perform comparative analysis of the selected metrics for each display grain.
The default display grain is one hour.

¢ Analyze the reason for any ups and downs in the performance of the selected ATM virtual
circuits.

o Detect any persistent problem in the performance of the ATM virtual circuits.
This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Bar and Line Chart

Displays the trend of performance of the ATM virtual circuits for past 24 hours using the following
values:

e Primary Metric3 on the bar chart
o Secondary Metric on the line chart

Enables you to:

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

2Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.

SEnables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

4Enables you to select the metric that would overlay the primary metric. The secondary metric that
you select is displayed on the right Y axis of the report.
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o Compare the performance trends of multiple metrics.

« Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Bar Chart
Compares the performance of two metrics for the selected time range.
Enables you to:
o Compare the performance trends of multiple metrics.

« Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Chart
Analyzes the utilization trend for the selected metrics for the selected time range.
Enables you to:
o Perform comparative analysis of the selected metrics for each display grain.
The default display grain is one hour.

¢ Analyze the reason for any ups and downs in the performance of the selected ATM virtual
circuits.

o Detect any persistent problem in the performance of the selected ATM virtual circuits
This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Table
Analyzes the utilization trend for the selected metrics for the selected time range.
The default display grain is one hour.
Enables you to:
o Analyze the hourly performance of the metrics.
o Detect any abnormal or unexpected performance for the selected ATM virtual circuits.

¢ Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports up to six metrics.
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To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Sparkline
Evaluates the trend of how the selected metric value has changed for the selected time range.
Enables you to:
¢ Analyze the variations in the performance for the selected metric.
o Decide whether the expected behavior for the selected metric should be reassessed.
This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Chart

Ranks the individual contribution of each metric for the performance for the selected ATM virtual
circuits for the selected time range.

The performance of the interface is aggregated on hourly basis.
Enables you to:
o Spot the virtual circuits for which the performance metrics present extreme values.

o Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

o Group the report data based on a specific parameter. Click '{F_bl Add Group to add a subgroup.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Line Chart
Ranks the utilization trend for the selected metrics for the selected time range.
The performance of the virtual circuits is aggregated on hourly basis.
Enables you to:
e Spot the virtual circuits for which the performance metrics present extreme values.

¢ Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

o Group the report data based on a specific parameter. Click '{F_bl Add Group to add a subgroup.

This reportlet supports one metric.
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To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Stacked Chart
Ranks the individual contribution of each virtual circuit based on the selected metrics.
The performance of each interface is aggregated for the default display grain of one hour.
Enables you to:
o Spot the virtual circuits for which the performance metrics present extreme values.

o Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

o Detect the network path having a common network performance problem.
This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Table
Ranks the interfaces based on the selected metric.
Enables you to:
e Spot the virtual circuits for which the performance metrics present extreme values.

« Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

o Group the report data based on a specific parameter. Click '{F_hl Add Group to add a subgroup.

This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Table With Bars

Ranks the ATM virtual circuits based on the selected metric and displays a horizontal bar to depict
the aggregated metric value.

Enables you to:
e Spot the virtual circuits for which the performance metrics present extreme values.

¢ Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

o Group the report data based on a specific parameter. Click '{F_bl Add Group to add a subgroup.

This reportlet supports up to six metrics.
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To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.
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Frame Relay Reports

The Frame Relay reports show the performance data for the Frame Relay PVC data collected by
NNMi. Graphs and charts on Frame Relay reports reflect the details that help you identify the
following:

« Volume of data passed through the selected Frame Relay virtual circuits

¢ CIR and EIR utilization of the selected Frame Relay virtual circuits

o Number of discarded frames in the selected Frame Relay virtual circuits

o Number of frames marked for discard for the selected Frame Relay virtual circuits

o Number of frames received from the network indicating backward or forward congestion for the
selected Frame Relay virtual circuits

Use Frame Relay reports to determine the status of the Frame Relay virtual circuits on your
network.

Opening Reports from NNMi

From the NNMi Console, you have the following options to open reports:
o Move from NNMi to the iSPI, and launch reports from the Report tab in the navigation panel.
o Launch pre-filtered reports directly from NNMi.

If you are interested in a particular node group, node, interface, or virtual circuit, you will probably
want to launch a pre-filtered report from NNMi; otherwise, open a workspace view from NNM, move
to the iSPI, and begin your investigation from NPS Home Page. To move from NNM to the iSPI:

1. Log on to the NNMi console.

2. Select aworkspace.

3. Open aview of nodes, interfaces, or incidents.
4

Select Actions > Reporting - Report Menu

Glossary for Frame Relay Health Metrics

Available only on Frame Relay interfaces
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Metric Name Description

Discards - Frames (sum) Total number of inbound frames dropped due to any of the
following reasons:

o Format errors

o Inactive Virtual Circuit (VC)

BECN In - Frames (sum) Total number of frames received from the network indicating
backward congestion since the VC was created.

Backward congestion occurs in the following
circumstances:

o When the remote DTE sets the BECN flag to 1.

o When a switch in the network receives the frame from a
trunk with congested transmission queue.

FECN In - Frames (sum) Total number of frames received from the network indicating
forward congestion since the VC was created.

Forward congestion occurs in the following circumstances:
o When the remote DTE sets the FECN2 flagto 1.

o When a switch in the network enqueues the frame to a
trunk with congested transmission queue.

1 Backward-Explicit Congestion Notification (BECN): The BECN bit is part of the Address field in
the Frame Relay frame header. DCE devices set the value of the BECN bit to 1 in frames traveling
in the opposite direction of frames with their FECN bit set. This informs the receiving DTE device
that a particular path through the network is congested. The DTE device then relays this information
to a higher-layer protocol for processing. Depending on the implementation, the higher-layer
protocol may initiate flow-control ignore the indication.

2Forward-Explicit Congestion Notification (FECN): The FECN bit is part of the Address field in the
Frame Relay frame header. The FECN mechanism is initiated when a DTE device sends Frame
Relay frames into the network. If the network is congested, DCE devices (switches) set the value
of the frames' FECN bit to 1. When the frames reach the destination DTE device, the Address field
(with the FECN bit set) indicates that the frame experienced congestion in the path from source to
destination. The DTE device relays this information to a higher-layer protocol for processing.

Depending on the implementation, the higher-layer protocol then may initiate flow-control or ignore
the indication.
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FECN Frames In Rate
e avg
e Mmin

e Mmax

Rate of frames received from the network indicating forward
congestion as compared to the total number of frames
received over the selected VC

Calculated using the following formula:

100.00 =
congestion / Sum of frames received)

(Sum of frames indicating forward

BECN Frames In Rate
e avg
e min

e Max

Rate of frames received from the network indicating
backward congestion as compared to the total number of
frames received over the selected VC

Calculated using the following formula:

100.00 ~*
backward congestion / Sum of frames

(Sum of frames indicating

received)

FECNPIusBECN Frames In Rate
e avg
e min

e Mmax

Rate of frames received from the network indicating
congestion (backward or forward) as compared to the total
number of frames received over the selected VC

Calculated using the following formula:

100.00 *
backward congestion + Sum of frames
indicating forward congestion) / Sum of
frames received

(Sum of frames indicating

DE Frames In Rate
e avg
e min

e Mmax

Rate of frames received from network that were eligible for
discard as compared to the total number of frames received
over the selected VC

100.00 =
for discard / Sum of frames received)

(Sum of frames marked as eligible

DE Frames Out Rate
e avg
e Mmin

e Mmax

Rate of frames sent to the network that were eligible for
discard as compared to the total number of frames sent over
the selected VC

100.00 =
for discard / Number of frames sent)

(Sum of frames marked as eligible

Volume - Bytes (sum)

Total number of octets received and sent over the selected
VC for the time range that you selected.

Volume - Bytes In (sum)

Total number of octets received over the selected VC for
the time range that you selected.

Volume - Bytes Out (sum)

Total number of octets sent over the selected VC for the
time range that you selected.
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Volume - Frames (sum) Total number of frames received and sent over the selected
VC for the time range that you selected

Volume - Frames In (sum) Total number of frames received over the selected VC for
the time range that you selected.

Volume - Frames Out (sum) Total number of frames sent over the selected VC for the
time range that you selected.

Volume - DE Frames (sum) Total number of frames sent and received from the network
that were eligible for discard for the selected VC for the time
range you selected.

Volume - DE Frames In (sum) Total number of frames received from the network that were
eligible for discard for the selected VC for the time range
you selected.

Volume - DE Frames Out (sum) Total number of frames sent to the network that were
eligible for discard for the selected VC for the time range
you selected.

Volume - NonDE Frames (sum) Total number of frames sent and received from the network
that were not eligible for discard for the selected VC for the
time range you selected.

Calculated using the following formula:

(Sum of frames sent from the selected VC +
Sum of frames received on the selected VC)
- (Sum of DE frames sent from the selected
VC + Sum of DE frames received on the
selected VC)

Volume - NonDE Frames In (sum) [ Total number of frames received from the network that were
not eligible for discard for the selected VC for the time range
you selected.

Calculated using the following formula:

(Sum of frames received on the selected
VC) - (Sum of DE frames received on the
selected VC)

Volume - NonDE Frames Out Total number of frames sent to the network that were not
(sum) eligible for discard for the VC for the selected time range

Calculated using the following formula:

(Sum of frames sent from the selected VC)
- (Sum of DE frames sent from the selected
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VvC)

Frames Size - Bytes
e avg
e min

e Mmax

Sum of octets in total number of frames sent and received
over the VC for the selected time range

Frames Size - Bytes In
e avg
e min

e Mmax

Sum of octets in total number of frames received over the
VC for the selected time range

Frames Size - Bytes Out
e avg
e min

e Mmax

Sum of octets in total number of frames sent over the VC for
the selected time range

CIR Utilization
e avg
e Mmin

e Mmax

Amount of data (in bits) that the selected VC agrees to
transmit under normal conditions.

CIR In Utilization
e avg
e min

e Mmax

Amount of data (in bits) that the selected VC receives under
normal conditions.

Calculated using the following formula:

(Number of octets received * 8 * 100)/(CIR
* SySUpTimeDelta1 in seconds)

CIR Out Utilization
e avg
e min

e Mmax

Amount of data (in bits) that the selected VC sends under
normal conditions.

Calculated using the following formula:

(Number of octets sent * 8 * 100)/(CIR *
sysUpTimeDeltal in seconds)

LINumber of seconds since the node was restarted.
LINumber of seconds since the node was restarted.
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EIR Utilization
e avg
e Mmin

e Mmax

Amount of uncommitted data bits that the selected VC
attempts to transmit over the selected time period.

EIR In Utilization
e avg
e min

e Max

Amount of uncommitted data bits that the selected VC
receives over the selected time period.

EIR Out Utilization
e avg
e Mmin

e Mmax

Amount of uncommitted data bits that the selected VC
sends over the selected time period.

Availability

The state of the VC, as reported to NPS. The state can be
either active or not active.

SNMP Response Time (msecs)

The time it takes the VC to respond to an SNMP request
from NNMi

Period Length (secs)

The duration (in seconds) between consecutive polling
cycles of NNMi.

Unresponsive Target

Generated when the SNMP agent did not respond when
collecting metrics for a particular polling policy.

Target Error

Generated if the target VC returns any of the following
SNMP error responses:

o Authentication error
¢ Nosuchname

o No such object

Reboot

Generated if the target VC was restarted during the poll and
no data could be retrieved from the component.

Invalid Data

Generated when NNMi has successfully polled data from
the target, but has determined that the data is invalid. For
example, this metric is calculated when the number of
packets is greater than the number of octets.
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Frame Relay Reports

The Frame Relay reports show the performance data for the Frame Relay virtual circuits in your
environment.

Use Frame Relay reports to determine if a virtual circuit is over-utilized or if it needs an upgrade.

Opening Reports from NNMi
From the NNMi Console, you have these options:

o Click the Reporting - Report Menu option under the Actions menu; launch reports from the
Report tab in the navigation panel.

o Launching Pre-Filtered iSPI Reports Directly from NNMi

If you are interested in a particular interface, launch a pre-filtered report from NNMi; otherwise,
open a workspace view from NNMi, move to the iSPI, and begin your investigation from the
NPS Home Page. To move from NNMi to the iSPI:

a. Logintothe NNMi Console.
b. Select aworkspace.
c. Open aview (nodes, interfaces, components, or incidents).

d. Select Actions > Reporting - Report Menu page.

Frame Relay Calendar Report

The Calendar Report uses a traditional, calendar-style layout to show hourly statistics for two
metrics in a single, extended graph spanning over multiple days.

Features and Defaults

The Calendar Report defaults to:

o FrameRelay Pvc Name = All

o Dates/Times = Last 31 days

o Metric(s) Shown on Y1 Axis (Primary Metric) = Volume Bytes (sum)

o Metric(s) Shown on Y2 Axis (Secondary Metric) = CIR Ultilization (avg)

The default view shows data for the current month. Depending on how long the iSPI has been
collecting data from NNMi, you may have the option of looking at data for the previous 70 days if
you use the option Until Now.

Note: If you set the Time Range below 24 hours, the following message appears:
This report is not designed to operate with a time range of less than
24 hours. Please modify your time selections.

Use Case
Use this report to observe:
e gradual trends over time

o isolated spikes
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o to verify that an abnormal condition has returned to normal
o tomake comparisons

This report also reveals:

o Day of week patterns

o Hour of day patterns

For example, if utilization is spiking on Tuesdays, or if response time issues are occurring daily at
11:00 a.m., the report will highlight these events.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

« Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Frame Relay Chart Detail Report

Chart Detail report enables you to perform a trend analysis for the network health and performance
based on historical virtual circuit health data.

The Chart Detail report displays a comparative analysis of the selected metrics for each time unit.

For example, if you need to compare how the volume of frames received and sent was affected by
variance in the frame discards per millisecond for the past one week, you can generate the Weekly
Frame Relay report for the selected node group.

You can also select two or more nodes, node groups, virtual circuits, or interface types to generate
Chart Detail report.

Using this report you can:

o Analyze the trend of network health and performance for multiple nodes, node groups, virtual
circuits, or virtual circuit groups based on one unit of time. Each unit of time is called as a
Display Grain. Each Display Grain is measured as follows:
= Five minutes for Hourly report

= One hour for daily report
= One day for weekly report
= One day for monthly report

o Identify the virtual circuit that is causing any ups and downs in the network health and
performance.

o Detect any persistent problem in the virtual circuit health and performance.

e Compare network health and performance of more than two nodes, node groups, virtual circuits,
or virtual circuit groups based on historical virtual circuit health data.

The following are the available filters in the Time Controls pane for Chart Detail Report:
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o Start Date/Time

o Time Range

¢ Display Grain

o Hour of day

o Day of Week
Features and Defaults

The graph on this report tracks up to six metrics per axis over the selected time period. Unless you
modify the defaults, Chart Detail defaults to the following:

o FrameRelay Pvc Name = All

o Metric(s) Shown on Y1 Axis = Volume Bytes (sum)

¢ Metric(s) Shown on Y2 Axis = CIR Utilization (avg)

The Chart Detail report displays the selected metrics using two Y axis.

o Theleft Y axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

e TherightY axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

To add another metric, click Options and then click '{F_hl

To remove a metric that you have already added, click Options and then click X_

The Chart Detail report enables you to view the data in the tabular format as well. To view the table,
click Options, and then select Table. The Table appears instead of the chart. To view both the
chart and the table, click Options, and then select Chart and Table.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Frame Relay Heat Chart Report

The Heat Chart tracks the hourly performance of a single metric. The default metric is Volume -
Bytes (sum). The default time period is the last 31 days. Performance is color-coded, making it
easy to see whether performance has been satisfactory or unsatisfactory.

Features and Defaults

The legend at the top of the report maps a range of normalized performance values to a particular
color.

Beneath the legend, a table represents the normalized values of a performance metric (rows of the
table represent hours of the day; columns of the table represent days).
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Each cell inside the table is color-coded and each cell inside the table indicates a specific value of
the metric. You can also hover the mouse pointer on the cell to see the absolute metric value of
each hour.

The default topology filters for the Heat Chart are as follows:
o FrameRelay Pvc Name = All

e Time Period = Last 31 days

e Hour of Day = All

o Day of Week = Al

o Metric = Volume - Bytes (sum)

Time range options are any period that is not less than 24 hours.

Use Case

Use the Heat Chart to identify gradual shifts from one range of performance to another range, to
spot an isolated instance of poor performance that affected the results for past 24 hours, to spot

day-of-week patterns, and to verify that an abnormal condition returned to normal after a problem
was corrected.

o To change the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

« To change the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Frame Relay Managed Inventory Report

Use the Managed Inventory Report to view the number of instances of each topology attribute seen
in the collected data within the selected time range. For example, if the report is run for ‘Last 1
Hour,” you will see the number of unique values for each attribute seen in the data collected over the
last hour. This report can be useful for checking, for example, the number of nodes polled over any
given time range.

You can use the available attributes to filter the data of your interest and create a report that
represents only the elements of your interest. The report presents the list of attributes in the form of
atable; the Count column of the table indicates the number of entries for each attribute. For
example, count 5 for the topology item Node Location means all nodes on your network can be
grouped based on 5 different locations that host the nodes.

You can use the following topology attributes with the virtual circuit Health reports:
o Qualified FrameRelay Name

e FrameRelay Pvc Name

e FrameRelay Pvc DLCI

e FrameRelay Pvc ID

e Qualified Interface Name
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¢ Interface Name

o Interface Alias

o Interface Physical Address
e FrameRelay Pvc ID

o FrameRelay Pvc UUID
e Node Name

¢ Node Contact

¢ Node Location

o Node Family

¢ Node Vendor

e NodelD

e Node UUID

¢ Interface ODBID

o Node ODBID

e Tenant Name

e Tenant UUID

o SecGroup Name

e SecGroup UUID)

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

« Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.
The Managed Inventory report may take significant time to build if you select a time range greater
than 24 hours.

The Managed Inventory report may take significant time to build if you select a time range greater
than 24 hours.

Frame Relay Most Changed Report

This report compares performance the components for two different (consecutive) time periods and
ranks components by the amount of change. The sort order is most-changed to least-changed.

Features and Defaults

This report contains one table. The table provides data for one metric only.
The table columns are:

« Grouping by levels; one to five columns, each displaying a level

o Performance for the previous time period
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o Performance for the current time period

o Growth, expressed as a percentage increase

o Change

The default filters for the Most Changed report defaults to:

¢ Grouping by Elements = Qualified FrameRelay Name

o Start Date/Time = depends on default Time Range and data available in database
e Hourof Day (HOD) = All

o Day of Week (DOW) = All

« Ranking Metric = Volume - Bytes (sum)

e Top N Option=Top 10

You can select multiple grouping attributes by using the '{F_hl (Add New Grouping) button. Use the
P (Remove Grouping) button to remove a grouping attribute.
Use Case

Use this report to spot objects at selected grouping level that saw significant growth from the
previous selected time period to the selected time period. Significant growth could point to a
developing problem you need to know about. You can change the ranking metric and you can
change how many elements are listed.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o To change the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Frame Relay Peak Period Report

The Frame Relay Peak Period Report ranks the utilization and performance of an interface during
the busiest time of the selected time range.

Using this report, you can:
o Identify the performance and utilization of the selected metrics during the peak period.

« lIdentify the interfaces that have the highest or lowest performances or utilization levels during
the peak period.

o Compare the performance for multiple interfaces during the peak period using this report.
Use Case

Use this report to:

o Identify a group of virtual circuits having a common network performance problem.

« lIdentify the virtual circuit that is suffering from a persistent performance problem.
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Frame Relay Peak Period Report Options

e Top / Bottom N
o Select Metric(s)2
e Grouping by Time Period3

This report tracks up to six metrics over the selected time period.

To add another metric, click Options and then click '{F_bl

To remove a metric that you have already added, click Options and then click X_

To select a range of value for the metric, click + , click 77, and type a range of metric value that the
report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
« Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five virtual circuits for the node 15.2.103.112 with the
average utilization between 10% and 90% type the following ranges:

e 0.10r 10% as Lowest Value
e 0.90r90% as the Highest Value

By default, the report groups data by Qualified FrameRelay Name. You can select multiple grouping

attributes by using the + (Add New Grouping) button. Use the s (Remove Grouping) button
to remove a grouping attribute.

Tip:
o Use this report to identify the period when the virtual circuit utilization was the highest.
o Check this report once a day to see which virtual circuit may need special attention.

o Check this report periodically throughout the day to see which virtual circuit is performing at the
extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the

selected component.
2Select the metric based on which you want to generate the report. The metric that you select is

used to rank the report data.
SEnables you to group the report data based on a specific time grain. Click Add New Grouping icon

to add a new group.
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To change the Report Options defaults, see Change Report Options in the Using Reports > Change
Default Settings section.

Frame Relay Threshold Sleeve Report

This report analyzes how close the metric performance value is to the threshold levels. In other
words, this report enables you to analyze when the metric will reach the threshold.

Using this report, you can:
o Forecast over-utilization or under-utilization of the selected Frame Relay virtual circuit.
o Detect if the metric performance is about to cross the high and low thresholds.

For example, if you generate the Threshold Sleeve Chart report for Availability (avg), the chart
displays the how close the average virtual circuit availability is to the high and low threshold.

o Save multiple Threshold Sleeve Reports for a specific metric for different time ranges, and
analyze the metric performance trend.

This report supports one metric.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

Frame Relay Top N Report

This report ranks network elements by the metric that you select. Use this report to spot the
element that performed at the extremes. You can use this report to analyze the historical data for
elements that are exhibiting unusual utilization levels.

Using this report you can:
o Detect the Frame Relay virtual circuits having a health or performance problem.

o Analyze the utilization of the NNMi managed Frame Relay virtual circuits based on a specific
time range.

o Detect the over-utilized and under-utilized Frame Relay virtual circuits in the network.

o Compare the performance of multiple Frame Relay virtual circuits for a single node or multiple
nodes using this report.

Example

One of the routers in your network are performing poorly. Using this report, you can group the Frame
Relay virtual circuit for the router reporting highest average error rate. The virtual circuit reporting
the highest average error rate is ranked first.

Interface Health Top N Reports Options

The Top N report displays the following options:
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e Top / Bottom N1

o Select Metric(s)z: The report ranks the selected virtual circuits based on the value of the first
metric listed in the Select Metric(s) field.

o Display Time Series Chart3
« Grouping By?#

This report tracks up to six metrics for each metric type over the selected time period.

To add another metric, click Options and then click '{F_bl

To remove a metric that you have already added, click Options and then click X.

To select a range of value for the metric, click '{EI click "I, and select a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five interfaces for the node 15.2.103.112 where the average
utilization between 10% and 90% type the following ranges:

¢ 0.10r10% as Lowest Value
e 0.90r90% as the Highest Value

By default, the report groups data by Qualified FrameRelay Name. You can select multiple grouping

attributes by using the E (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

The Time Series Chart report displays the selected metrics using two Y axis.

e TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

Tip :

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

23elect the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.

3elect Yes to view the detail chart with the table. Select No to hide the chart and display only the
table. The created Top N Report displays the graphical representation of the metric values for the
components over the selected time range.

4Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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o By default, Top N Report does not display the Time Series Chart. To view the chart with the
detail table,perform any of the following steps:
= Select Options > Display Time Series Chart > Confirm Selection.

= Click Show Chart link below the detail table.
o Check this report once a day to see which network interface may need special attention.

o Check this report periodically throughout the day to see which network interfaces are performing
at the extremes and may need special attention.

To change the Time Controls defaults, see Change Time Controls in the Using Reports > Change
Default Settings section.

To change the Topology Filters defaults, see Set Topology Filters in the Using Reports > Change
Default Settings section.

To change the Report Options defaults, see Change Report Options in the Using Reports > Change
Default Settings section.

Frame Relay Top N CSV Report

Top N report may have performance problem, as it retrieves huge amount of data from the NPS
database for the selected time range. To resolve this problem, NPS enables you to schedule the
following reports in CSV format:

« TopN CSV report’
 Top N Detail CSV report?
Frame Relay Top N Chart

Like the Top N report, this report also ranks the Frame Relay virtual circuits by the metric you
select.

Using this report, you can:

The Top N CSV report ranks selected topology element based on the utilization level of the
selected metric in the descending order.

2The Top N Detail CSV report lists the metric utilization for the selected topology element based on
the selected time grain.

This report displays the ranks the elements based on the total metric utilization for the selected time
range and breaks up the metric utilization value for each time grain. For example, you selected the
following options for the TOP N CSV report:

Time Range: Last 24 Hours. The default Display Grain for this time range is one hour.

Topology Element: FrameRelay Pvc Name

Metric: Volume —Bytes (sum) and CIR Utilization (avg)

The displayed report ranks the FrameRelay Pvc Names based on the metric Volume — Bytes
(sum). The FrameRelay Pvc Name with the highest volume of data passing through it receives the
highest rank. The Top N Detail CSV report then calculates and lists the volume of data passed
through this element every hour in last 24 hours.
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e Spot the virtual circuits that performed at the extremes.
« Analyze the historical data for virtual circuits that are exhibiting unusual utilization levels.
o Detect the virtual circuits having a health or performance problem.

o Analyze the utilization of the NNMi managed Frame Relay virtual circuits based on a specific
time range.

o Detect the over-utilized and under-utilized Frame Relay virtual circuits in the network.

o Detect the underlying reason of a persistent problem with a virtual circuit. You can compare the
performance for multiple virtual circuits using this report.

Frame Relay Top N Chart Options

The Top N Chart displays the following options:
e Top/ Bottom N

o Select Metric(s)2

¢ Grouping By3

This report tracks up to six metrics over the selected time period.

To add another metric, click Options and then click '{F_bl

To remove a metric that you have already added, click Options and then click X.

To select a range of value for the metric, click '{EI click "I, and select a range of metric value that
the report should consider.

While specifying the range for a percentage metric, make sure that the ranges are any of the
following formats:

o Decimal multiplier (for example, 1 to specify 100%, 0.5 to specify 50%, etc)
¢ Range with the % (Percentage) symbol (for example, 100%, 50%, etc)

For example if you want to see the top five Frame Relay virtual circuits for the node 15.2.103.112
with the average utilization between 10% and 90% type the following ranges:

e 0.10r 10% as Lowest Value

e 0.90r90% as the Highest Value

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

2Select the metric based on which you want to generate the report. The metric that you select is
used to rank the report data.

3Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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By default, the report groups data by Qualified FrameRelay Name. You can select multiple grouping

attributes by using the ﬁ (Add New Grouping) button. Use the P (Remove Grouping) button
to remove a grouping attribute.

The Top N Chart report displays the selected metrics using two Y axis.

e TheleftY axis (also known as the Y1 axis) displays the performance of the main metric based
on which you want to generate the report.

o Theright Y axis (also known as the Y2 axis) displays the performance of the metric that should
overlay the main (primary) metric.

Tip :
o Check this report once a day to see which interface may need special attention.

o Check this report periodically throughout the day to see which interfaces are performing at the
extremes and may need special attention.

o Tochange the Time Controls defaults, see Change Time Controls in the Using Reports >
Change Default Settings section.

o Tochange the Topology Filters defaults, see Set Topology Filters in the Using Reports >
Change Default Settings section.

o Tochange the Report Options defaults, see Change Report Options in the Using Reports >
Change Default Settings section.

iSPI for Performance Reportlets

In a large enterprise network the NNM iSP| Performance products1 may produce a large amount
of data and large cardinality. This means that these networks often have a very large amount of
unique IP addresses, source nodes and destination nodes, virtual circuits, interfaces, and
components each producing large amount of data. Generating reports using such large data volume
may be time consuming.

Reportlets enable you to generate quick impressions of the larger reports using the iSPI for
Performance Dashboards.

Viewing iSPI for Performance Reportlets
To display the reportlets:

1. Loginto Network Performance Server (NPS) Home Page.

2. Onthe left navigation panel, select Dashboard Reportlets.
3. Select an extension pack and then select a reportlet.

You can also create custom dashboards using the reportlets. See Creating Custom Dashboards
Using Bl Server Portal for information on the procedure to create the custom dashboards.

TNNM iSPI Performance for Metrics, NNM iSPI Performance for Quality Assurance, and NNM
iISPI Perforance for Traffic
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Calendar
Displays a comparative study of the selected Primary Metric! and Secondary Metric2
The default display grain is set to one hour. You cannot change the display grain of this reportlet.
Enables you to monitor the following:
o Daily CIR or EIR utilization for the selected Frame Relay virtual circuits
« Volume of data passed through the virtual circuit for past 24 hours
o Performance of the virtual circuit for past 24 hours
This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Gauge
Evaluates the metric for the selected point of time.
Select only the metrics that displays the percentage values.
Enables you to:
o Measure the daily performance of the selected metric.
o Detect any abnormal or unexpected performance level.
This reportlet supports one metric.
When the NPS database has no data, the needle icon on the gauge does not appear.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Heat Chart
Grades the performance of the selected metric for the selected time range.
The metric performance is aggregated based on an hourly display grain.
Enables you to:

« View how the performance of the selected Frame Relay virtual circuits get affected by a varying
metric.

o Compare the hourly performance of the selected metric.

o Detect the time range when the performance of the selected Frame Relay virtual circuits were
affected adversely because of the fluctuating metric value.

This reportlet supports one metric.

TEnables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

2Enables you to select the metric that would overlay the primary metric. The secondary metric that
you select is displayed on the right Y axis of the report.
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To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Metric Snapshot
Displays the metric performance for the selected time range.
Enables you to:

o Build a performance history for the selected metric and analyze how the metric performance
changes over time.

Such history may help you to decide the baseline value for the metric
o Compare the performance for multiple metrics over a specified time range.

Though you can generate snapshot report for a single metric, you can save the snapshot report
for various metrics and compare the performance of each metric over a time range.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Most Changed

Compares the metric performance between the following:

¢ Selected time range

o Period preceding the selected time range

Aggregates the metric utilization and ranks the performance in a descending order.
Enables you to:

o Measure the performance fluctuations for the Frame Relay virtual circuits.

o Detect the top N Frame Relay virtual circuits having a common performance or utilization
problem.

You can enhance the reportlet usability using the following features:
e Top/ Bottom N1

e Grouping By2

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Option in the Using Reports >
Change Default Settings section..

Multimetric Chart

Analyzes the performance trend for the selected metrics for the selected time range.

1Select a rank between top or bottom five, ten, 25, 50, 100, all descending, and all ascending for the
selected component.

2Organize the report data based on a specific parameter. Click Add New Grouping icon to add a
new group.
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Enables you to:
o Perform comparative analysis of the selected metrics for each display grain.
The default display grain is one hour.

« Analyze the reason for any ups and downs in the performance of the selected Frame Relay
virtual circuits.

o Detect any persistent problem in the performance of the Frame Relay virtual circuits.
This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Bar and Line Chart

Displays the trend of performance of the Frame Relay virtual circuits for past 24 hours using the
following values:

e Primary Metric! on the bar chart

o Secondary Metric2 on the line chart

Enables you to:

o Compare the performance trends of multiple metrics.

« Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Bar Chart
Compares the performance of two metrics for the selected time range.
Enables you to:
o Compare the performance trends of multiple metrics.

« Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Chart

Analyzes the utilization trend for the selected metrics for the selected time range.

TEnables you to select the main metric based on which you want to generate the report. The
primary metric that you select is displayed on the left Y axis of the report.

2Enables you to select the metric that would overlay the primary metric. The secondary metric that
you select is displayed on the right Y axis of the report.
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Enables you to:
o Perform comparative analysis of the selected metrics for each display grain.
The default display grain is one hour.

« Analyze the reason for any ups and downs in the performance of the selected Frame Relay
virtual circuits.

o Detect any persistent problem in the performance of the selected Frame Relay virtual circuits
This reportlet supports two metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Simple Table
Analyzes the utilization trend for the selected metrics for the selected time range.
The default display grain is one hour.
Enables you to:
¢ Analyze the hourly performance of the metrics.
o Detect any abnormal or unexpected performance for the selected Frame Relay virtual circuits.

« Analyze how the value of the secondary metric increases or decreases based on the increase or
decrease in the value of the primary metric.

This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Sparkline
Evaluates the trend of how the selected metric value has changed for the selected time range.
Enables you to:
o Analyze the variations in the performance for the selected metric.
o Decide whether the expected behavior for the selected metric should be reassessed.
This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Threshold Sleeve Chart
Analyzes how close the metric performance value is to the threshold levels.
Enables you to:
o Detect if the metric performance is about to cross the high and low thresholds.

For example, if you generate the Exception Sleeve Chart reportlet for CIR Utilization (avg), the
chart displays how many exceptions are raised on average CIR utilization in the past 24 hours,
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o Save multiple Sleeve Reports for a time range, and for analyze the trend of performance for the
metric.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Chart

Ranks the individual contribution of each metric for the performance for the selected Frame Relay
virtual circuits for the selected time range.

The performance of the interface is aggregated on hourly basis.
Enables you to:
e Spot the virtual circuits for which the performance metrics present extreme values.

¢ Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

o Group the report data based on a specific parameter. Click '{F_bl Add Group to add a subgroup.

This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Line Chart
Ranks the utilization trend for the selected metrics for the selected time range.
The performance of the virtual circuits is aggregated on hourly basis.
Enables you to:
o Spot the virtual circuits for which the performance metrics present extreme values.

o Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

o Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

o Group the report data based on a specific parameter. Click '{F_bl Add Group to add a subgroup.
This reportlet supports one metric.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Stacked Chart
Ranks the individual contribution of each virtual circuit based on the selected metrics.

The performance of each interface is aggregated for the default display grain of one hour.
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Enables you to:

Spot the virtual circuits for which the performance metrics present extreme values.

Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

Detect the network path having a common network performance problem.

This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Table

Ranks the interfaces based on the selected metric.

Enables you to:

Spot the virtual circuits for which the performance metrics present extreme values.

Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

Group the report data based on a specific parameter. Click '{F_hl Add Group to add a subgroup.

This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.

Top N Table With Bars

Ranks the Frame Relay virtual circuits based on the selected metric and displays a horizontal bar to
depict the aggregated metric value.

Enables you to:

Spot the virtual circuits for which the performance metrics present extreme values.

Investigate the aggregated data for the virtual circuits that are exhibiting unusual utilization
levels.

Select the metric based on which you want to generate the report. The metric that you select is
used to rank the virtual circuits.

Group the report data based on a specific parameter. Click '{F_bl Add Group to add a subgroup.

This reportlet supports up to six metrics.

To select a new metric for your reportlet, see Change Reportlet Options in the Using Reports >
Change Default Settings section.
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Path Health Overview

Path Health displays icons representing the nodes and interfaces in a path. A vertical chain of
nodes and interfaces represents the path from one managed element to another. Each step along
the path (node or interface) shows a series of small pie charts and trend lines depicting activity and
performance for that element over the previous six hours.

Path Health helps you analyze the following:
« Ratio of exceptions per metric over the last hour (one pie chart per metric)
o Metric values over the last six hours (one graph per metric)
Use them to view whether the values are:
o static
o rising steadily
o falling steadily
o fluctuating
1. From one of the NNMi inventory views, select two elements.
2. Select Action-->Path View from the NNMi console to view the Path View page.
Note: The only way to launch Path Health is from a Path View in NNMi.
2. From the Path View, select Actions-->Reporting - Path Health
The Path View page opens with the following segment menus:
o Source Node: The first element of the selected path
« Destination Node: The last element of the selected path
3. Select Actions-->Reporting - Path Health to create the Path Health report.

If the Path View is showing multiple paths between hops, NNMi will ask you to select a specific
path. To make the choice, click the appropriate connecting line within NNMi. The colors on the
screen will change when you make the selection. The Path Health option under Actions does not
function until your selections are complete.

Launch Path Health Reports for Nodes with Multiple paths

NNMi console may often present more than one path between your source and destination nodes.
When you request the Path Health report using the Actions > Reporting - Path Health menu, the
left-most icon on the path changes color if multiple paths exist between the source and destination
nodes. To launch a Path Health report, select a particular path by clicking every visible node on the
path, and then click Actions > Reporting - Path Health.

Features and Defaults

The Path Health report pulls data from the following extension packs:
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e Component Health
o Interface Health

From the Component Health collections, Path Health generates the following statistics for a node in
a path:

o CPU exceptions last hour/ CPU utilization last six hours
« Memory exceptions last hour/ Memory utilization last six hours
o Buffer exceptions last hour / Buffer utilization last six hours

From the Interface Health collections, Path Health generates the following statistics for an interface
in a path:

o Utilization exceptions last hour / Utilization over the last six hours

o Discard exceptions last hour / Number of discards per poll over the last six hours
o Error exceptions last hour/ Number of errors per poll last six hours

The Path Health report pulls data from two Tables:

o Component Health Live Table

¢ Interface Health Live Table

Use Case

Use Path Health to monitor the fault conditions that are showing up in a Path View. The
performance data in Path Health can help you determine what is causing the fault condition you are
seeing in the Path View.

If a node, orinterface, or component, in the Path Health report is showing exceptions, you can
easily find more information about those by clicking the links for node, interface, or component.

For example, if a node is showing CPU exceptions, you could open Report Menu, select a
appropriate report, and then drill down on the node until you identify the specific component that is
reporting problems.

Related Topics
Path Health Report

Path Health Report

Path Health displays icons representing the nodes and interfaces in a path. A vertical chain of
nodes and interfaces represents the path from one managed element to another. Each step along
the path (node or interface) shows a series of small pie charts and trend lines depicting activity and
performance for that element over the previous six hours.

Path Health helps you analyze the following:
« Ratio of exceptions per metric over the last hour (one pie chart per metric)
o Metric values over the last six hours (one graph per metric)

The selected Path View displays as shown below.
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The pie chart enables you to view the comparison between the number of polls which are below or
above the set threshold. The data shown in the pie chart represents the samples collected within
the last hour.

The line graphs track sampled data over the previous six hours.
Unknown Items

Unknown icons (icons associated with the ? icon) appear in the Path Health report for a device or
interface that is not being polled for the required data. The Path Health report presents Component
Health data for each node and Interface Health data for each interface. It is possible that a node can
support the Interface Health collections (MIB-I1), but not the Component Health collections. For this
reason, the report may display data regarding the inbound and outbound interfaces on a node but not
about the node itself.

Related Topics

Path Health Overview
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Glossary

E

extension pack

Extension packs provide rules and
definitions to generate reports from the
data gathered from different sources. The
default, ready-to-use extension pack
available with the NPS—the Self
Diagnostics extension pack—helps you
view reports indicating the health and
performance of different components and
processes of the NPS.
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