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Overview and Installation 

HP OpenView Reporter creates Web-based reports from data of targeted systems it 
discovers, because of OpenView agent software running on the systems. Agent software 
includes: 

●     HP OpenView Performance Agent on UNIX or Windows
(also known as MeasureWare Agent). 

●     HP OpenView Operations subagent (version 7 and later). 

NOTE: HP-UX and Solaris are the only platforms where Oracle is supported. Access is supported for 
upgrading customers only (from OVR3.0). Clean install do not support Access. Some features such as "Long 
host name" and "composite indexes" will not be supported in access as access do not support them 

When Reporter is first installed, it begins operation automatically, using pre-configured 
settings which come with the product. These initial settings are sufficient for Reporter to 
discover systems in the local domain, running OpenView agent software. Reporter can also 
discover systems in a configured OpenView Operations database. After installation, 
Reporter completes a number of steps as illustrated below. After Reporter has run through 
its discovery, it gathers data based on pre-defined and user-specified lists of metrics. It 
then uses this data to generate reports.

NOTE: In order to generate additional reports for other OpenView products, you must add the Reporter 
package for the OpenView product you are using. Please refer to the online Help "Working with Reports" 
topics for instructions.

What happens after installation?



As shown in the preceding illustration, following installation, Reporter begins a cycle of its 
actions immediately. This immediate start, which is different from the schedule that 
Reporter follows by default, occurs so that you can see reports right away without having to 
wait until the next day. After the above actions are completed, Reporter follows the default 
schedule, which begins at 12:30 AM every night unless you change those default settings. 
Reporter's default schedule is described in "How Reporter Works," Chapter 3 of the 
Reporter Concepts Guide.

IMPORTANT: Do not run multiple copies of Reporter with the same Reporter database as unexpected 
results occur when more than one copy of Reporter attempts to write data to the Reporter database.

The OpenView Performance Agent and OpenView Operations (OVO) are sold separately 
from Reporter. No changes are required to the OpenView Performance Agent in order to 
support Reporter. However, for OpenView Operations on HP-UX or SUN, see the 
appropriate sections in this document to configure a connection to the OVO database.*



In addition, to generate reports from other OpenView Reporter-enabled products, you must 
select the report package from Reporter's File>Configure Report Packages menu. 

NOTE: Reporter stores data in a default database (MSDE SP3a with Reporter A.03.6). If you want to use 
a different database, please see the configuration instructions pertaining to your database software.* 
(Installation and Special Configurations Guide).

*Due to Oracle requirements, Reporter does not support connections to more than one 
version of Oracle Server at a time. Please see the Oracle8 Online Generic Documentation 
or contact Oracle support for further details.

Reporter's Daily Routine

After you install Reporter and it goes through the discovery process, it starts collecting data 
based on the metric lists. Metric lists for OpenView Performance Agent and OpenView 
Operations Agent can be modified. Metric lists for service and event data gathered from 
OpenView Operations management server cannot. The default metric lists provided for the 
respective agents are grouped as follows: 

For OpenView Performance Agent systems:

●     Global 
●     Application 
●     Transaction 
●     Uptime 

For OpenView Operations systems:

●     ITO Messages 
●     ITO Operator 

The data collected by Reporter is stored in a database from which reports can be 
generated. Reporter also performs routine database maintenance and builds a web page 
that can display all reports generated by Reporter. This web page is viewable from your 
browser.

Reporter performs the following actions to discover new systems and to continue to track 
systems already in the database. 

●     Searches systems selected for inclusion in the Discovery Area (or initially, by default, systems in the 
local domain) and adds entries into the schedule to gather data when it finds new sources of data 
added. 

●     Gathers a default set of metric data based on the metrics available through OpenView Performance 



Agents and stores this data in the Reporter database. 
●     Updates the database with any new information. 
●     Creates a series of pre-defined reports based on the data available in the Reporter database. 
●     Creates a web page that links into all the HTML reports created by Reporter. 

From the data it collects, Reporter automatically generates a number of different reports, 
providing you with critical information about the systems in your computing environment.

After you have begun using Reporter, you will likely want to customize Reporter by 
organizing your systems into different system groups (see the Concepts Guide, Chapter 5). 
With these changes you can assign reports to these new system groups and generate sets 
of reports that are immediately organized in a way that is relevant to the way your 
organization functions. Lastly, you might also decide to create custom reports (see the 
Concepts Guide, Chapter 4), for which you can purchase Crystal Reports and define new 
reports with data that you select (by creating metric lists).

  

To install Reporter - New Installation: 

1.  At the Windows system, insert the CD in the CD-ROM drive.
2.  In the window that appears, please select, print, and review the two documents:

—read before installing
—release notes

3.  Select install reporter.
4.  Follow the instructions as they appear on screen.

 NOTE: More detailed instructions [covering upgrades and other situations] are available in the Release 
Notes.

To Upgrade Reporter

If you are upgrading Reporter and using Microsoft Access, see the Reporter Release 
Notes if you want to change your database type to the current default, which is MSDE SP3.

 NOTE: If you want to continue to use Access as your database, please do not uninstall the previous 
version of Reporter. This guide contains instructions for migrating from Access to SQL Server or Oracle. If 
you decide in the future to use MSDE, Microsoft provides tools (Access 2000, Upsizing Wizard in; SQL Client 
Tools, Import and Export Data Wizard) for migrating Access to MSDE.

1.  Create a backup copy of your Reporter database if you are updating over a previous version, in case 
you decide to roll back to a prior version.

2.  To save configuration data (this does NOT save the gathered data) from the database in a file, enter 
the following from a Command Prompt window: repload -save <filename>

3.  Complete the steps above for a new installation. Your existing database configuration is detected 



during installation and is left intact.

NOTE: To restore configuration data (if you removed the old database) in a new database, after you 
complete the installation, open a Command Prompt window and enter: repload -load <filename>

What happens during the upgrade: 

●     The Reporter binaries are overwritten.
●     New versions of the default report templates are added or updated over existing versions in 

<installation_directory>\data\reports. Your custom templates are not disturbed, providing you gave 
them different file names from the Reporter default templates.

●     Customizations that you made to report templates through the Reporter GUI will be preserved. 
Customizations made through Crystal Reports Professional will not.

●     Reporter Web pages are not disturbed (<installation_directory>\data\Webpages).
●     The Reporter database is updated by adding new columns or tables to the Reporter database; this 

change does not disturb your data.

To Uninstall Reporter: 

1.  From the Start menu select Settings>Control Panel.
2.  In the Control Panel Window double-click Add/Remove Programs.
3.  In The Add/Remove Programs window select HP OpenView Reporter and click the Remove button. 

❍     Two options Remove Standard and Remove Clean are available. Use the Remove Clean 
option to remove the data files and HTML reports that are created by the product. Remove 
Standard will not remove the data files and HTML reports that are created by the product. 

NOTE:Select the Remove Clean option only if no other OV products are installed on your 
system. 

What happens during the uninstallation: 

●     Reporter binaries and product files are removed.
●     The following Reporter directories remain intact:

<installation_directory> \data\datafiles\ (the Reporter database is not removed).
<installation_directory> \data\Webpages\ (Webpages are not removed).

●     For Reporter A.02, if you use SQL server or Oracle for the Reporter database, the database 
connection is lost, even though you do not lose the database or any data. Your report configurations 
and other data remain in the database.

 NOTE: for Reporter A.03 or later, the database connection is not removed during an 
uninstallation.

●     For Reporter A.02, if you re-install, you must re-configure the connection by opening the Reporter 
main window and selecting File>Configure>Databases). You can find instructions for re-
establishing the ODBC configuration for your database type in the appropriate section covering the 
database configuration in this guide.

 NOTE: for Reporter A.03 or later, no re-configuration is necessary when re-installing.
●     An uninstallation has no effect on the virtual directory settings in IIS. These settings remain available 

to other OpenView products, such as OV Internet Services. If you no longer have any OV products 
using IIS, you can manually remove any remaining "HPOV_" entries from the Web server.



UNIX Settings
This document shows settings (Part I) for the default installation, where you use the 
Reporter database, and settings for a custom database configuration (Part 2). The topics 
are as follows: 

●     Part 1: Setting Kernel Parameter Minimum Values 
●     Part 2: For Oracle Database Setup on UNIX / Setting UNIX Environment Variables 

Part 1: Setting Kernel Parameter Minimum Values

Kernel parameters setting for HP-UX and Solaris systems are outlined below.

HP-UX Systems

For your system to run more efficiently, modify (as necessary) the HP-UX kernel 
parameters to meet or exceed the minimum values listed below. To modify kernel values, 
run SAM and use the Kernel Parameters area to change the specific parameters within 
the Action menu.

maxdsiz 32 MB

maxfiles 120

maxssiz 2 MB

maxuprc 100

nfile 3000

nproc 700

semmni 20

semmns 128

shmmax 64 MB

shmmni 100

shmseg 12

IMPORTANT: To activate changes to settings, you must reboot your system. 

Solaris Systems

For your system to run more efficiently, modify (as necessary) the Solaris shared 
memory parameters to meet or exceed the minimum values listed below. To modify 



shared memory values, edit the /etc/system file and change the specific parameters as 
listed below:

set shmsys:shminfo_shmmax 67108864

set shmsys:shminfo_shmmin 1

set shmsys:shminfo_shmmni 100

set shmsys:shminfo_shmseg 40

set semsys:seminfo_semmns 200

set semsys:seminfo_semmni 100

set semsys:seminfo_semmsl 30

IMPORTANT: To activate changes to settings, you must reboot your system.

Part 2: For Oracle Database Setup on UNIX / Setting UNIX 
Environment Variables

New Oracle Installations

1.  You must be logged on as root or su. 
2.  Set UNIX environment variables as follows: 

ORACLE_BASE – set to admin pathname default (/opt/oracle)
ORACLE_SID - set to the database name you want to create (reporter)
ORACLE_HOME - set to full pathname of the Oracle system home directory
$ORACLE_TERM – set to the appropriate value (hpterm, etc…)
PATH - needs to include $ORACLE_HOME/bin
UMASK = 022

Existing Oracle Installations

Verify that the following HP-UX environment variables are set:

ORACLE_BASE – set to admin pathname default (/opt/oracle)
ORACLE_SID - set to the database name you want to create (reporter)
ORACLE_HOME - set to full pathname of the Oracle system home directory
ORACLE_TERM – set to the appropriate value (hpterm, etc…)
PATH - needs to include $ORACLE_HOME/bin



 



Set Up Microsoft SQL Server as the 
Reporter Database
Reporter now uses the MSDE SP3a (Microsoft Database Engine) as its database. The 
MSDE SP3a version that Reporter currently uses is a subset of SQL Server 2000, which 
means that that much of the SQL 2000 functionality is present in the MSDE database, 
even though no dialogs are available to assist in the configuration. MSDE has a 2GB size 
limit per database instance. Knowing this, you may at some point choose to migrate your 
data to SQL Server 2000 database. 

IMPORTANT: Do not run multiple copies of Reporter as unexpected results occur when more than one 
copy of Reporter attempts to write data to the configured Reporter database.

IMPORTANT: If HP OpenView Internet Services 4.5 or later and Reporter are installed on the same 
system, migration of your OVIS/Reporter data from your existing database to SQL Server is not 
supported.

IMPORTANT: To upgrade from a previous version of OVIS or Reporter, the minimum requirement for 
SQL Server 2000/MSDE is currently Service Pack 3a. This Service Pack is essential to guard against the 
vulnerability in SQL Server 2000 towards destructive computer viruses (such as the SLAMMER worm 
virus). Refer to the OVIS release notes for detailed instructions to upgrade to this Service Pack.

Configure Microsoft SQL Server 2000 as the Reporter database explains the 
configuration of supported versions of SQL Server. 



Set Up Microsoft SQL Server as the Reporter 
Database 

Part A: Configure SQL Server 2000 

Set Up SQL Server 2000 as the Reporter Database

To use Microsoft SQL Server as the Reporter database requires both server and client software. The 
first section of this procedure covers the SQL Server server installation and configuration. The second 
section covers the SQL Server client installation as well as Reporter configuration as a SQL Server 
account.

Reporter 3.6 uses the MSDE SP3a (Microsoft Database Engine) as its database. The MSDE SP3a 
version that Reporter currently uses is a subset of MS SQL Server 2000, which means that that much 
of the MS SQL 2000 functionality is present in the MSDE database, even though no dialogs are 
available to assist in the configuration. MSDE has a 2GB size limit per database instance. Knowing 
this, you may at some point choose to migrate your data to an MS SQL Server 2000 database. When 
upgrading from MSDE to SQL Server 2000, follow the instructions provided by Microsoft and choose 
OVOPS instance to upgrade.

IMPORTANT: To upgrade from a previous version of OVIS or Reporter, the minimum requirement for SQL Server 
2000/MSDE is currently Service Pack 3a. This Service Pack is essential to guard against the vulnerability in SQL Server 
2000 towards destructive computer viruses (such as the SLAMMER worm virus). Refer to the OVIS release notes for 
detailed instructions to upgrade to this Service Pack.

IMPORTANT: If HP OpenView Internet Services 4.0 and Reporter are installed on the same system, migration of your 
OVIS/Reporter data from your existing database to SQL Server 2000 is not supported.

Because Reporter uses an MSDE SP3a instance, you see the instance name when using MS SQL 
Server 2000 Enterprise Manager to look at the MSDE Reporter database. The corresponding MS SQL 
Server 2000 examples do not use the instance name. You are not required to use an instance name 
when using MS SQL Server 2000. 

 NOTE: To migrate data from Access or MSDE database to MS SQL Server, skip Task 5 and go directly to Task 6 or 6a. 
Task 6 covers migration from Access (Reporter 2.0 default database) to MS SQL Server (allow approximately 1.5 times the 
space used in Access). Task 6a migration from MSDE (Reporter 3.5 default database) to SQL Server 2000. (no change in 
space requirements).



 

Install and Configure MS SQL Server Software

If you have already installed MS SQL Server, you can skip Task #1. If your Reporter and the MS SQL 
Server system are in the same domain, you can skip task Task #2 and go directly to Task #3.

Prerequisites include: (1)Windows 2000 Server and (2) Internet Explorer 5.01, Service Pack 2 or 
higher.

 IMPORTANT: Service Pack 3a is mandatory for SQL Server 2000. 

Task 1  Install MS SQL 2000 Server Software 

1.  Insert the MS SQL Server 2000 CD into the CD-ROM drive. 
2.  Select Install MS SQL 2000 Components. 
3.  Select Database Server – Standard Edition. 
4.  Select Local Computer and respond to prompts as they appear.
5.  Be sure to use Mixed Mode for authentication. 
6.  Restart the system. 
7.  Upgrade to SQL Server 2000 Service Pack 3. 
8.  Restart the system. 

Task 2  Verify Trust Relationship Between Client and Server
NOTE: A trust relationship should be set up if the Reporter client and SQL Server are in separate domains in NT4 or if 

the client and server run on mixed systems (Windows NT4 or Windows NT4 and Windows 2000). If the Reporter client and 
SQL Server are running on Windows 2000, skip this task. 

1.  Log on to the MS SQL Server-installed system with Administrator privileges. 
2.  From the Start menu select Programs > Administrative Tools > User Manager for Domains. 
3.  From the Policies menu select Trust Relationships. 



 

4.  In the Trusting Domains dialog box, look for the Domain where Reporter is located. If the appropriate domain is 
displayed, continue to the next task. If not, add the trusting domains as needed. If you have questions about 
trusting domains, click the Help button (if Reporter and SQL Server systems are in separate domains, you must 
configure a trust relationship between the systems). 

Task 3  Configure the Reporter Database on SQL Server  2000

1.  From the Start menu select Programs > Microsoft SQL  2000 >Enterprise Manager.
2.  In the Microsoft Console Root window, select your SQL Server Group.
3.  If your SQL Server system is not listed under the SQL Server Group, right-click SQL Server Group, select New SQL 

Server Registration from the drop-down menu and follow the wizard online steps to register. 
4.  Right-click Databases – New Database 
5.  In the General tab for the Name box, enter a name for the database (example uses Reporter as the name).



NOTE: The SQL Server database no longer needs to be named Reporter. 

6.  Select the Data Files tab and in the Database files segment, in the Initial size (MB) column, enter 100.
7.  Click OK to close the window.



8.  After the database is created, expand Security.
9.  Right-click Logins – new login.

10.  Click the General tab and in the Name box, enter the user name as openview.



11.  Under Authentication select the SQL Server authentication radio button and enter your password.
12.  Under the Defaults, select Reporter from the Database list box.
13.  Select the Database Access tab and under Database access check the Permit box that corresponds to Reporter.
14.  Under Database roles for Reporter, check public and db_owner and select OK to exit. 



15.  Confirm the new password from Step 11.

16.  To verify User has Database Access, in the left pane expand the security folder, or click the plus sign next to each 
item: Security>Logins and you should see openview in the right pane.



17.  Exit Enterprise Manager and go to the client system (where Reporter is installed).

  

Install and Configure SQL Client Software

Installing SQL 2000 Client includes three general areas: 

■     Upgrade newer versions of Reporter or the SQL database, or install Reporter
■     Configure Reporter ODBC connection
■     Install SQL 2000 software

SQL 2000 Client Installation Prerequisites 

■     Internet Explorer 5.01 SP 2
■     500 MB Free Disk Space
■     SQL Server 2000 CD
■     Product License – 10 digit code

Task 1  Upgrade or Install Reporter           

(If migrating current data from the default database to SQL Server, skip this task.) 

1.  Install Reporter.
2.  During the installation, select No in response to choosing Automatic Service startup.



Task 2  Install SQL Client Software

IMPORTANT: This task is unnecessary if Reporter and SQL Server are installed on the same system. 

1.  Insert the SQL Server  2000 CD to install the SQL Client 2000 software.
2.  Click autorun.exe.
3.  Click SQL Server 2000 Components. 

 

4.  Select Install Database Server 



 

5.  Choose Next for Select Install Method screen and click OK in response to the following message. 

 

6.  Follow the instructions as they appear.
7.  Select Management Tools and Client Connectivity as the components to install; you can choose whether or not to 

install documentation. 



  

8.  Reboot the system after installation is complete

Task 3  Establish the ODBC Connection

 IMPORTANT: Before continuing, if you are migrating data from the default database to SQL Server, stop the Reporter 
Service using the Reporter toolbar button; then close the Reporter main window.

 

Windows 2003 Enterprise / Windows 2000 / Server / Professional / Windows XP

1.  From the Start menu, select Settings>Control Panel.
2.  Double-click Administrative Tools.
3.  Double-click Data Sources (ODBC).
4.  Highlight Reporter and select the Remove button.



5.  Select the Add... button to create a new Reporter data source.
6.  In the Create New Data Source dialog box select the SQL Server driver and the Finish button.

6.  In the Create a New Data Source to SQL Server dialog, make sure that the server name appears in the Server: text 
box. Then select Next.



7.  Select - With SQL Server authentication using a login ID and password entered by user.
Also check the box for Connect to SQL Server to obtain default settings. 
Enter the login ID and password that you used in the first section Install and Configure SQL Server 2000: Task 3  - 
Configure the Database on SQL Server  2000.  Then select Next. 

8.  Check Change the default database to, select Reporter, and click Next.



9.  Check Perform translation for character data and select Finish.

10.  In the ODBC Microsoft SQL Server Setup dialog select the Test Data Source... button.



11.  Exit the SQL Server ODBC Data Source Test by clicking OK.



Task 4  Configure SQL as the Reporter Database

1.  From the Start menu select Programs > HP OpenView > Reporter>Reporter.
2.  An error message is expected; click Yes to proceed.
3.  In the Reporter main window select File > Configure > Databases.

(Another error message is expected; click Yes to proceed.)
4.  In the Configure Databases in the uppermost section (Reporter Database), enter the login ID and password that 

you used in the first section Install & Configure SQL Server 2000: Task 3  - Configure the Database on SQL Server  
2000, and click OK.
(No entries required for remaining text boxes.)

5.  Verify that Reporter Service and Reporter UI are stopped

Task 5  Upgrade Reporter SQL Sever Database Tables

To migrate data from an Access database to SQL Server, skip this section and see Task 6.

1.  Run <install_directory>\bin\NewDB.exe
2.  Start Reporter by double-clicking <install_directory>\bin\Reporter.exe, and in the Status Pane, look for the 

message: Completed creation/modification of required Reporter database tables.

Task 6  Migrate Data from an Access database to SQL Server (optional, use as 
appropriate)

1.  Run <installation_directory>\bin\NewDB.exe -empty
2.  Open the Reporter main window and stop all services (accessing the source database) by clicking the Stop/Start 

Reporter Service toolbar button (or by selection Action>Stop Reporter Service).

3.  In the SQL Server Enterprise Manager console start the DTS Import Wizard by right-clicking  the newly created 
Reporter database.

4.  Select All Task -> Import Data…, and click Next.
5.  From the Source drop down list choose Microsoft Access .



6.  Enter the location to the Reporter.mdb file in the Filename text box, click Next (An Access login and password is 
not required)

7.  In the Server: box click the down-arrow and select the SQL Server system that has the newly created Reporter 
database.

8.  Select the Use SQL Server authentication radio button.
9.  Enter the login ID and password that you used in the first section Install and Configure SQL Server 2000: Task 3  - 

Configure the Database on SQL Server 2000.



10.  Select reporter from the Database Name drop-down list and click Next.
11.  Select the radio button next to Copy table(s) from the source database and click Next.

12.  Press the Select All button under the source tables and click Next.



13.  Select the Run immediately check box and click Next.
14.  View the Summary information box to ensure the source and destination information is correct, and select Finish.

(The status pane should appear with the progress of the import, finally a message should appear with the number 
of successful tables imported from the default database to Microsoft SQL Server. All tables should have transferred 
without errors.)

15.  Open the Reporter main window and select the Start/Stop Reporter Service toolbar button to restart the Reporter 
service.

Task 6A  Migrate Data from a default MSDE database to SQL Server (optional, use as 
appropriate)

1.  Open the Reporter main window and stop all services (accessing the source database) by clicking the Stop/Start 
Reporter Service toolbar button (or by selection Action>Stop Reporter Service).

2.  In the SQL Server Enterprise Manager console start the DTS Import Wizard by right-clicking  the newly created 
Reporter database.

3.  Select All Tasks>Import Data…, and click Next.



4.  From the Data Source drop down list choose SQL Server.

5.  In the Server: box click the down-arrow and select the SQL Server system that has the newly created Reporter 
database.



6.  Select the Use SQL Server Authentication radio button.
7.  Enter the login ID (username) and password that you used in the first section Install and Configure SQL Server  

2000: Task 3  - Configure the Database on SQL Server  2000.
8.  Enter the login ID and password that you used in the first section Install and Configure SQL Server  2000: Task 3  - 

Configure the Database on SQL Server 2000.

9.  Select reporter from the Database Name drop-down list and click Next.
10.  Select the radio button next to Copy objects and data between SQL Server databases and click Next.



11.  Select Include extended properties and click Next. 



12.  Select the Run immediately check box and click Next.

13.  View the Summary information box to ensure the source and destination information is correct, and select Finish.
(The status pane updates you on the progress of the import, finally stating the number of successfully imported 
tables now in Microsoft SQL Server. All tables should have transferred without error.)

14.  Open the Reporter main window and select the Start/Stop Reporter Service toolbar button to restart the Reporter 
service.

Task 7  Confirm that the Database is Set Up

1.  From the Start menu, select Programs > Microsoft SQL  2000 > Query Analyzer.
2.  Connect to your SQL Server using SQL Server authentication using the user name and password you created.
3.  In the SQL Server Query Analyzer dialog, select DB: reporter.
4.  Enter a query to verify the database connection.

  



Oracle Setup/Connections 

(Covers connecting to the OpenView Operations Oracle database)

Reporter can be configured to work with Oracle as its database. The topics below cover 
many versions of Oracle and also offer information on configuring the connection to the 
Oracle listener. 

 IMPORTANT: Note that screen examples and steps may be different than documented in the following 
sections if your operating system or version is different than the one used in the example. 

 IMPORTANT: An Oracle DBA should be involved in creating the database, particularly for configuration 
issues like database sizing and AUTOEXTEND of data files. 

 IMPORTANT: Do not run multiple copies of Reporter as unexpected results occur when more than one 
copy of Reporter attempts to write data to the configured Reporter database.

 IMPORTANT: If HP OpenView Internet Services 4.5 or later and Reporter are installed on the same 
system, migration of your OVIS/Reporter data from your existing database to Oracle  is not supported. 

■     Part A: Configure/edit the Oracle listener and tsnnames files
■     Part B: Transfer data to Oracle
■     Part C: Connect the Oracle 8.1.7 OpenView Operations database to Reporter (to generate reports 

on OVO-managed systems)
■     Part D: Configure Oracle 8.1.7 (HP-UX or Solaris) as the Reporter database



Oracle Setup/Connections 
Part A: Edit templates to configure Oracle listener.ora and 
tnsnames files

  

Template 1 (listener.001) is for situations where no listener has been configured for 
Oracle. This template allows you to insert text pertaining to the host system and directory 
where Oracle resides and use the file to replace the existing listener file. 

Template 1/A (tnsnames.001) is for configuring one Oracle database instance (for 
Reporter data). You can use this template to insert text pertaining to the database 
instance you will use for the Reporter database.

Template 2   (listener.002) is for situations where a listener is already configured. This 
template allows you to copy and paste settings relating to Reporter into your existing 
template.

Template 2/A (tnsnames.002) is for adding the configuration of an Oracle database 
instance for Reporter data to the existing tnsnames.ora file that already is configured to 
recognize other Oracle database instances.

 

Template 1: Configuring the listener.ora file

The sample file below helps you edit the template included with Reporter (listener.001) 
for setting up a listener for the Oracle database instance connection to Reporter. Before 
using the template:

1.  Replace the host name in two places 
2.  If necessary, change the ORACLE_HOME path (where Oracle resides).
3.  Rename the template to listener.ora. and copy it to the /etc directory for HP-UX or the 

$ORACLE_HOME/network/admin directory for Solaris.

######################################################
# FILENAME: listener.ora



# DATE....: Jun 16 1999
# NETWORK.: openview
# NODE....: Server
# SERVICE.: LISTENER
# COMMENT.: For use with HP OpenView Reporter
######################################################

LISTENER =
   (ADDRESS_LIST =
      (ADDRESS=
      (PROTOCOL=IPC)
      (KEY= REPORTER)

      )

      (ADDRESS =
        (PROTOCOL = TCP)
        (HOST = host_name) #### Insert your host name for <host_name>
        (PORT = 1521)
        (QUEUESIZE = 50) ##### Increased queue size for REPORTER
      )

      (ADDRESS =
         (PROTOCOL = TCP)
         (HOST = host_name) #### Insert your host name for <host_name>
         (PORT = 1526)
         (QUEUESIZE = 50) ##### Increased queue size for REPORTER
      )
   )

SID_LIST_LISTENER =
  (SID_LIST =
     (SID_DESC =
        (SID_NAME = REPORTER)
        (ORACLE_HOME= /opt/oracle/product/7.3.4)
        (ENVS='EPC_DISABLED=TRUE')
     )
  )

STARTUP_WAIT_TIME_LISTENER = 0
CONNECT_TIMEOUT_LISTENER = 30 ##### Increased timeout for REPORTER
LOG_DIRECTORY_LISTENER = /opt/oracle/product/7.3.4/network/log
LOG_FILE_LISTENER = listener
TRACE_LEVEL_LISTENER = OFF

Template 1A: Configuring the tnsnames.ora file, using the 
template

The sample file below helps you edit the template included as tnsnames.001 for 



configuring one Oracle database instance connection to Reporter. Before you can use 
the file:

1.  Replace the host name. 
2.  Rename the file to tnsnames.ora and copy into the /etc directory for HP-UX or the 

$ORACLE_HOME/network/admin directory for Solaris.

####################
# FILENAME: tnsnames.ora
# DATE....: Jun 16 1999
# NETWORK.: openview
# NODE....: Server
# SERVICE.: LISTENER
# COMMENT.: For use with HP OpenView Reporter.
####################

RPT.world =
   (DESCRIPTION =
     (ADDRESS = (PROTOCOL= TCP)(Host= <host_name>)(Port= 1521))
     (CONNECT_DATA = (SID = REPORTER))
   )

  

Template 2: Editing the Existing listener.ora file, copying 
from the template 

The sample file below helps you edit the template included with Reporter (listener.002) to 
set up a listener for the database instance connection to Reporter. Before using the 
template: 

1.  Replace the host name in two places. 
2.  If necessary, modify the path where Oracle is located in two places.
3.  Paste the REPORTER blocks and the "Increased queue size" line into the appropriate places in your 

existing listener.ora file.  
4.  Paste in or change the CONNECT_TIMEOUT_LISTENER line so that the timeout value is at least 30.

#########################
# FILENAME: listener.ora
# DATE....: Jun 16 1999
# NETWORK.: openview
# NODE....: Server
# SERVICE.: LISTENER
# COMMMENT: For use with HP OpenView Reporter
#########################



LISTENER =

  (ADDRESS_LIST =
    (ADDRESS=
           (PROTOCOL=IPC)
           (KEY= openview)
    )

##### Begin REPORTER block number 1 #######
    (ADDRESS=                             #
           (PROTOCOL=IPC)                 #
           (KEY= REPORTER)                #
    )                                     #
##### End REPORTER block number 1 #########

    (ADDRESS =
            (PROTOCOL = TCP)
            (HOST = <host_name>)
            (PORT = 1521)
            (QUEUESIZE = 50) #### Increased queue size for REPORTER
    )

##### Begin REPORTER block number 2 ########
    (ADDRESS =                             #

            (PROTOCOL = TCP)                    #
            (HOST = <host_name>)           #
            (PORT = 1526)                  #
            (QUEUESIZE = 50)               #
    )                                      #
##### End REPORTER block number 2  #########

  )

SID_LIST_LISTENER =
  (SID_LIST =
      (SID_DESC =
         (SID_NAME = openview)
         (ORACLE_HOME= /opt/oracle/product/7.3.4)
      )
  )
##### Begin REPORTER block number 3 ##################
      (SID_DESC =                                    #
         (SID_NAME = REPORTER)                       #
         (ORACLE_HOME= /opt/oracle/product/7.3.4)    #
         (ENVS='EPC_DISABLED=TRUE')                  #
       )                                             #
  )                                                  #
##### End REPORTER block number 3 ####################

)



STARTUP_WAIT_TIME_LISTENER = 0
CONNECT_TIMEOUT_LISTENER = 30 #### Increased timout for REPORTER
LOG_DIRECTORY_LISTENER = /opt/oracle/product/7.3.4/network/log
LOG_FILE_LISTENER = listener
TRACE_LEVEL_LISTENER = OFF

Template 2A: Editing the existing tnsnames.ora file, copying 
from the template

The sample file below helps you edit the template included as tnsnames.002 for use in 
changing your existing tnsnames.ora file to recognize an Oracle database instance 
connection to Reporter. To use the template:

1.  Replace the host name in two places. 
2.  Paste the REPORTER blocks into the appropriate places in your existing tnsnames.ora file. 

########################
# FILENAME: tnsnames.ora
# DATE....: Jun 16 1999
# NETWORK.: openview
# NODE....: Server
# SERVICE.: LISTENER
# COMMENT.: For use with HP OpenView Reporter. 
#########################

ov_net =
(DESCRIPTION =
(ADDRESS = (PROTOCOL= TCP)(Host= <host_name>)(Port= 1521))
(CONNECT_DATA = (SID = openview))
)

##### Begin REPORTER block##################################
RPT.world =                                                #
(DESCRIPTION =                                             #
(ADDRESS = (PROTOCOL= TCP)(Host= <host_name>)(Port= 1521)) #
(CONNECT_DATA = (SID = REPORTER))                          #
)                                                          #
##### End REPORTER block ###################################



Oracle Setup/Connections 
Part B: Transfer Data from Access to Oracle

  

Transferring data from a Reporter Access database to Oracle can be done using an 
Oracle utility. Even though the Oracle utility should maintain the data in its original form, 
you should still back up your Reporter database before you start. 

Prerequisites: To migrate data from the Reporter database, you must have  installed 
Reporter 2.0 or higher. Reporter 3.6 initially supports Oracle versions 8.1.7 , Oracle 9.2.0 
and Oracle 9.2.1. Follow the instructions in the Installation and Special Configurations 
Guide for installing an Oracle database for Reporter, including database objects, 
tablespaces, data files, users and privileges. Also perform all needed installations and 
configurations for the Oracle client on Windows except do not run the 
“\HPOpenView\bin\Newdb.exe” executable against the database.

 NOTE: The current Oracle Migration Workbench (version 2.0.2.0.0) is an Oracle 9i product. This 
product must be installed in an Oracle Home (directory structure) different from the Oracle 8i client. Use 
of the Oracle “Home Selector” utility is required to switch between the OMWB home (Oracle 9i) and the 
client home (Oracle 8i). The migration workbench may install a new Oracle Universal Installer version and 
new ODBC drivers. The OMWB requires an ODBC connection (using the new 9.x driver) to the target 
Reporter database.

The OMWB product is an evolving product and is updated frequently by Oracle 
Corporation. The intent of these instructions is to provide general guidelines for using the 
OMWB. Please refer to Oracle documentation for specific information about installation 
and use of the OMWB.

Task 1  Download the Oracle Migration Workbench

At the Oracle Technology Network web site (  http://otn.oracle.com   ) select software 
downloads
(  http://otn.oracle.com/software/content.html   ) and select the Oracle Migration 
Workbench
( http://otn.oracle.com/software/tech/migration/workbench/content.html )

Download the Oracle Migration Workbench (current version 2.0.2.0.0 ) for Windows. A 

http://otn.oracle.com/
http://otn.oracle.com/software/content.html
http://otn.oracle.com/software/tech/migration/workbench/content.html


core component should be downloaded first, followed by a plug-in for the specific 
database from which data is migrated (i.e. MS Access, or SQL server).

Migration Workbench documentation is available at 
http://otn.oracle.com/docs/tech/migration/workbench/content.html

Task 2  Stop Reporter services

1.  Stop all Reporter services that are using the Access database.
2.  Stop the services of any other OpenView products that use the Reporter database, such as 

OpenView Internet Services or Web Transaction Observer.

Task 3  Install the Oracle Migration Workbench Core Component

1.  Begin installation by executing the OMWB program (omwb_20200.exe)
2.  Unzip to the default location and when the Oracle Universal Installer appears, click Next.
3.  Change the following:

Destination Name: OraHome9
Destination Path: \oracle\ora9 (or your preferred location).
(Installation requires that the OMWB must be installed in a directory different from the existing 
client software.)

4.  Click Next to continue.
5.  Select Typical installation type, and click Next.
6.  Review the Summary, and click Install (Requires approx.174 MB)
7.  When the Net8 Configuration Assistant dialog appears, to the prompt to use a directory service, 

select No.
8.  Click Next.
9.  Select the Oracle database version that you are using and click Next.

10.  Type in the Service Name: REPORTER; then click Next.
11.  Select the TCP protocol and click Next.
12.  Type in the Host Name where the Oracle database will reside and click Next.
13.  Select Yes to perform a connection test.

(You may have to change the default login username and password.)
14.  Click Next.
15.  Enter a Net Service Name: rpt_migrate, (this is an arbitrary name for destination database which 

uses the 9.x ODBC driver, different than the 8i client driver) click Next.
16.  When prompted to configure another service, select No and click Next.
17.  Click Next to the completion message that appears and exit.

Task 4  Install the OMWB Database-specific Plug-in

1.  Begin installation by executing the OMWB plug-in program (msaccess_20200.exe)
2.  Unzip to the default location and when the Oracle Universal Installer appears, click Next.
3.  Install into the destination as specified in Task 3, click Next.
4.  Review the Summary, click Install (Requires approx.3 MB)
5.  Exit the Universal Installer at the End of Installation.

http://otn.oracle.com/docs/tech/migration/workbench/content.html


Task 5  Start the OMWB and create data repository

1.  Upon starting the OMWB, select the Default Repository (this creates a local storage structure for 
holding models of the Access and Oracle databases).

2.  Select the appropriate Migration Source (Microsoft Access).
3.  The source database “Capture Wizard” starts; click Next.
4.  Follow the instructions for creating a Microsoft Access XML data file. Select the XML file, click 

Next.
5.  Review the data type mappings. No changes are recommended. Click Next.
6.  Select Yes for creation of the Oracle Model. Click Next.
7.  Review the Capture Details. Click Finish.
8.  A log is displayed during creation of the Oracle Model. A dialog should indicate any errors or 

warnings. Correct any condition that causes errors. Click OK.
9.  Select No if prompted to run the Migration Wizard to create schemas in the Oracle database. (The 

oracle model needs to be adjusted prior to migration).

Task 6  Make adjustments to the Oracle Model

1.  Select the Oracle Model tab in the OMWB dialog.
2.  Use the Tablespace Discoverer tool to fully populate the tablespaces element of the Oracle Model. 

You need to access the Oracle database with DBA privileges to obtain the tablespace names. Select 
Reporter as the default tablespace.
After using the tool, several tablespaces should be present including REPORTER and 
RPT_INDEXES.

3.  Change the name and password of the “REPORTER” user to match the name and password of the 
user created when the Oracle Reporter database was created.

4.  For each index under the user you modified in step 3, select the Override Default Storage 
Options tab and as the Tablespace select RPT_INDEXES.

5.  Click Apply each time to set the change for each index.

Task 7  Migrate to Oracle

1.  After the Migration Wizard begins, select the Migrate to Oracle Action in the OMWB dialog.
2.  Supply a username and password with DBA privileges for the Destination Service: RPT_MIGRATE, 

click Next.
3.  To migrating table data to Oracle prompt, select Yes and click Next.
4.  Select all schema objects for migration, click Next.
5.  Review the summary, click Next.
6.  A logging dialog appears for the migration process.
7.  Because the REPORTER tablespace already exists in the destination database, select Ignore Error 

if this error is reported.
8.  Since the OPENVIEW (or the username established with the initial creation of the REPORTER Oracle 

Database) user already exists in the destination database, select Ignore Error if this error is 
reported.

9.  If prompted to modify the MS Access database, select Cancel.
10.  Attempt to resolve any error conditions.
11.  Ignore warnings about milliseconds not being migrated in date columns.
12.  Exit the migration workbench.

The data should be successfully migrated.



Task 8  Set Oracle Home, Start Reporter

1.  Use the Oracle Home Selector utility to change back to the Oracle client home
(Oracle 8i).

2.  In the Control Panel>Administrative Tools>Data Sources>System DSN tab, ensure that the the 
REPORTER ODBC points to the new Oracle database.

3.  Run \Program Files>HP OpenView\bin\Newdb.exe against the Oracle database which will perform 
any needed schema updates for Reporter 3.5.

4.  Start the Reporter main window, where you can start the Reporter service (from the toolbar).

Now Reporter is ready for operation with the migrated data. 



Oracle Setup/Connections 
Part C: Connect the OVO 7 (Oracle 8.1.7), or 8 Database to Reporter

Set Up Oracle 8.1.7 on HP-UX System and on the Windows System 

Prerequisites: Check your settings as compared with those in HP-UX system kernel parameters. If you need to modify them, 
you must reboot your system. In addition, please do not attempt to run multiple copies of Reporter as unexpected results 
occur.

For other system, memory and disk requirements, pleas check the “System Requirements” section of the Oracle8i Installation 
Guide Release 2 (8.1.7) for HP 9000 Server and Workstations that is published by Oracle and included with the software 
distribution. 

Oracle has specific recommendations regarding optimal database installation and architecture.This document does not 
discuss all aspects of database installation and administration. We suggest that you consult Oracle technical literature and 
qualified Oracle professionals to achieve optimum database performance in your particular environment.

Before Reporter can create reports containing OpenView Operations (OVO), formerly known as ITO, data, you must configure 
the connection between the OVO database (Oracle on the UNIX system) and Reporter (on the Windows system). The 
following illustration gives you an overview of the steps you complete on the two systems. 

 

Prerequisites and Preparations

■     Software on the OVO management server: OVO 6, 7, or 8 using Oracle 8.1.7 must be installed and running. 
■     Software on the Reporter system: Oracle Client Software, version 8.1.7 a software package from Oracle.  
■     Information: Know the fully qualified OVO Oracle database server name, the ORACLE_HOME directory, and the user name and password for 

logging into the OVO database. 
■     Case Sensitivity: Some required entries in Windows are case-sensitive; so we recommend you match instruction text exactly. 
■     UNIX Shells: Since HP-UX users typically use the Korn shell and Solaris users typically use the Bourne shell, the syntax for exporting 

variables differs. 
For the Korn shell, the format is:
   export VARIABLE_NAME=<value>
For the Bourne shell, the format is:



   VARIABLE_NAME=<value>
   export VARIABLE_NAME
In the discussion below the Korn shell format is used; if you are running a Bourne shell, substitute the correct format. 

 

Configure the UNIX Server System

This section covers checking for installation of the Net8 listener on the UNIX system which is the Oracle database server for 
OVO, and if necessary, installing it. 

Task 1  Check for Net8 listener installation

On the Oracle database server for systems running OVO 6, 7, or 8, the Net8 listener should already be installed and running. 
Check to see if the Net8 listener is already installed and running as follows. It is assumed you are logged on to the Oracle 
database server system for OVO as root. 

■     To see if the listener is configured, enter the command:
grep listener /etc/services 

■     If the output includes a line beginning with "listener," such as
listener      1521/tcp #Oracle listener 
the listener is already configured and you can proceed to Task 3. 

If the port number in the output is different from 1521/tcp, consult with your Oracle database or OVO administrator to see if the port 
number can be changed to 1521 and the listener restarted. If not, you can change the port number on the client side in two ways (whichever 
you prefer) as follows:

■     Select a different port in the Windows configuration in Task 2, step #7 to match the port specified on the UNIX Oracle server.
OR

■     Modify the \Oracle\Ora81\network\admin\tnsnames.ora file to enter the port number you specified in Task 2, step #7 (below) on 
system. 

If no output appears, the listener is not configured, and you must proceed to the next task.

Task 2  If necessary, configure the Net8 listener

To configure the Net8 listener on the HP-UX Oracle database server system, run the opcsqlnetconf script. For OVO 6 
installations, this script is located on the OVO server system in directory /opt/OV/bin/OpC. 

 NOTE: If you run the the script and receive the WARNING: "Above Net8 files already exist. Do you want to replace them?," respond "No" to end 
the script execution. Call your OVO or database administrator for assistance.

The script assumes the OVO Oracle database instance "openview" is on the same system where OVO is installed, and 
prompts you with the system name where the script is running as the default "listener" system. The script must be run on the 
system where the OVO Oracle database instance "openview" resides. 

To configure the OVO 6 UNIX server, follow these steps:

1.  At the UNIX server on which OVO is installed, log on as root
2.  Run the /opt/OV/bin/OpC/opcsqlnetconf script. 

(Most responses require only that you press Enter.) 

The script prompts and output are as follows:

OVO Net8 configuration script opcsqlnetconf.
Verify/Set Variables:
Please enter ORACLE_SID [openview]: [Enter]
Please enter ORACLE_HOME [/opt/oracle/product/8.1.7]: [Enter]
Please enter the name of the database server node
(normally management server) [voyager]: [Enter]
Do you want to enable automatic startup of the Net8 listener at system boot (y/n) [y] ? [Enter]
Do you want to start the Net8 listener now (y/n) [y] ? [Enter]



LSNRCTL for HPUX: Version 2.3.4.0.0 - Production on 18-NOV-98 14:39:39
Copyright (c) Oracle Corporation 1994. All rights reserved.
Starting /opt/oracle/product/8.0x/bin/tnslsnr: please wait...
TNSLSNR for HPUX: Version 2.3.4.0.0 - Production
System parameter file is /etc/listener.ora
Log messages written to /opt/oracle/product/8.1.7/network/log/listener.log
Listening on: (ADDRESS=(PROTOCOL=ipc)(DEV=10)(KEY=openview))
Listening on: (ADDRESS=(PROTOCOL=tcp)(DEV=14)(HOST=15.8.153.173)(PORT=1521))
Connecting to (ADDRESS=(PROTOCOL=IPC)(KEY=openview))
STATUS of the LISTENER
------------------------
Alias LISTENER
Version TNSLSNR for HPUX: Version 2.3.4.0.0 - Production
Start Date 18-NOV-98 14:39:46
Uptime 0 days 0 hr. 0 min. 1 sec
Trace Level off
Security OFF
SNMP OFF
Listener Parameter File /etc/listener.ora
Listener Log File /opt/oracle/product/8.1.7/network/log/listener.log
Services Summary...
openview has 1 service handler(s)
The command completed successfully
OVO Net8 configuration script opcsqlnetconf finished.
#

Task 3  Verify that the Listener is Running

Enter the commands:
  export ORACLE_HOME=<pathname>          
        (pathname is typically /opt/oracle/product/8.1.7)
  $ORACLE_HOME/bin/lsnrctl status

Look in the resulting status summary for a Services Summary indicating that openview has <number> service handler(s) 
(showing one or more for the number). If an error message appears, indicating "no listener," ask your Oracle database or 
OVO administrator to start the listener.

Configure the Windows Client System 
(Running Reporter) 

This section covers the Windows client configuration. This configuration allows Reporter to connect to the UNIX system, from 
which the OVO database is accessed. 

Task 1   Install Oracle 8.1.7 Client software

To begin, you need the following Oracle product: Oracle8i Client, Release 2 ( 8.1.7). You also need administrator privileges 
on the Windows client where Reporter is installed.

 NOTE: If you have the Reporter main window open, you must close it before you begin the installation of Oracle 8.1.7 Client software.

1.  If you have Oracle installed on your system, at your Windows system insert the Oracle8i Client CD and in the dialog box that appears select 
Install/Deinstall Products.
If you have no Oracle Products on your system skip this step. 

2.  In the Oracle Universal Installer Welcome dialog click Next. 
3.  In File Locations enter the Source and Destination file locations for this product; click Next.
4.  In the Installation Types select Administrator as the installation type and click Next. 
5.  Verify information in the Summary dialog that appears. Click Install 

The install process automatically starts the Configuration Tools dialog where you can choose to run the Net8 Configuration 
Assistant. 

Task 2  Configure the Net8 connection to the OVO database

After you complete the installation of the Oracle client software (the Net8 Configuration is optionally part of the client install 



and dialog steps may differ slightly)  on the Windows system running Reporter, on that same system complete the following 
steps: 

1.  From the Start>Programs menu, select Oracle - <Oracle Home>, and Network Administration, and Net8 Configuration Assistant.

At the Welcome dialog select Local Net Service Name Configuration, click Next.

2.  In the Net Service Name Configuration dialog select Add and click Next.
3.  In the Database Version dialog, select Oracle8i database or service (select the other option if connecting to a previous Oracle version), 

click Next.
4.  At the Service Name dialog supply the global database name specified during database creation.

Click Next.

Rerun the Net8 assistant and select test to verify the actual, full Net Service Name. 



 NOTE: The Net Service Name (i.e., openview) may have the network domain appended to its name. (For example, 
openview.rose.hp.com, where "rose.hp.com" is the domain name. Domain name may or may not be necessary, depending on how your 
system is set up.) 

1.  At the Select Protocols dialog, select TCP, click Next.  
2.  At the TCP/IP Protocol dialog, supply the Host Name and port number (typically 1521), click Next.

3.  At the Test dialog, select Yes, perform a test, and click Next. 
4.  At the Connecting dialog, verify that the connection was successful (you may have to change the login credentials for the test to succeed; the 

login/password should match those set up for OVO connecting to the database). Click Next. 
5.  At the Net Service Name dialog, supply a Net Service Name, (suggested: openview) click Next. 

11.  At the Another Net Service Name? Dialog, select No, click Next.

12.  At the Done dialog, click Next, then click Finish.



 NOTE: The Net Service Name (i.e., openview) may have the network domain appended to its name. (For example, 
openview.rose.hp.com, where "rose.hp.com" is the domain name. Domain name may or may not be necessary, depending on how 
your system is set up.) 
Rerun the Net8 assistant and select test to verify the actual, full Net Service Name.

Task 3   Verify the Net8 connection to the OVO database

After you complete the Net8 configuration, verify that you can contact the OVO database from your system as follows: 

1.  From the Start/Programs menu, select Oracle <Oracle Home>, Database Administration, and SQLPlus Worksheet.
2.  In the Oracle Enterprise Manager Login dialog, enter the database User Name  (the recommend user name is opc_report) and 

Password.  Enter the Service name (openview<.DOMAIN.NAME>).

3.  Click the OK button.  The SQL*PLUS Worksheet should appear.  If error messages appear, you have an error in the 
connection from the system to the Oracle OVO database. Review previous tasks in this section.



4.  In the SQL*Plus Worksheet, enter the command to retrieve data from one of the Oracle database tables:

select node_group_name from opc_node_groups;

A response like the following indicates successful access to the OVO database. If you receive errors, you need to 
correct them before proceeding. Contact your Oracle database administrator for assistance.

NODE_GROUP_NAME
--------------------------------
hp_ux
net_devices
NT40

5.  From the File menu select Exit.

Task 4  Configure the ODBC data source in the Control Panel

After you have configured Net8 on the Windows system running Reporter, you must configure the ODBC data source. 

On the Windows system where Reporter is (or will be) installed, complete the following steps: 

1.  Select Control Panel from the Windows Start>Settings menu. 
2.  Double-click ODBC in the Control Panel window . 
3.  Select the System DSN tabbed page. 
4.  Choose the Add… button and highlight Oracle ODBC driver and select Finish. 
5.  In the dialog box that appears, enter the following:

Data Source Name:        ov_net  
Description:                   <your_description>
Service Name:               openview<.domain.name>
User ID:                        (no entry necessary)

 NOTE: You must provide the Data Source Name as ov_net8 in case of ovo 8 database to configure OV Operations for Unix 8. 

6.  Click OK. 
7.  Close the ODBC Data Source Administrator window.   
8.  Close the Control Panel window. 

Task 5 Install the OVO Report Package



To add report definitions and configuration information, you need to add the OV Operations for Unix 7, and 8 package.

 IMPORTANT: If you have installed an earlier version of OVO (OpenView Operations for UNIX [ITO]) reports, you must remove that package from 
the Installed Packages area of the Configure Report Packages dialog (as shown below)

1.  Select the package in the Installed Packages area and click the left-arrow.
(The report package then no longer appears in the Installed Packages area.)

2.  Click OK to close the dialog; then proceed as instructed below.

 NOTE: Any modifications you made to the reports you just removed, you must re-configure in the newly installed package. 

To add the package: 

1.  Start Reporter from the Start/Programs/HP Openview/Reporter menu. 
2.  In the Reporter main window from the File menu select Configure>Report Packages.

3.  Select the appropriate OpenView Operations version from the Available Packages box; click the right-arrow to move to the Installed Packages 
box, and click OK. 
If you currently use report packages for ITO 5 or VPO 6, new packages are available:

●     OV Operations for Unix 7
●     OV Operations for Unix 8 

Make sure to remove your current package before installing the new one (see Important preliminary information/instructions 
above).



1.  Verify that the Reporter service is running 
(the service is not running if the 3rd through 6th toolbar buttons are disabled); if not, start it by clicking the 2nd button. 

2.  In the Status pane, check for the messages: 
RepLoad:Loading package for " OV Operations for Unix 6 & 7" 
RepLoad:Completed loading template file
(to indicate successful package installation) 

Task 6  Configure the Database in Reporter

Now that you have configured the database connection to the Windows 2000 system and installed the OpenView Operations 
Report Package, you can configure Reporter to recognize the OpenView Operations database as the source for its data. With 
Reporter installed on the Windows system, follow the steps below: 

1.  In the Reporter main window, from the File menu select Configure, then Databases from the submenu. 
2.  In the Other Databases section (lower area) of the Configure Databases dialog box select the down-arrow in the Database text box, and 

choose openview. 
(If openview does not appear, you will need to review the steps of the previous sections to configure the ODBC setup.)

 NOTE: You must choose openview8 to configure OV Operations for Unix 8. 
3.  Complete the remaining text boxes as follows: 

Server: ov_net
User ID:< your_OpenView Operations_ database_user_name>
Password:<your_OpenView Operations_database_password>

 NOTE: You must choose ov_net8 as the Server to configure OV Operations for Unix 8. 

 IMPORTANT: Though asterisks appear for the password, you must enter the correct password for the OpenView Operations user ID. 
4.  Click OK.
5.  Reboot the system.

Task 7  Discover OpenView Operations Systems and Gather OVO Data

 NOTE: Reporter's Discover_ITO.exe program targets the OpenView Operations database. 

1.  Select Schedule in the left pane to display a list of all scheduled actions in the right pane. 

 NOTE: If configured with OVO 8, add a new schedule entry for DISCOVER_ITO.exe and Gather_ITO.exe with openview8 as a parameter.
2.  In the right pane, right-click Discover_ITO.exe and select Run Now. 
3.  In the Status pane, check for messages such as: 

2000/12/27 15:12:19 Discover_ITO: Begin Discovery of ITO database openview2000/12/27 15:12:19 Discover_ITO: Found 
NEW ITO Agent on plumas.rose.hp.com
2000/12/27 15:12:19 Discover_ITO: Found NEW ITO Agent on zephram.rose.hp.com
2000/12/27 15:12:19 Discover_ITO: Found NEW ITO Agent on ros59102raw.rose.hp.com
2000/12/27 15:12:19 Discover_ITO: Found NEW ITO Agent on highbeam.rose.hp.com
2000/12/27 15:12:19 Discover_ITO: Examined 4 systems, found 4 new ITO Agents for a total of 30 known
2000/12/27 15:12:20 Discover_ITO: Examined systems in groups for 3 systems, found 3 new
2000/12/27 15:12:20 Scheduler: Next scheduled action at 12/28/00 00:15:0 

If you see errors, return to Task 6 and make sure the password and other fields have been correctly filled in. 
4.  In the right pane, right-click Gather_ITO.exe and select Run Now. 
5.  In the Status pane, check for messages such as:

2000/12/27 15:12:40 Scheduler: 
Starting program "Gather_ITO.exe" 2000/12/27 15:12:40 Gather_ITO: Begin synchronizing with ITO database openview
2000/12/27 15:12:41 Gather_ITO: Processing Historical messages
2000/12/27 15:13:19 Gather_ITO: Processed 2775 Historical messages, Added 860 Summaries, 854 Operator Sums
2000/12/27 15:13:19 Gather_ITO: Processing Active messages
2000/12/27 15:13:21 Gather_ITO: Processed 755 Active messages, Added 9 Summaries, 6 Operator Sums
2000/12/27 15:13:22 Scheduler: Next scheduled action at 12/28/00 00:15:00

6.  If you want to see reports immediately, in right pane right-click RepCrys.exe and select  Run Now. 

Your configuration of the OpenView Operations database with Reporter is now complete. OpenView Operations reporting will 
now run in the normal nightly reporting cycle. 



Oracle Setup/Connections 
Part D: Configure Oracle 8.1.7 as the Database

Set Up Oracle 8.1.7 on HP-UX or Solaris and Configure on Windows

Prerequisites: Check your HP-UX or Solaris system kernel parameters and modify as necessary. 
Reporter requires 900MB disk space in the Oracle database.

For other system, memory, and disk requirements, please check the "System Requirements" section of 
the Oracle 8i Installation Guide included with the software distribution. Oracle has specific 
recommendations regarding optimal database installation and architecture. This document does not 
discuss all aspects of database installation and administration. We suggest that you consult Oracle 
technical literature and qualified Oracle professionals to achieve optimum database performance in your 
particular environment.

 IMPORTANT: If HP OpenView Internet Services 4.5 or later and Reporter are installed on the same system, migration of 
your OVIS/Reporter data from your existing database to Oracle 8.1.7 is not supported.

 

The following illustration shows the tasks you must complete to set up Oracle as the Reporter database. 
To the left are the steps on the HP-UX or Solaris system which differ for new and existing installations 
of Oracle. To the right is the procedure for configuring the Oracle Reporter database on the Windows 
system.

  



On the UNIX or Solaris system (choose the appropriate procedure by clicking it): 

●     Setup for new installations of Oracle 8
     (Task 1 — 6)

●     Setup for existing installations of Oracle 8
    (Task 4 — 6)

On the Windows system running Reporter: 

●     Configure Reporter to use the Oracle database
●     Case Sensitivity: Some required entries in Windows are case-sensitive; so we recommend you match instruction 

text exactly.

Setup for new installations of Oracle 8.1.7 

●     Task 1 Create Oracle groups, user, and home directory
●     Task 2 Mount the CD
●     Task 3 Install Oracle software using the Oracle Universal Installer
●     Task 4 Create Reporter database objects
●     Task 5 Create Reporter Tablespace, User, and Privileges
●     Task 6 (optional) Configure Automatic Database Startup and Shutdown

Task 1  Create Oracle groups, user, and home directory 

Before you begin, you need the following administrator privileges: root and dba privileges on the UNIX 
system where you are using Oracle; administrator privileges on the Windows client where Reporter is 
installed. 

1.  You must be logged on as root or su.
2.  For HP-UX: Use System Administration Manager (SAM) utility on HP-UX 11.0 to create UNIX group dba.



For Solaris: Use admintool or (groupadd utility) to create UNIX group dba.
3.  For HP-UX: Use SAM utility to create UNIX group oinstall.

For Solaris: Use admintool or (groupadd utility) to create UNIX group oinstall.
4.  For HP-UX: Use SAM utility to create UNIX user oracle.

For Solaris: Use admintool (or useradd utility) to create UNIX user oracle. 
❍     Login name: oracle
❍     Primary Group Name: oinstall

    Secondary Group Name: dba
❍     Home directory: consistent with local standards
❍     Login shell: consistent with local standards

5.  Create Oracle Home mount point: mkdir –p /opt/oracle/product/8.1.7
6.  Enter: cd /opt
7.  Enter chown –R oracle:oinstall oracle

Task 2  Mount the CD 

For HP-UX: 

1.  Edit the /etc/pfs_fstab file to add the following line:
Syntax:
<device_file> <mount_point> <filesystem_type> <translation_method>
Definitions of the syntax above:
<device_file> = CD-ROM device file (discover with ioscan –nFC disk)
<mount_point> = /CDROM
<filesystem_type> = CD-ROM is in IS09660 format, Rockridge extension <translation_method> = unix
For example:
/dev/dsk/c1t2d0 /SD_CDROM pfs-rrip xlat=unix 0 0 

2.  Perform the following steps as the root user:
Enter: /usr/sbin/pfs_mountd &  
NOTE:pfs creates the correct format to read the CD
Enter: /usr/sbin/pfsd &

3.  Insert the CD into the CD-ROM and mount the device as follows:
/usr/sbin/pfs_mount /SD_CDROM

4.  Leave the root user window available for executing a script during installation .

For Solaris:

—If you are using Volume Management software (available by default on Solaris) the CD-ROM is 
mounted automatically to /cdrom/oracle8i when you put it into the disk drive.

—If you are not using the Volume Management software, you must mount the CD-ROM manually. 

1.  Place the Oracle 8i CD-ROM in the CD-ROM drive.
2.  Log in as the root or su user and create a CD-ROM mount point directory:

$ su root
# mkdir cdrom_mount_point_directory

3.  Mount the CD-ROM drive on the mount point directory and exit:
# mount option device_name cdrom_mount_point_directory
# exit

Task 3  Install Oracle software using the Universal Oracle Installer 

1.  Log in to the oracle account
a. Verify umask command returns 022
b. Set umask 022 in .profile if needed

2.  Set UNIX environment variables as follows: (add to .profile,or set manually)
DISPLAY=<workstation_name>:0.0 (<workstation_name> is computer where output from the Oracle Universal 



Installer should be displayed)
ORACLE_BASE=/opt/oracle
ORACLE_HOME=/opt/oracle/product/8.1.7
ORACLE_SID=REPORTER
PATH includes $ORACLE_HOME/bin, /usr/bin, /etc, /usr/ccs/bin, /usr/local/bin

3.  Start the Installer: /CDROM./runInstaller
NOTE: The order for the following dialog boxes may vary according to your version of Oracle.
In the Welcome dialog, click Next.

4.  In File Locations do not change the product Source...Path entry.,
The Oracle Home Destination...Path entry should display the value for ORACLE_HOME if previously set; click Next. 
The illustration uses 8.1.7 for example.

 IMPORTANT: These procedures and screen examples are for Oracle 8.1.7 on HP-UX. Other operating systems and 
versions may be different. 

1.  For the UNIX Group Name enter oinstall and click Next. 



2.  If /var/opt/oracle does not exist or can not be edited by the oracle user, you are prompted to run 
/tmp/Orainstall/orainstRoot.sh.
After running this script, click Retry to continue.

3.  Under Available Products select Oracle8i Enterprise Edition 8.1.7.0.0, click Next.
4.  Under the Installation Types select Minimal installation; click Next.  
5.  In the Privileged Operating System Groups enter dba for the UNIX groups and click Next. 
6.  In Select Starter Database select No, and click Next.  
7.  In the Summary verify Space Requirements and select the Install button.

The Install dialog appears. 
8.  In the Setup Privileges dialog run root.sh as instructed. 
9.    When the "Install successful" message appears, click Next.

The Configuration Tools dialog appears. 
10.  In the Net8 Configuration Assistant Welcome window click Next.

 



11.  Select No to defer directory naming; click Next.  
12.  Select a Listener name—LISTENER is recommended—and click Next.   



13.  Select TCP for the connection protocol, click Next.  
14.  Select the standard port number of 1521, click Next.  
15.  Select No for configuring another listener, click Next.  
16.  At "Listener configuration complete" message, click Next. 
17.  Select No for changing the naming methods, click Next.  
18.  At the "Net8 Configuration Complete" message, click Finish.
19.  In the End of Installation dialog click Exit.

Task 4  Create Reporter database objects 

1.  Log in to the oracle account
2.  Update UNIX environment variables as follows: (add to .profile,or set manually)

DISPLAY=<workstation_name>:0.0
(<workstation_name> is computer where output from the Oracle products should be displayed)
ORACLE_BASE=/opt/oracle
ORACLE_HOME=/opt/oracle/product/8.1.7
ORACLE_SID=REPORTER
PATH includes $ORACLE_HOME/bin, /usr/bin, /etc, /usr/ccs/bin, /usr/local/bin

for HP-UX: SHLIB_PATH=$ORACLE_HOME/lib
for Solaris: LD_LIBRARY_PATH=$ORACLE_HOME/lib

for Oracle 8.1.7:
CLASSPATH=$ORACLE_HOME/JRE/lib:$ORACLE_HOME/jlib:
$ORACLE_HOME/network/jlib:$ORACLE_HOME/rdbms/jlib:$ORACLE_HOME/assistants/jlib
TNS_ADMIN=$ORACLE_HOME/network/admin

3.  Run the Database Configuration Assistant by entering dbassist
4.  In the startup window select Create a database, click Next. 
5.  Select Custom as the database type, click Next.
6.  Select Multipurpose as the type of application, click Next.
7.  Select number of concurrently connected users (suggest 40), click Next.



8.  Select Dedicated Server Mode, click Next.
9.  No options required for reporter; click Next.

10.  Enter the Global Database Name (i.e. reporter<.domain.name> ) and SID (REPORTER). Note that 
REPORTER must be entered as all uppercase. Then click Next. 



11.  Review the Control File information, click Next.

NOTE: Oracle recommends multiplexing controls files on different disks to support database recoverability.



12.  Accept the defaults for all the tabs (click Next through the tabs) unless otherwise recommended by your Oracle
Administrator.  



13.  Review the Redo Log Files information; click Next.

14.  Review the logging parameter information; click Next.
15.  Review the SGA parameter information; click Next.
16.  Review the Trace File Directory information; click Next. 
17.  Select Create database now; click Finish.

 Task 5  Create Reporter tablespace, user, and privileges* 

1.  Log on as root or su.
2.  Create the file (below) and save as repconfig.sql in the $ORACLE_BASE/admin/reporter/create/ directory:

(the edits you need to make are highlighted) :

NOTE: For performance considerations Oracle recommends to place data (tablespace REPORTER), index 
(tablespace RPT_INDEXES), and rollback segments (tablespace RBS) on different disks if available. See  "Chapter 6: 
Scalability and System Requirements"   for tablespace sizing.

NOTE: You must replace /database/oradata with the path you have established for your database data files. 
The data file names are only recommendations and can be changed to conform to the standards at your site. Also 
the user and password are highlighted; change as necessary.

 IMPORTANT: If the actual storage size of 600MB for REPORTER tablespace and 300MB for the RPT_INDEXES 
tablespace is not large enough, please consult your Oracle DBA on the appropriate size for your environment or how 
to setup the AUTOEXTEND datafile feature in Oracle.

create tablespace REPORTER datafile
'/database/oradata/reporter/rptdb01.dbf' SIZE 600M
extent management local autoallocate;



create tablespace RPT_INDEXES datafile
'/database/oradata/reporter/rptidx01.dbf' size 300M
extent management local autoallocate;
 

CREATE USER "OPENVIEW" PROFILE "DEFAULT" 
IDENTIFIED BY "openview" 
DEFAULT TABLESPACE "REPORTER" 
TEMPORARY TABLESPACE "TEMP" 
QUOTA UNLIMITED ON REPORTER 
QUOTA UNLIMITED ON RPT_INDEXES 
ACCOUNT UNLOCK;

GRANT CREATE ANY INDEX TO "OPENVIEW"
GRANT CREATE PROCEDURE TO "OPENVIEW"
GRANT CREATE SEQUENCE TO "OPENVIEW"
GRANT CREATE SESSION TO "OPENVIEW"
GRANT CREATE TABLE TO "OPENVIEW"
GRANT CREATE TRIGGER TO "OPENVIEW"
GRANT CREATE VIEW TO "OPENVIEW"
GRANT "CONNECT" TO "OPENVIEW"; 
 

3.  Log on as the oracle software owner.
4.  (If migrating Reporter data from the default database to Oracle, skip forward to step #8.)

Make sure the ORACLE_SID is set to REPORTER; otherwise the Reporter tables will be put in the wrong SID.
5.  Run the $ORACLE_HOME/bin/svrmgrl program and enter the following commands to start the database (the 

database may have already been started)
connect internal
startup

6.  Enter the following SQL statement:
@$ORACLE_BASE/admin/reporter/create/repconfig.sql

7.  Enter the following command to exit: Exit
8.  Enter the following commands to restart the SQL listener:

lsnrctl stop
lsnrctl start

Task 6 Configure Automatic Database Startup and Shutdown

You may optionally configure the database for automatic startup and shutdown. See the Oracle 
documentation for details on this procedure.

 WARNING! If your database administrator already has the startup procedure in place, you should skip 
this step.

 WARNING! If the OVO (also known as VantagePoint Operations or ITO) (openview) database is installed 
on same Oracle server, you must modify its oratab entry to change the startup flag from "Y" to "N" since it is 
restarted by a different facility. For example, change openview:$ORACLE_HOME:Y to 
openview:$ORACLE_HOME:N.

Now you are ready to configure Reporter to use the Oracle database.

Configure Reporter on the Windows System

This section covers the installation of the software that allows the Windows system, on which Reporter 
runs, to connect to the HP-UX or Solaris system, from which the Oracle database is accessed.



Task 1  Install Oracle Client software

To begin, you need the following Oracle product: Release 3 (8.1.7) for Windows 2000. You also need 
administrator privileges on the Windows client where Reporter is installed 

1.  At your Windows system, insert the Oracle8i Client CD and select Install/Deinstall Products in the dialog box that 
appears. 

2.  In the Oracle Universal Installer Welcome dialog click Next.
3.  In the File Locations dialog enter the Source and Destination file locations and click Next.
4.  In the Installation Types dialog select Administrator as the installation type and click Next.
5.  Verify information in the Summary dialog and click Install.

The installation process starts the Configuration Tools dialog. The Net8 Configuration Assistant will 
optionally be run.

Task 2 Configure the Net8 connection to the Reporter database

After you complete the installation of the Oracle client software (the Net8 Configuration is optionally part 
of the client install and dialog steps may differ slightly) on the Windows system running Reporter, on 
that same system complete the following steps: 

1.  From the Start/Programs menu, select Oracle><Oracle_Home>:Network Administration:Net8 Configuration 
Assistant.

2.  In the Welcome dialog select Local Net Service Name configuration and click Next.
3.  Select the Add radio button; click Next.
4.  In the Database Version dialog, select Oracle8i database or service (select the other option if connecting to a 

previous Oracle version), click Next. 
5.  In the Service Name dialog supply the global database name you entered in Task 4, step #10, of Configure reporter 

on UNIX; (i.e. reporter.<domain.name>); click Next.  
6.  At the Select Protocols dialog, select TCP, click Next.
7.  At the TCP/IP Protocol dialog, supply the Host Name and port number (typically 1521), click Next. 



8.  At the Test dialog, select Yes, perform a test; click Next.  
9.  At the Connecting dialog, verify that the connection was successful (you may have to change the login credentials 

(i.e., openview/openview) for the test to succeed); click Next.



10.  At the Net Service Name dialog, supply a Net Service Name (suggested: RPT), and click Next.

11.  In the Another Net Service Name? dialog, select No, and click Next.
12.  In the Done dialog, click Next, and then Finish.

NOTE: The Net Service Name (i.e., RPT) may have the network domain appended to its name, for example 
RPT.<DOMAIN.NAME>. Rerun the Net8 assistant and select test to verify the actual, full Net Service Name.

Task 3 Verify the Net8 connection to the REPORTER database

After you complete the Net8 configuration, perform the following steps to verify that you can contact the 
Reporter database from your Windows system: 

1.  From the Start/Programs menu, select Oracle <Oracle_Home>, Database Administration, and SQLPlus 
Worksheet.

2.  In the Oracle Enterprise Manager Login dialog, enter the database Username and Password that you used for the 
UNIX system configuration in Task 5, step 2 (username: openview, password:openview). Enter the Service name 
(RPT.<domain_name>)



3.  Click the OK button.
4.  In the SQL*Plus Worksheet, enter the command:

select TABLESPACE_NAME, STATUS from user_tablespaces

The following tablespace names should be displayed:
TABLESPACE_NAME                 STATUS
--------------------------------------
SYSTEM ONLINE
TOOLS                           ONLINE
RBS                             ONLINE
TEMP                            ONLINE
USERS                           ONLINE
INDX                            ONLINE
REPORTER                        ONLINE
RPT_INDEXES                     ONLINE
8 rows selected.

If you cannot connect to the database, or do not see these tables, check with the Oracle 
database administrator for the UNIX host system.

5.  From the File menu select Exit.

Task 4  Configure the ODBC data source in the Windows Control Panel

After you have configured Net8 on the Windows system running Reporter, you must configure the 
ODBC data source. On the Windows system where Reporter is (or will be) installed, complete the 
following steps.

IMPORTANT: If the Reporter main window is open, close it before continuing.

1.  Select Start > Settings > Control Panel.
2.  In the Control Panel window::

for Windows 2000 double-click Administrative Tools (Windows 2000), then
ODBC Data Sources.
for NT 4 double-click ODBC Data Sources.

3.  Select the System DSN tabbed page.



4.  (If migrating data from the default database to Oracle, omit this step.)
Choose Reporter with the default database driver and remove it.

5.  Select the Add… button and highlight Oracle ODBC Driver and select Finish.
6.  In the dialog box that appears, enter the following:

Data Source Name: Reporter 
Description: <your_description>
Service Name:  RPT.<domain_name>
User ID:  (no entry necessary)

 IMPORTANT: You must enter Reporter as the Data Source Name in mixed case (uppercase "R") to match 
references to it in Reporter executables.

Task 5  Configure the Database in Reporter*

*If you are migrating data from the default database to Oracle, OMIT step #7. 

1.  To start Reporter, select > Start > Programs > HP OpenView > Reporter.
2.  An error message is expected; click OK to proceed.

3.  In the Reporter main window, from the File menu select Configure > Databases.
The same error message appears as in the previous step; ignore and click OK to proceed.



4.  In the Configure Databases dialog box under the Reporter Database section, enter the database User Name and 
Password that you used for the UNIX system configuration in Task 5, step 2 (username: openview; password: 
openview).
If you are migrating from the default database to Oracle, User Name is system and Password is manager. 

5.  Click OK
6.  (If migrating data from the default database to Oracle, OMIT this step.)

Run <install_directory>\bin\Newdb.exe
7.  Close, then re-open the Reporter main window.



Oracle Setup/Connections 
Part E: Configure Oracle 9i as the Database

Set Up Oracle 9i on HP-UX or Solaris and configure the the Reporter Windows 
Client System

 IMPORTANT: If HP OpenView Internet Services 4.0 and Reporter are installed on the same system, migration of your OVIS/Reporter data 
from your existing database to Oracle 9i is not supported.

The following illustration shows the tasks you must complete to set up Oracle as the Reporter database. To the left are 
the steps on the HP-UX or Solaris system which differ for new and existing installations of Oracle. To the right is the 
procedure for configuring the Oracle Reporter database on the Windows system.

 

Prerequisites: Because a successful Oracle configuration is dependent upon correct kernel parameter settings, check 
your HP-UX or Solaris system kernel parameters (see the Oracle 9i Release Notes for these parameters). Ensure you 
have the following available:

●     Memory: 256 MB RAM minimum 
●     Swap space: disk space equivalent to greater of 2*RAM, or 400 MB 
●     CD-ROM: capable of reading ISO 9660 format with RockRidge extensions 
●     Disk space: 2.5 GB for database software; 1 GB for database 
●     Temp disk space: 400MB in /tmp directory 
●     HP-UX 11.0 (64-bit) or or HP-UX 11i (64-bit)

or
Solaris 7 (5.7) or Solaris 8 (5.8) or Solaris 9.

●     Operating system patches (detail in the Oracle9i Release Notes) \
●     JAVA components (detailed in the Oracle9i Release Notes) 
●     HP-UX note: an important pre-installation step is required relating to X library symbolic links 

Oracle Documentation: The documents can be found on the Oracle9i Database CD-ROMs. To access them, mount 
Disk 1 of the Oracle9i Database CD-ROM and open the index.html. Oracle also provides online resources for 
documentation at the Oracle Documentation Center (docs.oracle.com) and the Oracle Technology Network 
(otn.oracle.com/docs/).For Oracle-specific information, please check the following:



●     Oracle9i Installation Guide
●     Oracle9i Quick Installation Procedure
●     Oracle9i Release Notes 

Configuration steps are divided into two sets of tasks as follows:

Server setup for Oracle9i on HP-UX or Solaris system:

●     Prepare the UNIX environment 
●     Mount the installation CD 
●     Install Oracle9i Database Server software 
●     Configure a database listener 
●     Create the Reporter database structure 
●     Create the Reporter database user and privileges 

Client setup for Oracle9i on Windows Reporter system:

●     Install Oacle9i client software 
●     Configure the Oracle Net connection 
●     Verify the Oracle Net connection 
●     Configure the ODBC data source 
●     Configure the database in Reporter

Task 1  Prepare the UNIX Environment

1.  Create the Oracle UNIX groups:
HP-UX: use the System Administrator's Manager (SAM) to create groups
Solaris: use the admintool or groupadd utility to create groups 

i.  Log in as the root user.
ii.  Create UNIX group "dba" (The OSDBA group)
iii.  Create UNIX group "oper" (The OSOPER group)
iv.  Create UNIX group "oinstall" (The ORAINVENTORY group)
v.  HP-UX note: See the Oracle9i Quick Installation Procedure for the special privileges that should be assigned to the OSDBA 

group.
2.  Create the UNIX user "oracle":

HP-UX: use the System Administrator's Manager (SAM) to create accounts
Solaris: use the admintool or useradd utility to create accounts. 

Create UNIX user "oracle" (This account is for Oracle software installation and upgrading only)
— Primary group: oinstall (The ORAINVENTORY group)
— Secondary group: dba (The OSDBA group)
Create UNIX user "apache"
— Primary group: oinstall (The ORAINVENTORY group)
— Secondary group: group in which apache is only member.
The Apache account should have minimum privileges.

3.  Create mount points for Oracle database software
i.  Create Oracle Home mount point:

mkdir -p /opt/oracle/product/9.0.1
ii.  Enter: cd /opt
iii.  Enter: chown -R oracle:oinstall oracle
iv.  Make sure a local bin directory such as /usr/local/bin or /opt/bin exists.
v.  Set UNIX system and Oracle environment variables

(add to .profile or set manually) 

DISPLAY=<workstation_name>:0.0 (where output from Oracle installer displays)
ORACLE_BASE=/opt/oracle
ORACLE_HOME=/opt/oracle/product/9.0.1
ORACLE_SID=reporter
PATH includes $ORACLE_HOME/bin, /usr/ccs/bin, /usr/bin, /etc, (/usr/bin/X11
for HP-UX), (/usr/openwin/bin for Solaris), and /usr/local/bin (if it exists)

Example of .profile for HP-UX:



# Oracle Environment
ORACLE_BASE=/opt/oracle; export ORACLE_BASE
ORACLE_HOME=/opt/oracle/product/9.0.1; export ORACLE_HOME
ORACLE_SID=reporter; export ORACLE_SID
ORACLE_TERM=xterm; export ORACLE_TERM
TNS_ADMIN=/export/home/oracle/config/9.0.1; export TNS_ADMIN
NLS_LANG=AMERICAN_AMERICA.UTF8; export NLS_LANG
ORA_NLS33=$ORACLE_HOME/ocommon/nls/admin/data; export ORA_NLS33
LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib:$ORACLE_HOME/rdbms/lib
SHLIB_PATH=$ORACLE_HOME/lib32:$ORACLE_HOME/rdbms/lib32
export LD_LIBRARY_PATH
export SHLIB_PATH

#set shell search paths
PATH=/bin:/usr/bin:/usr/sbin:/etc:/opt/bin:/usr/ccs/bin:/usr/local/bin:$ORACLE_HOME/bin
export PATH

#CLASSPATH must include the following JRE locations:
CLASSPATH=$ORACLE_HOME/JRE:$ORACLE_HOME/jlib:$ORACLE_HOME/rdbms/jlib
CLASSPATH=$CLASSPATH:$ORACLE_HOME/network/jlib

Task 2  Mount the Installation CD

1.  Edit the /etc/pfs_fstab file to add the following: 
<device_file> <mount_point> <filesystem_type> <translation_method> 

Definitions of the above syntax: 
<device_file> = CD-ROM device file (discover with ioscan -nFC disk) 
<mount_point> = path name of the mount point 
<filesystem_type> = CD-ROM is in IS09660 format, Rockridge extension 
<translation_method> = unix
For example:
/dev/dsk/c1t2d0 /SD_CDROM pfs-rrip xlat=unix 0 0 

Perform the following steps as the root user: 

2.  Enter: /usr/sbin/pfs_mountd & 
NOTE:pfs creates the correct format to read the CD
Enter: /usr/sbin/pfsd & 

3.  Insert the CD into the CD-ROM and mount the device as follows:
/usr/sbin/pfs_mount /SD_CDROM 

4.  Change directories to /SD_CDROM where you can see a lower-case listing of the directories and files on the CD-ROM.
(The mounted CD should appear as another read-only file system.) 

Leave the root user window available for executing a script during installation .

For Solaris:
If you are using Volume Management software (available by default on Solaris) the CD-ROM is mounted automatically 
to /cdrom/orcl901_1 when you put it into the disk drive.
If you are not using the Volume Management software, you must mount the CD-ROM manually.

1.  Place the Oracle 9i CD-ROM in the CD-ROM drive. 
2.  Log in as the root or su user and create a CD-ROM mount point directory:

$ su root
# mkdir cdrom_mount_point_directory 

3.  Mount the CD-ROM drive on the mount point directory and exit:
# mount option device_name cdrom_mount_point_directory
# exit 

Task 3  Install Oracle 9i Database Server Software



1.  Log in to the Oracle account. 
2.  Launch the Oracle Universal Installer by typing the full path to the installer executable.

 WARNING! Do not launch the installer from within the CDROM directory or you will not be able to mount multiple CDs.
Example:
/cdrom/oracle9i/runInstaller or /SD_CDROM/runInstaller. 

3.  For first-time Oracle9i installations the Welcome window appears, where you click Next. 
4.  In the Inventory Location window specify a base directory and click OK. 
5.  In the UNIX Group Name window enter oinstall (the ORAINVENTORY Group) and click Next. 
6.  You may have to run a script if pre-installation tasks were not completed. 
7.  In the File Locations window do not change the text in the source field and click Next. 
8.  In the Available Products window select Oracle9i Database and click Next. 
9.  In the Installation Types window select Enterprise Edition.

(Alternatively you can select the Standard Edition; see Oracle documentation for differences between these installation types.) Click 
Next. 

10.  In the Database Configuration Window select Software Only and click Next. 
11.  In the Choose JDK Home Directory enter the appropriate location and click Next. 
12.  Review the Summary Window and click Install.

(When the Install window appears, wait as the products is installed.) 
13.  When the Setup Privileges window appears, run the script as instructed. 
14.  In the End of Installation window select Exit. 

Task 4  Configure a database listener

1.  At a UNIX console window, logged in as the Oracle user, enter netca to start the Oracle Net Configuration Assistant. 
2.  In the Welcome window select Listener configuration and click Next. 
3.  Select Add and click Next. 
4.  Enter a listener name (LISTENER is suggested) and click Next. 
5.  For the connection protocol select TCP and click Next. 
6.  Select the standard port number 1521 and click Next. 
7.  For configuring another listener, select No. 
8.  At the configuration complete message click Next. 
9.  In the final window click Finish. 

Task 5  Create the Reporter database structure 

1.  At a UNIX console window, logged in as the Oracle user, enter dbca to Start the Oracle Database Configuration Assistant.
2.  Select the Create a Database option and click Next.



3.  Select the New Database template and click Next.



4.  Supply Global Database Name and the SID and click Next.

5.  You can optionally de-select the  listed features, which are not required for Reporter, and click Next.



6.  Select the Dedicated Server Mode click Next.

7.  For Memory Parameters, the user concurrency may be as high as 40, depending upon the options selected in reporter; use 200 - 300 
MB of RAM (or as directed by your DBA) and click Next.



8.  (optional) Select the Archive tab and the Archive Log Mode if you want a back up strategy that ensures data recoverability that goes 
beyond the most recent backup.



9.  Click Next.
10.  Select the DB Sizing tab and set the Block Size to 8K.



11.  Select the File Locations tab, where you can review the location settings, and click Next.



12.  In the Database Storage window click the Tablespaces entry in the tree to view current tablespace configuration.



13.  Click the Add button to add the REPORTER tablespace. Size the tablespace to 100MB.



14.  Select the Storage tab, verify Locally Managed extents with Automatic Allocation, and click Create.
15.  Click the Add button to add the RPT_INDEXES tablespace, size the tablespace to 100MB.
16.  Select the Storage tab, verify Locally Managed extents with Automatic Allocation, and click Create.
17.  Click the Tablespaces entry in the tree to verify that the REPORTER and RPT_INDEXES tablespaces have been added to the 

configuration, and click Next.
18.  Select the Create Database option. (Optionally, you can save scripts for this DB creation process and execute them later.) Click 

Finish.
19.  When the Database Creation progress window appears, several hours may be required to create the database depending upon the 

options that are selected. Respond to the database creation completion messages and close the Database Configuration Assistant. 



20.  (Optional) Verify the availability of the REPORTER database.
A. At a UNIX console window, log in as the Oracle user, and start the SQL *Plus environment by
    entering: sqlplus
B. Supply the user-name and password (for example, system / manager should be available as a user-name and password on this 
newly created database).
C. At the SQL prompt enter column tablespace_name format a40;.
D. Enter select tablepspace_name, status from user_tablespaces;
E. Verify that the expected tablespaces are available and enter exit to leave SQL *Plus.



Task 6 Create the Reporter database user and privileges

1.  Start the SQL *Plus environment as described above.
2.  Execute the following SQL statements to create the user for the REPORTER database: 

create user openview profile default
identified by openview
default tablespace reporter
temporary tablespace temp
quota unlimited on reporter
quota unlimited on rpt_indexes
account unlock;
grant
create any index,
create procedure,
create sequence,
create session,
create table,
create trigger,
create view,
select any table, 
connect to openview; 

Configure Reporter on the Windows System

This section covers the installation of the software that allows the Windows system, on which Reporter runs, to connect 
to the HP-UX or Solaris system, from which the Oracle database is accessed.

Task 1  Install Oracle 9i Client software

1.  At the Windows NT/2000 system that hosts reporter, insert the Oracle9i installation CD and in the window that appears select 
Install/Deinstall Products . 

2.  In the Oracle Universal Installer Welcome window click Next. 
3.  Enter or select an Oracle 9 home location for this installation and click Next. 
4.  In the Available Products window select Oracle9i Client and click Next. 
5.  In the Installation Types window select Administrator and click Next. 
6.  Verify the information in the Summary window and click Install. 

A window showing installation progress will appear. The installation process also starts the Oracle Net Configuration 
Assistant tool. Proceed to Task 2 for completion of this activity.

Task 2  Configure the Oracle Net connection

The Oracle Net Configuration Assistant tool can be started independently (without re-installing client software) by 
selecting 
Start > Programs > Oracle-OraHome9 > Configuration and Migration Tools > Net Configuration Assistant. The 
first few dialogs differ between an installation-initiated Assistant compared with an independently started Assistant. The 
steps below use the dialogs encountered when the Assistant is started as part of the client installation.

1.  In the Welcome window select No, I will create net service names myself., and click Next. 
2.  In the Database Version window select Oracle8i or later and click Next. 
3.  In the Service Name window supply the service name for the database (typically reporter or reporter.<domain>, the global database 

name), and click Next. 
4.  In the Select Protocols window choose the appropriate network protocol (typically TCP), and click Next. 
5.  In the TCP/IP Protocol window, supply the Host name and port number (typically 1521), click Next. 
6.  In the Test window, select Yes, and click Next. 
7.  In the Connecting window verify that the connection was successful; you may have to change the login credentials 

(openview/openview) for the test to succeed. 
8.  Click Next. 
9.  In the Net Service Name window supply a service name (suggested: RPT), and click Next. 

10.  In the Another Net Service Name window select No, and click Next. 
11.  In the Done window click Next and then Finish. 



Task 3  Verify the Oracle Net connection

After completion of the Oracle Net Configuration, perform the following steps to verify that you can connect to the 
Reporter database from your Windows system.

1.  Start the SQL *Plus tool by selecting Start > Programs > Oracle-OraHome9 > Application Development > SQL Plus. 
2.  At the Log On dialog supply the User Name (system), Password (manager), and Host String (RPT), [the Net Service Name supplied in 

Task 2, step 9]. 
3.  Enter the following SQL statement: select tablespace_name, status from user_tablespaces; 

If you cannot connect to the database, or do not see these tablespaces, check with the Oracle database administrator 
for the UNIX host system.

4.  To leave the SQL *Plus environment, type Exit. 

Task 4  Configure the ODBC data source

1.  To launch the Windows Control Panel, select Start -> Settings -> Control Panel.
2.  For Windows 2000, double-click Administrative Tools, then double-click Data Sources (ODBC).

For Windows NT4, double-click ODBC Data Sources.
3.  In the ODBC Data Source Administrator, select the System DSN tab.
4.  If it exists, select the Reporter DSN and remove it.
5.  Select the Add… button and highlight the Oracle in OraHome9 driver and click Finish.
6.  In the Oracle ODBC Driver Configuration window enter Reporter as the Data Source name.

For the TNS Service Name, from the drop-down menu select the name configured in
Task 2, step 9 (RPT).

7.  Select the Oracle tab and set Prefetch Count to 25 and disable LOBs.



8.  To test the connection (if desired), click Test Connection and supply the username and password (openview/openview).
9.  To add this data source to the System DSNs, click OK.

Task 5  Configure the Database in Reporter

1.  To start Reporter, select Start -> Programs -> HP OpenView -> Reporter.
2.  (An error message about the table or view not existing is expected.) Click OK to proceed.
3.  In the Reporter main window, from the File menu select Configure -> Databases and click OK to proceed past another similar error 

message.
4.  In the Configure Databases dialog box in the Reporter Database segment, enter the database User ID and Password as determined in 

the UNIX setup, Task 6 (openview / openview).
If you intend to migrate data from the Reporter default database to Oracle, use a dba account such as system / manager.

5.  Click OK, and then close and re-open the Reporter main window to allow the new username and password to be applied to the database 
connection.

6.  If you are migrating data from the default database to Oracle, you do not need to run newdb.exe as directed below since the 
migration tools create the required database schema objects.
If you are not migrating data, create the required database schema objects in the Reporter Oracle database by running the 
C:\Program Files\hp OpenView\bin\newdb.exe program.



 Set Up Unified Reporting
Unified Reporting Overview

Unified Reports is an additional Reporter component that further expands its Web-based reporting system. Working in conjunction with specific 
OpenView products/agents—OpenView Internet Services, the Smart Plug-ins for Databases, and the Network Diagnosis Add-On 
Module—Unified Reports captures and summarizes the data into a unique overview. With this new, consolidated view of the data, you can generate 
reports on Web servers, application servers, and database servers, provided those systems are accessible to OpenView data collectors/agents. The 
following areas of your distributed environment are accessed as shown in the diagram below:

 IMPORTANT: Please do not attempt to run multiple copies of Reporter as unexpected results occur.

Unified Reports Configuration

Prerequisite: To successfully generate reports using Unified Reports, Reporter requires the following HP OpenView products/components be 
installed and running:

Required 
Products/

Components Description/Function Minimum Version

Installation Location
Reporter 
system

Web Server 
System

Application 
Server system

Database Server 
System

OpenView
Reporter

OpenView data 
gathering/report 
generating

A.03.6 X - - -

OpenView Internet 
Services 

Probe deployment for 
Web performance 
monitoring

A.04.00
or A.03.50 X X - -

Database SPI:
SPI for Oracle
    or
SPI for
MS SQL Server

Monitors Oracle or SQL 
Server databases.

A.03.51 or
higher -   -   - X



Network Diagnosis 
Add-On Module
(NDAOM)1

Monitors the 
performance of the 
network path between 
specified nodes.  An 
add-on module to the  
Problem Diagnosis 
product that allows 
integration into 
OpenView Operations 
(OVO)

A.01.50 - X X X

Problem Diagnosis Prerequisite for NDAOM A.01.00 -   - - -

OpenView Operations 
performance 
subagent (Coda)
or
OpenView 
Performance Agent 
(MeasureWare 
Agent)

Monitors operating 
system performance 
metrics and 
collects/logs data from  
the Database SPIs and 
NDAOM metrics.

All - X X  X

OpenView Operations 
for UNIX

Used for configuring 
some of the above 
required components.

Version 7, or 8 - - - -

1 Problem Diagnosis must be installed prior to NDAOM installation.

NOTE:  The following databases are supported by Unified Reports:
      -SQL Server
      -MSDE
      -Oracle

Access databases are not supported by Unified Reports. To use Unified Reports, you must migrate data from Access to a supported database, then 
configure Unified Reports.

Unified Reports Configuration: Step-by-step

Complete the tasks below to configure and use Unified Reporting. Click the task below to jump to the specific instructions. 

●     Task 1 Configure Service Targets in OpenView Internet Services 
●     Task 2 Install the Unified Reports Package in Reporter 
●     Task 3 Add Web server systems to Reporter discovered systems 
●     Task 4 Confirm a successful configuration
●     Task 5 Assign reports to systems 
●     Task 6 Set up NDAOM configuration 
●     Task 7 Verify DB-SPI configuration 
●     Task 8 Review types and descriptions of Unified Reports

           Group Reports
           System Reports
           Report Descriptions

●     Task 9 View Unified Reports 

Task 1  Configure Service Targets in OpenView Internet Services

Prerequisites: 

■     OpenView Reporter A.03 installed/configured
■     OpenView Internet Services installed/configured 

Complete the following tasks to set up Unified Reports for OpenView Internet Services. 

1.  Open the OpenView Internet Services main window by selecting: Start>Programs>HP OpenView>
OpenView Internet Services>Configuration Manager. 
(The Internet Services Configuration  Manager window appears as illustrated below.)



2.  In the left pane under a customer you have defined, highlight the Service Groups folder.
and select File>New>Service Group
or
Right-click the Service Groups folder and select New>Service Group.
(The Create Service Group dialog box appears as illustrated below.)

3.  In the Create Service Type dialog, enter the name of the service group in the Service Group Name box.  
4.  In the Create Service Group dialog box, click the down-arrow in the Monitored Service box and select the type of service you want to monitor 

from the drop-down list and click OK.

In the left pane of the OVIS Configuration Manager window, the following folders appear under the Service Group you just created.

■     Service Targets
■     Service Objectives
■     Probe Locations

And in the right pane of the OVIS Configuration Manager window, the following tabs appear: 

■     Service Groups
■     Service Targets
■     Objectives
■     Probes



Editing the Service Targets Folder 

1.  Right-click Service Targets and select New Service Targets.  
2.  Complete the field information.
3.  Click OK when you are finished.

Editing the Service Objectives Folder (Optional)

1.  Right-click Service Objectives and select New Objective.  
2.  Complete the field information.
3.  Click OK when you are finished.

Editing the Probe Locations Folder

1.  Right click Probe Locations and select New Probe Location.  
2.  Complete the field information (use the default settings for Local Probe field).
3.  Click OK when you are finished.

 NOTE: The information you provide is displayed in tabs located in the right pane of the Internet Services Configuration Manager window.

For more information on OpenView Internet Services, refer to the OpenView Internet Services Active Monitoring Concepts 
Guide.

Task 2  Install the Unified Reports Package in Reporter

Configure Reporter 

1.  Open the Reporter main window by selecting Start>Programs>HP OpenView>
Reporter>Reporter.
(The Report window appears as illustrated below.)



 NOTE: If you require additional information on using Reporter, see the Reporter Concepts Guide. 

2.  From the File menu, select Configure>Report Packages. The Reporter Packages window appears as illustrated in the figure below.

2.  In the left pane of the Available Packages window, select Unified Reporter for Hosting IDCs and click the right arrow.
3.  Click OK.



Task 3  Add Web server systems to Reporter (AppServer, DBServer, or WebServer groups)

In the Web Services monitoring task, you are asked to provide information on the Web site(s) you want to monitor.  Before Reporter can access a 
system and gather metrics, the system must be discovered. In this task, if necessary, you set up  system to be discovered. Once discovered, the 
system can be added to the appropriate Unified Reports node group.

In the procedures below, you need to identify those physical systems responsible for Web service and add the system to the appropriate node group. 
You must have each physical system available as a discovered system in order for Reporter to generate reports on it.

Discover/Assign Systems to Appropriate Server Groups

When you added the Unified Reports package to Reporter, you not only added reports but the system groups to which you want to assign those 
reports. They are: AppServer, DBServer, and WebServer. In the procedure below, as appropriate, add application server, database server, and 
Web server systems to those groups. But first, the systems must be discovered by Reporter. If a system is among those discovered by Reporter, you 
can skip step #1 and go to steps #2-4, where you add the discovered system(s) to the system group: 

1.  In the Reporter main window in the Discovery Area identify each system (providing Web services) that you want to monitor and add it to the 
Discovered Area (please see the Reporter online Help if you need instructions for how to discover systems both inside and outside the 
Reporter system local domain).

2.  After all Web service systems have been discovered, expand the All group under the Discovered Systems area
(Reporter shows the current discovered systems in the left pane and the groups in the right pane).

3.  In the left pane, click the group you want to assign a system to.
4.  In the All group of systems in the left pane, select system(s) you want to assign to the group in the right pane and drag and drop each system 

from left to right.  (Use the Shift or Ctrl keys to select multiple systems.)
5.  Using drag and drop from left to right, add application server systems to the

AppServer group.

Repeat the steps for all database servers; discovering systems as necessary and adding them to the
DBServer group.

Repeat the steps for the all Web servers; discovering systems as necessary and adding them to the WebServer group.

Add the Service Group (created in OpenView Internet Services)

Now you must add an additional group to match the name you typed in Task 1, Step 3: 

1.  Highlight Discovered Systems and right-click it.
2.  From the submenu, Select Add Group.   The Add Group Name dialog box appears as illustrated below.

3.  Type the name of your group in the box.  The group name you typed appears in the Groups pane.

4.  Add all Application, Database, and Web Server nodes you previously created in Adding Systems to Appropriate Server Groups to the newly 
created group.

How to Delete a Group 

1.  Select Discovered Systems and right-click it.
2.  In the right-pane of the window, select the group you want to Delete.
3.  Right-click and select Delete.

Task 4 Confirm a Successful Configuration

To confirm that the configuration was successful, verify that you can view the information below: 

1.  From the Reporter window, select Metric Lists. The following metric lists should be displayed as illustrated in the graphic below:
■     CDR_GLOBAL
■     CDR_MSSQL_METRICS
■     CDR_MSSQLOSM
■     CDR_NDAOM



■     CDR_ORADB_METRICS
■     CDR_ORAOSM_METRICS

2.  From the Reporter window tree hierarchy, select Reports>Unified Report.   The following reports should appear in the right pane of the 
Reporter window: 

■     Webserver Application Stack - Month, Week, and Day
■     Webserver Farm - Month, Week, and Day
■     Webserver Transaction Chain - Month, Week, and Day
■     Web Service Configuration - Month, Week, and Day

3.  From the Reporter window, select Discovered Systems.  The following node groups have been created and will appear in the right pane 
of the Reporter window:

■     AppServer (for all application servers)
■     DBServer (for all database servers)
■     WebServer (for all HTTP servers)



4.  Highlight AppServer and expand it by clicking on the App Server icon. In the right pane beneath Systems, all AppServer nodes you 
added should appear.

5.  Add additional nodes by selecting the node in the left pane and dragging it to the right pane.
6.  Highlight DBServer and repeat Step 5 to add Database Server nodes.
7.  Highlight WebServer and repeat Step 5 to add Web Servers nodes.

 NOTE: All identified physical systems must be added to Discovery Systems prior to creating node groups and after a successful installation 
has been completed.

Task 5  Assign Reports to System Groups  or Single Systems

Assign Group Reports

Group reports provide information for the system group you want to monitor. Complete the following steps to add Group reports to Unified 
Reports.

1.  Select the Group reports you want to add to the the newly created node.  Use the drag and drop functionality to add the desired group 
reports of the Unified Reports to the AppServer, DBServer, or WebServer group.

2.  Press F5 to refresh the screen.

 NOTE:  The group reports are identified with a blue icon.

Assign System Reports

System reports provide information on the single system you have chosen to monitor.   The system can include a Web  server, application 
server, or database server you have chosen to monitor. Complete the following steps to add System Reports to Unified Reports.

1.  Select the System reports you want to add to the newly created AppServer, DBServer, or WebServer group.  Use drag and drop to add 
the System reports of the Unified Reports to the single system in the WebServer group.

2.  Click F5 to refresh the screen.
3.  Repeat Step 1-2 for all systems in the node group.

 NOTE:  The system reports are identified with a green icon. 

Report Template Descriptions

The table below lists provides detailed information on each report template:

Report Template Timeframe Group/System
Template Description

s_webappstack_d.rpt Yesterday System
Correlation of top metrics for a single system, 
represented in multiple graphs.s_webappstack_w.rpt Week System

s_webappstack_m.rpt Last 31 days System

g_webtrans_d.rpt Yesterday Group
Correlation of metrics across servers along one 
transaction chain.g_webtrans_w.rpt Week Group

g_webtrans_m.rpt Last 31 days Group

g_websvrfarm_d.rpt Yesterday Group
Correlation of the same metric across several of the 
same classification of servers.g_websvrfarm_w.rpt Week Group

g_websvrfarm_m.rpt Last 31 days Group

g_config_d.rpt Yesterday Group Displays the used available and hardware platforms 
running the applications and the utilization of the 
CPUs on separate hardware platforms.

g_config_w.rpt Week Group

g_config_m.rpt Last 31 days Group

Task 7   Configure NDAOM

The section provides a description of the NDAOM commands that must be run in order to integrate with Unified Reports. Please see the HP 
OpenView Network Diagnosis Add-On Module Administrator's Guide, included with NDAOM, for full details on installing/configuring 
NDAOM.

Upon completion of these instructions you will be able to monitor the performance of the path between a Web server, application server, and a 



database server on the managed node.

Configuring NDAOM  information into the database

1.  From the OpenView Operation Server directory /opt/OV/ndaom/bin enter the full command below:
./ovnwlinkmon -add
     root=america
     parent=Application_Server
     interval=10m
     source=parsley.london.mycom.com
     target=sundev1.london.mycom.com
     label=parsley_to_sundev1

 NOTE: The NDAOM Field Descriptions below offer additional information. 

To monitor the path, deploy it by entering the command line below:
ovnwlinkmon -deploy -NoGUI

(The path will not be monitored until it is deployed.) 

2.  Configure all available network connections between source servers and target servers in monitored environments. 

NDAOM Field Descriptions

Field Description

<RootServiceID> The Service Object ID where infrastructure information is inserted.  The infrastructure 
information is inserted as sub-service.  If the NoNewObject field is selected, the 
RootServiceID is used to determine which service object the network connection belongs 
to.  
The information in this field is used for delete operations.

<ParentServiceID>
The Service ID of the service object (which is the parent of all new service objects).  If 
the NoNewObject field is selected, this field receives messages for monitored network 
connections. The Parent Service ID is located either in root service or the sub-tree of the 
root service.

<Label>
Service label of the newly created service object parameter. If not specified, the label is 
the same as the Service ID.  Use this parameter when NoNewObject is not specified. This 
field entry is optional.

<PollingInterval> Defines the unit of measures for how often the network connections are polled. The 
default is minutes.

<SourceNode> The IP address or node name at the beginning of a path (for example,  AppServer).

<TargetNode> The IP address or node name at the end of a path (for example, DBServer).

Task 8   Configure the Database SPI (as necessary)

To monitor database performance/availability in a Web service environment, you can use your currently installed/configured HP OpenView 
Smart Plug-in for Databases (specifically Oracle or Microsoft SQL Server). As part of the Database SPI configuration, you should have 
reporting and graphing enabled for each managed node.

For full details on installing and configuring the Database SPI, please see: 

❍     the HP OpenView Smart Plug-in for Databases User's Guide (for A.04.x or earlier)
or 

❍     the HP OpenView Smart Plug-in for Databases Configuration Guide (for A.05 or later). 

In both earlier and later releases of the product the manuals covering installation/configuration and reports are the same. Please see Chapter 
2 for installation and configuration, including enabling reports; see Chapter 5 for details on Database SPI reports. The guide covers four 
database types, but for Unified Reports only those areas referencing Oracle and/or Microsoft SQL Server are relevant.

Task 9  Review Unified Reports content

Unified Reports offers the following three group report packages. Each report package includes various graphs that display metrics, system 
availability, etc.



Group Reports 

❍     Server Farm
❍     Transaction Chain
❍     Configuration

(1) Server Farm Reports Package (Group)

Application Server graphs display the following:

■     Operating System - CPU utilization for all applications servers. 
■     Network Response Time  - Network response time for all application servers.
■     Availability - System availability. 

Web Server graphs display the following:

■     Operating System  - CPU utilization for all applications servers. 
■     Network Response Time - Network response time for all web servers by source.
■     Network Response Time for Group - Network response time of web servers (i.e., application, database).
■     Application Performance - Response time for the web servers.
■     Availability - Web server availability.

Database Server graphs display the following:

■     Operating System  - CPU utilization for all database servers.
■     Network Response Time by Source - Network response time for all database servers.
■     Network Response Time for Group  - Network response time from database server to other servers (i.e., application, webserver).
■     Application Performance Graph - Commit rate for the database servers.
■     Availability  - Database server availability.

(2) Transaction Chain Reports Package

The Transaction Chain group consists of the following graphs:

The Operating System CPU Utilization graphs display the following: 

■     CPU utilization for the transaction servers, (that is; database, application, and web servers).  The down time for the systems are 
displayed in the graph.

The Network Response Time (ms) by Source graph displays the following: 

■     The Network time of the transaction servers of the database and web servers.

The Application Performance graph displays the following: 

■     Web server response time
■     Web server throughput in KB
■     Database transaction commit rate
■     Downtime

The Availability Graph displays the following: 

■     Availability of the database server, web server, and the entire system of the transaction displayed as a percentage.

(3) Configuration Reports Package

The Configuration group consists of the following graphs:

The Operating System graph displays the following: 

■     Quantity of running operating systems

The Server Type graph displays the following: 
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■     Quantity of server types

The CPU Utilization per Operating System graph displays the following: 

■     CPU utilization on various operating systems

Unified reporting also includes the following single system report package.  This report package contains, like the group packages, various 
graphs that display metrics, system availability, etc. 

System Reports 

❍     Application Stack

Application Stack Reports Package

The Application Group group consists of the following graphs:

The Overview for Systems graph displays the following averages:

■     Cache hit ratio
■     Commit rate
■     CPU utilization

The Database for system graph displays the following averages: 

■     Commit rate
■     Cache hit ratio
■     Number of users 

The Web Server Performance for System graph displays
the following averages:

■     Throughput (Kb)
■     Server time
■     Transfer time
■     DNS_time
■     Connect time

The Operating System for Systems graph displays the following averages: 

■     Run queue
■     CPU utilization
■     Memory utilization
■     Normal average net packet rate
■     Normal average disk physical IO rate

The Availability graph displays the following: 

■     Database
■     Web server
■     System

Unified Reports table names and report descriptions

The table below identifies the components, fields, and descriptions identified with the Unified Reporting reports.

Report Used Views Description

g_websvrfarm_d.rpt
g_websvrfarm_w.rpt
g_websvrfarm_m.rpt

VUR_GLOBAL, VUR_GROUPS, 
VUR_DOWNTIME, 
VUR_NDAOM_AVG_UPTIME, 
VUR_APPL_WEBFARM, 
VUR_AVAIL_WEBFARM

Correlating the same metrics across 
several servers of the same type (for 
example, CPU utilization across 
several web servers) and determining 
which server is 
underutilized/overloaded.
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g_webtrans_d.rpt
g_webtrans_w.rpt
g_webtrans_m.rpt

VUR_GLOBAL, VUR_GROUPS,  
VUR_NDAOM_AVG_UPTIME, 
VUR_APPL_WEBFARM, 
VUR_AVAIL_WEBFARM

Correlating metrics across servers 
along one transaction chain, 
potentially displaying a bottleneck 
and providing additional information 
for transaction breakdown.

g_webappstack_d.rpt
g_webappstack_w.rpt
g_webappstack_m.rpt

VUR_GROUPS, 
VUR_APPLSTACK_WEBFARM, 
VUR_GLOBAL, VUR_AVAIL_WEBFARM, 
VUR_DOWNTIME

Correlating top metrics for a single 
system represented in several graphs 
(e.g. OS metrics for a system are 
correlated into a single graph, 
database performance metrics for the 
system are correlated into a single 
graph).

g_config_d.rpt
g_config_w.rpt
g_config_m.rpt

VUR_SYSCONFIG

displays the used and available 
hardware platforms running the 
applications CPU utilization on the 
separate hardware platforms. 

Unified Reports View Designs

The table below identifies the components, fields, and descriptions identified with the Unified Reporting views

Table Name Reports 
(used by) Views (used by) Referenced 

Tables/Views Fields

VUR_APPL_WEBFARM Websvr farm, 
Webtrans

 VUR_DBMetrics, 
VUR_VP_IS

System name, 
Date/Time, Service 
name, Response 
time, VPIS 
availability, VPIS 
group count, IS 
transfer 
throughput, Probe 
name, Commit 
rate, Buffer cache 
hit ratio, User logon 
count

VUR_APPLSTACK
_WEBFARM

Webappstack  VUR_DBMetrics, 
VUR_VP_IS_DETAIL, 
VUR_GLOBAL

System name, 
Date/Time, Service 
name, Response 
time, VPIS 
availability, VPIS 
group count, VPIS 
transfer 
throughput, Probe 
name, -DNS Tim, 
Connect Time, 
Server Time, 
Transfer Time, 
Commit rate, Buffer 
cache hit ratio, 
User logon count, 
CPU Utilization

VUR_AVAIL_WEBFARM
Websvrfarm, 
Webtrans, 
Webappstack

 
VUR_GROUPS, 
VUR_VP_IS, DOWNTIME, 
VUR_DB_UPTIME

Group name, 
Subgroups, System 
name, Time bucket, 
Sysdowntime, 
SysShifttime, 
DbUpMin, 
Servicename, 
ISDBServer, OVIS 
(VPIS) availability, 
OVIS (VPIS) group 
count

VUR_DB_UPTIME  VUR_AVAIL_WEBFARM CDR_ORAOSM_METRICS, 
CDR_MSSQL_METRICS

Time bucket, 
DbUpMin, 
Systemname

VUR_DBMetrics  
VUR_APPLSTACK
    _WEBFARM, 
VUR_APPLWEBFARM

CDR_ORAB_METRICS, 
CDR_MSSQL_METRICS

System name, 
Date/time, Commit 
rate, Buffer cache 
hit ratio, User logon 
count



VUR_DOWNTIME Websvrfarm, 
Webappstack V_AVAIL_WEBFARM DOWNTIME

System name, 
Date/time, Shift 
name, Shift time, 
Downtime

VUR_GLOBAL
Websvrfarm, 
Webtrans, 
Webappstack

VUR_APPLSTACK
   _WEBFARM CDR_GLOBAL

System name, 
Time bucket, Run 
queue, CPU total 
util, System CPU 
utili ratio, User CPU 
utili ratio, FS Space 
Util Peak, Disk Phys 
IO rate, Memory 
util, Net packet 
rate Interval, Swap 
space util, empty

VUR_GROUPS
Websvrfarm, 
Webtrans, 
Webappstack

VUR_AVAIL_WEBFARM

SYSTEMS GROUPS, 
SUBGROUPS, 
IOPS_SERVICES, 
IOPS_SERVICE-TARGETS

Group name, 
Subgroup, 
Systemname, 
System ID

VUR_NDAOM_AVG_UPTIME Websvrfarm, 
Webtrans  CDR_NDAOM, GROUPS

Systemname, Time 
bucket, ndaom 
destination, 
NDAOM Path ID, 
NDAOM Hop Num, 
NDAOM mean, MM 
Systemname, Num, 
Dest group

VUR_SYSCONFIG Config  SYSTEMS

System ID, 
Systemname, 
OSname, 
OSrelease, 
OSversion, Machine 
type, Exclude

VUR_VP_IS  VUR_AVAIL_WEBFARM, 
VUR_APPL_WEBFARM

IOPS_PROBE_DATA, 
IOPS_SERVICES, 
IOPS_SERVICE_TARGETS

Systemname, Time 
bucket, Service 
name, Response 
time availability, 
Group count, 
Transfer, 
hroughput, Host, 
Probe name, 
System ID

VUR_VP_IS_DETAIL  VUR_APPLSTACK
   _WEBFARM

IOPS_PROBE_DATA, 
IOPS_SERVICES, 
IOPS_SERVICE_TARGETS

Systemname, Time 
bucket, Service 
name, Response 
time availability, 
Group count, 
Transfer 
throughput, Probe 
name, DNS time, 
Connect time, 
Server time, 
Transfer time

Task 9  View Unified Reports

Reports should be ready the next day as Reporter generates new reports with new data every 24 hours. When you are 
ready, you can view reports by following these instructions. The Unified Reports should also appear on Reporter's cover 
Web page with all other reports. 

Viewing Group Reports

1.  Select the group for the reports you want to view.
2.  From the Action menu select Show>Reports

or
Click the Show Reports toolbar button.



 NOTE: To toggle from the Group to System reports view press Refresh (F5) to access the appropriate report group.

Viewing System Reports

1.  Select the system for the reports you want to view.
2.  From the Action menu select Show > Reports

or
Click the  Show Reports toolbar button.

 



Running Reporter and OVOW 7.5 on 
Separate Systems 

It is possible to integrate Reporter with remote OVO W 7.5 to collect managed node 
information and generate OVO W reports. 

 NOTE: This configuration is not supported with OVO W 7.2 or older versions of the OVO W.

Follow the steps mentioned in the following sections to configure the OVO W and 
Reporter system.

Configuring the OVO W 7.5 System

1.  Select the Reporter service using the Start menu, select Settings > Control Panel > 
Administrative tools > Services applet.

2.  From the Startup type drop-down list box, select Manual.



 

3.  Click Stop to stop the Reporter Service. Refer to section "How to add a user to user group" to add 
a user to a user group on OVO W system. 

Configuring the Reporter System 

1.  Install OVO W package from the OVO W CD.
2.  From the Start menu, select Settings > Control Panel >Administrative Tools >Data sources 

(ODBC).
3.  Click Add in the ODBC Data Source Administrator dialog box to add Openview DSN pointing to 

OVOW database.



1.  Select Reporter GUI > File > Configure > Databases and create a new database 
OVMSDB using openview DSN added in step 2.



4.  Select Reporter GUI > File > Configure > Options and specify the OVOW Settings parameters. 
5.  Enter the OVOW system name as OVOW Management Server, a user name as Domain \User 

Name (with or without domain) and the password as Password in the OVOW Settings. 



 

6.  Select Reporter GUI > Left Pane > Schedule and then right click and select Add Schedule to 
add Discovery_Neutron to reporter scheduler.

 IMPORTANT: The User Name entered in the OVOW Settings panel must be part of the 
Administrators, HP-OVE-ADMINS, or HP-OVE-OPERATORS user group on the OVOW management 
server System. 

Adding a user to a user group on OVOW system

1.  From the Start menu, select Settings > Control Panel > Administrative tools > Computer 
Management. 

2.  Select System Tools > Local Users and Groups > Groups from the left pane. 



3.  Right click on a group in the right pane, in which you want to add a user and follow the procedure 
to add a user.





Installation in Microsoft Cluster Server 
(MSCS) 
PREREQUISITES

The following are the prerequisites for installing Reporter in MSCS:

●     Windows Server 2003 Enterprise Edition or Datacenter Edition.
●     Install and Configure Microsoft cluster server before installing Reporter (Refer to the URL: 

http://www.microsoft.com/resources/documentation/WindowsServ/2003/datacenter/proddocs/en-
us/cluad_pr_50.asp to create cluster server).

●     Install and cluster SQL Server 2000 Enterprise Edition with Service Pack 3a or later on cluster 
nodes.

●     Configure the Reporter ODBC DSN before installing Reporter.
●     A MSCS cluster resource group containing a Physical Disk, IP, and Network Name (Virtual Server) 

resource must be running.
●     Logged in user must have administrative permissions to access or modify the cluster.

Installing and configuring Reporter 

Follow the procedures in the sections below to install Reporter in MSCS. 

Installing SQL Server 2000 SP 3a

Refer to the URL http://msdn.microsoft.com/library/default.asp?url=/library/en-
us/adminsql/ad_clustering_2icn.asp for Installing and Administering SQL Server in 
Microsoft cluster.

Creating the Reporter Database

Follow the steps mentioned in Task 3 Configure the Reporter Database on SQL Server 
2000 of the Install and Configure MS SQL Server Software section of the Installation and 
Special Configurations Guide, to create a reporter database.

 NOTE: The Data files and Transaction log must be stored to the shared disk for high availability.

http://www.microsoft.com/resources/documentation/WindowsServ/2003/datacenter/proddocs/en-us/cluad_pr_50.asp%20
http://www.microsoft.com/resources/documentation/WindowsServ/2003/datacenter/proddocs/en-us/cluad_pr_50.asp%20
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/adminsql/ad_clustering_2icn.asp
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/adminsql/ad_clustering_2icn.asp


Establishing an ODBC Connection to the Database

Follow the steps mentioned in Task 3 Establish the ODBC Connection of the Install and 
Configure SQL Client Software section in the Installation and Special Configurations 
Guide to create an ODBC connection to the Reporter database.

 NOTE: Create and Configure Reporter ODBC DSN on each node you will be installing Reporter.

Adding a Group or IP Address or a Network Name 

1.  From the Start menu, select Programs > Administrative Tools > Cluster administrator 
(Microsoft Cluster Administrator Tool) to create a resource group or IP Address and a Virtual 
Server(Network Name).

2.  Right click on Groups in the left pane, point to New, and click Group.

3.  Add a new group, for example, OvReporter and press the Next button. The User can choose any 
name for group.



4.  Add Preferred owners from the list of Available nodes. 

5.  Click Finish to add OvReporter group to the cluster.
6.  Right click on OvReporter, point to New, and then click Resource.



7.  Select Resource Type as IP Address and Group as OvReporter.
8.  Enter Name as IP Address. The User can choose any name for IP Address.



9.  Click Next and add preferred owners from the list of Available nodes. 



10.  Do not add any dependencies and click Next.

 

11.  Enter Address and Subnet mask. Click Finish to add the IP Address resource to the OvReporter 
group.



 

12.  Right click on OvReporter group, point to New, and click on Resource

13.  Select Resource Type as Network Name and Group as OvReporter. Enter the name for the 
network name and click Next. The User can choose any name for Network Name.



 

14.  Add Preferred owners from the list of Available nodes and click Next.

 

15.  Select IP Address as the Resource Dependencies and click Next.



 

16.  Enter your choice as the Virtual Server name. Click Finish to add the network name to the 
OvReporter group. 



 

Installing Reporter on an active node

1.  From the Start menu, select Programs > Administrative Tools > Cluster administrator 
(Microsoft Cluster Administrator Tool) to create a resource group containing Virtual server, IP 
address, and shared disk cluster resources. 

 NOTE: The user can skip the creation of a resource group containing the Virtual server, IP 
address, and the shared disk cluster resources if these have already been configured in MSCS. 
Refer to section How to add resource group / IP Address and Virtual Server to create resource 
group, Virtual server, IP address and shared disk cluster resources. 

 IMPORTANT: The resource group containing Physical Disk, IP and Network Name resource 
must be running on the current node.

2.  Insert the Reporter Installation CD into the CD-ROM drive on the node that has active ownership of 
the virtual server. 

3.  Select Install Reporter and follow the instructions to install the Reporter.

 NOTE: The Installation Selection dialog box shown below is not displayed if the current user 
does not have administrative rights or if the system is not clustered.



4.  Select Cluster for the Cluster installation of Reporter.
5.  Click Next to display the dialog box showing the cluster details.



6.  Enter the existing Virtual Server name and IP address as you specified in step 1.
7.  Select a valid shared folder and make sure to select a local drive for the program files and a 

shared drive for the shared data files. 
For example, if S is your shared drive you must select: 
Install hp OpenView reporter to: C:\Program Files\HP OpenView\ 
Install hp OpenView reporter local Data to: C:\Program Files\HP OpenView\Data 
Install hp OpenView reporter Shared Data to: S:\MyShare\



Important: Make sure you select the same Program files, Shared Data and Data directory when 
you install Reporter on other nodes in the cluster.

8.  Select the Manual- Start Reporter service manually check box.



9.  Click Next and follow the instructions to install the Reporter

Installing OvReporter on Additional Node

1.  Use Microsoft Cluster Administrator Tool and select OvReporter Service. Right-click and select 
Take Offline option to move the resource status to offline.

2.  Do not move the OVReporter Group (containing the OvReporter Service) to the subsequent node.



Installing OvReporter on Current Node

1.  Follow the instructions from the previous section Installing OvReporter on an active node to install 
Reporter on the current node.

2.  Repeat steps 1 and 2 to install Reporter on the remaining nodes within the cluster.

Uninstalling Reporter

1.  Last installed node should be the first node during uninstallation. Make sure that the OvReporter 
Service is offline before uninstalling Reporter. (Refer Step 1 of the previous section Installing 
OvReporter on additional nodes to turn the OvReporter service offline 

2.  Uninstall Reporter from the active node that manages the OvReporter Service resource. 

 NOTE: The data on the shared drive is removed only if the current node is the last node.
3.  Move the resource group (containing the resource, OvReporter Service) to the next Reporter node 

in MSCS using the Microsoft Cluster Administrator tool.
4.  Repeat steps 2 and 3 till Reporter is uninstalled from all nodes.

Constraints

1.  The Clustered Reporter is not supported with other non-Clustered OpenView products.
2.  No OpenView performance products (for example, OVOW or OVIS) must be installed on the same 



system as long as they do not support running with a clustered Reporter installation.
3.  Only an active/passive configuration is supported. This means that the Reporter can be installed 

on all cluster nodes, but can run only once at a time. No load balancing is possible and supported. 
Only one running Reporter service per cluster is allowed.

4.  The upgrades from Reporter 3.1 or 3.5 to Clustered Reporter are not possible and are also not 
supported.
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Documentation Set

●     Concepts Guide
Contains information, both basic and advanced, on Reporter features, interface, use, 
and daily operation.

●     Installation and Special Configurations Guide
Contains an overview of the installation process and detailed instruction sets for 
configuring alternative database software to store and retrieve Reporter data. Also 
included are the setting requirements for these special configurations

●     Release Notes
Contains new feature updates added to the current version as well as requirements 
for installation and use.

file:///D|/reporter/reporter3.6/reporter/Install_Config/concepts_guide.htm
file:///D|/reporter/reporter3.6/reporter/Install_Config/..\..\..\releasenotes\reporterreleasenotes.htm
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