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���
ding Astra LoadTest Analysis

The Analysis provides graphs and reports to help you analyze the per
of your system. These graphs and reports summarize the scenario ex

This chapter describes:

• Creating Analysis Sessions

• Starting the Analysis

• Collating Execution Results

• Analysis Graphs

• Applying a Filter to a Graph

• Grouping and Sorting Results

• Working with Analysis Graphs

• Viewing the Legend

• Viewing the Data as a Spreadsheet and as Raw Data

• Configuring Display Options

• Setting General and Database Options
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ut the Analysis

During scenario execution, Vusers generate result data as they perfor
transactions. To monitor the scenario performance during test executio
Online Monitoring tools. To view a summary of the results after test exec
can use one or more of the following tools: 

• The Vuser output file, output.txt, contains a full trace of the scena
each Vuser. This file is located in the scenario results directory. (W
run a Vuser script in standalone mode, this file is placed in the Vus
directory.) The information is also available in the Vuser log.

• The Controller Output window displays information about the sce
If your scenario run fails, look for debug information in this window.
information, see the Astra LoadTest Controller User’s Guide.

• The Analysis graphs help you determine system performance and
information about transactions and Vusers. You can compare multip
by combining results from several scenarios or merging several gra
one. 

• The Graph Data and Raw Data views display the actual data used
generate the graph in a spreadsheet format. You can copy this data
external spreadsheet applications for further processing.

• The Report utilities enable you to view a Summary report and sum
HTML report for each graph. 
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ating Analysis Sessions

When you run a scenario, data is stored in a result file with an .lrr exten
Analysis is the utility that processes the gathered result information an
generates graphs and reports.

When you work with the Analysis utility, you work within a session. An
session contains at least one set of scenario results (lrr file). The Analy
the display information and layout settings for the active graphs into a f
.lra extension. 

rting the Analysis

You can open the Analysis through the Astra LoadTest  program group
independent application, or directly from the Controller. To open the new
utility as an independent application, choose Tools > Analysis from th
LoadTest Program Group. 

To open the Analysis directly from the Controller, select Results > Ana
Results. This option is only available after running a scenario. The Ana
the latest result file from the current scenario, and opens a new sessio
these results. You can also instruct the Controller to automatically ope
Analysis after it completes scenario execution by selecting Auto Load 
To do this, select Results > Auto Load Analysis.
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When creating a new session, the Analysis prompts you for the result 
extension) that you wish to include in the session. To open an existing
you specify an Analysis Session file (.lra extension).  

lating Execution Results

When you run a scenario, by default all Vuser information is stored local
Vuser host. After scenario execution the results are automatically colla
consolidated—results from all of the hosts are transferred to the results
You disable automatic collation by choosing Results > Auto Collate R
from the Controller window, to clear the check mark adjacent to the op
manually collate results, choose Results > Collate Results. If your re
not been collated, the Analysis will automatically collate the results be
generating the analysis data. For more information about collating res
Astra LoadTest Controller User’s Guide.
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lysis Graphs

The Analysis graphs are divided into the following categories:

• Transactions 

• Vusers 

• Rendezvous

• System Resources

• Web Server Resources

• Web Application Server Resources

• Network Monitor

Transaction graphs and reports provide information about transaction
performance and response time. For more information, see Chapter 2
Transaction Graphs. 

Vuser graphs display information about Vuser states and other Vuser 
For more information, see Chapter 3, Vuser and Rendezvous Graph

Rendezvous graphs show the behavior of Vusers that participated in 
rendezvous during the scenario. For more information, see Chapter 3, V
Rendezvous Graphs. 
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System Resource graphs show statistics relating to the system resou
were monitored during the scenario using the Online Monitor. This cate
includes graphs for SNMP monitoring. For more information, see Chap
Resource Graphs.  

Web Server Resource graphs provide information about the throughp
per second for Web Vusers. In addition, these graphs provide resourc
details for Netscape, IIS, and Apache Web servers. For more informat
Chapter 5, Web Resource Graphs. 

Web Application Server Resource graphs provide information about
resource usage for various Web application servers such as BroadVis
ColdFusion, SilverStream, ASP,  WebLogic, and WebSphere. For mor
information see Chapter 5, Web Resource Graphs. 

Network Monitor graphs provide information about the network delays
information, see Chapter 6, Network Graphs.  

Cross Result graphs let you compare the results from several scenario
example, this feature can be useful for benchmarking hardware to deter
a superior system will improve performance. For more information, se
Chapter 7, Cross Result and Merged Graphs. 
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lying a Filter to a Graph

When viewing graphs in an Analysis session, you can specify to displa
desired information. By default, ten transactions are displayed for the 
length of the scenario. You can filter a graph to show fewer transaction
specific segment of the scenario. For example you can display four tra
beginning from five minutes into the scenario and ending three minutes 
end of the scenario. 

The filter conditions differ for each type of graph. The filter conditions als
on your scenario. For example, if you only had one group or one host m
your scenario, the Group Name and Host Name filter conditions do not 
following table lists the available filter conditions for each graph type. 

Graph Filter Conditions

Transactions
Transaction Name, Transaction Response T
Scenario Elapsed Time, Host Name, Transa
End Status, Group Name, Vuser ID

Vusers 
Vuser End Status, Scenario Elapsed Time, H
Name, Group Name, Vuser ID, Vuser Status

Rendezvous
Number of Released Vusers, Scenario Elap
Time, Host Name, Group Name, Vuser ID

System Resources
Resource Name, Resource Value, Scenario 
Time, Host Name, Group Name, Vuser ID
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You can also activate global filter conditions that will apply to all graph
session. The available global filter conditions are a combination of the
conditions that apply to the individual graphs. 

Note that you can also filter merged graphs. The filter conditions for ea
are displayed on separate tabs. 

To set a filter condition for an individual graph:

 1 Select the graph you want to filter. Click on a graph tab or click on the 
name in the tree view. 

Web Server Resources
Resource Name, Resource Value, Scenario 
Time, Host Name, Group Name, Vuser ID

Web Application Server 
Resources

Application Name, Application Value, Scena
Elapsed Time, Host Name, Group Name, Vu

Network Monitor
Network Path Name, Network Path Delay, S
Elapsed Time, Host Name, Group Name, Vu

Graph Filter Conditions
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 2 Choose View > Set Filter/Group By. The Graph Settings dialog box o

 3 Click in the Criteria box for the condition you want to set. Select eithe
"<>" (does not equal) from the drop down list.

 4 Click in the Values box of the filter condition you want to set. Select a v
the drop down box. For several filter conditions, a new dialog box ope
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 5 For Transaction Response Time, the Set Dimension Information dialog
opens. You specify a start and end time (in minutes:seconds format) fo
transaction. The time is relative to the beginning of the scenario. 
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 6 For Scenario Elapsed Time, the Scenario Elapsed Time dialog box op
Specify the start and end time for the graph in minutes:seconds format
is relative to the start of the scenario.

 7 For Rendezvous graphs, while setting the Number of Released Vuse
condition, the Set Dimension Information dialog box opens. Specify a 
and maximum number of released Vusers. 

 8 For all graphs that measure resources (Web Server, Database Server
when you set the Resource Value condition, the Set Dimension Inform
dialog box opens displaying a full range of values for each resource. S
minimum and maximum value for the resource.   

 9 Click OK to accept the settings and close the Graph Settings dialog bo

To apply a global filter condition for all graphs displayed in the session
File > Set Global Filter or click the Set Global Filter button, and set th
filters. 
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uping and Sorting Results

When viewing a graph, you can group the data in several ways. All grap
grouped by the Vuser ID. Transactions graphs can be grouped by the Tr
End Status. The Vuser graphs can be grouped by the Scenario Elapse
Vuser End Status, Vuser Status and VuserID. 

You can also sort by more than one group—for example by Vuser ID a
Vuser status. The results are displayed in the order in which the groups
You can change the order in which things are grouped by rearranging th
following graph shows the Transaction Summary grouped according to 
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To sort the graph data according to groups: 

 1 Select the graph you want to sort. Click on a graph tab or click on the 
name in the tree view. 

 2 Choose View > Set Filter/Group By. The Graph Settings dialog open

 3 In the Available Groups box, select the group by which you want to s
results.

 4 Click the right-facing arrow to move your selection to the Selected Gro

 5 To change the order in which the results are grouped, select the group
to move and click the up or down arrow until the groups are in the desi

 6 To remove an existing grouping, select an item in the Selected Group
click the left-facing arrow to move it to the Available Groups box. 

 7 Click OK to close the dialog box. 
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orking with Analysis Graphs

The Analysis contains several utilities that allow you to view the data i
in the most effective way:

• Determining a Point’s Coordinates

• Performing a Drill Down

• Enlarging a Section of a Graph

• Changing the Granularity of the X-axis
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Determining a Point’s Coordinates
You can determine the coordinates and values at specific points in a gra
the cursor over the point you want to evaluate. The Analysis displays t
values and other grouping information. 
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Performing a Drill Down
The Analysis provides another filtering mechanism called drill down. D
lets you focus on a specific measurement within your graph. You selec
measurement within the graph and display it according to desired grou
available groupings are Vuser ID, Host, Group Name, Vuser Status, et
depending on the graph. For example, the Transaction Response Ti
Average graph shows one line per transaction. To determine the resp
for each host, you drill down on one transaction and sort it according to
graph displays a separate line for the transaction response time on ea

In the following example, the graph shows a line for each of the six tran
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In a drill down for the FAQ transaction per host, the graph displays the
time only for the FAQ transaction, one line per host. 

You can see from the graph that the response time was longer on one
you sort it by Vuser ID, each Vuser is represented by a separate line. 
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To drill down in a graph:

 1 Click on a line or bar within the graph. The Drill Down Options dialog b
listing all of the measurements in the graph.
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 2 Select a measurement for drill down.   

 3 From the Group By box, select a group by which to sort. 

 4 Click OK. The Analysis drills down and displays the new graph.

 5 To undo the last drill down settings, choose Undo Set Filter/Group By
right-click menu. 

 6 To perform additional drill downs, repeat steps 1 to 4. 

 7 To clear all filter and drill down settings, choose View > Clear Filter/G

Enlarging a Section of a Graph 
Graphs initially display data representing the entire duration of the sce
can enlarge any section of a graph to zoom-in on a specific period of the
run. For example, if a scenario ran for ten minutes, you can enlarge and
the scenario events that occurred between the second and fifth minute

To zoom in on a section of the graph:

 1 Click inside a graph.

 2 Move the mouse pointer to the beginning of the section you want to en
not over a line of the graph. 

 3 Hold down the left mouse button and draw a box around the section  t

 4 Release the left mouse button. The section is enlarged.

 5 To restore the original view, choose Undo Zoom In from the right-click
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Changing the Granularity of the X-axis
You can make the graphs easier to read and analyze by changing the g
(scale) of the x-axis. The maximum granularity is half of the graph’s tim
To ensure readability and clarity, the Analysis automatically adjusts the
granularity of graphs with ranges of 500 seconds or more.

To change the granularity of a graph:

 1 Click inside a graph.

 2 Select View > Set Granularity, or click the Set Granularity button. Th
Granularity dialog box opens.

 3 Enter a new granularity value in milliseconds, minutes, seconds, or ho

 4 Click OK.
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.

Granularity=1

Granularity=5

Granularity=10
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In the above example, the Hits per Second graph is displayed using d
granularities. The y-axis represents the average transaction response
within the granularity interval. For a granularity of 1, the y-axis shows t
average response time for each one second period of the scenario. Fo
granularity of 5, the y-axis shows the average response time for every
second period of the scenario

In the above graphs, the same scenario results are displayed in a gran
1, 5, and 10. The lower the granularity, the more detailed the results. For
using a low granularity as in the upper graph, you see the intervals wh
transactions were performed. It is useful to use a higher granularity to 
overall Vuser behavior throughout the scenario. 

By viewing the same graph with a higher granularity, you can easily se
overall transaction response time averaged 1 hit per second.
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wing the Legend

The Legend displays the color, scale, minimum, maximum, average, me
standard deviation of each measurement appearing in the graph.

The Legend shortcut menu (right-click) has the following additional fea

• Show/Hide: Displays or hides a measurement in the graph.

• Show only selected: Displays the highlighted measurement only.

• Show all: Displays all the available measurements in the graph.
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• Configure measurements: Opens the Measurement Options dialog b
which you can set the color and scale of the measurement you selecte

• Animate selected line: Displays the selected measurement as a flash

• Sort by [SELECTED] column: Sorts the measurements according to
selected column, in ascending or descending order.
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• Configure columns: Opens the Legend Columns Options dialog box
you can choose the columns you want to view, the width of each colum
way you want to sort the columns.
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wing the Data as a Spreadsheet and as Raw Data 

The Analysis allows you to view the data in a grid form in two ways:

• Spreadsheet: The graph values displayed in a grid.

• Raw Data: The actual raw data collected during the scenario.

Spreadsheet View
You can view the graph displayed by the Analysis in spreadsheet form
Graph Data tab below the graph, displays the data in a grid format. 

The first column displays the values of the x-axis. The following colum
the y-axis values for each transaction. 

If there are multiple values for the y-axis, as in the Transaction Perform
Summary graph (min, average, and max), all of the plotted values are d
If you filter out a transaction, it will not appear in the view. 
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The Spreadsheet shortcut menu (right-click) has the following additiona

• Copy: You can copy one or more columns to the clipboard in order to 
it/them into an external spreadsheet program. 

• Save As: You can save the spreadsheet data to an Excel file. Once yo
the data in Excel, you can generate your own customized graphs.

Raw Data View
You can view the actual raw data collected during test execution for th
graph. The Raw Data view is not available for all graphs.

Viewing the raw data can be especially useful for:

• determining specific details about a peak—for example which Vuser wa
the transaction that caused the peak value(s). 

• performing a complete export of unprocessed data for your own sprea
application. 
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To display a graph’s Raw Data view:

 1 Choose View > View Raw Data or click the Raw Data button. The Ra
dialog box opens. 

 2 Specify a time range—the entire graph (default) or a specific range of ti
click OK.

 3 Click the Raw Data tab below the graph. The Analysis displays the raw
grid directly below the active graph. 

 4 To show a different range, repeat the above procedure. 
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figuring Display Options

You can configure both standard and advanced display options for eac
The standard options let you select the type of graph and the time sett
advanced options allow you to modify the scale and format of each gra

Standard Display Options
The standard display options let you choose the type of graph to displ
point, bar, or pie graph. Not all options are available for all graphs. 

You can also indicate whether the graph should be displayed with a 3 dim
look. This applies primarily to bar and pie graphs. You can specify the p
the 3 dimensional graphs. This percentage indicates the thickness of t
pie chart.

   3-D %

15 %

95 %
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The standard display options also let you indicate how to plot the resul
time-based: relative to the beginning of the scenario (default), or abso
based on the system clock of the machine. 

To open the Display Options dialog box, choose View > Display Optio
the Display Options button. 

Choose a graph type, specify a 3 dimensional percent, and/or choose
option. Click Close to accept the settings and close the dialog box.
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Advanced Display Options
The Advanced options let you configure the look and feel of your graph
its title and the format of the data. To set the Advanced options, you m
open the Display Options dialog. Choose View > Display Options or 
Display Options button. To access the Advanced options, click Advan
Editing MainChart dialog box opens.

tyle

how/hide

olor
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You can customize the graph layout by setting the Chart and Series pre
Click the appropriate tab and sub-tab to configure your graph.

Chart Settings
The Chart settings control the look and feel of the entire graph—not the
points. You set Chart preferences using the following tabs: Series, Gen
Titles, Legend, Panel, Walls, and 3D.

Series: displays the graph style, (bar, line, etc.) the hide/show settings
fill color, and the title of the series.

General: contains options for print preview, export, margins, scrolling,
magnification. 

Axis: indicates which axes to show as well as their scales, titles, ticks
position.

Titles: allows you to set the title of the graph, its font, background colo
and alignment.

Legend: includes all legend-related settings, such as position, fonts, a
lines.

Panel: shows the background panel layout of the graph. You can modif
set a gradient option, or specify a background image.
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Walls: lets you set colors for the walls of 3-dimensional graphs.

3D: contains the 3-dimensional settings, offset, magnification, and rota
for the active graph.

Series Settings
The Series settings control the appearance of the individual points plo
graph. You set Series preferences using the following tabs: Format, Po
General, and Marks.

Format: allows you to set the border color, line color, pattern and inver
for the lines or bars in your graph.

Point: displays the point properties. Points appear at various points w
line graph. You can set the size, color and shape of these points. 

General: contains the type of cursor, the format of the axis values, and 
settings for the horizontal and vertical axis. 

Marks: allows you to display the value for each point in the graph and
the format of those marks. 
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ting General and Database Options

You use the General and Database Options to regulate the size of the
containing your test results and optimize the processing time of your A
session.

Setting General Options 
Vuser data from long scenario runs (lasting two hours or more) create
databases. To decrease the size of the database and thereby decreas
processing time, you can increase the granularity for the two primary W
measurements that account for over half of the data in the database—
Second and Throughput.
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To configure Web granularity:

 1 Select Tools > Options.  The Options dialog box opens, displaying th
tab.

 2 To allow the Analysis to determine the best granularity for displaying th
select Use automatically calculated Web granularity (the default op
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 3 To specify a custom granularity for the Hits per Second and Throughp
measurements, select Set Web granularity and select the number of
you want the Analysis to wait before it summarizes the Hits and Throu

By default, the Analysis summarizes the Hits per Second and Through
measurements every 5 seconds. To reduce the size of the database, inc
granularity. To focus on more detailed results, decrease the granularity

Setting Database Options
When you configure and set up your Analysis session, the database c
the results may become fragmented. As a result, it will use excessive d
To repair and compress your results and optimize the database, selec
Tools > Options and click the Database tab. Click the Compact Datab
button. 

Note: The long scenarios (duration of two hours or more) will require m
for compacting.
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�����
ansaction Graphs 

After running a scenario, you can analyze the transactions that were e
during the test using one or more of the following graphs:

• Transaction Summary Graph 

• Transaction Performance Summary Graph 

• Transactions per Second Graph 

• Transaction Response Time - Average Graph 

• Transaction Response Time - Under Load Graph 

• Transaction Response Time - Distribution Graph 

• Transaction Response Time - Percentile Graph 
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ut Transaction Graphs

During scenario execution, Vusers generate data as they perform tran
The Analysis enables you to generate graphs that show the transactio
performance and status throughout script execution.

You can use additional Analysis tools such as merging and crossing re
understand your transaction performance graphs. You can also sort th
information by transactions. For more information about working with t
Analysis, see Chapter 1, Understanding Astra LoadTest Analysis. 
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nsaction Summary Graph

The Transaction Summary graph summarizes the number of transacti
scenario that failed, passed, aborted and ended in error. 

The x-axis specifies the name of the transaction. The y-axis shows the
number of transactions performed during the scenario run. 
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nsaction Performance Summary Graph

The Transaction Performance Summary graph displays the minimum, 
and average performance time for all the transactions in the scenario.

The x-axis specifies the name of the transaction. The y-axis shows the
rounded off to the nearest second—taken to perform each transaction
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nsactions per Second Graph

The Transactions per Second graph displays the number of transactio
performed during each second of a scenario run. This graph helps you 
the actual transaction load on your system at any given moment. You 
compare this graph to the Transaction Response Time - Average grap
to analyze the effect of the number of transactions on the performance

The x-axis represents the elapsed time (in seconds) from the beginnin
scenario run. The y-axis represents the number of transactions succes
performed during the scenario run. 
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nsaction Response Time - Average Graph

The Transaction Response Time – Average graph displays the averag
taken to perform transactions during each second of the scenario run.

The x-axis represents the elapsed time (in seconds) from the beginnin
scenario run. The y-axis represents the average time (in seconds) tak
perform each transaction. 

This graph is displayed differently for each granularity. The lower the g
the more detailed the results. However, it may be useful to view the res
higher granularity to study the overall Vuser behavior throughout the s
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For example, using a low granularity, you may see intervals when no 
transactions were performed. However, by viewing the same graph wit
granularity, you will see the graph for the overall transaction response
more information on setting the granularity, see Chapter 1, Understan
Astra LoadTest Analysis. 

You can compare the Transaction Response Time – Average graph to
States graph to see how the number of running Vusers affects the tran
performance time. 

For example, if the Transaction Response Time – Average graph show
performance time gradually improved, you can compare it to the Vuse
graph to see whether the performance time improved due to a decrea
Vuser load. 
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nsaction Response Time - Under Load Graph

The Transaction Response Time - Under Load graph indicates transac
relative to the number of Vusers running at any given point during the 
This graph helps you view the general impact of Vuser load on perform
and is most useful when analyzing a scenario with a gradual load. You c
a gradual load using the scheduling options in the Vuser information b

The x-axis indicates the number of running Vusers, and the y-axis indi
average transaction time in seconds. 
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In order for this graph to be meaningful, the performance is calculated
there is a stable load (constant number of running Vusers) for at least 
seconds (by default). If the Vuser load is not stable for at least five sec
transaction time is not calculated and the graph will indicate zeros.

For example, if you have a scenario with a load of between 50 and 70 V
an average performance of 10 seconds, yet the graph shows zero, the
Vusers did not stabilize for 5 seconds. 

nsaction Response Time - Distribution Graph 

The Transaction Response Time - Distribution graph displays the distr
the time taken to perform a transaction. If you compare it to the Transa
Performance Summary graph, you can see how the average performa
calculated. 

The x-axis represents the time range, in seconds, to perform the selec
transaction. The y-axis represents the number of transactions execute
the scenario.
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In the following graph, 10 Vusers executed the config_asp transaction 
second of the scenario. 

If you have defined acceptable minimum and maximum transaction pe
times, you can use this graph to determine whether the performance o
server is within the acceptable range.
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nsaction Response Time - Percentile Graph 

The Transaction Response Time - Percentile graph analyzes the perc
transactions that were performed within a given time range. This graph
determine the percentage of transactions that met the performance cr
defined for your system. In many instances, you need to determine the 
transactions with an acceptable response time. The maximum response
be exceptionally long, but if most transactions have acceptable respon
the overall system is suitable for your needs. 

The x-axis represents the percentage of the total number of transactio
measured during the scenario run. The y-axis represents the time take
perform the transactions.
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In the following graph, approximately 90 per cent of the Action1_Trans
transactions had a response time of 5 seconds or less. 

It is recommended to compare the Percentile graph to a graph indicati
average response time such as the Transaction Response Time - Ave
graph. A high response time for several transactions may raise the ov
average. However, if the transactions with a high response time occur
than five percent of the times, that factor may be insignificant.
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����
 Rendezvous Graphs 

After running a scenario, you can check the behavior of the Vusers tha
participated in the scenario using the following Vuser and Rendezvous

• Vuser Summary Graph

• Running Vusers Graph

• Rendezvous Graph 

t Vuser and Rendezvous Graphs

During scenario execution, Vusers generate data as they perform tran
The Vuser and Rendezvous graphs let you determine the overall beha
Vusers during the scenario. They display the Vuser states, the number
that completed the script, and rendezvous statistics. Use these graph 
conjunction with Transaction graphs to determine the effect of the num
Vusers on transaction response time.    
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er Summary Graph

The Vuser Summary graph displays a summary of Vuser performance.
view the number of Vusers that successfully completed the scenario ru
to those that did not.

This graph may be viewed as a pie, line, point, or bar graph. 
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ning Vusers Graph

The Running Vuser States graph displays the number of Vusers that e
Vuser scripts and their status during each second of the test. This grap
for determining the Vuser load on your server at any given moment.  B
this graph only shows the Vusers with a Run status. To view another Vu
set the filter conditions to the desired status. For more information, see C
Understanding Astra LoadTest Analysis. 

The x-axis represents the elapsed time (in seconds) from the beginnin
scenario run. The y-axis represents the number of Vusers in the scena
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The Rendezvous graph indicates when Vusers were released from rende
points, and how many Vusers were released at each point. 

This graph helps you understand transaction performance times. If you co
the Rendezvous graph to the Transaction Response Time - Average grap
can see how the load peak created by a rendezvous influences transaction

On the Rendezvous graph, the x-axis indicates the number of seconds th
elapsed since the beginning of the scenario. The y-axis indicates the num
Vusers that were released from the rendezvous. If you set a rendezvous 
Vusers, and the graph indicates that only 20 were released, you can see t
rendezvous ended when the timeout expired because all of the Vusers di
arrive. 
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Graphs 

After running a scenario, you can check the various resources that were 
monitored during the scenario using the:

• System Resource Graphs

t Resource Graphs

During scenario execution, Astra LoadTest collects data from the Vusers 
online monitors. You configure the online monitors before running the scen
indicating which resources to measure. You can view a summary of the st
collected for each resource after the scenario using the Analysis tool. Eac
resource is represented by a separate line in the appropriate graph. For 
information about setting the online monitors, see the Astra LoadTest Con
User’s Guide. 

The following Resource Graphs are available:

• System Resource Graphs

• Web Server Resource Graphs

• Web Application Server Graphs

This chapter describes System Resource graphs. For information on Web
Web Application graphs, see Chapter 5, Web Resource Graphs.  
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tem Resource Graphs

System Resource graphs display the system resource usage measure
online monitors during the scenario run. These graphs require that you
the resources you want to measure before running the scenario. For m
information, see the section on online monitors in the Astra LoadTest C
User’s Guide. System Resource graphs are available for: 

• Server Resources

• SNMP

The Server Resource graph shows the NT resources measured durin
scenario. The NT measurements correspond to the built-in counters a
from the NT Performance Monitor. 
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This graph helps you determine the impact of Vuser load on the variou
resources. The x-axis represents the elapsed time. The y-axis represe
resource usage. 

The SNMP graph shows statistics for machines using the Simple Netw
Management Protocol (SNMP).

.
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������
urce Graphs

After a scenario run, you can use graphs to analyze Web server and W
application server performance. 

This chapter describes:

• Web Server Resource Graphs

• Web Application Server Graphs 

t Web Resource Graphs

Web Vuser Graphs provide you with information about your Web serve
application server. These graphs display information about hits, throug
other resources specific to your server.

There are two types of Web Vuser graphs: Web server graphs and We
application server graphs. Web server graphs show general performan
information for the Web server. Web Application Server graphs provide
information about application servers such as BroadVision and MS Act
Pages. 
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Note that in order to obtain data for Web Vuser graphs (except for Hits
Second and Throughput), you need to activate the online monitor for 
before running the scenario. When you set up the online monitor for a s
indicate which statistics and measurements to monitor. For example, o
Apache server you could measure Busy Servers, Idle Servers, and CP
For more information, see the Astra LoadTest Controller User’s Guide

In order to display all the measurements on a single graph, the Analys
scale them. The legend below the graph indicates the scale factor for 
resource. To obtain the true value, multiply the scale factor by the displa
For example, in the following graph the actual value of KBytes Sent pe
in the second minute is 1; 10 multiplied by the scale factor of 1/10. 
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b Server Resource Graphs

The following Web Server Resource graphs are available:

• Hits Per Second

• Throughput 

• Apache 

• Microsoft Information Internet Service (IIS) 

• Netscape Enterprise Server 

Note that the Apache, Microsoft IIS, and Netscape Server graphs re
you specify which resources you want to measure before running the 
For more information, see the Astra LoadTest Controller User’s Guide
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Hits per Second Graph
The Hits per Second graph shows the number of hits made on the Web
Vusers during each second of the scenario run. This graph helps you ev
amount of load Vusers generate, in terms of the number of hits. You can
this graph to the Transaction Performance graph to see how the numb
affects transaction performance.
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The x-axis represents the number of seconds elapsed since the start o
scenario run. The y-axis represents the number of hits on the server. F
example, the graph above shows that the most hits per second took pla
the eighth second.

Throughput Graph
The Throughput graph shows the amount of throughput on the server du
second of the scenario run. Throughput is measured in kilobytes and r
the amount of data that the Vusers received from the server at any give
This graph helps you to evaluate the amount of load Vusers generate, i
server throughput. You can compare this graph to the Transaction Per
graph to see how the throughput affects transaction performance.

The x-axis represents the number of seconds elapsed since the start o
scenario run. The y-axis represents the throughput of the server, in kil
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The following graph shows the highest throughput to be 7,500 bytes d
sixth second of the scenario.
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Apache Server Graph
The Apache Server graph shows server statistics as a function of the 
scenario time. 

In the above graph, the CPU usage remained steady throughout the sc
the end of the scenario, the number of idle servers increased. The numb
servers remained steady at 1 throughout the scenario implying that the V
accessed one Apache server. Note that the scale factor for the Busy S
resource is 1/10 and the scale factor for CPU usage is 10. 
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b Application Server Graphs

The following Web Application Server Resource graphs are available:

• BroadVision 

• ColdFusion

• Microsoft Active Server Pages 

• SilverStream 

• WebLogic 

• WebSphere

Note that the above graphs require that you specify the resources you
measure before running the scenario. 

When you open a Web Application Server Resource graph, you can filte
show the relevant application. When you need to analyze other applica
can change the filter conditions and display the desired resources. 

Each Web Application Server Resource graph measures different reso
These are detailed in the following sections.
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BroadVision
The BroadVision monitor supplies performance statistics for all the 
servers/services available within the application server.

The following table describes all the Servers/Services that can be mon

Server
Multiple 
Instances 

Description 

adm_srv No
One-To-One user administration server.
must be one. 

alert_srv No
Alert server handles direct IDL function 
the Alert system. 

bvconf_srv No
One-To-One configuration management
There must be one. 

cmsdb Yes Visitor management database server. 

cntdb Yes Content database server. 

deliv_smtp_d Yes

Notification delivery server for e-mail typ
messages. Each instance of this server 
have its own ID, numbered sequentially 
with "1". 

deliv_comp_d No Notification delivery completion process
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extdbacc Yes
External database accessor. You need a
one for each external data source. 

genericdb No

Generic database accessor handles con
query requests from applications, when 
specifically called from the application. T
also used by the One-To-One Command

hostmgr Yes

Defines a host manager process for eac
machine that participates in One-To-One
doesn’t run any One-To-One servers. Fo
example, you need a hostmgr on a mac
runs only servers. You don’t need a sepa
hostmgr on a machine that already has o
servers in this list. 

g1_ofbe_srv No Order fulfillment back-end server. 

g1_ofdb Yes Order fulfillment database server. 

g1_om_srv No Order management server. 

pmtassign_d No

The payment archiving daemon routes p
records to the archives by periodically c
the invoices table, looking for records wi
completed payment transactions, and th
moving those records into an archive tab

pmthdlr_d Yes
For each payment processing method, y
one or more authorization daemons to pe
acquire the authorization when a reques
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pmtsettle_d Yes

Payment settlement daemon periodicall
the database for orders of the associate
payment processing method that need t
settled, and then authorizes the transac

sched_poll_d No
Notification schedule poller scans the da
tables to determine when a notification m
run. 

sched_srv Yes
Notification schedule server runs the scr
generate the visitor notification message
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Performance Counters

Performance counters for each server/service are divided into logical g
according to the service type.

The following section describes all the available counters under each 
Please note that for some services the number of counters for the sam
can be different.

Counter groups:

• BV_DB_STAT

• BV_SRV_CTRL

• BV_SRV_STAT

• NS_STAT  

• BV_CACHE_STAT  

• JS_SCRIPT_CTRL 

• JS_SCRIPT_STAT 
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BV_DB_STAT 

The database accessor processes have additional statistics available 
BV_DB_STAT memory block. These statistics provide information abo
database accesses, including the count of selects, updates, inserts, de
stored procedure executions. 

• DELETE - Count of deletes executions

• INSERT - Count of inserts executions

• SELECT - Count of selects executions

• SPROC - Count of stored procedure executions.

• UPDATE - Count of updates executions

BV_SRV_CTRL

• SHUTDOWN
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NS_STAT

The NS process displays the namespace for the current One-To-One 
environment, and optionally can update objects in a name space. 

• Bind

• List

• New

• Rebnd

• Rsolv

• Unbnd

BV_SRV_STAT

The display for Interaction Manager processes includes information ab
current count of sessions, connections, idle sessions, threads in use, a
of CGI requests processed. 

• HOST - Host machine running the process. 

• ID - Instance of the process (of which multiple can be configured in
bv1to1.conf file), or engine ID of the Interaction Manager. 

• CGI - Current count of CGI requests processed.

• CONN - Current count of connections.
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• CPU - CPU percentage consumed by this process. If a process is u
of the CPU time, consider moving it to another host, or creating an 
process, possibly running on another machine. Both of these speci
are done in the bv1to1.conf file. The CPU % reported is against a s
processor. If a server is taking up a whole CPU on a 4 processor m
this statistic will report 100%, while the Windows NT Task Manager
25%. The value reported by this statistic is consistent with "% Proc
Time" on the Windows NT Performance Monitor. 

• GROUP - Process group (which is defined in the bv1to1.conf file),
Interaction Manager application name. 

• STIME - Start time of server. The start times should be relatively clo
times might be an indication that a server crashed and was automa
restarted. 

• IDL - Total count of IDL requests received, not including those to th

• IdlQ 

• JOB 

• LWP - Number of light-weight processes (threads). 

• RSS - Resident memory size of server process (in Kilobytes).

• STIME - System start time.

• SESS - Current count of sessions.

• SYS - Accumulated system mode CPU time (seconds). 
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• THR - Current count of threads. 

• USR - Accumulated user mode CPU time (seconds). 

• VSZ - Virtual memory size of server process (in kilobytes). If a proc
growing in size, it probably has a memory leak. If it is an Interaction
process, the culprit is most likely a component or dynamic object (t
Interaction Manager servers do grow and shrink from garbage colle
during normal use). 

BV_CACHE_STAT

Monitors the request cache status.

The available counters for each request are:

• CNT- Request_Name-HIT - Count of requests found in the cache. 

• CNT- Request_Name-MAX - Maximum size of the cache in bytes

• CNT- Request_Name-SWAP - Count of items that got swapped ou
cache. 

• CNT- Request_Name-MISS - Count of requests that were not in th

• CNT- Request_Name-SIZE - Count of items currently in the cache
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Cache Metrics

Cache metrics are available for the following items:

• AD 

• ALERTSCHED - Notification schedules are defined in the 
BV_ALERTSCHED and BV_MSGSCHED tables. They are defined
One-To-One Command Center user or by an application. 

• CATEGORY_CONTENT

• DISCUSSION - The One-To-One discussion groups provide moder
system of messages and threads of messages aligned to a particu
Use the Discussion group interfaces for creating, retrieving and de
individual messages in a discussion group. To create, delete, or ret
discussion groups, use the generic content management API. The 
BV_DiscussionDB object provides access to the threads and mess
the discussion group database. 

• EXT_FIN_PRODUCT 

• EDITORIAL - Using the Editorials content module, you can point ca
community cast personalized editorial content, and sell published te
One-To-One site. You can solicit editorial content, such as investme
and weekly columns, from outside authors and publishers, and cre
own articles, reviews, reports, and other informative media. In additi
you can use images, sounds, music, and video presentations as ed
content. 
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• INCENTIVE - Contains sales incentives

• MSGSCHED - Contains the specifications of visitor-message jobs.
Notification schedules are defined in the BV_ALERTSCHED and 
BV_MSGSCHED tables. They are defined by the One-To-One Com
Center user or by an application. 

• MSGSCRIPT - Contains the descriptions of the JavaScripts that ge
visitor messages and alert messages. Contains the descriptions of
JavaScripts that generate targeted messages and alert messages.
Command Center to add message script information to this table by
the Visitor Messages module in the Notifications group. For more in
see the Command Center User’s Guide. 

• PRODUCT - BV_PRODUCT contains information about the produc
visitor can purchase.

• QUERY - BV_QUERY contains queries. 

• SCRIPT -  BV_SCRIPT contains page scripts.

• SECURITIES
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• TEMPLATE - The Templates content module enables you to store 
content database any BroadVision page templates used on your On
site. Combining BroadVision page templates with BroadVision dyna
objects in the One-To-One Design Center application is one way fo
developers to create One-To-One Web sites. If your developers us
page templates, you can use the Command Center to enter and m
them in your content database. If your site doesn’t use BroadVision
template, you will not use this content module. 

JS_SCRIPT_CTRL

• CACHE

• DUMP 

• FLUSH 

• METER 

• TRACE 
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JS_SCRIPT_STAT

• ALLOC 

• ERROR 

• FAIL 

• JSPPERR

• RELEASE

• STOP

• SUCC

• SYNTAX

ColdFusion
The following measurements are available for Allaire’s ColdFusion ser

• % Total Processor Time (System) - The % Total Processor Time 
average percentage of time that all the processors on the system a
executing non-idle threads. On a multi-processor system, if all proce
always busy this is 100%, if all processors are 50% busy this is 50%
1/4th of the processors are 100% busy this is 25%. It can be viewe
fraction of the time spent doing useful work. Each processor is ass
Idle thread in the Idle process which consumes those unproductive 
cycles not used by any other threads. 



Web Resource Graphs

Astra Lo hapter 5, page 81

Back

Find

Find

Chapter
Top of

 Again

nt of time, 
e CF 

nt of time, 
ral page 
 

usion 

by the 

g to be 

g actively 
adTest Analysis User’s Guide C

• Avg. Queue Time (msec) - This is a running average of the amou
in milliseconds, requests spent waiting in the CF input queue befor
began to process that request. 

• Avg Req Time (msec) - This is a running average of the total amou
in milliseconds, it took CF to process a request. In addition to gene
processing time, this value includes both queue time and database
processing time. 

• Bytes Out/sec - This is the number of bytes returned by the ColdF
Server per second. 

• Page Hits/sec - The number of web pages processed per second 
ColdFusion Server. 

• Queued Requests - This is the number of requests currently waitin
processed by the ColdFusion Server. 

• Running Requests - This is the number of requests currently bein
processed by the ColdFusion Server. 
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MS Active Server Pages (ASP)
The following measurements are available for MS Active Server Page

• % Total Processor Time (System) - The % Total Processor Time 
average percentage of time that all the processors on the system a
executing non-idle threads. On a multi-processor system, if all proce
always busy this is 100%, if all processors are 50% busy this is 50%
1/4th of the processors are 100% busy this is 25%. It can be viewe
fraction of the time spent doing useful work. Each processor is ass
Idle thread in the Idle process which consumes those unproductive 
cycles not used by any other threads. 

• Request Bytes Out Total - The total size, in bytes, of responses s
clients. This does not include standard HTTP response headers. 

• Requests Executing - The number of requests currently executing

• Requests Queued - The number of service requests on the queue

• Requests/sec - The number of requests executed per second. 

• Transactions Aborted - The number of transactions aborted. 

• Transactions Pending - Number of transactions in progress. 
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SilverStream
The following measurements are available for the SilverStream server

• #Idle Sessions - Number of sessions in the Idle state. 

• Avg.Request processing time - Average request processing time

• Bytes Sent/sec - The rate at which data bytes are sent from the W

• Current load on Web Server - Percentage of load utilized by Silve
web server, scaled at a factor of 25. 

• Hits/sec - The HTTP request rate. 

• Total sessions - The total number of sessions.

• Free memory  - The total amount of memory in the Java Virtual Ma
currently available for future allocated objects.

• Total memory  - The total amount of memory in the Java Virtual M

• Memory Garbage Collection Count  - The total number of times t
Garbage Collector has run since the server has started.

• Free threads  - The current number of threads not associated with
connection and available for immediate use. 

• Idle threads - The number of threads associated with a client conne
not currently handling a user request.

• Total threads  - The total number of client threads allocated.
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WebLogic
The following measurements are available for the WebLogic server:

• Server Table

Lists all WebLogic Servers that are being monitored by the agent. A
must be contacted or be reported as a member of a cluster at least
before it will appear in this table.  Servers are only reported as a me
cluster when they are actively participating in the cluster, or shortly 

ServerState - State of the WebLogic Server, as inferred by the SNM
Up implies the agent can contact the server; down implies the agen
contact the server. 

ServerLoginEnable - This value is true if client logins are enabled
server.

ServerMaxHeapSpace - Maximum heap size for this server, in KB

ServerHeapUsedPct - Percentage of heap space currently in use 
server.

ServerQueueLength - Current length of the server execute queue

SeverQueueThroughput - Current throughput of execute queue, e
as number of requests processed per second

ServerNumEJBDeployment - Total number of EJB deployment un
to the server.
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ServerNumEJBBeansDeployed - Total number of EJB beans acti
deployed on the server.

• Listen Table 

The set of protocol, ip address, port combinations on which servers
listening. There will be multiple entries for each server: one for eac
(protocol,ipAddr,port) combination.

If clustering is used, then the clustering related MIB objects will ass
higher priority.

ListenPort - Port number 

ListenAdminOK - True if admin requests are allowed on this 
(protocol,ipAddr,port), else false.

ListenState - listening if the (protocol, ipAddr, port) is enabled on t
notListening if it is not.The server may be listening but not acceptin
clients if its serverLoginEnable state is false. In this case existing c
continue to function but new ones will not.

• ClassPath Table 

Table of classpath elements for Java, WebLogic Server and servlet
are multiple entries in this table for each server; there may be multip
for each path on a server.

If clustering is used, then the clustering related MIB objects will ass
higher priority.
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CPType - The type of CP element: Java, weblogic, servlet. A Java 
means the cpElement is one of the elements in the normal Java cla
weblogic CPType means the cpElement is one of the elements in 
weblogic.class.path. A servlet CPType means the cpElement is one
elements in the dynamic servlet classpath.

CPIndex - Position of element within its path. The index starts at 1

WebSphere Graph
The following measurements are available for the WebSphere server:

• Run Time Resources

BeanData

BeanObjectPool

OrbThreadPool

DBConnectionMgr

TransactionData

• ServletEngine

• Sessions
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��
raphs

You can use Network graphs to determine whether your network is ca
delay in the scenario. You can also determine the problematic network

This chapter describes:

• Network Monitor Graph

• Network Monitor Segment Graph

• Timeout Count Graph

• Verifying the Network as a Bottleneck

t Network Monitoring

Network configuration is a primary factor in the performance of applica
web systems. A poorly designed network can slow client activity to una
levels. 

In an application, there are many network segments. A single network
with poor performance, can affect the entire system.

Network graphs let you locate the network related problem so that it ca
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erstanding Network Monitoring

The following diagram shows a typical network. In order to go from the
server machine to the Vuser machine, data must travel over several se

You can use analyze the Network Monitor graphs to help you improve
system. The available graphs are:

• Network Monitor Graph - to help you determine whether the netw
bottleneck

• Network Monitor Segment Graph - to help you locate the problem
segment

• Timeout Count Graph - displays the number of timeouts that occu
during the scenario run.
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In order for the Analysis to generate Network Monitor graphs, you mus
the Network monitor before executing the scenario. In the Network Mo
settings, you specify the path you want to monitor. For information abo
up the Network monitor, see the Astra LoadTest Controller User’s Guid

work Monitor Graph

The Network Monitor graph shows the delays for the complete path b
the source and destination machines (for example the database serve
Vuser host). The graph maps the delay as a function of the elapsed sc
time. 

Each path defined in the Controller is represented by a separate line w
different color in the graph. 
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The following graph shows the network delay as a function of the elap
scenario time. It shows a delay of 16 seconds in the 8th minute of the 
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work Monitor Segment Graph

The Network Monitor Segment graph shows the delay for each segm
path according to the elapsed scenario time. Each segment is displaye
separate line with a different color.

In the following example, four segments are shown. The graph indicate
segment caused a delay of 70 seconds in the sixth minute. 
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eout Count Graph

The Timeout Count graph shows when network timeouts occurred dur
scenario. When Astra LoadTest sends a packet of information and the
does not return before the timeout period, it is indicated in the Timeou
graph. 

You set the Packet Roundtrip Timeout value in the Controller’s Monito
Options. The default value is 4000 milliseconds. For more information
Astra LoadTest Controller User’s Guide. 

In the Timeout Count graph, each segment is displayed by a different 
You can apply a filter to the graph to display only specific segments, o
segments with a significant delay. For information on filtering, see Cha
Understanding Astra LoadTest Analysis.  
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In the following example, timeouts occurred twice during the scenario.

You can compare this graph to the Network Monitor Segment graph to 
how each timeout affected the delay for that path. 
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ifying the Network as a Bottleneck

You can use merge various graphs to determine if the network is a bottle
example, using the Network Monitor and Running Vusers graphs, y
determine how the number of Vusers effects the network delay. The N
Monitor graph indicates the network delay during the scenario run. The
Vusers graph shows the number of running Vusers. 

In the following merged graph, the network delays are compared to th
Vusers. The graph shows that when all 10 Vusers were running, a a netw
of 22 milliseconds occurred, implying that the network may be overloa
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���
ult and Merged Graphs

The Analysis utility lets you compare results and graphs to determine t
of a problem. 

This chapter discusses:

• Cross Result Graphs

• Generating Cross Result Graphs

• Merging Graphs

• Creating a Merged Graph

t Cross Result and Merged Graphs

Comparing results is essential for determining bottlenecks and problem
Cross Result graphs to compare the results of multiple scenario runs. Y
Merged graphs to compare results from different graphs within the same
run. 
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ss Result Graphs

Cross Result graphs are useful for:

• benchmarking hardware

• testing software versions

• determining system capacity

If you want to benchmark two hardware configurations, you run the sa
scenario with both configurations and compare the transaction respon
using a single Cross Result graph. 

Suppose that your vendor claims that a new software version is optimi
quicker than a previous version. You can verify this claim by running th
scenario on both versions of the software, and comparing the scenario

You can also use Cross Result graphs to determine your system’s cap
run scenarios using different numbers of Vusers running the same scr
analyzing Cross Result graphs, you can determine the number of user
cause unacceptable response times.
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In the following example, two scenario runs are compared by crossing
results, res12, and res15. The same script was executed twice—first w
Vusers and then with 50 Vusers. In the first run, the average transaction
approximately 59 seconds. In the second run, the average time was 4.7
It is apparent that the system works much slower with a greater load. 
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The Cross Result graphs have an additional filter and group by catego
Name. The above graph is filtered to the OrderRide transaction for resu
and res15, grouped by Result Name. If the graph was not grouped by 
name, the results from the two scenario runs would not be displayed s

The filter conditions for the above graph are:

The Group By settings for the above graph are: 
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nerating Cross Result Graphs

You can create a Cross Result graph for two or more result sets. 

To generate a Cross Result graph:

 1 Choose File > Cross With Result. The Cross Results dialog box ope

 2 Click Add to add an additional result set to the Result List. The Selec
Files for Cross Results dialog box opens.

 3 Locate a results directory and select its result file (.lrr). Click OK. The s
added to the Result List.

 4 Repeat steps 2 and 3 until all the scenarios you want to compare are i
Result List. 
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 5 When you generate a Cross Result graph, by default it is saved as a n
Analysis session. To save it in an existing session, clear the Create N
Analysis Session for Cross Result check box. 

 6 Click OK. The Analysis processes the result data and asks for a confir
open the default graphs. 

After you generate a Cross Result graph, you can filter it to display sp
scenarios and transactions. You can also manipulate the graph by cha
granularity, zoom, and scale. For more information, see Chapter 1, 
Understanding Astra LoadTest Analysis. 
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rging Graphs

The Analysis lets you merge the results of two graphs from the same sce
a single graph. The merging allows you to compare several different 
measurements at once. For example, you can make a merged graph t
the network delay and number of running Vusers, as a function of the 
time. 

In order to merge graphs, their x-axis must be the same measuremen
example, you can merge Web Throughput and Hits per second, becau
common x-axis is Scenario Elapsed Time. The drop-down list only sho
active graphs with an x-axis common with the current graph. The Anal
provides three types of merging:

• Overlay

• Tile

• Correlate

Overlay: Superimpose the contents of two graphs that share a comm
The left y-axis on the merged graph shows the current graph’s values.
y-axis shows the values of the graph that was merged. There is no lim
number of graphs that you can overlay. When you overlay two graphs, 
for each graph is displayed separately to the right and left of the graph
you overlay more than two graphs, the Analysis displays a single y-ax
the different measurements accordingly.   
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In the following example the Throughput and Hits per Second graph ar
with one another. 
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Tile: View contents of two graphs that share a common x-axis in a tile
one above the other. In the following example the Throughput and Hits
Second graph are tiled one above the other.

Correlate: Plot the y-axis of two graphs against each other. The active
axis becomes the x-axis of the merged graph. The y-axis of the graph
merged, becomes the merged graph’s y-axis.
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In the following example, the Throughput and Hits per Second graph a
correlated with one another. The x-axis is Bytes per Second (the Thro
measurement) and the y-axis shows the Hits per Second. 

ating a Merged Graph

You can merge all graphs with a common x-axis. 

To create a merged graph:

 1 Select a graph in the tree view or click on its tab to make it active.
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 2 Choose View > Merge Graphs or click the Merge Graphs button. Th
Graphs dialog box opens and displays the name of the active graph.
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 3 Select a graph with which you want to merge your active graph. Only t
with a common x-axis to the active graph, are available. 

 4 Select the type of merge: Overlay, Tile, or Correlate. 

 5 Specify a title for the merged graph. By default, the Analysis combines
of the two graphs being merged.

 6 Click OK.

 7 Filter the graph just as you would filter any ordinary graph. 
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�
ding Analysis Reports

After running a scenario, you can use the Analysis reports to analyze 
performance of your application. 

This chapter describes:

• Viewing Summary Reports

• Creating HTML Reports

t Analysis Reports

After running a scenario, you can view reports that summarize your sy
performance. The Analysis provides the following reporting tools:

• Summary report

• HTML reports

The Summary report provides general information about the scenario 
can view the Summary report at any time from the Analysis window. 

You can instruct the Analysis to create an HTML report. The Analysis c
HTML report for each one of the open graphs. 



Understanding Analysis Reports

Astra ter 8, page 108

In

Back

Find

Find

Chapter
Top of

 Again

V

n. This 
ndow. It 
raphs: 
ction 
e 
 LoadTest Analysis User’s Guide Chap

iewing Summary Reports

The Summary report provides general information about scenario executio
report is always available from the tree view or as a tab in the Analysis wi
lists statistics about the scenario run and provides links to the following g
Running Vusers, Throughput (Web), Hits Per Second (Web), and Transa
Summary. At the bottom of the page, the Summary report displays a tabl
containing the scenario’s run-time data. 
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ating HTML Reports 

The Analysis lets you create HTML reports for your scenario run. It cre
separate report for each one of the open graphs and a Summary repo
Summary report is identical to the Summary report that you access fro
Analysis window. The report also provides a link to an Excel file conta
graph data.
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To create HTML reports:

 1 Open all graphs that you want to be included in the report.

 2 Choose Reports > HTML Report or click the Create HTML Report bu
Save dialog box opens. 

 3 Specify a path and file name for the HTML report and click OK. The A
saves a Summary report in the selected folder and the rest of the grap
folder with the same name. When you create an HTML report, the Ana
opens your default browser and displays the Summary report. 

 4 To view an HTML report for one of the graphs, click on its link in the le

 5 To copy the HTML reports to another location, be sure to copy the filen
the folder with the same name. For example, if you named your HTML
test1, copy test1.html and the folder test1 to the desired location.
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�
Results Using TestDirector

The integration of the Analysis with TestDirector lets you manage resu
sessions using TestDirector projects. TestDirector helps you organize 
manage all scripts, scenarios, and results using a repository. 

This chapter describes:

• Opening a Connection to a TestDirector Project

• Creating a New Session Using TestDirector

• Opening an Existing Session Using TestDirector

• Saving Sessions to a TestDirector Project

For detailed information on using TestDirector to manage your session
the TestDirector User’s Guide.
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ut Managing Results Using TestDirector

The Analysis works together with TestDirector, Mercury Interactive’s te
management tool. You can store both sessions and results in a TestDi
repository and organize them into unique groups. You can also retriev
from the TestDirector repository, and save the Analysis sessions with yo
graph settings, locally. 

You can instruct the Analysis to automatically connect to the TestDirec
upon startup. 

ening a Connection to a TestDirector Project

Before you can work with a TestDirector project, you must open a con
the server hosting the project. After connecting to the TestDirector serve
have complete access to the regular file system. 
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To open a connection to a TestDirector project:

 1 Choose Tools > TestDirector Connection from the Analysis window.

 2 In the Server box, type in the name of the TestDirector server and the
Connect. A message appears indicating that the Analysis is connectin
server. 
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 3 In the Project Connection box, select one of the available projects. 

 4 Provide the user login and password. 

 5 Select the Reconnect on Startup check box to automatically open the
connection to the TestDirector server and project when you start the A
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 6 If you select Reconnect on Startup, you can save the specified passwo
automate the login process. Select the Save Password for Reconnect
Startup check box.

 7 Click Connect. A message appears indicating that you are connecting
project. 

 8 Click Close to close the Connection to TestDirector dialog box.

ating a New Session Using TestDirector

You can create a new Analysis session using a result file (.lrr extensio
in the TestDirector repository or file system. 

To create a new session using results from the TestDirector repo

 1 Connect to the TestDirector server (see Opening a Connection to a 
TestDirector Project on page 112.)
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 2 Choose File > New or click the New File button. The Open Result File
Analysis Session from TestDirector Project dialog box opens.

 3 Select a result file from the project.

 4 Click OK. The Analysis loads the results.   
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 5 To select a session file from the standard file system, click the File Sy
button in the upper right corner of the dialog box. The Open Result Fil
Session dialog box opens. 

To return to the TestDirector dialog box, click the TestDirector button 
bottom right of the dialog box. 
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pening an Existing Session Using TestDirector

You can open an existing Analysis session through the standard file sys
TestDirector repository. 

To open a session from the TestDirector repository:

 1 Open a connection to the TestDirector server (see Opening a Connec
TestDirector Project on page 112.)

 2 Choose File > Open or click the File Open button. The Open Existing
Session File from TestDirector Project dialog box opens.
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 3 Select a session from the project.

 4 Click OK. The Analysis loads the scenario. The name of the session a
the banner. The session’s graphs are displayed in the tree-view. 

 5 To select a session file from the standard file system, click the File Sy
button in the upper right corner of the dialog box. The Open Existing A
Session File dialog box opens. 

To return to the TestDirector dialog box, click the TestDirector button 
bottom right of the dialog box. 
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ing Sessions to a TestDirector Project

You can save a new analysis session, or one that previously existed as a
into a TestDirector project.

To save a session to the TestDirector project:

 1 Connect to the TestDirector server (see Opening a Connection to a 
TestDirector Project on page 112.)

 2 Choose File > Save As. The Save to TestDirector Project dialog box o

 3 Type a session name, select a folder and click OK. 

 4 To save the session to disk, click File System and save the file as you
a standard file system. 
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