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Welcome to This Guide

This guide describes the best practices for using and configuring the
integration of SiteScope with HP Business Service Management (BSM) and
HP Operations Manager (HPOM) products.

This chapter includes:

» How This Guide Is Organized on page 7

» Who Should Read This Guide on page 8

» How Do I Find the Information That I Need? on page 8

» Additional Online Resources on page 9

» Documentation Updates on page 9

How This Guide Is Organized

Chapter 1

Chapter 2

The guide contains the following chapters:

Integrating SiteScope with Business Service Management
Applications

Describes best practices for integrating SiteScope with BSM applications.

Integrating SiteScope with Operations Manager Applications

Describes best practices for using and configuring the HP Operations
Manager (HPOM) integration for sending events and reporting metrics to
HPOM and HP Performance Manager.
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Chapter 3  Integrating SiteScope with Business Service Management or
Operations Manager

Describes best practices for using SiteScope with BSM and HPOM
applications.

Chapter 4  Troubleshooting SiteScope Integration Issues

Describes troubleshooting when using and configuring the integration of
SiteScope with BSM and HPOM applications.

Who Should Read This Guide

This guide is intended for the following users of SiteScope and BSM:

» SiteScope/BSM/HPOM administrators

» SiteScope/BSM/HPOM application administrators
» SiteScope/BSM/HPOM data collector administrators
» SiteScope/BSM/HPOM end users

Readers of this guide should be knowledgeable about enterprise system
administration, infrastructure monitoring systems, and SiteScope, and have
familiarity with the systems being set up for monitoring. Readers should
also be familiar with BSM/HPOM, and enterprise monitoring and
management concepts.

How Do | Find the Information That | Need?

This guide is part of the HP SiteScope Help. The SiteScope Help provides a
single-point of access for all SiteScope documentation.

You can access the SiteScope Help by selecting Help > SiteScope Help on the
SiteScope server.
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Additional Online Resources

Troubleshooting & Knowledge Base accesses the Troubleshooting page on
the HP Software Support Web site where you can search the Self-solve
knowledge base. Choose Help > Troubleshooting & Knowledge Base. The
URL for this Web site is http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software Support accesses the HP Software Support Web site. This site
enables you to browse the Self-solve knowledge base. You can also post to
and search user discussion forums, submit support requests, download
patches and updated documentation, and more. Choose Help > HP Software
Support. The URL for this Web site is www.hp.com/go/hpsoftwaresupport.

Most of the support areas require that you register as an HP Passport user
and sign in. Many also require a support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport user ID, go to:

http://h20229.www2.hp.com/passport-registration.html

HP Software Web site accesses the HP Software Web site. This site provides
you with the most up-to-date information on HP Software products. This
includes new software releases, seminars and trade shows, customer support,
and more. Choose Help > HP Software Web site. The URL for this Web site
is www.hp.com/go/software.

Documentation Updates

HP Software is continually updating its product documentation with new
information.

To check for recent updates, or to verify that you are using the most recent
edition of a document, go to the HP Software Product Manuals Web site
(http://h20230.www2.hp.com/selfsolve/manuals).
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Integrating SiteScope with Business
Service Management Applications

SiteScope can be used to report data that is used in many applications in

Business Service Management (BSM). This section contains details of the

benefits, prerequisites, best practices, and troubleshooting for integrating
SiteScope with BSM applications.

This section includes:

"Integration Benefits" on page 12
"Integration Prerequisites" on page 13

"Integration Options and Details" on page 14

Y VY VY Y

"Troubleshooting" on page 19

Note: For recommendations on integrating SiteScope with BSM or HP
Operations Manager (HPOM), see "Integrating SiteScope with Business
Service Management or Operations Manager" on page 25.

11
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Integration Benefits

> Events: Ability to configure and generate events directly from SiteScope,

reuse existing alerts as events, and manage and use SiteScope events in
BSM’s Operations Management and Service Health. For details, see
"Sending Events" in Using SiteScope.

> Run-time Service Model (RTSM): SiteScope can discover and report

topology on monitored systems to BSM’s RTSM. You can then manage
and work with these discovered configuration items (CIs) in views that
provide a subset of the components in which your business functions. For
details, see "Integrating SiteScope Data with BSM’s Configuration Items"
in Using SiteScope.

» Service Health and Service Level Management: Health indicators assigned

to SiteScope monitor data provide a more detailed view of the health of a
configuration item (CI) when SiteScope reports metrics or events.

» For details on managing indicators in the centralized Indicator
Assignments repository in SAM Administration, see "Indicator
Assignment Settings" in Using System Availability Management in the
HP Business Service Management Documentation Library.

» For details on mapping metrics to indicators in SiteScope, see
"Assigning SiteScope Metrics to Indicators" in Using SiteScope.

System Availability Management Administration: Enables viewing and
managing multiple SiteScopes from within System Availability
Management Administration. For details, see "System Availability
Management Administration Overview" in Using System Availability
Management in the HP Business Service Management Documentation
Library.

Reports: Ability to create and view reports of SiteScope monitor metrics in
System Availability Management and Operations Management.

» For details on System Availability Management reports, see "System
Availability Management Reports" in Using System Availability
Management in the HP Business Service Management Documentation
Library.

» For details on Performance Perspective (the graphing component of
Operations Management), see the Using Operations Management guide
in the HP Business Service Management Documentation Library.
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» Downtime: Centralized management enables configuring downtime for
your IT infrastructure from one place in BSM. For details, see "CI
Downtime" in Using SiteScope.

Integration Prerequisites

The following are required to enable the integration:

license. For details, see "System
Availability Management
Administration Overview" in Using
System Availability Management in the
HP Business Service Management
Documentation Library.

SiteScope .. )
Integration Prerequisites Enables reporting
BSM System Availability Management » Metrics (using

the BSM
integration)

» Topology data to
BSM

HP Operations
Manager

HP Operations agent must be installed
on the SiteScope server. For details, see
the HP SiteScope Deployment Guide
PDF.

» Metrics (using
the Operations
Manager
Integration)

» Events to BSM'’s
Operations
Management

13
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Integration Options and Details

The metrics and event data collected by SiteScope monitors is used in BSM
applications. Choose the integration option according to the type of data to
be collected, and the monitoring environment that exists in your
organization.
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BSM
Application

What to Use

SiteScope
Integration

Where to Get Details

Service Health

Metrics (using the BSM
Integration)

Advantages:

» Displays metric values in
Service Health tooltips.

» You can create
customized calculation
rules. For details, see
"Business Rule
Repository Overview" in
Using Service Health in
the HP Business Service
Management
Documentation Library.

Recommended if you do
not have Operations
Management.

BSM

"How to Configure the
Integration between SiteScope
and BSM" in Using SiteScope

Events
(metrics status change)

Advantage: Reduces the
amount of data SiteScope
sends to BSM.

Recommended when
managing events in
Operations Management.

HP
Operations
Manager

"How to Enable SiteScope to
Send Events to HPOM or BSM's
Operations Management" in
Using SiteScope

Topology (required)

BSM

"HP Integration Settings" in
Using SiteScope

(To report topology, make sure
the Report monitor and related
Cl topology check box is selected
in BSM Integration Data and
Topology Settings for each
monitor instance)

15
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BSM. . What to Use SlteScop.e Where to Get Details
Application Integration
Service Level Metrics (using the BSM BSM "How to Configure the
Management Integration) Integration between SiteScope
(recommended) and BSM" in Using SiteScope
Events HP "How to Enable SiteScope to
(optional) Operations Send Events to HPOM or BSM's
Manager Operations Management" in
Using SiteScope
Topology BSM "HP Integration Settings" in
(required) Using SiteScope
(To report topology, make sure
the Report monitor and related
Cl topology check box is selected
in BSM Integration Data and
Topology Settings for each
monitor instance)
SAM Reports Metrics (using the BSM BSM "How to Configure the
Integration) Integration between SiteScope
(required) and BSM" in Using SiteScope
Topology BSM "HP Integration Settings" in
(required) Using SiteScope

(To report topology, make sure
the Report monitor and related
Cl topology check box is selected
in BSM Integration Data and
Topology Settings for each
monitor instance)

16
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BSM
Application

SiteScope

. Where to Get Details
Integration

What to Use

Service Health
and

Service Level
Management/
SAM Reports

Since SiteScope can report metrics to BSM (which are used in Service Level
Management and System Availability Management), and metrics and events
(which are used in Service Health), perform the following steps:

1. Decide on the reporting mode (events, metrics, or both) that you want to use
in Service Health. For details, see Service Health above.

2. Select the data preference (events or metrics) for influencing Service Health
when both SiteScope events and metrics are reported to Service Health,
according to the specific use case. For details, see "BSM Service Health
Preferences" in Using SiteScope.

17
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Recommended for:
» Topology-based event
correlation rules.

» Drill downs from events
to views and related ClIs.

BSM. . What to Use SlteScop.e Where to Get Details
Application Integration
Operations Events (required) HP For details on status change or
Management Status change: Operations alert events, see "How to Enable
Manager SiteScope to Send Events to
> Use if you want to HPOM or BSM’s Operations
manage raw (low-level) Management" in Using SiteScope
events.
» These events affect
services.
Alerts:
» Use if you want to
manage alerts as events.
» These events do not
affect services. You need
to select the event or
metrics reporting mode
for Service Health. For
details, see Service
Health above.
Events generated from
health indicators: For details on events generated
by health indicators, see
> Use if you create "Business Rule Repository
customized calculation Overview" in Using Service Health
rules for metrics in in the HP Business Service
Service Health. Management Documentation
» Use for earlier versions Library.
of SiteScope (10.x) that
report metrics to BSM.
Topology BSM "HP Integration Settings" in

Using SiteScope

(To report topology, make sure
the Report monitor and related
Cl topology check box is selected
in BSM Integration Data and
Topology Settings for each
monitor instance)

18
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BSM. . What to Use SlteScoRe Where to Get Details

Application Integration

Performance Metrics (using the HP "How to Enable SiteScope to

Perspective Tab | Operations Manager Operations Report Metrics to the HP

(the graphing Integration) Manager Operations Agent" in Using

component in SiteScope

Operations ., - .

Management) Topology BSM HP Intfzgratlon Settings" in

(required) Using SiteScope
(To report topology, make sure
the Report monitor and related
Cl topology check box is selected
in BSM Integration Data and
Topology Settings for each
monitor instance)
Troubleshooting

» For topology reporting issues, see "Business Service Management

Topology Issues" on page 27.

» For Operations Manager Event Integration issues, see "Operations

Manager Event Integration Issues" on page 34.

» For BSM Metrics integration issues, see "Business Service Management

Metrics Integration Issues" on page 43.

» For Operations Manager Metrics Integration issues, see "Operations

Manager Metrics Integration Issues" on page 48.

» For CI downtime issues, see "Business Service Management CI Downtime

Issues" on page S1.

Note: Depending on the integration option, the suggested troubleshooting
might be applicable to specific HPOM or BSM applications only.

19
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Integrating SiteScope with Operations
Manager Applications

The purpose of this section is to provide best practices for using and
configuring the HP Operations Manager integration for sending events to
HP Operations Manager (HPOM) and reporting metrics to HP Performance
Manager (HPOM reporting component).

Note: For recommendations on integrating SiteScope with BSM or HPOM,
see "Integrating SiteScope with Business Service Management or Operations
Manager" on page 235.

This section includes:

> "Integration Benefits" on page 21
> "Integration Prerequisites" on page 22
> "Integration Options and Details" on page 23

» "Troubleshooting" on page 24

Integration Benefits

» SiteScope works together with HPOM to provide a powerful combination
of agentless and agent-based infrastructure management.

» SiteScope can communicate with HPOM using the HP Operations agent,
which is installed on the SiteScope server. The agent enables SiteScope to
integrate both events and metrics data.

21
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» SiteScope sends events by writing them to a log file which is
monitored by the HP Operations agent. The agent reads the data and
converts it to common events, which it forwards to the HPOM

management server.

» SiteScope stores the data in the HP Operations agent data storage,
which is collected by Performance Manager and used in Performance

Manager graphs.

Integration Prerequisites

The following are required to enable the integration:

Prerequisites

Where to Get Details

The HP Operations agent must be installed on
the SiteScope server. If the agent is used only for
integrations (not for monitoring), ignore the
request from HPOM for the agent license.

The agent can be installed during SiteScope
installation, or after SiteScope is installed using
the SiteScope Configuration Tool.

HP SiteScope Deployment
Guide PDF

For HP Operations Manager for Windows 8.1x,
patch OMW_00071 is required to support the
Node discovery feature in SiteScope-HPOM event
integration.

The Patches page on the HP
Software Support site

For HP Operations Manager for UNIX/Linux
9.10, patch 9.10.200 is required to support the
Node discovery feature in SiteScope-HPOM event

integration.

The Patches page on the HP
Software Support site
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Integration Options and Details

The following SiteScope-HPOM integration options are available. Choose
the most suitable for the monitoring environment that exists in your

organization.
Application What to Use Where to Get Details
HP Operations | Events "How to Enable SiteScope to

Manager

» Status change: If you

want to manage raw
(low-level) events.

» Alerts: If you want to

manage alerts as events.

Discovery Policies:

» Node discovery policy

(recommended).
Advantage:
Automatically maps
SiteScope events to
nodes created in HPOM
for each node monitored
by SiteScope.

Note: For nodes
monitored by SiteScope
only, you can ignore the
request from HPOM for
a Target Connector
license.

Monitor discovery
policy (not required).
Advantage:
Automatically maps
SiteScope events to
SiteScope monitors in
HPOM Service
Navigation maps.

Send Events to HPOM or BSM's
Operations Management" in
Using SiteScope

Note: For details on the
discovery policies, see "Sending
Events" in Using SiteScope, and
expand Discovery Scripts and
the Drill Down User for Viewing
HPOM Events.

23
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Application What to Use Where to Get Details
HP Metrics (required) "How to Enable SiteScope to
Performance Report Metrics to the HP
Manager Operations Agent" in Using
SiteScope
Troubleshooting

» For Operations Manager Event Integration issues, see "Operations
Manager Event Integration Issues" on page 34.

» For Operations Manager Metrics Integration issues, see "Operations
Manager Metrics Integration Issues" on page 48.

Note: Depending on the integration option, the suggested troubleshooting

might be applicable to specific HPOM or BSM applications only.
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Integrating SiteScope with Business
Service Management or Operations
Manager

The following are recommendations for integrating SiteScope with Business
Service Management (BSM) or HP Operations Manager (HPOM):

» [t is recommended to integrate SiteScope directly with BSM’s Operations
Management rather than with HPOM.

» If your deployment prevents you from integrating directly with
Operations Management in BSM, or you want to get event pre-processing
in HPOM before forwarding SiteScope events to Operations Management,
you should integrate SiteScope with HPOM.

Note: Even if you are integrating SiteScope with HPOM, it is
recommended to integrate SiteScope directly with BSM and to configure
SiteScope to report topology to BSM (a System Availability Management
license is required). Reporting topology provides topology-based event
correlation rules and drill down from events to views and related Cls. You
can report topology to BSM with or without metrics. If you do not want
SiteScope metrics to be used in System Availability Management, Service
Level Management, and so forth, report topology without metrics.

For details on integrating SiteScope with BSM, see "How to Configure the
Integration Between SiteScope and BSM" in Using SiteScope.

25
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Troubleshooting

» For topology reporting issues, see "Business Service Management
Topology Issues" on page 27.

» For Operations Manager Event Integration issues, see "Operations
Manager Event Integration Issues" on page 34.

» For BSM Metrics integration issues, see "Business Service Management
Metrics Integration Issues" on page 43.

» For Operations Manager Metrics Integration issues, see "Operations
Manager Metrics Integration Issues" on page 48.

» For CI downtime issues, see "Business Service Management CI Downtime
Issues" on page S1.

Note: Depending on the integration option, the suggested troubleshooting
might be applicable to specific HPOM or BSM applications only.
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Troubleshooting SiteScope Integration
Issues

This section describes troubleshooting when integrating SiteScope with
HP Business Service Management (BSM) and HP Operations Manager
(HPOM) products.

» Business Service Management Topology Issues on page 27

» Operations Manager Event Integration Issues on page 34

> Business Service Management Metrics Integration Issues on page 43
» Operations Manager Metrics Integration Issues on page 48

» Business Service Management CI Downtime Issues on page 51

Business Service Management Topology Issues

This section describes troubleshooting and limitations when SiteScope is

integrated with BSM and enabled to report monitor and related CI topology

to BSM.

This section includes:

"Opening Logs in SiteScope in Debug Mode" on page 28
"Opening Logs in BSM in Debug Mode" on page 31

"No Topology Reported" on page 32

"RTSM Troubleshooting" on page 33

Y Y Y Y Y

"Where to Configure the Port to Which Data Flow Reports" on page 33

27
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Opening Logs in SiteScope in Debug Mode

The following log files in SiteScope contain information relating to the BSM
integration. Open the relevant log files in debug mode using the
instructions listed below.

> SiteScope\logs\bac_integration\bac_integration.log
> SiteScope\logs\bac_integration\discovery.log
> SiteScope\logs\bac_integration\probeGW-taskResults.log

> SiteScope\logs\bac_integration\topology_queue_consumer.log

To open logs in SiteScope in debug mode:

1 In the <SiteScope root directory>\conf\core\Tools\log4j\Plainjava
folder, open the bac_integration.properties file and change the debug
level to the following appenders:

# discovery logger
log4j.category.com.hp.ucmdb.discovery=DEBUG, discovery.appender
log4j.additivity.com.hp.ucmdb.discovery=false

# Change ${loglevel} to DEBUG to view topology sent to BAC
log4j.category.com.hp.ucmdb.discovery.probe.services.dynamic.core.TopologyD
ynamicService=DEBUG, discovery.appender
log4j.additivity.com.hp.ucmdb.discovery.probe.services.dynamic.core.TopologyD
ynamicService=false

# Jython logger
log4j.category.PATTERNS_DEBUG=DEBUG, discovery.appender
log4j.additivity. PATTERNS_DEBUG-=false
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2 Add the following appender to the probeGW-taskResults.log file:

TR R R R R R R R
R

# Topology task results
R R R R
HHHHHE

log4j.category.ProbeTaskResultsLog=DEBUG, PROBE_TASK_RESULT_FILE
log4j.additivity.Probe TaskResultsLog=false

log4j.appender.PROBE_TASK_RESULT_FILE=org.apache.log4j.RollingFileAppend
er

log4j.appender.PROBE_TASK_RESULT_FILE.MaxFileSize=10MB
log4j.appender.PROBE_TASK_RESULT_FILE.MaxBackuplndex=5
log4j.appender.PROBE_TASK_RESULT_FILE.File=../${log.file.path}/probe GW-
taskResults.log

log4j.appender.PROBE_TASK_RESULT_FILE.Threshold=DEBUG
log4j.appender.PROBE_TASK_RESULT_FILE.Append=true
log4j.appender.PROBE_TASK_RESULT_FILE.layout=org.apache.log4j.PatternLayo
ut

log4j.appender.PROBE_TASK_RESULT_FILE.layout.ConversionPattern=<%d> %-
4r [%-5p] (%F:%L) - %om%n
log4j.appender.PROBE_TASK_RESULT_FILE.encoding=UTF-8

29
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3 Add the following appender for the log topology_queue_consumer.log:

TR T R R R R R
HHHH I

# Topology queue consumer printer

R R R R
HHHEHHHHHIHE

log4j.category.TopologyQueueConsumer=DEBUG,
topology.queue.consumer.appender
log4j.additivity. TopologyQueueConsumer=false

log4j.appender.topology.queue.consumer.appender=org.apache.log4j.RollingFileAp
pender
log4j.appender.topology.queue.consumer.appender.File=../${log.file.path}/topology
queue_consumer.log
log4j.appender.topology.queue.consumer.appender.MaxFileSize=1000KB
log4j.appender.topology.queue.consumer.appender.MaxBackupIndex=5
log4j.appender.topology.queue.consumer.appender.layout=org.apache.log4j.Pattern
Layout
log4j.appender.topology.queue.consumer.appender.layout.ConversionPattern=%d
[%t] (%F:%L) %-5p - %m%n
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Opening Logs in BSM in Debug Mode

The following log files in BSM contain information relating to the
integration with SiteScope. Open the relevant log files in debug mode using
the instructions listed below.

> <BSM root directory>\log\odb\odb\mam.autodiscovery.log
» <BSM root directory>\log\odb\odb\cmdb.reconciliation.log

» <BSM root
directory>\log\odb\odb\cmdb.reconciliation.datain.ignored.log

» <BSM root directory>\log\odb\odb\discovery-servlet.log
To open logs in BSM (on the Data Processing server machine in a
distributed environment) in debug mode:

Change RTSM debug level in BSM:

» <BSM root directory>\odb\conf\log\reconciliation.properties
» <BSM root directory>\odb\conf\log\mam.properties

» <BSM root directory>\odb\conf\log\mam.web.properties

31
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No Topology Reported

1 Open all SiteScope and BSM logs in debug mode. For details, see "Opening
Logs in SiteScope in Debug Mode" on page 28 and "Opening Logs in BSM
in Debug Mode" on page 31.

2 Check if there are \bin files stuck in the
<SiteScope root directory>\cache\topologyresultsData\merged
directory.

3 Check for errors in the logs in the following order:

» bac_integration.log. Topology is not sent due to general errors or
syntax problems in the scripts.

» discovery.log. Shows the complete picture of the topology reported
from SiteScope to BSM using Data Flow Management.

> topology_queue_consumer.log. Shows the topology SiteScope is trying
to send to the Data Flow probe. (It does not mean that this is the
topology that the probe client sends to the server). This log reflects
what SiteScope script intended to report to Data Flow Management.

> probeGW-taskResults.log. Shows the topology Data Flow Management
sends to the RTSM server.

> mam.autodiscovery.log. Shows the steps Data Flow Management
probe is doing on the topology reporting from SiteScope to Data Flow
Management (bulk creation) and the interaction with the RTSM server.

» cmdb.reconciliation.log. If the issues are on the RTSM server-side, it is
most likely a reconciliation issue.

» cmdb.reconciliation.datain.ignored.log. Shows topology that is
ignored by the RTSM server and not reported.

» discovery-servlet.log. Shows data from the connection opened by
SiteScope and the reply sent to SiteScope. Check for exceptions in this
log when there are issues with topology not being sent to BSM. This
log exists also on BAC 8.0.

4 It is recommended to open logs that are in XML format using an XML

editor.
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RTSM Troubleshooting

To get the properties of a CI reported to a Data Flow database with JMX:
1 Open hitp://<BSM_machine>:21212/jmx-console/ in a Web browser.

2 Click UCMDB:service= Model Services.

3 Invoke method: retrieveObjectProperties.

Where to Configure the Port to Which Data Flow Reports

The server settings are initialized in BSM in Admin > System Availability
Management > Topology Settings from the Topology receiver port or
Topology receiver SSL port boxes.
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Operations Manager Event Integration Issues

34

This section describes troubleshooting when using the HP Operations
Manager integration to send SiteScope events directly to the HPOM
management server or to Operations Management in BSM.

This section includes:

"Installation Problems" on page 34
"Integration Setup Problems" on page 36

"Problems Sending Events" on page 39

Y Y VY Y

"Node Discovery and Monitor Discovery Troubleshooting" on page 42

Tip: When referring to the integration log file, you can open it from the
SiteScope user interface (Server Statistics > Log files >
HPSiteScopeOperationsManagerintegration.log).

Installation Problems
Symptom:

An error occurred while running the HP Operations agent installation in the
SiteScope Configuration Wizard during SiteScope installation.

Troubleshooting:

1 Open the agent installation log, opc_inst.log, in the c:\Windows\Temp,
/var/tmp (Solaris) or /tmp (Linux) folder, and delete opc_inst.lock.

2 Refer to the SiteScope documentation to make sure your operating system
is supported for HP Operations agent installation.

3 Run the SiteScope Configuration Tool, and install the HP Operations
agent again (it is also recommended to restart the server).

4 Run SiteScope Configuration Tool, and uninstall the HP Operations agent
and then install it again (it is also recommended to restart the server).
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5 Manually reinstall the HP Operations agent (it is also recommended to
restart the server).

On Windows:

Uninstall the agent:

a C:\Program Files\HP\HP BTO Software\bin\OpC\install
b cscript opc_inst.vbs -remove -force

¢ From the Control Panel, uninstall the HP Operations Integration
Adapter Policy Activation package.

Install the agent:

a <SiteScope root directory>\install\components\oa\<Operating
System>

b cscript opc_inst.vbs

c Install
<SiteScope root directory>\install\components\oa_policy_signing_
tool

On UNIX:
a /opt/HP/SiteScope/install/components/oa/<operating_system>/opc_inst -
remove
where <operating_system> is either solaris, linux, or linux64.
b /opt/HP/SiteScope/install/components/oa/<operating_system>/opc_inst
¢ For Solaris:

/opt/HP/SiteScope/install/components/oa_policy signing_tool/
solaris pkgadd -a HPOprlAPA.admin -d HPOprlAPA-09.00.<version>-
Sun0S5.10-release.sparc

For Linux:

/opt/HP/SiteScopel/install/components/oa_policy_signing_tool/
rpm -i HPOprlAPA-09.00.<version>-Linux2.6-release.rpm

6 Put a new clean image on the system and install SiteScope and the HP
Operations agent again.

7 Contact your HPOM administrator for assistance.
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Integration Setup Problems
Symptom:

Any problem that occurs while trying to configure the HP Operations
Manager Integration (between connecting the agent to the HPOM/BSM
server and sending a test message).

Troubleshooting:

1 In SiteScope, open the HP Operations Manager Integration dialog box
panel (Preferences > Integration Preferences > HP Operations Manager
Integration).

2 In the HP Operations Manager Integration Main Settings pane, check the
HP Operations agent installation path.

a Click the Resolve Path button.
b Make sure the agent is installed on the path you see in this field.

» If the agent is installed on a different path, update the path
accordingly.

» If you do not see the path is resolved (probably the agent is not
installed properly), try restarting the server machine. If it does not
help, follow the troubleshooting in "Installation Problems" on
page 34.

¢ Make sure your HPOM management server or BSM Gateway host name
is typed correctly in the host field.

3 Click the Analyze button.

a If the command outputs are empty, there is a problem with the agent
installation. Follow the troubleshooting in "Installation Problems" on
page 34.

b Check that the bbcutil command output returns status=eServiceOK. If
it does not, there is a connectivity problem to your HPOM server and
you should contact your HPOM administrator for assistance.

¢ Check the opcagt -status command output. You should see a few
processes running (some can be in Aborted state—this is fine at this
stage). If they are not running, manually start the agent by running
command line: opcagt -start, or restart your server machine.
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4 Make sure your HPOM server is up and running.

5 If you are working with BSM, check your Gateway and Data Processing
Server. Run command line ovc -status. Make sure all processes are running
(in particular, the "Certificate Broker") if they do not start with ovc -start.

6 If you are working with a distributed BSM environment (in BSM 9.00 or
later), follow the procedures for initiating trust between your Gateway
and Data Processing Server, and forwarding the certificate request from
the Gateway to the Data Processing Server. For details, see "How to Enable
SiteScope to Send Events to HPOM or BSM’s Operations Management" in
Using SiteScope.

7 Click the Connect button, and make sure the command output returns:
opcactivate Info: Successfully activated OVO agent.

If it does not, contact your HPOM administrator for assistance.
8 Accept the certificate request.

» When connecting to a BSM server, follow the step for accepting the
agent connection request in "How to Enable SiteScope to Send Events
to HPOM or BSM’s Operations Management" in Using SiteScope.

» When connecting to an HPOM management server, consult your
HPOM administrator. If you do not see the certificate request, contact
your HPOM administrator.

9 Click the Analyze button.
Make sure the ovcert -check is ok, and it ends with "Check Succeeded".
Make sure ovcert -list lists some certificates.
c If there are problems with the command outputs:
» Contact your HPOM administrator, or

» Start the integration process troubleshooting from the connect
phase, or even reinstall the agent.
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10 Click the Install Policies button.

a

If you get an error here or this process is stuck with "please wait" and:

> You recently reinstalled the agent and did not restart yet, restart
your server.

» Otherwise, there is a problem with the agent (and the additional
policy activation tool package) installation. Reinstall on a clean
image.

Click the Analyze button, or check the output of the Install Policies for
the list of policies. Make sure you see the following list with all
enabled:

» HP_SiteScope_to_Operations_Manager_Integration_by_Log File
» HP_SiteScope_to_Operations Manager_Integration

» SiteScope_Hosts_Discovery

11 In the Test Message box, type a message and click Send test message.

a

Check your HPOM Event Console or Operations Management Event
Browser.

If you do not see the message in the Event Console/Browser:
» Run command line: opcmsg a=a 0=0 msg_t=xxx

» If the command is not available, something went wrong with the
process so far (either the certificate or the policies does not work).
Try to install the policies again, and if the same problem occurs
contact HP Software Support.

» If the command is executed but you still do not see the message in
the Event Console, contact your HPOM administrator for support.
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Problems Sending Events

Symptom 1:

Sending a test event from the HP Operations Manager Integration dialog
box does not reach the HPOM Event Console/Operations Management
Event Browser.

Troubleshooting:

1

In the HP Operations Manager Integration dialog box, enter a test
message in the Test message box, and click Send test message. If the test
message is not displayed in the Event Console, follow all the steps in
"Integration Setup Problems" on page 36, and then try again.

Click the Analyze button, and make sure all commands are successful (in
particular, see the list of policies installed). For details, see "Integration
Setup Problems" on page 36.

3 Click the Send Test Event button.

In the <SiteScope root directory>\logs directory, check the events log
file, HPSiteScopeOperationsManagerintegration.log. Verify the event
entry in the log file. If you do not see it, contact HP Software Support.

If you still do not see the event in the HPOM Event Console/Operations
Management Event Browser, check you are viewing the correct node in
HPOM, or are not filtering out anything in the Operations Management
Event Browser. If you still do not see the event, contact HP Software
Support.

Open the <SiteScope root>\tools\OMIntegration\Policies\F516CEC3-
3AD4-4627-9CFD-BB155B894349_data file, and check that the path
specified for HPSiteScopeOperationsManagerintegration.log is correct (it
might use an environment variable). If you make any changes here, you
must install the policies again.
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Symptom 2:

The metric status change or alert event is not displayed in the HPOM Event
Console/Operations Management Event Browser.

Troubleshooting:

1

Check if the test event is displayed in the Event Console/Browser. If it not
displayed, follow the guidelines for Symptom 1 in "Problems Sending
Events" on page 39 above.

Check that event integration is enabled in the monitor or alert
configuration settings. Change the monitor metric status, or trigger an
alert. In the <SiteScope root directory>\logs directory, check the events
log file, HPSiteScopeOperationsManagerintegration.log.

If you do not see the event entry in the log file, check you enabled event
integration correctly in the monitor or alert you are running (for details,
see "How to Enable SiteScope to Send Events to HPOM or BSM'’s
Operations Management" in Using SiteScope). If it still not in the log file,
contact HP Software Support.

If you see the event entry in the log file, but not in the Event
Console/Browser:

Check that no filter is set in the Event Browser.

b If it is a newly-created monitor, and you are filtering the related CI in

Operations Management, it is possible that the CI topology is not
reported yet. Try again in a few minutes.

¢ In HPOM legacy, make sure the event target node exists on your
console.

d Contact HP Software Support.
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Symptom 3:

You see the metric or alert event in the Operations Management Event
Browser, but it has no related CI or HI, or Indicator state or severity.

Troubleshooting:

1 Check the event attribute values in the
HPSiteScopeOperationsManagerintegration.log file located in the
<SiteScope root directory>\logs directory. Look for the HI (ETI) and CI
hint. They should look like this: CPULoad:High:80 and
SiteScope:3:123456 respectively.

a To know the attribute order in this tab separated values line, you can
send a test event before this event and compare the lines. The test
event writes the name of each attribute in its order.

b If the CI Hint or HI hint are unknown, empty, or look different than
the example, there is a problem with the SiteScope configuration.

» Check that the SiteScope is registered to BSM.

» Check that the monitor thresholds have indicator states assigned to
them, or that your alert has some ETI and ETI state set.

» Check the preference setting for reporting SiteScope data in the
monitor configuration is set to Events (in HP Integration Settings >
BSM Service Health Preferences).

2 If everything looks fine in the log file in SiteScope, open the event in the
Operations Management Event Browser.

a In the General tab, check the related Cl attribute. If you do not see the
related CI, select the Resolver tab and check the Status field.

» Check if there is information about the CI resolution failure.

» Check that the monitor topology is available in the RTSM (you can
check this in the System Hardware or System Monitors views).

Note: If this is a newly-created monitor, it will take few minutes for
the topology to arrive and the event to be assigned with a related CI.
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b In the General tab, if you see the related Cl but Event Type Indicator is
empty:
» Select the Resolver tab and check the ETI Hint attribute value sent

by SiteScope. If it is empty or unknown, check your SiteScope
configuration.

» If the value exists but does not show up in Event Type Indicator in
the General tab, there was a problem when applying the indicator to
the CI. Check out Service Health or Operations Management for
support.

Node Discovery and Monitor Discovery Troubleshooting

Node Discovery:

» If you are using HP Operations Manager for Windows 8.1x, patch
OMW_00071 is required to support the Node discovery feature in
SiteScope-HPOM event integration.

» If you are using HP Operations Manager for UNIX/Linux 9.10, patch
9.10.200 is required to support the Node discovery feature in SiteScope-
HPOM event integration.

Problems with Node discovery:

1 Click the Analyze button in the HP Operations Manager Integration
dialog box. Make sure you see the SiteScope_Hosts_Discovery policy
installed and enabled.

2 Check that your event configuration is set. Send a test event and make
sure you see it in the HPOM Event Console on the SiteScope node.

New nodes are reported within 5 minutes from the time they started to
being monitored by SiteScope monitors.

The discovery policy runs SiteScope scripts that generate XML consumed
by the policy. Each run is logged in the following log:
%OvDataDir%\log\System.txt (for Linux <SiteScope
Server>/var/opt/OV/log).
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3 You can invoke the process manually, by running the following
commands:

ovagtrep -run "SiteScope_Hosts_Discovery"
ovagtrep -publish

Monitor Discovery:

» To enable HPOM Service Navigator to view SiteScope groups and
monitors in HPOM service maps, follow the configuration instructions in
"How to Enable the SiteScope Monitor Discovery Policy" in Using
SiteScope.

Business Service Management Metrics Integration Issues

This section describes troubleshooting when working with the BSM metrics
integration if CI statuses are not displayed in Service Health.

This section includes:

» "Check HI/KPI Assignment" on page 44
> "Check that SiteScope data is not ignored by BSM" on page 44
» "Check CI resolution" on page 46
>

"If there are no HIs on the relevant CI (in case the problem is with the
monitored CI and not the monitor/measurement)" on page 46

» "If there are no KPIs on the relevant CI (in case the problem is with the
monitored CI and not the monitor/measurement)" on page 47

» "If there are no HIs/KPIs and everything seemed to work in the previous
two steps" on page 47
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1 Check HI/KPI Assignment

If CI statuses are not displayed in Service Health, check if HIs and KPIs are
assigned to the relevant CI:

a In BSM, select Admin > Service Health > Cl indicators, expand the

Monitors folder, and select one of the following views: System
Monitors, System Hardware Monitoring, or System Software
Monitoring.

In the view you have selected, check if there are HIs and KPIs assigned
to the relevant CI, as follows:

» System Monitors view: SiteScope Monitor or SiteScope Measurement
CI

» System Hardware Monitoring view: Node or Computer CI

» System Software Monitoring view: Running Software CI

2 Check that SiteScope data is not ignored by BSM

If HIs and KPIs are assigned to the relevant CI, check if SiteScope sends
data and that the data is not ignored by BSM.

a Run the relevant monitor in SiteScope.

b On the BSM machine, open the wdelgnoredSamples.log located in

<BSM root directory>\log\wde folder. If this log includes samples of
the monitor you have just run, or you see many ignored samples, this
means SiteScope is sending the wrong data.

If you do not see the relevant SiteScope sample, look for it in the
wdePublishedSamples.log and check that Eti_id and ci_hint are not
null.
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d If you cannot find the SiteScope sample in the wde logs in BSM, check
in SiteScope if the sample was generated. Open the
bac_integration.properties file located in
<SiteScope root directory>\conf\core\Tools\log4j\Plainjava and add
the following to the end of the file:

R R R
HEHHHHEHH

# Sample printer

R R R R R
HEHHHHIHEHHR

log4j.category.SamplePrinter=DEBUG, samples.appender
log4j.additivity.SamplePrinter=false

log4j.appender.samples.appender=org.apache.log4j.RollingFileAppender
log4j.appender.samples.appender.File=../${log.file.path}/samples.log
log4j.appender.samples.appender.MaxFileSize=1000KB
log4j.appender.samples.appender.MaxBackuplndex=5
log4j.appender.samples.appender.layout=org.apache.log4j.PatternLayout
log4j.appender.samples.appender.layout.ConversionPattern=%d [%t] (%F:%L)
%-5p - %m%n

e Run the monitor, and check the samples.log file in the
<SiteScope root directory>\logs\bac_integration directory.
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3 Check Cl resolution

If HIs and KPIs are assigned to the relevant CI, and samples are not
ignored by the wde logs in BSM, check CI resolution (in case the problem
is with the monitored CI and not the monitor or measurement).

Run the relevant monitor in SiteScope.

b On the BSM machine, open the cir_enrichment.log file located in the
<BSM root directory>\log\wde folder, and check if there are badHint
or Cl not found messages.

Note: To change the log file to debug mode, open the
cir_enrichment_service.properties file located in the

<BSM root directory>\conf\core\Tools\log4j\wde folder and change
loglevel to loglevel=-DEBUG.

4 If there are no His on the relevant Cl (in case the problem is

with the monitored Cl and not the monitor/measurement)

If the relevant CI does not have any HIs, in SiteScope, check the indicator
mappings in the monitor user interface (HP Integration Settings >
Indicator Settings).

» If the mapping seems correct, go to the correct SiteScope Monitor CI or
SiteScope Measurement CI in RTSM in BSM, and check that you can
see the HI ID in the health_indicator_list attribute.

» If you can see it, check that you can see the monitored CI connected to
this SiteScope Monitor or Measurement CI with a monitored_by link.

» If it seems fine, check that HPOM (HPOpr) content packs are deployed
(in Admin > Platform > Content Packs), and that you can see the
indicators you expect to get in it (in most cases, you will find it in the
HPOprinf package).
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5 If there are no KPIs on the relevant Cl (in case the problem is
with the monitored Cl and not the monitor/measurement)

If the relevant CI does not have any KPIs, check if the HPOM content
pack has KPI assignments.

In BSM, select Admin > Service Health > Assignments > KPI
Assignments.

In the CI Types tree, drill down to the relevant CI (for example,
Infrastructure Element > Node > Computer), and check if the CIT has a
KPI assignment defined. KPI assignments appear in the right pane.

6 If there are no His/KPIs and everything seemed to work in
the previous two steps

Try to resynchronize the HI and KPI assignments on the problematic Cls,
based on their CI types.

a

In BSM, select Admin > Service Health > Assignments > Health
Indicator Assignments.

Select the problematic CI type (for example, computer), and select the
assignment you HI want to run.

Click the Synchronize Cl Type button.

When this is done, perform the same action on the KPI assignment
using the KPI Assignments tab.
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Operations Manager Metrics Integration Issues

This section describes troubleshooting when using the HP Operations
Manager integration to make SiteScope metrics data available to HP
Performance Manager or to Performance Perspective in BSM’s Operations
Management.

This section includes:

"SiteScope and HP Operations Agent Configuration" on page 48
"Health Monitors Errors" on page 50

"HP Performance Manager Configuration" on page 50

Y VY VY Y

"CI Resolution does not work ("BadHint error" in the cir_enrichment.log)"
on page 50

SiteScope and HP Operations Agent Configuration

Check the HP Operations Agent Configuration

1 Check the status of the HP Operations agent installed on the SiteScope
server status by running the following command: opcagt -status

The expected output is:

C:\Documents and Settings p== = opcagt =status
AGENT . EA Aborted
ouo e AGENT . Ef ( J Running

oyo S5 AL rceptor AGENT . EfA Running

If opcacta or opcmsgi are not running, try to restart the agent by running:
opcagt -stop
opcagt -start

2 Select Preferences > Integration Preferences, and select an existing or
create a new HP Operations Manager Integration. Verify that the Enable
sending events check box is selected.

3 In the HP Integration Settings for the monitor, Verify that the Report
metrics to HP Operations agent check box is selected.

4 Run the monitor, and wait for about a minute.
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5 Run the following command to check if the agent data store contains the
data:

set CODAMAGIC=0X05201993
ovcodautil -obj -ds AGENTLESS

You should receive object names from AGENTLESS data source (similar to
the following):

ovcodauntil —obj —ds AGENTLESS

JRY
JALDISK

QUEUES

URL__MONITOR
APACHE

8 QUERY

ORACLE

UHWARE

ORACLEYIAS _HTTP_SERVER

Data source: AGENTLESS
MunMetrics = 128

To dump the summarized last record for AGENTLESS data source, run the
following command:

ovcodautil -dumpds AGENTLESS

Check the Relevant SiteScope Logs

Check the following logs that are available from the <SiteScope root
directory>\logs directory:

> error.log
» RunMonitor.log
> om_metric_integration.log

» data_integration.log
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Health Monitors Errors

In the SiteScope monitor tree, expand Health and click Log Event Checker.

» If the Failed to report data to HP OM Agent counter is in error, SiteScope
failed to connect or report data to the HP Operations agent using Java
APL. For more information, see the oa_metric_integration.log file in the
<SiteScope root directory>\logs directory.

» If the Generic Data Integration queue exceeded allowed size counter is in
error, the queue of metrics waiting to be sent is oversized and some
metrics were dropped to maintain SiteScope stability. For more
information, data_integration.log file in the <SiteScope root
directory>\logs directory.

HP Performance Manager Configuration

1 On the Performance Manager server, open the OVPMconfig.ini file in the
%ovdatadir%)\shared\server\conf\perf directory.

2 Update the SiteScope server details as follows:
» [SITESCOPE]
» SERVER = servername
» NODEGROUP = Agentless

3 Restart the HP Openview Tomcat(B) service.

CI Resolution does not work ("BadHint error" in the
cir_enrichment.log)

1 Go to Admin > Platform > Infrastructure Setting.

2 In the Application dropdown, select End User/System Availability
Management.

3 In the SiteScope Cl Resolver Settings, check for TQL Queries value.
The default value is Cls Monitored by SiteScope.
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4 Go to Admin > RTSM Administration and check for Cls Monitored by
SiteScope query results. If you do not get the requested CI in the query
results, CI resolution will not find it as well.

Possible problem: CI has missing attributes orthe SiteScope monitor CI is
not connected to any monitored CI.

Business Service Management Cl Downtime Issues

This section describes troubleshooting CI downtime issues when SiteScope is
integrated with BSM.

This section includes:

» "Troubleshooting CI Downtime (BSM-side)" on page 51

» "Troubleshooting CI Downtime (SiteScope-side)" on page 52

Troubleshooting Cl Downtime (BSM-side)

If the SiteScope monitor does not enter downtime (it is still running, or is
sending alerts while it should not be according to the downtime
configuration), perform the following checks on SiteScope and BSM:

1 Check SiteScope reported topology to BSM. In BSM, select Admin > RTSM
Administration, and check the node and monitor ClIs.

2 Logs:

» Open <BSM root
directory>\conf\core\Tools\log4j\Plainjava\topaz.properties and
change the debug level to the following appender:

log4j.category.com.mercury.topaz.sitescopetmc=DEBUG, aims.appender
» Open the aims.ejb.log file located in <BSM root
directory>\log\EJBContainer and search for "downtime" string. Check

whether your downtime was created, which CIs were affected by it,
and when a downtime request was made from SiteScope.
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Troubleshooting Cl Downtime (SiteScope-side)

If the SiteScope monitor is still running after configuring downtime on a
specific node using the stop monitoring option, perform the following
checks on SiteScope:

1 In Preferences > Infrastructure Preferences > General Settings, check the
Enable downtime mechanism setting is enabled.

2 Check the following logs:
> <SiteScope root directory>\logs\audit.log

> <SiteScope root directory>\logs\downtime.log

To open these logs in debug mode:

a In the <SiteScope root directory>\conf\core\Tools\log4j\Plainjava
folder, open the log4j.properties file.

b Change the debug level to the following appenders:

# Downtime logger
log4j.category.com.mercury.sitescope.integrations.bac.downtime=DEBUG,
downtime.appender
log4j.additivity.com.mercury.sitescope.integrations.bac.downtime=false
log4j.category.com.mercury.sitescope.platform.downtime=DEBUG,
downtime.appender
log4j.additivity.com.mercury.sitescope.platform.downtime=false
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