Summary
In Service Manager 9.2, special characters "less than" (>) and "greater than" (<) are not displayed in QBE lists in the web client. Text following these characters may also not be displayed.
Error
This does not occur in the Windows client. Note, however, that defect QCCR1E28000 is currently open for the issue where the first character is removed from a field if it is a special character. This document refers to cases where the Windows and web clients show different results, even taking into account this defect.
The behaviour can be seen in the following example, performed in an out-of-the-box Service Manager 9.20 system: - QCCR1E60469
- Login to the Windows client as "falcon"
- System Navigator ->Incident Management ->Search Incidents
- Enter a Status value of "Open" ->Search
- Select an open Incident for testing, e.g. IM10004
- Change the text in the Title field to <Text>Test and add some update text
- Select Save & Exit and check that the text is displayed correctly in the Title field in the QBE list
- Repeat steps 5 and 6 using the following text for the Title field:
- Text<Test
- Repeat the tests using the web client
- <Text>test is displayed Test
- Text<Test is displayed as Text
Cause
This has been identified as a product defect
Fix
Defect QCCR1E60469 has been logged to address this issue