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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

Visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. 
As a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. 
Many also require a support contract.  To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
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Welcome to This Tutorial

Welcome to HP Application Lifecycle Management (ALM). ALM empowers 
IT to manage the core application lifecycle, from requirements through 
deployment, granting application teams the crucial visibility and 
collaboration needed for predictable, repeatable, and adaptable delivery of 
modern applications.

This tutorial is a self-paced guide that instructs you how to use the ALM 
application to organize and manage all phases of the application lifecycle. 
To successfully complete this tutorial, you should perform the tutorial in the 
order in which the information is presented.

Note: To learn how to work with the HP ALM Performance Center Edition, 
refer to the HP ALM Performance Center Quick Start.
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How This Tutorial Is Organized 

This tutorial contains the following lessons: 

 Lesson 1 Introducing HP ALM

Introduces you to the application lifecycle management process, and 
familiarizes you with the ALM user interface and the sample Mercury Tours 
Web site.

 Lesson 2 Specifying Releases and Cycles

Shows you how to define releases and cycles and monitor their progress and 
quality.

 Lesson 3 Specifying Requirements

Shows you how to define requirements, view the requirements tree, and 
convert requirements to tests.

 Lesson 4 Planning Tests

Shows you how to create a test plan tree, define test steps, define test 
configurations, link test configurations to requirements, and automate 
manual tests.

 Lesson 5 Running Tests

Shows you how to define test sets, schedule test runs, and run manual and 
automated tests.

 Lesson 6 Adding and Tracking Defects

Shows you how to add new defects, update defects, and manage defects.

 Lesson 7 Alerting on Changes

Shows you how to keep track of changes made to your requirements, tests, 
and defects as you perform your project testing.
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 Lesson 8 Analyzing ALM Data

Shows you how to monitor the application lifecycle management process by 
creating reports and graphs.

 Lesson 9 Creating Libraries and Baselines

Shows you how to create libraries and baselines, and how to compare 
baselines to track changes in your project.

 Lesson 10 Customizing Projects

Shows you how to set up project users, and how to create project fields and 
lists.

 Lesson 11 Conclusion

Summarizes the ALM application lifecycle management process and 
suggests the steps to consider for each phase.
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Before You Begin

To work with this tutorial, consider the following specifications:

ALM Editions HP ALM is also available in three editions which provide 
subsets of ALM functionality — HP Quality Center Starter 
Edition, HP Quality Center Enterprise Edition, and HP ALM 
Performance Center Edition.

This tutorial assumes that you are working in HP ALM or HP 
Quality Center Enterprise Edition. Some of the lessons and 
exercises in this tutorial are not applicable if you are working 
in HP Quality Center Starter Edition. To determine which 
edition you are using, contact your ALM site administrator.

Note: If you are working with the HP ALM Performance 
Center Edition, refer to the HP ALM Performance Center Quick 
Start. 

ALM_Demo 
Project

➤ The demo project is available with the ALM Platform 11.00 
installation DVD and is obtained by importing the 
ALM_Demo.qcp file using Site Administration. For more 
information, refer to the HP Application Lifecycle 
Management Installation Guide.

➤ To ensure that you get the same results as the ones specified 
in this tutorial, make sure that you work on a new copy of 
the ALM_Demo project. For more information, contact 
your ALM site administrator.

➤ By default, the demo project is version control enabled. 
This tutorial assumes that your demo project is version 
control enabled. For more information on version control, 
refer to the HP Application Lifecycle Management User Guide.

Mercury Tours ➤ The Mercury Tours is a sample application that simulates a 
Web-based site for reserving flights, hotel rooms, car 
rentals, cruises, and vacation deals.

➤ Mercury Tours is installed during the installation of ALM 
on a server machine. For more information, refer to the 
HP Application Lifecycle Management Installation Guide.
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Documentation Library

The Documentation Library is an online help system that describes how to 
use ALM. You can access the Documentation Library in the following ways:

➤ Click Documentation Library in the ALM Help menu to open the 
Documentation Library home page. The home page provides quick links 
to the main help topics.

➤ Click Help on this page in the ALM Help menu to open the 
Documentation Library to the topic that describes the current page.

HP QuickTest 
Professional

➤ To run the automated tests in this tutorial, 
QuickTest Professional must be installed.

➤ To integrate ALM with QuickTest Professional, you must 
download and install the HP QuickTest Professional add-in 
and the HP Quality Center Connectivity add-in from the 
HP Application Lifecycle Management Add-ins page. For 
more information on ALM add-ins, refer to the 
HP Application Lifecycle Management Installation Guide.

HP Sprinter ➤ To run manual tests in this tutorial, you can use Manual 
Runner, HP Sprinter, or both. For enhanced functionality 
and a variety of tools to assist in the manual testing 
process, run manual tests with Sprinter. 

➤ To run tests with Sprinter, download and install the 
Sprinter add-in from the HP Application Lifecycle 
Management Add-ins page. For more information on ALM 
add-ins, refer to the HP Application Lifecycle Management 
Installation Guide.
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Documentation Library Guides

The Documentation Library consists of the following guides and references, 
available online, in PDF format, or both. PDFs can be read and printed using 
Adobe Reader, which can be downloaded from the Adobe Web site 
(http://www.adobe.com).

Application Lifecycle Management Guides

Reference Description

Using this 
Documentation 
Library 

Explains how to use the Documentation Library and how 
it is organized.

What’s New? Describes the newest features in the latest version of 
ALM. 

To access, select Help > What's New.

Product Feature 
Movies

Short movies that demonstrate the main product 
features.

To access, select Help > Product Feature Movies.

Readme Provides last-minute news and information about ALM.

Guide Description

HP ALM User Guide Explains how to use ALM to organize and execute all 
phases of the application life cycle management process. 
It describes how to specify releases, define requirements, 
plan tests, run tests, and track defects.

HP ALM 
Administrator Guide

Explains how to create and maintain projects using Site 
Administration, and how to customize projects using 
Project Customization.

HP ALM Tutorial A self-paced guide teaching you how to use ALM to 
manage the application life cycle management process.

http://www.adobe.com
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ALM Performance Center Guides

HP ALM Installation 
Guide

Describes the installation and configuration processes for 
setting up ALM Platform.

HP Business Process 
Testing User Guide

Explains how to use Business Process Testing to create 
business process tests.

Guide Description

HP ALM Performance 
Center Quick Start

A self-paced guide giving the Performance Center user a 
high level overview of creating and running performance 
tests.

HP ALM Performance 
Center Guide

Explains to the Performance Center user how to create, 
schedule, run, and monitor performance tests. Explains 
to the Performance Center administrator how to use Lab 
Management for overall lab resource management, lab 
settings management, and system configuration.

HP ALM Performance 
Center Installation 
Guide

Describes the installation processes for setting up 
Performance Center Servers, Performance Center Hosts 
and other Performance Center components.

HP ALM Performance 
Center 
Troubleshooting 
Guide

Provides information for troubleshooting problems while 
working with HP ALM Performance Center.

HP Performance 
Center of Excellence 
Best Practices

Provides best practices for successfully building and 
operating Performance Centers of Excellence.

HP Performance 
Monitoring Best 
Practices

Provides best practices for monitoring the performance 
of applications under test.

Guide Description
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ALM Best Practices

ALM API References

Guide Description

HP ALM Database 
Best Practices Guide

Provides best practices for deploying ALM on database 
servers.

HP ALM Upgrade 
Best Practices Guide

Provides methodologies for preparing and planning your 
ALM upgrade.

HP ALM Business 
Models Module Best 
Practices Guide

Provides best practices for working with the Business 
Models module.

Guide Description

HP ALM Project 
Database Reference

Provides a complete online reference for the project 
database tables and fields.

HP ALM Open Test 
Architecture API 
Reference

Provides a complete online reference for the ALM COM-
based API. You can use the ALM open test architecture to 
integrate your own configuration management, defect 
tracking, and home-grown testing tools with an ALM 
project.

HP ALM Site 
Administration API 
Reference

Provides a complete online reference for the Site 
Administration COM-based API. You can use the Site 
Administration API to enable your application to 
organize, manage, and maintain ALM users, projects, 
domains, connections, and site configuration 
parameters.

HP ALM REST API 
Reference

Provides an online reference for the ALM REST-based API. 
You can use the REST API to access and work with ALM 
data.

HP ALM Custom Test 
Type Guide

Provides a complete online guide for creating your own 
testing tool and integrating it into the ALM 
environment.
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Additional Online Resources

The following additional online resources are available from the ALM Help 
menu:

Part Description

Troubleshooting & 
Knowledge Base

Opens the Troubleshooting page on the HP Software 
Support Web site where you can search the Self-solve 
knowledge base. Choose Help > Troubleshooting & 
Knowledge Base. The URL for this Web site is 
http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software Support Opens the HP Software Support Web site. This site 
enables you to browse the Self-solve knowledge base. You 
can also post to and search user discussion forums, 
submit support requests, download patches and updated 
documentation, and more. Choose Help > HP Software 
Support. The URL for this Web site is 
www.hp.com/go/hpsoftwaresupport.

Most of the support areas require that you register as an 
HP Passport user and sign in. Many also require a support 
contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport user ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

HP Software Web site Opens the HP Software Web site. This site provides you 
with the most up-to-date information on HP Software 
products. This includes new software releases, seminars 
and trade shows, customer support, and more. Choose 
Help > HP Software Web site. The URL for this Web site 
is www.hp.com/go/software.

Add-ins Page Opens the HP Application Lifecycle Management Add-
ins Page, which offers integration and synchronization 
solutions with HP and third-party tools.

http://h20230.www2.hp.com/troubleshooting.jsp
http://www.hp.com/go/hpsoftwaresupport
http://h20230.www2.hp.com/new_access_levels.jsp
http://h20229.www2.hp.com/passport-registration.html
http://www.hp.com/go/software
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1
Introducing HP ALM

ALM helps you organize and manage all phases of the application lifecycle 
management process, including defining releases, specifying requirements, 
planning tests, executing tests, and tracking defects.

In this lesson, you will learn about:

➤ The Application Lifecycle Management Process on page 17

➤ Starting ALM on page 18

➤ The ALM Window on page 21

➤ The Mercury Tours Sample Web Site on page 25

The Application Lifecycle Management Process

The application lifecycle management process with ALM includes the 
following phases:

Phase Description

Release 
Specifications

Develop a release-cycle management plan to help you 
manage application releases and cycles efficiently. 

Requirement 
Specifications

Define requirements to meet your business and testing 
needs. 
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Throughout the process, you can generate reports and graphs to assist you 
in “go/no-go” decisions about your application readiness.

Starting ALM

Start ALM from your Web browser using the HP ALM URL.

To start ALM:

 1 Verify tutorial prerequisites.

Before you begin the lessons in this tutorial, verify that you have the 
appropriate prerequisites. For more information, see "Before You Begin" 
on page 10.

 2 Open the Application Lifecycle Management Options window.

Open your Web browser and type your ALM URL:
http://<ALM Platform server name>[<:port number>]/qcbin. Contact your 
system administrator if you do not have the correct path.

Test Planning Based on the project requirements, you can build test 
plans and design tests. 

Test Execution Create a subset of the tests in your project designed to 
achieve specific test goals. Execute scheduled tests to 
diagnose and resolve problems. 

Defect Tracking Submit defects and track their repair progress. 

Phase Description
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The HP Application Lifecycle Management Options window opens.

 3 Open ALM.

Click the Application Lifecycle Management link.

Each time ALM is run, it checks the version. If it detects a newer version, 
it downloads the necessary files to your machine.

Notes:

➤ Windows Vista and 7: If you do not have administrator privileges on 
your machine, and a Security Warning displays, click Don’t Install. You 
will be redirected to the Install screen.

➤ If file downloads are prohibited by your browser, you can install these 
files by using the HP ALM Client MSI Generator Add-in on the More 
HP Application Lifecycle Management Add-ins page. For more 
information on add-ins, refer to the HP Application Lifecycle 
Management Installation Guide.
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The ALM Login window opens.

 4 Type a user name and authenticate.

In the Login Name box, type alex_alm.

Skip the Password box. A password was not assigned.

Click the Authenticate button. ALM verifies your user name and password 
and determines which domains and projects you can access.

 5 Log in to the project.

In the Domain list, select DEFAULT.

In the Project list, select ALM_Demo. If more than one ALM_Demo 
project is listed, contact your ALM site administrator to determine which 
project to use.

Click the Login button.

The first time you run ALM, the Welcome page opens. From the Welcome 
page, you can directly access the ALM documentation and feature movies. 
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When you log in to a project, the ALM main window opens and displays 
the module in which you were last working. In the upper-right corner of 
the window, the domain name, project name, and your user name are 
displayed.

The ALM Window

In this exercise, you will explore the ALM modules and their common 
elements. You will also learn how to navigate the online help.

To explore the ALM window:

 1 Explore the ALM modules.

Click the following sidebar buttons:

Button Description

Includes the following modules:

➤ Analysis View. Enables you to create graphs, reports, 
and Excel reports. 

➤ Dashboard View. Enables you to create dashboard 
pages, in which you can view multiple graphs in a 
single display.

Includes the following modules:

➤ Releases. Enables you to define releases and cycles 
for the application management process.

➤ Libraries. Enables you to define libraries to track 
changes in your project, reuse entities in a project, or 
share entities across multiple projects.

Includes the following modules:

➤ Requirements. Enables you to manage requirements 
in a hierarchical tree-structure. Requirements can be 
linked to other requirements, tests, or defects.

➤ Business Models. Enables you to import business 
process models, and test the quality of the models 
and their components. Access to this module is 
dependent on your ALM license.
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 2 Explore the common ALM elements.

All the ALM modules have common elements. For example, click the 
Defects sidebar button.

Includes the following modules:

➤ Test Resources. Enables you to manage test resources 
in a hierarchical tree-structure. Test resources can be 
associated with tests.

➤ Business Components. Depending on your ALM 
license, you may also have access to the Business 
Components module. This module enables subject 
matter experts to drive the quality optimization 
process using Business Process Testing, the HP test 
automation solution. For more information, refer to 
the HP Business Process Testing User Guide.

➤ Test Plan. Enables you to develop and manage tests 
in a hierarchical tree-structure. Tests can be linked to 
requirements and defects.

➤ Test Lab. Enables you to manage and run tests. After 
running tests, you can analyze the results.

Enables you to add defects, determine repair priorities, 
repair open defects, and analyze the data.

Button Description
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Each of the ALM modules contains the following key elements:

➤ ALM common toolbar. This toolbar is accessible from all modules and 
contains the following buttons:

➤ Module menu bar. Displays the menus from which you select 
commands in the current ALM module.

➤ Module toolbar. This is located below the menu bar. It contains 
buttons for frequently used commands in the current ALM module.

 3 View ALM help topics.

 a To view the help topic of the Defects module window, click the Defects 
sidebar button. The Defects module is displayed. Choose Help > Help 
on this page. The help topic opens in a separate window. 

 b To display the navigation pane, which includes the Contents, Search, 
and Favorites tabs, click the Search and Navigate button. The 
navigation pane is displayed on the left side of the page.

Button Description

Navigates to your previous/next view in ALM.

Includes commands that you can run from each of the 
ALM modules. 

Enables you to open the HP Application Lifecycle 
Management Documentation Library and other 
additional online resources. It also enables you to 
display version information for each ALM client 
component. For more information, see 
"Documentation Library" on page 11 and "Additional 
Online Resources" on page 15.

<domain, 
project, user>

Details of the current domain, project, and user.

Logs you out of your current project and returns you to 
the Application Lifecycle Management Login window. 
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 c To view the Application Lifecycle Management Documentation 
Library home page, in the Contents tab, click Home. The 
Documentation Library home page opens. 

The Documentation Library consists of guides and references, available 
online, in PDF format, or both. 

 d Under the Contents tab, click the Using This Documentation Library 
link. The Using This Documentation Library section describes how to 
navigate, use, update and print the HP ALM guides. It also describes 
additional available resources.

 e Click the Close button.
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The Mercury Tours Sample Web Site

Mercury Tours is the sample Web application used in this tutorial. It 
simulates a Web-based application for reserving flights, hotel rooms, car 
rentals, cruises, and vacation deals. Before continuing with the tutorial, 
familiarize yourself with this application.

To explore Mercury Tours:

 1 Open the Mercury Tours application.

Open a separate instance of your Web browser, and type this URL: 
http://<ALM Platform server name>[<:port number>]/mtours

The Mercury Tours home page opens.
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 2 Register with Mercury Tours.

 a Click Register. The Register page opens. 

 b Under User Information, enter any user name and password, and 
confirm your password. (Other information is not required.)

 c Click Submit. Mercury Tours confirms your registration.
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 3 Log on to Mercury Tours. 

 a Click Sign-on. The Sign-on page opens. 
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 b Type your registered user name and password. Click Submit. The Flight 
Finder page opens.

 4 Reserve a flight. 

Follow the on-screen instructions to reserve a flight. 

 5 End your Mercury Tours session. 

Click Sign-off.
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2
Specifying Releases and Cycles

You begin the application lifecycle management process by specifying 
releases and cycles. A release represents a group of changes in one or more 
applications that will be available for distribution at the same time. Each 
release can contain a number of cycles. A cycle represents a development 
and QA cycle based on the project timeline. The releases and cycles have 
defined start and end dates.

You can organize and track your upcoming releases by defining a 
hierarchical release tree containing releases and cycles. In this lesson, you 
will add a release to an existing release tree, and then add cycles to the 
release.

ALM Editions: This lesson is not available for Quality Center Starter Edition.

In this lesson, you will learn about:

➤ Defining Releases and Cycles on page 30

➤ Viewing Releases and Cycles on page 32
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Defining Releases and Cycles

In this exercise, you will define a release and then add cycles to the release. 
Releases and cycles each have start dates and end dates. The date range for a 
cycle must be contained within the date range of the release.

To define a release and its cycles:

 1 Open the ALM_Demo project.

If the ALM_Demo project is not already open, log in to the project. For 
more information, see "Starting ALM" on page 18.

 2 Display the Releases module.

On the ALM sidebar, under Management, select Releases.

 3 Create a new release folder.

 a In the releases tree, select the root Releases folder. Click the New 
Release Folder button. The New Release Folder dialog box opens.

 b In the Release Folder Name box, type Service Packs.

 c Click OK. The Service Packs release folder is added to the releases tree.

 d In the Description box in the right pane, type the following 
description for the release folder: This folder contains service pack 
releases.

 4 Add a release.

 a In the releases tree, make sure that the new Service Packs release folder 
is selected.

 b Click the New Release button. The New Release dialog box opens.

 c In the Name box, type Service Pack 1.

 d In the Start Date box, click the down arrow and select yesterday’s date. 
In the End Date box, click the down arrow and select the date two 
months from today’s date. 

 e In the Description box, type the following description for the release: 
This release is the first service pack release.

 f Click OK. The Service Pack 1 release is added to the Service Packs 
release folder.
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 5 Add a cycle to the release.

 a In the releases tree, make sure that the Service Pack 1 release is 
selected.

 b Click the New Cycle button. The New Cycle dialog box opens.

 c In the Name box, type Cycle 1 - New Features.

 d In the Start Date box, click the down arrow and select yesterday’s date. 
In the End Date box, click the down arrow and select the date a month 
from today’s date. 

 e In the Description box, type the following description for the cycle: 
This cycle tests new features added for this service pack.

 f Click OK. The Cycle 1 - New Features cycle is added to the Service Pack 
1 release.

 6 Add a second cycle to the release.

 a In the releases tree, right-click the Service Pack 1 release and choose 
New Cycle. The New Cycle dialog box opens.

 b In the Name box, type Cycle 2 - Full.

 c In the Start Date box, click the down arrow and select the date one 
month and a day from today’s date. In the End Date box, click the 
down arrow and select the date two months from today’s date. 

 d In the Description box, type the following description for the cycle: 
This cycle fully tests all application features.

 e Click OK. The Cycle 2 - Full cycle is added to the Service Pack 1 release.
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Viewing Releases and Cycles

You can view the status of your releases and cycles. ALM shows a high-level 
overview of the progress of the currently selected release or cycle. It also 
shows the number of defects opened over the course of the currently 
selected release or cycle. You can also view the number of outstanding 
defects. 

In this exercise you will learn how to display the progress and graphs of a 
selected release and cycle. 

To view releases and cycles:

 1 Make sure the Releases module is displayed.

On the ALM sidebar, under Management, select Releases.

 2 Display the Progress graph for the Service Pack 1 release.

In the releases tree, select the Service Pack 1 release, located in the Service 
Packs release folder. In the right pane, click the Status tab. The Progress 
tab is displayed by default.
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The Progress tab displays the progress of the release based on requirement 
coverage, elapsed and remaining time, and actual and remaining test 
instances to run. As you have not yet created requirements or tests, the 
information in the Coverage Progress graph indicates 0% progress.

 3 Display the Progress graph for a cycle.

In the releases tree, select the Cycle 1 - New Features cycle, located in the 
Service Pack 1 release. 

In the right pane, click the Progress tab. You can see that the information 
available is similar to that available for the release, but at the cycle level. 
As in the case of the release, you have not yet created requirements and 
tests, therefore the information in the Coverage Progress graph indicates 
0% progress.
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3
Specifying Requirements

Requirements describe in detail what needs to be solved or achieved to meet 
the objectives of your application under development.

You define the requirements in ALM by creating a requirements tree in the 
Requirements module. This is a hierarchically graphical representation of 
your requirements. You can group and sort requirements in the tree, 
monitor the progress in meeting requirements, and generate detailed reports 
and graphs. 

In this lesson, you will create requirements in an existing requirements tree. 
You will then assign the requirements to a cycle in the releases tree. You will 
also learn how to convert requirements to tests.

In this lesson, you will learn about:

➤ Defining Requirements on page 36

➤ Viewing Requirements on page 41

➤ Converting Requirements to Tests on page 45
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Defining Requirements

In this exercise, you will define requirements for testing the functionality of 
reserving cruises in Mercury Tours. 

ALM Editions: If you are using Quality Center Starter Edition, multiple 
requirement types are not supported. In addition, fields and commands 
related to cycles and releases are not available.

To define a requirement:

 1 Open the ALM_Demo project.

If the ALM_Demo project is not already open, log in to the project. For 
more information, see "Starting ALM" on page 18.

 2 Display the Requirements module.

 a On the ALM sidebar, under Requirements, select Requirements.

 b Choose View > Requirements Tree to display requirements in a tree.

 3 Select the Mercury Tours Application requirement.

Expand the Requirements root requirement and select the Mercury Tours 
Application requirement. 
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 4 Create a new requirement.

 a Click the New Requirement button. The New Requirement dialog box 
opens.

 b In the Requirement Name box, type Cruise Reservation.

 c In the Requirement Type box, select Functional. Each requirement 
belongs to a requirement type. The requirement type to which a 
requirement belongs determines which fields are available for the 
requirement. Your project administrator can modify existing types and 
add new types. 

ALM Editions: If you are using Quality Center Starter Edition, ignore 
this step.
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 d In the Details tab, type or select the following: 

Priority: 4-Very High

Product: Mercury Tours Web Site

 e Click Submit. 

 f Click Close to close the New Requirement dialog box. The Cruise 
Reservation requirement is added to the requirements tree under the 
Mercury Tours Application requirement.

 5 Add the Cruise Search child requirement.

 a In the requirements tree, make sure that the new Cruise Reservation 
requirement is selected.

 b Click the New Requirement button to add a requirement below Cruise 
Reservation. The New Requirement dialog box opens.

 c In the Requirement Name box, type Cruise Search.

 d In the Requirement Type box, select Functional. 

ALM Editions: If you are using Quality Center Starter Edition, ignore 
this step.

 e In the Details tab, type or select the following: 

Priority: 4-Very High

Product: Mercury Tours Web Site

 f Click Submit. 

 g Click Close to close the New Requirement dialog box. The Cruise 
Search requirement is added as a child of the Cruise Reservation 
requirement.
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 6 Add the Cruise Booking child requirement.

 a In the requirements tree, make sure that the Cruise Reservation 
requirement is selected.

 b Click the New Requirement button to add a requirement below Cruise 
Reservation. The New Requirement dialog box opens.

 c In the Requirement Name box, type Cruise Booking.

 d In the Requirement Type box, select Functional. 

ALM Editions: If you are using Quality Center Starter Edition, ignore 
this step.

 e In the Details tab, type or select the following: 

Priority: 4-Very High

Product: Mercury Tours Web Site

 f Click Submit. 

 g Click Close to close the New Requirement dialog box. The Cruise 
Booking requirement is added as a child of the Cruise Reservation 
requirement.
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 7 Assign the requirements to a cycle.

ALM Editions: If you are using Quality Center Starter Edition, ignore this 
step.

 a In the requirements tree, select Cruise Reservation.

 b Choose Requirements > Assign to Cycle. The Select Cycles dialog box 
opens.

 c Locate the Service Packs releases folder. Under Service Pack 1, select 
the check box for the Cycle 1 - New Features cycle. 

 d Click OK to close the releases tree. 

 e Click Yes to assign the cycle to the requirement and its sub-
requirements.
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 8 Assign additional requirements to a cycle.

ALM Editions: If you are using Quality Center Starter Edition, ignore this 
step.

 a In the requirements tree, under Mercury Tours Application, select 
Online Travel Booking Services.

 b Choose Requirements > Assign to Cycle. In the Select Cycles dialog 
box, locate the Service Packs releases folder. Under Service Pack 1, 
select the check box for the Cycle 1 - New Features cycle. Click OK.

 c Version Control: If the Check Out dialog box opens, click OK.

 d Click Yes to assign the cycle to the requirement and its sub-
requirements.

Viewing Requirements

You can change the way requirements are displayed. In this exercise, you 
will learn how to zoom in and out of the requirements tree, rearrange the 
requirement order, and display and filter requirements in the requirements 
grid.

To view requirements:

 1 Make sure the Requirements module is displayed.

 a If the Requirements module is not displayed, on the ALM sidebar, 
under Requirements, select Requirements.

 b Choose View > Requirements Tree to display requirements in a tree.
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 2 Zoom in and out of the requirements tree.

 a Select Cruise Reservation in the requirements tree.

 b To zoom in, click the Zoom arrow and choose Zoom In. The 
requirements tree displays only the child requirements of Cruise 
Reservation.

 c To reverse the zoom-in action and display the entire requirements tree, 
click the Zoom arrow and choose Zoom Out To Root.

 3 Rearrange the order of requirements in the requirements tree.

ALM adds requirements to the requirements tree in order of creation. To 
rearrange the order, select the Cruise Search requirement and click the 
Move Down button. The Cruise Search requirement moves down below 
the Cruise Booking requirement.

 4 View requirements in the requirements grid.

Choose View > Requirements Grid to display requirements in a flat non-
hierarchical view. Each line in the grid displays a separate requirement.
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 5 Define a filter to view requirements created on a specific date.

 a Click the Filter button. The Filter dialog box opens. 
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 b For the Creation Date field, click the Filter Condition box. Click the 
down arrow button. The Select Filter Condition dialog box opens, 
displaying today’s date in the calendar.

 c Select the date on which you added requirements.

 d Click OK to close the Select Filter Condition dialog box.

 e Click OK to apply your chosen filter.

 f The Requirements Grid displays the requirements you added.
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Converting Requirements to Tests

After you create the requirements tree, you can use the requirements as a 
basis for defining your test plan tree in the Test Plan module. 

You can use the Convert to Tests wizard to assist you when designing your 
test plan tree. The wizard enables you to convert selected requirements or all 
requirements in the requirements tree to subjects or tests in the test plan 
tree.

In this exercise, you will convert the Cruise Reservation requirement to a 
subject in the test plan tree, and the child requirements of Cruise 
Reservation to tests in the Cruise Reservation subject folder.

To convert a requirement to test:

 1 Make sure the Requirements module is displayed.

If the Requirements module is not displayed, on the ALM sidebar, under 
Requirements, select Requirements.

 2 Select a requirement.

 a Choose View > Requirements Tree to display requirements in a tree.

 b In the requirements tree, select Cruise Reservation. 
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 3 Open the Convert to Tests wizard.

Choose Requirements > Convert to Tests. The Step 1 dialog box opens.

 4 Choose an automatic conversion method.

Select the second option, Convert lowest child requirements to tests, to 
convert the selected requirement to a subject folder, and its sub-
requirements to tests.
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 5 Start the conversion process.

 a Click Next to begin converting the requirements. When the 
conversion process is complete, the results are displayed in the Step 2 
dialog box.
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 b Click Next. The Step 3 dialog box opens.

 6 Choose the destination subject path.

 a In the Destination Subject Path box, click the browse button. The 
Select Destination Subject dialog box opens.

 b If any filters are applied, click the Set Filter/Sort arrow and choose 
Clear Filter/Sort. Click OK to confirm.
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 c In the test plan tree, select the Cruises subject.

 d Click OK to close the Select Destination Subject dialog box. The 
Destination Subject Path box now indicates this path:

 7 Finalize the conversion process.

Click Finish. The Required Test Fields dialog box opens and displays the 
missing required fields of the Cruise Booking test.
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 8 Specify the required test fields.

 a Select the following: 

Level: Basic

Priority: 4-Very High

Reviewed: Reviewed 

 b Click OK. The Required Test Fields dialog box reopens and displays the 
missing required fields of the Cruise Search test.

 c Select the same values entered for the Cruise Booking test. Click OK.

 d Click OK to close Convert to Tests wizard.

 9 View the tests in the test plan tree.

 a On the ALM sidebar, under Testing, select Test Plan.

 b Choose View > Test Plan Tree to display the test plan tree.

 c Expand Cruises. The test plan tree displays Cruise Reservation under 
Cruises. 

 d Expand Cruise Reservation. The test plan tree displays the Cruise 
Booking and Cruise Search tests.
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4
Planning Tests

After you define your requirements, you need to determine your testing goal 
and outline the strategy for achieving your goal. 

After you determine your testing goal, you build a test plan tree, which 
hierarchically divides your application into testing units, or subjects. For 
each subject in the test plan tree, you define tests that contain steps. For 
each test step, you specify the actions to be performed on your application 
and the expected result. 

ALM enables you to use the same test to test different use-cases, each with 
its own test configuration. Each test configuration uses a different set of 
data. You define the data by adding test parameter values for each test 
configuration. A test parameter is a variable that can be assigned a value.

When you create a test, a single test configuration with the same name as 
the test is created simultaneously. You can create as many additional test 
configurations as needed. 

It is essential that the tests in your test plan comply with your requirements. 
To help ensure compliance throughout the application lifecycle 
management process, add coverage between tests and requirements. For 
finer granularity, you add coverage between test configurations and 
requirements.
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In this lesson, you will learn about:

➤ Developing a Test Plan Tree on page 52

➤ Designing Test Steps on page 54

➤ Defining Test Parameters on page 58

➤ Defining Test Configurations on page 61

➤ Creating and Viewing Coverage on page 65

➤ Copying Test Steps on page 73

➤ Generating Automated Test Scripts on page 75

Developing a Test Plan Tree

The typical application is too large to test as a whole. The Test Plan module 
enables you to divide your application according to functionality. You 
divide your application into units, or subjects, by creating a test plan tree. 
The test plan tree is a graphical representation of your test plan, displaying 
your tests according to the hierarchical relationship of their functions. After 
you define subjects in the tree, you decide which tests to create for each 
subject, and add them to the tree.

In this exercise, you will add a subject and a test to the test plan tree in the 
Test Plan module.

To develop a test plan tree:

 1 Open the ALM_Demo project.

If the ALM_Demo project is not already open, log in to the project. For 
more information, see "Starting ALM" on page 18.

 2 Display the Test Plan module.

On the ALM sidebar, under Testing, select Test Plan.
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 3 Add a subject folder to the test plan tree.

 a Select the Subject folder and click the New Folder button. The New 
Folder dialog box opens.

 b In the Folder Name box, type Payment Methods. Click OK. The new 
folder is added to the test plan tree. 

 c In the Description tab in the right pane, type a description of the 
subject: This folder contains tests that verify the payment methods.

 4 Add a test to the subject folder.

 a Select the Payment Methods folder and click the New Test button. The 
New Test dialog box opens. 

 b In the Test Name box, type a name for the test: Credit Cards. 

 c In the Test Type box, select MANUAL to create a manual test. 

 d In the Details tab, select the following:

Level: Basic 

Reviewed: Not Reviewed

Priority: 4-Very High
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 e In the Description tab, type a description for the test: The test verifies 
credit card types.

 f Click OK. The new test is added to the test plan tree under the 
Payment Method folder.

Designing Test Steps

After you add a test to the test plan tree and define basic test information, 
you define test steps—detailed, step-by-step instructions that specify how to 
execute the test. A step includes the actions to be performed on your 
application and the expected results.

You can create test steps for both manual and automated tests. For manual 
tests, you complete test planning by designing the test steps. Using your 
plan, you can begin test execution immediately. For automated tests, you 
create automated test scripts using HP testing tools, custom testing tools, or 
third-party testing tools. 

In this exercise, you add test steps to the Credit Cards test. This test verifies 
the credit card type used to book a flight. 

To design a test step:

 1 Make sure the Test Plan module is displayed.

If the Test Plan module is not displayed, on the ALM sidebar, under 
Testing, select Test Plan.



Lesson 4 • Planning Tests

55

 2 Display the Credit Cards test.

Expand the Payment Methods folder, and select the Credit Cards test.

 3 Open the Design Step Details dialog box.

 a Click the Design Steps tab.

 b Click the New Step button. The Design Step Details dialog box opens. 

In the Step Name box, a step name is displayed. The default name is 
the sequential number of the test step. 

 4 Define the first test step. 

In the Design Step Details dialog box, type the following:

Step Name: Step 1: Log in to Mercury Tours. 

Description: 

1. Enter URL.

2. Log in. 

Expected Result: User is logged in to Mercury Tours. 
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 5 Add the remaining test steps.

Click the New Step button to open the Design Step Details dialog box and 
type the following test steps:

Step Name Description Expected Result

Step 2: Select a flight 
destination.

1  Click the Flights 
button.

2  Enter flight details and 
preference.

3  Click Continue.

Flight details and 
preference are entered.

Step 3: Enter departure 
and return flight.

Select departure and 
return flights. Click 
Continue.

The flights are selected.

Step Name: Step 4: Enter 
passenger details.

Enter first name, last 
name, and meal 
preference.

Passenger details are 
entered.

Step 5: Enter credit 
card details.

1  Enter credit card type.
2  Enter credit card 

number.
3  Enter expiration date.

Credit card details are 
entered.

Step 6: Enter addresses. Enter billing and delivery 
addresses.

Addresses are entered.

Step 7: Completing the 
purchase.

Click Secure Purchase. Purchase completed.

Step 8: Log out. Click the Log Out button. User logs out of Mercury 
Tours.
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 6 Close the Design Step Details dialog box.

Click OK. The Design Steps tab displays the design steps.
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Defining Test Parameters

To increase the flexibility of your tests, you can add parameters to your tests. 
This enables you to run the same test repeatedly with different data each 
time.

When working with a manual test, you can add parameters to the design 
steps from within the test or you can add parameters by calling them from 
other tests. This is useful if you have common steps you often want to 
perform as part of other tests. 

When working with an automated test, you can define parameters for a test 
script from within the test or you can load parameters from a shared test 
resource file. 

When defining a test configuration, you define data by setting test 
parameter values for each test configuration.

In "Designing Test Steps" on page 54, you defined steps for the Credit Cards 
test. In this exercise, you will add parameters to enhance this test.

To define test parameters:

 1 Display the Parameters tab for the Credit Cards test.

 a In the test plan tree, expand the Payment Methods folder, and select 
the Credit Cards test.

 b Click the Parameters tab.
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 2 Add a parameter.

 a Click the New Parameter button. The New Test Parameter dialog box 
opens.

 b Type the following:

Parameter Name: Credit card type.

Default Value: American Express, Visa, or MasterCard.

 c Click OK to close the New Test Parameter dialog box. The parameter is 
added to the Parameters tab.

 3 Add an additional parameter.

 a Click the New Parameter button. The New Test Parameter dialog box 
opens.

 b Type the following:

Parameter Name: Credit card number.

Default Value: XXXX-XXXX-XXXX

 c Click OK to close the New Test Parameter dialog box. The parameter is 
added to the Parameters tab.
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 4 Assign parameters to the test steps.

 a Click the Design Steps tab.

 b Click the Description box of Step 5.

 c Place the cursor after 1. Enter credit card type and click the Insert 
Parameter button. The Parameters dialog box opens.

 d Select the Credit card type parameter. Click OK. 
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 e Place the cursor after 2. Enter credit card number and click the Insert 
Parameter button. The Parameters dialog box opens. Select the Credit 
card number parameter. Click OK.

The parameters are added to your design step.

Defining Test Configurations

You can reuse a test to test different use-cases. For each use-case you create a 
test configuration that uses a different data set. When working with a 
manual test, the data set of a test configuration contains values for your 
defined test parameters. When working with a QuickTest Professional or a 
business process test, the data set can use an external test resource file. 

In the following exercise, you will create a test configuration for each of the 
following credit cards: American Express, Visa, and MasterCard. You will 
then define the actual parameter values to be used when running these 
instances.
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To define test configurations:

 1 Display the Test Configurations tab for the Credit Cards test.

 a In the test plan tree, expand the Payment Methods folder, and select 
the Credit Cards test.

 b Click the Test Configurations tab. 

By default, ALM created the Credit Cards test configuration.

 2 Rename the test configuration name to American Express.

 a Under Name, click Credit Card. Type American Express.

 b Under Description, type: Test configuration for American Express.

 3 Assign data to the test configuration.

 a Click the Data tab.

 b Under Actual Value, click the top cell. Click the arrow and click in the 
box. Type: 2222-2222-3333-4444. Click OK. 
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 c Under Actual Value, click the second cell. Click the arrow and click in 
the box. Type: American Express. Click OK.

 4 Add a new test configuration for Visa.

 a Click the New Test Configuration button. The New Test Configuration 
dialog box opens.

 b Type the following:

Name: Visa

Description: Test configuration for Visa.

 c Click OK. The test configuration is added to the Test Configuration 
tab.

 d Make sure the Visa test configuration is selected. 

 e Click the Data tab. Under Actual Value, click the top cell. Click the 
arrow and click in the box. Type: 3333-4444-5555-6666. Click OK. 

 f Under Actual Value, click the second cell. Click the arrow and click in 
the box. Type: Visa. Click OK.

 5 Add a new test configuration for MasterCard.

 a Click the New Test Configuration button. The New Test Configuration 
dialog box opens.

 b Type the following:

Name: MasterCard

Description: Test configuration for MasterCard.



Lesson 4 • Planning Tests

64

 c Click OK. The test configuration is added to the Test Configuration 
tab.

 d Make sure the MasterCard test configuration is selected. 

 e Click the Data tab. Under Actual Value, click the top cell. Click the 
arrow and click in the box. Type: 4444-5555-6666-7777. Click OK. 

 f Under Actual Value, click the second cell. Click the arrow and click in 
the box. Type: MasterCard. Click OK.

 6 Version Control: Check in the test configurations.

Check in the test and its test configurations. In the test plan tree, right-
click the Credit Card test, and select Versions > Check In. Click OK to 
confirm.
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Creating and Viewing Coverage

It is essential that the tests in your test plan comply with your requirements. 
To help ensure compliance throughout the application lifecycle 
management process, you can add coverage between your tests and 
requirements. You can also add coverage between test configurations and 
requirements.

You can create coverage from the Test Plan module and the Requirements 
module. A test or a test configuration can cover more than one requirement, 
and a requirement can be covered by more than one test or test 
configuration.

In these exercises, you will learn about the following:

➤ "Creating Coverage" on page 65

➤ "Analyzing Coverage" on page 69

Creating Coverage
In this exercise, you will create the Credit Cards requirement and then 
create coverage by associating it to the Credit Cards test.

To create coverage:

 1 Display the Requirements module.

 a On the ALM sidebar, under Requirements, select Requirements.

 b Choose View > Requirement Details. The Requirement Details view is 
displayed.
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 2 Create the Credit Card requirement.

 a Select the Mercury Tours Application folder. 

 b Click the New Folder button. In the New Requirement Folder dialog 
box, type: Payments. Click OK.

 c Select the Payments folder and click the New Requirement button. 
The New Requirement dialog box opens.

 d In the Requirement Name box, type Credit Cards.

 e In the Requirement Type box, select Functional. 

ALM Editions: If you are using Quality Center Starter Edition, ignore 
this step.

 f Click Submit. Click Close. The new requirement is added to the 
requirements tree.

 3 Display the Test Coverage tab.

 a In the requirements tree, make sure that the Credit Cards requirement 
is selected.

 b In the right pane, click the Test Coverage tab. 
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 4 Display the Test Plan Tree pane.

Click the Select Tests button to show the test plan tree on the right.

 5 Select the Credit Cards test in the test plan tree.

 a In the Test Plan Tree pane, expand the Payment Methods folder, and 
select the Credit Cards test. 

 b If the Test Configurations pane is not displayed, click the Show button 
on the bottom of the pane. Under the Test Configurations pane, you 
can see that the test contains three test configurations.

 6 Add the test to the coverage grid.

In the Test Plan Tree pane, click the Add to Coverage button. The Credit 
Cards test is added to the coverage grid. 

 7 Display the Test Configuration Status tab.

Click the Test Configuration Status tab. 
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The Test Configuration Status tab shows the associated test configurations 
and their status.

Tip: To add selected configurations of a test to the requirement's test 
coverage, add coverage from the Test Configurations pane.

 8 Hide the test plan tree.

Click the Close button above the tests plan tree.

 9 Version Control: Check in the Payments folder and the Credit Card 
requirement.

 a In the test plan tree, right-click the Payments folder, and select 
Versions > Check In. Click OK to confirm. 

 b Right-click the Credit Cards requirement, and select Versions > Check 
In. Click OK to confirm.
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Analyzing Coverage
After you create test coverage, you can use the Coverage Analysis view in the 
Requirements module to analyze the breakdown of child requirements 
according to test coverage. 

In this exercise, you will analyze the Application Client System requirement.

To analyze test coverage:

 1 Make sure that the Requirements module is displayed.

If the Requirements module is not displayed, on the ALM sidebar, under 
Requirements, select Requirements.

 2 Display the requirements tree in Coverage Analysis view.

Choose View > Coverage Analysis. The Coverage Analysis view is 
displayed. 
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 3 Display the Application Client System requirement in Coverage Analysis 
view.

 a If any filters are applied, click the Filter arrow and choose Clear 
Filter/Sort. Click Yes to confirm.

 b Under the Mercury Tours Application requirement, expand the 
Application Client System requirement and its children.

In the Coverage Analysis column, you can see graphically the number 
of child requirements that have a direct cover status and those that are 
not yet covered. 
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 4 Display coverage analysis for the Application Client System requirement.

Right-click the Application Client System requirement, and choose 
Coverage Analysis. The Coverage Analysis dialog box opens.

 5 Display the child requirements with a “Failed” status.

Click the red Failed area of the graph. The child requirements with a 
“Failed” status are listed.
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 6 Display test coverage for the requirement.

 a Click the Show Test Coverage link to extend the Coverage Analysis 
dialog box and display the Test Coverage Chart. 

This pie chart graphically displays the full test coverage for the 
requirement, grouped according to test status.

 b Click the Passed section of the chart to open the Tests Coverage dialog 
box and display the list of tests with the selected status. Close the Test 
Coverage dialog box.

 7 Close the Coverage Analysis dialog box.

Click the Close button. 
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Copying Test Steps

You can copy steps from another test in the same project or from a different 
project. In this exercise, you will copy the test steps from the HTML Page 
Layout test and paste them into a newly created test. 

To copy a test step:

 1 Display the Test Plan module.

 a On the ALM sidebar, under Testing, select Test Plan.

 b If the test plan tree view is not displayed, select View > Test Plan Tree.

 2 Create a new test.

 a In the test plan tree, expand the Mercury Tours Site folder.

 b Select the HTML Pages folder and click the New Test button. The New 
Test dialog box opens. 

 c In the Test Name box, type a name for the test: New HTML Page 
Layout. 

 d In the Test Type box, select MANUAL to create a manual test. 

 e In the Details tab, select the following:

Level: Basic 

Reviewed: Not Reviewed

Priority: 4-Very High

 f Click OK. The new test is added to the test plan tree under the HTML 
Pages folder.

 3 Display the Design Steps tab for the HTML Page Layout test.

 a In the HTML Pages folder, select the HTML Page Layout test.

 b Click the Design Steps tab.
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 4 Select the steps that you want to copy.

Position the mouse pointer in the gray sidebar on the left. The mouse 
pointer changes to a pointing hand. Select all rows.

 5 Copy the selected steps.

Click the Copy Steps button.

 6 Paste the steps into the New HTML Page Layout test.

 a In the test plan tree, select the New HTML Page Layout test.

 b In the Design Steps tab, click the Paste Steps button. The test steps are 
copied to the Design Steps tab.
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Generating Automated Test Scripts

Test planning involves deciding which tests to automate. If you choose to 
execute tests manually, the tests are ready for execution as soon as you 
define the test steps. If you choose to automate tests, you can generate test 
scripts and complete them using other HP testing tools (for example, 
QuickTest Professional).

Consider these issues when deciding whether to automate a test.

In this exercise, you will generate a QuickTest Professional test script for the 
Address Options test.

Note: For prerequisites to working with a QuickTest Professional test, see 
"Before You Begin" on page 10.

To generate an automated test script:

 1 Make sure the test plan tree view is displayed.

If the test plan tree view is not displayed, select View > Test Plan Tree.

Do automate: ➤ Tests that run with each new version of your application 
to check the stability of basic functionality across the 
entire application (regression tests). 

➤ Tests that use multiple data values for the same operation 
(data-driven tests). 

➤ Tests that are run many times (stress tests) and tests that 
check a multi-user client/server system (load tests). 

Do not automate: ➤ Tests that are executed only once.

➤ Tests that require immediate execution.

➤ Tests that check how easy the application is to use 
(usability tests).

➤ Tests that do not have predictable results.
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 2 Locate the Address Options manual test.

 a Select the Subject folder at the root of the test plan tree and choose 
Edit > Find. The Find dialog box opens.

 b In Value To Find, type Book.

 c In the Search for, select Folders.

 d Click Find. The Search Results dialog box opens and displays a list of 
possible matches.

 e Double-click the Flight Reservation\Book Flight folder to highlight the 
folder in the test plan tree. Click Close to close the Search Results 
dialog box.

 f In the test plan tree, expand the Book Flight folder and select the 
Address Options test.

 3 Display the Design Steps tab.

In the right pane, click the Design Steps tab.

 4 Generate a test script.

 a Click the Generate Script button.

 b Choose QUICKTEST_TEST to generate a QuickTest Professional test.

 c Version Control: If a check out message box opens, click OK.

The steps in the Address Options test are used to create the automated 
test script. 

 5 View the test script.

 a Click the Test Script tab.

 b To display and modify your test script in QuickTest Professional, click 
the Launch QuickTest Professional button.
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5
Running Tests

Throughout the application lifecycle management process, you can run 
manual and automated tests to locate defects and assess the quality of your 
application.

You start by creating test sets and choosing which tests to include in each 
set. A test set contains a subset of the tests in an ALM project designed to 
achieve specific test goals. ALM enables you to control the execution of tests 
in a test set by setting conditions and scheduling the date and time for 
executing your tests.

After you define test sets, you can begin to execute your tests. You can then 
use ALM to view and analyze the results of your tests.

When you run a test manually, you execute the test steps you defined in test 
planning. You pass or fail each step, depending on whether the actual 
results match the expected output. When you run a test automatically, ALM 
opens the selected testing tool, which runs the test, and imports the test 
results to ALM.

In this lesson, you will learn about:

➤ Defining Test Sets on page 78

➤ Adding Tests to a Test Set on page 84

➤ Scheduling Test Runs on page 88

➤ Running Tests Manually on page 96

➤ Viewing and Analyzing Test Results on page 107

➤ Running Tests Automatically on page 115
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Defining Test Sets

After you design tests in the Test Plan module, you create a test sets tree. A 
test sets tree enables you to organize your testing needs by grouping test sets 
in folders and organizing them in different hierarchical levels in the Test Lab 
module. You assign each test set folder to a cycle. This enables you to group 
together test sets that will be run during the same cycle and analyze the 
progress of the cycle as you run your tests.

When defining a test set, ALM adds instances of your selected tests to the 
test set. Each test instance contains a defined test configuration. Test sets 
can include instances from both manual and automated tests. You can also 
include instances of the same test in different test sets or add more than one 
instance to the same test set.

To decide which test sets to create, consider the goals you defined at the 
beginning of the application lifecycle management process. Consider issues 
such as the current state of the application and the addition or modification 
of new features.

Following are examples of general categories of test sets you can create:

Test Set Description

Sanity Checks entire application at a basic level—focusing on 
breadth, rather than depth—to verify that the application is 
functional and stable. This set includes fundamental tests 
that contain positive checks, validating that the application 
is functioning properly. For example, in the Mercury Tours 
application, you could test whether the application opens 
and enables you to log in.

Regression Tests the system in a more in-depth manner than a sanity set. 
This set can include both positive and negative checks. 
Negative tests attempt to fail an application to demonstrate 
that the application is not functioning properly.
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In this exercise, you will define the Mercury Tours Site test set. You will also 
set failure rules for the test set to instruct ALM how to proceed in the event 
that an automated test in the test set fails.

ALM Editions: If you are using Quality Center Starter Edition, fields and 
commands related to cycles and releases are not available.

To define a test set:

 1 Display the Test Lab module.

On the ALM sidebar, under Testing, select Test Lab. By default, the Test 
Sets tab is displayed.

 2 Add a folder to the test sets tree.

 a In the test sets tree in the left pane, select the Root folder.

 b Click the New Folder button. The New Test Set Folder dialog box 
opens.

 c In the Folder Name box, type Service Pack 1 and click OK.

 3 Create subfolders for the test set folder.

Select the Service Pack 1 folder you created and repeat the previous step to 
create two subfolders, named Cycle 1 - New Features, and Cycle 2 - Full.

Advanced Tests both breadth and depth. This set covers the entire 
application, and also tests the application’s advanced 
options. You can run this set when there is ample time for 
testing.

Function Tests a subsystem of an application. This could be a single 
feature or a group of features. For example, in the Mercury 
Tours application, a function set could test all activities 
related to booking a flight.

Test Set Description
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 4 Assign the test set folders to a cycle.

ALM Editions: If you are using Quality Center Starter Edition, proceed to 
Step 5.

 a Right-click the Cycle 1 - New Features test set folder and select the 
Assign to Cycle button. The Select Cycles dialog box opens. 

 b Expand the Service Packs releases folder. In the Service Pack 1 release, 
select the Cycle 1 - New Features cycle (created in Lesson 2, "Specifying 
Releases and Cycles").

 c Click OK. The icon for the folder in the test sets tree changes to show 
that the folder has been assigned to a cycle.

 d Right-click the Cycle 2 - Full test sets folder and choose Assign to Cycle. 
Assign the folder to the Cycle 2 - Full cycle, located in the Service Pack 
1 release in the releases tree.
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 5 Add a test set to the Cycle 1 - New Features test set folder.

 a In the test sets tree, select Cycle 1- New Features.

 b Click the New Test Set button. The New Test Set dialog box opens.

 c Type the following:

Name: Mercury Tours Site

Description: This test set includes tests that verify the functionality of the 
Mercury Tours site.

 d Click OK. The Mercury Tours Site test set is added to the test sets tree 
in the left pane.
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 6 Define the test set details.

 a Click the test set in the test sets tree. The Details tab is displayed. 

 b Perform the following:

Open Date: Select a date from the calendar for the planned opening 
date for the test set. Today's date is selected by default.

Close Date: Select the planned closing date for the test set.
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 7 Set rules for the automated tests in the test set in the event of a test 
failure. 

 a Click the Automation tab.

 b Perform the following: 

On Automatic Test Failure: Select the Rerun test check box. In 
Maximum test reruns, set to 1. 

On final failure: Make sure that the Do nothing option is selected.
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 8 Instruct ALM to send email to specified users if certain events occur.

Under Notification, perform the following:

Send email in the event of: Select the first check box to send email 
notification if any test in the test set fails. 

To: Type your email address.

Message: Type the following: 
This test failed. Please review the test results and submit a defect. 

Adding Tests to a Test Set

After you define a test set, select tests for inclusion in the test set. ALM adds 
instances of the selected tests to the test set. Each instance contains a 
defined test configuration.

In this exercise, you will add test instances to the Mercury Tours Site test set.

To add a test to a test set:

 1 Display the Execution Grid tab.

 a If the Test Lab module is not displayed, on the ALM sidebar, under 
Testing, select Test Lab. By default, the Test Sets tab is displayed.

 b Click the Execution Grid tab.

 2 Select the Mercury Tours Site test set.

In the test sets tree, expand the Cycle 1 - New Features test set folder 
under Service Pack 1. Select the Mercury Tours Site test set. 
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 3 Display the right pane if it is not already displayed.

Click the Select Tests button. The right pane displays the Test Plan Tree 
and Requirements Tree tabs.

The Test Plan Tree tab enables you to select tests from the test plan tree to 
add to the test set. The Requirements Tree tab enables you to select tests 
covering requirements to add to the test set. 
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 4 Add the Credit Card test to the test set.

 a In the Test Plan Tree tab, expand the Payment Methods folder and 
select the Credit Cards test. 

 b If the Test Configurations pane is not displayed, click the Show button 
on the bottom of the pane. Under the Test Configurations pane, you 
can see the three test configurations for the selected test.

 c To include all test configurations, in the Test Plan Tree tab, click the 
Add Tests to Test Set button. The instances are added to the test set.

 5 Add several tests from the Book Flight folder to the test set.

 a Under the Flight Reservation folder, expand the Book Flight folder. 

 b Select the Passenger Name test.

 c Press the CTRL key and select the following tests: Credit Card Number, 
Credit Card Expiration Date, Credit Card Owner, and Billing And 
Delivery Address. Click the Add Tests to Test Set button. The instances 
are added to the test set.
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 6 Add the Number of Passengers test to the test set.

 a Under the Flight Reservation folder, expand the Flight Finder folder. 

 b Drag the Number of Passengers test from the test plan tree to the 
Execution Grid to add it to the test set.

 7 Close the right pane.

Click the close button. 
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Scheduling Test Runs

The Execution Flow tab enables you to specify a date and time to execute a 
test instance and set conditions for it. A condition is based on the results of 
another specified test instance in the Execution Flow. By setting conditions, 
you can postpone the execution of a test instance until another specified 
test instance finishes running or passes. You can also set the sequence in 
which to execute the test instances. 

For example, you can determine that Test 2 will run only if Test 1 passed, 
and Test 3 will run only if Test 2 passed. Test 1 is scheduled to run at 9:00 
AM on a specified date. The Execution Flow displays the tests and their 
conditions in a diagram. 

A blue line  arrow indicates that the test instance is to be 
executed after the previous test instance, with no conditions. A green line 

 arrow indicates that the test instance is to be executed only if 
the previous test instance has status Passed. A black line  arrow 
indicates that the test instance is to be executed only if the previous test 
instance has finished running. When a test instance is time-dependent, a 
Time Dependency  icon is added to the diagram. 
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In this exercise, you will create a new test set and add to it three test 
instances that verify the login procedure on the Sign-On page of the 
Mercury Tours site. Then, you will set the conditions for each instance and 
specify when each one is to be run.

To schedule a test run:

 1 Make sure the Test Lab module is displayed.

On the ALM sidebar, under Testing, select Test Lab. By default, the Test 
Sets tab is displayed.

 2 Create a new test set.

 a In the test sets tree, choose the Service Pack 1 folder and click the New 
Test Set button. The New Test Set dialog box opens.

 b Type the following:

Test Set Name: Test Run Schedule

Description: This test set is used to explain how to schedule a test run.

 c Click OK. The Test Run Schedule test set is added to the test sets tree in 
the left pane. 

 3 Add tests from the Sign-On/Sign-Off folder to the Test Run Schedule test 
set.

 a Click the Execution Flow tab. If the right pane is not already displayed, 
click the Select Tests button. The Test Plan Tree tab and the 
Requirements Tree tab are displayed.

 b In the Test Plan Tree tab, under the Profiling folder, expand the 
Sign-On/Sign-Off folder.
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 c Press the CTRL key and select the following tests: Sign-On Page, 
Sign-On User Name, and Sign-On Password. Click the Add Tests to 
Test Set button. The test instances are added to the test set.
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 4 Add an execution condition to the Sign-On User Name test.

 a In the Execution Flow tab diagram, right-click the Sign-On User Name 
test instance and choose Test Run Schedule. The Run Schedule dialog 
box opens and displays the Execution Conditions tab. 

 b Click New Execution Condition. The New Execution Condition dialog 
box opens.

 c In the Test box, select <[1]Sign-On Page>.
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 d Select Passed from the list on the right to instruct ALM to execute the 
Sign-On User Name test instance only if the Sign-On Page test 
instance finishes executing and passes.

 e Click OK. The condition is added to the Run Schedule dialog box.
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 5 Add a time dependency condition to the Sign-On User Name test 
instance.

 a Click the Time Dependency tab.

 b Click Run At Specified Time. Select the Date check box and select 
tomorrow’s date.
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 c Click OK to close the Run Schedule dialog box. Your conditions are 
displayed in the Execution Flow diagram.

 6 Add an execution condition to the Sign-On Password test.

Add the same execution condition as described in Step 4 on page 91 for 
the Sign-On Password test. This time select Sign-On User Name from the 
Test box in the New Execution Condition dialog box.
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 7 Add a time dependency condition to the Sign-On Password test.

 a Add the same time dependency condition as described in Step 5 on 
page 93 for the Sign-On Password test.

 b Click OK to close the Run Schedule dialog box. Your conditions are 
displayed in the Execution flow diagram.
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Running Tests Manually

When you run a test manually, you follow the test steps and perform 
operations on your application. Then, you compare the expected results 
with the actual outcome and record the results. You can execute a manual 
test as many times as needed. The results are stored separately for each run. 

You can run both manual and automated tests manually. You can also 
choose to run a single test or to run an entire test set.

You run tests in ALM using HP Sprinter, HP’s solution for manual testing. If 
you are not working with Sprinter, you run tests manually using Manual 
Runner.

In these exercises, you will learn about the following:

➤ Running with Sprinter on page 96

➤ Running with Manual Runner on page 102

Running with Sprinter
Sprinter provides advanced functionality and tools to assist you in the 
manual testing process. Sprinter is fully integrated with ALM, enabling you 
to get the maximum benefit from both solutions.

Note: 

➤ ALM Editions: Sprinter functionality is not available with Quality Center 
Starter Edition or Performance Center Edition.

➤ For information on installing Sprinter, see "Before You Begin" on page 10.

In this exercise, you will run the Credit Cards test. This test contains three 
test configurations. For the purpose of this exercise, you will perform the 
steps without testing them against the Mercury Tours application.
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To run a test using Sprinter:

 1 Open Sprinter.

 a If the Test Lab module is not displayed, on the ALM sidebar, under 
Testing, select Test Lab. By default, the Test Sets tab is displayed.

 b Click the Execution Grid tab.

 c Click the Run arrow and select Run with Sprinter. HP Sprinter opens.

 2 Select the instances to run from the test set.

 a Click the Open HP ALM Tests button. The Open dialog box opens.
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 b In the left pane, expand the Root folder. Under Service Pack 1, expand 
Cycle 1 - New Features. Select the Mercury Tours Site test set. The test 
set is displayed. 

 c Select American Express, Visa, and MasterCard check boxes. Click 
Open. 

 3 Display the test steps to run the American Express instance.

Click the Run the Active Test button. The Steps pane is displayed.
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 4 Perform the first step.

 a Click the Actual Result button. In the Actual Result dialog box, type: 
The Mercury Tours site opens. Click OK. 

 b Click the Passed Selected Step button.

 5 Perform the second step.

 a Click the Actual Result button. In the Actual Result dialog box, type: 
Flight details and preference are entered. Click OK. 

 b Click the Passed Selected Step button.

 6 Pass the remaining steps.

Click the Passed Selected Step arrow and select Pass All.

 7 Continue on to the Visa instance.

Click Next Test. Sprinter advances to the next instance in the test list.

 8 Pass all steps of the Visa instance.

Click the Passed Selected Step arrow and select Pass All. 

 9 Continue on to the MasterCard instance.

Click Next Test. Sprinter advances to the next instance in the test list.

 10 Pass all steps of the MasterCard instance.

Click the Passed Selected Step arrow and select Pass All. 

 11 Fail the last step on the MasterCard instance.

Select Step 8 and click the Fail Selected Step button.
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 12 End the run and view run results.

 a In the upper-right side of your screen, click Run Control. The Run 
Control pane opens.

 b Click the End Run button. 

 c Under Tests, you view the run results.
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 13 View results in the Execution Grid tab.

Close Sprinter.

The test run results are displayed in the execution grid. The Last Run 
Report pane displays run results of each test step.
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Running with Manual Runner
If Sprinter is not installed you can run tests manually using Manual Runner.

In this exercise, you will run the Credit Cards test. This test contains three 
test configurations. For the purpose of this exercise, you will perform the 
steps without testing them against the Mercury Tours application.

To run a test using Manual Runner:

 1 Make sure the Cycle 1 - New Features test set folder is displayed in the 
Execution Grid.

 a If the Test Lab module is not displayed, on the ALM sidebar, under 
Testing, select Test Lab. 

 b In the test set tree, expand the Cycle 1 - New Features test set folder 
under Service Pack 1. Select the Mercury Tours Site test set. 

 c Click the Execution Grid tab.

 2 Select the instances to run from the test set.

Press the CTRL key and select the following instances in the Execution 
Grid: American Express, Visa, and MasterCard.
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 3 Open Manual Runner.

Click the Run arrow and select Run with Manual Runner. The Manual 
Runner dialog box opens.
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 4 Start the test run.

Click the Begin Run button. The Manual Runner dialog box opens.

 5 Perform the first step.

 a In the Actual box, type: The Mercury Tours site opens.

 b Click the Pass Selected button. Step 2 is displayed.
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 6 Perform the second step.

 a In the Actual box, type: Flight details and preference are entered.

 b Click the Pass Selected button. Step 3 is displayed.

 7 Pass the remaining steps.

Click the Passed Selected arrow and select Pass All.

 8 End the run.

Click the End Run button to end your test run.

 9 Continue on to the Visa instance.

Click the Begin Run button. The Manual Runner dialog box opens. Note 
the name of the instance in title bar.

 10 Pass all steps of the Visa instance.

Click the Passed Selected arrow and select Pass All. 

 11 End the run.

Click the End Run button to end your test run.

 12 Continue on to the MasterCard instance.

Click the Begin Run button. The Manual Runner dialog box opens. Note 
the name of the instance in title bar

 13 Fail all steps of the MasterCard instance.

Click the Fail Selected arrow and select Fail All. 

 14 End the run.

Click the End Run button to end your test run.
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 15 View the run results in the Execution Grid.

Following the execution of your tests, you can view the run results of 
your last run in the Execution Grid. 

 16 View the results of each test step in the Last Run Report pane.

 a Select one of the recently run instances. If the Last Run Report pane is 
not displayed, click the Show button on the bottom of the pane. The 
Last Run Report pane is displayed below the Execution Grid.

 b Click each step to view its description, as well as the expected and 
actual results.
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Viewing and Analyzing Test Results

ALM provides a number of features that enable you to view and analyze the 
results of your tests.

This section includes:

➤ Viewing Test Results on page 107

➤ Viewing Test Coverage on page 109

➤ Viewing Coverage Progress on page 113

You can also use ALM reports and graphs to further analyze your test results. 
For more information, see "Analyzing ALM Data" on page 141.

Viewing Test Results
You can view results for a test in the Test Instance Properties dialog box. This 
includes details of a test’s runs, attachments, linked defects, and history. 

In this exercise, you will learn how to view test run information in the Test 
Instance Properties dialog box.

To view test results:

 1 Make sure the Test Lab module is displayed.

On the ALM sidebar, under Testing, select Test Lab. By default, the Test 
Sets tab is displayed.

 2 Make sure the Cycle 1 - New Features test set folder is displayed.

 a In the test set tree, expand the Cycle 1 - New Features test set folder 
under Service Pack 1. Select the Mercury Tours Site test set. 

 b Click the Execution Grid tab.

 3 Select American Express in the Execution Grid.

In the Execution Grid tab, select American Express.

 4 View detailed test results from the Test Instance Details dialog box.

Click the Test Instance Details button. The Test Instance Details dialog 
box opens.



Lesson 5 • Running Tests

108

 5 View test run information.

Click Runs. The run details are displayed.

 6 View other test run information in the Test Instance Details dialog box.

 a Click Execution Settings to view parameters used to run the instance. 
Note that any changes that you make are implemented in the next test 
run.

 b Click Linked Defects. This view lists the defects linked to the currently 
selected test instance. You can view, add, and remove defect links.

 c Click History to view a list of changes made to the test run fields.

 7 Close the Test Instance Details dialog box.

Click the Close button.
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Viewing Test Coverage
You previously saw how you can use the Coverage Analysis view to analyze 
the breakdown of child requirements according to their tests coverage (see 
"Analyzing Coverage" on page 69). 

In this exercise, you will learn how to filter the tests included in the 
coverage analysis by cycle.

ALM Editions: This exercise is not available for Quality Center Starter 
Edition.

To view test coverage:

 1 Display the Coverage Analysis view in the Requirements module.

 a On the ALM sidebar, under Requirements, select Requirements.

 b Choose View > Coverage Analysis. The Coverage Analysis view is 
displayed. 

 2 Filter the coverage analysis by cycle.

 a On the upper-right side of the window, click the Settings button. The 
Analysis Settings dialog box opens. 

 b Select Execution Analysis. Click the arrow. In the releases tree, expand 
the release folder Service Packs and the release Service Pack 1. Select 
the Cycle 1 - New Features check box and click OK.

 c Click OK to close the Analysis Settings dialog box.
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 d Expand the Payments requirement. In the Coverage Analysis column, 
you can see that the requirement has failed. This is because the Credit 
Cards test which covers the requirement failed.

 3 Display test coverage details for the Credit Cards requirement.

 a Right-click the Credit Cards requirement, and choose Coverage 
Analysis. The Coverage Analysis dialog box opens. 
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 b Click the Show Test Coverage link to extend the Coverage Analysis 
dialog box and display the Test Coverage Chart. 

 c This pie chart graphically displays the full test coverage for the 
requirement, grouped according to test status.
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 d Click the pie chart to open the Tests Coverage dialog box.

The dialog box shows the failed test together with the test run status of 
each test configuration.

 e Close the Test Coverage dialog box.

 4 Close the Coverage Analysis dialog box.

Click the Close button. 
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Viewing Coverage Progress
You were previously introduced to the Progress tab in the Releases module 
(see "Viewing Releases and Cycles" on page 32). In this exercise, you will 
view the graphs and statistics that now reflect the results of tests you ran in 
previous exercises.

ALM Editions: This exercise is not available for Quality Center Starter 
Edition.

To view coverage progress:

 1 Display the Releases module.

On the ALM sidebar, under Management, select Releases.



Lesson 5 • Running Tests

114

 2 View the effect of your test runs on the Progress tab.

In the releases tree, expand the release folder Service Packs and the release 
Service Pack 1. Select Cycle 1 - New Features and click the Progress tab.

The top pane shows information such as the total and remaining days in 
the cycle, total test instances for the cycle, and actual and remaining test 
instances to run. 

The bottom pane displays the Coverage Progress graph. Planned coverage 
indicates the percentage of tests planned to be run each day within a 
cycle. Executed coverage indicates the percentage of tests that ran each 
day within a cycle. Passed coverage indicates the percentage of tests that 
ran successfully each day within a cycle.
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Running Tests Automatically

When you run an automated test, ALM automatically opens the selected 
testing tool, which runs the test on your local machine or on remote hosts, 
and imports the results to ALM. 

You can run all tests in a test set or run specific tests. You can run tests from 
the Execution Grid tab or the Execution Flow tab. 

In this exercise, you will run a QuickTest Professional test.

Note: For prerequisites to running a QuickTest Professional test, see "Before 
You Begin" on page 10.

To run a test automatically:

 1 Make sure the Test Lab module is displayed.

On the ALM sidebar, under Testing, select Test Lab. By default, the Test 
Sets tab is displayed.

 2 Select the Number of Passengers test.

 a In the test sets tree, expand the Mercury Tours Web Site test set folder. 
Under Functionality And UI, select the Mercury Tours Functionality test 
set. 

 b Click the Execution Grid tab.

 c Select the Number of Passengers test.
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 3 Open the Automatic Runner dialog box.

Click the Run button. The Automatic Runner dialog box opens and 
displays the selected test.

 4 Set the test run settings.

Select the Run All Tests Locally check box to run the test on your local 
computer.

 5 Run the test.

Click the Run button. ALM opens the selected testing tool automatically 
and runs the test. You view the test execution progress in the Status 
column.

 6 Close the Automatic Runner dialog box.

After the test run is complete, choose Run > Exit.

 7 View a summary of test results in the Execution Grid. 

The Execution Grid displays the updated status for the test run. Results 
for each test step appear in the Last Run Report pane.

 8 Close QuickTest Professional.

In QuickTest Professional, choose File > Exit.



117

6
Adding and Tracking Defects

Locating and repairing defects is an essential phase in application 
development. Defects can be detected and submitted by users in all stages of 
the application lifecycle management process. Using HP Application 
Lifecycle Management (ALM), you can submit defects detected in the 
application and track them until they have been repaired and retested.

In this lesson, you will learn about:

➤ How to Track Defects on page 118

➤ Adding New Defects on page 119

➤ Matching Defects on page 121

➤ Updating Defects on page 122

➤ Linking Defects to Tests on page 127

➤ Creating Favorite Views on page 129
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How to Track Defects

When you submit a defect to an ALM project, it is tracked through these 
stages: New, Open, Fixed, and Closed. A defect may also be Rejected or it 
may be Reopened after it is fixed.

When you initially report the defect to an ALM project, it is assigned the 
status New, by default. A quality assurance or project manager reviews the 
defect and determines whether or not to consider the defect for repair. If the 
defect is denied, it is assigned the status Rejected. If the defect is accepted, 
the quality assurance or project manager determines a repair priority, 
changes its status to Open, and assigns it to a member of the development 
team. A developer repairs the defect and assigns it the status Fixed. You then 
retest the application, making sure that the defect does not recur.

If the defect recurs, the quality assurance or project manager assigns it the 
status Reopened. If the defect is repaired, the quality assurance or project 
manager assigns it the status Closed.
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Adding New Defects

You can add a new defect to an ALM project at any stage of the application 
lifecycle management process. In this exercise, you will submit a defect 
connected to the Flight Confirmation test.

To add a new defect:

 1 Open the ALM_Demo project.

If the ALM_Demo project is not already open, log in to the project. For 
more information, see "Starting ALM" on page 18.

 2 Display the Defects module.

On the ALM sidebar, select Defects. The Defects Grid displays defect data 
in a grid. Each row in the grid displays a separate defect record.

 3 Open the New Defect dialog box.

Click the New Defect button. The New Defect dialog box opens.
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 4 Describe the defect.

Enter the following data in the specified fields. Scroll down the dialog box 
as necessary.

Summary: Missing information on Flight Confirmation page. 

Category: Defect

Severity: 2-Medium

Subject: Flight Reservation > Flight Confirmation

Description: The defect was detected on the Flight Confirmation page. 
Passenger details and meal preferences are not displayed.

 5 Determine the cycle in which the defect was detected.

Quality Center Starter Edition: If you are using Quality Center Starter 
Edition, proceed to Step 6.

 a In the Detected in Cycle box, click the arrow. The releases tree opens. 
Expand the tree. In the Mercury Tours Application releases folder, in 
the Release 10.5 release, select the Cycle 1 - New Features cycle. 

 b Click OK to close the releases tree.

 c You can see that ALM automatically assigns the value Release 10.5 to 
the Detected in Release field. This is because Cycle 1 - New Features is 
part of the Release 10.5 release.

 6 Attach the URL address for the Mercury Tours page where the defect was 
detected.

 a On the New Defect dialog box sidebar, click Attachments. The 
Attachment page opens.

 b Click the URL button. The Attach Uniform Resource Locator (URL) 
dialog box opens. 

 c Type the URL address of the Mercury Tours page: 
http://<ALM Platform server name>/mtours
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 d Click OK. A link to the Mercury Tours page is displayed above the 
Description box.

 7 Add the defect to the ALM project.

 a Click the Submit button. The defect is added to the Defects Grid.

 b Click Close to close the New Defect dialog box.

Matching Defects

Identifying matching defects enables you to eliminate duplicate or similar 
defects in your project. Each time you add a new defect, ALM stores lists of 
keywords from the Summary and Description fields. When you search for 
similar defects, keywords in these fields are matched against other defects. 
Note that keywords must be more than two characters long, and letter case 
does not affect your results.

In this exercise, you will match defects by comparing a selected defect with 
all other existing defects in the ALM_Demo project.

To match defects:

 1 Make sure that the Defects module is displayed.

If the Defects module is not displayed, on the ALM sidebar, select Defects. 

 2 Select Defect ID 80.

 a If a filter is applied to the grid, click the Set Filter/Sort arrow and 
choose Clear Filter/Sort to clear the filter.

 b In the Defects Grid, select Defect ID 80. 
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 3 Find similar defects.

Click the Find Similar Defects button. The results are displayed in the 
Similar Defects pane at the bottom of the window, sorted by the 
percentage of detected similarity. Note that there are no duplicate defects 
in the project for the selected defect.

Close the Similar Defects pane.

Updating Defects

Tracking the repair of defects in a project requires that you periodically 
update defects. You can do so directly in the Defects Grid or in the Defect 
Details dialog box. The ability to update some defect fields depends on your 
permission settings. After you have updated defects, you can view the 
quality status of your release in the Releases module.

In this exercise, you will update your defect information by changing the 
severity of a defect, assigning the defect to a cycle, and adding a comment. 
You will then see how updating defects is reflected in the Quality tab of the 
Releases module.

In addition, you will practice updating multiple records simultaneously.

Quality Center Starter Edition: If you are using Quality Center Starter 
Edition, fields and commands related to cycles and releases are not 
available.
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To update defects:

 1 Make sure that the Defects module is displayed.

If the Defects module is not displayed, on the ALM sidebar, select Defects. 

 2 Open the Defect Details dialog box.

In the Defects Grid, select the defect you added in "Adding New Defects" 
on page 119. Click the Defect Details button. The Defect Details dialog 
box opens. 

 3 Change the severity level of the defect.

In the Severity box, select 5-Urgent.

 4 Determine the cycle in which the defect will be fixed.

Quality Center Starter Edition: If you are using Quality Center Starter 
Edition, proceed to Step 5.
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 a In the Target Cycle box, click the arrow. The releases tree opens. 
Expand the tree. In the Mercury Tours Application releases folder, in 
the Release 10.5 release, select the Cycle 4 a - Full cycle. 

 b Click OK to close the releases tree.

 c You can see that ALM automatically assigns the value Release 10.5 to 
the Target Release field. This is because the Cycle 4 a - Full cycle is part 
of the Release 10.5 release.

 5 Add a new comment to explain the change in the severity level.

 a Click the Add Comment button. A new section is added to the 
Comments box, displaying your user name and the current date.

 b Type: This defect should be fixed in the next service pack.

 6 View the Attachments.

Click Attachments on the sidebar. Note that the URL attachment is listed.

 7 View Linked Entities.

Click Linked Entities on the sidebar to view entities that have been linked 
to the defect. Linked entities can include requirements, tests, test sets, test 
instances, runs, run steps, and other defects. There are currently no linked 
entities. You will learn how to link a defect to a test in "Linking Defects to 
Tests" on page 127.

 8 View the History.

Click History on the sidebar to view the history of changes made to the 
defect. For each change, the grid displays the date and time of the change 
and the name of the user who made the change. You can expand a 
change to view a list of fields modified during the change. For each field, 
the grid displays the old value and the new value.

 9 Close the Defect Details dialog box.

Click OK to exit the dialog box.
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 10 Update defects directly in the Defects Grid.

Quality Center Starter Edition: If you are using Quality Center Starter 
Edition, ignore this step.

 a In the Defects Grid, select defect ID 23. 

 b Click the Detected in Cycle box and click the arrow. In the releases 
tree, expand the release folder Mercury Tours Application and the 
release Release 10.5. Select the Cycle 1 - New Features cycle and click 
OK.

 c Drag the horizontal scroll bar to the right until the Target Cycle 
column comes into view. Click the Target Cycle box for defect ID 23, 
and click the arrow. In the releases tree, expand the release folder 
Mercury Tours Application and the release Release 10.5. Select the 
Cycle 1 - New Features cycle and click OK.

 11 Update multiple records simultaneously.

 a In the Defects Grid, select defect 35.

 b Hold down the CTRL key, and select defect 36. Now both defects 35 
and 36 are selected.

 c Select Edit > Update Selected. The Update Selected dialog box opens.

 d Click the arrow adjacent to the Update Field box, and select Assigned 
To. Notice that the Value box displays the Assigned To value of the 
defect you selected last.
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 e Click the arrow adjacent to the Value box. The users list opens.

 f In the users list, select michael_alm, and click OK.

 g In the Update Selected dialog box, click Update.

 h After the update completes, an Information dialog box displays a 
summary of the update. Click OK, then close the Update Selected 
dialog box.

 12 View the number of defects opened in Cycle 1 - New Features on the 
Quality tab.

Quality Center Starter Edition: If you are using Quality Center Starter 
Edition, ignore this step.

 a On the ALM sidebar, under Management, select Releases. On the 
Releases tree, expand the release folder Mercury Tours Application and 
the release Release 10.5, and select the cycle Cycle 1 - New Features. 
Click the Quality tab.

 b In the Defect Opening Rate graph, you can see the defects detected in 
Cycle 1 - New Features according to defect severity.

 c In the Outstanding Defects graph, you can see the outstanding defects 
in Cycle 1 - New Features according to defect status. 
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Linking Defects to Tests

You can link a test in your test plan to a specific defect in the Defects Grid. 
This is useful, for example, when a new test is created specifically for a 
known defect. By creating linkage, you can determine if the test should be 
run based on the status of the defect. Note that you can also link the defect 
to other entities, such as requirements.

A defect can be linked directly or indirectly to an entity. When you add a 
defect link to an entity, ALM adds a direct link to this entity and indirect 
links to other related entities. 

The following diagram illustrates the flow of indirect linkage:

For instance, when you link a defect to a run step, it adds an indirect link to 
its run, test instance, test set, and test. If the same test is covered by a 
requirement, an indirect link is also added to the requirement. Note that the 
indirect linkage is a one-directional flow. For example, if you link a defect to 
a run, it is not indirectly linked to its run steps.

In this exercise, you will link your defect to the Flight Confirmation test in 
the Test Plan module, and view the linked test in the Defects Grid.

To link a defect to a test:

 1 Display the Test Plan module.

On the ALM sidebar, under Testing, select Test Plan.

 2 Select the Flight Confirmation test.

In the test plan tree, under Flight Reservation, expand the Flight 
Confirmation test subject, and select the Flight Confirmation test. Click 
the Linked Defects tab.
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 3 Add a linked defect.

 a In the Linked Defects tab, click the Link Existing Defect arrow and 
choose Select. The Defects to Link dialog box opens. 

 b Select the defect you added in "Adding New Defects" on page 119 and 
click the Link button. Your defect is added to the Linked Defects grid.

Tip: If you cannot find your defect in the Defects to Link dialog box, 
click the Set Filter/Sort arrow and choose Clear Filter/Sort to clear the 
filter that is applied to the grid.
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 4 View the linked test in the Defects Grid.

 a On the ALM sidebar, select Defects.

 b Double-click defect ID 80 in the Defects Grid. The Defect Details dialog 
box opens.

 c Click Linked Entities on the sidebar, and select the Others tab. The 
Flight Confirmation test is linked to your defect.

 d Click OK to close the Defect Details dialog box.

Creating Favorite Views

A favorite view is a view of an ALM window configured with the settings 
you applied to it. For example, in the Defects Grid, you may want to apply a 
filter to display only the defects that were detected by you, are assigned to 
you, or have the status “Not Closed”. 

In this exercise, you will create a favorite view in the Defects Grid.

To create a favorite view:

 1 Make sure that the Defects module is displayed.

If the Defects module is not displayed, on the ALM sidebar, select Defects. 



Lesson 6 • Adding and Tracking Defects

130

 2 Define a filter to view defects you detected that are not closed.

 a Click the Set Filter/Sort button. The Filter defects dialog box opens. 
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 b For the Detected By field, click the Filter Condition box. Click the 
arrow. The Select Filter Condition dialog box opens.

 c Under Name, select the [CurrentUser] variable, or select your ALM 
login name from the list. Click OK to close the Select Filter Condition 
dialog box.

 d For the Status field, click the Filter Condition box. Click the arrow. The 
Select Filter Condition dialog box opens.

 e In the right pane, click the logical expression Not.

 f In the left pane, select Closed.

 g Click OK to close the Select Filter Condition dialog box.

 h Click OK to apply your chosen filter. The Defects Grid displays the 
defects you detected that are not closed.



Lesson 6 • Adding and Tracking Defects

132

 3 Add a favorite view.

 a In the Favorites menu, select Add to Favorites. The Add Favorite dialog 
box opens.

 b In the Name box, type: My detected defects (status ‘Not Closed’)

 c You can add a favorite view to either a public folder or a private folder. 
Views in the public folder are accessible to all users. Views in the 
private folder are accessible only to the person who created them. 
Select Private.

 d Click OK. The new favorite view is added to your private folder, and is 
displayed in the list of recently used favorite views, located under the 
Private and Public folders.
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 4 Organize favorites.

 a In the Favorites menu, select Organize Favorites. The Organize 
Favorites dialog box opens.

 b Double-click the Public folder.

 c Click the New Folder button. The New Favorite Folder dialog box 
opens.

 d In the Favorite Folder Name box, type QA defects, and click OK. The 
QA defects folder is added as a sub-folder to the Public folder.

 e Drag the following favorites into the QA defects folder:

➤ QA Bug Verification

➤ QA Team Member - My Fixed and Rejected defects

 f Click Yes to confirm, and close the Organize Favorites dialog box.
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7
Alerting on Changes

You can instruct HP Application Lifecycle Management (ALM) to create 
alerts automatically and send emails to notify those responsible when 
certain changes occur in your project that may impact the application 
lifecycle management process. You can also add your own follow-up alerts.

To generate automatic notification alerts, your ALM project administrator 
must activate alert rules in Project Customization. Alert rules are based on 
associations you make in ALM between requirements, tests, and defects. 
When an entity in your project changes, ALM alerts any associated entities 
that may be impacted by the change. The alerts can be seen by all users. 
ALM also notifies the person responsible for the entity at the time of the 
change of any associated entities that may be impacted by the change.

ALM also enables you to add your own follow-up flag to a specific 
requirement, test, test instance, or defect to remind you to follow up on an 
issue. When the follow-up date arrives, ALM sends you an email reminder.

In this lesson, you will learn about:

➤ Triggering an Alert on page 136

➤ Creating Follow Up Alerts on page 139
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Triggering an Alert

When a requirement, test, test instance, or defect in your project changes, 
ALM can notify those responsible for any associated entities. You can 
associate tests with requirements (see "Defining Test Configurations" on 
page 61) and defects with other ALM entities (see "Linking Defects to Tests" 
on page 127). In addition, you can create traceability links between 
requirements. For more information on creating traceability links between 
requirements, see the HP Application Lifecycle Management User Guide.

ALM can generate alerts for these changes:

In this exercise, you will trigger alerts for tests by changing the associated 
requirement. You will modify the View Reservations requirement and then 
you will view the flagged tests.

To trigger an alert:

 1 Display the requirements tree.

 a On the ALM sidebar, under Requirements, select Requirements. 

 b In the Requirements module, select View > Requirement Details.

 2 Select the requirement that you want to change.

Under Reservation Management, select the View Reservations 
requirement. 

What changed?
Which associated 
entities are flagged?

Who is notified?

Requirement (excluding 
change of Direct Cover 
Status and risk-based 
quality management 
fields)

Tests Test designers

Requirements Requirement authors

Defect status changed to 
Fixed

Test instances Responsible testers

Test ran successfully Defects Users assigned to defects
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 3 View the associated tests.

To view the tests that will be impacted by the change, click the Test 
Coverage tab. The tab displays the associated tests.

 4 Change the priority of the Cruise Booking requirement.

 a Click the Details tab.

 b Click the down arrow adjacent to the Priority box and select 5-Urgent.

Version Control: If you are prompted to check out the requirement, 
click OK.

This change causes ALM to generate alerts for the tests associated with 
the requirement. ALM also sends email notification to the designers of 
the associated tests.

Version Control: Check in the new version of the requirement. 
Right-click the requirement, and select Versions > Check In. Click OK 
to confirm.
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 5 View the alert for the Flight Confirmation test.

 a In the Test Coverage tab, click the link to the Flight Confirmation test. 
The test is highlighted in the test plan tree.

 b Click the Refresh All button.

The Flight Confirmation test has an alert flag , indicating that a 
change was made to an associated requirement. 

 c Click the Alerts flag for the Flight Confirmation test. The Alerts dialog 
box opens. 
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The alert indicates the requirement and the change that triggered the 
alert. It also indicates the name of the person to whom ALM sends 
email notification of this change. 

Version Control: The alert states that the version status has changed to 
Checked In. It does not indicate which fields have been modified. You 
can then compare the new version with the previous version.

 d Click OK.

 6 View the alerts of the other associated tests.

In the test plan tree, view the alerts of the following tests: Itinerary > 
Itinerary Page and Itinerary > View Reservations > Review Reservations.

Creating Follow Up Alerts

ALM enables you to add your own alerts to remind you to follow up on 
outstanding issues. In this exercise, you will add a follow-up flag to a defect 
whose status you want to check one week from today.

When you add a follow-up flag, ALM also adds an information bar that 
reminds you about the follow-up alert. When the follow-up date arrives, 
ALM sends you an email reminder, and changes the flag icon from gray to 
red.

Follow-up flags are specific to your user name, meaning that only you can 
see your follow-up alerts.

To create a follow up alert:

 1 Display the Defects module.

On the ALM sidebar, select Defects.

 2 Select the defect that you want to flag with a follow up reminder.

In the Defects Grid, select a defect.
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 3 Create the follow up alert.

 a Click the Flag for Follow Up button. The Flag For Follow Up dialog box 
opens. 

 b Perform the following:

Follow up by: Select the date one week from today.

Description: Type: Remind me about this defect on this date.

 c Click OK. The flag icon  is added to the defect record.
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8
Analyzing ALM Data

HP Application Lifecycle Management (ALM) reports and graphs help you 
assess your application lifecycle management process. You can generate 
reports and graphs at any time during the process.

You can create project reports in the Analysis View module that enable you 
to design and generate versatile reports containing information from the 
ALM project.

You can create graphs either in the Analysis View module, or during your 
work in the Requirements, Test Plan, Test Lab, Business Components, or 
Defects modules. In either case, you can save the graphs in the Analysis 
View module for future reference.

Using the Dashboard View module, you can also create dashboard pages 
that display multiple graphs side-by-side.

In this lesson, you will learn about:

➤ Generating Project Reports on page 142

➤ Generating Predefined Standard Reports on page 148

➤ Generating Graphs on page 151

➤ Generating Dashboard Pages on page 161
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Generating Project Reports

Project reports enable you to compile versatile reports of project data.

In a project report, you define sections and sub-sections, each listing records 
of a specified ALM entity.

To each report section, you assign a template that determines the fields and 
layout of the section. You also assign document and style templates that 
determine the overall report appearance.

In this exercise, you will create a report of tests with their linked defects.

To generate a project report:

 1 Open the ALM_Demo project.

If the ALM_Demo project is not already open, log in to the project. For 
more information, see "Starting ALM" on page 18.

 2 Display the Analysis View module.

On the ALM sidebar, under Dashboard, select Analysis View.

 3 Add a folder to the Private root folder.

 a In the tree, select the Private folder. 

 b Click the New Folder button. The New Folder dialog box opens.

 c Under Folder Name, type My_Analysis_Items.

 d Click OK. The new folder is added as a sub-folder of the Private folder. 
The Details tab displays the folder name and the user that created the 
folder. 

 e In the Description tab, type This folder includes my demo analysis items.

 4 Create a project report.

 a Click the New Item button and select New Project Report. The New 
Project Report dialog box opens.

 b In the Project Report Name box, type Reviewed tests and linked defects.

 c Click OK. A new project report is added to the folder you created. 
Notice that the  icon represents a project report. 
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The Configuration tab is selected.

 5 Add a main section to report.

 a Click the Add Report Section button. The Add Report Section dialog 
box opens.

 b Under Type, select Tests. The default section name Tests displays in 
the Name field.

 c Click OK. The Tests section is added to the report tree, under the 
Document root folder.
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 6 Add a sub-section to the report.

 a In the report tree, right-click the Tests section, and select Add Report 
Section. 

In the Add Report Section dialog box, you can select an entity related 
to the main section.

 b Under Type, select Defects. The Relationship field describes the nature 
of the relationship between the tests and defects. The default section 
name Linked Defects displays in the Name field.

 c Click OK. The Linked Defects section is added to the report tree, under 
the Tests section.
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 7 Configure document settings.

 a In the report tree, select the Document root node.

 b In the right pane, in the Output Format field, select PDF.

 c Under Document Templates, you assign templates that affect different 
areas of the report.

Default templates are assigned to the different template types. 
Additional templates can be designed by the project administrator in 
Project Customization.

Template Type Description

Document Template Defines fields on the title page, headers and 
footers, page orientation, and other document 
layout settings.

Style Template Defines formatting of report elements. For 
example, tables, headings, and paragraphs.

History Template Defines the style in which history information is 
displayed in report sections.
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 d Click the Edit Document Field Values button alongside the Document 
Template field. The Edit Document Template Field Values dialog box 
opens.

The dialog box enables you to type values for fields in areas such as the 
title page, headers and footers, as defined in the document template.

 e For each field name, type the following values:

 f Click OK.

Field Name Field Value

Project ALM Demo Project

Title1 Interim Report

summary An interim report of reviewed tests and their linked 
defects.

Author Alex ALM
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 8 Configure the Tests report section.

 a In the report tree, select the Tests section.

 b Under Report Section Details, in the Name field, rename the section 
Reviewed Tests. The section name is used as the section title in the 
report.

 c Under Template Details, make sure Project Template is selected.

 d Click the arrow, and select Test Template created by Alice. The 
template you assign to the section determines the section format, and 
the entity fields displayed in the section.

 e Under Filter, click the Set Filter/Sort button. The Filter Tests dialog box 
opens.

 f Click the arrow adjacent to the Reviewed field.

 g In the Select Filter Condition dialog box, select Reviewed, and click 
OK.

 h Click OK to close the Filter Tests dialog box.

 9 Configure the Linked Tests report section.

 a Select the Linked Defects section.
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 b Click the arrow alongside Project Template, and select Defect Tabular 
Template. Tabular templates display records in rows of a table.

 10 Generate the report.

Click Generate. A dialog box opens, displaying the progress of the report 
generation. 

When the report is ready, a PDF reader opens, displaying the report 
results.

Generating Predefined Standard Reports

Predefined standard reports enable you to generate reports of your data in 
the Requirements, Test Plan, Test Lab, Business Components, and Defects 
modules, while working in those modules. You can either choose from a list 
of predefined reports, or you can create reports on selected records for 
immediate display. 

You can use predefined reports for one-time reference, or save them in the 
Analysis View module, where you can continue to configure their data and 
appearance.

In this exercise, you will generate a standard report from the Requirements 
module and save it in the Analysis View module.

To generate a predefined standard report:

 1 Display the Requirements module.

 a On the ALM sidebar, under Requirements, select Requirements.

 b If the Requirements Tree view is not already displayed, choose View > 
Requirements Tree.
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 2 Generate a report.

Choose Analysis > Reports > Standard Requirement Report. The Standard 
Requirement Report dialog box opens.

This report lists the requirements that appear in the current requirements 
view.
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 3 Save the report in the Analysis View module.

 a Click Save. The New Standard Report dialog box opens.

 b Under Select Folder, expand the Private folder, and select 
My_Analysis_Items. Click Save.

The Analysis View module opens, and the report displays under the 
View tab.
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Generating Graphs

You can create graphs in the Analysis View module, that display data from 
the Requirements, Test Plan, Test Lab, Business Components, and Defects 
modules. You can also create predefined graphs directly from the 
Requirements, Test Plan, Test Lab, Business Components, and Defects 
modules. In either case, you can use a graph wizard to guide you through 
the stages of creating a graph.

After creating a graph, you can share the graph for viewing in a Web browser 
outside ALM.

This section includes:

➤ Generating Graphs in the Analysis View Module

➤ Generating Predefined Graphs

➤ Sharing Graphs

Generating Graphs in the Analysis View Module
In the Analysis View module, you can create graphs and configure them 
according to your specifications. You can also create a graph using the graph 
wizard. The graph wizard takes you through the steps involved in creating a 
graph and defining its settings.

You create graphs in either a public folder or a private folder. Graphs in a 
public folder are accessible to all users. Graphs in a private folder are 
accessible only to the user who created them.

In this exercise, you will use the graph wizard to generate a graph that 
summarizes the defects by status and priority level. 

To generate a graph in the Analysis View module:

 1 Make sure the Analysis View module is displayed.

If the Analysis View module is not displayed, on the ALM sidebar, under 
Dashboard, select Analysis View.
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 2 Open the graph wizard.

Click the New Item button and select Graph Wizard. The graph wizard 
opens on the Select Graph Type dialog box.

 3 Select the graph type.

 a Under Entity, select Defects.

 b Under Graph Type, make sure Summary Graph is selected.

 4 Select the projects to include.

Quality Center Starter Edition: If you are using Quality Center Starter 
Edition, ignore this step.
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 a Click Next. The Select Projects dialog box opens.

 b You can include data from multiple projects in the graph. For this 
exercise, we will use only the current project. Make sure Use Current 
Project is selected.

 5 Define a filter to view defects with high to urgent priority.

 a Click Next. The Select Filter dialog box opens.

 b Under Filter Selection, select Define a new filter. Click the Filter 
button. The Filter defects dialog box opens. 
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 c Click the browse button adjacent to the Priority field. The Select Filter 
Condition dialog box opens. 

 d In the right pane, select the logical expression >=.

 e In the left pane, select 3-High.

 f Click OK to close the Select Filter Condition dialog box.

 6 Define a filter to view defects that are not closed.

 a Click the browse button adjacent to the Status field. The Select Filter 
Condition dialog box opens.

 b In the right pane, select the logical expression Not.

 c In the left pane, select Closed. 

 d Click OK to close the Select Filter Condition dialog box.

 e Click OK to close the Filter dialog box.

 7 Set the graph attributes.

 a Click Next. The Select Graph Attributes dialog box opens. 
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 b Under Group By field, make sure that it is set to <None>. 

 c Under X-axis field, select Priority to view the number of defects by 
priority.

 8 Generate the Graph.

Click Finish. The graph is displayed in the graph window.

The graph shows a summary of defects with High to Urgent priority, 
whose status is not Closed.
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 9 Save the graph in the Analysis View module.

 a Click Save. The New Graph dialog box opens.

 b Expand the Private folder, and select My_Analysis_Items. 

 c Click Save. The Defects Summary graph is saved in the analysis tree, 
and displayed in the View tab.

 10 Display additional defect details.

 a Click a bar in the graph. The Drill Down Results dialog box opens and 
displays the defects that belong to the bar. 

 b Close the Drill Down Results dialog box.
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 11 Display other graph views.

 a Click the Pie Chart button to display the graph as a pie chart.

 b Click the Data Grid button to display the data as a grid.

Generating Predefined Graphs
You can create predefined graphs during your work in the Requirements, 
Test Plan, Test Lab, Business Components, and Defects modules. Predefined 
graphs enable you to create several types of graphs in each module, using 
the existing module filter. You can use predefined graphs for one-time 
reference, or save them in the Analysis View module, where you can 
continue to configure their data and appearance. 

In this exercise, you will generate a summary graph from the Defects 
module.

To generate a predefined graph:

 1 Display the Defects module.

On the ALM sidebar, select Defects.

 2 Clear the Defects grid filter.

Click the Set Filter/Sort arrow, and choose Clear Filter/Sort to clear the 
filter that is applied to the grid.
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 3 Generate a report.

Choose Analysis > Graphs > Defects Summary - Group by Status. The 
graph window opens, displaying the selected graph.

The graph shows the number of defects that exist in your project, 
according to the people to whom they are assigned. Defects in the graph’s 
columns are grouped according to their status. 

 4 Close the graph window.

Click the Cancel button.
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Sharing Graphs
You can allow ALM users or others to view read-only versions of graphs 
outside ALM. Each time you access the graph outside ALM, it displays the 
most up-to-date information.

In this exercise, you will share the Defects Summary graph you created in 
the Generating Graphs in the Analysis View Module exercise.

To share a graph:

 1 Display the Analysis View module.

On the ALM sidebar, under Dashboard, select Analysis View.

 2 Share the Defects Summary graph.

 a In the Private folder, under My_Analysis_Items, select Defects 
Summary Graph - by ‘Priority’.

 b Right-click the graph, and select Share Analysis Item. The Share 
Analysis Item dialog box opens.

 c Select Copy Analysis Item Public URL. This option allows others to view 
the graph without entering ALM user credentials.

 d Click OK. A URL of the graph is saved to the clipboard.
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 3 View the graph outside ALM.

 a Open a Web browser window.

 b In the address bar, paste the clipboard content, and press ENTER. The 
graph is displayed in the Web browser.

Below the graph, the Last Generated date and time is displayed, and a 
link to the item in ALM.
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Generating Dashboard Pages

Using the Dashboard module, you can arrange and view multiple graphs on 
a single dashboard page. You select the graphs to include in the dashboard 
page from the graphs in the analysis tree. You can arrange and resize the 
graphs on the page. 

You create dashboard pages in either a public folder or a private folder. 
Dashboard pages in a public folder are accessible to all users. Dashboard 
pages in a private folder are accessible only to the user who created them.

In this exercise, you will create a dashboard page for the defect graphs in the 
public folder. 

To generate a dashboard page:

 1 Display the Dashboard View module.

On the ALM sidebar, under Dashboard, select Dashboard View. 

 2 Add a page to the Public folder.

 a In the tree, select the Public folder.

 b Click the New Page button. The New Dashboard Page dialog box 
opens.

 c In the Dashboard Page Name field, type Summary of Defects page. 

 d Click OK. A dashboard page is added to the dashboard tree under the 
Public folder.

 3 Select the graphs that you want to include in the dashboard page.

 a Click the Configuration tab. 

 b In the Graphs Tree pane, expand the Public folder.



Lesson 8 • Analyzing ALM Data

162

 c Expand the Defects folder. The folder includes four graphs.

 d Double-click the first graph. A placeholder for the graph is created in 
the Configuration tab displaying the graph’s title.

 e Add the other three graphs to the dashboard page.
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 4 Rearrange the dashboard page.

 a Select the second placeholder and drag it upwards so that it is 
alongside the first placeholder.

 b Select the fourth placeholder and drag it upwards so that it is alongside 
the third placeholder.
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 5 View the dashboard page.

 a Click the View tab. ALM generates and displays the graphs in the View 
tab.

The dashboard page displays the unresolved defects per cycle, per 
person, per severity, and per subject.

 b To view the dashboard page in full-screen mode, click the View Page in 
Full Screen button, located in the upper-right corner of the page.

 c To return to the standard view, click the close button, located in the 
upper-right corner of the page.
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9
Creating Libraries and Baselines

A library represents a set of entities in a project and the relationships 
between them. The entities in a library can include requirements, tests, test 
resources, and business components. A baseline is a snapshot of the library 
at a specific point in time. Baselines enable you to keep track of changes 
made to your project over time. 

You create libraries in the Libraries module.

You can compare baselines at all stages of the application lifecycle 
management process. For example, you can compare two baselines in a 
library to review changes made to tests in the library over time. You can also 
compare a baseline to the current entities in the library.

In this lesson, you will create a library of tests and requirements. You will 
then compare two baselines in the library to review changes made to tests in 
the library over time.

Quality Center Starter Edition: This lesson is not available for Quality 
Center Starter Edition.

In this lesson, you will learn about:

➤ Creating Libraries on page 166

➤ Creating Baselines on page 168

➤ Comparing Baselines on page 170
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Creating Libraries

In this exercise, you will add a library of tests and requirements to ALM. To 
perform this exercise you must log in as alex_alm.

To create a library:

 1 Make sure to log in to ALM_Demo as alex_alm.

Open the HP ALM Login window. In the Login Name box, type alex_alm. 
Skip the Password box. 

For more information, see "Starting ALM" on page 18.

 2 Display the Libraries module.

On the ALM sidebar, under Management, select Libraries.

 3 Create a library folder.

 a In the libraries tree, select the root Libraries folder. Click the New 
Folder button. The New Library Folder dialog box opens.

 b In the Library Folder Name box, type Folder1.

 c Click OK. The Folder1 folder is added to the libraries tree.

 d In the Description box in the right pane, type the following 
description for the library folder: This folder contains a library of tests 
and requirements.
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 4 Add a library to your library folder.

 a Click the Create Library button. The New Library dialog box opens on 
the Content page. 

 b In the Name box, type Library1.

 c In the Requirements tab, expand the Requirements root folder. Select 
the check box adjacent to the Mercury Tours Application folder, to 
include the folder in the library.

 d Click the Tests tab. Make sure the Tests in selected folders option is 
selected. Expand the Subject root folder, and select the Mercury Tours 
Site folder to include in the library.

 e Click Details on the sidebar. In the Description box, type This library 
includes tests and requirements.

 f Click OK. The new library is added to the libraries tree. 
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Creating Baselines

A baseline is a snapshot of your library at a specific point in time. You can 
use a baseline to mark any significant milestone in the application lifecycle 
management process. A baseline includes all the entities defined in the 
library, including requirements, tests, test resources, and business 
components. Baselines also include the relationships between the entities in 
the library, such as traceability and coverage. Baselines enable you to keep 
track of changes made to your project over time.

In the following exercise, you will create an initial baseline that will later be 
compared to another baseline to evaluate the impact of changes.

To create a baseline:

 1 Make sure the Libraries module is displayed.

If the Libraries module is not displayed, on the ALM sidebar, under 
Management, select Libraries.

 2 Add a baseline to your library.

 a In the libraries tree, select the Library1 library.

 b Click the Create Baseline button. The Baseline Verification dialog box 
opens, and a verification process begins. 
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The Verification results window displays the results of the library size 
verification. The process checks that the size of the library does not 
exceed the limit defined in Site Administration.

 c Click Continue. The New Baseline dialog box opens.

 d In the Baseline Name field, type Baseline1. Click OK. The baseline is 
added to the libraries tree, and the creation process begins.

The baseline is created in a background process, and may take some 
time. You can continue working in ALM during the baseline creation 
process.

 e In the Details tab, click the Description pane and type Baseline of tests 
and requirements. 

 3 View the baseline log file.

In the Details tab, click the View Log button. The Log: Create Baseline 
dialog box opens and displays progress. Click Close to close the dialog 
box.

The View Log button is no longer displayed.
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Comparing Baselines

You can compare two baselines in a library. For example, you can compare 
baselines at different stages of development to assess the impact of changes 
made to requirements in your project. You can then update the relevant 
tests in your project accordingly.

You can also compare a baseline to the current entities in the library. For 
example, suppose you create a baseline at the start of a new release. Over 
time, changes are made to requirements in the library. To determine 
whether product development is proceeding as planned, you can compare 
requirements in the initial baseline with the current requirements in the 
library.

In the following exercise, you will add test coverage to a requirement and 
then create another baseline. You will then compare your two baselines to 
evaluate the impact of the changes.

To compare baselines:

 1 Modify a requirement.

 a On the ALM sidebar, under Requirements, select Requirements.

 b Select View > Requirement Details.

 c In the requirements tree, under Mercury Tours Application, expand 
Application Usability. Select Keyboard Support. 

 d Click the Test Coverage tab. The Test Coverage tab displays coverage 
for this requirement.

 e If the Test Plan Tree tab on the right is not displayed, click the Select 
Tests button.

 f In the Test Plan Tree tab, expand the Mercury Tours Site and HTML 
Pages subject folders.

 g Double-click the HTML Page Source test. The test is added to the 
coverage grid. 

 2 Create a new baseline.

Repeat Steps 1 and 2 on page 168. Name your new baseline Baseline2.
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 3 Select a baseline with which to compare.

 a In the libraries tree, select Baseline1. Click the Compare To button, 
and select Select Baseline to compare the baseline with another 
baseline. The Select Baseline dialog box opens. 

 b Click the arrow and select Baseline2 from the list. Click OK. 

 c Click OK to close the Select Baseline dialog box. Click Yes to close the 
Warning dialog box. The Compare Baselines Tool dialog box opens.

The baselines are displayed in separate panes, with the more recently 
created baseline displayed in the right pane. In each pane, the library’s 
entities are displayed in the same hierarchical tree structure as defined 
in the specific module. 
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 4 View requirement changes between the baselines.

 a Click the Go To Next Change button in the right pane to view the 
change. 

Differences between the two baselines are indicated in the Changes 
column. The tool indicates that there is a difference in the Keyboard 
Support requirement between the baselines.

 b To compare the modified requirement between baselines, select 
Keyboard Support and click the Compare Entities button on the 
toolbar. The Compare Entities dialog box opens. 
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 c Click the Test Coverage button on the sidebar.

The Test Coverage view displays details of the entity in each baseline.

 d Click Close.
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10
Customizing Projects

In the previous lessons, you learned how to use HP Application Lifecycle 
Management (ALM) to help you manage all phases of the application 
lifecycle management process, including specifying releases and cycles, 
specifying requirements, planning tests, running tests, and tracking defects.

In this lesson, you will learn how to customize your ALM project to meet 
the needs of your team. You can control access to a project by defining the 
users who can access the project and by specifying the types of tasks each 
user can perform. When new members are added to your team, you assign 
them to the projects that they will be using, and specify the tasks that they 
can perform. 

You can also customize your ALM project by modifying system fields or by 
adding user-defined fields. System fields are ALM default fields. You cannot 
add or delete system fields, you can only modify them. User fields are fields 
that you can define. You can add, modify, and delete user-defined fields. 

Fields can be associated with system and user-defined lists. A list contains 
the values that the user can enter in a field. For example, if you are running 
tests on two different database servers, you can add a Database field to your 
project. You can then create a selection list containing the values Oracle and 
Microsoft SQL, and associate the list with the Database field.
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In this lesson, you will learn about:

➤ Starting Project Customization on page 176

➤ Adding a New Project User on page 179

➤ Assigning a User to a User Group on page 182

➤ Defining a User-Defined Field on page 184

➤ Creating a Project List on page 186

Starting Project Customization

You customize your ALM projects using the Project Customization window. 
In this exercise, you will log in to the Project Customization window with 
project administrator privileges.

To start project customization:

 1 Open the HP ALM Login window.

Make sure that the ALM Login window is open. For more information, see 
"Starting ALM" on page 18.

 2 Type a user name with project administrator privileges and authenticate.

 a In the Login Name box, type alex_alm.

 b Skip the Password box. A password was not assigned to this user name.

 c Click the Authenticate button. ALM verifies your user name and 
password and determines which domains and projects you can access. 

 3 Log in to the project.

 a In the Domain list, select Default.

 b In the Project list, select ALM_Demo.

 c Click the Login button.

The ALM main window opens and displays the module in which you 
were last working.
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 4 Open the Project Customization window.

Choose Tools > Customize on the ALM masthead. The Project 
Customization window opens.

By default, the Project Customization window contains the following 
links:

Option Description

User Properties Enables you to change your user properties. For 
example, you can change your email address. You 
can also change your password.

Project Users Enables you to add and remove users from an ALM 
project. You can also assign users to user groups to 
restrict user access privileges.

Groups and Permissions Enables you to assign privileges to user groups by 
specifying permission settings.

Module Access Enables you to control the modules that each user 
group can access. By preventing users from 
accessing unnecessary modules, you can better 
utilize your ALM licenses.
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Project Entities Enables you to modify the behavior of ALM system 
fields or define user-defined fields that are unique to 
your project. For example, if you are running tests 
on several builds of an application, you can add a 
Detected in Build user-defined field to the New 
Defect dialog box. You can then associate it with a 
selection list containing the values for this field.

Requirement Types Enables you to customize the definitions for 
requirement types.

Quality Center Starter Edition: This option is not 
available for Quality Center Starter Edition.

Risk-Based Quality 
Management

Enables you to customize settings for risk-based 
quality management.

Quality Center Starter Edition: This option is not 
available for Quality Center Starter Edition.

Project Lists Enables you to add customized lists to a project. A 
list contains values that the user can enter in system 
or user-defined fields. For example, for the Detected 
in Build field, you can create a selection list 
containing the values Build1, Build2, and Build3.

Automail Enables you to set up automatic mail notification 
rules to inform users via email each time changes 
are made to specified defects.

Alert Rules Enables you to activate alert rules for your project. 
This instructs ALM to create alerts and send emails 
when changes occur in the project.

Workflow Enables you to generate scripts that perform 
commonly needed customizations on dialog box 
fields in the Defects module. In addition, you can 
write scripts to customize dialog boxes in other 
modules, and control the actions that users can 
perform.

Option Description
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Adding a New Project User

You can control access to an ALM project by defining the users who can log 
in to the project, and by specifying the types of tasks each user may 
perform.

For each project, you select project users from the ALM site users list. This 
list is created in Site Administration.

From Project Customization, you add users to a project and assign them to 
user groups. Each user group has access to certain ALM tasks. 

In this exercise, you will add a new project user to the ALM_Demo project.

Note: For the purpose of the exercise, we will first remove a user from the 
project, and then add the user to the project again.

Project Planning and 
Tracking

Enables you to create and customize the project 
planning and tracking (PPT) KPIs. ALM Editions: 
The Project Planning and Tracking link in Project 
Customization is not available for Quality Center 
Starter Edition and Quality Center Enterprise 
Edition.

Project Report 
Templates

Enables you to create and customize report 
templates that project users can assign to template 
based reports.

Sprinter Enables you to configure settings for working with 
HP Sprinter for manual testing in ALM. 
ALM Editions: The Sprinter link in Project 
Customization is not available for Quality Center 
Starter Edition and Performance Center Edition.

Option Description
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To add a new project user:

 1 Make sure that you are logged in to ALM as a project administrator.

For more information on how to open the Project Customization 
window, see "Starting Project Customization" on page 176.

 2 Open the Project Users page.

In the Project Customization window, click the Project Users link. The 
Project Users page opens and displays a list of users that have been 
assigned to the project.

 3 Remove a user.

In the Project Users list, select cecil_alm, and click Remove User. Click Yes 
to confirm.

 4 Add a new user name.

 a Click the Add User arrow.

You can add an existing user from the list of site users by typing the 
user’s name or by selecting the user from the list of site users. You can 
also create a new user and add the new user to the project.
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 b Select Add User by Name. The Add User dialog box opens.

 c In the User Name box, type cecil_alm and click OK.

The new user is added to the Project Users list and the user properties 
are displayed in the Details tab. User personal settings are defined in 
Site Administration.
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Assigning a User to a User Group

To enable users to do their job, and to protect a project from unauthorized 
access, ALM enables you to assign each user to a specific user group. Each 
group has access to certain ALM tasks. You can use the predefined user 
groups with their default permissions or you can customize your own user 
groups with unique sets of permissions. 

In this exercise, you will assign the new user cecil_alm to the QATester user 
group.

To assign a user to a user group:

 1 Make sure that the Project Users page is displayed.

If the Project Users page is not already open, click the Project Users link in 
the Project Customization window.

 2 Select cecil_alm from the Project Users list.

In the Project Users list, select cecil_alm. 
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 3 Display user’s membership in user groups.

Click the Membership tab. The user groups that cecil_alm belongs to and 
does not belong to are displayed. 

By default, a new user is assigned to the Viewer user group.

 4 Assign cecil_alm to the QATester group.

Under Not Member of, select QATester and click the right arrow button 
to move the group to Member of.

 5 Remove cecil_alm from the Viewer group.

 a Under Member of, select Viewer and click the left arrow button to 
move the group to Not Member Of.

 b Click Save to save the changes to the Project Users page. Click OK.
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Defining a User-Defined Field

You can define user-defined fields that are unique to your project, or modify 
the behavior of ALM system fields.

The fields are stored in ALM project entities. For example, the Defect entity 
contains data entered in the Defects module.

In the following exercise, you will add the Database user-defined field to the 
Defect entity. This field indicates the server database in use when testing an 
application.

To add a user-defined field:

 1 Make sure that the Project Customization window is displayed.

For more information on how to open the Project Customization 
window, see "Starting Project Customization" on page 176.

 2 Open the Project Entities page.

In the Project Customization window, click the Project Entities link. The 
Project Entities page opens.
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 3 Add a new user-defined field to the Defect entity.

 a Under Project Entities, expand Defect. 

 b Click the User Fields folder and click the New Field button. A new field 
is added under the User Fields folder.

BG_USER_nn indicates a user-defined field under the Defect entity.

 4 Rename the default field name.

 a In the Label box, instead of the default name, type Database. 

 b Click Save.

 c Click OK.
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Creating a Project List

You can associate fields with system and user-defined lists. A list contains 
values that the user can enter in a field. 

In the previous exercise you added the Database field. In the following 
exercise you will create a list and assign it to the Database field. You will 
then open the New Defect dialog box to view the new field.

To create a project list:

 1 Make sure that the Project Customization window is displayed.

For more information on how to open the Project Customization 
window, see "Starting Project Customization" on page 176.

 2 Open the Project Lists page.

In the Project Customization window, select the Project Lists link. The 
Project Lists page opens.
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 3 Create a new list.

 a Click New List. The New List dialog box opens.

 b In the List Name box, type DB. Click OK to close the New List dialog 
box.

 4 Add Items to your list.

 a Click New Item. The New Item dialog box opens. Type Oracle and click 
OK.

 b Repeat the same procedure and add MS SQL to the DB list.

 c Click Save to save the changes to the Project Lists page. Click OK.

 5 Assign the list to the Database field.

 a In the Project Customization window, click the Project Entities link. 
The Project Entities page opens.

 b Under Project Entities, expand Defect.

 c Expand the User Fields folder and select Database.
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 d Under Settings, in the Type list, select Lookup List to set the field type 
as a drop-down list. The Lookup list section is displayed below the field 
settings.

 e Under Lookup List, select the DB list. 

 f Click Save to save the changes to the Project Entities page. Click OK.
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 6 View the new user-defined field in the New Defect dialog box.

 a Click the Return button located on the upper-right corner of the 
window. 

 b In the Customization Changes dialog box, select Major Change, and 
click OK. The Project Customization window closes, and you return to 
your ALM project.

 c In the Defects module, click the New Defect button. The New Defect 
dialog box opens. 

The Database field is displayed in the New Defect dialog box. You may 
need to drag the scroll bar down to display the field.

 d Click the down arrow and view the database types you defined. Click 
Close.

New user-defined 
field
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11
Conclusion

ALM helps you organize and manage all phases of the application lifecycle 
management process, including defining releases, specifying requirements, 
planning tests, executing tests, and tracking defects. Throughout each 
phase, you can analyze data by generating detailed reports and graphs.

Phase Description

Release 
Specifications

Develop a release-cycle management plan to help you 
manage application releases and cycles more efficiently. 
You can track the progress of an application release 
against your plan to determine whether your release is on 
track. 

Requirement 
Specifications

Define requirements to meet your business and testing 
needs. You can manage the requirements and conduct 
multi-dimensional traceability between requirements, 
tests and defects, across multiple releases and cycles. ALM 
provides real-time visibility of requirements coverage and 
associated defects to evaluate quality and business risk.

Test Planning Based on the project requirements, you can build test 
plans and design tests. ALM provides a repository for both 
manual and automated tests.
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Test Execution Create a subset of the tests in your project designed to 
achieve specific test goals. ALM supports sanity, 
functional, regression, and advanced testing. Execute 
scheduled tests to diagnose and resolve problems. 

Defect Tracking Submit defects and track their repair progress. Analyzing 
defects and defect trends helps you make effective “go/no-
go” decisions. ALM supports the entire defect lifecycle—
from initial problem detection through fixing the defect 
and verifying the fix.

Phase Description



 




	HP Application Lifecycle Management 11.00 Tutorial 
	Table of Contents
	Welcome to This Tutorial
	How This Tutorial Is Organized
	Before You Begin
	Documentation Library
	Documentation Library Guides
	Additional Online Resources

	Introducing HP ALM
	The Application Lifecycle Management Process
	Starting ALM
	The ALM Window
	The Mercury Tours Sample Web Site

	Specifying Releases and Cycles
	Defining Releases and Cycles
	Viewing Releases and Cycles

	Specifying Requirements
	Defining Requirements
	Viewing Requirements
	Converting Requirements to Tests

	Planning Tests
	Developing a Test Plan Tree
	Designing Test Steps
	Defining Test Parameters
	Defining Test Configurations
	Creating and Viewing Coverage
	Creating Coverage
	Analyzing Coverage

	Copying Test Steps
	Generating Automated Test Scripts

	Running Tests
	Defining Test Sets
	Adding Tests to a Test Set
	Scheduling Test Runs
	Running Tests Manually
	Running with Sprinter
	Running with Manual Runner

	Viewing and Analyzing Test Results
	Viewing Test Results
	Viewing Test Coverage
	Viewing Coverage Progress

	Running Tests Automatically

	Adding and Tracking Defects
	How to Track Defects
	Adding New Defects
	Matching Defects
	Updating Defects
	Linking Defects to Tests
	Creating Favorite Views

	Alerting on Changes
	Triggering an Alert
	Creating Follow Up Alerts

	Analyzing ALM Data
	Generating Project Reports
	Generating Predefined Standard Reports
	Generating Graphs
	Generating Graphs in the Analysis View Module
	Generating Predefined Graphs
	Sharing Graphs

	Generating Dashboard Pages

	Creating Libraries and Baselines
	Creating Libraries
	Creating Baselines
	Comparing Baselines

	Customizing Projects
	Starting Project Customization
	Adding a New Project User
	Assigning a User to a User Group
	Defining a User-Defined Field
	Creating a Project List

	Conclusion



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /None
  /Binding /Left
  /CalGrayProfile (Gray Gamma 2.2)
  /CalRGBProfile (Adobe RGB \0501998\051)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Error
  /CompatibilityLevel 1.4
  /CompressObjects /Off
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.0000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize false
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Remove
  /UsePrologue false
  /ColorSettingsFile (None)
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 300
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /JPXEncode
  /AutoFilterColorImages false
  /ColorImageAutoFilterStrategy /JPEG2000
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 100
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 300
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /JPXEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG2000
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 100
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck true
  /PDFX3Check false
  /PDFXCompliantPDFOnly true
  /PDFXNoTrimBoxError false
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile (None)
  /PDFXOutputConditionIdentifier (CGATS TR 001)
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /False

  /Description <<
    /CHS <>
    /CHT <>
    /DAN <>
    /DEU <>
    /ESP <>
    /FRA <>
    /ITA (Utilizzare queste impostazioni per creare documenti Adobe PDF che devono essere conformi o verificati in base a PDF/X-1a:2001, uno standard ISO per lo scambio di contenuto grafico. Per ulteriori informazioni sulla creazione di documenti PDF compatibili con PDF/X-1a, consultare la Guida dell'utente di Acrobat. I documenti PDF creati possono essere aperti con Acrobat e Adobe Reader 4.0 e versioni successive.)
    /JPN <>
    /KOR <>
    /NLD (Gebruik deze instellingen om Adobe PDF-documenten te maken die moeten worden gecontroleerd of moeten voldoen aan PDF/X-1a:2001, een ISO-standaard voor het uitwisselen van grafische gegevens. Raadpleeg de gebruikershandleiding van Acrobat voor meer informatie over het maken van PDF-documenten die compatibel zijn met PDF/X-1a. De gemaakte PDF-documenten kunnen worden geopend met Acrobat en Adobe Reader 4.0 en hoger.)
    /NOR <>
    /PTB <>
    /SUO <>
    /SVE <>
    /ENU (Use these settings when submitting to HP. These settings require font embedding.)
  >>
  /Namespace [
    (Adobe)
    (Common)
    (1.0)
  ]
  /OtherNamespaces [
    <<
      /AsReaderSpreads false
      /CropImagesToFrames true
      /ErrorControl /WarnAndContinue
      /FlattenerIgnoreSpreadOverrides false
      /IncludeGuidesGrids false
      /IncludeNonPrinting false
      /IncludeSlug false
      /Namespace [
        (Adobe)
        (InDesign)
        (4.0)
      ]
      /OmitPlacedBitmaps false
      /OmitPlacedEPS false
      /OmitPlacedPDF false
      /SimulateOverprint /Legacy
    >>
    <<
      /AddBleedMarks false
      /AddColorBars false
      /AddCropMarks false
      /AddPageInfo false
      /AddRegMarks false
      /ConvertColors /ConvertToCMYK
      /DestinationProfileName ()
      /DestinationProfileSelector /DocumentCMYK
      /Downsample16BitImages true
      /FlattenerPreset <<
        /PresetSelector /HighResolution
      >>
      /FormElements false
      /GenerateStructure false
      /IncludeBookmarks false
      /IncludeHyperlinks false
      /IncludeInteractive false
      /IncludeLayers false
      /IncludeProfiles false
      /MultimediaHandling /UseObjectSettings
      /Namespace [
        (Adobe)
        (CreativeSuite)
        (2.0)
      ]
      /PDFXOutputIntentProfileSelector /DocumentCMYK
      /PreserveEditing true
      /UntaggedCMYKHandling /LeaveUntagged
      /UntaggedRGBHandling /UseDocumentProfile
      /UseDocumentBleed false
    >>
  ]
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice




