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0
Welcome to Astra QuickTest

Welcome to Astra QuickTest, Mercury Interactive’s functional testing tool for Web 
sites. Astra QuickTest provides everything you need to quickly create and run 
tests.

Using This Guide

This guide describes how to use Astra QuickTest to test your Web site. It provides 
step-by-step instructions to help you create, debug, and run tests, and report 
defects detected during the testing process.

This guide contains 6 parts:

 Part  I: Starting the Testing Process

Provides an overview of Astra QuickTest and the main stages of the testing 
process.

 Part  II: Creating Tests

Describes how to create tests, insert checkpoints, assign parameters, use regular 
expressions, actions, and handle unexpected events that occur during a test run.
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 Part  III: Running and Debugging Tests

Describes how to run tests and analyze test results, and how to control test runs 
to identify and isolate bugs in test scripts.

 Part  IV: Advanced Features

Describes how to enhance your test in Expert View mode and introduces several 
programming techniques to create a more powerful test. It also describes how to 
streamline the testing process of your Web sites. This section is recommended 
for advanced users of Astra QuickTest.

 Part  V: Configuring Astra QuickTest

Describes how to change Astra QuickTest’s default settings, both globally and per 
test. It also describes how to customize the test script editor. 

 Part  VI: Working with TestDirector

Describes how Astra QuickTest interacts with TestDirector, Mercury Interactive’s 
test management tool.
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Online Resources

Astra QuickTest includes the following online resources:

Read Me First provides last-minute news and information about Astra QuickTest.

Astra QuickTest Tutorial teaches you basic Astra QuickTest skills and shows 
you how to start  testing your Web site.

Mercury Tours sample Web site is the basis for many examples in this book. The 
URL for this Web site is http://astra.mercuryinteractive.com/mercurytours.

Astra QuickTest  Help describes dialog boxes and toolbar buttons, and provides 
procedural information.

Astra QuickTest Function Reference gives you online access to the Astra 
VBScript functions, including a description of each object, a list of the functions 
(methods) associated with each object, and description syntax and usage of each 
function (method).

VBScript Reference describes Microsoft’s VBScript language, and includes a 
tutorial and function reference.

Technical Support Online uses your default Web browser to open Mercury 
Interactive’s Customer Support Web site. The URL for this Web site is 
http://support.mercuryinteractive.com.
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Support Information presents the locations of Mercury Interactive’s Customer 
Support Web site and home page, the e-mail address for sending information 
requests, the name of the relevant news group, the location of Mercury 
Interactive’s public FTP site, and a list of Mercury Interactive’s offices around the 
world.

Mercury Interactive on the Web uses your default Web browser to open 
Mercury Interactive’s home page. This site provides you with the most up-to-date 
information on Mercury Interactive and its products. This includes new software 
releases, seminars and trade shows, customer support, educational services, 
and more. The URL for this Web site is http://www.mercuryinteractive.com.
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Typographical Conventions

This book uses the following typographical conventions:

1, 2, 3 Bold numbers indicate steps in a procedure.

• Bullets indicate options and features.

> The greater than sign separates menu levels (for 
example, File > Open).

Bold Bold text indicates function names.

Italics Italic text indicates variable names.

Helvetica The Helvetica font is used for examples and statements 
that are to be typed in literally.

[  ] Square brackets enclose optional parameters.

{ } Curly brackets indicate that one of the enclosed values 
must be assigned to the current parameter. 

... In a line of syntax, an ellipsis indicates that more items of 
the same format may be included. In a program example, 
an ellipsis is used to indicate lines of a program that were 
intentionally omitted.

| A vertical bar indicates that either of the two options 
separated by the bar should be selected.
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Starting the Testing Process
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Introduction

Welcome to Astra QuickTest, Mercury Interactive’s functional testing tool for Web 
sites. This guide provides you with detailed descriptions of Astra QuickTest 
features and testing procedures.

Testing with Astra QuickTest

Astra QuickTest facilitates creating tests on your Web site by recording as you 
navigate. As you navigate through your site, Astra QuickTest records each step 
you perform and generates a test that graphically displays this step in an icon-
based test tree. For example, clicking a link, selecting a check box, or submitting 
a form are all recorded in your test. 

In addition, you can instruct Astra QuickTest to check the response of your site to 
specific Web objects, text strings, or tables. For example, you can instruct Astra 
QuickTest to check that a specific text string appears in a particular location on 
your Web page, or you can check that a hypertext link goes to the correct URL 
address.
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After you record, you can further enhance your test by adding and modifying steps 
in the test tree. When you run the test, Astra QuickTest connects to your site and 
performs each step in your test. After you run your test, you can view a report 
detailing which steps in your test succeeded or failed.

Note that by default, each test includes a single action, however a test can include 
multiple actions. Most of the chapters in this guide provide information on how to 
work with a single action. For information on why and how to work with multiple 
actions in a test, see Chapter 10, Working with Actions. 
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Astra QuickTest Testing Process

Testing with Astra QuickTest involves 3 main stages:
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Creating Tests
You create a test by recording a Web session to check the functionality of your 
site.

To create a test:

• Record a session on your site. 

As you navigate through your site, Astra QuickTest graphically displays each 
step you perform in the form of a collapsible icon-based test tree. A step 
changes the content of a Web page in your site, for example, clicking a link or 
image, or submitting a data form. For more information, see Chapter 3, Creating 
Tests. 

• Insert checkpoints into your test. 

A checkpoint searches for a specific value of a page, object or text string on a 
Web page and enables you to identify whether or not your Web site is 
functioning correctly. You can check a Web page for objects, text strings, and 
tables. For more information, see Chapter 4, Creating Checkpoints. 

• Broaden the scope of your test by replacing fixed values with parameters.

When you test your site, you can parameterize your test to check how your Web 
site performs the same operations with multiple sets of data. The data is stored 
in a table in the Data pane. When you parameterize your test, Astra QuickTest 
substitutes the parameters in your test with values from the table. During each 
iteration of your test, Astra QuickTest changes the values in the parameterized 
statements. For more information, see Chapter 6, Parameterizing Tests. 
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You can also use output parameters to parameterize your test. An output 
parameter is a value retrieved from a parameter in your test during the test run, 
and entered into your table in the Data pane. You can subsequently use this 
output parameter as an input variable in your test. This enables you to use data 
retrieved during a test in other parts of the test. For more information, see 
Chapter 7, Creating Output Parameters. 

Running Tests
After you create your test, you run it to check the behavior of your Web site.

You can:

• Run your test to check your site.

The test runs from the first line in your test and stops at the end of the test. While 
running, Astra QuickTest connects to your Web site and performs each operation 
in your test, checking any text strings, objects or tables you specified. If you 
parameterized your test, Astra QuickTest repeats the test for each set of data 
values you defined. For more information, see Chapter 13, Running Tests. 

• Run a test to debug your test.

You can control your test run to help you identify and eliminate defects in your 
test. You can use the Step commands to run your test step by step. You can also 
set breakpoints to pause your test at pre-determined points. For more 
information, see Chapter 15, Debugging Tests. 
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Analyzing Test Results
After you run your test, you can view the test results.

You can:

• View the test results in the Test Results window.

After you run your test, the Test Results window opens and displays the results 
of your test. You can view a summary of your test results or a detailed report. For 
more information, see Viewing the Results of a Test Run on page 236.

• Report defects detected during a test run.

If a test run detects a defect in you site, you can report it using the Web Defect 
Manager, Mercury Interactive’s system for reporting and tracking defects and 
errors over the World Wide Web. 

The Web Defect Manager is a scalable, cross-platform defect tracking system 
that helps you monitor defects closely from initial detection until resolution. The 
Web Defect Manager is tightly integrated with TestDirector, Mercury Interactive's 
test management tool. 

For more information on the Web Defect Manager, see Chapter 25, Reporting 
Defects.  For more information on TestDirector , see Chapter 24, Managing the 
Testing Process. 
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Expert View

You can use the Expert View tab to view a text-based version of your test. The 
test script is composed of VBScript statements (Microsoft’s Visual Basic Scripting 
language) that correspond to the steps and checks displayed in your test tree. For 
more information, see Chapter 18, Testing in the Expert View. 

Actions

You can divide your test into sections called “actions.” This enables you to 
parameterize only part of your test. It also enables you to use an action in multiple 
tests by importing it from one test into another test. For more information on 
parameterizing tests, see Chapter 6, Parameterizing Tests.  For more 
information on working with actions, see Chapter 10, Working with Actions. 

Sample Site

Many examples in this guide use the Mercury Tours sample Web site. The URL 
for this Web site is http://astra.mercuryinteractive.com/mercurytours.

The first page of the Mercury Tours site is the login page. You must log in to begin 
using the site. To log in, enter “mercury” as your member name and “mercury” 
as your password.
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Managing the Testing Process

Astra QuickTest works with TestDirector, Mercury Interactive’s test management 
tool. You can use TestDirector to create a project (central repository) of manual 
and automated tests, build test cycles, run tests, and report and track defects. You 
can also create reports and graphs to help you review the progress of test 
planning, test runs, and defect tracking before a software release.

When you work in Astra QuickTest, you can create and save tests directly to your 
TestDirector project. You can also run Astra QuickTest tests from TestDirector and 
then use TestDirector to review and manage the results. For more information, 
see Chapter 24, Managing the Testing Process. 
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Astra QuickTest at a Glance

This chapter explains how to start Astra QuickTest and introduces the Astra 
QuickTest window.

This chapter describes:

• Starting Astra QuickTest

• The Astra QuickTest Window

• Test Pane

• Display Pane

• Data Pane

• Using Astra QuickTest Commands
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Starting Astra QuickTest

To start Astra QuickTest, click Programs > Astra QuickTest > Astra QuickTest 
in the Start menu. 

The first time you start Astra QuickTest, the Welcome to Astra QuickTest window 
opens. You can choose to open the Astra QuickTest tutorial, start recording a new 
test, open an existing test, or open a new test.
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If you do not want this window to appear the next time you start Astra QuickTest, 
select the Don’t show this dialog next time check box.
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The Astra QuickTest Window

The Astra QuickTest window contains the following key elements:

• Astra QuickTest title bar, displaying the name of the currently open test

• Menu bar, displaying menus of Astra QuickTest commands

• File toolbar, containing buttons to assist you in managing your test

• Main toolbar, containing buttons to assist you in the testing process

• Debug toolbar, containing buttons to assist you in debugging your test

• Test pane, containing two tabs to view your test—the Tree View and the Expert 
View

• Display pane, containing three tabs to assist you in the testing process—
ActiveScreen and Defect Report

• Data pane, containing two tabs to assist you in parameterizing your test—Global 
and Action

• Status bar, displaying the status of the test
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Test Pane

The Test pane contains two tabs to view your test—Tree View and Expert View. 

Tree View Tab
In the Tree View tab (default mode), Astra QuickTest displays your test in the form 
of a collapsible icon-based test tree. Each operation performed on your Web site 
is recorded as an icon in your test tree. For every icon in the Tree View, Astra 
QuickTest displays a corresponding line of script in the Expert View.
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Expert View Tab
In the Expert View tab, Astra QuickTest displays your test in the form of a test 
script instead of a test tree. Your test script is composed of VBScript statements. 
For every statement in the Expert View tab, a corresponding icon exists in the test 
tree in the Tree View tab. For more information on using the Expert View, see 
Chapter 18, Testing in the Expert View.  
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Display Pane

Astra QuickTest’s Display pane contains two tabs to assist you in the testing 
process—the ActiveScreen and the Defect Report. To view this pane, click the 
Display Views button or choose View > Display Views.

ActiveScreen Tab
The ActiveScreen tab displays the Web page or object corresponding to a 
highlighted step in your test. It provides you with an easy way to view your test, 
make modifications, and add checkpoints.

Defect Report Tab
The Defect Report tab displays the Web Defect Manager, Mercury Interactive's 
system for reporting and tracking software defects and errors over the World Wide 
Web. The Web Defect Manager is a scalable, cross-platform defect tracking 
system that helps you monitor defects closely from initial detection until 
resolution. For more information, refer to the online Web Defect Manager User’s 
Guide, which you can open from the Help link in the Web Defect Manager.
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Data Pane

In a new test, the Data pane contains two tabs to assist you in parameterizing your 
test—Global and Action1. If you add new actions to your test, corresponding 
action tabs are added to the data pane. To view this pane, click the Data Views 
button or choose View > Data Views.

Global Tab
The Global tab contains variable values for the parameters defined in your 
parameterized test. The variable values are available for an entire test. When you 
run your parameterized test, Astra QuickTest inserts the data from the Global tab 
into the test. For more information, see Chapter 10, Working with Actions. 

Action Tab
The Action tab contains variable values for the parameters defined in your 
parameterized test. The variable values are available only for a specific action 
and not for an entire test. When you run your parameterized test, Astra QuickTest 
inserts the data from the Action tab into the relevant action in the test. For more 
information, see Chapter 10, Working with Actions. 
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Using Astra QuickTest Commands

You can select Astra QuickTest commands from the menu bar or from a toolbar. 
Certain Astra QuickTest commands can also be executed by pressing shortcut 
keys.

Choosing Commands on a Menu
You can choose all Astra QuickTest commands from the menu bar. 

Clicking Commands on a Toolbar
You can execute some Astra QuickTest commands by clicking buttons on the 
toolbars. Astra QuickTest has three built-in toolbars: the File toolbar, the Main 
toolbar, and the Debug toolbar. 
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File Toolbar

The File toolbar contains buttons for managing a test. For more information on 
managing your test, see Chapter 3, Creating Tests.  The following buttons 
appear on the File toolbar:

Main Toolbar

The Main toolbar contains buttons for the commands used when creating and 
maintaining your test. The following buttons appear on the Main toolbar:

Open

SaveNew

Print

Display 
Views

Data
Views

Test 
Results

New 
Action

Insert
CheckpointStop

Start
Run

Record
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Debug Toolbar

The Debug toolbar contains buttons for the commands used when debugging the 
steps in your test. The following buttons appear on the Debug toolbar:

Executing Commands Using Shortcut Keys
You can execute some Astra QuickTest commands by pressing shortcut keys. 
The following shortcut keys appear on the corresponding menu commands:

Command Shortcut Key Function

New Ctrl + N
Creates a new test and closes your 
browser. 

Open Ctrl + O Opens a test. 

Save Ctrl + S Saves the active test. 

Print Ctrl + P Prints the active test. 

Step 
Into

Step 
Over

Pause

Step 
Out

Toggle 
Breakpoints

Clear All 
Breakpoints
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Function Arguments Alt + Enter
Opens the Function Arguments 
dialog box. 

Object Properties Ctrl + Enter
Opens the Object Properties dialog 
box. 

Properties Alt + Enter
Opens the Script Line Properties 
dialog box (Expert View only). 

Undo Ctrl + Z
Reverses the last command or 
deletes the last entry you typed 
(Expert View only). 

Redo Ctrl + Y
Reverses the action of the Undo 
command (Expert View only). 

Cut Ctrl + X
Removes the selection from your 
test. 

Copy Ctrl + C Copies the selection from your test.

Paste Ctrl + V Pastes the selection to your test. 

Delete Del Deletes the selection from your test. 

Rename F2
Changes the name of an action or a 
step (Tree View only). 

Find Ctrl + F
Searches for a specified character 
(Expert View only). 

Command Shortcut Key Function



Starting the Testing Process • Astra QuickTest at a Glance

Astra QuickTest User’s Guide Chapter 2, page 40

In

Back

Find

Find

Chapter
Top of

 Again

Replace Ctrl + H
Searches and replaces a specified 
character (Expert View only). 

Go To Ctrl + G
Moves to a particular line in the test 
(Expert View only). 

Complete Word Ctrl + Space

When you type the beginning of a 
VBScript function or object, 
completes the word (Expert View 
only). 

Parameter Info
Ctrl + Shift + 
Space

Displays the syntax of a parameter 
(Expert View only). 

Checkpoint F12
Creates a checkpoint for an object, 
or a table.

Output Parameter Ctrl + F12
Creates an output parameter for a 
text string, an object, or a table.

Run F5
Runs the test from the beginning or 
from the line at which the test was 
stopped.

Stop F4 Stops test recording or the test run.

Pause PAUSE
Stops the test run after the statement 
has been executed. The test run can 
be resumed from this point.

Command Shortcut Key Function
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Step Into F11

Runs only the current line of the test 
script. If the current line calls a 
function, the function is displayed in 
the view but is not executed.

Step Over F10

Runs only the current line of the test 
script. When the current line calls a 
function, the function is executed in 
its entirety, but is not displayed in the 
view.

Step Out Shift + F11

Runs to the end of the function then 
pauses execution. (Available only 
after running a function using Step 
Into.)

Toggle Breakpoint F9
Sets or clears a breakpoint in the 
test.

Clear All Breakpoints Ctrl + Shift + F9 Deletes all breakpoints in the test.

Command Shortcut Key Function
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Part II

Creating Tests
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�
Creating Tests

You can quickly create a test by recording the operations you perform on your 
Web site. 

This chapter describes:

• Planning a Test

• Recording a Test

• Creating Checkpoints

• Understanding Your Test

• Modifying Steps in Your Test

• Changing the ActiveScreen

• Managing a Test
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About Creating Tests

Astra QuickTest enables you to generate an automated test by recording the 
typical processes that you perform on your Web site. As you navigate through 
your site, Astra QuickTest graphically displays each step you perform as an icon 
in a test tree. A step is anything a user does that changes the content of a Web 
page in your site, for example, clicking a link, or typing data into an edit box. 

While recording, you can insert checkpoints into your test. A checkpoint compares 
the current value of the specified property with the expected one in order to help 
you determine whether or not your Web site is functioning correctly.

When you test your site, you may want to check how it performs the same 
operations with multiple sets of data. This is called parameterizing your test. The 
data is stored in a table in the Data pane. When you parameterize your test, Astra 
QuickTest substitutes the parameters in your test with values from the table. 
During each iteration, or repetition, of your test, Astra QuickTest inserts a different 
value in the parameterized statements. Astra QuickTest runs one iteration of your 
test for each set of values in the Data pane.

After recording, you can further enhance your test by adding and modifying steps 
in the test tree. 



Creating Tests • Creating Tests

Astra QuickTest User’s Guide Chapter 3, page 45

Back

Find

Find

Chapter
Top of

 Again

Planning a Test

Before you start recording, you should plan your test. You should consider the 
following:

• Determine the functionality you want to test. Short tests that check specific 
functions of the site or complete a transaction are better than long tests that 
perform several tasks.

• Decide which information you want to check during the test. A checkpoint can 
check for differences in the text strings, objects, and tables in your site. For more 
information, see Chapter 4, Creating Checkpoints. 

• Evaluate the types of events you need to record. If you want to record more or 
fewer events than Astra QuickTest generally records by default, you can 
configure the events you want to record. For more information, see Chapter 16, 
Configuring Event Recording. 

• Consider increasing the power and flexibility of your test by replacing fixed 
values with parameters. When you parameterize your test, you can check how it 
performs the same operations with multiple sets of data. For more information, 
see Chapter 6, Parameterizing Tests.  

• You can change the way that Astra QuickTest identifies objects in your 
application. This is particularly helpful when running tests on objects that change 
frequently or are created using dynamic content, e.g. from a database. For 
additional information, see Chapter 12, Understanding How Astra QuickTest 
Identifies Objects. 

• If you are an advanced user, consider using actions to streamline the testing 
process. For additional information, see Chapter 10, Working with Actions. 
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Recording a Test

You create a test by recording the typical processes that users perform on your 
Web site. Astra QuickTest records each step you perform and generates a test 
tree. 

Note that by default, each test includes a single action, but a test can include 
multiple actions. This chapter describes how to record a test with a single action. 
For information on why and how to work with multiple actions, see Chapter 10, 
Working with Actions.  

Consider the following guidelines when recording a test:

• Before you start to record, close all applications not required for the test.

• Determine the security zone of your site. When you record your test, the Web 
browser may prompt you with security alert dialog boxes. You may choose to 
disable/enable these dialog boxes.

• You can control how Astra QuickTest records and displays your tests by setting 
testing options in the Options dialog box. For more information, see Chapter 21, 
Setting Astra QuickTest Testing Options. 
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To record a test:

 1 Open Astra QuickTest. For more information, see Starting Astra QuickTest on 
page 26.

 2 Open a test:

• To create a new test, click the New button or choose File > New. 

• To open an existing test, click the Open button or choose File > Open. In the 
Open Astra Test dialog box, select a test and click Open.

For more information, see Managing a Test on page 57.

 3 Click the Start Record button or choose Test > Record.

• If this is your first recording session in a test, the Start Recording dialog box 
opens.
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Choose which browser to use and whether to use an existing Web browser 
window or to open a new browser window to a specified location.

If you select Open new Web browser window at the following URL, type 
or select the Web address from which you want to start recording the test. By 
default , the URL for the Mercury Tours site appears as the address.

Click OK. If you chose to open a new Web browser, then it opens, displaying 
the Web address you specified. 

Note: If you choose to use an existing Web browser window, then you must start 
the browser session after starting Astra QuickTest.

• If this is not your first recording session in a test, Astra QuickTest remembers 
your choices from the previous session. Proceed to step 4.

 4 Navigate through your site. Astra QuickTest records each step you make in the 
test tree in the Tree View tab.

 5 You can insert text checkpoints, object checkpoints, and table checkpoints to 
compare the current value of the specified property with the expected one, in 
order to determine whether or not a site is functioning correctly. For more 
information, see Chapter 4, Creating Checkpoints. 
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 6 You can parameterize your test to check how it performs the same operations 
with multiple sets of data. For more information, see Chapter 6, Parameterizing 
Tests. 

 7 When you complete your Web session, click the Stop button or choose Test > 
Stop. 

 8 To save your test, click the Save button or choose File > Save. Assign a name to 
the test. For more information, see Managing a Test on page 57.
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Creating Checkpoints

Astra QuickTest enables you to add checkpoints to your test. A checkpoint is a 
verification point that compares a current value for a specified property with the 
expected value for that property. This enables you to identify whether or not your 
Web site is functioning correctly.

You can create checkpoints to check various objects in a Web site. You can check 
Web page statistics, text strings, objects, and tables. You can also use formulas 
to check that the data displayed on a Web page is valid. For information, see 
Chapter 5, Checking Web Objects. 

For general information about creating checkpoints, see Chapter 4, Creating 
Checkpoints.  
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Understanding Your Test

While recording, Astra QuickTest creates a test tree—a graphical representation 
of the navigation you perform on your site. The test tree appears in the Tree View 
tab. Each step in the tree represents a step performed on your site and browser.

The following is a sample test of a login procedure to the Mercury Tours site, 
Mercury Interactive’s sample Web site.

The table below provides an explanation of each step in the tree.

Step Description

The action number.

The browser invokes the Mercury Tours site.

The name of the Web page. 
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A checkpoint that checks for broken links in the 
Mercury Tours page. 

username is the name of the edit box. Set is the 
method performed on the edit box. mercury is the 
value of the edit box.

password is the name of the edit box. SetSecure is 
an encrypt method performed on the edit box. 
381c384c is the encrypted value of the password.

Login is the name of the image. Click is the 
method performed on the image. 52, -8 are the x- 
and y-coordinates where the image was clicked.

Step Description
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Modifying Steps in Your Test

As the content of your Web site changes, you can continue to use tests you 
developed previously. Your test includes all steps you perform, such as clicking 
hypertext and image links. As Web sites change, the objects in the steps may also 
change.

Suppose an object in a step in your test changes. You would need to modify the 
step in your test containing the object so that Astra QuickTest can continue to 
identify it. You can modify the step by modifying one or more property values of 
the object in the Object Properties dialog box. 

For example, the Mercury Interactive Web site (www.mercuryinteractive.com) has 
a “Home” hypertext link. Suppose that the text string in this link is changed to 
“About Mercury Interactive”. You need to update your test so that Astra QuickTest 
will identify the link properly.
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To modify a step in your test:

 1 Right-click the step containing the object that changed, and choose Object 
Properties.

The Object Properties dialog box for the selected object opens and displays the 
properties Astra QuickTest uses to identify the object.

original text

new text
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 2 Highlight the property and value to modify. 

 3 In the Constant box, enter a new value for the property.

 4 Click OK to close the dialog box.
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Changing the ActiveScreen

As the content of your Web site changes, you can continue to use tests you 
developed previously. You simply change the ActiveScreen display so that Astra 
QuickTest can continue to find the objects in your modified site.

For example, suppose that one of the screens in the Mercury Tours site now 
includes a new object and you want add a checkpoint that checks for this object. 
You can use the Change ActiveScreen command to replace the screen in your 
ActiveScreen tab and then proceed to create a checkpoint for this object.

To change the ActiveScreen:

 1 Make sure that your Web browser displays the page that you want to use to 
replace with the current ActiveScreen tab display.

 2 In the test tree, click a step that you want to change, the page is displayed in the 
ActiveScreen tab.

 3 Choose Tools > Change ActiveScreen. The Astra QuickTest window is 
minimized, the mouse pointer becomes a pointing hand.

 4 Click the page displayed in your browser. A message asks you whether you want 
to change your current ActiveScreen display. 

 5 Click Yes.
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Managing a Test

You can use the File toolbar to create, open, save, and print recorded tests. 

Creating a New Test
To create a new test, click the New button or choose File > New. A new test 
opens. You are ready to start recording your test.

Opening an Existing Test
You can open an existing test in order to enhance or run it. 

To open an existing test:

 1 Click the Open button or choose File > Open. The Open Astra Test dialog box 
opens. 

 2 Select a test and click Open. The test opens and the title bar displays the test 
name.
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Saving a Test
You can save a new test or save changes to an existing test.

To save a new test:

 1 Click the Save button or choose File > Save to save the test. The Save Astra 
Test dialog box opens.

 2 Choose the folder in which you want to save the test.

 3 Type a name for the test in the File name box.

 4 Click Save. Astra QuickTest displays the test name in the title bar.

To save changes to an existing test:

• Click the Save button or choose File > Save to save changes to the test.

• Choose File > Save As to save an existing test to a new name or a new location. 

Printing a Test
You can print your test.

To print a test:

 1 Click the Print button or choose File > Print. The Print dialog box opens.

 2 Click OK to print.
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�
Creating Checkpoints

You can check objects in your Web site to ensure that your Web site functions as 
desired.

This chapter describes:

• Checking Objects

• Adding Checkpoints to a Test

• Understanding the Checkpoint Properties Dialog Box

• Modifying Checkpoints
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About Creating Checkpoints

Astra QuickTest enables you to add checks to your test. A checkpoint is a 
verification point that compares a current value for a specified property with the 
expected value for that property. This enables you to identify whether or not your 
Web site is functioning correctly. 

When you add a checkpoint, Astra QuickTest adds a checkpoint icon under the 
highlighted step in the test tree. When you run the test, Astra QuickTest compares 
the expected results of the checkpoint to the current results. If the results do not 
match, the checkpoint fails. You can view the results of the checkpoint in the Test 
Results window.

Checking Objects

You can create checkpoints to check various objects in a Web site. You can check 
Web page statistics, text strings, objects, and tables.You can also use formulas to 
check that the data displayed on a Web page is valid. For information, see 
Chapter 5, Checking Web Objects. 
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Adding Checkpoints to a Test

You can add checkpoints during or after recording a test. It is generally more 
convenient to define checks once the initial test has been recorded.

There are several ways to add checkpoints:

• Use the commands on the Insert menu or click the arrow beside the Insert 
Checkpoint button on the Main toolbar. This displays a menu of checkpoint 
options that are relevant to the selected step in the test tree.

• Right-click the step where you want to add the checkpoint and choose Insert 
Checkpoint.

• Right-click the ActiveScreen and choose Insert Checkpoint. This option can be 
used only after you record a test.

Understanding the Checkpoint Properties Dialog Box

While the Checkpoint Properties dialog box varies slightly depending on the type 
of object you are checking, the Checkpoint Properties dialog box generally 
includes the following basic elements:

Note: The Text Checkpoint Properties dialog box is quite different from the 
Checkpoint Properties dialog box described below. For more information see 
Understanding the Text Checkpoint Properties Dialog Box on page 82.
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Identifying the Object
The top part of the dialog box displays basic information about the object to 
check such as the name and type of object. 

This icon indicates 
that the value of the 
property to check is 
a constant.

The selected check 
box indicates that 
this property will be 
checked.
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Choosing which Property to Check
The next part of the dialog box displays the available properties for the object, 
and enables you to select which properties to check.

You can also create checkpoints on objects with variable descriptions. For more 
information, see Chapter 12, Understanding How Astra QuickTest Identifies 
Objects. 

Modifying the Expected Value
In the Edit value section, you can edit the value of any property that you want to 
check. 

If the expected value of one of the properties you are checking changes, you 
don’t have to rerecord the object. You can modify the expected value by 
selecting the relevant property and changing its value in the Constant box.

You can parameterize the expected value of an object by entering a parameter 
name in the Parameter box and entering the expected values in the appropriate 
column in the data table. For more information on parameterization, see 
Chapter 6, Parameterizing Tests. 

You can also enter the expected value as regular expression in the Constant 
box or in the data table cells for the parameter. If you choose to enter a regular 
expression for the expected value, select Regular expression at the bottom of 
the Edit value section. 

For more information data tables, see Chapter 8, Working with Data Tables.  
For more information on regular expressions, see Chapter 9, Using Regular 
Expressions. 



Creating Tests • Creating Checkpoints

Astra QuickTest User’s Guide Chapter 4, page 64

In

Back

Find

Find

Chapter
Top of

 Again

Modifying Checkpoints

If you already created a checkpoint, or if Astra QuickTest automatically created 
page checkpoints, you can modify the settings. For example, you can choose to 
use parameters, or you can use filters to specify which image sources and links 
to check.

To modify a checkpoint:

 1 Right-click an existing checkpoint in the test tree and choose Function 
Arguments. A checkpoint dialog box opens.

 2 Modify the properties and click OK.

Tip: You can also open a checkpoint dialog box by double-clicking a checkpoint 
in your test tree.
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�
Checking Web Objects

By adding Web object checkpoints to your tests, you can compare Web objects in 
different versions of your Web site. 

This chapter describes:

• Checking Pages

• Checking Text

• Checking Objects

• Checking Tables

About Checking Web Objects

You can check the Web objects in your Web site to ensure that your Web site 
functions as desired. Web object checkpoints compare the expected values of 
object properties to the object’s current values during a test run. You can perform 
checks on Web page properties, text, tables and other Web objects such as 
images and form elements.
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Checking Pages

You can check statistical information on your Web pages by adding page 
checkpoints to your test. These checkpoints check the links and the source of 
images on a Web page. You can also instruct page checkpoints to include a check 
for broken links. 

When you record, by default Astra QuickTest creates automatic page checkpoints 
in your test tree that check the load time of the page. If you instruct Astra 
QuickTest not to create automatic page checkpoints, you can insert them for 
pages you want to check, as described in Creating a Page Checkpoint on page 
67.

Note: You can instruct Astra QuickTest not to create automatic page checkpoints 
in your test tree while you record by clearing the Add automatic checks for 
each page during record check box in the Page Verification tab of the Options 
dialog box. You can also instruct Astra QuickTest not to perform automatic page 
checkpoints when you run your test by clearing the Don’t perform automatic 
checkpoints during test run check box in the Page Verification tab of the 
Options dialog box. For more information, see Chapter 21, Setting Astra 
QuickTest Testing Options. 
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You cannot create a page checkpoint if one has already been created 
automatically. However, you can modify a page checkpoint that has already been 
created, as described in Understanding the Page Checkpoint Properties 
Dialog Box on page 69.

Creating a Page Checkpoint
If you did not choose to add page checkpoints automatically while recording, you 
can add a page checkpoint to your script to check the links and the image sources 
on a selected Web page either while recording or after recording.

To add a page checkpoint while recording:

 1 Click the page step  in your test tree where you want to add a checkpoint. The 
ActiveScreen displays the Web page corresponding to the highlighted step. 

 2 Choose Insert > Checkpoint and click in the page you want to check. The 
Object Selection - Checkpoint Properties dialog box opens. 

 3 Select the page item and click OK. The Page Checkpoint Properties dialog box 
opens. 

 4 Modify the settings for the checkpoint in the Page Checkpoint Properties dialog 
box, as described in Understanding the Page Checkpoint Properties Dialog 
Box on page 69.

 5 When you are done, click OK to close the dialog box.

A tree item with a checkpoint  icon is added to your test tree.
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To add a page checkpoint after recording:

 1 Make sure the Display Views button and the ActiveScreen tab are selected.

 2 Right-click anywhere on the ActiveScreen and choose Insert Checkpoint. The 
Object Selection - Checkpoint Properties dialog box opens. 

 3 Select the page item and click OK. The Page Checkpoint Properties dialog box 
opens. 

 4 Specify the settings for the checkpoint in the Page Checkpoint Properties dialog 
box, as described in Understanding the Page Checkpoint Properties Dialog 
Box on page 69.

 5 When you are done, click OK to close the dialog box.

A tree item with a checkpoint  icon is added to your test tree.
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Understanding the Page Checkpoint Properties Dialog Box
The Page Checkpoint Properties dialog box enables you to choose which 
properties to check.
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Identifying the Object

The top part of the dialog box displays information about the object to check:

Choosing which Property to Check

The default properties for the object are listed in the Properties pane of the 
dialog box. The pane includes the properties, their values, and their types:

Information Description

Logical name The title of the Web page as defined in the HTML code.

Class The type of object.

Pane Element Description

check box For each object class, Astra QuickTest recommends default 
property checks. You can accept the default checks or 
modify them accordingly.
To include a property check, select the corresponding check 
box.
To exclude a property check, clear the corresponding check 
box.

Type The  icon indicates that the value of the property is a 
constant. 
The  icon indicates that the value of the property is a 
parameter.
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Editing the Value of a Property

In the Edit value section, you use the following options to edit the value of the 
property to check:

Property The name of the property to check.

Value The value of the property to check. Note that unless you edit 
this value, the value in the page will be the expected value of 
the property when you run your test. For information about 
editing the value of a property, see Editing the Value of a 
Property on page 71.

Option Description

Constant (default) Sets the value of the property.

Parameter Sets the property value as a parameter. For more 
information, see Chapter 6, Parameterizing Tests. 

Global Adds a parameter to the Global tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Local Adds a parameter to the Action tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Pane Element Description
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Use data table 
formula (advanced)

Inserts two columns in the table in the Data pane: the first 
column contains a formula that checks the validity of output 
in the second column. Astra QuickTest uses the data in the 
second (output) column to compute the formula, and inserts 
a value of TRUE or FALSE in the table cell of the first 
(formula) column. For more information, see Chapter 8, 
Working with Data Tables. 

Regular expression Sets the value as a regular expression. For more 
information, see Chapter 9, Using Regular 
Expressions. 

Option Description
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Checking the HTML Source

In the HTML Source section, you can check the HTML source and tags of the 
page.

Option Description

HTML Source Checks that the source in the web page being tested 
matches the expected HTML code (the source code of the 
page at the time that the test is recorded).

Edit HTML Source 
(enabled only when 
the HTML Source 
check box is 
selected)

Opens the HTML Source dialog box, which displays the 
expected HTML code. Note that you can also use regular 
expressions when editing the expected HTML source code if 
you click the regular expression check box at the bottom of 
the page. Edit the expected HTML source code and click 
OK.

HTML Tags Checks that the HTML tags in the web page being tested 
match the expected HTML tags (the HTML tags on the page 
at the time that the test is recorded).

Edit HTML Tags 
(enabled only when 
the HTML Tags 
check box is 
selected)

Opens the HTML Tags dialog box, which displays the 
expected HTML tags. Note that you can also use regular 
expressions when editing the HTML tags if you click the 
regular expression check box at the bottom of the page. Edit 
the expected HTML tags and click OK.
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Checking All the Objects in a Page

In the All Objects in Page section, you can check all the links, images, and 
broken links in a page. You can use the following options to check the objects in 
a page:

Option Description

Links Checks the functionality of the links in the page.

Filter Link Check Opens the Filter Link Checks dialog box, which enables you 
to specify which hypertext links to check in the page. For 
additional information, see Filtering Hypertext Links on 
page 75.

Images Checks that the images are displayed on the page.

Filter Images 
Check

Opens the Filter Image Check dialog box, which enables you 
to specify which image links to check in the page. For 
additional information, see Filtering Image Sources on 
page 78.

Broken Links Checks for broken links in the page.
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Filtering Hypertext Links
You can filter which hypertext links to check in a page checkpoint using the Filter 
Link Checks dialog box. You open this dialog box from the Page Checkpoint 
Properties dialog box. For additional information, see Checking All the Objects 
in a Page on page 74. 
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Choosing which Hypertext Links to Check

You can choose which hypertext links to check in a page checkpoint.

Pane Element Description

check box Each link on the page has a corresponding check box.
To check a link, select the corresponding check box (by 
default all links are selected).
To exclude a link from the page checkpoint, clear the 
corresponding check box.

Type The  icon indicates that the target URL is a constant. 
The  icon indicates that the target URL is a parameter.

Link name The text in the hypertext link.

Link URL The target URL.
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Editing the Value of the Target URL

In the Edit Value section, you use the following options to edit the value of the 
target URL to which the hypertext links:

Option Description

Constant (default) Sets the value of the target URL.

Parameter Sets the target URL as a parameter. For more information, 
see Chapter 6, Parameterizing Tests. 

Global Adds a parameter to the Global tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Local Adds a parameter to the Action tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Regular expression Sets the value as a regular expression. For more 
information, see Chapter 9, Using Regular 
Expressions. 
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Filtering Image Sources
You can filter which image sources to check in a page checkpoint using the Filter 
Image Check dialog box. You open this dialog box from the Page Checkpoint 
Properties dialog box. For additional information, see Checking All the Objects 
in a Page on page 74.
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Choosing which Image Sources to Check

You can choose which image sources to check in a page checkpoint.

Pane Element Description

check box Each image source on the page has a corresponding check 
box.
To check an image source, select the corresponding check 
box (by default all image sources are selected).
To exclude an image source from the page checkpoint, clear 
the corresponding check box.

Type The  icon indicates that the image source is a constant. 
The  icon indicates that the image source is a parameter.

Image name The name of the image.

Image source The image source file and path.
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Editing the Value of the Path of the Image Source File

In the Edit Value section, you use the following options to edit the path of the 
image source file

Option Description

Constant (default) Sets the value of the path of the image source file.

Parameter Sets the path of the image source file as a parameter. For 
more information, see Chapter 6, Parameterizing Tests. 

Global Adds a parameter to the Global tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Local Adds a parameter to the Action tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Regular expression Sets the value as a regular expression. For more 
information, see Chapter 9, Using Regular 
Expressions. 
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Checking Text

You can check that a specified text string appears on your Web page by adding a 
text checkpoint to your test. To add a text checkpoint to your test, you use the Text 
Checkpoint Properties dialog box. 

Creating a Text Checkpoint
You can add a text checkpoint while recording or afterward.

To add a text checkpoint while recording:

 1 Highlight a text string on the Web page.

 2 Choose Insert > Text Checkpoint.

The mouse pointer turns into a pointing hand.

 3 Click the text string. The Text Checkpoint Properties dialog box opens.

 4 Specify the settings for the checkpoint. For more information, see 
Understanding the Text Checkpoint Properties Dialog Box on page 82.

 5 Click OK to close the dialog box.

A tree item with a checkpoint  icon is added to your test tree.
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To add a text checkpoint after recording:

 1 Make sure the Display Views button and the ActiveScreen tab are selected.

 2 Click a step in your test where you want to add a checkpoint. The ActiveScreen 
displays the Web page corresponding to the highlighted step. 

 3 Highlight a text string on the ActiveScreen.

 4 Right-click the text string and choose Insert Text Checkpoint. The Text 
Checkpoint Properties dialog box opens.

 5 Specify the settings for the checkpoint. For more information, see 
Understanding the Text Checkpoint Properties Dialog Box on page 82.

 6 Click OK to close the dialog box.

A tree item with a checkpoint  icon is added to your test tree.

Understanding the Text Checkpoint Properties Dialog Box
In the Text Checkpoint Properties dialog box, you can specify which text to check 
as well as which text appears before and after the text to check. This is particularly 
helpful when the text string you want to check appears several times in the same 
Web page. For example, suppose you want to check that the “Mercury Tours” text 
string appears in a specific location in the first page of the sample Web site, 
Mercury Tours. This text string actually appears three times on that Web page. To 
check for the text string in a specific location, you can specify which text precedes 
and/or follows the text string you are checking.
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Specifying which Text to Check

In the Check for Text section, you use the following options to specify which text 
to check:

Option Description

Constant (default) The text Astra QuickTest checks when running the test.

Parameter Sets the text string as a parameter. For more information, 
see Chapter 6, Parameterizing Tests. 

Use data table 
formula (advanced)

Inserts two columns in the table in the Data pane. The first 
column contains a formula that checks the validity of output 
in the second column. Astra QuickTest uses the data in the 
second (output) column to compute the formula, and inserts 
a value of TRUE or FALSE in the table cell of the first 
(formula) column. For more information, see Chapter 8, 
Working with Data Tables. 

Global Adds a parameter to the Global tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Local Adds a parameter to the Action tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Regular expression Sets the text string as a regular expression. For more 
information, see Chapter 9, Using Regular 
Expressions. 
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In the Appears After section, you use the following options to specify which text, 
if any, should appear after the text to check:

Match case Conducts a case sensitive search.

Exact match Checks according to the exact expected text.

Text not exist Checks that text string does not appear.

Option Description

Appears after 
(default)

Checks that the text to check appears after the text in this 
box. To ignore the text that appears after the text to check, 
clear this check box.

Constant (default) Displays the text that appears after the text to check.

Parameter Sets the text string as a parameter. For more information, 
see Chapter 6, Parameterizing Tests. 

Option Description
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Specifying What Appears Before the Text to Check

In the Appears Before section, you use the following options to specify which 
text, if any, should appear before the text to check:

Option Description

Appears before 
(default)

Checks that the text to check appears after the text in this 
box. To ignore the text that appears before the text to check, 
clear this check box.

Constant (default) Displays the text that appears before the text to check.

Parameter Sets the text string as a parameter. For more information, 
see Chapter 6, Parameterizing Tests.  
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Checking Objects

You can check that a specified object appears on your Web page by adding an 
object checkpoint to your test. To add an object checkpoint to your test, you use 
the Checkpoint Properties dialog box.

Creating an Object Checkpoint
You can add an object checkpoint while recording or afterward.

To add an object checkpoint while recording:

 1 Click the Insert Checkpoint button or choose Insert > Checkpoint.

The mouse pointer turns into a pointing hand.

 2 Click the object to check. The Object Selection - Checkpoint Properties dialog 
box opens.
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 3 Select the last tree item. The tree item name depends on the object’s class, for 
example:

 4 Click OK. The Checkpoint Properties dialog box opens.

 5 Specify the settings for the checkpoint. For more information, see 
Understanding the Checkpoint Properties Dialog Box on page 90.

 6 Click OK to close the dialog box.

A tree item with a checkpoint  icon is added to your test tree.

Object Class

Check box WebCheckBox

Edit box WebEdit

Image Image

Radio button WebRadio
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To add an object checkpoint after recording:

 1 Make sure the Display Views button and the ActiveScreen tab are selected.

 2 Click a step in your test where you want to add a checkpoint. The ActiveScreen 
displays the Web page corresponding to the highlighted step. 

 3 Right-click an object on the ActiveScreen and choose Insert Checkpoint.

 4 Click the object to check. The Object Selection - Checkpoint Properties dialog 
box opens.

 5 Select the last tree item. The tree item name depends on the object’s class, for 
example:

 6 Click OK. The Checkpoint Properties dialog box opens.

 7 Specify the settings for the checkpoint. For more information, see 
Understanding the Checkpoint Properties Dialog Box on page 90.

 8 Click OK to close the dialog box.

A tree item with a checkpoint  icon is added to your test tree.

Object Class

Check box WebCheckBox

Edit box WebEdit

Image Image

Radio button WebRadio
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Understanding the Checkpoint Properties Dialog Box
In the Checkpoint Properties dialog box, you can specify which properties of the 
object to check, and edit the values of these properties.

This icon indicates 
that the value of the 
property to check is 
a constant.

The selected check 
box indicates that 
this property will be 
checked.
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Identifying the Object

The top part of the dialog box displays information about the object to check:

Choosing which Property to Check

The dialog box also displays the default properties of the object you can check in 
the Properties pane, which lists the properties, their values, and their types:

Information Description

Logical name The name of the object as defined in the HTML code of the 
Web page.

Class The type of object. In this example, the "WebCheckBox" 
class indicates that the object is a check box.

Pane Element Description

check box For each object class, Astra QuickTest recommends default 
property checks. You can accept the default checks or 
modify them accordingly.
To check a property, select the corresponding check box.
To exclude a property check, clear the corresponding check 
box.

Type The  icon indicates that the value of the property is a 
constant. 
The  icon indicates that the value of the property is a 
parameter.
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Editing the Value of an Object Property

In the Edit Value section, you use the following options to edit the value of the 
property to check.

Property The name of the property to check.

Value The value of the property to check. Note that unless you edit 
this value, the listed value will be the expected value of the 
property when you run your test. For information about 
editing the value of a property, see Editing the Value of 
an Object Property on page 92.

Option Description

Constant (default) Sets the value of the property.

Parameter Sets the property value as a parameter. For more 
information, see Chapter 6, Parameterizing Tests. 

Global Adds a parameter to the Global tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Local Adds a parameter to the Action tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Pane Element Description
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Use data table 
formula (advanced)

Inserts two columns in the table in the Data pane. The first 
column contains a formula that checks the validity of output 
in the second column. Astra QuickTest uses the data in the 
second (output) column to compute the formula, and inserts 
a value of TRUE or FALSE in the table cell of the first 
(formula) column. For more information, see Chapter 8, 
Working with Data Tables. 

Regular expression Sets the property value as a regular expression. For more 
information, see Chapter 9, Using Regular 
Expressions.  

Option Description
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Checking Tables

You can check that a specified text string appears in a cell in a table on your Web 
page by adding a table checkpoint to your test. To add a table checkpoint to your 
test, you use the Table Checkpoint Properties dialog box.

Creating a Table Checkpoint
You can add a table checkpoint while recording or afterward.

To add a table checkpoint while recording:

 1 Choose Insert > Checkpoint or click the Insert Checkpoint button.

The mouse pointer turns into a pointing hand.

 2 Click the table. The Object Selection - Checkpoint Properties dialog box opens.

 3 Select a table item and click OK. The Table Checkpoint Properties dialog box 
opens.

 4 Specify the settings for the checkpoint. For more information, see 
Understanding the Table Checkpoint Properties Dialog Box on page 95.

 5 Click OK to close the dialog box.

A tree item with a checkpoint  icon is added to your test tree.



Creating Tests • Checking Web Objects

Astra QuickTest User’s Guide Chapter 5, page 95

Back

Find

Find

Chapter
Top of

 Again

To add a table checkpoint after recording:

 1 Make sure the Display Views button and the ActiveScreen tab are selected.

 2 Click a step in your test where you want to add a checkpoint. The ActiveScreen 
displays the Web page corresponding to the highlighted step. 

 3 Right-click the table and choose Insert Checkpoint. The Object Selection - 
Checkpoint Properties dialog box opens.

 4 Select a table item and click OK. The Table Checkpoint Properties dialog box 
opens.

 5 Specify the settings for the checkpoint. For more information, see 
Understanding the Table Checkpoint Properties Dialog Box on page 95.

 6 Click OK to close the dialog box.

A tree item with a checkpoint  icon is added to your test tree.

Understanding the Table Checkpoint Properties Dialog Box
In the Table Checkpoint Properties dialog box, you can choose which cells in the 
table to check and specify the settings for the table checkpoint.
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Select/Clear 
an entire 
column

Select/Clear 
an entire row

Select/Clear 
an entire 
table

Row and cell 
indicator
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Choosing which Cell to Check

The top part of the Table Checkpoint Properties dialog box displays a grid 
representing the cells in the table. The grid displays rows and columns of a table. 
By default the entire table is selected. You can check the entire table, a row, a 
column, or a cell. Astra QuickTest will only check cells for which the 
corresponding row and column check boxes are selected.

• To select or clear a row or column, select or clear the corresponding check 
box.

• To highlight a cell, click it. In the Row Cell section, the cell value is displayed 
in the Constant box.

Specifying Cell Contents

The Row Cell section displays information about the value of the highlighted cell 
in the table. You can choose from the following tree items:

Option Description

Row Cell Displays the row and cell numbers of the highlighted cell in 
read-only format. 

Constant (default) Displays the value of the text string in the highlighted cell.

Parameter Sets the value of the cell as a parameter. For more 
information, see Chapter 6, Parameterizing Tests. 
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Global Adds a parameter to the Global tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Local Adds a parameter to the Action tab in the Data pane. For 
more information, see Chapter 10, Working with 
Actions. 

Regular expression Sets the value of the cell as a regular expression. For more 
information, see Chapter 9, Using Regular 
Expressions. 

Key cell Instructs Astra QuickTest to search for this row according to 
the contents of this cell.

Ignore cell Instructs Astra QuickTest not to check the contents of this 
cell.

Exact match Checks that the exact text, and no other text, appears in the 
cell. Clear this box if you want to check that a text string 
appears in a cell as part of the contents of the cell.

Match case Conducts a case sensitive search. 

Option Description
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�
Parameterizing Tests

Astra QuickTest enables you to expand the scope of a basic test by replacing 
fixed values with parameters. This process, known as parameterization, greatly 
increases the power and flexibility of your tests.

This chapter describes:

• Parameterizing Steps

• Parameterizing Checkpoints

• Example of a Parameterized Test
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About Parameterizing Tests

You can use Astra QuickTest to enhance your tests by parameterizing values in 
the test. A parameter is a variable that is assigned a value from outside the test 
in which it is defined.

You start by recording a test that performs a set of actions. After you finish 
recording, you can parameterize certain constants in the test so that the test will 
run the same set of actions many times. In each repetition, or iteration, Astra 
QuickTest substitutes the constant value with a parameter value. You supply the 
list of possible values for a parameter in a table in the Data pane.

Each column in the table represents the list of values for a single parameter. The 
column header is the parameter name.
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Each row in the table represents a set of values that Astra QuickTest submits for 
all the parameters during a single iteration of the test. When you run your test, 
Astra QuickTest runs one iteration of the test for each set of data in the table. 
Thus, a test with ten-rows in the data table will run ten times.

For example, consider the sample Web flight site, “Mercury Tours,” which enables 
you to book flight requests. To book a flight, you supply the flight itinerary and click 
the Continue button.
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The site returns the available flights for the requested itinerary.

You could conduct the test by accessing the Web site and recording the 
submission of numerous queries. This is a slow, laborious, and inefficient 
solution. When you parameterize your test, you first record a test that accesses 
the Web site and checks for the available flights for one requested itinerary. You 
then substitute the recorded itinerary with a parameter, and add multiple sets of 
data, one for each itinerary, into the table linked to the test.
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When you run the test, Astra QuickTest submits a separate query for each 
itinerary.

When you add parameters to your test, you can parameterize a step recorded in 
your test or a checkpoint added to your test. When you parameterize a step, you 
parameterize either the object that you navigate in your Web page or the method 
by which you navigate. When you parameterize a checkpoint, instead of 
checking how your Web site performs an operation on a single text string or 
object, you can check how it performs with multiple sets. 
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You can also parameterize your test by creating output parameters, which retrieve 
variables from the test while it runs and insert them into a table in the Data pane 
so that you can use them as input later in the test. For more information, see 
Chapter 7, Creating Output Parameters.  

Note: After running, you can view the results of the values used in a 
parameterized test in the Runtime Data table. For more information, see 
Viewing the Runtime Data Table for a Parameterized Test on page 242.
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Parameterizing Steps

You can parameterize a step while recording your test or afterward. You 
parameterize a step in your test tree. A step is made up of an object that you 
navigate in your Web page, and/or a method by which you navigate the step. 
When you parameterize a step, you are actually parameterizing either the object 
or the method. For an example of a parameterized step, see Example of a 
Parameterized Test on page 115.

Parameterizing an Object in a Step
You can parameterize the object that you navigate in a step. For example, your 
Web site may include a form in which the user can choose to click one of several 
buttons. You may want to test how your site responds when different buttons are 
selected. Rather than record a separate test for clicking each button, you can 
parameterize your test so that during each iteration of the test run, Astra 
QuickTest clicks a different button.
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To parameterize the object in a step:

 1 Right-click a step in the test tree and choose Object Properties. The Object 
Properties dialog box opens and displays the properties of the object in the step. 
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The Object tab displays information about the object in the step:

The dialog box displays the default properties you can parameterize, in a pane 
listing the properties, their values, and their types: 

 2 Click the property to parameterize in the Properties section. The property is 
highlighted.

Information Description

Logical name The logical name of the object.

Class The type of object. In this example, the "WebEdit" class 
indicates that the object is an edit box.

Pane Element Description

Type The  icon indicates that the property value is a constant. 
The  icon indicates that the property value is a parameter.

Property The name of the property whose value will be parameterized.

Value The value of the property to parameterize.

Add/Remove 
Properties

Opens the Add/Remove Properties dialog box, to enable you 
to modify the list of properties that you can parameterize. To 
add/remove a property, select/clear a check box and click OK. To 
set the default, click the Default button and click OK.
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 3 In the Edit value section, click Parameter. 

 4 In the Parameter box, choose a parameter from the list or enter a new name.

• To use a parameter that you already created, select it from the list.

• To create a new parameter, either use the default parameter name or enter a 
descriptive name for the parameter.

 5 Click Global or Local.

• To add the parameter to the Global tab in the Data pane, click Global.

• To add the parameter to the Action tab, click Local.

For more information, see Chapter 10, Working with Actions. 

 6 If you want to set the property value of the step as a regular expression, select 
the Regular expression check box. For more information, see Chapter 9, 
Using Regular Expressions. 

 7 Click Close to save the parameter and close the dialog box.

 8 If you created a new parameter, the Astra Parameters dialog box prompts you 
to add the new parameter to the table in the Data pane. Click OK. A new column 
is highlighted in the table for the new parameter.

In your test tree, the  icon next to the step indicates that the step has been 
parameterized.
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Note: You can specify additional data values for the parameter by entering them 
directly into the table in the Data pane. For more information, see Chapter 8, 
Working with Data Tables. 

Parameterizing a Method in a Step
You can parameterize the method you use to navigate a step. For example, your 
Web site may include a form with an edit field into which the user types a text 
string. You may want to test how your site responds to different data in the form. 
Rather than record a separate test for each text string typed, you can 
parameterize your test so that during each iteration of the test run, Astra 
QuickTest enters a different text string into the edit field.
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To parameterize the method in a step:

 1 Right-click a step in the test tree and choose Function Arguments. The 
Function Arguments dialog box opens and displays the method arguments in the 
step. 
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The Method tab displays the name of the function performed in the step:

The dialog box displays the default arguments you can parameterize, in a pane 
listing the arguments, their values, and their types:

 2 Click an argument in the Arguments section. The argument is highlighted. 

 3 In the Edit value section, click Parameter. 

 4 In the Parameter box, choose a parameter from the list or enter a new name.

• To use a parameter that you already created, select it from the list.

• To create a new parameter, either use the default parameter name or enter a 
descriptive name for the parameter.

Information Description

Function The name of the function performed.

Pane Element Description

Type The  icon indicates that the argument value is a constant. 
The  icon indicates that the argument value is a parameter.

Argument The name of the argument whose value will be parameterized.

Value The value of the argument to parameterize. 
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 5 Click Global or Local.

• To add the parameter to the Global tab in the Data pane, click Global.

• To add the parameter to the Action tab, click Local.

For more information, see Chapter 10, Working with Actions. 

 6 If you want to set the argument value of the step as a regular expression, select 
the Regular expression check box. For more information, see Chapter 9, 
Using Regular Expressions. 

 7 Click Close to save the parameter and close the dialog box.

 8 If you created a new parameter, the Astra Parameters dialog box prompts you 
to add the new parameter to a table in the Data pane. Click OK. A new column is 
highlighted in the table for the new parameter.

In your test tree, the  icon next to the step indicates that the step has been 
parameterized.

Note: You can specify additional data values for the parameter by entering them 
directly into the table in the Data pane. For more information, see Chapter 8, 
Working with Data Tables. .
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Parameterizing Checkpoints

You can parameterize a checkpoint while recording your test or afterward. For 
information on parameterizing checkpoints while creating them, see Chapter 4, 
Creating Checkpoints. 

When you test your Web site, you may want to check how it performs the same 
operations with multiple sets of data. For example, if you are testing the sample 
flight Web site, “Mercury Tours,” you may create a checkpoint to check that once 
you book a ticket, it is booked correctly. Suppose that you want to check that 
flights are booked correctly for a variety of different destinations. Rather than 
create a separate test with a separate checkpoint for each destination, you can 
parameterize the destination information: for each iteration of the test, Astra 
QuickTest checks the flight information for a different destination. For an example 
of a parameterized checkpoint, see Example of a Parameterized Test on page 
115.

To parameterize a checkpoint either while recording your test or afterward:

 1 Right-click a checkpoint in the test tree and choose Function Arguments. 

• For a page checkpoint, the Page Checkpoint Properties dialog box opens. 

• For a text checkpoint, the Text Checkpoint Properties dialog box opens. 

• For an object checkpoint, the Checkpoint Properties dialog box opens. 

• For a table checkpoint, the Table Checkpoint Properties dialog box opens.
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 2 In the dialog box, click Parameter to set the value as a parameter. 

 3 In the Parameter box, choose a parameter from the list or enter a new name.

• To use a parameter that you already created, select it from the list.

• To create a new parameter, either use the default parameter name or enter a 
descriptive name for the parameter.

You can create the parameter in the global or a local data table. For additional 
information, see Chapter 8, Working with Data Tables. 

 4 To use a regular expression with the parameter, select the Regular expression 
check box. For additional information, see Chapter 9, Using Regular 
Expressions. 

 5 Click OK to save the parameter and close the dialog box.

 6 If you created a new parameter, the Astra Parameters dialog box prompts you to 
add the new parameter to the data. Click OK. A new column is highlighted in the 
table for the new parameter.

In your test tree, the  icon next to the checkpoint indicates that the checkpoint 
has been parameterized.

Note: You can specify additional data values for the parameter by entering them 
directly into the table in the Data pane. For more information, see Chapter 8, 
Working with Data Tables. 



Creating Tests • Parameterizing Tests

Astra QuickTest User’s Guide Chapter 6, page 115

Back

Find

Find

Chapter
Top of

 Again

Example of a Parameterized Test

The following example shows how to parameterize a step object, step method, 
and checkpoint. 

When you test your Web site, you may want to check how it performs the same 
operations with multiple sets of data. For example, if you are testing the sample 
flight Web site, “Mercury Tours,” you may want to check that the correct departure 
and the arrival cities are selected before you book a particular flight. Suppose that 
you want to check that the flights are booked correctly for a variety of different 
locations. Rather than create a separate test with a separate checkpoint for each 
location, you can parameterize the location information: for each iteration of the 
test, Astra QuickTest checks the flight information for a different locations.
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The following is a sample test of a flight booking procedure. The departure city is 
“Frankfurt” the arrival city is “Acapulco”.

Parameterize a Step
Parameterize the object and the method of the following step:
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In the Object Properties dialog box, select the “name” property. In the Parameter 
box, rename the “depart_name” to Activity. Close the dialog box. The Activity 
row is added to the data table. Note that the Activity row will be used for both 
departures and arrivals.
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In the following example, parameterize the method of the above step. In the 
Function Arguments dialog box, select the “item” property. In the Parameter box, 
rename the “depart_item” to Location. Close the dialog box. The Location row is 
added to the data table. Note that the Location row will be used for both 
departure cities and arrival cities.
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For more information on parameterizing a step, see Parameterizing Steps on 
page 105.

Parameterize a Checkpoint
In the following example, a parameterized text checkpoint is added to check that 
the correct locations were selected before you book a flight. A text checkpoint is 
created for the following text:
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In the Text Checkpoint Properties dialog box, the text is parameterized. Close 
the dialog box. A text checkpoint parameter row is added to the data table. 
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For more information on parameterizing a checkpoint, see Parameterizing 
Checkpoints on page 113.

Enter Data in the Data Table 
Complete the table in the Data pane. The data table may appear as follows:

For more information on data tables, see Chapter 8, Working with Data Tables. 
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Modified Test
The following example shows the test after parameterizing the step and creating 
a parameterized text checkpoint.

Parameterized 
step

Parameterized text 
checkpoint
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Creating Output Parameters

Astra QuickTest enables you to parameterize your test by retrieving a variable 
value from your test and entering it in your table in the Data pane, as an output 
parameter. You can subsequently use this output parameter as an input variable 
in your test. This enables you to use data retrieved during a test in other parts of 
the test.

This chapter describes:

• Creating Page Output Parameters

• Creating Text Output Parameters

• Creating Object Output Parameters

• Creating Table Output Parameters
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About Creating Output Parameters

You parameterize your test by adding values to a table in the Data pane that 
replace variables in the test. When you run the test, Astra QuickTest runs one 
iteration of the test for each set of values from your table, as discussed in 
Chapter 6, Parameterizing Tests.  

You can also use output parameters to parameterize your test. An output 
parameter is a value that is retrieved from a parameter in your test while the test 
runs and is entered into your table. 

For example, consider a flight reservation site. You design a test to create a new 
reservation and then view the reservation details. Every time you run the test, 
the site generates a unique order number for the new reservation. To view the 
reservation, the site requires the user to input the same order number. You 
cannot know the order number before you run the test, however.

To solve this problem, you create an output parameter for the unique order 
number that the site generates when creating a new reservation. In the view 
reservation screen, you parameterize the order number input field. You use the 
same output parameter of the unique order number.

When you run the test, Astra QuickTest retrieves the unique order number 
generated by the site for the new reservation and inserts it in the table for the 
order number output parameter. When the test reaches the order number input 
field required to view the reservation, Astra QuickTest uses the unique order 
number stored in the table for the order number input field parameter.
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You can add an output parameter by using commands on the Insert menu or by 
clicking the arrow beside the Insert Checkpoint button on the Main toolbar. This 
displays a menu of output parameter options that are relevant to the selected step 
in the test tree.

Note: After running, you can view the output parameters retrieved during a test 
run in the Runtime Data table. For more information, see Viewing the Runtime 
Data Table for a Parameterized Test on page 242.
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Creating Page Output Parameters

When you create a page output parameter, you parameterize a constant page 
property by replacing it with a variable. When you run the test, Astra QuickTest 
retrieves the value in the output parameter and inserts it in the data table. For 
example, the number of links on a page may vary based on the selections a user 
makes on a form on the previous page. You could make an output parameter to 
return the number of links on the page during each run. To parameterize a page 
property, you open the Page Output Parameter Properties dialog box.
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Adding a Page Output Parameter
You can create a page output parameter while recording your test or afterward. 

To create a page output parameter while recording:

 1 Choose Insert > Output Parameter. 

The mouse pointer turns into a pointing hand.

 2 Click the page to parameterize. The Object Selection - Output Parameter 
Properties dialog box opens.

 3 Select the page item and click OK. The Page Output Parameter Properties 
dialog box opens.

 4 Specify the settings for the output parameter. For more information, see 
Understanding the Page Output Parameter Properties Dialog Box on page 
128.

 5 Click OK to close the Page Output Parameter Properties dialog box.

 6 If you created a new output parameter, the Astra Parameter dialog box prompts 
you to add the new output parameter to the table in the Data pane. Click OK. A 
new column is highlighted in the table for the new output parameter. 

An output parameter tree item  is added to your test tree. 
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To create a page output parameter after recording:

 1 Make sure the Display Views button and the ActiveScreen tab are selected.

 2 Click a page step  in your test tree where you want to add an output 
parameter. The ActiveScreen displays the Web page corresponding to the 
highlighted step. 

 3 Right-click the page to parameterize in the ActiveScreen and choose Output. 
The Object Selection - Output Parameter Properties dialog box opens.

 4 Select the page item and click OK. The Page Output Parameter Properties 
dialog box opens.

 5 Specify the settings for the output parameter. For more information, see 
Understanding the Page Output Parameter Properties Dialog Box on page 
128.

 6 Click OK to close the Page Output Parameter Properties dialog box.

 7 If you created a new output parameter, the Astra Parameter dialog box prompts 
you to add the new output parameter to the table in the Data pane. Click OK. A 
new column is highlighted in the table for the new output parameter. 

An output parameter tree item  is added to your test tree. 

Understanding the Page Output Parameter Properties Dialog 
Box
In the Page Output Parameter Properties dialog box, you can specify which 
property of the page to parameterize, and edit the values of this property.
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Identifying the Page

The top part of the dialog box displays information about the page to 
parameterize:

Choosing which Property to Parameterize

The dialog box also displays the page properties that you can parameterize, in a 
pane listing the properties, their values, and their types:

Information Description

Logical name
The name of the page as defined in the HTML code of the 
Web page.

Class The type of object. 

Pane Element Description

Check box
To parameterize a property, select the corresponding check 
box.

Type

The  icon indicates that the value of the property is a 
constant. 
The  icon indicates that the value of the property is a 
parameter.

Property The name of the property to check.

Value The value of the property to parameterize.
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Choosing an Output Parameter

In the Edit Value section, you use the following options to specify the output 
parameter name:

Option Description

Parameter name

Specifies the output parameter name. To use an 
output parameter that you already created, select an 
output parameter from the list. To create a new output 
parameter, you can use the default output parameter 
name, or type a descriptive name for the output 
parameter.

Global (default)
Adds the output parameter name to the Global tab in 
the Data pane. For more information, see Chapter 10, 
Working with Actions. 

Local
Adds the output parameter name to the Action tab in 
the Data pane. For more information, see Chapter 10, 
Working with Actions. 
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Creating Text Output Parameters

When you create a text output parameter, you parameterize a constant text string 
by replacing it with a variable. To parameterize a text string, you open the Text 
Output Parameter Properties dialog box.

Adding a Text Output Parameter
You can create a text output parameter while recording your test or afterward. 

To create a text output parameter while recording:

 1 Highlight the text string you want to parameterize.

 2 Choose Insert > Text Output Parameter. 

The mouse pointer turns into a pointing hand.

 3 Click the text string to parameterize. The Text Output Parameter Properties 
dialog box opens.

 4 Specify the settings for the output parameter. For more information, see 
Understanding the Text Output Parameter Properties Dialog Box on page 
134.

 5 Click OK to close the Text Output Parameter Properties dialog box.

 6 If you created a new output parameter, the Astra Parameter dialog box prompts 
you to add the new output parameter to the table in Data pane. Click OK. A new 
column is highlighted in the table for the new output parameter. 

An output parameter tree item  is added to your test tree. 
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To create an output parameter after recording:

 1 Make sure the Display Views button and the ActiveScreen tab are selected.

 2 Click a step in your test where you want to create an output parameter. 

The ActiveScreen displays the Web page corresponding to a highlighted step. 

 3 Highlight and then right-click the text string to parameterize in the ActiveScreen.

 4 Choose Insert Text Output. The Text Output Parameter Properties dialog box 
opens.

 5 Specify the settings for the output parameter. For more information, see 
Understanding the Text Output Parameter Properties Dialog Box on page 
134.

 6 Click OK to close the Text Output Parameter Properties dialog box.

 7 If you created a new output parameter, the Astra Parameter dialog box prompts 
you to add the new output parameter to the table in the Data pane. Click OK. A 
new column is highlighted in the table for the new output parameter. 

An output parameter tree item  is added to your test tree. 
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Understanding the Text Output Parameter Properties Dialog 
Box
In the Text Output Parameter Properties dialog box, you can specify which text to 
parameterize as well as which text appears before and after the parameter. This 
is particularly helpful when the text string you want to parameterize appears 
several times in the same Web page. For example, suppose you want to 
parameterize the “Mercury Tours” text string in a specific location in the first page 
of the sample Mercury Tours Web site. This text string actually appears three 
times on that Web page. To parameterize the text string in a specific location, you 
can specify which text precedes and/or follows the text string you are 
parameterizing.
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Specifying which Text to Parameterize

In the Output Text section, you use the following options to specify the output 
parameter name for the highlighted text string:

Option Description

Parameter name

Specifies the output parameter name. To use an 
output parameter that you already created, select an 
output parameter from the list. To create a new output 
parameter, you can use the default output parameter 
name, or type a descriptive name for the output 
parameter.

Global (default)
Adds the output parameter name to the Global tab in 
the Data pane. For more information, see Chapter 10, 
Working with Actions. 

Local
Adds the output parameter name to the Action tab in 
the Data pane. For more information, see Chapter 10, 
Working with Actions. 
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Specifying What Appears After the Text to Parameterize

In the Appears After section, you use the following options to specify which text, 
if any, should appear after the text output parameter:

Specifying What Appears Before the Text to Parameterize

In the Appears Before section, you use the following options to specify which text, 
if any, should appear before the text output parameter:

Option Description

Appears after (default)
Specifies that the output parameter text appears after 
the text in this box. To ignore the text that appears 
after the parameter, clear this check box.

Constant (default) Displays the text that appears after the parameter.

Parameter Sets the text string as a parameter. 

Option Description

Appears before (default)
Specifies that the output parameter text appears 
before the text in this box. To ignore the text that 
appears before the parameter, clear this check box.

Constant (default) Displays the text that appears before the parameter.

Parameter Sets the text string as a parameter. 
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Creating Object Output Parameters

You can parameterize an object on your Web page to create an object output 
parameter. To parameterize an object, you open the Object Output Parameter 
dialog box.

Adding an Object Output Parameter
You can create an object output parameter while recording your test or afterward. 

To create an object output parameter while recording:

 1 Choose Insert > Output Parameter. 

The mouse pointer turns into a pointing hand.

 2 Click the object to parameterize. The Object Selection - Output Parameter 
Properties dialog box opens.
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 3 Select the last tree item. The tree item name depends on the object’s class, for 
example:

 4 Click OK. The Output Parameter Properties dialog box opens.

 5 Specify the settings for the output parameter. For more information, see 
Understanding the Output Parameter Properties Dialog Box on page 141.

 6 Click OK to close the Output Parameter Properties dialog box.

 7 If you created a new output parameter, the Astra parameters dialog box prompts 
you to add the new output parameter to the table in the Data pane. Click OK. A 
new column is highlighted in the table for the new output parameter. 

An output parameter tree item  is added to your test tree. 

Object Class

Check box WebCheckBox

Edit box WebEdit

Image Image

Radio button WebRadio
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To create an object output parameter after recording:

 1 Make sure the Display Views button and the ActiveScreen tab are selected.

 2 Click a step in your test where you want to create an output parameter. 

The ActiveScreen displays the Web page corresponding to a highlighted step. 

 3 Right-click the object to parameterize in the ActiveScreen and choose Output. 
The Object Selection - Output Parameter Properties dialog box opens.

 4 Select the last tree item. The tree item name depends on the object’s class, for 
example:

 5 Click OK. The Output Parameter Properties dialog box opens.

 6 Specify the settings for the output parameter. For more information, see 
Understanding the Output Parameter Properties Dialog Box on page 141.

 7 Click OK to close the Output Parameter Properties dialog box.

 8 If you created a new output parameter, the Astra parameters dialog box prompts 
you to add the new output parameter to the table in the Data pane. Click OK. A 
new column is highlighted in the table for the new output parameter. 

An output parameter tree item  is added to your test tree. 

Object Class

Check box WebCheckBox

Edit box WebEdit

Image Image

Radio button WebRadio
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Understanding the Output Parameter Properties Dialog Box
In the Output Parameter Properties dialog box, you can specify which property of 
the object to parameterize, and edit the values of this property.



Creating Tests • Creating Output Parameters

Astra QuickTest User’s Guide Chapter 7, page 142

In

Back

Find

Find

Chapter
Top of

 Again

Identifying the Object

The top part of the dialog box displays information about the object to 
parameterize:

Choosing which Property to Parameterize

The dialog box also displays the properties of the object you can parameterize, in 
a pane listing the properties, their values, and their types:

Information Description

Logical name
The name of the object as defined in the HTML code of the 
Web page.

Class
The type of object. In this example, the "WebEdit" class 
indicates that the object is an edit field.

Pane Element Description

Check box
To parameterize a property, select the corresponding check 
box.

Type

The  icon indicates that the value of the property is a 
constant. 
The  icon indicates that the value of the property is a 
parameter.
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Choosing an Output Parameter

In the Edit Value section, you use the following options to specify the output 
parameter name:

Property The name of the property to check.

Value The value of the property to parameterize.

Option Description

Parameter name

Specifies the output parameter name. To use an 
output parameter that you already created, select an 
output parameter from the list. To create a new output 
parameter, you can use the default output parameter 
name, or type a descriptive name for the output 
parameter.

Global (default)
Adds the output parameter name to the Global tab in 
the Data pane. For more information, see Chapter 10, 
Working with Actions. 

Local
Adds the output parameter name to the Action tab in 
the Data pane. For more information, see Chapter 10, 
Working with Actions. 

Pane Element Description
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Creating Table Output Parameters

You can parameterize a text string in your table to create a table output parameter. 
To parameterize a text string in a table, you open the Table Output Parameter 
Properties dialog box.

Adding a Table Output Parameter
You can create a table output parameter while recording your test or afterward. 

To create a table output parameter while recording:

 1 Choose Insert > Output Parameter. 

The mouse pointer turns into a pointing hand.

 2 Click the table to parameterize. The Object Selection - Output Parameter 
Properties dialog box opens.

 3 Select a table item and click OK. The Table Output Parameter Properties dialog 
box opens.

 4 Specify the settings for the output parameter. For more information, see 
Understanding the Table Output Parameter Properties Dialog Box on page 
146.

 5 Click OK to close the Table Output Parameter Properties dialog box.
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 6 If you created a new output parameter, the Astra parameters dialog box prompts 
you to add the new output parameter to the table in the Data pane. Click OK. A 
new column is highlighted in the table for the new output parameter. 

An output parameter tree item  is added to your test tree. 

To create a table output parameter after recording:

 1 Make sure the Display Views button and the ActiveScreen tab are selected.

 2 Click a step in your test where you want to create an output parameter. 

The ActiveScreen displays the Web page corresponding to a highlighted step. 

 3 Highlight a text string in a table on the ActiveScreen tab.

 4 Right-click the table to parameterize in the ActiveScreen and choose Output. 
The Object Selection - Output Parameter Properties dialog box opens.

 5 Select a table item and click OK. The Table Output Parameter Properties dialog 
box opens.

 6 Specify the settings for the output parameter. For more information, see 
Understanding the Table Output Parameter Properties Dialog Box on page 
146.

 7 Click OK to close the Table Output Parameter Properties dialog box.

 8 If you created a new output parameter, the Astra parameters dialog box 
prompts you to add the new output parameter to the table in the Data pane. Click 
OK. A new column is highlighted in the table for the new output parameter. 

An output parameter tree item  is added to your test tree. 
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Understanding the Table Output Parameter Properties Dialog 
Box
In the Table Output Parameter Properties dialog box, you can specify the name 
of the output parameter.
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The dialog box displays rows and columns of a table. Your highlighted text string 
appears in a cell.

Use the following options to specify the output parameter name:

Option Description

Parameter name

Specifies the output parameter name. To use an 
output parameter that you already created, select an 
output parameter from the list. To create a new output 
parameter, you can use the default output parameter 
name, or type a descriptive name for the output 
parameter.

Global (default)
Adds the output parameter name to the Global tab in 
the Data pane. For more information, see Chapter 10, 
Working with Actions. 

Local
Adds the output parameter name to the Action tab in 
the Data pane. For more information, see Chapter 10, 
Working with Actions. 
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�
Working with Data Tables

Astra QuickTest enables you to create and run tests that are driven by data stored 
in the data table.

This chapter describes:

• Global and Local Sheets

• Editing the Data Table

• Using Formulas in the Data Table

• Using Data Table Scripting Functions

About Working with Data Tables

You can parameterize your test with input and output parameters so that it will run 
several times on different sets of data. The data your test uses is stored in the data 
table, which appears in the Data pane at the bottom of the site. The data table has 
the characteristics of a Microsoft Excel spreadsheet, meaning that you can also 
execute mathematical formulas within the cells. 

After you run a test, the data you enter in the data table is displayed in the 
Runtime data table within the Test Results window. For more information on the 
Runtime data table, see Viewing the Runtime Data Table for a Parameterized 
Test on page 242.
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Global and Local Sheets

There are two types of sheets within the data table: Global and Local. You can 
access the different sheets by clicking the appropriate tabs below the data table. 

Global Sheet
The Global sheet contains the data that replaces parameters in each iteration of 
the test. If you create a Global parameter called Arrivals, the Global sheet might 
look like this:
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Local Sheets
Each time you add a new action to the test, a new Local sheet is added to the data 
table. Local sheets are automatically labeled with the exact name of the 
corresponding action. The data contained in a local sheet is relevant for the 
corresponding action only. For example, if a test had the data table below, Astra 
QuickTest would only use the data contained in the Departure column when 
running iterations on the Purchase action:
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Editing the Data Table

The data table contains the values that Astra QuickTest substitutes for 
parameters when you run a test. Whenever you save your test, Astra QuickTest 
automatically saves the test’s data table. Astra QuickTest automatically saves the 
data table for a test in the test folder and assigns it an .xls extension. 

You can edit information in the table by typing directly into the table. You can also 
import data in Excel 95, Excel 97, or ASCII format. You use the table in the same 
way as an Excel spreadsheet, including inserting formulas into cells.

To edit the data table:

 1 Open your test.

 2 Make sure the Data Views button is enabled.
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• Each row in the table represents the set of values that Astra QuickTest 
submits for the parameterized arguments during a single iteration of the test 
or action. The number of iterations that a test runs is equal to the number of 
rows in the table.

• Each column in the table represents the list of values for a single 
parameterized argument. The column header is the parameter name.

Note: You must enter data in rows from top to bottom, i.e., you cannot enter data 
in a cell in a row until you have entered data in a previous row.

 3 To change the name of a column, double-click the column heading cell. The 
Change Parameter dialog box opens. Type a parameter name and click OK. If 
you change the name in the table, you must also change the corresponding 
parameter name in the test pane.

 4 Use the data table menu commands described below to edit the table. To open 
the data table menu, right-click a cell. The following menus are available: File, 
Edit, Data, and Format. 
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File Menu
The following commands are available in the File menu:

Edit Menu
The following commands are available in the Edit menu:

File Command Description

Import Imports an existing table file into the table. 
Note that the new table file replaces all data currently in any 
sheet of the table.

Export Saves the table as a file.

Print Prints the table. 

Edit Command Description

Cut Cuts the table selection and puts it on the Clipboard.

Copy Copies the table selection and puts it on the Clipboard.

Paste Pastes the contents of the Clipboard to the current table 
selection.

Paste Values Pastes values from the Clipboard to the current table selection. 
Any formatting applied to the values is ignored. In addition, only 
formula results are pasted; formulas are ignored.
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Clear Clears formats or contents from the current selection. You can 
clear only formats, only contents (including formulas), or both 
formats and contents.

Insert Inserts empty cells at the location of the current selection. Cells 
adjacent to the insertion are shifted to make room for the new 
cells.

Delete Deletes the current selection. Cells adjacent to the deleted cells 
are shifted to fill the space left by the vacated cells.

Fill Right Copies data in the left-most cell of the selected range to all cells 
to the right of it within the selected range.

Fill Down Copies data in the top cell of the selected range to all cells 
below it within the selected range.

Find Finds a cell containing specified text. You can search by row or 
column in the table and specify to match case or find entire cells 
only.

Replace Finds a cell containing specified text and replaces it with 
different text. You can search by row or column in the table and 
specify to match case and/or to find entire cells only. You can 
also replace all.

Go To Goes to a specified cell. This cell becomes the active cell.

Edit Command Description
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Data Menu
The following commands are available in the Data menu:

Format Menu 
The following commands are available in the Format menu:

Data Command Description

Recalc Recalculates any formula cells in the table. 

Sort Sorts a selection of cells by row and/or column and keys.

AutoFill List Creates, edits, or deletes an autofill list. An autofill list contains 
frequently-used series of text such as months and days of the 
week. When adding a new list, separate each item with a semi-
colon. To use an autofill list, enter the first item into a cell in the 
table. Drag the cursor across or down and Astra QuickTest 
automatically fills in the cells in the range according to the 
autofill list.

Format 
Command

Description

General Sets format to General. General displays numbers with as many 
decimal places as necessary and no commas.

Currency(0) Sets format to currency with commas and no decimal places.
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Currency(2) Sets format to currency with commas and two decimal places.

Fixed Sets format to fixed precision with commas and no decimal 
places.

Percent Sets format to percent with no decimal places. Numbers are 
displayed as percentages with a trailing percent sign (%).

Fraction Sets format to fraction.

Scientific Sets format to scientific notation with two decimal places.

Date: (M/d/yy) Sets format to Date with the M/d/yy format.

Time: h:mm 
AM/PM

Sets format to Time with the h:mm AM/PM format.

Custom Number Sets format to a custom number format that you specify. 

Validation Rule Sets validation rule to test data entered into a cell or range of 
cells. A validation rule consists of a formula to test, and text to 
display if the validation fails.

Format 
Command

Description
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Using Formulas in the Data Table

You can use any Excel formula in your data table. This enables you to create 
contextually relevant data during the test run. You can also use formulas as part 
of a checkpoint to check that objects from a page created on-the-fly (dynamically 
generated) or other variable objects in your Web page have the values you expect 
for a given context.
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Using Formulas to Create Input Parameterization Data
You can enter formulas rather than fixed values in the cells of an input parameter 
column.

For example, suppose you want to parameterize the value for a WebEdit object 
that requires a date value no earlier than today’s date. You can set the cells in the 
Date column to the date format, and enter the =NOW() Excel formula into the first 
row in order to set the value to today’s date for the first iteration. Then you can 
use another formula in the rest of the rows in order to enter the above date plus 
one day, as shown below. By using this formula you can run the test on any day, 
and the dates will always be valid.
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Using Formulas in Checkpoints
You can use a formula in a checkpoint in order to confirm that an object from a 
page created on-the-fly (dynamically generated) or another variable object in your 
Web page contains the value it should for a given context. For example, suppose 
a shopping cart Web site displays a price total. You can create a text checkpoint 
on the displayed total value and use a data table formula to check whether the site 
properly computes the total, based on the individual prices of the products 
selected for purchase in each iteration.

When you use the data table formula option with a checkpoint, Astra QuickTest 
creates two columns in the data table. The first column contains a default 
checkpoint formula. The second column contains the value to be checked in the 
form of an output parameter. The result of the formula is Boolean: TRUE or 
FALSE. 

A FALSE result in the checkpoint column during a test run causes the test to fail.

Once you finish adding the checkpoint, you can modify the default formula in the 
first column to perform the check you need.
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To use a formula in a checkpoint:

 1 Select the page, text, or object for which you want to create a checkpoint and 
open the Insert Checkpoint dialog box as described in Chapter 4, Creating 
Checkpoints. 

 2 Click Parameter and specify a logical name for the parameter.

 3 Select the Use data table formula check box.

 4 Specify your other checkpoint setting preferences as described in Chapter 4, 
Creating Checkpoints. 

 5 Click OK. 

 6 Confirm the addition of two columns in the data table. The two columns are 
added to the table, and a checkpoint  icon is added to your test tree. 

 7 Highlight the value in the first (formula) column to view the formula and modify 
the formula to fit your needs.

 8 If you want to run several iterations, add the appropriate formula in subsequent 
rows of the formula column for each iteration in the test or action.
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Using Data Table Scripting Functions

Astra QuickTest provides several data table functions that enable you to retrieve 
information about the data table and to set the value of cells in the data table.

You enter these statements manually in the Expert View. For more information 
about working in the Expert View see Chapter 18, Testing in the Expert View. 

For more details on the data table functions, refer to the Astra QuickTest Function 
Reference.

From a programming perspective, the data table is made up of three types of 
objects: DataTable, Sheet (sheet), and Parameter (column). Each object has 
several functions and properties that you can use to retrieve or set values.

The functions and properties available for each type of object are described 
below.



Creating Tests • Working with Data Tables

Astra QuickTest User’s Guide Chapter 8, page 162

In

Back

Find

Find

Chapter
Top of

 Again

The DataTable Object
The table below summarizes the functions and properties of the DataTable object. 
For these functions and properties, use the syntax:

DataTable.PropOrFunc ( params )

For example, the following statement returns the MySheet sheet.

DataTable.GetSheet ("MySheet")

Function or Property Description

DataTable ( ParameterID , SheetID )
or
DataTable.Value ( ParameterID , 
SheetID )

Retrieves the value of the cell in the 
specified parameter and the current 
row.

DataTable 
( ParameterID , SheetID )=newvalue
or
DataTable.Value 
( ParameterID , SheetID )=newvalue

Sets the value of the cell in the 
specified parameter and the current 
row.
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RawValue ( ParameterID , SheetID ) Retrieves the raw value of the 
specified parameter and current row.

The raw value is the actual string 
written in the cell before it has been 
computed, such as the actual text of a 
formula.

GetSheetCount Returns the total number of sheets in 
the data table.

GetSheet ( SheetID ) Returns the specified sheet.

GlobalSheet Returns the Global sheet.

LocalSheet Returns the current local sheet.

AddSheet ( SheetName ) Adds the specified sheet and returns it 
so that you can directly set or return 
properties of the new sheet in the 
same statement.

DeleteSheet ( SheetID ) Deletes the specified sheet. Note that 
deleting the sheet will cause the test to 
fail if the corresponding action has 
parameterized values.

GetRowCount Returns the total number of rows in the 
longest column of the Global sheet.

Function or Property Description
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GetCurrentRow Returns the current row in the Global 
sheet.

SetCurrentRow ( RowNumber ) Sets the specified row as the current 
row in the Global sheet.

SetNextRow Sets the row after the currently active 
row as the new current row in the 
Global sheet.

SetPrevRow Sets the row above the currently active 
row as the mew current row in the 
Global sheet.

Import ( FileName ) Imports the specified Excel file. Note 
that the imported table completely 
replaces all data in the existing data 
table.

Export ( FileName ) Saves a copy of the data table in the 
specified location. 

Function or Property Description
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The Sheet Object
The table below summarizes the functions and properties of the Sheet object. For 
these functions and properties, use the syntax: 

...Sheet.PropOrFunc ( params ).

For example, the following statement returns the name that Astra QuickTest 
assigned to the newly added Sheet, which may be different than the name 
specified, if the specified name already exists in the data table or if the name 
contains an invalid character.

DataTable.AddSheet ("MySheet").Name 

In the above example, if the sheet, ‘MySheet’ already exists, Astra QuickTest 
returns MySheet1 as the name of the new sheet.

Function or Property Description

GetParameterCount Returns the total number of 
parameters (columns) in the sheet.

GetParameter ( ParameterID ) Returns the specified parameter from 
the sheet.

Name Returns the name of the sheet.
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AddParameter ( ParameterName, value 
)

Adds the specified parameter to the 
sheet, sets the value of the first row to 
the specified value, and returns the 
parameter so that you can directly set 
or return properties of the new 
parameter in the same statement.

DeleteParameter ( ParameterID ) Deletes the specified parameter 
(column) from the sheet. Note that 
deleting a parameter from the data 
sheet will cause the test to fail if a 
corresponding parameter exists in the 
test.

GetRowCount Returns the total number of rows in the 
longest column of the sheet.

GetCurrentRow Returns the current row in the sheet.

SetCurrentRow ( RowNumber ) Sets the specified row as the current 
row in the sheet.

SetNextRow Sets the row after the currently active 
row as the new current row in the 
sheet.

SetPrevRow Sets the row above the currently active 
row as the new current row in the 
sheet.

Function or Property Description
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The Parameter Object
The table below summarizes the functions and properties of the Parameter 
(column) object. For these functions and properties, use the syntax: 

...Parameter.PropOrFunc ( params )

For example, the following statement returns the name that Astra QuickTest 
assigned to the newly added Parameter (column), which may be different than 
the name specified, if the specified parameter name already exists in the sheet 
or if the name contains an invalid character.

DataTable.GetSheet("MySheet").AddParameter("ParamA", 2).Name

Function or Property Description

Parameter
or
Parameter.value

Retrieves the value of the cell in the 
current row of the parameter.

Parameter=newvalue
or
Parameter.value=newvalue

Sets the value of the cell in the current 
row of the parameter.
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RawValue Retrieves the raw value of the current 
row of the parameter.

The raw value is the actual string 
written in the cell before it has been 
computed, such as the actual text of a 
formula.

ValueByRow ( RowNum ) Returns the value of the cell in the 
specified row of the parameter

Name Returns the name of the parameter.

Function or Property Description
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�
Using Regular Expressions

You can use regular expressions to increase the flexibility and adaptability of your 
tests. This chapter describes:

• Using Regular Expressions in Steps

• Using Regular Expressions in Object Checkpoints

• Using Regular Expressions in Text Checkpoints

• Regular Expression Syntax

About Regular Expressions

When you run your test, regular expressions enable Astra QuickTest to identify 
Web objects and text strings with varying values. You can use regular expressions 
when defining the properties of a step or when parameterizing a step, and when 
creating checkpoints with varying values. For example, when you create a 
checkpoint on a text string with a varying date, you can define the date as a 
regular expression.

A regular expression is a string that specifies a complex search phrase. By using 
special characters such as a period (.), asterisk (*), caret (^), and brackets ([ ]), 
you define the conditions of the search. When one of these special characters is 
preceded by a backslash (\), Astra QuickTest searches for the literal character. 
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Using Regular Expressions in Steps

You can use regular expressions when defining or parameterizing a step in your 
test tree. A step is made up of an object that you navigate in your Web page, 
and/or a method by which you navigate the step. You can use regular expressions 
when defining or parameterizing the object of a step.

For example, your site may include a form in which the user inputs data and clicks 
the Send button to submit the form. When a required field is not completed, the 
form reappears for the user to complete. When resubmitting the form, the user 
clicks the Resend button. You can define the value of the button’s “name” property 
as a regular expression, so that Astra QuickTest ignores variations in the button 
name when clicking the button. 
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To define a property value as a regular expression:

 1 Right-click a step in the test tree and choose Object Properties. The Object 
Properties dialog box opens. 
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The Object tab displays information about the object in the step: 

The Object tab displays the properties of the object in the step: 

Information Description

Logical name The name of the object as defined in the HTML code of 
the Web page.

Class The type of object. In this example, the "WebButton" 
class indicates that the object is a button.

Option Description

Type The  icon indicates that the property value is a 
constant. 
The  icon indicates that the property value is a 
parameter.

Property The name of the property value.

Value The value of the property.

Add/Remove Opens the Add/Remove dialog box to enable you to 
modify the list of properties that you can check. To 
add/remove a property, select/clear a check box and click 
OK. To set the default, click the Default button and click 
OK.
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 2 Click the property you want to set as a regular expression in the Properties 
section. The property is highlighted.

 3 In the Edit value section, set the property value as a regular expression. 

• To set the property value as a constant, click Constant.

In the Constant box, set the value as a regular expression. For information 
on regular expression syntax, see Regular Expression Syntax on page 184.

• To set the property value as a parameter, click Parameter.

In the Parameter box, choose a parameter from the list or enter a new name. 
To use a parameter that you already created, select it from the list. To create 
a new parameter, either use the default parameter name or enter a 
descriptive name for the parameter. For more information on 
parameterization, see Chapter 6, Parameterizing Tests. 

To add the parameter to the Global tab in the Data pane, select Global. To 
add the parameter to the Action tab, select Local. For more information, see 
Chapter 10, Working with Actions. 

Note: The property value in the Parameter box should not be defined as a 
regular expression. When you add additional values for the parameter into the 
table in the Data pane, you specify the values as regular expressions.

For information on regular expression syntax, see Regular Expression Syntax 
on page 184. For information on editing the table, see Chapter 6, 
Parameterizing Tests. 
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 4 Select the Regular Expression check box. You are prompted to normalize the 
regular expression.

 5 By default, Astra QuickTest treats all characters in a regular expression literally, 
except for a period (.), asterisk (*), caret (^), brackets ([ ]), parentheses (()), dollar 
sign ($), vertical line (|), plus sign (+), question mark (?), and backslash (\). When 
one of these special characters is preceded by a backslash (\), Astra QuickTest 
treats it as literal character.

• Click Yes to instruct Astra QuickTest to treat a special character literally. The 
special character is now preceded by a backslash (\). 

• Click No to instruct Astra QuickTest to treat all the characters literally, except 
for special characters.

 6 Click OK to save and close the Object Properties dialog box.

If you created a new parameter, the Astra parameters dialog box prompts you to 
add the new parameter to the table in the Data pane. Click OK. A new column is 
highlighted in the table for the new parameter.

In your test tree, the  icon next to the step indicates that the step has been 
parameterized.
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Using Regular Expressions in Object Checkpoints

When creating an object checkpoint to verify that an object appears on your Web 
site, you can also set the property value of the object as a regular expression, so 
that the object with varying name can be verified. 

For example, suppose you want to check that when booking the number of 
passengers for a flight reservation in the “Mercury Tours” sample site, whole 
numbers are used. Astra QuickTest will ignore variations in the object’s property 
value as long as the value is a whole number. 

To define a regular expression in an object checkpoint:

 1 Right-click the object on the ActiveScreen and choose Insert Checkpoint. The 
Object Selection - Checkpoint Properties dialog box opens. 

 2 Select the object in the Object Selection - Checkpoint Properties dialog box 
and click OK. 
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The Checkpoint Properties dialog box opens. 

The Checkpoint Properties dialog box enables you to specify which properties of 
the object to check, and to edit the values of these properties. For more 
information, see Chapter 4, Creating Checkpoints. 
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 3 Select the check box of a property to be set as a regular expression. The 
property is highlighted.

 4 In the Edit value section, set the property value as a regular expression. 

• To set the property value as a constant, click Constant.

In the Constant box, set the value as a regular expression. For information 
on regular expression syntax, see Regular Expression Syntax on page 184.

• To set the property value as a parameter, click Parameter.

In the Parameter box, choose a parameter from the list or enter a new name: 
To use a parameter that you already created, select it from the list. To create 
a new parameter, either use the default parameter name or enter a 
descriptive name for the parameter. For more information on 
parameterization, see Chapter 6, Parameterizing Tests. 

To add the parameter to the Global tab in the Data pane, select Global. To 
add the parameter to the Action tab, select Local. For more information, see 
Chapter 10, Working with Actions. 

Note: The property value in the Parameter box should not be defined as a 
regular expression. When you add additional values for the parameter into the 
table in the Data pane, you specify the values as regular expressions. 

For information on regular expression syntax, see Regular Expression Syntax 
on page 184. For information on editing the table, see Chapter 6, 
Parameterizing Tests. 
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 5 Select the Regular Expression check box. You are prompted to normalize the 
regular expression.

 6 By default, Astra QuickTest treats all characters in a regular expression literally, 
except for a period (.), asterisk (*), caret (^), brackets ([ ]), parentheses (()), dollar 
sign ($), vertical line (|), plus sign (+), question mark (?), and backslash (\). When 
one of these special characters is preceded by a backslash (\), Astra QuickTest 
treats it as literal character.

• Click Yes to instruct Astra QuickTest to treat a special character literally. The 
special character is now preceded by a backslash (\). 

• Click No to instruct Astra QuickTest to treat all the characters literally, except 
for special characters.

 7 Click OK to save and close the Checkpoint Properties dialog box.

If you created a new parameter, the Astra parameters dialog box prompts you to 
add the new parameter to the table in the Data pane. Click OK. A new column is 
highlighted in the table for the new parameter.

In your test tree, the  icon next to the step indicates that the step has been 
parameterized. The  icon indicates a checkpoint.
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Using Regular Expressions in Text Checkpoints

When creating a text checkpoint to check that a varying text string appears on 
your Web site, you define the text string as a regular expression. 

For example, when booking a flight in the “Mercury Tours” sample site, the total 
cost charged to a credit card number should not be less than $300. You define the 
amount as a regular expression, so that Astra QuickTest will ignore variations in 
the text string as long as the value is not less than $300.
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To define a regular expression in a text checkpoint:

 1 Open the Text Checkpoint Properties dialog box.
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The Text Checkpoint Properties dialog box enables you to specify which text to 
check as well as which text appears before and after the text to check. For more 
information, see Chapter 4, Creating Checkpoints. 

 2 In the Check for text section, define the text string as a regular expression. 

• To set the text string as a constant, click Constant.

In the Constant box, define the text string as a regular expression. For 
information on regular expression syntax, see Regular Expression Syntax 
on page 184.

• To set the text string as a parameter, click Parameter.

In the Parameter box, choose a parameter from the list or enter a new name: 
To use a parameter that you already created, select it from the list. To create 
a new parameter, either use the default parameter name or enter a 
descriptive name for the parameter. For more information on 
parameterization, see Chapter 6, Parameterizing Tests. 

To add the parameter to the Global tab in the Data pane, select Global. To 
add the parameter to the Action tab, select Local. For more information, see 
Chapter 10, Working with Actions. 
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Note: The name in the Parameter box should not be defined as a regular 
expression. When you add additional values for the parameter into the table in 
the Data pane, you specify the values as regular expressions. 

For information on regular expression syntax, see Regular Expression Syntax 
on page 184. For information on editing the table, see Chapter 6, 
Parameterizing Tests. 

 3 Select the Regular Expression check box. You are prompted to normalize the 
regular expression.

 4 By default, Astra QuickTest treats all characters in a regular expression literally, 
except for a period (.), asterisk (*), caret (^), brackets ([ ]), parentheses (()), dollar 
sign ($), vertical line (|), plus sign (+), question mark (?), and backslash (\). When 
one of these special characters is preceded by a backslash (\), Astra QuickTest 
treats it as literal character.

• Click Yes to instruct Astra QuickTest to treat a special character literally. The 
special character is now preceded by a backslash (\). 

• Click No to instruct Astra QuickTest to treat all the characters literally, except 
for special characters.

 5 Click OK to save and close the Text Checkpoint Properties dialog box.
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If you created a new parameter, the Astra parameters dialog box prompts you to 
add the new parameter to the table in the Data pane. Click OK. A new column is 
highlighted in the table for the new parameter.

In your test tree, the  icon next to the step indicates that the step has been 
parameterized. The  icon indicates a checkpoint.
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Regular Expression Syntax

Astra QuickTest searches for all characters in a regular expression literally, except 
for a period (.), asterisk (*), caret (^), brackets ([ ]), parentheses (()), dollar sign 
($), vertical line (|), plus sign (+), question mark (?), and backslash (\) as 
described below. When one of these special characters is preceded by a 
backslash (\), Astra QuickTest searches for the literal character. 

The following options can be used to create regular expressions:

Matching Any Single Character
A period (.) instructs Astra QuickTest to search for any single character. For 
example: 

welcome.

matches welcomes, welcomed, or welcome followed by a space or any other 
single character. A series of periods indicates the same number of unspecified 
characters.



Creating Tests • Using Regular Expressions

Astra QuickTest User’s Guide Chapter 9, page 185

Back

Find

Find

Chapter
Top of

 Again

Matching Any Single Character within a Range
In order to match a single character within a range, you can use square brackets 
([ ]). For example, to search for a date that is either 1968 or 1969, write:

196[89]

You can use a hyphen (-) to indicate an actual range. For instance, to match any 
year in the 1960s, write:

196[0-9]

A hyphen does not signify a range if it appears as the first or last character within 
brackets, or after a caret (^).

A caret (^) instructs Astra QuickTest to match any character except for the ones 
specified in the string. For example:

[^A-Za-z]

matches any non-alphabetic character. The caret has this special meaning only 
when it appears first within the brackets.

Note that within brackets, the characters “.”, “*”, “[“ and “\” are literal. If the right 
bracket is the first character in the range, it is also literal. For example:

[]g-m] 

matches the right bracket, and g through m.
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Matching Specific Characters
An asterisk (*) instructs Astra QuickTest to match one or more occurrences of 
the preceding character. For example:

me*

causes Astra QuickTest to match “me” in Mercury and menu, and the “mee” 
in the word meet.

You can also use a combination of brackets and an asterisk to limit the label 
to a combination of non-numeric characters. For example:

"!O[a-zA-Z]*"



Creating Tests • Using Regular Expressions

Astra QuickTest User’s Guide Chapter 9, page 187

Back

Find

Find

Chapter
Top of

 Again

Combining Special Characters
You can combine special characters in a regular expression. The most common 
use of this is the combination of the ‘.’ and ‘*’ characters in order to find zero or 
more occurrences of any character.

For example,

start.* 

matches start, started, starting, starter, etc.

Matching End of String
A dollar sign ($) instructs Astra QuickTest to match the end of a string. For 
example:

book

matches both book and bookend, while a string that is followed by ($), matches 
only that string. For example,

book$

matches only book.
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Matching Either the Preceding or Following Expression
A vertical line (|) instructs Astra QuickTest to match either the preceding or 
following expression. For example: 

l|book

matches l or book, while the following expression:

(l|b)ook

matches look or book.

Matching One or More of the Preceding Expression
A plus sign (+) instructs Astra QuickTest to match the preceding character one or 
more times. For example,

zo+

matches zoo but not z.
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Matching the Preceding Character Zero or One Time
A question mark (?) instructs Astra QuickTest to match the preceding characters 
zero or one time. For example,

ca?r

matches only car and cr.

Grouping Regular Expressions
Parentheses (()) instruct Astra QuickTest to match the pattern and remember the 
match. The matched substring can be retrieved using [0]...[n].

Using the Backslash Character
A backslash (\) instructs Astra QuickTest to treat the next character as either a 
special character or a literal. Examples are as follow:

• n matches the character n

• \n matches a newline character

• \\ matches \

• \( matches (



Creating Tests
Working with Actions

Astra QuickTest User’s Guide Chapter 10, page 190

In

Back

Find

Find

Chapter
Top of

 Again

��
Working with Actions

Astra QuickTest enables you to divide your test into actions in order to streamline 
the testing process of your Web sites. 

This chapter describes:

• Using Multiple Actions in a Test

• Inserting Actions from Another Test

• Guidelines for Working with Actions
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About Working with Actions

When you use Astra QuickTest, you can utilize the action feature to design more 
modular and efficient tests. Actions enable you to parameterize specific 
components of a test and to reuse components created in other tests. Actions 
also enable you to easily re-record one action so that you don’t have to re-record 
the entire test when part of your web site or application changes.

When you divide your test into actions, you can:

• parameterize one action in a test without parameterizing the remainder of the 
test

• have unique sets of parameters and data in the table in the Data pane for 
each action

• copy an action from another test

• link to an action from another test
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Using Multiple Actions in a Test

When you create a test, each test includes one action by default. All the steps you 
record and all the modifications you make after recording are part of a single 
action. 

When you divide your test into multiple actions, you can parameterize each one 
separately. For information on parameterizing tests, see Chapter 6, 
Parameterizing Tests, and Chapter 7, Creating Output Parameters.  

When you run a test with actions, the The Test Results are divided by actions 
within each test iteration so that you can see if each action passed, and you can 
view the results for each action individually. For more information on the Test 
Results window, see Chapter 14, Analyzing Test Results. 

Suppose you want to test how a flight reservation system handles multiple 
bookings. You may want to parameterize the test to check how your site responds 
to multiple sets of customer flight itineraries. When you plan your test, you plan 
the following procedures: 

 1 The travel agent logs into the flight reservation system.

 2 The travel agent books five sets of customer flight itineraries.

 3 The travel agent logs out of the flight reservation site.
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When you consider these procedures, you realize that it is necessary to 
parameterize only the second step: after all, the travel agent logs into the flight 
reservation system only once, at the beginning and logs out of the system only 
once, at the end. Therefore, it is not necessary to parameterize the login and 
logout procedures in your test. 

By creating three separate actions within your test—one for logging in, another for 
booking a flight, and a third for logging out—you can parameterize the second 
action in your test without parameterizing the others.

When you divide your test into three actions, it is structured as shown:

Logging in

Logging out

Booking a flight
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Creating a New Action
You can create a new action in your test.

To create a new action in your test:

 1 Choose Insert > New Action or click the New Action button. The 
Insert New Action dialog box opens.

 2 Type a new action name or use the default name.

 3 Click OK.

A new action is added to your test and is displayed at the bottom of the test tree.

You can also add a description for an action. 
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To add a description to an action:

 1 Right-click the action in the test tree and select Action Properties. The Action 
Properties dialog box opens.

 2 Enter a description of the action in the Description box.

For every action in your test, Astra QuickTest creates a corresponding sheet in 
the Data pane so that you can enter parameters that are specific to that action 
only. For more information on parameterizing actions, see Parameterizing an 
Action on page 197.
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Copying an Action within a Test
If you want to create two very similar actions, you can copy an action from within 
your test.

To copy an action within a test:

 1 Right-click the action to copy.

 2 Choose Copy Action in the menu.

 3 Right-click the action and choose Paste Action in the menu. The 
Rename Action dialog box opens.

 4 Give the action a logical name. 

 5 Click OK.

A new action is added to your test and is displayed at the bottom of the test tree.
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Parameterizing an Action
You parameterize an action by parameterizing the steps within that action. When 
you add a parameter to your test, you specify whether it is a global parameter, for 
the entire test, or a local parameter, for a specific action within the test.

In the parameterization dialog boxes:

• Choosing Global creates parameters in the Global sheet in the Data pane.

• Choosing Local creates parameters in the corresponding Action sheet in the 
Data pane. When there are parameters in an Action sheet, Astra QuickTest 
runs the relevant number of iterations on that action before continuing with 
the test. 

Note: You can choose to run iterations on specific rows within the action sheet 
rather than on all rows, from the Run Tab of the Test Settings dialog box. For 
more information, see Chapter 22, Setting Testing Options for a Single Test. 
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To parameterize an action:

 1 Right-click a step in the test tree and select Function Arguments. The Function 
Arguments dialog box opens and displays the properties of the object in the step. 

 2 In the Edit value section, click Parameter. 
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 3 In the Parameter box, choose a parameter from the list or enter a new name.

• To use a parameter that you already created, select it from the list.

• To create a new parameter, accept the default parameter name or enter a 
descriptive name for the parameter.

 4 Select In Local Data Table to add the parameter to the Action sheet.

 5 Click OK to close the dialog box.

 6 If you created a new parameter, the Astra Parameter dialog box prompts you to 
add the new parameter to the relevant action sheet in the Data pane. Click OK. A 
new column is highlighted in the table for the new parameter.

In your test tree, the  icon next to the step indicates that the step has been 
parameterized.

Note: You can specify additional data values for the parameter by entering them 
directly into the relevant action sheet in the Data pane. For more information, 
see Chapter 8, Working with Data Tables. 
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Inserting Actions from Another Test

When you plan a suite of tests, you may realize that each test requires one or 
more identical activities, such as logging in. Rather than record the login process 
three times in three separate tests, and enhancing this part of the script (with 
checkpoints and parameterization) separately for each test, you can use the 
Insert > New Action command to create an action in one test that logs into the 
flight reservation system. Once you are satisfied with the action you recorded and 
enhanced, you can insert it into other tests. You can insert an action from another 
test by pasting a copy of the action into your test, or by linking to the action in the 
original test.

For more information on creating a new action in a test, see Using Multiple 
Actions in a Test on page 192.
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Suppose you wanted to record the following three tests in the Mercury Tours site: 
Booking a flight, Modifying a reservation and Deleting a reservation. While 
planning your test you realize that for each test you need to log in and log out of 
the site. If you plan to use the insert action option for the repeated activities, then 
you would initially record the three tests as shown:

Once you have set up your tests, you must choose whether you want to paste a 
copy of the action or paste a link to it.

When you paste a copy of an action into a test, the action is copied in its entirety, 
including checkpoints, parameterization, and the corresponding action tab in the 
Data pane. Once it is pasted in the test, you can add to, delete from, or modify the 
action just as you would with any other recorded action. Any changes you make 
to this action after you insert it affect only this action, and changes you make to 
the action in the original test do not affect the action in this test.

When you paste a link to the action, the action is inserted in read-only format. You 
can view the components of the action, but you cannot modify them. If you modify 
the action in the original test, the modifications also take effect in any tests that 
are linked to the action.
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To paste a copy of an action into a test:

 1 Choose Insert > Action from test. The Select Action dialog box opens.

 2 Use the browse button to find the test from which you want to insert the action.
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 3 Select the action you want to insert from the list. When you highlight an action, 
its description, if one exists, appears in the action’s description box. This helps 
you identify the action you want to insert. For more information about inserting 
action descriptions see page 195.

 4 Click Paste.

 5 Click OK. The action is pasted into the test and appears at the bottom of the test 
tree. You can move the action to another location in the test by dragging it to the 
desired location in the test tree.

Note: If you try to insert an action in a test that already contains an action with 
the same name, you are prompted to rename the action. You can rename the 
action by choosing Edit > Rename.
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To paste a link of an action into a test:

 1 Choose Insert > Action from test. The Select Action dialog box opens.

 2 Use the browse button to find the test from which you want to insert the action.

 3 Select the action you want to insert from the list.
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 4 Click Paste link.

 5 Click OK. A link to the action is pasted into the test and appears at the bottom of 
the test tree with a special linked action icon. You can move the action to another 
location in the test by dragging it to the desired location in the test tree.
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Guidelines for Working with Actions 

Consider the following guidelines when working with actions: 

• When you parameterize an action in your test, the action must ‘clean up after 
itself’. In other words, the action must end at the same point it started, so that it 
can run again without interruption. For example, suppose you are testing the 
sample flight reservation site. If the action starts with a blank flight reservation 
form, it should conclude with a blank flight reservation form.

• A single test may include both global parameterization and action 
parameterization. For example, you can create a test in which a travel agent logs 
into the flight reservation system, books three flights, and logs out; the next 
travel agent logs into the flight reservation system, and books three flights and 
logs out, etc. To parameterize the ‘book a flight’ action, you choose Local in the 
parameterization dialog box and enter the three flights into the relevant Action 
tab in the Data pane. To parameterize the entire test, you choose Global in the 
parameterization dialog box and enter the login names and passwords for the 
different agents into the Global tab in the Data pane.

• You should rename the actions in your test with descriptive names to help you 
identify them. This facilitates inserting actions from one test to another. You can 
rename the action by choosing Edit > Rename.
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• If you plan to use an identical procedure in more than one test, you should 
consider inserting an action from another test. If you want to make modifications 
to the action in only one test, or to make different modifications in different tests, 
you should use the Paste option to paste a copy of the action. If you want 
modifications to affect all tests containing the action, you should use the Paste 
link option to insert a link to the action in the original test.

• If you expect certain elements of your Web site to change regularly, it is a good 
idea to divide the steps related to changeable element into a separate action so 
that it will be easy to re-record the required steps when the site is modified.
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Handling Unexpected Events and Errors

You can instruct Astra QuickTest to handle unexpected events and errors that 
occur in your testing environment during a test run.

This chapter describes:

• Changing the Status of Exceptions

• Modifying Exceptions

• Adding New Exceptions

• Deleting Exceptions
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About Handling Unexpected Events and Errors

Unexpected events and errors during a test run can disrupt your test and distort 
test results. This is a problem particularly when running tests unattended: the 
tests are suspended until you perform the action needed to recover.

You can use the Exception Editor to instruct Astra QuickTest to detect and handle 
the appearance of a specific dialog box and act to recover the test run.

For example, if a Security Alert dialog box is displayed during a test run, you can 
instruct Astra QuickTest to recover the test run by clicking the default button. In 
this particular case, the Yes button is the default button.

The Exception Editor contains a list of exceptions that Astra QuickTest supports. 
Each exception is associated with a handler function that is activated when there 
is a need to recover the test run. You can modify the list of exceptions and 
configure additional types of dialog box exceptions that you would like Astra 
QuickTest to support.
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Changing the Status of Exceptions

The Exception Editor includes a list of all the available exceptions. You can 
choose to activate or deactivate any exception in the list.

To change the status of an exception:

 1 Choose Tools > Exception Editor. The Exception Editor opens.
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 2 In the Choose An Exception list, click an exception. 

The exception is highlighted. The current description of the exception appears in 
the Exception Details area.

 3 To activate an exception, select its check box. To deactivate the exception, clear 
its check box.

 4 Click OK to save the changes.
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Modifying Exceptions

You can modify the details of an exception listed in the Exception Editor.

To modify the details of an exception:

 1 Choose Tools > Exception Editor. The Exception Editor opens.

 2 In the Choose An Exception list, click an exception. 

The exception is highlighted. The current description of the exception appears in 
the Exception Details area.
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 3 You can modify the title or the content of the exception dialog box, or which 
handler function to associate with it.

• To modify the title of the exception dialog box, edit the text in the Title box.

• To modify the text that appears in the exception dialog box, edit a text line in 
the Text box.

• To change the handler function associated with this exception dialog, choose 
a function from the Action list. This function recovers the test run.

 4 Click OK to save the changes.

Function Description

<enter> Presses the Enter key.

<login> 
Uses the user name and password you supply in the 
User Name and Password edit boxes.

<press button>
Clicks the button you select from the Button Name 
list.
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Adding New Exceptions

You can add a new exception to the list of exceptions in the Exception Editor.

To add a new exception:

 1 Choose Tools > Exception Editor. The Exception Editor opens.

 2 Click the Learn button. The mouse pointer becomes a pointing hand. Click the 
dialog box. A new exception is added to the list. 
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The Exception Editor displays the title of the exception dialog box, the property 
class of the exception, the text that appears in the dialog box, and the handler 
function that is responsible for recovering test execution. To modify these fields, 
refer to Modifying Exceptions on page 212.

 3 Click OK to save the exception.
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Deleting Exceptions

You can delete an exception from the list of exceptions in the Exception Editor.

To delete an exception:

 1 Choose Tools > Exception Editor. The Exception Editor opens.

 2 In the Choose An Exception list, click an exception to delete. 

The exception is highlighted. The current description of the exception appears in 
the Exception Details area.

 3 Click the Delete button. A warning dialog box opens.

 4 Click Yes to delete the exception.

 5 Click OK to exit the Exception Editor.
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Understanding How Astra QuickTest 
Identifies Objects

This chapter explains how Astra QuickTest identifies objects in your application. 
It also describes how to modify the way Astra QuickTest identifies an object, which 
is useful when working with objects that change dynamically.

This chapter describes:

• Understanding Dynamic Descriptions of Objects

• Modifying How Astra QuickTest Identifies Objects

About How Astra QuickTest Identifies Objects

Astra QuickTest identifies each object in your application by its physical 
description: a list of physical properties and their assigned values. The properties 
in an object’s physical description are its logical name and its class. The logical 
name is the object’s label. The class indicates the object’s type. Each object 
belongs to a different class, according to its functionality, such as Browser, Image, 
Link (hypertext link), WebList (drop-down list box).
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You can open the Object Properties dialog box for an object to see its physical 
description. The example below displays the physical description for an image in 
a Web page.

physical description



Creating Tests • Understanding How Astra QuickTest Identifies Objects

Astra QuickTest User’s Guide Chapter 12, page 219

Back

Find

Find

Chapter
Top of

 Again

For each object class, Astra QuickTest learns a set of default properties, which it 
uses to identify objects of that class in your application.

Astra QuickTest learns the values of an object’s default properties when it records 
a test, and it uses this information to identify the object when it runs the test. 

For example, by default, Astra QuickTest identifies an image by its physical 
description, the image’s HTML tag, the alternate text (displayed if the image is not 
available or as a tooltip for the image), and its index. The index is a unique number 
that Astra QuickTest uses to identify an object (in this case the image) on the Web 
page. The index is numbered in the order in which the object appears in the Web 
page, starting from top to bottom, and from left to right.

image icon

logical name
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Understanding Dynamic Descriptions of Objects

You can change the properties that Astra QuickTest uses to identify an object. 
This is useful when you want to create and run tests on an object that changes 
dynamically. An object may change dynamically if it is frequently updated or if it 
is created using dynamic content, e.g. from a database. You can also change the 
properties that identify an object in order to reference objects using properties 
that were not automatically learned while recording.

For example, suppose you are testing a Web site that contains news headlines. 
This site includes a hypertext link to each current news story. The text in the 
hypertext link changes as the current news stories change. Suppose you always 
want to create a step in your test in which you always click the same hypertext 
link in the News section of your Web page. Since the news is always changing, 
the text in the hypertext link keeps changing. You need to modify how Astra 
QuickTest identifies this hypertext link so that it can continue to find it.

The default properties for a Link object (hypertext link) are “text” and “HTML tag”. 
The text property is the text inside the link. The HTML tag property is always, “A”, 
which indicates text. 

You can modify the default properties for a hypertext link, so that you can identify 
it by where it appears on the page, rather than by the text in the link. You can use 
the “source_image” property to check the link by a unique index identifier in the 
source HTML file instead of using the “text” property to check the link by the text 
in the link. This index does not change, even if the text within the link changes. 
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Modifying How Astra QuickTest Identifies Objects

Suppose you are testing a Web page that contains an image that is an 
advertisement. Clicking this image opens the advertiser’s Web page. You do not 
want to identify the image by its name, since the image changes whenever the 
advertiser changes. Therefore, the value of the name property changes. You 
would want to create a test that will run no matter what the image’s name is. 
Therefore, you would want Astra QuickTest to identify your image using 
properties other than the name property. 

You can use the Add/Remove Properties dialog box to instruct Astra QuickTest to 
learn properties of the object other than the default properties.
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To modify how Astra QuickTest identifies an object:

 1 In the test tree, right-click the object for which you want to modify the identifying 
properties and choose Object Properties. 

The Object Properties dialog box opens.
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 2 Click the Add/Remove button.

The Add/Remove Properties dialog box opens, listing the properties that can be 
used to identify the object. A selected check box next to a property indicates a 
property that Astra QuickTest uses to identify the object. The value for each 
property is displayed in the Value column.

 3 Modify the default properties that Astra QuickTest uses to identify the object:

• To add a property, select the corresponding check box.

• To remove a property, clear the corresponding check box.

 4 Click OK to close the Add/Remove Properties dialog box.

The Object Properties dialog box is reactivated.

Tip: After you add a new property, you can modify its value in the Edit Value box 
in the Object Properties dialog box. 
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Part III

Running and Debugging Tests
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Running Tests 

Once you have created a test, you run it to check the behavior of your Web site. 

This chapter describes:

• Running a Test

• Optional Steps
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About Running Tests

When you run a test, Astra QuickTest navigates through your Web site, 
performing the steps you recorded. If your test does not contain parameterized 
values, Astra QuickTest runs the test once. If the test contains global parameters 
(in the Global tab of the Data pane), Astra QuickTest runs the test for each row in 
the table, using the parameters you specified.

If the test contains local parameters (in one or more Action tabs in the Data pane), 
you can specify whether to run the action in iterations, or to run the action in 
iterations for a range of data sets. For additional information, see Chapter 10, 
Working with Actions. 

Once the test run is complete, Astra QuickTest displays a report detailing the test 
results. After you run your test, you can update your ActiveScreen with the 
screens of your current test results. By updating, you refresh the screens in your 
ActiveScreen to include any changes to your Web site.

You can also run tests on objects with dynamic descriptions. For additional 
information, see Chapter 12, Understanding How Astra QuickTest Identifies 
Objects. 
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Running a Test

When you run a test, Astra QuickTest performs the steps you recorded on your 
Web site and displays each Web page in your browser. Astra QuickTest always 
runs a test from the first step in the test. 

If your test does not contain parameterized values, Astra QuickTest runs the test 
once. If the test does contain parameters, Astra QuickTest runs the test for each 
row in the table in the Data pane, using the parameters you specified. If an action 
within your test is parameterized, you can choose to set and run only certain data 
sets. For more information, see Chapter 10, Working with Actions. 
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To run a test:

 1 If your test is not already open, choose File > Open or click the Open button to 
open the test.

 2 Click the Start Run button on the toolbar, or choose Test > Run. The Run Test 
dialog box opens, displaying the path and a default test run name for the test 
results. 

 3 To save the test results under a different name, type it in the text box or click 
Browse to locate the folder. 

To run the test and overwrite the previous test results, select the Debug mode 
check box. 

If you do not want to display the Run Test dialog box the next time you run your 
test, select the Don’t show again check box.
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 4 Click OK. The Run Test dialog box closes and Astra QuickTest begins running 
the test. Astra QuickTest always runs a test from the first step in the test. As 
Astra QuickTest runs the test, it highlights each step in the test tree. 

When the test stops running, the Test Results window opens.

Note: If you want to interrupt a test that is running, you can:

Click the Pause button or choose Debug > Pause. The test pauses. To resume 
running a paused test, click the Run button or choose Test > Run.

Click the Stop button or choose Test > Stop. The test stops running and the 
Test Results window opens. 
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Optional Steps

When running a test, if a step does not open a particular dialog box, Astra 
QuickTest does not interrupt the test run. It bypasses this step and continues to 
run the test. A bypassed step is an optional step. By default, Astra QuickTest sets 
some dialog boxes as optional steps. You can also set a step as optional.

Setting Optional Steps
When running a test, you can bypass certain steps if they are not required, by 
setting them as optional steps. For example, when recording a test, the site you 
are testing may prompt you to enter your user name and password in a logon 
window. However, when you run the test, the site does not prompt you to enter 
your user name and password, because it has retained the information that was 
previously entered. In this case, the steps that were recorded for entering the 
logon information are not required and should be marked as optional. When Astra 
QuickTest runs the test, it will use these optional steps when needed.
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To set an optional step:

Right-click a step in the test tree and choose Optional Step. The Optional Step 
 icon is added next to the selected step.

Note: You can also add an optional step from the Expert View using a 
OptionalStep.Browser("browser_name").Page("page_name").Link("link_nam
e") VBScript statement. For information on working in Expert View, see 
Chapter 18, Testing in the Expert View.  For information on the OptionalStep 
object, refer to the Astra Function Reference.
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Default Optional Steps
When running a test, if a step fails to open a particular dialog box, Astra QuickTest 
automatically bypasses this step and continues to run the test. When the test run 
is completed, a message is displayed for the step that failed to open the dialog 
box. 

Astra QuickTest automatically recognizes the following dialog boxes:

Logical Name Title

Auto Complete Auto Complete

File Download File Download

IE message Internet Explorer

Netscape message Netscape

Password Enter Network Password

Runtime error Error

Security Alert Security Alert

Security Information Security Information

Security Warning Security Warning

Username and Password Required Username and Password Required
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Analyzing Test Results 

After you run a test, you can view a report of all the major events that occurred 
during the test run.

This chapter describes:

• The Test Results Window

• Viewing the Results of a Test Run

• Viewing the Results of a Checkpoint

• Viewing the Runtime Data Table for a Parameterized Test

• Printing Test Results

About Analyzing Test Results

After you run your test, the test results are displayed in the Test Results window. 
This window contains a description of every step performed during the test run. If 
the test does not contain parameterized values, the Test Results window shows 
a single test iteration result. If the test does contain parameters, the Test Results 
window shows a test iteration for each row in the table in the Data pane.
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The Test Results Window

After a test run, you can view the results in the Test Results window. By default, 
the Test Results window automatically opens when a test run is completed. For 
more information on opening the Test Results window, see Viewing the Results 
of a Test Run on page 236.

Test results tree

Test results 
details
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Test Results Tree
The left pane in the Test Results window displays the test results tree—a 
graphical representation of the test results. This includes the  icon for a 
successful iteration, and the  icon for a failed iteration. In the example above, 
the tree includes two iterations. The test results tree also includes the  icon that 
displays the Runtime Data—a table that shows the values used to run a 
parameterized test, or the values retrieved from a parameterized test while it runs 
(output parameters). Note that your test results are organized by action.

You can collapse or expand a branch in the test results tree in order to change 
the level of detail that the tree displays.

Test Results Details
The right portion of the window displays the test results details—additional 
information for a selected branch of the report tree.

By default, when the Test Results window opens, a test summary appears. It 
indicates the test name, the date and time of the test run, and whether a test 
iteration passed or failed. 
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Viewing the Results of a Test Run

After a test run, you can view the results in the Test Results window. By default, 
the Test Results window automatically opens when a test run is completed. For 
more information, see Astra QuickTest Testing Options on page 347.

To view the results of a test run:

 1 If the Test Results window is not already open, then click the Test Results 
button or choose Test > Results. The Select Results File dialog box opens. 
Select a results file (.qtp extension). Click Open. The Test Results window 
opens.
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 2 You can collapse or expand a branch in the test results tree in order to change 
the level of detail that the tree displays.

• To collapse a branch, click the Collapse (-) sign to the left of the branch icon. 
The report tree hides the details for the branch and the Collapse sign 
changes to Expand.

• To collapse all the branches in the report tree, choose View > Collapse All.
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• To expand a branch, click the Expand (+) sign to the left of the branch icon. 
The tree displays the details for the branch and the Expand sign changes to 
Collapse.

• To expand all the branches in the report tree, choose View > Expand All.

 3 To filter the information contained in your test results report, click the Filter 
button or choose View > Filters. The Filters dialog box opens.

The default filter options are displayed above. 

• Click Iteration Range to limit the test results to a specified range of test 
iterations.

• Click Fail Only to limit the test results to test iterations that failed.
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 4 To view other test run results, click the Open button or choose File > Open. The 
Open dialog box opens. Select a results file (.qtp extension) and click the Open 
button.

 5 To print the test results, see Printing Test Results on page 244.

 6 Choose File > Exit to close the Test Results window.

Note: You can open the Test Results window as a standalone application from 
the Start menu. To open the Test Results window, choose Start > Programs > 
Astra QuickTest > Report Viewer.
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Viewing the Results of a Checkpoint

By adding checkpoints to your tests, you can compare pages, text strings, objects, 
and tables in different versions of your Web site. This enables you to ensure that 
your Web site functions as desired. 

When you run the test, Astra QuickTest compares the expected results of the 
checkpoint to the current results. If the results do not match, the checkpoint fails. 
You can view the results of the checkpoint in the Test Results window.

For more information on checkpoint, see Chapter 4, Creating Checkpoints. 

To view the results of a checkpoint:

 1 If the Test Results window is not already open, then click the Test Results 
button or choose Test > Results. The Select Results File dialog box opens. 
Select a results file (.qtp extension). Click Open. The Test Results window 
opens.

 2 In the left pane of the Test Results window, expand the branches of a test 
iteration.
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 3 Click a checkpoint branch. The right pane displays detailed results of the 
selected checkpoint.

In the above example, the detailed results of the failed checkpoint indicates that 
the expected results and the current results do not match. The expected value of 
the flight departure is “Seattle”, but the actual value is “Acapulco”.

 4 Choose File > Exit to close the Test Results window.
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Viewing the Runtime Data Table for a Parameterized Test

After you run a parameterized test, the Runtime data table displays the values 
used to run a parameterized test, or the values retrieved from a parameterized 
test while it runs (output parameters). For more information on parametrization, 
see Chapter 6, Parameterizing Tests.  For more information on output 
parameterization, see Chapter 7, Creating Output Parameters.  For more 
information on the test Data Table, see Chapter 8, Working with Data Tables. 

To view the Runtime Data Table:

 1 If the Test Results window is not already open, then click the Test Results 
button or choose Test > Results. The Select Results File dialog box opens. 
Select a results file (.qtp extension). Click Open. The Test Results window 
opens.
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 2 In the left pane of the Test Results window, click the Runtime Data icon. The 
right pane displays the Runtime data table. 

In the above example, the Runtime data table contains the parameterized flight 
departure values and the flight arrival values.

 3 Choose File > Exit to close the Test Results window.
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Printing Test Results

You can print your test results from the Test Results window.

To print the test results:

 1 To print the report, click the Print button or choose File > Print. The Print dialog 
box opens.

 2 Select a Print Range option:

• Select All to print the entire results report.

• Select Selection to only print a selected branch in the report tree.

• Select Iterations to only print a specified range of test iterations.

 3 Click OK to print.
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Debugging Tests

Controlling test runs can help you to identify and eliminate defects in your tests.

This chapter describes:

• Using the Step Commands

• Pausing Test Runs

• Setting Breakpoints

• Deleting Breakpoints
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About Debugging Test Scripts

After you create a test script you should check that it runs smoothly, without errors 
in syntax or logic. In order to detect and isolate defects in a test, you can use the 
Step and Pause commands to control how it runs. In addition, you can also control 
how the test runs by setting breakpoints.

The following Step commands are available:

• The Step Into command calls a function or displays another test.

• The Step Out command—used in conjunction with Step Into—completes the 
execution of a function or called test.

• The Step Over command executes a function or a called test. 

You can also use the Pause command to temporarily suspend a test run. When 
you resume running the test, it continues from the point where you invoked the 
Pause command.

In addition, you can also control test runs by setting breakpoints. A breakpoint 
pauses a test run at a pre-determined point, enabling you to examine the effects 
of the test on your Web site.
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Using the Step Commands

You can run a single line of a test using the Step Into, Step Out, and Step Over 
commands.

Step Into
Choose Debug > Step Into or click the Step Into button to run only the current 
line of the active test script. If the current line of the active test calls another test 
or a function, the called test or function is executed in its entirety, and the called 
test or function is displayed in the Astra QuickTest window. 

Step Out
Choose Debug > Step Out or click the Step Out button only after entering a test 
or a user-defined function using Step Into. Step Out runs to the end of the called 
test or user-defined function, returns to the calling test, and then pauses the test 
run.

Step Over
Choose Debug > Step Over or click the Step Over button to run only the current 
step in the active test. When the current step calls another test or a user-defined 
function, the called test or function is executed in its entirety, but the called test 
script is not displayed in the Astra QuickTest window. 
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Pausing Test Runs

You can temporarily suspend test runs by choosing Debug > Pause or clicking 
the Pause button. A paused test stops running when all previously interpreted 
steps have been run.

To resume running a paused test, click the Run button or choose Test > Run. The 
test run continues from the point that you invoked the Pause command.
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Setting Breakpoints

By setting a breakpoint you can stop a test run at a specific place in a test. A 
breakpoint is indicated by a red-colored hand in the left margin of the test window. 
Astra QuickTest pauses the test run when it reaches a breakpoint. You can 
examine the effects of the test run up to the breakpoint, make any necessary 
changes, and then continue running the test from the breakpoint. 

You can use breakpoints to:

• suspend a test run and inspect the state of your site

• mark a point from which to begin stepping through a test script using the Step 
commands

To set a breakpoint: 

 1 Click a step or a line in the test where you want the test run to stop.

 2 Choose Debug > Toggle Breakpoint or click the Toggle Breakpoint button. 
The breakpoint symbol appears in the left margin of the Astra QuickTest window.

Note: The breakpoints you define are active only during your current Astra 
QuickTest session. If you terminate your Astra QuickTest session, you must 
redefine breakpoints to continue debugging the script in another session.
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Deleting Breakpoints

You can delete a single breakpoint or all breakpoints defined for the current test 
using the Debug menu.

• To delete a single breakpoint, click a line in your test with the breakpoint 
symbol and choose Debug > Toggle Breakpoint, or click the Toggle 
Breakpoint button.

The breakpoint symbol is removed from the left margin of the Astra QuickTest 
window.

• To delete all breakpoints, choose Debug > Clear All Breakpoints or click the 
Clear All Breakpoints button.

All breakpoint symbols are removed from the left margin of the Astra 
QuickTest window.
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Part IV

Advanced Features
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Configuring Event Recording

If Astra QuickTest does not record all the events you need, you can configure the 
events you want to record for each type of Web object. 

This chapter describes:

• Selecting a Standard Event Recording Configuration

• Customizing the Event Recording Configuration

• Resetting Standard Event Recording Configuration Settings

About Configuring Event Recording

Astra QuickTest records your test by recording the events you perform on your 
Web site. An event is a notification that occurs in response to an action, such as 
a change in state, or as a result of the user clicking the mouse or pressing a key 
while viewing the document. You may find that you need to record more or fewer 
events than Astra QuickTest automatically records by default. You can modify the 
default event recording settings by using the Event Configuration Settings dialog 
box to select one of three standard configurations, or you can customize the 
individual event recording configuration settings to meet your specific needs.
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For example, Astra QuickTest does not generally record mouseover events on 
link objects. If, however, you have a mouseover behavior connected to a link, it 
may be important for you to record the mouseover event. In this case, you could 
customize the configuration to record mouseover events on link objects only if 
they are connected to a behavior.

Note that event configuration is a global setting and therefore affects all tests that 
are recorded after you change the settings.

Note: Changing the event configuration settings does not affect tests that have 
already been recorded. If you find that Astra QuickTest recorded more or less 
than you need, change the event recording configuration and then re-record the 
part of your test that is affected by the change.
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Selecting a Standard Event Recording Configuration

By default, Astra QuickTest uses the Basic recording configuration level. If Astra 
QuickTest does not record all the events you need, you may require a higher 
event configuration level.

The Event Configuration Settings dialog box offers three standard event 
configuration levels. 

Level Description

Basic Default 
- Always records click events on standard web 
objects.
- Always records reset and submit events within 
forms.
- Records click events on other objects with a handler 
or behavior connected.
- Records the event following a mouseover event on 
images and image maps. 
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Medium Records click events on the <DIV>, <SPAN>, and 
<TD> HTML tag objects in addition to the objects 
recorded in the basic level.

High Records mouseover, mousedown, and double-click 
events on objects with handlers or behaviors attached 
in addition to the objects recorded in the basic level.
For more information on handlers and behaviors, see 
Listening Criteria on page 265.

Level Description
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To set a standard event recording configuration:

 1 Choose Tools > Web Event Recording Configuration. The Web Event 
Recording Configuration Settings dialog box opens.

 2 Use the slider to select your preferred standard event recording configuration.

 3 Click OK. 
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Customizing the Event Recording Configuration

If the standard event configuration levels do not exactly match your recording 
needs, you can customize the event recording configuration using the Custom 
Event Configuration dialog box.

The Custom Event Configuration dialog box enables you to customize event 
recording in several ways. You can:

• add or delete objects to which Astra QuickTest should apply special listening or 
recording settings. 

• add or delete events to which Astra QuickTest should listen for all objects.

• add or delete events to which Astra QuickTest should listen for one or more 
specific objects.

• modify the listening or recording settings of an event to which Astra QuickTest 
listens for all objects.

• modify the listening or recording settings of an event for one or more specific 
objects.
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To customize the event recording configuration:

 1 Choose Tools > Web Event Recording Configuration. The Web Event 
Recording Configuration dialog box opens. 

 2 Click the Custom Settings button. The Custom Web Event Recording 
Configuration dialog box opens.

 3 Set the event recording configuration options you want. The sections below 
describe the event recording configuration options in detail.
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 4 Click OK. The Custom Event Configuration dialog box closes. The slider on the 
Event Configuration Settings dialog box disappears and the configuration 
description displays: Custom Settings.
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Adding and Deleting Objects in the Custom Configuration 
Object List
The Custom Event Configuration dialog box lists objects in an object hierarchy. 
The top of the hierarchy is Any Web Object. The settings for Any Web Object 
apply to any object on the Web page being tested, for which there is no specific 
settings. Below this are the Standard and HTML Tag Objects categories, each of 
which contains a list of objects.

When working with the objects in the Custom Event Configuration dialog box, 
keep the following principles in mind:

• If an object is listed in the Custom Event Configuration dialog box, then the 
settings for that object override the settings for Any Web Object.

• Astra QuickTest always listens to the objects listed under standard objects. 
Therefore, you cannot delete or add to the objects in this category.

• You can add any HTML Tag object in your web page to the HTML Tag Objects 
category.
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To add objects to the event configuration object list:

 1 From the Custom Event Configuration dialog box, choose Object > Add. A “New 
Object” object appears in the HTML Tag Objects list.  

 2 Click New Object to rename it. Enter the exact HTML Tag name.

By default the new object is set to listen and record onclick events with handlers 
attached.

For more information on adding or deleting events, see Adding and Deleting 
Listening Events for an Object on page 263.
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For more information on listening and recording settings, see Modifying the 
Listening and Recording Settings for an Event on page 265.

To delete objects from the HTML Tag Objects list:

 1 From the Custom Event Configuration dialog box, select the object in the HTML 
Tag Objects category that you want to delete.

 2 Choose Object > Delete. The object is deleted from the list.

Note: You cannot delete objects from the standard objects category.
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Adding and Deleting Listening Events for an Object
You can modify the list of events that trigger Astra QuickTest to listen to an object.

To add listening events for an object:

 1 From the Custom Event Configuration dialog box, select the object to which you 
want to add the event, or select Any Web Object.

 2 Choose Event > Add. A list of available events opens.
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 3 Select the event you want to add. The event appears in the Event Name column 
in alphabetical order. By default, the event is set to record when a handler is 
attached to the object.

For more information on listening and recording settings, see Modifying the 
Listening and Recording Settings for an Event on page 265.

To delete listening events for an object:

 1 From the Custom Event Configuration dialog box, select the object from which 
you want delete an event, or select Any Web Object.

 2 Select the event you want to delete from the Event Name column.

 3 Choose Event > Delete. The event is deleted from the Event Name column. 
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Modifying the Listening and Recording Settings for an Event
You can select the listening criteria and set the recording status for each event 
listed for each object.

Listening Criteria

For each event, you can instruct Astra QuickTest to listen every time the event 
occurs on the object, if an event handler is attached to the event and/or if a 
DHTML behavior is attached to the event.

An event handler is code in a web page, typically a function or routine written in a 
scripting language, that receives control when the corresponding event occurs. 

A DHTML behavior is a simple, lightweight component that encapsulates specific 
functionality or behavior on a page. When applied to a standard HTML element 
on a page, a behavior enhances that element’s default behavior. 
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To specify the listening criterion for an event:

 1 From the Custom Event Configuration dialog box, select the object for which you 
want to modify the listening criterion or select Any Web Object.

 2 In the row of the event you want to modify, select the listening criterion you want 
from the Listen column. 

You can select Always, If Handler, If Behavior, or If Handler or Behavior.
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Recording Status

For each event to which Astra QuickTest listens, you can enable recording, 
disable recording, or enable recording only if the next event is dependant on this 
event.

• Enabled - records the event each time the listening criterion is met.

• Disabled - does not record the specified event and ignores event bubbling 
where applicable.

Bubbling is the process whereby, when an event occurs on a child object, the 
event can travel up the chain of hierarchy within the HTML code until it 
encounters an event handler to process the event. 

• Enabled on next - records the event only if the subsequent event occurs on the 
same object and is dependant on this event. For example, suppose a 
mouseover behavior modifies an image link. You may not want to record the 
mouseover event each time you happen to move the mouse over this image. 
Because only the image that appears after the mouseover event enables the link 
event, however, it is essential that the mouseover event is recorded before a 
click event on the same object. This option applies only to the Image and 
WebArea standard objects.
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To set the recording status for an event:

 1 From the Custom Event Configuration dialog box, select the object for which you 
want to modify the recording status or select Any Web Object.

 2 In the row of the event you want to modify, select the recording status you want 
from the Record column.  
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Resetting Standard Event Recording Configuration Settings

If you want to restore standard settings after you have set Custom settings, there 
are two ways to reset the settings. 

• You can reset the event recording configuration settings to the basic level from 
the Event Configuration Settings dialog box.

• You can reset the settings to any one of the standard settings from within the 
Custom Event Configuration dialog box so that you can begin customizing from 
that point. 

Note: When you choose to reset standard settings, your custom settings are 
cleared completely.

To reset basic level configuration settings from the Event Configuration 
Settings dialog box:

 1 Choose Tools > Web Event Configuration. The Event Configuration Settings 
dialog box opens.

 2 Click Default. The standard configuration slider re-appears and all event settings 
are restored to the Basic event recording configuration level.

 3 If you want to select a different standard configuration level, see Selecting a 
Standard Event Recording Configuration on page 254.
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To reset standard settings from the Custom Event Configuration dialog 
box:

 1 Choose Tools > Web Event Configuration. The Event Configuration Settings 
dialog box opens.

 2 Click the Customize button. The Custom Event Configuration dialog box opens.

 3 In the Reset To box, select the standard event recording level you want.

 4 Click Reset. All event settings are restored to the defaults for the level you 
selected.
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Enhancing Your Tests with Programming

After recording a test, you can use Astra QuickTest to enhance your test using a 
few simple programming techniques. 

This chapter describes:

• Inserting Functions

• Using Conditional Statements

• Sending Messages to Your Test Results

• Adding Comments
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About Enhancing Your Tests with Programming

When recording, a test is generated by recording the typical processes that you 
perform on your Web site. As you navigate through your site, Astra QuickTest 
graphically displays each step you perform as an icon in a test tree. 

Once you record your test, you can increase the power and flexibility of your tests 
by programming. Astra QuickTest includes the Function wizard, a programming 
tool which helps you to quickly and easily add recordable and non-recordable 
functions to your test. You can use the wizard to add functions that perform 
operations on Web objects or retrieve information from your site. For example, 
you can add a step that checks that an object exists, or you can retrieve the return 
value of a function.

Astra QuickTest also enables you to incorporate decision-making into your test. 
You can add conditional statements to control the logical flow of your test. 

In addition, you can define messages in your test that Astra QuickTest sends to 
your test results. To improve the readability of your tests, you can also add 
comments to your test.

This chapter introduces some programming concepts and shows you how to use 
simple programming techniques in the Tree View in order to create more powerful 
tests. For information on how to use programming concepts in the Expert View, 
see Chapter 18, Testing in the Expert View. 
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Inserting Functions

After recording, you can add additional functions to your tests using the Function 
wizard. With the wizard you can add recordable and non-recordable functions that 
perform operations on objects or retrieve information from your site. For example, 
the QueryValue function enables you to query the method argument value. You 
can use the return value of the function as an output parameter or as part of a 
conditional statement. 

To insert a function in a test:

 1 In the Tree View, click a step in the test tree. A menu opens. Choose Insert > 
Step > Function. 

Tip: To add a function from the Expert View, click a statement in the test script. 
Right-click the highlighted object in the ActiveScreen and choose Insert 
Function. The Object Selection - Insert Function opens. Select an object and 
click OK.

 2 The Function Wizard - Introduction screen opens. Click Next.
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 3 The Function Wizard - Select Function screen opens.

Select a function and click Next.
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 4 If the function you chose returns a value, the Function Wizard - Return Value 
screen opens. Otherwise, proceed to the next step.
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The following options are available:

Click Next to continue. 

Option Description

Put the value in 
the data table 
(default)

Inserts the return value of the function as an output parameter 
into your Data pane. For more information, see Chapter 7, 
Creating Output Parameters. 

Parameter name Sets the name for the output parameter. You can accept the 
default name, select from the list, or enter a new name. For 
more information, see Chapter 7, Creating Output 
Parameters. 

Place the value in 
a new condition 
statement

Inserts the return value of the function into a conditional 
statement. For more information, see Using Conditional 
Statements on page 280.

Assign the return 
value to a variable 
by the name of

Assigns the return value to a variable of the specified name.
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 5 If the function you chose has function arguments, the Function Wizard - Function 
Arguments screen opens. Otherwise, proceed to the next step.
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The screen displays the arguments you can parameterize, in a pane listing the 
arguments, their values, and their types:

In the Edit value section, you use the following options to edit the argument 
value.

Click Next to continue. 

Option Description

Type The  icon indicates that the argument value is a constant. 
The  icon indicates that the argument value is a parameter.

Argument The name of the argument whose value will be parameterized.

Value The value of the argument to parameterize. 

Option Description

Constant 
(default)

Sets the argument value as a constant.

Parameter Sets the argument value as a parameter. For more information, see 
Chapter 6, Parameterizing Tests. 
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 6 The Function Wizard - Finished screen opens. 

Click Finish to complete the process and add the function to your test.



Advanced Features • Enhancing Your Tests with Programming

Astra QuickTest User’s Guide Chapter 17, page 280

In

Back

Find

Find

Chapter
Top of

 Again

Using Conditional Statements 

You can control the flow of your script with conditional statements. Using 
conditional statements, you can incorporate decision-making into your tests using 
If...Then...Else statements.

The If...Then...Else statement is used to evaluate whether a condition is true or 
false and, depending on the result, to specify one or more statements to run. 
Usually the condition is an expression that uses a comparison operator to 
compare one value or variable with another. The following comparison operators 
are available: less than <, less than or equal to <=, greater than >, greater than or 
equal to >=, not equal <>, and equal =. 

Your If...Then...Else statement can be nested to as many levels as you need. It 
has the following syntax:

If condition Then statements [Else elsestatements ] 

Or, you can use the block form syntax: 

If condition Then
[statements]

[ElseIf condition-n Then
[elseifstatements]] . . .

[Else
[elsestatements]]

End If
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For example, the statement below (as it appears in the Expert View) checks that 
the user name edit box exists in the Mercury Tours site. If the edit box exists, then 
a user name is entered; else a message is sent to test results.

Part of Statement Description

condition One or more expressions that evaluate to true or false. If the 
condition is null, it is treated as false.

statements One or more statements, separated by colons, that are 
executed if the condition is true.

condition-n Same as condition.

elseifstatements One or more statements, separated by colons, that are 
executed if the associated condition-n is true.

elsestatements One or more statements, separated by colons, that are 
executed if no previous condition-n expression is true.
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The same example is displayed in the Tree View as follows:

In the test tree, the following icons are used to indicate the different levels of 
If...Then...Else statements:

Icon Description

Starts an If statement.

Starts a Then statement.

Starts an Elseif statement.

Starts an Else statement.
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To add a conditional statement:

 1 In the Tree View, click a step in the test tree. 

 2 Choose Insert > Step > If...Then...Else > If...Then. The If Statement dialog box 
opens.

 3 Set the expression as a constant or a parameter. Note that the expression must 
be a Boolean expression.

• To set the expression as a constant, select Constant, and type the 
expression in the box. For example, type i>5.

• To set the expression as a parameter, select Parameter, and choose a 
parameter from the list or enter a new parameter. For example, type a>c for a 
formula in a table. For more information, see Chapter 6, Parameterizing 
Tests. 

• To add the parameter to the Global tab in the Data pane, select Global. To 
add the parameter to the Action tab, select Local. For more information, see 
Chapter 6, Parameterizing Tests. 
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 4 Click OK to close the dialog box.

 5 To complete the Then statement you can:

• Record a new step and then use the Cut/Paste commands to add it to your 
Then statement.

• Copy an existing step and paste it in your Then statement. 

• Click and drag a step to move it to your Then statement. 

 6 To nest an additional level to your statement, click the Then statement and 
choose one of the following options:

To complete the new statement you can:

• Record a new step and then use the Cut/Paste commands to add it to your 
statement.

• Copy an existing step and paste it in your statement. 

• Click and drag a step to move it to your statement. 

To add: Choose:

an If statement Insert > Step > If...Then...Else > If...Then

an Elseif statement Insert > Step > If...Then...Else > Elseif...Then

an Else statement Insert > Step > If...Then...Else > Else 
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Sending Messages to Your Test Results

You can define a message in your test that Astra QuickTest sends to your test 
results. For example, suppose your want to check that a password edit box exists 
in the Mercury Tours site. If the edit box exists, then a password is entered. 
Otherwise, Astra QuickTest sends a message to the test results indicating that the 
object is not found.

To send a message to your test results:

 1 In the test tree, click a step. A menu opens.

 2 Choose Insert > Step > Report. The Insert Report dialog box opens.
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 3 Select a status from the Status list.

 4 In the Name box, type a step name to associate with the message. For example, 
“Password edit box”.

 5 In the Details box, type a message to insert in your test results. For example, 
“Password edit box does not exist”.

 6 Click OK.

After your run the test, the  icon indicates in the Test Results window 
indicates the message sent. 

Status Description

Passed sends a message if the step passes

Failed sends a message if the step fails

General sends a message regardless of the status of the step
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Adding Comments

While programming, you can add comments to your tests. A comment is an 
explanatory remark in a program. When you run a test, Astra QuickTest does not 
process comments. Use comments to explain sections of a test in order to 
improve readability and to make tests easier to update.

To add a comment:

 1 In the test tree, click a step. A menu opens.

 2 Choose Insert > Step > Comment. The Insert Comment dialog box opens.

 3 Type a comment and click OK.

A comment statement is added to your test. If you are working in Tree View, the 
 icon indicates a comment. In the Expert View, a comment is specified as 

Rem.
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Testing in the Expert View

In Astra QuickTest, test scripts are composed of statements coded in Microsoft’s 
programming language, VBScript. This chapter provides a brief introduction to 
VBScript and shows you how to enhance your test scripts using a few simple 
programming techniques.

This chapter describes:

• Understanding the Expert View

• Programming in the Expert View

• Enhancing Tests with Comments, Calculations, and Control-Flow 
Statements
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About Testing in the Expert View

The Expert View provides an alternative to the Tree View for testers who are 
familiar with VBScript. In the Expert View, you can view the recorded test in 
VBScript and enhance it with programming. 

In the Expert View you can also add functions manually instead of from the 
Function wizard. For information on using the Function wizard, see Chapter 17, 
Enhancing Your Tests with Programming. 
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Understanding the Expert View

Astra QuickTest can display tests you record in two formats:

• the Tree View, where Astra QuickTest displays the object hierarchy in an icon-
based tree

• the Expert View, where Astra QuickTest displays the object hierarchy in VBScript

Note that in the diagram above, the object hierarchy is identical in both views.
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Each line of VBScript in the Expert View represents a step in the test. The 
example above represents a step in the test in which the user inserts the name 
“mercury” into an edit field. The hierarchy of the step enables you to see the name 
of the site, the name of the page, the name of the object in the page, and the name 
of the method performed on the object. When you record your test, Astra 
QuickTest records the operations you perform on your Web site in terms of the 
objects on the page. It identifies the objects on a Web page by specific names 
(e.g. a button or a list) and the function performed on the object (e.g. click or 
select).

To further understand how a step in the Expert View corresponds with a step in 
the Tree View, examine the table below:

Tree View Expert View Description

Browser (“Mercury Tours”) The name of the Web site is 
“Mercury Tours”.

Page (“Mercury Tours”) The name of the current 
page in the Web site is 
“Mercury Tours”.
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An object’s logical name appears in parentheses following the object type. In the 
following example, the object type is Browser, and the logical name of the 
Browser is “Mercury Tours”:

Browser ("Mercury Tours")

The object types in the object hierarchy are separated by a period. In the 
following example, Browser and Page are two separate objects:

Browser("Mercury Tours"). Page("Mercury Tours")

WebEdit(“username”) The name of the edit field 
upon which the action is 
performed is “username”.

Set “mercury” The name of the function 
performed on the edit box is 
“Set”. The name inserted 
into the edit box is 
“mercury”.

Tree View Expert View Description
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The function performed on the object always appears at the end of the line of 
script. In the following example, the word “mercury” is inserted in the “username” 
edit box using the Set function:

Browser("Mercury Tours").Page("Mercury Tours").WebEdit("username").Set
"mercury"

For a complete list of objects and their associated functions, choose Help > 
Astra QuickTest Function Reference to open the Astra QuickTest Function 
Reference.

Checkpoints
In Astra QuickTest, you create checkpoints on pages, text strings, objects, and 
tables. When you create a checkpoint in the Tree View, Astra QuickTest creates 
a corresponding line in VBScript in the Expert View. It uses the Check function to 
perform the checkpoint. 

For example, in the following statement Astra QuickTest performs a check on the 
word “confirmed”:

Browser("Mercury Tours").Page("Flight Confirmation").
Check Checkpoint("confirmed")

The corresponding step in the Tree View appears as follows:
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Note: You cannot insert checkpoints into your test while in the Expert View. Use 
the Tree View to insert and modify checkpoints. For more information on 
inserting and modifying checkpoints, see Chapter 4, Creating Checkpoints. 

Parameters
You can use Astra QuickTest to enhance your tests by parameterizing values in 
the test. A parameter is a variable that is assigned a value from outside the test 
in which it is defined. When you create a parameter in the Tree View, Astra 
QuickTest creates a corresponding line in VBScript in the Expert View.

Astra QuickTest calls the values of a parameterized object from the data table 
using the following syntax:

function_name DataTable ( parameterID, sheetID )

function_name The name of the function that Astra QuickTest executes 
on the parameterized object. 

DataTable The data table object.

parameterID The name of the column in the data table.

sheetID The name of the sheet. If the parameter is a global 
parameter, the word “global” appears. 
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Note: You cannot create parameters from the Expert View. Use the Tree View to 
create parameters. For more information on parameterization, see Chapter 6, 
Parameterizing Tests. 

For example, suppose you are creating a test on the Mercury Tours site, and you 
select “Paris” as your destination. The following statement is inserted into your 
test in the Expert View:

Browser("Mercury Tours").Page("Find Flights").WebList("depart").Select 
"Paris"

Now suppose you want to parameterize the destination, and you create a 
“Departure” column in the data table. The previous statement is modified to the 
following:

Browser("Mercury Tours").Page("Find Flights").WebList("depart").Select
DataTable("Departure",dtGlobalSheet)

where Select is the function name, DataTable is the object, Departure is the 
name of the column in the data table, and dtGlobalSheet is the name of the 
sheet in the data table.
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Programming in the Expert View

The Expert View displays in VBScript the steps you executed while recording your 
test. After you record your test, you can increase the power and flexibility of your 
test by adding recordable and non-recordable VBScript statements. You can add 
statements that perform operations on objects or retrieve information from your 
site. For example, you can add a step that checks that an object exists, or you can 
retrieve the return value of a function.

Most objects have corresponding functions. For example, the Back function is 
associated with the Browser object. Some functions are associated with more 
than one object. For example, the Click function may be used on the WebArea 
object as well as the WebButton object. 

The objects in Astra QuickTestare divided by environment.

Astra QuickTest environments include Web objects, DataTable objects and Utility 
objects.
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Functions Associated with Web Objects
The following table summarizes the web objects and the functions with which they 
are associated:

Object Description Functions

Browser the site AddCookie, Back, Check, Close, 
Exist, Forward, FullScreen, 
GetProperty, Highlight, Home, 
Init, Navigate, QueryValue, Set, 
SetProperty, Stop, Sync

Page the page Check, EndTransaction, Exist, 
GetProperty, Highlight, Init, 
QueryValue, SetProperty, 
StartTransaction, Sync

Image an image with or 
without a target URL

Check, Click, Exist, FireEvent, 
GetProperty, Highlight, Init, 
MouseOver, Output, QueryValue, 
SetProperty

Link a hypertext link Check, Click, Exist, FireEvent, 
GetProperty, Highlight, Init, 
MouseOver, Output, QueryValue, 
SetProperty 
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WebArea a client-side image 
map

Check, Click, Exist, FireEvent, 
GetProperty, Highlight, Init, 
MouseOver, QueryValue, 
SetProperty 

WebButton a button Check, Click, Exist, FireEvent, 
GetProperty, Highlight, Init, 
MouseOver, Output, QueryValue, 
SetProperty 

WebCheckBox a check box with 
"ON" and "OFF" 
states

Check, Click, Exist, FireEvent, 
GetProperty, Highlight, Init, 
MouseOver, QueryValue, Set, 
SetProperty

WebEdit an edit field Check, Click, Exist, FireEvent, 
GetProperty, Highlight, Init, 
MouseOver, QueryValue, Set, 
SetProperty, SetSecure, Submit 

WebFile an edit field with a 
“Browse” button 
attached

FireEvent, GetProperty, 
Highlight, QueryValue, Set, 
SetProperty

WebList a dropdown or multi-
selection list

Check, Click, DeSelect, Exist, 
ExtendSelect, FireEvent, 
GetProperty, Highlight, Init, 
MouseOver, QueryValue, Select, 
Set, SetProperty

Object Description Functions
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In the following example, the user inserts “mercury” in the User Name edit box 
while recording. The following line is recorded in the Expert View:

Browser ("Mercury_Tours"). Page ("Mercury_Tours"). WebEdit ("username").
Set"Mercury"

Browser object Mercury_Tours

Page object Mercury_Tours

WebEdit object (edit box) username

WebRadioGroup a radio button Check, Click, Exist, FireEvent, 
GetProperty, Highlight, Init, 
MouseOver, Output, QueryValue, 
Select, Set, SetProperty

WebTable a table CellText, CellTextByContext, 
Check, ChildItem, 
ChildItemCount, Click, 
ColumnCount, Exist, FireEvent, 
GetProperty, Highlight, Init, 
MouseOver, Output, QueryValue, 
RowCount, RowText, 
RowTextByContext, SetProperty, 
TextCellExist, TextRowExist

Object Description Functions
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The Set function sets the “Mercury” text into the WebEdit object.

In the following example, the user selects “Paris” from the Departure City drop-
down list while recording. The following line is recorded in the Expert View:

Browser("Mercury Tours").Page("Find Flights").WebList("depart").Select 
"Paris"

Browser object Mercury Tours

Page object Find Flights

WebList object (drop-down list) depart

The Select function selects Paris in the WebList object.

Note: For the syntax for Astra functions, refer to the Astra QuickTest Function 
Reference. To open this, choose Help > Astra QuickTest Function Reference.
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Functions Associated with DataTable Objects
The following table summarizes the DataTable objects and the properties and 
functions with which they are associated:

Object Description Functions

DataTable a data table GetSheetCount, GetSheet, 
GlobalSheet, LocalSheet, 
AddSheet, DeleteSheet, 
GetRowCount, GetCurrentRow, 
SetCurrentRow, SetNextRow, 
SetPrevRow, Import, Export, 
Value, RawValue

Sheet a sheet in the data 
table

GetParameterCount, 
GetParameter, AddParameter, 
DeleteParameter, GetRowCount, 
GetCurrentRow, SetCurrentRow, 
SetNextRow, SetPrevRow, Name

Parameter a parameter 
(column) in the sheet 
of a data table

Value, RawValue, ValueByRow
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Functions Associated with Utility Objects
The following table summarizes the Utility objects and the properties and 
functions with which they are associated:

Object Description Functions

Crypt The object used to encrypt 
strings.

Encrypt

OptionalStep object that causes the step 
to which it is attached to be 
bypassed, if the object 
referred to in the step 
cannot be found. A 
bypassed step is an optional 
step.

N/A

Reporter the object used to send 
information to the test report

ReportEvent
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Functions Not Associated with Objects
In addition to the functions discussed above, there are functions that can be 
inserted into the test script that are not associated with any object.

Setting the object used to modify 
test settings during the test 
run.

Add, 
AutomaticLinkCheck, 
CheckBrokenLinks, 
CheckHtmlContent, 
CheckHtmlTag, 
CheckImagesSource, 
CheckLinksUrl, 
CheckLoadtime, 
CheckNumberOfImages, 
CheckNumberOfLinks, 
DefaultLoadTime, 
DefaultTimeOut, 
LocalLinks, Remove, 
WebTimeOut

WebPackage the object used to modify 
test settings specific to Web 
objects during the test run.

ReplayType

Object Description Functions
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Adding a Pause During a Test Run

In the following example, the user records a test on the Mercury Tours sample 
site, which selects an arrival city and a departure city. The following statements 
are recorded in the Expert View:

Browser("Mercury Tours").Page("Find Flights").WebList("depart").
Select"New York"

Browser("Mercury Tours").Page("Find Flights").WebList("arrive").Select 
"Paris"

In order to instruct Astra QuickTest to pause between these two steps, the user 
inserts the Wait function between the steps. The Wait function has the following 
syntax:

Wait (seconds)

In order to pause the test for 10 seconds, the user inserts 10 as the value for the 
seconds argument. The script now appears as follows:

Browser("Mercury Tours").Page("Find Flights").WebList("depart").
Select "New York"

wait(10)
Browser("Mercury Tours").Page("Find Flights").WebList("arrive").Select 
"Paris"
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When the test runs, Astra QuickTest pauses for 10 seconds between selecting 
the departure city and the arrival city.

Setting the Run Mode

By default, Astra QuickTest runs the test by events. If it is necessary to run the 
test, or part of the test, directly by mouse operations, you can change this setting 
in the test script from the Expert view with the WebPackage ("ReplayType") 
function.

To set the test to run by mouse operations, enter:

Setting.WebPackage("ReplayType") = 2 

To return to the event run mode, enter:

Setting.WebPackage("ReplayType") = 1 
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Generating a Function for an Object
In the Expert View you can generate functions. You can also generate functions 
in the Tree View using the Function wizard. For additional information, see 
Chapter 17, Enhancing Your Tests with Programming. 

By default, Astra QuickTest  displays the syntax for functions as you type. You can 
disable or enable this Statement Completion option in the Editor Options dialog 
box. For additional information, see Chapter 20, Customizing the Test Script 
Editor. 

To generate a function in the Expert View:

 1 In the Expert View, type a period after the object upon which you want to perform 
the function.
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 2 A list of the available functions for the object is displayed.

Double-click a function in the list. Astra QuickTest inserts the function into the 
line of script.

 3 If the function contains arguments, and the Statement Completion option is 
enabled, Astra QuickTest  displays the syntax of the function. 

In the above example, the Set function has one argument, called Text. The 
argument name represents the text to enter in the edit box.
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 4 Insert an argument after the function. 

Note: To find the syntax for a function, you can also refer to the Astra QuickTest 
Function Reference. 
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Enhancing Tests with Comments, Calculations, and 
Control-Flow Statements

Astra QuickTest enables you to incorporate decision-making into your test by 
adding conditional statements that control the logical flow of your test. In addition, 
you can define messages in your test that Astra QuickTest sends to your test 
results. To improve the readability of your tests, you can also add comments to 
your test.

For information on how to use these programming concepts in the Tree View, see 
Chapter 17, Enhancing Your Tests with Programming. 

Comments
A comment is a line or part of a line in a test script that is preceded by an 
apostrophe (‘). When you run a test, Astra QuickTest does not process comments. 
Use comments to explain sections of a test script in order to improve readability 
and to make tests easier to update. Comments are displayed in the color green. 
For example:

Browser("Mercury Tours").Page("Mercury Tours").WebEdit("username").
Set "mercury"

‘Sets the word “mercury” into the “password” edit field.



Advanced Features • Testing in the Expert View

Astra QuickTest User’s Guide Chapter 18, page 310

In

Back

Find

Find

Chapter
Top of

 Again

Note: You can also add a comment line using VBScript’s Rem function. For 
additional information, refer to the VBScript Reference.

Performing Calculations
You can create tests that perform simple calculations using mathematical 
operators. For example, you can use a multiplication operator to multiply the 
values displayed in two text boxes in your site. VBScript supports the following 
mathematical operators:

+ addition

- subtraction

- negation (a negative number - unary
operator)

* multiplication

/ division

^ exponent
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In the following example, the multiplication operator is used to calculate the total 
luggage weight of the passengers at 100 pounds each.

passenger = Browser ("Mercury_Tours"). Page ("Find_Flights").
WebEdit("numPassengers"). QueryValue("value")

‘Retrieves the number of passengers from the edit box using the QueryValue
function

weight = passenger * 100

‘Multiplies the number of passengers by 100

msgbox("The maximum weight for the party is "& weight &"pounds.")

‘Inserts the maximum weight into a message box.
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For...Next Statement
A For...Next loop instructs Astra QuickTest to execute one or more statements a 
specified number of times. It has the following syntax:

for counter = start to end [Step step]
statement

Next

counter variable used as a counter

start the start number of the counter

end the last number of the counter

step number to increment at the end of each loop. The default 
is 1.

statement statement to be executed during the loop

In the following example, Astra QuickTest  queries the value of the 
“numpassengers” edit field using the QueryValue function. Astra QuickTest 
executes a loop ten times using the For statement. Each time the loop runs, 
Astra QuickTest increments the number of passengers by one.

passengers = Browser("Mercury Tours").Page("Find Flights").
WebEdit("numpassengers").QueryValue("value")

For i = 1 to 10
passengers = passengers + 1

Next
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For...Each Statement
A For...Each loop instructs Astra QuickTest to execute one or more statements 
for each element in an array. It has the following syntax:

For Each item In array
statement

Next

item a variable representing the element in the array

array the name of the array

statement a statement or series of statements to be executed during 
the loop

Do...Loop Statement
The Do...Loop statement instructs Astra QuickTest to execute a statement or 
series of statements while a condition is true or until a condition becomes true. It 
has the following syntax:

Do [{while}{until}condition]
statement

Loop

condition a condition to be fulfilled

statement a statement or series of statements to be executed during 
the loop
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In the following example, Astra QuickTest performs a loop until the number of 
passengers is more than four. Within each loop, Astra QuickTest increments the 
number by one.

passengers = Browser("Mercury Tours").Page("Find Flights").
WebEdit("numpassengers").QueryValue("value")

do until passengers > 4
passengers = passengers + 1

While Statement
A While statement instructs Astra QuickTestto execute a statement or series of 
statements while a condition is true. It has the following syntax:

While condition
statement

Wend

In the following example, Astra QuickTest performs a loop using the While 
statement while the number of passengers is fewer than four. Within each loop, 
Astra QuickTest increments the number by one.

passengers = Browser("Mercury Tours").Page("Find Flights").
WebEdit("numpassengers").QueryValue("value")

while passengers < 4
passengers = passengers + 1

wend
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If...Then...Else Statement
The If...Then...Else statement instructs Astra QuickTest to execute a statement 
or a series of statements based on specified conditions. If a condition is not 
fulfilled, the next elseif or else statement is examined. It has the following syntax:

If condition Then
statement

ElseIf
statement

Else
statement

EndIf

condition condition to be fulfilled

statement statement to be executed
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In the following example, if the number of passengers is fewer than four, Astra 
QuickTest closes the browser.

passengers = Browser("Mercury Tours").Page("Find Flights").
WebEdit("numpassengers").QueryValue("value")

if (passengers < 4) then
Browser("Mercury Tours").close

Else
Browser("Mercury Tours").Page("Find Flights").Image("continue").Click 

69,5
End If

The Dim Statement
The Dim statement is used to declared variables of all types, including strings, 
integers, and arrays. Use the Dim statement at the beginning of the procedure. It 
has the following syntax:

Dim variable [(subscript)]

variable the name of the variable

subscript the dimensions of the array
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In the following example, the Dim statement is used to declare the “passengers” 
variable.

Dim passengers
passengers = Browser("Mercury Tours").Page("Find Flights").

WebEdit("numpassengers").QueryValue("value")

Note: Astra QuickTest includes Microsoft’s VBScript Language Reference. The 
VBScript Language reference describes VBScript in detail. To open this 
reference, choose Help > VBScript Reference.
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Working with Astra QuickTest—for Power Users

This chapter answers some of the questions that are asked most frequently by 
advanced users of Astra QuickTest. The questions and answers are divided into 
the following sections:

• Recording and Running Tests

• Working with Dynamic Web Content

• Advanced Web Issues

• Test Maintenance
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Recording and Running Tests

• How does Astra QuickTest capture user processes?

Astra QuickTest hooks the browser (Netscape or Microsoft Internet Explorer). As 
the user navigates the Web site, Astra QuickTest intercepts and records all steps 
as they enter the browser. Astra QuickTest can then run the test by running the 
steps as they originally occurred.

• How does Astra QuickTest record and identify objects on Web pages? 

Astra QuickTest can record all Web objects on a Web page. Each HTML tag is 
considered a Web object. Astra QuickTest identifies each object by its HTML tag 
and logical name and stores these descriptions of each object in the memory.
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Working with Dynamic Web Content

• How can I record and run tests on objects that change dynamically from 
viewing to viewing?

Sometimes the content of objects in a Web page changes due to dynamic 
content. You can create dynamic descriptions of these objects so that Astra 
QuickTest will recognize them when it runs the test. For more information, see 
Chapter 12, Understanding How Astra QuickTest Identifies Objects. 

• How can I check that a spawned window exists (or does not exist)?

Sometimes a link in one window spawns another window. Use the Exist function 
to check whether or not a spawned window exists. For example:

Brower("Window_logical_name").Exist

For additional information about the Exist function, refer to the Astra QuickTest 
Function Reference.
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• How does Astra QuickTest record on dynamically generated URLs and 
Web pages?

Astra QuickTest actually clicks on links as they appear on the page. Therefore, 
Astra QuickTest records how to find a particular object, such as a link on the page, 
rather than the object itself. For example, if the link to a dynamically generated 
URL is an image, then Astra QuickTest records the “IMG” HTML tag, and the 
name of the image. This enables Astra QuickTest to find this image in the future 
and click on it. 
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Advanced Web Issues

• How does Astra QuickTest handle cookies? 

Server side connections, such as CGI scripts, can use cookies both to store and 
retrieve information on the client side of the connection. 

Astra QuickTest stores cookies in the memory for each user, and the browser 
handles them as it normally would.

• How does Astra QuickTest handle session IDs? 

The server, not the browser, handles session IDs, usually by a cookie or by 
embedding the session ID in all links. This does not affect Astra QuickTest. 

• How does Astra QuickTest handle server redirections? 

When the server redirects the client, the client generally does not notice the 
redirection, and misdirections generally do not occur. In most cases, the client is 
redirected to another script on the server. This additional script produces the 
HTML code for the subsequent page to be viewed. This has no effect on Astra 
QuickTest or the browser.
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• How does Astra QuickTest handle meta tags? 

Meta tags do not affect how the page is displayed. Generally, they contain 
information only about who created the page, how often it is updated, what 
the page is about, and which keywords represent the page’s content. 
Therefore, Astra QuickTest has no problem handling meta tags. 

• Does Astra QuickTest work with .asp?

Dynamically created Web pages that utilize ActiveX scripting have an .asp 
extension (Active Server Pages). This technology is completely server-side and 
has no bearing on Astra QuickTest. 

• Does Astra QuickTest work with COM?

Astra QuickTest complies with the COM standard. 

Astra QuickTest supports COM objects embedded in Web pages (which are 
currently accessible only using Microsoft Internet Explorer).

• Does Astra QuickTest work with XML?

XML is eXtensible Markup Language, a pared-down version of SGML for Web 
documents, that enables Web designers to create their own customized tags.

Astra QuickTest supports XML and recognizes XML tags as objects. Note that 
XML is not currently completely supported by Microsoft Internet Explorer and 
Netscape.



Advanced Features • Working with Astra QuickTest—for Power Users

Astra QuickTest User’s Guide Chapter 19, page 324

In

Back

Find

Find

Chapter
Top of

 Again

Test Maintenance

• How do I maintain my test when my application changes?

The way to maintain a test when your application changes depends on how much 
your application changes. This is one of the main reasons you should create a 
small group of tests rather than one large test for your entire application. When 
your application changes, you can rerecord part of a test. If the change is not 
significant, you can manually edit a test to update it.

You can also use Astra QuickTest’s action feature to design more modular and 
efficient tests. While recording, you divide your test into several actions, based on 
functionality. When your application changes, you can rerecord an action, without 
changing the rest of the test. For additional information, see Chapter 10, Working 
with Actions. 
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Part V

Configuring Astra QuickTest
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Customizing the Test Script Editor

Astra QuickTest includes a powerful and customizable script editor. This enables 
you to set the size of margins in test windows, change the way the elements of a 
test script appear, and create a list of typing errors that will be automatically 
corrected by Astra QuickTest.

This chapter describes:

• Setting Display Options

• Personalizing Editing Commands
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About Customizing the Test Script Editor

Astra QuickTest’s script editor lets you set display options, and personalize script 
editing commands.

Setting Display Options
Display options let you configure Astra QuickTest’s test windows and how your 
test scripts will be displayed. For example, you can set the size of test window 
margins, and activate or deactivate word wrapping.

Display options also let you change the color and appearance of different script 
elements. These include comments, strings, Astra QuickTest reserved words, 
operators and numbers. For each script element, you can assign colors, text 
attributes (bold, italic, underline), font, and font size. For example, you could 
display all strings in the color red.

Finally, there are display options that let you control how the hard copy of your 
scripts will appear when printed.
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Personalizing Script Editing Commands
Astra QuickTest includes a list of default keyboard commands that let you move 
the cursor, delete characters, cut, copy, and paste information to and from the 
clipboard. You can replace these commands with commands you prefer. For 
example, you could change the Set Bookmark [#] command from the default 
CTRL + K + [#] to CTRL + B + [#].
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Setting Display Options

Astra QuickTest’s display options let you control how test scripts appear in test 
windows, how different elements of test scripts are displayed, and how test scripts 
will appear when they are printed.

Customizing Test Scripts and Windows
You can customize the appearance of Astra QuickTest’s test windows and how 
your scripts are displayed. For example, you can set the size of the test window 
margins, highlight script elements, and show or hide text symbols.
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To customize the appearance of your script:

 1 In the Expert View, choose Tools > Editor Options. The Editor Options dialog 
box opens.

 2 Click the Options tab.
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 3 Under the General options choose from the following options:

Options Description

Auto indent Causes lines following an indented line to 
automatically begin at the same point as the previous 
line. You can click the Home key on your keyboard to 
move the cursor back to the left margin.

Smart tab A single press of the tab key will insert the appropriate 
number of tabs and spaces in order to align the cursor 
with the text in the line above.

Smart fill Insert the appropriate number of tabs and spaces in 
order to apply the Auto indent option. When this option 
is not selected, only spaces are used to apply the Auto 
indent.
(Both Auto indent and Use tab character must be 
selected to apply this option).

Use tab character Inserts a tab character when the tab key on the 
keyboard is used. When this option is not enabled, the 
appropriate number of space characters will be 
inserted instead.

Line numbers in gutter Displays a line number next to each line in the script. 
The line number is displayed in the test script 
window’s gutter.
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Statement completion Opens a list box displaying all available matches to 
the function prefix whenever the user presses the Ctrl 
and Space keys simultaneously, the Underscore key, 
or chooses Edit > Complete Word. Select an item 
from the list to replace the typed string. To close the 
list box, press the Esc key.
Displays a tooltip with the function parameters once 
the complete function name appears in the editor. The 
function parameters are displayed also whenever the 
user presses the Ctrl, Shift, and Space keys 
simultaneously or choose Edit > Parameter Info.

Show all chars Displays all text symbols, such as tabs and paragraph 
symbols.

Block cursor for 
Overwrite

Displays a block cursor instead of the standard cursor 
when you select overwrite mode.

Word select Selects the nearest word when you double-click on 
the test window.

Syntax highlight Highlights script elements such as comments, strings, 
or reserved words.

Cursor beyond EOL Enables Astra QuickTest to display the cursor after the 
end of the current line.

Visible right margin Displays a line that indicates the test window’s right 
margin. 

Options Description
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Highlighting Script Elements
Astra QuickTest scripts contain many different elements, such as comments, 
strings, Astra QuickTest reserved words, operators and numbers. Each element 
of a Astra QuickTest script is displayed in a different color and style. You can 
create your own personalized color scheme and style for each script element. For 
example, all comments in your scripts could be displayed as italicized, blue letters 
on a yellow background.

Right margin Sets the position, in characters, of the test window’s 
right margin (0=left window edge).

Visible gutter Displays a blank area (gutter) in the test window’s left 
margin.

Gutter width Sets the width, in pixels, of the gutter.

Block indent step size Sets the number characters that the selected block of 
TSL statements will be moved (indented) when the 
INDENT SELECTED BLOCK softkey is used. For more 
information on editor softkeys, see Personalizing 
Editing Commands on page 339.

Tab stop Sets the distance, in characters, between each tab 
stop.

Options Description
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To edit script elements:

 1 In the Expert View, choose Tools > Editor Options. The Editor Options dialog 
box opens to the Highlighting tab.

 2 Select a script element from the Elements list.
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 3 Choose from the following options: 

An example of each change you apply will be displayed in the pane at the bottom 
of the dialog box.

 4 Click OK to apply the changes.

Options Description

Foreground Sets the color applied to the text of the script element.

Background Sets the color that appears behind the script element.

Text Attributes Sets the text attributes applied to the script element. 
You can select bold, italic, or underline or a 
combination of these attributes.

Use defaults for Applies the font and colors of the “default” style to the 
selected style.

Font Sets the typeface of the script element.

Size Set the size, in points, of the script element.

Charset Sets the character subset of the selected font.
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Customizing Print Options
You can set how the hard copy of your script will appear when it is sent to the 
printer. For example, your printed script can include line numbers, the name of the 
file, and the date it was printed.

To customize your print options:

 1 In the Expert View, choose Tools > Editor Options. The Editor Options dialog 
box opens.
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 2 Click the Options tab.
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 3 Choose from the following Print options:

 4 Click OK to apply the changes.

Option Description

Wrap long lines Automatically wraps a line of text to the next line if it is 
wider than the current printer page settings.

Line numbers Prints a line number next to each line in the script.

File name in header Inserts the file name into the header of the printed 
script.

Date in header Inserts today’s date into the header of the printed 
script.

Page numbers Numbers each page of the script.
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Personalizing Editing Commands

You can personalize the default keyboard commands you use for editing test 
scripts. Astra QuickTest includes keyboard commands that let you move the 
cursor, delete characters, cut, copy, and paste information to and from the 
clipboard. You can replace these commands with your own preferred commands. 
For example, you could change the Paste command from the default CTRL + V 
to CTRL + P.

To personalize editing commands:

 1 In the Expert View, choose Tools > Editor Options. The Editor Options dialog 
box opens.



Configuring Astra QuickTest • Customizing the Test Script Editor

Astra QuickTest User’s Guide Chapter 20, page 340

In

Back

Find

Find

Chapter
Top of

 Again

 2 Click the Key Assignments tab.

 3 Select a command from the Commands list.
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 4 Click Add to create an additional key assignment or click Edit to modify the 
existing assignment. The Add/Edit key pair for dialog box opens. Press the keys 
you want to use. For example, CTRL + 4. 

 5 Click Next. To add an additional key sequence, press the keys you want to use. 
For example, U.
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 6 Click Finish to add the key sequence(s) to the Use keys list.

If you want to delete a key sequence from the list, highlight the keys in the Uses 
Key list and click Delete.

 7 Click OK to apply the changes.
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Setting Astra QuickTest Testing Options

You can control how Astra QuickTest records and runs tests by setting testing 
options.

This chapter describes:

• Setting Astra QuickTest Testing Options

• Astra QuickTest Testing Options



Configuring Astra QuickTest • Setting Astra QuickTest Testing Options

Astra QuickTest User’s Guide Chapter 21, page 344

In

Back

Find

Find

Chapter
Top of

 Again

About Setting Astra QuickTest Options

Astra QuickTest testing options affect how you record and run tests. For example, 
you can set the speed at which Astra QuickTest runs a test, or set the timing-
related settings used by Astra QuickTest. The values you set remain in effect for 
all tests and for subsequent testing sessions.

You can also set testing options for that effect only the test currently open in Astra 
QuickTest. For more information, see Chapter 22, Setting Testing Options for a 
Single Test. 
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Setting Astra QuickTest Testing Options

Before you record or run a test, you can use the Options dialog box to modify your 
testing options. The values you set remain in effect for all tests.

To set Astra QuickTest testing options:

 1 Choose Tools > Options. 

The Options dialog box opens. It is divided by subject into three tabbed pages.
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 2 To choose a page, click a tab.

 3 Set an option, as described in Astra QuickTest Testing Options on page 347.

 4 To apply your changes and keep the Options dialog box open, click Apply.

 5 When you are done, click OK to apply your changes and close the dialog box.
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Astra QuickTest Testing Options

The Test Settings dialog box contains the following tabbed pages:

This section lists the testing options you can set using the Options dialog box.

Tab Heading Subject

General options for run mode and global settings

Active Screen options for displaying Web pages in the ActiveScreen 
tab in the Display pane

Page Verification options for adding automatic checkpoints
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General Testing Options
The General tab options affect how Astra QuickTest runs tests, displays test 
results, and specifies the Web server for reporting defects.
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The General tab includes the following options:

Option Description

Run mode - Slow 
(with cursor)

Instructs Astra QuickTest to run your test with the 
execution arrow in the left margin of the test, marking 
each step or statement as it is interpreted.

Run mode - Fast (without 
cursor) 

Instructs Astra QuickTest to run your test without the 
execution arrow in the left margin of the test, marking 
each step or statement as it is interpreted.

View results when test 
run ends

Instructs Astra QuickTest to display the test results 
automatically following the test run.

On run error Determines how Astra QuickTest responds to an error 
during a test run. 
Choose an option from the list:
pop up message box displays an error message 
dialog box when an error occurs.
proceed to next iteration jumps to the next iteration 
when an error occurs.
stop run stops the test run when an error occurs.

TestDirector Web server Designates the HTTP address to use to report and 
maintain defects in the Web Defect Manager. For 
example, if the TestDirector Web Defect Manager 
server is accessed using the 
http://testdirector.mycompany.com/defects/bugs.htm 
page, then the HTTP address should be specified as 
http://testdirector.mycompany.com/defects/.
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Activate pointed window 
after

Specifies the time (in tenths of a second) that Astra 
QuickTest waits before it sets focus on the Web 
browser.

Show welcome screen on 
start

Determines whether the Welcome screen is displayed 
when starting Astra QuickTest.

Option Description
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Active Screen Testing Options
The Active Screen tab options affect how Astra QuickTest displays Web pages in 
the ActiveScreen view in the Display pane.
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The Active Screen tab includes the following options:

Option Description

Load images Instructs Astra QuickTest to load images from your 
browser page to the ActiveScreen pane.

Load Java applets Instructs Astra QuickTest to load Java applets from 
your browser page to the ActiveScreen pane.

Load ActiveX controls Instructs Astra QuickTest to load ActiveX controls from 
your browser page to the ActiveScreen pane.

Run scripts Instructs Astra QuickTest to run scripts while loading 
your browser page on the ActiveScreen pane.
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Page Verification Options
The Page Verification tab options affect how Astra QuickTest performs automatic 
checkpoints on a Web page.

If you are testing a page with dynamic content, you should probably not change 
the default settings for automatic checkpoints. 
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The Page Verification tab includes the following options:

Option Description

Add automatic checks for 
each page during record 

Instructs Astra QuickTest to add a page checkpoint for 
each page navigated to in your site. 

Number of links Checks that the number of links which appeared 
during the record session and the run session are 
identical.

Links URL Checks that the URL links which appear during the 
record session and the run session are identical.

HTML content Checks that the source code which appears during the 
record session and the run session are identical.

Load time Checks that the amount of time it takes for the page to 
load during the record session and the run session are 
identical.

Number of images Checks that the number of images which appear 
during the record session and the run session are 
identical.

Image source Checks that the source files of the images which 
appear during the record session and the run session 
are identical.

HTML tag Checks that the HTML tags which appear in the 
source code during the record session and the run 
session are identical.
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Broken links Displays the number of broken links which appear 
during the run session.

Don’t perform automatic 
checks during test run

Instructs Astra QuickTest to ignore the automatically 
added page checkpoints when running your test.

Add to load time Instructs Astra QuickTest to add a specified number of 
seconds to the load time of the page. This option is a 
safeguard which prevents the test from failing in the 
event that the amount of time it takes for a page to 
load during the run session is higher than the amount 
of time it took during the record session.

Broken links - Check only 
links going to current 
host

Instructs Astra QuickTest to check for broken links that 
are targeted to your current host.

Option Description
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Setting Testing Options for a Single Test

You can control how Astra QuickTest records and runs specific tests by setting 
testing options.

This chapter describes:

• Setting Testing Options for a Single Test

• Testing Options for a Single Test

About Setting Testing Options for a Single Test

You can set testing options that affect how you record and run a specific test. For 
example, you can instruct Astra QuickTest to run a parameterized action for only 
certain lines in the table in the Data pane. You can also teach Astra QuickTest to 
recognize a specific object in your test as a standard object. These testing options 
are saved when you save the test.

You can also set testing options from within a test, for part of the test. For more 
information, see Chapter 23, Setting Testing Options from a Test Script. 

You can also set testing options that affect all tests. For more information, see 
Chapter 21, Setting Astra QuickTest Testing Options. 
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Setting Testing Options for a Single Test

Before you record or run a test, you can use the Test Settings dialog box to modify 
your testing options.

To set testing options for a single test:

 1 Choose Test > Settings. 

The Test Settings dialog box opens. It is divided by subject into five tabbed 
pages. 
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 2 To choose a page, click a tab.

 3 Set an option, as described in Testing Options for a Single Test on page 359.

 4 To apply your changes and keep the Test Settings dialog box open, click Apply.

 5 When you are done, click OK to apply your changes and close the dialog box.
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Testing Options for a Single Test

The Test Settings dialog box contains the following tabbed pages:

This section lists the testing options you can set using the Test Settings dialog 
box.

Tab Heading Subject

StartUp options for setting a Web browser for recording tests

Run options for setting test runs for tests and actions

Properties options for setting the properties of tests

Web options for recording tests

ActiveScreen options for controlling the behavior of Web pages in the 
ActiveScreen
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StartUp Testing Options
The StartUp tab options set which Web browser to use while recording and 
whether to use an existing Web browser window or to open a new browser 
window to a specified location. 
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The StartUp tab includes the following options:

Note: You can also set the Use existing Web browser window and Open new 
Web browser window at the following URL options for a specific test in the 
Start Recording dialog box, which opens when you start recording a new test.

Option Description

Use existing Web 
browser window 

Instructs Astra QuickTest to use your existing browser 
window to record a test.

Open new Web 
browser window at the 
following URL

Instructs Astra QuickTest to open a new browser session 
to record a test using the specified Web location address.

Choose browser Instructs Astra QuickTest to use the specified browser 
type to record a browser session.
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Run Testing Options
When you run a test, Astra QuickTest performs the steps you recorded on your 
Web site. When you run a test with global parameters, Astra QuickTest runs the 
test for each row in the table in the Data pane, using the parameters you specified. 
If your test includes local parameters, you can choose to run a range of data sets. 
For more information on global and local parameters, see Chapter 8, Working 
with Data Tables. 

You can use the Run tab to instruct Astra QuickTest to parameterize a test or an 
action for only certain lines in the local tab in the Data pane. 
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The Run tab includes the following options:

Option Description

Do not run iterations Runs the test or action (depending on which is 
highlighted) only once, using only the constant value. 

Run all iterations in 
data table

Runs the test or action (depending on which is 
highlighted) using all the values in the local data table 
(for an action) or in the global data table (for a test).

Run for specified 
iterations in data table

Runs the test or action (depending on which is 
highlighted) using the values in the local data table (for 
an action) or in the global data table (for a test) for the 
specified range. Use Start from row to indicate the row 
number to start the run. Use Run to row to indicate the 
row number to end the run. 
Note: If you specify this option for an action, your action 
must begin and end within the same frame, so that it 
"cleans up after itself." Otherwise, problems will occur 
during the test run.
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Properties Testing Options
The Properties tab option defines general test information.
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The Properties tab includes the following options:

Option Description

Name Indicates the name of the test.

Location Indicates the path of the test.

Owner Indicates the user name.

Description Indicates the test description.

Default Location Instructs Astra QuickTest to use data stored in the default 
data table location.

Other Location Instructs Astra QuickTest to use data stored in a user 
defined data table location.
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Web Testing Options
The Web tab options affect the recording in Astra QuickTest.  
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The Web tab includes the following options:

Option Description

Navigation timeout Indicates the interval (in seconds) Astra QuickTest waits 
for the Web page to load before running a test step.

Change the default 
navigation timeout

Changes the default Navigation timeout globally.

Object timeout Indicates the interval (in seconds) Astra QuickTest waits 
to determine that the Web object is stable before running 
a test step.

Change the default 
timeout

Changes the default Object timeout globally.

Continue to the 
following page if an 
object isn’t found 
during the test run

Instructs Astra QuickTest to submit the original HTTP 
request instead of performing the specified action on an 
object, when that step fails. 
Suppose clicking an image in a Web page submits an 
HTTP request. If Astra QuickTest cannot find the 
specified image in the page, it submits the original HTTP 
request instead of stopping the test run. 
The advantage of this option is that the test continues to 
run; the disadvantage is that the action performed may 
not be the desired action. Note that when Astra 
QuickTest submits the original HTTP request because 
performing an action on an object fails, it automatically 
sends a message to the test results.
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ActiveScreen Testing Options
The ActiveScreen options enable you to control the behavior of the pages in the 
ActiveScreen while you modify your test. The Enter Network Password section 
enables you to enter a User name and password for the test. If an ActiveScreen 
page requires a User name and password, it will take them from this entry rather 
than requiring you to enter them each time you want to access that Active Screen 
page.
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The ActiveScreen tab includes the following options:

Option Description

User name The User name for the password protected page(s) in 
your test.

Password The Password for the password protected page(s) in 
your test.
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Setting Testing Options from a Test Script

You can control how Astra QuickTest records and runs tests by setting and 
retrieving testing options from within a test script.

This chapter describes:

• Setting Testing Options

• Retrieving Testing Options

• Controlling the Test Run

• Adding and Removing Run-Time Settings

• Test Script Testing Options
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About Setting Testing Options from a Test Script

Astra QuickTest testing options affect how you record test scripts and run tests. 
For example, you can set the maximum time that Astra QuickTestallows for 
finding an object in a page. 

You can set and retrieve the values of testing options from within a test script 
using the Setting Object function in the Expert View. For more information on 
Programming in the Expert View, see Chapter 18, Testing in the Expert View. 

By retrieving and setting testing options in a test script using the Setting Object, 
you can control how Astra QuickTest executes a test. 

You can also set many testing options using the Options dialog box (global testing 
options) and the Test Settings dialog box (test-specific settings). For more 
information on setting global testing options using the Options dialog box, see 
Chapter 21, Setting Astra QuickTest Testing Options.  For more information on 
setting options for a single test, see Chapter 22, Setting Testing Options for a 
Single Test. 
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Setting Testing Options 

You can use the Setting Object to set the value of a testing option from within the 
test script. To set the option, use the following syntax:

Setting ( testing_option ) = new_value

In this function, testing_option may specify any one of the following: 

Testing Option Possible Values Setting Type

AutomaticLinkCheck 1 (ON)
0 (OFF)

Global

CheckBrokenLinks 1 (ON)
0 (OFF)

Global

CheckHtmlContent 1 (ON)
0 (OFF)

Global

CheckHtmlTag 1 (ON)
0 (OFF)

Global

CheckImagesSource 1 (ON)
0 (OFF)

Global

CheckLinksUrl 1 (ON)
0 (OFF)

Global
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For example, if you execute the following statement:

Setting("AutomaticLinkCheck")=0

Astra QuickTest disables the Add automatic checks for each page during 
record testing option. The setting remains in effect during the testing session 
until it is changed again, either with another Setting statement or from the 
corresponding Add automatic checks for each page during record check box 
in the Page Verification tab of the Options dialog box (Tools > Options).

CheckLoadtime 1 (ON)
0 (OFF)

Global

CheckNumberOfImages 1 (ON)
0 (OFF)

Global

CheckNumberOfLinks 1 (ON)
0 (OFF)

Global

DefaultLoadTime 0-9999 Global

DefaultTimeOut 1-1000 Test-specific

LocalLinks 1 (ON)
0 (OFF)

Global

WebTimeOut 1-1000 Test-specific

Testing Option Possible Values Setting Type
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Using the Setting object with a global testing option changes a testing option 
globally, and this change is reflected in the Options dialog box. You can also use 
the Setting object to set testing options for a specific test, or even for part of a 
specific test. For more information see Controlling the Test Run on page 376.
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Retrieving Testing Options

You can also use the Setting object to retrieve the current value of a testing 
option. To retrieve the value of a testing option, use the following syntax:

Setting ( testing_option )

To store the value in a variable, use the syntax:

new_var = Setting ( testing_option )

To display the value in a message box, use the syntax:

MsgBox ( Setting ( testing_option ) ) 

In this function, testing_option may specify any of the setting values listed in the 
table on page 372.

For example:

LinkCheckSet = Setting("AutomaticLinkCheck")

assigns the current value of the AutomaticLinkCheck setting to the user-
defined variable LinkCheckSet.
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Controlling the Test Run

You can use the retrieve and set capabilities of the Setting object together to 
control a test run without changing global settings. For example, if you want to 
change the DefaultTimeOut testing option to 5 seconds for objects on one Web 
page only, insert the following statement after the Web page opens in your test 
script:

Rem Keep the original value of the DefaultTimeOut testing option
old_delay = Setting ("DefaultTimeOut") 

Rem Set temporary value for the DefaultTimeOut testing option
Setting("DefaultTimeOut")= 5

To change back the DefaultTimeOut testing option to its original value at the end 
of the Web page, insert the following statement just before linking to the next 
page in the script:

Rem Change the DefaultTimeOut testing option back to its original value.
Setting("DefaultTimeOut")=old_delay
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Adding and Removing Run-Time Settings

In addition to the global and test-specific settings, you can also add, modify, and 
remove your own run-time settings. These settings are applicable during the test 
run only.

To add a new run-time setting, use the syntax:

Setting.Add ( testing_option, value )

For example, you could create a setting that indicates the name of the current 
tester and writes the name in the report.

Setting.Add (“Tester Name”, “Mark Train”)
Reporter.ReportEvent 1, "Test Run By:", paramcount

To modify a run-time setting that has already been initialized, use the same 
syntax you use for setting any standard setting option:

Setting ( testing_option ) = new_value

For example:

Setting(“Tester Name”)=Alice Wonderlin
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To remove a run-time setting, use the following syntax:

Setting.Remove ( testing_option )

For example:

Setting.Remove ("Tester Name")
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Test Script Testing Options

This section describes the Astra QuickTest testing options that can be used with 
the Setting object from within a test script. The corresponding dialog box option 
is listed where applicable.

AutomaticLinkCheck 

Sets or retrieves the setting for the Add automatic checks for each page during 
record option. 

AutomaticLinkCheck is a global testing option. 

Note that you may also set this option using the Add automatic checks for each 
page during record option in the Page Verification tab of the Options dialog box 
as described in Page Verification Options on page 353.

CheckBrokenLinks

Sets or retrieves the setting for the check broken links option in an automatic page 
check. 

CheckBrokenLinks is a global testing option.

Note that you may also set this option using the Broken links option in the Page 
Verification tab of the Options dialog box as described in Page Verification 
Options on page 353.
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CheckHtmlContent

Sets or retrieves the setting for the check HTML content option in an automatic 
page check. 

CheckHtmlContent is a global testing option.

Note that you may also set this option using the Html content option in the Page 
Verification tab of the Options dialog box as described in Page Verification 
Options on page 353.

CheckHtmlTag

Sets or retrieves the setting for the check HTML tag option in an automatic page 
check. 

CheckHtmlTag is a global testing option.

Note that you may also set this option using the Html tag option in the Page 
Verification tab of the Options dialog box as described in Page Verification 
Options on page 353.
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CheckImagesSource

Sets or retrieves the setting for the check image source option in an automatic 
page check. 

CheckImagesSource is a global testing option.

Note that you may also set this option using the Image source option in the Page 
Verification tab of the Options dialog box as described in Page Verification 
Options on page 353.

CheckLinksUrl

Sets or retrieves the setting for the check links URL option in an automatic page 
check. 

CheckLinksUrl is a global testing option.

Note that you may also set this option using the Links url option in the Page 
Verification tab of the Options dialog box as described in Page Verification 
Options on page 353.
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CheckLoadtime

Sets or retrieves the setting for the check load time option in an automatic page 
check. 

CheckLoadtime is a global testing option.

Note that you may also set this option using the Load time option in the Page 
Verification tab of the Options dialog box as described in Page Verification 
Options on page 353.

CheckNumberOfImages

Sets or retrieves the setting for the check number of images option in an 
automatic page check. 

CheckNumberOfImages is a global testing option.

Note that you may also set this option using the Number of images option in the 
Page Verification tab of the Options dialog box as described in Page Verification 
Options on page 353.
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CheckNumberOfLinks

Sets or retrieves the setting for the check number of links option in an automatic 
page check. 

CheckNumberOfLinks is a global testing option.

Note that you may also set this option using the Number of links option in the 
Page Verification tab of the Options dialog box as described in Page Verification 
Options on page 353.

DefaultLoadTime

Sets or retrieves the setting for the add to load time option. 

DefaultLoadTime is a global testing option.

Note that you may also set this option using the Add to load time option in the 
Page Verification tab of the Options dialog box as described in Page Verification 
Options on page 353.

DefaultTimeOut

Sets or retrieves the delay for finding objects. 

DefaultTimeOut is a test-specific option.

Note that you may also set this option using the Object Timeout option in the 
Web tab of the Test Settings dialog box as described in Web Testing Options on 
page 366.
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LocalLinks

Sets or retrieves the setting for the check broken links going to local host option. 

LocalLinks is a global testing option.

Note that you may also set this option using the Broken links - Check only links 
going to current host option in the Page Verification tab of the Options dialog 
box as described in Page Verification Options on page 353.

WebTimeOut

Sets or retrieves the delay for navigating to a URL address. 

WebTimeOut is a test-specific option.

Note that you may also set this option using the Navigation Timeout option in the 
Web tab of the Test Settings dialog box as described in Web Testing Options on 
page 366.
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Part VI

Working with TestDirector
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Managing the Testing Process

Web site testing typically involves creating and running thousands of tests. 
TestDirector, Mercury Interactive’s test management tool, can help you organize 
and control the testing process. 

This chapter describes:

• About Managing the Testing Process

• Using Astra QuickTest with TestDirector

• Connecting to and Disconnecting from a Project

• Saving Tests to a Project

• Opening Tests in a Project

• Running Tests from TestDirector
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About Managing the Testing Process

TestDirector is a powerful test management tool that enables you to manage and 
control all phases of software testing. It provides a comprehensive view of the 
testing process so you can make strategic decisions about the human and 
material resources needed to test a Web site and repair defects. 

TestDirector divides testing into three modes of operation: Plan Tests, Run Tests, 
and Track Defects. In Plan Tests mode, you begin the testing process by dividing 
your site into test subjects and building a test plan tree. 
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This is a graphical representation of your test plan, displaying your tests 
according to the hierarchical relationship of their functions.

After you build the test plan tree, you plan tests for each subject. You then use 
Astra QuickTest to record your tests and save them under the test plan tree.

Test plan tree
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In Run Tests mode, you define test sets. A test set is a group of tests designed to 
meet a specific testing goal. For example, to verify that your site is functional and 
stable, you create a sanity test set that checks the site’s basic features. You could 
then create other test sets to test the advanced features.

To build a test set, you select tests from the TestDirector test repository. Once you 
build a test set, you can schedule test runs. You can run tests on your own 
computer (locally), or on multiple remote hosts. A host is any computer connected 
to your network. After TestDirector runs a test in Astra QuickTest, it displays the 
results and marks the test as passed, failed, or not completed.

In Track Defects mode, you report defects that were detected in the Web site you 
are testing. Information about defects is stored in a defect database. The defects 
are assigned to developers to be fixed, and then they are tracked until they are 
corrected.

In all stages of test management, you can create detailed reports and graphs to 
help you analyze testing data and review the progress of testing on your site.

For more information on working with TestDirector, refer to the TestDirector User’s 
Guide.
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Using Astra QuickTest with TestDirector

TestDirector and Astra QuickTest work together to integrate all aspects of the 
testing process. In Astra QuickTest, you can create tests and save them in your 
TestDirector project. After a test is run, the results are viewed in TestDirector.

TestDirector stores test and defect information in a project. TestDirector project 
databases can be either file-based (Microsoft Access) or client/server (Oracle, 
Sybase, and Microsoft SQL). A file-based database resides on your local file 
system or in a shared network directory. Client/server databases always reside on 
a central database server. You create individual project databases within 
TestDirector. These project databases store information related to the current 
testing project, such as tests, test run results, and reported defects. 

In order for Astra QuickTest to access the project, you must connect it to the 
TestDirector server. This is a program that handles the communication between 
Astra QuickTest and the TestDirector project. Note that the TestDirector server 
usually runs on your TestDirector machine but you can also install it on any 
computer connected to the network.
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When Astra QuickTest is connected to TestDirector, you can save a test by 
associating it with a subject in the test plan tree, instead of assigning the test to a 
folder in the file system. This makes it easy to organize tests by subject for your 
Web site. When you open a test, you search for it according to its position in the 
test plan tree. After you run the test, results are sent directly to your TestDirector 
project.

Note: The integration of Astra QuickTest with TestDirector (described in this 
chapter) is valid only for TestDirector 6.0.

TestDirector project

TestDirector 
Server

Astra QuickTest
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Connecting to and Disconnecting from a Project

If you are working with both Astra QuickTest and TestDirector, Astra QuickTest 
can communicate with your TestDirector project. You can connect or disconnect 
Astra QuickTest from a TestDirector project at any time during the testing process. 
However, do not disconnect Astra QuickTest from TestDirector while an Astra 
QuickTest test is opened from TestDirector.

The connection process has two stages. First, you connect Astra QuickTest to the 
TestDirector server. This server handles the connections between Astra 
QuickTest and the TestDirector project. 

Next, you choose the project you want Astra QuickTest to access. The project 
stores tests and test run information for the Web site you are testing. Note that 
TestDirector project databases are password protected, so you must provide a 
user name and a password. 

Connecting Astra QuickTest to a TestDirector Server and 
Project
You must connect Astra QuickTest to the TestDirector API server before you 
connect Astra QuickTest to a project. For more information, see Using Astra 
QuickTest with TestDirector on page 390.
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To connect Astra QuickTest to a TestDirector server and project:

 1 Choose Tools > TestDirector Connection. The Connection to TestDirector 
dialog box opens.

 2 In the Server Connection section, in the Server box, enter the name of the host 
where the TestDirector server runs.

 3 Click Connect.
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Once the connection to the server is established, the server’s name is displayed 
in read-only format in the Server box.

 4 In the Project Connection section, select a TestDirector project from the 
Project box.

 5 Type a user name in the User Name box.

 6 Type a password in the Password box.

 7 Click Connect to connect Astra QuickTest to the selected project.

Once the connection to the selected project is established, the project’s name is 
displayed in read-only format in the Project box.

To automatically reconnect to the TestDirector server and the selected project on 
startup, select the Reconnect on Start Up check box.

If the Reconnect on Start Up check box is selected, then the Save Password 
for Reconnection on Start Up check box is enabled. To save your password for 
reconnection on startup, select the Save Password for Reconnection on Start 
Up check box. If you do not save your password, you will be prompted to enter it 
when Astra QuickTest connects to TestDirector on startup.

 8 Click Close to close the Connection to TestDirector dialog box. 
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Disconnecting from a TestDirector Project 
You can disconnect from a TestDirector project. This enables you to select a 
different project while using the same TestDirector server.

To disconnect Astra QuickTest from a TestDirector project:

 1 Choose Tools > TestDirector Connection. The Connection to TestDirector 
dialog box opens.



Working with TestDirector • Managing the Testing Process

Astra QuickTest User’s Guide Page 396

In

Back

Find

Find

Chapter
Top of

 Again

 2 In the Project Connection section, click Disconnect to disconnect Astra 
QuickTest from the selected project.

 3 Click Close to close the Connection to TestDirector dialog box. 

Disconnecting from a TestDirector Server 
You can disconnect from a TestDirector server. This enables you to select a 
different TestDirector server and a different project.

To disconnect Astra QuickTest from a TestDirector server:

 1 Choose Tools > TestDirector Connection.

The Connection to TestDirector dialog box opens.

 2 In the Server Connection section, click Disconnect to disconnect Astra 
QuickTest from the TestDirector server.

 3 Click Close to close the Connection to TestDirector dialog box. 

Note: If you disconnect Astra QuickTest from a TestDirector server without first 
disconnecting from a project, Astra QuickTest’s connection to that database is 
automatically disconnected.
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Saving Tests to a Project

When Astra QuickTest is connected to a TestDirector project, you can create new 
tests in Astra QuickTest and save them directly to your project. To save a test, you 
give it a descriptive name and associate it with the relevant subject in the test plan 
tree. This helps you to keep track of the tests created for each subject and to 
quickly view the progress of test planning and creation.

To save a test to a TestDirector project:

 1 In Astra QuickTest, click Save or choose File > Save to save the test. 

The Save Astra Test to TestDirector Project dialog box opens and displays the 
test plan tree.
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Note that the Save Astra Test to TestDirector Project dialog box opens only when 
Astra QuickTest is connected to a TestDirector project. 
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To save a test directly in the file system, click the File System button to open the 
Save Astra QuickTest Test dialog box. (From the Save Astra Test dialog box, you 
may return to the Save Astra Test to TestDirector Project dialog box by clicking 
the TestDirector button.) 

Note: If you save a test directly in the file system, your test will not be saved in 
the TestDirector project.

 2 Select the relevant subject in the test plan tree. To expand the tree and view a 
sublevel, double-click a closed folder. To collapse a sublevel, double-click an 
open folder.

 3 In the Test Name text box, enter a name for the test. Use a descriptive name 
that will help you easily identify the test. 

 4 Click OK to save the test and to close the dialog box.

The next time you start TestDirector, the new test will appear in TestDirector’s test 
plan tree. Refer to the TestDirector User’s Guide for more information.
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Opening Tests in a Project

If Astra QuickTest is connected to a TestDirector project, you can open automated 
tests that are a part of your database. You locate tests according to their position 
in the test plan tree, rather than by their actual location in the file system.

To open a test saved to a TestDirector project:

 1 In Astra QuickTest, click Open or choose File > Open to open the test. The 
Open Astra Test dialog box opens. The Open Astra Test from TestDirector 
Project dialog box opens and displays the test plan tree.
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Note that the Open Astra Test from TestDirector Project dialog box opens only 
when Astra QuickTest is connected to a TestDirector project. 

To open a test directly from the file system, click the File System button to open 
the Open Astra QuickTest Test dialog box. (From the Open Astra Test dialog box, 
you may return to the Open Astra Test from TestDirector Project dialog box by 
clicking the TestDirector button.)

 2 Click the relevant subject in the test plan tree. To expand the tree and view 
sublevels, double-click closed folders. To collapse the tree, double-click open 
folders.

Note that when you select a subject, the tests that belong to the subject appear 
in the Test Name list.

 3 Select a test in the Test Name list. The test appears in the read-only Test Name 
box.

 4 Click OK to open the test. The test opens in a window in Astra QuickTest.
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Running Tests from TestDirector

You can run an Astra QuickTest test from a TestDirector project.

To run a test from a TestDirector project:

 1 In TestDirector, click the Run Tests tab.

 2 Select the tests you want to run from the Run Tests grid.
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 3 Click the Automated button. The Test Run Scheduler opens with the selected 
tests displayed in the Test Run Scheduler grid.
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 4 To run a single test, select a test from the grid and click the Run button. 
Alternatively, click the Run All button to run all the tests in the Test Run 
Scheduler. Click the Stop button if you need to terminate the test run before it is 
complete.

After the test run has finished running, you can view a summary of test results in 
TestDirector. The updated status for each test run appears in the Run Tests grid. 
Results for each test step appear in the Last Run grid. You must click the 
Refresh button before you can view the latest test results in the Run Tests grid. 
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��
Reporting Defects

You can report defects detected in your Web site using TestDirector’s Web Defect 
Manager.

This chapter describes:

• Using the Web Defect Manager

• Reporting New Defects
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About Reporting Defects

When you click the Defect Report tab in Astra QuickTest’s Display pane, 
TestDirector’s Web Defect Manager opens. It enables you to report defects 
detected in your site. You provide detailed information about the defect and then 
add it to a central repository (TestDirector project), so that the defect can be 
tracked until it is fixed.

Before you can launch the Web Defect Manager, you must ensure that a Web 
Defect Manager server is installed on your Web server, and that a TestDirector 
Web server is specified in the Test Settings dialog box. For more information 
about specifying the TestDirector Web server, see Chapter 25, Reporting 
Defects.  For more information about installing the Web Defect Manager Server, 
refer to the TestDirector Installation Guide.
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Using the Web Defect Manager

The Web Defect Manager is Mercury Interactive’s system for reporting and 
tracking software defects and errors over the World Wide Web. The Web Defect 
Manager is a scalable, defect tracking system that helps you monitor defects 
closely from initial detection until resolution.

The Web Defect Manager is tightly integrated with TestDirector, Mercury 
Interactive's test management tool. Multiple users can share defect-tracking 
information stored in a central repository (TestDirector project). Several projects 
can be stored on a database server. This ensures that all software development, 
Quality Assurance, and Information Systems personnel can share defect-tracking 
information. For more information about TestDirector projects, refer to the 
TestDirector User’s Guide.

When you detect a defect in your site, you report it to a TestDirector project. For 
example, suppose you are testing a flight reservation site. You discover that 
errors occur when you try to order an airline ticket. You open the Web Defect 
Manager and report the defect. This includes a summary and detailed description 
of the defect, where it was discovered, and if you are able to reproduce it. You can 
also include screen captures, text documents, and other files relevant to 
understanding and repairing the problem. For information on using the Web 
Defect Manager, refer to the online Web Defect Manager User’s Guide.
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Reporting New Defects

Once the Web Defect Manager is set up, you can use it to report defects.

To report new defects:

 1 In Astra QuickTest, click the Defect Report tab. The Web Defect Manager 
window opens and displays a list of TestDirector projects.

 2 Select a project from the TestDirector Projects list. The Connect To dialog box 
opens. 

 3 Type your user name and password and click OK. If you do not know your 
password, check with your TestDirector administrator. The Web Defect Manager 
opens and displays the View Defects tab.
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 4 Click the Add Defect tab.

 5 In the Summary box, type in a brief summary of the defect.

 6 In Detected By, click the name of the person who detected the defect. Note that 
the current date appears automatically.
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 7 Enter information in the rest of the defect fields. Note that you must enter 
information in all the text boxes with red labels.

 8 In the Description section, type in a detailed description of the defect. You may 
also type in other information, such as suggestions for working around the 
defect.

 9 You can also choose from the following options:

• If the defect can be recreated under the same conditions by which it was 
detected, select the Reproducible check box. 

• To associate a file with a defect record. Use attachments to reference 
relevant files such as detailed defect descriptions and captured screen 
images, click the New Attachments button.

• To associate an address of a document on the World Wide Web (URL) with a 
defect record, click the New Web Link button. 

 10 Click the Add button to save the defect record in the database. TestDirector 
assigns the new defect a unique record number. 

 11 Click the Logout button to exit the Web Defect Manager.
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A

action data sheet   150
Action tab, Data pane   35, 197
actions   190–207

copying within a test   196
creating new   194
diagram   193, 201
guidelines for working with   206
inserting from other tests   200–205
multiple actions in a test   192–199
overview   191
parameterizing   196

Activate Pointed Window After box   350
ActiveScreen tab

in Display pane   34
in Options dialog box   351
in Test Settings dialog box   368

Add Automatic Checks for Each Page During 
Record check box   354

Add button, Web Defect Manager   410
Add to Load Time box   355
Add/Remove Properties dialog box   107, 172, 

223
adding checkpoints

objects   87–93
pages   66–80

adding checkpoints (cont’d)
tables   94–98
text   81–86

analyzing test results   233–244
checkpoints   240
filtering results   238
printing results   244
Runtime Data table   242
Test Results button   236
Test Results window   234

application, sample   13, 23
ASCII   151
Astra QuickTest

Data pane   28
Debug toolbar   28, 38
Display pane   28
File toolbar   28, 37
introduction   17–24
Main toolbar   28, 37
menu bar   28
overview   25–41
resources   13
starting   26
status bar   28
Test pane   28
testing process   19
title bar   28

Index
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Astra QuickTest (cont’d)
Welcome window   26
window   28

Astra QuickTest help   13
Astra QuickTest Readme file   13
Astra QuickTest testing options   343–355
Astra QuickTest testing process   19
Astra QuickTest Tutorial   13
AutomaticLinkCheck testing option   379

B

Basic event recording configuration level   254
behavior, definition   265
breakpoints

Clear All Breakpoints button   250
deleting   250
overview   246
setting   249
Toggle Breakpoint button   249, 250

Broken Links - Check only links going to current 
host check box   355

Broken Links check box   355
bubbling, definition   267
buttons, Astra QuickTest toolbars   36

C

calculations, in the Expert View   310
Change the Default Navigation Timeout check 

box   367
Change the Default Timeout check box   367
CheckBrokenLinks testing option   379
CheckHtmlContent testing option   380
CheckHtmlTag testing option   380
CheckImagesSource testing option   381
checking Web objects   65–98
CheckLinksUrl testing option   381
CheckLoadtime testing option   382
CheckNumberOfImages testing option   382
CheckNumberOfLinks testing option   383
Checkpoint command   40
Checkpoint Properties dialog box   61, 90
checkpoints   65–98

checking objects   87–93
checking pages   66–80
checking tables   94–98
checking text   81–86
Checkpoint Properties dialog box   90
definition   50, 60
in the Expert View   293
modifying   64, 98
Page Checkpoint Properties dialog box   67
parameterizing   113–114
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checkpoints (cont’d)  
Table Checkpoint Properties dialog box   

95
Text Checkpoint Properties dialog box   82
Use Data Table Formula option   159

Choose browser option   361
Clear All Breakpoints button   38, 250
Clear All Breakpoints command   41
Collapse All command   237
commands using shortcut keys   38–41
comments

in the Expert View   309
in the Tree View   287

Complete Word command   40
conditional statements   280
configuration levels

custom   257–268
standard   254–256

configuring event recording   252–270
connecting Astra QuickTest to a TestDirector 

project   392–396
Connection to TestDirector dialog box   393
Continue to the following Page if an Object isn’t 

Found During the Test Run check box   
367

conventions. See typographical conventions
Copy command   39

copying actions   200–205
within a test   196

creating tests   43–58, 59–64
Custom event recording configuration   

257–268
adding listening events   263
adding objects to the custom list   261
deleting objects from the custom list   262
setting   258
specifying listening criteria   265

Custom Web Event Recording Configuration 
dialog box   258

customizing test scripts   326–342
highlighting script elements   333
overview   327
print options   329
script window customization   338

Cut command   39

D

Data menu commands, data table   155
Data pane   28, 35

Action tab   35, 197
Global tab   35, 197
table columns   100
table rows   101
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data sheets
global   149
local   150

data table
AutoFill List command   155
Clear command   154
Copy command   153
Currency(0) command   155
Currency(2) command   156
Custom Number command   156
Cut command   153
Data menu commands   155
data sheets   149
Date (M/d/yy) command   156
Delete command   154
Edit menu commands   153
editing tables   151–156
Export command   153
File menu commands   153
Fill Down command   154
Fill Right command   154
Find command   154
Fixed command   156
Format menu commands   155
Fraction command   156
General command   155
Go To command   154
Import command   153

data table (cont’d)
importing data in ASCII   151
importing data in Microsoft Excel 95   151
importing data in Microsoft Excel 97   151
Insert command   154
local data sheets   150
menu commands to edit tables   152
Paste command   153
Paste Values command   153
Percent command   156
Print command   153
Recalc command   155
Replace command   154
Scientific command   156
scripting functions, using   161–168
Sort command   155
Time (hmm AM/PM) command   156
using formulas in   157–160
Validation Rule command   156
working with   148–168
See also Data pane

Data Views button   37
DataTable object

default property   162
DeleteSheet function   163
Export function   164
functions and properties of   162
GetCurrentRowt function   164
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DataTable object (cont’d)
GetRowCount function   163
GetSheet function   163
GetSheetCount function   163
GlobalSheet property   163
Import function   164
LocalSheet property   163
RawValue property   163
SetCurrentRow function   164
SetNextRow function   164
SetPrevRow function   164
Value property   162

Debug toolbar, Astra QuickTest window   28, 
38

debugging tests   245–250
deleting breakpoints   250
overview   246
pausing runs   248
setting breakpoints   249
Step Into button   247
Step Out button   247
Step Over button   247

Default Location option   365
default properties, modifying   217–223
DefaultLoadTime testing option   383
DefaultTimeout testing option   383
Defect Report tab, Display pane   34, 408
defects, reporting   405–410

Delete command   39
deleting breakpoints   250
Description option   365
descriptions, modifying   221–223
Dim statement, in the Expert View   316
disconnecting from a TestDirector

project   395
server   396

Display pane   28
ActiveScreen tab   34
Defect Report tab   34

Display pane, Astra QuickTest window
Defect Report tab   408

Display Views button   37
Do Not Run Iterations option   363
Do...Loop statement, in the Expert View   313
Don’t Perform Automatic Checks during Test 

Run check box   355
dynamic descriptions of objects   220

E

Edit menu commands, data table   153
event configuration   252–270
Excel formulas   158, 159
Exception Editor   209
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exception handling   208–216
adding new exceptions   214
changing status of exceptions   210
deleting exceptions   216
Exception Editor   209
modifying exceptions   212

Expand All command   238
expected value, modifying   63
Expert View

checkpoints   293
functions   303
objects and functions   297
parameters   294
viewing steps   290

Expert View mode   23, 288–317
Expert View tab   32
Expert View tab, Test pane   32

F

File menu commands, data table   153
File toolbar, Astra QuickTest window   28, 37
Filter button   238
Filter Image Check dialog box   78
Filter Link Checks dialog box   75
filtering

hypertext links to check   75
image sources to check   78

Find command   39
For...Each statement, in the Expert View   313
For...Next statement, in the Expert View   312
Format menu commands, data table   155
formulas

using in checkpoints   159
using in the data table   157–160
using to create input parameters   158

Function Arguments command   39
Function Arguments dialog box   110
Function Reference, Astra   13
Function wizard   272, 273–279
functions

Expert View   297, 303
in the Tree View   273–279

G

General tab, Options dialog box   348
Global data sheet   149
Global tab, Data pane   35, 197
Go To command   40
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H

handler, definition   265
handling exceptions   208–216

adding new exceptions   214
changing status of exceptions   210
deleting exceptions   216
Exception Editor   209
modifying exceptions   212

help   13
High event recording configuration level   255
HTML Content check box   354
HTML Tag check box   354
hypertext links, filtering   75

I

identifying objects   217–223
If Statement dialog box   283
If...Then...Else statement, in the Expert View   

315
Image Source check box   354
image sources, filtering   78
Insert Checkpoint button   37
inserting actions from other tests   200–205

K

key assignments, creating   339
keyboard shortcuts

creating   339
deleting   339
editing   339

L

Link URL check box   354
linking to actions   200–205
Load ActiveX Controls check box   352
Load Images check box   352
Load Java Applets check box   352
Load Time check box   354
local data sheets   150
LocalLinks testing option   384
Location option   365
Logout button, Web Defect Manager   410

M

Main toolbar, Astra QuickTest window   28, 37
managing tests   57–58

creating new   57
opening   57
printing   58
saving   58
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managing the testing process   24, 386–404
mathematical formulas   158, 159
Medium event recording configuration level   

255
menu bar, Astra QuickTest window   28
Mercury Interactive on the Web   14
Mercury Tours sample application   13, 23, 175
Microsoft Excel   151
Microsoft Visual Basic Scripting language   23
modifying

checkpoints   98
default properties   217–223
descriptions   221–223
steps   53–55

multiple actions in a test   192–199

N

Name option   365
Navigation Timeout box   367
New Action button   37, 194
New Action command   194
New Attachments button, Web Defect Manager   

410
New button   37
New command   38
New Web Link button, Web Defect Manager   

410

normalizing regular expressions   174
Number of Images check box   354
Number of Links check box   354

O

object descriptions, modifying   221–223
Object Properties commend   39
Object Properties dialog box   106, 171, 218, 

222
Object Timeout box   367
objects

dynamic descriptions   220
Expert View   297
identifying   217–223

On Run Error box   349
Open Astra Test dialog box   47, 57
Open Astra Test from TestDirector Project 

dialog box   400
Open button   37, 47, 57
Open command   38
Open dialog box   57
Open New Web Browser Window at the 

Following URL option   361
opening tests   57

in a TestDirector project   400
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options
setting testing options for a single test   

356–369
setting testing options for all tests   

343–355
Options dialog box

ActiveScreen tab   351
General tab   348
Page Verification tab   353

options, testing
See setting testing options

Other Location option   365
Output Parameter command   40
Output Parameter Properties dialog box   141
output parameters   123–147

defined   124
objects   138–143
Output Parameter Properties dialog box   

141
Page Output Parameter Properties dialog 

box   128
pages   126–131
Table Output Parameter Properties dialog 

box   146
tables   144–147

output parameters (cont’d) 
text   132–137
Text Output Parameter Properties dialog 

box   134
Owner option   365

P

Page Checkpoint Properties dialog box   67, 69
Page Output Parameter Properties dialog box   

128
Page Verification tab, Options dialog box   353
Parameter Info command   40
Parameter object

default property   167
functions and properties of   167
Name property   168
RawValue property   168
Value property   167
ValuebyRow property   168

parameterization   99–122
checkpoints   113–114
example   115–122
overview   100
steps   105–112
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parameterization (output)   123–147
objects   138–143
Output Parameter Properties dialog box   

141
Page Output Parameter Properties dialog 

box   128
pages   126–131
Table Output Parameter Properties dialog 

box   146
tables   144–147
text   132–137
Text Output Parameter Properties dialog 

box   134
parameterized test, example   115–122
parameterizing actions   196
parameters, Expert View   294
Paste command   39
pasting actions   200–205
pasting links to actions   200–205
Pause button   38, 229, 248
Pause command   40
pausing test runs   248
planning tests   45
Print button   37, 58, 244
Print command   38
print options   329, 338
printing tests   58

programming
adding functions to tests   273–279
comments   287
conditional statements   280
Expert View   288–317
Function wizard   272, 273–279
in the Expert View   310
sending messages to test results   285
Tree View   271–287

project (TestDirector)
connecting Astra QuickTest to a   392–396
disconnecting from a   395
opening tests in a   400
running tests from a   402
saving tests to a   397–399
viewing test results from a   404

Properties command   39
Properties tab, Test Settings dialog box   364
properties, default   217–223

R

Readme file   13
Record button   37
Recording status options   267
recording tests   46–49
Redo command   39
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regular expressions   169–189
defining in object checkpoints   175
defining in steps   170
defining in text checkpoints   179
normalizing   174
overview   169
syntax   184

Rename Action command   206
Rename Action dialog box   196
Rename command   39
Replace command   40
reporting defects   405–410
resetting standard event recording 

configuration settings   269
resources

Astra Function Reference   13
Astra QuickTest help   13
Astra QuickTest Readme file   13
Astra QuickTest Tutorial   13
Mercury Interactive on the Web   14
support information   14
technical support online   13
VBScript reference guide   13

Run All Iterations in Data Table option   363
Run button   37, 248
Run command   40
Run for Specified Iterations in Data Table 

option   363

Run Mode box   349
Run Scripts check box   352
Run tab, Test Settings dialog box   362
Run Test dialog box   228
running tests   225–232

from a TestDirector project   402
Pause button   229
Run Test dialog box   228
Start Run button   228
Stop button   229
viewing test results   236

Runtime Data table, Test Results window   235
run-time settings, adding and removing   377

S

sample application, Mercury Tours   13, 23, 
175

Save Astra Test dialog box   58
Save Astra Test to TestDirector Project dialog 

box   397
Save button   37, 58
Save command   38
Save dialog box   58
saving tests   58
saving tests to a TestDirector project   397–399
server (TestDirector), disconnecting from a   

396
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setting
ActiveScreen options in the Options dialog 

box   351
ActiveScreen options in the Test Settings 

dialog box   368
breakpoints   249
General options in the Options dialog box   

348
Page Verification options in the Options 

dialog box   353
Properties options in the Test Settings 

dialog box   364
Run options in the Test Settings dialog box   

362
StartUp options in the Test Settings dialog 

box   360
Web options in the Test Settings dialog box   

366
Setting object   372
setting testing options, 
       within a test script   370–384

See also testing options
Sheet object

AddParameter function   166
DeleteParameter function   166
functions and properties of   165
GetCurrentRow function   166
GetParameter function   165

Sheet object (cont’d)
GetParameterCount function   165
GetRowCount function   166
Name property   165
SetCurrentRow function   166
SetNextRow function   166
SetPrevRow function   166

shortcut keys   38–41
Show Welcome Screen on Start check box   

350
Standard event recording configuration   

254–256
Standard event recording configuration, setting   

256
Start Record button   47
Start Recording dialog box   47
Start Run button   228
StartUp tab, Test Settings dialog box   360
status bar, Astra QuickTest window   28
Step commands   247
Step Into button   38, 247
Step Into command   41
Step Out button   38, 247
Step Out command   41
Step Over button   38, 247
Step Over command   41
steps, modifying   53–55
Stop button   37, 49, 229
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Stop command   40
support information   14

T

Table Checkpoint Properties dialog box   95
Table Output Parameter Properties dialog box   

146
technical support online   13
test

checking objects   87–93
checking pages   66–80
checking tables   94–98
checking text   81–86
checking Web objects   65–98
creating new   57
debugging   245–250
managing   57–58
modifying checkpoints   98
opening   57
parameterization   99–122
parameterization (output)   123–147
pausing runs   229, 248
planning   45
printing   58
printing results   244
programming   271–287
recording   46–49

test (cont’d)
running   225–232
saving   58
test results   233–244

Test pane   28, 30
Expert View tab   32
Tree View tab   30

test plan tree (TestDirector)   387
Test Results button   236
Test Results window   234

Runtime Data table   235
test results details   235
test results tree   235

test results, sending messages to   285
test scripts

customizing   326–342
highlighting script elements   333
print options   329
script window customization   338

test sets (TestDirector)   389
Test Settings dialog box

ActiveScreen tab   368
Properties tab   364
Run tab   362
StartUp tab   360
Web tab   366
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test tree
creating   48
definition   51

test window
customizing appearance of   327
highlighting script elements   333

TestDirector
managing the testing process   24
modes of operation   387
Plan Tests mode   387
project   407
Run Tests mode   387
test plan tree   387
test sets   389
Track Defects mode   387
using Astra QuickTest with   24, 390
Web Defect Manager   34, 405–410
working with   386–404

TestDirector project   390–404, 407
connecting Astra QuickTest to a   392–396
disconnecting from a   395
opening tests in a   400
running tests from a   402
saving tests to a   397–399
viewing test results from a   404

TestDirector server   390, 392–396
connecting Astra QuickTest   392
disconnecting from a   396

TestDirector Web Defect Manager   405–410
TestDirector Web Server box   349
testing in Expert View   288–317
testing options

AutomaticLinkCheck   379
CheckBrokenLinks   379
CheckHtmlContent   380
CheckHtmlTag   380
CheckImagesSource   381
CheckLinksUrl   381
CheckLoadtime   382
CheckNumberOfImages   382
CheckNumberOfLinks   383
DefaultLoadTime   383
DefaultTimeout   383
LocalLinks   384
restoring   376
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