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Welcome to This Guide

This guide describes the best practices for using and configuring the
integration of SiteScope with HP Business Service Management (BSM) and
HP Operations Manager (HPOM) products.

This chapter includes:

» "How This Guide Is Organized" on page 7

» "Who Should Read This Guide" on page 8

\

"How Do I Find the Information That I Need?" on page 8

\

"Additional Online Resources" on page 9

\

"Documentation Updates" on page 9

How This Guide Is Organized

The guide contains the following parts:

Chapter 1 Integrating SiteScope with Business Service Management Products

Describes best practices for integrating SiteScope with HP Business Service
Management (BSM) applications.

Chapter 2  Integrating SiteScope With Operations Manager Products

Describes best practices for using and configuring the HP Operations
Manager integration for sending events and reporting metrics to HP
Operations Manager (HPOM) and HP Performance Manager.
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Chapter 3

Chapter 4

Integrating SiteScope with Business Service Management or
Operations Manager

Describes best practices for using SiteScope with HP Business Service
Management (BSM) and HP Operations Manager (HPOM) products.

Troubleshooting SiteScope Integration Issues

Describes troubleshooting when using and configuring the integration of
SiteScope with HP Business Service Management (BSM) and HP
Operations Manager (HPOM) products.

Who Should Read This Guide

This guide is intended for the following users of HP SiteScope and
HP Business Service Management (BSM):

» SiteScope/BSM/HP Operations Manager administrators

» SiteScope/BSM/HP Operations Manager application administrators
» SiteScope/BSM/HP Operations Manager data collector administrators
» SiteScope/BSM/HP Operations Manager end users

Readers of this guide should be knowledgeable about enterprise system
administration, infrastructure monitoring systems, and SiteScope, and have
familiarity with the systems being set up for monitoring. Readers should
also be familiar with BSM/HP Operations Manager, and enterprise
monitoring and management concepts.

How Do | Find the Information That | Need?

This guide is part of the HP SiteScope Help. The SiteScope Help provides a
single-point of access for all SiteScope documentation.

You can access the SiteScope Help by selecting Help > SiteScope Help on the
SiteScope server.
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Additional Online Resources

Troubleshooting & Knowledge Base accesses the Troubleshooting page on
the HP Software Support Web site where you can search the Self-solve
knowledge base. Choose Help > Troubleshooting & Knowledge Base. The
URL for this Web site is http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software Support accesses the HP Software Support Web site. This site
enables you to browse the Self-solve knowledge base. You can also post to
and search user discussion forums, submit support requests, download
patches and updated documentation, and more. Choose Help > HP Software
Support. The URL for this Web site is www.hp.com/go/hpsoftwaresupport.

Most of the support areas require that you register as an HP Passport user
and sign in. Many also require a support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport user ID, go to:

http://h20229.www2.hp.com/passport-registration.html

HP Software Web site accesses the HP Software Web site. This site provides
you with the most up-to-date information on HP Software products. This
includes new software releases, seminars and trade shows, customer support,
and more. Choose Help > HP Software Web site. The URL for this Web site
is www.hp.com/go/software.

Documentation Updates

HP Software is continually updating its product documentation with new
information.

To check for recent updates, or to verify that you are using the most recent
edition of a document, go to the HP Software Product Manuals Web site
(http://h20230.www2.hp.com/selfsolve/manuals).
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Integrating SiteScope with Business
Service Management Products

SiteScope can be used to report data that is used in various applications in
Business Service Management (BSM). This section contains details of the
benefits, prerequisites, best practices, and troubleshooting for integrating
SiteScope with the various BSM applications.

This section includes:

"Integration Benefits" on page 11
"Integration Prerequisites" on page 13

"Integration Options and Details" on page 14

Y VY VY Y

"Troubleshooting" on page 18

Integration Benefits

» Events: Ability to configure and generate events directly from SiteScope,
reuse existing alerts as events, and manage and use SiteScope events in
BSM'’s Operations Management and Service Health. For details, see
"Sending Events" in Using SiteScope.

> Run-time Service Model (RTSM): SiteScope is able to discover and report
topology on monitored systems to BSM’s RTSM. You can then manage
and work with these discovered configuration items (CIs) in views that
provide a subset of the components in which your business functions. For
details, see "Integrating SiteScope Data with BSM’s Configuration Items"
in Using SiteScope.

11
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12

» Service Health and Service Level Management: Health indicators assigned

to SiteScope monitor data provide a more detailed view of the health of a
configuration item (CI) when SiteScope reports metrics or events.

» For details on managing indicators in the centralized Indicator
Assignments repository in SAM Administration, see "Indicator
Assignment Settings" in Using System Availability Management in the
HP Business Service Management Documentation Library.

» For details on mapping metrics to indicators in SiteScope, see
"Assigning SiteScope Metrics to Indicators" in Using SiteScope.

System Availability Management Administration: Enables viewing and
managing multiple SiteScopes from within System Availability
Management Administration. For details, see "System Availability
Management Administration Overview" in Using System Availability
Management in the HP Business Service Management Documentation
Library.

Reports: Ability to create and view reports of SiteScope monitor metrics in
System Availability Management and Operations Management.

» For details on System Availability Management reports, see "System
Availability Management Reports" in Using System Availability
Management in the HP Business Service Management Documentation
Library.

» For details on Performance Perspective (the graphing component of
Operations Management), see the Using Operations Management guide
in the HP Business Service Management Documentation Library.

Downtime: Centralized management enables configuring downtime for
your IT infrastructure from one place in BSM. For details, see "CI
Downtime" in Using SiteScope.
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Integration Prerequisites

The following are required to enable the integration:

license. For details, see "System
Availability Management
Administration Overview" in Using
System Availability Management in the
HP Business Service Management
Documentation Library.

SiteScope .. )
Integration Prerequisites Enables reporting
BSM System Availability Management » Metrics (BSM)

» Topology data to
BSM

HP Operations
Manager

HP Operations agent must be installed
on the SiteScope server. For details, see
the HP SiteScope Deployment Guide
PDF.

» Metrics (HPOM)

» Events to BSM’s
Operations
Management.

13
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Integration Options and Details

The metrics and event data collected by SiteScope monitors is used in
various applications in BSM. Choose the integration option according to the
type of data to be collected, and the monitoring environment that exists in

your organization.
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BSM
Application

What to Use

SiteScope
Integration

Where to Get Details

Service Health

Metrics (BSM)
Advantages:

» Displays metric values in
Service Health tooltips.

» You can create
customized calculation
rules. For details, see
"Business Rule
Repository Overview" in
Using Service Health in
the HP Business Service
Management
Documentation Library.

Recommended if you do
not have Operations
Management.

BSM

"How to Configure the
Integration between SiteScope
and BSM" in Using SiteScope

Events
(metrics status change)

Advantage: Reduces the
amount of data SiteScope
sends to BSM.

Recommended when
managing events in
Operations Management.

HP
Operations
Manager

"How to Enable SiteScope to
Send Events to HPOM or BSM" in
Using SiteScope

Topology (required)

BSM

"HP Integration Settings" in
Using SiteScope

(To report topology, make sure
the Report monitor and related
Cl topology check box is selected
in BSM Integration Data and
Topology Settings for each
monitor instance)

15
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BSM. . What to Use SlteScop.e Where to Get Details
Application Integration
Service Level Metrics (BSM) BSM "How to Configure the
Management (recommended) Integration between SiteScope
and BSM" in Using SiteScope
Events HP "How to Enable SiteScope to
(optional) Operations Send Events to HPOM or BSM" in
Manager Using SiteScope
Topology BSM "HP Integration Settings" in
(required) Using SiteScope
(To report topology, make sure
the Report monitor and related
Cl topology check box is selected
in BSM Integration Data and
Topology Settings for each
monitor instance)
SAM Reports Metrics (BSM) BSM "How to Configure the
(required) Integration between SiteScope
and BSM" in Using SiteScope
Topology BSM "HP Integration Settings" in
(required) Using SiteScope

(To report topology, make sure
the Report monitor and related
Cl topology check box is selected
in BSM Integration Data and
Topology Settings for each
monitor instance)

Service Health
and

Service Level
Management/
SAM Reports

Since SiteScope can report metrics to BSM (which are used in Service Level
Management and System Availability Management), and metrics and events
(which are used in Service Health), you need to perform the following:

1. Decide on the reporting mode (events, metrics, or both) that you want to use
in Service Health. For details, see Service Health above.

2. Select the preference (events or metrics) for reporting SiteScope data to
Service Health, according to the specific use case. For details, see "BSM Service
Health Preferences" in Using SiteScope.

16
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BSM. . What to Use S'teSCOP.e Where to Get Details
Application Integration
Operations Events (required) HP For details on status change or
Management Status change: Operations alert events, see "How to Enable
Manager SiteScope to Send Events to
> Use if you want to HPOM or BSM" in Using SiteScope
manage raw (low-level)
events.
» These events affect
services.
Alerts:
» Use if you want to
manage alerts as events.
» These events do not
affect services. You need
to select the event or
metrics reporting mode
for Service Health. For
details, see Service
Health above.
Events generated from For details on events generated
health indicators: by health indicators, see
"Business Rule Repository
> Use if you create Overview" in Using Service Health
customized calculation in the HP Business Service
rules for metrics in Management Documentation
Service Health. Library.
» Use for earlier versions
of SiteScope (10.x) that
report metrics to BSM.
Topology BSM "HP Integration Settings" in

Recommended for:
» Topology-based event
correlation rules.

» Drill downs from events
to views and related ClIs.

Using SiteScope

(To report topology, make sure
the Report monitor and related
Cl topology check box is selected
in BSM Integration Data and
Topology Settings for each
monitor instance)

17
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BSM. . What to Use SlteScop.e Where to Get Details

Application Integration

Performance Metrics (HPOM) HP "How to Enable SiteScope to

Perspective Operations Report Metrics to the HP

(the graphing Manager Operations Agent" in Using

component in SiteScope

Operations . - .

Management) Topology BSM HP Int'egratlon Settings" in

(required) Using SiteScope
(To report topology, make sure
the Report monitor and related
Cl topology check box is selected
in BSM Integration Data and
Topology Settings for each
monitor instance)
Troubleshooting

» For troubleshooting topology reporting issues, see "Business Service
Management Topology Issues" on page 25.

» For troubleshooting Operations Manager Event Integration issues, see
"Operations Manager Event Integration Issues" on page 31.

» For troubleshooting BSM Metrics integration issues, see "Business Service
Management Metrics Integration Issues" on page 40.

» For troubleshooting Operations Manager Metrics Integration issues, see
"Operations Manager Metrics Integration Issues" on page 44.

» For troubleshooting CI downtime issues, see "Business Service
Management CI Downtime Issues" on page 47.

Note: Depending on the integration option, the suggested troubleshooting
might be applicable to specific HPOM or BSM applications only.

18



2

Integrating SiteScope With Operations
Manager Products

The purpose of this section is to provide best practices for using and
configuring the HP Operations Manager integration for sending events and
reporting metrics to HP Operations Manager (HPOM) and HP Performance
Manager.

This section includes:

"Integration Benefits" on page 19
"Integration Prerequisites" on page 20

"Integration Options and Details" on page 21

Y VY VY Y

"Troubleshooting" on page 22

Integration Benefits

» SiteScope works together with HPOM to provide a powerful combination
of agentless and agent-based infrastructure management.

» SiteScope is able to communicate with HPOM using the HP Operations
agent, which is installed on the SiteScope server. The agent enables
SiteScope to integrate both events and metrics data.

» SiteScope sends events by writing them to a log file which is
monitored by the HP Operations agent. The agent reads the data and
converts it to common events, which it forwards to the HPOM
management server.

» SiteScope stores the data in the HP Operations agent data storage,
which is collected by Performance Manager and used in Performance
Manager graphs.

19



Chapter 2 e Integrating SiteScope With Operations Manager Products

20

Integration Prerequisites

The following are required to enable the integration:

Prerequisites

Where to Get Details

The HP Operations agent must be installed on
the SiteScope server. If the agent is used only for
integrations (not for monitoring), ignore the
request from HPOM for the agent license.

The agent can be installed during SiteScope
installation, or after SiteScope is installed using
the SiteScope Configuration Tool.

HP SiteScope Deployment
Guide PDF

For HP Operations Manager for Windows 8.1x,
the OMW_00071 patch is required to support the
Node discovery feature in SiteScope-HPOM event
integration.

The Patches page on the HP
Software Support site

If using SiteScope version 11.00, patch SIS_00088
is required to support both the Node and Monitor
discovery features in the event integration.

The Patches page on the HP
Software Support site

The Node discovery feature is not supported for
HP Operations Manager for Linux/UNIX/Solaris
9.0.

Refer to the HPOM
documentation
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Integration Options and Details

The following SiteScope-HPOM integration options are available. Choose
the most suitable for the monitoring environment that exists in your
organization.

Application What to Use Where to Get Details
HP Operations | Events "How to Enable SiteScope to
Manager » Status change: If you Send Events to HPOM or BSM" in
want to manage raw Using SiteScope
(low-level) events. Note: For details on the
» Alerts: If you want to discovery policies, see "Sending
manage alerts as events. EVentS” in USing SiteSCOPe, al’ld

expand Discovery Scripts and

the Drill Down User for Viewing

» Node discovery policy HPOM Events.
(recommended).
Advantage:
Automatically maps
SiteScope events to
nodes created in HPOM
for each node monitored
by SiteScope.

Discovery Policies:

Note: For nodes
monitored by SiteScope
only, you can ignore the
request from HPOM for
a Target Connector
license.

» Monitor discovery
policy (not required).
Advantage:
Automatically maps
SiteScope events to
SiteScope monitors in
HPOM Service
Navigation maps.

21
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Application What to Use Where to Get Details
HP Metrics (required) "How to Enable SiteScope to
Performance Report Metrics to the HP
Manager Operations Agent" in Using
SiteScope
Troubleshooting

» For troubleshooting Operations Manager Event Integration issues, see
"Operations Manager Event Integration Issues" on page 31.

» For troubleshooting Operations Manager Metrics Integration issues, see
"Operations Manager Metrics Integration Issues" on page 44.

Note: Depending on the integration option, the suggested troubleshooting
might be applicable to specific HPOM or BSM applications only.

22



3

Integrating SiteScope with Business
Service Management or Operations
Manager

The following are recommendations for integrating SiteScope with Business
Service Management (BSM) or HP Operations Manager (HPOM):

» [t is recommended to integrate SiteScope directly with BSM’s Operations
Management rather than with HPOM.

» If your deployment prevents you from integrating directly with
Operations Management in BSM, or you want to get event pre-processing
in HPOM before forwarding SiteScope events to Operations Management,
you should integrate SiteScope with HPOM.

Note: Even if you are integrating SiteScope with HPOM, it is
recommended to integrate SiteScope directly with BSM and to configure
SiteScope to report topology to BSM (a System Availability Management
license is required). Reporting topology provides topology-based event
correlation rules and drill down from events to views and related Cls. You
can report topology to BSM with or without metrics. If you do not want
SiteScope metrics to be used in System Availability Management, Service
Level Management, and so forth, report topology without metrics.

For details on integrating SiteScope with BSM, see "How to Configure the
Integration between SiteScope and BSM" in Using SiteScope.

23
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Troubleshooting

» For troubleshooting topology reporting issues, see "Business Service
Management Topology Issues" on page 25.

» For troubleshooting Operations Manager Event Integration issues, see
"Operations Manager Event Integration Issues" on page 31.

» For troubleshooting BSM Metrics integration issues, see "Business Service
Management Metrics Integration Issues" on page 40.

» For troubleshooting Operations Manager Metrics Integration issues, see
"Operations Manager Metrics Integration Issues" on page 44.

» For troubleshooting CI downtime issues, see "Business Service
Management CI Downtime Issues" on page 47.

Note: Depending on the integration option, the suggested troubleshooting
might be applicable to specific HPOM or BSM applications only.
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Troubleshooting SiteScope Integration
Issues

This section describes troubleshooting when integrating SiteScope with
HP Business Service Management (BSM) and HP Operations Manager
(HPOM) products.

» Business Service Management Topology Issues on page 25

» Operations Manager Event Integration Issues on page 31

> Business Service Management Metrics Integration Issues on page 40
» Operations Manager Metrics Integration Issues on page 44

> Business Service Management CI Downtime Issues on page 47

Business Service Management Topology Issues

This section describes troubleshooting and limitations when SiteScope is

integrated with BSM and enabled to report monitor and related CI topology

to BSM.
This section includes:

» "Opening Logs in SiteScope to Debug Mode" on page 26

» "Opening Logs in Business Service Management to Debug Mode" on
page 28

> "No Topology Reported" on page 29
» "ODB Troubleshooting" on page 30

25
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> "Where to Configure the Port to which Data Flow Reports" on page 30

» "Discovery Agent in SSL Environment Limitations" on page 30

Opening Logs in SiteScope to Debug Mode

The following log files in SiteScope contain information relating to the BSM
integration. Open the relevant log files to debug mode using the
instructions listed below.

> SiteScope\logs\bac_integration\bac_integration.log
> SiteScope\logs\bac_integration\discovery.log

> SiteScope\logs\bac_integration\probeGW-taskResults.log

To open logs in SiteScope to debug mode:

1 In the <SiteScope root directory>\conf\core\Tools\log4j\Plainjava
folder, open the bac_integration.properties file and change the debug
level to the following appenders:

# discovery logger
log4j.category.com.hp.ucmdb.discovery=DEBUG, discovery.appender
log4j.additivity.com.hp.ucmdb.discovery=false

# Change ${loglevel} to DEBUG to view topology sent to BAC
log4j.category.com.hp.ucmdb.discovery.probe.services.dynamic.core.TopologyD
ynamicService=DEBUG, discovery.appender
log4j.additivity.com.hp.ucmdb.discovery.probe.services.dynamic.core.TopologyD
ynamicService=false

# Jython logger
log4j.category.PATTERNS_DEBUG=DEBUG, discovery.appender
log4j.additivity. PATTERNS_DEBUG-=false

26
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2 Add the following appender to the probeGW-taskResults.log file:

TR R R R R R R R
R

# Topology task results
R R R R
HHHHHE

log4j.category.ProbeTaskResultsLog=DEBUG, PROBE_TASK_RESULT_FILE
log4j.additivity.Probe TaskResultsLog=false

log4j.appender.PROBE_TASK_RESULT_FILE=org.apache.log4j.RollingFileAppend
er

log4j.appender.PROBE_TASK_RESULT_FILE.MaxFileSize=10MB
log4j.appender.PROBE_TASK_RESULT_FILE.MaxBackuplndex=5
log4j.appender.PROBE_TASK_RESULT_FILE.File=../${log.file.path}/probe GW-
taskResults.log

log4j.appender.PROBE_TASK_RESULT_FILE.Threshold=DEBUG
log4j.appender.PROBE_TASK_RESULT_FILE.Append=true
log4j.appender.PROBE_TASK_RESULT_FILE.layout=org.apache.log4j.PatternLayo
ut

log4j.appender.PROBE_TASK_RESULT_FILE.layout.ConversionPattern=<%d> %-
4r [%-5p] (%F:%L) - %om%n
log4j.appender.PROBE_TASK_RESULT_FILE.encoding=UTF-8

27
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Opening Logs in Business Service Management to Debug
Mode

The following log files in BSM contain information relating to the
integration with SiteScope. Open the relevant log files to debug mode using
the instructions listed below.

> <BSM root directory>\log\odb\odb\mam.autodiscovery.log

» <BSM root directory>\log\odb\odb\cmdb.reconciliation.log

> <BSM root
directory>\log\odb\odb\cmdb.reconciliation.datain.ignored.log

To open logs in BSM (on the Data Processing server machine in a

distributed environment) to debug mode:

Change RTSM debug level in BSM:

» <BSM root directory>\odb\conf\log\reconciliation.properties

» <BSM root directory>\odb\conf\log\mam.properties
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No Topology Reported

1 Open all SiteScope and BSM logs in debug mode. For details, see "Opening
Logs in SiteScope to Debug Mode" on page 26 and "Opening Logs in
Business Service Management to Debug Mode" on page 28.

2 Check if there are \bin files stuck in the
<SiteScope root directory>\cache\topologyresultsData\merged
directory.

3 Check for errors in the logs in the following order:

> bac_integration.log. Topology is not sent due to general errors or
syntax problems in the scripts.

» discovery.log. Get the complete picture of the topology reported from
SiteScope to BSM via Data Flow Management.

> probeGW-taskResults.log. This is the log that shows the topology Data
Flow Management sends to the RTSM server.

>» mam.autodiscovery.log. This log shows the steps Data Flow
Management probe is doing on the topology reporting from SiteScope
to Data Flow Management (bulk creation) and the interaction with the
RTSM server.

» cmdb.reconciliation.log. If the issues are in RTSM server side it is in
most case some reconciliation issues.

» cmdb.reconciliation.datain.ignored.log. topology that is ignored by
RTSM server and not reported.

4 It is recommended to open logs that are in XML format using an XML
editor.

29
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ODB Troubleshooting
To get the properties of a CI reported to a Data Flow database with J]MX:

1 Open http://[<BSM_machine>:21212/jmx-console/ in a Web browser.
2 Click UCMDB:service= Model Services.

3 Invoke method: retrieveObjectProperties.

Where to Configure the Port to which Data Flow Reports

The server settings are initialized in BSM in Admin > System Availability
Management > Topology Settings from the Topology receiver port or
Topology receiver SSL port boxes.

Discovery Agent in SSL Environment Limitations

The following are limitations relating to the path and encrypted password
for trustStore and keyStore in the ssl.properties file in the
<SiteScope root directory>\WEB-INF\classes\security folder:

» The password can be encrypted using the Data Flow Management JMX
Console (not available in SiteScope). The default passwords for keyStore
and trustStore supplied in ssl.properties are "logomania".

» To be available to the Data Flow probe, the Java trustStore password
should be "changeit".

» The MAMTrustStoreExp.jks file must also be located in
<SiteScope root directory>\WEB-INF\classes\security, otherwise it will
not work.
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Operations Manager Event Integration Issues

This section describes troubleshooting when using the HP Operations
Manager integration to send SiteScope events directly to the HPOM
management server or to Operations Management in BSM.

This section includes:

"Installation Problems" on page 31
"Integration Setup Problems" on page 33

"Problems Sending Events" on page 36

Y Y VY Y

"Node Discovery and Monitor Discovery Troubleshooting (HPOM for
Windows only)" on page 39

Tip: When referring to the integration log file, you can open it from the
SiteScope user interface (Server Statistics > Log files >
HPSiteScopeOperationsManagerintegration.log).

Installation Problems
Symptom:

An error occurred while running the HP Operations agent installation in the
SiteScope Configuration Wizard during SiteScope installation.

Troubleshooting:

1 Open the agent installation log, opc_inst.log, in the c:\Windows\Temp,
/var/tmp (Solaris) or /tmp (Linux) folder, and delete opc_inst.lock.

2 Refer to the SiteScope documentation to make sure your operating system
is supported for HP Operations agent installation.

3 Run the SiteScope Configuration Tool, and install the HP Operations
agent again (it is also recommended to restart the server).

4 Run SiteScope Configuration Tool, and uninstall the HP Operations agent
and then install it again (it is also recommended to restart the server).
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5 Manually reinstall the HP Operations agent (it is also recommended to
restart the server).

On Windows:

Uninstall the agent:

a C:\Program Files\HP\HP BTO Software\bin\OpC\install
b cscript opc_inst.vbs -remove -force

¢ From the Control Panel, uninstall the HP Operations Integration
Adapter Policy Activation package.

Install the agent:

a <SiteScope root directory>\install\components\oa\<Operating
System>

b cscript opc_inst.vbs

c Install
<SiteScope root directory>\install\components\oa_policy_signing_to
ol

On UNIX:
a /opt/HP/SiteScope/install/components/oa/solaris/opc_inst -remove
b /opt/HP/SiteScope/install/components/oa/solaris/opc_inst

¢ /opt/HP/SiteScopel/install/components/oa_policy signing_tool/solaris
pkgadd -a HPOprlAPA.admin -d HPOprlAPA-09.00.091-Sun0S5.10-
release.sparc

6 Put a new clean image on the system and install SiteScope and the HP
Operations agent again.

7 Contact your HPOM administrator for assistance.
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Integration Setup Problems
Symptom:

Any problem that occurs while trying to configure the HP Operations
Manager Integration (between connecting the agent to the HPOM/BSM
server and sending a test message).

Troubleshooting:

1 In SiteScope, open the HP Operations Manager Integration setting panel
(Preferences > Integration Preferences > HP Operations Manager
Integration).

2 In the HP Operations Manager Integration dialog box, check the HP
Operations agent installation path.

a Click the Resolve Path button.
b Make sure the agent is installed on the path you see in this field.

» If the agent is installed on a different path, update the path
accordingly.

» If you do not see the path is resolved (probably the agent is not
installed properly), follow the troubleshooting in "Installation
Problems" on page 31.

¢ Make sure your HPOM management server or BSM Gateway host name
is typed correctly in the host field.

3 Click the Analyze button.

a If the command outputs are empty, there is a problem with the agent
installation. Follow the troubleshooting in "Installation Problems" on
page 31.

b Check that the bbutil command output returns status=eServiceOK. If it
does not, there is a connectivity problem to your HPOM server and
you should contact your HPOM administrator for assistance.

¢ Check the opcagt -status command output. You should see a few
processes running (some can be in Aborted state—this is fine at this
stage). If they are not running, manually start the agent by running
command line: opcagt -start, or restart your server machine.
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4 Make sure your HPOM server is up and running.

5 If you are working with BSM, check your Gateway and Data Processing
Server. Run command line ovc -status. Make sure all processes are running
if they do not start with ovc -start.

6 If you are working with a distributed BSM environment (in BSM 9.00 or
later), follow the procedures for initiating trust between your Gateway
and Data Processing Server, and forwarding the certificate request from
the Gateway to the Data Processing Server. For details, see "How to Enable
SiteScope to Send Events to HPOM or BSM" in Using SiteScope.

7 Click the Connect button, and make sure the command output returns:
opcactivate Info: Successfully activated OVO agent.

If it does not, contact your HPOM administrator for assistance.
8 Accept the certificate request.

» When connecting to a BSM server, follow the step for accepting the
agent connection request in "How to Enable SiteScope to Send Events
to HPOM or BSM" in Using SiteScope.

» When connecting to an HPOM management server, consult your
HPOM administrator. If you do not see the certificate request, contact
your HPOM administrator.

9 Click the Analyze button.
Make sure the ovcert -check is ok, and it ends with "Check Succeeded".
Make sure ovcert -list lists some certificates.
c If there are problems with the command outputs:
» Contact your HPOM administrator, or

» Start the integration process troubleshooting from the connect
phase, or even reinstall the agent.
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10 Click the Install Policies button.
a If you get an error here or this process is stuck with "please wait" and:

> You recently reinstalled the agent and did not restart yet, restart
your server.

» Otherwise, there is a problem with the agent (and the additional
policy activation tool package) installation. Reinstall on a clean
image.

b Click the Analyze button, or check the output of the Install Policies for
the list of policies. Make sure you see the following list with all
enabled:

» HP_SiteScope_to_Operations_Manager_Integration_by_Log File
» HP_SiteScope_to_Operations Manager_Integration
» SiteScope_Hosts_Discovery

11 In the Test Message box, type a message and click Send test message.

a Check your HPOM Event Console or Operations Management Event
Browser.

b If you do not see the message in the Event Console/Browser:
» Run command line: opcmsg a=a 0=0 msg_t=xxx

» If the command is not available, something went wrong with the
process so far (either the certificate or the policies does not work).
Try to install the policies again, and if the same problem occurs
contact HP Software Support.

» If the command is executed but you still do not see the message in
the Event Console, contact your HPOM administrator for support.
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Problems Sending Events

Symptom 1:

Sending a test event from the HP Operations Manager Integration dialog
box does not reach the HPOM Event Console/Operations Management
Event Browser.

Troubleshooting:

1

In the HP Operations Manager Integration dialog box, enter a test
message in the Test message box, and click Send test message. If the test
message is not displayed in the Event Console, follow all the steps in
"Integration Setup Problems" on page 33, and then try again.

Click the Analyze button, and make sure all commands are successful (in
particular, see the list of policies installed). For details, see "Integration
Setup Problems" on page 33.

3 Click the Send Test Event button.

In the <SiteScope root directory>\logs directory, check the events log
file, HPSiteScopeOperationsManagerintegration.log. Verify the event
entry in the log file. If you do not see it, contact HP Software Support.

If you still do not see the event in the HPOM Event Console/Operations
Management Event Browser, check you are viewing the correct node in
HPOM, or are not filtering out anything in the Operations Management
Event Browser. If you still do not see the event, contact HP Software
Support.
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Symptom 2:

The metric status change or alert event is not displayed in the HPOM Event
Console/Operations Management Event Browser.

Troubleshooting:

1

Check if the test event is displayed in the Event Console/Browser. If it not
displayed, follow the guidelines for Symptom 1 in "Problems Sending
Events" on page 36 above.

Check that event integration is enabled in the monitor or alert
configuration settings. Change the monitor metric status, or trigger an
alert. In the <SiteScope root directory>\logs directory, check the events
log file, HPSiteScopeOperationsManagerintegration.log.

If you do not see the event entry in the log file, check you enabled event
integration correctly in the monitor or alert you are running (for details,
see "How to Enable SiteScope to Send Events to HPOM or BSM" in Using

SiteScope). 1f it still not in the log file, contact HP Software Support.

If you see the event entry in the log file, but not in the Event
Console/Browser:

Check that no filter is set in the Event Browser.

b If it is a newly-created monitor, and you are filtering the related CI in
Operations Management, it is possible that the CI topology is not
reported yet. Try again in a few minutes.

¢ In HPOM legacy, make sure the event target node exists on your
console.

d Contact HP Software Support.
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Symptom 3:

You see the metric or alert event in the Operations Management Event
Browser, but it has no related CI or HI, or Indicator state or severity.

Troubleshooting:

1 Check the event attribute values in the
HPSiteScopeOperationsManagerintegration.log file located in the
<SiteScope root directory>\logs directory. Look for the HI (ETI) and CI
hint. They should look like this: CPULoad:High:80 and
SiteScope:3:123456 respectively.

a To know the attribute order in this tab separated values line, you can
send a test event before this event and compare the lines. The test
event writes the name of each attribute in its order.

b If the CI Hint or HI hint are unknown, empty, or look different than
the example, there is a problem with the SiteScope configuration.

» Check that the SiteScope is registered to BSM.

» Check that the monitor thresholds have indicator states assigned to
them, or that your alert has some ETI and ETI state set.

» Check the preference setting for reporting SiteScope data in the
monitor configuration is set to Events (in HP Integration Settings >
BSM Service Health Preferences).

2 If everything looks fine in the log file in SiteScope, open the event in the
Operations Management Event Browser.

a In the General tab, check the related Cl attribute. If you do not see the
related CI, select the Resolver tab and check the Status field.

» Check if there is information about the CI resolution failure.

» Check that the monitor topology is available in the RTSM (you can
check this in the System Hardware or System Monitors views).

Note: If this is a newly-created monitor, it will take few minutes for
the topology to arrive and the event to be assigned with a related CI.
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b In the General tab, if you see the related Cl but Event Type Indicator is
empty:

» Select the Resolver tab and check the ETI Hint attribute value sent
by SiteScope. If it is empty or unknown, check your SiteScope
configuration.

» If the value exists but does not show up in Event Type Indicator in
the General tab, there was a problem when applying the indicator to
the CI. Check out Service Health or Operations Management for
support.

Node Discovery and Monitor Discovery Troubleshooting
(HPOM for Windows only)

Node Discovery:
1 Make sure you are using HP Operations Manager for Windows 8.1x with

patch 00071 installed. This patch is required for Node discovery.

2 If you have SiteScope 11.00 (build 2470) or SiteScope 11.01, and you want
to use Monitor discovery, you need to install a SiteScope patch (contact
HP Software Support for patch details).

3 Problems with Node discovery:

a Click the Analyze button in the HP Operations Manager Integration
Preferences dialog box. Make sure you see the
SiteScope_Hosts_Discovery policy installed and enabled.

b Check that your event configuration is set. Send a test event and make
sure you see it in the HPOM Event Console on the SiteScope node.

New nodes are reported within 5 minutes from the time they started to
being monitored by SiteScope monitors.

The discovery policy runs SiteScope scripts that generate XML
consumed by the policy. Each run is logged in the following log:
%OvDataDir%\log\System.txt.
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¢ You can invoke the process manually, by running the following
commands:

ovagtrep -run "SiteScope_Hosts_Discovery"
ovagtrep -publish

Monitor Discovery:

» Follow the instructions in the
SiteScopeMonitorDiscoveryPolicy_readme.docx in the
SiteScope\tools\OMIntegration\SiteScopeMonitorDiscoveryPolicy
directory (available in SiteScope 11.01 and later).

Business Service Management Metrics Integration Issues

This section describes troubleshooting when working with the BSM metrics
integration.

This section includes:

» "If you do not see CI statuses in Service Health, check if there are health
indicators and KPIs assigned to the relevant CI" on page 41

» "If HIs and KPIs are assigned to the relevant CI, check if SiteScope sends
data and that the data is not ignored by BSM" on page 41

» "If HIs and KPIs are assigned to the relevant CI, and samples are not
ignored by the wde logs in BSM, check CI resolution" on page 43

» "If there are no HIs on the relevant CI" on page 43

» "If there are no KPIs on the relevant CI" on page 43
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If you do not see Cl statuses in Service Health, check if
there are health indicators and KPIs assigned to the
relevant Cl

In BSM, select Admin > Service Health > View Management > Cl indicators,
expand the Monitors folder, and select one of the following views: System
Monitors, System Hardware Monitoring, or System Software Monitoring.

In the view you have selected, check if there are HIs and KPIs assigned to the
relevant CI, as follows:

> System Monitors view: SiteScope Monitor or SiteScope Measurement CI
» System Hardware Monitoring view: Node or Computer CI

» System Software Monitoring view: Running Software CI

If His and KPIs are assigned to the relevant Cl, check if
SiteScope sends data and that the data is not ignored by
BSM

1 Run the relevant monitor in SiteScope.

2 On the BSM machine, open the wdelgnoredSamples.log located in
<BSM root directory>\log\wde folder. If this log includes samples of the
monitor you have just run, or you see many ignored samples, this means
SiteScope is sending the wrong data.

3 If you do not see the relevant SiteScope sample, look for it in the
wdePublishedSamples.log and check that Eti_id and ci_hint are not null.
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4 If you cannot find the SiteScope sample in the wde logs in BSM, check in
SiteScope if the sample was generated. Open the
bac_integration.properties file located in
<SiteScope root directory>\conf\core\Tools\log4j\PlainJava and add the
following to the end of the file:

R R R R R
HEHIHHIHEHHR

# Sample printer
R R R R
HEHHHHIHEHHR

log4j.category.SamplePrinter=DEBUG, samples.appender
log4j.additivity.SamplePrinter=false

log4j.appender.samples.appender=org.apache.log4j.RollingFileAppender
log4j.appender.samples.appender.File=../${log.file.path}/samples.log
log4j.appender.samples.appender.MaxFileSize=1000KB
log4j.appender.samples.appender.MaxBackuplndex=5
log4j.appender.samples.appender.layout=org.apache.log4j.PatternLayout
log4j.appender.samples.appender.layout.ConversionPattern=%d [%t] (% F:%L) %-5p
- %m%n

5 Run the monitor, and check the samples.log file in the
<SiteScope root directory>\logs\bac_integration directory.
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If His and KPIs are assigned to the relevant Cl, and
samples are not ignored by the wde logs in BSM, check Cl
resolution

1 Run the relevant monitor in SiteScope.

2 On the BSM machine, open the cir_enrichment.log file located in the
<BSM root directory>\log\wde folder, and check if there are badHint or
Cl not found messages.

Note: To change the log file to debug mode, open the
cir_enrichment_service.properties file located in the

<BSM root directory>\conf\core\Tools\log4j\wde folder and change
loglevel to loglevel=DEBUG.

If there are no Hls on the relevant Ci

If the relevant CI does not have any HlIs, in SiteScope, check the indicator
mappings in the monitor user interface (HP Integration Settings > Indicator
Settings).

If there are no KPIs on the relevant Ci

If the relevant CI does not have any KPIs, check if the HPOM content pack
has KPI assignments.

1 In BSM, select Admin > Service Health > Assignments > KPI Assignments.

2 In the CI Types tree, drill down to the relevant CI (for example,
Infrastructure Element > Node > Computer), and check if the CIT has a
KPI assignment defined. KPI assignments appear in the right pane.
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Operations Manager Metrics Integration Issues

This section describes troubleshooting when using the HP Operations
Manager integration to make SiteScope metrics data available to HP
Performance Manager or to Performance Perspective in BSM’s Operations
Management.

This section includes:
» "SiteScope and HP Operations Agent Configuration" on page 44

> "Health Monitors Errors" on page 46

» "HP Performance Manager Configuration" on page 46

SiteScope and HP Operations Agent Configuration

Check the HP Operations Agent Configuration

1 Check the status of the HP Operations agent installed on the SiteScope
server status by running the following command: opcagt -status

The expected output is:

s and Settings™ = = Jopcagt status
0 £ ge Agent AGENT . EA Ahorted
ion Agent AGENT . ER J Running

U0 MHeszsage Interceptor AGENT . EA 7 Running

If opcacta or opcmsgi are not running, try to restart the agent by running:
opcagt -stop
opcagt -start

2 Select Preferences > Integration Preferences, and select an existing or
create a new HP Operations Manager Integration. Verify that the Enable
HP Operations Manager metrics integration check box is selected.

3 In the HP Integration Settings for the monitor, Verify that the Report
metrics to HP Operations agent check box is selected.

4 Run the monitor, and wait for about a minute.
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5 Run the following command to check if the agent data store contains the
data:

set CODAMAGIC=0X05201993
ovcodautil -obj -ds AGENTLESS

You should receive object names from AGENTLESS data source (similar to
the following):

ovcodauntil —obj —ds AGENTLESS

AGENTLESS

NumnOhbj

AGENT L EMHORY
AGENT L JALDISK
MGENTL

SOR
R_WORK_QUEUES

MONITOR
CHE

QUERY
E

GE A
AGENT L ORACLE?IAS _HTTP_SERUVER

Data source: AGENTLESS
MunMetrics = 128

To dump the summarized last record for AGENTLESS data source, run the
following command:

ovcodautil -dumpds AGENTLESS
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Check the Relevant SiteScope Logs

Check the following logs that are available from the <SiteScope root
directory>\logs directory:

> error.log
> RunMonitor.log
» om_metric_integration.log

> data_integration.log

Health Monitors Errors

In the SiteScope monitor tree, expand Health and click Log Event Checker.
» If the Failed to report data to HP OM Agent counter is in error, SiteScope
failed to connect or report data to the HP Operations agent using Java

API. For more information, see the oa_metric_integration.log file in the
<SiteScope root directory>\logs directory.

» If the Generic Data Integration queue exceeded allowed size counter is in
error, the queue of metrics waiting to be sent is oversized and some
metrics were dropped to maintain SiteScope stability. For more
information, data_integration.log file in the <SiteScope root
directory>\logs directory.

HP Performance Manager Configuration

1 On the Performance Manager server, open the OVPMconfig.ini file in the
%ovdatadir%\shared\server\conf\perf directory.

2 Update the SiteScope server details as follows:
» [SITESCOPE]
» SERVER = servername
» NODEGROUP = Agentless

3 Restart the HP Openview Tomcat(B) service.
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Business Service Management Cl Downtime Issues

This section describes troubleshooting CI downtime issues when SiteScope is
integrated with BSM.

This section includes:

» "Troubleshooting CI Downtime (BSM-side)" on page 47

» "Troubleshooting CI Downtime (SiteScope-side)" on page 48

Troubleshooting Cl Downtime (BSM-side)

If the SiteScope monitor is still running after configuring downtime on a
specific node using the stop monitoring option, perform the following
checks on BSM:

1 Check SiteScope reported topology to BSM. In BSM, select Admin > ODB
Administration, and check the node and monitor Cls.

2 Logs:

» Open <BSM root
directory>\conf\core\Tools\log4j\Plainjava\topaz.properties and
change the debug level to the following appender:

log4j.category.com.mercury.topaz.sitescopetmc=DEBUG, aims.appender
» Open the aims.ejb.log file located in <BSM root
directory>\log\EJBContainer and search for "downtime" string. Check

whether your downtime was created, which CIs were affected by it,
and when a downtime request was made from SiteScope.
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Troubleshooting Cl Downtime (SiteScope-side)

If the SiteScope monitor is still running after configuring downtime on a
specific node using the stop monitoring option, perform the following
checks on SiteScope:

1 In Preferences > Infrastructure Preferences > General Settings, check the
Enable downtime mechanism setting is enabled.

2 Check the following logs:
> <SiteScope root directory>\logs\audit.log

> <SiteScope root directory>\logs\downtime.log

To open these logs to debug mode:

a In the <SiteScope root directory>\conf\core\Tools\log4j\Plainjava
folder, open the log4j.properties file.

b Change the debug level to the following appenders:

# Downtime logger
log4j.category.com.mercury.sitescope.integrations.bac.downtime=DEBUG,
downtime.appender
log4j.additivity.com.mercury.sitescope.integrations.bac.downtime=false
log4j.category.com.mercury.sitescope.platform.downtime=DEBUG,
downtime.appender
log4j.additivity.com.mercury.sitescope.platform.downtime=false
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