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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2007–2011 Hewlett-Packard Development Company, L.P.

Trademark Notices
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Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.

Oracle is a registered trademark of Oracle Corporation and/or its affiliates.
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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

You can visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and support that HP 
Software offers.

HP Software Support Online provides customer self-solve capabilities. It provides a fast and efficient way to 
access interactive technical support tools needed to manage your business. As a valued support customer, you 
can benefit by using the HP Software Support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 

To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 
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1 Getting Started
The Financial Planning & Analysis installation package guides the installation and 
configuration of all the components necessary to run the application successfully. 

Installation Prerequisites

There are requirements for drivers and external tools that the Financial Planning & Analysis 
application needs to run successfully. For example, you need a Java Runtime Environment 
(JRE), the right Microsoft SQL Server software and drivers, and a new (or existing) 
installation of 
SAP® BusinessObjects Enterprise XI 3.1 (BOE) to manage the data used by Financial 
Planning & Analysis. For more information about the environment requirements, read 
Chapter 2, Requirements.

Data Warehouse

The installation process builds a data warehouse, using your external RDBMS, that is the 
repository for key business data that is cleansed, consolidated, and organized to support 
efficient queries, reports, and to populate a variety of business analytics. The contents of the 
data warehouse depend on the external HP applications that generate business data. For 
example, the data may originate with an HP Financial applications such as Asset Manager, or 
HP Demand and Portfolio Management applications like Project and Portfolio Management.

The data warehouse consolidates the data from one or more of these external applications and 
makes it available for analysis by Financial Planning & Analysis.

Distributed or Consolidated Environment?

You can consolidate all of the required components, such as the RDBMS, data warehouse, 
BOE, and Financial Planning & Analysis on a single server as shown in Figure 2 on page 14. 
This configuration is useful for building prototypes and test environments. 

For production, it is probable that you will need to deploy the components in a distributed 
environment. In that case, the metadata, staging, target, and ABC components can be 
configured in separate databases on separate servers.

To use a distributed environment successfully, your RDBMS must be 
Microsoft SQL Server. 
11



This distributed environment might look different in different installations, depending on 
how you decide to deploy each component. For example:

Case 1: You could define one database for the metadata on one server, a separate database for 
staging on the same server, and merge the target and ABC areas into a single database on 
another server. 

Case 2: You could define four separate databases on separate servers, one each for metadata, 
staging, target, and ABC. 

Distributed Server Environment

Most combinations of servers and deployment scenarios will work in a distributed 
environment. Although you can install all components on one server, the data warehouse 
typically runs in a distributed server environment. Data sources are usually on remote 
servers. 

Before you begin the Financial Planning & Analysis installation process, verify that you have 
an existing RDBMS server running Microsoft SQL Server 2005, and that you have network 
connections to your remote data sources. Figure 1 shows the recommended distributed 
configuration after you complete the Financial Planning & Analysis installation process.

Figure 1 Distributed Server Environment
.
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Supported Configuration Variations

If you already use BOE for other applications, or you have Apache Tomcat running on another 
server, you can eliminate the Financial Planning & Analysis web server by:

• Installing the Financial Planning & Analysis web application on the BOE server. See 
Existing BOE Server.

and

• Using the BOE-embedded instance of Tomcat to run the Financial Planning & Analysis 
web application. See Existing BOE Server.

You can modify the Financial Planning & Analysis installation scenario to accommodate 
existing instances of BOE and Apache Tomcat.

Existing BOE Server

You do not have to install a second instance that is dedicated to Financial Planning & 
Analysis. You can use an existing BOE installation on a separate server, but it must be 
version 3.1 and have the fix packs required by Financial Planning & Analysis. 

• If this is the case, skip Chapter 6, Installing SAP BusinessObjects Enterprise and proceed 
to Chapter 7, Installing the Data Warehouse Server.

• You can use the BOE Apache Tomcat server to run other web applications, such as BODS 
and Financial Planning & Analysis. It is not necessary to create multiple instances of 
Tomcat.

• After the installation is complete, make sure that you enable enterprise authentication on 
the existing BOE server. For more information, see Chapter 9, Configuring User Roles 
and Authentication.

Non-BOE Tomcat

You may have an existing instance of Apache Tomcat on another server that you want to use 
to deploy the Financial Planning & Analysis web application. You can use it instead of the 
BOE Tomcat if it meets the version requirements described in the HP Financial Planning & 
Analysis 9.10 Compatibility Matrix. For more information, see Chapter 2, Requirements.

The Appendix C, Installation Checklist appendix prompts you to gather this information 
before you begin the installation process.When you complete the tasks in Chapter 8, 
Installing the Web Application and Antivia XWIS, you must specify the location of this 
existing Tomcat installation directory and its service name, the login name, and the password 
to be used by Financial Planning & Analysis. 

Unsupported Configuration Variations

There are some installation scenarios that are not supported. In general, you should follow 
the described multiple server or single server scenarios described in this chapter. Only the 
exceptions noted in Existing BOE Server or Non-BOE Tomcat are supported. If you customize 
the server combination scenarios, you may not be able to install components successfully. For 
example, you cannot use an existing instance of BODS on a different server. You must install 
a new instance on the data warehouse server.
13



Consolidated Server Environment

You can replicate a distributed configuration on a single server. In this scenario, all 
components share the same server. BODS has an integrated installation with BOE where 
BODS shares the Apache Tomcat instance installed with BOE.

You must have an RDBMS installation of Microsoft SQL Server 2005 on that server before 
you begin the Financial Planning & Analysis installation process. The data sources can be 
remote or local. Complete the installation of all other components on the same server. 
Figure 2 on page 14 shows a consolidated configuration where all components are on the same 
server.

Figure 2  Consolidated Environment

Other HP Software Products

The data warehouse imports source data created by other HP applications using an integral 
ETL process. This source data should reside on servers that are separate from the installed 
Financial Planning & Analysis and related data warehouse components.

Installation Media

The installation media consolidates all the required components into two DVDs. DVD 1, 
labeled HP Financial Planning & Analysis 9.10, contains all the application installation files 
for BOE, BODS, the Financial Planning & Analysis application, and the data warehouse. Use 
this DVD to complete the tasks described in Chapter 7 through Chapter 9. 

DVD 2, labeled Dashboard Development Kit, contains the installation files for the optional 
installation of SAP BusinessObjects Xcelsius 2008 SP3 and the Antivia Xcelsius™ Web 
Intelligence Integration Suite (XWIS)  add-on. Install these products if you plan to use the 
dashboard feature of the Financial Planning & Analysis application. For more information, 
see Appendix A, Installing SAP BusinessObjects Xcelsius and the Xcelsius XWIS Add-On.
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Installation Guide Overview

This guide contains information about how to install the HP Data Warehouse. Table 1 
summarizes the content of each chapter.

Other Documentation Resources

There are other documentation sources that you need to reference for data management and 
administration tasks. 

When you complete all the tasks described in this guide to install and configure a complete 
working environment for the Financial Planning & Analysis application, you can turn to the 
HP Data Warehouse Administration Guide for the information you need to prepare the data 

Table 1 Document Map

Chapter Describes

Chapter 1, Getting Started Product overview.

Chapter 2, Requirements Hardware, software, and other requirements.

Chapter 4, HP Licensing How to obtain your license keys and 
passwords.

Chapter 3, Configuring Required Databases Everything that you need to define on the 
RDBMS server.

Chapter 5, Installing Financial Planning & 
Analysis

The Financial Planning & Analysis 
installation and configuration tools.

Chapter 6, Installing SAP BusinessObjects 
Enterprise

Everything that you need to install and 
configure on the BOE server.

Chapter 7, Installing the Data Warehouse 
Server

Everything that you need to install and 
configure on the data warehouse server.

Chapter 8, Installing the Web Application 
and Antivia XWIS

Everything that you need to install and 
configure on the FPA web server.

Chapter 9, Configuring User Roles and 
Authentication

Configuring user access for LDAP or Active 
Directory.

Chapter 10, Next Steps The remaining tasks for the initial sync and 
ETL run.

Appendix A, Installing SAP 
BusinessObjects Xcelsius and the Xcelsius 
XWIS Add-On

How to install BusinessObjects Xcelsius and 
Antivia Xcelsius™ Web Intelligence 
Integration Suite (XWIS).

Appendix B, Setting Up File Based 
Authentication

Configuring user access for file based 
authentication.

Appendix C, Installation Checklist Checklists of server names, passwords, and 
paths that you need to gather before you 
begin the installation.
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warehouse for the first ETL job and other ongoing maintenance tasks. This guide, and related 
Financial Planning & Analysis documentation, is available on the product manuals web site 
at HP Software Product Manuals (http://h20230.www2.hp.com/selfsolve/manuals).

This site requires you to register as an HP Passport user and sign in. To register for an HP 
Passport, go to HP Passport Registration (http://h20229.www2.hp.com/
passport-registration.html).

For all BOE or BODS tasks and troubleshooting, refer to the BOE documentation that 
accompanies the BusinessObjects installation software.

Before You Begin

You can avoid problems by reading Chapter 2, Requirements carefully. Review the Support or 
Compatibility Matrix for each HP application that will access the data warehouse to ensure 
that you have the required environment for all applications to export data to, or import data 
from, the data warehouse. For more information, see the HP Software Support web site 
(http://support.openview.hp.com/sc/support_matrices.jsp).
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2 Requirements
Read this chapter to learn more about the preparation required before you begin the Financial 
Planning & Analysis installation. 

• Hardware Requirements on this page

• Operating System Requirements on page 18

• Third Party Software Requirements on page 18

• Other Requirements on page 19

Hardware Requirements

Table 2 describes the minimum hardware requirements for the data warehouse. If you have a 
consolidated server environment, make sure that this server meets the combined total 
minimum space requirement. HP also recommends that you increase the number of 
processors for this single server to four. 

Table 2 Hardware Requirements

Item Minimum Requirement

RAM Tomcat application server: 2 GB.
Data warehouse server: 2 GB.
SAP BusinessObjects Enterprise XI 3.1 (BOE) server with SAP Business 
Objects Data Services XI 3.1 (BODS) job server: 4 GB.
Web server: 2 GB.

Virtual 
Memory

Tomcat application server: 2 GB.
Data warehouse server: 2 GB.
BOE server with BODS job server: 4 GB.
Web server: 2 GB.

Disk Space Tomcat application server: 3 GB.
Data warehouse server: 5 GB. 
BOE server with BODS job server: 10 GB.†
Web server: 2 GB.

† You can install BOE on an auxiliary disk drive; however, the installation process requires a 
minimum of 5 GB of temporary file space on the C drive. Do not begin the installation until 
you verify that you have this free space available.
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Operating System Requirements

All servers in the Financial Planning & Analysis environment require the Windows Server™ 
2003 operating system with SP2. SAP BusinessObjects Xcelsius software can run on Windows 
XP or Vista operating systems.

Third Party Software Requirements

The data warehouse requires third party components to support importing and exporting 
data. Use the Self-solve knowledge search feature on the HP Support web site to locate the 
Financial Planning & Analysis 9.10 Compatibility Matrix (HP software support 
(www.hp.com/go/hpsoftwaresupport). You must meet all software and hardware 
requirements described in the HP Financial Planning and Analysis 9.10 Compatibility Matrix 
before you begin the installation process.

Java Memory Options

The Java virtual machine that runs the Tomcat application server hosting both the Financial 
Planning & Analysis web application and BOE Web tier requires specific memory options. 

Note: If you have an external Tomcat, you must set the memory options to ensure that the 
BOE installation works.

If you use the Tomcat embedded with BOE, no additional configuration is required. If you 
have an external Tomcat instance, use the Configuration Tool to specify the Tomcat location, 
Service name, and whether the Configuration Tool can modify the server.xml file. Then 
configure the JVM running the Tomcat service with the following memory options. These are 
the minimum required values by BOE:  

-Xmx1024m -XX:MaxPermSize=256m

To update Java memory options:

1 From the Windows Start menu, click > All Programs > Tomcat > Tomcat Configuration.

2 Click the Java tab.

3 Add these memory settings to Java Options:

-Xmx1024m

-XX:MaxPermSize=256m

4 Click Apply and OK.

If you have other applications that the Java virtual machine is hosting, you may have to 
adjust this setting. 

For more information, see your Java or Apache Tomcat documentation.

Microsoft Patches

Install these Microsoft operating system patches before you begin the installation process.

• Install the Microsoft Windows Server 2003 (KB925336) patch on the SAP Business 
Objects software server.
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 For more information, see the Microsoft Download Center web site 
(www.microsoft.com/downloads/details.aspx?
FamilyId=8EFFE1D9-7224-4586-BE2B-42C9AE5B9071&displaylang=en)

• Install the Microsoft Visual C++ 2005 SP1 Redistributable Package (x86) patch 
that contains Visual C++ Libraries runtime components on any server where you plan to 
install Financial Planning & Analysis components. In a distributed server environment, 
make sure that you install this patch on the Financial Planning & Analysis, Data 
Warehouse, and SAP Business Objects servers. 

For more information, see the Microsoft Download Center web site 
(http://www.microsoft.com/downloads/details.aspx?
FamilyID=200b2fd9-ae1a-4a14-984d-389c36f85647&displaylang=en).

• If you do not have an installed version of Microsoft Core XML Services (MSXML) 6.0 SP1, 
install the following on the BOE server:

— Microsoft Core XML Services (MSXML) 6.0 Service Pack 1 (msxml6_x86.msi).

For more information, see the Microsoft Download Center web site 
(http://www.microsoft.com/downloads/details.aspx?displaylang=en&
FamilyID=d21c292c-368b-4ce1-9dab-3e9827b70604) and see 
(http://www.microsoft.com/downloads/details.aspx?
FamilyId=59914795-60c7-4ebe-828d-f28cb457e6e3&displaylang=en)

Other Requirements

Review and verify that the servers where you plan to install Financial Planning & Analysis 
components meet the requirements described in the HP Financial Planning & Analysis 9.10 
Compatibility Matrix. There are other considerations before you begin the complete Financial 
Planning & Analysis installation process. Make sure that:

• You have Administrator rights to access your database server, the name of the server, and 
the password.

• Users who will log on to the BOE server have appropriate rights.

• You have the JRE version described in the HP Financial Planning & Analysis 9.10 
Compatibility Matrix on every server where you plan to install a Financial Planning & 
Analysis component.

• You create a JAVA_HOME environment variable that points to the supported JRE on 
every server where you plan to install a Financial Planning & Analysis component. In 
case there are multiple versions installed on any server, JAVA_HOME will always point to 
the correct JRE.

License Requirements

If you have an existing BOE installation, you can use that instance. If you purchase BOE with 
the HP application, the purchase includes the required licenses.

Microsoft Core XML Services (MSXML) 6.0 Service Pack 2 
(msxml6-KB954459-enu-x86.exe) is an optional security patch on MSXML 6.0 
SP1.
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Other applications that generate or use data require separate licenses. For more information 
about licenses, contact your HP sales representative or visit the HP software support 
(www.hp.com/go/hpsoftwaresupport) web site. If you obtain SAP BusinessObjects 
software products from HP, the HP License Key Delivery Service web site 
(webware.hp.com) manages HP software licensing for the Financial Planning & Analysis 
application. For more information, see Chapter 4, HP Licensing.
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RDBMS License Requirements

Obtain Microsoft SQL Server 2005 Enterprise Edition software and license keys directly from 
Microsoft Corporation to manage the BOE, data warehouse, target and staging databases.

In addition, BODS requires an Oracle client installation on the data warehouse server. If you 
do not have Oracle Database 10g client software, go to the Oracle.com site to download and 
install the free Database 10g Instant Client version 10.2.0.4 software before you begin the 
tasks in Chapter 7, Installing the Data Warehouse Server. 
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3 Configuring Required Databases
The supported RDBMS is Microsoft SQL Server 2005. Verify that you have a complete 
installation and configuration of the RDBMS server environment before you install the 
Financial Planning & Analysis components. There are required databases that you must 
create on the RDBMS server and ODBC connections that you must define to connect 
Financial Planning & Analysis applications and the Financial Planning & Analysis data 
warehouse to these databases. Figure 3 shows the RDBMS server and the resident databases 
to be configured. Complete these tasks on the RDBMS server.

• Task 1: Install Microsoft SQL Server 2005 SP2 and sqlcmd Utility on page 24.

• Task 2: Set Authentication Properties on page 25.

• Task 3: Enable TCP/IP on page 25.

• Task 4: Create the Required Databases on page 26.

• Task 5: Configure the BODS Database Port Number on page 33.

Complete this task on the data warehouse server:

• Task 6: Verify the RDBMS Clients on page 34.
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Figure 3 RDBMS server

Task 1: Install Microsoft SQL Server 2005 SP2 and sqlcmd Utility

Any installation of Microsoft SQL Server 2005 must have Microsoft SQL Server 2005 service 
pack (SP) 2 applied. If you already installed SP2 and you are working in the single server 
configuration, you can proceed to Task 2: Set Authentication Properties.

If your data warehouse is on a separate server, as shown in Figure 3 on page 24, and your 
data warehouse server does not have SQL Server 2005 client/server components installed, for 
example, no SQL Server Management Studio, you must install both the Microsoft SQL Server 
2005 sqlcmd utility and the Microsoft SQL Server Native Client on the data warehouse server. 
Note that the Microsoft SQL Server 2005 sqlcmd utility and the Microsoft SQL Server Native 
Client can be found in the Feature Pack for Microsoft SQL Server 2005 on the RDBMS 
server.

For more information, see the Microsoft Download web site 
(http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c
-4479-9b91-9e8b9d835cdc&displaylang=en).

To make sure that any directory can call the sqlcmd utility, after you install the utility, edit 
the Path system variable to add the directory location of the sqlcmd utility.
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Task 2: Set Authentication Properties

To set your server authentication properties, follow these steps.

1 From the Windows Start menu, click > All Programs > Microsoft SQL Server 2005 > SQL 
Server Management Studio.

2 Log in the with appropriate credentials.

3 In the Object Explorer, right-click the server name and select Properties.

4 Click Security in the left navigation pane (Select a page). 

5 If necessary, select SQL Server and Windows Authentication mode, shown in Figure 4.

Figure 4 Server Security Properties

Task 3: Enable TCP/IP

To enable TCP/IP, follow these steps.

1 From the Windows Start menu, click > All Programs > Microsoft SQL Server 2005 > 
Configuration Tools > SQL Server Configuration Manager.

2 In the navigation pane, expand SQL Server 2005 Network Configuration.

3 Click Protocols for MSSQLSERVER. 

4 If necessary, right-click TCP/IP and select Enable. Figure 5 shows the correct Protocol 
settings.
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Figure 5 Configuration Manager

Task 4: Create the Required Databases

Follow the instructions  in this section to create the six databases that FPA requires:

• A BusinessObjects Enterprise (BOE) Central Management Server (CMS) database, which 
manages security, metadata, and content such as reports and universes.

• A BOE Audit database, which monitors user actions and helps track and manage your 
BOE deployment.

• A BusinessObjects DataServices (BODS) database, required by DataServices.

• An FPA staging database for ETL.

• An FPA target database for ETL.

• An Antivia Xcelsius Web Intelligence Integration Suite (XWIS) database, which contains 
data such as business intelligence system entries and XWIS license and user information.

Guidelines for creating databases

Follow these guidelines when you create the required databases:

• Before you create the databases, make sure that each database is on a separate named 
instance of Microsoft SQL Server. For more information, see your Microsoft SQL Server 
documentation.

• You can refer to the information in Database Naming Conventions on page 113 for tips 
about database names. The names of the databases are user-defined but if you use the 
suggested names in this guide, the names will be descriptive and meet all syntax 
requirements. For later reference, the name in the Checklist should be the same value 
that you specify in the naming process.

• When you define each required database, you must specify a collation that supports 
Unicode nchar, nvarchar and ntext column data types.

Note: You will create the ODBC connections to these databases when you begin the BOE 
server installation in Chapter 6, Installing SAP BusinessObjects Enterprise.
26 Chapter : Configuring Required Databases



• The login for each BOE database must have read/write/administration rights.

• The default database for the boecms login must be the boecms database.

• The default database for the boeaudit login must be the boeaudit database.

Create the BOE CMS Database

1 From the Windows Start menu, select Programs > Microsoft SQL Server 2005 > SQL Server 
Management Studio.

2 Log in to SQL Server Management Studio.

3 Select Databases in the Object Explorer pane, right-click, and select New Database. The 
New Database window opens.

4 On the General page, type the database name. Do not create a BOE CMS database with 
embedded blanks or special characters in the database name.
Example: boecms
Invalid names: boe cms, boe@cms

5 Click Options to open the Options page.

6 Select SQL_Latin1_General_CP1_CI_AS from the Collation drop-down list. This collation 
type supports Unicode nchar, nvarchar, and ntext column data types.

7 Click OK.

8 In the Object Explorer pane, select the Security folder. This is the Security folder for the 
main server. Right-click the folder, and select New > Login. The Login - New window opens.

9 On the General page, type the login name. You must create a different login name for the 
CMS, Audit, BODS, FPA staging, FPA target, and XWIS databases.

10 Select SQL Server authentication.

11 In the Password field, type the password for the login name. Then retype the password in 
the Confirm password field.

12 Clear the Enforce password policy, Enforce password expiration, and User must change 
password at next login check boxes.

13 Select the BOE CMS database name from the Default database drop-down list.

14 Click Server Roles to open the Server Roles page.

15 Select the public (if available) and sysadmin roles.

16 Click User Mapping to open the User Mapping page.

17 In the Users mapped to this login area, select the CMS database that you just created. 
The Users column becomes populated with the login name that you created in step 8.

18 In the Default Schema column, click in the cell to the right of the User column, and type 
the same value that appears in the User column.

19 Press Enter.

20 In the Database role membership for area, select db_owner. Also make sure that public is 
selected.

21 Click OK.

For information about additional database and security settings, refer to the Microsoft SQL 
Server documentation.
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Create the BOE Audit Database

1 From the Windows Start menu, select Programs > Microsoft SQL Server 2005 > SQL Server 
Management Studio.

2 Log in to SQL Server Management Studio.

3 Select Databases in the Object Explorer pane, right-click, and select New Database. The 
New Database window opens.

4 On the General page, type the database name. Do not create a BOE Audit database with 
embedded blanks or special characters in the database name.
Example: boeaudit
Invalid names: boe audit, boe@audit

5 Click Options to open the Options page.

6 Select SQL_Latin1_General_CP1_CI_AS from the Collation drop-down list. This collation 
type supports Unicode nchar, nvarchar, and ntext column data types.

7 Click OK.

8 In the Object Explorer pane, select the Security folder. This is the Security folder for the 
main server. Right-click the folder, and select New > Login. The Login - New window opens.

9 On the General page, type the login name. You must create a different login name for the 
CMS, Audit, BODS, FPA staging, FPA target, and XWIS databases.

10 Select SQL Server authentication.

11 In the Password field, type the password for the login name. Then retype the password in 
the Confirm password field.

12 Clear the Enforce password policy, Enforce password expiration, and User must change 
password at next login check boxes.

13 Select the BOE Audit database name from the Default database drop-down list.

14 Click Server Roles to open the Server Roles page.

15 Select the public (if available) and sysadmin roles.

16 Click User Mapping to open the User Mapping page.

17 In the Users mapped to this login area, select the Audit database that you just created. 
The Users column becomes populated with the login name that you created in step 8.

18 In the Default Schema column, click in the cell to the right of the User column, and type 
the same value that appears in the User column.

19 Press Enter.

20 In the Database role membership for area, select db_owner. Also make sure that public is 
selected.

21 Click OK.

For information about additional database and security settings, refer to the Microsoft SQL 
Server documentation.
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Create the BODS Database

1 From the Windows Start menu, select Programs > Microsoft SQL Server 2005 > SQL Server 
Management Studio.

2 Log in to SQL Server Management Studio.

3 Select Databases in the Object Explorer pane, right-click, and select New Database. The 
New Database window opens.

4 On the General page, type the database name. Do not create a BODS database with 
embedded blanks or special characters in the database name.
Example: bodsrepo
Invalid names: bods repo, bods@repo

5 Click Options to open the Options page.

6 Select SQL_Latin1_General_CP1_CI_AS from the Collation drop-down list. This collation 
type supports Unicode nchar, nvarchar, and ntext column data types.

7 Click OK.

8 In the Object Explorer pane, select the Security folder. This is the Security folder for the 
main server. Right-click the folder, and select New > Login. The Login - New window opens.

9 On the General page, type the login name. You must create a different login name for the 
CMS, Audit, BODS, FPA staging, FPA target, and XWIS databases.

10 Select SQL Server authentication.

11 In the Password field, type the password for the login name. Then retype the password in 
the Confirm password field.

12 Clear the Enforce password policy, Enforce password expiration, and User must change 
password at next login check boxes.

13 Select the BODS database name from the Default database drop-down list.

14 Click Server Roles to open the Server Roles page.

15 Select the public (if available) and sysadmin roles.

16 Click User Mapping to open the User Mapping page.

17 In the Users mapped to this login area, select the BODS database that you just created. 
The Users column becomes populated with the login name that you created in step 8.

18 In the Default Schema column, click in the cell to the right of the User column, and type 
the same value that appears in the User column.

19 Press Enter.

20 In the Database role membership for area, select db_owner. Also make sure that public is 
selected.

21 Click OK.

For information about additional database and security settings, refer to the Microsoft SQL 
Server documentation.
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Create the FPA Staging Database

1 From the Windows Start menu, select Programs > Microsoft SQL Server 2005 > SQL Server 
Management Studio.

2 Log in to SQL Server Management Studio.

3 Select Databases in the Object Explorer pane, right-click, and select New Database. The 
New Database window opens.

4 On the General page, type the database name. Do not create an FPA staging database 
with embedded blanks or special characters in the database name.
Example: fpastaging
Invalid names: fpa staging, fpa@staging

5 Click Options to open the Options page.

6 Select SQL_Latin1_General_CP1_CI_AS from the Collation drop-down list. This collation 
type supports Unicode nchar, nvarchar, and ntext column data types.

7 Click OK.

8 In the Object Explorer pane, select the Security folder. This is the Security folder for the 
main server. Right-click the folder, and select New > Login. The Login - New window opens.

9 On the General page, type the login name. You must create a different login name for the 
CMS, Audit, BODS, FPA staging, FPA target, and XWIS databases.

10 Select SQL Server authentication.

11 In the Password field, type the password for the login name. Then retype the password in 
the Confirm password field.

12 Clear the Enforce password policy, Enforce password expiration, and User must change 
password at next login check boxes.

13 Select the FPA staging database name from the Default database drop-down list.

14 Click Server Roles to open the Server Roles page.

15 Select the public (if available) and sysadmin roles.

16 Click User Mapping to open the User Mapping page.

17 In the Users mapped to this login area, select the FPA staging database that you just 
created. The Users column becomes populated with the login name that you created in 
step 8.

18 In the Default Schema column, click in the cell to the right of the User column, and type 
the same value that appears in the User column.

19 Press Enter.

20 In the Database role membership for area, select db_owner. Also make sure that public is 
selected.

21 Click OK.

For information about additional database and security settings, refer to the Microsoft SQL 
Server documentation.
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Create the FPA Target Database

1 From the Windows Start menu, select Programs > Microsoft SQL Server 2005 > SQL Server 
Management Studio.

2 Log in to SQL Server Management Studio.

3 Select Databases in the Object Explorer pane, right-click, and select New Database. The 
New Database window opens.

4 On the General page, type the database name. Do not create an FPA target database with 
embedded blanks or special characters in the database name.
Example: fpatarget
Invalid names: fpa target, fpa@target

5 Click Options to open the Options page.

6 Select SQL_Latin1_General_CP1_CI_AS from the Collation drop-down list. This collation 
type supports Unicode nchar, nvarchar, and ntext column data types.

7 Click OK.

8 In the Object Explorer pane, select the Security folder. This is the Security folder for the 
main server. Right-click the folder, and select New > Login. The Login - New window opens.

9 On the General page, type the login name. You must create a different login name for the 
CMS, Audit, BODS, FPA staging, FPA target, and XWIS databases.

10 Select SQL Server authentication.

11 In the Password field, type the password for the login name. Then retype the password in 
the Confirm password field.

12 Clear the Enforce password policy, Enforce password expiration, and User must change 
password at next login check boxes.

13 Select the FPA target database name from the Default database drop-down list.

14 Click Server Roles to open the Server Roles page.

15 Select the public (if available) and sysadmin roles.

16 Click User Mapping to open the User Mapping page.

17 In the Users mapped to this login area, select the FPA target database that you just 
created. The Users column becomes populated with the login name that you created in 
step 8.

18 In the Default Schema column, click in the cell to the right of the User column, and type 
the same value that appears in the User column.

19 Press Enter.

20 In the Database role membership for area, select db_owner. Also make sure that public is 
selected.

21 Click OK.

For information about additional database and security settings, refer to the Microsoft SQL 
Server documentation.
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Create the Antivia XWIS Database

1 From the Windows Start menu, select Programs > Microsoft SQL Server 2005 > SQL Server 
Management Studio.

2 Log in to SQL Server Management Studio.

3 Select Databases in the Object Explorer pane, right-click, and select New Database. The 
New Database window opens.

4 On the General page, type the database name. Do not create an XWIS database with 
embedded blanks or special characters in the database name.
Example: antiviaxwis
Invalid names: antivia xwis, antivia@xwis

5 Click Options to open the Options page.

6 Select SQL_Latin1_General_CP1_CI_AS from the Collation drop-down list. This collation 
type supports Unicode nchar, nvarchar, and ntext column data types.

7 Click OK.

8 In the Object Explorer pane, select the Security folder. This is the Security folder for the 
main server. Right-click the folder, and select New > Login. The Login - New window opens.

9 On the General page, type the login name. You must create a different login name for the 
CMS, Audit, BODS, FPA staging, FPA target, and XWIS databases.

10 Select SQL Server authentication.

11 In the Password field, type the password for the login name. Then retype the password in 
the Confirm password field.

12 Clear the Enforce password policy, Enforce password expiration, and User must change 
password at next login check boxes.

13 Select the XWIS database name from the Default database drop-down list.

14 Click Server Roles to open the Server Roles page.

15 Select the public (if available) and sysadmin roles.

16 Click User Mapping to open the User Mapping page.

17 In the Users mapped to this login area, select the XWIS database that you just created. 
The Users column becomes populated with the login name that you created in step 8.

18 In the Default Schema column, click in the cell to the right of the User column, and type 
the same value that appears in the User column.

19 Press Enter.

20 In the Database role membership for area, select db_owner. Also make sure that public is 
selected.

21 Click OK.

For information about additional database and security settings, refer to the Microsoft SQL 
Server documentation.
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Task 5: Configure the BODS Database Port Number

When you install BODS on the data warehouse server, you will have to create a connection to 
the BODS database on the RDBMS server. To complete this task, you will need the port 
number.

1 From the Windows Start menu, click > Programs > Microsoft SQL Server 2005 > Configuration 
Tools > SQL Server Configuration Manager.

2 In the navigation pane, expand SQL Server 2005 Network Configuration.

3 Click Protocols for MSSQLSERVER. 

4 Right-click TCP/IP and select Properties. 

5 Select the IP Addresses tab.

6 If necessary, expand (or scroll down to) the IPAll section.

7 Record the TCP Port number in the 2a) BODS Configuration Information section of the 
Checklist on page 116. You will need this information later. 
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Task 6: Verify the RDBMS Clients

Verify that there is RDBMS client software installed on the data warehouse server. You must 
have two clients: 

• A Microsoft SQL Server 2005 client to support connection to the databases on the RDBMS 
server. Use your licensed Microsoft SQL Server 2005 installation media to install only a 
client on this server. A full installation is not required.

• An Oracle client to support BODS. If you do not have licensed Oracle 10g Release 2 
(10.2.x.x) client software, go to the Oracle.com web site to download free client software 
before you begin the data warehouse installation (Chapter 7, Installing the Data 
Warehouse Server). 

For more information, see the Oracle.com web site (http://www.oracle.com/
technology/software/products/database/xe/htdocs/102xewinsoft.html).

Figure 6 shows the two RDBMS clients on the data warehouse server.

Figure 6 RDBMS Clients
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4 HP Licensing
The HP License Key Delivery Service web site (webware.hp.com) manages HP software 
licensing for the Financial Planning & Analysis application. You can view or download the 
latest version of the ESD and Webware License Management Guide from this site. The guide 
describes the current process to obtain your entitlement certificate, which contains the HP 
order number that you need to generate your permanent license keys. 

Follow the steps in the ESD and Webware License Management Guide to present your HP 
order number, select the products that need licenses, and provide other required information. 
If you are a first time visitor to the web site, you will be asked to create an account with an 
email address and password. Most requests to generate permanent license keys require the 
following:

• Financial Planning & Analysis product name and number shown on the product receipt or 
in the email sent by HP to acknowledge the order

• The order number from the entitlement certificate

• A target server name and IP address 

• Contact information, such as company name, your name, fax and phone numbers, and 
license ownership details

Managing Permanent License Keys

After you create your user account on the HP License Key Delivery Service web site, 
generate the entitlement certificate, and generate the license keys, the License Key Delivery 
Service sends permanent keys to you in an email text file attachment. When you receive the 
permanent license key file, stage it in a convenient directory on one of the servers where you 
plan to install Financial Planning & Analysis components. 

If necessary, you can return to the HP License Key Delivery Service web site and retrieve 
the permanent license keys again by selecting Manage Licenses on the web site home page and 
logging into your account. 

Porting the License File

From the stored location of the license file, you must copy it to a similar directory on each 
server where you plan to install one of these Financial Planning & Analysis components:

• SAP BusinessObjects Enterprise XI 3.1

• SAP BusinessObjects Data Services XI 3.1

• Financial Planning & Analysis data warehouse

• Financial Planning & Analysis web application
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To import the license file, copy it to an external USB storage device, or use a File Transfer 
Protocol (FTP) tool to store the license file on each affected server. During installation, the 
Configuration Tool will request the path to the permanent license file on each of these servers.
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5 Installing Financial Planning & Analysis
The Financial Planning & Analysis installer is self-directing with embedded instructions and 
default values. You can change these values to suit your local environment. There are two 
installation tools:

• The installer builds the directory structure and positions the files for configuration.

• The Configuration Tool collects relevant information and installs the associated 
components.

Before you start the installation process on any server, verify that you completed the steps to 
acquire the license keys file from HP and port it to the target server. For more information, 
see Chapter 4, HP Licensing. 

Running the Installer

The installer builds the directory structure on the target server and stages the files for final 
installation in the specified path. As you proceed through the installation, you can choose a 
complete setup for a single server, or a custom setup for a multiple server environment.

If you have an existing implementation of IT Analytics 2.01 and you want to upgrade to 
Financial Planning & Analysis 9.10, install the new version and use the Configuration Tool to 
complete the installation. You must install the upgrade in a separate directory. Failure to do 
so will cause the system to become inoperable.  

Installation Path 

During the Financial Planning & Analysis installation, you can override the default 
installation path and choose a custom path. However, make sure that the number of 
characters in the directory structure path does not exceed the maximum 256 characters that 
Financial Planning & Analysis permits. Avoid all special characters in paths except 
underscores (_), periods (.), back slashes (\), and blanks.  

HP recommends that you use the default path to avoid installation path issues. 

To install Financial Planning & Analysis 9.10

1 Close all windows before you install Financial Planning & Analysis 9.10.

2 Insert the Financial Planning & Analysis media into the DVD/CD-ROM drive.

HP recommends that you always back up your data before you begin a new installation. For 
more information, see the HP Financial Planning & Analysis Data Warehouse 
Administration Guide.

Do not install Financial Planning & Analysis 9.10 in the same folder that you installed 
previous implementations of IT Analytics 2.00 or IT Analytics 2.01. If you do so, you will 
overwrite files that the Configuration Tool references and cause the sytem to be inoperable. 
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3 Follow the prompts. The installer builds the directory structure on the target server and 
stages the files for final installation in the specified path.

As you proceed through the installation, you can choose a complete setup for a single 
server or a custom setup for a multiple server environment.

4 Click Finish.

5 Wait for the Configuration Tool to open, then configure Financial Planning & Analysis.

Running the Configuration Tool

The Configuration Tool is a user interface that collects required information, such as login 
names, passwords, and other information and applies it as needed to the actual file 
installation. The Configuration Tool divides the installation process into three parts:

1 Install BOE

2 Install BODS and build the data warehouse
3 Install the Financial Planning & Analysis web application and the Antivia Xcelsius Web 

Intelligence Integration Suite (XWIS)

You must follow this logical order because the installation of one component depends on the 
success of the prior steps.

The Configuration Tool marks each step when you complete it successfully with a green check 
mark. If the step is not successful, the Configuration Tool displays a red X for that step. If you 
exit and restart the Configuration Tool, always begin after the last successful step. The 
Configuration Tool abandons a step and displays a red X if you exit before the successful 
completion of that step. Figure 7 on page 40 shows the three main parts of the installation 
and the subordinate steps in Part 2.

About the Configuration Path

The Configuration Path screen enables you choose whether to install a new instance of 
Financial Planning & Analysis or to upgrade an existing instance. After you commit to a 
configuration path, this screen will no longer appear. To re-enable this screen in the event of 
an upgrade failure, you must modify the config.ini file.

To modify the config.ini file

1 Open this file with a text editor:

C:\Program Files\HP\FPA 9.10\Setup\Config Tool\config.ini

2 Locate these properties and set the value to blank:

install.showUpgradeOptionScreen=
install.type=
install.upgrade.configStatus=

• You can choose the location of the BOE software installation. 

• The default location must be outside the Financial Planning & Analysis 
installation path.

• The maximum number of characters that SAP BusinessObjects permits  in the 
directory structure is 39 characters.
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3 Save and close the file.

Configuring Financial Planning & Analysis 9.10

You must use the Configuration Tool to upgrade to or install Financial Planning & 
Analysis 9.10. 

HP recommends that you back up the staging database, target database, and the SAP 
BusinessObjects Data Services XI 3.1 repository before you begin a new installation or 
upgrade an existing configuration. For more information, see the HP Financial Planning & 
Analysis Data Warehouse Administration Guide.

1 From the Windows Start menu, click All Programs > HP > FPA 9.10 > Configuration Tool. 

2 If necessary, complete the steps to copy and import the license file. For more information, 
see Porting the License File on page 35.

3 On the Configuration Path dialog, select the configuration type.

— For a new installation, click Configure A New Instance. Click Next. At the Main Menu, 
begin Part 1 of the Configuration Tool, then complete Part 2a, 2b, 2c and Part 3a and 
3b. Because this is a new configuration, do not proceed to step 4 of these instructions.

— To upgrade a previous installation, click Upgrade An Existing Instance. Click Next and 
follow the prompts.

The upgrade process removes customized files. If you customized any ETL files, you must 
update them when you complete the installation. 
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Figure 7 Configuration Tool

4 Verify the Product, Version, and Install Location of the previous configuration. 

a If the Install Location path is missing or incorrect, click Browse to select the correct 
location.

b If the Install Location path is correct, click Next to verify the configuration. You must 
have a successfully installed IT Analytics 2.01 to continue.

– If the installation verification fails, a warning message displays that the file is 
incorrect. 

– If the installation verification is valid, this message displays: This option will erase 
all customizations. Do you want to continue? 

c Do one of the following actions:

– To continue, click Yes.

Do not install Financial Planning & Analysis 9.10 in the same folder that you 
installed previous implementations of IT Analytics 2.00 or IT Analytics 2.01. If 
you do so, you will overwrite files that the Configuration Tool references and 
cause the sytem to be inoperable. 
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– To stop the configuration process, click Exit or Cancel.

Upgrading to Financial Planning & Analysis 9.10

Financial Planning & Analysis, formerly known as IT Analytics, uses the existing underlying 
architecture of IT Analytics. Follow these guidelines to upgrade from IT Analytics 2.01 to 
Financial Planning & Analysis 9.10. 

  

When upgrading from IT Analytics 2.01 to Financial Planning & Analysis 9.10 using either 
LDAP or Windows AD authentication, you must update the security roles because their 
names have changed. 

See Task 2a: Configure LDAP Authentication on page 80 and Task 2b: Configure Active 
Directory Authentication on page 84 for more information about changing the BOE security 
roles.

1 Back up the staging database, target database, and the SAP BusinessObjects Data 
Services XI 3.1 repository. For more information, see the HP Financial Planning & 
Analysis Data Warehouse Administration Guide.

2 Insert the Financial Planning & Analysis media into the DVD/CD-ROM drive and 
double-click HP_FPA_910.msi.

3 After the installer is launched, select Upgrade as the installation path and follow the 
prompts to complete the upgrade. 

4 If you see a pop-up message indicating that FPA is unable to stop the Tomcat service, you 
must manually uninstall IT Analytics 2.00 and IT Analytics 2.01 and delete the 
installation folders.

Before you begin the upgrade process, make sure that you meet these requirements:

• IT Analytics 2.01 is successfully installed and configured.

• If you ran initial sync, you must restore your Staging and Target databases to their 
original state. For more information, contact your Data Base Administrator.

• The external file folders were created. For example:
C:\ETL_EXTRACTIONS\EXTERNAL
C:\ETL_EXTRACTIONS\AM
C:\ETL_EXTRACTIONS\PPM

The upgrade process overwrites your customizations. If you customized any ETL files, you 
must update them after completing the upgrade process. 

Table 3 User Groups

IT Analytics Group Name Financial Planning & Analysis Group Name

ITA_ADMIN FPA_ADMIN

ITA_ANALYTIC FPA_ANALYTIC

ITA_CE_CONFIG FPA_CE_CONFIG

DW_ADMIN DW_ADMIN (no change)
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a Stop Tomcat.

– From the Windows Start menu, click Programs > Control Panel > Administrative Tools 
> Services.

– Right-click the Apache Tomcat service and select Stop.

b From the Windows Start menu, click Control Panel > Add or Remove Programs (or 
Programs and Features). 

– Locate ITA 2.00.166 and click Remove. Proceed to the next step if the entry is not 
there.

– Locate ITA 2.01 and click Remove. Proceed to the next step if the entry is not there.

c Remove the following folders from the IT Analytics 2.00 installation directory. The 
default path is C:\Program Files\HP\IT Analytics 2.00.

ContentPacks
Foundation
Patches
Setup
Web Application

d Restart Tomcat.

5 When the upgrade process completes, click Finish.

6 From the Windows Start menu, click All Programs > HP > FPA 9.10 > Configuration Tool to 
start the Configuration Tool.

7 Configure Financial Planning & Analysis as needed.  See Configuring Financial Planning 
& Analysis 9.10 on page 39. 

8 Manually execute this additional SQL script on your target database: 
fpa91_migration_target_schema_additional.sql

— Navigate to this location from your Financial Planning & Analysis installation 
directory. For example: C:\Program Files\HP\FPA 9.10\Setup\Resources\Scripts

9 You must restart BusinessObjects services and Tomcat.

a From the Windows Start menu, click Programs > BusinessObjects XI 3.1 > 
BusinessObjects Enterprise > Central Configuration Manager.

b Right-click the Server Intelligence Agent (IT Analytics) service and select Restart.

c In the Central Configuration Manager, right-click the Apache Tomcat 5.5.20 service 
and select Restart.

10 Before running ETL, copy the AllocationMetric.xls file from the installed files to the 
external directory that was created in Part 2c of the Configuration Tool. 

a Navigate to 
C:\Program Files\HP\FPA 9.10\ContentPacks\FPA\ETL\flatfiles\spreadsheets. 

b Copy and paste the AllocationMetric.xls file to the external sources folder. For 
example, D:\EXTERNAL. 

11 Run ETL. For more information, see the HP Financial Planning & Analysis Data 
Warehouse Administration Guide.
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Uninstalling the Software

Although you can uninstall the software using the Windows Control Panel Add or Remove 
Programs utility, HP recommends that you also remove files and related databases to delete 
data generated by the data warehouse.

1 From the Windows Start menu, click Control Panel > Add or Remove Programs.

2 Navigate to Financial Planning & Analysis 9.10 and click Remove.

3 To remove all FPA components from your system, do the following:

a Uninstall SAP BusinessObjects Enterprise (BOE). For more information, see the BOE 
documentation.

b Uninstall SAP BusinessObjects Data Services (BODS). For more information, see the 
BODS documentation.

4 Using Windows Explorer, navigate to this directory to delete all files and sub-directories:

C:\Program Files\HP\FPA 9.10\

5 If you configured the FPA databases, you must delete them.

a To delete the Staging and Target databases, go to the database management console 
that you used to create the databases. For more information, see your database 
documentation.

b To delete the SAP BusinessObjects Data Services (BODS) repository, see the SAP 
BODS documentation.

c To delete the SAP BusinessObjects Enterprise (BOE) CMS/Audit Databases, see the 
BOE documentation.

d To delete Antivia XWIS files that the silent installer created, open a Windows 
command line window to run this command:

java -DantiviaInstallDir="C:\Program Files\HP\FPA\Antivia XWIS"
 -DwebAppDeploymentDestination="C:\Program Files\HP\BOE\Tomcat55"
 -DwebAppDeploymentPackage="C:\Program Files\HP\FPA\Setup
  \Antivia XWIS Installer\ant-frame-deploy-xwis-hp.zip"
 -DANTIVIA_CONFIG_DIRECTORY="C:\Program Files\HP\FPA\Antivia XWIS
  \config" 
-DantiviaDBCConnectUrl="jdbc:sqlserver://localhost;databaseName=XWIS" 
-DantiviaDBUid=sa -DantiviaDBPwd=passw0rd 
-DantiviaDBPlatform=MSSQLServer 
-Doem=HP02 -DhideDeploymentProgress=true 
-DremoveDeployedFiles=true 
-jar config-tool-2.0.491.jar
43



44 Chapter : Installing Financial Planning & Analysis



6 Installing SAP BusinessObjects Enterprise
Financial Planning & Analysis uses BOE server software for a variety of tasks. The BOE 
server software typically is on a separate server, as shown in Figure 8.

Complete these tasks on the BOE server.

• Task 1: Configure the BOE CMS Database DSN on page 46.

• Task 2: Configure the BOE Audit Database DSN on page 47.

• Task 3: Configure the Data Warehouse Administration DSN on page 47.

• Task 4: Configure the Data Warehouse Operations DSN on page 48.

• Task 5: Configure the Financial Planning & Analysis DSN on page 48.

• Part 1: Install SAP BusinessObjects Enterprise Server on page 49.

Figure 8 SAP BusinessObjects server 

 Only the English language pack is installed with BusinessObjects products.
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The BOE installation also populates the boecms and boeaudit databases that you created in 
Chapter 3, Configuring Required Databases with schemas and data.

At the end of this installation process, you will have a complete installation of the BOE server 
software and access to all the BOE components, including: 

• BusinessObjects Enterprise Central Management Console

• BusinessObjects Enterprise Java InfoView

• Central Configuration Manager

• Universe Builder

• BOE documentation

Creating ODBC Connections

Before you begin the BOE installation, create the required ODBC connections. These 
connections are from the BOE server to databases on the RDBMS server:

• BOE Central Management Server (CMS) database

• BOE audit database

• The data warehouse databases (to view two types of data warehouse reports)

• The IT Analytics universe

Use the Windows ODBC Data Source Administrator wizard to complete the following tasks.

Task 1: Configure the BOE CMS Database DSN

Use the information in the BOE CMS Database Connections section of the Checklist on 
page 115. Create this DSN to access the BOE CMS database.

1 From the Windows Start menu, click Control Panel > Administrative Tools > Data Sources 
(ODBC). Windows displays the ODBC Data Source Administrator wizard.

2 Click the System DSN tab.

3 Click Add.

4 Select SQL Server from the list of drivers.

5 Click Finish.

6 Type the Name of the new data source connection (DSN). For example: boecms_dsn. Refer 
to the naming convention that you defined in the Checklist on page 115.

7 Type a brief Description of the DSN.

8 Select the name of the Server where SQL Server resides. If the server is remote, the server 
name will appear in the drop-down list.

9 Click Next.

Before you begin the BOE installation, make sure that the server meets the requirements 
described in Chapter 2, Requirements. BOE must have enough free space to complete the 
installation and perform daily tasks. If there is not enough free space, the installation will 
fail.
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10 Select the SQL Server authentication option.

11 Type the Login ID and Password to access the server.

12 Click Next.

13 Click Next, then Finish to accept the remaining default values shown in the remaining 
dialog boxes.

14 Click Test Connection to verify that you can connect to the RDBMS server.

15 Click OK to return to the ODBC Data Source Administrator wizard.

Task 2: Configure the BOE Audit Database DSN

Use the information in the BOE Audit Database Connections section of the Checklist on 
page 115. Create this DSN to access the BOE audit database.

1 On the System DSN tab, click Add.

2 Select SQL Server from the list of drivers.

3 Click Finish.

4 Type the Name of the new DSN. For example: boeaudit_dsn. Refer to the naming 
convention that you defined in the Checklist on page 115.

5 Type a brief Description of the DSN.

6 Select the name of the Server where SQL Server resides. If the server is remote, the server 
name will appear in the drop-down list.

7 Click Next.

8 Select the SQL Server authentication option.

9 Type the Login ID and Password to access the server.

10 Click Next.

11 Click Next, then Finish to accept the remaining default values shown in the remaining 
dialog boxes.

12 Click Test Connection to verify that you can connect to the RDBMS server.

13 Click OK to return to the OCBC Data Source Administrator wizard.

Task 3: Configure the Data Warehouse Administration DSN

Create this DSN to view data warehouse administrative reports using BOE Infoview tools. 

1 On the System DSN tab, click Add.

2 Select SQL Server from the list of drivers.

3 Click Finish.

4 Type the Name of the new DSN. You must specify this name: ita_admin.

5 Type a brief Description of the DSN. For example: ABC administration reports connection.

If you chose to create a single BOE database to serve both CMS and Audit functions in 
Task 4: Create the Required Databases on page 26, you can skip Task 2 and go to Task 3: 
Configure the Data Warehouse Administration DSN.
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6 Select the name of the Server where SQL Server resides. If the server is remote, the server 
name will appear in the drop-down list.

7 Click Next.

8 Select the SQL Server authentication option.

9 Type the Login ID and Password to access the server.

Use sa and the accompanying password until you establish your own ODBC connection. 
See Check ODBC Connections on page 63.

10 Click Next.

11 Click Next, then Finish to accept the remaining default values shown in the remaining 
dialog boxes.

12 Click Test Connection to verify that you can connect to the RDBMS server.

13 Click OK to return to the OCBC Data Source Administrator wizard.

Task 4: Configure the Data Warehouse Operations DSN

Create this DSN to view data warehouse operations reports using BOE Infoview tools. 

1 On the System DSN tab, click Add.

2 Select SQL Server from the list of drivers.

3 Click Finish.

4 Type the Name of the new DSN. You must specify this name: ita_operations.

5 Type a brief Description of the DSN. For example: ABC operational reports connection.

6 Select the name of the Server where SQL Server resides. If the server is remote, the server 
name will appear in the drop-down list.

7 Click Next.

8 Select the SQL Server authentication option.

9 Type the Login ID and Password to access the server.

Use sa and the accompanying password until you establish your own ODBC connection. 
See Check ODBC Connections on page 63.

10 Click Next.

11 Click Next, then Finish to accept the remaining default values shown in the remaining 
dialog boxes.

12 Click Test Connection to verify that you can connect to the RDBMS server.

13 Click OK to return to the OCBC Data Source Administrator wizard.

Task 5: Configure the Financial Planning & Analysis DSN

Create this DSN to view the analytics produced by the Financial Planning & Analysis 
application using BOE Infoview tools.

1 On the System DSN tab, click Add.

2 Select SQL Server from the list of drivers.

3 Click Finish.
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4 Type the Name of the new DSN. You must specify this name: itafpaqry.

5 Type a brief Description of the DSN. For example: FPA analytics query.

6 Select the name of the Server where SQL Server resides. If the server is remote, the server 
name will appear in the drop-down list.

7 Click Next.

8 Select the SQL Server authentication option.

9 Type the Login ID and Password to access the server.

Use sa and the accompanying password until you establish your own ODBC connection. 
See Check ODBC Connections on page 63.

10 Click Next.

11 Click Next, then Finish to accept the remaining default values shown in the remaining 
dialog boxes.

12 Click Test Connection to verify that you can connect to the RDBMS server.

13 Click OK to return to the OCBC Data Source Administrator wizard.

14 Click OK to close the ODBC Data Source Administrator wizard.

Part 1: Install SAP BusinessObjects Enterprise Server

Consolidated Server: Complete step 11 on page 50 through step 19 on page 52 on the 
consolidated server. 

Multiple Servers: From the BOE server, follow these steps.

1 If necessary, complete the steps to copy and import the license file. For more information, 
see Porting the License File on page 35.

2 Insert the Financial Planning & Analysis media into the DVD/CD-ROM drive.

3 Complete the Welcome tasks. 

4 Choose Custom Setup.

5 Select SAP BusinessObjects Enterprise Server. 

6 Confirm (or change) the installation path and click Next.

7 The Financial Planning & Analysis installer copies the required files from the installation 
media. Click Finish to start the Configuration Tool.

8 When you begin the configuration process, the first task is to specify the location of the 
license file. Click Browse to locate the license file path that you specified in the Part 1: 
SAP BusinessObjects Enterprise XI 3.1 Server Checklist on page 115.

Sequence is important with SAP BusinessObjects tools. If you plan to use the BOE 
instance of Apache Tomcat for BODS, you must install BOE before you install 
BODS. 

If you uninstall BOE and BODS uses the shared Apache Tomcat, BODS will lose 
access to Apache Tomcat.
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9 Click Import License to store the license details and expiration dates.

10 Click Run Configuration to proceed with configuring the Financial Planning & Analysis 
component. 

11  From the Configuration Tool main menu, shown in Figure 9, select Configure SAP 
BusinessObjects Enterprise Server.
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Figure 9 Configuration Tool

12 On the Install Directory tab, specify the installation path and click Next. 

13 Now you must specify the same database connection and login information that you used 
to build the BOE CMS and Audit databases on the RDBMS server, and the names of the 
ODBC connections that you created on the BOE server. Refer to the names that you 
specified in Part 1: SAP BusinessObjects Enterprise XI 3.1 Server Checklist on page 115. 

On the CMS Database tab, specify the ODBC data source (DSN) name, database name, 
login, and password. 

14 Click Verify Connection to ensure that you have database connectivity, then click Next.

• The installation path must not be in the same directory as Financial Planning 
& Analysis.  

• If you do not specify \boe as a subdirectory of your installation path, the 
configuration tool will create one for you and place all boe files in this 
subdirectory.

• Make sure that the number of characters in the directory structure path does 
not exceed the maximum 39 characters that SAP BusinessObjects permits. 
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15 On the Audit Database tab, specify the ODBC data source (DSN) name, database name, 
login, and password that you specified in Part 1: SAP BusinessObjects Enterprise XI 3.1 
Server Checklist on page 115. If you chose to create a single database, select the option to 
Use the same database as the CMS, click Next, and skip to step 17.

16 Click Verify Connection to ensure that you have database connectivity, then click Next.

17 Click Next to review the configuration information.

18 Click Run Configuration to begin the file installation process. 

19 Click Finish when the file installation process is complete. 

Verification

You can confirm that the BOE server installation is successful. 

• From the Windows Start menu, click All Programs to verify that there is a 
BusinessObjects XI 3.1 > BusinessObjects Enterprise program group. 

• You should be able to start any of the applications listed in the BusinessObjects 
Enterprise program group.

Troubleshooting

The Configuration Tool displays a list of actions and a check mark when each finishes 
successfully. If an error occurs, the installation and configuration process stops. 

The Configuration Tool maintains a log that is a running history of all installation events. If 
an error occurs during the installation process, log messages can provide information to help 
you remedy the error. If an error occurs during the installation and configuration process, 
click View Logs to display the related logs. The log generated by the Configuration Tool is 

C:\Program Files\HP\FPA 9.10\Setup\Config Tool\logs\config.log 

The Configuration Tool appends new event information as you complete each step. Therefore, 
an error may occur that is captured in the log, and then the correction shows that the next 
attempt is successful. To locate the information about the most recent error, scroll to the 
bottom of the log and read upwards. 

BOE Errors

If an error occurs, click View Logs. The Configuration Tool displays a BOE log file and the 
Configuration Tool log. The log generated by the BOE installer is
C:\Program Files\HP\FPA 9.10\Setup\BO Installers\boe\boeConfig.log

Verify that: 

• You have enough free disk space to manage the installation. There should be at least 
10 GB of free space available before you begin.

Make sure that you do not click Run Configuration until you are ready to commit to 
the BOE installation. BOE is a large product that requires a significant amount 
of time to install, and if you terminate the installation process, you will have to 
manually clear partially installed files. Even if you close the Configuration Tool 
window, the BOE silent installation will continue.
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• You have no previous installation of BOE on that server. Use the Add or Remove 
Programs utility in the Windows Control Panel to verify that you have no existing 
installation of BOE that should be uninstalled.

• You have access to the folders where the installation software resides. You can be a 
SYSTEM user, or a named user.

BOE Fixpack 1.2 Installation

The installation process includes application of BOE FP 1.2. You can verify that the fixpack 
installed correctly if you open this log:

<bo_install_dir>\BusinessObjects Enterprise 12.0\Logging\BOE_SP1FP2_Install_0.log   

Look for this message:

Product: BusinessObjects Enterprise XI 3.1 - Update 'BusinessObjects 
Enterprise XI 3.1 FP1.2' installed successfully.

Fixpack Failure

The fixpack application that occurs during the BOE installation may fail if there is a missing 
operating system component: MSXML 6.0. This component should be available if the BOE 
server has the Windows Server 2003 Service Pack 2 applied before you begin the installation. 

1 Look for these messages in this log: 

C:\Program Files\HP\FPA 9.10\Setup\Config Tool\logs\config.log:

[INFO] com.hp.ita.configtool.util.StreamReader - Wed May 20 15:45:24 PDT 
2009 OK: ERROR - FixPack installation failed. See log file.
[ERROR] com.hp.ita.configtool.util.SwingWorkerManager - Install SAP BOE 
fix pack failed: 2

2 And look for this message in this log:

C:\Program Files\HP\FPA_9.10\Setup\BO Installers\boe\boeConfig.log:

[INFO] com.hp.ita.configtool.util.SwingWorkerManager - SAP BOE 
configuration failed

3 Verify that the MSXML 6.0 component is installed, or obtain the component from 
Microsoft and install it. For more information, see Microsoft Patches on page 18.

Fixpack Workaround

If the fixpack installation fails, follow these steps to install it manually: 

1 Exit from the Configuration Tool.

2 Click the following to restart the fixpack installation:

C:\Program Files\HP\FPA 9.10\Setup\resources\media\boe-fp1.2\setup.exe 

3 Restart the Configuration Tool and proceed to the next step.
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BOE Installation Log Messages

If a CMS warning popup appears during BOE installation, an installation problem occurred. 
The warning says that the CMS could not (or did not) start and you have a choice to Retry or 
Cancel. The installation can fail because of access issues to the database, such as unsupported 
characters in the password, unauthorized access rights, or other user limitations.

If the Retry option produces the same error message, do the following:

• Open the BOE CMS database and look in the tables folder to verify that tables exist in the 
CMS database. If there are no tables, verify that you specified the correct login 
credentials.

• Navigate to the installation log file: 

C:\Documents and Settings\dwuser\Local Settings\Temp\1\BOEInstall_0.log

Look for messages that describe an error condition:

MSI (s) (08:5C) [15:38:21:224]: Invoking remote custom action. DLL: 
C:\WINNT\Installer\MSI60.tmp, Entrypoint: FixService

MSI (s) (08:70) [15:38:21:584]: Executing op: 
ActionStart(Name=BOBJConfigDbServer.60F4A18A_ACCB_48F0_A673_017C6A585288,
Description=Configuring Databases,Template=Server: [1], Database: [2])

MSI (s) (08:70) [15:38:21:599]: Executing op: 
CustomActionSchedule(Action=BOBJConfigDbServer.60F4A18A_ACCB_48F0_A673_01
7C6A585288,ActionType=25665,Source=BinaryData,Target=**********,CustomAct
ionData=**********)

MSI (s) (08:10) [15:38:21:662]: Invoking remote custom action. DLL: 
C:\WINNT\Installer\MSI61.tmp, Entrypoint: BOBJConfigDbServer
5/27/2009, 15:38:22: [ODBC] About to connect to ODBC Server
5/27/2009, 15:38:22: [ODBC] SQLDriverConnect failed: SQL_ERROR
5/27/2009, 15:38:22: [ODBC] 28000 [Microsoft][ODBC SQL Server Driver][SQL 
Server]Login failed for user 'dbuser'.

• Verify that you met all the requirements described in the Compatibility Matrix before you 
began the installation.

• Verify that the passwords you specified do not contain blanks or unsupported characters.

• Use the Windows Control Panel Add/Remove Programs feature to uninstall any Financial 
Planning & Analysis components that appear in the Programs list.

• Restart the server.

• Restart the installation process from the beginning.

Upgrade Errors

In the event of an upgrade error, you must modify the config.ini file. See About the 
Configuration Path on page 38.
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7 Installing the Data Warehouse Server
Financial Planning & Analysis uses SAP BusinessObjects Data Services XI 3.1 (BODS) 
software to extract data from remote data sources. The BODS software is on the data 
warehouse server, as shown in Figure 10. Complete these tasks on the data warehouse server.

• Part 2a: Configure SAP BusinessObjects Data Services on page 57.

• Part 2b: Configure ETL Data Sources on page 60.

• Part 2c: Configure the Data Warehouse on page 62.

Figure 10 Data Warehouse Server
.

At the end of this part of the installation process, the data warehouse server contains:

• Data warehouse developer tools

• ABC tools to run ETL jobs

• BODS
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The RDBMS Server contains:

• The bods database that you created in Chapter 3, Configuring Required Databases 
populated with schemas and data. 

• The data warehouse staging and target databases that you created in Chapter 3, 
Configuring Required Databases populated with schemas.

RDBMS Clients

Verify that you have a Microsoft SQL Server client and an Oracle 10g client installed on the 
data warehouse server. You must install an Oracle 10g client even if you have an Oracle 11g 
client. The data warehouse requires a Microsoft SQL Server client to update the databases 
that you created on the RDBMS server. BODS and the data warehouse depend on an Oracle 
client for connectivity to source databases. 

License Installation

Consolidated Server: Skip to Part 2a: Configure SAP BusinessObjects Data Services on 
page 57 to continue the installation on the consolidated server. 

Multiple Servers: From the data warehouse server, follow these steps.

1 If necessary, complete the steps to copy and import the license file. For more information, 
see Porting the License File on page 35.

2 Insert the Financial Planning & Analysis media into the DVD/CD-ROM drive.

3 Complete the Welcome tasks. 

4 Choose Custom Setup.

5 Select Data Warehouse Environment. 

6 Confirm the installation path and click Next.

7 The Financial Planning & Analysis installer copies the required files from the installation 
media. Click Finish to start the Configuration Tool.

8 When you begin the configuration process, the first task is to specify the location of the 
license file. Click Browse to locate the license file path that you specified in Part 2: 
Financial Planning & Analysis Data Warehouse Checklist on page 116.

After completing the configuration and before running the ETL, run a SQL script to create 
views for each of your identified source databases. For more information about running these 
scripts, see Task 2: Create the Source Data Views in the Initialization and  ETL chapter of the 
HP Financial Planning & Analysis Data Warehouse Administration Guide.

Sequence is important with SAP BusinessObjects tools. If you plan to use the BOE 
instance of Apache Tomcat for BODS, you must install BOE before you install 
BODS. 

If you uninstall BOE and BODS uses the shared Apache Tomcat, BODS will lose 
access to Apache Tomcat.
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9 Click Import License to store the license details and expiration dates.

10 Click Run Configuration to proceed with configuring the Financial Planning & Analysis 
component. 

Part 2a: Configure SAP BusinessObjects Data Services

1 From the Configuration Tool main menu, shown in Figure 11 on page 58, select Configure 
SAP BusinessObjects Data Services. 

2 On the Install Directory tab, specify the installation path and click Next. 

3 Now you must specify the same database connection and login information that you used 
to build the BODS database on the RDBMS server and define the ODBC connections on 
the data warehouse server. Refer to the names that you specified in the 2a) BODS 
Configuration Information section of the Checklist on page 116.

• The installation path must not be in the same directory as Financial Planning 
& Analysis. 

• If you do not specify \bods as a subdirectory of your installation path, the 
configuration tool will create one for you and place all bods files in this 
subdirectory.

• Make sure that the number of characters in the directory structure path does 
not exceed the maximum 39 characters that SAP BusinessObjects permits. 
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On the Repository tab, specify the server name, database name, login, and password. 

4 Click Verify Connection to ensure that you have database connectivity, then click Next.

5 Click Next to review the configuration information.

6 Click Run Configuration to begin the file installation process. 

7 Click Finish when the file installation process is complete. If an error occurs, see 
Troubleshooting on page 64.

Figure 11 Configuration Tool

Verification

You can confirm that the BODS installation is successful. 

• From the Windows Start menu, click All Programs > BusinessObjects XI 3.1 to verify that 
there is a BusinessObjects Data Services program group. 
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• You should be able to start any of the applications listed in the BusinessObjects Data 
Services program group.

Adding the BODS Database Connection

You must register the BODS database that you defined on the RDBMS server on the BODS 
Management Console before you can install the data warehouse files.

1 Restart the data warehouse server. 

2 Click All Programs > BusinessObjects XI 3.1 > BusinessObjects Data Services > Data Services 
Management Console.

3 Type your login and password. The default login for BODS is admin and the default 
password is admin. 

4 Click Login.

5 Select Administrator.

6 In the left navigation pane, expand Management and select Repositories.

7 In the main pane, click Add.

For the following steps, use the information that you recorded in the 2a) BODS Configuration 
Information section of the Checklist on page 116.

8 Type the Repository name (the BODS registration name in the Checklist). 

9 Choose the Database type. It should be Microsoft_SQL_Server.

10 If appropriate, select Windows authentication.

11 Type the Machine name (the BODS database server name in the Checklist).

12 Type the Database port (the BODS database TCP port number in the Checklist. 1433 is the 
default value).

13 Type the Database name (the BODS database name in the Checklist). The BODS database 
name cannot exceed 12 characters.

14 Type the User name (the BODS login in the Checklist).

15 Type the Password (the BODS password in the Checklist).

16 Click Apply.

The MS SQL Server default port number value is 1433. BODS verifies that a connection 
exists using the port number that you specify.

Troubleshooting

If an error occurs, click View Logs. The Configuration Tool displays a BODS log file and the 
Configuration Tool log. Read each log message to identify the error and recommended 
corrective action.
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Part 2b: Configure ETL Data Sources

The ETL process automatically configures the data warehouse with AM or PPM data sources. 
Although you can select an alternate source, you must manually run a script to configure the 
data warehouse when you use only an alternate source. 

1 From the Configuration Tool main menu, shown in Figure 10 on page 55, select Configure 
ETL Data Sources.

2 On the Data Sources tab, select Asset Manager 5.10/5.20 or Project and Portfolio Management 
(or both). You can also select Alternate Source with Asset Manager or Project and Portfolio 
Management. The Configuration Tool displays one or both tabs to specify the required 
configuration information. If you do not have AM or PPM as a data source, select Alternate 
Source. 

— For Asset Manager (or Asset Manager and Alternate Source):

– Use the information that you recorded in 2b) ETL Data Source Configuration 
Information for Asset Manager in the Checklist on page 116. 

– Go to step 3.

— For Project and Portfolio Management (or Project and Portfolio Management and 
Alternate Source):

– Select the PPM version from the drop-down list. 
Note: To configure the PPM 9.10 data source, select PPM 8.00 and ensure that 
the Oracle 10g client is installed. In the Oracle JDBC library location field, link to 
the ojdbc14.jar that is in the Oracle 10g client. Place the connection information to 
PPM 9.10 in the Oracle 10g client tnsnames.ora file.

– Use the information that you recorded in 2b) ETL Data Source Configuration 
Information for Project and Portfolio Management in the Checklist on page 117. 

– Go to step 3.

— For Alternate Source, see Using an Alternate Data Source on this page.

3 For each data source, make sure that you click Verify connection before you proceed. 

If the Oracle connection fails, see Troubleshooting on page 62.

4 The Configuration Tool will capture time zone information if it can. If not, choose the time 
zone where the data source originates from the drop-down lists. 

5 Click Next to review the configuration information.

6 Click Run Configuration to apply the data sources information. 

7 Click Finish when the data sources information is complete. If an error occurs, see 
Troubleshooting on page 64.

If you select AM, PPM, or both data sources, the Alternate Data Source will be ignored. The 
Alternate Date Source option will take effect if it is the only option selected.

You must use an Oracle 10g client JDBC library for the connection to verify.
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Using an Alternate Data Source

If you use an alternate data source, you must complete these steps before you begin Part 3 of 
the Configuration Tool. 

1 Navigate to the C:\Program Files\HP\FPA 9.10\Setup\Resources\Scripts folder.

2 Extract AlternateSourceConfig.zip to a folder on your system. For example, C:\Scripts

3 Create an external sources folder to stage the external source spreadsheets for the 
extract, transform, and load (ETL) process. The content of these flat files is important to 
the ETL workflow. For example, create the folder C:\EXTERNAL.

4 Open a Windows command line window.

5 Navigate to the cmd subdirectory under the folder where you extracted the contents.
For example, C:\Scripts\cmd. 

6 Run this command:

AlternateSourceConfig.bat

For example, C:\Scripts\cmd>AlternateSourceConfig.bat

7 At the prompt, type the value for these required parameters:

— Staging Database Server Name

— Staging Database Admin User ID

— Staging Database Admin Password

— Staging Database Name

— Staging Database Password for User IDs to be created

— Target Database Server Name

— Target Database Admin User ID

— Target Database Admin Password

— Target Database Name

— Target Database Password for User IDs to be created

8 After the batch file successfully runs, follow the instructions in Check ODBC Connections 
on page 63, and then open the Configuration Tool and go to Part 3  to complete the 
configuration. For more information, see Part 3a: Configure the Web Application on 
page 70.

Make sure that you have two databases created: one staging database and one target 
database. Each database must have an administrative user ID and password.
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Troubleshooting

If an error occurs, click View Logs. The Configuration Tool displays a Windows Explorer view 
of all the data warehouse log files that contain information about the error, and the 
Configuration Tool log. 

If a step in the data warehouse configuration fails, there is a reference in the Configuration 
Tool log to the related data warehouse log where the information about the failure appears. 
There may be references to other logs that are available in the same Windows Explorer 
window. Sort the list of logs by date and read them sequentially, starting from the most recent, 
for the source of the error and recommended corrective action. 

Oracle Connection Fails

The default authentication for the Oracle 10g client is set to use NT credentials. When the 
Oracle connection uses NT credentials instead of those supplied by the Configuration Tool, the 
connection test fails. Change the authentication option to include NONE in the sqlnet.ora file.

1 Open this file with a text editor:

<ORACLE_HOME>10.2.0\client_1\NETWORK\ADMIN\sqlnet.ora

2 Edit the authentication services option to include NONE.

SQLNET.AUTHENTICATION_SERVICES= (NTS|NONE)

3 Save and close the file.

Oracle Client Configuration

If your installation of an Oracle 10g client does not set the TNS_ADMIN or ORACLE_HOME 
environment variable to point to TNSNAMES.ORA, the connection to the Oracle database 
through the TNS name will fail. You can use the Oracle Net Configuration Assistant to create 
the TNS entry. For more information, see your Oracle documentation.

After you create the environment variable, follow the steps in Restarting the Data Warehouse 
Installation on page 65.

Part 2c: Configure the Data Warehouse

1 From the Configuration Tool main menu, shown in Figure 10 on page 55, select Configure 
Data Warehouse.

2 Use the information that you recorded in 2c) Data Warehouse Configuration Staging 
Database Information and 2c) Data Warehouse Configuration Target Database 
Information in the Checklist on page 117 and page 118 to configure the data warehouse.

3 On the Units of Measure tab, provide the time and date constraints for ETL processing. 

4 In a multiple server installation, confirm the data warehouse password on the Server tab.

5 On the Staging tab, provide the location of the External Sources files and the Asset 
Manager (AM) and Project and Portfolio Management (PPM) extraction files.  If you do 
not know the file location, click Browse.  

If AM is not configured, the AM folder location does not appear.
If PPM is not configured, the PPM folder location does not appear.
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Follow these rules when you create folders:

— The maximum number of characters for the folder location is 200.

— Folder locations must be on the same physical machine.

— The folders must be unique.

6 Click Next to review the configuration information.

7 Click Run Configuration to begin the data warehouse configuration process. 

8 Click Finish when the data warehouse configuration process is complete. If an error occurs, 
see Troubleshooting on page 64.

Check ODBC Connections

The installation creates static user IDs for databases and universes. These IDs may conflict 
with the ones you configured. You must correct the universe and ODBC connection 
information to ensure that you have database access. For each universe, follow these steps.

1 From the Windows Start menu, click  All Programs > BusinessObjects XI 3.1 > 
BusinessObjects Enterprise > Designer.

2 Login with the appropriate credentials. Administrator is the default user name.

3 Click File > Import.

4 In the Import Universe dialog box, click Browse to locate the folder that contains the data 
warehouse universes.

5 Select a universe from the list of Available Universes.

6 Click OK. The selected universe should import successfully.

7 Click File > Parameters.

8 If you click Test, the connection fails and returns an error message.

9 Click Edit. At the Warning prompt, click Yes to change the connection information.

10 In the Login Parameters [2/4] dialog box, click Next.

11 In the Configuration Parameters dialog box, change these parameters.

12 Click Next.

13 Click Finish.

14 Click OK.

15 Click File > Export to save the changes back to the database.

Table 4 Configuration Parameters

Parameter Value

Connection pool mode Keep the connection for

Pool timeout 10

Array fetch size 10

Array bind size 5

Login timeout 600
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16 Click Continue.

17 Click OK to complete the export process.

18 Click OK when the confirmation message appears.

19 Click File > Close.

When you finish updating the connection information, complete these steps for each 
connection.

1 From the Windows Start menu, click Administrative Tools > Data Sources (ODBC).

2 Click the System DSN tab.

3 Choose one of these connections: ita_admin, ita_operations, itafpaqry.

4 Click Configure.

5 On the first dialog box, click Next.

6 Change the Login ID and Password to match the values in the following table.

Test each database to verify that you have connectivity.

Troubleshooting

If an error occurs, click View Logs. The Configuration Tool displays a Windows Explorer view 
of all the data warehouse log files that contain information about the error, and the 
Configuration Tool log. 

If a step in the data warehouse configuration fails, there is a reference in the Configuration 
Tool log to the related data warehouse log where the information about the failure appears. 
There may be references to other logs that are available in the same Windows Explorer 
window. Sort the list of logs by date and read them sequentially, starting from the most recent, 
for the source of the error and recommended corrective action. 

Database Collation Sequence

If you failed to specify the correct collation value for a staging or target database, you may 
have to return to the RDBMS to change that value. For more information, see Task 4: Create 
the Required Databases on page 26.

BODS Registration

If you failed to register the BODS repository, you must complete that step first before you 
build the data warehouse. For more information, see Adding the BODS Database Connection 
on page 59.

Table 5 Configuration Parameters

This ODBC Connection Uses This Login ID For this Target Database

ita_admin dwmetadata Staging

ita_operations dwabc Staging

itafpaqry itafpaqry Target
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Restarting the Data Warehouse Installation

If an error occurs after you begin Part 2c: Configure the Data Warehouse on page 62, you must 
delete the data warehouse tables created during the installation and repeat some steps to 
configure the new databases. 

On the RDBMS server:

1 From Microsoft SQL Server Management Studio, delete these databases:

• bods

The bods database will have a connection to a BODS repository. Make sure that you 
select the option to close that connection when you delete this database.

• staging

• target

2 Recreate these three databases and specify the correct collation sequence. For more 
information, see Task 4: Create the Required Databases on page 26.

On the data warehouse server:

3 From the Windows Start menu, click All Programs > BusinessObjects Data Services > 
Data Services Repository Manager.

4 Specify the following information about the bods database:

• Repository type.

• Database type (Microsoft SQL Server is the default value).

• Database server name.

• Database name.

• Choose Windows authentication or specify the User name and Password.

• Click Create to re-establish the connection between the BODS application and the 
bods database.

5 From the Windows Start menu, click All Programs > BusinessObjects Data Services > 
Data Services Server Manager.

6 Select JobServer 1.

7 Click Restart.

8 Repeat Part 2c: Configure the Data Warehouse on page 62.

Working with Data Sources

Read this section if you have Financial Planning & Analysis 9.10 implemented with one data 
source, AM 5.10, AM 5.20, PPM 7 50, or PPM 8.00, and you want to add another data source 
or reconfigure Financial Planning & Analysis to use an upgraded data source.
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Add a data source

1 Back up the staging database, target database, and the SAP BusinessObjects Data 
Services XI 3.1 repository. For more information, see the HP Financial Planning & 
Analysis Data Warehouse Administration Guide.

2 From the Windows Start menu, click All Programs > HP > FPA 9.10 > Configuration Tool.

3 From the Configuration Tool main menu, select Configure ETL Data Sources.

4 On the Data Sources tab, select Asset Manager 5.10/5.20 or Project and Portfolio Management. 
The Configuration Tool displays one or both tabs to specify the required configuration 
information.

5 For Asset Manager, use the information that you recorded in 2b) ETL Data Source 
Configuration Information for Asset Manager in the Checklist on page 116.

6 For Project and Portfolio Management:

a Select the PPM version.

b Use the information that you recorded in 2b) ETL Data Source Configuration 
Information for Project and Portfolio Management in the Checklist on page 117.

7 For each data source, make sure that you click Verify connection before you proceed. 

8 The Configuration Tool will capture time zone information if it can. If not, choose the time 
zone where the data source originates from the drop-down lists. 

9 Click Next to review the configuration information.

10 Click Run Configuration to apply the data sources information. 

11 Click Finish when the data sources information is complete. If an error occurs, see 
Troubleshooting on page 64.

12 Use the Configuration Tool to configure the data warehouse. For more information, see 
Part 2c: Configure the Data Warehouse on page 62.

13 Run ETL. For more information, see the HP Financial Planning & Analysis Data 
Warehouse Administration Guide.

Reconfigure Financial Planning & Analysis 9.10 to Use an Upgraded Data Source

1 Back up the staging database, target database, and the SAP BusinessObjects Data 
Services XI 3.1 repository. For more information, see the HP Financial Planning & 
Analysis Data Warehouse Administration Guide.

2 Run the data warehouse clean-up utility to remove the staging and target data for all 
consolidated entities related to the specified data source:

a Switch to this directory:

C:\Program Files\HP\FPA 9.10\Foundation\bin

b Run this command:

dw_cleandb.bat -option
66 Chapter : Installing the Data Warehouse Server



where option is one or more of the following options:  

3 Recreate the BODS repository.

4 Delete the entities_integration.xml file in this directory:
C:\Program Files\HP\FPA 9.10\Foundation\conf

5 Delete this directory:
C:\Program Files\HP\FPA 9.10\Foundation\etc\ABC

6 Delete this directory:
C:\Program Files\HP\FPA 9.10\Foundation\etc\ETL

7 From the Windows Start menu, click All Programs > HP > FPA 9.10 > Configuration Tool.

8 From the Configuration Tool main menu, select Configure ETL Data Sources.

9 On the Data Sources tab, select Asset Manager 5.10/5.20 or Project and Portfolio Management. 
The Configuration Tool displays one or both tabs to specify the required configuration 
information.

10 For Asset Manager, use the information that you recorded in 2b) ETL Data Source 
Configuration Information for Asset Manager in the Checklist on page 116.

11 For Project and Portfolio Management:

a Select the PPM version.

b Use the information that you recorded in 2b) ETL Data Source Configuration 
Information for Project and Portfolio Management in the Checklist on page 117.

12 For each data source, make sure that you click Verify connection before you proceed. 

13 The Configuration Tool will capture time zone information if it can. If not, choose the time 
zone where the data source originates from the drop-down lists. 

14 Click Next to review the configuration information.

15 Click Run Configuration to apply the data sources information. 

16 Click Finish when the data sources information is complete. If an error occurs, see 
Troubleshooting on page 64.

17 Recreate the SAP BusinessObjects Data Services XI 3.1 repository and re-sync. For more 
information, see the SAP BusinessObjects Data Services XI 3.1 documentation.

18 Use the Configuration Tool to configure the data warehouse. For more information, see 
Part 2c: Configure the Data Warehouse on page 62.

Option Description

-help Display the command syntax.

-file <file> File name for the list output.

-listonly Only list the affected tables. Write the affected tables to a file but do not 
execute the SQL. If you use listonly without specifying a product file, 
Financial Planning & Analysis writes the list of  tables to the 
dw_cleandb.log file in 
C:\Program Files\HP\FPA 9.10\ContentPacks\Core
\Foundation\log.

-product <product> Name of the product for which to clean the data from the database.

For example

dw_cleandb.bat -product AM
dw_cleandb.bat -product PPM
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19 Run ETL. For more information, see the HP Financial Planning & Analysis Data 
Warehouse Administration Guide.
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8 Installing the Web Application and Antivia 
XWIS
The final step is to install and configure the Financial Planning & Analysis (FPA) web 
application and the Antivia Xcelsius Web Intelligence Integration Suite (XWIS). At the end of 
this part of the installation process, the FPA web server contains the FPA web application. 
Figure 12 shows how the web application displays in a browser window on a client 
workstation. Complete these tasks on the FPA web server.

• Part 3a: Configure the Web Application on page 70.

• Part 3b: Configure XWIS on page 74.

• Restart Tomcat on page 75.

• Start the Web Application on page 75.

Figure 12 FPA Environment
.
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At the end of the installation, you should be able to see the startup page of the Financial 
Planning & Analysis web application in a browser window. You must complete the 
authentication procedures described in Chapter 9, Configuring User Roles and 
Authentication before you can login and run the application.

Part 3a: Configure the Web Application

Consolidated Server: Complete step 12 on page 71 through step 21 on page 73 on the 
consolidated server.

Multiple Servers: From the web application server, follow all steps below.

1 If necessary, complete the steps to copy and import the license file. For more information, 
see Porting the License File on page 35.

2 Insert the Financial Planning & Analysis media into the DVD/CD-ROM drive.

3 Double-click HP_FPA_910.msi.

4 Complete the Welcome tasks. 

5 Choose Custom as the Setup Type to install only the Web Application.

a Click the down arrow beside SAP BusinessObjects Enterprise Server.

b From the menu, select Entire feature will be unavailable.

c Click the down arrow beside Data Warehouse Environment.

d From the menu, select Entire feature will be unavailable.

Only the Web Application will be installed on this machine.

6 Confirm the installation path and click Next. The Financial Planning & Analysis installer 
copies the required files from the installation media. 

7 Click Finish to start the Configuration Tool.

8 If you are installing the web application in a distributed environment that uses an 
external (non-BOE Tomcat) Tomcat, stop Tomcat.

a From the Windows Start menu, click Programs > Control Panel > Administrative Tools > 
Services.

b Right-click the Apache Tomcat service and select Stop.

9 When you begin the configuration process, the first task is to specify the location of the 
license file. Click Browse to locate the license file path that you specified in the Part 3: 
Financial Planning & Analysis Web Application and Antivia XWIS Checklist on page 120.
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10 Click Import License to store the license details and expiration dates.

11 Click Run Configuration to proceed with configuring the Financial Planning & Analysis 
component. 

12 From the Configuration Tool main menu, shown in Figure 13, select Configure Web 
Application.
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Figure 13 Configuration Tool

13 The Tomcat tab enables you to specify a pre-existing (external) Tomcat that is not created 
by the Financial Planning & Analysis BOE installation. Financial Planning & Analysis 
can use an external Tomcat if it has the Location and Service name.

14 Complete these fields on the SAP BOE tab.

— SAP BOE server name: Establish a web service session between the Financial Planning 
& Analysis application and BOE. You must use the fully qualified domain name for 
the BOE server name. For example, boeservername.americas.hp.com.

— Install directory: Specify where to install the SAP BusinessObjects Enterprise Web 
Tier.

15 On the FPA Application tab, choose one of the following options. Refer to the target/itaapp 
configuration information that is recorded in the 3a) Financial Planning and Analysis 
(FPA) Application Information on page 120.

— Select Simple Connection to specify the database server name, target database name, 
login, and password. 

or
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— Select JDBC URI (Advanced) to specify the database URI.

16 Click Verify Connection to ensure that you have database connectivity, then click Next.

17 Click Next to review the configuration information.

18 Click Run Configuration to begin the file installation process. 

19 When the installation is complete, click Main Menu.

20 Update Java memory options.

a From the Windows Start menu, click > All Programs > Tomcat > Tomcat Configuration.

b Click the Java tab.

c Add these memory settings to Java Options:
-Xmx1024m
-XX:MaxPermSize=256m

d Click Apply and OK.

21 Start Tomcat.

a From the Windows Start menu, click Programs > Control Panel > Administrative Tools > 
Services.

b Right-click the Apache Tomcat service and select Start.

22 Using a text editor, type the remote BOE server name in the domain property of this file:
C:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\dswsbobje
\WEB-INF\classes\dsws.properties

Tomcat Session Time out Parameters

The default time out value for BOE applications is 20 minutes. To extend the session time out 
parameter for the applications and for Tomcat, follow these steps.

1 Stop the Tomcat service.

2 Open this file with a text editor:

<bo_install_dir>\boe\Tomcat55\webapps\dswsbobje\WEB-INF\classes
\dsws.properties

3 Add this property at the end of the file. Express the time out value in seconds. For 
example, a session time-out value of 24 hours would be

# Session timeout
session.timeout=86400

4 Save and close the file.

5 Open this file with a text editor:

<bo_install_dir>\boe\Tomcat55\conf\server.xml

6 Update the connectionTimeout property for port 8080 in server.xml to match the value 
that you specified in dsws.properties, but express the timeout value for the Tomcat 
instance in milliseconds. For example, this is a session timeout value of 24 hours:

connectionTimeout=86400000

7 Save and close the file.

8 Restart the Tomcat service.
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Troubleshooting

If you need to re-install the Financial Planning & Analysis application, follow these steps.

1 Stop the Tomcat service. 

2 From the Windows Control Panel, select Add/Remove Programs.

3 Remove HP Financial Planning & Analysis 9.10.

4 Repeat step 2 on page 70 through step 19 on page 73. 

Java Memory Options

If the web application fails to start, check for an OutOfMemoryError message in the log. For 
example:

SEVERE: Context [/FPA] startup failed due to previous errors
...
java.lang.OutOfMemoryError: PermGen space

This issue might be due to the heap size available to the Java virtual machine used by Apache 
Tomcat. For more information, see Java Memory Options on page 18.

Part 3b: Configure XWIS

The Antivia database is an empty database that you must manually create before running 
this step.  When you configure the database, record the information in the 3b) XWIS 
Configuration Information section of the Checklist on page 121.

 To install and configure Antivia Xcelsius Web Intelligence Integration Suite (XWIS), set up 
connections to the XWIS database.

1 From the Configuration Tool main menu, click Configure XWIS.

2 On the XWIS tab, use the information that you recorded in the 3b) XWIS Configuration 
Information section of the Checklist on page 121 to provide these details:

— Server name: Type the name of the server where the XWIS database resides.

— Database name: Type the name of the XWIS database.

— Login: Type the name that you use to log in to the XWIS database.

— Password: Type the password that you use to access the XWIS database.

— Confirm password: Retype the password.

3 Click Verify Connection to test the connection to the XWIS database.

4 Click Next to review your Antivia XWIS installation and configuration settings and 
complete the configuration.

5 On the Review tab, review your settings for the XWIS database. If you receive errors or 
need to make changes, click the appropriate tab, make the changes, and then return to the 
Review tab to complete the XWIS configuration.

6 Click Run Configuration. The Configuration Tool installs and configures Antivia XWIS and 
populates the XWIS database.
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311)
Note: Several exceptions will appear in the Config log file after the configuration. The 
error messages are expected and indicate that the XWIS database has been populated for 
the first time. For example: 

7 Click Main Menu to return to the Configuration Tool main menu.

Restart Tomcat

After you complete the Web Application and XWIS installation and configuration, HP 
recommends that you restart Apache Tomcat to ensure that the application deploys correctly. 

1 From the Windows Start menu, click Programs > Control Panel > Administrative Tools > 
Services.

2 Right-click the Apache Tomcat service and select Stop.

3 Delete all of the contents in the Tomcat work folder: 

<bo_install_dir>\Tomcat55\work

4 Right-click the Apache Tomcat service and select Start.

Start the Web Application

Type this URL to start the Financial Planning & Analysis application:

http://server_name:8080/FPA/ 

Note: Port 8080 is the default port number. If you use an external Tomcat, make sure that you 
use the correct port number of that Tomcat to access the Financial Planning & Analysis 
application.

You can display the login window, but you will not be able to log into the application until you 
configure user authentication that is consistent with your security requirements. In an 
enterprise environment, user profiles are usually managed through Lightweight Directory 

com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name 'ENTVERSION'.
at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(Unknown Source)
at com.microsoft.sqlserver.jdbc.SQLServerStatement.getNextResult(Unknown Source)
at com.microsoft.sqlserver.jdbc.SQLServerStatement.doExecuteStatement(Unknown Source)
at com.microsoft.sqlserver.jdbc.SQLServerStatement$StmtExecCmd.doExecute(Unknown Source)
at com.microsoft.sqlserver.jdbc.TDSCommand.execute(Unknown Source)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.executeCommand(Unknown Source)
at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeCommand(Unknown Source)
at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeStatement(Unknown Source)
at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeQuery(Unknown Source)
at com.antivia.configtool.model.DBConnectionInfo.getCurrentVersion(DBConnectionInfo.java:
at com.antivia.configtool.ui.ConfigTool.createAndShowGUI(ConfigTool.java:97)
at com.antivia.configtool.ui.ConfigTool.access$100(ConfigTool.java:33)
at com.antivia.configtool.ui.ConfigTool$2.run(ConfigTool.java:173)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
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Access Protocol (LDAP) or Windows Active Directory (AD) authentication. For more 
information, see Chapter 9, Configuring User Roles and Authentication. For isolated 
installations, or test environments, file based authentication may be appropriate. For more 
information, see Appendix B, Setting Up File Based Authentication.
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9 Configuring User Roles and Authentication
Financial Planning & Analysis security models use predefined access levels and security 
roles. Administrators must grant access rights to the groups and security roles using the BOE 
Central Management Console (CMC).

Financial Planning & Analysis supports Lightweight Directory Access Protocol (LDAP) or 
Windows Active Directory (AD) authentication. Administrators can configure the Common 
Web Client (CWC) to enable LDAP. The BI Authentication Processing filter validates users 
and groups.

File based security is a quick way to set up authentication for proof-of-concept, demo, or 
prototype installations. It is not recommended in a production environment. For more 
information, see Appendix B, Setting Up File Based Authentication.

Authentication Model

The Authentication process involves the Financial Planning & Analysis application and BOE. 
Whether you install BOE with Financial Planning & Analysis, or you use an existing BOE 
server, you must complete the required authentication configuration. The authentication 
process consists of these steps:

1 The Financial Planning & Analysis application passes the user name and password to the 
authentication source (LDAP or AD). This step uses the jaas.config and 
applicationContext.xml files.

2 The Authentication Source replies with the user name and attribute details.

3 The Financial Planning & Analysis application passes the information received in Step 2 
to BOE. This action starts the second phase of the authentication process and references 
the web.xml file.

4 BOE queries the Authentication Source with the user name and password.

5 BOE receives authorization from the Authentication source.

6 BOE passes a session ID to the Financial Planning & Analysis application.
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Before you begin, make sure that you have access to your local LDAP or Active Directory 
servers and consult your BOE documentation. Follow the Authentication Checklist to 
complete the authentication tasks. If you want to configure simple authentication, see 
Appendix B, Setting Up File Based Authentication.

Authentication Checklist

Print this checklist to use during the installation process. As you complete each task, mark it 
finished. Complete these tasks on the LDAP or Active Directory server.

Task 1: Create Financial Planning & Analysis Users and Groups on page 79.

If You Choose LDAP Authentication

Task 2a: Configure LDAP Authentication on page 80.

— Step 1: Configure LDAP on the BOE Central Management Console on page 80.

— Step 2: Add User Groups on the BOE Central Management Console on page 81.

— Step 3: Configure the LDAP Options on the BOE Central Management Console on 
page 81.

— Step 4: Test BOE Central Management Console Configuration Access on page 81.

— Step 5: Modify the web.xml File on page 82.

— Step 6: Modify the applicationContext.xml File on page 82.

— Step 7: Modify the jaas.config File on page 83.

— Step 8: Test InfoView Access on page 83.

If You Choose Active Directory Authentication 

Task 2b: Configure Active Directory Authentication on page 84.

— Step 1: Enable Active Directory on the BOE Central Management Console on page 84.

— Step 2: Configure Administration Credentials on the BOE Central Management 
Console on page 85.
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— Step 3: Add Member Groups on the BOE Central Management Console on page 85.

— Step 4: Choose Kerberos Authentication Options on page 85.

— Step 5: Choose Active Directory Authentication Options on page 86.

— Step 6: Test BOE Central Management Console Configuration Access on page 86.

Finishing Authentication Tasks for Active Directory

Task 3: Configure JAVA Authentication for Active Directory on page 87.

— Step 1: Create a krb5.ini File on page 87.

— Step 2: Create a bscLogin.conf File on page 87.

— Step 3: Modify the web.xml File on page 87.

— Step 4: Modify the applicationContext.xml File on page 88.

— Step 5: Modify the jaas.config File on page 88.

— Step 6: Test the Active Directory Connection on page 89.

Task 4: Configure Tomcat for Active Directory on page 89.

— Step 1: Specify the krb5.ini and bscLogin.conf File Locations on page 89.

— Step 2: Edit Authentication Parameters on page 90.

— Step 3: Test InfoView Access on page 90.

Final Steps

Task 5: Configure BOE Access Rights on page 91.

— Step 1: Enable Access to the FPA Analytics and FPA Dashboard Folders on page 91.

— Step 2: Enable Access to the DW Administration and DW Operations Folders on 
page 92.

— Step 3: Enable Access to the Root Folder on page 92.

— Step 4: Enable Users to Refresh Reports on page 93.

Task 6: Test Authentication on page 94.

Task 1: Create Financial Planning & Analysis Users and Groups

You must configure the LDAP or Active Directory host before you make configuration changes 
to BusinessObjects Enterprise XI. This includes adding Financial Planning & Analysis 
out-of-box groups and your own groups to the LDAP or Active Directory server. Changes to 
group names require changes to both the web.xml file and the LDAP or Active Directory 
server. 
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Financial Planning & Analysis (FPA) recognizes the following out-of-box groups.

If you create these groups and assign the user name itauser to each one on the LDAP or Active 
Directory server, you will be able to log in to the Financial Planning & Analysis application. 
Make sure that you also assign the appropriate access rights within BOE for these users; 
otherwise, they will be unable to refresh reports. For more information, see the BOE 
documentation.

Task 2a: Configure LDAP Authentication

Before you define and enable LDAP authentication, create an LDAP server and ensure that 
your LDAP directory is valid. For more information, see your LDAP documentation.

Complete the following steps to configure the host, Secure Socket Layer authentication, LDAP 
mapping options, and LDAP groups.

Step 1: Configure LDAP on the BOE Central Management Console

1 Click Start > Programs > BusinessObjects XI 3.1 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Central Management Console.

2 Log in with your user name and password.

3 Click Authentication, then click the LDAP tab.

4 Click Start LDAP Configuration Wizard.

5 In the Add LDAP Host (hostname: port) field, type your host and port information.

Table 6 User Groups

Group Name Group User Role Read/Write Application Rights

FPA_ANALYTIC FPA analytic designer or 
user

• Dashboards 
• Reports
• Tools

FPA_CE_CONFIG FPA user • Allocations (read only)
• Dashboards
• Reports
• Tools

FPA_ADMIN FPA administrator or super 
user

• Allocations
• Dashboards 
• Reports
• Admin
• Tools

DW_ADMIN Data warehouse 
administrator

• Admin
• Tools

Ensure that all users have a valid password. Financial Planning & Analysis does not support 
blank passwords for users.
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6 Click Add.

7 Click Next.

8 In the LDAP Server Type drop-down list, select your server, and click Next.

9 In the Base LDAP Distinguished Name field, type the distinguished name and click Next.

10 Type the LDAP host credentials:

— In LDAP Server Administration Credentials, type the distinguished name and password 
for a user account that has rights to administer your LDAP server.

— In LDAP Referral Credentials, type the same distinguished name and password you 
entered for LDAP Server Administration Credentials.

11 In the Maximum Referral Hops field, type the number of referral hops to limit forwarding 
the credential request. If you set this field to zero, no referral hops are allowed.

12 Click Next.

13 From the Type of SSL authentication drop-down list, select Basic (no SSL) and click Next.

14 From the Authentication drop-down list, select Basic (no SSO) and click Next.

Step 2: Add User Groups on the BOE Central Management Console

1 Click Start > Programs > BusinessObjects XI 3.1 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Central Management Console.

2 Log in with your user name and password.

3 Click Authentication, then click the LDAP tab.

4 In Mapped LDAP Member Groups, add each out-of-box group listed in Table 6 on page 80 in 
the Add LDAP group (by cn or dn) field.

5 Click Add.

6 Click Update.

7 Repeat step 4 through step 6 to add another group. 

8 To remove a group, select the group entry, click Delete, then click Update.

Step 3: Configure the LDAP Options on the BOE Central Management Console

1 Select the following LDAP options:

— Create a new account for every added LDAP alias 

— Create new aliases only when the user logs on

— New users are created as named users 

2 Click Next.

3 Click Finish.

Step 4: Test BOE Central Management Console Configuration Access

1 Click Start > Programs > BusinessObjects XI 3.1 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Central Management Console.
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2 To log in:

a Type your user name and password. 

b From the Authenticationdrop-down menu, select LDAP. 

3 If the login fails, repeat Step 1 through Step 3 in Task 2a on page 80.

Step 5: Modify the web.xml File

1 Open this file with a text editor:

C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF\web.xml

2 Locate the biAuthType parameter section. This section is commented out for file-based 
authentication. You must uncomment the context-param part of this section to configure 
LDAP authentication.
 <!-- BO authentication method:
         secEnterprise (file based)
         secLDAP (LDAP),
         secWinAD (Active Directory)
Default is secEnterprise if this param is not set
<context-param>
    <param-name>biAuthType</param-name>
    <param-value>secEnterpise</param-value>
</context-param>
-->

3 Uncomment the context-param by moving the --> so that it is placed before the 
context-param element:
<!-- BO authentication method:
         secEnterprise (file based)
         secLDAP (LDAP),
         secWinAD (Active Directory)
Default is secEnterprise if this param is not set -->
<context-param>
    <param-name>biAuthType</param-name>
    <param-value>secEnterpise</param-value>
</context-param>

4 Change the parameter value to secLDAP. The result should look like this:

<context-param>
<param-name>biAuthType</param-name>
<param-value>secLDAP</param-value>

</context-param>

5 Save and close the file.

Step 6: Modify the applicationContext.xml File

1 Open this file with a text editor:

No navigation items are available because the groups do not have rights.
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C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF
\applicationContext.xml

2 Locate the loginContextName property in the jaasAuthenticationProvider section.

3 Change the parameter value to dpJndi. The result should look like this:

<bean id="jaasAuthenticationProvider" 
class="org.acegisecurity.providers.jaas.JaasAuthenticationProvider">

<property name="loginConfig" value="/WEB-INF/jaas.config"/>
<property name="loginContextName" value="dpJndi"/>
…

</bean>

4 Save and close the file.

Step 7: Modify the jaas.config File

1 Open this file with a text editor:

C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF\jaas.config

2 Locate the dpJndi section.

3 Change the parameter values to your local values. Verify whether the specified parameter 
values have case sensitivity restrictions. 

The result should look like this: 

where any value shown in italics is replaceable with a valid local value. For more 
information about the settings, see the sample jaas.config file on the installation media.

4 Save and close the file.

Step 8: Test InfoView Access

1 Click Start > Programs > BusinessObjects XI 3.1 > BusinessObjects Enterprise > 
BusinessObjects Enterprise JavaInfoView.

2 To log in:

a Type the user name and password that you used in Step 4: Test BOE Central 
Management Console Configuration Access on page 81.

b From the Authenticationdrop-down menu, select LDAP.

dpJndi {
  com.hp.ov.cwc.security.jaas.JndiLoginModule required
    ldap.server.url="ldap://server.name.com:ort_number"
    manager.dn="uid=admin,ou=administrators,dc=my,dc=server,dc=com"
    manager.password="password_value"
    user.search.base="dc=labs,dc=peregrine,dc=com"
    user.search.filter="(&(uid=<0>)(objectClass=person))"
    group.search.base="ou=groups,dc=labs,dc=peregrine,dc=com"
    group.search.filter="(&(uniqueMember=<0>)
     (objectClass=groupOfUniqueNames))";
};
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3 If the login fails, repeat Step 1 through Step 3 in Task 2a page 80. 

Task 2b: Configure Active Directory Authentication

Windows Active Directory is an optional method of authentication. Before you set up and 
enable Active Directory authentication, make sure that you have the correct domain and 
group information and that you have a user account on the Business Objects server that 
enables you to authenticate administrative users and groups. 

You can avoid initial configuration issues by following these suggestions:

• Use the default Financial Planning & Analysis groups. You can add custom groups after 
you successfully confirm the connection.

• Ensure that the Active Directory groups are Security Groups and not Distributed Groups.

• Financial Planning & Analysis Active Directory authentication does not support multiple 
users across multiple domains. You can use InfoView to create and view reports.

• For initial testing, make sure that users are in the base directory that is specified in 
Business Objects and the URL of the jaas.config file.

• Do not use Secure Socket Layer during the initial configuration. You can add this option 
after you confirm authentication on port 389.

When you create a Security Principal user, follow these suggestions:

• Ensure that this user is a member of the Domain Users group with rights to search all 
users.

• Assign this user to the same Active Directory container as other users who will be trying 
to authenticate.

• Verify that this user has DES encryption set and that the password has not expired.

• Ensure that you do not select the do not require Kerberos preauthentication option for the 
Security Principal user.

• Add the Security Provider user to the default Financial Planning & Analysis groups for 
initial testing with the Security Principal to confirm successful authentication. 

Step 1: Enable Active Directory on the BOE Central Management Console

1 On the Business Objects server, ensure that the Central Management Server is running.

2 Click Start > Programs > BusinessObjects XI Release 3.1 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Central Management Console.

3 Type your User Name, Password, and click Log On.

4 In the Manage section, click Authentication.

5 Click the Windows AD tab.

At this time, you can assign appropriate access rights for users to enable them to refresh 
reports.

Ensure that all users have a valid password. Financial Planning & Analysis does not support 
blank passwords for users. 
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6 If necessary, select Windows Active Directory Authentication is enabled.

Step 2: Configure Administration Credentials on the BOE Central Management 
Console

Administration credentials enable a Business Objects user to use Active Directory 
authentication, map groups, check rights, and perform other tasks.

1 Click the value for the AD Administration Name to change it.

2 Type the Name and Password of the domain user account configured on your Active 
Directory server. Business Objects Enterprise will use this name and password to 
authenticate Active Directory users and groups. Use one of these formats:

— NT name (DomainName\UserName). For example:

server.domain.com\dc_administrator

— User Principal Name (UPN) (user@DNS_domain_name). For example:

dc_administrator@DNS_domain.com

3 Type the Default AD Domain value. You must specify a default domain to enable Active 
Directory authentication and to map groups. For example:

server.domain.com

4 Click Update.

Step 3: Add Member Groups on the BOE Central Management Console

1 Type the group name in the Add AD Group (Domain\Group) field in this format:

DomainName\GroupName

For example: 

server.domain\FPA_Admin

2 Click Add.

3 Repeat the following steps for each out-of-box group name described in Table 6 on page 80.

4 When you finish adding all groups, click Update.

Step 4: Choose Kerberos Authentication Options

1 Select Use Kerberos authentication.

2 Select Cache security context (required for SSO to database).

3 Type the Service principal name. This should be the administrator user that you created in 
Step 2: Configure Administration Credentials on the BOE Central Management Console 
on page 85. For example:

ita_administrator@DNS_domain.com

If you specify the Default AD Domain name, users do not have to specify the Active 
Directory domain name when they log in to Business Objects Enterprise with 
Active Directory authentication.
85



Step 5: Choose Active Directory Authentication Options

1 Choose these options. 

2 Click Update. A message appears stating that it will take several seconds to update the 
member groups.

3  Click OK.

Step 6: Test BOE Central Management Console Configuration Access

1 Click Start > Programs > BusinessObjects XI 3.1 > BusinessObjects Enterprise > 
BusinessObjects Enterprise Central Management Console.

2 To log in:

a Type your user name and password. 

b From the Authenticationdrop-down menu, select Windows AD. 

3 If the login fails, repeat Step 1 through Step 3 in Task 2b on page 84.

Table 7  Authentication 0ptions

Option Description

Assign each added AD 
alias to an account with 
the same name

Use this option when you know users have an existing 
enterprise account with the same name. Active 
Directory aliases are assigned to existing users if auto 
alias creation is active. Users who do not have an 
existing enterprise account, or who do not have the same 
name in their enterprise and Active Directory account, 
are added as new Active Directory users.

New aliases will be added 
and new users will be 
created

Choose this option to automatically create a new alias 
for every Active Directory user mapped to Business 
Objects Enterprise. 

New users are created as 
named users
or
New users are created as 
concurrent users

Choose this option for Named User licenses.

or
Choose this option for Processor licenses. 

New Active Directory accounts are added for users without 
Business Objects Enterprise accounts, or for all users if you 
selected the Create a new account for every added AD alias option.

No navigation items are available because the groups do not have rights.
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Task 3: Configure JAVA Authentication for Active Directory

BOE uses a Java authentication module called Krb5AuthLoginModule. This log-in module 
requires some additional configuration information. There are two configuration files, krb5.ini 
and bscLogin.conf.

By default, the Java SDK automatically looks for these configuration files in C:\winnt folder 
even if this folder does not exist. You can create the files in the C:\winnt folder, or in any other 
folder.

Step 1: Create a krb5.ini File

This file gives Java information about your domain and location of the Kerberos Key 
Distribution Center. This file can be simple or complex depending on the size and 
implementation of your Active Directory domain. 

For example: 

[libdefaults] 
default_realm = DOMAIN.COM 
dns_lookup_kdc = true 
dns_lookup_realm = true 
[realms] 
DOMAIN.COM = {
kdc = ADSERVER.DOMAIN.COM 
default_domain = DOMAIN.COM 
}

Step 2: Create a bscLogin.conf File

The bscLogin.conf file is the JAAS log-in configuration file. It contains an entry that specifies 
the authentication technology to be used. When you use the SUN Java SDK, the entry looks 
like this:

com.businessobjects.security.jgss.initiate {
com.sun.security.auth.module.Krb5LoginModule required; 
}; 

Step 3: Modify the web.xml File

1 Open this file with a text editor:

C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF\web.xml

2 Locate the biAuthType parameter section. This section is commented out for file-based 
authentication. You must uncomment the context-param part of this section to configure 
AD authentication.
 <!-- BO authentication method:
         secEnterprise (file based)
         secLDAP (LDAP),
         secWinAD (Active Directory)
Default is secEnterprise if this param is not set
<context-param>
    <param-name>biAuthType</param-name>
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    <param-value>secEnterpise</param-value>
</context-param>
-->

3 Uncomment the context-param by moving the --> so that it is placed before the 
context-param element:
<!-- BO authentication method:
         secEnterprise (file based)
         secLDAP (LDAP),
         secWinAD (Active Directory)
Default is secEnterprise if this param is not set -->
<context-param>
    <param-name>biAuthType</param-name>
    <param-value>secEnterpise</param-value>
</context-param>

4 Change the parameter value to secWinAD. The result should look like this:

<context-param>
<param-name>biAuthType</param-name>
<param-value>secWinAD</param-value>

</context-param>

5 Save and close the file.

Step 4: Modify the applicationContext.xml File

1 Open this file with a text editor:

C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF
\applicationContext.xml

2 Locate the loginContextName property in the jaasAuthenticationProvider section.

3 Change the parameter value to QAAD. The result should look like this:

<bean id="jaasAuthenticationProvider" 
class="org.acegisecurity.providers.jaas.JaasAuthenticationProvider">

<property name="loginConfig" value="/WEB-INF/jaas.config"/>
<property name="loginContextName" value="QAAD"/>
…

</bean>

4 Save and close the file.

Step 5: Modify the jaas.config File

1 Open this file with a text editor:

C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF\jaas.config

2 Locate the QAAD section.

3 Change the parameter values to your local values. Verify whether the specified parameter 
values have case sensitivity restrictions.
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The result should look like this:  

where any value shown in italics is replaceable with a valid local value  For more 
information about the settings, see the sample jaas.config file on the installation media.

4 Save and close the file.

Step 6: Test the Active Directory Connection

You can verify that your connection is valid by running a command line utility. Follow these 
steps:

1 Open a Windows command line window.

2 Change directories to:

<bo_install_dir>\javasdk\bin

3 Run this command:

kinit.exe username@domain <mailto:username@domain> password

The user name should identify the administrator that you created in Step 2: Configure 
Administration Credentials on the BOE Central Management Console on page 85. For 
example:

ita_administrator@DNS_domain.com password 

Task 4: Configure Tomcat for Active Directory

Tomcat loads Java at startup. Java needs to know the location of the krb5.ini and 
bscLogin.conf files.

Step 1: Specify the krb5.ini and bscLogin.conf File Locations 

1 Stop Tomcat.

2 Click Start > Programs > Tomcat > Tomcat Configuration. 

3 Click the Java tab.

4 At the bottom of the list of options in the Java Options text box, type these values:

-Djava.security.auth.login.config=C:\winnt\bscLogin.conf 
-Djava.security.krb5.conf=C:\winnt\Krb5.ini 

QAAD {
  com.hp.ov.cwc.security.jaas.JndiLoginModule required
   ldap.server.url="ldap://server.name:port"
   manager.dn="CN=admin,OU=Users,DC=your,DC=server,DC=com"
   manager.password="password_value"
   user.search.base="DC=labs,DC=peregrine,DC=com"
   user.search.filter="(&(sAMAccountName=<0>)(objectClass=user))"
   group.search.base="group"
   group.search.filter="(&(member=<0>)(objectClass=group))";
};
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5 Click OK.

Step 2: Edit Authentication Parameters

1 Open this file with a text editor:

C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF\web.xml

2 Change this parameter:

<context-param>
<param-name>biAuthType</param-name>
<param-value>secLDAP</param-value>

</init-param>

      To

<context-param>
<param-name>biAuthType</param-name>
<param-value>secWinAD</param-value>

</context-param>

3 Save and close the file.

4 Open this file with a text editor:

C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF
\applicationContext.xml

5 Locate this section:

<bean id="jaasAuthenticationProvider" class="....">

6 Change the value in this section:

<property name="loginContextName">
<value>dpJndi</value>

</property>

To

<property name="loginContextName">
<value>QAAD</value>

</property>

7 Save and close the file.

8 Delete this directory:

...\Tomcat\work\Catalina\localhost\FPA

9 Restart the Tomcat service.

Step 3: Test InfoView Access

1 Click Start > Programs > BusinessObjects XI 3.1 > BusinessObjects Enterprise > 
BusinessObjects Enterprise JavaInfoView.

2 To log in:

a Type the user name and password that you used in Step 6: Test the Active Directory 
Connection on page 89.

b From the Authenticationdrop-down menu, select Windows AD.
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3 If the login fails, repeat Step 1 through Step 3 in Task 2b on page 84. 

Task 5: Configure BOE Access Rights

You must enable FPA users or groups to view or edit the contents of a BOE folder and disable 
the access to any folder that a user or group should not view or edit.

Step 1: Enable Access to the FPA Analytics and FPA Dashboard Folders 

Follow these steps to grant access to the FPA analytics and FPA dashboard folders.

1 From the Windows Start menu, click Programs > BusinessObjects XI 3.1 > BusinessObjects 
Enterprise > BusinessObjects Enterprise Central Management Console.

2 Login with the appropriate credentials. (The default value is Administrator with no 
password.)

3 Select Folders from the drop-down list in the upper left corner.

4 Right-click the FPA EN FPA Analytics folder and select User Security from the context menu. 
The Central Management Console displays the User Security: FPA EN FPA Analytics window.

5 Select Add Principals. The Add Principals window appears.

6 Add full access rights to the FPA_ANALYTIC group.

a Choose FPA_ANALYTIC from the list of Available users/groups.

b Click the single right arrow (>) to move this selection to the Selected users/groups list.

c Click Add and Assign Security. The Central Management Console displays the Assign 
Security window.

d Choose Full Control from the list of Available Access Levels.

e Click the single right arrow (>) to move this selection to the Assigned Access Levels 
list.

f Click OK.

7 Add view access rights to the DW_ADMIN group.

a Select Add Principals.

a Choose DW_ADMIN from the list of Available users/groups.

b Click the single right arrow (>) to move this selection to the Selected users/groups list.

c Click Add and Assign Security. The Central Management Console displays the Assign 
Security window.

d Choose View from the list of Available Access Levels.

e Click the single right arrow (>) to move this selection to the Assigned Access Levels 
list.

f Click OK.

8 Click Close.

At this time, you can assign appropriate access rights for users to enable them to refresh 
reports.
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9 Repeat step 4 through step 8 on page 91, replacing FPA EN FPA ANALYTICS with FPA EN 
FPA Dashboard.

Step 2: Enable Access to the DW Administration and DW Operations Folders

Follow these steps to grant access to the data warehouse administration and operations 
folders.

1 If necessary, select Folders from the drop-down list in the upper left corner of the Central 
Management Console.

2 Right-click the DW EN Administration folder and select User Security from the context menu. 
The Central Management Console displays the User Security: DW EN Administration 
window.

3 Select Add Principals. The Add Principals window appears.

4 Choose DW_ADMIN from the list of Available users/groups.

5 Click the single right arrow (>) to move this selection to the Selected users/groups list.

6 Click Add and Assign Security. The Central Management Console displays the Assign 
Security window.

7 Choose Full Control from the list of Available Access Levels.

8 Click the single right arrow (>) to move this selection to the Assigned Access Levels list.

9 Click OK.

10 Click Close.

11 Repeat step 2 through step 10, replacing DW EN Administration with DW EN Operations.

Step 3: Enable Access to the Root Folder

Follow these steps to grant the users and groups access to the root folder.

1 If necessary, select Folders from the drop-down list in the upper left corner of the Central 
Management Console.

2 Right-click All Folders and select Properties from the context menu.

3 Select User Security. The Central Management Console displays the User Security: Root 
Folder window.

4 Select Add Principals. The Add Principals window appears.

5 Add full access rights to the FPA groups.

a Choose FPA_ANALYTIC, FPA_ADMIN, and FPA_CE_CONFIG  from the list of Available 
users/groups.

b Click the single right arrow (>) to move this selection to the Selected users/groups list.

c Click Add and Assign Security. The Central Management Console displays the Assign 
Security window.

d Choose Full Control from the list of Available Access Levels.

e Click the single right arrow (>) to move the selection.
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f On the Advanced tab, click Add/Remove Rights. 

g In the right pane, scroll to select View Objects in the list. and do the following:

– Select the green check icon to grant acccess.

– Clear the Apply to SubObject check box.

h Click OK to return to the Add Principals window.

i Click OK to return to the User Security: Root Folder window.

6 Add view access rights to the DW_ADMIN group.

a Select Add Principals. The Add Principals window appears.

a Choose DW_ADMIN from the list of Available users/groups.

b Click the single right arrow (>) to move this selection to the Selected users/groups list.

c Click Add and Assign Security. The Central Management Console displays the Assign 
Security window.

d Choose View from the list of Available Access Levels.

e Click the single right arrow (>) to move the selection.

f Click OK to return to the Add Principals window.

g Click OK to return to the User Security: Root Folder window.

7 Click Close.

Step 4: Enable Users to Refresh Reports

You must assign access rights to the Universe Designer to refresh WebI reports.

1 Select Users and Groups from the drop-down list in the upper left corner of the Central 
Management Console.

2 In the right pane, right-click FPA_ANALYTIC and select Member Of from the context menu.

3 Select Join Group. The Central Management Console displays the Join Group: 
FPA_Analytic window.

4 Select Group Hierarchy.

5 Select Universe Designer Users.

6 Click the right arrow (>) to move it into the Destination Group(s) list.

7 Click OK.

8 Repeat step 2 through step 7 for FPA_ADMIN, FPA_CE_CONFIG, and DW_ADMIN.

9 Close the Central Management Console.

For more information, see the SAP BusinessObjects Enterprise XI 3.1 Administration Guide.

You can ignore the highlighted yellow message at the top of the window.

Click File > Exit to ensure that the session closes correctly.
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Task 6: Test Authentication

1 From a browser, type the Financial Planning & Analysis URL. For example:

http://server_name:8080/FPA 

2 Type the user login and password for one of the user profiles that you created.

3 If the login fails, repeat the configuration tasks in the LDAP or Active Directory sections.

4 If the login succeeds, test the other user login and password combinations that you 
created.

Troubleshooting

When authentication fails, do the following:

• Review modified files for spelling errors and case sensitivity.

• Verify user and group settings in the BOE Central Management Console.

• Start the debugging feature in log4j.xml files to trace the authentication process.

• If an error message appears indicating that the system could not locate the navigation 
menu, verify that the user belongs to a valid FPA group.

LDAP Authentication

Modified Files

If LDAP authentication fails, review this information from these files located in the 
C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF directory:

• The biAuthType is set to secLDAP in web.xml.

• The loginContextName is set to dpJndi in applicationContext.xml.

• The dpJndi section is configured properly in jaas.config.

BOE Central Management Console

Verify this information from the CMC:

• The user names are spelled correctly with the correct case.

• The group names are spelled correctly with the correct case and match the groups that are  
in web.xml.

• The user has been added to the group.
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InfoView Authentication

When accessing the InfoView login page from Financial Planning & Analysis, the option to 
choose the authentication type might not be available. Updating the InfoView web.xml file 
enables users   to select LDAP authentication. 

1 Open this file with a text editor:

<bo_install_dir>\boe\Tomcat55\webapps\InfoViewApp\\WEB-INF\web.xml

2 Locate the authentication.visible parameter name.

3 Change the parameter value to true. The result should look like this:

4 Save and close the file.

If a user cannot access InfoView, review the user and group settings. If a user can access  
infoView but not Financial Planning & Analysis, check the group settings:

• If needed, delete the group from the BOE CMC and re-add it.

• Verify that the user is in a regular group, not an organization unit or security group.

Active Directory Authentication

When Active Directory authentication fails, review the spelling and case of these files located 
in the C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF directory:

• web.xml

• applicationContext.xml

• jaas.config

Check the spelling and case of the following files. They are in the location you specified when 
you configured Tomcat for Active Directory:

• krb5.ini

• bscLogin.conf 

Authentication Log Files

By setting the log files to trace the authentication process, you can identify possible security 
or configuration issues.

Creating Business Objects Logs

1 From the Windows Start menu, click All Programs > Tomcat > Tomcat Configuration.

2 Click the Java tab.

3 In Java Options, add this statement:

-Dcrystal.enterprise.trace.configuration=verbose

4 Click OK.

   <context-param>
        <param-name>authentication.visible</param-name>
        <param-value>true</param-value>
   </context-param>
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5 View this file:
<bo_install_dir>\boe\Tomcat55\logs\stdout.log

You can also view this file: 
C:\documents and settings\<username>\.businessobjects\jce_verbose.log

Creating Financial Planning & Analysis Logs

To begin logging files, change the level value in log4j.xml for Common Web Client (CWC).

1 Open this file with a text editor:

C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF\classes\log4j.xml

2 Locate logger name="com.hp.ov.cwc".

3 Change the level value to debug. The result should look like this:

<logger name="com.hp.ov.cwc" additivity="false">
     <level value="debug" />
     <appender-ref ref=”cwc”>
</logger>

4 Verify that the log path for the cwc appender section is a valid server location. If not, log 
files will be located in C:\Windows\system32. For example:

<!-- cwc file appender -->
 <appender name="cwc" class="org.apache.log4j.RollingFileAppender">
   <param name="File" value="C:\cwc.log"/>
   <param name="MaxFileSize" value="1000KB"/>
   <param name="MaxBackupIndex" value="3"/>
   <layout class="org.apache.log4j.PatternLayout">
      <param name ="ConversionPattern" value="%d [%-5p] %t %c - %m%n"/>
   </layout>
 </appender>
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10 Next Steps
After you install the required components of the Financial Planning & Analysis application 
and data warehouse, and configure security roles, you should be able to start the application 
user interface. You must complete these post-installation tasks.

• Task 1: Change Connection Properties in the BOE Central Management Console.

• Task 2: Schedule Reports to Refresh on page 98.

• Task 3: Install Financial Planning & Analysis 9.11 on page 99.

Task 1: Change Connection Properties in the BOE Central Management Console

Because each Financial Planning & Analysis component uses a connection to BusinessObjects 
Enterprise (BOE), you must increase the default settings for the connections in the BOE 
Central Management Console.

1 From the Windows Start menu, click Programs > BusinessObjects XI 3.1 > BusinessObjects 
Enterprise > BusinessObjects Enterprise Central Management Console.

2 Log on the BOE Central Management Console as an administrator.

3 Click Servers.

4 Expand Service Categories in the left pane.

5 Click Web Intelligence.

6 Double-click ITAnalytics.WebIntelligenceProcessingServer in the right pane.

7 In the Properties window, change the values for the following settings:

— Maximum Documents per User: HP recommends that you increase this setting to  20. 
However, this value should be set according to the needs of your company.
This setting specifies the maximum number of active sessions or Web Intelligence 
reports that can be associated with a user at any time. The valid range is 1 – 20.

— Maximum Connections: HP recommends that you increase this setting to 700. However, 
this value should be set according to the needs of your company.
This setting specifies the approximate maximum number of simultaneous sessions 
that can be opened at one time. The valid range is 5 – 65,535.

— Idle Connection Timeout (minutes): HP recommends that you increase this setting to 40. 
However, this value should be set according to the needs of your company.
This setting specifies the number of minutes that the server waits for a request from 
an idle connection. If you set this value too low, the request may close prematurely. If 
you set this value too high, requests will be queued while the server waits for idle 
requests to close.

8 Click Save & Close.

9 Log off the BOE Central Management Console and close the application.

10 Stop the BOE service:
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a From the Windows Start menu, click Programs > BusinessObjects XI 3.1 > 
BusinessObjects Enterprise > Central Configuration Manager.

b Right-click the Server Intelligence Agent (IT Analytics) service and select Stop.

11 Stop the Tomcat service: 

— In the Central Configuration Manager, right-click the Apache Tomcat 5.5.20 service and 
select Stop.

12 Restart the BOE service: 

— In the Central Configuration Manager, right-click the Server Intelligence Agent (IT 
Analytics) service and select Start.

13 Delete all of the contents in the Tomcat work folder: 

<bo_install_dir>\Tomcat55\work\

14 Restart the Tomcat service:

— In the Central Configuration Manager, right-click the Apache Tomcat 5.5.20 service and 
select Start.

Task 2: Schedule Reports to Refresh

You must schedule the Web Intelligence (WebI) reports to refresh automatically to get the 
most current data from your sources. The XcelSius components require that you use the 
schedule feature to properly retrieve data. Do not refresh reports manually or run them 
interactively to refresh them.

1 From the Windows Start menu, click Programs > BusinessObjects XI 3.1 > BusinessObjects 
Enterprise > BusinessObjects Enterprise Java InfoView.

2 Log on to InfoView.

3 Click Document List.

4 Expand Public Folders.

5 Find the report folders for analytics and  dashboards:

— FPA EN FPA Analytics: Contains the WebI reports for Financial Planning & Analysis.

— Xcelsius FPA Dashboard Data Provider: Contains the WebI reports for the Financial 
Planning & Analysis dashboards.

6 Click the FPA EN FPA Analytics folder.

7 Schedule a report to refresh.

a Right-click a report in the right pane and select Schedule.

b Click Recurrence in the left pane.

c From the Run object drop-down list, select a recurrence value according to how often 
your business needs to refresh data.

If the default or published allocation scenario is modified, dashboards will not be 
current until the WebI is refreshed.
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d Depending on the recurrence value that you choose, InfoView displays additional 
fields where you can enter specifics about when to refresh the report. Provide the 
information for these fields, then click Schedule.

8 Repeat step 7 for each report in the folder.

9 Click the Xcelsius FPA Dashboard Data Provider folder.

10 To schedule a report to refresh, repeat step 7 for each report in the folder.

Task 3: Install Financial Planning & Analysis 9.11

Financial Planning & Analysis (FPA) 9.11 is an optional patch that provides support for 
loading data from a non-HP data source into the FPA data warehouse. If you want to install 
FPA 9.11, you must install it on top of FPA 9.10 before you complete the initialization or run 
the extract, transform, and load (ETL) process. Do not complete the tasks described in the HP 
FPA 9.10 Data Warehouse Administration Guide. Go to the HP Software Patches web site to 
download the FPA 9.11 patch .zip file. Then follow the instructions in the HP FPA 9.11 
Installation and Configuration Guide to install and configure FPA 9.11, initialize the FPA 
9.11 data warehouse, and run the initial ETL process. 

HP Software Patches web site: https://ovrd.external.hp.com/rd/
sign-in?TYPE=33554433&REALMOID=06-000dbac2-dc02-1680-9aa0-a14d91440000&GUID=
&SMAUTHREASON=0&METHOD=GET&SMAGENTNAME=$SM$i%2bVqGd4Zrg0nzFPT
AbCG%2fQrn0f2UZowYfT2RitHvQEb1t1qlFq3Rt65IHxgfcRnD&TARGET=$SM$http%3a%2f
%2fsupport%2eopenview%2ehp%2ecom%2fselfsolve%2fpatches

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

HP recommends that you refresh nightly, depending on the amount of data and 
the size of your server.

If you do not want to install FPA 9.11, view the HP FPA 9.10 Data Warehouse Administration 
Guide for the next steps to create a successful initial ETL process. You can download the 
current version of the guide from the HP Support manuals web site. For more information, 
see Support on page 4.
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A Installing SAP BusinessObjects Xcelsius and the 
Xcelsius XWIS Add-On
The SAP BusinessObjects Xcelsius 2008 SP3 product is a visual tool that you can use to create 
and edit analytics and dashboards. DVD 2, labeled Dashboard Development Kit, contains the 
files for the installation of Xcelsius. 

Although Xcelsius is optional, you must install it and the Antivia Xcelsius™ Web Intelligence 
Integration Suite (XWIS)  add-on to enable Financial Planning & Analysis to retrieve data 
from the BOE server and to create customized dashboards.  

Install Xcelsius

If you install Xcelsius, you can take advantage of its ability to integrate with the Microsoft 
Office suite of tools. For example, if you have an SAP BusinessObjects Xcelsius installation, 
you can e-mail reports or embed analytics in Microsoft PowerPoint presentations. It also 
integrates with the Financial Planning & Analysis installation of BOE to create new analytics 
or dashboards. 

You must install Xcelsius at the command line. Do not use the Windows installer. Enterprise 
licensing for Xcelsius is not managed through the Windows interface and the command line 
installation also installs the required Xcelsius fixpacks.

Requirements

Xcelsius requires installation of Microsoft Excel 2003 or 2007 and Adobe Flash 
Player 10.0.45.2 or higher. For a complete list of Xcelsius 2008 SP3 supported platforms, see 
the Xcelsius 2008 Service Pack 3 – Supported Platforms documentation at this web site:

http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/
50fdb3d2-50cc-2c10-e392-a2e481f71694?QuickLink=index&overridelayout=true

Table 8 describes the minimum hardware requirements for the server that hosts SAP 
BusinessObjects Xcelsius 2008 SP3. 

Table 8 Xcelsius 2008 SP3 Hardware Requirements

Item Minimum Requirement

Disk Space 1.25 GB

RAM 1 GB

Processor 1 GHz
101

http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/50fdb3d2-50cc-2c10-e392-a2e481f71694?QuickLink=index&overridelayout=true


Command Line Syntax

You can install Xcelsius 2008 SP3 at the command line.  

:

Return codes

0  – Success

1  –  Success with warnings

>1 –  Errors

Examples

install-xcelsiusSP3 -installdir “C:\Program Files\xcelsius\”

install-xcelsiusSP3 -help

Installation Steps

1 Copy the DVD-2 contents from the installation media to your local file system.

2 If you are copying files to a remote machine where Xcelsius will be installed, you must 
make the files writeable before installing:

— Right-click the root directory where the contents of DVD2 were copied, clear the 
Read-only check box, and select to apply this change to all its sub-folders and files.

3 Open a Windows command line window.

4 Change to the location where you copied the DVD-2 contents.

5 Type this command:

install-xcelsiusSP3 

6 Press Enter. After the Xcelsius installation completes, your system may restart.

To specify a different installation directory, see Command Line Syntax on this page.

Syntax

install-xcelsiusSP3 [-installdir <directory>]

[-help] 

Table 9 Syntax Options

Option Required? Description

-installdir path_and_directory N Installation path and directory. If none is 
specified, the default is: 
C:\Program Files\HP\BO\xcelsius.
Note: If other BOE applications exist on the 
host server, Xcelsius 2008 SP3 installs in 
the same directory, regardless of the 
-installdir specification.

-help N Display command syntax.
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Install the Xcelsius XWIS Add-On

Install the Antivia Xcelsius Web Intelligence Integration Suite for HP OEM add-on to enable 
Financial Planning & Analysis to retrieve data from the BOE server. For more information 
about XWIS Components and Content Panel used with Financial Planning & Analysis, see 
the Antivia Xcelsius Web Intelligence Integration Suite (XWIS) User Guide HP OEM Version 
available on the FPA installation media. 

1 Download the add-on from the XWIS web application. From Windows Internet Explorer 
type the address of the XWIS application that you configured in Part 3b: Configure XWIS 
on page 74.
For example, http://fpa.americas.hpqcorp.net:8080/xwis-webapp

2 From the Components list on the web application getting started window, click Download 
antivia-xwis XLX.

3 Navigate to the location on your computer where you want to save the file and click Save. 
Antivia saves the file to your computer as a .zip file.

4 Change the extension from .zip to .xlx.

5 Open Xcelsius. From the File menu, select Manage Add-Ons to open the Xcelsius Add-On 
Manager.

6 Click Install Add-On, navigate to the location of the antivia-xwis.xlx file you saved in step 4, 
and double-click it. 

Xcelsius installs the add-on. When the add-on is successfully installed, Xcelsius Web 
Intelligence Integration Suite for HP OEM appears in the Xcelsius Add-On Manager window. 

7 Click Close to close Add-On Manager.

8 Click Exit.

9 Close the XWIS application window.
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B Setting Up File Based Authentication
File based authentication is a quick way to set up temporary authentication for a test 
environment or prototype. It is not recommended for a production environment. 

File Based Authentication Checklist

Print this checklist to use during the installation process. As you complete each task, mark it 
finished. Complete these tasks to configure authentication specified by a file.

Task 1: Create a User on this page.

Task 2: Create a Group on page 106.

Task 3: Configure File Based Authentication on page 106.

Task 4: Configure Financial Planning & Analysis Access Rights on page 107.

Task 5: Configure BOE Access Rights on page 107.

— Step 1: Enable Access to the FPA Analytics and FPA Dashboard Folders on page 107.

— Step 2: Enable Access to the DW Administration and DW Operations Folders on 
page 108.

— Step 3: Enable Access to the Root Folder on page 109.

— Step 4: Enable Users to Refresh Reports on page 110.

Task 6: Test Authentication on page 110.

Task 1: Create a User

1 From the Windows Start menu, click All Programs > BusinessObjects XI 3.1 > 
BusinessObjectsEnterprise > Business Objects Central Management Console.

2 Click Users and Groups.

3 Right-click User List and select New User. 

4 Type an Account Name, such as demo.

5 Type a Password value. 

6 Re-type the password to Confirm.

7 Accept (or change) the default Authentication Type (Enterprise) and the Connection Type 
(Concurrent User).

8 Click Create & Close.

You must use BusinessObjects to create a user and group prior to configuring file based 
authentication and accessing the web application.
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Task 2: Create a Group

1 If necessary, log in to the BusinessObjects Central Management Console: From the 
Windows Start menu, click All Programs > BusinessObjects XI 3.1 > 
BusinessObjectsEnterprise > Business Objects Central Management Console.

2 Log in with the appropriate credentials.

3 From the upper left drop-down list, select Users and Groups.

4 In the left navigation pane, right-click Group List and select New Group.

5 Type a new Group Name. For example, type FPA_ADMIN.

6 Click OK. The new group appears in the right pane.

7 In Tasks 4 and 5 below, you will need groups for FPA_ANALYTIC, FPA_CE_CONFIG, and 
DW_ADMIN. Repeat 4 to 6 above to create the FPA_ANALYTIC, FPA_CE_CONFIG, and 
DW_ADMIN groups.

8 To populate your groups with users, right-click the new group and select Add Members to 
Group.

9 Add one or more users to the group by selecting a user role and clicking the right arrow (>) 
to move that user role into the group. For example, you can select Everyone, or select 
Administrators to limit the access to Administrators.

10 Click OK and close the Central Management Console.

Task 3: Configure File Based Authentication

1 Open this file with a text editor:

C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF\web.xml

2 Change this parameter:

<init-param>
<param-name>biAuthType</param-name>
<param-value>secLDAP</param-value>

</init-param>

      To

<init-param>
<param-name>biAuthType</param-name>
<param-value>secEnterprise</param-value>

</init-param>

3 Save and close the file.

4 Open this file with a text editor:

C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF
\applicationContext.xml

5 Locate this section:

<bean id="jaasAuthenticationProvider" class="....">

6 Change the value in this section:

<property name="loginContextName">
<value>dpJndi</value>
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</property>

To

<property name="loginContextName">
<value>BILoginModule</value>

</property>

7 Save and close the file.

Task 4: Configure Financial Planning & Analysis Access Rights

1 Stop the Tomcat service.

2 Delete this directory:

...\Tomcat\work\Catalina\localhost\FPA

3 Under the C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF\lib directory, 
rename file ita-application-main.jar to ita-application-main.zip.

4 Open the renamed ita-application-main.zip file with WinZip.

5 Extract the biusers.properties file to this location:

C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF\classes
\biusers.properties

6 Open it with a text editor.

7 Locate the last line and replace demo=demo with the login=password value that you 
specified when you defined the generic user in Task 1: Create a User, step 4 and step 5 on 
page 105. The groups that the user is part of follow the password value. The line will look 
like this: 

demo=demo,FPA_ADMIN,FPA_ANALYTIC, FPA_CE_CONFIG, DW_ADMIN

8 Save and close the file.

9 Add the biusers.properties file back into ita-application-main.zip using Winzip.

10 Rename the ita-application-main.zip file to ita-application-main.jar.

11 Restart the Tomcat service.

Task 5: Configure BOE Access Rights

You must enable FPA users or groups to view or edit the contents of a BOE folder and disable 
the access to any folder that a user or group should not view or edit.

Step 1: Enable Access to the FPA Analytics and FPA Dashboard Folders 

Follow these steps to grant access to the FPA analytics and FPA dashboard folders.

1 From the Windows Start menu, click Programs > BusinessObjects XI 3.1 > BusinessObjects 
Enterprise > BusinessObjects Enterprise Central Management Console.

2 Login with the appropriate credentials. (The default value is Administrator with no 
password.)

3 Select Folders from the drop-down list in the upper left corner.
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4 Right-click the FPA EN FPA Analytics folder and select User Security from the context menu. 
The Central Management Console displays the User Security: FPA EN FPA Analytics window.

5 Select Add Principals. The Add Principals window appears.

6 Add full access rights to the FPA_ANALYTIC group.

a Choose FPA_ANALYTIC from the list of Available users/groups.

b Click the single right arrow (>) to move this selection to the Selected users/groups list.

c Click Add and Assign Security. The Central Management Console displays the Assign 
Security window.

d Choose Full Control from the list of Available Access Levels.

e Click the single right arrow (>) to move this selection to the Assigned Access Levels 
list.

f Click OK.

7 Add view access rights to the DW_ADMIN group.

a Select Add Principals.

a Choose DW_ADMIN from the list of Available users/groups.

b Click the single right arrow (>) to move this selection to the Selected users/groups list.

c Click Add and Assign Security. The Central Management Console displays the Assign 
Security window.

d Choose View from the list of Available Access Levels.

e Click the single right arrow (>) to move this selection to the Assigned Access Levels 
list.

f Click OK.

8 Click Close.

9 Repeat step 4 on page 108 through step 8, replacing FPA EN FPA ANALYTICS with FPA EN 
FPA Dashboard.

Step 2: Enable Access to the DW Administration and DW Operations Folders

Follow these steps to grant access to the data warehouse administration and operations 
folders.

1 If necessary, select Folders from the drop-down list in the upper left corner of the Central 
Management Console.

2 Right-click the DW EN Administration folder and select User Security from the context menu. 
The Central Management Console displays the User Security: DW EN Administration 
window.

3 Select Add Principals. The Add Principals window appears.

4 Choose DW_ADMIN from the list of Available users/groups.

5 Click the single right arrow (>) to move this selection to the Selected users/groups list.

6 Click Add and Assign Security. The Central Management Console displays the Assign 
Security window.

7 Choose Full Control from the list of Available Access Levels.
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8 Click the single right arrow (>) to move this selection to the Assigned Access Levels list.

9 Click OK.

10 Click Close.

11 Repeat step 2 through step 10, replacing DW EN Administration with DW EN Operations.

Step 3: Enable Access to the Root Folder

Follow these steps to grant the users and groups access to the root folder.

1 If necessary, select Folders from the drop-down list in the upper left corner of the Central 
Management Console.

2 Right-click All Folders and select Properties from the context menu.

3 Select User Security. The Central Management Console displays the User Security: Root 
Folder window.

4 Select Add Principals. The Add Principals window appears.

5 Add full access rights to the FPA groups.

a Choose FPA_ANALYTIC, FPA_ADMIN, and FPA_CE_CONFIG  from the list of Available 
users/groups.

b Click the single right arrow (>) to move this selection to the Selected users/groups list.

c Click Add and Assign Security. The Central Management Console displays the Assign 
Security window.

d Choose Full Control from the list of Available Access Levels.

e Click the single right arrow (>) to move the selection.

f On the Advanced tab, click Add/Remove Rights. 

g In the right pane, scroll to select View Objects in the list. and do the following:

– Select the green check icon to grant acccess.

– Clear the Apply to SubObject check box.

h Click OK to return to the Add Principals window.

i Click OK to return to the User Security: Root Folder window.

6 Add view access rights to the DW_ADMIN group.

a Select Add Principals. The Add Principals window appears.

a Choose DW_ADMIN from the list of Available users/groups.

b Click the single right arrow (>) to move this selection to the Selected users/groups list.

c Click Add and Assign Security. The Central Management Console displays the Assign 
Security window.

d Choose View from the list of Available Access Levels.

e Click the single right arrow (>) to move the selection.

f Click OK to return to the Add Principals window.

g Click OK to return to the User Security: Root Folder window.

You can ignore the highlighted yellow message at the top of the window.
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7 Click Close.

Step 4: Enable Users to Refresh Reports

You must assign access rights to the Universe Designer to refresh WebI reports.

1 Select Users and Groups from the drop-down list in the upper left corner of the Central 
Management Console.

2 In the right pane, right-click FPA_ANALYTIC and select Member Of from the context menu.

3 Select Join Group. The Central Management Console displays the Join Group: 
FPA_Analytic window.

4 Select Group Hierarchy.

5 Select Universe Designer Users.

6 Click the right arrow (>) to move it into the Destination Group(s) list.

7 Click OK.

8 Repeat step 2 through step 7 for FPA_ADMIN, FPA_CE_CONFIG, and DW_ADMIN.

9 Close the Central Management Console.

For more information, see the SAP BusinessObjects Enterprise XI 3.1 Administration Guide.

Task 6: Test Authentication

1 From a browser, type the Financial Planning & Analysis URL. For example:

http://server_name:8080/FPA/

2 Type the user login and password for one of the user profiles that you created.

3 If the login fails, repeat Task 3: Configure File Based Authentication on page 106.

4 If the login succeeds, test the other user login and password combinations that you 
created.

Troubleshooting

When file based authentication fails, review the spelling and case of these files located in the 
C:\Program Files\HP\FPA 9.10\Web Application\WEB-INF directory:

• web.xml

• applicationContext.xml

• \classes\biusers.properties

• If an error message appears indicating that the system could not locate the navigation 
menu, verify that the user belongs to a valid FPA group.

Click File > Exit to ensure that the session closes correctly.
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BOE Central Management Console

Verify this information from the CMC:

• The user names are spelled correctly with the correct case.

• The group names are spelled correctly with the correct case and match the groups that are  
in web.xml.

• The user has been added to the group specified in the biusers.properties file.
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C Installation Checklist
The Financial Planning & Analysis complete installation requires many login names, 
passwords, and other connection information. If you gather this information before you begin, 
you can ensure that you apply consistent naming conventions across the server environment. 
Complete the following checklist before you begin the file installation. Use it as a reference as 
you install the application, data warehouse, and create data source connections among the 
different servers.

Naming Limitations

RDBMS applications, BOE, and BODS allow blank or empty database passwords. However, 
Financial Planning & Analysis does not support databases with blank or empty passwords. 
You can use the same password for each database if you want to simplify access control.

Unsupported Password Characters

The ampersand special character (&), exclamation point (!), double quotation mark (“), single 
quotation mark (‘), pipe (|), and carat (^) are not supported within a password. Underscores 
are valid.

Database Naming Conventions

HP recommends that you do not create database names with embedded spaces. Financial 
Planning & Analysis supports only alphanumeric characters and the underscore in database 
names. You can use underscores or camel case to create more descriptive names. For example, 
boecms can be boe_cms or boeCms, but avoid “boe cms” with an embedded blank space. If 
database names have embedded blank spaces, dashes, or other special characters, results may 
be unpredictable.

Target and Staging Database Naming 

The first character of the Target database name and Staging database name must begin with 
an alpha character. The DBinit utility will fail if you use database names that begin with 
numbers.

Before you start the application, make sure that BusinessObjects access rights are set up. For 
more information, see Chapter 9, Configuring User Roles and Authentication.
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Using the Checklists

These checklists help you prepare for the steps that you complete to install a complete 
working environment for Financial Planning & Analysis and configure all the necessary 
connections shown in Figure 14. There are separate checklists to gather all of the 
configuration information that you need before you start each new step in the installation 
process:

• Part 1: SAP BusinessObjects Enterprise XI 3.1 Server Checklist on page 115.

• Part 2: Financial Planning & Analysis Data Warehouse Checklist on page 116.

• Part 3: Financial Planning & Analysis Web Application and Antivia XWIS Checklist on 
page 120.

Figure 14 Financial Planning & Analysis Working Environment
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Part 1: SAP BusinessObjects Enterprise XI 3.1 Server Checklist

Configurable Information Your Value

License information

License text file location

 

BOE CMS Database Connections

There are no requirements for naming; however, the recommendation is lower 
case with a suffix to distinguish the ODBC DSN from the database name and 
login.

BOE CMS ODBC data source name 
Example: boecms_dsn

BOE CMS database name
(Do not create a BOE CMS database 
with embedded blanks or special 
characters in the database name)

Example: boecms
Invalid: boe cms, boe-cms, boe@cms

BOE CMS database login name
Example: boecms

BOE CMS database password
Windows or Microsoft SQL Server 
password, depending on 
authentication method.

BOE Audit Database Connections

There are no requirements for naming; however, the recommendation is lower 
case with a suffix to distinguish the ODBC DSN from the database name and 
login. This database is optional. You can store audit information in the CMS 
database.

BOE Audit database ODBC DSN
Example: boeaudit_dsn

BOE Audit database name
(Do not create a BOE Audit database 
with embedded blanks or special 
characters in the database name)

Example: boeaudit
Invalid: boe audit, boe-audit, 
boe@audit

BOE Audit database login name
Example: boeaudit

BOE Audit database password
Windows or Microsoft SQL Server 
password, depending on 
authentication method.
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Part 2: Financial Planning & Analysis Data Warehouse Checklist

This phase of the installation has three separate installation steps: SAP Business Objects 
Data Services XI 3.1 (BODS), the data sources for ETL, and the data warehouse.

Configurable Information Your Value

License information

License text file location

2a) BODS Configuration Information

There are no requirements for naming; however, the recommendation is lower 
case. You cannot use a pre-existing instance of BODS.

BODS database server name

BODS database registration name
(User-defined name to register the 
database on the BODS Management 
Console)

Example: bods_repository

BODS database name 
(Do not create a BODS database with 
embedded blanks or special characters 
in the database name)

(Cannot exceed 12 characters)
Example: bods
Invalid: bo ds, bo-ds, bo@ds

BODS login
(admin is the default login value. You 
can change it after the initial login)

Example: bods 

BODS password Windows or Microsoft SQL Server 
password, depending on 
authentication method.

BODS database TCP port number
Example: 1433 

2b) ETL Data Source Configuration Information for Asset Manager

You can configure a connection for a maximum of two data sources: one Asset 
Manager source and one Project and Portfolio Management data source.

Database type Microsoft SQL Server 2005 (MSSQL)
or Oracle 10g

Server name (MSSQL only)

Database name (MSSQL only)

Schema name (MSSQL only)

Oracle JDBC library location (Oracle 
only)

Example: 
C:\oraclexe\app\oracle\product
\10.2.0\server\jdbc\lib\ojdbc14.jar
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Connection name (Oracle only)

Login

Password

Time Zone†
(If available, this information is 
obtained from Asset Manager. If not, 
you must provide the correct value.)

Example: 
America/Indiana/Indianapolis

2b) ETL Data Source Configuration Information for Project and Portfolio Management

You can configure a connection for a maximum of two data sources: one Asset 
Manager source and one Project and Portfolio Management source.

Oracle JDBC library location Example for Oracle 10g: 
C:\oraclexe\app\oracle\product
\10.2.0\server\jdbc\lib\ojdbc14.jar

Example for Oracle 11: 
C:\app\server\product\11.1.0
\client_1\jdbc\lib\ojdbc.jar

Connection name

Login

Password

2c) Data Warehouse Configuration Staging Database Information

The ETL process uses the staging database to consolidate extracted data from 
external sources.

Staging database server name

Staging database name
(Do not create a staging database with 
embedded blanks or special characters 
in the database name.)

Example: staging
Invalid: boe staging, boe-staging, 
boe@staging

Staging server administrator login
Example: sa

Staging server administrator password
Windows or Microsoft SQL Server 
password, depending on 
authentication method.

Staging database owner password
Windows or Microsoft SQL Server 
password, depending on 
authentication method.

External Sources location Example: D:\External

AM Extract files location Example: D:\AM\extract

Configurable Information Your Value
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PPM Extract files location Example: D:\PPM\extract

2c) Data Warehouse Configuration Target Database Information

The target database contains the final version of the extracted data.

Target database server name
Example: target

Target database name
(Do not create a target database with 
embedded blanks or special characters 
in the database name.)

Example: target
Invalid: boe target, boe-target, 
boe@target

Target server administrator login
Example: sa

Target server administrator password
Windows or Microsoft SQL Server 
password, depending on 
authentication method.

Target database owner password
Windows or Microsoft SQL Server 
password, depending on 
authentication method.

2c) Time and Currency Information

This information identifies the right data to populate analytics.

Date dimension start year

Date dimension end year †‡ 
Minimum: One year after start year

Time granularity

Data presentation time zone †
Example: 
America/Indiana/Indianapolis

2c) Related Servers

Configurable Information Your Value
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† Time zone assignment depends on whether the Financial Planning & Analysis 
Configuration Tool can auto-detect GMT offset information in the Asset Manager source data. 
If this is the case, Financial Planning & Analysis can provide the precision to capture time 
zone information that includes 
GMT +/- hh:mm:ss; however, there is no automatic adjustment for daylight savings time 
variations. 

The most definitive reference for time zone specification is the public domain Time Zone and 
Daylight Saving Time (tz) database, which uses region/city/smallest_region formatting. This 
is the default Configuration Tool time zone model. 

For more information, see http://www.twinsun.com/tz/tz-link.htm.

‡ If the date range that you specify is shorter than the actual date range of the source data, 
your initial sync with the remote data source will fail. Make sure the date range that you 
specify is all-inclusive.

SAP BOE server name

Web application server name

Web application server port

Configurable Information Your Value
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Part 3: Financial Planning & Analysis Web Application and 
Antivia XWIS Checklist

Configurable Information Your Value

License information

License text file location

3a) Apache Tomcat

The Tomcat tab appears if you use an existing instance of Apache Tomcat that 
is part of a pre-installed instance of BOE.

Tomcat location
Example: C:\....\Tomcat

Service name
From Control Panel > Administrative 
Tools > Services, right-click the Apache 
Tomcat service to find the Service name 
on the General tab.

Example: Tomcat5

3a) Pre-Existing BOE Server Configuration Information

The SAP BOE tab appears if you use a pre-installed instance of BOE.

BOE server name
Example: server.name.com

3a) Financial Planning and Analysis (FPA) Application Information

Database server
Example: \....\server.name

Database name
(This is the same target database 
identified in 2c) Data Warehouse 
Configuration Target Database 
Information on page 118.) 

Example: target

Login Required: itaapp

Password

JDBC URI (optional)
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3b) XWIS Configuration Information

There are no requirements for naming; however, the recommendation is lower 
case. 

Server name
Example: \....\server.name

Database name
(Do not create an XWIS database with 
embedded blanks or special characters 
in the database name)

Example: xwis_fpa
Invalid: xwis fpa, xwis-fpa, xwis@fpa

Login
Example: xwis_user

Password Windows or Microsoft SQL Server 
password, depending on 
authentication method.

Configurable Information Your Value
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