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0
Welcome to Astra LoadTest

Welcome to Astra LoadTest, Mercury Interactive’s tool for testing the performance 
of Web-based applications. Astra LoadTest stresses your entire Web-based 
application to isolate and identify bottlenecks and optimize the end user 
experience. 

Astra LoadTest enables you to test your system under controlled and peak load 
conditions. To generate load, Astra LoadTest runs hundreds of Virtual Users that 
are distributed over a network. Using a minimum of hardware resources, these 
Virtual Users provide consistent, repeatable, and measurable load to exercise 
your Web-based application just as real users would. Astra LoadTest’s in-depth 
reports and graphs provide the information that you need to evaluate the 
performance of your Web-based application.
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Online Resources

Astra LoadTest includes the following online tools:

Read Me First provides last-minute news and information about Astra LoadTest.

Books Online displays the complete documentation set in PDF format. Online 
books can be read and printed using Adobe Acrobat Reader 4.0, which is 
included in the installation package. Check Mercury Interactive’s Customer 
Support Web site for updates to Astra LoadTest online books.

Astra LoadTest Context Sensitive Help provides immediate answers to 
questions that arise as you work with Astra LoadTest. It describes dialog boxes, 
and shows you how to perform Astra LoadTest tasks. To activate this help, click 
in a window and press F1. Check Mercury Interactive’s Customer Support Web 
site for updates to Astra LoadTest help files.

Technical Support Online uses your default Web browser to open Mercury 
Interactive’s Customer Support Web site.

Support Information presents the locations of Mercury Interactive’s Customer 
Support Web site and home page, the e-mail address for sending information 
requests, the name of the relevant news group, the location of Mercury 
Interactive’s public FTP site, and a list of Mercury Interactive’s offices around the 
world.

Mercury Interactive on the Web uses your default Web browser to open 
Mercury Interactive’s home page.
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Astra LoadTest Documentation Set

Astra LoadTest is supplied with a set of documentation that describes how to:

• install Astra LoadTest

• create Vuser scripts using the Virtual User Recorder

• use the Astra LoadTest Controller to run and analyze load test scenarios

Using the Astra LoadTest Documentation Set

The Astra LoadTest documentation set consists of an Installation Guide, 
Controller User’s Guide, and a Virtual User Recorder User’s Guide.

Installation Guide
For instructions on installing Astra LoadTest, refer to the Astra LoadTest 
Installation guide. 

Controller User’s Guides
For a description of how to create and run Astra LoadTest scenarios using the 
Astra LoadTest Controller, refer to the Astra LoadTest Controller User’s Guide . 
The Controller User’s Guide presents an overview of the Astra LoadTest testing 
process. 
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Guide for Creating Vuser Scripts
The Virtual User Recorder User’s guide describes how to create Vuser scripts that 
you will use in your load testing.

Note: The Virtual User Recorder is also used to create functional tests for Astra 
QuickTest.

Throughout this guide, the use of the term script is synonymous with the term 
test for the Virtual User Recorder.
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Typographical Conventions

This book uses the following typographical conventions:

Bold Bold text indicates function names and the elements of 
the functions that are to be typed in literally. 

Italics Italic text indicates variable names and book names.

Helvetica The Helvetica font is used for examples and statements 
that are to be typed in literally.

[  ] Square brackets enclose optional parameters.

{ } Curly brackets indicate that one of the enclosed values 
must be assigned to the current parameter. 

... In a line of syntax, three dots indicate that more items of 
the same format may be included. In a program example, 
three dots are used to indicate lines of a program that 
have been intentionally omitted.

| A vertical bar indicates that either of the two options 
separated by the bar should be selected.
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�
Introduction 

To load test your Web-based application, Astra LoadTest emulates an 
environment where multiple users work concurrently. While the Web-based 
application is under load, Astra LoadTest accurately measures, monitors, and 
analyzes a system’s performance and functionality. 

About Load Testing

Modern Web-based architectures are complex. While they provide an 
unprecedented degree of power and flexibility, these systems are difficult to test. 
Whereas single-user testing focuses primarily on functionality and the user 
interface of a single application, Web-based testing focuses on performance and 
reliability of an entire Web-based application. 

For example, a typical Web-based testing scenario might depict 100 Web Users 
that login simultaneously to a system: What is the response time of the system? 
Does the system crash? To be able to answer these questions—and more—a 
complete Web-based application testing solution must:

• test a system that combines a variety of software applications and hardware 
platforms

• determine the suitability of a Web server for any given application
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• emulate an environment where multiple users interact with a single server 
application

• test a Web-based application under the load of tens or hundreds of potential 
users

Manual Testing Limitations
Traditional or manual testing methods offer only a partial solution to load testing. 
For example, you can test an entire system manually by constructing an 
environment where many users work simultaneously on the system. Each user 
works at a single machine and submits input to the system. However, this manual 
testing method has the following drawbacks:

• it is expensive, requiring large amounts of both personnel and machinery

• it is complicated, especially coordinating and synchronizing multiple testers

• it involves a high degree of organization, especially to record and analyze results 
meaningfully

• the repeatability of the manual tests is limited
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The Astra LoadTest Solution

The Astra LoadTest automated solution addresses the drawbacks of manual 
performance testing:

• Astra LoadTest reduces the personnel requirements by replacing human 
users with virtual users or Vusers. These Vusers emulate the behavior of real 
users—operating real applications. 

• Because numerous Vusers can run on a single computer, Astra LoadTest 
reduces the hardware requirements. 

• The Astra LoadTest Controller allows you to easily and effectively control all 
the Vusers—from a single point of control. 

• Astra LoadTest monitors the Web-based performance online, enabling you to 
fine-tune your system during test execution. 

• Astra LoadTest automatically records the performance of the Web-based 
application during a test. You can choose from a wide variety of graphs and 
reports to view the performance data.

• Astra LoadTest checks where performance delays occur: network or client 
delays, CPU performance, I/O delays, or other issues at the database or Web 
server. Astra LoadTest monitors the Web resources to help you improve 
performance.

• Because Astra LoadTest tests are fully automated, you can easily repeat 
them as often as you need.
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Using Astra LoadTest

Using Astra LoadTest, you divide your Web-based performance testing 
requirements into scenarios. A scenario defines the events that occur during each 
testing session. Thus, for example, a scenario defines and controls the number 
of users to emulate, the actions that they perform, and the machines on which 
they run their emulations.

In the scenario, Astra LoadTest replaces human users with virtual users or 
Vusers. When you run a scenario, Vusers emulate the actions of human users—
operating your Web-based application. While a workstation accommodates only 
a single human user, many Vusers can run concurrently on a single workstation. 
In fact, a scenario can contain tens or hundreds of Vusers. 

To emulate conditions of heavy user load, you create a large number of Vusers 
that perform a series of tasks. For example, you can observe how a Web-based 
banking system behaves when one hundred Vusers simultaneously check 
account information. To accomplish this, you create 100 Vusers, and each Vuser:

 1 enters a User ID number into the system 

 2 enters the PIN number for the account

 3 request a list of recent transactions for the account

 4 checks the balance of the account

 5 repeats the process numerous times

Scenarios

Vusers
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The actions that a Vuser performs during the scenario are described in a Vuser 
script. When you run a scenario, each Vuser executes a Vuser script. The Vuser 
scripts include functions that measure and record the performance of your Web 
application.

To measure the performance of the server, you define transactions. A transaction 
represents an action or  a set of actions that you are interested in measuring. You 
define transactions within your Vuser script by enclosing the appropriate sections 
of the script with start and end transaction statements.  For example, you can 
define a transaction that measures the time it takes for the server to process a 
request to view the balance of an account and for the information to be displayed 
in the Web browser. 

You insert rendezvous points into Vuser scripts to emulate heavy user load on the 
application. Rendezvous points instruct Vusers to wait during test execution for 
multiple Vusers to arrive at a certain point, in order that they may simultaneously 
perform a task. For example, to emulate peak load on the bank application, you 
can insert a rendezvous point instructing 100 Vusers to transfer funds within their 
accounts at the same time. 

You use the Astra LoadTest Controller to manage and maintain your scenarios. 
Using the Controller, you control all the Vusers in a scenario from a single 
workstation.

Vuser Scripts

Transactions

Rendezvous 
points

Controller
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When you execute a scenario, the Astra LoadTest Controller distributes each 
Vuser in the scenario to a host. The host is the machine that executes the Vuser 
script, enabling the Vuser to emulate the actions of a human user. 

Vuser scripts include functions that measure and record system performance 
during load-testing sessions. During a scenario run, you can monitor the network 
and server resources. Following a scenario run, you can view performance 
analysis data in reports and graphs. 

Hosts

Performance 
analysis
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Astra LoadTest Vuser Technology

On each Windows host, you install a Remote Command Launcher and an Agent.

The Remote Command Launcher enables the Controller to start applications on 
the host machine. 

The Agent enables the Controller and the host to communicate with each other. 
When you run a scenario, the Controller instructs the Remote Command 
Launcher to launch the Astra LoadTest Agent. The Agent receives instructions 
from the Controller to initialize, run, pause, and abort Vusers. At the same time, 
the Agent also relays data on the status of the Vusers back to the Controller.

 Vuser

 Vuser

 Vuser

Controller

Agent

Remote Command 
Launcher 

Host

Remote 
Command 
Launcher

Agent
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Working with Astra LoadTest

Suppose you want to test an online banking Web server that is accessed by many 
Internet users. The Web site provides a full range of banking services to the 
customers—such as the ability to transfer funds and check account balances. To 
test this server using Astra LoadTest, you create a scenario. The scenario defines 
the actions that are performed on the server during the load test. 

During the scenario that loads and monitors the Web server, you want to: 

• emulate conditions of controlled load on the server

• emulate conditions of maximum load on the server

• measure server performance under load

• check where performance delays occur: network or client delays, CPU 
performance, I/O delays, database locking, or other issues at the server
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• monitor the network and server resources under load
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�
The Astra LoadTest Testing Process

You can easily create and run load-test scenarios by following the Astra LoadTest 
testing process below. The following illustration outlines the testing process: 

This chapter gives you an overview of Astra LoadTest’s five–step process for 
testing your Web-based application under load.

������

�������

��������

�������

������

Analyzing Test Results

Running the Scenario

Creating the Scenario

Creating Vuser Scripts

Planning the Test
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Step I: Planning the Test 

Successful load testing requires that you develop a thorough test plan. A clearly 
defined test plan will ensure that the Astra LoadTest scenarios that you develop 
will accomplish your load testing objectives. For more information, see Chapter 3, 
Load Test Planning. 

Step II: Creating the Vuser scripts

Vusers emulate human users interacting with your Web-based application. A 
Vuser script contains the actions that each virtual user performs during scenario 
execution. 

In each Vuser script you determine the tasks that will be:

• performed by each Vuser

• performed simultaneously by multiple Vusers

• measured as transactions

For more information on creating Vuser scripts, refer to the Virtual User Recorder 
guide.
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Step III: Creating the Scenario

A scenario describes the events that occur during a testing session. A scenario 
includes a list of machines that “host” Vusers; a list of scripts that the Vusers run; 
and a list of Vusers and Vuser groups that run during the scenario. You create 
scenarios using the Astra LoadTest Controller. For an introduction to the 
Controller, see Chapter 4, The Astra LoadTest Controller at a Glance.  

Creating the List of Hosts to Run Vusers
For each scenario, you create a list of hosts—machines configured to execute 
Vuser scripts. For more information, see Chapter 5, Creating a Scenario. 

Creating the List of Vuser Scripts
For each scenario, you create a list of scripts that Vusers run during scenario 
execution. For more information, see Chapter 5, Creating a Scenario. 

Creating the Vuser Groups
To each Vuser group in a scenario, you assign a quantity of individual Vusers, a 
script, and a host to run the script. For more information, see Chapter 5, 
Creating a Scenario. 
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Step IV: Running the Scenario

You emulate user load on the server by instructing multiple Vusers to perform 
tasks simultaneously. You can set the level of load by increasing and decreasing 
the number of Vusers that perform tasks at the same time. For more information, 
see Chapter 6, Using Rendezvous Points. 

Before you run a scenario, you set the scenario configuration and scheduling. 
This determines how all the hosts and Vusers behave when you run the scenario. 
For more information, see Chapter 7, Configuring a Scenario and Chapter 8, 
Setting the Scenario Scheduling. 

You can run the entire scenario, groups of Vusers (Vuser groups), or individual 
Vusers. While a scenario runs, Astra LoadTest measures and records the 
transactions that you defined in each Vuser script. You can also monitor your 
system’s performance online. For more information, see Chapter 11, Running a 
Scenario. 

Step V: Analyzing Test Results

During scenario execution, Astra LoadTest records the performance of the 
application under different loads. You use Astra LoadTest’s graphs and reports to 
analyze the application’s performance. For more information about Astra 
LoadTest’s reports and graphs, see Chapter 18, Understanding Astra LoadTest 
Analysis.  
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�
Load Test Planning

Developing a comprehensive test plan is a key to successful load testing. A 
clearly defined test plan ensures that the Astra LoadTest scenarios you develop 
will accomplish your load testing objectives. 

This chapter introduces the load test planning process:

• Analyzing the Web-based Application

• Defining Testing Objectives

• Planning Astra LoadTest Implementation

• Examining Load Testing Objectives
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About Load Test Planning

As in any type of system testing, a well-defined test plan is the first essential step 
to successful testing. Planning your load testing helps you to:

• Build test scenarios that accurately emulate your working environment.

Load testing means testing your Web-based application under typical working 
conditions, and checking for system performance, reliability, capacity, etc. 

• Understand which resources are required for testing.

Load testing requires hardware, software, and human resources. Before you 
begin testing, you should know which resources are available and decide how to 
use them effectively.

• Define success criteria in measurable terms. 

Focused testing goals and test criteria ensure successful testing. For example, 
it’s not enough to define vague objectives like “Check server response time 
under heavy load.” A more focused success criteria would be “Check that 50 
customers can check their account balance simultaneously, and that the server 
response time will not exceed one minute.”
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Load test planning is a three-step process:

Analyzing the Web-based Application

The first step to load test planning is analyzing the Web-based application. You 
should become thoroughly familiar with the hardware and software components, 
the system configuration, and the typical usage model. This analysis ensures that 
the testing environment you create using Astra LoadTest will accurately reflect the 
environment and configuration of the system under test.
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Identifying System Components
Draw a schematic diagram to illustrate the structure of the Web-based 
application’s architecture. If possible, extract a schematic diagram from existing 
documentation. If the system under test is part of a larger network system, you 
should identify the components of the system to be tested. Make sure the diagram 
includes all system components, such as application clients (GUI), source 
systems, databases, firewalls, network, middleware, and servers. 

The following diagram illustrates an online banking system which is accessed by 
many Web users. The Web users each connect to the same database to transfer 
funds and check balances. The customers connect to the database server 
through the Web, using multiple browsers.

Describing the System Configuration
Enhance the schematic diagram with more specific details. Describe the 
configuration of each system component. You should be able to answer the 
following questions:

• How many users are anticipated to connect to the system?

• What is the application client’s machine configuration? (hardware, memory, 
operating system, software, development tool, etc.)

• What types of Database and Web servers are used? (hardware, database type, 
operating system, file server etc.)
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• How does the server communicate with the application client?

• What is the middleware configuration and application server between the front-
end client and back-end server?

• What other network components may affect response time? (modems etc.)

• What is the throughput of the communications devices? How many concurrent 
users can each device handle?
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For example, the schematic diagram above specified that there are multiple 
application clients accessing the system.

Analyzing the Usage Model
Define how the system is typically used, and decide which functions are important 
to test. Consider the system interface, the multiple browsers and modems of the 
application clients, and each client’s common tasks. In addition, consider any 
background load that might affect the system response time.

For example, suppose between 9:00 - 9:15 each business day, 200 application 
clients log on to check their account balance. During the same time period, 50 
application clients log on to transfer funds between accounts. You could create an 
Astra LoadTest scenario with 250 virtual users signing in to the Web-based 
application, and check the server response time. 

Front-End Client Configuration

Anticipated number of application clients 50 concurrent application clients

Hardware / Memory 586 / 32MB

Operating system & version Windows NT 4.0

Client browser Internet Explorer 4.0
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To check how background load affects the response time, you could run your 
scenario on a network where you also simulate the load of application clients 
performing various account transactions.

Task Distribution

In addition to defining the common user tasks, examine the distribution of these 
tasks. For example, suppose the bank uses a central database to serve clients 
across many states and time zones. The 250 application clients are located in two 
different time zones, all connecting to the same Web server. There are 150 in 
Chicago and 100 in Detroit. Each begins their business day at 9:00 AM, but since 
they are in different time zones, there should never be more than 150 users 
signing in at any given time.

You can analyze task distribution to determine when there is peak Web activity, 
and which activities typically occur during peak load time. 
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Defining Testing Objectives

Before you begin testing, you should define exactly what you want to accomplish. 

Following are common Web-based application testing objectives that Astra 
LoadTest helps you test, as described in Robert W.Buchanan Jr’s The Art of 
Testing Network Systems (John Wiley & Sons, Inc., 1996). 

A more detailed description of each objective appears at the end of this chapter.

Objective  Answers the Question 

Measuring end-user response 
time

How long does it take to complete a business 
process?

Defining optimal hardware 
configuration

Which hardware configuration provides the best 
performance?

Checking reliability How hard or long can the system work without 
errors or failures?

Checking hardware or software 
upgrades

How does the upgrade affect performance or 
reliability?

Evaluating new products Which server hardware or software should you 
choose?

Measuring system capacity How much load can the system handle without 
significant performance degradation?

Identifying bottlenecks Which element is slowing down response time?
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Stating Objectives in Measurable Terms
Once you decide on your general load testing objectives, you should provide 
more focused goals by stating your objectives in measurable terms. To provide a 
baseline for evaluation, determine exactly what constitutes acceptable and 
unacceptable test results. 

For example:

General Objective - Product Evaluation: choose hardware for the Web server.

Focused Objective - Product Evaluation: run the same group of 300 virtual users 
on two different servers, HP and NEC. When all 300 users simultaneously browse 
the pages of your Web application, determine which hardware gives a better 
response time.
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Deciding When to Test
Load testing is necessary throughout the product life cycle. The following table 
illustrates what types of tests are relevant for each phase of the product life cycle:

Planning 
and Design

Development Deployment Production Evolution

Evaluate 
new 
products

Measure 
response time

Check 
reliability

Measure 
response 
time

Check HW or 
SW upgrades

Measure 
response 
time

Check optimal 
hardware 
configuration

Measure 
response time

Identify 
bottlenecks

Measure 
system 
capacity

Check HW or 
SW upgrades

Measure 
system 
capacity

Check 
reliability
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Planning Astra LoadTest Implementation

The next step is to decide how to use Astra LoadTest to achieve your testing 
goals.

Defining Vuser Activities
Create Vuser scripts based on your analysis of Vuser types, their typical tasks and 
your test objectives. Since Vusers emulate the actions of a typical end-user, the 
Vuser scripts should include a browse sequence that a typical end-user would 
follow. For example, to emulate an online banking client, you should create a 
Vuser script that performs typical banking tasks. You would browse the pages that 
you normally visit to transfer funds or check balances.

You decide which tasks to measure based on your test objectives and define 
transactions for these tasks. Transactions measure the time that it takes for the 
server to respond to tasks submitted by Vusers (end-to-end time). For example, 
to check the response time of a bank Web server supplying an account balance, 
define a transaction for this task in the Vuser script.

In addition, you can emulate peak activity by using rendezvous points in your 
script. Rendezvous points instruct multiple Vusers to perform tasks at exactly the 
same time. For example, you can define a rendezvous to emulate 70 users 
simultaneously updating account information.
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Choosing Testing Hardware/Software
The hardware and software should be powerful and fast enough to emulate the 
required number of virtual users. 

To decide on the number of machines and correct configuration, consider the 
following:

• It is advisable to run the Astra LoadTest Controller on a separate machine.

• Configuration of the test machine for Vusers should be as similar as possible to 
the actual user’s machine.

Refer to the following table to estimate the required hardware for each Astra 
LoadTest testing component. These requirements are for optimal performance.
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Windows Configuration Requirements

Requirement Controller Web Vuser

Hardware Pentium 90 or 
higher

Pentium 120 Mhz or 
higher recommended for 
running large numbers of 
users (more than 30).

Memory 24 MB or more 
on Controller 
machine

At least 1 MB per non-
multithreaded Vuser or at 
least 2.5 MB for 10 users 
in multithreaded mode 
(depends on application)

Swap Space Two times the 
total physical 
memory

Two times the physical 
memory for 
multithreaded mode or 
four times the physical 
memory for non-
multithreaded mode

Software tcp/ip support HTTP support

1 CPU* supports 
x users

n/a ~250 in multithreaded 
mode
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Note: The results file requires a few MB of disk space for a long scenario run 
with many transactions. The host machines also require a few MB of disk space 
for temporary files if there is no NFS. See Chapter 7, Configuring a Scenario 
for more information about run-time file storage.

* Pentium Pro 200 MHz may have multiple CPUs per machine.

Examining Load Testing Objectives

Your test plan should be based on a clearly defined testing objective. This section 
presents an overview of common testing objectives: 

• Measuring end-user response time

• Defining optimal hardware configuration

• Checking reliability

• Checking hardware or software upgrades

• Evaluating new products

• Identifying bottlenecks

• Measuring system capacity
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Measuring End-user Response Time
Check how long it takes for the application client to perform a business process 
and receive a response from the Web server. For example, suppose that you want 
to verify that while your system operates under normal load conditions, the 
application client receives responses to all requests within 20 seconds. The 
following graph presents a sample load vs. response time measurement for a 
banking application:

0
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Check account
information
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Defining Optimal Hardware Configuration
Check how various system configurations (memory, CPU speed, cache, 
adaptors, modems) affect performance. Once you understand the system 
architecture and have tested the application response time, you can measure the 
application response for different system configurations to determine which 
settings provide the desired performance levels.

For example, you could set up three different server configurations and run the 
same tests on each configuration to measure performance variations:

• Configuration 1: 200MHz, 64MB RAM

• Configuration 2: 200MHz, 128MB RAM

• Configuration 3: 266MHz, 128MB RAM

Checking Reliability
Determine the level of system stability under heavy or continuous work loads. You 
can use Astra LoadTest to create stress on the system: force the system to handle 
extended activity in a compressed time period to simulate the kind of activity a 
system would normally experience over a period of weeks or months. 
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Checking Hardware or Software Upgrades
Perform regression testing to compare a new release of hardware or software to 
an older release. You can check how an upgrade affects response time 
(benchmark) and reliability. Regression testing does not check new features of an 
upgrade; rather it checks that the new release is as efficient and reliable as the 
older release.

Evaluating New Products
You can run tests to evaluate individual products and subsystems during the 
planning and design stage of a product’s life cycle. For example, you can choose 
the hardware for the Web server machine or the database package based on 
evaluation tests.
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Identifying Bottlenecks
You can run tests which identify bottlenecks on the system to determine which 
element is causing performance degradation, for example, file locking, resource 
contention and network overload. Use Astra LoadTest in conjunction with the new 
network and host monitoring tools to create load and measure performance at 
different points in the system. For more information, see Part IV of this manual, 
Monitoring Resources. 

ISDN

Router

Application Server

WAN

Database
Server

Modem

Clients

??
?

?
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Measuring System Capacity
Measure how much excess capacity the system can handle without performance 
degradation. To check capacity, you can compare performance versus load on the 
existing system, and determine where significant response-time degradation 
begins to occur. This is often called the “knee” of the response time curve. 

Once you determine the current capacity, you can decide if resources need to be 
increased to support additional users.

Number of Users

Response Time
(seconds)

Unacceptable

Acceptable

knee
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�
The Astra LoadTest Controller at a Glance

This chapter introduces the Controller window and explains how to perform basic 
scenario operations.

This chapter describes:

• Opening the Controller

• Introducing the Astra LoadTest Controller

• Selecting Astra LoadTest Commands

• Managing Scenario Files

• Running a Scenario
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Opening the Controller

Set up the Astra LoadTest environment according to the instructions in the Astra 
LoadTest Installation Guide. 

To open the Controller:

Select Start > Programs >Astra LoadTest > Products > Controller.

The Controller window opens with the Astra LoadTest Controller dialog box 
inside.
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The Astra LoadTest Controller dialog box includes the following options:

Wizard: Creates a scenario with the aid of the Astra LoadTest Scenario wizard, 
an interactive, step-by-step guide to creating a scenario. 

New: Creates a new scenario.

Open an existing scenario: Opens an existing scenario.

Show at Startup: If you do not want this window to appear the next time you 
start Astra LoadTest, clear the “Show at Startup” check box. When you open the 
Controller, the window layout from the last time you worked with the Controller 
appears.

If you want to display this dialog box when the Controller starts, select 
View > Show Startup Dialog from the Controller’s main menu.
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Introducing the Astra LoadTest Controller

The Astra LoadTest Controller window contains the following elements:

Title bar Displays the name of the scenario on which you are 
currently working.

Menu bar Displays the menus from which you select commands.

Tool bar Provides shortcuts for selecting commands. Clicking on a 
button executes a command. 

Status bar Provides information on the current state of the scenario.
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Design tab Run tab Scenario Groups window

Browser pane

Status Bar
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The Controller window has two tabs which correspond to two views: 

Design view Displays the Scenario Groups window with a list 
of all the Vuser groups in a scenario (default 
view), and the Vuser scripts, host machines, and 
Vusers assigned to each group. This view also 
displays the Browser pane.

Run view Displays information on the running Vusers and 
Vuser groups, as well as online monitor graphs 
showing transaction, server resource, Web 
server resource, and Web application server 
information. 

In addition, if you select View > Output, the Controller opens the Output 
window which displays error and notification messages generated by Vusers 
during scenario execution. 
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Selecting Astra LoadTest Commands

You select Astra LoadTest commands from the menu bar or on the toolbar.

Choosing Commands from a Menu
You select Astra LoadTest commands from the menus on the menu bar. Some 
commands use standard Microsoft Windows shortcut conventions. 

Choosing Commands from the Toolbar
You can execute many Astra LoadTest commands by clicking a button on the 
toolbar in the Astra LoadTest Controller.

New Save Virtual 
User 
Recorder

Open Schedule Selector Host 
Information

Reset 
Session

Schedule 
Builder
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Managing Scenario Files

A scenario describes the events that occur during each load testing session. A 
scenario contains lists of hosts, Vuser groups, Vusers, tests, transactions, and 
rendezvous points. You create a scenario using the Design view of Astra 
LoadTestController. 

After you create the scenario, Astra LoadTest saves the information in a scenario 
file (.lrs). You use the commands in the File menu to create, open, save, and close 
scenario files. Some of these commands are available from the toolbar. 

Creating a New Scenario
You record tests for your scenario with the Virtual User Recorder. You can 
automatically include a recorded test in a new scenario by opening the Controller 
from the Virtual User Recorder. Click the Controller button from the Virtual User 
tool bar. The New command creates a completely new scenario. Note that the 
New command clears all the information displayed in the Controller windows. To 
create a new scenario, choose File > New, or click the New button. 

You can also create a new scenario by using the Scenario wizard. The wizard is 
an interactive, step-by-step guide to creating a scenario. To create a new scenario 
by using the Scenario wizard, select Tools > Scenario Wizard.



Understanding Astra LoadTest • The Astra LoadTest Controller at a Glance

Astra LoadTest Controller User’s Guide Chapter 4, page 59

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

Opening an Existing Scenario
The Open command opens any existing scenario.

To open an existing scenario:

 1 Choose File > Open, or click the Open button. The Open Scenario dialog box 
opens.

 2 Click a file in the File Name list or type a file name in the File Name box.

 3 Click OK. The File Open dialog box closes and the scenario appears in the Astra 
LoadTest Controller.
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Saving a Scenario
The Save command saves the current scenario. 

To save a scenario:

 1 Choose File > Save, or click the Save button. The Save Scenario dialog box 
opens the first time you save a scenario.

 2 Type a scenario name in the File Name text box. Note that by default scenario 
files have the extension .lrs.

 3 Click OK. The scenario is saved in the location you specified.
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Closing a Scenario
Closing a scenario closes all the Controller windows. To close the scenario, 
choose File > Close. If you made changes to the scenario, a Save Changes 
message appears. Choose Yes to save the changes you made. All open windows 
and icons in the Controller close.

Running a Scenario

Once you have designed your scenario, you are ready to run it.  You can control 
the Vusers and Vuser groups and monitor their performance online using the Run 
view of the Astra LoadTest Controller.
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Design tab Scenario Groups window

Online Monitor Graphs

Status BarRun tab
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During scenario execution, you use the Scenario Groups window in the Run view 
to monitor the actions of all the Vusers and Vuser groups in the scenario. The 
Status field of each Vuser group displays the current state of each Vuser in the 
group.

You can also manipulate individual Vusers within the Vuser groups you have 
defined by selecting a group and clicking the Vusers button. The Vusers dialog 
box appears, with a list of the ID, Status, Script, Host, and Elapsed time (since 
the beginning of the scenario) for each of the Vusers in the group.
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In addition, you can view a synopsis of the running scenario in the box at the top 
right-hand corner of the Run view.

While the scenario runs, the Vusers and hosts send error, notification, and 
warning messages to the Controller. You can view these messages in the Output 
window. 

You use the online monitors and online monitor graphs to monitor Vuser status, 
transactions, server resources, Web server resources, and Web application 
server resources while running a scenario.
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Part II

Designing a Scenario
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�
Creating a Scenario 

To build a scenario, you create groups and specify the script, the host, and the 
number of Vusers included in each group. This chapter describes how to add 
these items to a scenario. 

This chapter discusses:

• Selecting Scripts for a Scenario

• Creating Vuser Groups

• Configuring Hosts

• Configuring Scripts

• Using Relative Paths for Scripts
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About Creating a Scenario

To test your system with Astra LoadTest you must create a scenario, a file with 
information about the test session. The scenario is the means by which you 
emulate a real-life user. The scenario contains information about how to emulate 
real users: the groups of virtual users (Vusers), the test scripts the Vusers will run, 
and the host machines upon which to run the scripts.    

To create a scenario, you first select the scripts you want to use in your scenario. 
Then you create Vuser groups and assign them a script, a number of virtual users, 
and a host machine. 
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Selecting Scripts for a Scenario

When you open the Controller and choose to create a new scenario, the New 
Scenario dialog box opens.

To select the script or scripts that you want to use in your scenario:

 1 Select a script from the Available Scripts window, or Browse to locate the script 
you want to use.

 2 Click the Add button to copy the script you selected to the Scripts in Scenario 
window.
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 3 Click the Remove button to remove a script from the Scripts in Scenario 
window.

 4 To bypass this dialog box the next time you create a new scenario, clear the 
Show at startup check box. You will be able to add scripts later on, while 
building your scenario. For further details, see Creating a Scenario on page 66.

 5 Click OK to close the dialog box.

Creating Vuser Groups

A scenario consists of groups of Vusers which emulate human users interacting 
with your Web-based system. When you run a scenario, the Vusers generate load 
on the server, and Astra LoadTest monitors the server and transaction 
performance.

You create Vuser groups based on the different tasks you want to assign Vusers. 
Each group contains a specified number of Vusers that run the same script, and 
run on the same host machine. 
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You create Vuser groups from the Scenario Groups window of the Controller. 



Designing a Scenario • Creating a Scenario

Astra LoadTest Controller User’s Guide Chapter 5, page 71

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

To create Vuser Groups:

 1 Click the Add Group button on the right of the Scenario Groups window. The 
Add Group dialog box opens:

 2 In the Group Name box, enter a name for the Vuser group. 

 3 From the Vuser Quantity box, select the number of Vusers that you want to 
create in the group.
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 4 Select a host from the Host Name list. The Host list contains all hosts that you 
previously added to the scenario. 

To use a host that does not appear, select Add... from the Host Name list. The 
Add Host dialog box opens:

Type the name of the host in the Name box. 

By default, Astra LoadTest  stores temporary files on the host during scenario 
execution, in a temporary directory specified by the host’s TEMP or TMP 
environment variables. To override this default for a specific host, type a location 
in the Temporary Directory box.

Click More to expand the dialog box and show the Add Host tabs. For 
information on configuring the Vuser quotas and display attributes, see 
Configuring Hosts on page 75.

Click OK to close the Add Host dialog box.
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 5 Select a script from the Script Name list. The Script list contains all scripts that 
you previously added to the scenario. 

To use a script that does not appear, click the Browse button. Browse to select 
the path and file name of the new script. 

In the Script Name box, type a name for the script. By default, Astra LoadTest 
uses the script’s file name without an extension. 

For information on configuring the Command Line, Rendezvous, Groups, and 
Files, see Configuring Scripts on page 79.

 6 Click OK to close the Add Group dialog box. The new group’s properties appear 
in the Scenario Groups window.

Modifying a Vuser Group from the Scenario Groups Window
You can modify the Script, Vuser Quantity, and Host for a Vuser group directly 
from the Scenario Groups window of the Controller, or by using the Group 
Information dialog box. 

To modify a Vuser Group directly from the Scenario Groups window:

 1 Select the Group, Script, Vuser Quantity, or Host you want to modify.

 2 Enter or select another name or number for the property. 
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To modify a Vuser Group using the Group Information dialog box:

 1 Double-click the property you want to modify, or right-click it and select Details. 
The Group Information dialog box opens.

 2 In the Group Name box, enter the Vuser group name. 

 3 From the Vuser Quantity box, select the number of Vusers that you want to run 
in the group.

 4 Select a host from the Host Name list. To use a host that does not appear, select 
Add... from the Host Name list and add a new host using the Add Host dialog 
box. 

 5 To change the script for the Vuser group, click Change Script. Select the script 
you want to use from the Add Scripts dialog box and click OK. 

 6 Click OK to close the Group Information dialog box.
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Sorting Vuser Groups in the Scenario Groups Window
Once you have created your Vuser groups, you can sort them by group name, 
script name, host name, or quantity of Vusers assigned to the group.

To sort Vuser groups:

• Select the column by which you want to sort the groups.  Double-click the 
column header.

• Alternatively, you can right-click anywhere within the column you want to sort, 
and select Sort By Name.

Configuring Hosts

You can set a host’s attributes while adding it to the host list, or modify the 
attributes of an existing host at any time, using the Hosts dialog box. 

To configure global settings for all hosts participating in the scenario, use Astra 
LoadTest’s Options dialog box. For more information, see Chapter 7, 
Configuring a Scenario.  To set properties specific for each host, use the Hosts 
dialog box as described below. 

You can also indicate which hosts will run Vusers in the scenario. For example, if 
a host is unavailable for a particular scenario run, you can exclude it temporarily 
instead of removing it entirely from your list of hosts. 
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You select which hosts will take part in the scenario by using the Enable and 
Disable commands. Disabling a host temporarily removes it from the list. Enabling 
a host reinstates it. Disabling hosts is particularly useful if you want to isolate a 
specific machine to test its performance. 

To configure a host:

 1 Click the Hosts button. The Hosts dialog box opens. The Name of the host, its 
Status, and Details are displayed.

 2 Click Connect to change the Status of the host from Down to Ready. Click 
Disconnect to change the Status of the host from Ready to Down.

 3 To disable a host, select the host and click Disable. The host name changes 
from blue to gray, and the host is disabled.
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 4 To enable a host, select the host and click Enable. The host name changes from 
gray to blue, and the host is enabled.

 5 To view details of a host, select the host and click Details. The Host Information 
dialog box opens with information about the host you selected.

 6 To add a host, or modify information for an existing host, click Add. The Add 
Host dialog box opens.
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Type the name of the host in the Name box. 

By default, Astra LoadTest stores temporary files on the host during scenario 
execution, in a temporary directory specified by the host’s TEMP or TMP 
environment variables. To override this default for a specific host, type a location 
in the Temporary Directory box.

Click More to expand the dialog box and show the Status and Runtime Quota 
tabs.

The Status window displays details of the Host Status.

In the Runtime Quota window, you determine how many Vusers a host can 
initialize or stop at a time. Initializing or stopping a large number of Vusers 
simultaneously, places large stress on a host. To reduce stress on a host, you 
can initialize or stop smaller batches of Vusers.

In the Vuser Quota section, enter the maximum number of Vuser types that the 
host will initialize or stop simultaneously.

Click Defaults to use the Default values.

Click OK to close the dialog box.

 7 Click Close to close the Hosts dialog box. The host name you entered appears 
in the Host list; its status is set to DOWN.
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Configuring Scripts

You add a script to a Vuser group using the Add Group dialog box described 
above (see Creating a Scenario on page 66). Once you have created the Vuser 
group, you can select a different script for the group to run, or view the details of 
the script you selected, from the Group Information dialog box. 

To select another script for a Vuser group:. 

 1 Double-click in the Script column, or right-click in the column and select Details. 
The Group Information dialog box opens with the Path, Name, and Type of the 
script you previously selected.
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 2 To select a different script for the Vuser group, click Change Script. The Add 
Scripts dialog box opens.

 3 Click the Browse button to the right of the Path box. The Open Test dialog box 
opens. 

 4 Select the path and file name of the new script. 
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Note: When you specify the location of a script, you can specify a location that is 
relative to the current scenario directory. For details, see Using Relative Paths 
for Scripts on page 84.

 5 Click Open to select the files. The Open Test dialog box closes, and the new 
script name appears in the Add Scripts dialog box.

 6 In the Script Name box, type a name for the script. By default, Astra LoadTest 
uses the script’s file name without an extension. 

 7 Click OK to close the Add Scripts dialog box and enter the new script 
information.

To view script details:

 1 Double-click in the Script column, or right-click in the column and select Details. 
The Group Information dialog box opens. You can view the Path, Name, and 
Type of the script you selected.
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 2 Click More to expand the Group Information dialog box and view additional script 
information. 

 3 In the Command Line box, type any command line options to use when running 
the script. For example: -x value -y value
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For information about passing command line argument values to a script, refer to 
the Virtual User Recorder guide.

 4 To see the rendezvous points declared in the selected script, click the 
Rendezvous tab. 

 5 To see the list of Vusers associated with the selected script, click the Vusers tab. 
If you have not yet created Vusers, the box will be empty.

 6 To see the list of files used by the script, click the Files tab. By default this list 
shows all files in the script’s directory (only after your script has been added to 
the script list). These files include the configuration settings file, the init, run, and 
end portions of the script, the parameterization definitions file, and the usr file. To 
exclude a file from the list, click on the check box adjacent to it. To add a file to 
the list, click Add. 

 7 Click OK to close the Group Information dialog box. The new script name and its 
details appear in the Script list.  

Note: If you use the Virtual User Recorder  to make changes to a script while the 
Controller is running, click the Refresh button in the Controller’s Group 
Information dialog box to update the script details in the scenario.
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Using Relative Paths for Scripts

When you specify the location of a script, you can specify a relative location. The 
location can be relative to the current scenario directory, or the Astra LoadTest 
installation directory. 

You can specify a path relative to the current scenario directory by typing either 
of the following notations at the start of the script path:

.\ indicates that the path is relative to the location of the 
scenario directory.

..\ indicates that the path is relative to the location of the 
parent directory of the scenario directory.

For example, if the current scenario is located at F:\scenarios, to specify a script 
located at F:\scenarios\scripts\user.usr, you could type:

You can specify a path relative to the Astra LoadTest installation directory by 
typing a percent sign (%) at the beginning of the script path. For example, if the 
Astra LoadTest installation directory is located at F:\LoadTest, to specify a script 
located at F:\LoadTest\scripts\user1.usr, you could type:

.\scripts\user1.usr

%\scripts\user1.usr
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Note: When specifying a relative path, you can include standard DOS notation 
(.\ and ..\) inside the path, as shown in the following example: 
M:\ALT\my_tests\..\..\test.usr.

When you run a scenario, by default, the script is copied to a temporary directory 
on the Vuser group machine. This enables the Vuser group host to access the 
script locally instead of over a network. 
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�
Using Rendezvous Points 

Astra LoadTest allows you to check your system’s response under specific load. 
To do this, you can use rendezvous points to cause multiple Vusers to perform 
tasks at exactly the same time, thereby creating intense user load on the server.

This chapter describes:

• Setting the Rendezvous Attributes

• Setting the Rendezvous Behavior

• Disabling and Enabling Rendezvous Points

• Disabling and Enabling Vusers at Rendezvous Points

• Viewing Rendezvous Information
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About Using Rendezvous Points

During a scenario run you can instruct multiple Vusers to perform tasks 
simultaneously by using rendezvous points. A rendezvous point creates intense 
user load on the server and enables Astra LoadTest to measure server 
performance under load. 

Suppose you want to measure how a bank server performs when ten Vusers 
simultaneously withdraw cash from ten different automatic teller machines 
(ATMs). In order to emulate the required user load on the server, you instruct all 
the Vusers to withdraw cash at exactly the same time. 

You ensure that multiple Vusers act simultaneously by creating a rendezvous 
point. When a Vuser arrives at a rendezvous point, it is held there by the 
Controller. The Controller releases the Vusers from the rendezvous either when 
the required number of Vusers arrive, or when a specified amount of time has 
passed. For details on the release criteria, see Setting the Rendezvous 
Behavior on page 91.

You define rendezvous points in the Vuser script. For information about inserting 
rendezvous points into Vuser scripts, refer to theVirtual User Recorder guide.

Using the Controller, you can influence the level of server load by selecting:

• which of the rendezvous points will be active during the scenario

• how many Vusers will take part in each rendezvous
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For example, to test an online bank you could create a scenario that contains two 
rendezvous points. The first rendezvous ensures that one thousand Vusers 
simultaneously deposit cash. The second rendezvous ensures that another 
thousand Vusers simultaneously withdraw cash. If you want to measure how the 
server performs when only five hundred Vusers deposit cash, you can deactivate 
(disable) the “withdraw” rendezvous, and instruct only five hundred Vusers to 
participate in the “deposit” rendezvous. 

The following procedure outlines how to control load peaks on the server: 

 1 Create the Vuser scripts, inserting the necessary rendezvous points.

 2 Create a scenario.

When you add a Vuser group to a scenario, Astra LoadTest scans the group’s 
associated script for the names of the rendezvous points and adds them to the 
list in the Rendezvous window. If you create another Vuser group that runs the 
same script, the Controller adds the new Vusers to the rendezvous and updates 
the list.

 3 Set the level of emulated user load. 

You determine the exact level of load by selecting the rendezvous points that will 
take part in the scenario, and how many Vusers will participate in each 
rendezvous.
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 4 Set the attributes for the rendezvous (optional). 

For each rendezvous you can set the timeout and policy attributes. For more 
information, see Setting the Rendezvous Behavior on page 91.

 5 Run the scenario. 

Setting the Rendezvous Attributes

You can set the following rendezvous attributes from the Rendezvous Information 
dialog box:

• Timeout

• Rendezvous Policy

• Enabling and Disabling Rendezvous

• Enabling and Disabling Vusers
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In addition, the dialog box displays general information about the rendezvous 
point: which script is associated with the rendezvous and release history. 

For information on manipulating the Vusers during scenario execution using the 
Release command, see Chapter 11, Running a Scenario. 
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Setting the Rendezvous Behavior

Setting the rendezvous behavior determines how the Vusers handle a 
rendezvous point. You set the following behavior attributes for each rendezvous:

timeout how long the Controller waits before releasing Vusers 
from a rendezvous.

policy sets how many Vusers will be released from a rendezvous 
at a time.

Setting the Timeout Behavior Attribute
The timeout determines the maximum time (in seconds) that Astra LoadTest waits 
for each Vuser to arrive at a rendezvous. After each Vuser arrives at the 
rendezvous, Astra LoadTest waits up to timeout seconds for the next Vuser to 
arrive. If the next Vuser does not arrive within the timeout period, then the 
Controller releases all the Vusers from the Rendezvous. Each time a new Vuser 
arrives, the timer is reset to zero. The default timeout is thirty seconds. You set a 
timeout for each rendezvous point.

To set a timeout:

 1 Choose Scenario > Rendezvous. The Rendezvous Information dialog box 
opens.

 2 Select the rendezvous for which you want to set a timeout from the Rendezvous 
list . 
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 3 In the Behavior section, locate the Timeout box. Enter a timeout value—the 
default is 30 seconds.

 4  Click OK to close the dialog box and set the timeout for the rendezvous.

Setting the Release Policy Attribute
The policy attribute determines how the Controller releases Vusers from the 
rendezvous. For each rendezvous you can set the following policies:

All Arrived Instructs the Controller to release the Vusers from the 
rendezvous only when all the Vusers included in the 
rendezvous arrive. All the Vusers are released 
simultaneously. The default policy is All Arrived. 

Quota Sets the number of Vusers that must arrive at a 
rendezvous point before the Controller releases the 
Vusers. For instance, suppose that you are testing a 
scenario of fifty Vusers and that you want a particular 
operation to be executed simultaneously by ten Vusers. 
You can designate the entire scenario as participants in 
the rendezvous and set a quota of ten Vusers. Every time 
ten Vusers arrive at the rendezvous, they are released.
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To set the policy attribute:

 1 Choose Scenario > Rendezvous. The Rendezvous Information dialog box 
opens.

 2 Click a rendezvous in the Rendezvous list. 

 3 In the Behavior section, locate the Policy box. 

 4 To set the policy to All Arrived, select All Arrived from the list. The new policy 
appears in the Policy field.

 5 To set the policy to Quota, select Quota from the list. The Rendezvous - Quota 
dialog box opens.

Enter the number of Vusers in the Quota box. 

 6 Click OK to close the dialog box. The new policy appears in the Policy field.
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Disabling and Enabling Rendezvous Points

You can temporarily disable a rendezvous and exclude it from the scenario. By 
disabling and enabling a rendezvous, you influence the level of server load. 

You use the Disable and Enable buttons in the Rendezvous Information dialog 
box, to change the status of a rendezvous. 

To disable a rendezvous:

 1 Choose Scenario > Rendezvous. The Rendezvous Information dialog box 
opens.

 2 Select the rendezvous you want to disable.

 3 Click the Disable button. The button changes to Enable and the rendezvous 
becomes disabled. 

To enable a rendezvous:

 1 Choose Scenario > Rendezvous. The Rendezvous Information dialog box 
opens.

 2 Select the disabled rendezvous that you want to enable.

 3 Click the Enable button. The button changes to Disable and the rendezvous 
becomes enabled.
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Disabling and Enabling Vusers at Rendezvous Points

In addition to disabling a rendezvous point for all Vusers in a scenario, Astra 
LoadTest lets you disable it for specific Vusers. By disabling Vusers at a 
rendezvous, you temporarily exclude them from participating in the rendezvous. 
Enabling disabled Vusers returns them to the rendezvous. You use the Disable 
and Enable commands to specify which Vusers will take part in a rendezvous. 

To disable a Vuser in a rendezvous:

 1 Choose Scenario > Rendezvous. The Rendezvous Information dialog box 
opens.
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 2 Select the rendezvous for which you want to disable Vusers from the 
Rendezvous list . 

 3 In the section Enable/Disable Vusers, select the Vuser(s) you want to exclude 
from the rendezvous. Select multiple Vusers using the CTRL key.

 4 Click Disable (the button directly below the Vuser list). The disabled Vusers 
change from black to gray and will not take part in the rendezvous. 

 5 To enable a Vuser, select it and click Enable.
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Viewing Rendezvous Information

During and after a scenario, you can view the rendezvous status in the 
Rendezvous Information dialog box. The following information is provided:

Time: The time the rendezvous was released.

Reason: The reason the rendezvous released the Vusers. The possible values 
are Timeout or Arrived.

Arrived: The number of Vusers that arrived at the rendezvous point, out of the 
total number of Vusers assigned to the rendezvous. 
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To view rendezvous information:

 1 Choose Scenario > Rendezvous. The Rendezvous Information dialog box 
opens.

 2 Select the rendezvous whose information you want to view. The rendezvous 
status is displayed in the Status Information section.
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�
Configuring a Scenario

You can configure how hosts and Vusers behave when you run a scenario so that 
the scenario accurately emulates your working environment. 

This chapter describes:

• Saving Messages to the Output Files

• Setting Timeout Intervals

About Configuring a Scenario

Before you run a scenario, you can configure both the host and Vuser behaviors 
for the scenario. Although the default settings correspond to most environments, 
Astra LoadTest allows you to modify the settings in order to customize the 
scenario behavior. The settings apply to all future scenario runs and generally 
only need to be set once.

The settings described in this chapter apply to all the hosts in a scenario. To 
change the settings for individual host machines, refer to Chapter 5, Creating a 
Scenario.  If the global scenario settings differ from those of an individual host, 
the host settings override them.
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The settings discussed in this chapter are unrelated to the Vuser Runtime 
settings. These settings, which apply to individual Vusers or scripts, contain 
information about logging, think time, and the number of iterations. For 
information on setting the Run-Time settings, see the Virtual User Recorder 
guide.

For information on setting the options for online monitors, see Chapter 13, Online 
Monitoring. 

The Astra LoadTest Expert mode allows you to configure additional settings for 
the Astra LoadTest agent and other Astra LoadTest components. For more 
information, see Appendix B, Working in Expert Mode.



Designing a Scenario • Configuring a Scenario

Astra LoadTest Controller User’s Guide Chapter 7, page 101

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

Saving Messages to the Output Files

By default, Astra LoadTest generates an output file, output.log, and stores it in the 
script directory. This file contains error, warning and notification messages issued 
by the Controller during scenario execution. Using the Options dialog box, you 
can select the type of messages to save to the output file. In addition, you can 
disable the logging entirely.

You can specify the number of messages that will appear in the output window. If 
the number of messages exceeds the limit, they are deleted. A deletion quota 
value specifies the number of messages that may be deleted from the output. The 
deletion quota overrides the limit number. For example, assume that you limit the 
number of messages to 500 and set the deletion quota to 50. If there are 600 
messages, 550 will appear in the output. 
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To configure the output file:

 1 Choose Tools > Options. The Options dialog box opens. Click the Output tab. 

 2 Select Do not save the output messages to disable writing to the output.log 
file. 

 3 Select Save all messages to instruct Astra LoadTest to save message of all 
types to the log file.
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 4 Select Save messages of type to exclude a specific message type. Then select 
the message type(s) to include in the log file.

 5 To limit the number of output messages, select Limit the number of messages 
to and specify a value.

 6 To set a deletion quota, specify a value in the Deletion quota box.

Setting Timeout Intervals

Astra LoadTest enables you to set the timeout interval for commands, pinging of 
hosts, and Vuser elapsed time.

The command timeouts are the maximum time limits for various Astra LoadTest 
commands. When a command is issued by the Controller, you set a maximum 
time for the host or Vuser to execute the command. If it does not complete the 
command within the timeout interval, the Controller issues an error message.

The command timeouts relate to hosts and Vusers. The host commands for which 
you can specify a timeout interval are Connect, Disconnect, and Heartbeat. The 
Vuser commands for which you can specify a timeout interval are Init, Run, 
Pause, and Abort. 
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For example, the default Init timeout is 180 seconds. If you select a Vuser and 
click the Initialize button, Astra LoadTest checks whether the Vuser reaches the 
Ready state within180 seconds; if it does not, the Controller issues a message 
indicating that the Init command timed out.

In the Vuser view, the Elapsed column (the last column) indicates the amount of 
time that elapsed from the beginning of the scenario. You can specify the 
frequency in which Astra LoadTest updates this value. The default is 4 seconds.

During scenario execution, Astra LoadTest periodically pings all of the hosts 
participating in the scenario to ensure that a connection still exists. You can set 
the ping frequency. The default is 30 seconds. 

Note: Astra LoadTest’s calculations consider the number of active Vusers and 
their influence on the timeout values. For example, 1000 Vusers trying to 
initialize will take much longer than 10 Vusers. Astra LoadTest adds an internal 
value, based on the number of active Vusers, to the specified timeout value. 
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To set timeout intervals:

 1 Choose Tools > Options. The Options dialog box opens. Click the Timeout tab. 

 2 Clear the Enable timeout checks check box to disable the timeout test. Astra 
LoadTest waits an unlimited time for the Initialize, Run, Pause, and Stop 
commands to be executed.

 3 To specify a command timeout interval, select the Enable timeout checks 
check box and specify the appropriate timeouts. 
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 4 Specify the frequency at which Astra LoadTest updates the Elapsed time, in the 
Update Vuser Elapsed Time every box.

 5 Enter the frequency at which Astra LoadTest pings the various host machines 
participating in the scenario in the Ping all hosts every box.

The Astra LoadTest Expert mode allows you to configure additional timeout-
related settings. For more information, see Appendix B, Working in Expert 
Mode.
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�
Setting the Scenario Scheduling

After you create a scenario, you can set the start and duration time of the scenario 
or of the Vuser groups within the scenario. In addition, you can gradually run the 
Vusers within a scenario or within a Vuser group.

This chapter describes:

• Opening the Schedule Builder

• Scheduling a Scenario

• Scheduling Vuser Groups
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About Scenario Scheduling

An important factor in the creation of a scenario, is developing a test that 
accurately portrays user behavior—the types of actions and the timing of those 
actions. The actions are represented by Vuser scripts. You set the timing aspect 
of the scenario using the Astra LoadTest Schedule Builder. 

You can instruct Astra LoadTest to begin executing a scenario or Vuser group 
with a delay. You specify the number of minutes to wait from the time a Run 
command is issued, until the scenario or Vuser group begins. 

You can limit the time duration of a scenario or Vuser group. You specify the 
number of minutes a scenario or Vuser group should be in the Running state. 
When the scenario or group reaches its time limitation, it finishes.

You can stipulate how many Vusers Astra LoadTest runs within a certain time 
frame during a scenario or Vuser group. You specify whether Astra LoadTest 
should run all Vusers simultaneously, or run only a certain number of Vusers 
within a specified amount of time.
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Opening the Schedule Builder

You use the Schedule Builder to schedule both a scenario and an individual Vuser 
group. You can either create a New Schedule with new properties, or change the 
properties for one of the two existing schedules: Slow Ramp Up and Ramp Up 
(the default schedule).

To open the Schedule Builder:

 1 Select Scenario > Schedule Builder or click the Schedule Builder button. 
Alternatively, you can choose Slow Ramp Up, Ramp Up, or New Schedule 
from the Schedule selector on the toolbar. 

If you select New Schedule, the New Schedule dialog box opens.
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In the Name text box, type the name of the New Schedule and click OK. The 
Schedule Builder dialog box opens.

 2 In the General Settings box, select the schedule name.

To rename a schedule, click Rename. Enter the new name you want to use in 
the dialog box that opens. To delete a schedule, click Delete.

 3 To delay the start of the scenario, check Delay scenario start for and select the 
amount of time you want to delay the start of your scenario.
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Scheduling a Scenario

Using the Schedule Builder, you can control the execution of your scenario by:

• Limiting the scenario duration 

• Gradually running Vusers within a scenario

To set the scheduling options for a scenario:

 1 Select the Scenario Scheduling option. 

 2 In the Scenario Settings box, select Maximum Duration and specify the 
maximum amount of time you want to allot to the scenario.
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 3 In the Ramp Up box:

• Select Run all Vusers simultaneously if you want to run all the Vusers at once.

• To gradually run the Vusers, select the number of Vusers you want to run and the 
time span within which you want to run them.

 4 Click OK to save your settings.

Scheduling Vuser Groups

After you create a Vuser group, you can schedule the group’s script execution by 
setting:

• the amount of time after the start of the scenario that the group must wait 
before it starts running

• the number of Vusers that will run within a specified period of time

• the amount of time the group will run
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To schedule a Vuser Group:

 1 Select the Group Scheduling option. 

 2 Select a group from the box on the left. 

 3 To set the start time for the group, click the Start Time tab. Choose one of the 
following three options:

• Start the group at the beginning of the scenario.

• Specify the amount of time that you want to elapse before the group begins 
running.

• Specify that you want to begin the group after another group finishes running.
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 4 To set the ramp up for the group, click the Ramp Up tab.

Choose one of the following options:

• Load all of the Vusers simultaneously.

• Specify the number of Vusers you want to load within a certain period of time.
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 5 To set the duration of the group, click the Duration tab.  

Choose one of the following options:

• Run until completion.

• Specify the amount of time for which you want to run the group.

 6 Click OK to close the Schedule Builder and save your settings.
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�
Preparing to Run a Scenario

Before you run a scenario, you specify a location for the scenario results and 
other runtime related settings.   

This chapter describes:

• Specifying a Results Location

• Results Directory File Structure

• Collating Results

• Limiting Access to a Host Machine

• Setting Scenario Summary Information
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About Preparing to Run a Scenario

Before you run a scenario, you need to specify the location of the results 
(mandatory), assign a name to the results, schedule the scenario, and provide 
scenario summary information. In addition, you can specify the applications to 
invoke at the start of a scenario. 

Although most of the pre-scenario settings are optional, by using them you can 
enhance the testing process. These values are scenario specific—you can set 
different values for each Astra LoadTest scenario. 

For information on one-time configuration settings such as timeout, output, and 
quotas, see Chapter 7, Configuring a Scenario. 
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Specifying a Results Location

When you run a scenario, by default the runtime files are stored locally on each 
host. After the scenario, the results are collated together and processed on the 
Controller machine.  

You can also use Mercury Interactive’s test management program, TestDirector, 
to store results to a project. For information on connecting to a TestDirector 
database, see Chapter 10, Managing Scenarios Using TestDirector. 

Astra LoadTest allows you to give descriptive names to each result set. This is 
especially useful for cross-scenario analysis, which lets you compare the results 
of multiple scenario runs. Astra LoadTest superimposes the results of several 
scenario runs in a single graph. The descriptive graph names enable you to 
distinguish between the results of the multiple runs.
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In the example below, the results of three scenario runs are superimposed. The 
result sets are cfg_1, cfg_2, and cfg_3.

For more details on cross-scenario graphs, see Chapter 22, Cross-Scenario 
Analysis. 
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To specify where results are stored(not in TestDirector): 

 1 Choose Results > Results Settings. The Set Results Directory dialog box 
opens. 

 2 In the Results Name box, enter a name for the results. Avoid using the same 
name with different paths, since the names will appear identical on the graphs.

 3 In the Directory box, type the full path of the results directory. If you are using 
the default file storage setting (local machine), specify a directory in which to 
store all of the collated results after the scenario run. If you specified a shared 
network drive as the file storage method, specify the directory to which Vuser 
groups should write during scenario execution.
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Using the results name from step 2, the Controller creates a subdirectory within 
the results directory. All results are saved within this subdirectory. 

 4 Select the appropriate check box for subsequent executions: Automatically 
create a results directory for each scenario execution or Automatically 
overwrite existing results directory without prompting for confirmation. 

 5 Click OK to save the results directory setting.

To specify where results are stored (using TestDirector): 

 1 Choose Options > TestDirector Connection to open a connection to a 
TestDirector server and database.

 2 Open a scenario from the database (File > Open), or save the current scenario 
to the TestDirector database (File > Save As). 
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 3 Choose Results > Results Settings. The Set Results Directory dialog box 
opens. 

 4 Click TestDirector. The Directory box changes to Test sets. 
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 5 In the Results Name box, enter a name for the results. Avoid using the same 
name with different paths, since the names will appear identical on the graphs.

 6 Select an existing test set from the Test Sets list, or specify a new one.

 7 Select the appropriate check box for subsequent executions: Automatically 
create a results directory for each scenario execution or Automatically 
overwrite existing results directory without prompting for confirmation. 

 8 Click OK to save the results settings.

Results Directory File Structure

When you set the results directory, you also specify a results name. Astra 
LoadTest creates a subdirectory using the results name, and places all of the data 
it gathers in that directory. Every set of results contains general information about 
the scenario in a result file (.lrr) and an event (.eve) file.
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During scenario execution, Astra LoadTest also gathers data from each Vuser 
and stores it in an event file _t_rep.eve and an output file output.txt. Astra 
LoadTest creates a directory for each group in the scenario and a subdirectory for 
each Vuser. A typical result directory has the following structure: 

• t_rep.eve in the main result directory contains Vuser and rendezvous 
information. 

• *.def are definition files for graphs that describe the online and other custom 
monitors.

Results directory

Result file

Data directory

Vuser directories

Event file

Vuser files

Results name

Definition file

Output logfile

Group directory
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• results_name.lrr is the Astra LoadTest Analysis document file.

• output.log contains output information about the scenario generated during test 
execution. 

• The Data directory contains the database created by the Analysis (from the 
results files).

• g1 is a group directory. A separate directory exists for each Vuser group that runs 
in the scenario. Each group directory consists of Vusers subdirectories.

• t_rep.eve in each Vuser directory contains transaction and Data Point 
information.

• output.txt in each Vuser directory contains output information generated during 
replay. 

When you generate analysis graphs and reports, the Astra LoadTest Analysis 
engine copies all of the scenario result files (.eve and .lrr) to a database. Once 
the database is created (and stored in the Data directory), the analysis works 
directly with the database and does not use the result files. 

For information on Astra LoadTest Analysis, see Chapter 18, Understanding 
Astra LoadTest Analysis. 
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Collating Results

When you run a scenario, by default all Vuser information is stored locally on each 
host. After scenario execution, the results are automatically collated or 
consolidated—results from all of the hosts are transferred to the results directory. 
You set the location of the results directory as described in Specifying a Results 
Location on page 118. 

To disable automatic collation, choose Results > Auto Collate Results to clear 
the check mark adjacent to the option. To manually collate results, choose 
Results > Collate Results.  If your results have not been collated, then Astra 
LoadTest will automatically collate the results before generating the analysis data.
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Limiting Access to a Host Machine

You can limit access to a host by creating a list of authorized machines in the 
host’s Remote Command Launcher (shortcut menu). Only machines which 
appear on the list are authorized to launch applications on the host.

To limit access to a host machine:

 1 Make sure that the Remote Command Launcher, rmcdl.exe, is active on the host 
machine.

 2 Select Edit Permissions from the Remote Command Launcher’s shortcut 
menu.

The host list opens in Notepad. 

 3 Create or update the list of machines which are authorized to access this host. 
Place each machine name on a separate line.

 4 Close the Notepad file.

 5 To save the permissions list, select Update Permissions from the Remote 
Command Launcher’s shortcut menu.
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Setting Scenario Summary Information

The Controller allows you to provide a detailed description of the scenario. In 
addition, you can specify the author’s name and a subject title for the scenario. 
Whenever you open this scenario, the summary information is available to you. 

To set the scenario summary information:

 1 Choose Scenario > Summary Information. The Summary Information box 
opens. 

 2 In the Author box, enter the name of the author.

 3 In the Subject box, enter a subject name or short title for the scenario.

 4 In the Description box, enter a detailed description about the scenario.

 5 Click OK to close the dialog box.
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Managing Scenarios Using TestDirector

Astra LoadTest integration with TestDirector lets you manage Astra LoadTest 
scenarios using TestDirector. TestDirector helps you organize and manage all 
scripts, scenarios, and results using a repository. 

This chapter describes:

• Opening a Connection to a TestDirector Project

• Opening a Scenario Using TestDirector

• Saving Scenarios to the TestDirector Project

• Saving Results to the TestDirector Project

• Adding Vuser Scripts with TestDirector

• Managing Your Scenario in TestDirector

For detailed information on using TestDirector to manage your scenarios, refer to 
the TestDirector User’s Guide.
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About Managing Scripts Using TestDirector

Astra LoadTest works together with TestDirector, Mercury Interactive’s test 
management tool. TestDirector provides an efficient method for storing and 
retrieving scenarios and collecting results. You store scenarios and results in a 
TestDirector repository and organize them into unique groups.

The Controller’s Tools menu contains two menu items related to TestDirector. 
The first item, TestDirector Connection changes the test repository from the 
standard file system to the TestDirector database. The second item, TestDirector, 
invokes TestDirector. To save scenario results to a TestDirector repository, it is 
sufficient to open the TestDirector connection. However, if you want to include 
details about the scenario, open TestDirector and enter the appropriate details 
from the program’s UI. 

The following sections describe how to use the TestDirector repository to:

• open scenarios 

• save scenarios 

• save results

• open scripts
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Opening a Connection to a TestDirector Project

Before you can work with a TestDirector project, you must open a connection to 
the server hosting the project. 

To open a connection to a TestDirector project:

 1 Choose Tools > TestDirector Connection (not TestDirector) from the 
Controller.
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 2 In the Server box, type the name of the TestDirector server and click Connect. A 
message appears indicating that Astra LoadTest is connecting to the server. 

 3 In the Project Connection box, select one of the available projects. 

 4 Provide the user login and password. 

 5 Select the Reconnect on Startup check box to automatically open the 
connection to the TestDirector server and project when you start Astra LoadTest. 



Designing a Scenario • Managing Scenarios Using TestDirector

Astra LoadTest Controller User’s Guide Chapter 10, page 133

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

 6 If you select Reconnect on Startup, you can save the specified password to 
automate the login process. Select the Save Password for Reconnection on 
Startup check box.

 7 Click Connect. A message appears indicating that Astra LoadTest is connecting 
to the project. 

 8 Click Close to close the Connection to TestDirector dialog box.

Opening a Scenario Using TestDirector

You can open a scenario through the standard file system or the TestDirector 
repository. Before opening a scenario through TestDirector, make sure you have 
opened a connection to the project.
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To open a scenario from the TestDirector repository:

 1 Choose File > Open or click the File Open button. The Open Scenario from 
TestDirector Project dialog box opens.

 2 Select an Astra LoadTest scenario from the project.
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 3 Click OK. Astra LoadTest loads the scenario. The name of the scenario appears 
in the Controller’s banner. The Design tab shows the scripts, the hosts, and the 
Vusers and Vuser groups in the scenario.

 4 To select a scenario file from the standard file system, click the File System 
button in the upper right corner of the dialog box. The Open dialog box opens. 

 5 To return to the Open from TestDirector Project dialog box, click the 
TestDirector button in the bottom right of the dialog box. 
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Saving Scenarios to the TestDirector Project

You can save a new scenario, or one that previously existed as a local file, into 
the TestDirector project.

To save a scenario to the TestDirector project:

 1 Connect to the TestDirector server (see Opening a Connection to a 
TestDirector Project on page 131.)

 2 Choose File > Save As. The Save in TestDirector Project dialog box opens.
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 3 Type a scenario name, select a folder and click OK. 

 4 To save the scenario to disk, click File System and save the file as you would on 
a standard file system. 

Saving Results to the TestDirector Project

Before you run a scenario, you set the results location. If you have a connection 
open to the TestDirector project, results are saved to the default test set. You can 
also save the results to a new or existing test set, or to disk using the standard file 
system.
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To specify a results location:

 1 Choose Results > Results Setting. The Set Results Directory dialog box opens.  

If you have a connection to TestDirector, a TestDirector button also appears. 

 2 Type a name for the results in the Results name box. 

 3 Specify a directory for the results, or click TestDirector to save the results in a 
TestDirector repository.

 4 For a TestDirector project, specify the name of a test set. 

 5 Click OK to close the dialog box. 
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Adding Vuser Scripts with TestDirector

You can add scripts from the TestDirector project to the Controller’s script list. 

To add a script to the script list:

 1 Connect to the TestDirector server (see Opening a Connection to a 
TestDirector Project on page 131.)

 2 In the Scenario Groups window, double-click within the Script column. The 
Group Information dialog box opens. Click the Change Script button.  The Add 
Scripts dialog box opens. 
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 3 Click the Browse button to the right of the Path box. The Open dialog box 
opens. 

 4 Locate the script in the TestDirector repository and click OK. The full path and 
name of the script appear in the Path box. TestDirector scripts are preceded by a 
“[TD]”.

 5 Click OK to close the Add Scripts dialog box. The script appears in the Script 
column in the Scenario Groups window. 

Managing Your Scenario in TestDirector

You can further utilize TestDirector to manage scenario and test information. After 
you save a scenario to the TestDirector project, you can enter details about the 
scenario and the structure of the test. 

To enter scenario details: 

 1 Choose Tools > TestDirector or click the TestDirector button to start 
TestDirector.

 2 Open the database where the results are stored and select a scenario.



Designing a Scenario • Managing Scenarios Using TestDirector

Astra LoadTest Controller User’s Guide Chapter 10, page 141

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

 3 Enter information about the test level, version, owner, and designer. 
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TestDirector also enables you to manage the user access to a test’s project. By 
creating a list of authorized users and assigning each user a password and user 
type, you control the kinds of additions and modifications each user makes to the 
project. The user type determines the privileges that the user has within 
TestDirector.

For more information on using TestDirector to manage your scenarios, refer to the 
TestDirector User’s Guide.
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Part III

Executing a Scenario
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Running a Scenario

When you run a scenario, Astra LoadTest generates load on the Web system you 
are testing, and measures the system’s performance.

This chapter describes:

• Running an Entire Scenario

• Controlling Vuser Groups

• Controlling Individual Vusers

• Manually Releasing Vusers from a Rendezvous
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About Running a Scenario

When you run a scenario, the Vuser groups are assigned to their hosts and 
execute their Vuser scripts. During scenario execution, Astra LoadTest:

• records the durations of the transactions you defined in the Vuser scripts

• performs the rendezvous included in the Vuser scripts

• collects error and notification messages generated by the Vusers

You can run an entire scenario unattended, or you can interactively select the 
Vuser groups and Vusers that you want to run. When the scenario starts running, 
the Controller first checks the scenario configuration information. Next, it invokes 
the applications that you selected to run with the scenario. Then, it distributes 
each Vuser script to its designated host. When the Vuser groups are ready, they 
start executing their scripts. While the scenario runs, you can stop both Vuser 
groups and individual Vusers. 

The scenario ends when all the Vusers have completed their scripts, when the 
duration runs out, or when you terminate it.

The following procedure outlines how to run a scenario:

 1 Open an existing scenario or create a new one. 

 2 Configure and schedule the scenario. 

 3 Set the results directory. 
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 4 Run and monitor the scenario.

While the scenario runs, you can stop both Vuser groups and individual Vusers; 
monitor each Vuser in the scenario; and view error and notification messages 
generated by the Vusers.

Running an Entire Scenario

You can run all the Vusers and Vuser groups in a scenario, or you can select the 
specific Vuser groups and Vusers that you want to run. Note that when you run 
an entire scenario, Astra LoadTest does not begin running Vusers until all of them 
have reached the Ready state.  However, if you run individual groups or Vusers,  
Astra LoadTest runs the Vusers as soon as they reach the Ready state. 

The following section describes how to run an entire scenario. Controlling Vuser 
Groups on page 148 and Controlling Individual Vusers on page 151, describe 
how to manipulate Vuser groups and individual Vusers.
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To run an entire scenario:

 1 Open an existing scenario or create a new one. Click the Run tab. The Scenario 
Groups window appears in the top left-hand corner of the screen.

 2 Choose Scenario > Start, or select all the Vuser groups in your scenario and 
click the Run button. The Controller starts initializing the Vusers and distributing 
them to their designated hosts—where they begin to execute their Vuser scripts.

If you have not specified a results directory for the scenario, the Set Results 
Directory dialog box opens. 

During scenario execution you can manipulate individual Vusers and Vuser 
groups. This is described in Controlling Vuser Groups on page 148 and 
Controlling Individual Vusers on page 151. 

 3 Choose Scenario > Stop, or click the Stop button to terminate the scenario.

 4 Choose Scenario > Reset, or click the Reset button to reset all Vusers to their 
pre-scenario, DOWN status. 
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Controlling Vuser Groups

You can run an entire scenario as described above, or you can manipulate 
individual Vuser groups in the scenario. This section describes how to initialize, 
run, and stop Vuser groups.

Initializing Vuser Groups
Initializing a Vuser group distributes the Vusers in the group to their designated 
hosts so that they are ready to execute their script. By initializing all of the Vusers 
in a group before running them, you can ensure that they all begin executing the 
scenario at the same time. 

To initialize a Vuser group:

 1 Select the Vuser group or groups that you want to initialize.

 2 Choose Scenario > Initialize, or right-click the Vuser group or groups you want 
to initialize and select Initialize. The Vuser group’s status changes from DOWN to 
PENDING to INITIALIZING to READY. If a Vuser group fails to initialize, the Vuser 
group status changes to ERROR.
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Running Vuser Groups
Running a Vuser group tells the Vuser group to execute its script. 

To run a Vuser group:

 1 Select the Vuser group or groups that you want to run.

 2 Choose Scenario > Start, or click the Run button. The Vuser groups execute 
their scripts. If you run a Vuser group in the DOWN or ERROR state, Astra 
LoadTest initializes and then runs the Vuser group.

Stopping Vuser Groups
Stopping a Vuser group stops script execution. If you stop a Vuser group, the 
group still appears in the Vuser group list.

To stop a Vuser group: 

 1 Select the Vuser group or groups that you want to stop.

 2 Choose Scenario > Stop, or click the Stop button. The Vuser groups stop 
executing their scripts.
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Resetting Vuser Groups
Resetting a Vuser group causes all Vusers to revert to their pre-scenario, DOWN 
status.

To reset a Vuser group:

 1 Select the Vuser group or groups that you want to reset.

 2 Choose Scenario > Reset, or click the Reset button. The Vuser groups revert to 
their pre-scenario, DOWN status. 
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Controlling Individual Vusers

You can also manipulate individual Vusers within the Vuser groups you have 
defined. This section describes how to initialize, run, and stop individual Vusers.

To control an individual Vuser:

 1 In the Scenario Groups window, select a group and click the Vusers button. The 
Vusers dialog box opens, with a list of the ID, Status, Script, Host, and Elapsed 
time (since the beginning of the scenario) for each of the Vusers in the group.
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You can control an individual Vuser using the following utilities:

• Select a Vuser and click Run to run it.

• Select a Vuser and click Stop to stop it from running.

• Select a Vuser and click Reset to revert its status to DOWN.

• To initialize a Vuser, right-click it and select Initialize.

• To filter the Vusers listed, right-click in one of the columns and select Filter 
Vusers.  Select the way in which you want to filter the Vusers.

• To sort the Vusers listed, right-click in one of the columns and select Sort 
Vusers.  Select the way in which you want to sort the Vusers.

• To view a Vuser executing its assigned script, select the Vuser and click the 
Show button. A browser opens, allowing you to see the Vuser executing the 
script. 

To close the browser, click the Hide button.
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• To view the Vuser script log, click the Vuser log button. A script log, such as the 
following, appears.

To close the Vuser script log, click the Close Vuser log button.

 2 Click Close to close the Vusers dialog box.
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Manually Releasing Vusers from a Rendezvous

While you run a scenario, you can manually release Vusers from a rendezvous 
before the Controller releases them.

To manually release Vusers from a rendezvous:

 1 Choose Scenario > Rendezvous. The Rendezvous Information dialog box 
opens.

 2 Select a rendezvous from the Rendezvous list.

 3 Click Release. The Vusers in the rendezvous are released.
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Viewing Vusers During Execution

During scenario execution, you can view the actions that are performed by 
Vusers. 

This chapter describes:

• Monitoring Vuser Status

• Viewing the Output Window

• Viewing the Agent Summary

About Viewing Vusers During Execution

Astra LoadTest lets you view Vuser activity during a scenario: 

• On the Controller host machines, you can view the Output window,  monitor 
Vuser performance online, and check the status of Vusers executing the 
scenario.

• On remote machines, you can view the Agent summary with information about 
the active Vusers.   
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Monitoring Vuser Status

During scenario execution, you can use the Scenario Groups window in the Run 
view to monitor the actions of all the Vusers and Vuser groups in the scenario. 

The Status field of each Vuser group displays the current state of each Vuser in 
the group. The following table describes the possible Vuser states during a 
scenario.

Status Description

DOWN The Vuser is down. 

PENDING The Vuser is ready to be initialized and is waiting for an 
available host, or is transferring files to the host. The Vuser will 
run when the conditions set in its scheduling attributes are 
met.

INITIALIZING The Vuser is being initialized on the remote machine.

READY The Vuser already performed the init section of the script and 
is ready to run.

RUNNING The Vuser is running. The Vuser script is being executed on a 
host.

RENDEZVOUS The Vuser has arrived at the rendezvous and is waiting to be 
released by Astra LoadTest.

DONE.PASSED The Vuser has finished running. The script passed.
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You can also view a synopsis of the running scenario in the box at the top right-
hand corner of the Run view.

DONE.FAILED The Vuser has finished running. The script failed.

ERROR A problem occurred with the Vuser. Check the Status field on 
the Vuser dialog box or the output window for a complete 
explanation of the error.

EXITING The Vuser has finished running or has been stopped, and is 
now exiting. 

STOPPED The Vuser stopped when the Stop command was invoked.

Status Description
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Status Summary Description

SCENARIO STATUS indicates whether the scenario is ACTIVE or DOWN

RUNNING VUSERS indicates how many Vusers are being executed on a 
host machine

PASSED TRANSACTIONS indicates how many transactions have been executed 
successfully

FAILED TRANSACTIONS indicates how many transactions have been executed 
unsuccessfully

HITS/SECOND indicates how many hits there have been to the Web site 
being tested per second that each Vuser has been 
running

ERRORS indicates how many problems have occurred with the 
Vusers
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To view details of the transactions and errors:

 1 Click the Show Snapshot button. The Transactions dialog box opens.

The Name column lists the individual transactions in a script. For each 
transaction, the Transactions dialog box lists information concerning the number 
of Transactions Per Second (TPS), the number of transactions Passed, and 
the number of transactions Failed.
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 2 Click the Exclamation Point button.  The Output window opens. 

The Vusers column lists the Vusers that did not execute properly. The Output 
window also lists the time at which the errors occurred, the host machine on 
which the errors took place, and the reason for each error. For more information 
on the Output window, see  see Viewing the Output Window, on page 161.

The Status Bar
At the bottom of the Run view is a Status Bar, where the status of the scenario—
ACTIVE or DOWN—is displayed.  To view the Status Bar, select View > Status Bar.



Executing a Scenario • Viewing Vusers During Execution

Astra LoadTest Controller User’s Guide Chapter 12, page 161

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

Viewing the Output Window

While the scenario runs, the Vusers and hosts send error, notification, and 
warning messages to the Controller. You can view these messages in the Output 
window. Astra LoadTest clears the messages in this window at the start of each 
scenario execution.
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The Output window provides the following scenario information: 

Note: You can limit the number of messages in the output window, and set a 
deletion quota for the number of messages that will be overwritten. For more 
information, see Appendix B, Working in Expert Mode.

Column Description

TIME the time each message arrived

TYPE the type of message sent: Error, Notify, Warning

HOST the Vuser’s host

VUSER the ID of the Vuser that sent the message

MESSAGE - ALL MESSAGES the text of the message
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You can view and manipulate the messages using the following utilities:

• To show (or hide) the Output window choose View > Output. 

• To sort output messages, click the appropriate column header, or right-click 
within the Output window and select Sort Messages.  Choose the method by 
which you want to sort the messages.

• To filter output messages to display only certain message types, choose the type 
of message you want to view in the selector, or right-click within the Output 
window and select Filter Messages. Choose the way in which you want to filter 
the messages.

• To view all of a message’s details, right-click the message and select Details. 

• To save messages, right-click within the Output window and select Export To 
File, or click the Export to File button. 

• To clear scenario execution messages,  right-click within the Output window and 
select Remove All, or click the Remove All button.

• To view more details about a Vuser who sent a message, right-click a message 
and select Vuser Details. 
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• To view the complete Vuser log, right-click a message and select Show Vuser 
Log, or click the Show Vuser Log button. This log contains runtime information 
about the Vuser and is refreshed every 1000 milliseconds. To disable the 
refreshing of this log, clear the Refresh check box. 

• To view a snapshot of the Web page where an error occurred, highlight the error 
in the Vuser Log and click the Show Snapshot button.
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Viewing the Agent Summary

When you run a scenario, the machine running the Vusers invokes an agent that 
controls the Vuser execution on that host. During scenario execution, the agent 
displays a summary of the Ready, Running, and Paused Vusers.

The Agent window comes forward at the start of the scenario, You can minimize 
and restore it at any time.
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Part IV

Monitoring a Scenario
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Online Monitoring

You can monitor scenario execution using the Astra LoadTest online Vuser status, 
transaction, server resource, Web server resource, Web application server 
resource, and database server resource monitors. 

The specific monitors are discussed in the next few chapters. This chapter 
describes the online monitor user interface: 

• Starting the Monitors

• Configuring Online Monitors

• Configuring Online Graphs

• Understanding Online Monitor Graphs

• Configuring Online Measurements

• Exporting Online Monitor Graphs

• Viewing Data Offline
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About Online Monitoring

Astra LoadTest provides the following online monitors:

• Server Resources

• Vuser Status

• Transaction

• Web Server Resources

• Web Application Server Resources

The Server Resource monitor gauges the system resources used during a 
scenario. It is capable of measuring NT and SNMP resources gathered by 
custom monitors. To activate the Server Resource monitor, you must set the 
monitor options before you run your scenario. For information on setting these 
options, see Chapter 15, Resource Monitoring. 

The Vuser Status monitor displays the current states of the Vusers participating 
in the scenario. (READY, RUNNING, etc.) It also provides the Data Point graph that 
displays the real-time values for user-defined points. 

The Transaction monitor displays the transaction rate and response time during 
scenario execution. For more information, see Chapter 14, Runtime and 
Transaction Online Monitors. 
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The Web Server Resource monitor measures statistics at the Web server(s) 
during scenario runs. It provides information about the number of Web 
connections and throughput volume during the scenario, as well as Apache, 
Microsoft IIS, and Netscape servers. To activate the Web Server Resource 
monitor, you must set up a list of resources to monitor before you run your 
scenario. For more information, see Chapter 16, Web Performance Monitors. 

The Web Application Server Resource monitor measures statistics at the Web 
Application Server(s) during the scenario. To activate the Web Application Server 
Resource monitor, you must set up a list of resources to monitor before you run 
your scenario. For more information, see Chapter 16, Web Performance 
Monitors.  

An additional monitor, the Network Delay monitor, displays information about the 
network delays on your system. You can view a summary of the results at the 
conclusion of the scenario. For more information see Chapter 17, Network 
Monitoring. 

All of the monitors allow you to view a summary of the collected data at the 
conclusion of the scenario. Using Astra LoadTest Analysis, you can generate a 
graph for any of the monitors. For more information, see Chapter 18, 
Understanding Astra LoadTest Analysis. 
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Starting the Monitors

You use the online monitors to monitor Vuser status, transactions, server 
resources, Web server resources, and Web application server resources while 
running a scenario.

To start the online monitors:

 1 Start the scenario. Select the Vusers you want to run and choose 
Scenario > Start. 
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 2 Click the Run tab. The default graphs are displayed below the Scenario Groups 
window.

 3 Double-click a graph to maximize it. Repeat the operation to restore the tiled 
view. 



Monitoring a Scenario • Online Monitoring

Astra LoadTest Controller User’s Guide Chapter 13, page 172

In

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

 4 Click the "+" in the left pane to expand the graph tree.

 5 Select a graph from the tree and drag it into the right pane. You can also drag 
graphs between panes.

Note: The Transaction Monitor graphs will not contain any data unless 
transactions are being executed. In addition, the Server Resource Monitor and 
Web Application Server Monitor graphs will not contain any data unless you set 
up a list of resources to monitor before running your scenario. To set up a list of 
resources to monitor, see Chapter 15, Resource Monitoring and Chapter 16, 
Web Performance Monitors. 
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Configuring Online Monitors

Astra LoadTest lets you configure the settings for your online monitors. You can 
set graph measurements and properties. 

Graph properties: refresh rate and graph time for the x-axis. For more 
information, see Viewing Data Offline on page 188.

Measurement settings: line color, scale of the y-axis, and whether to show or 
hide the line. For more information, see Configuring Online Measurements on 
page 180.

When you save a scenario, the online monitor configuration settings are saved as 
well.
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Configuring Online Graphs

You can customize your graph in the following areas:

• refresh rate

• x-axis style

• graph time

Note that these settings can be set globally—to apply to all graphs, or per graph.

Refresh Rate
The refresh rate is the interval in which the graph is refreshed with new data. By 
default, the graph is refreshed every second. If you increase the refresh rate, the 
data is refreshed less frequently. 

X-axis Style
You can specify how the graph displays the x-axis time: Don’t show, Clock time, 
or Relative to Scenario Start. The Don’t Show setting instructs Astra LoadTest 
not to display a name for the x-axis. The Clock Time setting displays the absolute 
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time, based on the system clock. The Relative to Scenario Start displays the 
time relative to the beginning of the scenario. In the following example the graph 
is shown with the Don’t show, and Clock time options:

Graph Time
The Graph Time settings indicate the scale for a graph’s x-axis when it is time-
based. A graph can show 60 or 3600 seconds of activity. To see the graph in 
greater detail, decrease the graph time. To view the performance over a longer 
period of time, increase the graph time. The available graph times are: Whole 
scenario, 60, 180, 600, and 3600 seconds.

Don’t Show Clock time
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To configure graph times:

 1 Select the online graph you want to configure (in either the right or left pane) and 
choose Monitors > Online Graphs > Configure. Alternatively, right-click a 
graph and select Configure. The Graph Configuration dialog box opens.
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 2 To apply the dialog box settings to all graphs, select Apply to all graphs.

 3 Enter the desired refresh rate—the time in seconds between two sequential 
samples—in the Refresh Rate box. 

 4 Select a style for the x-axis from the Time box. 

 5 Select a value from the Graph Time box. The graph time is the time in seconds 
displayed by the x-axis. 

 6 Click OK. 

Understanding Online Monitor Graphs

Online monitor graphs display information about the measurements listed below 
the graph. Each value is represented by a colored line. A legend beneath the 
graph indicates the color and measurement.
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By default, the online monitor displays each measurement—whether Status, 
Transaction, Web Resource, or Server Resource—in a scenario in the legend 
below the graphs. The legend displays the measurements for the selected 
graph.

To get additional information about a measurement right-click the measurement 
and choose Description.

To focus on a particular line, you can: 

• Highlight a measurement: To highlight a specific measurement, select it in the 
legend. The corresponding line in the graph is displayed in blue. 

• Hide a measurement: To hide a measurement, right-click the measurement and 
choose Hide.

To show a hidden measurement, right-click the measurement and choose Show. 

• Pause the monitor: To pause the monitoring of a specific graph during scenario 
execution, select the graph and choose Monitors > Online Graph > Freeze or 
right-click the graph and select Freeze. To resume, repeat one of the above 
actions. When you resume, the graph displays the data for the paused period.
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Configuring Online Measurements

You can configure the following online measurement settings: 

• line color

• scale

• show/hide

Changing Line Colors
Astra LoadTest assigns a unique color to each measurement. You can modify the 
color using the configuration interface. 

Setting the Scale of the Measurement
You can modify the scale of a measurement—the relationship between the y-axis 
and the graph’s actual value. For example, a scale set at 1 indicates that the 
measurement’s value is the value of the y-axis. If you choose a scale of 10, you 
must divide the y-axis value by 10 to obtain the true value of the measurement. 
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In the following example, the same graph is displayed with a scale of 1 and 10. 

The actual graph values range from 0-1, as shown in the left graph. You can 
view the information more accurately using a larger scale for the display, as 
shown in the right graph. However, to obtain the actual values, you need to 
divide the displayed value by the scale. In the example above, the highest value 
shown in the graph is 5. Since the scale is 10, the actual value is 0.5. 

scale = 1 scale = 10
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The legend below the graph indicates the scale factor.

By default, Astra LoadTest uses the autoscale option, which automatically scales 
the measurements by calculating the best ratio for displaying the graph.

Showing and Hiding Transactions
By default, the Transaction Monitor displays a line for each item in the transaction 
list. You can hide the line for any of the monitored transactions in order to focus 
on a specific measurement.

scale 
factor
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In the following example, a line is shown for each measurement.
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In this example, the second item in the legend is hidden.
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To configure a measurement:

 1 In the legend below the graphs, select the measurement you want to configure. 
Right-click and choose Configure. The Measurement Configuration dialog box 
opens. 

 2 To change the color of the line, select a color from the Color list.

 3 To change the scale, clear the Autoscale check box and select the desired ratio 
from the Scale list. 
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 4 To hide a measurement, click Hide. To show a hidden resource click Show. 

Note that you can also show and hide measurements without opening the 
Measurement Configuration dialog box by right-clicking a measurement in the 
legend and selecting Show/Hide. 

 5 Click OK to accept the settings and close the dialog box. 

The specified changes are reflected in the graph and in the legend beneath the 
graph. The color is displayed in the first column of the legend. Hidden 
transactions are displayed as unfilled boxes. The scale is displayed in the 
legend’s second column.
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Exporting Online Monitor Graphs

Astra LoadTest allows you to export the online graph to HTML for viewing at a 
later stage. When you export to HTML, the legend is also displayed with the 
graph. You can export all graphs or only the selected one.

To export online graphs to HTML:

 1 To export a specific graph, select the graph you want to export and choose 
Monitors > Online Graphs > Export to HTML. The Select Filename and Path 
dialog box opens.

 2 To export all graphs in the Online Monitor view, choose Monitors > Export 
Online Graphs to HTML. The Select Filename and Path dialog box opens.

 3 Specify a filename and path and click Save.
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Viewing Data Offline

After monitoring resources during a scenario run, you can view a graph of the data 
that was gathered using the Astra LoadTest Analysis. When you run the Analysis 
utility, it processes the data and generates a graph for each measurement that 
was monitored. 

To view a graph, choose Graph > Add Graph in the Analysis window and select 
the Resource Usage graph in the System Resources category. For more 
information about working with the Astra LoadTest Analysis at the conclusion of 
the scenario, see Chapter 18, Understanding Astra LoadTest Analysis. 
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Runtime and Transaction Online Monitors 

While running a scenario, you can use Astra LoadTest’s online monitors to view 
graphs of runtime status and transaction performance.

This chapter describes:

• Runtime Graphs

• User-Defined Data Point Graph

• Transaction Monitor Graphs

• Adding Transactions to a Script
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About Online Graphs

Astra LoadTest’s online monitor lets you view Vuser performance during scenario 
execution. You can view the current Vuser status, transaction rate and response 
time, server resource information, and Web server and Web application server 
statistical information. For information about monitoring server resources, see 
Chapter 15, Resource Monitoring.  For information regarding Web server 
resource and Web application server resource monitoring, see Chapter 16, Web 
Performance Monitors. 

The Runtime monitor provides information about the current state of the Vusers 
participating in a scenario. It also provides the Data Point graph that displays the 
real time values for user- defined points. 

The Transaction monitor displays the transaction rate and response time during 
scenario execution. For more information about transactions, see Adding 
Transactions to a Script on page 194.

Once the scenario finishes execution, you can use the Astra LoadTest Analysis 
to view summary graphs of all the data collected during execution. For more 
information, see Chapter 18, Understanding Astra LoadTest Analysis. 



Monitoring a Scenario • Runtime and Transaction Online Monitors

Astra LoadTest Controller User’s Guide Chapter 14, page 191

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

Runtime Graphs

The monitor’s Runtime graph provides information about the status of the Vusers 
running in the current scenario on all host machines. The graph shows the 
number of running Vusers, while the information in the legend indicates the 
number of Vusers in each state.

The Status field of each Vuser displays the current status of the Vuser. The 
following table describes each Vuser status.

Status Description

RUNNING The total number of Vusers currently running on all hosts.

READY
The number of Vusers that completed the initialization section 
of the script and are ready to run.

FINISHED
The number of Vusers that have finished running. This 
includes both Vusers that passed and failed.

ERROR
The number of Vusers whose execution generated an error. 
Check the Status field in the Vuser view or the Output window 
for a complete explanation of the error.
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User-Defined Data Point Graph

The User-Defined Data Point graph displays the real-time values of user-defined 
data points. User data points are represented by lr_user_data_point functions in 
the Vuser script. For further information about this function, see the Astra 
LoadTest Online Function Reference.

By default, Astra LoadTest displays all of the data points in a single graph. The 
legend provides information about each data point. If desired, you can hide 
specific data points using the legend below the graphs. 

You can also view data points offline, after the completion of the scenario. For 
more information, see Chapter 21, Analyzing Scenario Performance. 

Action1()
{

lr_think_time(1);
lr_user_data_point ("data_point_1",1);
lr_user_data_point ("data_point_2",2);
return 0;

}
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Transaction Monitor Graphs

The Transaction monitor provides the following graphs:

• Transaction Response Time 

• Transaction per Second (Passed) 

• Transaction per Second (Failed) 

The Transaction Response time graph shows the response time of 
transactions in seconds (y-axis) as a function of the elapsed time in the scenario 
(x-axis). 

The Transaction per Second (Passed) graph shows the number of successful 
transactions performed per second (y-axis) as a function of the elapsed time in 
the scenario (x-axis). 

The Transaction per Second (Failed) graph shows the number of failed 
transactions per second (y-axis) as a function of the elapsed time in the scenario 
(x-axis). 
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Adding Transactions to a Script

If there are no transactions defined in your Vuser script, no data will be displayed 
in the online graphs. To add transactions to an existing script, edit it using the 
Virtual User Recorder.

To add a transaction to a script:

 1 Click the Scripts tab to view the script list.

 2 Select the script you want to edit.

 3 Choose Script > Edit script to open the script generation tool.

 4 Insert Start and End Transaction functions or markers throughout your script.

For more information, see the appropriate user’s guide as described in the 
Welcome chapter.



Monitoring a Scenario
Resource Monitoring

Astra LoadTest Controller User’s Guide Chapter 15, page 195

In

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

��
Resource Monitoring

You can monitor a machine’s resource usage during a scenario run, using Astra 
LoadTest’s Server Resource monitor. After the scenario run, you view the results 
in an offline graph. 

This chapter describes:

• Creating a Measurement List

About Resource Monitoring

A primary factor in a transaction’s response time is its resource usage. By 
monitoring resources during a scenario run, you can determine why a bottleneck 
occurred on a particular machine. The Astra LoadTest Resource monitor lets you 
keep track of resources used during a scenario. During test execution, Astra 
LoadTest displays a graph display of the resource usage in real-time. 

You can monitor the NT or SNMP resources on a machine. The NT 
measurements correspond to the built-in counters available from the NT 
Performance Monitor. 

The SNMP monitor is available for monitoring machines using the Simple 
Network Management Protocol (SNMP). 
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You can also monitor Web server resources and Web application server 
resources. After you understand the basic procedure for creating a 
measurements list, see Chapter 16, Web Performance Monitors for additional 
details about monitoring Web resources. 

A description of each measurement appears in the Resource Monitors 
Description box when you highlight the measurement.

For information on  configuring monitor graphs, see Chapter 13, Online 
Monitoring. 

Creating a Measurement List

The resource monitor is automatically enabled when you execute a scenario. 
However, you must specify the host you want to monitor and which resources to 
monitor for each host. You can also add or remove hosts and resources during 
the scenario run. 

To set up a list of resources to monitor:

 1 Select the graph whose resource list you want to create from the online monitor 
tree view.
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 2 Choose Monitors > Add Online Measurement. The Server Resource 
Monitoring dialog box opens. 
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 3 Click Add... in the Monitored Server Machines section to add the host you 
want to monitor. The Add Machine dialog box opens. 

 4 Type a machine name and select a platform. Click OK to accept the settings and 
close the dialog box. 

 5 To delete a machine from the list (entered for a prior scenario), select it and click 
Delete. 

 6 Click Add in the Measurements section to display a list of available resources 
that can be monitored. The appropriate dialog box opens (NT Resources, 
SNMP) 



Monitoring a Scenario • Resource Monitoring

Astra LoadTest Controller User’s Guide Chapter 15, page 199

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

 7 For NT resources, select an object, counter, and instance. You can select 
multiple counters using the CTRL key. The instance is relevant only if multiple 
instances of the highlighted counter are running. For a description of each 
counter, click Explain>> to expand the dialog box. 

Click Add to place the selected counter on the resource list. Add all the desired 
resources to the list and then click Close. 
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 8 To add SNMP resources to the monitor list, select an SNMP resource from the 
Object list. For a description of each resource, click Explain>> to expand the 
dialog box. Click Add to place the selected item on the resource list. Add all the 
desired items to the list and then click Close.

 9 Repeat the above procedure for each machine you want to monitor. 

 10 Click OK to begin monitoring resources. 

You can modify the list of resources that you want to monitor at any point during 
the scenario. Note that a scenario does not have to be active in order for you to 
monitor the resources on a remote machine.
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��
Web Performance Monitors

The Web performance monitors aid in Web server and Web application server 
performance bottleneck isolation. The interface to Astra LoadTest’s Web 
performance monitors is similar for the various monitor types. 

This chapter describes:

• Web Server Resource Monitors

• Activating the Monitors

• Configuring the Monitors

• Troubleshooting the Monitors
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About Web Performance Monitors

There are two sets of monitors: Web server resource monitors and Web 
application server resource monitors. 

Web Server Resource Monitors 

Astra LoadTest supports the following Web server versions:

• Microsoft Information Internet Service (IIS) 4.0

• Netscape Enterprise Server 3.6

• Apache 1.3.9

Web Application Server Resource Monitors

Astra LoadTest supports the following Web application server versions:

• Microsoft Active Server Pages (ASP)

• BroadVision 4.1

• ColdFusion 4.5

• SilverStream 2.5

• WebLogic 5.0 (currently in beta)
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Web Server Resource Monitors

The Web Server Resource monitor provides the following Web graphs:

• Hits Per Second

• Throughput 

• Apache Server

• Microsoft IIS Server

• Netscape Server

The Hits Per Second graph shows the number of hits on the Web server (y-
axis) as a function of the elapsed time in the scenario (x-axis). This graph can 
display the whole scenario, or the last 60, 180, 600, or 3600 seconds. You can 
compare this graph to the Transaction Response Time graph to see how the 
number of hits affects transaction performance. 

The Throughput graph shows the amount of throughput on the Web server 
(y-axis) during each second of the scenario run (x-axis). Throughput is measured 
in kilobytes and represents the amount of data that the Vusers received from the 
server at any given second. You can compare this graph to the Transaction 
Response Time graph to see how the throughput affects transaction 
performance.
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In the following example, the Transaction Response time graph is compared with 
the Throughput graph. It is apparent from the graph that as the throughput 
increases, the transaction response time also increases. The peak throughput 
occurred at approximately 1 minute into the scenario. The highest response time 
also occurred at this time.
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The Apache Server Resource monitor measures statistics at the Apache server 
during scenario execution. For more information about the Apache Server 
Resource monitor, see the following sections of this chapter.

The Microsoft IIS Resource monitor measures statistics at the Microsoft IIS 
server during scenario execution. For more information about the Microsoft IIS 
Resource monitor, see the following sections of this chapter.

The Netscape Server Resource monitor measures statistics at the Netscape 
server during scenario execution. For more information about the Netscape 
Server Resource monitor, see the following sections of this chapter.
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Activating the Monitors

The Web performance monitors are not automatically activated when you begin 
running a scenario. In order to use these monitors, you must first activate them.

To activate the Web performance monitors from the Controller: 

 1 Click the Online Monitors tab to open the Online Monitor view.

 2 Click on a Web server graph in the tree and drag it into the right pane. 

 3 Right-click the graph and choose Add, or choose Monitors > Add Online 
Measurement. 

The procedures for selecting monitor measurements and configuring the 
monitors vary according to server type. Refer to the next section, Configuring 
the Monitors for specific instructions.
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Configuring the Monitors

Each of the sections below describes the configuration settings and limitations for 
a specific Web server monitor.

Apache Monitor
To monitor an Apache server you need to know the server statistics information 
URL. A simple way to verify the statistics information URL is to try to view it 
through the browser.

The URL should be in the following format: 

http://<server_name/IP address>:port/server-status?auto

For example: 

http://stimpy:80/server-status?auto

To activate the online Apache monitor from the Controller:

 1 Right-click the graph and choose Add, or choose Monitors > Add Online 
Measurement. 

 2 Enter the server name or IP address.

 3 In the Resource Measurements section, click Add.. to select the measurements 
that you want to monitor.
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The Apache dialog box displays the available measurements and server 
properties.

 4 Highlight the required measurements.

 5 In the Server Properties section, enter the Port number and URL (without the 
server name). The default URL is /server-status?auto.

 6 Click OK to activate the monitor.
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Note: The default port number and URL can vary from one server to another. 
Please consult your Web server administrator. 

To change the default server properties:

 1 Open the Apache.cfg file in the <ALT installation dir>\dat\ monitors\ directory. 

 2 Edit the following parameters after the Delimiter=: statement:

InfoURL server statistics information URL

ServerPort server port number 

SamplingRate rate (milliseconds) at which the Astra LoadTest monitor 
will poll the server for the statistics information. If this 
value is greater than 1000,  Astra LoadTest will use it as 
its sampling rate. Otherwise, it will use the sampling rate 
defined in the Online Monitors UI.
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Netscape Monitor
To monitor a Netscape server, you need to know the server statistics information 
URL. A simple way to verify the statistics information URL, is to try to view it 
through the browser.

The URL should be in the following format: 

http://<srv_name/IP addr>:port/https-<srv_name/IP addr>/bin/sitemon?doit

for example: 

http://lazarus:80/https-lazarus/bin/sitemon?doit

Note: In some server configurations, the URL must contain the server name and 
not the IP address.

To activate the Netscape monitor from the Controller:

 1 Right-click the graph and choose Add, or choose Monitors > Add Online 
Measurement. 

 2 Enter the server name or IP address.

 3 In the Resource Measurements section, click Add.. to select the 
measurements that you want to monitor.
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The Netscape dialog box displays the available measurements and server 
properties:

 4 Highlight the required measurements.
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 5 Fill in the Server Properties:

• Enter the user login name and password. The user must have administrator 
permissions on the server. 

• Enter the port number and URL (without the server name). The default URL is 
/https-<server>/bin/sitemon?doit. 

 6 Click OK to activate the monitor.

Note: The default port number and URL can vary from one server to another. 
Please consult the Web server administrator. In some server configurations, the 
URL must contain the server name and not the IP address.

To change the default server properties: 

 1 Open the netscape.cfg file in the <ALT installation dir>\dat\ monitors\ directory. 

 2 Edit the following parameters in the [Netscape] section:

Counters number of counters that the  Astra LoadTest Netscape 
monitor will show you. This value should match the 
number of counters defined in the file.

InfoURL server statistics information URL

ServerPort server port number 
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ServerLogin login name to the server

ServerPassword login password for the login name

SamplingRate rate (milliseconds) at which the  Astra LoadTest monitor 
will poll the server for the statistics information. If this 
value is greater than 1000,  Astra LoadTest will use it as 
its sampling rate. Otherwise, it will use the sampling rate 
defined in the Online Monitors UI.

SilverStream Monitor
To monitor a SilverStream server you need to know the server statistics 
information URL. A simple way to verify the statistics URL is to access it from a 
browser.

The URL should be in the following format: 

http://<srv_name/IP addr>[:#port]/SilverStream/Statistics

for example:

http://199.203.78.57:80/SilverStream/Statistics

To activate the SilverStream monitor from the Controller:

 1 Right-click the graph and choose Add, or choose Monitors > Add Online 
Measurement. 
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 2 Enter the server name or IP address (platform is detected automatically).

 3 In the Resource Measurements section, click Add.. to select the 
measurements that you want to monitor.

The SilverStream dialog box displays the available measurements and server 
properties:

 4 Highlight the required measurements.
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 5 In the Server Properties section, enter the port number and URL (without the 
server name). The default URL is /SilverStream/Statistics.

 6 Click OK to activate the monitor.

Note: The default port number and URL can vary from one server to another. 
Please consult the Web server administrator.

To change the default server properties:

 1 Open the SilverStream.cfg file in the <ALT installation dir>\dat\ monitors\ 
directory. 

 2 Edit the following parameters at the end of the file:

InfoURL server statistics information URL.

ServerPort server port number 

SamplingRate rate (milliseconds) at which the  Astra LoadTest monitor 
will poll the server for the statistics information. If this 
value is greater than 1000,  Astra LoadTest will use it as 
its sampling rate. Otherwise, it will use the sampling rate 
defined in the Online Monitors UI.
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BroadVision Monitor
To monitor a BroadVision Server, you need to have JDK 1.2 or higher installed on 
the Controller machine. 

You can install JDK 1.2 by following the download and installation instructions at 
the following website: http://java.sun.com/products/jdk/1.2/

Before activating the monitor, make sure that your Java environment is configured 
properly. 

To configure your Java environment:

 1 Open the Windows Registry.

 2 The registry should contain the correct path to the Java executable (java.exe) 
under the JDK 1.2 installation directory. Verify the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVer
sion\App Paths\java.exe

 3 The registry should contain the correct path to the Java runtime environment 
(JRE) under the JRE 1.2 installation directory. Verify the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime 
Environment\1.2\JavaHome
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To activate the BroadVision online monitor from the Controller:

 1 Right-click the graph and choose Add, or choose Monitors > Add Online 
Measurement. 

 2 Enter the server name or IP address with the port number according to the 
following format: server_name:port_number.

For example: dnsqa:1221. The platform is detected automatically.
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The BroadVision Monitor Configuration dialog box displays the available 
measurements: 

 3 Check the required performance counters in the BroadVision Monitor 
Configuration window’s right pane. Click OK.
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ColdFusion Monitor
To monitor the ColdFusion application server, you need to know its IP address.

To activate the ColdFusion monitor from the Controller:

 1 Right-click the graph and choose Add, or choose Monitors > Add Online 
Measurement. 

 2 Enter the server name or IP address (the platform is detected automatically).

The ColdFusion dialog box displays the default measurements to monitor:
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 3 Highlight the required measurements.

 4 Click OK to activate the monitor.

WebLogic Monitor
The WebLogic monitor uses SNMP to retrieve server statistics. To use this 
monitor, you must make sure that the WebLogic SNMP agent is installed and 
activated on the server.

To activate the WebLogic monitor from the Controller:

 1 Right-click the graph and choose Add, or choose Monitors > Add Online 
Measurement. 

 2 Enter the server name or IP address (the platform is detected automatically).

 3 In the Resource Measurements section, click Add.. to select the 
measurements that you want to monitor.
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 4 The WebLogic Resources dialog box displays the available measurements:

 5 Browse the WebLogic Object tree.

 6 Click Add to include more objects to be measured.

 7 After selecting and adding the required objects, click Close.
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Troubleshooting the Monitors

Setting Permissions for NT Monitoring
When you monitor NT servers and the following types of Web servers: MS IIS, MS 
ASP and ColdFusion, the monitored machine requires permission settings for NT 
monitoring. You may receive a message about failure to connect to a machine. 
Use the following guidelines to make sure that you can access the monitored 
machine.

Cannot connect to an NT machine on a different NT-domain:

Ensure that you can log in to the other domain. The login name used for the 
Controller machine should also have an account on the monitored machine’s 
domain.

Cannot monitor an NT machine on the same or different domain:

This means that the NT machine enables monitoring only for users with 
administrative permissions. To allow monitoring for non-admin users, you must 
give read permission to several files and registry entries (Microsoft tech-note 
number Q158438).
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 1 Using Explorer or File Manager, give the user at least read permission to 
%windir%\system32\PERFCxxx.DAT and 
%windir%\system32\PERFHxxx.DAT

where xxx is the basic language ID for the system (for example, 009 for English). 
These files may be missing or corrupted. If you suspect this, copy these files 
from the installation CD.

 2 Open the registry editor (Start Menu>run…>, 
REGEDT32>Security>Permissions…) 

 3 Give the user read permission to
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows 
NT\CurrentVersion\Perflib 

and all sub-keys of that key.

 4 Give the user read permission to
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\SecurePi
peServers\win reg
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Network Monitoring

You can use Network graphs to determine whether your network is causing a 
delay in the scenario. You can also determine the problematic network node. 

This chapter describes:

• Network Monitor Graphs

• Determining Bottlenecks through Network Monitoring

• Configuring the Network Monitor

• Setting the Network Monitor

• Opening Network Monitor Graphs
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About Network Monitoring

Network configuration is a primary factor in the performance of applications and 
web systems. A poorly designed network can slow client activity to unacceptable 
levels. 

In an application, there are many network segments. A single network segment 
with poor performance, can affect the entire system.

The following diagram shows a typical network. In order to go from the database 
server machine to the Vuser machine, data must travel over several segments. 
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You can use the Astra LoadTest Network monitoring to determine which network 
segment is causing the delay. Once you determine this, you can concentrate on 
improving the problematic segment.

In order to monitor a scenario’s network activity, you must enable Network 
monitoring and specify the path to monitor, before running the scenario. The 
monitor records the network activity on all of the segments of the specified path. 

Network Monitor Graphs

The Network monitor provides two types of graphs that display the information 
collected by the Network monitor:

• Network Monitor Graph

• Network Monitor Segment Graph

Network Monitor Graph

The Network Monitor graph shows the delays for the complete path between 
the source and destination machines (for example the database server and 
Vuser host). The graph maps the delay as a function of the elapsed scenario 
time. 

Each path defined in the Controller is represented by a line in the graph. 
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The following graph shows the path between the twilight source machine and 
www.merc-int.com. It shows a delay of 4,600 milliseconds in the 105th second of 
the scenario. 

Network Monitor Segment Graph

The Segment Delay graph shows the delay for each segment of the path 
according to the elapsed scenario time. 
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The title bar indicates the full network path. The individual segment names are 
indicated by their source and destination nodes. The source node is displayed 
without a domain. 

In the following example, there are five segments, but two of them are filtered out. 
The graph displays only three segments. The 
gip-sl-penn-fddi segment caused a delay of 4 seconds in the 160th second. 
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Determining Bottlenecks through Network Monitoring

You can use the Network Monitor to:

• determine whether the network is the bottleneck

• determine the bad segment, if you already know that the Network is the 
bottleneck. 

Verifying the Network as a Bottleneck
You can use the Network Monitor graphs to determine if the network is a 
bottleneck using the Timeouts and Path Delay Under Load graphs. 

The Timeout Count graph indicates loss of data and multiple retries. The 
Network Monitor checks network performance by sending packets of information 
over the network. If a packet does not return within a specified period, a timeout 
signal is generated. All of the timeouts that occurred during a scenario are 
displayed in the Timeouts graph. Multiple timeouts show that the network is 
overloaded. For information on setting the timeout period, see Configuring the 
Network Monitor on page 231.

The Path Delay Under Load graph shows the path delay relative to the number 
of running Vusers. If the delay increases (in a higher range than the increase of 
transaction time) with the number of running Vusers, the network is overloaded. 
However, if the network delay remains constant, but the transaction time 
increases, the problem lies in a different component of the transaction. 
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Determining the Problem Segment
When you perform Network monitoring, each node, or segment, is represented 
by a unique color in the graph. The problematic nodes are easily distinguishable.

In the above example, the gip-sl-penn-fddi node caused the primary delay. 
Fixing or bypassing this node would improve the network performance and 
overall response time.
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Configuring the Network Monitor

To measure performance, the Network monitor sends packets of data across the 
network. When a packet returns, the monitor calculates the time it takes for the 
packet to go to the requested node and return. This time is the delay which 
appears on the Network Delay graphs.

Before Astra LoadTest loads the network, it performs a calibration phase to 
determine the network delay at non-load condition. The monitor performs several 
iterations during which it sends packets across the network. It uses this 
information to map the segments between the source and target node. 

You can configure the monitoring scheme variables to influence the network 
behavior from the Network Monitor Configuration dialog box. To open the dialog 
box, click Configure from the main Network Monitor dialog box. 
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The Monitoring Scheme contains information about the packet sent across the 
network. 

The Packet Size is the size in bytes for each packet of data sent across the 
network. 

Wait Between Iterations indicates the time between two consecutive packets. 
The default value for "Wait Between Iterations" is 1000 milliseconds, or one 
second. If you have a long steady scenario, you can increase the interval by 
several seconds.

Packet Roundtrip Timeout is the total time allotted for the packet to return to the 
monitor. If a packet does not return within the timeout period, it is considered not 
to have returned. The timeout data appears in the Timeouts graph. The Packet 
Roundtrip Interval default value is 4 seconds. If your network is very large and 
loaded (an internet connection with a low capacity), you should increase the value 
by several seconds. If you have a small network (such as a LAN), you can 
decrease the value. To determine the appropriate value, check the packet 
response time on the path-delay graph and note the response time. If it is much 
lower than 4, lower the interval default. If it higher than 4, increase the default 
value. 

The Controller waits until the calibration is finished before running Vusers. During 
calibration, the Controller displays a dialog box indicating the status of the 
Network monitor. To allow Vusers to run before the completion of the initial 
calibration, click Don’t Wait in the dialog box.
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Setting the Network Monitor

You set up the Network monitor from the Controller before you begin a scenario. 
You select the machines to monitor. 

Note that the Network Monitor requires its own license. If the Network Delay 
option does not appear in the Monitor menu, you must enter a new license code 
to include it. You can enter a new license code from the Help > About menu. For 
information on upgrading a license, see the Astra LoadTest Installation Guide.

To set up the Network Monitor:

 1 Choose Monitor > Offline Monitors > Network Delay. The Network Monitoring 
dialog box opens.
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 2 Select the Enable Network Delay Monitoring check box. 

 3 Click Add. The Network Path dialog box opens. 
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 4 Enter the name of the remote machine running the Vusers and its platform. Make 
sure that the machine has an Astra LoadTest agent installed.

 5 Enter the name of the server machine. 

 6 Click OK. The names of the remote and server machines are listed in the 
Network Monitoring dialog box. 

 7 Repeat steps 3-6 for each path you want to monitor. 

 8 To configure the monitor’s settings, click Configure in the Network Monitoring 
dialog box. The Network Monitor Configuration dialog box opens. 

 9 Modify the Monitoring Scheme and click OK. Note that these configuration 
settings apply to all network paths. For information about these settings, see 
Configuring the Network Monitor on page 231.

 10 Click OK to accept the settings and close the Network Monitoring dialog box. 

 11 Run the scenario, and open the Network Monitor graphs.
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Opening Network Monitor Graphs

In order to view the Network monitor graphs, make sure to enable network 
monitoring before running a scenario. For more information, see Setting the 
Network Monitor on page 233.

To view the Network Monitor graphs:

 1 Run a scenario.

 2 If Auto Load Analysis is disabled, click Results > Analyze Results to open the 
Astra LoadTest Analysis.

 3 Open the desired Network graph—either a specific segment or the entire path. 
Choose Graph > Add Graph and choose the appropriate graph from the Add 
Graph dialog box. A separate graph is available for each segment and path that 
you indicated earlier in the monitor settings.
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 4 View the graph and determine the problematic node. In the following graph the 
problematic node is the one peaking at 4000 milliseconds—
gip-sl-penn-fddi.

 5 Perform the necessary operations such as modifying the application, upgrading, 
or bypassing the node.

 6 Repeat steps 1-5 until the network results are satisfactory.

Note: Dynamic paths are not supported; if the path changes after the start of the 
scenario, it is not shown in the Network Monitor graphs. 
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Part V

Analyzing Test Results
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��
Understanding Astra LoadTest Analysis

After running a scenario, you can use Astra LoadTest’s graphs and reports to 
analyze the performance of your application. 

This chapter describes:

• Starting the Analysis

• Collating Execution Results

• Viewing a Part of the Scenario

• Working with Analysis Graphs

• Working with Analysis Reports

• Spreadsheet and Raw Data Views
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About Astra LoadTest Analysis

During scenario execution, Vusers generate result data as they perform their 
transactions. To monitor the scenario performance during test execution, use the 
Online analysis (See Chapter 14, Runtime and Transaction Online Monitors. )

After running a scenario, you can view a summary of the results to determine how 
your system performed. You can view the results in several ways:

• The Vuser output file, output.txt, contains a full trace of the scenario run for 
each Vuser. This file is located in the scenario results directory. (When you 
run a Vuser script in standalone mode, this file is placed in the Vuser script 
directory.) For more information on Vuser output files, refer to the Virtual User 
Recorder guide.

• The Controller Output window displays information about the scenario run. 
If your scenario run fails, look for debug information in this window. For more 
information, see Chapter 11, Running a Scenario. 

• The Analysis graphs and reports provide information about transactions 
and Vusers that can be used to determine system performance. You can 
study individual graphs or you can compare graphs from several scenarios 
using Cross-Scenario analysis. 

• The Spreadsheet and Raw Data views display the actual data used to 
generate the graph in a spreadsheet format.
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• The Export data utility enables you to export scenario results to text or 
database files for use with external applications such as spreadsheet 
programs. 

This chapter discusses the graphs, reports, and the data exporting utility. 

Starting the Analysis

The Analysis is the Astra LoadTest component that processes results gathered 
during a scenario execution and generates graphs and reports. You can open the 
Analysis through the Astra LoadTest program group or directly from the 
Controller. 

When you open the Analysis as an independent application from the program 
group, you select a Astra LoadTest Results (.lrr) file. The Analysis processes the 
data and automatically displays the Percentile graph. This graph indicates the 
percentage of transactions completed with a given response time. 

To open the Analysis directly from the Controller, select Results > Analyze 
Results. This option is only available after running a scenario. It automatically 
takes the latest result file from the current scenario, and opens it. You can also 
instruct Astra LoadTest to automatically open the Analysis after it completes 
scenario execution by selecting Auto Load Analysis. To enable automatic 
analysis, select Results > Auto Load Analysis.
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Collating Execution Results

When you run a scenario, by default all Vuser information is stored locally on each 
Vuser host. After scenario execution the results are automatically collated or 
consolidated—results from all of the hosts are transferred to the results directory. 
To disable automatic collation, choose Results > Auto Collate Results to clear 
the check mark adjacent to the option. To manually collate results, choose 
Results > Collate Results. If your results have not been collated, Astra LoadTest 
Analysis will automatically collate the results before generating the analysis data. 
For more information about collating results, see Chapter 11, Running a 
Scenario. 
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Analysis Graphs and Reports

Astra LoadTest’s graphs and reports are divided into the following categories:

• Activity 

• Performance 

• Web 

Activity graphs and reports provide information about the number of Vusers and 
the number of transactions executed during the scenario run. For more 
information, see Chapter 20, Analyzing Scenario Activity. 

Performance graphs and reports analyze Vuser performance and transaction 
times. For more information, see Chapter 21, Analyzing Scenario 
Performance. 

Web graphs provide information about the throughput and hits of Web Vusers. 
For more information see Chapter 23, Web Vuser Graphs. 

Astra LoadTest cross-scenario analysis lets you compare the graphs from several 
scenarios. For example, this feature can be useful for benchmarking hardware to 
determine how a superior system will improve performance. For more 
information, see Chapter 22, Cross-Scenario Analysis. 

The following tables shows the available graphs and reports. Several graphs 
allow you to display their raw data (see Spreadsheet and Raw Data Views on 
page 260).
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Activity Graphs and Reports 

Name Graph Report Raw 
Data

Cross
Scenario

Description

Running 
Virtual Users

✓  ✓  The number of 
Running Vusers at 
any moment

Rendezvous ✓  3  ✓  Rendezvous data: 
The number of 
arrived members, 
etc. 

Transactions 
per Second 
(Pass/Fail)

✓  3 ✓  The number of 
transactions 
executed per second

Scenario 
Execution

3  ✓  Detailed scenario 
information for each 
Vuser
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Performance Graphs and Reports

Name Graph Report Raw 
Data

Cross
Scenario

Description

Data Point ✓  ✓  3 ✓  The performance of an 
external utility

Percentile ✓  ✓  The percentage of 
transactions 
performed within a 
given time range

Performance 
Under Load

✓  ✓  ✓  The transaction 
response time 
according to the 
number of running 
Vusers

Transaction 
Performance

✓  ✓ * 3 ✓  The transaction 
response time as a 
function of the elapsed 
scenario time

Transaction 
Performance 
Summary

✓  ✓  ✓  The minimum, 
maximum, and 
average transaction 
time 
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* The report is titled Detailed Transactions.

Web Graphs

Transaction 
Performance 
Summary by 
Vuser

✓  ✓  ✓  The minimum, 
maximum, and 
average transaction 
times for each Vuser

Transaction 
Distribution

✓  3 ✓  The distribution of 
time for transaction 
executions

Name Graph Repor
t

Raw 
Data

Cross
Scenari
o

Description

Hits per 
second

✓  3 3 The number of Web 
server hits per second

Throughout ✓  3 3 The number of kilobytes 
transferred per second

Name Graph Report Raw 
Data

Cross
Scenario

Description
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Viewing a Part of the Scenario

You can instruct Astra LoadTest to calculate graphs and reports based on a part 
of the scenario. For example, if you have a scenario with a duration of 400 
seconds, but you are only interested in the period beginning at 60 and ending with 
360 seconds, you specify that interval in the Time Filter dialog box. After setting 
the time filter, you must rebuild the result database in order for the changes to take 
effect. All subsequently generated graphs and reports are calculated using data 
only from the specified interval. 

To filter the scenario time:

 1 Choose Options > Time Filter in the Analysis window. The Time Filter dialog 
box opens.
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 2 Enter the desired time interval. 

 3 Click OK to accept the settings. 

 4 Choose File > Open (Rebuild). 

Working with Analysis Graphs

You generate graphs in the Analysis window by selecting the desired graphs from 
the Graph menu. For information about the available graphs, see Chapter 20, 
Analyzing Scenario Activity and Chapter 21, Analyzing Scenario 
Performance.  

Astra LoadTest also provides tools which enable you to modify the way that 
graphs are displayed. For each graph you can:

• filter specific transactions and Vusers

• enlarge a section of the graph

• change the interval of the x-axis
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Viewing Specific Transactions and Vusers
When you generate a graph, the graph initially includes all the transactions in the 
scenario. You can filter the graph to display one or more specific transactions. For 
example, if three transactions were monitored during a scenario, you can 
generate a graph that displays only one of the transactions. 

By default, the Transaction Performance and Transaction per Second graphs 
display all the transactions, while the Transaction Performance Summary and 
Transaction Distribution graphs display only the first transaction. 

To select transactions and Vusers to display:

 1 In the Analysis window, choose File > Open to open the desired results file (if it 
is not already open). The Percentile graph is displayed. 

 2 Select a graph from the Graphs menu. The graph is displayed. You can display 
multiple copies of the same graph.
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 3 Select View > Filter, or click the Graphic Filters button. 

 4 Select the transactions that you want to include in the graph. Use the CTRL key to 
select multiple transactions. 



Analyzing Test Results • Understanding Astra LoadTest Analysis

Astra LoadTest Controller User’s Guide Chapter 18, page 251

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

For graphs that show individual Vuser performance, such as Transaction 
Performance Summary by Vuser graph, you can filter the graphs to display 
information for a single Vuser. Click the Group and Vuser tab and select the 
Vuser that you want to display.

 5 Click OK. The Filter dialog box closes. The graph appears and displays the 
selected transactions or Vusers. 
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Using Location Lines
To determine the precise value of a point in a graph, you can use location lines. 
When location lines are enabled, a vertical and horizontal line (parallel to each of 
the axes) are displayed in the graph.

To enable location lines, choose View > Location lines in the Analysis window. 
Click on the point within your graph whose coordinates you want to determine. 
Note that even when you disable location lines, the coordinates of the cursor are 
displayed on each axis. 

Enlarging a Section of a Graph 
Graphs initially display data representing the entire duration of the scenario. You 
can enlarge any section of a graph to focus on a specific period in the scenario 
run. For example, if a scenario ran for ten minutes, you can enlarge and focus on 
the scenario events that occurred between the second and the fifth minutes. You 
can enlarge graphs using the mouse, or the Zoom In command.

To enlarge a section of a graph using the mouse:

 1 Select a graph from the Graphs menu. The graph is displayed.

 2 Move the mouse pointer to the beginning of the section that you want to enlarge.

 3 Hold down the left mouse button. A vertical bar appears on the x-axis. This 
marks the first boundary of the section to enlarge.
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 4 While holding down the left mouse button, move the mouse to the left or right of 
the vertical bar. A second vertical bar appears. This marks the second boundary 
of the section to enlarge.

 5 Release the left mouse button. The section is enlarged.

 6 Click the right mouse button to return the graph to its original size.

To enlarge a section of a graph using the Zoom In command:

 1 Select a graph from the Graphs menu. 

 2 Select View > Zoom In, or click the Zoom button. The Zoom In dialog box 
opens. 

 3 In the From box, enter the point that marks the left boundary of the section to 
enlarge. Note that this point must be on the x-axis.

 4 In the To box, enter the point that marks the right boundary of the section to 
enlarge. 
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 5 Click OK. The section is enlarged.

 6 Select View > Zoom Out to return the graph to its previous size. 

 7 Select View > Full View to return the graph to its original size.

Changing the Granularity of the X-axis for a Graph
You can make Astra LoadTest graphs easier to read and analyze by changing the 
granularity (scale) of the x-axis. 

To change the granularity of the x-axis for a graph:

 1 Select a graph from the Graphs menu.

 2 Select View > Granularity, or click the Granularity button. The Set Granularity 
dialog box opens.

 3 Enter a new scale in the Granularity box.
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 4 Click OK. Astra LoadTest regenerates the graph.

In the following example, the Transaction Performance graph is displayed using 
different granularities. The y-axis represents the average transaction response 
time within the granularity interval. For a granularity of 1, the y-axis shows the 
average response time for each one second period of the scenario. For a 
granularity of 2, the y-axis shows the average response time for every two second 
period of the scenario.
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In the above graphs, the same scenario results are displayed in a granularity of 
2, 5, and 10 (from top to bottom). The lower the granularity, the more detailed the 
results. It is useful to use a higher granularity to study the overall Vuser behavior 
throughout the scenario. For example, using a low granularity as in the upper 
graph, you see the intervals when no transactions were performed. By viewing 
the same graph with a higher granularity, you can easily see that the overall 
transaction response time averaged 3.5 seconds.

Working with Analysis Reports

In order to view a report, you must generate the report from the Astra LoadTest 
Analysis window. Astra LoadTest reports are displayed in a Report Viewer. You 
can print, save, or export the data using the viewer. 

Selecting and Displaying Reports
Astra LoadTest provides several built-in reports which contain detailed 
summaries about the scenario, the transactions and Vusers. For a list of the 
available reports, see Analysis Graphs and Reports on page 243.
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To display a report:

 1 In the Analysis window, choose File > Open to open the desired results file (if it 
is not already open).

 2 From the Reports menu choose a report. The report is generated and displayed. 
You can display multiple copies of the same report. 

The Report Viewer
Each report is displayed in its own report viewer. Each viewer contains a header 
and a toolbar. 

Report Header
The header displays general scenario information.
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The report header contains the following information:

Title: The name of the report.

Scenario: The name of the scenario described in the report.

Result: The pathname of the scenario results directory.

Start time: The time at which the Run Scenario command was executed.

End time: The time at which the scenario script was terminated.

Duration: The total run time of the scenario.

Report Viewer Toolbar
Each report viewer has a toolbar that lets you perform operations on displayed 
reports. 

Zoom

Export 

Print
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The report viewer toolbar contains the following buttons:

Zoom: Toggles between an actual size, full page, and magnified views of the 
report. 

Print: Prints the displayed report.

Export to file: Exports the displayed information to a disk file.

Spreadsheet and Raw Data Views

Astra LoadTest allows you to view the data in a grid form in two ways:

• Spreadsheet: The graph values displayed in a grid.

• Raw Data: The actual raw data collected during the scenario.
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Spreadsheet View
You can view the graph displayed by Astra LoadTest Analysis in spreadsheet 
format. The Spreadsheet view displays the data in a grid directly below the active 
graph. 

The first column displays the values of the x-axis. The following columns show the 
y-axis values for each transaction. For time based graphs, the absolute time is 
displayed in the second column. 
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To display a graph’s Spreadsheet view, select Spreadsheet > View 
Spreadsheet. To close the view, repeat the above step. 

If there are multiple values for the y-axis, as in the Transaction Performance 
Summary graph (min, average, and max), all of the plotted values are displayed. 
If you filter out a transaction, it will not appear in the view. 

To locate the spreadsheet data for a specific point on the graph, double-click that 
point on the graph—the spreadsheet displays the selected point. 

The Spreadsheet shortcut menu (right-click) has the following additional features:

• Export: You can export the spreadsheet data to an Excel file. Once you have the 
data in Excel, you can generate your own customized graphs.

• Copy to clipboard: You can copy one or more columns to the clipboard in order 
to paste it into an external spreadsheet program. 

• Print: You can print the data in spreadsheet format. A Print Preview option is 
also available from the print dialog box.

• Sort: You can sort the data according to any of the columns.
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In the following example, the data for the Transaction per Second graph shows 
the Elapsed Scenario Time, Absolute Time, and number of transactions per 
seconds for each transaction.

All Astra LoadTest graphs can be viewed in spreadsheet format. 

Raw Data Format
You can view the actual raw data collected by Astra LoadTest for the active graph. 
The Raw Data view is not available for all graphs. Refer to the chart on page 244 
for a list of the graphs with the Raw Data option. Note that in the raw data, the 
elapsed time is split into seconds and milliseconds.

Viewing the raw data can be especially useful for:

• determining specific details about a peak—for example which Vuser was running 
the transaction that caused the peak value(s). 

• performing a complete export of unprocessed data for your own spreadsheet 
application. This capability complements the File menu’s Export feature.
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To display a graph’s Raw Data view:

 1 Open the Spreadsheet view. (if it is not already open) Select Spreadsheet > 
View Spreadsheet.

 2 Select Spreadsheet > View Raw Data. The Show Raw Data dialog box opens. 

 3 Specify a time range—the entire graph or a specific range of time— and click 
OK. Astra LoadTest displays the data in a grid directly below the active graph. 

To show a different range, repeat the above procedure. When the Raw Data 
view is active, switch between the views by clicking on the appropriate tab. 
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Exporting Analysis Data 

You can export the data from Astra LoadTest’s Analysis graphs or reports into 
your own spreadsheet program. 

This chapter describes:

• Exporting Graph Data

• Exporting from the Analysis Window

• Exporting Data from the Report Viewer
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About Exporting Data from the Analysis

You can export performance data to a spreadsheet application or to a statistical 
analysis application for further processing. You can export from: 

• Graphs - Use the Spreadsheet or Raw Data view to copy and paste data 
directly into a spreadsheet program or save graph data as an Excel file.

• Analysis Window - Generate raw data text files with performance 
information. 

• Reports - Save report data in a format compatible with a spreadsheet 
application or Microsoft Mail.

Exporting Graph Data

You can export graph data directly through the clipboard using the Spreadsheet 
or Raw Data views. You select the columns you want to copy and copy them to 
the clipboard. You then paste the data directly into your spreadsheet program. 

Alternatively, you can save the spreadsheet as an Excel file. To save the file, click 
anywhere in the spreadsheet grid and choose Save As from the shortcut menu. 
For more information, see Chapter 18, Understanding Astra LoadTest 
Analysis. 
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Exporting from the Analysis Window

To generate simple text files with performance information, export the data from 
the Analysis window. The data files are exported to the specified directory in text 
format with.txt extensions. Each file begins with an explanation of the report and 
its fields. 

To export performance data from the Analysis window:

 1 In the Analysis window, choose File > Open to open the desired results file (if it 
is not already open).

 2 Click the Export button or choose File > Export. The Export dialog box opens.
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 3 In the Export Data to Directory box, type the path of the directory to which you 
want to export the information.

Alternatively, click the browse button next to the box and select a directory with 
the Export Path dialog box.

 4 From the Data files list, select the information you want to export. Use the CTRL 
key to select multiple files. For a list of the exportable data files, see the list 
below.

 5 Click OK to close the dialog box. 

You can export the following types of performance data: 

Transaction Meter contains information on all the transactions in the scenario, 
such as the ID of the Vusers performing the transaction and transaction 
performance times. The exported file name is tr_meter.txt. 

Transaction Distribution contains the distribution of the time taken to perform a 
transaction. The exported file name is distr.txt.

Running Vusers contains the total number of active Vusers during scenario 
execution. The exported file name is vurun.txt.

Transaction Summary contains general information about all transactions in 
the scenario, such as the minimum, maximum, and average performance times 
for all transactions in the scenario. The exported file name is trans.txt.

General Scenario Information contains the path of the scenario file and the 
total number of Vusers in the scenario. The exported file name is sc_map.txt.
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General Result Information contains the path of the results file and the start 
and end times for the scenario. The exported file name is sc_res.txt.

Groups contains the name and ID of each Vuser Group in the scenario. The 
exported file name is sg_res.txt.

Vuser Information contains all the Vusers that were in the RUNNING state during 
scenario execution. The exported file name is vu_res.txt.

Vuser Status Contains the status of each Vuser at the end of the scenario (PASS, 
FAIL, ABORT, ERROR). The exported file name is vu_stat.txt.

Transactions per Second contains the number of completed transactions 
during each second of the scenario. The exported file name is tps.txt.

Performance by Vuser contains transaction performance information for each 
Vuser in the scenario. The exported file name is vu_trans.txt.

Performance Under Load contains the performance time for transactions 
according to the total number of active Vusers during scenario execution. The 
exported file name is perf_run.txt.

Data Point contains performance information about user defined points known 
as data points. The exported file name is dpoint.txt.

Data Point Map contains a list of the data points measured throughout the 
scenario. The exported file name is dp_map.txt.

Rendezvous contains information about the rendezvous such as the number of 
members arrived, the arrival and release times, and the reason for the release. 
The exported file name is rendz.txt.
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Rendezvous Map contains a list of the rendezvous points in the scenario. The 
exported file name is rendzmap.txt.

Percentile contains the percentage of transactions performed within a given 
time range. The exported file name is percent.txt.

Exporting Data from the Report Viewer

From the Report Viewer, you can export analysis data to a file, an Exchange 
folder, or a Lotus Notes database for further processing. You can also export 
Astra LoadTest reports through Microsoft Mail. For a list of the available formats, 
click the arrow to the right of the Destination box to open the drop-down list box. 
The formats that are available for export depend on the type of destination—only 
the appropriate formats are enabled. 

To export report data to a file:

 1 In the Analysis window, choose File > Open to open the desired results file (if it 
is not already open).

 2 Open the Reports menu and choose a report to generate. Wait for the report to 
open. 
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 3 Click the Export button from the report viewer toolbar. The Export dialog box 
opens. 

 4 Click the arrow to the right of the Format box and select a file format from the 
list.

 5 Click the arrow to the right of the Destination box and select a destination from 
the list.
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 6 Click OK. The Choose Export File dialog box opens.
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 7 Specify a name for the export file and click OK. Astra LoadTest displays the 
report title in the window banner and exports the information. A dialog box 
displays the progress of the export. For example, if you are exporting the 
Detailed Vuser report, the dialog box title will read Printing Detailed Vuser. 

To export report information using Microsoft Mail:

 1 In the Analysis window, open the Reports menu and choose a report to 
generate. Wait for the report to open. 



Analyzing Test Results • Exporting Analysis Data

Astra LoadTest Controller User’s Guide Chapter 19, page 274

In

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

 2 Click the Export button from the report viewer toolbar. The Export dialog box 
opens. 

 3 Select Character separated values from the Format box.

 4 Select Microsoft Mail from the Destination box. 

 5 Click OK to close the dialog box. The Character-Separated Values dialog box 
opens. 
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 6 Specify a character to separate between values in the data file to which you are 
exporting. The default is a comma. Click OK to close the dialog box. The 
Number and Date Format dialog box opens.

 7 Check the appropriate boxes and then click OK. Astra LoadTest begins to export 
the information. 
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Analyzing Scenario Activity 

After running a scenario, you can analyze the Vuser activity that occurred during 
the scenario to check that the scenario ran as planned. You can use the following 
graphs or reports to analyze Vuser activity:

• Running Virtual Users Graph

• Rendezvous Graph and Report

• Transactions per Second Graph (Passed)

• Transactions per Second Graph (Failed)

• Failed Transactions Report

• Failed Vuser Report

• Scenario Execution Report
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About Scenario Activity

During scenario execution, Vusers generate data as they perform transactions. 
Astra LoadTest enables you to generate graphs that show scenario activity or 
overall scenario performance. Scenario activity graphs and reports let you track 
Vuser behavior throughout the scenario. The graphs map the transactions, 
rendezvous, and active status of the Vusers, according to the elapsed scenario 
time. 

When working with graphs, you can focus on specific segments of the scenario 
using the zoom tools. In addition, you can change the granularity of the graph. For 
more information about working with graphs, see Chapter 18, Understanding 
Astra LoadTest Analysis. 
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Running Virtual Users Graph

The Running Virtual User graph displays the number of Vusers that executed 
Vuser scripts during each second of a scenario run. Only Vusers in the RUNNING 
and RENDEZ states are included in the graph. Vusers in the LOADING, READY and 
PAUSE states are not displayed. 

This graph is useful for determining the Vuser load on your server at any given 
moment. The x-axis represents the elapsed time (in seconds) since the start of 
the scenario run. The y-axis represents the number of running Vusers in the 
scenario. 

For example, the above graph indicates that there was a maximum load of thirty 
Vusers. Until the 37th second of the scenario run, Vusers were gradually loading. 
Thereafter, the number of running Vusers decreased to twenty, and then to ten.
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Rendezvous Graph and Report

The Rendezvous graph indicates when Vusers were released from rendezvous 
points, and how many Vusers were released at each point. 

This graph helps you understand transaction performance times. If you compare 
the Rendezvous graph to the Transaction Performance graph, you can see how 
the load peak created by a rendezvous influences transaction times.
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On the Rendezvous graph, the x-axis indicates the number of seconds that 
elapsed since the start of the scenario run. The y-axis indicates the number of 
Vusers that were released from the rendezvous. If you set a rendezvous for 60 
Vusers, and the graph indicates that only 20 were released, you can see that the 
rendezvous ended when the timeout expired because all of the Vusers did not 
arrive. 

In the above Rendezvous graph, the first query rendezvous takes place during the 
312th second of the scenario, and 60 Vusers were released. By comparing these 
results to the Transaction Performance graph, you see that the peak time for the 
query transaction occurred under the load of sixty Vusers, with a response time 
of 20 seconds. 

The Rendezvous report provides additional information about the rendezvous.

In the above report, the rendezvous policy was set to All Arrived, requiring all 50 
Vusers to arrive at the rendezvous point. In the first rendezvous, 40 Vusers were 
released after the timeout period while 10 Vusers were manually released by the 
operator. In the next rendezvous, all 50 Vusers arrived. In the last rendezvous, 
two Vusers never arrived, causing the others to reach the timeout. 
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Transactions per Second Graph (Passed)

The Transactions per Second (Passed) graph displays the number of completed, 
successful transactions performed during each second of a scenario run. This 
graph helps you determine the actual transaction load on your system at any 
given moment. You can compare this graph to the Transaction Performance 
graph in order to analyze the effect of the number of transactions on the 
performance time. 
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The x-axis represents the elapsed time (in seconds) since the start of the 
scenario run. The y-axis represents the number of transactions successfully 
performed during the scenario run. For example, the above graphs indicate that 
in the 224th second of the scenario, nine query transactions were successfully 
completed. The response time at that point was 49 seconds. 

Transactions per Second Graph (Failed)

The Transactions per Second (Failed) graph displays the number of completed, 
unsuccessful transactions performed during each second of the scenario run. 
This graph contains information about transactions that were assigned an 
LR_FAIL value in the lr_end_transaction statement.

Note: The lr_end_transaction statement must be executed in order to generate 
the Failed Transaction graph. If your program aborts immediately upon an error, 
all current transactions are terminated—no data is generated for failed 
transactions. 
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The following example uses a Web Vuser script. Web Vuser statements return 
zero for success and a positive value for failure. The Web Vuser script below tries 
to access an HTML page using a GET statement. If the GET request succeeds, 
the script assigns the LR_PASS status to the transaction. If the GET request fails, 
the script assigns LR_FAIL to the transaction. 

On the Transactions per Second (Failed) graph, the x-axis represents the elapsed 
time (in seconds) since the start of the scenario run. The y-axis represents the 
number of transactions unsuccessfully performed during the scenario.

lr_start_transaction(“wizard”);
if (URL("http://www.wizard.com/index.html") == 0) 

lr_end_transaction(“wizard”, LR_PASS);
else {

lr_end_transaction(“wizard”, LR_FAIL);
lr_log_message("Wizard home page not returned");
}
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For example, the above graph indicates that in the 33rd second of the scenario, 
nine insert_row transactions failed.
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Failed Transactions Report

The Failed Transaction report provides detailed information about the beginning, 
end, and duration of the failed, yet completed transaction. 
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Failed Vuser Report

The Failed Vuser report provides details about all Vusers that were in the ERROR, 
ABORTED, or DONE:FAILED states during the scenario execution. The Ready At 
and Running At times are relative to the computer’s system clock. 

In this scenario, one Vuser failed, two had errors, and three were aborted. 
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Scenario Execution Report

The Scenario Execution report details the major events that occurred during the 
scenario run. This includes information on every Vuser, such as when it was ready 
to run and for how long it ran. 

The Ready At and Running At times are based on the computer’s system clock. 
The Termination Status field indicates the status of the Vuser at the end of the 
scenario run (PASSED, FAILED, ERROR, or ABORTED). At the end of the Group 
information, there is a summary of the Group’s activities.
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Analyzing Scenario Performance

After running a scenario, you can create graphs and reports to help you locate 
bottlenecks and analyze overall Vuser performance. You can determine if the 
transaction response time was adequate, and how your system handled a load of 
many users. 

This chapter discusses the graphs and reports that you can use to analyze Vuser 
performance:

• Percentile Graph

• Performance Under Load Graph

• Transaction Performance Graph

• Transaction Performance Summary Graph and Report

• Transaction Performance by Vuser Graph and Report

• Transaction Distribution Graph

• Detailed Transaction Report

• Data Point Graph and Report
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About Scenario Performance

During scenario execution, Vusers generate data as they perform their 
transactions. Astra LoadTest allows you to generate graphs that show scenario 
activity or overall scenario performance. Scenario performance graphs and 
reports let you analyze Vuser behavior throughout the scenario. The Performance 
graphs map the transaction response time, and other general information about 
the scenario. 

When working with graphs, you can focus on specific segments of the scenario 
using the zoom tools. In addition, you can change the granularity of the graph. 
When working with reports, you can export the data in ASCII format or in a custom 
format for common spreadsheet applications. 

For more information about working with graphs and reports, see Chapter 18, 
Understanding Astra LoadTest Analysis. 
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Percentile Graph

The Percentile graph analyzes the percentage of transactions that were 
performed within a given time range. This graph helps you determine the 
percentage of transactions that met the performance criteria defined for your 
system. In many instances, you need to determine the percent of transactions 
with an acceptable response time. The maximum response time may be 
exceptionally long, but if most transactions have acceptable response times, the 
overall system is suitable for your needs. 
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The x-axis represents the percentage of the total number of transactions 
measured during the scenario run. The y-axis represents the time taken to 
perform the transactions.

In the above example, a system administrator determines that 2 seconds is an 
acceptable time for a particular transaction. If 95 percent of the transactions are 
2 seconds or less, the current configuration is suitable. If more than five percent 
of the transactions have a response time greater than fifteen, the configuration 
must be optimized. In the above graph, 95 percent of the report transactions were 
performed in 2 seconds or less.

Compare the Percentile graph to a graph indicating average response time such 
as the Transaction Performance Summary graph. A high response time for 
several transactions may raise the overall average. However, if the transactions 
with a high response time occurred fewer than five percent of the times, that factor 
may be insignificant. 
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Performance Under Load Graph

The Performance Under Load graph indicates transaction times relative to the 
number of Vusers running at any given point during the scenario. This graph 
helps you view the general impact of Vuser load on performance time and is 
most useful when analyzing a scenario with a gradual load. You can create a 
gradual load using the scheduling options in the Vuser information box. 

The x-axis indicates the number of running Vusers, and the y-axis indicates 
average transaction time in seconds. In the above graph, the execution time for 
the top_sales transaction increases with the number of running Vusers. For 
twenty running Vusers, the response time for the transaction was 3.5 seconds. 
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The Performance Under Load Graph indicates transaction times relative to the 
number of Vusers running at any given point during the scenario. In order for this 
graph to be meaningful, the performance is calculated when there is a stable load 
(constant number of running Vusers) for at least five seconds (by default). If the 
Vuser load is not stable for at least five seconds, the transaction time is not 
calculated and the graph will indicate zero.

For example, a scenario with a load of 50 to 70 Vusers had an average 
performance of 10 seconds, but its graph displayed zero. This occurred because 
the Vusers did not stabilize for five seconds. 

You can instruct Astra LoadTest to measure transaction time for shorter periods 
of steady load. 
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To change the Performance Under Load interval:

 1 Choose Options > Performance Under Load Interval in the Analysis window.

 2 Enter the desired interval. 

 3 Click OK to accept the settings. 

 4 Regenerate the Performance Under Load graph. 

The Performance Under Load report provides the same information as the graph 
for each transaction in table form.
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Transaction Performance Graph

The Transaction Performance graph displays the average time taken to perform 
transactions during each second of the scenario run. 

The x-axis represents the elapsed time (in seconds) since the start of the scenario 
run. The y-axis represents the average time (in seconds) taken to perform each 
transaction.

You can compare the Transaction Performance graph to the Running Virtual 
Users graph to see how the number of running Vusers affects the transaction 
performance time. 
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If you have defined acceptable minimum and maximum transaction performance 
times, you can use this graph to determine whether the performance of the server 
is within the acceptable range. 
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For instance, the graph above shows the transaction performance times for two 
transactions. You can see that each time the transaction was executed, 
performance time decreased. If you compare this graph to the Running Virtual 
Users graph, you can see that the performance time improved because the Vuser 
load decreased. 

Note that the transaction times are only indicated by the peaks in the graph. When 
running multiple Vusers, one transaction may begin before the previous one ends, 
resulting in a continuous line. The line does not indicate the actual start and end 
times of transactions; it is only a mechanism used by the graph to join the peaks. 

The Transaction Performance graph may be displayed using different 
granularities. The y-axis represents the average transaction response time within 
the granularity interval. For example, for a granularity of 1, the y-axis shows the 
average response time for each one second period of the scenario. For a 
granularity of 2, the y-axis shows the average response time for every two second 
period of the scenario.
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In the above graphs, the same scenario results are displayed in a granularity of 
2, 5, and 10 (from top to bottom). The lower the granularity, the more detailed the 
results. However, it may be useful to view the results with a higher granularity to 
study the overall Vuser behavior throughout the scenario. For example, using a 
low granularity as in the upper graph, you see the intervals when no transactions 
were performed. By viewing the same graph with a higher granularity, you can 
easily see that the overall transaction response time averaged 3.5 seconds. 
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Transaction Performance Summary Graph and Report

The Transaction Performance Summary graph displays the minimum, maximum 
and average performance time for all the transactions in the scenario. 

The x-axis specifies the name of the transaction. The y-axis shows the time, 
rounded off to the nearest second, taken to perform each transaction. 

For example, the above graph displays the statistics of the query transaction. The 
transaction was performed in a minimum time of 24 seconds, an average time of 
36 seconds, and a maximum time of 42 seconds.
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The report shows similar information in table form,  with several additional 
statistical details. 

The following values are reported:

Pass, Fail: the number of Vusers that passed or failed the transaction.

Min, Avg, Max: the minimum, average, and maximum transaction times.  

90th Percentile: the mean transaction time for ninety percent of the transactions. 

PopStdDev:  The popular standard deviation of transaction times from the 
average value. 

Note that the data in the report is not rounded off to the nearest second as it is in 
the graph.
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Transaction Performance by Vuser Graph and Report

The Transaction Performance Summary by Vuser graph displays the time taken 
by an individual Vuser to perform transactions during the scenario. The 
minimum, maximum, and average times are plotted for each transaction 
performed by the Vuser. This graph is useful when you have different types of 
Vusers in a scenario, and you want to characterize performance for each type. 
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The x-axis specifies the name of the Vuser and the Group to which it belongs. The 
y-axis shows the time, in seconds, it takes to perform each transaction. For 
example, the above graph displays transaction processing times for the Vusers in 
the group15. Vuser two performed the query transaction in a minimum of 25 
seconds, an average of 32 seconds, and a maximum of 40 seconds. 

The Performance Summary by Vuser report shows similar information for each 
Vuser in table format.  
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Transaction Distribution Graph

The Transaction Distribution graph displays the distribution of the time taken to 
perform a transaction. The transaction response times are divided into five bars. 
Each bar shows how many times the transaction was completed within a given 
time range. If you compare it to the Transaction Performance Summary graph, 
you can see how the average performance was calculated. Note that this graph 
only displays information for a single transaction. 
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The x-axis represents the time range, in seconds, to perform the selected 
transaction. The y-axis represents the number of transactions executed during 
the scenario. 

For example, the above graph indicates that the performance time for 52 query 
transactions was between 38.44 and 41.99 seconds. 
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Detailed Transaction Report 

The Detailed Transaction report (by Vuser) is a list of all transactions executed 
by each Vuser during a scenario. The report provides details about the execution 
time of each transaction per Vuser. 

The following values are reported:

Start time: the system time at the beginning of the transaction

End time: the actual system time at the end of the transaction, including the think 
time and wasted time. 

Duration: The duration of the transaction in the following format: 
hrs:minutes:seconds:microseconds. This value includes think time, but does not 
include wasted time. 
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Think time: the Vuser’s think time delay during the transaction.

Wasted time: the Astra LoadTest internal processing time not attributed to the 
transaction time or think time.

Results: the final transaction status, either Pass or Fail.

Data Point Graph and Report

Astra LoadTest enables you to record your own data for analysis. You instruct 
Astra LoadTest to record the value of an external function or variable, also 
known as a data point, during the scenario run. Using the gathered data, Astra 
LoadTest creates a graph and report for the data point. 

The data point is set by including an lr_user_data_point function  in your Vuser 
script. For more information, refer to the Astra Function Reference. 
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The Data Point graph shows the value of the data point during the scenario run. 
The x-axis represents the number of seconds elapsed since the start time of the 
run. The y-axis displays the value of each recorded data point statement. 

In the above example, an lr_user_data_point statement was placed in a Vuser 
script, defining a data point called memory. The data point is associated with an 
external function that checks the computer’s virtual memory. The above graph 
indicates that the value of the function was 58 at the 134th second of the 
scenario. You can compare this graph with other graphs to understand why and 
when the peaks occurred. The peaks could indicate a rendezvous, or a 
transaction that uses a great deal of memory. 
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The Data Point report lists the name of the data point, its value, and the time its 
value was recorded. The values are displayed for each Group and Vuser. 
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Cross-Scenario Analysis

After running a scenario, you can analyze the performance of your application 
using Astra LoadTest’s graphs and reports. Cross-scenario graphs allow you to 
compare the results of several scenario runs by superimposing their results onto 
a single graph. 

This chapter discusses:

• Cross-Scenario Graph Types

• Generating Cross-Scenario Analysis Graphs

• Performing Cross-Scenario Analysis

• Cross-Scenario Analysis for Transaction Performance

• Cross-Scenario Analysis for Performance Summary

• Cross-Scenario Analysis with Percentile Graphs
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About Cross-Scenario Analysis

Cross-scenario analysis enables you to compare the results of multiple scenario 
runs. Astra LoadTest can superimpose the generated results onto a single cross-
scenario graph. On this graph, you can compare the performance of the server 
during multiple scenarios. Cross-scenario analysis is useful for:

• benchmarking hardware

• testing software versions

• determining system capacity

Suppose that you want to benchmark two hardware configurations. You run the 
same scenario with both configurations and compare the transaction response 
times using a single cross-scenario graph. 

Suppose that your vendor claims that a new software version is optimized to run 
quicker than a previous version. You can verify this claim by running the same 
scenario on both versions of the software, and comparing the scenario results. 

You can also use cross-scenario graphs to determine your system’s capacity. You 
run scenarios using different numbers of Vusers running the same script. By 
analyzing the cross-scenario graphs, you can determine the number of users that 
cause unacceptable response times. 
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Cross-Scenario Graph Types

You can perform cross-scenario analysis for the following graph types:

For information about the Activity graphs, see Chapter 20, Analyzing Scenario 
Activity.  For information about the Performance graphs, see Chapter 21, 
Analyzing Scenario Performance.  For information about the Web graphs, see 
Chapter 23, Web Vuser Graphs. 

Graph Name Type

Running Virtual Users Activity

Rendezvous Activity

Transactions per Second (Passed) Activity

Transactions per Second (Failed) Activity

Percentile Performance

Performance Under Load Performance

Transaction Performance Performance

Transaction Performance Summary Performance

Transaction Performance Summary by Vuser Performance

Transaction Distribution Performance

Connections per Second Web

Throughput Web
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Generating Cross-Scenario Analysis Graphs

You can perform cross-scenario analysis for two or more graphs. 

To perform cross-scenario analysis:

 1 Select Results > Analyze Results, or click the Analysis button to open the 
Analysis window. 

 2 Select File > Cross Scenario Graphs, or click the Cross-Scenario button. The 
Cross Scenario dialog box opens. You use the dialog box to select the scenarios 
to compare.

 3 Click Add to add scenarios to the Results list. The Open dialog box opens.

 4 In the Open dialog box, select a results directory and choose a results file (.lrr). 
Click OK. The scenario is added to the Results list.
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 5 Repeat steps three and four until all the scenarios you want to compare appear 
in the Results list. 

 6 Click OK. The Percentile graph appears. The information for each scenario is 
plotted in a different color.

 7 Select additional graphs from the Graphs menu. 
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 8 Filter the scenarios and transactions you want to view. Choose multiple 
transactions using the CTRL key. 

 9 Manipulate the graphs using the analysis tools. For example, you can tile graphs 
to compare their results, change the granularity, and zoom in on a specific area.
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Performing Cross-Scenario Analysis

Astra LoadTest cross-scenario analysis graphs allow you to compare results and 
performance data from various scenarios on a single graph. You can filter graphs 
to display selected scenarios, transactions, or Vusers. By comparing the scenario 
results, you can determine which Vusers had acceptable response times and 
what event caused a bottleneck. If you are benchmarking machines, you can 
determine if a new server justifies its cost by comparing the transaction response 
times. 

The following sections illustrate the use of cross-scenario analysis using three 
cross-scenario graphs:

• Transaction Performance 

• Transaction Performance Summary

• Percentile
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Cross-Scenario Analysis for Transaction Performance 

The Transaction Performance graph displays the average time taken to perform 
transactions during each second of the scenario run. Cross-scenario graphs are 
useful in comparing user behavior after a configuration change such as 
additional memory or CPUs. You run an identical scenario with the same number 
of Vusers for each configuration. Afterwards you compare the transaction results 
using cross-scenario analysis. 
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In the above example, the operator ran the same scenario three times, using 
three different configurations. The transaction response time was substantially 
longer in the second configuration. The transaction time for the second 
configuration was slightly better than the third. The graph also shows that the 
loading time in the third configuration was greater than the previous 
configurations. 

Cross-Scenario Analysis for Performance Summary 

Using the Transaction Response Time cross-scenario graphs, you can 
determine and compare the minimum, maximum, and average transaction times 
for your scenarios. These graphs only display statistics for a single transaction. 
To compare multiple transactions, regenerate the Transaction Response Time 
graph several times and select View > Filter to select a transaction to display. 
Select Window > Tile to align the axis of the graphs. 
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Note that the scale of the y-axis may differ between graphs. 
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In the above graphs, the average transaction response time ranged from 3.43 
seconds in the first configuration, to eight seconds in the third configuration. To 
determine the Vuser distribution—for example how many Vusers performed a 
transaction in the average time of 3.69 seconds, use the Transaction Distribution 
graph.

These graphs enable you to see that although the minimum transaction time was 
lower in the third configuration, the average response time was lower in the 
second configuration.
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Cross-Scenario Analysis with Percentile Graphs

The Percentile graph analyzes the percentage of transactions that were 
performed within a given time range. Use the Percentile cross-scenario graph to 
compare the transaction response times between scenario runs. 

For example, to compare transaction response time for several hardware 
configurations, you run the same scenario for each configuration. Run the cross-
scenario analysis to display the transaction response times. 
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The above graph indicates that a large percentage of the transactions had a 
better response time in the third configuration than in the second configuration. 

If we filter the graph to display only the first and third configurations, the 
y-axis scale shows that the response time for the first configuration is slightly 
better than the third. 
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��
Web Vuser Graphs

After a scenario run, you can use graphs to analyze Web server performance. 
Web Vuser graphs can help you analyze the behavior and performance of your 
Web site. They display information about server load, transaction performance 
time, hits, and throughput. 

This chapter describes:

• Hits per Second Graph

• Throughput Graph 

• Comparing Web Graphs
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Hits per Second Graph

The Hits per Second graph shows the number of hits made on the Web server by 
Vusers during each second of the scenario run. This graph helps you evaluate 
the amount of load Vusers generate, in terms of the number of hits. You can 
compare this graph to the Transaction Performance graph to see how the 
number of hits affects transaction performance.

The x-axis represents the number of seconds elapsed since the start of the 
scenario run. The y-axis represents the number of hits on the server. For 
example, the graph above shows how the number of hits decreased gradually 
throughout the scenario. The most hits per second took place during the 90th 
second.
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Throughput Graph

The Throughput graph shows the amount of throughput on the server during 
each second of the scenario run. Throughput is measured in kilobytes and 
represents the amount of data that the Vusers received from the server at any 
given second. This graph helps you to evaluate the amount of load Vusers 
generate, in terms of server throughput. You can compare this graph to the 
Transaction Performance graph to see how the throughput affects transaction 
performance.
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The x-axis represents the number of seconds elapsed since the start of the 
scenario run. The y-axis represents the throughput of the server, in kilobytes. For 
example, in the graph below, you can see that the highest throughput was about 
75,000 bytes, during the 60th second of the scenario.

Comparing Web Graphs

You can improve your scenario performance by analyzing a specific transaction 
to locate the bottlenecks. By comparing several graphs, you can view the 
maximum transaction time and determine why the transaction time reached its 
maximum at that point.

To view and compare several graphs simultaneously, generate the graphs within 
the analysis window and select Window > Tile. 
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In the following example, the maximum transaction response time was 26 
seconds. This occurred when the number of connections was at its peak. This 
graph clearly indicates that the response time is influenced by the number of hits. 

You can compare other graphs and report results to analyze the scenario and 
determine additional bottlenecks.
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Part VI

Appendixes
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A
Interpreting Astra LoadTest Graphs

Astra LoadTest online monitor and analysis graphs present important information 
about the performance of your scenario. This chapter describes some of the key 
graphs in greater depth and shows how they can be used to identify and pinpoint 
performance bottlenecks.

• Online Monitoring Graphs

• Analysis Graphs
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Online Monitoring Graphs

Using the online monitor graphs, you can determine whether transactions 
transpire within an acceptable amount of time, whether your bandwidth is 
sufficient to keep download times to a minimum, and whether your hardware and 
operating system can handle peak load.

Question 1: Do all transactions in my scenario transpire within an acceptable 
amount of time? Which particular transactions take too long?

Answer: The Transaction Response Time graph shows the amount of time it 
takes for each transaction to be completed.  Note that in the graph below, the 
transaction response time is quick, except for the login transaction. The initial 
login did not take much time, but subsequent logins were quite slow.  
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This indicates that the database is unable to process more than one login at a 
time, which may be due to inefficient database querying.
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Question 2: Is bandwidth sufficient to keep download times to a minimum?

Answer: The Throughput graph shows the amount of throughput on the Web 
server during each second of the scenario run.  Throughput represents the 
amount of data received from the server at any given second.

Note that in the graph above, the throughput scales upward as time progresses 
and the number of users increases.  If the graph were to remain relatively flat as 
the number of users increased, it would be reasonable to conclude that the 
bandwidth is constraining the volume of data requested.
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Question 3: Can the hardware and operating system handle peak load?  

Answer: The Server Resources graph displays NT server resource usage in 
real-time. You use this graph to monitor the resources used during a scenario 
and locate a bottleneck on a particular machine. 
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The % Total Processor Time in the above graph shows the amount of data 
processed by the server.  File Data Operations/sec shows the rate at which the 
server is issuing Read and Write operations to file system devices.  Page 
Faults/sec counts the number of page faults in the processor, representing 
virtual memory and caching algorithm opportunities.  

It is commonly thought that newer and faster servers can resolve slow download 
times. However the above graph demonstrates that only a small amount of data 
is processed by the server.  This indicates that there is adequate processor 
capacity, and more server hardware will not result in increased performance.  
There are cases, however, in which increased performance can be achieved by 
optimizing the data file system.
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Analysis Graphs

Using the analysis graphs, you can determine the maximum number of 
concurrent users your application can handle.

Question 4: Will the application scale to handle 100 or 1000 concurrent users? 
What happens to the response time as the number of users increases?

Answer: The Performance Under Load graph demonstrates what happens to 
response time as the number of users increases.  To view this graph, select 
Graphs > Performance Graphs > Performance Under Load.  The graph 
displays page download time relative to the number of active users.
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The above graph shows that for a load of over 50 users, the response time of the 
application increases dramatically.  Thus, if you anticipate more than 50 
concurrent users for your application, you will need to ensure that response time 
remains acceptable under peak load.

Yet a quick response time is only meaningful if the returned information is correct.  
To verify that your application is working reliably under peak load, use the 
Transactions per Second Passed and Failed reports. 
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Note that in the above graphs all of the transactions passed except for 
"typeofcreditcard," which failed near the end of the test.  Efforts should focus on 
fixing the problems associated with this critical transaction.
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B
Working in Expert Mode

Advanced users can fine-tune the Astra LoadTest configuration settings while 
working in Expert Mode. In Expert mode, additional options are displayed in the 
Settings dialog box. This chapter describes the additional settings that are 
available in the Expert mode: 

• Entering Expert Mode

• Agent Settings

• General Settings

• Debug Information Settings

• Output Settings

• Timeout Settings
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Entering Expert Mode

The Astra LoadTest Controller Expert Mode is intended for support personnel to 
provide access to system information. When you work in the Expert Mode, the 
Controller dialog boxes contain additional options for fine tuning the Controller 
operation.

To activate the Expert Mode, choose Tools > Expert Mode. An active Expert 
Mode is indicated by a check mark.

To exit the Expert Mode, repeat the above process.
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Agent Settings

The Agent settings allow you to customize the behavior of the agent on a remote 
host machine. Using the Settings dialog box, you set the online configuration and 
command line parameters for the agent. 

The available configuration settings are: 

Heartbeat rate: The time interval when all agents on remote hosts send 
messages to the Controller to indicate that the agent is still active. The default is 
every 30 seconds.

Heartbeat max miss: The maximum number of heartbeat misses that the 
Controller can tolerate before causing an agent to exit. Increase this number if the 
agents are exiting too soon after a heartbeat miss.

Debug level: The level of detail for the debug messages (from 0 - least detailed, 
to 15 - most detailed). The default is 0.

Rendz / Status grouping quota: The agent waits and collects Rendezvous and 
Status commands before releasing them. These settings specify how many 
Rendezvous or Status messages to gather before releasing the Vusers. The 
default is 100. 



Working in Expert Mode

Astra LoadTest Controller User’s Guide Appendix B, page 341

In

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

Timeout to Controller: The default timeout for the Controller when observing the 
agent. The Controller polls the agent at given intervals to determine whether it is 
still active. If it fails to respond within the specified timeout, the Controller issues 
a message that the agent is down. The default timeout is 120 seconds.

Max threads for driver: The maximum number of threads that can be executed 
for the current Vuser’s driver. 

Working Language: The agent’s working language (English or Japanese).

The available command line settings are:

Keep agent connection log: This is the command line used by the Controller to 
bring up this host’s agent. This appears only when the host is in the process of 
connecting or already connected. It is useful for determining why an agent failed 
to load. It saves the agent connection log in the directory specified in Agent log 
dir.

Debugger path: To launch a debugger with the agent, specify the debugger path. 
The agent appends this path to the b-daemon.exe command line.
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To set the Agent settings:

 1 Enter Expert Mode (see above).

 2 Choose Tools > Options. The Options dialog box appears. Select the Agent 
tab. 

 3 Set the desired parameters.

 4 Click OK to accept the settings and close the dialog box. 
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General Settings

The General Expert Mode settings allow you to specify global settings for the host 
connection delay, data table storage and multiple IP address allocation. 

Host connection delay: The delay, in seconds, that Astra LoadTest waits before 
connecting to a host. 

Data tables global directory: This setting is only required for scripts created with 
earlier versions of Astra LoadTest. The network location for data tables used as a 
source for parameter values.
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To set the General Expert Mode settings:

 1 Choose Tools > Options. The Options dialog box appears. Select the General 
tab. 

 2 Enter the desired host connection delay in seconds.

 3 Enter the global directory for data tables.

 4 Click OK to accept the settings and close the dialog box. 
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Debug Information Settings

The Debug Information settings allow you to determine the extent of the trace to 
be performed during scenario execution. The debug information is written to the 
Output window. 

The following trace flags are available: General, File Transfer, Incoming 
Communication, and Outgoing Communication. You only need to select the flags 
relating to your problem. For example, if you encounter specific problems with the 
transfer of files, select the File Transfer flag. 

The agent creates some temporary files in the TMP or TEMP directory, which are 
normally deleted at the end of the scenario. The temporary files contain 
information such as the parameter file sent to the Vuser, the output compilation 
file and the configuration file. The files are saved in the TMP/lrr#/UsrTmp 
directory, where # indicates the session number. Using the Debug Expert mode 
settings you can instruct Astra LoadTest to keep those temporary files. 
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To set the Debug Information settings:

 1 Choose Tools > Options. The Options dialog box appears. Select the Debug 
Information tab. 

 2 Select the check boxes for the desired trace flags. 

 3 To save the temporary runtime files, select the Keep temporary files check box.

 4 Click OK to accept the settings and close the dialog box. 
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Output Settings

Basic Output settings are available when Expert mode is disabled. However, 
Expert mode provides additional settings for handling output messages:

Save Every xxx messages: Defines how often to auto-save the output message 
file. The default is every 100 messages.

Limit the number of messages to: The maximum number of messages that 
may appear in the Output window. The default is 500 messages.

Deletion Quota: The maximum number of messages that may be deleted from 
the Output window (due to the limiting of the number of messages).
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To set the Output settings:

 1 Choose Tools > Options. The Options dialog box appears. Select the Output 
tab. 

 2 Enter the number of messages after which Astra LoadTest will perform an auto-
save operation. To limit the number of messages in the output window, select the 
check box and enter the desired number of messages and deletion quota.

 3 Click OK to accept the settings and close the dialog box. 
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Timeout Settings

Basic Timeout settings are available when Expert mode is disabled. However, 
Expert mode provides additional timeout settings:

Time to wait for grouping Vuser commands: You can tell Astra LoadTest to 
wait a specific time interval before issuing a group of commands. For example, 
wait 20 seconds before issuing a group of Pause commands. The commands 
which can be grouped are: Run, Pause, Abort, Rendezvous, Show and Hide. The 
default time is 0 seconds. 
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To set the Timeout settings:

 1 Choose Tools > Options. The Options dialog box appears. Select the Timeout 
tab. 

 2 Enter the timeout for each of the Vuser commands: Run, Pause, Abort, Rendz, 
Show, and Hide. 
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C
Troubleshooting the Controller

Astra LoadTest enables you to test entire applications. If one of the components 
of the application is not configured properly, Astra LoadTest scenarios will not run.

This appendix discusses the most common Astra LoadTest problems:

• Failure to Communicate with a Host

• Failure to Connect to the AUT Database

• Failure to Access Files

• Failed Vusers or Transactions

• Increasing the Number of Vusers on an NT Server

• Working with Firewall Limitations
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About Troubleshooting

Astra LoadTest relies heavily upon communication between host machines on a 
network. If communication is not established properly, the Controller will be 
unable to send commands to remote hosts and the scenario will fail. By 
understanding the reason for the failure and determining when the failure 
occurred, you can solve most of the communication-related problems. 

In order to ensure that the problem lies with your scenario and not your Vuser 
script, you should verify that your script runs properly on all remote hosts as a 
stand-alone:

• Test all types of Vuser scripts on Windows platforms by running them from 
the Virtual User Recorder.

For more information on running Vuser scripts in stand-alone mode, refer to the 
appropriate guide for creating Vuser scripts. 
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Astra LoadTest Communications

Most communication problems can be solved if you understand your Astra 
LoadTest configuration. This knowledge helps you to determine the source of the 
problem and perform the necessary actions to correct it.

The following diagram illustrates a sample network running Astra LoadTest. There 
are three servers: The Astra LoadTest Controller, the application or database 
server, and the file server which stores the scenario results (note that result files 
can also be saved on a non-dedicated server). There are five remote hosts, each 
one running multiple Vusers. 

The arrows indicate the type of communication necessary between the elements 
of the network. The Vusers communicate with the Controller in both directions 
(send/receive), but with the file server in one direction (send). The Controller must 
have access to the file server. All Vusers participating in the scenario must be able 
to communicate with the application server in both directions (send/receive). 
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In order for a client host to connect to the server host, it must be able to resolve 
the server host name.

If any of the connections are broken, the scenario will fail. 

Result 
File  

Server 

Remote Vuser Hosts

LoadRunner  
Controller

Database  or 
Application  

Server
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Failure to Communicate with a Host

The most common communication error is the failure of the Controller host to 
connect with a remote host. Check the following items:

• TCP/IP setup

• TCP/IP connectivity

• Remote Command Launcher

• Host connections

Checking TCP/IP Setup
The first step in checking your configuration is to verify your machine’s TCP/IP 
setup. Astra LoadTest includes a utility called Hostinfo (hostinfo.exe), located 
under Astra LoadTest’s bin directory. This utility provides information about the 
current host—local name and local address. It also insures that TCP/IP is 
properly installed on the current machine. 
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When you invoke Hostinfo, it automatically verifies the TCP stack by:

• retrieving and resolving the local host name

• retrieving and resolving the IP address

To resolve the IP address, Hostinfo tries to communicate using two UDP sockets 
on the same machine. It verifies that the IP address obtained while resolving the 
host name is the same as the actual IP address of this host.

To display the results of a test in the Details box, highlight the test name. 

Note that the Edit menu in Hostinfo allows you to copy all host information to the 
clipboard for sending to support personnel.

Checking TCP/IP Connectivity
Make sure that TCP/IP connectivity is functional on the Controller and Vuser host 
machines. Use a ping utility or type PING hostname from the DOS command line 
to verify communication with a remote machine. Make sure that the remote host 
and Controller machines can ping each other by IP addresses and hostnames. 

Remote Command Launcher 
All remote hosts running on a Windows platform, use a Astra LoadTest Agent to 
accept commands from Astra LoadTest. The Agent is started through the Remote 
Command Launcher placed in you StartUp group during installation. An active 
Remote Command Launcher is indicated by an icon (on the task bar in Windows 
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95 and NT 4.0). If the Remote Command Launcher is not active, invoke it from 
the Astra LoadTest program group. If you upgraded from an earlier version of 
Astra LoadTest, check that all remote hosts have an updated version of the 
Remote Command Launcher. 

Host Connections
To verify the host connectivity, connect to each one of the remote hosts from the 
Controller’s Hosts dialog box. Select the host(s) and click the Connect button. The 
status changes to Connecting.

If the Connection fails, the status changes to Fail and details are written to the 
Details box. Double-click the details box for more information about a failure. 

If a connection succeeds, the status changes to Ready, and the actual platform 
name appears in the Platform box, such as WIN95, WINNT, etc. 
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Failure to Connect to the AUT Database

If you are running a database application, you must ensure that all remote clients 
can connect with the database server. If network or configuration errors occur 
when the client accesses the server, you must correct them before running a 
scenario. To ensure that your client application can connect with the database 
server, perform the following tests.

• Ping

• SQL utilities

Ping: Ensure that the client can communicate with the database server using 
TCP/IP. Use a ping utility or type PING hostname from the DOS command line.

SQL Utilities: Use a simple utility such as ISQL or SQLPLUS to logon to the 
database server and perform several basic operations. 
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Failure to Access Files

An Astra LoadTest scenario will fail if the result path or Vuser script is inaccessible 
to one or more of the participating hosts. Check the following items:

• Vuser Script

• Result Path

Vuser Script: Make sure that the Vuser script is accessible to all hosts 
participating in the scenario through path translation and permissions. View or run 
the Vuser script as a stand-alone on each of the participating hosts. 

Result Path: Make sure that the result path is accessible to all hosts participating 
in the scenario through path translation and permissions. Check the permissions 
of the result directory files and modify them if necessary. 
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Failed Vusers or Transactions

Astra LoadTest Vusers or transactions may fail for a variety of reasons relating to 
the network, database, or actual script. You can find information about scenario 
runs from the following sources:

• Run view

• Output window

• Output file 

• Analysis reports and graphs

Run View
The Run view is part of the Astra LoadTest Controller. The Scenario Groups 
window in the top left-hand corner of the view indicates the status of the Vuser 
groups during and after the scenario run. During the scenario run, the column will 
show a PENDING, INITIALIZING, READY, RUNNING, or RENDEZVOUS status. You can 
also view the status of each individual Vuser in the Vusers dialog box. If a Vuser 
fails and does not complete the script execution, Astra LoadTest displays an error 
status. If a Vuser completes the script some of the transactions may have failed. 
Astra LoadTest indicates the transaction status of a completed script run using the 
DONE.FAILED or DONE.PASSED status. 
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For more information about the Vuser states, see Chapter 11, Running a 
Scenario. 
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Output Window 
View the Output window from the Controller. The output window contains useful 
information for debugging a scenario. The output window lists three types of 
messages: error, warning, and notifications. An error message usually results in 
a failed script. A warning message indicates that the Vuser encountered a 
problem, but test execution continued. A notification provides useful information 
such as recorded think time values and other run-time information. 

For more information about the Output window, see Chapter 12, Viewing 
Vusers During Execution. 
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Output File
For non-GUI Vusers, you can view information about script execution in an output 
file located in the Vuser result directory. The output file, output.txt, contains: 

• a list of the primary functions called during the scenario 

• error messages from the database server 

• transactions and rendezvous information

The extent of the information dumped to the output file, depends on the output file 
settings. In the Virtual User Recorder’s runtime settings, you specify a Brief or 
Extended log. For the Extended log, you can specify a full trace, returned data, or 
current parameter value. An extended log is helpful for debugging a script, but if 
you are not debugging, Extended log is not recommended as it introduces extra 
overhead. For more information about configuring run-time settings, refer to the 
Virtual User Recorder guide.
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The following example is a segment of a log file generated during the recording 
of a database application in Brief mode. 

Start vuser_init.
r:\lr_tests\odbc_f3\jtestf\init.c (16): lrd_open_connection: User="scott", 
Server="hammer"r:\jtestf\init.c (24):  
r:\lr_tests\odbc_f3\jtestf\init.c (44): lrd_stmt: SELECT * FROM DUAL
r:\lr_tests\odbc_f3\jtestf\init.c (47): lrd_fetch: 1 row(s) fetched 
r:\lr_tests\odbc_f3\jtestf\init.c (81): lrd_stmt: commit
End vuser_init. rc = 0
Running Vuser...
Start Actions.
Transaction insert_row started.
r:\lr_tests\odbc_f3\jtestf\run.c (10): lrd_stmt: insert into test2 values 
(’Jim’,102)
Transaction insert_row ended successfully.
At rendezvous: query_rnd.
Transaction query started.
r:\lr_tests\odbc_f3\jtestf\run.c (22):  lrd_stmt: select name, id from test2
r:\lr_tests\odbc_f3\jtestf\run.c (26):  lrd_fetch: 1170 row(s) fetched 
Transaction query ended successfully.
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Analysis Reports and Graphs
You can generate graphs and reports to view information about the scenario run. 
For example, the Scenario Execution report lists information about the 
termination status of each Vuser: PASS, FAIL, or ABORTED. 

The transaction related graphs and reports only list information for successful 
transactions. For information on failed transactions, use the Transaction per 
Second (Failed) graph, the Failed Transaction report, or the Failed Vuser report. 
For more information on the available graphs and reports, see Chapter 18, 
Understanding Astra LoadTest Analysis.  
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Increasing the Number of Vusers on an NT Server

Under the normal settings of an NT server, you are limited to several hundred 
Vusers. This limitation is related to the operating system and not to the CPU or 
memory.

To work around the limitation of the NT operating system, modify the NT Kernel 
as follows:

 1 Save a copy of the registry file in case you have trouble with these modifications. 

 2 Run Regedit.

 3 Go to following key in KEY_LOCAL_MACHINE:

System\CurrentControlSet\Control\Session Manager\SubSystems

 4 Select the Windows key. The default Windows key for NT 4.0 looks like this:

%SystemRoot%\system32\csrss.exe ObjectDirectory=\Windows
SharedSection=1024,3072
Windows=On SubSystemType=Windows ServerDll=basesrv,1 
ServerDll=winsrv:UserServerDllInitialization,3 
ServerDll=winsrv:ConServerDllInitialization,2
ProfileControl=Off MaxRequestThreads=16
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The SharedSection=1024,3072 key has the format xxxx,yyyy where:

xxxx defines the maximum size of the system-wide heap (in kilobytes) 

yyyy defines the size of the per desktop heap.

 5 Increase the SharedSection parameter.

Change the yyyy settings from 3072 to 8192 ( which is 8 MB).

This setup successfully allowed 1250 Oracle Vusers to run on an NT server 
using 2 Pentium PRO 200 MHz with 1 GB RAM. 

Since each Vuser in this setup used approximately 2MB memory, other Vusers 
may require more memory.

We were able to load over 2500 Vusers when we ran the NT terminal server as 
the Operating System and changed the above registry setting.

The above registry changes enable us to run more threads allowing us to run 
more Vusers on the machine. This implies that we are not bound by the NT 
operating system, but only by hardware and internal scalability limitations.
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Working with Firewall Limitations

Working with a Firewall means that you can prevent access to the outside world 
and from the outside world on specific port numbers.

For example, you can specify that there is no access to any port from the outside 
world, with the exception of the mail port (23) or you can specify that there is no 
outside connection to any ports except for the mail port and WEB port (80). The 
port settings are configured by the system administrator.

 uses rcmdl for launching the Agents  (via the PortMapper) on PC machines. 
When the Agent and the Controller are brought up, they look for a free port 
number from the range of free ports reserved for programs. If there is a firewall, 
then the Agent or the Controller may not find a free port. 

Therefore, make sure that the following ports are open:

• The PortMapper port number (111) on the Vuser machines should be open to 
access from the outside.

• The User range on the Vuser and Controller machines should be open to access 
in both directions.

Note that Vusers usually need to access a server machine. A firewall in this case 
also poses a problem: the Vusers will not be able to run the client program at all.
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A

aborting Vusers, See stopping Vusers
Acrobat Reader   14
Activity reports and graphs   276–287
agent

defined   25
settings   340–341
summary window   165

Analysis   239–264
collating results   242
graphs   243
interpreting analysis graphs   335
partial scenario viewing   247
reports   243
starting   241
working with graphs   248
working with reports   257

Analysis data files   268
Analysis reports   244–264
Analysis results   123
application

configuration   35
usage model   37

Astra LoadTest Analysis   240, 335
Astra LoadTest implementation planning   42
Astra LoadTest overview   19–27

emulating human users with Vusers   22
load testing   19
working with Astra LoadTest   26

Astra LoadTest testing process
see Testing process

B

Books Online   14

C

collating scenario results   126
command line options, Vuser script   82
command line parameters, agent   340
communication failure   355
configuring a host   75–78
configuring a script   79–85
connecting to TestDirector server   131
Context Sensitive Help   14

0
Index
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Controller
defined   23
invoking   52
managing scenario files   58
overview   54
quick tour   51–64
selecting LoadTest commands   57

Controller window
Design view   56
icon bar   57
menu bar   54, 57
Output window   56
Run view   56
Scenario Groups window   56
status bar   54
title bar   54

creating Vuser groups   69–74
creating Vuser scripts   29
cross-scenario analysis   310–322

generating cross-scenario graphs   313
graphs types   312
naming result sets   118
overview   311
Percentile Graphs   321
performance summary   318
performing   316
transaction performance   317

D

data files of exported data   268
Data Point

graph(offline)   307
graph(online)   192
report   307

data, exporting   265–275
debug information settings   345
debug level   340
Detailed Transaction (by Vuser) report   306
documentation set   15
Done.Failed - Vuser state   157
Done.Passed - Vuser state   156
Down - Vuser state   156

E

Error - Vuser state   157, 191
Excel file, exporting   262
Exiting - Vuser state   157
expert mode   338–350

entering   339
expert mode settings

debug   345
general   343
output   347
timeout   349

Export analysis data   264, 265–275
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exporting data   265–275
from Analysis window   267
from graph   266
from report viewer   270
to a file   270
to Microsoft Mail   273

F

Failed Transactions report   285
Failed Vuser report   286
files, Vuser script   83
filtering graphs   249

G

granularity   254
graph time   175
graphs

activity   243, 276–287
changing the x axis interval   254
comparing Web Vusers   326
Data Point(offline)   307
Data Point(online)   192
enlarging   252
Hits per Second   324
interpreting analysis graphs   335
Network monitoring   226
Network Monitor-Segement Delay   227

Path Delay   226
Performance   245, 288–309
Performance Under Load   292, 335
Rendezvous   279
Running Virtual Users   278
spreadsheet view   260
Throughput   325
Transaction Distribution   304
Transaction Performance   295
Transaction Performance Summary   300
Transaction Performance Summary by 

Vuser   302
Transactions per Second (failed)   282, 336
Transactions per Second (passed)   281, 

336
viewing specific transactions   249
Web Vusers   246, 323–327
zooming in   252

graphs, See online graphs

H

hardware
checking communications   353
selecting for testing   43–45

heartbeat rate   340
hide a measurement   179, 182
Hits per Second graph   324
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host configuration   75–78
connecting hosts   76
disabling hosts   76
disconnecting hosts   76
enabling hosts   75
initializing quota   78
selecting hosts   72

host list   75–78
Hostinfo utility   355
hosts   25

adding   77
defined   24
modifying   77
selecting   72
setting host attributes   75–78
viewing host details   77

I

initialization quota   78
installing Astra LoadTest, see the Astra 

LoadTest Installation Guide.
interpreting online graphs   329–337
interval, performance under load   293
invoking the controller   52

K

killing Vusers, See stopping Vusers

L

language   341
license

Network monitor   233
lists

host list   75–78
rendezvous list   86–98
script list   79–83
sorting   75
Vuser group list   69–74

load testing, Web   19
Loading - Vuser state   156
location lines   252
lr_user_data_point   192

M

middleware, system configuration   36
monitors

Network   224–237
online   167–169
runtime   191
server resources   195–200
Transaction   193
Web performance   201–223
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N

naming results   118
Network monitoring   224–237

configuring graph   231
determining bottlenecks   229
graphs   226
node   230
opening graphs   236
Path Delay graph   226
Segment Delay graph   227

O

online graphs
configuring   174
exporting   187
interpreting   329–337
sampling rate   174
viewing data offline   188
x-axis style   174

online monitors   167–169, 189–223
configuring graphs   174
configuring measurements   180
graph time   175
graphs   177
interpreting online monitoring graphs   330
line color   180
pausing   179

server resources   195–200
show/hide   179
show/hide lines   182
starting   170
viewing data offline   188
Web performance   201–223

online transaction monitoring
adding transactions   194
graphs   193

online Web performance monitoring
activating the monitors   206
configuring the monitors   207
overview   202
troubleshooting the monitors   222

output file   363
saving messages   101

Output window   56, 64, 161, 362
clearing   163
saving messages to a file   163
viewing Vuser details   163

P

packet size   232
packets, timeout   232
Path Delay graph   226
path translation   85
pausing a monitor   179
Pending - Vuser state   156



Index

Astra LoadTest Controller User’s Guide Page 374

Back

Find

Find

Help

Chapter
Top of

Books
Online

 Again

QE F G H J K LB RPI M N O S T U V W X Y ZA C D

performance analysis, defined   24
performance reports and graphs   288–309
Performance Summary by Vuser report   302
Performance Under Load graph   292, 335
Performance under load interval   293
planning load tests   32–49
policy, rendezvous   92

R

raw data   260
Ready - Vuser state   156, 191
Refresh button   83
relative script paths   81, 84
Remote Command Launcher   25, 356
rendezvous   86–98

attributes   89
disabling Vusers   95
enabling Vusers   95
information   97
overview   87
setting release policy   92
setting the attributes   89
setting the behavior   91
setting the timeout   91

Rendezvous - Vuser state   156
Rendezvous graph   279
Rendezvous points

defined   23
manually releasing Vusers   154

Rendezvous report   279
renumbering Vusers   82
report viewer   258
reports   244–264

activity   243, 276–287
Data Point   307
Detailed Transaction (by Vuser)   306
detailed Vuser   306
displaying   257
Failed Transactions   285
Failed Vuser   286
Performance   288–309
Performance Summary by Vuser   302
Rendezvous   279
Scenario Execution   287
Transaction Performance Summary   300

Resource monitor
activating   196
setup   196

result files   123
results

collating   126
naming   119

results location in TestDirector database   137
Running - Vuser state   156, 191
Running Virtual Users graph   278
runtime graphs   189–194, 330
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S

saving messages to the output file   101
scale of graph   254
scenario activity   277
scenario analysis   239–264
scenario configuration

output file   101
specifying results location   118
timeout intervals   103

scenario execution   61–64, 144–154
controlling individual Vuser Groups   148
controlling individual Vusers   151
delaying   110, 111
limiting duration   111
loading Vuser groups   148
loading Vusers   152
manually releasing Vusers from a 

rendezvous   154
monitoring active Vusers   156
overview   145
running scenarios unattended   146
running Vuser groups   149
stopping Vuser groups   149

scenario execution messages   161
Scenario Execution report   287
scenario performance results   289
scenario results   240

scenarios
closing a scenario   61
collating results   126
configuring   99–106
creating   66–85
creating a new scenario   53, 58
creating a new scenario using the wizard   

53
defined   22
managing scenario files   58–61
opening a scenario   59
opening a scenario from TestDirector   133
preparing to run   116–128
result directory   123
running   61–64, 144–154
saving a scenario   60
scheduling   111
summary information   128
viewing output messages   161

scheduling   107–115
general settings   110
scenarios   111
the Schedule Builder   109
Vuser groups   112
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script list
adding from TestDirector database   139
adding scripts   80
configuring   79–85
modifying script details   79
selecting scripts   68, 73

script list, See also Vuser scripts
script paths, relative   81, 84
segment delay   227
Segment Delay graph   227
selecting scripts for a scenario   68
Server Resource monitor   195–200
settings

agent   340–341
debug   345
debug level   340
general   343
heartbeat rate   340
host   75–78
language   341
output   347
threads   341
timeout   103, 349

show a measurement   179, 182
SNMP monitor   195
sorting

Vuser groups   75
Vusers   152

spreadsheet view   260
spreadsheets   266
Stopped - Vuser state   157
stopping Vuser groups   149
stopping Vusers   152
Support Information   14
Support Online   14

T

TCP/IP setup   355
test objectives

defining   39–41
summary of common objectives   45–49

TestDirector integration   129–142
adding scripts   139
connecting to TestDirector server   131
managing scenarios   140
managing scripts   130
opening a scenario   133
saving results   137
saving scenarios to TestDirector   136

testing process
analyzing test results   31
creating the scenario   30
creating the Vuser scripts   29
planning the test   29
running the scenario   31
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threads, maximum number   341
Throughput graph   325
timeout settings   103
Transaction Distribution graph   304
Transaction monitor   189–194
Transaction Performance graph   295
Transaction Performance Summary by Vuser 

graph   302
Transaction Performance Summary graph   

300
Transaction Performance Summary report   

300
transactions

deciding which to define   42
defined   23
failed   360
filtering in graphs   246

Transactions per Second (failed) graph   336
Transactions per Second (passed) graph   281, 

336
Transactions per Second graph (failed)   282
troubleshooting

controller   351–368

U

user privileges   142
user types   142

user-defined data point   192

V

viewing Vusers   155–165
agent summary   165
output window   161
overview   155

Virtual users, see Vusers
Vuser details, viewing from Output window   

163
Vuser group list   69–74
Vuser groups

creating   69–74
loading Vuser groups   148
modifying   73
running Vuser groups   149
scheduling   112
sorting   75
stopping Vuser groups   149

Vuser list
filtering   152
sorting   152
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Vuser scripts   23
command line options   82
configuring, See also script list
creating   29
defined   23
files   83

Vuser states   156, 191
Vuser window   63
Vusers   22

defined   22
emulating maximum user load   86–98
error and notification messages   161
loading Vusers   152
monitoring   156
renumbering   82
running Vusers   152
stopping Vusers   152
viewing   155–165

W

Web Application Server Resource monitors   
202

BroadVision monitor   216
ColdFusion monitor   219
SilverStream monitor   213
WebLogic monitor   220

Web Server Resource monitors
Apache Server Resource monitor   205
Hits per Second graph   203
Microsoft IIS Server Resource monitor   

205
Netscape Server Resource monitor   205
Throughput graph   204

Web Vuser graphs   323–327
Hits per Second graph   324
Throughput Graph   325

Wizard   53
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Host Resolution Functions Copyright Agreement
Copyright (c) 1980, 1983, 1985, 1987, 1988, 1989, 1990, 1993

The Regents of the University of California.  All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the 
following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the 
following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the 
following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following 
acknowledgement:

 This product includes software developed by the University of California, Berkeley and its contributors.

4. Neither the name of the University nor the names of its contributors may be used to endorse or promote 
products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ‘‘AS IS’’ AND ANY EXPRESS OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE REGENTS OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS 
OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON 
ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE 
OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE.

Portions Copyright (c) 1993 by Digital Equipment Corporation.

Permission to use, copy, modify, and distribute this software for any purpose with or without fee is hereby granted, 
provided that the above copyright notice and this permission notice appear in all copies, and that the name of 
Digital Equipment Corporation not be used in advertising or publicity pertaining to distribution of the document 
or software without specific, written prior permission.
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THE SOFTWARE IS PROVIDED "AS IS" AND DIGITAL EQUIPMENT CORP. DISCLAIMS ALL WARRANTIES WITH 
REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS.   
IN NO EVENT SHALL DIGITAL EQUIPMENT CORPORATION BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, 
OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR 
PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING 
OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Copyright (c) 1996 by Internet Software Consortium.

Permission to use, copy, modify, and distribute this software for any purpose with or without fee is hereby granted, 
provided that the above copyright notice and this permission notice appear in all copies.

THE SOFTWARE IS PROVIDED "AS IS" AND INTERNET SOFTWARE CONSORTIUM DISCLAIMS ALL WARRANTIES 
WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS. IN NO EVENT SHALL INTERNET SOFTWARE CONSORTIUM BE LIABLE FOR ANY SPECIAL, DIRECT, 
INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, 
DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, 
ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.rmission to use, 
copy, modify, and distribute this software for any purpose with or without fee is hereby granted, provided that the 
above copyright notice and this permission notice appear in all copies.

THE SOFTWARE IS PROVIDED "AS IS" AND INTERNET SOFTWARE CONSORTIUM DISCLAIMS ALL WARRANTIES 
WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS. IN NO EVENT SHALL INTERNET SOFTWARE CONSORTIUM BE LIABLE FOR ANY SPECIAL, DIRECT, 
INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, 
DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, 
ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
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