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Before You Install

Welcome to WinRunner, Mercury Interactive’s enterprise functional testing
tool for Windows 95, Windows 98, Windows NT 4.0, and Windows 2000.
This guide describes everything you need to know to install WinRunner on a
standalone computer or on a network. It describes the WinRunner package
contents, system configuration, registration and backup procedures, and
how to run the setup program.

Before you begin to install WinRunner, please review the following pre-
installation procedures.

Registering Your Copy of WinRunner

Register your copy of WinRunner to become a licensed user with all rights
and privileges. Registered users can access technical support and
information on all Mercury Interactive products, and are eligible for updates
and upgrades.

Note: You can register your copy of WinRunner on Mercury Interactive’s
Customer Support site (http://support.merc-int.com).

You can also register your copy of WinRunner by filling out the Mercury
Interactive Software Registration card.

O If you are in the United States, fill out the USA Owners portion of the card.
Send the card to the Sunnyvale, California address printed on the card. No
postage is necessary.

[ If you are outside the United States, fill out the non-USA portion of the
registration card and mail it to the appropriate international address using
correct postage.
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If your address changes, notify Mercury Interactive or your local
representative, so that you can continue to receive product information and

updates.

System Requirements

In order to successfully run WinRunner, you need the following minimum

system requirements:

Platform

Memory

Disk Space

Operating System

An IBM-PC or compatible with a Pentium® /100MHz
or higher microprocessor.

A minimum of 32 MB of RAM memory.

50 MB of free disk space for a compact installation or
120 MB for a typical or complete installation. You may
need an additional 2 to 40 MB on the drive where
Windows is installed, depending on the shared
components already installed on the machine. (An
additional 5 MB of free disk space is required during
the installation process.)

Windows 95, Windows 98, Windows NT 4.0, or
Windows 2000.

Upgrading from a Previous Version

You can install a standalone version of WinRunner over a previous version.
Note that any changes made to the tests in the \/ib directory or in any other
files will be overwritten. However, the existing \lib directory will be backed
up as \lib.bak. Note that if lib.bak already exists, the existing \/ib directory
will not be backed up. You should separately save any files you added or
changed manually before installing WinRunner 6.0 over a previous
WinRunner installation. Note that configuration changes made in the
wrun.ini file will not be overwritten when installing WinRunner 6.0.
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Before You Install

Note: There are documented backward compatibility problems with
Microsoft ODBC 4, which is installed by WinRunner, Microsoft Office 2000,
and other applications. When any of these programs is installed on a
machine where TestDirector 5.0 is installed, TestDirector may behave
unexpectedly.

When upgrading to WinRunner 6.0 or higher, make sure to upgrade to
TestDirector 6.0 or higher, or install the software that installs ODBC 4 on
another machine.

Note that you cannot install WinRunner over WinRunner 2000 or
WinRunner EURO. You must uninstall WinRunner 2000 or WinRunner
EURO before installing WinRunner. For more information, see “Uninstalling
WinRunner” on page 45.

on Windows NT or Windows 2000

If you are installing WinRunner on Windows NT or Windows 2000, mak:
sure you have administrator permissions before you run the setup
program.

Otherwise, you will receive a warning message and the setup program
will close.
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Installing WinRunner

WinRunner is installed with a temporary 30-day license that can only be
installed once on each machine. If you do not install the permanent
software license within 30 days, you will not be able to continue using
WinRunner once the temporary license expires.

You can install WinRunner on a local computer or on a network drive. The
main steps for a WinRunner installation are as follows:

Standalone Installation
Install WinRunner using the Standalone option.
[J If you plan to test a Visual Basic application, configure Visual Basic support.

O Within 30 days of installing WinRunner, install the license server and the
software license.

Network Installation
O Install WinRunner using the Network option.
Run the workstation installation on each user workstation.

[J If you plan to test a Visual Basic application, configure Visual Basic support.

Note: If you add WinRunner add-ins to a network installation after
installing workstations from that network installation, you need to re-run
the workstation setup to update each workstation with the list of available
add-ins.

[0 Within 30 days of installing WinRunner, install the license server and the
software license.
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Running a Standalone or Network Installation

You use the following procedure in order to install WinRunner on a
standalone computer or on a network drive. If you are performing a network
installation, follow the procedure below, and then run the workstation
installation on each user workstation as described on page 16.

To install WinRunner:

1 Insert the CD-ROM into the CD-ROM drive. If the CD-ROM drive is on your
local machine, the WinRunner Setup window opens. If you are installing
from a network drive, connect to it and run autorun.exe under the \setup
subdirectory.

<3 WinRunner Setup

WinRunner’
E'.J Install ik k

=) | in=tan winRunner

Readme
Open Readme file

Browse
Erowse thiz CD

Quick Preview
View a Quick Prevdew of WinRunner

Install License Server

In=tall & network leense server for WinRunner B
Install Software License

In=tall Licenses for using WinRunner MERCURY INTERACTIVE

1[=[0)|©)|m)

If you want to view the Readme file, click Readme. If you want to browse
the WinRunner Installation CD-ROM, click Browse. If you want to open an
overview of WinRunner, click Quick Preview.

2 Click Install. The WinRunner Setup splash screen and the Setup progress bar
open.
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3 The software license agreement is displayed. To install WinRunner, you
must accept the terms of the license agreement by clicking Yes. If you click
No, the setup program will close.

4 In the Registration Information screen, type your name, the name of your
company, and a WinRunner maintenance number. This number can be
found in the Maintenance Pack Number envelope or on the bill of lading
you received when you purchased WinRunner. Note that there is a single
maintenance number for each team of users. (The maintenance number
replaces what was formerly a serial number for each purchased copy of
WinRunner. The maintenance number, which identifies the customer,
determines how many licenses are generated.)

Reagistration Information

Please type pour name, the name of your company and pour
maintenance number. The maintenance number was provided to
you with the WinBunner package.

M ame I

Carnpany I

t aintenance Mumber I

< Back I ik [ I Cancel

Click Next.

5 Click Yes to confirm the registration information.
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6 Do one of the following:

O  To install on a hard disk of a local computer, click Standalone
Installation.

[0  To install on a network drive, click Network Installation.

To install on a network drive and configure your workstation to run
WinRunner from the network, click Network Installation and add
shortcuts to your Start menu.

Note: You cannot install a network installation over a previous version of
WinRunner.

Inztallation Type E2

Select an inztallation type.

™ Metwork Installation

™ Metwork Installation and add shorbcuts bo your Start menu

Once you have selected an installation type, click Mest.

Mate: IF pou add WinRunner add-ins to a netwark installation after
installing warkstations, pou must re-iun the work station setup to
update each wark station with the add-ins.

< Back I Heut » I Cancel

Click Next.
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7 Setup prompts you to install DCOM if you are installing WinRunner on
Windows 95, you do not have DCOM version 4,71,0,2618 installed, and you
are performing one of the following:

[J  astandalone installation

[0 anetwork installation which adds shortcuts to your Start menu

[0 aworkstation installation

Note that DCOM must be installed on your machine in order to install
WinRunner.

If you click Next to install DCOM, the WinRunner setup program closes and
the DCOM installation begins. Once you finish installing DCOM, you must
reboot your computer and then restart the WinRunner setup program.
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8 Choose the type of installation: Typical, Compact, or Custom.

Setup Type E

Click. the type of Setup pou prefer, then click Mest,

Frogram will be installed with the mozt common
optionz. Recommended far most users.

" Compact Frogram will be installed with minimum reguired
options.

" Custom Y'ou may chooze the options you want ta install
Fecommended for advanced users,

< Back I Hewt » I Cancel |

Typical Installation installs commonly used program files, including online
documentation and samples, WebTest add-in support, and add-in support
for PowerBuilder and Visual Basic applications and ActiveX controls. Note
that you can choose which add-ins to load at the beginning of each
WinRunner session. For additional information on loading add-in support,
refer to Chapter 2, “WinRunner at a Glance,” in the WinRunner User’s Guide.

Compact Installation installs only the required WinRunner program files,
without online documentation, samples, WebTest add-in support, or add-in
support for PowerBuilder and Visual Basic applications and ActiveX
controls.

Custom Installation enables you to select which components to install.

Note: When you install a standalone installation of WinRunner, Microsoft
ODBC version 4.0 is installed on your machine.

Click Next.
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9 If you chose Custom Installation, the Select Components screen opens.
Select the components you want to install. You can also specify the
destination folder using the Browse button. To check the space available on
a disk drive, click Disk Space.

Select Components

Select the WinRunner components and add-ing vou want to
install, clear the components you do not want to install

LComponents

Samples 11.1 ME
Orline Dacumentation 335 MB
YWisual Basic 12.0MB
PowserBuilder 05 MB
Activel Controls 0.0 ME
w'ehT est 7AMB

— Destination Folder

D:h . wfinFunner Browsze. . |
Space Required: 113.3 MB S
Space Available: 260.9 MB 4” PR

< Back I Heut » I Cancel |

Click Next.

10
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10 If you chose Typical or Compact Installation the Choose Destination
Location screen opens. Specify the destination folder. To check the space
available on a disk drive, click Disk Space.

Chooze Destin Location E2

Setup will inztall WinBunner it the follawing falder.
Tainztall ta this folder, click Nest.

Tainztal ta a different folder, click Browse and zelect another
falder.

Destination Folder
[ \Program Fileghhercung InteractiveywinRunner

Space Required: 113.3 MB S
Space Available: 260.4 MB ﬂl

< Back Heut » | Cancel |

Click Next.

11
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12

11 If you have Microsoft Internet Explorer version 3.0 or higher installed (or
any other software that installs wininet), you can check the Mercury
Interactive Web site for updated components.

Update Components E2

Setup can how check the Mercuny Interactive web site for
updated components, Would pou like to connect now’?

" |se local update folder

If you choose not to connect, the components will be inztalled
from the CD.

< Back I Heut » I Cancel |

Click Yes to check the Mercury Interactive Web site for updated
components. Click No, if you want to install the components from the CD-
ROM without checking for updated components. Click Use local update
folder only if you know that updated components have already been
downloaded to a folder on your local network. See page 19 for more
information on this option.

Click Next.

12 If you chose Yes in the previous screen, the installation checks the Mercury
Interactive Web site for updated components. If there are components on
the Web site that are newer than components on the CD-ROM, setup
prompts you to overwrite the CD-ROM components with the Web site
components. If no newer components are found on the Web site, then setup
installs all components from the CD-ROM.

If the installation cannot access the Web site, you can click Retry to try to
connect to the Web site again. If you click Cancel, setup installs the
WinRunner components from the CD-ROM.
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13 If you selected Network Installation and add shortcuts to your Start menu
earlier in the setup, the Choose local WinRunner Folder screen opens. Select
a location for the local WinRunner folder. This folder will allow you to
configure WinRunner to meet your specific testing requirements, while
running a shared version over the network.

Choosze Local WinRBunner Folder

WfinBunner will uze the following folder to store configuration filez
that you create during the testing process.

To accept thiz folder, click Mest.

To chooze a different folder, click Browse and select another
falder.

" Local winRunner Folder

D% AwinFunnerlocal Browze.. |

< Back Cancel |

Click Next.

13
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14 Choose the location of your WinRunner temporary folder.

Choose WinRBunner Temporary Folder E

WinFunner will stare temporary files in the following folder.

To accept thiz folder, click Mext.

To choose a different folder, click Browse and select another
folder.

Make zure you have write permizzion for the folder.

Db SwinRunnerstmp Brawse... |
Cancel |

"Winﬂ unner Temporarg Folder

< Back

Click Next.

15 Review the settings you selected. To select different settings, click Back. To
confirm the settings, click Next.

The installation process begins. To pause or quit the installation process,
click Cancel.

14
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16 Select the program folder for the WinRunner icons.

Select Program Folder E2

Setup will add program icons ta the Program Folder listed below.
You may type a new folder name, or zelect one from the Existing
Falders lizst. Click. Mest to continue.

Program Folder:

WinRunner

Episting Folders:

3Com NIC Utilities -
ACceszones

ACD Spstems

ActivePerl

Adobe

Adobe Acrobat 4.0

ADL Instant Meszenger [Sk)]

Data Junction 6.5

erceed

e¥ceed System Administration j

[ ndie VN PY

< Bach I Hewt » I Cancel |

Click Next to proceed.

17 The installation settings you selected are displayed in a read-only window.
Review the settings. If you want to select different settings, click Back. If you
are satisfied with the settings, click Next.

18 The installation process begins. To pause or quit the installation process,
click Cancel.

19 Read the information about accessing online documentation. If you
installed add-in support for Visual Basic applications, additional
information appears on your screen. Click Next to proceed.

20 Read the information about Mercury Interactive’s Customer Support. Click
Next.

21 The installation process is complete.

22 Restart your computer.

15
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Note: If you try to start WinRunner before restarting your computer,
WinRunner will not run properly.

Note: If you installed WinRunner on Windows NT or Windows 2000,
then after restarting your computer, you must log in (for the first time)
with the same login name that was used when installing WinRunner.

If you installed WinRunner on the network, run a workstation installation
on all workstations. See the next section for details.

To read any last-minute information, click Start > Programs > WinRunner >
Read Me. The Readme file opens in Microsoft Wordpad.

To view the WinRunner online books, you must have Acrobat Reader 4.0
installed. You can install it by clicking Start > Programs > WinRunner >
Documentation > Acrobat Reader Setup and following the on-screen
instructions. To view online books, click Start > Programs > WinRunner >
Documentation > WinRunner Books Online.

g O To start WinRunner, click Start > Programs > WinRunner > WinRunner.

Running a Workstation Installation

16

A workstation installation should be performed for each user running
WinRunner from the network. This installation can be performed only after
the network installation is successfully completed.

Click Start > Run.
Type <network installation_directory>\setup\setup.exe and click OK.

The WinRunner setup program starts. The WinRunner Setup splash screen
and the Setup progress bar open.

The software license agreement appears. To install WinRunner, you must
accept the terms of the license agreement by clicking Yes. If you click No,
the setup program will close.
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10

Installing WinRunner

In the Registration Information dialog box, type your name and click Next.
Click Yes to confirm the registration information.

Confirm the Workstation Installation message and click Next.

Define the location for the local WinRunner folder.

The WinRunner folder on your hard drive is used to store configuration files
you create during the testing process. Configuration files in this folder
override configuration files of the same name on the network, so that you
can configure WinRunner to your specific testing requirements.

Click Next.

Select the location of your WinRunner temporary folder.
Setup updates and installs system files.

Click Next.

Select the program folder for the WinRunner icons.
Click Next.

Restart your computer.

Note: If you try to start WinRunner before restarting your computer,
WinRunner will not run properly.

Note: If you installed WinRunner on Windows NT or Windows 2000,
then after restarting your computer, you must log in (for the first time)
with the same login name that was used when installing WinRunner.

17
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18

The WinRunner program folder is added to your Start menu.

O To read what’s new in WinRunner and any last-minute information, click
Start > Programs > WinRunner > Read Me. The Readme file opens in
Microsoft Wordpad.

[0 To view the WinRunner online books, you must have Acrobat Reader 4.0
installed. You can install it by clicking Start > Programs > WinRunner >
Documentation > Acrobat Reader Setup and following the on-screen
instructions. To view online books, click Start > Programs > WinRunner >
Documentation > WinRunner Books Online.

g O To start WinRunner, click Start > Programs > WinRunner > WinRunner.
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Using a Local Network Drive for Updates

You can download WinRunner installation updates from the Mercury
Interactive Web site to a network drive and then access the local network
drive to update your WinRunner installations.

To download updates to a local network drive:

1 Insert the CD-ROM into the CD-ROM drive and run <CD drive>\update.exe.

2 The Download Updates screen opens.

Download Updates E2

Setup will now download and zave allwinBunher updates.
Pleasze zelect the path where the updates will be saved and click
Mest.

LAwWR_Update

" Destination Folder

< Back | Heut » | Cancel |

Choose the local network drive for the WinRunner update files. Click Next.

3 Setup begins to download the files. When the download is complete, the
Updates Download Complete screen opens. Click Finish.

19
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Note: When you run update.exe, the program downloads all posted updates,
regardless of their contents and versions. When installing updates from a
local path, however, the setup program downloads in the same way as it
downloads from the Web site, installing only those components that are
part of the current installation and newer than the components on the CD.

Once the updates have been downloaded to a local network drive, you can
link to that drive from the WinRunner installation in order to download the
updates locally.

To download updates from a local network drive:

When the Update Components screen of the WinRunner installation opens,
select Use local update folder.

Update Components E2

Setup can how check the Mercuny Interactive web site for
updated components, Would pou like to connect now’?

& |lse lncal update folder

If you choose not to connect, the components will be inztalled
from the CD.

< Back I Heut » I Cancel
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2 The Select Downloaded Updates Path screen opens.

Select Downloaded Updates Path E2

Pleaze zelect the path where the downloaded updates are
zaved.

Destination Folder
’1: R _Update

< Back | Hewt » | Cancel |

Use the Browse button to select the path where the updates are stored. Click
Next. The installation program checks the specified network folder for
updated components. If there are components in the update folder that are
newer than components on the CD-ROM, setup prompts you to overwrite
the CD-ROM components with the update folder components. When the
check is complete, the installation program continues as described in step
13 on page 13.

21
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Configuring Visual Basic 4.0 Support

22
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8

Before you can start using WinRunner's extended support for Visual Basic
4.0 in Windows 95, Windows 98, Windows NT, or Windows 2000 Visual
Basic applications (32-bit), you need to compile the WinRunner OCX
(wrvb40.o0cx) in the application under test.

To configure 32-bit Visual Basic 4.0 support:
Start Visual Basic 4.0 and open the project.
Select Tools > Custom Controls.

In the Custom Controls dialog box, select the Wrvb40 OLE Custom Control
Module item. Click OK. The item is added to the toolbar.

Drag the new item onto the main application form.

Right-click this object and select View Code.

Select Object > Form.

Insert the following line into the beginning of the Form_Load function:

Wrvbl.Init Forms

For example:

Private Sub Form Load ()
Wrvb1l.Init Forms
End Sub

Run or recompile your application and run the .exe file.
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Configuring Visual Basic 5.0 and 6.0
Support

WinRunner’s add-in support for Visual Basic 5.0 and 6.0 applications
includes all the support provided for Visual Basic 4.0 applications, plus:

[0 all standard Visual Basic 5.0 and 6.0 controls

[ Visual Basic projects that create ActiveX controls

Preparing Your Visual Basic Application

Before you can start testing a Visual Basic application using WinRunner’s
add-in support for Visual Basic 5.0 and 6.0, the application developer must
add the WinRunner agent to the application. To do so, the developer runs
the setup.exe program from the \vbdev directory on the WinRunner
installation CD-ROM.

Note that if the application currently references the WinRunner OCX, you
must first remove all references from forms, as well as the associated code
(Wrb1.Init Forms).

The WinRunner agent installation installs an AddIn to your Visual Basic
IDE. The name of this AddIn is WinRunnerAddIn.Connect. It adds lines of
code to your Visual Basic source code.

WinRunnerAddIn.Connect

O adds a reference to the wrvbasr.dll component

O adds a new code Module to the Visual Basic project called
“WinRunnerSupport”

[0 adds a line to the WinRunnerSupport Module:
Global asr As New WRVBASRLib.VbMod

23
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24

[J adds code to the StartUp object:

If the Startup Object is a Form, the AddIn adds the following line of code to
the Form_Load event: asr.Init Forms

If the Startup Object is Sub Main, the AddIn adds the following line of code
to the Main() method: asr.Init Forms

For all Class modules in the project, the AddIn adds the following line of
code to the Class_Intialize event: asr.Init Forms

For all UserControl modules in the project, the AddIn adds the following
line of code to the UserControl_Intialize event: asr.Init Forms, UserControl

For all UserDocument modules in the project, the AddIn adds the following
line of code to the UserControl Intialize event: asr.Init Forms, UserDocument

Notes: If the error message “DIIRegisterServer in <windows
directory>\system \wrvbasr.dll failed” appears during the WinRunner agent
installation, copy the file oleaut32.dll (version 2.20.4054.1 or higher) to
your system directory and re-install the WinRunner agent.

Do not run WinRunner and the Visual Basic IDE together.

Test your application only as a running executable.
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Enabling Table Contents Checks for an
ActiveX Control

To enable support for contents verification on any ActiveX control that can
be viewed as a table object, you must implement a capture function for the
ActiveX control in Visual Basic and then execute a TSL function.

WinRunner includes Visual Basic project files (wrvbsrv4.vbp for Visual Basic
4.0 and wrvbsrv5.vbp for Visual Basic 5.0 and 6.0) that compile into an OLE
Automation Server. WinRunner uses this server to capture table contents.

Follow these steps to enable contents verification on an ActiveX control that
can be viewed as a table object:

1 Start Visual Basic 4.0/5.0/6.0.

2 In Visual Basic, open the appropriate wrvbsrv project file (wrvbsrv4.vbp or
wrvbsrv5.vbp) located in the WinRunner installation folder under
custom\wrvbsrv.

3 Open capture.cls and add a Sub with the following prototype:
Public Sub<CaptureFunctionName>(ByVal <tab_ctrI> As Object, ByVal
<file_name> As String)
The function should dump the table contents of the ActiveX control into
<file_name> in the following format:

cells separated by Tab(Chr(9)), rows separated by Newline.

Note: Cell data should not contain escape characters such as Tabs or
Newlines. Cells in the first row (Column Titles) should not contain either
escape characters or space characters. See the MSGridCapture Sub for an
example.

25
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4 Compile the project into a .dll.
For Visual Basic 4.0, from the File menu select Make OLE DLL file.

For Visual Basic 5.0 or 6.0, from the File menu select Make WRVBSRV DLL
file.

5 In WinRunner, execute the add_table_capture_function statement. Set the
second argument to the name of the Sub you implemented in the Visual
Basic function. For example:

add_table_capture_function ("MSGrid.Grid", "MSGridCaptureFunc");

26
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Installing the License Manager

You can install WinRunner on as many machines as you want. However,
WinRunner’s license server regulates the number of copies of WinRunner
that are allowed to run concurrently. The license manager lets you run at the
same time the number of copies of WinRunner you have purchased. You can
increase the number of copies of WinRunner you can run at the same time
by purchasing additional copies of WinRunner from Mercury Interactive.

When you install WinRunner for the first time, it includes an automatic 30-
day temporary license. During this time period, you must contact Mercury
Interactive’s Customer Support Organization to obtain a permanent license.
Obtaining a permanent license consists of two main steps:

installing the license server
O installing the software license

Once you install the license server and install the software license, your
permanent license overrides your temporary license(s).

Note: Do not change the date on a computer running WinRunner with a
temporary license.

27
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Installing the License Server

28

We recommend that you install the license server on a machine that is
running the Windows NT 4.0 Server.

You should install the license server on a machine that also meets the
following criteria:

has a fixed IP address, i.e., it is not a laptop

has TCP/IP installed

Note: To ascertain that TCP/IP is installed and functioning propetly, you can
check that another machine on the network can identify the machine
where you plan to install the license server. On another machine, click
Start > Run. In the Open box, type “ping [name of the machine where the
license server will be installed]”. Click OK. If the first machine can identify
the second machine on the network, an MS-DOS window opens and four
successful reply messages appear. If the first machine cannot identify the
second machine on the network, an MS-DOS window opens, but there are
no successful reply messages.

Note that once you have installed the license server, it must be running
whenever you use WinRunner.
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To install the license server:

1 Insert the CD-ROM into the drive from which you want to install. If the CD
drive is on your local machine, the WinRunner Setup window opens. If you
are installing from a network drive, connect to it and run autorun.exe under
the \setup subdirectory.

<3 WinRunner Setup

WinRunner
2] | 1nstan ik k

=l ;nstan winRunner

Readme
Open Feadre file

Browse
Browse this CL

Quick Preview
Wiew a Quick Preview of WinRunner

Install License Server

Install a network license serwer for WinFunner -
Install Software License

Install Licenses for using WinRunner MERCUEY INTERACTIVE

][ [0)|©)| )

2 Click Install License Server.
3 The SentinelLM Server setup program starts.

4 Make sure that you have exited all Windows programs. Click Next to
proceed.
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5 Specify the destination folder. To choose a different destination, click
Browse.

Location E

Setup will inztall SentinglLt Server in the following folder.
Tainztall ta this folder, click Nest.

Tainztal ta a different folder, click Browse and zelect another
falder.

“r'ou can chooge not to install Sentinellk Server by clicking
Cancel to exit Setup.

Db hzentLMA\S erver Browse... |
Cancel |

" Destination Folder

< Back

Click Next to proceed.

The installation process begins. To pause or quit the installation process,
click Cancel.

6 Click Finish to complete the installation process.

Once you have installed the license server, you must run the software
license installation in order to obtain your permanent license.
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Installing the Software License

Once the license server is installed, you must run the software license
installation in order to obtain your permanent license. Installing the
software license consists of two main stages:

O using the maintenance number to create information which is sent to
Mercury Interactive’s Customer Support Organization

O entering the license code provided by Mercury Interactive’s Customer
Support Organization

If you are installing a network license, you must install the software license
on the license server. If you are installing a standalone license, you can
install the software license on the machine where you want to run
WinRunner.

Note: If you are installing a network license on Windows 95, you should
restart your license server before installing the software license.
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To install the software license:

1 Insert the CD-ROM into the drive from which you want to install. If the CD
drive is on your local machine, the WinRunner Setup window opens. If you
are installing from a network drive, connect to it and run autorun.exe under
the \setup subdirectory.

£3 WinRunner Setup

WinRunner’
Install T k

Install WinRunner

Readme
Open Readme file

Browse
BErowse this CO

Quick Preview
Yiew a Quick Preview of WinRunner

Install License Server

In=tall a network Heense server for WinRunner -
Install Software License

In=tall Licenses for using wWinRunner MERCUEY INTERACTIVE

1[=0)©)|mfa

2 Click Install Software License.
3 The WinRunner Software License Installation program starts.

Make sure that you have exited all Windows programs. Click Next to
proceed.
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4 The User Information screen opens.

WinRunner Software License Installation - Usger Information E

Tupe in below vour name and your compary name. v'ou must alzo
twpe in your maintenance number [this number was shipped to you

WinRunner® BT

First Hame: Last Hame:

LCompany:

Maintenance Mumber:

< Back I i [ I Cancel

Enter your first name, last name, and company name in the appropriate
boxes. In the Maintenance Number box, enter your maintenance number,
which you received from Mercury Interactive when you purchased
WinRunner. This number can be found in the Maintenance Pack Number
envelope or on the bill of lading. Note that there is a single maintenance
number for each team of users. The maintenance number replaces what was
formerly a serial number for each purchased copy of WinRunner. The
maintenance number, which identifies the customer, determines how many
licenses are generated.

Click Next to proceed.
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5 The Permanent License Type screen opens.

WinRBunner Software License Installation - Permanent License Type E2

WinRunner’

WinRunner requires a Software Licensze to work, Hetwork-bazed
Licenze Servers are the preferred licenzing method, as they allow
ary maching on the network to uze the installed licenzes. Pleaze
zelect the type of licenze you wish to Lze:

" Stand-alone License

Thiz type of a license iz locked' ta the current maching, and
cannot be used on any other machine, & stand-alone icenze
will only be granted if vou have problems using a netwark
software license,

{* Metwork License

Metwork icenzes can be uzed by any maching connected to
the zerver. MOTE: To use network, licenses, pou must first
inztall a Licenze Server, and then request and install the
network licenses on the network License Server machine.

Cahicel

WinRunner’s license server requires either a standalone license or a network
license. A network license enables you to run WinRunner on any machine

on your network. A standalone license enables you to run WinRunner only
on one specific machine. A standalone license will be issued only if you are

unable to use a network software license. Unless instructed otherwise by
Mercury Interactive’s Customer Support Organization, choose Network

License (the default setting).

Click Next to proceed.
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6 Send all the information that appears in the read-only box to your local
Mercury Interactive Customer Support office. You may contact your local
organization by phone or e-mail. It may be easiest to copy the information
from this screen and paste it into an e-mail message.

WinRunner Software License Installation - Details

Pleaze contact the local Mercury Interactive, Inc. Customer
Support office. vou will be azked for the following information;

o B
WinRunner®
Product Name : WinFunner ;I
Maintenance Number : 1840-1234E5672
Locking Code : B-3E335
Authorization Type @ Permanent
License Type : Network License

" o

Upan completion of your telephone registration process, the
Cugtomer Support Engineer will either give pou a Licenze Code, or
zend you a code later. Please enter the License Code in the box
below.

Licenze Code:

| < Back I Hewt = I Cancel

7 Mercury Interactive’s Customer Support Organization will provide you with
the license code, which you should insert into the License Code box.

Note: If you do not receive the license code immediately from Mercury
Interactive, you can click Cancel to quit the installation. You can run the
installation again, using the above steps, once you receive the license code.

8 Click Next to proceed.

The installation program is complete.
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When the License Manager is functioning properly, WinRunner detects the
license automatically: You should not receive any messages about your
licenses. However, the first time you start WinRunner after installing the
license server, you may receive one of the following messages:

"The software license in use will expire in x days."

"The software license in use expires today!"

"This is a 30-day evaluation version of the product.”

"Click the Retry button to search for a permanent license on the network, or click
Cancel to work with current license."

If you receive one of these messages, click Retry. Once WinRunner finds the
permanent license that you have installed, you should not receive any more
messages.

Note: If you receive messages after installing the License Manager, please see
“Troubleshooting” on page 37. If you are still having difficulties, please
contact Mercury Interactive’s Customer Support Organization for assistance.




Troubleshooting

Installing the License Manager

I do not receive any error messages, but when | start
WinRunner, | receive one of the following temporary license

messages:

"The software license in use will expire in x days."

"The software license in use expires today!"

"This is a 30-day evaluation version of the product.”

"Click the Retry button to search for a permanent license on the network, or click

Cancel to work with current license."

Problem: WinRunner is not identifying the host license server, and is still
using the temporary license. There could be several explanations for this:

Explanation

Solution

You used WinRunner with the
temporary license before you installed
the license server with the proper
software license. WinRunner is not
searching the network for the software
licenses.

Click Retry. WinRunner will search the
network for the license server and the
permanent license.

You installed the license server (host)
on a different subnet mask from one or
more client machines running
WinRunner. WinRunner is not
searching outside the subnet for the
License Manager.

Check that the client machine
(running WinRunner) can identify the
host (license server) on the network. In
the client machine, click Start > Run.
In the Open box, type “ping [name of
the machine with the license server
installed]”. Click OK. If the client can
identify the host on the network, an
MS-DOS window opens and four
successful reply messages appear. If the
client cannot identify the host on the
network, an MS-DOS window opens,
but there are no successful reply
messages.
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If the client is connected to the network, but cannot identify the host, they
may be in different subnets. In order for the client to see the host, you must
make the following change in the client machine:

If the client machine is running Windows NT:

1 Click Start > Settings > Control Panel.

Double-click System.

The System Properties dialog box opens.

3 Click the Environment tab.

In the Variable box, type “LSHOST”.

5 In the Value box, type the full name of the license server. Alternatively, you

may enter the IP address of the host machine.

Note: For multiple host names (i.e., where there are multiple WinRunner
license servers running on one network), use a colon (:) to separate the
hosts’ names or IP addresses in the Value box.

Click Set.

7 Click OK.

If the client machine is running Windows 95 or Windows 98:
Click Start > Run.

In the Open box, type “sysedit”.

The System Configuration Editor opens, displaying 5 systems files.
Make the following addition to the AUTOEXEC.BAT file:

Set LSHOST=[full name of server]

Alternatively, you may substitute the IP address of the host machine.
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Note: For multiple host names (i.e., where there are multiple WinRunner
license servers on one network), use a colon (:) to separate the hosts’ names
or IP addresses in the Value box.

Save and close the AUTOEXEC.BAT file.

I want to turn off or reset the license server.

If you want to reset the license server, we recommend rebooting the
machine. You can also turn off the license server without rebooting the
machine by following the instructions below:

Note that the license server starts at startup on the host machine.

To turn off the license server if the host machine is running Windows NT
4.0:

Click Start > Settings > Control Panel.

Double-click Services.

Note that “SentinelLM” appears in the Service list in the Services dialog
box.

3 Highlight “SentinelLM” and click Stop.

To restart the license server, highlight “SentinelLM” and click Start.

To turn off the license server if the host machine is running Windows 95:

Note that SentinelLM appears in the taskbar. Right-click on the icon and
click Close on the pop-up menu.

To restart the license server, reboot your machine.
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Note: We do not recommend running the license server on a machine
running on Windows 95 or Windows 98. We recommend running the
license server on a machine running on the Windows NT 4.0 Server.

License Management Utilities

40

WinRunner’s License Manager includes three utilities that assist you in
managing your WinRunner licenses. The license management utilities can
be found in the WinRunner CD-ROM\LicenseManager\utils folder.

Displaying Current WinRunner Users

LSMON

You can run the LSMON utility on a client machine (running WinRunner) or
the host machine (the license server). It is a DOS-based program that
displays:

the maximum number of concurrent WinRunner users allowed by the
license

the number of machines currently running WinRunner

[ the IDs of the machines currently running WinRunner

the number of WinRunner licenses currently not in use

Note: To run the LSMON utility from a client machine and display
information for all the machines in the network, type “LSMON «<license
server host name>".




O 0o o d

Installing the License Manager

WLSQUERY

You can run the WLSQUERY utility on a client machine (running
WinRunner) or the host machine (the license server). The WLSQUERY
utility is effective only in cases where multiple WinRunner license servers
are running. It is a Windows-based program that displays:

the maximum number of concurrent WinRunner users allowed by the
license

the number of machines currently running WinRunner
the IDs of the machines currently running WinRunner
the number of WinRunner licenses currently not in use

the host name of the WinRunner license server from which the client is
currently running WinRunner

Displaying License Servers

LSWHERE

You can run the LSWHERE utility on a client machine (running WinRunner)
or the host machine (the license server). It is a Windows-based program that
displays the network names of all machines running WinRunner license
servers.
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Uninstalling the License Server
If you uninstall the license server, you will not be able to use WinRunner.

To uninstall the license server:

1 Click Start > Settings > Control Panel.

2 Double-click Add/Remove Programs.
The Add/Remove Programs dialog box opens.

3 In the Install/Uninstall tab, select “SentinelLM”.

4 Click Add/Remove.
If you want to uninstall the license manager in order to reinstall it on a
different machine, you must follow the directions described above in
“Installing the License Server” on page 28 and “Installing the Software
License” on page 31 for your new machine. You must contact Mercury

Interactive’s Customer Support Organization in order to receive a new
license code for the machine on which you want to install the license server.
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Adding WinRunner Components

Once you install WinRunner, you can run the setup program at any time to
add program components, such as an additional development environment
or control support, samples, or online documentation.

To add components:

1 Insert the CD-ROM into the drive from which you want to add WinRunner
components. If the CD drive is on your local machine, the WinRunner
Setup window opens. If you are installing from a network drive, connect to
it and run autorun.exe under the \setup subdirectory.

2 Click Install. The WinRunner setup program starts. The WinRunner Setup
splash screen and the Setup progress bar open.

3 The software license agreement appears. To accept the terms of the license
agreement, click Yes. If you click No, the setup program will close. To install
additional WinRunner components, you must accept the license agreement.

4 In the User Information dialog box, type your name, the name of your
company, and a WinRunner maintenance number. You can find this
number on the outside of your WinRunner box. Click Next to proceed.

5 Click Yes to confirm the registration information.

6 Select your installation type: Standalone Installation, Network Installation,
or Network Installation and add shortcuts to your Start menu. Click Next to
proceed.

7 Choose Custom Installation. Click Next to proceed.

8 Select the components you want to install and specify the destination
folder. Click Next to proceed.

9 Select Yes, No, or Use local update folder to set your update components
preferences. Click Next to proceed.
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10 If you select a component that is already installed, you are prompted to

11

12
13
14

overwrite it. To overwrite existing components of WinRunner, click the
Overwrite button. If you do not want to overwrite existing components of
WinRunner, click Cancel. The previous window reopens and you can
modify your selection.

If you chose Network Installation and add shortcuts to your Start menu in
step 6, select a location for the local WinRunner folder. Click Next to
proceed.

Select a location for temporary WinRunner files. Click Next to proceed.
Select a program folder for WinRunner icons. Click Next to proceed.

The installation settings you selected are displayed in a read-only window.
Review the settings. If you want to select different settings, click Back. If you
are satisfied with the settings, click Next.

The installation process begins.

To pause or quit the installation process, click Cancel.
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Uninstalling WinRunner

Your WinRunner installation includes an uninstall program that uninstalls
WinRunner software and files from your computer and removes WinRunner
shortcuts from your Start menu.

To uninstall WinRunner:
1 Click Programs > WinRunner > Uninstall WinRunner on your Start menu.
The Uninstall Shield window opens.

2 You may be prompted to remove shared files that are not in use by any
program. If you are not sure what to do, click No to All.

UninstallShield removes WinRunner from your computer.

3 When the Uninstall program is completed, the OK button is enabled. Click
OK.

4 You must reboot your machine to complete the uninstall process or before
reinstalling WinRunner.

45



WinRunner Installation Guide

46






i

MERCURY INTERACTIVE

Mercury Interactive Corporation
1325 Borregas Avenue
Sunnyvale, CA 94089 USA

Main Telephone: (408) 822-5200
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