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Before You Install

Checking

O 0o o o o o

Welcome to WinRunner, Mercury Interactive’s enterprise functional testing
tool for Windows 95, Windows 98, and Windows NT 4.0. This guide
describes everything you need to know to install WinRunner on a
standalone computer or on a network. It describes the WinRunner package
contents, system configuration, registration and backup procedures, and
how to run the setup program.

Before you begin to install WinRunner, please review the following pre-
installation procedures.

Your WinRunner Package

Please make sure your WinRunner package contains the items below. If any
item is missing or damaged, contact Mercury Interactive or your local
distributor.

Program Disks

Your WinRunner package contains 1 CD-ROM.

Documentation

In addition to this installation guide, your WinRunner package contains the
following printed materials:

WinRunner Tutorial

WinRunner User’s Guide
WinRunner Customization Guide
WebTest User’s Guide

TSL Reference Guide

Registration Card
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Registering Your Copy of WinRunner

Register your copy of WinRunner to become a licensed user with all rights
and privileges. Registered users can access technical support and
information on all Mercury Interactive products, and are eligible for updates
and upgrades.

To register your copy of WinRunner, fill out the Mercury Interactive
Software Registration card.

O If you are in the United States, fill out the USA Owners portion of the card.
Send the card to the Sunnyvale, California address printed on the card. No
postage is necessary.

[ If you are outside the United States, fill out the non-USA portion of the
registration card and mail it to the appropriate international address using
correct postage.

If your address changes, notify Mercury Interactive or your local
representative, so that you can continue to receive product information and
updates.

Note: You can also register your copy of WinRunner on Mercury
Interactive’s Customer Support site (http://web.merc-int.com).
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System Requirements

In order to successfully run WinRunner, you need the following minimum
system requirements:

Platform An IBM-PC or compatible with a Pentium® /100MHz
or higher microprocessor.

Memory A minimum of 32 MB of RAM memory.

Disk Space 50 MB of free disk space for a compact installation or

120 MB for a typical or complete installation. You may
need an additional 2 to 40 MB on the drive where
Windows is installed, depending on the shared
components already installed on the machine. (An
additional 5 MB of free disk space is required during
the installation process.)

Operating System Windows 95, Windows 98, or Windows NT 4.0.

Upgrading from a Previous Version

You can install a standalone version of WinRunner over a previous version.
Note that any changes made to the tests in the \lib directory or in any other
files will be overwritten. However, the existing \lib directory will be backed
up as \lib.bak. Note that if lib.bak already exists, the existing \/ib directory
will not be backed up. You should separately save any files you added or
changed manually before installing WinRunner 6.0 over a previous
WinRunner installation. Note that configuration changes made in the
wrun.ini file will not be overwritten when installing WinRunner 6.0.

Note that you cannot install WinRunner over WinRunner 2000 or
WinRunner EURO. You must uninstall WinRunner 2000 or WinRunner
EURO before installing WinRunner. For more information, see “Uninstalling
WinRunner” on page 27.
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Installing on Windows NT

If you are installing WinRunner on Windows NT, make sure you have
administrator permissions before you run the setup program.
Otherwise, you will receive a warning message and the setup program
will close.
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Installing WinRunner

You can install WinRunner on a local computer or on a network drive.
Following are the main steps for a WinRunner installation:

Standalone Installation
[J Install WinRunner using the Standalone option.

[J If you are testing a Visual Basic application, configure Visual Basic support.

Network Installation
0 Install WinRunner using the Network option.
[0 Run the workstation installation on each user workstation.

If you are testing a Visual Basic application, configure Visual Basic support.

Note: If you add WinRunner add-ins to a network installation after
installing workstations from that network installation, you need to re-run
the workstation setup to update each workstation with the list of available
add-ins.
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To install WinRunner:

1 Insert the CD-ROM into the CD-ROM drive. If the CD-ROM drive is on your
local machine, the WinRunner Setup window opens. If you are installing
from a network drive, connect to it and run autorun.exe under the \setup
subdirectory

£3 WinRunner Setup

WinRunner |
Install k

Inztall ‘WinRunner

Readme
Open Readme file

Browse
Brovwse thiz CD

g
Quick Preview
Yiew a Quick Preview of WinRunner

MERCURY INTERACTIVE

0)|&)| |k

If you want to view the Readme file, click Readme. If you want to browse
the WinRunner Installation CD-ROM, click Browse. If you want to open an
overview of WinRunner, click Quick Preview.

2 Click Install. The WinRunner Setup splash screen and the Setup progress bar
open.

3 The software license agreement is displayed. To install WinRunner, you
must accept the terms of the license agreement by clicking Yes. If you click
No, the setup program will close.
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4 In the Registration Information screen, type your name, the name of your
company, and a WinRunner maintenance number. This number can be
found in the Maintenance Pack Number envelope or on the bill of lading
you received when you purchased WinRunner. Note that there is a single
maintenance number for each team of users. (The maintenance number
replaces what was formerly a serial number for each purchased copy of
WinRunner. The maintenance number identifies the customer.)

Registration Information E

Pleaze type your hame, the name of your company and pour
maintenance number. The maintenance number vwas provided to
you with the WinRunner package.

Mame I

Compary I

taintenance Mumber I

< Back I Hewt = I Cancel

Click Next.

5 Click Yes to confirm the registration information.
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6 Do one of the following:

O  To install on a hard disk of a local computer, click Standalone
Installation.

[0  To install on a network drive, click Network Installation.

To install on a network drive and configure your workstation to run
WinRunner from the network, click Network Installation and add
shortcuts to your Start menu.

Note: You cannot install a network installation over a previous version of
WinRunner.

Installation Type E

Select an inztallation type.

 MNetwaork Installation

™ Metwork Installation and add shorbcuts bo your Start menu

Once you have selected an installation type, click Mest.

< Back I Heut » I Cancel

Click Next.



Installing WinRunner

7 If you are installing WinRunner in Windows 95, and you do not have
DCOM version 4,71,0,2618 or higher installed on your machine, you will be
prompted to install it if you are performing one of the following
installations:

[0 astandalone installation

[0 anetwork installation which adds shortcuts to your Start menu

0  a workstation installation

Note that DCOM must be installed on your machine in order to install
WinRunner.

If you click Next to install DCOM, the WinRunner setup program closes and
the DCOM installation begins. Once you finish installing DCOM, you must
reboot your computer and then restart the WinRunner setup program.
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8 Choose the type of installation: Typical, Compact, or Custom.

Setup Type E

Click. the type of Setup pou prefer, then click Mest,

Frogram will be installed with the mozt common
optionz. Recommended far most users.

" Compact Frogram will be installed with minimum reguired
options.

" Custom Y'ou may chooze the options you want ta install
Fecommended for advanced users,

< Back I Hewt » I Cancel |

Typical Installation installs commonly used program files, including online
documentation and samples, WebTest add-in support, and add-in support
for PowerBuilder and Visual Basic applications and ActiveX controls. Note
that you can choose which add-ins to load at the beginning of each
WinRunner session. For additional information on loading add-in support,
refer to Chapter 2, “WinRunner at a Glance,” in the WinRunner User’s Guide.

Compact Installation installs only the required WinRunner program files,
without online documentation, samples, WebTest add-in support, or add-in
support for PowerBuilder and Visual Basic applications and ActiveX
controls.

Custom Installation enables you to select which components to install.

Note: When you install a standalone installation of WinRunner, Microsoft
ODBC version 4.0 is installed on your machine.

Click Next.
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9 If you chose Custom Installation, select the components you want to install

and specify the destination folder. To check the space available on a disk

drive, click Disk Space.

Select Components

Select the WinRunner components and add-ing you want to
inztall, clear the components you do not want ta install.

LCompaonents
5
amples 111 B
rline D ocumentation 3316 mMB
YWisual Basic 12.0MB
PowserBuilder 05 MB
Activel Controls 0.0 ME
w'ehT est 7AMB

" Destination Folder

D:h . wfinFunner Browsze. . |
Space Required: 113.3 MB S
Space Available: 260.9 MB 4” PR

< Back I Heut » I Cancel |

Click Next.

11
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10 If you chose Typical or Compact Installation, specify the destination folder.
To check the space available on a disk drive, click Disk Space.

Chooze Dest Location E2

Setup will inztall WinBunner it the follawing falder.
Tainztall ta this folder, click Nest.

Tainztal ta a different folder, click Browse and zelect another
falder.

Destination Folder
D:%Program Fileshh ercury Interactive'WwinBunner

Space Reguired: 1133 B :
Space fyvailable: 260.4 ME Ml

< Back Hewt » | Cancel |

Click Next.

12
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Installing WinRunner

If you have Microsoft Internet Explorer version 3.0 or higher installed (or
any other software that installs wininet), you can check the Mercury
Interactive web site for updated components.

Update Components E2

Setup can now check the Mercuny Interactive web site for
updated components, Would pou like to connect now’?

If you choose not to connect, the components will be inztalled
from the CD.

< Back I Heut » I Cancel |

To check the Mercury Interactive web site for updated components, click
Yes. If you click No, the components will be installed from the CD-ROM.

Click Next.

If you chose Yes in the previous screen, the installation checks the Mercury
Interactive web site for updated components. If there are components on
the web site that are newer than components on the CD-ROM, setup
prompts you to overwrite the CD-ROM components with the web site
components. Then it installs the newer components from the web site. If no
newer components are found on the web site, then setup installs all
components from the CD-ROM

If the installation cannot access the web site, you can click Retry to try again
to connect to the web site. If you click Cancel, setup installs the WinRunner
components from the CD-ROM.

13
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13 If you selected Network Installation and add shortcuts to your Start menu
earlier in the setup, select a location for the local WinRunner folder. This
folder will allow you to configure WinRunner to meet your specific testing
requirements, while running a shared version over the network.

Choose Local WinRunner Folder

WfinBunner will uze the following folder to store configuration filez
that you create during the testing process.

To accept thiz folder, click Mest.

To chooze a different folder, click Browse and select another
falder.

D% AwinFunnerlocal Browze.. |

" Local winRunner Folder

< Back

Cahicel |

Click Next.

14
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14 Choose the location of your WinRunner temporary folder.

Choose WinRBunner Temporary Folder E

WinFunner will stare temporary files in the following folder.
To accept thiz folder, click Mext.

To choose a different folder, click Browse and select another
folder.

Make zure you have write permizzion for the folder.

Db SwinRunnerstmp Brawse... |
Cancel |

"Winﬂ unner Temporarg Folder

< Back

Click Next.
15 Review the settings you selected. To select different settings, click Back. To
confirm the settings, click Next.

The installation process begins. To pause or quit the installation process,
click Cancel.

15
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16 Select the program folder for the WinRunner icons.

Select Program Folder E2

Setup will add program icons ta the Program Folder listed below.
You may type a new folder name, or zelect one from the Existing
Falders lizst. Click. Mest to continue.

Program Folder:

Episting Folders:

3Com NIC Utilities -
ACceszones

ACD Spstems

ActivePerl

Adobe

Adobe Acrobat 4.0

ADL Instant Meszenger [Sk)]

Data Junction 6.5

erceed

e¥ceed System Administration j
=C Tenla

< Bach I Hewt » I Cancel |

Click Next to proceed.

17 Read the information about accessing online documentation. If you
installed add-in support for Visual Basic applications, additional
information appears on your screen. Click Next to proceed.

18 Read the information about Mercury Interactive’s Customer Support. Click
Next.

19 The installation process is complete.

Restart your computer.

Note: If you try to start WinRunner before restarting your computer,
WinRunner will not run properly.

Note: If you installed WinRunner on Windows NT, then after restarting
your computer, you must log in (for the first time) with the same login
name that was used before installing WinRunner.
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Installing WinRunner

If you installed WinRunner on the network, run a workstation installation
on all workstations. See the next section for details.

To read any last-minute information, click Start > Programs > WinRunner >
Read Me. The Readme file opens in Microsoft Wordpad.

To view the WinRunner online books, you must have Acrobat Reader 4.0
installed. You can install it by clicking Start > Programs > WinRunner >
Documentation > Acrobat Reader Setup and following the on-screen
instructions. To view online books, click Start > Programs > WinRunner >
Documentation > WinRunner Books Online.

To start WinRunner, click Start > Programs > WinRunner > WinRunner.

Running a Workstation Installation

N & »n b

A workstation installation should be performed for each user running
WinRunner from the network. This installation can be performed only after
the network installation is successfully completed.

Click Start > Run.
Type installation_directory\setup\setup.exe and click OK.

The WinRunner setup program starts. The WinRunner Setup splash screen
and the Setup progress bar open.

The software license agreement appears. To install WinRunner, you must
accept the terms of the license agreement by clicking Yes. If you click No,
the setup program will close.

In the Registration Information dialog box, type your name and click Next.
Click Yes to confirm the registration information.

Confirm the Workstation Installation message and click Next.

Define the location for the local WinRunner folder.

The WinRunner folder on your hard drive is used to store configuration files
you create during the testing process. Configuration files in this folder
override configuration files of the same name on the network, so that you
can configure WinRunner to your specific testing requirements.

Click Next.

17
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8 Select the location of your WinRunner temporary folder.

Setup updates and installs system files.

Click Next.

9 Select the program folder for the WinRunner icons.

Select Program Folder

Setup will add program iconz to the Program Folder listed belov,
You may type a new folder name, or select ane from the Esisting
Folders list. Click Mest to continue,

Program Folder:

WwinR uner

E xizsting Folders:

ACom MIC Utilities -
Acceszones

ACD Spatems

ActivePerl

Adobe

Adobe Acrobat 4.0

AOL Instant Meszenger [SK)

Data Junction B.5

ecead

eceed Syztem Adminiztration LI
ZC Tomels

< Hack: I Heut » I Cancel |

Click Next.

Restart your computer.

Note: If you try to start WinRunner before restarting your computer,

WinRunner will not run properly.

Note: If you installed WinRunner on Windows NT, then after restarting
your computer, you must log in (for the first time) with the same login

name that was used before installing WinRunner.

The WinRunner program folder is added to your Start menu.
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[ To read what’s new in WinRunner and any last-minute information, click
Start > Programs > WinRunner > Read Me. The Readme file opens in
Microsoft Wordpad.

[J To view the WinRunner online books, you must have Acrobat Reader 4.0
installed. You can install it by clicking Start > Programs > WinRunner >
Documentation > Acrobat Reader Setup and following the on-screen
instructions. To view online books, click Start > Programs > WinRunner >
Documentation > WinRunner Books Online.

g O To start WinRunner, click Start > Programs > WinRunner > WinRunner.

19
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Configuring Visual Basic 4.0 Support

20
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Before you can start using WinRunner's extended support for Visual Basic
4.0 in Windows 95, Windows 98, or Windows NT Visual Basic applications
(32-bit), you need to compile the WinRunner OCX (wrvb40.ocx) in the
application under test.

To configure 32-bit Visual Basic 4.0 support:
Start Visual Basic 4.0 and open the project.
Select Tools > Custom Controls.

In the Custom Controls dialog box, select the Wrvb40 OLE Custom Control
Module item. Click OK. The item is added to the toolbar.

Drag the new item onto the main application form.

Right-click this object and select View Code.

Select Object > Form.

Insert the following line into the beginning of the Form_Load function:

Wrvbl.Init Forms

For example:

Private Sub Form Load ()
Wrvb1l.Init Forms
End Sub

Run or recompile your application and run the .exe file.



Configuring Visual Basic 5.0 and 6.0 Support

Configuring Visual Basic 5.0 and 6.0
Support

WinRunner’s add-in support for Visual Basic 5.0 and 6.0 applications
includes all the support provided for Visual Basic 4.0 applications, plus:

[0 all standard Visual Basic 5.0 and 6.0 controls

[ Visual Basic projects that create ActiveX controls

Preparing Your Visual Basic Application

Before you can start testing a Visual Basic application using WinRunner’s
add-in support for Visual Basic 5.0 and 6.0, the application developer must
add the WinRunner agent to the application. To do so, the developer runs
the setup.exe program from the \vbdev directory on the WinRunner
installation CD-ROM.

Note that if the application currently references the WinRunner OCX, you
must first remove all references from forms, as well as the associated code
(Wrb1.Init Forms).

The WinRunner agent installation installs an AddIn to your Visual Basic
IDE. The name of this AddIn is WinRunnerAddIn.Connect. It adds lines of
code to your Visual Basic source code.

WinRunnerAddIn.Connect

O adds a reference to the wrvbasr.dll component

O adds a new code Module to the Visual Basic project called
“WinRunnerSupport”

[0 adds a line to the WinRunnerSupport Module:
Global asr As New WRVBASRLib.VbMod

21
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[J adds code to the StartUp object:

If the Startup Object is a Form, the AddIn adds the following line of code to
the Form_Load event: asr.Init Forms

If the Startup Object is Sub Main, the AddIn adds the following line of code
to the Main() method: asr.Init Forms

For all Class modules in the project, the AddIn adds the following line of
code to the Class_Intialize event: asr.Init Forms

For all UserControl modules in the project, the AddIn adds the following
line of code to the UserControl_Intialize event: asr.Init Forms, UserControl

For all UserDocument modules in the project, the AddIn adds the following
line of code to the UserControl Intialize event: asr.Init Forms, UserDocument

Notes: If the error message “DIIRegisterServer in <windows
directory>\system \wrvbasr.dll failed” appears during the WinRunner agent
installation, copy the file oleaut32.dll (version 2.20.4054.1 or higher) to
your system directory and re-install the WinRunner agent.

Do not run WinRunner and the Visual Basic IDE together.

Test your application only as a running executable.
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Enabling Table Contents Checks for an
ActiveX Control

To enable support for contents verification on any ActiveX control that can
be viewed as a table object, you must implement a capture function for the
ActiveX control in Visual Basic and then execute a TSL function.

WinRunner includes Visual Basic project files (wrvbsrv4.vbp for Visual Basic
4.0 and wrvbsrv5.vbp for Visual Basic 5.0 and 6.0) that compile into an OLE
Automation Server. WinRunner uses this server to capture table contents.

Follow these steps to enable contents verification on an ActiveX control that
can be viewed as a table object:

1 Start Visual Basic 4.0/5.0/6.0.

2 In Visual Basic, open the appropriate wrvbsrv project file (wrvbsrv4.vbp or
wrvbsrv5.vbp) located in the WinRunner installation folder under
custom \wrvbsrv.

3 Open capture.cls and add a Sub with the following prototype:
Public Sub<CaptureFunctionName>(ByVal <tab_ctrI> As Object, ByVal
<file_name> As String)
The function should dump the table contents of the ActiveX control into
<file_name> in the following format:

cells separated by Tab(Chr(9)), rows separated by Newline.

Note: Cell data should not contain escape characters such as Tabs or
Newlines. Cells in the first row (Column Titles) should not contain either
escape characters or space characters. See the MSGridCapture Sub for an
example.

23
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4 Compile the project into a .dll.
For Visual Basic 4.0, from the File menu select Make OLE DLL file.

For Visual Basic 5.0 or 6.0, from the File menu select Make WRVBSRV DLL
file.

5 In WinRunner, execute the add_table_capture_function statement. Set the
second argument to the name of the Sub you implemented in the Visual
Basic function. For example:

add_table_capture_function ("MSGrid.Grid", "MSGridCaptureFunc");

24
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Adding WinRunner Components

Once you install WinRunner, you can run the setup program at any time to
add program components, such as additional development environment or
control support, samples, or online documentation.

To add components:

1 Insert the CD-ROM into the drive from which you want to add WinRunner
components. If the CD drive is on your local machine, the WinRunner
Setup window opens. If you are installing from a network drive, connect to
it and run autorun.exe under the \setup subdirectory.

2 Click Install. The WinRunner setup program starts. The WinRunner Setup
splash screen and the Setup progress bar open.

3 The software license agreement appears. To accept the terms of the license
agreement, click Yes. If you click No, the setup program will close. To install
additional WinRunner components, you must accept the license agreement.

4 In the User Information dialog box, type your name, the name of your
company, and a WinRunner maintenance number. You can find this
number on the outside of your WinRunner box. Click Next to proceed.

5 Click Yes to confirm the registration information.

6 Select your installation type: Standalone Installation, Network Installation,
or Network Installation and add shortcuts to your Start menu. Click Next to
proceed.

7 Choose Custom Installation. Click Next to proceed.

8 Select the components you want to install and specify the destination
folder. In the Choose Destination Location window, click Next to confirm
the location of your WinRunner files.

If you select a component that is already installed, you are prompted to
overwrite it. To overwrite existing components of WinRunner, click the
Overwrite button. If you do not want to overwrite existing components of

25
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WinRunner, click Cancel. The previous window reopens and you can
modify your selection.

The installation settings you selected are displayed in a read-only window.
Review the settings. If you want to select different settings, click Back. If you
are satisfied with the settings, click Next.

The installation process begins.

To pause or quit the installation process, click Cancel.
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Uninstalling WinRunner

Your WinRunner installation includes an uninstall program which
uninstalls WinRunner software and files from your computer and removes
WinRunner shortcuts from your Start menu.

To uninstall WinRunner:
1 Click Programs > WinRunner > Uninstall WinRunner on your Start menu.
The Uninstall Shield window opens.

2 You may be prompted to remove shared files that are not in use by any
program. If you are not sure what to do, click No to All.

UninstallShield removes WinRunner from your computer.

3 When the Uninstall program is completed, the OK button is enabled. Click
OK.

4 You must reboot your machine to complete the uninstall process before
reinstalling WinRunner.

27
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