Upgrade pre-check task 'Suite Status Check’

  • KM03813558
  • 09-Jun-2021
  • 09-Jun-2021

Summary

During the pre-check the 'Suite Status Check’ is failing with a Unknown time-zone ID: n/a

Error

 
During the pre-check the 'Suite Status Check’ is failing with a Unknown time-zone ID: n/a
 
update-ui-2021-06-03.log
 
2021-06-03 15:53:20 - info: Pre Check progress, {"jobId":"885fa8e19fc74092a7dbea9d827ab945","name":"Suite Status Check","detail":"Fail to trigger the PreCheck of Suite Status Check. Found Exception: java.time.zone.ZoneRulesException: Unknown time-zone ID: n/a\n\tat java.time

 

 

 

 

Cause

The setting is not properly set:
 
kubectl describe pod suite-upgrade-pod-itsma -n itsma-toq1f | grep TIME
      MASTERNODE_TIME_ZONE:         <set to the key 'MASTERNODE_TIME_ZONE' of config map 'suite-upgrade-cm-itsma'>          Optional: false

 

Fix

You need to update below configmap to UTC and restart upgrade process by deleting tenant upgrade pod.
              
For core:
    kubectl edit cm -n core base-configmap
    MASTERNODE_TIME_ZONE: UTC
 
For SMAX:
    kubectl edit cm -n itsma-toq1f itsma-common-configmap
     time_zone: UTC