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Summary
Upgrade process has failed message appears in the wizard
Error
While upgrading to APM 9.51, Upgrade process has failed message appears in the upgrade wizard.
Cause
1. Open <APM Home Directory>/log/supervisor/hardening.log file.
2. Verify if the following message appears:
Caused by: java.sql.SQLException: Could not create DB Connection to dbType=(Unrecognized);
hostName=localhost; dbName=TOPAZ_MANAGEMENT; userName=sa; server=localhost; sid=orcl;
port=1521
Fix
Run the upgrade wizard again if the upgrade fails, and the error message specified in the Cause section appears in the hardening.log file.